[jsr369-experts] Re: ServletMapping should be HttpServletMapping

From: Mark Thomas <markt_at_apache.org>
Date: Tue, 2 May 2017 18:43:57 +0100

On 01/05/17 08:40, Greg Wilkins wrote:
> All,
> I know I've promised feedback on this API from an implementation many
> times... and now it is probably too late... however....
> Shouldn't this class be called HttpServletMapping? It is in
> javax.servlet.http and all other Servlet related classes in that package
> are prefixed with HttpServlet. I know it is a small thing, but the
> first hurdle I have in implementing this is dealing with the
> inconsistent naming.

No objections to the name change.