[jsr369-experts] ServletMapping should be HttpServletMapping

From: Greg Wilkins <gregw_at_webtide.com>
Date: Mon, 1 May 2017 09:40:36 +0200


I know I've promised feedback on this API from an implementation many
times... and now it is probably too late... however....

Shouldn't this class be called HttpServletMapping? It is in
javax.servlet.http and all other Servlet related classes in that package
are prefixed with HttpServlet. I know it is a small thing, but the first
hurdle I have in implementing this is dealing with the inconsistent naming.


Greg Wilkins <gregw@webtide.com> CTO http://webtide.com