Consume/Produce and Input/Output

From: Paul Sandoz <Paul.Sandoz_at_Sun.COM>
Date: Fri, 18 May 2007 14:33:40 +0200

Hi Jerome,

I think there are two separate issues:

1) The more general annotations for the support of additional
    content for negotiation; and

2) The placement of those annotations on classes/methods/parameters.

I don't detect any general disagreement over 1, although i would like to 
hear more opinions on this by others.
IMHO the Input/Output names are too vague. I would prefer something more 
descriptive and accurate, for example ConsumeContent/ProduceContent. The 
use of consume/produce also tends to read very nicely when expressed in 
sentences (at least in English!) about a resource or a method of a resource.
I guess we could argue over Input vs. Consume till entropy death of the 
universe, life is too short :-) the only strong opinion i have is that 
the annotation names clearly reflect what they are specified to do so 
that developers can make intuitive guesses.
IIRC Marc has discussed this before in other email threads. But it has 
been a long time. Perhaps you could refresh our memories and summarize 
the differences/commonalities/pros/cons of the two positioning 
approaches from your perspective?
| ? + ? = To question
    Paul Sandoz