[jax-rs-spec users] [jsr339-experts] Re: ContainerRequestContext abortWith method name

From: Sergey Beryozkin <>
Date: Wed, 6 Mar 2013 13:18:09 +0000

On 05/03/13 16:26, Sergey Beryozkin wrote:
> Hi
> I wonder if it can make sense to rename somehow
> ContainerRequestContext.abortWith(Response) method ?
> It is not a big deal, but I'm finding myself thinking that in most cases
> so far, when I write "abortWith" I actually mean a non-exceptional
> response and "abortWith" reads as if it is some kind of error that
> causes the filter to call this method...
> May be "setResponse" ? Or something else...

endWith(Response) ? Though I guess I can live with "abortWith"

Cheers, Sergey