On 11/30/11 5:52 AM, Marek Potociar wrote:
>
> public interface NextAction { }
>
> IMO it should be defined as an inner interface of FilterContext. We can add some methods if we find it useful. Otherwise
> it should be up to the implementation how to implement the interface and what methods should be internally provided.
Yuck. -1 on a special interface. What about my proposal with filter
returning void, and FilterContext having a state or a set of boolean
methods that describe the state:
void preFilter(FilterContext ctx) {
context.stop();
}
ctx.isStopped();
BTW, We're starting to implement the spec next week. I'll probably have
a lot more comments when we start playing with things.
--
Bill Burke
JBoss, a division of Red Hat
http://bill.burkecentral.com