jsr339-experts@jax-rs-spec.java.net

[jsr339-experts] Re: move accept header to a client method

From: Jan Algermissen <jan.algermissen_at_nordsc.com>
Date: Thu, 7 Feb 2013 00:08:20 +0100

On 06.02.2013, at 23:48, Bill Burke <bburke_at_redhat.com> wrote:

> IMO
>
> I think this:
>
> webTarget.request().accept("application/json").get();
>
> looks more readable than this:
>
> webTarget.request("application/json").get();


+1

> request("application/json")

continues to feel like an obstacle in the flow of the API for me.

Jan


>
>
> It's more typing, but more readable.
>
> --
> Bill Burke
> JBoss, a division of Red Hat
> http://bill.burkecentral.com