dev@glassfish.java.net

Re: list-applications VS list-components

From: Jane Young <Jane.Young_at_Sun.COM>
Date: Fri, 28 Mar 2008 14:12:51 -0700

Hi, Jerome.

I added the list-components command and display the warning message in
list-applications since we didn't want to support two commands that do
the same thing. To be compatible with v2, we need to have the
list-components command. But since there may be confusion with add-on
components, maybe we should deprecate list-components command and
officially support list-applications command instead of displaying a
warning message that this command will be removed. What do you think?

The ListApplicationsCommand.java is actually calling
ListComponentsCommand.java so there is no duplicate code. I think
adding @Alias would be nice.

Kedar, Bryon and I actually came up with a proposal to allow user to
create command aliasing using asadmin. See:
http://wiki.glassfish.java.net/Wiki.jsp?page=ProvidingScriptsInBinFolder2HideDomains#section-ProvidingScriptsInBinFolder2HideDomains-CommandAliasing

Let me know your thoughts.

Thanks,
Jane


Jerome Dochez wrote:

> so somehow we changed the list-applications into list-components and
> issue warnings when doing a list-applications.
>
> can't we just alias the commands, seems to me that list-applications
> is a *lot* more natural command name than list-components which could
> soon be confused with add-on components related commands.
>
> I would love to see an official aliasing in place in the asadmin
> adapter, maybe we could have a new annotation @Aliases
>
> so we could have something in that spirit
>
> @Service(name="list-components")
> @Alias("list-applications")
> pubic class ListComponentsCommand implements AdminCommand {
>
> }
>
> what do people think ?
>
> Jerome
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe_at_glassfish.dev.java.net
> For additional commands, e-mail: dev-help_at_glassfish.dev.java.net
>