Re: Container Independence

From: Dhanji R. Prasanna <>
Date: Thu, 12 Apr 2007 21:25:47 +1000

On 4/12/07, Jerome Louvel <> wrote:
> Marc,
> > Right but, as you say, you have to name the field "value". Even if
> > the field is called "value" you also can't write:
> >
> > @Resource("blah", other="blah2")

I think this is an ugly syntax. if you're specifying more than one attribute
you *should* name them all, makes it clear and obvious.

What might be better is suggesting an alternate way to indicate the shortcut
attribute than by naming convention:

public @interface Ann {
   default int id();

and use it as:

Anyway Afaik, the only JSR active for annotations is the one on annotating
types--their scope is very specific.
This would have to be the dolphin JSR if any, as it proposes changes to the
language core.

We're very much *Offtopic*!!!