users@jax-rs-spec.java.net

[jax-rs-spec users] Re: Adopt-a-JSR

From: Santiago Pericas-Geertsen <Santiago.PericasGeertsen_at_oracle.com>
Date: Wed, 2 Jan 2013 09:36:40 -0500

Arun, Mohamed,

 Please move this e-mail thread to a different alias; this is not about JAX-RS 2.0. Either a GF alias or Jersey one would be better.

 Thanks.

-- Santiago

On Dec 29, 2012, at 8:54 AM, Mohamed Taman <mohamed.taman_at_gmail.com> wrote:

> Dear Arun,
>
> Thanks very much for the information,
>
> I already downloaded the latest version, and it works normally now.
>
> Here are some points I found while running the windows installer and .zip version.
>
> Note: I am working on Windows and Mac OSs, and I test on both environments.
> Windows: The screen wizards of the windows installer version still the same referring to Glassfish 3 and JEE6. it will be reported on JIRA.
> Windows: The windows installer stuck on 41% for about one hour and more. provided a screen shoot.
> Win&Mac:The problem of JSF2+Ajax missing that appeared before on app server console is now solved.
>
> Enhancement (Win&Mac): I have JDK6(Default) and JDK7 installed on the same machine, and when I have unzipped the glassfish_4_b69 and run it for the first time it reports the following exception
>
> "asadmin> start-domain domain1
> Waiting for domain1 to start .............Error starting domain domain1.
> The server exited prematurely with exit code 1.
> Before it died, it produced the following output:
> ........
> Caused by: A MultiException has 2 exceptions. They are:
> 1. java.lang.UnsupportedClassVersionError: org/glassfish/jdbc/config/JdbcResourceInjector : Unsupported major.minor version 51.0"
>
> After investigation, It should run on JDK7 not 6, but the error is misleading somehow, it should be there some sort of detection for the exact version of proper supported JDK, and then reports a proper error message, something like"Unsupported JDK version, use JDK7+ version."
>
> any way the solution is to set the following script line inside the "\Glassfish_4\glassfish\config\asenv.bat"
>
> set AS_JAVA=C:\Program Files\Java\jdk1.7.0_06
>
> I think it will report it too.
>
>
> On Fri, Dec 28, 2012 at 11:24 PM, <arun.p.gupta_at_oracle.com> wrote:
> Hi Mohamed,
>
> I don't have a Windows machine to test but typically I download the zip
> file and unzip it on my Mac. The latest available version is b69 and
> can be downloaded from:
>
> http://dlc.sun.com.edgesuite.net/glassfish/4.0/promoted/glassfish-4.0-b
> 69.zip
>
> The directory names and installation screens have not been updated. Can
> you please file a bug at:
>
> http://java.net/jira/browse/GLASSFISH
>
> and use the tag #adoptajsr.
>
> GlassFish4/Java EE 7 requires JDK 7. JAX-RS 2 is already integrated
> there.
>
> Thanks,
> Arun
>
>
>
> --
>
> Thanks & Best Regards
>
>
> “Improve your Life through Science and Art…”
>
> Mohamed Mahmoud Taman
>
> Business Solutions,
>
> Systems Architect & Design Supervisor
>
> Java Team Leader
>
> | JCP (Java Community Process) Member
>
> |Oracle Egypt Architects Club board member
>
> | JavaOne & EG-JDC Speaker
>
> | SCJP, SCWCD, OCP PL/SQL
>
>
> e-finance,BLDG17, Smart Village,
>
> KM 28 Cairo-Alex Desert Road,
>
> Ground Floor, Giza, Egypt
> Postal Code : 12577
>
> ( : +(202) 3827 1422
>
> (: +(202) 3827 1499
>
> (: +(202) 3827 1599
>
> Č: +(201) 00531 8017
>
> P Before you print Think about Your ENVIRONMENTAL responsibility.
>
> <Glassfish4Stucks.png>