> Markus, Sergey: I have reintroduced the target.request(), you didn't
> like. However I tried to do it in a way that does
> not bring any extra method into the invocation chain. Instead of:
>
> client.target().accept("text/plain").get();
>
> You can now write:
>
> client.target().request("text/plain").get();
Actually I do not see why it is necessary to *rename* the method. Obviously it still is used to pass in the accept header, so why not still name it accept, independent of what it actually does or produce?
> In the fluent interface I prefer async().put() over putAsync() or
> asyncPut().
Me, too.
Regards