Hi folks,
The only gotcha I've had on the candidate PFD at this point is a
suggestion to rename the new lifecycle call(s) on Encoder/Decoder.
Currently, it follows a style I'd suggested using
setEndpointConfig(EndpointConfig config) with the config when being
brought into service and null when being taken out. I thought this
naming and semantic convention was more common than it is: I can only
find it used in the BeanContext API, and nowhere in Java EE. So I would
like to rename this to use the much more familiar:-
void init(EndpointConfig config)
void destroy()
pattern, as seen in the servlet API for servlets and filters.
As a final convenience, I'd like to add a member Adapter class to
Encoder and Decoder with no-op implementations of these lifecycle
methods. For developers who don't need the lifecycle, they can just
subclass the Decoder.Adapter/Encoder.Adapter and implement the relevant
Encoder/Decoder interface as usual.
Let me know ASAP if anyone has any objections to this minor refactoring.
Thanks !
- Danny
--
<http://www.oracle.com> *Danny Coward *
Java EE
Oracle Corporation