jsr356-experts@websocket-spec.java.net

[jsr356-experts] Couple small renames

From: Danny Coward <danny.coward_at_oracle.com>
Date: Mon, 25 Feb 2013 16:43:06 -0800

Hi folks,

These may be the last renames to propose.

* MessageHandler.Basic and MessageHandler.Async

Particularly now that we have refactored the RemoteEndpoint into
RemoteEndoint.Basic and RemoteEndpoint.Async, is highlights that we have
two different notions of 'Async'. On the message handlers, 'Async'
refers to receiving messages in parts. On the RemoteEndpoints, it refers
to committing the message to the wire after the return of the call to
send it. So I think its confusing to use the same 'Async' for both. I
think the RemoteEndpoint 'Async' is closer to what most people would
think of as asynchronous.

So the proposal is

MessageHandler.Basic -> MessageHandler.Whole
MessageHandler.Async -> MessageHandler.Partial


* ServerEndpointConfiguration/ServerEndpointConfigurator,
ClientEndpointConfiguration/ClientEndpointConfigurator

As Pavel on our Tyrus team found over the weekend, the autocomplete for
ServerEndpointConfigurat* is not very useful as the names are so
similar. Also, Config seems to be a in common useage in Java APIs, and
is shorter than Configuration.

The proposal is

ServerEndpointConfiguration -> ServerEndpointConfig
ServerEndpointConfigurator -> ServerEndpointConfig.Configurator
ClientEndpointConfiguration -> ClientEndpointConfig
ClientEndpointConfigurator -> ClientEndpointConfig.Configurator

and, consequently, the same [Configuration -> Config] contraction for
ServerApplicationConfiguration, ServerEndpointConfigurationBuilder,
ClientEndpointConfigurationBuilder.

Does anyone think these changes are less clear that what is there now ?

Thanks,

- Danny
-- 
<http://www.oracle.com> 	*Danny Coward *
Java EE
Oracle Corporation