Hi folks,
Some other feedback I've consistently had was to look again at the
package naming. Currently we have
javax.net.websocket - core APIs
javax.net.websocket.annotations - annotations
javax.net.websocket.extensions - extension SPI
One feedback has been: use javax.websocket.* instead of
javax.net.websocket. The original rationale for javax.net.websocket was
that websocket is a network protocol, so should live under java.net. But
javax.websocket is consistent with the web service specs, servlet etc.
So I think we should make that change.
Secondly, I put annotations subpackage there so that it would clearly
separate the API classes from the annotations, for the sake of making
the spec easier to review and understand. But the common practice for
APIs seems to be to put annotations in with API classes. So I think we
should move the annotations into the core too.
Depending on how we see the client API, we may need to split the API
such that we have a separate client-only and server-only packages, but
apart from that change, I would like to move ahead with these proposed
changes to the package naming.
Please let me know if you see any issues with that approach.
And that's it for today. I know we have a lot of issues on the list
right now, I will do a summary of all the open issues later this week so
if you are not following everything, you can jump back aboard.
Cheers,
- Danny
--
<http://www.oracle.com> *Danny Coward *
Java EE
Oracle Corporation