I think some form of @Cookie injection would be useful:
@GET
public String get(@Cookie("myCookie") int value)
{
}
Would save a lot of typing. The only problem I see with this is that it
overloads with javax.ws.rs.core.Cookie. Maybe rename the object to
CookieInstance?
I'm thinking you could also do:
@GET
public String get(@Cookie("myCookie") CookieInstance instance){}
--
Bill Burke
JBoss, a division of Red Hat
http://bill.burkecentral.com