[jax-rs-spec users] [jsr339-experts] Heads-up: Proposed Request/Response API changes as part of the fix for #JAX_RS_SPEC-152

From: Marek Potociar <>
Date: Fri, 27 Jan 2012 11:57:56 +0100

Hello experts,
please take a moment to kindly review the changes proposed as part of the #JAX_RS_SPEC-152 issue resolution.

Other than updating javadoc, we are proposing to rename getEntity(...) to readEntity(...) as the name better represents
the functionality. Also, unlike typical getters, these methods are neither safe not idempotent. We would keep only a
single parameter-less getEntity() getter method which does not modify the internal state of a message instance.

Additionally, we propose to remove all the getters from Req/Resp builders API since these really seem redundant and go
against the style of JAX-RS 1.x builder API.

See the full diff here:

Thank you,