admin@glassfish.java.net

Re: Code review request

From: Bill Shannon <bill.shannon_at_sun.com>
Date: Thu, 21 Sep 2006 11:00:45 -0700

Abhijit Kumar wrote:
> How about using Boolean.getBoolean(JKS_DB_PROPERTY)

Much better!

Or even

if (System.getProperty(JKS_DB_PROPERTY, "false").equalsIgnoreCase("true"))

Personally, I just *hate* the "if constant equals variable" style,
even though I understand why people do it. I just find it very
distracting when reading code.

But we better not turn this into a coding style "discussion" or it
will never end... :-)