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Oracle welcomes customers' comments and suggestions on the quality and usefulness 
of this document.

Your feedback is important, and helps us to best meet your needs as a user of our 
products. For example:

■ Are the implementation steps correct and complete?

■ Did you understand the context of the procedures?

■ Did you find any errors in the information?

■ Does the structure of the information help you with your tasks?

■ Do you need different information or graphics? If so, where, and in what format?

■ Are the examples correct? Do you need more examples?

If you find any errors or have any other suggestions for improvement, then please tell 
us your name, the name of the company who has licensed our products, the title and 
part number of the documentation and the chapter, section, and page number (if 
available).

Send your comments to us using the electronic mail address: retail-doc_us@oracle.com

Please give your name, address, electronic mail address, and telephone number 
(optional).

If you need assistance with Oracle software, then please contact your support 
representative or Oracle Support Services. 

If you require training or instruction in using Oracle software, then please contact your 
Oracle local office and inquire about our Oracle University offerings. A list of Oracle 
offices is available on our Web site at http://www.oracle.com.

Note: Before sending us your comments, you might like to check 
that you have the latest version of the document and if any concerns 
are already addressed. To do this, access the Online Documentation 
available on the Oracle Technology Network Web site. It contains the 
most current Documentation Library plus all documents revised or 
released recently.
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Preface

This User Guide describes the Oracle Retail Clearance Optimization Engine Grid 
Designer Application and provides step-by-step instructions to complete most grid 
configuration tasks using the Grid Designer user interface.

Audience
This User Guide is intended for users, administrators, and implementation personnel 
of Oracle Retail Clearance Optimization Engine. This includes merchandisers, buyers, 
business analysts, and administrative personnel.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible to all users, including users that are disabled. To that end, our 
documentation includes features that make information available to users of assistive 
technology. This documentation is available in HTML format, and contains markup to 
facilitate access by the disabled community. Accessibility standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be 
accessible to all of our customers. For more information, visit the Oracle Accessibility 
Program Web site at http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an 
otherwise empty line; however, some screen readers may not always read a line of text 
that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or 
organizations that Oracle does not own or control. Oracle neither evaluates nor makes 
any representations regarding the accessibility of these Web sites.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/support/contact.html or visit 
http://www.oracle.com/accessibility/support.html if you are hearing 
impaired.
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1Introduction

This chapter provides an introduction to the Grid Designer application and describes 
how you can access the Grid Designer application. It also provides information on the 
organization of the content in this document and the prerequisites you must consider 
before accessing the application. This chapter includes the following topics:

■ About Grid Designer

■ How to Use Grid Designer

■ Prerequisites

■ Accessing the Grid Designer Application

■ Understanding the Grid Designer User Interface

■ Grid Configuration Concepts

About Grid Designer
Most of the screens in the Clearance Optimization Engine application display data in 
grids that are based on a framework infrastructure defined by an XML schema 
(Grid.xsd) and Java ResourceBundles (gridResources.properties) files. Configuration 
for such grids include an XML file that define the metric column in the grid and the 
associated resource keys or values within the gridResources.properties file (for all 
supported locales).

The Grid Designer is a Web-based rich application that enables you to modify the 
following main components of the grid configuration in a graphical user interface:

■ Column Definitions. For more information, see Chapter 2, "Setting Up Column 
Definitions".

■ Grid Resources. For more information, see Chapter 3, "Setting Up Grid Resources".

■ Grid Configuration Files. For more information, see Chapter 4, "Setting Up Grid 
Configuration Files".

■ Item Details Grid Configuration. For more information, see Chapter 5, "Setting Up 
Item Details Grid Configuration".

The Web-based user interface makes it easier for you to capture, implement, and apply 
grid configurations to the Clearance Optimization Engine environments. It is designed 
to help make this task faster and reduce configuration errors associated with editing 
raw grid configuration XML files.
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For more detailed information on the Clearance Optimization Engine application 
configuration, refer to the Oracle Retail Clearance Optimization Engine Configuration 
Guide.

How to Use Grid Designer
In order to use the Grid Designer application effectively, it is recommended that you 
review the instructions in this guide in the following order. The following table also 
highlights how the content is organized in this guide:

Note: In the p4pgui-config.xml file, configuration aspects other than 
the grids and their order for worksheet and merchandise category 
need to configured manually.

The Items Detail grid (item-details-layout.xml) currently cannot be 
configured through the Grid Designer application. You must configure 
it manually.

Table 1–1 How to Use Grid Designer

Task Description Chapter/Section Reference

Familiarize yourself with the Grid Designer user interface. Chapter 1, "Introduction" (Current Chapter)

See Understanding the Grid Designer User Interface.

Ensure that you meet the prerequisites Chapter 1, "Introduction" (Current Chapter)

See Prerequisites.

Log On to the Grid Designer Application. Chapter 1, "Introduction" (Current Chapter)

See Accessing the Grid Designer Application.

Set up column definitions. 

In case you want to set up column definitions with custom 
resources, you can choose to set up a new resource 
definition from the Resource Browser Editor screen 
available in the Edit Column Definitions area. For more 
information on the Resource Browser Editor, see Creating 
New Resource Definitions.

Chapter 2, "Setting Up Column Definitions"

Set up grid resources. Chapter 3, "Setting Up Grid Resources"

Set up individual grid configuration files. Chapter 4, "Setting Up Grid Configuration Files"

Set up the Item Details grid configuration file. Chapter 5, "Setting Up Item Details Grid 
Configuration"

Review the validation logs to ensure that all validation 
issues have been fixed before you save and publish the 
updated grid configuration to the production 
environments.

Chapter 6, "Reviewing the Validation Logs"

Once all the grid configuration updates are done, and all 
validation issues resolved, publish the updated grid 
configuration to the Clearance Optimization Engine 
environment using the Publish option in the Configuration 
Actions menu. 

The Configuration Actions menu also includes options that 
enable you to revert the configuration to the default out of 
the box settings or back up a grid configuration.

Chapter 1, "Introduction" (Current Chapter)

See Configuration Actions Menu Options.
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Prerequisites
Before you start using the Grid Designer application, ensure that you meet the 
following prerequisites:

■ Skills and Expertise

■ GRID_DESIGNER Role

Skills and Expertise
Setting up and applying the grid configuration to the Clearance Optimization Engine 
application, requires that you are familiar with the following:

■ Clearance Optimization Engine user interface and grid configuration. For more 
information on the application configuration, refer to the Oracle Retail Clearance 
Optimization Engine Configuration Guide.

■ Implementing grid configuration in a production environment.

■ Working knowledge of UNIX. 

GRID_DESIGNER Role
To update and set up additional grid resources and column definitions, your user 
account must also include the GRID_DESIGNER role. For more information on 
assigning a role to a user account, refer to the Oracle Retail Clearance Optimization 
Engine Administration Guide.

Without this role, you can still log in to the Grid Designer application using your user 
account set up for the Clearance Optimization Engine application and view the 
existing grid configuration. User accounts without the Grid Designer role cannot save 
grid configuration changes.

The Clearance Optimization Engine installation includes a default user account with 
the user name griduser1 that is set up with the GRID_DESIGNER role. Before you log 
on to the Grid Designer application using this user account, it must be first unlocked 
using the User Management module.

Accessing the Grid Designer Application
Before you access the Grid Designer application, ensure that your system meets the 
recommended configuration. For more information, see the section Prerequisites and 
also refer to Oracle Retail Clearance Optimization Engine Installation Guide.

To access the Grid Designer application:

1. In the Web browser, enter the following URL in the Address bar, and press Enter:

https://<hostname>:<port>/GridDesigner/faces/login

2. On the login screen, enter the following information:

■ Grid Designer Language – The language in which you want to view the Grid 
Designer application.

Note: Based on the HTTP protocol specified for the application 
during the installation, the Grid Designer URL may use http or https.
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■ Username – The relevant user name (similar to your user name for the 
Clearance Optimization Engine application) to access the Grid Designer 
application.

■ Password – The password associated with the user name.

3. Click Login. Once logged in, the Grid Designer screen appears.

The Grid Designer screen displays the Configuration Actions menu and the 
Configuration Navigator navigation panel. The navigation panel enables you to 
update the relevant column definitions, resource keys, and grid configuration files. 
The Configuration Actions menu includes menu options that enable you to save, 
revert, validate, back up, and publish the grid configurations to the Clearance 
Optimization Engine application.

Understanding the Grid Designer User Interface
The following figure highlights the various components of the Grid Designer user 
interface:

Figure 1–1 Grid Designer User Interface Components

The following table (Table 1–2) describes the user interface components highlighted in 
the figure above:

Note: The Grid Designer application is a single user application. To 
ensure data concurrency, only one user can be logged into the Grid 
Designer application at any given time.
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Quick Access Toolbar
The Quick Access toolbar includes the following menus:

■ Configuration Actions menu – The Configuration Actions menu provides access 
to the general options for the Grid Designer application. This includes options 
such as Save, Validate, Publish, and so on. For more information on each option 
available in the Configuration Actions menu, see Configuration Actions Menu 
Options.

■ Grid Designer Settings menu – The Grid Designer Settings menu enables you to 
choose the resource key languages you want to review or set up. Once you select 
the languages you want to view, the application only enables those lists at run 
time. For example, if you are currently working on setting up the resource keys for 
the German language, and you do not wish to review the strings for the Japanese 
and Spanish languages, you can de-select these languages from the list. 

The Grid Designer Settings menu also enables you to view the translated strings 
for some resourced settings when you are browsing for a certain element. When 
you are searching for a <column-def> element to edit it may be helpful to see the 
label value in a particular language than the key. For example, it may be easier to 
identify a column definition with the label value "Ventes $ il y a 2 semaines" than 
the key "p4pgui.salesDollarsLLW.column.label".

■ Configuration Navigator link – The Configuration Navigator link appears 
enabled only when you are on a screen other than the Grid Designer home page. 
Click this link to go back to the Grid Designer home page at any given time. Any 
changes you made before clicking this link will not be saved.

Table 1–2 Grid Designer User Interface Screen Components

Screen Component Description

Global Header Displayed at the top of the screen, this area appears across the 
Grid Designer application. It includes the Grid Designer 
branding and links for the About window and Online Help.

Quick Access Toolbar Displayed below the global header, the quick access toolbar 
includes the Configuration Actions and Grid Designer Settings 
menus. These menus include options that enable you to perform 
various actions, such as saving, publishing, or reverting 
configuration changes. For more information, see Quick Access 
Toolbar.

Configuration Navigator 
Panel

Displayed on the left of the screen, the Configuration Navigator 
taskflow panel provides the various grid configuration options 
and files that you can set up.

Status Bar The Status bar appears at the bottom of the screen. It displays 
the status of any action performed on the Grid Designer screen. 
For example, when you click Save from the Configuration 
Actions men, the message "Configuration has been saved." 
appears in the Status bar.

Note: The options in the Grid Designer Settings menu are different 
from the Grid Designer Language list that appears on the Login 
screen. The Grid Designer Language list enables you to set the 
language in which you want to view the Grid Designer application.
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Configuration Actions Menu Options
The Configuration Actions menu includes the following options:

■ Save – Use this menu option to save all the changes done to the grid configuration. 
When you click Save, the Status bar will display a confirmation message when the 
configuration is saved.

■ Validate – Use this menu option to run a comprehensive validation check on the 
entire grid configuration. Once the validation check is complete, the Validation 
Logs window appears. It list any validation issues or informational messages that 
may be present in the updated grid configuration. When you click Validate, the 
Status bar will display a confirmation message when the configuration is validated 
or an error message in case of failures.

■ Publish – Use this menu option to publish and apply the updated grid 
configuration to the relevant Clearance Optimization Engine application 
environment. In case you have the Clearance Optimization Engine application 
installed over a cluster, the updated grid configuration gets published to all the 
relevant clusters set up in the gdconfig.properties file. When you click Publish, the 
Status bar will display a confirmation message when the configuration is 
published.

■ Revert Deployed – After an updated grid configuration was published, use this 
menu option to revert the grid configuration back to the default settings (from a 
previous backup copy).

■ Backup – Use this option to back up the updated grid configuration. When you 
click Backup, the Status bar will display a confirmation message when the backup 
configuration is saved. This option may overwrite any previous backups.

■ Revert Working – Use this option to abandon the current working grid 
configuration settings and revert back to the most recent backup.

■ Exit – Use this menu option to exit the Grid Designer application.

Grid Configuration Concepts
This section highlights the grid configuration concepts associated with the Grid 
Designer application. It includes the following topics:

■ Grid Designer Configuration (gdconfig.properties) File

■ Grid Configuration Directory Structure

Grid Designer Configuration (gdconfig.properties) File
The gdconfig.properties file (located in <configuration root>\griddesigner) enables you 
to set up the following parameters for the Grid Designer application:

■ gd.resource.supported.locales – This parameter lists the locales supported by the 
application. It must only be updated when new supported languages are added to 
the product.

■ gd.resource.configured.locales – This parameter sets the default locale used in the 
Resource Browser Editor. For more information on the Resource Browse Editor, see 
Setting Up Grid Resources. 

Use this parameter to set the list of locales to be configured for your business need. 
For example, if your implementation supports only the French language, you will 
include fr as the only value (gd.resource.configured.locales=fr).
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■ gd.publish.conf.host.name – This parameter enables you to set up a list of host 
names in a cluster where you want to publish the configuration. For standalone 
installations, leave the parameter value blank. For more information on the 
publish feature, see Configuration Actions Menu Options.

Grid Configuration Directory Structure
This section describes the directory structure used for Clearance Optimization Engine 
grid configuration. It also highlights the changes and updates to the relevant 
directories based on the actions in the Grid Designer application.

The following list illustrates the updates to the relevant directories when you use on 
the options from the Configuration Actions menu:

Table 1–3 Grid Configuration Directory Structure

First 
Level

Second 
Level

Third 
Level

Fourth
Level Description

<Clearance Optimization Engine 
Configuration Root Directory>

The Clearance Optimization Engine application configuration 
root directory.

|------ Price The Price folder contains the standard Clearance Optimization 
Engine configuration files (including the config.properties file). By 
default, the content of this directory is used for the Clearance 
Optimization Engine application user interface.

|------ grids The grids subfolder includes all the standard grid configuration 
files.

|------ resources The resources subfolder includes all the standard resource 
definition files.

|------ client The client subfolder is created when you first publish a custom grid 
configuration through the Grid Designer application. It contains the 
relevant custom grid configuration files to be used by the Clearance 
Optimization Engine going forward.

|------ griddesigner The griddesigner folder contains the Grid Designer configuration 
file (gdconfig.properties). It also acts as the working and backup area 
for the grid configuration files currently being set up in the Grid 
Designer application.

|------ backup The backup subfolder contains the latest backup copy of the grid 
configuration files (includes the config.properties file, grids 
subfolder, and resources subfolder). 

When you back up a grid configuration in the Grid Designer 
application, the deployed grid configuration is saved to this 
subfolder. The backup subfolder always retains only one latest 
revision of the grid configuration.

|------ working The working subfolder contains the latest working copy of the grid 
configuration. 

|------ grid The config.properties file, and the grid and resources subfolders at 
this level represent the standard grid configuration for Clearance 
Optimization Engine. 

It is recommended that you retain them As Is in this directory.

|------ resources

|------ config.properties

|------ client The client subfolder contains the latest saved copy of the custom 
grid configuration (includes the config.properties file, grids 
subfolder, and resources subfolder).

When you publish the updated grid configuration through the Grid 
Designer application, contents of this subfolder are copied to the 
Price/client subfolder.
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■ When you click Save, the updated grid configuration in-memory is saved to 
<configuration root>/griddesigner/working/client directory.

■ When you click Backup, files from the <configuration root>/Price/client subfolder 
are copied to the <configuration root>/griddesigner/backup subfolder.

■ When you click Publish, files from the 
<configuration root>/griddesigner/working/client subfolder are copied to the 
<configuration root>/Price/client subfolder.

■ When you click Revert Deployed, files from the 
<configuration root>/griddesigner/backup subfolder are copied to the 
<configuration root>/Price/client subfolder.

■ When you click Revert Working, files from the 
<configuration root>/griddesigner/backup subfolder are copied to the 
<configuration root>/griddesigner/working/client subfolder.
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2Setting Up Column Definitions

The grid configuration XML files include column definition (<column-def>) elements 
that are used to provide the default settings for each metric column included in the 
Clearance Optimization Engine grids. The <column-def> elements include standard 
columns/metrics and any custom metrics required based on specific business 
requirements. 

This chapter describes how you can set up and create column definitions to suit your 
business need. It includes the following sections:

■ About Column Definitions

■ Accessing the Browse <column-def> Screen

■ Understanding the Browse <column-def> User Interface

■ Column Definition States

■ Updating Column Definitions

■ Creating Column Definitions

■ Deleting Custom Column Definitions

■ Reverting to the Default Column Definition

About Column Definitions
Column definitions are the <column-def> XML elements that describe the metric 
columns in generic terms that may be used in multiple grids. The column definitions 
are stored in the following XML files:

■ p4p-column-list.xml – This XML file lists all the standard column definitions 
available to the grids in the Clearance Optimization Engine application.

■ p4p-custom-column-list.xml – This file lists the custom column definitions that you 
add using the Grid Designer application.

Once you publish the updated grid configuration, the p4p-column-list.xml file is 
updated to reflect the latest column definitions. Any new custom column definitions 
are made available in the p4p-custom-column-list.xml file.

In the Grid Designer application, the Browse <column-def> screen lists all the valid 
column definitions used in the Clearance Optimization Engine application. It enables 
you to identify and set up column definitions. You can also use this screen to create 
new column definitions, based on the existing column definitions.
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Accessing the Browse <column-def> Screen
To access the Browse <column-def> screen:

■ On the Grid Designer screen, click Column Definitions from the Configuration 
Navigator task panel.

Understanding the Browse <column-def> User Interface
The Browse <column-def> screen includes the following user interface components:

■ Column Definition Grid

■ Column Definition Grid Toolbar

■ <column-def-properties> Area

Figure 2–1 Browse <column-def> Screen

Note: The Configuration Actions menu is disabled when you are on 
the Browse <column-def> screen.
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Column Definition Grid
The Column Definition grid lists all the default columns along with the relevant 
column definition properties. It displays a list of all column definitions available in the 
p4p-column-list.xml and p4p-custom-column-list.xml files. For more information on the 
column definition properties, see Updating Column Definitions.

Column Definition Grid Toolbar
The Column Definition grid menu includes the following:

■ Edit Menu

■ View Menu

■ Query By Example Button

Edit Menu
The Edit menu includes the following options that enable you to update, create, or 
delete column definitions:

■ Edit <column-def> – This menu option enables you to update the existing column 
definitions. Select the column definition you want to edit, and click this menu 
option to update the column definition. The Edit <column-def> screen appears. 
For more information, see Updating Column Definitions.

■ Duplicate <column-def> – This menu option enables you to create a duplicate 
version of an existing column definition. By creating a duplicate version, you can 
then easily set it up as a new column definition. For more information, see 
Creating Column Definitions.

■ Revert <column-def> to Default – This menu option enables you to revert the 
column definitions to the out of the box settings. For more information, see 
Reverting to the Default Column Definition.

■ Delete <column-def> – This menu option enables you to remove unused custom 
column definition elements in the grid configuration. For more information, see 
Deleting Custom Column Definitions.

View Menu
The View menu includes the following menu options:

■ Columns submenu – This submenu enables you to show or hide the parameter 
columns you want in the Column Definition grid.

■ Reorder Columns – This menu option enables you to reorder the parameter 
columns in the Column Definition grid.

■ Query By Example – This menu option enables you to filter the list of column 
definitions based on a specific query. When you click this option, a set of search 
fields appear on top of each column in the Column Definition grid. You can use 
these search fields to filter the list and review the column definitions you want.

To view all entries in a column with a specific text string, place a % (percentage) 
sign before and after the string, and then press Enter.
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Query By Example Button
The Query By Example button enables you to toggle the appearance of the search 
fields that appear on top of each column in the Column Definition grid. You can use 
these fields to filter the column definitions list and review the column definitions you 
want.

<column-def-properties> Area
The <column-def-properties> area appears on the right side of the screen. It lists the 
current parameter values for the column definition element selected in the Column 
Definition grid.

Column Definition States
Each column definition row is flagged using the state column. The state column 
displays the following states for each column definition:

■ DEFAULT – This indicates that the column definition is part of the default out of 
the box settings.

■ MODIFIED – This indicates that the default column definition has been modified 
and no longer identical to the default settings.

■ CUSTOM – This indicates that the column definition is a new custom definition 
with no default settings.

Updating Column Definitions
Use the Edit <column-def> menu option (from the Edit menu) to edit the column 
definitions you want. You can only update one column definition at a time. When you 
update a column definition, the value in the state column for the column definition 
changes from DEFAULT to MODIFIED.

To update a column definition:

1. On the Browse <column-def> screen, select the column definition row from the 
Column Definition grid.

2. From the Edit menu, click Edit <column-def>. The Edit <column-def> screen 
appears.
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Figure 2–2 Edit <column-def> Screen

3. On the Edit <column-def> screen, enter the relevant information in the following 
tabs:

■ <column-def-properties> Tab

■ <function> Tab

■ <custom-property> Tab

■ <ColumnDependency> Tab

4. Once you have made the necessary edits, click Done on any tab. The changes are 
saved temporarily and the Browse <column-def> screen appears.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit <column-def> screen.

5. On the Browse <column-def> screen, click Done. The Grid Designer screen 
appears.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit <column-def> screen.

6. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

Basic/Advanced Toggle Button
By default, only the <column-def-properties> and <function> tabs appear with the 
frequently used attribute fields for column definition. To view the other tabs and all 
the available attributes, click the Advanced button next to the Cancel button.

When you click the Advanced button, all the available attributes and tabs appear on 
screen, and the button name toggles to Basic. To switch back to the default basic view, 
click the Basic button.

The Basic/Advanced toggle button sets the view globally across the Grid Designer 
application. When you click Advanced on the Edit <column-def> screen, all available 
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attributes and tabs will appear by default on the Edit screens for the grid and report 
configuration files.

<column-def-properties> Tab
The <column-def-properties> tab displays the valid properties for the column 
definition element.

Figure 2–3 <column-def-properties> Tab on the Edit <column-def> Screen

To set up the column definition properties:

1. On the Edit <column-def> screen, click the <column-def-properties> tab.

2. Enter relevant information for the following properties:

■ key – Enter a unique key name for the column definition. This field appears 
only for custom column definitions.

■ dbColumnName – Name of the column in the database table or view.

■ label – The localized resource key label name. This name appears as the 
column name in the Clearance Optimization Engine user interface. The values 
in this field typically end with ".label". To set up a label name, click the 
Magnifying Glass icon next to the label text field. The Resource Browser Editor 
window appears. Click the check mark in the select <key> column next to the 
resource you want to select (see Figure 2–4). For more information on the 
Resource Browser Editor, see Chapter 3, "Setting Up Grid Resources".
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Figure 2–4 Resource Browser Editor Screen

■ description – The localized label description associated with the column. This 
description text appears as a tool tip when users hover over the column. To set 
up a description, click the Magnifying Glass icon next to the description text 
field. The Resource Browser Editor window appears. Click the check mark in 
the select <key> column next to the description resource you want to select 
(see Figure 2–4). The values in this field typically end with ".description". For 
more information on the Resource Browser Editor, see Chapter 3, "Setting Up 
Grid Resources". 

■ type – The data type of the column in the database. Valid values are integer, 
double, number, current, percent, date, and string.

■ displayType – The data type of the column displayed on screen. Valid values 
are date, edit, float, integer, currency, percent, pic, static-text, time, button, 
combobox, dropdown, picture, checkbox, owner-drawn, hyperlink, lock, and 
blank.

■ dbTableName – The associated database table or view name.

■ derivation – Specific SQL-based expression (condition or algorithm) that is 
used to derive the data in the column.

■ format – The format in which the column values will appear on screen. To set 
up a format, click the Magnifying Glass icon next to the format field. The 
Resource Browser Editor window appears. Click the check mark in the select 
<key> column next to the format resource you want to select (see Figure 2–4). 
The values in this field typically end with ".format". For more information on 
the Resource Browser Editor, see Chapter 3, "Setting Up Grid Resources". 

Note: It is recommended that you validate the SQL expression using 
a SQL editor before you inserting the derivation string. The Grid 
Designer application does not validate the accuracy of the SQL 
expressions.
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■ filterable – Specify whether you want to provide the data filtering 
functionality on the column. Valid values are true and false.

■ operatortype – The type of operator used during a filter operation. Valid 
values are numeric, list, and equals.

■ filtertype – The type of filtering functionality to be used for the column. Valid 
values are text, text-area, dropdown, and date.

■ columntype – The type of column. Valid values are row-select, 
expand-collapse, spacer, and none.

■ filterEnumSql – The specific SQL statement to be used for the filtering 
functionality on the column.

■ caseSensitive – Specify whether you want the data in the column to be case 
sensitive. Set the value to true or false.

■ sortable – Enables the users to use the sort feature in the grid based on this 
column. Set the value to true or false.

■ orderable – Enables the users to reorder the column in the grid at runtime. Set 
the value to true or false.

■ hideable – Enables the users to hide the column in the grid at runtime. Set the 
value to true or false.

■ editable – Enables the users to edit the data displayed in the column. Set the 
value to true or false.

■ readOnlyType – The data type of the column when it is in read-only mode 
(editable parameter set to false). Valid values are date, edit, float, integer, 
currency, percent, pic, static-text, time, button, combobox, dropdown, picture, 
checkbox, owner-drawn, hyperlink, lock, and blank.

■ editableInReadMode – Enables the users to edit the data in this column when 
the grid is in Read-Only mode.

■ composeable – Enables the users to compose the data in this column. Set the 
value to true or false.

■ visibility – Specify whether you want the column to be visible on screen. Valid 
values are visible, not-visible, and never-visible.

■ expandable – Specify whether you want the column to use the 
expand/collapse structure. Set the value to true or false.

■ template – Specify whether you want the column to be based on a template. 
Set the value to true or false.

■ imageHeader – Specify whether you want the column to include an image 
header.

■ resource – Specify whether you want to use the resource element for the 
column.

■ resourcedLabel – Specify whether you want to use the resource label for the 
column.

■ resourcedDescription – Specify whether you want to use the resource 
description for the column.

■ resourcePrefix – In case you want to use a resource prefix, click the 
Magnifying Glass icon. The Resource Browser Editor window appears. Select 
or create a prefix resource from this window. The values in this field typically 
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end with ".description". Click the check mark in the select <key> column next 
to the description resource you want to select. For more information on the 
Resource Browser Editor, see Chapter 3, "Setting Up Grid Resources". 

■ groupId – In case you want this column to be part of a column group, specify 
the column group key name in this field.

■ groupDescription – In case you specified a column group, specify the relevant 
group description in this field.

3. Click any other tab to continue setting up additional properties for the column 
definition or click Done to save changes temporarily and go back to the Browse 
<column-def> screen.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit <column-def> screen.

<function> Tab
The <function> tab enables you to set up the <function> element for the relevant 
column definition. the <function> element defines the aggregation function used to 
generate parent rows in the Clearance Optimization Engine grids.

Figure 2–5 <function> Tab on the Edit <column-def> Screen
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To set up a function for the column definition:

1. On the Edit <column-def> screen, click the <function> tab.

2. On the <function> tab, select a relevant function key from the key list (in the 
Aggregation Function Key area). This step applies when you are updating an 
existing default metric column definition. In case you are setting up a function for 
a new column definition, you may need to click Create Function first.

3. Click Remove Function to remove any function no longer needed for the column 
definition.

4. Once you select the function key, click Create (in the Function Arguments area) to 
add the function arguments. Based on the aggregation function selected, the 
argument values can be column keys or resource keys. 

Based on the function key you select, the valid arguments are automatically 
generated, and a relevant list of values (LOV) field appears in the Function 
Arguments area.

5. At any point, select the specific row, and click Delete to remove any unnecessary 
arguments.

6. Click any other tab to continue setting up additional properties for the column 
definition or click Done to save changes temporarily and go back to the Browse 
<column-def> screen.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit <column-def> screen.

Note: Clearance Optimization Engine only has leaf level values and 
all parent rows are calculated at runtime using the aggregation 
function. There are separate sets of aggregation functions for the grids. 
Not all aggregation functions may be relevant for all types of data. 
Some aggregation functions take additional arguments and some do 
not need additional arguments. 

For more information on the standard functions available for the 
Clearance Optimization Engine application, refer to the Oracle Retail 
Clearance Optimization Engine Configuration Guide.

Note: Not all aggregation functions take arguments. For example, 
P4P_MAX.

Note: The Create and Delete buttons are only active when a function 
accepts an optional argument. P4P_PRICELADDER, for example, 
accepts an optional argument.
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<custom-property> Tab
The <custom-property> tab enables you to add configuration elements to the column 
definition that are not part of the Grid.xsd specification. 

Figure 2–6 <custom-property> Tab on the Edit <column-def> Screen

To set up custom properties to the column definition:

1. On the Edit <column-def> screen, click the <custom-property> tab.

2. On the <custom-property> tab, click Create. A new blank row appears.

3. Enter relevant information in the name, value, and customType columns. 

4. At any point, select the specific row, and click Delete to remove any 
<ColumnDependency> elements.

5. Click any other tab to continue setting up additional properties for the column 
definition or click Done to save changes temporarily and go back to the Browse 
<column-def> screen.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit <column-def> screen.
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<ColumnDependency> Tab
The <ColumnDependency> tab enables you to specify additional column definitions 
that may be required as arguments to an aggregation function or to suit specific 
business needs.

Figure 2–7 <ColumnDependency> Tab on the Edit <column-def> Screen

To set up column dependency elements:

1. On the Edit <column-def> screen, click the <ColumnDependency> tab.

2. On the <ColumnDependency> tab, click Create. A new blank row is added.

Figure 2–8 New Row Added to the <ColumnDependency> Tab
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3. Under the <column-def> key column, click the Magnifying Glass icon next to the 
text field. The Column Definition Browser Editor window appears. 

Figure 2–9 Column Definition Browser Editor Window

4. Click the check mark in the select <key> column next to the column key you want 
to select, and then click OK.

5. Repeat steps 3 and 4 to add more rows.

6. At any point, select the specific row, and click Delete to remove any unnecessary 
custom properties.

7. Click any other tab to continue setting up additional properties for the column 
definition or click Done to save changes temporarily and go back to the Browse 
<column-def> screen.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit <column-def> screen.

Creating Column Definitions
Use the Duplicate <column-def> menu option (from the Edit menu) to create a new 
column definition based on an existing column definition. You can then edit the new 
column’s properties based on your business need.

You can create or duplicate one column definition at a time. When you create a 
duplicate column definition, the value in the state column for the column definition is 
set to CUSTOM.

To create a new column definition:

1. On the Browse <column-def> screen, select the column definition row from the 
Column Definition grid.

2. From the Edit menu, click Duplicate <column-def>. The duplicate version of the 
selected column definition is added to the Column Definition grid with a prefix 
copy_ added to the original column key name.
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3. Select the duplicate version, and then click Edit <column-def> from the Edit 
menu. The Edit <column-def> screen appears.

4. Set up the duplicate version as a new column definition referring to the 
instructions mentioned in the section Updating Column Definitions.

Deleting Custom Column Definitions
Use the Delete <column-def> menu option (from the Edit menu) to delete column 
definitions with the CUSTOM state.

You can delete one custom column definition at a time. 

To delete a custom column definitions:

1. On the Browse <column-def> screen, select the column definition row from the 
Column Definition grid.

2. From the Edit menu, click Delete <column-def>.

3. Once you have deleted the custom column definitions, on the Browse 
<column-def> screen, click Done. The Grid Designer screen appears. 

4. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out.

Reverting to the Default Column Definition
Once you modify a column definition, use the Revert <column-def> to Default menu 
option (from the Edit menu) to revert the column definition to the default out of the 
box setting.

Only column definitions with a MODIFIED state can be reverted back to the default 
out of the box setting (DEFAULT state).

To revert a column definition to default out of the box settings:

1. On the Browse <column-def> screen, select the column definition row from the 
Column Definition grid.

2. From the Edit menu, click Revert <column-def> to Default.

Note: Column definitions with the state DEFAULT and MODIFIED 
cannot be deleted.

Note: A column definition may be referenced by another column 
definition or grid. Before deleting a custom column definition, ensure 
that you remove such references. In case such references are not 
updated, validation errors may occur.
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3Setting Up Grid Resources

Grid resources specify the localized text for the column labels, descriptions, formats, 
grid names, and other such grid resources. 

This chapter describes how you can set up and create resource definitions to suit your 
business need. It includes the following sections:

■ About Grid Resources

■ Accessing the Resource Browser Editor Screen

■ Understanding the Resource Browser Editor User Interface

■ Resource Definition States

■ Updating Resource Definitions

■ Creating New Resource Definitions

■ Deleting Resource Definitions

■ Reverting to the Default Resource Definition

About Grid Resources
Grid resources are the localized resource strings that allow Clearance Optimization 
Engine to display the relevant grids and metric columns in any of the supported 
languages. The resource strings are stored in the gridResources.properties file and 
include the column label text, format, description, grid names, and other grid 
resources. For each supported language, a separate gridResources.properties file is 
available. For example, resource strings for the French language are available in the 
gridResources_fr.properties file. 

The Grid Designer application enables you to set up resource strings for all the 
supported languages. Once you publish the updated grid configuration, the 
gridResources.properties file for the relevant language is updated to reflect the latest 
resource strings.

The Grid Designer application enables you to configure resource strings for any 
configured languages within the set of supported languages. A typical Clearance 
Optimization Engine implementation may only configure one or two languages.

In the Grid Designer application, the Resource Browser Editor screen lists all the valid 
resource definitions used in the Clearance Optimization Engine application. It enables 
you to identify and set up specific resource keys and values in any of the supported 
locales.
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Accessing the Resource Browser Editor Screen
To access the Resource Browser Editor screen:

■ On the Grid Designer screen, click Resources Editor from the Configuration 
Navigator task panel.

Understanding the Resource Browser Editor User Interface
The Resource Browser Editor screen includes the following user interface components:

■ Resource Definition Grid

■ Resource Definition Grid Toolbar

Figure 3–1 Resource Browser Editor

Resource Definition Grid
The Resource Definition grid lists all the default grid resources along with the relevant 
definition properties. The grid includes an individual column for each available 
resource key language. Each such column lists information from the 
gridResources.properties file for the relevant language. 

Note: The Configuration Actions menu is disabled when you are on 
the Resource Browser Editor screen.
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Resource Definition Grid Toolbar
The Resource Definition grid menu includes the following:

■ Edit Menu

■ View Menu

■ Query By Example Button

Edit Menu
The Edit menu includes the following options that enable you to create or delete 
resource definitions:

■ New Resource – This menu option enables you to create a new resource key. For 
more information, see Creating New Resource Definitions.

■ Revert – This menu option enables you to revert the resource definitions to default 
out of the box settings. For more information, see Reverting to the Default 
Resource Definition.

■ Delete – This menu option enables you to remove unused custom resource 
definitions. For more information, see Deleting Resource Definitions.

View Menu
The View menu includes the following menu options:

■ Columns submenu – This submenu enables you to show or hide the parameter 
columns you want in the Resource Definition grid.

■ Reorder Columns – This menu option enables you to reorder the parameter 
columns in the Resource Definition grid.

■ Query By Example – This menu option enables you to filter the list of resource 
definitions based on a specific query. When you click this option, a set of search 
fields appear on top of each column in the Resource Definition grid. You can use 
these search fields to filter the list and review the resource definitions you want.

To view all entries in a column with a specific text string, place a % (percentage) 
sign before and after the string, and then press Enter.

Query By Example Button
The Query By Example button enables you to toggle the appearance of the search 
fields that appear on top of each column in the Resource Definition grid. You can use 
these fields to filter the resource definitions list and review the resource definitions 
you want.
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Resource Definition States
Each column definition row is flagged using the state column. The state column 
displays the following states for each column definition:

■ DEFAULT – This indicates that the column definition is part of the default out of 
the box settings.

■ MODIFIED – This indicates that the default column definition has been modified 
and is no longer identical to the default settings.

■ CUSTOM – This indicates that the column definition is a new custom definition 
with no default settings.

Updating Resource Definitions
You can update values of any key in the supported locale. When you update an 
existing resource definition, the value in the state column for the resource definition 
changes from DEFAULT to MODIFIED. The default values appear in grey colored text 
in italics, whereas the modified values appear in black plain text.

To update the resource definition:

1. In the Resource Definition grid, double-click the row you want to update. The 
fields under the Default and listed locale columns become editable.

Figure 3–2 Editable Fields under the Default and Listed Locale Columns

2. Enter valid values within the columns. In case you are setting up resource strings 
in a language other than English, you can choose to enter labels and descriptions 
in the characters used by the relevant language (as you want them to appear on 
screen). UTF-8 based characters are supported. 

Changes to existing resource definitions are persisted to the session by any other 
user action in Grid Designer. Key values that appear in italics represent edits that 
are different from the standard configuration values. You must enter a unique key 
name in the Key field. 

3. Click Done to save the changes temporarily. The Grid Designer screen appears.

4. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

Note: Key values cannot be changed once they are created.
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Creating New Resource Definitions
When new metrics or grids are added to a configuration, you also need to add new 
keys to the resources definition table. When you create a new resource definition, the 
value in the state column for the resource definition is set to CUSTOM.

To add new resource definitions:

1. From the Resource Definition Grid Toolbar, click New Resource in the Edit 
menu. The Specify Resource Key window appears.

Figure 3–3 Specify Resource Key Window

2. In the Specify Resource Key window, enter a valid key name in the key field.

3. Click OK. A new row is added with the key value you set in the previous step. 

4. Double-click this row, enter relevant information in the Default and configured 
locale columns, and then click Done to save the changes temporarily. The Grid 
Designer screen appears.

5. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

Deleting Resource Definitions
Use the Delete menu option (from the Edit menu) to delete column definitions with 
the CUSTOM state. You can delete one custom resource definition at a time. 

To delete a custom resource definition:

1. On the Resource Browse Editor screen, select the resource definition row from the 
Resource Definition grid.

2. From the Edit menu, click Delete.

3. Click Done to save the changes temporarily. The Grid Designer screen appears.

4. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out.

Note: Existing resource definitions (with the state DEFAULT and 
MODIFIED) cannot be deleted.

Note: When you delete a resource definition, ensure that you also 
update any column definition references that may be using the 
resource definition. In case such references are not updated, validation 
errors may occur.
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Reverting to the Default Resource Definition
Once you modify a resource definition, use the Revert menu option (from the Edit 
menu) to revert the resource definition to the default out of the box setting. Only 
resource definitions with a MODIFIED state can be reverted back to the default out of 
the box setting (DEFAULT state).

To revert a resource definition to default out of the box settings:

1. On the Resource Browse Editor screen, select the resource definition row from the 
Resource Definition grid.

2. From the Edit menu, click Revert.

3. Click Done to save the changes temporarily. The Grid Designer screen appears.

4. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 
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4Setting Up Grid Configuration Files

Once you have the column and resource definitions set up, you can start setting up 
these individual grid configuration files. Double-click on the grid configuration file 
you want and use the Edit screen to make the necessary updates. A right-click context 
menu is also available that provides additional configuration options.

This chapter describes how you can use the Grid Designer application to set up the 
individual grid configuration files. It includes the following sections:

■ About Grid Configuration Files

■ Updating a Grid Configuration File

■ Setting Up New Grid Configuration Files

■ Setting Up Duplicate Grid Configuration Files

■ Deleting Grid Configuration Files

■ Rearranging the Grid Configuration Files

■ Applying Column Layouts

About Grid Configuration Files
Grid configuration files represent the grids that appear in the Clearance Optimization 
Engine application. A grid configuration file includes elements that define the grid 
properties, the columns or column groups that appear in the grid, and other 
dependencies needed for the data to appear accurately in the grid.

The Grid Designer application enables you to set up the existing grid configuration 
files or use them as a template to create custom grid configuration files. By default, the 
Grid Designer application lists the standard grid configuration files based on the 
contents of the following files categorized into functional areas:

■ config.properties – This is the main application properties file for Clearance 
Optimization Engine. It contains a list of all XML files that are loaded when the 
application starts up. It also shows the application where to find the necessary 
column, grid, and properties files.

■ p4pgui-config.xml – This XML file defines the elements not defined in other 
configuration files. For example, grid name, metric item properties, and so on. It 
also includes the configuration elements for the Worksheet and Maintenance grids, 
and unique configurations for the Worksheet Summaries grid.
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Once you publish the updated grid configuration, the config.properties file is updated to 
reflect any new, duplicate, deleted grid configuration files. The p4pgui-config.xml file is 
also updated when any similar updates to the Worksheet Summaries and Maintenance 
grids are published. The p4pgui-config.xml file is also updated when changes to the tabs 
in Worksheet and Maintenance grids are published.

Default Grid Configuration Files
By default, the Configuration Navigator task panel includes the following list of grids 
configuration files (categorized based on the functional areas) under the Grids section:

■ Maintenance 

– p4p-maint-grid-groups.xml

■ Edit Pricing Group 

– p4p-edit-group-grid.xml

These grid configuration files are used to manage the Maintain Pricing Groups screen 
in Clearance Optimization Engine. For more information on the individual grid 
configuration files, refer to the Oracle Retail Clearance Optimization Engine Configuration 
Guide.

Using the Right-click Context Menu
In the Configuration Navigator panel, a right-click context menu is available for each 
grid configuration listed under the Grids section. The right-click menu provides you 
the following features:

■ Edit/View – Use this option to launch the Edit screen. You can also launch the Edit 
screen by double-clicking the grid configuration file. For more information, see 
Updating a Grid Configuration File.

■ New <grid> from template – Use this option to create a new grid configuration 
file based on the grid configuration file selected as template. For more information, 
see Setting Up New Grid Configuration Files.

■ Duplicate <grid> – Use this option to create a duplicate grid configuration file of 
the existing grid configuration file. For more information, see Setting Up Duplicate 
Grid Configuration Files.

■ Delete <grid> – Use this option to delete a grid configuration file. The standard 
grid configuration files cannot be deleted. For more information, see Deleting Grid 
Configuration Files.

Note: In the p4pgui-config.xml file, configuration aspects other than 
the grids and their order for worksheet and merchandise category 
need to configured manually.

To configure the Items Detail grid (item-details-layout.xml), see Setting 
Up Item Details Grid Configuration.

Note: The config.properties and p4pgui-config.xml files are updated 
even when the published grid configuration includes changes to the 
order of the grid configuration files listed within a category.
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■ Move up – Use this option to move the selected grid configuration file up the 
order in the list. For more information, see Rearranging the Grid Configuration 
Files.

■ Move down – Use this option to move the selected grid configuration file down 
the order in the list. For more information, see Rearranging the Grid Configuration 
Files.

■ Validate <grid> – Use this option to validate the selected grid configuration file. 
For more information, see Reviewing the Validation Logs.

■ Copy <column-group-spec> – Use this option to copy the column layout of the 
selected grid configuration. For more information, see Applying Column Layouts.

■ Paste <column-group-spec> – Use this option to paste the copied column layout 
of the selected grid configuration. For more information, see Applying Column 
Layouts.

■ Apply <column-group-spec> to All <grid>s in Category – Use this option to 
apply the column layout of the copied grid configuration to all the other grid 
configuration files in the specific category. For more information, see Applying 
Column Layouts.

■ Collapse – Use this option to collapse the grid configuration category.

■ Expand – Use this option to expand the grid configuration category.

■ Expand All Below – Use this option to expand all the grid configuration 
categories.

■ Collapse All Below – Use this option collapse all the grid configuration categories.

■ Show as Top – Use this option to view the grid configuration file as the top level 
element.

Updating a Grid Configuration File
To update a grid configuration:

1. From the Configuration Navigator task panel, in the Grids section, double-click 
the grid configuration file you want to set up. 

Or

Right-click on the grid configuration file you want to edit, and then click 
Edit/View from the right-click context menu.

An Edit screen appears with tabs that represent each of the following grid 
configuration elements:

■ <grid-properties>

■ <column-group-spec>

■ <row-group>

■ <ColumnDependency>

■ <custom-property>
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Figure 4–1 Edit Screen

2. On the Edit screen, enter the relevant information in the following tabs:

■ <grid-properties> Tab

■ <custom-property> Tab

■ <column-group-spec> Tab

■ <row-group> Tab

■ <ColumnDependency> Tab

3. Once you have made the necessary edits, click Done on any tab. The changes are 
saved in memory and the Grid Designer screen appears.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit screen.

Basic/Advanced Toggle Button
By default, only the <grid-properties>, <column-group-sec>, and <row-group> tabs 
appear with the frequently used attribute fields for grid configuration. To also view 
the <custom-property> and <ColumnDependency> tabs, and all the available 
attributes, click the Advanced button next to the Cancel button.

When you click the Advanced button, all the available attributes and tabs appear on 
screen, and the button name toggles to Basic. To switch back to the default basic view, 
click the Basic button.

The Basic/Advanced toggle button sets the view globally across the Grid Designer 
application. When you click Advanced on the Edit screen, all available attributes and 
tabs appear by default on the Edit screens for the grid and Edit <column-def> screen.
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<grid-properties> Tab
The <grid-properties> tab lists the base properties for configuring a grid. To set up the 
properties for the <grid-properties> element:

1. On the Edit screen, click the <grid-properties> tab.

Figure 4–2 <grid-properties> Tab on the Edit Screen

2. Enter relevant information for the following properties:

■ readonly – Specify whether you want the grid to appear read-only. From the 
list, select true or false.

■ defaultrowlevel – Specify the default row level for the grid.

■ firstrowheadercolumn – Specify the first row header column number.

■ DBTableName – Specify the relevant database table or view name.

■ DBKeyColumnName – Specify the relevant database column name.

■ name – Resource name for the grid. This will be the name of the grid 
displayed in the Clearance Optimization Engine user interface. Use the 
magnifying glass button to select a resource key. When you click the 
magnifying glass button, the Resource Browser Editor appears. Click the 
check mark in the select <key> column next to the resource you want to select 
(see Figure 2–4). For more information on working with the Resource Browser 
Editor, see Chapter 3, "Setting Up Grid Resources".

■ columnsFrozen – Specify the number of columns you want to appear as 
frozen. This is similar to the frozen pane in Microsoft Excel, where frozen rows 

Note: The key parameter always appears as read-only and cannot be 
edited.
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or columns will remain on screen when users scroll through a grid vertically 
or horizontally.

■ rowsFrozen – Specify the number of rows you want to appear as frozen. This 
is similar to the frozen pane in Microsoft Excel, where frozen rows or columns 
will remain on screen when users scroll through a grid vertically or 
horizontally.

■ filterable – Specify whether you want to allow the use of filters in the grid. 
From the list, select true or false.

■ maxVisibleColumns – Select the maximum number of columns that can be 
visible in the grid.

■ maxResultSetRows – Select the maximum number of rows that can appear as 
results for a search or filter action.

3. Click any other tab to continue setting up additional properties for the grid 
definition or click Done to save changes temporarily and go back to the Grid 
Designer screen.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit screen.

4. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

<custom-property> Tab
The <custom-property> tab enables you to add configuration elements to the grid 
definition that are not part of the Grid.xsd specification. 

To set up custom properties to the grid definition:

1. On the Edit screen, click the <custom-property> tab.

Figure 4–3 <custom property> Tab on the Edit Screen
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2. On the <custom-property> tab, click Create. A new blank row appears.

3. Enter relevant information in the name, value, and customType columns. 

At any point, select the specific row, and click Delete to remove any unnecessary 
custom properties.

4. Click any other tab to continue setting up additional properties for the grid 
definition or click Done to save changes temporarily and go back to the Grid 
Designer screen.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit screen.

5. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

<column-group-spec> Tab
The <column-group-spec> tab enables you to specify the order and hierarchical 
arrangement of the columns in a grid. 

A <column-group-sec> element includes a nested arrangement of <column-group> 
and <column> elements. Each of these elements inherit properties from the column 
definition (<column-def> element), specified in the <parent-key> property in the 
<key> property itself. The <column-group> elements contain <column> elements or 
other <column-group> elements, and act as labeled headers. Only the <column> 
elements have a corresponding data column in the Clearance Optimization Engine 
application. Properties of the <column-group> and <column> elements can be set to 
override the defaults set in the relevant column definition elements using the Edit 
option (from the Edit menu).

Figure 4–4 <column-group-spec> Tab on the Edit Screen
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Understanding the <column-group-spec> Tab User Interface
The <column-group-spec> tab includes the following two areas:

■  Column Group Specification Area

■  Column Definition Browser Area

Column Group Specification Area  This area appears on the left side of the screen and 
displays the order and hierarchical structure of the columns and groupings in the 
Clearance Optimization Engine user interface. It also includes a toolbar with the 
following menus and buttons:

■ Edit menu – The Edit menu enables you to make updates to the listed columns or 
column groups. It includes the following menu options:

– Edit – Use this option to set up the column or column group definitions. When 
you choose to edit a column, an Edit screen similar to the Edit <column-def> 
screen appears. In case you choose to edit a column group, a similar Edit 
screen appears with only the <columngroup-properties> and 
<custom-property> tabs. The <columngroup-properties> tab is similar to the 
<column-def-properties tab> and includes only the properties that are relevant 
to column groups. 

For more information on the tabs and fields, see Updating Column 
Definitions.

– Cut – Use this option to cut the elements you want from the list.

– Paste – Use this option to paste the elements you cut before the location you 
have selected in the list.

– Paste Into – Use this option to paste the elements you cut into a column group 
you have selected in the list.

– Convert to <column-group> – Use this option to convert a column that you 
have selected to a column group element. This menu option appears only 
when you select a column.

– Convert to <column> – Use this option to convert a column group that you 
have selected to a column. This menu option appears only when you select a 
column group. When you convert a column group to a column, all child 
columns will be automatically removed.

– Delete – Use this option to delete the elements from the list. Deleting a column 
group will automatically also delete any child columns.

■ View menu – The View menu includes the following menu options:

– Columns submenu – This submenu enables you to show or hide additional 
parameter columns.

– Collapse – Use this option to collapse an expanded column group. This menu 
option appears enabled only when you select a column group.

– Expand All Below – Use this option to expand all column groups that are 
listed after the selected column group. This menu option appears enabled only 
when you select a column group.

– Collapse All Below – Use this option to collapse all column groups that are 
listed after the selected column group. This menu option appears enabled only 
when you select a column group.

– Expand All – Use this option to expand all column groups listed. 
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– Collapse All – Use this option to collapse all column groups listed.

– Show as Top – Use this option to view the column group as the top level 
element. This menu option appears enabled only when you select a column 
group.

– Go to Top – This menu option appears enabled only when you view the 
column group as the top level element (using Show as Top). Use this option to 
revert back to the top level that includes the list of all columns and column 
groups.

– Scroll to First – Use this option to scroll to the first row in the list.

– Scroll to Last – Use this option to scroll to the last row in the list. 

■ Go Up button – This button appears enabled only when you view the column 
group as the top level element (using Show as Top). Click this button to revert 
back to the upper level within a column group.

■ Go To Top button – This button appears enabled only when you view the column 
group as the top level element (using Show as Top). Click this button to revert 
back to the top level that includes the list of all columns and column groups.

■ Show as Top button – Use this button to view the column group as the top level 
element. This button appears enabled only when you select a column group.

Column Definition Browser Area  This area appears on the right side of the screen and 
displays a list of all the column definition elements available for the grid. This area is 
similar to the Browse <column-def> screen, except that the Edit menu only includes 
the option to copy column definitions. For more information on the Browse 
<column-def> screen, see Understanding the Browse <column-def> User Interface.

Setting Up New Column Definitions in a Grid Layout
To add new columns to the grid configuration or layout:

1. Select the column definitions listed in Column Definition Browser area (right side 
of the screen), and click Copy in the Edit menu. 

2. Once copied, click Paste in the Edit menu of the Column Groups Specification 
area (left side of screen). To add a column to a column group, use the Paste Into 
option.

OR

You can also drag the column definition rows from the table on the right to the tree on 
the left. If the target node in the tree is a column group, the dropped columns are put 
into the column group. For regular columns, the dropped columns are put after the 
target.

Note: You can rearrange the column layout by dragging and 
dropping selected columns within the tree. Once you drop the 
selected columns, the tree will refresh automatically to reflect the new 
order of columns and column groups. 
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<row-group> Tab
The <row-group> tab enables you to set up properties of a hierarchy of aggregated 
rows at and above the leaf-level. Nodes in a tree structure represent each level in a 
hierarchy. Each node has row properties, and may also have overrides of column 
properties that apply only at a specific row hierarchy level.

Figure 4–5 <row-group> Tab on the Edit Screen

Understanding the <row-group> Tab User Interface
The <row-group> tab user interface includes the following areas:

■ <row-group> tree – This tree appears on the left side of the screen and lists the 
hierarchical structure of the row group keys.

■ <row-group> toolbar – Located above the <row-group> tree, this toolbar includes 
the Edit and View menus. The Edit menu includes the following options that 
enable you to create, delete, or move the row groups up and down in the 
hierarchy:

– Duplicate – Use this option to create a duplicate version of an existing row 
group element. You can then rename the key and update the relevant 
properties to set this as a new row group.

– Move Up – Use this option to move the selected row group up in the 
hierarchy.

– Move Down – Use this option to move the selected row group down in the 
hierarchy.

– Delete – Use this option delete the selected row group from the hierarchy.

■ <rowgroup-properties> tab – This tab enables you to update the name of the key 
and set the base properties for the row group.

■ <override-column-group> tab – This tab enables you to override the default 
values of the column definitions included. It also includes a View menu that 
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enables you to show or hide and reorder the following columns displayed in the 
tab.

■ <custom-property> tab – This tab enables you to set up any custom property for 
the row group and is similar to the <custom-property> tab on the Edit screen. For 
more information, see <custom-property> Tab.

Setting Up Row Groups
To set up row groups:

1. On the <row-group> tab, click the row group you want to set up in the 
<row-group> tree.

2. In the <rowgroup-properties> tab, enter relevant information in the following 
fields:

■ key – Specify a unique row group key name.

■ expandable – Specify whether you want the row-group to use the 
expand/collapse structure. Set the value to true or false.

■ isExpanded – Specify whether you the row-group appear expanded on screen 
by default.

■ name – Name of the row group.

■ topGroupBy – Specify a relevant column name that will act as the top level 
element for the row group.

3. In the <override-column-group> tab, for the column definition you want, update 
the values under the relevant columns. The <override-column-group> tab 
includes the following columns in the grid:

■ key – The unique column group key name.

■ functionKey – Name of the function used by the column group.

■ displayType – The data type used to display the column group.

■ editable – Indicates whether the column group can be edited.

■ readOnlyType – The data type used when the column group is in read-only 
mode.

■ editableInReadMode – Indicates whether the data in the column group can be 
edited when the grid is in read-only mode.

■ format – Indicates the format of the data that appears in the column group.

■ resource – Indicates whether resources are used for the column group.

■ resourcePrefix – Indicates whether a resource prefix is used for the column 
group.

4. In the <row-group> tree, use the Move Up and Move Down menu options from 
the Edit menu to move the row-group up or down in the hierarchy.

To create a new row group:

1. Select a row group that is similar to the row group you want, and click Duplicate 
from the Edit menu. A duplicate row group is added to the hierarchy.

2. Follow Steps 2 through 4 above to create a new key name and set the correct place 
in the hierarchy.
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<ColumnDependency> Tab
The <ColumnDependency> tab enables you to specify additional column definitions 
that may be required for the grid to work accurately or to suit specific business needs.

To set up column dependency elements:

1. On the Edit screen, click the <ColumnDependency> tab.

Figure 4–6 <ColumnDependency> Tab on the Edit Screen

2. On the <ColumnDependency> tab, click Create. The Specify <column-def> key 
window appears.

3. On the Specify <column-def> key window, select a relevant column key from the 
key list.

4. Click OK.

5. At any point, select the specific row, and click Delete to remove any unnecessary 
custom properties.

6. Click any other tab to continue setting up additional properties for the grid 
definition or click Done to save changes and go back to the Grid Designer screen.

On any tab, click Cancel to reset any changes you made. This will cancel any 
changes made on any tab since entering the Edit screen.

7. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 
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Setting Up New Grid Configuration Files
From the right-click context menu, use the New <grid> from template option to set up 
new grid configuration files using the existing grid configuration files (in the relevant 
category) as a template.

To set up a new grid configuration file:

1. In the Configuration Navigator panel, under Grids, right-click on any file within 
the category where you want to set up a new grid configuration file.

2. From the right-click context menu, click New <grid> from template. The New 
<grid> from template window appears.

3. On the New <grid> from template window, enter the relevant information in the 
following fields:

■ Select Template Grid – From the list, select the existing grid configuration file 
you want to use as a template.

■ Grid <key> – Specify a grid key name for the new grid configuration file.

■ Grid filename – Specify an unique file name for the new grid configuration 
file.

4. Click OK. The Configuration Navigator panel automatically gets updated to 
include the new grid configuration file. 

5. Double-click the grid configuration file (or right-click on the grid configuration file 
and click Edit/View from the right-click context menu) to launch the Edit screen 
and update the grid configuration properties. For more information on updating 
the grid configuration, see Updating a Grid Configuration File.

Setting Up Duplicate Grid Configuration Files
From the right-click context menu, use the Duplicate <grid> option to create a 
duplicate copy of an existing grid configuration file. 

To set up a duplicate copy of a grid configuration file:

1. In the Configuration Navigator panel, under Grids, right-click on any file within 
the category where you want to set up the duplicate grid configuration file.

2. From the right-click context menu, click Duplicate <grid>. The Duplicate Grid 
window appears.

3. On the Duplicate Grid window, enter relevant information in the following fields:

■ Grid <key> – Specify a grid key name for the duplicate grid configuration file.

■ Grid filename – Specify an unique file name for the duplicate grid 
configuration file.

4. Click OK. The Configuration Navigator panel automatically gets updated to 
include the duplicate grid configuration file. 

5. Double-click the grid configuration file (or right-click on the grid configuration file 
and click Edit/View from the right-click context menu) to launch the Edit screen 
and update the grid configuration properties. For more information on updating 
the grid configuration, see Updating a Grid Configuration File.
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Deleting Grid Configuration Files
From the right-click context menu, use the Delete <grid> option to delete the custom 
grid configuration files. Standard grid configuration files cannot be deleted.

To delete a grid configuration file:

1. In the Configuration Navigator panel, under Grids, right-click on the grid 
configuration file you want to delete.

2. From the right-click context menu, click Delete <grid>. The Configuration 
Navigator panel automatically gets updated and no longer includes the grid 
configuration file.

Rearranging the Grid Configuration Files
The order of the configuration files that appear within Worksheet and Maintenance 
categories are based on the tab order of the relevant grids in Clearance Optimization 
Engine. You can change the tab order by moving the grid configuration file up or 
down within the category.

From the right-click context menu, use the Move up and Move down options to 
rearrange the grid configuration files within a category. 

To move a grid configuration file up in the order: 

■ Right-click the grid configuration file, and then click Move up. The Configuration 
Navigator panel automatically gets updated with the selected grid configuration 
file one level up in the order. 

To move a grid configuration file down in the order:

■ Right-click the grid configuration file, and then click Move down. The 
Configuration Navigator panel automatically gets updated with the selected grid 
configuration file one level down in the order. 

Applying Column Layouts
From the right-click context menu, use the Copy <column-group-spec>, Paste 
<column-group-spec>, and Apply <column-group-spec> to All <grid>s in Category 
options to apply column layouts from the existing grid configuration. Once you copy 
the column layout from an existing grid configuration, you can choose to apply the 
column layout to a single grid configuration file or all grid configuration files within a 
category.

To apply a column layout:

1. In the Configuration Navigator panel, under Grids, right-click on the grid 
configuration file whose column layout you want to apply.

2. From the right-click context menu, click Copy <column-group-spec>.

3. Right-click on the grid configuration file where you want to apply the column 
layout.

4. From the right-click context menu, click Paste <column-group-spec>.

5. To apply the copied column layout on all the grid configuration files within a 
category, from the right-click context menu, click Apply <column-group-spec> to 
All <grid>s in Category.
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6. Double-click the grid configuration file (or right-click on the grid configuration file 
and click Edit/View from the right-click context menu) to launch the Edit screen 
and update the grid configuration properties. For more information on updating 
the grid configuration, see Updating a Grid Configuration File.
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5Setting Up Item Details Grid Configuration

The Item Info dialog box provides detailed item information and appears when you 
click the item name link on the worksheet in the Clearance Optimization Engine 
application. It displays metrics information for an item in a tabular format based on 
the Item Details grid configuration file (item-details-layout.xml) that is organized into 
groups and labeled headers. The Item Details Layout screen enables you to set up the 
Item Details grid configuration.

This chapter describes how you can use the Item Detail Layout screen in the Grid 
Designer application to set up the Item Details grid configuration. It includes the 
following sections:

■ Accessing the Item Details Layout Screen

■ Understanding the Item Details Layout User Interface

■ Updating Item Details Grid Configuration

■ Adding Columns to the Item Details Grid Configuration

■ Adding Groups to the Item Details Grid Configuration

■ Adding Rows to the Item Details Grid Configuration

■ Deleting Rows from the Item Details Grid Configuration

■ Deleting Groups from the Item Details Grid Configuration

■ Deleting Columns from the Item Details Grid Configuration

■ Rearranging Rows in the Item Details Grid Configuration

Accessing the Item Details Layout Screen
To access the Browse <column-def> screen:

■ On the Grid Designer screen, click Item Details Layout from the Configuration 
Navigator task panel.
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Understanding the Item Details Layout User Interface
The Item Details Layout screen includes the following user interface components:

■ Item Details Layout Grid

■ Item Details Layout Footer Area

■ Item Details Layout Toolbar

Figure 5–1 Item Details Layout Screen

Item Details Layout Grid
The Item Details Layout grid displays the metrics in the Item Details grid 
configuration that are set to appear in the Item Info dialog box. By default, the grid 
appears with two columns with each column listing multiple rows of metrics. The 
metrics are organized in two groups (set in the groupTitle column). You can use the 
options from the Edit menu to add more columns, groups, and rows. For more 
information, see Edit Menu.

Item Details Layout Footer Area
The Item Details Layout footer area includes the following fields:

■ Show Messages check box – Use this check box to display status messages in the 
Item Info dialog box. 

■ Messages Title – This field enables you to choose a title for the status messages 
area in the Item Info dialog box. Click the Magnifying Glass icon next to the text 
field. The Resource Browser Editor window appears. Click the check mark in the 
select <key> column next to the resource you want to select.
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Item Details Layout Toolbar
The Item Details Layout toolbar includes the following menus:

■ Edit Menu

■ View Menu

Edit Menu
The Edit menu includes the following menu options:

■ Add Column – This menu option enables you to add columns to the Item Details 
grid configuration. For more information, see Adding Columns to the Item Details 
Grid Configuration.

■ Add Group – This menu option enables you to add groups and organize the 
metrics in the Item Details grid configuration. For more information, see Adding 
Groups to the Item Details Grid Configuration.

■ Add Row – This menu option enables you to add additional rows to the Item 
Details grid configuration. For more information, see Adding Rows to the Item 
Details Grid Configuration.

■ Delete Row – This menu option enables you to delete the selected row in the Item 
Details Layout grid. For more information, see Deleting Rows from the Item 
Details Grid Configuration.

■ Delete Group – This menu option enables you to delete the selected group in the 
Item Details Layout grid. When you delete a group, all children rows within the 
group will also be deleted. For more information, see Deleting Groups from the 
Item Details Grid Configuration

■ Delete Column – This menu option enables you to delete the last column (far right 
column) in the Item Details Layout grid. For more information, see Deleting 
Columns from the Item Details Grid Configuration.

■ Move Up – This menu option enables you to move the selected rows up by one 
row in the Item Details Layout grid. For more information, see Rearranging Rows 
in the Item Details Grid Configuration.

■ Move Down – This menu option enables you to move the selected rows down by 
one row in the Item Details Layout grid. For more information, see Rearranging 
Rows in the Item Details Grid Configuration.

View Menu
The View menu includes the following menu option:

■ Columns submenu – This submenu enables you to show or hide the columns in 
the Item Details Layout grid.
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Updating Item Details Grid Configuration
To update an existing Item Details grid configuration:

1. On the Item Details Layout screen, in the relevant cell, click the magnifying glass 
icon next to the attribute you want to update. The Column Definition Browser 
window appears.

Figure 5–2 Column Definition Browser Window

2. Click the check mark in the select <key> column next to the column definition you 
want to select.

3. Click OK.

4. Click Done to save the changes temporarily. The Grid Designer screen appears.

5. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

Adding Columns to the Item Details Grid Configuration
You can add upto 10 columns in the Item Details Layout grid. To add columns to the 
Item Details grid configuration:

1. On the Item Details Layout screen, from the Edit menu, click Add Column. 

A new column is added to the Item Details Layout grid as the last column (to the 
far right).

2. Under the relevant column, for the cell you want, click the magnifying glass icon 
next to the attribute you want to update. The Column Definition Browser 
window appears.

3. Click Done to save the changes temporarily. The Grid Designer screen appears.

4. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 
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Adding Groups to the Item Details Grid Configuration
To add a group to the Item Details grid configuration:

1. On the Item Details Layout screen, from the Edit menu, click Add Group. A blank 
group row gets added at the bottom of the grid. If you had a row selected, the new 
group row gets added below the selected row.

2. Under the groupTitle column, click the magnifying glass icon next in the relevant 
cell. The Column Definition Browser window appears.

You can also enter the key value manually.

3. In the Column Definition Browser window, click the check mark in the select 
<key> column next to the column definition you want to select.

4. Click OK.

5. Click Done to save the changes temporarily. The Grid Designer screen appears.

6. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

Adding Rows to the Item Details Grid Configuration
To add a row to the Item Details grid configuration:

1. On the Item Details Layout screen, from the Edit menu, click Add Row. A blank 
row gets added at the bottom of the grid. If you had a row selected, the new row 
gets added below the selected row.

2. Under the relevant column, for the cell you want, click the magnifying glass icon. 
The Column Definition Browser window appears.

You can also enter the key value manually. 

3. In the Column Definition Browser window, click the check mark in the select 
<key> column next to the column definition you want to select.

4. Click OK.

5. Click Done to save the changes temporarily. The Grid Designer screen appears.

6. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

Note: For group rows, cells under the columns other than the 
groupTitle column are not editable.

Note: For rows, cells under the groupTitle column are not editable.
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Deleting Rows from the Item Details Grid Configuration
To delete a row from the Item Details grid configuration:

1. On the Item Details Layout screen, select the row you want to delete. 

2. From the Edit menu, click Delete Row.

To delete multiple rows, select the rows you want to delete using the CTRL or 
SHIFT keys, and then click Delete Row from the Edit menu.

3. Click Done to save the changes temporarily. The Grid Designer screen appears.

4. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

Deleting Groups from the Item Details Grid Configuration
To delete a group from the Item Details grid configuration:

1. On the Item Details Layout screen, select the group row you want to delete. 

2. From the Edit menu, click Delete Group.

To delete multiple groups, select the rows you want to delete using the CTRL or 
SHIFT keys, and then click Delete Group from the Edit menu.

3. Click Done to save the changes temporarily. The Grid Designer screen appears.

4. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

Deleting Columns from the Item Details Grid Configuration
The Item Details Layout screen enables you to delete columns from the far right in the 
Item Details Grid. To delete a column from the Item Details grid configuration:

1. On the Item Details Layout screen, from the Edit menu, click Delete Column. 
Column to the far right is deleted.  You can delete columns up to the groupTitle 
and column1 columns.

2. Click Done to save the changes temporarily. The Grid Designer screen appears.

3. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 

Note: You can use the Delete Row option to delete a single group 
row from the Item Details grid. Once deleted the children rows for 
that group appear under the previous group row. 

Only group rows other than the first group row/element in the Item 
Details grid can be deleted.
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Rearranging Rows in the Item Details Grid Configuration
To rearrange rows in the Item Details grid configuration:

1. On the Item Details Layout screen, select the row you want to move.

2. From the Edit menu, click Move Up or Move Down. The selected row moves up 
or down (based on the option you clicked) by one row.

To move multiple rows, select the rows you want to move using the CTRL or 
SHIFT keys, and then click Move Up or Move Down from the Edit menu.

3. Click Done to save the changes temporarily. The Grid Designer screen appears.

4. To ensure that the updates are saved, you must click Save from the Configuration 
Actions menu (on the Grid Designer screen) before you log out. 
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6Reviewing the Validation Logs

When setting up the grids, validation issues may occur. You must fix any such 
validation issues before you publish the updated grid configuration to the production 
system/environments. The Validation Log window enables you to review such 
validation issues, along with informational messages.

This chapter describes how you can review any validation messages that are recorded 
during the grid configuration. It includes the following sections:

■ Accessing the Validation Log Window

■ Understanding the Validation Log Window User Interface

Accessing the Validation Log Window
You can access the Validation Log window using one of the following options:

■ On the Grid Designer screen, click Validation Log from the Configuration 
Navigator task panel.

OR

■ From the Configuration Actions menu, click Validate to perform a validation 
check on the updated configuration again. The Validation Log window appears 
with the updated log information.

Keeping this window open for reference, you can go back to the relevant Grid 
Designer screens to fix the validation errors.

Once you have fixed the validation issues, close the Validation Logs window, and click 
Validate (in the Configuration Actions menu) perform a validation check again.

Validation for the Grid Configuration Files
You can validate individual grid configuration files. To validate an individual grid 
configuration file:

1. From the Grids section in the Configuration Navigator panel, right-click on the 
file you want to validate.

2. From the right-click context menu, click Validate.

Note: The validation framework does not catch any issues with SQL 
expressions. It is recommended that you use a SQL editor to validate 
any SQL expressions you want to use.



Understanding the Validation Log Window User Interface

6-2 Oracle® Retail Clearance Optimization Engine Grid Designer User Guide

Validation During the Publish Operation
The validation framework is set to automatically run when you choose publish an 
updated grid configuration. 

Understanding the Validation Log Window User Interface
The Validation Log window includes the following user interface components:

■ Validation Log Grid

■ Validation Log Grid Toolbar

Figure 6–1 Validation Log Window

Validation Log Grid
The Validation Log grid lists all the relevant validation errors that may have occurred 
during the grid configuration. It displays data using the following columns:

■ Components – This column lists the grid configuration file where the validation 
issue has occurred.

■ Severity – This column lists the severity of the issue.

■ Message – This column provides a summary of the validation issue.

Note: You cannot publish a configuration with errors.



Understanding the Validation Log Window User Interface

Reviewing the Validation Logs 6-3

Validation Log Grid Toolbar
The Validation Log grid toolbar appears on the top of the Validation Log grid and 
includes the following:

■ View Menu

■ Query By Example Button

View Menu
The View menu includes the following menu options:

■ Columns submenu – This submenu enables you to show or hide the parameter 
columns you want in the Validation Log grid.

■ Reorder Columns – This menu option enables you to reorder the parameter 
columns in the Validation Log grid.

■ Query By Example – This menu option enables you to filter the list of validation 
logs based on a specific query. When you click this option, a set of search fields 
appear on top of each column in the Validation Log grid. You can use these search 
fields to filter the list and review the validation logs you want.

To view all entries in a column with a specific text string, place a % (percentage) 
sign before and after the string, and then press Enter.

Query By Example Button
The Query By Example button enables you to toggle the appearance of the search 
fields that appear on top of each column in the Validation Log grid. You can use these 
fields to filter the validation logs list and review the validation logs you want.
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