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Preface 
Oracle Retail® Point-of-Sale (RPOS) is a Java® point-of-sale system that allows you to 
extend and modify your point-of-sale (POS) functionality. RPOS combines an intuitive 
graphical-user interface (GUI), a comprehensive list of retail functionality, real-time 
processing, high-availability features including off-line capabilities, security features, and 
other POS features needed to thrive in a retail environment. 
With its integrated application tools (RPOS Tools Application Builder, RPOS Tools 
Mission Control, RPOS Tools Receipt/Report Builder, and RPOS Tools Object Inspector), 
RPOS expands the definition of a POS system by allowing you to customize the 
application to meet all of your business needs. 

Related Documents 
For more information, see the following documents in the Oracle Retail Point-of-Sale 
Release 11.1.3 documentation set: 
 Oracle Retail Point-of-Sale Installation Guide 
 Oracle Retail Point-of-Sale Release Notes 
 Oracle Retail Point-of-Sale Operations Guide 
 Oracle Retail Point-of-Sale Data Model 
 Oracle Retail Point-of-Sale Mission Control User Guide 
 Oracle Retail Point-of-Sale Receipt and Report Builder User Guide 
 Oracle Retail Point of Sale User Guide 
 Oracle Retail Point-of-Sale Online Help 

Customer Support 
 https://metalink.oracle.com  

When contacting Customer Support, please provide: 
 Product version and program/module name. 
 Functional and technical description of the problem (include business impact). 
 Detailed step-by-step instructions to recreate. 
 Exact error message received. 
 Screen shots of each step you take. 

Review Patch Documentation 
For a base release (".0" release, such as 12.0), Oracle Retail strongly recommends that you 
read all patch documentation before you begin installation procedures. Patch 
documentation can contain critical information related to the base release, based on new 
information and code changes that have been made since the base release. 

https://metalink.oracle.com/
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Oracle Retail Documentation on the Oracle Technology Network 
In addition to being packaged with each product release (on the base or patch level), all 
Oracle Retail documentation is available on the following Web site: 
http://www.oracle.com/technology/documentation/oracle_retail.html 
Documentation should be available on this Web site within a month after a product 
release. Note that documentation is always available with the packaged code on the 
release date.  

Conventions 
Navigate: This is a navigate statement. It tells you how to get to the start of the procedure 
and ends with a screen shot of the starting point and the statement “the Window Name 
window opens.” 

Note: This is a note. It is used to call out information that is 
important, but not necessarily part of the procedure. 

This is a code sample 
 It is used to display examples of code 
 

A hyperlink appears like this. 
 
 

http://www.oracle.com/technology/documentation/oracle_retail.html
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Introduction 

Introduction  
The Oracle Retail® ISO - Object Library and Tools Application Builder™ provides a set 
of modules to customize the Oracle Retail Point of Sale and Cash Management™ (RPOS) 
application. The following are the five main modules within Application Builder: 
 Business Rule Repository module—allows you to generate and assign business 

rules. 
 Design Applet Model module—allows you to view and modify the navigational 

flow of RPOS. 
 Menu Options module—allows you to customize and create new RPOS application 

menus and menu options. 
 Resource Bundles module—allows you to bundle information for 

internationalization resourcing. 
 Service Code Generator module—allows you to change a method definition in a 

Services class. 

WorkSpace overview 
The Application Builder workspace consists of a single window containing a menu bar, 
toolbar, tabs, and a panel. The panel consists of panes that vary depending on selected 
module. The options visible on the toolbar also vary depending on the task being 
performed.  
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Application Builder workspace 

Menus 
Application Builder consists of the following menus: 
 File 
 Edit 
 Wizards 
 View 
 Options 
 Help 

The File and Edit menus are dynamic menus whose menu options change depending on 
the selected module. All other menus are static and their menu options remain the same 
regardless of the task you are performing. 
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File menu 
Menu options on the File menu vary depending on the selected module. The Close and 
Exit menu options are the only default options that are available regardless of the task 
being performed. The table lists and describes the File menu options. 

File Menu Options 

Menu Option Description 

Close Closes the active window. This is a default menu option. 

Exit Closes all open windows and exits Application Builder. This is a 
default menu option. 

New Rule Creates a new business rule. This menu option is available using the 
Business Rules Repository module. 

New Applet Model Creates a new applet model. This menu option is available using the 
Design Applet Model module. 

Open Applet Model Opens an existing applet model. This menu option is available using 
the Design Applet Model module. 

Save Applet Model Saves the active applet model. This menu option is available using 
the Design Applet Model module. 

Print Applet Model Prints the active applet model. This menu option is available using 
the Design Applet Model module. 

Details Provides details of the active applet model. This menu option is 
available using the Design Applet Model module. 

New Menu Options Creates a new menu button or option. This menu option is available 
using the Menu Options module when the Menu Options tab 
is selected. 

Save Menu Options Saves the active menu button or menu option. This menu option is 
available using the Menu Options module when the Menu Options 
tab is selected. 

New Menu Creates a new menu. This menu option is available using the Menu 
Options module when the Menu tab is selected. 

Save Menu  Saves the active menu. This menu option is available using the Menu 
Options module when the Menu tab is selected. 

New Menu Constant Creates a new menu constant. This menu option is available using the 
Menu Options module when the Generate Menu Helper tab 
is selected. 

Save Menu Constant Saves the active menu constant. This menu option is available using 
the Menu Options module when the Generate Menu Helper tab 
is selected. 

Compile Menu Constant Compiles the active menu constant. This menu option is available 
using the Menu Options module when the Generate Menu Helper tab 
is selected. 

New Bundle Creates a new resource bundle. This menu option is available using 
the Resource Bundles module. 
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File Menu Options 

Menu Option Description 

Save Bundle Saves the active resource bundle. This menu option is available using 
the Resource Bundles module. 

Compile Bundle Compiles a resource bundle. This menu option is available using the 
Resource Bundles module. 

Delete Bundle Deletes the selected resource bundle. This menu option is available 
using the Resource Bundles module. 

Note: To an example of a File menu, see the appropriate 
chapter for each module. 

Edit menu 
The Edit menu options vary depending on the selected module. The table lists and 
describes the Edit menu options. 

Edit Menu Options 

Menu Option Description 

Assign Rule Assigns a business rule to a method. This menu option is available 
using the Business Rules Repository module. 

Unassign Rule Unassigns a business rule from a method. This menu option is 
available using the Business Rules Repository module. 

Move Priority Up Moves a business rule up in priority within a method. This menu 
option is available using the Business Rules Repository module. 

Move Priority Down Moves a business rule down in priority within a method. This menu 
option is available using the Business Rules Repository module. 

Delete Rule Deletes a business rule from a method. This menu option is available 
using the Business Rules Repository module. 

Delete Menu Options Deletes a menu option from a menu. This menu option is available 
using the Menu Options module when the Menu Options tab 
is selected. 

Delete Menu Deletes a menu from the RPOS application. This menu option is 
available using the Menu Options module when the Menu tab 
is selected. 

Insert Key Inserts a key value pair to a resource bundle. This menu option is 
available using the Resource Bundles module. 

Delete Key Deletes a key value pair from a resource bundle. This menu option is 
available using the Resource Bundles module. 

Update Updates the Resource Bundles window. 

Find Allows you to search and find a resource. This menu option is 
available using the Resource Bundles module. 
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Edit Menu Options 

Menu Option Description 

Add List Entry Adds a list entry to a service. This menu option is available using the 
Configuration Manager module. 

Delete List Entry Deletes a list entry from a service. This menu option is available 
using the Configuration Manager module. 

Note: The Edit menu is inactive when you first start 
Application Builder. To make the Edit menu active, you 
must perform a task (for example, create a new menu 
button). 

Note: To an example of a Edit menu, see the appropriate 
chapter for each module. 

Wizards menu 
The Wizards menu allows you to access the Rule Wizard, Applet Wizard, and the 
Resource Wizard. The table lists and describes the Wizard menu options. 

 
Wizards menu 

Wizard Menu Options 

Menu Option Description 

Rule Wizard Allows you to create a new business rule by following step-by-step 
instructions. 

Applet Wizard Allows you to create a new applet, remove an existing applet from a 
model, or to move an applet to a different model by following step-
by-step instructions. 

Resource Wizard Allows you to view and modify the resource hard-coded strings 
found in the source code by following step-by-step instructions. 
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View menu 
The table lists and describes the View menu options. 

 
View menu options 

View Menu Options 

Menu Option Description 

Business Rules Starts the Business Rules Repository module that allows you to work 
with business rules. 

Applet Model Starts the Design Applet Model module that allows you to work with 
an applet models. 

Menu Options Starts the Menu Options module that allows you to work with menus 
and menu options. 

Resource Bundles Starts the Resource Bundles module that allows you to work with 
resource bundles. 

Generate Services Starts the Service Code Generator module that allows you to generate 
services. 

Show Toolbar Allows you to show the toolbar. 

Assign Rule Pane Allows you to show the Assign Rule pane when working with 
business rules. 

Applet List Pane Allows you to show the Applet List pane when working with 
applet models. 

State Source Pane Allows you to show the State Source pane when working with applet 
models. The state source code for a selected applet is displayed in the 
State Source pane. 
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View Menu Options 

Menu Option Description 

Look and Feel Allows you to change the appearance of Application Builder. There 
are three options to choose from:  

 Metal 
 CDE/Motif 
 Windows 

Options menu 
The table lists and describes the Options menu options.  

 
Options menu options 

Options Menu Options 

Menu Option Description 

Properties Displays the properties file of the Application Builder item. 

Applets This menu option is only available when you are working in the 
Design Applet Model module. This menu options allows you to show 
the Applet Map and display Applet panes by screen name or 
classname. 

Help menu 
The Help menu allows you to information about Application Builder.  

 
Help menu 
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Toolbars 
The toolbar options and command buttons correspond with the menu options. 
Command buttons visible on the toolbar vary depending on the active module. For a list 
of available command buttons in each module, see the section in this guide specific to 
that module. 

Command buttons 
The table lists and describes the Application Builder command buttons. 

Command Buttons  

Menu Option Description Modules 

Business Rules 

Repository  

Opens the Business Rules Repository 
module. 

All modules 

Design Applet Model 

 

Opens the Design Applet Model 
module. 

All modules 

Menu Options 

 

Opens the Menu Options module. All modules 

Resource Bundles 

 

Opens the Resource Bundles module. All modules 

Service Code Generator 

 

Opens the Service Code Generator 
module. 

All modules. 

Launch Receipt & Report 

Builder  

Starts ISO - Object Library and Tools 
Receipt & Report Builder. 

All modules 

Launch Merchandise 
Administrator 

 

Starts Merchandise Administrator. All modules 

New 

 

Depending on the module you are 
working in, it creates a new business 
rule, applet model, resource bundle, or 
menu constant. 

Business Rules 
Repository, Design 
Applet Model, 
Menu Options, and 
Resource Bundles 
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Command Buttons  

Menu Option Description Modules 

Assign Rule to Method 

 

Assigns a business rule to a method. Business Rules 
Repository 

Unassign Rule to Method 

 

Unassigns a business rule to a method. Business Rules 
Repository 

Move Rule Priority Up 

 

Moves a business rule up in priority 
within a method. 

Business Rules 
Repository 

Move Rule Priority Down 

 

Moves a business rule down in priority 
within a method. 

Business Rules 
Repository 

Open Applet Model 

 

Opens a new applet model. Design Applet 
Model 

Save 

 

Saves the file you are working in. Design Applet 
Model, Menu 
Options, and 
Resource Bundles 

Print 

 

Prints the file you are working in. Design Applet 
Model 

New Menu Option 

 

Creates a new menu option. Menu Options 

Delete Menu Option 

 
or Menu 

Deletes a menu option or a menu 
depending on the selected tab. 

Menu Options 

New Menu  

 

Creates a new menu. Menu Options 
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Command Buttons  

Menu Option Description Modules 

Compile Menu Constant or 
Resource Bundle 

 

Compiles a menu constant or a resource 
bundle depending on the selected 
module. 

Menu Options and 
Resource Bundles 

Insert New Resource Key-
Value Pair 

 

Inserts a new key value pair in a 
resource bundle. 

Resource Bundles 

Delete Resource Key-Value 
Pair 

 

Deletes a key value pair from a 
resource bundle. 

Resource Bundles 

Find Resource Key-Value 
Pair 

 

Finds resources while working with 
resource bundles. 

Resource Bundles 

Tabs 
Tabs within Application Builder allow you to navigate through panes. The available tabs 
vary depending on the module and task being performed. Application Builder may not 
display some tabs when performing certain tasks.  

Panes 
Application Builder panels consist of panes. Information contained in panes can be 
dragged and dropped into other panes on the same panel.  
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Business rule repository  
Business rules are assigned to methods that modify business objects. Before performing 
an operation, a business object will check its assigned business rules to determine 
whether that operation should or should not be performed. Business rules that are 
assigned to common business objects are grouped into business rule packages. 
The Business Rules Repository module allows you to create business rules, provide 
business logic, and assign business rules to methods. However, you will have to supply 
the decision-making or business logic to execute the method. You can perform the 
following tasks using the Business Rules Repository module: 
 Open a business rule 
 Create a new business rule 
 Delete a business rule 
 Assign a rule to a class or method 
 Unassign a rule from a class or method 
 Move the priority of a rule up or down 

To access the Business Rules Repository module: 
 Select View>Business Rules. 

OR 
Click Business Rules Repository. The Business Rules Repository window is 
displayed. 
  

 
Business Rules Repository button 
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Business rules repository module workspace overview 
The Business Rules Repository workspace consists of four panes in a single panel. The 
menu options available from the File menu and Edit menu and some command buttons 
on the toolbar are specific to working with business rules. 

 
Business Rule Repository workspace 

Business rules repository module menu options 
The File and Edit menus and menu options in the Business Rules Repository module are 
specific to this module. The other menus remain the same regardless of the module you 
are working in. 

File menu options 
The following File menu options are available when working in the Business Rules 
Repository module: 
 New Rule*—Creates a new business rule. 
 Close—Closes active window. 
 Exit—Closes all open windows and exits Application Builder. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 
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Edit menu 
The following Edit menu options are available when working in the Business Rules 
Repository module: 

 
Edit menu when using the Business Rules Repository module 

 Assign Rule*—Assigns a business rule to a method. 
 Unassign Rule*—Unassigns a business rule from a method 
 Move Priority Up*—Moves a business rule up in priority within a method. 
 Move Priority Down*—Moves a business rule down in priority within a method. 
 Delete Rule—Deletes a business rule from a method. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 

Business rules repository module toolbar and command buttons 
The Business Rules Repository toolbar varies from all other toolbars. Command buttons 
that appear on the toolbar correspond with the File and Edit menu options. The 
following is a list of command buttons that appear on the Business Rules Repository 
toolbar: 

 
Business Rules Repository toolbar 

 New Rule*—Creates a new business rule. 
 Assign Rule to Method*—Assigns a business rule to a method. 
 Unassign Rule to Method*—Unassigns a business rule from a method. 
 Move Rule Priority Up*—Moves a business rule up in priority within a method.  
 Move Rule Priority Down*—Moves a business rule down in priority within a 

method. 
 Business Rules Repository—Opens the Business Rules Repository module. 
 Design Applet Model—Opens the Design Applet Model module. 
 Menu Options—Opens the Menu Options module. 
 Resource Bundles—Opens the Resource Bundles module. 
 Service Code Generator—Opens the Service Code Generator module. 
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 Launch Receipt Architect—Starts Receipt & Report Builder. 
 Launch Merchandise Manager—Starts Merchandise Administrator. 

Note: Command buttons marked with an asterisk (*) have 
corresponding menu options. 

Business rules repository module panes 
The Business Rules Repository workspace consists of four panes within the main panel. 
The following four panes are displayed in the Business Rules Repository workspace: 
 Assign Rules pane—displays the class, package, available methods, and assigned 

rules for the selected business object. 
 All Rules pane—displays all the available rules. 
 Object Hierarchy pane—displays the hierarchy and inheritance of the selected 

business object. 
 Source Code pane—displays a classname, description, and source code for the 

selected rule.  

Assign rules pane 
The Assign Rules pane displays the following information: 

 
Assign Rules pane 

 Class—displays the selected class. 
 Package—displays the package that the business rule is grouped in. 
 Method—displays the available methods that the rules can be assigned to. The 

methods displayed on the Methods list depend on the class selected from the Classes 
drop-down list.  

 Assigned Rules—displays the rules that are assigned to parent objects. Rules 
displayed in green are inherited rules. 
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All rules pane 
The All Rules pane displays all the available business rules. Rules displayed in red are 
loaded into the rules repository. 

 
All Rules pane 

Object hierarchy/inheritance pane 
The Object Hierarchy/Inheritance Pane displays the hierarchy and inheritance of the 
selected business object.  

 
Object Hierarchy/Inheritance Pane 
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Source code pane 
The Source Code pane displays the classname, classpath, description, and source code for 
the selected business rule. The Source Code pane allows you to edit, compile, and save a 
business rule by using the Save and Compile command buttons that appear on the pane.  

 
Source Code pane 

The Source Code pane contains the following tabs: 
 Source Code—displays the classname, description, and source code of the selected 

business rule. 
 Assignments—displays the classname and shows the business objects and methods 

the selected business rule is assigned to. 
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Create a new business rule 
There are two ways to create a new business rule:  
 Manually assign properties to the business rule 
 Using the Rules Wizard for step-by-step instructions on how to create a new 

business rule. 

Create a new business rule manually 
Note: You must select a method before you can create a new 
business rule. If you try to create a business rule without 
selecting a method, the Generate Rule dialog box is 
displayed. 

To create a new business rule manually: 
1. On the Assign Rules pane, select a method. 

a. Click Class. The Locate Business Object dialog box is displayed. 

 
Locate Business Object dialog box 
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b. In the Locate Business Object dialog box, drill down and select the a business 
object. 

c. After you have selected a business object, click OK. 
d. In the Methods drop-down list box, select the appropriate method.  

 
Methods  

Note: Methods with rules assigned to them are highlighted 
in blue. 

2. Select File>New Rule. 
OR 
Click New Rule. The Generate Rule dialog box is displayed. 

 
Generate Rule dialog box 

 
New Rule button 

Note: Click Tab or Enter to navigate through the Generate 
Rule dialog box. 
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3. In the Generate Rule dialog box, select a package from the Package drop-down 
menu. 

4. In the Class Name field, enter a class name. 
5. In the Rule Name field, enter a rule name. 
6. In the Description field, enter a description. 
7. To submit the new business rule information, click OK or Enter. The new business 

rule is displayed in the Assign Rules field, and the source code is displayed in the 
Source Code pane. 

Create a new business rule using rule wizard 
The Rule Wizard allows you to create a new business rule by following step-by-step 
instructions. The Rules Wizard simplifies the process of creating a new business rule. 
You will need to provide the following information to create a business rule using the 
Rules Wizard: 
 Rule name 
 Designate the rules package 
 Rule classname 
 Source path 
 Classpath 
 Rules package 
 Description of rule 
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To create a new business rule using the Rule Wizard. 
1. Select Wizard>Rule Wizard. The Rule Wizard is displayed. 

 
Rule Wizard 

2. To finish creating a new business rule, follow the instructions provided by the Rule 
Wizard. 
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Assign rules to classes and methods 
To assign a business rule to a class and method: 
1. On the Assign Rules pane, select the method you want to assign a rule to: 

a. Click Class. The Locate Business Object dialog box is displayed. 

 
Locate Business Object dialog box 
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22 Oracle Retail Point-of-Sale 

b. Drill down and select the desired business object. 

 
Business object 

c. Click OK. 
d. In the Methods drop-down list box, select the method you wish to assign a rule 

to.  

 
Method 

Note: Methods with rules assigned to them are displayed in 
blue. 



Business rule repository 

Business rule repository 23 

2. Select Edit>Assign Rule. 
OR 
Click Assign Rule. The Choose Rule to Assign dialog box is displayed. 

 
Choose Rule to Assign dialog box 

 
Assign Rule button 

3. On the Choose Rule to Assign dialog box, drill down and select the rule you wish to 
assign to the method. 

4. Click OK. The selected rule is displayed in the Assign Rule field, and it is also 
displayed in red on the Assigned Rule pane. 
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Unassigning rules from classes and methods 
To unassign a rule from a class and method: 
1. On the Assign Rules pane, select the method you want to unassign a rule from: 

a. Click Class. The Locate Business Object dialog box is displayed. 
b. Drill down and select the desired business object. 
c. Click OK. 
d. In the Methods drop-down list box, select the method you want to unassign a 

rule from.  

Note: Methods with rules assigned to them are displayed in 
blue. 

2. In the Assign Rule field, select the rule you wish to unassign. 
3. Select Edit>Unassign Rule. 

OR 
Click Unassign Rule. The rule is no longer assigned to the method, and the rule does 
not appear in the Assign Rule field. 

 
Unassigned Rule button 

Note: If you do not select a rule before you try to unassign a 
rule, the Unassign dialog box is displayed. Click OK to close 
the dialog box. 

Move the rule priority 
Multiple rules can be assigned to a business object. However, rules within a business 
object have a hierarchical order in which a rule is called upon before another rule. When 
a business object performs a function, it checks the business rules in their order of 
priority. 
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Move a rule priority up 
To move the priority of the rule up in order: 

Note: Before you can move a rule up in priority, you must 
open a business rule and select a method that has multiple 
rules assigned to that method. 

1. On the Assign Rules pane, select an assigned rule from the Assign Rule field. The 
selected rule is highlighted in blue. 

2. Select Edit>Move Rule Priority Up. 
OR 
Click Move Rule Priority Up. The rule is moved up in priority. 

 
Move Rule Priority Up button 

3. To continue to move the priority of the rule up in order, repeat Step 2. 
OR 
To move the priority of the rule up in order, repeat Steps 1-2. 

Move a rule priority down 
To move the priority of the rule down in order:   

Note: Before you can move a rule up in priority, you must 
open a business rule and select a method that has multiple 
rules assigned to that method. 

1. On the Assign Rules pane, select an assigned rule from the Assign Rule field. The 
selected rule is highlighted in blue. 

2. Select Edit>Move Rule Priority Down. 
OR 
Click Move Rule Priority Down. The rule is moved down in priority. 

 
Move Rule Priority Down button 

3. To continue to move the priority of the rule down in order, repeat Step 2. 
OR 
To move the priority of the rule down in order, repeat Steps 1-2. 
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Design applet model 

Design applet model  
The Design Applet Model module allows you to view the navigational flow of the Oracle 
Retail® Point-of-Service™ (RPOS) application. The navigation flow shows the hierarchy 
of parent and child applets. Using the flow-chart interface, you can map application 
processes visually and quickly to identify the appropriate window sequences.  
You can perform the following tasks using the Design Applet Model module: 
 View applet models 
 Create a new applet model 
 Move an applet to a new location within an applet model 
 Remove an applet from a location within an applet model 
 Delete an applet from an applet model 

To access the Design Applet Module module: 
 Select View>Applet Model. 

OR 
Click Design Applet Model. The Design Applet Module window is displayed. 

 
Design Applet Model button 
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Design applet model workspace overview 
The Design Applet Flow workspace allows you to map application processes visually. 
The workspace is made up of two panes within the panel. The menu options available 
from the File menu and some command buttons on the toolbar are specific to working 
with design applet models. The Options menu also contains a submenu specific to 
working with this module. 

 
Design Applet Flow workspace 
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Menu options 
The File menu and menu options in the Design Applet Model module are specific to this 
module. The Options menu also contains a submenu specific to working with this 
module. The remaining menus are the same regardless of the module you are working 
in. 

File menu options 
The following File menu options are available when working with applet flow: 
 New Applet Model*—Creates a new applet model. 
 Open Applet Model*—Opens an existing applet model. 
 Save Applet Model*—Saves the active applet model. 
 Print Applet Model*—Prints the active applet model. 
 Details—Provides details of the active applet model. 
 Close—Closes the active window. 
 Exit—Closes all the open windows and exits Application Builder. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 

Options menu 
The Options menu has a submenu that is only active if you are working in the Design 
Applet Model module. The following options are available from the Applets submenu: 

 
Applets submenu on the Options menu 

 Show Map—select to show a thumbnail map of the applet flow. 
 Only Model.ser Applets—select to view only applets assigned numbers. 
 Screen Name—select to view applets by screen name. 
 Class Name—select to view applets by classname. 

Toolbar and command buttons 
The Design Applet Model toolbar varies from all other toolbars. Command buttons that 
appear on the toolbar correspond with the File and Edit menu options. The following is a 
list of command buttons that appear on the Design Applet Model toolbar: 

 
Design Applet Model toolbar 
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 New Applet Model—Creates a new applet model. 
 Open Applet Model—Opens an existing applet model. 
 Save Applet Model—Saves the active applet model. 
 Print Applet Model—Prints the active applet model. 
 Business Rules Repository—Opens the Business Rules Repository module. 
 Design Applet Model—Opens the Design Applet Model. 
 Menu Options—Opens the Menu Options module. 
 Resource Bundles—Opens the Resource Bundles module. 
 Launch Receipt Architect—Starts RPOS Tools Receipt/Report Builder. 
 Launch Merchandise Manager—Starts the Merchandise Administrator application. 

Panes 
The Design Applet Model workspace consists of three panes within the main panel. The 
following panes are displayed in the Design Applet Model workspace: 
 Available Applets pane—Displays a list of the available applets used in RPOS. 
 Navigation pane—Displays the navigational flow and hierarchy of applets that make 

up the RPOS application 
 Applet pane (appears within the Navigation pane)—Represent RPOS applets. 

Available applets pane 
The Available Applets pane displays a list of the available applets used in RPOS. By 
default, the Available Applets pane is viewable each time you open the Design Applet 
Model module.  

 
Available Applets pane 
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You can view the flow of a particular applet by selecting that applet from the Available 
Applets pane. The applet will then appear in the Navigation pane. If the applet is not 
being used in the applet model, then the viewable applets in the Navigation pane will not 
change. 

Note: You must open an applet model to view the applets. 

Navigation pane 
The Navigation pane shows the navigational flow and hierarchy of applets that make up 
the RPOS application. Within the Navigation pane are Applet panes that represent the 
available applets. 

 
Navigation pane 
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Applet panes 
Applet panes represent RPOS applets, and they are found within the Navigation pane. 
Applet panes display information and options regarding the selected applet. 
The Applet pane of the applet model’s root applet is highlighted in blue. The root applet 
is the parent applet for all other applets within the model.  

 
Root Applet pane 

Back panes represent child applets, and they are highlighted in red. You can navigate to 
back panes by selecting a previous option from the parent applet. For example, if you 
select the Previous option from the Point of Sale Menu applet, the system returns you to 
the Operator Login applet.  

 
Back Applet pane 

Note: To prevent loops in the application, you cannot assign 
a child applet to back applets. 

Flow Arrows and Child Applet Index Numbers 
Flow arrows stretch between panes. The number centered on the arrow represents the 
child applet index number. The child applet index number is an assigned value to a child 
applet for navigational purposes. If the return of a method equals a particular child 
applet index number, the application will go to that child applet. 
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Open an applet model 
An applet model must be open in order to view the available applets. To open an applet 
model: 
1. Select File>Open Applet Model. 

OR 
Click Open Applet Model. The Open dialog box is displayed. 

 
Open dialog box 

 
Open Applet Model button 

2. Select the appropriate model file and click Open. The selected applet model is 
displayed in the Navigation pane. 

Note: Applet models are saved as XML files. Existing applet 
models are found in the \files\prod\model directory. 

Note: It may take Application Builder a few seconds to load 
and display the applet model. 
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View applet panes 
By default, the Navigation pane displays the root applet model and the child applets 
closest to it when you first open the applet model. The following are ways to view the 
different Applet panes: 
 Select an applet from the Available Applets pane. 
 Select an applet from the Navigation pane. 
 Select an applet from the Applet Map. 

To view an Applet pane. 
 On the Available Applets pane, select the applet you wish to view. 

OR 
Using the scroll bars on the Navigation pane, click on the scroll arrows or pull the 
scroll box until the Applet pane of the applet you wish to view is displayed.  

To view an Applet pane using the Applet Map feature: 
1. Select Options>Applets>Show Map. The Applet Map is displayed. 

 
Applet Map  

2. On the Applet Map, select the Applet pane you wish to view. The corresponding 
applet is highlighted in the Available Applets pane, and the Navigation pane 
displays the selected Applet pane. 
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Applet model viewing options 
Within the Navigation pane, each Applet pane has several viewing options that allows 
you to view the different navigation and applet information. The following is a list of 
viewing options within the Navigation and Applet panes: 
 View the Applet Map 
 Change the model view of an applet pane 
 View applet by screen name 
 View applets by class name 

View the applet map 
The Applet Map is a graphical view of the hierarchy of the applet model. The Applet 
Map displays the applet model in a tree structure that distinguishes the root, parent, and 
child applets. The Applet Map can be viewed in conjunction with the Navigation pane so 
you can navigate to each applet within the applet model. The Applet Map makes 
navigating through a applet model easy by displaying the root applet in blue and back 
applets in red. Also, if you leave the cursor over an applet, the applet name is displayed.  

 
Applet Map 

Note: If you open the Applet Map without opening an 
applet model, the Applet Map displays an empty Applet 
Map. 

To view the Applet Map: 
 Select Options>Applets>Show Map. The Applet Map is displayed. 
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View applet name using the applet map 
To view an applet name using the Applet Map: 
1. Select Options>Applets>Show Map. The Applet Map is displayed. 
2. Place the cursor over an applet. The applet name is displayed. 

 
Applet name is displayed 

Change the model view of an applet pane 
You can change the model view displayed on each Applet pane. The following is a list of 
model views displayed on an Applet pane: 
 Buttons—lists the buttons assigned as options to the selected applet. 
 Menus—lists the menus assigned to the selected applet. 
 State objects—lists the state objects assigned to the selected applet. 

To change the model view within an applet: 
1. Select the applet you wish to view. The selected pane title is displayed in bolded text. 
2. Right-click on the applet. A pop-up menu is displayed. 

 
Applet pop-up menu 
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3. On the pop-up menu, select the List View option. The system displays a drop-down 
list of options. 

 
Drop-down list 

4. Select the appropriate option: 
 To view the buttons assigned as options to the selected applet, select the Buttons 

radio button. 
 To view the menus assigned as options to the selected applet, select Menus 

radio button. 
 To view the state objects assigned to the selected applet, select State Objects 

radio button. 

View applet by screen name 
Each Applet pane has a pane title that corresponds with either the applet’s screen name 
or class name. 
To view an applet by screen name: 
1. Select the applet you wish to view. The selected pane title is displayed in bolded text. 
2. Select Options>Applet>Screen Name. The screen name of the selected applet is 

displayed. 

Note: When you first open an applet model, the screen 
names of the applets are displayed by default. 

View applet by classname 
Each Applet pane has a pane title that corresponds with either the applet’s screen name 
or classname. 
To view an applet by classname: 
1. Select the applet you wish to view. The selected pane title is displayed in bolded text. 
2. Select Options>Applet>Class Name. The classname of the selected applet is 

displayed. 
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Add a new GUI screen 
Using the Design Applet Model module, you can add a new GUI screen to the RPOS 
application. Before you can add a new GUI screen, you must select the applet model to 
which you want to add the new screen to. 
To add a new GUI screen to the RPOS application: 
1. Open an applet model. 
2. Add a child applet. 
3. Assign the child applet an applet index number. 
4. Compile and save the source code. 

Add a child applet 
Before you add a child applet, you must first select the parent applet or the applet that 
will allow you to navigate to the child applet. The child applet represents the new GUI 
screen. Each applet has menus, buttons, and state objects assigned to them that are all 
configurable. 
To add a child applet: 
1. Select the parent applet you wish to add a child applet to. The selected pane title is 

displayed in bolded text. 
2. Right click on the selected applet. A pop-up menu is displayed. 
3. Select Add Child Applet. The Add Child Applet dialog box is displayed. 

 
Add Child Applet dialog box 
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4. Drill down and select the appropriate applet. 

 
Drill down 

5. Click OK. The selected applet is displayed. 

 
Selected applet 
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Assign an applet index number 
After you add an child applet to a parent applet, you must assign the child applet an 
applet index number. Each menu option has a method. If the method-return value is 
equal to the applet index number, that child applet is displayed.  
If you add a child applet and do not assign it a applet index number, then that parent 
applet cannot navigate to the child applet. 
To assign an applet index number to an applet: 
1. On the flow arrow connecting the parent applet and the child applet, right click. A 

pop-up menu is displayed. 
2. On the pop-up menu, click Assign. The Assign Connection dialog box is displayed. 

 
Assign Connection dialog box 

3. On the Assign Connection dialog box, assign the applet an applet index number.  
 To assign a new applet index number, click New. The applet will be assigned an 

index number that is next number in sequence.  
 If you want to assign an existing applet index number to the new applet, select 

the index number and click Replace. The applet index number is displayed in the 
flow arrow between the parent and child applets. 

4. Right click on the child applet. A pop-menu is displayed. 
5. On the pop-up menu, click Generate State. The State Source pane is displayed. 
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State Source pane 

6. On the State Source pane, assign a method return value that equals the applet index 
number. You will need to code the method return value. 

7. Click Generate State to update the source code. 

Unassign an applet index number 
The Design Applet Model module allows you to unassign an applet index number from 
an applet. Unassigning the index number means that you can no longer navigate from 
the parent applet to the child applet. Unassigning an index number does not remove the 
applet from the applet model. 
To unassign an applet index number: 
1. Right click on the flow arrow connecting the parent applet and the child applet. A 

pop-up menu is displayed. 
2. On the pop-up menu, click Unassign. The applet index number is no longer 

displayed. 

Compile and save the source code 
After you have made all modifications to the source code, you are ready to compile and 
save the source code to include the child applet and GUI screen.  
To compile and save the source code: 
 On the Source Code pane, click Compile. The source code is compiled and 

automatically saved. You can now view your new GUI screen using the RPOS 
application.  

 
Compile button 
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Move an applet to a new location 
Using the Applet Wizard, you can move an applet to a new location within the applet 
model. The Applet Wizard will delete the existing applet and then add the applet to the 
new location within the applet model.  
To move an applet to a new location: 
1. Select Wizards>Applet Wizard. The Applet Wizard wizard is displayed. 
2. Select Move Applet to new location. 

 
Move Applet to new location 

3. Click Next. 
4. To complete moving the applet to a new location, follow the instructions provided by 

the Applet Wizard. 
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Remove an applet from its location 
Using the Applet Wizard, you can remove the applet index number from a parent applet. 
The applet and source code will persist, however you cannot navigate that a that applet. 
To remove an applet from its current location: 
1. Select Wizards>Applet Wizard. The Applet Wizard is displayed. 
2. Select Remove Applet from Location. 

 
Remove Applet from Location 

3. Click Next. 
4. To remove the applet from its location, follow the instructions provided by the 

Applet Wizard. 
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Create a new applet 
Using the Applet Wizard, you can add a new applet. The Applet Wizard streamlines this 
process by making the assignment between parent and child applets, adding the 
necessary code to the state of the applet, and allowing you to create and assign buttons to 
the applet. 
To create a new applet model: 
1. Select Wizards>Applet Wizard. The Applet Wizard is displayed. 
2. Select Add a new Applet. 

 
Add a new Applet 

3. Click Next. 
4. To add a new applet, follow the instructions provided by the Applet Wizard. 
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Delete an applet from an applet model 
Unlike removing an applet from its current location, deleting an applet removes the 
applet and the source code from the applet model. 
To delete an applet from the applet model: 
1. Select the applet you wish to delete. The selected pane title is displayed in bolded 

text. 
2. Right-click on the applet. A pop-up menu is displayed. 
3. On the pop-up menu, select Delete Applet. The system removes the applet and 

source code from the model. 

 
Delete Applet 

Viewing an applet In RPOS 
After making modifications or creating a new applet, the Design Applet Model module 
allows you to view an applet as it would appear in the RPOS application. 
To view an applet as it will appear in RPOS: 
1. Select the applet you wish to view. The selected pane title is displayed in bolded text. 
2. Right-click on the applet pane. A pop-up menu is displayed. 
3. On the pop-up menu, select View Applet. The selected applet is displayed in a self-

titled pop-up window as it would appear in the RPOS application. 

 
View Applet 
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Viewing applet model information 
To view applet model information: 
 Select File>Details. The system displays the Current Information dialog box. 

Printing applet models 
When printing an applet model, the first page printed provides instructions on where to 
place the pages in relationship to the model piece. Subsequent pages are pieces of the 
overall model. 
To print an applet model: 
 Select File>Print Applet Model. 

OR 
From the toolbar, click Print Applet Model shortcut icon. 
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Menu options 

Menu options  
The Menu Options module allows you to customize and create new RPOS application 
menus. You can perform the following tasks using the Menu Options menu: 
 Customize an existing menu 
 Create a new menu 
 Create a new menu option 
 Assign menu options to a menu 
 Assign a business rule to menu options 
 Assign a security role to menu options 
 Delete a menu option 
 Delete a menu 

To access the Menu Options menu: 
 Select View>Menu Options. 

OR 
Click Menu Options. The Menu Options window is displayed. 

 
Menu Options button 

Menu options workspace overview 
The Menu Options workspace allows you to customize RPOS menus. The workspace is 
made up of two panes and three tabs. Each tab changes the appearance of the two panes, 
and they also change the menu options available on the File menu and Edit menu and the 
command buttons on the toolbar.  
The following are the three tabs on the Menu Options workspace: 
 Menu Options—Allows you to customize, modify, and create new menu options 

or buttons. 
 Menus—Allows you to customize, modify, and create new menus. 
 Generate Menu Helper—Allows you to view and generate source code, and this tab 

provides you with a list of all the menus as constants. For more information, see 
Generate Menu Helper. 

Note: The Menu Options tab is the default tab. 
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Menu options tab 
The Menu Options tab allows you to customize, modify, and create new menu options or 
buttons. The Menu Options tab also allows you to assign business rules to a menu 
option.  

 
Menu Options tab 

Menu options tab menus 
The menu options for the File menu and Edit menu are specific to the Menu Options tab.  
The following File menu options are available when the Menu Options tab is selected: 
 New Menu Option*—Creates a new menu option or button. 
 Save Menu Option*—Saves the active menu button or option. 
 Close—Closes the active window. 
 Exit—Closes all open windows and exits Application Builder. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 

The following Edit menu options are available when the Menu Options tab is selected: 
 Delete Menu Options*—Deletes the selected menu option. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 
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Menu options tab toolbar and command buttons 
The Menu Option toolbars vary depending on the selected tab. Command buttons that 
appear on the toolbar correspond with the File and Edit menu options. The following is a 
list of command buttons that appear on the Menu Options toolbar when the Menu 
Options tab is selected: 

 
Toolbar and command buttons when the Menu Options tab is selected 

 New Menu Option*—Creates a new menu option. 
 Save Menu Option*—Saves the active menu option or button. 
 Delete Menu Option*—Deletes the selected menu option. 
 Business Rules Repository—Opens the Business Rules Repository module. 
 Design Applet Model—Opens the Design Applet Model. 
 Menu Options—Opens the Menu Options module. 
 Resource Bundles—Opens the Resource Bundles module. 
 Launch Receipt Architect—Starts RPOS Tools Receipt/Report Builder. 
 Launch Merchandise Manager—Starts the Merchandise Administrator application. 

Note: Command buttons marked with an asterisk (*) have 
corresponding menu options.  

Panes 
With the Menu Options tab selected, the following panes are available within the Menu 
Options workspace: 
 Available Menu Options pane—Displays a list of menu options that can be assigned 

to a menu. 
 Assign Business Logic pane—Displays the assigned business logic to the selected 

menu option or button. 
 Define Menu Option pane—Displays information regarding the selected menu 

option in the Available Menu Options pane. 
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Menus tab 
The Menus tab allows you to customize, modify, and create new menus. Using the 
Menus tab, you can add or remove menu options from an existing menu.  

 
Menus tab 

Menus tab menu options 
The menu options for the File menu and Edit menu are specific to the Menu Options tab.  
The following File menu options are available when the Menu Options tab is selected: 
 New Menu*—Allows you to create a new menu. 
 Save Menu*—Allows you to save a menu. 
 Close—Closes the active window. 
 Exit—Closes all open windows and exits Application Builder. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 

The following Edit menu options are available when the Menu Options tab is selected: 
 Delete Menu*—Allows you to delete a menu. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 
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Menus tab toolbar and command buttons 
The Menu Option toolbars vary depending on the selected tab. Command buttons that 
appear on the toolbar correspond with the File and Edit menu options. The following is a 
list of command buttons that appear on the Menu Options toolbar when the Menus tab is 
selected: 

 
Toolbar and command buttons when the Menus tab is selected 

 New Menu*—Allows you to create a new menu. 
 Save Menu*—Allows you to save a menu. 
 Delete Menu*—Allows you to delete a menu. 
 Business Rules Repository—Opens the Business Rules Repository module. 
 Design Applet Model—Opens the Design Applet Model module. 
 Menu Options—Opens the Menu Options module. 
 Resource Bundles—Opens the Resource Bundles module. 
 Launch Receipt Architect—Starts RPOS Tools Receipt/Report Builder. 
 Launch Merchandise Manager—Starts the Merchandise Administrator application. 

Note: Command buttons marked with an asterisk (*) have 
corresponding menu options. 

Menus tab panes 
When the Menu tab is selected, the following panes are available on the Menu Options 
workspace: 
 Available Menus pane—Displays a list of existing menus. 
 Available Menu Options pane—Displays a list of menu options that can be assigned 

to a menu 
 Assigned Options pane—Displays a list of the menu options assigned to the selected 

menu. 

Menu options 
The File and Edit menu and menu options in the Menu Options module vary depending 
on the tab that you select. For more information, see the section on each of the tabs. 

Toolbar and command buttons 
The Menu Option module toolbar not only differs from other module’s toolbars, but each 
toolbar within this module is tab-specific. For more information, see the section on each 
of the tabs. 



Menu options workspace overview 
 

52 Oracle Retail Point-of-Sale 

Panes 
The following panes display when working with menus and menu options: 
 Available Menu Options pane—Displays a list of menu options that can be assigned 

to a menu 
 Assign Business Logic pane—Displays the assigned business logic to the selected 

menu option or button. 
 Define Menu Option pane—Displays information regarding the selected menu 

option in the Available Menu Options pane. 
 Available Menus pane—Displays a list of existing menus. 
 Assigned Options pane—Displays a list of the menu options assigned to the selected 

menu. 
 Generate Menu Helper pane—Displays the source code and provides a list of all the 

menus as constants 

Available menu options pane 
The Available Menu Options pane is displayed when either the Menu Options or Menus 
tab is selected. This pane displays a list of menu options that can be assigned to a menu. 
The Available Menu Options pane displays the label of the menu option in the left-hand 
column and the command name of the menu option in the right-hand column.  

 
Available Menu Options pane 
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Assign business logic pane 
The Assign Business Logic pane is displayed when the Menu Options tab is selected. This 
pane displays the following columns: 

 
Assign Business Logic pane 

 Assigned Security Roles column—Displays the assigned security roles for the 
selected menu option. 

 Assigned Business Rules column—Displays the assigned business roles for the 
selected menu option. 

The Assign Business Logic also allows you to add and remove security roles and 
business rules to a menu option.  
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Define menu option pane 
The Define Menu Option pane is displayed when the Menu Options tab is selected. This 
pane displays information regarding the selected menu option on the Available Menu 
Option pane. The Define Menu Option displays the following information: 

 
Define Menu Option pane 

 Command—displays the command name of the menu option selected in the 
Available Menu Options pane. You cannot change a command. You must delete the 
old command and create a new one. 

 Label—displays the label name of the menu option selected in the Available Menu 
Options pane. The label name is the text that appears on the button. 

 View—select to view the label name and button as it would appear in RPOS. The 
label name and button are displayed in the default theme. Themes can be changed in 
the configuration files. 

 Font—select to change the typeface, color, size, and appearance of the label name as 
it appears on the button. Changing the appearance of the text does not persist. This 
option allows you to view the appearance of the text based on your changes. You will 
have the make modifications to the appropriate configuration file for the changes to 
persist. 

 Available Off-Line—allows you to make a menu option available when the 
application is in off-line mode. Menu options that are mission critical should be made 
available during offline activities. It is recommended that menu options that require 
the backend should not be made available in off-line mode. 

 Always update this resource bundle—allows you to update the resource bundle 
with modifications and new menu options. 
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Available menus pane 
The Available Menus pane is displayed when the Menus tab is selected. The pane 
displays the available menus in the RPOS application. Selecting a menu in the Available 
Menus pane displays the menu options that are assigned to the selected menu in the 
Assigned Options pane.  

 
Available Menus pane 
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Assigned options pane 
The Assigned Options pane is displayed when the Menus tab is selected. This pane 
displays a list of menu options assigned to the selected menu.  

 
Assigned Options pane 

Generate menu helper pane 
The Generate Menu Helper pane is displayed when the Generate Menu Helper tab is 
selected. This pane displays the source code and provides a list of all the menus as 
constants. 

 
Generate Menu Helper pane 
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Create a new menu option 
To create a new menu option: 
1. Select File>New Menu Option. 

OR 
Click New Menu Option. The fields in the Define Menu Options pane are active. 

2. In the Command field, type the command name of the new menu option. 
3. In the Label field, type the label of the new menu option. 
4. If you want the menu option to be available in off-line mode, click Available Off-

line. 
5. If you want to update the resource bundle after you save or make modifications to 

the menu option, click Always Update this Resource Bundle. 
6. Select File>Save Menu Option. 

OR 
Click Save Menu Option. 

Assign business logic 
The Menu Options module allows you to add business logic to new and existing menu 
options. The following is a list of business logic that can be added to a menu option: 
 Business rules 
 Security rules 

Assign business rules 
To assign a business rule to a menu option: 
1. Select a menu option from the Available Menu Option pane. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. In the Assign Business Logic pane, click the Add Rule button. The Select Rule of 
Menu Option dialog box is displayed. 

3. On the Select Rule of Menu Option dialog box, drill down and select the desired 
business rule. 

4. Click OK. The selected business rule appears in the Assigned Business Rules column. 
5. Repeat steps 2-4 to assign more business rules to the menu option. 

 

 



Delete menu option 
 

58 Oracle Retail Point-of-Sale 

Assign security roles 
The Menu Options model allows you to assign security roles to menu options. Security 
roles allow you to customize the RPOS application based on your users. A user must 
meet the defined security role to be privy to certain menus and menu options. 
Security roles are configurable. The RPOS application has the following predefined 
security roles: 
 Manager 
 Assistant Manager 
 Sales Associate 
 Cashier 

To assign a security role to a menu option: 
1. Select a menu option from the Available Menu Option pane. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. In the Assign Business Logic pane, click Add Role. The Choose Security Role dialog 
box is displayed with a list of available security roles. 

3. On the Choose Security Role dialog box, select a security role. 
4. Click OK. The selected security role appears in the Assigned Security Roles column. 
5. Repeat steps 2-4 to assign more security roles to the menu option. 

Delete menu option 
The Menu Options module allows you to delete menu options. Deleting a menu option 
removes the menu option entirely from the system. It is recommended that you unassign 
a menu option from a menu instead of deleting the option. By unassinging the menu 
option, you have not removed it from the system, and you can assign the menu option to 
a menu at a later time. 
To delete a menu option: 
1. Select a menu option from the Available Menu Option pane. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. Select Edit>Delete Menu Option. 
OR 
Click Delete Menu Option. The Delete Menu Option dialog box is displayed. 

3. On the Delete Menu Option dialog box, click OK. The menu option is removed from 
the system and no longer displayed in any of the panes. 
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Remove business logic 
The Menu Options module allows you to remove business logic to new and existing 
menu options. The following is a list of business logic that can be removed to a menu 
option: 
 Business rules 
 Security rules 

Remove business rules 
To remove a business rule to a menu option: 
1. Select a menu option from the Available Menu Option pane. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. In the Assign Business Logic pane, select a business rule from the Assigned Business 
Rules column. 

3. Click Remove Rule. 
4. The selected business rule is removed from the Assigned Business Rules column. 
5. Repeat steps 2-4 to assign more business rules to the menu option. 

Remove security roles 
To remove a security role to a menu option: 
1. Select a menu option from the Available Menu Option pane. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. In the Assign Business Logic pane, select a security role from the Assigned Security 
Roles column. 

3. Click Remove Role. 
4. The selected security role is removed from the Assigned Security Roles column. 
5. Repeat steps 2-4 to assign more security roles to the menu option. 

Define menu options 
The Menu Options module allows you to define properties of new and existing menu 
options. The following is a list of menu option properties that you can change: 
 Label name 
 Label appearance 
 Off-line availability 
 Automatically update resource bundles 
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Modify label name 
The label name is the text that appears on a menu option in RPOS. To modify the label 
name: 
1. On the Available Menu Options pane, select a menu option. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. In the Label field, select the existing label name. 
3. Type the new label name and press Enter. 

Modify label appearance 
The label name is the text that appears on the menu option in RPOS. Using the Menu 
Options module, you can change the typeface, color, type size, and style of the label 
name as it would appear on the menu button in RPOS. Changing the appearance of the 
label does not persist. The Menu Options module allows you to view the appearance of 
the text based on your changes. To actually change the appearance of a label in RPOS, 
you will need to make modifications to the appropriate configuration file. 
To modify the appearance of a label: 
1. On the Available Menu Options pane, select a menu option. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. Click Font. The Select Font dialog box is displayed. 

Note: The Select Font dialog box displays changes made to 
the appearance of the label as you make the changes. 

3. Select the desired type face. Drag the menu bar down to view more type face options. 
4. Select the desired type size. 
5. Select the desired style of type. 
6. Select the desired color of the type. 
7. After making all the modifications to the appearance of the label, click OK. 

View a menu option 
The View button allows you to view a menu option as it would appear in RPOS.  
To view a menu option: 
1. On the Available Menu Options pane, select a menu option. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. Click View. The View Button dialog box is displayed. The menu option is displayed 
as a RPOS menu button. 

3. Select Menu>Save Menu Option. 
OR 
Click Save Menu Option. 
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Modify off-line availability 
The Menu Options module allows you to designate which menu options will be available 
when the RPOS system is in off-line mode. Menu options that are mission critical should 
be made available during off-line activities.  

Note: It is recommended that menu options that require the 
backend should not be made available when the RPOS 
system is in off-line mode. 

To modify the off-line availability of a menu option: 
1. On the Available Menu Options pane, select a menu option. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. In the Define Menu Option pane, click Available Off-line. 
3. Select Menu>Save Menu Option. 

OR 
Click Save Menu Option. 

Update resource bundles 
To automatically update the resource bundles: 
1. On the Available Menu Options pane, select a menu option. The menu option’s 

information is displayed in the Define Menu Option and Assign Business Logic 
panes. 

2. In the Define Menu Option pane, click Always update this resource bundle. 
3. Select Menu>Save Menu Option. 

OR 
Click Save Menu Option. 

Create a new menu 
To create a new menu: 
1. Click Menus. 
2. Select File>New Menu. 

OR 
Click New Menu. 

3. In the Name field, type the name of the new menu. 
4. To save the menu, select File>Save Menu. 

OR 
Click Save Menu. 
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Assign menu options to a menu 
To assign a menu option to a menu: 
1. Click the Menus tab. 
2. From the Available Menus pane, select the appropriate menu. 
3. From the Available Menu Options pane, select the appropriate menu option. 
4. Select the Add Menu Option button. The selected menu option is displayed in the 

Assigned Options pane. 
5. Click Move Up and Move Down to arrange the way the menu options will display 

on the RPOS applet. 

Arrange menu options 
The Menu Options module allows you arrange menu options after you have assigned 
them to a menu. Arranging menu options affects the order in which they will appear 
when you run RPOS. The Assigned Options pane displays the menu options in the order 
in which they will appear when you run RPOS. 
To arrange menu options on a menu: 
1. Select the Menus tab. 
2. From the Available Menus pane, select the appropriate menu. The menu options 

assigned to the selected menu are displayed in the Assigned Options pane. 
3. From the Assigned Options pane, select the menu option you wish to move up or 

down. 
4. To move the menu option up in order of appearance, click Move Up until the menu 

option is in the order you desire. 
OR 
To move the menu option down in the order of appearance, click Move Down until 
the menu option is in the order you desire. 

5. Repeat steps 3-4 to arrange other menu options on the same menu. 

Remove a menu option from a menu 
To remove a menu option to a menu: 
1. Click the Menus tab. 
2. From the Available Menus pane, select the appropriate menu. 
3. From the Available Menu Options pane, select the appropriate menu option. 
4. Select Remove Menu Option. The selected menu option is removed from the 

Assigned Options pane. 
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Delete a menu 
The Menu Options module allows you to delete a menu. Deleting a menu removes the 
menu entirely from the system. Deleting a menu is not recommended. 
To delete a menu: 
1. Click the Menus tab. 
2. From the Available Menus pane, select the appropriate menu. 
3. Select Edit>Delete Menu. 

OR 
Click Delete Menu. The Delete Menu Option dialog box is displayed. 

4. On the Delete Menu Option dialog box, click OK. 

Generate menu helper 
The Generate Menu Helper tab allows you to view and generate source code, and it 
provides you with a list of all the menus as constants. The Generate Menu Helper tab is 
beneficial for modifying and creating menus. The figure below shows the Menu Options 
workspace when the Generate Menu Helper tab is selected. 

 
Generate Menu Helper tab 
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Generate menu helper tab menu options 
The menu options for the File menu and Edit menu are specific to the Generate Menu 
Helper tab. The following File menu options are available when the Generate Menu 
Helper tab is selected: 
 New Menu Const*—Allows you to create a new menu constant. 
 Compile Menu Const*—Allows you to compile the code for a menu constant. 
 Save Menu Const*—Allows you to save a menu constant. 
 Close—Closes the active window. 
 Exit—Closes all open windows and exits Application Builder. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 

The Edit menu is not active when the Generate Menu Helper tab is selected. 

Generate menu helper tab toolbar and command buttons 
The Menu Option toolbars vary depending on the selected tab. Command buttons that 
appear on the toolbar correspond with the File menu option. The following is a list of 
command buttons that appear on the Menu Options toolbar when the Generate Menu 
Helper tab is selected: 

 
Toolbar and command buttons when the Menus tab is selected 

 New Menu Const*—Allows you to create a new menu constant. 
 Compile Menu Const*—Allows you to compile the code for a menu constant. 
 Save Menu Const*—Allows you to save a menu constant. 
 Business Rules Repository—Opens the Business Rules Repository module. 
 Design Applet Model—Opens the Design Applet Model module. 
 Menu Options—Opens the Menu Options module. 
 Resource Bundles—Opens the Resource Bundles module. 
 Launch Receipt Architect—Starts RPOS Tools Receipt/Report Builder. 
 Launch Merchandise Manager—Starts the Merchandise Administrator application. 

Note: Command buttons marked with an asterisk (*) have 
corresponding menu options. 

Generate menu helper tab pane 
When the Generate Menu Helper tab is selected, the only pane available is the Generate 
Menu Helper pane.  
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5 
Resource bundles 

Resource bundles  
The Resource Bundles module allows you to bundle information for internationalization 
resourcing. Resource bundles are specific to language localization. The Oracle Retail® 
Point-of-Service™ (RPOS) application can be customized for any language by modifying 
the key-value pairs in the resource bundles. The RPOS graphical-user interface (GUI) 
uses keys that have a value that displays information on the RPOS windows.  

Note: A list of available resource bundles is located in the 
client_master.cfg file. The source path for resource bundles 
is located at com/rpos/util. RPOS automatically loads all 
resource bundles. 

You can perform the following tasks using the Resource Bundles module: 
 Create a new resource bundle 
 Modify an existing resource bundle 
 Add a new key-value pair 
 Modify an existing key-value pair 
 Delete a key-value pair 
 Update a resource bundle 
 Search within a resource bundle 
 Delete a resource bundle 

To access the Resource Bundle module: 
 Select View>Resource Bundles. 

OR 
Click Resource Bundles. The Resource Bundles window is displayed. 

 
Resource Bundles button 
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Resource bundles workspace overview 
The Resource Bundles workspace consists of a single pane and multiple tabs that allow 
you to view and work with resource bundles. The menu options available on the File 
menu and Edit menu and some command buttons on the toolbar are specific to working 
with resource bundles.  

 
Resource Bundles workspace 

Menu options 
The menu options on the File menu and Edit menu in the Resource Bundles module are 
specific to this module. The remaining menus and menu options are the same regardless 
of the module. 

File menu options 
The following File menu options are available when working in the Resource Bundles 
module: 
New Bundle*—Creates a new resource bundle. 
Save Bundle*—Saves the active resource bundle. 
Compile Bundle*—Complies a resource bundle. 
Delete Bundle*—Deletes a resource bundle. 
Close—Closes active window. 
Exit—Closes all open windows and exits Application Builder. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 
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Edit menu options 
The following Edit menu options are available when working in the Resource Bundles 
module: 
Insert Key*—Inserts a key-value pair to a resource bundle. 
Delete Key*—Deletes a key-value pair from a resource bundle. 
Update—Updates the Resource Bundles window. 
Find—Allows you to search and find a resource. 

Note: Menu options marked with an asterisk (*) have 
corresponding command buttons available on the toolbar. 

Toolbar and command buttons 
The Resource Bundles toolbar varies from all other toolbars. Command buttons that 
appear on the toolbar correspond with the File menu and Edit menu options. The 
following is a list of command buttons that appear on the Resource Bundles toolbar: 

 
Resource Bundles toolbar 

New Resource Bundle*—Creates a new resource bundle. 
Insert New Key-Value Pair*—Inserts a key-value pair to a resource bundle. 
Delete Key-Value Pair*—Deletes a key-value pair from a resource bundle. 
Save Resource Bundle*—Saves the active resource bundle. 
Compile Resource Bundle—Compiles a resource bundle. 
Find Resource Bundle*—Allows you to search and find a resource. 
Business Rules Repository—Opens the Business Rules Repository module. 
Design Applet Model—Opens the Design Applet Model module. 
Menu Options—Opens the Menu Options module. 
Resource Bundles—Opens the Resource Bundles module. 
Launch Receipt Architect—Starts RPOS Tools Receipt/Report Builder. 
Launch Merchandise Manager—Starts the Merchandise Administrator application. 



Create a new resource bundle 

68 Oracle Retail Point-of-Sale 

Panes 
The Resource Bundles workspace is made up of a single pane with multiple tabs that 
changes the information displayed on the pane. The Key-Value Pairs pane allows you to 
view and work with RPOS resource bundles.  
The Key-Value Pairs pane has tabs for each resource bundle in the system. Selecting a tab 
allows you to view the selected resource bundle. When a new resource bundle is created, 
a tab is added.  

 
Key Value Pairs pane 

Create a new resource bundle 
Creating a new resource bundle allows you to internationalize RPOS as needed. You can 
create a new resource bundle based on an existing resource bundle. The Resource Bundle 
module will append the values with the country code to help you manage the new 
resource bundle. 
To create a new resource bundle: 
1. Click the tab of the resource bundle you would like to base the new resource bundle 

on. The Resource Bundles module will generate a new resource bundle based on the 
key-value pairs of the selected resource bundle. 

2. Select File>New Bundle. 
OR 
Click New Resource Bundle. The Create New Resource Class dialog box is 
displayed. The classpath of the selected resource bundle is displayed in the Copy 
Keys From field. 
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3. In the Enter 2 Character Language Code field, type the language code for the new 
resource bundle. 

4. In the Enter 2 Character Country Code field, type the country code for the new 
resource bundle. 

5. If you want to prepend the values of the keys for the new resource bundle with the 
country code, click Prepend Locale ID to Value. 

6. Click OK. The Resource Bundles module creates a tab for the new resource bundle. 

Work with key-value pair 
Create a new key-value pair 

You can add a new key-value pair to a new or existing resource bundle. Creating a new 
resource bundle only adds the new resource bundle to only the selected resource bundle 
and not all resource bundles. After you create a new key-value pair, you can use the 
Update feature to update all resource bundles with the new key-value pair.  
To create a new key-value pair: 
1. Click the tab of the resource bundle you wish to add a new key-value pair to. 
2. Select Edit>Insert Key. 

OR 
Click Insert New Key-Value Pair. The new key-value pair is added at the bottom of 
the Key-Value Pairs pane of the selected resource bundle. Scroll down to view the 
blank row. 

3. In the Key column, type the new key. 
4. In the Value column, type the new value. 
5. To save the new key-value pair, select File>Save Bundle. 

OR 
Click Save Resource Bundle. 

Modify a key-value pair 
To modify a key-value pair: 
1. Click the tab of the resource bundle you wish to modify a new key-value pair from. 
2. Select the key-value pair you wish to modify. The selected key-value pair is 

highlighted. 
3. Modify the key, value, or both. 
4. To modify more key-value pairs, repeat steps 2-3. 
5. To save changes to the modified key-value pairs, select File>Save Bundle. 

OR 
Click Save Resource Bundle. 
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Delete a key-value pair 
To delete a key-value pair: 
1. Click the tab of the resource bundle you wish to delete a new key-value pair from. 
2. Select the key-value pair you wish to delete. The selected key-value pair is 

highlighted. 
3. Select Edit>Delete Key. 

OR 
Click Delete Key-Value Pair. The Delete Key dialog box is displayed. 

4. On the Delete Key dialog box, click Yes. The key-value pair is deleted from the 
resource bundle. 

Rearrange the order of the key-value pairs 
By default, the key-value pairs are arranged in alphabetical order by keys. You can 
rearrange the order of the key-value pairs by either the keys or values. 
To rearrange the order of the key-value pairs: 
1. Click the tab of the resource bundle you wish to rearrange the order of the key-value 

pairs. 
2. If you want to rearrange the order of the keys, click the error beside Key in the Key 

column. 
OR 
If you want to rearrange the order of the values, click the error beside Value in the 
Value column. 

Update a resource bundle 
After you have made modifications to a resource bundle or the key-value pairs in the 
resource bundle, you will have to update the resource bundle. To update a resource 
bundle: 
1. Click on the tab of the resource bundle you wish to update. 
2. Select Edit>Update. The Select Resource Bundle File dialog box is displayed. 
3. Select the resource bundle file that contains the keys you wish to update the selected 

resource bundle with. 
4. If you want to prepend the updated resource bundle with the country code, select the 

Prepend Locale ID to Value button. 
5. Click OK. 
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Search in a resource bundle 
To search for a key or value in a research bundle: 
1. Click the tab of the research bundle you wish to search in. 
2. Select Edit>Find. 

OR 
Click Find Resource. The Find Resource dialog box is displayed. 

3. Type the word or words you wish to search for. 
4. In the Search area, click whether you want to search in the Key column, Value 

column, or both columns. 
5. In the Directions area, click whether you want to search up or down the selected 

column or columns. 
6. In the Look In area, click whether you want to search in the selected resource bundle 

or all resource bundles. 
7. In the Options area, select the appropriate search criteria you wish to apply to your 

search. 
8. Click OK. Application Builder begins the search based on your parameters and 

criteria. 

Compile a resource bundle 
Compiling a resource bundle creates a class file from the source code to be used by 
RPOS. 

Note: Before you can save a resource bundle, you must save 
it first. 

To compile a resource bundle: 
1. Click the tab of the resource bundle you wish to compile. 

OR 
If you are working in a resource bundle, save the resource bundle. 

2. Select File>Compile. 
OR 
Click Compile Resource Bundle. 

Delete a resource bundle 
Deleting a resource bundle removes the class file from the source code. 
To delete a resource bundle. 
1. Click the tab of the resource bundle you wish to delete. 
2. Select File>Delete. The resource bundle is deleted from the system. 
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