CEP/BAM/BPM Airport Demo Installation and Operation


1 Introduction

These are instructions for installing the necessary components for the 10gR3 Airline Demo on a Windows platform. The accompanying demo files are packaged in AirlineDemo10gR3.zipfile.

2 Prerequisite installation

· Database (Oracle XE recommended)

· Oracle BAM 11g Tech Preview 4 (including BAM)

· http://www.oracle.com/technology/products/ias/bpel/techpreview/index.html
· http://updates.oracle.com/ARULink/PatchDetails/process_form?patch_num=7009057
· note that only sections 12 and 13 of the installation instructions are required for this demo

3 Required installations

3.1 Download and run the Oracle CEP 10gR3 installer

http://www.oracle.com/technology/software/products/cep/index.html
3.2 Download and install ALBPM 6.0.4 (any 6.0+ version OK
http://www.oracle.com/technology/software/products/bpm/index.html
3.3 Download and install Eclipse 3.3 http://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/europa/winter/eclipse-jee-europa-winter-win32.zip
3.4 Unzip the demo files to a local directory. 

Your local path to the top-level directory, AirlineDemo10gR3, will be referred to hereafter as “[demo-path]”.

Edit the pathnames in [demo-path]\dist\setenv.bat to point to your local environment. WLEVS_HOME should be the directory where you installed Oracle CEP.

4 Launch Eclipse and create a CEP Server

Enter a new workspace in the startup dialog. When the IDE comes up, exit the “Welcome” view. You should have the Java EE perspective:
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4.1 Install the CEP Developer Tools plug-in

The 10gR3 GA version of the Oracle CEP Eclipse plug-in is included in the product distribution. From the top menu in Eclipse, select Help->Software updates->Search for new features to install->new archived site->[install-path]\ocep_10.3\eclipse-update-site\cep-tools-10.3.0.20080917-2044.zip

4.2 Create a new CEP domain (optional)

Use the CEP configuration wizard (Windows Start->All Programs->Oracle Complex Event Processing 10gR3->Tools->Configuration Wizard) to create a new domain for this demo. Be sure to browse to the “defaultserver” directory in this domain when you create the new CEP server below. You can also just use the default wlevs30_domain if you do not plan to configure other demos from this CEP installation.

4.3 Create a CEP Server

Open the Servers View (Window->Show View->Servers), then right click in the Server view: New>Server
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Click Next to proceed and create the new server instance. For the Server home directory, browse to the path you used for BEAHOME during the CEP install.  
4.4 Set compiler compliance level and create classpath variables

Make sure your compiler JDK compliance level is set to 5.0 (Window->Preferences->Java->Compiler->Compiler compliance level)

Add two new classpath variables (Window->Preferences->Java->Build Path->Classpath Variables):

WLEVS_HOME = your Oracle CEP install directory (see 4.2 above)

OC4J_HOME =  your OracleBAM directory

4.5 Import the Airline Demo projects

File->Import->General->”Existing Projects into workspace”, browse to [demo-path]\java (see next figure).
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Click Finish. Your IDE should look like this. If there are errors (red x’s) on any of the projects, check that the steps in 4.3 were performed successfully.
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5 Configure BAM, start BAM server and configure the demo

5.1 Add JMS Destinations to the OC4J configuration

The file: [demo-path]\dist\jms\jms_queues.txt includes JMS configuration elements that need to be added to OC4J_HOME\ j2ee\home\config\jms.xml.  Add the two groups of elements as instructed in the text file.

Note: if you are running a remote or non-default OC4J configuration, you will need to follow additional steps for JNDI and JMS configuration which are detailed in Appendix A.

5.2 Start the BAM server

Run the script: OC4J_HOME\bin\start-oc4j-in-console.bat

5.3 Import the Airline Demo data objects, message sources and report

Edit the file:

 [demo-path]\dist\oracleBam\ data\airlinedemo_external_actions.xml to set the path to the jar file that contains the external action that starts BPM processes.

ID="_Library_Name" 

Value=

"[demo-path]\java\StartAlbpmProcessExternalAction\dist\StartBpmProcessAction.jar"/>

Run the script [demo-path]\dist\oracleBam\script\import_all.bat

5.4 Start the BAM Web applications and configure the demo

Start Internet Explorer with the BAM Start Page URL: 

http://localhost:8888/OracleBAM/2609/default.htm
Login with username: fmwadmin, password: welcome1

Select “Architect”.

Start the Enterprise Message Sources

Select “Enterprise Message Sources” from the drop-down list. Select each of the Enterprise Message Sources and click on the start link from the list of commands at the top of the right side. “Status” will change from “Stopped” to “Started”.

Associate the AirlineDemoStartBagTrackingProcess external action with the alert.




Select “Alerts” from the drop-down list.

Edit the AirlineDemoStartBagTrackingProcess alert.

Select the Next button from the first screen.

Select the AirlineDemoStartBagTrackingProcess as the selected action (scroll down in the right hand window).

Select OK to save the change.

5.5 Clear existing demo data

To start the demo with a clear dashboard, run the script:

[demo-path]\dist\oracleBam\script\clear_data.bat
NOTE: Do not run this script while a report is open in Active Viewer. This will cause a race condition. To clear data from a running report, exit the report, run the script, and restart the report.

6 Start the CEP server, install the OC4J Client Bundle and add the Airline Demo project

6.1 Start the CEP server 

Right-click in the IDE Server view and select “Start”.

6.2 Deploy the OC4J Client Bundle

Connecting to OC4J requires a number of Oracle libraries (e.g. JNDI provider).  These are included in a bundle that must be installed to the CEP server before the demo application. 

While OC4J is running, and the CEP server are running, execute the deploy script:



[demo-path]\dist\oc4jclient\deploy_oc4jclient.cmd

6.3 Deploy the Airline Demo project 

Right-click in the Server view and select “Add and Remove Projects”.



Add the project: com.bea.wlevs.demo.airline



Right-click again and select “Publish”.

7 Start ALBPM Studio

7.1 Create a new workspace

7.2 Import the Airline Demo project

File->Import->Exported BPM Project
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Click next and browse to [demo-path]\ \dist\albpm\AirlineDemo.exp. Complete the wizard.

7.3 Start the BPM engine

Select the project in the Project Navigator and start the engine (Run->Start Engine or click on the green triangle.)

8 Running the Demo

8.1 Start the BAM Server and Active Viewer

Start OC4J as in Start Internet Explorer with the BAM Start Page URL: 

http://localhost:8888/OracleBAM/2609/default.htm
Login with username: fmwadmin, password: welcome1

Start “Active Viewer” and select “Airline Operations Dashboard”

8.2 Start the CEP server from within the IDE

See 6.1

8.3 Bring up the EPN (Event Processing Network) viewer in the IDE

In the Project Explorer, right-click on com.bea.wlevs.demo.airline and select “Open in EPN Viewer”. 
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8.4 Run the client application from within the IDE: 

Expand the airlineDemoSimulation project in the Project Explorer as shown below. Right-click on AirlineDemo.java as shown below and select “Run as Java Application”. 
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In the client application GUI window, enter at least one concurrent flight and click on “Start”. The simulator will begin sending passenger, baggage, and flight events to the CEP server which will be seen in the BAM dashboard. These “background” events can slow a small PC, so be careful not to run too many concurrent flights in your demo.

To drive a particular flight scenario, click on “Create Flight” and then select passengers from the list to be stuck in security or have problems with their bags. When you’ve selected your passengers, click on “Activate Flight”. To show the connection to OBPM, click “Skip Add to Container” for at least one customer. This simulates a bag missing the flight. Observe the progress of the flight in the BAM dashboard.
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8.5 In the BAM dashboard, start the tracking process for a lost bag
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In the Actions view, select a passenger with a lost bag and click on “Start Tracking Process”. This will generate a JMS message to a “customer service rep” via JMS and an OBPM workspace.

8.6 In OBPM Studio, click on “Launch Workspace” in the Run menu.

Login to the BPM workspace as “csr1”. Click on the “Inbox” icon in the Views section of the webpage. You should see a lost bag work-item. 
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Click on “ScheduleAlternateDeliver” at the right of the item and check to see that the “Owner” field in the BAM dashboard has been updated. 

Complete the task in the BPM workspace by clicking on “Send” and check that the “Status” field in the BAM dashboard has been updated to “Complete”.

You can repeat the demo sequence by returning to the demo client application, clicking on “Create Flight” and repeating similar steps.

Appendix A: Update JNDI/JMS Configuration properties

NOTE: You only need to make changes to these configuration properties if you are running a non-default configuration of OC4J.  In other words, if the server instance is not on your local machine or is listening on a non-default port.  If you’re using a local install of the 11G BAM TP, then you can skip this section.

8.7 Client Application

The file: /airlineDemoSimulation/src/com/bea/wlevs/demo/airline/client/simulation/JmsEventPublisher.properties

Contains configuration properties for connecting to the OC4J instance.  

jndiCtxFactory=oracle.j2ee.rmi.RMIInitialContextFactory
jndiCtxUserName=fmwadmin
jndiCtxPassword=welcome1
jmsConnectionFactory=jms/ConnectionFactory
jmsProviderUrl=ormi://localhost:23791/default
The only values you may need to change are: jndiCtxUserName, jndiCtxUserName, jmsProviderUrl

8.8 CEP Application

In prior versions of the demo, the JNDI/JMS configuration values were defined in the Spring context configuration file.  With the transition to using the built-in JMS adapters, the configuration of JNDI/JMS properties has been moved to application configuration files (i.e. in META-INF/wlevs rather than META-INF/spring).

Similar to other Event Server application configuration files, there is no required file name.  The file simply needs to be in the META-INF/wlevs directory, conform to the appropriate XML schema, and end in .xml.  In the current release of the product, there is no ability to use placeholder values to use the same value in multiple locations.  So each JMS endpoint will have all the properties defined.  In the airline demo, the JMS adapter configuration properties are in the file: java\com.bea.wlevs.demo.airline\META-INF\wlevs\AdapterConfiguration.xml.  If you need to connect to a non-default configuration of OC4J, then you’ll need to update the endpoint related elements in each jms-adapter entry.  Following is a fragment of the default configuration file:

<n1:config

 xsi:schemaLocation="http://www.bea.com/ns/wlevs/config/application wlevs_application_config.xsd"

 xmlns:n1="http://www.bea.com/ns/wlevs/config/application"

 xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

<jms-adapter>

        <name>OutboundBagEventsAdapter</name>

        <jndi-provider-url>ormi://localhost:23791/default</jndi-provider-url>

        <jndi-factory>oracle.j2ee.rmi.RMIInitialContextFactory</jndi-factory>

        <connection-jndi-name>jms/ConnectionFactory</connection-jndi-name>

        <destination-jndi-name>jms/demos/cep/airline/outboundMapEvents</destination-jndi-name>

        <user>fmwadmin</user>

        <password>welcome1</password>

        <work-manager>JettyWorkManager</work-manager>

        <concurrent-consumers>1</concurrent-consumers>

        <session-transacted>false</session-transacted>

    </jms-adapter>…

</n1:config>
As with the client configuration, the only values you should need to change are the provider URL, user, and password.

