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1 Lab Overview 
 
 
This lab demonstrates native web services integration to Siebel using Oracle BPEL Process Manager. 
Siebel has increased support for native web services, and exposes a number of functions as Application 
Service Interfaces (ASIs). There is also tooling support in Thin Client (browser) and Siebel Tools to 
generate and consume WSDLs. In this tutorial you will Query a Siebel Account. 
 
For more hands-on tutorials, check out the Oracle By Example Tutorials on the Siebel and Fusion 
Middleware Best Practice Center on Oracle Technology Network: 
  
http://www.oracle.com/technology/tech/fmw4apps/siebel 
 
In this Lab:  
 

• You will generate a WSDL in Siebel for the Siebel Account Business Service* 

• Consume the WSDL in BPEL as a Partnerlink 

• Invoke the QueryByID() operation within the WSDL 

• Setup a BPEL transformation via the XSLT mapper 

• Submit a customer ID to verify if the response is as expected 
 

We have completed step (a) for you, and the generated WSDL is located in your C:\FMW4Apps � 
LabFiles � Siebel folder. This was done primarily to ensure we finish the lab in the short duration. 
For those of you who complete the lab and still have time remaining, follow instructions at the end of 
this document on steps to generate the WSDL. 

 
Software Used: 
 

• Siebel 8.0 Call Center 

• Oracle SOA Suite version 11gR1 (available for download from OTN) 

• Oracle JDeveloper version 11gR1 (available for download from OTN) 

• All lab content and software are also available from FMW Best Practice Center for Siebel 
o http://www.oracle.com/technology/tech/fmw4apps/siebel 

• Also check out FMW Best Practice Centers for E-Business Suite, Siebel and PeopleSoft 
o Web Search => Best Practice Center Siebel PeopleSoft E-Business Suite JD Edwards 

 
The Siebel server is connected to the local lab environment. 
 
Questions: 

• Nishit Rao nishit.rao@oracle.com 

• Srikant Subramaniam srikant.subramaniam@oracle.com 



Service-enable Siebel CRM with Oracle SOA Suite BPEL Process Manager 

4 

2   Getting Started 

2.1 Starting Oracle SOA Suite and JDeveloper 
 
This guide assumes that you have access to the 11gR1 versions of the Oracle SOA Suite and 
JDeveloper. 
 
The guide also assumes that the WSDL (SeblAccount.wsdl) and the schema (SiebelAcct.xsd) files are 
located at C:\FMW4Apps\LabFiles\Siebel.  If these files are located elsewhere on your setup, make the 
appropriate modifications. 
 
Ensure that the Oracle SOA Suite is running and start JDeveloper. 
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3 Create the BPEL Process 

3.1 Create the BPEL Workspace and Project 
 
1. Select File > New 
 

 
 
 
2. Select Applications in the Categories tree and SOA Application from the Items list. Click OK to 

continue. 
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3. Name the Application as BPELSEBL. Click Next. 
 

 
 

4. Enter AccountQuery as the Project Name. Click Next. 
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5. Select the Composite with BPEL template. Click Finish. 
 

 
 

6. Set the Process Name to AccountQuery and select the Synchronous BPEL Process template as 

shown.   
 
7. Click on the icon next to the Input field to browse the input elements. 
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8. Click on the Import Schema File icon. 
 

 
 
9. Click on the Browse Resources icon. 
 

 
 
10. Locate the schema file in your folder (C:\FMW4Apps → LabFiles → Siebel) and click OK. 
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11. Accept defaults on the next two screens by clicking OK. 
 

 
 

 
 
12. Select SiebelAcctProcessRequest and click OK. 
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13. Click on the icon next to the Output  field to browse the output elements. 
 

 
 
14. Select SiebelAcctProcessResponse and click OK. 
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15. Click OK. 
 

 
 

16. The BPEL process diagram should look as shown. 
 
 

 
 
 

17. Select File > Save All to save your work.



Service-enable Siebel CRM with Oracle SOA Suite BPEL Process Manager 

12 

3.2 Create the Siebel Partner Link  
 
1. Drag and drop a  PartnerLink activity from the BPEL Services drop down list to the designer window 

as shown.   
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2. In the Create Partner Link window, click on the SOA Resource Lookup icon.  
 

 
 
3. Navigate to the location of the Siebel WSDL file (C:\FMW4Apps\LabFiles\Siebel) and click OK. 
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4. Accept defaults and click OK. 
 

 
 

5. Select Yes. 
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6. Enter the following values to create the partner link: 
 

Name: QueryAccount 
 
Choose Partner Role: CustAccount_Role 

 
(Partner Link Type is automatically populated). 

 
Click OK. 
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3.3 Create an Invoke activity 
 
1. Drag and drop an Invoke from the BPEL Activities and Components drop down list to the designer 

window (after the receiveInput activity) as shown. 
  

 
 
 

 
 

2. Double-click the Invoke icon to open the Invoke window.
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3. In the Invoke window: 
 

a. Set Invoke Name to Invoke_Siebel 
 

b. Click on icon next to the Partner Link field and select QueryAccount 
 
c. Click OK 
 

 
 

d. Set Operation to AccountQueryById.  
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e. Click on the icon next to the Input Variable text field to create a global variable for this activity. 
Accept defaults. Click Apply and then OK. 

 
f. Click on icon next to the Output Variable text field to create a global variable for this activity. 

Accept defaults. Click Apply, followed by OK. 
 

 
 
g. Ensure your invoke window looks as shown.  Click OK. 
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3.4 Create an Assign activity 
 
1. Drag and drop an Assign activity from BPEL Activities and Components drop down list to between 

the receiveInput and Invoke_Siebel activities as shown. 
 

 
 

 
 
2. Double click on the recently added Assign icon. 

 
3. Click on the General tab and enter CopyInput in the Name field. 

 
4. Click Apply 

 
5. Click the Copy Operation tab 
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6. Select Copy Operation from the drop down list. 
 

 
 
 

7. Create the Copy Operation as shown. Click OK. 
 

 
 
 

8. Click OK to close the Create Copy Rule window.  
 
9. Click OK to close the Assign window. 
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3.5 Create a Transform activity 
 
1. Drag and drop a Transform activity from the BPEL Activities and Components drop down list to 

between the Invoke_Siebel and replyOutput activities. 
 

 
 
 

 
 
 
2. Double-click the recently added Transform icon. 

 
3. Click the General tab and Enter TransformOutput in the Name field.
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4. Click the Transformation tab and click on the icon to create a new transformation. 
 

 
 
5. Select the Source Variable from the drop down list as shown. Click OK. 
 

 
 

6. Select the Target Variable from the drop down list as shown. Click OK.  
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7. In the XSLT mapper, expand the parent elements by clicking on the “+” sign next to their names. Your 
screen should look as shown below. We can now create the mappings (transformations). 

 

 
 

8. To create a mapping from the source to the target, we simply drag and drop the element from the left 
column (source) to the corresponding element in the right column (target). 

 
a. Drag and drop the Name element from the source (on the left) to the Name element on the right. 

This will create a mapping as shown. 
 

 
 
b. Repeat the above mapping step for the following source elements: 
 

• AccountStatus → AccountStatus 

• CompetitorFlag → CompetitorFlag 

• NumberofEmployees → NumberofEmployees 

• Location → Location 

• Type → Type 
 
c. Verify that the mappings look as shown in the next figure. 
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9. Go back to the BPEL Process by clicking on the AccountQuery.bpel tab 
 

 
 

10. This completes the creation of the BPEL process. 



Service-enable Siebel CRM with Oracle SOA Suite BPEL Process Manager 

25 

3.6 Validating, Compiling and Deploying the BPEL Process 
 
1. The completed BPEL process should resemble the following figure. 

 

 
 
2. Select File > Save All button to save the BPEL project. 

 
3. Right-click the AccountQuery BPEL Project. 

 
4. Select Deploy ���� AccountQuery ���� FMWApps as shown. 
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5. Click OK on the next screen (SOA Deployment Configuration Dialog) to accept defaults and set off 

the compilation process (this could take a few minutes). 
 
6. Enter username/password (weblogic/welcome1). 
 

 
 
7. This will deploy the BPEL process to the local Application Server and could take a minute or two. 

Click on the Deployment tab (at the bottom of the screen) to view the progress. 
 
8. Deployment was successful. 
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4 Testing 
 
1. Log into the Oracle Enterprise Manager Console at: http://localhost:7001/em 
 
2. The default Username is weblogic and the default Password is welcome1 
 

 
 

3. Click on the AccountQuery process in the SOA Deployments. 
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4. Click on the Test tab to initiate a test instance. 
 

 
 
5. Enter 1-5GZO in the input field and click on Test Web Service. 
 

Other valid inputs are:  
 
1SIA-7UKI 
24-28V6 

 

 
 

6. The output is the customer account summary containing only the fields that we mapped out earlier. 
This marks the successful completion of the lab. 
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5 Additional Credit 

5.1 BPEL Console 
 

• Go back to the BPEL Dashboard and look at the completed process instances. 

• Check the executed flow diagram of completed instances. Click on each step in the process to 
see the XML data flowing through the step. 

5.2 JDeveloper 
 

• Explore the different activities you can use in a BPEL process. Look at Process Activities and you 
will find an array of nodes to use. Interesting ones are Human Task flow, which can be used to 
include human approval steps and assign tasks to people. 

5.3 Log into Siebel and Generate the WSDL 
 

• Login to Siebel using the shortcut in the desktop folder (FMW4Apps -> Shortcuts) with userid and 
password SADMIN/SADMIN 

 

• Click on menu item Navigate � Site Map. 
 

• Click on Administration-Web Services, followed by Inbound Web Services 
 

• In the list of Inbound Web Services find the one we used – see below. Use the mouse to find by 
scrolling down (do not use query button). This is to ensure you don’t change the definition of the 
Web service. (Note: Siebel saves on change without prompting user.) You can hit the generate 
WSDL button and you will be prompted to save. Here choose open to view the WSDL in Internet 
Explorer. Examine the WSDL for schema types and the server port it is binding to. Do not save. 
Close the browser. 

 

 
 

• Scroll down and see the service ports and operations we have for this web service. You will find 
three operations (AccountQuerybyID, AccountQueryByExample and AccountInsert). 
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These are out of the box operations exposed on any Siebel Business Object.  
 
Other operations found on business objects include Update, Insert, Synchronize and Delete. We 
have chosen not to expose them in our case. Instructions on how to make these available as 
operations can be found in Siebel Bookshelf or you can see a tutorial for this on FMW Best 
Practice Center for Siebel on OTN.  
 
Make sure you have made no changes in the Siebel instance.  
 
Logout from the application using File�Logout menu in Siebel browser.  
 
Exit the browser. 


