Copyright © 2005, 2006, Oracle. All rights reserved.

The Programs (which include both the software and documentation) contain proprietary information; they are provided under a license agreement containing restrictions on use and disclosure and are also protected by copyright, patent, and other intellectual and industrial property laws. Reverse engineering, disassembly, or decompilation of the Programs, except to the extent required to obtain interoperability with other independently created software or as specified by law, is prohibited.

The information contained in this document is subject to change without notice. If you find any problems in the documentation, please report them to us in writing. This document is not warranted to be error-free. Except as may be expressly permitted in your license agreement for these Programs, no part of these Programs may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose.

PRODUCT MODULES AND OPTIONS. This guide contains descriptions of modules that are optional and for which you may not have purchased a license. Siebel’s Sample Database also includes data related to these optional modules. As a result, your software implementation may differ from descriptions in this guide. To find out more about the modules your organization has purchased, see your corporate purchasing agent or your Siebel sales representative.

If the Programs are delivered to the United States Government or anyone licensing or using the Programs on behalf of the United States Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS. Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the Programs, including documentation and technical data, shall be subject to the licensing restrictions set forth in the applicable Oracle license agreement, and, to the extent applicable, the additional rights set forth in FAR 52.227-19, Commercial Computer Software--Restricted Rights (June 1987). Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

The Programs are not intended for use in any nuclear, aviation, mass transit, medical, or other inherently dangerous applications. It shall be the licensee's responsibility to take all appropriate fail-safe, backup, redundancy and other measures to ensure the safe use of such applications if the Programs are used for such purposes, and we disclaim liability for any damages caused by such use of the Programs.

Oracle, JD Edwards, PeopleSoft, and Siebel are registered trademarks of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective owners.

The Programs may provide links to Web sites and access to content, products, and services from third parties. Oracle is not responsible for the availability of, or any content provided on, third-party Web sites. You bear all risks associated with the use of such content. If you choose to purchase any products or services from a third party, the relationship is directly between you and the third party. Oracle is not responsible for: (a) the quality of third-party products or services; or (b) fulfilling any of the terms of the agreement with the third party, including delivery of products or services and warranty obligations related to purchased products or services. Oracle is not responsible for any loss or damage of any sort that you may incur from dealing with any third party.
Contents

Chapter 1: What’s New in This Release

Chapter 2: Overview of Siebel Business Analytics Applications Upgrade

Supported Upgrade Paths 7
Preupgrade Considerations 7
Best Practices for Preparing to Upgrade 8
Major Stages of Analytics Applications Upgrade 9

Chapter 3: Upgrading Siebel Business Analytics Applications

Detailed Tasks for Upgrading Analytics Applications 11
Analytics Platform Upgrade 13
Installing the Latest Version of Analytics Applications 13
Upgrading the DAC Metadata Repository 14
Upgrading the Data Warehouse Schema 16
Process of Upgrading the Siebel Transactional Database Schema 17
  Importing the SIF File into the Siebel Transactional Database 17
  Verifying the SIF Patch Application 18
Informatica Version 7.1.2 Upgrade 19
Upgrading the Informatica Repository 19
Migrating Data for Siebel Business Applications 21
Migrating Data for Siebel Industry Applications 24
Migrating Data for Analytics Bridge Applications 27
Verifying ETL Customizations 29
Process of Upgrading the Analytics Repository 29
  Preparing for the Analytics Repository Upgrade 30
  Trimming the Analytics Repositories 30
  Equalizing the Analytics Repositories 32
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Merging the Analytics Repositories</td>
<td>33</td>
</tr>
<tr>
<td>Fixing Analytics Repository Merge Errors</td>
<td>34</td>
</tr>
<tr>
<td>Regression Testing the Analytics Repository Merge</td>
<td>34</td>
</tr>
<tr>
<td>Process of Upgrading the Analytics Web Catalog</td>
<td>35</td>
</tr>
<tr>
<td>Trimming the Input Web Catalog</td>
<td>35</td>
</tr>
<tr>
<td>Running the Catalog Upgrade for the Existing Web Catalog</td>
<td>35</td>
</tr>
<tr>
<td>Merging New and Existing Web Catalogs</td>
<td>36</td>
</tr>
<tr>
<td>Testing the Results of the Web Catalog Upgrade</td>
<td>36</td>
</tr>
</tbody>
</table>

**Index**
What’s New in Siebel Business Analytics Applications Upgrade Guide, Version 7.8.4

The Siebel Business Analytics Applications Upgrade Guide, Version 7.8.4, is a new guide. Some of the material appearing in this guide was formerly in the Siebel Business Analytics Applications Installation and Administration Guide. Table 1 describes the derivation of the material for each section of this guide.

Table 1. New Product Features in Siebel Business Analytics Applications Upgrade Guide, Version 7.8.4

<table>
<thead>
<tr>
<th>Topic</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overview of Siebel Business Analytics Applications Upgrade on page 7.</td>
<td>New topic. Lists the major stages of the Siebel Business Analytics Applications upgrade process.</td>
</tr>
<tr>
<td>Detailed Tasks for Upgrading Analytics Applications on page 11.</td>
<td>New topic. Lists the tasks required to upgrade Siebel Business Analytics Applications.</td>
</tr>
<tr>
<td>Upgrading the DAC Metadata Repository on page 14.</td>
<td>Formerly in the Siebel Business Analytics Applications Installation and Administration Guide.</td>
</tr>
<tr>
<td>Upgrading the Informatica Repository on page 19.</td>
<td>Formerly in the Siebel Business Analytics Applications Installation and Administration Guide.</td>
</tr>
<tr>
<td>Verifying ETL Customizations on page 29.</td>
<td>New topic. Describes how to verify upgraded ETL sessions.</td>
</tr>
<tr>
<td>Process of Upgrading the Analytics Repository on page 29.</td>
<td>New topic. Describes the process of merging the customizations of a prior release of the repository with a new version of the repository.</td>
</tr>
<tr>
<td>Process of Upgrading the Analytics Web Catalog on page 35.</td>
<td>New topic. Describes the process of upgrading the Siebel Business Analytics Web catalog.</td>
</tr>
</tbody>
</table>
Overview of Siebel Business Analytics Applications Upgrade

This chapter provides an overview of Oracle’s Siebel Business Analytics Applications upgrade process. It includes the following topics:

- Supported Upgrade Paths on page 7
- Preupgrade Considerations on page 7
- Best Practices for Preparing to Upgrade on page 8
- Major Stages of Analytics Applications Upgrade on page 9

Supported Upgrade Paths

*Siebel Business Analytics Applications Upgrade Guide* provides instructions for upgrading to Siebel Business Analytics Applications 7.8.x from the previous versions listed below. The major stages of the upgrade process are the same for each of these upgrade paths. You can upgrade directly to Siebel Business Analytics Applications 7.8.x from any of the previous versions listed below.

- Siebel Business Analytics 7.5.x
- Siebel Business Analytics 7.7
- Siebel Business Analytics 7.7.1.x

Preupgrade Considerations

You should consider the following points before you begin your upgrade:

- Review the *System Requirements and Supported Platforms for Siebel Business Analytics Applications* on Siebel SupportWeb to make sure your database platform versions are supported.

- The upgrade process is not only a technical process. You will also need to analyze the impact of the schema changes on your current custom implementation. The extent of your customizations will have an impact on the length of time required for the upgrade.

In addition, at different stages of the upgrade you will also need to analyze your organization’s business requirements. For example, at the stage in which you are upgrading the Siebel Business Analytics repository, you will need to know which repository objects are not in use so that they can be trimmed from the repository. To determine this information, you will need to know what reports are in use.

- For each stage of the upgrade process, you need to allocate a reasonable amount of time to validate the results of that stage and address any problems. In addition, final user acceptance testing must confirm that the entire upgrade process was successful.
When you perform the Siebel Business Analytics Web catalog upgrade, it is recommended that you use side-by-side environments and have users review and compare reports and dashboard content between the previous version and the upgraded version.

For the other stages of the upgrade, you can upgrade your environments in place.

Best Practices for Preparing to Upgrade

This section provides best practice steps you need to perform before you begin the upgrade process.

- Back up and rename your current repository and Siebel Business Analytics Web Catalog files as listed below.

<table>
<thead>
<tr>
<th>File Type</th>
<th>File Name</th>
<th>File Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAC metadata repository</td>
<td>*.xml</td>
<td>SiebelAnalytics\DAC\export</td>
</tr>
<tr>
<td>Analytics repository</td>
<td>SiebelAnalytics.rpd</td>
<td>SiebelAnalytics\Repository</td>
</tr>
<tr>
<td>Informatica repository</td>
<td>Siebel_DW_rep.rep</td>
<td>SiebelAnalytics\dwrep\Informatica\Repository</td>
</tr>
<tr>
<td>Web catalog</td>
<td>SiebelAnalytics.webcat</td>
<td>SiebelAnalyticsData\Web\Catalog</td>
</tr>
</tbody>
</table>

- Gather information that describes the current implementation, including the following:
  - Version of the Siebel transactional database to which you upgraded.
  - Version of the Siebel Business Analytics platform from which you are upgrading.

  To determine the Analytics platform version from which you are upgrading, launch the Siebel Business Analytics Server Administration Tool, and click Help > Administration Tool in the toolbar. A message box provides the platform version.

  - Version of Siebel Business Analytics Applications from which you are upgrading.

  To determine the version of Analytics Applications from which you are upgrading, launch the Data Warehouse Administration Console (DAC), and click Help > Metadata Version. A message box provides the metadata version, which will be either 7.7 or 7.7.1.

    - If your metadata version is 7.7, you are running Analytics 7.7.
    - If your metadata version is 7.7 and your transactional database version is 6.3.x, you are running the Siebel Business Analytics Bridge - 6.3.
    - If your metadata version is 7.7 and your transactional database version is 7.5.x, you are running the Siebel Business Analytics Bridge - 7.5.
    - If your metadata version is 7.7.1, you are running Siebel Business Analytics 7.7.1.x.

    **NOTE:** If the DAC is not a component of your Analytics installation, you are running Analytics 7.5.x.
Major Stages of Analytics Applications Upgrade

Figure 1 shows the upgrade flow for the major stages of the Siebel Business Analytics Applications upgrade process. For the detailed steps and tasks associated with each stage, see Table 3 on page 12. Table 2 provides the documentation you should refer to for each stage of the upgrade.

Figure 1. Siebel Business Analytics Applications Upgrade Flow

Table 2. Major Stages of the Siebel Business Analytics Applications Upgrade and Related Documentation

<table>
<thead>
<tr>
<th>Stage</th>
<th>Related Documentation</th>
</tr>
</thead>
</table>
| 1     | Upgrade to the latest version of Siebel Business Analytics platform.  
**NOTE:** The Siebel Business Analytics platform is code-independent from the Siebel Business Analytics Applications. |
|       | **Siebel Business Analytics Platform Upgrade Guide.** |
| 2     | Install the latest version of Siebel Business Analytics Applications. |
|       | **Siebel Business Analytics Applications Upgrade Guide.** |
| 3     | Upgrade the Siebel Data Warehouse. |
|       | **Siebel Business Analytics Applications Upgrade Guide.**  
**Siebel Business Analytics Applications Installation and Administration Guide.**
You must complete the first and second stages sequentially; that is, you must first upgrade to the latest version of the Siebel Business Analytics platform and then install the latest version of Siebel Business Analytics Applications. You can perform stages three, four, and five simultaneously, but you must perform the tasks for these stages in the order listed in Table 3.

**CAUTION:** It is highly recommended that you consider obtaining support from Siebel Professional Services to assist with the end-to-end upgrade process.

**NOTE:** Upgrading Siebel CRM applications is out of the scope of this document. A CRM applications upgrade must precede the Siebel Business Analytics Applications upgrade. For more information, see *Upgrade Guide*.

### Table 2. Major Stages of the Siebel Business Analytics Applications Upgrade and Related Documentation

<table>
<thead>
<tr>
<th>Stage</th>
<th>Related Documentation</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Upgrade the Siebel Business Analytics repository.</td>
</tr>
<tr>
<td></td>
<td>- Siebel Business Analytics Applications Upgrade Guide</td>
</tr>
<tr>
<td></td>
<td>- Siebel Business Analytics Server Administration Guide</td>
</tr>
<tr>
<td>5</td>
<td>Upgrade the Siebel Business Analytics Web catalog.</td>
</tr>
<tr>
<td></td>
<td>- Siebel Business Analytics Applications Upgrade Guide</td>
</tr>
<tr>
<td></td>
<td>- Siebel Business Analytics Web Administration Guide</td>
</tr>
</tbody>
</table>
This chapter provides the detailed tasks required to upgrade Siebel Business Analytics Applications. It covers the following topics:

- Detailed Tasks for Upgrading Analytics Applications on page 11
- Analytics Platform Upgrade on page 13
- Installing the Latest Version of Analytics Applications on page 13
- Upgrading the DAC Metadata Repository on page 14
- Upgrading the Data Warehouse Schema on page 16
- Process of Upgrading the Siebel Transactional Database Schema on page 17
- Informatica Version 7.1.2 Upgrade on page 19
- Upgrading the Informatica Repository on page 19
- Migrating Data for Siebel Business Applications on page 21
- Migrating Data for Siebel Industry Applications on page 24
- Migrating Data for Analytics Bridge Applications on page 27
- Verifying ETL Customizations on page 29
- Process of Upgrading the Analytics Repository on page 29
- Process of Upgrading the Analytics Web Catalog on page 35

Detailed Tasks for Upgrading Analytics Applications

Table 3 provides the detailed steps and corresponding tasks you need to perform to upgrade Siebel Business Analytics Applications. It also provides a link to the instructions for each task or a cross-reference for an alternative guide.
You must perform stages one and two sequentially. You can perform stages three, four, and five simultaneously, but you must perform the tasks for these stages in the order listed in Table 3.

Table 3. Detailed Task List for Upgrading Siebel Business Analytics Applications

<table>
<thead>
<tr>
<th>Step</th>
<th>Instructions for Task Corresponding to Step</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Stage 1: Step to Upgrade Siebel Business Analytics Platform</strong></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>Upgrade to the latest version of the Siebel Business Analytics platform. For more information, see Siebel Business Analytics Platform Upgrade Guide.</td>
</tr>
<tr>
<td><strong>Stage 2: Step to Upgrade Siebel Business Analytics Applications</strong></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Install the latest version of Siebel Business Analytics Applications. Installing the Latest Version of Analytics Applications on page 13.</td>
</tr>
<tr>
<td><strong>Stage 3: Steps to Upgrade Siebel Data Warehouse</strong></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Upgrade the Data Warehouse Administration Console (DAC) metadata repository. Upgrading the DAC Metadata Repository on page 14.</td>
</tr>
<tr>
<td>4</td>
<td>Upgrade the Data Warehouse schema. Upgrading the Data Warehouse Schema on page 16</td>
</tr>
<tr>
<td>a</td>
<td>Import the SIF file into the Siebel transactional database. ■ Importing the SIF File into the Siebel Transactional Database on page 17</td>
</tr>
<tr>
<td>b</td>
<td>Verify the SIF patch application. ■ Verifying the SIF Patch Application on page 18</td>
</tr>
<tr>
<td>6</td>
<td>Upgrade Informatica to version 7.1.2. See the Informatica upgrade documentation on the Siebel Business Applications Third-Party Bookshelf.</td>
</tr>
<tr>
<td>7</td>
<td>Upgrade the Informatica Repository. Upgrading the Informatica Repository on page 19.</td>
</tr>
<tr>
<td>8</td>
<td>Perform Data Migration. ■ Migrating Data for Siebel Business Applications on page 21. ■ Migrating Data for Siebel Industry Applications on page 24 ■ Migrating Data for Analytics Bridge Applications on page 27</td>
</tr>
<tr>
<td>9</td>
<td>Verify ETL customizations. Verifying ETL Customizations on page 29.</td>
</tr>
<tr>
<td><strong>Stage 4: Steps to Upgrade Siebel Business Analytics Repository</strong></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Upgrade the Analytics repository. Process of Upgrading the Analytics Repository on page 29.</td>
</tr>
</tbody>
</table>
Table 3. Detailed Task List for Upgrading Siebel Business Analytics Applications

<table>
<thead>
<tr>
<th>Step</th>
<th>Instructions for Task Corresponding to Step</th>
</tr>
</thead>
<tbody>
<tr>
<td>a</td>
<td>Prepare for the Analytics repository upgrade.</td>
</tr>
<tr>
<td>b</td>
<td>Trim the Analytics repositories.</td>
</tr>
<tr>
<td>c</td>
<td>Equalize the Analytics repositories.</td>
</tr>
<tr>
<td>d</td>
<td>Merge Analytics repositories.</td>
</tr>
<tr>
<td>e</td>
<td>Fix errors in the Analytics repository merge.</td>
</tr>
<tr>
<td>f</td>
<td>Regression test the Analytics repository merge.</td>
</tr>
</tbody>
</table>

Stage 5: Steps to Upgrade Web Catalog

<table>
<thead>
<tr>
<th>Step</th>
<th>Instructions for Task Corresponding to Step</th>
</tr>
</thead>
<tbody>
<tr>
<td>11</td>
<td>Upgrade the Analytics Web catalog.</td>
</tr>
<tr>
<td>a</td>
<td>Trim the input Web catalog.</td>
</tr>
<tr>
<td>b</td>
<td>Run the catalog upgrade for the existing Web catalog.</td>
</tr>
<tr>
<td>c</td>
<td>Merge the new and existing Web catalogs.</td>
</tr>
<tr>
<td>d</td>
<td>Test the results of the Web catalog upgrade.</td>
</tr>
</tbody>
</table>

Analytics Platform Upgrade

For information on upgrading the Siebel Business Analytics platform to the latest version, see the *Siebel Business Analytics Platform Upgrade Guide*.

Installing the Latest Version of Analytics Applications

Follow this procedure to install the latest version of Siebel Business Analytics Applications.
To install the latest version of Analytics Applications

1. Access the installation files on the Siebel Business Analytics Applications installation CD-ROM, and then run the program setup.exe.

2. The installation wizard window appears and prompts you through each screen, as shown in the following table.

   To continue to the next screen, click Next. To return to a previous screen, click Back.

<table>
<thead>
<tr>
<th>Screen</th>
<th>Your Action</th>
<th>Notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Click Next.</td>
<td></td>
</tr>
<tr>
<td>License Agreement</td>
<td>Select “I accept...” and click Next.</td>
<td></td>
</tr>
<tr>
<td>License File</td>
<td>Browse for and select the appropriate XML file, and then click Next.</td>
<td></td>
</tr>
<tr>
<td>Data Warehouse Selection</td>
<td>Select RMW, and then click Next.</td>
<td></td>
</tr>
<tr>
<td>Applications Selection</td>
<td>Select the applications you want to install, and then click Next.</td>
<td></td>
</tr>
<tr>
<td>Summary Information</td>
<td>Click Next.</td>
<td>The Analytics Applications product is installed in the same directory where you installed the Analytics platform.</td>
</tr>
<tr>
<td>Summary Information</td>
<td>Click Finish to exit the installation wizard.</td>
<td></td>
</tr>
</tbody>
</table>

3. To confirm the installation was successful, verify the following files were installed:

<table>
<thead>
<tr>
<th>File</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>SiebelAnalytics.rpd</td>
<td>SiebelAnalytics\Repository</td>
</tr>
<tr>
<td>Siebel_DW_rep.rep</td>
<td>SiebelAnalytics\dwrep\Informatica\Repository</td>
</tr>
<tr>
<td>SiebelAnalytics.webcat</td>
<td>SiebelAnalyticsData\Web\Catalog</td>
</tr>
</tbody>
</table>

Upgrading the DAC Metadata Repository

Follow this procedure to upgrade the DAC metadata repository.

To upgrade the DAC metadata repository

1. Make sure you have backed up and renamed your existing DAC metadata repository.
2 If you are upgrading from Analytics 7.7, navigate to the SiebelAnalytics\DAC directory, and run the script UpgradeFromAn77ToAN771.sql. This step is required only for upgrades from Analytics 7.7.

3 Upgrade the DAC metadata to the latest Analytics format by merging your current DAC metadata repository with the new version received from Siebel Systems.

   a In the DAC, set up database connections for the current and new repositories by navigating to Setup > Database Connections and entering the following information:

   b From the DAC toolbar, choose Tools > DAC Repository Management > Compare and Merge Repositories.

   c In the Compare and Merge Repositories dialog box, select the source (current) and target (new) repositories that you want to compare.

   d To import from the source repository into the target the objects that are missing, select the Import Missing Objects check box.

   **NOTE:** Modifications made to objects in the source repository must be entered manually in the target repository.

   The Difference report is automatically created.
To view the Difference report, navigate to SiebelAnalytics\DAC\diff\html, and double-click index.html.

For more information about comparing and merging DAC repositories, see the Siebel Business Analytics Applications Installation and Administration Guide.

Upgrading the Data Warehouse Schema

This procedure adds new tables, columns, and indexes to the existing Siebel Data Warehouse schema. It does not alter or disrupt your existing data.

To upgrade the Siebel Data Warehouse Schema

1. From the DAC menu bar, choose Tools > ETL Management > Configure.
2. In the Sources dialog box, select the database platform for the target data warehouse, source transactional database, and the Informatica repository.
   The Data Warehouse Configuration Wizard opens.
3. Select the Create Siebel Data Warehouse Tables check box, and click Next.
   The Data Warehouse tab is active.
4. Enter the following information.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database Type</td>
<td>Type of database. If the database type is DB2 390, then select the 390 Database check box.</td>
</tr>
<tr>
<td>Table Owner</td>
<td>Valid database user.</td>
</tr>
<tr>
<td>Password</td>
<td>Valid database user password.</td>
</tr>
<tr>
<td>ODBC Data Source</td>
<td>Data Source Name (DSN) for the Siebel Data Warehouse.</td>
</tr>
<tr>
<td>Data Area</td>
<td>(Optional) Tablespace where the data warehouse tables are created.</td>
</tr>
<tr>
<td>Index Area</td>
<td>(Optional) Indexspace where the data warehouse indices are created (applicable only to Oracle and DB2 databases).</td>
</tr>
<tr>
<td>Is Unicode</td>
<td>Specifies whether the data warehouse database is Unicode. Check with your database administrator to determine whether your database is Unicode.</td>
</tr>
</tbody>
</table>

5. Check the log file to confirm the new tables, columns, and indexes were added to the schema.
   The log file lists all new objects that were added to the schema.
Process of Upgrading the Siebel Transactional Database Schema

This procedure upgrades transactional database objects that relate to Siebel Business Analytics. It does not upgrade transactional database objects for CRM applications. A CRM applications upgrade must precede the Siebel Business Analytics Applications upgrade.

To upgrade transactional database objects that related to Siebel Business Analytics, perform the following tasks:

- Importing the SIF File into the Siebel Transactional Database on page 17
  
  **NOTE:** To complete this task, use Siebel Tools.

- Verifying the SIF Patch Application on page 18

Importing the SIF File into the Siebel Transactional Database

Follow this procedure to import new schema definitions into the Siebel transactional database.

This task is a step in the Process of Upgrading the Siebel Transactional Database Schema.

**To import new schema definitions into the Siebel transactional database**

1. Copy the file named SRW_OLTP_78.sif from the SiebelAnalytics\dwrep to \tools\objects directory.
2. Open Siebel Tools, and point to the development database.
3. Lock the projects named: Table ETL and Table Nquire.
4. In the menu, choose Tools > Import from Archive.
5. Navigate to the directory containing the SIF files, and open SRW_OLTP_78.sif.
   
   The Import Wizard—Preview screen appears.
7. Click Next.
8. Select the option, Merge the object definition, from the archive file with the definition in the repository, and click Next.
   
   The Import Wizard reviews all the object conflicts between what is in the repository and what is in the SIF file.
9. When the Import Wizard process is done, expand the tree under Conflicting Objects to verify the changes being applied from the SIF file to the repository. When you are done, click Next.
   
   A warning appears:
   
   The operation is going to modify your repository ...
10. Click Yes.
11. When the process is finished, click Finish.
After you import the new schema into Siebel Tools, apply the schema to the physical database.

**To apply schema definitions to the Siebel transactional database**

1. In Siebel Tools, in the Object Explorer, click the Table tab and query for S_ETL_*.
2. Select all the tables in the list, and click Apply.
   
   The Apply Schema wizard appears.

3. In the Tables drop-down menu, choose Current Query. Enter the appropriate connection parameters, and click Apply.

**Verifying the SIF Patch Application**

Follow this procedure to verify that the SIF import is complete. After the SIF file is imported, verify the following tables were created in the Siebel transactional database.

This task is a step in the **Process of Upgrading the Siebel Transactional Database Schema**.

**To verify the SIF import is complete**

- For Siebel Business Applications, after the SIF import is complete, verify the following tables were created in the Siebel transactional database:
  - S_ETL_R_IMG_1 through S_ETL_R_IMG_88
  - S_ETL_I_IMG_1 through S_ETL_I_IMG_88
  - S_ETL_D_IMG_1 through S_ETL_D_IMG_88
  - S_ETL_R_IMG_133 through S_ETL_R_IMG_147
  - S_ETL_I_IMG_133 through S_ETL_I_IMG_147
  - S_ETL_D_IMG_133 through S_ETL_D_IMG_147
  - S_ETL_PARAM
  - S_ETL_PRD_ATTR
  - S_ETL_PRD_REL

- For Siebel Industry Applications, after the SIF import is complete, verify the following tables were created in the Siebel transactional database:
  - S_ETL_R_IMG_84 through S_ETL_R_IMG_132
  - S_ETL_I_IMG_84 through S_ETL_I_IMG_132
  - S_ETL_D_IMG_84 through S_ETL_D_IMG_132
  - S_ETL_R_IMG_148 through S_ETL_R_IMG_151
  - S_ETL_I_IMG_148 through S_ETL_I_IMG_151
  - S_ETL_D_IMG_148 through S_ETL_D_IMG_151
For Siebel Business Analytics Bridge - 7.5, after the SIF import is complete, verify the following tables were created in the Siebel transactional database:

- S_ETL_R_IMG_1 through S_ETL_R_IMG_88
- S_ETL_I_IMG_1 through S_ETL_I_IMG_88
- S_ETL_D_IMG_1 through S_ETL_D_IMG_88

For Siebel Business Analytics Bridge - 7.5 SIA, after the SIF import is complete, verify the following tables were created in the Siebel transactional database:

- S_ETL_R_IMG_84 through S_ETL_R_IMG_132
- S_ETL_I_IMG_84 through S_ETL_I_IMG_132
- S_ETL_D_IMG_84 through S_ETL_D_IMG_132

**Informatica Version 7.1.2 Upgrade**

For information on upgrading to Informatica version 7.1.2, see the Informatica upgrade documentation on the *Siebel Business Applications Third-Party Bookshelf*.

**Upgrading the Informatica Repository**

Follow this procedure to upgrade the Informatica Repository.

*To upgrade the Informatica Repository*

1. Back up your current Informatica Repository.
   
   For instructions, see the Informatica documentation on the *Siebel Business Applications Third-Party Bookshelf*.

2. Create the Informatica Repository:
   
   a. From the DAC menu bar, choose Tools > ETL Management > Configure.
   
   b. Select the database platforms for the following:
      
      - Target data warehouse
      - Source transactional database
      - Informatica repository
   
   c. In the Data Warehouse Configuration wizard, select the Create Informatica Repository check box, and then click Next.
      
      The Informatica Repository tab is active.
Enter the following information.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database Type</td>
<td>Type of database.</td>
</tr>
<tr>
<td>Database Connection String</td>
<td>If you are using one of the following:</td>
</tr>
<tr>
<td></td>
<td>□ Oracle (OCI8), use the tnsnames entry.</td>
</tr>
<tr>
<td></td>
<td>□ Oracle (Thin), use instance name.</td>
</tr>
<tr>
<td></td>
<td>□ SQL Server, use the database name.</td>
</tr>
<tr>
<td></td>
<td>□ DB2-UDB/DB2-390, use the connect string as defined in the DB2 configuration.</td>
</tr>
<tr>
<td>Host</td>
<td>Applicable only to an SQL Server. Indicates the machine host name where the server resides.</td>
</tr>
<tr>
<td>Database Table Owner</td>
<td>Name of the table owner.</td>
</tr>
<tr>
<td>Database Password</td>
<td>Password for the table owner.</td>
</tr>
<tr>
<td>MSSQL Database Name</td>
<td>Applicable to an SQL Server only. Indicate the database name where you want to restore the repository.</td>
</tr>
<tr>
<td>Informatica Repository name</td>
<td>A logical name for the Informatica repository.</td>
</tr>
<tr>
<td>Informatica Administrator Login</td>
<td>Not applicable while creating the repository. Used only to configure the repository.</td>
</tr>
<tr>
<td>Informatica Administrator Password</td>
<td>Not applicable while creating the repository. Used only to configure the repository.</td>
</tr>
<tr>
<td>Repository Server</td>
<td>Name of the machine hosting the Informatica Repository Server.</td>
</tr>
<tr>
<td>Repository Server Port</td>
<td>Port number used by Informatica Repository Server to listen to requests.</td>
</tr>
<tr>
<td>Email Address</td>
<td>Not applicable while creating the repository. Used only to configure the repository.</td>
</tr>
</tbody>
</table>

A message box informs you that the repository was created successfully.

3 Copy the Custom folder from your previous Informatica repository to the newly created Informatica repository:

a Launch the Informatica Repository Manager, and connect to both your previous and newly created Informatica repositories.

b Select the Custom folder in your previous repository and copy it (Edit > Copy).

c Select the newly created Informatica Repository and paste it (Edit > Paste). Rename the folder if necessary to paste it to this location.

This action creates the Custom folder and all its contents (mappings, workflows, and so on).
Migrating Data for Siebel Business Applications

In this task, you run an upgrade execution plan to populate data in the new Siebel Data Warehouse schema.

**NOTE:** If you do not have historical data, such as slowly changing dimensions or accumulated snapshot facts, such as pipeline facts, you can perform a full load ETL to populate 7.8.x data. If you perform a full load ETL, you do not need to perform the data migration steps listed in the following sections.

This section includes information on migrating data for the following upgrade options:

- Migrating Data Warehouse Data from Version 7.5.x to 7.8.x on page 21
- Migrating Data Warehouse Data from Version 7.7 to 7.8.x on page 22
- Migrating Data Warehouse Data from Version 7.7.1.x to 7.8.x on page 23

**NOTE:** The term INCA, which is used in certain folder names in this section, is an internal term.

Migrating Data Warehouse Data from Version 7.5.x to 7.8.x

Follow this procedure to migrate data from the Siebel Data Warehouse version 7.5.x to version 7.8.x for Siebel Business Applications.

**To migrate data warehouse data from version 7.5.x to 7.8.x**

1. In the Informatica Workflow Manager, navigate to the folder, Upgrade_7.5.XtoINCA, and run the following workflows in the following order:
   a. Upgrade_DAW
   b. Upgrade_R_Image
   c. Upgrade_Unspecifieds
   d. Upgrade_Agree
   e. Upgrade_Asset
   f. Upgrade_Opty
   g. Upgrade_Order
   h. Upgrade_Quote
   i. Upgrade_Response
   j. Upgrade_ServiceRequest

   d. Create an individual workflow for each of the mappings in the Custom folder.
   e. Register the mappings in the DAC.

   You will verify your customized mappings in the procedure “Verifying ETL Customizations” on page 29, which you perform after the data migration.
Configure the DAC:
- In the DAC, navigate to Setup > Database Connections.
- In the Tables subtab, set the Refresh Date to null for the source tables S_SRC and S_SRC_DCP. This step performs a full load on the S_SRC and S_SRC_DCP tables. This step is required because the image tables corresponding to these tables were used in a previous release, and, therefore, need to be refreshed.

Execute the Upgrade 7.7 DW to 7.8 DW execution plan:
- Navigate to the Execute view.
- In the Execution Plans tab, select Upgrade 7.7 DW to 7.8 DW.
- Click Run Now.

In the Informatica Workflow Manager, navigate to the folder, Upgrade_INCA_to_7.8, and run the following workflows in the following order:
- Upgrade_Workflow_1_Dimensions
- Upgrade_Workflow_2_Dimensions
- Upgrade_Workflow_3_Facts
- Upgrade_Workflow_4_Facts
- Upgrade_Workflow_5_Facts

If the Usage Accelerator subject area is part of the data warehouse, run the Upgrade_From77_to78_for_UsageAccelerator workflow, which is in the Upgrade_INCA_to_7.8 folder.

In the DAC, run the Complete ETL execution plan as a refresh (to populate new data warehouse entities).

To verify that the data migrated successfully, make sure the new tables and columns in the schema are populated.

## Migrating Data Warehouse Data from Version 7.7 to 7.8.x

Follow this procedure to migrate data from the Siebel Data Warehouse version 7.7 to version 7.8.x for Siebel Business Applications.

**To migrate data warehouse data from version 7.7 to 7.8.x**

1. Configure the DAC:
   - In the DAC, navigate to Setup > Database Connections.
In the Tables subtab, set the Refresh Date to null for the source tables S_SRC and S_SRC_DCP. This step performs a full load on the S_SRC and S_SRC_DCP tables. This step is required because the image tables corresponding to these tables were used in a previous release, and, therefore, need to be refreshed.

2 Execute the Upgrade 7.7 DW to 7.8 DW execution plan:
   a Navigate to the Execute view.
   b In the Execution Plans tab, select Upgrade 7.7 DW to 7.8 DW.
   c Click Run Now.

3 In the Informatica Workflow Manager, navigate to the folder, Upgrade_INCA_to_7.8, and run the following workflows in the following order:
   a Upgrade_Workflow_1_Dimensions
   b Upgrade_Workflow_2_Dimensions
   c Upgrade_Workflow_3_Facts
   d Upgrade_Workflow_4_Facts
   e Upgrade_Workflow_5_Facts

4 If the Usage Accelerator subject area is part of the data warehouse, run the Upgrade_From77_to78_for_UsageAccelerator workflow, which is in the Upgrade_INCA_to_7.8 folder.

5 In the DAC, run the Complete ETL execution plan as a refresh (to populate new data warehouse entities).

6 To verify that the data migrated successfully, make sure the new tables and columns in the schema are populated.

Migrating Data Warehouse Data from Version 7.7.1.x to 7.8.x

Follow this procedure to migrate data from the Siebel Data Warehouse version 7.7.1.x to version 7.8.x for Siebel Business Applications.

To migrate data warehouse data from version 7.7.1.x to 7.8.x

1 In the Informatica Workflow Manager, navigate to the folder, Upgrade_7.7.1_to_7.8, and run the following workflows in the following order:
   a Update_Dimensions
   b Update_Dimensions_Unspecified
   c Update_Facts

2 If the Usage Accelerator subject area is part of the data warehouse, run the Upgrade_From77_to78_for_UsageAccelerator workflow, which is in the Upgrade_INCA_to_7.8 folder.
3 In the DAC, run the Complete ETL execution plan as a refresh (to populate new data warehouse entities).

4 To verify that the data migrated successfully, make sure the new tables and columns in the schema are populated.

**Migrating Data for Siebel Industry Applications**

In this task, you run an upgrade execution plan to populate data in the new Siebel Data Warehouse schema.

**NOTE:** If you do not have historical data, such as slowly changing dimensions or accumulated snapshots, such as pipeline facts, you can perform a full load ETL to populate 7.8.x data. If you perform a full load ETL, do not perform the data migration steps listed in the following sections.

This section includes information on migrating data for the following upgrade scenarios:

- Migrating Data Warehouse Data from Version 7.5.x to 7.8.x for Industry Applications on page 24
- Migrating Data Warehouse Data from Version 7.7 to 7.8.x for Industry Applications on page 25
- Migrating Data Warehouse Data from Version 7.7.1.x to 7.8.x for Industry Applications on page 26

**Migrating Data Warehouse Data from Version 7.5.x to 7.8.x for Industry Applications**

Follow this procedure to migrate data for Siebel Industry Applications from the Siebel Data Warehouse version 7.5.3 to version 7.8.x.

**To migrate data warehouse data from version 7.5.x to 7.8.x for Industry Applications**

1 In the Informatica Workflow Manager, navigate to the folder, Upgrade_7.5.XtoINCA_1, and run the following workflows in the following order:

   a Upgrade_DAW
   b Upgrade_R_Imag
   c Upgrade_Unspecifieds
   d Upgrade_Agree
   e Upgrade_Asset
   f Upgrade_Opty
   g Upgrade_Order
   h Upgrade_Quote
   i Upgrade_Response
   j Upgrade_ServiceRequest
k Upgrade_Others
l Upgrade_Visibility
m UpgradeSlowlyChangingDimensionStartDates

2 In the Informatica Workflow Manager, navigate to the folder, Upgrade_7.5.XtoINCA_2, and run the following workflows in the following order:
   a SIA_Upgrade_R_Image
   b SIA_Upgrade_Unspecifieds
   c LS_Upgrade_ActivityProduct
   d LS_Upgrade_Others
   e SIA_Upgrade_Household
   f FINS_Upgrade_Visibility
   g SIA_UpgradeSlowlyChangingDimensionStartDates

3 Configure the DAC:
   a In the DAC, navigate to Setup > Database Connections.
   b In the Tables subtab, set the Refresh Date to null for the source tables S_SRC and S_SRC_DCP.
      This step performs a full load on the S_SRC and S_SRC_DCP tables. This step is required because the image tables corresponding to these tables were used in a previous release, and, therefore, need to be refreshed.

4 Execute the Upgrade 7.7 DW to 7.8 DW execution plan:
   a Navigate to the Execute view.
   b In the Execution Plans tab, select Upgrade 7.7 DW to 7.8 DW.
   c Click Run Now.

5 In Informatica Workflow Manager, navigate to the folder, Upgrade_INCA_to_7.8._1, and run the workflows in the order listed in the folder.

6 If the Usage Accelerator subject area is part of the data warehouse, run the workflows in the folder, Upgrade_From77_to78_for_UsageAccelerator.

7 In the DAC, run the Complete ETL execution plan as a refresh (to populate the new data warehouse entities).

8 To verify that the data migrated successfully, make sure the new tables and columns in the schema are populated.

Migrating Data Warehouse Data from Version 7.7 to 7.8.x for Industry Applications
Follow this procedure to migrate data for Siebel Industry Applications from the Siebel Data Warehouse version 7.7 to version 7.8.x.
To migrate data warehouse data from version 7.7 to 7.8.x for Industry Applications

1. **Configure the DAC:**
   a. In the DAC, navigate to Setup > Database Connections.
   b. In the Tables subtab, set the Refresh Date to null for the source tables S_SRC and S_SRC_DCP.
      This step performs a full load on the S_SRC and S_SRC_DCP tables. This step is required because the image tables corresponding to these tables were used in a previous release, and, therefore, need to be refreshed.

2. **Execute the Upgrade 7.7 DW to 7.8 DW execution plan:**
   a. Navigate to the Execute view.
   b. In the Execution Plans tab, select Upgrade 7.7 DW to 7.8 DW.
   c. Click Run Now.

3. In Informatica Workflow Manager, navigate to the folder, Upgrade_INCA_to_7.8.1, and run the workflows in the order listed in the folder.

4. Navigate to the folder, Upgrade_INCA_to_7.8.2, and run the workflows in the order listed in the folder.

5. In the DAC, run the Complete ETL execution plan as a refresh (to populate the new data warehouse entities).

6. To verify that the data migrated successfully, make sure the new tables and columns in the schema are populated.

Migrating Data Warehouse Data from Version 7.7.1.x to 7.8.x for Industry Applications

Follow this procedure to migrate data for Siebel Industry Applications from the Siebel Data Warehouse version 7.7.1.x to version 7.8.x.

To migrate data warehouse data from version 7.7.1.x to 7.8.x for Industry Applications

1. In Informatica Workflow Manager, navigate to the folder, Upgrade_INCA_to_7.8.1, and run the workflows in the order listed in the folder.

2. Navigate to the folder, Upgrade_INCA_to_7.8.2, and run the workflows in the order listed in the folder.

3. In the DAC, run the Complete ETL execution plan as a refresh (to populate new data warehouse entities).

4. To verify that the data migrated successfully, make sure the new tables and columns in the schema are populated.
Migrating Data for Analytics Bridge Applications

In this task, you run an upgrade execution plan to populate data in the new Siebel Data Warehouse schema.

This section includes information on migrating data for the following upgrade options:

- Migrating Data Warehouse Data from Analytics 7.5.3 to Analytics Bridge - 7.5 on page 27
- Migrating Data Warehouse Data from Analytics 7.5.3 SIA to Analytics Bridge - 7.5 SIA on page 28

Migrating Data Warehouse Data from Analytics 7.5.3 to Analytics Bridge - 7.5

Follow this procedure to migrate data warehouse data from Analytics 7.5.3 to the Analytics Bridge - 7.5.

To migrate data warehouse data from Analytics 7.5.3 to Analytics Bridge - 7.5

1. In the Informatica Workflow Manager, navigate to the folder, Upgrade_7.5.XtoINCA, and run the following workflows in the following order:
   
a. Upgrade_DAW
   b. Upgrade_R_Image
   c. Upgrade_Unspecifieds
   d. Upgrade_Agree
   e. Upgrade_Asset
   f. Upgrade_Opty
   g. Upgrade_Order
   h. Upgrade_Quote
   i. Upgrade_Response
   j. Upgrade_ServiceRequest
   k. Upgrade_Others
   l. Upgrade_Visibility
   m. UpgradeSlowlyChangingDimensionStartDates

2. In the DAC, run the Complete ETL execution plan as a refresh (to populate new data warehouse entities).

3. To verify that the data migrated successfully, make sure the new tables and columns in the schema are populated.
Migrating Data Warehouse Data from Analytics 7.5.3 SIA to Analytics Bridge - 7.5 SIA
Follow this procedure to migrate data warehouse data from Siebel Business Analytics 7.5.3 SIA to the Analytics Bridge - 7.5 SIA.

To migrate data warehouse data from Analytics 7.5.3 SIA to Analytics Bridge - 7.5 SIA

1. In the Informatica Workflow Manager, navigate to the folder, Upgrade_7.5.XtoINCA_1, and run the following workflows in the following order:
   a. Upgrade_DAW
   b. Upgrade_R_Image
   c. Upgrade_Unspecifieds
   d. Upgrade_Agree
   e. Upgrade_Asset
   f. Upgrade_Opty
   g. Upgrade_Order
   h. Upgrade_Quote
   i. Upgrade_Response
   j. Upgrade_ServiceRequest
   k. Upgrade_Others
   l. Upgrade_Visibility
   m. UpgradeSlowlyChangingDimensionStartDates

2. In the Informatica Workflow Manager, navigate to the folder, Upgrade_7.5.XtoINCA_2, and run the following workflows in the following order:
   a. SIA_Upgrade_R_Image
   b. SIA_Upgrade_Unspecifieds
   c. LS_Upgrade_ActivityProduct
   d. LS_Upgrade_Others
   e. SIA_Upgrade_Household
   f. FINS_Upgrade_Visibility
   g. SIA_UpgradeSlowlyChangingDimensionStartDates

3. In the DAC, run the Complete ETL execution plan as a refresh (to populate new data warehouse entities).

4. To verify that the data migrated successfully, make sure the new tables and columns in the schema are populated.
Verifying ETL Customizations

While upgrading the Informatica Repository, you copied the Custom folder, which contained your mapping customizations, from your previous Informatica Repository to the newly created Informatica Repository. Then, when you migrated data, you ran the Complete ETL execution plan as a refresh, which populated data warehouse entities. Now, to verify that your custom mappings were upgraded successfully, check the DAC and Informatica log files to confirm there were no errors during the Complete ETL process.

Process of Upgrading the Analytics Repository

This process merges your customizations of a prior release of the repository with a new version.

To upgrade the Siebel Business Analytics repository, perform the following tasks:

- Preparing for the Analytics Repository Upgrade on page 30
- Trimming the Analytics Repositories on page 30
- Equalizing the Analytics Repositories on page 32
- Merging the Analytics Repositories on page 33
- Fixing Analytics Repository Merge Errors on page 34
- Regression Testing the Analytics Repository Merge on page 34

The tasks in this section refer to multiple versions of the Analytics repository. Table 4 provides the names and descriptions of the repositories used in the examples in this section.

<table>
<thead>
<tr>
<th>Name of Repository</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SiebelAnalytics_7x.rpd</td>
<td>The standard Siebel Business Analytics repository for the version you are upgrading from.</td>
</tr>
<tr>
<td>SiebelAnalytics_78x.rpd</td>
<td>The standard Siebel Business Analytics repository for the version you are upgrading to.</td>
</tr>
<tr>
<td>Customer_SiebelAnalytics.rpd</td>
<td>The Siebel Business Analytics repository that contains your customizations for the version you are upgrading from.</td>
</tr>
<tr>
<td>Merged_Repository_SiebelAnalytics_78x.rpd</td>
<td>The Siebel Business Analytics repository that contains your customizations for the version you are upgrading to.</td>
</tr>
</tbody>
</table>
Preparing for the Analytics Repository Upgrade

Follow this procedure to prepare for the Siebel Business Analytics repository upgrade.

This task is a step in the Process of Upgrading the Analytics Repository.

To prepare for the Analytics repository upgrade

1. Use the Analytics Server Administration Tool’s Compare Repositories feature to analyze the differences between your existing Analytics repository and the new version of the repository to which you are upgrading. Note where elements have been created, removed, or changed in the new version. Consider whether you can use the new metadata and retire customizations you made in the existing repository.

   For instructions on how to use the Administration Tool’s Compare Repositories feature, see Siebel Business Analytics Server Administration Guide.

2. Set up a directory for the merge process, such as\SiebelAnalyticsUpgrade, and create the following subfolders:
   - Original
   - AfterTrim
   - AfterEqualize
   - AfterMerge
   - AfterManualWork
   - AfterRegressions

3. Copy the original repository (for example, SiebelAnalytics_7x.rpd), the production repository (for example, Customer_SiebelAnalytics.rpd), and the repository from the latest installation (for example, SiebelAnalytics_78x.rpd) into the \SiebelAnalyticsUpgrade\Original folder.

Trimming the Analytics Repositories

This task is a step in the Process of Upgrading the Analytics Repository.

Trimming the repositories reduces the time and complexity involved in the merge process. It also helps with metadata maintenance and performance efforts.

Trimming a repository involves deleting objects that you do not use. You might consider these objects to be irrelevant at the levels of the subject area, logical table, or individual column. Complete this step by either visually inspecting and manually deleting the objects that are not required, or by using the Import from the Repository feature of the Analytics Server Administration Tool.

To determine which objects might be irrelevant, make a list of the reports used by business users, and then in Siebel Answers, determine the subject areas that are used for the different reports. The subject area indicates which presentation catalogs are in use. For instructions on using Siebel Answers, see Siebel Business Analytics User Guide.
To trim the Analytics repositories

1. Copy the three repositories in the directory \SiebelAnalyticsUpgrade\Original into the \SiebelAnalyticsUpgrade\AfterTrim folder.

2. Delete from the three repositories all the presentation catalogs that have been identified as not in use. For example, if you are using Siebel Business Applications and not Siebel Industry Applications, delete all the Presentation Catalogs beginning with Pharma.

3. Using the Query Repository Utility, identify the business models that are no longer in use or will not be used after the upgrade, and delete them in all three repositories:
   a. In the Analytics Server Administration Tool, navigate to Tools > Query Repository.
   b. In the Name field, enter the asterisk (*) wildcard character.
   c. In the Type field, enter Business Model.
   d. Click the Filter button:
      - In the Item drop-down list, select Related to.
      - In the Operator column, select <>.
      - Click the Ellipsis button, and then select Set Condition for Presentation Catalog.
      - Click OK.
   e. Click the Query button.
      A list of the business models that have no related presentation catalogs appears in the window.
   f. Select the business model you want to delete, and then click Delete.
   g. Click Yes to confirm you want to delete the object.

4. Identify the databases that are not in use and that will not be used after the upgrade, and delete them in the three repositories.

   CAUTION: Do not delete the Siebel transactional database (OLTP) in the physical layer, because it is used by the authorization initialization blocks.

5. Identify the initialization blocks that do not have connection pools, and delete them in all three repositories.

At the end of this process, the three repositories in the \SiebelAnalyticsUpgrade\AfterTrim folder are significantly smaller in size than in the previous stage if the process runs correctly. These repositories serve as the input for the next stage of equalization.
Equalizing the Analytics Repositories

The Merge feature in the Analytics Server Administration Tool relies on a change detection algorithm to determine the changes that need to be made to upgrade repositories correctly. For the algorithm to work correctly, it has to determine which objects in the three repositories (SiebelAnalytics_7x.rpd, SiebelAnalytics_78x.rpd, and Customer_SiebelAnalytics.rpd) are equivalent. Equivalence between objects is established by running the equalizerpds executable (equalizerpds.exe) in the \SiebelAnalytics\Bin folder.

The equalizerpds executable file has several mechanisms for determining whether an object in two different repositories is semantically the same:

- **Fully Qualified Name.** If an object in one repository has the same fully qualified name as another object of the same class in another repository, then the two objects are declared equal.

- **Simple String Substitution.** Equivalence can be declared between two objects of the same class in two repositories whose only difference is that some key characters in their names differ. The equalizerpds executable file ignores those characters while checking fully qualified names. For example, "Core"."W\_DAY\_D" might be considered equivalent to "Core"."W DAY D" if the characters "\_" and " " have been declared as equivalent.

- **Rename File.** When none of the preceding rules are applicable, equivalence can be manually declared using a script as input to the equalizerpds executable file. Siebel Systems ships the rename files (MAP) for the most common upgrade paths. You must also create your own rename files for customizations not covered in the files that Siebel Systems ships. You can open and edit the rename files in Microsoft Excel.

The syntax of the equalizerpds command is as follows:

```
equalizerpds.exe -A userid1 [-B [password1]] -C base_repository_name -D userid2 [-E [password2]] -F repository2_name [-J udml_utf8_file_name_equalization] [-O output_repository_name] [-X] [-Y equalStringSet]
```

- `-X` Treat 'Factxxxx' as 'Fact' in Business Model.
- `-Y` Treat the characters as equals.
- `-J` repository2 in case of conflict.
- `/?` Display this usage information and exit.

**To equalize a repository**

1. Run equalizerpds.exe to equalize the repository from the latest installation (for example, SiebelAnalytics_78x.rpd) with the original repository (for example, SiebelAnalytics_7x.rpd). An example of the equalizerpds command is as follows:

```
equalizerpds.exe -A Administrator -B SADMIN -C \SiebelAnalyticsUpgrade\AfterTrim\SiebelAnalytics_7x.rpd
```

```
-D Administrator
-E SADMIN -F \\SiebelAnalyticsUpgrade\AfterTrim\SiebelAnalytics_78x.rpd
```
The MAP files are located in the \SiebelAnalytics\Bin directory or the \SiebelAnalytics\Upgrade directory.

If the equalizerpds.exe executable file runs correctly, no errors are returned.

2 Run equalizerpds.exe to equalize your customized repository (for example, Customer_SiebelAnalytics.rpd) with the original repository (for example, SiebelAnalytics_7x.rpd). An example of the equalizerpds command is as follows:

equalizerpds -A Administrator -B SADMIN -C \\SiebelAnalyticsUpgrade\AfterTrim\SiebelAnalytics_7x.rpd

-D Administrator

-E SADMIN -F \\SiebelAnalyticsUpgrade\AfterTrim\Customer_SiebelAnalytics.rpd

-O \\SiebelAnalyticsUpgrade\AfterEqualize\Customer_SiebelAnalytics.rpd

The execution of equalizerpds that equalizes the customer repository with the original repository does not use the rename file.

Make sure that the original repository is copied unchanged into its new location so that after running the script, all three repositories are contained within the \SiebelAnalyticsUpgrade\AfterEqualize directory.

Merging the Analytics Repositories

This task is a step in the Process of Upgrading the Analytics Repository.

In this procedure you execute the main algorithm to upgrade the repository. For more information on merging the Siebel Business Analytics repositories, see Siebel Business Analytics Server Administration Guide.

To merge versions of the Analytics repositories

1 Open the repository from the latest installation (for example, SiebelAnalytics_78x.rpd) in the \SiebelAnalyticsUpgrade\AfterEqualize directory.

2 Save the repository with a new name, for example, Merged_Repository_SiebelAnalytics_78x.rpd. This new repository will contain the final results of the upgrade.

3 From the Administration Tool menu bar, choose File > Merge.
4 In the Select Original Repository dialog box, select the original repository (for example, SiebelAnalytics_7x.rpd).

5 Enter the password, and click OK.

6 Click Select for the Modified Repository field.

7 In the Select Modified Repository dialog box, select the repository that contains the customizations you made to the previous version of the Analytics repository.

8 Click Open, type the password, and then click OK.

9 In the Decision drop-down list, select the action you want to take regarding the repository change, or accept the default action.

10 To locate subsequent rows with empty Decision fields, click the Decision header cell.

When all rows have a value in the Decision field, the Merge button is enabled.

11 Click Merge.

A message appears indicating that the merge is complete.

12 Save the repository.

This repository serves as the input for the next stage.

13 Copy the repository to the directory \SiebelAnalyticsUpgrade\AfterManualWork.

Fixing Analytics Repository Merge Errors

This task is a step in the Process of Upgrading the Analytics Repository.

Many consistency errors and warnings might result from merging different versions of Siebel Business Analytics repositories. Correct these errors manually. After you correct the errors, save the repository, and copy it to the directory \SiebelAnalyticsUpgrade\AfterRegressions.

Regression Testing the Analytics Repository Merge

This task is a step in the Process of Upgrading the Analytics Repository.

In performing a regression test for the Siebel Business Analytics repository merge, the objective is to collect a set of logical SQL statements that are used for reports and to verify that they continue to work with the new metadata. For this purpose, it is recommended that you perform the following procedure.

To perform regression testing

1 Run the reports that are necessary to include in the regression suite. These reports might be a subset of the reports in the Analytics Web catalog.

2 Collect the logical SQL generated in the previous step. You can do this using Usage Tracking or by parsing the query log file.
3. Execute the logical SQL against the old repository using the command line utility nQCmd.exe located in \SiebelAnalytics\Bin, and save the results to a file.

4. Edit the logical SQL test scripts to account for the name changes or modifications resulting from the upgrade.

5. Execute the edited logical SQL against the merged repository, and save the results.

6. Compare the results from the steps above and try to explain the differences. If it is determined that these differences are due to the upgrade process, then you have to correct them manually.

   This repository now contains the merged content from the new SiebelAnalytics_78x.rpd and the production repository.

**Process of Upgrading the Analytics Web Catalog**

To upgrade Oracle's Siebel Business Analytics Web catalog, perform the following tasks:

- **Trimming the Input Web Catalog on page 35**
- **Running the Catalog Upgrade for the Existing Web Catalog on page 35**
- **Merging New and Existing Web Catalogs on page 36**
- **Testing the Results of the Web Catalog Upgrade on page 36**

**Trimming the Input Web Catalog**

This task is a step in the Process of Upgrading the Analytics Web Catalog. Before you upgrade and merge your current Web catalog with the new preconfigured Web catalog, determine which of the existing content you want to keep and which new content you want to incorporate. Review your existing Web catalog and determine the usage patterns of reports and dashboards. Note that some of the preconfigured content in the existing catalog may appear in the new version in a redesigned format. In addition, the new version includes completely new content. After you have decided the content that is to make up your enterprise Web catalog, trim the input Web catalogs using the Catalog Manager. For information on trimming Web catalogs, see Siebel Business Analytics Web Administration Guide.

**Running the Catalog Upgrade for the Existing Web Catalog**

This task is a step in the Process of Upgrading the Analytics Web Catalog. This task generates a new, upgraded Web catalog by migrating your existing reports so that they run from the new presentation catalogs of the upgraded repository. The input to this process is your existing Web catalog, trimmed down as appropriate, from the previous step, “Trimming the Input Web Catalog” on page 35.
You run the catalog upgrade process with the assistance of Siebel Technical Support or onsite Siebel Professional Services. As part of this process, you must provide Siebel Technical Support with a cross-reference file for any custom presentation catalogs and columns.

**Merging New and Existing Web Catalogs**

This task is a step in the Process of Upgrading the Analytics Web Catalog.

In this step you combine your recently upgraded Web catalog with the new preconfigured Web catalog in order to take advantage of the new reports and dashboards. The output of this process is your final enterprise Web catalog. You use the Catalog Manager for this process. For information, see *Siebel Business Analytics Web Administration Guide*.

**Testing the Results of the Web Catalog Upgrade**

This task is a step in the Process of Upgrading the Analytics Web Catalog.

This step ensures that the upgraded reports and the new preconfigured reports are functional and render correct results within the new, merged Web catalog. This step is typically performed by visually inspecting the final results of the complete end-to-end upgrade process.

For upgraded reports, the preferred approach for comparison purposes is to have side-by-side environments, and have users review specific dashboard content between the two environments. Examine not only the look and feel of the application but also the data contained in the reports to make sure the content remains the same. It is recommended that you request users to use various elements of the user interface to validate results, such as global prompts, column selectors, report filters, drills, and navigations, as they normally do on a day-to-day basis.

Also review the overall visibility and administrative settings in the new Web catalog to ensure they are correct. Pay careful attention to the visibility rules that are established for any content that was migrated during the upgrade. You might have to manually adjust these settings.
# Index

## A
- **Analytics Applications**
  - installing 13
- **Analytics Applications upgrade**
  - detailed tasks 11
  - major stages 9
- **Analytics Bridge Applications**
  - migrating data 27
- **Analytics platform**
  - upgrade 13
- **Analytics repository**
  - equalizing 32
  - merge errors 34
  - merging 33
  - regression testing 34
  - trimming 30
  - upgrading 29

## B
- **best practices**
  - preparing to upgrade 8

## D
- **DAC**
  - metadata repository, upgrade 14
- **data**
  - migrating data 21
- **data warehouse schema**
  - upgrade 16

## E
- **ETL**
  - verifying customizations 29

## I
- **Informatica**
  - upgrade 19
  - upgrading repository 19

## P
- **preupgrade**
  - best practices 8
  - points to consider 7

## S
- **Siebel Business Applications**
  - data migration 21
- **Siebel Industry Applications**
  - data migration 24
- **SIF file**
  - importing 17
- **SIF patch**
  - verifying 18

## T
- **transactional database schema**
  - upgrading 17

## U
- **upgrade paths**
  - supported 7

## W
- **Web catalog**
  - merge 36
  - trimming input 35
  - upgrading 35