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1 

Introduction 

Oracle Configuration Controls Governor (CCG) monitors setup data in business-
management applications. It can take “snapshots” that document application setups; 
compare snapshots with one another, to show how application setups differ; and 
employ change tracking to monitor changes. 

This Administration Guide tells how to configure CCG after it is installed, provides 
reference information that will enable you to administer the application over time, and 
tells how to use MetaBuilder — a tool for compiling metadata (detailed information 
about the data structure of the ERP application database).  

As you read through the Administration Guide (and use CCG) you may encounter 
the following terms: 

Systems and Databases 

• CCG Agent: CCG-installed and owned schema in the ERP instance. Used by 
CCG for tasks that require access to the instance. 

• CCG Home schema: Contains all data about your CCG users, security, and 
deployments. Usually named AMHOME. 

• CCG UI: User interface CCG; i.e., the portion of the application with which 
most users and administrators work directly. 

• ERP application: An enterprise-scale application, such as “General Ledger.” 

• ERP application UI: The ERP application’s user interface. 

• ERP instance: Database instance that contains ERP application data. 

• ERP module: Synonymous with ERP application. 

• ERP system: Joins or integrates your ERP applications. 

Using CCG 

• Definition: Collection of one or more programs and their user-specified 
parameters. 

• Job: A sequence of one or more definitions and/or standalone programs 
scheduled for execution. 
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Future jobs are those whose execution has not begun; current jobs are those 
being executed now; past jobs have been completely executed or terminated. 

• Occurrence: Generated when a definition is executed. Contains data about the 
definition’s execution, and reports generated by the definition’s programs. 

• Program: A batch of steps or instructions that can be scheduled for execution in 
a job. 

Standalone programs can be scheduled independently of other programs (in 
contrast to the programs that are part of a definition and therefore always 
scheduled together). 

• Change Tracker: Displays all changes collected by change tracking definitions. 

• Change Tracking Definition: Definition type that monitors changes to ERP 
application setups. 

• Change Tracking Alert: Email message that describes changes to ERP applica-
tion setups. Based on change tracking queries. 

• Change Tracking Query: Filters the data displayed in the change tracker. 

• Change Tracking Trigger: Installed in the ERP instance by the change tracking 
definition; notes events you specify (inserts, updates, deletes) 

• Comparison: Report that identifies differences between two snapshot 
occurrences. 

• Field Description: Field prompt or label that is visible to ERP system users. 

• Object: Group of setup tables to be monitored. Helps you choose the informa-
tion to be monitored without having to grapple with data model or entity rela-
tionships. An object is typically associated with an ERP application setup form 
or page. 

• Snapshot Definition: CCG definition type that reports ERP application setup 
data. 

• Template: Determines the data presented in snapshot occurrences. 
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Initial Configuration 

This chapter shows you step-by-step how to configure Configuration Controls Gov-
ernor 5.5 for the first time. If you’ve already configured CCG 5.5, see Administrative 
Tasks (page 3-1) for tutorials, or Reference (page 4-1) for quick overviews of fea-
tures and options. 

Log In 

To log in to CCG: 

1. Open a web browser window and visit the Secure Login page: 

http://hostname/web-application-name 

In this URL: 

• hostname is the domain name of the web server configured to serve CCG 

• web-application-name is the name of the CCG web application (usually ccg). 

If you have a CCG icon on your desktop; double-clicking it opens this page. 

 

2. If you already have your own CCG username and password, enter them now. 
However, if this is the first time your organization has logged into CCG, use the 
following default login information: 

• Username. amadmin 

• Password. amadmin (case sensitive) 

You must be assigned the Administrator role to access the Home Configuration 
page. The amadmin user has this role. 
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Connecting to Your Email Server 

Complete the following procedure to enable your email server to send CCG email 
alerts — messages that inform users when changes are made to application setups.  

1. Select Administrator > Home Configuration from the menu bar. The Home 
Configuration page appears. 

 

2. Enter the following information: 

• SMTP server domain. The domain name of your mail server. If left blank, 
CCG cannot send email notifications. 

• Port. The port number of your mail server. 

3. Click Save. 

4. Click Test. The Send Test Message from Email Server page appears. 

 

5. Enter From and To addresses, and optionally a Subject, and click Send.  

The page is refreshed, displaying Status information. If the test message is sent 
successfully, but you don’t receive it, first verify that the message isn’t being 
treated erroneously as spam by your incoming mail server or mail client. 

6. When you’re finished, click Back. The Home Configuration page reappears. 

CCG does not use the Oracle Alerts product. It sends email messages directly from 
the database, using Oracle’s UTL_SMTP feature. 

Configure the System Profile 

A system profile records information about this instance of CCG: 

1. Select Administrator > System Profile from the menu bar. The System Profile 
page appears. 
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2. Enter this information: 

• CCG Application Path. The web-application-name portion of the URL 
that summons the Secure Login page. Typically, this value is ccg. (See 
“Log In” on page 2-1). 

• Company Logo. Name of the image file displayed in the upper left corner of 
each page. The file must be located in the images subdirectory of the direc-
tory on the CCG UI server where the CCG web application is deployed. 

• Authentication Mode. There are two options for validating users: 

– RDBMS uses a CCG RDBMS module.  

– LDAP uses an LDAP directory maintained by your organization. This 
eliminates the need for CCG users to enter passwords on the Secure 
Login page. If you choose this option, the following fields are required. 

• LDAP Base Distinguished Name. LDAP entry that identifies an author-
ized user of the LDAP server. 

• LDAP Host. Machine name or IP address where the LDAP server is hosted. 

• LDAP Port. Port number to use when communicating with the host. 

3. Click Save. 

Configure CCG for Each ERP Instance 
You must configure CCG to work with each ERP instance that you want to manage. 
Broadly speaking, you will perform these tasks for each instance: 

• Define a new instance in CCG. 

• Create CCG Agent tablespaces for the instance. The CCG Agent lets CCG 
perform tasks that require access to the instance’s data. 

• Configure CCG Agent parameters. 

• Configure CCG parameters. 

Define a New ERP Instance 

To define a new ERP instance: 

1. Select Administrator > ERP Instances from the menu bar. If one or more 
instances have been defined already, a list of instances appears. 
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2. Click Add ERP Instance. A new definition page appears. 

 

 

3. Enter the following information: 

• ERP Instance. Short name that identifies the ERP instance 

• Description. Longer, more descriptive name for the ERP instance. For 
example, if Instance name is Dev, Description could be Development 
Instance 

• Service Name. TNSNAMES service name that will be used when CCG 
creates a database link from the CCG Home schema to the new CCG Agent 
schema on the ERP instance. This name must be present in the TNSNAMES 
configuration for the CCG Home instance’s Oracle Home. 

• ERP Version. ERP application version 

4. Click Save. The page is refreshed.  

Create Tablespaces 

If the following tablespaces already exist, there is no need to recreate them. 

1. Select Administrator > Tablespaces from the menu bar. The Tablespaces 
Workbench appears. 

 

2. Click Add Tablespace. The Tablespaces page appears. 
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3. Enter the following “Tablespace Basics” information: 

• Instance. Click the icon and select the ERP instance. 

• Type. Click the icon and select AM_AGENT DATA. 

• Name. AM_AGENT_D 

• Initial extent (KB). 64 

• Next extent (KB). 64 

Tablespaces will be locally managed with user-defined extents. If you must 
define a tablespace differently, create it manually and enter its name in the 
Name field. There will be a warning the tablespace exists; choose yes to continue. 

4. Click Save. The page refreshes, with a new Datafiles section below Tablespace 
Basics. The new section contains these fields: 

5. Enter the following “Add Datafile” information: 

• Datafile Name: Enter the full path from the root directory to a new datafile 
named AM_AGENT_D1.DBF. 

• Max Size (MB): 1000  

About Max Size: The datafile’s size will initially be 10 percent of this 
value, and will increase in 10 percent increments until Max Size is reached. 

6. Click Save. You will be asked for the system password. After you enter it, the 
page refreshes again. 

7. Click Create Tablespace. A job to create the tablespace will be submitted for 
immediate execution. 

8. Select View > View Current Jobs, and monitor the job’s progress. 

9. Once the job has completed, return to the Tablespace Workbench by selecting 
Administrator > Tablespace Workbench. 

10. Create the following additional tablespace(s) using the steps above: 

An index tablespace for the AM_AGENT DATA tablespace you’ve already created: 

• Instance. The ERP instance 

• Type. AM_AGENT INDEX 

• Name. AM_AGENT_X 

• Initial extent (KB). 64 

• Next extent (KB). 64 

• Datafile Name. Enter the full path from the root directory to a new datafile 
named AM_AGENT_X1.DBF 

• Max Size (MB). 1000 

A CCG data tablespace: 

• Instance. The ERP instance 

• Type. APS_DATA 
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• Name. APS_AGENT_D 

• Initial extent (KB). 64 

• Next extent (KB). 64 

• Datafile Name. Enter the full path from the root directory to a new datafile 
named APS_AGENT_D1.DBF 

• Max Size (MB). 500 

A corresponding index tablespace: 

• Instance. The ERP instance 

• Type. APS_INDEX 

• Name. APS_AGENT_X 

• Initial extent (KB). 64 

• Next extent (KB). 64 

• Datafile Name. Enter the full path from the root directory to a new datafile 
named APS_AGENT_X1.DBF 

• Max Size (MB). 500 

Configure CCG Agent 

The CCG  Agent is a CCG-installed and owned schema in the ERP instance: 

1. Select Administrator > ERP Instances from the menu bar. 

2. In the ERP Instance Workbench, click Edit to the right of the ERP instance’s 
name. 

3. To the far right of CCG Agent, click Edit. The Configure CCG Agent 
Component section appears. 

 



 

 Initial Configuration 2-7 

4. Revise the following information if necessary: 

• CCG Agent Username. For the CCG Agent schema. Created on the ERP 
instance if it does not exist. 

Default value: AM_AGENT 

• Database Link from HOME to Agent. Needed to transfer metadata from the 
CCG Home instance to the ERP instance, and to execute any process on the 
ERP instance. Created on the CCG Home instance if it does not exist. 

The value must contain no more than 20 characters. 

• ERP Username. Existing ERP instance user with full access to the ERP 
instance’s data. 

– Oracle E-Business Suite: The typical value is APPS 

– PeopleSoft Enterprise: The typical value is SYSADM 

– Siebel CRM Applications: The typical value is SIEBEL 

• ERP User Database Link. Needed to access ERP application information. 
Created on the ERP instance if it does not exist. 

The value must contain no more than 20 characters. 

• Temporary Tablespace Name. Name of the ERP instance’s temporary 
Tablespace. 

• Database Version. ERP instance’s database version. 

Example: 9.2.0.6 

• Remote File System Directory of the $ORACLE_HOME. File system 
directory that corresponds to the $ORACLE_HOME of the ERP instance. 

• Remote File System Directory of the UTL_FILE_DIR. File system 
directory specified by the UTL_FILE_DIR parameter in the ERP instance’s 
INIT.ORA file. 

Tells CCG where to read and write files that reside on the ERP instance. 

• File System Directory IMP/EXP/SQLPLUS Binaries. File system directory 
path where these executables reside on the ERP instance. 

• Remote Instance File System Directory Delimiter. The character used by 
your ERP instance’s file system to separate elements within pathnames. 

– Unix/Linux: / (forward slash) 

– Windows: \ (backslash) 

• Export/Import Buffer Value. Sets the BUFFER parameter, which is used 
when invoking the IMP and EXP utilities. Default value: 100000 

• ISO language. Default value: US 

• Parallel Workers. Default value: 4 

• Database Host. Server where database resides. 

• Database Port. Port for installing and launching the database. 
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• Database SID. Name of the database that contains the ERP application 
schema. 

• Analyze Date Tolerance: Default value: 7 

Informia Subset users: Subset will not perform a row count if there is an 
existing one that was created within this many days. 

• APPSORA.env. Default value: APPSORA.env 

5. Click the Save button near the bottom of the page. You will be prompted for the 
following passwords: AM_AGENT, ERP USER, SYSTEM. Be sure to record your 
entries for later use. 

6. Click the Configure button. An ERP instance configuration job is submitted, 
and the page is refreshed. The Latest Status column will indicate the job’s status. 
To update the Latest Status column, click the Refresh button at the bottom of 
the page. 

7. When the job completes, the Latest Status indicates that configuration of the 
CCG Agent either succeeded or failed. If it failed: 

a. Click Edit to the right of CCG Agent. 

b. Click the Remove button near the bottom of the page. 

c. Select Jobs > View Current Jobs from the menu bar. Find the instance 
configuration job that was created when you clicked the Configure button, 
and view the job’s logs/details to determine the cause of the failure.  

d. Resolve the cause of the failure. 

e. Select Administrator > ERP Instances, edit the instance definition, click 
Edit to the right of CCG Agent, and click the Configure button. 

When you configure the CCG Agent, a job containing a number of programs is 
scheduled for immediate execution. Information about those programs is provided 
below. All programs (other than the noted exception) must complete without error. 

• Configure CCG Agent [instance name]. The main program that calls other 
programs to perform specific tasks. 

• Drop SYSTEM Database Link. Drops the database link in the CCG Home 
schema to the SYSTEM user on the ERP instance, if one exists. 

If one does not exist, this job will end in error. You can safely ignore this error. 

• Create SYSTEM Database Link. Creates a database link for the CCG Home 
schema to connect as SYSTEM on the ERP instance. This link is used to create 
the CCG Agent schema on the ERP instance. 

• Create CCG Agent User. This user (or schema) will contain all CCG packages 
and tables. 

• Grant User Privileges and Roles. Grants necessary privileges and roles to the 
CCG Agent user. 

• Create CCG Agent Database Link. Creates a database link for the CCG 
Home schema user to connect to the CCG Agent schema on the ERP instance. 
This link is used to create CCG Agent objects. 
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• Create CCG Agent Schema Objects. Creates tables and indexes used by CCG 
Agent. 

• Compile Target Packages. Compiles all packages used by the CCG Agent. 

• Install Java Classes and Allocate File Permissions. Installs Java components 
used by the CCG Agent. 

• Create ERP Database Link. Creates a database link for the CCG Home 
schema user to connect to the ERP User schema on the ERP instance. 

• Populate CCG Agent Seed Data. Populates the CCG Agent objects’ seed data. 

• Drop SYSTEM Database Link. Drops the database link from the CCG Home 
schema to the SYSTEM user on the ERP instance. 

Configure CCG  

To configure CCG: 

1. To the far right of Configuration Controls Governor, click Edit. The page is 
refreshed, and the lower portion displays fields for configuring CCG (depending 
on your installation, tables might be listed in the Mappings section). 

 

2. Enter the following information: 

• APPLSYS Username. Oracle E-Business Suite users: ERP instance’s APPLSYS 
username. PeopleSoft Enterprise users: ERP instance’s SYSADM username. 

• HR Username. Oracle E-Business Suite users: ERP instance’s HR 
username. 
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• Remote Instance Directory of the FND_TOP. Oracle E-Business Suite 
users: ERP instance’s $FND_TOP directory. 

• Baseline Definition Owner. CCG User who will own the snapshot and 
change tracking definitions that will be generated automatically when you 
complete this configuration process. 

• Remote Instance Directory of the APPL_TOP. Oracle E-Business Suite 
users: ERP instance’s $APPL_TOP directory. 

• Freeze Table Overlays. If you have moved or renamed any ERP tables or 
views from their defaults, enter N to map them (which will make them visi-
ble to CCG). The default value is Y. 

• Descriptive Flexfields Flag. Oracle E-Business Suite users: Enter Y to cap-
ture all specific values entered in every Descriptive Flexfield of every setup 
object in this ERP instance. The default value is N. To report on the struc-
ture or definition of a Descriptive Flexfield, use the System Administration 
application’s Descriptive Flexfield Segments object. 

• Freeze Definition Flag. This value is not used, and so may be set to Y, N, 
or blank.  

• Remote APPLTOP (Y/N). Oracle E-Business Suite users: Enter Y if your 
APPL_TOP is on a different physical server than the ERP instance. The de-
fault value is N. 

• Remote APPLTOP Server Name. Oracle E-Business Suite users: Name of 
server , if your APPL_TOP is on a different computer than the ERP instance. 

3. Click Save. 

4. Specify the applications that CCG will be able to monitor on this ERP instance. 
You can: 

• Click Add Application to add applications one-by-one, clicking Save after 
selecting each application. 

• Click Add Suite to add all applications in a product suite. 

5. Click the Configure button. You will be prompted for the following passwords: 
AM_AGENT, ERP USER, SYSTEM. Be sure to record your entries for later use. 

6. Once you supply the passwords, an ERP instance configuration job is submitted 
and the page is refreshed. The Latest Status column indicates the job status. To 
update the Latest Status column, click the Refresh button at the bottom of the page. 

7. When the job completes, the Latest Status indicates that configuration of CCG 
either succeeded or failed. If it failed: 

a. Click Edit to the right of CCG. 

b. Click the Remove button near the bottom of the page. 

c. Select Jobs > View Current Jobs from the menu bar. Find the instance 
configuration job that was created when you clicked the Configure button, 
and view the job’s logs/details to determine the cause of the failure.  

d. Resolve the cause of the failure. 

e. Select Administrator > ERP Instances, edit the instance definition, click 
Edit to the right of CCG, and click the Configure button. 
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When you configure CCG, a job containing a number of programs is scheduled for 
immediate execution. Information about those programs is provided below. All pro-
grams must complete without error. 

• Configure CCG. Main configuration program that calls all other programs to 
perform specific tasks. 

• Create Target Schema Objects (OA 10.7-specific). Oracle E-Business Suite 
10.7 users: Creates CCG Views and Synonyms. 

• Create Target Schema Objects (OA 11.0.3 and 11i-specific). Oracle E-
Business Suite 11.0.3 and 11i users: Creates CCG Views and Synonyms. 

• Create Target Schema Objects. Creates CCG database objects (e.g., tables, 
sequences, and indexes). 

• Create tick_ct_target_pkg. Creates CCG change tracking package specifica-
tion and body. 

• Run Target Synchronize. Copies metadata to the ERP instance and verifies 
that there are no conflicts with the Oracle Data Dictionary. 

If, owing to customizations, CCG cannot locate tables or views, or locates the same 
table name within more than one schema, it will populate the Mappings section. 

1. For each item: Click Edit to the item’s right and specify the object that CCG 
should use. If two schemas own tables with the same name, enable only one 
table. 

2. Click the Configure button again and follow the preceding steps. 

Create Users, Roles, and Security Groups 

Typically, each CCG user has his or her own username and password. This lets you 
control each user’s login access, roles and permissions. Roles determine the menu 
items the user sees; permissions control the ERP data the user can access. Rather 
than granting permissions directly to users, you grant them to security groups, then 
assign users to the security groups. Users who do not belong to any security groups 
will not be able to access any ERP data. Similarly, users who do not have any roles 
will not see any CCG menu items. 

If you are configuring CCG for the first time, create the users and roles specified in 
your implementation plan. Then create security groups and assign your users to them. 

At minimum, you must: 

• Create at least one new user (unless you will be the only person using CCG). 

• Assign each possible role to at least one user (unless there are roles that you do 
not wish to assign to any user). 

• Create at least one security group. 

• Assign each user to at least one security group (except for users who should not 
have access to any ERP data). 

The simplest possible setup would be to assign all roles to yourself, create one 
security group with access to all ERP data, and assign yourself to that group. 
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Creating Users 

To create a CCG user: 

1. Select Administrator > Users from the menu bar. The Users page appears. 

 

2. Click the Add User button. A blank definition appears. 

 

3. Enter the following information: 

• Full name. User’s full name. The name may consist of letters, spaces,  
’ (apostrophe), and - (hyphen); other characters are not allowed. 

• Department. User’s department or organization. Use any combination of 
letters, digits, spaces, and - (hyphen); other characters are not allowed.  

• Email. The user will receive alerts at this address. 

• Login ID. User’s CCG login ID. The ID may consist of letters and digits 
only; spaces and other characters are not allowed. 

• Password. Password for the new user. This data is encrypted before it is 
stored. Not required if LDAP Authentication is used; see “System Profile” 
(page 4-13). Use up to 30 characters, excluding these:  !  |  /  =  $  &  @  "  '  `  , 

• Confirm password. Re-enter the password to confirm. 

• Valid from. First day user can log in 

• Valid until. Last day user can log in (optional). 

• Enabled. Enables the user to log in; if not checked, the user cannot log in. 
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4. Click Save. The page is refreshed, and a Roles section is added. 

5. In the Roles section, click on the Add Role button. The the following Roles 
page appears. 

 

6. Enter the following information to assign a role to the user: 

• Role. Select a role from the drop-down list. 

• Enabled. Enables this role for this user. 

• Valid from. First day the user will have this role. 

• Valid until. Last day the user will have this role (optional). 

The following roles are available for CCG 5.5. 

• CCG Developer: Create and edit templates. Use MetaBuilder to create 
metadata — information about ERP objects for which CCG may take or 
compare snapshots, or track changes.  

• Change Tracking Scheduler: Schedule change tracking definitions for 
execution. 

• Snapshot Scheduler: Schedule snapshot definitions for execution, and com-
pare snapshot occurrences. 

• CCG User: Create and edit snapshots and change tracking. 

• Administrator. Perform tasks accessible from the Administrator menu bar. 

7. Click the Save button. The page refreshes, displaying a summary of the user’s roles. 

 

8. To add another role, click Add Role again. The new role is added when you 
click the Save button. You can add as many roles as you wish. 

9. Click the Back button. The definition page reappears. 

10. Click the Save button. The new definition is saved and the Users page appears. 
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Adding Security Groups 

To add a security group: 

1. Select Administration > Security Groups from the menu bar. The Security 
Groups page appears. 

 

2. Click Add Security Group. A blank definition appears. 

 

3. Enter the following information: 

• Name. The group’s name. 

• Description. A short description of the group. 

• ERP Instance. The ERP instance that the group can work with. 

• Enabled. When checked, the group is active. 

4. Click Save. The page is refreshed, displaying the Permissions and Users 
sections. 
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5. Click Add Permission. The Permissions page appears. 

 

6. Enter the following information: 

• Scope and Values. Each entry in the Scope field is a class of items that give 
access to ERP data — in Oracle EBS 11i, applications, business groups, organi-
zation units, and sets of books; in EBS R12, applications, business groups, 
organization units, ledger sets, and ledgers; in PeopleSoft, applications and 
set IDs. The Value field can contain an individual instance of a Scope item 
— for example, if Scope is Application, Value may be Payables (AP). 
Select a scope and one of its values to grant access to that value (you can 
select only one value at a time). Or, select a scope and leave the value blank 
to select all possible values for that scope. 

• Enabled. When checked, the permission is active. 

7. Click Save. The page refreshes, displaying a summary of the Permission. 

 

8. To add another permission, click Add Permission again, and select another 
scope and value. (You may select a scope for which you have already selected a 
value, in order to select another value for it.) The new permission is added when 
you click Save. You may add as many permissions as you wish. 

Before you can add users to a group, you must select each scope item and either 
select at least one value for it, or leave its Values field blank to select all values.  

Add all the permissions you intend to create before adding the first user. Once 
you add a user, you cannot change the group’s permissions. 

9. When you are done adding permissions, click Back. The definition page 
reappears. 

10. Click Add User. The Users page appears. 
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11. Enter the following information: 

• User. Select a user from the pop-up window. 

• Enabled. When checked, this user is an active member of the group. 

• Valid from. First day the user will be a member of the group. 

• Valid until. Last day the user be a member of the group (optional). 

12. Click Save. The page refreshes. 

13. To add another user, click Add User again. The user is added when you click 
Save. You may add as many users as you wish. 

14. Click the Back button. The definition page reappears. 

15. Click Save. The new definition is saved and the Security Groups page appears. 

Schedule Change Tracking Transfer 

The Change Tracking Transfer program transfers change tracking data from the 
ERP instances to CCG. When users view the CCG change tracker, they see only the 
data that has been transferred by this program. You are advised to schedule this 
program to run as frequently as possible: 

1. Select Jobs > Schedule a Job from the menu bar. The Schedule a Job page 
appears. 

 

2. Click Add item. The Add Item page appears (as shown in step 4). 

3. Click the icon to the right of the Program Name field. An LOV (List of Values) 
window appears, displaying all standalone programs. 
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4. Highlight Change Tracking: Transfer and click the Select button. The LOV win-
dow disappears, and the Add Item page displays “Change Tracking: Transfer” 
in its Program Name field. 

 

5. Click Save.  

6. Click Back. The Schedule a Job page reappears. 

7. Set all scheduling options as desired. You are advised to choose the Repeat: 
Minute option for frequent updating (perhaps every 60 minutes or less). 

8. Click Schedule. 
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3 

Administrative Tasks 

This chapter tells how to complete a variety of administrative tasks in Configuration 
Controls Governor: create tablespaces, schedule definitions and work with jobs, recon-
figure an instance, maintain the CCG Home schema, create templates, and purge 
occurrences and definitions. 

Create Tablespaces 

CCG requires the creation and maintenance of several tablespaces. Use the 
Tablespace Workbench to work with tablespaces. All tablespaces created by CCG 
are locally managed. 

To create a tablespace: 

1. Select Administrator > Tablespaces from the menu bar. The Tablespaces 
Workbench appears. 

 

2. Click Add Tablespace. The Tablespaces page appears. 
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3. Enter the following information: 

• Instance. Where the tablespace will reside. 

• Type. Choose the appropriate type. 

• Name. The name of the tablespace. 

• Initial extent. Size of the tablespace’s initial extent. 

• Next extent. Size of the tablespace’s subsequent extents. 

4. Click Save. The page refreshes, with a new Datafiles section below Tablespace 
Basics.  

 

5. Enter the following information: 

• Datafile Name. The datafile’s name, including the file system directory 
path for where the datafile will be stored. 

• Max Size. The maximum size of the datafile. Its initial size will be 10 
percent of the amount specified here; it will be allowed to AUTOEXTEND in 
increments of 10 percent or 200 MB, whichever is less, until reaching the 
size entered here. 

6. Click Save. The page refreshes. 

7. To add another datafile to the tablespace, fill in the fields and click Save again. 
You may add as many datafiles as you wish. 

8. Click Create Tablespace. A job to create the tablespace will be submitted for 
immediate execution; you can monitor it on the Jobs > View Current Jobs page. 

9. Repeat the preceding steps to create more tablespaces. 

To view or edit a tablespace: 

1. Select Administrator > Tablespace Workbench from the menu bar. The Table-
space Workbench appears (see page 3-1). 

2. Click Edit to the right of the tablespace you want to view or edit. 

To add a datafile to an existing tablespace 

1. Edit the tablespace. 

2. Fill in the Datafile Name and Max Size fields. 

3. Click Save. The page refreshes. 

4. Click Alter Tablespace to add the datafile. 

Schedule Definitions and Work with Jobs 

Many actions, such as scheduling a definition, cause the creation of jobs. Each is a 
sequence of one or more programs. (A scheduled definition is really a job containing 
the programs you saw when you created or edited the definition.) Programs are 
executed in sequence, so if a program cannot be completed, remaining programs in 
the sequence are not executed. 
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Each job is scheduled to run on one or more occasions. See “Scheduling a Job” 
(below) for more information. 

All jobs scheduled for the future are listed on the View Future Jobs page (select 
Jobs > Future Jobs from the menu bar). All jobs that are being executed, or that 
already have been executed, are listed on the View Current Jobs page (Jobs > Cur-
rent Jobs). See “Viewing Job Status or Details” (page 3-6) for more information. 

Scheduling a Job 

Before scheduling a job, prepare all definitions to be included in it. Then: 

1. Go to the Schedule a Job page (select Jobs > Schedule a Job from the menu bar 
or click Schedule as you edit a definition or perform an administrative task). 

 

2. In the upper part of the page, set schedule options. The default is to run the job 
once, immediately. 

3. If you select the On radio button, supply a date, time, and time zone in the fields 
to its right. You these Repeat options: 

• Minute — repeat every n minutes 

 

• Day — repeat every n days, every weekday, or every weekend day 
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• Week — repeat every n weeks on specified days 

 

• Month — repeat every n months on a specified day 

 

• Year — repeat every year on the specified day 

 

4. In the lower part of the page, include all items to be executed, in the order you want. 
To select the first item, click the Add Item button. An Add Item to Job page appears. 

 

5. Select a Program Name. When you do, additional fields might appear, in which 
you can set parameters for the job you’ve chosen. (These vary by program. For 
example, for a Create Tablespaces job, you specify the instance on which the 
tablespace is to be created, and its name.) Set all parameters, and click Save. 
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6. The following page appears, indicating that the item has been successfully 
added to the joband offering the opportunity to select more items. To add an 
item, click the Add Item button. You can add as many items as you like.  

 

7. When you are done adding items, click Back. The Schedule a Job page reappears. 

 

8. When you are done, click Schedule. If the job is scheduled to run immediately, 
the View Current Jobs page appears. 
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If the job is scheduled to run in the future, the View Future Jobs page appears. 

 

Viewing Job Status or Details 

To see the status of: 

• A job that’s running now, or that ran in the past: Select Jobs > View Current 
Jobs from the menu bar. The View Current Jobs page appears (see page 3-5); 
the most recently scheduled jobs are listed, sorted by Job ID, newest ID first. 

• A job that will run in the future: Select Jobs > View Future Jobs from the menu 
bar. The View Future Jobs page appears (see above); jobs are sorted by start date/ 
time, most imminent jobs first. 

In either case, if you don’t see the job you’re looking for, you can: 

• Increase the number of results per page. 

• Click Next > to see the next page of jobs. 

• Click Revise Search, fill in the search form and click the Search button. 

On the View Current Jobs page, jobs may be at any of the following statuses: Pend-
ing, Running, Paused, Error, Terminating, Terminated, Complete, or Warning. The 
View Future Jobs page does not display status, because all its jobs have the same 
status — Pending.  

In either page, click on the + icon for a job to see its details and control buttons. 
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Depending on the job status, some of these buttons could appear: 

• If execution  of the job has been paused: Click Resume Job to resume execution 
of the paused job. 

• If the job is being executed, or if its execution has been paused: Click Terminate 
Job to cancel the job. Not all jobs can respond to a termination request. 

For current/past jobs, one or both of the following links will appear to the right of 
each program: 

• Click Log to view log information, including error messages. 

• Click Details to view additional details about the program’s execution, and all 
reports generated by the program. 

Modifying a Job 

To cancel the current execution of a job: 

1. Find the job on the View Current Jobs page. 

2. Click the job’s Terminate job button. The job’s status changes to Terminating. 
Once the currently running program terminates or completes, the job’s status 
changes to Terminated. 

To cancel future execution of a job: 

1. Find the job on the View Future Jobs page. 

2. Click the job’s Remove link. 

To examine a job’s occurrences: 

1. Find the job on the View Current Jobs page. 

2. Click Details to the right of any of the definition’s programs. 

To change a job’s schedule: 

1. Cancel future execution of the job (see above). 

2. Schedule a new job. 

To schedule a job again (after all occurrences have completed), simply schedule a 
new job. 

To edit a definition that is scheduled for use in future jobs: 

1. On the View Future Jobs page, remove all jobs that use the definition. 

2. Edit the definition. 

3. Reschedule the jobs that you removed in step 1. 

To add or remove definitions or programs from a job, or change their order of 
execution: 

1. Cancel future execution of the job (see above). 

2. Schedule a new job. 
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Reconfigure an Instance 
You will need to reconfigure the CCG Agent on an ERP instance when either: 

• The CCG Agent no longer exists (e.g., because you have refreshed the instance). 

• You have changed the password on the instance for any of these users: ERP USER, 
SYSTEM, or AM_AGENT. 

If you have changed the password for the ERP USER, SYSTEM, or AM_AGENT: 

1. Select Administrator > ERP Instances from the menu bar. A list of instances appears. 

2. Click Edit  to the right of the instance where the password changed. 

3. For the Configuration Controls Governor component (not the CCG Agent): 

a. To the right of the component’s name, click Edit. 

b. Click Remove to remove the component from the business application 
instance. The page refreshes, and the Latest Status column is updated. 

c. If Latest Status indicates that removal of the component failed: 

• Select Jobs > View Current Jobs from the menu bar. Find the instance 
removal job that was created when you clicked the Remove button, and 
view the job’s logs/details to determine the cause of the failure.  

• Resolve the cause of the failure. 

• Repeat the steps above. 

4. Repeat step 3 for the CCG Agent. 

5. Reconfigure the CCG Agent with the new passwords (see “Configure CCG 
Agent,” page 2-6). 

6. Reconfigure the Configuration Controls Governor component. (see “Configure 
CCG,” page 2-9). 

During the CCG testing cycle, you may need to refresh your ERP instance. This 
usually means you reconfigure the CCG Agent and recreate its tablespaces. 

You must perform the following steps before refreshing the ERP instance: 

1. Select Administrator > ERP Instances from the menu bar. A list of instances 
appears. 

2. Click Edit  to the right of the instance you want to reconfigure. 

3. For the Configuration Controls Governor component (not the CCG Agent): 

a. To the right of the component’s name, click Edit. 

b. Click Remove to remove the component from the business application 
instance. The page refreshes, and the Latest Status column is updated. 

c. If Latest Status indicates that removal of the component failed: 

• Select Jobs > View Current Jobs from the menu bar. Find the instance 
removal job that was created when you clicked the Remove button, and 
view the job’s logs/details to determine the cause of the failure.  

• Resolve the cause of the failure. 

• Repeat the steps above. 

4. Repeat step 3 for the CCG Agent. 
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You may now refresh the ERP instance. After doing so: 

1. Make note of the datafile information for each CCG tablespace on the ERP 
instance. This includes: 

• AM_AGENT_D 

• AM_AGENT_X 

• All CCG-specific tablespaces 

2. Delete those tablespaces.  

3. Recreate those tablespaces. 

4. Reconfigure the CCG Agent with the new passwords (see “Configure CCG 
Agent,” page 2-6). 

5. Reconfigure the Configuration Controls Governor component (see “Configure 
CCG,” page 2-9). 

Your refreshed ERP instance is now reconfigured. 

Maintain the CCG Home Schema 

The CCG Home schema can affect many operations within your organization, 
because it stores information about: 

• The CCG system as a whole 

• The Configuration Controls Governor component and ERP instance 

When creating your maintenance plans for the CCG Home database, be sure to 
consult all: 

• CCG Administrators 

• IT and business unit managers who use or rely on CCG 

• Functional and technical superusers who use CCG 

• Designated ERP application end users 

• Database administrators 

These decision-makers must agree, among other things, on whether to retain or 
purge the information in the CCG Home during maintenance. 

Your DBAs should monitor the size of the CCG Home tables and indexes, to ensure 
sufficient tablespace capacity to fulfill the needs of your organization. 

Database Passwords 

The operation of CCG is impacted when any these passwords is changed: 

• CCG Home schema (AMHOME). The CCG Home schema database password 
on your CCG Home instance 

• CCG Agent schema (AM_AGENT). The CCG Agent schema database password 
on any of your ERP instances 
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• CCG Public schema (AMHOME_PUBLIC). The CCG Public schema database 
password on your CCG Home instance (if your CCG UI is served by Oracle 
Forms and Reports servers). 

• ERP instance system. System password for the ERP instance; e.g., 
System/Manager. 

• ERP schema password. Typical values: 

– Oracle E-Business Suite: APPS 

– PeopleSoft Enterprise: SYSADM 

– Siebel CRM Applications: SIEBEL 

Once you understand the effect of database password changes on CCG, you will be 
able to change passwords on schedule or on demand, while keeping CCG available 
without disruption. However, you are advised to change these database passwords 
only during scheduled downtime, or after you have broadcast an announcement 
indicating that CCG will be temporarily unavailable. 

Change the CCG Home Schema Password 

To ensure that the CCG Home database remains secure, you may choose to change 
the CCG Home schema database password from time to time. Since end users do 
not typically perform ad-hoc queries of the CCG Home database, it is unusual for 
the CCG Home schema database password to be disclosed to anyone other than the 
database administrator. However, it is easy to change the CCG Home schema pass-
word when necessary: 

1. Obtain the script amhome_reset_45.zip from Oracle Support. 

2. Extract the file amhome_reset_45.sql from amhome_reset_45.zip. 

3. Choose a new password for the CCG Home schema. The maximum length for a 
password is 30 characters. The following characters are not allowed: 
!  |  /  =  $  &  @  "  '  `  , 

4. Connect to the CCG Home database as SYSTEM, and change the CCG Home 
schema database password. You can use this syntax: 

ALTER USER AMHOME IDENTIFIED BY <NEW_PASSWORD>; 

Or, you can use Oracle Enterprise Manager or other methods to change the 
password, according to your usual database administration procedure. 

5. Run the following script against the CCG Home schema: 

@amhome_reset_45.sql 

This script prompts for connection information (including the new password that 
you designated). 

Change the CCG Agent Schema Password or ERP Schema Password 

To ensure security of the CCG Agent schema(s), you may choose to change the 
CCG Agent schema database password from time to time, according to your 
organization’s database security policies. 
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Follow these steps to change the CCG Agent schema or ERP schema passwords: 

1. Select Administrator > ERP Instances from the menu bar. A list of instances 
appears. 

2. Click Edit  to the right of the instance where the password changed. 

3. For the Configuration Controls Governor component (not the CCG Agent): 

a. To the right of the component’s name, click Edit. 

b. Click Remove to remove the component from the business application 
instance. The page refreshes, and the Latest Status column is updated. 

c. If Latest Status indicates that removal of the component failed: 

• Select Jobs > View Current Jobs from the menu bar. Find the instance 
removal job that was created when you clicked the Remove button, and 
view the job’s logs/details to determine the cause of the failure.  

• Resolve the cause of the failure. 

• Repeat the steps above. 

4. Repeat Step 3 for the CCG Agent. 

5. Reconfigure the CCG Agent with the new passwords (see “Configure CCG 
Agent,” page 2-6). 

6. Reconfigure the Configuration Controls Governor component (see “Configure 
CCG,” page 2-9). 

Patches 

CCG patches let your organization take advantage of added functionality, increased 
performance, fixes, or changes related to ERP system patches and upgrades. 

There are four patchable elements in the CCG environment. A patch can affect 
some or all of them: 

• Data structure and database packages 

• Servers 

• Metadata 

• Web application 

The CCG Home schema contains a table that lists the installed patches. You can see 
this information by selecting Help > About products from the menu bar. 

From time to time, maintenance releases are offered. Each maintenance release is 
accompanied by a Readme file, which contains a description of the patches included, 
other changes provided, prerequisites for successful installation, and installation 
instructions. 

Patches are created routinely so that CCG remains compatible with ERP system 
patches and upgrades. Whenever you patch or upgrade your ERP system, verify that 
you have installed the latest CCG patch set(s). 
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Create Templates 

Templates let you customize the reports generated by snapshot definitions. You can 
streamline the information presented in snapshot reports based on your preferences, 
and display information specific to your needs. Each template governs the display of 
one CCG object (an object being a group of ERP setup tables to be monitored). 

To summarize, you will: 

• Create a template. 

• Run a snapshot definition that includes the template’s object. 

• View the report(s), applying the new template. 

To create a template: 

1. Select Workbench > CCG Templates from the menu bar. A CCG Templates 
page appears, listing templates if any already exist. 

 

2. Click Add Template. A blank definition appears. 

 

3. Enter the following information: 

• Name. A short name that will identify this definition. 

• Application. ERP application whose setup data will be recorded in the 
snapshot. 

• Object. Group of ERP application setup tables that helps you select 
information to monitor without having to consider the complexity of the 
data model or entity relationships. An object is typically associated with an 
ERP application setup form. 
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4. Click Save. The page is refreshed based on object, listing the tables belonging 
to the object; here is an example. 

 

5. Click Edit to the right of any table to change how the template handles the 
table’s data. A page similar to this appears: 

 

6. Set the following fields if they appear: 

• Column. Checking/unchecking this box toggles all the following 
checkboxes. 

• Field1, Field2, ... FieldN. When checked, the column’s data is included in 
the snapshot report. 

7. Click Save. The page refreshes. 

8. Repeat steps 5–7 for other tables, as desired. 

9. Click Back. The definition page reappears. 

10. Click Save. You have the option to share the template with other CCG users. 

Run a snapshot definition that uses the template’s object, and view the resulting 
snapshot report. (See “Creatubg Snapshots” in the Configuration Controls Governor 
User Guide for instructions about creating and scheduling snapshot definitions, and 
viewing snapshot reports). 
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Purge Occurrences and Definitions 

The following standalone programs are available: 

• Purge: Change Tracking Data. Purges unwanted change tracking data from 
the CCG Home schema. The data to be purged is selected by ERP instance and 
end date. 

• Purge: Change Tracking Definitions. Purges unwanted change tracking 
occurrences and definitions from the CCG Home schema. You can purge only 
occurrences, or both occurrences and their definitions. The data to be purged is 
selected by ERP instance and CCG user. 

• Purge: Inside Jobs. Purge data from “inside” tables. Jobs create entries in an 
AM_SCHEDULE_JOBS table, but each job involves smaller, “inside” jobs that 
store data in other tables. This program purges data from those tables.  

• Purge: Migration Definitions. Purges unwanted Migration definitions from the 
CCG Home schema. You can purge only occurrences, or both occurrences and 
their definitions. 

The data to be purged is selected by ERP instance. 

• Purge: Snapshots and Comparisons (Administrator). Purges unwanted snap-
shot definitions, occurrences, and comparisons from your CCG Home schema. 
In the case of snapshots, you can purge only occurrences, or both occurrences 
and their definitions. When you remove a snapshot definition associated with a 
comparison, you will also remove the comparison. 

The data to be purged is selected by ERP instance and CCG user. 

• Purge: Snapshots and Comparisons. This program functions similarly to 
Purge: Snapshots and Comparisons (Administrator), but purges only data 
created by the user who schedules this program. 

The data to be purged is selected by ERP instance. 

To schedule a program: 

1. Select Jobs > Schedule a Job from the menu bar. 

2. Click Add Item. 

3. Set Job Type to Standalone. 

4. Set Program Name to that of the program you want to run. 

5. Click Save. 

6. Click Back. 

7. Set any other options desired, and click Schedule. 
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Reference 

This chapter serves as a reference to several topics: login, home configuration, 
security groups, users and roles, ERP instances, tablespaces, system profile, and 
help. 

Login 

All CCG users must begin by logging in on the Secure Login page. 

 

The URL for this page is: 

http://hostname/web-application-name 

In this URL: 

• hostname is the domain name of the web server configured to serve CCG 

• web-application-name is the name of the CCG web application (usually ccg). 

The upper portion of the page has these fields: 

• Username. Your CCG Administrator creates your username. 

• Password. Your CCG Administrator creates your password. To change it, log 
in, then select Home > User Profile from the menu bar. 

The upper portion of the page has this button: 

• Log in. Verifies your username and password, and displays your Welcome 
Page. To change your Welcome Page, log in, then select Home > User Profile 
from the menu bar. 
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The lower portion of the page displays information about CCG. This content is 
updated regularly if your server firewall permits HTTP transactions across the 
Internet. 

Security Notice: The Secure Login page is the only CCG page that attempts to send 
or receive information using the Internet. Once you log in, all communications are 
restricted to your organization’s internal networks. 

Home Configuration 

The Home Configuration page contains settings that apply to all of CCG. 

 

To view the page, select Administration > Home Configuration from the menu bar. 

The Email Server (upper) portion of the page contains these fields. If left blank, 
CCG cannot send email notifications. 

• SMTP server domain. The domain name of your mail server.  

• Port. The port number of your mail server. 

The Home Instance (lower) portion of the page contains these fields: 

• Filesystem Directory of the AMHOME $ORACLE_HOME. File system path to 
the directory that holds the ERP application database. 

Filesystem Directory of the AMHOME UTL_FILE_DIR. Use any valid file 
system path. We recommend that you create a new directory for this purpose. 
Ensure that the value is accurate and that the permissions on the specified direc-
tory are set properly. An invalid entry or insufficient privileges will result in 
errors. 

• Filesystem Directory Delimiter. Backslash (\) for Windows systems, or 
forward slash (/) for UNIX/Linus. 

• Oracle Database Version. The database version of the CCG Home instance. 

• Allow Alerting with Change Tracking. When this field is set to Y, the change 
tracker lets you configure alerts. 
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The page contains these buttons: 

• Test. Displays the Send Test Message from Email Server page (see “Email 
Alerts,” below). 

• Save. Saves the changes you make on this page. 

Email Alerts 

The optional Email Alert feature is used for sending Change Tracking alerts. When 
you click Test on the Home Configuration page, the Send Test Message from Email 
Server page appears. 

 

To use this page: 

1. Enter From and To addresses, and optionally a Subject, and click Send. The 
page is refreshed, displaying a Status field. 

2. To update Status, click Refresh. If the test message is sent successfully, but you 
don’t receive it, first verify that the message isn’t being treated erroneously as 
spam by your incoming mail server or mail client. 

3. When you’re finished, click Back. The Home Configuration page reappears. 

CCG does not use the Oracle Alerts product. It sends email messages directly from 
the database, using Oracle’s UTL_SMTP feature. 

Security Groups 

Security Groups control users’ access to ERP data. To view existing Security 
Groups or add new ones, select Administrator > Security Groups from the menu bar. 
You will see a list of existing Security Groups. 

 

You can see more (or different) results by changing Results Per Page, clicking  
Next >, or clicking Revise Search. 

Click Edit to view an existing group, or Add Security Group to add a new one. In 
either case, the Security Groups page appears. 
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Security Groups Definition 

 

The Group Basics (upper) portion of the page contains these fields: 

• Name. The group’s name. 

• Description. A short description of the group. 

• ERP Instance. The ERP instance that the group can work with. 

• Enabled. When checked, the group is active. 

The page contains these buttons and links: 

• Edit. Appears to the right of each permission or user that has been added. 
Displays the appropriate page — Group Permissions or Group Users, and lets 
you revise the permission or user. 

• Add permission. Visible until the first user is added. Displays the Group 
Permissions page and lets you add a permission to the group. 

• Add user. Disabled until you have added at least one permission with each 
Scope. Displays the Group Users page and lets you add a user to the group. 

• Save. Saves the changes made to the fields on this page. Does not affect 
changes to permissions and users, which are saved or discarded while on the 
Group Permissions and Group Users pages, respectively. 

• Cancel. Discards the changes made to the fields on this page. Does not affect 
changes to permissions and users, which are saved or discarded while on the 
Group Permissions and Group Users pages, respectively. 
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Permissions 

Permissions control the group’s access to data. Before you can add users to a group, 
you must add a permission for each scope. Add all permissions you intend to create 
before adding a user. Once you add a user, you cannot change the group’s permissions. 

 

The page contains these fields: 

• Scope and Values. Each entry in the Scope field is a class of items that give 
access to ERP data — in Oracle EBS 11i, applications, business groups, organi-
zation units, and sets of books; in EBS R12, applications, business groups, 
organization units, ledger sets, and ledgers; in PeopleSoft, applications and set 
IDs. The Value field can contain an individual instance of a Scope item — for 
example, if Scope is Application, Value may be Payables (AP). Select a scope 
and one of its values to grant access to that value. Or, select a scope and leave 
the value blank to select all possible values for that scope. 

• Enabled. When checked, the permission is active. 

The page contains these buttons and links: 

• Edit. Refreshes the page and lets you revise a permission. 

• Save. Saves your changes to the permission and refreshes the page. 

• Cancel. Discards your changes to the permission and refreshes the page. 

• Add permission. Refreshes the page and lets you add a permission. 

• Back. Discards any unsaved changes and displays the Security Groups page. 

Users 

Users must belong to security groups in order to have access to ERP data. 

 

The page contains these fields: 

• User. Select a user from the pop-up window. 

• Enabled. When checked, this user is an active member of the group. 

• Valid from. First day the user will be a member of the group. 

• Valid until. Last day the user be a member of the group (optional). 

The page contains these buttons and links: 

• Edit. Refreshes the page and lets you revise a user’s information. 

• Save. Saves your changes to the user’s information and refreshes the page. 
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• Cancel. Discards your changes to the user’s information and refreshes the page. 

• Add user. Refreshes the page and lets you add a user. 

• Back. Discards any unsaved changes and displays the Security Groups page. 

Users and Roles 

Use the Users page to configure a user’s login access and roles. You can also 
modify a user’s access or roles, or disable a user’s access. To view existing users or 
add new ones, select Administrator > Users from the menu bar. 

 

You can see more (or different) results by changing Results Per Page, clicking  
Next >, or clicking Revise Search. 

Click Edit to view an existing user, or Add User to add a new one. In either case, the 
Users page appears. 

Users Definition 
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The User Basics (upper) portion of this page contains these fields: 

• Full name. CCG user’s full name. The name may consist of letters, spaces,  
’ (apostrophes), and - (hyphens); other characters are not allowed.  

• Department. User’s department or organization. The department may consist 
of letters, digits, spaces, and - (hyphens); other characters are not allowed. 

• Email. The user will receive alerts at this address. 

The Login (middle) portion of this page contains these fields: 

• Login ID. User’s CCG Login ID. The ID may consist of letters and digits only; 
spaces and other characters are not allowed.  

• Password. Initial password for the new user (30 character length limit). This 
data will be encrypted before it is stored. Not required if LDAP Authentication 
mode is used. See “System Profile” (page 4-13) for more information. The 
following characters are not allowed: 
  !  |  /  =  $  &  @  "  '  `  , 

• Confirm password. Re-enter the password to confirm 

• Valid from. First day user can log in 

• Valid until. Last day user can log in (optional) 

• Enabled. Enables the user to log in; if not checked, the user cannot log in. 

The page contains these buttons and links: 

• Edit. Appears when one or more roles have been assigned. Displays the Roles 
page (see “Roles,” below), where you can revise the role. 

• Add role. Displays the Roles page and lets you add a role. 

• Save. Saves the changes made on this page. Does not affect changes to roles, 
which are saved or discarded while on the Roles page. 

• Restore. Discards the changes made on this page. Does not affect changes to 
roles, which are saved or discarded while on the Roles page. 

• Back. Displays the list of Users. 

Roles 

Each user can have one or more roles. To add a role, click Add Role on the Users 
page. To revise a role, click Edit to the right of the role’s name on the Users page. 

 

The page contains these fields: 

• Role. Select a role from the drop-down list. 

• Enabled. Enables this role for this user. 
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• Valid from. First day the user will have this role. 

• Valid until. Optional: Last day the user will have this role. 

The following roles are available for CCG 5.5. 

• CCG Developer: Create and edit templates. Use MetaBuilder to create 
metadata — information about ERP objects for which CCG may take or 
compare snapshots, or track changes. 

• Change Tracking Scheduler: Schedule change tracking definitions. 

• Snapshot Scheduler: Schedule snapshot definitions, and compare snapshot 
occurrences. 

• CCG User: Create and edit snapshots and change tracking. 

• Administrator. Perform tasks accessible from the Administrator menu bar. 

The page contains these buttons and links: 

• Edit. Refreshes the page and lets you revise a role. 

• Save. Saves your changes to the role and refreshes the page. 

• Cancel. Discards your changes to the role and refreshes the page. 

• Add role. Refreshes the page and lets you add a role. 

• Back. Discards any unsaved changes and displays the Users page. 

ERP Instances 

You must configure CCG to work with each ERP instance that you want to manage. 
Broadly speaking, you will perform these tasks for each instance: 

• Define a new instance in CCG. 

• Create CCG Agent tablespaces for the instance. The CCG Agent lets CCG com-
ponents perform tasks that require access to data on the ERP the instance. 

• Configure CCG Agent parameters. 

• Configure parameters for CCG itself. 

To view ERP instances or add new ones, select Administrator > ERP Instances from 
the menu bar. A list of ERP instances appears. 
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You can see more (or different) results by changing Results Per Page, clicking  
Next >, or clicking Revise Search. 

Click Edit to view an existing instance, or Add Instance to add a new one. In either 
case, the ERP Instances page appears. 

ERP Instances Definition 

 

The ERP Instance Basics (upper) portion of the page contains these fields: 

• ERP Instance. Short name that identifies the ERP instance 

• Description. Longer, more descriptive name for the ERP instance. For example, 
if Instance name is Dev, Description could be Development Instance 

• Service Name. TNSNAMES service name that will be used when CCG creates a 
database link from the CCG Home schema to the new CCG Agent schema on 
the ERP instance. This name must be present in the TNSNAMES configuration 
for the CCG Home instance’s Oracle Home. 

• ERP Version. ERP application version 

The page contains these buttons and links: 

• Edit. Displays the Components page (see “Component Details,” below), where 
you can configure, remove or reconfigure the component. 

• Save. Saves the changes made on this page. Does not affect changes to compo-
nents, which are performed while on the Components page. 

• Restore. Discards the changes made on this page. Does not affect changes to 
components, which are performed while on the Components page. 

• Back. Displays the list of ERP instances. 

Component Details 

The Component Details area lets you configure or remove the CCG Agent (which 
lets CCG perform tasks that require access to the instance’s data) and a Configuration 
Controls Governor component (which provides other CCG functionality). The area 
contains these buttons and links: 

• Remove. Appears when the component has already been configured. Removes 
the component from the instance and refreshes the page. 
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• Configure. Configures the component on the instance and refreshes the page. If 
the component has already been configured, this button updates the 
configuration. 

If you have made changes to values on this page, click Save before clicking 
Configure. 

• Save. Saves your changes to the fields on this page without configuring the 
component, and refreshes the page. 

• Cancel. Discards your changes and refreshes the page. 

These buttons appear at the bottom of the ERP Instances page when working with 
Component Details: 

• Refresh. Retrieves the latest status of the instance. 

• Back. Discards unsaved changes and displays the ERP Instances page. 

The fields on this page vary by component. CCG Agent fields include: 

• Data. The data tablespace used by the CCG Agent. Normally, the tablespace is 
named AM_AGENT_D. 

• Index. The index tablespace used by the CCG Agent. Normally, the tablespace 
is named AM_AGENT_X. 

• CCG Agent Username. For the CCG Agent schema. Created on the ERP 
instance if it does not exist. Default value: AM_AGENT. 

• Database Link from HOME to Agent. Needed to transfer metadata from the 
CCG Home instance to the ERP instance, and to execute any process on the 
ERP instance. Created on the CCG Home instance if it does not exist. 

The value must contain no more than 20 characters. 

• ERP Username. Existing ERP instance user with full access to the ERP 
instance’s data. 

– Oracle E-Business Suite: The typical value is APPS. 

– PeopleSoft Enterprise: The typical value is SYSADM. 

– Siebel CRM Applications: The typical value is SIEBEL. 

• ERP User Database Link. Needed to access ERP application information. 
Created on the ERP instance if it does not exist. 

The value must contain no more than 20 characters. 

• Temporary Tablespace Name. Name of the ERP instance’s temporary 
Tablespace. 

• Database Version. ERP instance’s database version. Example: 8.1.7 

• Remote File System Directory of the $ORACLE_HOME. File system directory 
that corresponds to the $ORACLE_HOME of the ERP instance. 

• Remote File System Directory of the UTL_FILE_DIR. File system directory 
specified by the UTL_FILE_DIR parameter in the ERP instance’s INIT.ORA file. 
Tells CCG where to read and write files that reside on the ERP instance. 
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• File System Directory IMP/EXP/SQLPLUS Binaries. File system directory path 
where these executables reside on the ERP instance. 

• Remote Instance File System Directory Delimiter. The character used by 
your ERP instance’s file system to separate elements within pathnames. 

– Unix/Linux: / (forward slash) 

– Windows: \ (backslash) 

• Export/Import Buffer Value. Sets the BUFFER parameter, which is used when 
invoking the IMP and EXP utilities. Default value: 100000 

• ISO language. Default value: US 

• Parallel Workers. Default value: 4 

• Database Host. Server where database resides. 

• Database Port. Port for installing and launching the database. 

• Database SID. Name of the database that contains the ERP application schema. 

• Analyze Date Tolerance. Default value: 7 

Informia Subset users: Subset will not perform a row count if there is an 
existing one that was created within this many days. 

• APPSORA.env. Default value: APPSORA.env 

Configuration Controls Governor component fields include: 

• Data. Data tablespace used by the CCG Agent. Typically named 
APS_AGENT_D. 

• Index. Index tablespace used by the CCG Agent. Typically named 
APS_AGENT_X. 

• APPLSYS Username. Oracle E-Business Suite users: ERP instance’s APPLSYS 
username. PeopleSoft Enterprise users: ERP instance’s SYSADM username. 

• HR Username. Oracle E-Business Suite users: ERP instance’s HR username. 

• Remote Instance Directory of the FND_TOP. Oracle E-Business Suite users: 
ERP instance’s $FND_TOP directory. 

• Baseline Definition Owner. CCG user who will own the snapshot and change 
tracking definitions that will be generated automatically when you complete this 
configuration process. 

• Remote Instance Directory of the APPL_TOP. Oracle E-Business Suite users: 
ERP instance’s $APPL_TOP directory. 

• Freeze Table Overlays. If you have moved or renamed any ERP tables or 
views from their defaults, enter N to map them (which will make them visible to 
CCG). The default value is Y. 

• Descriptive Flexfields Flag. Oracle E-Business Suite users: Enter Y to capture 
all values entered in every Descriptive Flexfield of every setup object in this 
ERP instance. The default value is N. 

To report on the structure or definition of a Descriptive Flexfield, use the 
System Administration application’s Descriptive Flexfield Segments object. 
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• Remote APPLTOP (Y/N). Oracle E-Business Suite users: Enter Y if your 
APPL_TOP is on a different physical server than the ERP instance. The default 
value is N. 

• Remote APPLTOP Server Name. Oracle E-Business Suite users: Name of 
server, if your APPL_TOP is on a different computer than the ERP instance. 

Tablespaces 

CCG requires the creation and maintenance of several tablespaces. Use the 
Tablespace Workbench to work with tablespaces. 

All tablespaces created by CCG are locally managed. 

To use the Tablespace Workbench, select Administrator > Tablespaces from the 
menu bar. A list of existing tablespaces appears. 

 

You can see more (or different) results by changing Results Per Page, clicking  
Next >, or clicking Revise Search. 

Click Edit to view an existing tablespace, Delete to delete a one, or Add Tablespace to 
add a new one.  

Tablespaces Definition 
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The Tablespace Basics (upper) portion of the page contains these fields: 

• Instance. Where the tablespace will reside. 

• Type. Choose the appropriate type. 

• Name. The tablespace’s name. 

• Initial extent. Size of the tablespace’s initial extent. 

• Next extent. Size of the tablespace’s subsequent extents. 

The page contains these buttons: 

• Create Tablespace/Alter Tablespace. Creates all listed datafiles and refreshes 
the page. If some datafiles already exist, this button updates their configurations. 

• Save. Saves the changes made on this page. Does not affect changes to datafile 
configuration settings. 

• Back. Discards the changes made on this page. Does not affect changes to 
datafile configuration settings. 

Datafile Basics 

Each tablespace uses one or more datafiles, and has exclusive use of its datafiles. 

The Datafile Basics section contains these fields: 

• Datafile Name. The datafile’s name, including the file system directory path for 
where the datafile will be stored. 

• Max Size. The maximum size of the datafile. Its initial size will be 10 percent of 
the amount specified here; it will be allowed to AUTOEXTEND in increments of 
10 percent or 200 MB, whichever is less, until reaching the size entered here. 

The section contains a Clear button, which clears the Datafile Name and Max Size fields. 

The section contains these links: 

• Edit. Appears to the right of undeployed datafile definitions. Displays the 
Datafiles page, and lets you revise the datafile’s configuration. 

• Delete. Appears to the right of undeployed datafile definitions. Deletes the datafile. 

System Profile 
To change the System Profile, select Administrator > System Profile from the menu 
bar. The System Profile page appears. 
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The page contains these fields: 

• CCG Application Path. The web-application-name portion of the URL that 
summons the Secure Login page. Typically, this value is ccg.  

• Company Logo. Name of the image file that is displayed in the upper left cor-
ner of each page. The file must be located in the images subdirectory of the di-
rectory on the CCG UI server where the CCG web application is deployed. 

• Authentication Mode. There are two options for validating users: 

– RDBMS uses an CCG RDBMS module.  

– LDAP uses an LDAP directory maintained by your organization. This 
eliminates the need for CCG users to enter their password on the Secure 
Login page. If you choose this option, the following fields are required. 

• LDAP Base Distinguished Name. LDAP entry that identifies an authorized 
user of the LDAP server. 

• LDAP Host. Machine name or IP address where the LDAP server is hosted. 

• LDAP Port. Port number to use when communicating with the host. 

The page contains these buttons: 

• Save. Saves changes made on this page. 

• Restore. Discards changes made on this page. 

Help 

Selecting Help > About products from the menu bar displays the following 
information about each installed component: 

• Product (component name) 

• Release Number 

• Patch Number (latest patch release applied, and patch history) 

• Metadata release 

• Metadata Patch Number (latest metadata patch release applied), and Patch History 
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5 

Using MetaBuilder 

Metadata is detailed information about the data structure of the ERP application’s 
database. 

Configuration Controls Governor comes with predefined metadata, which covers 
many ERP application versions and modules. MetaBuilder lets you customize this 
metadata to better serve your business needs. 

Because MetaBuilder lets you create metadata for any application, you can also use 
it to build metadata for applications that are not defined in CCG. 

How to Create Metadata 

The following pages describe how to create metadata in step-by-step detail. You 
must perform all steps, in the order shown. Here is a summary of the steps you will 
perform: 

Set up the structure needed to store custom metadata 

1. Define a Product Family 

2. Define Suites 

3. Define Applications 

4. Assign Applications to Suites 

5. License Suites 

6. Assign Applications to ERP Instance 

7. Import Data Dictionary into MetaBuilder 

Create the metadata needed for snapshots, comparisons and change tracking 

8. Create Schemas 

9. Assign Schemas to an Application 

10. Add Tables to a Schema 

11. Configure Columns within a Table/View 
Insert Phantom Columns 
Insert Missing Columns 
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12. Assign Translation Details to Columns 
Option 1: Column 
Option 2: Function (Existing) 
Option 3: Function (New): Create a Translation Function; test the function; 
apply the function; add multiple SELECTS to the function 

13. Create Objects 
Cross-Reference an Object to another Application 
Maintain Column Filters: Security Filters; Suggested Filters 
Copy a Standard CCG Object 

14. Synchronize 

15. Manage Security Groups 

Test the metadata by verifying that CCG returns the correct information when 
using the new or updated metadata 

16. Test Metadata 

Preparation 
Before creating metadata, you must identify non-standard application objects and 
their data sources. 

Identify Non-standard Application Objects 

An object is a group of application setup tables that helps users select information to 
monitor. As a MetaBuilder user, you must identify all objects that you want to work 
with. Your choice of each object’s contents facilitates the use of CCG by those who 
are familiar with the ERP application. To provide an intuitive look and feel, objects 
should be closely aligned with the organization of information seen in the ERP 
application’s menus. 

For example, the Oracle E-Business Suite General Ledger Define Set of Books form 
contains fields stored in different tables. This is not apparent, nor typically relevant, 
to managers and end-users. CCG contains a Set of Books object that aggregates the 
information in these tables, facilitating reporting and change tracking. 

Identify Object Data Sources 

Once you identify an object, you must identify the tables associated with it. 

Oracle E-Business Suite users: Forms are usually based on database views. Each 
view usually contains one table that serves as the primary source of information 
(since it stores a majority of the data), but other tables might need to be included in 
the object’s definition too. You can usually see a setup form’s table or view informa-
tion using the Help Record History menu item; if not, you must do more research. 
One useful set of resources are the eTRMs (electronic technical reference manual). 

PeopleSoft Enterprise users: Pages can be based on either tables or views; use 
Application Designer to identify them. Typically, objects containing a suffix of 
_VW indicate that the page is based on a view. 
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Set Up Metadata Structure 

Before creating metadata, you must set up the necessary product family, suites, 
applications, application licensing and ERP instance configuration, and import your 
data dictionary. 

The following instructions assume that your CCG Administrator has given you the 
CCG Developer role. If you do not have this role, contact your CCG Administrator. 

Step 1: Define a Product Family 

A Product Family is a software product that provides a business solution and 
supports different business functions; Oracle E-Business Suite is an example of a 
Product Family. 

A Product Family often contains more than one Product Family Version. Software 
makers typically provide more functionality with each new Product Family Version 
they release. 

1. Log into MetaBuilder. 

2. From the Navigator, under the CCG Developer role, select Navigate...CCG 
Metadata...MetaBuilder Workbench. MetaBuilder opens the MetaBuilder 
Workbench. 

 

3. Select the Products tab to define a new Product Family. Use the following 
information to enter your Product Family details: 

• Description. Name of the Product Family 

• Short Name. Abbreviated version of the Product Family name. You cannot 
change this value once you have defined the Product Family; if you need to 
change the name, change the Description instead. 
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4. Enter the following information in the Product Family Version zone to define a 
Product Family Version: 

• Name. Used within MetaBuilder to describe the Product Family. 

• Compatibility. ERP application suite version that the metadata will be 
compatible with. 

• MetaBuilder Model Instance. Database instance where the data dictionary 
information that you use for metadata development is kept. Contact your 
Administrator if you want to use a new database instance. 

5. Select Action...Save from the menu to save your work. 

Step 2: Define Suites 

In this step, you will create suites to assign to your Product Family/Version. A suite 
comprises a number of applications within a product family, usually corresponding 
to a group of interrelated business processes (e.g., Financials or Manufacturing). 

Follow these steps to create a suite: 

1. On the MetaBuilder Workbench, select the Product Family and the Version in 
the Products tab for which you want to define suites. 

2. Navigate to the Suites tab. The MetaBuilder Workbench displays the Product 
Family/Version that you selected from the Products tab in the Product Family/ 
Version field. 

 

3. Enter the following information in the Suite zone to define a suite: 

• Name. Name of the suite. 

• Description. Description of the suite you are creating. This Description 
should represent all the applications that you plan to assign to this suite. 

4. Select Row...Insert from the menu and repeat step 3 for each suite that you want 
to create under this Product Family/Version. 

5. Select Action...Save from the menu to save your work. 
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Step 3: Define Applications 

In this step, you will create applications to assign to suites. MetaBuilder suites com-
prise applications, which usually satisfy a particular business function (e.g., Payables 
or Receivables).  

Follow these steps to define an application: 

1. On the MetaBuilder Workbench, navigate to the Applications tab pertaining to a 
specific Product Family/Version. 

 

2. Enter the following information in the Application zone to define a new 
application: 

• Name. Name of the application. 

• Description. Description of the application. 

• Enabled. Select this checkbox to enable the application. 

3. Select Row...Insert from the menu and repeat step 2 for each application that 
you want to create under this product family/version. 

4. Select Action...Save from the menu to save your work. 

Step 4: Assign Applications to Suites 

Once you define your applications, you must assign them to one or more suites. An 
application may be assigned to one or more suites, and a suite may contain one or 
more applications. 

Follow these steps to assign applications to suites: 

1. On the MetaBuilder Workbench, navigate to the Suites tab pertaining to a 
specific product family/version. 

2. In the Suite zone, select a suite to which you want to assign your applications. 
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3. In the Applications Assigned to Suite zone, select an application from the list of 
values to assign to the selected suite. The list of applications contains only those 
created in “Step 3: Define Applications” (page 5-5). 

 

4. Select Row...Insert from the menu and repeat Step 3 for each application that 
you want to assign to this suite. 

5. Select Action...Save from the menu to save your work. 

Step 5: License Suites 

After assigning your applications to a suite, you must add the suite to the list of 
licensed suites and applications on the CCG Application Licensing page; this allows 
your site’s ERP instances to report on the suite’s applications. 

You must have access to the CCG Administrator menu to complete this step. If you 
do not, contact your CCG Administrator. 

Follow these steps to assign your suites to the Home Configuration: 

1. Log into CCG. 

2. Select Administrator > Application Licensing from the menu bar. 

3. Click Add Application By Suite. The Add Application By Suite page appears. 

 

4. Select the appropriate ERP Version. 

5. Select the new application suite. 

6. Click Save. 
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Step 6: Assign Applications to ERP Instance 

After licensing suites, you must assign them to each ERP instance where you want 
to be able to report and track changes. 

You must have access to the CCG Administrator menu to complete this step. If you 
do not, contact your CCG Administrator. 

Follow these steps to assign your applications to an ERP instance: 

1. Select Administrator > ERP Instances from the menu bar. A list of configured 
ERP instances appears. 

2. Click Edit to the far right of the ERP instance you want to assign applications 
to. Information about the ERP instance configuration appears. 

3. Click Edit to the far right of Configuratin Controls Governor. The page is 
refreshed, and the lower portion now displays fields for configuring CCG. 

 

4. Specify the applications CCG can monitor on this ERP instance. You can: 

• Click Add application... to add applications one by one, clicking Save after 
selecting each application. 

• Click Add suite... to add all applications in a product suite. 

5. Click the Configure button. See “Configure CCG” (page 2-9). 

Step 7: Import Data Dictionary into MetaBuilder 

Before you can create metadata for your database tables and columns, MetaBuilder 
needs information for the MetaBuilder Model Instance. To retrieve this information, 
you must run a job to import information stored in the ERP instance data dictionary. 

Follow these steps to run this job: 

1. Select Jobs > Schedule a Job. The Schedule a Job page appears. 

2. Click Add Item... near the bottom of the page. The Schedule a Job page appears. 
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3. Set Program Name to MetaBuilder: Import Table Definitions from Target. 

4. Enter the following information: 

• Development Instance. ERP instance where you want to import your data 
dictionary from. 

• Target Schema Name. Schema from which you want to import. Optional, 
but you should enter this value to avoid performance and tablespace issues. 

A list of values does not exist for this field. You must type your schema 
name precisely as it appears in your database dictionary. 

• Table/View Name. Name of a table or view from which you want to import. 
Optional; leave this field empty if you want to import all metadata associ-
ated with a schema. 

5. Press the Save button. The page is refreshed. 

6. Press the Back button. The Schedule a Job page reappears. 

7. Click Schedule. The job is scheduled to run immediately. 

8. Select Jobs > View Current/Past Jobs to view the status of your job. 

9. Repeat thes steps to import more table or view definitions for a schema. 

Create Metadata 
Once you have set up your metadata structure, you can begin creating metadata. 
You can create metadata pertaining to database schemas, tables and columns. 

Step 8: Create Schemas 

A schema owns a collection of database objects (tables, stored procedures and 
functions, triggers, synonyms). GL is an example of an Oracle E-Business Suite 
schema; it contains the database objects associated with the Oracle General Ledger 
application. 

Follow these steps to create a schema for your application: 

1. Log into MetaBuilder. 

2. From the Navigator, under MetaBuilder, navigate to the MetaBuilder 
Workbench. 

3. On the MetaBuilder Workbench, navigate to the Schemas tab pertaining to a 
specific Product Family/Version. 
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4. Enter the following information to create a schema, using list of values where 
applicable: 

• Expected Schema Name. The precise schema name found in your database 
dictionary. 

• Schema Description. Description of the schema. 

• MetaBuilder Model Schema. Schema name pertaining to your expected 
schema name. The MetaBuilder Model Schema list of values contains only 
database schema names for which you have run the MetaBuilder: Import 
Table Definitions from Target job. 

5. Select Row...Insert from the menu and repeat step 4 for each schema that you 
want to create under this product family/version. 

6. Select Action...Save from the menu to save your work. 

Step 9: Assign Schemas to an Application 

An application typically comprises one or many schemas. In order for your 
applications to connect to the appropriate schemas in MetaBuilder, you must create 
relationships between applications and schemas. Follow these steps to assign 
schemas to an application: 

1. On the MetaBuilder Workbench, navigate to the applications tab pertaining to a 
specific Product Family/Version. 

 

2. In the Application zone, select an application to which you want to assign a 
schema. 

3. In the Schemas Assigned to Application zone, select the schema that you want 
to assign to this application. 

4. Select Row...Insert from the menu and repeat Step 3 for each schema that you 
want to add to this application. 

5. Select Action...Save from the menu to save your work. 
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Step 10: Add Tables to a Schema 

Follow these steps to add tables owned by a schema. You must add the tables for 
which you want to create metadata. 

1. On the MetaBuilder Workbench, navigate to the Schemas tab pertaining to a 
specific Product Family/Version. 

2. Select the Expected Schema Name to which you want to assign a table. 

3. Navigate to the Tables tab. The MetaBuilder Workbench displays the schema 
you selected from the Schemas tab in the Schema field. 

 

You can click the Dependencies... button to view the dependencies from a 
table/view. MetaBuilder opens the Table table-name Dependencies window. 
This is useful if more than one object is based on the same table/view. 

4. Enter the following information to assign a table to a schema: 

• Table/View Name. Table that you want to include in your selected schema. 
The list of values for this field is based on the tables and views that you 
imported in “Step 7: Import Data Dictionary into MetaBuilder” (page 5-7). 

• Type. Read-only: MetaBuilder populates this field when you save, based on 
the information you selected for the Table/View Name field. The potential 
values of this field are Table and View. 

• Description. Description of the table. 

• Primary Key Description. Primary key description for your table or view. 
You can enter this field after you complete “Step 11: Configure Columns 
within a Table/View” (page 5-11). 

5. Select Row...Insert from the menu and repeat step 4 for each table that you want 
to add under this schema. 

6. Select Action...Save from the menu to save your work. 
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Step 11: Configure Columns within a Table/View 

Once you have added the Tables/Views to your metadata, you must also add/modify 
columns. Follow these steps to add/modify columns from a table/view: 

1. On the MetaBuilder Workbench, navigate to the Schemas tab pertaining to a 
specific product family/version. 

2. Select the schema from which you want to select a table. 

3. Navigate to the Tables tab. The Schema field displays the schema that you 
selected from the Schemas tab. 

4. Select the table to which you want to add/modify columns. 

5. Click the Columns button. MetaBuilder opens the columns in Table table-name 
window, listing all the table’s columns. 

 

6. Enter or modify the following information to define metadata for the columns: 

• Order. Order in which you want this column to appear on CCG reports. 

• Name. MetaBuilder populates this field with data dictionary information. 

• PK. Select this checkbox if the column is part of the table’s primary key. If 
you do not know whether this column is part of the table’s primary key, use 
step 9 below to retrieve the table’s primary key. 

• Description. The name of the column as it will appear in CCG reports. 

• Data Type. MetaBuilder pre-populates this field with the column’s data 
type from the data dictionary. 

7. Select Action...Save from the menu to save your work. 

8. Repeat steps 6 and 7 for each column in this table that you want to modify. 

9. Click the Get Primary Key button to select the column(s) that will make your 
record unique. MetaBuilder opens the Choose PK Constraint window, 
containing a list of unique constraints and their columns. 

10. Select the constraints name that you want to specify as your table’s primary key. 

11. Click the OK button. MetaBuilder enables the PK checkbox for each column 
that belongs to the unique constraint you selected. You can reset these check-
boxes manually at any time. 
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When creating snapshot reports, CCG uses columns selected as PK to group 
records. If your table does not have a primary key or a unique constraint 
defined, ensure that your selection of PK columns makes each record within the 
table unique. Once you define PK columns, navigate to the Tables tab and click 
the Get PK Description button to populate this field. 

12. Click the Set Flags button to set the Audit, Snapshot, Compare, Form and Filter 
checkboxes based on predefined rules for each column. You can reset these 
checkboxes manually at any time. 

13. Decide whether to enable each of these checkboxes: 

• Audit. Select this checkbox to be able to track changes against the data 
contained within this column. 

Oracle E-Business Suite users: Your table must meet the following con-
ditions to be able to use the CCG change tracking functionality: 

– Your table must contain the standard Who columns (CREATION_DATE, 
CREATED_BY, LAST_UPDATE_DATE, LAST_UPDATED_BY). 

– Your table’s CREATED_BY and LAST_UPDATED_BY columns must be 
foreign keys of the Oracle Users table (FND_USER). 

• Snapshot. Select this checkbox to include this column in CCG snapshot 
reports when you select Displayed & non-Displayed Fields option when 
running a report. 

• Compare. Select this checkbox to be able to compare this column across 
points in time or database instances. 

• Form. Select this box to include this column in CCG snapshot reports when 
you select the displayed fields only option when running a report. You 
should not select this checkbox if you do not select the Snapshot checkbox. 

• Filter. Select this checkbox to let CCG users filter on this column when 
running a snapshot report. You should use this checkbox only when the 
associated table is a child table of an object. The columns in the object’s 
parent table are automatically available for filtering whenever Form is 
checked. 

14. Select Action...Save from the menu to save your work. 

15. Press the Validate Columns button to perform a validation on your column 
metadata configuration. MetaBuilder verifies your checkbox selections, your 
metadata, and that you designated a Primary Key. 

16. Select Action...Save from the menu to save your work if you made any changes. 

Insert Phantom Columns 

Phantom columns allow you to add another instance of an existing column to your 
table in the Columns in Table window. It may be the case that you need to use an 
existing column for another data translation for your snapshot reports. We refer to 
columns of this type as phantom columns. 

Follow these steps to add a phantom column: 

1. Select an Order field of the Column record prior to the order in which you want 
add the phantom column. 
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2. Select Row...Insert from the menu to insert a phantom column. 

3. MetaBuilder inserts a record and increments the Order field for the subsequent 
columns. 

4. Navigate to the Name field and select the column that you want to add again 
using the list of values. 

5. Configure this phantom column. Refer to the instructions above. 

6. Select Action...Save from the menu to save your work. 

Insert Missing Columns 

You may have inadvertently deleted a column, or you may have upgraded your ERP 
application version. You can add this new or deleted column using the Insert Miss-
ing Columns button. 

If you have upgraded your ERP application version and want to add missing col-
umns, verify that you have changed your MetaBuilder model instance to the up-
graded ERP instance, and import the table information again using the MetaBuilder: 
Import Table Definitions from Target program. 

Follow these steps to insert a missing column: 

1. In the Columns in Table... window, press the Insert Missing Columns button. 

2. Configure this column. Refer to the instructions above. 

3. Select Action...Save from the menu to save your work. 

Step 12: Assign Translation Details to Columns 

Your table’s columns might require information that is stored in another table, or 
you might want to use data from a different column within the same table. Use the 
Translation Details zone to generate this information. 

You have three options for translating data: 

• Column: Assign the column data from another column of the same table. 

• Function (Existing): assign the column an CCG translation function. 

• Function (New): Create and assign the column a new CCG  translation function. 

Column 

Use this option if you have an inactive column and want to display another column 
data of the same table that you already placed a translation function or you already 
assigned another column data. Thus, you do not have to insert a phantom column. 

1. Select the column to which you want to assign the data of another column. 

2. In the Translation Details zone, enter the following information: 

• Method. Select Column from the drop-down list. 

• Function Name. MetaBuilder disables this field for this option. 

• Column. Select the column containing the data you want to display. 

3. Select Action...Save from the menu to save your work. 
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Function (Existing) 

Use this option if the data that you want to display is stored in more than one table, 
or if you store data as an ID rather than a value, and would like to provide the full 
description of the ID in your snapshot reports. An example of a translation function 
is the conversion of a code combination ID in the Oracle General Ledger to a multi-
segment accounting flexfield value. 

1. Select the column that you want to assign a translation function. 

2. In the Translation Details zone, enter the following information: 

• Method. Select Function from the drop-down list. 

• Function Name. Select the translation function that you want to apply to 
this field.  

To verify or test the selected function name, click the Translation button to 
view the translation function’s definition. 

CCG metadata uses the following name convention: 

tick_app_version.function-name 

In this line: 

– app is the ERP application’s short name. 

– version is the abbreviated version number (e.g., 107, 1103, 1157, 1158, 
1159). 

– function-name is the descriptive name of the function. 

You can find existing functions by navigating to the Translation Function 
window and clicking the Find button. MetaBuilder opens the Find Function 
window. Refer to “Function (New)” below for more information. 

You can also check which columns, if any, apply this translation function. 
Navigate to the Translation Function window, and press the Referenced By 
button. 

• Column. MetaBuilder disables the column field for this method. 

3. Select Action...Save from the menu to save your work. 

Function (New) 

This option is equivalent to Function (Existing) above in all respects but one: the 
translation function that you need does not exist yet. You will create a new transla-
tion function and apply it to the column that you want to translate. 

You may need the assistance of a technical resource (e.g., a developer) to create a 
data translation using this option. 

Follow these steps to create and apply a new translation function: 

Begin to Create a Translation Function 

1. From the Navigator, under MetaBuilder, select Navigate...Maintain 
Metadata...Translation Functions. MetaBuilder opens the form shown at the top 
of the next page. 
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2. Enter the following information to create a translation function: 

• Function Name. Name of your translation function. You should name your 
translation functions logically to facilitate the process of finding and reusing 
these functions. 

• Product Family/Version. Select a product family/version to which you 
want to apply this function. 

• Description. Description of this function. 

• Translation Object Name. This is usually a concatenation of a function 
name and parameter names to be passed to the function. 

You must enter the translation object name in the following form, in which 
name is the function name: 

name(tms.tickvalue) 

The variable tms.tickvalue references the table column record on which you 
apply the function. If you specify the column name instead of using this var-
iable, you will be unable to apply this function to a column in another table 
(one that stores the same information but has a different column name). 

You can include a maximum of four parameters per translation function 
(columns 1, 2 and 3 are column names in the source table): 

name(tms.tickvalue, tms.Column1, tms.Column2, tms.Column3) 

• Parameter Types. Enter the column data types for the parameters that you 
pass to your translation function. Use one of the following values: 

– C. Character 

– N. Number 

– D. Date 
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If you have multiple parameters for your translation object name, separate 
the data types with a comma (,). Other parameter types are not supported. 

• Stored. If you must store the translation function on your ERP instances, 
select this check box after completing “Create a Stored Function,” below. 

Generally, you do not need to do this. Store functions on your ERP 
instances only if the Maintain Translation Functions form cannot support 
the complexity of your function. For example, IF statements and multiple 
SUBSTRING/INSTRING operations are typically created as stored functions. 

• Incompatible with Filters. Select this checkbox if the information in the 
Select Statements For window (see “Finish Creating a Translation Func-
tion” on page 5-17) is incompatible with your stored procedure. This disables 
your ability to update the data in the Select Statements For window. This 
checkbox works only when the Stored checkbox is selected. 

• Parameter Name. Name of the parameter. 

• Type. Data type of the parameter. 

• Order. Order in which you pass the parameter in the Translation Object 
Name field.  

• Assign Select. Enter a function if your translation function contains 
multiple SELECT statements or you want to manipulate the parameter data 
that you are passing. Typically, your translation functions will contain only 
one SELECT statement. In this case, you should leave this field blank. 

Create a Stored Function 

If you are creating a stored function (See the Stored field, above), complete these steps. 
Otherwise, skip ahead to “Finish Creating a Translation Function” (page 5-17). 

1. Click the SELECT Statement(s) button. Enter 'test' (or any other string surrounded 
by single-quote marks) in Translation Function Return Column Code. 
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2. Click the Test button and make note of the long number that appears in the first 
line of Create Stmt Text (underlined in this figure; discard the leading zeroes). 

 

3. Using your database editor, find the row in the CCG Home schema’s 
TICK_META_FUNCTION_OVERLOADS table where meta_function_overload_id 
equals the value noted in the preceding step. 

4. In the same row, the create_stmt_text column holds the statement that defines 
the function. Modify the statement as needed to perform the desired function. 

5. CCG uses an internal function name instead of the name designated in 
MetaBuilder, employing this format: 

tick_f_test_################ 

Remove the string test_ from each occurrence of the internal function name (in 
the first and last lines of the statement). 

6. Copy the new function name to the function_overload_name column. 

7. Return to the MetaBuilder Translation Functions form (see page 5-15), and 
check the Stored checkbox. 

Finish Creating a Translation Funciton 

To finish your translation function (stored or otherwise), complete these steps: 

1. Select Action...Save from the menu to save your work. 

(Press the Delete button if you want to delete your translation function. 
MetaBuilder raises a message to confirm your command.) 
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2. Press the SELECT Statement(s) button to create a SELECT statement for your 
translation function. MetaBuilder opens the SELECT Statements For window. 

 

3. Enter the following information to create a SELECT statement for your transla-
tion function: 

• SELECT NUMBER. MetaBuilder defaults this field to 1. Retain this value for 
your first SELECT statement. If you need to create another SELECT statement, 
press the down arrow key and increment the number. 

• Translation Function Return Column Code. Database column to be 
returned by the Function. You also have the option to perform SQL 
functions on a database column. 

• No Rows Returned Code. Enter a message if you want to return a message 
when your function input value(s) return a NULL value. Your message 
must be enclosed in single quotes ('). 

If your translation function is a valid function and its input values are NULL, 
MetaBuilder returns a NULL value. 

• Order By. Database column name used to sort the results of the SELECT 
statement. Try to make your SELECT statement identify a unique value. If 
your statement returns more than one record, CCG uses the first translated 
value from the sort order. 

• Alias. Alias of the table or view from which you are selecting values. You 
must denote any reference to any table’s columns with the column name 
preceded by the Alias. 
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• Table/View Name. Database table or view from which you are selecting 
values. If the table or view does not exist in the list of values, you must add 
your table in the MetaBuilder Workbench and run MetaBuilder: Synchro-
nize to synchronize your ERP instance prior to creating the function. 

• Order. Number that specifies the order of the tables in the SELECT 
statement. 

• Exclude. Select this checkbox for any table from which you are not directly 
selecting information. 

• Where Clause. Condition(s) of your SELECT statement. Do not include 
the word WHERE in this field. 

4. Select Action...Save from the menu to save your work. 

Test the Translation Function 

After you define your translation function, you must verify that it compiles. You 
have the option to specify test values for each input parameter so that you can verify 
the function’s results. 

First, synchronize the ERP instance that you will test the function on: 

1. Log into CCG. 

2. Select Jobs > Schedule a Job. The Schedule a Job page appears. 

3. Click Add Item... near the bottom of the page. The Items To Execute page 
appears. 

4. Set Program Name to MetaBuilder: Synchronize. 

5. For Tarbet Instance Name, select the ERP instance you want to synchronize. 

6. Press the Save button. The page is refreshed. 

7. Press the Back button. The Schedule a Job page reappears. 

8. Click Schedule. The job is scheduled to run immediately. 

9. Select Jobs > View Current/Past Jobs to view the status of your job. 

Wait until this program has completed successfully prior to viewing your 
changes to the reports. The MetaBuilder: Synchronize program also checks that 
your metadata data structure complies with the data dictionary. 

Return to MetaBuilder and follow these steps to test your new translation 
function: 

10. To test the translation function using specific parameter values, enter the values 
in the Translation Functions window’s Test Value fields. Otherwise, leave the 
Test Value fields empty. 

11. Select Action...Save from the menu to save your work. 



 

5-20 Oracle Configuration Controls Governor Administration Guide 

12. Click the Test button to test your translation function. MetaBuilder opens the 
Create Statement and Test Value window. 

 

This window contains the following three fields: 

• Create Stmt Text:. Contains the code that CCG runs for this translation 
function. Use this field to verify that your definition is correct and/or to 
identify possible mistakes. 

• Create Error Text. Lists the database error encountered if your translation 
function conains a syntax error. This field contains the value No error if 
your translation function compiles on the ERP instance without errors. 

• Test Return Value. Contains the value returned from your translation 
function using your Test Value(s). If you did not specify any input 
parameters, this field is empty. 

Apply the New Translation Function 

Once you have verified that your translation function compiles and returns the 
desired output, you must apply this function to your metadata column. 

1. In the MetaBuilder Workbench, navigate to the Schemas tab pertaining to a 
specific product family/version. 

2. Select the schema that owns the table containing the column you want to 
translate. 

3. Select the table containing the column you want to translate. 

4. Click the Columns button. MetaBuilder opens the Columns in Table window, 
listing all the columns that define this table. 

5. Select the column to which you want to assign a translation function. 

6. In the Translation Details zone, enter the following information: 

• Method. Select Function from the drop-down list. 
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• Function Name. Select the new translation function. To verify or retest the 
Function Name that you selected, press the Translation button to view the 
translation function’s definition. 

• Column. MetaBuilder disables the Column field for this method. 

7. Select Action...Save from the menu to save your work. 

Add Multiple SELECTS to a Translation Function 

The Translation Functions form can handle multiple SELECT statements for a 
column translation. For example, you may need to create SELECT statements based 
on the value of another column in the table. If so, use the Assign Select field to 
handle multiple SELECT statements. Follow these steps: 

1. In MetaBuilder, navigate to the Translation Functions form. 

2. Query the translation function to which you want to assign SELECT statements. 

3. In the Assign Select field, enter a SQL function that assigns the correct SELECT 

NUMBER to the translation function based on certain conditions. Typically, you 
should use the DECODE function. 

4. Press the SELECT Statement(s) buton to create SELECT statements for your 
function. MetaBuilder opens the SELECT Statement(s) window for your 
function. 

5. In the SELECT NUMBER field, navigate to the next record to create another 
SELECT statement. 

6. Increment the SELECT NUMBER. 

7. Enter information for your SELECT statement. See “Create a Translation 
Function.”  

8. Repeat steps 4–7 to create additional SELECT statements. 

9. Select Action...Save from the menu to save your work. 

In the following example, if p_ type = LOW, the translation function uses SELECT 

statement 1. Otherwise, the translation function uses SELECT statement 2. 
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Step 13: Create Objects 

A MetaBuilder object is a group of database tables that store information for 
specific business functions. you must define an object within an application. 

You can create objects based on one or more tables. There is no limit to the number 
of tables that you can link within an object.  

Follow these steps to create an object associated with your application: 

1. In the MetaBuilder Workbench, navigate to the Applications tab pertaining to a 
specific product family/version. 

2. Select the application for which you want to create objects. 

3. Navigate to the Objects tab. The MetaBuilder Workbench displays the applica-
tion that you selected in the Applications tab along with its associated suite 
information. 

 

4. Enter the following information to create an object: 

• Object Name. Identifiable name for the object. 

• Description. Description of the object. 

• Owning Application. Application that will own the object. 

• Status. Read-only: MetaBuilder defaults this field to Enabled. 

5. Select Action...Save from the menu to save your work. 

6. Press the Details button to enter your object’s table information. MetaBuilder 
opens the Object window (as shown at the top of the next page). MetaBuilder 
populates the PK Description field and Parent Table field after you enter your 
object’s table information (in the following step). 

7. Select Action...Save from the menu to save your work. 
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8. Specify the object’s parent table in the Object Tables zone: 

• Order. Enter 1 to identify this table as the object’s parent table. All other 
tables must be descendents of this table. 

• Table Name. Parent Table. The list of values for this field contains only the 
tables that you have previously added in “Step 10: Add Tables to a Schema” 
(page 5-10). 

• Parent Table Name. Leave this field empty, because the parent table has 
no parent. 

• Snapshot. Select this checkbox to include this table in snapshot reports. 

9. Select the change tracking options for the table: 

a. Select the Change Trackable? checkbox to allow change tracking for this 
object. If this is an object that contains tables included in other objects that 
are change trackable, leave this checkbox unchecked. 

Oracle E-Business Suite users: Your table must meet the following condi-
tions to use CCG change tracking functionality: 

• Your table must contain the standard Who columns (CREATION_DATE, 
CREATED_BY, LAST_UPDATE_DATE, LAST_UPDATED_BY). 

• Your table’s CREATED_BY and LAST_UPDATED_BY columns must be 
foreign keys of the Oracle Users table (FND_USER). 

b. Select a value for Tracked by Field if this object is not change trackable 
because another object contains tables from your object. Select the other 
object that contains your object’s tables. 

Be sure to include all tables that you want to change track from the object in 
the tracked by field with the Snapshot? checkbox deselected. 
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10. Select Action...Save from the menu to save your work. 

11. To add more tables if an object comprises more than one table: 

a. Select Row...Insert from the menu 

b. Enter the following information to specify an object’s child table 
information in the Object Tables zone: 

• Order. Enter a number for the order in which you want the table to 
appear in snapshot reports. 

• Table Name. Child table to add to the object. 

• Parent Table Name. Parent table on which the child table is based. 
This value should be a table that has already been added to the object. 

• Snapshot? Select this checkbox to include this table in snapshot 
reports. 

c. Enter the following information to link the parent table to the child table in 
the Joins zone: 

• Parent Column Name. Column from the parent table that has a foreign 
key reference to the child table. 

• Child Column Name. Column from the child table that has a foreign 
key reference to the parent table. 

• Meta Child Table Value. Enter a value if you want to constrain on the 
records returned based on this column value. This field is case-sensitive. 

d. Set change tracking for the table (see the preceding steps). 

e. Select Action...Save from the menu to save your work. 

You must verify that all tables used in a translation function for the object 
are included in the object’s tables information, or accounted for in another 
object. 

f. Repeat step 11 to insert additional child tables. 

You must add any translated tables associated with your parent and child tables. 
This allows you to enable change tracking for these translated tables. You 
should leave the Snapshot? checkbox deselected. 

12. Click the Add Owning App button to allow the Owning Application field to 
view the object. MetaBuilder creates an enabled record in the Cross-references 
zone for the object. 

13. Select Action...Save from the menu to save your work. 

Cross-Reference an Object to another Application 

Several applications may share the same or similar configuration data. MetaBuilder 
lets you assign or cross-reference metadata objects across applications to eliminate 
the need to create duplicate metadata. 

Follow these steps to cross-reference an object to another application: 

1. In the Object window, navigate to the Cross-References zone. 
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2. Select Row...Insert from the menu to enter the following information to create a 
cross-reference object: 

• Meta Application Name. Application to which you want to cross-reference 
the object. 

• Object Displayed Name. Name of the object. Typically, this value equals 
the original object name that you are cross-referencing. You may change 
this value to reflect the exact object name for the other application. 

• Enabled? MetaBuilder selects this checkbox automatically to enable the 
object in the meta application specified. You may deselect the checkbox if 
you do not want to run snapshot report for that application’s object. 

3. To cross-reference additional applications, repeat the preceding step. 

4. Select Action...Save from the menu to save your work. 

Maintain Column Filters 

Security Filters. If you want to add data security to the object, use the Maintain 
Column Filters form. 

 

Oracle E-Business Suite users: If your custom objects are associated with 
organizations and sets of books, you have two options for security: 

• ORG Security. Create a filter of this type to allow Oracle E-Business Suite 
organization security. You should only apply this filter type to meta column 
names that are associated with the ORGANIZATION_ID column in the 
HR_ALL_ORGANIZATION_UNITS table. 

• SOB Security. Create a filter of this type to allow Oracle E-Business Suite set of 
books security. You should only apply this filter type to meta column names 
that are associated with the SET_OF_BOOKS_ID column in the 
GL_SETS_OF_BOOKS table. 

When you create the object in the MetaBuilder Workbench, the workbench auto-
matically adds a security record in this form for the columns ORGANIZATION_ID, 
ORG_ID and SET_OF_BOOKS_ID.  
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PeopleSoft Enterprise users: If your custom objects are associated with SETID, the 
MetaBuilder Workbench also automatically adds a SETID Security record in this 
form pertaining to your object. 

Create Suggested Filters 

You may want to add suggested filters that users can remove when creating 
definitions. For example, PeopleSoft tables contain historic data that users might not 
want to view in snapshots. A suggested filter could remove that data; users who 
want to see only the latest and future data would leave the filter in place, while those 
who want to view historic data would remove it. 

Follow these steps to create a suggested filter: 

1. From the Navigator, under the CCG Developer role, select Navigate...CCG 
Metadata...Maintain Column Filters. MetaBuilder opens the Maintain Column 
Filters form. 

2. Enter the following information (use Edit...List of Values from the menu where 
applicable): 

• Application. Name of the application. 

• Meta Object Name. Name of the object. 

• Meta Table Name. Name of the table (within the object) on which you 
want to apply the suggested filter. 

• Meta Column Name. Name of the column on which you want to apply the 
suggested filter. 

• Condition Type. Select suggestion from the dropdown list. 

• Enabled. Check this box to enable the suggested filter. 

• Description. Description of the suggested filter. 

• Operator. Operator for the condition that will be applied to the meta 
column name during the snapshot run.  The list of values for this field 
changes based on the data type. 

• Expression. Enter the expression for the condition precisely as you would 
in a WHERE clause of a SELECT statement.  For example, enter single quotes 
before and after literal values. 

3. To create another suggested filter on this object, select Row...Insert from the 
menu and repeat the preceding step. You may create as many suggested filters 
as you like. 

4. Select Action...Save from the menu to save your work. 

Copy a Standard CCG Object 

You may want to modify the metadata of a standard CCG object to better manage 
your business requirements. This CCG program lets you copy and modify a stan-
dard CCG object instead of having to recreate metadata that already exists. 

Follow these steps to copy and modify a standard CCG object. 

1. Log into CCG. 

2. Select Jobs > Schedule a Job. The Schedule a Job page appears. 
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3. Click Add Item... near the bottom of the page. The Items To Execute page 
appears. 

4. Set Program Name to MetaBuilder: Copy Standard CCG Object. 

5. Enter the following information: 

• Copy From Product. Product family version from which you want your 
application. 

• From Application. Application from which you want your CCG object. 

• From Object. CCG object you want to copy. 

• Copy to Product. Product family version to which you want to your 
application. 

• To Appplication. Application to which you want to create the object. 

• New Object Name. Name for your new object. 

6. Press the Save button. The page is refreshed. 

7. Press the Back button. The Schedule a Job page reappears. 

8. Click Schedule. The job is scheduled to run immediately. 

9. Select Jobs > View Current/Past Jobs to view the status of your job. 

10. Repeat the steps above to copy additional standard CCG objects. 

Use this program only when you have not imported and manually added tables or 
views that are the underlying metadata of the CCG objects you intend to copy. 

Step 14: Synchronize 

After you make changes or create new metadata within the MetaBuilder Work-
bench, you must run a synchronization process to update the metadata for your ERP 
instances. 

Configuration Controls Governor does not display metadata changes if you do not 
run the following program. 

Follow these steps to run this program: 

1. Log into CCG. 

2. Select Jobs > Schedule a Job. The Schedule a Job page appears. 

3. Click Add Item... near the bottom of the page. The Items To Execute page 
appears. 

4. Set Program Name to MetaBuilder: Synchronize. 

5. For Target Instance Name, select the ERP instance you want to synchtronize. 

6. Press the Save button. The page is refreshed. 

7. Press the Back button. The Schedule a Job page reappears. 

8. Click Schedule. The job is scheduled to run immediately. 
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9. Select Jobs > View Current/Past Jobs to view the status of your job. 

Wait until this program has completed successfully prior to viewing your 
changes to the reports. The MetaBuilder: Synchronize program also checks that 
your metadata data structure complies with the data dictionary. 

10. Repeat steps 2–9 to synchronize additional ERP instances. 

Step 15: Manage Security Groups 

Security Groups control the ERP data that users can access. Each group has several 
permissions; one of them determines the applications whose data can be accessed. 

Users who belong to groups with the applications permission left blank can access 
data from all applications, including the new application you have created in the 
preceding steps. No other users will have access to the new application’s data unless 
you one of the following 

• Add them to a group with the Applications permission left blank 

• Create a new Security Group with Applications set to the new application, and 
add the users to the group 

For more information about security groups, see Create Users, Roles, and Security 
Groups (page 2-11). 

Step 16: Test Metadata 

Once you have created your metadata, you must verify that CCG monitors your 
objects accurately when using it. Follow these steps: 

1. Log into CCG. 

2. Create and schedule one or more snapshot definitions. Verify that their reports 
contain the data you see in your ERP applications.  

3. Compare two snapshot reports and verify the results.  

4. Create and deploy one or more change tracking definitions. Schedule and run 
the Change Tracking Transfer program. Verify that the change tracker contains 
the correct data.  

For instructions on completing steps 2–4, see the Configuration Controls Governor 
User Guide. 

MetaBuilder Glossary 

Application. An application is a set of forms, menus, reports and other components 
that satisfies a particular business function. General Ledger is an example of an appli-
cation. The application stores the accounting and tracking of fixed assets for a site. 

Columns. Columns are subdivisions of a table with a column name and data type. 

Configure. A configure process configures your ERP instance for your CCG  solu-
tion component. This process allows your CCG users to run snapshots, translation 
functions, change tracking and other jobs. 
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Cross-references. Two or more applications can share configuration data; to 
eliminate the need to create metadata multiple times, CCG let you assign (cross-
reference) metadata objects across applications. 

Data Dictionary. A data dictionary is a central source of information for the 
database itself and for its users. This dictionary contains a comprehensive set of all 
tables and views within the database. 

MetaBuilder — Copy Standard CCG Object. A program that allows a user to 
copy an object from Standard CCG objects to the user’s custom applications. 

MetaBuilder — Import Table Definitions from Target. A program used to 
import information from an ERP instance’s database dictionary into an CCG table 
that stores data dictionary information for which a user would like to track via 
metadata. 

MetaBuilder Model Instance. Database instance where the data dictionary 
information that you use for metadata development is kept. 

MetaBuilder — Synchronize. A program that copies metadata to ERP instances. 

Object. An object is a logical grouping of database tables that store information 
based on specific business functions within an application. Payables Options is an 
example of a setup object on which a user can base a snapshot definition. 

Phantom Column. A phantom column is a duplicate column. Please refer to 
Column. 

Product Family. A product family is a software product that provides a business 
solution. Product families often contain different versions. Software companies 
typically provide increased functionality within their product with each version that 
they release. Oracle E-Business Suite is an example of a product family. It is a 
product that supports many different business functions. 

Product Family Version. A product family version is a specific release of a 
product family.  Most applications usually denote versions with numbers. Version 
11i of Oracle E-Business Suite is an example of a product family version. 

Schemas. A Schema owns a collection of database objects, such as tables, stored 
procedures and functions, triggers, synonyms, etc. AP is an example of an Oracle E-
Business Suite schema. Within the database, the AP schema contains all database 
objects associated with the Oracle Payables application. 

Suite. A suite comprises a number of applications within a product family, usually 
corresponding to a group of inter-related business processes. Oracle Financials is an 
example of a suite.  The software contains a number of different applications (GL, 
AP, AR, FA, etc.) to support the financial accounting of a business. 

Table. A table is the basic data storage structure in a relational database 
management system. Tables consist of rows and columns. 

Translation Function. If your data is stored as an ID rather than as a literal value, 
and you would like to provide the full description of the ID on your snapshot defi-
nition output, you use a translation function. An example of a translation function is 
the conversion of a code combination ID (CCID) in the Oracle General Ledger to a 
multisegment accounting flexfield value. 
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