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Introduction

Cimmetry Systems Corp. has developed afamily of products designed to meet all
levels of business and engineering needs. Collectively, our products provide
viewing and Markup capabilities, and support the visualization of 2D
engineering and office formats.

AutoVue

AutoVueisaviewing and Markup application that has been developed for both
business and technical users.

AutoVueis capable of displaying over 450 different file formats without the
authoring application. Supported file types include text, database, graphic and
spreadsheet. Even contents of archive files can viewed in AutoVue. Moreover,
when you view afile you do not need to specify the file type. AutoVue
automatically detects the type of file you are requesting to view — even files
with false extensions!

Marking Up Documents

AutoVue has the ability to create markupsfor all its readable file formats without
the document's authoring application. AutoVue creates markups for different
formats without modifying the origina file.

You can attach comments, notes and drawings to any file you display in
AutoVue. Thisis called marking up afile, commonly known as annotating or
redlining. A Markup is an object or entity that you attach to afile. All Markups
are saved in a separate file called aMarkup or aMarkup file. However, when
you display afile with its Markups, the Markups appear to be part of it.

AutoVue provides avariety of flexible, user-friendly entities. To name a few,
there are circles, clouds, polygons and leaders. You can also attach text to
entities, insert a note for longer comments or add a symbol such as a company
logo. In addition, you can create measurement markup entities and hyperlinks
that link between the current file and other associated files or applications.
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Starting AutoVue

1

From the Windows Start menu, select Programs > AutoVue, Desktop
Edition > AutoVue....

or...

From the Windows Start menu, select Run.

The Run dialog appears.

Enter the path and filename for avwin.exe.

Example: C:\Progra~l\av\avwin\avwin.exe

Click OK.

The main AutoVue window appears.

Note After starting AutoVue, an AutoVueicon @ appears in the system
tray located on the far right side of thetask bar. Thisiconisaways
accessible after exiting AutoVue since AutoVue continues running until you

close AutoVue completely. Right-click the AutoVueicon @ to access the
system tray Quick Menu. To resume working with AutoVue, double-click
theicon or right-click the icon and select Restore AutoVue from the
Quick menu.

Exiting AutoVue

1

Select File > Exit from the AutoVue main menu.
or...

Click the Close button Q] in the upper right corner of the window.
or...

From the system tray, right-click the AutoVue icon @ and select Close

AutoVue from the Quick Menu.
AutoVue closes completely and the icon disappears from the system tray.
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Help About

AutoVue provides a Help menu that allows you to easily access information on
how to use AutoVue.

From the Help About dialog, you can see information about your current
installation of AutoVue. Information such as the variation of AutoVue you are
using, the version, the build number and the current language that AutoVueis
running is displayed. You can aso change the localization of the AutoVue user
interface.
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Changing the Locale of
AutoVue

AutoVue supports different localizations for the User Interface. AutoVue
supports the following languages: English, French, German, Chinese, Japanese
and Korean.

1 Select Help > About from the AutoVue main menu.
2 TheAbout diaog appears.
3 Click Change Language.

The Language Change dialog appears.

Language Change ﬂ

Current language: I = Default =

Mew language: I j

Ok I Cancel |

From the New Language drop-down list, select the language you want.
Click OK.

Click OK inthe About dialog.

Restart AutoVue for the new localization to take effect.

~No o h~
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Viewing and Exporting File
Versions Information

From the Help About dialog, you can view the version, build number and date
of the decoder dll files, aswell as export the filesinto atext file.

Viewing File Versions

1 Select Help > About from the AutoVue main menu.
The About dialog appears.

2 Click Version Info....
The File Versions dialog appears.

3 Whenyou are finished viewing, click Close.

Exporting File Versions

1 Select Help > About from the AutoVue main menu.
The About dialog appears.
2 Click Version Info....
The File Versions dialog appears.
3 Click Export....
The Export dialog appears.
Navigate and select the directory you want to export the file to.
Enter aFile name with the extension .txt.
Note: Thefile can only be exported to text file.
6 Click Save.
The markup fileis exported to the selected directory.

(G2 >3
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AutoVue Basics

This section introduces you to the basics of working with AutoVue's graphical
user interface.

H Auto¥ue Electro-Mechanical Professional, Desktop Edition - [AutoCad3D_2007. dwg]
:E\Ia Edit  ¥iew Analysis Options Window Help
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) Models| B Views B Bookmarks

6] /@] | Autocad3b_201 AutoCAD 2007-2008 114% |pa 3/3 162240 bytes  |2007/02/01
=

Menu Bar

The Menu bar isthe main access to al the menu commands. The selection of
commands changes according to the tasks being accomplished by AutoVue. In
addition, the Menu bar can be configured to include and exclude items via DDE
scripting capabilities. For more information, see the AutoVue APl Manual.
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Toolbars

Toolbars are fully adaptable to individual work preferences and can be easily
customized, moved or removed. The Toolbar buttons offer easy access to the
options presented in the drop-down menus found in the Menu bar.

Status Bar

In both View mode and Markup mode, thereis a Status bar located at the
bottom of the main window. The fields displayed from left to right on the Status
bar are: marker, current active filename, file type, zoom factor, current page and
total number of pages, current active file size, file creation date and cursor’s
coordinate position.

In addition to the fields, there are two markers that may be present on the Status
bar.

Thered light bulb " indicates that the current active file has associated
Markups. Whilein View mode, click the red light bulb to view the Markup
Files dialog, then select a Markup file or group of Markup filesto open. By
opening a Markup file, Markup mode is automatically launched.

win

A redcirclewithan“i” € indicates that some main resources required to
properly read the current active file are not available. To identify the missing
resources, click the red circle to display the File Properties dialog.

Quick Menus

One of the quickest ways to access optionsisthrough Quick Menus —— or
context-sensitive shortcut menus. These are the menus you see when you right-
click in theworkspace. The Quick Menu options available depend on the mode
you arein and what is selected prior to right-clicking.

Cimmetry Systems Corp.



8 AutoVue

Opening Files with AutoVue

How to open files depends on the current active mode in AutoVue. In View
mode, you can open basefiles. In Markup mode, you can open aMarkup filefor
abasefile.

You can browse filesin a directory, open files simultaneously and view the
contents of archivefiles.

Openlng a File

Select File > Open from the AutoVue main menu.
The Open dialog appears.
Enter aFile name or browse to locate the file that you want to open.
3 Click Open.
The file appears in the AutoVue workspace.

N

Opening Multiple Windows

By default, AutoVue keeps onefile open at atime. If you open a new file, the
currently opened file is replaced with the new file. However, it is possible to have
multiple files open by creating windows within AutoVue.

1 Select Window > New from the AutoVue main menu.
A new window appears on top of the opened file.

2 SelectFile > Open.
The Open dialog box appears.

3 FromtheLook in drop-down list, select the file that you want to open or
enter the File name.

4  Click Open.
The file appearsin the new window.
Note You can open as many windows as you like by selecting Window >
New and repeating steps 2 to 4.

Viewing Multiple Files at the Same
Time

You can arrange the files so you can view them at the same time.
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Select Window > Cascade if you want the files to appear on top of each other.
Select Window > Tile Horizontally if you want the files to appear side by
side.

Select Window > Tile Vertically if you want the files to appear above each
other.

Browsing Files

When you use the Browse option, all files and foldersin the current directory
are displayed in the Browse dialog and the last file opened is highlighted.

1 Select File > Browse from the AutoVue main menu.
The Browse dialog appears listing the files located in the current active
directory.

Note You can also click the Browse button & on the AutoVue tool bar.
2 Tochangethe current active directory, type the full path of the directory in
thetext field at the top of the Browse dialog.
Thelist of files contained in the directory appear.
3 Sdect thefile that you want to view.
Thefileis displayed in the AutoVue workspace.
4  Continue selecting and viewing files as often as you like since the Browse
dialog box floats over the other AutoVue windows.
5 Click Close to close the Browse dialog.
Thelast file displayed remains open.
Note You can aso browse filesin the current active directory by selecting

File > Next File or Previous File or by clicking the Next File button b,

or the Previous File button ’-’1 on the AutoVue tool bar.

Archive Files

The full archive file directory displaysin the AutoVue window. It is not
necessary to decompress the file. Double-click afile to display it within
AutoVue. If you would like to markup an archive file, the file must be accessible
for AutoVue in aformat other than archive.
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Viewing File Properties

You can access the file properties from the File menu. The Properties dialog
providesinformation specific to the current activefile, such asfilename, file size,
date of creation and file type. The file properties that you can view are:

Property Description

File Information specific to the current activefile, such asfilename, file
size, date of creation, filetypeand X, y & z dimensions.

Resource Resources specific to the current activefile, such astext font,
Information shape file, line style and external reference files.
Native Custom propertiesfor file types, such aslast person who saved the

file, signature verification and author comments.

Note Thefile properties can vary depending on the file format viewed.

1 Select File > Properties from the AutoVue main menu.
The Properties dialog appears.

2 Toview file properties, click the File Properties tab.
To view resource information, click the Resource Information tab.
To view native properties, click the Native Properties tab.

3 Click OK to closethedialog.

Selecting

The Select option is available when viewing graphic and non-graphic files. For
non-graphic files, you can only select text, click and drag to the select text.

1 Select Edit > Select from the AutoVue main menu.
A checkmark appears beside Select.

2 Inthegraphic file, click and drag the area you want to select.

3 Toselect ablock of text, database or spreadsheet cells, etc., position the
cursor at the beginning of the block, then while pressing the Shift key click
at the end of the block.

4 To copy the selected data, select Edit > Copy or press Ctrl+C.

The dataiis sent to the clipboard.
Note To exit Select mode, select Edit > Select. The checkmark
disappears.
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Associations

Files of a particular file extension can be associated with an application other
than AutoVue. These files can be opened by the associated application for
viewing, editing and printing. For example, you can configure WordPerfect to
openadl .wpd filesfor viewing and printing, while you are operating AutoVue.
If you have afile with a non-standard extension, this option can associate that
particular file with AutoVue.

Note Sinceonly files and programs of the same type can be associated, select
programs that use the same extensions for their files as the current active file.

Creating an Association

1 Select File > Associate from the AutoVue main menu.

A dialog appears with the full path of the current active file displayed in the
title bar.

Enter adescription for the association (optional).

3 IntheCommand Line, enter the full path or click Browse to locate the
program that you want to associate with the current file.

Click OK.

To activate the association, select File > Launch.

The associated program is launched.

N
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Removing an Association

1 Select File > Associate from the AutoVue main menu.
A dialog appears with the full path of the current activefile displayed in the
title bar.

2 Click Remove.
The associated program file disappears.

3 Click OK to close the dialog.

Activating an Association

1 Openthefilethat you want to activate an association, then select File >
Launch from the AutoVue main menu.
The associated program is launched.
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Working With 2D Files

AutoVue provides easy access to entity information and displays color-coded
comparative data for 2D drawings. You can instantly manipulate how the current
activefileis displayed. You can also modify AutoVue to suit your needs and
preferences through a broad range of configuration options.

Searching Text

You can perform atext search on 2D vector and text-based documents.
Note You can not perform atext search on raster files.

AutoVue provides search options that you can use to customize a search. These
options are:

Option Description

Match Whole Word Only Match a complete word.

Match Case Search for aword or text string with specific
capitalization.

Up Search backward in the document.

Down Search forward in the document.

1 Select Edit > Search from the AutoVue main menu.
The Find dialog appears.
2 IntheFind What text box, enter the word or phrase that you want to find.
Note If you are searching in avector file, select atext string from thelist.
3 Customize your search.
4 Click Find Next.
AutoVue highlights the text and zooms into the text area.
5 Click Close to close the Find dialog.
Note To repeat thelast search criteria, select Edit > Repeat Search from
the AutoVue main menu.
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Manipulating 2D Views

With the View options you can instantly manipul ate how the current activefileis
displayed. You can rotate afile's orientation counterclockwise by 90, 180 or 270
degrees, flip afile’s orientation horizontaly, vertically or both simultaneously.

AutoVue provides several ways to change the view size of a selected area of a
file, display different views, layers and blocks of the current active file. You can
also navigate from one page to another page of a multi-pagefile.

You can access these options from the View menu. The options are:

Menu Option Description

Zoom In Zoom in by afactor of 2.

From the toobar, click the &1 button.

Out Zoom out by afactor of 2.
From the toobar, click the a button.

Full Resolution Display thefile at full resolution.
From the toobar, click the ﬁ button.

Fit Adjust the contents of afile along the
horizontal or vertical axisto fully display
within the current window.

Fit Both - AutoVue finds the best fit for the
current file with respect to both its vertical and
horizontal dimensions.

Note ThisoptionisalsoknownasZoom Fit
when right-clicking in the workspace.

Fit Vertical - Fit theimage vertically in the
active window. The horizontal dimensions of
the image are zoomed proportionally but may
be too large or small for the window.
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Menu Option Description

Fit Horizontal - Fit theimage horizontally in
the active window. The vertical dimensions of
the image are zoomed proportionally but may
be too large or small for the window.

Note Thisoptionisalso know asZoom
Page Width when right-clicking in the
workspace.

Previous Revert to the previous selected zoom option.

Note The Rotate optionisdisabled for text-based documents and spreadsheets.
Rotate 0 Set thefile to its original position.
From the toobar, click the KI? button.
20 Rotate the file 90 degrees anti-clockwise.
From the toobar, click the Eh button.
180 Rotate the file 180 degrees anti-clockwise.
From the toobar, click the Iﬁ?ﬂ button.
270 Rotate the file 270 degrees anti-clockwise.

From the toobar, click the ﬁ button.

Note Whenin Markup mode, you can specify if the rotate is to be applied to the
Markups only or to the base file and Markups.

Note TheFlip option is disabled for text-based documents and spreadsheets.
Flip None Reset the drawing to its original position.

Horizontal Axis Flip the drawing onits horizontal axis.

Vertical Axis Flip the drawing onits vertical axis.
Both Axes Flip the drawing on its vertical and horizontal
axes.

Note Whenin Markup mode, you can specify if the flip is to be applied to the
Markups only or to the base file and Markups.
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Menu Option

Description

Note TheImage optionisused for black-and-white (monochrome) raster files.

Image Contrast Light, normal, dark and darkest.
Anti-alias Enhance the details of monochrome raster files.
Note Also known as*“Scaeto Grey”.
Invert Reverse the background and foreground colors.
Page Next Page Go to the next page of amulti-page file.
From the toobar, click the T[?F button.
Previous Page Go to the previous page of a multi-page file.
From the toobar, click the TKF button.
Page Number Go to the specified page of amulti-pagefile.

From the toobar, click the bt button.

Specid View Birds Eye
Modes

Magnify Glass

Magnify Window

Display aclose-up view of aparticular areaof a
file while maintaining a view of the entirefile.

From the toobar, click the S button.

Note TheBirds Eye optionisdisabled for
text-based documents and spreadsheets.

See Using Bird's Eye View

Magnify an area of thefile that is specified by
the cursor location.

From the toobar, click the = button.
See Using the Magnifying Glass

Magnify aselected area of afile and displaysit
in the Magnify Window.

From the toobar, click the & putton.
See Using the Magnifying Window

Click and drag to move the drawing. To exit
right-click.
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Menu Option Description
Show Model Show/hide the Model tree of the current
Tree activefile.

Using Birds Eye View

TheBirds Eye view option allows a close-up view of a particular area of afile
while maintaining a full view of the file. The Birds Eye window displays a
miniature version of the file. A movable box frame on top of the miniature
indicates the area of the file displayed in the AutoVue workspace.

Note TheBirds Eye option isdisabled for text-based documents and
spreadsheets.

1 Select View > Special View Modes > Birds Eye from the AutoVue
main menu.
TheBird’s Eye window appears displaying afull view of thefile.

2 Toview thechangesin“rea time”, select Options > Dynamic from the
Birds Eye menu.

3 Toview aclose-up of aspecific area of the file in the AutoVue workspace,
minimize the frame box by clicking and dragging the frame handles.
To view adifferent area of the file in the AutoVue workspace, click and drag
the frame box to the area that you want to view.
Note If you perform azoom function in the AutoVue workspace, the area
displayed in the workspace is highlighted by the frame box in the Birds
Eye window.

4 Select Bird’'s Eye > Exit to closethe Bird’s Eye dialog.
The last view performed remains in the AutoVue workspace.

Using the Magnify Glass

The Magnify Glass view option zooms an area specified by the position of the
Magnify Glass. You can view the details of a selected area of afile while
maintaining afull view of thefile.

1 Select View > Special View Modes > Magnify Glass from the
AutoVue main menu.

Note You can also click the Magnify Glass button &L onthe AutoVue
toolbar.
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Move the cursor to the area that you want to magnify.
3 Click and hold the left mouse button.

The areais magnified in the Magnify Glass.

Note To view different areas of thefile, click and drag the mouse.
4 Right-click to exit Magnify Glass.

Using the Magnify Window

The Magnify Window option zooms an area specified by the position of the
cursor. You can view the details of a select portion of the displayed file while
maintaining the display of the full file.

1 Select View > Special View Modes > Magnify Window from the
AutoVue main menul.
The Magnify Window appears.

Note You can also click the Magnify Window button L@ on the AutoVue
tool bar.

2 Movethe cursor to the area that you want to magnify in the current active
file.

3 Click once.
The area appears magnified in the Magnify Window.

4 Right-click to exit the Magnify Window.

Conversion

Sometimes you need to trandate afile to be able to use it with an application it
was not created from. AutoVue provides several conversion file formats for you.
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Conversion Options

Depending on the conversion type being performed, the available options in the
Convert dialog will vary. These options are:

Option Description

Color Depth Select an option from the drop-down list:
¢ 1 =Black and white
e 4=16colors
e 8=256colors
e 24 =Truecolor
e auto = AutoVue selects the color depth that best
matches the origind file.

Convert to Format A drop-down list of all the possible types of output file
formats currently availablefor conversion. The available
formats are:

e CALSGP4
e Encapsulated Postscript (Raster)
e HPLaserjet Printer (HLP)

 PCX Bitmap

e PDF

¢ RunLengthRLCFile
e TIFF

¢ Windows Bitmap

Output Specify the name and path of the file in which the con-
version isto be stored. Thisfileisalso known asthe

output file. You can use Browse to provide AutoVue
with thefile's path.

Sub-Format The Sub-Format drop-down list appears when you
selected HP Laserjet Print or TIFF from the
Convert to Format drop-down list. Select a sub-
format from the drop-down list..
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Option

Description

Convert Region

Convert Pages

XandY

The area of the file to be converted. The available

options are:

» Display - the area displayed in the workspace.
For example, if you zoomed in on a particular
region of the file, the zoomed portion of thefileis
converted.

« Extent - refersto the entire extents of thefile.

The number of pages to be converted. The available
options are:

* All - convert al pages

« Current - convert the current page

¢ Range - convert the pages indicated in the range

Choose from pixels, inches and millimeters for the units.

Note With raster filesthe units are preset as pixels:

«  Xindicates the number of horizontal pixels

e Y isthe number of vertical pixelsfor the current
active file contents.

At times, AutoVue will preset X and Y to match the

specifications of the selected conversion file format.

Other times, X and Y will be available and may be

changed according to your preferences. Your selection

here will not affect the current display but will affect the

conversion file's resolution.

PDF

With AutoVueit is possible to convert Office, 2D and EDA formatsto PDF.
When converted from Markup Mode, markups are “burned” onto the PDF.
When you open the PDF, you will see the base file along with all markups.

XandY

Three factors affect the resolution of animage: the type of image you are
scanning, the output device and the acceptable file size. High-resolution scans
often require large files, causing longer processing and print time. Note that a
high-resolution may not produce a better-quality printed image if your output
device does not recognize the higher resolution information stored in the file. To
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keep file sizes manageable, select the lowest resolution that provides acceptable
quality on your output device.

With some file types, the Size option appears giving you a choice between
millimeters and inches. Page sizes can be selected from the Size drop-down list
or you can customize page sizes by configuring the Initialization file. For more
information, see System Administration Guide.

Technical Drawing Page Sizes ISO Paper Format
A8.5" X 11.0" (216 mm X 279 mm) A4 285 mm X 198 mm
B11.0" X 17.0" (279 mm X 432 mm) A3 396 mm X 273 mm
C17.0" X 22.0” (432 mm X 559 mm) A2 570 mm X 396 mm
D22.0" X 34.0" (559 mm X 864 mm) Al 817 mm X 570 mm
E34.0" X 44.0” (864 mm X 1118 mm) A0 1165 mm X 817 mm

Converting a File

1 Select File > Convert from the AutoVue main menu.
The Convert dialog appears.
Note TheInput areavaries according to the type of file. A word-
processing file displays the file format; araster file displays the file format
and size;vector and database files display the size, file type and dimensions.

2 Inthe Save As text box, enter the path and filename or click Browse to
locate the directory where you want to save the converted file.
Note If writing on to an existing file, the contents of the output file will be
overwritten.

3 Specify the conversion options.
See Conversion Options

4 Click OK. Thefileis converted and appears in the specified directory.
Note You can convert several selected pages of amulti-page file to a multi-
page TIFF.

See Also Batch Conversion

Changing the Pen Settings

With AutoVue, you can specify a thickness for each pen color.
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Note Thisoption only appliesto vector files.

1

2

10

11

Select File > Convert from the AutoVue main menu.

The Convert dialog appears.

Click Pens.

The Pen Settings dialog appears.

Inthe From/To, select the Color Index for which you want to modify the
thickness.

Note To select more than one Color Index, click the Shift or Ctrl key
while selecting.

From the Units drop-down list, select the unit in which you want to set the
thickness.

Click Thickness.

The Modify Pen Thickness dialog appears.

Enter athickness.

Click OK.

The new Thickness appears beside the selected Color Index.

To save the changes that you made, click Save As.

The Save As dialog appears.

Enter aName for the new pen settings.

Click OK.

The new pen settings are saved and appear in the Current Pen Settings
list.

Note To modify an existing Pen Settings, select the pen settings from the
Current Pen Settings drop-down list, make the changes, then click
Save.

Click OK to closethe Pen Settings dialog.

Batch Conversion

You can save time by simultaneously converting files with the same output file
format.

1

2

Select File > Convert from the AutoVue main menu.

The Convert dialog appears.

Click Batch Convert.

TheBatch Convert dialog appears.

Click Add. The Open dialog appears.

Enter the File name or browse to locate the file that you want to add, then
click Open.

Thefile appearsin the Input File List.
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Note To add morefiles, repeat steps 3 to 4. To remove afile, select thefile
fromthe Input File List and click Remove.

5 Customize the convert options.
See Converting a File

6 Click OK.
AutoVue stores the newly converted file(s) in the same directory as the first
fileyou entered in the Input File List.

Measuring in 2D non-vector Files

AutoVue provides the ability to perform measurementsin 2D files. Measure
options vary between vector and non-vector files. For vector files, AutoVue
providesthe option to “snap” to fixed points on the drawing. For non-vector files,
you can only “free snap”.

AutoVue provides several measure options that you can choose from.You can
access the measure options from the Analysis > Measure menu. The options
are:

Name Description
Angle Measure the angle between selected points.
Click the Angle button in the toolbar.
Arc Measure an arc.
Click the Arc button in the tool bar.
Area Measure a selected area.

Click the Area button in the toolbar.

Distance Measure the distance between two points.

P4
Click the Distance button in the toolbar.

Measuring Distance

Use the Distance option to measure the distance between two specific points.

1 Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.
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Note You can aso click the Distance button on the AutoVue toolbar.
Click the Distance tab.

From the Measured Distance Units drop-down list, select the unit in
which you want to measure the distance.

Note [f you want to measure the distance along a path, select Cumulative.
Click a paint on the drawing to define the starting point.

Click another point on the drawing to define the end point.

Note If you selected Cumulative, continue clicking points along the path
that you want to measure.

Right-click to complete the measurement.

The points are joined by aline. The measured distance, Delta-X and Delta-Y
appear in the Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Calibrating Distance

1

M easure distance between two points or measure cumulative distance.

See Measuring Distance

Inthe Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured
distance.

From the Measured Dist. drop-down list, select the unit to which you want
to calibrate the distance.

Click Calibrate to and enter avalue if you want to calibrate the distance to
avalue.

Click Set Factor and enter avalue if you want to calibrate the distance by a
factor.

Click OK.

The calibration result appears in the Measurement dialog.

Click Close to close the Measurement dialog.

Measuring Area

Use the Area option to measure the area and perimeter of aregion.

1

Select Analysis > Measure from the AutoVue main menu.The
Measurement dialog appears.

Note You can aso click the Area button on the AutoVue toolbar.
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Click the Area tab.

From the Measured Area Units drop-down list, select the unit in which
you want to measure the area.

From the Perimeter Units drop-down list, select the unit in which you
want to measure the perimeter.

Note TocumulateaNet Area Result of different areas, select Add in the
Measurement dialog. To subtract an areafrom the Net Area Result,
select Subtract. Select Clear to clear the Net Area Result.

Click a point on the drawing to define the starting point.

Continue clicking points on the drawing to define the area you want to
measure.

Each point isjoined by aline. The area and perimeter measurements appear
in the Measurement dialog.

Right-click to complete the measurement.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Measuring an Angle

Use the Angle option to measure the angle between points on a drawing.

1

N

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Angle button on the AutoVue toolbar.
Click the Angle tab.

From the Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.

Click points on the drawing to define the angle you want to measure.
Angle arms appear with an arc connecting them. The angle measurement
appears in the Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Measuring an Arc

Use the Arc option to define an arc in the drawing and measure its radius, center
and diameter.

1

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Cimmetry Systems Corp.



AutoVue 25

N

Note You can aso click the Arc button on the AutoVue toolbar.

Click the Arc tab.

From the Arc Info drop-down list, select the unit in which you want to
measure the arc.

From the Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.

Click points on the drawing to define the arc.

The points are joined by an arc. The measurements for center point
coordinates, radius, diameter, arc length, start and end of angle and sweep
appear in the Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Calibrating an Arc

1

Measure an arc in the drawing.

See Measuring an Arc

Inthe Measurement dialog, click Calibrate.

The Radius Calibration dialog appears displaying the measured distance.
From the Measured Rad. drop-down list, select the unit to which you want
to calibrate the distance.

Click Calibrate to and enter avalue if you want to calibrate to a value.
Click Set Factor and enter avalueif you want to calibrate by afactor.
Click OK.

The calibration result appear in the Measurement dialog.

Click Close to close the Measurement dialog.

Working with 2D Vector Files

In addition to all features that are available for generic 2D files, AutoVue
provides the ability to access entity information, access views saved in the
drawing and the ability to “intelligent snap” when performing measurements.

AutoVue references various sources to obtain all data required to completely and
accurately display vector files. These sources can be internal to the file, like
layers and blocks or external reference files that are located outside the file.

Cimmetry Systems Corp.



26 AutoVue

Manipulating 2D Vector Views

With the View options you can instantly manipul ate how the current activefileis
displayed. You can rotate afile€'s orientation counterclock-wise by 90, 180 or 270
degrees, flip afile’s orientation horizontaly, vertically or both simultaneoudly.
AutoVue provides several ways to change the view size of a selected area of a
file, display different views, layers and blocks of the current active file. You can
also navigate from one page to another page of a multi-page file. For more
information on how to manipulate views, see Manipulating 2D Views.

For 2D vector files, there are additional View options:

Option Description

Views Select and display different views of a drawing.

From the toobar, click the B button.
See Selecting Views

Layers Select and display different layers of a drawing.
From the toobar, click the button.
See Layers

Blocks Select and display ablock from a drawing.

From the toobar, click the % button.
See Blocks

Drawing Information

The Drawing Information option is available with AutoCAD and
MicroStation drawings, and is accessed from Analysis of the AutoVue main
menu in both View and Markup modes. The Drawing Information options
available are: Select Single Entity, List Tags/Attributes and Entity
Information.

Viewing Details of a Single Entity

Note Thisfeatureiscurrently not supported with AutoVue Server running on
Unix Platforms.
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Select Analysis > Drawing Information > Select Single Entity from
the AutoVue main menu.

Click the entity for which you want to view information.

The Get Entity Info dialog appears displaying the information for the
selected entity.

The XData button appears if additional information exists for that entity.
Click XData to view the information.

Note If you did not select an entity, a message appears informing you that
no entities were found and prompts you to select again.

Click OK to closethe Get Entity Info dialog.

Viewing information for a Set of Entities
Note Thisfeatureiscurrently not supported with AutoVue Server running on
Unix Platforms.

The Entity Information option allows you to view information of a set of
entities contained in a specific area of afile.

1

2

3

Select Analysis > Drawing Information > Entity Information from
the AutoVue main menu.

Click and drag to draw a box around an area for which you want to view
entity information for the list of entities contained inside the area.

The List Entities dialog appears displaying the information of all the
selected entities.

Note If there are no entities within the selected area, a message appears
informing you that no entities were found and prompts you to select again.
Click OK to closethe List Entities dialog.

Viewing Tags/Attributes

Note Thisfeatureiscurrently not supported with AutoVue Server running on
Unix Platforms.

1

2

Select Analysis > Drawing Information > List Tags/Attributes from
the AutoVue main menu.

Click inthe area of the file for which you want to view information on block
attributes and tags.

The Block Attributes dialog appears displaying the attributes/tags for the
selected entity.

Note If there are no entities within the selected box, a message appears
informing you that no entities were found and prompts you to select again.
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3 Click OK toclosethe Block Attributes dialog.

Viewing XRefs

AutoVue references various sources to obtain all the data required to completely
and correctly display files. These sources can be internal to the file, like layers
and blocks. External reference files or Xrefs are located outside the file.

Use the XRefs option to display the external references of the current activefile.

1 Select View > XRefs from the AutoVue main menu.
The Select the External References to display dialog appearslisting
the external reference files associated with the current active file.
2 Select the checkbox beside the XRefs that you want to display.
Clear the checkbox beside the XRefs that you want to hide.
3 Click OK.
The selected XRefs are displayed.

Displaying Details About Missing XRefs

If afile has missing resources, ared circlewith an“i” & appearsto theleft of

the AutoVue status bar.
1 Click the Resourceicon € on the AutoVue status bar.
The Properties dialog appears.

Note You can aso select File > Properties from the AutoVue main
menu.

2 Clickthe Resource Information tab to display details about missing
resource information required to properly display thisfile.

A green check mark ¥ indicates the resources that AutoVue is able to
access.

Ared & indicates the external reference files or components that are not
accessible.
3 Click OK toclosethe Properties dialog.

Layers

Use this option to configure the current active file's layers to display.
1 Select View > Layers from the AutoVue main menu.
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The Select the layers to display dialog appears listing the layers and
layer visibility for the current active file.

Note You can aso click the Layers button on the AutoVue toolbar.

2 Tosortthelist of layersin the diaog, click Name to sort alphabetically or
numerically, or click Status to sort by visibility.

3 Select the checkbox beside the layers that you want to set visible.
Clear the checkbox beside the layers that you want to hide.

4 Click OK.
The selected layers are displayed.

Blocks

Use this option to select a block to display from the current activefile.

1 Sdect View > Blocks from the AutoVue main menu.
The Select a block to display dialog appears listing the blocks for the
current activefile.

Note You can aso click the Block button B on the AutoVue toolbar.

From the drop-down list, select the block that you want to display.
3 Click OK.
The selected block is displayed.

N

Selecting Views

The Views option allows you to access different named views of afile.

1 Select View > Views from the AutoVue main menu.
The Select a named view dialog appears.

Note You can aso click the View button "B on the AutoVue toolbar.
From the drop-down list, select the view that you want to display.
3 Click OK.

The selected view is displayed.

N

Specifying a View Point
The View Point option allow you to render a drawing from a selected
viewpoint. The default view point is the one used to create the file.

1 Sdect View > View Point from the AutoVue main menu.
The View Point dialog appears.
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2 Enter the X, Y and Z coordinates for the viewpoint with which you want to
render the drawing.

3 Click OK.
The drawing is displayed from the selected viewpoint.

Comparing 2D Files

AutoVue provides the ability to visually compare two files and display color-
coded comparative data. When you compare two files, AutoVue displays three
windows, the first containing the original file, the second containing the file you
compared the original against, and the third containing the comparison results.

Inthe Comparison Result window you can specify whether you want to
display only the additions, deletions or unchanged, or any combination of the
three. To access these options, right-click in any window and select an option
from the pop-up menu.

The comparison results are displayed in different colors to differentiate the

results of the file comparison. The comparison options and corresponding colors
are:

Option Color Description
View Additions Indicates that something has been added.
View Deletions Red Indicates that something has been deleted.
View Unchanged Blue Indicates that there is no change.

1 View the basefilein AutoVue.

2 Select Analysis > Compare from the AutoVue main menu.
The File Open diaog appears.

3 Enter the File Name or click Browse to select the file that you want to
compare with the current activefile.

4 Click OK.
AutoVue displays three windows, the first displaying the original file, the
second displaying the compare file and the third displaying the comparison
results.
Note If you apply achangefrom the View menu, all three windows display
the synchronized change.

5 Toaccessthe Compare options, right-click in any of the windows.
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A pop-up menu appears displaying the Compare options.
Note To maximize any of the windows, double-click the title bar of the
window that you want to maximize. To restore the window, double-click the
title bar.

6 Toexit Compare mode, select File > Exit Compare Mode from the
AutoVue main menu.
The original file appears in the workspace.
Note You can aso exit Compare maode by right-clicking in any of the
windows and selecting Exit Compare Mode from the pop-up menu.

See Also Specifying Scale and Offset for a Compare File

Specifying Scale and Offset for a Compare File

You can scale or translate afile in order to compare files accurately. With the
Scale and Offset option you can modify the coordinates (XOffset and
YOffset) or enter ascaling factor for the second file.

Note XOffset and YOffset arerelative to the base drawing and all options are
displayed at their current values.

1 InCompare mode, select View > Scale and Offset from the AutoVue
Main window.
The Scale and Offset dialog appears.

2 Inthe Scale and Offset dialog, enter the required values for the Scale
Options: XOffset, YOffset and Scale.

3 Click OK.
The scaling/offset modifications are applied to the file in the second
window.

Overlays

When working with 2D files, you can overlay other files over the current active
file. You can also adjust an overlay, move an overlay, and scale an overlay by
defining the X and Y coordinates and the scaling factor.

Adding an Overlay
Note When working with araster file, it should be used as the base file because
raster formats are opague and would hide files underneath them.

1 View thefilethat you want to use as the base file for the overlay.
2 Sdlect Analysis > Overlays > Select from AutoVue main menu.
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The File Open dialog appears.

Enter the File Name or click Browse to select the file you want to overlay.
Click OK.

The base file is displayed with the selected overlay file on top of it.

Note To lay multiple files over one base file, repeat steps 2 to 4 using the
same base file. Overlays are added one at atime.

Modifying an Overlay

1

2
3

Select Analysis > Overlays > Modify from AutoVue main menu.

The Modify Overlay dialog appears.

Select the Overlay that you want to modify.

Click the Action that you want to apply to the overlay.

» Click Move if you want to move the overlay.
Click a point on the base file where you want to set the lower |eft corner
of the overlay. Click another point where you want to set the upper right
corner of the overlay.
Note Asyou select the point to define the position of the upper right
corner, you can resize the destination box.

» Click Scale if you want to resize the overlay.
Enter the XOffset and YOffset coordinates and/or the Scale factor.
Note XOffset and YOffset arerelative to the base drawing and all
options are displayed at their current values.

e Click Warp to adjust the overlay.
Click a point on the overlay and drag the cursor to where you want the
overlay starting point. Click another point and drag the cursor to where
you want the overlay to end.
Note The overlay’s size is scaled to accommodate the origin and
destination points you defined.

Click OK.

The changes are applied to the selected overlay.

Note To modify other overlays, repeat steps 2 to 4.

Removing an Overlay

1

2
3

Select Analysis > Overlays > Modify from AutoVue main menu.
The Modify Overlay dialog appears.

Select the Overlay that you want to remove.

Click Remove.

A confirmation dialog appears.
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4  Click Yes.
The overlay isremoved from the list in the Modify Overlay dialog and
from the display.

Measuring in 2D Vector Files

AutoVue provides the ability to perform measurementsin 2D files. M easurement
options vary between vector and non-vector files. For vector files, AutoVue
providesthe option to “snap” to fixed points on the drawing. For non-vector files,
you can only “free snap”.

You can access the measure options from the Analysis > Measure menu.
These options are;

Name Description
Angle Measure the angle between selected points.
From the toobar, click the button.
Arc Measure an arc entity.
From the toobar, click the button.
Area Measure selected area.
From the toobar, click the button.
Distance Measure the distance between two points.

From the toobar, click the button.

2D Vector Snapping Modes

The Snapping Modes available allow you to click to precise geometrical
points on adrawing. For example, if you select Snap to end-point and you
move the cursor over an end-point of aline, the end-point will be highlighted by
a snap box.
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The Snapping modes alow you to snap to the mid, center and end-points of

an entity:
Button Snap to Description
o\ End-point Geometric snap mode where a snap box appears
when moving the cursor near alinear component’s
end point.
Mid-point Geometric snap mode where a snap box appears
\ when moving the cursor near the halfway point of
alinear component.
Center-point Geometric snap mode where a snap box appears
6 when moving the cursor near the center of an
eliptical component.
% Free snap Allow snapping at any point on the drawing.

Measuring Distance

Use the Distance option to measure the distance between two specific points.

1

N

(€3]

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Distance button on the AutoVue toolbar.
Click the Distance tab.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See 2D Vector Snapping Modes

From the Measured Distance Units drop-down list, select the unit in
which you want to measure the distance.

Note If you want to measure the distance along a path, select Cumulative.
Click a point on the drawing to define the starting point.

Click another point on the drawing to define the end point.

Note If you selected Cumulative, continue clicking points along the path
that you want to measure.

Right-click to complete the measurement.
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The points are joined by aline. The measured distance, Delta-X and Delta-Y
appear in the Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Calibrating Distance

1

5

6

M easure distance between two points or measure cumul ative distance.

See Measuring Distance

Inthe Measurement diaog, click Calibrate.

The Distance Calibration dialog appears displaying the measured
distance.

From the Measured Dist. drop-down list, select the unit to which you want
to calibrate the distance.

Click Calibrate to and enter avalue if you want to calibrate the distance to
avaue.

Click Set Factor and enter avalue if you want to calibrate the distance by a
factor.

Click OK.

The calibration result appears in the Measurement dialog.

Click Close to close the Measurement dialog.

Measuring Area

Use the Area option to measure the area and perimeter of aregion.

1

N

Select Analysis > Measure from the AutoVue main menu.The
Measurement dialog appears.

Note You can aso click the Area button on the AutoVue toolbar.

Click the Area tab.

Select Between Points if you want to measure the area between points on
adrawing. Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping
Modes click All Off.

See 2D Vector Snapping Modes

Select Shape if you want to measure the area of a predefined shape on the
drawing. Snapping Modes are disabled.

From the Measured Area Units drop-down list, select the unit in which
you want to measure the area.
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10
1

12

From the Perimeter Units drop-down list, select the unit in which you
want to measure the perimeter.

To cumulate aNet Area Result of different areas, click Add.

To subtract an areafrom the Net Area Result, click Subtract.

Select Clear to clear the Net Area Result.

If you selected Between Points, click points on the drawing to define the
area.

Each point isjoined by aline. The area and perimeter measurements appear
in the Measurement dialog.

Right-click to complete the measurement.

If you selected Shape, click the edge of the predefined shape.

The shape is highlighted and the area and perimeter measurements appear in
the Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Measuring an Angle

Use the Angle option to measure the angle between points on a drawing.

1

N

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Angle button on the AutoVue toolbar.

Click the Angle tab.

Select From 3 Points if you want to measure the angle between three
points. Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping
Modes click All Off.

See 2D Vector Snapping Modes

Select Between 2 lines if you want to measure the angle between two
lines. Snapping Modes are disabled.

From the Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.

If you selected From 3 Points, click three points on the drawing to define
theangle.

If you selected Between 2 Lines, click two lines on the drawing to define
theangle.

Angle arms appear with an arc connecting them. The angle measurement
appears in the Measurement dialog.
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9

Note Click Reset to take another measurement.
Click Close to close the Measurement dialog.

Measuring an Arc

Use the Arc option to define an arc in the drawing and measure its radius, center
and diameter.

1

N

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Arc button on the AutoVue tool bar.

Click the Arc tab.

Select From 3 Points if you want to measure the arc between three points.
Snapping Modes are enabled.

Click the Snapping Modes that you want to select as the points for the
measurement.

See 2D Vector Snapping Modes

Note To select all Snapping Modes click All On. To clear al
Snapping Modes click All Off.

Select Arc Entity if you want to measure a predefined arc. Snapping
Modes are disabled.

From the Arc Info drop-down list, select the unit in which you want to
measure the distance.

From the Measure Angle Units drop-down list, select the unit in which
you want to measure the angle.

If you selected From 3 Points, click three points on the drawing to define
thearc.

The points are joined by an arc. The measurements for center point
coordinates, radius, diameter, arc length, start and end of angle and sweep
appear in the Measurement dialog.

If you selected Arc Entity, click the edge of the arc that you want to
measure.

The arc is highlighted. The measurements for center point coordinates,
radius, diameter, arc length, start and end of angle and sweep appear in the
Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.
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Calibrating an Arc

1 Measurean arcinthe drawing.
See Measuring an Arc
2 Inthe Measurement dialog, click Calibrate.
The Radius Calibration dialog appears displaying the measured distance.
3 FromtheMeasured Rad. drop-down list, select the unit to which you want
to calibrate.
4 Click Calibrate to and enter avalueif you want to calibrate to avalue.
Click Set Factor and enter avalueif you want to calibrate by afactor.
5 Click OK.
The calibration result appears in the Measurement dialog.
6 Click Close to close the Measurement dialog.
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Working with EDA Files

In addition to all features that are available for generic 2D files, AutoVue
providesintelligent querying for EDA files. You can create/modify layer sets,
you can query entity information, generate BOM, verify EDA designs, cross-
probe and perform intelligent measurements.

Navigation Panel

The Navigation Panel isdisplayed on the left-hand side of the AutoVue
workspace when you view an EDA drawing. The Navigation Panel allowsyou
to navigate through alist of component instances, nets and the associated pins
and net nodes (pins connected to a net) present in the current schematic drawing
or PCB design.

The columns displayed in the Navigation Panel are determined by the profile
of the entity typesin the current schematic drawing or PCB design. Lists can be
sorted in order to group similar component instances.

You can also use the Navigation Panel to select (highlight) a component or
entity; zoom to a component or entity and query entity information.

File Edit Wiew Analysis Collabora

By lHRE &I

AT Components
E |RefDes |Compo... | Locatior

i RS SMORES (13300, ~
IE R4 SMDRES [(750.0).
Ak R3 SMDRES [(1200.0.
R2 SMDRES [(1200.0.
= Rl SMWDRES [(1400.0.
i g ZIF20 (27100,
q UG ZIP20 (25100,
& s ZIP20 (25900,

s SOIC20W|(500.0)..
v SCIC200 |(500.0)..
s SOIC20W|(500.0)..
14 SOIC200 |(500.0)..
U235 SCIC1E  |(850.0).

DR T e T TP AT O b
4 g
Cotmpanent Pins

Mame Met Pin U=ze
U711 ADDROD M ~

Uraz2 ADDRT [N
uri3 ADDRZ N

Cimmetry Systems Corp.



40 AutoVue

Components Tab

The Components tab lists component instances and the associated pins.The top
portion of the panel lists all the instances of the currently displayed page of the
drawing. The lower portion of the panel lists the associated pins for selected
instance(s).

When you select a component, it appears highlighted on the drawing. To select
more than one component, press Shift or Ctrl and then select the desired
components. All the components you selected are highlighted. The associated
pins for the selected component(s) are displayed.

Nets Tab

The Nets tab lists nets and associated net nodes (pins connected to a net). The
top portion of the panel lists al the nets of the currently displayed page of the
drawing. The lower portion of the panel lists the associated net nodes for selected
net(s).

When you select anet, it appears highlighted on the drawing. To select more than
one net, press Shift or Ctrl and then select the desired nets. You can also click
and drag in the Navigation Panel list to select multiple nets. All the nets you
selected are highlighted. The associated net node list(s) for all the nets you
selected are displayed.

Bookmarks Tab

The Bookmarks tab alows you to navigate between PCB and schematic pages
or between the 2D and 3D view of a PCB design.

Customizing the Navigation Panel

In the Navigation Panel, you can sort a column, change column order, or hide
or show acolumn.

1 To sort acolumn, click the column heading.

2 To change the column order or to show or hide a column, right-click a
column heading and select Customize from the pop-up menu.
The Customize Columns dialog appears.
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3 To show or hide a column, select the checkbox beside the column(s) you

want to show.

Clear the checkbox beside the column(s) you want to hide.

Note To show all columns, click Show All. To hide all columns, click
Hide All.

4 To change the column order, select the column you want to move, then click
Move Up to move the column up in thelist or click Move Down to move
the column down in the list.

5 Click OK.

The changes appear in the Navigation Panel.

Selecting Entities

Selecting an entity or entities is often the first step to many of the operations that
you will perform with EDA files. You can select an entity or entitiesin an EDA
file from the Navigation Panel or the workspace. You can also select entities
from the Entity Browser when you search for entities. To specify which types
of entities you can or cannot select, use the Entity Type Filter dialog.

Once you have selected an entity, you can zoom to it in the workspace and
perform other operations with the EDA file.

Selecting Entities from the Navigation
Panel

Click any components, nets, associated pins or net nodes in the Navigation
Panel to select them. To select more than one entity, Shift-click or Ctrl-click.

The selected entity or entities are highlighted in the workspace. If the selected
entity is small, aflash box appearsindicating the location of the highlighted
entity in the workspace.

See Also Zooming to a Selected Entity

Selecting Entities in the Workspace

Click an entity in the workspace to select it. To select more than one entity,
Shift-click or Ctrl-click the entities.

The selected entity or entities appear highlighted in the workspace and in the
Navigation Panel. If the selected entity is small, aflash box appearsindicating
the location of the highlighted entity in the workspace.
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You can also apply selection filters when selecting entities in the workspace. For
more information, see Filtering Entity Types.

Note When you hover the mouse over an entity in the workspace, atooltip with
information about the entity’s attributes appears. The tooltip displays whether or
not you select the entity.

See Also Zooming to a Selected Entity

Selecting Entities from the Entity Browser

1 Perform an attribute-based or entity type-based search using the Entity
Browser.
See Entity Browser

2 Select an entity or entitiesfrom the Entity Types list or the Attributes list
of the Entity Browser diaog.
Note To select more than one entity, press the Shift or Ctrl key while
selecting.
The selected entity or entities appear highlighted in the workspace and in the
Navigation Panel.
Note If the selected entity istoo small, aflash box appearsindicating the
location of the highlighted entity in the workspace.

See Also Zooming to a Selected Entity

Filtering Entity Types

With the Entity Type Filter option, you can display certain entity types while
hiding others, without having to hide an entire layer. For example, you might
want to turn off all entities and display only the component instances.

You can aso limit the types of entities you can select in the workspace.

1 Select View > Entity Type Filter from the AutoVue menu.
The Entity Type Filter dialog appears.

Note You can aso click the Entity Type Filter button m on the AutoVue
toolbar.

2 Under the Visibility column, select the checkbox beside the entity typesyou
want to display in the workspace.
Clear the checkbox to hide the entity types.

3 Under the Selection column, select the checkbox beside the entity types
that you want to be able to select in the workspace.
Clear the checkbox beside the entity types that you do not want to select.
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Note To select all entity types, select the checkbox in the column header.
Clear the checkbox to deselect all entity types.

Click Apply to apply the changes.

Close OK to close the Entity Type Filter dialog.

Only the selected entities types remain displayed in the workspace.

When you click in the workspace, only the entities types checked in the
Entity Type Filter dialog will be highlighted.

Zooming to a Selected Entity

1

2

In the workspace or Navigation Panel select the entity, then right-click
and select Zoom selected.

In the Entity Browser dialog, select the entity from the Entity Types list
or the Attributes list, then right-click and select Zoom selected.
AutoVue zooms to the selected entity in the workspace.

Entity Properties

The Entity Properties dialog displays detailed information about any selected
entity in the current schematic drawing or PCB design. To open the Entity
Properties diaog, you can double-click an entity in the workspace, or right-
click an entity intheworkspace, Navigation Panel or Entity Browser dialog,
then select Entity Properties from the menu.

Entity Properties... ﬂ
> | Expand |
—Aszociations:—————— [~ Entity Info:
B F_S? < Component Instance » ;I
- Component Instance
i RefDes = C4
= Component Mame = SMOCAP

n Location = [1870.000000, 3615.000000, 0.000000)
-4 Rotation = 90.000000

L 42 Board Side = Bottom

Placement Status = Placed

Component Clazs = DISCRETE

Package Symbol = SMDCAP

Device Type = CAP-0MUF

PART_MUMBER = 21505-267-01

VaLUE = 01UF
K| _>l_I
ok | Help

Cimmetry Systems Corp.



44 AutoVue

On the left side of the Entity Properties dialog, atree control displaysall the
entities associated with the entity you selected. The entity you selected is the root
of thetree, and all the associated entities (grouped by their type) are shown asits
children.

The attributes of the entity display to the right of the tree, under Entity Info. In
the tree, select any associated entity to display its attributes under Entity Info.

You can also view entity attributes in the workspace. When you hover the mouse
over an entity in the workspace, atooltip with commonly used entity information
appears. You can turn these tooltips off or on from the Configuration dialog.
See Configuring AutoVue for more information.

Viewing the Properties of an Entity

The Entity Properties dialog displays detailed information about any selected
entity in the current schematic drawing or PCB design.

1 Select the entity in the workspace or from the Navigation Panel or Entity
Browser.

2 Right-click and select Entity Properties from the pop-up menu.
The Entity Properties dialog appears displaying the selected entity and its
associated entities under Associations, and its attributes under Entity
Information.
Note You can aso double-click the entity in the workspace for which you
want to view its entity information.

3 Select any associated entity in the tree to display its attributes under Entity
Information.

4 Toview all associated entities for any given entity in the tree, select the
entity and click Expand.
Note To view the entity properties for the previous entity, click the back

[ < | arrow. To return to the entity properties displayed before you clicked

the back arrow, click the forward = - | arrow.

5 Click OK to close the Entity Properties dialog.

Showing Net Connectivity

1 FromtheNavigation Panel, right-click an entity such asapin, viaor trace
for which you want to display the net connectivity and select Show Net
Connectivity from the pop-up menu.
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Note Show Net Connectivity isdisabled when more than one entity is
selected.

The graphical entities belonging to the connected nets are highlighted.

Displaying the Entity Properties of a Net

Itispossible to view properties of anet via Entity Properties.
Note Entity Properties isdisabled when more than one net entity is selected.

1

2

Select an entity such asapin, viaor trace from the workspace.

The corresponding net is highlighted in the workspace.

Right-click the net and select Entity Properties from the pop-up menu.
The Entity Properties dialog appears displaying the properties of the
selected net.

Click OK to closethe Entity Properties dialog.

Note You can aso select anet from the Navigation Panel, right-click
and select Entity Properties.

Showing Net Instances

In AutoVue, you can display the instances of anet in a multi-page file.

1

From the Navigation Panel, click the Nets tab and select the net you want
to view.

The net is highlighted in the Navigation Panel and in the workspace.
Select View > Go To Net Instances from the AutoVue main menu or
right-click the highlighted net from the Navigation Panel or workspace
and select Go To Net Instances.

AutoVue highlights the instance(s) of the selected net.

Cimmetry Systems Corp.



46 AutoVue

If the selected net appears on multiple pages the Go to Net Instances
dialog appears.

Go to Net Instances... g]

Fleaze select a page:

33
44

Cancel |

3 Select the page on which you want to view the net instance, then click OK.
The selected page is displayed and the instance of the selected net is high-
lighted.

Note [f there are no instances for the selected net the option is disabled.

Design Hierarchy Navigation

AutoVue supports navigation through the hierarchical structure of a schematic
drawing. A hierarchical block in a schematic isa symbol that refersto achild
schematic. With the Descend Hierarchy option, you can navigate to a child
schematic. With the Ascend Hierarchy option, you can navigate from the
child schematic to the parent page.

Navigating using Descend Hierarchy

1 Onthe parent page, select any hierarchical block in the workspace, then
right-click and select Descend Hierarchy from the pop-up menu.
AutoVue opens the page with the selected child schematic.

Note You can aso select the hierarchical block in the Navigation Panel
or in the Entity Browser dialog, then right-click and select Descend
Hierarchy.

Navigating using Ascend Hierarchy

1 Onthe child page of your schematic’'s design hierarchy, right click an entity
in the workspace and select Ascend Hierarchy from the pop-up menu.
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AutoVue returns to the parent page.
If you select an entity that has multiple parents, the Ascend Hierarchy
dialog appears displaying the parent pages.

Ascend Hierarchy g]

Pleaze zelect a page:

15: Channel CD Data Flow
17: Channel A8 Data Flow
18: Channel EF D ata Flow
20: Channel GH Data Flow

Cahicel

Select the Parent page you want to go to, then click OK.

AutoVue returns to the selected parent page.

Note You can aso select the entity in the Navigation Panel or in the
Entity Browser dialog, then right-click and select Ascend Hierarchy.

Layers

When working with EDA files, AutoVue letsyou view all the physical layersand
associated logical layers of the EDA drawing. You can view all layer sets for that
file, or create your own. You can manipulate certain layer attributes, such as
visihility, color, ordering.

You can access the layer settings using the Layers dialog. To open the Layers
dialog, select View > Layers from the AutoVue main menu. You can aso click

the Layers button in the toolbar.

Note: For drawings which do not contain layers, the Layers menu option and
button are disabled.

The Layers dialog has aPhysical Layers pane and aLogical Layers pane. You

can display and hide these panes using the Expand @& and Collapse &
buttons. The Logical Layers pane displays the layersin the order they display in
the workspace, whereas the Physical Layers pane displays the layersin the order
they appear in the layer stackup when manufactured.

The Physical Layers pane displays a matrix with amapping of physical layer
names to entity types. Each row in the matrix corresponds to a physical layer in
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the board. Each column in the matrix lets you control the visibility of an entity
type, such as pin, via, trace, and so on. The entity types that display depend on
the entities available in the open file. Select a physical layer to change its
visibility, printability, layer order, and color. Select or clear aphysical layer’s
entity type to affect its visibility separately from the layer’s other entities.
When you select a physical layer from the Physical Layers pane, associated
logical layers are also selected in the Logical Layers pane. You can also select
individual logical layers from the Logical Layers pane, or Shift-click or Ctrl-
click to select multiple logical layers.
The Logical Layers pane displays alist of logical layers and the layer attribute
options you can modify: visibility, printability, order, and color.
To modify these attributes for both physical and logical layers, first select the
layers you want to modify, then use the settings to make the changes you want.
When you select physical or logical layers and modify settings from the Layers
dialog, a message displays at the bottom of the Layersdialog to indicate your last
action.
When you are satisfied with the changes, click Apply to make the changesin the
workspace. You can aso create layer sets to save your modified layer settingsto
reuse them later.
When you open afilein AutoVue, it displays all layer setsfor that file. You can
choose the layer set you need, or create your own.
See Changing the Order of Layers

Modifying Layer Visibility

Setting Printability for Layers

Changing Layer Color

Sorting Logical Layers

Creating User-Defined Layer Sets

Changing the Order of Layers

You can change the order in which layers display in the workspace. That is, you
can change the z-order of layers.

1 OpenthelLayers diaog by taking one of the following steps:

» Click theLayers button in the AutoVue toolbar.
» Select View > Layers from the AutoVue main menu.

Cimmetry Systems Corp.



AutoVue 49

If necessary, click the Expand button & to open the Logical Layers

pane.

Select the layer or layersthat you want to move. You can:

» Select aphysica layer from the Physical Layers pane. Logical layers
associated with the selected physical layer are selected. When you make
changes to a selected physical layer, logical layers associated with it are
also affected.

» Select one or multiple logical layers from the Logical Layers pane. Shift-
click or Ctrl-click to select multiple logical layers.

Click one of the following buttons:

e Click theBring to Front button {F to move al selected layersto the
front in the workspace. In the Logical Layers pane, these layers move to
thetop of thelist.

« Click theUp button 4 | to move selected layers up one layer.

* Click the Down button ﬂ to move selected layers down one layer.
Note You can aso drag and drop selected logical layersin the Logical
Layer pane.

Click Apply to see the changes in the workspace.

The file now displays according to the layer scheme you arranged. Also,
logical layers are renumbered in the Logical Layers pane's Order column.
To save your changes as a user-defined layer set, see Creating User-
Defined Layer Sets.

Click Close to closethe Layers dialog.

Modifying Layer Visibility

Usethe Layersdialog to hide or display specific physical and logical layersinthe
workspace.

1

Open the Layers dialog by taking one of the following steps:

» Click theLayers button in the AutoVue toolbar.

» Select View > Layers from the AutoVue main menu.

Modify the visibility of physical layers and their entities from the Physical
Layers pane.

Modify the visibility of individual logical layersfrom the Logical Layers
pane.

See Modifying Visibility for Physical Layers
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Modifying Visibility for Logical Layers

Modifying Visibility for Physical Layers

In the Physical Layers pane, you can show or hide the following:

» All physical layers: Click the All column header.

* One physical layer: Click the checkbox to the left of the layer name.
You can also select alayer and click the Visibility button =3 |.

* One entity type for all physical layers: Click the column header.
For example, click the Trace column header to show or hide all trace
entities of all physical layers.

* One entity type for one physical layer: Click a specific checkbox.

Click Apply to view the changes in the workspace. To save your changes as a

user-defined layer set, see Creating User-Defined Layer Sets.

Note: Checkboxesfor physical layers can have four states: Checked,
unchecked, gray checked, and gray unchecked. Checkboxesthat are checked and
gray indicate that the entities of a physical layer are neither al visible nor all
hidden. Gray checkboxes that you cannot select indicate that thereis no entity of
that type for that layer.

Modifying Visibility for Logical Layers

If the Logical Layers paneis not open, click the Expand button &) . The
Logica Layers pane lets you show or hide the following:

* One logical layer: Click the layer’s checkbox in the Visibility column
=]

» Multiple logical layers: To select more than one layer, Shift-click or
Ctrl-click, then click the Visibility button k= .

Click Apply to view the changes in the workspace.
To save your changes as a user-defined layer set, see Creating User-
Defined Layer Sets.

(62N

Setting Printability for Layers

You can select which physical or logical layersto print using the Layers dialog.

Note You can only print layersthat are visible in the workspace. See
Modifying Layer Visibility.
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Open the Layers dialog by taking one of the following steps:

» Click theLayers button in the AutoVue toolbar.
» Select View > Layers from the AutoVue main menu.

If necessary, click the Expand button @& to openthe Logical Layers

pane. In the Logical Layers pane, thereisa Printability column that lets

you see which layers are set to print.

Select the layer or layers that you want to be able to print. You can:

» Select aphysical layer from the Physical Layers pane. Logical layers
associated with the selected physical layer are also selected.

» Select one or multiple logical layers from the Logical Layers pane. Shift-
click or Ctrl-click to select multiple logical layers.

You can only print layers that are visible, so make sure the layers and

entities you want print are visible in the workspace. See Modifying Layer

Visibility.

Click the Printability button .

Note IntheLogical Layers pane, you can also click the checkboxesin the

Printability column E for each logical layer you want to be able to print.
Click Apply.

Only the layers selected in the Printability column can be printed.

To save your changes as a user-defined layer set, see Creating User-
Defined Layer Sets.

Click Close to closethe Layers dialog.

Changing Layer Color

You can modify the color of any physical or logical layer from the Layers
diaog.

1

Open the Layers dialog by taking one of the following steps:

» Click the Layers button in the AutoVue toolbar.
e Select View > Layers from the AutoVue main menu.

If necessary, click the Expand button & to open the Logical Layers

pane.

Select the layer or layers for which you want to change the color. You can:

» Select aphysical layer from the Physical Layers pane. Logical layers
associated with the selected physical layer are also selected.
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o]

9

10

» Select one or multiple logical layers from the Logical Layers pane. Shift-
click or Ctrl-click to select multiple logical layers.

Once you have selected alayer, you can modify its attributes.

Take one of the following steps:

+ Click theColor button ¥} |. Use thisbutton if you want to change the

color of all logical layers associated with a selected physical layer, or to
change the color of many selected logical layers at the same time.

» Double-click acolored square inthe Color column m of the Logical
Layers pane. Use the colored square to change the color of individual
logical layers.

Note Do not click the Color column heading unless you want to sort the

layersin the Logical Layers pane according to color.

In the menu that appears, select the color that you want.

Click OK.

The color of al selected layers changesin the Color column.

Click Apply to save the changes.

The display updates in the workspace based on the changes you made to the

layer color.

To save your changes as a user-defined layer set, see Creating User-

Defined Layer Sets.

Click Close to closethe Layers dialog.

Sorting Logical Layers

You can sort thelist of logical layersin the Logical Layers pane by name,
visihility, printability, color, or physical layer.

1

Open the Layers dialog by taking one of the following steps:

e Click the Layers button in the AutoVue toolbar.
e Select View > Layers from the AutoVue main menu.

If the Logical Layers paneis closed, click the Expand button & to
open it.

Click the column header of an attribute. Layers are sorted according to the
attribute header you click.

For example, clicking the Color column header m sortsall logical layers
in the pane according to their color.

Note: To restore the original sort order, click the Order column header.
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Layer Sets

A layer set is comprised of all the physical and logical layersin the drawing.
Layer sets differ in the attributes of the different layer(s): z-order, visibility,
printability, color, and so on. Define your own layer setsto control which layers
you can view and print.

Viewing Layer Sets

AutoVue lists top, bottom, and default layer sets, aswell as any layer set that is
stored in thefile. You can choose to display any layer set you need. You can also
create user-defined layer sets and display them later. To view alayer set, take the
following steps:

1 Takeone of the following steps:

» Click the Layers button in the AutoVue toolbar. In the Layers
dialog that appears, select alayer set from the Layer Set drop-down list,
then click Apply.

* Inthe AutoVue main menu, select View > Layer Sets > x, wherex is
the layer set you want to see.

* Inthe AutoVuetoolbar, select alayer set from the drop-down list beside

the Layers button .

The selected layer set displays in the workspace.
2 Torestore the default layer set, select View > Layer Sets > (Default) or
(Default) from the toolbar or inthe Layers dialog.
See Creating User-Defined Layer Sets
Deleting User-Defined Layer Sets
Saving User-Defined Layer Sets with Markups

Creating User-Defined Layer Sets

You can define alayer set and saveit for the duration of the session. The layer set
you defined is added to the Layer Set listin the Layers dialog and to the
Layers drop-down list on the AutoVue toolbar.

By default the Top, Bottom and Default layer sets and any other layer sets
belonging to the file are listed in the Layer Set drop-down list.

1 OpenthelLayers diaog by taking one of the following steps:
» Click theLayers button in the AutoVue toolbar.
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e Select View > Layers from the AutoVue main menu.
Click Add.
The Add Layer Set dialog appears.
Enter the Layer Set Name.
Click OK.
The new layer set appearsin the Layer Set drop-down list.
To modify the attributes of the new layer set, select one or more layers and
change the Visibility, Printability, Order or Color.
See Changing the Order of Layers
Modifying Layer Visibility
Setting Printability for Layers
Changing Layer Color
Click Apply to save the changes and to display the new layer set in the
workspace.
To define more layer sets, repeat steps 2 to 6.
Click Close to closethe Layers dialog.
The new layer set appears in the drop-down list beside the Layers button

on the AutoVue toolbar and is also displayed in the workspace.

See Viewing Layer Sets
Deleting User-Defined Layer Sets
Saving User-Defined Layer Sets with Markups

Deleting User-Defined Layer Sets

1

(G2 3

Open the Layers dialog by taking one of the following steps:

e Click the Layers button in the AutoVue toolbar.

e Select View > Layers from the AutoVue main menu.
From the Layer Set drop-down list, select the user-defined layer set you
want to delete.
Note: You can only delete user-defined layer sets.
Click Delete.
Note: Thelayer settings of the deleted layer set remain displayed on the
screen until you select another layer set.
Click Apply to save the changes.
Click Close to closethe Layers dialog.
See Creating User-Defined Layer Sets
Viewing Layer Sets
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Saving User-Defined Layer Sets with Markups

Saving User-Defined Layer Sets with
Markups

In AutoVue, you can save custom layer sets using markup files.

1

Create custom layer sets.
See Creating User-Defined Layer Sets
Enter Markup mode by taking one of the following steps:

» Click the Markup button in the toolbar.
» Select File > Markup from the AutoVue main menu.
Create any markup entities that you need.
Select File > Save As from the AutoVue main menu and use the dialog
that appears to save the markup file.
The Layer setsyou created are saved with the Markup file. When you reopen
the file during a different session, you can view the Layer sets when you
open the Markup file.
See Creating User-Defined Layer Sets

Viewing Layer Sets

Deleting User-Defined Layer Sets

Saving User-Defined Layer Sets with Markups

Markups

3D View

For some ECAD formats, AutoVue supports 3D views of PCB boards.

1
2

Inthe Navigation Panel, click the Bookmarks tab.

Select 3D View from the Bookmark Tree.

The 3D view of the PCB board is displayed in the workspace.

Note You can aso display a3D view by selecting View > Page > Next

Page or by clicking the Next Page button 1}$ on the toolbar.
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Cross Probing

Cross probing is the ability to select elements in the schematic and have them
mapped to the corresponding components in the layout drawings and vice versa.
You can also cross probe between the 2D and 3D view of the samefile.

See Cross Probing Between Two or More EDA Files
Showing the Net Connectivity when Cross Probing
Cross Probing Between 2D and 3D Views of the Same File
Zooming when Cross Probing

Cross Probing Between Two or More EDA
Files

The Cross Probe option letsyou select entities in the schematic drawing or the
PCB and AutoVue highlights what you selected in al the open files.

1 Openafileyouwant to cross probe.
2 Select Analysis > Cross Probe from the main menu.
The Cross Probe dialog appears.

Note: You can aso click the Cross Probe button @ in the toolbar.

3 Click Add File.

4 Inthe Open dialog that appears, enter the File name or browse to locate
the file you want to cross probe, then click Open.

5 Repeat steps 3 and 4 for each additional file that you want to open.

6 IntheCross Probe diaog, click OK.

Each file you selected appears in anew window. A dialog appears for each

new window which lets you change the view or page for each file.

Each dialog is set to Automatic by default. When the Automatic optionis

selected for each dialog, you see different behavior depending on the files

you cross probe, asfollows:

« If you cross probe a schematic and PCB, one window automatically
displays a2D PCB and the other window displays a schematic. The same
istrueif either file contains a PCB and a schematic. For example, if files
A and B contain both a schematic and a PCB and they are cross probed,
one of the files displays the schematic page and the other displays the 2D
PCB.

« If you cross probe two PCBs, one window automatically displays a2D
PCB and the other window displays a 3D PCB.

« If you cross probe two schematics, both are set to schematic.
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7 Tochangethe view of afilein awindow, take the following steps:

a. Clear the Automatic option in the dialog for the window you want to
change.

b. Select Schematic, PCB, or PCB 3D View from the Type menu.
These options are available in the Type menu only when the views are
present in thefile.

The view of the file changes in the window.

8 To switch between multiple occurrences of a selected component, take the
following steps:

a. From the Navigation panel, select acomponent in one file that has
multiple component occurrences in the other file.

b. From the dialog of the file with multiple component occurrences, select
one of the components from the Occurrence menu or click the Next
button or Previous buttons to switch between component
OCCUrrences.

x|
Scope
¥ Automatic  Type: ISchematic 'l
QCcurrences
|SCHEMATIC1PAGEL: C4 =l
<]
9 Select any entity in the schematic drawing.

The same entity is highlighted in the PCB design(s).

Cross Probing Between 2D and 3D Views
of the Same File

1

N

Select Analysis > Cross Probe from the AutoVue main menu.
The Cross Probe dialog appears.

Note: You can aso click the Cross Probe button @ in the tool bar.

Click Add File.

In the Open dialog that appears, select the samefile, then click Open.
Inthe Cross Probe dialog, click OK.

Thefile appearsin a new AutoVue window. The views that display in each
window depend on the contents of file you are cross probing.
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If the file does not contain a schematic, one window shows the 2-

dimensiona view of the PCB and the other shows the 3-dimensional view of

the PCB.

If thefile contains a schematic as well asa PCB, the schematic view displays

in one window and the 2D PCB view displaysin the other window. In this

case, take the following steps to see the 2D and 3D views of the PCB:

a. Inthewindow’sdialog, clear the Automatic option.

b. Select adifferent view from the Type menu. For example, you can
switch between Schematic and PCB 3D View.

Select an entity in the 3D view.

The same entity is highlighted in the 2D view of thisfile.

Note: You can select entitiesin the 2D view or 3D view of thefile. The

selected entities are highlighted in both open views of thisfile.

Showing the Net Connectivity when Cross
Probing

1
2

Select an entity or entitiesin any openfile.

Right-click and select Show Net Connectivity from the pop-up menu.
The net connectivity for the entity or entities that you selected are
highlighted in all the files.

Zooming when Cross Probing

When you are cross probing files, you can zoom in on the entities you select.
Zoom in on a selected entity or entities:

when cross probing between a schematic drawing and a PCB design.
when cross probing between the 2D and 3D views of the samefile.

To zoom in on a selected entity:

1

Select an entity or entitiesin either one of the open files or views.

Note If you are cross probing between a schematic drawing or a PCB
design, you can select entitiesin either file. You can also select entitiesin
any open file when cross probing the 2D view and 3D view of the samefile.
Right-click and select Zoom Selected from the pop-up menu.

AutoVue zooms to the same entitiesin all the open files.

See Configuring Zoom Behavior when Cross Probing
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Comparing a PCB with Artwork

In AutoVue, you can visually compare PCB designs or schematic drawings. In
Compare mode for EDA files, EDA options such as Select Entity, Entity
Browser and Entity Type Filter are available.

For more information on how to compare files, see Comparing 2D Files.
To compare a PCB with artwork:

1 Openthe PCB file that you want to compare with the artwork.

2 Seect Analysis > Compare from the AutoVue main menu.
The Open dialog appears.

3 Enter the File name or browse to locate the artwork file you want to
compare with the PCB file.

4  Click Open.
The PCB-Artwork Comparison dialog is displayed.

5 From the drop-down list, select the PCB physical layer that represents the
artwork. For example: TOP, BOTTOM or POWER.

6 Click OK.
AutoVue displays three windows, the first displaying the original PCB
drawing, the second displaying the Artwork drawing and the third the
Comparison Result window.

7 Toexit Compare mode, select File > Exit Compare Mode from the
AutoVue main menu.
The original file appears in the AutoVue workspace.
Note You can right-click in any window and select Exit Compare Mode.

See Also Specifying Scale and Offset for a Compare File

Generating a Bill of Material

For EDA files, you can obtain alist of the components and parts required for
manufacturing the item featured in the schematic drawing or PCB design.

The Bill of Material (BOM) report produces a count of the unique components
or parts needed for manufacturing. It lists the quantity required, component
name, reference designators, value (for resistors and capacitors), size and
descriptions. When determining a component’s uniqueness, the count considers
only the attributes chosen for inclusion in the report output. It includes only those
attributes that provide the most accurate, unique component quantities.

To generate aBill of Material:
1 Select Analysis > BOM from the AutoVue main menu.
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Note You can aso click the BOM button in the toolbar.
If you are generating a BOM for a schematic with multiple pages, adialog
appears.

Generate BOM. .. EI

BOM Scope

(:} Entire design

l (9] ] l Cancel ]

Select if you want to generate a BOM for the Current page or the Entire
design, then click OK.
A dialog appears listing the attributes of thefile.

2 Select the attributes that you want to appear in the report, then click
Generate.

The Bill of Material dialog appears listing the Count for each component
or part possessing the attributes you selected. There are also columns
displaying the values of the attributes you selected.

Note To sort acolumn by alphanumerical or aphabetical order, click on
the column heading.

3 TosavetheBill of Materia, click Export. The Save As dialog appears.
Specify the directory where you want to store thefile, the file name and
extension, then click Save.

Note You can specify either xml (Product Data Exchange) or csv
(Common Separated Values) for the extension.

AutoVue automatically savesthe resultsin afile with the format you
specified.

4 Click Close to closethe Bill of Material dialog.

Design Verification

Design verifications are operations that check the electrical design of a PCB
against a set of rules defining physical and electrical design limitations.
Performing these checks will prevent short circuits and process errors. The types
of designrules are;
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e Clearances - the minimum spacing (air gaps) allowed between two sets of
entitiesin the design. These sets can belong to the same type of entity or to

different types.

e Electrical - targets certain properties of the nets
* Manufacturing - targets the physical properties of aparticular entity.

Design Rule Checks

For design rule checks that have values, you can change the unit of measure and
change the value of each check. The available design rule checks are:

Design Rule

Type # Check

Description

Min.Clearance
(Pad > Pad)

Clearance 1

2 Min.Clearance
(Pad > Trace)

3 Min.Clearance
(Trace > Trace)

4 Min. Clearance
(Comp > Comp)

Specify the minimum pad to pad clearance
on the same physical layer.
Note Only the pad outlineis considered.

Specify the minimum pad to trace
clearance and pads on the same physical
layer.

Note Only the pad outlineis considered.
Does not take into account traces
connected to a pin (pad) on the same net.

Specify the minimum trace to trace
clearance on the same physical layer.
Note Doesnot takeinto account directly
connected traces.

Specify the minimum component to
component clearance on the same physical
layer (component top side or component
bottom side).

Note Only thelogical layer that defines
the actual outline of the component is
considered.

Note A component entity is usually
made up of geometrics on different logical
layers (silkscreen, keepout, etc.), but only
the logical layer that defines the actual
outline of the component is considered.
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Design Rule .
Type # Check Description
Manufacturing 5 Min. Annular Specify the distance between the pad out-
Ring line and the outline of its drill hole on all
physical layers.
Note Thetwo outlines (geometries) are
part of the pin (pad) entity but on different
logical layers.
6 Min. Pad Specify the minimum diameter of a pad.
Diameter Note Only applicable to rounded pads.
8 AcuteAngle Specify the minimum acute angle between
(indeg.) connected traces on the same physical
layer.
Note Only two traces belonging to the
same net should be considered.
9 Min. Drill Hole  Specify the minimum diameter of the drill
Size hole size allowed.
Note Only applicable to rounded pads.
10 Max. Drill Hole  Specify the maximum diameter of the drill
Size hole size allowed.
Note Only applicable to rounded pads.
Electrical 7 Max. ViaCount  Specify the maximum via count allowed
for anet.
11  Min. Route Specify the minimum route (trace) width
Width alowed in the design.
12 Max. Route Specify the maximum route (trace) width
Width alowed in the design.
13  Min. Route Specify the minimum route (trace) length
Length alowed in the design.
14 Max. Route Specify the maximum route (trace) length
Length alowed in the design.
15 Empty Nets Select this checkbox if you want to check

for any netsthat are not connected to any
pin, via, trace and power/ground plane.
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Design Rule .
Type # Check Description
16 Un-routed Select this checkbox if you want to check
Traces for any trace segment that is not connected
to another trace segment, pin, viaon either
end.

17 Single Select this checkbox if you want to check

Connection for anet connected to only one pin.
Exception: power and ground nets.

18  Short Circuit Select this checkbox if you want to check
for intersections (on the same layer) of
traces that belong to different nets.

Note Trace entitieswill be divided into
n sets where n is the number of netsin the
design.

19  Unconnected Select this checkbox if you want to check

Pin for any pin (pad) that is not graphically

intersected with any traces on the same
physical layer.

Verifying a Design

1

Select Analysis > Verify Design from the AutoVue main menu.
A design dialog appears.

Note You can also click the Verify Design button ** on the AutoVue

toolbar

To enable aDesign Rule, select the checkbox beside the Design Rule.
To disableaDesign Rule, clear the checkmark.

Note You can sort the Design Rules by Enabled, Description or
Value by clicking the column heading.

To add avalue to the selected Design Rules, double-click in the value box

and enter avaue.

Note The Desigh Rule must be enabled to be able to add a value.

Inthe Maximum Violation text box, enter the maximum number of results
you want to display in the Results text box.

From the Distance Units drop down list, select the unit you want to use as
the unit of measure.

Cimmetry Systems Corp.



64

AutoVue

Click Verify.

Verify button changesto Stop.

Note To stop the Design Verification process at any point, click Stop.
When the process is complete, the total number of errors found during the
Design Verification process, up to the maximum number specified in the
Maximum Violation text box, appear in the Results list.

To view the description of a violation result, select the violation from the
Results list.

The description appearsin the Description text box. The description
includes information such as the type of violation, the location where it
occurs (x- and y-coordinates), the component or entity it affects and the
actual value measured.

Note When you select aviolation result, AutoVue zoomsto the entity or set
of entities that were affected and highlights them on the drawing.
Continue to select violation Results to view its description.

Note Click Reset to restart anew check.

Click Close to close the dialog.

Exporting the Design Verification Results
You can export the Design Verification results into atext file.

1

2
3

Click Export in the design dialog.

An export dialog appears.

Navigate and select the directory that you want to export the results to.
Enter aFile name.

Click Save.

AutoVue saves the Design Verification resultsin atxt (text) or csv
(Common Separated Values) file listing each violation result and its
description.

Click Close to close the design dialog.

Searching Using Entity Browser

You can search for an entity in a schematic drawing or a PCB design using the
Entity Browser. To filter entities, apply attribute or entity type filters as search
criteria. You can select entities from the resultslist to highlight them in the
workspace and the Navigation Panel. You can also export the search resultsto
a.txtfile.
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Note [f the selected entity issmall, aflash box appears indicating the location of
the highlighted entity in the workspace.

To open the Entity Browser, select Analysis > Entity Browser from the
AutoVue main menul.

If your schematic has multiple pages, aDefining Scope dialog appears.

Defining Scope le

Scope

+ Current Schematic Page

" Entire Schematic Design

Cancel |

Select Current Schematic Page to browse through only one page. Select
Entire Schematic Design to browse through all schematic pages.

Entity Browser [‘S_<|
Aftributes
Ertity Types  |Met W || Attribute |BUS_NAME B | [ Acled Fiter ]
Walue |@PROJECT1_LIBESD.. ¥
MNarme Pir List Partially ... | Uzer Sc...
wy_R L3511 [ o] A Aftribute | Walueg |
WWEL LG5 L7 8. N o]
UMMAKE... [R1A 1.8 NG s}
ROMOEL  (LME.25 L. MO [N
RESETL LM0.5 195 | o]
RESET L33 U [N s}
REF LH0.7 UL [ [N
ROYL LT UL [ o]
RASL U39 L7.9. NG e
R&5 L4 6 L20... MO [N w Export Resuft ] [ Apply Fitter(=)
< >

Performing an Entity Type-based Search

1 Select Analysis > Entity Browser from the AutoVue menu.
The Entity Browser dialog appears.

Note You can aso click the Entity Browser button E on the AutoVue
toolbar.
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Click the Entity Types tab.

From the Entity Types drop-down list, select an entity type.
A list of attributes for the selected entity type appear.

Note To sort thelist by attribute, click the attribute column heading that
you want to sort by.

If you want to search by attribute, select an attribute from the Attribute
drop-down list.

If you want to search by value, select avalue from the Value drop-down
list.

Click Add Filter.

The Attribute and its Value appear in thelist.

Repeat steps 4 and 5 until you have all the filters you want.

Click Apply Filter(s).
A list of entities matching the search criteria appear showing the column
headers for the entity’s available attributes.

Note To remove afilter, select thelinein thelist containing the Attribute
and Value you do not want to use as afilter, then click Remove Filter.
To save the results, click Export Result.

The Save As dialog appears.

Browse to locate the directory where you want to store the file and enter a
File name.

Click Save.
AutoVue saves theresultsin acsv (Comma Separated Values) file.

To view the properties of an entity, select the entity from theTypes list or
the Attributes list, then right-click and select Entity Properties.

The Entities Properties dialog appears displaying the properties for the
selected entity.

To show the net connectivity, click the Attributes tab, select the entity
from the list, then right-click and select Show Net Connectivity.

The net connectivity for the selected entity is highlighted.

Click Close to close the Entity Browser dialog.

Performing an Attribute-based Search

1

Select Analysis > Entity Browser from the AutoVue menu.
The Entity Browser dialog appears.

Note You can aso click the Entity Browser button E on the AutoVue
toolbar.
Click the Attributes tab.
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3 Fromthe Attributes drop-down list, select an attribute.
The Owner, Type and Value of the selected attribute appear in the list.
Note To sort thelist by Owner, Type or Value, click the column heading
that you want to sort by.

4  If you want to search by owner, select an owner from the Owner filter
drop-down list.
If you want to search by value, select avalue from the Value Filter drop-
down list.
Note You can aso enter an Owner filter or Value Filter in the text box.

5 Click Apply Filter(s).
A list of entities matching the search criteria appear displaying the Owner,
Type and Value columns.
Note Select anitemintheresult list and right-click to access options like
Zoom Selected and Entity Properties.

6 Tosavetheresults, click Export Result.
The Save As dialog appears.

7 Specify the file name and the directory where you want to store the file, then
click Save.
AutoVue savestheresultsin acsv (Comma Separated Values) file.

8 Click Close to close the Entity Browser dialog.

Measuring in EDA Files

In EDA files, you can take measurements of distances, areas, arcs, and so on.
When measuring, you have the option to “snap” to geometrical or electrical
points on the drawing.

Click Analysis > Measure to access the Measurment options. You can also
click the measurement buttons in the toolbar, as shown in the following table:

Button Name Description

Angle Measure the angle between selected points.
[LLLLL ]

Arc Measure an arc entity.
Area Measure a selected area.
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Button Name Description
Distance Measure the distance between two points.
Lilui]
Minimum Distance Measure the minimum distance between
= entities.

EDA Snapping Modes

The Snapping Modes allow you to click to precise geometrical or electrical
points. For example, when you select Snap to pin, movethe cursor over the pin
you want to select until the pin is highlighted, then click. Highlight and click a
second pin to measure the distance between them.

The Snapping Modes allow you to snap to the mid, center and end-points of an
entity, aswell asapin, via, and symbol:

Button  Snap to Description
o\ End-point Geometric snap mode where a snap box appears
when moving the cursor near the component’s end
point.

Mid-point Geometric snap mode where a snap box appears
when moving the cursor near the halfway point of a
linear component.

|#

Center-point Geometric snap mode where a snap box appears
when moving the cursor near the center of an ellipti-
cal component.

I=]

Pin Electrical snap mode where a snap box appears
when the cursor touches apin.

Viaorigin Electrical snap mode where a snap box appears
when the cursor touches avia.

Symboal origin Electrical snap mode where a snap box appears
when the cursor touches the entire component.

Free snap Allows snapping at any point on the drawing.

X & e |¥
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Measuring Distance

Use the Distance option to measure the distance between two specific points.

1

N

(6]

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can dso click the Distance button on the AutoVue tool bar.
Click the Distance tab.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See EDA Snapping Modes

From the Measured Distance Units drop-down list, select the unit in
which you want to measure the distance.

Note If you want to measure the distance along a path, select Cumulative.
Click a paint on the drawing to define the starting point.

Click another point on the drawing to define the end point.

Note If you selected Cumulative, continue clicking points along the path
that you want to measure.

Right-click to complete the measurement.

The points are joined by aline. The measured distance, Delta-X, Delta-Y
and the “Manhattan Distance” appear in the Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Calibrating Distance

1

N

M easure the distance between two points or measure cumulative distance.
See Measuring Distance

Inthe Measurement diaog, click Calibrate.

The Distance Calibration dialog appears displaying the measured
distance.

From the Measured Dist. drop-down list, select the unit to which you want
to calibrate the distance.

Click Calibrate to and enter avalue if you want to calibrate the distance to
avaue.

Click Set Factor and enter avalue if you want to calibrate the distance by a
factor.

Click OK.
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The calibration results appear in the Measurement dialog.
Click Close to close the Measurement dialog.

Measuring Minimum Distance

Use the Minimum Distance option to measure the minimum distance between
entities. The avail able entities for snapping are nets, pins, vias and traces.

1

w

10

11

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Minimum Distance button on the
AutoVue toolbar.

Click the Min.Distance tab.

Select First Set to select the entities that you want to measure from.
Select the Snapping Modes that you want to select as the entities for the
measurement.

See EDA Snapping Modes

Note If you select Net, you cannot select any other type of entity.

Click thefirst set of entities on the drawing.

The entities are highlighted.

Note To clear the last set of entities you selected, click Clear Set.

Select Second Set to select the entities that you want to measure to.
Click the second set of entities on the drawing.

The entities are highlighted in a different color.

From the Measured Min Distance drop-down list, select the unit in which
you want to measure the distance.

Click Zoom to Result, if you want to zoom in to the measurement on the
drawing.

Click Compute.

The minimum distance from the first set of entitiesto the second set is
highlighted by aline. The minimum measured distance, Delta-X, Delta-Y
and the Manhattan Distance appear in the Measure Minimum Distance
dialog.

Click Close to close the Measurement dialog.

Measuring Area

Use the Area option to measure the area and perimeter of aregion.
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Select Analysis > Measure from the AutoVue main menu.The
Measurement dialog appears.

Note You can dso click the Area button on the AutoVue toolbar.

Click the Area tab.

Select Between Points if you want to measure the area between points on
adrawing. Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See EDA Snapping Modes

Select Shape if you want to measure the area of a predefined shape on the
drawing. Snapping Modes are disabled.

From the Measured Area Units drop-down list, select the unit in which
you want to measure the area.

From the Perimeter Units drop-down list, select the unit in which you
want to measure the perimeter.

To cumulate aNet Area Result of different areas, select Add inthe
Measurement dialog.

To subtract an areafrom the Net Area Result, select Subtract.

Select Clear to clear the Net Area Result.

If you selected Between Poaints, click points on the drawing to define the
area.

Each point isjoined by aline. The area and perimeter measurements appear
in the Measurement dialog.

If you selected Shape, click the edge of the predefined shape that you want
to measure.

The shape is highlighted. The area and perimeter measurements appear in
the Measurement dialog.

Note Click Reset to take another measurement.

10 Click Close to closethe Measurement dialog.

Measuring an Angle

Use the Angle option to measure the angle between points on a drawing.

1

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Angle button ﬁ on the AutoVue toolbar.

Click the Angle tab.
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Select From 3 Points if you want to measure the angle between three
points. Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See EDA Snapping Modes

Select Between 2 lines if you want to measure the angle between two
lines. Snapping Modes are disabled.

From the Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.

If you selected From 3 Points, click three points to define the angle.

If you selected Between 2 Lines, click two lines to define the angle.
Angle arms appear with an arc connecting them. The angle measurement
appears in the Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Measuring an Arc

Use the Arc option to define or select an arc in the drawing and measure its
radius, center and diameter.

1

N

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can dso click the Arc button on the AutoVue toolbar.

Click the Arc tab.

Select From 3 Points if you want to measure the arc between three points.
Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See EDA Snapping Modes

Select Arc Entity if you want to measure a predefined arc. Snapping
Modes are disabled.

From the Arc Info drop-down list, select the unit in which you want to
measure the distance of the arc.

From the Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.

If you selected From 3 Points, click three points to define the arc.
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The points are joined by an arc. The measurements for center point
coordinates, radius, diameter, arc length, start and end of angle and sweep
appear in the Measurement dialog.

If you selected Arc Entity, click the edge of the arc that you want to
measure.

The arc is highlighted. The measurements for center point coordinates,
radius, diameter, arc length, start and end of angle and sweep appear in the
Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Calibrating an Arc

1

N

Measure an arc in the drawing.

See Measuring an Arc

Inthe Measurement diaog, click Calibrate.

The Radius Calibration dialog appears displaying the measured distance.
From the Measured Rad. drop-down list, select the unit to which you want
to calibrate the distance.

Click Calibrate to and enter avalue if you want to calibrate to avalue.
Click Set Factor and enter avalueif you want to calibrate by afactor.
Click OK.

The calibration results appear in the Measurement dialog.

Click Close to close the Measurement dialog.

EDA Terms and Definitions

Annular ring

A circular strip of conductive material that remains after a hole has been drilled
through the pad of a printed circuit board.

Anti-copper

An areawithin afill zonein which copper cannot be placed.
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Aperture

An opening, similar to the aperture of a camera, that is used for photo-plotting.
Apertures are available in various sizes and shapes.

Aperture list

A text file containing the dimensions for each of the apertures used to photo-plot
PCB artwork.

Clusters

Components that are grouped according to their interrelationships and placed in
close proximity on the board. This keeps the connections on the PCB short so
that the board is easier to work with.

Component
An element or a part of a PCB.

Component density

The quantity of components on a unit area of a PCB.

Component hole

A holein the printed circuit board that correspondsto apin or wire of a
component. This hole serves the dual function of attaching the component to the
board and establishing the electrical connection between the pin or wire and the
remainder of the board circuitry.

Component library

A computer datafile that contains the footprint patterns for a number of
components.

Component side

The uppermost or top layer of aboard on which most components are placed.
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Component silkscreen

The silkscreen markings of the printed circuit board that appear on the
component side. The silkscreen is applied over the solder mask.

Component solder mask
The colored, usually tranducent, coating applied to the board over the etched
copper. It protects the selected areas from the soldering process.

Connection

An unrouted, partialy routed, or completely routed path between two pads. In a
net with n pads, there are exactly n—1 connections.

Copper pour

A method by which a copper zone is filled with a specified pattern, with objects
that cross the zone or lie within the zone being avoided.

Copper zone

An area on a board designed to be covered by alayer of copper when
manufactured. Also known asa"meta zone."

Cross hatching

The breaking up of large conductive areas by the use of a pattern of lines and
spaces in the conductive material.

Datum

A specific location (a point) that serves as areference to locate a PCB pattern or
layer for manufacture.

Density

On a PCB, the degree to which components are packed on the board. Generally,
the density is given as the number of square inches per equivalent, i.e., alower
number indicates a more dense board.
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Discrete components

Components with three or fewer electrical connections (for example, resistors or
capacitors).

Electrical check

The process of checking the PCB to ensure that the connections they are on
match those specified in the net list.

Fill zone

A zone that defines an areato be filled with copper.

Fine pitch

A class of surface-mount components that is characterized by pins measuring
0.025 inches or less from pad center to pad center.

Footprint

The physical description of a component. It consists of three elements:
padstacks, representing the pads of the component; obstacles, representing
among other things, the physical outline of the component, silkscreens, keepouts/
keepins, and assembly drawing data; and text documenting the footprint
information (for example, the component name). You may want each project to
have its own footprint library containing all the footprints used in that project.

Ground plane

A large area on the PCB, usually an entire layer, that provides a common ground
connection for all component ground pins and other ground connections.

Heatsink

A mechanical device made of ahigh thermal conductivity material that dissipates
heat generated by a component or assembly.
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Heuristics

A method of routing that consists of repeated attempts to apply very smple
routing patterns to unrouted connectionsin order to complete the routing quickly
and cleanly. Typically, heuristics are used for memory and short point-to-point
routing.

Hole

The area where board material must be removed by drilling or milling.

Isolation

The clearance around a pad, track, zone, or viathat defines the nearest approach
allowed by conductors of another signal set.

Jumper wire

A discrete electrical component or wire used to make electrical connections
between points that have no copper etch due to board density or some other
factor.

Keepout

An areafill within which no routing is allowed.

Land
The copper pad needed for a surface mount pin.

L ayer
Onein aseries of planesin a PCB design on which tracks are arranged to connect
components. Vias connect tracks and zones between layers.

Manual routing

Individual connections, in the form of traces, vertices, arcs, etc., which are
entered manually into the PCB design.
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Mounting hole

A hole used for the mechanical support of a PCB or for the mechanical
attachment of componentsto a PCB.

Multi-layer board

A PCB that has multiple layers, separated by dielectric material, with
connectivity between layers established by vias or through-holes. This term
usually refers to a board with more than two layers.

Net

A logical construct (circuit) that originates in a schematic and is transferred to a
board to describe required electrical connections. The connections may be
completed by using vias, tracks, or zones.

Net list

List of names of symbols or parts and their connection points which are logically
connected in each net of acircuit. A net list can be extracted electronically on a
computer from a properly prepared schematic.

Obstacle

An outline representing an object on the board. It must be taken into account
during routing, placement, or copper pour.

Pad

On a PCB, a copper shape on one or more layers (there may be a hole and an
isolation surrounding the copper) used for connecting a component pin to the
PCB. The pad indicates where pins of a component are placed.

Padstack

A numbered list of pad descriptions. Each description contains a pad definition,
including layer, style, drill diameter, size, offset, and solder mask guard width.
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PCB - Printed Circuit Board

A PCB is aboard made up of components affixed to a common surface and
connected by copper tracks.

Pin
The portion of a component to which an electrical connection can be made.

Ratsnest

A number of unrouted straight-line connections between two or more pads that
represent the electrical connectionsin the netlist. The ratsnest servesas a
reminder that the pads must be connected, and that, currently, thereisno track on
the board to make that connection.

Reference designator

A character string denoting the type of component and a number that is specific
to that component.

Routing

Placing conductive interconnects between components on a PCB layout. The
process of turning nets into tracks.

Schematic

A graphical description of an electrical circuit.

Segment

The partial track that exists between two adjacent vertices or between a vertex
and a pin. Sometimes the track between two pinsis also called a segment,
although connection is usually the more appropriate term here.

Signal

An electrical impulse of a predetermined voltage, current, polarity, and pulse
width.
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Silkscreen

Text or outlines (in ink) on the solder mask, on the top, and sometimes on the
bottom of board modules. A silkscreen is used for component and identification
placement on a PCB and usually includes component outlines, reference
designators, polarity indicators, pin one markings, part numbers, the company
name, and copyright info.

SMT - Surface Mount Technology

PCB technology whereby the leads on the chips and components are soldered
onto the surface of the board rather than inserted into it. The use of SMT results
in smaller and faster printed circuit boards.

Solder mask

A negative plot of padswith a guard band around the pads. Also, alacquer
applied to prevent solder from adhering to unwanted areas on the PCB.

Solder paste

A pattern that serves as atemplate for solder paste application when the board is
manufactured.

Solder side

The PCB surface opposite the one on which most components are mounted
(component side). Also, the bottom layer of the board.

Test point

A special point of accessto an electrical circuit that is used for electrical testing
purposes.

Through-hole via

A viathat connects the surface layers on a PCB.
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Trace (Track)

The copper trails (electrical connection between two or more points) on the PCB
and the onscreen representation of that copper.

Venting patterns
Patterns etched in the board that allow gases formed during fabrication to escape.

Vertex

A logical point at which atrack isended and restarted. A vertex islocated at each
change of direction on the track.

Via (feed-through hole)

A hole connecting layers of aPCB. A through-hole via connects the surface
layers of aboard. On multilayer boards, avianot reaching a surface layer on one
sideiscaled ablind via, and avia not reaching a surface layer on either side,
thus being externally invisible, iscaled aburied via.

Viastack

A numbered list of via descriptions. Each description contains avia definition,
including layer, style, drill diameter, size, offset, and solder mask guard width.
Via stringer

The copper etch that exists between a SMT pad and a corresponding fanout via.

Zero-length connection

An unrouted connection between layers where the end points in the connection
have the same X- and Y- coordinates.

Zone

An areaon aPCB layer designated as copper or anti-copper. Copper zones may
have net names, while anti-copper zones may not.
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Working with 3D Files

From AutoVue's 3D mode, you can select model parts to transform independent
of the rest of the model. You can import 3D models into the current window and
export files to other formats. The Global Axesinform you of wherethe X, Y and
Z axes are positioned throughout all the operations you perform in AutoVue.

The Perspective option shows objects in three dimension with distances,
planes and curved surfaces adjusted to give a sense of depth. You have lighting
options where you can adjust the overall lighting surrounding amodel or just its
source light.

In AutoVue's 3D mode, you can customize operations to suit your needs. For
example, you can create and save your own views. Define cross sections and cut-
throughs of 3D models. Create a customized three-axis coordinate system that
you can set as the active coordinate system for your 3D files.

There are also features like Bill of Material (BOM), Interference Checking and
Product and Manufacturing Information (PM1) Filtering.

Models Tab

The Models tab displays the model’s hierarchy, inter-relation of different parts,
assemblies and bodies. With the Model tree, you can select different parts and
modify their attributes such as color, visibility, render mode or transformation.

Views Tab

The Views tab lists all the standard and user-defined views. You can switch to a
standard or user-defined view, as well as add or del ete user-defined views.

Bookmarks Tab

The Bookmarks tab listslinks to specific views (Draft views, 2D plans) or
other files with information related to the model. Navigate between these files
and views by clicking the appropriate link. Bookmarks lead to various views of
CAD files such as CATIA file Model Space, the 3D model of afile and
associated 2D engineering drafts.
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If aplus sign appears to the left of abookmark, click it to expand and view the
lower bookmark levels. If aminus sign appears to the left of the bookmark, click
it to collapse the lower bookmark levels.

To go to a destination specified by a bookmark, click the bookmark text or the
page icon located to the left of the bookmark text.

Global Axes

By default, there is athree-axis representation in the lower |eft corner of the
workspace. The X-axis isred, the Y-axis isgreen and the Z-axis is blue. When
transforming a model or defining a viewpoint, all operations are applied with
respect to these axes.

Selecting Model Parts

In AutoVue, you can select model parts from the Model Tree or from the
workspace and have them appear highlighted in the Model Tree and on the
model. You can also select amodel part and have all itsidentical parts appear
highlighted on the model and in the Model Tree.

Note In AutoVue, you can configure the Selection Highlight, see
Configuring AutoVue for 3D Files.

Selecting Model Parts from the Model Tree

1 Click the Models tab.

2 Select the part or parts from the Model Tree.
Note To select more than one model part, pressthe Shift or Ctrl key while
selecting.
The selected part(s) appear highlighted on the model and in the Model
Tree.

Select Model Parts from the Workspace

1 Select apart or parts on the model in the workspace.
Note To select more than one model part, pressthe Shift or Ctrl key while
selecting.

2 To select the parent entities of a selected part, press the Shift key and select
the part again.
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A pop-up appears listing the parent entities of the selected part. Select an
entity from the pop-up list.

The selected part(s) appear highlighted on the model and in the Model
Tree.

To select agroup of parts, select Edit > Select, then click and drag the
mouse around the parts.

The entities within the box are selected and highlighted in the Model Tree.
Note If the selected entity is hidden in the Model Tree, the Model Tree
expands to display the selected entity.

Selecting All Identical Parts of a Model

1

Select amodel part in the workspace or from the Model Tree, thenright-
click and select Select Identical Parts from the pop-up menu.

All identical parts are highlighted on the model and in the Model Tree.

If there are no identical parts found, a message appears indicating No
identical parts found.

Note You can also select sub-assemblies and Select Identical Parts to
display all identical sub-assemblies.

Hiding Model Parts

In AutoVue, you can hide specific parts of amodel or display specific parts and
hide the rest of the model.

1

Select the part or parts on the model or from the Model Tree.

Note To select more than one model part, pressthe Shift or Ctrl key while
selecting.

The selected part(s) appear highlighted on the model and in the Model
Tree.

To hide the selected part(s), right-click a selected part on the model or from
the Model Tree and select Hide from the pop-up menu.

The selected part(s) are hidden on the model.

To display the selected part(s) and hide the rest of the model, right-click a
selected part on the model or from the Model Tree and select Hide Rest
from the pop-up menu.

The selected parts are displayed in the workspace and the rest of themodel is
hidden.
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Re-centering

The Re-center option repositions the model back to the center of the View
window. You can use amodel part as a central reference point to reposition a
model. You can select several model parts to use as one collective central
reference point.

Re-centering a Model to a Selected Model
Part

Note The Re-Center > Selected option is only available when one or more
model parts are selected.

1 Select the model part or parts that you want to use.

2 Select View > Re-Center > Selected from the AutoVue main menu.
The model is repositioned using the selected model part or parts as the
central reference point.

Re-center All

The Re-Center All option repositions the entire model back to the center of the
AutoVue workspace.

1 Select View > Re-Center > All from the AutoVue main menu.
The model is repositioned to the center of the workspace.

Re-centering a Model to an Entity

You can use an entity as a central reference point to reposition amodel. The
entities are:

Entity Description
Vertex All vertices are highlighted. Select a vertex to use as the central refer-
ence point.

Note A snap box appears when moving the mouse over a vertex.

Edge All edges are highlighted. Select an edge to use as the central reference
point.
Note A snap box appears when moving the mouse over an edge.
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Entity Description

Midedge Highlight all edgesin the model. Select a mid-edge to use asthe central

reference point.

Arc Center  Highlight al arcsand circlesin the model. Select an arc center to use as

the central reference point.
Note A snap box appears when moving the mouse over an arc or
circle, indicating the center of the arc.

Face Select aface to use as the central reference point.

Note When moving the cursor along amodel face, the faceis
highlighted.

Select View > Re-Center > Entity from the AutoVue main menu.

The Re-Center dialog appears.

Select the entity that you want to use as the central reference point.

All instances of the entity are highlighted.

Click an instance of the entity.

The model is repositioned using the selected entity as the central reference
point.

Close the Re-Center diaog.

Expanding/Collapsing the Model
Tree

In AutoVue, you can expand the Model Tree to display child entities of a
selected node or nodes.

Note In AutoVue, you can also can configure the level you want to expand the
Model Tree. To configurethe Model Tree Level, see Configuring
AutoVue for 3D Files.

1
2

Click the Models tab.

From the Model Tree, select the node or nodes that you want to expand,
then right-click and select Expand All Children from the pop-up menu.
Note To select more than one node, press the Shift or Ctrl key while
selecting.

The selected entities are highlighted. The Model Tree expands displaying
the child entities of the selected node(s).
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To collapse anode(s), select the node(s), then right-click and select
Collapse All Children from the pop-up menu.
The Model Tree collapses the selected node(s).

Note You can also expand anode by clicking * . To collapse a node click

Creating 3D Mockups

In AutoVue you can import other 3D Models into the current activefile.
Note Theimported files must be 3D and have similar dimensions.

1

2

3

Select Analysis > DMU from the AutoVue main menu.

The Import Design appears.

Click Add.

The Import Design Dialog appears.

Enter the File name or browse to locate the file you want to import.
Click Open.

Thefile appearsin the Import Design diaog.

Note To import more than onefile, repeat steps 2 to 4.

Click OK.

Thefile(s) you imported appear in the workspace.

Note Once open, you can position these models in the desired manner
using the Transformation tool, or align the models using Part
Alignment, or run Interference Checks.

See Also Transformation

Part Alignment
Performing Interference Checks

Deleting Models from a Mockup

1

N

Select Analysis > DMU from the AutoVue main menu.
The Import Design dialog appears.

Select the file(s) that you want to remove.

Click Remove.

Thefile(s) are removed from the list.

Click OK.

Thefile(s) disappear from the workspace.
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Converting 3D Models to Other
Formats

Sometimes you need to trandate a 3D model to be able to use it with an
application it was not created from. AutoVue provides several conversion file
formats for you.

Conversion Options

Depending on the conversion type being performed, the available optionsin the
Convert dialog will vary. These options are;

Option Description

Save As Specify the name and path of the file in which the con-
version isto be stored. Thisfileis aso known as the out-
put file. You can use Browse to provide AutoVue with
thefile's path.

Convert to Format A drop-down list of all the possible types of output file
formats currently available for conversion. The available
formats are:

e CALSGP4

e Encapsulated Postscript (Raster)
e HPLaserjet Printer (PCL)

¢ RunLengthRLCFile

¢ PCX Bitmap

+ PDF

¢ Stereolithography (STL)
« TIFF

e Virtua Reality Modeling Language (VRML)
¢ Windows Bitmap

Sub-Format The Sub-Format drop-down list appears when you
select TIFF or STL from the Convert to Format drop-
down list.

Select the Sub-Format from the drop-down list.

Cimmetry Systems Corp.



AutoVue 89
Option Description
Color Depth Select an option from the drop-down list:

Postive Triangle Values

Convert Region

Convert Pages

¢ 1 =Black and white

e 4=16colors

e 8=256colors

e 24 =Truecolor

e auto = AutoVue selects the color depth that best
matches the original file.

Note Optionisnot available for STL and VRML

formats.

When selected, the model is translated so that al the ver-
tex coordinate values are positive.

Note Optionisonly available when Convert to
Format isset to STL.

The area of the file to be converted. The available

options are:

e All -convertstheentirefile

« Display - converts theimageto fit on the output
page
For example, if you zoomed in on a particular
region of the file, the zoomed portion of thefileis
converted.

¢ Extent - convertsthe entire extents of thefile

¢« Selected - convertsthe selected model partsin
thefile

Note Optionsvary depending on the selected format.

The number of pages to be converted. The available

options are:

e All - converts all pages of thefile

e Current - convertsthe current page of thefile

¢ Range - converts the pages of thefile indicated in
therange

Note Optionisonly enabled when converting to TIFF.
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Option Description
XandY Specify X and Y to define the resolution for the con-

verted file. Choose from pixels, inches and millimeters

for the units.

¢ Xindicates the number of horizontal pixels

¢ Y isthenumber of vertical pixelsfor the current
active file contents

Note At times, AutoVue presets X and Y to match the

specifications of the selected conversion file format.

PDF

With AutoVueit is possible to convert Office, 2D and EDA formatsto PDF.
When converted from Markup Mode, markups are “burned” onto the PDF.
When you open the PDF, you will see the base file along with all markups.

Converting a 3D Model

1

2

Select File > Convert from the AutoVue main menu.

The Convert dialog appears.

Inthe Save As text box, enter the path and filename or click Browse to
locate the directory where you want to convert the file to, then enter afile
name.

From the Convert to Format drop-down list, select the format you want to
convert thefileto.

Note The Output and Convert area options change according to the type
of format you choose.

Select the output and convert options that you want to set for thefile.

See Conversion Options

Click OK.

TheConversion in progress dialog appears. The dialog disappears when
thefile is converted successfully.

Manipulating Views

AutoVue provides the flexibility to manipulate the display of a 3D model. You
can rotate, scale or translate a model or any selection of model parts. You can
also navigate from one page to another page of a multi-pagefile.
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You can access these options from the View menu of the AutoVue main menu.

The options are:

Select

Description

Zoom In

Out

Fit

Previous

Selected

Box Mode

Dynamic Mode

Zoom in by afactor of 2.
Zoom out by afactor of 2.

Resize object to fit window.

From the toobar, click the # button or right-
click in workspace and select from pop-up
menu.

Return to the previous zoom level.
Right-click in workspace and select from pop-
up menu.

Resize the object so that the objects selected
fill the window.

Click and drag to draw a box around an object
that you want to enlarge to fill the window.

From the toobar, click the '@. button or

right-click in workspace and select from pop-
up menu.

Click and drag the cursor up to zoom in or
down to zoom out.
From the toobar, click the %} button or

right-click in workspace and select from pop-
up menu.

Click and drag to reposition the model, then
rel ease the mouse button.

From the toobar, click the {n-? button or
right-click in the workspace and select from
the pop-up menu
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Select

Description

Rotate Mode

Spin Mode

Re-center

Click and drag to rotate the model on al three
axes, then release the mouse button.

From the toobar, click the G button or

right-click in workspace and select from pop-
up menu.

Click and drag the object in the direction you
want the object to spin continuously, then
release mouse button. To stop the object from
spinning, click once anywhere in the work-
space.

Note Thespinvelocity isdetermined by the
speed at which you drag the mouse.

From the toobar, click the @' button.

Repositions the model.

Re-center All - reposition the entire model
back to the center of the AutoVue workspace.
Selected - only available when one or more
model parts are selected. The selected part or
parts are considered as the central reference
point by which the model is repositioned.
Entity - select amodel part or entity asa
central reference point to reposition a model.
See Re-centering

Next Page
Previous Page

Page Number

Go to the next page of a multi-page file.
Go to the previous page of a multi-page file.

Go to the specified page of a multi-pagefile.

Perspective

Show objects in three dimensions with the
distances, planes and curved surfaces adjusted
to give asense of depth that reflects the
desired perspective to the eye.
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Select Description

Views Display different views of 3D models or create
your own.
Right-click in workspace and select the view
from the pop-up menu.
See 3D Views

Display Display a 3D modé in different render modes.

Attributes From the toobar, click the @ button or
right-click in workspace and select from pop-
up menu.
See Displaying Attributes

Show Tree Show the Model Tree of the current active

file.

From the toobar, click the | button.

Display Attributes

AutoVue provides several different render methods to display a3D CAD model.
You can also adjust the degree of transparency, change color or visihility, to suit

your preferences.

Render Modes

The choice of render mode varies between the level of detail and the render speed
of the model. For example, a shaded model is three-dimensional and highly
detailed but requires more time to render. The different render modes are:

Method Description

Wireframe A skeletal model constructed using lines and curves that represent
the model's "true" edges. All internal lines are visible.

Shaded A solid model constructed of planes and surfaces. These surfaces
are shaded to increase theillusion of three dimensions.

Hidden Line A wireframe constructed with all internal lines hidden.

Cimmetry Systems Corp.



94 AutoVue
Method Description
Silhouette A wireframe constructed with all internal lines visible but

including additional silhouette edges. These are not "true” edges
but help to visualize the model.

Wire Polygons A skeletal model constructed of unfilled polygons.

Shaded Wire An outlined solid model constructed of planes and surfaces. The

outlineis asolid line and the mode!'s surfaces are shaded to
increase theillusion of three dimensions.

Changing the Render Mode

Note A checkmark beside the attribute indicates the current render mode.

1

From the AutoVue main menu, select View > Display Attributes and the
render mode that you want to render the model in.
Note You can aso change the render mode for selected model parts.

Note You can also click the Render Mode button (il on the AutoVue
toolbar or right-click in the workspace and select Display Attributes.
The model or selected model parts change to the selected render mode.

Changing the Visibility

In AutoVue, you can show or hide parts of amodel.

1

From the Model Tree, clear the checkbox beside the model part(s) that you
want to hide.

Select the checkbox beside the model part(s) that you want to set visible.
The selected model part(s) appear or disappear from the model.

Note You can aso hide model part(s) by selecting them on the model or
from the Model Tree, then right-clicking and selecting Hide from the pop-
up menu. Selecting Hide Rest displays the selected model part(s) and hides
therest of the model.

Changing Model Color

In AutoVue, you can change the color of a specific model part or selected model
parts.

1

Select the model or model parts whose color you want to change.
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Note If no part is selected, the change is applied to the entire model.
Select View > Display Attributes > Color from the AutoVue main
menu.

The Color dialog appears.

Select the color that you want to change to.

Click OK.

The selected part(s) change to the selected color.

Note To set the model color to its default color, repeat steps 1 to 2 and click
Reset in the Color dialog.

Note You can aso right-click in the workspace and select Display
Attributes > Color. Inthe Model Tree, you can select the model part(s),
then right-click and select Display Attributes > Color from the pop-up
menu.

Adjusting the Transparency

You can adjust the degree of transparency of amodel. This function only applies
to shaded and shaded wire models.

1
2

Select the model or model parts whose transparency you want to adjust.
Select View > Display Attributes > Transparency from the AutoVue
main menu.

The Set Transparency dialog appears.

To adjust the transparency, move the slider |eft or right.

Select Apply Dynamically if you want the transparency to simultaneously
change with the movement of the slider.

Note You can also adjust the transparency by entering a Value from 0 to 1:
0 = opaque

1 = transparent

Click Close to apply the changes and close the Set Transparency dialog.
Note You can aso right-click in the workspace and select Display
Attributes > Transparency. In the Model Tree, you can select the
model part(s), then right-click and select Display Attributes >
Transparency from the pop-up menu.

Changing the Mesh Resolution

Note A checkmark beside the mesh option indicates the current mesh
resolution.

1

Select the parts that you want to change the mesh resol ution.
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2 From the AutoVue main menu, select View > Display Attributes >
Mesh Resolution and then High, Medium or Low.
Note You can aso change the mesh resolution by right-clicking in the
workspace and selecting Display Attributes > Mesh Resolution. In the
Model Tree, you can select the model part(s), then right-click and select
Display Attributes > Mesh Resolution from the pop-up menu.
Note Changing the mesh resolution will not affect the default Mesh
Resolution set in the Configuration dialog.

Light Settings

The default light setting consists of awhite light positioned directly in front of
the object asit is displayed. Inthe Lighting dialog it appears as aball of white
light in the center of the larger sphere.

Ambient lighting isthe overall lighting that surrounds an object. It provides
congtant illumination to every surface of the model. Thistype of lighting is
particularly effective as afill-light for surfaces not directly illuminated by a
directional light source. You can set the intensity or source position. Too high a
setting tends to saturate the image and reduce its clarity.

Using the Directional lighting option, you can adjust the position of the light
source on an object.

In AutoVue, you can:

e  Settheintensity and source position of the ambient light.
e Setthedirection of light.

e Add and remove light source.

e Changelight color.

Setting Ambient Lighting

1 Select View > Set Light from the AutoVue main menu.
The Lighting dialog appears.

Note You can aso click the light bulb button | &' on the AutoVue main
toolbar.

2 Click and drag the Ambient Light dliding bar until you achieve the desired
lighting.
The lighting automatically changes with the movement of the sliding bar.
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3

Note To set the ambient lighting to its default setting, click Reset.
Click Close to closethe Lighting dialog.

Setting Directional Lighting

Setting the directional lighting adjusts the position of the light source on the
model. You can also add a new light source.

1

Select View > Set Light from the AutoVue main menu.
The Lighting dialog appears.

Note You can aso click the light bulb button ‘¢ on the AutoVue main
toolbar.

To change the direction of thelight, click and drag the small ball until you
achieve the desired lighting.

Note You can aso drag the white ball outside of the large ball.

The direction of the light reflected on the 3D model automatically changes
with the movement of the white ball.

Note To set the light direction to its default setting, click Reset.

Click Close to closethe Lighting dialog.

Adding a New Light Source

1

Select View > Set Light from the AutoVue main menu.
The Lighting dialog appears.

Note You can aso click the light bulb button ‘' on the AutoVue main
toolbar.

Right-click inside the square surrounding the ball and select Create New
Light source from the pop-up menu.

A second small ball appears.

Click and drag the small ball until you achieve the desired lighting.

Note To restore the light source to its default setting, right-click inside the
square and select Restore Default from the pop-up menu.

Click Close to closethe Lighting dialog.

Note You can add up to eight light sources.

Changing the Light Color

1

Select View > Set Light from the AutoVue main menu.
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The Lighting dialog appears.

Note You can aso click thelight bulb button "% on the AutoVue main
toolbar.

2 Tochangethe color of thelight source, right-click directly on the small ball
and select Set Light Color.
The Color dialog appears.

3 Selectacolor.

4 Click OK.
The small ball changes color and the model reflects the selected light color.
Note To set the light color to its default setting, click Reset in the
Lighting dialog.

5 Click Close to close the Lighting dialog.

Removing a Light Source

1 Select View > Set Light from the AutoVue main menu.
The Lighting dialog appears.

Note You can aso click thelight bulb button "% on the AutoVue main
toolbar.

2 Right-click directly on the small ball that you want to remove and select
Remove Light.
The small ball disappears and the light change is reflected.

3 Click Close toclosethe Lighting dialog.

3D Views

In AutoVue, you can display different views of 3D Models or create your own
views.

Default View

The Default View istheisometric view for three-dimensional CAD models.
This viewpoint has the viewing camera positioned at an equal distance from all
three axes and pointing directly at the origin.
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Setting Standard or Predefined Views

Rather than entering Rotation mode, you can view various predefined rotations
with the Views option from View and Markup modes.

Note A checkmark beside the view option indicates the current pre-defined
view you want to display.
1 From the AutoVue main menu, select View > Views and the pre-defined
view you want to display.
The model changes to the selected view.
The view optionsthat you can select from are sometric, Top, Bottom, Front,
Back, Left and Right.
Note You can aso click the Views tab, then click the view from the
Standard Views tree, or right-click in the workspace and select Views.

Setting Native Views

AutoVue displays views for a 3D file as saved in its native application. The

views are listed under Native Views from the Views tab.

Note Native views are present only if the file contains saved views.

1 From the AutoVue main menu, select View > Views > Native Views and
the view you want to display.
The model re-orients to the selected view.
The view options vary depending on the file. Examples of the view options
are Last Saved View, Presentation, Front, Back, Left, Right, Top, Bottom,
Isometric, Trimetric and Dimetric.
Note You can also right-click inthe workspace and select Views > Native
Views.

Creating a User-defined View

You may want to create and save your own views. AutoVue allows you to define
aview and add it to the User Defined Views.
Note You can defineauser view in View or Markup mode. Any views you
apply to displayed models during Markup mode are saved as part of the Markup.
1 Apply your own views or transformation to the displayed model.
Note Theview statesthat you can apply and save for your defined view are
Extents, Rotation, Model Transformation, Explosion, Render Modes, Color,
Transparency, Visibility, Sectioning, Camera Settings and views involving
Mockups.
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2 Select View > User Defined Views > Add from the AutoVue menu.
The Add User Defined View dialog appears.
Note You can aso click the Views tab, then right-click User Defined
Views and select Add from the pop-up menu or right-click in the
workspace and select Views > User Defined Views.

3 Enter aView Name for the view that you want to define.

4 Click OK.
The view you defined is saved and appearsin the Views tree under User
Defined Views.
Note To seethe view you defined, click the Views tab and select it from
the tree or select View > Views > User Defined Views. You can also
alternate between User Defined Views and Standard Views without
affecting your personalized views.

Deleting a User Defined View

1 Under the User Defined Views, select the view that you want to delete,
then right-click and select Delete.
A Confirmation dialog appears.

2 Click OK.
The view disappears from the User Defined Views.

Displaying the Perspective Projection of a
3D Model

The Perspective option shows objects in three dimensions with distances,
planes and curved surfaces adjusted to give a sense of depth that reflects the
desired perspective to the eye.

Note You can usethe Perspective option in any of the 3D Viewssinceitisa
projection mode rather than a viewpoint.

1 Select View > Perspective from the AutoVue main menu.
The depth of the model changes.
Note A checkmark beside Perspective indicatesthe view is selected.

Viewing a Model from a Particular
Viewpoint

To view amodel from a particular point, you can specify aviewpoint.
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1 Select View > Views > View Point from the AutoVue main menu.

2 TheView Point diaog appears.
Note You can aso right-click in the workspace and select Views > View
Point.

3 Enter the coordinatesfor X, Y and Z.
For Camera Position, enter the coordinates to determine the position of
the cameralens.
For Target Position, enter the coordinates to determine the position of the
3D model viewed through the camera lens.
For Up Direction, change the coordinates to values between 0 and 1 to
determine the upward orientation.

4 Click OK.
The entity moves to the defined viewpoint. The Global axes and the User
Coordinates System change position to reflect the viewpoint.

Layers

Use this option to configure the current active file's layers to display.

1 Select View > Layers from the AutoVue main menu.
The Select the layers to display dialog appears listing the layers and
layer visibility for the current active file.
Note You can aso click the Layers button on the AutoVue tool bar.

2 Tosortthelist of layersin the dialog, click Name to sort alphabetically or
numerically, or click Status to sort by visibility.

3 Select the checkbox beside the layers that you want to set visible.
Clear the checkbox beside the layers that you want to hide.

4 Click OK.

The selected layers are displayed.

Entity Properties

In AutoVue, you can view properties such as visibility, colors, transparency,
mass properties and extents of amodel or model parts.
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Viewing Attributes

The Attributes tab displays amodel or model part’s attributes. The list of
attributes will vary depending on the model. Some of the viewable General
attributes are;

Attribute Description

Color Color of the selected model part.

Density The density of the model or selected model part(s).

Mesh Resolution The number of polygons drawn when displaying a model.

Name The model part name or the displayed page name of the
model.

Render Mode The dynamic rendering used for displaying model or model
part. For example, Shaded, Shaded Wire and Wire-
frame.

Transparency The value between 0 and 1 representing the model or model
part’s degree of transparency.

0 = opaque
1 =transparent

Visibility The value True (visible) or False (invisible) for amodel or

model part.

If you are displaying the 3D view of an EDA, AutoVue displays the general
attributes mentioned above. In addition, displays attributes specific to the Printed
Circuit Board (PCB), such as component name, board side, component class and
device type.

If a3D file has Product and Manufacturing Information (PMI) and a PMI entity
is selected, the PMI attributes are displayed along with the above general
attributes and attributes specific to the PCB board. Some of the viewable PMI
attributes are X-Axis, Y-Axis, font color, text font name and tolerance type.

1 Toview the attributes of specific model part(s), select the parts from the
model.
To view the attributes of the entire 3D model, make sure that no parts are
selected.

2 Select Analysis > Entity Properties form the AutoVue main menu.
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4

The Entity Properties dialog appears.

Note You can aso click the Entity Properties button "E ontheAutoVue
toolbar or right-click in the workspace and select Entity Properties. Inthe
Model Tree, select the model part(s), then right-click and select Entity
Properties from the pop-up menu.

Click the Attributes tab.

The attributes of the selected model part(s) are displayed in a hierarchical
tree.

Click Close to close the Entity Properties dialog.

Viewing Mass Properties

The Mass Properties pane displays the precise measurements for mass,
volume, area, center of gravity, moments of inertiaand inertia tensor for any
model or selection.

1

Select the part(s) for which you want to calculate the Mass Properties.
Note To view the Mass Properties of the entire 3D model, make sure no
parts are sel ected.

Open the Entity Properties dialog by taking one of the following steps:

» Click the Entity Properties button ?E in the AutoVue toolbar.

» Double-click amodel part or partsin the workspace.

* Right-click model part or partsin either the Model Tree or the
workspace, then select Entity Properties from the pop-up menu.

» Select Analysis > Entity Properties from the AutoVue main menu.

Select amodel part or parts.

Click the Mass Properties tab to view the Mass properties.

Note WhenaMass property cannot be calculated, “N/A” displaysin red for

that property. When thisisthe case, you can aso click the Error Report

button for alist of Mass properties that could not be calculated.

Click Options to change the density, change measurement units, or

configure computation of inertia tensor.

The Options dialog appears.

See Configuring Mass Properties

Click Close to close the Entity Properties diaog.
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Configuring Mass Properties

From the Mass Properties pane, you can change the density, the measurement
units or configure the reference point of inertia tensor.

1 Fromthe Mass Properties pane, click Options.
The Options dialog appears.

2 Tochangethe Density, enter avalue.

To change the Density units, select the unit for Mass and Length from
their respective drop-down lists.

3 Toapply the density to model parts with unknown density, select Use Only
for Parts with Unknown Density.

To apply the density to all model parts, select Use for All Parts.

4  To change the Display units, select the unit for Mass and Length from
their respective drop-down lists.

5 To compute the inertia tensor based on output coordinate system, select
Output Coordinate System Origin.

To compute the inertia tensor based on the center of gravity, select Center
of Gravity.

6 Click OK.

Mass properties are instantly calculated and displayed in the Mass
Properties panel.

Note When aMass property cannot be calculated, “N/A” displays for that
property. When thisis the case, you can also click the Error Report button
for alist of Mass properties that could not be cal culated.

7 Tosavethe changes, click Save As. The Save As dialog appears.
Specify the path where you want to store the file and enter the File name,
then click Save.

AutoVue saves theresultsin acsv (Comma Separated Values) file.

8 Click Close to close the Entity Properties diaog.

Viewing Extents

The Extents tab displays the orientation coordinates and center coordinates of
the X, Y and Z axes for any model or selection, aswell as the width, height and
depth measurements.

1 Select the part(s) for which you want view Extents.

Note To view the Extents of the entire 3D model, make sure no parts are
selected.

2 Select Analysis > Entity Properties form the AutoVue main menu.
The Entity Properties dialog appears.
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Note You can aso click the Entity Properties button "E onthe AutoVue
toolbar or right-click in the workspace and select Entity Properties. Inthe
Model Tree, select the model part or parts, then right-click and select
Entity Properties from the pop-up menu.

3 Click the Extents tab.

4 Click Transformed if you want to view the extents after you have
transformed the model.
Click UnTransformed if you want to view the extents of the model
without transformation.
Click Oriented if you want to view the X, Y and Z coordinates of the
reoriented model or selection.

5 Click Close to close the Entity Properties diaog.

PMI Filtering

A 3D file's Product and Manufacturing Information (PMI) is composed of
annotationsthat are included in design files. These annotationsindicate the limits
and constraints that must be observed during the production of the object
displayed in the 3D model.

At the highest level, PMI providesinformation about dimensions, feature control
frames, weld specifications, and surface finishes. Thisinformation is based upon
key design features which are specified through datum targets, measurement
points, reference geometry (construction lines, surfaces, objects), or the geometry
inherent in the object.

The following terms can be used interchangeably with the term PMI:

»  Datums Cosmetics

» Dimensioning Cosmetics

»  Geometric Tolerances (GTOLS)

»  Geometric Dimensioning and Tolerance (GDT & GD&T)

»  Functional Tolerance Annotation (FTA or FTA&A)

Use PMI Filtering to select which types of product and manufacturing
information to display.

1 Select View > PMI Filtering from the AutoVue main menu.
The PMI Filtering dialog appears displaying all PMI types.

H=—H
Note You can also click the PMI Filtering button PMI on the AutoVue
toolbar.
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2 Inthe Tree column, select the checkbox beside the items that you want to
show inthe Model Tree.
In the View column, select the checkbox beside the items that you want to
show on the model.
Clear the checkbox beside the items that you want to hide.
Note To show or hide al items, click All to show all or None to hide all.
3 Click OK.
Only items selected in the Tree column are displayed in the Model Tree.
Only items selected in the View column are visible on the 3D model.
Note Visibility settings are saved and will be restored the next time you
open the PMI filtering dialog.
4  AutoVue supports default PMI visibility as saved in thefile. To restore
default PMI visibility, click Default in the PMI Filtering dialog.

Aligning to a PMI Entity

From the Model Tree, right-click the PMI item that you want to align to and
select Align to from the pop-up menu.

AutoVue alignsto the selected PMI item.

Go To a displayed PMI Entity

From the Model Tree, right-click the PMI item that you want to go to on the
model and select Go To from the pop-up menu.

AutoVue zooms to the selected PMI item.

Manipulators

In AutoVue, you can rotate 3D CAD models along a specific axis. You can scale
amodel part up and down, as well as trandate the model.

Using the Manipulators, you can resize, trand ate and/or rotate sel ected parts of
the model. When you select one or more model parts, AutoVue displays a model-
size representation of the Global Axes going through the selected part(s) of the
3D model.

Panning a Model Along the X, Y and Z-Axis

1 Sdlect Analysis > Manipulators from the AutoVue main menu.

Cimmetry Systems Corp.



AutoVue 107

You are now in Manipulators mode.

Note You can aso click the Manipulators button ﬁ on the AutoVue

toolbar or right-click in the workspace and select Manipulators. In the
Model Tree, you can select the model part(s), then right-click and select
Manipulators from the pop-up menu.

Select the model part or parts that you want to move.

Note To select more than one part, press the Shift or Ctrl key when
selecting.

A model-size representation of the Global Axes appears through the model
part or parts and are encased by a three-dimensional box.

Click and hold the mouse button on the arrow at the end of the axis that you
want to pan.

Drag the mouse to where you want to move the part or parts.

Note To remove the Manipulators, click the Manipulators button.

Rotating a Model Along the X, Y and Z-
AXis

1

Select Analysis > Manipulators from the AutoVue main menu.
You are now in Manipulators mode.

Note You can aso click the Manipulators button ﬁ on the AutoVue
toolbar or right-click in the workspace and select Manipulators. In the
Model Tree, you can select the model part(s), then right-click and select
Manipulators from the pop-up menu.

Select the model part or parts that you want to manipul ate.

Note To select more than one part, press the Shift or Ctrl key when
selecting.

A model-size representation of the Global Axes appears through the model
part or parts and are enclosed by athree-dimensional box.

Click and hold the mouse button on the sphere at the end of the axis you
want to rotate.

Clicking on an axis sphere allows rotation around one of the other two axes.
Note Theinitial mouse movement determines which of the two axes will
mark the site of rotation. If the axis you chose does not rotate around the
right axis for the rotation that you want to make, click the sphere again and
move the mouse in a different direction.

Move the mouse to rotate the model by the selected axis.
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Note [f you want to rotate the selection freely, as done in Rotate Mode,
press the Ctrl key during rotation.

5 Toremove the Manipulators, click the Manipulators button ﬁ .

Note To remove Manipulators, you can also select Analysis >
Manipulators.

Mouse actions are restored to what they were prior to entering Manipulators
mode.

Scaling a Model Along the X, Y and Z-Axis

1 Sdlect Analysis > Manipulators from the AutoVue main menu.
You are now in Manipulators mode.

Note You can aso click the Manipulators button ﬁ on the AutoVue

toolbar or right-click in the workspace and select Manipulators. In the
Model Tree, you can select the model part(s), then right-click and select
Manipulators from the pop-up menu.

2  Select the model part or parts that you want to scale.
Note To select more than one part, press the Shift or Ctrl key when
selecting.
A model-size representation of the Global Axes appears through the model
part or parts and are encased by a three-dimensional box.

3 Click and drag a corner cube of the box up or down to scale the selected
model part.
Note To remove the Manipulators, click the Manipulators button.

Part Alignment

With the Part Alignment option in AutoVue, you can select apoint on a
model’s vertex, edge or face to align amodel or model part to another model or
part.

The Mobile point determines the precise point of alignment for the model part.
The Fixed point on the model determines the precise fixed point to which the
mobile part will align.

With the Show Preview option, you can visualize the part alignment before
applying the change.
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When aligning models parts, you can choose from one of the following
Constraint Types.

Option Type Description

Constraint Coincident The Mobile part is positioned so that the
selected point on the mobile part coincides
with the selected part on the Fixed part.

Parallel Alignthe Mobile point so that it is parallel to
the Fixed point.

Perpendicular Align the Mobile point so that it is
perpendicular to the Fixed point.

Concentric Alignthe Mobile point sothat it has the same
center asthe Fixed point
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Part Alignment Constraints

Thetable below list the available Constraint Types for different combinations
of part alignment.

q) E
— o
+— () o c ()
5 2 c | 3 | § | % S
ol 4 < o n O (@)
Cone Coin Par Con Per Coin Par Coin
Con Per Con Con Con Con
Par
Cylinder Con Par Par Per Coin Par
Con Con Con Con
Sphere Con Coin Con Coin Coin
Con Con
Plane Coin Per Coin Coin
Par Par
Arc Con Per Par
Con Con
Line Coin Coin
Par
Point Coin

Note Thelettersin the table indicate the Constraint Type:

Where:
Coin - Coincident
Par - Pardl€

Per - Perpendicular
Con - Concentric

Aligning Model Parts

Note To see apreview of the alignment before applying the change, click
Show Preview.
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1 Select Analysis > Part Alignment from the AutoVue main menu.
The Part Alignment dialog appears.

Note You can aso click the Part Alignment button [45! on the AutoVue

toolbar or right-click in the workspace and select Part Alignment. Inthe
Model Tree, you can select the model part(s), then right-click and select
Part Alignment from the pop-up menu.

Part Alignment E|

Please select the mokile parts to align.

Constraint Defintion

Constraint Type Alignment Type
(®) Coincident (&) Aligned
) Parallel ) Anti-tligned

(:) Perpendicular
O Concentric

Geometry
hohile Fixed

EER EBE

Constraints
Constraints | arti-igned |

Showy Preview

2  Select the Constraint Type that you want to perform.
See Part Alignment Constraints

3 Selectthe Alignment Type.
Select Aligned if you want to align the Mobile point on the model part to
the Fixed point on the model.
Select Anti-Aligned if you want to align the Mobile point on the model
part so that it is opposite to the Fixed point on the model.

4  Select amodel part. The Mobile arrow is enabled.

5 Click Vertex @ Edge @ or Face 6| to select the type of
geometrical point you want to click on the model part to be aligned.
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All instances of the sel ected geometrical point appear highlighted.
6 Click the geometrical point on the selected model part.
The geometrical point is highlighted.

The Fixed arrow E| is enabled.

7 Click Vertex @ Edge @ or Face 6| to select the type of

geometrical point you want to click on the model part to remain fixed.

Click the geometrical point on the model.

9 Click Apply.
The model part is aligned according to the chosen options. The Constraint
Type and the types of geometrical points aligned appear under
Constraints.
Note To remove aconstraint, select the Constraint that you want to
remove, then click Remove. To removeall part alignments, click Remove
All.

10 Click Close to closethe Part Alignment dialog.
Note If you did not apply the changes before clicking Close, a message
appearsindicating Do you wish to apply the constraint(s)?

(o]

Transformation

With the Transformation option, you can rotate, scale or translate a model or
any selection of model parts, by using the illustrated buttons or by entering X, Y
or Z values.

To accessthe Transformation dialog, you can select Analysis > Transform

> Apply from the AutoVue menu, or click the Transform button ¥ onthe

S
AutoVue toolbar. From the Model Tree, you can select the model part(s), then
right-click and select Transform > Apply from the pop-up menu.

Cimmetry Systems Corp.



AutoVue 113

The buttons on the left correspond to the rotational moves along the three axes.
The buttons on the right correspond to the translational moves along the three
axes and the scaling up and down.

Transformation

Ready
Transformation -
Ratate [Deagree) — Translation [in.]
w |0 % |
Y. |0 Yo |0
z |0 z |0
Firror - Scale—

YZ[ 2 #YT || Factar [1

dy

[ Absolute Apply

Cloze Help I

Transforming a Model using lllustration
Buttons

1 Select Analysis > Transform > Apply from the AutoVue main menu.
The Transformation dialog appears.

Note You can aso click the Transform button i@; on the AutoVue
toolbar.

2  Select the model part or parts that you want to rotate, translate or scale.
Note To select more than one model part, pressthe Shift or Ctrl key while
selecting.

Note If no partis selected, transformation is applied to the entire model.
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3  Click the direction buttons on the left-hand side to rotate the model in the
direction that you want.
Click the translate buttons on the right-hand side to move the model in the
direction that you want.

To scale the model, click [j to scaleup or click [j to scale down.

Note To repeat atransformation, continue clicking the illustrated button.
Note Click Reset to set the model to its original transformation.

4 Click Close to closethe Transformation dialog.
The transformation state remains displayed.

See Also Resetting the Transformation of a 3D Model

Transforming a Model by Setting Values

1 Select Analysis > Transform > Apply from the AutoVue main menu.
The Transformation dialog appears.

Note You can aso click the Transform button #5% on the AutoVue

S
toolbar.

2  Select the model part or parts that you want to rotate, translate or scale.
Note To select more than one model part, pressthe Shift or Ctrl key while
selecting.

3 Torotatethe model by set values, enter the X, Y and Z value.

To trandlate the model by set values, enter the X, Y and Z value.

4  Toview amirror image, select the checkbox beside the Mirror plane.
5 To scalethe model by afactor, enter a Scale Factor.
6 Click OK.
To apply absolute transformation instead of incremental, select Absolute.
7 Click Apply inthe Transformation dialog.

8 Torepeat atransformation, ensure that Absolute is cleared, then continue
clicking Apply.
Note Click Reset to set the model to its original transformation.

9 Click Close to close the Transformation dialog.
The transformation state remains displayed.

See Also Resetting the Transformation of a 3D Model
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Resetting the Transformation of a 3D
Model

In AutoVue, you can reset amodel or selected partsto their original
transformation.

1 View thetransformed 3D Model in AutoVue.

2 Toreset the entire model to its original transformation, select Analysis >
Transform > Reset All.
To reset selected model part(s) to their original transformation, select the
part(s) on the model, then select Analysis Transform > Reset
Selected.
The model or selected parts changes to their original transformation.
Note You can aso reset selected model part(s), by clearing the checkmark

beside the part(s) in the Transformation column gﬁ} of the Model Tree.

*

Cross Section/Cut-through

With Cross Section/Cut-through feature, you can view the cross-section and
cut-through of 3D models. In the Define Section dialog you can define the
section plane position, section plane orientation and the cut-through.

Section Plane Options

In the Define Section dialog, you can use below options to define the
orientation of the section plane.

Option Description

XY Plane Section plane is oriented along the XY plane.

YZ Plane Section plane is oriented along the Y Z plane.

XZ Plane Section plane is oriented along the XZ plane.

From 3 Vertices Select three vertices on the object to define the orienta-

tion of the section plane.

From Face Normal Select aface on the object to define the orientation of the
section plane perpendicular to the face.
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Option

Description

From Edge Tangent

Define a Plane

Select an edge on the object to define the orientation of
the section plane perpendicular to the edge's tangent.

Define X, Y and Z coordinates to orient the section
plane.

Cut Options
Inthe Define Section dialog, you can use cut-options to define the cut-through
of an object.

Option Description

Don't Cut Display the object without a cut.

Cut Object displayed is cut along the section plane.

Invert Reverse the selection, display the other part of the

object.
Show Both Restore the cut part of the object.
Edges Only Display only the edges of the object along the section

plane.

Defining the Section Plane and Cut-

through

1 Select Analysis > Section > Define from the AutoVue main menu.
The Define Section dialog appears.

Note You can aso click the Define Section button E‘ on the AutoVue
toolbar. In the Model Tree, you can select model part(s), then right-click
and select Section > Define from the pop-up menu.

2 Fromthe Section Plane drop-down list, select the orientation for the

section plane.

See Section Plane Options
3 Fromthe Cut Options drop-down list, select the cut option that you want.

See Cut Options
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4

(6]

(0]

10

To define the plane position, click and drag the Plane Position dlider to
the position you want.

Click Dynamic, if you want the plane to move simultaneously with the
dlider.

Select Show Plane, if you want the section plane visible.

Select Fill, if you want the section plane filled.

The section planeis displayed asfilled and the Section Area iscalculated.
Note Fill color can be set from the Configuration dialog.

From the Measured Units drop-down list, select the unit in which you
want to measure the section surface.

Click Close to close the Define Section dialog.

Once you have defined the section plane and closed the Define Section
dialog, you can access the cut options from the Section menu.

To remove a previously defined section, select Section > Remove from
the AutoVue main menu.

The section plane and cut section disappears instantly.

Exporting Section Edges

In AutoVue, you can export a copy of the section plane and save it asa.dxf or
.dwg file.

1
2

(G2 >3

Define a section plane.

Select Analysis > Section > Export from the AutoVue main menu or if
the Define Section dialog isopen, click Export.

The Export Section As dialog appears.

Note You can also click the Define Section button [l on the AutoVue
toolbar. From the Model Tree, you can select the model part(s), then right-
click and select Section > Export.

From the Save in drop-down list, select the directory where you want to
export a copy to.

Enter the file name.

Select the Save as type from the drop-down list.

Note You can only savethefilein .dxf or .dwg format.

Click Save.

Note To remove a section plane, select Section > Remove from the
AutoVue main menu.

Cimmetry Systems Corp.



118 AutoVue

Exploding
In AutoVue, users can use the Explode option to better understand the structure
of an assembly and to analyze the dismount capability. The user can also savethe

exploded view, as well as obtain a printed document of the exploded product for
further analysis.

Explode Options

From the Explode dialog, you can define how the explosion isto be performed
and to visually explode or implode amodel. The options that you can set are:

Option Description

Maximum Depth Define up to which level you want to explode. All entities
from the root level to the specified level are exploded. All
entities on the other levels will not be exploded.

If you are exploding:

¢« Whole model - the number of available levels depends
on how many explodable levels exist in the model. For
example, if there are four levels, with level 2 being the
first level under the main assembly, then level 3 and
level 4 are added to the drop-down list.

« Selected parts - the number of available levelsto be
added to the drop-down list depends on the selected vir-

tual tree.
Animated When selected, animation is shown while exploding or
imploding the model.
Show Arrows When selected, arrows are displayed in an explosion assem-

bly. The arrow starts from an exploded entity and pointsto the
center point of its parent.
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Option Description

Scroll Explode Dragging the slider gradually displays the progression of the

explosion to show the explosion dynamics.

* Explode - pressing the button brings the

explosion level to the (n-1) level if current explosion
level is between n-1 (inclusive) and n level (exclusive).

e Implode - pressing the button brings the

explosion level tothenlevel if current explosion level is
between n-1 (exclusive) and n level (inclusive).

Exploding a 3D Model

1
2

Select Analysis > Explode from the AutoVue main menu.

Select the parts that you want to explode.

Note To select more than one model part, pressthe Shift or Ctrl key while
selecting.

To explode the entire model, ensure that no parts are selected.

From the Maximum Depth drop-down list, select the level to which you
want the model to explode.

Select Animated if you want to see an animated view of the explosion. Set
by default.

Select Show Arrows if you want to display the arrows.

To explode the model, click the button.
The whole model or the select model parts explode.

See Saving an Exploded View of a 3D Model

Note To implode the model, click the button. To manually change
the explosion state, click and drag the scroll bar.
Click OK to closethe Explode dialog.

The explode state remains displayed and theTransformation column E@} in
the Model Tree is updated indicating the exploded parts.
See Also Resetting the Transformation of a 3D Model

Saving an Exploded View of a 3D Model

From the Explode dialog, you can save the exploded view of the 3D model.
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1 Explodea3D Modédl.
See Exploding a 3D Model
2 Click Save View inthe Explode dialog.
The Add User Defined View dialog appears.
3 Enter aView Name.
4 Click OK.
The view is saved and appearsin the Views tree under User Defined
Views.
5 Click OK to close the Explode dialog.
The exploded state is saved.

See Also Resetting the Transformation of a 3D Model

User-defined Coordinate Systems

In AutoVue you have the option of creating customized three-axis coordinate
systems. Aswith the Global Axes and the World Coordinate System, the
user-defined axes are represented by ared X-axis, agreen Y- axisand ayellow
Z-axis.

When you set a User-defined Coordinate System (UCS) as the active axes,
operations such as measuring, transforming a model, or defining a viewpoint are
applied with respect to these axes.

You can create multiple UCS'sfor a 3D file. For multiple-page 3D files, you can
even set active a different UCS for each page.

Position Options

When defining a UCS, you can define the point where you want to place the user
coordinate system. The options are:

Position Description
(%, ¥, 2) Coordinates If selected, enter avalue to specify where the three axes
are positioned.
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Position

Description

Vertex

Edge

Midedge

Arc Center

Face

If selected, all vertices are highlighted on the model. A
snap box appears when you move the cursor on avertex.
Click the vertex point where you want to place the user
coordinate system. The X, y and z coordinate values for
the vertex are displayed. The UCS axes move to the new
position.

If selected, all edges are highlighted on the model. A
snap box appears when you move the cursor near an
edge. Click at a point on an edge where you want to
place the user coordinate system. The X, y and z
coordinate values for the edge point are displayed. The
UCS axes move to the new position.

If selected, all edges are highlighted on the model. A
snap box appears when you move the cursor near the
halfway point of an edge. Click at the mid-edge point
where you want to place the user coordinate system. The
X, Yy and z coordinate values for the mid-edge point are
displayed. The UCS axes move to the new position.

If selected, all arcs and circles are highlighted on the
model. A snap box appears when you move the cursor
near the center of acircle or arc. Click on the arc center
where you want to place the user coordinate system. The
X, Y and z coordinate values for the arc center are
displayed. The UCS axes move to the new position.

If selected, when you move the cursor along a model
face, the faceis highlighted. Click at a point on the face
where you want to place the user coordinate system. The
X, Y and z coordinate values for the arc center are
displayed. The UCS axes move to the new position.
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Orientation Options

When defining a UCS, you can define the orientation for the coordinate system.
The options are:

Position Description

(X, ¥, 2) Coordinates If selected, enter a value to specify the UCS orientation
according to one or more of the three axes.

Edge Tangent If selected, all edges are highlighted on the model. A
snap box appears when you move the cursor near an
edge. First select the axis that will determine the UCS
orientation. Click at a point on an edge to define the
orientation. The X, y and z values for the edge point are
displayed. The UCS axes are reoriented to the selected
edge.

Face Normal If selected, when you move the cursor along a model
face, thefaceishighlighted. First select the axis that will
determine the UCS orientation. Click at apoint on an
face to define the orientation. The X, y and z valuesfor
the face point are displayed. The UCS axes are reori-
ented to the selected face.

2 Vertices If selected, all vertices are highlighted on the model. A
snap box appears when you move the cursor on avertex.
First select the axis that will determine the UCS
orientation. Click two vertex points to define the
orientation. The X, y and z values for the vertices are
displayed. The UCS axes are reoriented to the selected
vertices.

3 Vertices If selected, all vertices are highlighted on the model. A
snap box appears when you move the cursor on avertex.
First select the axis that will determine the UCS orienta-
tion. Click three vertex points to define the orientation.
TheX, Yy and z valuesfor the vertices are displayed. The
UCS axes are reoriented to the selected vertices.
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Defining a User Coordinate System

1

o b~ w

Select Analysis > User Coordinate Systems from the AutoVue main
menu.
The User Coordinate Systems dialog appears.

Note You can aso click the User Coordinate Systems button «#~ on the
AutoVue toolbar.

Click New.

The name of the User-defined Coordinate System (UCS1 for the first one)
appearsin the Coordinate Systems box.

To change the name, type the new Name that you want for the UCS.

Click the Position tab to define the origin of the UCS.

From the Define from drop-down list, select the point where you want the
UCS axes to appear.

See Position Options

Click the Orientation tab to define the orientation of the UCS.

From the Define from drop-down list, select the point where you want to
orient the UCS.

See Orientation Options

To hide the UCS axes on the model, clear the checkbox beside Show
Trihedron. Enabled by default.

Click OK.

The newly active trihedral coordinate system appears bolder and larger and
its name appears in the User Coordinate Systems drop-down list on the
AutoVue toolbar.

Note If there is more than one coordinate system for thisfile, select which
coordinate system the new UCS will be Relative To. Otherwise, the new
UCS will be calculated with respect to the World Coordinate System.

10 Click OK to closethe User Coordinate Systems dialog.

Modifying a User-defined Coordinate
System

1

Select Analysis > User Coordinate Systems from the AutoVue main
menu.
The User Coordinate Systems dialog appears.
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Note You can aso click the User Coordinate Systems button «#~ on the
AutoVue toolbar.

2 Fromthe Coordinate Systems list, select the UCS that you want to
modify.

The settings you configured for the UCS are displayed.

3 Tochangethe Name, highlight the name and enter the new name.

4  Tochangethe Position, click the Position tab, then select the point where
you want the UCS axes to appear from the Define From drop-down list.
See Position Options

5 Tochangethe Orientation, click the Orientation tab, then select the point
where you want to orient the UCS from the Define From drop-down list.
See Orientation Options

6 To show the UCS axes, select Show Trihedron. To hide the UCS axes,
clear the checkmark.

7 Tochangethe UCSthat it isrelative to, select the UCS from the Relative
To drop-down list.

8 Click OK to closethe User Coordinate Systems dialog.

If you modified the Position or Orientation, the UCS axes dynamically
move to the new position. A changein Show Trihedron, will make the
UCS axes appear or disappear accordingly. A Name change, will display
the new name in the Coordinate Systems list and in the drop-down list

next to the UCS button i, on the toolbar.

Activating a Coordinate System

When you set a user-defined coordinate system (UCS) as the active axes,
operations such as measuring, transforming a model or defining a viewpoint are
applied with respect to these axes.

1 FromtheUser Coordinate Systems diaog, select the Coordinate
System that you want to use.

2 Click Set Active.

3 Click OK to closethe User Coordinate Systems dialog.
The newly active trihedral coordinate system appears bolder and larger on
the model and its name is displayed in the drop-down list next to the UCS

button PN on the AutoVue tool bar.
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Note You can aso set adifferent coordinate system from the User

Coordinate Systems drop-down list next to the UCS button A onthe
tool bar.

Deleting a User Coordinate System

1 FromtheUser Coordinate Systems diaog, select the Coordinate
System that you want to delete.

2 Click Delete.
Note The UCS disappears from the list and from the User Coordinate

Systems drop-down list next to the UCS button . on the toolbar.
3 Click OK toclosethe User Coordinate Systems dialog.

Interference Checks

In AutoVue, you can check for spatial interference of any two model parts.

Interference Check Options

With the Interference Checking option, you can perform different
interference checks. These checks are:

Check Description

All Against All Check for interference of any of the parts in the model.

Set Against the Rest Check where amodel part or set of model partsinterfere
with other model part(s).

Set Against Itself Check where amodel part or set of model partsinterfere
with itself.

Set 1 Against Set 2 Check where amodel part or set of model partsinterfere

with another model part or set of model parts.

Performing an Interference Check

1 Select Analysis > Interference Checking from the AutoVue main
menu.
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The Interference Checking dialog appears.

Note You can also click the Interference Checking button g on the
AutoVue toolbar.

2  Click the type of interference check that you want to perform.
See Interference Check Options

3 Ifyouselected Set Against the Rest or Set Against Itself, select oneor
more model parts on the model or from the Model Tree.
Note To select more than one model part, pressthe Shift or Ctrl key while
selecting.
The model part(s) appear inthe Selected Set list and are highlighted on the
model and in the Model Tree.
Note To clear the last set of selected model part(s), click Clear.

4 If you selected Set 1 Against Set 2, click the Set 1 arrow ,then
select one or more model parts on the model or from the Model Tree.
The model part(s) appear in the Set 1 list and are highlighted on the model
and in the Model Tree.
Note To clear aselected part, pressthe Ctrl key and click on the part on the
model. To clear the last set of selected model part(s), click Clear.

Click the Set 2 arrow i| then select one or more model parts on the model
or from the Model Tree.
The model part(s) appear in the Set 2 list and are highlighted in a different
color on the model and in the Model Tree.
5 Enter aMinimum Clearance Distance. Default value is 0.
Note Adding aMinimum Clearance Distance not only checksif the
two model partsinterfere, but also checksif they are located within a set
minimum distance.
From the Units drop-down list, select the unit for the clearance distance.
7  To configure the interference check results, click Options.
The Options dialog appears.
See Interference Check Results Options
8 Click Compute intheInterference Checking dialog.
Compute button changesto Stop.
Note Section planeis not taken into consideration when computing an
interface check.
Note To stop the Interference Checking process at any point, click Stop.

(o3}
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When the processis complete, al the instances of interfering pairs appear in
the Results list. The number of interfering pairs found appearsin the
Description box.
Note To view apair’sinterference information, click the corresponding
Results line. The information appears in the Description box and
AutoVue zooms into the interfering area.

9 Tosavetheresults, click Export.
The Export Results dialog appears.

10 Specify the file name and the directory where you want to save the file.

11 Click Save.
AutoVue saves theresultsin acsv (Comma Separated Values) file.
Note To perform another interference check click Reset, then click the
type of interference check.

12 Click Close to closethe Interference Checking dialog.

Interference Check Results Options

With AutoVue, you can configure the results of an Interference Check. The
configuration options are:

» Actions - provides aclose-up look at how model partsinterfere

» Selected Pair - configureif the selected pair from the Results list should
display opaque, transparent or hidden

» The Rest - configure if the other parts of the model should display
transparent or hidden while the selected pair is displayed

Option Select Description

Actions Zoom To Once the interference check is computed
and aresult setisselected from the list of
results, AutoVue zooms to the result.

Show Intersection Once the interference check is computed
and aresult set isselected from thelist of
results, AutoVue shows where the
intersection of model parts occur.

Selected Pair Opaque The selected pair from the list of results
appear opague.
Transparent The selected pair from the list of results

appear transparent.
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Option Select Description
Hide The selected pair from the list of results
appear hidden.
The Rest Transparent The rest of the model appears transparent

while the selected pair is displayed.

Hide The rest of the model is hidden while the
selected pair is displayed.

Comparing 3D Files

AutoVue providesthe ability to compare two 3D files or two sets of entitiesfrom
the samefile or different files and display color-coded comparative data. When
you compare two files, AutoVue displays a Compare Tree and three windows,
the first containing the base file, the second containing the file you compared the
base against, and the third containing the comparison results.

The Compare Tree displays the model’s hierarchy with a State column
displaying different icons representing the results of the file comparison. The

iconsindicate if an model part has been added & , modified & , moved
deleted == .

Inthe Comparison Result window, results are displayed in different colorsto
differentiate the results of the file comparison. The comparison options and
corresponding colors are:

Option Color Description

View Additions Indicates that something has been added.
View Deletions Red Indicates that something has been deleted.
View Unchanged Blue Indicates that there is no change.

To compare files:

1 View thebasefilein AutoVue.
2 Select Analysis > Compare from the AutoVue main menu.
The Open dialog appears.

Cimmetry Systems Corp.



AutoVue 129

~

Enter the File name or browse to locate the file you want to compare with
the current active file.

Click Open.

AutoVue displaysthe Compare Tree and three windows. The first window
displays the base file, the second displays the compare file and the third
displays the comparison results.

To view the properties of a modified or moved entity in the base fileand in

the compare file, select the modified & or moved entity from the
Compare Tree, then right-click and select Entity 1 Properties.

The Entity Properties dialog appears displaying the properties of the
entity in the base file.

See Entity Properties

Select the entity again, then right-click and select Entity 2 Properties.
The Entity Properties dialog display the properties of the entity in the
comparefile.

To compare the results of the entity in the base file to the compare file, select
the entity from Compare Tree, then right-click and select Compare
results.

The Compare results dialog appears.

To view the attribute differences, click Attributes.

To view the transformation difference, click Transformation.

Note If there are no attribute or transformation differences, the buttons are
disabled.

Click OK to closethe Compare results dialog.

To exit Compare mode, select File > Exit Compare Mode from the
AutoVue main menu.

The base file appears in the workspace.

Note You can aso exit Compare maode by right-clicking in any of the
windows and selecting Exit Compare Mode from the pop-up menu.

Comparing Entity Sets

From the file comparison, you can compare a set of entities from one file against
a set of entities from the another file. You can also compare sets of entities from
the samefile.

1

2

Select the files you want to compare.
See Comparing 3D Files
Select File > Compare Sets.
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The Compare Sets dialog appears.

A Compare Sets @

|| 30UGAssEmblyValve prt |1 3DUGAssemblyvalve pri
= ] Page2 = [ ]Page
= ] 30UGAssemblyvalve p = ] 30UGAssemblyyalve p
| 30UGPartYoke prt 1 30UGPartY oke prt
| 3DUGPanHousing ¢ 1 30UGPartHousing K
] 3DUGPartSeal prt ] 3DUGPartSeal prt
| 30UGPartSeal prt 1 3DUGPartSeal prt
| 3DUGPanGasket p ] 30UGPartGazket pr
1 3DUGParEody prt ] 3DUGRaHEady prt
< > 4 >
Set 1 Set 2
[ Clear ] [ ” Clear
[ Cancel ] [ Help ]

3 Click B Set 1. Set by defauilt.

4  Select the entities from either the tree on the |eft or the tree on the right.
Note Thetree on theleft isthe base file and the tree on theright isthe
comparefile.

The selected entities appear in the Set 1 list.

Click B set 2 point.

6 Select the entities from the other tree that you did not select for Set 1.
The selected entities appear in the Set 2 ligt.
Note To compare entities from the same file, select the entities for Set 1
and Set 2 from either the base file or the compare file.

7 Click OK.
The Compare Tree and the three windows are updated with the set
comparison results.

8 Torestore the comparison files, select File > Compare Files.

The files appear in the three windows.

(€3]
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Generating a Bill of Material

For 3D files, you can obtain alist with a count of the parts required for
manufacturing the item featured in the file.

To generate a Bill of Material:

1 Select Analysis > Bill of Material from the AutoVue main menu.
The Bill of Material dialog appears.

Count

Part Names

fitting1:0_0,1,Zhared-Shared

QD_Cpl0_0;1 Shared-Shared

LFitting:0_0;1 Shared-Shared

Tuhing: 0_0;1,Shared-Shared

Bott:0_0,1,5hared-Shared, Bolt:0_0;1,Shared-Shared

Fam0_0;1 Shared-Shared

Mipple:0_0;1 Shared-Shared

Lett_Carm0_0,1 Shared-Shared

Cam0_0;1 Shared-Shared

CamPlate:0_0;1 Shared-Shared, CamPlate:0_0,1, Shared-Shar...

1
1
1
1
2
1
1
1
1
2
1
1

bazez 0_0,1 Shared-Shared

Housing:0_0;1,Shared-Shared

[ Export... ] [ Close ]

2 Tosort the list numericaly, click the Count column header.

To sort the list alphabeticaly, click the Part Names column header.

3 Toview apart or parts on the model, select the part(s) from the Part
Names list.
Note To select more than one part, press the Shift or Ctrl key while
selecting.
The parts are highlighted on the model and in the Model Tree.

4 TosavetheBill of Material, click Export. The Save As dialog appears.
Enter aFile name or browse to locate the directory where you want to store
thefile, then click Save.
AutoVue saves theresultsin acsv (Comma Separated Values) or xml file.

5 Click Close to close the Bill of Material dialog.
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Entity Search

AutoVue allows you to search for entitiesin a3D Model using the Entity
Search dialog. You can search the whole model or selected entities on the
model, apply attributes, entity type or PMI filters as search criteriato filter
entities. You can also search for entities by the size of an entity and location or
select entities from the results list and have them appear highlighted in the
workspace and in the Model Tree.

The Search options are;

Where Option

Description

3D Search Selection
tab

Type

Show PMI
parent entity
in results

PMI Filter

PMI Type

Specify if you want to search the entire model or
selected parts or parts that are not selected.

Specify the type of entity you want to search. For exam-
ple, part, body, assembly or PMI.

When selected, displays only the parent entity of a PMI
entity that matches search criteria.

If cleared, displays PMI entities that match search crite-
riain the Results dialog.

Note Optionisenabled if Type isset to PMI or All
and file has PM1 entities.

Filters the entities that have PMI information.
Note Optionisenabled if Type issetto PMI or All.

Specify the specific PMI attribute you want to search.
Note Optionisdisabled if PMI Filter isset to All.
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Where Option Description
Attribute Name Specify the specific attribute you want to search. The
Filter available attributes are:
dialog «  Coalour
¢« Density
¢ Display_Mode
e Filepath
e Layer ID
¢ Mesh_Resolution
*« Name

¢« Shading_Style

e Tranducency

e Vishility

Note Additional attributes may be available
depending on the file selected.

Any Value When selected, AutoVue searches for any value of the
selected attribute.
Note The attribute value options are disabled.
If cleared, specify the values for the selected attribute
you want to search.
Note The attribute value options correspond to the
selected attribute.

Advanced olume Specify the size of an entity, the minimum and

3D Search maximum dimensions. The dimensions of an entity

tab boundary box must be between the specified
dimensions to meet the search criteria.

Location Specify an axes aligned boundary box. The boundary
box of an entity must be inside it to meet the search cri-
teria.

Performing a Search

1 Sdlect Analysis > Entity Search from the AutoVue menu.
The Entity Search dialog appears.

Note You can aso click the Entity Search button E on the AutoVue
toolbar.
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2 Click the 3D Search tab.

X

Entity Search

rc:h Advanced 3D Search
Selection: &1 w Attribute Fiters

Type: a0 - Defirition | 2ddd

P Filter:
Pl Type:
Results

Type | Mame

3 Fromthe Selection drop-down list, specify what parts of the model that

you want to search.

To search the entire model, select All.

To search specific parts of amodel, select Selected and then select the
parts on the model.

To search the model parts that are not selected, select Not selected.

4 From the Type drop-down list, select the type of entity that you want to
search.

Note For 3D Modelsthat have PMI information, the PMI search features
are enabled.

5 Select the checkbox beside Show PMI parent entity in results if you
want only the parent entity of the selected PMI entity or entities to appear in
the Results list.

Clear the checkmark if you want all PMI entities to appear in the Results
list.

Note Optionisenabled if Type isset to PMI or All and files has PMI
entities.

6 From the PMI filter drop-down list, select the type of entities that you want
to search.

To search all entities, select All.
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To search entities with PMI, select With PMI.
To search entities without PMI, select Without PMI.
7 Fromthe PMI type drop-down list, select the type of entity that you want to
search.
Note PMI type isdisabledif PMI Filter isset to All.
See Saving Search Results
8 Click Close to close the Entity Search dialog.

Performing an Attribute-based Search

From the 3D Search dialog, you can search for entities by their attributes, such
as color, density, shading, etc.
1 Select Analysis > Entity Search from the AutoVue menu.

The Entity Search dialog appears.

Note You can aso click the 3D Entity Search button E on the AutoVue
toolbar.
Click the 3D Search tab.
3 Select the search criteria that you want to use for your search.
See Performing a Search
4 Click Add. The Attribute Filter dialog appears.

N

Mtribute Filter X
|:| Ay value
User defined value:
Test:
Equals '
Walue:
(0,128, 255) w
[ Ok ] [ Cancel ]

5 From the Name drop-down list, select the attribute that you want to search.
The Value group box appears corresponding to the selected attribute.

6  Select the checkbox beside the Any Value if you want to search by any
value. The Value options are disabled.
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7  Clear the checkbox if you want to search by a specific value, then from the
Value drop-down list(s), select the values that you want to search.
8 Click OK.
Note To add more than one Attribute Filter, repeat steps4to 5.
9 Toedit an Attribute Filter, select the filter and click Edit.
The Attribute Filter dialog box appears allowing you to edit the filter.
10 Todisable an Attribute Filter, clear the checkbox beside the filter(s) that
you want to disable.
To enable an Attribute Filter, select the checkbox beside the filter(s).
11 Toremove an Attribute Filter, select the filter and click Remove in the
Entity Search diaog.
The Attribute Filter disappears from thelist.
12 Inthe Entity Browser, click Search.
A list of entities matching the search criteria appear in the Results list
displaying the Type and Name.
See Saving Search Results
13 Click Close to closethe Entity Search dialog.

Performing an Advanced 3D Search

From the 3D Search dialog, you can search for entities using volume or
location filters. Volume specifies the size of the entity: you can specify the
minimum and maximum dimensions an entity must be between. Location
specifies an axes aligned boundary box: you can specify the dimensions for an
axes aligned boundary box that an entity must be inside.
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1 Fromthe Entity Search dialog, click the Advanced 3D Search tab.

Entity Search g|
[ Enabled
Miritiun Ditensions Maxitnum Dimensions
H H
ke ke
7 z Units:
Location
[T Enabled
Pairt 1 Pairt 2
W H
bR kB
Z Z Units:

2 Tosearch for entities by Volume, select the checkbox beside Enabled.
Note [f you want to search for entities that match all three dimensions,
select the checkbox beside Completely contained. If the checkmark is
cleared, then an entity only has to match one dimension in order to appear in
the Results list.

3 Enter the Minimum and Maximum Dimensions.

4 From the Units drop-down list, select the unit you want to set for the
Volume dimensions.

5 Tosearch for entities by Location, select the checkbox beside Enabled.
Note If you want to search for entities that match all three dimensions,
select the checkbox beside Fits completely. If the checkmark is cleared,
then an entity only hasto match one dimension to appear inthe Results list.

6 From the Units drop-down list, select the unit you want to set for the
Location dimensions.

7 Enter thedimensionsfor Point 1 and Point 2.

8 Click the 3D Search tab.

9 Click Search.

A list of entities matching the search criteria appears in the Results list.
See Saving Search Results
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10 Click Close to closethe 3D Search dialog.

Saving Search Results

1 Perform an 3D entity search.
See Performing a Search
Performing an Attribute-based Search
Performing an Advanced Search
2 Click Search.
A list of entities matching the search criteria appear in the Results list
displaying the Type and Name.
3 Tosavetheresults, click Export.
The Save As dialog appears.
4 Specify the path where you want to store the file and enter the File name,
then click Save.
AutoVue saves theresultsin acsv (Comma Separated Values) file.

Measuring in 3D Files

AutoVue provides the ability to perform measurementsin 3D files. When
measuring, AutoVue provides the option to “snap” to different entity types on the
model.

You can access the measure options from the Analysis > Measure menu. The
options are:

Button Name Description
<8 Angle Measure the precise angle between any three
o] verticesor any two edges, planes, faces or

any combination of these entity types.

Arc Measure the precise radius, length and angle
of any arc and calculate the center point.

Distance M easure the preci se distance between any two
[ vertices, edges, mid-edges, arc centers, faces
or any combination of these entity types.
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Button Name Description
Minimum Distance M easure minimum distance between any two
o vertices, edges, mid-edges, arc centers, faces

or any combination of these entity types.

Edge Length Measure the precise length of a edge.
Face Surface Measure the precise surface area.

Vertex Coordinates Provide the coordinates of each vertex.

xéz

3D Snapping Modes

The Snapping Modes available allow you to select or snap to different entity
types on amodel. For example, if you select Vertex, all vertices are highlighted
and when you move the cursor over a vertex, a snap box appears.

The Snapping Modes allow you to snap to vertices, edges, faces, planes and
arcs.

Button Snap to Description

@ Edge Edges are highlighted on the model.
When moving the cursor over an edge, a snap
circle appears.

6‘ Face Faces are highlighted when you move the cur-
sor over aface and a snap triangle appears.

@ Vertex Vertices are highlighted on the model.
When moving the cursor over avertex, a snap
box appears.

Measuring Distance

Use the Distance option to measure the precise distance between two vertices,
edges, mid-edges, arc centers, faces or any combination of these entity types.

Note When measuring the distance between faces, if the faces are parallel,
AutoVue compares the shortest distance between the faces.
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1 Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Distance button on the AutoVue toolbar.

Click the Distance tab.
3 Fromthe Measured Distance Units drop-down list, select the unit in
which you want to measure.

N

4  ClicktheFrom arrow to select the entity type that you want to measure
from.

5 Select the Snapping Modes that you want to use for measuring.
See 3D Snapping Modes
All entities of the selected entity type are highlighted on the model.

6 Onthe model, select the entity you want to measure from.
Note [f you want to take more than one measurement from the same
starting point, click Fix Position.

7 Click the To arrow to select the entity type that you want to measure to.
8 Selectthe Snapping Modes that you want to select asthe end point for the
measurement.
All entities of the selected entity type are highlighted on the model.
9 Onthemodel, select the entity you want to measure to.
The points are joined by aline. The measured distance, Delta X, DeltaY and
Delta Z appear in the Measurement dialog.
Note Click Reset to take another measurement.
10 Click Close to closethe Measurement dialog.

Calibrating Distance

1 Measureadistance.

See Measuring Distance

Inthe Measurement dialog, click Calibrate.

3 TheDistance Calibration dialog appears displaying the measured
distance.

4 Inthe Measured Dist drop-down list, select the unit to which you want to
calibrate the distance.

5 Click Calibrate to and enter avalueif you want to calibrate the distance to
avalue.
Click Set Factor and enter avalue if you want to calibrate the distance by a
factor.

N
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6

7

Click OK.
The calibration result appears in the Measurement dialog.
Click Close to close the Measurement dialog.

Measuring Minimum Distance

With the Minimum Distance option you can measure the minimum distance
between model parts, as well as any two points from the selection sets: vertices,
edges, mid-edges, arc centers, faces or any combination of entity types.

1

w

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Minimum Distance button onthe
AutoVue toolbar.
Click the Min. Distance tab.

Click Set 1 point.

Click Entity if you want to measure the distance between model parts.
Snapping Modes are disabled.

Click Geometry if you want to measure the distance between entity types.
Snapping Modes are enabled.

If you selected Entity, select a part or parts on the model.

The model part(s) appearsin the list under Set 1 and are highlighted on the
model and in the Model Tree.

If you selected Geometry, select the Snapping Modes that you want to
use for measuring.

See 3D Snapping Modes

All entities of the selected entity type are highlighted on the model.

Select the entity or entities on the model.

The selected entities appearsin the list under Set 1 and are highlighted on
the model.

Note To reset a Set, click Clear. To clear items from a Set, select the
items and press the Delete key. To deselect a part or entity type on the
model, press the Ctrl key and left-click the part or entity type.

click B set 2 point.

Repeat step 5.

The model part appears in the list under Set 2.

From the Measured Min Distance drop-down list, select the unit in which
you want to measure the distance.

Click Compute.
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The minimum distance from the first set of entitiesto the second set is
highlighted by a line. The measured minimum distance, X, Y and Z
coordinates for Position1 and X, Y and Z coordinates for Position2
appear in the Measurement dialog.
Note Click Reset to take another measurement.

10 Click Close to closethe Measurement dialog.

Measuring an Angle

Use the Angle option to measure the preci se angle between any three vertices or
any two edges, planes, faces or any combination of these entity types.

1 Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Angle button “/m—a on the AutoVue toolbar.

Click the Angle tab.

3 Select the Snapping Modes that you want to use for measuring.
Entities of the selected types are highlighted on the model.
See 3D Snapping Modes

4  To measure the angle between an entity type and a plane, select the
checkbox beside Plane, then from the drop-down list select the plane.

5 Fromthe Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.

6 Click two points on the model to define the angle.
If you selected aPlane, click the vertex, edge or face whose angle you want
to measure between the plane.
Angle arms appears indicating the angle. The measurement appearsin the
Measurement dialog.
Note Click Reset to take another measurement.

7 Click Close to close the Measurement dialog.

N

Measuring an Arc

Usethe Arc option to measure the precise radius, length and angles of any arc on
the model. You can also calculates the center point location.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note You can aso click the Arc button on the AutoVue toolbar.
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N

Click the Arc tab.

Select Arc Entity if you want to measure a predefined arc.

All arc and circles are highlighted on the model. Snapping Modes are
disabled.

Select From 3 Points if you want to measure the arc between three points.
Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

See 3D Snapping Modes

From the Arc Info Dist. Units drop-down list, select the unit in which you
want to measure the arc distance.

From the Angles Units drop-down list, select the unit in which you want to
measure the angle.

If you selected From 3 Points, click three points to define the arc.

The points are joined by an arc. The measurements for center point
coordinates, radius, diameter, arc length, start and end of angle and sweep
appear in the Measurement dialog.

If you selected Arc Entity, click the edge of the arc that you want to
measure.

The arc is highlighted. The measurements for center point coordinates,
radius, ratio, arc length, angles start, end and sweep appear in the
Measurement dialog.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

Calibrating an Arc

1

N

Measure an arc.

See Measuring an Arc

Inthe Measurement dialog, click Calibrate.

The Radius Calibration dialog appears displaying the measured distance.
From the Measured Rad. drop-down list, select the unit to which you want
to calibrate the distance.

Click Calibrate to and enter avalue if you want to calibrate to a value.
Click Set Factor and enter avalueif you want to calibrate by afactor.
Click OK.

The calibration results appear in the Measurement dialog.

Click Close to close the Measurement dialog.
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Measuring Vertex Coordinates

The Vertex Coordinates option provides the coordinates of vertices on the
model.

1 Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Vertex Coordinates button onthe
AutoVue toolbar.

2 Click the Vertex tab.
All vertices on the model are highlighted.

3 Fromthe Coordinates Units drop-down list, select the unit in which you
want to measure.

4  Move the cursor over the highlighted vertex that you want to measure.
The X, Y and Z coordinates appear in atooltip.

5 Select the vertex.
The X, Y an Z coordinates appear in the Measurement dialog.
Note Click Reset to take another measurement.

6 Click Close the close the Measurement dialog.

Measuring the Length of an Edge

Use the Edge Length option to measure the length of any edge on the model.

1 Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can also click the Edge Length button on the AutoVue
toolbar.

2 Clickthe Edge Length tab.
All edges on the model are highlighted.

3 FromtheUnits drop-down list, select the unit in which you want to measure
the edge length.
Note If you want to cumulate the measurement of more than one edge,
click Cumulative.

4 Click the edge that you want to measure.
The edge length measurement appears in the Measurement dialog.
Note Click Reset to take another measurement.

5 Click Close to close the Measurement dialog.
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Measuring Face Surface

Use the Surface option to measure the surface area of aentity face or an entire
entity on the model.

1

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Face Surface button on the AutoVue

tool bar.

Click the Surface tab.

Select Face Surface if you want to measure the surface area of aface on an
entity.

Select Entity Surface if you want to measure the surface area of an entire
entity.

From the Measure Surface Units drop-down list, select the unit in which
you want to measure the surface.

Note If youwant to cumulate the measurement of more than one surface,
click Cumulative.

If you selected Face Surface, move the cursor on the model to highlight a
face surface, then click the face surface that you want to measure.

The face surface is highlighted. The measured surface appearsin the
Measurement dialog.

If you selected Entity Surface, click the entity that you want to measure.
The entity, aswell as all the faces belonging to the body are highlighted. The
measured surface of the body appearsin the Measurement dialog.

To measure the face surface of the entity, click on the highlighted body.

A pop-up list appears displaying the entity and its parents.

Select the entity or a parent from the pop-up list.

The selected entity is highlighted and the measured surface appearsin the
Measurement dialog.

Note To measure the face surface of a parent, select the parent from the
pop-up list.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.
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Configuring AutoVue

Use the configuration options to configure the AutoVue workspace for different
groups of fileformats or for al filesin general. For example, you can set
different background colors for EDA, 2D, 3D, or Officefiles. You can also set
pathsto locate external resources such asfonts, symbols, or XREFS, or configure
measurement options.

You can access the configuration options using the Configuration dialog. To
open the Configuration dialog, select Options > Configuration from the
AutoVue main menu.

For details on each configuration option, see:

General Options

Configuring AutoVue for 2D Files

Configuring AutoVue for 3D Files

Configuring AutoVue for EDA Files

Configuring Background Colors for Graphic Files
Configuring Background Colors for Desktop Office

General Options

To access the General configuration options, select Options >
Configuration from the main menu. Inthe Configuration dialog that appears,
click General in the tree.

Configuring Options for CAD Files

Configure how you want to display w.r.t. text, dimensions, line styles, and so on
for CAD files.

Option Description

Text ¢ Select to display text entities.
¢ Clear to hidetext entities.

Dimensions »  Sdlecttodisplay al dimensional entities.
¢  Clear to hide smple dimension entities.
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Option Description

Line Weights e Select to display varying line thicknesses.
e Clear to makeal lines appear equal, with awidth of 1
pixel. No line weights display for any line.

Force to Black e Select toforce all colors of adrawing to black.
¢ Cleartodisplay thefilein color.

Line Style e Select to display dotted and dashed lines.
¢  Cleartodisplay al lines as solid.
Filling e Select to display filled entities as filled rather than just
an outline.

e Cleartohidefilling for filled entities.

Load External e Select to load Xrefs automatically.
References ¢ Clear to keep Xrefs from loading automatically.
Raster Files

Select Full Resolution to display raster files at full resolution, or select Fit to
Window to display raster filesto fit the current window.

System options

Select Enable system tray hibernation if you want the AutoVue icon to
remain in the system tray even after you close AutoVue. Double-clicking this
icon lets you quickly reopen AutoVue, access recently-used files, and so on. To
completely exit AutoVue when this option is selected, you need to right-click the
AutoVueiconin the system tray and select Close AutoVue.

Clear Enable system tray hibernation if you want AutoVue to quit
completely when you closeiit.

Configuring Paths

Configure the paths for XRefs, fonts, symbols, or Markups.

When working with files that need external resources, such as fonts or XRefs,
you may need to specify the path to these external resourcesif they do not exist
in the same location as the base file.
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You may also need to access symbal libraries that are stored in a non-default
location or you may need to configure from where AutoVue reads and locates
Markup files.

Path Description
XRefs The directory paths for any external reference files associated with 2D,
3D or EDA files.

See Configuring Xref Paths

Font The directory paths for fonts required by AutoVue's vector files.
See Configuring Font Paths

Symbol The directory path for symbol libraries used by AutoVue's Markup
entities.

See Configuring Symbol Paths

Markup The directory paths for Markup files.
See Configuring Markup Paths

Configuring XRef Paths

XRef Paths are the directory paths for any external reference files associated
with 2D, 3D or EDA files.

1 Select Options > Configuration from the main menu.
The Configuration dialog appears.
2 Click General > XRef Paths inthetree.
3 Click the Add button
The Browse for Folder dialog appears.
4  Enter the directory path, or scroll to locate the directory where the external
reference files are located.
» To make AutoVue locate all subdirectories below the current folder, type
two asterisks (**) at the end of the file path.
For example, if you type C:\samples\**, AutoVue browses all subdirectories
below “samples’.
» To make AutoVue locate one subdirectory below the current folder, type
one asterisk * at the end of the file path.
For example, if you type C:\samples\*, AutoVue browses one subdirectory
below “samples’.
5 Click OK.
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The directory path appears.

Note To add more than one path to the list, repeat steps 3 to 5.

To change the order, select the path you want to move, then click Up or
Down to move the path to where you want it in the list.

To remove a path, select the path and click Remove.

Click OK to closethe Configuration dialog.

Configuring Font Paths

Font Paths arethe directory pathsfor fontsrequired by 2D, 3D, EDA, or Office
files.

1

2
3

Select Options > Configuration from the AutoVue main menu.

The Configuration dialog appears.

Click the General > Font Paths inthetree.

Click the Add button.

TheBrowse for Folder dialog appears.

Enter the directory path or scroll to locate the directory where the external
font files are located.

To browse al subdirectories below the current path, type two asterisks ** at
the end of the file path.

For example, C:\samples\** will result in browsing all subdirectories
below “samples’.

To browse one subdirectory below the current path, type one asterisk * at the
end of the file path.

For example, C:\samples\* will result in browsing one subdirectory below
“samples’.

Click OK.

The directory path appears.

Note To add more than one path to the list, repeat steps 3 to 5.

To change the order, select the path you want to move, then click Up or
Down to move the path to where you want it in the list.

To remove a path, select the path and click Remove.

The selected path disappears from the list.

Click OK to closethe Configuration dialog.

Configuring Symbol Paths

Symbol Paths are the directory paths for symbols libraries used by AutoVue's
Markup entities.

1

Select Options > Configuration from the AutoVue main menu.
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The Configuration dialog appears.

Click General > Symbol Paths in thetree.

3 Select the Auto option if you want to use the default directory to store the
Symbol libraries.

4  Selectthe User-Defined option if you want to select adirectory to store the
Symbol libraries. Enter the directory path where you want to store the

Symbol filesor click the Browse button El to locate the directory.
5 Click OK to close the Configuration dialog.

N

Configuring Markup Paths

Markup Paths arethe directory paths for Markup files associated with the
currently loaded document.

1 Select Options > Configuration from the AutoVue main menu.
The Configuration dialog appears.

2 Click General > Markup Paths in thetree.

3  Select the Auto option if you want to use the default directory to store the
Markup. AutoVue, by default, stores the Markup filesin an avred
subdirectory at the location of the basefile.

4  Select the User-Defined option if you want to select adirectory to store the
Markup. Enter the directory path where you want to store the Markup, or

click the Browse button El to locate the directory.

All markups will now be saved to and read from this new location.
5 Click OK to closethe Configuration dialog.

Measurement

To access the common Measurement configuration options, select Options >
Configuration from the main menu. Inthe Configuration dialog that appears,
click General > Measurement in the tree to display the options you need.

The Measurement options et you define the default measurement units and the
number of decimal places, asfollows:

Option Description

Significant Digits Lets you specify the number of decimal digits displayed for
each measurement. Enter a number from 1 to 18.

Defaults Units Lets you specify the default unit for measuring.
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Configuring the Base Font for Text Files

1 Select Options > Configuration from the main menu.

The Configuration dialog appears.

Select General > Base Font from the treeto display the options you need.
Select afont from the Font list.

Select Regular, Bold, Italic, or Bold Italic from the Font Style list.
Select afont size from the Size list.

Note You can see apreview of thetext in the Sample area.

Click OK to apply the font change and close the Configuration dialog.

a b~ wiN
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Configuring AutoVue for 2D Files

You can configure background color and snap settings for 2D files. To accessthe
2D configuration options, select Options > Configuration from the main
menu. In the Configuration dialog that appears, click 2D in the tree.

Snap Settings

In measurement mode, when you move the cursor within a predetermined snap
radius, the snap box appears for the entity to be selected. To change the snap
radius, change the value in the Snap Radius field. The snap radiusis
configured in pixels.

Access this option from the Configuration dialog. Select Options >
Configuration from the main menu, then click 2D in the tree.

Configuring Colors

The Colors settings let you modify colorsfor 2D files. In the Configuration
dialog, select 2D > Colors in thetree to display the following options:

Option Description
Background Change the color of the background for 2D files.
Measurement Modify the color you want displayed when taking

measurements on 2D files.
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Configuring AutoVue for 3D Files

In AutoVue, there are configuration options that you can set to customize the
work environment when working with 3D files. To access the 3D configuration
options, select Options > Configuration from the main menu. In the
Configuration dialog that appears, click 3D in the tree.

Rendering

The Rendering options let you modify the manner in which the model is
rendered. Changing these options affects the level of detailed displayed. The

Rendering options are:

Option Description

Smooth Shading  Set by default. Turning this option off renders curved surfaces of
shaded models as a series of flat surfaces. The level of detail is
thus reduced but render speed isincreased.

Note Only affects shaded models.

Back-Face If selected, instructs AutoVue not to render the back faces of the
Remova model being displayed. This increases the render speed but the
model appears |ess realistic while in motion.
Note Only affects shaded models.

Precise Hidden Instruct AutoVue to precisely calculate and render all hidden lines
Line inamode.
Note Selecting this option decreases render speed.
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Dynamic Rendering

The Dynamic Rendering options let you select the rendering mode for a
model in motion. The options you can select are:

Menu Option Description

Fast Frame Model spinsor rotates at afast rate. Thelevel of detail is
reduced, which enables faster rendering when the model
isin motion.

Wire Frame Model is displayed as wire framed during rotation or
spinning.

Flat Shading Smooth shading is not performed on curved surfaces
while the model isin motion.

Wire Polygons Render the model in wire polygon mode whilein
motion.

Vertex Cloud Model is displayed as a skeleton of verticeswhenin
motion.

Bounding Box Model parts are enclosed by bounding boxes when the

model isin motion.

Current Render Mode Model is rendered in the same mode whether moving or
static.

Model

The Model configuration options let you specify if you want to load the M odel
in Mesh Mode or BREP mode and let you control the Mesh Resol ution.

To access the Model configuration options, select Options > Configuration
from the main menu. In the Configuration dialog that appears, click 3D >
Model in thetree.

Loading

Select the Load Mesh Data option to load available mesh data. Clear Load
Mesh Data to load BREP data.

Note You need to reload the file for your changesto take effect.
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Default Mesh Resolution

The Default Mesh Resolution dlider lets you modify the number of polygons
drawn when displaying a model. Drag the slider between Low, Medium and
High resolution levels.

A low resolution level means fewer polygons are drawn giving lower detail and
higher render speed.

Note The Default Mesh Resolution dlider only affects shaded models and
wire polygon mode.

PMI Filtering

Inthe Configuration dialog, select 3D > PMI in the tree to display the PMI
options.

The PMI Filtering options let you configure which types of product and
manufacturing information to display. The checkboxes in the Tree column let
you select which PMI entity types display in the 3D model tree. The checkboxes
in the View column let you select which PMI entity types display in the
workspace. For more information on PMI Filtering, see PMI Filtering.

The following PMI Text Rendering Style options let you define the style for
the PMI text:

Option Description

Native Setting PMI text displays with the default setting.
(fromfile)

3D PMI text displaysin 3-dimensions. It may not always face you.

Flat-to-screen PMI text always faces you.

Configuring Color

With the Color options, you can configure the color to allow easier viewing of
3D file details. The Color options are grouped under Common, Section
Highlight, and Geometry Highlight, asfollows:
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Common

Option Description

Background Set the background color for 3D files.

Selection Set the color when selecting amodel or model parts.

Entity Default Set the default color to use when the model color is not stored in
the nativefile.

Measurement Set the color for measurements.

Min. Distance Set the color of the first set-point when measuring minimum

Set 1 distance.

Min. Distance Set the color of the second set-point when measuring minimum

Set 2 distance.

Section Highlight

Option Description

Edges Set the color for the section edges when defining Section Cut
Options.

Fill Set thefill color when defining Section Cut Options.

Geometry Highlight

Option Description

Vertex Set the color for vertices when highlighted during measurement
and markup.

Face Set the color for faces when highlighted during measurement and
markup.

Edge Set the color for edges when highlighted during measurement and
markup.
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Miscellaneous

In the Configuration dialog, select 3D > Miscellaneous in the tree to display
the Miscellaneous options.

Display

The Show Global Axes option is active by default. Disable this option to
remove the axes that display in the bottom-right corner of the workspace.

Model Tree

Enter adifferent valuein the Tree Level field to define the level at which you
want the Model Tree to collapse when opening a 3D file. The default is 3 levels.

Manipulator

Enable the Align with current UCS option to automatically align the
manipulators with the current User-defined Coordinate System.

Highlight Selection

Thefollowing Highlight Selection options let you define how AutoVue indicates
that an object is selected.

Option Description

Highlight Bounding Selection is enclosed in awireframe box.
Box

Hightlight Entity Selectionisindicated by changing color.

Configuring AutoVue for EDA
Files

In AutoVue, there are configuration options that allow you to customize your
work environment when working with EDA files. To access the EDA
configuration options, select Options > Configuration from the main menu.
Inthe Configuration diaog that appears, click EDA in the tree.
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See Customizing Selections
Displaying Tooltips
Modifying 3D View
Synchronizing Layers when Comparing Files
Configuring Zoom Behavior when Cross Probing
Modifying Colors

Customizing Selections

Configure how you want selected components to be highlighted. Click
Options > Configuration to open the Configuration dialog, then click EDA in
the tree. There are two selection options: Highlight Entity and Dim Unselected.

Highlight Entity: Activate this option to highlight al entities that you
select. This option is enabled by default.

Note The default highlight color is yellow. To change the highlight color,
see Modifying Colors.

Dim Unselected: Activate this option to dim all the entities that are not
selected. Selected entitiesretain their origina entity color.

Note: You can also select the Dim Unselected button inthemain
toolbar.

When the Dim Unselected option is enabled, you can set the dimness level for
entities that are not selected. Drag the slider to the right to increase the dimness
level and to the l€eft to decrease the dimness level. Theicon to the right of the
dimness settings in the Configuration dialog lets you preview the dimness level.

Displaying Tooltips

When you hover the mouse over an entity, a tooltip appears to show you
information about the entity. You can disable or enable these tooltips.

1
2
3

4

Click Options > Configuration to open the Configuration dial og.
Click EDA inthetree.

Under the Mouse Hover heading, select or clear the Show Entity
Information Tooltip option.

Click OK.

Modifying 3D View

You can configure the 3D PCB view of EDA files.
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Note The Default Board Thickness and Component Height values are read-only
if the EDA 3D file does not contain board and component information.

1
2
3

Click Options > Configuration to open the Configuration dial og.

Click EDA inthetree.

Enter avaluein the Default Board Thickness field to change the board’s
thickness.

Note The Default Board Thickness option only affects boards that have no
board thickness defined in the design. If aboard has a defined thickness, this
option does not affect that board.

Enter avaluein the Default Component Height field to change the
component height.

Note The Default Component Height option affects componentsthat do not
have height defined in the design. If a component has a defined height, this
option does not affect that component.

To work with a different unit of measurement, select another unit from the
Default Units menu. Thisisthe unit of measurement used for values set in
the Default Board Thickness and Default Component Height fields.

Reload the file to see your changes.

Synchronizing Layers when Comparing
Files
When you compare files, you can synchronize all layer settings. When the layer

settings are synchronized, changing one setting changes the same setting for both
files you are comparing.

1
2
3

Click Options > Configuration to open the Configuration dial og.

Click EDA > Analysis inthetree.

Activate the Layer Settings option to synchronize all layer settings when
comparing files.

Note: Thisoptionisonly applicable for PCB drawings.

Configuring Zoom Behavior when Cross
Probing

You can configure the zoom options when you cross probe files.

1
2
3

Click Options > Configuration to open the Configuration dial og.
Select EDA > Analysis in the tree.
Select one of the following Cross Probe options:
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e Click Keep Current Zoom Level. When this option is active, the view
of the target files remains the same while you cross probe.
» Click Zoom Selected to automatically zoom in on selected entities
while you cross probe. This option is enabled by default.
» Click Zoom Fit to automatically adjust the contents of afile along the
horizontal or vertical axisto fully display within the current window.
4 Click OK.

Modifying Colors

You can configure the colors for EDA files. To access these options, click
Options > Configuration to open the Configuration dialog, then click EDA >
Colors inthetree.

In the Color Options diaog, the options that you can configure are grouped
under Common and 3D View asfollows:

Common
Option Description
Background Change the background color for EDA files.
Selection Configure the color used to highlight entities.
Min. Distance Set 1 Configure the color of the first selection set point when
measuring minimum distance.
Min. Distance Set 2 Configure the color of the second selection set point

when measuring minimum distance.
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3D View
Option Description
Default Board Color Configure the color of the board in 3D view.

Default Component Color ~ Configure the component color in 3D view.

Configuring Background Colors
for Graphic Files

Specify background colors for mono raster files and color raster files.

To access these configuration options, select Options > Configuration from
the main menu. In the Configuration dialog that appears, click Graphics in
thetree.

Configuring Background Colors
for Desktop Office

Specify background colors for the following types of Desktop Office files:

e Document

*  Spreadsheet

e Database

e Archive

To access these configuration options, select Options > Configuration from
the main menu. In the Configuration dialog that appears, click Desktop
Office inthetree.
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Markups

AutoVue has the ability to view over 450 different file formats and to create
markups for all its readable file formats without the document's authoring
application.

Marking up refers to drawing and writing on an electronic document. AutoVue
provides the ability to markup different formats without modifying the original
file. When you create amarkup for afile, the markup is created on top of the
original file. Markups are saved in separate files.

If afile has existing markup files, ared light bulb @ appears on the status bar at
the bottom of the AutoVue workspace. Clicking this button opens the Markup
Files dialog allowing you to select markup files to open or create a new markup
file. When you open a markup file, AutoVue lays the markup over the original
file.

In Markup mode you can:

»  create entities such asarcs, boxes, circles, clouds, lines, arrows and polygons

» add asymbol, add information to an entity by adding text or a note

»  create, name and color layers to organize your work

» create anew markup file that combines copies of selected layers of different
markup files

»  create measurement markup entities that can be moved or resized

* navigate markups through a hierarchy tree, view markup properties and sort
the tree according to each property

»  view markup layersindividually or in combination

Note Markup capability isonly available in certain versions of the AutoVue
product. See the Product Variations Checklist for more information.

Markup Navigation Tree

When opening afilein Markup mode, aMarkup Navigation Tree appearsto
the | eft of the document. If the Markup Navigation Tree does not appear,
select View > Show Model Tree, then click the Markups tab.

The Markup Navigation Tree displays a hierarchy tree of markups or
comments created by users. You can navigate through the markups. A set of
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properties are generated for each markup. You can sort the markupsin the tree
according to each property by clicking the column headers. These properties are:

Property Description
Entity Type of markup entity created.
Author The name of the user who created the markup.

Last Modified The date and time the markup was modified.

Page Page number of the original document on which the markup entity
is created.
Layer Markup layer on which the markup entity is created.

When amarkup entity is created, it appearsin the Markup Navigation Tree
and the information is recorded and saved in the markup file.

Note Hover your mouse over an entity to seeits Author and Date properties
appear in atooltip.

To see more markup properties or to expand the tree, click and drag the Markup
Navigation Tree window. You can also drag the column headers | eft or right to
resize the columns. Click the column headers to sort the markupsin the tree.
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Working with Markup Files

Markup files are divided into uniquely named layers. Create, name and color
layersto organize your work. For example, different colors can indicate time
priorities and each layer can contain Markups related to acommon purpose.

Saved States

When you create and save a Markup file, you also save the view state, such asthe
zoom level at which you are working. If you save the Markup file while you are
working at your preferred zoom level, the next time you open the Markup it
displays at the same zoom level. Some examples of view states include zoom
level (extents), rotation and flip settings, transformation, section plane and
visibility. When creating Markups for 3D files containing imported models, the
imported design becomes part of the view state. For more information on 3D
view states, see Creating a User-defined View.

Stateinformation is also saved with each markup entity. For instance, if you were
at acertain zoom level when you created a markup entity, AutoVue saves the
information with the markup entity. To “Go To” the state you were at when you
created or modified the markup entity, select the markup entity and select Go
To.

Creating a Markup File

1 View afile that you want to markup.
2 Select File > Markup from the AutoVue main menu.

Note You can aso click the Markup button in the AutoVue main
toolbar.

AutoVue enters Markup mode and anew Markup file appearsin the
Markup Navigation tree.

See Also Creating a Markup Layer

Entering Markup Information

In AutoVue, when creating a Markup you can provide user information that you
can save with the Markup.

1 Select Markup > Information from the main menu.
The Markup Information dialog appears.
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Enter aUser name.

Enter a Department.

Enter aCompany name.

Enter the Location of the Company.
Enter aTelephone number.

Click OK.

The Markup Information is saved.

~NOoO o~ WN

Saving a New Markup File

1 Select File > Save As from the AutoVue main menu.
The Save Markup File As dialog appears.
The Markup Information that you entered when creating the Markup
displaysinthe dialog.
Enter aMarkup ID consisting of any combination of characters or numbers.
3 Click OK.

The Markup fileis saved and remains displayed in the workspace.

N

Opening Markup Files

1 View afilethat has existing markups.

2 Click thered lightbulb button *® in the bottom-left corner of the status bar.
Note: If thisbutton does not display, the file you opened has no existing
markups associated to it.

The Markup Files dialog appears.

3 Fromthe Markup list, select the checkbox beside the markup(s) that you
want to open.

Note: If you select more than one Markup, the Active Markup menu lets
you select which one of them isinitially active.

4 Click OK.

The selected markup(s) appear in the workspace on top of the original file.
Note: When you select more than one markup file, the markups display
simultaneousdly.

See Also Setting the Active Markup File

Saving an Existing Markup File

1 Modify the markup file.
2 Select File > Save from the AutoVue main menu.
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Note If you have multiple markups open that you have modified and want
to save them all, select File > Save All.

Note To save an existing Markup as a new Markup, select File > Save
As.

Importing a Markup File

1 Select File > Open from Markup mode.

2 IntheMarkup Files dialog that appears, click Import.
The Select markup file to import dialog appears.

3 Navigate to the markup file that you want to import and select it.

4  Click Open.
The imported Markup file appears in the workspace on top of the original
file.

Exporting a Markup File

1 InMarkup mode, select File > Save As.

Note For anew Markup file, select File > Save.
2 Click Export.
The Select markup file export to dialog appears.
Navigate and select the directory you want to export the markup file to.
Enter File name.
Click Save.
The markup file is exported to the selected directory.
Note The default format saved is Markup Files (*.*), but you can select
another one. In the Save as type drop-down list, there are six formats to
choose from: Markup Files (*.*), DXF Output (*.dfx), AutoCAD DWG R12
(.dwg), AutoCAD DWG R13 (.dwg), AutoCAD DWG 14 (.dwg) and
Microstation DGN Output (*.dgn).
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Setting the Active Markup File

A file can have several markup files. When you open several markup files
simultaneously, you can set one of the markups as the active markup. Any
changes you make is applied to the current active markup.

1 InMarkup Mode, select File > Open.

The Markup Files dialog appears.
2  Click the checkbox beside the markups you want to open.
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The Active Markup drop-down list appears when you select more than one
markup.

3 Fromthe Active Markup drop-down list, select the markup you want to
make active.
Note: An active markup displaysin bold in the Markup Navigation
Tree.

4 Click OK.
The selected markup appears in the AutoVue workspace.

Changing the Active Markup File

When you have multiple markup files open, you can change the active markup.
Note: An active markup displaysin bold in the Markup Navigation Tree.
Take one of the following steps:

* Inthe Markup Navigation Tree, right-click the name of the markup file you
want to make active, then select Set Active from the menu.

*  You can set the active markup by selecting a markup from the drop-down
list on the Markup toolbar.
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Markup Layers

Markup files can be divided into layers with each layer having its own unique
name. You can create, name and color layers to organize your work. For
example, different colors can indicate time priorities and each layer can contain
markups relating to a common purpose.

When working with markup layers, you can view layersindividually or in
combination, add, rename or delete layers. You can also specify adifferent color
for each layer; default layer color isred.

Creating a Markup Layer

Note Ensure that no markup entity is selected when creating a markup layer.

1 Select Markup > Markup Layers from the Markup menu.
The Markup Layers dialog appears.

Note You can aso click the Markup Layers button = onthe Markup
toolbar.
2 IntheMarkup Layers diaog, click New.
The New Markup Layer dialog appears.
3 Enter the name that you want for the markup layer.
4 Click OK.
The new markup layer is added to the list in the Markup Layers diaog.
5 To changethe color of the new layer, click Color inthe Markup Layer
dialog.
The Layer Color dialog appears. Select a Color, then click OK.
6 Click OK to closethe Markup Layers dialog.

Setting the Active Markup Layer

A markup can have several layers and you can set alayer as the active markup
layer. When amarkup layer is active, al modifications you make are applied to
that markup layer.

Note Ensure that no markup entity is selected when setting the active markup
layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.
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Note You can aso click the Markup Layers button = onthe Markup
toolbar.

2 Fromthe Markup Layers list, select the checkbox beside the layer you
want to make active.

3 Click OK.
The selected Markup layer appears in the workspace.

Changing the Active Markup Layer

When you have multiple markup layers, you can change the active layer to
another layer.

1 Select Markup > Markup Layers from the Markup menu.
The Markup Layers dialog box appears.

2 Fromthe Currently Active Layer drop-down list, select the layer you
want to make active.

3 Click OK.
The selected layer appearsin the workspace.

You can also change the active layer by selecting the layer from the drop-down
list on the Markup toolbar.
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Changing the Color of a Markup Layer

Note Ensure that no markup entity is selected when changing the color of a
markup layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note You can also click the Markup Layers button £: from the Markup

toolbar.
Select the markup layer that you want to change the color.
3 Click Color.
The Layer Color dialog appears.
4 SelectaColor.

N
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5 Click OK.

Note Only the entities that were created with the by-layer £: color

defined in the Markup Layers dialog will change color. Any entities that
were created using the color options from the Markup toolbar, will override
the by-layer color and will not change color.

6 Click OK to closethe Markup Layers dialog.

Renaming a Markup Layer

1 Select Markup > Markup Layers from the Markup menu.
The Markup Layers dialog appears.

Note You can aso click the Markup Layers button =: from the Markup
toolbar.

2 Under Markup Layers, select the checkbox beside the markup layer you
want to rename.

3 Click Rename.

The New Markup Layer dialog appears.

Enter the new layer name.

Click OK.

The markup layer is assigned the new name.

6 Click OK to closethe Markup Layers dialog.

(623

Toggling Markup Layers

From the Markup Layers dialog, you can turn alayer’svisibility on and off,
even if thereisonly one layer. Turning alayer’s visibility off, hides all markups
belonging to that layer.

1 Select Markup > Markup Layers from the Markup menu.
The Markup Layers dialog appears.

Note You can aso click the Markup Layers button & from the Markup
toolbar.
Under Markup Layers, select the layer(s) you want visible.
3 Click Toggle.
A checkmark appears beside the selected layers.
4  Tohide alayer, select the layer(s) with a checkmark, then click Toggle

again.

N
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Note You can alsoview alayer by selecting the checkbox besideit. To hide
alayer, clear the checkmark. To view all the Markup layers, click All On.
To hide all Markup layersclick All Off.

5 Click OK.
The markup entities belonging to the selected layer(s) appear in the
workspace on top of the original file.

Deleting a Markup Layer

1 Select Markup > Markup Layers from the Markup menu.
The Markup Layers dialog appears.

Note You can aso click the Markup Layers button = from the Markup
toolbar.

2 Fromthe Markup Layers ligt, select the checkbox beside the markup layer
you want to delete.
Note You can select more than one layer to delete at the sametime.

3 Click Delete.

4 Click OK.
Thelayer is deleted along with al entities belonging to the layer.

Moving a Markup Entity to Another Layer

1 Select the entity or entities that you want to move.
2 Seect Markup > Markup Layers from the Markup menu.
The Move to Layer dialog appears.

Note You can aso click the Layer button £ onthe Markup toolbar.
3 Select the Layer you want to move the entity or entities to.
4 Click OK.

The selected entity or entities are moved to the selected layer.

Note Only the entities that were created with the = By Layer color
defined inthe Markup Layers dialog will change color. Any entities that
were created using the color options from the Markup toolbar, will override
the by-layer color and will not change color.
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Consolidating Markup Files

The Consolidate option allows you to create a new markup file that combines
copies of selected layers of different markup files. During the review cycle,
consolidation simplifies document revisions by providing the author with one
combined markup file instead of several markup files.

Note The Consolidate option isonly active when more than one markup file

is opened.

1 Open the markup files that you want to consolidate.

2 Select File > Consolidate from the Markup menu.
The Consolidate Markups dialog appears.

3 Select the markup layers that you want to consolidate into onefile.

4  Enter aMarkup ID for the new markup file.

5 If you want to open the newly consolidated markup as the active markup,
select the Open as active markup option.

6 Click OK.
The consolidated markup file is saved. If you selected Open as active
markup, the consolidated markup opens and is set as the active markup.

Modifying Markup Entities

With AutoVue, you can assign an entity its own color, the same color as the
current active layer or create a custom color. You aso have the option of
grouping Markup entities. When you group Markup entities, you can manage the
group as you would a single entity.

In Markup mode, there are several options for modifying an entity. You can

apply these options to selected entities while you specify the change or new
entities that you add.

The modify options can be accessed from the Markup menu in Markup mode.
The options are:

Option Description

Delete Delete a selected markup entity or entities.
Delete All Delete al markup entities.

Delete Dimensions Delete al markup measure entities.

See Deleting Markup Measure Entities
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Option

Description

Hide Dimensions

Group or Ungroup

Line Style

Line Thickness

Arrow Style

Fill Type

Entity Color

Markup Entity
Properties

Hide al markup measure entities.
See Hiding Markup Measure Entities

Group or ungroup markup entities.
See Grouping Markup Entities

Change the line style for a selected markup entity or entities.

See Changing the Line Style

Change the line thickness for a selected markup entity or
entities.

Click the Line Thickness button == _I in the tool bar.
See Changing the Line Thickness

Add an arrow head at one or both ends of amarkup line
entity.

Click the Arrow Style button ::—J'J in the tool bar.
See Changing the Arrow Style

Change the transparency for selected markup entity or
entities.

Click the Fill Type button =l in the toolbar.

See Changing the Fill Type of An Entity

Change the line color, fill color and fill type for a selected
markup entity or entities.

Click the Line Color button L? _| inthetoolbar to change the
line color.

See Changing the Line Color of An Entity

Click the Fill Color button % _| inthe toolbar to change the
fill color.

See Changing the Fill Color of An Entity

Open the Markup Entity Properties dialog, which lets you see
and modify markup entity properties from one dialog.

See Modifying Markup Entity Properties
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Option Description

Hide Markups Hide all markup entities.

“Go To” a Markup Entity

Go To restores the view state when a created entity is saved. Opening an
existing markup for afile aso restores the last saved view state.
1 Fromthe Markup Navigation Tree, select the markup entity that you
want to view.
2 Right-click and select Go To from the drop-down menu.
AutoVue displays the markup page containing the entity.
Note If you selected a Markup entity that is on another page of the Markup,
the page containing that entity will be displayed.

Selecting Markup Entities

1 Click the Select button 3 from the Markup toolbar, then from the
workspace click the entity’s outer edge.
Note You can aso select the entity from the Markup Navigation Tree.
Note To select multiple entities, press the Shift or Ctrl key while
selecting.

Moving a Markup Entity

1 IntheMarkup Navigation Tree or in the workspace, select the entity or
entities that you want to move.
See Selecting Markup Entities

2 Intheworkspace, click and drag the selected entity or entitiesto anywherein
the workspace.

Editing a Markup Entity
The entities that you can edit are notes, text, dimensions, leaders and hyperlinks.

1 IntheMarkup Navigation Tree or from the workspace, double-click the
entity that you want to edit.
AutoVue zoomsin on the entity and the appropriate dialog appears allowing
you to make changes to the entity.
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Note You can aso edit an entity by right-clicking it in the Markup
Navigation Tree and selecting Edit from the pop-up menu.

Grouping Markup Entities

When you group markup entities, you can move, delete, copy and paste, resize,
or perform any modification on the group of entities that you would on asingle
markup entity.
1 IntheMarkup Navigation Tree or from the workspace, select the entities
that you want to group.
See Selecting Markup Entities
2 Select Markup > Group from the Markup menu.
The group of entities appear on the Markup Navigation Tree asaGroup.
3 Perform any modifications.
The modifications are applied to all the entitiesin the group.

Ungrouping Markup Entities
1 IntheMarkup Navigation Tree or the workspace, select the Group that
you want to ungroup.

2 Select Markup > Ungroup from the Markup menu.
The group of entities appear on the markup asindividual entities.

Hiding Markup Entities

To hide the Markup entities of a markup file, take one of the following steps:

e Inthe Markup Navigation Tree, right-click the markup file, then select
Hide.
Note To show hidden Markups, right-click the file name again and select
Show.

*  Select Markup > Hide Markups from the Markup menu.
The markup entities are hidden on the markup file.
Note To “unhide” markups, select Markup > Hide Markups again from
the Markup menu.

Changing Line Thickness of an Entity

Note A checkmark beside the thickness option indicates the current line
thickness.
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Select the entity or entities for which you want to change the line thickness.
See Selecting Markup Entities

From the Markup menu, select Markup > Line Thickness and theline
thickness that you want.

The line thickness changes for the selected entity or entities.

Note You can aso click the Line Thickness button == _I on the Markup
toolbar.

To define a custom line thickness, select Modify > Custom Thickness
from the Markup menu.

The Custom Thickness dialog appears.

Enter an integer value in pixels.

Click OK to closethe Custom Thickness dialog.

Note Any new entities that you create will have the new line thickness.

See Also Modifying Markup Entity Properties

Changing Line Style of an Entity

Note A checkmark beside the style option indicates the current line style.

1

Select the entity or entities for which you want to change the line style.

See Selecting Markup Entities

From the Markup menu, select Markup > Line Style and the line style that
you want.

The line style changes for the selected entity or entities.

Note Any new entitiesthat you create will have the new line style.
See Also Modifying Markup Entity Properties

Changing the Arrow Style

1

Select the line entity or entities for which you want to change the arrow
style.

See Selecting Markup Entities

Take one of the following steps:

* Right-click the entity and select Arrow Style from the menu.

 Click the Arrow Style button = | in the tool bar.
e Select Markup > Arrow Style from the main menu.
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3 Fromthe Arrow Style drop-down list, select the style of arrow that you
want for the entity.
You have the choice between no arrow heads, an arrow head at either one or
the other end of the line entity, or arrow heads at both ends of the line entity.
The arrow style changes for the selected line entity or entities.
Note Any new entitiesthat you create will have the new arrow style.

See Also Modifying Markup Entity Properties

Changing Line Color of an Entity

1 Select the entity or entities for which you want to change the line color.
See Selecting Markup Entities

2 Select Markup > Entity Color from the Markup menu.
The Entity Color dialog appears.

Note You can aso click the Line Color button & i onthe Markup
toolbar.

3 FromtheLine Color drop-down list, select the color that you want for the
entity.

Note Selecting By Layer = changes the entity color to the color of the
layer.
4 To define acustom line color, select Custom Color fromtheLine
Color drop-down list.
From the Color dialog that appears, select a color and click OK.
6 Click OK to closethe Entity Color dialog.
Theline color changes for the selected entity or entities.
Note Any new entities that you create will have the new line color.

See Also Modifying Markup Entity Properties

(61

Changing Fill Color of an Entity

1 Select the entity or entities for which you want to change thefill color.
See Selecting Markup Entities

2 Seect Markup > Entity Color from the Markup menu.
The Entity Color dialog appears.

Note You can aso dlick the Fill Color button %l on the Markup toolbar.
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From the Fill Color drop-down list, select the color that you want for the
entity.

Note Selecting =: By Layer changes the entity color to the color of the
layer.

To define you own color, select Custom Colr from the Fill Color
drop-down list.

From the Color dialog that appears, select a color and click OK.

Thefill color changes for the selected entity or entities.

Click OK to closethe Entity Color dialog.

Note Any new entitiesthat you create will have the new fill color.

See Also Modifying Markup Entity Properties

Changing Fill Type of an Entity

1

Select the entity or entities for which you want to change the fill type.
See Selecting Markup Entities

Select Markup > Entity Color from the Markup menu.

The Entity Color dialog appears.

Note You can aso click the Fill Type button =il on the Markup toolbar.
From the Fill Type drop-down list, select thefill type that you want for the
entity.

Select Solid Fill, if you want thefill color to be solid.

Select Transparent Fill, if you want thefill color to be transparent.
Select No Fill, if you do not want any fill color.

Click OK.

Thefill type changes for the selected entity or entities.

Note Any new entities that you create will have the new fill type.

See Also Modifying Markup Entity Properties

Assigning an Entity the Same Color as the
Layer

1

Select the entity or entities for which you want to assign the color of the
layer that they belong to.

See Selecting Markup Entities

Select Markup > Entity Color from the Markup menu.

The Entity Color dialog appears.
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3 Toassigntheline color, select the =: BYLAYER fromthe Line Color
drop-down list.

Note You can aso click the Line Color button & from the Markup
toolbar.

4  Toassign thefill color, select the =: BYLAYER from the Fill Color drop-
down list.

Note You can aso dlick the Fill Color button &1 | from the Markup
tool bar.
5 Click OK.
The selected entity or entities change to the color of the layer that the entity
belongs to.

Deleting Markup Entities

1 Select the entity or entities that you want to delete.
See Selecting Markup Entities

2 Select Markup > Delete from the Markup menu.
The selected entity or entities are deleted from the current activefile.
Note To delete all entities, select Markup > Delete All from the Markup
menu. Delete All will delete all existing entities from the active markup,
whether they are visible or not.

Modifying Measurement Markup Entities

In AutoVue, you can modify the font of a measurement.

1 Create the markup measure entity that you want.
See Creating 2D non-vector Markup Measure Entities
Creating 2D Vector Markup Measure Entities
Creating EDA Markup Measure Entities
Creating 3D Markup Measure Entities
2 Double-click the measurement for which you want to modify the font.
The appropriate Measure dialog appears.
3 Click Font. The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
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Select the font Style(s), then click OK.
4  Click OK to close the appropriate Measure dialog.
The measurement font is modified.

Changing Measurement Units and
Symbols

In AutoVue, you can change the unit of measure and add a symbol to a
measurement and have it appear on the drawing.
1 Create the markup measure entity that you want.
See Creating 2D non-vector Markup Measure Entities
Creating 2D Vector Markup Measure Entities
Creating EDA Markup Measure Entities
Creating 3D Markup Measure Entities
2 Double-click the measurement that you want to change the unit of measure
or add a symboal to.
The appropriate Measure dialog appears.
3 Clear the checkmark beside Display Unit if you want to hide the unit on the
drawing. Unit appears by default.
4 From the Units drop-down list, select the unit that you want to change the

measurement to.

5 Fromthe Symbol drop-down list, select the symbol that you want to add to
the measurement.

6 Click OK.

The unit of measure changes and the selected symbol is added to the
measurement and appears in the workspace.

Hiding Markup Measure Entities
Select Markup > Hide Dimensions from the Markup menu.
The markup measurements are hidden on the markup file.

To “unhide” markups, select Markup > Hide Markups from the Markup
menu.

Deleting Markup Measure Entities

Select Markup > Delete Dimensions from the Markup menu.
The markup measurements are deleted on the markup file.
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Modifying Markup Entity Properties

In AutoVue, you can use the Markup Entity Properties dialog to modify markup
entities.

To open the Markup Entity Properties dialog, select Markup > Markup Entity
Properties from the Markup menu. You can aso right-click a markup entity in
the Markup Navigation Tree or the workspace and select Markup Entity
Properties from the contextual menu.

Line Color

Change the line color the selected markup entity or entities.

1 Select the entity or entities for which you want to change the line color.
See Selecting Markup Entities

2 FromtheLine Color drop-down list, select the color that you want for the
entity.

Note: Selecting By Laye = changes the entity color to the color of the
layer.
3 Todefine acustom line color, take the following steps:

a. Select Custom Color from the Line Color drop-down list.
b. Fromthe Color dialog that appears, select a color and click OK.

4 Make other changes you want with the Markup Entity Properties dialog,
then click OK to closeit.
Theline color changes for the selected entity or entities.
Note: Only selected entities that you create will have the new line color. To
apply the new line color to any new entity you create, make sure no entity is
selected before opening the Markup Entity Properties dialog.

See Also Changing the Line Color of An Entity

Line Style

Change the line style for a selected markup entity or entities.

1 Select the entity or entities for which you want to change the line style.
See Selecting Markup Entities

2 Select theline style that you want from the Line Style menu.
The line style changes for the selected entity or entities.
Note: Any new entities that you create will have the new line style.
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See Also Changing the Line Style

Line Thickness

Change the line thickness for a selected markup entity or entities.

1 Select the entity or entities for which you want to change the line thickness.
See Selecting Markup Entities

2 Select the line thickness that you want from the Line Thickness menu.
The line thickness changes for the selected entity or entities.

To define a custom line thickness, take the following steps:

1 Select Customize fromthe Line Thickness menu.

2 IntheWidth (Pixels) menu, enter the desired width.

3 Make other changes you want with the Markup Entity Properties diaog,
then click OK to closeit.
The line thickness changes for the selected entity or entities.
Note: Any new entities that you create will have the new line thickness.

See Also Changing the Line Thickness

Width (Pixels)

Customize the line thicknesswhen Customize is selected in the Line Thickness
menu. When other line thicknesses are selected, thisfield displaysits valuein
pixels but cannot be edited.

See Line Thickness

Arrow Style

Add an arrow head at one or both ends of a markup line entity.

1 Select theline entity or entities for which you want to change the arrow
style.
See Selecting Markup Entities

2 Fromthe Arrow Style drop-down list, select the style of arrow that you
want for the entity.

3 Make other changes you want with the Markup Entity Properties dialog,
then click OK to closeit.
The arrow style changes for the selected entity or entities.
Note: Any new entities that you create will have the new arrow style.

See Also Changing the Arrow Style
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Fill Type

Change the transparency for selected markup entity or entities.

1 Select the entity or entities for which you want to change the fill type.
See Selecting Markup Entities
2 FromtheFill Type drop-down list, select the fill type that you want for the
entity.
e Select Solid Fill, if you want thefill color to be solid.
» Select Transparent Fill, if you want the fill color to be transparent.
e Select No Fill, if you do not want any fill color.
3 Make other changes you want with the Markup Entity Properties dialog,
then click OK to closeit.
Thefill type changes for the selected entity or entities.
Note: Any new entities that you create will have the new fill type.

See Also Changing the Fill Type of An Entity

Fill Color

Change the line color, fill color and fill type for a selected markup entity or

entities.

1 Select the entity or entities for which you want to change thefill color.
See Selecting Markup Entities

2 FromtheFill Color drop-down list, select the color that you want for the
entity.

Note: Selecting =: By Layer changes the entity color to the color of the
layer.
3 Todefine you own color, take the following steps:
a. Select Custom Color from the Fill Color drop-down list.
b. Fromthe Color dialog that appears, select a color and click OK.
Thefill color changes for the selected entity or entities.
4  Make other changes you want with the Markup Entity Properties dialog,
then click OK to closeit.
Thefill type changes for the selected entity or entities.
Note: Any new entities that you create will have the new fill color.

See Also Changing the Fill Color of An Entity
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Markup Layers

When you have multiple markup layers, you can change the active layer to
another layer.

1 Fromthe Markup Layers drop-down list, select the layer you want to
make active.

2 Make other changes you want with the Markup Entity Properties dialog,
then click OK to closeit.
The selected layer appearsin the workspace.

See Also Changing the Active Markup Layer

Marking Up 2D Files

AutoVue provides avariety of user-friendly markup options that you can use
when marking up 2D files. You can create entities such as arcs, boxes, circles,
clouds, lines and polygons. You can draw aleader with multi-line segments and
add text to it. You can also add a symbol, add text to an entity or add information
by adding a note.

Note When you are creating a markup entity, you can press Escape to cancel.

2D Markup Entities

In AutoVue, you can drawing many different types of entities. You can access
the entities from the Entities menu in Markup mode. The entities are:

Option Description

Note Right click to complete an entity.

Arc Click and drag the mouse to draw an arc.
From the toolbar, click the Arc button B
Box Click and drag to draw arectangle.

From the toolbar, click the Box button 0l .
Note To draw asquare instead of arectangle, press and
hold the Shift key while you click and drag.
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Option Description

Closed Polyline Click and drag to draw a closed Polyline.
From the toolbar, click the Closed Polyline button £ .

Cloud Click and drag to draw acloud.
From the toolbar, click the Cloud button @ .

Circle Click and drag to draw a€llipse.

From the toolbar, click the Circle button o
Note Todraw acircleinstead of an ellipse, press and hold
the Shift key while you click and drag.

Filled Box Click and drag to draw afilled box. The box isfilled with a
solid color.

From the toolbar, click the Filled Box button ' .
Note To draw asquare Filled Box instead of arectangular
Filled Box, press and hold the Shift key while you click and

drag.
Freestyle Click, release mouse button, then drag to draw an entity.

From the toolbar, click the Freestyle button £ .
Note You can create a contiguous or non-contiguous
freestyle entity.

See Creating a Non-contiguous Freestyle Entity
Creating a Contiguous Freestyle Entity

Highlight Click and drag to highlight a boxed area.

From the toolbar, click the Highlight button | = .

Note The highlighted box will be filled with atransparent
color.

Leader Click and drag to draw aleader.

From the tool bar, click the Leader button & .

Note To forcealine segment in aLeader entity to be
aligned to the closer axis, horizontal or vertical axis, hold the
Shift key while you click and drag for that line segment.

See Adding a Leader
Forcing a Line Segment
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Option Description

Line Click and drag to draw aline.

From the toolbar, click the Line button s

Note Todraw aline and forceit to be aligned to the closer
axis, horizontal or vertical, press and hold the Shift key
whileyou click and drag.

See Forcing aLine Segment
Note Add anote to the Markup.

From the toolbar, click the Note button = .
See Adding a Note

OLE Insert anew or existing OLE entity to the Markup.
See Creating an OLE Markup Entity
Polyline Click and drag to draw a polyline.

From the toolbar, click the Polyline button .+ .

Note To force aline segment in a Polyline entity to be
aligned to the closer axis, horizontal or vertical, press and
hold the Shift key while you click and drag for that line
segment.

See Forcing aLine Segment

Signoff Create an approval stamp containing information about the
Markup author, date and time of creation.

From the toolbar, click the Signoff button f .
See Creating Signoff Entities

Symbol Click and drag a symbol to the Markup.

From the toolbar, click the Symbol button b .
See Creating Symbols

Text Add text to the Markup.
From the toolbar, click the Text button T .
See Adding Text
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Creating a Non-contiguous Freestyle
Entity

1 Select Entities > FreeStyle from the Markup menu.

Note You can aso click the Freestyle button £ from the Markup toolbar.
Click a point on the drawing where you want to start the freestyle entity.
Move the cursor to create the freestyle entity.

Click a point on the drawing where you want to interrupt the freestyle entity.
Click another point on the drawing where you want to restart the freestyle
entity.

Note You can interrupt the freestyle entity as many times as you like by
repeating steps 4 and 5.

6 Right-click to end the freestyle entity.

abhwN

Creating a Contiguous Freestyle Entity
1 Select Entities > FreeStyle from the Markup menu.

Note You can aso click the Freestyle button #. on the Markup toolbar.
Click a point on the drawing where you want to start the freestyle entity.
3 Movethe cursor to create the freestyle entity.

4  Right-click to end the freestyle entity.

N

Adding a Leader
1 Select Entities > Leader from the Markup menu.

Note You can aso click the Leader button =2, from the Markup toolbar.
Click a point on the document where you want the leader to start.
3 Movethe cursor to draw the leader.
Note To draw aleader and forceit to be aligned to the closest axis, vertical
or horizontal, hold the Shift key while moving the cursor.
4  Todraw aleader with multiple line segments, repeat steps 2 and 3 as often as
you like. You can click, then drag as often as you like.
5 Right-click to end the leader.
The Text dialog appears.
6 Tochangethefont, click Font. The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the checkbox beside the font style(s).

N
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Type the text that you want to attach to the leader, then click OK.

7 Right-click outside the text area to complete the modification.
The leader appears on the drawing and in the Markup Navigation Tree.
Note To edit the leader text, double-click the leader in the Markup
Navigation Tree or in the workspace to open the Text dialog.

See Also Forcing a Line Segment

Forcing a Line Segment to Become
Horizontal or Vertical

You can draw aline segment and force it to be aligned with the closer axis,
horizontal or vertical. You can also take an existing line segment and have it
align with the closer axis. The types of line segmentsthat you can align arelines,
line segments of leaders and polylines, and measure entities.

Note This procedure only works for measure entities that are drawn using Free
snap.

1 Todraw and force aline segment, press and hold the Shift key while you
click and drag for that line segment.
To force an existing line segment, click and hold the left mouse button on
the line segment, then press and hold the Shift key.

2 When you seethat the line segment is horizontal or vertical, release the left
mouse button, then release the Shift key.

Adding Text

With AutoVue, you can add text entitiesto a markup.
1 Select Entities > Text from the Markup menu.

Note You can also click the Text button “I* from the Markup toolbar.

2 Click apoint on the drawing where you want to add text.
The Text dialog appears.
3 Tochangethefont, click Font. The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the checkbox beside the font style(s).
Type the text that you want to add, then click OK.
4 Right-click outside the text area to complete the modification.
The text appears on the drawing and in the Markup Navigation Tree.
5 Tomove the text box click and drag it.
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6 Click and drag the frame handles to enlarge the text box.
Note To edit text, double-click the text in the Markup Navigation Tree
or in the workspace to open the Text dialog.

Adding a Note

You can attach longer comments and notes to a markup with AutoVue's Markup
Control Note Editor. A note is represented by a standard size graphical symbol
labelled Note. To read the text inside, double-click the entity to open it or move
the mouse over the entity to display the tooltip.

1 Select Entities > Note from the Markup menu.

Note You can also click the Note button = from the Markup toolbar.
2 Click apoint on the document where you want to insert the note.
The Markup Control Note Editor dialog appears.
Enter the text that you want in the note.
To modify the text, select Formatting and the format you want to apply.
Select File > Information.
The Note Information dialog appears.
Enter aName, Author and Key Words for the note, then click OK.
6 Closethe Markup Control Note Editor dialog.
The note appears on the drawing and in the Markup Navigation Tree.
Right-click outside the note area to complete the modification.
8 Tomove the note, click and drag it.

g b~ w

~

Note To edit anote, double-click the note symbol ﬁ in the workspace.

You can aso select the notein the Markup Navigation Tree, right-click
and select Edit, or double-click the note.

Viewing the List of Notes

You can view alist of the notes you added to afile. You can also print the notes
or find a note in the workspace.

1 Select Markup > List Notes from the Markup menu.
The List Notes dialog appears.
2 Tofind anote, select the note from the list and click Go To.
AutoVue zooms into the selected note in the workspace.
Note You can aso select the note from the Markup Navigation Tree,
right-click and select Go To.
3 Toprint anote, select the note from the list.
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Note To print more than one note, press the Shift or Ctrl key while
selecting. To print all the notesin thelist, click Select All.

Click Print. The Note print options dialog appears.

Note To print each selected note on a separate page, select One note per
page.

Configure the print options, then click OK. The selected notes are printed.
Click OK to closethe List Notes dialog.

Creating Signoff Entities

The signoff entity isan approval stamp containing information about the Markup
author, date and time of creation. You create a signoff entity when the Markup
fileisfinalized.

Note If you create an entity after the Signoff, the signoff entity disappears. The
Signoff should be the last entity added to a Markup.

1

Select Entities > Signoff from the Markup menu.

Note You can aso click the Signoff button Vad on the Markup toolbar.
Click and drag to create a box on the drawing where you want the signoff.
The Signoff dialog appears displaying details of the signoff.

Click OK.

The signoff entity is created and appears on the drawing and in the Markup
Navigation Tree.

Rescinding the Signoff

You can rescind a signoff on a drawing.

1

Double-click the Signoff on the drawing or from the Markup Navigation
Tree.

Note You can aso select Entities > Signoff from the Markup menu.
The Signoff dialog appears.

Click Rescind.

The signoff disappears from the drawing but remainsin the Markup
Navigation Tree.

Note To have the signoff re-appear on the drawing, double-click it from the
Markup Navigation Tree, then click Approve in the Signoff dia og.
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Viewing the History of a Signoff

1 Double-click the Signoff on the drawing or from the Markup Navigation
Tree.
Note You can aso select Entities > Signoff from the Markup menu.
The Signoff dialog appears.

2 Click History.
The Signoff History dialog appears displaying the author, date and time
the signoff was created.

3 Click OK.

4  Click Cancel to close the Signoff dialog.

Creating an OLE Markup Entity

In AutoVue, you can insert anew or an existing OLE object.
1 Select Entities > OLE from the Markup menu.

Note You can aso click the OLE button on the Markup toolbar.

2 Click and drag to select the area on the drawing where you want to insert an
OLE object.
The Insert Object dialog appears.

3 Click Create New toinsert a new object and select the Object Type from
thelist.

4  Click Create from File to insert an existing object and enter the filename
and path or click Browse to locate thefile.

5 Todisplay the object asanicon, click Display As Icon.
Theicon that the object will be displayed as appears and the Change Icon
button.
To changetheicon, click Change Icon. The Change Icon dialog
appears.
Select theicon that you want to change to, then click OK.
Note The Change Icon button isonly enabled if icons are available.

6 Click OK inthelnsert Object dialog.
The object appears on the Markup.
Note If you selected Display as Icon, the selected icon appears as the
object on the Markup.

7 Select Entities > OLE to exit or right-click in the workspace.
Note To open the object, double-click on it.
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Symbols

A Symbol isagraphical entity, such as acompany logo. Before a graphic entity
can be used as a symboal, it must be added to a Symbol Library.

In AutoVue, you can create a Symbol Library and add symbolsto it. You can
also add or remove symbols from existing libraries.

Adding a Symbol

A symbol isagraphical entity, such asacompany logo. With AutoVue, you can
add a symbol to a markup.

1 Select Entities > Symbol from the Markup menu.
The Symbols dialog appears.

Note You can aso click the Symbol button = inthe Markup toolbar.
Click the Symbols tab.
3 Fromthe Symbol Library drop-down list, select the library from which
you want to select a symbol.
The symbols appear for the selected library.
4  Click Isotropic if you want to scale the symbol proportionately.
Click Anisotropic if you want to scale the symbol disproportionately.
5 Drag the symbol onto the workspace.
The symbol appears on the drawing and in the Markup Navigation Tree.
Note To add more symbols, repeat steps 3 to 5.
6 Closethe Symbols dialog.

N

Creating a New Symbol Library

1 Select Entities > Symbol from the Markup menu.
The Symbols diaog appears.

Note You can aso click the Symbol button =k in the Markup toolbar.

Click the Libraries tab.

3 Click Create.

The Symbol Library dialog appears.

Enter the Library Name, Description, Author and Keywords.

To add a symboal to the library, click Add.

The Open dialog appears.

6 Browseto locate the symbol you want to add, then click Open.
Thefile appearsin the Symbol Files list.

N

(SN
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Note To add more symbols, repeat steps 4 and 5. To remove a symbol,
select the symbol and click Remove.
7 Closethe Symbols dialog.

See Also Adding a Symbol to a Library

Editing a Symbol Library Information
Deleting a Symbol Library

Adding a Symbol to a Library

1 Select Entities > Symbol from the Markup menu.
The Symbols dialog appears.

Note You can aso click the Symbol button = inthe Markup toolbar.
Click the Symbols tab.
3 Fromthe Symbol Library drop-down list, select the library that you want
to add a symbol.
4 Click Add Symbol.
The Symbol Definition dialog appears.
Enter the Source file, Symbol Name and Description or click Browse
to locate the sourcefile.
5 Click OK.
The symbol appears under Drag and drop a Symbol onto AutoVue in
the Symbols dialog.
Note To add more than one symbol, repeat steps 4 and 5.
6 Closethe Symbols dialog.

N

Deleting a Symbol from a Library

1 Inthe Symbols diaog, click the Symbols tab.

2 Fromthe Symbol Library drop-down list, select the library which contains
the symbol you want to delete.

3 The symbols appear in the Drag and drop a Symbol onto AutoVue
area.

4  Select the symbol you want to delete, then click Delete.
The symbol disappears from the library.

5 Closethe Symbols dialog.
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Editing Symbol Library Information

1 Select Entities > Symbol from the Markup menu.
The Symbols dialog appears.

Note Youcanasoclick the =& button in the Markup toolbar.

Click the Libraries tab.

3 Fromthe Symbol Libraries list, select the library that you want edit.
4  Click Edit.

The Symbol Library dialog appears.

Edit the information.

Click OK.

7 Closethe Symbols dialog.

N

o Ol

Deleting a Symbol Library

1 Inthe Symbols diaog, click the Libraries tab.
2 Fromthe Symbol Libraries list, select the library that you want to delete.
3 Click Delete.
Thelibrary disappears from the list and from the Symbol Library drop-
down list under the Symbols tab.
4 Closethe Symbols dialog.

Working with Hyperlinks

A hyperlink isalink between the current file and the new file or application. You
can create hyperlinks within your current file so that your files and applications
outside AutoVue are only a click away. The main benefit of adding hyperlinksto
afileisthat you can gather al files of related information into one file with the
files kept separate. In other words, the files may be accessible from one location
but the information is referenced, not duplicated. This ensures a manageable file
size when loading. If changes need to be made to alinked file, they need to be
done in one location — to the linked file itself.

Creating a Hyperlink

1 Select Markup > Hyperlink > Establish from the Markup menu.

2 Click apoint on the document where you want to place the hyperlink.
The Establish Hyperlink dialog appears.

3 EnteralLink Name.
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Enter aLink Description (optional).

From the Link to drop-down list, select the type of link.

For example, Data File opens adocument file, whereas Application open

an application other than AutoVue.

The link change according to the selected link.

6 Click Browse to locate the Data file or application and its path that you
want to link to or enter the information manually.

Note For Application, ensure that the executable file is selected. For
example, mspaint.exe.

7 To change the hyperlink icon, click Set Icon. The Open dialog appears.
Enter the file name or browse to locate the bitmap file that you want to use
astheicon, then click Open.

8 Click OK inthe Establish Hyperlink dialog.

The hyperlink appears on the Markup.

Note If you changed theicon, the selected icon appears as the hyperlink on

the Markup.

(G2 3

Firing a Hyperlink

1 Tofireahyperlink, double-click on it from the workspace.
The hyperlink file opens in the window you selected in the Establish
Hyperlink dialog.
Note You can aso fire ahyperlink by selecting it, then right-clicking and
selecting Hyperlinks > Fire from the pop-up menu or selecting Hyperlink
> Fire from the Markup menu.

Editing a Hyperlink

1 IntheMarkup Navigation Tree or from the workspace, select the
hyperlink that you want to edit.

2 Select Markup > Hyperlink > Edit from the Markup menu.
The Establish Hyperlink dialog appears.
Note You can right-click a hyperlink in the Markup Navigation Tree
and select Edit from the pop-up menu.

3 Edit the information that you want.

4 Click OK.
The changes are saved.

Cimmetry Systems Corp.



AutoVue 195

Deleting a Hyperlink

1

2

Inthe Markup Navigation Tree or from the workspace, select the
hyperlink that you want to delete.

Select Markup > Hyperlink > Break or Markup > Delete from the
Markup menu.

The hyperlink is deleted from the file.

Note You can aso delete a hyperlink by right-clicking it in the Markup
Navigation Tree and selecting Delete from the pop-up menu.

Viewing List of Hyperlinks

1

Select Markup > Hyperlink > List from the Markup menu.

The List Hyperlinks dialog appears listing the hyperlinks.

Note You can right-click in the workspace and select Hyperlinks > List
from the pop-up menu.

Note You can fire ahyperlink by selecting the hyperlink and clicking Fire.
Click OK.

Viewing History of a Hyperlink

AutoVue lets you view information about a hyperlink’s path. From afilethat is
launched from a hyperlink, you can see what document invoked the hyperlink.

1

2

From the hyperlink file, select File > Markup from the AutoVue main
menu.

Select Markup > Hyperlink > History from the Markup menu.

The Hyperlink History dialog appears listing the path linking the
hyperlink file to the file that invoked the hyperlink.

To jump to the file where you fired the hyperlink from, select the path in the
Hyperlinks History dialog.

Click Jump to.

Note You can aso go back by right-clicking in the hyperlink file and
selecting Go Back from the pop-up menu.
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Creating 2D Non-vector Markup
Measure Entities

When marking up 2D non-vector files, in addition to all the markup options
available for 2D files, you can create markup measure entities. The measure
options in Markup mode work a bit differently than in View mode. For
information on marking up 2D files, see Marking Up 2D Files.

When measuring in Markup mode, the specified measurement lines and values
are displayed on the current active markup layer as entities. These entities can be
moved, resized, hidden or deleted. You can also modify the font of a measure
entity, align a“free snap” measure entity to the horizontal or vertical axis, aswell
as add units of measure and symbols to a measurement and have them appear on
the drawing.

Note When you are creating a markup entity, you can press Escape to cancel.
M easure options vary between vector and non-vector files. For vector files,
AutoVue provides the option to “snap” to fixed points on the drawing. For non-
vector files, you can only “free snap”.

In Markup mode, you can choose from several measure options to create markup
measure entities. You can access the measure options from the Analysis >
Measure menu. The options are:

Option Description
Angle Measure the angle between selected points.
From the toolbar, click the Angle button .
Arc Measure an arc entity.
From the toolbar, click the Arc button .
Area Mesasure a selected area.

From the toolbar, click the Area button .

Distance Measure the distance between two points.

From the toolbar, click the Distance button .
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Measuring Distance

Use the Distance option to measure the distance between two specific points.

Note If you want a markup entity for the measurement, you must ensure that
Add Distance is selected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Distance button on the Markup toolbar.

Click the Distance tab.
3 Fromthe Measured Distance Units drop-down list, select the unit in
which you want to measure the distance.

N

4  Click apoint on the drawing to define the starting point.
5 Click another point on the drawing to define the end point.

The measured line path appears as an entity on the current active markup.
6 Dragto move the measured line path.

7  Click on the measured line path.
The measurement and unit appear as an entity on the current active markup
layer. The measured distance, Delta-X and Delta-Y appear in the
Measurement dialog.

8 Click and drag the frame handles to change the size of the box.
Note Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Measuring Cumulative Distance

Use the Cumulative Distance option to measure the distance aong a path of
multi-faceted (adjoining) points.

Note If you want a markup entity for the measurement, you must ensure that
Add Distance is selected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Distance button on the AutoVue toolbar.

Click the Distance tab.

3 Fromthe Measured Distance Units drop-down list, select the unit in
which you want to measure the distance.

4  Select Cumulative.

N
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Click a paint on the drawing to define the starting point.

6 Continue clicking points along the path that you want to measure.
Each point isjoined by aline.

7 Right-click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the
current active markup layer. The cumulated measured distance, Delta-X and
DeltaY appear in the Measurement dialog.

8 Click and drag the frame handles to change the size of the box.
Note Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Calibrating Distance

1 Measure the distance between two points or measure cumulative distance.
See Measuring Distance

2 IntheMeasurement dialog, click Calibrate.
The Distance Calibration dialog appears displaying the measured
distance.

3 Inthe Distance drop-down list, select the unit to which you want to
calibrate the distance.

4 Click Calibrate to and enter avalueif you want to calibrate the distance to
avalue.
Click Set Factor and enter avalue if you want to calibrate the distance by a
factor.

5 Click OK.
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Measuring Area

Use the Area option to measure the area and perimeter of aregion.

Note If you want a markup entity for the measurement, you must ensure that
Add Area is selected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.The Measurement
dialog appears.
Note You can aso click the Area button on the Markup toolbar.

2 Click the Area tab.
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From the Measured Area Units drop-down list, select the unit in which
you want to measure the area.

From the Perimeter Units drop-down list, select the unit in which you
want to measure the perimeter.

To cumulate aNet Area Result of different areas, select Add in the
Measurement dialog.

To subtract an areafrom the Net Area Result, select Subtract.

Select Clear to clear the Net Area Result.

Click a point on the drawing to define the starting point.

Continue clicking points on the drawing to define the area you want to
measure.

Each point isjoined by aline.

Right click to complete the measurement.

The measured line path, measurement and unit appear as an entity on the
current active markup layer. The area and perimeter measurements appear in
the Measurement dialog.

Click and drag the frame handles to change the size of the box.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Measuring an Angle

Use the Angle option to measure the angle between points on a drawing.

Note [f you want a markup entity for the measurement, you must ensure that
Add dimensions isselected in the Measurement dialog.

1

N

Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Angle button ﬁ/m—ﬂ on the Markup toolbar.

Click the Angle tab.

From the Measured Angle Units drop-down lit, select the unit in which
you want to measure the angle.

Click points on the drawing to define the angle you want to measure.

The points are joined by angle arms with an arc connecting them.

Click again to complete the measurement.

The measured line path, angle measurement and unit appear as an entity on
the current active markup layer and in the Measurement dialog.

Click and drag to change the size of the arc.
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7  Click and drag the frame handles to change the size of the box.
Note Click Reset to take another measurement.
8 Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Measuring an Arc

Use the Arc option to define an arc in the drawing and measure its radius, center
and diameter.

Note [f you want a markup entity for the measurement, you must ensure that
Add Radius or Add Diameter is selected in the Measurement dialog.

1 Sdlect Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Arc button on the Markup toolbar.

Click the Arc tab.

3 Fromthe Arc Info drop-down list, select the unit in which you want to
measure the arc.

4 Fromthe Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.

5 Select Add Radius if you want to measure the radius of the arc.
Select Add Diameter if you want to measure the diameter of the arc.

6 Click points on the drawing to define the arc you want to measure.
The points are joined by an arc.

7  Click again to complete the measurement.
The measured line path, arc measurement and unit appear as an entity on the
current active markup layer and in the Measurement dialog.

8 Click and drag the box anywhere on the drawing.
Click and drag the frame handles to change the size of the box.
Note Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

N

Calibrating an Arc

1 Measurean arcinthedrawing.
See Measuring an Arc
2 IntheMeasurement dialog, click Calibrate.
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The Distance Calibration dialog appears displaying the measured
distance.

3 Fromthe Distance drop-down list, select the unit to which you want to
calibrate the distance.

4  Click Calibrate to and enter avalueif you want to calibrate to avalue.
Click Set Factor and enter avalueif you want to calibrate by afactor.

5 Click OK.
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Creating 2D Vector Markup
Measure Entities

When marking up 2D vector files, in addition to al the markup options available
for 2D files, you can create markup measure entities. The measure optionsin
Markup mode work slightly different than in View mode. For information on
marking up 2D files, see Marking Up 2D Files.

M easure options vary between vector and non-vector files. For vector files,
AutoVue provides the option to “snap” to fixed points on the drawing. For non-
vector files, you can only “free snap”.

When measuring in Markup mode, the specified measurement lines and values
are displayed on the current active markup layer as entities. These entities can be
moved, resized, hidden or deleted. You can also modify the font of a measure
entity, align a“free snap” measure entity to the horizontal or vertical axis, aswell
as add units of measure and symbols to a measurement and have them appear on
the drawing.

Note When you are creating a markup entity, you can press Escape to cancel.

In Markup mode, you can choose from several measure options to create markup
measure entities. You can access the measure options from the Analysis >
Measure menu. The options are;

Option Description

Angle Measure the angle between selected points.

=}
From the toolbar, click the Angle button .
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Option Description
Arc Measure an arc entity.
From the toolbar, click the Arc button .
Area Mesasure selected area.
From the toolbar, click the Area button .
Distance Measure the distance between two points.

oo
From the toolbar, click the Distance button | @ |,

2D Vector Snapping Modes

The Snapping Modes available allow you to click to precise geometrical
points on adrawing. For example, if you select Snap to end-point and you
move the cursor over an end-point of aline, the end-point will be highlighted by

a snap box.
The Snapping modes alow you to snap to the mid, center and end-points of
an entity:
Button  Snap to Description
Q\ End-point Geometric snap mode where a snap box appears
when moving the cursor near alinear component’s
end point.
Mid-point Geometric snap mode where a snap box appears
\ when moving the cursor near the halfway point of a
linear component.
Center-point Geometric snap mode where a snap box appears
@ when moving the cursor near the center of an
liptical component.
Free snap Allow snapping at any point on the drawing.
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Measuring Distance

Use the Distance option to measure the distance between two specific points.

Note [f you want a markup entity for the measurement, you must ensure that
Add Distance is selected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Distance button on the Markup toolbar.

Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.
See 2D Vector Snapping Modes
4  From the Measure Distance Units drop-down list, select the unit in
which you want to measure the distance.
Click a paint on the drawing to define the starting point.
6 Click another point on the drawing to define the end point.
The measured line path appears as an entity on the current active markup.
Drag to move the measured line path.
8 Click on the measured line path.
The measurement and unit appear as an entity on the current active markup
layer. The measured distance, Delta-X and Delta-Y appear in the
Measurement dialog.
9 Click and drag the frame handles to change the size of the box.
Note Click Reset to take another measurement.
10 Click Close to closethe Measurement dialog.

See Also Modifying Measurement Markup Entities

N
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Measuring Cumulative Distance

Use the Cumulative Distance option to measure the distance along a path of
multi-faceted (adjoining) points.

Note If you want a markup entity for the measurement, you must ensure that
Add Distance is selected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Distance button on the Markup toolbar.
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Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.
See 2D Vector Snapping Modes
4  Fromthe Measured Distance Units drop-down list, select the unit in
which you want to measure the distance.
Select Cumulative.
Click a point on the drawing to define the starting point.
7  Continue clicking points along the path that you want to measure.
Each point isjoined by aline.
8 Right-click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the
current active markup layer. The cumulated measured distance, Delta-X and
Delta-Y appear in the Measurement dialog.
9 Click and drag the frame handle to change the size of the box.
Note Click Reset to take another measurement.
10 Click Close to closethe Measure Distance dialog.

See Also Modifying Measurement Markup Entities

o Ol

Calibrating Distance

1 Measure the distance between two points or measure cumulative distance.
See Measuring Distance

2 Inthe Measurement dialog, click Calibrate.
The Distance Calibration dialog appears displaying the measured
distance.

3 Inthe Measured Distance drop-down list, select the unit to which you
want to calibrate the distance.

4  Click Calibrate to and enter avalue if you want to calibrate the distance to
avaue.
Click Set Factor and enter avalueif you want to calibrate the distance by a
factor.

5 Click OK.
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.
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Measuring Area

Use the Area option to measure the area and perimeter of aregion.

Note [f you want a markup entity for the measurement, you must ensure that
Add Area is selected in the Measurement dialog.

1

N

10

1

Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Area button on the Markup toolbar.

Click the Area tab.

Select Between Points if you want to measure the area between points on
adrawing. Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See 2D Vector Snapping Modes

Select Shape if you want to measure the area of a predefined shape on the
drawing. Snapping Modes are disabled.

From the Measured Area Units drop-down list, select the unit in which
you want to measure the area.

From the Perimeter Units drop-down list, select the unit in which you
want to measure the perimeter.

To cumulate a Net Area Result of different areas, select Add inthe
Measurement dialog.

To subtract an areafrom the Net Area Result, select Subtract.

Select Clear to clear the Net Area Result.

If you selected Between Poaints, click points on the drawing to define the
area, then right click to complete the measurement.

Each point isjoined by aline. The measured line path, measurement and unit
appear as an entity on the current active markup layer. The areaand
perimeter measurements appear in the Measurement dialog.

If you selected Shape, click the edge of a predefined shape on the drawing.
The shape is highlighted. The measured line path, measurement and unit
appear as an entity on the current active markup layer. The areaand
perimeter measurements appear in the Measurement dialog.

Click and drag the frame handles to change the size of the box.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities
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Measuring an Angle

Use the Angle option to measure the angle between points on a drawing.

Note [f you want a markup entity for the measurement, you must ensure that
Add dimensions isselected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Angle button on the Markup tool bar.

2 Clickthe Angle tab.
Select From 3 Points if you want to measure the angle between three
points. Snapping Modes are enabled.
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.
See 2D Vector Snapping Modes
3 Select Between 2 lines if you want to measure the angle between two
lines. Snapping Modes are disabled.
4  Fromthe Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.
5 If you selected From 3 Points, click three points on the drawing to define
theangle.
If you selected Between 2 Lines, click two lines on the drawing to define
theangle.
Angle arms appear with an arc connecting them.
6 Click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the
current active markup layer. The measured angle appearsin the
Measurement dialog.
Click and drag to change the size of the arc.
Click and drag the box anywhere on the drawing.
9 Click and drag the frame handles to change the size of the box.
Note Click Reset to take another measurement.
10 Click Close to closethe Measurement dialog.

See Also Modifying Measurement Markup Entities

o
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Measuring an Arc

Use the Arc option to define an arc in the drawing and measure its radius, center
and diameter.

Note To create amarkup entity for the measurement, you must ensure that Add
Radius or Add Diameter is selected in the Measurement dialog.

1

N

10
1

12

Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Arc button on the Markup toolbar.

Click the Arc tab.

Select From 3 Points if you want to measure the arc between three points.
Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See 2D Vector Snapping Modes

Select Arc Entity if you want to measure a predefined arc. Snapping
Modes are disabled.

From the Arc Info drop-down list, select the unit in which you want to
measure the distance.

From the Measure Angle Units drop-down list, select the unit in which
you want to measure the angle.

Select Add Radius if you want to measure the radius.

Select Add Diameter if you want to measure the diameter

If you selected From 3 Points, click three points to define the arc, then
click to complete the measurement

The points are joined by an arc.

If you selected Arc Entity, click the edge of the arc that you want to
measure. The arc is highlighted.

Click to complete the measurement.

The measured line path, measurement and unit appear as an entity on the
current active markup layer. The measurements for center point coordinates,
radius, diameter, arc length, start and end of angle and sweep appear in the
Measurement dialog.

Click and drag the box anywhere on the drawing.

Click and drag the frame handles to change the size of the box.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities
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Calibrating an Arc

1 Measurean arcinthe drawing.
See Measuring an Arc
2 Inthe Measurement dialog, click Calibrate.
The Radius Calibration dialog appears displaying the measured distance.
3 FromtheMeasured Rad. drop-down list, select the unit to which you want
to calibrate the distance.
4 Click Calibrate to and enter avalueif you want to calibrate to avalue.
Click Set Factor and enter avalueif you want to calibrate by afactor.
5 Click OK.
The calibration result appears in the Measurement dialog.
6 Click Close to close the Measurement dialog.

Creating EDA Markup Measure
Entities

When marking up EDA files, in addition to all the markup options available for
2D files, you can create markup measure entities. The measure optionsin
Markup mode work slightly different than in View mode. For information on
marking up 2D files, see Marking Up 2D Files.

Note When you are creating a markup entity, you can press Escape to cancel.

When measuring in Markup mode, the specified measurement lines and values
are displayed on the current active markup layer as entities. These entities can be
moved, resized, hidden or deleted. You can also modify the font of a measure
entity, align a“free snap” measure entity to the horizontal or vertical axis, aswell
as add units of measure and symbols to a measurement and have them appear on
the drawing.

AutoVue provides the option to “snap” to geometrical or electrical points on the
drawing.
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In Markup mode, you can choose from several measure options to create markup
measure entities. You can access the measure options from the Analysis >
Measure menu. The options are;

Option Description
Angle Measure the angle between selected points.
From the toolbar, click the Angle button .
Arc Measure arc entity.
From the toolbar, click the Arc button .
Area Mesasure a selected area.

From the toolbar, click the Area button .
Distance Measures the distance between two points.

From the toolbar, click the Distance button .
Minimum Distance M easure the minimum distance between entities.

From the tool bar, click the Minimum Distance button .

EDA Snapping Modes

The Snapping Modes allow you to click to precise geometrical or electrical
points. For example, when you select Snap to pin, movethe cursor over the pin
you want to select until the pin is highlighted, then click. Highlight and click a
second pin to measure the distance between them.

The Snapping Modes allow you to snap to the mid, center and end-points of an
entity, aswell asapin, via, and symbol:

Button  Snap to Description
End-point Geometric snap mode where a snap box appears
a.‘ when moving the cursor near the component’s end
point.
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Button  Snap to Description

Mid-point Geometric snap mode where a snap box appears
\ when moving the cursor near the halfway point of a
linear component.

Center-point Geometric snap mode where a snap box appears
when moving the cursor near the center of an ellipti-
cal component.

Pin Electrical snap mode where a snap box appears
when the cursor touches apin.

Viaorigin Electrical snap mode where a snap box appears
when the cursor touches avia.

Symboal origin Electrical snap mode where a snap box appears
when the cursor touches the entire component.

Free snap Allows snapping at any point on the drawing.

X &8 & ¥ |©

Measuring Distance

Use the Distance option to measure the distance between two specific points.

Note If you want a markup entity for the measurement, you must ensure that
Add Distance is selected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Distance button on the Markup toolbar.
Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.
See EDA Snapping Modes
4  From the Measured Distance Units drop-down list, select the unit in
which you want to measure the distance.
5 Click apoint on the drawing to define the starting point.

N
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Click another point on the drawing to define the end point.

The points are joined by aline. The measured line path appears as an entity
on the current active markup.

Drag to move the measured line path.

Click on the measured line path.

The measurement and unit appear as an entity on the current active markup
layer. The measured distance, Delta-X, Delta-Y and the “ Manhattan
Distance” appear in the Measurement dialog.

Click and drag the frame handles to change the size of the box.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Measuring Cumulative Distance

Use the Cumulative Distance option to measure the distance aong a path of
multi-faceted (adjoining) points.

Note If you want a markup entity for the measurement, you must ensure that
Add Distance is selected in the Measurement dialog.

11

12
13

14
15
16
17

18

19

Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Distance button on the Markup toolbar.

Click the Distance tab.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See EDA Snapping Modes

From the Measured Distance Units drop-down list, select the unit that
you want to measure the distance.

Select Cumulative.

Click thefirst entity to define the starting point.

Continue clicking points along the path that you want to measure.

Each point isjoined by aline.

Right-click to complete the measurement.

The measured line path, measurement and unit appear as an entity on the
current active markup layer. The measured distance, Delta-X, Delta-Y and
the “Manhattan Distance” appear in the Measurement dialog.

Click and drag the frame handles to change the size of the box.

Cimmetry Systems Corp.



212 AutoVue

Note Click Reset to take another measurement.
20 Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Calibrating Distance

1 Measure the distance between two points or measure cumulative distance.

See Measuring Distance

Inthe Measurement dialog, click Calibrate.

3 TheDistance Calibration dialog appears displaying the measured
distance.

4 Inthe Measured Distance drop-down list, select the unit to which you
want to calibrate the distance.

5 Click Calibrate to and enter avalueif you want to calibrate the distance to
avalue.
Click Set Factor and enter avalue if you want to calibrate the distance by a
factor.

6 Click OK.
The calibration result appears in the Measurement dialog.

7 Click Close to close the Measurement dialog.

N

Measuring Minimum Distance

Use the Minimum Distance option to measure the minimum distance between
entities. The avail able entities for snapping are nets, pins, vias and traces.

Note If you want a markup entity for the measurement, you must ensure that
Add Distance is selected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can also click the Minimum Distance button on the Markup
toolbar.
2 Click the Min. Distance tab.

3 Click ﬂ| First Set to select the entities that you want to measure from.
4  Select the Snapping Modes that you want to use for measuring.

See EDA Snapping Modes

Note If you select Net, you cannot select any other type of entity.
5 Click thefirst set of entities on the drawing.
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The entities are highlighted.
Note To clear the last set of entities you selected, click Clear Set.

Click ﬂ| Second Set to select the entities that you want to measure to.
Click the second set of entities on the drawing.

The entities are highlighted in a different color.

From the Measured Min Distance drop-down list, select the unit in which
you want to measure the distance.

Click Zoom to Result, if you want to zoom in on the measured value on
the drawing.

Click Compute.

The minimum distance from the first set of entitiesto the second set is
highlighted by aline. The measured line path, measurement and unit appear
as an entity on the current active markup layer. The measurement, delta-X,
delta-Y and the “Manhattan Distance” appear in the Measurement dialog.
Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Measuring Area

Use the Area option to measure the area and perimeter of aregion.

Note If you want a markup entity for the measurement, you must ensure that
Add Area is selected in the Measurement dialog.

1

N

Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Area button on the Markup toolbar.

Click the Area tab.

Select Between Points if you want to measure the area between points on
adrawing. Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See EDA Snapping Modes

Select Shape if you want to measure the area of a predefined shape on the
drawing. Snapping Modes are disabled.

From the Measured Area Units drop-down list, select the unit in which
you want to measure the area.
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6 Fromthe Perimeter Units drop-down list, select the unit in which you
want to measure the perimeter.

7 Tocumulate aNet Area Result of different areas, select Add in the
Measurement dialog.
To subtract an areafrom the Net Area Result, select Subtract.
Select Clear to clear the Net Area Result.

8 If you selected Between Points, click points on the drawing to define the
area.
Each point isjoined by aline and the measurement appearsin the
Measurement dialog.

9 If you selected Shape, click the edge of a predefined shape on the drawing.
The shape is highlighted.

10 Right-click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the
current active markup layer. The area and perimeter measurements appear in
the Measurement dialog.
Note Click Reset to take another measurement.

11 Click Close to closethe Measurement dialog.

See Also Modifying Measurement Markup Entities

Measuring an Angle

Use the Angle option to measure the angle between points on a drawing.

Note [f you want a markup entity for the measurement, you must ensure that
Add dimensions isselected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Angle button on the Markup toolbar.

Click the Angle tab.
3 Seect From 3 Points if you want to measure the angle between three
points. Snapping Modes are enabled.
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.
See EDA Snapping Modes
4 Select Between 2 lines if you want to measure the angle between two
lines. Snapping Modes are disabled.

N
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From the Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.

If you selected From 3 Points, click three points to define the angle.

If you selected Between 2 Lines, click two lines to define the angle.
Angle arms appear with an arc connecting them.

Right-click to complete the measurement.

The measured line path, measurement and unit appear as an entity on the
current active markup layer. The measured angle appearsin the
Measurement dialog.

Click and drag to change the size of the arc.

Click and drag the box anywhere on the drawing.

Click and drag the frame handles to change the size of the box.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Measuring an Arc

Use the Arc option to define an arc in the drawing and measure its radius, center
and diameter.

Note To create amarkup entity for the measurement, you must ensure that Add
Radius or Add Diameter is selected in the Measurement dialog.

1

N

Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Arc button on the Markup toolbar.

Click the Arc tab.

Select From 3 Points if you want to measure the arc between three points.
Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear al Snapping
Modes click All Off.

See EDA Snapping Modes

Select Arc Entity if you want to measure a predefined arc. Snapping
Modes are disabled.

From the Arc Info drop-down list, select the unit in which you want to
measure the distance of the arc.

From the Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.
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7 Select Add Radius if you want measure the radius.
Select Add Diameter if you want to measure the diameter.

8 If you selected From 3 Points, click three points to define the arc.
The points are joined by an arc.
If you selected an Arc Entity, click an edge of the arc.
The arc is highlighted.

9 Click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the
current active markup layer. The measurements for center point coordinates,
radius, diameter, arc length, start and end of angle and sweep appear in the
Measurement dialog.

10 Click and drag the box anywhere on the drawing.

11 Click and drag the frame handles to change the size of the box.
Note Click Reset to take another measurement.

12 Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Calibrating an Arc

1 Measurean arcinthe drawing.

See Measuring an Arc

Inthe Measurement dialog, click Calibrate.

3 TheDistance Calibration dialog appears displaying the measured
distance.

4  FromtheMeasured Rad. drop-down list, select the unit to which you want
to calibrate the distance.

5 Click Calibrate to and enter avalueif you want to calibrate to avalue.
Click Set Factor and enter avalueif you want to calibrate by afactor.

6 Click OK.
The calibration result appears in the Measurement dialog.

7 Click Close to close the Measurement dialog.

N

Marking up 3D Files

When marking up 3D files, you can attach text or anote, aswell as create markup
measure entities. The measure options in Markup mode work slightly different
than in View mode.

Note When you are creating a markup entity, you can press Escape to cancel.
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3D Snapping Modes

The Snapping Modes available allow you to select or snap to different entity
types on amodel. For example, if you select Vertex, all vertices are highlighted
and when you move the cursor over a vertex, a snap box appears.

The Snapping Modes allow you to snap to vertices, edges, faces, planes and arcs.

Button  Snap to Description
Vertex Vertices are highlighted on the moddl.

E When moving the cursor over avertex, a snap box

appears.
) Edge Edges are highlighted on the model.

LT When moving the cursor over an edge, a snap circle
appears.

E Face Faces are highlighted when you move the cursor
over aface and a snap triangle appears.

Attaching a Note

1

o 01 b~

Select Entities > Note from the Markup menu.
The Attach to dialog appears.

Note You can also click the Note button &I from the Markup toolbar.
Inthe Attach to dialog, click the entity type that you want to attach the note
to.

See 3D Snapping Modes

Select the entity on the model that you want to attach a note to.

The Note dialog appears.

Type the text that you want in the note.

To change the font, select Font and font type.

Close the Note dialog.

The note symbol appears on the entity and in the Markup Navigation
Tree.

Right-click outside the note area to complete the modification.

Note To edit anote, double-click on the note to open the Note dialog.

Note Whenever an entity is attached to a 3D model, the anchor point (the point
at which the entity is attached) is highlighted by a small square. The squareis
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visible only when the anchor point is visible. Thisfeature allows you to precisely
identify the location of the anchor point and whether the associated entities are
visible or hidden.

Attaching Text

1 Select Entities > Text from the Markup menu.
The Attach to dialog appears.

Note You can also click the Text button “E* from the Markup toolbar.
2 IntheAttach to dialog, click the entity type that you want to attach the text.
See 3D Snapping Modes
3 Click the entity on the drawing that you want to attach text.
The Text dialog appears.
4  To changethefont, click Font. The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the font style and type the text that you want to attach, then click OK.
The text appears on the entity and in the Markup Navigation Tree.
5 Right-click outside the text area to complete the modification.
Note To edit text, double-click on the text to open the Text dialog.

Note Whenever an entity is attached to a 3D model, the anchor point (the point
at which the entity is attached) is highlighted by a small square. The squareis
visible only when the anchor point isvisible. Thisfeature allows you to precisely
identify the location of the anchor point and whether the associated entities are
visible or hidden.

Creating 3D Markup Measure
Entities

When marking up 3D files, you can create markup measure entities. The measure
options in Markup mode work slightly different than in View mode.

When measuring in Markup mode, the specified measurement lines and values
are displayed on the current active markup layer as entities. These entities can be
moved, resized, hidden or deleted.

Note When you are creating a markup entity, you can press Escape to cancel.
AutoVue provides the option to “snap” to different entity types on the model.
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In Markup mode, you can choose from several measurement options to create
markup measure entities. You can access the measurement options from the
Analysis > Measure menu. The options are;

Name Description

Angle Measure the precise angle between three vertices or any two
edges, planes or faces.

]
From the toolbar, click the Angle button .

Arc Measure the precise radius, length and angle of any arc and
calculate the center point location.

From the toolbar, click the Arc button .

Distance Measure the precise distance between any two Vertex, Edge,
Midedge, Arc Center or Face.

. . P
From the toolbar, click the Distance button .

Minimum Distance Measure minimum distance between any two Vertex, Edge,
Midedge, Arc Center or Face.

From the toolbar, click the Minimum Distance button .

Note You cannot create a Markup measure entity when
measuring minimum distance.

Edge Length Measure the precise length of a edge.

From the toolbar, click the Edge L ength button .
Note You cannot create a Markup measure entity when
measuring the length of an edge.

Face Surface Measure the precise surface area.

From the toolbar, click the Face Surface button .
Note You cannot create a Markup measure entity when
measuring surface area.

Vertex Coordinates Provide the coordinates of each vertex.

et
From the toolbar, click the Vertex Coordinates button .
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Measuring Distance
Use the Distance option to measure the precise distance between two vertices,
edges, mid-edges, arc centers, faces or any combination of entity types.

Note When measuring the distance between faces, if the faces are parallel,
AutoVue compares the shortest distance between the parallel faces.

Note If you want a markup entity for the measurement, you must ensure that
Add dimensions isselected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Distance button on the Markup toolbar.

Click the Distance tab.
3 Fromthe Measured Distance Units drop-down list, select the unit in
which you want to measure the distance.

N

4  ClicktheFrom arrow to select the entity type that you want to measure
from.

5 Select the Snapping Modes that you want to use for measuring.
See 3D Snapping Modes
All entities of the selected entity types are highlighted on the model.

6 Onthemodel, select the entity you want to measure from.
Note If you want to take more than one measurement from the same
starting point, click Fix Position.

7 Click the To arrow to select the entity type that you want to measure to.
8 Selectthe Snapping Modes that you want to select asthe end point for the
measurement.
All entities of the selected entity types are highlighted on the model.
9 Onthemodel, select the entity you want to measure to.
10 Click again to complete the measurement.
The measured line path appears as an entity on the current active markup.
11 Drag to move the measured line path.
12 Click on the measured line path.
The measurement and unit appear as an entity on the current active markup
layer. The measured distance, Delta-X, Delta-Y and Delta-Z appear in the
Measurement dialog.
13 Click and drag the frame handles to change the size of the box.
Note Click Reset to take another measurement.
14 Click Close to close the Measurement dialog.
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See Also Modifying Measurement Markup Entities

Calibrating Distance

1

N

M easure the distance between to points.

See Measuring Distance

Inthe Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured
distance.

Inthe Measured Distance drop-down list, select the unit to which you
want to calibrate the distance.

Click Calibrate to and enter avalue if you want to calibrate the distance to
avaue.

Click Set Factor and enter avalueif you want to calibrate the distance by a
factor.

Click OK.

The calibration result appears in the Measurement dialog.

Click Close to close the Measurement dialog.

Measuring Minimum Distance

With the Minimum Distance option you can measure the minimum distance
between model parts, aswell as any two points from the selection sets: vertices,
edges, mid-edges, arc centers, faces or any combination of entity types.

Note If you want a markup entity for the measurement, you must ensure that
Add dimensions isselected in the Measurement dialog.

1

Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.

Note You can aso click the Minimum Distance button on the
AutoVue tool bar.
Click the Min. Distance tab.

Click B set 1 point.

Click Entity if you want to measure the distance between model parts.
Snapping Modes are disabled.

Click Geometry if you want to measure the distance between entity types.
Snapping Modes are enabled.

If you selected Entity, select a part or parts on the model.
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The model part(s) appearsin the list under Set 1 and are highlighted on the
model and in the Model Tree.

If you selected Geometry, select the Snapping Modes that you want to
use for measuring.

See 3D Snapping Modes

All entities of the selected entity type are highlighted on the model.

Select the entity or entities on the model.

The selected entities appearsin the list under Set 1 and are highlighted on
the model.

Note To reset aSet, click Clear. To clear itemsfrom a Set, select the
items and press the Delete key. To deselect a part or entity type on the
model, press the Ctrl key and left-click the part or entity type.

Click Set 2 point.

7 Repeat step 5.
The model part appears in the list under Set 2.

8 Fromthe Measured Min Distance Units drop-down list, select the unit
in which you want to measure the distance.

9 Click Compute.
The minimum distance from the first set of entitiesto the second set is
highlighted by aline. The measured line path, measurement and unit appear
as an entity on the current active markup layer. The X, Y and Z coordinates
for Position1 and X, Y and Z coordinates for Position2 appear in the
Measurement dialog.
Note Click Reset to take another measurement.

10 Click Close to closethe Measurement dialog.

See Also Modifying Measurement Markup Entities

»

Measuring an Angle
Use the Angle option to measure the precise angle between three vertices, any
two edges, planes or faces or any combination of entity types.

If you want a markup entity for the measurement, you must ensure that Add
dimensions is selected in the Measurement dialog.

1 Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Angle button % on the Markup tool bar.

Click the Angle tab.
3 Select the Snapping Modes that you want to use for measuring.

N
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See 3D Snapping Modes

All entities of the selected entity types are highlighted on the model.

To measure the angle between an entity type and a plane, select the
checkbox beside Plane, then from the drop-down list select the plane.
From the Measured Angle Units drop-down list, select the unit in which
you want to measure the angle.

On the model, click points to define the angle.

Angle arms appear with an arc connecting them.

Click again to complete the measurement.

The measured line path, measurement and unit appear as an entity on the
current active markup layer. The measurement appearsin the
Measurement dialog.

Drag to change the size of the arc.

Click and drag the frame handles to change the size of the box.

Note Click Reset to take another measurement.

Click Close to close the Measurement dialog.

See Also Modifying Measurement Markup Entities

Measuring an Arc
Usethe Arc option to measure the precise radius, length and angles of any arc on
the model. It also calculates the center point location.

Note [f you want a markup entity for the measurement, you must ensure that
Add dimensions isselected in the Measurement dialog.

1

N

Select Analysis > Measure from the Markup menu.
The Measurement dialog appears.

Note You can aso click the Arc button on the Markup toolbar.

Click the Arc tab.

Select Arc Entity if you want to measure a predefined arc.

All arc and circles are highlighted on the model. Snapping Modes are
disabled.

Select From 3 Points if you want to measure the arc between three points.
Snapping Modes are enabled.

Select the Snapping Modes that you want to use for measuring.

See 3D Snapping Modes

All entities of the selected entity types are highlighted on the model.

From the Arc Info Dist. Units drop-down list, select the unit in which you
want to measure the arc distance.
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6 FromtheAngles Units drop-down list, select the unit in which you want to
measure the angle.

7 If you selected From 3 Points, click three points to define the arc.
The points are joined by an arc.
If you selected Arc Entity, click the edge of an arc.
The arc is highlighted.

8 Click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the
current active markup layer. The measurements for center point coordinates,
radius, diameter, arc length, start and end of angle and sweep appear in the
Measurement dialog.

9 Click and drag the box anywhere on the markup.
Click and drag the frame handles to change the size of the box.
Note Click Reset to take another measurement.

10 Click Close to closethe Measurement dialog.

See Also Modifying Measurement Markup Entities

Calibrating an Arc

1 Measure an arc on the model.

See Measuring an Arc

Inthe Measurement dialog, click Calibrate.

3 The Calibration dialog appears displaying the measured distance.

4  FromtheMeasured Rad. drop-down list, select the unit to which you want
to calibrate the distance.

5 Click Calibrate to and enter avalueif you want to calibrate to avalue.
Click Set Factor and enter avalueif you want to calibrate by afactor.

6 Click OK.
The calibration result appears in the Measurement dialog.

7 Click Close to close the Measurement dialog.

N

Measuring Vertex Coordinates

The Vertex Coordinates option provides the coordinates of vertices on the
model.

1 Select Analysis > Measure from the AutoVue main menu.
The Measurement dialog appears.
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Note You can aso click the Vertex Coordinates button on the
AutoVue toolbar.

2 Click the Vertex tab.
All vertices on the model are highlighted.

3 Double-click the vertex whose coordinates you want to add to the Markup.
The X, Y and Z coordinates appear in atooltip.

4  Select the vertex.
The X, Y an Z coordinates and unit appear as an entity on the current active
markup layer and in the Measurement dialog.

5 Click and drag the box anywhere on the markup.
Click and drag the frame handles to enlarge the box.

6 Toremove the highlighted vertices on the model, click Close in the
Measurement dialog.
Note You can aso remove the highlighted vertices by selecting Analysis
> Measure > Vertex again.

See Also Modifying Measurement Markup Entities
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Printing

With AutoVue, you can print and preview files. Origina files can be printed on
their own or with associated Markups and Overlays. You can also choose which

Markup layers to make visible so that they can print.

With the Batch Print option, you can send alist of filesto print at the same

time.
When printing afile, there are print properties that you can define. The properties
are:
Option Description
Print Define the print options.
See Configuring the Print Options
Margins Define the margin settings.
See Setting the Print Margins
Headers/Footers Define the headers/footers to be included on every page
printed.
See Adding a Header/Footer
Watermark Define the watermark to be included on every page printed.
See Adding a Watermark
Stamps Define the stamp to be included on every page printed.
See Adding a Stamp
Pen Settings Change the thickness assigned to a pen.

See Assigning Pen Settings

Print Options

With the Options tab, you can define print options for the printed file. The

options are:
Option Type Description
Print to File Click to print to file and not to a printer.
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Option Type

Description

Modify

Sets printer properties, such as printer, paper
size, orientation, €etc.

Scaling Fit to page

Factor

Scale

Scales the image to fit on the output page.

Scales the image according to the scaling fac-
tors that you have manually entered in the
input fields.

Note Units can be entered asinches,
millimeters or pixels.

Scales the image according to percentage. You
can select a predefined scaling factor or manu-
ally enter a customer scaling factor.

Note Decimal places are excepted.

Document Pages

Sets the document pagesto print: All, Cur-
rent or Range.

Alignment/Offset

Specifieswhere the drawing will appear on the
print out.

Page Area Extents Prints the extents of the document.

Displayed Prints the area displayed in the View window.

Limits Limits printing to one page when the scaling
options selected causes a single document
page to span over multiple printer pages.
Note Optionisonly enabled when
Current is selected for Document Pages.

Selected Prints the area selected in the View window.

Note Option will only be enabled when
Current is selected for Document Pages.

Forceto Black

Forces all colorsto black.

Output asingle page

Prints file on asingle page.

Print Row Headers

Prints row headers.
Note Optionisonly enabled for
spreadsheets, archive and database files.
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Option Type Description

Print Column Head- Prints column headers.

ers Note Optionisonly enabled for
spreadsheets, archive and database files.

Partial Preview Displays aview of the printer page, highlight-
ing the printable area.

Number of Copies Select the number of copies you want to print

of thefile.

Configuring the Print Options

1

N

Select File > Print from the AutoVue main menu.
The Print Properties dialog appears.

Note You can aso click the Print button & on the AutoVue tool bar.
Click the Options tahb.
Configure the print options.
See Print Options
Configure other print options.
See Adding a Header/Footer
Setting the Print Margins
Adding a Watermark
Adding a Stamp
Assigning Pen Settings
To view apartia view of thefile, click Partial Preview.
The Partial Preview dialog appears.
See Partial Preview of a File
Click OK to print.
The Print dialog appears indicating the document is printing.

See Also Previewing a File Before Printing
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Print Margins

With the Margin tab, you can define the top, bottom, right and left margins for
the printed file. You can define;

Option Description

Margins Set the value for the Left, Top, Right and Bottom
margins.

Minimum Sets the acceptable minimum margins for the selected printer.

Override printer- If selected, overrides the minimum margins for the selected

minimum margins printer.

Units Specify the unit for the margins.

Setting the Margins

1

N

o]

Select File > Print from the AutoVue main menu.
The Print Properties dialog appears displaying the Options tab.

Note You can aso click the Print button &# on the AutoVue tool bar.
Click the Margins tab.
Enter the margin size that you want for Left, Top, Right and Bottom or
click Minimum if you want to set the margins to the minimum acceptable
for the selected printer.
Select the checkbox Override printer-minimum margins if you want to
override the minimum margins set for the printer.
Note When you click Minimum, the minimum margins allowable
automatically appear inthe Margins.
From the Units drop-down list, select the unit in which you want to set the
margins at.
Configure other print options.
See Configuring the Print Options

Adding a Header/Footer

Adding a Watermark

Adding a Stamp

Assigning Pen Settings
To view apartia view of thefile, click Partial Preview.
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The Partial Preview diaog appears.
See Partial Preview of a File
7 Click OK toprint.
The Print dialog appears indicating the document is printing.

See Also Previewing a File Before Printing

Header/Footer

From the Headers/Footers tab of the Print Properties dialog, you can
define the headers and footers that you want to print on every page of the
document. You can enter the text manually or choose from alist of Insert
Codes.

Thelist of insert codes are:

*  %f: Full path of document

*  %v: Document Drive

*  %d: Document Directory

*  %pb: Document Base name

*  %e Document file extension
*  %n: Total document pages

*  %p: Current page number

*  %N: Total tiled-pages

*  %P: Current tile number

e %Y: Date: Year

*  %M: Date: Month

*  %D: Date: Day

*  %W: Date: Day of week

*  %H: Time Hour

*  %U: Time Minute

*  %S: Time: Seconds

*  %r: New line

*  OF: Native Print Settings (Excel)

Note A literal percentage mark is entered manually as %%.

Adding a Header and Footer

Inthe Headers/Footers tab, you can manually enter text or choose from a list
of Insert Codes to appear in the headers and footers. You can also print system
variables.
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N

Select File > Print from the AutoVue main menu.
The Print Properties dialog appears displaying the Options tab.

Note You can aso click the Print button &# on the AutoVue tool bar.
Click the Headers/Footers tab.
Click inthe Left, Center or Right text box to specify where you want the
text to appear in the header and footer, then enter the text.
Note You can have text appear in the Left, Center and Right of a header
and footer.
To Insert Code in the header or footer, click Left, Center or Right, then
select a code from the drop-down list.
For example, if you select %n: Total document pages the total number
of pages for the selected file will appear in the header and footer.
To change the Font, click Font. The Font dialog appears.
Configure the font, then click OK.
Inthe Print Properties dialog, configure other print properties.
See Configuring the Print Options
Setting the Print Margins
Adding a Watermark
Adding a Stamp
Assigning Pen Settings
To view apartia view of thefile, click Partial Preview.
The Partial Preview dialog appears.
See Partial Preview of a File
Click OK to print.
The Print dialog appears indicating the document is printing.

See Also Previewing a File Before Printing

Native Print Settings

You can choose to included predefined headers and footers when printing an
Excel file from AutoVue.

1
2

3

4

From the Print Properties dialog, click the Headers/Footers tab.
Under Headers and Footers, click inside the Left, Center and Right
boxes corresponding to the header or footer position in the origina file.
Select %F: Native Print Settings (Excel) from the Insert Code drop-
down list.

Click OK to print.

The Excdl file's headers and footers are printed.
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Watermarks

With the Watermark tab, you can specify awatermark that will appear on a
printed file. When printing awatermark, it appears transparent on the file
contents. You can choose a horizontally or vertically oriented watermark.

In addition to entering text, you can:

e setthetype, size and style of font
* insert Watermark information
e print system variables

To insert Watermark information, AutoVue provides alist of codes that you can
choose from. These codes are:

*  %f: Full path of document
*  %v: Document Drive

*  %d: Document Directory
*  %pb: Document Base name
*  %e Document file extension
*  %n: Total document pages
*  %p: Current page number
*  %N: Total tiled-pages

e  %P: Current tile number

*  %Y: Date: Year

*  %M: Date: Month

*  %D: Date: Day

*  %W: Date: Day of week

*  %H: Time Hour

*  %U: Time: Minute

*  %S: Time: seconds

*  %r: New line

Note A literal percentage mark is entered manually as %%.

Adding a Watermark

1 Select File > Print from the AutoVue main menu.
The Print Properties dialog appears displaying the Options tab.

Note You can aso click the Print button =3 on the AutoVue tool bar.

Click the Watermark tab.
3 Enter the Watermark Text that you want to appear on thefile.

N
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To insert a code in the watermark, select a code from the Insert Code drop-
down list.
For example, if you select %n: Total document pages, the total number
of pages for the selected file will appear in the Watermark.
Note You can insert more than one code.
To set the orientation of the watermark, click Diagonal, Horizontal or
Vertical.
To change the Font, click Font. The Font dialog appears.
Configure the font, then click OK.
Inthe Print Properties dialog, configure other print properties.
See Configuring the Print Options
Setting the Print Margins
Adding a Header/Footer
Adding a Stamp
Assigning Pen Settings
To view apartia view of thefile, click Partial Preview.
The Partial Preview dialog appears.
See Partial Preview of a File
Click OK to print.
The Print dialog appears indicating the document is printing.

See Also Previewing a File Before Printing

Assigning Pen Settings

From the Pen Settings tab of the Print Properties dialog, you can set the
thickness of the color indices for the print file.

Note AutoVue usesthe default pen color indices of the native document for the
vector file being viewed. You will not be able to change the color assigned to a
pen with AutoVue.

1

N

Select File > Print from the AutoVue main menu.
The Print Properties dialog appears displaying the Options tab.

Note You can aso click the Print button =3 on the AutoVue toolbar.

Click the Pen Settings tab.

Under From/To, select the Color Index that you want to assign a new pen
thickness.

Note To change more than one color indices, pressthe Shift or Ctrl key
while selecting.
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4 From the Units drop-down list, select the unit of measure that you want to
set the thickness.
5 Enter the new thickness.
The new Thickness appears beside the Color Index.
Inthe Print Properties dialog, configure other print properties
7  Configure other print options.
See Configuring the Print Options
Setting the Print Margins
Adding a Header/Footer
Adding a Watermark
Adding a Stamp
8 Toview apartia view of thefile, click Partial Preview.
The Partial Preview dialog appears.
See Partial Preview of a File
9 Click OK toprint.
The Print dialog appears indicating the document is printing.
Note Pen settings are stored in *c2t files. The Current Pen Settings
drop-down list displaysall existing *.c2t filesfor the current file. The default
pen settings are stored in default.c2t and alternate pen settings are stored in
alt.czt.

See Also Previewing a File Before Printing

o

Creating a New Pen Setting

1 Setthethicknessfor the color indices that you want.

See Assigning Pen Settings
2 Click Save As. The Save As dialog appears.

Enter aFile Name with a.c2t extension, then click OK.

The new pen setting appearsin the Current Pen Settings drop-down list.
3 InthePrint Properties dialog, click OK to print.

The Print dialog appears indicating the document is printing.

Deleting a Pen Setting

1 Select the pen setting that you want to delete from the Current Pen
Settings.

2 Click Delete.
The pen setting disappears from the list.

3 Click Cancel to close the Print Properties dialog.
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Partial Preview of a File

The Partial Preview dialog displays the printable area on top of the page area
so that users can have a clear idea of what will be printed.
Note Optionisonly enabled when Current is selected from Document
Pages.
1 Configurethe print properties.
See Configuring the Print Options
Setting the Print Margins
Adding a Header/Footer
Adding a Watermark
Adding a Stamp
Assigning Pen Settings
2 Click Partial Preview inthe Print Properties diaog.
The Partial Print Preview dialog appears.The Partial Preview dialog
highlights the area that will be printed. The Paper size, Printable Area
and Drawing Area are displayed.
3 Click OK to closethe Partial Preview dialog.

See Also Previewing a File Before Printing

Previewing a File Before Printing

You can preview a print copy of the current active file on screen according to
your printer’s capabilities and the print property settings.
1 View thefilein AutoVue.
2 Select File > Print Preview from the AutoVue main menu.
The Print Properties dialog appears.

Note You can aso dlick the Print Preview button £# on the AutoVue
toolbar.
3 Configure the print properties.
See Configuring the Print Options
Setting the Print Margins
Adding a Header/Footer
Adding a Watermark
Adding a Stamp
Assigning Pen Settings
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4 Click OK.
Thefile appearsin Print Preview Mode in the Print Preview window.
Note You can print the file from the Print Preview window by clicking
Print. You can aso zoom in and out of afile, aswell as navigate from one
page to another of a multi-page file.

5 Click Close to close the Print Preview window.

Printing a File

In AutoVue you can print original files along with their Markup files and

selected Markup layers together so that they appear as onefile.

1 Openthefileyou want to print in AutoVue.
To print the associated Markups, open the Markup file(s) you want to print.
If you are printing Markup file(s) and you want to print the visible layers,
select Modify > Markup Layers from the Markup menu, then from the
Markup Layers dialog select the Markup layers you want visible.

2  Select File > Print from the AutoVue main menu.
The Print Properties dialog appears displaying the Options tab.

Note You can aso click the Print button &# on the AutoVue tool bar.
3 Configure the print properties.
See Configuring the Print Options
Setting the Print Margins
Adding a Header/Footer
Adding a Watermark
Adding a Stamp
Assigning Pen Settings
4 Toview apartial view of thefile, click Partial Preview.
The Partial Preview dialog appears.
See Partial Preview of a File
5 Click OK toprint.
The Print dialog appears indicating the document is printing.

See Also Previewing a File Before Printing
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Batch Printing

With the Batch Print option you can send alist of filesto print at the sametime.
You can aso generate a batch by simultaneously opening all thefilesincluded in
the batch print.

1

2

Select File > Batch Print from the AutoVue main menu.
TheBatch Print dialog appears.
To add afileto theList of files to be printed, click Add. The Open
dialog appears.
Enter the File name or browse to locate the file(s) that you want to add,
then click Open.
Thefile(s) appearsin the List of files to be printed.
Note To add morefilesto the list, repeat steps 2 to 4. To remove afile(s),
select the file from the List of files to be printed and click Remove.
Click OK inthe Batch Print dialog.
The Print Properties dialog appears.
Configure the print properties.
See Configuring the Print Options
Setting the Print Margins
Adding a Header/Footer
Adding a Watermark
Adding a Stamp
Assigning Pen Settings
Click OK to print.
The Print dialog appears indicating the document is printing.
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Customizing AutoVue

There are configuration options that allow you to customize the AutoVue work
environment. You can define the type of information copied to the clipboard,
create tools to automate a variety of functions, including creating a hot key or
access key. You can also customize tool bars and thumbnails to display according
to your preferences. You can access the configuration options from the Options
menu.

Defining the Clipboard

With the Clipboard Options you can define the type of information copied to
the clipboard for later transfer to other applications.

The types of information that you can copy for raster, vector, spreadsheet,
document and database files are:

Type Description

DIB The acronym for Device Independent Bitmap and refersto the
hardware information that is used to create a conversion
bitmap.

Bitmap A rectangular array of colors representing a pixel bit map
image.

Palette Refers to color image information.

Metefile A file storing the commands necessary for a Windows

application to recreate a vector format image.
Text Refersto ASCII formatted text.

RTF Acronym for Rich Text Format and refers to the formatting
information found in documents that allow fonts, margins and
tabs to remain in documents.

Include Headings Refersto displaying the row and column titles for databases
and spreadsheets.

To define clipboard options:
1 Select Options > Clipboard from the AutoVue main menu.
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The Clipboard Options dialog appears.

Under the different file types, click the type of information that you want to
copy to the clipboard.

Click OK.

Copying Information

1 Select Edit > Select from the AutoVue main menu.
2 Click and drag to select the area you want to copy.
3 Select Edit > Copy.
Theinformation is copied to the clipboard.
4 Launch the application that you want to copy the information to.
5 Pastetheinformation.
Tools

Tools are shortcuts for commonly repeated tasks. You can create tools to
automate a variety of function such asimporting objects, files and applications
into the user interface; running a script file; connecting AutoVue to Dynamic
Data Exchange (DDE) servers and linking to Dynamic Link Library (DLL)
loads.

Adding a Tools Menu ltem

1

g b~ w

Select Options > Customize Tools from the AutoVue main menu.

The Add Tool Menu Item dialog appears.

Click Add.

The Configure Tools Menu Item dialog appears.

Enter aMenu Item Name.

Click aMenu Item Action.

Click Application to launch an outside application.

Click Script File to launch a script file.

Click DDE Server to send DDE commands to a server application.

Click DLL toinvokeaDLL.

Enter the name and path of the executablefile, or click Browse to locate the
specific file or application.

If you selected Application, click Configure. The Link to Application
dialog appears. Enter the Command Line to launch an application, then
click OK.
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If you selected Script File, click OK.
If you selected DDE Server, click Configure. The Link to DDE dialog
appears. Enter the Topic and Commands, click Start Application, then
click OK.
If you selected DLL Load, click Configure. TheLink to DLL dialog
appears. Enter the Entry Function toinvokeaDLL, then click OK.
Enter aMenu Item Description.
8 Click OK.

The Menu Item appears under Options > Customize Tools.
9 Click OK to closethe Add Tool Menu Item dialog.

~

Creating a Hot Key

1 Select Options > Customize Tools from the AutoVue main menu.
The Add Tool Menu Item dialog appears.
2 Click Add.
The Configure Tools Menu Item dialog appears.
3 Enter an ampersand (&) beforethe Menu Item Name.
For example, if you entered the menu item name &Application. The letter
A after the & will be the hotkey.
4 Click OK.
The menu item appears under Options > Customize Tools with the letter
A underlined.
5 Click OK to closethe Add Tool Menu Item dialog.
Note To activate the hotkey, hold the Alt key while pressing T and then A.

Modifying a Tools Menu Item

1 Select Options > Customize Tools from the AutoVue main menu.
The Add Tool Menu Item dialog appears.

2 Under Menu Contents, select the item that you want to modify.

3 Click Modify.
The Configure Tools Menu Item dialog appears.

4  Make the necessary changes.

5 Click OK.

6 Click OK toclosethe Add Tool Menu Item dialog.

Moving a Tools Menu Item

1 Select Options > Customize Tools from the AutoVue main menu.
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The Add Tool Menu Item dialog appears.

From the Menu Contents list, select the item that you want to move.
3 Click Up or Down to move the item to where you want in the list.

4 Click OK to closethe Add Tool Menu Item dialog.

N

Deleting a Tools Menu Item

1 Select Options > Customize Tools from the AutoVue main menu.
The Add Tool Menu Item dialog appears.
From the Menu Contents list, select the item that you want to delete.
3 Click Delete.

The item disappears from the list.
4 Click OK to closethe Add Tool Menu Item dialog.

N

Customizing Toolbars

In AutoVue, you can customize the toolbars to have them float freely or docked
to the window frame. You can a so change the background color of the toolbars.

1 Select Options > Customize Toolbars from the AutoVue main menu.
The Toolbar Settings dialog appears.

2 Click the checkbox beside the toolbars that you want to display or clear the
checkmark beside the toolbars that you want to hide.

3 Click the Toolbar button size that you want the buttons to appear on the
toolbars.

4 Click OK.
The selected toolbars are changed.

Configuring the Mail Utility

At thetime of installation, AutoVue integrates with MAPI compliant mail
utilities that are installed on your computer, such as Microsoft Outlook.
Electronic mail can then be accessed from within AutoVue, with the option to
send a message only, send a message with links to Markup files or send a
message with copies of Markup files.

The graphical interface and mailing options that are available to you are
determined by the MAPI compliant mail utility you are using. AutoVue
automatically attaches the current activefile to messages when the Mail optionis
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activated. However, Markup files associated with the original file are left for you
to select and attached to your mail message.

To configure the mail utility:

1 Select Options > Configure Mail from the AutoVue main menu.
The Mail Options dialog appears.

2 Fromthe Mail using drop-down list, select the type of MAPI compliant
mail utility you are using.

3 Click the Mailing Preferences that you want.

4  Click OK to close the Mail Options dialog.

Activating the Mail Utility

At thetime of installation, AutoVue integrates with MAPI compliant mail
utilities that are installed on your computer, such as Microsoft Outlook.

From AutoVue, you can access electronic mail with the option to send a message
only, send amessage with links to Markup files or send a message with copies of
Markup files, for more information see Configuring the Mail Utility.
To access electronic mail:
1 Select File > Mail from the AutoVue main menu.

The mail utility installed on your computer is launched.

Note When saving aMarkup file, you can click Notify from the Save or
Save As diaog to launch the mail utility.
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Thumbnaills

Thumbnails allow you to build a visual representation of the entire contents of a
directory in athumbnails folder. Miniature visuals of the thumbnails folder file
contents is created to help you preview files.

Also availableis a generic customized icon that is particularly helpful for
identifying files that are more readily acknowledged by their file type. For
example, aword-processing document located in a directory where the majority
of the files are graphic formats. Asfiles are modified, their thumbnails can be
updated quickly and easily. AutoVue stores thumbnails information in the
avwin/folders directory.

Customizing Thumbnails

You can customize thumbnails to display according to your preferences.

1 Select Options > Configure Thumbnails from the AutoVue main menu.
The Configure Thumbnails dialog appears.
Note You can aso configure thumbnails by selecting Thumbnails >
Configuration from the Thumbnails window.

2 Select the Size in pixels of the thumbnails.
Note You can customize the size of the thumbnails by clicking Custom
and entering avalue.

3 Enter the Space between thumbnails.
Note The space between thumbnails must be between 2 and 20.

4  Click the File Details that you want to display in the thumbnail.

Click Full if you want to display the filename, size, date and time of

creation.

Click Partial if you want to only display the filename.

Click OK.

6 Toclosethe Thumbnails window, select Thumbnail > Exit

Thumbnails or click the Exit Thumbnails button [J .

(3]

Creating a Thumbnail Folder

Note If athumbnailsfolder already exists for the current directory, the
Thumbnails window will appear displaying the thumbnails.

1 Select Options > Display Thumbnails from the AutoVue main menu.
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The New Folder dialog appears.

Note You can aso click the Display Thumbnails button £§ onthe
AutoVue toolbar.

2 Click Create.
AutoVue creates the thumbnails folder for the current directory and the
Thumbnails window appears displaying the thumbnails for that folder.
Note Thismay take afew minutes depending on the size and number of
filesinthefolder. If the thumbnailsfolder istaking to long to create, you can
skip it by clicking Skip inthe New Folder dialog. To resume creating the
folder, select Thumbnail > Update All.

Viewing a Thumbnail Folder

You can display thumbnail folders from View or Markup mode.
Note If athumbnailsfolder does not exist for the current directory, the New
Folder dialog appears with the option to create a new folder.

1 Select Options > Display Thumbnails from the AutoVue main menu.
The Thumbnails window appears.

Note You can aso click the Display Thumbnails button & on the
AutoVue toolbar.
2 Select Thumbnail > Folder.
The Browse for Folder dialog appears.
3 Browseto locate the thumbnails folder that you want to view.
4 Click OK.
The thumbnails for the selected folder appear in the Thumbnails window.
5 Toclosethe Thumbnails window, select Thumbnail > Exit

Thumbnails or click the Exit Thumbnails button [J .

Sorting a Thumbnail Folder

1 Select Options > Display Thumbnails from the AutoVue main menu.
The Thumbnails window appears.

Note You can aso click the Display Thumbnails button g5 onthe

AutoVue toolbar.
2 Select Thumbnail > Folder.
The Browse for Folder dialog appears.
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Browse to locate the thumbnails folder that you want to sort.

Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
Select Thumbnail > Sort and the option that you want to sort by.

Note A checkmark beside the sort option indicates the current sort order.
To sort the thumbnails in ascending or descending order, select Thumbnail
> Sort Order then Ascending or Descending.

To close the Thumbnails window, select Thumbnail > Exit

Thumbnails or click the Exit Thumbnails button [ .

Viewing a Thumbnail

Files are instantly accessible from the Thumbnails window.

1

Select Options > Display Thumbnails from the AutoVue main menu.
The Thumbnails window appears.

Note You can aso click the Display Thumbnails button £§ onthe

AutoVue tool bar.

Select Thumbnail > Folder.

The Browse for Folder dialog appears.

Browse to locate the thumbnails folder that you want to view.

Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
Select the thumbnail that you want to view.

Select Thumbnail > Load File or click the Load File button [BE .
The thumbnail islaunched in the AutoVue workspace.

Note You can aso launch athumbnail by double-clicking on the
thumbnail .

Updating Thumbnails

You can update all the thumbnailsin the current folder or update one or more
thumbnails in the current folder.

1

Select Options > Display Thumbnails from the AutoVue main menu.
The Thumbnails window appears.

Note You can aso click the Display Thumbnails button g5 onthe
AutoVue tool bar.
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2 Select Thumbnail > Folder.
The Browse for Folder dialog appears.
3 Browseto locate the thumbnails folder that you want to view.
4 Click OK.
The thumbnails for the selected folder appear in the Thumbnails window.
5 Select the thumbnail (s) that you want update.
Note To select more than one thumbnail, press the Shift or Ctrl key while
selecting.
6 Select Thumbnail > Updated Selected.
The selected thumbnails are updated in the current folder.
Note To update all thumbnails, select Thumbnail > Update All or click

the Update All button #8 on the Thumbnails tool bar.
7 Toclosethe Thumbnails window, select Thumbnail > Exit

Thumbnails or click the Exit Thumbnails button 3 .

Viewing the Properties of a
Thumbnail

1 Select Options > Display Thumbnails from the AutoVue main menu.
The Thumbnails window appears.

Note You can aso click the Display Thumbnails button §§ on the
AutoVue toolbar.
2 Select Thumbnail > Folder.
The Browse for Folder dialog appears.
3 Browseto locate the thumbnails folder that you want to view.
4 Click OK.
The thumbnails for the selected folder appear in the Thumbnails window.
5 Select the thumbnail that you want to view the properties.
6 Select Thumbnail > Properties.
The Properties dialog appears.
7 Click Close.
8 Toclosethe Thumbnails window, select Thumbnail > Exit

Thumbnails or click the Exit Thumbnails button [3J .
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Converting Thumbnails

1

(0]

Select Options > Display Thumbnails from the AutoVue main menu.
The Thumbnails window appears.

Note You can aso click the Display Thumbnails button £§ onthe
AutoVue toolbar.

Select Thumbnail > Folder.

The Browse for Folder dialog appears.

Scroll to locate the thumbnails folder that you want to print.

Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
Select the thumbnail (s) that you want to convert.

Note To select more than one thumbnail, press the Shift or Ctrl key while
selecting.

Select Thumbnail > Convert.

TheBatch Convert dialog appears.

Customize the conversion options.

See Batch Conversion

Click OK.

To close the Thumbnails window, select Thumbnail > Exit

Thumbnails or click the Exit Thumbnails button [J .

Printing Thumbnails

1

Select Options > Display Thumbnails from the AutoVue main menu.
The Thumbnails window appears.

Note You can also click the Display Thumbnails button & onthe

AutoVue toolbar.

Select Thumbnail > Folder.

The Browse for Folder dialog appears.

Scroll to locate the thumbnails folder that you want to print.

Click OK.

The thumbnails for the selected folder appear in the Thumbnails window.
Select the thumbnail (s) that you want to print.

Note To select more than one thumbnail, press the Shift or Ctrl key while
selecting.

Select Thumbnail > Print.
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The Print Properties dialog appears.
7  Customize the print properties.
See Printing
Click OK.
9 Toclosethe Thumbnails window, select Thumbnail > Exit

Thumbnails or click the Exit Thumbnails button [ .

(0]
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Full Text Extraction

The Full Text Extraction application provides afacility for obtaining all the
textual information from a selected file. This may be used by a search engineto
provide document indexing services. It eliminates duplicates and enables the
search for all type of documents, including CAD.

Note Auto Text Extraction is not available for raster files.

Using the Full Text Extraction
Utlllty

Sdlect File > Tools > Auto Text Extraction from the AutoVue main
menu.
The Automatic Text Extraction dialog appears.
Note You can also openthe Auto Text Extraction dialog by opening the
fileouttext . exe located inthe directory C: \Program
Files\av\avwin.

2 Inthe From text box, enter the path and filename of the file from which the
text isto be extracted.

3 IntheTo text box, enter the path and filename or click Browse to locate the
file to which the text isto be copied.
Note Fileextensionsinclude . txt and . out. The default istext . out
located in the temp directory. If the file does not exist, the file will be
created for you.

4 Click Display Output Contents if you want to preview the extracted text
under Contents.

5 Click Extract.
The path and filename, and the text appearsin the Output Contents.

6 Click Close to closethe Automatic Text Extraction dialog.

CAD Information Extraction

This utility allows users to extract XRef information from a CAD file. Thisis
useful for batch importing AutoCAD, MicroStation and various other types of
CAD filesinto a document management system.

1 SdectFile > Tools > Auto Text Extraction from the AutoVue main
menu.
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The CAD/Doc Text Extraction dialog appears.

2 Inthe From text box, enter the path and filename of the file from which the
text isto be extracted.

3 IntheTo text box, enter the path and filename or click Browse to locate the
file to which the text isto be copied.
Note Fileextensionsinclude . txt and .out. The defaultis text . out
located in the temp directory. If the file does not exist, the file will be
created for you.

4 Click Display Output Contents if you want to preview the extracted text
under Contents.

5 Click Extract.
The path and filename, and the text appearsin the Output Contents.

6 Click Close to closethe CAD/Doc Text Extraction dialog.
Note Examples of integrations can be found in the Integrat directory of the
AutoVue CD.
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Package Files

AutoVue can retrieve files stored in Package File Format and then load them in
AutoVue. The Package File Format includes the basefile, external referencesand
Markups. All the basic Markup capabilities are supported: adding anew Markup
for a basefile, consolidating multiple Markups into a Markup, modifying an
existing Markup and saving it as a new one.

AutoVue provides Package File functionality through a:

»  Package File Creation Tool

*  Markup Import Tool

» Package File DMAPI Component
» PackageFile Library

Package File Creation Tool

When a package fileis created, the base file's identity is obtained, along with the
list of associated files, e.g. Xrefs and Markups. Users have the option to choose
which of the associated filesto include in the output file.

Note The Package File Creation Tool isonly available with Vuelink for
Documentum.

Markup Import Tool

Users have the option of choosing which Markup files to import for a package
file or whether afileto beimported is to keep its default identity or be imported
under another user 1D.

Note Markup Import Tool isonly available with Vuelink for Documentum.

DMAPI Component

The key component in the package file creation facility isa DMAPI component.
This component enables AutoVueto treat package files as DM Ses containing one
viewablefile.
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Viewing

Package files are opened in the same way as ordinary files. Users have access to
all the external references and Markups bundled with the base file. Users have
the option to modify existing Markups or create new ones to be associated with
the packagefile.
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