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Support Information
If you have any questions or require support for AutoVue please contact your 
system administrator. Some customization and maintenance must be done on the 
server side and cannot be implemented on the client machine. If the administrator 
is unable to resolve the issue, please contact Cimmetry Systems, Corp.

Contact Information
If at any time you have questions or concerns regarding AutoVue, call or e-mail 
us.

General inquiries
Telephone:  +1 514 735-3219
Fax:              +1 514 735-6440
E-mail:          info@cimmetry.com 
Web Site:     http://www.cimmetry.com

Sales inquiries
Telephone:  +1 514 735-3219 or 1 800 361-1904
Fax:              +1 514 735-6440
E-mail:         sales@cimmetry.com 

Customer Support
Telephone:  +1 514 735-9941
Web Site:         http;//www.cimmetry.com/support
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Introduction
Cimmetry Systems Corp. has developed a family of products designed to meet all 
levels of business and engineering needs. Collectively, our products provide 
viewing and Markup capabilities and support the visualization of 2D engineering 
and office formats.

AutoVue
AutoVue is a viewing and Markup application that has been developed for both 
business and technical users.
AutoVue is capable of displaying over 450 different file formats without the 
authoring application. Supported file types include text, database, graphic and 
spreadsheet. Even contents of archive files can viewed in AutoVue. Moreover, 
when you view a file you do not need to specify the file type. AutoVue 
automatically detects the type of file you are requesting to view — even files 
with false extensions!

Marking Up Documents
AutoVue has the ability to create markups for all its readable file formats without 
the document's authoring application.  AutoVue creates markups for different 
formats without modifying the original file.
You can attach comments, notes and drawings to any file you display in 
AutoVue. This is called marking up a file, commonly known as annotating or 
redlining. A Markup is an object or entity that you attach to a file. All Markups 
are saved in a separate file called a Markup or a Markup file. However, when 
you display a file with its Markups, the Markups appear to be part of it.
AutoVue provides a variety of flexible, user-friendly entities. To name a few, 
there are circles, clouds, polygons and leaders. You can also attach text to 
entities, insert a note for longer comments or add a symbol such as a company 
logo. In addition, you can create measurement markup entities and hyperlinks 
that link between the current file and other associated files or applications.
Cimmetry Systems Corp.
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Viewing and Exporting File 
Versions Information
From the Help About dialog, you can view the version, build number and date 
of the decoder dll files, as well as export the files into a text file.

Viewing File Versions
1 Select Help > About from the AutoVue main menu.

The About dialog appears.
2 Click Version Info....

The File Versions dialog appears.
3 When you are finished viewing, Click OK.

Exporting File Versions
1 Select Help > About from the AutoVue main menu.

The About dialog appears.
2 Click Version Info....

The File Versions dialog appears.
3 Click Export....

The Export dialog appears.
4 Navigate and select the directory you want to export the file to.
5 Enter a File name with the extension .txt.

Hinweis  The file can only be exported to text file.
6 Click Save.

The markup file is exported to the selected directory.
Cimmetry Systems Corp.
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AutoVue Basics
This section introduces you to the basics of working with AutoVue’s graphical 
user interface.

Menu Bar
The Menu bar is the main access to all the menu commands. The selection of 
commands changes according to the tasks being accomplished by AutoVue. 

Toolbars
The Toolbar icons offer easy access to the options presented in the drop-down 
menus found in the Menu bar.
Cimmetry Systems Corp.
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Status Bar
In both View mode and Markup mode, there is a Status bar located at the 
bottom of the main window. The fields displayed from left to right on the Status 
bar are: marker, current active filename, file type, zoom factor, current page and 
total number of pages, current active file size, file creation date and cursor’s 
coordinate position.
In addition to the fields, there are two markers that may be present on the Status 
bar.

The red light bulb  indicates that the current active file has associated 
Markups. While in View mode, click the red light bulb to view the Markup 
Files dialog, then select a Markup file or group of Markup files to open. By 
opening a Markup file, Markup mode is automatically launched.

A red circle with an “i”  indicates that some main resources required to 
properly read the current active file are not available. To identify the missing 
resources, click the red circle to display the File Properties dialog.

Quick Menus
One of the quickest ways to access options is through Quick Menus or context-
sensitive shortcut menus. These are the menus you see when you right-click in 
the workspace. The Quick Menu options available depend on the mode you are 
in and what is selected prior to right-clicking.
Cimmetry Systems Corp.
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Opening Files with AutoVue
How to open a file depends on the current active mode in AutoVue. In View 
mode, you can open base files. In Markup mode, you can open a Markup file for 
a base file.
With AutoVue, you can open a file from the current active directory or from 
another directory, or manually specify the file to open by entering the URL.

Opening a Local File
1 Select File > Open Local File from the AutoVue main menu.

The File Open dialog appears.
2 Browse to locate the file that you want to open.
3 Click Open.

The file appears in the AutoVue workspace.

Opening a URL
You can open a file by specify the URL.
1 Select File > Open URL from the AutoVue main menu.

The File Open dialog appears.
2 In the File Name type the URL http or ftp path or click Browse to locate 

the file that you want to open.
3 Click OK.

The file appears in the AutoVue workspace.

Archive Files
The full archive file directory displays in the AutoVue window. It is not 
necessary to decompress the file. Double-click a file to display it within 
AutoVue. If you would like to markup an archive file, the file must be accessible 
for AutoVue in a format other than archive.
Cimmetry Systems Corp.
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Viewing File Properties
You can access the file properties from the File menu. The Properties dialog 
provides information specific to the current active file, such as filename, file size, 
date of creation and file type. The file properties that you can view are:

Note  The file properties can vary depending on the file format viewed.
1 Select File > Properties from the AutoVue main menu.

The Properties dialog appears.
2 To view file properties, click the File Properties tab.

To view resource information, click the Resource Information tab.
To view native properties, click the Native Properties tab.

3 Click OK to close the dialog.

Property Description

File Information specific to the current active file, such as filename, file 
size, date of creation, file type and x, y & z dimensions.

Resource 
Information

Resources specific to the current active file, such as text font, 
shape file, line style and external reference files.

Native Custom properties for file types, such as last person who saved the 
file, signature verification and author comments.
Cimmetry Systems Corp.
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Working With 2D Files
AutoVue provides easy access to entity information and displays color-coded 
comparative data for 2D drawings. You can instantly manipulate how the current 
active file is displayed. You can also modify AutoVue to suit your needs and 
preferences through a broad range of configuration options.

Searching Text
You can perform a text search on 2D vector and text-based documents.
Note  You can not perform a text search on raster files.
AutoVue provides search options that you can use to customize a search. These 
options are:

1 Select Edit > Search from the Autovue main menu.
The Find dialog appears.

2 In the Find What text box, enter the word or phrase that you want to find.
Note  If you are searching in a vector file, select a text string from the list.

3 Customize your search.
4 Click Find Next.

AutoVue highlights the text and zooms into the text area.
5 Click Cancel to close the Find dialog.

Note  To repeat the last search criteria, select Edit > Repeat Search from 
the AutoVue main menu.

Option Description

Match Whole Word Only Match a complete word.

Match Case Search for a word or text string with specific 
capitalization.

Up Search backward in the document.

Down Search forward in the document.
Cimmetry Systems Corp.
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Manipulating 2D Views
With the View options you can instantly manipulate how the current active file is 
displayed. You can rotate a file’s orientation counterclockwise by 90, 180 or 270 
degrees, flip a file’s orientation horizontally, vertically or both simultaneously.
AutoVue provides several ways to change the view size of a selected area of a 
file, display different views, layers and blocks of the current active file. You can 
also navigate from one page to another page of a multi-page file.
You can access these options from the View menu. The options are:

Menu Option Description

Zoom In Zoom in by a factor of 2.

From toolbar click  icon.

Out Zoom out by a factor of 2.

From toolbar click  icon.

Full  Resolution Display the file at full resolution.

From toolbar click  icon.

Fit Adjust the horizontal or vertical axis of a file to 
fully display within the current window.

Fit Both - AutoVue finds the best fit for the 
current file with respect to both its vertical and 
horizontal dimensions.
Note  This option is also known as Zoom Fit 
when right-clicking in the workspace.

Fit Vertical - Fit the image vertically in the 
active window. The horizontal dimensions of 
the image are zoomed proportionally but may 
be too large or small for the window.
Cimmetry Systems Corp.
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Fit Horizontal - Fit the image horizontally in 
the active window. The vertical dimensions of 
the image are zoomed proportionally but may 
be too large or small for the window.
Note  This option is also know as Zoom 
Page Width when right-clicking in the 
workspace.

Previous Revert to the previous selected zoom option.

Note  The Rotate option is disabled for text-based documents and spreadsheets.

Rotate 0 Set the file to its original position.

From toolbar click  icon.

90 Rotate the file 90 degrees anti-clockwise.

From toolbar click  icon.

180 Rotate the file 180 degrees anti-clockwise.

From toolbar click  icon.

270 Rotate the file 270 degrees anti-clockwise.

From toolbar click  icon.

Note  When in Markup mode, you can specify if the rotate is to be applied to the 
Markups only or to the base file and Markups.

Note  The Flip option is disabled for text-based documents and spreadsheets.

Flip None Reset the drawing to its original position.

Horizontal Axis Flip the drawing on its horizontal axis.

Vertical Axis Flip the drawing on its vertical axis.

Both Axes Flip the drawing on its vertical and horizontal 
axes.

Note  When in Markup mode, you can specify if the flip is to be applied to the 
Markups only or to the base file and Markups.

Menu Option Description
Cimmetry Systems Corp.
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Note  The Image option is used for black-and-white (monochrome) raster files.

Image Contrast Light, normal, dark and darkest.

Anti-alias Enhance the details of monochrome raster files.
Note  Also known as “Scale to Grey”.

Invert Reverse the background and foreground colors.

Page Next Page Go to the next page of a multi-page file. 

From toolbar click  icon.

Previous Page Go to the previous page of a multi-page file.

From toolbar click  icon.

Page Number Go to the specified page of a multi-page file.

From toolbar click  icon.

Special View 
Modes

Birds Eye Display a close-up view of a particular area of a 
file while maintaining a view of the entire file.

From toolbar click  icon.
Note  The Birds Eye option is disabled for 
text-based documents and spreadsheets.
See    Using Bird’s Eye View

Magnify Glass Magnify an area of the file that is specified by 
the cursor location.

From toolbar click  icon.
See  Using the Magnifying Glass

Magnify Window Magnify a selected area of a file and displays it 
in the Magnify Window.

From toolbar click  icon.
See   Using the Magnifying Window

Pan Click and drag to move the drawing. To exit 
right-click.

Menu Option Description
Cimmetry Systems Corp.
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Using Birds Eye View
The Birds Eye view option allows a close-up view of a particular area of a file 
while maintaining a full view of the file. The Birds Eye window displays a 
miniature version of the file. A movable box frame on top of the miniature 
indicates the area of the file displayed in the AutoVue workspace.
Note  The Birds Eye option is disabled for text-based documents and 
spreadsheets.
1 Select View > Special View Modes > Birds Eye from the AutoVue 

main menu. 
The Bird’s Eye window appears displaying a full view of the file.

2 To view the changes in “real time”, select Options > Dynamic from the 
Birds Eye menu.

3 To view a close-up of a specific area of the file in the AutoVue workspace, 
minimize the frame box by clicking and dragging the frame handles.
To view a different area of the file in the AutoVue workspace, click and drag 
the frame box to the area that you want to view.
Note  If you perform a zoom function in the AutoVue workspace, the area 
displayed in the workspace is highlighted by the frame box in the Birds 
Eye window.

4 Select Bird’s Eye > Exit to close the Bird’s Eye dialog.
The last view performed remains in the AutoVue workspace.

Using the Magnify Glass
The Magnify Glass view option zooms an area specified by the position of the 
Magnify Glass. You can view the details of a selected area of a file while 
maintaining a full view of the file.
1 Select View > Special View Modes > Magnify Glass from the 

AutoVue main menu.

Note  You can also click the Magnify Glass icon  on the AutoVue 
toolbar.

Show Tree Show/hide the Model tree of the current 
active file.

Menu Option Description
Cimmetry Systems Corp.
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2 Move the cursor to the area that you want to magnify.
3 Click and hold the left mouse button. 

The area is magnified in the Magnify Glass.
Note  To view different areas of the file, click and drag the mouse.

4 Right-click to exit Magnify Glass.

Using the Magnify Window
The Magnify Window option zooms an area specified by the position of the 
cursor. You can view the details of a select portion of the displayed file while 
maintaining the display of the full file.
1 Select View > Special View Modes > Magnify Window from the 

AutoVue main menu. 
The Magnify Window appears.

Note  You can also click the Magnify Window icon  on the AutoVue 
toolbar.

2 Move the cursor to the area that you want to magnify in the current active 
file.

3 Click once. 
The area appears magnified in the Magnify Window.

4 Right-click to exit the Magnify Window.

Conversion
Sometimes you need to translate a file to be able to use it with an application it 
was not created from. AutoVue provides several conversion file formats for you. 

Conversion Options
Depending on the conversion type being performed, the available options in the 
Convert dialog will vary. These options are:
Cimmetry Systems Corp.
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Option Description

Color Depth Select an option from the drop-down list:
• 1 = Black and white
• 4 = 16 colors
• 8 = 256 colors
• 24 = True color
• auto = AutoVue selects the color depth that best 

matches the original file.

Convert to Format A drop-down list of all the possible types of output file 
formats currently available for conversion. The available 
formats are:
• CALS GP4
• Encapsulated Postscript (Raster)
• HP Laserjet Printer (HLP)
• PCX Bitmap
• PDF
• Run Length RLC File
• TIFF
• Windows Bitmap 

Output Specify the name and path of the file in which the con-
version is to be stored.  This file is also known as the 
output file. You can use Browse to provide AutoVue 
with the file’s path.
Note  If writing onto an existing file, the contents of 
the output file will be overwritten. 

Sub-Format The Sub-Format drop-down list appears when you 
selected HP Laserjet Print or TIFF from the Convert 
to Format drop-down list. Specify the variety of 
convert-to-format by selecting a sub-format.

Convert Region The area of the file to be converted. The available 
options are:
• Display - refers to the image to fit on the output 

page. 
For example, if you zoomed in on a particular 
region of the file, the zoomed portion of the file is 
converted.

• Extent - refers to the entire extents of the file.
Cimmetry Systems Corp.
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PDF
With AutoVue it is possible to convert Office, 2D and EDA formats to PDF. 
When converted from Markup Mode, markups are “burned” onto the PDF. 
When you open the PDF, you will see the base file along with all markups.

X and Y
Three factors affect the resolution of an image: the type of image you are 
converting, the output device and the acceptable file size. High-resolution scans 
often require large files, causing longer processing and print time. Note that a 
high-resolution may not produce a better-quality printed image if your output 
device does not recognize the higher resolution information stored in the file. To 
keep file sizes manageable, select the lowest resolution that provides acceptable 
quality on your output device.
With some file types, the Size option appears giving you a choice between 
millimeters and inches. Page sizes can be selected from the Size drop-down list 

Convert Pages The number of pages to be converted. The available 
options are:
• All - converts all pages.
• Current - converts the current page
• Range - converts the pages indicated in the range

X and Y Choose from pixels, inches and millimeters for the units.
Note  With raster files the units are preset as pixels:  
• X indicates the number of horizontal pixels
• Y is the number of vertical pixels for the current 

active file contents. 
At times, AutoVue will preset X and Y to match the 
specifications of the selected conversion file format. 
Other times, X and Y will be available and may be 
changed according to your preferences.  Your selection 
here will not affect the current display but will affect the 
conversion file’s resolution.

Option Description
Cimmetry Systems Corp.
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or you can customize page sizes by configuring the Initialization file. For more 
information, see System Administration Guide.

Converting a File
1 Select File > Convert from the AutoVue main menu.

The Convert dialog appears.
Note  The Input area varies according to the type of file. A word-
processing file displays the file format; a raster file displays the file format 
and size. Both vector and database files display the size, file type and 
dimensions.

2 In the Save As text box, enter the path and filename or click Browse to 
locate the directory where you want to save the converted file.
Note  If writing on to an existing file, the contents of the output file will be 
overwritten.

3 Select the convert options that you want to set for the file.
See  Conversion Options

4 Click OK.
The file is converted and appears in the specified directory.
Note  You can convert several selected pages of a multi-page file to a multi-
page TIFF.

Changing the Pen Settings
With AutoVue, you can specify a thickness for each pen color.
Note  This option only applies to vector files.
1 Select File > Convert from the AutoVue main menu.

The Convert dialog appears.

Technical Drawing Page Sizes ISO Paper Format

A8.5” X 11.0” (216 mm X 279 mm) A4  285 mm X 198 mm

B11.0” X 17.0” (279 mm X 432 mm) A3  396 mm X 273 mm

C17.0” X 22.0” (432 mm X 559 mm) A2  570 mm X 396 mm

D22.0” X 34.0” (559 mm X 864 mm) A1  817 mm X 570 mm

E34.0” X 44.0” (864 mm X 1118 mm) A0  1165 mm X 817 mm
Cimmetry Systems Corp.
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2 Click Pens.
The Pen Settings dialog appears.

3 In the From/To, select the Color Index for which you want to modify the 
thickness.
Note  To select more than one Color Index, click the Shift or Ctrl key 
while selecting.

4 From the Units drop-down list, select the unit in which you want to set the 
thickness.

5 Click Thickness.
The Modify Pen Thickness dialog appears.

6 Enter a thickness.
7 Click OK.

The new Thickness appears beside the selected Color Index.
8 To save the changes that you made, click Save As.

The Save As dialog appears.
9 Enter a Name for the new pen settings.
10 Click OK.

The new pen settings are saved and appear in the Current Pen Settings 
list.
Note  To modify an existing Pen Settings, select the pen settings from the 
Current Pen Settings drop-down list, make the changes, then click 
Save.

11 Click OK to close the Pen Settings dialog.

Measuring in 2D non-vector Files
AutoVue provides the ability to perform measurements in 2D files. Measure 
options vary between vector and non-vector files. For vector files, AutoVue 
provides the option to “snap” to fixed points on the drawing. For non-vector files, 
you can only “free snap”.
AutoVue provides several measure options that you can choose from.You can 
access the measure options from the Analysis > Measure menu. The options 
are:

Name Description

Angle Measure the angle between selected points.

From toolbar click  icon.
Cimmetry Systems Corp.
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Measuring Distance
Use the Distance option to measure the distance between two specific points.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the AutoVue toolbar.
2 Click the Distance tab.
3 From the Measured Distance Units drop-down list, select the unit in 

which you want to measure the distance.
Note  If you want to measure the distance along a path, select Cumulative.

4 Click a point on the drawing to define the starting point.
5 Click another point on the drawing to define the end point.

Note  If you selected Cumulative, continue clicking points along the path 
that you want to measure.

6 Right-click to complete the measurement.
The points are joined by a line. The measured distance, Delta-X and Delta-Y 
appear in the Measurement dialog.
Note  Click Reset to take another measurement.

7 Click Close to close the Measurement dialog.

Calibrating Distance
1 Measure distance between two points or measure cumulative distance.

See  Measuring Distance
2 In the Measurement dialog, click Calibrate.

Arc Measure an arc.

From toolbar click  icon.

Area Measure a selected area.

From toolbar click  icon.

Distance Measure the distance between two points.

From toolbar click  icon.

Name Description
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The Distance Calibration dialog appears displaying the measured 
distance.

3 From the Measured Dist. drop-down list, select the unit to which you want 
to calibrate the distance.

4 Click Calibrate to and enter a value if you want to calibrate the distance to 
a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

5 Click OK.
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Measuring Area
Use the Area option to measure the area and perimeter of a region.
1 Select Analysis > Measure from the AutoVue main menu.The 

Measurement dialog appears.

Note  You can also click the Area icon  on the AutoVue toolbar.
2 Click the Area tab.
3 From the Measured Area Units drop-down list, select the unit in which 

you want to measure the area.
From the Perimeter Units drop-down list, select the unit in which you 
want to measure the perimeter.
Note  To cumulate a Net Area Result of different areas, select Add in the 
Measurement dialog. To subtract an area from the Net Area Result, 
select Subtract. Select Clear to clear the Net Area Result.

4 Click a point on the drawing to define the starting point.
5 Continue clicking points on the drawing to define the area you want to 

measure.
Each point is joined by a line. The area and perimeter measurements appear 
in the Measurement dialog.

6 Right-click to complete the measurement.
Note  Click Reset to take another measurement.

7 Click Close to close the Measurement dialog.

Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
1 Select Analysis > Measure from the AutoVue main menu.
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The Measurement dialog appears.

Note  You can also click the Angle icon  on the AutoVue toolbar.
2 Click the Angle tab.
3 From the Measured Angle Units drop-down list, select the unit in which 

you want to measure the angle.
4 Click points on the drawing to define the angle you want to measure.

Angle arms appear with an arc connecting them. The angle measurement 
appears in the Measurement dialog.
Note  Click Reset to take another measurement.

5 Click Close to close the Measurement dialog.

Measuring an Arc
Use the Arc option to define an arc in the drawing and measure its radius, center 
and diameter.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the AutoVue toolbar.
2 Click the Arc tab.
3 From the Arc Info drop-down list, select the unit in which you want to 

measure the arc.
4 From the Measured Angle Units drop-down list, select the unit in which 

you want to measure the angle.
5 Click points on the drawing to define the arc.

The points are joined by an arc. The measurements for center point 
coordinates, radius, diameter, arc length, start and end of angle and sweep 
appear in the Measurement dialog.
Note  Click Reset to take another measurement.

6 Click Close to close the Measurement dialog.

Calibrating an Arc
1 Measure an arc in the drawing.

See  Measuring an Arc
2 In the Measurement dialog, click Calibrate.

The Radius Calibration dialog appears displaying the measured distance.
3 From the Measured Rad. drop-down list, select the unit to which you want 

to calibrate the distance.
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4 Click Calibrate to and enter a value if you want to calibrate to a value.
Click Set Factor and enter a value if you want to calibrate by a factor.

5 Click OK. 
The calibration result appear in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Working with 2D Vector Files
In addition to all features that are available for generic 2D files, AutoVue 
provides the ability to access entity information, access views saved in the 
drawing and the ability to “intelligent snap” when performing measurements.
AutoVue references various sources to obtain all data required to completely and 
accurately display vector files. These sources can be internal to the file, like 
layers and blocks or external reference files that are located outside the file.

Manipulating 2D Vector Views
With the View options you can instantly manipulate how the current active file is 
displayed. You can rotate a file’s orientation counterclock-wise by 90, 180 or 270 
degrees, flip a file’s orientation horizontally, vertically or both simultaneously.
AutoVue provides several ways to change the view size of a selected area of a 
file, display different views, layers and blocks of the current active file. You can 
also navigate from one page to another page of a multi-page file. For more 
information on how to manipulate views, see Manipulating 2D Views.
For 2D vector files, there are additional View options:

Option Description

Views Select and display different views of a drawing.

From toolbar click  icon.
See   Selecting Views

Layers Select and display different layers of a drawing.

From toolbar click  icon.
See  Layers
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Drawing Information
Note  This feature is currently not supported with AutoVue Server running on 
Unix Platforms. 
The Drawing Information option is available with AutoCAD and 
MicroStation drawings, and is accessed from Analysis of the AutoVue main 
menu in both View and Markup modes. The Drawing Information options 
available are: Select Single Entity, List Tags/Attributes and Entity 
Information.

Viewing Details of a Single Entity
Note  This feature is currently not supported with AutoVue Server running on 
Unix Platforms. 
1 Select Analysis > Drawing Information > Select Single Entity from 

the AutoVue main menu.
2 Click the entity for which you want to view information.

The Get Entity Info dialog appears displaying the information for the 
selected entity.
The XData button appears if additional information exists for that entity. 
Click XData to view the information.
Note  If you did not select an entity, a message appears informing you that 
no entities were found and prompts you to select again.

3 Click OK to close the Get Entity Info dialog.

Viewing information for a Set of Entities
Note  This feature is currently not supported with AutoVue Server running on 
Unix Platforms. 
The Entity Information option allows you to view information of a set of 
entities contained in a specific area of a file.

Blocks Select and display a block from a drawing.

From toolbar click  icon.
See  Blocks

Option Description
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1 Select Analysis > Drawing Information > Entity Information from 
the AutoVue main menu.

2 Click and drag to draw a box around an area for which you want to view 
entity information for the list of entities contained inside the area.
The List Entities dialog appears displaying the information of all the 
selected entities.
Note  If there are no entities within the selected area, a message appears 
informing you that no entities were found and prompts you to select again.

3 Click OK to close the List Entities dialog.

Viewing Tags/Attributes
Note  This feature is currently not supported with AutoVue Server running on 
Unix Platforms. 
1 Select Analysis > Drawing Information > List Tags/Attributes from 

the AutoVue main menu.
2 Click in the area of the file for which you want to view information on block 

attributes and tags.
The Block Attributes dialog appears displaying the attributes/tags for the 
selected entity.
Note  If there are no entities within the selected box, a message appears 
informing you that no entities were found and prompts you to select again.

3 Click OK to close the Block Attributes dialog.

Viewing XRefs
AutoVue references various sources to obtain all the data required to completely 
and correctly display files. These sources can be internal to the file, like layers 
and blocks. External reference files or Xrefs are located outside the file.
Use the XRefs option to display the external references of the current active file.
Note  For AutoVue to locate a resource file, the XREFPATHS must point to the 
directory or directories where the resource files exist. For more information, see 
System Administration Guide.
1 Select View > XRefs from the AutoVue main menu.

The Select the External References to display dialog appears listing 
the external reference files associated with the current active file.

2 Select the checkbox beside the XRefs that you want to display.
Clear the checkbox beside the XRefs that you want to hide.

3 Click OK.
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The selected XRefs are displayed.

Displaying Details About Missing XRefs
If a file has missing resources, a red circle with an “i”  appears to the left of 
the AutoVue status bar.

1 Click the Resource icon  on the AutoVue status bar.
The Properties dialog appears.
Note  You can also select File > Properties from the AutoVue main 
menu.

2 Click the Resource Information tab to display details about missing 
resource information required to properly display this file.

A green check mark  indicates the resources that AutoVue is able to 
access.

A red  indicates the external reference files or components that are not 
accessible.

3 Click OK to close the Properties dialog.

Layers
Use this option to configure the current active file’s layers to display.
1 Select View > Layers from the AutoVue main menu.

The Select the layers to display dialog appears listing the layers and 
layer visibility for the current active file.

Note  You can also click the Layers icon  on the AutoVue toolbar.
2 To sort the list of layers in the dialog, click Name to sort alphabetically or 

numerically, or click Status to sort by visibility.
3 Select the checkbox beside the layers that you want to set visible.

Clear the checkbox beside the layers that you want to hide.
4 Click OK.

The selected layers are displayed.

Blocks
Use this option to select a block to display from the current active file.
1 Select View > Blocks from the AutoVue main menu.
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The Select a block to display dialog appears listing the blocks for the 
current active file.

Note  You can also click the Block icon  on the AutoVue toolbar.
2 From the drop-down list, select the block that you want to display.
3 Click OK.

The selected block is displayed.

Selecting Views
The Views option allows you to access different named views of a file.
1 Select View > Views from the AutoVue main menu.

The Select a named view dialog appears.

Note  You can also click the View icon  on the AutoVue toolbar.
2 From the drop-down list, select the view that you want to display.
3 Click OK.

The selected view is displayed.

Specifying a View Point
The View Point option allow you to render a drawing from a selected 
viewpoint. The default view point is the one used to create the file.
1 Select View > View Point from the AutoVue main menu.

The View Point dialog appears.
2 Enter the X, Y and Z coordinates for the viewpoint with which you want to 

render the drawing.
3 Click OK.

The drawing is displayed from the selected viewpoint.

Comparing 2D Files
AutoVue provides the ability to visually compare two files and display color-
coded comparative data. When you compare two files, Autovue displays three 
windows, the first containing the original file, the second containing the file you 
compared the original against, and the third containing the comparison results.
In the Comparison Result window you can specify whether you want to 
display only the additions, deletions or unchanged, or any combination of the 
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three. To access these options, right-click in any window and select an option 
from the pop-up menu.
The comparison results are displayed in different colors to differentiate the 
results of the file comparison. The comparison options and corresponding colors 
are:

1 View the base file in AutoVue.
2 Select Analysis > Compare from the Autovue main menu.

The File Open dialog appears.
3 Enter the File Name or click Browse to select the file that you want to 

compare with the current active file.
4 Click OK.

AutoVue displays three windows, the first displaying the original file, the 
second displaying the compare file and the third displaying the comparison 
results.
Note  If you apply a change from the View menu, all three windows display 
the synchronized change.

5 To access the Compare options, right-click in any of the windows.
A pop-up menu appears displaying the Compare options.

Note  To maximize any of the windows, click the  button on the title bar 

of the window that you want to maximize. To minimize, click the  

button. To restore the window, click the  button.

6 To exit Compare mode, select File > Exit Compare Mode from the 
AutoVue main menu.
The original file appears in the workspace.
Note  You can also exit Compare mode by right-clicking in any of the 
windows and selecting Exit Compare Mode from the pop-up menu.
See Also  Specifying Scale and Offset for a Compare File

Option Color Description

View Additions Green Indicates that something has been added.

View Deletions Red Indicates that something has been deleted.

View Unchanged Blue Indicates that there is no change.
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Specifying Scale and Offset for a Compare File
You can scale or translate a file in order to compare files accurately. With the 
Scale and Offset option you can modify the coordinates (XOffset and 
YOffset) or enter a scaling factor for the second file.
Note  XOffset and YOffset are relative to the base drawing and all options are 
displayed at their current values.
1 In Compare mode, select View > Scale and Offset from the AutoVue 

Main window.
The Scale and Offset dialog appears.

2 In the Scale and Offset dialog, enter the required values for the Scale 
Options: XOffset, YOffset and Scale.

3 Click OK.
The scaling/offset modifications are applied to the file in the second window.

Overlays
When working with 2D files, you can overlay other files over the current active 
file. You can also adjust an overlay, move an overlay, and scale an overlay by 
defining the X and Y coordinates and the scaling factor.

Adding an Overlay
Note  When working with a raster file, it should be used as the base file because 
raster formats are opaque and would hide files underneath them.
1 View the file that you want to use as the base file for the overlay.
2 Select Analysis > Overlays > Select from AutoVue main menu.

The File Open dialog appears.
3 Enter the File Name or click Browse to select the file you want to overlay.
4 Click OK.

The base file is displayed with the selected overlay file on top of it.
Note  To lay multiple files over one base file, repeat steps 2 to 4 using the 
same base file. Overlays are added one at a time.

Modifying an Overlay
1 Select Analysis > Overlays > Modify from AutoVue main menu.

The Modify Overlay dialog appears.
2 Select the Overlay that you want to modify.
3 Click the Action that you want to apply to the overlay.
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•   Click Move if you want to move the overlay. 
Click a point on the base file where you want to set the lower left corner 
of the overlay. Click another point where you want to set the upper right 
corner of the overlay.
Note As you select the point to define the position of the upper right 
corner, you can resize the destination box.

•   Click Scale if you want to resize the overlay. 
Enter the XOffset and YOffset coordinates and/or the Scale factor.
Note XOffset and YOffset are relative to the base drawing and all 
options are displayed at their current values.

•   Click Warp to adjust the overlay. 
Click a point on the overlay and drag the cursor to where you want the 
overlay starting point. Click another point and drag the cursor to where 
you want the overlay to end.
Note The overlay’s size is scaled to accommodate the origin and 
destination points you defined.

4 Click OK.
The changes are applied to the selected overlay.
Note  To modify other overlays, repeat steps 2 to 4.

Removing an Overlay
1 Select Analysis > Overlays > Modify from AutoVue main menu.

The Modify Overlay dialog appears.
2 Select the Overlay that you want to remove.
3 Click Remove.

A confirmation dialog appears.
4 Click Yes.

The overlay is removed from the list in the Modify Overlay dialog and 
from the display.

Measuring in 2D Vector Files
AutoVue provides the ability to perform measurements in 2D files. Measurement 
options vary between vector and non-vector files. For vector files, AutoVue 
provides the option to “snap” to fixed points on the drawing. For non-vector files, 
you can only “free snap”.
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You can access the measure options from the Analysis > Measure menu. 
These options are:

2D Vector Snapping Modes
The Snapping Modes available allow you to click to precise geometrical 
points on a drawing. For example, if you select Snap to end-point and you 
move the cursor over an end-point of a line, the end-point will be highlighted by 
a snap box. 
The Snapping modes allow you to snap to the mid, center and end-points of 
an entity:

Name Description

Angle Measure the angle between selected points.

From toolbar click  icon.

Arc Measure an arc entity.

From toolbar click  icon.

Area Measure selected area.

From toolbar click  icon.

Distance Measure the distance between two points.

From toolbar click  icon.

Icon Snap to Description

End-point Geometric snap mode where a snap box appears 
when moving the cursor near a linear component’s 
end point.

Mid-point Geometric snap mode where a snap box appears 
when moving the cursor near the halfway point of a 
linear component.

Center-point Geometric snap mode where a snap box appears 
when moving the cursor near the center of an 
elliptical component.
Cimmetry Systems Corp.



AutoVue 29
Measuring Distance
Use the Distance option to measure the distance between two specific points.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the AutoVue toolbar.
2 Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See  2D Vector Snapping Modes

4 From the Measured Distance Units drop-down list, select the unit in 
which you want to measure the distance.
Note  If you want to measure the distance along a path, select Cumulative.

5 Click a point on the drawing to define the starting point.
6 Click another point on the drawing to define the end point.

Note  If you selected Cumulative, continue clicking points along the path 
that you want to measure.

7 Right-click to complete the measurement.
The points are joined by a line. The measured distance, Delta-X and Delta-Y 
appear in the Measurement dialog.
Note  Click Reset to take another measurement.

8 Click Close to close the Measurement dialog.

Calibrating Distance
1 Measure distance between two points or measure cumulative distance.

See  Measuring Distance
2 In the Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured 
distance.

3 From the Measured Dist. drop-down list, select the unit to which you want 
to calibrate the distance.

Free snap Allow snapping at any point on the drawing.

Icon Snap to Description
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4 Click Calibrate to and enter a value if you want to calibrate the distance to 
a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

5 Click OK. 
The calibration result appears in the Measurement dialog.

6 Click Close to close the Measurement dialog.

Measuring Area
Use the Area option to measure the area and perimeter of a region.
1 Select Analysis > Measure from the AutoVue main menu.The 

Measurement dialog appears.

Note  You can also click the Area icon  on the AutoVue toolbar.
2 Click the Area tab.
3 Select Between Points if you want to measure the area between points on 

a drawing. Snapping Modes are enabled.
4 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See  2D Vector Snapping Modes

5 Select Shape if you want to measure the area of a predefined shape on the 
drawing. Snapping Modes are disabled.

6 From the Measured Area Units drop-down list, select the unit in which 
you want to measure the area.

7 From the Perimeter Units drop-down list, select the unit in which you 
want to measure the perimeter.

8 To cumulate a Net Area Result of different areas, click Add. 
To subtract an area from the Net Area Result, click Subtract.
Select Clear to clear the Net Area Result.

9 If you selected Between Points, click points on the drawing to define the 
area. 
Each point is joined by a line. The area and perimeter measurements appear 
in the Measurement dialog.

10 Right-click to complete the measurement.
11 If you selected Shape, click the edge of the predefined shape.

The shape is highlighted and the area and perimeter measurements appear in 
the Measurement dialog.
Note  Click Reset to take another measurement.
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12 Click Close to close the Measurement dialog.

Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the AutoVue toolbar.
2 Click the Angle tab.
3 Select From 3 Points if you want to measure the angle between three 

points. Snapping Modes are enabled. 
4 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See  2D Vector Snapping Modes

5 Select Between 2 lines if you want to measure the angle between two 
lines. Snapping Modes are disabled.

6 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.

7 If you selected From 3 Points, click three points on the drawing to define 
the angle.

8 If you selected Between 2 Lines, click two lines on the drawing to define 
the angle.
Angle arms appear with an arc connecting them. The angle measurement 
appears in the Measurement dialog.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.

Measuring an Arc
Use the Arc option to define an arc in the drawing and measure its radius, center 
and diameter.
1 Select Analysis > Measure from the AutoVue main menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the AutoVue toolbar.
2 Click the Arc tab.
3 Select From 3 Points if you want to measure the arc between three points. 

Snapping Modes are enabled. 
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Click the Snapping Modes that you want to select as the points for the 
measurement.
See  2D Vector Snapping Modes
Note  To select all Snapping Modes click All On. To clear all 
Snapping Modes click All Off.

4 Select Arc Entity if you want to measure a predefined arc. Snapping 
Modes are disabled.

5 From the Arc Info drop-down list, select the unit in which you want to 
measure the distance.

6 From the Measure Angle Units drop-down list, select the unit in which 
you want to measure the angle.

7 If you selected From 3 Points, click three points on the drawing to define 
the arc.
The points are joined by an arc. The measurements for center point 
coordinates, radius, diameter, arc length, start and end of angle and sweep 
appear in the Measurement dialog. 

8 If you selected Arc Entity, click the edge of the arc that you want to 
measure.
The arc is highlighted. The measurements for center point coordinates, 
radius, diameter, arc length, start and end of angle and sweep appear in the 
Measurement dialog.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.

Calibrating an Arc
1 Measure an arc in the drawing.

See   Measuring an Arc
2 In the Measurement dialog, click Calibrate.

The Radius Calibration dialog appears displaying the measured distance.
3 From the Measured Rad. drop-down list, select the unit to which you want 

to calibrate.
4 Click Calibrate to and enter a value if you want to calibrate to a value.

Click Set Factor and enter a value if you want to calibrate by a factor.
5 Click OK. 

The calibration result appears in the Measurement dialog.
6 Click Close to close the Measurement dialog.
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Configuring AutoVue for 2D Files
In AutoVue, there are configuration options that allow you to customize the work 
environment when working with 2D vector and non-vector files. You can access 
the configuration options from Options > Configuration under the General 
tab. 

All 2D Files
The configuration option can be configured for all 2D files:

Vector Files
The configuration options for vector files are:

Option Description

Force to Black • If selected, AutoVue forces all colors of a drawing to 
black

• If cleared, the file will be displayed in color

Option Description

Text • If selected, text entities are displayed
• If cleared, no text is displayed

Line Style • If selected, dotted and dashed lines are displayed
• If cleared, all lines are displayed as solid

Dimensions • If selected, all dimensional entities are displayed
• If cleared, simple dimension entities are not displayed

Filling • If selected, displays filled entities as filled rather than 
just an outline

• If cleared, does not display filling for filled entities

Line Weights • If selected, displays varying line thicknesses
• If cleared, displays no line weights for any line (all lines 

appear equal)

Load External
References

• If selected Xrefs are automatically loaded
• If cleared, Xrefs are not loaded
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Raster Files
The configuration options for Raster files are:

Configuring AutoVue
1 Select Options > Configuration from the AutoVue main menu.
2 The Configuration dialog appears.
3 Click the General tab.
4 Configure the options that you want.
5 To configure the background color, click Background Color. The 

Background Color dialog appears.
Select the color that you want to set for the background.
Select the checkbox beside the Type of file format that you want to change.
Clear the checkmark beside the Type that you do not want to change, then 
click OK.
The color change is applied.
Note  The Type of file formats that you can select are Mono Raster, Color 
Raster, Database, Document, Spreadsheet, Default Archive and Vector.

6 Click OK to close the Configuration dialog.

Configuring the Base Font for Text-based 
Files
1 Configure the options that you want.

See  Configuring AutoVue for 2D Files
2 Click Base Font.
3 The Font dialog appears.
4 From the Font drop-down list, select the type of font.
5 From the Size drop-down list, select the size of font.
6 Select Bold, Italic or both for font Style.
7 Click OK.

The font change is applied.

Option Description

Full Resolution Displays the file at full resolution.

Fit to Window Displays the file to fit the current window.
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8 Click OK to close the Configuration dialog.

Rendering
When Enable Look Ahead is selected and you zoom into a part of a file, 
AutoVue renders adjacent tiles. The advantage to this is improvement in 
performance when zooming in on parts of a file. The disadvantage is that if the 
client machine is idle for at least one second, Enable Look Ahead is triggered 
which could slow down current operations. However, once all tiles are rendered, 
all zoom operations speed up again.
If Enable Look Ahead is cleared, AutoVue renders the tiles when requested 
(i.e., when you zoom in on parts of the file).
Note  The Enable Look Ahead option is only applied when rendering in Tiled 
mode. For more information, see Installation Guide.

Snap Settings
With the Snap Settings option, you can configure the snap options for 
measuring. When you move the cursor within a predetermined snap radius, the 
snap box appears for the entity to be selected. The snap radius is configured in 
pixels. You can access this option from Options > Configuration dialog under 
the 2D tab.
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Markups
AutoVue has the ability to view over 450 different file formats and to create 
markups for all its readable file formats without the document's authoring 
application.
Marking up refers to drawing and writing on an electronic document. AutoVue 
provides the ability to markup different formats without modifying the original 
file. When you create a markup for a file, the markup is created on top of the 
original file. Markups are saved in separate files.

If a file has existing markup files, a red light bulb  appears on the status bar at 
the bottom of the AutoVue workspace. Clicking this icon opens the Open 
Markup dialog allowing you to select markup files to open or create a new 
markup file. When opening a markup file, AutoVue lays the markup over the 
original file.
In Markup mode you can:
• create entities such as arcs, boxes, circles, clouds, lines and polygons
• add a symbol, add information to an entity by adding text or a note
• create, name and color layers to organize your work
• create a new markup file that combines copies of selected layers of different 

markup files
• create measurement markup entities that can be moved or resized
• navigate markups through a hierarchy tree, view markup properties and sort 

the tree according to each property
• view markup layers individually or in combination
Note  Markup capability is only available in the Professional versions of the 
AutoVue product: AutoVue Professional and AutoVue SolidModel Professional.

Markup Navigation Tree
When opening a file in Markup mode, a Markup Navigation Tree appears to 
the left of the document. If the Markup Navigation Tree does not appear, 
select View > Show Model Tree.
The Markup Navigation Tree displays a hierarchy tree of markups or 
comments created by a user. The user can navigate through the markups. A set of 
Cimmetry Systems Corp.



AutoVue 37
properties are generated for each markup and the tree can be sorted according to 
each property. These properties are:

When a markup entity is created, it appears in the Markup Navigation Tree 
and the information is recorded and saved in the markup file.
Note  To see more markup properties or to expand the tree, click and drag the 
Markup Navigation Tree window.

Working with Markup Files
Markup files are divided into uniquely named layers. Create, name and color 
layers to organize your work. For example, different colors can indicate time 
priorities and each layer can contain Markups related to a common purpose.

Property Description

Entity Type Type of markup entity created.

Page Page number of the original document on which the markup entity 
is created.

Layer Markup layer on which the markup entity is created.

Author The name of the user who created the markup.

Modified The date and time the markup was modified.
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Saved States
When you create Markup entities in a file, you can save the view state. For 
example, the zoom level at which you are working. If you save the Markup while 
you are working at your preferred zoom level, the next time you open the 
Markup, it is displayed at the same zoom level. Some examples of view states 
include zoom level (extents), rotation and flip settings.
State information is also saved with each markup entity. For instance, if you were 
at a certain zoom level when you created a markup entity, AutoVue saves the 
information with the markup entity. To “Go To” the state you were at when you 
created or modified the markup entity, select the markup entity and select Go To.

Creating a Markup File
1 View a file that you want to markup.
2 Select File > Markup from the AutoVue main menu. 

Note  You can also click the Markup icon  from the AutoVue main 
toolbar.

3 AutoVue enters Markup mode.
See Also  Creating a Markup Layer

Entering Markup Information
In AutoVue, when creating a Markup you can provide user information that you 
can save with the Markup.
1 Select Markup > Information from the Markup menu.

The Markup Information dialog appears.
2 Enter a User name.
3 Enter a Department.
4 Enter a Company name.
5 Enter the Location of the Company.
6 Enter a Telephone number.
7 Click OK.

The Markup Information is saved.

Saving a New Markup File
1 Select File > Save As from the AutoVue main menu.

The Save Markup File As dialog appears.
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The Markup Information that you entered when creating the Markup is 
display in the dialog.

2 Enter a Markup ID consisting of any combination of characters or numbers.
3 Click OK.

The Markup file is saved and remains displayed in the workspace.

Opening Markup Files
1 View the file that has existing markups.
2 Select File > Markup from AutoVue main menu.

The Open markup dialog appears.

Note  You can also click the Markup icon  from the Markup toolbar or 

click the red light bulb  at the bottom left corner of the status bar.
3 From the Markup list, select the checkbox beside the markup(s) that you 

want to open.
Note  If you selected more than one Markup, the Active Markup option 
appears.

4 Click OK. 
The selected markup(s) appear in the workspace on top of the original file.
Note  When you select more than one markup file, the markups are 
displayed simultaneously.
See Also   Setting the Active Markup File

Saving an Existing Markup File
1 Modify the markup file.
2 Select File > Save from the AutoVue main menu.

Note  If you have multiple markups open that you have modified and want 
to save them all, select File > Save All.
Note  To save an existing Markup as a new Markup, select File > Save 
As.

Importing a Markup File
1 Select File > Open from Markup mode.
2 The Open markup dialog appears.

Note  You can also click the Markup icon  from the Markup toolbar.
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3 Click Import.
The Select markup file to import dialog appears.

4 Navigate to the markup file that you want to import and select it.
5 Click Open.

The imported Markup file appears in the workspace on top of the original 
file.

Exporting a Markup File
1 Select File > Save As from the Markup menu.

Note  For a new Markup file, select File > Save.
2 Click Export.

The Select markup file export to dialog appears.
3 Navigate and select the directory you want to export the markup file to.
4 Enter File name.
5 Click Save.

The markup file is exported to the selected directory.
Note  The default format saved is Markup Files (*.*), but you can select 
another one. In the Save as type drop-down list, there are six formats to 
choose from: Markup Files (*.*), DXF Output (*.dfx), AutoCAD DWG R12 
(.dwg), AutoCAD DWG R13 (.dwg), AutoCAD DWG 14 (.dwg) and 
Microstation DGN Output (*.dgn).

Setting the Active Markup File
A file can have several markup files. When you open several markup files 
simultaneously, you can set one of the markups as the active markup. Any 
changes you make is applied to the current active markup.
1 Select File > Open from the Markup menu.

The Open markup dialog appears.
2 Click the checkbox beside the markups you want to open.

The Active Markup drop-down list appears when you select more than one 
markup.

3 From the Active Markup drop-down list, select the markup you want to 
make active.

4 Click OK.
The selected markup appears in the AutoVue workspace.
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Changing the Active Markup File
When you have multiple markup files open, you can change the active markup.
1 Select File > Set Active from the Markup menu.

The Set Active Markup dialog appears.
2 From the Select Active Markup drop-down list, select the markup you 

want to make active.
3 Click OK.

Note  You can set the active markup by selecting a markup from the drop-
down list on the Markup too1bar.

Markup Layers
Markup files can be divided into layers with each layer having its own unique 
name. You can create, name and color layers to organize your work. For example, 
different colors can indicate time priorities and each layer can contain markups 
relating to a common purpose. 
When working with markup layers, you can view layers individually or in 
combination, add, rename or delete layers. You can also specify a different color 
for each layer; default layer color is red.

Creating a Markup Layer
Note  Ensure that no markup entity is selected when creating a markup layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.
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Note  You can also click the Markup Layers icon  on the Markup 
toolbar.

2 In the Markup Layers dialog, click New.
The New Markup Layer dialog appears.

3 Enter the name that you want for the markup layer.
4 Click OK.

The new markup layer is added to the list in the Markup Layers dialog.
5 To change the color of the new layer, click Color in the Markup Layer 

dialog. 
The Layer Color dialog appears. Select a Color, then click OK.

6 Click OK to close the Markup Layers dialog.

Setting the Active Markup Layer
A markup can have several layers and you can set a layer as the active markup 
layer. When a markup layer is active, all modifications you make are applied to 
that markup layer.
Note  Ensure that no markup entity is selected when setting the active markup 
layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  on the Markup 
toolbar.

2 From the Markup Layers list, select the checkbox beside the layer you 
want to make active.

3 Click OK.
The selected Markup layer appears in the workspace.

Changing the Active Markup Layer
When you have multiple markup layers, you can change the active layer to 
another layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog box appears.
2 From the Currently Active Layer drop-down list, select the layer you 

want to make active.
3 Click OK.

The selected layer appears in the workspace.
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You can also change the active layer by selecting the layer from the drop-down 
list on the Markup too1bar.

Changing the Color of a Markup Layer
Note  Ensure that no markup entity is selected when changing the color of a 
markup layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  from the Markup 
toolbar.

2 Select the markup layer that you want to change the color.
3 Click Color.

The Layer Color dialog appears.
4 Select a Color.
5 Click OK.

Note  Only the entities that were created with the by-layer  color 
defined in the Markup Layers dialog will change color. Any entities that 
were created using the color options from the Markup toolbar, will override 
the by-layer color and will not change color.

6 Click OK to close the Markup Layers dialog.

Renaming a Markup Layer
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  from the Markup 
toolbar.

2 Under Markup Layers, select the checkbox beside the markup layer you 
want to rename.

3 Click Rename.
The New Markup Layer dialog appears.
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4 Enter the new layer name.
5 Click OK. 

The markup layer is assigned the new name.
6 Click OK to close the Markup Layers dialog.

Toggling Markup Layers
From the Markup Layers dialog, you can turn a layer’s visibility on and off, 
even if there is only one layer.Turning a layer’s visibility off, hides all markups 
belonging to that layer.
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  from the Markup 
toolbar.

2 Under Markup Layers, select the layer(s) you want visible.
3 Click Toggle.

A checkmark appears beside the selected layers.
4 To hide a layer, select the layer(s) with a checkmark, then click Toggle 

again.
Note  You can also view a layer by selecting the checkbox beside it. To hide 
a layer, clear the checkmark. To view all the Markup layers, click All On. To 
hide all Markup layers click All Off.

5 Click OK.
The markup entities belonging to the selected layer(s) appear in the 
workspace on top of the original file.

Deleting a Markup Layer
1 Select Markup > Markup Layers from the Markup menu.

The Markup Layers dialog appears.

Note  You can also click the Markup Layers icon  from the Markup 
toolbar.

2 From the Markup Layers list, select the checkbox beside the markup layer 
you want to delete.
Note  You can select more than one layer to delete at the same time.

3 Click Delete.
4 Click OK.

The layer is deleted along with all entities belonging to the layer.
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Moving a Markup Entity to Another Layer
1 Select the entity or entities that you want to move.
2 Select Markup > Markup Layers from the Markup menu.

The Move to Layer dialog appears.

Note  You can also click the Layer icon  on the Markup toolbar.
3 Select the Layer you want to move the entity or entities to.
4 Click OK. 

The selected entity or entities are moved to the selected layer.

Note  Only the entities that were created with the  By Layer color 
defined in the Markup Layers dialog will change color. Any entities that 
were created using the color options from the Markup toolbar, will override 
the by-layer color and will not change color.

Consolidating Markup Files
The Consolidate option allows you to create a new markup file that combines 
copies of selected layers of different markup files. During the review cycle, 
consolidation simplifies document revisions by providing the author with one 
combined markup file instead of several markup files.
Note  The Consolidate option is only active when more than one markup file 
is opened.
1 Open the markup files that you want to consolidate.
2 Select File > Consolidate from the Markup menu.

The Consolidate Markups dialog appears.
3 Select the markup layers that you want to consolidate into one file.
4 Enter a Markup ID for the new markup file.
5 Click OK.

The consolidated markup file is saved.

Modifying Markup Entities
With AutoVue, you can assign an entity its own color, the same color as the 
current active layer or create a custom color. You also have the option of 
grouping Markup entities. When you group Markup entities, you can manage the 
group as you would a single entity. 
Cimmetry Systems Corp.



46 AutoVue
In Markup mode, there are several options for modifying an entity. You can apply 
these options to selected entities while you specify the change or new entities that 
you add. The modify options can be accessed from the Markup menu in Markup 
mode. The options are:

“Go To” a Markup Entity
Go To restores the view state when a created entity is saved. Opening an existing 
markup for a file also restores the last saved view state.

Option Description

Delete Delete a selected markup entity or entities.

Delete All Delete all markup entities.

Entity Color Change the line color, fill color and fill type for a selected 
markup entity or entities.

From toolbar click  icon to change the Fill Color.
See   Changing the Fill Color of An Entity

From toolbar click  icon to change the Line Color.
See   Changing the Line Color of An Entity

Fill Type Change the transparency for selected markup entity or 
entities.

From toolbar click  icon.
See  Changing the Fill Type of An Entity

Hide Markups Hide all markup entities.

Line Style Change the line style for a selected markup entity or entities.

From toolbar click  icon.
See   Changing the Line Style

Line Thickness Change the line thickness for a selected markup entity or 
entities.

From toolbar click  icon.
See   Changing the Line Thickness
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1 From the Markup Navigation Tree, select the markup entity that you 
want to view.

2 Right-click and select Go To from the drop-down menu.
Autovue displays the markup page containing the entity.
Note  If you selected a Markup entity that is on another page of the Markup, 
the page containing that entity will be displayed.

Selecting Markup Entities
1 Click the Select icon  from the Markup toolbar, then from the workspace 

click the entity’s outer edge.
Note  You can also select the entity from the Markup Navigation Tree.
Note  To select multiple entities, press the Shift or Ctrl key while selecting.

Moving a Markup Entity
1 In the Markup Navigation Tree or from the workspace, select the entity 

or entities that you want to move.
See   Selecting Markup Entities

2 Move the cursor over the selected entity or entities until the cursor changes 
to a hand.

3 Click and drag the selected entity or entities to anywhere in the workspace. 

Editing a Markup Entity
The entities that you can edit are notes, text, dimensions, leaders and hyperlinks.
1 In the Markup Navigation Tree or from the workspace, double-click the 

entity that you want to edit.
Autovue zooms in on the entity and the appropriate dialog appears allowing 
you to make changes to the entity.
Note  You can also edit an entity by right-clicking it in the Markup 
Navigation Tree and selecting Edit from the pop-up menu.

Grouping Markup Entities
When you group markup entities, you can move, delete, copy and paste, hide, 
resize, or perform any modification on the group of entities that you would on a 
single markup entity.
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1 In the Markup Navigation Tree or from the workspace, select the entities 
that you want to group.
See   Selecting Markup Entities

2 Select Markup > Group from the Markup menu.
The group of entities appear on the Markup Navigation Tree as a Group.

3 Perform any modifications.
The modifications are applied to all the entities in the group.

Ungrouping Markup Entities
1 In the Markup Navigation Tree or the workspace, select the Group that 

you want to ungroup.
2 Select Markup > Ungroup from the Markup menu.

The group of entities appear on the markup as individual entities.

Hiding Markup Entities
1 Select Markup > Hide Markups from the Markup menu.

The markups are hidden on the markup file.
Note  To “unhide” markups, select Markup > Hide Markups from the 
Markup menu.

Changing Line Thickness of an Entity
Note  A checkmark beside the thickness option indicates the current line 
thickness.
1 Select the entity or entities for which you want to change the line thickness.

See   Selecting Markup Entities
2 From the Markup menu, select Markup > Line Thickness and the line 

thickness that you want.
The line thickness changes for the selected entity or entities.

Note  You can also click the Line Thickness icon  on the Markup 
toolbar.

3 To define a custom line thickness, select Modify > Custom Thickness 
from the Markup menu.
The Custom Thickness dialog appears.

4 Enter an integer value in pixels.
5 Click OK to close the Custom Thickness dialog.
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Note  Any new entities that you create will have the new line thickness.

Changing Line Style of a Entity
Note  A checkmark beside the style option indicates the current line style.
1 Select the entity or entities for which you want to change the line style.

See   Selecting Markup Entities
2 From the Markup menu, select Markup > Line Style and the line style that 

you want.
The line style changes for the selected entity or entities.

Note  You can also click the Line Style icon  on the Markup toolbar.
Note  Any new entities that you create will have the new line style.

Changing Line Color of an Entity
1 Select the entity or entities for which you want to change the line color.

See   Selecting Markup Entities
2 Select Markup > Entity Color from the Markup menu.

The Entity Color dialog appears.

Note  You can also click the Line Color icon  on the Markup toolbar.
3 From the Line Color drop-down list, select the color that you want for the 

entity.

Note  Selecting  By Layer changes the entity color to the color of the 
layer.

4 To define a custom line color, select  CUSTOM from the Line Color 
drop-down list.

5 From the Color dialog that appears, select a color and click OK.
6 Click OK to close the Entity Color dialog.

The line color changes for the selected entity or entities.
Note  Any new entities that you create will have the new line color.

Changing Fill Color of an Entity
1 Select the entity or entities for which you want to change the fill color.

See   Selecting Markup Entities
2 Select Markup > Entity Color from the Markup menu.

The Entity Color dialog appears.
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Note  You can also click the Fill Color icon  on the Markup toolbar.
3 From the Fill Color drop-down list, select the color that you want for the 

entity.

Note  Selecting  By Layer changes the entity color to the color of the 
layer.

4 To define you own color, select  CUSTOM from the Fill Color drop-
down list.

5 From the Color dialog that appears, select a color and click OK.
The fill color changes for the selected entity or entities.

6 Click OK to close the Entity Color dialog.
Note  Any new entities that you create will have the new fill color.

Changing Fill Type of an Entity
1 Select the entity or entities for which you want to change the fill type.

See   Selecting Markup Entities
2 Select Markup > Entity Color from the Markup menu.

The Entity Color dialog appears.

Note  You can also click the Fill Type icon  on the Markup toolbar.
3 From the Fill Type drop-down list, select the fill type that you want for the 

entity.
Select Solid Fill, if you want the fill color to be solid.
Select Transparent Fill, if you want the fill color to be transparent.
Select No Fill, if you do not want any fill color.

4 Click OK. 
The fill type changes for the selected entity or entities.
Note  Any new entities that you create will have the new fill type.

Assigning an Entity the Same Color as the 
Layer
1 Select the entity or entities for which you want to assign the color of the 

layer that they belong to.
See   Selecting Markup Entities

2 Select Markup > Entity Color from the Markup menu.
The Entity Color dialog appears.
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3 To assign the line color, select the  BYLAYER from the Line Color 
drop-down list.

Note  You can also click the Line Color icon  from the Markup toolbar.

4 To assign the fill color, select the  BYLAYER from the Fill Color drop-
down list.

Note  You can also click the Fill Color icon  from the Markup toolbar.
5 Click OK.

The selected entity or entities change to the color of the layer that the entity 
belongs to.

Deleting Markup Entities
1 Select the entity or entities that you want to delete.

See   Selecting Markup Entities
2 Select Markup > Delete from the Markup menu.

The selected entity or entities are deleted from the current active file.
Note  To delete all entities, select Markup > Delete All from the Markup 
menu. Delete All will delete all existing entities from the active markup, 
whether they are visible or not. 

Modifying Measurement Markup Entities
In AutoVue, you can modify the font of a measurement.
1 Create the markup measure entity that you want.

See   Creating 2D non-vector Markup Measure Entities
 Creating 2D Vector Markup Measure Entities

2 Double-click the measurement for which you want to modify the font.
The appropriate Measure dialog appears.

3 Click Font. The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the font Style(s), then click OK. 

4 Click OK to close the appropriate Measure dialog.
The measurement font is modified.
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Changing Measurement Units and 
Symbols
In AutoVue, you can change the unit of measure and add a symbol to a 
measurement and have it appear on the drawing.
1 Create the markup measure entity that you want.

See   Creating 2D non-vector Markup Measure Entities
 Creating 2D Vector Markup Measure Entities

2 Double-click the measurement that you want to change the unit of measure 
or add a symbol to.
The appropriate Measure dialog appears.

3 Clear the checkmark beside Display Unit if you want to hide the unit on the 
drawing. Unit appears by default.

4 From the Units drop-down list, select the unit that you want to change the 
measurement to.

5 From the Symbol drop-down list, select the symbol that you want to add to 
the measurement.

6 Click OK.
The unit of measure changes and the selected symbol is added to the 
measurement and appears in the workspace.

Marking Up 2D Files
AutoVue provides a variety of user-friendly markup options that you can use 
when marking up 2D files. You can create entities such as arcs, boxes, circles, 
clouds, lines and polygons. You can draw a leader with multi-line segments and 
add text to it. You can also add a symbol, add text to an entity or add information 
by adding a note. 

2D Markup Entities
In AutoVue, you can drawing many different types of entities. You can access the 
entities from the Entities menu in Markup mode. The entities are:

Option Description

Note  Right click to complete an entity.
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Arc Click and drag the mouse to draw an arc.

From the toolbar click  icon.

Box Click and drag to draw a rectangle.

From the toolbar click  icon.
Note  To draw a square instead of a rectangle, press and 
hold the Shift key while you click and drag.

Closed Polyline Click and drag to draw a closed Polyline.

From the toolbar click  icon.

Cloud Click and drag to draw a cloud.

From the toolbar click  icon.

Circle Click and drag to draw a ellipse.

From the toolbar click  icon.
Note  To draw a circle instead of an ellipse, press and hold 
the Shift key while you click and drag.

Filled Box Click and drag to draw a filled box. The box is filled with a 
solid color.

From the toolbar click  icon.
Note  To draw a square Filled Box instead of a rectangular 
Filled Box, press and hold the Shift key while you click and 
drag.

Freestyle Click, release mouse button, then drag to draw an entity.

From the toolbar click  icon.
Note  You can create a contiguous or non-contiguous 
freestyle entity.
See   Creating a Non-contiguous Freestyle Entity
See    Creating a Contiguous Freestyle Entity

Highlight Click and drag to highlight a boxed area.

From the toolbar click  icon.
Note  The highlighted box will be filled with a transparent 
color.

Option Description
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Leader Click and drag to draw a leader. 

From the toolbar click  icon.
Note  To force a line segment in a Leader entity to be 
aligned to the closer axis, horizontal or vertical axis, hold the 
Shift key while you click and drag for that line segment.
See    Adding a Leader
See   Forcing a Line Segment

Line Click and drag to draw a line.

From the toolbar click  icon.
Note  To draw a line and force it to be aligned to the closer 
axis, horizontal or vertical, press and hold the Shift key 
while you click and drag.
See    Forcing a Line Segment

Note Add a note to the Markup.

From the toolbar click  icon.
See    Adding a Note

Polyline Click and drag to draw a polyline.

From the toolbar click  icon.
Note  To force a line segment in a Polyline entity to be 
aligned to the closer axis, horizontal or vertical, press and 
hold the Shift key while you click and drag for that line 
segment.
See    Forcing a Line Segment

Symbol Click and drag a symbol to the Markup.

From the toolbar click  icon.
See    Adding a Symbol

Text Add text to the Markup.

From the toolbar click  icon.

See    Adding Text

Option Description
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Creating a Non-contiguous Freestyle 
Entity
1 Select Entities > FreeStyle from the Markup menu.

Note  You can also click the Freestyle icon  from the Markup toolbar.
2 Click a point on the drawing where you want to start the freestyle entity.
3 Move the cursor to create the freestyle entity.
4 Click a point on the drawing where you want to interrupt the freestyle entity.
5 Click another point on the drawing where you want to restart the freestyle 

entity.
Note  You can interrupt the freestyle entity as many times as you like by 
repeating steps 4 and 5.

6 Right-click to end the freestyle entity.

Creating a Contiguous Freestyle Entity
1 Select Entities > FreeStyle from the Markup menu.

Note  You can also click the Freestyle icon  on the Markup toolbar.
2 Click a point on the drawing where you want to start the freestyle entity.
3 Move the cursor to create the freestyle entity.
4 Right-click to end the freestyle entity.

Adding a Leader
1 Select Entities > Leader from the Markup menu.

Note  You can also click the Leader icon  from the Markup toolbar.
2 Click a point on the document where you want the leader to start.
3 Move the cursor to draw the leader.

Note  To draw a leader and force it to be aligned to the closest axis, vertical 
or horizontal, hold the Shift key while moving the cursor.

4 To draw a leader with multiple line segments, repeat steps 2 and 3 as often as 
you like. You can click, then drag as often as you like. 

5 Right-click to end the leader.
The Text dialog appears.

6 To change the font, click Font. The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the checkbox beside the font style(s).
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Type the text that you want to attach to the leader, then click OK.
7 Right-click outside the text area to complete the modification.

The leader appears on the drawing and in the Markup Navigation Tree.
Note  To edit the leader text, double-click the leader in the Markup 
Navigation Tree or in the workspace to open the Text dialog.
See Also   Forcing a Line Segment

Forcing a Line Segment to Become 
Horizontal or Vertical
You can draw a line segment and force it to be aligned with the closer axis, 
horizontal or vertical. You can also take an existing line segment and have it align 
with the closer axis. The types of line segments that you can align are lines, line 
segments of leaders and polylines, and measure entities.
Note  This procedure only works for measure entities that are drawn using Free 
snap. 
1 To draw and force a line segment, press and hold the Shift key while you 

click and drag for that line segment.
To force an existing line segment, click and hold the left mouse button on the 
line segment, then press and hold the Shift key.

2 When you see that the line segment is horizontal or vertical, release the left 
mouse button, then release the Shift key.

Adding Text
With AutoVue, you can add text entities to a markup.
1 Select Entities > Text from the Markup menu.

Note  You can also click the Text icon  from the Markup toolbar.
2 Click a point on the drawing where you want to add text.

The Text dialog appears.
3 To change the font, click Font. The Font dialog appears.

From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
Select the checkbox beside the font style(s).
Type the text that you want to add, then click OK.

4 Right-click outside the text area to complete the modification.
The text appears on the drawing and in the Markup Navigation Tree.

5 To move the text box click and drag it. 
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6 Click and drag the frame handles to enlarge the text box.
Note  To edit text, double-click the text in the Markup Navigation Tree 
or in the workspace to open the Text dialog.

Adding a Note
You can attach longer comments and notes to a markup with AutoVue’s Markup 
Control Note Editor. A note is represented by a standard size graphical symbol 
labelled Note. To read the text inside, double-click the entity to open it or move 
the mouse over the entity to display the tooltip.
1 Select Entities > Note from the Markup menu.

Note  You can also click the Note icon  from the Markup toolbar.
2 Click a point on the document where you want to insert the note. 

The Note dialog appears.
3 Enter the text that you want in the note.
4 To change the default font, select Font and the type of font.
5 Close the Note dialog.

The note appears on the drawing and in the Markup Navigation Tree.
6 Right-click outside the note area to complete the modification.
7 To move the note, click and drag it.

Note  To edit a note, double-click the note symbol  in the Markup 
Navigation Tree or in the workspace to open the Note dialog.

Adding a Symbol
A symbol is a graphical entity, such as a company logo. With AutoVue, you can 
add a symbol to a markup.
1 Select Entities > Symbol from the Markup menu.

The Symbols dialog appears.

Note  You can also click the  icon in the Markup toolbar.
2 Click the Symbols tab.
3 From the Symbol Library drop-down list, select the symbol library that 

you want.
The symbols appear for the selected library.

4 Click Isotropic if you want to scale the symbol proportionately. 
Click Anisotropic if you want to scale the symbol disproportionately.

5 Click and drag the symbol onto the workspace.
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6 Release the mouse button. 
The symbol appears on the drawing and in the Markup Navigation Tree
Note  To add more symbols, repeat steps 3 to 5.

7 Click OK. 

Working with Hyperlinks
A hyperlink is a link between the current file and the new file or application. You 
can create hyperlinks within your current file so that your files and applications 
outside AutoVue are only a click away. The main benefit of adding hyperlinks to 
a file is that you can gather all files of related information into one file with the 
files kept separate. In other words, the files may be accessible from one location 
but the information is referenced, not duplicated. This ensures a manageable file 
size when loading. If changes need to be made to a linked file, they need to be 
done in one location — to the linked file itself.

Creating a Hyperlink
When you create a hyperlink, you can choose where to open the hyperlinks.

1 Select Markup > Hyperlink > Establish from the Markup menu.
2 Click a point on the document where you want to place the hyperlink.

The Establish Hyperlink dialog appears.
3 Enter a Link Name.
4 Enter a Description (optional).
5 Type the URL or click Browse to locate the file that you want to link to.
6 From the Link to drop-down list, select the type of link.

For example, Data File opens a document file, whereas Application open 
an application other than AutoVue.

Open in Description

Applet Opens the file in another AutoVue window.

Current Applet Opens the file in the current AutoVue window.

Browser Opens the file in the default browser window.

Current Browser Opens the file in the current browser window.
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7 From the Open in drop-down list, select where you want the hyperlink to 
open.

8 Click OK.
The hyperlink appears on the Markup.

Firing a Hyperlink
1 To fire a hyperlink, double-click on it from the workspace.

The hyperlink file opens in the window you selected in the Establish 
Hyperlink dialog.
Note  You can also fire a hyperlink by selecting it, then right-clicking and 
selecting Hyperlinks > Fire from the pop-up menu or selecting Hyperlink 
> Fire from the Markup menu.

Editing a Hyperlink
1 In the Markup Navigation Tree or from the workspace, select the 

hyperlink that you want to edit.
2 Select Markup > Hyperlink > Edit from the Markup menu.

The Edit Hyperlink dialog appears.
Note  You can right-click a hyperlink in the Markup Navigation Tree 
and select Edit from the pop-up menu.

3 Edit the information that you want.
4 Click OK.

The changes are saved.

Deleting a Hyperlink
1 In the Markup Navigation Tree or from the workspace, select the 

hyperlink that you want to delete.
2 Select Markup > Hyperlink > Break or Markup > Delete from the 

Markup menu.
The hyperlink is deleted from the file.
Note  You can also delete a hyperlink by right-clicking it in the Markup 
Navigation Tree and selecting Delete from the pop-up menu.

Viewing List of Hyperlinks
1 Select Markup > Hyperlink > List from the Markup menu.

The List Hyperlinks dialog appears listing the hyperlinks.
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Note  You can right-click in the workspace and select Hyperlinks > List 
from the pop-up menu.
Note  You can fire a hyperlink by selecting the hyperlink and clicking Fire.

2 Click OK. 

Viewing History of a Hyperlink
AutoVue lets you view information about a hyperlink’s path. From a file that is 
launched from a hyperlink, you can see what document invoked the hyperlink.
1 From the hyperlink file, select File > Markup from the AutoVue main 

menu.
2 Select Markup > Hyperlink > History from the Markup menu.

The Hyperlink History dialog appears listing the path linking the 
hyperlink file to the file that invoked the hyperlink.

3 To jump to the file where you fired the hyperlink from, select the path in the 
Hyperlinks History dialog.

4 Click Jump to.
Note  You can also go back by right-clicking in the hyperlink file and 
selecting Go Back from the pop-up menu.

Creating 2D non-vector Markup 
Measure Entities
When marking up 2D non-vector files, in addition to all the markup options 
available for 2D files, you can create markup measure entities. The measure 
options in Markup mode work slightly different than in View mode. For 
information on marking up 2D files, see Marking Up 2D Files.
When measuring in Markup mode, the specified measurement lines and values 
are displayed on the current active markup layer as entities. These entities can be 
moved, resized, hidden or deleted. You can also modify the font of a measure 
entity, align a “free snap” measure entity to the horizontal or vertical axis, as well 
as add units of measure and symbols to a measurement and have them appear on 
the drawing.
Measure options vary between vector and non-vector files. For vector files, 
AutoVue provides the option to “snap” to fixed points on the drawing. For non-
vector files, you can only “free snap”.
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In Markup mode, you can choose from several measure options to create markup 
measure entities. You can access the measure options from the Analysis > 
Measure menu. The options are:

Measuring Distance
Use the Distance option to measure the distance between two specific points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the Markup toolbar.
2 Click the Distance tab.
3 From the Measured Distance Units drop-down list, select the unit in 

which you want to measure the distance.
4 Click a point on the drawing to define the starting point.
5 Click another point on the drawing to define the end point.

The measured line path appears as an entity on the current active markup.
6 Drag to move the measured line path.
7 Click on the measured line path.

The measurement and unit appear as an entity on the current active markup 
layer. The measured distance, Delta-X and Delta-Y appear in the 
Measurement dialog.

Option Description

Angle Measure the angle between selected points.

From toolbar click  icon.

Arc Measure an arc entity.

From toolbar click  icon.

Area Measure a selected area.

From toolbar click  icon.

Distance Measure the distance between two points.

From toolbar click  icon.
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8 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring Cumulative Distance
Use the Cumulative Distance option to measure the distance along a path of 
multi-faceted (adjoining) points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the AutoVue toolbar.
2 Click the Distance tab.
3 From the Measured Distance Units drop-down list, select the unit in 

which you want to measure the distance.
4 Select Cumulative.
5 Click a point on the drawing to define the starting point.
6 Continue clicking points along the path that you want to measure.

Each point is joined by a line. 
7 Right-click to complete the measurement.

The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The cumulated measured distance, Delta-X and 
Delta-Y appear in the Measurement dialog.

8 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Calibrating Distance
1 Measure the distance between two points or measure cumulative distance.

See   Measure Distance
2 In the Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured 
distance.
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3 In the Distance drop-down list, select the unit to which you want to 
calibrate the distance.
Click Calibrate to and enter a value if you want to calibrate the distance to 
a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

4 Click OK. 
The calibration result appears in the Measurement dialog.

5 Click Close to close the Measurement dialog.

Measuring Area
Use the Area option to measure the area and perimeter of a region.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Area is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.The Measurement 

dialog appears.

Note  You can also click the Area icon  on the Markup toolbar.
2 Click the Area tab.
3 From the Measured Area Units drop-down list, select the unit in which 

you want to measure the area.
From the Perimeter Units drop-down list, select the unit in which you 
want to measure the perimeter.

4 To cumulate a Net Area Result of different areas, select Add in the 
Measurement dialog. 
To subtract an area from the Net Area Result, select Subtract. 
Select Clear to clear the Net Area Result.

5 Click a point on the drawing to define the starting point.
6 Continue clicking points on the drawing to define the area you want to 

measure.
Each point is joined by a line. 

7 Right click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The area and perimeter measurements appear in 
the Measurement dialog.

8 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities
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Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
Note  If you want a markup entity for the measurement, you must ensure that 
Add dimensions is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the Markup toolbar.
2 Click the Angle tab.
3 From the Measured Angle Units drop-down list, select the unit in which 

you want to measure the angle.
4 Click points on the drawing to define the angle you want to measure.

The points are joined by angle arms with an arc connecting them. 
5 Click again to complete the measurement. 

The measured line path, angle measurement and unit appear as an entity on 
the current active markup layer and in the Measurement dialog.

6 Click and drag to change the size of the arc.
7 Click and drag the frame handles to change the size of the box.

Note  Click Reset to take another measurement.
8 Click Close to close the Measurement dialog.

See Also   Modifying Measurement Markup Entities

Measuring an Arc
Use the Arc option to define an arc in the drawing and measure its radius, center 
and diameter.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Radius or Add Diameter is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the Markup toolbar.
2 Click the Arc tab.
3 From the Arc Info drop-down list, select the unit in which you want to 

measure the arc.
4 From the Measured Angle Units drop-down list, select the unit in which 

you want to measure the angle.
5 Select Add Radius if you want to measure the radius of the arc.
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Select Add Diameter if you want to measure the diameter of the arc.
6 Click points on the drawing to define the arc you want to measure.

The points are joined by an arc. 
7 Click again to complete the measurement.

The measured line path, arc measurement and unit appear as an entity on the 
current active markup layer and in the Measurement dialog.

8 Click and drag the box anywhere on the drawing.
Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

9 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Calibrating an Arc
1 Measure an arc in the drawing.

See   Measuring an Arc
2 In the Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured 
distance.

3 From the Distance drop-down list, select the unit to which you want to 
calibrate the distance.
Click Calibrate to and enter a value if you want to calibrate to a value.
Click Set Factor and enter a value if you want to calibrate by a factor.

4 Click OK. 
The calibration result appears in the Measurement dialog.

5 Click Close to close the Measurement dialog.

Creating 2D Vector Markup 
Measure Entities
When marking up 2D vector files, in addition to all the markup options available 
for 2D files, you can create markup measure entities. The measure options in 
Markup mode work slightly different than in View mode. For information on 
marking up 2D files, see Marking Up 2D Files.
Measure options vary between vector and non-vector files. For vector files, 
AutoVue provides the option to “snap” to fixed points on the drawing. For non-
vector files, you can only “free snap”.
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When measuring in Markup mode, the specified measurement lines and values 
are displayed on the current active markup layer as entities. These entities can be 
moved, resized, hidden or deleted. You can also modify the font of a measure 
entity, align a “free snap” measure entity to the horizontal or vertical axis, as well 
as add units of measure and symbols to a measurement and have them appear on 
the drawing.
In Markup mode, you can choose from several measure options to create markup 
measure entities. You can access the measure options from the Analysis > 
Measure menu. The options are:

2D Vector Snapping Modes
The Snapping Modes available allow you to click to precise geometrical 
points on a drawing. For example, if you select Snap to end-point and you 
move the cursor over an end-point of a line, the end-point will be highlighted by 
a snap box. 

Option Description

Angle Measure the angle between selected points.

From toolbar click  icon.

Arc Measure an arc entity.

From toolbar click  icon.

Area Measure selected area.

From toolbar click  icon.

Distance Measure the distance between two points.

From toolbar click  icon.
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The Snapping modes allow you to snap to the mid, center and end-points of 
an entity:

Measuring Distance
Use the Distance option to measure the distance between two specific points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the Markup toolbar.
2 Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes

4 From the Measure Distance Units drop-down list, select the unit in 
which you want to measure the distance.

5 Click a point on the drawing to define the starting point.
6 Click another point on the drawing to define the end point.

The measured line path appears as an entity on the current active markup.
7 Drag to move the measured line path.
8 Click on the measured line path.

Icon Snap to Description

End-point Geometric snap mode where a snap box appears 
when moving the cursor near a linear component’s 
end point.

Mid-point Geometric snap mode where a snap box appears 
when moving the cursor near the halfway point of a 
linear component.

Center-point Geometric snap mode where a snap box appears 
when moving the cursor near the center of an 
elliptical component.

Free snap Allow snapping at any point on the drawing.
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The measurement and unit appear as an entity on the current active markup 
layer. The measured distance, Delta-X and Delta-Y appear in the 
Measurement dialog.

9 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

10 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring Cumulative Distance
Use the Cumulative Distance option to measure the distance along a path of 
multi-faceted (adjoining) points.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Distance is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Distance icon  on the Markup toolbar.
2 Click the Distance tab.
3 Select the Snapping Modes that you want to use for measuring.

To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes

4 From the Measured Distance Units drop-down list, select the unit in 
which you want to measure the distance.

5 Select Cumulative. 
6 Click a point on the drawing to define the starting point.
7 Continue clicking points along the path that you want to measure.

Each point is joined by a line. 
8 Right-click to complete the measurement.

The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The cumulated measured distance, Delta-X and 
Delta-Y appear in the Measurement dialog.

9 Click and drag the frame handle to change the size of the box.
Note  Click Reset to take another measurement.

10 Click Close to close the Measure Distance dialog.
See Also   Modifying Measurement Markup Entities
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Calibrating Distance
1 Measure the distance between two points or measure cumulative distance.

See   Measuring Distance
2 In the Measurement dialog, click Calibrate.

The Distance Calibration dialog appears displaying the measured 
distance.

3 In the Measured Distance drop-down list, select the unit to which you 
want to calibrate the distance.
Click Calibrate to and enter a value if you want to calibrate the distance to 
a value.
Click Set Factor and enter a value if you want to calibrate the distance by a 
factor.

4 Click OK. 
The calibration result appears in the Measurement dialog.

5 Click Close to close the Measurement dialog.

Measuring Area
Use the Area option to measure the area and perimeter of a region.
Note  If you want a markup entity for the measurement, you must ensure that 
Add Area is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Area icon  on the Markup toolbar.
2 Click the Area tab.
3 Select Between Points if you want to measure the area between points on 

a drawing. Snapping Modes are enabled.
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes

4 Select Shape if you want to measure the area of a predefined shape on the 
drawing. Snapping Modes are disabled.

5 From the Measured Area Units drop-down list, select the unit in which 
you want to measure the area.

6 From the Perimeter Units drop-down list, select the unit in which you 
want to measure the perimeter.
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7 To cumulate a Net Area Result of different areas, select Add in the 
Measurement dialog. 
To subtract an area from the Net Area Result, select Subtract. 
Select Clear to clear the Net Area Result.

8 If you selected Between Points, click points on the drawing to define the 
area, then right click to complete the measurement.
Each point is joined by a line. The measured line path, measurement and unit 
appear as an entity on the current active markup layer. The area and 
perimeter measurements appear in the Measurement dialog.

9 If you selected Shape, click the edge of a predefined shape on the drawing.
The shape is highlighted. The measured line path, measurement and unit 
appear as an entity on the current active markup layer. The area and 
perimeter measurements appear in the Measurement dialog.

10 Click and drag the frame handles to change the size of the box.
Note  Click Reset to take another measurement.

11 Click Close to close the Measurement dialog.
See Also   Modifying Measurement Markup Entities

Measuring an Angle
Use the Angle option to measure the angle between points on a drawing.
Note  If you want a markup entity for the measurement, you must ensure that 
Add dimensions is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Angle icon  on the Markup toolbar.
2 Click the Angle tab.

Select From 3 Points if you want to measure the angle between three 
points. Snapping Modes are enabled. 
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes

3 Select Between 2 lines if you want to measure the angle between two 
lines. Snapping Modes are disabled.

4 From the Measured Angle Units drop-down list, select the unit in which 
you want to measure the angle.
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5 If you selected From 3 Points, click three points on the drawing to define 
the angle.
If you selected Between 2 Lines, click two lines on the drawing to define 
the angle.
Angle arms appear with an arc connecting them. 

6 Click to complete the measurement. 
The measured line path, measurement and unit appear as an entity on the 
current active markup layer. The measured angle appears in the 
Measurement dialog.

7 Click and drag to change the size of the arc.
8 Click and drag the box anywhere on the drawing.
9 Click and drag the frame handles to change the size of the box.

Note  Click Reset to take another measurement.
10 Click Close to close the Measurement dialog.

See Also   Modifying Measurement Markup Entities

Measuring an Arc
Use the Arc option to define an arc in the drawing and measure its radius, center 
and diameter.
Note  To create a markup entity for the measurement, you must ensure that Add 
Radius or Add Diameter is selected in the Measurement dialog.
1 Select Analysis > Measure from the Markup menu.

The Measurement dialog appears.

Note  You can also click the Arc icon  on the Markup toolbar.
2 Click the Arc tab.
3 Select From 3 Points if you want to measure the arc between three points. 

Snapping Modes are enabled. 
Select the Snapping Modes that you want to use for measuring.
To select all Snapping Modes click All On. To clear all Snapping 
Modes click All Off.
See   2D Vector Snapping Modes

4 Select Arc Entity if you want to measure a predefined arc. Snapping 
Modes are disabled.

5 From the Arc Info drop-down list, select the unit in which you want to 
measure the distance.

6 From the Measure Angle Units drop-down list, select the unit in which 
you want to measure the angle.
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7 Select Add Radius if you want to measure the radius.
Select Add Diameter if you want to measure the diameter

8 If you selected From 3 Points, click three points to define the arc, then 
click to complete the measurement
The points are joined by an arc. 
If you selected Arc Entity, click the edge of the arc that you want to 
measure. The arc is highlighted.

9 Click to complete the measurement.
The measured line path, measurement and unit appear as an entity on the 
current active markup layer.The measurements for center point coordinates, 
radius, diameter, arc length, start and end of angle and sweep appear in the 
Measurement dialog.

10 Click and drag the box anywhere on the drawing.
11 Click and drag the frame handles to change the size of the box.

Note  Click Reset to take another measurement.
12 Click Close to close the Measurement dialog.

See Also   Modifying Measurement Markup Entities

Calibrating an Arc
1 Measure an arc in the drawing.

See   Measuring an Arc
2 In the Measurement dialog, click Calibrate.

The Radius Calibration dialog appears displaying the measured distance.
3 From the Measured Rad. drop-down list, select the unit to which you want 

to calibrate the distance.
Click Calibrate to and enter a value if you want to calibrate to a value.
Click Set Factor and enter a value if you want to calibrate by a factor.

4 Click OK. 
The calibration result appears in the Measurement dialog.

5 Click Close to close the Measurement dialog.
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Printing
With AutoVue, you can print and preview files. Original files can be printed on 
their own or with associated Markups and Overlays. 
With the Batch Print option, you can send a list of files to print at the same 
time.
When printing a file, there are print properties that you can define. The properties 
are:

Print Options
From the Options tab of the Print Properties dialog, you can define options 
for the printed file.

Option Description

Print Define the print options.
See   Configuring the Print Options

Margins Define the margin settings.
See   Setting the Print Margins

Headers/Footers Define the headers/footers to be included on every page 
printed.
See   Adding a Header/Footer

Watermark Define the watermark to be included on every page printed.
See  Adding a Watermark

Pen Settings Change the thickness assigned to a pen.
See   Assigning Pen Settings

Option Type Description

Printer Modify Select a printer and configure print proper-
ties, such as paper size, number of copies, etc.

Paper size Displays selected paper size.
Cimmetry Systems Corp.



74 AutoVue
Orientation • Portrait - Specify if file should be 
printed portrait 

• Landscape - Specify if the file should 
be printed landscape

• Auto - Specify if orientations should be 
printed as saved in the file
Note  Option is available with Java 2 
and is only enabled for PDF and word 
documents.

Units Select a unit from the drop-down list to set 
the unit for Scaling and Alignment/Off-
set. The available units are pixels, inches and 
millimeters.

Scaling Fit to Page Scales the image to fit on the output page.

Factor Scales the image according to the scaling fac-
tors that you have manually entered in the 
input fields.

Scale Scales the image according to a percentage. 
You can select a predefined scaling factor or 
manually enter a custom scaling factor.
Note   Decimal places are accepted.

Alignment/Offset Specify where the drawing will appear on the 
printout. Some of the available options are 
Top-Left, Center-Right, Bottom-Center, etc.
Note  You can define custom alignment by 
entering a X and Y value.

Document Pages Specify the document pages to print: All, 
Current or Range.

Page Area Select the page area to print.

Extents Print the extent of the document.

Displayed Print the area displayed in the View window.
Note  Option is only enabled when 
Current is selected for Document Pages.

Option Type Description
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Limits Prints the file limits instead of extents.
Note  Option is only enabled when 
Current is selected for Document Pages.

Selected Print selected area. When option is selected, 
the select button is enabled allowing you to 
select an area on the drawing.
Note  Option will only be enabled when 
Current is selected for Document Pages.

Force to Black Force all colors to black.

High Resolution Prints the file with more definition.
Note   AutoVue Client Server Edition is 
based on Java 1.1 to make it compatible with 
the current browsers. One drawback with 
Java 1.1 is its limited support for printing -- 
the print resolution is limited to 72 dpi. 
AutoVue implements and delivers this limited 
print capability as part of the package. 
Cimmetry has identified the need for higher 
resolution and has implemented a solution for 
High Resolution and Large Format printers/ 
plotters output for client machines running on 
a Windows platform.

Output a single page Limits output to a single page when the scal-
ing options selected causes a single page to 
span over several pages.

Print Row Headers Print row headers.
Note  Option is only enabled for 
spreadsheets, archive and database files.

Print Column Head-
ers

Print column headers.
Note  Option is only enabled for 
spreadsheets, archive and database files.

Partial Preview Display a view of the printer page, highlight-
ing the printable area.

Option Type Description
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Configuring the Print Options
1 Select File > Print from the AutoVue main menu.

The Print Properties dialog appears.

Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Options tab.
3 Configure the print options.

See   Configuring Print Options
4 Configure other print properties.

See   Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Assigning Pen Settings

5 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
See   Partial Preview of a File

6 Click OK to print.
The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Print Margins
From the Margin tab of the Print Properties dialog, you can define the top, 
bottom, right and left margins for the printed file. You can define:

Setting the Margins
1 Select File > Print from the AutoVue main menu.

The Print Properties dialog appears.

Option Description

Margins Set the value for the Left, Top, Right and Bottom margins.

Minimum Set the acceptable minimum margins for the selected printer.

Units Specify the unit for the margins.
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Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Margins tab.
3 Enter the margin that you want for Left, Top, Right and Bottom or click 

Minimum if you want to set the margins to the minimum acceptable for the 
selected printer.
Note  When you click Minimum, the minimum margins allowable 
automatically appear in the Margins.

4 From the Units drop-down list, select the unit in which you want to set the 
margins at.

5 Configure other print properties.
See   Configuring Print Options

 Adding a Header/Footer
 Adding a Watermark
 Assigning Pen Settings

6 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
See   Partial Preview of a File

7 Click OK to print.
The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Headers/Footers
From the Headers/Footers tab of the Print Properties dialog, you can 
define the headers and footers that you want to print on every page of the 
document. You can enter the text manually or choose from a list of Insert 
Codes.
The list of insert codes are:
• %f: Full path of document
• %v: Document Drive
• %d: Document Directory
• %b: Document Base name
• %e: Document file extension
• %n: Total document pages
• %p: Current page number
• %N: Total tiled-pages
• %P: Current tile number
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• %Y: Date: Year
• %M: Date: Month
• %D: Date: Day
• %W: Date: Day of week
• %H: Time: Hour
• %U: Time: Minute
• %S: Time: Seconds
• %r: New line
• %F: Native Print Settings (Excel)
Note  A literal percentage mark is entered manually as %%.
You can also print system variables in headers and footers. Select a variable from 
the Insert Variable drop-down list. Some Insert Variable options are: 
user.name, browser and java.home.

Adding a Header and Footer
1 Select File > Print from the AutoVue main menu.

The Print Properties dialog appears.

Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Headers/Footers tab.
3 Click in the Left, Center or Right box and enter the text that you want to 

appear in the header and footer, or choose an Insert Code or Insert 
Variable.

4 To Insert Code in the header or footer, click Left, Center or Right, then 
select a code from the drop-down list.

5 To Insert Variable in the header or footer, click Left, Center or Right, 
then select a variable from the drop-down list.

6 To change the Font, click Set Font. The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
To set the font Style, click Bold or Italic or both, then click OK.

7 In the Print Properties dialog, configure other print properties.
See   Configuring Print Options

 Setting the Print Margins
 Adding a Watermark
 Assigning Pen Settings

8 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
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See   Partial Preview of a File
9 Click OK to print.

The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Native Print Settings
You can choose to included predefined headers and footers when printing an 
Excel file from AutoVue. 
1 From the Print Properties dialog, click the Headers/Footers tab.
2 Under Headers and Footers, click inside the Left, Center and Right 

boxes corresponding to the header or footer position in the original file.
3 Select %F: Native Print Settings (Excel) from the Insert Code drop-

down list.
4 Click OK to print.

The Excel file’s headers and footers are printed.

Watermarks
From the Watermark tab of the Print Properties dialog, you can specify a 
watermark that will appear on a printed file. When printing a watermark, it 
appears transparent on the file contents. You can choose a horizontally or 
vertically oriented watermark.
In addition to entering text, you can:
• set the type, size and style of font
• insert Watermark information
• print system variables
To insert Watermark information, AutoVue provides a list of codes that you can 
choose from. These codes are:
• %f: Full path of document
• %v: Document Drive
• %d: Document Directory
• %b: Document Base name
• %e: Document file extension
• %n: Total document pages
• %p: Current page number
• %N: Total tiled-pages
• %P: Current tile number
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• %Y: Date: Year
• %M: Date: Month
• %D: Date: Day
• %W: Date: Day of week
• %H: Time: Hour
• %U: Time: Minute
• %S: Time: seconds
• %r: New line
Note  A literal percentage mark is entered manually as %%.
You can also print system variables in watermarks. Select a variable from the 
Insert Variable drop-down list. Some Insert Variable options are: user.name, 
browser and java.home.

Adding a Watermark
1 Select File > Print from the AutoVue main menu.

The Print Properties dialog appears.

Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Watermark tab.
3 Enter the Watermark Text that you want to appear on the file.

To insert a code in the watermark, select a code from the Insert Code drop-
down list.
For example, if you select %n: Total document pages, the total number 
of pages for the selected file will appear in the Watermark.
Note  You can insert more than one code.

4 To insert a system variable, select a variable from the Insert Variable drop-
down list.
For example, if you select browser.version, the version of the browser 
that the file is displayed in will appear in the Watermark.
Note  You can insert more than one system variable.

5 To set the orientation of the watermark, click Diagonal, Horizontal or 
Vertical.

6 To change the Font, click Set Font.The Font dialog appears.
From the Font drop-down list, select the type of font.
From the Size drop-down list, select the size of font.
To set the font Style, click Bold or Italic or both, then click OK.

7 In the Print Properties dialog, configure other print properties.
See   Configuring Print Options
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 Setting the Print Margins
 Adding a Header/Footer
 Assigning Pen Settings

8 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
See   Partial Preview of a File

9 Click OK to print.
The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Assigning Pen Settings
From the Pen Settings tab of the Print Properties dialog, you can set the 
thickness of the color indices for the print file.
Note  AutoVue uses the default pen color indices of the native document for the 
vector file being viewed. You will not be able to change the color assigned to a 
pen with AutoVue.
1 Select File > Print from the AutoVue main menu.

The Print Properties dialog appears.

Note  You can also click the Print icon  on the AutoVue toolbar.
2 Click the Pen Settings tab.
3 Under From/To, select the Color Index for which you want to assign a 

new pen thickness.
Note  To change more than one color indices, press the Shift or Ctrl key 
while selecting.

4 From the Units drop-down list, select the unit that you want to set for the 
thickness.

5 Click Thickness. The Modify pen thickness dialog appears.
Enter the new thickness, then click OK.
The new Thickness appears beside the Color Index.

6 In the Print Properties dialog, configure other print properties.
See   Configuring Print Options

 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark

7 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
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See   Partial Preview of a File
8 Click OK to print.

The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Creating a New Pen Setting
1 Set the thickness for the color indices that you want.

See   Assigning Pen Settings
2 Click Save As. The Save As dialog appears.

Enter a pen Name for your pen setting, then click OK.
The new pen setting appears in the Current Pen Settings drop-down list.

3 In the Print Properties dialog, click OK to print.
The Print dialog appears indicating the document is printing.

Deleting a Pen Setting
1 Select the pen setting that you want to delete from the Current Pen 

Settings.
2 Click Delete.

The pen setting disappears from the list.
3 Click Cancel to close the Print Properties dialog.

Partial Preview of a File
The Partial Preview dialog displays the printable area on top of the page area 
so that users can have a clear idea of what will be printed.
Note  Option is only enabled when Current is selected from Document 
Pages.
1 Configure the print properties.

See   Configuring Print Options
 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Assigning Pen Settings

2 Click Partial Preview in the Print Properties dialog.
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The Partial Preview dialog appears.The Partial Preview dialog 
highlights the area that will be printed. The Paper size, Printable Area 
and Drawing Area are displayed.

3 Click OK to close the Partial Preview dialog.

Previewing a File Before Printing
You can preview a print copy of the current active file on screen according to 
your printer’s capabilities and the print property settings.
1 View the file in AutoVue.
2 Select File > Print Preview from the AutoVue main menu.

The Print Properties dialog appears.

Note  You can also click the Print Preview icon  on the AutoVue 
toolbar.

3 Configure the print properties.
See   Configuring Print Options

 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Assigning Pen Settings

4 Click OK.
The file appears in Print Preview Mode in the Print Preview window.
Note  You can print the file from the Print Preview window by clicking 
Print. You can also zoom in and out of a file, as well as navigate from one 
page to another of a multi-page file.

5 Click Close to close the Print Preview window.

Printing a File
In AutoVue you can print original files along with their Markup files and selected 
Markup layers together so that they appear as one file.
1 Open the file you want to print in AutoVue.

To print the associated Markups, open the Markup file(s) you want to print.
If you are printing Markup file(s) and you want to print the visible layers, 
select Modify > Markup Layers from the Markup menu, then from the 
Markup Layers dialog select the Markup layers you want visible.

2 Select File > Print from the AutoVue main menu.
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The Print Properties dialog appears.

Note  You can also click the Print icon  on the AutoVue toolbar.
3 Configure the print properties.

See   Configuring Print Options
 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Assigning Pen Settings

4 To view a partial view of the file, click Partial Preview. 
The Partial Preview dialog appears.
See   Partial Preview of a File

5 Click OK to print.
The Print dialog appears indicating the document is printing.
See Also   Previewing a File Before Printing

Batch Printing
With the Batch Print option you can send a list of files to print at the same time. 
You can also generate a batch by simultaneously opening all the files included in 
the batch print.
1 Select File > Batch Print from the AutoVue main menu.

The Batch Print dialog appears.
2 To add a file to the List of files to be printed, click Add. The File Open 

dialog appears.
Enter a File Name or click browse to locate the file you want to add, then 
click OK.
The file(s) appears in the List of files to be printed.
Note  To add more files to the list, repeat steps 2 to 4. To remove a file(s), 
select the file from the List of files to be printed and click Remove.

3 Click Print in the Batch Print dialog.
The Print Properties dialog appears.

4 Configure the print properties.
See   Configuring Print Options

 Setting the Print Margins
 Adding a Header/Footer
 Adding a Watermark
 Assigning Pen Settings
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5 Click OK to print.
The Print dialog appears indicating the document is printing.
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Collaboration
Collaboration option enables multiple users to review files interactively and 
simultaneously, thereby shortening the review process for documents.
Participants in a Collaboration Session assume different roles. Each 
Collaboration Session has a Host, a Controller and one or more users. These 
participants have varying privileges during the Collaboration Session.

Collaboration User Tree
When you are in a Collaboration Session, the bar on the left-hand side of the 
screen displays the Users and Markup Tree tabs, in addition to the tabs 
displayed when you are normally viewing a file. The Users tab displays the 
Username, the Layer Color representing the user, the In Session value and 
the user Status. The Markup Tree tab displays the Markup entities added to 
the file. 

The Host
The person who initiates the Collaboration Session is automatically the acting 
Host and Controller by default. The Host and Controller are not always the same 
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person. The acting Host can assign another user to be the Host by selecting 
Assign Host from the Collaboration menu.
The Host is the only one who can save the Session Markup. When initiating a 
Collaboration Session, the Host can specify the Markup to open; the host can also 
open a Markup file during a session. The Host can invite other users to join the 
Collaboration Session during the session or at initiation of the session. 

The Controller
The Controller is the person who controls the base file's view during the 
Collaboration Session. Other participants in the Collaboration Session can 
choose between displaying or hiding the Controller's View changes.
When a session is initiated, the Controller is also the Host. The Controller can 
change the base file anytime during the Collaboration Session. However, when 
the Controller is no longer the Host, opening a new file has to be approved by the 
acting Host.
At any time during a session, a participant who is not an Observer can request 
control of a Collaboration Session.

Lock
Any user who is not the Controller of the Collaboration Session can select Lock 
View from the Collaboration menu or click the Lock View icon  in the 
lower left part of the screen to display the Controller's View modifications on the 
base file and the other participants' modifications on the Markup file made during 
the Collaboration Session.
When you lock your view, the file displayed will have the same Configuration 
options the Controller has set in the Configuration menu.
Note  For all users, except for the Controller, view options are disabled.

Observer
Observers can take part in a Collaboration Session but cannot create Markup 
entities. They can observe and make comments in the Chat window. The Host 
can designate a user as an Observer when he invites him to the Collaboration 
Session. A user can also decide to take part as an Observer in the Collaboration 
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Session by selecting Observer in the Join Session dialog. There can be more 
than one Observer during a Collaboration Session.

Open URL
The Controller is the only user who can open a URL during a Collaboration 
Session. To open a URL, select Open URL from the File menu. The File Open 
dialog box appears where you specify the file to open. When AutoVue Client-
Server edition is integrated with a Document Management System (DMS), 
Open URL opens a DMS file.
You can work on this file opened through Open URL during the Collaboration 
Session. When the Host opens a URL, he or she is prompted to save the Session 
Markup from the Collaboration Session that was in session. When the Controller 
opens a URL, the Host still owns the Collaboration Session and is the only one 
who can save the Session Markup.

Pointer
The Pointer  is the cross-hair marker the Controller uses to point to a 
specific place in the file.

Session Information
The Session Information option is available from the Collaboration menu 
during a Collaboration Session. It displays the Session Subject (the name 
assigned to the Collaboration Session), the Session ID, the name of the base file 
viewed, the Host and the list of users participating.

Session Markup
This is the Markup file created during the Collaboration Session. All participants 
can add Markup entities to the Session Markup file.
Note  Only the Host can save the Session Markup. Save and Save As are 
disabled for all other users.
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Show Tracker
The Show Tracker option in the Collaboration menu is available to any user 
whose view is set to unlocked. When you select Show Tracker from the 
Collaboration menu, the Collaboration View window appears displaying a 
bird's eye view of the base file viewed and the Markup changes done during the 
Collaboration Session.
When you use Show Tracker, you can simultaneously track the Controller's 
base file view changes and everyone's Markup changes in the Collaboration 
View window while your main window display remains unaffected by anyone’s 
modifications. It is like having a locked view and an unlocked view on hand at 
the same time.

Collaboration Session
The Collaboration menu provides you with a means to initiate a Collaboration 
Session or join an existing session. When you initiate a Collaboration Session, a 
session object is created on the server and you are the Host and Controller of the 
session. The Host owns the Session Markup and is the only one who can save it 
and open an existing Markup. The Host can also invite other users during a 
session.

Initiating a Collaboration Session
When you initiate a Collaboration Session, a session object is created on the 
server. The session object is maintained for the duration of the Collaboration 
Session. When you initiate a session from View mode, you are the Host and the 
Controller of the session.
1 Select Collaboration > Initiate Session from the AutoVue main menu.

The Initiate Session dialog appears.
2 Under Session Subject, enter a session name.
3 If you want to open a Markup for the Collaboration Session, click Browse. 

See   Opening a Markup While Initiating a Session
4 Click Public if you want the Collaboration Session visible to others who 

may want to join the session. 
Click Private if you want the Collaboration Session only visible to the 
participants.

5 If you want to set a password for the Collaboration Session, enter a 
Password, then enter it again to Confirm.
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Note  If you selected Private and chose not to set password, when you 
click OK, a confirmation dialog appears asking if you are sure you do not 
want to set a password.

6 From the Users list, select the users that you want to invite.
7 Click Add.

The user you selected appears in the Invited list.
Note  To remove a user, select the user from the Invited list and click 
Remove.

8 To designate a user as an Observer, select the checkbox under Invited.
9 Click OK.

AutoVue goes into Collaboration mode and the session is started. The 
user(s) that are invited receive a tooltip notification that he or she has been 
invited to join the session. The notification message indicates Session Name, 
File and Initiator.

Changing a User’s Layer Color of a 
Session
1 In the Initiate Session dialog, click Layer Color.

The Layer Color dialog appears.
2 Select a Layer Color from the drop-down list or select Let user choose 

if you want the user to choose their own color.
3 Click OK.

In the Initiate Session dialog, the selected Layer Color appears beside 
the Username in the Invited list.

If you selected Let user choose, a custom color  appears beside the 
Username, indicating that the color can be changed By User.

Adding New Users to a Session
1 In the Initiate Session dialog, click Add New.

The Add User dialog appears.
2 Enter Username.
3 Select Observer if you want to designate the user as an Observer.
4 Select a Layer Color from the drop-down list or select Let user choose 

if you want the user to choose their own color.
5 Click OK.

The new user is added to the Invited list in the Initiate Session dialog.
Note  To add more than one user, repeat steps 1 to 5.
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Opening a Markup While Initiating a 
Session
1 Select Collaboration > Initiate Session from the AutoVue main menu.

The Initiate Session dialog appears.
2 Click Browse.

The Open markup dialog appears.
3 In the Markup list, select the checkbox beside the Markup that you want to 

open.
4 To import a Markup file, click Import.

The Select markup file to import dialog appears.
5 Locate the file that you want to open.
6 Click Open.
7 Click OK in the Open markup dialog.
8 In the Initiate Session dialog, select Session Markup if you want to 

open a Session Markup and keep the layer colors and Markup entities from 
the Collaboration Session.

9 Click OK.
The selected Markup appears in the Initiate Session dialog.

Opening a Markup During a Session
The Host can open Markups during a Collaboration Session. These Markups can 
be session markups created during Collaboration Sessions or any non-session 
Markup files.
1 During a Collaboration Session, select File > Open from the AutoVue main 

menu.
A confirmation dialog appears, prompting you to save the current Session 
Markup.

2 Click Yes or No.
The Open markup dialog appears.

3 Click the checkbox beside the Markup that you want to open.
4 To import a Markup file, click Import.

The Select markup file to import dialog appears.
5 Locate the file that you want to open.
6 Click Open.
7 In the Open markup dialog, select Session Markup if you want to open 

a Session Markup and keep layer colors and Markup entities from the 
Collaboration Session.

8 Click OK.
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The selected Markup appears in the Collaboration window.

Joining a Session
Note  If you do not want to receive any notifications to join Collaboration 
Sessions, select Collaboration > Do Not Disturb from the AutoVue main 
menu.
1 Select Collaboration > Join from the AutoVue main menu.

The Join Session dialog appears.

Note  You can also click the Join Session icon  on the status bar at the 
bottom of the workspace.

2 From the Session ID drop-down list, select the active session you want to 
join.

3 Enter the Session ID of the session you want to join.
4 Enter the Password if the Host has set one.
5 If you just want to be an Observer, select the checkbox.
6 If you want to select a layer color, click Layer Color.

The Layer Color dialog appears.
Note  The Layer Color is disabled if the Host did not select Let user 
choose when initiating the Collaboration Session or when you are invited 
to join the session.

7 Select a color from the drop-down list.
8 Click OK.
9 Click OK in the Join Session dialog.

You have joined the session.

Inviting Users During a Session
1 Select Collaboration > Invite from the AutoVue main menu.

The Invite dialog appears.
2 From the Users list, select the user(s) that you want to invite.
3 Click Add.

The user(s) you selected appears in the Invited list.
Note   You can add user(s) that are going to join the session at a later time 
by clicking Add New and entering the Username.

4 Click OK.
The user(s) receives a tooltip notification that he or she has been invited to 
join the session.
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Removing Users from a Session
1 Select Collaboration > Invite from the AutoVue main menu.

The Invite dialog appears.
2 From the Invited list, select the user(s) that you want to remove.
3 Click Remove.

The user(s) you selected appear in the Online list.
4 Click OK.

The user(s) receives a tooltip notification that he or she is no longer invited 
to the session. 

Assigning a Host During a Session
1 Select Collaboration > Assign Host from the AutoVue main menu.

The Assign Host dialog appears.
2 From the Users list, select the user that you want to assign as host.
3 Click OK.

The user you selected is now the host of the Collaboration Session.

Granting Control of a Session to Another 
User
When you initiate a Collaboration Session, you are the default Controller of the 
session until you relinquish control to another user. You may grant control to 
another user any time during the session. Once you grant control to another user, 
all other users will automatically lock their views to the new Controller.
1 Select Collaboration > Grant Control from the AutoVue main menu.

The Grant Control dialog appears.
2 From the Users list, select the user that you want to grant control to.
3 Click OK.

The user you selected has control of the Collaboration Session.

Saving a Session Markup
The Host owns the Session Markup and is the only one who can save it. 
1 At the end of the Collaboration Session, select File > Save As from the 

AutoVue main menu. 
The Save Markup File As dialog appears.

2 Enter the Markup ID.
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Note  The Markup Information is optional.
3 Click OK.

The session Markup is saved.

Closing a Session
Only a Host can close a Collaboration Session.
1 Select Collaboration > Close Collaboration Session from the 

AutoVue main menu.
The Save Markup dialog appears prompting you to save the Session 
Markup.

2 Click Yes.
All users are notified that the Collaboration Session is closed.

Requesting Control of a Session
1 Select Collaboration > Request Control from the AutoVue main menu.

Note  You can also click the Wand icon  on the status bar at the bottom 
of the workspace.
The Controller receives a message that you have requested control.

2 The Controller clicks Yes.
 You become the Controller of the Collaboration Session.
Note   If the Controller does not respond within 10 seconds, control is 
automatically granted to the user who requested it.

Tracking Changes
The Show Tracker option allows you to simultaneously track the Controller’s 
base file view changes and everyone’s markup changes while your markup file 
remains unchanged.
Note   You must be in an unlocked state before selecting Show Tracker.
1 Select Collaboration > Show Tracker from the AutoVue main menu.

You can now track changes without affecting your view. 

Unlocking a View
If you do not want to see the Controller’s view changes, clear the Lock View.
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1 Select Collaboration and deselect Lock View from the AutoVue main 
menu.
The checkmark disappears beside the Lock View option.

Note  You can also click the Unlock View icon  on the status bar.
2 Select Collaboration > Show Tracker if you want to simultaneously 

track the Controller’s base file view changes and everyone’s markup changes 
while your markup file remains unchanged.
You can now track changes without affecting your view. 
Note  The Show Tracker option is only available when a view is set 
unlock.

Locking a View
The Lock View option allows you view changes the Controller is making. When 
you select the Lock View option, you are also propagating your Markup 
modifications to the other participants in the session.
Note  Lock View is the default for all participants in a session.
1 Select Collaboration > Lock View from the AutoVue main menu. Lock 

View set by default.

Note  You can also click the Lock View icon  on the status bar at the 
bottom of the workspace. 
A checkmark appears beside the Lock View option and the Lock View icon 

 turns red on the status bar.

Viewing Session Information
1 Select Collaboration > Session Information from the AutoVue main 

menu.
The Session Information dialog appears displaying the Subject, 
Session ID, File Name, Host and Users of the session.

2 Click OK.

Leaving a Session
Only a Host can close a Collaboration Session. All other participants can leave a 
Collaboration Session and rejoin at a later time if it is still in session. 
Cimmetry Systems Corp.



96 AutoVue
1 Select Collaboration > Leave Collaboration Session from the 
AutoVue main menu.
The other participants are notified that you left the Collaboration Session 
and AutoVue returns to View mode.

Chat Window
The Chat Window, is a tool you can use to communicate with other users. You 
send each other messages via the Chat Window. The Chat Window is also 
useful in giving you Collaboration Session updates such as which users are 
present and which users have joined or left the session.
 At the end of the Collaboration Session, a transcript of the Chat Window is 
saved as a Note entity along with the Markup as the Collaboration Session 
Markup file. The Note entity contains session information such who the Host 
was, who was invited and session time and duration.
The Chat Window contains these menu options:

Sending a Message to Selected Users
1 Select Collaboration > Chat Window from the AutoVue main menu.

The Chat dialog appears.

Note  You can also click the Chat Window icon  on the status bar at the 
bottom of the workspace.

Menu Option Description

File Send Message Sends text messages to other users.

Print Prints the contents of the Chat window.

Quit Closes the Chat window.

Edit Copy Copy text from the Chat window.

Clear Clears all the text in the Chat window.

Select All Selects the entire text in the Chat window.

Options Users Displays the users in the Collaboration Ses-
sion.
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2 Click Selected users.
A list of Users appear in the Chat dialog.

3 Under Users, select the user(s) that you want to send the message to.
Note  To select more than one user, press the Shift or Ctrl key while 
selecting.

4 In the Send Message to: type your message.

5 Click the Send Message  button.
The private message is sent to the selected users of the Collaboration 
Session.

Sending a Message to All Users
1 Select Collaboration > Chat Window from the AutoVue main menu.

The Chat dialog appears.

Note  You can also click the Chat Window icon  on the status bar at the 
bottom of the workspace.

2 Click All Users.
3 In the Send Message to: type your message.

4 Click the Send Message  button.
The message is sent to all users in the Collaboration Session.
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