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Topics
• What is Open ESB?
• What is JBI?
• JBI and GlassFish
• Usage Scenario
• Open ESB Development & Deployment Enviornment
• SE's and BC's (available right now)
• NetBeans support of Open ESB
• Java EE SE, IEP SE, Aspect SE, etc
• IEP (Intelligent Event Processing) SE Demo
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Open ESB
• Open Source Enterprise Service Bus runtime implemented 

atop the Java Business Integration (JBI) foundation
> http://open-esb.org/

• Runs within Glassfish/
Sun App Server

http://open-esb.org/
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What Is JBI?
• Standard “meta-container” 

for integrated services
• Provides for plug-in:

> Service Engines (SE): business logic
> Binding Components:  

communications protocols
• Standard deployment model
• Loose coupling via WSDL 

message exchanges 
between WSDL described 
Services
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Normalized Message Router

• Key to interoperation between components
• Mediated Message Exchange
• Normalized Message

> Abstract Message (payload) +
> Message Properties (metadata)

• Message Exchange Pattern
> Support for simple communications primitives
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Administration

• Component Life Cycle (containers)
> Installation

• Packaging and Deployment to Components
> Service Units
> Service Assemblies
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JBI and ESBs
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JBI v2
• Submitted: 2007-03-13  (JSR 312)
• Public Review: mid-2007

> Looking more end-users on the EG
• Focus

> Administration of clustered / distributed enviros
> Better alignment with Java EE
> Interceptors
> Policy/capabilities
> Greater coverage of JBI enablement of Composite Apps
> Choreography
> SCA alignment
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JBI Support in GlassFish
• A JBI runtime has been integrated with GlassFish V2
• GlassFish admin console now supports JBI
• Java EE Service Engine act as the bridge between 

Java EE applications and JBI
• A Java EE application archive (ear/war/jar) can be 

packaged in a JBI composite application
• JBI runtime has been enhanced to adhere to the 

appserver clustering architecture
> Each instance in the appserver cluster will also have a JBI 

runtime in it
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JBI in Admin Console
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Usage Scenario: Loan Processing
• Loan Requestor Service:

> LoanRequestProcess
> WS-I BP
> BPEL Orchestration

> LoanProcessor
> JavaEE

> TransformReport
> XSLT

> LoanReportStore
> Business Partner thru FTP

> LoanReportMailer
> Legacy thru JMS
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Open ESB Environment

IDE Web Server

BPEL
Editor

Java EE
SE JBI Bus

XSLT

SE

HTTP

BC

FTP

BC

FTP

BC
Many More

SEs…

FTP

BC
Many More

BCs…

Ap
p 

Se
rv

er

XSLT
Editor

Composite
Application

Project

IEP Editor

Composite
Application

Manager

Runtime

BPEL

SE

Java EE

EJBs

Servlets

Java EE
SE JBI Bus

XSLT

SE

HTTP

BC

FTP

BC

FTP

BC
Many More

SEs…

FTP

BC
Many More

BCs…
Ap

p 
Se

rv
er

BPEL

SE

Java EE

EJBs

Servlets

Design-Time Management

3rd Party

Service

Platforms

3rd Party

Service

Platforms

Open Standard Based 
Service Bus
WS-Reliable Messaging
WS-Security
WS-FastInfoSet, …

Many More
EditorsMany More
Editors

IEP
Monitor

BPEL
Monitor

XSLT
Monitor

Many More
EditorsMany More
Monitors



24

OpenESB Architecture

Normalized Message Router

HTTP Binding 
Component

System 
Management 

Layer

Binding 
Component

Service EngineJava EE
Service Engine

EJB 
Application BPEL

Service Engine

Java EE Container 
(“App Server”)

EJB 
Application

Web 
Application

Web Container 
(“App Server”)

Web 
Application

External 
Service 

Consumer

JMX Based Admin tools 
(CAM / App Server Admin 

Console /NetBeans)

HTTP Binding 
Component

External 
Service 
Provider

JBI Container

Sun Java App Server 9.2 (Glassfish)



  
Service Engines (SE) &Service Engines (SE) &
Binding Components (BC)Binding Components (BC)
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JBI Components
• Service Engines

> BPEL SE
> XSLT SE
> JavaEE SE
> IEP SE
> ETL SE
> SQL SE
> Workflow SE

• Binding Comps
> MQSeries BC
> HL7 BC
> SAP BC
> SMTP BC
> HTTP BC
> JMS BC
> File BC
> CICS BC
> DCOM BC
> CORBA BC
> ...

• Other
> Clustering
> CASA
> JBI Mock
> WSIT Tech

• In Progress
> CAM
> Aspect SE
> Encoding SE
> Rules SE
> Scripting SE



27

open-esb.dev.java.net/Components.html
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Open ESB Package Ships Many SE's/BC's
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Types of SOA “NetBeans” Projects
• When creating a composite application, you typically 

use the following types of SOA “NetBeans” projects:
> BPEL Module project (NetBeans 6.0)
> XSLT Module project (NetBeans 6.0)
> SQL Module project (NetBeans 6.0)
> Composite Application project (NetBeans 6.0)
> IEP Module project (OpenESB package)
> Worklist Module project (OpenESB package)
> ETL (Extract, Transform, and Load) (OpenESB package)
> EDM (Enterprise Data Mashup) (OpenESB package)
> And more
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Types of SOA “NetBeans” Projects
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BPEL Module Project
• BPEL Module project is a group of source files 

which includes 
> XML Schema (*.xsd) files
> WSDL files
> BPEL files

• Within a BPEL Module project, you can author a 
business process compliant with the WS-BPEL 2.0 
language specification.

• Will be added to a Composite application as a JBI 
module
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Composite Application Project
• Composite Application project is a project whose 

primary purpose is to assemble a deployment unit 
for the Java Business Integration (JBI) server 
> BPEL Module projects must be added to a Composite 

Application project in order to be deployed to the BPEL 
runtime. 

• The Composite Application Project can also be 
used to create and execute test cases that can then 
be run, in JUnit fashion, against the deployed BPEL 
processes.
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Composite Application Project
• With a Composite Application project, you can:

> Assemble an application that uses multiple project types 
(BPEL, XSLT, IEP,  SQL, etc.)

> Configure external/edge access protocols (SOAP, JMS, 
SMTP, and others)

> Build JBI deployment packages
> Deploy the application image to the target JBI server
> Monitor the status of JBI server components and 

applications



35

Lots of Step by Step Tutorials
• http://www.netbeans.org/kb/60/ep-index.html



  
BPEL SEBPEL SE
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BPEL SE

• Standards
> BPEL 2.0 (subset)
> WSDL1.1

• BPEL SE Configuration
> num threads
> persistence
> failover

• BPEL Editor
> BPMN
> Debugger



  
Java EE SEJava EE SE
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JavaEE SE
• Ideal place to execute complex business logic
• Bridge between JavaEE container and JBI container
• Provides support for

> Transactions
> Resource Pooling
> Security

• Code re-use – Invoke your EJBs/web applications 
from OpenESB components (BPEL SE)

• Ability to expose your EJB/Web applications to 
multiple transports (using BCs) – just add bindings 
to your WSDL
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Scenario 1: Remote throughHTTP BC
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➔ Network layer
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➔ Unmarshal <xml>
➔ Create DOM
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➔ WS.helloWorld(name)

• BPEL
➔ NMR
➔ HTTP BC
➔ Marshall DOM to <xml>
➔ SOAP/HTTP
➔ Network layer
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Scenario 2: Local through NMR
• BPEL
➔ NMR
➔ HTTP BC
➔ Marshall DOM to <xml>
➔ SOAP/HTTP
➔ Network layer
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➔ JAXWS
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➔ Create DOM
➔ JAXB
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Advantages:
> Performance
> Transaction propagation
> Security context propagation
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Scenario: Portal + EE + BPEL

• Portlet gets name, invokes WAR which calls BPEL 
to orchestrate process

• BPEL activity requires complex business logic 
> executes faster in EJB right
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Intelligent Event Processing (IEP) SE 
• Handles real time events and process them to 

higher level events which then can be used for 
further analysis or monitoring.
> Aggregation
> Filtering
> Correlation
> Partition

• Provides real time event notifications and triggers
> Update database in realtime



45

IEP SE



46

Usage Scenario 
• Many modern applications require long-running, or 

continuous, queries over continuous unbounded 
streams of data.

• The need exists to detect business-critical issues as 
they happen, and to route, filter and pre-process 
data continuously over an indeterminate period of 
time.

• Event processing involves the continuous 
processing and analysis of high volume, high-speed 
data streams from inside and outside an 
organization. 
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IEP Operators
• Input

> Stream-Input
> Table-Input

• Output
> Stream-Output
> Relation-Output
> Table-Output

• Correlation and Filtering
> Stream-Project-and-Filter
> Tuple-Serial-Correlation
> Relation-Map

• Aggregator
> Time-Based-Aggregator
> Tuple-Based-Aggregator
> Relation-Aggregator.

• Stream Converter
> Tuple-Based-Window
> Time-Based-Window
> Attribute-Based-Window
> Partitioned-Window

• Relation Converter
> Insert-Stream
> Delete-Stream
> Relation-Stream
> Table

• Relation Operator
> Distinct
> Union
> Union-All
> Minus
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       IEP Support in NetBeans



  
Intelligent Event Intelligent Event 
Processing (IEP) SEProcessing (IEP) SE
DemoDemo

You can try this demo yourself! You can try this demo yourself! 
http://www.javapassion.com/handhttp://www.javapassion.com/hand
sonlabs/openesbiep/sonlabs/openesbiep/
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Demo Scenario
• External program keep sending stock quote data 

stream events to the IEP (through JBI)
> The IEP receives the stock quote stream as real time 

events 
• The IEP send notifications to the database and the 

database gets updated continuously
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Steps to follow
1.Create IEP module project

➢ Create quotes.iep
➢ Generate quotes.wsdl

2.Create a Composite application
➢ Add IEP module to the Composite application

3.Run the test application that sends stock quote 
stream to the composite application



  
Aspect SEAspect SE
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Aspect SE

• Aspects help to encapsulate cross-cutting 
expressions in one place. 

• By applying an Advice, at various points in an 
application called Join-Points, Aspects can alter the 
behavior of the non-aspect parts of a software 
application.

• There are two types of aspect patterns that are 
addressed:
> Gateway Pattern
> Aspect-Weaving Pattern 



  
CASACASA
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CompApp Service Assembly Editor
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CompApp Manager
● collect statistics for 

endpoints, SUs / 
SAs

● monitor and 
configure runtime 
parameters for a 
managed 
component

● control managed 
components (e.g. 
start/stop/shutdow
n/etc)
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OpenESB: Projects 
• Glassfish JBI Integration

> Place where JBI runtime will be implemented
> will become the OpenJBI project

• Open JBI Components
> Component Development
> “Independant” of OpenESB. E.g., could be used in other JBI 

based environment. E.g., JBossESB
• Open ESB

> Umbrella Project, includes runtime and components
• Open B2B

> B2B specific components: HIPAA, RFID, EDI, ebXML
• Netbeans Enterprise Pack
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Open ESB Distribution

• Open ESB
> JBI Runtime
> Full collection of 

OpenESB components
> NetBeans based tooling 

(see Tooling section of 
presentation)

> Latest builds

• Java Application 
Platform SDK
> Glassfish
> JBI Runtime
> Milestone of OpenESB 

components
> Includes other open 

source projects
>Portal, OpenSSO, etc 

> http://open-esb.dev.java.net
> http://java.sun.com/developer/technicalArticles/J2EE/sdk_overview/

 
> http://enterprise.netbeans.org/ 

http://open-esb.dev.java.net/
http://java.sun.com/developer/technicalArticles/J2EE/sdk_overview/
http://enterprise.netbeans.org/
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Open ESB and JavaCAPS

• Open ESB
> JBI Runtime
> Glassfish v2 AppServer
> Full collection of 

OpenESB components
> NetBeans v6 based 

tooling 
> Combination of Sun and 

3rd party components
> Constantly evolving
> Community Support

• JavaCAPS 5.2 ++
> JBI Runtime + 

JavaCAPS 5.1 Runtime
> Glassfish v2 AppServer
> Selection of OpenESB 

components
> NetBeans v6 based 

tooling (incl Enterprise 
Designer components)

> Combination of Sun and 
3rd party components

> Sun Support
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More Info
• JBI

> http://www.jcp.org/en/jsr/detail?id=208 
> http://java.sun.com/integration/ 

• OpenESB Project
> http://open-esb.dev.java.net/ 
> https://open-jbi-components.dev.java.net/ 
> http://www.glassfishwiki.org/jbiwiki/Wiki.jsp?page=Jbicomps 

• JavaEE SDK
> http://java.sun.com/javaee/downloads/index.jsp 

• Examples and Demos:
> http://enterprise.netbeans.org/ 

http://www.jcp.org/en/jsr/detail?id=208
http://java.sun.com/integration/
http://open-esb.dev.java.net/
https://open-jbi-components.dev.java.net/
http://www.glassfishwiki.org/jbiwiki/Wiki.jsp?page=Jbicomps
http://java.sun.com/javaee/downloads/index.jsp
http://enterprise.netbeans.org/


OpenESBOpenESB

●Sang ShinSang Shin
–Java Technology EvangelistJava Technology Evangelist
●Sun Microsystems, Inc.Sun Microsystems, Inc.

62


