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Introduction

The GlassFishTMServer is a free, open source Application Server that implements the Java EE
platform. It is the industry standard for implementing enterprise-class Service-Oriented
Architecture (SOA) and next-generation web applications.

The Eclipse is a popular open source Integrated Development Environment that is widely
adopted in the developer community.

The GlassFish Tools Bundle for Eclipse is a co-bundle of GlassFish Server v2.1 and v3 Prelude,
Eclipse IDE 3.4 and the plug-ins that enables them to work together.

This document helps users of GlassFish Tools Bundle for Eclipse, to become familiar with using
the bundle and its various features. The document contains information on the following
topics:

■ Installing GlassFish Tools Bundle for Eclipse
■ Configuring and Using GlassFish Server from Eclipse IDE
■ Developing Applications for GlassFish Server from Eclipse IDE
■ Appendix A, “Using Popup Menu”
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Installing GlassFish Tools Bundle for Eclipse

This chapter describes the process of installing GlassFish Tools Bundle for Eclipse, that includes
Eclipse IDE 3.4, GlassFish Server v2.1 and v3 Prelude Servers, and the plug-in that integrates
these products, on various platforms.

■ “To Install on Windows Platform” on page 7
■ “To Install on Mac OS Platform” on page 8
■ “To Install on Linux Platform” on page 9
■ “To Uninstall” on page 10
■ “Troubleshooting” on page 11

▼ To Install on Windows Platform
Download GlassFish Tools Bundle for Eclipse Windows package from the following
locationhttp://download.java.net/glassfish/eclipse

Double click the downloaded file, to start installer wizard.
Welcome Message is displayed.

Click Next to continue.
License Agreement page is displayed.

Read and accept the License Agreement.

In the next page, accept default location or specify a different location to install software.
For example: C:\Program Files\GlassFish-Tools-Bundle-For Eclipse-<version>\

Click Install to continue.
Wait for installation to complete.
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When installation is completed, Eclipse IDE 3.4 and GlassFish Servers v2.1 and v3 Prelude
along with the plug-ins that integrates these products are installed on system.

Click Close to quit Installer wizard.

To start Eclipse IDE, select Start ->Programs->GlassFish Tools Bundle for Eclipse
<version>->GlassFish Tools Bundle for Eclipse.
Workspace Launcher page is displayed.

Accept default Workspace or select a different Workspace.

Click Next to continue.
GlassFish Registration page is displayed.

Register GlassFish Server from Registration page.
You can also choose one of the other registration options.

Tip – By registering your GlassFish Installation, you have the advantage of receiving patch
information and updates, screen casts and tutorials, support and training offerings from
GlassFish community.

Click Next or Finish, to continue.
Eclipse IDE is opened.

Close Welcome page to enter default Workbench, in Java EE Perspective.

▼ To Install on Mac OS Platform
Download GlassFish Tools Bundle for Eclipse Mac OS package from the following
locationhttp://download.java.net/glassfish/eclipse

Double click downloaded file to create pkg file.

Click pkg file to start installer wizard.
Welcome Message is displayed.

Click Continue to continue.
License Agreement page is displayed.

Read and accept the License Agreement.
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In the next page, accept default location or specify another location to install software.

For example: HD Disk.

Click Install to continue.

Wait for installation to complete.

When installation is complete, Eclipse IDE 3.4 and GlassFish Servers v2.1 and v3 Prelude along
with the plug-ins that integrates these products are installed on system.

To start Eclipse IDE, select Start→GlassFish Tools Bundle for Eclipse.

Workspace Launcher page is displayed.

Accept default Workspace or select a different Workspace.

Click Next to continue.

GlassFish Registration page is displayed.

Register GlassFish Server from the Registration Screen.

You can also choose one of the other registration options.

Tip – By registering your GlassFish Installation, you have the advantage of receiving patch
information and updates, screen casts and tutorials, support and training offerings from
GlassFish community.

Click Next or Finish to continue.

Eclipse IDE is opened.

Close the Welcome page to enter default Workbench, in Java EE Perspective.

▼ To Install on Linux Platform
Download GlassFish Tools Bundle for Eclipse Linux package from the following
locationhttp://download.java.net/glassfish/eclipse

Move the downloaded file to a suitable directory.

Use gunzip and then extract tar file.

When file is extracted, Eclipse IDE 3.4 and GlassFish Servers v2.1 and v3 Prelude along with the
plug-ins that integrates these products are installed on system.
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Navigate to install location, <glassfish-tools-bundle-for-eclipse-xxxx> directory.

This directory contains Eclipse IDE 3.4, GlassFish Server v2.1 and v3 Prelude installations.

Start Eclipse IDE, by using the following command:

./eclipse

GlassFish Registration page is displayed.

Click Next to continue.

GlassFish Registration page is displayed.

Register GlassFish Server from Registration Screen.

You can also choose one of the other available options.

Tip – By registering your GlassFish Installation, you have the advantage of receiving patch
information and updates, screen casts and tutorials, support and training offerings from
GlassFish community.

Click Next or Finish to continue.

Install wizard configures GlassFish Server v2.1 and v3 Prelude Servers for you.

Workspace Launcher page is displayed.

Accept default Workspace or select a different Workspace.

Eclipse IDE is opened.

Close Welcome page to enter Eclipse IDE default Workbench, in Java EE Perspective.

▼ To Uninstall
To uninstall your GlassFish Tools Bundle for Eclipse installation, use the following procedure:

For Windows installations, select Start->GlassFish Tools Bundle For Eclipse
<version>->GlassFish Tools bundle Uninstall.

For Mac OS installations, go to <Disk>/Applications directory, remove the
<installation>directory.

For Linux installations, remove the <installation>directory.
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▼ Troubleshooting
If you face any issues in installing the bundle, use the following steps to clean up the failed install
and restore the pre-installation state of system.

Remove the <installation>directory.

Remove any relevant hidden directories and files from you home directory.
For example: ~.glassfish-tools-bundle-for-eclipse-<version> on Linux.

Remove the associated Eclipse workspace for installation, if configured.

Install the GlassFish Tools Bundle for Eclipse again.
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Configuring and Using GlassFish Server from
Eclipse IDE

This chapter introduces you to configuring and using the GlassFish Server from Eclipse IDE.
When the GlassFish Tools Bundle for Eclipse is installed, you can configure and take advantage
of advanced features available in the GlassFish Server. The following topics describe the process
of configuring the GlassFish Server from Eclipse IDE.

Several of the following procedures use the Server popup menu. For more information using
Server popup menu, see Appendix A, “Using Popup Menu”

■ “To create a new Server” on page 13
■ “To start GlassFish Server” on page 14
■ “To stop GlassFish Server” on page 15
■ “To restart GlassFish Server” on page 15
■ “To start GlassFish Server in debug mode” on page 16
■ “To publish Projects” on page 16
■ “To clean published Projects” on page 16
■ “To add and remove Projects” on page 17
■ “To display GlassFish Sever properties” on page 17
■ “To access GlassFish Server Administration Console” on page 18
■ “To register GlassFish Server Installation” on page 18
■ “To use GlassFish Update Center from Eclipse IDE” on page 19
■ “To use Help menu for GlassFish Server” on page 19
■ “To change Preferences for GlassFish Server Plug-in” on page 20
■ “To monitor TCP/IP for Web Applications with GlassFish Server” on page 20
■ “To view Sample JavaDB” on page 21
■ “Miscellaneous” on page 22

▼ To create a new Server
The GlassFish Tools Bundle for Eclipse will install a new instance of GlassFish v2.1 Server and
GlassFish v3 Prelude Server (Bundled GlassFish v2.1 and Bundled GlassFish v3 Prelude) for you
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by default. If you need to add a new Server to Eclipse, use the following procedure. In some
cases, this option also downloads and installs a new Server. For example: GlassFish v3 Promoted
Build

Select Servers view.

Select New, from Server popup menu.

New Server page is displayed

Provide GlassFish Server details.

For example, provide details for the following:

Server's host name

Server type

Server name

Server Runtime Environment

Click Next.

Complete Server configuration. For example, provide values for the following:

Domain Directory

Domain Name

Administrator ID

Administrator password

Click Next.

Add and Remove Projects page is displayed.

Select any existing projects you want to add to the new Server.

Click Finish.

New Server creation is completed.

▼ To start GlassFish Server
This task describes the process of starting your GlassFish Server from Eclipse IDE.
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Note – By default, Eclipse Workbench is set to Java EE Perspective. Skip Step 1 if Workbench is
already set to Java EE Perspective.

Select Window->Open Perspective->Java EE Perspective, to set Eclipse IDE to Java EE
Perspective.

Select Servers view.

Select the GlassFish Server instance you want to start.

Select Start from Server popup menu.
GlassFish Server is started.

Tip – You could also use the Start icon on the tool bar, to start Server.

▼ To stop GlassFish Server
To stop the running GlassFish Server, use the following procedure.

Select Servers view.

Select the GlassFish Server instance you want to stop.

Select Stop from Server popup menu.
GlassFish Server is stopped.

Tip – You could also use the Stop icon on the tool bar, to stop the Server.

▼ To restart GlassFish Server
To stop and restart the GlassFish Server, use the following procedure.

Select Servers view.

Select the GlassFish Server you want to restart.

From Server popup menu, select Restart.
GlassFish Server is stopped and restarted.
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▼ To start GlassFish Server in debug mode
When you want to debug an application, run GlassFish Server in debug mode. To start
GlassFish Server in debug mode, use the following procedure.

Select Servers view.

Select the GlassFish Server, you want to start in debug mode.

Select Debug, from Server popup menu.
GlassFish Server is started in Debug mode.

Note – If GlassFish Server is already running, you will see Restart in Debug option in the popup
menu, instead of Debug.

For more information on using GlassFish Server to debug applications, see “To debug a Servlet
with GlassFish Server” on page 28.

▼ To publish Projects
To publish applications to the GlassFish Server, use the following procedure.

Select Servers view.

Select GlassFish Server, you want to publish to.

From Server popup menu, select Publish.
The applications are published to the GlassFish Server.

▼ To clean published Projects
To discard all published projects, and republish from scratch, use the following procedure.

Select Servers view.

Select GlassFish Server, you want to clean.

From Server popup menu, select Clean.

Click OK to accept the warning regarding discarding the published state.
The published state of projects is discarded and projects are republished.
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▼ To add and remove Projects
To add and remove projects that are configured to run on GlassFish Server, use the following
procedure.

Select Servers view.

Select GlassFish Server.

Select Add and Remove Projects, from Server popup menu.

Add and Remove Project screen is displayed.

To add a project to Server:

a. Select the project you want to add from Available projects panel.

b. Click Add, to add the project to Configured projects panel.

To remove a project from Server:

a. Select the project you want to remove from Configured projects panel.

b. Click Remove, to remove the project to Available projects panel.

Click Finish to exit.

▼ To display GlassFish Sever properties
To view some of the GlassFish Server current properties and to restore them to default, use the
following procedure.

Select Servers view.

Select GlassFish Server.

Select Properties, from Server popup menu.

Properties for GlassFish Server page is displayed.

View current Server properties or restore them to default.
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▼ To access GlassFish Server Administration Console
The GlassFish Sever offers many administrative features that are not accessible from Eclipse
IDE. These features are available from GlassFish Server Administration Console which is
accessible from Eclipse IDE. The following procedure describes the process of accessing
GlassFish Server Administration Console, from Eclipse IDE.

For more information on how to access GlassFish Server popup menu, see Appendix A, “Using
Popup Menu.”

Make sure that GlassFish Server is running.

Open Eclipse IDE.
Default Workbench is displayed.

Select Servers view.

Select Server popup menu → GlassFish Enterprise Server →GlassFish Administration Console.
GlassFish Administration Console is displayed.

Access various features available from Administration Console such as Registration,
Subscription and Documentation.

▼ To register GlassFish Server Installation
By registering your GlassFish Installation, you have the advantage of receiving patch
information and updates, screen casts and tutorials, support and training offerings from
GlassFish community.

If you did not register during installation, use the following procedure to register your GlassFish
Server from Eclipse IDE.

Make sure that GlassFish Server is running.

For more information on how to access GlassFish Server popup menu, see Appendix A, “Using
Popup Menu.”

To view Registration page, select Server popup menu →GlassFish Enterprise Server →Register
GlassFish Enterprise Server.

Provide required information to register GlassFish Server Installation.

To access Support Information, from GlassFish Server popup menu, select →GlassFish
Enterprise Server →Get Support for GlassFish Enterprise Server.

Before You Begin
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▼ To use GlassFish Update Center from Eclipse IDE
The GlassFish Update Center provides access to Add-On components and product updates for
GlassFish Server.

Use the following procedure to access GlassFish Update Center from Eclipse IDE.

Note – You can update the GlassFish Plug-in in the bundle, by accessing Help→Software
Updates option and downloading the latest version of the GlassFish Plug-in.

Make sure that the GlassFish Server is running.

For more information on how to access GlassFish Server popup menu, see Appendix A, “Using
Popup Menu.”

From Server popup menu, select GlassFish Enterprise Server →GlassFish Update Center.

Select Add-On components and product updates as required.

For example: JRuby.

▼ To use Help menu for GlassFish Server
In the GlassFish Tools Bundle for Eclipse, additional GlassFish help options are added to the
Eclipse IDE Help menu. You can access the Online Help for GlassFish Server v2.1 and GlassFish
Server v3 Prelude from Eclipse IDE Help->GlassFish Enterprise Server menu. The Help options
are useful for learning how to use, administer or deploy with GlassFish server.

Select Help->Java EE 5 Javadoc, to view Java EE javadoc.

Select Help->GlassFish Enterprise Server, to view GlassFish Server help options.

The following options are available:

■ Get Support for GlassFish Enterprise Server

■ Aquarium: GlassFish Community News

■ GlassFish v3 Prelude (Documentation)

■ GlassFish v2.1 Java EE 5 (Documentation)

Before You Begin
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▼ To change Preferences for GlassFish Server Plug-in
The GlassFish Tools Bundle for Eclipse allows you to change the preferences for GlassFish
Server Plug-in from Eclipse IDE.

To change GlassFish Plug-in preferences from Eclipse IDE, select Window->Preferences.

The available GlassFish Server preference flags are explained in detail.

■ Enable GlassFish Plug-in Log information in IDE log file

This preference is useful for debugging purposes. Turning on this option allows you to see
additional traces in Eclipse log file specific to GlassFish Plug-in. This option is OFF by
default.

■ Start the JavaDB database process when Starting GlassFish Server

GlassFish Tools Bundle for Eclipse includes a preconfigured JavaDB Database. This option
allows you to start the database automatically when the server is started. It is useful when
working with JPA applications. This option is OFF by default.

■ Start the GlassFish Enterprise Server in Verbose Mode

Turning on this option will send GlassFish server output log to Eclipse console. This option
is OFF by default as there is a GlassFish specific log view.

■ Enable colored rendering in GlassFish Log Viewer

This option will enable log messages to be displayed in color. For example, Eclipse IDE
renders messages by default colors as INFO level messages in black, WARNING messages in
yellow, SEVERE messages in red, and multiple line entries in Italic. This option is ON by
default.

Tip – You an always modify Error message text color. Select
Window→Preferences→General→Appearance→Colors and Fonts. From Colors and
Fonts panel, select Basic and then Error Text color. Modify error text color as per your
requirement.

▼ To monitor TCP/IP for Web Applications with GlassFish
Server
TCP/IP monitoring is a useful Eclipse IDE feature that is enabled for GlassFish Server in this
bundle. It allows you to trace HTTP requests made to your web application. Use the following
procedure to configure TCP/IP monitoring for GlassFish Server.

●
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Select GlassFish Server popup menu Monitoring->Properties.
Monitoring Properties page is displayed.

Click Add.
Monitoring Ports page is displayed.

Select Server Port, which is the http port used by GlassFish server.
By default, it is 8080. The port that will be used to actually do monitoring is 8081 which is
specified in the Monitor Port field.

Note – You can modify port numbers as required.

Click Start, to start monitoring.
The port 8080 is now monitored from port 8081.

The Status column in page will show (monitoring) status as Started.

Select Apply and then OK, to complete setup.
When GlassFish server is running, access a web page using port 8081 instead of the regular port
8080. The TCP/IP monitor view should appear below, and fill up with the traffic between your
Web browser and your web application. When you select each request in the tree at the top left
of page, information about the request/response is shown. The bottom left of the view will
display the HTTP request that was made to your web application, and the bottom right will
show each response.

▼ To view Sample JavaDB
The GlassFish Tools Bundle for Eclipse installs and creates a JavaDB sample database for you by
default. Use the following procedure to view the tables that exist in the database.

Skip Step 1 to Step 5 if the database is already started.

Select Window→Preferences.
Preferences page is displayed.

Select GlassFish Preferences.

Select the Checkbox next to Start JavaDB database process when Starting GlassFish Server
option.

Click Close.
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Restart the GlassFish Server.

The sample JavaDB database will be started along with the GlassFish Server.

Select Data Source Explorer view.

Select Sample JavaDB database node.

Right click the node to view the popup menu and confirm if the Database is connected.

If not, select Connect from the popup menu.

You will be connected to the Database.

Click to expand the database node.

You will be able to see the various schemata and tables that are already created for you.

▼ Miscellaneous
The above procedures describe the use of Server popup menu for various tasks, such as starting
and stopping GlassFish Server.

The same tasks can also be performed using other menus such as Eclipse IDE toolbar menu or
Project right click menu. Use any of the available menus as per your requirement.

For example, starting the Server in Debug mode as described in “To debug a Servlet with
GlassFish Server” on page 28, can also be done from Eclipse toolbar menu.

Select the Project in Project Explorer.

Select Debug As.

Menu is displayed.

Select Debug As icon from toolbar.

a. Select Run on Server.

Debug On Server page is displayed.

b. Select Bundled GlassFish Server v3 Prelude.

c. Click Next to continue.

d. Select any other Projects you want to Debug.
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e. Click Finish.
Prompt to Switch mode is displayed.

f. Select Switch Mode option and click OK.

For more information on Eclipse IDE menus, see Eclipse Documentation.See Also
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Developing Applications for GlassFish Server
from Eclipse IDE

When the GlassFish Tools Bundle for Eclipse is configured and ready to use from Eclipse IDE,
you can develop applications for GlassFish Server.

The following topics will help you to get familiar with developing applications for GlassFish
Server from Eclipse IDE, using the advanced features available in GlassFish Server v3 Prelude.

This section of the document assumes GlassFish Server v3 Prelude as Server runtime. You can
use GlassFish Server v2.1 for developing applications but without support for the features
specific to v3 Prelude. You may also need to perform further configuration, for the following
tasks to work with GlassFish Server v2.1.

For example: Use of EclipseLink described in “To create a JPA Project for GlassFish Server” on
page 30, is preconfigured to work with GlassFish Server v3 Prelude but not with GlassFish
Server v2.1.

■ “To Create a new Web Application project for GlassFish Server” on page 25
■ “To add a Servlet and use Session Preservation feature” on page 26
■ “To debug a Servlet with GlassFish Server” on page 28
■ “To Create a New Data Source and register it to GlassFish Server” on page 29
■ “To create a JPA Project for GlassFish Server” on page 30

▼ To Create a new Web Application project for GlassFish
Server
You can create different types of applications using GlassFish Tools Bundle for Eclipse. The
following procedure describes the process of creating a Web Application for publishing to
GlassFish Server.

Select File->New->Dynamic Web project.
Project creation page is displayed.
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Enter a Project Name in the first field.
For example: MyFirstWebApp.

Select GlassFish Server version to use as Target Runtime.
For example: GlassFish v3 Prelude.

Click Finish.
A new dynamic Web Project is created and is visible in Project Explorer panel.

A default JSP file index.jsp page is created and opened in JSP Editor View.

Add or modify index.jap code as required.

From Eclipse main menu, select Run menu or Run icon from toolbar.

Select Run On→GlassFish Server v3 Prelude, as the server to run this application.

Note – You can select Always use this server when running this project checkbox to streamline
further run invocations.

Build the Web Application and publish to GlassFish Server v3 Prelude.
The Console view displays server log. The index.jsp page appears in Eclipse IDE default Web
Browser.

Note – You can always switch back and forth between Editor view and Web Browser view. Both
views are available from Eclipse Editor. Each time the application is changed, it is redeployed on
server, and page is reloaded in the Browser, to see the changes immediately.

▼ To add a Servlet and use Session Preservation feature
Session Preservation is a new and convenient feature of GlassFish Server v3 Prelude, critical
when you are developing/debugging complex Web Applications with complex Session
management such as Shopping Cart applications, and when you want to retain information
about your Sessions across redeployments.

This section of document explains how to use Session Preservation feature. For testing this
feature, you can use the Project created in the previous example or create a new Project. If you
are using the previously created project, skip Step 1.

This section of the document is applicable for GlassFish Server v3 Prelude only. It is not
applicable to GlassFish Server v2.1.
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Create a new Dynamic Web Project, in the manner described in the previous section.

From Project Explorer window, right click the Project node.

Select New->Servlet, to create a new servlet.
Create Servlet screen is displayed.

Enter a package name.
For example: apkg.

Enter a servlet name.
For example:MyServlet

Click Finish.
A new servlet is created and opened in Eclipse IDE editor view.

From Eclipse IDE editor, add more logic to the servlet.
An example Servlet code for showing Session data is available from here:Sample Servlet code for
Session Preservation

Save servlet file.
The file is deployed on the GlassFish Server.

Go the to Web Browser view to activate the servlet page.
http://localhost:8080/MyFirstWebApp/MyServlet.

Reload the servlet web page, a number of times.
In the servlet page, you can see the Number of Previous Accesses field growing. This counter is
stored in Servlet Session data.

Modify servlet source code, and redeploy the web application.
Go the Web Browser view and click Reload to see the updated page.

Tip – By default, Deploy On Save mode is enabled. When you save servlet source file, it is
automatically redeployed on the Server.

To test Session Preservation feature, add some text in servlet source code.
For example:
session.putValue("accessCount", accessCount);

out.println (

..............
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..............

"<H2> Updated Servlet!!! Information on your Session:<H2>\n"+
..............

..............

and save the servlet page.

When the update is saved, the servlet is redeployed.

Access the web page once again.

You can see the newly added text, Updated Servlet!!! in the web page, and the field, Number
of Previous Accesses, as 5.

You have verified that the Servlet Session data was preserved during redeployment.

▼ To debug a Servlet with GlassFish Server
The GlassFish Tools Bundle for Eclipse enables you to debug various types of web applications
such as servlet helper classes, JPA (Java Persistence API) applications, Web Services, or JSP
pages containing Java code fragments. The following procedures describes the process of setting
up a servlet for debugging.

Set breakpoints for an application.

Go relevant line of application code from Eclipse IDE editor.

Select Run->Toggle Break Point.

■ You can also select the popup menu available in the vertical grey bar, on the left side of
Eclipse IDE editor, and select Toggle Break Point.

If Eclipse IDE can set up a breakpoint on this selected line, a small icon will appear on the vertical
grey bar.

If Eclipse IDE cannot set a breakpoint on this line, you will be notified.

Select Debug from Server popup menu to start GlassFish server in debug mode.

Eclipse IDE will switch to Debug Perspective as soon as the Web Page with breakpoint set, is
activated.

You can now start to debug the servlet using the feature-rich Eclipse Debugger.
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Note – For debugging a project, you can always use the Debug As icon from the Menu toolbar or
the Debug As option from the Project node right click menu.

For more information on using the Eclipse IDE, use the Help Menu.

▼ To Create a New Data Source and register it to
GlassFish Server
As described in Chapter 3, “Configuring and Using GlassFish Server from Eclipse IDE,” by
default GlassFish Tools Bundle for Eclipse installs and configures a database instance for you.

You can also create a new Data Source and register it with GlassFish Server from Eclipse IDE.
The procedure is as follows:

Select Databases from Data Source Explorer view. Right click the Databases node and select
New.

Select Derby from New Connection Profile options. Accept default name New Derby or choose
another name and select Next.

Derby Connection Profile screen is displayed.

Click New Driver Definition button located next to Driver text box.

Edit Driver Definition screen is displayed.

Select Jar List tab, and select location of Derby Client jar file from GlassFish Server Installation
directory.

Select Properties tab and view properties of Driver Definition.

Click OK to exit Edit Driver Definition screen.

From Connection Profile screen, modify any other details as required.

Click Test Connection to test Database connectivity.

Click Next to view a summary of Connection Profile.

Verify Profile details.

If necessary, go back and change details.
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Click Finish to complete creation of new Data Source profile.
The newly created Derby Data Source can be seen from Data Source Explorer view.

Note – You can also edit Data Resources from GlassFish Server Administration Console.

Additional details on editing Data Resources are available from GlassFish Server
Administration Documentation.

▼ To create a JPA Project for GlassFish Server
The following steps explain how to create a Java Persistence API (JPA) based project and
generate DDL for it.

This section of the document is applicable for GlassFish Server v3 Prelude only. It is not
applicable to GlassFish Server v2.1.

Select Window->Preferences.
Preferences page will be displayed.

Select GlassFish Server Preferences.

Select the checkbox next to Start JavaDB database process when Starting GlassFish Server
option.

Click OK to close the page.

Start or restart GlassFish Server.
The JavaDB database is started along GlassFish Server.

Select File->New->Other.
New project wizard will be displayed.

Select JPA->JPA Project.

Click Next to continue.
New JPA Project wizard will be displayed.

Create a name and select to run on GlassFish Server v3 Prelude.
For example:MyJPAProject.

Click Next to continue.
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Select EclipseLink as Platform and Sample JavaDB Database as connection.

Select Annotated classes must be listed in persistence.xml option, for Persistent class
management.
Other default options need not be changed.

Click Finish to complete new JPA project creation.

Accept Eclipse message prompt to switch to JPA perspective.

Select File->New->Other.
New project wizard will be displayed.

Select JPA->Entity.

Create a name and package name.
For example: MyEntity

Click Next to continue.

Add two fields in the Entity Fields panel, one of which should be selected as key field.
For example: Type=Int:Fieldname=id, Type=String:Fieldname=Name.

Click Finish.
A New Entity Class is created

Right click on JPA Project Node and select JPATools->Generate DDL.

Click OK to warning that you are about to create new tables.
New tables will be created in database.

Select Data Source Explorer.

Select the Sample JavaDB database.
You can view the newly created tables by expanding the Sample JavaDB Database node.

Additional Resources
The following resources provide additional information on Eclipse IDE and GlassFish Server.
■ Sun GlassFish Enterprise Server v3 Prelude Documentation
■ Sun GlassFish Enterprise Server 2.1 Documentation
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■ Eclipse Documentation
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Using Popup Menu

The popup menu available from Servers view provides a number of usage options, including
customized options for GlassFish Server. To access popup menu from Eclipse IDE, select
Servers view, and right click mouse.

The following options are available from Server popup Menu:

New Allows user to add a new GlassFish Server instance to Eclipse.
The new server should be pre-installed. In some cases, this
option also downloads and installs a new Server. For example:
GlassFish v3 Promoted Build

Open (F3) Allows user to access Server Overview page. The Server
Overview page allows user to view and modify some GlassFish
Server properties:
■ Specify hostname and other common settings
■ Edit Server configuration properties (Open launch

configuration)
■ Modify settings for Publishing
■ Specify time limit to complete Server operations
■ Edit some Server runtime properties

Note – Alternately, select and double-click the Server from
Servers view, to launch Server Overview page.

Show In (Shift+Alt+W) Allows user to direct GlassFish Server log messages to Console
or Debug windows. This option is also accessible through
(Shift+Alt+W) key action.

Copy (Ctrl+C) Allows user to copy GlassFish Server Instance. This option is
also accessible through (Ctrl+C) key action.
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Paste (Ctrl+V) Allows user to paste the copied GlassFish Server Instance.
This option is also accessible through (Ctrl+V) key action.

Delete (Delete) Allows user to delete selected GlassFish Server Instance from
configuration. This option is also accessible through Delete
button from keyboard.

Rename (F2) Allows user to rename GlassFish Server Instance. This option
is also accessible through the F2 function key.

Debug (Ctrl+Alt+D) Allows user to start GlassFish Server Instance in Debug mode.
This option is also accessible through (Ctrl+Alt+D) key
action.

Start (Ctrl+Alt+R) Allows user to start GlassFish Server Instance. This option is
also accessible through (Ctrl+Alt+R) key action.

Profile This option is not implemented in GlassFish Tools Bundle for
Eclipse.

Stop (Ctrl+Alt+S) Allows user to stop GlassFish Server Instance. This option is
also accessible through (Ctrl+Alt+S) key action.

Publish (Ctrl+Alt+P) Allows user to deploy the built applications to GlassFish
Server. This option is also accessible through (Ctrl+Alt+P)
key action.

Clean Allows user to discard all published state from GlassFish
Server and republish from scratch.

Add and Remove Projects Allows user to add or remove Projects that are configured to
run on GlassFish Server.

Monitoring Allows user to monitor GlassFish Server ports for access. This
is a new feature available in GlassFish Server v3 Prelude.

GlassFish Enterprise Server Allows user to access to the following additional sub menu
options:
■ GlassFish Update Center
■ Register the GlassFish Enterprise Server
■ Get Support for GlassFish Enterprise Server
■ Aquarium: GlassFish Community News
■ View Admin Console
■ View Log File

Properties (Alt+Enter) Allows user to view GlassFish Server properties and modify
some of them. This option is also accessible through
(Alt+Enter) key action.

Using Popup Menu
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