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Preface

Welcome to Developer/2000! This document will help you get started with Devel-
oper/2000 Release 2.0 for Windows NT or Windows 95.

Structure
Chapter Contents

Chapter 1 Installing Developer/2000 and using the Oracle Client Software 
Manager.

Chapter 2 For System Administrators: Steps for setting up and maintain-
ing database tables.

Chapter 3 Overview of the Developer/2000 components:

■ Project Builder

■ Form Builder

■ Graphics Builder

■ Report Builder

■ Procedure Builder

■ Query Builder

■ Schema Builder

■ Translation Builder



Prerequisites
You should be familiar with your computer and its operating system. For example, 
you should know the commands for deleting and copying files and understand the 
concepts of search paths, subdirectories, and path names. Refer to your Microsoft 
Windows 95 or NT and DOS product documentation for more information.

You should also understand the fundamentals of Microsoft Windows, such as the 
elements of an application window.

■ On Windows 95 or NT 4.0: You should be familiar with such programs as the 
Explorer, Taskbar or Task Manager, and Registry.

■ On Windows NT 3.51: You should be familiar with such programs as the Pro-
gram Manager, File Manager, and Registry.

Notational Conventions
The following typographical conventions are used in this guide:

Related Publications
You may also wish to consult the following Oracle documentation:

Convention Meaning

fixed-width font Text in a fixed-width font indicates commands that you enter 
exactly as shown. Text typed on a PC is not case-sensitive unless 
otherwise noted.

In commands, punctuation other than brackets and vertical bars 
must be entered exactly as shown.

lowercase Lowercase characters in a command statement represent a vari-
able. Substitute an appropriate value.

UPPERCASE Uppercase characters within the text represent command 
names, SQL reserved words, and keywords.

boldface Boldface is used to indicate user interface items such as menu 
choices and buttons.

C> C> represents the DOS prompt. Your prompt may differ.

Title Part Number

Developer/2000 Release 2.0: Guidelines for Building Applications A50994

SQL*Plus User’s Guide and Reference Version 3.1 A24801
x
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Installing Developer/2000

This chapter explains how to install Developer/2000 for Windows NT and Win-
dows 95 and provides the following information to help you get started:

■ System Requirements

■ Installing Developer/2000

■ Using the Oracle Client Configuration Manager

■ Upgrading from a Previous Release

■ Removing Oracle Products

1.1 System Requirements
This section lists the recommended system requirements for Developer/2000 for 
Windows 95 or NT. The specifications below represent a configuration that should 
work well for most application development projects. You may find that your 
project works well with even fewer resources.

■ An IBM or 100% compatible PC with an 80486/Pentium 33 MHZ processor or 
better.

■ A CD-ROM drive functioning as a logical drive (for installation only).

■ 8 MB RAM for one Runtime component and 3 MB for each additional Runtime 
component you want to run concurrently.

■ 16 MB RAM for one Builder component and an additional 4 MB for each addi-
tional Builder you want to run concurrently.

■ The Oracle Installer provides hard disk space requirements for each product in 
the Space Required field.
000 1-11



Installing Developer/2000
■ For 32-bit applications, either Microsoft Windows 95 or Microsoft Windows NT 
3.51 or later.

■ A remote Oracle7 Server and SQL*Net for Windows, Personal Oracle7 for Win-
dows, or Personal Oracle Lite.

■ (Optional) SQL*Plus for Windows, Version 3.1.1.9.3 or later, or SQL*DBA for 
Windows, Version 6.0.33.0.5 or later. (SQL*Plus is included with Developer/
2000. SQL*DBA is available separately.) SQL*Plus or SQL*DBA is necessary 
only for users who want to store Developer/2000 modules in database tables.

For information on monitor, printer, and mouse requirements, see your Microsoft 
Windows 95 or NT documentation.

1.2 Installing Developer/2000
Note: Before installing, it is strongly recommended that you read the Developer/
2000 Release 2.0 Release Notes for the most current product information. They can 
be found in the file Relnotes.txt  in the root directory of the Developer/2000 CD-
ROM.

You can install Developer/2000 on either a single client machine, using the Oracle 
Installer, or on several client machines at once, using the Oracle Client Configura-
tion Manager.

To install Developer/2000, perform the following steps:

1. Start the Oracle Installer.

2. For a single-client installation:

Install Developer/2000.

For a multiple-client installation:

a. Install the Oracle Client Configuration Manager.

b. Use the Oracle Client Configuration Manager to configure and install 
Developer/2000 on the client machines.

3. Build the database tables.

The rest of this section addresses each step in detail.

WARNING: If you are upgrading from a previous release, be sure to read 
Section 1.4, “Upgrading from a Previous Release” on page 1-22 for pre-installation 
considerations.
1-12 Developer/2000: Getting Started                              
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1.2.1 Step 1: Starting the Oracle Installer
1. Shut down any active Windows applications.

2. Open the Run dialog box from the Start menu.

3. In the Run dialog, type the following (where D: is your CD-ROM drive letter):

For a single-client installation:

D:\SETUP.EXE

For a multiple-client installation:

D:\ORAINST.EXE /SHARED

4. Click OK to start the Oracle Installer.

Note: The Oracle Installer for Windows 95 and for NT 4.0 also has an autorun fea-
ture. When you insert the CD, setup.exe  executes and launches the Oracle 
Installer. To disable the autorun feature, hold down the shift key while inserting the 
CD. Note that not all CD-ROM drives support the autorun feature.

1.2.2 Step 2: Installing Developer/2000
When you start the Oracle Installer, it displays the following dialog box:

Figure 1–1 Developer/2000 Installation Options dialog box
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The Software Asset Manager dialog box also contains the following buttons:

Option Description

Development Installation This option automatically installs a particular subset of the 
Developer/2000 components. To list the components that are 
installed with these installation options, click the Help button 
in the Developer/2000 Installation Options dialog box

Deployment Installation This option automatically installs a particular subset of the 
Developer/2000 components. To list the components that are 
installed with these installation options, click the Help button 
in the Developer/2000 Installation Options dialog box

Custom Installation or 
Removal

If you select this option, the Software Asset Manager dialog 
box is displayed, which offers the following information:

■ The products that are available for installation are listed 
under Products available. The plus sign (+) to the left of a 
product’s name indicates that this is the name of a soft-
ware package, which consists of a main application and 
its supporting software. You can select the entire package 
by clicking the line with the plus icon, or you can double-
click that line to display the pieces of the package, which 
can be selected individually.

■ The products that are already installed on your machine 
are listed under Products installed. Some of these may also 
be software packages, and they behave as described in the 
previous paragraph.

■ The disk space required for your selection and the disk 
space currently available on your machine are displayed 
in the Space Required area below the product lists.

Button Use

Exit Closes the Software Asset Manager and exits the Oracle 
Installer.
1-14 Developer/2000: Getting Started                              



Installing Developer/2000
To install a product:

1. Click the desired product in the Products Available list.

As with other Windows-based applications, you can Shift+click to select a 
series of products from the list, or you can Ctrl+click to select multiple, discon-
tinuous products.

For a single-client installation:

Select the Developer/2000 products you wish to install.

For a multiple-client installation:

Select Oracle Client Configuration Manager and Oracle Client Software Agent.

2. When you have selected all the products you wish to install, click the Install 
button.

Options . . . Allows you to do the following:

■ Request confirmations before removing or installing prod-
ucts.

■ Receive detailed messages and prompts during various 
phases of the Oracle Installer's function.

■ Record the actions being performed by the Oracle 
Installer in a log file.

View Log . . . Displays the Event Log. The Event Log displays installation 
and configuration events in the Description Level you choose: 
Summary, Brief, and Detail. You can store and retrieve logs 
and save them to files.

By default, log files are stored in 
%ORACLE_HOME%\ORAINST\ORAINST.LOG. If a log file 
from a previous logging exists, it is renamed to 
ORAINST.OLG.

If you want to keep more than two log files (.LOG and .OLG), 
rename the .OLG file so that it is not overwritten.

Restore Icons Restores Oracle product icons that have been accidently 
deleted.

Help Displays the online Help system.

Button Use
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Oracle recommends that you accept the default product locations.

When installation is complete, each product you have installed is listed in the 
Products Installed window.

3. For a single-client installation:

Exit the Oracle Installer. Shut down and restart Windows.

For a multiple-client installation:

See Section 1.3, “Using the Oracle Client Configuration Manager” for contin-
ued instructions.

1.2.3 Step 3: Building the database tables
As an optional final step in your product installation, you or your database admin-
istrator may build the Developer/2000 database tables, which allow application 
modules to be saved to the Oracle Server. Chapter 2 gives instructions for building 
these tables.

The Oracle Translation Builder and Schema Builder components of Developer/2000 
require the use of database tables. If you plan to use Translation Builder or Schema 
Builder, building the Developer/2000 database tables is a requirement.

WARNING: If you are upgrading from a previous release of Developer/2000 and 
already have modules stored in the database, please be sure to read Section 2.5, 
“Upgrading the Developer/2000 Database Tables” on page 2-28 for more informa-
tion. Removing the existing tables or attempting to install the database tables for the cur-
rent version of Developer/2000 destroys any Developer/2000 modules currently stored in 
the database.

1.3 Using the Oracle Client Configuration Manager
The Oracle Client Configuration Manager (OCCM) is used to administer configura-
tions on Shared Oracle host machines. A configuration is a named description of 
the set of software products that should be present on the client machines assigned 
to the configuration, along with instructions on how the software products are to be 
installed on the client machines.

1.3.1 Granting permissions
After installing the Oracle Client Configuration Manager on the file server, verify 
that you have granted the following client access permissions:

■ Read access to %ORACLE_HOME%
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■ Read and write access to the %ORACLE_HOME%\CLIENTS subdirectory (the 
Oracle Client Software Agent writes to this directory during updates)

Note: In a NetWare environment, you must also grant Create access to clients.

1.3.2 Configuring clients
Start the Oracle Client Configuration Manager from the appropriate Start→Pro-
grams menu from the taskbar.

The window displays three different views, which you can select from the View 
drop-down list:

■ Configuration Definitions, where you define configurations containing sub-
sets of the available products.
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■ Client Assignments, where you assign clients to specific configurations.
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■ Install Options (Configurations and Conflict Resolution), where you can 
specify client installation options and means of resolving configuration installa-
tion conflicts.

The Oracle Client Configuration Manager dialog box also contains the following 
buttons:

Button Use

OK Save all changes and close the window.

Reset This Clear changes in the currently displayed page, for the cur-
rently displayed configuration only. All other changes are kept.

Reset All Clear changes on all pages, for all configurations. Effectively 
returns the tool to the state it was in when it was opened.

Cancel Close the window without saving any changes.
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The steps for configuring clients are as follows:

1. Define configurations.

2. Select products for the configurations.

3. Assign clients to the configurations.

4. Define installation options.

5. Resolve installation conflicts.

1.3.2.1 Step 1: Defining configurations
1. Click the drop-down list and choose Configuration Definitions.

2. To add a configuration, click Add, then type the name of the new configuration 
in the dialog box.

To remove a configuration, click Remove, then click OK in the dialog box to 
confirm that you want the current selection to be deleted.

1.3.2.2 Step 2: Selecting products for the configuration
The Available Products list displays all products on the host that are not already 
included in the configuration. Products that are included in the configuration are 
listed under Selected Products.

To add a product:

1. In the Available Products area, select the product you want to add to the con-
figuration. You can select multiple products using Shift+click or Ctrl+click.

2. Click Add.

The selected products and their dependencies are added to the Selected Prod-
ucts list for the configuration.

To remove a product:

1. In the Selected Products area, select the product you want to remove from the 
configuration. You can select multiple products using Shift+click or Ctrl+click.

2. Click Remove.

Help Display the online Help system.

Button Use
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1.3.2.3 Step 3: Assigning clients to configurations
Assigning a client to a configuration specifies which products should be installed 
on the client and the manner in which they should be installed.

1. Click the drop-down list, and choose Client Assignments.

2. In the Configuration box, select a configuration.

The list of clients on the host that are not already assigned to the selected con-
figuration appears in the Available Clients list.

3. To add a client:

a. Select the desired client in the Available Clients list. You can select multiple 
clients using Shift+click or Ctrl+click.

b. Click Add.

The selection appears in the Selected Clients list.

To remove a client:

a. Select the desired client in the Selected Clients list. You can select multiple 
clients using Shift+click or Ctrl+click.

b. Click Remove.

1.3.2.4 Step 4: Defining installation options
Within a configuration, the install options control the way the products are 
installed on the named clients.

1. Click the drop-down menu and choose Install Options (Configurations and 
Conflict Resolution).

2. Select a configuration from the list.

The Client Installation Options for the selected configuration appear.

3. If the products in the configuration must be installed in a specific way:

a. Select the checkbox Force Executable Location.

b. Select an installation option from the list:

Run from OCSM Host   All product files are kept on the OCSM Host. This 
saves disk space on the client, but the software runs more slowly because 
the client must run the software over the network.
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Download EXE/DLL to Client Machine   Configuration files, EXEs, DLLs, 
and other binaries are downloaded to the client machine. This type of 
installation improves performance over the first option, because executa-
bles run locally.

Install Completely on Client Machine   All product files are fully repli-
cated on the client machine. This type of installation takes up more disk 
space than a partial download, but the client can run the software even 
when completely disconnected from the host machine.

Note: If you do not select Force Executable Location, clients may choose how to 
install the products.

4. To require that all products you select for the configuration be installed for cli-
ent use, select Force Client Installation.

Note: If you do not select Force Client Installation, the Installer prompts clients 
for which products to install from among the list of products you specified for 
the configuration.

1.3.2.5 Step 5: Resolving installation conflicts
If a client belongs to more than one configuration, and some options are set differ-
ently for the two configurations, a conflict arises. If there is a conflict, settings made 
in the Conflict Resolution section take precedence over individual settings for con-
figurations. The Conflict Resolution section contains the same options as the Client 
Installation Options section.

To save the setting, click OK.

1.4 Upgrading from a Previous Release
If you are upgrading from an Oracle CDE or Developer/2000 Release 1 product to 
Developer/2000 Release 2.0, you must upgrade all the components you have 
installed. Because of improvements to the underlying support files, such as the 
Tools Utilities, GUI Common files, and Required Support Files, the older set of com-
ponents cannot run with the newer set.

Caution: Do not install or build the Developer/2000 database tables until you run 
the appropriate upgrade script. Refer to Chapter 2 for more information. If you 
have customized your product resource (.RES) files (e.g., fmrusw.res ) you should 
back up these files as well before upgrading.
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1.4.1 Upgrading to Developer/2000 Release 2.0 on Windows 95 or Windows NT
If you have used previous versions of Developer/2000 on Microsoft Windows 3.x, 
your %ORACLE_HOME% directory was called ORAWIN.

If you have since upgraded your operating system to Windows 95 or Windows NT, 
your new installation of Developer/2000 Release 2.0 creates a new 
%ORACLE_HOME% directory. This new directory is named either ORAWIN95 (on 
Windows 95) or ORANT (on Windows NT). In either case, your old ORAWIN direc-
tory is not overwritten.

1.4.2 Upgrading your applications
If you are upgrading applications that were created using a previous version of 
Developer/2000, please keep in mind the following information.

■ If you want to run an application that was built using a 16-bit version of Devel-
oper/2000, you need to recompile that application using the 32-bit version of 
Developer/2000 on either Windows 95 or Windows NT.

You can streamline the compilation process using Project Builder:

1. Create a new project.

2. Add all your source files to the new project.

3. Click Project→Compile All.

Please see the Project Builder online help for more information on compiling 
projects.

See the Form Builder, Graphics Builder, and Report Builder online help for 
more information on upgrading applications created using older versions of 
Developer/2000.

■ If you are upgrading applications that use user exits and user-created DLLs, 
those DLL files may need to be recompiled after recompiling your applications 
with the new release.

■ Applications that use VBX controls do not run properly under Windows 95 due 
to an operating system incompatibility between 16-bit VBX controls and 32-bit 
executables.

■ Applications that make calls through the Developer/2000 foreign function 
interface (ORA_FFI package) to 16-bit DLLs do not work under Windows 95 
due to an operating system incompatibility between 16-bit code and 32-bit exe-
cutables.
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■ Developer/2000 Release 1 was based on PL/SQL Version 1.1; Developer/2000 
Release 2.0 is based on PL/SQL Version 2.3. Because V2.3 syntax and semantics 
differ from V1, all modules (Forms, Reports, Graphics, and PL/SQL libraries) 
must be converted from PL/SQL V1 to PL/SQL V2. Developer/2000 Release 
2.0 Builders incorporate a conversion utility to simplify this task. The utility 
runs automatically whenever you open a Release 1 module in a Release 2.0 
Builder, allowing you to interactively perform the conversion. The conversion 
can also be run automatically in batch mode. Using Project Builder, a large 
number of modules can be converted without user intervention.

Please see the online help for Project Builder, Form Builder, Report Builder, and 
Graphics Builder for more detailed information on the PL/SQL conversion util-
ity.

Note: Once a module has been saved in a Release 2.0 Builder, it becomes a 
Release 2.0 module. The conversion utility runs only on Release 1.0 modules. 
Oracle strongly recommends that you make a backup of all modules before 
beginning the conversion process.

Note: The Windows 3.x 64K limit on the size of compiled PL/SQL program units 
does not apply on Windows 95.

1.5 Removing Oracle Products
You can use the Oracle Installer to remove an Oracle product from your system. 
Removing a product de-installs all product files and subdirectories associated with 
the product.

To remove a product from your system:

1. Start the Oracle Installer from your Oracle product media or file system. See 
Section 1.2.1 for instructions on starting the Oracle Installer.

2. Select the product you want to remove from those listed in the Products 
Installed window.

3. Click Remove. If the products you select to de-install affect other products, 
Developer/2000 displays a confirmation prompt before de-installing.

Note: If you are not using the standard Windows application to control your desk-
top (if you are using Central Point PC Tools or Norton Desktop, for example), the 
Oracle Installer may not remove program items correctly.
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2

Building and Maintaining the Database

Tables

This chapter describes administrative procedures that system administrators 
should follow after installing Developer/2000. If you are not a system administra-
tor, you do not need to reference the information in this chapter.

The following topics are included:

■ Building the Developer/2000 Database Tables

■ Using the Database Tables

■ Granting and Revoking User Access

■ Deleting the Developer/2000 Database Tables

■ Upgrading the Developer/2000 Database Tables

2.1 Building the Developer/2000 Database Tables
WARNING: These instructions are for new installations only. If you already have 
database tables installed for a previous version of a Developer/2000 product, be 
aware that removing the existing tables or attempting to install the database tables 
for the current version of Developer/2000 will destroy any Developer/2000 mod-
ule currently stored in the database. Please see Section 2.5, “Upgrading the Devel-
oper/2000 Database Tables” on page 2-28 for instructions on upgrading database 
tables.

When you create applications with Developer/2000, you can either save your mod-
ules as files or save them to the Oracle Server. Saving modules to the server con-
serves disk space on client machines and allows shared access to the modules, 
although access to modules stored on the server can be slower than when they are 
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stored as files on the client machine. You may wish to consider the following infor-
mation when deciding where to store your modules.

Before users can save modules to the server, you must build tables to accommodate 
the modules and grant access privileges to users who will work with them. 

2.1.1 Step 1: Installing the SQL scripts with the Oracle Installer
If you have not already done so, use the Oracle Installer to install the SQL scripts 
needed to build and administer the Developer/2000 database tables.

To install the SQL scripts:

1. Start the Oracle Installer and select Custom Installation or Removal from the 
Developer/2000 Installation Options dialog box. (Refer to Chapter 1 for more 
information on the Oracle Installer.)

2. Select Developer/2000 Database Tables from the Available Products list.

3. Click Install.

Installing these scripts creates a Start menu item called Developer 2000 R2.0 
Admin and the associated submenu items Developer 2000 Build, Developer 2000 
Drop, Developer 2000 Grant, and Developer 2000 Revoke. These menu items, 
when selected, run a script or a series of scripts to perform database administration 
tasks.

2.1.2 Step 2: Building the Developer/2000 database tables
To build the Developer/2000 database tables:

■ Click Start→Programs→Developer 2000 R2.0 Admin→Developer 2000 Build.

Storage Location When to Use

Database server ■ When you want security that is not provided by your oper-
ating system.

■ When you want to store applications on the client machine, 
but you do not have enough disk space.

■ When you want to share applications with other users.

■ When module access speed is not as important as the con-
siderations listed above.

File system When the above criteria are not true or not important.
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This menu item runs the following SQL script:

%ORACLE_HOME%\TOOLS\DBTAB20\D2KBILD.SQL

2.2 Using the Database Tables
The database tables are intended to be used only by the Developer/2000 Builders 
for storing modules. The structure and organization of the tables is likely to change 
from release to release, so we strongly recommend that you do not try to use SQL 
queries against the tables to produce reports or documentation about your mod-
ules. Use of the tables in this way is not supported by Oracle, and for that reason 
the structure and content of the tables are not provided.

2.3 Granting and Revoking User Access
After building the Developer/2000 database tables, you must grant (and, later, 
revoke) user access to the tables.

2.3.1 Granting access to the Developer/2000 database tables 
You must perform this task for each user who requires access to the tables. Alterna-
tively, you can grant access to all users simultaneously by granting access for user 
PUBLIC. 

To grant access to the Developer/2000 database tables:

■ Click Start→Programs→Developer 2000 R2.0 Admin→Developer 2000 Grant. 
You will be prompted to enter a username.

This menu item runs the following SQL script:

%ORACLE_HOME%\TOOLS\DBTAB20\D2KGRNT.SQL username

2.3.2 Revoking access to the Developer/2000 database tables 
You must perform this task for each user whose access to the tables you want to 
revoke. Alternatively, you can revoke access for all users simultaneously by revok-
ing access for user PUBLIC. 

To revoke access to the Developer/2000 database tables:

■ Click Start→Programs→Developer 2000 R2.0 Admin→Developer 2000 
Revoke. You will be prompted to enter a username.
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This menu item runs the following SQL script:

%ORACLE_HOME%\TOOLS\DBTAB20\D2KRVKE.SQL username

2.4 Deleting the Developer/2000 Database Tables
WARNING: Deleting the database tables erases any module stored in those tables. 
Do not delete database tables until you have verified that you do not need any 
module currently stored in the table or tables you intend to delete. See Section 2.5.1 
for more information on backing up modules currently stored in your database.

To delete the Developer/2000 database tables:

■ Click Start→Programs→Developer 2000 R2.0 Admin→Developer 2000 Drop.

This menu item runs the following SQL script:

%ORACLE_HOME%\TOOLS\DBTAB20\D2KDRP.SQL

2.5 Upgrading the Developer/2000 Database Tables
If you are upgrading from an earlier version of Developer/2000 products, you can 
run one or more upgrade scripts instead of creating the tables from scratch. Doing 
so updates the information in your tables (preserving your existing information) 
rather than rebuilding the tables.

Note: Once you upgrade from a previous version, you must grant user access to the 
database tables again. See Section 2.3 for information about how to do this.

2.5.1 Step 1: Backing up the database
If you have any modules stored in the database that you wish to continue using 
after upgrading the database tables, you will need to back up these modules. Any 
modules that you do not back up will be lost.

To list all modules currently stored in the database, use the following SQL script:

column product format a15
column modtype format a15
SELECT product, modtype, owner, modname
FROM tool_module
ORDER BY product, modtype, owner;
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To back up a module:

1. Open the module in the appropriate Builder.

2. Save the module as an operating system file using the File→Save As command.

Once you have completed upgrading the database tables, you can restore the mod-
ules to the database.

To restore a module:

1. Open the module in the appropriate Builder.

2. Save the module as a database module using the File→Save As command.

The source files for your applications consist of the following:

■ Form Builder: .FMB, .MMB, and .PLL files

■ Report Builder: .RDF and .SQL files 

■ Graphics Builder: .OGD files

■ Procedure Builder: .PLL files

■ Query Builder: .BRW and .SQL files

2.5.2 Step 2: Upgrading the tables
Once you have backed up the database, you can upgrade the database tables.

2.5.2.1 Common tables
There has been no change to the underlying structure of the Developer/2000 com-
mon tables, so no upgrade scripts are needed.

2.5.2.2 Form Builder
Because the database tables for the Form Builder component have been renamed, 
there is no upgrade script provided. If you have any modules stored in the Form 
Builder database tables from a prior release of Developer/2000, perform the follow-
ing steps.

Note: All SQL scripts should be run under the SYSTEM account.

1. Back up the existing database tables and modules. (See Section 2.5.1 for details.)

2. Drop the existing tables by running the following script:

%ORACLE_HOME%\TOOLS\DBTAB20\FORMS50\FRM50DRP.SQL
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3. Create the tables by running the following script:

%ORACLE_HOME%\TOOLS\DBTAB20\FORMS50\FRM50BLD.SQL

4. Grant access to the tables by running the following script:

%ORACLE_HOME%\TOOLS\DBTAB20\FORMS50\FRM50GRT.SQL

2.5.2.3 Report Builder
If you have any modules stored in the Report Builder database tables from a prior 
release of Developer/2000, perform the following steps.

Note: All SQL scripts should be run under the SYSTEM account.

1. Back up the existing database tables and modules. (See Section 2.5.1 for details.)

2. Upgrade the existing tables by running the following script:

%ORACLE_HOME%\TOOLS\DBTAB20\REPORT30\SRW3020.SQL

3. Grant access to the tables by running the following script:

%ORACLE_HOME%\TOOLS\DBTAB20\REPORT30\SRW2GRNT.SQL

2.5.2.4 Graphics Builder
There has been no change to the underlying table structure in Graphics Builder, so 
no upgrade scripts are needed.

2.5.2.5 Procedure Builder
There has been no change to the underlying table structure in Procedure Builder, so 
no upgrade scripts are needed.

2.5.2.6 Query Builder
There has been no change to the underlying table structure in Query Builder, so no 
upgrade scripts are needed.

2.5.2.7 Schema Builder
There has been no change to the underlying table structure in Schema Builder, so 
no upgrade scripts are needed.

2.5.2.8 Translation Builder
If you have any modules stored in the Translation Builder database tables from a 
prior release of Developer/2000, perform the following steps.
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Note: All SQL scripts should be run under the SYSTEM account.

1. Back up the existing database tables and modules. (See Section 2.5.1 for details.)

2. Upgrade the existing tables by running the following script:

%ORACLE_HOME%\TOOLS\DBTAB20\OTM31\SQLMIG.SQL
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3

Using Developer/2000

This chapter contains information about benefits and features of Developer/2000 
Release 2.0, product overviews of each of the Developer/2000 components, and 
instructions for viewing Developer/2000 online help.

The chapter is arranged into the following sections:

■ About Developer/2000: Features and Benefits

■ About Project Builder

■ About Form Builder

■ About Graphics Builder

■ About Report Builder

■ About Procedure Builder

■ About Query Builder

■ About Schema Builder

■ About Translation Builder

■ About Developer/2000 Documentation

3.1 About Developer/2000: Features and Benefits
Developer/2000 is a multi-tier Web and client/server development tool for build-
ing scalable applications that run on all major platforms. It incorporates an inte-
grated set of builders for creating forms, reports, charts, queries, and procedures. 
The declarative capabilities of these components enable you to create applications 
from database definitions without the need to write any code.

Developer/2000 offers the following features and benefits:
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■ Productivity enhancements

■ Web deployment of applications

■ Scalability

■ Openness

3.1.1 Productivity
Developer/2000 employs rapid application design (RAD) techniques, object orien-
tation, built-in computer-based training, and a unified client-server architecture to 
enhance productivity. Creating applications is simplified via re-entrant wizards and 
through inheritance of reusable components. Developer/2000 applications can also 
be created directly from models created using Oracle Designer/2000 (CASE).

Developer/2000 offers an environment for development teams of all sizes. The 
new, integrated Project Builder manages all application components and external 
components (such as multimedia content), and enables the components to be 
opened with the appropriate tool. Project Builder increases productivity by facilitat-
ing deployment of completed applications. You can use Project Builder to package 
applications into a .tar or .zip file and create your own installation scripts for use 
with the Oracle Installer. Configuration management, including check-in, check-
out, version labeling, auto-recompilation, and difference reporting are all provided 
through interfaces to popular source- and version-control packages.

3.1.2 Web Deployment
Developer/2000 enables developers to deploy new and existing applications on the 
World Wide Web, either on an internal company intranet or on the Internet. Devel-
oper/2000 takes advantage of the ease and accessibility of the Web, elevating it 
from a static information-publishing mechanism to an environment capable of sup-
porting complex, dynamic applications. Form Builder forms and Graphics Builder 
displays generated for the Web have the same rich interactive GUI environment as 
those generated for client/server, coupled with the scalability expected of mission-
critical, transaction-intensive applications. Reports generated for the Web provide 
the degree of presentation quality and precision that is critical for publishing enter-
prise-wide information.

3.1.3 Scalability
Scalability is inherent in the multi-tiered architecture of the product. It is explicit in 
the support for server functionality, such as array DML, database cursors, bind vari-
ables, savepoints, and result sets, and it is definitive in the drag-and-drop client/
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server object partitioning which dramatically reduces network traffic between cli-
ent and server. Developer/2000’s flexible multi-tier architecture supports Oracle7 
application servers or third-party application servers such as TP monitors, ensuring 
scalability from the desktop to the enterprise.

3.1.4 Openness
Standards-based interaction between Developer/2000 and other applications and 
tools is enabled through OCX/ActiveX controls, OLE (Object Linking and Embed-
ding), and DDE (Dynamic Data Exchange). Support for a variety of multimedia for-
mats is complemented by an open architecture, giving developers the flexibility to 
extend Developer/2000 applications and integrate other components into them.

Developer/2000 offers integration with Oracle databases as well as transparent 
access to all major databases including Rdb, SQL Server, Informix, Sybase, and DB/
2. Database access is provided through ODBC database drivers as well as through 
the Oracle Gateways.

A number of interfaces to third-party products are available from members of the 
Open Tools Initiative. These interfaces include configuration management tools, 
CASE and modeling tools, workflow engines, transaction processing (TP) monitors, 
and many others.

3.2 About Project Builder

3.2.1 Overview
Project Builder helps you organize and maintain the many different files that make 
up an application. Within a single project, you can track everything from applica-
tion documentation created using your favorite word processor, to forms, reports, 
and the charts they contain, as well as user exits and the routines they call. Project 
Builder is able to provide a single point of contact for you by integrating all the 
tools, files, and tasks that make up a development project.

3.2.2 Major Concepts
A project is a collection of pointers to the files you consider part of your applica-
tion. Within projects, you can define the editors, compilers, and other tools you use 
to work with project files. Project files can be shared and ported across platforms. 
Subprojects are projects that are contained within other project files, rather than 
being stored in their own files. Subprojects are useful when you want to further 
group all items relating to a specific part of an application. You can, for example, 
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create a subproject containing the charts, menus, libraries, and documents that com-
prise a large form.

The Project Wizard is a quick and easy way to create a project. You can use the 
Project Wizard to create a project registry file, which provides a means for you to 
associate the files that make up an application, thus enabling you to manage the 
application-building process more efficiently. The Wizard leads you through the 
steps necessary to define a project. You can define a new standalone project or a 
subproject, name your project, select the directory in which it will reside, and spec-
ify a default connection. When you complete the Project Wizard, you’ll be ready to 
start adding files.

The Global Registry stores information common to an entire Developer/2000 instal-
lation. This information is restricted to type definitions and their associated actions, 
and built-in or user-defined properties. The use of the Global Registry is optional; 
its functions can be performed by individual user registries.

User registries store configuration information on a per-user basis. Each user regis-
try inherits type information from the Global Registry and may contain new types 
defined by the individual user. The user registry may also override aspects of type 
definitions it inherits from the Global Registry. A user registry also stores environ-
ment and preference information, such as preferred connect strings, UI settings, 
and certain general project information.

3.2.3 Process
To build a project using Project Builder, you perform the following steps:

1. Create a new project using the Project Wizard.

2. Add items (types, actions, macros, and files) to your project.

3. Build project and deliver application.

3.3 About Form Builder

3.3.1 Overview
Form Builder is a development tool for building applications that provide users 
access to information stored in a database. Form Builder modules can run standal-
one, and they can also have reports or graphics embedded in them.
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3.3.2 Major Concepts
When you create a Form Builder application, you work with three types of mod-
ules: forms, menus, and libraries. A form module is a collection of objects and data 
that users interact with in order to modify database tables. They make up the main 
body of a Form Builder application, and they contain any of the user interface 
items as well as the data source definitions and behavior. A menu module is com-
prised of menus and menu code. Users choose menu items to execute application 
functions. A library module is a collection of client-side code that can be shared 
across modules and applications.

The Object Navigator provides a hierarchical display of all the objects in the appli-
cation.

The Data Block Wizard enables you to easily create or modify data blocks for use in 
your application. The Data Block Wizard can be reentered after initial creation of 
the data block, enabling you to modify an existing data block, even if it was not 
originally created with the wizard.

The Object Libraries provide an easy method of reusing objects and enforcing stan-
dards across the entire development organization.

The Layout Wizard enables you to quickly lay out the items of a data block. The 
wizard displays the items in a frame on a canvas and lays them out in one of sev-
eral layout styles, after which you can manually alter the layout to your own speci-
fications. You can reenter the Layout Wizard after the initial creation of a frame, 
enabling you to modify an existing frame, even if it was not created with the Lay-
out Wizard.

The Property Palette enables you to set the properties of objects you create in form 
and menu modules. When you select an object in an editor or in the Object Naviga-
tor, the Property Palette updates to show the properties of that object. When you 
need to compare the properties of two different objects, you can invoke additional 
Property Palettes as needed.

The integrated PL/SQL Editor enables you to write PL/SQL code from within 
Form Builder. It provides a graphical interface for editing and debugging both cli-
ent- and server-side functions and procedures.

3.3.3 Process
To build a Form Builder application, you perform the following steps:

1. Create modules using the Object Navigator.

2. Create blocks and items manually or by using the Data Block Wizard.
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3. Apply user interface standards to your objects using the Object Library.

4. Fine-tune the layout using the Layout Wizard or the Layout Editor.

5. Set properties using the Property Palette.

6. Add code using the PL/SQL Editor.

7. Test your application using the Forms Runtime component and the integrated 
source-level debugger.

3.4 About Graphics Builder

3.4.1 Overview
Graphics Builder enables you to produce interactive graphical displays that repre-
sent and interact with data visually. A display is a combination of data and behav-
ior, encapsulated in a self-contained graphical application. This enables you to 
reuse your displays and embed them in a form or a report.

3.4.2 Major Concepts
An application created in Graphics Builder is called a display. A display contains 
all components used in the application, including data source definitions, visual ele-
ments, and behavior. Each display contains a layout, on which the display’s graphi-
cal objects are drawn. The layout consists of one or more layers containing 
individual visual elements of the display. At runtime, you can hide, show, and rear-
range layers to present different graphical views to the user. All other components 
of the application, such as data queries and PL/SQL constructs, are also part of the 
display.

There are over fifty predefined common chart styles, and you can also use a full set 
of drawing tools to create custom graphical displays such as interactive maps and 
import a wide range of image formats. You can use the Layout Editor to create and 
modify the graphical objects themselves.

The Object Navigator provides a hierarchical display of all the objects in the display.

The Chart Wizard enables you to quickly create a chart, select a data source, and 
create a query to specify the data to be plotted in the chart. You can reenter the 
Chart Wizard after the initial creation of a display, enabling you to modify an exist-
ing display, even if it was not originally created with the Chart Wizard.

The Property Palette enables you to set the properties of objects in displays. When 
you select an object in the Object Navigator, the Property Palette updates to show 
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the properties of that object. When you need to compare the properties of two dif-
ferent objects, you can invoke additional Property Palettes as needed.

The integrated PL/SQL Editor enables you to write PL/SQL code from within 
Graphics Builder. It provides a graphical interface for editing and debugging both 
client- and server-side functions and procedures.

3.4.3 Process
To create a chart object using one of the predefined chart styles in Graphics Builder, 
you perform the following steps:

1. Use the Chart Wizard to create a chart object, select a data source, and create a 
query to specify the data to be plotted in the chart.

2. Select a chart type from the Chart Properties sheet.

3. Modify the chart and chart element properties as necessary.

4. Add code using the PL/SQL Editor.

5. Test your application using the Report Builder or Form Builder Runtime com-
ponent and the integrated source-level debugger.

6. Integrate the display with a form module.

3.5 About Report Builder

3.5.1 Overview
Report Builder enables you to develop production-quality reports in a client/server 
or Web environment. You can deploy reports on the Web using the Reports Server 
and Reports Web CGI. Reports can be run standalone, or they can be embedded in 
forms or Graphics Builder displays. 

3.5.2 Major Concepts
A report is a collection of objects defining its data, layout, and runtime interface.

To quickly create new reports, you use the Report Wizard. The wizard guides you 
through the process of choosing a report type, defining a data model, and laying 
out the data. You can reenter the Report Wizard after the initial creation of a report, 
so you may re-invoke it on an existing report, make changes, and re-default the 
report, even if the report was not originally created with the Report Wizard.
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When you complete the Report Wizard, your report is displayed in the Report Edi-
tor’s Live Previewer. The Live Previewer is a WYSIWYG editing environment for 
making basic changes to your report layout. For more complex report editing, you 
can use the Report Editor’s Data Model, Layout Model, and Parameter Form 
views. (All of the Report Editor’s views are accessible from the View menu.) To gen-
erate HTML or PDF output from your report, use the Web Wizard.

To run reports on remote servers, you use the Reports Multi-tier Server (hereafter 
referred to as the Reports Server). The Reports Server accepts job requests from cli-
ent machines and maintains a request queue. You can view and administer the 
queue with the Reports Queue Manager (r30rqm32.exe ). For information on how 
to set up and use the Reports Server, refer to r30mtsus.htm  in %ORACLE_HOME%/
TOOLS/DOC20.

To dynamically run reports from a Web client, you use the Reports Server in combi-
nation with the Reports Web Cartridge or Web CGI. The Reports Web Cartridge or 
Web CGI enables your Web server to send report requests to the Reports Server for 
execution and receive the report output back in the Web browser. For information 
on how to set up and use the Reports Web Cartridge or Web CGI, refer to 
r30ows.htm  or r30cgi.htm  in %ORACLE_HOME%/TOOLS/DOC20.

3.5.3 Process
To build a report using Report Builder, you perform the following steps:

1. Use the Report Wizard to create a report.

2. Edit the Report in the Live Previewer, Data Model, Layout Model, and Parame-
ter Form views of the Report Editor.

3. Run the report to the desired format and destination, such as PostScript printer, 
HTML file, or PDF file.

3.6 About Procedure Builder

3.6.1 Overview
Procedure Builder is a unified environment for developing and maintaining client/
server application code.

3.6.2 Major Concepts
Procedure Builder provides a graphical user interface for creating, editing, and com-
piling both client- and server-side PL/SQL, including program units, libraries, and 
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database triggers. The Object Navigator provides a hierarchical display of these 
objects and enables you to launch any Procedure Builder editors or dialogs. You 
can drag and drop objects in the Object Navigator to change the relationships 
between them, and you can partition your applications by dragging and dropping 
procedural logic between client and server. Because Procedure Builder is embedded 
in Form Builder, Report Builder, and Graphics Builder, you can also drag and drop 
PL/SQL in the same way in those Builders.

The Program Unit Editor provides you with full text editing capabilities for enter-
ing and editing your program unit source code. You can also use the Program Unit 
Editor to compile program units and troubleshoot PL/SQL syntax errors with an 
interactive error message window.

The Database Trigger Editor provides a graphical interface for creating database 
triggers.

The Interpreter is the central debugging workspace in which you can set debug 
actions and test the program unit in runtime simulation. Breakpoints suspend exe-
cution of a compiled program unit, enabling you to step through code and trouble-
shoot runtime errors. Due to Procedure Builder's integrated client-server 
environment, debugging stored program units involves the same process as debug-
ging local program units.

Libraries are collections of program units that you can store on the client or server 
for easy reuse by multiple applications. Libraries also offer performance benefits 
because library program units are not loaded into memory until they are called. 
Program units in attached libraries are loaded into memory only when they are 
needed by the application, and are searched for through all attached libraries in the 
order indicated by the Object Navigator hierarchy.

3.6.3 Process
To create a program unit with Procedure Builder, you perform the following steps:

1. Use the GUI editor to create and compile PL/SQL program units.

2. Test the program unit in runtime simulation.

3. Perform debugging actions by controlling the flow of execution and examining 
program state.

4. Iterate through the development cycle incrementally. Test program units imme-
diately after incorporating changes.
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3.7 About Query Builder

3.7.1 Overview
Query Builder provides an intuitive means to access information from your organi-
zation’s databases for analysis and reporting. Query Builder displays your tables 
graphically, providing visual assistance as you use the point-and-click interface to 
create a single query.

3.7.2 Major Concepts
Each table in a query appears as a box in the Query window. The columns that 
make up a table are listed in the Query window under the table name.

The Query window is divided into two panels, the Conditions panel and the Data-
source panel. In the Datasource panel you specify which tables to include in your 
query and which columns to query from those tables. Query Builder understands 
the relationships between tables and displays those relationships graphically, using 
a relationship line. You can place conditions involving comparisons, character 
matches, or nulls, as well as using multiple conditions in a query.

You can sort query results, generate summary calculations, and use data from dif-
ferent parts of the database. You can also perform calculations on the data to con-
struct what-if scenarios and forecasts, change fonts and formats, print and save 
retrieved data, and export data to other applications such as Lotus 1-2-3 and 
Microsoft Excel.

Query Builder displays the requested data in the Results window.

The Data Editor enables you to insert, update, and delete database rows. It per-
forms SQL Data Manipulation Language (DML) commands used to edit the data in 
your database.

Note: Because the Data Editor enables you to change or delete data, Query Builder 
is shipped with the Data Editor disabled. You cannot access it unless you have the 
proper database privileges and the Data Editor has been enabled on the server side 
by your database administrator.

3.7.3 Process
To create a query using Query Builder, you perform the following steps:

1. In the Datasource panel, specify which tables to include in your query and the 
columns to query from those tables.
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2. Specify comparisons and other query properties such as sort order or summary 
calculations, as necessary.

3. Execute the query.

4. Use the Data Editor to insert, update, and delete database rows.

3.8 About Schema Builder

3.8.1 Overview
Schema Builder is a graphical tool that enables you to create, copy, modify, and 
remove database objects and their relationships.

3.8.2 Major Concepts
A schema is a collection of logical database objects, such as tables, views, indexes, 
and relationships, defined according to your needs. Schema Builder provides a way 
for you to view any combination of objects in your database, so you only need to 
see the objects you currently want to work with. Typically, the database objects you 
include in Schema Builder are those on which you expect to perform operations 
such as copying, modifying, and deleting.

Because the schema is a logical construct designed for convenience, you won’t cre-
ate or save the schema itself. Instead, you use Schema Builder to set up a series of 
SQL operations within your schema. A commit executes those operations in the 
database.

The Schema Builder interface is designed to look very much like the Query win-
dow in Query Builder. Rather than manipulating queries on existing tables, how-
ever, Schema Builder lets you perform SQL Data Definition Language operations. 
You can edit your data dictionaries and redefine database objects in an environ-
ment that lets you visualize your changes before you commit them to the database.

Note: Because Schema Builder enables you to change or delete vital tables, you can-
not access it unless you have the proper database privileges. Check with your Sys-
tem Administrator.

3.8.3 Process
To create a schema using Schema Builder, you perform the following steps:

1. Create a new schema.

2. Select data tables for your schema.
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3. Create and activate relationships.

3.9 About Translation Builder

3.9.1 Overview
Oracle Translation Builder supports and manages translations of text extracted 
from both Oracle resource files, such as Developer/2000 applications, and non-Ora-
cle resource files, such as Microsoft Windows (.rc) and HTML files.

3.9.2 Major Concepts
Translation Builder organizes projects and glossaries, manages base and translation 
modules in multiple versions, and enables reuse of earlier translations.

When you need to perform a translation, Translation Builder extracts the strings to 
be translated from resource files and imports them to the translation repository. The 
Project Navigator manages the overall process and ensures integrity of the data. 
From the Project Navigator, you can launch the Editor, which you use to translate 
the given set of strings and add the translations into the repository. Once transla-
tion is complete, the strings are extracted from the repository and exported to the 
resource files. If the resource type supports multiple languages, the translations are 
added back to the original resource. Otherwise, a copy of the resource is created 
with the base strings replaced by the translations.

One of the key features of Translation Builder is that previous translations are 
stored in the translation repository. The set of previous translations and glossaries 
is collectively known as Translation Memory. Upgrades and changes to an applica-
tion do not require that the translation process be restarted from the beginning. 
Each new translation adds to the Translation Memory, making future translations 
easier and quicker to accomplish. Version control of loaded text and translations is 
also provided by the Translation Memory.

Modules can be translated from any language to any other language. Once a given 
translation is complete, that translation can be used as a base for further transla-
tions. For example, if an English module needs to be translated to both Traditional 
and Simplified Chinese, you can translate first to Traditional Chinese, and then 
translate the Traditional Chinese to Simplified Chinese, rather than returning to 
English. This can make translations quicker and less expensive.

Translation Builder can be operated in both client-server and stand-alone configura-
tions, and the translations themselves are portable across multiple platforms.
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3.9.3 Process
To translate a resource using Translation Builder, you perform the following steps:

1. Extract translatable strings from Oracle or non-Oracle resources and import 
them into the Translation Repository.

2. Add a translation by indicating the language(s) to which a given module will 
be translated.

3. Use the Translation Editor to execute the translation.

4. Preview the translation by performing appearance checking and tuning to pre-
serve an acceptable look and feel.

5. Extract the translated strings from the repository and merge them back into the 
original resource or into copy of the original by using the export utility.

3.10 About Developer/2000 Documentation
Developer/2000 includes a comprehensive online help system that provides infor-
mation on a variety of conceptual, reference, and instructional topics.

■ To review the Quick Tours for a brief overview of each Developer/2000 compo-
nent:

Click Help→Quick Tour.

■ To step through the Cue Cards to learn how to perform common tasks:

Click Help→Cue Cards.

■ To access the online manuals for detailed product information:

Click Help→Manuals.

■ To locate help topics:

For the table of contents and index for online help, choose Help→Help Topics.

For context-sensitive help, press [Help] (the F1 key on most platforms).

For Form Builder key commands, choose Help→Keyboard Help, or press 
[Show Keys] (control-K on most platforms).
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