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Preface

Agile PLM is a comprehensive enterprise PLM solution for managing your product value 
chain. 

Audience
This document is intended for administrators and users of Agile PLM products.

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle Accessibility 
Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support

Oracle customers that have purchased support have access to electronic support through My 
Oracle Support. For information, visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.

Related Documents
Oracle's Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle 
Technology Network (OTN) Web site 
http://www.oracle.com/technetwork/documentation/agile-085940.html contains 
the latest versions of the Agile PLM PDF files. You can view or download these manuals from 
the Web site, or you can ask your Agile administrator if there is an Agile PLM Documentation 
folder available on your network from which you can access the Agile PLM documentation 
(PDF) files. 

Conventions
The following text conventions are used in this document:

Convention Meaning

boldface Boldface type indicates graphical user interface elements associated with an 
action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for which 
you supply particular values.



xii

monospace Monospace type indicates commands within a paragraph, URLs, code in 
examples, text that appears on the screen, or text that you enter.

Convention Meaning
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1Introduction

Test This chapter provides an introduction to the Agile Product Cost Management solution.

Overview of the Agile PLM Suite
? Agile Product Collaboration (PC) - Management and collaboration of product record 

information throughout the product lifecycle, across internal organizations and the 
extended supply chain.

? Agile Product Governance & Compliance (PG&C) - Management and tracking of all 
substances and materials contained by any item or manufacturer part, allowing companies 
to meet substance restrictions and reporting requirements, design recyclable products, 
minimize compliance costs, and eliminate noncompliance on future products.

? Agile Product Portfolio Management (PPM) - Integration of project and product 
information for overall product development to streamline business processes across the 
product portfolio and lifecycle.

? Agile Product Quality Management (PQM) - Management of customer, supplier and 
product quality issues, tied to the product design through a closed loop corrective action 
process.

? Agile Product Cost Management (PCM) - Management of product costs across the 
product lifecycle and synchronization of product cost and cost processes with both internal 
and external participants.

? Agile Engineering Collaboration - Management of CAD design data from the engineer's 
desktop directly in a central PLM product record, automating both the design and product 
BOM change processes and supporting IP reuse.

? Agile Enterprise Visualization - Visualization, markup, and analysis of native documents 
(MS Office, image, drawing, and CAD) through the Web across the extended enterprise, 
without the need for the original authoring tool or conversion to a neutral format.

What is Product Cost Management
Agile Product Cost Management (PCM) enables companies to manage direct material sourcing 
across the product cost lifecycle, from product inception to the product's end-of-life. It is 
designed to continuously manage a product's lifecycle cost against a company's target cost 
objectives and maximize lifecycle profitability.

It addresses the requirements across a multitiered network of materials and resources consumed 
in the delivery of the product to the customer, and it enables key people within sales/marketing, 
procurement, operations, engineering, and trading partners to collaborate on product design 
decisions.
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The four distinct levels of cost reduction that you can achieve by implementing Agile PCM are:

? Commodity and Supplier Leveraging

? Co-Sourcing and Reprice Management

? Design for Total Cost and Margins

? New Business Acquisition

For examples of PCM use cases, see "PCM Use Cases" on page A-1.

Commodity and Supplier Leveraging
A company can reduce product costs by identifying and leveraging opportunities across 
suppliers and manufacturing partners. Agile PCM provides a forward and comprehensive 
lifecycle view of the product forecast, new product bills of material, product changes, and 
cost/quote history. It fully automates the creation of the bid package, the bidding and 
negotiation process, and supplier/customer contract management.

Agile PCM lets you abstract and aggregate the appropriate view of product usage across all 
relevant product records. You can analyze the potential cost impact of a change collaboratively, 
in real-time, across all partners and suppliers. A successful sourcing strategy enables a 
company to reduce sourcing cycle time and direct materials spending while improving overall 
sourcing efficiency.

Co-Sourcing and Reprice Management
In addition to reducing sourcing cycle time and direct materials spending, companies can use 
Agile PCM to develop sourcing strategies that extend across their network of manufacturing 
contractors and suppliers. With Agile PCM, companies can ensure BOM accuracy across their 
multitier network of manufacturing partners and suppliers.

With Agile PCM, all business partners are assured they are using the current bills of material 
while responding to and analyzing material and non-material cost adders. Inter-enterprise 
sourcing teams collaboratively uncover savings opportunities through co-sourcing analysis, 
which identifies the strongest collective negotiation position. On a regularly scheduled basis, 
you can renegotiate and reset prices as the market dictates.

Design for Cost and Supply
Agile PCM improves New Product Introduction (NPI) processes by aligning design objectives 
with sourcing strategies to achieve product cost targets and minimize supply risks. Companies 
that design for cost and supply analyze each design selection against downstream supply and 
manufacturing objectives.

During the early design phase, your supply and cost planning teams stay current against 
dynamically changing product structures. They are provided the capabilities to cost each 
program, factor sourcing alternatives, forward cost projections and time-based constraints. 
Within a project-based environment, design and sourcing teams can establish an audit trail of 
bi-directional changes against the bills of material, sourcing alternative recommendations, and 
price updates.

Agile PCM enables you to achieve target costing, manage component obsolescence, identify 
at-risk items and suppliers earlier in the process, and drive sourcing preference management 
into the design phase.
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New Business Acquisition
You can use Agile PCM to support the new business acquisition process across the front and 
back office. Automating the reuse of a rich repository of contract prices, previous quotes and 
ERP cost feeds, with the ability to gather new cost information (deltas), you can dramatically 
reduce average customer response time to new business requirements. The results include the 
ability to process a higher volume of price quotes faster, improving operating efficiency and 
customer win rates.

Agile Client Applications
Oracle Agile PLM provides two clients:

? Web Client - HTML-based client that you run from a Web browser. It requires no 
client-side installation. The Web Client provides full access to Agile PCM functionality, 
but limited access to administration features.

? Java Client - Java application that provides advanced UI features, such as multiple 
windows, and full access to Agile administration features. You install Java Client locally, 
and it is updated automatically over the network through Java WebStart. The Agile Java 
Client enables you to search for Agile PCM objects, such as projects and RFQs, but not to 
create them.

Use the Web Client to access most Agile PCM functionality, such as creating sourcing projects, 
RFQs, and RFQ responses. Use the Java Client to administer the Agile PLM server.

Unless otherwise noted, the Web Client is used throughout this manual to perform Agile PCM 
procedures. For general information about Agile Web Client functionality, see Getting Started 
with Agile PLM.

Licenses
To set up licenses, the Agile administrator uses the Java Client to turn on licenses for the PLM 
solutions that your company has purchased. Once the PCM license is turned on, PCM-specific 
classes, such as Sourcing Projects, and other solution-based functions that pertain to your 
company's business will be enabled. For more information about licenses, see Agile PLM 
Administrator Guide.

Item Master and Sourcing Projects
The Item Master is also known as the product record. It is the entire collection of Items - Parts, 
Documents, and any other user-defined subclasses of the Items class maintained under change 
control in the Agile system. If you run a search for all Items in Agile PLM, the search results 
would essentially be from the Item Master. However, the Item Master also includes all objects 
associated with Item revisions, such as changes (ECOs, MCOs, SCOs), sites, manufacturer 
parts, and prices.

The Item Master figures prominently in Agile PCM. Most data that you bring into a Sourcing 
Project comes from the Item Master, as shown in the figure below. You can also create new 
project items or import them from external data files.
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Figure 1–1 Item Master and Sourcing Projects

When you add data to a Sourcing Project, you can select objects from the Item Master. If you 
make changes to Items or Manufacturer Parts contained within a project, you can publish the 
changes to the Item Master to update the following content:

? Items

– Bills of Material

– Approved Manufacturer Lists

? Manufacturer Parts

You can selectively import BOM Items using filters. For more information about publishing 
Items and Manufacturer Parts to the Item Master, see "Publishing Items and Manufacturer 
Parts" on page 4-9.

After negotiating prices with your suppliers, you can publish them to the Item Master. For more 
information about publishing prices, see "Publishing Prices for Items and Manufacturer Parts" 
on page 5-22.

Each project can have a specific manufacturing site, which constrains the project to include 
only items associated with that site.

Understanding Ship To Locations
When the Agile PLM administrator configures system settings for Agile PCM, one of the 
things they must do is define the Ship To locations. As the name implies, a Ship To location is 
one place where suppliers can directly ship materials to fulfill orders made by your company. 
Ship To locations are important to the product sourcing process for several reasons:

? The Agile administrator defines systemwide Ship To locations in the Agile Java Client. For 
more information, see "Ship To Location" on page B-2.

? Sourcing Project managers must have at least one authorized Ship To location defined in 
their user profile. Otherwise, they will not be able to specify a Ship To location for 
Sourcing Projects.

? Each Sourcing Project must have a specific Ship To location. Without a Ship To location, 
project status cannot be changed from Draft to Open.

? When sourcing managers send RFQs to Suppliers, they can choose to disseminate the 
RFQs only to the Suppliers with manufacturer or commodity offerings that match the 
desired parts, ratings, and Ship To location.
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The following figure is an example of how a company's Ship To locations are assigned to a 
Sourcing Project manager, who then selects a specific Ship To location for a Sourcing Project.

Figure 1–2 Ship To Location Assignment Process

Searching Agile Objects
When you use Agile PLM, you will need to find existing objects in the Agile system, such as 
sourcing projects, suppliers, items, manufacturer parts, and RFQs. You can search objects in the 
following ways:

? Quick Search - Searches objects by Name, Number, or Description.

? Advanced Search - Searches all objects with fields that match the conditions you have 
defined. For example, you could search for parts where the Description field contains 
"Computer."

? Saved Searches - Pre-defined searches that have been saved for later use.

? Bookmarks - A list of frequently visited Agile objects. You can click a bookmark to 
quickly display that object.

For complete information about how to search for Agile objects, see Getting Started with Agile 
PLM.

Working with Customers, Suppliers, and Partners
You can use Agile PLM to manage organizations that exist outside your company, such as 
Customers, Suppliers, and Partners. These outside organizations participate in business 
processes such as sourcing, quality management, and design engineering, and are involved 
throughout various phases and activities of a program.

Customers and Suppliers are two Agile PLM classes you can use to define organizations. 
Partners are suppliers with whom your company has a special relationship, and are therefore 
given access to complete project BOMs, whereas ordinary suppliers can view only the 
information about assigned Items in an RFQ.

Each Sourcing Project can be associated with a Customer, Supplier, and/or Partner. These 
objects must exist in the Agile system before you create a project.

For details on how to create and manage Customers and Suppliers, see the chapter called 
"Managing Customers and Suppliers" in Getting Started with Agile PLM.
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Top PCM User Tasks
In PCM, there are many activities that take place during the sourcing process. From creating 
suppliers to creating sourcing projects and RFQs to publishing prices, some top tasks that PCM 
users must complete include the following:

? Working with Sourcing Projects

– To create a sourcing project, see "Creating a New Sourcing Project" on page 2-2.

– To add items to a sourcing project, see "Adding Items to a Project" on page 2-15.

? Creating RFQs

– To create RFQs from a sourcing project, see "Creating Request for Quote" on 
page 6-7.

– To request information from the suppliers, see "Creating Request for Quote" on 
page 6-7.

? Working with RFQs

– To change the status of an RFQ to Open, see "Changing the RFQ Status" on 
page 6-15.

– To share an RFQ, see "Sharing an RFQ With Other Users" on page 6-22.

– To open an RFQ to suppliers, see "Sending RFQs by Changing the Status" on 
page 6-13.

– To lock the responses in the Responses tab, see "Editing Responses" on page 6-20.

– To request a requote, see "Requesting Requotes" on page 6-22.

? Analyzing Prices in a Sourcing Project

– To set best responses for item response lines, see "Setting the Best Response for an 
Item" on page 5-16.

– To view a Costed BOM comparison, see "Viewing Costed BOM Comparisons" on 
page 5-5.

? Managing Prices

– To create prices, see "Creating Prices" on page 9-5.

– To add price lines, see "Creating Price Lines" on page 9-7.

– To release prices through a PCO, see "Redlining Price Information" on page 10-4.

? Managing Suppliers

– To create suppliers, see "Creating a Supplier" on page 7-7.

– To assign line cards, see "Defining Manufacturer and Commodity Offerings" on 
page 7-11.

? Managing Commodities

– To create commodity objects, see "Creating Commodities" on page 7-4.

– To add items to a commodity, see "Associating Items with Commodities" on page 7-6.

? Using Java Client for PCM administrative tasks

– To map attributes between Product Collaboration and PCM, see "Pulling Data from 
Item Master Flex Fields into Sourcing Projects" on page B-8.

– To set up RFQ Terms & Conditions, see "RFQ Terms and Conditions" on page B-3.
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What's New in PCM
The following sections list PCM new features by the product release in which they were 
introduced.

New features in PCM 9.3.6
There are no new features in Agile PCM Release 9.3.6.

New features in PCM 9.3.5
There are no new features in Agile PCM Release 9.3.5.

New features in PCM 9.3.4
New features in Agile PCM Release 9.3.4 include the following:

? Support for decimal values in PCM has been increased from a maximum of 6 to 9 for all 
PCM money attributes. The decimal value is controlled by the Price Scale attribute in the 
Administrator. For more information see, "Configuring Preferences for PCM" on 
page B-22.

Some new, general PLM features that affect PCM include the following:

? Ten new large text attributes have been introduced for P2 and P3 of all objects. The large 
text attributes are not available for mapping from PC to PCM. For more information, see 
the Agile PLM Administration Guide.

New features in PCM 9.3.3
New features in Agile PCM Release 9.3.3 include the following:

? You can now update the Quantity Per Assembly (QPA) for an item in a sourcing project. 
You can also update the QPA field with data from the Item Master, and publish the QPA 
back to the Item Master when publishing the items. For more information see, "Editing 
Quantity Per Assembly (QPA)" on page 3-4.

? QPA can be edited in PCM through Import, SDK, and Web Services. See relevant 
documentation for more information.

Some new, general PLM features that affect PCM include the following:

? Several new list fields have been added to Page Two for only the Item object (Parts and 
Documents). Although these fields are not directly related to PCM, just like other P2 
fields, they can be mapped to sourcing project attributes. For more information, see the 
Agile PLM Administration Guide.

New features in PCM 9.3.2
New features in Agile PCM Release 9.3.2 include the following:

? You can now restrict suppliers from proposing alternates in an RFQ, by unchecking the 
Propose Alternates option in the RFQ's Data to Share options. See "Selecting Data to Share 
with Suppliers" on page 2-17 for more information.

Some new, general PLM features that affect PCM include the following:

? Additions have been made to routable object workflows, such as PCOs in PCM, to allow 
for greater efficiency when a user changes job functions. A new global list, Job Function, 
was created so that job functions, users, and user groups can be linked together to form 
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functional teams. The functional team attribute was added to the following PCM-related 
objects:

– Prices (General Information tab)

– PCO (Cover Page tab)

– Part Group (General Info tab)

Read and modify privileges for Prices, PCOs, and Part Groups now have the Functional 
Team(s) attribute. Functional teams that have been added in the Prices Cover page will be 
pulled into the PCO > Affected Prices tab as a read-through field. Functional teams can also be 
added to the PCO manually. The Functional Team attribute is a read only field on an Items's 
Prices tab, Manufacturer Part's Prices tab, and PCO's Affected Prices tab. For more information 
about these workflow changes, see the Getting Started with Agile PLM.

? Also, in addition to approvers and observers, a new group of reviewers called 
acknowledgers, have been added to workflows. For the PCO workflow, acknowledgers 
need the Acknowledge PCOs privilege or the (Restricted) Acknowledge PCOs privilege 
for suppliers. Acknowledgers need to confirm that they performed what was expected of 
them when the object (PCO in PCM) was routed in the Price Review and Release status 
criteria. It is not an approval, but is required. For more information about these and other 
related changes, see Getting Started with Agile PLM.

? Audit windows now contain hyperlinks to unresolved issues, where the errors are 
highlighted, so that a user can correct errors more easily to pass the audit. In PCM, you can 
get audit warnings if:

– there are manufacturer redlines that will be lost after the routable object is released.

– there are conflicts due to another routable object being released first.

– the DuplicateFindNumbers SmartRule is set to Warning or Disallow and there are 
duplicate numbers caused by a change release.

– the DuplicateRefDes SmartRule is set to Warning or Disallow and there are duplicate 
reference designators caused by a change release.

– the Item Release First SmartRule is set to Warning or Disallow and there are 
unreleased children.

There are additional circumstances that prompt audit warnings in PCM and elsewhere in PLM. 
To learn more about the audit warnings and how to resolve the issues, see Getting Started with 
Agile PLM.

New features in PCM 9.3.1
New features in Agile PCM Release 9.3.1 include the following:

? Supplier users can now be authenticated through an LDAP server. For more information, 
see the Agile PLM Administrator Guide.

? The BOM filtering feature now enables filtering on fields other than BOM flex fields and 
BOM Quantity. All enabled cover page, P2, and BOM tab fields are available for filtering. 
See "BOM Filtering" on page 2-9 for details.

? All standard and flex fields are now bulk editable on the Analysis tab. See "Bulk Editing" 
on page 4-2 for details.

? Several features that were previously only available on the Items tab or the AML tab are 
now also available on the Analysis tab. For example, you can now add items to a sourcing 
project from the Analysis tab. See "Completing Non-Analysis Tasks on the Analysis Tab" 
on page 5-1 for details.
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? You can publish rolled up material costs for an assembly. See "Publishing Rolled Up 
Material Costs for Assemblies" on page 5-22 for details.

? Multi-column sorting and filtering is available on "Configuring Project Tabs" on page 2-12 
for details.

? Multi-column filtering is available on the RFQ-Responses tab and the RFQ 
Response-Responses tab.

? Using SDK, you can now export PCM data into a spreadsheet, apply your own price 
models, recalculate the costs using your own formulas and data from external sources, and 
finally import the recalculated costs back into PCM. Two new IProject APIs are available 
through web services to support this new price model feature. For more information, see 
the SDK Developer Guide.

? All dates related to prices are now in DateOnly format in GMT. Project periods, RFQ due 
dates, price line effective from/to dates, valid from, and valid until dates are all now in 
DateOnly format.

? A new configurable attribute is available on the RFQ Response Entry form to allow you to 
explicitly set a start date for prices that have quantity breaks. The new attribute, Valid 
From, has a default of the current date.

? Table Edit mode for editing response lines is unavailable.

Some new, general PLM features that affect PCM include the following:

? You now have the ability to choose which tabs you see with the "Manage Tab Display" 
privilege. See Getting Started with Agile PLM for details.

? Your Agile administrator now has the ability to configure a status in a workflow so that no 
password is required for approval or rejection. Therefore in PCM, you may not need to 
enter your password in the approval/rejection window for a PCO. For more general 
information, see the Agile PLM Administrator Guide.

? There are a few new search features that affect PCM:

– You can now access the advanced search palette from within the quick search window 
when you attempt to add objects to a table by search. You can also use saved searches 
to populate the advanced search palette. Once you have the results you need in the 
advanced search palette, you can directly add the objects to the table by drag and drop, 
and so on. For more information about how this affects your ability to add items to a 
table, see "Adding Items to a Project" on page 2-15

– When filling in list or multi-list fields, in addition to being able to either type in values 
or use the quick search, you can now use saved searches. A saved search button 
appears on the quick search palette. The saved search feature is available for all list 
and multi-list fields in cover pages, tabs, action dialogs, and wizards.

– The ability to use advanced searches is now available when running reports that have a 
step in their wizard that requires you to add items or another object to a table. For 
example, in PCM, the Effective Cost Comparison report wizard requires that you add 
items or manufacturer parts to be analyzed in the report to a table. You can click the 
"Custom Search" button to launch the advanced search palette. Saved searches are also 
accessible from within the advanced search palette. You can add objects directly from 
the advanced search palette to the table.

– Custom search is now also available during the export process scenarios, as well.

Note: For detailed information about any of the new search features, see 
Getting Started with Agile PLM.
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New features in PCM 9.3
Several new UI enhancements in Agile PLM help make the PCM experience more efficient and 
beneficial. Additionally, event functionality is now available to help automate certain actions. 
The following sections provide an overview of PCM-specific enhancements. For details about 
general UI enhancements that affect all Agile PLM modules, see Getting Started with Agile 
PLM.

UI Enhancements
There are several new enhancements and changes to the UI in PCM. The following are some 
general changes:

? You can "drag and drop", or copy and paste, data into Sourcing Projects, PCOs, and 
Suppliers. For example, you can drag items from your My Bookmarks folder and drop 
them into the Items table on the Items tab of a sourcing project.

? When filling in list and multi-list fields in a form, you can type ahead values if you already 
know the value you want to enter. If you do not know the value to enter or if the value you 
enter displays in red, you can search for the value by clicking the search button.

? When filling in date fields, you can either type in the date manually or click the calendar 
button to select a date.

? The Prices, PCO, and Commodity objects support full view personalization.

? The Supplier, Sourcing Project, RFQ, and RFQ Response objects support limited view 
personalization.

For details about view personalization and other general UI enhancements, such as the drag and 
drop feature, see the Getting Started with Agile PLM.

UI Enhancements for Sourcing Projects
The following are enhancements that affect the Sourcing Project object:

? Some action buttons, and their menu options, have been rearranged and/or renamed in the 
Items, AML, and Analysis tabs.

? The Personalize button replaces the Configure Display button. The Personalize button 
launches the personalization palette.

? Multi-column filtering is supported in the AML tab through view personalization. Sorting 
is not supported.

? Filtering is supported in the Analysis tab through view personalization. Multi-column 
filtering is not supported. For more details about filtering in Sourcing Projects, see 
Filtering Project Data.

? On the Items tab and the AML tab, editing of Item/Manufacturer Part information is done 
through the Item/Manufacturer Part quick view palette. To access the quick view palette, 
click the number of the Item or Manufacturer Part.

? Changes tab has 3 sub-tabs: Item Master Changes, Project Item Changes, and Supplier 
Response Changes. The content on the three tabs was previously available as three separate 
views.

Note: For more information about personalization in PCM, see 
"Configuring Project Tabs" on page 2-12.
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? On the Analysis tab, view options for price details, that were previously accessed through 
Filter functionality, have been relocated to a View drop-down list.

? On the Analysis tab, the price lookup wizard was redesigned to improve efficiency. See 
"Looking Up Price Information" on page 5-19.

? When adding items from Product Collaboration to a sourcing project, you can now narrow 
down your search by item revision.

? Changes in the BOM filter UI and the process. See "BOM Filtering" on page 2-9

? Changes in the procedure for adding AML to an item in a project. See "Adding an AML to 
an Item" on page 4-3

UI Enhancements in RFQs and RFQ Responses
The following are enhancements that affect the Requests For Quote object:

? Some action buttons, and their menu options, have been rearranged and/or renamed on the 
Responses tab.

? Filtering is supported in the Responses tab through view personalization. Multi-column 
filtering is not supported.

? Response Status tab has 2 sub-tabs - Supplier Response Status and Terms & Conditions. 
The content on the two tabs were previously displayed as tables on the same page.

The following are enhancements that affect the RFQ Response object:

? Some action buttons, and their menu options, have been rearranged and/or renamed on the 
Responses tab.

? Filtering is supported in the Responses tab through view personalization. Multi-column 
filtering is not supported.

? When using Advanced Table Edit mode, inline table editing is supported for editable fields.

? The wizard flow diagram in the left pane is no longer displayed. Instead, when using Basic 
edit mode, the diagram is replaced with a text version of the flow steps. The flow is not 
displayed while in other edit modes.

UI Enhancements in Prices and Price Change Orders
The following enhancement affects the PCO object:

? On the Workflow tab, the Summary table and the Signoff History table have been 
combined into one table. Now, the two sections on this tab are the Summary section and 
the Workflow section, which contains the table.

Events in PCM
In Agile PLM, a preconfigured event is an automation that occurs when a user performs a task 
that is specified by an event mask. The triggered event then results in an event outcome, such as 
the delivery of a notification to a user. There is limited event functionality for the PCM 
solution, however, some events are configurable for PCM objects, including Sourcing Projects. 
For more details about event functionality in PCM, see "Managing Events in PCM" on 
page B-22.
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2Working with Sourcing Projects

This chapter provides information about working with sourcing projects in PCM.

About Sourcing Projects
A sourcing project is the entry point of sourcing and product pricing. A sourcing project tracks 
data required for sourcing and pricing, to perform data analysis for effective pricing.

The project data includes Items and Assemblies, Bills of Material (BOMs), and Approved 
Manufacturers Lists (AML). Multiple users can work as a team to complete sourcing and 
pricing activities, since the project lets multiple users view and modify the same components. 
Projects allow you to execute sourcing activities, including Request for Quotes (RFQs), 
depending on the lifecycle phase and analysis of your Item Master content.

Product Cost Management (PCM) consists of the Product Sourcing solution in combination 
with the Price Management solution to integrate and leverage valuable price and cost 
information within your business processes.

You can create a project from the beginning or create a copy of an existing project using the 
Actions > Save As command. The copied projects will not contain information such as 
partners, RFQs, supplier responses, and history.

The following diagram shows how a project functions in the RFQ, supplier response, and 
analysis flow in Product Cost Management.

Note: The object previously known as the PPM Program was renamed as 
Project object. There is no relation between the PPM Project object and the 
PCM Sourcing Project. All references to projects in this guide are to PCM 
Sourcing Projects.

Note: You access Sourcing Projects primarily through the Agile Web 
Client.
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Figure 2–1 Project Flow

Project Lifecycle Phases
The lifecycle phases of a project are Draft, Open, and Closed. A project is in the Draft state 
when it is created. You can create RFQs and receive supplier responses when the project state is 
Open. You can change the status of the project from the Change Status menu.

A project remains open until the project owner changes the status to Closed.

Creating a New Sourcing Project
This section describes different methods to create a sourcing project.

Using the Project Creation Dialog
You can create a project by choosing Create New > Sourcing Projects.

Note: You must complete the Ship To Location field on the General 
Information tab before you change the state of the project from Draft to 
Open.

Status Description

Draft This is the initial lifecycle phase of a project. In this state, you can edit only 
the Cover Page attributes, Item component data, and Attachments. In this 
state, however, you cannot create RFQs from the project.

Open The RFQ creation and supplier responses are active after the project is 
moved to the Open state.

Closed Set by the project owner when all tasks for the project are completed.

Note: The Project object in the Create New menu is a PPM object. It is 
different from the PCM Sourcing Project object.
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Creating a Project
1. Click Create New > Sourcing Projects. The Create New Sourcing Projects dialog 

appears.

2. Select the type from the Type drop-down list.

3. Enter a unique identification number (unique identifier for the project) in the Number field, 
or click the Auto Number icon for the system to generate a number based on the Auto 
Numbering functionality defined for the Project Type.

4. Define the price scenarios for the project. Select Quantity Breaks or Effectivity Periods. 
For more information, see "Specifying the Price Scenario" on page 2-6.

5. If you selected Quantity Breaks in step 4, select the number of quantity breaks you want 
from the drop-down list. You can set up to six Quantity Breaks per project.

6. If you selected Effectivity Periods in step 4, follow these steps:

1. Select a number in the Number of Date Periods drop-down list. You can set up to 20 
date periods.

2. Select the period type from the Period Type drop-down list. Available values are 
Monthly, Quarterly, Semi-Annually, Yearly, and Variable.

3. If you selected Monthly, Quarterly, Semi-Annually, or Yearly for the Period Type, 
select the effective start date from the Start Date drop-down list.

4. If you selected Variable for the Period Type, specify the start and end dates for each 
period.

5. Select a number from the Quantity Breaks per Period drop-down list.

6. Click Save. The General Info tab of the new sourcing project appears.

The specified project is created in the Draft state.

Entering Sourcing Project Information
Enter general information for a sourcing project from the General Info tab of the project. The 
following table describes sourcing project fields that are included on the General Info tab.

Note: The fields in the Create New Sourcing Projects dialog that are 
marked in bold are required fields. Fill in required fields to proceed.

Note: The number field could also be filled in automatically and may not 
be editable. Numbering for sourcing projects depends on the configuration set 
up by your Agile administrator.

Field name Constraint Description

Number Read-only The unique identification number of the project.

Description Optional The description about the project.

Lifecycle Phase Read-only The current lifecycle phase of the project. The 
default state is Draft.
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Program Optional The program to which the project applies. For 
example, you can define your programs and 
information needed for a specific program. You 
can select the program for which the project is 
being created from the drop-down list. If this field 
is blank, the project information applies to all the 
programs.

Customer Optional Customer to whom the project applies. You can 
select the customer by clicking the Search button 
next to this field and running a search. If this field 
is blank, the project information applies to all the 
customers.

Manufacturing Site Optional The site where the project will be handled. You 
can select the site from the drop-down list.

Select a site only if the project is site-specific. If it 
is, when adding an assembly from PC, only the 
bill of materials (BOM) belonging to the specific 
site is added to the project; the rest of the items 
are ignored. For example, if a project is specific to 
"San Jose" and if you add an assembly which has 
a BOM from "San Jose", "Milpitas", and "global", 
only the BOM for San Jose is added to the project. 
It will not add the global/common BOM or 
Milpitas BOM.

Ship To Location Required (for RFQ 
creation)

The location to which the items in the project are 
to be shipped. You must specify the location to 
move the project into the Open lifecycle phase.

The list of Ship To locations is determined by the 
setting for the Authorized Ship To property in 
your user profile. If your user profile does not 
specify any authorized Ship To locations, you 
won't be able to select a value for this field.

Project Currency Required You can select the currency from the drop-down 
list.

The project currency determines how other 
currency values (for example, price quotes entered 
by suppliers in an RFQ response) are normalized 
based on the system's currency exchange rate 
table. The default currency depends on the 
currency of the current user.

Product Lines Optional The product line(s) the project is associated with.

Number of Periods Read-only Number of effectivity periods.

Number of Qty 
Breaks

Read-only The number of quantity breaks in the project.

Data to Share Optional The data to share with the suppliers in all RFQs 
generated from the sourcing project. You can 
select the fields to expose to the supplier in the 
RFQ in the Data to Share with Suppliers window 
by clicking the button next to the Data to Share 
field. The Data to Share settings at the sourcing 
project level can be overridden at the RFQ level.

Field name Constraint Description
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To enter data into a sourcing project:

1. Open the sourcing project.

2. Click the Edit button on the General Info tab.

3. Modify fields, as needed.

4. Click Save.

Adding Items to the Project
Once you have created a project, you can add items to a project in several ways. See "Adding 
Items to a Project" on page 2-15 for more details.

Adding Attachments to the Project
1. Open a sourcing project and click the Attachments tab.

2. Click Add > Add Files or Add > Add URLs or click Add > By Search to search for file 
folders.

Response Required 
Fields

Optional The response information required from the 
suppliers for all RFQs generated from the 
sourcing project. You can select the required 
fields from the Response Data Requirements 
window by clicking the button next to the 
Response Required Fields field. The Response 
Required Fields settings at the sourcing project 
level can be overridden at the RFQ level.

Supplier Instructions Optional Instructions that are communicated to suppliers 
through RFQs created from the project.

Owner Required The owner responsible for the project. Only the 
owner can create RFQs from the project. You can 
select the owner by clicking the Address Book 
button next to the Owner field.

Creator Read-only The creator of the project.

Created Date Read-only The date when the project was created.

Last Modified Read-only The date when the project information was last 
modified.

Project Type Read-only The type of the project. It is Sourcing Project by 
default.

Authorized Users Optional Users authorized to work with this project. You 
can select the authorized users by clicking the 
Address Book button next to the Authorized Users 
field.

Disallow AML 
Statuses

Optional Specifies AML statuses for parts that you do not 
want brought into the project. Use this field to 
automatically filter out manufacturer parts that are 
not preferred, discontinued, or are disqualified for 
some other reason.

Note: The Project Number, Lifecycle Phase, Number of Periods, Number 
of Qty Breaks, Creator, Created Date, and Last Modified Date fields are 
updated automatically.

Field name Constraint Description
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Quick Step from an Item
You can create a project directly from the Item object within Agile Product Collaboration (PC).

1. Open an item.

2. Click Actions > Create New > Sourcing Project.

3. Select the Sourcing Project Type.

4. Enter Number.

5. Enter the Price Scenarios (either quantity breaks or effectivity periods).

6. Select the Manufacturing Site location from the drop-down list.

7. Select any AML status in the Disallow AML Statuses field that you want to exclude. An 
AML with the selected status will not be added from PC into the sourcing project.

8. Click Save.

Specifying the Price Scenario
The two types of project price scenarios are Quantity Breaks and Effectivity Periods.

? Specify Quantity Breaks to capture prices based solely on quantities. You can determine 
how the cost of products might change based on different quantity scenarios. When you 
select the Quantity Breaks price scenario, you can capture prices for up to six quantity 
breaks. Although the system automatically generates a start date for this type of price, you 
can choose to specifically set the Valid From and Valid Until date fields on the RFQ 
Response entry form. See "Response Entry Form" on page 6-21

? Specify Effectivity Periods to capture prices based on future dates, which helps you assess 
the cost of products for future time periods. The Effectivity Periods scenario also supports 
quantity breaks per period, which enables you to create a combination of period and 
quantity scenarios. When you select the Effectivity Periods price scenario, you can capture 
prices for up to 20 price periods, and potentially six quantity breaks per period.

Quantity Break Example
The following table provides an example of the Quantity Breaks price scenario, using three 
quantity breaks.

Note: For more information about adding an attachment, see Getting 
Started with Agile PLM.

Note: The Manufacturing Site field and the Disallow AML Statuses field 
(from the next step) only appear if they have been enabled by the Agile 
administrator.

Quantity breaks
Selected quantity 
breaks

500 X

200 X

100 X
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Effectivity Period Examples
The following table provides an example of the Effectivity Periods price scenario, using four 
date periods and one quantity break per period.

The following table gives an example of the Effectivity Periods price scenario, using four price 
periods and two quantity breaks per period.

Dates for Price Periods
Agile PCM does not use a fixed calendar for its dates, so technically all price periods that you 
specify can have any start and end date. All dates related to prices are in DateOnly format in 
GMT.

When you create a project, the Sourcing Projects Creation dialog enables you to specify up to 
20 price periods. However, there is no actual limit to the number of price periods in a project. If 
you open a project and choose Actions > Modify Price Scenarios, you can add more than 20 
periods.

If you delete a price period, the period and any price information associated with it are 
removed. If the Auto Publish Quote History SmartRule is set to "Allow," the system 
automatically creates quote histories when you delete a price period from a sourcing project, if 
and only if, the sourcing project has an RFQ associated to it. For more information about 
SmartRules, see Agile PLM Administrator Guide.

Because there is no fixed calendar in Agile PCM, effectivity periods can overlap. However, if 
the Overlap Price Line Effectivity Periods SmartRule is set to "Disallow," the system rejects 
any overlapping periods when you publish prices.

When you modify price scenarios, you can delete price periods or add new price periods before 
or after the existing range of price periods. For more information, see "Modifying Price 
Scenarios" on page 2-19.

Quantity breaks
01/01/09 to 
03/31/09

04/01/09 to 
06/30/09

07/01/09 to 
09/30/09

10/01/09 to 
12/31/09

500 This cell is blank. This cell is blank. X This cell is blank.

350 This cell is blank. This cell is blank. This cell is blank. X

200 This cell is blank. X This cell is blank. This cell is blank.

100 X This cell is blank. This cell is blank. This cell is blank.

Quantity breaks
01/01/09 to 
03/31/09

04/01/09 to 
06/30/09

07/01/09 to 
09/30/09

10/01/09 to 
12/31/09

500 This cell is blank. This cell is blank. X X

350 This cell is blank. X X X

200 X X This cell is blank. This cell is blank.

100 X This cell is blank. This cell is blank. This cell is blank.

Note: The Modify Price Scenarios option appears in the Actions 
drop-down list only when the project has price periods. This option is not 
available when project is created with quantity breaks.
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Creating a Project Using Save As
At times, you may want to create a project that requires the same general information and items 
as an existing project. To save time, search for the existing sourcing project and save it with a 
different name. Saving an existing sourcing project with a different name saves the general 
information about the project, the items it includes, and any attachments to the project. The 
partners, RFQs, responses, response lines, and history are not saved.

To reuse cover page information such as, Effective Periods, Data to Share, Response Required 
Fields, and/or Supplier Instructions, for all of your sourcing projects, you can create a sourcing 
project that has those fields set to specific values and use the project as a template. Every time 
you want to create a sourcing project, you can do a save-as on the template project so that the 
new project automatically inherits all the cover page information and attachments.

To save a copy of a project:

1. Open the project you want to use as the basis for a new project.

2. Select Actions > Save As. The Save As dialog appears.

3. Select the Type of sourcing project from the drop-down list.

4. The next available number appears in the Number field. You can click the AutoNumber 
button to generate the next project number, or enter the project number.

5. Click Save.

6. Click Edit to modify the general project information. Click each tab in the project to verify 
and edit the information, as needed.

Sharing a Project with Other Users
Sharing is how you define the people who have access to a project. When you share a project, 
you grant one or more of your roles to another Agile user or user group. The roles that you can 
share with a user include your own assigned roles and roles that have been shared with you by 
belonging to a user group. Any users or user groups that you share a project with can perform 
actions permitted by the role(s) for that project only.

For general information about sharing Agile objects with other users, see Getting Started with 
Agile PLM.

To share project:

1. Open the project.

2. Choose Actions > Sharing. The Share With Users dialog appears.

3. Click Add. The Add Users dialog appears.

Note: AutoNumber functionality is controlled at the subclass level in Java 
Client and may have been changed by your Agile PLM administrator.

Note: You can modify the price scenarios of projects, which use Effectivity 
Periods and are created using the Actions > Save As feature. For more 
information, see "Modifying Price Scenarios" on page 2-19

Note: You cannot share those roles that have been shared with you by 
another user.
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4. Click the Address Book button to the right of the Users field. The Users search palette 
appears.

5. Use the drop-down filter in the Users search palette to select all users (Users) or all groups 
(Groups) or any other specific groups.

Enter your search criteria and click Search. You may also type a user's name if you know 
exactly how it appears in the system, but you must select a group first to populate the 
Available Users list.

6. Select the users one by one or select multiple users/user groups using the Ctrl button on 
your keyboard. Drag and drop your selected item(s) to the Users cell.

7. Click the list button to the right of the Roles field. The Roles palette appears. Select the 
appropriate role or roles for your chosen users to have available in relation to the project. 
Drag and drop them into the Roles cell.

8. Click Save. Your additions are listed in the Share With Users window.

9. Click Close.

To remove users from a project's Access Control List:

1. Open the project.

2. Choose Actions > Sharing. The Access Control List: Share With Users dialog appears.

3. Click the rows of users to remove.

4. Click Remove.

To see which objects have been shared with you:

1. Click the My Settings button in the Courtesy Controls area in the left pane.

2. Click the Share tab.

The Share tab lists the objects that have been shared with you by another user.

3. From your user profile, see if any objects have been shared with you through user groups.

4. Click the User Group tab.

5. Click a desired group.

6. Click its Share tab.

The Share tab lists the objects for which the group and all its users have been granted shared 
roles by another user.

BOM Filtering
The BOM filtering feature enables you to set up filters to selectively add components in BOM 
structures. You can filter components based on any enabled attributes from the cover page, P2, 
and BOM tabs of the Item object. Since the Parts and Documents classes are based on the Items 
base class, the Parts and Documents cover page fields are also available for filtering.

Note: To see the Access Control List for a project, choose Actions > 
Sharing again. The Access Control List shows the complete list of users who 
have access to the project.
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To use BOM filtering, you must first enable and configure BOM filters through the Java Client 
Admin tab. For procedural steps to set up the BOM filters, see "Configuring BOM Filters" on 
page B-20.

BOM filters are inherited by top-level assemblies when the assemblies are added into a 
sourcing project from PC Item Master. Alternatively, when adding an assembly to a sourcing 
project, a BOM filter can be set up for that assembly, which overrides the inherited filter.

Content update uses the same filter settings that you use during the item additions. These filter 
settings display in the sourcing project Item table. You can update the project filters even after 
you add the items.

The BOM filter is updated through a special dialog that is similar to the controls of the general 
filter functionality. When adding items by search, you have access to BOM filtering from 
within the search palette, as shown below.

Figure 2–2 BOM Filtering in Search Palette

If you have BOM filters enabled and you try to add items using copy/paste or drag/drop, the 
BOM Item Filter pops up.

Figure 2–3 BOM Item Filter Pop Up Dialog

Note:  P3 fields, Document-P2 fields, and all read through fields are 
unavailable for filtering.

Note: Part-P2 fields are available for filtering.

Note: The settings affect only the future item additions and have no impact 
on the added items.
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When you click the Edit button from within the search palette or the BOM Item Filter pop up 
window, the BOM filter window appears, as shown below.

Figure 2–4

Adding BOM Components with Filters
You can set up filters to selectively add BOM components when you add items to a sourcing 
project.

To use BOM filters:

1. Attempt to add an item to a project by search, drag and drop, and so on.

2. If enabled, the BOM Filter field appears when you attempt to add existing items to a 
sourcing project. Go to "BOM Filtering" on page 2-9 to see how the BOM filter appears in 
the UI.

3. Apply BOM filters during the item addition process.

4. After an item addition, the filter is associated with the item.

5. Content Update uses the filter settings that are used during the item addition.

6. BOM filter setting defaults to the filter setting of the last import.

7. Alternate filters can be applied to each new item added to a single sourcing project.

BOM Filter Examples
The following are examples of BOM filter usage.

Example 1: No Filter Applied
When you add items from PC to a sourcing project, duplicate items are not added. Only one 
instance of an item is retained.

Note: Your administrator must have enabled this field in the Java Client in 
order for it to appear when you add items by drag and drop or for it to be 
visible in the search palette (if you add by search).
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Example 2: Apply a BOM Filter to exclude unwanted components
Assume that the assembly belongs to several product lines. If you are interested in components 
of only a specific product line, you can set up the filter criteria in the BOM filter to be Product 
Line = 'X'. As a result, only components of that product line will be added to the sourcing 
project.

Example 3: Apply a BOM Filter to exclude unwanted components
Take the following assembly structure as an example.

Assume, for example, that your organization uses a QPA of 0 to indicate unwanted parts or 
items. When adding this assembly, you could use the BOM filter to only add items with "QPA 
not equal to 0". In that case, everything except P3 is added, which had a QPA of 0 indicating 
that it is unusable.

Configuring Project Tabs
On some tabs of PCM objects, you can select which fields to view (and how to view them) to 
obtain better performance and to meet your specific needs. The default view appears when you 
open the tab after login. Use the Personalize button, which brings up the Table Personalization 
palette to reconfigure the tab display.

From the Table Personalization palette, depending on the tab that you are on, you may be able 
to:

? Sort table results by up to three attributes.

For example, on the Discussions tab, you can sort discussions by the Create Date field in 
ascending or descending order. You can further sort the results by discussion Subject in 
ascending or descending order.

? Filter the information based on specified criteria.

For example, on the AML tab, you may want to view only the manufacturer parts that have 
a preferred status. To accomplish this, you can set your filter criteria to be "AML Status In 

Number QPA

A1 1

    P2 1

    P3 0

    P4 3

Note: Although the Personalize button is available for other PCM objects, 
this section focuses on Sourcing Projects since it is the object that buyers 
most frequently use.

Note: On the Analysis tab, primary sorting occurs on the item number. You 
can further sort the rows according to manufacturer part fields (for example, 
MPN #), AML fields (for example, AML status), and manufacturer part 
response fields (for example, transportation terms). You cannot sort by item 
or item-level fields. You can only sort AML rows within the context of the 
parent IPN.
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Preferred". For details on how to filter table rows, see "Filtering Project Data" on 
page 2-14.

? Format/select the fields (columns) that appear on the tab and set the order of the fields

For example, on the Attachments tab, if the Modified Date field is not visible, you can 
make it visible, and also change the location of the column to make it easier to find. For 
example, you could make the Modified Date the third column in the Attachments table by 
changing the order in which it appears.

You can also lock a particular column to ensure that it is always visible as you use the 
horizontal scroll bar. For example, you can lock the Number column so that it is always 
visible as you scroll to view other data to the right of the column.

The following table shows the personalization features that are available for each Sourcing 
Project tab.

Configuring the Display of a Project Tab
To configure the display of a Sourcing Project tab:

1. Open a project and select one of the configurable tabs.

2. Click Personalize. The Table Personalization palette appears.

? To sort fields: On the Sort tab, you can select up to three fields by which the table 
rows should be sorted. For each field, choose whether the sort should be done in 
ascending or descending order.

? To filter data: See "Filtering Project Data" on page 2-14.

? To format fields: On the Format tab, select the fields that you want to view on the tab 
from the Hidden Fields list. Click the right arrow button to move fields into the 
Displayed Fields list. Use the up/down arrows to change the order of appearance of the 
columns.

Tab Name Sort Filter Format Properties

Items This cell is blank. This cell is blank. X X

AML This cell is blank. X X X

Changes

(All sub-tabs)

This cell is blank. This cell is blank. X X

Analysis X X X X

RFQs This cell is blank. This cell is blank. X X

Discussions X X X X

Relationships X X X X

Attachments X X X X

History This cell is blank. X X X

Note: In addition to being able to personalize the data you see on a 
particular tab, you can also personalize which tabs you see for an entire 
object. You must have the "Manage Tab Display" privilege to do this. See 
Getting Started with Agile PLM for more details.
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? To lock a field (column): To lock a field in the Displayed Fields list, go to the Format 
tab, select the column, and click the lock icon.

3. Click Apply to apply the new display.

For more information about configuring your display using the Personalize button, see Getting 
Started with Agile PLM.

Filtering Project Data
The filter tool enables you to filter the rows of a table that is on an object tab, such as the table 
on the Items tab of a Sourcing Project object. This feature is not available on all tabs. Filtering 
is only available on the AML, Analysis, History, Attachments, and Discussion tabs of sourcing 
projects.

The Personalize button appears on most tabs and enables you to sort and format table content, 
and filter table content. Use the filter tab on the Table Personalization palette to display only 
the table rows you need.

To filter data on a tab:

1. Open the sourcing project and click the desired tab.

2. Click Personalize. The Table Personalization palette appears.

3. Click the Filter tab.

4. Click the Field drop-down list to select a field by which to filter.

5. Click the Operator drop-down list to select a relational operator for the filter. The list of 
relational operators varies based on the type of attribute selected.

6. Select a value for the filter criteria.

? For text attributes, type a value.

? For list attributes, click the list icon to select a single or multiple values from available 
values list.

7. To add additional filters, click the Add button.

Note:  If the selected field/column is not the first column in the table, all of 
the columns to the left of the selected column are also locked as you use the 
horizontal scroll bar.

Note: Once you click Apply, only the current view is affected. Once you go 
away from the current page, the applied view will be lost unless you save the 
view. When you make a change to the base view or a pre-defined view, you 
must click Save and then Save As to save the view as a new view. Later on, if 
you make changes to a view that was not pre-defined, you only have to click 
Save and the changes are saved to the existing view.

Note: The attributes available on the AML, Analysis, and Responses tabs 
vary based on how your Agile PLM system has been configured.
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8. Click Apply.

Filters are specific to each tab and do not affect other tabs.

Only Text, Numeric, List, and Money fields are filterable. Date, Multi-list, and Multi-text fields 
are not filterable.

For complete information about the table personalization features, see Getting Started with 
Agile PLM.

Adding Items to a Project
You can add items to a project while on the Items tab or while on the Analysis tab. You can add 
them using one or more of the following methods:

? Search and add items from the Item Master.

? Drag items from your Bookmarks folder, Recently Visited folder, Navigator Drawer, or 
search (advanced or quick) window and drop them into the table on the tab.

? Copy items from your Bookmarks folder, Recently Visited folder, Navigator Drawer, or 
search window and paste them into the table on the tab.

? Import items from an external document, such as an Excel Workbook or a text file. See 
"Importing Item Data from a Spreadsheet" on page 2-17.

? Create new items. For more information, see "Creating Items to Add to a Project" on 
page 2-17.

To add existing items to a project:

1. Open a sourcing project and select the Items or Analysis tab.

2. Click Add > Search for Items.

3. Search for existing items. You can use either the quick search or custom search.

? Quick search: Enter your search criteria and click the right to do a quick search. Select 
the revision state from the drop-down to narrow your search

Note: Multi-column filtering is not available on all tabs.

Note:  To save this filter for future use, click Save. You must then click 
Save As to save the settings as a new filter.

Note: You cannot create a BOM in a sourcing project.

Note: The newly created items are not automatically added to the Item 
Master. You can publish content by using the publish feature on the AML or 
Analysis tabs.

Note: If BOM filtering is enabled, the BOM filter appears when you 
attempt to add items by search, drag and drop, or copy/paste.
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? Custom search: Click the custom search button. The custom search option launches 
the advanced search palette.

4. Once you have selected the row(s) you want to add, use your mouse to drag and drop them 
in the table. You can also double-click individual items to add them or select multiple rows 
and press Enter.

Adding Items with Filters
When adding items from PC to a sourcing project, if BOM filtering is enabled, you can use 
BOM filters to filter out unwanted items.

To use BOM filters with the Add Project Items dialog:

1. Open the Sourcing Project and click the Items tab.

2. Click Add > Search for Items. The Search palette appears.

3. Click Edit next to the Filter field, which is located at the bottom of the Search palette. The 
BOM Filter palette appears.

4. Select a field and an operator from the corresponding drop-down lists.

5. Enter a value.

6. Click the Add button to add more filter criteria.

7. Click OK. The BOM Filter appears in the Filter field in the page.

Note: From within the advanced search palette, you can also click to launch 
a palette that lists any saved searches that return objects of the same base 
class that is selected in the search criteria in the advanced search palette 
window. When you click the name of a saved search, the results appear in the 
advanced search palette.

Note: You can also add items to a project by dragging items from the 
Bookmarks or Recently Visited folders or from the Navigator Drawer and 
dropping the items directly into the Items table. You can also copy and paste 
objects into the Items table. For general information about these shortcuts, as 
well as more details about searching for objects in Agile PLM, see Getting 
Started with Agile PLM.

Note: If there are any duplicate components in the selected items, the QPA 
(Quantity Per Assembly) attribute of the duplicated components are 
automatically added together and the duplicate components are represented as 
a single item in the sourcing project. This automatic aggregation occurs only 
when the DuplicateItemNumbers SmartRule is set to Allow or Warning. If 
the SmartRule is set to Disallow, and duplicates are selected, PCM does not 
aggregate the QPAs, but instead selects the QPA of the first BOM entry that 
is encountered.

Note: The Search button does not appear when you are required to input a 
value.
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Importing Item Data from a Spreadsheet
You can import item data into a sourcing project.

For complete details on the import process, see Agile Import/Export Guide.

Creating Items to Add to a Project
You can create items in the project in the Create Item dialog. Items created in this dialog are not 
published to the Item Master automatically. However, you can publish them later. For more 
details about publishing items, see "Publishing Items and Manufacturer Parts" on page 4-9.

To create new items:

See "Creating New Items in a Project" on page 3-2.

Selecting Data to Share with Suppliers
You can decide on the data about the project that you want to share with suppliers. You can 
restrict the information available to a supplier in an RFQ.

You can use the Data to Share with Suppliers palette to restrict the visibility of information to 
the supplier.

The types of data to share include:

? Cover Page fields

? Item and AML fields (including AML split percentages)

? Other information (BOM view, RFQ attachments, and item and manufacturer part 
attachments, Propose Alternates, and so on)

Partners and suppliers can view the BOM structure only if the Content BOM View is shared 
with them. Partners can only see the Costed BOM, if the Costed BOM View is shared with 
them. These options provide partners and suppliers with more information before they submit 
their responses. Also remember that suppliers can only propose alternate parts if the Propose 
Alternates option is selected, which it is by default.

To select data to share with suppliers:

1. Open a project and go to the General Information tab.

2. Click Edit.

3. Click the list button next to the Data to Share field. The Data to Share palette appears.

4. Select the check boxes next to the fields and other information to make them visible to the 
supplier in the RFQ.

Note: You cannot add child items to an item created in a sourcing project 
until the item has been published to the Item Master.

Note: You can modify these fields at a later time by editing the information 
in the sourcing project's General Information tab. Changes in the Data To 
Share attribute is reflected in all new RFQs created in the future from the 
project. You can also modify this attribute in the RFQ's CoverPage tab (to 
apply changes to only an RFQ).
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5. Click Apply.

Requesting and Requiring Data from Suppliers
You can require suppliers to submit specific data that you have requested through an RFQ. The 
Response Required Fields palette enables you to request certain data and make some (if not all) 
of the requested data required. Lead Time and Inventory Available are a couple of the data 
items that you may require from a supplier.

To select data to request and require from suppliers:

1. Open a project and go to the General Information tab.

2. Click Edit.

3. Click the list button next to the Response Required Field field. The Response Required 
Fields dialog appears.

4. Select the check boxes next to the fields that you want to make Requested or Required.

5. Click Apply.

Updating Project Content from the Item Master
You can update the content of a project with information about the latest revisions. For 
example, your manufacturing division might have added a part in an assembly in the Item 
Master, and you may have the older version of the assembly in the project. You can update the 
assembly with the part in the Item Master on the Items or Analysis tab of the project. You can 
specify to update all BOMs, AMLs, and item and manufacturer part information, or just 
specific attributes, such as standard cost. To check for updates to sourcing project content, go to 
the Unapplied Item Changes sub-tab on the Changes tab.

Note: You can restrict the visibility of internal part numbers and internal 
part information by clearing the IPN Info check box in the Items & AML 
Fields section. Doing so makes the BOM invisible to suppliers receiving 
RFQs for this project. However, if no AML is associated with a given IPN, 
suppliers can still view part of the IPN information so that they can respond 
to the RFQ.

Note: You can modify these fields at a later time by editing the information 
in the sourcing project's General Information tab. Changes in the Response 
Required Fields attribute are reflected in all new RFQs created in the future 
from the project. You can also modify this attribute in the RFQ's CoverPage 
tab (to apply changes to only an RFQ).

Note: To be selected as Required, a field must also be marked as 
Requested. The system automatically marks the Requested check box, if not 
already checked, for any field that you mark as Required.

Note: If the project content update includes new components in assemblies, 
be sure to calculate new quantities after you do the update.
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The content update modifies the attributes of selected objects as follows:

? BOM - Updates the BOM structure (additions or deletions), quantity requirement per 
assembly, and part revisions.

? AML - Maintains AML attributes you changed, or resets all attributes to Item Master 
values.

? Item attributes - Updates by selected attributes, including description, commodity, unit of 
measure, standard cost, custom part, and any flex fields that appear.

? Manufacturer part attributes - Updates descriptions and any flex fields that appear.

To update project content:

1. Open a project and go to Items or Analysis tab.

2. Choose Edit > Update From Item Master. A caution message appears.

3. Click OK to update the content. The Update Content from Item Master dialog appears.

4. Select the All Content option to update all the objects associated in the project, or select 
the Selected Content option and select the attributes manually.

5. Regarding the Approved Manufacturer List, choose whether you want to update the 
sourcing project with AML information (Maintain AML changes made in Sourcing 
Project) or update the AML with the latest Item Master content (Synchronized AML with 
Item Master).

6. If you chose to update only "Selected Content", then you must also select the Item Part 
Attributes and Manufacturer Part Attributes that you want updated.

7. Click Update. The update is applied.

8. To view the update, click the Project Item Changes sub-tab on the Changes tab.

Modifying Price Scenarios
When a project uses the Effectivity Periods price scenario, you can remove old price periods, 
add new ones, and reset the current period. A notification lets you know when the current price 
period is about to expire so you can add new ones.

To modify price periods:

1. Open a project.

2. From any tab, choose Actions > Modify Price Scenarios. The Modify Periods dialog 
appears.

Note: Target cost is not present in Item Attributes in Content Update pop 
up. To update Target Cost, the user must opt for updating all objects. This is 
the only item attribute that you cannot update selectively. You can also 
choose to synchronize the AML with the Item Master.

Note: You cannot change the set price scenario for a project. To change 
from a price period-based to a quantity-based scenario, you need to create a 
project.



Modifying Price Scenarios

2-20 Agile Product Lifecycle Management Product Cost Management User Guide

Figure 2–5 Modify Price Periods Dialog

1. To delete a price period, click the Delete Row button to the right of a period's end date.

2. To insert a new price period, click the Insert Row button to the right of the last period's 
end date. Although the period is added after the last period in the project, you can specify 
any start date or end date.

3. To make a price scenario required for supplier response check the Response Required box. 
By leaving the Response Required check box blank, users are providing the supplier the 
freedom to respond or not respond to the specified price scenario(s).

4. Click OK to confirm the changes.

Note: The Modify Price Scenario command does not appear on the 
Actions menu if there are no price periods in the project.

Note:  If you delete a price period, it is automatically deleted from the 
corresponding RFQ, as well. If you add a price period, you must manually 
add it to the RFQ, if needed.

Note: If you are modifying the current price period for analysis purposes 
only, be sure to change it back before creating any new RFQs for the project.
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Quickstep to Costed BOM
Non PCM users, such as Engineering, Marketing, Finance, NPI Teams, and so on. require an 
intuitive mechanism to cost a BOM without going through PCM steps. This can be done using 
the Actions > Rollup Cost function.

Rollup cost generates an Assembly Cost Report (ACR) based on available prices using 
automated background processes. It picks up lowest costs from filtered data, performs Set as 
Best (on user defined or default parameters), and performs costed BOM rollup (aggregation) to 
generate an ACR.

Figure 2–6 Cost Rollup Process

To Rollup Cost:

1. Open the sourcing project.

2. Click Actions > Rollup Cost. You can opt for either:

? the existing prices available in a sourcing project (Actions > Rollup Cost > Using 
Project Prices) or

? the latest prices that have been published in Item Master (Actions > Rollup Cost > 
Using Price Repository).

If you opt to use previously published prices (Using Price Repository):

3. Click the list icon next to the Price Types field to select one or more available values.

This feature helps you base your BOM costing for varying sourcing situations, such as 
temporary requirements.

4. You may specify the remaining parameters or use default settings.

Note: Any manually set best responses are over written when the Rollup 
Cost Report is run, since auto-set as best is executed as part of the report 
process. To keep your manually set best responses, run the Assembly Cost 
Report instead.
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5. If desired, click Optional Criteria to specify the Ship To location, Suppliers, Customers, 
or Programs.

6. Click Look-up to generate the report.

Other Project Actions
This chapter already described how to use the Sharing and Save As actions, which appear on 
the Actions menu. The Actions menu for projects also includes the following commands:

? Bookmark - Save a bookmark so that you can return to the project quickly. To see 
bookmarks you have saved in an Agile client, open the My Bookmarks folder.

? Subscribe - Subscribe to the project and consequently receive notification of events that 
happen to that object.

? Delete - Delete a project. You can delete a project at any lifecycle phase (Draft, Open, or 
Closed). Deleting a project does not in any way affect the product record. Deleting a 
project only soft-deletes the project.

? Send - Send an email message containing a link to the project. You can send a project to 
any user listed in the Agile PLM address book.

For more information on how to perform these actions, see Getting Started with Agile PLM.

Note: Time taken for report generation depends upon the size of the 
project. It is advisable to run it as a background process by clicking on 
Generate this report as a background process check box.

Note: The subscription functionality is only for changes that happen to 
certain fields on the cover page of the sourcing project. It is not applicable to 
any changes on the other project tabs.

Note: PCM does not support hard-deleting a project.
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3Managing Project Items

This chapter provides information about managing items in a sourcing project.

About Project Items
You add items to a project so you can get information about terms and prices from your 
suppliers based on the quantities required. You can add items that exist in the Item Master, and 
you can create items within the project. The items created in the project are not updated to the 
Item Master automatically. You must manually publish the item information to the Item Master.

When you add an item to a project, all the sub-components and manufacturer parts are added to 
the project by default. An assembly item is any item that has a BOM.

Unlike the Item Master, sourcing projects hold only one revision of an item. When you import 
items into a project, any existing items are replaced with the source data even if it is for a 
previous revision.

The information you require about an item can be sent as a request for quotes (RFQ) to 
suppliers. Updated prices that you receive from suppliers can be published to the Item Master.

Managing Project Items
You can add, create, import, view, and delete items in a project. You can also set the critical 
quote and cost attributes of items for a response.

This section contains the following topics:

? Adding Existing Items to a Project

? Creating New Items in a Project

? Importing Items into a Project

? Editing Item Information

? Exporting Items from a Project

? Modifying Item Quantities

? Updating Project Item Information

? Calculating Item Quantities

? Viewing Item Information

? Deleting Items from a Project
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Adding Existing Items to a Project
You can add items to a project when you create the project, or you can add them later. See 
"Adding Items to a Project" on page 2-15 for more details.

Creating New Items in a Project
You can create items to add to a project either during or after project creation. When you create 
an item, it is not automatically added to the Item Master. However, you can publish the item to 
the Item Master. For more information, see "Creating New Items in a Project" on page 3-2.

To create new items to add to a project:

1. Open a sourcing project and click the Items tab.

2. Click Add > Create Items.

3. Select the Subclass of the item you want to create from the drop-down list.

4. If needed, change or enter the Number for the item. The system may automatically fill in 
this field.

5. Enter relevant text for the Description field.

6. Click the Search button to search for the Commodity lines, if any, that pertain to the item.

7. Click the list icon to select the related Product Lines.

8. Enter a value for the Standard Cost and select the currency from the drop-down list.

9. Click the Add AML button.

10. Click the Search button to search for and select the Manufacturer Name, if needed, or 
begin to type in the name of the manufacturer and the system attempts to auto-complete 
your entry.

11. Enter the Manufacturer Part Number.

12. Enter details in the Manufacturer Part Description field.

13. Select the status of the manufacturer item from the drop-down list.

14. Click the Add to Table button.

15. Click Finish when you are done.

Importing Items into a Project
You can import items into a project either during project creation or afterward. Items imported 
into a project are not automatically added to the Item Master. However, you can publish items 
to the Item Master. For more information, see "Publishing Items and Manufacturer Parts" on 
page 4-9.

Note: At this point, you can click Finish to create the item. To add AML 
information for the item, continue with this procedure.

Note: You can add more parts to the AML by repeating steps 10-14 or you 
can add another item by clicking the Add Another Item button.
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You cannot add duplicate top-level assembly items to a project. An assembly is any item that 
has a BOM. Each project can have multiple top-level assemblies, assuming each one is unique. 
The item number alone determines an item's uniqueness.

For complete information about how to import items into a project, see Agile Import/Export 
Guide.

Exporting Items from a Project
After you add items to a project, you may want to edit the item fields. Rather than editing each 
item individually, you may find it easier and more efficient to export project items and edit the 
exported document. BOM and AML data are not included in the export.

After you edit the file, you can import the revised items back into the project. See "Importing 
Items into a Project" on page 3-2.

To export project items:

1. Open a project and select the Items tab.

2. Choose More > Export(csv) orExport(xls).

3. Save the file to your computer.

4. Click Close in the download dialog to return to project.

Editing Item Information
You can edit item information, such as the commodity, description, unit of measure, buyer, and 
planner, at any time.

To edit item information:

1. Open a project and select the Items tab.

2. Click the Number of the item you want to edit. The Project Item Information page 
appears.

3. Click Edit.

4. Edit the information in the fields as necessary.

5. Click Save.

Note: You must have the appropriate privileges to import objects.

Note: Some exported item fields, such as State and Is Validated, are not 
useful. Do not map such fields when you import the data into a project.

Note: CSV is Comma Separated Values format, where a comma is used as 
an identifier of table columns. This ensures that when you export a CSV file, 
Agile PLM will place the data into its appropriate columns.

Note: The item information edited on the Project Item Information page 
does not affect the Item Master. You can view the Item Master details by 
clicking View in Item Master.
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Modifying Item Quantities
You can edit item quantities, or quantity breaks, on the Items tab or Analysis tab. Only 
root-level items can be modified.

To modify quantity breaks:

1. Open a project and select the Items or Analysis tab.

2. Select the row(s) of item(s) or click the All Rows Selection cell to select all the rows.

3. Choose Edit > Quantities. The Edit Item Quantities dialog appears.

4. Double-click in the field for each Quantity Break in each Effectivity Period that you want 
to modify and enter the new quantity.

5. Click Save to update the quantities in the project.

Editing Quantity Per Assembly (QPA)
You can edit an item's Quantity Per Assembly (QPA) on the Item tab of a sourcing project. 
Only child level QPA's can be edited. A top level, parent item's QPA cannot be edited. QPA is 
only editable when the sourcing project is in Draft or Open status.

To edit an item's QPA:

1. Open a project and select the Items tab.

2. Double-click the QPA field to make it editable.

3. Enter in the new value.

4. Click Save.

To avoid overwriting the updated QPA, when updating the sourcing project's content from the 
Item Master, you can choose to not have QPAs updated by un-selecting the QPA check box. By 
default, the QPA check box is selected, when either the All Content or BOM and AML options 
are selected. For more information, see "Updating Project Content from the Item Master" on 
page 2-18.

Additionally, you can publish the items in a sourcing project, including the QPA, to the Item 
Master. To publish the QPA, you must select the Bill of Materials option when selecting content 
to publish. For more information, see "Publishing Items and Manufacturer Parts" on page 4-9.

Updating Project Item Information
Sometimes item information changes due to an Engineering Change Order (ECO). You can 
update the items in a project with the information available in the Item Master.

Note: The Top Level Parts view on the Analysis tab displays only 
root-level items, which enables you to easily see which items you can edit.

Note: You can click the Fill Up or Fill Down buttons to copy the value of a 
Quantity Break to several selected cells in the column.

Note: Once your changes are saved, the quantities are automatically 
updated through sub-assemblies and components in the project.
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To update project item information:

1. Open a project and select the Items tab.

2. Choose Edit > Update From Item Master. For more information, see "Updating Project 
Content from the Item Master" on page 2-18.

Calculating Item Quantities
When an item is added to a project, regardless of whether it is entered manually or imported, its 
BOM and the associated manufacturer parts are also added. An item may contain many 
sub-components. Any item that has a BOM is called an assembly. Each assembly has a 
specified quantity. When an assembly is quoted for a specific quantity, the quote includes 
quantities for all its sub-components.

Within a sourcing project, you specify quantities only for top-level assemblies, not for BOM 
components. However, you can calculate component level quantities based on the assembly 
quantities and the Quantity Per Assembly (QPA) specified for each component. The project 
aggregates the quantities across assemblies for common items.

At the top of the Items tab, the date and time when quantities were last calculated is displayed. 
When the calculated date and time is red, you need to click the Recalculate button to recalculate 
quantities.

The following table shows a portion of a BOM. Assembly A1 has a Quantity of 1000.

The calculation to determine the quantities for sub-components P2, P3, and P4 is simple. For 
example, the following formula is used to calculate the quantity of P4:

[Quantity of P4] = [QPA of P4] * [QPA of A1] * [Quantity of A1]

[Quantity of P4] = 3 * 1 * 1000 = 3000

To view sub-component quantities:

1. Open a project and select the Items tab.

2. Click the Recalculate button to calculate quantities for all BOM components.

Note: If partner splits have been specified, the project also applies the splits 
to the calculated quantities. See "Calculating Quantities for Partner Splits" on 
page 6-12 for more information.

Note: If you choose Edit > Quantities to change quantities, you can check 
the Calculate quantities through sub-assemblies and components box to 
calculate quantities. Calculated quantities affect items in the project, and not 
the items in other projects or in the Item Master.

Number QPA Quantity

A1 1 1000

    P2 1 NA

    P3 2 NA

    P4 3 NA
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Viewing Item Information
You can view item information from the Item Master or the project. Any change to an item at 
the project level will not be reflected in the Item Master, whereas changes in the Item Master 
affect the project items when you update the item content in the project.

For example, if you set a target price for an item by editing the item at the project level, it 
differs from the target price information stored in the Item Master.

To view item information from a project:

1. Open a project and select the Items tab. A list of items appears.

2. Click an item number to view the details of the item.

To view item information from an RFQ:

1. Open an RFQ and select the Responses tab. The RFQ's line items appear.

2. Click an item number to view the details of the item.

Deleting Items from a Project
You delete items from a project to eliminate items that were added or imported by mistake or 
are now obsolete. You can delete an item from a project at any time, if it is not a sub-item 
within a BOM structure. You cannot change the BOM structure within Agile PCM. When you 
delete an item from a project, it is removed from all RFQs in the project.

Deleting an item from a project does not affect the Item Master. Published items exist in the 
Item Master even after deletion.

To delete items from a project:

1. Open a project and select the Items tab.

2. Select the item you want to delete.

3. Click Remove. A message appears to confirm the removal.

Quote As and Cost Attributes
When you send RFQs, you can seek Quotes of an item as an assembly, component, or custom 
component. These are the Quote As options available in the sourcing project for items. The 
price information for the items depends on the Quote As and Cost attributes.

? Cost defines whether the specified item will have a price in the quote project.

Note: You can choose to execute the action as a background process.

Note: You can also view item information using the search function in the 
navigation pane or using an item bookmark. For details, see Getting Started 
with Agile PLM.

Note: You can view the item information in the Item Master by clicking 
View in Item Master. The View in Item Master link appears when you mouse 
over the item number.
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– Yes: If you select Yes, a response line will be created for the item.

– No: If you select No, no response line is created for the item or its associated 
manufacturer parts, and so the supplier cannot quote a price. If the Cost is No for an 
assembly, the response lines are not created for its children, as well.

? Quote As defines the response line in the RFQ. material price and non-material price of 
the items in the response lines.

– Assembly: If an item is quoted as an assembly, the supplier specifies only the 
non-material price for the item in the response line. The non-material price is the price 
that includes the labor rate, sales tax, and other overhead costs.

– Component: If an item is quoted as a component, the supplier specifies only the 
material prices in the response line.

– Custom Component: If an item is quoted as a custom component, the supplier 
specifies both the material and the non-material price in the response line.

The Quote As and Cost attributes are not site-specific within a sourcing project. In PC, if you 
have the Sites tab enabled for the Items object, you can use Quote As and Cost in that tab and 
map the attributes into the sourcing project. Alternatively, you can map the attributes from 
Item-P2 into the project.

To change the Quote As and Cost attribute information of an item in the project:

1. Open a project and select the AML tab.

2. Select the row(s) of the item(s) for which you want to change the Quote As and Cost 
attribute information.

3. Choose Edit > Bulk Edit Items. The Bulk Edit dialog appears.

4. Change the attributes as necessary.

5. Click OK.

Alternatively, you can change the Quote As and Cost attributes by clicking on the item number 
and changing them for that particular item.

Expanding an Assembly
Assemblies and parts comprise a bill of material (BOM). An assembly can contain items and 
subassemblies. 

To expand an assembly:

1. Open a project and select the Items or Analysis tab. The content of the project appears.

2. Note Select the row of the assembly and choose More > Expanded Display. A window 
pops up with the assembly and its subassemblies expanded.

Note: Once an RFQ is created for an item, the Quote As and Cost attributes 
cannot be edited or changed.

Note: You can change these attribute values from Items and Analysis tabs, 
as well.
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On the Items tab, you can also expand an assembly, one level at a time, by clicking arrow next 
to the assembly icon.

Manufacturer part information is not displayed when you expand a BOM.

Managing Partner Information for Items
You can assign partners to assemblies, which enables you to compare costs provided by 
multiple partners. Partners are really Supplier objects in PLM and there is no separate 
configuration that is required to make a Supplier as a Partner. Although a partner is 
fundamentally a supplier, if a partner is assigned to an assembly, the partner, unlike a supplier, 
can quote on all the parts in that assembly, assuming the parts are set to be costed.

If multiple partners are selected, you can split the quantity among the partners by specifying 
what percentage of the items you want to receive from each supplier. For example, if you 
require 100 ship anchors, and two partners supply ship anchors to you, you can add both 
partners to the list and assign 50% to each.

You can select the Content BOM View check box in the Data to Share With Suppliers dialog 
to make the project BOM visible to the partner (on the General Information tab of a project, 
click the button next to the Data to Share field). If you want the partner to have access to the 
costed BOM analysis before they submit responses, for example, you can select the Content 
BOM View check box.

Adding Partners to Project Items
You can add partners to items in the project. You can assign the partners to all the items in the 
RFQ, if desired.

To add partners to projects:

1. Open a project and go to the Items or Analysis tab.

2. Select the row(s) of the item(s) to which you want to add partners.

3. Choose Edit > Partners. The Assign Partners dialog appears.

4. Click Add.

5. Search for and select the suppliers that you want to add. You can drag and drop them into 
the Partners table on the Assign Partners dialog.

6. Enter the Quantity Split percentage for each partner by editing the Splits % field. For 
more information about partner splits, see "Calculating Quantities for Partner Splits" on 
page 6-12.

7.  Click Next Record to continue to edit partners for remaining items.

8.  Optional: Select the Apply to all Remaining Selected Items check box to assign the 
partner and split percentage information to all the selected items in the project.

9.  Click Finish. The partners appear in the Partner/Supplier list.

Note: If you select another assembly and then click More > Expanded 
Display, a separate pop-up window appears.

Note: If you have not added partners to your project, no partners appear on 
the Select Suppliers page of the RFQ creation wizard.
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Removing Partners from Project Items
You can remove partners from selected items in a project.

To remove partners:

1. Open a project and go to the Items or Analysis tab.

2. Select the row(s) of the item(s) to which you want to add partners.

3. Choose Edit > Partners. The Assign Partners dialog appears.

4. Select the row of the partner you want to remove.

5. Click Remove.

6. Modify the split percentage for the remaining suppliers (if applicable).

7. Optional: Select the Apply to remaining records check box to assign the partner and split 
percentage information to all the selected items in the project.

8. Click Finish.

Note: You can also add partners and specify their AML splits from a 
project's AML tab. However, to display the partner splits on the AML tab, 
you must configure the tab's display properly. For more information, see 
"Configuring Project Tabs" on page 2-12

Note: When you delete the partners for an open RFQ, all the partner names 
are listed on the RFQ's Responses tab because the RFQs were sent to the 
suppliers when the state of the RFQ was changed from Draft to Open.
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4Project AMLs

This chapter provides information about managing AML data in a sourcing project.

About Project AMLs
An AML is the Approved Manufacturer List for an item. It lists all of the preferred or alternate 
manufacturer parts that correspond to an internal part/item. When you source parts for a 
project, you can choose to source them by assembly, by AML, or both.

Figure 4–1 Sample AML

An AML can have manufacturer parts of status preferred, alternate, or any additional status that 
has been configured in the Java Client. For each internal item, there can be multiple 
manufacturer parts. In such cases, you can specify AML percentage splits. For example, you 
may want to use 70% of one manufacturer part and 30% of another, based on cost or 
availability. The sum of the AML percentage splits must equal 100.

Manufacturers listed in a project AML must already exist in the Item Master. You can validate 
both project manufacturers and manufacturer parts, correctly matching the information to 
objects in your system. After performing cleanup of project AMLs, you can publish them to the 
Item Master.
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Show or Hide AML
The AMLs of an item can be viewed, added, deleted, or modified in the AML tab. In the 
heading row, the Has AML icon marks the Has AML column. If a dot icon is present in the Has 
AML column, that item has AML.

You can view the AMLs by clicking on the right arrow icon next to the item number. To view 
AMLs of all the Items across the entire list simultaneously, click More > Display AML Rows. 
To hide all the AMLs across the entire list, click More > Hide AML Rows.

Editing Item Attributes
The approved manufacturers list shows all manufacturer parts at the lowest internal part 
number across all bills of material and assemblies in this project. You can edit the item 
attributes such as Quote As and Cost on the AML tab to get the responses you need from the 
supplier.

The Quote As and Cost of the item define the type of price required for that item - material, non 
material or both. For more information, see "Quote As and Cost Attributes" on page 3-6.

Bulk Editing
When you need to make a universal change in certain visible attributes, such as Cost, Make/buy 
or Quote As, across the entire list of items or a set of selected items, you may bulk edit them.

To bulk edit an attribute:

1. In a sourcing project, click the AML or Analysis tab.

2. Select the desired row(s) of Items or all the rows on displayed page or all the pages.

3. Click Edit > Bulk Edit Items (or Edit > Bulk Edit Mfr Parts). The Bulk Edit dialog 
appears.

4. Pick a field from the Attribute drop-down list and enter a corresponding Value.

5. To change more attributes, click the Add icon to open up more Attribute and Value rows.

6. Click OK to save the changes.

Filtering AML Data
In the AML tab, you can use filters to see only a subset of data, instead of seeing the whole set. 
You can filter on any number of fields or you can use one of the pre-defined filters.

The pre-defined filters available through the Views drop-down list are:

? Invalid Data - Displays items or manufacturer parts that do not exist in the product record. 
Click More > Validate Items to identify which are valid and which ones are not.

? Items not in RFQ - Displays items that are not part of any RFQ.

Note: You cannot use bulk edit to modify all attributes of an item or 
manufacturer part. You can only edit flex fields and a few cover page 
standard attributes, such as Make/Buy, UOM, and Description.

Note: On the Analysis tab, your only option is to click Edit > Bulk Edit.
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? Items with Splits - Displays items with AML

? Supplier proposed Alternates - Displays items that have alternate manufacturer parts that 
have been proposed by suppliers.

Alternatively, you can use filters by clicking on the Personalize button.

To filter AML Data in a project:

1. Open a project and click the AML tab.

2. Click Personalize.

3. Click the Field drop-down list to select a field by which to filter.

4. Click the Operator drop-down list to select a relational operator for the filter. The list of 
relational operators depends on the type of attribute selected.

5. Select a value for the filter criteria.

? For text attributes, type a value.

? For list attributes, click the list button to select a single or multiple values from 
available values list.

6. To add additional filters, click the Add button.

7. Click Apply.

Adding an AML to an Item
An AML represents a manufacturer part made by a particular manufacturer. Each project item 
can have multiple manufacturer parts, and you can specify percentage splits to use for those 
parts. You can add AMLs to an item by specifying a manufacturer part, manufacturer, and its 
AML status.

When you add an AML, the manufacturer you specify must exist in your system. Otherwise, 
the AML will be invalid and you will not be able to quote on it. Manufacturer parts, however, 
do not have to exist in your system; you can publish them to the Item Master later.

You can add an AML to items in three ways:

? Manually

? By importing

? By updating the project with data from the Item Master

To add an AML to a project item manually:

1. Open the sourcing project and click the AML tab.

Note: The Views drop-down is located next to the Personalize button.

Note: To save this filter for future use, click Save. You may have to click 
Save As to save the settings as a new filter. If you are unable to save, you 
may not have the proper privileges.

Note: For information about updating the project with data from the Item 
Master, see "Updating Project Content from the Item Master" on page 2-18.
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2. Click the number of the item to which you want to add an AML. The quick view window 
appears for the item.

3. Select the AML tab.

4. Click Add. The Add AML to Item dialog appears.

5. Click Search button next to the Manufacturer Name field. The search palette appears.

6. Enter the search criteria and click Search. The search results appear.

7. Add the manufacturers by double-clicking the row you want to add.

8. Enter the manufacturer part number and description in the corresponding fields.

9. Select the status of the AML, for example, Preferred or Alternate, from the Status 
drop-down list.

10. Click Finish.

11. Change the AML status and split percentage in the corresponding fields, as necessary.

12. Click Close.

Importing AML Data
Using Agile PCM, it is easy to import manufacturer information, manufacturer part numbers, 
and commodity codes to add an AML row for an item. The import wizard walks you through 
the steps to import AML data.

You can import AML data into the Item Master or directly into a project, depending on your 
specific business process. If you import AML data directly into a project, it is not automatically 
added to the Item Master.

For complete information about how to import AML data, see the Agile Import/Export Guide.

Retrieving AML Data from the Item Master
The AML data for a project item may have been updated in the Item Master. At any time, you 
can retrieve AML data from the Item Master into a project.

Note: If you know the Manufacturer Name, begin typing it in the 
Manufacturer Name field and the system will attempt to auto-complete the 
name.

Note: You can add an AML to other items from within this window, by 
clicking Next, finding the desired item, and then repeating steps 3-10 in this 
procedure.

Note: If the manufacturer part information is not available in the Item 
Master, an invalid symbol appears in the Number field on the project AML 
tab. Click the symbol to search for the existing manufacturer part 
information.

Note: AML data often needs validation after it is imported into projects. A 
question mark symbol indicates the data that must be validated.
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To retrieve an AML from the Item Master:

1. Open a project and go to the AML or Analysis tab.

2. Select one or more items.

3. Chose Edit > Update AML from Item Master.

The Update AML from Item Master dialog, which facilitates you to "Update the Approved 
Manufacturers List" and/or “Update the Approved Manufacturers List Attributes,” appears.

Figure 4–2 Update AML from Item Master Dialog

The check boxes enable you to select "Do not overwrite changes made in this Sourcing 
Project" or "Overwrite changes made in this Sourcing Project", thus bringing forth four 
possible scenarios:

? Update the Approved Manufacturers List + Do not overwrite changes made in 
this Sourcing Project

– AMLs added in the PC are brought into the Project.

– AMLs deleted in the PC are deleted from the Project also, even if any of these 
AMLs were updated by the buyer.

–

AMLs added only in the Project, and not in the PC, are retained.

–

AMLs deleted only from the Project, and not in the PC, will not be added again.

? Update the Approved Manufacturers List + Overwrite changes made in this 
Sourcing Project

– AMLs added in the PC are brought into the Project
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– AMLs deleted in the PC are deleted from the Project also, even if any of these 
AMLs were updated by the buyer.

– AMLs added only in the Project, and not in the PC, are removed.

– AMLs deleted only from the Project, and not in the PC, will remain deleted, 
'unless' they come again as part of PC.

?  Update the Approved Manufacturers List Attributes + Do not overwrite changes 
made in this Sourcing Project

The system updates only those AMLs and Manufacturer Parts that have not been 
modified by the buyer. If, however, buyer has modified the AML Split of a 
Manufacturer Part, then only Mfr Part attributes, such as Description, flex fields, and 
so on will be updated, not the AML Split & AML Status.

? Update the Approved Manufacturers List AttribNoteutes + Overwrite changes 
made in this Sourcing Project

The system updates existing AML attributes, including AML Splits & AML Status, 
besides updating Manufacturer Part attributes, such as, Manufacturer Part flex fields, 
and Description.

4. Click Update.

Deleting an AML Row
You can delete AML rows of the item in the project.

To delete AML rows:

1. Open the sourcing project and click the AML tab.

2. Click the number of the item from which you want to delete an AML. The quick view 
window appears for the item.

3. Select the AML tab.

4. Select the row(s) of the AMLs you want to delete.

5. Click Remove.

6. Adjust the AML split percentage, if necessary.

7. Click Close.

Validating Manufacturer Names
Validating is the process of checking the existence of the manufacturer in the Item Master. 
Validating can be useful when manufacturers are imported from an external source. For 
example, after importing data into a project, you need to validate it manually. A question mark 
icon appears next to the manufacturer names that you need to validate. First you attempt to 
validate all similar items in a batch. Manually entered manufacturers are validated 
automatically.

After you have validated a group of imported manufacturers against the Item Master, a question 
mark icon appears beside each item that you need to validate individually.

Note: You can also delete an AML by selecting the row(s) you want to 
delete in the AML table and then clicking the Remove button.
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To validate manufacturer names:

1. Open a project and go to the AML or Analysis tab.

2. Select the row(s) of the AML(s) you want to validate.

3. Click More > Validate Items. If the information is in the Item Master, the validation is 
successful.

4. If not successful, click the question mark icon next to the manufacturer name. The Search 
Manufacturers palette appears.

5. Enter in the search criteria and press Enter.

6. Select the correct manufacturer from the search results by double-clicking the row.

The AML table is updated with the manufacturer name.

Validating Manufacturer Part Numbers
At times, you may require a new manufacturer part number for an item in a specific project. 
You can enter the new manufacturer part number while adding the AML row to the item. You 
can validate the MPNs against the MPNs in the Item Master. The invalid MPNs (the MPNs not 
found in the Item Master) are identified and marked by a question mark icon in the Number 
column. You can click the icon to change the information. The new manufacturer part number 
is marked by a question mark icon, because it does not yet exist in the Item Master.

To validate MPNs:

1. Open a project and go to the AML or Analysis tab.

2. Select the row(s) of the AML(s) that you need to validate.

3. Click More > Validate Items. If the information is in the Item Master, the validation is 
successful.

4. If not successful, click the question mark icon next to the manufacturer part number. The 
Search Manufacturer Parts palette appears.

5. Enter the search criteria and press Enter.

6. Select the correct manufacturer part from the search results by double-clicking the row.

The AML table is updated with the manufacturer part information, including the name and 
number.

Setting the Target Price
Target price is the price you quote for an item with the standard cost in mind. Standard cost is 
the market cost per unit of the item or the manufacturer part. The target cost of an item or the 
manufacturer part can be a percentage of the standard cost. In general, the target cost will be 
less than the standard cost.

The target price is specified when items are ordered in large quantities. When items are sent to 
suppliers for quotes, the suppliers may quote the price a bit lower or higher for the item 
according to their pricing conditions.

Note: If a supplier-proposed manufacturer exists in the Item Master, and 
you validate the manufacturer and manufacturer part once, the manufacturer 
will be shown as valid. There will be no need to create a manufacturer.
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You can set a target price for an item and choose to share that price with the supplier. The target 
price can be different for each price scenario. For instance, if you have 2 quantity breaks, you 
can have different target prices for each quantity break.

You can enter the target price of items in two ways:

? Auto - set the target price for selected items as a percentage of standard cost or any other 
price/cost field. For example, if you have multiple types of standard cost, one from an ERP 
system and one from an external source (which is stored as a price/cost field in the Items 
tab), you can set the target price to be a percentage of the actual standard cost or as a 
percentage of the cost from the external source.

? Manual - set the target price for each selected item manually.

To auto-set the target price:

1. Open a project and go to the AML or Analysis tab.

2. Select the row(s) of the item(s) for which you want to set the target price.

3. Choose Edit > Auto set Targets. The Set Target Price dialog appears.

4. From the drop-down list located after the phrase "Set Target Price as a percentage of", 
select the base cost, such as Standard Cost, to establish targets.

5. In the Percentage of Base Cost field for each quantity break, enter the number that 
indicates the percentage of the standard cost you entered in the Item Master.

6. Click OK. The target price is updated on the tab of the project.

To manually set the target price:

1. Open a project and go to the AML or Analysis tab.

2. Select the row(s) of the item(s) for which you want to set the target price.

3. Choose Edit > Target Costs. The Set Target Price dialog appears.

4. Enter the target cost for each item (if multiple items were selected) in the corresponding 
Target Cost field. You can copy and paste values, as needed.

5. Click Apply. The target price is updated on the AML tab of the project.

Updating Target Prices in RFQs
You can update the target price of items that you have set in the project in RFQs. When you set 
the target price for an item at the project level, the change is not applied to any associated RFQs 
until you update the target price in the RFQs. You can update target prices in RFQs from the 
project.

Note: All money fields are listed as options in this drop-down list.

Note: This overwrites the existing target price displayed in the project.

Note: These target prices will be reflected in new RFQs. To apply these 
target prices to existing RFQs, choose More > Update RFQ Targets.
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To update target prices in RFQs from a project:

1. Open a sourcing project and go to the AML or Analysis tab.

2. Select the row(s) of the items that you want to update in all RFQs in the project.

3. Choose More > Update RFQ Targets. The target price of the selected items is updated in 
all the RFQs in the project.

Publishing Items and Manufacturer Parts
If you make changes to items or manufacturer parts, you can publish those changes to the Item 
Master. You can publish objects that already exist in the Item Master or that only exist in a 
project.

When you publish data, you can use Redlining or Authoring mode. You can add redlines to a 
change order, such as an ECO, MCO, or SCO. In PCM, you most often will use Price Change 
Orders (PCOs).

To publish items and manufacturer parts:

1. Open a project and go to the AML or Analysis tab.

2. Select the row(s) of the item(s) you want to publish.

3. Click More > Publish Items to Item Master. The Publish to Item Master dialog appears.

4. Set the following options:

? Specify Contents to Publish - Check the box for each content type to publish. 
Depending on the project data you have selected, you can select Item, Bill of Material, 
Approved Manufacturer List, and Manufacturer Part.

? Specify Default Types - Select the default type for items, manufacturers, and 
manufacturer parts. The items and manufacturer parts get published only to the types 
selected in this section. If the default type is different than the type that the item 
belongs to in the Sourcing Project, the item gets published based on the default type. 
For example, if the part is defined as a "Capacitor" in the Project-Items tab and during 
publish, if you choose "Resistor" as the default, the part is going to be published as a 
resistor and not as a capacitor.

? Publish Mode - Select either Redlining or Authoring mode.

If you select Redlining mode, you must specify a change order. Redlining mode, as its 
name implies, highlights in red any existing BOMs or AMLs that have changed. All 
items published in Redlining mode are placed on the Affected Items tab of the 
specified change order.

If you select Authoring mode, you can update unreleased items and create new 
preliminary items. Once an item has a pending change, you can no longer use 
Authoring mode to update it.

Note: The target price stored in the Item Master may be different from the 
target price set in the project for items.

Note: The target price is only updated for response lines that are locked and 
in draft mode.
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? Update Mode - Select "Only Add and modify data (do not delete it)" or "Add, modify, 
and delete data."

If you choose "Only Add or modify data (do not delete)," BOMs and AMLs are 
updated but no information is deleted. This is the default selection. If you choose 
"Add, modify, and delete data," new data will be added and existing BOMs and AMLs 
will be completely replaced with the published data.

5. If you selected Redlining mode, set the following option:

? Change Order - You can select an existing change order or create a new one. Click to 
select an existing change order. Click to create a change order.

6. Click Publish Items to Item Master. After the BOM and AML changes are published to 
the Item Master, the tab from which you launched the publish action appears.

Note: If you published from the AML tab, the published date and time 
appear in the Publish Date field on the AML tab. If you published from the 
Analysis tab, the published date and time appear in the Publish Item Date 
field on the Analysis field. If the appropriate field is not visible, click 
Personalize to change the selected attributes.
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5Analyzing Project Data

This chapter provides information about analyzing sourcing project data.

Analyzing Project Data
In Agile PCM, you can review and analyze a project's item content, including price information 
and RFQ response information. On the Analysis tab of a project, you can view the item 
information across all RFQs in the project along with response lines. You can create RFQs and 
send them to suppliers. You can publish the price information in the response line as well. 
Costed BOM analysis and other analysis can be performed on product cost information and 
RFQ response lines.

The table on the Analysis tab displays information such as the supplier name, the item or the 
manufacturer part number, the revision (if any), the manufacturer, the manufacturer status, and 
the response line information.

You can select which fields to view on the Analysis tab. You can also filter the data. For more 
information, see "Filtering Project Data" on page 2-14.

The Analysis tab provides support for several analysis features including:

? Best Response selection

? Costed BOM analysis

? Sourcing exceptions

? Other cost analysis views and reports

Completing Non-Analysis Tasks on the Analysis Tab
During the sourcing process, you may have to move from tab to tab within the sourcing project 
to accomplish specific tasks that are necessary to completing the sourcing process.

To improve the efficiency of the sourcing process, however, several key tasks that you could 
previously only complete on the Items or AML tabs are now available on the Analysis tab. This 
enables you to remain on the Analysis tab and use the same filters and views that you need to 
manage project items, AML, and project data analysis. Tasks that have been replicated on the 
Analysis tab from the AML or Items tabs are still also available on the original tabs.

The following table describes the tasks that have been replicated from the AML or Items tab to 
the Analysis tab.
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Task Description Relevant sections

Add Items Items can be added using the 
following methods:

Create New

Search & Add

Import

Copy/Paste

Drag/Drop

See "Adding Items to a Project" 
on page 2-15 for more 
information.

Remove Items Remove items at the root level. See "Removing Items" on 
page 5-18 for more information.

Edit Quantities Edit item quantities for all root 
items.

See "Modifying Item 
Quantities" on page 3-4 for 
more information.

Expanded Display Select a root item and click 
More > Expanded Display to 
display the expanded BOM in a 
separate pop-up window.

See "Expanding an Assembly" 
on page 3-7 for more 
information.

Edit Partners Edit partners. Previously this 
was only available on the Items 
and AML tabs.

See "Adding Partners to Project 
Items" on page 3-8 and 
"Removing Partners from 
Project Items" on page 3-9for 
more information.

Bulk Edit Items & Bulk Edit 
Mfr. Parts

Bulk edit items or manufacturer 
items by clicking Edit > Bulk 
Edit.

See "Bulk Editing" on page 4-2 
for more information.

Content Update Update sourcing project content 
with the latest information from 
Item Master. Previously, this 
feature was only available on 
the Items tab.

See "Updating Project Content 
from the Item Master" on 
page 2-18for more information.

Update AML from Item Master Get the latest information for 
the AML from the Item Master.

See "Retrieving AML Data 
from the Item Master" on 
page 4-4 for more information.

Set Target Costs Set target costs manually or 
automatically. Previously, this 
feature was only available on 
the AML tab.

See "Setting the Target Price" 
on page 4-7 for more 
information.

Update RFQ Targets Previously, this feature was only 
available on the AML tab.

See "Updating Target Prices in 
RFQs" on page 4-8 for more 
information.

Validate Items Validate items. Previously, this 
feature was only available on 
the AML tab.

See "Validating Manufacturer 
Names" on page 4-6 and 
"Validating Manufacturer Part 
Numbers" on page 4-7 for more 
information.

Publish Content Publish content by clicking 
Publish > Prices.

See "Publishing Items and 
Manufacturer Parts" on 
page 4-9 for more information.
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Filtering Project Data
In the Analysis tab, you can use filters to see only a subset of data, instead of seeing the whole 
set. You can use one of the pre-defined filters that are available through the Views drop-down.

The pre-defined filters available through the Views drop-down list are:

? Items not in RFQ - Displays those items that are not in an RFQ. If an item has multiple 
manufacturer parts and one of the parts is not in an RFQ, then the item and that particular 
part gets displayed.

? Items with Sourcing Exceptions - Displays those items that have supplier responses that 
have exceptions.

? Items with Split - Displays those items that have AML with splits among them.

? Parts with Best Price - Displays those items or manufacturer parts that have been flagged 
as "best". A part's price gets flagged as best when you use the Analyze > Set As Best 
option.

? Parts with Price - Displays those items or manufacturer parts that have prices.

? Parts without Best Price - Displays those items or manufacturer parts that have not been 
flagged as “best.”

? Parts without Supplier - Displays those items that do not have prices from suppliers or 
from the price lookup.

? Parts awaiting Response - Displays those items or manufacturer parts that have been sent 
to a supplier through an RFQ, but have not received a response from the supplier.

? Supplier Proposed Alternates - Displays manufacturer parts that have been proposed as 
alternates.

? Top Level Parts - Displays the root-level items.

Alternatively, to specify attributes by which the data should be filtered, you can use the filter 
functionality that is available through the Personalize button. Multi-column filtering is 
available on the Analysis tab.

To filter data in a project:

1. Open a project and click the Analysis tab.

2. Click Personalize.

3. Click the Field drop-down list to select a field by which to filter.

4. Click the Operator drop-down list to select a relational operator for the filter. The list of 
relational operators depends on the type of attribute selected.

5. Select a value for the filter criteria.

? For text attributes, type a value.

? For list attributes, click the list icon to select a single or multiple values from available 
values list.

6. To add additional filters, click the Add button.

7. Click Apply.

Note: A few of the tasks mentioned in this table are only applicable to 
root-level items. You can use the Top Level Parts option in the Views 
drop-down to filter out non-root items.
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To save this filter for future use, click Save. You must then click Save As to save the 
settings as a new filter.

Filtering Published Prices
When the prices are published from the Analysis tab in a sourcing project, the system stamps its 
publishing date. If, and when, a publish operation fails, the Publish Date field remains empty, 
however, the Publish Status field will contain a dot icon. The reason for failure is displayed 
when you mouse over the dot icon in that column.

To be able to identify the failed, or successful, instances, you can filter the Published Prices 
across their Date and Status using the attributes Publish Price Date and Published Price 
Status, respectively.

? Publish Price Date - You can filter the prices published before, on or after a particular 
date.

For example, if a few users in your organization published a certain number of responses 
today, and you want to know how many they were, this attribute lets you do so.

You could also, for example, filter for "Publish Price Date Is Null" to display all the prices 
that have not been published or that failed to publish.

? Published Price Status - You can filter the prices that got published or did not.

To see the list of all unpublished responses, select this filter attribute and "Is not Null" 
parameter. To see all the responses (published and never published), select "Is Null" 
parameter.

Understanding Costed BOM Comparisons
A costed BOM comparison view enables you to compare prices across multiple partners and 
the best of component suppliers. Duplicate item rows show the various responses. When you 
run the Costed BOM Comparison analysis, the system calculates material and non-material 
costs for each Cost Roll Up.

? For material costs, the system takes the material price and applies any price adders 
specified in the response line. Price adders can be fixed costs or percentages. If the item 
has AML splits, the system calculates an average for the material costs.

? For non-material costs, the system sums all non-material flex fields.

If there are multiple BOM levels, the system rolls up material costs for each level of the BOM 
hierarchy to calculate the Total Materials Price for each subassembly and assembly. If you do 
not see any costs while in the Costed BOM view, it is most probably because a cost rollup has 
not been run yet for the project using the Calculator button.

The following table shows an example of a costed BOM with a subassembly.

Note: If you modify the current price period for analysis purposes only, be 
sure to change it back before creating any new RFQs for the project.

Table 5–1 Example of Costed BOM with a Subassembly

Number Cost Quote As QPA

Total 
Unit 
Cost

Total 
Materials 
Price

Total 
Non-Materials 
Prics

A1 Yes Assembly 1 20.50 18.00 2.50
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The Cost and Quote As fields determine how prices are rolled up for the Costed BOM. If the 
Cost field is set to No, pricing information cannot be entered for that item and it appears gray. 
The Quote As field sets whether the item is quoted as an assembly, component, or custom 
component.

? If Quote As is set to Assembly, the Total Materials Price field will be the sum of the Total 
Materials Price fields from all its sub-components.

? If Quote As is set to Component, the Total Materials Price field is entered on the response 
line and is not calculated. Total Non-Materials Price is not entered for components.

? If Quote As is set to Custom Component, the Total Materials Price field is entered on the 
response line and is not calculated. The Total Non-Materials Price field also becomes 
enabled. The Total Unit Cost field equals the sum of the Total Materials Price and the Total 
Non-Materials Price fields.

The total cost is only rolled up for partners, not best of suppliers. A partner is an Original 
Equipment Manufacturer (OEM). OEMs deal with the complete assembly rather than 
individual parts. For example, let us assume that Company A is an OEM for Company B. If 
Company B needs a quote for B1234 laptop, Company A gives the costs for the complete 
assembly and its parts. Non-material costs are incurred to assemble the parts at different 
sub-assemblies and assemblies. Agile PLM rolls up the costs to the top-level assembly by 
multiplying the costs by the QPA.

A supplier, however. is an Equipment Manufacturer (EMS). An EMS deals with individual 
parts. For example, Company C is an EMS of Company B, which needs a quote for different 
parts for the B1234 laptop, like CPU and memory. Company C only gives costs for the parts. 
Even if Company C does deal with assemblies, Company A treats it as an EMS, which means 
that the application assumes that the EMS/supplier will not give costs for a complete assembly. 
Therefore, total costs are not rolled up at the top-level assembly for supplier-provided 
responses.

Viewing Costed BOM Comparisons
To view the costed BOM comparison:

1. Open a project and go to Analysis tab.

2. Choose Analyze > Costed BOM Comparison. The Costed BOM table appears showing 
duplicate item rows, one for each partner or the best supplier. All Partners and only the 
Best Supplier are displayed in the Costed BOM View.

? For items with a split percentage, an average is calculated.

? For items with no split percentage, the lowest price response is provided across all 
partners or suppliers.

   P2 Yes Component 1 2.00 2.00 0.00

   P3 Yes Component 2 3.00 3.00 0.00

   P4 Yes Component 3 1.00 1.00 0.00

   A2 Yes Assembly 2 3.50 2.50 1.00

     P5 Yes Component 1 1.50 1.50 0.00

     P6 Yes Component 1 1.00 1.00 0.00

Table 5–1 (Cont.) Example of Costed BOM with a Subassembly

Number Cost Quote As QPA

Total 
Unit 
Cost

Total 
Materials 
Price

Total 
Non-Materials 
Prics
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3. To view information for a selected price scenario, click the Price Scenarios drop-down list 
and select either Default Price Scenario, All Price Scenarios, or Selected Price Scenarios.

If you chose Selected Price Scenarios, select price scenarios in the Hidden Fields list, and 
then click the right arrow to add them to the Displayed Fields list. Click OK.

4. Click OK to return to the Analysis tab.

Exporting a Costed BOM
After you have created a costed BOM comparison, you can quickly export the results to a text 
file.

To export a costed BOM comparison:

1. Open a project and go to the Analysis tab.

2. Choose Analyze > Costed BOM Comparison. The Costed BOM table appears showing 
duplicate item rows, one for each partner or supplier.

3. Click the Export button. The Export Assembly Cost (Sourcing Project) dialog appears.

To recalculate costs, make sure the Recalculate Costs Upon Report Execution box is 
checked.

4. Select the Assembly Lines, Suppliers, and Price Scenarios to export.

5. Click Finish to generate the report.

6. The File Download dialog box appears.

7. Click Save to save the costed BOM comparison information as an Excel Comma Separated 
Value (CSV) or Worksheet (XLS) format file to your computer.

8. Click Close.

9. Click Return to return to the Analysis tab.

Viewing Non-Material Cost Comparisons
The non-material cost comparison displays the non-material total cost and the non-material cost 
breakdown. Prices could be taken from associated RFQs or from price lookups. This view lets 
you compare the non-material costs provided by various suppliers.

The following table shows an example of a Non-Material Comparison.

Note:  If your project includes price periods, the lowest cost is based on the 
current price period. Best Response is selected based on the criteria 
mentioned while performing Set As Best. But Lowest Price Response will 
not be provided across all the Partners & Suppliers, each Partner/Supplier 
will have their own Response Line. If there are multiple quantity breaks per 
price period, the first quantity break is used. For information about how to 
calculate costs for a different price period, see "Modifying Price Scenarios" 
on page 2-19.

Note: When you perform Cost Roll Up, Costs will be calculated for all the 
Price periods present in the Project. For selecting the Best supplier for a 
specific Price period, you need to mention Price Period in "Select the Price 
Scenario To Analyze".
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When you run a non-material comparison, you can display AML-related columns like MPN 
number, manufacturer, AML status, and so on for those items that have AML and are set to 
custom component. Each manufacturer part is displayed in its own row in context with its 
parent item. If an item does not have any AMLs, but was quoted as custom component, it still 
appears in this view.

To view a non-material cost comparison:

1. Open a project and select the Analysis tab.

2. Choose Analyze > Non-Material Comparison. The non-material costs appear.

3. To view information for a selected price scenario, click the Price Scenarios drop-down list 
and select either Default Price Scenario, All Price Scenarios, or Selected Price Scenarios.

If you chose Selected Price Scenarios, select price scenarios in the Hidden Fields list, and 
then Click the right arrow to add them to the Displayed Fields list. Click OK.

4. Click Return to return to the Analysis tab.

Understanding PCM Analysis Reports
Agile PCM offers a selection of analysis reports, which provide information directly from a 
project. You generate analysis reports from the project Analysis tab. These analysis reports 
include flex fields from Items, Manufacturer Parts, and RFQ Response lines.

The following table describes the analysis reports:

Number Rev Commodity Supplier

Quantity 
Break 1 -  
Quantity

Total 
Non-
Materials

Quantity 
Break 2- 
Quantity

Total 
Non-
Materials

A1 A ASSY EMS1 100 2.50 USD 200 5.0 USD

A1 A ASSY EMS2 100 2.25 USD 200 4.0 USD

A1 A ASSY EMS3 100 2.00 USD 200 4.0 USD

A2 B ASSY EMS1 500 8.00 USD 1000 16.00 USD

A2 B ASSY EMS2 500 6.00 USD 1000 12.00 USD

A2 B ASSY EMS3 500 5.00 USD 1000 10.00 USD

A3 C ASSY EMS1 200 20.00 USD 400 40.00 USD

A3 C ASSY EMS2 200 15.00 USD 400 30.00 USD

A3 C ASSY EMS3 200 12.00 USD 400 24.00 USD

Note: To see a breakdown of any non-material fields (apart from totals), 
those fields need to be enabled in the Java Client in the Sourcing Projects 
Class > Analysis Tab > Attributes:Non Material Price Entry. Only the 
attributes that are enabled in this tab in the Java Client are visible in the 
Non-Material Comparison view.

Report Description

AML Differences Displays changes made to the AML through validation or from supplier 
responses.
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Use Case Scenarios
There are a few business use cases that may require you to run specific analysis reports. The 
following table provides a breakdown of which reports to run according to the use case 
scenario.

Assembly Cost Establishes a total costed BOM, including material and non-material costs, 
and displays assembly-level and component-level breakdowns. The Supplier 
Assembly Cost Report also has the QPA and Total Extended Cost 
(UnitCost*QPA) fields.

Cost Pareto Identifies the items or commodities in a project that have the greatest impact 
on total cost; also known as the 80/20 analysis.

Effective Cost 
Comparison

Compares the effective extended cost accounting for minimum order and 
package quantity requirements.

Supply Base Analysis Evaluates the price differences between multiple suppliers and applies 
discounts to strategic suppliers for further analysis.

Sourcing Exceptions Establishes potential sourcing issues by letting you quickly view sourcing 
exceptions for project items. The exceptions are based on supplier 
responses, displaying obsolete and long lead-time items, EOL dates, or 
unknown part numbers.

Unit Cost Comparison Compares the material and non-material unit costs between multiple 
suppliers and internal reference cost sources, highlighting the lowest price 
across all price sources.

Response Comparison Compares the costs and terms between two different sourcing projects.

Note: The Unit Cost Comparison, Effective Cost Comparison, and 
Response Comparison reports enable comparison of response lines against 
selected target cost(s). You have the option to select target cost(s).

Use Case Scenario Description of Scenario Time Frame of 
Analysis

Reports to Run

Commodity 
Management

This is a common 
business scenario in 
which you need to 
evaluate the aggregate 
volume costs and 
supplier/material risks 
of items and AMLs.

Quarterly or forward 
pricing (4 qtrs)

To analyze costs:

Unit Cost Comparison

Cost Pareto

(Optional) Response 
Comparison

To analyze risk:

Sourcing Exceptions

(optional) AML 
Differences

Report Description
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Generating Analysis Reports
You can run reports directly from within an open sourcing project.

To generate an analysis report from within a sourcing project:

1. Open a project and select the Analysis tab.

Co-Sourcing In this scenario, you are 
faced with the need to 
evaluate product cost 
leverage and risk across 
suppliers and 
manufacturing partners.

Single period (1 qtr) or 
sometimes multiple 
periods, for example, 
current + 2-3 quarters 
forward cost

To analyze material 
costs:

Assembly Cost Report

Unit Cost Comparison

Cost Pareto

(optional) Response 
Comparison

To analyze risk:

Sourcing Exceptions

(optional) Effective 
Cost Comparison

(optional) AML 
Differences

Design for Cost & 
Supply

In this scenario, you are 
faced with the need to 
evaluate product cost 
and risk across product 
lifecycle.

1-3 years forward cost 
(proto period, pilot, 
early product or full 
production ramp)

To analyze costs:

Assembly Cost Report

Unit Cost Comparison

Cost Pareto

(optional) Response 
Comparison

(optional) Effective 
Cost Comparison

(optional) Supply Base 
Analysis

To analyze risk:

Sourcing Exceptions

(optional) AML 
Differences

External 
Manufacturing: New 
Business Acquisition

In this scenario, you 
must analyze pricing to 
win new business.

If trying to win new 
business: 
Quantity-based.

If re-pricing: 
Time-based, 1 quarter.

To analyze costs:

Assembly Cost Report

Unit Cost Comparison

Cost Pareto

Effective Cost 
Comparison

(optional) Response 
Comparison

To analyze risk:

Sourcing Exceptions

(optional) AML 
Difference

(optional) Supply Base 
Analysis
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2. Select the item(s) you want to include in the report, and then choose Analysis > Reports 
& Analytics > (report name). The report wizard appears.

Alternatively, you can run sourcing reports without having to open a project. This is useful in 
situations where you need to run several reports, but do not need to interact with any particular 
sourcing projects. You can run reports without opening a sourcing project, by accessing the 
Reports drawer in the left pane.

To generate an analysis report from the Reports drawer:

1. Click the Reports drawer in the left pane.

2. Navigate to sourcing reports by clicking Reports and Analytics > Standard Reports > 
Sourcing Reports.

3. Click the name of the report that you want to run.

4. Click Execute. In some cases, as part of the report wizard, you will have to select the 
project that you want to run the report on.

For general instructions for generating a report, see Getting Started with Agile PLM.

The following four sections describe, in more detail, the procedures for generating the four 
most commonly used reports:

? Assembly Cost

? Cost Pareto

? Sourcing Exceptions

? Unit Cost Comparison

Running the Assembly Cost Report
You can use the Assembly Cost Report to understand the total cost of a BOM. You can also use 
the report to compare total costs between multiple manufacturers and determine the impact of 
non-material and material cost differences.

To run the Assembly Cost Report

1. Open a sourcing project and select the Analysis tab.

2. Select the item rows you want to include in the report, by clicking the corresponding row 
selection cells or the All Rows Selection cell.

3. Select Analyze > Reports and Analytics > Assembly Cost Report. The Assembly Cost 
Report wizard appears.

4. On the Select Layout and Configuration page, select the Layout you want to use.

5. Click Next.

6. Select the Assembly Lines you want to include in the report. Only top-level assemblies are 
available for selection.

7. Select the Suppliers you want to include in the report. Project partners and best of 
suppliers are available for selection.

8. Select the Price Scenarios. All available price scenarios from the project are available for 
selection.

Note:  If running this report for a supplier response, rather than a project, 
both top-level and subassemblies are available for selection.
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9. Optional: If desired, select the check box to "Recalculate costs upon execution."

10. Click Finish.

The following is an example of the report output.

Figure 5–1 Sample Assembly Cost Report Output

Running the Cost Pareto Report
You can use the Cost Pareto report to identify key items or commodities with the greatest 
impact on total cost. Based on report results, you can then focus your price negotiation efforts 
on those items and commodities that have the greatest impact on total cost.

To run the Cost Pareto report

1. Open a sourcing project and select the Analysis tab.

2. Select the item rows you want to include in the report, by clicking the corresponding row 
selection cells or the All Rows Selection cell.

3. Select Analyze > Reports and Analytics > Cost Pareto Report. The Run Cost Pareto 
Report wizard appears.

4. On the Select Layout and Configuration page, select the Layout that you want to use.

Note: If this option is selected, the report dynamically runs a new costed 
BOM roll-up.
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5. Click Next.

6. Select the Grouping Options that you want to include in the report. The grouping options 
that are available depends on the layout you chose in the previous step.

7. Optional: Enter a percentage value (0 to 100) to filter the results of the analysis based on 
the commodities' contribution to the total cost.

8. Select the Cost for Analysis options. You can select up to four different criteria, such as 
Standard Cost, by which the costs should be compared.

9. Select the Price Scenario that should be considered in the analysis.

10. Click Finish.

The following is an example of the report output.

Note: All leaf-level items from selected commodities or items are included 
in the analysis.

Note: If the system finds a price for an item based on the first option, it 
returns that price. If not, the system continues to try the other criteria. 
Items/commodities without a value for any of the four costs, are then 
displayed with empty cost fields in the report.

Note: Only price scenarios from the project are available for selection.
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Figure 5–2 Sample Cost Pareto Report Output

Running the Sourcing Exceptions Report
The Sourcing Exceptions report enables you to identify exceptions that are a signal of high risk, 
such as parts approaching end-of-life, parts with long lead times, or parts with no alternate 
sources. Once you have identified the high risk situations, you can take appropriate measures to 
eliminate the risks.

To run the Sourcing Exceptions report:

1. Open a sourcing project and select the Analysis tab.

2. Select the item rows you want to include in the report, by clicking the corresponding row 
selection cells or the All Rows Selection cell.

3. Select Analyze > Reports and Analytics > Sourcing Exceptions Report. The Run 
Sourcing Exceptions Report wizard appears.

4. On the Select Layout and Configuration page, select the Layout that you want to use.

5. Click Next.

6. Select the check box for the sourcing exceptions, such as Obsolete Parts, that you want to 
report.
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7. Optional: Select specific Price Scenario(s) to include in the report.

8. Click Finish.

The following is an example of the report output. Sample 

Figure 5–3 Sample Sourcing Exceptions Report Output

Running the Unit Cost Comparison Report
The Unit Cost Comparison report enables you to monitor costs to identify opportunities for 
proactive cost management with suppliers and partners. You can compare costs between 
suppliers, and compare costs to existing reference costs, such as standard costs, target costs, and 
contracts. Based on results from the analysis, you may want to renegotiate with suppliers to 
realign prices and set targets to match market prices.

To run the Unit Cost Comparison report

1. Open a sourcing project and select the Analysis tab.

Note: Some sourcing exception options also require that you enter a time 
period (in days). For example, to find parts that are near their end of life date, 
you must enter a number to indicate how close the parts are to that date.

Note: Only price scenarios from the project are available for selection.



Understanding PCM Analysis Reports

Analyzing Project Data 5-15

2. Select the item rows you want to include in the report, by clicking the corresponding row 
selection cells or the All Rows Selection cell.

3. Select Analyze > Reports and Analytics > Unit Cost Comparison Report. The Unit 
Cost Comparison Report wizard appears.

4. On the Select Layout and Configuration page, select the Layout that you want to use.

5. Click Next.

6. Select the Suppliers and Price Scenarios you want to include in the report. The project 
prices that will be included in the report are based on the suppliers and price scenarios 
chosen here.

7. Click Next. The Compare Against Reference Prices page appears.

8. Click Add. You must add reference prices from the Item Master to compare to the sourcing 
project prices that were provided by the suppliers you selected in the previous step.

9. On the Add Scenario page, complete the fields, as desired. Some fields, such as Price Type, 
are required for defining the price comparison scenario.

10. Click Finish. The reference prices from the added scenarios appear on the Compare 
Against Prices page.

11. Click Next.

12. Choose one base price to which all other prices listed should be compared. Select the row 
by clicking its row selection cell.

13. Click Finish.

The following is an example of the report output.

Note: In the Suppliers field, the Best of Suppliers/Partners option is 
available for selection.

Note: You can narrow down the comparison scenario by specifying the 
desired Program, Customer, Ship To location, and so on.

Note: All of the sourcing project prices, and the prices from the Item 
Master, that you selected in the previous steps are listed here.



Setting the Best Response for an Item

5-16 Agile Product Lifecycle Management Product Cost Management User Guide

Figure 5–4 Sample Unit Cost Comparison Report Output

Setting the Best Response for an Item
You can analyze the supplier responses to find out which supplier response is the best for a 
given item. By setting the best response, you flag it to track your selection and make that 
selection available for use in other analysis features and reports. You can set best responses 
either manually or by the auto-select process.

You can have only one response per item (and its AMLs) as 'best', with an exception for when 
AML splits are utilized. In such a case, each AML with nonzero splits can have a best response.

The best response is indicated by a dot icon in the Best Response field. If the Best Response 
field is not visible, click Personalize to add it to the list of selected attributes.

You can also apply constraint factors, for example, lead-time, so that only qualified responses 
can be set as best.

To set the best response manually:

1. Open a sourcing project and select the Analysis tab.

2. Select the row(s) of one or more response lines in the Analysis table.

3. Choose Analyze > Set As Best. The system automatically selects the lowest price among 
all the suppliers and flags it as best.

Note: Any manually set best responses are over written when the Rollup 
Cost Report is run, since auto-set as best is executed as part of the report 
process.
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To auto-select the best response:

1. Open a sourcing project and select the Analysis tab.

2. Select the row(s) of the response lines in the Analysis table from which you want to find 
the best response.

3. Choose Analyze > Auto-set as Best. The Auto-Select Responses dialog appears.

4. Select the Content Selection Criteria.

Choose the price scenario to which the rules should be applied. You can apply auto-select 
to all Items, or just selected Items. By default, the All Items option is selected.

Although only a single scenario can be selected, the Best Response flag is applied to the 
Response Line as a whole. Only one Response Line shall be set as the "best" per Item. 
Therefore only a single supplier / partner can be selected as having the "best" Response 
Line for that Item. If another Response Line had previously been set as the Best Response 
for an Item, the new selection shall override the previously selected Best Response.

5. Select the additional criteria for finding the best response:

? Alternate Parts - Select this check box to find the best response for the selected items 
and manufacturer parts among the preferred and alternate parts in the Analysis table.

? Historical Quote Responses - Select this check box to find the best response for the 
manufacturer part from the item's quote history (if any).

6. From the Best Response Selection Criteria drop-down, select up to three of the following 
criteria by which to auto-select best responses:

? Lowest Cost - Selects the best response based on which has the lowest cost.

? Lowest Cost Within Lead Time Constraint - Selects the best response based on the 
lowest cost within a specified lead time constraint (in days).

? Shortest Lead Time - Selects the best response based on which has the shortest lead 
time.

? Supplier Rating - Selects the best response based on supplier ratings. You can 
prioritize the list of ratings. Your Agile administrator can customize the supplier 
ratings as required. The default ratings are Approved, Offered Active, Offered 
Inactive, and Strategic.

? AML Preferred status - Select the best response based on AML status. You can 
prioritize the list of AML status types. The Agile administrator can customize the 
AML status types as required. The default AML status types are Preferred and 
Alternate.

7. Click Auto-Select.

Removing Responses
Before you send out an RFQ to suppliers, you may choose to do a price lookup on items in your 
sourcing project. The lookup process retrieves prices from the Item Master and creates 
responses on the Analysis tab. These prices can then be used as base prices for the suppliers.

Note: There is one exception to the rule of having one "best" per Item, and 
this is in the case where an Item has an AML split percentage. In this case, 
the system shall support multiple "best" response selections, one per AML 
entry with a nonzero split percentage.
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When you no longer need these responses, you can remove these responses or any other 
responses from a sourcing project if they are not already part of an active RFQ.

To remove responses from a project:

1. Open a project and select the Analysis tab.

2. Select the response line(s) you want to delete.

3. Click Edit > Remove > Responses.

Removing Items
You can delete items from a project to eliminate items that were added or imported by mistake, 
or that are now obsolete. You can delete an item from a project at any time, as long as it is not a 
sub-item within a BOM structure. You cannot change the BOM structure within Agile PCM. 
When you delete an item from a project, it is removed from all RFQs in the project.

Deleting an item from a project does not affect the Item Master. Published items exist in the 
Item Master even after deletion.

To remove items from a project:

1. Open a project and select the Analysis tab.

2. Select the item you want to delete.

3. Click Remove > Items.

Applying Price Adders to Responses
Price adders are essentially overhead rates. Price adders can be the additional cost of an item, 
apart from the material cost, such as the intellectual property value, the royalty value, and so 
on. You can add as many price adders as you want. Your Agile administrator can customize the 
price adder fields to meet your needs. The price adder fields are common to all projects.

Price adder fields can be enabled for suppliers or for buyers (for internal purposes). In the 
Analysis tab, a buyer can only set price adders that have been enabled for internal purposes. If 
there are price adders that are enabled for suppliers, only suppliers can set them during the RFQ 
process; those fields cannot be set by the buyer. For more information, see Agile PLM 
Administrator Guide.

If a price adder field is enabled for suppliers, the field must also be selected as one of the 
Response Required Fields in the RFQ or project. Suppliers can enter price adders for each 
quantity break in the response line.

You can apply internal price adders by Part, Commodity, or Supplier. When you apply internal 
price adders by:

? Commodity - Each commodity is listed so that you can include a unique price adder 
percent or a fixed amount for each one.

Note: Only root-level items can be selected for removal.

Note: You may choose to use the Top Level Parts view to display only 
root-level items, which enables you to easily see which items you can 
remove.



Looking Up Price Information

Analyzing Project Data 5-19

? Part - The price adders are applied only to the parts that you select.

? Supplier - You get the list of all the suppliers that have been associated to the current 
project, not necessarily only to the part that you selected. Price adders are applied to all 
response lines associated with the supplier, as in a penalty for the selected supplier(s)' 
performance.

Using SmartRules, you can also regulate whether price adders can have zero or negative values. 
You can use the Zero Value For Material Price Adder Fields SmartRule and the Negative Value 
For Material Price Adder Fields SmartRule to either "Allow" or "Disallow" a user from setting 
a price adder to 0 or a negative value, respectively. You can also set the SmartRules to 
"Warning", which is the default value.

To Apply Price Adders:

1. Open a project and select the Analysis tab.

2. Select the row(s) of the items for which you need to add price adders.

3. Choose By Part, By Commodity, or By Supplier in Analyze > Apply Price Adder. The 
corresponding Apply Price Adders dialog appears.

4. Enter the price adder information for each item for each quantity break.

5. Click Apply.

Looking Up Price Information
You can verify the existence of a price for a specified period and quantity in the Item Master. If 
a part already has a price, you can decide whether you still want to create an RFQ for that part, 
or whether you want to use the price you already have. You can either use the price information 
of the item, or you can modify the price information and send the RFQ to suppliers for requote.

In Agile PCM, there are three types of prices that are available out-of-box:

? Contracts - Pre-defined agreements with your suppliers for item prices over a specified 
time period.

? Published Prices - Item price information that has been published from other projects to 
the Item Master.

? Quote Histories - Quoted prices that were previously received for an item.

When you look up data for a particular item or manufacturer part, the price and response fields 
are updated with data that you can leverage in your analysis process. You can have any number 

Note: Price adders are automatically inherited by the parts that belong to a 
commodity.

Note: You cannot select multiple parts to apply price adders universally.

Note: All costed BOM rollups and reports apply the price adders to the 
total material cost, regardless of whether suppliers can see the field.

Note: You can use the Fill-up and Fill-down buttons to copy a price from 
one row to the rows above or below it.
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of price types, which are configured in the Java Client as Price subclasses. All those price types 
are displayed when you do a price lookup so that you can choose the price type the application 
should be searching for when it does a price lookup.

Looking Up Contracts, Published Prices, or Quote Histories
You can look up prices of any type of price that is configured in the Java Client.

Contract prices are pre-defined prices from the potential contractors or suppliers for a specified 
period. By looking up existing contracts with suppliers, you can save time by pulling 
contract-pricing information from the Item Master directly into the project BOM. The contract 
information is specific to suppliers, sites, programs, and effectivity periods. If multiple 
contracts meet the required criteria, the information from the contract with the lowest unit price 
appears. However, when you view the contract information, you can view all the contracts for 
the supplier and part.

Price information associated with items in the Item Master is called published prices. Prices for 
a part can be published after you have finished price negotiations with a supplier. For more 
information about publishing prices, see "Publishing Prices for Items and Manufacturer Parts" 
on page 5-22. You can use the published price for items in the project.

Quote histories are created automatically from supplier responses when you lock or close a 
response line. Therefore, you have a record of price quotes from suppliers even if those prices 
are not published to the Item Master.

When deciding on how to populate the prices, consider the following example. Assume that an 
RFQ has two price scenarios, Q1 & Q2, and you want to look up prices for Q1. The system will 
try to find a price based on the "base scenario," which is Q1. If the All Price Scenarios option 
was selected, once the system finds a price, it will use the same price (Q1's price) for Q2 and 
update both scenarios with the same price. If just one scenario was chosen, only that one is 
updated.

To look up prices:

1. Open a project and select the Analysis tab.

2. Select the row(s) of the item for which you want to look up pricing information.

3. Choose Edit > Price Lookup. The Price Lookup from Item Master dialog appears.

4. Select a price scenario from the Base Scenario drop-down list.

5. Click the button next to the Price Types field. Select either Contract, Published Price, or 
Quote History.

6. Decide whether to Populate Price to all scenarios or just one.

7. Enter the quantity deviation, in percentage, if you select that option, or select the Ignore 
Quantities button to ignore the quantity.

8. Enter the number of days from the RFQ date range, plus or minus, within which the quotes 
have been received or select the Ignore the date ranges button to ignore the date of quote.

Note: Selection of the Price details depends on the Look Up criteria 
mentioned. It can be Lowest Price or Shortest lead time or Most recent 
Response.
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9. Enter the number of days before the current date to consider quotes that occurred within 
that period.

10. Select the Lowest Price, Lead time, or Most recent response button to filter the results if 
multiple rows are retrieved.

11. Optional: You can also specify the following search criterion:

? Ship To Location

? Supplier(s)

? Program(s)

? Customer(s)

12. Click Look Up.

Looking Up Partner Pricing
You can look up partner pricing for all pricing that you are authorized to view. For example, 
you can look up pricing information before creating an RFQ.

There are two ways to use this feature:

? Price object has two suppliers; a primary supplier and an authorized supplier. Project 
lookup will create a response price line for the primary supplier if both suppliers are 
present in the lookup criteria's supplier list and this price is picked up during project 
lookup.

? Multiple suppliers are present in the lookup criteria, and they all appear in the authorized 
supplier list of a price object and that price is used during lookup, the first qualifying 
supplier appearing in the price object's authorized supplier list will be picked up for 
response price line creation in the project. The authorized supplier list on the price object 
will be used as a priority list to determine which supplier gets picked up during project 
lookup.

Price Lookup Precedence
Primary Supplier takes precedence over Authorized Suppliers during the price lookup process 
wherein one price can be returned from the query.

Order for price lookup precedence is defined in the Authorized Suppliers list.

Looking Up Prices From a Sourcing Project
Instead of looking for prices from the price repository, you can look for prices from parts in 
another sourcing project. In this case, you must pick which price scenario you want to look up 
in the other project. If the same part exists in both projects, the system gets the best price from 
the other project and applies it to the current project.

To look up prices:

1. Open a project and select the Analysis tab.

2. Select the row(s) of the item for which you want to look up contract pricing information.

Note: This date range criterion is only applied to sourcing projects with 
effectivity periods. In sourcing projects with quantity breaks, all prices are 
considered regardless of the date range.
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3. Choose Edit > Lookup Prices From a Project. The Price Lookup from Sourcing Project 
dialog appears.

4. Select a sourcing project from which you want to look up prices.

5. Optional: Select the supplier(s) to which you want to narrow down your search.

6. Optional: You can choose to include or not include the following:

a. Prices that are not flagged as best

b. Items that do not have matching revisions

7. Click Continue.

8. Using the drop-downs, select the price points from the source sourcing project that you 
want to map to each of the target sourcing project's price points.

9. Click Look-up.

Publishing Prices for Items and Manufacturer Parts
You can publish as much price information as you get for each item or manufacturer part. You 
can use the published price information for items and manufacturer parts in other sourcing 
projects.

On the Analysis tab, you can publish response line information for selected items and 
manufacturer parts. You cannot, however, publish the response line information when the 
response is pending.

When you publish prices, you can use Redlining or Authoring mode. To create redlines for 
price line data, you must specify a PCO. Once prices are published to the product record, they 
are searchable and viewable from the Prices tab in an item or manufacturer part.

Publishing Rolled Up Material Costs for Assemblies
When you attempt to publish a price, the manner in which prices are published is based on how 
the part was quoted during the quoting process.

If a part is quoted as a:

? component, only material prices get published.

? assembly, non-material prices get published. (See note below.)

? custom-component, both material and non-material prices get published.

If you choose to publish an assembly, and if that assembly has rolled up material prices, the 
application publishes both the rolled up material prices and the non-material prices. The rolled 
up price is published even if it is partial, however, there will be no indication in the price 
repository that the price is partial. The supplier that provided the non-material prices is also 
used when publishing the rolled up prices. If the assembly does not have non-material prices, 
the prices for the assembly will not be published, regardless of whether there is a partial rolled 
up material price.

Note: Regardless of how the part was quoted, rolled up prices are 
partner-specific. Only the values corresponding to the assigned partner are 
rolled-up and published.
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Price Publishing Process
The price publishing process supports large amounts of price items. Each item is published in a 
single transaction so that if one price item fails to publish, it will not affect the publishing of the 
other items.

Each failure is reflected in the Published Price Status column with a dot icon.

In addition to publishing prices contained in a project, you can publish items and manufacturer 
parts. For more information, see "Publishing Items and Manufacturer Parts" on page 4-9

To publish item prices:

1. Open a project and select the Analysis tab.

2. Select the row(s) of the response lines that you want to publish to the Item Master.

3. Choose Publish. The Publish to Item Master dialog appears.

4. Set the following options:

?  Publish - Select specific price scenarios or you can choose to publish for all price 
scenarios.

? Price Type - Select a Price type. The price types provided with Agile PLM are 
Contract, Published Price, and Quote History, but your company may implement other 
types.

? AutoNumber Source - This drop-down list appears once you select a Price Type. If a 
Price Type has more than the default AutoNumber Sources, the list facilitates selection 
of one.

? AML Prices - Select Publish AML Pricing to Manufacturer Parts to only publish the 
AML price(s). Select Publish AML Pricing to Items to publish AML price(s) to 
Item(s). This will display the Item price and AML prices in Prices tab under Item 
Master. This feature is beneficial when Agile PCM extracts/feeds an ERP system, 
enabling other users (such as a different manufacturing site) to refer Item prices and 
their AML prices.

? Assembly Price - Select Best of Supplier roll up/Partner roll up option.

? Publish Mode - Select either Update (redlining) or Authoring mode.

If you select Authoring mode, you can update existing price lines if the parent price is 
unreleased and does not have a pending Price Change Order (PCO). Authoring mode 
is helpful when you are importing price lines for preliminary prices. Once a price has a 
pending PCO, you can no longer use Authoring mode to update its price lines.

If you select Redlining mode, you must specify a PCO to publish updated prices. 
Redlining mode, as its name implies, highlights in red any price lines that have 
changed. All prices imported in Redlining mode appear on the Affected Prices tab of 
the specified PCO.

Change Order - Click to the Search button to select a PCO. You can select an existing 
PCO or create a new one.

Note: You should look for the best responses and publish those to the Item 
Master.
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Update Mode - The "Only add and modify data only (do not delete it)" setting updates 
price lines without deleting rows. If you choose "Add, modify, and delete data," existing 
price lines are completely replaced with the published price lines, potentially deleting price 
line data.

? Publish Error Stops - The publishing prices process can stop due to errors resulting 
from a PCO that is not closed, or a manufacturer part number in the sourcing project 
that does not exist in the Item Master, etc. Once the system encounters an error, it 
terminates the price publishing process immediately. You can choose from 50 or None.

To minimize the amount of stops due to publish errors, you can select 50 from the Publish 
Error Stops drop-down list. This makes the system carry on with the publishing of the 
prices despite the errors, and stops the process only when the 50th error occurs.

If you select the None option from the drop-down list, the system continues to attempt 
publishing for all responses, irrespective of the number of errors it encounters.

5. Click Publish items to Item Master.

Converting Currency Values
In Agile PCM, you can convert any currency to the project currency by the currently prevailing 
conversion rates. Suppliers can quote the rates in their currency, which you can convert to the 
project currency for calculations. You can track and view normalized and original conversion 
rates.

Some currency conversion features provided with Agile PCM include the following:

? systemwide currency conversion table for storing conversion rates.

? Ability to create snapshots of project conversion rates for analysis purposes.

? Supplier responses are stored in their original quoted currency.

? Prices in historical responses and contracts are normalized based on the snapshot 
conversion rate.

? Ability to refresh conversion rates.

Note:  If any existing prices to which you are publishing are already subject 
to a pending PCO, you cannot publish updated prices until the PCO is 
released.

Note: If an error occurs when you publish prices, a dot icon is displayed in 
the Published Price Status column. When you mouse over the dot icon, you 
can see a description of the error. If the Published Price Status field is not 
visible, click Personalize to change the selected attributes on the Format tab.

Note: When you re-publish a response that has been modified, instead of 
overwriting the existing price line, a new price line is created. One of the 
attributes that determines price line uniqueness is the Date Effective From 
field. This field is automatically set once a supplier sends in a response. 
Therefore, once the response line is published, if the modified price line m 
published again, the Date Effective From field will not be the same as the 
original, so the system creates a new price line.
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Viewing Responses in the Normalized Currency
Normalized currency is the project currency. Normalizing the currency is converting the value 
of the supplier's response quote to the project currency. Agile PCM normalizes response 
currencies to the default currency specified in the project by applying the conversion rate.

To view normalized currency rates:

1. Open a project and select the Analysis tab.

2. Select More > View in Project Currency. The information in the table is refreshed.

Viewing Responses in the Original Currency
The original currency is the currency the supplier uses in quotes. When you view supplier 
responses, you view them in the suppliers' currency by default.

To view original currency rates:

1. Open a project and select the Analysis tab.

2. Select More > View in Project Currency. The information in the table is refreshed.

Refreshing Currency Conversion Rates
When you refresh conversion rates in a project, all currencies are normalized based on any new 
rates stored in the conversion rate table. However, this does not apply to the published response 
items in the project.

In addition, Agile PCM makes a snapshot of the latest conversion rates used to re-normalize the 
project currency fields.

To refresh currency conversion rates:

1. Open a project and select the Analysis tab.

2. Choose More > View Latest Currency Rates. The View Conversion Rates dialog appears.

Note: The only place currency exchange rates affect Agile PCM is on the 
Analysis tab of a sourcing project. Currency conversion is not an automatic 
process. From the Analysis tab, you can switch between normalized currency 
rates and the original currency values entered by suppliers. Elsewhere in 
Agile PCM, currency conversion rates do not apply. For example, you can 
configure your system to have money fields on Page Two or Page Three of 
items. If you change the currency for a money field (for example, from USD 
to GBP), the field value is not automatically recalculated for the new 
currency. You can also switch between Original & normalized currencies in 
the RFQ Responses tab.

Note: Conversion calculations are performed in the background based on 
the prevailing conversion rates.

Note: By default, the currency view is Original.

Note: The Agile administrator can update the conversion rates. For more 
information, see Agile PLM Administrator Guide.
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3. Click Update to update response line prices other than the published item prices in the 
project.

Exporting Price Information from a Project
After you have completed your sourcing activities, you can quickly export the results to an 
Excel file. You can export the responses as a flat list of responses and prices.

To export price information:

1. Open a project and select the Analysis tab.

2. Select the item response line(s) you want to export.

3. Choose More > Export (xls) or More > Export (csv), depending on the file type you want 
to export (Microsoft Excel Workbook or CSV). The File Download dialog box appears.

4. Click the Save button to download the file.

Bulk Editing
You can use the bulk edit feature to edit an entire list of items or a set of select items when you 
need to make a universal change to any of the following:

? standard item fields

? flex item fields

? standard manufacturer part fields

? flex manufacturer part fields

? flex response fields

Data can be edited in bulk in the following two locations:

? AML tab - enables you to edit item and manufacturer part fields. Standard fields (like item 
description, manufacturer part description, and so on) and flex fields are bulk-editable in 
this view.

? Analysis tab - enables you to edit standard and flex item and manufacturer part fields. 
Additionally, flex response fields are bulk-editable in this view.

To Bulk Edit in the Analysis tab:

1. Open the sourcing project and select the Analysis tab.

2. Select the desired row(s) of item(s) or select all rows by clicking the All Rows Selection 
cell.

3. Select Edit > Bulk Edit. It opens up Bulk Edit dialog.

4. Select a field from the Attributes drop-down list and enter a value in the corresponding 
Value field.

5. To change more attributes, click the Add button to open up more Field and Value rows.

Note:  You can edit AML status and split percentage on a per-item basis, by 
clicking on the item number.
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Important: The Attributes drop-down list contains only those attributes, 
such as RESPONSE_TEXT01, that have been set Visible in Java Client. For 
more information on enabling Flex Field Attributes, see the Agile PLM 
Administrator Guide.

The flex attributes enabled in the source table such AML.ITEMS, 
AML.AML, RFQ.RESPONSE and in ANALYSIS table are available for bulk 
edit. For example, resp text01 must be enabled in both Analysis and RFQ 
Response tables, ipn text01 must be enabled in both Analysis and AML.Items 
tables to be editable.

The attributes will only be updated when the attributes are applicable to the 
row. For example, item flex attributes will only be applied to item rows and 
will not have effects on manufacturer rows. Response flex attributes will only 
be applied when there are suppliers associated with the item.
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6Requests for Quotes (RFQs)

This chapter provides information about working with requests for quotes (RFQs).

About RFQs
You establish your sourcing contact with your suppliers through Requests For Quotes (RFQs). 
Using RFQs, you can request quotes for any items involved in a project, and the suppliers can 
respond to your requests. To create RFQs, you must have the create privilege for RFQ objects. 
Generally, this means you must either be assigned the Sourcing Administrator or RFQ Manager 
roles, or someone with similar privileges must share a sourcing project with you.

Once an RFQ is created, a sourcing project manager can send it to one or more suppliers for 
quotes. The rich features in Agile PLM help you negotiate prices and terms with suppliers. You 
can analyze responses from multiple suppliers and select the best terms.

You can use RFQs to do the following:

? Create, prepare, and target RFQs to one or more suppliers.

? Leverage contract and historical response information to eliminate unnecessary supplier 
requests.

? Review and adjust RFQs when they are in the Draft state.

? Send the RFQs to suppliers, and track their response status.

? Review, compare, and analyze supplier responses.

? Negotiate to establish better pricing or terms with specified suppliers and line items.

? Mandate suppliers to accept RFQ Terms and Conditions before viewing an RFQ.

The following table describes the RFQ tabs and the actions you can perform from each one.

Tab Description Actions

Cover Page Displays general details about 
the RFQ.

View and edit RFQ details.

Responses Displays response details. View by Supplier Response 
Summary. Select a Price 
Scenario to view responses. 
Filter view of response details. 
Delete items. Add, auto-assign, 
and remove suppliers. Manage 
responses. View currencies.

Response Status Displays a summary of the RFQ 
and supplier response.

Expedite the RFQ. Export or 
import the RFQ for non-Web 
suppliers.
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RFQ Terminology
This section provides definitions of important terminology related to RFQs.

Changes Displays item or response 
changes in the RFQ.

View the item change summary 
by items that were added or 
changed. View Unapplied Item 
Changes in RFQ Changes tab.

Discussion Displays the discussion objects 
related to the RFQ.

View the list of discussions in 
the table with the options to 
reply, delete, and add 
discussions.

Attachments Displays a list of any file 
attachments for the RFQ.

View file attachment details. 
Edit, remove, and add 
attachments.

History Displays a list of actions 
performed during the life of the 
RFQ.

View user, date, time, and 
description for each action.

Terms Descriptions

RFQ Request for quote. A medium for requesting quotes for items from 
suppliers.

RFQ Response (or 
Supplier Response)

The medium through which the supplier can respond to the RFQ. Multiple 
responses are created in the RFQ when multiple suppliers send responses.

Response line The response medium between you and the supplier for negotiating the 
price terms. Each item has a response line in the response depending on the 
Quote As attribute set for the item.

Standard Cost Applies to an item. This is the market cost of the item. It is site-specific. 
The standard cost is for a unit.

Target Cost Applies to item. This is the expected cost of the item by you or the supplier. 
This can be a percentage of the standard cost. Target cost is for a unit.

Quote As Applies to an item. This is used in the RFQ for getting the quote according 
to the option you set. There are three Quote As options:

Assembly - The supplier quotes only the non-material price.

Component - The supplier quotes only the material price.

Custom Component - The supplier quotes both the material price and 
non-material price. Non-material fields, including labor rate and sales tax, 
are flex fields and are not available out-of-box.

Cost Applies to the item. This is site-specific. You can set the Cost to Yes or No 
to specify whether the item has a price in the Item Master. You can edit this 
setting in the project later. If the Cost is neither Yes nor No when an item is 
added to a project, it is set to Yes in the project by default.

Yes - Suppliers must quote a price for items.

No - Suppliers cannot quote BOM parts (children in an assembly).

Tab Description Actions
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RFQ Terms and Conditions
You can bind the suppliers to accept specialized terms and conditions before they can open an 
RFQ.

Configuring RFQ Terms & Conditions in Agile Java Client
To specify Terms and Conditions that the supplier must accept before they can open an RFQ, 
you must configure the Java Client node, System Settings > Product Cost Management > 
RFQ Terms & Conditions from the Admin tab in the Java Client to activate this feature.

After you have configured the RFQ Terms & Conditions in the Java Client, you can set up the 
buyer side to see RFQ Terms & Conditions.

Buyer Side RFQ Terms and Conditions Set Up
Users can make RFQ Terms & Conditions mandatory at the sourcing project level. To make the 
terms and conditions mandatory, select Yes for the "Require RFQ Terms and Conditions" field 
when you create the sourcing project. This setting automatically applies to all RFQs created 
from the sourcing project, however, you can override this at the RFQ level by altering the 
setting for "Require RFQ Terms and Conditions" on the RFQ cover page. You must have the 
correct privileges.”

You can maintain status of the Terms and Conditions acceptance status. As supplier users 
accept the Terms and Conditions, you can see their acceptance status on the Terms and 
Conditions sub-tab on the Response Status tab of the RFQ.

NCNR Non-Cancelable Non-Returnable. Applies to an item. NCNR can be Yes or 
No, depending on the supplier. You can ask for the NCNR information in 
the supplier response. This is one of the critical factors in finding the best 
deal among the supplier responses.

Yes - The item ordered or purchased cannot be canceled or returned to the 
supplier even if the item is not needed or is defective.

No - The item ordered or purchased can be canceled or returned to the 
supplier if the item is not needed or is defective.

UOM Unit of measure. The standard unit of measure of the item. For example, 
fuel is measured in gallons.

Note: For information on how to configure your RFQ Terms & Conditions 
form, read the section "RFQ Terms and Conditions" on page 6-3.

Terms Descriptions
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Figure 6–1 RFQ Terms and Conditions

Supplier View
When a supplier opens an RFQ, the Terms and Conditions form opens with Accept and Decline 
buttons. If the supplier declines, the RFQ will not open, and hence, the supplier user will not be 
able to see its contents. All avenues to the RFQ are blocked: search, link from notification and 
from Workflow Routings. The supplier needs to accept the Terms and Conditions only once to 
proceed with the RFQ. The Terms and Conditions form does not appear again after you accept 
them.

If a supplier user forwards the RFQ to another supplier user, the new user will also have to first 
accept the terms to open the RFQ.

RFQ Process Flow
The RFQ process involves three related objects:

? RFQ - You can ask for quotations for an item from suppliers and partners. You can send an 
RFQ to multiple suppliers.

? RFQ response - A medium of communication between you and the supplier. One response 
from a supplier can contain multiple response lines for different items. Price data is added 
to the project automatically when the supplier submits the response.

? Response line - Each response line has information about only one item. The negotiation 
of price and terms for items is dealt with in the response line.

Note: If a supplier does not accept the Terms and Conditions the first time 
they try to open an RFQ, the Terms and Conditions form continues to open 
every time they attempt to open the RFQ, until the terms are accepted.
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Figure 6–2 Sample RFQ Process Flow

How RFQ Responses and Response Lines are Determined
RFQ responses and response lines are based on the items in an RFQ and the selected suppliers. 
Although you can select specific suppliers for items, Agile PLM can also automatically 
disseminate RFQ responses based on suppliers' manufacturer and commodity offerings and the 
selected routing rules for the RFQ. Consequently, suppliers can be sent an RFQ response to 
quote on one or more items, depending on their offerings.

The following table shows an example of two items being quoted by three suppliers. Part A is 
being quoted by Supplier 1 and Supplier 3. Part B is being quoted by Supplier 1 and Supplier 2.

The following diagram shows the responses, response lines, and suppliers for Part A and Part 
B.

Figure 6–3 Example of RFQ, Responses, and Response Lines by Supplier

Item Supplier 1 Supplier 2 Supplier 3

Part A Yes NA Yes

Part B Yes Yes NA
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RFQ Tasks
The goal of an RFQ is to establish pricing and availability of parts from various suppliers. 
When you are finished with the RFQ process, you can publish negotiated prices to the Item 
Master. Here are the steps needed to complete the RFQ process:

1. Create an RFQ.

2. Add items to the RFQ.

3. Assign suppliers and partners.

4. Change RFQ status to Open.

5. Send the RFQ to suppliers and partners.

6. Review response lines from suppliers.

7. Negotiate or requote (if needed).

8. Publish prices to the Item Master.

The following table lists PCM symbols that help you quickly identify the status of RFQs. These 
symbols appear on tabs in either the sourcing project or the RFQ.

Symbol Represents Description

RFQ This icon represents an RFQ.

Quoted On Items and AML tabs of a sourcing project, 
this icon appears for items that are added to the 
RFQ.

Error This icon indicates that there is an error in the 
response line. When you enter invalid data, such 
as text data in a numeric field, or when you leave 
a required field unfilled, this icon appears.

Not Read On the RFQs tab of a sourcing project, this 
symbol indicates that the RFQ has still not been 
opened to the Supplier.

Pending On the Responses tab of an RFQ, this icon 
appears for items in RFQs to indicate that the 
RFQ for the item has been sent to the supplier and 
a response is pending.

Expedite On the Responses tab of an RFQ, this symbol 
represents that a message to expedite the RFQ 
Response has been sent to the supplier.

Locked This icon appears for items in RFQs to indicate 
that the supplier cannot make any changes to the 
response lines they have sent. Once you open the 
RFQ line to a supplier, you can edit it only when 
it is subsequently Unlocked.

Response On the Responses tab of an RFQ, this icon 
appears for items that have received a response 
from the supplier.

Requote On Responses tab of an RFQ, this icon appears 
for items that are sent to suppliers for requote.
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RFQ Status
The lifecycle statuses of RFQs are Draft, Open, Locked, and Closed. The following table 
provides information about these statuses and the icons that represent them.

These symbols appear between RFQ Number and RFQ Description columns in RFQs Tab of a 
Sourcing Project

Creating Request for Quote
You can create RFQs in the project from Items, AML, or Analysis tab. You can create multiple 
RFQs and send them to multiple suppliers and partners for a quote. To create RFQs, you must 
have the Create privilege for RFQ objects. Agile provides two roles that let users create RFQs:

? Sourcing Administrator

? RFQ Manager

Details On the Responses tab of an RFQ, this icon marks 
the Has Price Information (price details) column. 
If a line item has a icon in this column, it means 
that it has price information available for it. You 
can click this dot icon to view the quoted amount.

View Response 
Changes

On the Responses tab of an RFQ, this icon 
indicates that some changes were made to the 
quotes since the first response. You can click the 
icon to view the changes that have been made to 
the quote.

Alternate/Proposed 
manufacturer part

On the Responses tab of an RFQ, this icon 
indicates that the supplier has proposed an 
alternate part for the quoted manufacturer part. 
The response line displays the icon and the part 
information. Note: Suppliers cannot propose 
alternates unless the Propose Alternates option is 
selected in the Data To Share in the RFQ.

Status Description

Draft (in progress) The default status of the RFQ upon creation is Draft. You can add items and 
assign suppliers to items manually or using the auto-assignment tool. Look 
up contract and response history. Flag items as pre-quoted, not to send to the 
suppliers, but to keep those items for analysis.

Open (in progress) When the status of the RFQ is changed to Open, the RFQ is sent to the 
assigned suppliers. The suppliers see the RFQ notification in their inbox and 
can then quote for the RFQ items. You can send RFQs to suppliers for 
requote when the RFQ is open.

Locked (in progress) You can analyze or make any changes to the response from the supplier for 
requote or acceptance. It temporarily blocks suppliers from updating the 
RFQ (supplier responses are not accepted). Quote Histories are created even 
if the RFQ is locked.

Closed The final state of the RFQ. You can close the RFQ when you have received 
satisfactory responses. Suppliers cannot make changes to the RFQ.

Note: When you close an RFQ, you automatically trigger the creation of a 
Quote History object to preserve a snapshot of quoted prices (if any). For 
more information about SmartRules, see the Agile PLM Administrator 
Guide.

Symbol Represents Description
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If you have not been assigned either of these roles, someone with appropriate privileges can 
share a sourcing project with you, thereby allowing you to create RFQs. For more information, 
see "Sharing a Project with Other Users" on page 2-8.

To create an RFQ:

1. Open a sourcing project and select either the Items, AML, or Analysis tab.

2. Select the row(s) of the item(s) for which you want to create an RFQ.

3. Choose RFQ > Create. The Create Requests for Quote with Identify RFQ Number wizard 
appears.

4. Enter a unique identification number for the RFQ in the Number field, or click the 
AutoNumber icon to get an automatically generated number.

5. Click Next. The Enter RFQ Information page appears.

6. Enter mandatory information

? A brief description about the RFQ in RFQ Description field.

? Click the Due Date calendar and select a date. Suppliers should send responses by this 
date.

7. Enter optional information

? Click the list button next to the Data to Share field, and select the data that you would 
like your suppliers to see.

?  Click the list button next to the Response Requirements field, and select the 
response data that you need from the suppliers.

? Enter any instructions that you find important or useful for the suppliers in the 
Supplier Instructions field.

? Select the Owner of the RFQ. The owner, by default, is the one who created the RFQ. 
Only users with the appropriate privileges can create RFQs.

? Select the RFQ Type.

? Add users to the Authorized Users field. These users will have access to the RFQ.

8. Click Next. The Select Part Addition Rule page appears. See "Part Addition Rule" on 
page 6-9 for details.

9. Click Next. The Select Suppliers page appears.

All the partners associated with the item(s) appear under Select Partners. By default, all the 
partners are selected to receive the RFQ. To send the RFQ only to some of them, you may 

Note: You can create RFQs only when the project status is Open.

Note: On any page of this wizard, you can click Finish instead of Next. The 
system will create the RFQ, but you must fill in details at a later time.

Note: The Data to Share, Response Requirements, and Supplier 
Instructions settings are all automatically inherited from the sourcing project.
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clear the check boxes of the rest. You can decide to send the RFQ only to the partners, only 
to the suppliers, or to both.

10. Click the list button next to the Suppliers field to open the supplier search palette. You can 
narrow down your search by selecting Suppliers, Supplier Groups, or any other 
user-defined category of supplier. For easy identification of suppliers, see "Supplier 
Identification" on page 7-9.

11. Select the dissemination method from the Dissemination Method drop-down list. For 
more information, see "Dissemination Methods" on page 6-9.

12. Filter the selected suppliers based on their ratings, by selecting the desired check boxes 
next to the listed ratings. For example, if you want the RFQ to be responded to only by the 
Approved Suppliers, select the check box next to Approved. This filter eliminates the rest 
of the suppliers.

13. Click Next. The Add Attachments page appears.

14. Add attachments, and click Finish.

Part Addition Rule
In the Select Part Addition Rule page, you can select specific items for the RFQ. The following 
table describes the options.

The figure displayed for each option is a representation of the effect that the option has on the 
items in the RFQ. Use the figures to determine which option is best for you.

Dissemination Methods
Dissemination is the process of assigning RFQs to suppliers based on the methods you specify. 
The manufacturer or commodity offerings that a supplier sets up indicate what products they 
sell. Agile PLM supports the creation of these offerings by geographic regions that can be 
associated with the project's specified Ship To location.

You can also apply a rating to the Product - Ship To location relationship, which lets you 
specify whether the supplier is strategic or approved to sell a product for your ship-to location. 
It can also specify that they offer the product, but that you have not approved it.

Note: This option to select partner appears only if the items have partners 
associated to them. See "Assigning Suppliers and Partners" on page 6-11.

Note: Errors on the page are marked by the Error icon.

Option Description

Add selected items and all sub-components Adds selected assemblies, sub-assemblies, and 
items, and any of their sub-components.

Add selected items only, without sub-components Adds only selected assemblies, sub-assemblies, 
items, and sub-components. If an assembly is 
selected, its sub-components are not added unless 
they are also selected.

Add only sub-components of selected items Adds only sub-components of the selected 
assemblies and sub-assemblies. The 
sub-components include the BOM components 
and their associated manufacturer parts.
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When RFQs are disseminated, Agile PLM looks at the manufacturer and commodity offerings 
for each supplier and assigns parts to suppliers according to the selected routing rules for the 
RFQ.

The dissemination method involves the supplier ratings. The pre-defined supplier ratings 
provided with Agile PLM are:

? Approved

? Strategic

? Offered Active

? Offered Inactive

The RFQ dissemination methods include:

? Manufacturer - The RFQ is assigned to suppliers based on their manufacturer offerings.

? Commodity - The RFQ is assigned to suppliers based on their commodity offerings.

? All - The RFQ is assigned to all suppliers regardless of their manufacturer or commodity 
offerings.

Example - Dissemination by Manufacturer
Project: PRJ

Part: Part A

Manufacturer: Acme

Ship To Location: San Jose

Supplier Rating: Strategic

Here is a list of suppliers and their manufacturer offerings:

When the dissemination method is Manufacturer and the supplier rating is Strategic, the RFQ 
is assigned to Supplier C, since it is has a matching manufacturer offering.

Example - Dissemination by Commodity
Project: PRJ

Part: Part A

Commodity: Comm1

Ship To Location: San Jose

Rating: Approved

Note: Agile PLM administrators can define additional supplier ratings. 
There is no implied order to the supplier ratings. When you disseminate an 
RFQ, you can select multiple supplier ratings.

Supplier Manufacturer Ship To Location Rating

Supplier A Acme San Jose Approved

Supplier B Acme Bangalore Strategic

Supplier C Acme San Jose and Bangalore Strategic
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Here is a list of suppliers and their commodity offerings:

When the dissemination method is Commodity and supplier rating is Approved, the RFQ is 
assigned to Supplier A since it has a matching commodity offering. Although Supplier C 
supplies the commodity, Comm1, for San Jose, it is not assigned the response line because its 
rating is Strategic.

Routing RFQs
Information that you enter when you create an RFQ determines which suppliers receive the 
RFQ. This can help you get the best deal from suppliers. To be sure an RFQ is sent to the 
correct supplier organizations, make sure all manufacturer and commodity offerings are current 
and suppliers are rated.

Every supplier organization has an RFx Routing table that defines how RFQs should be routed 
to specific users based on their region. When an RFQ is sent to a supplier, it is automatically 
routed to the appropriate user within the organization. If the Ship To location does not match 
any of the specified locations in a supplier's RFx Routing table, the RFQ response is routed to 
the supplier's default recipient.

Adding Items to an RFQ
After you create an RFQ, you can add more items to it even if you have already sent the RFQ to 
suppliers for quotes.

To add items to an RFQ:

1. Open a sourcing project and select the Items tab.

2. Select the row(s) of the item(s) you want to add to the RFQ.

3. Choose Quote > Add Items. The Add Items to RFQ with Select RFQ wizard appears.

4. Select the row(s) of the RFQ(s) to which you want to add the selected items.

5. Click Next. The Select Part Addition Rule page appears. For information, see "Part 
Addition Rule" on page 6-9.

6. Click Next. The Select Suppliers page appears.

7. Select the suppliers or supplier groups.

8. Select the dissemination method from the Dissemination Method drop-down list. For 
more information, see "Dissemination Methods" on page 6-9.

9. Click Finish.

Assigning Suppliers and Partners
For any item in the RFQ, you need to assign the supplier or partner information. This is the 
procedure that sets up RFx routing.

A partner is essentially a supplier that has the advantage of access to AMLs of the top level 
assemblies. A supplier only sees the Assemblies, and not its AMLs. You can assign partners to 

Supplier Manufacturer Ship To Location Rating

Supplier A Comm1 San Jose Approved

Supplier B Comm1 Bangalore Strategic

Supplier C Comm1 San Jose Strategic
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the items on the Items tab of a sourcing project. See "Adding Partners to Project Items" on 
page 3-8 for details.

You can also assign suppliers to items on the RFQ Responses tab. See "Assigning Suppliers" on 
page 6-17 for details.

Calculating Quantities for Partner Splits
Although partner splits are defined within the sourcing project, they do not directly impact the 
quantities within a sourcing project. Once you create an RFQ, the system splits the quantities in 
the RFQ based on the split percentages you had defined.

If you have split desired quantities among partners using percentages, quantity calculations are 
automatically done within the RFQ. The following table shows a portion of a BOM. Assembly 
A1 has a Quantity of 1000. Two partners, P1 and P2, have been assigned to the assembly with 
percentage splits of 60% and 40%, respectively.

To find quantities for each partner assigned to a sub-component, the total quantity for the 
sub-component is multiplied by the split percentage:

[Quantity of P4 for P1] = 3000 * 0.60 = 1800

[Quantity of P4 for P2] = 3000 * 0.40 = 1200

There is no restriction on the sum of the partner percentage splits. The sum does not have to 
equal 100 and can exceed a total of 100, if desired.

Updating Target Prices of Items
When you set the target price for an item at the project level, the change is not applied in any 
associated RFQs until you update the target price in the RFQs. You can update the target price 
of items in RFQs from the project or in the RFQ.

Project-Level Update
The project-level update affects all the RFQs in the project that include the selected items.

To update target price of items in RFQs from the project:

1. Open a sourcing project and select the AML tab.

Note: Although partner splits do not affect quantities in a sourcing project, 
analysis on the Analysis tab does get impacted by the splits.

Number QPA Quantity
Partners/ Splits 
P1 (60%)

Partners/ Splits 
P2 (40%)

A1 1 1000 600 400

   P2 1 1000 600 400

   P3 2 2000 1200 800

   P4 3 3000 1800 1200

Note: You can edit the target price of the item in the AML tab of the 
project. For information about how to publish prices to the Item Master, see 
"Publishing Prices for Items and Manufacturer Parts" on page 5-22..
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2. Select the row(s) of the item(s) for which you want to update the target price in the RFQ.

3. Choose More > Update RFQ Targets.

RFQ-Level Update
The RFQ-level update affects only the items in the selected RFQ with the project-level target 
price.

To update target price of items in RFQs from within the RFQ:

1. Open an RFQ and select the Responses tab.

2. Select the row(s) of the item(s) for which you want to update the target cost from the 
project.

3. Select Edit > Update Target From Project.

Deleting Items from RFQs
You can delete items from RFQs when you decide to continue with the same price information 
available for an item and no longer need to request quotes from suppliers.

To delete items from RFQs:

1. Open an RFQ and select the Responses tab.

2. Select the row(s) of the item(s) you want to delete.

3. Choose Remove > Items.

Sending RFQs
You can send RFQs to Web suppliers, or you can export an RFQ to an Excel Worksheet or 
Comma Separated Value (CSV) file and send it as an email attachment or as a hardcopy to 
non-Web suppliers. If an RFQ is sent to a non-Web supplier through Agile PLM, the RFQ 
originator receives the new RFQ notification since the non-Web supplier has no web contact to 
whom the system can send the notification.

Sending RFQs by Changing the Status
RFQs are sent to suppliers and partners when the status is changed to Open.

To send RFQs by changing the status:

Note: You can set target prices only on draft or locked responses, or 
responses in a locked RFQ.

Note: You cannot delete items from RFQ that have already been sent to a 
supplier for quoting.

Note: The items are deleted only from the RFQ. They are not removed 
from the project.

Note: You can send individual line items that are ready for a quote before 
all the items in the RFQ are ready.
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1. Open a sourcing project and select the RFQ tab

2. Open an RFQ by clicking the RFQ number.

3. Choose Change Status > Open.

The RFQ notification is sent to Web suppliers.

Sending Line Items in RFQs
You can send out line items that are ready for quoting, rather than waiting until all the items in 
the RFQ are ready to send out for quotes.

To send line items in an RFQ:

1. From the Responses tab of an RFQ, select the row(s) of the items that you want to send 
out.

2. Choose Response > Send Requests to Suppliers.

Exporting RFQs for Non-Web Suppliers
Non-Web suppliers are those who do not perform transactions online. They do not have web 
access and therefore cannot use the Agile Web Client to respond to RFQs. You cannot send 
RFQs to non-Web suppliers by changing the status of the RFQ to Open or by opening the line 
items. To send RFQs to non-Web suppliers, you need to export the RFQ and send it as an 
attachment in email or as hardcopy through any appropriate channel.

To export RFQs for non-Web suppliers:

1. Open an RFQ and go to Response Status tab.

2. In the Supplier Response Status section, select the row(s) of the non-Web supplier to 
whom the RFQ should be sent.

3. Click Export > Export (csv) or Export > Export (xls), depending on the file type you 
want to export (Microsoft Excel Workbook or CSV). The File Download dialog box 
appears.

4. Click the Save button to download the file.

Note: Once you open an RFQ it cannot be changed to Draft state again.

Note: Make sure that each line item has an assigned supplier.

Note: This sends only the selected line items to suppliers.

Note:  If a supplier is a non-Web supplier, the Web Supplier status on the 
supplier General Info tab should be set to No

Note: You can send the file as an attachment through email, or send a 
hardcopy of the RFQ through any appropriate channel to the non-Web 
supplier.
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Working with RFQs
This section consists of the following:

? Finding RFQs

? Viewing RFQs

? Changing the RFQ Status

? Deleting RFQs

? Viewing RFQ Changes

? Viewing RFQ History

Finding RFQs
All RFQs are associated with a specific sourcing project. To see the list of RFQs for a project, 
open the project and go to the RFQs tab.

Like any other Agile object, you can also find an RFQ through a search. You can use quick 
search, advanced search, saved search, or bookmarks to find the RFQ.

The search result displays the name and the identification number of the RFQ, the description 
of the RFQ, and the status of the RFQ. You can click the RFQ Number to view and edit the 
information about the RFQ.

To find RFQs assigned to you:

1. In the left pane, under Searches, expand Supplier RFQ Searches.

2. Click RFQ Requests that I Own. You may also use any of other preset search criteria as 
required.

Viewing RFQs
You can view the RFQs created in a particular project in its RFQs tab. A dot symbol on RFQ 
tab denotes that the project has RFQs.

The table in the RFQs tab lists information including the RFQ description, status, response 
percentage, and the number of suppliers who responded.

To view the RFQ in the project:

1. Open a sourcing project and select the RFQs tab.

2. Click the RFQ number to view the RFQ information.

Changing the RFQ Status
You should change the status of the RFQ when you want to edit the response line, send the 
response to suppliers, or close the RFQ.

To change the status of the RFQ:

1. Open a sourcing project and select the RFQs tab.

2. Select the row(s) of the RFQ(s) whose status you want to change.

3. Click Change RFQ Status, and choose the status you want.

Note: A user must have the (Restricted) RFQ Responder role to be able to 
view the Supplier RFQ Searches.
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Deleting RFQs
You can delete an RFQ only if its status is Draft or Closed. You cannot delete open or locked 
RFQs. When you delete an RFQ, any prices previously published from the RFQ to the Item 
Master remain unaffected. Since there is no recycle bin search available for RFQs, once 
deleted, there is no way to bring an RFQ back.

To delete an RFQ:

1. Open an RFQ.

2. Click Change RFQ Status. The status of the RFQ must be either Draft or Closed.

3. Choose Actions > Delete. A message appears for you to confirm whether you want to 
delete the RFQ.

4. Click OK to delete the RFQ.

Viewing RFQ Changes
You can view RFQ changes to track items that were added, deleted, or changed, or to monitor 
response changes. The Changes tab displays a list of changes that have occurred to the RFQ 
because of project item updates. When a change is made to items in the project, and that change 
affects the contents of an existing RFQ, an RFQ change notice is generated.

You can view the item changes and the response changes made to the RFQ on the Changes tab. 
The filters are available in the Changes tab for viewing the added, changed, and deleted items 
individually. You can also view the Unapplied Items changes, for Items that are present in the 
RFQ.

To view RFQ changes:

1. Open an RFQ and click the Changes tab.

2. Click the sub-tab that you want to view.

You can select the Unapplied Item Changes tab (default view), the Project Item Changes 
tab, or the Supplier Responses tab.

3. You can change the view on the sub-tabs by selecting a view from the Views drop-down 
list.

In the Project Item Changes tab, you can choose to see Items Added, Items Deleted, or Items 
Modified.

Viewing RFQ History
The History tab shows information about each action for this RFQ, including the name of the 
person who performed the action, the date and time of the action, and a description of each 
action.

To view RFQ history:

1. Open an RFQ.

Note: When you change an RFQ status to Closed, all suppliers and partners 
associated with the RFQ are automatically notified.

Note: The content of the Changes tab is refreshed automatically when an 
action is performed on it.
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2. Click History tab.

You can view the actions and transactions that happened in the RFQ since it was created.

Working with RFQ Responses
Suppliers enter and submit their quotes for items in responses. The Responses tab of an RFQ 
displays all the items, BOMs, and the manufacturer parts of the items in the RFQ. It also 
displays the status of each response line, the details of the response from the supplier, and the 
changes made to the response.

This section consists of the following:

? Filtering RFQ Responses

? Assigning Suppliers

? Expediting RFQ Responses

? Viewing Responses in Different Currencies

? Looking Up Price Information

Filtering RFQ Responses
On the Responses tab of an RFQ, the filter toolbar enables you to isolate the responses you 
want to see. You can use pre-defined filters/views, or filter by specific attributes.

To filter the Responses tab of an RFQ:

1. Open an RFQ and go to the Responses tab.

2. Click Personalize.

3. Click the Field drop-down list to select a field by which to filter.

4. Click the Operator drop-down list to select a relational operator for the filter. The list of 
relational operators depends on the type of attribute selected.

5. Select a value for the filter criteria.

? For text attributes, type a value.

? For list attributes, click the list icon to select a single or multiple values from available 
values list.

6. To add additional filters, click the Add button.

7. Click Apply.

Assigning Suppliers
The Responses tab lists all response lines from suppliers for items, BOMs, and manufacturer 
parts. The response line consists of the data that you requested from the supplier, such as the 

Note: Alternatively, you can use one of the pre-defined filters, such as 
Items Without Price and Items With Split, which are listed in the Views 
drop-down list. This drop-down is located next to the Personalize button.

Note: To save this filter for future use, click Save. You must then click 
Save As to save the settings as a new filter.
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pricing information and the price change information. The suppliers receive the RFQ for the 
items to which they have been assigned.

You can add suppliers to items from the Responses tab either manually or automatically.

Assigning Suppliers Manually
You can add any supplier to any item manually. Agile PLM ignores the dissemination method 
and assigns the selected suppliers to all the selected items.

To assign suppliers manually:

1. From the Responses tab of an RFQ, select the row(s) of the items to which you want to 
add suppliers.

2. Choose Add > Suppliers. The Search Suppliers palette appears.

3.  Search for and select the suppliers you want to add. Double-click the suppliers or press 
Enter to add them to the Suppliers table.

4. Close the search palette.

Assigning Suppliers at AML Level
Suppliers can be assigned at the AML level in an Item. This makes the RFQ process more 
efficient and effective, since the Supplier receives an RFQ, and has to respond, only for those 
Items that it supplies.

From the buyer's perspective, this function helps secure the information about other AMLs in 
an Item that need not be seen by a Supplier who does not supply them.

To assign Suppliers at the AML Level:

1. From the Responses tab of an RFQ, select the row(s) of the AML(s) in an Item, including 
the Item row, to which you want to add suppliers.

2. Choose Add > Suppliers. The Search Suppliers palette appears.

3. Search for and select the suppliers you want to add. You can double-click to add a supplier 
or drag and drop the supplier(s) to the Suppliers table.

4. Close the search palette.

Auto-Assigning Suppliers
When you attempt to auto-assign suppliers to items in an RFQ, the application determines 
which suppliers, from the suppliers you specified, satisfy the dissemination and rating 
constraints that you selected. When you auto-assign suppliers to items after the original RFQ 
creation, you can specify additional auto-assignment rules. Auto-assignment does not remove 
any current supplier assignments, but adds any additional assignments based on the criteria you 
define.

To Auto-assign suppliers to items:

1. From the Responses tab of an RFQ, select the row(s) of the item(s) to which you want to 
add suppliers.

2. Choose Add > Auto-Assign Suppliers. The Auto-Assign Suppliers dialog appears.

Note: To distinguish suppliers, see "Supplier Identification" on page 7-9.

Note: To distinguish suppliers, see "Supplier Identification" on page 7-9.
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3. Click the Search button next to the Suppliers field. The Suppliers Groups search palette 
appears.

4. Search, and select the suppliers from the results. Double-click individual suppliers or select 
multiple rows and press Enter to add suppliers into the Suppliers cell.

5. Select a dissemination method from the RFQ Dissemination Method drop-down list.

6. Select ratings from the list of available ratings. Only suppliers with the selected ratings will 
be used.

7. Click OK.

Expediting RFQ Responses
Tracking supplier response status and expediting delinquent supplier responses is an important 
part of the RFQ process. You can quickly view the progress of your RFQ and send email 
notifications to suppliers to remind them that the RFQ response is pending. You can request 
responses even after the specified due date.

To expedite RFQ responses:

1. From the Response Status tab of an RFQ, select the row(s) of the supplier(s) from whom 
you require a response.

2. Click Expedite. The Expedite window appears.

3. Enter the subject in the Subject line and the message in the Message field.

4. Click Send.

Importing Responses from Non-Web Suppliers
Non-Web suppliers are those who do not use the Internet or Agile Web Client. Therefore, RFQs 
have to be sent to them either as an email attachment or as hardcopy through any appropriate 
channel. They may return the response lines as an attachment or as hardcopy.

If a non-Web supplier sends you a response line as an email attachment, you can import the file 
directly into a project. If a non-Web supplier sends you the response line as hardcopy, you need 
to enter the information in an electronic file and import it. You can import response lines only 
from non-Web suppliers. If, for any reason, you want to import response lines for a supplier 
with Web access, ask the Supplier Manager to set the Web supplier status to No temporarily on 
the supplier's General Info tab.

Note: To distinguish suppliers, see "Supplier Identification" on page 7-9.

Note: The auto-assign suppliers functionality only works on IPN levels, 
and is not applicable to the AML level.

Note: A notification is sent to the supplier who has not responded to the 
RFQ. An expedited symbol appears in the Expedite column of the Supplier 
Response Status table.

Note: To specify that a supplier does not have Web access, the Supplier 
Manager sets the Web Suppler field to No on the supplier’s General Info tab
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For information about importing responses from non-Web suppliers, see Agile Import/Export 
Guide.

Viewing Responses in Different Currencies
You can view the response lines on the Responses tab of the RFQ. The supplier can respond to 
an RFQ in their own currency, which can be different from the project currency. You can view 
and analyze the quote information in either the supplier (original) currency or the project 
(normalized) currency. Using the normalized currency lets you analyze all responses in a single 
currency.

When you select the view, Agile PLM calculates and displays the price information based on 
the currency conversion rates. You select currency views and refresh currency conversion rates 
from the Responses tab the same way you do from the Analysis tab of a project. For more 
information, see "Converting Currency Values" on page 5-24.

Looking Up Price Information
You look up price information in the Responses tab the same way you look up for price 
information in Analysis tab of a project. See "Looking Up Price Information" on page 6-20.

Editing Responses
At times, you might need to edit supplier responses so you can negotiate or request that the 
supplier provide another quote for an item. For example, you can ask for a shorter lead time or 
lower cost by specifying the changes in the response line. The supplier can choose to re-quote 
or stay with their previous quote.

You can edit a response line when the RFQ and Response lines are in draft state. Otherwise, 
only the assigned supplier can edit a response line.

To lock response lines:

1. From the Responses tab of an RFQ, select the row(s) of the response line(s) to lock.

2. Choose Response > Lock Response. A message may appear to warn you that a quote 
history will be created when the RFQ is locked.

Once you have locked the response, you can edit the response line.

To edit the response line:

1. From the Responses tab of an RFQ, select the row(s) of the locked response line that you 
need to edit.

2. Choose Edit > Response Line. The Response Entry page appears. See Response Entry 
Form for more details.

3. Edit the information as necessary.

4. Click Next if you have selected multiple response lines, or click Finish.

In the Responses tab, "Sourcing Manager Edited" appears in the Source column of the response 
line you edited.

Note: You can look up prices and bring them into an RFQ response only if 
suppliers are assigned to the items.

Note: When you select the "Apply to all the selected response lines" check 
box, the Next button is disabled.
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Response Entry Form
This is a dynamic entry form, which performs requisite calculations instantly. For example, 
when you enter a certain amount in Material Price field, and then change it to another amount, 
the Total Material Price figures change immediately to reflect the latest value that was entered.

Figure 6–4 Response Entry Form

On this form there is an Apply to all the selected response lines check box. When you select 
this box, the data (Inventory Available, Material Price, Valid Until, and so on) that you fill in 
for the current item, is applied to all the other response lines that you selected for editing.

Setting Response Lines as Pre-Quoted
A pre-quoted response line is one for which you do not need a quote from suppliers, perhaps 
because you are using published prices or existing contract pricing. When you set response 
lines to be pre-quoted, they are not sent out to suppliers for new quotes.

To set response lines as pre-quoted:

1. From the Responses tab of an RFQ, select the rows of the response lines to mark as 
pre-quoted.

2. Choose Response > Set As Pre-Quoted.
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Requesting Requotes
You can negotiate with suppliers by requesting that they quote again for an item.

To request Requotes:

1. From the Responses tab of an RFQ, select the row(s) of the response line(s) that require a 
requote.

2. Choose Response > Lock Responses.

3. Choose Response > Edit. See "Response Entry Form" on page 6-21 for more details.

4. Click Next if you have selected multiple response lines, or click Finish.

5. Select the Apply to all the selected response lines check box to use the price and terms 
information of the current item for all the response lines selected. (Optional.)

6. Choose Response > Requote.

Viewing Requote Status
You can view the status of the items that were sent to be requoted on the Response Status tab of 
the RFQ. The Open Requotes field in the Supplier Response Status section displays the number 
of requotes that suppliers have not yet responded to.

To view requote status:

1. Open an RFQ.

2. Select the Response Status tab.

You can see the total number of requotes in the Requote column of the RFQ Status section and 
the number of open requotes that need responses from suppliers in the Open Requotes column 
of the Supplier Response Status section.

Sharing an RFQ With Other Users
You can share an RFQ with another user. Sharing an RFQ means that you are granting another 
user or user group one or more of your roles.

For general information about sharing Agile objects with other users, see Getting Started with 
Agile PLM.

To share an RFQ:

1. Open the RFQ.

2. Choose Actions > Sharing. The Share With Users dialog appears.

3. Click Add. The Add Users dialog appears.

4. Click the Address Book button to the right of the Users field.

5. Use the drop-down filter in the Users search palette to select all users (Users) or all groups 
(Groups) or any other specific group.

Note: The Requote Requested icon in the Response Status column indicates 
that a requote has been requested for the response line.

Note: You cannot share those roles that have been shared with you by 
another user.
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Enter your search criteria and click Search. You may also type a user's name if you know 
exactly how it appears (in the system), but you must first select a group to populate the 
Available Users list.

6. Select the users one by one, or select multiple users/user groups using the ctrl button on 
your keyboard. Drag and drop your selected item(s) to the Users cell.

7. Click the list button to the right of the Roles field. The Roles palette appears. Select the 
appropriate role or roles for your chosen users to have available related to the RFQ. Drag 
and drop them into the Roles cell.

8. Click Save. Your additions are listed in the Share With Users window.

9. Click Close.

To remove users from an RFQ's Access Control List:

1. Open the RFQ.

2. Choose Actions > Sharing. The Access Control List: Share With Users dialog appears.

3. Click the rows of users to remove.

4. Click Remove.

To see which objects have been shared with you:

1. Click the My Settings button in the Courtesy Controls area in the left pane.

2. Click the Share tab.

The Share tab lists the objects that have been shared with you by another user.

3. From your user profile, see if any objects have been shared with you through user groups. 
Click the User Group tab. Click a desired group. Click its Share tab.

The Share tab lists the objects for which the group and all its users have been granted 
shared roles by another user.

Note: To see the Access Control List for a RFQ, choose Actions > 
Sharing. The Access Control List shows the complete list of users who have 
access to the RFQ.
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7Managing Customers, Commodities, and
Suppliers

This chapter provides information about managing customers, commodities, and suppliers.

Collaborating with External Organizations
An organization could be a company, division, department, group, or team. These organizations 
participate in business processes such as sourcing, quality management, and design engineering 
and are involved throughout various phases and activities of a program. You can manage 
organizations outside your own boundaries (such as your customers, your suppliers, and your 
partners).

As competition increases, customers demand quality product on time and at a lower cost while 
the product lifecycle time decreases. Agile PLM enables you to effectively support the 
following business processes in which multiple organizations may be involved:

? Obtain pricing quotes and sourcing proposals for your customers.

? Send out RFQs to obtain pricing quotes from suppliers.

? Capture quality issues reported from your customers.

? Report quality issues resulting from parts or services provided by your suppliers.

Before You Begin
This chapter assumes that you are informed about Product Service Requests (PSRs) for 
managing Problem Reports and Non Conformance Reports (NCRs). For more details on PSRs, 
see the Product Quality Management (PQM) User Guide.

Roles Required to Manage Customers and Suppliers
The roles a user requires to manage customers and suppliers are:

? Organization Manager - create and manage customers and suppliers

? Supplier Administrator - manage the organization profile, users, RFx routings, and line 
cards for a supplier organization

? Compliance Manager - responsible for routing material declarations to suppliers; also 
create and manage PG&C objects and run PG&C reports

For more details on roles and privileges, see the Agile PLM Administrator Guide.
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Managing Customers
Customers are clients of your company. You can associate product service requests (PSRs), 
quality change requests (QCRs), sourcing projects and RFQs, and prices with a customer. You 
can use the Agile SDK or the Import tool to import customers from CRM systems.

Creating a Customer
You must have the necessary privileges to create customers. These privileges are part of the 
Organization Manager role. You create a customer the same way you create other Agile PLM 
objects. You can use the New Object button or Save As feature in the Java Client, or the Create 
New menu or the Save As feature in the Web Client.

To create a customer object in Java Client:

1. Click the New Object button.

The New dialog box appears. Agile PLM remembers what type of object you created last 
and displays that type in the Type field.

2. Select a customer type from the Type list.

3. In the Customer Number field, type a number, or click the AutoNumber button to enter a 
system generated number.

4. In the Customer Name field, type a name. Click OK. The customer is created and the 
General Info tab is displayed.

5. Complete the fields on this tab. For more information about the Customer Name, and other 
fields, see customer General Info tab fields table in "Customer Fields and Attributes" on 
page 7-3.

You can attach files and URLs to the customer from the Attachments tab. To attach a file, 
click the down arrow next to the Add Folder Reference icon, and click Add File. To 
attach a URL, click the down arrow next to the Add Folder Reference icon, and click 
Add URL.

To create a customer object using the Save As feature in Java Client:

1. In an open customer, right click anywhere on the dialog and choose Save As.

The Save As dialog box appears. Java Client automatically fills in the Type and Customer 
Number fields as they appear in the original customer.

2. If required, select a different customer type from the Type list. Click OK. The customer is 
created.

3. You can change the information in the fields as necessary. For more information about the 
Customer Name and other fields, see "Customer Fields and Attributes" on page 7-3.

In Java Client, these buttons are available at the bottom of the customer window:

? The Save button saves modifications made to the fields in the active window.

? The Refresh button updates the window to show the latest information from the Agile 
database.

? The Close button closes the active window.

To create a customer object in Web Client:

1. Click Create New Customers > Base Class from the main toolbar. The Create New 
Customers Base Class dialog appears.

2. Select a customer type from the drop-down list.
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3. In the Number field, use the automatically system-generated number or type a new 
number. Alternatively, you can click the AutoNumber button, if set up by your Agile 
administrator, to get a system generated number.

4. In the Customer Name field, type a name.

5. Click Save. Web Client creates the customer and displays the customer with the General 
Info tab on top.

6. Click the other tabs to add additional information about the customer.

To create a customer object using the Save As feature in Web Client:

1. In an open customer object window, choose Actions > Save As. The Save As dialog 
appears.

2. In the Customer Number field, type a number or click the AutoNumber button to get a 
system generated number. The Web Client may automatically fill in both the Customer 
Number and the Type fields.

3. Type a new Customer Name.

4. Click Save. The newly created customer appears.

In Web Client, use the Edit button on the General Info tab on the customer page to edit 
the general customer information.

Customer Fields and Attributes
The following table lists and describes the fields in the customer General Info tab in Web 
Client.

Note: The way your Agile administrator has set up your system affects how 
things work in this step. You may be able to modify both fields, if needed.

Field Completed... Contains...

Customer Number When created; type the number 
or use the AutoNumbers button. 
Customer is uniquely identified 
by the number. (Required)

The number assigned to the 
customer when you create it.

Customer Type Manually (Required) drop-down list of the customer 
types.

Customer Name Manually (Required) The name of the customer.

Description Manually The description of the customer. 
The maximum number of bytes 
is set by the Agile 
administrator; can be up to 1023 
bytes, including space and 
carriage returns (which count as 
two bytes).

D-U-N-S Number Manually The industry standard Data 
Universal Numbering System 
(DUNS) number.

Address Manually The mailing address of the 
customer.

City Manually The city where customer is 
located.
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Editing a Customer
After you have created a customer, you can go back and edit the customer's information at any 
time.

To edit a customer:

1. Open the customer you want to edit, and display the General Info tab.

2. In Web Client, click the Edit button, and fill out the appropriate fields.

In Java Client, change the information in the fields as necessary.

See "Customer Fields and Attributes" on page 3 for details.

3. Click Save.

Customers are not under change control. Anyone with the necessary privileges can edit a 
customer at any time. The changes take effect immediately.

Creating Commodities
A part group can be one of the following:

? Commodity - used only in PCM

? Part Family - used only in PG&C

? Item Group - used only in PC

In PCM, commodities let users categorize parts for sourcing and analysis processes. 
Commodities are associated with items (parts and documents). It is a way of grouping similar 
types of items. By associating each item with a commodity, your users can distribute RFQs to 
suppliers based on the commodities they offer.

Commodities can be active or inactive. Unlike other Agile PLM business objects, commodities 
do not have workflows. They are used to categorize groups of items.

If your company has a Product Governance & Compliance (PG&C) license, you can use 
commodities to collect information on restricted substances for part families. For more details 
on how to use Commodity objects for PG&C, see the Product Governance & Compliance User 
Guide.

Zip Code Manually The zip code of the customer.

Contact Manually The name of contact person 
from the customer side.

Email Manually. The email address of the 
customer.

Phone Manually The customer contact phone 
number.

Fax Manually The customer fax number.

URL Manually The URL of the customer Web 
site.

Lifecycle Phase Manually The lifecycle phase of the 
customer. For example, the 
customer is Active or Inactive 
in this lifecycle phase.

Field Completed... Contains...
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When creating a commodity, there is a Make Available As attribute that enables you to decide 
how the commodity should be treated. The options are:

? Commodity Only - only for PCM

? Part Family Only - only for PG&C

? Commodity and Part Family - used for PG&C & PCM

? Item Group - only for PC

You can create commodities using Web Client. You can search for commodities in Java Client 
but not create them.

To create a commodity in Web Client:

1. Choose Create New > Part Groups from the global menu bar. The Create New Part 
Groups dialog appears.

2. In the Type list, select Commodity. Other types of Part Family subclasses may also be 
available.

3. Specify a unique commodity name, which can be a short abbreviation (such as "Trans" for 
Transistor). The name is not case-sensitive.

4. Note Specify how you want the commodity to be treated using the Make Available As 
option.

5. Click Save. The new commodity appears with the General Info page.

6. Click Edit. Enter general information, such as a description. Make sure the Lifecycle 
Phase field is set to Active. The weight field is optional; it is only relevant for Product 
Governance & Compliance. Click Finish.

7. Click the other tabs to add additional information about the commodity.

Commodity Tabs
Commodities have the following tabs:

? General Info - provides general information about the commodity

? Parts - lists the parts that belong to this commodity category

? Compliance - lists the Specifications and Compositions of the commodity

? Suppliers - lists the suppliers who supply this commodity

? Attachments - lists the attached files for the commodity

Note: If the part group is only for PCM, the part group cannot have 
compliance information. If it is only for PG&C, the part group cannot be used 
for RFQ dissemination.

Note: To create commodities, you must have the create privilege for 
commodities. If needed, contact your Agile administrator to obtain privileges.

Note: You cannot delete an item that is associated with a Part Group, or in 
other words, an item that appears on the Parts tab of a Part Group object. If 
the Commodity field is populated, the Actions > Delete command is disabled.
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? History - shows the history of events related to a commodity

Associating Items with Commodities
A commodity's Parts tab lists all items that are associated with it. This association between 
commodities and items is important because it determines which parts a supplier will be asked 
to quote on when an RFQ is disseminated by commodity.

To associate an item with a commodity in Web Client:

1. Open the commodity you want to work with and select the Parts tab.

2. Click Add. A new row appears in the Parts table.

3. Click the Search button and search for existing items.

4. Select items by double-clicking them or dragging and dropping them into the Parts table.

If not successful, any errors or warnings appear in the error message bar on the Parts tab. If 
there is no error, the added items appear as rows in the Parts table.

Managing Suppliers
An organization manager checks in the organization's PSRs and sets up global supplier groups 
that can be leveraged by users with the appropriate roles. They can obtain pricing quotes and 
sourcing proposals for your customers and send out RFQs to obtain pricing quotes from 
suppliers.

Supplier Types
There are five out-of-the-box supplier types (but you can add more to your Agile PLM system):

? Component Manufacturer - sells individual parts or components

? Contract Manufacturer - manufactures products but does not necessarily own the 
engineering design

? Distributor - purchases and resells products

? Manufacturer Representative - direct customer representative for a manufacturer

? Broker - responsible for the supply of goods and services to trading partners

Partners and Suppliers
Suppliers may be either partners or suppliers. A partner receives the complete bill of material 
(BOM) of the items in the RFQ, and the supplier receives only the assigned parts. The Agile 
administrator creates partners. The administrator can also create supplier groups, which permit 
you to select multiple suppliers during the RFQ process.

Note:  The Compliance tab is used only for Product Governance & 
Compliance (PG&C). If your company does not have the PG&C license, this 
tab may be hidden.

Note: In the Title Block tab of a Part, the Part Family or Commodity 
attributes indicates which Part Group this part is associated with. Either of 
these attributes can be enabled. Both are read-only.
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Supplier Lifecycle Phases
The lifecycle phase of the supplier can be either Active or Inactive.

Creating a Supplier
Use the Supplier Creation dialog to create a supplier organization.

To create a supplier in Web Client:

1. Choose Create New > Supplier from the global menu bar. The Create New Supplier 
dialog appears.

2. In the Type list, select the appropriate supplier type, for example Broker. Once selected, all 
of the required fields will be displayed in the dialog.

3. Specify a unique supplier Name.

4. Enter details for the remaining fields, including flex field details.

See "Supplier Fields and Attributes" on page 7 for descriptions of the fields that appear in 
this dialog.

5. Click Save.

To edit fields of a supplier, click the Edit button. You may not be able to edit the contents 
of some fields.

Click the other tabs, including the Contact Users tab, to add additional information about 
the supplier. See the corresponding sections in this chapter for information.

Supplier Fields and Attributes
As with other Agile objects, information about the supplier is displayed on a series of tabs. 
Each tab contains information about, or related to, that supplier.

By default, the General Info tab contains the fields listed in the following table. Agile 
administrators can add custom class and subclass fields to the General Info tab.

Status Description

Active The supplier is currently active and able to receive RFQs.

Inactive The supplier is currently not active. In this status, the supplier cannot be 
included in new RFQs or price objects.

Note: In the Number field, use the automatically system-generated number 
or type a new number. You can also click the AutoNumber  button to get a 
different system generated number, if needed.

Note: Your Agile administrator may have altered the way the Number field 
is populated.

Note: Some tabs may not be enabled by your administrator.
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Buttons on the General Info tab
The General Info tab contains the following buttons:

? Edit - appears when the General Info tab is not in edit mode. To edit the General Info tab, 
click Edit.

Field Description

Name Name of the supplier.

Supplier Type The following are the out-of-box supplier types:

Component Manufacturer

Contract Manufacturer

Broker

Distributor

Manufacturer Representative

This field is configurable in the Java Client. More supplier types can be 
added, if needed.

Lifecycle Phase Indicates if this supplier is Active or Inactive.

Note: Only active Suppliers can participate in product sourcing activities.

Number The supplier number assigned to the supplier when you create it.

DUNs The industry standard Data Universal Numbering System (DUNS) number.

Display Name Indicates the display name

Description Text that describes the supplier. The Agile administrator sets the maximum 
length.

Web Supplier Indicates if this supplier logs in to the Web Client (Yes or No). If No, they 
receive offline communication.

Corporate Currency The default currency for this corporation. By default, RFQs will be responded 
to in the assigned corporate currency. Supplier users can set their own default 
currency.

Address Address

City City

Postal/Zip Code Postal or zip code

Phone Phone number

Fax Fax number

URL URL for supplier Web site

Maximum number of 
Contact Users

The maximum number of supplier users that can be created for this supplier

Maximum Number of 
Licensed Contact 
Users

The maximum number of supplier users that can be assigned a concurrent 
user license

Maximum Number of 
Power Contact Users

The maximum number of supplier users that can be assigned a power user 
license

Default RFQ 
Recipient

The user in the supplier organization who gets the notification when an RFQ 
gets sent to the supplier.

Default Declaration 
Recipient

The user in the supplier organization who gets the notification when a 
declaration gets sent to the supplier.
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? Save - appears when the General Info tab is in edit mode. To save the changes that you 
made to the tab while it was in edit mode, click Save.

? Cancel - appears when the General Info tab is in edit mode. To undo the changes that you 
made to the tab while it was in edit mode, click Cancel.

The following sections describe the additional tabs.

Supplier Identification
Sometimes, an organization may have more than one supplier with identical names. The system 
does not stop you from giving a name to a supplier that already exists, as internally, they are 
differentiated by their unique identification numbers. As a user, however, it is difficult to 
distinguish the desired supplier from a list of identical supplier names.

In Agile PLM, the supplier listings display their identification numbers, in brackets, next to 
their names. You can notice this in Responses and Analysis tabs in a Sourcing Project, in 
Supplier Response Export files and in Supplier search results.

When you wish to sort a suppliers list in ascending or descending order, it sorts first on supplier 
name and then its number.

For example, if a list has supplier Agile1 (SJ001), Agile1 (AG015), Agile1 (sup001), Agile1 
(A0001), the ascending order will appears as:

Agile1 (A0001)

Agile1 (AG015)

Agile1 (SJ001)

Agile1 (sup001)

Adding Contact Users
The Contact Users tab defines which users can log in to Agile PLM to represent a supplier. 
Supplier users have restricted privileges to the Agile PLM system that allow them to respond to 
RFQs.

To create a supplier user in Web Client:

1. Open a supplier and click the  Contact Users tab.

2. Click the Add button.

3. Click the Create New button. The Create New dialog appears.

4. Enter the Username. Type the Login Password, and retype it to confirm.

5. Enter the Approval Password and retype it to confirm.

6. Enter user details: First Name, Last Name, and Email.

7. Click Add.

Once the contact user is created, you may consider changing some of the following contact 
user fields:

? Status - Make sure the status field is set to Active.

Note: To use the same password as the Login Password, select the Use 
Login Password for Approval check box. This will disable the Approval 
Password fields.
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? Role - The user's role assignments. This property determines a user's access to the 
objects in Agile PLM from the point of discovery forward.

? User Category - Agile PLM has three types of user licenses: Power, Concurrent, and 
Restricted. Restricted users are people outside your company (such as suppliers) who 
are given limited access to the Agile PLM system. Power users are not subject to 
concurrency counts and can therefore log in at any time. Both Restricted and Power 
users can respond to RFQs, but only Power users can generate and view reports.

? Sites and Default Site - Sites are used for distributed manufacturing, and indicate all 
of the company's locations where the user is involved. Default Site is the user's main 
base of work.

? Authorized Ship To and Home Ship To - The Authorized Ship To field indicates all 
company locations where the user can initiate sourcing activity. The Home Ship To 
location is the primary location where the user is responsible for sourcing activities.

To add an existing PC Supplier as a PCM Supplier in Web Client:

1. Assign the desired restricted Supplier role to the User.

2. Open the Supplier.

3. If you know the first name, last name, or user ID, enter it into the User ID field, which 
auto-completes as you type. Instead of using the auto-complete feature, you can search for 
the user and add it to the Supplier's Contact Users tab.

4. If applicable, on RFx Routing tab, select the user as the Default Recipient.

5. Under the Users Preferences - Display Preferences change Response Edit Mode to either 
Advanced Wizard Edit or Basic.

To add an existing user to a supplier in Web Client:

1. Open a supplier, and then click the Contact Users tab.

2. Click Add.

3. Search for an existing user by first name, last name, or username.

4. Add the user by double-clicking the row you want to add or by using the drag and drop 
feature.

Note: Power Users can be added to the Contact Users tab only if the 
Maximum Number of Contact Power Users field has been set to other than 
0 (or blank) on the General Info tab of the supplier. Otherwise, only users 
with a Restricted user license can be assigned to a supplier.

Note: If the Response Edit Mode is set to Basic, the user will not have 
access to PC related tasks.

Note: Power Users can be added to the Contact Users tab only if the 
Maximum Number of Contact Power Users field has been set to other than 
0 (or blank) on the General Info tab of the supplier. Otherwise, only users 
with a Restricted user license can be assigned to a supplier.
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Creating and Modifying RFx Routing Rules
The RFx Routing tab defines which supplier contacts are responsible for which RFQs. You can 
specify which supplier contact will respond to RFQs coming from a given ship-to location. 
These routing rules are geography-based.

When you specify a routing rule, you associate a supplier contact user with a geographic 
location. That contact user is then responsible for RFQs coming from ship-to locations in the 
specified geography. Geographies are defined as a Continent, Country, and Region. A rule can 
be specified broadly, by continent, or specific to a region.

When you create a supplier, the first contact user you add becomes the default RFQ recipient. 
The default recipient receives any RFQs that could not be routed based on a routing rule. You 
can change the default recipient at any time.

To add a new routing rule:

1. Open a supplier, and then click the RFx Routing tab.

2. Click Add. The Add Routing Rule dialog appears.

3. Select a user from the Contact drop-down list.

4. Specify the Geography by selecting the continent, country/area, and state/province/region 
to associate with the contact user.

5. Click Add.

To edit a rule:

1. Select the routing rule that you want to modify on the RFx Routing tab.

2. Make required changes by directly editing the fields within the table.

3. To save the changes that you made to the  RFx Routing tab, click Save. To undo the 
changes that you made to the RFx Routingtab while it was in edit mode, click Cancel.

To delete a rule:

1. Open a supplier, and then click the RFx Routing tab.

2. Select the routing rule that you want to delete.

3. Click Remove button.

To change the default recipient:

1. Open a supplier, and then click the General Info tab.

2. Click Edit.

3. Select the Default RFQ Recipient from the list of contact users.

4. Click Save.

Defining Manufacturer and Commodity Offerings
Each supplier can have different manufacturer and commodity offerings.

? Manufacturer offerings are used to map a manufacturer, whose goods a supplier carries, 
to a specific geographic location where those goods are available. This is a way for 
suppliers to indicate the manufacturers whose goods they are franchised to offer in certain 
geographic regions. For example, a supplier called ACME might sell Motorola and Kemet 
products.

? Commodity offerings define the product categories that a supplier sells. For example, a 
supplier called ACME might sell commodities such as fuses, integrated circuits, and 
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resistors. The commodity offerings map each commodity a supplier carries to a specific 
geographic location where those goods are available.

RFQs can be sent to suppliers based on the type of manufacturer or commodity offerings they 
have.

The ratings for manufacturer and commodity offerings also determine which suppliers receive 
RFQs. The out-of-box supplier ratings provided with Agile PLM are:

? Approved

? Strategic

? Offered Active

? Offered Inactive

Creating a New Manufacturer Offering
You can specify general information about the manufacturer offerings that you are creating 
from the Manufacturers tab. Each manufacturer line card definition is a unique combination of 
manufacturer, supplier, and ship-to locations. A supplier can have multiple lines for one 
manufacturer, each line associated with a different ship-to location. If there are changes to the 
geographic locations where the goods are offered, the supplier manager can edit the 
manufacturer line cards for the supplier organization.

If you choose to add a manufacturer offering by Geography, rather than Ship To location, an 
offering is only added if there is a Ship To location defined in that particular region.

For example, assume that the following are the only Ship To locations defined in the system:

? Santa Clara, CA, USA

? Los Angeles, CA, USA

? Bangalore, India, Asia

If a user uses the Geography option and selects San Jose, CA, USA as the geographical location, 
the system does not add any rows to the Manufacturers table, because there are no Ship To 
locations defined for that specific location. If the user selects CA, USA as the location, however, 
the Santa Clara, CA, USA and Los Angeles, CA, USA Ship To locations are added, because 
those locations are included in the broader region of CA, USA.

To create a manufacturer offering in the Web Client:

1. Open the supplier you want to work with, and click the Manufacturers tab.

2. Click Add.

3. For Manufacturers, click the search button to select one or more manufacturers. You can 
add manufacturers by using the drag and drop feature or by double-clicking the row of the 
manufacturer to be added.

Note: Agile PLM administrators can define additional supplier ratings. 
There is no implied order to the supplier ratings. When you disseminate an 
RFQ, you can select multiple supplier ratings.

Note: You can filter manufacturer and commodity offerings based on 
criteria that you specify, for example, to see only the offerings for a particular 
region.
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4. Select the appropriate option to base the offering on the geographic location or ship-to 
locations

5. Follow either step 5.a or 5.b, depending on the option you chose in the previous step.

a. If you selected Ship To option, click the button next to the Ship To field to select the 
locations.

b. If you selected the Geography option, click the button to select the geographical area.

6. Select a supplier rating (for example, Approved or Offered Active).

7. Click Add. The new manufacturer line card definition appears in the list.

Creating a New Commodity Offering
Before you can specify commodity offerings for a supplier, commodities must be defined in 
your Agile PLM system. See "Creating Commodities" on page 7-4.

From the Commodities tab of a supplier object, you can specify information about the 
commodity offerings for that supplier. Each commodity line card definition is a unique 
combination of commodity, supplier, and ship-to locations. A supplier can have multiple lines 
for one commodity, each line associated with a different ship-to location. If there are changes to 
the geographic locations where the goods are offered, the supplier manager can edit the 
commodity line cards for the supplier organization.

Similar to manufacturer offerings, if you choose to add a commodity offering by Geography, 
rather than Ship To location, an offering is only added if there is a Ship To location defined in 
that particular region. See the example in "Creating a New Manufacturer Offering" on 
page 7-12. for more information.

To create a commodity offering in Web Client:

1. Open the supplier you want to work with and select the Commodities tab.

2. Click Add.

3. For Commodities, click the search button to select one or more commodities. You can add 
commodities by using the drag and drop feature or by double-clicking the row of the 
commodity to be added.

4. Select the appropriate option to base the offering on the geographic location or ship-to 
locations

5. Follow either step 5.a or 5.b, depending on the option you chose in the previous step.

a. If you selected Ship To option, click the list button next to the Ship To field to select the 
locations.

b. If you selected the Geography option, click the list button to select the geographical 
area.

6. Select a supplier rating (for example, Approved or Offered Active).

7. Click Add. The new commodity line card definition appears in the list.

Updating Manufacturer and Commodity Ratings
Each line on the Manufacturers tab and the Commodities tab represents the combination of a 
supplier, manufacturer or commodity, ship-to locations, and ratings. You can change ratings one 
line at a time, or you can change multiple lines at once.

Note: You can rate the manufacturer or commodity offerings only when 
ship-to locations are specified and the type is Rating.
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To update manufacturer and commodity ratings in the Web Client:

1. Open the supplier you want to work with, and click the Commodities tab or 
Manufacturers tab.

2. Click in the Ratings column of the row that must be updated.

3. Select a new rating from the drop-down list.

4. If desired, select any other rows that need to have their rating similarly updated. Use the 
Fill-up/Fill-down options by clicking the More button.

Working with the PSRs Tab
The PSRs tab of a customer or supplier lists all product service requests reported by a 
customer. It can help gauge customer satisfaction with your products. This tab is read-only and 
is automatically completed whenever this customer is added to a PSR.

PSRs can be closed (promoted to their Complete type status) in the following ways:

? The Agile administrator can set up the system so that a problem report closes automatically 
when the related issue closes.

? The Agile administrator can set up the system so that a PSR (problem report or issue) 
closes automatically when the related PSR closes.

? An organization manager or supplier administrator with the appropriate privileges can 
manually close a PSR.

Refer to the Product Quality Management (PQM) User Guide for more details on PSRs, 
including initiating and managing PSRs.
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8Changes, Discussions, and Attachments

This chapter provides information about changes, discussions, and attachments as they relate to 
PCM.

Item and Response Changes
Sourcing projects serve as a knowledge repository of the items, BOMs, AMLs, RFQs, 
responses, and changes related to those objects. Changes to the items and responses in a project 
can be tracked on the Changes tab. You can view the changes made to the items and responses 
separately, and you can filter the data to view only items that have been added, deleted, or 
changed.

Changes to items and responses can be made in several ways:

? When new change orders (ECOs, MCOs, and SCOs) are released for Item Master items 
contained in the project. Until you update the project with information from the Item 
Master, these changes are Unapplied Changes.

? When you update the Quantity Per Assembly (QPA) for items with information from the 
Item Master. Other changes to item descriptions or flex fields are not recorded on the 
Changes tab.

? When you add, modify, or remove project items either manually or using the Import 
wizard.

? When suppliers submit RFQ responses.

To view unapplied item changes:

1. Open a project and select the Changes tab.

2. The default view of the Changes tab is the Unapplied Item Changes tab. All the 
unapplied changes like ECO, MCO, SCOs are listed in the table. Affected items for each 
change are listed in the Affected Item(s) column.

If for any reason, the manufacturing division changes the item content in a project for 
specific output, the changes are recorded in this view. You can link to the details of the 
ECO, MCO, or SCO. After viewing details of the change, you can decide whether to 
update the project with latest information from the Item Master.

To view item changes:

1. Open a project and select the Changes tab.

2. Click the Project Item Changes tab to view item changes. By default, the changes 
summary table and the added items are displayed. The Changes Summary table displays 
the number of changes made to the items in the project.
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3. Select Items Added, Items Deleted, or Items Modified from the Views drop-down list to 
view the added, changed, or deleted items in the project.

To view response changes:

1. Open a project and select the Changes tab.

2. Click the Supplier Response Changes tab to view response changes. The table displays 
response changes made in the project.

3. Click the item number to edit the project item information.

Discussions
When you are negotiating with your suppliers and customers, you often need to conduct 
informal, threaded dialogue to finalize the quotes, discuss issues related to your projects and 
RFQs, and to share other relevant information.

Discussions in Agile PLM replace the conventional email messaging service. Discussions have 
features similar to the email model, which has a subject line, message area, priorities you can 
specify, and a notification list. You can reply to discussions the way you reply to an email. The 
discussion is sent to the recipients as a notification in their inbox. Only Agile users can 
participate in discussions.

The Discussions tab lists information about each message, including the number of replies, the 
message, the creator, and the notification list.

Adding Discussions
You can add discussions about different subjects. For example, MMY Suppliers have recently 
started using Agile PLM, and you need to send project information along with a welcome letter. 
You can send the welcome letter through the project discussion. You can add any number of 
discussions in a project.

To create and add discussions:

1. Open the object, for example, sourcing project, and select the Discussions tab.

2. Click Add. A new row appears in the Discussions table.

3. Click the Create New button. The Create New dialog appears.

4. Select the type of discussion from the Discussion Type field.

5. Enter the subject in the Subject field.

6. Enter discussion text in the Message field.

7. Select the priority of the message from the Priority drop-down list.

8. Click the Address Book button next to the Notify List field, and select the names of 
recipients.

Note: You can view the item changes made in the project since the project 
was created.

Note: You can also add an existing discussion by clicking the Search icon 
and searching for it.
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9. Click Add. Users in the Notify List are sent a notification for the discussion.

Replying to Discussions
Replying to a discussion is similar to replying to an email. You can find the discussion 
notification in your Inbox. You must have the Discussion Participant role assigned to you to 
reply to a discussion.

You can access a discussion by clicking on the Discussion tab of the Agile PLM object, for 
example, RFQ, that is associated to the discussion. Alternatively, you can access the discussion 
from your Notifications inbox. From within your inbox, click the subject in the Regarding 
column to open the discussion.

To reply to discussions:

1. On the Discussion tab of the discussion object, click Reply. The Reply to Discussion 
dialog appears.

2. Enter the reply in the Message field.

3. To change the list of recipients, click the Address Book icon next to the Notify List field. 
Select the names of recipients.

4. Click Send.

Removing Discussions
You should be the owner of the project to remove a discussion from the project. If you have the 
(Restricted) Discussion Participant role, you can delete the individual messages, or replies, in a 
discussion.

To remove discussions:

1. Open the project, and click the Discussions tab.

2. Click the row selection cell for the discussion that you want to remove.

3. Click Remove.

Attachments
Attachments are electronic files that contain related information about a project, item, change, 
or other object. An attachment can be of any file type, such as a blueprint (a CAD diagram) of a 
mechanical device, the architecture explanation flowchart (an MS Word file), or a presentation 
file related to the object (.PPT, audio, or video). Agile supports viewing any type of file using 
AutoVue for Agile. You can either download it or view it from its own location.

The attachments added to the object are stored in a unique folder by default. You can add 
different versions of the same file and view the appropriate versions at any time.

You can reference the files and URLs related to a project on the Attachments tab of the project.

Attachment features are described in detail in Getting Started with Agile PLM. This section 
provides a brief summary of how you can use attachments in sourcing projects.

Note: You can send any number of replies in a discussion.

Note: When you delete a discussion, any replies are also deleted.
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Project Objects that Can Have Attachments
In addition to the project itself, the following objects contained within a project can have 
attachments:

? Items

? Manufacturer parts

? RFQs

Working with Attachments
You can attach most file types, but users viewing the file can open it only if the appropriate 
software is installed on their computers.

For example, if the file is a Microsoft® Excel (.XLS) file, you need to have Microsoft® Excel 
installed to view the file. The Attachments tab information shows the file description, name, 
version, type, and size, and the dates the file was modified and viewed.

For more details about working with attachments, see Getting Started with Agile PLM.

Viewing Attachments
You can either view a file attachment from Agile Web Client, or you can download it to your 
computer for viewing or editing.

To view an attachment in the AutoVue for Agile viewer:

1. Open the object for which you want to view an attachment.

2. Display the Attachments tab.

3. Select the row of the file that you want to view.

4. Click View > View. The file is opened in the AutoVue for Agile viewer.

To save the attachment:

1. Open the object for which you want to view an attachment.

2. Display the Attachments tab.

3. Click the Get button for the attachment you want to download. Use can choose to use the 
Java tool or the standard browser capabilities to download the file.

4. Save the file to the desired location.

For more information on working with attachments, see Getting Started with Agile PLM Guide.

Note: AutoVue for Agile viewer does not support all file types. An error 
appears if you attempt to view an unsupported file type.
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9Managing Price Information

This chapter provides information about managing price information.

About Contract Management
Contract Management is a key component of managing product costs. To effectively reduce the 
cost of products, you should be able to assess and leverage price and terms information as 
established throughout the organization. Agile PCM provides you with a single controlled 
process for doing this.

You can store information about prices for items. From the sourcing project, you can publish 
price information to the Item Master. Users in departments throughout the organization can 
access this information to use in finalizing the prices for an item or manufacturer part. You can 
share the new price information from one company with other companies as part of the process 
of finalizing prices.

For example, the price manager might get information from a supplier about a price change for 
a particular item (a new, reduced item price). The price manager changes the price information 
by creating a new price line, publishes it to the repository, and routes it through the workflow 
for signoff.

Price objects are created automatically when you perform the following actions in a sourcing 
project:

? Publish prices - By publishing prices from a project to the Item Master, you automatically 
create price objects associated with Item Master items and manufacturer parts. You can 
select which type of price objects to create, such as contracts, published prices, or quote 
histories. You can publish prices in Authoring or Redline mode; if you use Redline mode, 
you must specify a PCO. For more information about publishing prices, see "Publishing 
Prices for Items and Manufacturer Parts" on page 5-22.

? Lock or close an RFQ response line - When you lock or close a response line in an RFQ, 
you automatically create a snapshot of that quoted price by generating a Quote History 
object.

Additionally, you can manually create a price in for an item or manufacturer part in the Web 
Client. For more information, see "Creating Prices" on page 9-5.

Note: Whether Quote Histories are created automatically depends on how 
the SmartRule called Auto Publish Quote History is configured. If the 
SmartRule is set to Disallow, Quote Histories are not automatically created 
when you lock or close an RFQ response line. For more information about 
SmartRules, see the Agile PLM Administrator Guide.
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Pricing Overview
This section covers the following topics:

? Objects in Price Routines

? Associated Roles and Privileges

? Price Types

Objects in Price Routines
A price routine is the flow of the price information of any item or manufacturer part. Pricing 
information is provided by the supplier. You can publish this information to the respective item 
or manufacturer part. A price routine involves:

? Prices

? Price Lines

? Price Change Orders (PCOs)

Prices
The Price is an object where you record the price and terms conditions of items and 
manufacturer parts with relation to the supplier, customer, program, and manufacturing site. 
You create prices for items or manufacturer parts. The uniqueness of a price is controlled by the 
item/manufacturer part number and item revision number (if applicable) combined with the 
supplier, customer, program, and the manufacturing site.

A price is a routable object, so it follows a workflow through price change orders. A price 
object can have multiple price lines. You can add it to any PCO without having to create a 
PCO.

The Price objects have certain limitations:

? A price object can have only one pending PCO. You cannot create PCOs for a price object 
when a PCO for the same price object already exists and is pending.

? A price line cannot be added to a price object that already has a pending PCO.

? The (Restricted) Price Collaborator role is intended for supplier users. Price Collaborators 
can create published prices and PCOs for their items and manufacturing parts only.

Price Lines
Price lines contain the core price information about an item or manufacturer part, which is 
unique by quantity, Ship To location, and Effectivity Period. You can create any number of 
price lines within a price object, but they should be uniquely identified. Price lines share the 
general information that defines the price object.

Price lines have certain limitations:

? Users with the Price Administrator or Price Manager role can create price lines, since they 
are also responsible for creating prices.

? Price collaborators can create price lines for their items and manufacturing parts only.

Note: Price Collaborators can only create prices for only their suppliers.
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Price Change Orders (PCOs)
A Price Change Order, or PCO, is a process for revising, or deleting, the price information 
about an object. A PCO follows a workflow from the Preliminary through the Signoff phase. A 
PCO can have multiple Price objects, and a price can be added to any existing PCO. You can 
use a PCO to redline the price line information of any price object.

For more information about PCOs, see "Price Change Orders" on page 10-1.

Associated Roles and Privileges
You can control price information for items in Agile PCM through three important roles. The 
privileges for these roles are assigned by the Agile administrator.

The Contract Management related roles are:

? (Restricted) Price Collaborator - Users with this role have limited privileges for 
managing pricing information through price and price change order creation. This role is 
typically provided to suppliers.

? Price Administrator - Users with this role have privileges allowing them to control 
contract management activities, including the price change order process. Users with this 
role are also called as Approvers. They have the privilege to review and release PCOs.

? Price Manager - Users with this role have privileges for managing pricing information 
through price and price change order creation. These users cannot review or release PCOs, 
and so they are not the approvers of PCOs.

Price Types
The Price base class is divided into two classes, Quote Histories and Published Prices. These 
classes are further divided into the following three subclasses:

? Contract - This is a subclass of the Published Prices class. Contract prices are prices 
provided by the supplier for a specific item or manufacturer part. This price information 
applies only for the specified duration and can apply to any project.

? Published Price - This is a subclass of the Published Prices class. Published prices are 
prices provided by the suppliers in response to an RFQ and published from the project. The 
published price information can also be used in other projects.

? Quote History - This is a subclass of the Quote Histories class. Quote history prices are 
the stored prices from supplier responses that you can use. Any change in the response line 
of an RFQ is stored in the historical response and is usable at any time.

Note the following points about price types:

? An item cannot have more than one price of the same type subclass with the same unique 
keys, such as supplier, customer, and program.

? Only prices of type contract and published price can be changed using a PCO.

? To create additional price types, the Price base class can be subclassed further into 
additional classes. Your Agile administrator can create multiple price types to group 
different prices according to business logic.

Managing Price Information
Managing price information is a critical task for any organization. The price administrator 
should closely follow the pricing information about items and update it in the Item Master.

This section covers the following topics:
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? Accessing Price Information

? Creating Prices

? Price Page Tabs

Accessing Price Information
Each item or manufacturer part has associated price information. Any number of price objects 
can be created for an item, and any number of price lines, which are identified by their unique 
combinations of ship-to location, ship-from location, quantity, and effectivity period, can be 
created in a price object. The Prices tab of an item or manufacturer part lists all prices for that 
item or part.

To access the price information for an item:

1. Open an item and select the Prices tab. The prices, if any, are displayed.

2. Click the Price Number in a row. It opens a General Information page of the Price. Go to 
Price Lines tab to view more details.

Price Fields
By default, the General Info tab of a price contains the fields listed in the following table. 
Agile administrators can add custom class and subclass fields to the General Info tab.

Field Description

Item Number (or Mfr. Part Number) Identification number of the item or manufacturer 
part.

Mfr. Name (if price is for Mfr. Part) Name of the manufacturer who makes the part.

Item Rev (if price is for an Item) Revision number of the part.

Note: This field is displayed, even if the user does 
not have privileges to read the item itself.

Supplier Supplier who submitted the price for the item or 
manufacturer part, or the supplier for which a 
price is created.

Price Type Type can be Quote History, Published Price, 
Contract, or a customized price subclass.

Number Unique identification number for the price.

Description Brief description of the price terms.

Lifecycle Phase Current state in the price object workflow.

Owner By default, the user who created the price. The 
ownership of a price can be transferred to another 
user who has the same privileges.

Customer If a Customer is selected, the price will only 
apply to that customer.

Program If a Program is selected, the price will only apply 
to that program.

Manufacturing Site Location in which the item or part is 
manufactured.

Authorized Suppliers Suppliers other than the primary supplier who are 
authorized to use this price. Authorized suppliers 
have the same viewing privileges as the primary 
supplier for the price.
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Creating Prices
Agile PCM creates prices automatically when you publish prices from a project to the Item 
Master or when you lock or close an RFQ response line, if the Auto Publish Quote History 
SmartRule is set to "Allow".

You can also use the Price Creation dialog to create prices for items and manufacturer parts.

To create a price for an item or manufacturer part:

1. Open the item or manufacturer part.

2. Click Actions > Create New > Price. The Create New dialog appears.

3. Select a price type from the Type drop-down list. Once you select a price type, additional 
fields appear on the page.

4. A unique, system-generated number may automatically be filled in the Number field by the 
Price Type you selected. You may also be able to modify this number, give one of your 
own or click the AutoNumber icon to generate a new number.

Part EOL Date End of life date for the part or item, as given by 
the supplier.

Min Minimum quantity that should be ordered from 
the supplier

Mult Number of units in a package

NCNR Non-Cancelable Non-Returnable. Applies to an 
item. NCNR can be Yes or No, depending on the 
supplier.

Inventory Available stock.

Version Version of the price. A new version of a price is 
created when that price is part of PCO that was 
released.

Version Release Date Version release date.

Effectivity Date Date the price goes into effect.

Allow Qty Breaks Whether to allow quantity breaks for the 
manufacturer part or item at the given price. Can 
be Yes or No.

Contract Number Number of a contract or document supplier by the 
supplier.

Functional Team(s) Group(s) of users and/or user groups who work as 
a team while performing specific job functions.

Note: To create prices, you must have the Create privilege for price objects. 
Agile provides two roles that let users create prices - Price Administrator and 
Price Manager. On the supplier side, the same privileges are available 
through the Restricted Price Collaborator role.

Note: Alternatively, you can choose to create a price using the Create New 
button in the top menu bar.

Field Description
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5. Select the Part Type, for example, Item or Manufacturer Part, from the drop-down list.

6. Type in the Item or Manufacturer Part or click the Search icon to search and select an 
item or manufacturer part from the search palette.

7. If you had selected Item from the Part Type list, select the revision from the Rev 
drop-down list.

8. If you had selected Manufacturer Part from the Part Type list, select the Manufacturing 
Site from the drop-down list.

If a manufacturing site is selected, the item price information applies to the items or 
manufacturer parts manufactured only at that site. If the field is left blank, the price 
information applies to the item or manufacturer part regardless of their manufacturing site.

9. Type in the supplier or click the Search icon to search and select Suppliers through 
Suppliers search palette.

10. Select a Program from its drop-down list.

If a program is selected, the item price information applies only to that program. If All is 
selected, then the item price information applies to all programs.

11. Select a Customer from its drop-down list.

If a customer is selected, the item price information applies only to that customer. If All is 
selected, the item price information applies to all the customers.

12. Click Save. The new price's cover page appears in edit mode.

13. To add a new price line, go to the Price Lines tab. For more information about adding price 
lines, see "Creating Price Lines" on page 9-7.

14. To add a new attachment, go to the Attachments tab. For information about adding 
attachments, see Getting Started with Agile PLM.

Note: Auto-numbering settings, such as the automatic generation of an 
AutoNumber, are set by the Agile administrator. These settings can limit the 
options you have for the Number field. See the Agile PLM Administrator 
Guide for more information.

Note: The Part Type and Item or Manufacturer Part fields are automatically 
filled in if you create the price from within an item or manufacturer part.

Note: As you type in the item/manufacturer part, if there are multiple 
entries that match what you have typed so far, a drop-down list appears from 
which you can select a value.

Note: As you type in the item/manufacturer part, if there are multiple 
entries that match what you have typed so far, a drop-down list appears from 
which you can select a value.
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Price Page Tabs
The tabs on the Price page store information about price and term attributes. Attachments and 
change orders related to the price can also be found on the Price page tabs. The following table 
describes each tab on the Price page.

Managing Price Lines
Price lines contain unique price information about the item. Price lines store information about 
prices and terms that apply to specific quantity breaks.

You can change price lines after they are published through price change orders (PCOs).  
However, you can also redline price information, which is sent for review and release before 
you use the changed information. For more information about redlining, see "Redlining Price 
Information" on page 10-4.

You can see price line information on the Price Lines tab of the price object. The price line 
information is created or modified in the Add Price Line dialog.

Creating Price Lines
You create price lines from the Price Lines tab of a price.

General Information This tab displays basic information about the price, including information 
controlled by the workflow, item and manufacturer part attributes, and 
supplier-supplied information. Click Edit to edit the information on this tab.

Changes This tab displays pending and historical changes that affect the price. Any 
unreleased price change orders (PCOs) where this price is listed on the 
Affected Prices tab are listed in the Pending Changes table. The Change 
History table displays any released PCOs where this price is listed on the 
Affected Prices tab. Agile PCM automatically fills in the information on 
this tab.

The changes listed are those that apply to the revision specified in the Rev 
field at the top of the page.

Note Although its name is similar, the History tab shows all actions taken 
on a price, while the Change History table on the Changes tab lists released 
and canceled changes for the price. The Changes tab is not displayed if the 
price type is Quote History.

Price Lines A price line is a unique combination of ship-to location, ship-from location, 
effective-from date, effective-to date, and quantity that applies to a price. A 
price can have multiple price lines, based on specific contexts.

Overlapping price lines can occur when all or some effectivity periods of 
one price line fall within the effectivity periods of a second price line, and 
all other attributes are the same. Check with your Agile administrator to 
determine if overlapping price lines have been set as allowed using 
SmartRules.

Attachments This tab lists the files and URLs attached to the price. For more 
information, see Getting Started with Agile PLM.

History This tab shows a summary of actions taken on the price object. History 
records are not captured for preliminary prices.

Note: Users with the Price Administrator and Price Manager roles can 
create price lines for any item or manufacturer part. Users with the Price 
Collaborator role can create price lines only for items or manufacturer parts 
they supply.
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To add price lines:

1. Open a price object and go to Price Lines tab.

2. Click Add. The Add Price Line dialog appears.

3. Enter the mandatory fields:

1. Select the Ship To locations from its drop-down list.

2. Select a date from the Price Effective From Date calendar.

3. Enter Quantity for which the price line information applies in the Qty field.

4. Select the supplier currency from the Currency Code drop-down list.

4. Enter the optional data:

1. Change the currency conversion date, if necessary, in the Conversion Date calendar.

2. Enter the material price per unit in the Material Price field.

3. Enter the non-recurring cost in the Non Recurring Cost field.

4. Enter the lead time for supply in the Lead Time field.

5. Select the Transportation Terms from the drop-down list.

6. Select the Country of Origin of the item from the drop-down list.

7. Enter any comments or additional information in the Price Line Notes field.

5. Click Finish.

Modifying Price Lines
You can modify the price line information on the Price Lines tab.

To modify the price line information:

1. Open a price object and go to Price Lines tab.

2. Edit the price line information in the Price Line table by directly editing the field.

3. Click Save.

Removing Price Line Information
You can remove price line information from the Price Lines tab.

To remove the price line information:

1. Open a price object and go to Price Lines tab.

2. Select the row(s) of the price lines(s) you want to remove.

3. Click Remove.

Note: Overlapping effectivity periods for a price line are allowed if the 
SmartRule, Allow Overlapping Price Effectivity Periods, is enabled.

Note: Any flex fields that have been enabled will also be displayed.
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Importing Price Lines
You can import the Price Lines from the responses submitted in an Excel workbook. The 
responses in a workbook belong to a particular Price object. When you import them, the system 
appends the associated price objects, and not elsewhere.

For complete details on import process, see AgileImport/Export Guide.

Note: The number of price lines that can be imported in a single import 
process depends upon the system/server configuration. See Capacity 
Planning Guide for more on server sizing.

Important: If the number of price lines is high, Agile recommends you to 
split them into multiple Excel workbooks for import. In the Authoring mode, 
each workbook should not exceed 5000 price lines, and in the Redlining 
mode, it should be less than 1000.
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10Price Change Orders

This chapter provides information about working with price change orders (PCOs).

About Price Change Orders
You control any changes that need to be made to prices through a price change order (PCO). 
PCOs are routed through workflows, from the Pending phase through the Released phase. 
Through a PCO, you can release a price, redline the price information, and track the history of 
the price information.

You create PCOs for price objects only. A PCO can contain multiple prices that can be 
associated with different items, but a price be associated with more than one pending PCO.

Managing PCOs
Price change orders control changes to the prices of items or manufacturer parts. The price 
administrator can create PCOs, and the price collaborators can publish the prices of items from 
the response lines of RFQs.

This section covers the following topics:

? Creating PCOs

? Adding Price Objects to PCOs

? Workflows

? Adding Objects to the Relationships Tab

Creating PCOs
You can create PCOs from prices or from the Create New menu on the main menu bar. When 
you create a PCO from the Actions menu of a price, the price is associated with the PCO by 
default. When you create the PCO from the Create New menu, you must associate the price 
with the PCO manually.

To create a PCO from the Create New menu:

1. Click Create New > Changes > Price Change Orders. The Create New Price Change 
Orders dialog appears.

2. Select the Type of PCO from the drop-down list.

3. A unique, system generated number may automatically be filled in the Number field on 
the basis of Price Type you selected. You may also be able to modify this number, give one 
of your own or click the AutoNumber button to generate a new number.
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4. Click Save. The cover page of the newly created PCO appears.

5. Select a category from the Change Category drop-down list.

6. Enter the Description of Change and the Reason for Change in the corresponding fields.

7. Select a Reason Code, Workflow, and Price Admin from the corresponding drop-down 
lists.

8. Click the Address Book button next to the Originator. It opens a search palette to find and 
select an originator from the list of users. By default, the originator is the user who creates 
the PCO.

9. Change the Date Originated using the calendar to stamp the date of origination of the 
PCO, if it is different from today's date.

10. Click the list button next to the Product Lines to select the affected product lines.

11. Click Save. The updated cover page appears.

Add affected prices or attachments to the PCO by clicking on the corresponding tabs.

To create a PCO from a Price object:

1. Open a Price object.

2. Choose Actions > Add to Change > Create New. The Create Changes window appears.

3. Select a PCO from the Change Type drop-down list.

4. Click the AutoNumber button to have a system-generated unique number inserted in the 
Number field. You can also choose to enter in your own unique number.

5. Click Save.

6. To add details to the newly created PCO, follow steps 4 through 11 from the preceding 
procedure, To create a PCO from the Create New menu.

Cover Page Tab
This tab displays general information about the PCO, including the unique identification 
number of the PCO, the current workflow status of the PCO, the description of the change, and 
the reason for the change.

You can edit the Cover Page tab by clicking the Edit button.

Affected Prices Tab
The Affected Prices tab displays information about the prices associated with the PCO. You can 
make changes to the price information through redlining. You can see the history of the 
redlined information on this tab.

Note: Auto-numbering settings, such as the automatic generation of an 
AutoNumber, are set by the Agile administrator. These settings can limit the 
options you have for the Number field. See the Agile PLM Administrator 
Guide for more information.

Note: Your Agile administrator may have modified the way that the 
Number of a PCO is set. AutoNumbers may not be available or it may be 
required. Check with your administrator for more information.
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You can click the Price Number in the table to view the price information.

You can redline price information on this tab. For information about redlining, see "Redlining 
Price Information" on page 10-4.

Adding Price Objects to PCOs
You can add any number of price objects to a PCO, but a price object can be associated with 
only one pending PCO. Once a price is published, you must create a PCO to make even a small 
change in the price information.

You can add an existing price to the PCO. Alternatively, you can create a price for any item or 
manufacturer part and add it to the PCO. You can also create price lines for the item or 
manufacturer part, but this is not required.

To add existing prices to a PCO:

1. Open a PCO and select the Affected Prices tab.

2. Click Add. A new row appears with an editable Price Number field.

3. Type in the Price Number directly or search for it by clicking the Search icon. For 
information about searching for Agile objects, see Getting Started with Agile PLM. 
Alternatively, you can create a price object, if needed, by clicking the Create New icon.

If you try to add a price object that already has a pending PCO, the attempt to add fails and an 
error message appears.

Applying the Effective Date
You can apply the effective date of the price using the Auto Populate Effective Date dialog.

To apply the effective date:

1. In the Affected Prices tab of a price object, select the row(s) of the price rows in the table.

2. Click Auto Populate Effective Date. The Auto Populate Effective Date dialog appears.

3. Select the date from the Enter a Date calendar.

4. Check Apply to All Items to apply the selected date to all the selected price objects.

5. Click Set Date.

Workflows

Figure 10–1 Sample Workflow
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The Workflow tab displays information about the workflow of the PCO in the form of a 
flowchart. A PCO begins in the Unassigned phase and ends in the Released phase. The price 
information in the PCO takes effect when the PCO reaches the Released phase. However, the 
PCO can be canceled or put on hold during any phase.

A user with the appropriate role submits the PCO and forwards it to the next phase by notifying 
the price reviewer. The price reviewer receives the notification, reviews the price information, 
makes any necessary modifications, and then notifies approvers, observers, and acknowledgers. 
They review the price information sent by the price reviewer, make any necessary changes, and 
pass it on to the next stage for implementation.

You can view sign off history and the workflow diagram for the PCO in the Workflow tab.

Only price administrators, who are also approvers, can approve or reject a PCO. Observers are 
those who analyze the PCO and give their comments. Acknowledgers are those who need to be 
aware of the change. Notifications regarding the PCO can be sent to other users such as 
suppliers and customers.

Functional teams help determine which users should be used as approvers, acknowledgers, and 
observers. You can add or remove approvers, acknowledgers, and observers by clicking Add 
Reviewers or Remove Reviewers. The reviewers can approve, acknowledge, or reject the PCO 
by clicking the Approve, Acknowledge, or Reject buttons.

The workflow may have multiple phases depending on your requirements. The Agile 
administrator can customize the workflow. For more information about workflows, including 
functional teams, see Getting Started with Agile PLM.

Adding Relationships
In the Relationships tab, you can add the information about objects that affect the PCO status 
and add Rules to those objects. You can add multiple objects but objects in their Released state 
cannot be added to either table.

To relate existing objects to a PCO:

1. Open a PCO and select the Relationships tab.

2. Click Add > Search. The search window appears.

3. Search for and select object(s). Drag and drop (or double-click) objects you want to add 
into the Relationships table.

Applying Relationship Rules
Once you have added relationship objects, you can select them one by one and add their 
relationship rules.

Redlining Price Information
You can publish price information to the Item Master in two modes-Authoring and Redlining.

? Authoring mode enables you to publish price information directly to the Item Master. You 
can publish prices in Authoring mode from the Analysis tab of a sourcing project and from 
the Response tab in an RFQ. In Authoring mode, changes do not go through an approval 
process.

? Redlining mode keeps track of all the previous price information. You redline price 
information when you want to make changes to the published information, but want to go 

Note: Actions are not captured on the History tab for unassigned PCOs.
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through an approval process. You use PCOs to deal with changes to prices that have been 
published. A PCO contains multiple price objects, which in turn contain multiple price 
lines. You can redline the price line information of any price object in the PCO.

You can also add price lines to the price object or delete them in Redline mode. Adding price 
lines in Redline mode is similar to adding price line information to the price object.

Price managers submit the redlined price information to price administrators to approve (Price 
Review stage) and release. The price administrators review the redlined price information and 
release the PCO with or without the changes.

To redline price lines:

1. Open a PCO and select the Affected Prices tab.

2. In the Affected Prices table, select the row of the price that must be redlined. The price 
lines for that price are displayed in the Redlines table below.

3. In the Redlines table, click Add. The Add Price Line dialog appears.

4. Edit information as required.

5. Click Finish. The newly added price line appears in the Redlines table in red.

Deleting Price Lines in Redlining Mode
You can delete a price line and send it for price review. The approvers can accept or reject the 
deletion.

To delete the price line in Redlining mode:

1. Open a PCO and select Affected Prices tab.

2. In the Affected Prices table, select the row of the price that has a price line that must be 
removed. The price lines for the selected price are displayed in the Redlines table below.

3. In the Redlines table, select the row of the price line that must be removed.

4. Click Remove.

The system keeps the deleted price line in the table, but strikes it through with a red line. You 
can undo the "deletion" by selecting the row and clicking the Undo Redlines button.

Note: You can view the original information as it was originally published 
from the redline dialog by selecting the price lines and clicking the Undo 
Redlines button.
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APCM Use Cases

There are four main use cases for PCM functionality. They are as follows:

? New Product Introduction (NPI) or New Product Development (NPD)

? Reprice Management

? Electronics Manufacturing Services

? Commodity Management

New Product Introduction
The New Product Introduction/Development (NPI/NPD) process consists of all the work an 
organization puts into preparing a new product for the market. This process includes the 
development, prototyping, and manufacturing of the product. Normally there are four phases in 
this process: physical design, prototype manufacture, pre-production, and volume ramp. You 
can use PCM during the NPI process to gather pricing information for the new product.

In the NPI use case, the general procedure is as follows:

? Design product in Product Collaboration (PC).

? Determine parts and add them to PC.

? Create sourcing project.

? Add BOM to sourcing project.

? Send sourcing project to suppliers through RFQ.

? Get prices at part level.

? Negotiate prices.

? Publish prices to PC.

Reprice Management
Reprice management is a common PCM use case that enables you to refresh prices, as needed. 
Prices change for many reasons, including:

? environmental variables

? market

? demand

? sales

? time
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? quantity

During price refreshes, PCM helps maintain BOM accuracy across a multitier network of 
manufacturing partners and suppliers. It allows for efficient renegotiation and resetting of 
prices.

In the Reprice Management use case, the general procedure is as follows:

1. Create sourcing project.

2. Add BOM to sourcing project.

3. Do price lookup for existing published prices for BOM items.

4. Send sourcing project to suppliers through RFQ.

5. Get prices at part level.

6. Negotiate prices.

7. Publish prices to PC.

Design for Cost and Supply
Electronic Manufacturing Services (EMS) is a term used for companies that design, test, 
manufacture, distribute, and provide return/repair services for electronic components and 
assemblies for Original Equipment Manufacturers (OEM). PCM allows an EMS company to 
start with PCM and work with design partners to design and build a BOM.

In the EMS use case, the general procedure is as follows:

1. Start with top-level idea or design with some minimal part requirements.

2. Collaborate with design partner to design a product and build its BOM.

3. Create sourcing project.

4. Add BOM to sourcing project.

5. Send sourcing project to suppliers through RFQ.

6. Get prices at part level.

7. Negotiate prices.

8. Publish prices to PC.

Note: Usually, the RFQ is sent to the suppliers that were used previously, 
however, sometimes the RFQ is sent to additional suppliers for new quotes. 
This is often the case when there is a top-level mandate for price reduction.

Note: For example, you may know that you want to use a specific part, but 
have not determined the rest of the BOM items.

Note: Partners are often provided the Content BOM view in the RFQ, 
which allows them to see the complete, expanded BOM view
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Commodity Management
A commodity is a good, such as a resistor or diode, for which there is demand, but which is 
supplied without qualitative differentiation across a market. The manufacturer of commodity 
goods is not considered to be very important, since the commodity is similar regardless of who 
produces it. Commodity management is the process of developing a systematic approach to the 
entire usage cycle for a group of items. PCM enables you to consolidate commodity sourcing 
and reduce commodity prices.

In this use case, the general procedure is as follows:

1. Commodity manager is informed of a commodity that is needed.

2. They check where the part is used in other BOMs and then uses a sales tool to see future 
demand forecasts.

3. Based on the forecasts, the commodity manager creates a sourcing project for the target 
amount of the commodity.

4. Add commodity part group to sourcing project.

5. Send sourcing project to suppliers through RFQ.

6. Get prices at part level.

7. Negotiate prices.

8. Publish prices to PC.

Note: You may choose not to publish the prices to PC and instead keep the 
prices in the sourcing project. This is often done with manufacturer BOMs.
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BConfiguring Product Cost Management

This section provides information about nodes in the Product Cost Management folder under 
System Settings.

Product Cost Management Configuration Checklist
Use the following checklist to configure Agile PLM server settings for Product Cost 
Management:

? Define your company profile - Specify the name, address, phone number, URL, and the 
corporate currency for your company. For more information, see the Agile PLM 
Administrator Guide.

? Define currency exchange rates - Suppliers may quote prices in different currencies. You 
must maintain a table of currency exchange rates so that you can view normalized prices 
that have been converted to the project currency. For more information, see the Agile PLM 
Administrator Guide.

? Define your company's Ship To locations - Ship To locations are essential to take 
advantage of Product Cost Management features. For more information, see "Ship To 
Location" on page B-2.

? Configure SmartRules - Make sure you properly configure SmartRules related to price 
fields, effectivity periods, automatic publishing of quote histories, and commodities. For 
more information, see the "Configuring SmartRules For PCM" on page B-3.

? Configure the Product Cost Management class - Configure the Agile PLM classes for 
Product Cost Management. For more information, see "Configuring Product Cost 
Management Classes" on page B-7.

? Configure the Sourcing Projects class - There are several things you can do to customize 
the Sourcing Projects class, which affects all of its subclasses. For example, you can enable 
flex fields on different tabs, configure AML tab attributes to pull values from other Item 
and Manufacturer Part attributes, and define price adders and non-material price fields for 
RFQ responses. For more information, see "Configuring Product Cost Management 
Classes" on page B-7.

? Define Suppliers - Define the suppliers with whom sourcing project managers and RFQ 
managers will be working. This may be the responsibility of another user, someone with 
the Organization Manager role. For more information about creating and managing 
suppliers, see Getting Started with Agile PLM.

Note: Separately, supplier managers should define the contact users and 
line cards for their particular suppliers. Supplier users have restricted access 
to Product Cost Management functionality.
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? Define Supplier Offering Ratings - In the Agile PLM List Library, there is a list called 
Supplier Offering Rating, which is used to rate each supplier offering. You can customize 
the list of ratings. By default, the ratings are Approved, Strategic, Offered Active, and 
Offered Inactive. For more information, see the Agile PLM Administrator Guide.

? Define Product Cost Management Users and Roles - Define the users who will create 
and manage sourcing projects, RFQs, and prices. Assign those users appropriate roles, such 
as Sourcing Administrator, Sourcing Project Manager, RFQ Manager, and Price 
Administrator. For more information, see "Product Cost Management Roles" on page B-3. 
Make sure every user who will create sourcing projects has at least one authorized Ship To 
location. Otherwise, the user will not be able to move a project from Draft to Open status. 
For more information about the available PCM roles, see the Agile PLM Administrator 
Guide.

? Configure Administrator Privilege - To see the RFQ Terms and Conditions node on the 
Admin tab in Java Client, you must configure the Administrator privilege. This is covered 
in "Configuring the RFQ Terms and Conditions Node" on page B-4.

? Define new subclasses of the Sourcing Projects class - Agile PLM provides one subclass 
of the Sourcing Projects class called Sourcing Project, but you can extend Sourcing 
Projects and define any number of subclasses for specific types of projects. For more 
information, see the Agile PLM Administrator Guide.

? Configure BOM Filters - To use the BOM filtering feature in PCM, you must create and 
configure certain attributes in Data & Workflow Settings > Classes > Parts. For more 
information about how to use this feature after it is set up, see "Configuring BOM Filters" 
on page B-20.

? Establish Relationships between Objects - For information about how to establish 
relationships between fields, refer to Getting Started with Agile PLM, "Working with 
Business Objects" chapter.

? Define Preferences for Price - For information, see, "Configuring Preferences for PCM" 
on page B-22.

Ship To Location
Ship To locations are important for differentiating sourcing projects and for disseminating 
requests for quotes (RFQs) to suppliers.

To add a Ship To location:

1. Under System Settings > Product Cost Manageent, double click Ship To Location. The 
Ship To Locations window opens.

2. Click New icon. The Create Ship To Location dialog box appears.

3. Type the name and location code of the new Ship To location. Fill in other fields as needed.

4. Click OK. The new Ship To location appears on the list.

Note: Sourcing project managers must have at least one Ship To location 
defined in their user profiles. Otherwise, the projects they create cannot be 
opened. Similarly, each sourcing project must have a specified Ship To 
location. A project's Ship To location determines how RFQs are disseminated 
to suppliers based on their line cards.
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Configuring SmartRules For PCM
The following are PCM-specific SmartRules:

? Negative Value For Material Price Adder Fields - See "Applying Price Adders to 
Responses" on page 5-18.

? Zero Value For Material Price Adder Fields - See "Applying Price Adders to Responses" 
on page 5-18.

? Negative Value For Material Price Fields

? Zero Value For Material Price Fields

? Negative Value For Non-Material Price Fields

? Zero Value For Non-Material Price Fields

? DuplicateItemNumbers - See "Adding Items to a Project" on page 2-15.

? Auto Publish Quote History

See the Agile PLM Administrator Guide for more details about SmartRules.

Product Cost Management Roles
Agile PLM provides pre-defined roles that you can assign to Product Cost Management users. 
These roles grant users the privileges to work with sourcing projects, RFQs, prices, discussions, 
suppliers, customers, and PCOs.

Roles with names that start with the prefix (Restricted) are intended for Suppliers. For a 
complete list of the predefined Agile PLM roles, see the Agile PLM Administrator Guide.

RFQ Terms and Conditions
You can limit a supplier's access to an RFQ until they electronically agree to RFQ Terms and 
Conditions that you specify in Java Client. The RFQ Terms and Conditions node must be 
enabled in Java Client, then you can set and store the content of the Terms and Conditions page.

To use the RFQ Terms and Conditions feature, you will need to complete several tasks.

Tasks to Enable RFQ Terms and Conditions:

1. Enable the RFQ Terms and Conditions node in Java Client. For a detailed description of 
this task, see "Configuring the RFQ Terms and Conditions Node" on page B-4.

Note: When a Ship To Location is being used (referenced to) in any 
Sourcing Project, be the project in Draft or Open stage, it cannot be deleted in 
Java Client. When you attempt deleting, system issues a warning message 
"Fail to delete Ship To; one of the Ship To(s) is referenced to other objects".

Note: Although the Agile PLM administrator may not have assigned you 
the privileges needed to work with a sourcing project, other users with access 
to a project can share them with you, thereby granting you the same 
privileges that apply to the project and all the objects contained within it. 
However, you cannot access other projects that are not shared with you.
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2. Set up and enter the content of the RFQ Terms and Conditions that you want the supplier 
to read and accept. For a detailed description of this task, see "Setting and Storing the RFQ 
Terms & Conditions Content" on page B-5.

3. Make the Require RFQ Terms and Conditions attribute visible in the Sourcing Project 
class. For a detailed description of this task, see "Making the Attribute visible in Sourcing 
Project class" on page B-5.

4. Make the Require RFQ Terms and Conditions attribute visible in the Requests for 
Quotes class. For a detailed description of this task, see "Making the Attribute Visible in 
Requests for Quote Class" on page B-5.

5. Update Modify My Sourcing Project General Info privilege to include Applied To field 
value: Sourcing Projects.Sourcing Project.Require RFQ Terms and Conditions. For a 
detailed description of this task, see "Adding criteria to Modify My Sourcing Project 
privilege" on page B-6.

6. Update Read RFQs privilege to include Applied To field value: Requests for 
Quote.RFQHeader.Require RFQ Terms and Conditions. For a detailed description of this 
task, "Adding Criteria to Read RFQs Privilege in Sourcing Project Manager Role" on 
page B-6.

7. Update Read RFQs privilege to include the following Applied To field values: Status 
Accept Date, Status Accept User, Status Status, and Status Supplier. For a detailed 
description of this task, see "Adding Criteria to Read Privilege" on page B-7.

Configuring the RFQ Terms and Conditions Node
To see RFQ Terms and Conditions node in Java Client, you must configure the user's 
Administrator privilege. By default, it is disabled.

For more information about the Administrator Privilege, and how Administrator nodes are 
made available to a user, see the Agile PLM Administrator Guide.

Configuring the Administrator Privilege:

1. Go to Settings > User Settings > Privileges.

2. Double-click Administrator privilege key to open the Administrator window.

3. Select Show All in the Match If drop-down list and click Apply.

4. Double-click the Administrator privilege line. The Privilege:Administrator window 
opens.

5. Click the Arrow button in the Applied To field.

6. Select the RFQ Terms and Conditions option in the choices list and move it to the Selected 
list. Click OK.

7. Make sure the Enabled field is set to Yes.

8. Click Save and Close.

9. Close the Privileges for Administrator window.

10. Log out of Java Client and log back in. You should see RFQ Terms and Conditions node 
under Settings > System Settings > Product Cost Management.

Note: Optionally, you can make Terms mandatory at the project level.
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Setting and Storing the RFQ Terms & Conditions Content
After you have enabled the RFQ Terms & Conditions node, you can set and store the content.

Create RFQ Terms & Conditions Content:

1. Under Settings, expand System Settings node, and then the Product Cost Management 
node.

2. Double-click RFQ Terms and Conditions. The RFQ Terms and Conditions window 
appears.

3. Enter the content for your RFQ's Terms and Conditions in the text field.

4. Click Save followed by Close.

Making the Attribute visible in Sourcing Project class
You must make the Require RFQ Terms and Conditions attribute visible in the Sourcing 
Project class General Information tab.

To make the attribute visible:

1. Double-click the Settings > Data Settings > Classes.

2. Double-click the Sourcing Projects class.

3. Double-click the General Information in User Interface Tabs tab.

4. Go to Attributes: General Information tab and double-click Require RFQ Terms and 
Conditions.

5. Select Yes in the Visible field.

6. Click Save followed by Close.

To enable the attribute for search:

1. Double-click Settings > Data Settings > Classes.

2. Double-click Sourcing Projects class.

3. Double-click General Information in User Interface Tabs tab.

4. Go to Attributes: General Information tab and double-click Require RFQ Terms and 
Conditions.

5. Select Yes in Enable for Search Criteria.

6. Click Save followed with Close.

Making the Attribute Visible in Requests for Quote Class
You must make the "Require RFQ Terms and Conditions" attribute visible in the Requests for 
Quote class.

To make the attribute visible:

1. Double-click Classes in Settings > Data Settings.

2. Double-click Requests for Quote class.

3. Go to User Interface Tabs tab and double-click Cover Page.

4. Go to Attributes:Cover Page tab and double-click Require RFQ Terms and Conditions.

5. Select Yes in the Visible field.

6. Click Save and Close.
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Bid Decision attribute in RFQ Responses
The List entries of Bid Decision attribute are pre-defined by Agile. You can neither add a new 
list item, nor modify or delete any.

To see the available list items:

1. In Request for Quote class, go to User Interface Tabs tab.

2. Double-click the Responses row and go to Attributes:Response tab.

3. Double-click the Bid Decision attribute.

4. In Attributes:Bid Decision window, click View Details button. The List:Response_Bid_
Decision window opens.

5. Go to the List tab to see the pre-defined entries.

Adding criteria to Modify My Sourcing Project privilege
You need to add criteria to "Modify My Sourcing Project General Information" privilege.

To add criteria to Modify My Sourcing Project General Information Privilege:

1. Go to Settings > User Settings > Privileges.

2. Double-click All Privileges.

3. Type Modify My Sourcing Project in the Value field and click Apply.

4. Double-click Modify My Sourcing Project row.

5. Click the arrow button next to the Applied To field.

6. From the Choices cell, pick Sourcing Projects.General Information.Require RFQ 
Terms and Conditions and move it in the Selected cell.

Adding Criteria to Read RFQs Privilege in Sourcing Project Manager 
Role

To add criteria to Read RFQs Privilege in Sourcing Project Manager Role:

1. Double-click Roles in Settings > User Settings.

2. Type Sourcing Project Manager in the value field and click Apply.

3. Double-click Sourcing Project Manager.

4. Go to Privileges tab.

5. Double-click the Read RFQs in the Name column.

6. Click the arrow button next to the Applied To field.

7. From the Choices cell, pick Requests for Quote.RFQHeader.Require RFQ Terms and 
Conditions and move it to Selected cell

8. Click OK.

Note: If you do not find Sourcing Projects.General Information.Require 
RFQ Terms and Conditions in the Choices list, clear the 'Show visible 
attributes only check box.
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Adding Criteria to Read Privilege
To add criteria to Read Privilege:

1. Double-click Read privilege key in Settings > User Settings > Privileges.

2. Type Read RFQs in the Value field and click Apply.

3. Double-click Read RFQs.

4. Click the arrow button next to the Applied To field.

5. From Choices cell, pick the following and move them to Selected cell

? Requests for Quote.Terms and Condition Status.Accept Date

? Requests for Quote.Terms and Condition Status.Accept User

? Requests for Quote.Terms and Condition Status.Status

? Requests for Quote.Terms and Condition Status.Supplier

6. Click OK.

Configuring Product Cost Management Classes
This section describes ways to configure Product Cost Management specific Agile PLM 
classes. For details on how to configure Agile PLM classes, see the Agile PLM Administrator 
Guide.

Product Collaboration and Product Cost Management automatically exchange data between the 
Item Master and Sourcing Projects. If your Agile PLM system has enabled custom flex fields, 
you must configure the fields consistently and map them correctly to make sure the data 
exchange occurs successfully between the Item Master and sourcing projects for those fields.

If you require help customizing your Agile PLM system, contact your Oracle Consulting - 
Agile Practice representative.

If your company has purchased both Product Cost Management and Product Governance & 
Compliance solutions, you must decide how to configure the Part Groups class.

Disabling Flex Fields

To avoid Create New Attribute buttons being disabled (grayed out) in an RFQ or Sourcing 
Project's Page Two, you must set the Page Two tab as invisible in Java Client.

Note: If you have set the Force Commodity and Part Family to be Identical 
SmartRule to No, enable the Make Available As attribute in Class:Part 
groups > User Interface Tabs tab > General Info > Attributes:General 
Info tab (set Visible to Yes). The Make Available As attribute enables you to 
specify whether a part group is used as a commodity in PCM, a part family in 
Product Governance & Compliance (PG&C), or both.

Class Flex Fields Supported

This cell is blank. Page Two Page Three

Sourcing Project Yes Yes

Request for Quote Yes No

RFQ Responses No No
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The creation of a new flex field in Page Two or Page Three is not supported for Request of 
Quote and Sourcing Projects classes. By default, the Icon "New" in their corresponding 
Attributes Tabs is disabled (grayed out), however, the Page Two/Page Three attributes can be 
enabled or disabled in Java Client.

To make Page Two invisible in Java Client:

1. Go to Settings > Data Settings > Classes.

2. Double-click either Sourcing Projects or Request for Quotes class.

3. Click User Interface Tabs, and double-click Page Two.

4. Select the attribute Visible as No.

5. Click Save and Close.

Tips for Configuring Flex Fields
When you configure flex fields to share data between the Item Master and sourcing projects, 
make sure you configure the fields consistently across classes. Otherwise, the Map Data To and 
Publish actions in a sourcing project may not work. If you map a list field to another list field, 
both fields must be configured to use the same list.

Remember to name flex fields consistently across classes. Before modifying the Name of an 
attribute, copy the original name into the Description field so that you can identify the original 
attribute name later.

Product Cost Management does not support user-defined flex fields, except for Product 
Collaboration classes such as Parts and Manufacturer Parts. Consequently, you cannot map 
sourcing project attributes to any user-defined flex fields.

Pulling Data from Item Master Flex Fields into Sourcing Projects
Sourcing projects can contain items and manufacturer Parts added directly from the Item 
Master. They are added as a copy of the part in Item Master, and not as a reference. The item or 
manufacturer part inside a sourcing project supports only a few flex fields, as opposed to an 
unlimited amount in the Item Master.

Standard fields on the Title Page tab of Items and the General Info tab of Manufacturer Parts 
are mapped automatically to related sourcing project AML fields. You may, however, also want 
to pull data from item and manufacturer part flex fields (such as those on Page Two or Page 
Three) into the AML and Analysis tab of sourcing projects and the Responses tab of RFQs. 
You can map custom fields so that sourcing projects automatically pull data from them 
correctly when you import those objects.

List flex fields (SingleList or MultiList) in a sourcing project have both a List property and a 
Map Data To property. If you select a value for the Map Data To property, the List property is 
automatically disabled (you cannot pull data from two places into one field). You can 
subsequently reconfigure the list field to pull data from another item master field, even after 
items have already been added to the project. However, when you change the value of the Map 
Data To property, you will see a message warning that application data already exists with the 
current settings. If you decide to continue, the original flex field mapping is purged and cannot 
be recovered.

Note: User-defined flex fields can be created in Prices and PCO classes.
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You can map these fields to flex fields in Item-Page Two & Item-Page Three.

Similarly, a Manufacturer Part in a Sourcing Project has the same number of flex fields. You 
can map them to flex fields in Manufacturer Parts > Page Two or Page Three.

When you map attributes from Project to the Page Three attributes of Items or Manufacturer 
Parts, you must ensure that they follow the names of Page Three attributes and point to the 
same list (for List attributes) across all subclasses of the Item or Manufacturer Part.

To map sourcing project flex fields to Item and Manufacturer flex fields:

1. Enable and configure any of the following item, manufacturer part, and sites flex fields:

2. Enable and configure similar flex fields (that is, of the same data type) in the Sourcing 
Projects class. Make sure the fields are configured consistently with their related Item and 
Manufacturer Part flex fields. Otherwise, the data transfer between Product Collaboration 
and Product Cost Management will not work. For more information, see "Tips for 
Configuring Flex Fields" on page B-8.

The mapping of flex fields for Items & Manufacturer Parts can be done only in Sourcing 
Projects > AML tab. For each flex field that you enable in Sourcing Projects > AML > Items 
and in Sourcing Projects > AML > AML, specify the Map Data To property. This establishes 
the mapping between Product Collaboration and Product Cost Management.

The following table lists the Sourcing Projects flex fields that you can map to Item and 
Manufacturer Part flex fields.

Note: There are a limited number of flex fields provided for the AML tab 
of sourcing projects, so you cannot map AML attributes to all the flex fields 
that exist for item and manufacturer part attributes.

Field Type Number of Fields

Date 5

List 5

Money 5

Multi-list 2

Multi-text 2

Number 5

Text 10

Class/Tab Attributes Pull From

Sourcing Projects > AML > 
Items

Date (5)

List (5)

MultiText (2)

Text (10)

Money (5)

Number (10)

MultiList (2)

Items.Page Two fields

Page Three fields
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You can also enable flex fields on the Sourcing Projects > Analysis > Analysis and Requests for 
quote > Responses tabs. Fields with an "ipn" prefix and an "mpn" prefix automatically map to 
the Map Data To fields that you have selected for Sourcing Projects > AML.

For example, the Sourcing Projects > AML > Items > Date01 field shares its Map Data To 
mapping with Sourcing Projects > Analysis > Analysis > ipnDate01 and Requests for quote > 
Responses > ipnDate01.

The following table lists IPN and MPN flex fields.

Example: Mapping Sourcing Project Flex Fields to Item Master Flex 
Fields
The following example shows how to configure sourcing projects to map data to flex fields, a 
Page Two field for items and a Page Two field for manufacturer parts. You can follow these 
steps to configure other item or manufacturer part flex fields for Product Cost Management.

Step 1: Enable a Page Two field for the Parts class

1. Under Data Settings, double-click the Classes node. The Classes page appears.

2. Double-click the Items > Parts class.

3. Click User Interface Tabs.

4. Double-click Page Two.

5. Click the Attributes: Page Two tab.

6. Double-click Text01.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, change the value to Part Dimensions.

Sourcing Projects > AML > 
AML

Date (5)

List (5)

Money (5)

MultiList (2)

MultiText (2)

Number (10)

Text (10)

Manufacturers Parts.Page Two 
fields

Page Three fields

Class/Tab Item flex fields
Manufacturer Part flex 
fields

Sourcing Projects > Analysis > 
Analysis

ipnDate (5)

ipnList (5)

ipnMoney (5)

ipnMultiList (2)

ipnMultiText (2)

ipnNumber (10)

ipnText (10)

mpnDate (5)

mpnList (5)

mpnMoney (5)

mpnMultiList (2)

mpnMultiText (2)

mpnNumber (10)

mpnText (10)

Requests for quote > Responses NA NA

Class/Tab Attributes Pull From
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9. In the Visible field, select Yes.

10. Click Save.

Step 2: Enable a Page Two field for the Manufacturer Parts class

1. Under Data Settings, double-click the Classes node. The Classes page appears.

2. Double-click the Manufacturer Parts > Manufacturer parts class.

3. Click User Interface Tabs.

4. Double-click Page Two.

5. Click the Attributes: Page Two tab.

6. Double-click Text01.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, change the value to Mfr Part Dimensions.

9. In the Visible field, select Yes.

10. Click Save.

Step 3: Map a sourcing project AML attribute to a Page Two attribute for items

1. Under Data Settings, double-click the Classes node. The Classes page appears.

2. Double-click the Sourcing Projects class.

3. Click User Interface Tabs.

4. Double-click AML.

5. Click the Attributes: Items tab.

6. Double-click text1.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, change the value to Part Dimensions.

9. In the Visible field, select Yes.

10. Click Map Data To field. Select Parts.Page Two.Part Dimensions. The AML tab attribute 
will pull its data from that Page Two attribute.

11. Click Save.

Step 4: Map a sourcing project AML attribute to a Page Two attribute for manufacturer 
parts

1. Go to Data Settings > Classes.

Note: In Java Client, when you, for example, map part.pagetwo.Text01 to 
Sourcing Project.AML.Items.Text05, this data will be pulled to Text05 in 
sourcing project.AML tab. If the sourcing project.item.Text05 is enabled, this 
value will be pulled to sourcing project.items.Text05.

Note: To map a List or a Multi List field, make sure it points to the same 
list as pointed by the Page Two field in Items
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2. Double-click Sourcing Projects class.

3. Click User Interface Tabs.

4. Double-click AML.

5. Click the Attributes: AML tab.

6. Double-click text1.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, change the value to Mfr Part Dimensions.

9. In the Visible field, select Yes.

10. Click Map Data To field. Select Manufacturer Parts.Page Two.Mfr Part Dimensions. The 
AML tab attribute pulls its data from that Page Two attribute.

11. Click Save.

Step 5: Enable corresponding text attribute in Sourcing Project > Analysis tab

1. Go to Data Settings > Classes.

2. Click User Interface Tabs.

3. Double-click Analysis.

4. Click the Attributes: Analysis tab.

5. Double-click ipnText1.

6. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

7. In the Name field, change the value to Part Dimensions.

8. In the Visible field, select Yes.

9. Click Save.

10. Double-click mpnText1.

Note: To map a List or Multi List field, make sure it points to the same list 
as pointed by the Page Two field in Manufacturer Parts.

Note: To map a List or Multi List field, make sure it points to the same list 
as pointed by the Page Two field in Items.

Note: Each flex field with the "ipn" prefix is automatically mapped to the 
same Item flex field as its related Sourcing Projects > AML > Items flex 
field.

Note: To map a List or multiList field, make sure it points to the same list 
as pointed by the Page Two field in Manufacturer Parts
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11. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

12. In the Name field, change the value to Mfr Part Dimensions.

13. In the Visible field, select Yes.

14. Click Save.

Step 6: Enable corresponding text attributes in RFQ Responses > Response tab

1. Go to Data Settings > Classes.

2. Double-click the Requests for Quote > Requests for quote class.

3. Click User Interface Tabs.

4. Double-click Responses.

5. Click the Attributes: Responses tab.

6. Double-click ipnText 1.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, change the value to Part Dimensions.

9. In the Visible field, select Yes.

10. Click Save.

11. Double-click mpnText1.

12. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

13. In the Name field, change the value to Mfr Part Dimensions.

14. In the Visible field, select Yes.

15. Click Save.

Pushing Price Flex Fields from Sourcing Projects into the Item Master
Your company can enable custom price fields, such as additional material or non-material 
prices, for Item Master classes, such as Parts and Manufacturer Parts, and the Sourcing Project 
class. After you receive price quotes from a supplier, you can publish the prices from the 
project back to the Item Master. For subsequent sourcing projects, you can verify existing price 
scenarios by doing price lookups from the Analysis tab.

Note: Each flex field with the "mpn" prefix is automatically mapped to the 
same Manufacturer Part flex field as its related Sourcing Projects > AML > 
AML flex field.

Note: To map a List or Multi List field, make sure it points to the same list 
as pointed by the Page Two field in Items

Note:  To map a List or Multi List field, make sure it points to the same list 
as pointed by the Page Two field in Manufacturer Parts.
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The Price Details tab of a sourcing project provides several price flex fields that you can enable 
for Product Cost Management. There are both Material Price Adder fields and Non Material 
Price Adder fields.

Price adders are essentially overhead rates. Price adders can be the additional cost of an item 
such as the intellectual property value, the royalty value, and so on, apart from the material 
cost. You are limited to seven price adder fields, which are common to all projects. Price adder 
fields can be enabled for suppliers or buyers, that is, for Supplier or Internal only (Buyer) 
purposes.

Non-material prices are prices that include the labor rate, sales tax, and other overhead costs.

The following table lists Material Price and Non-Material Price flex fields you can enable in 
different classes. Make sure you configure the fields consistently from one class to another.

The fields are automatically mapped to one another based on ID. For example, Non Material 
Price 1 in one class is automatically mapped to other Non Material 1 fields. For more 
information about configuring flex fields, see "Tips for Configuring Flex Fields" on page B-8.

Price Adders
Price Adders can be either material or non-material. Many customers require partners/suppliers 
to apply adders to the top level of assemblies, not at the individual line items. Often, these 
adders are represented as a percent (%) value instead of a fixed value.

Most non-material costs can only be a fixed value, so to use a percent value, configure one of 
the percent-specific Non-Material Adders that are configurable.

The price adders that are configurable are:

? Material Adders - numbers 1 through 7 are configurable as Internal or Supplier.

? Non-Material Adders - numbers 20 through 25 are configurable as a calculation type of 
either percent (%) or a fixed value.

Important: There are seven Material Price Adder fields. All the material 
price adders can be set to visible "internally" (these will not be visible to 
suppliers) or to suppliers (suppliers will be able to view and edit these fields). 
You can configure these fields also if they have to store a "fixed" value or a 
"percent" value.

Class/Tab Material Price Attributes
Non-Material Price 
Attributes

Sourcing Projects > Price 
Details

7 Material Price Adders Non Material Price (25)

Sourcing Projects > Analysis > 
Non Material Price Entry

n/a nonMaterialModifier (20)

Non-Material Price (5)

Prices > Published Prices > 
Price Lines

Material Price (7) Non Material Price (25)

Prices > Quote Histories > Price 
Lines

Material Price (7) Non Material Price (25)

Items > Documents > Prices Material Price (7) Non Material Price (25)

Items > Parts > Prices Material Price (7) Non Material Price (25)

Manufacturer Parts > Prices Material Price (7) Non Material Price (25)
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When a supplier enters a percent value, the system will multiply the percentage with the 
material cost and the result is added to the non-material price.

The attributes are added to the total cost and are not associated with the non-material costs as 
shown in the table below.

Configuring Material Price Adders
You can configure Material Adders numbered 1 through 7 as Internal or Supplier, with a fixed 
or percent value. The Material Adders function as Cost Elements that are added to every Cost 
Estimate after the initial Estimate of Costs for material and labor. Adders typically include 
General and Administrative Cost, Overhead and Profit.

Configuring Material Adders

1. Go to Data Settings > Classes.

2. Double-click the Sourcing Projects class and go to User Interface Tabs tab.

3. Double-click Price Details and go to Attributes: Price Details tab.

4. Double-click Material Price Adder 1.

5. Select either Fixed or Percent from the Calculation Type drop-down list

6. Select either Internal Only or Supplier from the Visible To drop-down list

7. Click Save and Close.

Non-Material Adders
Non-material costs support a percent value of Material Costs. Some costs that are added to a 
Cost Estimate, such as royalties, warranties, and guarantees.

You can configure Non-Material Adders 20 through 25 to support a percent value of Material 
Costs.

Configuring Non-Material Adders as a Percent value:

1. Go to Data Settings > Classes.

Note: Non-material percent types are useful only if a material price exists.

Non-Material Price Material Price

Non-Material Price_1 (fixed value) = 50 Material Price = 100

Non-Material Price_20 (percent value) = 25 NA

Total Non-Material Price = 75

((0.25 * 100) + 50)

Total Material Price = 100

Total Extended Cost = 175 NA

Note: The Material Adders can be given a fixed or percent value.

Note: Sometimes the Non-Material Adders are referred to as Non-Standard 
Adders in the industry.
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2. Double-click the Sourcing Projects class and go to User Interface Tabs tab.

3. Double-click Price Details and go to Attributes: Price Details tab.

4. Double-click Non-Material Price 20.

5. Select either Fixed or Percent from the Calculation Type drop-down list.

6. Select Yes in the Visible list.

7. Click Save and Close.

Example: Enabling a Labor Cost Per Unit Field
The following example shows how to enable a Non-Material Price flex field called Labor Cost 
Per Unit for several Agile PLM classes. You can follow these steps to configure other price flex 
fields for Product Cost Management.

Enabling a Labor Cost Per Unit Field

1. Go to Data Settings > Classes.

2. Complete steps 3 through 9 for each of the following steps:

a. For Parts: Double-click the Items > Parts class

b. For Documents: Double-click the Items > Documents class

c. For Manufacturer Parts: Double-click the Manufacturer Parts > Manufacturer parts class

d. For Published Prices: Double-click the Prices > Published Prices class

e. For Quote Histories: Double-click the Prices > Quote Histories class

f. For Sourcing Projects: Double-click the Sourcing Projects > Sourcing projects class.

3. Go to User Interface Tabs tab.

4. Double-click Prices and go to Attributes: Prices tab.

5. Double-click Non-Material Price1.

6. Cut the text from the Name field and paste it in the Description field. This will help you 
identify the original attribute name.

7. In the Name field, type Labor Cost Per Unit.

8. Select Yes in the Visible list.

9. Click Save.

Note: You can only configure Non-Material Price Adders 20 to 25 as 
"Percent." All others are set to "Fixed" and are not configurable.

Note: In all the above, to use a specific price field (like Non-Material 
Price1), you must use the same Non-Material Price1 field in all 
corresponding classes (Parts, Documents, Manufacturer Parts, Published 
Prices, Quote Histories & Sourcing Projects). You cannot use Non-Material 
Price1 to capture Labor Cost in Parts Class and Non-Material Price 2 to 
capture the same in Manufacturer Parts Class.
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Pushing Response Flex Fields from Project-Analysis into Published 
Prices & Quote Histories

RFQ Responses contain a header area that can include several flex fields. If you enable any flex 
fields on the Responses tab of RFQs, you can map to Page Two fields in Published Prices & 
Quote Histories. When you publish the responses to the Item Master, the flex fields that you 
map will be updated.

To map Response flex fields in Project-Analysis tab to Page Two or Price Line fields in 
Published Prices & Quote Histories

1. Enable and configure any of the following flex fields in the Sourcing Projects class. The 
same set of flex fields is also available in "Requests for Quote" class and can be filled by 
the Suppliers when responding to RFQs.

2. Enable and configure similar flex fields (that is, of the same data type) listed in the tables 
below. Make sure the fields are configured consistently with their related Requests for 
Quote flex fields. Otherwise, the data transfer between Product Collaboration and Product 
Cost Management will not work. For more information, see "Tips for Configuring Flex 
Fields" on page B-8. 

3. Finally, enable and configure flex fields on the Sourcing Projects > Projects > Analysis > 
Analysis tab. Make sure you specify the Map Data To property. This establishes the 
mapping between Product Cost Management and Product Collaboration.

Class/Tab Attributes

Sourcing Projects > Analysis > Analysis resp Date (5)

resp List (5)

resp Money (10)

resp MultiList (2)

resp MultiText (2)

resp Number (10)

resp Text (10)

Items > Documents > Prices Date (5)

List (5)

Money (5)

MultiList (2)

MultiText (2)

Number (10)

Text (10)

Items > Parts > Prices NA

Manufacturer Parts > Prices NA

Prices > Published Prices > Page Two NA

Prices > Published Prices > Page Three NA

Prices > Published Prices > Price Lines NA

Prices > Quote Histories > Page Two NA

Prices > Quote Histories > Page Three NA

Prices > Quote Histories > Price Lines NA
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Pushing Data in Flex Fields from Sourcing Project to Item Master
To publish data from Flex Fields in Sourcing Project to Item Master, you can use the Map Data 
To field. This field actually functions to "push" data to that location, and requires a value.

Example: Mapping a Response Flex Field
The following example shows how to enable a Response flex field called Supplier Note in 
Sourcing Project so that it is mapped to "Published Price" or "Quote History" classes. You can 
follow these steps to configure other RFQ flex fields for Product Cost Management.

Step 1: Enabling a Supplier Note field for the Responses tab of RFQs

1. Go to Data Settings > Classes.

2. Double-click the Requests for Quote > Request for quote class.

3. Click User Interface Tabs.

4. Double-click Responses.

5. Click Attributes: Responses.

6. Double-click resp MultiText 1.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, type Supplier Note.

9. In the Visible field, select Yes.

10. Click Save.

Step 2: Enabling a Supplier Note Field for Published Prices

1. Go to Data Settings > Classes.

2. Double-click the Prices > Published Prices class.

3. Click User Interface Tabs.

4. Double-click Price Lines.

5. Click the Attributes: Price Lines tab.

6. Double-click MultiText01.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, type Supplier Note.

9. In the Visible field, select Yes.

10.  Click Save.

Class/Tab Attributes Push Data To

Sourcing Projects > Analysis > 
Analysis

respDate (5)

respList (5)

respMoney (10)

respMultiList (2)

respMultiText (2)

respNumber (10)

respText (10)

Prices.Price Lines fields

Prices.Page Two fields

Page Three fields
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Step 3: Enabling a Supplier Note Field for Quote Histories

1. Go to Data Settings > Classes.

2. Double-click the Prices > Quote Histories class.

3. Click User Interface Tabs.

4. Double-click Price Lines.

5. Click the Attributes: Price Lines tab.

6. Double-click MultiText01.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, type Supplier Note.

9. In the Visible field, select Yes.

10. Click Save.

Step 4: Enabling a Supplier Note Field for Parts

1. Go to Data Settings > Classes.

2. Double-click the Items > Parts class.

3. Click User Interface Tabs.

4. Double-click Prices.

5. Click the Attributes: Prices tab.

6. Double-click MultiText01.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, type Supplier Note.

9. In the Visible field, select Yes.

10. Click Save.

Step 5: Enabling a Supplier Note Field for Documents

1. Go to Data Settings > Classes.

2. Double-click the Items > Documents class.

3. Click User Interface Tabs.

4. Double-click Prices.

5. Click the Attributes: Prices tab.

6. Double-click MultiText01.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, type Supplier Note.

9. In the Visible field, select Yes.

10. Click Save.

Step 6: Enabling a Supplier Note Field for Manufacturer Parts

1. Go to Data Settings > Classes.
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2. Double-click the Manufacturer Parts > Manufacturer parts class.

3. Click User Interface Tabs.

4. Double-click Prices.

5. Click the Attributes: Prices tab.

6. Double-click MultiText01.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, type Supplier Note.

9. In the Visible field, select Yes.

10. Click Save.

Step 7: Enabling a Supplier Note field for the Analysis tab of sourcing projects

1. Go to Data Settings > Classes

2. Double-click the Sourcing Projects > Sourcing projects class.

3. Click User Interface Tabs.

4. Double-click Analysis.

5. Click the Attributes: Analysis tab.

6. Double-click resp MultiText 1.

7. Copy the text in the Name field and paste it into the Description field. This will help you 
identify the original attribute name.

8. In the Name field, type Supplier Note.

9. In the Visible field, select Yes.

In the Map Data To field, select "Published Prices.Price Lines.MultiText01". Even though 
the drop-down will list the fields from both Published Prices & Quote Histories, you can 
choose only one.

You can also map the above flex field to a Multi Text field in Page Two tab of "Published 
Prices" class. The above example maps it to the Price Lines tab of the "Published Prices" 
class.

10. Click Save.

Configuring BOM Filters
This section explains how to set up the BOM filters. For more details on concepts and usage of 
BOM filters, see the "Working with Sourcing Projects" chapter which contains a section, 
"Adding Items to a Project," that explains how to set up the BOM filter in Web Client.

Set up a Sourcing Project Class BOM attribute:

1. Go to Data Settings > Classes.

2. Double-click Sourcing projects class.

3. Go to User Interface Tabs tab and double-click Items in the list.

Note: Although the field is named Map Data To, in this case it pushes data 
to the selected field when you publish responses to the Item Master.
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4. Go to Attributes: Items tab.

5. Double-click Filter in the Attributes name list.

6. Select Yes from the Visible drop-down list.

7. Rename the Filter for your purposes. For example: "Production BOM."

Setting up Names of BOM Filters
To distinguish between BOM items that you will filter for import, you must first set up and 
name certain attributes for each specific BOM that you plan to import.

For example, if you have two versions of the same BOM, one called "Production" and another 
called "Prototype," you would need to set up a list attribute for each BOM. It is suggested that 
you name the list attribute based on your use case scenario. You can use any existing attribute 
as a template; this example uses "BOM List 3" as a template.

Set up a Parts Class BOM attribute:

1. Go to Data Settings > Classes.

2. Double-click Parts class.

3. Go to User Interface Tabs tab and double-click BOM.

4. Go to Attributes: BOM tab.

5. From the list of attribute names, double-click the attribute you will use as a template. For 
example, "BOM List 3."

6. Copy the original attribute's name into the description field and rename the attribute 
according to your use case scenario, for example: "Prod Load."

7. In the Visible field, select Yes.

8. To the right of the List field, click the New List button to create a list. A Create List 
window pops up.

9. Name the list the same as the new attribute, and give a description. For example, name it 
"Prod Load" and give it the description, "Filter."

10. You may Enable or Disable the New List by making appropriate selection in Enabled 
drop-down list.

11. Chose Yes or No from Cascade drop-down list to create a cascaded List.

a. If you select No for Cascade, the List window (the New List name window) appears 
along with the Create a new list value pop-up. Enter a name in Name field and click Add 
button, or click Add Another button to continue adding more list values.

b. You can also add the list values later. For more information on adding or configuring 
Lists, see Lists.

Note: BOM Filters are supported in the Parts class, but not in the 
Documents class.

Note: A BOM Filter supports filtering on multiple BOM flex fields only. It 
supports only Text1-5, Numeric1-5, List1-5 that are defined in Item.BOM 
tab, besides Qty from the Item.BOM tab. It does not support filtering on date 
fields, multi-list fields, and multi-text fields.
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c. If you select Yes for Cascade, the List window (the New List name window) appears. In 
the List tab, you will find the New List Name as the first item, denoting that it is the base 
value of the Cascade List. Click New button to add cascade list values under this.

d. The Create a new list value pops up. Enter a name in Name field and click Add button, 
or click Add Another button to continue adding more list values. These list values appear 
as cascaded under the New List name.

e. You can add list values to these list values to get any level of cascaded lists. To do so, 
select a List Value and click New button. Follow step 3 above.

f. Click Save and Close to return to BOM List 3.

12. Click Save and Close.

For detailed instructions on how to create a sourcing project using this new BOM filter, 
refer to "Working with Sourcing Projects" on page 2-1.

Configuring Preferences for PCM
The PCM money attributes’ decimal values are controlled by the Price Scale preference setting. 
The Price Scale can range from 0 to a maximum of 9. The default value is 6. If you attempt to 
lower the value of the Price Scale, a warning appears to remind you that lowering the Price 
Scale may cause rounding errors.

To set Price Scale:

1. Go to Server Settings > Preferences.

2. On the General Information tab, find the Price Scale field.

3. Set the new value of Price Scale.

4. Click Save.

The value set by the administrator is copied to all of the PCM money attributes and cannot be 
overwritten on the attribute itself.

Managing Events in PCM
In Agile PLM, a preconfigured event is an automation that occurs when a user performs a task 
that is specified by the event mask. The triggered event then results in event outcome, such as 
the delivery of a notification to a user. An Agile administrator, with the appropriate privileges, 
can manage the different components of the event process.

There is limited event functionality for the PCM solution, however, some events are 
configurable for PCM objects including Sourcing Projects, RFQs, RFQ Responses, Suppliers, 
Prices, and PCOs. Additionally, some events are supported only for certain tabs of an object.

The following content breaks down the PCM objects tab by tab to show you which event types 
are supported.

For the Commodity object:

? (at object level) - Create Object, Delete Object, Export Object, Save As Object

? General Info Tab - Update Table

? Parts Tab - Update Table

? Relationships Tab - Update Table

? Attachments Tab - Check In Files, Check Out Files, Get File, Update Table

For the Price object:
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? (at object level) - Create Object, Delete Object, Export Object, Save As Object

? General Information Tab - Update Table

? Relationships Tab - Update Table

? Attachments tab - Check In Files, Check Out Files, Get File, Update Table

For the PCO object:

? (at object level) - Create Object, Delete Object, Export Object, Save As Object, Change 
Status For Sourcing Object

? Cover Page Tab - Update Table

? Relationships Tab - Update Table

? Attachments tab - Check In Files, Check Out Files, Get File, Update Table

For the RFQ object:

? (at object level) - Delete Object, Change Status For Sourcing Object

? Cover Page Tab - Update Table

? Relationships Tab - Update Table

? Attachments tab - Check In Files, Check Out Files, Get File, Update Table

For the RFQ Response object:

? Cover Page Tab - Update Table

? Relationships Tab - Update Table

? Attachments tab - Check In Files, Check Out Files, Get File, Update Table

For the Sourcing Project object:

? (at object level) - Create Object, Delete Object, Save As Object, Change Status For 
Sourcing Object

? General Information Tab - Update Table

? Relationships Tab - Update Table

? Attachments tab - Check In Files, Check Out Files, Get File, Update Table

For the Supplier object:

? (at object level) - Create Object, Delete Object, Export Object, Save As Object

? General Info Tab - Update Table

? Relationships Tab - Update Table

? Attachments Tab - Check In Files, Check Out Files, Get File, Update Table

The following are examples of practical situations in which events could be used in PCM:

? Once a sourcing buyer sets authorized users for a sourcing project or an RFQ, notifications 
can be sent to the users by using the Update Table event type.

? You can use the Create Object event type to automatically open a project for RFQ creation.

? You can use the Create Object event type to carry prices over to a newly created MCO.

? A global commodity manager imports parts into a sourcing project. some parts are 
associated with specific regional commodity managers. You can use the Change Status for 
Sourcing Object event type to send notifications to the regional managers once the project 
is open and ready for RFQ creation.
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There are many other situations in which the use of events may be a useful and efficient way to 
achieve a certain outcome. For more details about events and how to configure and manage 
them, see the Agile PLM Administrator Guide.
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CDeleting Agile Objects

Java Client and Web Client support "soft" and "hard" deletes for many Agile object classes. 
When you soft-delete an object in the database, it is not permanently deleted. A soft-deleted 
object is marked "Deleted" in the database, and its object number or name is reserved. You 
cannot create another object with the same type and number or name as a soft-deleted object.

When you run a search, soft-deleted objects do not appear in the search results table. To locate 
soft-deleted objects, you must run the predefined deleted object searches in the Recycle Bin 
Searches folder.

A hard-deleted object is permanently removed from the database.

To soft-delete, hard-delete or undelete an Agile object:

? You must have the appropriate Delete or Undelete privileges for that object.

? All relationships and subscriptions must be removed.

? The object must meet any additional conditions that determine whether it can be deleted or 
undeleted.

In general, if deleting or undeleting an object would cause the compromise of data integrity, the 
delete or undelete action is disabled.

For detailed information about deleting specific object types, see "Notes about Deleting 
Specific Agile Object Types" on page C-3.

Soft-Deleting an Object
When an object is soft-deleted, it is no longer available for use. However, until it is 
hard-deleted, its number or name is reserved in the Agile PLM database and cannot be reused.

To soft-delete an object in Web Client:

1. Select and open the object you want to delete.

Note: You have access to the Recycle Bin Searches folder if Recycle Bin 
Searches is included in the Searches field of your user profile. If you have the 
appropriate privileges, then you can edit your user profile and add Recycle 
Bin Searches to the list of searches in the Searches field. If you do not have 
the appropriate privileges to modify the Searches field in your user profile, 
then ask the Agile administrator to modify your user profile.

Caution: You cannot undelete a hard-deleted object.
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2. Choose Actions > Delete, and respond OK to the confirmation prompt.

The object is soft-deleted.

To soft-delete an object in Java Client:

1. Select and open the object you want to delete.

2. Click the Delete button, and respond Yes to the confirmation prompt.

The object is soft-deleted.

See also: "Deleting Agile Objects" on page C-1, "Undeleting an Object" on page C-2 , and 
"Hard-Deleting an Object" on page C-2.

Undeleting an Object
If you have the appropriate privileges, then you can undelete soft-deleted objects.

To undelete an object in Java Client:

1. Run the appropriate Deleted objects search from the Recycle Bin Searches folder.

2. Open the deleted object you want to restore.

3. Click the Undelete button.

To undelete an object in Web Client:

1. Run the appropriate Deleted objects search from the Recycle Bin Searches folder.

2. Open the deleted object you want to restore.

3. Choose Actions > Undelete.

Hard-Deleting an Object
Soft-deleted objects still exist in the database. To remove an object permanently, you must 
hard-delete it. While an object is still only soft-deleted, you can undelete it. Run the appropriate 
Deleted object search from the Recycle Bin Searches folder.

To hard-delete a soft-deleted object (if you have the appropriate privileges) in Java Client:

1. Run the appropriate Deleted objects search from the Recycle Bin Searches folder.

2. Open the object.

3. Click the Delete Object button, and respond Yes to the confirmation prompt.

To hard-delete a soft-delete object (if you have the appropriate privileges) in Web Client:

1. Run the appropriate Deleted objects search from the Recycle Bin Searches folder.

2. Select the one or more object rows in the search results table.

3. Click the Delete button.

4. In response to the warning prompt, choose Continue and then click Finish.

5. Or, you can hard-delete one object at a time:

Open the object.

Choose Actions > Delete, and respond OK to the confirmation prompt.

Note: You can click the Navigator button in the search results table to 
display the search result object links in the left pane NAVIGATOR drawer.
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See also: "Undeleting an Object" on page C-2 and "Soft-Deleting an Object" on page C-1

Notes about Deleting Specific Agile Object Types
The following sections provide important notes about deleting specific Agile Object Types.

Notes about Deleting Item Objects
Before you can delete an item object, it must meet the conditions described below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

? The item has no released changes against it.

? The item is not listed on the Affected Items tab of any pending changes.

You must first remove the item from the Affected Items tab of each pending change before you 
can delete the item.

? The item has not been added to PSR.

? The item has not been added to QCR.

? The item has not been added to Material Declaration.

? The item has not been added to Price.

? The item has no content on its BOM tab for the current revision or any pending revisions.

? The item has no content on its Manufacturers tab for the current revision or any pending 
revisions.

? The item is not used on the Bill of Materials of any other item, that is, the item to be 
deleted is not a child item on the BOM tab of a parent item revision, including the latest 
released revision, past released revisions, or pending revisions of the parent item.

? The item is not associated with a Part Family, that is, the item does not appear on the Parts 
tab of a Part Family object. On the Title Page of the item to be deleted, the Part Family 
field must be empty. If the Part Family field is populated, then the Actions > Delete 
command is disabled.

Notes about Deleting Change Objects
Before you can delete a change object, it must meet the conditions described below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges. For example, you are the change analyst or component engineer, and the Agile 
administrator has given change analysts or component engineers the appropriate privileges 
to delete a change.

? All relationships and subscriptions have been removed.

? The change is at the Pending status type or the Unassigned status.

? You have Discovery and Read privileges for any items on the Affected Items table, 
otherwise, you cannot delete the change.

Note: You can click the Navigator button in the search results table to 
display the search results object links in the left pane NAVIGATOR drawer.
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? When you soft-delete a change that has items on the Affected Items tab, all redlines 
associated with that change are discarded. To preserve data integrity, a soft-deleted change 
with items on the Affected Items tab cannot be undeleted. That is, a soft-deleted change 
can be undeleted only if there are no items on the Affected Items tab.

Notes about Deleting Transfer Order Objects
Before you can delete a Transfer Order object, it must meet the conditions described below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

? The transfer order is at the Pending status type or the Unassigned status.

Notes about Deleting PSR or QCR Objects
Before you can delete a Product Service Request (PSR) or Quality Change Request (QCR) 
object, it must meet the conditions described below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

? The PSR or QCR is at the Pending status type or the Unassigned status.

? You have Discovery and Read privileges for any items on the Affected Items table; 
otherwise, you cannot delete the PSR or QCR.

You cannot delete a PSR if:

? It appears on the Relationships tab of a QCR.

? It is currently part of a corrective action process. Remove the PSR from the QCR and then 
delete the PSR.

? It appears in the Related PSR tab of another PSR.

? It is currently part of a larger problem. Remove this PSR from the parent PSR and then 
delete it.

Note: To delete a change that has already been released, you must first 
unrelease the change. You need the appropriate privileges to unrelease a 
change by using the Workflow tab to switch it to a different status.

Note: If you think you might want to undelete a soft-deleted routable object 
in the future, then be sure to clear its Affected Items tab before you delete it. 
You can undelete only routable objects with no entries on the Affected Items 
tab. To keep the record of affected items but still want to delete the change 
object, then use the Save As command to copy it under another change object 
number before deleting it.

Note: To delete a PSR or QCR that has already been released, you must 
first unrelease it. You need the appropriate privileges to unrelease a PSR or 
QCR by using the Workflow tab to switch it to a different status.



Notes about Deleting Specific Agile Object Types

Deleting Agile Objects C-5

? It appears on the Related PSR tab.

? It is being used to aggregate multiple problems. Remove the related PSRs and then delete 
it.

You cannot delete a QCR if:

? It has any PSRs on the Relationships tab.

? If the corrective action process contains Problem Reports. Remove the PSR from the QCR 
and then delete the QCR.

? It has any Changes on its Relationships tab.

? If the corrective action process is already routed through engineering changes. Remove the 
Changes from the QCR and then delete the QCR.

Notes about Deleting Sourcing Project, RFQ and RFQ Response 
Objects

Agile Product Cost Management (PCM) objects include: Sourcing Project, RFQ, and RFQ 
Response. Before you can delete any Agile PCM object it must meet the conditions described 
below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

? Sourcing Project

The sourcing project has no RFQs.

If the sourcing project has RFQs, the RFQs are in the closed state.

? RFQ

The RFQ has no released changes against it.

? RFQ Response

The delete action is not supported for RFQ response objects.

Notes about Deleting Package Objects
Before you can delete a Package object, it must meet the conditions described below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

? The package is at the Pending status type or the Unassigned status.

Note: Sourcing project objects can be soft deleted, but soft-deleted 
sourcing project objects cannot be undeleted or hard deleted.

Note: RFQ objects can be soft deleted, but soft-deleted RFQ objects cannot 
be undeleted or hard deleted.
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Notes about Deleting Manufacturer Objects
Before you can delete a manufacturer object, it must meet the conditions described below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

? It is not listed on the Manufacturers tab of an item. (Check the Where Used tab of the 
manufacturing object.)

? If the object is a manufacturer, no manufacturer parts are associated with it.

Notes about Deleting Site Objects
Before you can delete a Site object, it must meet the conditions described below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

? The site does not appear on any item's Sites tab.

? The site is not associated with any other Agile object.

? The site has a lifecycle of Disabled.

Notes about Deleting User Objects
Before you can delete a User object, it must meet the conditions described below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

Note: If all manufacturer parts associated with a manufacturer have been 
deleted, then the manufacturer can be deleted as well. However, you will not 
be allowed to undelete the soft-deleted manufacturer parts until the 
soft-deleted manufacturer object is undeleted.

Note: Site objects can be soft deleted, but soft-deleted sites cannot be 
undeleted or hard deleted. If you are no longer using a site, then Agile 
recommends that you disable it.

Note:  If it meets the conditions listed above, then a disabled site can be 
soft-deleted even when it is listed in the Sites or Default Site field of user 
profiles. The deleted site is automatically removed from the Sites list in any 
user profile where it is listed.

§ Once the site has been associated with an item, you can change its status to 
Disabled, but you cannot delete it.

Note: User objects cannot be hard-deleted.
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User access to Agile PLM can also be controlled by using the user profile Status property. For 
example, if someone leaves the company, or will no longer be using Agile PLM, or you need to 
prevent a user from logging in to the Agile PLM system, then disable the user object by setting 
the Status property to Inactive. The user remains listed on the Java Client Administrator Users 
node and on the Web Client Address Book Users tab, and the name still appears on existing 
workflows, escalations, and so forth, but the user will no longer appear in the Address Book for 
other users to select. You can re-set the user to Active status at any time.

In Java Client Administrator, to display the list of deleted users, you can use either the Deleted 
Users node or the Recycle Bin search Deleted Users. In Agile Web Client, to display the list of 
deleted users, use the Recycle Bin search Deleted Users.

For detailed information about managing Agile PLM users, see Agile PLM Administrator 
Guide.

Notes about Deleting User Group Objects
You can delete a user group that is no longer needed.

Before you can delete a user group object, it must meet the conditions described below.

? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

If you delete a user group to which users have been assigned, then you can do so without 
removing the users who were in the user group:

? Global User Groups - when you soft-delete a global user group, the group is listed in the 
group members' user profile Groups tabs as an inactive group. When you hard-delete a 
global user group, the user assignments to that global user group are also deleted and do 
not appear on the user profile Groups tab.

? Personal User Groups - For personal user groups, whether active or inactive, assignments 
are not listed on the group members' user profile Groups tabs.'

When you delete a user group, it is removed from the Agile PLM address book. You cannot 
delete a user group if it is in use in these cases:

? It is on any routable object signoff list on the routable object Workflow tab.

? It is listed in any workflow definition Notify properties.

? It is used as a designated escalation person for any users, user groups, and partners.

In Java Client Administrator, to display the list of deleted user groups, you can use either the 
Deleted User Groups node or the Recycle Bin search Deleted User Groups. In Agile Web 
Client, to display the list of deleted users, use the Recycle Bin search Deleted User Groups.

Notes about Deleting PG&C Objects
Agile Product Governance & Compliance (PG&C) objects include: Declarations, 
Specifications, Substances, and Part Groups. Before you can delete any Agile PG&C object it 
must meet the conditions described below.

Note: If you set a user group Status to Inactive, then the inactive group 
appears in the search results table. In contrast, a soft-deleted user group does 
not appear in the search results table.
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? The Agile administrator has assigned to you a role that has the appropriate Delete 
privileges.

? All relationships and subscriptions have been removed.

? Substances, Specifications, and Part Groups

If the substance, specification or part group object is in use, then it cannot be deleted.

? Declaration

The Declaration is at the Pending status type or the Unassigned status.
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Activity

A project activity in Agile Product Portfolio Management, such as a program, task, or phase.

Affected Files

Similar to Affected Items, these objects are EC files that are Design Release Candidates.

Agile Configuration Propagation (ACP)

Propagating existing configuration of PLM to the newly installed version of PLM.

Agile Content Service (ACS) 

ACS is an event-driven XML-based publishing service that makes the product record available 
to a wide variety of business applications and users, internally and across the global 
manufacturing network

Agile Destination

A package created by an Agile PLM system in the target PLM using Web Services to import 
from the Attachments tab of the package in the target system.

Agile Integration Services (AIS)

A collection of predefined Web Services in the Agile Integration Framework that enable 
communication between the Agile Application Server and disparate systems

Agile Product Portfolio Management

The Agile PLM project management solution that is integrated with the product information in 
PLM.

AI

Affected Items tab on Change objects in Agile.

Approved Manufacturer Parts List (AML)

List of approved manufacturer parts associated with an item.

Application Programming Interface (API)

A set of routines, protocols, and tools for building software applications. An API expresses a 
software component in terms of its operations, inputs, outputs, and underlying types.

Assembly

A product assembly lists the parts in a product and shows the substances and materials that 
comprise those parts. It is linked to specifications that can restrict how much of a particular 
substance that product assembly may contain



Automated Transfer Orders (ATO)

Glossary-2

Automated Transfer Orders (ATO)

Content published by Agile PLM users in real time with a content transfer order (CTO) or set 
up subscribers to automatically create automated transfer orders (ATO) based on a schedule or 
triggered by a workflow status change.

Baseline

A snapshot of a project, usually in its initial stage, used as a reference for future comparison in 
Agile Product Portfolio Management.

Bill of Material (BOM)

A hierarchical representation of a product that is made up of other products.

Bill of Substances (BOS)

A hierarchical list of substances that are contained in the parts and assemblies that make up a 
BOM.

Change Sequence

A series of three-digit numbers (001 through 099) that define the order in which DFCOs 
(Design File Change Orders) have been published for a specific Design or File Folder. Each 
Change Sequence number is associated with one specific DFCO and with the specific file 
folder version number in use when the DFCO is published.

Commodity

A class of goods that is in demand, that is supplied without qualitative differentiation regardless 
of supplier.

Computer-aided Design (CAD)

The use of computer systems to assist in the creation, modification, analysis, or optimization of 
a design. CAD software is used to increase the productivity of the designer, improve the quality 
of design, improve communications through documentation, and to create a database for 
manufacturing. CAD output is often in the form of electronic files for print, machining, or other 
manufacturing operations.

Contract (Price)

This is a subclass of the Published Prices class. Contract prices are prices provided by the 
supplier for a specific item or manufacturer part. This price information applies only for the 
specified duration and can apply to any project.

Co-Sourcing

The process of leveraging product cost across suppliers. 

Deliverable

A unit of work required for a project's success, usually fulfilled by generating a digital file. 
(Word processing documents, spreadsheet documents, PDFs, presentation documents, and so 
on.) Deliverables can also be Agile PLM objects and processes. Also called ’content’ in Agile 
Product Portfolio Management.

Design Change Order (DCO)

A Change Order subclass that is available when the effected File Tab is enabled and provides 
access to all Agile PLM Workflow functions.
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Design File Folder

An EC file folder that is integrated with CAD and PLM files, providing full access to PLM 
Workflow function.

EC Client

A Java-based UI to access, administer and operated the EC solution.

Engineering Collaboration (EC)

An application that provides data and process integration between CAD applications and Agile 
PLM. It allows CAD designers and engineers to capture and control the data representing a 
primary source of the product record.

Engineering Collaboration Order (ECO)

An object that carries with it all the proposed changes to a product and/or its BOM. When 
approved and implemented, the proposed changes become effective.

Extensible Markup Language (XML) 

A markup language that defines a set of rules for encoding documents in a format that is both 
human-readable and machine-readable

File Manager

The File Manager manages files in a repository or vault in the file system and provides a place 
to store and retrieve files locally or remotely. You can install it on the same server as the Agile 
Application Server or on a separate one. You can also install the File in a redundant 
configuration and/or distributed across geographic regions. 

File Transfer Protocol (FTP)

A standard network protocol used to transfer computer files from one host to another host over 
a TCP-based network, such as the Internet.

Fully Qualified File Name

The exact name of a file on a computer that is completely specified such that it is unambiguous 
and cannot be mistaken for any other file on that system.

Fully Qualified Path Name (FQPN)

The full path of a resource, directory or file, stored in a computer. It is composed by the full 
path to the resource and its syntax depends on the operating system.

Gantt Chart

A project management tool that shows project activities and schedule as a bar chart. The chart 
lists project activities in sequence, and presents critical information such as the start and end 
dates of each activity, as well as interdependencies between activities.

Item Master

The product record. It is the entire collection of Items - Parts, Documents, and any other 
user-defined subclasses of the Items class maintained under change control in the Agile system.

Java Message Service (JMS)

The Java Message Service (JMS) API is a Java Message Oriented Middleware (MOM) API for 
sending messages between two or more clients.

Lifecycle Phase

Current state in an object’s workflow.
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LRR

Latest Released Rev - concerning a Part or Document. 

Non Cancelable Non Returnable (NCNR) 

Applies to an item. NCNR can be a Yes or No, depending on the supplier. You can ask for the 
NCNR information in the supplier response. This is one of the critical factors in finding the best 
deal among the supplier responses.

PDX

See Product Definition eXchange (PDX).

PLM

See Product Lifecycle Management (PLM).

Percent allocation or % allocation

The percentage of a resource's time allocated to a specific task or tasks in Agile Product 
Portfolio Management..

Percent complete or % complete

Amount of time and effort expended on a project measured as a percentage of the time and 
effort required to complete the whole project. Used in Agile Product Portfolio Management.

Product Definition eXchange (PDX)

A standard designed for the e-supply chain. This standard is based on the XML format because 
it provides a simple yet powerful and flexible way to encode structured data into a format that 
is both human- and computer-readable. In PLM, PDX packages contain product content, such 
as items.

Product Lifecycle Management (PLM)

The process of taking parts/documents from inception to production to phase-out, and all the 
stages in between.

Protocol

A system of digital rules or agreed-upon format for data exchange within or between devices. It 
determines the type of error checking and data compression used.

Published Price

This is a subclass of the Published Prices class. Published prices are prices provided by the 
suppliers in response to an RFQ and published from the project. The published price 
information can also be used in other projects.

Price

An object that carries with it all the proposed changes to a product and/or its BOM. It can be 
approved and implemented to make the proposed changes effective.

Price Change Order

It is an object that carries with it all the proposed changes to a price. It can be approved and 
implemented to make the proposed changes effective.

Quote History

A subclass of the Quote Histories class. Quote history prices are the stored prices from supplier 
responses that you can use. Any change in the response line of an RFQ is stored in the 
historical response and is usable at any time.



Target Cost

Glossary-5

Request for Information (RFI)

A material declaration that lists the parts in a product assembly and shows the substances and 
materials contained in the part.

Request for Quote (RFQ)

A standard business process whose purpose is to invite suppliers into a bidding process to bid 
on specific products or services.

Request for Proposal (RFP)

A solicitation, often made through a bidding process, by an agency or company interested in 
procuring a commodity, service or valuable asset, to potential suppliers.

Response Line

A response line has information about only one item. The negotiation of price and terms for 
items is dealt with in a response line.

Resource Pool

A group of users who can be bulk assigned as resources for a particular project or task in Agile 
Product Portfolio Management.

RFQ Response

A medium of communication between the user and the supplier. One response from a supplier 
can contain multiple response lines for different items. Price data is added to the project 
automatically when the supplier submits the response.

Schedule Editor

The scheduling engine that handles updates to the project schedule in Agile Product Portfolio 
Management.

Schema

In computer programming, a schema is the organization or structure for a database. The activity 
of data modeling leads to a schema.

Software Development Kit (SDK or "devkit")

A set of software development tools that allows the creation of applications for a certain 
software package, software framework, hardware platform, computer system, video game 
console, operating system, or similar development platform.

Sourcing Project

The entry point of sourcing and product pricing. A sourcing project tracks data required for 
sourcing and pricing, to perform data analysis for effective pricing.

Standard Cost

Applies to an item. This is the market cost of the item. It is site-specific. The standard cost is 
for a unit.

Supplier

A supplier of one or several commodities.

Target Cost

Applies to item. This is the expected cost of the item by you or the supplier. This can be a 
percentage of the standard cost. Target cost is for a unit.
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Timesheet

The time entry system in Agile Product Portfolio Management, used to track actual hours spent 
by resources on project activities and to calculate corresponding labor cost. 

Top Level Assembly (TLA)

The level in a BOM that indicates the ultimate product being manufactured. 

Transfer order

Every time Agile Content Service (ACS) publishes product content, it produces a transfer order 
that keeps track of what, where, and when product content is transferred.

User Productivity Kit (UPK)

The Oracle online help system used in some Oracle products.

Web Service Extensions (WSX)

A Web service engine that enables communication between Agile Product Lifecycle 
Management system and disparate internal and external systems.

XML

See Extensible Markup Language (XML).

XML Schema

Description of a type of XML document, typically expressed in terms of constraints on the 
structure and content of documents of that type, above and beyond the basic syntactical 
constraints imposed by XML rules.
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