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About this guide

About this guide

Empirica Signal release 7.3.3.4 and higher provides the ability to generate reports on topic content using
Oracle® Business Intelligence Enterprise Edition (Oracle BI EE). This guide provides system requirements
and configuration instructions to integrate Oracle BI EE with Empirica Signal.

This guide assumes you have both the Empirica Signal application and Oracle BI EE already installed. This
guide also assumes that you have an understanding of operating system and database concepts, and have
experience using the supporting software described in the Installation prerequisites.

Audience

This guide is intended for database administrators, I'T administrators, and Empirica Signal administrators.
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1: Installation prerequisites

1: Installation prerequisites

To use Oracle Business Intelligence to report on Empirica Signal Topics, the following requirements must

be met.

Database requirements

Oracle® Database 11g Release 2 (11.2.0.3.0 or later).

SYSTEM password for the Oracle database instance.

Name of the Signal application database account and tablespace.

TNS name used for database access from Empirica Signal and Oracle BI EE.

Oracle Business Intelligence requirements

64-bit Oracle® Business Intelligence Enterprise Edition release 11.1.1.7.0 with WebLogic Server
10.3.6.0.8.

Java 1.7 with Java Cryptography Extension (JCE) installed.

Oracle® Business Intelligence Developer Client Tools, 64-bit or 32-bit. This tool is only for a
Windows client. You can download it from Download BI Desktop Tools in your OBIEE instance.

Oracle Business Intelligence URL.

Oracle Business Intelligence administrator username and password.

Oracle Fusion Middleware Enterprise Manager URL.

Oracle Fusion Middleware Enterprise Manager administrator username and password.
Oracle WebLogic Server Administrator Console URL.

Oracle WebLogic Server Administrator Console administrator username and password.
Server and file system access to the Oracle BI EE and WebLogic installation.

These software tools and installation instructions are available as downloads from
http:/ /www.oracle.com/technetwork.

Empirica Signal requirements

Empirica Signal release 7.3.3.3.360 or higher, installed and configured.

Empirica Signal product CD or product ZIP file from the Oracle Software Delivery Cloud.
Empirica Signal URL.

Empirica Signal administrator username and password.

Empirica Signal Topics feature, installed and configured.

Name of the topic workflow account.

Topic Workflow Configuration ID.

Server and file system access to the Empirica Signal application server.

For information on the topic workflow account created during the Empirica Signal installation, see section
2.1.3 in the Empirica Signal Windows 2003/ 2008 Server Installation and Upgrade Instructions, release 7.3.3 ot latet.
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1: Installation prerequisites

Note: Before you configure Oracle Business Intelligence for Topics reporting, you must ensure that you
have available the installation media that corresponds to the version of Empirica Signal that you have
installed. The Oracle Business Intelligence configuration procedures require files provided on the
installation media.
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2: Prepare the Empirica Signal data account

In this section, you create an Oracle BI EE database account for Empirica Signal Topics, and then populate
it with views that point to data items in your topic workflow.

Creating the Oracle Bl EE Topics database account
1. Extract the contents of the database.zip file on your Empirica Signal application server.

2. Remove the read-only flag, if it exists, and open the create_topics_user_obiee.sql file in a text
editort.

3. Verify that the following properties are set to the appropriate values for your environment, and edit the
values if necessary:

DEFINE TOPIC_WORKFLOW = "<topic workflow account>";
DEFINE SIGNAL = "<Signal account>";
DEFINE TABLESPACE = "<tablespace>";

4. Open a Command Prompt window and execute the create_topics_user_obiee._sql script as the
Oracle system user:

C:> sqlplus system@webvdme @ create_topics_user_obiee.sql
5. When prompted, enter the Oracle system account password.

A list of topic workflow configuration names and IDs appears.
6. When prompted, enter the target topic workflow configuration ID.

The script creates the OBIEE_<topic workflow account>_<topic workflow ID> database
account.

7. When prompted, choose and enter a password for the OBIEE_<topic workflow account>_<topic
workflow ID> database account.

The script completes, and creates the create_topics_user_obiee. log file.

Creating the Oracle Bl EE Topics views

1. On your Empirica Signal application server, locate the populate_obiee_topics.sql file in the
contents extracted from the database.zip file.

2. Remove the read-only flag, if it exists, and open the populate_obiee_topics.sql file in a text editor.

3. Verify that the following properties are set to the appropriate values for your environment, and edit the
values as necessary:

DEFINE TOPIC_WORKFLOW = "<topic workflow account>";
DEFINE SIGNAL = "<Signal account>" ;

4. Open a Command Prompt window and execute the populate_obiee_topics.sql script as the
database user created in step 6 in Creating the Oracle BI EE Topics database account:
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2: Prepare the Empirica Signal data account

C:> sqlplus OBIEE_<topic workflow account> <topic workflow I1D>@webvdme @
populate _obiee topics.sql

5. When prompted, enter the password for the OBIEE_<topic workflow account>_<topic workflow
ID> database account that you created in step 7 in Creating the Oracle BI EE Topics database account.

6. When prompted, enter the same topic workflow configuration ID that you entered in step 6 in Creating
the Oracle BI EE Topics database account.

The script completes and creates the populate_obiee_topics. log file.
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3: Configure Oracle BI EE Authentication

3: Configure Oracle Bl EE Authentication

You must install and configure the authentication plugin that allows you to access Topics reports in Oracle
BI EE using your Empirica Signal password.

Copying and extracting the authentication files

1.

On the Empirica Signal application server, generate a password for the obiee_auth.properties file:

a.

d.

Navigate to the following folder:
C:\Lincoln\apps\webvdme\bin
Double-click the obiee_auth_password.bat file.

The batch process inserts the password you choose into the obiee_auth.properties file in
encrypted form.

When prompted, enter and confirm the WebLogic user password.
A notification message appears, indicating that the password was written to the password property.

Press any key to continue.

Verity that properties are set to the correct values:

a.

Navigate to the following directory:
C:\Lincoln\apps\webvdme\lib
Open the obiee_auth._properties file.

Verity that the following properties are set to the appropriate values for your WebLogic server, and
edit the default values if necessary:

HOSTNAME=localhost
PORT=7000
USERNAME=weblogic

Perform the following steps:

Download and install the JCE7 strong encryption libraries from Oracle.
Unzip the UnlimitedJ CEPolicy] DK7.zip file.

Copy the following files to the jre/lib/security folder for the JDK that is used to run WebLogic on
the Oracle BI EE server:

local _policy.jar

us_export _policy. jar

Create a directory such as the following on the Oracle BI EE server:

/u0l/app/oracle/empiricaprovider

Copy the following files from your Empirica Signal application server to the directory you just created
(such as ZuO1/app/oracle/empiricaprovider) on the Oracle BI EE server:
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3: Configure Oracle BI EE Authentication

e license.config from the Lincoln\apps\webvdme\lib directory.
e obiee_auth.properties from the Lincoln\apps\webvdme\lib directory.
e ESAPI.properties from the Lincoln\apps\webvdme\lib directory.

e webvdme.properties from the Lincoln\apps\webvdme\webapps\web_ root\WEB-
INF\classes directory.

If the connect property in the webvdme.properties file refers to localhost, replace localhost
with the name of the server hosting the Empirica Signal application.

6. Locate the empiricaprovider<version>.zip file from the product ZIP file, and extract the
following files to the <WebLogic server>/server/lib/mbeantypes folder on the Oracle BI EE
server:

e ESAPI-1.4.4jar

e log4j-1.2.16.jar

® secure-coding<version>.jar

® empirica<version>.jar

e SignalTopicsCommon<version>.jar
e Signal<version>.jar

e cmpiricaprovider<version>.jar

7. Using cd, change the current working directory to the bin directory of the Oracle BI EE installation. For
example:

cd /uO0l/middleware/user_projects/domains/bifoundation_domain/bin

8. Stop WebLogic:
./stopWeblLogic.sh

9. Start WebLogic:
nohup ./startWebLogic.sh &

Creating a new Authentication Provider

1. Login to Oracle WebLogic Server Administration Console using your administrator username and
password.

You can access the server at http://<server>:<port>>/console.
2. In the Domain Structure pane, click Security Realms.

The Summary of Security Realms page appears.
3. In the Realms table, click myrealm.

The Settings for myrealm page appears.
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3: Configure Oracle BI EE Authentication

4. In the Change Center pane, click Lock & Edit.
Select the Providers tab, and select the Authentication subtab.
6. Click New.
The Create a New Authentication Provider page appears.
7. Specify the following:
e Name: Type EmpiricaAuthenticationProvider.
e Type: Select EmpiricaAuthenticator.
8. Click OK.
The authentication provider is created.
9. Click the new EmpiricaAuthenticationProvider link.
10. Change the Control Flag setting to REQUISITE.
11. Click Save.
12. Select the Provider Specific tab.
13. Change the Empirica Signal Application Root value to /Zu0O1/app/oracle/empiricaprovider.
14. Click Save.
15. At the top of the page, click the Providers link.
16. Click the Reorder button, and move EmpiricaAuthenticationProvider to the top of the list.
17. Click OK.
18. Click the DefaultAuthenticator link.
19. Change the Control Flag sctting to SUFFICIENT.
20. Click Save.
21. Click Activate Changes.

Verifying attribute information

1. Login to Oracle Fusion Middleware Enterprise Manager using your administrator username and
password.

You can access Oracle Fusion Middleware Enterprise Manager at http://<server>:<port>/em.
2. Expand the WebLogic Domain folder.
3. Right-click on the domain name, and select System MBean Browser.

The System MBean Browser opens.
4. In the System MBean Browser pane, expand the Configuration Mbeans folder.

Expand the Security folder.
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3: Configure Oracle BI EE Authentication

10.

11.
12.

13.

14.
15.

16.

17.

Click the myrealmEmpiricaAuthenticationProvider mbean.
The attributes appear.

On the Attributes tab, verify that the Value column for the EmpiricaSignal ApplicationRoot attribute
contains the /u01/app/oracle/empiricaprovider folder that you created in step 4 in Copying and
extracting the authentication files.

Edit the value if necessary, and click Apply.
Log out.

Log in to Oracle WebLogic Server Administration Console using your administrator username and
password.

You can access the server at http://<server>:<port>>/console.
In the Change Center pane, click Lock & Edit.

Make your Oracle BI EE usernames case-insensitive to ensure successful logins from the Empirica
Signal application:

a. In the Domain Structure pane, click the domain name, such as bifoundation_domain.
The Settings for <domain name> page appears.

b. Select the Security tab, and select the General tab, if it is not already selected.

c. At the bottom of the page, click Advanced.
Advanced options appear.

d. Select the Principal Equals Case Insensitive checkbox.

e. Click Save.
Your changes are saved.

For more information, see the following documentation:

http://docs.oracle.com/cd/E21764 _01/web.1111/e13707/domain._htm
In the Change Center pane, click Activate Changes.

Your changes are activated.

Log out.

Using cd, change the current working directory to the bin directory of the Oracle BI EE installation. For
example:

cd /uO0l/middleware/user_projects/domains/bifoundation_domain/bin
Stop WebLogic:

./stopWeblLogic.sh

Start WebLogic:

nohup ./startWebLogic.sh &
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4: Configure Empirica Signal

4: Configure Empirica Signal

In this section, you enable Oracle BI EE Topics reporting, assign permissions, and add the Oracle BI EE
URL to the webvdme.properties file.

Enabling the Oracle BI EE site setting
1. Log in to Empirica Signal as an administrator.
2. Click Settings.
The Settings page appears.
3. Click Set Site Options.
The Site Options page appears.
4. Select the Enable OBI EE Reporting checkbox.
Click Save.
Your changes are saved.

6. Log out.

Assigning permissions

You must assign the appropriate Oracle BI EE permissions to users who need access to the Topics reports.
The permissions provided in Empirica Signal correspond to the associated roles (BI Consumer, BI Author,
BI Administrator) in Oracle BI EE. You should assign the permissions to Empirica Signal users according
to their roles in Oracle BI EE.

Users must have at least the BI Consumer permission to view Topics reports in Oracle BI EE.
1. Login to Empirica Signal as an administrator.
2. Click Settings.
The Settings page appears.
3. Click Edit Users.
The Users page appears.
4. Click the Action menu icon next to a uset, and select Edit.
The Edit User page appears.
5. Click Assign Permissions.
The Permissions for User: page appears.
6. In the OBIEE Reporting section, select the appropriate BI permission.
7. Click Save.

Your changes are saved.
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4: Configure Empirica Signal

Modifying the webvdme.properties file

1
2
3.
4

Log in to the Empirica Signal application server.

Navigate to the C:\Lincoln\apps\webvdme\webapps\web_root\WEB-INF\classes directory.
Open the webvdme .properties file.

Add the following:

reportingURL=http://<server>:<port>/analytics

replacing <server> and <port> with the appropriate values for your Oracle BI EE instance.

Run the set_permissions.bat file.

e Tor Windows 2008, right-click on the set_permissions.bat file, and then select Run as
administrator.

Or

e For Windows 2003, double-click the set_permissions.bat file.

Restart the Empirica Signal application server.
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5: Install and configure sample reports

5:

Install and configure sample reports

In this step, you configure Oracle BI EE to point to the topic workflow data, and then upload predefined
sample reports.

Updating the RPD connection pool

1.

A

10.
11.

12.

13.
14.

15.

Open the Oracle BI Developer Client Tool on the Windows client where it is installed.

a. Select Start > All Programs.

b. Select Oracle Business Intelligence Enterprise Edition Plus Client > Administration.
Select File > Open > Offline.

A dialog box opens.

Click Browse, and navigate to the OBIEE_Reporting folder on the product ZIP file.

Select twc_repository.rpd.

Click Open.

When prompted, enter the repository password. Oracle provides a default password of abc123.
Select File > Change Password.

The Change Repository Password dialog box opens.

Specity the default password of abc123 in the Old Password field.

Specity and confirm a new password for the repository.

Click OK.

In the Physical pane, expand the TWC node.

The TWC subnode appears.

Right-click on the TWC subnode, and select Properties.

The Connection Pool — TWC dialog box opens.

Click the General tab if it is not already selected.

Edit the following:

a. In the Data source name field, specify the entire connection string for your Empirica Signal Topics
database server.

If you choose to enter the net service name as defined in the tnsnames.ora file, see the associated
documentation at:

http://docs.oracle.com/cd/E17904 _01/bi.1111/e10540/deploy_rpd.htm#CHDJIDIJI
b. In the User name and Password fields, enter the username and password of the Oracle BI EE
database account that you created in 2: Prepare the Empirica Signal data account.
Click OK.
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5: Install and configure sample reports

16.

17.

18.
19.

20.

When prompted, confirm the password, and then click OK.

The Connection Pool — TWC dialog box closes.

Select Tools > Update All Row Counts to test the connection to your BI Server.
e If successful, row counts are available on the Physical pane.

e [f unsuccessful, an error occurs. To troubleshoot, check your database settings.
Select File > Save.

When prompted to check for global consistency, click No.

Your changes are saved.

Select File > Close, and sclect File > Exit.

The Oracle BI Developer Client Tool closes.

Uploading the RPD file

1.

10.
11.

Log in to Oracle Fusion Middleware Enterprise Manager using the administrator username and
password.

You can access the server at http://<server name>:<port>/em.

In the left pane, expand the Business Intelligence folder, and click coreapplication.

The coreapplication page appears.

Click the Deployment tab, and click the Repository subtab.

Click Lock and Edit Configuration above the Capacity Management tab.

A confirmation message appears.

Click Close.

In the Upload BI Server Repository section, click Browse next to the Repository File field.
The Choose File to Upload dialog box opens.

Navigate to the twc_repository.rpd file you saved in step 18 in Updating the RPD connection pool.

Select the twe_repository.rpd file, and then click Open.
The Choose File to Upload dialog box closes.

Specify and confirm the repository password in the Repository Password field and the Confirm
Password field using the password that you chose in step 9 in Updating the RPD connection pool.

Click Apply in the top-right corner of the BI Server Repository section.
Click Activate Changes above the Capacity Management tab.

A confirmation message appears.
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5: Install and configure sample reports

12. Click Close.

13. Restart Oracle Fusion Middleware:

a. Click the Overview tab.

b. In the System Shutdown & Startup section, click Restart.
A confirmation message appears.

c. Click Yes.
A confirmation dialog box appears.

d. Click Close.

14. Log out.

Deploying the web catalog file

1.

Log in to Oracle BI EE using an Empirica Signal superuser username and password.
You can access Oracle Bl EE at http://<server name>:<port>/analytics.
Click Catalog under the Search field at the top of your screen.

The Catalog tab appears.

In the top-most portion of the left pane, select Shared Folders.

In the Tasks section of the left pane, click Unarchive.

The Unarchive dialog box opens.

Click Browse next to the Archive file field.

The File Upload dialog box opens.

Navigate to the OBIEE_Reporting folder in the product ZIP file.

Select the twe_repository.catalog file, and click Open.

Specify the following:

Replace: All

ACL: Inherit

Click OK.

The web catalog file is deployed.

10. Log out.

Testing Topics reports in Oracle Bl EE

When you have completed all configuration steps, you should test the predefined Topics reports in Oracle
BI EE to ensure the configuration was successful.

1.

Log in to the Empirica Signal application.
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5: Install and configure sample reports

2. Click the Topics tab.
The Topics page appears.

3. Click Report.
The Oracle BI EE login page appears.

4. Log in to Oracle BI EE using your Empirica Signal username and password.
The Topics dashboard appears.

Note: If your organization has implemented the single sign-on feature, you must log in to Oracle BI EE
using your Empirica Signal username and password. You cannot log in to Oracle BI EE from Empirica
Signal using your single sign-on username and password.

If the Topics Dashboard does not appear, do the following to access Topics reports:
1. Click Catalog at the top of the page.
The Catalog tab appears.
2. In the Folders pane, expand Shared Folders.
Expand the Topics subfolder.
4. Expand My Dashboard, and then click Topics.
Topics reports appeat.

5. Click Open next to a report to open it.
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A: Upgrading OBIEE

A: Upgrading OBIEE

Upgrading OBIEE consists of the following tasks:

e Upgrading the OBIEE Topics views.
e Upgrading the Empirica Authenticator.
e Updating the RPD file and redeploying the web catalog file.

Upgrading the OBIEE Topics views

The Empirica Signal upgrade references the topic workflow configuration used before the upgrade;
however, you must refresh the views in it.

1. Identify the topic workflow account used by the previous version of the Empirica Authenticator for
Empirica Signal release 7.3. This account often has the name of the form

OBIEE_TOPIC_WORKFLOW_n, where n represents the topic workflow configuration ID of the
targeted topic workflow configuration.

2. Obtain the Oracle database password for this account.

3. On the Empirica Signal application server, in the contents extracted from the Database. zip file, locate
the populate_obiee_topics.sql file.

4. Open the populate_obiee_topics.sql file in a text editor.

5. Verify that the following properties are set to the appropriate values for your environment, editing the
values as necessary:

DEFINE TOPIC_WORKFLOW = "<topic workflow account>";
DEFINE SIGNAL = "<Signal account>";

6. Open a command prompt window, and use the following command to execute the
populate_obiee_topics.sql script as the database user identified in step 1:

sqlplus OBIEE_TOPIC WORKFLOW n@<TNS_Name> @populate_obiee_ topics.sql
7. When prompted, type the password for the OBIEE_TOPIC_WORKFLOW_n.

8. When prompted, type the same topic workflow configuration ID, which is the n value from step 1.

Upgrading the Empirica Authenticator

1. Login to Oracle WebLogic Server Administration Console using your administrator username and
password.

You can access the server at http://<server>:<port>/console.

2. In the Domain Structure pane, select Security Realms.
The Summary of Security Realms page appears.
3. In the Realms table, click myrealm.

The Settings for myrealm page appears.
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10.
11.
12.
13.
14.

15.
16.

17.

18.

In the Change Center pane, click Lock & Edit.
Select the Providers tab, and select the Authentication subtab.

Click the EmpiricaAuthenticationProvider link, and change the Control Flag value to
REQUISITE.

Click Save.
Click the Providers link at the top of the page.

Click the DefaultAuthenticator link, and change the Control Flag value to SUFFICIENT, if it is not
already set to this value.

Click Save.

Click the Activate Changes button, and log out of the WebLogic Console.
Stop all of the OBIEE server processes.

If possible, reboot the server hosting OBIEE.

Locate the empiricaprovider directory on the OBIEE server, often located at
/u0l/oracle/empiricaprovider.

Locate the <WebLogic server>/server/lib/mbeantypesdirectory on the OBIEE server.
Replace the following files in the mbeantypes directory:

e ESAPI-1.4.4jar

e log4j-1.2.16.jar

® secure-coding<version>.jar

e empirica<version>.jar

e SignalTopicsCommon<version>.jar

e Signal<version>.jar

e cmpiricaprovider<version>.jar

If the webvdme . properties file used by the Signal installation has changed, copy
webvdme . properties used by the Empirica Signal application to the
/u0l/app/oracle/empiricaprovider directory.

Restart OBIEE.

Updating the RPD file and re-deploying the web catalog file

Empirica Signal upgrades include updated versions of the OBIEE RPD and web catalog files. You must
upload the updated RPD file and redeploy the web catalog file after upgrading your Empirica Signal
installation.

If you modified your web catalog file by adding new reportts, the new reports are preserved.
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e If you modified your web catalog file by editing existing reports, the upgrade overwrites your report
modifications. Contact Oracle for assistance to avoid losing modifications to existing reports.

For information about upgrading the RPD file, see Updating the RPD connection pool and Uploading the
RPD file.

To upgrade the web catalog:
1. Log in to OBIEE using an Empirica Signal superuser account.
2. Make a backup copy of the web catalog file:
a. At the top of the page, under the Search field, click Catalog.
The Catalog tab appears.
b. In the Folders pane on the left, expand Shared Folders.

c. Under Shared Folders, sclect Topics, and in the Tasks pane in the lower-left corner, click
Archive.

d. In the popup window, click OK.
e. In the popup window, select Save File, and click OK.
f.  Choose a location on your local file system, and click Save.
In the Folders pane on the left, select Shared Folders.
4. In the Tasks pane in the lower-left corner, click Unarchive.
The Unarchive dialog box opens.
5. Next to the Archive file field, click Browse.
The File Upload dialog box opens.
6. Navigate to the OBIEE_Reporting folder in the product ZIP file.
7. Select the twc_repository.catalog file, and click Open.
8. Specify the following:
e Replace: All
e ACL: Inherit
9. Click OK.
The web catalog file is deployed.
10. Log out.
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