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Preface 
Oracle's Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle Technology 

Network (OTN) Web site http://www.oracle.com/technetwork/documentation/agile-085940.html 
contains the latest versions of the Agile PLM PDF files. You can view or download these manuals 
from the Web site, or you can ask your Agile administrator if there is an Agile PLM Documentation 
folder available on your network from which you can access the Agile PLM documentation (PDF) 
files. 

Note To read the PDF files, you must use the free Adobe Acrobat Reader version 9.0 or later. 
This program can be downloaded from the Adobe Web site http://www.adobe.com. 

The Oracle Technology Network (OTN) Web site 
http://www.oracle.com/technetwork/documentation/agile-085940.html can be accessed through Help 
> Manuals in both Agile Web Client and Agile Java Client. If you need additional assistance or 
information, please contact My Oracle Support (https://support.oracle.com) for assistance. 

Note Before calling Oracle Support about a problem with an Agile PLM manual, please have 
the full part number, which is located on the title page. 

TTY Access to Oracle Support Services 

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479. 

Readme 

Any last-minute information about Agile PLM can be found in the Readme file on the Oracle 

Technology Network (OTN) Web site http://www.oracle.com/technetwork/documentation/agile-
085940.html. 

Agile Training Aids 

Go to the Oracle University Web page 
http://www.oracle.com/education/chooser/selectcountry_new.html for more information on Agile 
Training offerings. 

Accessibility of Code Examples in Documentation  

Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise empty line; 
however, some screen readers may not always read a line of text that consists solely of a bracket or 
brace.  

This documentation may contain links to Web sites of other companies or organizations that Oracle 
does not own or control. Oracle neither evaluates nor makes any representations regarding the 
accessibility of these Web sites.  

http://www.oracle.com/technetwork/documentation/agile-085940.html
http://www.adobe.com/
http://www.oracle.com/technetwork/documentation/agile-085940.html
https://support.oracle.com/
http://www.oracle.com/technetwork/documentation/agile-085940.html
http://www.oracle.com/technetwork/documentation/agile-085940.html
http://www.oracle.com/education/chooser/selectcountry_new.html
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Chapter 1 

Introduction 

This chapter includes the following: 

 About this Guide .................................................................................................................................................. 1 
 Overview of Agile Product Lifecycle Management Data Mapping ....................................................................... 3 
 Overview of Agile PLM for Process Extensibility ................................................................................................. 4 
 The Agile PLM Oracle PLA Configurator ............................................................................................................. 4 
 What's New for Oracle PLA Configurator in this Release .................................................................................... 5 

 

In order to support enterprise reporting and analysis needs, accurate operational data 
encompassing millions of product records must be made available for use within analytics 
applications. This data must be organized and formatted in meaningful ways to support different 
query modes and ensure that business users derive the right information for decision making.  

Typically, Extract-Transform-Load (ETL) processes are used to reorganize source data before 
loading it into the target system. Field-level data mappings need to be carried out to resolve any 
differences in the field names.  

 

 
 

About this Guide 

This document is intended for data warehouse administrators who are familiar with Agile Product 
Lifecycle Management 9.x application (Agile PLM 9) and Agile PLM for Process application 
administrators who have database warehousing skills. 
 
 
 
 
 

Acronyms Used in This Document 

The table below lists the acronyms used in this document. 
 
 

Acronym Expansion  

BI Business Intelligence 

CAPA Corrective and Preventive Action 



Configurator and Data Mapping Guide  

 

 

2 Oracle Product Lifecycle Analytics 

  

Acronym Expansion  

CRM Customer Relationship Management 

DM Data Mart 

ECO Engineering Change Order 

ECR Engineering Change Request 

ETL Extract-Transform-Load 

FS Fact Staging 

MCO Manufacturing Change Order 

MDS Multi-Dimensional Schema 

NCR Non-Conformance Report 

OBIEE Oracle Business Intelligence Enterprise Edition 

ODI Oracle Data Integrator 

ODM Operational Data Mart 

Oracle PLA Oracle Product Lifecycle Analytics 

PLM Product Lifecycle Management 

PLM BI Product Lifecycle Management Business Intelligence 

PLM DM Product Lifecycle Management Data Mart 

PPM Product Portfolio Management 

PQM Product Quality Management 

PR Problem Report 

SCM Supply Chain Management 
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Acronym Expansion  

SS Stop Ship 

 

 

 
 

Related Documentation 

The documents that you may need to reference during the data mapping process, mainly the Oracle 
Product Lifecycle Analytics (Oracle PLA) product installation documentation and the database 
schema documentation, are available on Oracle Technology Network 
(http://www.oracle.com/technology/documentation/agile.html). 
 

 Oracle Product Lifecycle Analytics Setup Guide - Describes the installation and deployment of 
BI product components. 
 

 Oracle Product Lifecycle Analytics Data Reference Manual - Describes the entities of the 
published model of the MDS schema. 
 

 Oracle Product Lifecycle Analytics User Guide - Oracle PLA helps you to analyze business 
data, assess business impact, make timely decisions, and conduct trend analysis. 

 

 

 
 

Overview of Agile Product Lifecycle Management Data 
Mapping 

 
The Oracle Product Lifecycle Analytics (Oracle PLA) application queries data for reports and 
dashboards from the Multi-Dimensional Schema (MDS) database. The MDS database schema 
contains a set of tables and columns to support PLM business reporting and analytics requirements. 
The data for this MDS schema is sourced from Agile Product Lifecycle Management (Agile PLM). 

 

You define fields in Agile PLM according to your business process requirements. The Oracle 
Product Lifecycle Analytics application retrieves accurate field data for analysis only if the data in 
the MDS fields and the data in the Agile PLM fields are synchronized. Additionally, you should map 
the source custom-defined fields (Page Two and Page Three) of Agile PLM business objects.   

http://www.oracle.com/technology/documentation/agile.html
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Data type mapping is available in all three models - PC, PQM, and PPM. 
 
 

Note For more information on Oracle Product Lifecycle Analytics architecture, see the Oracle 
Product Lifecycle Analytics Installation and Setup Guide. 

 

 
 

Overview of Agile PLM for Process Extensibility 

Oracle Product Lifecycle Analytics (Oracle PLA) solution framework for Agile PLM for Process 
source allows you to customize and extend the out-of-the-box solution by providing configuration 
and customization capabilities.  
 
 

Data flows from Agile PLM for Process to the presentation layer within Oracle PLA happens in the 
following order: 
 

1. Source to Staging 
 

2. Staging to Multi-Dimensional Schema (MDS) 
 

3. MDS to the presentation layer of the OBIEE repository 

 

 
 

The Agile PLM Oracle PLA Configurator 

The Oracle PLA Configurator tool allows you to map attributes from the Agile PLM application to 
fields in the data layer of the Oracle Product Lifecycle Analytics application. With an easy-to-use 
graphical interface, the Oracle PLA Configurator simplifies the process of mapping fields from Agile 
PLM to the tables and columns in the MDS database schema. These saved field-level mappings 
are used by the ETL process to load data into the target MDS database schema. 
 
 

Note When you open an object in the Agile PLM Web Client or Java Client, you see a tabbed 
window with fields. In Agile PLM these fields are called attributes. For complete 
information on Agile PLM attributes, refer to the Agile Administrator Guide. 
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Important The Oracle PLA Configurator tool is used only for Agile PLM application data 
mapping. 

 

 

 
 

What's New for Oracle PLA Configurator in this 
Release 

From this release the Oracle PLA Configurator supports the following languages: 

 English 

 French 

 German 

 Italian 

 Japanese 

 Simplified Chinese 

 Traditional Chinese 

 

To learn more about enabling localization, see the "Enabling Localization" section in the Oracle PLA 
Installation and Setup Guide. 
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Chapter 2 

Mapping the Agile Product Lifecycle 
Management Data 

This chapter includes the following: 

 Data Mapping Process ........................................................................................................................................ 7 
 What's Configurable in Agile PLM ....................................................................................................................... 8 
 Mappings Supported in this Release ................................................................................................................... 10 

 
 
This chapter relates to Agile PLM for information on configuration (attribute mapping) related to 
Agile PLM for Process see  Extending the Agile PLM for Process Data on page 49. 
 
 

 
 

Data Mapping Process 

The Oracle PLA Configurator’s configuration capabilities includes the mapping of Cover Page, Page 
Two, Page Three, and Flex attributes of supported Agile PLM classes, as follows: 
 

 MDS fact fields to Agile PLM source fields. 
 

 MDS dimension fields to Agile PLM source lists that are assigned to the Agile PLM fields. 
 

Data accessed by the tool is located in the MDS and ODM database tables. 
 
 
 
 

Important Any changes to the Data Dictionary definitions in Agile Oracle PLA staging schema or 
MDS impacts the tool.  
 
Please refer to the latest published model as documented in the relevant Data 
Reference Manual available on the Oracle Technology Network. 

 
 
 

The Oracle Product Lifecycle Analytics reports derive data from fixed target columns within the 
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database tables. Using the Oracle PLA Configurator, the data elements (in the fixed target columns) 
are mapped to the source columns. Data is derived from these source columns. 

For these changes to take effect, you must perform the following actions in the order given:   
 

1. Before you start mapping, at least one successful completion of a Stage ETL run. 
 

2. After you finish mapping, at least one successful ETL run on MDS. 
 

Note The Oracle PLA Configurator is purely a mapping tool. Data is retrieved and updated 
through the ETL processes. If there is any configuration mapping changes, MDS ETL is 
automatically set to Full Load. When you change the PLM version, set MDS ETL to Full 
Load by using ETL Configurations > Runtime Options. 

 

 

 
 

What's Configurable in Agile PLM 

The MDS has three field types: 
 

1. Main fields (Not configurable) - These fields correspond to an object's Cover Page attributes in the 
Agile PLM application. Some Cover Page attributes, such as multi-text fields, are not relevant 
for analysis and are excluded from the MDS. Since these fields have a predefined meaning 
they are embedded in the OBIEE model and used to compute relevant predefined metrics.  

These are exposed in the presentation layer of the model as measures and dimensions. 
Reports created using these measures and dimensions are embedded in the out-of-the-box 
role-based and functional dashboards. 
 

2. Defined extensions (Configurable) - Defined extension fields in each fact or subject area capture 
important information about the subject area. They have predefined semantics and in Agile 
PLM are configurable to the Cover Page, Page Two, Page Three, and flex attributes. Out-of-
the-box, they are not mapped to any Agile PLM attribute. These defined fields are mapped as 
dimensions and measures in the OBIEE model. 
 

3. User-defined extensions (Configurable) - User-Defined extension fields in each fact or subject area 
are used to capture important information about the subject area. They have predefined 
semantics, and in Agile PLM are configurable to the Cover Page, Page Two, Page Three, and 
flex attributes. Out-of-the-box, they are not mapped to any Agile PLM attribute. If you want to 
use these fields you need to customize the model. Contact your Oracle PLA administrator for 
further information. 

 



 Chapter 2: Mapping the Agile Product Lifecycle Management Data 

 

 

 9  

  

 

 

 

 

The figure above illustrates the following: 
 

1. How each type of MDS field is mapped from one layer to the next. 
 

2. Shows the field that you can configure or customize. 
 

Note Use the OBIEE Admin features for additional configuration and customization. 
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Mappings Supported in this Release 

The table below shows the data sources for the target MDS tables.  The Target Fact Table column 
lists the target MDS table name. The Classes column lists the attribute groups (from where the data 
is sourced). 
 
 

Target  Fact  
Table  

Classes Subclasses  Supported  Source At t r ibute  Groups  

Core Fact 
Table 

 

 PR 

 NCR 

 CAPA 

 Change Orders 

 Change Requests 

 Manufacturing 
Change Orders 

 Stop Ship 

 Deviations 
 

 

 Cover Page, Page Two attributes, Page Three 
attributes of subclasses 

 Flex attributes 

 Mfr Part 

 Mfr 
 

 Cover Page attributes, Page Two attributes, 
Page Three attributes of subclasses 

 Flex attributes 

 Item Mfr Part 

 Item Product 
Performance 

 

 Item AML flex attributes 

 Read through of dimensions configured on 
Item facts and Mfr Part fact 

Gate  

 Cover Page attributes, Page Two attributes, 
Page Three attributes of Gate subclasses 
configured as Gate domain. 

 Gate subclass Flex attributes 

 Team tab P3 and Flex attributes 
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Target  Fact  
Table  

Classes Subclasses  Supported  Source At t r ibute  Groups  

Activity 

 Program 

 Project 

 Phase 

 Portfolio 

 Cover Page attributes, Page Two attributes, 
Page Three attributes of Activity subclasses 
configured as different domain values. 

 Activity subclass Flex attributes 

 Team tab P3 and Flex attributes 

 

For every supported domain (Program, Portfolio 
and Phase), you can map only the subclasses 
that are configured as domain attributes. 

Affected Item 
Fact Table 

 PR 

 NCR 

 CAPA,  

 Audit, ECO 

 ECR 

 MCO 

 SS 

 Deviations 

 

All Attributes configured on the Affected Item tab.  

 

Note Excludes Item read-through attributes. 

Single 
Materialized 
view 
consisting of  
subclass 

 Audit 

 CAPA 

 NCR 

 PR 

 Change Order  

 Engineering Change 
Request  

 Manufacturing 
Change 

 Stop Ship 

 Deviations 

 
Read through of dimensions configured on Item 
facts, subclass facts 
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PPM-Specific Mappings 

The table below describes how the Oracle Product Lifecycle Analytics Configurator (Oracle PLA 
Configurator) provides mapping ability to Agile PLM Product Portfolio Management (PPM) source 
data. 
 
 

OPLA Conf igurator  MDS Target  tab le  

Conf igurator  
Subject  Area  

Mapping Descr ipt ion  Fact  Table  Dimension Table  

Portfolio 

Oracle PLA Configurator 
provides the ability to map 
Cover Page/P2/P3/Flex 
attribute of any Activity 
subclass. Choose the 
attributes relevant to the 
Portfolio domain subclasses as 
configured in domain look up. 

Portfolio fact: 

PPM_PORTFOLIO
_F 

Portfolio Dimensional 
attribute:  

PPM_PORTFOLIO_D 

Program 

Oracle PLA Configurator 
provides the ability to map 
Cover Page /P2/P3/Flex 
attribute of any Activity 
subclass. Choose the 
attributes relevant to the 
Program domain subclasses 
as configured in domain look 
up. 

Program fact: 

PPM_PROGRAM_F 

Program Dimensional 
attribute: 

PPM_PROGRAM_D 
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OPLA Conf igurator  MDS Target  tab le  

Conf igurator  
Subject  Area  

Mapping Descr ipt ion  Fact  Table  Dimension Table  

Project 

Oracle PLA Configurator 
provides the ability to map 
Cover Page /P2/P3/Flex 
attribute of any Activity 
subclass. Choose the 
attributes relevant to Activities 
subclasses that are considered 
as Projects according to the 
Phase domain configured in 
domain value lookup. 

Project Summary fact: 

PPM_PRJ_SUM_F 

The Project dimensional 
attribute: 

PPM_PROJECT_D 

Phase 

Oracle PLA Configurator 
provides the ability to map 
Cover Page /P2/P3/Flex 
attribute of any Activity 
subclass. Choose the 
attributes relevant to the Phase 
domain subclasses as 
configured in domain look up. 

Phase Gate fact: 

PPM_PHASE_GAT
E_F 

Phase dimensional 
attribute: 

PPM_PHASE_D 

Activity 

OPLA Configurator provides 
the ability to map Cover Page 
/P2/P3/Flex attribute of any 
Activity subclass. Also, the P3 
and Flex attributes of Team 
tab. 

Activity base fact: 

PPM_ACTIVITY_
F 

Activity dimensional 
attribute: 

PPM_ACTIVITY_D 
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OPLA Conf igurator  MDS Target  tab le  

Conf igurator  
Subject  Area  

Mapping Descr ipt ion  Fact  Table  Dimension Table  

Gate 

Oracle PLA Configurator 
provides the ability to map 
Cover Page /P2/P3/Flex 
attribute of any Gate subclass. 
Also, the P3 and Flex attributes 
of Team tab. 

Choose the attributes relevant 
to the Decision Gate domain 
subclasses as configured in 
domain look up or any Gate 
subclass if you are planning to 
bring it across to Detailed 
areas 

Phase Gate fact: 

PPM_PHASE_GAT
E_F 

Gate dimensional 
attribute: 

PPM_GATE_D 

 

 

 
 

Supported Data Types 

The table below lists the supported data type mappings. 
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Target :   MDS Table/Column Type  Source:   Agi le  PLM Att r ibute  Type  

Dimension 

 List 
 

 Multi-list 
 

 Cascade 
 

 Single-select dynamic list 
 

Note Cascade lists are not supported for the PPM module 
in Oracle Product Lifecycle Analytics Release 3.3. 

Bridge 

 Multi-list 
 

 Multi-list cascade 
 

 Multi-list dynamic 

Date Date 

Number Number 

Float Money 

Text Alphanumeric text 

Money Also known as Cost 
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Chapter 3 

Using the MDS Configurator 

This chapter includes the following: 

 Key Features ....................................................................................................................................................... 17 
 Accessing the Software ....................................................................................................................................... 34 
 Running the Oracle Product Lifecycle Analytics Configurator ............................................................................. 36 
 Execute the Staging ETL from the ODI ............................................................................................................... 36 
 Mapping PLM Attributes ...................................................................................................................................... 40 
 Executing the MDS ETL for ODI 10g ................................................................................................................... 44 
 Executing the MDS ETL for ODI 11g ................................................................................................................... 45 

 

 

This chapter relates to Agile PLM for information on configuration (attribute mapping) related to 
Agile PLM for Process see Extending the Agile PLM for Process Data on page 49. 

 

 
 
 

Key Features 

The Oracle Product Lifecycle Analytics (Oracle PLA) Configurator interface consists of the following 
two basic panes:  
 

1. Subject Area pane - Displays the Agile PLM module and its subject areas. It is located on the left-
hand-side of the Oracle PLA Configurator. 
 

2. Mapping Table pane - Displays the target and source destinations for all the PLM attributes that 
can be configured.  It is located on the right-hand-side of the Oracle PLA Configurator. 
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You can customize the default values for the Subject Area pane and the Mapping Table pane as 
per your requirements. 

For more information on how to customize the default values, see Customizing the Interface on 
page 21. 

 

 
 

Understanding the Subject Area Pane 

A Subject Area is a group of configurable fact tables in the MDS schema. These configurable fact 
tables correspond to subject areas of PLM Analytics modules within the Oracle Product Lifecycle 
Analytics (Oracle PLA). 

The Subject Area pane has a hierarchical tree structure. The first level shows the Agile PLM module 
name, and the second level shows the supported subject areas for that module. 
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Each subject area can be associated with one or more Fact types. Each fact type appears as a tab 
on the right pane, where its corresponding attributes are displayed. 

 

Note In Product Portfolio Management, for the Program, Phase and Portfolio subject areas, 
the Cover page, Page Two, and Page Three attributes specific to the corresponding 
domains appear on the right pane. For example, the Phase subject area displays only 
the Phase-specific P3 attributes. For Gate, Activity and Project subject areas, the P3 
attributes of all the subclasses are displayed. 
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Understanding the Mapping Table Pane 

In the Oracle PLA Configurator the right side shows the Mapping Table pane.  It is a fact table 
where the target and source information is displayed.  
 
 
 

Some tips on the Mapping Table pane: 
 

1. Some target values are auto-populated.  
 

2. Source data for each row needs to be selected manually from the options provided.  
 

3. Target columns show the target field name and dimension table where applicable.  
 

4. User-defined fields are prefixed with 'USR_DEF'. 
 

 

Column Descr ipt ion  

Target Column 
Column name within the Fact table in MDS schema to which the PLM 
Attribute is mapped. 

Mappable PLM Attribute Type 
Type of PLM Attribute (or Field) that can be mapped to the corresponding 
column in the Fact table. Possible Values: Number, Date, List, Multi-list, and 
Money. 

PLM Attribute Name 
Name of the PLM Attribute (or Field) that is mapped to the corresponding 
column in the Fact table. 

Target Dimension Table 

Name of the dimension table in the target MDS schema. It is used only if 
the PLM Attribute Type is "List" or "Multi-List". 
 

Note The user cannot change the Target Dimension Tables for the user-
defined "List" attributes of PPM, as all the user-defined columns for 
PPM are maintained in a single dimension table. Refer Oracle Product 
Lifecycle Analytics Data Reference Manual for the database tables.  
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Column Descr ipt ion  

Target Map Table 
Name of the bridge table in the target MDS schema. It is used only if the 
PLM Attribute Type is "Multi-List". 

 

 

 
 

Customizing the Interface 

You can customize the data elements (in the user interface) to suit your requirements. The 
customizable settings are described in the table below.  

 

Note All configuration files are located at <install directory>\config.  

 

 

To conf igure  the  fo l lowing set t ings  Edi t  the  fo l lowing f i le  

User Interface button names Messages_en_US.properties 

Table column headers Messages_en_US.properties 

Logging levels log4j.properties 
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Display Preferences 

To display the Preferences dialog box, select Tools > Preferences. The Preferences dialog box 
controls how table and column categories appear based on their status (valid, invalid, undefined, or 
nonresistant). 

 

 

 

For each category and its status, you can select the icon that is associated with the category, the 
color of the font, and determine if the category should be hidden. The preferences are saved to the 
Settings.xml file and will appear the next time you start DataLoad. You can copy the Settings.xml file 
to other computers so that DataLoad uses the same preferences. 

 

 

Setting the Display Preferences 

 
To set the display preferences: 
 

1. Click Options > Preferences. 
 

2. Select the attribute types you want displayed in the right pane. 
 

3. Click Save. 
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Note To view the Source columns corresponding to the displayed Target columns in the right 
pane, select Run in Debug mode. 

 

 

 
 

Extend User-Defined (Configurable) Fields 

You can increase the number of the available user-defined (configurable) fields in the schema. 

You can add columns to enhance the MDS Schema if the available user-defined configurable fields 
in the tables are not sufficient to accommodate your business requirements.  

 

The supported attribute types are:  
 

 Date 

 List 

 Multi List 

 Number 

 Money or Cost 

 Text 

 

 

 

 
 

Adding New User-Defined Columns in the MDS Schema 

 

To add new user-defined columns in the MDS Schema: 
 
 

1. Click Options > Add user-defined Fields. The Schema Enhancer dialog box appears. 
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The Schema Enhancer dialog box lists the tables that have Date, List, Number, Money, Multi-List, 
and Text columns and the count of each of these columns for every table. 
 
 

2. In the New columns cell, enter the number of additional columns of the attribute type you need 
in the table. 
 
 

3. Click Generate SQL File to generate the SQL script that enables you to alter the tables to include 
the additional columns. 
 
 

4. Save the generated file with a .sql extension. 
 
 

5. Run the generated SQL file manually on the MDS database schema user, to include the 
additional user-defined columns in the specific table. The Oracle PLA Configurator displays the 
new columns as rows. 
 
 

Note Select Generate Revoke File checkbox to generate a script that retains the existing table 
structure. If you want to reverse the addition of new fields, execute the revoke file. 

 

 

You can associate PPM sub classes with domains such as Portfolio, Program, Project, and Phase. 
Agile PPM allows you to create multiple sub classes within the Activity class. You can associate 
more than one of these sub classes to a specific domain. The differentiation of the attributes 
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specific to each of these similar sub classes requires the addition of Fact Staging (FS) tables in the 
schema design. Refer to the Oracle Product Lifecycle Analytics Data Reference Manual for 
information. 

The ETL propagates data from the Source to the FS tables and then to the target Fact tables. The 
Schema Enhancer generates scripts to create additional columns for Fact tables, FS tables, and 
Dimension tables. It also generates appropriate meta data information for the Dictionary table. 
 
 
 

 
 

Adding User-Defined Dimension Tables to the Schema 

You can manually add new user-defined dimension tables to the MDS schema if the available 
dimension tables are not sufficient to accommodate your business requirements. 

 

To add new user-defined dimension tables to the schema: 
 

1. Using the structure given below, you can create new dimension tables in the MDS Schema: 
 

CREATE TABLE USRDEF_L<xxx>_D 

( 

  USRDEF_L<XXX>_ID    NUMBER(22)          NOT NULL, 

  NAME                VARCHAR2(4000 CHAR)  NOT NULL, 

  LEVEL0              NUMBER(22), 

  LEVEL1              NUMBER(22), 

  LEVEL2              NUMBER(22), 

  LEVEL3              NUMBER(22), 

  LEVEL4              NUMBER(22), 

  LEVEL0_NAME         VARCHAR2(256 CHAR), 

  LEVEL1_NAME         VARCHAR2(256 CHAR), 

  LEVEL2_NAME         VARCHAR2(256 CHAR), 

  LEVEL3_NAME         VARCHAR2(256 CHAR), 

  LEVEL4_NAME         VARCHAR2(256 CHAR), 

  USRDEF_TEXT0        VARCHAR2(256 CHAR), 

  USRDEF_TEXT1        VARCHAR2(256 CHAR), 

  USRDEF_TEXT2        VARCHAR2(256 CHAR), 

  USRDEF_DATE0        DATE, 

  USRDEF_DATE1        DATE, 

  USRDEF_DATE2        DATE, 
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  USRDEF_NUMBER0      NUMBER, 

  USRDEF_NUMBER1      NUMBER, 

  USRDEF_NUMBER2      NUMBER, 

  LAST_MODIFIED_DATE  DATE, 

  LIST_ID             NUMBER(22), 

  ENABLE              NUMBER(1)             DEFAULT 1, 

  INTEGRATION_ID      VARCHAR2(80 CHAR), 

  ROW_ID              NUMBER(22), 

  DATASOURCE_NUM_ID   NUMBER(22) 

) 
 
 

 

Note The table is named in the following format: 
 
 USRDEF_ XXX  
 
Where XXX represents the dimension table name. 

 

 

2. Add the newly created table name as an XML element into <installdir>\config\Configurator.xml  
 

<usrdimensionTables> 

<!—Existing entries 

 <list name="USRDEF_L01_D" dimcol="USRDEF_L01_ID"/> 

<list name="USRDEF_L02_D" dimcol="USRDEF_L02_ID"/> 

 <list name="USRDEF_L03_D" dimcol="USRDEF_L03_ID"/> 

<!—New Entry--> 

<list name=" USRDEF_L<xxx>_D " dimcol=" USRDEF_L<XXX>_ID"/> 

</usrdimensionTables> 

 

 

3. Save the Configurator.xml file. 
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Setting Up the ETL Run Time Configuration 

PPM provides a flexible project management platform to organize your projects in a way that suits 
your business and operations. However, to obtain meaningful analytical reports on your projects, 
Oracle Product Lifecycle Analytics (Oracle PLA) recommends that you organize your projects 
according to structured templates. These templates are an outcome of proven best practices in 
project management. For information on these best practices, see the Oracle Product Lifecycle 
Analytics (Oracle PLA) User Guide. The comprehensive out-of-the-box reports in Oracle Product 
Lifecycle Analytics (Oracle PLA) are based on these best-practice templates. 

In Agile PLM-PPM, Activity and Gate are the two Classes in PPM. You can configure the 
subdivisions in your project as sub classes of the Activity or Gate Classes.  
 
 

These user-configured sub classes need to be mapped into one of the following domains, so they 
adhere to the best practice templates: 
 

 Portfolio 

 Program 

 Phase 

 Decision Gate 

 

 

Oracle Product Lifecycle Analytics (Oracle PLA) uses domain values to determine Portfolio, 
Program, Project, Phase, Tasks, and Decision Gates to report and analyze against the Subject 
Areas. 

Projects and Tasks are identified using the Phase domain value. An activity that is one level above 
a Phase is considered a Project, and activities that are one or more levels below a Phase are 
considered Tasks. Decision gates for a project are identified using the Decision Gate domain 
values. 

A root Project in PLM can be identified as a Project in Oracle PLA only if you configure domain 
values. If you do not configure domain values, the ETL run does not populate the Phase-Gate Fact 
table and you receive a warning notification on email. 
 
 

 

The ETL Runtime Configuration window enables you to: 
 

 Configure the Domain values for all the sub classes using Domain Lookup tab 

 Set the ETL properties at run time using the Run Time tab 
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Configuring the Domain Values 

 
To configure the Domain values: 
 

1. Click Options > ETL Configurations. The ETL Run Time Configuration Window appears - as shown 
below. 
 

 

 

In the Domain Lookup tab, the Domain Group column lists all the available domain groups. The 
Mapped PLM Class column displays the PLM sub classes mapped to the domain groups. 
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2. Click the Add icon on a domain group row. This is the domain group for which you want to 
configure a corresponding PLM subclass. For example, Program. The Select Domain values for 
Program popup window is displayed. 
 

 

 

The sub classes displayed in the Select Program Domain Values popup window are specific to the 
Activity class. This applies to Project, Portfolio, and Phase Domain Groups. 
 
 

Note If you had clicked the Add icon on the Gate Domain Group row in the Domain Lookup 
tab, only sub classes specific to the Gate class appear in this window. 

 

3. Select the checkbox in the Add column to choose the PLM subclass. 
 
 

Note You can select any sub class that belongs to Activity class. 

 
 

4. Click Apply. 

 

The selected PLM subclasses are appended into the target domain group and saved into the 
database. If a subclass is already mapped to another domain, a warning message appears. If you 
are a 9.2.2.x user, it is recommended that you create separate sub classes for your 'Program' and 
'Portfolio', and configure both these subclasses to 'Program' domain. This ensures meaningful 
analytical reports.  
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Setting the ETL Run Time Properties 

 
To set the ETL run time properties: 
 
 

1. Click Options > ETL Configurations. The ETL Runtime Configuration Window appears. 
 
 

Click the Run Time tab. The ETL Runtime properties appears as follows: 
 

 

 

 

Note Calendar to use parameter: 
Out-of-the-box the default variable is Default Calendar.  
Choose the Gregorian Calendar option to see the traditional January to December 
calendar.  

 
 

2. Double-click on the Property value column against a Property Name. 
 
 

3. Enter or modify the ETL Run time property. 
 

4. Click Apply. 
 

These properties come into effect only after the ETL has been run. 
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ETL Run Time Property Names 

 
 

Property  Name Descr ipt ion  

STAGE ETL Load Type  
and  
MDS ETL Load Type 

You can set this property to run ETL as any of the following:  
 

1. Full Load (Full)  
 

2. Incremental Load (CDC) 
 

3. Disable (Disable) 
 

The very first time you use the Oracle PLA Configurator for new 
mappings, the ETL run type is always Full Load irrespective of the 
value of this property. 

Change Orders 
Enter a date from when you want to start analyzing week-level 
aggregations. 

Mail server to use 
Enter a valid mail server name. Use the server that sends email 
notifications for the ETL execution status. 

From mail ID to send ETL 
Notification 

Enter the e-mail ID from which the ETL execution status emails are to 
be sent. 

Change Orders 
Enter a date from when you want to begin runtime configuration 
analysis. 

Mail ID to send ETL Notification 
Enter the e-mail IDs of the users who need to receive emails of the 
ETL execution status. 
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Property  Name Descr ipt ion  

Calendar to use 
If you are a Time Utility Member choose Fiscal Calendar as your 
default calendar. You can change this parameter manually if you want 
to use Default Calendar. 

Fiscal Calendar Start Date 
Enter the start date of the Fiscal year. This setting allows you to 
perform analysis of Business Intelligence data based on your 
organization's fiscal or calendar year. 

Fiscal year offset 

This parameter specifies the offset for the fiscal calendar year with 
reference to the Default Calendar year.  
 

Values are: 
 

 0 - The dates and year for the Fiscal Calendar match the dates 
and year of the Default Calendar.    
 

 1 - The dates and year for the Fiscal Calendar is one year ahead 
of the current calendar year. 
 

 -1 - The dates and year for the Fiscal Calendar is one year 
behind the current calendar year. 
 

For example, if your fiscal calendar year for 2011 starts on April 1, 
2010, then for the Fiscal year offset value choose 1.  
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Property  Name Descr ipt ion  

Logging level 

This parameter indicates the debugging level required to log the run 
time ETL messages into the VLOG table. 

Options are: 
 

 ERROR 
 

 WARNING 
 

 INFO 
 

 DEBUG 
 

 ALL 

Snapshot Frequency Type 

Based on the project summary snapshot, this setting is used to 
perform analysis of BI data. 

Options are: 
 

 Month - Snapshot fact table populated monthly. 
 

 Week - Snapshot fact table populated weekly 
 

 No Snapshot - Snapshot fact table never populated. 
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Property  Name Descr ipt ion  

Snapshot to run on 

Based on the project summary snapshot, this setting is used to 
perform analysis of BI data.  You select which day of the week you 
want to run the ETL to take a snapshot of the project summary table. 

 

Options are: 
 

 SUNDAY 
 

 MONDAY 
 

 TUESDAY 
 

 WEDNESDAY 
 

 THURSDAY 
 

 FRIDAY 
 

 SATURDAY 

 

If you have choose Month as your Snapshot Frequency Type, and 
the day of the week you choose for the Snapshot to run on field 
does not occur in that month, then the snapshot will run on the last 
day of the month. 

 

 
 

Accessing the Software 

The Oracle PLA Configurator is a standalone executable provided with the Oracle Product Lifecycle 
Analytics (Oracle PLA) installation software. When you install Oracle Product Lifecycle Analytics, 
the executable is automatically downloaded to the bin folder (within the Oracle PLA installation 
directory) on your computer. All dependent files are downloaded to the lib folder. Configuration files 
are downloaded into the config folder, while the configuration logs are stored in the log folder. 

For information on running the Oracle PLA Configurator, see Running the MDS Configurator on 
page 36. 
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Connection Information 

The Oracle PLA Configurator uses database authentication to connect to the Staging Schema and 
MDS databases. No additional database privileges are required. 

Connection information is maintained in the property file -  
<install dir>/config/DataMartConfig.properties.  

 

The password used for the connection is encrypted as per the prescribed Oracle Agile algorithm. 

 

 
 
 

Changing the Password 

 
To change the password: 
 

1. Run the DMEncoder.bat file available at the path <install directory>\bin and enter the password 
string for ODM / Oracle PLA MDS database users. 
 

2. Copy the generated strings for ODM_USER_PASSWORD and MDS_USER_PASSWORD 
respectively. 
 

3. Open the <install directory>\config\DataMartConfig.properties file where the password is 
initialized for the MDS database schema user. 
 

4. Replace the copied strings as values for ODM_USER_PASSWORD and 
MDS_USER_PASSWORD respectively. 
 

5. Save changes and close the file. 
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Running the Oracle Product Lifecycle Analytics 
Configurator 

 
To run the Oracle Product Lifecycle Analytics Configurator, follow these steps: 
 

1. In the Oracle PLA installation folder, navigate to the bin folder. 
 

2. Double-click the Configurator.bat file. (On Solaris/Linux, run Configurator.sh). The Oracle Product 
Lifecycle Analytics Configurator interface is displayed. 
 

3. From the Options menu in the Oracle Product Lifecycle Analytics Configurator, select ETL 
Configurations. This opens the ETL Runtime Configurations window. 
 

4. In the ETL Runtime Configurations window, select the Run Time tab. 
 

5. From the Property Name column, select the MDS ETL Load Type row.  From the adjacent Property 
value column (and the MDS ETL Load Type row) select the Disable option.  
 

6. From the Property Name column, select the STAGE ETL Load Type row.  From the adjacent Property 
value column (and the STAGE ETL Load Type row) select the Full or CDC option.  
 

7. In the ETL Runtime Configurations window, first select Apply, and then Close. 
 

8. Click OK, in the ETL Parameters Updated message box. 
 

 
The next step is to execute the ETL from the Oracle Data Integrator (ODI). 

 

 
 

Execute the Staging ETL from the ODI 

 
To load data into the MDS from the Agile PLM source database, you must carry out a data 
integration using the Operator feature in Oracle Data Integrator. 
 

For more information on how to install and use the Oracle Data Integrator (ODI), see the ODI 
documentation in the Oracle Technology Network 
(http://www.oracle.com/technology/documentation/agile.html). 
 

http://www.oracle.com/technology/documentation/agile.html
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Executing ETL Using ODI 10g 

 
To execute the ETL using the Operator feature in ODI, and run the staging schema, follow 
these steps: 
 

1. Go to Start > Oracle Data Integrator > Operator. 
 

2. From the Oracle Data Integrator Login window, select your Login Name, and enter your User name 
and Password. 
 

3. Click OK. 
 

4. From the Windows menu select Show View > Scenarios. 
 

5. Select ANALYTICS_ETL_Version001, and right-click. 
 

6. From the ANALYTICS_ETL_Version001 context menu select Execute. 
 

7. In the Execution dialog box, select the following: 
 

a. MDS for the Context attribute. 
 

b. Local (No Agent) for the Agent attribute. 
 

c. 5 for the Log Level attribute. 
 

d. Click OK. 

 
You have now finished executing the staging ETL, and can now proceed to configurator mapping. 
 
 

 
 

Executing ETL Using ODI 11g 

 
To execute the ETL using the Operator feature in ODI, and run the staging schema, follow 
these steps: 
 
 

1. Go to Start > Programs > Oracle > Oracle Data Integrator > ODI Studio. 
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2. Click the Connect to Repository... icon 

The Oracle Data Integrator Login window appears.  
 

3. Select your Login Name, and enter your User name and Password. 
 

4. Click OK. 
 

5. Select the Operator tab, and navigate to Load Plans and Scenarios section. 
 

6. Right-click the ANALYTICS_ETL Version 001 component for Agile PLM or the AGILEP4P_ETL_LOAD 
component for Agile PLM for Process and select Execute. The Execution window appears. 
 

7. In the Execution dialog box, select the following: 
 

a. MDS for the Context attribute. 
 

b. Local (No Agent) for the Agent attribute. 
 

c. 5 for the Log Level attribute. 
 

d. Click OK.  The Information window stating the message Session started appears. 
 

8. Click OK. The ETL process begins. 

 

Note After ETL is executed, ODI sends a success or failure notification to the email users 
configured during installation. Email user configurations can be changed in the 
ETL_PARAMETER table in the MDS schema. The ETL_PARAMETER table is in the 
ODM schema if ODM and MDS were installed in separate schemas. These parameters 
can also be changed using the Configurator for Agile PLM deployments only. 

 

 
 

Viewing ETL Process Status for ODI 10g 

To view the status of the ETL process: 
 

1. Log in to the ODI Operator 
 

2. In the Sessions List tab, select All Executions in the left frame - to view all running tasks. 

Alternatively, in the Hierarchical Sessions tab, select Status or All Executions in the left frame to 
check overall progress. 
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Viewing ETL Process Status for ODI 11g 

To view the status of the ETL process: 
 

1. Log in to the ODI. 
 

2. Select the Operator tab, and navigate to the Session List section. 
 

3. To view all running tasks, select All Executions or Status from the left frame. 
 

Alternatively: 

To check overall progress, go to the Hierarchical Sessions section and select Status or All 
Executions. 

 

 
 

Increasing the Operator Display Limit in ODI 10g 

You can increase the Operator Display Limit to 1000 (default value is 100) to view the status of all the 
tasks that are under execution in ODI.  
 

To increase the Operator Display Limit, in ODI Operator, follow these steps: 
 

1. Go to File > User Parameters > Set Operator Display Limit. 
 

2. Set the value for Operator display limit to 1000. 

 

 
 

Increasing the Operator Display Limit in ODI 11g 

You can increase the Operator Display Limit to 1000 (default value is 100) to view the status of all the 
tasks that are under execution in ODI.  
 

To increase the Operator Display Limit, in ODI Operator, follow these steps: 
 

1. Go to ODI > User Parameters > Operator Display Limit. 
 

2. Set the value for Operator display limit to 1000. 
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Mapping PLM Attributes 

 
 

Important You need a thorough understanding of the Agile PLM classes and the attribute 
definitions in the source environment, in order to perform an accurate mapping of PLM 
attributes.  
 
You must also be a power user of the Agile Java Client. 
 

 
 

Before you begin: 
 

 Make sure you have a complete working environment that includes the following layers: 
 

 Agile PLM Java Client 

 Agile PLM MDS schema and ETL components 
 
 

 To verify the mapping, keep any database SQL editor open. 
 
 

 Understand the color coding used in the Oracle PLA Configurator: 
 

 Blue text:  Indicates attributes that have already been mapped. 

 Red text:  Indicates attributes that are disabled in PLM. 
 
 

 Keep a copy of the Oracle Product Lifecycle Analytics MDS Data Reference Manual handy to 
verify target tables used by the BI Reports. You can download this manual from Oracle 
Technology Network. 
 
 

 You must have completed a staging FULL load ETL. 
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How to Map Attributes 

Attributes are located and then mapped.  It is done using the Agile Java Client Admin module and 
the Oracle PLA Configurator. 

 

 

How to Locate Attributes in Agile Java Client Admin Module 

 
In the Agile Java Client Admin module: 
 

1. Open the Setting > Data Setting > Classes node. 
 

2. Open the class or subclass tab from which you wish to source attributes for the MDS target 
tables. 
 

3. Under User Interface Tabs, select an attribute group, for example, Page Two. 
 

4. View the attributes and note them down. 
 
 
 

 

Mapping Attributes in Oracle PLA Configurator 

 
In the Oracle PLA Configurator: 
 

1. In the left pane, expand the subject area category node, and click the subject area 
corresponding to the Agile PLM class. For example, under PQM, click NCR. 
 

2. In the right pane, select either the Base Fact or the Affected Items tab. 
 

3. Select the Target Column row for the attribute type you wish to map, and click . The Edit 
the selected Row dialog box opens.  Alternatively, you can right-click on a target cell. 
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4. In the Edit the selected Row dialog box, select options from the drop-down lists to map the 
field or column to PLM attributes as per the details you noted down earlier. 
 
 

a. In the Attribute Group list, select the PLM attribute group from which you wish to source 
attributes. The list of attribute groups is different for Base Fact and Affected Items. For 
details, see Supported Mappings. 
 
 

b. In the Attribute Name list, select the attribute name that you want to map. The list shows 
the options that you have enabled in Java Client. If a list ID has already been mapped 
to a target dimension table, only those attributes associated with the same list ID are 
displayed for selection. 
 
 

If you choose a user-defined list, you are now provided the option to map it to a target 
dimension table. This is not applicable to user-defined list attributes of PPM. 
 

Note The Attribute Name list displays only the attribute names that correspond to the 
Attribute Group you select. 

c. From the Dimension Table Name list, select a target dimension table for the mapping. 
You can map the same list /multi-list attribute to any number of target dimension table 
names, but a list ID can be associated with only one target dimension table. You 
cannot map a cascade list to any user-defined list. 
 

d. Click OK. 
 

e. Click Save. 
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Note If you are a 9.2.2.7 user, you need to configure the multi-list attribute in 
PPM_ACTIVITY_PLM_REFERENCE table, for Program or Portfolio analysis. This multi-
list attribute is available in PPM > Activity > Activity Fact Tab. 

 
 
 
 

Validating the Mappings 

 
Click Validate, to validate your attribute mappings. 
 

You will see an Errors and Warnings dialog box if you have any errors or warnings, or if any of the 
following conditions occur: 
 

 Column already used for mapping - In MDS an Agile PLM attribute is mapped to more than one 
target column. 
 

 Attribute disabled in PLM after configuration - In Agile PLM, a previously mapped Agile PLM 
attribute is now disabled. 
 

 List modified in PLM after configuration - An Agile PLM attribute previously configured to a 
conforming dimension has been modified in Agile PLM to use a non-conforming source list. 
 

 
If you get any of these errors, you must change the mapping for the attribute identified in the error 
message. 

 

Errors are also logged in the Configurator.log file.  The Configurator.log file is located in <install 
directory>/logs/. 

You can also save the errors to a .csv file, click Save to File. 
 
 
 
 

Validating the Data 

After you finish mapping, run the MDS ETL (full load). This ensures that the data loads from the 
source tables in Agile PLM Data Mart to MDS as per your mapping.  
 
 

Note To learn how to run the ETL, see Executing the MDS ETL.  
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Data loads into the newly configured tables after the MDS ETL runs. 

After the ETL run, verify the records in the target table by using any database SQL editor to connect 
to the MDS database. 
 
 

 
 

Executing the MDS ETL for ODI 10g 

To execute the MDS ETL, you must first open the Oracle PLA Configurator, select the pertinent 
property names and their respective values.  After this is done, you need to run the required 
attribute in Oracle Data Integrator Operator feature. 
 
 

To run the MDS ETL, follow these steps: 
 

1. In the Oracle PLA installation folder, navigate to the bin folder. 
 

2. Double-click the Configurator.bat file. (On Solaris/Linux, run Configurator.sh).  
The Oracle Product Lifecycle Analytics Configurator interface is displayed. 
 

3. From the Options menu in the Oracle Product Lifecycle Analytics Configurator, select ETL 
Configurations.  
This opens the ETL Runtime Configurations window. 
 

4. In the ETL Runtime Configurations window, select the Run Time tab. 
 

a. From the Property Name column, select the STAGE ETL Load Type row.  Click the adjacent 
Property value column, select Disable.  
 

b. From the Property Name column, select the MDS ETL Load Type row.  Click the adjacent 
Property value column, select CDC.  
 

c. In the ETL Runtime Configurations window, first select Apply, and then Close. 
 

5. Click OK, in the ETL Parameters Updated message box. 
 

6. Go to Start > Oracle Data Integrator > Operator. 
 

7. From the Oracle Data Integrator Login window, select your Login Name, and enter your User name 
and Password.  Click OK. 
 

8. From the Windows menu select Show View > Scenarios. 
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9. Select ANALYTICS_ETL_Version001, and right-click.  From the ANALYTICS_ETL_Version001 context 
menu select Execute. 
 

10. In the Execution dialog box, select the following: 
 

a. MDS for the Context attribute. 
 

b. Local (No Agent) for the Agent attribute. 
 

c. 5 for the Log Level attribute. 
 

d. Click OK. 

 

After you complete the above steps the data populates into the MDS, and you can now start 
analysis in OBIEE. 

If you are a user of custom user defined dimension and measures you must first complete RPD 
customizations. 

 

 
 

Executing the MDS ETL for ODI 11g 

To execute the MDS ETL, you must first open the Oracle PLA Configurator, select the pertinent 
property names and their respective values.  After this is done, you need to run the required 
attribute in Oracle Data Integrator Operator feature. 
 
 

To run the MDS ETL, follow these steps: 
 

1. In the Oracle PLA installation folder, navigate to the bin folder. 
 

2. Double-click the Configurator.bat file. (On Solaris/Linux, run Configurator.sh).  
The Oracle Product Lifecycle Analytics Configurator interface is displayed. 
 

3. From the Options menu in the Oracle Product Lifecycle Analytics Configurator, select ETL 
Configurations.  
This opens the ETL Runtime Configurations window. 
 

4. In the ETL Runtime Configurations window, select the Run Time tab. 
 

a. From the Property Name column, select the STAGE ETL Load Type row.  Click the adjacent 
Property value column, select Disable.  
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b. From the Property Name column, select the MDS ETL Load Type row.  Click the adjacent 
Property value column, select CDC.  
 

c. In the ETL Runtime Configurations window, first select Apply, and then Close. 
 

5. Click OK, in the ETL Parameters Updated message box. 
 

6. Go to Start > Programs > Oracle > Oracle Data Integrator > ODI Studio. 
 

7. Launch the ODI Studio, and log in using authentication details for the ODI session created during 
installation.  
 

8. Select the Operator tab, and navigate to Load Plans and Scenarios section. 
 

9. Right-click the ANALYTICS_ETL Version 001 component for Agile PLM or the AGILEP4P_ETL_LOAD 
component for Agile PLM for Process and select Execute. The Execution window appears. 
 

10. In the Execution dialog box, select the following: 
 

a. MDS for the Context attribute. 
 

b. Local (No Agent) for the Agent attribute. 
 

c. 5 for the Log Level attribute. 
 

d. Click OK.  The Information window stating that the message Session started appears. 
 

11. Click OK. The ETL process begins. 

 

After you complete the above steps the data populates into the MDS, and you can now start 
analysis in OBIEE. 

If you are a user of custom user defined dimension and measures you must first complete RPD 
customizations. 

Note After ETL is executed, ODI sends a success or failure notification to the email users 
configured during installation. Email user configurations can be changed in the  
ETL_PARAMETER table in the MDS schema. The ETL_PARAMETER table is in the 
ODM schema if ODM and MDS were installed in separate schemas. These parameters 
can also be changed using the Configurator for Agile PLM deployments only. 
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Chapter 4 

Extending the Agile PLM for Process 
Data 

This chapter includes the following: 

 General Solution .................................................................................................................................................. 49 
 What's Extensible in Agile PLM for Process ........................................................................................................ 50 
 NPD Project Metrics ............................................................................................................................................ 52 
 Extended Attributes ............................................................................................................................................. 59 

 
 

 

General Solution 

For all areas of extension the general solution is characterized by an initial setup.  This setup is then 
used by the overall ETL process every time data is transferred.  
 
 

The initial setup comprises of the following:  
 

 In the staging schema tables, custom-data mappings are created to specific predefined user-
data columns. 
 

 Use the OBIEE Administrator to: 
 

 Customize and add the MDS user-defined columns to the already existing Physical Layer 
tables, Logical/Business Layer objects, and Presentation Layer objects within a given 
Subject Area. 

 Customize the names of these columns and fields. 

 

If there are any errors in the data in the mapping tables (for example, non-existent NPD Project 
Metrics, non-existent Extended Attributes, and/or misnamed target DB tables or columns, and so 
on.) they will cause the overall ETL run to fail. Error messages are logged in the TLOG table. 
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Important You must conduct a FULL extract run if you make any content changes to the 
P4P_CONFIG_EA table or to the P4P_METRIC_CONFIG_MAP table. 
 
A CDC (incremental) run does not pick up any changes made to the tables. 
 

 
 

 
 

What's Extensible in Agile PLM for Process 

 
There are three key data elements from Agile PLM for Process to the Presentation layer: 
 

1. Core Attributes (Not Configurable): Are attributes available from the Agile PLM for Process out-of-
the-box solution. In Oracle Product Lifecycle Analytics (Oracle PLA) only the relevant attributes 
are brought out as measures and dimensions. 
 
 
 

2. Extended Attributes (Configurable): In order to capture additional information – beyond core 
attributes, Agile PLM for Process allows you to add extra (extended) attributes. Oracle PLA 
provides configuration and customization steps that bring out dimension and measure fields. 
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3. Project Metrics (Configurable): Project metrics are definable in Agile PLM for Process. Project 
metrics allow you to capture information related to a project (for example, cost, revenue 
forecasts, and so on). Based on whether the metrics have basis, financial year, or category 
information, the measures are simple or complex. Oracle PLA provides configuration and 
customization steps to bring out the fields as measures (but not as dimensions). 
 

 

 
 
 

Important Oracle PLA does not support Custom Sections. 
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NPD Project Metrics 

 
 

Important Any changes to the content of the P4P_CONFIG_EA table or the 
P4P_METRIC_CONFIG_MAP table must be followed by a FULL extract run.  A CDC 
run will not pick up these changes. 

 

Oracle Product Lifecycle Analytics (Oracle PLA) delivers two out-of-the-box metrics that correspond 
to Project Metrics in Agile PLM for Process: 
 

 Three year NPV 

 Annualized case volume 

 

These metrics flow through the prebuilt ETL and mappings all the way to the presentation layer, 
provided certain naming conventions are adhered to. Even if the naming convention followed is 
different, you can replace names of these metrics via a custom script. 

 

Simple Metrics are Project Metrics that have no phase, no basis, no category, and no fiscal year.  
These measures have to be mapped to the Project Summary fact. This mapping can be created 
using the custom script between Source to Staging. From Staging to MDS, prebuilt mapping & ETL 
exist. You need to customize the OBIEE RPD to expose the metric as a measure in the 
presentation layer. 

 

Complex metrics are Project Metrics that are dimensionalized and have a phase, basis, category, or 
fiscal year.  These measures have to be mapped to the Project Metrics fact (unlike Simple metrics). 
Other than that the process of customization/ configuration is similar to that of simple metrics. 

 
 

Important The Project Metrics cannot be exposed as a dimension in the Presentation layer. The 
only dimensions that are supported for Complex metrics are Phase, Basis, Category 
and Fiscal Year. 
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Mapping the NPD Project Metrics 

 
There are three basic types of NPD Project Metrics mappings: 
 

1. System-Defined replacements 
 

2. Simple (dimensionless) User-Defined additions 
 

3. Dimensionalized User-Defined additions 
 

 
 

All types are mapped via inserting the name of the metric and the table and column to map it to into 
the meta-data table named: P4P_METRIC_CONFIG_MAP.  

Data is then transferred to the targeted table at ETL time for each NPD Project that contains that 
given named metric. Projects that do not have a value for that metric will have that column left 
"null". 

 
 
 

The table below defines the P4P_METRIC_CONFIG_MAP metrics mapping database table. 
 

COLUMN DATA TYPE DESCRIPTION 

METRIC_NAME varchar2(200) The NPD project metric ID. 

TABLE_NAME varchar2(40) 

The destination table name.  One of the following:  
 

 P4P_PRJ_SUM_FS 

 P4P_PRJ_DET_FS 

 P4P_PRJ_METRICS_FS 

 P4P_PROJECT_DS 

COLUMN_NAME varchar2(100) 
The destination column name (for example, 
PRJ_USRDEF_DATE2, PRJ_USRDEF_LIST8, etc.) 

 
 

The TABLE_NAME is dependent upon the preferred BI Subject Area and the metric's data type.  
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Use the table below to select the TABLE_NAME.  
 

TABLE NAME BI  SUBJECT AREA 
DATA 
TYPE 

EXPLANATION 

P4P_PRJ_SUM_FS Project Summary Numeric The available Project Summary FACT 
table column for numeric metrics. 

P4P_PRJ_DET_FS Project Detail Numeric 
The available Project Detail FACT table column 
for numeric metrics. 

P4P_PRJ_METRICS_FS Project Metrics Numeric The available Project Metrics FACT table 
column for numeric metrics. 

P4P_PROJECT_DS ALL of the above Text The available Project DIMENSION table 
column for text metrics. 

 
The COLUMN_NAME is dependent upon the TABLE_NAME you choose. 

 

 

If you chose P4P_PRJ_SUM_FS as your TABLE_NAME, then use the table below to select the 
COLUMN_NAME. 
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COLUMN_NAME DATA TYPE DESCRIPTION 

THREE_YR_NPV, 
ANNUAL_CASE_VOL 

NUMBER(22, 7) 

 Only available in the P4P_PRJ_SUM_FS 
table. 
 

 Initially mapped to the simple (fully-qualified 
metric names) of 
THREE_YR_NPV_NOB_NOPH_NOFY and 
ANNUALIZED_VOLUME_CASES_NOB_NOP
H_NOFY. However you can also override 
them as well. See examples. 
 

 These metrics are available already in the 
OBIEE Answers list under Project Summary 
subject area, Agile PLM for Process Metrics 
Measures as "3 Year NPV (No Basis, No 
Phase, No Year)" and "Annualized Case 
Volume (No Basis, No Phase, No Year)", so 
they will not have to be enabled via the 
Administrator like the USRDEF columns. 

PRJ_USRDEF_COST0 - 
PRJ_USRDEF_COST 

NUMBER(22, 7) 10 user-defined decimal fields 

PRJ_USRDEF_DATE0 - 
PRJ_USRDEF_DATE4 

NUMBER(10) 
5 user-defined date columns, formatted as: 
YYYYMMDD 

PRJ_USRDEF_NUMBER0 - 
PRJ_USRDEF_NUMBER9 

NUMBER(10) 10 user-defined integer fields 

 
 
 

If you chose P4P_PRJ_DET_FS as your TABLE_NAME, then use the table below to select the 
COLUMN_NAME. 
 

COLUMN_NAME DATA TYPE DESCRIPTION 

PRJ_USRDEF_COST0 - 
PRJ_USRDEF_COST 

NUMBER(22, 7) 10 user-defined decimal fields 
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COLUMN_NAME DATA TYPE DESCRIPTION 

PRJ_USRDEF_DATE0 - 
PRJ_USRDEF_DATE4 

NUMBER(10) 
5 user-defined date columns, formatted as: 
YYYYMMDD 

PRJ_USRDEF_NUMBER0 - 
PRJ_USRDEF_NUMBER9 

NUMBER(10) 10 user-defined integer fields 

 
 
 

If you chose P4P_PRJ_METRICS_FS as your TABLE_NAME, then use the table below to select 
the COLUMN_NAME. 
 

COLUMN_NAME DATA TYPE DESCRIPTION 

THREE_YR_NPV  
OR 
ANNUAL_CASE_VOLUME 

NUMBER(22, 7) 

These are not initially pre-mapped to any metrics. 
However they are available already in the OBIEE 
Answers list under the Project Summary subject 
area, P4P Metrics Measures as "3 Year NPV" and 
"Annualized Case Volume", so they will not have to 
be enabled via the OBIEE Administrator like the 
USRDEF columns. 

USRDEF_COST0 - 
USRDEF_COST9 

NUMBER(22, 7) 10 user-defined decimal fields 

USRDEF_DATE0 - 
USRDEF_DATE4 

NUMBER(10) 
5 user-defined date columns, formatted as: 
YYYYMMDD 

USRDEF_NUMBER0 - 
USRDEF_NUMBER9 

NUMBER(10) 10 user-defined integer fields 

 
 

Note The P4P_PRJ_METRICS_FS table is only for the mapping of Base-Metric-Name 
metrics.  
 
For more information, see "Base Metric Name - User-Defined NPD Project Metric-Set 
Additions". 
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If you chose P4P_PROJECT_DS as your TABLE_NAME, then use the table below to select the 
COLUMN_NAME. 
 

COLUMN_NAME DATA TYPE DESCRIPTION 

PRJ_USRDEF_LIST0 - 
PRJ_USRDEF_LIST14 

VARCHAR2(1000 CHAR) 
15 user-defined text fields (for example. for 
multi-value comma-delimited text lists) 

PRJ_USRDEF_TEXT0 - 
PRJ_USRDEF_TEXT9 

VARCHAR2(450 CHAR) 10 user-defined text fields 

 

 

 
 

System-Defined NPD Project Metric Replacements 

 
A System-Defined NPD Project Metric does NOT require any use of the OBIEE Administrator tool.  

System-Defined NPD Project Metrics are metrics where the predefined BI analytics mapping (from 
physical to logical to presentation) have been rationalized in the Project Summary Subject Area of 
the OBIEE Answers section.  
 
 

There are two System-Defined NPD Project Metrics:  
 

1. 3 Year NPV (pre-mapped metric ID: THREE_YR_NPV_NOB_NOPH_NOFY)  
 

2. Annualized Case Volume (pre-mapped metric ID: 
ANNUALIZED_VOLUME_CASES_NOB_NOPH_NOFY)  
 

 

The concepts for the above System-Defined NPD Project Metrics are common, but their names are 
not standard across customers.  

For this reason, Oracle allows you to remap (replace) these metrics.  For example, replace 
THREE_YR_NPV_NOB_NOPH_NOFY with THREE_YR_NPV_ABS_PREL_FY10. 
 
 

Example:  SQL script for replacing the 3 Year NPV metric 

insert into P4P_METRIC_CONFIG_MAP (metric_name, table_name, 
column_name) values (‘THREE_YR_NPV_ABS_PREL_FY10’, 'P4P_PRJ_SUM_FS', 

‘THREE_YR_NPV’); 
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Example:  SQL script for replacing the Annualized Case Volume metric 

insert into P4P_METRIC_CONFIG_MAP (metric_name, table_name, 
column_name) values (‘BIGCORP_METRIC_AN_CS_VOL’, 'P4P_PRJ_SUM_FS', 

‘ANNUAL_CASE_VOL’); 

 
 
 

 
 

Simple (dimension-less) User-Defined NPD Project Metric Additions 

 
Simple (dimension-less) user-defined NPD project metric additions are simple metrics for which no 
previous BI Analytics exists. 
 

Example SQL script for adding the "Project Cost" metric to an available user-defined cost column in 
the Project Detail Subject Area: 
 
 

insert into P4P_METRIC_CONFIG_MAP (metric_name, table_name, 
column_name) values (‘PROJECT_COST_NOB_POST_FY09’, 'P4P_PRJ_DET_FS', 
‘PRJ_USRDEF_COST1’); 

 

Note To view the data in the Answers section, in OBIEE Administrator, enable the 
PRJ_USRDEF_COST1 column from the Project Detail Subject Area. 

 

 
 

Dimensionalized User-Defined NPD Project Metric-Set Additions 

Dimensionalized User-Defined NPD Project Metric-Set Additions are metrics that allow you to 
analyze its different values (based on the intersection of the different dimensions that have defined 
it). 
 
 

The different possible dimensions are: 
 

 Fiscal Year 
 

 Basis 
 

 Phase 
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 Category 
 

 

When you specify the METRIC_NAME of this type, you should only specify the base or prefix of the 
ID. 

For example, a metric with a base name of CONTRIBUTION; Fiscal Year values of FY08, FY09, 
and FY10; Phase values of Pre-Launch, Launch and Post-Launch; and Basis value of Absolute; it 
would have the following nine intersections of its dimensions:  
 
 

 CONTRIBUTION_ABS_PREL_FY08 

 CONTRIBUTION_ABS_PREL_FY09 

 CONTRIBUTION_ABS_PREL_FY10 

 CONTRIBUTION_ABS_LNCH_FY08 

 CONTRIBUTION_ABS_LNCH_FY09 

 CONTRIBUTION_ABS_LNCH_FY10 

 CONTRIBUTION_ABS_POST_FY08 

 CONTRIBUTION_ABS_POST_FY09 

 CONTRIBUTION_ABS_POST_FY10 

 

 

Example SQL script for adding this CONTRIBUTION metric-set to the Project Metrics Fact group: 
 

insert into P4P_METRIC_CONFIG_MAP (metric_name, table_name, 
column_name) values ('CONTRIBUTION', 'P4P_PRJ_METRICS_FS', 
'USRDEF_COST4'); 

 
 
 
 
 

Extended Attributes 

Extended Attributes (EAs) are optional custom-data feature available in Agile PLM for Process.  
EAs exist on both GSM Specifications and NPD Projects.  
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Warning If you install the optional Extended Attributes Denormalization feature on the PLM4P 
database AFTER you have already installed OPLA, then you need to rerun the 
appropriate db-type PLM4P source views script (that is, AllinOneViews.sql for SQL-
SERVER source DB, and OracleAllInOneViews.sql for Oracle source DB) for any 
P4P_CONFIG_EA mappings to work. 

 

Only distinct EAs can be denormalized, and therefore are the only candidates for mapping into BI.   

Extended Attributes may require prebuilt content, mapping, and customization.  
 
 

Prebuilt mappings and ETL exist between: 
 

1. Source to Staging 
 

2. Staging to MDS  
 

 

After you have identified the Extended Attributes to bring in to Oracle PLA for analysis, you must 
map them between the Source to Staging. This is done by using a custom mapping script. After you 
have created the mapping and run the ETL this data flows from Source to Staging. The data then 
moves to MDS using prebuilt mappings between Staging to MDS. You must customize OBIEE RPD 
in order for the extended attributes to be exposed as a measure or a dimension in the presentation 
layer. 
 
 

 
 
 

EAs Process Steps 

 
The steps for getting an EA into the BI solution are as follows: 
 

1. EA Denormalization:  the automated process where EAs are extracted into denormalization 
tables, for example, DENORM_EA_NUMERIC and DENORM_EA_TEXT.   
 

2. Mapping:  The manual configuration and mapping of which EAs to extract from the 
denormalized data into specific BI Subject Areas. 
 

3. ETL:  The automated process by which the data is moved from the source system to the target 
system.  This data includes any optional EA denormalized data.  This process also transfers 
specific EAs per the above Mapping step into the desired location(s). 
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4. Enabling:  The manual configuration via OBIEE Administrator of the enabling of the targeted 
tables and columns in the desired Subject Area in the Answers section. 

 

 
 

EA Mapping Table and Column Choices 

 

1. The extended attribute mapping table (P4P_CONFIG_EA) is defined as follows: 

COLUMN NAME DB-TYPE DESCRIPTION 

EA_DENORM_TABLE_NAME VARCHAR2(256 CHAR) Source EA denorm table name 

EA_DENORM_COLUMN_NAME VARCHAR2(256 CHAR) Source EA denorm column name 

ATTRIBUTE_ID VARCHAR2(80 CHAR) Source EA ID 

OWNING_OBJECT_TYPE VARCHAR2(256 CHAR)  
Source Owning object type (that is, 
GSM or NPD) 

DEST_TABLE_NAME VARCHAR2(256 CHAR) Destination table name 

DEST_COLUMN_NAME VARCHAR2(256 CHAR) Destination column name 

 
 

2. The EA_DENORM_TABLE_NAME and EA_DENORM_COLUMN_NAME depend on the type 
of the EA data.  Specifically: 

EA Data-Type DENORM_TABLE_NAME DENORM_COLUMN_NAME 

Boolean P4P_DENORM_EA_BOOLEAN VALUE 
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EA Data-Type DENORM_TABLE_NAME DENORM_COLUMN_NAME 

Quantitative 
Range 

P4P_DENORM_EA_QUANTITATIVERANGE 

 MIN 

 TARGET 

 MAX 

 MINBASE 

 TARGETBASE 

 MAXBASE 

 UOM 

 UOMBASE 

 MINPRECISION 

 TARGETPRECISION 

 MAXPRECISION 

Quantitative 
Tolerance 

P4P_DENORM_EA_QUANTTOLERANCE 

 VALUE 

 TOLERANCE 

 UOM 

 VALUEBASE 

 UOMBASE 

 VALUEPRECISION 

 TOLERANCEPRECISION 

Date P4P_DENORM_EA_DATE VALUE 

Text P4P_DENORM_EA_TEXT VALUE 

Number P4P_DENORM_EA_NUMERIC 

 VALUE 

 UOM 

 VALUEBASE 

 UOMBASE 

 PRECISION 
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3. The destination table name (DEST_TABLE_NAME) to choose depends on the desired owning 
object type (OWNING_OBJECT_TYPE), Subject Area, and EA data type.  Specifically: 
 

OBJECT TYPE 
SUBJECT AREA  

&   
DATA TYPE 

TABLE NAME 

GSM 

Specification numeric P4P_SPEC_FS 

Specification text P4P_SPEC_DS 

NPD 

Project Summary numeric P4P_PRJ_SUM_FS 

Project Detail numeric P4P_PRJ_DET_FS 

Project text P4P_PROJECT_DS 

 

 

4. The COLUMN_NAME to choose depends on the TABLE_NAME chosen as follows: 
 
 

a. P4P_SPEC_FS (the available GSM Specification FACT table columns for numeric EAs) 
 

COLUMN_NAME DB-TYPE DESCRIPTION 

SPEC_USRDEF_COST0 to 
SPEC_USRDEF_COST9 

NUMBER(22, 7) 10 user-defined decimal fields 

SPEC _USRDEF_DATE0 to 
SPEC _USRDEF_DATE4 

NUMBER(10) 
5 user-defined date columns, 
formatted as: YYYYMMDD 

SPEC _USRDEF_NUMBER0 to 
SPEC _USRDEF_NUMBER9 

NUMBER(10) 10 user-defined integer fields 
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b. P4P_SPEC_DS (the available GSM Specification DIMENSION table columns for text EAs) 
 

COLUMN_NAME DB-TYPE DESCRIPTION 

SPEC_USRDEF_TEXT0 to 
SPEC_USRDEF_TEXT9 

VARCHAR2(450 CHAR) 10 user-defined text fields 

 

 

 

c. P4P_PRJ_SUM_FS, P4P_PRJ_DET_FS (the available NPD Project Summary and Project 
Detail FACT table columns for numeric EAs) 
 

COLUMN_NAME DB-TYPE DESCRIPTION 

PRJ_USRDEF_COST0 to 
PRJ_USRDEF_COST9 

NUMBER(22, 7) 10 user-defined decimal fields 

PRJ_USRDEF_DATE0 to 
PRJ_USRDEF_DATE4 

NUMBER(10) 
5 user-defined date columns, 
formatted as: YYYYMMDD 

PRJ_USRDEF_NUMBER0 to 
PRJ_USRDEF_NUMBER9 

NUMBER(10) 10 user-defined integer fields 

 
 

d. P4P_PROJECT_DS (the available NPD Project DIMENSION table columns for text EAs) 
 

COLUMN_NAME DB-TYPE DESCRIPTION 

PRJ_USRDEF_LIST0 to 
PRJ_USRDEF_LIST14 

VARCHAR2(1000 CHAR) 
15 user-defined text fields (for multi-value 
comma-delimited text lists) 

PRJ_USRDEF_TEXT0 to 
PRJ_USRDEF_TEXT9 

VARCHAR2(450 CHAR) 10 user-defined text fields 
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EA Example 

 

Example SQL script for adding the distinct numeric EA named FPCalciumOverride to an available 
user-defined cost column in the Specification Subject Area: 
 

insert into P4P_CONFIG_EA  

(Ea_Denorm_Table_Name, Ea_Denorm_Column_Name, Ea_Select_Value, 
Attribute_Id, Owning_Object_Type, Dest_Table_Name, Dest_Column_Name) 

Values ( 'P4P_DENORM_EA_NUMERIC', 'VALUE', 'VALUE', 
‘FPCalciumOverride’, 'GSM Spec', 'P4P_SPEC_FS', ‘SPEC_USRDEF_NUMBER3’); 
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Chapter 5 

Frequently Asked Questions 

This chapter includes the following: 

 Frequently Asked Questions Related to Agile Product Lifecycle Management ................................................... 67 
 Frequently Asked Questions Related to Agile PLM for Process .......................................................................... 71 

 
 

Frequently Asked Questions Related to Agile Product 
Lifecycle Management 

Answers to some frequently asked questions are listed below. 
 
 
 

1. Why are some PLM attributes not appearing in its attribute options list for mapping? 

 

All attributes that are defined in the PLM database are not available for selection. Only those 
attributes that have corresponding mapping information defined in the Data Mart tables are 
displayed. 
 
 
 

 

2. Can I map disabled attributes using the Configurator? 

 

The Configurator does not support the mapping of disabled attributes. If a previously mapped 
attribute is subsequently disabled in PLM, the mapping is highlighted in red for your attention. 
 
 
 

 

3. Why am I prompted to select a target dimension table only for certain attributes? 

 

You can change the target dimension table only for list, multi-list, and user-defined attributes. 
For conforming dimension tables, you can only change the attribute name.  In PPM module, 
you can change the target dimension table only for multi-list attributes. 
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4. Why do some of the dimension table names in the list appear in blue? 

 

This indicates that the dimension table has already been mapped for the selected attribute. 
 
 
 

 

5. Only a few PLM attributes are displayed for the predefined dimension table names. Why? 

 

Some List IDs may already have been mapped to a predefined dimension table in another row 
or tab. In this case, only the attributes for the same List ID are displayed. A target dimension 
table can be mapped to only one List ID. 
 
 
 

 

6. Can I start the Configurator before the ODM ETL process runs? 

 

Yes, but Flex attributes will not be available for mapping. 
 
 
 

 

7. Can I use the Configurator while the MDS ETL is running? 

 

This is best avoided as it can interfere with the ETL process. 
 
 
 

 

8. Why are some of my flex attributes not displayed in the Oracle PLA Configurator? 

 

Newly created flex attributes should have been entered in the new columns using the Agile 
JavaClient or WebClient in order to be picked up by the ODM ETL process. Unless this is done, 
these attributes will not appear in the Oracle PLA Configurator. 
 
 
 

 

9. Will my changes to Agile PLM configuration require any changes to existing mappings? 
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After you finish the initial mapping of PLM attributes, you will need to update the mappings 
whenever a mapped attribute is changed or disabled in Agile PLM. 
 
 
 

 

10. When I upgrade to Oracle PLA Configurator version 3.3, what happens to the configurations done using 
MDS Configurator version 3.0? 

 

See Upgrade Considerations section in Oracle Product Lifecycle Analytics (Oracle PLA) 
Installation and Setup Guide. 
 
 
 

 

11. In Oracle PLA Configurator, if I need more mappable fields what should I do? 

 

Use Options > Add user-defined fields menu to add more user-defined configurable fields. See 
Extending user-defined (Configurable) fields. 
 
 
 

 

12. Can I extend the number of User-defined dimension tables using Oracle PLA Configurator? 

 

No. For information on adding user-defined dimension tables to MDS Schema using Oracle 
PLA Configurator, refer section, Adding User-defined dimension tables to the Schema. 

The Oracle PLA Configurator supports only the extension of columns in Fact tables and 
creation of corresponding bridge tables (wherever applicable). 
 
 
 

 

13. How do I get more elaborated logging messages in my log file? 

 

Oracle PLA Configurator uses Apache log4j libraries for logging messages. You can change 
log4j.properties file with different logging level (INFO, DEBUG, WARN, ERROR) to control the 
type of messages logged in the log file. 

For more information see Apache log4j at http://logging.apache.org/log4j/1.2/manual.html. 
 
 

http://logging.apache.org/log4j/1.2/manual.html
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14. When I upgrade from PLM BI 3.0 / 3.1 / 3.2 to Oracle PLA 3.3, can I retain all configurations done using the 
3.0 version of the MDS Configurator? 

 

Yes. It is possible to retain all the configurations done using the 3.0 version of the MDS 
Configurator when you upgrade from PLM BI 3.0 to Oracle PLA 3.3. 
 
 
 

 

15. Why do we have domain value lookup in Oracle PLA 3.3? 

 

You can configure your own PPM subclasses in Agile PLM. These subclasses can be used as 
Program, Project, and Portfolio according to the needs in your organization. You need to map 
these configured subclasses into respective domains to obtain meaningful reports. 
 
 
 

 

16. What happens if I do not configure domains? 

 

If you do not configure domain values, the ETL run does not populate values in the Phase-Gate 
Fact Table. You will receive a WARNING email notification indicating that you have not 
configured Phase and Gate. 
 
 
 

 

17. What are the mandatory domain values that need to be configured for PPM? 

 

You need to configure the Program, Portfolio, Phase and Decision Gate domain values for 
PPM. 
 
 
 

 

18. Why are the source attributes not showing up in the PPM subclasses configuration in MDS Configurator? 

 

There are two answers to this question. 
 

a. The staging ETL did not run successfully.   
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b. Before using PPM subclass configuration users should always configure the appropriate 
domains under Options--> ETL Configurations > Domain lookup tab. 

 
 
 
 
 

Frequently Asked Questions Related to Agile PLM for 
Process 

Answers to some frequently asked questions are listed below. 
 
 
 

1. Why are there no records returned when I create an Answer by selecting in Project Summary Subject Area's 
P4P Metrics Measures for any projects in "3 Year NPV" nor "Annualized Case Volume"? 
 
There are no pre-mapped results for these Measures. 
 
 
 

2. Why are there no records returned when I create an Answer by selecting in Project Summary Subject Area's 
P4P Metrics Measures for any projects in "3 Year NPV (No Basis, No Phase, No Year)" nor "Annualized Case 
Volume (No Basis, No Phase, No Year)"? 
 
None of your NPD Projects use the expected pre-mapped Project Metric names of:  
THREE_YR_NPV_NOB_NOPH_NOFY nor 
ANNUALIZED_VOLUME_CASES_NOB_NOPH_NOFY.  You can re-map these as needed. 
 
 
 

3. Why are there no records returned when I add the P4P Metrics Dimension of Basis Name (and/or Category 
Name, Metric Phase Name, Fiscal Year) to my Project Summary Subject Area's Answer with P4P Metrics 
Measures for any projects in "3 Year NPV (No Basis, No Phase, No Year)" nor "Annualized Case Volume (No 
Basis, No Phase, No Year)"? 
 
These Dimensions are only useful with the "3 Year NPV" and "Annualized Case Volume" 
measures (note that there is no parenthetical qualifying of Basis or Phase or Fiscal Year in their 
names). 
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Chapter 6 

Troubleshooting Guidelines 

This chapter includes the following: 

 Troubleshooting Guidelines Related to Agile Product Lifecycle Management .................................................... 73 
 Troubleshooting Guidelines Related to Agile PLM for Process ........................................................................... 75 

 

 
 
The subsequent sections highlight a few of the most common errors you can encounter and their 
solutions. 
 
 

 

 
 

Troubleshooting Guidelines Related to Agile Product 
Lifecycle Management 

In previous releases conformed dimensions (when the same dimension is used by two subject 
areas) did not work. 

From this release, Oracle PLA is providing the ability to use conformed dimensions for multiple lists.  
To display a new multi-list user-defined attribute as a column in an existing dimension table in BI 
Reports use the Attribute ID or the Attribute Name. 

To view and use the multi-list attribute in BI Reports, you must configure the multi-list attribute in the 
BMM layer, and then expose it in the OBIEE Repository’s Presentation Layer. 

For the corresponding data to populate, you must map the column using Oracle PLA Configurator. 

The table below lists Agile PLM related errors and their solutions. 

ISSUE SOLUTION 

The System 
cannot find the file 
specified. 

Check if any of the following files are missing under the <install.dir>/config 
directory. If any are missing, reinstall BI. 
 

 BIDataLayerConfig.properties 

 Configurator.xml 

 Configurator.xsd 

 log4j.properties 

 Messages_en_US.properties 
 



Configurator and Data Mapping Guide  

 

 

74 Oracle Product Lifecycle Analytics 

  

ISSUE SOLUTION 

TNS: listener does 
not currently know 
of SID given in 
connect 
descriptor. 

Ensure that the SID provided in the following token within the 
BIDataLayerConfig.properties file is the same as the database SID. 

TGT_DB_URL =I jdbc:oracle:thin:@<machine name>:<port 
number>:<SID> 

 

Invalid user 
name/password; 
login denied. 

Check if the following tokens reflect the right user name and password information in 
the BIDataLayerConfig.properties file: 
 

 ODM_UN - user name for Data Mart database schema 

 <ODM_PASSWORD> - password for Data Mart database schema user 

 BI_USER_NAME - user name for MDS database schema 

 <BI_PASSWORD> - password for MDS database schema user 
 
Encode the Data Mart and MDS passwords and compare the values with the 
ODM_PASSWORD and BI_PASSWORD. 

 

TNS:  listener 
could not hand off 
client connection.  

 
OR  

 
Error while saving 
records. 

 

Test your database connection and make sure the database server and listener 
have successfully started. 

userid:  following 
logging levels are 
used in 
application 

 

userid:  fatal - The 
FATAL level 
designates very 
severe error 
events that will 
presumably lead 
the application to 
abort 

 INFO - The INFO level designates informational messages that highlight the 
progress of the application at coarse-grained level. 
 

 ERROR - The ERROR level designates error events that might still allow the 
application to continue running. 
 

 DEBUG - The DEBUG Level designates fine-grained informational events that 
are most useful to debug an application. 
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Troubleshooting Guidelines Related to Agile PLM for 
Process 

The tables below list Agile PLM for Process related errors and their solutions. 

Use the table below if you have mapped an Extended Attribute, or a Project Metric, via an insert to 
the appropriate mapping table, but it does not show up in OBIEE. 
 

Did  you . . .  So lut ion  

commit the insert? 
By default, Oracle DB sessions does not automatically 
commit any changes. 

run the ODI Operator after the commit? See main guide for information on how to run ODI. 

run the ODI Operator run to successful 
completion? 

If the ODI Operator did not successfully complete, then 
check the TLOG table for mapping error messages. 

also modify the RPD file (via the OBIEE 
Administrator) to enable the viewing of those 
fields in the appropriate Subject Area? 

Only if the text for the column you mapped to 
begins with USRDEF_. 

If not, then modify the RPD file. 

restart the OBIEE service and/or flush its cache 
after completing the above changes? 

You must flush the cache and restart the OBIEE 
service. 

 

 

On occasion you may get a TLOG table error message.  The table below lists some of the most 
frequent TLOG table error messages and their solutions. 
 

TLOG Table  Message  Solut ion  

There is a config error in P4P_METRIC_CONFIG_MAP. 
Unsupported Table.  Use one of the following tables: 
P4P_PRJ_SUM_FS, P4P_PRJ_DET_FS, 
P4P_PROJECT_DS and P4P_PRJ_METRICS_FS. 

Inspect the records in the 
P4P_METRIC_CONFIG_MAP table 
for an unsupported table, and fix. 

There is a config error in P4P_METRIC_CONFIG_MAP. 
Multiple metrics mapped into same column. 

Inspect the records in the 
P4P_METRIC_CONFIG_MAP table 
for two rows where the table_name 
and column_name values are the 
same.  Remove or fix duplicates. 
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TLOG Table  Message  Solut ion  

There is a config error in P4P_METRIC_CONFIG_MAP.  
Project Metric mapped to same column as Extended 
Attribute. 

Inspect and compare the table_name 
and column_name values of the records 
in the P4P_METRIC_CONFIG_MAP 
and P4P_CONFIG_EA tables.  
Remove or fix duplicates. 

There is a config error in P4P_METRIC_CONFIG_MAP. 
XXXX.YYYY is not a valid column. 

Please refer to the legal destination table 
and column names list elsewhere in this 
document. 

Could not find Metric Definition for fully qualified metric: 
XXXXX. 

Double-check the name of the NPD 
Project Metric in the Agile PLM for 
Process source projects.  Remember it 
will probably have some underscore 
characters in it separating the Basis, 
Phase and Fiscal Year qualifications. 

Could not find Metric Definition for metric base name: 
XXXXX. 

Double-check the name of the NPD 
Project Metric in the Agile PLM for 
Process source projects.  Remember it 
will have NO qualification suffixes 
attached to it for Basis, Phase nor Fiscal 
Year. 

Attempt to map Text Metric to non-text column. 

OR 

Attempt to map numeric or date Metric to non-numeric 
column 

Inspect and verify the data-types of the 
table_name and column_name 
values of the records in the 
P4P_METRIC_CONFIG_MAP table 
and the NPD Project Metrics that are 
mapped to them.  Refer to the legal 
destination list elsewhere in this 
document. 
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