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Preface

This guide is intended for administrators and operators of Oracle's StorageTek SL3000 
modular library system. It assumes the reader is familiar with the SL3000 library 
modules and components. For introductory and planning information, see the SL3000 
Systems Assurance Guide on OTN at:

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.h
tml

Documentation Accessibility
For information about Oracle's commitment to accessibility, visit the Oracle 
Accessibility Program website at 
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or 
visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing 
impaired.

Conventions
The following text conventions are used in this document:

Convention Meaning

boldface Boldface type indicates graphical user interface elements associated 
with an action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for 
which you supply particular values.

monospace Monospace type indicates commands within a paragraph, URLs, code 
in examples, text that appears on the screen, or text that you enter.

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
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1Introduction

Oracle's StorageTek SL3000 Modular Library System is an enterprise storage solution 
that provides fully automated tape-cartridge storage and retrieval. This document 
provides guidelines for library and device management using StorageTek Library 
Console (SLConsole).

For more information related to the SL3000 library, see the following documents on the 
Oracle Technical Network (OTN) at:

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.h
tml

■ SL3000 Systems Assurance Guide - overview of the library and installation planning 
guide

■ SL3000 Host Connectivity Guide - networking information on Dual TCP/IP, 
redundant electronics, and partitioning

■ SL3000 Barcode Technical Brief - barcode and label guidelines

■ SL3000 SNMP Reference Guide - SNMP information

■ Library management software documentation:

■ ACSLS Administrator's Guide

■ ELS System Programmer's Guide

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
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2StorageTek Library Console

Oracle's StorageTek Library Console (SLConsole) is a Java-based software application 
that provides a graphical user interface (GUI) for monitoring and managing the 
StorageTek SL3000. You can perform activities with the SLConsole such as:

■ View and modify status and properties of the library and associated devices 
(drives, CAP, robot, and elevators)

■ Perform an audit, self-test, or diagnostic move

■ Locate or move a cartridge

■ Display library logs, status messages, error explanations, context-sensitive help

■ Download new library firmware while the library is in operation

SLConsole Modes
Throughout this document you can perform the procedures using any SLConsole 
mode, unless otherwise noted.

■ "Local Operator Panel" on page 2-8

■ "Web-launched SLConsole" on page 2-5

■ "Standalone SLConsole" on page 2-7

Download the SLConsole Media Pack
The Media Pack includes the web-launched SLConsole server, web-launched 
SLConsole client, and the standalone SLConsole.

1. Go to the Oracle Software Delivery Cloud at:

http://edelivery.oracle.com/

2. Click Sign In/Register. Sign in or register.

3. On the Terms & Restrictions screen, read the License Agreement and Export 
Restrictions, and select the check boxes to indicate your acceptance. Click 
Continue.

4. On the Media Pack Search screen:

a. In the Select a Product Pack list, select Oracle StorageTek Products.

b. In the Platform list, select Generic Platform.

c. Click Go.
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5. Select the SLConsole version to download, click Continue.

6. To review the download instructions, click Readme. Optionally, use the View 
Digest button to verify the MD5 and SHA-1 digests of the download files.

7. Verify the SLConsole version is correct, click Download.

8. Save the file.

9. Extract the media pack to the desired location.

SLConsole Screen Display

Figure 2–1 SLConsole Screen Layout

Callout Component Name Description

1 Menu bar: Includes the Tools 
Menu and the Help Menu

Tools — access to SLConsole utilities

Help — access to the help system and identifies the SLConsole version

2 Title bar Displays the title of the current page

3 Function tabs Identifies the available functions for a page

4 Options bar Contains buttons related to active utility. Always includes the Help button (?).

5 Work area Location of the page data

6 Library health indicator Identifies the library connected to SLConsole, and displays library health

7 UserID indicator Displays the user ID currently logged in to the SLConsole
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Modifying the Screen Layout
■ To sort a column: Click the heading of the column. The initial sort is in ascending 

order. Click the heading again to switch between ascending and descending order.

■ To arrange the columns: Click and drag a column heading horizontally to any 
position in the heading row.

■ To resize the columns: Click the border of the column heading and drag it left or 
right to change the column width.

Synchronizing the SL Console With the Controller Database
SLConsole receives library configuration data from the library controller. 
Configuration data may be unavailable if you log in to SLConsole before the library is 
fully initialized. Exit and log in again after initialization. Additionally, configuration 
data displayed during an audit may not be accurate until the audit completes.

Library Configuration Updates
SLConsole displays the most recently saved data from the library controller database. 
When the configuration changes (such as taking a drive offline, or removing or adding 
a cartridge), synchronize SLConsole by clicking the Refresh button.

Multiple users can access the library simultaneously. Coordinate with other library 
users when making major modifications to the configuration (such as adding modules, 
defining partitions, and so on), to prevent conflicts.

In SLConsole, no changes are made to the library controller database until you click 
the Apply button.

SLConsole Help
The SLConsole help displays information about SLConsole utilities.

■ To display context-sensitive help for the current SLConsole screen, click the ? 
button in the Options bar.

■ To display general help information, click Help > Contents in the Menu bar.

SLConsole help uses JavaHelp. For information about the JavaHelp interface, see: 
http://docs.oracle.com/cd/E19253-01/819-0913/

SLConsole Reports
The SLConsole library reports provide information on the library and its associated 
devices, events, and tape cartridges. Use the reports to monitor library activity and 
identify potential problems (see "Library Reports" on page 6-4).

8 Server communication indicator Displays current heartbeat monitor indicating server communication health

9 Navigation tree Lists the devices included in the library

Note: Running multiple instances of SLConsole on the same 
workstation can cause inconsistent data on reports. Only one user per 
workstation should produce reports, unless all instances of SLConsole 
are the same version.

Callout Component Name Description
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Report Types
■ Log: Detailed system event logs

■ Statistics: Statistical information on library operations

■ Status Detail: Details on the status of the library and associated devices, such as 
CAPs, drives, and robots

■ Status Summary: Summary information on the status of the library and devices

■ Version: Details about library hardware and software versions

User Management
To access SLConsole you must have a valid user ID and password. Only one user at a 
time can log in to the local operator panel, but any number of users can log in to the 
standalone or web-launched SLConsole.

User IDs
The user ID controls user authorization. Each user ID is assigned a set of permissions, 
which determines access to utilities within SLConsole. There are a fixed set of user IDs 
at each site:

■ admin: customer administrator

■ service: Oracle support representative

■ oem: third-party field service technician

Passwords
The library administrator must activate the admin user ID with the first 8 characters of 
a one-time use activation password provided by an Oracle support representative. 
After logging in with the activation password, the administrator should change the 
admin user ID password to ensure system security.

For details about this process, Oracle representatives can refer to the SL3000 Installation 
Guide.

Change a User Password
1. Log in to the SLConsole using the account you want to modify.

2. Select Tools > User Mgmt

3. On the navigation tree, expand the Permanent folder. Select the current user 
account

4. Complete the following fields: Current Password, New Password, and Retype 
Password.

5. Click Modify.

SLConsole Login
When you log in to SLConsole you must provide.

■ User ID: SLC_login. SLConsole user ID.

■ Password: password. Password assigned to this user ID. (Beginning with 
SLConsole 4.50 password must be between 5-8 characters.)
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■ Library: library_ID. Either the IP address or DNS alias of the library to which to 
connect. 

Automatic Logout
After six hours (default), the SLConsole session will expire. The system allows four 
attempts to log back in, the logs the user ID out. To log in, return to the main login 
screen.

SLConsole Logoff
Before you log off, make sure all operations for the current SLConsole session have 
completed (for example, code loads, audits, diagnostic moves).

1. Select Tools > Log Off.

2. Click OK.

3. Click Exit to close the SLConsole.

Web-launched SLConsole
The web-launched version enables SLConsole to be installed on a centralized server. 
Then, individual clients can use a web browser to download the web-launched 
SLConsole. Using the Web-launched SLConsole you can connect to any library for 
which you have a valid user ID.

To install the web-launch version on a server, download the web-launch SLConsole 
server (.war) file from the Oracle Software Delivery Cloud (see "Download the 
SLConsole Media Pack" on page 2-1). Deploy the file on the web-server of your choice. 
The web-launched SLConsole is delivered to clients as a Java Web Start process, which 
executes outside the browser.

You only have to install updates to the web-launched SLConsole on the centralized 
web-server. You can update the web-launched SLConsole server while it is running. 
After the updates are installed on the server, they are downloaded automatically to all 
clients whenever the application is started.

Security Considerations
The web-launched SLConsole software is digitally signed, which guarantees that it has 
been issued by Oracle Corporation and has not been altered or corrupted since it was 
created. As a Java Web Start process, the Web-launched SLConsole includes the 
security features provided by the Java 2 platform.

The customer is responsible for implementing all appropriate security systems, 
including firewalls, user access, and so on.

Client Requirements

Platform
■ Solaris 9: SPARC (Firefox 2.x) or Solaris 10: SPARC (Firefox 2.x)

■ Windows 2000: 32 bit (IE 5, IE 5.5, Firefox 2.x)

■ Windows XP: 32 or 64bit (IE 7, Firefox 3.x), Windows 7: 64 bit (IE 7, Firefox 3.x)
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Other
■ Java 1.5 Plug-in (the browser should install this automatically)

■ Ethernet connection to the Web-launched SLConsole server

Log in to the Web-launched SLConsole
To log in using a web-browser, download a recent version of the Firefox web-browser 
from http://www.mozilla.com. On Solaris platforms, you can also log in to the 
web-launched SLConsole using the command line. 

1. Obtain the DNS alias or IP address of the SLConsole server. See your library 
administrator for assistance.

2. Choose a login method:

– Command line: Available on Solaris only. In the terminal window, enter:

javaws http://server_ID:port_ID/opel/slc.jnlp

– Web browser: Available on either Windows or Solaris. In a web-browser on 
the client workstation go to the SLConsole Web Start application:

http://server_ID:port_ID/opel

where:

■ server_ID: Either the IP address or DNS alias of the SLConsole server

■ port_ID: Port ID of the SLConsole application, typically 8080

■ opel: The name (context root) of the Web-launched SLConsole application on 
the server.

3. Click Launch Now.

4. Complete the Opening slc.jnlp dialog box:

a. Specify the action to take with the slc.jnlp file:

Select Open with Java(TM) Web Start Launcher to start the SLConsole 
directly.

Select Save to Disk to save the slc.jnlp file to your client and log in to the 
SLConsole later (see "Log in to the Web-launched SLConsole Using an Icon" 
on page 2-6).

b. Optionally, select Do this automatically for files like this from now on.

c. Click OK.

5. If this is your first time running the web-launched SLConsole, complete the digital 
signature warning dialog box:

a. Verify the Publisher.

b. Optionally, select Always trust content from the publisher.

c. Click Run.

6. Enter your SLConsole login information, and click Log on.

Log in to the Web-launched SLConsole Using an Icon
You must first save the web-launched SLConsole slc.jnlp file to your client (see"Log in 
to the Web-launched SLConsole" on page 2-6).
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1. Double-click the slc.jnlp desktop icon on your client.

2. Click Launch Now.

3. If this is your first time running the web-launched SLConsole, complete the 
security warning dialog box:

a. Verify the publisher is Oracle Corporation.

b. Optionally, select Always trust content from the publisher.

c. Click Run.

4. Enter your login information, and click Log on.

Standalone SLConsole
The standalone version runs SLConsole remotely from any workstation with a 
network connection to the library.

You must deinstall the previous version before installing a new version of the 
standalone SLConsole. Running multiple versions of SLConsole on the same 
workstation can cause inconsistent data.

Security Considerations
The SLConsole application interfaces with the primary library interface (PLI) over a 
secure sockets layer (SSL). SSL provides a secure communication path between the 
library and the customer's SLConsole session. This security prevents an unauthorized 
network user from monitoring library activity.

Installation Requirements

Platform
■ Solaris 9: SPARC, Solaris 10.9 SPARC, or Solaris 10.9 x86

■ Windows Server 2003, Windows Server 2008 SP2: 64bit, Windows XP SP3: 32 or 
64bit

■ Windows Enterprise 7 SP1: 64bit

■ Oracle Unbrakable Linux 5

■ SUSE Enterprise Linux 10.2

Other
■ Ethernet connection to the library

Install the Standalone SLConsole
De-install any older versions of SLConsole before installing an update.

1. Download and extract the standalone SLConsole media pack (see "Download the 
SLConsole Media Pack" on page 2-1).

2. Select the SLConsole installer file for your operating system (refer to the media 
pack readme).

3. Review the information. Click Next.

4. Specify where to install the SLConsole program. Click Next.
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5. Specify where to create the SLConsole shortcut icons. Click Next.

6. Verify the information is correct. Click Install.

7. Click Done.

Log in to the Standalone SLConsole
1. To start the SLConsole application on your client workstation either:

■ Double-click the SLConsole icon on the desktop.

■ Select Start > RunSLConsole or Launch > RunSLConsole.

2. Enter your login information, and click Log on.

Local Operator Panel
The local operator panel is built in to the Customer Interface Module. It enables you to 
run most of the SLConsole utilities directly at the library. LEDs located directly below 
the local operator panel provide status information:

■ Active: Library processor is working.

■ Wait: Library firmware is loading.

■ Service Required: Library is rebooting.

Virtual Keypad
For screen fields that require text entry, click the keyboard icon to display the virtual 
keypad. Invalid characters are grayed out.

Log in to the Local Operator Panel
Only one user at a time can log in to the local operator panel.

1. If the screen is blank, touch the screen anywhere to activate the Login screen.

Note: On Solaris, you must choose something other than the default 
root directory. It is recommended you choose /u-sr/bin or a similar 
location.

Table 2–1 Virtual Keypad Controls

Button Function

Insert If highlighted, inserts text at the cursor position. If not highlighted, replaces text 
to the right of the cursor. 

Home Places cursor at the beginning of the field.

Del Deletes character to the right of the cursor.

End Places cursor at the end of the field.

Back Deletes character to the left of the cursor

Clear Clears the entire field

Left Moves cursor one character to the left

Right Moves cursor one character to the right
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2. Use the virtual keypad to enter your login information.

3. Click Log on.

Touch Screen Calibration
Alignment of the local operator panel touch screen is calibrated at the factory. If the 
touch screen becomes mis-alignment, re-calibrate or reset the touch screen.

■ If you have a Linux-based local operator panel, you can re-calibrate it yourself or 
reset it to factory setting with the procedures below.

■ If you have a Windows-based local operator panel, contact your Oracle support 
representative.

Re-calibrate the Local Operator Panel
For an accurate calibration, make sure there is no debris on the touch screen.

1. Log in to the local operator panel.

2. Select Tools > Calibrate.

3. Tap Calibrate.

4. Gently tap in the center of each target with your finger or a pointing stylus.

5. To save the new settings:

a. Tap the Click Me buttons within the indicated time period.

If the buttons do not depress, the touch screen is not properly aligned. Discard 
the new settings, see Step 6.

b. Click OK to save the new settings.

6. To discard the new settings:

a. Let the timer run out without tapping the Click Me button.

b. Return to Step 4 and re-calibrate.

The local operator panel reboots automatically after an unsuccessful second 
calibration and restores the previously saved alignment.

Reset the Local Operator Panel Calibration
To restore the alignment to the factory settings:

1. Log in to the local operator panel.

2. Select Tools > Calibrate.

3. Click Reset Calibration. The local operator panel reboots.
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3Hardware Activation Files

The hardware activation utility enables you to activate and monitor selected optional 
features on the SL3000 library. Some library features are activated by the customer, 
while other must be installed and enabled by an Oracle support representative. 
Features you can activate include capacity upgrades, dual TCP/IP, redundant 
electronics, and partitioning.

■ "Oracle Hardware Activation Files" on page 3-1

■ "Hardware Activation File Installation Overview" on page 3-1

■ "Download a New Hardware Activation File" on page 3-2

■ "Install a New Hardware Activation File on the Target Library" on page 3-2

■ "Delete a Hardware Activation File" on page 3-3

■ "Display Current Hardware Activation Files" on page 3-3

■ "Display the Feature Audit Log" on page 3-3

Oracle Hardware Activation Files 
An Oracle hardware activation file is a digitally signed Java Archive (.jar) file 
containing a feature activation key. You must install one hardware activation file for 
each feature purchased. Once installed, the feature is added to the features already 
activated on the library. 

Legacy Hardware Activation Files 
For SL3000 libraries prior to firmware version FRS_3.0, hardware activation files are 
delivered by e-mail from Oracle Corporation. In addition, all features purchased for a 
library are included in a single hardware activation file. When you install a new 
hardware activation file on the library, it overlays any previously installed activation 
files. 

After upgrading to firmware version FRS_3.0 and above, use the process described in 
this chapter to activate new features.

Hardware Activation File Installation Overview 
1. Purchase a feature for an Oracle StorageTek library from Oracle. 

2. "Download a New Hardware Activation File" from Oracle Software Delivery 
Cloud and save it to a system accessible to your SLConsole session. 

3. "Install a New Hardware Activation File on the Target Library" using SLConsole. 
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4. Configure the new feature. See: 

a. Chapter 4, "Capacity Activation"

b. Chapter 5, "Library Partitioning"

c. Chapter 7, "Redundant Electronics"

Download a New Hardware Activation File 
1. Go to the Oracle Software Delivery Cloud at:

http://edelivery.oracle.com/

2. Click Sign In /Register.

3. On the Terms & Restrictions screen:

a. Read the License Agreement and Export Restrictions, and select the check 
boxes to indicate your acceptance.

b. Click Continue.

4. On the Media Pack Search screen:

a. In the Select a Product Pack list, select Oracle StorageTek Products.

b. In the Platform list, select Generic Platform.

c. Click Go.

5. Select the SL8500 hardware activation file media pack. Click Continue.

6. Verify that you have selected the correct media pack. Click Download beside each 
desired feature. 

7. Save the file.

8. Extract the files to a location that you can reach from SLConsole.

Install a New Hardware Activation File on the Target Library 
1. Complete the steps in "Download a New Hardware Activation File" on page 3-2.

2. Use SLConsole to log in to the target library.

3. Select Tools > Hardware Activation.

4. Click the Install Hardware Activation Keys tab. 

5. Enter the full path of the hardware activation file to install, and press Enter. 
Optionally, click Browse and navigate to the file location.

6. Review the hardware activation file details, and then click Compare. Changes that 
will be implemented by the new hardware activation file, such as additional 
capacity or expiration date changes, are highlighted in red. Click OK.

7. Click Install.

8. Click Yes, then OK.

9. Verify that the activation file has been installed and activated successfully (see 
"Display Current Hardware Activation Files" on page 3-3). 

Depending on the features activated, you may need to perform additional tasks to 
use the new features (refer to the feature-specific chapter).
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Delete a Hardware Activation File 
Deleting a hardware activation file is rarely necessary and can impact library 
operations. Having extra hardware activation files installed on a library does not 
present any problems (for example, capacity activation files that exceed the physical 
capacity of the library). The extra activation files are simply not used. 

1. Use the SLConsole to log in to the target library.

2. Click Tools > Hardware Activation.

3. Click the Delete Hardware Activation Files tab.

4. Click the activation file to delete.

5. Verify the correct activation file is selected, and click Delete....

6. Click Yes.

Depending on the feature of the hardware activation file, you may need to 
perform additional tasks after deleting the file (refer to the feature-specific 
chapter).

Display Current Hardware Activation Files 
To display the features currently activated on a target library:

1. Select Tools > Hardware Activation. 

2. Select the Current Hardware Activation Keys tab.

Display the Feature Audit Log 
The Feature Audit Log displays a list of all feature activation activity for the life of the 
library. Use this log to verify the features installed on the library. 

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns (see "Modifying the Screen Layout" 
on page 2-3). 

1. Select Tools > Reports.

2. Expand the Audit Logs folder, and select the Feature Audit Log tab. The Feature 
Audit Log page appears. 
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4Capacity Activation

There are two types of capacity:

■ Physical capacity — the number of storage cells that are physically present in the 
library.

■ Active capacity — the number of storage cells activated with a hardware 
activation file. The active capacity does not have to equal the full number of 
physical storage cells.

Configuring Active Capacity
In a non-partitioned library, purchased capacity is automatically activated after 
installing the hardware activation file. However, you can customize the configuration 
and select which cells will be automatically activated (see "Capacity Activation Tasks" 
on page 4-2). The automatic configuration activates storage cells in the same order as 
SCSI element numbering (see "Default Capacity Assignment" on page A-7). 

In a partitioned library, capacity is assigned automatically, but the total number of 
storage cells allocated to all library partitions cannot exceed the activated capacity (see 
"Library Partitioning" on page 5-1). 

Coordinate with other library users before configuring the library to prevent conflicts.

HLI Connections
With HLI libraries, you can increase active capacity without stopping host jobs or 
having host connections go offline. When you decrease capacity, the library goes 
offline only momentarily and then comes back online automatically. After a 
configuration change, ACSLS and ELS must perform an audit of the library to account 
for the new library configuration information. Hosts can continue processing jobs 
while the audit takes place.

Adding Active Capacity
Whenever you add active storage cells, the library stays online. The library controller 
sends an asynchronous message to all hosts notifying them that the library 
configuration has changed.

Removing Active Capacity
The library goes offline temporarily whenever you deactivate a storage cell or remove 
an empty drive slot. The library comes back online after the configuration change is 
updated in the library controller database. The library controller sends an 
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asynchronous message to all hosts notifying them that the library configuration has 
changed.

FC-SCSI Connections
With FC-SCSI libraries, the library goes offline temporarily with a Unit Attention 
condition whenever you:

■ Activate or deactivate a storage cell, drive, or CAP cell

■ Add, change, or remove a host LUN connection

Multiple error messages may be generated, and all hosts must issue the appropriate 
commands to update their library configuration information. See the appropriate tape 
management software documentation for detailed procedures and commands. In the 
case of adding or removing drives, the device SCSI numbering is updated as well.

Orphaned Cartridges
In non-partitioned libraries, an orphaned cartridge is a cartridge located in an inactive 
storage cells. In partitioned libraries, an orphaned cartridge is a cartridge located in a 
non-allocated cell or drive. Orphaned cartridges are inaccessible to all hosts.

A cartridge can become orphaned when reducing active storage capacity, changing 
partitioning, or manually moving a cartridge to an inaccessible cell.

If the SLConsole identifies an orphaned cartridge, it displays a warning message. To 
help resolve an orphaned cartridge, you can generate a report of orphaned cartridges, 
perform an audit of the library, or perform a recovery move on a cartridge. to 
resolving orphaned cartridges, see "Moving Cartridges (Recovery Moves)" on 
page 10-4. 

Capacity Icons in SLConsole

Capacity Activation Tasks
Capacity changes cannot be performed at the local operator panel.

No changes are committed to the library controller database unless you click Apply at 
the top of the screen and confirm your choice. If you log off the SLConsole session, if 
the session times out, or if the connection to the library is lost before you save changes, 
any changes will be lost. At any time, you can discard changes and restore the last 
saved configuration by clicking Refresh.

Table 4–1 Capacity Icons

Icon Description

(rectangle with X) Not Accessible — cell not available for activation (reserved for 
diagnostic cartridges, physically blocked, and so on).

(white rectangle) Inactive — cell not yet licensed for use

(rectangle with triangle) Active — cell licensed for use

(purple rectangle) Selected — cell designated for activation or deactivation

(brown rectangle) No activation needed — resource is active by default
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Modify Active Storage Regions
You can customize the active storage region by activating or deactivating storage cells 
or deselect storage cells so they will not be automatically activated when capacity is 
increased.

1. Select Tools > Select Active Cells.

2. Click a module to modify.

3. Click the Select Active Cells tab.

Click Move Left or Move Right to display an adjacent module.

4. Choose the Select by method, and click either the Add or Remove option.

5. Use the library map to select the storage cells you want to activate or deactivate.

6. To confirm and verify your changes, click Apply.

7. If there are no warnings, click OK. Proceed to step 9.

8. If there are warnings, click Details.

If orphaned cartridges are reported, do not continue with this procedure until you 
have performed recovery moves on the listed cartridges (see "Moving Cartridges 
(Recovery Moves)" on page 10-4).

9. Reconfigure library host applications to recognize the changes (see the tape 
management software documentation).

Display Active Cells Report
These reports only display data saved to the library controller database.

1. Click Tools > Select Active Cells, and then click the View Reports tab.

2. Select a report:

■ Cartridge Cell and Media Summary: Displays a detailed list of all library 
resources and their status (active or inactive).

■ Orphaned Cartridge Report: Displays a detailed list of all orphaned 
cartridges.

3. To save the report as a comma-sperated value (csv) file, click Save to File.

Display Active Cell Detail
Use this procedure to display which storage cells are currently active, inactive, or 
selected for activation. You can also display detailed information about cartridge, 
drive, and storage cell locations.

1. Select Tools > Select Active Cells.

2. Select the module you want to display.

Note: Capacity is automatically applied in a partitioned library. You 
may only manually activate capacity in a non-partitioned library.

Note: You may perform this task at the local operator panel.
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3. Select the Current Active Cells tab. You can mouse-over a cell or drive to display a 
tooltip of detailed information.
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5Library Partitioning

Library partitioning reserves library resources (drives, cells, and CAPs) for the 
exclusive use of specified hosts. Each partition appears to the host as a separate library. 
Partitioning is an optional feature enabled with a hardware activation file (see 
"Hardware Activation Files" on page 3-1).

The SL3000 library partitioning specifications include:

■ Up to eight partitions

■ Smallest increment is a single storage cell, single tape drive, or CAP

■ Support for non-contiguous resource assignments

■ The total number of storage cells allocated to all library partitions cannot exceed 
the activated capacity of the library (see "Configuring Active Capacity" on 
page 4-1).

■ Supports "HLI Hosts" or "FC-SCSI Hosts" (one type per partition)

Partitioning CAPs

A partition can only use a CAP explicitly allocated to it. All cells in the CAP are 
allocated as a whole to the partition. It is not possible to allocate or remove individual 
cells within a CAP (the library does not support common CAPs, split CAPs, or the 
allocation of individual CAP cells to a partition).

Because a library can have more partitions than CAPs, it may be necessary to share 
CAPs among partitions. Only partitions with the same host interface type (FC-SCSI or 
HLI) can share a CAP. Each partition can have dedicated CAPs or shared CAPs, but 
not both. A shared CAP can be used by only one partition at a time (see "HLI CAP 
Reservations" on page 5-2 and "FC-SCSI CAP Associations" on page 5-3).

HLI Hosts 
An HLI partition can have up to 16 assigned hosts. You define the HLI host-partition 
connection configuration through the library management software, ACSLS or ELS, 
(see the tape management software documentation).

Note: AEM CAPs are subject to the same partitioning rules and 
restrictions as rotational CAPs. In this chapter, the term CAP refers to 
both types of CAPs, unless otherwise specified. 
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A single ACSLS server can manage multiple partitions in the same library. Each 
partition is configured as a separate automated cartridge system (ACS). 

ELS hosts using a common control data set (CDS) database (called a host group) can 
share one partition. A single ELS CDS database can manage more than one partition 
within the same SL3000 library. Individual HSC hosts and groups of up to 16 ELS 
hosts that share a common control data set can control a single partition. 

Configuration Changes in HLI Partitions 
A partition remains online when allocating resources to the partition. You do not need 
to stop host jobs. However, a partition will go offline when resources are removed 
from the partition. The partition automatically comes back online and the library 
notifies all hosts connected to the partition that a configuration change has occurred. 
Neighboring partitions are always left undisturbed. After allocating or removing 
resources, the hosts experience a brief interruption as library configuration 
information is updated. The host automatically continues to process jobs.

HLI CAP Reservations 
HLI hosts use a reservation scheme to manage CAP usage. Each host reserves a CAP 
for exclusive use as needed, then releases the CAP when it is no longer required. A 
host can reserve a CAP if the CAP is empty, closed, locked, and not already reserved 
by another partition. After an enter or eject operation completes, the host terminates 
the command. Then, the library controller releases the CAP after verifying that the 
CAP is closed and empty. 

If for any reason a CAP reservation is not released and the enter or eject command 
cannot be terminated in ACSLS or HSC on the host, a library administrator must 
override the host partition reservation (see "Override a CAP Reservation" on page 5-8).

CAP Auto Enter Mode
CAP auto enter mode enables a library operator to open a CAP and initiate an enter 
operation without issuing an explicit enter request and without an explicit reservation 
from a host application. Auto enter mode is available for HLI CAPs that have been 
dedicated to a partition. CAPs in auto enter mode are left unlocked. 

Auto enter mode is managed by host applications (see the tape management software 
documentation).

CAP States 

FC-SCSI Hosts 
An FC-SCSI partition can have one or more host-partition connections. However, some 
host applications may not allow for CAP sharing (see "FC-SCSI CAP Associations" on 
page 5-3). 

Table 5–1 Default States of HLI CAPs in Partitioned Library

Type of CAP
Default 
State

Default CAP 
Light Condition Comment

Dedicated or shared Locked Off Host reservation unlocks the CAP and 
turns the light on.

Auto enter mode Unlocked On N/A
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Configuration Changes in FC-SCSI Partitions 
The host-partition connection configuration is user-defined and consists of the world 
wide port name of the FC-SCSI host bus adapter and the logical unit number (LUN) of 
the host. 

After adding or deleting a host-partition connection or changing the LUN, the affected 
partition goes offline with a "LUNS Data Has Changed Unit Attention" condition. If a 
host has unique ITL nexus connection mappings for each partition connection, then 
only the partition experiencing the connection change is affected.

After allocating or removing a storage cell, drive, or CAP in a partition, the affected 
partition goes offline with a condition of "Mode Parameters Have Changed Unit 
Attention". 

Neighboring partitions and their connected hosts are not disturbed. The hosts 
connected to an affected partition must issue the appropriate commands to update 
their library configuration information (see the tape management software 
documentation).

FC-SCSI CAP Associations 
Most FC-SCSI host applications typically assume sole ownership of a CAP and 
therefore do not coordinate CAP sharing. To avoid contention among partitions for a 
shared CAP, you must manually associate a partition to a CAP for an enter or eject 
operation (see "Enter/Eject Cartridges for FC-SCSI Partition with Shared CAP" on 
page 5-8).

The following rules apply when making partition-CAP associations: 

■ You can associate only one partition at a time to a CAP. 

■ Selecting a partition causes all its allocated CAPs to become associated. You cannot 
select an individual CAP. 

■ Partition-CAP associations remain active until you explicitly remove them, the 
CAP becomes allocated to a different partition, the library reboots, the power 
cycles, the library door open/closes, or the CAP initializes. 

If a partition-CAP association is removed while the CAP is open or has cartridges in it, 
the CAP ownership will be changed to the default requester (the library controller), 
and the CAP will be unavailable to all partitions. You must empty and close the CAP 
before it can be associated to any partitions. 

CAP States 

Deleting the Partitioning Feature 
To delete an individual partition, see "Delete a Partition" on page 5-6. To delete the 
partitioning feature, you must delete the partitioning hardware activation file from the 

Table 5–2 Default States of FC-SCSI CAPs in Partitioned Library

Type of CAP
Default 
State

Default CAP 
Light Condition Comment

Dedicated Unlocked On N/A

Shared Locked Off Partition-CAP association unlocks the CAP 
and turns the light on.
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library (see "Delete a Hardware Activation File" on page 3-3). You must reboot the 
library after deleting the partitioning activation file for the deletion to take effect. 

Deleting the partitioning feature has the following effects on the library configuration: 

■ Changes the library state to non-partitioned. 

■ Makes all activated storage cells, drives, and CAPs accessible to hosts. 

■ All existing partition summary information and resource allocations are retained, 
but not usable. If the partitioning activation file is later re-installed, the partition 
allocations are restored. 

Hardware Changes to a Partitioned Library 
Some library hardware changes may require modification of an existing partitioned 
module. Use the following process to make such hardware changes without losing 
partitioning information for unchanged library sections. 

1. All resources that will be affected by the hardware change must be removed from 
their respective partitions (see "Module Map & Design Tabs - Design a Partition" 
on page 5-6).

2. Power down the library (see "Power Off the Library" on page 13-2). 

3. Install the hardware change. 

4. Power up the library (see "Power On the Library" on page 13-3). 

All partition allocations for the unchanged parts of the library remain in effect. 

5. Allocate the library resources that have been added due to the hardware change 
(see "Module Map & Design Tabs - Design a Partition" on page 5-6). 

Partitioning Icons in SLConsole

Library Partitioning
■ "Instructions Tab - Prepare for Partitioning" on page 5-5

Caution: The partitioning feature cannot be deleted if it was 
activated by a legacy hardware activation file prior to SL3000 
firmware version FRS_3.0.

Table 5–3 Partitioning Icons

Icon Description

(rectangle with X) Not Accessible — resources not available for host operations 
(reserved system cell, physically blocked, and so on).

(white rectangle) Unallocated — resource unassigned to a partition and available 
for assignment

(yellow rectangle) Partition # — resources assigned to the current partition

(red rectangle) Other Partitions — resources assigned to another partition

(gray rectangle) Shared CAP — a CAP assigned to multiple partitions
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■ "Summary Tab - Add, Delete, or Modify a Partition" on page 5-5

■ "Module Map & Design Tabs - Design a Partition" on page 5-6

■ "Commit Tab - Confirm Partitioning Changes" on page 5-7

■ "Reports Tab - Generate Partitioning Reports" on page 5-7

■ "Current Partition Definitions Tab" on page 5-8

Instructions Tab - Prepare for Partitioning 
1. Quiesce any host operations. 

You should make the library unavailable to other users before committing 
partitioning changes. Configuration conflicts may arise if you change partition 
boundaries while other users are assessing the library.

2. Select Tools > Partitions.

3. Review the Instructions tab.

Summary Tab - Add, Delete, or Modify a Partition 
You can create up to eight partitions.

Add a Partition
1. Select the Summary (Step 2) tab of the Partitions interface.

2. In the Partition Allocation Summary area, click Add Partition.

3. Select the Partition ID and enter the Name and Interface Type. Partition IDs do not 
need to be contiguous. 

4. Click OK.

5. Repeat steps 2-4 until you have added all the required partitions.

6. For FC-SCSI partitions, you must add a host connection (HLI host-partition 
connections are configured through the host library management software):

a. In the Partition Allocation Summary area, click the partition.

b. Click Add Connection.

c. Enter the Initiator (WWPN) and LUN. Each initiator connected to the library 
must have one library partition assigned to LUN 0.

d. Click OK.

e. Repeat steps a - d until you have added all required FC-SCSI connections. 
Each partition can have up to nine host connections, and each host can connect 
to multiple partitions. 

7. Design the partition (see "Module Map & Design Tabs - Design a Partition" on 
page 5-6).

Note: No actual changes to partitioning occur until the design is 
applied using the Commit tab. At any time, you can discard all 
uncommitted partition changes by clicking the Refresh button.
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Delete a Partition 
When you delete a partition:

■ All resources allocated to the partition are marked available. 

■ All host connections for the partition are deleted. 

■ The partition ID is deleted. 

To delete a partition:

1. Click the Summary (Step 2) tab of the Partitions interface.

2. In the Partition Allocation Summary area, click the partition to remove. 

3. Click Delete Partition. 

4. Click OK to confirm the deletion. If partitions still remain in the library, proceed to 
the next step.

If no partitions remain, select the library interface type you want to assign for all 
host connections to the library, either HLI or FC-SCSI. Click OK.

5. Click OK to confirm the change.

6. Commit the changes, see "Commit Tab - Confirm Partitioning Changes" on 
page 5-7. 

Modify a Partition
You cannot change the partition ID. To assign a different Partition ID, you must delete 
the old partition and create a new one with the new ID.

1. Select the Summary (Step 2) tab of the Partitions interface.

2. To modify the name or interface type:

a. In the Partition Allocation Summary area, click the partition to modify.

b. Enter the changes you want to make. Click OK.

3. To modify a FC-SCSI host connection:

a. In the Connections section, select the host-partition connection to modify.

b. Click Modify a Connection.

c. Enter the changes you want to make. Click OK.

4. Commit your changes (see "Commit Tab - Confirm Partitioning Changes" on 
page 5-7).

Module Map & Design Tabs - Design a Partition 
Library resources can be allocated to only one partition at a time. If you want to add 
currently-allocated resources to a different partition, you must first remove the 
resources from the assigned partition, and then add them to the new partition. CAPs 
can be shared (see "Partitioning CAPs" on page 5-1).

1. Click the Module Map (Step 3a) tab of the Partitions interface.

2. Click the module for which you want to design a partition. 

Caution: Changing the interface type can result in loss of active host 
connections or existing shared CAP assignments.
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3. Click the Design (Step 3b) tab.

4. Use the list control to select a partition ID.

5. Choose the Select by method, and then select either the Add or Remove option.

6. Use the library map to select the resources to add or remove. Click Move Left or 
Move Right to display an adjacent module.

7. After you have completed the partition configuration, click Verify. This checks for 
orphaned cartridges, oversubscribed capacity, and whether each host has a 
partition assigned to LUN 0.

8. If there are warnings, click Details.

If orphaned cartridges were found, perform recovery moves on the all listed 
volumes (see "Moving Cartridges (Recovery Moves)" on page 10-4). After you 
have resolved all orphaned cartridges, re-verify the partitioning configuration. 

9. If there are no warnings, repeat steps 4-8 for each partition ID. After all partitions 
are configured, see "Commit Tab - Confirm Partitioning Changes" on page 5-7.

Commit Tab - Confirm Partitioning Changes 
Use this procedure to apply the partition configuration. No changes are made to the 
library until you complete these procedures.

1. Take the library offline to ACSLS and ELS tape management software (see the tape 
management software documentation). 

2. Click the Commit (Step 4) tab of the Partitions interface.

3. Click Apply. If the library capacity is over-subscribed, the Apply button is grayed 
out. Remove storage cells from a partition or purchase more capacity. 

4. If there are no warnings, click OK. If there are warnings, click Details >>. 

If orphaned cartridges were found, perform recovery moves on all listed volumes 
before committing partitioning changes. See "Moving Cartridges (Recovery 
Moves)" on page 10-4.

5. Configure all affected library host applications (see the tape management software 
documentation).

Reports Tab - Generate Partitioning Reports 
1. Select the Reports tab of the Partitions interface. 

2. Select a report from the menu:

■ Cartridge Cell and Media Summary - displays a list of all resource partition 
assignments. 

■ Host Connections Summary - displays host-partition connection information 
for all partitions. 

■ Orphaned Cartridge Report - displays a list of all orphaned cartridges. 

■ Partition Details - displays information for a selected partition. 

■ Partition Summary - displays summary information for all partitions. 

3. To print the report data, click Print. To save the report, click Save to File. 
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Current Partition Definitions Tab 
Use this procedure to display current partition boundaries and allocations. You can 
also display detailed information about cartridge, drive, and storage cell locations. 

1. Click the Module Map (Step 3a) tab of the Partitions interface. 

2. Click the module to display. 

3. Click the Current Partition Definitions tab. You can hover over a cell to display a 
tooltip of detailed information about the cell.

CAP Operational Tasks
This section describes tasks for operating CAPs in a partition.

Enter/Eject Cartridges for FC-SCSI Partition with Shared CAP 
This procedure is not necessary for dedicated FC-SCSI CAPs. For HLI hosts or 
dedicated CAPs, see "Entering Cartridges" on page 10-5 and "Ejecting Cartridges" on 
page 10-6.

Use this procedure to give the partition exclusive ownership of a shared CAP for an 
enter or eject operation. The association remains until you explicitly remove the 
association.

1. Select Tools > Shared CAP Assignment. 

2. Select the check box of the partition into which you want to enter cartridges. 

3. Click Apply, and then OK.

4. Perform the enter or eject operation (see "Entering Cartridges" on page 10-5 and 
"Ejecting Cartridges" on page 10-6).

5. Once the operation is complete, remove the CAP association. Select 
Tools > Shared CAP Assignment.

6. Deselect the check box of the partition with the CAP associations.

7. Click Apply, and then OK.

Override a CAP Reservation 
If for any reason a CAP reservation by a partition is not released and the enter or eject 
command cannot be terminated on the ACSLS or HSC host, use this procedure to 
override the CAP reservation. 

1. Select Tools > Shared CAP Assignment. 

2. Expand the CAP folder, and then click the CAP to override. AEM CAPs are 
identified as column –31 for the left and column 31 the right. 

3. Click the Unreserve tab.

4. Click Apply to override the reservation. 

5. Click OK to continue with the override operation. 

Note: You must follow all steps in this procedure, or the CAP could 
be left unavailable to all partitions.



CAP Operational Tasks

Library Partitioning 5-9

6. If the CAP is locked, unlock it at the SLConsole (see "Lock/Unlock a CAP or 
AEM" on page 8-3).

7. Open the CAP. Remove any cartridges and label them with the partition ID.

8. Close the CAP. The CAP status changes to "unreserved".

9. Determine if the cartridges from the CAP should be re-entered into the library and 
then enter the cartridges into the correct partition.
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6Library Management

Library management tasks involve viewing the library status, device status, and alerts. 
Additionally, you can view IP addresses, library and drive controller properties, and 
event statistics.

Library and Device Status
SLConsole shows health status for devices, SLConsole communication, and the library.

Health Status of a Device
Found in navigation tree of System Details and Diagnostics page

■ Normal — library device is functioning normally

■ Warning — device is offline or operating in a degraded state

■ Error — device has experienced a failure

Communication Status
Found in lower left of all SLConsole screens. Indicates the communication status 
between SLConsole and the library controller.

■ Normal — SLConsole is communicating normally with the library controller

■ Warning — server is taking longer than 10 seconds to respond

■ Error — server is taking longer than 30 seconds respond

After about 30–60 seconds of lost communication the heartbeat monitor turns gray, 
then red, and the following error message appears:

Heartbeat message not received from the library controller.

Log off the SLConsole, and then log on again to restore communication.

Table 6–1 Status Indicators

Icon Meaning

Normal

Warning

Error
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Health Status of the Library
Found in lower right of all SLConsole screens.

■ Normal — all library devices are functioning normally

■ Warning — one or more library devices is offline or operating in a degraded state

■ Error — one or more library devices has experienced a failure

After a device error is fixed, the library health indicator changes to "Warning". The 
indicator will not change to "Normal" until the library is taken offline. If there are 
multiple problems with a device or status alert condition, the health indicator 
displays the most severe condition.

Upgrade Library Firmware
To upgrade firmware, use the SLConsole code load utility. You cannot perform a code 
download or activation at the local operator panel.

Library firmware does not contain drive code upgrades (see drive-specific 
documentation). Firmware upgrades for libraries with the redundant electronics 
feature are minimally disruptive (see Chapter 7, "Redundant Electronics"). 

Download Code to the Library Controller
1. Locate the firmware upgrade package (.jar file) at: http://edelivery.oracle.com

2. Download the code to your workstation.

3. Log in to the SLConsole.

4. Select Tools > Diagnostics, and then click the Library folder.

5. Click the Load Code tab.

6. Enter the full path of the firmware package to download, and then press Enter. 

Optionally, click Browse and navigate to the file location. 

7. Verify the contents and file name. Click Load.

8. Click OK. The download process could take up to 10 minutes.

9. After the code unpacks, activate the code at any time (see "Activate Code on the 
Library Controller" on page 6-2).

Activate Code on the Library Controller
The library controller can store up to two versions of firmware, but only one is active. 
The active version is identified as "running". You can restore the earlier firmware 
version if required.

A reboot of the library is required. Schedule the code activation accordingly.

1. If you have not done so, download and unpack the code (see "Download Code to 
the Library Controller" on page 6-2).

2. Select Tools > Diagnostics, and then click the Library folder.

Note: Next to the Failed label, you should see "0". If there are any 
failures indicated, contact your Oracle support representative for 
assistance.
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3. Click the Activate Code tab.

4. In the Target list, select the code package to activate (in this case SL3000 Code).

5. In the Available Versions section, select the code version to activate.

6. Click Activate.

7. Click OK to start activation.

8. When the activation process finishes, click OK to reboot the library.

9. Click OK to terminate the SLConsole session.

10. After library initialization completes, log in to SLConsole.

Special Library Configuration Options
The Library Configuration page provides the following configuration options. In 
partitioned libraries, these options can be configured separately for each partition.

■ Barcode presentation (see"Configure Cartridge Barcode Presentation (FC-SCSI 
only)" on page 10-2)

■ SCSI FastLoad controls the criteria by which cartridge mounts are considered 
complete (see "SCSI FastLoad Feature" on page 11-2).

■ Library Auto Clean controls the management of cleaning cartridge and drive clean 
functions (see "Drive Cleaning" on page 9-1). 

Display Library Information
■ "Display Library Status" on page 6-3

■ "Display Library Properties" on page 6-4

■ "Library Reports" on page 6-4

■ "Display Library Power Supply Information" on page 6-5

Display Library Status
1. Select Tools > System Detail, and then click the Library folder in the navigation 

tree.

2. Click the Status tab.

3. Select a secondary tab:

■ General - displays the current operational state of the library. These values 
update whenever there is host activity, background operations, or operator 
activity.

■ Status Module - displays library status alerts and highlights significant 
messages. This feature is available only if service is active on the library. If 
service is not active on the library, this screen will be blank except for a 

Caution: POTENTIAL INTERNAL FILE CORRUPTION. Do not 
reboot any devices in the library or execute any operations on the 
library while activating code.
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message indicating that the "Service activation is not valid". If you see the 
"warning" status, a failure may occur. Contact a service representative.

■ HLI - displays the current status of all HLI interface ports on the library. 
Information includes the local TCP/IP socket, local IP, connection status, port 
status, and transmission sent and received from the time of connection.

■ FC-SCSI - display the current status of all host FC–SCSI interface ports on the 
library. Detailed information is shown by port number. If the Multi Port Fibre 
feature has been activated on the library, detail is shown for all ports.

Display Library Properties
1. Select Tools > System Detail, and then click the Library folder.

2. Click the Properties tab.

3. Select a secondary tab:

■ General - displays the physical, mechanical, logical, and network 
configuration of the library. Some of the information can be set up 
automatically during library initialization, while other information can be 
defined by the user.

■ Library Controller - displays details of the library controller, including the 
serial number and firmware versions.

■ Drive Controller - displays details of the drive controller, including the serial 
number and current firmware versions.

Library Reports
Use this procedure to display, search, or save library reports available from the Tools > 
Reports menu. Additional reports are available from the Tools > Partitions menu.

All report output is a static display of information at the time the report is generated. 
Click Update in the upper right corner to refresh the information.

1. Select Tools > Reports.

2. In the navigation tree, expand a report category.

3. Select a report.

Search a Library Report
1. With the report displayed, click Search.

2. Enter a text string (case-sensitive and wildcards are invalid). Click Search.

Save Library Report Data to a File
1. With the report displayed, click Save.

2. Browse to the desired directory, enter a file name, select a format, and click Save.

Display Library Statistics Reports
The Energy Monitor Reports help you monitor your power and energy usage, and 
identify periods of peak and low usage over time.

To change the sort order of the screen or rearrange and resize the columns, see 
"Modifying the Screen Layout" on page 2-3.
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1. Select Tools > Reports.

2. Expand the Statistics folder, and then click a report: .

■ General Events - displays summary statistics for library operations. For each 
event, the report lists the event type, number of occurrences, and the date and 
time of the most recent occurrence of the event.

■ Energy Monitor - Last 24 Hours - displays minute-by-minute energy and 
average power usage for the entire library over the last 24 hours

■ Last Month Energy Monitor - Last Month - displays energy and average 
power usage for the entire library, measured in 15-minute intervals over the 
last 32 days

■ Last Month Energy Monitor - Last Year - displays energy and average power 
usage for the entire library, measured in one-day intervals over the last 365 
days

Display Library Power Supply Information
For power configuration information, see the SL3000 Systems Assurance Guide "Power" 
chapter found on OTN.

The Power Supply Data screen displays summary information for all power supplies 
in the library. Use this screen to monitor the status of the power supplies for 
maintenance or replacement. By default, the display is sorted by internal address. To 
change the sort order, and rearrange and resize the columns, see "Modifying the Screen 
Layout" on page 2-3.

1. Select Tools > System Detail.

2. In the Library navigation tree, click the Power Supply folder to display summary 
information.

3. For detailed information, expand the Power Supply folder. Select a power supply.

Generate Library Diagnostic Files
These procedures generate files to diagnose library problems.

Transfer the Library MIB File
Use this procedure to transfer the public SNMP management information base (MIB) 
file to an Oracle support representative.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the TransferFile tab.

4. Select the Transfer Type of SNMP MIB. Click Transfer File.

5. Browse to the desired directory, and then enter the file name with a .txt suffix.

6. Click Save.

7. E-mail the file to your Oracle support representative.
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Generate and Transfer the Library Log Snapshot File
If a support representative requests a library Log Snapshot, use this procedure to 
generate and transfer the file. The system saves the file in an encrypted format, so you 
cannot view or edit it. You must save the log within 15 minutes of generation.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the Transfer File tab.

4. Select the Log Snapshot radio button.

5. In the Selected Devices list, select either All Devices or Selected Device. If you 
choose Selected Device, select the device.

6. Click Generate Log Snapshot on Library.

7. Click Yes, and then OK.

8. Click Transfer Log Snapshot To Your Computer.

9. Browse to the desired directory or enter the directory path. Click Save. The file is 
named automatically.

10. E-mail the file to your Oracle support representative.

Clear Library Status Alerts
You can only clear alerts marked as "Clearable" and only if service is active on the 
library.

Clearing an alert only removes it from the Status Module display; it does not resolve 
the underlying cause. The library health indicator returns to "Normal" if there are no 
other device or status alerts. If the alert is subject to periodic updates, it will reappear 
at the next update cycle. 

1. Select Tools > System Detail, and click the Library folder.

2. Click the Status tab, and then the Status Module tab.

3. On the Clear Alert Number list, select the alert number to clear, and then click 
Apply.

Perform a Library Self-Test
The self-test diagnostic can help diagnose library operational problems. A self-test 
typically runs after the library is installed. You can run library self-test routines in 
either non-disruptive (cartridges are returned to home cells) or disruptive mode 
(cartridges may be moved to new cells).

When performing a self-test, the system:

■ Checks the communication path between the library controller, drives, elevators, 
and robots.

■ Performs get and put operations to check the health of the robots, elevators, and 
CAPs. This includes get and put operations from a reserved system cell to a 
random empty storage cell or CAP cell.

■ Performs a full library audit.
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■ Performs mounts and dismounts of diagnostic cartridges for all the drives 
installed in the library. The self-test does not begin unless a diagnostic cartridge is 
found in the system cells. If the system finds a compatible diagnostic cartridge, the 
self-test repeats for each drive type. If the system does not find a diagnostic 
cartridge for a drive type, the system skips the mount/dismount operation for the 
drive.

1. Make sure the proper drive diagnostic cartridges are in the library (see "Display 
Cartridge Information" on page 10-2).

2. Select Tools > Diagnostics, and click the Library folder.

3. Click the SelfTest tab.

4. In the Mode list, select the type of self-test:

■ Non-Disruptive - all cartridges used in the test are returned to their original 
locations

■ Disruptive - the library must be taken offline to all hosts before running this 
test

5. Click Run. When the test completes, the results of the test display. 

6. For disruptive tests, bring the library online to resume normal operations.

Reboot the Library
Use this procedure to reboot the library. This process involves reloading the firmware 
from flash memory and restarting the library controller.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click Reboot. 

4. All other users must log off. Click OK. 

5. If the library is online, click OK to take the library offline. 

6. Click OK to reboot the library.

7. Click OK to terminate this SLConsole session. Do not log back in to the SLConsole 
until the library has fully initialized.

Place the Library Online or Offline
Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if ACSLS/ELS servers cannot communicate with the library. For 
instructions on changing the state of the library and its components through ACSLS or 
ELS, see the appropriate tape management software documentation.

Place the Library Offline
You may need to place the library offline at the following times:

■ Before powering down the library

 Note: Before performing a disruptive test, the library must be taken 
offline. See "Place the Library Online or Offline" on page 6-7.
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■ Before opening a library access door

■ When the library is inoperative and requires maintenance

To place the library offline:

1. Take all library drives offline. See "Change a Drive Online/Offline Status" on 
page 9-5.

2. Select Tools > System Detail.

3. Click the Library folder in the navigation tree.

4. Click the Status tab, and then the General tab.

5. In the Transition Request field, click Take offline. 

6. Click Apply. Before the library goes offline, all outstanding library jobs complete.

7. Wait for the offline confirmation message. If the library does not come offline, 
check the status of the library.

Bring the Library Online
1. Select Tools > System Detail.

2. Click the Library folder in the navigation tree.

3. Click the Status tab, and then the General tab.

4. In the Transition Request field, click Bring online.

5. Click Apply.

6. If applicable, bring the library online to ACSLS and ELS hosts. See the ACSLS and 
ELS documentation.

Bring the Drives Online
LTO drives are automatically brought online when you bring the library online. To 
bring T-series drives online manually:

1. To verify that the T-series drives are ready and online, press the MENU switch. 
The display should now read Online.

2. If the drive displays Offline, press the SELECT switch once to bring it online.

■ If the drive message indicates Online, the transition to online completed.

■ If the Onl Pend message appears, the online state is pending due to 
completion of diagnostic tests.

■ If other messages appear, refer to the drive documentation.

Change the Library Interface Type (Non-Partitioned Libraries)
Use this procedure to change the interface type that all hosts use to connect to the 
library. This procedure applies to non-partitioned libraries only.

1. Select Tools > Select Active Cells.

Note: To change interface types in a partitioned library, see "Modify 
a Partition" on page 5-6.
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2. Click the Select Active Cells tab.

3. In the Interface Type list, select the interface type you want to assign. Click Apply.

4. Click Yes to update the library controller database.

5. Click OK to return to the Select Active Cells page.

The new interface type is active immediately. The library does not need to be 
rebooted.

Audits
An audit is the process of cataloging or verifying cartridge locations within a library 
and updating the cartridge database. The database contains the volume ID (vol-id or 
volser), current location (in library internal address format), and verified status (true 
or false). 

You can use the SLConsole to perform a "Physical Audit", "Verified Audit", or virtual 
audit. A virtual audit displays a report listing the contents of the cartridge database. 
Audit times vary according to the type of audit, size of the library, the number of 
HandBots, and the speed of the scan engine for the barcode scanner.

The library performs an audit when:

■ One or both access doors have been opened and closed.

■ An audit request is made through the SLConsole.

■ A host request to audit the library is entered. (System-level problems may occur if 
a host's record of the cartridge does not match what is in the cartridge database of 
the library controller.)

■ The library initializes at power on.

Audit Indicator
To indicate an audit is in progress, the SLConsole displays a spinning indicator and the 
message "Audit in progress". When you see this indicator do not open the library 
access door. This will cause the audit to restart.

The audit indicator only displays when an audit is initiated automatically (library 
access door has been opened and closed, library power up or reboot). The indicator 
does not display for audits initiated from SLConsole or the host.

Physical Audit
In a physical audit, the robot visits cartridge locations and records the vol-id of the 
cartridges. The library controller updates the cartridge database based on the physical 
audit. This audit changes the "verified" status of the cartridge locations to true.

You can manually initiate a physical audit for either the entire library or a specific 
range of cells.

Audit the Entire Library
The robot verifies all cells (storage, CAP, drive, reserved). Although an entire library 
audit is a background process and does not interrupt library operations, it does require 

Note: You cannot stop a physical audit after it begins.
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sharing of robot resources. It is not recommended that you run this audit during peak 
activity periods.The audit takes approximately 1/2 second per cartridge slot.

After a few hours of the audit, you can view the Cartridge Summary report for the 
latest cartridge locations and vol-ids. See "Library Reports" on page 6-4.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the Audit tab.

a. In the Entire Library section, click Yes.

b. Click Audit.

4. Click OK to begin the audit.

Audit a Range of Cells
During this audit, the library verifies only a specific range of storage cells (including 
the CAP and drives). The audit information is displayed on the SLConsole while the 
audit is performed. After the audit completes, view the Cartridge Summary report for 
the latest cartridge locations and vol-ids. See "Library Reports" on page 6-4.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the Audit tab.

a. In the Entire Library section, click No.

In the Physical Audit section, select Yes. 

In the Verified Audit section, select No.

b. In the Start Address and End Address sections, select the device types to audit 
and the internal address locations.

c. Click Audit.

4. Click OK to begin the audit. The Audit Console section displays the progress of 
the audit. 

Verified Audit
A verified audit validates the status of a specific cartridge location or range of 
locations (including CAPs and drives) in the cartridge database. If a cartridge address 
has a verified status of false, a physical audit of that location is performed and the 
cartridge database is updated.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree. 

3. Click the Audit tab.

a. In the Entire Library section, select No. 

In the Physical Audit section, select No. 

In the Verified Audit section, select Yes.

b. In the Start Address and End Address sections, select the device types to audit 
and the internal address locations.

4. Click Audit. The Audit Console section displays the progress of the audit.
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The optional redundant electronics (RE) feature provides failover protection for the 
library controller. This allows an Oracle support representative to replace the faulty 
card while the library is online and provides minimal disruption during firmware 
upgrades.

Requirements
■ Two library controller (HBC) cards

■ Two drive controller (HBT) cards

■ Minimum SL3000 firmware version FRS_3.0 and SLConsole version 5.00

■ Hardware activation file (see "Hardware Activation Files" on page 3-1)

■ HLI host with TCP/IP or FC-SCSI host using ACSLS (RE is not available to hosts 
using a native FC-SCSI interface)

Redundant Electronics Overview
If the library controller or drive controller experiences errors, operations can switch to 
the standby controller with minimal disruption to the library and host operations. The 
library controller and drive controller installed on the same side of the card cage are 
always switched as a pair. Failover can be initiated automatically or manually. A 
failover cannot occur if:

■ The standby library or drive controller is in a fault or eject state

■ The standby code is not running on the standby library or drive controller cards

■ A firmware download or card initialization is in progress

In a failover, the active library controller attempts to complete all in-process jobs and 
copies the cartridge database to the standby controller card. If the database cannot be 
copied (usually only in a sudden failure), you must perform and audit after the 
failover completes (see "Audits" on page 6-9). Any in transit cartridges are returned to 
their home slots. If a cartridge cannot be moved to its home slot, it is moved to a 
library system cell. The host must return the cartridge to its home cell (see library 
management software documentation).

After all in-process jobs have completed or timed out, the card roles switch. Active 
software is brought up on the standby controller. This controller becomes active and 

Note: Any reference to the HBC card also refers to the HBCR card.
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the previously active controller becomes the standby. If the standby software cannot be 
brought up on the previously active controller, the controller enters a fault state.

Automatic Failover
An automatic failover can be initiated by either the active or standby library controller.

The active library controller initiates an automatic failover when:

■ Its partner drive controller card is not installed or it is not communicating.

■ It detects a catastrophic internal software error.

The standby library controller initiates an automatic failover if the active controller is 
not functioning normally.

Manual Failover
Before initiating a manual switch, you should verify that the standby library and drive 
controllers are running normally. You can initiate a manual switch using:

■ Host tape management (ACSLS or ELS): Failover can be initiated from either the 
active or standby library controller. The standby library controller accepts only set 
host path group and force switchover HLI requests.

■ SLConsole: Failover is initiated from the active library controller only (see 
"Manual Redundant Electronics Switch" on page 7-4).

■ CLI: Failover can be initiated from either the active or standby library controller. 
This function is available to your Oracle support representative only.

You may want to perform a manual switch after initial installation of the standby 
cards, after a firmware upgrade, or periodically to check the failover function is 
working properly. It is not possible to manually switch the library controllers without 
the drive controllers — the controllers are always switched as a pair.

Connections
Each library controller card requires a unique IP address. For libraries with Dual 
TCP/IP, each card requires two unique IP addresses: one for the primary port (2B) and 
one for the secondary (2A) port. A library equipped with both RE and Dual TCP/IP 
requires four unique IP addresses.

The failover process is minimally disruptive to host operations.

■ Users of tape management software (Symantec or Virtual Storage Manager) do not 
see an interruption.

■ HLI host applications (ACSLS and ELS) queue requests during the failover process 
for completion after the failover switch. For ACSLS, only mount and dismount 
requests are affected (see the ACSLS and ELS documentation).

■ SLConsole and CLI connections are terminated. You must re-establish connections 
to the library using the IP address or DNS alias of the new active library controller 
(the former standby controller).

Firmware Upgrades
Firmware upgrades for libraries with RE are minimally disruptive to library 
operations. New code is loaded and unpacked simultaneously on the active and 
standby controller cards and on all devices. The code is then activated, and the active 



Display Redundant Electronics Information

Redundant Electronics 7-3

and standby controllers and most devices are re-initialized. Under most circumstances, 
robot initialization is bypassed.

The loading, unpacking, and activation of code are not disruptive to library operations 
until the library is rebooted. During the reboot process (which takes approximately 10 
minutes), the HLI host applications (ACSLS and ELS) queue all mount and dismount 
requests. After the reboot is complete, the queued requests are submitted to the library 
controller.

See "Upgrade Library Firmware" on page 6-2 for firmware download and activation 
information.

Controller Card Status
Controller card status is indicated by LEDs on the card and displayed in SLConsole.

LEDs
The LEDs and meanings are the same on both card types (HBC and HBT).

SLConsole Status
Some SLConsole screens identify the individual library controller with an A or B 
suffix. "A" indicates the bottom card slot and "B" indicates the top card slot. To display 
the status the controller cards in SLConsole, see "Display Redundant Electronics 
Information" on page 7-3.

Display Redundant Electronics Information
1. Select Tools > System Detail.

2. Click the Redundant Electronics folder to display summary information. 

Table 7–1 LED Status Indicators

LED Definition

ACTIVE - Green Card is functioning as the active and is running active code.

STANDBY - Amber Card is functioning as the standby and is running standby code.

FAULT - Red Card has experienced a serious error.

EJECT OK - Blue Support representative can safely initiate a card eject. 

Table 7–2 SLConsole Controller Card Statuses

Status Definition

Duplex: Software ready, 
switch possible

Active library controller is functioning normally.

Not installed Card is not installed in the library.

Ok Active or standby drive controller card is functioning normally.

Pre-standby:

Software not ready

Standby library controller card is loading standby code and is not 
ready to be used in an automatic failover or manual switch.

Standby: 

Software ready

Standby library controller card is functioning normally and can be 
used for an automatic failover or manual switch.
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3. For detailed information about each card, expand the Redundant Electronics 
folder in the navigation tree.

4. Select a card (see "SLConsole Status" on page 7-3 for status meanings):

a. hbca: Library controller, A (bottom) slot

b. hbcb: Library controller, B (top) slot

c. hbta: Drive controller, A (bottom) slot

d. hbtb: Drive controller, B (top) slot

Manual Redundant Electronics Switch
This procedure is not available at the local operator panel.

1. Verify the device state of the card indicates "switch is possible" (see "Display 
Redundant Electronics Information" on page 7-3).

2. Select Tools > Diagnostics.

3. Select the Redundant Electronics folder

4. Click Apply to begin the switch process. If there is a problem with the standby 
library and drive controller cards, you are not allowed to continue with the switch.

5. If there are no errors, click Yes.

6. Click OK to log off the SLConsole.

7. Wait until the switch is complete before logging back into the library. You must 
specify the IP address or DNS alias of the new active controller to log in.
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Cartridge access ports (CAPs) are used to enter or eject cartridges to or from the 
library. A CAP can be a shared library resource (see "Partitioning CAPs" on page 5-1). 
This chapter describes general CAP activities:

■ "CAP Modes and States" on page 8-1

■ "CAP Priorities for FC-SCSI Hosts" on page 8-2

■ "AEM Operations" on page 8-2

■ "Display CAP and AEM Safety Door Information" on page 8-2

■ "Lock/Unlock a CAP or AEM" on page 8-3

■ "Change the CAP Assignment Mode for an FC-SCSI Library" on page 8-4

■ "Change CAP Online/Offline Status" on page 8-4

■ "Perform CAP Self-Test" on page 8-4

CAP Modes and States

Auto Enter Mode
Only HLI libraries support CAP auto enter mode.

Auto enter mode enables you to open a CAP and begin an enter operation without 
issuing an explicit enter request or having an explicit CAP reservation from a host 
application. However, to eject cartridges through the CAP, you still have to issue an 
explicit eject command. When in auto mode, a CAP is unlocked and its LED is on. The 
system locks the CAP only during cartridge enter, eject, or audit operations. To initiate 
an enter operation using an automatic CAP, press CAP Open on the key pad.

Host applications manage the auto enter mode. To place a CAP in auto enter mode, 
enter the appropriate tape management command to unlock the CAP (see the tape 
management software documentation).

Manual Mode
Manual mode is the most secure method of CAP operations. When in manual mode, 
the system locks a CAP by default, and its LED is off. To initiate an enter or eject 
operation using a manual CAP, enter an explicit enter or eject request before pressing 
the CAP Open button on the keypad.

Note: The term CAP refers to both AEMs and rotational CAPs, 
unless otherwise noted.
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Assignment Mode
Only non-partitioned FC-SCSI host connections support assignment mode. The CAP 
assignment mode controls whether library CAPs can be used for normal host 
operations or for manual operations (see "Change the CAP Assignment Mode for an 
FC-SCSI Library" on page 8-4).

CAP States

CAP Priorities for FC-SCSI Hosts
In a non-partitioned library, the SCSI interface treats all CAPs as one large CAP. When 
you initiate an eject operation from an FC-SCSI host, the robot loads cartridges the 
left-most rotational CAP, then moves right, and then moves to AEMs. For partitioned 
libraries, the CAP priority is dependent on how CAPs are allocated to partitions.

For example, assume an FC-SCSI library with a base module, two CEMs (one on each 
side of the base), and two AEMs (one on each end of the library). For an eject operation 
of 350 cartridges, the robots fills CAP cells as shown Table 8–2.

AEM Operations
The front panel of the access door includes the following components:

■ Deadbolt Override Lock — enables fast access to the inside of the AEM (has the 
same effects on library operations as opening the main library access door).

■ Service Access Lock — releases the access door deadbolt (only for Oracle support)

■ Operator Request CAP button — releases the access door deadbolt for normal 
access to the inside of the AEM, to load or unload cartridges.

■ Latch — opens and closes the access door after the deadbolt is released.

Display CAP and AEM Safety Door Information
Use this procedure to display information for rotational and AEM CAPs in the library. 
This information is also available through Reports > CAP Summary (see "Library 
Reports" on page 6-4).

Table 8–1 CAP States in Non-partitioned Library

Type of CAP Default State Default CAP Button Light Condition

HLI: Manual mode Locked Off

HLI: Auto enter mode Unlocked On

FC-SCSI Unlocked On

Table 8–2 Fill Order of CAP Cells in Eject Operation

Order Module Number of Cartridges Total Cartridges

1 Left CEM 26 26

2 Base Module 26 52

3 Right CEM 26 78

4 Left AEM 234 312

5 Right AEM 38 350
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Display CAP Status and Properties
To display the current operational state or properties of a rotational or AEM CAP:

1. Select Tools > System Detail.

2. Select the CAP folder in the navigation tree. The system lists all the library's CAPs 
and their locations

3. For more information, expand the CAP folder, and select the CAP to display. AEM 
CAPs are column –31 for the left and column 31 for the right.

4. Select a tab:

■ Status tab - displays the current status of the selected CAP

■ Properties tab - displays the CAP properties, including code version

Display AEM Safety Door Status and Properties
To display the current status or properties of an AEM safety door: 

1. Select Tools > System Detail.

2. Expand the Safety Door folder, and select the safety door you want to display.

3. Click the tab you want to view: 

■ Status tab - displays the current state of the door. Beside the Door Position 
label, "open" indicates the safety door is up and the TallBot is free to move in 
and out of the AEM. "Closed" indicates the safety door is completely closed 
and it is safe for you to open the AEM access door.

■ Properties tab - displays detailed information for an AEM safety door, 
including the serial number and current firmware versions.

Lock/Unlock a CAP or AEM
Normally, the host unlocks a CAP or AEM access door. If the CAP is reserved by a 
host, the host must release the CAP reservation before you can use this procedure. An 
unlocked CAP is reserved by the library and unavailable to all hosts until it is locked. 
Use this procedure when you need to perform the lock/unlock operation manually at 
the SLConsole.

1. Select Tools >Diagnostics.

2. Expand the CAP folder, and select the CAP to modify. AEM CAPs are column –31 
for the left and column 31 the right. 

3. Click the Access tab.

4. In the Locked list select:

■ True to unlock

■ False to lock

5. Click Apply. When locking a CAP, a confirmation message appears. Click OK to 
unlock the CAP.
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Change the CAP Assignment Mode for an FC-SCSI Library
Use this procedure to change the CAP assignment mode for all CAPs in an 
un-partitioned FC-SCSI library. The CAP assignment mode controls whether library 
CAPs can be used for normal host operations or for diagnostic moves.

1. Verify that all library CAPs are unreserved, empty, closed, and locked.

2. If you are changing the CAPs to diagnostics mode, quiesce the library to all hosts 
(see the tape management software documentation).

3. Select Tools > CAP Assignment.

4. At the Mode list, select a mode:

■ Diagnostics — causes all CAPs to be available for diagnostic operations. Select 
this if you want to perform manual cartridge moves, such as moving cleaning 
or diagnostic cartridges from the CAPs to system cells.

■ Host Operations — causes all CAPs to be available for normal host 
operations. Select this if you want to return the library to normal tape 
mount/dismount operations.

5. Click Apply and then OK.

Perform CAP Self-Test
1. Select Tools > Diagnostics. 

2. Expand the CAP folder, and click the CAP to test. AEM CAPs are identified as 
column –31 for the left and column 31 the right. 

3. Click the SelfTest tab. 

4. In the Mode list, select Non-Disruptive. 

5. Click Run. A message appears when the test finishes. 

Change CAP Online/Offline Status
Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if their servers are unable to communicate with the library. For 
instructions on changing the state of the library and its components through ACSLS or 
ELS, see the appropriate tape management software documentation.

1. Select Tools > System Detail. 

2. Expand the CAP folder. Click the CAP to modify. AEM CAPs are identified as 
column –31 for the left and column 31 the right.

3. Click the Status tab. 

4. In the Transition Request list, select either:

■ Take Offline - all outstanding jobs for the CAP will complete first.

■ Bring online

5. Click Apply. 

Note: Library devices that are offline and in an error state cannot go 
online. The error condition must be cleared first.
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■ "Drive Cleaning" on page 9-1

■ "Display Drive Information" on page 9-4

■ "Display the Drive and Drive Media Reports" on page 9-4

■ "Configure the Drive Tray Serial Numbers" on page 9-5

■ "Change a Drive Online/Offline Status" on page 9-5

■ "Perform a Drive Self-Test" on page 9-6

Drive Cleaning
Library tape drives require periodic cleaning to prevent read/write errors. A drive 
cleaning occurs when the system mounts a compatible cleaning cartridge in response 
to a cleaning request from the drive. You can manage drive cleaning using either:

■ Host-Managed Cleaning — Host applications (such as ACSLS or ELS) or 
direct-attach applications (such as Symantec and NetBackup) manage all cleaning 
cartridge and drive clean functions. This method is available for HLI libraries and 
partitions.

■ Library Auto Clean — The library controller manages all cleaning cartridge and 
drive clean functions. Check your tape management software documentation to 
determine whether this method is recommended for your library.

For a non-partitioned library, select one method for the entire library. In a partitioned 
library, select one method per partition.

Host-Managed Cleaning
When a drive requires cleaning, it notifies the host and the host mounts a cleaning 
cartridge to the drive. To enter/export cleaning cartridges in the library, use the 
applicable ACSLS or ELS commands. Do not use the SLConsole import/export 
feature. All cleaning cartridges are stored in data cells.

You must disable library auto clean before enabling host-managed cleaning (see 
"Configure Library Auto Clean" on page 9-3). To enable host-managed cleaning, see 
the ACSLS Administrator's Guide or ELS System Programmer's Guide.

Library Auto Clean
When a drive requires cleaning, the library controller automatically mounts a cleaning 
cartridge on the drive. While a drive is being cleaned, the system marks it as busy to 
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all hosts. If an FC-SCSI host requests the drive while the drive is being cleaned, the 
request is rejected. 

Ensure that the library contains a sufficient number of cleaning cartridges that are 
compatible with each drive type in your library. You must use the SLConsole to 
enter/export cleaning cartridges (see "Import/Export Cleaning Cartridges (Library 
Auto Clean Only)" on page 9-3). Imported cleaning cartridges are stored in reserved 
system cells.

The library tracks cleaning cartridge usage and sends notification when cleaning 
cartridges have expired or have reached a user-defined warning threshold (see "Define 
Warning Thresholds (Library Auto Clean Only)" on page 9-3). Cleaning cartridges are 
expired based on information from the drives. If a drive cannot use a cleaning 
cartridge, the drive sends a "cleaning cartridge expired" notification to the library 
controller. Expired cleaning cartridges can be exported from the library in bulk, by 
expiration date, or by selected cartridge volume ID (vol-id or volser). Replace expired 
cartridges as soon as possible.

Manual Cleaning
Normally, either the library auto clean feature or the host tape management software 
manages drive cleaning. However, there may be occasions when you need to perform 
a manual clean. See the drive manufacturer's documentation for information on 
whether manual cleaning is allowed.

1. Verify that the drive needs cleaning (see "Display Drive Information" on page 9-4).

2. Display a list of cleaning cartridges (see "Display Cleaning Cartridges" on 
page 9-2).Verify there is a compatible cleaning cartridge for the drive.

3. Move a compatible cleaning cartridge from a system cell to the drive that needs 
cleaning (see "Moving Cartridges (Recovery Moves)" on page 10-4).

4. When the cleaning operation is complete, move the cleaning cartridge from the 
drive back to a system cell.

Display Cleaning Cartridges
Use this procedure to monitor the status and usage count for all cleaning cartridges in 
reserved system cells. A cleaning cartridge may not appear on this page if it is in use, 
in transit, or was entered into the library with host tape management software.

1. Select Tools > Diagnostics.

2. Select the Library folder on the navigation tree

3. Click the Auto Clean tab, and then the Cleaning Cartridges tab. Possible cleaning 
cartridge statuses are:

■ OK — cartridge is usable for cleaning.

■ warning — usage count has reached or exceeded the warning threshold 
defined for this cartridge type.

■ expired — cartridge has expired, based on information from the drives.

Caution: Cleaning a drive before it is due is not recommended. 
Excessive drive cleaning can wear out a drive head prematurely.
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Configure Library Auto Clean
If the library is partitioned, you can enable or disable library auto clean for individual 
partitions.

1. Select Tools > Configuration.

2. Set the Enable Auto Clean option:

■ Uncheck the box to turn library auto clean off (default). Host management 
software must manage drive cleaning.

■ Check the box to turn library auto clean on.

3. Click Apply.

Define Warning Thresholds (Library Auto Clean Only)
The cleaning cartridge warning threshold notifies you when a cleaning cartridge is 
nearing time for replacement. Set the threshold lower than the cartridge's 
recommended maximum usage to allow time to replace the cartridge. See the drive 
manufacturers' documentation for maximum recommended usage for each type of 
cleaning cartridge.

When you import a cleaning cartridge into the library, the library controller sets the 
usage count to zero. The count will not be accurate when importing a used cleaning 
cartridge. See "Display Drive Information" on page 9-4 to display the current usage 
count.

To assign usage warning thresholds to selected cleaning cartridge types:

1. Select Tools > System Detail. Click the Library folder on the navigation tree.

2. Select Auto Clean, and then the Warning Threshold tab.

3. In the "Threshold warning index to change" list, select the index number of the 
cleaning cartridge type to configure.

4. In the "New warning threshold count" field, enter the warning threshold for the 
cartridge type. 

All cleaning cartridges of this type are assigned the threshold. An entry of 0 
(default) deactivates the warning threshold feature for the cartridge type. 

5. Click Apply.

Import/Export Cleaning Cartridges (Library Auto Clean Only)
Only one cleaning or diagnostic cartridge import or export operation can be 
performed at a time. The library controller reserves the CAP for the entire operation. 

Import Cleaning Cartridges
Ensure there are enough empty reserved system cells (one system cell on each side of 
the library must be left open for robot recovery or library initialization). The library 
distributes imported cleaning cartridges evenly in reserved system cells, and sets their 
usage counts to 0. The library auto clean feature requires that cleaning cartridge 
volume IDs (VOLIDs or volsers) be eight characters in length, with CLN as the first 
three characters.

1. Verify that the CAP is empty, unreserved, closed, and locked.

2. Select Tools > Diagnostics.
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3. Expand the CAP folder and then select a CAP to use. Click the Import/Export tab.

4. Select Import Cleaning/Diagnostic cartridges.

5. Click Start, and then OK to begin the import operation.

6. Load the cleaning cartridges into the CAP (see steps 2 to 4 of "Entering Cartridges" 
on page 10-5).

Export Cleaning Cartridges
1. Verify the CAP is empty, unreserved, closed, and locked.

2. Select Tools > Diagnostics.

3. Expand the CAP folder and then select a CAP to use. Click the Import/Export tab.

4. Select a type of export operation:

a. Export expired cleaning cartridges — exports all cleaning cartridges with an 
"expired" status. 

b. Export specific cleaning cartridges — select the cartridges to export in the 
"Select Cartridges(s) to export" list.

c. Export all cleaning cartridges — exports all cleaning cartridges in the library.

5. Click Start.

6. Click OK to begin the export operation.

7. Remove the cartridges from the CAP (see steps 2 to 5 of "Ejecting Cartridges" on 
page 10-6).

Display Drive Information
Use this procedure to display drive information for all drives in the library. This 
information is also available through Reports > Drive Details. See "Library Reports" 
on page 6-4.

1. Select Tools > System Detail.

2. Click the Drive Folder in the navigation tree for the drive status and locations of 
library drives.

3. For more detailed information, expand the Drive folder in the navigation tree. 
Select a drive.

4. Select a tab:

■ Status tab — displays the current operational state of the selected drive

■ Properties tab — displays configuration information, including the drive type, 
serial number, and port configuration

■ Display tab — displays network data, the Virtual Operator Panel (VOP) for 
T10000 and T9840D drives, and drive LED status

■ Drive Tray tab — displays the current status of a drive tray

Display the Drive and Drive Media Reports
The Drive and Drive Media Events Reports summarize drive and media events and 
errors that have occurred on library drives. Use these reports to help identify and 
diagnose faulty drives and cartridges.
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By default, the reports are sorted in drive serial number order. Optionally, you can 
change the sort order and rearrange and re-size the columns. See "Modifying the 
Screen Layout" on page 2-3 for more information.

1. Select Tools > Reports.

2. Expand the Statistics folder.

3. In the navigation tree, click a report type:

■ Drive Events — summarizes drive events and errors. For each drive that has 
experienced an event, the report lists the type of drive, type of error, the 
number of occurrences, and the date and time of the last such event. The 
report can display up to 70 entries.

■ Drive Media Events — summarizes media events. For each drive that has 
experienced media events, the report lists the vol-id of the cartridge, the type 
of event, the number of occurrences, and the date and time of the last such 
event. The report can display up to 500 entries.

Configure the Drive Tray Serial Numbers
Use this procedure to add or edit the drive tray serial number.

1. Select Tools > Configuration.

2. Click the Drive Tray S/N tab.

3. Click Refresh to display the current data.

4. Double-click the field for the drive tray serial number.

5. Enter the correct drive tray serial number.

6. Click Apply, then Yes.

Change a Drive Online/Offline Status
A drive can be online (available for read/write operations) or offline (unavailable for 
read/write operations).

Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if their servers cannot communicate with the library. For instructions on 
changing the state of the library and its components through ACSLS or ELS, see the 
tape management software documentation.

1. Select Tools > System Detail.

2. Expand the Drive folder, and then click the drive to modify.

3. Click the Status tab.

4. In the Transition Request field, select either:

■ Take Offline — the system completes all outstanding jobs for the drive first.

■ Bring Online

5. Click Apply.

Note: Library devices that are offline and in an error state cannot go 
online. Clear the error condition first.
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Perform a Drive Self-Test
1. Select Tools > Diagnostics.

2. Expand the Drive folder, and then click the drive to test.

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive.

5. Click Run.
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■ "Cartridge Types" on page 10-1

■ "Cartridge Labels" on page 10-1

■ "Resolving Orphaned Cartridges" on page 10-2

■ "Display Cartridge Information" on page 10-2

■ "Locating Cartridges" on page 10-3

■ "Moving Cartridges (Recovery Moves)" on page 10-4

■ "Entering Cartridges" on page 10-5

■ "Ejecting Cartridges" on page 10-6

■ "Import/Export Diagnostic Cartridges" on page 10-7

■ "Cartridge Handling" on page 10-8

Cartridge Types
■ Data cartridges

■ Diagnostic cartridges — used by service representatives to run read/write tests on 
drives (see "Import/Export Diagnostic Cartridges" on page 10-7)

■ Cleaning cartridges — used to clean the tape path and read/write heads of the 
tape drives (see "Drive Cleaning" on page 9-1)

Library cartridges must meet specifications defined in American National Standard 
Magnetic Tape and Cartridge for Information Interchange. For more information on 
cartridges, refer to the drive vendor's publication and website.

Cartridge Labels
All library cartridges must have a readable external label. The HandBot reports an 
error when it encounters an unreadable label.

Non-labeled cartridges are not supported. The library exports any non-labeled 
cartridges it finds through the CAP. A non-labeled or unknown type cartridge will not 
mount to a drive.

Caution: Do not re-enter a cleaning cartridge ejected by the library. 
The library will consider it to be new, and set the usage counter to 
zero. 
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Cartridge labels include a media domain and media ID. The media domain indicates 
the cartridge type — data, cleaning (CLN), or diagnostic (DG).The media ID indicates 
the compatible drive type. Some FC-SCSI host applications, may require you to 
configure the barcode presentation to use the full eight-character barcode. For 
information about barcode label standards for each cartridge type, refer to the Barcode 
Label Technical Brief on OTN.

Configure Cartridge Barcode Presentation (FC-SCSI only)
Use this procedure to configure the cartridge barcode presentation format for an 
FC-SCSI library or FC-SCSI partition. This specifies which part of a cartridge barcode 
the library passes to host applications that use the FC-SCSI interface.

1. Select Tools > Configuration.

2. In the Barcode Presentation list, select the presentation format to use for each 
partition. The Partition Name scsi0 indicates a non-partitioned library. Format 
options are:

■ all — passes all eight barcode characters to the host.

■ left6 — passes only the six VOLID characters to host applications. It does not 
pass the domain and type characters, which are the two characters on the right 
of the barcode. This is the default setting.

3. Click Apply.

4. Click OK to dismiss the message.

Resolving Orphaned Cartridges
An orphaned cartridge is a cartridge which is inaccessible to a host. Orphaned 
cartridges can occur when you change the capacity, delete a partition, or move a 
cartridge to a cell or drive that is not allocated to a partition.

In a partitioned library, orphaned cartridges can cause data loss. A host that finds an 
orphaned cartridge in its partition may treat the cartridge as a scratch volume and 
overwrite the data. 

SLConsole will warn you when it identifies orphaned cartridges. Resolve the 
orphaned cartridges by performing recovery moves on listed cartridges. Recovery 
moves transfer the orphaned cartridges to accessible locations within their parent 
partitions. See "Moving Cartridges (Recovery Moves)" on page 10-4.

Display Cartridge Information
The reports feature can display information about all library cartridges, including 
cartridge vol-id, location, and media type. You can display the information in a tabular 
format or a list. For drive-related media events, see "Display the Drive and Drive 
Media Reports" on page 9-4.

1. Select Tools > Reports.

2. Expand the Status Summary folder in the navigation tree.

3. Click the report to view:

■ Cartridge Table - displays cartridge information in a tabular form. You can 
modify the layout and display of this screen. See "Modifying the Screen 
Layout" on page 2-3.



Locating Cartridges

Cartridge Management 10-3

■ Cartridge Summary - displays cartridge information in a list.

4.  To search the report data or save it to a file, see "Library Reports" on page 6-4.

Locating Cartridges
You can display the library internal address of any cartridge by using the SLConsole. 
You can locate a cartridge based on vol-id, internal library address, or HLI address.

This utility is especially useful when you must perform a manual mount of a cartridge. 
The library management software (ELS or ACSLS) provides the vol-id, HLI-PRC 
address of the cartridge, and drive bay address of an available drive. Before you enter 
the library, write down the vol-id, cartridge location, and the drive slot location (see 
"Library Addressing" on page A-1).

Locate a Cartridge by vol-id
Use this procedure to display the current location of a cartridge with a specified 
volume ID. You can display cartridge location in the library internal address or 
HLI-PRC address format.

1. Select Tools > Diagnostics, and then click the Library folder.

2. Click the Search tab.

3. In the Search Type list, select VOLID.

4. Enter the VOLID (wildcards are valid).

5. The Requester field controls the address format of the search results. Select:

■ default to display in library internal address format.

■ hli0 or hli1 to display in HLI-PRC address format.

6. Select the Cartridge Type.

7. Click the Search tab. The Search Results section updates.

Locate a Cartridge by Address
Use this procedure to display detailed information for cartridges with a specified 
location. You can specify the location using library internal address, HLI-PRC address, 
or FC-SCSI address.

1. Select Tools > Diagnostics, and then click the Library folder.

2. Click the Search tab.

3. In the Search Type list, select Location.

4. In the Location list, select the search criteria.

5. In the Location field, enter the address (wildcards are invalid)

6. In the Requester list, select the type of address format - FC-SCSI, HLI, or default 
(internal address). Make sure the type matches what was entered in the Location 
field.

7. Click the Search tab.

8. To see details about a cartridge or to view a location mapping, click the ". . ." 
button in the Details column. 
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Moving Cartridges (Recovery Moves)
Using the recovery move diagnostic function, you can move a cartridge from one 
location to another. For example, you can:

■ Return a cartridge to its original location from a CAP cell, drive, or another storage 
cell location.

■ Transfer orphaned cartridges to accessible locations

■ Group cartridges by data type or move them closer to assigned drives.

■ Eject a cleaning or diagnostic cartridge that has expired.

■ Enter a new cleaning or diagnostic cartridge and move it to a reserved storage cell.

A cartridge in a storage cell can be moved only to a CAP, a system cell, or another 
storage cell, and not to a drive. A cartridge currently in a drive, CAP, or system cell can 
be moved to any other unoccupied location in the library. 

Before moving any cartridge, it is helpful to display or print a report showing where 
cartridges are currently located and which storage cells are unoccupied (see "Display 
Cartridge Information" on page 10-2).

Move a Cartridge by Vol-id or Specified Location
Use these procedures to move a cartridge in the library to a new specified location. 
These procedures update the cartridge's location in the library controller database, but 
not in the host database. You must perform an audit from the host software to update 
the host database. Failure to do so will cause future mount requests from the host 
software to fail.

1. Select Tools > Diagnostics. Click the Library folder.

2. Click the RcvrMove tab.

3. In the Source Location Mode section, select either:

■ VOLID to use vol-id. In the VOLID field, enter the vol-id of the cartridge to 
move.

■ Location to use a specific location. Select the cartridge's current location type. 
Options are: CAP, Slot, Drive, Reserved Slots.

4. In the Destination Location Type list, select the type of location to which to move 
the cartridge. Options are: CAP, Storage Slots, Drive, and Reserved Slots.

Selection restrictions include:

■ The destination can be a drive only if the source is a CAP or reserved slot.

■ To move a cartridge to a drive, the cartridge media type must be compatible 
with the drive type.

■ You cannot move a cartridge to a location that is already occupied.

■ Only diagnostic or cleaning cartridges should be moved to reserved slots.

Caution: Potential data loss. Use caution when moving cartridges in 
partitioned libraries. Accidentally moving a cartridge from one 
partition to another allows the new partition to overwrite data.
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5. In the Destination Location table, specify the cartridge destination with the library 
internal address lists: Library, Rail, Column, Side, Row.

Options include:

■ Min: First element of that location type (library, rail, column, side, row) in the 
library

■ Max: Last element of that location type (library, rail, column, side, row) in the 
library

6. Click Start to begin the move.

7. Click OK.

8. To verify the new location, you can display a Cartridge Summary report. See 
"Display Cartridge Information" on page 10-2.

9. To update the new cartridge location in the host database, initiate a library audit 
from the host software (see the tape management software documentation).

Entering Cartridges
Before you enter a cartridge, verify that it is labeled properly. Do not enter unlabeled 
cartridges or place cartridges upside-down.

A rotational CAP holds 26 cartridges and an AEM hold 234 cartridges. Place cartridges 
in any magazine slot and in any order with the hub gear facing down and cartridge 
label facing you. The magazine is removable for cartridge placement.

After a cartridge is entered through the CAP, the library moves the cartridge from the 
CAP to a library storage slot, records the cartridge's location, and sends the location to 
the host.

Rotational CAPs
1. If the CAP is in auto enter mode (see "CAP Modes and States" on page 8-1), 

proceed to the next step. If it is in manual mode, initiate the enter operation at the 
host (see tape management software documentation). 

2. Press the CAP button.

The CAP door opens, and the CAP button light turns ON.

3. Place the cartridges in the CAP with the hub gear face down and barcode toward 
you.

4. Press the CAP button.

The CAP closes and locks automatically, and the CAP button light turns OFF. 
When the CAP is empty, the library returns the CAP to its default state

AEMs
1. If the CAP is in auto enter mode (see "CAP Modes and States" on page 8-1), 

proceed to the next step. If it is in manual mode, initiate the enter operation at the 
host (see tape management software documentation). The "Unlocked" indicator 
lights.

Caution: Possible equipment damage: DO NOT force the CAP to open 
or close.
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2. Push the AEM CAP button. The "Wait" indicator blinks until the safety door is 
completely down. Then the "Enter" light displays solid. Depending on the level of 
activity in the library, this may take several minutes.

3. Lift the latch, and open the door. Place the cartridges in the CAP with the hub gear 
face down and barcode toward you. Close and latch the AEM access door.

4. Push the AEM CAP button. The "Enter" light goes off, and the "Wait" light starts 
blinking. The safety door goes up.

Ejecting Cartridges
A rotational CAP holds 26 cartridges and an AEM holds 234 cartridges. To export a 
cartridge, specify the vol-id of the cartridge to remove from the library. For HLI hosts 
you can select a CAP for the eject operation. For FC-SCSI hosts, the library uses CAPs 
in a pre-defined order (see "CAP Priorities for FC-SCSI Hosts" on page 8-2). The 
system retrieves the vol-id location from the library's memory. The robot locates the 
cartridge and places it into the CAP slot.

After the CAP opens, the system erases the location of the cartridge from the library 
controller database and the host database. The robot does not read cartridge labels 
during export operations.

Rotational CAPs
1. Initiate the eject operation at the host. Specify the vol-ids of the cartridges to 

remove from the library (see the tape management software documentation).

2. Press the appropriate CAP button.

The CAP door opens, and the CAP button light turns ON.

3. Remove the cartridges from the CAP.

4. Push the CAP button to close the CAP.

The CAP closes and locks, and the CAP button light turns OFF.

5. If more cartridges must be exported, the robot continues filling the CAP. Wait until 
the CAP door is unlocked and repeat step 2 through step 4.

Once the system ejects all cartridges, the robot audits the CAP to verify it is empty. 
The CAP returns to its default state.

AEMs
1. Initiate the eject operation at the host. Specify the vol-ids of the cartridges to 

remove from the library (see the tape management software documentation). 

2. Push the AEM CAP button.

Caution: Possible equipment damage: DO NOT force the CAP to open 
or close.

CAUTION: Potential data loss. If you do not remove the cleaning 
cartridge from the CAP and the CAP closes, the library treats the 
cartridge as new and the expired cleaning cartridge is used again.
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The "Wait" indicator blinks until the safety door is in place. The the "Enter" light 
displays solid. Depending on the level of activity in the library, this process may 
take several minutes.

3. Lift the latch, and open the door. Remove the cartridges from the AEM CAP. Close 
and latch the AEM access door.

4. Push the AEM CAP button. The "Enter" light goes off, and the "Wait" light begins 
blinking. The safety door moves up. If more cartridges need to be exported, the 
TallBot continues filling the necessary AEMs. 

5. If more cartridges must be exported, wait until the AEM "Unlocked" light is comes 
on and repeat step 2 through step 4.

Import/Export Diagnostic Cartridges
Library self-tests and some other diagnostic activities require the use of diagnostic 
cartridges. Make sure the library contains a enough diagnostic cartridges for these 
activities. Diagnostic cartridges are stored in the reserved system cells, and cannot be 
imported or exported with host management software.

To import/export a diagnostic cartridge through a CAP, use the SLConsole 
Import/Export function. The library controller reserves the CAP for the entire 
operation. The system can perform only one diagnostic or cleaning cartridge import or 
export operation at a time.

Diagnostic cartridge volume IDs (vol-ids or volsers) must be eight characters in length, 
with DG as the first two characters. The library import/export function works only for 
diagnostic cartridges with labels in this format. You can use any of the following 
SLConsole reports and searches to display information about diagnostic cartridges. 
Search for cartridges that begin with DG.

■ "Display Cartridge Information" on page 10-2

■ "Locating Cartridges" on page 10-3

Import Diagnostic Cartridges
Make sure that the library has enough empty reserved system cells for the diagnostic 
cartridges. There must be at least one empty system cell on each side of the library for 
robot recovery or library initialization. The diagnostic cartridges are distributed as 
evenly as possible in reserved system cells, or you can assign priority to one rail.

1. Verify that the CAP is empty, available for use (not reserved by a host), and closed 
and locked.

2. Select Tools > Diagnostics.

3. Expand the CAP folder and click a CAP to use. Click the Import/Export tab.

4. In the Operation section, select Import Cleaning/Diagnostic cartridges.

5. In the "Select favored rail for import" list, select the preferred storage rail or No 
affinity.

The system enters diagnostic cartridges into reserved system cells on the favored 
rail on a space-available basis. After the system cells on the rail are full, the system 
distributes cartridges among system cells on other rails.

6. Click Start. 

7. Click OK to begin the import operation.
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8. Follow steps 2 to 4 of "Entering Cartridges" on page 10-5 to complete the import 
operation.

Export Diagnostic Cartridges
1. Verify that the CAP is empty, available for use (not reserved by a host), and closed 

and locked.

2. Select Tools > Diagnostics.

3. Expand the CAP folder, click a CAP to use. Click the Import/Export tab.

4. In the Operation list, select the type of export operation:

■ Export specific diagnostic cartridges, then select the cartridges to export in 
the "Select Cartridge(s) to export" list

■ Export all diagnostic cartridges, then select a rail in the "Select rail to export 
cartridges from" list.

5. Click Start. 

6. Click OK to begin the export operation. The Import/Export page displays a 
message when the CAP is ready to be unloaded.

7. Follow steps 2 to 5 of "Ejecting Cartridges" on page 10-6 to complete the export 
operation.

Cartridge Handling

■ Keep cartridges clean and inspect for damage before each use.

■ Never open a cartridge.

■ Do not handle tape that is outside the cartridge; the tape edge might be damaged.

■ Do not expose the tape or cartridge to direct sunlight, moisture, or magnetic fields.

Inspecting a Cartridge
Always inspect a cartridge before you insert it into a tape drive or a library. A 
defective or dirty cartridge can damage a tape drive. Never use a damaged cartridge. 
Look for:

■ Dirt or debris

■ Cracked or broken housing

■ Damaged write-protect switch

■ Liquid in the cartridge

■ Labels not firmly attached, or that extend over the cartridge edge

Caution: When cartridges are improperly handled, loss of data or 
damage to a library component can occur.
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Cleaning the Cartridge Exterior
Wipe all dust, dirt, and moisture from the cartridge with a lint-free cloth. Use Oracle 
StorageTek Tape Cleaner Wipes to clean the cartridges. These wipes are saturated with 
isopropyl alcohol. Do not let any solution touch the tape or get inside the cartridge.

Storing Cartridges
Store cartridges in a clean environment. Do not take a cartridge out of its protective 
wrapping until you are ready to use it. Use the tear string, not a sharp instrument, to 
remove the wrapping. Before using a cartridge, ensure that it has been in its operating 
environment for at least 24 hours.

Apply a Label to a Cartridge
If you did not order cartridges with pre-applied labels, you must apply them yourself. 
Use labels that do not leave a residue when they are removed.

1. Make sure the cartridge has been at room temperature for at least 24 hours.

2. Use OracleStorageTek Tape Cleaner Wipes to clean the surface where the label will 
be placed (see "Cleaning the Cartridge Exterior" on page 10-9)

3. Locate the type of label you need (see "Cartridge Labels" on page 10-1). Make sure 
the label contains a vol-id.

4. Peel the backing from the cartridge label.

5. Orient the cartridge:

■ LTO — hold the cartridge so that the write-protect switch is toward you.

■ T-series — hold the cartridge so that the two recessed areas are toward you.

6. Place the label within the indented area of the cartridge so that the edges of the 
label are parallel to the edges of the cartridge. The label must not overlap the edge 
of the indented area. Press into place.

Make sure the edges of the labels do not curl, as the label may be misread or 
become jammed in a drive.

7. For T-series cartridges, repeat step 2 through step 6 for the media ID label. Make 
sure both labels are aligned with each other.

Caution: Potential damage to cartridges. Do not use acetone, 
trichloroethane, toluene, xylene, benzene, ketone, methylethyl ketone, 
methylene chloride, ethyldichloride, esters, ethyl acetate, or similar 
chemicals to remove labels or clean cartridges.
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11Robot and Safety Door Management

■ "AEM Safety Door Overview" on page 11-1

■ "Reboot an AEM Safety Door" on page 11-1

■ "TallBot Overview" on page 11-1

■ "SCSI FastLoad Feature" on page 11-2

■ "Display Robot Information" on page 11-2

■ "Change Robot Online/Offline Status" on page 11-2

■ "Perform a Robot Self-Test" on page 11-3

■ "Robot Diagnostic Moves" on page 11-3

AEM Safety Door Overview
The safety door is a sliding barrier that closes off an AEM from the operational portion 
of the library. The door slides into place when performing robot maintenance or a bulk 
load/unload operation. The safety door allows a service representative to perform 
maintenance on a robot while the library remains online and protects an operator from 
robot activity during a bulk load/unload. See "Display AEM Safety Door Status and 
Properties" on page 8-3.

Reboot an AEM Safety Door 
Use this procedure to reboot an AEM safety door. You may need to do this to clear 
errors if the AEM safety door has experienced an abnormal condition. 

1. Select Tools > Diagnostics.

2. Expand the Safety Door folder, and then select the AEM safety door to reboot. 

3. Click Reboot.

4. If the safety door is online, click OK to take the safety door offline. 

5. Click OK to confirm the reboot. The library controller reboots the safety door. The 
safety door re-initializes, and the TallBot audits the AEM.

6. Click OK to dismiss the success message.

TallBot Overview
A TallBot is a robot that moves cartridges between storage slots, tape drives, and 
CAPs. With the dual TallBot option, two robots operate in parallel, significantly 
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increasing the overall performance of the library. If one robot fails, the other robot can 
move the defective robot into an AEM service area or PEM parking area.

SCSI FastLoad Feature 
SCSI FastLoad is an optional feature which can enable faster mount and dismount 
operations for libraries or partitions with FC-SCSI host connections. After a robot 
successfully inserts a cartridge into a drive, it is immediately available for the next 
request and does not wait until the drive reports that the cartridge has been loaded. 
The library controller waits to return the mount request response until it detects that 
the tape drive has successfully loaded the cartridge. If a cartridge fails to load after the 
TallBot has been released, it is up to the FC-SCSI host to move the cartridge from the 
drive back to the source element.

This feature requires minimum SL3000 firmware FRS_2.33 and SLConsole 4.47.

Configure SCSI FastLoad Feature
You can enable or disable SCSI FastLoad separately for each partition.

1. Select Tools > Configuration.

2. For each partition, use the Enable FastLoad Feature check box:

■ Checked turns SCSI FastLoad on.

■ Unchecked turns SCSI FastLoad off (default).

3. Click Apply. 

4. Click OK to dismiss the message. 

Display Robot Information

1. Select Tools > System Detail.

2. Click the Robot folder on the navigation tree to display summary information.

3. For detailed information, expand the Robot folder in the navigation tree, and then 
select a robot.

4. Select a tab:

■ Status Tab — displays the current operational state of the selected robot

■ Properties Tab — displays robot configuration information, including the 
serial number and current firmware levels

Change Robot Online/Offline Status
Use this procedure only if you are not using ACSLS or ELS tape management 
software, or if their servers cannot communicate with the library. For instructions on 
changing the state of the library and its components through ACSLS or ELS, see the 
tape management software documentation.

Use this procedure to take a robot offline or bring a robot online through the 
SLConsole.

Note: This information is also available through Reports > Robot 
Summary. See "Library Reports" on page 6-4.



Robot Diagnostic Moves

Robot and Safety Door Management 11-3

1. Select Tools > System Detail.

2. Expand the Robot folder, and then click the robot to modify.

3. Click the Status tab.

4. In the Transition Request field, select either:

■ Take Offline — the system completes all outstanding jobs for the robot.

■ Bring Online — the robot moves to the end of the rail, and the library cannot 
use it. If the library is using the redundant robotics feature, the second robot 
will take all requests.

5. Click Apply. 

Perform a Robot Self-Test

1. Select Tools > Diagnostics.

2. Expand the Robot folder, and then click the robot to test.

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive.

5. Click Run. A message indicates the diagnostic test is complete.

Robot Diagnostic Moves
Diagnostic moves can help monitor or diagnose robotic problems by issuing a series of 
"get" and "put" operations. The system chooses a robot for the diagnostic move based 
on the minimum and maximum ranges set for the target and pool addresses. Multiple 
robots may be selected if the address range requires it. 

Successful diagnostic moves do not rearrange the cartridges in the library — the 
system returns cartridges to their original locations. However, some diagnostic move 
failures can cause cartridges to be left in new locations.

A diagnostic move is defined by:

■ Target Address Range — defines the area used to perform the "get" operation in a 
diagnostic move. Valid target address types are storage cells, CAP, drive and 
storage cells, system cells, or all.

Note: Library devices that are offline and in an error state cannot go 
online. The error condition must be cleared first.

Note: To perform a robot self-test, diagnostic cartridges must be 
available in the library.

Note: All resources within the target address range are reserved. 
However, only the location currently being accessed by the robot for a 
get/put operation is unavailable to the host.



Robot Diagnostic Moves

11-4 StorageTek SL3000 User’s Guide

■ Pool Address Range — defines the area used to supply cartridges or empty cells if 
a target address does not contain a cartridge or no empty cells are available. The 
pool and target address can overlap.

■ Access Order — determines how the robot performs get operations within the 
target address range. There are two options:

– Sequential — robot performs a get operation starting with the first location in 
the target address ranges. The robot continues visiting the locations 
sequentially through the range until it completes the requested number of 
moves.

– Random — robot randomly picks a location in the target address range to get a 
cartridge. The robot can also visit the same location in the target address range 
multiple times to get a cartridge, however if you specify enough move request 
the robot is guaranteed to visit all cells. The random access routine ends after 
the requested number of moves is complete.

Define a Diagnostic Move
You can set up and run multiple diagnostic move routines simultaneously if the target 
and pool ranges for each diagnostic move do not overlap.

1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. In the Defined Sequence section, click Add. 

5. Complete the Sequence screen to define the target address:

a. In the Selection Mode section, select the type of cells to diagnose.

b. In the Minimum Address and Maximum Address sections, select the library 
internal address of the starting and ending locations of the cells to diagnose.

6. Click Next.

7. Complete the SOURCE screen to define the pool address:

a. In the Selection Mode sections, select the appropriate cartridge pool address 
type.

b. In the Minimum Address and Maximum Address sections, select the library 
internal addresses of the starting and ending locations of the cartridge pool to 
use.

8. Click Next.

9. Complete the Sequence screen:

a. Name of the diagnostic move.

b. Move Count: Specify a number between 1 and 5000.

c. Access order: Sequential or Random.

d. Move Type: Robot and Cartridge or Robot Only.

Note: This procedure requires sharing of robot resources. You should 
not run it during peak activity periods.
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e. Only if you are certain the cartridges and drives in the diagnostic move are 
compatible, select "Disable pre-move cartridge compatibility check".

10. Click Finish to complete the setup. The new diagnostic sequence is listed in the 
Defined Sequences section.

Manage Diagnostic Move Definitions
Use this procedure to manage diagnostic move sequence definitions. Each diagnostic 
move has its own monitor screen.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. In the Defined Sequences section, select an option:

5. See "Monitor and Control Open Diagnostic Moves" on page 11-6 to manage the 
diagnostic moves currently open.

Save a Diagnostic Move
Use this procedure to save a defined diagnostic move to a file on your workstation. 
The file is saved as a JavaBean component represented as an XML 1.0 document (.xml).

You can use the file to:

■ Restore a move that has been deleted from the library.

■ Copy it to a different library.

To save a diagnostic move file:

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. Select a diagnostic move. Click Save. 

5. Browse to the desired directory, enter a file name, and click Save.

Table 11–1 Diagnostic Moves Options

 Option Definition Notes

Add Define a diagnostic move None

Open Start a diagnostic move Multiple diagnostic moves may be open at a time, 
so long as the target and pool address ranges setup 
for the moves do not overlap.

Modify Modify options for a 
diagnostic move

This diagnostic move routine must not be open or 
if open must be in a "Stopped" state.

Remove Remove a diagnostic move This diagnostic move routine must not be open.

Copy Copy an existing diagnostic 
move

Copy a diagnostic move definition, make changes 
if necessary, and assign a different name.
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Start a Diagnostic Move
Use this procedure to begin a diagnostic move. A monitor window displays for each 
move you open. You can repeat this procedure to open multiple moves, as long as the 
target and pool address ranges for the moves do not overlap.

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

3. Click the DiagMove tab, and then the Manage tab.

4. In the Defined Sequences section, select a diagnostic move. Click Open.

5. From each monitor window, select File > Start Sequence to start the move.

Monitor and Control Open Diagnostic Moves
Use this procedure to control and monitor the status of one or more open diagnostic 
moves.

1. See "Start a Diagnostic Move" on page 11-6 for instructions on starting one or more 
diagnostic moves.

2. Select Tools > Diagnostics. Click the Library folder.

3. Click the DiagMove tab, and then the Monitor tab. Each monitor window 
indicates the status of the move.

4. Use the File menu in each Monitor window to start/stop/pause the sequence, 
clear the output window, or start/stop spooling.

Table 11–2 Status Indicators for Moves

Status Indicators Valid Values

Spooling Status — whether the move output is being spooled to a file True, False

State — execution state of the move Running, pausing, paused, 
stopping, stopped

Health — health state of the move OK, warning, error

Completed moves — Number of moves completed in the requested move 
count

N/A
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12SLConsole Diagnostics and Utilities

The SLConsole enables you to perform many diagnostic tasks, including library 
self-tests, monitoring events, and device diagnostics. 

■ "Library and Device Self-Tests" on page 12-1

■ "Diagnostic Support Information" on page 12-1

■ "Troubleshooting" on page 12-2

■ "Library Events" on page 12-3

■ "Create an Event Monitor" on page 12-5

■ "Display Device Status or Result Code" on page 12-6

For information on using SLConsole diagnostic tools not described in this chapter, see:

■ "Import/Export Diagnostic Cartridges" on page 10-7

■ "Robot Diagnostic Moves" on page 11-3

Library and Device Self-Tests 
Self-tests can help diagnose issues with the library or devices. Refer to: 

■ "Perform a Library Self-Test" on page 6-6

■ "Perform CAP Self-Test" on page 8-4

■ "Perform a Drive Self-Test" on page 9-6

■ "Perform a Robot Self-Test" on page 11-3

Diagnostic Support Information
The following diagnostic tools aid in troubleshooting. Your Oracle support 
representative may request that you capture and transfer these files.

■ Management Information Base (MIB) file - an SNMP database used to manage 
your library devices. This file can be saved as a text file. See "Transfer the Library 
MIB File" on page 6-5.

■ Log Snapshot file - an encrypted snapshot of the library event log. You cannot 
view or edit this file. This file is available for only 15 minutes from the time it is 
generated. See "Generate and Transfer the Library Log Snapshot File" on page 6-6.

■ Device Reserve Table - a table displaying device information and status. See 
"Library Reports" on page 6-4.



Troubleshooting

12-2 StorageTek SL3000 User’s Guide

■ Event monitors - spool of events that captures error data. See "Create an Event 
Monitor" on page 12-5.

Troubleshooting
Before you run diagnostic tests, check the following areas of the library by using the 
following troubleshooting tips.

Service Required (amber) LED is constantly on
Use SLConsole to check the health of the library and the attached devices (drives, 
CAPs, and robots). See Chapter 6, "Library Management" for more details.

To perform a health check:

1. Log in to the SLConsole.

2. Access the System Detail module, View > System Detail.

3. Check the navigation tree for the following indicators: Device Healthy or Device 
Error

Additional checks:

1. Check the Status (for example, online/offline) and Statistics (for example, uptime, 
downtime, errors and warnings) tabs for more information on the health of the 
library and devices.

2. Make sure the cartridges are fully seated and properly oriented in their storage 
cells.

3. Inspect the X table for any foreign objects or debris and remove them if found.

Library does not power-on and SLConsole does not display any messages
1. Check that the library power switch is in the ON position.

2. Check all power cord connections.

3. Replace the power cord.

4. Make sure that there is power to the outlet.

CAP Open LED is on and blinking
Open the CAP and make sure the cartridges in the CAP cells are properly seated. 
Close the CAP.

SLConsole does not display modified data or information remains static
Check the SLConsole Heartbeat icon.

Robot Fault or Library Fault Amber LED is constantly on
1. Check the SLConsole for any displayed error messages. Write down the error 

messages reported.

2. Open the front door. Observe and note the state of the cartridges, hand, and tape 
drives.

3. Make sure cartridges are fully seated and properly oriented in their storage cells.

4. Make sure packing materials have been removed.

5. Inspect the library floor for any objects or debris. If there are any, remove them.

6. Check the status of the tape drives.

7. Close the front door.
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8. Make sure the tape drives are fully seated and locked forward by pushing and 
pulling on the rear of the drive tray. Any motion of the tray indicates that it 
requires re-seating and locking down.

Client computer cannot communicate with the library or tape drives
Make sure cables are securely attached to their connectors on the rear of the library, the 
tape drives, and the client computer.

Library is unable to communicate with the drives and drive status on the SLConsole 
displays "Not communicating" 
Make sure cables are securely attached to their connectors on the rear of the library, the 
drives, and the client computer.

Repeated or excessive drive cleaning or cleaning messages
1. Replace the cleaning cartridge with a new cleaning cartridge.

2. Run the Library Self-Test and note if errors are reported for the drive.

3. Run any client computer-based drive diagnostic tests.

Library Events 
The library controller continually monitors library operations and logs all events. 
Using SLConsole, you can spool event data to a file (see "Create an Event Monitor" on 
page 12-5)

Event Monitors 
The system stores event monitors under the following three headings: 

■ Communication events: Includes host-to-library, library-to-library, and 
library-to-drive communications. 

■ Error event: Each error event is assigned a four-digit (hexadecimal) action code. 

■ Warning events: Indicate a loss of performance or conditions that may be 
indicative of future fatal errors. 

The following information can help you diagnose the cause of the event: 

■ Date/time stamp: Identifies when the event occurred. 

■ Action codes: Identifies the command that was issued, such as "load drive". 

■ Result codes: Identify the result of the requested action.

■ Known service plan diagnosis: Identifies the mechanism or component 
responsible for the task or fault. 

Event Codes Reference
The following tables list the event types, descriptions, and their respective codes.

Activity Code
Activity associated with the event. For example, HLI host mount, diagnostic fetch, 
robot communication diagnostic

Valid Code Description

0000 no action /no activity
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Result Code
Reason for the activity. For example: Activity: HLI host mount, Result: robot X 
cartridge fetch failure.

Severity
Identifies the significance of the event from the perspective of the activity associated 
with the event. The severity levels also identify log activity that must persist across 
system power cycles from that which might be considered volatile.

Valid Codes:

Error (1): Indicates a fault occurred which prevented a request (host or diagnostic) 
from completing successfully. Error data is non-volatile and accumulates across system 
power cycles.

Warning (2): Indicates a fault occurred, but the fault has not stopped the library's 
ability to complete requests (host or diagnostic). Warning data is non-volatile and 
accumulates across system power cycles.

Information (3): Indicates data that is not significant, but may be important to establish 
a history of activity around a severity 1 or 2 event. Information data is volatile.

0100 - 0199 common/shared activity (across devices and the controller)

0200–0299 common/shared activity (across devices - robot, drive, PTP, and so on)

0400–0499 common/shared configuration activity

1000–1999 host interface activity

2000–2999 management interface activity

3000–3999 internal server/library activity

4000–4999 partner library-initiated activity

5000–5999 robot activity

6000–6999 drive activity

7000–7999 CAP activity

8000–8999 elevator activity

9000–9999 PTP activity

Valid Code Description

0000 no problem /normal

0100–0199 common/shared results (across devices and the controller)

1000–1999 host interface results

2000–2999 management interface results

3000–3999 internal server/library controller results

4000–4999 partner library interface results

5000–5999 robot results

6000–6999 drive results

7000–7999 CAP results

8000–8999  elevator activity

9000–9999 PTP activity

Valid Code Description
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Configuration (4): Indicates change in the library's configuration. This includes the 
addition and removal of drives, robots, controllers, and interface cards. This also 
includes changes to the software configuration. Configuration data are non-volatile 
resources and accumulate across system power cycles.

Diagnostic (5): Records normal diagnostic activity tracing. This is independent of the 
debug or trace activity when a diagnostic activity affects the availability of drives or 
other devices to host operations. Diagnostic data is volatile.

Request Identifier
Identifies all host interface requests. Helps track the sequence of log activity resulting 
from each host request.

Create an Event Monitor
Event monitors are useful tools for root cause analysis of errors. Open an event 
monitor and spool all events to a file to capture the error data, then send the file to 
your Oracle support representative for analysis. See  "Event Codes Reference" on 
page 12-3 for a listing of event types and codes.

Display an Event Monitor
1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree.

3. Click an event monitor type. Click Open.

4. Use the Monitor menu to pause, resume, permanently stop, or clear the event 
monitor.

5. To close a monitor, click the X in the upper right corner of the window.

Spool Event Monitor Data to a File
Use this procedure to spool and save event monitor data to a file. You can send the file 
to your Oracle support representative to assist in diagnosing problems.

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree.

3. Select an event monitor. Click Open.

4. In the event monitor window, select Spool File > Start Spooling.

5. Browse to the desired directory, enter the file name, and click Save.

6. To stop spooling, select Monitor > Stop Spooling.

Display Multiple Monitors
You can open and manage multiple event monitors using the Window menu:

Table 12–1 Controls for Displaying Multiple Monitors

To Select

Custom arrange the open monitors on screen Window > Arrange

Arrange the event monitor windows horizontally Window > Tile Horizontal
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Display Device Status or Result Code
1. Select Tools > Diagnostics.

2. Click the Library folder in the navigation tree.

3. Click the Search tab.

4. In the Search Type list, select either:

■ Device Status — device status codes and their descriptions

■ Result Code — result codes and their descriptions

5. Complete the remaining fields:

a. To search for a specific device status code, enter the complete code. Wildcards 
or partial codes are not accepted.

b. To list all device status codes, select List All.

6. Click Search.

Arrange the event monitor windows vertically Window > Tile Vertical

Stack the event monitors Window > Cascade

Table 12–1 (Cont.) Controls for Displaying Multiple Monitors

To Select
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■ "Modes of Operation" on page 13-1

■ "Safety Precautions when Entering the Library" on page 13-1

■ "Powering the Library On or Off" on page 13-2

■ "Accessing the Main Door and AEM Door" on page 13-3

Modes of Operation

Manual Mode
Manual operation may be required if the library has experienced an unrecoverable 
error or a library component requires service or installation. To perform manual 
operations, the library is placed in manual mode. 

A library in manual mode cannot accept host requests (host requests may continue to 
generate and cartridge mounts and dismounts require human intervention). The 
library is in manual mode when a library main access door is open, a robot does not 
automatically mount and dismount cartridges, or the navigation tree in the SLConsole 
indicates that there is a problem with the library.

Maintenance Mode
Maintenance mode is active when a service representative enters the access door to 
perform maintenance or to replace a component. The library continues to operate and 
process host request.

Safety Precautions when Entering the Library

When entering a library, strictly observe the following safety precautions:

■ Know the location of the emergency door unlocking mechanisms (see "Door 
Interlocks" on page 13-2).

■ Ensure the library is offline (see "Place the Library Online or Offline" on page 6-7). 
Do not enter the library or move any of the robot mechanisms if you have any 
reason to suspect the robots are online.

WARNING:  When entering the library, lock the access door open 
and retain the key to prevent accidental closure.
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■ Leave the access door open whenever working inside the library. This disconnects 
DC power and signal lines to the library's motors (see "Servo Power Interrupt" on 
page 13-2).

■ Know the location of the mechanical door releases. See "Mechanical Door 
Releases" on page 13-2 for more information.

■ Know the physical restrictions of the library. Be careful not bump your body 
against the arrays or to snag clothing on the arrays (only 0.4 m [18 in.] of aisle 
clearance).

■ If you must move a robot avoid damaging the robot's mechanical or electronic 
components.

■ If you are manually loading or unloading a cartridge, your hands must remain 
clear of the drive's mechanical and electronic load components.

Door Interlocks
Door safety interlocks are located behind the front access doors of the base module 
and DEM. To open either access door, an access key is required.

Door safety interlocks are constantly monitored by the library controller. If an access 
door is opened during normal operation, an Emergency Robotics Stop condition is 
initiated and all library motors are immediately disabled. This prevents motors from 
operating while a library door is open. If the library is varied offline, opening the 
access door disconnects DC voltages to the rails and the power bus.

The door switches are also monitored when the library is powered off. A battery 
supplies power for the circuitry to detect a door opening/closing event while the 
library is powered off.

When a base module and DEM are connected together, opening an access door to 
either module automatically suspends operations within the entire library (the two 
door switches are connected in series).

Servo Power Interrupt
An additional safety feature is the servo power interrupt (SPI). If the library controller 
detects that a library motor is out-of-range, it will generate an SPI to turn off drive 
voltage to the faulty motor. This prevents a servo runaway condition until the cause of 
the problem can be determined.

Mechanical Door Releases
Each lock handle on the access doors of the base module and DEM includes a 
mechanical release which is painted yellow. This release serves as a safeguard in case a 
person is inside the library and the access door is accidentally closed and locked. 
When you push the release, it unlocks and opens the door.

Powering the Library On or Off
Use the following procedures to power the library on or off.

Power Off the Library
Use this procedure to power down the library.

1. Ensure all jobs have completed and quieces the library.
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2. Take all library drives offline (see "Change a Drive Online/Offline Status" on 
page 9-5).

3. Take the library offline (see "Place the Library Online or Offline" on page 6-7).

4. Open the rear doors of the Base Module and DEM (if present).

5. Turn off the power enable switches.

6. If necessary, turn off the circuit breakers on the PDUs.

Power On the Library
Use this procedure to power up the library. 

1. Open the rear doors of the Base Module and DEM (if present).

2. If necessary, turn on the circuit breakers on the PDUs.

3. Turn on the power enable switches.

4. The library goes through the initialization sequence. If the access doors have been 
opened and closed, a full audit of the library will be performed.

Accessing the Main Door and AEM Door
Use these procedures to open and close the main library access door. Additionally, you 
can open the AEM door in emergency situations.

Open the Main Door
1. Observe all safety precautions (see "Safety Precautions when Entering the Library" 

on page 13-1).

2. Take all library drives offline (see "Change a Drive Online/Offline Status" on 
page 9-5).

3. Take the library offline (see "Place the Library Online or Offline" on page 6-7).

4. Insert the key into the door lock, and turn the key to unlock the door.

5. Pull up on the door latch to release it, and open the door.

6. Turn the key in the lock, to lock the door open, and then remove the key from the 
lock and keep it with you. This will prevent the door from being closed while you 
are in the library.

7. Enter the library.

Close and Lock the Main Door
Use this procedure to close and lock the main doors of the library. When you close the 
access door, the library will perform a full audit.

1. Verify that there are no loose items in the library.

2. If the access doors were locked open, insert the key into the door lock, and turn 
the key, to unlock the door.

3. Push the door closed and make sure it latches securely.

4. Turn the key in the lock, to lock the door closed.

5. Remove the key from the lock and keep it in a safe place.
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6. If the library has been powered off, power it on. See "Power On the Library" on 
page 13-3for details.

Open AEM Door for Emergency Access
Use this procedure to gain emergency access to the AEM.

1. Insert the library access door key in the Deadbolt Override lock, and unlock the 
door by turning the key clockwise. The key cannot be removed from the lock 
while it is in the unlocked position.

2. Lift the AEM access door latch, and open the door. DO NOT force the AEM access 
door to open or close.

All power to the TallBots is stopped immediately. All in-process jobs are stopped 
abruptly, and the TallBots and AEM CAPs are brought offline.

Close AEM Access Door
Use this procedure to close the AEM access door and re-initialize the library after 
performing an AEM emergency access. This procedure initiates a full audit of the 
library.

1. Close and latch the AEM access door. DO NOT force the AEM access door to open 
or close.

2. Lock the door by turning the key counter-clockwise in the Deadbolt Override lock.

a. The library re-initializes.

b. The TallBots go through their initialization sequence.

c. A full audit of the library is conducted.

d. The AEM CAP is brought online and returned to its default state.

Caution: This procedure has the same effects on library operations as 
opening the main library access door. It causes an abrupt interruption 
of library activity. This procedure does not lower the internal AEM 
safety door.
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This appendix explains the addressing schemes used in the SL3000 library. There are 
four main types of addressing schemes:

■ Internal Firmware (Library, Rail, Column, Side, Row) — used by the firmware 
and internal communications to represent all devices and locations within the 
library.

■ HLI-PRC (LSM, Panel, Row, and Column) — used by HLI clients, such as ACSLS 
and ELS, to represent library locations and components.

■ FC-SCSI Element Numbering — used by hosts with FC-SCSI connections to the 
library.

■ External hardware numbering — used for drive bay locations (see "Tape Drive 
Numbering" on page A-12).

CenterLine
Internal firmware and HLI addressing use the centerline as a reference point. When 
additional modules are added to either end of the library, the existing components do 
not change address number.

The basis of centerline technology involves balancing additional modules on the left 
and right side of the Base Module. This reduces the overall travel of the robot to help 
balance the work load and improve library performance. 

Figure A–1 shows the location of the centerline for various library configurations.

Note: In this appendix, "left" and "right" are in reference to viewing 
the library from the CAP-side (front) unless otherwise specified.
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Figure A–1 CenterLine Location in Sample Libraries

Internal Firmware
Internal firmware addressing designates physical location using five parameters: 
Library, Rail, Column, Side, Row (L,R,C,S,W).

Library
Always equal to 1.

Rail
Always equal to 1.
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Column
Indicates the horizontal location of a tape cartridge referenced from the centerline of 
the library. Numbering is static, allowing modules to be added without renumbering 
existing columns.

■ Positive (+) value indicates right of centerline

■ Negative (-) value indicates left of centerline

Base Module

■ Contains columns 1 to 6 for data cartridges and 1 to 4 for tape drives.

DEM

■ Contains columns -1 to -6 for data cartridges and -1 to -4 for tape drives.

CEM

■ Contains six columns for data cartridges.

■ Column numbering continues consecutively from the adjacent module. However, 
if there is no DEM, a CEM placed directly to the left of a Base contains columns -7 
to -12 (columns -1 to -6 are skipped).

PEM

■ Contains only three columns for data cartridges. The outer most three columns are 
inactive.

AEM

■ AEM columns are numbered as if a DEM and four CEMS are installed to the left of 
the Base Module and four CEMs are installed to the right.

■ Left AEM columns are always numbered -33 to -31.

■ Right AEM columns are always 31 to 33. 

Side
Indicates the front or rear walls of the library.

■ Rear wall = 1

■ Front wall = 2

Row
The vertical location of a tape cartridge, consecutively numbered from the top (1) 
down (52).
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Figure A–2 Internal Firmware Addressing Examples (viewed from top of library)

HLI-PRC
HLI-PRC addressing designates physical location using four parameters: LSM, Panel, 
Row, and Column. 

LSM
Always equal to 0. 

Panel
Indicates the front or rear wall of a module. The panel number can range from 0 to 23 
depending on the configuration of the library.

■ Rear wall = even numbers

■ Front wall = odd numbers
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The panel location is defined relative to the Base Module (panels 12 and 13). Panel 
values less than 12 indicate the module is to the left of the Base Module, while values 
greater than 13 indicate the module is to the right of the Base Module.

Base Module

■ Panels 12 and 13

DEM

■ Panels 10 and 11

CEM

■ Panels are numbered consecutively from the adjacent module. However, if there is 
no DEM, a CEM placed directly to the left of a Base Module contains panels -8 and 
-9 (panels -10 and -11 are skipped).

AEM

■ AEMs are considered CAPs by HLI addressing. Therefore, AEMs have a CAP ID 
instead of a panel number (see "Cartridge Access Ports - HLI" on page A-16)

■ Left AEM CAP ID is always numbered 0 

■ Right AEM CAP ID is always numbered 11

Row
The vertical location of a slot, consecutively numbered from the top down (0 to 51). 
However, drive bays have row numbering from 0 to 23 for the Base Module, and 0 to 
31 in the DEM.

Column
The horizontal location of a slot from left to right (0 to 5). However, drive bays always 
have a column value of 0 (see "Tape Drive Numbering" on page A-12").

AEM column numbering starts at the rear wall and runs left to right (columns 0–2), 
then proceeds to the front wall and runs left to right (columns 3–5).

Tape Drives and CAPs
HLI addressing defines tape drives with a drive ID instead of a row value. The 
addressing is LSM, panel, drive ID, column (see "Tape Drive Numbering" on 
page A-12).

HLI addressing defines CAP locations with a CAP ID instead of a panel value. The 
addressing is LSM, CAP ID, row, column (see "Cartridge Access Ports - HLI" on 
page A-16").
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Figure A–3 HLI-PRC Addressing Examples (viewed from top of library)

FC-SCSI Element Numbering
For FC-SCSI element numbering, each active component in the library is defined by a 
unique element ID number. SCSI element numbering consists of three element types:

■ Storage Elements (active cartridge slots)

– Begins at 2000 and increments by one for every active slot.

– Numbered top to bottom, left to right, and rear to front. See Figure A–4.

■ Import/Export Elements (rotational CAPs)

– Begins at 10 for the left most CAP in the library. Storage and Import/Export 
elements are numbered sequentially by slot. No slots are skipped. 

– Numbered top to bottom, left to right. See Figure A–7.
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■ Data Transfer Elements (tape drives)

– Begins at 1000 and increments by one for every installed tape drive.

– Numbered left to right, top to bottom, starting at the centerline in the Base 
module and continuing in the DEM if installed. This numbering scheme 
allows the user to add a bank of drives and not disturb the ordering of the 
banks above. See Figure A–5.

The behavior of the FC-SCSI element numbering depends on the whether the library is 
partitioned and if the active capacity was assigned by default or was user-selected.

Default Capacity Assignment
When active capacity is assigned by default, the library always begins the active 
capacity from the upper left slot on the rear wall of the left-most module. The activated 
capacity and SCSI numbering scheme follows the pattern defined in Figure A–4. The 
default SCSI element numbering for tape drives follows the numbering scheme 
defined in Figure A–5. 

With default numbering, any configuration change to the library causes the element 
numbers to be reassigned. Therefore, the element numbers will be reassigned and the 
library will reboot when:

■ A storage module is added/removed from the library

■ Activated capacity changes

■ Tape drives are added/removed

User Defined—Non-Partitioned Capacity Assignment
When the active capacity location is selected by the user in a non-partitioned library, 
the numbering begins with the left most slot on the rear wall within the selected active 
area. The numbering scheme follows the pattern defined in "Default SCSI Storage 
Element Numbering Scheme" on page A-8 for all active slot cells, but skips over any 
inactive cells.

If additional capacity is activated, the SCSI numbering of previously activated cells 
does not change — the library simply appends the SCSI numbering for newly 
activated cells (see Figure A–8 and Figure A–9  on page A-11).

However, if tape drives are added to a user-defined, non-partitioned library, the 
library reassigns SCSI Data Transfer element numbering following the "Default SCSI 
Data Transfer Element Numbering Scheme" on page A-8. Then, the library reboots

User Defined—Partitioned Capacity Assignment
When the active capacity location is selected by the user in a partitioned library, the 
numbering begins with the left most slot on the rear wall within the partition. The 
numbering scheme follows the pattern defined in Figure A–4 for all active slot cells, 
but skips over any inactive cells and cells not within the partition. Therefore, element 

Note: When the library powers on, a vacant drive slot will not be 
included in the element number sequence. Open Systems backup 
applications do not tolerate Data Transfer Elements that cannot or do 
not respond when you power-on the library.
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numbering is continuous within each partition, even if cell locations for the partition 
are not adjacent. 

If additional capacity is activated or tape drives are added to a partition, the SCSI 
numbering of previously numbered elements in the partition does not change. The 
library simply appends the SCSI numbering for newly activated cells or newly 
inserted tape drives within the partition.

Default SCSI Storage Element Numbering Scheme
Figure A–4 shows the default numbering scheme for SCSI Storage Elements. The 
numbering scheme follows these rules:

1. The numbering starts in the upper left slot on the rear wall of the left-most 
module. 

2. The numbering increases from top to bottom and left to right.

3. When the numbering reaches the last slot on the rear wall, it crosses to the front 
wall of the left-most module (A to B in Figure A–4). 

4. The numbering continues top to bottom, left to right, and ends at the lower right 
slot of the right-most module.

Figure A–4 SCSI Storage Element Numbering

Default SCSI Data Transfer Element Numbering Scheme
Figure A–5 shows the default numbering scheme for SCSI Data Transfer Elements. The 
numbering scheme follows these rules:

1. The numbering starts in the upper left drive slot in the Base Module.

2. The numbering increases from left to right and top to bottom (skipping any empty 
drive slots). 
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3. When the numbering reaches the lower right drive slot on the Base Module, it 
crosses to the Drive Expansion Module (A to B in Figure A–5). 

4. The numbering continues left to right, top to bottom, and ends at the lower right 
slot of the DEM.

Figure A–5 SCSI Data Transfer Element Numbering (viewed from front of library)

Element Numbering Examples
The library in the example has been simplified and is not an exact representation of a 
SL3000 library.

Default Numbering
Figure A–6 and Figure A–7 provide an example of default SCSI element numbering. 
The example library includes:

■ Four modules: one Base, one DEM, and two CEMs 

■ 166 data cartridge slots: numbered 2000 to 2165

■ 40 tape drive bays (two tape drives are missing, one in each module): numbered 
1000 to 1037

■ Two CAPs, each with seven slots: numbered 10 to 23
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Figure A–6 SCSI Element Numbering - Rear Wall (viewed from front of library)

Figure A–7 SCSI Element Numbering - Front Wall (viewed from front of library)

User-Defined Numbering
Figure A–8 and Figure A–9 provide an example of user-defined SCSI element 
numbering. The library in the example has been simplified and is not an exact 
representation of a SL3000 library. For simplification, the active areas selected are only 
on the rear wall.

For this example, the user has decided to activate 50 cells, beginning with the DEM. As 
a result, the SCSI storage element numbering begins at 2000 with the upper left-most 
active cell in the DEM. The cells in the left CEM are currently inactive and are 
therefore not numbered (Figure A–8).
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Figure A–8 User Defined Capacity SCSI Element Numbering - Rear Wall

At a later date, the user decides to activate the remaining 30 cells in the library. Since 
the active capacity was initially user-defined, the SCSI numbering does not re-assign 
numbering to the previously-activated cells. The SCSI storage element numbering for 
the newly-activated cells is appended (Figure A–9).

Figure A–9 User Defined Added Capacity SCSI Element Numbering - Rear Wall

Comparison of Addressing Schemes
Internal Firmware

■ Uses: library, rail, column, side, and row.

■ Begins at 1 and uses negative numbers.

■ Side indicates the front or rear wall of the library.

■ Drive bays have column values 1 to 4 (BM) and -1 to -4 (DEM).

HLI-PRC

■ Uses: LSM, panel, row, and column.

■ Begins at 0 with no negative numbers.
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■ Panel indicates the front or rear wall of a specific module.

■ Drive bays always have column value of 0.

FC-SCSI Element

■ Uses single positive number for the element ID.

■ Cartridge slots begin at 2000, tape drives begin at 1000, CAPs begin at 10.

■ Inactive slots and empty drive bays are skipped when element numbers are 
assigned.

■ Default element numbering is reassigned with any library configuration change.

■ Element numbering is dependent on active capacity.

Tape Drive Numbering
All of the tape drives in the SL3000 library are physically located at the rear of the Base 
Module or Drive Expansion Module. There are four addressing schemes used to define 
the location of drives:

■ "Hardware Numbering" on page A-12

■ "Internal Firmware" on page A-13

■ "HLI-PRC" on page A-14

■ FC-SCSI Element numbering (see "Default SCSI Data Transfer Element Numbering 
Scheme" on page A-8).

Hardware Numbering
The physical hardware numbering of tape drives is assigned by the HBC controller 
card. The card automatically assigns a number, 1-56, to each drive bay.

Note: The perspective in Figure A–10 is from the drive-side (rear) of 
the library.
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Figure A–10 Tape Drive Physical Hardware Numbering (viewed from rear of library)

Internal Firmware
The firmware addressing (library, rail, column, side, row) distinguishes a drive based 
on column and row. The library, rail, and side values are always equal to 1.

Note: The perspective in Figure A–11 is from the drive-side (rear) of 
the library. 
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Figure A–11 Tape Drive Internal Firmware Addressing (viewed from rear of library)

HLI-PRC
The HLI-PRC uses drive IDs instead of row values. Therefore, the addressing is LSM, 
panel, drive, column. HLI distinguishes a drive based on the panel and drive value. 
The LSM and column values are always equal to 0.

Note: The perspective in Figure A–12 is from the drive-side (rear) of 
the library.
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Figure A–12 Tape Drive HLI-PRC Addressing (viewed from rear of library)

Addressing of Components—CAPs and Robots
The addressing of components, such as CAPs and robots, have unique addressing 
rules: 

■ The library and rail values are always 1.

■ A row value of 0 indicates the address is referring to the device, not a slot in the 
device.

■ The column value of a rotational CAP depends on module location.

Cartridge Access Ports - Internal Firmware
Both rotational CAPs and AEMs are considered cartridge access ports for addressing 
purposes.

Rotational CAPs

Column
The column value depends on the size of the library and the location of the module 
that contains the CAP.

For modules to the left of centerline, the CAP column value corresponds to the second 
column from the right of the module. For example, in a DEM, the column value for the 
CAP would be -2 and a CEM to the left of the DEM would have a CAP column value 
of -8.

Note: "Left" and "right" are in reference to viewing the library from 
the CAP-side (front) unless otherwise specified.
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For modules to the right of centerline, the CAP column value corresponds to the fifth 
column from the left of the module. For example, a CAP in the Base has a column 
value of 5 and a CEM to the right of the Base would have a CAP column value of 11.

Side
The side value is always 2, since the CAPs are only located on the front of the module.

Row
When addressing the device: the row value is 0.

When addressing a specific slot: the row value is the slot in the CAP magazine (values 
1 to 26).

Example - Rotational Firmware Addressing
For this example, the library has a Base, DEM, and four CEMs (two on each side). The 
address refers to the sixth cell down in the CAP in the CEM on the far left.

The firmware address is: (1, 1, -14, 2, 6)

AEM CAPs

Column
The column value when referencing the CAP is:

■ -31 for left AEM

■ 31 for right AEM

The column value when referencing a slot in the CAP:

■ -31 to -33 for left AEM

■ 31 to 33 for right AEM

Side
Indicates the front or rear CAP doors on the library.

■ Rear wall = 1

■ Front wall = 2

Row
When addressing the device: the row value is 0.

When addressing a specific slot: the row value is the slot in the CAP (values 1 to 26).

Example - AEM CAP Firmware Addressing
For this example, the address is referencing a cartridge slot in the right AEM. The slot 
is the 37th down in the far right column in the rear CAP door.

The firmware address is: (1, 1, 33, 1, 37)

Cartridge Access Ports - HLI
CAPs have CAP IDs instead of panel values. CAP IDs range from 0 to 11, depending 
on location. 

Rotational CAPs

LSM
Always equal to 0.
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CAP ID
Ranges from 1 to 10

■ CEMs left of centerline = 1 to 4 (left to right)

■ DEM = 5

■ Base Module = 6

■ CEMs right of centerline = 6 to 10 (left to right)

Row
The value is the slot in the CAP (can be values 0 to 25).

Column
The value always equals 0.

Example - Rotational CAP HLI Addressing
For this example, the library has a Base, DEM, and eight CEMs (four on each side). The 
address refers to the sixth cell down in the CAP in the CEM on the far left.

The HLI address is: (0, 1, 5, 0)

AEM CAPs

LSM
Always equal to 0.

CAP ID
Left AEM equals 0.

Right AEM equals 11.

Row
The value is the slot in a column (can be values 0 to 38). 

Column
Rear wall = columns 0 to2

Front wall = columns 3 to 5

Robots - Internal Firmware

Column
The column value is always 0.

Side
If there is only one robot: the side value is always 1.

For redundant robot configurations:

■ Left robot = 1

■ Right robot = 2

Row
When addressing the device: the row is 0.

When addressing the specific slot: the row is the slot value (1).
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Example - Robot Firmware Addressing
For this example, the address is referring to the right robot in a redundant robotics 
library.

The firmware address is: (1, 1, 0, 2, 0)
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BWall Diagrams

This appendix explains special library cells, such as reserved system slots and the 
module identification blocks. Additionally, the appendix contains library wall maps 
for each possible module configuration

Reserved System Slots
Both the Base Module and the Drive Expansion Module have reserved system cells on 
the lower rear wall. These cells provide special functions for the library and tape 
drives. Do not place data cartridges in a reserved slot. The reserved cells are composed 
of: 

■ Two swap cells in column 2, rows 49 and 50.

■ One diagnostic cell in column 2, row 51, and four diagnostic cells in column 3, 
rows 49, 50, 51, and 52.

■ A module identification block in column 4, rows 49, 50, 51, and 52 (see Figure B–1).

■ Four cleaning cartridges in column 5, rows 49, 50, 51, and 52, and four cleaning 
cartridges in column 6, rows 49, 50, 51, and 52.

Figure B–1 Reserved System Cells

Module Identification Block
Each module has an identification block with labels that identify the module 
configuration. This block is on the lower rear wall in the forth column from the left, 
rows 49, 50, 51, and 52. 

During an initialization or after an upgrade, the robotic assembly visits the module 
identification block to determine the module configuration.

The block identifies the: 
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■ Type of module: Base Module, Drive Expansion Module, Cartridge Expansion 
Module, Parking Expansion Module, or Access Expansion Module.

■ Back wall configuration: 1 drive array, 2 drive arrays, 3 drive arrays, 4 drive arrays, 
arrays, bulk load magazines, or empty.

■ Front wall configuration: Arrays, cartridge access port, CAP window, empty, or bulk 
load magazines.

■ Options: Arrays, op panel or window, empty, or service bay.

Figure B–2 Module Identification Block Base Module Example
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Figure B–3 Module Identification Block Examples

1. Base Module with one Drive Block for eight drives, a CAP installed and no Op 
Panel or Window installed.

2. Drive Expansion Module (DEM) with one drive array for eight drives, no CAP 
and no Op Panel or Window installed.

3. Cartridge Expansion Module (CEM) with no Drives, no CAP and no Op Panel or 
Window installed.

4. Access Expansion Module (AEM) with no Drives, no CAP, no Op Panel or 
Window installed. It includes Bulk Load Magazines on the front and back walls 
and has the safety door to allow service without interruption.

Special Labels
The CAPID/ label and NOMAG/ label are special labels that do not include an icon. 

■ CAPID/ is mounted only at the top of all CAPs as a generic identifier for the 
library if the CAP does not have any magazines installed on which to target. 

■ NOMAG/ is mounted behind the removable magazines in the bulk load AEM.

Wall Diagrams
■ Base Module front wall (Figure B–4)

■ Base Module rear wall (Figure B–5 and Figure B–6)

Table B–1 Special Labels

Function Label Text Barcode Icon

Cartridge Access Port ID SPECIAL: CAP IDENTIFICATION CAPID/ None

No Magazines SPECIAL: NO MAGAZINES NOMAG/ None
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■ DEM front wall (Figure B–7 and Figure B–8)

■ DEM rear wall (Figure B–9 and Figure B–10)

■ CEM front wall (Figure B–11)

■ CEM rear wall (Figure B–12)

■ Left PEM (Figure B–13)

■ Right PEM (Figure B–14)

■ Left AEM (Figure B–15)

■ Right AEM (Figure B–16)

Figure B–4 Base Module, Front Wall
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Figure B–5 Base Module, Rear Wall
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Figure B–6 Base Module, rear wall with 24 drives

.
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Figure B–7 DEM Front Wall
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Figure B–8 DEM Front Wall (continued)
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Figure B–9 DEM Rear Wall
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Figure B–10 DEM Rear Wall (continued)
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Figure B–11 Cartridge Expansion Module, Front Wall
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Figure B–12 Cartridge Expansion Module, Rear
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Figure B–13 Parking Expansion Module, Left
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Figure B–14 Parking Expansion Module, Right
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Figure B–15 Access Expansion Module, Left
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Figure B–16 Access Expansion Module, Right
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CControlling Contaminants

This chapter includes information on the importance of preventing contaminants.

Environmental Contaminants
Control over contaminant levels in a computer room is extremely important because 
tape libraries, tape drives, and tape media are subject to damage from airborne 
particulates. Most particles smaller than ten microns are not visible to the naked eye 
under most conditions, but these particles can be the most damaging. As a result, the 
operating environment must adhere to the following requirements: 

■ ISO 14644-1 Class 8 Environment.

■ The total mass of airborne particulates must be less than or equal to 200 
micrograms per cubic meter.

■ Severity level G1 per ANSI/ISA 71.04-1985.

Oracle currently requires the ISO 14644-1 standard approved in 1999, but will require 
any updated standards for ISO 14644-1 as they are approved by the ISO governing 
body. The ISO 14644-1 standard primarily focuses on the quantity and size of 
particulates as well as the proper measurement methodology, but does not address the 
overall mass of the particulates. As a result, the requirement for total mass limitations 
is also necessary as a computer room or data center could meet the ISO 14644-1 
specification, but still damage equipment because of the specific type of particulates in 
the room. In addition, the ANSI/ISA 71.04-1985 specification addresses gaseous 
contaminations as some airborne chemicals are more hazardous. All three 
requirements are consistent with the requirements set by other major tape storage 
vendors.

Required Air Quality Levels
Particles, gasses and other contaminants may impact the sustained operations of 
computer hardware. Effects can range from intermittent interference to actual 
component failures. The computer room must be designed to achieve a high level of 
cleanliness. Airborne dusts, gasses and vapors must be maintained within defined 
limits to help minimize their potential impact on the hardware. 

Airborne particulate levels must be maintained within the limits of ISO 14644-1 Class 8 
Environment. This standard defines air quality classes for clean zones based on 
airborne particulate concentrations. This standard has an order of magnitude less 
particles than standard air in an office environment. Particles ten microns or smaller 
are harmful to most data processing hardware because they tend to exist in large 
numbers, and can easily circumvent many sensitive components' internal air filtratio 
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systems. When computer hardware is exposed to these submicron particles in great 
numbers they endanger system reliability by posing a threat to moving parts, sensitive 
contacts and component corrosion.

Excessive concentrations of certain gasses can also accelerate corrosion and cause 
failure in electronic components. Gaseous contaminants are a particular concern in a 
computer room both because of the sensitivity of the hardware, and because a proper 
computer room environment is almost entirely recirculating. Any contaminant threat 
in the room is compounded by the cyclical nature of the airflow patterns. Levels of 
exposure that might not be concerning in a well ventilated site repeatedly attack the 
hardware in a room with recirculating air. The isolation that prevents exposure of the 
computer room environment to outside influences can also multiply any detrimental 
influences left unaddressed in the room. 

Gasses that are particularly dangerous to electronic components include chlorine 
compounds, ammonia and its derivatives, oxides of sulfur and petrol hydrocarbons. In 
the absence of appropriate hardware exposure limits, health exposure limits must be 
used. 

While the following sections will describe some best practices for maintaining an ISO 
14644-1 Class 8 Environment in detail, there are some basic precautions that must be 
adhered to:

■ Do not allow food or drink into the area.

■ Cardboard, wood, or packing materials must not be stored in the data center clean 
area.

■ Identify a separate area for unpacking new equipment from crates and boxes.

■ Do not allow construction or drilling in the data center without first isolating 
sensitive equipment and any air targeted specifically for the equipment. 
Construction generates a high level of particulates that exceed ISO 14644-1 Class 8 
criteria in a localized area. Dry wall and gypsum are especially damaging to 
storage equipment.

Contaminant Properties and Sources
Contaminants in the room can take many forms, and can come from numerous 
sources. Any mechanical process in the room can produce dangerous contaminants or 
agitate settled contaminants. A particle must meet two basic criteria to be considered a 
contaminant:

■ It must have the physical properties that could potentially cause damage to the 
hardware.

■ It must be able to migrate to areas where it can cause the physical damage.

The only differences between a potential contaminant and an actual contaminant are 
time and location. Particulate matter is most likely to migrate to areas where it can do 
damage if it is airborne. For this reason, airborne particulate concentration is a useful 
measurement in determining the quality of the computer room environment. 
Depending on local conditions, particles as big as 1,000 microns can become airborne, 
but their active life is very short, and they are arrested by most filtration devices. 
Submicron particulates are much more dangerous to sensitive computer hardware, 
because they remain airborne for a much longer period of time, and they are more apt 
to bypass filters.
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Operator Activity
Human movement within the computer space is probably the single greatest source of 
contamination in an otherwise clean computer room. Normal movement can dislodge 
tissue fragments, such as dander or hair, or fabric fibers from clothing. The opening 
and closing of drawers or hardware panels or any metal-on-metal activity can produce 
metal filings. Simply walking across the floor can agitate settled contamination 
making it airborne and potentially dangerous.

Hardware Movement
Hardware installation or reconfiguration involves a great deal of subfloor activity, and 
settled contaminants can very easily be disturbed, forcing them to become airborne in 
the supply air stream to the room's hardware. This is particularly dangerous if the 
subfloor deck is unsealed. Unsealed concrete sheds fine dust particles into the 
airstream, and is susceptible to efflorescence -- mineral salts brought to the surface of 
the deck through evaporation or hydrostatic pressure. 

Outside Air
Inadequately filtered air from outside the controlled environment can introduce 
innumerable contaminants. Post-filtration contamination in duct work can be 
dislodged by air flow, and introduced into the hardware environment. This is 
particularly important in a downward-flow air conditioning system in which the 
sub-floor void is used as a supply air duct. If the structural deck is contaminated, or if 
the concrete slab is not sealed, fine particulate matter (such as concrete dust or 
efflorescence) can be carried directly to the room's hardware. 

Stored Items
Storage and handling of unused hardware or supplies can also be a source of 
contamination. Corrugated cardboard boxes or wooden skids shed fibers when moved 
or handled. Stored items are not only contamination sources; their handling in the 
computer room controlled areas can agitate settled contamination already in the room.

Outside Influences
A negatively pressurized environment can allow contaminants from adjoining office 
areas or the exterior of the building to infiltrate the computer room environment 
through gaps in the doors or penetrations in the walls. Ammonia and phosphates are 
often associated with agricultural processes, and numerous chemical agents can be 
produced in manufacturing areas. If such industries are present in the vicinity of the 
data center facility, chemical filtration may be necessary. Potential impact from 
automobile emissions, dusts from local quarries or masonry fabrication facilities or sea 
mists should also be assessed if relevant.

Cleaning Activity
Inappropriate cleaning practices can also degrade the environment. Many chemicals 
used in normal or office cleaning applications can damage sensitive computer 
equipment. Potentially hazardous chemicals outlined in the "Cleaning Procedures and 
Equipment"section should be avoided. Out-gassing from these products or direct 
contact with hardware components can cause failure. Certain biocide treatments used 
in building air handlers are also inappropriate for use in computer rooms either 
because they contain chemicals, that can degrade components, or because they are not 
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designed to be used in the airstream of a re-circulating air system. The use of push 
mops or inadequately filtered vacuums can also stimulate contamination.

It is essential that steps be taken to prevent air contaminants, such as metal particles, 
atmospheric dust, solvent vapors, corrosive gasses, soot, airborne fibers or salts from 
entering or being generated within the computer room environment. In the absence of 
hardware exposure limits, applicable human exposure limits from OSHA, NIOSH or 
the ACGIH should be used. 

Contaminant Effects
Destructive interactions between airborne particulate and electronic instrumentation 
can occur in numerous ways. The means of interference depends on the time and 
location of the critical incident, the physical properties of the contaminant and the 
environment in which the component is placed.

Physical Interference
Hard particles with a tensile strength at least 10% greater than that of the component 
material can remove material from the surface of the component by grinding action or 
embedding. Soft particles will not damage the surface of the component, but can 
collect in patches that can interfere with proper functioning. If these particles are tacky 
they can collect other particulate matter. Even very small particles can have an impact 
if they collect on a tacky surface, or agglomerate as the result of electrostatic charge 
build-up.

Corrosive Failure
Corrosive failure or contact intermittence due to the intrinsic composition of the 
particles or due to absorption of water vapor and gaseous contaminants by the 
particles can also cause failures. The chemical composition of the contaminant can be 
very important. Salts, for instance, can grow in size by absorbing water vapor from the 
air (nucleating). If a mineral salts deposit exists in a sensitive location, and the 
environment is sufficiently moist, it can grow to a size where it can physically interfere 
with a mechanism, or can cause damage by forming salt solutions.

Shorts
Conductive pathways can arise through the accumulation of particles on circuit boards 
or other components. Many types of particulate are not inherently conductive, but can 
absorb significant quantities of water in high-moisture environments. Problems caused 
by electrically conductive particles can range from intermittent malfunctioning to 
actual damage to components and operational failures.

Thermal Failure
Premature clogging of filtered devices will cause a restriction in air flow that could 
induce internal overheating and head crashes. Heavy layers of accumulated dust on 
hardware components can also form an insulative layer that can lead to heat-related 
failures.

Room Conditions
All surfaces within the controlled zone of the data center should be maintained at a 
high level of cleanliness. All surfaces should be periodically cleaned by trained 
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professionals on a regular basis, as outlined in the "Cleaning Procedures and 
Equipment"section. Particular attention should be paid to the areas beneath the 
hardware, and the access floor grid. Contaminants near the air intakes of the hardware 
can more easily be transferred to areas where they can do damage. Particulate 
accumulations on the access floor grid can be forced airborne when floor tiles are lifted 
to gain access to the sub-floor.

The subfloor void in a downward-flow air conditioning system acts as the supply air 
plenum. This area is pressurized by the air conditioners, and the conditioned air is 
then introduced into the hardware spaces through perforated floor panels. Thus, all air 
traveling from the air conditioners to the hardware must first pass through the 
subfloor void. Inappropriate conditions in the supply air plenum can have a dramatic 
effect on conditions in the hardware areas.

The subfloor void in a data center is often viewed solely as a convenient place to run 
cables and pipes. It is important to remember that this is also a duct, and that 
conditions below the false floor must be maintained at a high level of cleanliness. 
Contaminant sources can include degrading building materials, operator activity or 
infiltration from outside the controlled zone. Often particulate deposits are formed 
where cables or other subfloor items form air dams that allow particulate to settle and 
accumulate. When these items are moved, the particulate is re-introduced into the 
supply airstream, where it can be carried directly to hardware.

Damaged or inappropriately protected building materials are often sources of subfloor 
contamination. Unprotected concrete, masonry block, plaster or gypsum wall-board 
will deteriorate over time, shedding fine particulate into the air. Corrosion on 
post-filtration air conditioner surfaces or subfloor items can also be a concern. The 
subfloor void must be thoroughly and appropriately decontaminated on a regular 
basis to address these contaminants. Only vacuums equipped with High Efficiency 
Particulate Air (HEPA) filtration should be used in any decontamination procedure. 
Inadequately filtered vacuums will not arrest fine particles, passing them through the 
unit at high speeds, and forcing them airborne.

Unsealed concrete, masonry or other similar materials are subject to continued 
degradation. The sealants and hardeners normally used during construction are often 
designed to protect the deck against heavy traffic, or to prepare the deck for the 
application of flooring materials, and are not meant for the interior surfaces of a 
supply air plenum. While regular decontaminations will help address loose 
particulate, the surfaces will still be subject to deterioration over time, or as subfloor 
activity causes wear. Ideally all of the subfloor surfaces will be appropriately sealed at 
the time of construction. If this is not the case, special precautions will be necessary to 
address the surfaces in an on-line room.

It is extremely important that only appropriate materials and methodology are used in 
the encapsulation process. Inappropriate sealants or procedures can actually degrade 
the conditions they are meant to improve, impacting hardware operations and 
reliability. The following precautions should be taken when encapsulating the supply 
air plenum in an on-line room:

■ Manually apply the encapsulant. Spray applications are totally inappropriate in an 
on-line data center. The spraying process forces the sealant airborne in the supply 
airstream, and is more likely to encapsulate cables to the deck.

■ Use a pigmented encapsulant. The pigmentation makes the encapsulant visible in 
application, ensuring thorough coverage, and helps in identifying areas that are 
damaged or exposed over time.
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■ It must have a high flexibility and low porosity to effectively cover the irregular 
textures of the subject area, and to minimize moisture migration and water 
damage.

■ The encapsulant must not out-gas any harmful contaminants. Many encapsulants 
commonly used in industry are highly ammoniated or contain other chemicals 
that can be harmful to hardware. It is very unlikely that this out-gassing could 
cause immediate, catastrophic failure, but these chemicals will often contribute to 
corrosion of contacts, heads or other components.

Effectively encapsulating a subfloor deck in an on-line computer room is a very 
sensitive and difficult task, but it can be conducted safely if appropriate procedures 
and materials are used. Avoid using the ceiling void as an open supply or return for 
the building air system. This area is typically very dirty and difficult to clean. Often 
the structural surfaces are coated with fibrous fire-proofing, and the ceiling tiles and 
insulation are also subject to shedding. Even before filtration, this is an unnecessary 
exposure that can adversely affect environmental conditions in the room. It is also 
important that the ceiling void does not become pressurized, as this will force dirty air 
into the computer room. Columns or cable chases with penetrations in both the 
subfloor and ceiling void can lead to ceiling void pressurization.

Exposure Points
All potential exposure points in the data center should be addressed to minimize 
potential influences from outside the controlled zone. Positive pressurization of the 
computer rooms will help limit contaminant infiltration, but it is also important to 
minimize any breaches in the room perimeter. To ensure the environment is 
maintained correctly, the following should be considered: 

■ All doors should fit snugly in their frames. 

■ Gaskets and sweeps can be used to address any gaps. 

■ Automatic doors should be avoided in areas where they can be accidentally 
triggered. An alternate means of control would be to remotely locate a door trigger 
so that personnel pushing carts can open the doors easily. In highly sensitive areas, 
or where the data center is exposed to undesirable conditions, it may be advisable 
to design and install personnel traps. Double sets of doors with a buffer between 
can help limit direct exposure to outside conditions.

■ Seal all penetrations between the data center and adjacent areas. 

■ Avoid sharing a computer room ceiling or subfloor plenum with loosely controlled 
adjacent areas.

Filtration
Filtration is an effective means of addressing airborne particulate in a controlled 
environment. It is important that all air handlers serving the data center are 
adequately filtered to ensure appropriate conditions are maintained within the room. 
In-room process cooling is the recommended method of controlling the room 
environment. The in-room process coolers re-circulate room air. Air from the hardware 
areas is passed through the units where it is filtered and cooled, and then introduced 
into the subfloor plenum. The plenum is pressurized, and the conditioned air is forced 
into the room, through perforated tiles, which then travels back to the air conditioner 
for reconditioning. The airflow patterns and design associated with a typical computer 
room air handler have a much higher rate of air change than typical comfort cooling 
air conditioners so air is filtered much more often than in an office environment. 



Positive Pressurization and Ventilation

Controlling Contaminants C-7

Proper filtration can capture a great deal of particulates. The filters installed in the 
in-room, re-circulating air conditioners should have a minimum efficiency of 40% 
(Atmospheric Dust-Spot Efficiency, ASHRAE Standard 52.1). Low-grade pre-filters 
should be installed to help prolong the life of the more expensive primary filters.

Any air being introduced into the computer room controlled zone, for ventilation or 
positive pressurization, should first pass through high efficiency filtration. Ideally, air 
from sources outside the building should be filtered using High Efficiency Particulate 
Air (HEPA) filtration rated at 99.97% efficiency (DOP Efficiency MILSTD-282) or 
greater. The expensive high efficiency filters should be protected by multiple layers of 
pre-filters that are changed on a more frequent basis. Low-grade pre-filters, 20% 
ASHRAE atmospheric dust-spot efficiency, should be the primary line of defense. The 
next filter bank should consist of pleated or bag type filters with efficiencies between 
60% and 80% ASHRAE atmospheric dust-spot efficiency.

Low efficiency filters are almost totally ineffective at removing sub-micron particulates 
from the air. It is also important that the filters used are properly sized for the air 
handlers. Gaps around the filter panels can allow air to bypass the filter as it passes 
through the air conditioner. Any gaps or openings should be filled using appropriate 
materials, such as stainless steel panels or custom filter assemblies.

Positive Pressurization and Ventilation
A designed introduction of air from outside the computer room system will be 
necessary in order to accommodate positive pressurization and ventilation 
requirements. The data center should be designed to achieve positive pressurization in 
relation to more loosely controlled surrounding areas. Positive pressurization of the 
more sensitive areas is an effective means of controlling contaminant infiltration 
through any minor breaches in the room perimeter. Positive pressure systems are 
designed to apply outward air forces to doorways and other access points within the 
data processing center in order to minimize contaminant infiltration of the computer 
room. Only a minimal amount of air should be introduced into the controlled 
environment. In data centers with multiple rooms, the most sensitive areas should be 
the most highly pressurized. It is, however, extremely important that the air being 
used to positively pressurize the room does not adversely affect the environmental 
conditions in the room. It is essential that any air introduction from outside the 
computer room is adequately filtered and conditioned to ensure that it is within 
acceptable parameters. These parameters can be looser than the goal conditions for the 
room since the air introduction should be minimal. A precise determination of 
acceptable limits should be based on the amount of air being introduced and the 
potential impact on the environment of the data center.

Because a closed-loop, re-circulating air conditioning system is used in most data 
centers, it will be necessary to introduce a minimal amount of air to meet the 

Dust spot efficiency 
%

Fractional 
Efficiencies % for: 
3.0 micron

Fractional 
Efficiencies % for: 
1.0 micron

Fractional 
Efficiencies % for: 
3.0 micron

25-30 80 20 <5

60-65 93 50 20

80-85 99 90 50

90 >99 92 60

DOP 95 -- >99 95
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ventilation requirements of the room occupants. Data center areas normally have a 
very low human population density; thus the air required for ventilation will be 
minimal. In most cases, the air needed to achieve positive pressurization will likely 
exceed that needed to accommodate the room occupants. Normally, outside air 
quantities of less than 5% make-up air should be sufficient (ASHRAE Handbook: 
Applications, Chapter 17). A volume of 15 CFM outside air per occupant or 
workstation should sufficiently accommodate the ventilation needs of the room.

Cleaning Procedures and Equipment
Even a perfectly designed data center requires continued maintenance. Data centers 
containing design flaws or compromises may require extensive efforts to maintain 
conditions within desired limits. Hardware performance is an important factor 
contributing to the need for a high level of cleanliness in the data center.

Operator awareness is another consideration. Maintaining a fairly high level of 
cleanliness will raise the level of occupant awareness with respect to special 
requirements and restrictions while in the data center. Occupants or visitors to the data 
center will hold the controlled environment in high regard and are more likely to act 
appropriately. Any environment that is maintained to a fairly high level of cleanliness 
and is kept in a neat and well organized fashion will also command respect from the 
room's inhabitants and visitors. When potential clients visit the room they will 
interpret the overall appearance of the room as a reflection of an overall commitment 
to excellence and quality. An effective cleaning schedule must consist of specially 
designed short-term and long-term actions. These can be summarized as follows:

Daily Tasks
This statement of work focuses on the removal of each day's discarded trash and 
rubbish from the room. In addition, daily floor vacuuming may be required in Print 
Rooms or rooms with a considerable amount of operator activity.

Weekly Tasks
This statement of work focuses on the maintenance of the access floor system. During 
the week, the access floor becomes soiled with dust accumulations and blemishes. The 
entire access floor should be vacuumed and damp mopped. All vacuums used in the 
data center, for any purpose, should be equipped with High Efficiency Particulate Air 
(HEPA) filtration. Inadequately filtered equipment cannot arrest smaller particles, but 
rather simply agitates them, degrading the environment they were meant to improve. 
It is also important that mop-heads and dust wipes are of appropriate non-shedding 
designs.

Table C–1 Frequency of Actions

Frequency Task

Daily Actions Rubbish removal

Weekly Actions Access floor maintenance (vacuum and damp mop)

Quarterly Actions Hardware decontamination

Room surface decontamination

Bi-Annual Actions Subfloor void decontamination

Air conditioner decontamination (as necessary)
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Cleaning solutions used within the data center must not pose a threat to the hardware. 
Solutions that could potentially damage hardware include products that are:

■ Ammoniated

■ Chlorine-based

■ Phosphate-based

■ Bleach enriched

■ Petro-chemical based

■ Floor strippers or re-conditioners

It is also important that the recommended concentrations are used, as even an 
appropriate agent in an inappropriate concentration can be potentially damaging. The 
solution should be maintained in good condition throughout the project, and excessive 
applications should be avoided.

Quarterly Tasks
The quarterly statement of work involves a much more detailed and comprehensive 
decontamination schedule and should only be conducted by experienced computer 
room contamination-control professionals. These actions should be performed three to 
four times per year, based on the levels of activity and contamination present. All 
room surfaces should be thoroughly decontaminated including cupboards, ledges, 
racks, shelves and support equipment. High ledges and light fixtures and generally 
accessible areas should be treated or vacuumed as appropriate. Vertical surfaces 
including windows, glass partitions, doors, etc. should be thoroughly treated. Special 
dust cloths that are impregnated with a particle absorbent material are to be used in 
the surface decontamination process. Do not use generic dust rags or fabric cloths to 
perform these activities. Do not use any chemicals, waxes or solvents during these 
activities.

Settled contamination should be removed from all exterior hardware surfaces 
including horizontal and vertical surfaces. The unit's air inlet and outlet grilles should 
be treated as well. Do not wipe the unit's control surfaces as these areas can be 
decontaminated by the use of lightly compressed air. Special care should also be taken 
when cleaning keyboards and life-safety controls. Specially treated dust wipes should 
be used to treat all hardware surfaces. Monitors should be treated with optical 
cleansers and static-free cloths. No Electro-Static Discharge (ESD) dissipative 
chemicals should be used on the computer hardware, since these agents are caustic 
and harmful to most sensitive hardware. The computer hardware is sufficiently 
designed to permit electrostatic dissipation thus no further treatments are required. 
After all of the hardware and room surfaces have been thoroughly decontaminated, 
the access floor should be HEPA vacuumed and damp mopped as detailed in the 
Weekly Actions.

Bi-Annual Tasks
The subfloor void should be decontaminated every 18 months to 24 months based on 
the conditions of the plenum surfaces and the degree of contaminant accumulation. 
Over the course of the year, the subfloor void undergoes a considerable amount of 
activity that creates new contamination accumulations. Although the weekly above 
floor cleaning activities will greatly reduce the subfloor dust accumulations, a certain 
amount of surface dirt will migrate into the subfloor void. It is important to maintain 
the subfloor to a high degree of cleanliness since this area acts as the hardware's 
supply air plenum. It is best to perform the subfloor decontamination treatment in a 
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short time frame to reduce cross contamination. The personnel performing this 
operation should be fully trained to assess cable connectivity and priority. Each 
exposed area of the subfloor void should be individually inspected and assessed for 
possible cable handling and movement. All twist-in and plug-in connections should be 
checked and fully engaged before cable movement. All subfloor activities must be 
conducted with proper consideration for air distribution and floor loading. In an effort 
to maintain access floor integrity and proper psychrometric conditions, the number of 
floor tiles removed from the floor system should be carefully managed. In most cases, 
each work crew should have no more than 24 square feet (six tiles) of open access 
flooring at any one time. The access floor's supporting grid system should also be 
thoroughly decontaminated, first by vacuuming the loose debris and then by 
damp-sponging the accumulated residue. Rubber gaskets, if present, as the metal 
framework that makes up the grid system should be removed from the grid work and 
cleaned with a damp sponge as well. Any unusual conditions, such as damaged floor 
suspension, floor tiles, cables and surfaces, within the floor void should be noted and 
reported.

Activity and Processes
Isolation of the data center is an integral factor in maintaining appropriate conditions. 
All unnecessary activity should be avoided in the data center, and access should be 
limited to necessary personnel only. Periodic activity, such as tours, should be limited, 
and traffic should be restricted to away from the hardware so as to avoid accidental 
contact. All personnel working in the room, including temporary employees and 
janitorial personnel, should be trained in the most basic sensitivities of the hardware 
so as to avoid unnecessary exposure. The controlled areas of the data center should be 
thoroughly isolated from contaminant producing activities. Ideally, print rooms, check 
sorting rooms, command centers or other areas with high levels of mechanical or 
human activity should have no direct exposure to the data center. Paths to and from 
these areas should not necessitate traffic through the main data center areas.
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2N

A PDU that supplies power to the redundant AC power grid and the third and fourth 
accessory racks. See also N+1 and 2N+1. 

2N+1

Two PDUs for AC redundancy. Each PDU has extra DC power supplies for N+1 
redundancy for each PDU. 

ACSLS

See Automated Cartridge System Library Software (ACSLS). 

ADI

Automation drive interface. 

AEM

See access expansion module. 

access expansion module

Essentially a very large CAP, with all the characteristics of a CAP, such as 
online/offline state, ability to be shared by partitions, etc. The cartridge slots in the 
AEM cannot be used for long-term cartridge storage. 

access door

A door on either side of the front facade through which service personnel can enter the 
library. Optional CAPs are attached to the right access door. 

activated capacity

The number of storage cells the library is activated to use. This cannot exceed the 
installed capacity. 

Automated Cartridge System Library Software (ACSLS)

An open systems software package that manages library contents and controls library 
hardware to mount and dismount cartridges on tape drives. This application also 
provides library management services such as cartridge tracking, pooling, reports, and 
library control. 

audit

An inventory of cartridge locations in all areas of the library, including the slots in the 
storage and reserved areas. Audits occur when: 
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■ The library initializes at power-on. 

■ After either one or both access doors are opened and closed without activating the 
service safety door. 

■ A physical audit request is made through SL Console. 

Also see host audit, physical audit, security audit, verified auditand virtual audit. 

base module 

Provides the entry level offering for an SL3000 library. Consists of a single frame and 
centralizes the infrastructure for all other modules in the library. This module includes 
the power supplies, robotic units, electronics control module, cartridge access port, 
storage slots, tape drives, and operator controls. 

bar code line scan camera 

A component of the robot that is used for cartridge identification and position 
calibration. 

bulk load 

Manually loading cartridges into the library, for example, during library installation. 

CAP 

See cartridge access port (CAP). 

CDS 

Control data set. 

CEM 

See cartridge expansion module. 

CLI 

Command line interface. 

capacity 

The storage capacity of the library. See also activated capacityand installed capacity. 

cartridge 

A container holding magnetic tape that can be processed without separating the tape 
from the container. The library uses data, diagnostic, and cleaning cartridges. 

cartridge access port (CAP) 

A bi-directional port built into the door panel of the library which provides for the 
manual entry or automatic ejection of data or cleaning cartridges. Same as 
import/export mail slot in SCSI and open system libraries. 

cartridge bias 

Left or right justification of a cartridge within a storage cell, CAP, or tape drive. 

cartridge expansion module 

An optional module for the library that provides additional cartridge slot capacity and 
growth. 
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cartridge proximity detector 

A component that determines if a cell is empty or contains an unlabeled cartridge 
during a label reading error recovery procedure. Same as empty cell detector. 

cell 

The location in the library in which a tape cartridge is stored. Same as slot. 

cell array 

An array that holds multiple cartridges when not in use. 

cleaning cartridge 

A tape cartridge that contains special material to clean the tape path in a transport or 
drive.cold swap 

To remove and replace a system component (typically one such as a logic board that 
has no redundant backup) after system operations have been stopped and system 
power has been disabled. Contrast with hot swap. 

control data set 

Data set used by the host software to control the functions of the automated library. 
Also called a library database. 

customer interface module 

The front module of the library at which you has access to the touch screen operator 
panel and service personnel have access to the library and service bay. 

DEM 

See drive expansion module (DEM). 

dWWN 

See dynamic WWN. 

data cartridge 

A term used to distinguish a cartridge onto which a tape drive may write data from a 
cartridge used for cleaning or diagnostic purposes. 

diagnostic cartridge 

A data cartridge used for diagnostic routines. 

data path 

The path where data is transferred between the host and tape drives. 

drive and electronics module 

The module in an library that houses the electronics control module, power 
distribution units (PDUs), power supplies, accessory racks and equipment, and tape 
drives for the library. 

drive array assembly 

An array that is installed in the drive and electronics module for mounting tape drive 
tray assemblies. The drive and electronics module holds up to four array assemblies, 
and each array holds up to 16 tape drive tray assemblies. 



drive bay

Glossary-4

drive bay 

A partitioned section of the tape drive array assembly that holds one tape drive tray 
assembly. 

drive bay address 

A two-digit integer (01–64) that represents the physical locations into which drive tray 
assemblies are inserted. 

drive expansion module (DEM) 

A module that allows further expansion of tape drives. 

drop-off cells 

Cells used to hold a cartridge in the event of a robot failure that occurs while a 
cartridge is in the robot hand. 

Dual TCP/IP 

Provides two separate host connections between the host software (ACSLS or HSC) 
and the library controller. 

dynamic WWN 

When enabled, dWWN assigns names to library drive slots rather than devices. When 
a drive is replaced, the new drive receives the same name as the one it replaced, 
thereby eliminating the need for system re-configuration. dWWN assigns names to 
individual tape drive slots rather than devices 

ECM 

See electronics control module. 

ELS 

See Enterprise Library Software. 

ESCON 

See Enterprise Systems Connection (ESCON). 

EPO 

See emergency power-off (EPO). 

eject 

See export. 

electronics control module 

A module that includes the HBK card, HBC/HBCR card and HBT card. The assembly 
that: 

■ Processes commands from a host system 

■ Coordinates the activities of robots, elevators, pass-thru ports, and tape drives 

■ Monitors status inputs from sensors and switches 

emergency power-off (EPO) 

(1) A safety scheme that allows a power down of a subsystem or a system as a whole 
instead of powering it down component-by-component. 
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(2) A safety switch on a machine or in a data center that allows a user to immediately 
power down a machine or a data center power supply by cutting off the external 
source power. 

enter 

See import. 

Enterprise Library Software 

The software products that automate tape operations for mainframe users. 

Enterprise Systems Connection (ESCON) 

An optical fiber serial interface which supports half duplex data transfers. 

environmental monitors 

A collective term for the sensors that track temperatures, fan speeds, and the status of 
various other mechanism within a library. 

Ethernet 

A local-area, packet-switched network technology. Ethernet is a 10- or 
100-megabytes-per-second LAN. 

export 

The action in which the library places a cartridge into the cartridge access port so that 
the operator can remove the cartridge from the library. Same as eject. 

FCP 

See Fiber Channel Protocol (FCP). 

FICON 

See fibre connection (FICON). 

FRU 

Field replaceable unit. 

failover 

The act of moving to a secondary or redundant path when the primary path fails. Also, 
in ACSLS HA, failing over to the standby (alternate) ACSLS server. 

Fibre Channel 

A bidirectional, full-duplex, point-to-point, serial data channel structured for high 
performance capacity. The Fibre Channel is an interconnection of multiple 
communication ports, called N_Ports. These N_Ports are interconnected by a 
switching network, called a fabric, to a point-to-point link, or an arbitrated loop. Fibre 
Channel is a generalized transport mechanism with no protocol of its own. A Fibre 
Channel does not have a native input/output command set, but can transport existing 
Upper Level Protocols (ULP) such as SCSI and IPI. Fibre Channel operates at speeds of 
100 MB per second (full speed), 50 MB per second (half speed), 25 MB (quarter speed), 
or 12.5 MB (eighth speed). Fibre Channel operates over distances of up to 100 m over 
copper media or up to 10 km over optical links. 

Fiber Channel Protocol (FCP) 

A transport protocol (similar to TCP used in IP networks) which predominantly 
transports SCSI commands over Fibre Channel networks. 
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fibre connection (FICON) 

An IBM FC 4 protocol that extends the capabilities of ESCON. Used to map either 
ESCON or parallel channel-to-control-unit cabling infrastructure and protocol onto 
standard FC services and infrastructure.S/390-based channel architecture that 
provides up to 256 channels in a single connection, each having a capacity of 100 MB 
per second. 

front controller module 

The module that houses the controller for the elevators, CAPs, turntables, and safety 
barrier. 

front facade 

The external portion of the customer interface module, between the access doors, that 
holds the: 

■ Membrane keypad 

■ Product logos 

■ Optional touch screen operator control panel 

get 

An activity in which a robot obtains a cartridge from a cell or drive. 

gripper 

(1) The portion of the hand assembly that grasps the cartridge. (2) The part of the hand 
assembly that grasps and holds a cartridge during transport. 

HLI/PRC 

Host Library Interface/Panel Row Column 

hand assembly 

A part of the library robot whose function is to grasp cartridges and move them 
between storage cells and drives. A camera on the hand assembly reads cartridge 
volume labels. 

host audit 

The process of updating the cartridge vol-ids and locations (collected by a security 
audit) in a host CDS. This audit is initiated by a host command. 

hot swap 

Removal and replacement of a system component while system power remains on and 
system operations continue. Contrast with cold swap. Contrast with hot-pluggable. Same 
as online servicing. 

hot-pluggable 

The capability that allows an Oracle service representative to replace a system 
component while power to the system is maintained. This feature allows hardware 
maintenance actions and hardware upgrades to proceed without disrupting subsystem 
availability. Contrast with hot swap. 

import 

The process of placing a cartridge into the cartridge access port so that the library can 
insert it into a storage cell. 
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installed capacity 

The number of storage cells physically present in the library. 

interlock switch 

A switch that disconnects power to library mechanisms, excluding tape drives, when 
the front door is opened. 

keypad interface 

See membrane keypad. 

LCM 

See Library Content Manager (LCM). 

LTO 

See linear tape open format (LTO). 

LUN 

See logical unit number. 

library controller (LC) 

The HBC/HBCR card within the library that controls operations and communicates 
with the operator panel. 

Library Content Manager (LCM) 

Software that provides content management for mainframe automated tape 
environments. Works in conjunction with host software component, virtual storage 
manager and your tape management system. 

library operator panel 

See touch screen operator control panel. 

linear tape open format (LTO) 

A set of tape data format standards created to enable data interchange among different 
LTO Ultrium tape drive vendors. These standards allow data cartridges to be shared. 

logical library 

A virtual representation of a physical library. Same as virtual library partition. 

logical unit number 

A unique identifier for a physical storage allocation. A LUN could reference an entire 
RAID set, a single hard disk or partition, or multiple disks or partitions. Unlike a 
physical LUN, the virtual LUN does not map to a specific device or allocation of 
storage space but a virtualized space that can be created in excess of the actual 
physical space available. 

magazine 

A removable array that holds cartridges and is placed into the cartridge access port 
(CAP). 

membrane keypad 

A keypad mounted on the front facade used to monitor the status of the library and to 
operate the CAPs. 
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N+1 

A power configuration that provides AC power and redundant DC power by adding a 
second DC power supply to each DC bus. See also 2N. 

online replacement 

Replacement or service of a module while the library remains operational. The service 
person may be required to power off the module before removing or replacing it. Same 
as hot swap. 

operator panel 

See touch screen operator control panel. 

orphaned cartridge 

A cartridge in a partitioned library that is located in an unallocated cell or drive (that 
is, a cell or drive not allocated to any defined partition). Cartridges may become 
orphaned when partition boundaries are changed, partitions are deleted, or cartridges 
are manually moved to unallocated or inaccessible cells. 

PDU 

See power distribution unit (PDU). 

PEM 

See power distribution unit (PDU). 

PLI 

See primary library interface (PLI). 

parking expansion module 

An additional module available for the SL3000 library that allows a redundant robot to 
be parked in it. 

physical audit 

Physical audits occur when the robots: 

■ Scan the cartridge locations in the library 

■ Verify the volumes 

■ Update the library control card inventory 

■ Set the status of the cartridge location to true 

physical library 

A physically present library as opposed to a logical library. 

power distribution unit (PDU) 

A device for the distribution of AC line power from one inlet to multiple outlets. 
Multiple PDUs provide higher availability because the power continues if one PDU (or 
its alternating current source if the PDUs use separate AC sources) loses power. 

primary library interface (PLI) 

The communication path between the operator panel and the library controller. 

put 

An activity in which a robot places a cartridge into a cell or drive. 
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RE 

See Redundant Electronics (RE). 

RTD 

See real tape drive (RTD). 

rail 

(1) That portion of the upper robot track assembly that provides power and 
communication to the robot. (2) All of the cartridge slots and drives accessible through 
a rail. 

rail assembly 

The mechanism on which the robot travels between cartridge arrays and tape drives. 

reach mechanism 

A component of the robot that moves the gripper to get or put a cartridge at a 
designated location. 

real tape drive (RTD) 

The physical transport attached to the LSM. The transport has a data path to a VTSS 
and may also have a data path to MVS or to another VTSS. 

Redundant Electronics (RE) 

A feature that provides failover protection in enterprise libraries. RE uses a two sets of 
library controller cards. At any given time, one set is active and the other set is 
standby. The active library controller can failover to the standby in response to a 
command from ACSLS or the SL Console. Automatic failover can be initiated by the 
library in the event of a library card failure. 

remote operator console 

The customer's operator panel that interfaces with the PLI. See also security software 
layer. 

robot 

A mechanism that moves horizontally along a track to transport tape cartridges to and 
from other locations in the library. 

SSL 

See Secure Sockets Layer (SSL). 

security audit 

The process of reading and storing in library memory the vol-ids and locations of all 
cartridges in the library. See also host audit. 

Secure Sockets Layer (SSL) 

A cryptographic protocol that provides communication security. The communication 
path between the PLI and the remote operator console occurs through SSL. 

service area 

An area between the access doors of the customer interface module and the safety 
barrier. In the service area, a redundant or inoperable robot can be stored for service 
and other mechanisms can be repaired or replaced. 
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service safety door 

A motor-driven barrier that lowers and raises. This door separates the service areas of 
the front interface assembly from the rest of the library. The SSD allows service 
personnel to safely repair or replace library mechanisms while the front access door is 
opened and closed., without interference with most library operations. 

slot 

Same as cell. 

TTI 

See tape transport interface (TTI). 

tape cartridge 

A container holding magnetic tape that can be processed without separating the tape 
from the container. The library uses data, diagnostic, and cleaning cartridges. These 
cartridges are not interchangeable. 

tape drive 

An electromechanical device that moves magnetic tape and includes mechanisms for 
writing and reading data to and from the tape. 

tape drive tray assembly 

The mechanical structure that houses a tape drive, fan assembly, power and logic 
cards, cables, and connectors for data and logic cables. Same as drive tray assembly. 

tape storage area 

The area in the library where cartridges are stored. 

tape transport interface (TTI) 

An interface to control and monitor tape movement. 

touch screen operator control panel 

A flat-panel display with a touch screen interface and a panel mount computer. This 
feature is attached to the front of the library. 

track 

The horizontal path upon which a robot travels. 

track drive mechanism 

The component that moves the robot along the track between the cell arrays, CAPs, 
and tape drives. 

vol-id 

Volume ID assigned to a cartridge. Same as VOLSER. 

VOLSER 

Volume serial number. Same as vol-id. 

VSM 

See virtual storage manager (VSM). 

VTCS 

See virtual tape control system (VTCS). 
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VTD 

See virtual tape drive (VTD). 

VTSS 

See virtual tape storage subsystem (VTSS). 

vacancy plate 

A plate that covers an unused bay, such as a drive bay or power supply bay. 

verified audit 

Verified audits are invoked from the SL Console and actually validate the status of a 
specific cartridge slot or range of slots. 

virtual audit 

Virtual audits are invoked from the SL Console and only display the cartridge 
inventory in the console screen (either local or remote). 

virtual storage manager (VSM) 

A storage solution that virtualizes volumes and transports in the buffer of a virtual 
tape storage subsystem to improve media and transport use. 

virtual tape control system (VTCS) 

The primary host code that controls activity and information about VTSSs, VTVs, 
RTDs, and MVCs. 

virtual tape drive (VTD) 

An emulation of a physical transport in the VTSS that looks like a physical tape 
transport to MVS. The data written to a VTD is really being written to DASD. The 
VTSS has 64 VTDs that do virtual mounts of VTVs. 

virtual tape storage subsystem (VTSS) 

The DASD buffer containing virtual volumes (VTVs) and virtual drives (VTDs). The 
VTSS is a STK RAID 6 hardware device with microcode that enables transport 
emulation. The RAID device can read and write tape data from/to disk, and can read 
and write the data from/to an RTD. 

virtual tape volume (VTV) 

A portion of the DASD buffer that appears to the operating system as a real tape 
volume. Data is written to and read from the VTV, and the VTV can be migrated to 
and recalled from real tape. 

WWN 

See World Wide Name. 

wrist 

A mechanism in the robot assembly that allows the robot to access the outer and inner 
storage walls. 

World Wide Name 

A 64-bit address that uniquely identifies each individual device and vendor, much like 
the MAC address of an Ethernet interface. Each port on a Fibre Channel network must 
have a its own WWN. The WWN is not just a physical hardware address. It also serves 
as the logical address of a node on the SAN. This means that the SAN configuration 
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changes if any of the attached hardware changes. If a device fails and is replaced, the 
WWN of the node changes, forcing reconfiguration of the SAN. There are three World 
wide Names reserved for each drive bay: Node, Port A, and Port B.
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A
access door

closing, 13-3
opening, 13-3
safety interlocks, 13-2
safety release, 13-2

activated capacity
active storage regions, 4-1

defining, 4-3
reports, 4-3

cell activation rules, 4-1
changes and FC-SCSI connections, 4-2
changes and HLI connections, 4-1
orphaned cartridges and, 4-2

activated features
display current, 3-3
install, 3-1

active storage regions
automatic assignment, 4-1
defining, 4-3
manual assignment, 4-1
reports, 4-3

addressing, A-1
AEMs internal firmware, A-16
CAPs HLI, A-16
CAPs internal firmware, A-15
FC-SCSI, A-6
HLI-PRC, A-4
internal firmware, A-2
tape drives, A-12

AEM
allocating to partitions, 5-1
associating to a partition, 5-8
emergency access, 13-4
library partitions and, 5-1
properties, 8-3
rebooting, 11-1
removing partition associations, 5-8
status, 8-3
summary information, 8-3
using to bulk load cartridges, 8-2
using to bulk unload cartridges, 8-2

AEM access door
audits and, 13-4
closing, 8-3

fast access, 13-4
AEM operations

summarized, 8-2
AEM safety door

properties, 8-3
status, 8-3

audits
audit indicator, 6-9
description, 6-9
full library, 6-9
main access door and, 6-9
physical, 6-9, 6-10
range of cells, 6-10
verified, 6-10

auto enter mode (CAPs)
described, 8-1

automated mode
returning the library to, 6-8

B
barcode presentation, 10-2

C
CAP associations

library partitions and, 5-3, 5-8
removing, 5-8

CAP reservations
library partitions and, 5-2
overriding, 5-8

capacity
activated. See activated capacity.

CAPs
and library partitions, 5-1
auto enter mode, 8-1
closing, 8-3
display properties, 8-3
display status, 8-3
display summary information, 8-3
inserting cartridges, 10-5
library partitions and, 5-1, 5-8
making available for diagnostic moves, 8-4
manual mode, 8-1
self-test, 8-4, 9-6
states
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library partitions and, 5-2, 5-3, 8-2
varying offline, 8-4
varying online, 8-4

cartridges
applying labels, 10-9
barcode presentation, 10-2
display information, 10-2
ejecting into a partition, 5-8
ejects, 10-6
entering into a partition, 5-8
enters, 10-5
exterior cleaning, 10-9
handling, 10-8
inserting in a cell or drive, 10-8
inserting in the CAP, 10-5
inspecting, 10-8
list, 10-2
loading through the AEM, 8-2
locate by address, 10-3
locate by VOLID, 10-3
locating by address, 10-3
locating by VOLID, 10-3
move by VOLID, 10-4
move from specified location, 10-4
recovery moves, 10-4
storing, 10-9
unlabeled, 10-1
unloading through the AEM, 8-2

cautions
reentering cleaning cartridge, 10-1
solvents for cleaning a cartridge, 10-9

CenterLine, A-1
cleaning cartridges, 10-1

exporting, 9-4
importing, 9-3
list, 9-2
warning threshold, 9-3

D
device status, 6-1

listing codes, 12-6
diagnostic cartridges

description, 10-7
exporting, 10-8
importing, 10-7
library self-tests and, 6-7
management tasks, 10-7

diagnostic moves (robot)
controlling, 11-6
defining, 11-4
description, 11-3
managing definitions, 11-5
monitoring, 11-6
pool address range, 11-4
random access order, 11-4
robot selection, 11-3
saving, 11-5
sequential access order, 11-4
starting, 11-6

target address range, 11-3
diagnostic support files, 12-1
diagnostics

CAPs and, 8-4
domain, media labels, 10-2
drive cleaning

configuring library auto clean, 9-3
description, 9-1
display status of, 9-4
exporting cleaning cartridges, 9-4
importing cleaning cartridges, 9-3
library auto clean, 9-1
manual, 9-2

drive controller, 6-4
Drive Events Report, 9-4
Drive Media Events Report, 9-4
drive trays

status, 9-4
drive VOP

displaying for T10000, 9-4
drives

bringing online, 9-5
cleaning. See drive cleaning.
display drive properties, 9-4
display drive summary information, 9-4
display status, 9-4
LED status, 9-4
network data, 9-4
SCSI FastLoad and, 11-2
states, 9-5
taking offline, 9-5

E
eject operations, 10-6

partitioned libraries, 5-8
enter operations, 10-5

partitioned libraries, 5-8
event monitors

description, 12-3
display, 12-5
display multiple, 12-5
spool data to a file, 12-5

F
FC-SCSI elements, A-6
FC-SCSI interface, 6-8

barcode presentation and, 10-2
FastLoad feature and, 11-2

G
General Events Statistics Report, 6-4

H
hardware activation file

comparing to current features, 3-2
delete, 3-3
description, 3-1
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display current, 3-3
displaying contents of, 3-2
download, 3-2
Feature Audit Log, 3-3
file type, 3-1
install, 3-2
installing, 3-1

hardware activation key file
overlaying, 3-1

hardware activation tasks, 3-1
HLI interface, 6-8

displaying port status, 6-3
HLI-PRC addressing, A-4
host interfaces

changing the type, 6-8
HLI. See HLI interface., 6-3
non-partitioned libraries and, 6-8

I
internal firmware addressing, A-2

K
key

maintenance, 13-1

L
library

placing in manual mode, 6-7
placing online, 6-8
returning to automated mode, 6-8

library auto clean, 9-1
library configuration

display, 6-4
library controller

display redundant electronics, 7-3
log in to alternate, 7-2
properties, 6-4

library events, 12-3
library events. See Also event monitors.
library firmware upgrades, 6-2

activate, 6-2
download, 6-2

library initialization sequence, 13-3
library partitions

AEM associations and, 5-8
allocating an AEM CAP, 5-1
barcode presentation and, 10-2
CAP associations and, 5-3, 5-8
CAP reservations and, 5-2, 5-8
CAP states and, 5-2, 5-3, 8-2
commit configuration changes, 5-7
configuration tasks, 5-4
create, 5-5
delete, 5-6
described, 5-1
design, 5-6
displaying, 4-3, 5-8
ejecting cartridges into, 5-8

entering cartridges into, 5-8
hosts and, 5-1
library hardware changes and, 5-4
library resources and, 5-4
orphaned cartridges in, 10-2
reports, 5-7
SCSI FastLoad feature and, 11-2
shared CAPs and, 5-3
using AEMs in, 5-1
using CAPs in, 5-1
using CAPs with, 5-1
verify, 5-7

library power down, 13-2
library power up, 13-3
library reboot, 6-7
library reports, 2-3

displaying, 6-4
saving data to a file,SL Console report tasks, 6-4
searching, 6-4

library self-tests, 6-6, 12-1
performing, 6-6

library status, 6-1
display, 6-3

local operator panel
described, 2-8
entering data, 2-8
factory alignment, 2-9
logging in, 2-8
re-calibrating, 2-9
virtual keypad, 2-8

log snapshot file
generating process, 6-6
transfer process, 6-6

login IDs, 2-4
logs

Feature Audit Log, 3-3

M
main access door

audits and, 6-9
maintenance key, 13-1
manual CAP, 8-1
manual cleaning (drive), 9-2
manual mode

placing the library in manual mode, 6-7
returning the library to automated mode, 6-8

manual operations
safety precautions, 13-1

access door interlocks, 13-2
access door release, 13-2
general, 13-1
server power interrupt, 13-2

media
domain labels, 10-2
ID labels, 10-2

MIB file
described, 12-1
transfer process, 6-5
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N
non-disruptive partitioning

FC-SCSI partitions and, 5-3
HLI partitions and, 5-2

O
orphaned cartridges

non-partitioned libraries and, 4-2
partitioned libraries and, 10-2

P
Pass-thru Ports (PTPs)

locating cartridges, 10-3
passwords

activation, 2-4
modifying, 2-4

placing the library in manual mode, 6-7
port bonding, 6-3
ports

status, 6-3
power down the library, 13-2
power supplies

monitoring tasks, 6-5
status of, 6-5
summary information, 6-5

power up the library, 13-3

R
reboot

library, 6-7
recovery moves, 10-4
redundant electronics

manual switch, 7-4
tasks, 7-3

reports
cartridge summary, 10-2
cartridge table, 10-2
drive events, 9-4
feature audit log, 3-3

result codes
listing, 12-6

returning the library to automated mode, 6-8
robot

display status of, 11-2
display summary information, 11-2
monitoring tasks, 11-2
properties, 11-2
SCSI FastLoad and, 11-2
self-test, 11-3
varying offline, 11-2
varying online, 11-2

S
safety precautions, 13-1

access door interlocks, 13-2
access door release, 13-2

general, 13-1
servo power interrupt, 13-2

SCSI FastLoad, 11-2
self-tests

CAP, 8-4
drive, 9-6
library, 6-6, 12-1
robot, 11-3

SL Console
activation password, 2-4
communications failures, 6-1
description, 2-1
first-time access, 2-4
logging off, 2-5
login ID, 2-4
modes, 2-1
modifying passwords, 2-4
screen, components, 2-2
screen, modifying layout, 2-3
security, 2-4
synchronize with library, 2-3
user ID, 2-4

SL Console Help
description, 2-3
navigation, 2-3

SL Console reports
Drive Events, 9-4
Drive Media Events, 9-4
General Events, 6-4
types, 2-4

SLConsole
downloading, 2-1
media pack, 2-1

SNMP
transfer the library MIB file, 6-5

standalone SL Console
description, 2-7
logging in, 2-8

standalone SLConsole
updating, 2-7

status
library and devices, 6-1

status alerts
clearing, 6-6
described, 6-4
displaying, 6-3

T
tape drives

addressing, A-12
hardware numbering, A-12
HLI-PRCs, A-14
internal firmware address, A-13

transferring the log snapshot file, 6-6
troubleshooting, 12-2

U
User ID
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types, 2-4

V
vary the library offline, 6-7
vary the library online, 6-8
VOP

displaying for T10000 drives, 9-4

W
Web-launched SL Console

client requirements, 2-5
description, 2-5
logging in using a browser, 2-6
logging in using an icon, 2-6
logging in using CLI, 2-6
security, 2-5
starting on a client, 2-6
updating on a client, 2-5

web-launched SLConsole
installing, 2-5



Index-6


	Contents
	Preface
	Documentation Accessibility
	Conventions

	Summary of Changes
	1 Introduction
	2 StorageTek Library Console
	SLConsole Modes
	Download the SLConsole Media Pack
	SLConsole Screen Display
	Modifying the Screen Layout
	Synchronizing the SL Console With the Controller Database
	Library Configuration Updates


	SLConsole Help
	SLConsole Reports
	Report Types

	User Management
	User IDs
	Passwords
	Change a User Password

	SLConsole Login
	Automatic Logout

	SLConsole Logoff

	Web-launched SLConsole
	Security Considerations
	Client Requirements
	Log in to the Web-launched SLConsole
	Log in to the Web-launched SLConsole Using an Icon

	Standalone SLConsole
	Security Considerations
	Installation Requirements
	Install the Standalone SLConsole
	Log in to the Standalone SLConsole

	Local Operator Panel
	Virtual Keypad
	Log in to the Local Operator Panel
	Touch Screen Calibration
	Re-calibrate the Local Operator Panel
	Reset the Local Operator Panel Calibration



	3 Hardware Activation Files
	Oracle Hardware Activation Files
	Legacy Hardware Activation Files

	Hardware Activation File Installation Overview
	Download a New Hardware Activation File
	Install a New Hardware Activation File on the Target Library
	Delete a Hardware Activation File
	Display Current Hardware Activation Files
	Display the Feature Audit Log

	4 Capacity Activation
	Configuring Active Capacity
	HLI Connections
	Adding Active Capacity
	Removing Active Capacity

	FC-SCSI Connections
	Orphaned Cartridges

	Capacity Icons in SLConsole
	Capacity Activation Tasks
	Modify Active Storage Regions
	Display Active Cells Report
	Display Active Cell Detail


	5 Library Partitioning
	Partitioning CAPs
	HLI Hosts
	Configuration Changes in HLI Partitions
	HLI CAP Reservations
	CAP Auto Enter Mode
	CAP States


	FC-SCSI Hosts
	Configuration Changes in FC-SCSI Partitions
	FC-SCSI CAP Associations
	CAP States


	Deleting the Partitioning Feature
	Hardware Changes to a Partitioned Library
	Partitioning Icons in SLConsole
	Library Partitioning
	Instructions Tab - Prepare for Partitioning
	Summary Tab - Add, Delete, or Modify a Partition
	Add a Partition
	Delete a Partition
	Modify a Partition

	Module Map & Design Tabs - Design a Partition
	Commit Tab - Confirm Partitioning Changes
	Reports Tab - Generate Partitioning Reports
	Current Partition Definitions Tab

	CAP Operational Tasks
	Enter/Eject Cartridges for FC-SCSI Partition with Shared CAP
	Override a CAP Reservation


	6 Library Management
	Library and Device Status
	Upgrade Library Firmware
	Download Code to the Library Controller
	Activate Code on the Library Controller

	Special Library Configuration Options
	Display Library Information
	Display Library Status
	Display Library Properties
	Library Reports
	Search a Library Report
	Save Library Report Data to a File
	Display Library Statistics Reports

	Display Library Power Supply Information

	Generate Library Diagnostic Files
	Transfer the Library MIB File
	Generate and Transfer the Library Log Snapshot File

	Clear Library Status Alerts
	Perform a Library Self-Test
	Reboot the Library
	Place the Library Online or Offline
	Place the Library Offline
	Bring the Library Online
	Bring the Drives Online

	Change the Library Interface Type (Non-Partitioned Libraries)
	Audits
	Physical Audit
	Audit the Entire Library
	Audit a Range of Cells

	Verified Audit


	7 Redundant Electronics
	Requirements
	Redundant Electronics Overview
	Automatic Failover
	Manual Failover
	Connections
	Firmware Upgrades

	Controller Card Status
	LEDs
	SLConsole Status

	Display Redundant Electronics Information
	Manual Redundant Electronics Switch

	8 CAP Management
	CAP Modes and States
	CAP States

	CAP Priorities for FC-SCSI Hosts
	AEM Operations
	Display CAP and AEM Safety Door Information
	Display CAP Status and Properties
	Display AEM Safety Door Status and Properties

	Lock/Unlock a CAP or AEM
	Change the CAP Assignment Mode for an FC-SCSI Library
	Perform CAP Self-Test
	Change CAP Online/Offline Status

	9 Drive Management
	Drive Cleaning
	Host-Managed Cleaning
	Library Auto Clean
	Manual Cleaning
	Display Cleaning Cartridges
	Configure Library Auto Clean
	Define Warning Thresholds (Library Auto Clean Only)
	Import/Export Cleaning Cartridges (Library Auto Clean Only)
	Import Cleaning Cartridges
	Export Cleaning Cartridges


	Display Drive Information
	Display the Drive and Drive Media Reports
	Configure the Drive Tray Serial Numbers
	Change a Drive Online/Offline Status
	Perform a Drive Self-Test

	10 Cartridge Management
	Cartridge Types
	Cartridge Labels
	Configure Cartridge Barcode Presentation (FC-SCSI only)

	Resolving Orphaned Cartridges
	Display Cartridge Information
	Locating Cartridges
	Locate a Cartridge by vol-id
	Locate a Cartridge by Address

	Moving Cartridges (Recovery Moves)
	Move a Cartridge by Vol-id or Specified Location

	Entering Cartridges
	Ejecting Cartridges
	Import/Export Diagnostic Cartridges
	Import Diagnostic Cartridges
	Export Diagnostic Cartridges

	Cartridge Handling
	Inspecting a Cartridge
	Cleaning the Cartridge Exterior
	Storing Cartridges
	Apply a Label to a Cartridge


	11 Robot and Safety Door Management
	AEM Safety Door Overview
	Reboot an AEM Safety Door

	TallBot Overview
	SCSI FastLoad Feature
	Configure SCSI FastLoad Feature


	Display Robot Information
	Change Robot Online/Offline Status
	Perform a Robot Self-Test
	Robot Diagnostic Moves
	Define a Diagnostic Move
	Manage Diagnostic Move Definitions
	Save a Diagnostic Move
	Start a Diagnostic Move
	Monitor and Control Open Diagnostic Moves


	12 SLConsole Diagnostics and Utilities
	Library and Device Self-Tests
	Diagnostic Support Information
	Troubleshooting
	Library Events
	Event Monitors
	Event Codes Reference
	Activity Code
	Result Code
	Severity
	Request Identifier


	Create an Event Monitor
	Display an Event Monitor
	Spool Event Monitor Data to a File
	Display Multiple Monitors

	Display Device Status or Result Code

	13 Manual Operations
	Modes of Operation
	Safety Precautions when Entering the Library
	Door Interlocks
	Servo Power Interrupt
	Mechanical Door Releases

	Powering the Library On or Off
	Power Off the Library
	Power On the Library

	Accessing the Main Door and AEM Door
	Open the Main Door
	Close and Lock the Main Door
	Open AEM Door for Emergency Access
	Close AEM Access Door


	A Library Addressing
	CenterLine
	Internal Firmware
	HLI-PRC
	Tape Drives and CAPs

	FC-SCSI Element Numbering
	Default Capacity Assignment
	User Defined—Non-Partitioned Capacity Assignment
	User Defined—Partitioned Capacity Assignment
	Default SCSI Storage Element Numbering Scheme
	Default SCSI Data Transfer Element Numbering Scheme
	Element Numbering Examples
	Default Numbering
	User-Defined Numbering


	Comparison of Addressing Schemes
	Tape Drive Numbering
	Hardware Numbering
	Internal Firmware
	HLI-PRC

	Addressing of Components—CAPs and Robots
	Cartridge Access Ports - Internal Firmware
	Rotational CAPs
	AEM CAPs

	Cartridge Access Ports - HLI
	Rotational CAPs
	AEM CAPs

	Robots - Internal Firmware


	B Wall Diagrams
	Reserved System Slots
	Module Identification Block
	Special Labels

	Wall Diagrams

	C Controlling Contaminants
	Environmental Contaminants
	Required Air Quality Levels
	Contaminant Properties and Sources
	Operator Activity
	Hardware Movement
	Outside Air
	Stored Items
	Outside Influences
	Cleaning Activity

	Contaminant Effects
	Physical Interference
	Corrosive Failure
	Shorts
	Thermal Failure

	Room Conditions
	Exposure Points
	Filtration
	Positive Pressurization and Ventilation
	Cleaning Procedures and Equipment
	Daily Tasks
	Weekly Tasks
	Quarterly Tasks
	Bi-Annual Tasks

	Activity and Processes

	Glossary
	Index
	A
	B
	C
	D
	E
	F
	G
	H
	I
	K
	L
	M
	N
	O
	P
	R
	S
	T
	U
	V
	W


