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Summary of Changes

Current Version: E20869-04, August 2012
The following lists revisions in this edition:

• New troubleshooting report, the Device Reserve Table beginning with SL Console 
5.8 and FRS_8.0 (see ”Device Reserve Table” on page 329)

• Visual indicator to indicate the progress (by device) of code as it loads beginning 
with SL Console 5.8 and FRS_8.0 (see ”Activate Code on the Library 
Controller” on page 345)

• Automatic timeout of SL Console login after 6 hours beginning with SL Console 
5.8 and FRS_8.0 (see ”Automatic Logout” on page 21)

• Consolidated drive and library addressing appendices into Appendix A: Library 
Addressing (see ”Library Addressing” on page 431)

• Edited the chapter on activated capacity for clarity (see ”Capacity on 
Demand” on page 69)

• Updated chapter on contaminants to include warning regarding use of chlorine 
and other chemicals (see ”Controlling Contaminants” on page 459)

Revision History
The following lists all previous editions:

• Revision E20869-03, April 2012: Update made to mention use of the CLI by 
customers using StorageTek Tape Analytics.

• Revision E20869-02, March 2012: Updates were made to support versions 
FRS_7.70 and SL Console 5.70. The new features are:

• Generate Log Snapshot.

• Audit Indicator for the StorageTek Library Console.

• Previously optional equipment that is now standard for the SL8500:

• Local operator panel

• Web cameras

• Security door
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• CAP

• Additional updates not related to the new release include the following:

• Updates to the SLConsole Help, including instructions on saving favorite 
topics in Help. 

• Added SL Console password limitations from 5-8 characters as of SL 
Console  4.50.

• Added chapter on handling cartridges. 

• Incorprated the chapter “Configuring Non-Partitioned Libraries” into the 
chapter on capacity.

• Added a glossary.

• Added section on finding customer documentation. 

• Revision E20869-01, July 2011: This edition of Oracle’s StorageTek SL8500 Modular 
Library System User’s Guide receives a new Oracle document part number and 
revision number, E20869-01. Sun part number 96154 has been retired. Updates 
included:

• The Preface includes new support information.

• A revised and reorganized Chapter 1, “Introduction”, includes updated 
specifications and descriptions of new features.

• Chapter 3, “Capacity on Demand”, and Chapter 4, “Hardware Activation 
Files”, describe new capacity management features.

• Download procedures have been revised for the Oracle Software Delivery 
Cloud.   

• Chapter 6, “Library Partitioning”, explains major changes to this feature. 

• Chapter 11, “Drive Cleaning”, deletes obsolete information on automatic 
library cleaning. 

• A new Appendix E, “Controlling Contaminants”, explains the importance of 
minimizing airborne particulates and certain gases in areas where Oracle 
products are installed.

• Revision KB, June 2010

Sun document part number: 96154.

Former Chapter 3, “SL8500 Automated Library Operations”— Separated into the 
following chapters:

• Chapter 5, “Library Management”

• Chapter 7, “CAP Management”

• Chapter 8, “Drive Management”

• Chapter 9, “Cartridge Management”

• Chapter 10, “Drive Cleaning”

• Chapter 11, “Robot and Power Supply Management”

• Chapter 12, “Elevator and Pass-Thru-Port Management” 
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• Revision KA, November 2007: Sun document part number: 96154.

Added information regarding the optional Web-launched SLC feature.

• March 2007 (96154 K): Sun document part number: 96154. EC 114189. Updated for 
library partitioning feature. 

• August 2006 (96154 J): Sun document part number: 96154. EC114164 updates:

• Modified the safety information for Emergency Robotics Stop Switches and 
Smoke Detection.

• Included a section on Fire Suppression.

• Updated the host-to-library communication information to include the dual 
TCP/IP feature. 

• Updated trap notification information. 

• Older Revisions

• May 2006 (96154 H), EC114146

• September 2005 (96154 F), EC 114119

• May 2005, EC 111974

• February 2005, EC 111959

• November 2004, EC 111945

• July 2004EC 111920

• May 2004 (Initial release), EC 111906
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Preface

This book is about Oracle’s StorageTek SL8500 modular library system hardware, 
StorageTek Library Console management software, and related operations. For 
specific drive information or for client application software commands, see the 
appropriate drive or software documentation. 

Audience
This guide is intended primarily for administrators and operators of Oracle’s 
StorageTek SL8500 modular library system. It can also be used by Oracle partners 
and support representatives. 

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/support/contact.html or visit 
http://www.oracle.com/accessibility/support.html if you are hearing impaired.

Obtaining Customer Documentation
To access current product documentation for Tape Storage:

1. Use Web browser to go to the following Web page: 
http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html

The Tape Storage Products page opens.

2. Find the appropriate section and its list of products.

3. To view a list of documents for a product, click “View Library.”

A new page opens with a listing of all documents related to the product.

4. To download the entire suite of documents for the product, click “Download.”.

A compressed archive file will download that contains the entire suite of documents 
for that product.

5. To download a compressed archive file that contains the entire suite of documents, 
click the “Download” link.

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
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1

Introduction

The SL8500 is a highly scalable, high-performance, high-density, high-availability 
enterprise storage solution that provides fully automated tape-cartridge storage and 
retrieval. It is ideal for long-term data retention, archive, backup, heterogeneous data 
consolidation, and mission-critical or highly technical computing applications, 
particularly in high data growth environments and where multi-generational media 
support is essential. 

SL8500 Features
The SL8500 features include:

• RealTime Growth with Capacity on Demand (see “Capacity on 
Demand” on page 69)

• High-availability options, such as redundant robots and electronic components 
(see “Improved Performance” on page 10 and “Redundant Electronics 
Management” on page 205 on page 205 for more information)

• Ease of management with standalone and web-launched versions of  StorageTek 
Library Console (SLC) software (see “StorageTek Library Console” on page 19)

• Optional library partitioning (see “Library Partitioning” on page 123 for details) 

• Library cameras that enable you to view the inside of the SL8500 library remotely 
via an Ethernet connection and monitoring software (see “Library 
Cameras” on page 10)

• Support for multiple platforms and operating environments
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Component Views and Locations
An SL8500 library is assembled from modules, with drives and storage cells arranged 
along four rails on the inner and outer walls of the module. Robots move along each 
rail carrying cartridges between drives, storage cells, and cartridge access ports 
(CAPs). The basic configuration includes the following elements:

• One Drive and Electronics Module (DEM) containing the control electronics for 
the library and 1 to 64 tape drives

• One Robotics Interface Module that supplies power and control for four or eight 
HandBots  and space for 800 cartridges

• One Customer Interface Module with:

• User interfaces: LED operator touch panel

• An Elevator for transferring cells between library rails

• A Cartridge Access Port (CAP) with room for 39 cartridges

• Space for 198 diagnostic and cleaning cartridges, 648 data cartridges, and 24 
targeting and drop-off cells

• One service safety door to separate an area of the library for service or a parked 
robot

• Library Cameras that enable you to view the inside of the SL8500 library remotely

The base library is 2.37 m (7.76 ft) tall, 1.7 m (5.6 ft) wide, and 2.76 m (9.1 ft) deep. 
The base configuration can be extend by adding the following optional equipment: 

• One to five Cartridge Expansion Modules, each with space for 1,728 cartridges

• A second CAP

• Redundant HandBots

FIGURE 1-1 and FIGURE 1-2 show a typical SL8500 library configuration: A base 
model with one Cartridge Expansion Module (CEM). 
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FIGURE 1-1  SL8500 Library with One Cartridge Expansion Module, Front/Side View

1. The Drive and Electronics Module at the rear of the library

2. The Robotics Interface Module

3. The Cartridge Expansion Module

4. CAPs A and B on the front, right door of the Customer Interface Module

5. The left front door of the Customer Interface Module

6. The Customer Interface Module at the front of the library.
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FIGURE 1-2  SL8500 Library with One Cartridge Expansion Module, Plan View 

1. “Cartridge Access Port (CAP)” on page 8 

2. Facade: May contain up to 2 operator panels (Keypad and the SLC - StorageTek 
Library Console).  
The two elevators are located behind the operator panels. 

3. Customer Interface Module (CIM)

4. Cartridge Expansion Module (CEM)

5. Robotics Interface Module (RIM)

6. Pass-thru Ports
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Tape Drives and Cartridges
The SL8500 library supports from 1 to 64 drives via fiber-optic interfaces. Supported 
interfaces include Fibre Channel, FICON (IBM Fiber Connectivity), and ESCON (IBM 
Enterprise Systems Connectivity).

Current Drives

The following table lists the vendors, drive types, interfaces, maximum throughputs, 
and native media capacity for the most currently supported drives. 

TABLE 1-1  Tape Drives Currently Supported

Vendor Drive Type Host Interface Type Throughput Media Capacity

StorageTek T10000C Fibre Channel, FICON 240 MB/s 5 TB

T10000B Fibre Channel, FICON 120 MB/s 1 TB

T9840D Fibre Channel, FICON 30 MB/s 75 GB

HP Linear Tape-Open (LTO) Gen-5 Fibre Channel 140 MB/s 1.5 TB

Linear Tape-Open (LTO) Gen-4 Fibre Channel 120 MB/s 800 GB

IBM Linear Tape-Open (LTO) Gen-5 Fibre Channel 140 MB/s 1.5 TB

Linear Tape-Open (LTO) Gen-4 Fibre Channel 120 MB/s 800 GB

Older Drives

Older supported drives are listed below by vendor, drive type, and supported 
interfaces. 

TABLE 1-2  Older Tape Drives Currently Supported

Vendor Drive Type Host Interface Type 

StorageTek T10000A Fibre Channel, FICON

T9840C Fibre Channel, FICON, ESCON 

T9840B Fibre Channel, FICON, ESCON 

T9840A Fibre Channel, ESCON 

T9940B Fibre Channel, ESCON 

HP Linear Tape-Open (LTO 2, LTO 
3)

Fibre Channel 

IBM Linear Tape-Open (LTO 2, LTO 
3)

Fibre Channel 

Quantum SDLT-S3 Fibre Channel

Super DLT (SDLT600) Fibre Channel 
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Library Hardware Components
This section describes the following components:

• “Drive and Electronics Module” on page 6

• “Robotics Interface Module” on page 7

• “Customer Interface Module” on page 7

• “Cartridge Expansion Modules” on page 8

• “Library Storage Modules (LSMs)” on page 8

• “Cartridge Access Port (CAP)” on page 8

• “Robotic System” on page 9

• “Elevator” on page 9

• “HandBot” on page 9

• “Library Cameras” on page 10

• “Pass-Thru Ports” on page 10

• “Pass-Thru Ports” on page 10

Drive and Electronics Module

The Drive and Electronics Module contains the following components:

• 1 to 64 tape drives 

• Electronics Control Module (ECM)

• Pass-Thru Ports units and load-sharing power supplies for the tape drives and 
robotics 

• Accessory racks for networking components, servers, and the service delivery 
platform

Electronics Control Module (ECM)

The Electronics Control Module contains the control circuitry for the library.

The HBK card

The HBKT card maintains the configuration, firmware versioning, and feature-
activation information for the library for the library. 

Information is stored persistently in flash memory. The HBK card records the most 
recently activated firmware version and the previous version, so a service 
representative can roll back the firmware if needed. The card also records the library 
serial number (from the lower rear side of the Drive and Electronics Module) and the 
features that have been added to the library so that they can be correlated during 
feature activation. 
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The HBC/HBCR card: The Library Controller

The HBC/HBCR card coordinates all component operations within the library and 
provides the interface between the library and the host. It communicates with:

• Flash memory on the HBK card

• Ethernet hubs for the library-to-library and tape-drive service LANs

• TCP/IP Web host interface

• HBS cards on the robots

• Power, smoke, and environmental monitoring circuits throughout the library. 

HBC/HBCR cards operate on +3.3 VDC.

HBC/HBCR LED indicators and their meanings are:

• Active: Always lighted during operation

• Standby: Lighted when inactive

• Fault: Indicates the controller detected a fault

• Eject OK: Inactive

The HBT Card

The HBT card translates commands from the HBC/HBCR controller card into 
instructions which can be sent to the tape drives. 

HBT LED indicators and their meanings are:

• Active: Always lighted during operation

• Standby: Lighted when inactive

• Fault: Indicates the controller detected a fault

• Eject OK: Inactive

Robotics Interface Module

The Robotics Interface Module houses four robots (eight if redundant robots are 
installed) and storage cells for 800 data cartridges. Four robotic rail assemblies 
provide both power and communications for the robots.

Customer Interface Module

The Customer Interface Module hosts the button and indicator panel and the 
operator touch panel. It also holds the elevator that transfers cartridges between 
library rails, a Cartridge Access Port (CAP) with room for 39 cartridges, an optional 
second CAP, cells for 198 diagnostic and cleaning cartridges, 24 targeting and drop-
off cells, and cells for 648 data cartridges.
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Cartridge Expansion Modules

Cartridge Expansion Modules extend the basic configuration to accommodate more 
data cartridges. Each module adds 1728 storage cells to the library, and up to five 
modules may be added per library. Expansion modules are installed between the 
Robotics Interface Module and the Customer Interface Module.

Library Walls, Arrays, and Slots 

The library has two types of walls with arrays and slots that hold cartridges: 

• Inner walls: Consist of 14-slot arrays 

• Outer walls: Consist of 13-slot arrays with space for the robotic rails 

Cartridges are placed in slots and lie flat, hub-side down, parallel to the floor. To 
prevent slippage, cartridges are held within their slots by the cartridge retention 
feature. 

Library Storage Modules (LSMs)

After the modules of an SL8500 library are assembled, storage cells and tape drives 
are arranged along four rails, each with its own robotic assembly. Collectively, each 
unit is called a Library Storage Module (LSM). LSMs vary in length and capacity, 
depending on the expansion modules that are installed in the library. 

Cartridge Access Port (CAP)

Cartridge Access Ports (CAPs) are positioned on the right access door of the 
Customer Interface Module. When the library is operating in automated mode, 
operators can move cartridges in and out of the library through the CAPs. Each CAP 
can hold 39 cartridges. See “Library Partitioning” on page 123 for information on 
using the CAPs.

Doors for Access and Safety 

Whenever possible, do not open the front access doors. Opening a front access door 
on the SL8500 library can be a disruptive operation. 

Every SL8500 library has two front doors that contain safety interlock circuits. Unless 
the service safety door has been activated to block access to the library behind the 
access door, these interlock circuits remove all DC power to the HandBots, elevators, 
and pass-thru ports to protect operators from moving mechanisms. 

Note – Power to and operations of the tape drives remains 
unaffected. 

Activating the service safety door allows continued library operation. However, 
activating the service safety door blocks can block access to some components.

• If the service safety door is activated to the right side, it blocks access to the 
CAP(s).
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• The service safety door blocks access to the elevator on the same side as the 
service safety door. (There are two elevators in an SL8500, but blocking access to 
one of them reduces a library’s pass-thru capability.)

If an access door has been opened without the service safety door being activated, 
when the access door is closed, the HandBots and other mechanisms automatically 
go through an initialization process that takes about five minutes. During this time, 
the SL8500 is offline and library operations are stopped. 

Robotic System

Robots move cartridges between storage slots, tape drives, and the CAPs. 

Major components of the robotic system include: 

• Four separate robotic rail assemblies. These rail assemblies provide both power 
and communications to their own individual robotic system(s). 

• One HandBot on rail assembly (or two per rail assembly for redundancy). 
HandBots can service tape drives and all of the tape cartridges for that rail. The 
SL8500 library can have either one or two HandBots per rail. 

• Two elevator are vertically adjacent to the four rail assemblies. These elevators 
perform an internal pass-thru operation that allows cartridges to move between 
rails. 

Elevator

Elevators provide vertical operations between rails within the same library. The 
SL8500 library features two elevators that provide vertical pass-thru operations 
between library storage modules within the same library. 

Both elevators are located in the front of the library between the front access doors 
and the sliding safety door. Each of the four library storage modules share the 
resources of the two elevators. There is one elevator on the left and one elevator on 
the right that are located in the front of the library between the front access doors and 
the service safety door. 

HandBot

The robotic system in an SL8500 library consists of four HandBots (or eight for 
redundancy) controlled by the Library Control Card. HandBots are shared by the 
library and include a:

• Z-mechanism for vertical motion

• Wrist mechanism for lateral or horizontal motion

• Bar-code scanner for targeting and reading cartridge labels

• Proximity sensor for detecting empty slots and unlabeled cartridges

• Gripper mechanism for grasping cartridges
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Improved Performance

HandBots work in parallel to achieve an increase in throughput (or cartridge 
exchange rates) by allowing each robot to operate independently. The library can 
service multiple mount requests at the same time. 

A single SL8500 rail section can accommodate two HandBots to enable greater speed 
and efficency. Additionally, another robot provides continuous operation should the 
other robot fail.

To optimize system performance, the robots automatically implement FastLoad. With 
the FastLoad feature, after a HandBot successfully inserts a cartridge into a drive, it is 
immediately available for the next request. The HandBot does not wait until the drive 
reports that the cartridge has been loaded. The SL8500 library controller does not 
return the response to the mount request until it detects that the tape drive has 
successfully loaded the cartridge.

Library Cameras

Library cameras enable you to view library operations remotely via an Ethernet Local 
Area Network (LAN). Two cameras mount on the upper frame of the front access 
door, one on each side of the library. With monitoring software, you can view the 
output on a network host.

Pass-Thru Ports

To create a library complex consisting of more than one SL8500 library, pass-thru 
ports (PTPs) join libraries together. A PTP consists of a metal frame installed between 
two libraries. The frame  contains four robotic mechanisms, one for each rail level. 
These PTP mechanisms move cartridges from a reserved PTP slot in one library to a 
reserved slot in another library. The robot of the library receiving the cartridge then 
travels to the reserved PTP slot to obtain the cartridge. 

All SL8500 libraries come equipped and ready for PTP frames. ACSLS and ELS 
applications fully support PTP operations.

PTPs and Library Terms

When SL8500 PTPs are configured:

• The home library (the library on the right when viewed from the front) provides 
power, signal, and control lines to the PTP mechanisms. 

• The away library (to the left of the home library) exchanges cartridges with the 
home library via the PTPs. 

• The source library contains the home cell for a cartridge that is passed through a 
PTP.

• The destination library contains the tape drive or storage cell where the cartridge 
is mounted or stored. 

Library Configurations and Capacities
• The Base Library Configuration
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• Expanded Library Configurations 

• Library Complexes

The Base Library Configuration

The basic SL8500 library configuration can store up to 1,448 data cartridges, exclusive 
of cartridges stored in the following locations:

• The cartridge access ports (CAPs)

• The reserved slots (a total of 198 slots in the Customer Interface Module are 
dedicated to diagnostic and cleaning cartridges)

• The eight drop-off slots that are used if there is a robotics failure when a robot still 
has a cartridge in hand

• Slots specifically reserved for pass-thru ports

Expanded Library Configurations

To expand the capacity of the base library, you can add Cartridge Expansion 
Modules. Each SL8500 cartridge expansion module increases the base capacity by 
1728 storage cells.

See “Cartridge Slot Locations” on page 431 for information on reserved slots and 
cartridge addresses.

Library Complexes

When required, you can combine multiple libraries to form a library complex. In a 
library complex, libraries are connected by pass-thru ports (PTPs). A pass-thru port 
enables one  SL8500 library to exchange cartridges with another.

In a complex, each library can access any cartridge in the complex. In effect, the 
complex becomes a larger single library. For example, if a host issues a mount request 
for a cartridge in a given library and all the tape drives are busy in that library, the 
PTP can pass the cartridge to a library that has an idle tape drive.

Operating Firmware
SL8500 firmware resides on the HBC library controller card. The HBC/HBCR card 
can hold up to two firmware versions. When firmware is upgraded, the earlier image 
of remains in memory and may be restored if required. 

The firmware supports automatic discovery of tape drives, automatic discovery of 
new cartridge slots and added libraries, and automatic handling of dynamic World 
Wide Name (dWWN) assignments (See “Dynamic World Wide Names 
(dWWNs)” on page 13).

Library Interfaces and Controls
This section introduces the host, library management, and service interfaces to the 
SL8500 modular library.
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• “Host Interfaces”

• “Management and Service Interfaces” on page 14

Host Interfaces

Host systems and tape libraries exchange two distinct kinds of information:

• Library command-and-control information: A library control application 
(StorageTek ACLS or ELS) runs on the host and sends instructions that position 
robotics, mount and unmount volumes, clean drives, and query the status of 
components. The library returns the results of commands and queries to the 
software. 

• User/application data: A data backup, archiving, or management application 
(NetBackup, Tivoli, SAM-QFS, etc.) runs on the host and transfers user and 
application data to and from file systems and tape media mounted on tape drives 
in the library.

In the SL8500 library, commands and data travel over separate host interfaces, via a 
Library Control Path and a Data Path.

Library Control Path

The host exchanges command-and-control information with the SL8500 library over 
the Ethernet LAN (local area network) using TCP/IP. The physical interface between 
your Local Area Network (LAN) and the library is located on the library controller 
(the HBC/HBCR card), in the middle of the face plate. There are two separate ports 
for host-to-library communications: 2B and 2A. 

• Port 2B provides the standard, primary connection for host communications on 
SL8500 libraries.

• Port 2A provides the optional Dual TCP/IP host connection. Ports 1A and 1B are 
reserved for interlibrary communications when pass-thru ports are configured.

Oracle recommends a private network connection to an Ethernet hub or switch for 
maximum throughput and minimum resource contention.

Routing

The SL8500 library supports static routing only. Administrators must manually edit 
the routing tables to include a fixed path between the host and the library. Dynamic 
routing is not supported.

Dual TCP/IP 

Starting with firmware release FRS_3.08, SL8500 libraries can support two 
independent network paths between the host’s library management software (ACSLS 
or ELS) and the library controller. When both paths are available, the host software 
uses both of them. 

Your service representative can help you to identify the appropriate network 
topology and library configuration for Dual TCP/IP.
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Data Path 

The host exchanges user and application data with the tape drives in the library over 
the SAN (Storage Area Network). Optical fibre connects a port on an HBA (host bus 
adapter) on the host to a port on the drive. 

The SL8500 library supports tape drives that use the most widely implemented Fibre 
Channel SAN topologies, Switched Fabric (FC-SW) and Arbitrated Loop (FC-AL). 
Dynamic World Wide Names (dWWNs) are optional.

Switched Fabric (FC-SW)

In a switched fabric topology, all nodes on the storage area network connect to Fibre 
Channel switches that provide optimized, dynamic interconnections between nodes. 
When an SL8500 library is connected to a Fibre Channel switch or fabric-capable host, 
it automatically configures itself for switched topology. This configuration can 
support up to 16 million ports on the fabric.

To configure library-attached drives on an SL8500 library, you must use switched 
fabric topology.

Arbitrated Loop (FC-AL)

In an arbitrated loop topology, the nodes on the storage area network (SAN) are 
connected to one another in a one-way loop, usually via a hub. Only two ports can 
communicate over the loop at any given time. 

Each device on the arbitrated loop has an Arbitrated Loop Physical Address (ALPA) 
that is determined by its position in the loop. When the loop reinitializes, ALPAs are 
reassigned to accommodate devices that have been added to or removed from the 
loop since the last initialization, unless the device has been configured with a static or 
hard ALPA. 

Note – The SL8500 library does not support hard ALPAs.

Dynamic World Wide Names (dWWNs)

The Fibre Channel WWN is a 64-bit address that uniquely identifies each individual 
device and vendor, much like the MAC address of an Ethernet interface. Each port on 
a Fibre Channel network must have a its own WWN. 

The WWN is not just a physical hardware address. WWN also serves as the logical 
address of a node on the SAN. This means that the SAN configuration changes if any 
of the attached hardware changes. If a device fails and is replaced, the WWN of the 
node changes, forcing reconfiguration of the SAN. 

To reconfigure a large SAN to accommodate the replacement of a tape drive would be 
a major inconvenience, so the SL8500 library supports dynamic WWNs (dWWN) for 
tape drives. When enabled (usually at installation), dWWN assigns names to library 
drive slots rather than devices. When a drive is replaced, the new drive receives the 
same name as its predecessor, which eliminates any need for system re-configuration. 
To support this functionality, the dWWN feature assigns three reserved WWNs to 
each drive bay: Node, Port A, and Port B. 

Since library drive slots receive the WWNs in an SL8500 library that has dWWN 
enabled, tape drives do not appear to keep their original WWNs when they are 
migrated between libraries. A drive that was previously known to the SAN under it 
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own, drive-specific WWN will no longer be recognized. For this reason, best practice 
is always to configure all drive bay slots in the library and verify that the tape drive 
data path is bound correctly over the SAN.

Caution – Lack of host availability. Both the library and the tape 
drives must have supporting firmware installed, and all drives 
must be at the same firmware level. Any drives that lack the correct 
firmware will remain in the configuring state and thus unavailable 
for host use.

Caution – To avoid system problems, coordinate with the system 
administrator before changing the dWWN feature and keep careful 
records of any changes. 

Management and Service Interfaces

This section briefly describes the user interfaces that are used for managing the 
SL8500 library:

• “StorageTek Library Console”

• “Simple Network Management Protocol (SNMP)” on page 14

• “Command Line Interface (CLI)” on page 15

StorageTek Library Console 

The StorageTek Library Console (SL Console) is a standalone, Java-based or hosted, 
browser-based software application you use to administor and monitor the SL8500 
library.

TCP/IP Network

Your network connects to the Ethernet management ports 2B (the primary) and 2A on 
the SL8500 HBC/HBCR library controller card. The HBC/HBCR card is installed on 
the right in the Drive and Electronic Module. 

Simple Network Management Protocol (SNMP)

Using Simple Network Management Protocol (SNMP), system administrators and 
standards-compliant management applications can monitor the SL8500 library 
remotely over a TCP/IP local area network. SNMP can provide the following kinds 
of information: 

• The operational state of the library (firmware level, serial number, online/offline)

• The status of the CAPs (open, closed, etc.)

• The number of library elements (robots, drives, storage cells, CAPs, etc.) 

• Media and drive types

For full information on configuring and using SNMP with the SL8500 library, see the 
document SL8500 Library: Simple Network Management Protocol, available in the SL8500 
product documentation library on the Oracle Technical Network.
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Command Line Interface (CLI)

Through the commandline interface (CLI), Oracle support representatives can service 
the library via a serial connection to the CLI port on the HBC/HBCR library 
controller card. The CLI interface is reserved for authorized service personnel only, 
except for customers who use the StorageTek Tape Analytics (STA) server. For CLI 
commands related to the STA server, see the StorageTek Tape Analytics Installation and 
Administration Guide.

Local Controls and Indicators

This section describes the local controls and indicators you can use to monitor and 
troubleshoot the library. These include the following:

• The “Button and Indicator Panel”

• The “Local Operator Panel” on page 16

 For information on tape drive controls and indicators, refer to vendor publications. 

Button and Indicator Panel

The button and indicator panel for the SL8500 library (shown in shown in 
FIGURE 1-3) is located on the Customer Interface Module at the front of the library, 
in the center console between the CAP and Service doors.

FIGURE 1-3  Locations of Controls and Indicators   

Individual components include the following, starting from the left side of the panel:

1. The Emergency Robotics Stop switch: A large, rectangular, red button mounted at 
far left on the library control and indicator panel. Press this button to disconnect 
DC power to the power rails. Press the switch to restore power.

2. The Left Door key lock with wait and enter indicators. During normal operations, 
door locks keep data and library internal components secure and protect 
personnel from moving parts. Service representatives can unlock the doors when 
service is required.

3. The CAP A button: Press the corresponding CAP button to open and close CAP A 
or CAP B. 
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4. The Unlocked indicator for CAP A: The Unlocked indicator that accompanies each 
CAP button (an amber LED) is ON when the CAP is unlocked, and OFF when 
locked. 

The Unlocked indicator flashes ON and OFF if, for any reason, the library needs 
attention. For example, misaligned or poorly seated cartridges may keep the CAP 
from operating, in which case you may need to reseat cartridges by hand. 

5. The Library Active indicator: ON when the library is operating. 

6. The CAP B button

7. The Unlocked indicator for CAP B

8. The Service Required indicator: A red LED that is ON when operator intervention 
is required. 

9. The Right Door key lock with wait and enter indicators.

Local Operator Panel 

The local operator panel is a touch-screen that displays the SLC graphical user 
interface application on the library itself. It is installed on the Customer Interface 
Module at the front of the library, in the center console between the CAP and Service 
doors above the button and indicator panel.

Library Management Software
Library management software controls the library hardware and manages the library 
database. When the library is operating in automated mode, cartridge mount and 
dismount operations occur without manual intervention. The software tracks the 
volume identifiers (VOLIDs), attributes, and locations of cartridges using audit data 
uploaded from the library. Using this information, it allocates drives and requests 
library operations, such as entering, mounting, dismounting, and ejecting cartridges.

Oracle offers several library management software components for various 
combinations of platform, connection type, and operating system. 

Enterprise Library Software (ELS)

In mainframe environments, the Oracle Enterprise Library Software (ELS) suite 
includes the following components:

• The Client System Component (CSC)

• The Storage Management Component (SMC)

• The Oracle StorageTek HTTP Server

• The Host Software Component (HSC)

Client System Component (CSC)

Oracle’s MVS/CSC provides client functions and communications between an MVS 
host and Oracle’s Library Control System or server on a non-MVS host. MVS/CSC 
allows the MVS client to perform automatic tape handling on a StorageTek library in 
addition to sharing multiple host systems (both IBM and non-IBM). 
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The MVS/CSC can communicate with Oracle’s LibraryStation in an MVS-only 
environment, or the SMC and the Oracle’s StorageTek HTTP server can provide 
communication between MVS hosts.

Storage Management Component (SMC)

The Storage Management Component is the interface between IBM’s OS/390 and z/
OS operating systems and an Oracle library. The Storage Management Component:

• Performs the allocation processing, message handling, and SMS processing for the 
ELS solution.

• Resides on the MVS host system with Host Software Component and/or MVS/
CSC or on a remote system using the StorageTek HTTP server to communicate 
with the Host Software Component.

• Communicates with ELS or MVS/CSC to determine policies, volume locations, 
and drive ownership. The Storage Management Component is a required ELS 
component.

Oracle StorageTek HTTP Server

The StorageTek HTTP Server for OS/390 and z/OS optionally provides the 
middleware to enable communication between the Storage Management Component 
(client) and a remote Host Software Component subsystem (server). The HTTP server 
executes as a separate subsystem on the MVS host where the remote Host Software 
Component subsystem resides.

Host Software Component (HSC)

When an SL8500 library is in a stand-alone configuration with an MVS host, the host 
must run a version of Oracle’s Host Software Component along with the Storage 
Management Component. The Host Software Component resides within the MVS 
host, but is invisible to the actual operating system. 

The Host Software Component and Storage Management Component influence 
allocations, intercept mount and dismount messages, receive requests from the 
interface, and translate requests into commands.

Host Software Component 6.0 (with additional PTFs) or higher and ELS 6.1 with 
Near Continuous Operation support library complex operations. But users of Host 
Software Component 6.1 with Near Continuous Operation must seek assistance from 
Oracle support representatives before upgrading a library complex configuration 
without performing a LIBGEN or MERGEcds or without stopping and restarting the 
Host Software Component. Newer drives may require higher versions of Host 
Software Component. 

LibraryStation

LibraryStation provides a communications interface between ELS and a client system 
running an MVS or open systems host. This interface enables network clients to 
access the library services of a StorageTek Automated Cartridge System through the 
MVS host system. LibraryStation can communicate with MVS/CSC in an MVS-only 
environment, or the Storage Management Component and the Sun StorageTek HTTP 
server can provide communication between MVS hosts. LibraryStation executes in 
the ELS address space on MVS.
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Automated Cartridge System Library Software (ACSLS) 

In open systems environments, the Automated Cartridge System Library Software 
(ACSLS) software package provides library management services such as cartridge 
tracking, pooling, reports, and library control. ACSLS maintains a database that 
tracks tape volume names and their current locations in the tape libraries. In CSC 
configurations, ACSLS manages the library control software that runs in the UNIX-
based Library Control System. 

Note – ACSLS 7.1 (with PUT0601, for Near Continuous 
Operation) or higher is required to support PTP and T10000 tape 
drive operation. 

Note – The ACSLS application is sold to support a defined 
number of cartridge slots. 
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StorageTek Library Console

Oracle’s StorageTek Library Console (SL Console) is a Java-based software 
application that provides a graphical user interface (GUI) for monitoring and 
managing the StorageTek SL8500 library. 

This chapter contains the following topics:

• “Using the SL Console” on page 19

• “SL Console Modes” on page 20

• “SL Console Security” on page 20

• “SL Console Reports” on page 24

• “Web-launched SL Console” on page 30

• “Standalone SL Console” on page 32

Using the SL Console
You can perform activities with the SL Console such as:

• Manage and configure library partitions (optional feature)

• View and modify status and properties of the library and associated devices 
(drives, CAP, robots, and elevators)

• Perform an audit on all or part of the library

• Perform a self-test on the library or an associated device

• Perform a diagnostic move (exercise a robot)

• Locate a cartridge

• Move a cartridge from one location to another

• Display library logs

• Display error explanations

• Download new library firmware while the library is in operation

• Display context-sensitive help
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SL Console Modes
Depending on your needs, you can run the SL Console in any of the following 
modes. For details and procedures, see: 

• “Local Operator Panel” on page 29“Web-launched SL Console” on page 30 

• “Standalone SL Console” on page 32

SL Console Security
Security features built into the SL Console control both user authentication and user 
authorization. The security features include:

• User IDs: User IDs control user authentication. Each user must have a valid, active 
user ID and password to log in to the SL Console.

• Access permissions: Access permissions control user authorization. Each user ID is 
assigned a set of access permissions, which determine the types of requests the 
user can submit through the SL Console. For example, to modify the system 
properties of a drive, a user must log in with a user ID that has the proper access 
permissions.

When you log in to the SL Console with a valid user ID, password, and library name, 
the system authenticates your identity and then authorizes your access to the various 
SL Console functions. 

Note – Beginning with SL Console 4.50, passwords are limited to 
5 - 8 characters.

User IDs

To log in to the SL Console, you must have a valid, active user ID. Each user ID must 
be assigned a password.

There are a fixed set of user IDs at a site. The user IDs include:

• admin: customer administrator

• service: Oracle support representative

• oem: third-party field service technician

When you log in successfully, the SL Console displays your user ID in the status bar 
of the screen.

Only one user at a time can be logged in to the local operator panel. Any number of 
users can connect to a library through the standalone SL Console or Web-launched SL 
Console. 

Activation Password 

Before any users at your site can use the SL Console for the first time, your library 
administrator must activate the “admin” user ID with a special activation password. 
Your Oracle support representative provides your administrator with the activation 
password, which is valid for one-time use only. 
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After logging in with the activation password, the administrator must change the 
admin user ID password to ensure system security. 

Note – Beginning with SL Console 4.50, your password must be 
limited from 5 - 8 characters. Enter the first 8 characters of the 
initially assigned password. After initial login, you can change the 
password.

For details about this process, see the appropriate library Installation Guide.

Automatic Logout

Beginning with SL Console 5.8 and FRS_8.0, after you have been logged in to the SL 
Console for six hour, your session will expire. The system then displays a dialog box 
where you can either log back in or log off.

FIGURE 2-4  SL Console Session Time Out Dialog Box

You are allowed four attempts to login. If you are unable to login after four attempts, 
the system logs you out and displays the following message.

FIGURE 2-5  SL Console Login Retry Message

To log in, return to the main login screen.

SL Console Screen Display
The following TABLE 2-3 explain the components of the SL Console screen shown in 
FIGURE 2-6.



FIGURE 2-6  SL Console Screen Display

See TABLE 2-3 on page 22 for details.
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TABLE 2-3  SL Console Component Description

Component Name Description

1 Menu bar: Includes the 
Tools Menu and the Help 
Menu 

Tools menu provides access to System Detail, Reports, Monitors, 
Utilities, Partitioning, User Management, and Log off functions. 

Help menu provides access to the table of contents of the help 
system. It also identifies the version of the SL Console in use.

2 Title bar Displays the title of the current screen

3 Function tabs Identifies the available functions for a screen

4 Options bar Location of buttons related to the screen (for example, Apply, 
Refresh, Print). Always includes the SL Console Help button (?). 
See “Synchronizing the Display With the Controller 
Database” on page 23 for details on using the Apply and Refresh 
buttons. 

5 Work area Location of the screen data
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Modifying the Screen Layout

Note – This feature is available starting with SL Console version  
3.30. It is available on selected screens only. 

You can modify the layout and display of selected SL Console screens as listed in  
TABLE 2-4. 

TABLE 2-4  SL Console Display Options

Display Option Instructions

Sort the display by 
any column

Click the heading of the column you want to sort by. Initially 
the sort is in ascending order. Click the heading again to 
switch between ascending and descending order.

Arrange the 
columns in any 
order

Click and drag a column heading horizontally to any 
position in the heading row. 

Resize the columns Click the border of the column heading and drag it left or 
right to change the column width. 

Synchronizing the Display With the Controller Database

Logging In

The SL Console gets all library configuration data from the library controller. 
Therefore, be careful when logging in to the SL Console before the library has fully 
initialized. You may see warnings that configuration data is not yet available. In such 
a case, you must exit and log in again at a later time. Additionally, if a library audit is 
performed as part of initialization, until the audit is complete, any configuration data 
displayed may not be completely up to date and accurate. 

Library Configuration Updates

When you first bring up an SL Console screen, the display reflects the most recently 
saved data from the library controller database. If you have changed the 
configuration in some way (such as taking a drive offline, or removing or adding a 
cartridge), it is important that you sychronize the status of the library with the SL 
Console screen.

6 Library health indicator Identifies the library to which the SL Console is connected, and 
displays a graphical representation of the library health

7 UserID indicator Displays the user ID currently logged in to the SL Console

8 Server communication 
health indicator

Displays a graphical heartbeat monitor indicating the state of 
server communication health

9 Navigation tree Lists the devices included in the library

TABLE 2-3  SL Console Component Description

Component Name Description
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If you are making major modifications to the library configuration (such as adding 
modules, defining partitions, etc.), you should coordinate these changes with other 
library users. Failure to do so could result in conflicts within the controller database. 

Apply Button

If you use the screen to modify the library contents or configuration, your changes do 
not update the controller database until you commit your changes by clicking the 
Apply button. Multiple users can access the library at the same time, using the SL 
Console or  command line interface to make changes. Various host applications can 
also access the library to make their own changes to the library contents and 
configuration. 

Refresh Button

If other users make changes and apply them to the controller database, you will not 
see these changes until you click the Refresh button on your screen. If you have 
made changes to the library (such as removing a cartridge or taking a drive offline), 
the status of the library and its components will not be updated to the SL Console 
until you click Refresh. Using Refresh, you can select all of the library for 
synchronizing or one or more library components. 

SL Console Reports 
The SL Console library reports provide information on the library and its associated 
devices (for example, drives, robots, and CAPs), events, and tape cartridges. You can 
use the reports to monitor library activity and identify potential problems. In 
addition to displaying the reports on-screen, you can save the report data to a file, 
which you can then print or include in e-mail. 

All report output is a static display of information sent from the library controller at 
the time the report is generated. The SL Console does not update the information 
dynamically unless you explicitly select the Update button on the Options bar.

Note – Running multiple instances of the standalone SL Console 
or Web-launched SL Console on the same PC or workstation can 
cause problems such as inconsistent data on reports. It is 
recommended that only one user at a time produce SL Console 
reports on a PC or workstation, unless all instances of the SL 
Console are the same version.

Report Types

The SL Console provides the following types of reports:

• Log: Detailed system event logs

• Statistics: Statistical information on library operations 

• Status Detail: Details on the status of the library and associated devices, such as 
CAPs, drives, and robots

• Status Summary: Summary information on the status of the library and associated 
devices
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• Version: Details about library hardware and software versions

Report Options Bar

The Options bar on each report allows you to perform the following functions:

• “Search a Library Report” on page 53.

• Update the report with current data.

• “Save Library Report Data to a File” on page 55.

Report Procedures

For report procedures, see “General SL Console Report Tasks” on page 50. 
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SL Console Help
The SL Console Help displays information for library operators, system 
programmers, system administrators, and service representatives. 

Note – The information relates only to the SL Console. For 
information about library hardware, tape drives, or host software, 
see the appropriate product publication.

FIGURE 2-7 shows a sample SL Console Help screen.

FIGURE 2-7  SL Console Help, Sample Screen

To display the SL Console Help from any SL Console screen, use either of the 
following methods: 

• To display context-sensitive help for the current SL Console screen, click the ? 
button in the Options bar. 

• To display general help information, click Help > Contents in the Menu bar. 

Navigating Help

The left panel of the SL Console Help screen displays either of the following:

• Table of contents (TOC): An outline of topics and subtopics

• Index: A list of terms and topics, in alphabetical order

The right panel displays the Help topic itself.
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The top of the SL Console Help window includes the navigation buttons shown in 
FIGURE 2-8 and described in TABLE 2-5 on page 27.

FIGURE 2-8  SL Console Help Navigation Buttons

See TABLE 2-5 for details.

 

TABLE 2-5  SL Console Help, Navigation Buttons

Button Meaning Action

1 Back Retraces your steps, going backward one topic at a time

2 Forward Retraces your steps, going forward one topic at a time

3 Print Displays the Print dialog box, which allows you to print one or more 
topics:

• To print the current topic, click the Print button.

• To print a different topic, click the topic title in the SL Console Help 
table of contents, and click the Print button.

• To print more than one topic, highlight the topics in the SL Console 
Help table of contents by pressing Shift-Click or Ctrl-Click, and then 
click the Print button. 
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Managing Favorite Topics

To save favorite topics, navigate to the topic you want to save. Click the Add to 
Favorites button shown in FIGURE 2-9. The topic will then display in the left-hand 
column as a topic. To delete a topic, select it. Then right-click to display the menu, 
and click Remove.

FIGURE 2-9  Management Menu for Favorite Help Topics

Tips for Using the SL Console Help

You can minimize, maximize, or resize the Help screen to accommodate your needs.

You can resize the left and right panels of the Help screen by clicking the border 
between them and dragging it left or right. 

4 Print Setup Displays the Page Setup dialog box, which allows you to modify your 
print page layout

5 Add Favorite Saves the currently displayed topic as a favorite topic. See the following 
“Managing Favorite Topics” on page 28 for more information.

6 TOC Displays the SL Console Help table of contents

7 Index Displays the SL Console Help index

8 Favorites List Displays list of favorite topics

9 Search Allows you to enter a term and search the contents for that term

TABLE 2-5  SL Console Help, Navigation Buttons

Button Meaning Action
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Most topics include a Related Topics button at the bottom of the page. Click on this 
button to display and navigate to help topics containing related information. 

Local Operator Panel
The local operator panel is built in to the Customer Interface Module. It enables you 
to run most of the SL Console application directly at the library from a flat-screen 
display with a touch screen interface. 

The local operator panel has the following features:

• Flat-panel display (12.1-inch), resident within the library 

• Touch screen interface, allowing alphanumeric data entry. Stylus available. See 
“Virtual Keypad” on page 29 for details. 

• No keyboard or mouse option

LEDs located directly below the local operator panel provide the following status 
information:

• Library Active: Library processor is working. 

• Wait: Library firmware is loading. 

• Service Required: Library is rebooting. 

Virtual Keypad

Some screen fields require you to make a text entry. The local operator panel displays 
a keyboard icon next to these fields. By clicking on the keyboard icon, you can 
display a virtual keypad, which allows you to enter valid alphanumeric characters 
into the field. FIGURE 2-10 shows the keyboard icons on a sample screen. 

FIGURE 2-10  Virtual Keypad

The virtual keypad provides the standard alphanumeric and symbol characters. It 
enables you to enter only characters that are valid for the current field. Characters 
that are not valid are grayed out. 
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The virtual keypad also provides the following cursor movement buttons listed in the 
following TABLE 2-6.

TABLE 2-6  Virtual Keypad, Cursor Movement Buttons

Button Function

Insert If highlighted, inserts text at the cursor position. If not highlighted, 
replaces text to the right of the cursor. 

Home Places cursor at the beginning of the field.

Del Deletes character to the right of the cursor.

End Places cursor at the end of the field.

Back Deletes character to the left of the cursor

Clear Clears the entire field

Left Moves cursor one character to the left

Right Moves cursor one character to the right

OK Submits the text entry in the field

Cancel Cancels the text entry in the field and dismisses the virtual keypad 

Touch Screen Calibration

Alignment of the local operator panel touch screen is calibrated at the factory. The 
factory settings are appropriate for most situations, and it is usually not necessary for 
you to make any adjustments. On rare occasions, however, the touch screen may 
come out of alignment or need adjustment. 

To re-calibrate the touch screen, proceed as follows:

• If you have a Linux-based local operator panel, you can re-calibrate it yourself. 
See “Re-calibrate the Local Operator Panel” on page 58 for detailed instructions. 

• If you have a Windows-based local operator panel, contact your Oracle support 
representative. Windows-based local operator panels can be re-calibrated only by 
an authorized service representative. 

If you have a Linux-based local operator panel, you can re-set the touch screen to its 
factory settings at any time. See “Reset the Local Operator Panel 
Calibration” on page 61 for detailed instructions.

Web-launched SL Console
The Web-launched SL Console is a standard feature of the library. It enables the SL 
Console to be installed on a centralized Web server. Individual clients can then use a 
supported Web browser to download the Web-launched SL Console. Using the Web-
launched SL Console you can connect to any library for which you have a valid user 
ID.

The Web-launched SL Console is delivered to clients as a Java Web Start process, 
which executes outside the browser. 
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Security Considerations

The Web-launched SL Console software is digitally signed, which guarantees that it 
has been issued by Oracle Corporation and has not been altered or corrupted since it 
was created. As a Java Web Start process, the Web-launched SL Console includes the 
security features provided by the Java 2 platform.

You are responsible for implementing all appropriate additional security systems, 
including firewalls, user access, etc.

Client Requirements

You can download the Web-launched SL Console to clients meeting the requirements 
listed in the following TABLE 2-7. 

TABLE 2-7  Web-launched SL Console Requirements

Platform Solaris 9: SPARC (Firefox 2.x)

Solaris 10: SPARC (Firefox 2.x)

Windows 2000: 32 bit (IE 5, IE 5.5, Firefox 2.x)

Windows XP: 32 bit (IE 6, IE 7, Firefox 2.x)

Windows Vista: 32 bit (IE 7, Firefox 2.x)

Other • Java 1.5 Plug-in (the browser will install this automatically if it 
is not present already)

• Ethernet connection to the library

• Ethernet connection to the Web-launched SL Console server 

 

Web-launched SL Console Updates

Updates to the Web-launched SL Console only need to be installed on the centralized 
Web server. After the updates are installed on the server, they are downloaded 
automatically to all clients whenever the application is started on the client. 

Starting the Web-launched SL Console on a Client

You can use either of the following methods to start and log in to the Web-launched 
SL Console on a client: 

• From a command line (Solaris only) or supported browser. See “Log in to the 
Web-launched SL Console” on page 36. 

• By double-clicking the slc.jnlp icon on your client. To use this method from a 
client, you must use the browser method at least once and save the slc.jnlp file 
locally. See “Log in to the Web-launched SL Console Using an Icon” on page 41. 
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Standalone SL Console
The standalone SL Console is a standard feature of the StorageTek SL8500 library. It 
enables you to run the SL Console application remotely from a PC or workstation 
that has a network connection to the library. Using the standalone SL Console, you 
can connect to any library for which you have a valid user ID. 

Security Considerations

The SL Console application interfaces with the primary library interface (PLI) over a 
secure sockets layer (SSL). SSL provides a secure communication path between the 
library and the customer’s SL Console session. This security prevents an 
unauthorized network user from monitoring library activity.

Installation Requirements

You can install the standalone SL Console on a computer meeting the requirements 
listed in the following TABLE 2-8

TABLE 2-8  Standalone SL Console Requirements

Platform Solaris 9: SPARC

Solaris 10: SPARC 

Windows 2000 Server: 32 bit

Windows XP Client: 32 bit 

Windows Vista: 32 bit

Other Ethernet connection to the library 

: 

The standalone SL Console software is available for download at the Oracle Software 
Delivery Cloud, available at:

http://edelivery.oracle.com/ 

Standalone SL Console Updates 

Note – Before you can install a new version of the standalone SL 
Console, you must uninstall the previous version. See your PC or 
workstation documentation for detailed instructions. Running 
multiple versions of the SL Console on the same PC or 
workstation can cause problems such as inconsistent data on 
reports. 

After you have uninstalled the previous version of the SL Console, see the following 
procedures for detailed instructions on upgrading the software.

• “Download the Standalone SL Console Media Pack” on page 63 

• “Install the Standalone SL Console” on page 65 
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SL Console Task Summary
SL Console tasks are divided into the following categories:

• “General SL Console Usage Tasks” on page 34

• “General SL Console Report Tasks” on page 50

• “Local Operator Panel Calibration Tasks” on page 57

• “Standalone SL Console Installation Tasks” on page 62
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General SL Console Usage Tasks

Task
PagePag
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Log in to the Local Operator Panel  35

Log in to the Web-launched SL Console  36

Log in to the Web-launched SL Console Using an Icon  41

Log in to the Standalone SL Console  44

Log Off the SL Console  46

Change a User Password  48
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▼ Log in to the Local Operator Panel 

Task Tool

This procedure can be performed at the local operator panel.

Task Purpose

Use this procedure to log in to the local library. 

Note – Only one user at a time can log in to the local operator 
panel. 

Task Steps

1. If the touch screen panel is blank, touch the screen anywhere to activate the 
Login screen.

2. Use the virtual keypad to enter your login information (see “Virtual 
Keypad” on page 29 for details). 

User ID: SLC_login  
Password: password 

where:

• SLC_login is the SL Console user ID.

• password is the password assigned to this user ID. 

Note – Beginning with SL Console 4.50, your password must be 
limited from  5 - 8 characters. Enter the first 8 characters of the 
initially assigned password. After initial login, you can change the 
password.

Note – The user ID you use determines the screens you can 
access. See “SL Console Security” on page 20. 

3. Click Log on. 
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▼ Log in to the Web-launched SL Console

Task Tool

This procedure can be performed at either of the following:

• Web browser

• Command line

Task Purpose

Log in to the SL Console.

On Windows 2000, you may need to install a Java plugin for your Web browser 
before performing this procedure. You can download the plugin from the following 
location: 
http://java.sun.com/products/archive/j2se/5.0_04/index.html 

On Solaris platforms, it is easier to log in to the Web-launched SL Console using the 
command line. If you prefer to log in using a Web browser, however, you need to 
download a recent version of the Firefox Web browser from the following location:  
www.mozilla.com

Note – Before you perform this activity, you must obtain the DNS 
alias or IP address of the SL Console server. Depending on how 
your Web-launched SL Console server has been set up, it may be 
accessible only by IP address. See your library administrator for 
assistance. 

Note – The command line option is available on Solaris platforms 
only. 

Task Steps

1. Choose your login method:

• Command line: Available on Solaris only. Proceed to Step 2. 

• Web browser: Available on either Windows or Solaris. Proceed to Step 3. 

2. Open a terminal window, and type the following command:

javaws http://server_ID:port_ID/opel/slc.jnlp 

where:

• server_ID: Either of the following:

• IP address of the SL Console server 

• DNS alias of the SL Console server

• port_ID: Port ID of the SL Console application, typically 8080 

• opel: The name (context root) of the Web-launched SL Console application on 
the server. 

Proceed to Step 4. 
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3. Start a supported Web browser on your client PC or workstation (see “Client 
Requirements” on page 31 for a list of supported browsers), and in the Location 
Bar or Address field, enter the URL of the SL Console Web Start application: 

http://server_ID:port_ID/opel

where:

• server_ID: Either of the following:

• IP address of the SL Console server 

• DNS alias of the SL Console server

• port_ID: Port ID of the SL Console application, typically 8080 

• opel: The name (context root) of the Web-launched SL Console application on 
the server. 

Note – You can bookmark this URL for future logins. 

The SL Console Launch screen appears. 
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4. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates download automatically. 

The Opening slc.jnlp dialog box appears. 

5. Complete the dialog box as follows:

a. Specify the action you want to take with the slc.jnlp file:

• Click the Open with Java(TM) Web Start Launcher radio button if you 
want to start the SL Console directly. 

• Click the Save to Disk radio button if you want to save the slc.jnlp file 
to your client and log in to the SL Console later. See “Log in to the Web-
launched SL Console Using an Icon” on page 41 for login instructions. 

b. Optionally click the “Do this automatically for files like this from now on” 
check box. If you make this selection, this message will not appear during 
future logins. 

c. Click OK. 



General SL Console Usage Tasks

StorageTek Library Console   39

If this is the first time you are running the Web-launched SL Console, a digital 
signature warning dialog box appears. 

6. Complete the dialog box as follows:

a. Verify the Publisher. 

b. Optionally click the “Always trust content from the publisher” check box. If 
you make this selection, this dialog box will not appear during future logins. 

c. Click Run.

The SL Console Login screen appears. 

7. Enter your login information, and click Log on.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

• SLC_login: SL Console user ID.
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• password: Password assigned to this user ID. (Password must be between 5-8 
characters.)

• library_ID: Library to which you want to connect, expressed in either of the 
following ways:

• IP address of the library 

• DNS alias of the library

Note – Beginning with SL Console 4.50, your password must be 
limited from  5 - 8 characters. Enter the first 8 characters of the 
initially assigned password. After initial login, you can change the 
password.

Note – The user ID you use determines the screens you can 
access. See “SL Console Security” on page 20. 
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▼ Log in to the Web-launched SL Console Using an Icon

Task Tool

This procedure can be performed at your client.

Task Purpose

Log in to the SL Console.

Note – To perform this activity, you must first save the Web-
launched SL Console slc.jnlp file to your client. See “Log in to 
the Web-launched SL Console” on page 36 for details. 

Task Steps

1. Double-click the slc.jnlp desktop icon on your client. 

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates are downloaded automatically. 

The SL Console Launch screen appears. 
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2. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from 
the server. Any updates download automatically. 

If this is the first time you are running the Web-launched SL Console, a security 
warning dialog box appears. 

3. Complete the dialog box as follows:

a. Verify the Publisher is Oracle Corporation.

b. Optionally click the “Always trust content from the publisher” check box. If 
you make this selection, this dialog box will not appear during future logins. 

c. Click Run.

The SL Console Login screen appears. 
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4. Enter your login information, and click Log on.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

• SLC_login: SL Console user ID.

• password: Password assigned to this user ID. (Password must be between 5-8 
characters.)

• library_ID: Library to which you want to connect, expressed in either of the 
following ways:

• IP address of the library 

• DNS alias of the library

Note – Beginning with SL Console 4.50, your password must be 
limited from  5 - 8 characters.

Note – The user ID you use determines the screens you can 
access. See “SL Console Security” on page 20. 



General SL Console Usage Tasks

44   SL8500 User’s Guide

▼ Log in to the Standalone SL Console 

Task Tool

This procedure can be performed at your client.

Task Purpose

Log in to the SL Console.

Task Steps

1. Start the SL Console application on your PC or workstation by doing either of 
the following:

• Double-click the SL Console icon on the desktop.

• Select Start > RunSLConsole or Launch > RunSLConsole.

The SL Console starts, and the Login screen appears. 

2. Enter your login information.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

• SLC_login: SL Console user ID.

• password: Password assigned to this user ID. (Password must be between 5-8 
characters.)

• library_ID: Library to which you want to connect, expressed in either of the 
following ways:

• IP address of the library 

• DNS alias of the library
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Note – Beginning with SL Console 4.50, your password must be 
limited from  5 - 8 characters.

Note – The user ID you use determines the screens you can 
access. See “SL Console Security” on page 20. 

3. Click Log on. 
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▼ Log Off the SL Console

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Log off the SL Console.

Note – Before you log off, make sure all operations for the current 
SL Console session have completed (for example, code loads, 
audits, diagnostic moves). 

Task Steps

1. From any SL Console screen, select Tools > Log Off.

The Confirm message appears. 

Note – To remain logged in to the SL Console, click Cancel. You 
are returned to the originating screen without logging off. 

2. Click OK. 

You are logged off the SL Console, and the Login screen appears. 
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3. Click Exit to close the SL Console.
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▼ Change a User Password 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to change the password for a user account. 

Task Steps

1. Log in to the SL Console using any of the modes available to you (local operator 
panel, Web-launched SL Console, or standalone SL Console). You must log in 
using the user account you want to modify.

2. Select Tools > User Mgmt.

The User Management page appears. 
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3. On the navigation tree, expand the Permanent folder, and select the user 
account you want to modify (the user account you are logged in as). 

Detailed information for the user account is displayed. 

4. Complete the following fields: Current Password, New Password, and 
Retype Password. 

5. Click Modify.

The password for the account updates. 
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General SL Console Report Tasks
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▼ Display a Library Report

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display library reports available from the Tools > Reports 
menu.

Note – All report output is a static display of information sent 
from the library controller at the time the report is generated. The 
SL Console does not update the information dynamically unless 
you explicitly select the Update button in the upper right corner.

If you want to search the report data or save it to a file, see the following procedures:

• “Search a Library Report” on page 53 

• “Save Library Report Data to a File” on page 55

Additional reports are available from the following menus:

• Tools > Partitions 

Task Steps

1. Select Tools > Reports. 

The reports Display page appears. All library report options are listed in the 
navigation bar.

2. In the navigation tree, expand a report category to see the report options.
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3. Click the report you want to display. 

The selected report displays. 
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▼ Search a Library Report 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to search a library report for a specified text string. This procedure 
can be performed on any of the library report screens.

Task Steps

1. Select Tools > Reports. 

The reports Display page appears. All library report options are listed in the 
navigation bar.

2. In the navigation tree, expand a report category to see the report options.

3. Click the report you want to display. 

The specified report displays. All report screens include the Search button.
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4. Click Search. 

The Search Text dialog box appears. 

5. Enter the text string you want to search for, and click Search. 

Note – The search is case-sensitive, and wildcards are not 
supported. 

6. The Search Results message appears, displaying the number of occurrences of 
the text string. All instances of the text string in the report are highlighted. 

7. Click OK to dismiss the message. 
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▼ Save Library Report Data to a File

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display a library report and save the data to a file. Depending 
on the report, you can save to in text (.txt), HTML, XML, or comma-separated 
values (.csv) format. This procedure can be performed from any of the library report 
screens.

After the file is saved, you can print it or include it in e-mail. This may be useful for 
communicating about library issues with your Oracle support representative. 

Task Steps

1. Select Tools > Reports. 

The reports Display page appears. All library report options are listed in the 
navigation bar.

2. In the navigation tree, expand a report category to see the report options.

3. Click the report you want to display. 

The specified report displays. All report screens include the Save button.
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4. Click Save. 

The Save dialog box appears. 

5. Browse to the directory where you want to save the file. In the File Name field, 
you can accept the default entry or enter a different file name. 

6. In the Files of Type list, select the format in which you want to save the data 
(HTML, Text, XML). 

7. Click Save. 

The data is saved to the specified file. 

Note – If the file exists already, a message appears to prompt you 
whether you want to replace the file. 
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Local Operator Panel Calibration Tasks 

Task Page
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Reset the Local Operator Panel Calibration  61
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▼ Re-calibrate the Local Operator Panel 

Task Tool

This procedure can be performed at a Linux-based local operator panel.

Note – This procedure can be performed only at a Linux-based 
local operator panel. To re-calibrate a Windows-based local 
operator panel, contact your Oracle StorageTek support 
representative. 

Task Purpose

Use this procedure to change the alignment of the local operator panel touch screen. 
The touch screen comes pre-calibrated from the factory, and in most cases no 
adjustment is necessary. Typically, use this procedure only if the touch screen has 
come out of alignment. 

Note – Before beginning this procedure, make sure there is no 
debris on the touch screen, as this can interfere with an accurate 
calibration. 

Note – You can re-set the touch screen to its factory settings at any 
time. See “Reset the Local Operator Panel Calibration” on page 61 
for detailed instructions. 

Task Steps

1. Log in to the local operator panel.

See “Log in to the Local Operator Panel” on page 35 for detailed instructions. 

2. Select Tools > Calibrate. 

The Select Calibration Option message appears. 



Local Operator Panel Calibration Tasks

StorageTek Library Console   59

3. Click Calibrate. 

The alignment sequence begins. Ten targets are presented sequentially on the 
screen. 

4. Gently tap in the center of each target with your finger or a pointing stylus. 

This aligns the screen according to your touch. Be sure to touch the center of each 
target so you can get an accurate calibration. 

Note – If you tap outside of a target, you can potentially mis-align 
your touch screen. Depending on the severity of the mis-
alignment, you may have trouble logging back into the local 
operator panel if you save these new settings. See Step 7 for 
instructions on discarding settings. 

After you touch the last target of the alignment sequence, the first of two 
Accept Calibration messages appears, with a Click Me button on the left side of 
the message. 

5. Proceed as follows with the agility test, depending on whether the new 
alignment settings are good:

• To save the new alignment settings, proceed to Step 6. 

• To discard the new settings, proceed to Step 7. 

6. Use the following steps to save the new settings.

a. On the Accept Calibration message, touch the Click Me button within the 
indicated time period. 
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• If the button depresses when you touch it directly, the touch screen is 
properly aligned. The second Accept Calibration message appears, this 
time with a Click Me button on the right side of the message. 

• If the button does not depress when you touch it directly, the touch screen is 
not properly aligned and you should discard the new settings. Proceed to 
Step 7. 

b. On the second Accept Calibration screen, touch the Click Me button within 
the indicated time period. 

If you depress the button successfully, the alignment settings are saved and the 
Calibration Accepted message appears. 

c. Click OK to dismiss the message and save the new settings.

The new settings are effective immediately, and the display returns to the SL 
Console screen. The local operator panel is not rebooted. 

7. Use the following steps to discard the new settings. 

a. On either Accept Calibration message, let the timer run out without touching 
the Click Me button. 

The Retry Calibration countdown message appears. 

b. The calibration sequence screen is presented again. Return to Step 4 to try 
the calibration a second time. 

If you are not able to successfully calibrate the screen on the second try, the local 
operator panel is rebooted automatically, and the alignment is restored to the 
previously saved settings. 
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▼ Reset the Local Operator Panel Calibration

Task Tool

This procedure can be performed at a Linux-based local operator panel.

Note – This procedure is available only for a Linux-based local 
operator panel. To re-set the calibration of a Windows-based local 
operator panel, contact your Oracle support representative. 

Task Purpose

Use this procedure to restore the alignment of the local operator panel touch screen to 
the factory settings. This procedure forces a reboot of the local operator panel, which 
takes several minutes. 

Task Steps

1. Log in to the local operator panel.

See “Log in to the Local Operator Panel” on page 35 for detailed instructions. 

2. Select Tools > Calibrate. 

The Select Calibration Option message appears. 

3. Click Reset Calibration. 

The current touch screen calibration settings are discarded, and the alignment is 
restored to the factory settings. The Calibration Reset countdown message is 
displayed. 

The local operator panel reboots automatically, and the display returns to the SL 
Console screen.

Note – The reboot takes several minutes. 
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Standalone SL Console Installation Tasks 

Task
PagePa
ge

Download the Standalone SL Console Media Pack  63

Install the Standalone SL Console  65
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▼ Download the Standalone SL Console Media Pack

Task Tool

This procedure can be performed at the Web browser.

Task Purpose

Use this procedure to download and extract the current SL Console Media Pack from 
the Oracle Software Delivery Cloud. The Media Pack includes the Web-launched SL 
Console server, as well as the Web-launched SL Console client and the standalone SL 
Console. 

Note – Your Oracle support representative may have performed 
this procedure for you during library installation.

Task Steps

1. Launch a Web browser on your PC or workstation and navigate to the Oracle 
Software Delivery Cloud at the following URL: 

http://edelivery.oracle.com/ 

2. Click Continue. 

3. On the Export Validation screen, make the following entries:

• Enter your contact information.

• Read the License Agreement and Export Restrictions, and click the check boxes 
to indicate your acceptance. 

• Click Continue. 

4. On the Media Pack Search screen, make the following selections: 

• In the Select a Product Pack list, select Oracle StorageTek Products. 

• In the Platform list, select Generic Platform. 
  

• Click Go. 
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5. All media packs meeting your selection criteria are displayed in the Results 
section of the screen. Select the SL Console version you want to download. 
Click Continue. 

6. On the specific media pack screen, review the information to verify that you 
have selected the correct media pack. Click Download. 

7. In the dialog box, click Save File to save the media pack to your PC or 
workstation. Click OK. 

Note – This process may take several minutes.
 

8. To complete the installation, see “Install the Standalone SL 
Console” on page 65. 
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▼ Install the Standalone SL Console 

Task Tool

This procedure can be performed at the client.

Task Purpose

Use this procedure to install the standalone SL Console on your PC or workstation. 

Note – Your Oracle support representative may have performed 
this procedure for you during library installation.

Note – Prior to using this procedure, you must have downloaded 
and extracted the standalone SL Console media pack to your PC 
or workstation. See “Download the Standalone SL Console Media 
Pack” on page 63. 

Task Steps

1. On your PC or workstation, change to the directory where you saved the 
standalone SL Console media pack and expand the archive file. 

2. Open the Install folder. 

3. Open the SL Console installer file that is appropriate for your operating system. 

The installation wizard begins and the Introduction screen appears.

Note – At any time during the installation wizard, you can click 
Cancel to cancel the installation or Previous to return to the 
previous screen and re-enter information. 
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4. Review the information, and click Next. 

The Choose Install Folder screen appears. 

5. Specify where you want to install the SL Console program. You can accept the 
default location displayed, or you can click Choose to browse to a different 
directory. Click Next to continue. 

The Choose Shortcut Folder screen appears. 
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6. Enter the location where you want to create the SL Console shortcut icons. You 
can accept the default location displayed, or you can click one of the other 
choices listed and specify a different location. Click Next to continue. 

On Solaris, the default location for shortcuts is the user’s home directory. 
However, shortcuts cannot be created in the root directory (/), which is the root 
user’s home, so if you are installing on a Solaris platform as root you must 
choose something other than the default location. In this case, we recommend that 
you choose /usr/bin or a similar location. 

When you click Next, the Pre-Installation Summary screen appears.

7. Review the information and verify that it is all correct. Click Install to continue. 

The installation begins, and the Installing SL Console screen appears. 
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8. When the installation finishes, the Install Complete screen appears. 

9. Review the information and click Done to exit the installation program. 
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3

Capacity on Demand

The SL8500 grows as your needs grow and makes storage capacity available as 
needed. When you purchase additional capacity for an SL8500 library, you buy the 
ability to store an additional number of cartridges in the library.

There are three types of capacity: physical, purchased and activated.

Physical Storage Capacity
Physical capacity is the number of storage cells that are installed in the library. You 
can immediately install the full number of physical storage cells that you might need 
in the future while paying only for those that you use now. When your needs 
increase, you can pay for the number of additional slots that you need. 

Purchased Capacity
Purchased capacity is the number of cells that you purchase. Your purchased capacity 
does not have to equal the full number of storage cells. When you need more 
capacity, the physical hardware is already in place. But the acquisition cost of your 
fully provisioned system remains reasonable, because you do not need to 
immediately bear the cost of storage cells you are not currently using.

Note – All purchased storage cells must be activated after you 
have downloaded them.

Activated Capacity
Activated capacity is the number of cells that are activated for use after you have 
purchased them.

Process of Increasing Capacity
The following steps are an overview of the process to increase the capacity of your 
library:

1. Purchase a license for using additional storage cells.

2. Download the hardware activation file of the license (see “Download a New 
Hardware Activation File” on page 101).
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3. Install the hardware activation file on the library (see “Install a New Hardware 
Activation File on the Target Library” on page 106).

4. For an unpartitioned library with no or a single host connection, decide which 
approach you want to take:

a. Accept the default region where physical cells will be activated.

a. Choose which region(s) of physical cells to activate, using the SL Console (see 
“Design the Active Cell Configuration” on page 74) .

5. For a partitioned library, choose the region(s) of physical cells to be activated by  
using the SL Console (see “Library Partitioning” on page 123).

6. For a non-partitioned library, if you chose a customized activation scheme, 
perform the configuration using the SL Console. Otherwise, skip to step 7.

7. Reboot the library.

Note – ACSLS hosts must perform an audit of an unpartitioned 
library in order to account for the new capacity. Hosts can 
continue processing jobs while the audit takes place. For more 
information, see “HLI Hosts” on page 71.

Activating Added Capacity
Depending on which approach you chose, the purchased number of cells are 
activated in a default configuration or a customized configuration after the library is 
rebooted.

Default Configuration

For a non-partitioned library with a single host, the SL8500 library controller can  
automatically activate the amount of cells you purchased after you reboot the library. 

The default activation process begins on the outside wall on the left side of the 
library and works to the right until either of these occur:

• The storage cells you purchased have all been activated

• All purchased cells on the outside wall have been activated

If additional purchased capacity remains to be activated, the library continues 
activation, moving to the inside wall and proceeding from left to right.

Customized Configuration

For both non-partitioned and partitioned libraries, cells can be activated in a 
customized configuration:

• For non-partitioned libraries with a single host, see “Design the Active Cell 
Configuration” on page 74.

• For details on activating cells in partitioned libraries, see “Library 
Partitioning” on page 123.

Also keep in mind some guidelines when your activation of cells is customized. See 
“Guidelines for Customized Activation” on page 71 for more information.
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Exceeding Physical Capacity

There are times you will not be able to activate the total number of cells purchased. If 
the activated capacity exceeds the physical capacity, you will be notified by the SL 
Console. However, no additional action is required by you.

Unpartitioned Libraries
For unpartitioned libraries, you must be careful in changing the active status of cells 
in unpartitioned libraries in order to prevent orphaned cartridges.

Orphaned Cartridges in Unpartitioned Libraries

When you change the active capacity status of an unpartitioned library or manually 
move a cartridge to an inactive or otherwise inaccessible cell, the cartridge becomes 
inaccessible to the host that created it. These types of cartridges are called orphaned 
cartridges.

Orphaned cartridges are a serious problem that must be resolved. When the SL 
Console  displays orphaned cartridges, it warns you and provides detailed 
identifying information. You can then resolve the orphaned cartridges by performing 
recovery moves on the listed cartridges. 

Recovery moves transfer the orphans to accessible locations within their parent 
partitions. For more information, see “Recovery Moves” on page 252.

HLI Hosts

When an unpartitioned library is attached to an HLI host, the library will temporarily 
go offline upon reboot and then come back online. While offline, the library stops 
accepting new incoming host jobs, but will complete the jobs already accepted. There 
is no need to disconnect and re-connect the HLI host.

The library controller sends an asynchronous message to any host, notifying them 
that the library configuration has changed.

Guidelines for Customized Activation
To minimize implementation effort and maximize maintainability and operational 
flexibility, keep the following guidelines in mind when allocating capacity:

• Select storage resources in the largest blocks possible (rails, library sides, or 
library walls).

• To minimize use of the elevator and maximize the speed and efficiency of 
cartridge transfers, select complete library rails when possible. 

• For best access to drives, activate library inner and outer library walls together as 
a unit when possible. The inner walls do not hold drives. 

• Avoid selecting individual drives and storage cell arrays. Only use individual 
selection and deselection when required or when you need to fine-tune a capacity 
that has already been broadly defined in larger blocks.
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• When rapid import and export of cartridges is a priority, activate storage cells that 
are near the Cartridge Access Ports (CAPs).

• When rapid access to stored data is a priority, activate storage cells that are near 
the tape drives.
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Capacity Activation and Management Tasks 
No changes are committed to the library controller database unless you click the 
Apply button at the top of the screen and confirm your choice. At any time, you can 
discard changes and restore the last saved configuration by pressing the Refresh 
button. The SL Console will warn you if you attempt to leave the capacity activation 
interface without saving changes. 

Task Page

Design the Active Cell Configuration  74

Display an Active Storage Report  79

Active Capacity Configuration Screen Reference  81

Note – If you log off the SL Console session, if the session times 
out, or if the connection to the library is lost before you save 
changes, any  changes will be lost.

Note – The following tasks can be performed only from the 
standalone SLC or the Web-launched SLC. They cannot be 
performed at the local operator panel. 
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▼Design the Active Cell Configuration

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this task to either accept the default configuration or to choose your own 
configuration for capacity allocation.

Task Steps

1. Select Tools > Select Active Cells, and click the Design By Library tab. 

The Design by Library page displays.

2. Study the Legend in the upper left corner and note the meanings of the icons as 
follows: 

• Inactive cells (represented by plain, white rectangles) have not been activated 
by the library controller. They represent physical capacity that exceeds the 
purchased capacity prescribed by your hardware activation files and/or 
capacity that a user has deactivated in order to make other, specifically selected 
physical resources active.

• Active cells (represented by a solid white rectangle with a triangular mark in 
the upper left corner) have been activated by the library controller’s default 
settings or selected by a user for activation.
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• Selected cells (represented by solid purple rectangles) have been designated 
for activation or deactivation, either by the library controller or by a user.

• No Activation Needed (represented by solid dark red squares) indicates 
resources, such as drives, that are always active by default.

3. To accept the default configuration, go to Step 4. To configure a custom capacity 
design, go to Step 6.

4. To activate the default configuration for capacity, click the Apply Default 
Capacity button in the tool bar at the top of the interface. 

A configuration message will display.

Note – The Apply User Design button is disabled because you 
have not made any changes to the default design.

5. When the system displays the Submit Capacity dialog box, click the Yes button 
in the confirmation message, and go to step 11.

6. To customize which cells will be activated, choose the areas of the library to 
remove and add to the configuration by selecting from the rail, side or wall 
lists.

a. To add selections, click Add.

b. To remove selections, click Remove.

The changes will display in the library map.
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7. To refine the configuration, choose from the Rails list to Add Array or Remove 
Array. Then select which array you want to add or remove.

Note – The configuration is not applied to the library until you 
click the Apply User Design button.

8. If you want to discard all changes you have made in the current session, click 
the Refresh button in the tool bar at the top right of the screen.

Any changes not already applied are discarded and the last saved configuration is 
reloaded from the library controller database.
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9. When you have completed the configuration, click the Apply User Design 
button at the top of the page.

10. When the Submit User Capacity confirmation message appears, click the Yes 
button to apply your design and activate the selected storage cells.

11. If there are no warnings displayed, continue to step 14.
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12. If the Confirm Apply message reports Warnings Found, click the Details >> 
button and examine the Verify Results detail report for orphaned cartridges.

To print warning messages, click Print. To save warning messages in a comma-
delimited text file, click Save. 

13. If orphaned cartridges are reported, click OK, and do not continue with this 
process until you have performed recovery moves on the listed cartridges. 

Recovery moves transfer the orphans to accessible locations within their parent 
partitions. For more information, see “Recovery Moves” on page 252.

14. If there are no warnings found, the Commit Success message displays. Click the 
OK button to return to the Design by Library tab.

15. Reconfigure library host applications so that they recognize the changes. See 
the appropriate tape management software documentation for the correct 
procedures.
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▼Display an Active Storage Report 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to display the following active storage region reports:

• Cartridge Cell and Media Summary: Displays a detailed list of all library 
resources and their status (active or inactive)

• Orphaned Cartridge Report: Displays a detailed list of all orphaned cartridges

Note – The active storage reports display data saved to the library 
controller database. If you have made changes to the active 
storage region configuration without applying the changes to the 
library controller, the data in these reports will differ from data 
shown on Select Active Cells screen. 

Task Steps

1. Select Tools > Select Active Cells, and select the View Reports tab.

The View Reports page appears.
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2. To view cell addresses and volume serial numbers (volsers) for the media in 
each partition, select a Cartridge Cell and Media Summary report from the list.

3. To identify orphaned cartridges, select an Orphaned Cartridge Report from the 
list.

4. To Print a hard copy of a report, click the Print button.

5. To save a report to a comma-separated value (csv) file compatible with most 
spreadsheets, click the Save To File button. 
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Active Capacity Configuration Screen Reference
This section provides detailed descriptions of the active capacity configuration and 
management interfaces for an unpartitioned SL8500 library. 

Screen Page

Select Active Cells—Design by Library  82

Select Active Cells—Select Active Cells—Confirm Apply  87

Select Active Cells—View Reports  91

Select Active Cells—View Reports—Cartridge Cell and Media Summary  93

Select Active Cells—View Reports—Orphaned Cartridge Report  95
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Select Active Cells—Design by Library

Sample Screen

Note – The complete screen is too large for a single page. The 
inside wall and the right side of the library are not shown. The 
modules in the left side outer wall have been represented by 
wrapping them to fit the available space, and, for clarity, all 
selectors have been shown expanded. 
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Description

This interface enables you to customize the default active capacity configuration 
selected by the library controller. You can deselect blocks of storage cells (rails, sides, 
walls, and/or arrays) that the controller has selected for activation and replace them 
with your own selections. You can make any number of cells active, up to the total 
purchased capacity of the library.  Selected cells that cannot become active due to 
purchased capacity limits will remain selected and will automatically become active 
whenever additional capacity Hardware Activation Files are installed. 

Caution – Deactivating storage cells can result in orphaned 
cartridges and inaccessible data. See “Guidelines for Customized 
Activation” on page 71 for details. 

Note – Cartridge Access Ports (CAPs) and tape drives are always 
active. 

Screen Fields

Legend 

Legend for the library map. 

Active (cell)

White or purple rectangle with a triangular tick mark in the upper left corner.

These icons represent storage cells that have been activated by the library 
controller’s default settings or previously selected by a user for activation.

Inactive (cell)

White or purple plain rectangle (no triangular tick mark in the upper left corner).

These icons represent storage cells that have not been activated by the library 
controller (physical capacity that exceeds the logical capacity prescribed by your 
hardware activation files) and/or capacity that a user has deactivated.

Selected (cell) 

Purple rectangle (with or without a triangular tick mark in the upper left corner).

These icons represent storage cells that have been designated for activation or 
deactivation, either by the library controller or by a user.

Unselected (cell) 

White rectangle (with or without a triangular tick mark in the upper left corner).

These icons represent storage cells that have not been designated for activation or 
deactivation, either by the library controller or by a user.

No Activation Needed 

Red-brown squares.

These icons represent resources, such as drives, that are always active by default.
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Current Library Totals

Purchased Capacity

Display only.

This is the maximum logical capacity of the library, the total capacity that can be 
activated. The exact value is determined by the installed Hardware Activation 
Files. The value may exceed the physical capacity of the library.

Active Cells

Display only.

The total number of storage cells that have been activated. 

By default, the library controller activates all cells up to the Purchased Capacity 
or the physical capacity of the library, whichever is smaller. Active Cells cannot 
exceed Purchased Capacity, but excess, selected cells will remain selected and will 
automatically activate when you install additional Hardware Activation Files. 

Selection Totals 

Selected Cells 

Display only.

The total number of storage cells you selected for activation, including already 
activated cells. This number can exceed the Purchased Capacity of the library, as 
explained above. 

Unselected Cells 

Display only.

The total number of storage cells that you have de-selected and removed from 
your planned active capacity configuration. These cells are deactivated when the 
the new configuration is applied. 

The sum of Selected Cells and Unselected Cells is equal to the physical capacity 
of the library

% Capacity Used 

Display only.

The percentage of total Purchased Capacity that has been selected for activation. 
Equivalent to the number of Selected Cells divided by the Purchased Capacity 
times 100.

Buttons and Controls

Rail/Array (unlabeled control)

List of choices: All Rails, Rail 1, Rail 2, Rail 3, Rail 4, Add Array, Remove Array.

Default value: All Rails.
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Select All Rails to include resources (storage-cell arrays and drives) on rails 1-4 to 
the current selection.

Select Rail 1 | Rail 2 | Rail 3 |Rail 4 to include resources (storage-cell arrays and 
drives) on the specified rail to the current selection.

Select Add Array to include a specific array of storage cells to the current 
selection. Select the array by clicking on the corresponding cell-array rectangle in 
the graphical display.

Select Remove Array to remove a specific array of storage cells from the current 
selection. Select the array by clicking on the corresponding cell-array rectangle in 
the graphical display.

Left/Right Sides (unlabeled control)

List of choices: Left/Right Sides, Left Side, Right Side. 

Default value: Left/Right Sides.

Select Left/Right Sides to include resources (storage-cell arrays and drives) from 
both sides of the library in the current selection.

Select Left Side or Right Side to include resources (storage-cell arrays and drives) 
from the specified side of the library in the current selection. 

Inside/Outside Walls (unlabeled control)

List of choices: Inside/Outside Walls, Inside Wall, Outside Wall.

Default value: Inside/Outside Walls.

Select Inside/Outside Walls to include resources (storage-cell arrays and drives) 
from both walls of the library in the current selection.

Select Inside Wall or Outside Wall to include resources (storage-cell arrays and 
drives) from the specified wall of the library in the current selection. 

Add 

Button.

Click Add to include the current selection in the current partition.

Remove 

Button.

Click Remove to remove the current selection from the current partition.

Library map 

An unlabeled, graphical representation of the current library configuration, with 
storage resources represented by the icons described in the Legend. 

The outer wall of the library is shown at the top of the map with the inner wall at 
the bottom. The right and left front sections of the library are displayed at the 
right and left outside edges of the map, with the left and right rear sections in the 
center and the right- and left-side expansion modules laid out between.
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Map elements can be selected and modified using the Rail/Array (unlabeled 
control), Left/Right Sides (unlabeled control), Inside/Outside Walls (unlabeled 
control), Add, and Remove controls.

Initially, the map represents the most recent configuration stored in the library 
controller database. But SL Console the display reflects your modifications. 

Apply Default Capacity

Button.

Applies the default capacity configuration, overriding any customizations that 
have been previously committed to the library controller database.

Apply User Design

Button.

Applies the customer, user-defined configuration that you have defined using the 
these Design By Library controls. Commits the new configuration to the library 
controller database.

Refresh 

Button.

Click Refresh to discard uncommitted changes to the capacity configuration (if 
any) and update the partition workspace with the most recent data stored in the 
library controller database. 

? (Help)

The ? button displays online help for the screen. 

See Also

“Select Active Cells—View Reports” on page 91
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Select Active Cells—Select Active Cells—Confirm Apply

Sample Screen

Description

Displays a list of configuration errors in the defined active storage regions. This 
screen is a message that appears when you click Apply on the 
Select Active Cells > Select Active Cells screen. 

After viewing the error messages, you can commit all data from the 
Select Active Cells screen to the library controller database by clicking the Yes 
button. 

Note – Possible configuration conflicts. Although changes to 
active capacity are not disruptive to library hosts, it is 
recommended that you make the library unavailable to other 
users before committing your active storage region changes. 
Because the SL Console does not validate storage region 
boundaries against the library controller database in real-time, 
configuration conflicts may arise if you change active storage 
region boundaries while other users are performing cartridge 
movements or library configuration changes. See “Synchronizing 
the Display With the Controller Database” on page 23 for details.

Possible errors include:

• The library has orphaned cartridges. See “Resolving Orphaned 
Cartridges” on page 126 for details.

• Storage cells have been removed from the library. 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the 
library controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 
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Screen Fields

Warnings found

Display only.

Summary error messages regarding the storage region configuration. 

Module

Display only.

Module number where the orphaned cartridge is located. 

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row 1 at the top.

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the center of the drive bays. +1 is to the right of the drive bays. -1 
is to the left.

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the left edge of the Base Module. “+1” is to the right. “-1” is to the 
left.

Side

Display only.

Module side where the orphaned cartridge is located. “1” is the back wall. “2” is 
the front wall.

Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row “1” at the top.

Cause for Orphaned State

Display only.

Reason why the cartridge has been identified as orphaned. Options include:

• Just Activated 

• Inactive Media 
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Vol Ser 

Display only.

Volume serial number (vol-id) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Some possible options are:

• Media was found in an inactive cell. 

• Inactive cell with media was just activated. 

Buttons

Note – To display the Print and Save to File buttons, you may 
need to scroll down within the inner window. 

Print

Click to print the report on a selected printer.

Save to File

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Yes

Click to confirm that you want to update the library controller database with the 
current settings from the Select Active Cells. The status of the cells are updated in 
the library controller database, as follows: 

• White cells with a turned over left corner are made inactive.

• Purple cells without a turned over left corner are made active, up to the total 
activated capacity of the library. Purple cells that cannot be made active due to 
library activated capacity limits will remain purple and will automatically 
become active whenever additional activated capacity is installed. 

• All other cells are left unchanged. 

No

Click to cancel the update. The library controller database is not updated, but the 
current settings on the Select Active Cells are retained. 

Details 

Click to toggle between the expanded and collapsed views of the warning 
message display. 
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See Also

Select Active Cells—Design by Library 
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Select Active Cells—View Reports

Sample Screen

Description

Enables you generate an active storage capacity reports that summarizes cells and 
media or reports orphaned cartridges.

Screen Fields

None.

Buttons and Controls

Please select a report to display

List of choices: Cartridge Cell and Media Summary, Orphaned Cartridge Report. 

Select an option to view the corresponding report.

? (Help)

The ? button displays online help for the screen. 
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See Also

“Select Active Cells—Design by Library” on page 82
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Select Active Cells—View Reports—Cartridge Cell and Media 
Summary

Sample Screen

Description

A report listing the storage cells and media assigned to each partition in the library.

Screen Fields

Cell and Media Summary

Table listing storage cells and media by Rail, Column, Side, Row, Partition ID, 
Partition Name, Element Type, Vol Ser (volume serial number), Cell Status, and 
HLI Address. 

Buttons and Controls

Report Selector (unlabeled control)

List of choices: Cartridge Cell and Media Summary (selected), Orphaned 
Cartridge Report. 

Select an option to view the corresponding report.
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Print

Button.

Click Print to print the report.

Save to File

Button.

Click Save to File to save the report as a comma-separated value (csv) file 
compatible with most spreadsheet applications.

? (Help)

The ? button displays online help for the screen. 

See Also

“Select Active Cells—View Reports” on page 91
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Select Active Cells—View Reports—Orphaned Cartridge Report 

Sample Screen

Description

The report lists cartridges that have been left logically inaccessible (or orphaned) 
after changes to the active capacity of the library or manual moves. 

Screen Fields

Orphaned Cartridges (unlabeled control)

Table listing orphaned cartridges by Rail, Column, Side, Row, and Vol Ser 
(volume serial number), plus a brief explanation of the reason why the cartridge is 
an orphan. 

Buttons and Controls

Report Selector (unlabeled control)

List of choices: Cartridge Cell and Media Summary, Orphaned Cartridge 
Report (selected), Partition Summary, Partition Details. 

Select an option to view the corresponding report.

Print

Button.
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Click Print to print the report.

Save to File

Button.

Click Save to File to save the report as a comma-separated value (csv) file 
compatible with most spreadsheet applications.

? (Help)

The ? button displays online help for the screen. 

See Also

“Select Active Cells—View Reports” on page 91
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Hardware Activation Files 

Note – This feature is available starting with SL8500 firmware 
version FRS_7.00 and SL Console version 5.50.

This chapter explains how to activate optional features on the SL8500 tape library. It 
begins with a brief list of the “Customer-Activated Features” on page 97 and an 
overview of “Oracle Hardware Activation Files” on page 97. It then provides:

• An overview of the “Hardware Activation File Installation Process” on page 99

• “Hardware Activation Tasks” on page 100

• A “Hardware Activation Screen Reference” on page 112

Customer-Activated Features
Features you can activate include:

• Capacity Upgrades (100, 250, 500, 1000)

• Capacity Upgrades  

• Dual TCP/IP

• Partitioning

Oracle Hardware Activation Files
Selected SL8500 features are activated through an Oracle hardware activation file. 
This activation file is a digitally signed Java Archive (.jar) file containing a feature 
activation key. You install one hardware activation file for each feature you have 
purchased. When you install a new hardware activation file, the included feature is 
added to the ones already activated on the library. 

Downloading Oracle Hardware Activation Files

Download Oracle hardware activation files from the Oracle Software Delivery Cloud 
at: 

http://edelivery.oracle.com 
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Legacy Hardware Activation Files

For SL8500 libraries prior to firmware version FRS_7.00, hardware activation files 
were installed by your Oracle support representative. In addition, all features you 
purchased for an SL8500 library were included in a single hardware activation file. 
When a new hardware activation file was installed on the library, it would overlay 
any previously installed activation files. 

After the library is upgraded to SL8500 firmware version FRS_7.00, use the processes 
described in this chapter to activate any new features. See “Hardware Activation File 
Installation Process” on page 99 for a summary of the process. 

Note – If your SL8500 library is running firmware prior to 
FRS_7.00, features are still installed by your Oracle support 
representative. 
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Hardware Activation File Installation Process
To activate library features, perform the following tasks. 

1. Purchase a feature for an Oracle StorageTek library from Oracle Corporation.

2. Locate the hardware activation file for the feature on the Oracle Software 
Delivery Cloud  and download it to a system accessible to your StorageTek 
Library Console (SL Console) session.

3. Download the code using the SL Console.

4. To configure newly activated capacity or partitioning, see the following:

• For partitioned libraries, see “Library Partitioning” on page 123.

• For non-partitioned libraries, see “Capacity on Demand” on page 69.

5. To configure the Dual-Path TCP/IP feature, see “Redundant Electronics and 
Firmware Upgrades” on page 211.

Note – The functions described in this chapter can be performed 
from the standalone SL Console or Web-launched SL Console only. 
These functions are not available at the local operator panel.
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Hardware Activation Tasks

Task Page

Download a New Hardware Activation File  101

Install a New Hardware Activation File on the Target Library  106

Display Current Hardware Activation Files  108

Delete a Hardware Activation File  109

Display the Feature Audit Log  111
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▼Download a New Hardware Activation File

Task Tool

This procedure can be performed at a Web browser.

Task Purpose

Use this procedure to download a new hardware activation file for the library.

Note – This feature is available starting with SL8500 firmware 
version FRS_7.00 and SL Console version 5.50. 

Task Steps

1. Start a Web browser on your PC or workstation, and navigate to the Oracle 
Software Delivery Cloud at the following URL:

http://edelivery.oracle.com/ 

2. Click Sign In / Register.

3. When the Export Validation screen appears, read the instructions.

4. On the Export Validation screen, enter your full name, company name, and 
e-mail address in the text fields. Select a country from the list.

5. While still on the Export Validation screen, read the Notice.
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In the Electronic Delivery Trial License Agreement section, read the agreement and 
terms. Then check the YES check box to agree to the terms of your license.

6. While still on the Export Validation screen, read the Export Restrictions. Check 
the corresponding YES check box to accept the restrictions.

7. Click the Continue button to move from the Export Validation screen to the 
Media Pack Search screen.
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8. In the Select a Product Pack list of the Media Pack Search screen, select Oracle 
StorageTek Products. 

9. Click Go. 

The Media Pack Search screen refreshes. In the Results section of the screen, a list 
of media packs meeting your selection criteria replaces the *** No search 
conducted *** notice. 

10. In the Select a Product Pack list of the Media Pack Search screen, use the 
Platform list, and select Generic Platform.

11. Click the Select radio button that corresponds to the SL8500 media pack that 
you want to download, and click the Continue button. 
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12. When download screen for the selected media pack appears, review the 
information to verify that you have selected the correct media pack. Click the 
Readme button to review the readme file.

 

13. If this is not the correct software, use the Back and/or Search Again buttons to 
return to the search screen.

14. After verifying you have chosen the correct software, click the Download 
button beside each desired feature. 

15. The actual number, names, part numbers, and file sizes for SL8500 Hardware 
Activation files may differ from the values shown in these examples.

16. When the download dialog appears, select the Save File radio button, and click 
OK.

17. When the Enter name of file to save to dialog appears, browse to the local 
directory that will hold the download file, and click Save. 

The file is large and may take some time to download, depending on your 
connection speed.
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18. On the download screen for the media pack, click View Digest to view the MD5 
and/or SHA-1 digests of the download files. 

Files can be corrupted during long downloads over a network. A digest is a 
hexadecimal number that represents the contents of the file and enables you to 
verify the integrity of the download.

19. Compute your own digest of the downloaded media pack using the appropriate 
commandline utility.

For example, on Oracle’s Solaris, you could use the digest command:

# /usr/bin/digest -a sha1 download.zip  
9498a4f5303d056ad3ecae826b59f41448d63790

20.  To verify the integrity of your download, compare your computed digest with 
the digest displayed by the View Digest button on the download page. They 
should be identical.

21. If the digest values are not identical, the download file has been corrupted 
during download. Discard it and repeat the download process.

22. If the digests match, use the extraction utility appropriate for your operating 
system (gunzip, pkunzip, etc.) to extract the media pack to a location that you 
can reach from a StorageTek Library Console (SL Console) session. 
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▼ Install a New Hardware Activation File on the Target Library

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To install a new hardware activation file on a target library, follow this procedure 
using the StorageTek Library Console (SL Console).  You cannot use the local 
operator panel for this task. 

Note – This feature is available starting with SL8500 firmware 
version FRS_7.00 and SL Console version 5.50. 

Before performing this procedure, download a new hardware activation file to a 
system accessible to the SL Console session. See “Download a New Hardware 
Activation File” on page 101. 

Task Steps

1. Use the SL Console to log in to the target library. 

See “General SL Console Usage Tasks” on page 34 for details. 

2. Select Tools > Hardware Activation, and select the Install Hardware Activation 
Keys tab. 

The Install Hardware Activation Keys page appears. 

3. In the File Name field, enter the full path of the hardware activation file you 
want to install, and click Enter. Optionally, click Browse and navigate to the file 
location.

The Hardware Activation File Details display in the lower part of the page. 

4. Review the hardware activation file details, and then click the Install... button 
in the upper right corner. 
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The Activation File Installation Confirmation message appears. 

5. Click Yes to begin installing the activation file on the target library. 

6. The library controller installs the hardware activation file, and a confirmation 
message appears. 

7. Click OK to dismiss the message. 

8. You can verify that the activation file has been installed and activated 
successfully by displaying the current activation files. See “Display Current 
Hardware Activation Files” on page 108 for details. 

9. Depending on the features included in the hardware activation file, you may 
need to perform additional tasks to use the new features. 
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▼Display Current Hardware Activation Files 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To display the features currently activated on a target library, perform this procedure 
using the StorageTek Library Console (SL Console).

You cannot use the local operator panel for this task. 

Task Steps

1. Select Tools > Hardware Activation, and click the Current Hardware Activation 
Keys tab. 

The Current Activation Keys page appears, listing the currently activated 
features.

See “Hardware Activation > Current Hardware Activation Keys” on page 113 for 
detailed information about the fields. 
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▼Delete a Hardware Activation File 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To delete a hardware activation file from a target library, complete this procedure 
using the StorageTek Library Console (SL Console). You cannot use the local operator 
panel for this task. 

Note – This feature is available starting with SL8500 firmware 
version FRS_7.00 and SL Console version 5.50. 

Caution – Deleting a hardware activation file is an exceptional 
situation. Be sure you want to do this before you begin this 
procedure. Having extra hardware activation files installed on a 
library does not present any problems (for example, capacity 
activation files that exceed the physical capacity of the library). The 
extra activation files are simply not used. 

Caution – Partitioning feature removal. Deleting a partitioning 
hardware activation file deletes the partitioning feature from the 
library. See “Delete a Partition” on page 148 for details about the 
effects on the library configuration.

Task Steps

1. Use the SL Console to log in to the target library. 

See “General SL Console Usage Tasks” on page 34 for details. 

2. Select Tools > Hardware Activation, and click the Delete Hardware Activation 
Files tab. 

The Delete Hardware Activation Files screen appears. 

3. Click the activation file you want to delete. 

The Delete... button activates, and detail for the file is displayed in the Associated 
Activation Feature Detail(s) section of the screen.

4.  Verify you have selected the correct activation file, and click the Delete button. 

A Delete Confirmation message appears. 

5. Click Yes to begin the deletion. 

The hardware activation file is deleted from the library, and the Currently 
Installed Hardware Activation Files section updates. 

6. Depending on the feature included in the hardware activation file, you may 
need to perform additional tasks after deleting the key. 
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• See “Delete a Partition” on page 148 for special considerations that apply when 
you delete a Partitioning hardware activation file.
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▼Display the Feature Audit Log 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display a list of all feature activation activity that has occurred 
over the life of the library. You can use this log to verify the validity of all features 
installed on the library. 

Note – This feature is available starting with SL8500 firmware 
version FRS_7.00 and SL Console version 5.50. 

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 23.

Task Steps

1. Select Tools > Reports. 

2. Expand the Audit Logs folder, and click the Feature Audit Log tab. 

The Feature Audit Log appears. 

See “Reports > Feature Audit Log” on page 121 for detailed information about the 
fields.
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Hardware Activation Screen Reference
This section includes detailed descriptions of all SL Console hardware activation file 
screens, arranged by screen navigation path.

For example, Hardware Activation > Install Hardware Activation Keys: indicates 
the screen accessed by clicking:

1. Tools

2. Hardware Activation tab

3. Install Hardware Activation Keys tab

Screen Page 

Hardware Activation > Current Hardware Activation Keys  113

Hardware Activation > Install Hardware Activation Keys  115

Hardware Activation >Delete Hardware Activation Files  118

Reports > Feature Audit Log  121

Note – You can access the hardware activation file screens only 
from the standalone SL Console or the Web-launched SL Console. 
They are not accessible  from the local operator panel. 



Hardware Activation Screen Reference

Hardware Activation Files   113

Hardware Activation > Current Hardware Activation Keys

Sample Screen 

Description

Displays the contents of the hardware activation files currently installed on the 
library you are logged in to. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 23 for details. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Feature 

Name of the feature activated on the library. 

Expiration 

Number of days until the feature is due to expire or has expired. If there is no 
expiration date, the field displays “noExpiration.” 
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Value 

Qualification for the feature, if applicable. For example, for the Capacity feature, 
this field displays the capacity the activation file provides. Depending on the 
feature, the field may be blank or indicate “None.” 

Time Remaining

Amount of time remaining until the expiration of the feature. If there is no 
expiration date, the field is blank. 

Buttons

Refresh

Click to refresh the display with current data from the library controller database.

? (Help) 

Click to display online help for the screen. 

See Also

“Hardware Activation > Install Hardware Activation Keys” on page 115 
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Hardware Activation > Install Hardware Activation Keys

Sample Screen 

Description

Enables you to display the contents of a new hardware activation file and install it on 
the library. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 23 for details. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

File Name

Required.

Enter the full path of the hardware activation file you want to install on the 
library. Optionally, you can click Browse and navigate to the file location. The file 
must be located on a system accessible to the SL Console session. 

Product

Display only.

Type of library. For example, SL8500, SL3000 or SL500. 

Serial Number

Display only.

Serial number of the library the hardware activation file is for. This entry applies 
only to legacy hardware activation files. See “Legacy Hardware Activation 
Files” on page 98 for details. 

Generated On

Display only.

Date when the hardware activation file was created. 

Key Type

Display only.

Type of hardware. Options are:
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• Oracle Hardware Activation File: File downloaded from the Oracle Software 
Delivery Cloud. 

• Sun Hardware Activation File: Legacy file.  See “Legacy Hardware Activation 
Files” on page 98  for details. 

Comment Line 1

Display only.

Optional comment concerning the hardware activation file, from Oracle 
Corporation 

Comment Line 2

Display only.

Optional comment concerning the hardware activation file, from Oracle 
Corporation 

Hardware Activation File Details

Feature

Display only.

Name of a feature included in the hardware activation file.

Expiration

Display only.

Number of days until the feature is due to expire. If there is no expiration date, 
the field displays “noExpiration.”

Value 

Display only.

Qualification for the feature, if applicable. For example, for the Capacity feature, 
this field displays the amount of storage capacity the activation file provides. 
Depending on the feature, the field may be blank. 

Buttons

Install

Click to install the displayed hardware activation file on the library you are 
logged in to.

Browse

Click to navigate to the hardware activation file you want to display and install.

? (Help) 

Click to display online help for the screen. 
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See Also 

• “Hardware Activation > Current Hardware Activation Keys” on page 113 

• “Hardware Activation >Delete Hardware Activation Files” on page 118 
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Hardware Activation >Delete Hardware Activation Files

Sample Screen

Description

Enables you to review and delete selected hardware activation files from the 
library. Only customer-installed hardware activation files appear on this screen for 
deletion. 

Caution – Significant impact on operations. Deleting a hardware 
activation file is an exceptional situation and can have significant 
effects on library operations. See “Delete a Hardware Activation 
File” on page 109 for considerations. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console
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Screen Fields

Currently Installed Hardware Activation Files

File Number

Display only.

ID number assigned to the hardware activation file. The numbers indicate the 
sequence in which the features were installed on the library. There may be gaps in 
the sequence, which may result from one of the following reasons:

• A feature was deleted.

• A feature was installed and enabled by an Oracle support representative, and 
therefore does not appear on this list. 

Key Type

Display only.

Type of hardware activation file. Options are:

• incremental: Oracle hardware activation file downloaded from the Oracle 
Software Delivery Cloud. 

• absolute: Legacy Sun hardware Activation file. See “Legacy Hardware 
Activation Files” on page 98 for details. 

Associated Activation Feature Detail(s)

Feature 

Name of the feature activated on the library. 

Expiration 

Number of days until the feature is due to expire or has expired. If there is no 
expiration date, the field displays “noExpiration.” 

Value 

Display only.

Qualification for the feature, if applicable. For example, for the Capacity feature, 
this field displays the capacity the activation file provides. Depending on the 
feature, the field may be blank or may indicate “None.” 

Buttons

Delete

Click to delete the currently selected hardware activation file.

? (Help) 

Click to display online help for the screen. 
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See Also

• “Hardware Activation > Install Hardware Activation Keys” on page 115 
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Reports > Feature Audit Log

Sample Screen 

Description

Displays a list of all feature activation activity that has occurred over the life of the 
library. You can use this log to verify the validity of all features installed on the 
library. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Feature Name

Name of the feature. 

The first line of the display is the type of library. 

Feature Value

Special attributes of the feature. Options are:

• SN: Indicates that the serial number of the library is displayed in the Feature 
Action  field. Appears on the first line of the display.

• nnnn: For capacity hardware activation files, the number of cells added or 
removed. 
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• none: Appears for all other features. 

Feature Action

Action that was performed. Options are:

• nnnnnnnn: Serial number of the library. Appears on the first line of the display.

• deleted: The hardware activation file for the feature was deleted.

• disabled: The feature was disabled by an Oracle support representative. 

• enabled: The feature was enabled by an Oracle support representative.

• installed: The hardware activation file for the feature was installed. 

• Summary: The feature is active on the library. 

Action Date

Date and time when the action was performed. 

Buttons

Search

Click to search a library report for a specified text string.

Update

Click to update the report with current data.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• “Hardware Activation > Current Hardware Activation Keys” on page 113 

• “Hardware Activation > Install Hardware Activation Keys” on page 115 
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5

Library Partitioning

Note – Library partitioning is an optional feature which you can 
enable through the hardware activation process. For details, see 
“Hardware Activation Files” on page 97. This feature is available 
starting with SL8500 firmware version 3.70 and SLC version 3.25. 
See “Verifying System Requirements for Library 
Partitioning” on page 125 for complete details. 

Library partitioning reserves specified library resources for the exclusive use of 
specified hosts, so up to 8 hosts can share a single SL8500 library. For example, you 
can reserve one side of the library for an HSC mainframe host and the other for an 
ACSLS open-systems host. Or you can reserve the uppermost rail in the library for 
backing up your resource and development environment, the middle two rails for 
backing up your financial transactions, and the remaining rails for backing up the 
rest of your IT resources. 

This chapter’s topics include:

• “Overview of SL8500 Partitioning” on page 123

• “Planning and Preparations” on page 125

• “Library Partitioning Tasks” on page 127

• “CAP Operation Tasks” on page 150

Overview of SL8500 Partitioning
This section explains how SL8500 library partitioning affects hosts and library 
resources. Topics include:

• “Partitions and Capacity” on page 123

• “Hosts, Partitions, and Storage Resources” on page 124

• “Hosts, Partitions, and Library Mechanical Resources” on page 124

Partitions and Capacity 

In a partitioned library, the library controller does not automatically activate the 
number of physical storage cells specified in the hardware activation files. Instead, 
the controller activates individual physical cells as you allocate them to partitions. It 
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subtracts the number allocated to each partition from the total authorized in the 
Hardware Activation Files. The sum of the cells allocated to the partitions thus never 
exceeds the purchased capacity of the library.

Hosts, Partitions, and Storage Resources

An SL8500 library host has full-time exclusive access to all available storage resources 
in an SL8500 partition. It owns all tape drives, storage slots, and cartridges that are 
available to it, just as it would if these resources were located in a freestanding, 
unpartitioned library. The host has no access to resources that are assigned to other 
partitions in the library. Such resources might as well be located in a physically 
separate piece of equipment. 

Individual, Oracle StorageTek ACSLS hosts can control one or more SL8500 library 
partitions. Individual HSC hosts and groups of up to 16 HSC hosts that share a 
Common Control Dataset (CDS) can control a single partition.

Hosts, Partitions, and Library Mechanical Resources

While SL8500 library hosts enjoy full-time, exclusive use of storage resources, they 
must share library mechanical resources like robotics and Cartridge Access Ports 
(CAPs). Each host must reserve these resources for exclusive use when needed and 
must release them when they are no longer required. 

Since only one partition can use the CAP at a time, a host must temporarily reserve 
the CAP for its exclusive use before it can enter or eject cartridges. A host can reserve 
a CAP if all of the following conditions are met:

• The CAP is not already reserved by any other partition. 

• The CAP is empty.

• The CAP is closed and locked.

Once a host successfully reserves the CAP, the library directs CAP messages (CAP 
opened, CAP closed, etc.) to the reservation holder alone. No other host partition can 
use the CAP or reserve it for use. If a host tries to reserve a CAP that has already 
been reserved, the library controller notifies host and reports the partition ID and 
host ID that hold the reservation.

When a host finishes a CAP operation, it releases the reservation and makes the CAP 
available to other host partitions. Normally, this happens in one of two ways:

• After all cartridges have been successfully entered into the library, the user 
explicitly terminates the HSC or ACSLS enter command, and the library releases 
the CAP after verifying that the CAP is closed and empty. 

• After all cartridges have been successfully ejected, the host automatically 
terminates the HSC or ACSLS eject operation, and the library controller releases 
the CAP after verifying that the CAP is closed and empty. 

If for any reason a CAP reservation is not released, other host partitions cannot access 
the CAP. If the enter or eject command cannot be terminated in ACSLS or HSC on the 
host, a library administrator has to override the host partition reservation (for details, 
see “Override a CAP Reservation” on page 151).
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Note – When multiple hosts share access to CAPs, automatic CAP 
mode is not supported. Automatic CAPs let library operators open 
the CAP without issuing an explicit enter request. Since this 
would interfere with the reservation system, the commands that 
enable CAP auto mode are disabled in partitioned libraries.

Planning and Preparations
Library partitioning requires careful planning, a thorough knowledge of library wall 
and slot mapping, and expertise in configuring and administering ACSLS and HSC 
host software applications. There must be clear communication among all parties 
involved, including system programmers and administrators, library operators, and 
your Sun service representative. 

Planning and preparation should include the following activities:

• “Verifying System Requirements for Library Partitioning” on page 125

• “Verifying the Physical Configuration of a Partition” on page 125

• “Resolving Orphaned Cartridges” on page 126

Verifying System Requirements for Library Partitioning

The following are minimum system requirements for library partitioning:

• Activation of the partitioning feature (see “Hardware Activation Files” on page 97 
for details).

• SL8500 firmware version 3.7x

• StorageTek Library Console version 3.25 

• ACSLS version 7.1/7.1.1 with PUT 0701 (Solaris on SPARC)

• ACSLS HA 2.0 with PTF6514766 

• HSC 6.1 with current PTFs 

• NCS, ExPR, VTCS versions 6.1

• ExLM version 6.0

• VSM version 4 and 5

• All pass-thru ports (PTPs) are disabled.

Only single, free-standing libraries are supported. A library complex with 
functional PTPs cannot be partitioned. 

Verifying the Physical Configuration of a Partition

Before creating partitions, you must verify that all tape drives and cartridges have 
been moved to the proper location, according to the planned host/rail assignments. 
For example, if rails 1 and 2 will be owned by an ACSLS host, only ACSLS-
compatible drives can be installed at those rail positions, and all cartridges 
containing data for the ACSLS host must be migrated to those rails. 
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Resolving Orphaned Cartridges

When you change the capacity of a partition, delete a partition, or inadvertently 
move a cartridge to a cell or drive that is not allocated to a partition, the cartridge 
becomes inaccessible to the host that created it. The cartridge is referred to as 
orphaned. 

In a partitioned library, orphaned cartridges can cause data loss. To its host, a 
partition appears to be a complete standalone library. The host has no knowledge of 
other partitions on the physical library. So a host that finds an orphaned cartridge in 
its partition may treat the cartridge as a scratch volume and overwrite the data. 

Orphaned cartridges are thus serious problems that need to be resolved. When the 
SLC identifies orphaned cartridges, it warns you and provides the detail information 
that you need. You can then resolve the orphaned cartridges by performing recovery 
moves on listed cartridges. 

Recovery moves transfer the orphans to accessible locations within their parent 
partitions. For more information, see “Recovery Moves” on page 252.
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Library Partitioning Tasks

Task Page

Prepare for Partitioning  128

Add Partition Definitions  129

Allocate Library Resources to Partitions  132

Verify Partition Design and Resource Allocations  138

Commit Partitioning Changes  141

Generate Partitioning Reports  143

Delete a Partition  148
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▼ Prepare for Partitioning

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to prepare for partitioning the SL8500 library.

Task Steps

1. Quiesce any host software that carries out library operations. 

Host applications—library management software (ACSLS, ELS, etc.) and data 
management software, like backup and archiving applications—should not try to 
use the library during partitioning.

2. Select Tools > Partitions. 

The Partitions screen appears with the Instructions (Step 1) tab selected.

3. Review the Instructions (Step 1) tab carefully.
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▼Add Partition Definitions

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to add partition definitions.

Task Steps

1. When you are ready to define the partitions, select the Summary (Step 2) tab of 
the partitions interface.

2. On the left side of the Summary (Step 2) tab, note the Total Library Resources 
(storage cells, drive bays, CAPs and CAP cells, and activated capacity), the 
Resources Allocated, and the Resources Unallocated. 

If the library has not previously been partitioned, no resources will be allocated 
and the full capacity will be unallocated.

3. On the right side of the Summary (Step 2) tab, note the Partition Allocation 
Summary that displays the currently configured partitions (if any). Note the 
Add Partition, Delete Partition, and Modify Partition buttons.
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4. In the Partition Allocation Summary area, click the Add Partition button.

Note that this step adds a partition to the planned configuration, but does not 
actually make any changes to the library. No resources are actually allocated until 
the design is applied using the Commit (Step 4) tab.

5. When the Add a Partition dialog appears, use the list control to Select a 
partition ID. If desired, enter a Name in the text box provided. Click the OK 
button to continue.

The partition ID is a numeric label, but need not be selected consecutively. The 
Name can be anything. It might, for instance, explain the organizational principal 
behind the partition, such as the type of host application controlling the partition 
(ACSLS or HSC), the organization that owns the data (Finance, Engineering, etc.), 
or some other, logical identifier.

The new partition is now listed in the Partition Allocation Summary table on the 
Summary (Step 2) sheet. The Name of the partition is displayed below the table.
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6. When you return to the Summary (Step 2) sheet, repeat steps 4-5 until you have 
added all required partitions.
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▼Allocate Library Resources to Partitions

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to allocate library resources to one or more partitions.

After you have added all necessary partitions, you need to assign them storage. To 
minimize implementation effort and maximize maintainability and operational 
flexibility, keep the following guidelines in mind when allocating resources:

• Select storage resources in the largest blocks possible (rails, library sides, and/or 
library walls). 

• To minimize use of the elevator and thus maximize the speed and efficiency of 
cartridge transfers, select complete library rails when possible. 

• For best access to drives, activate library inner and outer library walls together, as 
a unit, when possible. The inner walls do not hold drives. 

• Avoid selecting individual drives and storage cell arrays piecemeal. Individually 
select and deselect resources only when you must or when you need to fine-tune 
a capacity that has already been broadly defined in larger blocks.

• When rapid import and export of cartridges is a priority, activate storage cells that 
are close to the Cartridge Access Ports (CAPs).

• When rapid access to stored data is a priority, activate storage cells that are close 
to the tape drives.

Task Steps

1. Select the Design by Library (Step 3) tab of the Partitions interface.

2. On the Design by Library (Step 3) sheet, use the list control to select the 
ID number of the partition that you want to configure.

3. To add all rails to the partition, use the list control to select All Rails.
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4. To add a specified rail, use the list control to select Rail 1, Rail 2, Rail 3, or 
Rail 4.

5. To add both sides of the library to the partition, use the list control to select 
Left/Right Sides.

6. To add only one side of the library to the partition, use the list control to select 
Left Side or Right Side.

7. To add both the inside and outside walls of the library to the partition, use the 
list control to select Inside/Outside Walls.
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8. To add only one wall to the partition, use the list control to select the Inside 
Wall or the Outside Wall.

9. Click the Add button to allocate the specified resources to the partition. 

10. To allocate additional resources to the partition, repeat steps 3 to 8 as needed.
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11. To deallocate individual drives or cell arrays from the partition, use the rails list 
control to select Remove Array. Then click on drive(s) and/or array(s) that you 
wish to remove from the partition. 

Storage cell arrays are magazines that hold cartridges within the library. 
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12. To allocate individual drives or cell arrays to the partition, use the rails list 
control to select Add Array. Then click on the drive(s) and/or array(s) that you 
wish to add to the partition.

13. For each additional partition that you wish to add to the library, repeat 
steps 2-12.
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▼ Verify Partition Design and Resource Allocations

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to verify the partition design(s) and resource allocations.

Task Steps

1. After you have assigned the planned resources to all partitions, test the planned 
configuration. In the upper right corner of the Design by Library (Step 3) tab of 
the Partitions interface, click the Verify button. 
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2. If the Verify Results dialog reports Warnings Found, click the Details >> button 
and examine the Verify Results detail report for orphaned cartridges.

In partitioned libraries, an orphaned cartridge is a cartridge located in an 
unallocated cell or drive (that is, a cell or drive not allocated to any defined 
partition). Cartridges may become orphaned when partition boundaries are 
changed, partitions are deleted, or cartridges are manually moved to unallocated 
or inaccessible cells. 

3. If you want to print warning messages, click the Print button in the detail 
report of the Verify Results dialog.

4. If you want to save warning messages in a comma-delimited text file, click the 
Save button in the detail report of the Verify Results dialog. 

5. If the Verify Results dialog reports orphaned cartridges, click the OK button, 
and do not proceed further until you perform recovery moves on the listed 
volumes. 

See “Recovery Moves” on page 252. You must correctly resolve orphaned 
cartridges before proceeding further, because hosts may treat orphans as scratch 
cartridges and overwrite valid data.
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6. If you resolved orphaned cartridges, reverify the configuration. Repeat this 
procedure.

7. Otherwise, if the Verify Results dialog reports No Warnings Found, go to 
“Commit Partitioning Changes” on page 141.
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▼Commit Partitioning Changes

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to apply the partition configuration you have designed to the 
library.

Task Steps

1. When all partitions have been configured, select the Commit (Step 4) tab, and 
review the instructions.

2. When you are sure that you are ready, click the Apply button at upper right.

3. If the Confirm Apply dialog indicates Warnings Found, click the Details >> 
button to view the warning messages.
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4. If the detail report indicates orphaned cartridges, click the No button, and do 
not proceed further until you perform recovery moves on the listed volumes. 

See “Recovery Moves” on page 252. You must correctly resolve orphaned 
cartridges before proceeding further, because hosts may treat orphans as scratch 
cartridges and overwrite valid data.

5. If the Commit Success dialog appears, click OK. 

The library has been successfully partitioned.
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▼Generate Partitioning Reports

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to generate reports on the partition configuration.

Task Steps

1. Select the Reports tab of the Partitioning interface.

2. Use the list control to select the desired type of report.
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3. To view cell addresses and volume serial numbers (volsers) for the media in 
each partition, select a Cartridge Cell and Media Summary report.
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4. To identify orphaned media, select an Orphaned Cartridge Report.

In partitioned libraries, an orphaned cartridge is a cartridge located in an 
unallocated cell or drive (that is, a cell or drive not allocated to any defined 
partition). Cartridges may become orphaned when partition boundaries are 
changed, partitions are deleted, or cartridges are manually moved to unallocated 
or inaccessible cells. 
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5. To view a summary of partition characteristics, select a Partition Summary.

6. For more detailed information on a specific partition, select a Partition Details 
report and specify the partition using the Partition ID list control. 
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7. To Print a hard copy of a report, click the Print button.

8. To save a report to a comma-separated value (csv) file compatible with most 
spreadsheets, click the Save To File button. 
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▼Delete a Partition

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to delete a partition from the library. 

When you delete a partition, the following changes are made to the library partition 
configuration:

• All resources allocated to the partition are marked available. 

• All host connections for the partition are deleted. 

• The partition ID is deleted. 

Task Steps

1. To prevent orphaned cartridges, move volumes that hold valid data out of the 
partition that you intend to delete before proceeding further. 

2. When you are ready to delete the partition, select the Summary (Step 2) tab of 
the partitions interface.

3. In the Partition Allocation Summary area, select the table row corresponding to 
the partition number of the partition that you want to delete.
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4. Click the Delete Partition button.

Note that this step deletes the partition from the current, working configuration, 
but does not actually make any changes to the library. The partition is not actually 
deleted until you click the Commit (Step 4) tab.

5. When the confirmation dialog appears, make sure that the correct partition 
number is displayed.

6. If all is as it should be, click OK to delete the partition from the current 
configuration. Otherwise, click Cancel.

7. If you pressed OK, verify the change to the partitioning configuration. See 
“Verify Partition Design and Resource Allocations” on page 138.

8. If the verification process generates warnings, check the details to see if 
orphaned cartridges are reported.

9. If orphaned cartridges were found, perform recovery moves on all listed 
volumes.

See “Recovery Moves” on page 252. If you do not move orphaned volumes to 
partitions that are configured to hold them, a host application that subsequently 
finds them will treat them as scratch cartridges and may overwrite valid data. 

10. Once you have resolved all orphaned cartridges, reverify the partitioning 
configuration.

11. When verification reports no warnings, commit the changes. See “Commit 
Partitioning Changes” on page 141.
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CAP Operation Tasks

Task Page

Override a CAP Reservation   151
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▼ Override a CAP Reservation

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to override an existing CAP reservation.

Task Steps

Note – You must follow all steps in this procedure. If you do not 
complete the procedure, the CAP could be left unavailable to all 
partitions, and/or cartridges assigned to one partition could be 
entered into another partition. 

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, and click the CAP whose reservation you want to 
override (unreserve). 

3. Click the Unreserve tab.

The Unreserve page appears, identifying the partition (hli1, hli2, hli3, hli4, or 
default) that has reserved the CAP.

4. Click Apply to override the reservation.

5. The page displays the dialog, “This will remove the reservation from the 
designated host...”

• Select OK to continue with the override operation. The library removes the 
CAP reservation and sets the CAP user to “default,” which makes the CAP 
unavailable to all partitions.

• Select Cancel to cancel the override operation and return to Step 4. 

6. If the CAP is locked, unlock it at the SLC. 

7. Open the CAP. 

• If it is empty, proceed to Step 9. 

• If it contains cartridges, remove them all. 

8. Label the cartridges with the partition ID displayed in Step 2. 

9. Close the CAP. It locks automatically.

The library locks and audits the CAP to verify that it is empty. It then sets the 
CAP status to “unreserved,” which makes the CAP available to all partitions. 

Note – You might need to refresh the CAP display to see the new 
CAP status. 
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10. Contact a person responsible for managing the removed cartridges to determine 
their disposition. If they are to be re-entered into the library, they must be 
entered to the correct partition.
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Partitioning Screen Reference
This section includes detailed descriptions of all SLC partition screens, arranged by 
screen navigation path. For example, Partitions—Summary (Step 2)—Add 
Connection indicates the screen accessed by clicking Tools and then Partitions from 
the Menu Bar, and then clicking the Summary (Step 2) tab, and then the 
Add Connection button. 

Note – Library partitioning must be enabled by your Oracle 
StorageTek service representative. This feature is available starting 
with SL8500 firmware version 3.7x and SLC version 3.25. See 
“Verifying System Requirements for Library 
Partitioning” on page 125 for complete details. 

Note – The partition Summary (Step 2) and Design (Step 3) 
screens, and all associated pop-ups, give you a dynamic 
workspace to design your library partitions. All partition 
configuration information is automatically saved to the partition 
workspace in SLC memory and retained for the duration of your 
SLC session. This allows you to switch among partition views and 
leave and return to the partition screens any number of times 
without losing your configuration changes. 

Caution – Information in the SLC partition workspace is saved to 
the library controller database only through the Commit (Step 4) 
screen. If your SLC session ends or you refresh the workspace data 
before you have committed your updates through the Commit 
(Step 4) screen, you will lose any partition changes you have made 
through the Summary (Step 2) and Design (Step 3) screens and all 
associated pop-ups. 
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Partition Summary Screens

Screen Page

Partitions—Instructions (Step 1)  155

Partitions—Summary (Step 2)  156

Partitions—Summary (Step 2)—Add a Partition  160

Partitions—Summary (Step 2)—Confirm Deletion of a Partition  161

Partitions—Summary (Step 2)—Modify a Partition  162

Partitions—Design by Library (Step 3)  163

Partitions—Design by Library (Step 3)—Partition Refresh  166

Partitions—Design by Library (Step 3)—Verify Results  167

Partitions—Commit (Step 4)  169

Partitions—Commit (Step 4)—Confirm Apply  171

Partitions—Commit (Step 4)—Commit Success  173

Partitions—Reports  174

Partitions—Reports—Cartridge Cell and Media Summary  175

Partitions—Reports—Orphaned Cartridge Report  177

Partitions—Reports—Partition Summary  179

Partitions—Reports—Partition Details  181
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Partitions—Instructions (Step 1)

Sample Screen

Description

Displays instructions for using the partitioning screens.

Note – This screen appears automatically the first time you select 
Tools > Partitions during an SLC login session. 

Screen Fields

None

Buttons

? (Help) 

The ? button displays online help for the screen. 

See Also

• Partitions—Summary (Step 2)

• Partitions—Design by Library (Step 3)

• Partitions—Commit (Step 4)

• Partitions—Reports
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Partitions—Summary (Step 2)

Sample Screen

Description

Summarizes total library resources optionally, resources allocated to partitions, and 
remaining, unallocated resources. Lists partitions (if any) and the resources assigned 
to them, including storage cells, drive bays, Cartridge Access Ports (CAPs), CAP 
cells, and the percentage of the capacity that has been activated. 

Buttons let you to carry out the following activities:

• Adding a new partition 

• Deleting a partition

• Modifying a partition name and/or identifier. 

Screen Fields

Partition Allocation Summary

This section of the interface summarizes the configuration of each of the partitions 
that have been configured on the library (if any).
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Partition Number

Display only.

ID assigned to the partition. IDs can range from 1–8.

Storage Cells

Display only.

The number of storage cells allocated to this partition. 

Drive Bays

Display only.

The number of tape drives allocated to this partition. 

CAPs

The number of Cartridge Access Ports (CAPs) allocated to this partition.

CAP Cells

Display only.

The number of individual CAP cells allocated to this partition. 

%Activated Capacity 

Display only.

The percentage of the activated capacity allocated to this partition. Activated 
capacity is the physical library capacity that has bee n enabled by installing 
hardware activation files.

Total Library Resources

This section of the interface summarizes the combined resources that are available in 
the library. 

Storage Cells 

Display only.

The total number of storage cells available for use in library partitions 

Drive Bays 

Display only.

The total number of tape drives available for use by library partitions.

CAP cells

Display only.

The total number of CAP cells available for use by library partitions.
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Activated Capacity

Display only.

The total capacity enabled by hardware activation files that have been installed.

Resources Allocated

Storage Cells

Display only.

The total number of storage cells that have already been allocated to partitions.

Drive Bays

Display only.

The total number of drive bays that have already been allocated to partitions.

Activated Capacity

Display only.

The activated capacity that has already been committed to partitions.

Resources Unallocated

Storage Cells

Display only.

The total number of storage cells that are still available for allocation to partitions.

Drive Bays

Display only.

The total number of drive bays that are still available for allocation to partitions.

Activated Capacity

Display only.

The total activated capacity that has not yet been committed to partitions and is 
still available for allocation.

Buttons

Refresh 

The Refresh button brings up a Partition Refresh confirmation dialog. When you 
confirm the refresh, the SLC discards any uncommitted partition changes that you 
have made and updates the partition workspace with the most recent data stored 
in the library controller database. 
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? (Help)

The ? button displays online help for the screen. 

Add Partition

The Add Partition button launches the Partitions—Summary (Step 2)—Add a 
Partition dialog. The dialog lets you create a name and identifier for a new 
partition. 

Delete Partition

The Delete Partition button launches a confirmation dialog that asks if you are 
sure that you want to delete the partition record that is currently highlighted in 
the Partitions—Reports—Partition Summary table. 

Modify Partition

Click to modify summary information for the currently selected partition. The 
Partitions—Summary (Step 2)—Modify a Partition message appears. 

See Also

• Partitions—Instructions (Step 1)

• Partitions—Summary (Step 2)—Add a Partition

• Partitions—Summary (Step 2)—Confirm Deletion of a Partition

• Partitions—Summary (Step 2)—Modify a Partition.

• Partitions—Design by Library (Step 3)

• Partitions—Commit (Step 4)

• Partitions—Reports
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Partitions—Summary (Step 2)—Add a Partition

Sample Screen

Description

Adds a partition record to the library controller database. 

Screen Fields

Select a partition ID

Required.

This list control lets you select a numeric partition identifier in the range 1-8. You 
do not need to select ID values consecutively.

Name

Optional.

This text field lets you assign a more memorable, user-friendly identifier for the 
library. For example, you might use the name of the office location, network 
segment, or organization that will store data in the partition.

Buttons

OK

Adds the partition record to the library controller database and returns you to the 
Partitions—Summary (Step 2) interface.

Cancel

Returns you to the Partitions—Summary (Step 2) interface.

See Also

• Partitions—Summary (Step 2)
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Partitions—Summary (Step 2)—Confirm Deletion of a Partition

Sample Screen

Description

Confirms the deletion of a partition. 

Screen Fields

None.

Buttons

OK

Confirms the deletion, deletes the partition, and returns you to the 
Partitions—Summary (Step 2) interface.

Cancel

Returns you to the Partitions—Summary (Step 2) interface.

See Also

• Partitions—Summary (Step 2)
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Partitions—Summary (Step 2)—Modify a Partition

Summary Screen

Description

Modifies a partition record currently stored in the library controller database. 

Screen Fields

Name

Optional.

This text field lets you assignor change a user-friendly identifier for the library. 
For example, you might use the name of the office location, network segment, or 
organization that will store data in the partition.

Buttons

OK

Adds the partition record to the library controller database and returns you to the  
Partitions—Summary (Step 2) interface.

Cancel

Returns you to the Partitions—Summary (Step 2) interface.

See Also

• Partitions—Summary (Step 2)
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Partitions—Design by Library (Step 3)

Sample Screen

Note – The complete screen is too large for a single page. The 
inside wall and the right side of the library are not shown. The 
modules in the left side outer wall have been represented by 
wrapping them to fit the available space, and, for clarity, all 
selectors have been shown expanded. 

Description

Presents a graphical, interactive display/workspace representing the resources and 
partitions in the library. Lets you allocate rails, walls, sides, drives, Cartridge Access 
Ports (CAPs), and arrays of storage cells to library partitions. 

Screen Fields

None.
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Buttons and Controls

Partition (unlabeled control)

List of partition numbers with color codes. 

Defaults to the first partition defined.

Lets you select the current working partition from the list defined on the  
Partitions—Summary (Step 2) tab. Displays the currently allocated resources for 
the selected partition using the color code for the partition.

Rail/Array (unlabeled control)

List of choices: All Rails, Rail 1, Rail 2, Rail 3, Rail 4, Add Array, Remove Array.

Default value: All Rails.

Select All Rails to include resources (storage-cell arrays and drives) on rails 1-4 to 
the current selection.

Select Rail 1 | Rail 2 | Rail 3 |Rail 4 to include resources (storage-cell arrays and 
drives) on the specified rail to the current selection.

Select Add Array to include a specific array of storage cells to the current 
selection. Select the array by clicking on the corresponding cell-array rectangle in 
the graphical display.

Select Remove Array to remove a specific array of storage cells from the current 
selection. Select the array by clicking on the corresponding cell-array rectangle in 
the graphical display.

Left/Right Sides (unlabeled control)

List of choices: Left/Right Sides, Left Side, Right Side. 

Default value: Left/Right Sides.

Select Left/Right Sides to include resources (storage-cell arrays and drives) from 
both sides of the library in the current selection.

Select Left Side or Right Side to include resources (storage-cell arrays and drives) 
from the specified side of the library in the current selection. 

Inside/Outside Walls (unlabeled control)

List of choices: Inside/Outside Walls, Inside Wall, Outside Wall.

Default value: Inside/Outside Walls.

Select Inside/Outside Walls to include resources (storage-cell arrays and drives) 
from both walls of the library in the current selection.

Select Inside Wall or Outside Wall to include resources (storage-cell arrays and 
drives) from the specified wall of the library in the current selection. 

Add 

Button.

Click Add to include the current selection in the current partition.
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Remove 

Button.

Click Remove to remove the current selection from the current partition.

Verify

Button.

Click Verify to test the new partition configuration for errors without committing 
the changes. 

Refresh 

Button.

Click Refresh to discard uncommitted changes to the partition configuration (if 
any) and update the partition workspace with the most recent data stored in the 
library controller database. 

? (Help)

The ? button displays online help for the screen. 

See Also

• Partitions—Instructions (Step 1)

• Partitions—Summary (Step 2)

• Partitions—Design by Library (Step 3)—Partition Refresh

• Partitions—Design by Library (Step 3)—Verify Results

• Partitions—Reports
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Partitions—Design by Library (Step 3)—Partition Refresh

Sample Screen

Description

Discards uncommitted changes (if any) and reloads the partition workspace using the 
most recent data stored in the library controller database. 

Screen Fields

None.

Buttons

Yes

Confirms the refresh, discards uncommitted partitioning changes, and reloads the 
last committed partitioning configuration stored in the library controller database. 
Returns you to the Partitions—Design by Library (Step 3) interface.

Cancel

Returns you to the Partitions—Design by Library (Step 3) interface without 
discarding uncommitted changes.

See Also

• Partitions—Design by Library (Step 3)
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Partitions—Design by Library (Step 3)—Verify Results

Sample Screen (Warnings)

Sample Screen (Warning Details)

Description

Warns you of the presence of orphaned cartridges (cartridges that are located in 
cells or drives that are not allocated to a partition). Cartridges may become 
orphaned when partition boundaries are changed, partitions are deleted, or 
cartridges are manually moved to unallocated or inaccessible cells. Optionally 
displays a detailed listing of the orphaned cartridges.
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Screen Fields

Warnings

None.

Warning Details

Orphaned cartridges table

Lists orphaned cartridges by Rail, Column, Side, Row, and Vol Ser (volume serial 
number), along with the Cause of the orphan condition (if known) and a brief 
Explanation.

Buttons

OK

Returns you to the Partitions—Design by Library (Step 3) interface.

Details >>

Opens the detailed warnings view.

<< Details

Returns you to the simplified view.

See Also

• Partitions—Design by Library (Step 3)
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Partitions—Commit (Step 4)

Sample Screen

Description

Displays a brief set of instructions for partitioning a library.

Screen Fields

None.

Buttons

Apply

Verifies the partition configuration. Returns a Confirm Apply dialog if warnings 
are found. Otherwise, stores the new partitioning configuration in the library 
controller database and returns a Commit Success dialog.

? (Help)

The ? button displays online help for the screen. 

See Also

• Partitions—Instructions (Step 1)

• Partitions—Summary (Step 2)

• Partitions—Design by Library (Step 3)
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• Partitions—Commit (Step 4)—Confirm Apply

• Partitions—Commit (Step 4)—Commit Success

• Partitions—Reports
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Partitions—Commit (Step 4)—Confirm Apply

Sample Screen (Warnings)

Sample Screen (Warning Details)

Description

Warns you of the presence of orphaned cartridges which are cartridges that are 
located in cells or drives that are not allocated to a partition. Cartridges may become 
orphaned when partition boundaries are changed, partitions are deleted, or 
cartridges are manually moved to unallocated or inaccessible cells. Optionally 
displays a detailed listing of the orphaned cartridges.



Partition Summary Screens

172  SL8500 User’s Guide  

 

Screen Fields

Warnings

None.

Warning Details

Orphaned cartridges table

Lists orphaned cartridges by Rail, Column, Side, Row, and Vol Ser (volume serial 
number), along with the Cause of the orphan condition (if known) and a brief 
Explanation.

Buttons

Yes

Ignores the warnings and commits the changes. Returns you to the 
Partitions—Commit (Step 4) interface.

No

Returns you to the Partitions—Commit (Step 4) interface.

Details >>

Opens the detailed warnings view.

<< Details

Returns you to the simplified view.

Print

In the detail view, prints the warnings.

Save

In the detail view, saves the warnings to a comma-separated value (csv) file 
compatible with most spreadsheet applications.

See Also

• Partitions—Commit (Step 4)
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Partitions—Commit (Step 4)—Commit Success

Sample Screen

Description

Notifies you when partitioning changes are successfully committed to the library 
controller database.

Screen Fields

None.

Buttons

OK

Closes the dialog.

See Also

• Partitions—Commit (Step 4) 
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Partitions—Reports 

Sample Screen

Description

Selects from a set of predefined partition reports.

Screen Fields

None.

Buttons and Controls

Please select a report to display

List of choices: Cartridge Cell and Media Summary, Orphaned Cartridge Report, 
Partition Summary, Partition Details. 

Select an option to view the corresponding report.

? (Help)

The ? button displays online help for the screen. 

See Also

• Partitions—Instructions (Step 1)

• Partitions—Summary (Step 2)

• Partitions—Design by Library (Step 3)

• Partitions—Commit (Step 4)
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Partitions—Reports—Cartridge Cell and Media Summary

Sample Screen

Description

A report listing the storage cells and media assigned to each partition in the library.

Screen Fields

Cell and Media Summary

Table listing storage cells and media by Rail, Column, Side, Row, Partition ID, 
Partition Name, Element Type, Vol Ser (volume serial number), Cell Status, and 
HLI Address. 

Buttons and Controls

Report Selector (unlabeled control)

List of choices: Cartridge Cell and Media Summary (selected), Orphaned 
Cartridge Report, Partition Summary, Partition Details. 

Select an option to view the corresponding report.

Print

Button.

Click Print to print the report.
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Save to File

Button.

Click Save to File to save the report as a comma-separated value (csv) file 
compatible with most spreadsheet applications.

? (Help)

The ? button displays online help for the screen. 

See Also

• Partitions—Reports
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Partitions—Reports—Orphaned Cartridge Report

Sample Screen

Description

The report lists orphaned cartridges (cartridges that are located in cells or drives that 
are not allocated to a partition). You may orphan cartridges by changing partition 
boundaries, deleting partitions, or manually moving cartridges to unallocated or 
inaccessible cells. 

You must correctly resolve orphaned cartridges, because hosts may treat orphans as 
scratch cartridges and overwrite valid data. To its host, a partition appears to be a 
complete standalone library. The host has no knowledge of other partitions on the 
physical library. So a host that finds an orphaned cartridge in its partition may use 
the cartridge as a scratch volume. 

Screen Fields

Orphaned Cartridges (unlabeled control)

Table listing orphaned cartridges by Rail, Column, Side, Row, and Vol Ser 
(volume serial number), plus a brief explanation of the reason why the cartridge is 
an orphan. 
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Buttons and Controls

Report Selector (unlabeled control)

List of choices: Cartridge Cell and Media Summary, Orphaned Cartridge 
Report (selected), Partition Summary, Partition Details. 

Select an option to view the corresponding report.

Print

Button.

Click Print to print the report.

Save to File

Button.

Click Save to File to save the report as a comma-separated value (csv) file 
compatible with most spreadsheet applications.

? (Help)

The ? button displays online help for the screen. 

See Also

• Partitions—Reports
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Partitions—Reports—Partition Summary

Sample Screen

Description

The report summarizes the main characteristics of the partitions in the library. 

Screen Fields

Partitions

Table listing the following data fields for each partition record:

• Partition ID

• Partition Name

• Storage Cells (the number of storage cells available in the partition)

• Media in Storage Cells (the number of data cartridges that currently reside in 
storage cells within the partition

• % Storage Cells with Media (the percentage of storage cells that are currently 
occupied by media cartridges)

• Drives (the number of drives allocated to the partition)

• CAPs (the number of cartridge access ports allocated to the partition) 
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• *Total Media (the number of cartridges in the partition).

Buttons and Controls

Report Selector (unlabeled control)

List of choices: Cartridge Cell and Media Summary, Orphaned Cartridge Report, 
Partition Summary (selected), Partition Details. 

Select an option to view the corresponding report.

Print

Button.

Click Print to print the report.

Save to File

Button.

Click Save to File to save the report as a comma-separated value (csv) file 
compatible with most spreadsheet applications.

? (Help)

The ? button displays online help for the screen. 

See Also

• Partitions—Reports
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Partitions—Reports—Partition Details

Sample Screen

Description

Provides a comprehensive list of partition parameters for the selected partition.

Screen Fields

Details

A table of name-value pairs for the partition parameters.
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Buttons and Controls

Report Selector (unlabeled control)

List of choices: Cartridge Cell and Media Summary, Orphaned Cartridge Report, 
Partition Summary, Partition Details (selected). 

Select an option to view the corresponding report.

Partition ID

Selectable list of the configured partitions.

Print

Button.

Click Print to print the report.

Save to File

Button.

Click Save to File to save the report as a comma-separated value (csv) file 
compatible with most spreadsheet applications.

? (Help)

The ? button displays online help for the screen. 

See Also

• Partitions—Reports
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6

Library Management 

This chapter covers the management of the SL8500 library, including:

• “Automated Mode of Operation” on page 183

• “Library and Device Status” on page 185

• “Library Management Tasks” on page 187

Automated Mode of Operation
When in automated mode of operation, the library or library complex automatically 
mounts and dismounts cartridges without physical intervention by a person.

Automated operations include the following activities:

• Mounting and dismounting cartridges

• Entering and ejecting cartridges through a CAP 

• Pass-thru port (PTP) activities 

• Logging library events

• Drive cleaning 

Cartridge Mount and Dismount Activities

The primary function of the library is the automated mounting and dismounting of 
cartridges. Host mount and dismount commands are accepted by the library 
controller and translated into robotic commands that are performed by the robot. 

Mount Sequence

A simplified mount sequence involves the following steps:

1. A host requests that a specific volume serial number (vol-id or volser) be mounted 
in a drive.

2. The library controller transmits to the host that the vol-id is located within the 
library and a drive is available to satisfy the mount request.

3. The library assumes responsibility for the mount.
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4. The library controller translates the host command into motion commands for the 
robot.

5. The robot takes the cartridge from its storage cell and places it in the drive.

6. The library returns status to the host that the mount operation is completed.

7. The drive performs the read/write activity directed by the host.

Dismount Sequence

A simplified dismount sequence involves the following steps:

1. A host requests that a specific vol-id be dismounted from a drive.

2. The library controller transmits to the host that the vol-id is located in the drive 
and the library is available to satisfy the dismount request.

3. The library assumes responsibility for the dismount.

4. The library controller translates the host command into mechanical commands for 
the robot.

5. The robot takes the cartridge from its storage cell and places it in its home cell.

6. The library returns status to the host that the dismount operation is completed.

Determining When the Library is Not in Automated Mode 

The library is not in automated mode when it is not able to accept host requests. The 
following conditions indicate that the library is not in automated mode:

• A library main access door is open. 

• The robot does not automatically mount and dismount cartridges. 

• The navigation tree in the SL Console indicates that there is a problem with the 
library.
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Library and Device Status
The SL Console screen displays health indicators for each of the following devices:

• Library 

• CAPs 

• Drives

• Robot

FIGURE 6-1 describes the health monitor indicators shown in FIGURE 6-1.

FIGURE 6-1  SL Console Health Status Indicators

Health status indicator and icon descriptions follow:

1: Health status by each device:

• 5: Normal. All library devices are functioning normally. (Green circle with 
check mark)

• 6: Warning. One or more devices in the library is offline or operating in a 
degraded state. (Yellow caution triangle with exclamation point)
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• 7: Error. One or more devices in the library has experienced a failure. (Red stop 
sign shape with black X)

• 2: Communicatino status between SL Console and library controller

• 5: Normal. The heartbeat monitor flashes periodically when the SL Console is 
communicating normally with the library controller.  (Green circle with check 
mark)

• 6: Warning. Appears if the server takes longer than 10 seconds to respond. 
(Yellow caution triangle with exclamation point)

• 7: Error. Appears when the server response takes longer than 30 seconds. (Red 
stop sign shape with black X)

• 3: Userid: User ID currently logged into the SL Console

• 4: Overall health status of library and devices

• 5: Normal. All library devices are functioning normally. (Green circle with 
check mark)

• 6: Warning. One or more devices in the library is offline or operating in a 
degraded state. (Yellow caution triangle with exclamation point)

• 7: Error. One or more devices in the library has experienced a failure. (Red stop 
sign shape with black X)

If there are multiple problems with a device or status alert conditions, the health 
indicator displays the one that is most severe. For example, if the library has been 
taken offline (a “yellow” condition) and a CAP has experienced a failure (a “red” 
condition), the library health indicator will be red. After the CAP problem is fixed, 
the library health indicator will change to yellow. The indicator will not return to 
green until the library has also been taken  online. 

Communications Failures

If the SL Console loses communication with the library controller, after about 30–60 
seconds the heartbeat monitor turns gray, then red, and the following error message 
appears:
Heartbeat message not received from the library controller.

Log off from the SL Console, and then log on again to restore communication.

See “Library Control Path” on page 24 for details. 

• “Host-Managed Drive Cleaning” on page 284 
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Library Management Tasks

Task Page

Display Library Complex Status  189

Display Library Status  188

Clear Library Status Alerts  193

Display HLI Port Status  195

Display Library Configuration Properties  196

Display Library Complex IP Addresses  199

Display Library Controller Properties  200

Display Drive Controller Properties  201
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▼ Display Library Status

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to view the current operational state of the library. These values 
update whenever there is host activity, background operations, or operator activity.

Note – This information is also available through 
Reports > Library Details. See “Display a Library 
Report” on page 51  for detailed instructions. 

Task Steps

1. Select Tools > System Detail, and click the Library folder in the navigation tree.

2. Click the Status tab, and then the General tab.

The page displays the current status of the library. 
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▼ Display Library Complex Status 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

View the current operational state of a library complex. This procedure is applicable 
only if your installation includes a library complex. 

Note – This information is also available through 
Reports > Library Details. See “Display a Library 
Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail, and click the Library folder.

2. Click the Status tab, then the Complex tab.

The page displays the current status of the library complex. 
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▼ Display Library Status Alerts  

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display library status alerts, which can help you to identify 
whether there are any current or pending issues with the library firmware or 
configuration.

You may perform this procedure whenever the library health indicator has changed 
from green to yellow or red, indicating a warning or error. 

Note – This feature is available only if service is active on the 
library. If service is not active on the library, this screen will be 
blank except for a message indicating that the “Service activation 
is not valid.” 

Task Steps

1. Select Tools > System Detail, and click the Library folder. 
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2. Click the Status tab, and then the Status Module tab. 

The page displays all library status alerts. 

Screen Fields

Clear Alert Number 

Optional.

Status alert message you want to clear from the display. 

The list displays numbers 0–20. Although you can select any of these, only the 
numbers that correspond to clearable alert messages shown in the display will 
actually cause a message to be cleared. 

Alert #

Display only.

Sequential number assigned to the status alert message. 

Level

Display only.

Severity level of the status alert message. Options are: 

• OK: The firmware module is functioning normally. 
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• Information: Information message. The firmware module is functioning 
normally. 

• Warning: The firmware module is operating in a degraded state. May indicate 
a future failure is possible. 

• Error: The firmware module has experienced a failure. 

Module Name

Display only.

Library controller firmware module that is affected by the message. 

Clearable? 

Display only.

Indicates whether the status alert message can be manually cleared from the 
display. Options are:

• Yes: Message can be cleared, and the firmware module status will be returned 
to OK. 

• No: Message cannot be cleared. Generally, OK and Information messages 
cannot be cleared. 

Description

Display only.

Full description of the status alert message. 

Buttons

Apply

Click to clear the selected alert message from the Status Module display. The 
firmware module status is returned to OK, and the library health indicator is 
updated. 

Note – If the alert message is updated periodically, it will 
reappear with the next update cycle.

Refresh 

Click to refresh the display with current data from the library controller database.
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▼ Clear Library Status Alerts

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to clear a library firmware status alert. Not all alerts can be 
cleared. This feature is available only if Service is active on the library. 

Note – Clearing an alert only removes it from this screen display. 
It does not resolve the underlying cause.

Task Steps

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the Status Module tab. 

The page displays all library status alerts. 

3. On the Clear Alert Number list, select the alert number you want to clear from 
the display, and Click Apply. 
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Note – Although you can select any alert number, only alerts 
marked as “Clearable” can actually be cleared. 

The alert is removed from the Status Module display. The library health indicator 
returns to green if there are no other device or status alerts. 

User Response: If the alert is subject to periodic updates, it will reappear at the 
next update cycle.
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▼ Display HLI Port Status

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the current status of all host library management unit 
(LMI) HLI interface ports on the library. Information includes the local TCP/IP 
socket, local IP, connection status, port status, and transmission sent and received 
from the time of connection.

Task Steps

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Status tab, and then the HLI tab. 

The page displays the current status and activity of all HLI ports on the library. 
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▼ Display Library Configuration Properties

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the physical, mechanical, logical, and network 
configuration of the library. Some of the information can be set up automatically 
during library initialization, while other information can be defined by the user.

This information is also available through Reports > Library Information. See 
“Display a Library Report” on page 51 for detailed instructions.

Task Steps

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the General tab.
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Screen Fields

Vendor 

Vendor is STK (for Oracle StorageTek). 

Frame Serial Number

Serial Number

Serial number of the library base module. 

Library Base WWN

World Wide Node Name (WWNN) for the library. 

Total number of physical storage cells installed in the library. Includes data 
cartridge cells as well as reserved system cells. Not all of these cells may be 
enabled for use, however. See “Display Current Hardware Activation 
Files” on page 108 for details on displaying the number of cells that are actually 
enabled. 

Empty Slot Count

Total number of unoccupied data storage cells. 

Drive Count

Total number of drives installed. 

Robot Count

Total number of robots installed. 

Cap Count

Total number of CAPs (cartridge access ports). This includes rotational and AEM 
CAPs. 

Drive Power Supply Count

Total number of drive power supplies installed. 

Hardware power Supply Count 

Total number of power supplies installed for library robotics and electronics. 

Host Interface TCP/IP 2B

These fields apply to the standard library TCP/IP port. 

DNS Domain Name

DNS domain name assigned to the library. 
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IP Address

IPv4 (IP version 4) address for the port, if applicable. 

NetMask

Netmask defined for the subnet that the port is on. 

MAC Address

MAC address for the port. 

Host Interface TCP/IP 2A 

These fields have values only if the Dual TCP/IP feature is installed and enabled on 
the library. They apply to the optional TCP/IP port. 

IP Address

IPv4 (IP version 4) address for the port, if applicable. 

IPv6 Address

IPv6 (IP version 6) address for the port, if applicable. 

NetMask 

Netmask defined for the subnet that the port is on. 

MAC Address

MAC address for the port. 
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▼ Display Library Complex IP Addresses

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to view IP address information for a library complex. This 
procedure applies only if your installation includes a library complex. 

Note – This information is also available through 
Reports > Library Information. See “Display a Library 
Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, then the Complex tab.
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▼ Display Library Controller Properties 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to view details of the library controller, including the serial 
number and firmware versions.

Note – This information is also available through 
Reports > Library Information. See “Display a Library 
Report” on page 51 for detailed instructions.

Task Steps

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the Library Controller tab.
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▼ Display Drive Controller Properties

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

View details of the drive controller, including the serial number and current firmware 
versions.

Note – This information is also available through 
Reports > Library Information. See “Display a Library 
Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the Drive Controller tab.

The Drive Controller page displays.
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▼ Display Library Events Statistics 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The General Events Statistics Report displays summary statistics about overall library 
operations. For each event, the report lists the type, number of occurrences, and the 
date and time of the last such event. 

You can change the sort order of the screen, and rearrange and resize the columns. 
See “Modifying the Screen Layout” on page 23. 

Note – This feature is available starting with SL8500 firmware 
version FRS_6.00 and SL Console version 4.65. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click General Events. 

The General Events page displays.

Screen Fields

Event Type

Type of library event being tracked.

Hours Running always appears as the last entry in the display. 
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Number of Events

Total number of events of this type that have been recorded for the library. 

For the Hours Running entry, this is the number of hours the library has been 
running continuously. 

Last Seen

Date and time of the most recent occurrence of the event. 

For the Hours Running entry, this is the current date and time. 
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7

Redundant Electronics Management 

Note – The information in this chapter applies only to libraries in 
which the Redundant Electronics feature has been installed and 
activated. 

Note – This feature is available starting with SL8500 firmware 
version FRS_6.00 and SL Console version 4.65. 

The optional SL8500 Redundant Electronics feature provides failover protection in 
HLI-managed libraries. If the library controller experiences errors, it automatically 
switches operations to a standby (alternate) library controller, with minimal 
disruption to library and host operations. This enables your Oracle support 
representative to replace the faulty card while the library continues normal 
operations. 

The Redundant Electronics feature also provides minimal disruption of library 
operations during firmware upgrades. 

Note – The SL8500 offers redundancy in a variety of components, 
including robots and power systems. The term “Redundant 
Electronics” refers specifically to redundancy in the library and 
drive controller components. 

Activating Redundant Electronics
The Redundant Electronics feature requires all of the following hardware 
components: 

• Active library controller (HBC/HBCR) card 

• Standby (alternate) library controller (HBC/HBCR) card

• Active drive controller (HBT) card 

• Standby (alternate) drive controller (HBT) card

Your Oracle support representative must install the necessary hardware and activate 
the feature by installing a hardware activation file. See “Hardware Activation 
Files” on page 97  for details.
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Redundant Electronics Operations
The library controller (HBC/HBCR) and drive controller (HBT) cards installed on the 
same side of the card cage are partnered with one another into a “cardset.” 

Each HBC/HBCR card determines its role whenever the card is reset or rebooted. If 
the HBC/HBCR card is the active controller and its partner HBT card is installed, the 
controller loads active code and assumes the role of active controller. If the standby 
(alternate) HBC/HBCR card and its partner HBT card are installed, it loads standby 
code. The HBT card assumes the same role (active or standby) as its partner HBC/
HBCR card. 

Role of the Active Controller 

The active library controller behaves, for the most part, like the library controller in a 
non-redundant library. It accepts connections and processes requests from HLI hosts 
and the SL Console and command line interface (CLI). 

In addition to these functions, the active library controller in a library with 
Redundant Electronics continually monitors the status of the standby (alternate) 
library controller. If the active controller determines that the standby (alternate) is not 
healthy and able to become active, it will not allow an automated or manual failover. 

Role of the Standby Controller 

The standby (alternate) library controller accepts HLI host connections, but processes 
only the set host path group and force switchover requests. All other 
requests are sent to the active controller.

The standby (alternate) controller continually monitors the status of the active 
controller. If the standby (alternate) controller determines that the active one is not 
functioning normally, it initiates an automatic failover. See “Automatic Failover 
Initiation” on page 208 for details. 

Role of the Drive Controllers 

The two drive controller cards (HBTA and HBTB) are partnered with the library 
controller cards installed on the same side of the card cage.

The active drive controller communicates with the library drives. The standby 
(alternate) drive controller does not run until its partner library controller card 
becomes the active controller. 

IP Addresses

Each library controller card requires its own unique IP address. If the Dual TCP/IP 
feature is active on the library, each card requires two unique IP addresses: one for 
the primary port (2B) and one for the secondary (2A) port. A library equipped with 
both Redundant Electronics and Dual TCP/IP requires four unique IP addresses. 
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When you use the SL Console to log into a library, you need to connect to the 
primary port on the active controller. The SL Console does not allow you to connect 
to the standby (alternate) controller, and if you attempt to do so an error message is 
displayed. 

After an automatic failover or manual switch, the IP address or DNS alias you need 
to specify changes because the previously active controller is now the standby 
(alternate), and vice versa. 

How Failover Works 
In a failover, control of the library is switched from the current active controller to the 
standby (alternate). The standby (alternate) library and drive controller cards become 
active, and the active ones become standby. Each library controller and its partnered 
drive controller are always switched as a pair. 

A failover can be initiated either automatically or manually. This section describes 
characteristics of all failovers. See the following sections for additional details specific 
to the automatic and manual processes:

• “Automatic Failover Initiation” on page 208

• “Manual Switch” on page 209 

Failover Process 

The failover process is minimally disruptive to library operations, usually taking only 
a few minutes. The process is summarized as follows:

1. Failover is initiated automatically or manually. 

2. The status of the standby (alternate) controllers is checked. The standby (alternate) 
library and drive controllers must be operating normally in order for failover to 
proceed. If any of the following conditions exist, the failover cannot proceed: 

• The standby (alternate) library or drive controller is in a fault state. 

• The standby (alternate) library or drive controller card is in the eject state. 

• The standby code is not running on the standby (alternate) library or drive 
controller cards. 

• A firmware download is in progress. 

• A card initialization is in progress. 

3. If functional, the active library controller attempts to complete all in-process jobs 
and copy the cartridge database to the standby (alternate) controller card. 

4. After all in-process jobs have completed or timed out, the card roles are switched. 

5. Active software is brought up on the standby (alternate) controller, and this 
controller becomes the active one. 

6. Standby software is brought up on the previously active controller, if possible, and 
this controller becomes the standby (alternate). If the standby software cannot be 
brought up on this controller, the controller enters a fault state. 
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What Happens to Connections

The failover process is minimally disruptive to host operations. The following 
changes occur to various connections:

• Tape management software (Symantec or Virtual Storage Manager, for example) 
users do not see an interruption. 

• HLI host applications (ACSLS and ELS) queue requests during the failover 
process, and then submit them to the library controller after the failover is 
complete. For ACSLS, the queuing and retry affects mount and dismount requests 
only. See the ACSLS and ELS documentation for details. 

• SL Console and CLI connections are terminated. YouUsers must re-establish 
connections to the library using the IP address of the new active library controller 
(the former standby controller). See “Log In to the Library After a 
Failover” on page 221 for detailed instructions. 

In-transit Cartridge Recovery

Any cartridges that are in-transit at the time a failover is initiated are returned to 
their home slots, if possible. If a cartridge cannot be moved to its home slot, it is 
moved to a library system cell, and the host must return the cartridge to its home cell. 

Audits

The cartridge location database resides on the active controller only and is not 
mirrored on the standby (alternate). If the database can be copied to the standby 
(alternate) prior to the failover, a cartridge audit is not necessary afterwards. Usually 
it is possible to copy the database in the following circumstances: 

• A manual switch 

• The active drive controller (HBTA) card is pulled or failed

Usually it is not possible to copy the database if there is a sudden hard failure in the 
active library controller. 

If an audit must be done after the failover, it is done in the background, while other 
jobs are processed. As a result, you may notice that library operations take slightly 
longer to perform until the audit is complete. In addition, if a particular request 
requires information about a location that has not yet been audited, the location will 
be audited first, causing a slight delay in processing the request. 

Automatic Failover Initiation

An automatic failover can be initiated by either the active or standby (alternate) 
library controller. 

The active library controller initiates an automatic failover in any of the following 
situations: 

• It determines that its partner drive controller (HBTA) card is not installed.

• It does not receive communication from its partner drive controller (HBTA) card 
within a defined time-out period.

• It detects a catastrophic internal software error.
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The standby (alternate) library controller initiates an automatic failover if it 
determines that the active controller is not responsive. 

Manual Switch 

You may want to perform a manual switch in the following circumstances, to verify 
that the standby (alternate) cards are functioning normally: 

• After initial installation of the standby (alternate) library and drive controller 
cards

• After a firmware upgrade

• Periodically (once a month or once a quarter, for example)

Each library controller and its partnered drive controller are always switched as a 
pair. It is not possible to manually switch only the library controllers and not the 
drive controllers, for example. 

Manual Switch Initiation 

A manual switch can be initiated through any of the following connections:

• Host tape management (ACSLS or ELS) console: From either the active or standby 
(alternate) library controller. 

• Remote SL Console: From the active library controller only. Since the SL Console 
cannot log into the standby (alternate) library controller, you cannot use the SL 
Console to initiate a manual switch from the standby (alternate). Also, the manual 
switch function is not available from the local operator panel. 

• CLI: From either the active or standby (alternate) library controller. This function 
is available to your Oracle support representative only. 

Before initiating a manual switch, you should verify that the standby (alternate) 
library and drive controllers are running normally. See the following topics for 
additional information on card status:

• “SL Console Displays” on page 210 

• “Display Redundant Electronics Detail” on page 215 

See “Manually Switch Redundant Electronics Cards” on page 219 for detailed 
instructions on initiating a manual switch from the SL Console. 

Monitoring Status of the Controllers 

LEDs and Controls 

The LEDs and controls are the same on all four cards. The following TABLE 7-1 lists  
what the LED lights mean.



TABLE 7-1  LED and Control Descriptions

LED Color Definition

ACTIVE Green Card is functioning as the active and is running active code. 

STANDBY Amber Card is functioning as the standby (alternate) and is running 
standby code. 

FAULT Red Card has experienced a serious error.

EJECT OK Blue Card can be safely removed. Your Oracle support representative 
can initiate a card eject through the CLI. 

Monitoring Status of the Controllers
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SL Console Displays 

You can display the status of all four controller cards through the SL Console. 

Card Positions

Some SL Console displays identify the individual library controller cards as HBC/
HBCRA and HBC/HBCRB and the drive controller cards as HBTA and HBTB. For 
both types of cards, the A or B suffix indicates the card’s position within the card 
cage, as viewed from the back of the machine, as follows: 

• A: Left card slot 

• B: Right card slot 

Card Statuses 

The possible status of the controller cards are described in the following TABLE 7-2. 

See the following topics for additional details:

• “Display Redundant Electronics Summary Information” on page 213

• “Display Redundant Electronics Detail” on page 215

TABLE 7-2  Possible Status of Controller Card

Status Applies to Definition

Duplex: software 
ready, switch possible

Active library controller only Card is functioning normally.

Not installed All cards Card is not installed in the machine. 

ok Active or standby (alternate) drive 
controller

Card is functioning normally.

Pre-standby: Software 
not ready

Standby (alternate) library controller 
only

Card is loading standby code and is 
not ready to be used in an automatic 
failover or manual switch. 

Standby: software 
ready

Standby (alternate) library controller 
only

Card is functioning normally and 
can be used in the event of an 
automatic failover or manual switch.
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Event Log Entries

Significant library and drive controller activities, such as deteriorated health, errors, 
failovers, and card ejects, are logged to the Event Log. Routine activities, such as a 
card monitoring the status of its partner, are not. 

Redundant Electronics and Firmware Upgrades
Firmware upgrades for libraries with the redundant electronics feature are minimally 
disruptive to library operations. New code is loaded and unpacked simultaneously 
on the active and standby (alternate) controller cards and on all devices. The code is 
then activated, and the active and standby (alternate) controllers and most devices 
are reinitialized. Under most circumstances, robot initialization is bypassed. 

The loading, unpacking, and activation of code are not disruptive to library 
operations until the library is rebooted. During the reboot process (which takes 
approximately 10 minutes), the HLI host applications (ACSLS and ELS) queue all 
mount and dismount requests. After the reboot is complete, the queued requests are 
submitted to the library controller. 

Note – For complexes, this process is performed concurrently on 
all libraries with the Redundant Electronics feature. 



Redundant Electronics Management Tasks

212   SL8500 User’s Guide

Redundant Electronics Management Tasks

Task Page

Display Redundant Electronics Summary Information  213

Display Redundant Electronics Detail  213

Manually Switch Redundant Electronics Cards  213

Log In to the Library After a Failover  221
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▼Display Redundant Electronics Summary Information 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display summary information about all Redundant Electronics 
cards in the library. 

Note – This feature is available starting with SL8500 firmware 
version FRS_6.00 and SL Console version 4.65. 

Task Steps

1. Select Tools > System Detail, and click the Redundant Electronics folder. 

The Redundant Electronics Data page appears. 

Screen Fields

Device 

Options are:

Type of card. Options are:

• libraryController: Library controller card

• driveController: Drive controller card

Address 

The card’s address within the library. Options are:

• hbca: Library controller, A (left) slot

• hbcb: Library controller, B (right) slot 
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• hbta: Drive controller, A (left) slot 

• hbtb: Drive controller, B (right) slot

Card Position

Position of the card within the card cage, as viewed from the back of the machine. 
Options are:

• Left: Left card slot. Also referred to as the A slot.

• Right: Right card slot. Also referred to as the B slot.

Device State 

Current operating state of the card. Options are:

• Duplex: Software ready, switch possible: Card is functioning normally. Used 
only for an active HBC/HBCR card in a library with Redundant Electronics. 

• Initializing State 0: Internal hardware manager state which may be seen during 
initialization. 

• Initializing State 1: Internal hardware manager state which may be seen during 
initialization.

• Not installed: Card is not installed in the machine. The library has the 
Redundant Electronics feature activated, but the standby (alternate) HBC/
HBCR or HBT card is not installed. 

• ok: Card is functioning normally. Used only for HBT cards. 

• Pre-simplex: software not ready. Card is loading code. Used only for an HBC/
HBCR card in a library without Redundant Electronics. 

• Pre-standby: software not ready. Card is loading standby code and is not ready 
to be used in the event of an automatic failover or manual switch. Used only 
for an standby (alternate) HBC/HBCR card in a library with Redundant 
Electronics. 

• Simplex: software ready. Card is functioning normally. Used only for an HBC/
HBCR card in a library without Redundant Electronics. 

• Standby: software ready: Card is functioning normally and can be used in the 
event of an automatic failover or manual switch. Used only for an standby 
(alternate) HBC/HBCR card in a library with Redundant Electronics. 

• Unknown: unknown value: The active HBC/HBCR card cannot communicate 
with the standby (alternate) and does not have any information about the 
standby (alternate)’s status. 

Health State

Current health of the card. Options are:

• error: Card has experienced a fault, such as it is in the Not Installed state. 

• warn: Card is in a degraded state, such as the card has been ejected or its 
alternate is not yet in the Standby state. 

• ok: Card is functioning normally
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▼Display Redundant Electronics Detail

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display detailed status information for the active and standby 
(alternate) library controller and drive controller cards. 

Note – If redundant electronics is not enabled on this library, the 
display shows as much detail as is applicable. 

Note – This feature is available starting with SL8500 firmware 
version FRS_6.00 and SL Console version 4.65. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Redundant Electronics folder in the navigation tree, and click the 
card you want to display. Cards are as follows:

• hbca: Library controller, A (left) slot

• hbcb: Library controller, B (right) slot 

• hbta: Drive controller, A (left) slot 

• hbtb: Drive controller, B (right) slot
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The page displays the current status of the selected card. 

Screen Fields

Device 

Type of card. Options are:

• libraryController: Library controller card

• driveController: Drive controller card

Card Type

The card’s address within the library. Options are:

•

• hbca: Library controller, A (left) slot

• hbcb: Library controller, B (right) slot 

• hbta: Drive controller, A (left) slot 

• hbtb: Drive controller, B (right) slot

IP Address: 2B

IP address of the 2B port on the selected library controller card. The 2B port is the 
primary port for host communications. 

If no card is installed, this field displays N/A.

Note – This field applies only to library controller (HBC/HBCR) 
cards. Drive controller (HBT) cards do not have a 2B or 2A port 
and therefore always display N/A. 
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IP Address: 2A

IP address of the 2A port on the specified HBC/HBCR card. The 2A port is the 
secondary port for host communications. 

If no card is installed, this field displays N/A.

Note – This field applies only to library controller (HBC/HBCR) 
cards. Drive controller (HBT) cards do not have a 2B or 2A port 
and therefore always display N/A. 

Position 

Position of the card within the card cage, as viewed from the back of the machine. 
Options are:

• Left: Left card slot; also referred to as the A side 

• Right: Right card slot; also referred to as the B side 

Device State

Current operating state of the card. Options are:

• Duplex: Software ready, switch possible: Card is functioning normally. Used 
only for an active HBC/HBCR card in a library with Redundant Electronics. 

• Initializing State 0: Internal hardware manager state which may be seen during 
initialization. 

• Initializing State 1: Internal hardware manager state which may be seen during 
initialization.

• Not installed: Card is not installed in the machine. The library has the 
Redundant Electronics feature activated, but the standby (alternate) HBC/
HBCR or HBT card is not installed. 

• ok: Card is functioning normally. Used only for HBT cards. 

• Pre-simplex: software not ready. Card is loading code. Used only for an HBC/
HBCR card in a library without Redundant Electronics. 

• Pre-standby: software not ready. Card is loading standby code and is not ready 
to be used in the event of an automatic failover or manual switch. Used only 
for an standby (alternate) HBC/HBCR card in a library with Redundant 
Electronics. 

• Simplex: software ready. Card is functioning normally. Used only for an HBC/
HBCR card in a library without Redundant Electronics. 

• Standby: software ready: Card is functioning normally and can be used in the 
event of an automatic failover or manual switch. Used only for an standby 
(alternate) HBC/HBCR card in a library with Redundant Electronics. 

• Unknown: unknown value: The active HBC/HBCR card cannot communicate 
with the standby (alternate) and does not have any information about the 
standby (alternate)’s status. 

Health State

Current health of the card. Options are:
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• error: Card has experienced a fault, such as it is in the Not Installed state. 

• warn: Card is in a degraded state, such as the card has been ejected or its 
standby (alternate) is not yet in the Standby state. 

• ok: Card is functioning normally

Standby HBC/HBCR Communicating

Current communications status of the standby (alternate) library controller (HBC/
HBCRB) card. Options are:

• true: Standby (alternate) HBC/HBCR card is successfully communicating with 
the active card. 

• false: Standby (alternate) HBC/HBCR card is not communicating with the 
active card.

• N/A: Standby (alternate) HBC/HBCR card is not installed, or the selected card 
is not a library controller. 

Software Switch Allowed

Indicator of whether an automatic failover or manual switch is possible, given the 
current status of the standby (alternate) library and drive controller cards. Options 
are:

• true: Automatic failover or manual switch is possible. 

• false: Automatic failover or manual switch is not possible. 

• N/A: Standby (alternate) HBC/HBCR card is not installed or the selected card 
is not a library controller
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▼Manually Switch Redundant Electronics Cards

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to switch the active and standby (alternate) controller cards. Each 
library controller and its partnered drive controller are always switched as a pair. The 
current standby (alternate) library and drive controller cards become active, and the 
active ones become standby (alternate).

Before performing this procedure you should verify that the Software Switch 
Allowed indicator on the Redundant Electronics Status Detail screen is “true.” See 
“Display Redundant Electronics Detail” on page 215 for detailed instructions. 

Note – You will be logged off the library as part of this procedure. 
After the switch completes, to log back into the library, you must 
specify the IP address or DNS alias of the new active library 
controller card. 

Note – This feature is available starting with SL8500 firmware 
version FRS_6.00 and SL Console version 4.65. 

Task Steps

1. Select Tools > Diagnostics and select Redundant Electronics Folder. 

The Redundant Electronics Switch screen appears. 

2. Click Apply to begin the switch process. 
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• If the standby (alternate) library and drive controller cards are operating 
normally, the Confirm dialog appears, prompting you to confirm that you 
want to proceed with the switch. 

• If there is a problem with the standby (alternate) library and drive controller 
cards, an error message is displayed and you are not allowed to continue with 
the switch. 

3. Click Yes to begin the switch process. 

The switch process begins, and a message appears indicating that your SL Console 
session will be terminated.

4. Click OK to dismiss the message and log off the SL Console. 

5. Wait until the switch is complete before logging back into the library. In 
addition, you must specify the IP address or DNS alias of the new active 
controller to log in. See “Log In to the Library After a Failover” on page 221 for 
detailed instructions. 
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▼ Log In to the Library After a Failover 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to log in to the library after an automatic failover or manual 
switch. You need to log in by connecting to the library controller that was the standby 
(alternate) prior to the failover or switch. 

Note – This feature is available starting with SL8500 firmware 
version FRS_6.00 and SL Console version 4.65. 

Task Steps

1. Obtain the IP address or DNS alias of the new active library controller. 

This was the standby (alternate) library controller prior to the failover or switch. 

2. Bring up the SL Console. See “General SL Console Usage Tasks” on page 34 for 
a list of procedures to do this.

The SL Console Login screen appears. 

3. Enter your login information, and click Log on.

User ID: SLC_login  
Password: password  
Library: library_ID 
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where:

• SLC_login is the SL Console user ID.

• password is the password assigned to this user ID. 

• library_ID is the library to which you want to connect, expressed in either of 
the following ways:

• IP address of the library 

• DNS alias of the library

Note – Beginning with SL Console FRS 4.50, your password must 
be limited from  5 - 8 characters.

Note – The user ID you use determines the screens you can 
access. See “SL Console Security”. 

4. If you are attempting to log into the wrong controller, the following dialog 
appears. You cannot use the SL Console to log into the standby (alternate) 
controller. 

Click OK and return to Step 3, this time entering the information for the correct 
controller. 
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CAP Management

By using cartridge access ports (CAPs), you can enter (or import) or eject (or export) 
cartridges to or from the library.

This chapter describes general CAP activities that apply to the SL500 library.

• “CAP Auto Enter Mode” on page 225

• “Manual CAP Mode” on page 225

Note – This section includes general information about CAPs. For 
details about using CAPs in partitioned libraries, see “CAP 
Operation Tasks” on page 150. 

The library includes one standard CAP A (on the left, as viewed from the front of the 
library). An optional CAP B (on the right, as viewed from the front) is also available. 

Each CAP contains three cartridge magazines. Each magazine contains 13 cells, 
enabling import/export of up to 39 cartridges at a time. You can remove the 
magazines from the CAP to load cartridges in a batch mode. 

The CAP magazines span only the lower three rails on the right side of the library. To 
import or export a cartridge from the top rail on the right side, a HandBot places the 
cartridge in an elevator slot to accomplish the move.

Each CAP spans across three rails: 2, 3, and 4 (LSMs 1, 2, and 3) only.

Note – In FIGURE 8-1, numbers 1 through 4 (shown inside the 
library) are rails. Numbers 1 through 3 on the right front access 
door are LSMs.
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There is no adjacent CAP section for the top rail. This requires an elevator (vertical 
pass-thru operation) to enter and eject cartridges.

FIGURE 8-1  Right Access Door Opened

Cartridge Slot Locations
Slot locations within the CAPs have the following addressing:

• Library number (within a library complex).

• Rail number: Rails are numbered 1 through 4, rail 1 is the topmost rail.

Note – CAP slots begin numbering at rail 2.

• Column number: Columns are “signed” numbers as seen from the front of the 
library, where +1 is right of the drive bays and -1 is to the left of the drive bays.

• Side number: Outer wall = 1, Inner wall = 2.

Note – For CAPs, side number -1 = CAP A and side number +1 = 
CAP B.

• Row number: Numbered consecutively, from the top down.

Note – CAP slots begin with row number 0, which is the 
magazine handle. CAP slots are not considered as storage slots. 



CAP Auto Enter Mode

CAP Management   225

The CAP Folder contains the address in the Internal Addr column.

CAP Auto Enter Mode
Note – Only HLI libraries support the CAP auto enter mode. 
FC-SCSI libraries do not support it.

Note – Partitioned libraries do not support the CAP auto enter 
mode. 

CAP auto enter mode enables you to open a rotational or AEM CAP and begin an 
enter operation, without:

• Issuing an explicit enter request

• An explicit reservation from a host application

When in auto mode, a CAP is unlocked and its LED is on. The system locks the CAP 
only during cartridge enter, eject, or audit operations. 

Host applications manage the auto enter mode. See the appropriate tape management 
software documentation for details. To place a CAP in auto enter mode, enter the 
appropriate tape management command to unlock the CAP. 

To initiate an enter operation using an automatic CAP, click the CAP Open button on 
the key pad. Auto enter mode does not affect CAP operations for ejecting cartridges. 
Therefore, always issue an explicit eject command to eject cartridges through the 
CAP.

Manual CAP Mode 
Manual mode is the most secure method of CAP operations. 

When in manual mode, the system locks a CAP by default, and its LED is not on. To 
initiate an enter or eject operation using a manual CAP, enter an explicit enter or eject 
request before pressing the CAP Open button on the keypad. 

  Additional CAP Information

See the following for complete details about CAPs:

• Procedures for using CAPs: “ CAP Management Tasks” on page 226

• Partition configuration information relating to CAPs: “Library 
Partitioning” on page 123



 CAP Management Tasks

226   SL500 User’s Guide

 CAP Management Tasks

Task Page

Display CAP Summary Information  227

Display Current CAP Status  228

Display CAP Properties  229

Unlock a CAP  230

Lock a CAP  232
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▼ Display CAP Summary Information

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To display summary information for all CAPs in the library, complete the following 
steps.

Note – This information is also available through 
Reports > CAP Summary. See “Display a Library 
Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail.

2. Select the CAP folder in the navigation tree. 

The system lists all the library’s CAPs and their locations.
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▼ Display Current CAP Status 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To display the current operational state of a CAP, complete the following steps. 

Note – This information is also available on the CAP Details 
report. See “Display a Library Report” on page 51 for detailed 
instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and select the CAP you want to display. 

3. Click the Status tab.

The CAP page displays the current status of the selected CAP. 
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▼ Display CAP Properties

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display static information for a CAP, including the serial 
number and number of cells. 

Note – This information is also available through Reports > CAP 
Details. See “Display a Library Report” on page 51 for detailed 
instructions.

Task Steps

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and select the CAP you want to display. 

3. Click the Properties tab. 

The CAP Properties page appears.
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▼ Unlock a CAP 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Normally, the host unlocks a CAP. Use this procedure when you need to perform the 
unlock operation manually at the SL Console. 

Note – If the CAP is reserved by a host, the host must release the 
CAP reservation before you can use this procedure. 

1. Select Tools > Diagnostics. 

2. Expand the CAP Folder, and select the CAP you want to modify. 

3. Click the Access tab. 

The Access page appears.
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4. In the Locked list, select false. Click Apply. 

The Confirm message appears. 

5. Click OK.

The CAP door unlocks, and the CAP button light turns on.

Note – The CAP status changes to “unlocked” in the host library 
management software.

Note – The library reserves the CAP and makes it inaccessible to 
all library hosts until you close and lock the CAP or AEM access 
door. See “Lock a CAP” on page 232 for details. 
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▼ Lock a CAP 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Note – Normally a CAP is locked from a host. Use this procedure 
when you must perform the lock operation manually at the SL 
Console. If you unlock a CAP (see “Unlock a CAP” on page 230 
for details.), the CAP is reserved by the library and unavailable to 
all hosts until you perform this procedure. 

Task Steps

1. Select Tools > Diagnostics. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

3. Click the Access tab. 

The Access page appears.

4. At the Locked list, select true. Click the Apply button. 

The CAP locks, and the CAP button light turns off.
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Drive Management

This chapter includes the following topics:

• “Maximum Drive Capacity” on page 233

• “Drive States” on page 233

• “Drive Management Tasks” on page 234

Maximum Drive Capacity
Each SL8500 library supports from 1 to 64 drives. The interface to these drives is fiber 
optic based, meaning Fibre Channel, FICON (Fiber Connection or Fiber Connectivity) 
or ESCON (Enterprise Systems Connection or Enterprise Systems Connectivity) 
attachments.

See “Cartridge Slot Locations” on page 431 for details on drive identification and 
addressing schemes.

Drive States
A drive can be in one of the following states:

• Online: The drive is available for read/write operations.

• Offline: The drive is not available for read/write operations. 
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Drive Management Tasks

Task Page

Display Drive Summary Information  235

Display Drive Status  237

Display Drive Properties  238

Display Drive VOP  239

Display Drive LED Status  241

Display Drive Tray Status  242

Display the Drive Events Report  243

Display the Drive Media Events Report  245
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▼ Display Drive Summary Information

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display summary information for all drives in the library. 

If you must perform a manual mount to a drive, this procedure displays a mapping 
of all addresses for each library drive:

• Firmware (internal address)

• Host software (HLI-PRC address)

• Hardware (drive bay)

The following information also displays:

• Access State: online, offline

• Drive State:

• Empty

• Unloaded: Cartridge is present 

• Ready: Cartridge is loaded

• NotCommunicating

• rewindUnload: Drive is busy rewinding and unloading 

• Drive Type

• Drive serial number

• Current code version

• Drive interface type

Note – This information is also available through 
Reports > Drive Summary. See “Search a Library 
Report” on page 53  for detailed instructions. 

Task Steps

1. Select Tools > System Detail, and click the Drive folder in the navigation tree. 

The page lists the library drives and displays their locations.



Drive Management Tasks

236   SL8500 User’s Guide

The internal address, drive bay, and HLI-PRC address are listed. 
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▼ Display Drive Status 

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the current operational state of a drive. The information 
includes:

• Current drive and drive tray status information 

• Whether the drive is loaded

• Cartridge vol-id if the drive is loaded

• Drive cleaning information

• Host activity

Note – This information is also available through 
Reports > Drive Details. See “Display a Library 
Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail

2. Expand the Drive Folder in the navigation tree, and click the drive you want to 
display. 

3. Click the Status tab.

The page displays the current status of the selected drive. 
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▼ Display Drive Properties 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

View detailed drive configuration information, including the drive type and serial 
number and port configuration.

Note – This information is also available through 
Reports > Drive Details. See “Display a Library 
Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder in the navigation tree, and click the drive you want to 
display. 

3. Click the Properties tab. 

The Properties page appears. 
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▼ Display Drive VOP

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the Virtual Operator Panel (VOP) for T10000 and 
T9840D drives. 

Note – This procedure is for Oracle StorageTek T10000 and 
T9840D drives only. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder in the navigation tab, and click the drive you want to 
display. 

3. Click the Display tab.

The drive VOP information displays in the Drive Virtual Op Panel section. 
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▼ Display Drive Network Data

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display IP and MAC address data for a library drive. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder in the navigation tree, and click the drive you want to 
display. 

3. Click the Display tab.

The data displays in the Network Data section. 
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▼ Display Drive LED Status

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display current statuses of a selected drive’s LEDs, including 
loaded, online, cleaning, and trace available.

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder in the navigation tree, and click the drive you want to 
display. 

3. Click the Display tab.

The data displays in the Drive Led Status section. 
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▼ Display Drive Tray Status

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the current status of a drive tray. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder in the navigation tree, and click the drive you want to 
display. 

3. Click the DriveTray tab.

The DriveTray page appears. 
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▼ Display the Drive Events Report

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Drive Events Report summarizes drive events and errors that have occurred on 
library drives. The system updates the report whenever there is a drive event not 
related to media. Use this report to help identify and diagnose faulty drives.

For each drive that has experienced events, the report lists the type of drive, type of 
error, the number of occurrences, and the date and time of the last such event. The 
report can display up to 70 entries. 

By default, the report is sorted in drive serial number order. Optionally, you can 
change the sort order, and rearrange and resize the columns. See “Modifying the 
Screen Layout” on page 23. 

Note – For media errors associated with drives, see “Display the 
Drive Media Events Report” on page 245. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Drive Events in the navigation tree. 

Screen Fields

Serial Number

Serial number of the drive.

Drive Type

Brand and model of the drive.
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Event Type

Type of event being tracked. All of these events indicate problems with the drive, 
not the media. Options are:

• Drive Error: Drive had a general problem. 

• Load Error: Drive was unable to load the cartridge. 

• Load Retry: Drive required retries to load the cartridge. 

Number of Events

Total number of events of this type that have been recorded for this drive. 

Last Seen

Date and time of the most recent occurrence of the error. 
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▼ Display the Drive Media Events Report

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Drive Media Events Report summarizes media events that have occurred on 
library drives. The report is updated whenever a media event or error occurs. You 
can use the report to help identify and diagnose faulty drives or cartridges.

For each drive that has experienced media events, the report lists the vol-id of the 
cartridge, the type of event, the number of occurrences, and the date and time of the 
last such event. The report can display up to 500 entries. 

By default, the report is sorted in drive serial number order. Optionally, you can 
change the sort order, and rearrange and resize the columns. See “Modifying the 
Screen Layout” on page 23. 

Note – For cartridge errors not necessarily associated with drives, 
see “Display the Media Events Report” on page 281. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Statistics folder, and click Drive Media Events in the navigation 
tree. 

Screen Fields

Serial Number

Serial number of the drive.

Drive Type

Brand and model of the drive.
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Cartridge Label 

vol-id of the cartridge that has experienced an event. 

Event Type

Type of media event being tracked. Option is Media Error. The drive indicated 
there was a problem with the media. This could also indicate a problem with the 
drive.

Number of Events 

Total number of events of this type that have been recorded for this cartridge on 
this drive. 

Last Seen

Date and time of the most recent occurrence of the event. 
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10

Cartridge Management

This chapter includes the following topics:

• “Cartridge Labels” on page 247

• “Entering Cartridges” on page 247

• “Ejecting Cartridges” on page 248

• “Importing Cartridges” on page 248

• “Exporting Cartridges” on page 251

• “Locating Cartridges” on page 252

• “Recovery Moves” on page 252

• “Cartridge Management Tasks” on page 253

Cartridge Labels
All library cartridges must have a readable external label.

The ELS and ACSLS host software applications do not support unlabeled cartridges 
and will not allow you to enter them through the CAP. If you place an unlabeled 
cartridge in a CAP, the host leaves it there and you must remove it from the CAP. 

If you place an unlabeled cartridge into a storage cell manually, the robot leaves it 
there during a hardware audit and does not attempt to place another cartridge into 
the slot.

During an ACSLS or ELS audit, however, the host moves the cartridge to the CAP for 
ejection from the library. 

The library controller will not allow you to mount an unlabeled or unknown type 
cartridge into any tape drive. 

Entering Cartridges
Before entering a cartridge into the library, verify it is labeled properly. Insert each 
cartridge into a CAP slot with the:

• Customer label (if present) facing you
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• Hub gear facing down

• Cartridge label facing you

You can place cartridges in any CAP slot in any order. The robot audits all CAP slots 
when the CAP door is closed. 

Note – The CAP design prevents you from placing a T9840 or 
T10000 cartridge upside-down in the CAP. It does not, however, 
prevent you from placing an LTO cartridge upside-down in the 
CAP.

The robot’s bar-code scanner reads cartridge labels only during enter operations. This 
is  because the vol-ids are new and must be added to the library controller database. 
The robot does not need to read cartridge labels during ejects.

When the system enters a cartridge into the library, the host either assigns the 
cartridge a home cell or mounts it on a drive, depending on the reason why it was 
entered. The system records the stored cartridge’s location in the library controller 
database, using the library internal address format. 

See “Cartridge Slot Locations” on page 431.

The system also transmits the location to the host for inclusion in the host’s cartridge 
database.

Ejecting Cartridges
To eject a cartridge, you must specify the vol-id of the cartridge you want to remove 
from the library. The robot moves to the storage location indicated in the library 
controller database, removes the cartridge from the slot, and places the cartridge in a 
CAP slot.

 After the CAP opens, the system deletes the cartridge and its location from the 
library controller database and the host database.

Note – The robot does not read cartridge labels during eject 
operations. 

Importing Cartridges
You can enter up to 39 cartridges one time through each CAP.

Before you enter a cartridge into the library, verify that it is labeled properly. Insert 
each cartridge into a CAP slot with the:

• Customer label (if present) facing you

• Hub gear facing down

• Cartridge label facing you

Cartridges can be placed in any CAP slot, in any order. The robot audits all CAP slots 
when the CAP door is closed. 

When the system imports a cartridge:

1. The HandBot hand’s bar-code line scanner reads the cartridge.
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2. The library controller assigns the cartridge a home cell or mounts it on a drive, 
depending upon the purpose for which it was imported.
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The system records the stored cartridge’s location in library memory, and formats the 
location as library number, rail, column, side, and row (see “Cartridge 
Handling” on page 445). The location is also transmitted to the host and stored in its 
cartridge database.

FIGURE 10-1  Placement of Cartridges with the Magazine Inside the CAP
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1. Customer label (9x40 only)

2. Magazine slot

3. Volume serial number label



FIGURE 10-2  Placement of Cartridges with the Magazine Outside the CAP
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Exporting Cartridges
When exporting a cartridge, you must specify the vol-ids of the cartridge you wish to 
remove from the library. Then the system retrieves the vol-id location from the 
library’s memory. The HandBot moves to the cartridge, removes it from its slot, and 
places the cartridge into the CAP slot. A total of 39 cartridges may be exported at one 
time through each CAP.

After the CAP opens, the system erases the location of the cartridge from the library 
controller database and the host database. 

Note – Especially important to keep in mind when exporting 
cleaning cartridges from a library: If you do not remove the 
cleaning cartridge from the CAP and the CAP closes, the library 
treats the cartridge as “new” and the expired cleaning cartridge is 
used again.
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Locating Cartridges
You can display the library internal address of any cartridge by using the SL Console. 
You can locate a cartridge based on any of the following criteria:

• vol-id:  See “Locate a Cartridge by vol-id” on page 264 for details. 

• Library internal address: See “Locate a Cartridge by Address” on page 266 for 
details.

• Host address (HLI): See “Locate a Cartridge by Address” on page 266 for details.

This utility is especially useful when you must perform a manual mount of a 
cartridge. The library management software (ELS or ACSLS) provides the:

• vol-id

• HLI-PRC or FC-SCSI address of the cartridge

• Drive bay address of an available drive

Before you enter the library, write down the vol-id, cartridge location, and the drive 
slot location. 

Note – If the library is in a complex, make sure you enter the 
correct library number (for the internal firmware address search) 
or the LSM number (for the HLI-PRC address search). For more 
information see “PTP Addressing Scheme” on page 306.

Recovery Moves 
Using the recovery move diagnostic function, you can move a cartridge from one 
location to another. For example, you can:

• Return a cartridge to its original location from a CAP cell, drive, or another 
storage cell location.

• Decide to group cartridges by data type or move them closer to their assigned 
drives.

• Eject a cleaning or diagnostic cartridge that has expired.

• Enter a new cleaning or diagnostic cartridge and move it to a reserved storage 
cell.

A cartridge currently in a storage cell can be moved only to a CAP, a system cell, or 
another storage cell, and not to a drive. A cartridge currently in a drive, CAP, or 
system cell can be moved to any other unoccupied location in the library. See the 
following procedures for complete details:

• “Move a Specified Cartridge by vol-id” on page 271

• “Move a Cartridge From a Specified Location” on page 276

Before moving any cartridge, it is helpful to display or print a report showing where 
cartridges are currently located and which storage cells are unoccupied. See the 
following procedures for detailed instructions:

• “Display Library Cartridge Information in Tabular Format” on page 257

• “List Library Cartridges” on page 261
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Cartridge Management Tasks

Task Page

Enter Cartridges Through a CAP  254

Eject Cartridges Through a CAP  255

Display Library Cartridge Information in Tabular Format  257

List Library Cartridges  261

Locate a Cartridge by vol-id  264

Locate a Cartridge by Address  266

Move a Specified Cartridge by vol-id  271

Move a Cartridge From a Specified Location  276

Display the Media Events Report  281
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▼ Enter Cartridges Through a CAP

Task Tool

This task can be performed at the host and the CAP.

Task Purpose

Use this procedure to enter cartridges into the library through a CAP.

Task Steps

1. Initiate the enter operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

Note – If the CAP is in auto enter mode, you can skip this step 
and proceed directly to Step 2. 

2. Press the appropriate CAP Unlocked button (CAP A or CAP B) on the operator 
key pad. 

The CAP door opens, and the CAP button light turns ON. 

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

3. Place the cartridges in the CAP. Insert the cartridges so that the:

• Customer label (if present) faces up

• Hub gear faces down

• Cartridge label faces you

You can enter the cartridges directly into the magazines while the magazines are 
in the CAP. Or you can remove the magazines from the CAP, insert cartridges into 
the magazines, and then replace the cartridge-filled magazines into the CAP.

Note – You can place cartridges in any CAP slot, in any order. The 
robot audits all CAP slots when the CAP door closes.

Caution – Possible Media Damage. While you can enter cartridges 
that do not contain external labels or place cartridges upside-down, 
this is not advisable. Such conditions present problems when the 
system performs an audit. Likewise, do not enter cartridges 
containing unreadable or damaged labels.

4. Press the appropriate CAP Unlocked button (CAP A or CAP B) on the operator 
key pad. 

The CAP closes and locks automatically, and the CAP button light turns OFF.

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

5. The HandBot audits the CAP, and then moves the cartridges from the CAP to 
storage cells. 

When the HandBot moves all cartridges from the CAP, the library recognizes that 
the CAP is empty and returns the CAP to its default state.
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▼ Eject Cartridges Through a CAP 

Task Tool

This task can be performed the host and the CAP.

Task Purpose

When ejecting (exporting) a cartridge, you must specify the vol-ids of the cartridge 
you wish to remove from the library. The system retrives the vol-id location from the 
library controller database. The robot moves to the cartridge and removes it from its 
slot, and places  the cartridge into the CAP slot. You can export up to 39 cartridges at 
one time through each CAP.

Use this procedure to eject cartridges from the library through a CAP. 

Task Steps

1. Initiate the eject operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

Specify the vol-ids of the cartridges you want to remove from the library.  
The HandBot places the cartridges into one or more available CAPs. Refer to your 
library management software publication for the console messages.

2. Press the appropriate CAP Unlocked button (CAP A or CAP B) on the operator 
key pad. 

The CAP door opens, and the CAP button light turns ON. 

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

3. Remove the cartridges from the CAP.

You can remove the cartridges directly from the magazines while the magazines 
are in the CAP. Or you can take the magazines out of the CAP, remove the 
cartridges from the magazines, and then replace the empty magazines in the CAP.

4. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns OFF.

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

If more cartridges must be exported, the robot continues filling the CAP. Wait 
until the CAP door is unlocked and repeat Step 2 through Step 4. 

The eject operation ends automatically when the system ejects all specified 
cartridges. 

5. The robot audits the CAP to verify that it is empty.

The CAP returns to its default state. 



Cartridge Management Tasks

256  SL8500 User’s Guide

Caution – Possible Media Damage. While you can enter cartridges 
that do not contain external labels or place cartridges upside-down, 
this is not advisable. Such conditions present problems when the 
system performs an audit. Likewise, do not enter cartridges 
containing unreadable or damaged labels.
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▼ Display Library Cartridge Information in Tabular Format

Note – This feature is available starting with SL8500 firmware 
version FRS_6.00 and SL Console version 4.65.

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display detailed information about all library cartridges in a 
sortable, tabular format. The information includes the cartridge vol-ids, locations, 
and media types. You can use this report for a variety of purposes, such as to:

• Locate cartridges by library internal address

• Verify that all cartridges in the library have valid, readable barcode labels

• Identify cleaning and diagnostic cartridges

• Identify cartridge media types in a mixed-media library

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 23 for details. To display most of the same data in a straight text 
format, see “List Library Cartridges” on page 261. 

Task Steps

1. Select Tools > Reports. 

The navigation tree lists all library report options. 
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2. Expand the Status Summary folder in the navigation tree.

The Status Summary reports display in a list. 

3. In the navigation tree, select Cartridge Table in the navigation tree. 

The Cartridge Table Report displays. See “Screen Fields” on page 259 below for a 
detailed description of each screen field.

4. If you want to search the report data or save it to a file, complete the following 
procedures:

• “Search a Library Report” on page 53 

• “Save Library Report Data to a File” on page 55
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Screen Fields

lib, rail, col, side, row

Library, rail, column, side, and row. Together, these values identify the library 
internal address where the cartridge is located. 

For a detailed description of the library internal address format, see .

Location Type

Type of library location where the cartridge is located. Options are:

• CAP: CAP cell

• cell: Regular storage cell

• drive: Loaded in a tape drive

• sysCell: System (reserved) cell; cleaning or diagnostic cartridges are typically 
stored in these cells 

Media Type

Type of media in the cartridge. For example, Lto Gen3_400GB, 9840_R, T10000. 

Type

Domain, or usage type, of the cartridge. Options are:

• clean: Cleaning cartridge

• data: Data cartridge

• diagnostic: Diagnostic cartridge

Label 

Unique vol-id of the cartridge. Standard vol-ids are eight characters in length. 

A value of #UREAD indicates the barcode label is unreadable. Possible reasons for 
this are as follows:

• The label is missing, damaged, or upside-down. In this case, the Custom Label 
field also indicates #UREAD. 

• The label has a non-standard format, such as a ten-character vol-id, or an 
unrecognized cartridge domain or media type indicator. In this case, the non-
standard vol-id displays in the Custom Label field. 

The library controller does not allow you to mount an unlabeled or unknown type 
cartridge into any tape drive. 

Custom Label

Non-standard vol-id of the cartridge, if applicable (requires the Open Format 
Volser feature). Possible entries for this field are as follows:

• Blank: The cartridge has a readable, standard eight-character vol-id cartridge 
label, as indicated in the Label field. 
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• #UREAD: The cartridge label is truly not readable, possibly because it is 
missing, damaged, or upside-down. 

• Any other value: Indicates the non-standard vol-id of the cartridge. 
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▼ List Library Cartridges

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display information about all library cartridges, including their 
vol-ids, locations, and media types. 

To display the same data in a tabular format, see “Display Library Cartridge 
Information in Tabular Format” on page 257.

Task Steps

1. Select Tools > Reports. 

The navigation tree lists all library report options. 

2. Expand the Status Summary folder in the navigation tree.

The Status Summary reports display in a list. 
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3. Select Cartridge Summary. 

The Cartridge Summary report displays.

See the following “Screen Fields” on page 262 for a detailed description of each 
screen field.

4. If you want to search the report data or save it to a file, see the following 
procedures:

• “Display a Library Report” on page 51 

• “Save Library Report Data to a File” on page 55

Screen Fields

Location

Library, rail, column, side, and row. Together, these values identify the library 
internal address where the cartridge is located. 

For a detailed description of the library internal address format, see “Cartridge 
Slot Locations” on page 431.

Location Type

Type of library location where the cartridge is located. Options are:

• CAP: CAP cell

• cell: Regular storage cell

• drive: Loaded in a tape drive
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• sysCell: System (reserved) cell; cleaning or diagnostic cartridges are typically 
stored in these cells 

Media Type

Type of media in the cartridge.

Type

Domain, or usage type, of the cartridge. Options are:

• clean: Cleaning cartridge

• data: Data cartridge

• diagnostic: Diagnostic cartridge

Cartridge 

Unique vol-id of the cartridge. Standard vol-ids are eight characters in length. 

A value of #UREAD indicates the barcode label is unreadable. Possible reasons for 
this are as follows:

• The label is missing or damaged. 

• The label has a non-standard format, such as a ten-character vol-id, or an 
unrecognized cartridge domain type or media type indicator. 

The library controller does not allow you to mount an unlabeled or unknown type 
cartridge into any tape drive. 
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▼ Locate a Cartridge by vol-id

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the current location of a cartridge with a specified 
volume ID. The location can be displayed in one of the following formats:

• Library internal address

• HLI-PRC address (HLI hosts only)

Task Steps

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the Search tab.

The Library Search page appears. 

The Requester field controls the address format that will be displayed for the 
cartridge location. 

• To display the library internal address, select default.
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• To display the HLI-PRC address, select hli0 or hli1. 

3. Click the Search tab. 

The Search Result section displays all cartridges meeting the search criteria. 
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▼ Locate a Cartridge by Address

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display detailed information for cartridges with a specified 
location. Using wildcards, you can display all cartridges in a specified general area 
(for example, in a specified panel, row, or column). You can specify the location using 
one of the following formats:

• Library internal address

• HLI-PRC address (HLI hosts only)

Task Steps

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the Search tab.

The Library Search page appears. 

3. In the Search Type list, select Location. 
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Note – The default Search Type is VOLID. 

The page updates to display fields enabling you to search by location. 

4. In the Location list, select the type of match you want to perform in the search.

5. In the Requester list, select the type of address format you want to use for the 
search. 

6. In the Location field, enter the parameters for the search. 

The format you use must correspond to the Requester you have specified. For 
example:

• Use the library internal address format if Requester is “default”.
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• Use the HLI-PRC address if Requester is an HLI host.
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Note – You cannot use wildcards in the Location field. 
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▼ Move a Specified Cartridge by vol-id

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to move a cartridge with a specified vol-id to a specified location 
within the library. 

Note – This procedure updates the cartridge’s location in the 
library controller database, but not in the host database. Therefore 
after performing this procedure, you must perform an audit from 
the host software to update the host database. Failure to do so will 
cause future mount requests from the host software to fail. 

Caution – Potential data overwrite. Use caution when performing 
this procedure in partitioned libraries. You could inadvertently 
move a cartridge from one partition to another, which would allow 
the new partition to overwrite data on the cartridge.

Task Steps

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the RcvrMove tab. 

The Recovery Move page appears. 
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3. In the Source Location Mode section, select VOLID. 

The page updates with the appropriate Source Location choices. 

4. In the VOLID field, enter the vol-id of the cartridge you want to move. 
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5. In the Destination Location Type list, select the type of location where you want 
to move the cartridge to. Options are:

• CAP

• Storage Slots 

• Drive

• Reserved Slots

The following restrictions apply to your selection:

• The destination can be a drive only if the source is a CAP or reserved slot. 

• For you to move a cartridge to a drive, the cartridge media type must be 
compatible with the drive type. 

• You cannot move a cartridge to a location that is already occupied. 

• Although not strictly enforced, it is recommended that only diagnostic or 
cleaning cartridges be moved to reserved slots. 

6. In the Destination Location table, specify the library internal address of the 
destination location by making the appropriate selections in the following lists:

• Library

• Rail 

• Column

• Side
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• Row

The following special selections are available on the lists:

• Min: First element of that location type (library, rail, column, side, row) in the 
library 

• Max: Last element of that location type (library, rail, column, side, row) in the 
library 

Caution – )Potential overwrite of data or loss of access. If the library is 
partitioned, make sure to keep the cartridge in the same partition it 
is currently allocated to. If you move a cartridge to a cell allocated 
to a different partition, the host could treat the cartridge as scratch 
and overwrite the data. If you move the cartridge to an unallocated 
cell, no hosts will be able to access the cartridge. 
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7. Click the Start button.

The robot moves the cartridge. A success message appears when the operation 
completes. 

8. Click OK.

9. To verify the new location, you can display a Cartridge Summary Report. See 
“List Library Cartridges” on page 261 for details. 

For example: 

10. To update the new cartridge location in the host database, initiate a library 
audit from the host software. See the appropriate tape management software 
documentation for the procedures and commands.
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▼ Move a Cartridge From a Specified Location

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to move a cartridge from one specified location to another within 
the library. 

Note – This procedure updates the cartridge’s location in the 
library controller database, but not in the host database. Therefore, 
after performing this procedure, perform an audit from the host 
software to update the host database. If you do not perform the 
audit, future mount requests from the host software will fail.

Caution – Potential overwrite of data. Use caution when performing 
this procedure in partitioned libraries. You could inadvertently 
move a cartridge from one partition to another, causing the new 
partition to overwrite data on the cartridge. 

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the RcvrMove tab. 

The Recovery Move page appears. 
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3. In the Source Location Mode section, select Location. 

The page updates with the appropriate Source Location choices. 

4. In the Source Location Type list, select the cartridge’s current location type. 
Options are:

• CAP

• Slot

• Drive

• Reserved Slots

5. In the Source Location table, specify the library internal address of the source 
location by making the appropriate selections in the following lists:

• Library

• Rail 

• Column

• Side

• Row

The following special selections are available on the lists:

• Min: First element of that location type (library, rail, column, side, row) in the 
library 
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• Max: Last element of that location type (library, rail, column, side, row) in the 
library 

6. In the Destination Location Type list, select the type of location where you want 
to move the cartridge to. Options are:

• CAP

• Storage Slots 

• Drive

• Reserved Slots

The following restrictions apply:

• The destination location can be a drive only if the source is a CAP or reserved 
slot. 

• For you to move a cartridge to a drive, the cartridge media type must be 
compatible with the drive type. 

• You cannot move a cartridge to a location that is already occupied. 

• Although not strictly enforced, it is recommended that only diagnostic or 
cleaning cartridges be moved to reserved slots. 

7. In the Destination Location table, specify the library internal address of the 
destination location by making the appropriate selections in the following lists:

• Library

• Rail 

• Column

• Side

• Row

The following special selections are available on the lists:
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• Min: First element of that location type (library, rail, column, side, row) in the 
library 

• Max: Last element of that location type (library, rail, column, side, row) in the 
library 

Caution – )Potential overwrite of data or loss of access. If the library is 
partitioned, keep the cartridge in the same partition it is currently 
allocated to. If you move a cartridge to a cell allocated to a different 
partition, the host could treat the cartridge as scratch and overwrite 
the data. If you move the cartridge to an unallocated cell, no hosts 
will be able to access the cartridge. 

8. Click the Start button.

The robot moves the cartridge, and then a success message appears.
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9. Click OK.

10. To verify the new location, you can display a Cartridge Summary Report. See 
“List Library Cartridges” on page 261 for details.

The following is an example.

11. To update the new cartridge location in the host database, initiate a library 
audit from the host software. See the appropriate tape management software 
documentation for the procedures and commands.
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▼ Display the Media Events Report

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Media Events Report summarizes library cartridge media events and updates 
whenever a media event or error occurs on any drive. Displaying up to 2000 entries, 
the report is helpful for identifying and diagnosing faulty cartridges.

For each cartridge that has experienced media events, the report lists:

• The vol-id of the cartridge

• The type of event

• The number of occurrences

• The date and time of the last such event

The report is sorted in vol-id order by default. Optionally, you can change the sort 
order, and rearrange and resize the columns. See .

Note – For cartridge events associated with particular drives, see 
“Display the Drive Media Events Report” on page 245. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Statistics folder, and select Media Events. 

Screen Fields

Cartridge Label 

VOLID of the cartridge that has experienced an event. 
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Event Type

Type of media event being tracked. Options are:

• Media Error: The drive indicated there was a problem with the media. Also, 
this possibly could indicate a problem with the drive.

• Misbuckle Error: The drive was unable to grab the buckle of the media and 
could not thread the tape. The media is likely damaged. 

Number of Events

Total number of events of this type that have been recorded for this cartridge. 

Last Seen

Date and time of the most recent occurrence of the event.
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Drive Cleaning

Library tape drives require periodic cleaning to prevent read/write errors. A drive 
cleaning occurs when the system mounts a compatible cleaning cartridge in response 
to a cleaning request from the drive.

With the SL8500, either host applications (such as ACSLS or ELS) or direct-attach 
applications (such as Symantec and NetBackup) usually manage all cleaning 
cartridge and drive clean functions. For additional details about this method, see 
“Host-Managed Drive Cleaning” on page 284.

Note – As of SL8500 firmware version FRS_7.00 and SL Console 
version 5.50, only your system administrator can configure and 
manage library auto clean through the command line interface 
(CLI). 



Host-Managed Drive Cleaning

284  SL8500 User’s Guide

Host-Managed Drive Cleaning 
You can use host tape management software (ACSLS or ELS) to manage drive 
cleaning in whole HLI libraries or partitions. The following is a summary of the 
actions to take in order to use host-managed cleaning. For full details, see the ACSLS 
or ELS documentation.

1. Confirm that the library auto clean function is disabled. (The auto clean feature is 
disabled by default on SL8500 libraries.) In partitioned libraries, confirm that it is 
disabled for all partitions.

Note – As of SL8500 firmware version FRS_7.00 and SL Console 
version 5.50, this activity is not available through the SL Console. 
Only the library administrator can perform it through the CLI. 

Library auto clean must be disabled in order for ACSLS or ELS to receive 
notification from the library when drives need cleaning. 

2. Enable automatic cleaning within the tape management software. 

• For ELS, see the MNTD AUtocln(ON) command in the ELS System 
Programmer's Guide for instructions on enabling the cleaning function. 

• For ACSLS, automatic cleaning is enabled by default. For details, see the 
AUTO_CLEAN variable, which is set by the acsss_config utility, in the ACSLS 
Administrator’s Guide. 

3. Use the applicable ACSLS or ELS commands to enter cleaning cartridges into the 
library. 

Do NOT use the SL Console Import/Export page to enter cleaning cartridges, as 
the library controller will store the cartridges in reserved system cells. ACSLS and 
ELS do not have access to these cells. 

4. Have the tape management software manage drive cleaning as required.

5. Use the applicable ACSLS or ELS commands to monitor status of cleaning 
cartridges and drives. 

6. Use the applicable ACSLS or ELS commands to eject cleaning cartridges from the 
library. 

You cannot use the SL Console Import/Export page to eject host-managed 
cleaning cartridges. 

The library auto clean feature enables the library controller to manage all drive clean 
functions. You can import cleaning cartridges into the library, where they are stored 
in reserved system cells. As soon as a drive indicates that it needs cleaning, the 
library controller automatically selects a compatible cleaning cartridge from the 
system cells and mounts it on the drive. When the cleaning activity is completed, the 
library controller dismounts the cartridge and returns it to a system cell. 

With the auto clean feature, the library tracks cleaning cartridge usage and sends 
notification  when cleaning cartridges have expired or have reached a user-defined 
usage threshold. Cleaning cartridges can be automatically exported from the library 
in bulk, by expiration date, or by selected cartridge volume ID (vol-id or volser). 

In partitioned libraries, auto clean can be configured for the entire library or for 
individual library partitions. 
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Host Interactions

With the auto clean feature, the library controller initiates a drive clean operation 
immediately upon receipt of a cleaning request from the drive. This request typically 
occurs when the drive dismounts a data cartridge. While the drive is being cleaned, 
the data cartridge dismount remains pending to the host. The host is not notified that 
the data cartridge dismount is complete until the drive clean operation has finished 
and the cleaning cartridge has been returned to a system cell. 

Unsuccessful Cleaning Operations

Any cleaning cartridges entered with the host tape management software (ACSLS or 
ELS) are stored in data cells and cannot be used for the library auto clean feature. 



Host-Managed Drive Cleaning

286  SL8500 User’s Guide



Robot, Safety Door and Power Supply Management   287

12

Robot, Safety Door and Power Supply 
Management

This chapter includes the following topics:

• “Robots” on page 287

• “Service Safety Door” on page 290

• “Robot Procedures” on page 290

• “Power Supplies” on page 291

• “Robot Monitoring Tasks” on page 293

• “Safety Door Monitoring Tasks” on page 297

• “Power Supply Monitoring Tasks” on page 301

Robots
The robots move cartridges between storage slots, tape drives, and the CAPs. Each 
robot can service up to 16 tape drives.

Note – Because of the four individual rails, each robotic assembly 
is considered a library storage module (LSM). The architecture of 
the SL8500 provides four separate and unique LSMs within a 
single library. 

FastLoad Feature

To optimize system performance, the robots automatically implement the Fast Load 
capability. Once a robot successfully inserts a cartridge into a drive, it is immediately 
available for the next request and does not wait until the drive reports that the 
cartridge has been loaded. The SL8500 library control electronics waits to return the 
response to the mount request until it detects that the tape drive has successfully 
loaded the cartridge tape.
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Redundant Robots

Two robots can service a single rail section within the library, providing redundancy. 
Each robot has two motors, if one fails, the other motor is powerful enough to move 
the defective robot into the forward service area. If both the motors fail for a robot, 
then the redundant robot moves the defective robot into the forward service area thus 
continuing robot operations.

Your Oracle support representative completes the following steps in order to install 
redundant robots: 

1. Install the Service Safety Door.

2. Upgrade the robot assemblies.

3. Upgrade the library firmware (FRS 2.50 or later).

4. Upgrade the HBS assemblies. These have an “X” on the upper left of the assembly.

5. Upgrade the HBN card .

6. HBQ rail terminator cards.

7. ENDSTOP bar code inserts in the three-cell arrays at the ends of all rails .

8. Additional DC power supplies.

Robot Initialization

When power is applied to the library, each robot begins its initialization routine. The 
sequence for initialization is in the following order:

Note – If there are multiple robots, each robot attempts 
initialization through the following sequence. If a failure is 
encountered in one robot, that robot is flagged as defective. 
Initialization continues for the other robots and, after they are 
successfully initialized, the defective robot is pushed into the 
maintenance area for replacement.

1. Logic/controller cards initialize (HBC/HBCR, HBB).

2. Rail communication is established with the robots: this is accomplished through 
the robot’s electrically conductive brushes that contact the rail. Robots are 
identified by number and hand address:

a. Number: The robot that encounters the left stop (referenced from the front of 
the customer interface module) is robot number “1,” the one encountering the 
right stop is robot number “2.”

b. Hand address: According to their rail location (numbered 1 – 4, from the top, 
down). See “Robot Numbering” on page 290 for more information.

3. If a service safety door is installed, the HBC/HBCR card checks that:

a. Both maintenance keys are in the vertical (OFF) positions

b. The door is in the center (disengaged) position. If the door is not in the correct 
position, the HBC/HBCR card will issue the command to move it into its 
center position.
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4. Robots move vertically (This is the only robot motion that is controlled by the 
microcode within the robot’s HBB card. All other motions are controlled by the 
HBC/HBCR card.)

5. The gripper sensors are checked. 

6. The hand retracts. This protects:

a. Hand components: If the hand’s “reach safe” sensor cannot be detected, 
initialization stops.

b. A customer cartridge that may have been left in the gripper during a power 
failure. If this is the case, the “cartridge present” sensor activates and the hand 
holds the cartridge in the retracted position.

7. Belt-driven wrist moves counterclockwise. 

8. For libraries without redundant robots, each robot moves to both the left and right 
end stops.

9.  For redundant robots:

a. Both robots move to their respective end stops

b. Both robots initialize.

c. The right robot remains at its end stop.

d. The left robot moves around the track to meet the right robot. This distance is 
calculated by the HBC/HBCR card as the absolute track distance.

e.  The left robot moves to the end of its track.

10. Robots move to an empty slot detection area (the slot under the bar code insert, in 
the 3-cell array at the front of the customer interface module) to verify proximity 
sensor accuracy. During normal operation, if an empty slot is detected, the “empty 
slot detector” sensor is activated. Non-labeled cartridges are also detected.

11. Belt-driven reach mechanism initializes by a wrist motion, pointing the hand to an 
aisle position, and reach components are then verified.

12. Gripper, reach, and scanner initialization is accomplished at the three cell array 
section:

a. If there is no cartridge in the gripper, the initialization continues.

b. If a cartridge is in the hand, the hand moves to the drop-off slot, the cartridge 
is placed in the slot, and gripper initialization continues.

Note – Cartridge drop-off slots are the bottom slots in the 3-cell 
arrays and the top fixed array slots under the PTP locations 
leading to a total of 16.

13. Hand points toward the rear of the library.

14. End status sent to HBC/HBCR card.

Note – If any hand or robotic error cannot be resolved by error 
recovery routines, the entire robot must be replaced.
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Robot Numbering

Rails are numbered from 1 (top rail) to 4 (bottom rail). They are also designated as 
separate library storage modules (LSMs) within a library. For example:

• Rails 1 and 2 can be designated LSMs for ELS, while rails number 3 and 4 can be 
designated LSMs for ACSLS.

• If only one host exists, all rails become separate LSMs for that host.

See “Cartridge Slot Locations” on page 431 for more details. 

Robots have the following numbering:

1. Library number (within a library complex)

2. Rail number: Rails are numbered 1 through 4, rail 1 is the top rail

3. Column number: Columns are “signed” numbers referenced from the customer 
interface module, where +1 is right of the center of the drive bays and -1 is to the 
left of the drive bays.

4. Side number: Outer wall = 1, Inner wall = 2

Note – Side numbers for robots are numbered according to their 
end stops: 1 (left robot stop) and 2 (right robot stop).

5. Row number: Numbered consecutively, from the top down

Note – Because robot hands are not storage slots, their row 
numbering is 0.

Robot Numbering Examples 

• Location 1, 1, 0, 1, 0 = the robot on rail 1 (top rail) that encounters the stop on the 
left side of the customer interface module

• Location 1, 1, 0, 2, 0 = the robot on rail 1 (top rail) that encounters the stop on the 
right side of the customer interface module

• Location 1, 2, 0, 1, 0 = the robot on rail 2 (next rail down) that encounters the stop 
on the left side of the customer interface module

Robot Procedures
For detailed robot management procedures, see “Robot Monitoring 
Tasks” on page 293. 

Service Safety Door
SL8500 libraries with the redundant robots are equipped with an internal service 
safety door that allows your Oracle StorageTek support representative to safely 
perform maintenance and service on one robot while the other robot continues 
normal operations
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The safety door is a sliding barrier that closes off the left or right maintenance area 
from the operational portion of the library. The maintenance area is the space 
between the two front doors and the rear of the elevator/turntable assembly. A 
defective robot automatically moves into the maintenance area for service. 

The safety door is activated only by your Oracle support representative using a 
maintenance key. However, you can use the SL Console to monitor the status of the 
safety door.

Safety Door Procedures

See the following sections for detailed information about monitoring and using the 
safety doors:

• “Safety Door Monitoring Tasks” on page 297. 

• “Service Safety Door Operation” on page 429. 

Power Supplies

N+1 Base Power Configuration

The base power configuration contains one system power distribution unit (PDU) 
and one N+1 PDU. 

• The system PDU, connected directly to the branch circuit, provides AC power to 
three DC power grids and the electronics control module. 

• The N+1 PDU supplies added +48 VDC load sharing power to each of the three 
DC power grids and an extra AC-to-DC power supply for the electronics control 
module. 

The base power configuration provides power to the:

• Tape drive power supplies

• Robotic rail power supplies

• Customer Interface Module power supplies

• Touch screen operator control panel

• Electronics control module power supplies

Note – The base power configuration does not offer redundant 
AC power.

2N Power Configuration

The 2N power configuration contains the base power configuration (PDU 1) and a 
second PDU, PDU number 2. 

This configuration provides power to the same components as N+1, plus power for:

• Optional, redundant load sharing power supplies

• Two additional accessory racks for customer components

• Redundant library controller cards
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Note – The 2N PDU is required for the 2N drive power, 2N 
robotic power, and also for the additional rack installed.

Power Supply Procedures

For detailed power supply procedures, see “Power Supply Monitoring 
Tasks” on page 301. 
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Robot Monitoring Tasks

Task Page

Display Robot Summary Information  294

Display Robot Status  295

Display Robot Properties  296
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▼ Display Robot Summary Information

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display summary information for the library robots. 

Note – This information is also available through 
Reports > Robot Summary. See “Display a Library 
Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Click the Robot folder on the navigation tree.

The Robot Data page appears. 



Robot Monitoring Tasks

Robot, Safety Door and Power Supply Management   295

▼ Display Robot Status 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the current operational state of a robot. 

Note – This information is also available through 
Reports > Robot Details. See “Display a Library 
Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Robot Folder in the navigation tree, and click the robot you want to 
display. 

3. Click the Status tab.

The page displays the current status of the selected robot. 
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▼ Display Robot Properties 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display detailed robot configuration information, including the 
serial number and current firmware levels.

Note – This information is also available through 
Reports > Robot Details. See “Display a Library 
Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot you want to display. 

3. Click the Properties tab. 

The Properties page appears. 
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Safety Door Monitoring Tasks

Task Page

Display Safety Door Summary Information  298

Display Safety Door Status  299

Display Robot Properties  296
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▼ Display Safety Door Summary Information

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display summary information for the safety doors. 

Note – The safety door is available only for libraries with the Dual 
Robot feature. 

Task Steps

1. Select Tools > System Detail. 

2. Click the Safety Door folder on the navigation tree.

The Safety Door Data page appears. 
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▼ Display Safety Door Status 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the current operational state of the safety door. 

Note – The safety door is available only for libraries with the Dual 
Robot feature. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Safety Door Folder in the navigation tree, and click the Safety Door. 

3. Click the Status tab.

The page displays the current status of the safety door. 
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▼ Display Safety Door Properties 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display detailed safety door configuration information, 
including the serial number and current firmware levels.

Note – The safety door is available only for libraries with the Dual 
Robot feature. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Safety Door Folder in the navigation tree, and click the Safety Door. 

3. Click the Properties tab. 

The Properties page appears. 
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Power Supply Monitoring Tasks

Task

Display Power Supply Summary Information  302

Display Power Supply Detail  303
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▼ Display Power Supply Summary Information

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Power Supply Data screen displays summary information for all power supplies 
in the library. You can use this screen to monitor the status of the power supplies. 

By default, the display is sorted by power supply internal address. Optionally, you 
can change the sort order, and rearrange and resize the columns. See “Modifying the 
Screen Layout” on page 23. 

Task Steps

1. Select Tools > System Detail.

2. In the Library navigation tree, click the Power Supply Folder.

The Power Supply Folder page displays. 
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▼ Display Power Supply Detail 

Task Tool

This procedure can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Power Supply Status screen displays detailed information for a selected power 
supply. You can use this screen to determine whether the power supply is in need of 
maintenance or replacement. 

Task Steps

1. Select Tools > System Detail.

2. In the Library navigation tree, expand the Power Supply Folder.

3. Click the power supply you want to display.

The Status screen displays. 
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Elevator and Pass-Thru Port Management

This chapter includes information on the following topics:

• “PTP Configuration” on page 305

• “Elevator and Pass-Thru Port Tasks” on page 308

PTP Configuration
The preferred method of adding a Pass-Thru Port (PTP) is by installing the PTP and 
second library to the left side (as viewed from the front of the existing library). This 
will makes the existing library a home library. This method does not require system 
reconfiguration.

If a PTP and second library are added to the right side (as viewed from the front of 
the existing library), this would make the existing library an away library and 
reconfiguration is required.

FIGURE 15-8 “Adding a PTP to an Existing Library Complex” on page 428 illustrates 
the concept of home and away libraries.

Nondisruptive Installation

Installing PTPs from right to left has several advantages:

• Existing libraries can remain operational while the PTP frame is attached to them 
during the installation of the adjacent library.

• No rebooting of ELS or ACSLS is required. 

• Mount requests continue as normal in the first library (or existing library 
complex). 

• If cartridges are placed into the new SL8500, an ACSLS or ELS audit must be run 
to add these cartridges to the database. The pre-existing LSMs can remain online 
during the audit.

The numbering process proceeds sequentially from right-to-left as follows:

• Existing Library A: LSMs 0-3

• Existing Library B: LSM 4-7
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• New Library C: LSMs 8-11

Disruptive Installation

Growing the library complex from left to the right requires the following:

• Taking the libraries offline 

• Renumbering the LSMs 

• Auditing the new and existing libraries to update volume locations

This type of installation is therefore is highly disruptive to the library operations. See 
“Perform a Disruptive PTP Installation – for ACSLS or ELS” on page 427 for detailed 
instructions. 

PTP Addressing Scheme

The following terms and definitions apply to PTP operations:

• Home Library: For two libraries connected by PTPs, the home library is the 
library supplying power and signals to the PTP through the left side of the Drive 
and Electronics Module, as viewed from the front of both libraries. 

• Away Library: For two libraries connected by PTPs, the away library is the library 
on the left side of the home library as viewed from the front of both libraries.

The PTP addressing scheme is the same five-digit value as the other SL8500 devices 
and locations (see “Internal Address” on page 432).

PTP numbering for the home library is:

• Library number

• Rail number (1-4 [internal firmware] or 0-3 [host])

• -6 (Column number)

• 1 (Side number)

• 0 (Row number)

PTP numbering for the away library would be:

• Library number

• Rail (LSM) number (1-4 [hardware] or 0-3 [host])

• +6 (Column number)

• 1 (Side number)

• 0 (Row number)
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Note – Columns +6 and -6 are the PTP areas for a library. Column 
+6 in a library firmware address refers to libraries connected to 
the right, -6 indicates libraries connected to the left.  
 
However, the host software (ACSLS and ELS) consider Panel 1 as 
the PTP area, whereas elevators are Panel 0. The first library 
installed in the complex is 1 and each additional library added to 
the complex increments by 1. 

Home and away designations are always referenced from a PTP perspective of the 
library it is connected to. When more than two libraries are connected in a complex, 
every library that has two neighbors is both a home and away library, depending on 
the perspective of the PTP devices. For example, the middle library in a set of three is 
the home library for the PTP's on its left and the away library for the PTPs on its 
right. 

PTP and Power Supply Procedures

For detailed power supply procedures, see “Elevator and Pass-Thru Port 
Tasks” on page 308. 
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Elevator and Pass-Thru Port Tasks

Task Page

Display Elevator Summary Information  309

Display Elevator Status  310

Display Elevator Properties  311

Display Pass-Thru Port Summary Information  312

Display Pass-Thru Port Status  313

Display Pass-Thru Port Properties  314
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▼Display Elevator Summary Information

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to display summary information for all library elevators. 

Note – This information is also available through 
Reports > Status Summary > Library Information. See “Display a 
Library Report” on page 51 for detailed instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Select the Elevator folder in the navigation tree.

The Elevator Data screen appears.
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▼Display Elevator Status

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to display the current operational state of an elevator. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Elevator Folder, and select the elevator you want to display. 

3. Select Status.

The page displays the current status of the selected elevator. 
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▼Display Elevator Properties 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to display detailed elevator configuration information, including 
the serial number and current firmware levels.

Task Steps

1. Select Tools > System Detail. 

2. Expand the Elevator Folder, and select the elevator you want to display. 

3. Select Properties. 

The Elevator Properties page appears. 
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▼Display Pass-Thru Port Summary Information

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to display summary information for all library pass-thru ports 
(PTPs). 

Note – This procedure is applicable only if your installation 
includes a library complex. 

Task Steps

1. Select Tools > System Detail. 

2. Select the PTP folder in the navigation tree.

The PTP Data page appears. 
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▼Display Pass-Thru Port Status

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to display the current operational state of a pass-thru port (PTP). 

Note – This procedure is applicable only if your installation 
includes a library complex. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the PTP Folder, and select the pass-thru port you want to display. 

3. Select Status.

The page displays the current status of the selected pass-thru port. 
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▼Display Pass-Thru Port Properties

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to display detailed pass-thru port (PTP) configuration 
information, including the serial number and current firmware levels.

Note – This procedure is applicable only if your installation 
includes a library complex. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the PTP Folder, and select the pass-thru port you want to display. 

3. Select Properties. 

The PTP Properties page appears. 
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14

 SL Console Diagnostics and Utilities

The StorageTek Library (SL) Console enables you to perform many diagnostic tasks, 
including library self-tests and firmware upgrades.

This chapter includes information on the following:

• “Library Events” on page 315

• “Event Codes” on page 317

• “Library Self-Tests” on page 320

• “Audits” on page 322

• “Robot Diagnostic Moves” on page 324

• “Troubleshooting” on page 327

Library Events
The library controller continually monitors library operations and logs all events.

Event Monitors

The system stores event monitors under the following three headings:

• Communication events: Includes host-to-library, library-to-library, and library-to-
drive communications.

• Error event: Each error event is assigned a four-digit (hexadecimal) action code.

• Warning events: Indicate a loss of performance or conditions that may be 
indicative of future fatal errors.

You or your Oracle StorageTek support representative can use the SL Console to:

• Review library events

• Spool event data to a text file

The following information can help you diagnose the cause of the event:

• Date/time stamp: Identifies when the event occurred.

• Action codes: Identifies the command that was issued, such as “load drive.”
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• Result codes: Identify the result of the requested action. To look up a result code, 
see “List a Result Code” on page 337. 

• Known service plan diagnosis: Identifies the mechanism or component 
responsible for the task or fault.

Note – Using the SL Console, you can spool event data to a file.
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Event Codes
TABLE 14-1  Event Codes

Event Type Description Valid Codes

Activity 
Code

Activity associated with the event. 
For example, HLI host mount, 
diagnostic fetch, robot 
communication diagnostic. 

0000: no action / no activity 

0100199: common/shared activity (across devices 
and the controller)

0200–0299: common/shared activity (across 
devices - robot, drive, PTP, and so on)

0400–0499: common/shared configuration 
activity

1000–1999: host interface activity

2000–2999: management interface activity

3000–3999: internal server/library activity

4000–4999: partner library-initiated activity

5000–5999: robot activity

6000–6999: drive activity

7000–7999: CAP activity

8000–8999: elevator activity

9000–9999: PTP activity



Library Events

318  SL8500 User’s Guide

Result Code Reason for the activity. For 
example,  
Activity: HLI host mount  
Result: robot X cartridge fetch 
failure

0000: no problem / normal

0100–0199: common/shared results (across 
devices and the controller)

1000–1999: host interface results

2000–2999: management interface results

3000–3999: internal server/library controller 
results

4000–4999: partner library interface results

5000–5999: robot results

6000–6999: drive results

7000–7999: CAP results

8000–8999: elevator results

9000–9999: PTP results

Severity Identifies the significance of the 
event from the perspective of the 
activity associated with the event. 
The severity levels also identify 
log activity that must persist in the 
system across machine power 
cycles from that which might be 
considered volatile.

Error (1): Indicates a fault occurred which 
prevented a request (host or diagnostic) from 
completing successfully. Error data is non-
volatile and accumulates across machine power 
cycles.

Warning (2): Indicates a fault occurred, but the 
fault has not stopped the library’s ability to 
complete requests (host or diagnostic). Warning 
data is non-volatile and accumulates across 
machine power cycles.

Information (3): Indicates data that is not 
significant, but may be important to establish a 
history of activity around a severity 1 or 2 event. 
Information data is volatile. 

Configuration (4): Indicates change in the 
library’s configuration. This includes the 
addition and removal of drives, robots, 
controllers, and interface cards. This also 
includes changes to the software configuration. 
Configuration data are non-volatile resources 
and accumulate across machine power cycles.

Diagnostic (5): Records normal diagnostic 
activity tracing. This is independent of the debug 
or trace activity when a diagnostic activity 
affects the availability of drives or other devices 
to host operations. Diagnostic data is volatile.

Request 
Identifier

Identifies all host interface 
requests. Helps track the sequence 
of log activity resulting from each 
host request. 

TABLE 14-1  Event Codes
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Library Firmware Upgrades
The library firmware resides on the library controller. Initial firmware is installed at 
the factory. Library firmware does not contain drive code upgrades. When new 
firmware is released, you must use the code load utility to upgrade the firmware on 
the library and associated devices (CAP and robot).

Firmware Upgrade Process

The steps for loading firmware code on the library controller are as follows: 

1. Locate the firmware upgrade package (.jar file) on the Oracle download site.

2. Download the code to a folder on your local PC or workstation. 

3. Download the firmware package from your PC or workstation to the library 
controller. This process also unpacks the package after downloading to make it 
ready for activation. See “Download Code to the Library Controller” on page 340. 

4. Activate the downloaded code on the library controller. See “Activate Code on the 
Library Controller” on page 345. 

5. Reboot the library to make the code operational. See “Download Code to the 
Library Controller” on page 340. 

Firmware Download Site

The SL8500 library firmware package is a .jar (Java Archive) file. The file is 
available at the Oracle Software Delivery Cloud at the following URL: 

http://edelivery.oracle.com/ 

Multiple Versions of Firmware

You can store up to two versions of the SL8500 firmware in the library controller flash 
memory. By storing two versions:

• The library can continue normal operations and run one version of firmware, 
while you download and unpack an upgrade package. Then you can activate the 
upgrade at a time that is convenient for library users. 

• You can revert to a previous version of firmware without having to download and 
unpack the code package again. 

Concurrent Upgrades on All Libraries in a Complex

Note – This feature is available starting with SL8500 firmware 
version FRS_6.00 and SL Console version 4.65. 

For library complexes, you can conduct firmware upgrades for all libraries in the 
complex from a single SL Console session. During the firmware download, the new 
code is automatically distributed and unpacked on all libraries in the complex 
concurrently.
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During the firmware activation, the new code is activated, and all libraries in the 
complex are rebooted concurrently. As a result, a firmware upgrade for a library 
complex takes about as much time as for a single library. 

Upgrades and Redundant Electronics

Note – This feature is available starting with SL8500 firmware 
version FRS_6.00 and SL Console version 4.65. 

Firmware upgrades for libraries with the Redundant Electronics feature are 
minimally disruptive to library operations. New code loads simultaneously on the 
active and standby (alternate) controller cards and on all devices. The system 
activates the code, and reinitializes the active and standby (alternate) controllers, and 
most devices. In most circumstances, robot initialization is bypassed. During the 
upgrade process, the library continues normal operations without interruption.

For details about this feature, see “Redundant Electronics Management” on page 205. 

Related Procedures

For detailed firmware upgrade procedures, see “Library Utility Tasks” on page 339. 

Library Self-Tests 
The self-test diagnostic utility is intended to help diagnose basic problems with the 
library. A self-test typically runs after the library is installed. The test also can be run 
whenever necessary. 

You can run library self-test routines in either non-disruptive or disruptive mode. In 
non-disruptive mode, all cartridges used in the test are returned to their original 
locations. Disruptive mode may leave cartridges in a different location from where 
they started. 

When performing a self-test, the system:

1. Checks the communication path between the library controller, drives, elevators, 
and robots.

2. Performs get and put operations to check the health of the robots, elevators, and  
CAPs. This includes get and put operations from a reserved system cell to a 
random empty storage cell or CAP cell.

3. Performs a full library audit.

4. Performs mounts and dismounts of diagnostic cartridges for all the drives 
installed in the library. The self-test does not begin unless a diagnostic cartridge is 
found in the system cells. If the system finds a compatible diagnostic cartridge, 
the self-test repeats for each drive type. If the system does not find a diagnostic 
cartridge for a drive type, the system skips the mount/dismount operation for the 
drive.

Related Procedures

For detailed procedures, see “Library Utility Tasks” on page 339. 
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Diagnostic Cartridge Management
Library self-tests and some other diagnostic activities require the use of diagnostic 
cartridges. Ensure the library contains a sufficient number of diagnostic cartridges for 
these activities. 

Diagnostic cartridge volume IDs (vol-ids or volsers) must be eight characters in 
length, with “DG” as the first two characters. The library import/export function 
works only for diagnostic cartridges with labels in this format. 

The system stores diagnostic cartridges in reserved system cells which the library 
controls. Host library applications cannot access diagnostic cartridges. The number of 
system cells available for diagnostic cartridge storage varies, depending on the 
configuration of your SL8500 library.

See “Reserved System Cells” on page 631 for details. 

CAP Import/Export Screen

You can use the Diagnostics > CAP > Import/Export screen to import and export:

• Diagnostic cartridges. See “Importing and Exporting Diagnostic 
Cartridges” on page 321 below. 

Importing and Exporting Diagnostic Cartridges

See “Import Diagnostic Cartridges” on page 368 for detailed instructions. 

Any diagnostic cartridges entered with the host tape management software (ACSLS 
or ELS) are stored in data cells and cannot be used for library diagnostic activities. 

To remove diagnostic cartridges from the library, use the SL Console Export 
function.You can choose to export all diagnostic cartridges or selected ones. 

 See “Export Diagnostic Cartridges” on page 371 for detailed instructions.

Note – The command line interface (CLI) also provides diagnostic 
cartridge import and export commands accessible to your Oracle 
support representative.

Related Procedures

For detailed procedures, see “Diagnostic Cartridge Management Tasks” on page 367. 
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Audits 
During an audit, the system reads and catalogs cartridges within a library, and 
verifies the locations of cartridges or validates a range of slot locations. The library 
controller maintains a cartridge database that contains the following information for 
all the cartridges in the library:

• Volume ID (vol-id or volser) 

• Current location (in library internal address format)

• Verified status (true or false)

During library initialization, the library audits the location and vol-id of all cartridges 
in the storage and reserve slots. The library audits all cartridge locations in the 
storage and reserved areas at the following times:

• After one or both access doors have been opened and closed

• An audit request is made through the SL Console

• A host request to audit the library is entered

You can use the SL Console to perform the following types of audits:

• “Physical Audit” on page 323 

• “Verified Audit” on page 323

Caution – System-level problems may occur if a host’s record of the 
cartridge does not match what is in the cartridge database of the 
library controller. 

Audit Indicator

Note – The  audit indicator feature is available starting with 
SL8500 firmware version FRS_7.70 and SL Console version 5.70.

The SL Console displays a spinning visual indicator and the message “Audit in 
progress” to indicate an audit is in progress. The audit indicator displays:

• Whenever a library access door has been opened and closed

• In libraries with an AEM, whenever the AEM access door is closed

The indicator may also display during power up in libraries with redundant 
electronics or after a reboot. 

When you see the audit indicator at the bottom of the screen along with the message 
“Audit  in progress,” do not open the library access door. Otherwise, the library must 
start the audit  process from the beginning.

Note – The audit indicator does not display for audits you initiate  
through the SL Console or the host.
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Physical Audit

In a physical audit, the robot visits cartridge locations and verifies the vol-id of 
resident cartridges. The library controller updates the cartridge database based on the 
physical audit. This audit changes the “verified” status of the cartridge locations to 
“True.”

Audit times vary according to the size of the library, the number of HandBots, and 
the speed of the scan engine for the barcode scanner.

The library performs a physical audit at the following times:

• At library power-up, or when a library access door has been opened and closed. 
This is always a full audit of the entire library. 

• When initiated manually from the SL Console. The following are the two types of 
manually initiated physical audits.

• Entire library audit: The robot:

• Visits all cells (storage, CAP, and drive)

• Catalogs the vol-ids and locations

• Updates the library controller cartridge database 

This audit is a background process, meaning it does not interrupt online 
library operations. The estimated time for a physical audit of an entire library 
is from less than 10 minutes for a 1,448 cartridge library to 45 minutes for 6,632 
cartridge library. See “Audit the Entire Library” on page 379 for details.

• Specific range audit: The robot visits only a specific range of cells (storage, 
CAP, and drive) and updates the library controller cartridge database. The 
audit information is displayed on the SL Console while the audit is performed. 
See “Audit a Range of Cells” on page 380 for details.

Verified Audit

A verified audit validates the status of a specific cartridge location or range of 
locations (including CAPs and drives) in the cartridge database. If a cartridge address 
has a verified status of “false,” a physical audit of that location is performed and the 
cartridge database is updated.

The progress of the audit is displayed in the Audit Console section of the SL Console. 
See “Perform a Verified Audit” on page 381 for details. 

Virtual Audit 

A virtual audit displays a report listing the contents of the cartridge database. 

Related Procedures

For detailed procedures, see “Audit Tasks” on page 378. 
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Robot Diagnostic Moves
Diagnostic moves are used to monitor or diagnose a problem with a robot. The move 
can be performed with or without cartridges. 

Successful diagnostic moves do not rearrange the cartridges in the storage cells. 
Instead, the system returns cartridges to their original locations after the diagnostic 
move completes. However, some diagnostic move failures can cause cartridges to be 
left in new locations. 

A diagnostic move involves the following elements:

• “Target Address Range” on page 324

• “Pool Address Range” on page 324

• “Move Access Order” on page 325

• “Robot Selection” on page 325

Target Address Range 

The system performs the get operation in a diagnostic move within a target address 
range of the library. There are two types of access orders for a target address:

• “Sequential Access Order” on page 325 

• “Random Access Order” on page 325 

Valid target address types are:

• Storage cells: Reserves storage locations as the target/pool range

• CAP: Reserves cells in a CAP as the target/pool range

• Drive and storage cells: Reserves drives and storage cells as the target/pool range

• System cells: Reserves system cells, which contain cleaning or diagnostic 
cartridges, as the target/pool range

• All: Reserves storage cells, system cells, CAP cells and drives as the target/pool 
range

Note – Selecting the Storage, CAP, Drive, System, or All option 
does reserve all the associated locations as the target range. 
However, only the location currently being accessed by the robot 
for a get/put operation is unavailable to the host.

Pool Address Range

The system uses the pool address range locations to supply cartridges required for 
diagnostic moves to and from the target address range. Also, the system uses a pool 
address in a get operation if a target address does not contain a cartridge. 

There is no specified access order within the pool address range. The pool address 
ranges do not and cannot include drive locations.
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Move Access Order

Sequential Access Order

In a diagnostic move with a sequential access order, the robot performs a get 
operation starting with the first location in the target address ranges. The robot 
continues visiting the locations sequentially through the range until it completes the 
requested number of moves. 

Note – If you choose not to move cartridges, the get/put 
operations are not performed. In such a case, the robot positions 
itself at the target and pool addresses.

Random Access Order

In a diagnostic move with a random access order, the robot randomly picks a location 
in the target address range to get a cartridge. The robot can also visit the same 
location in the in the target address range multiple times to get a cartridge. The 
random access routine ends after the requested number of moves is complete. 

If you choose not to move cartridges the get/put operations are not performed. The 
robot just positions itself at the target and pool addresses. 

Robot Selection

The system chooses a robot for the diagnostic move based on the minimum and 
maximum ranges you set for the target and pool addresses. Multiple robots maybe 
selected if the address range requires it.
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Diagnostic Move Control Functions

The following TABLE 14-2 lists the options available to manage moves that are 
currently open.

TABLE 14-2  Menu Options for Open Diagnostic Moves

To Select Menu Option Notes

Start File > Start Sequence

Pause File > Pause Sequence Stops all diagnostic moves, but maintains the 
current location in the access order

Stop   File > Stop Sequence Stops a running or paused exerciser

Resume File > Start Sequence Resumes a paused exerciser starting with the 
last known location in the target address 
range

Clear the messages 
displayed in the 
monitor window

File > Clear Output Window Erases the previous message lines and 
continues to fill the screen with new messages

Spool Spool File > Start Spooling Directs the move output to a file

Stop spooling the 
exerciser output to a 
file

Spool File > Stop Spooling Stops directing the move output to the spool 
file

Note – If multiple diagnostic moves are open, each move has its 
own monitor screen.

Related Procedures

For detailed procedures, see “Robot Utility Tasks” on page 394. 
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Troubleshooting 
Before you run diagnostic tests, check the following areas of the library by using the 
following troubleshooting tips in the following TABLE 14-3.

TABLE 14-3  Troubleshooting Tips Prior to Running Diagnostic Tests

Problem What to do

Service Required (amber) 
LED is constantly on.

Using the SL Console, check the health of the library and the attached 
devices (drives, CAPs, and robots).  
See “StorageTek Library Console” on page 19 for more details about 
operations.

To perform a health check:

1. Log in to the SL Console application.

2. Access the System Detail module, View > System Detail.

3. Check the navigation tree for the following indicators:

• Device Healthy

• Device Error

Additional checks:

• Check the Status (for example, online/offline) and Statistics (for 
example, uptime, downtime, errors and warnings) tabs for more 
information on the health of the library and devices. 

• Make sure the cartridges are fully seated and properly oriented in 
their storage cells.

• Inspect the X table for any foreign objects or debris and remove them 
if found.

CAP Open LED is on 
and blinking.

Open the CAP and make sure the cartridges in the CAP cells are properly 
seated. 

The SL Console does not 
display modified data or 
information remains 
static.

Check the SL Console Heartbeat icon.
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Robot Fault or Library 
Fault Amber LED is 
constantly on.

1. Check the SL Console for any displayed error messages. Write down 
the error messages reported.

2. Open the front door. Observe and note the state of the cartridges, 
hand, and tape drives.

3. Make sure cartridges are fully seated and properly oriented in their 
storage cells.

4. Make sure packing materials have been removed.

5. Inspect the library floor for any objects or debris. If there are any, 
remove them.

6. Check the status of the tape drives.

7. Close the front door.

8. Make sure the tape drives are fully seated and locked forward by 
pushing and pulling on the rear of the drive tray. Any motion of the 
tray indicates that it requires reseating and locking down.

Tape drive is unable to 
eject a cartridge.

Manually remove the cartridge from the tape drive. See “Remove a 
Cartridge from a Tape Drive” on page 421.

The client computer 
cannot communicate 
with the library or tape 
drives.

Make sure cables are securely attached to their connectors on the rear of 
the library, the tape drives, and the client computer. 

The library is unable to 
communicate with the 
drives.

Drive status on the SL 
Console displays Not 
communicating.

Make sure cables are securely attached to their connectors on the rear of 
the library, the drives, and the client computer. 

Repeated or excessive 
drive cleanings or 
cleaning messages.

1. Replace the cleaning cartridge with a new cleaning cartridge.

2. Run the Library Self-Test and note if errors are reported for the drive.

3. Run any client computer-based drive diagnostic tests.

TABLE 14-3  Troubleshooting Tips Prior to Running Diagnostic Tests

Problem What to do
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Diagnostic Support Information
The library maintains the MIB file, the Library Log Snapshot file and the Device 
Reserve table to aid in troubleshooting and problem diagnosis. (The Device Reserve 
table has been added as of SL Console 5.8 and FRS_8.0.) Depending on 
circumstances, your Oracle support representative can capture and transfer these 
files, or request that you do so. 

MIB File

The Management Information Base (MIB) file is an SNMP database used to manage 
your library devices. This file can be saved as a text file. See “Transfer the Library 
MIB File” on page 353 for detailed instructions. 

Library Log Snapshot File

The Library Log Snapshot File is an encrypted snapshot of the library event log. You 
cannot view or edit this file. This file is available for only 15 minutes from the time it 
is generated. See “Generate and Transfer the Library Log Snapshot File” on page 357 
for detailed instructions.

Device Reserve Table

As of SL Console 5.8 and FRS_8.0., the Device Reserve Table is available to assist 
Oracle support representatives in troubleshooting tasks.

Related Procedures

For detailed procedures, see “Library Utility Tasks” on page 339. 
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Diagnostic and Utility Tasks 
Library diagnostic and utility tasks are divided into the following categories:

• “Event Monitor Tasks” on page 331

• “Library Utility Tasks” on page 339

• “Diagnostic Cartridge Management Tasks” on page 367

• “Audit Tasks” on page 378

• “Drive Utility Tasks” on page 389

• “Robot Utility Tasks” on page 394
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Event Monitor Tasks

Task Page

Display an Event Monitor  332

Spool Event Monitor Data to a File  333

Display Multiple Monitors  334

List a Device Status Code  335

List a Result Code  337
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▼ Display an Event Monitor

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Event monitors are useful tools for root cause analysis of errors. If the library is 
experiencing reproducible errors, you can open an event monitor and spool all events 
to a file to capture the data. Later, you can send the file to your Oracle support 
representative for analysis.

Event monitor information is dynamically updated depending upon the occurrence 
of selected events. The information sent during an e-mail, print, save, or spool 
operation reflects the data (and format) shown on-screen at the time the operation is 
requested. 

Note – To monitor multiple events, see “Display Multiple 
Monitors” on page 334.

Task Steps

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree. 

The system displays the library monitors accessible to you.

3. Click the event monitor you want to use, and then click the Open button in the 
upper right corner. 

The system displays the associated data collected for the event.

4. Manage the information displayed on the screen for the event selected using 
the appropriate options.

The following TABLE 14-4 lists the options available and how to access them.

TABLE 14-4  Options for Managing Event Monitor Information

To Select

Pause the continuous display of data related to the event 
selected

Monitor > Pause

Resume displaying the events Monitor > Resume

Permanently stop the continuous display of data related 
to the event selected

Monitor > Stop

Clear the event monitor display Monitor > Clear

5. To close a monitor, click the X in the upper right corner of the window. 
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▼ Spool Event Monitor Data to a File

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to spool and save event monitor data to a file. You can send the 
file to your Oracle support representative to assist in diagnosing problems.

Task Steps

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree. 

The system displays the library monitors accessible to you. 

3. Click the event monitor you want to use, and then click Open in the upper right 
corner. 

The system displays the event monitor window.

4. In the event monitor window, select Spool File > Start Spooling. 

The Save dialog box appears.

5. Browse to the directory where you want to save the file. In the File Name field, 
enter the file name, and click Save. 

All event data is spooled to the specified file. 

6. To stop spooling, select Monitor > Stop Spooling. 

Following is a sample of the spool file:
2008-05-29T11:23:27.448  0,1,0,0     root  default       internal        281    
warn   0  rb_Reboot::reboot(): Resetting drive [0,3,4,9] 
2008-05-29T11:23:27.760  0,1,0,0     root  default       internal        281    
info   0  Service Beacon is ACTIVE: Current Health Event indicates Drive 04 in 
Module 03 is not operational 
2008-05-29T11:23:53.211  0,1,0,0     root  default       internal        281    
info   0  Service Beacon is ACTIVE: Current Health Event indicates Drive 04 in 
Module 03 is operational 
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▼ Display Multiple Monitors

You can open and manage multiple event monitors using the selections from the 
Options Bar shown in the following TABLE 14-5.

TABLE 14-5  Options for Opening and Managing Multiple Event Monitors

To Select

Custom arrange the open monitors on screen Window > Arrange

Arrange the event monitor windows horizontally Window > Tile 
Horizontal

Arrange the event monitor windows vertically Window > Tile Vertical

Stack the event monitors Window > Cascade
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▼ List a Device Status Code

Task Tool

This task can be performed at either of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to list device status codes and their descriptions. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder in the navigation tree.

The Library page appears.

3. Click the Search tab.

The Search page appears. 

4. In the Search Type list, select Device Status. 

5. Complete the Device Status field, as follows:

• To search for a specific device status code, enter the complete code. Wildcards 
or partial codes are not accepted. 
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• To list all device status codes, click the List All check box. 

6. Click the Search button in the upper right corner. 

The page lists the specified device status codes and their descriptions. 
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▼ List a Result Code

Task Tool

This task can be performed at either of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to list result codes and their descriptions. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder in the navigation tree.

The Library page appears.
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3. Click the Search tab.

The Search page appears. 

4. In the Search Type list, select Result Code. 

5. Complete the Result Code field, as follows:

• To search for a code, enter the complete code. Wildcards or partial codes are 
not accepted. 

• To list all codes, click the List All check box. 
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Library Utility Tasks 

Task Page

Download Code to the Library Controller  340

Activate Code on the Library Controller  345

Reboot the Library  340

Transfer the Library MIB File  353

Generate and Transfer the Library Log Snapshot File  357

Perform a Non-Disruptive Library Self-Test  361

Perform a Disruptive Library Self-Test  364
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▼ Download Code to the Library Controller

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to download and unpack library firmware upgrades on the 
library controller. 

After completing this procedure, you can choose a convenient time to activate the 
code on the library. See “Activate Code on the Library Controller” on page 345 for 
detailed instructions. 

Note – This procedure is not used for downloading drive 
firmware updates.

Note – You can perform this procedure from the standalone SL 
Console or Web-launched SL Console only. It is not available at 
the local operator panel. 

Task Steps

1. Locate the firmware upgrade package (.jar file) on the Oracle download site. 
See “Firmware Download Site” on page 319. 

2. Download the code to a folder on your local PC or workstation. 

3. Log into the SL Console. 

Note – If you are upgrading an SL8500 complex, you can connect 
to any library in the complex. The upgrade downloads 
simultaneously to all libraries in the complex from the single SL 
Console session. 

4. Select Tools > Diagnostics, and click the Library folder. 
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5. Click the Load Code tab. 

The Load Code page appears. 

The SL8500 library firmware package is a .jar (Java Archive) file.
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6. The contents of the file display. Review the contents and file name to verify 
that you have specified the correct firmware package. 

When the code is fully transferred to the library controller, the code unpack 
process begins.
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The page indicates the progress of the unpack. 
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The page indicates when the unpack process is complete. 

Next to the Failed label, you should see 0. If there are any failures indicated, 
contact your Oracle support representative for assistance. 

7. After the package is successfully unpacked, you can activate the code 
immediately or wait until a later time. See “Activate Code on the Library 
Controller” on page 345 for detailed instructions.
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▼ Activate Code on the Library Controller 

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to activate a version of library firmware currently residing in the 
library controller flash memory. Up to two versions of firmware can be resident in 
memory at one time, but only one can be active. The active version is identified as 
“running.”

Prior to performing this procedure you must download and unpack the code you 
want to activate. See “Download Code to the Library Controller” on page 340 for 
detailed instructions. 

This procedure involves a reboot of the library. Schedule the process for a time that is 
convenient for users. 

You can restore the earlier firmware version if required. 

Note – You can perform this procedure from either the standalone 
SL Console or Web-launched SL Console only. It is not available at 
the local operator panel. 

Task Steps

1. Select Tools > Diagnostics, and click the Library folder. 
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2. Click the Activate Code tab. 

The Activate Code page appears. 

3. In the Target list, select the code package you want to activate.

The list may display a library firmware package and an SL Console package. For 
this procedure, select the firmware package (SL8500 Code). 
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The Available Versions section of the page displays the versions currently 
residing in flash memory. The version identified as “running” is the currently 
active code. You cannot select this version again to activate.

4. Select the code version you want to activate. 
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5. Click the Activate button in the upper right corner.

The Activation Confirmation message appears, asking whether you want to 
continue with the process. 

6. Click OK to begin the activation.

If you click Cancel, the process terminates and returns to Step 4. 

The code activation process begins, and the Activate Console page displays the 
status of the process. 

Caution – POTENTIAL INTERNAL FILE CORRUPTION. Do not 
reboot any devices in the library or execute any operations on the 
library while code is being activated.

7. Note the Overall Progress bar. This shows the progress of devices that have 
code loaded.
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If all devices receive the code, the progress bar will show 100%. If one or more 
devices does not receive code, the progress bar will show a percentage completion 
less than 100%.

8. Note the devices named in the Progress section. The system shows what 
percentage of the code is loaded onto each device. 

As of SL Console 5.8 and FRS_8.0., the system shows the progress by device. A 
solid green circle with a white check box in front of the device name indicates 
100% of the code for that device has been sucessfully loaded onto it.

9. When the activation process finishes, a dialog appears, prompting you to reboot 
the library. 
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10. Click OK to reboot the library.

If you click Cancel, the process terminates, and you must reboot the library at a 
later time. See “Download Code to the Library Controller” on page 340 for 
detailed instructions. 

The reboot process begins, and a message appears indicating that your SL Console 
session is terminating.

11. Click OK to terminate the SL Console session.

The system logs you off the library.

12. When the library initialization has completed, you can log in again to the 
library through the SL Console login screen. 

The SL Console gets all library configuration data from the library controller. 
Therefore, be careful when logging in to the SL Console before the library has 
fully initialized. You may see warnings that configuration data is not yet available. 
In such a case, you must exit and log in again at a later time. Additionally, if a 
library audit is performed as part of initialization, until the audit is complete, any 
configuration data displayed may not be completely up to date and accurate. 
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▼ Reboot the Library

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to reboot the library. This process involves reloading the firmware 
from flash memory and restarting the library controller.

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click Reboot in the upper right corner.

The Reboot confirmation message appears. 

4. Click OK to continue. 

If the library is online, the Offline confirmation message appears.

5. Click OK to take the library offline. 

The Reboot confirmation message appears. 
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6. Click OK to continue. 

The SL Console termination message appears.

7. Click OK to terminate this SL Console session. 

You are logged off the SL Console. The library controller reboots the library. This 
could take several minutes. 

Note – You cannot log back in to the SL Console until the library 
has fully initialized. 
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▼ Transfer the Library MIB File

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to transfer (save) the public SNMP management information base 
(MIB) file to a specified location on your local PC or workstation. The file is saved as 
a text file. E-mail the file to your Oracle support representative to help diagnose 
problems with the library. 

Task Steps

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

The Library page appears.
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3. Click the TransferFile tab. 

The Library TransferFile page appears. 

Select SNMP MIB.

4. Click Transfer File. 

The Save dialog box appears. 

5. Browse to the directory where you want to save the file, and enter the file name 
in the File Name field. Be sure to give it a .txt suffix. 

6. Click Save. 
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The data is saved to the specified file, and the Transferred Successful message 
appears. 

The following is a partial sample of the MIB file output.



-- ********************************************************************** 
--          STREAMLINE-TAPE-LIBRARY-MIB (1.3.6.1.4.1.1211.1.15) 
-- 
-- Copyright (c) 2005, 2010, Oracle and/or its affiliates. All rights 
reserved. 
-- 
-- ********************************************************************** 
 
STREAMLINE-TAPE-LIBRARY-MIB DEFINITIONS ::= BEGIN 
IMPORTS      
    enterprises, Counter32, Integer32 FROM SNMPv2-SMI 
    --OBJECT-TYPE FROM RFC-1212 
    OBJECT-GROUP, NOTIFICATION-GROUP, MODULE-COMPLIANCE FROM SNMPv2-CONF 
    TEXTUAL-CONVENTION FROM SNMPv2-TC 
    OBJECT-TYPE, MODULE-IDENTITY, NOTIFICATION-TYPE FROM SNMPv2-SMI; 
 
streamlineTapeLibrary MODULE-IDENTITY 
    LAST-UPDATED "201010280000Z" -- Oct 28, 2010 
    ORGANIZATION "Oracle" 
    CONTACT-INFO "Please contact Oracle/Sun Support:  
                    http://www.sun.com/contact/support.jsp" 
    DESCRIPTION  "The MIB module for StreamLine Tape Library. 
                  Copyright (c) 2005-2010, 
                  Oracle. All Rights Reserved." 
... 
-- ******************************************************************* 
-- 
-- Generic traps: 1-10 
-- 
-- ******************************************************************* 
 
slTrapError  NOTIFICATION-TYPE 
    OBJECTS 
    { 
        slTrapLibrarySerialNumber, 
        slTrapDeviceId, 
        slTrapDeviceTime, 
        slTrapDeviceAddress, 
        slTrapDeviceUserName,  
        slTrapDeviceInterfaceName,  
        slTrapDeviceActivity,  
        slTrapDeviceRequestId, 
        slTrapDeviceSeverity, 
        slTrapDeviceResultCode, 
        slTrapDeviceFreeFormText 
    } 
    STATUS current 
    DESCRIPTION "An error trap - a device condition which is critical to 
machine operation was encountered" 
::= { slSnmpNotifications 1 }
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▼ Generate and Transfer the Library Log Snapshot File

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to generate and transfer (save) the library log snapshot file to a 
specified location on your local PC or workstation. The system saves the file in an 
encrypted format, which means you cannot view or edit it. After generating and 
transfering the snapshot file, e-mail it to your Oracle support representative who will 
use it to diagnose problems with the library.

Note – The feature to generate a log snapshot is available starting 
with  SL8500 firmware version FRS_7.70 and SL Console version 
5.70.

Note – Use this procedure only under the direction of your Oracle  
support representative. You must transfer the library log snapshot 
file  within 15 minutes after it is generated. After 15 minutes, the 
generated snapshot is no longer available, and you must generate 
another file.

Task Steps

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

The Library screen appears.

3. Click the TransferFile tab.
 

The TransferFile page appears.

4. Select the Log Snapshot radio button if it is not already selected.

5. At the Selected Devices list, select either All Devices or Selected Device.
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6. If you chose Selected Device, select the device for which you want to generate a 
log snapshot.

 

7. Click the button labeled Generate Log Snapshot on Library.

The Create Log confirmation message appears.

8. Click Yes to continue creating the log snapshot.

9. Click OK when the confirmation message displays.
 

10. Save the snapshot within 15 minutes after generating the snapshot. 
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If you do not save within this 15-minute window, you cannot save the currently 
generated log snapshot file. In this case, you must generate another log snapshot 
file.

Click Transfer Log Snapshot To Your Computer.
 

The Save dialog box appears.

11. If you have already created the directory where you want to save the file, 
browse to that directory and click Save.

12. If the directory you want does not exist, enter the name of the directory in the 
File Name field and click Save. 

The Directory Create message appears. Click OK to accept the directory creation 
and dismiss the message. Then click Save at the Save dialog box.

The data is saved in the specified directory, and the Transferred Successful 
message appears.
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13. Click OK to dismiss the message. The library automatically names the file. You 
cannot view the file because it is encrypted.
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▼ Perform a Non-Disruptive Library Self-Test 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to perform a non-disruptive library self-test, which can be used to 
help diagnose operational problems with the library. 

For the test to run completely, make sure the proper diagnostic cartridges for library 
drives are in the library. To verify this, see “List Library Cartridges” on page 261.

Task Steps

1. Select Tools > Diagnostics, and click the Library folder.

2. Click the SelfTest tab.

The Self Test page appears. 

3. In the Mode list, select Non-Disruptive. 

4. Click Run to start the test. 
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The test begins. The Diagnostic Console section of the page displays the status of the 
various diagnostic tests as they are performed.
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When the test completes, the results of the test display. 



Library Utility Tasks

364  SL8500 User’s Guide

▼ Perform a Disruptive Library Self-Test 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to perform a disruptive library self-test, which can be used to help 
diagnose operational problems with the library. 

In order for the test to run completely, make sure the proper diagnostic cartridges for 
library drives are present in the library. To verify this, see “List Library 
Cartridges” on page 261.

Prior to performing this procedure, the library must be taken offline to all hosts.See 
“Place the Library Offline” on page 413 for detailed instructions.

Task Steps

1. Select Tools > Diagnostics, and click the Library folder.

2. Click the Self Test tab.

The Self Test page appears. 

3. In the Mode list, select Disruptive. 



Library Utility Tasks

SL Console Diagnostics and Utilities   365

4. Click Run. 

A list appears to confirm that you have already taken the library offline to all hosts.
 

5. Click OK to begin the test. 

The test begins, and the Diagnostic Console section of the page displays the status of 
the various diagnostic tests as they occur.



Library Utility Tasks

366  SL8500 User’s Guide

When the test completes, the results of the test display in the Diagnostic Console 
section. 

6. Bring the library online to resume normal operations.
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 Diagnostic Cartridge Management Tasks

Task Page

Import Diagnostic Cartridges  368

Export Diagnostic Cartridges  371

Display Diagnostic Cartridge Information  375
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▼ Import Diagnostic Cartridges

Task Tool

This task can be performed at either of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to enter diagnostic cartridges into the library through a specified 
CAP. The library controller reserves the CAP for the entire operation. The systen can 
perform only one diagnostic or cleaning cartridge import or export operation at a 
time.

The diagnostic cartridges are distributed as evenly as possible in reserved system 
cells. Optionally, you can assign priority to one rail, and the cleaning cartridges are 
entered into reserved system cells on this rail, on a space-available basis. 

Before beginning this procedure, verify that the following conditions are met:

• The CAP is empty, available for use (not reserved by a host), and closed and 
locked. 

• The library has enough empty reserved system cells to store the diagnostic 
cartridges you want to import. At least one system cell on each side of the library 
must be left open for robot recovery or library initialization. 

Task Steps

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, highlight the CAP you want to use, and then click the 
Import/Export tab.

The Import/Export page appears. 
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3. In the Operation section , select Import Cleaning/Diagnostic cartridges. 

4. In the “Select favored rail for import” list, select the rail to accept the imported 
diagnostic first. 

The system will enter diagnostic cartridges into reserved system cells on this rail 
on a space-available basis. After all the system cells on this rail are filled, the 
system distributes cartridges among system cells on other rails. 

5. Click Start. 

A confirmation message appears. 
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6. Click OK to continue. 

The import operation begins, and the Import/Export page displays the ongoing 
status. The library controller unlocks the CAP door if the CAP is not in auto enter 
mode. 

7. Press the appropriate CAP Unlocked button (CAP A or CAP B) on the operator 
key pad. 

The CAP door opens, and the CAP button light turns ON. 

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

8. Load the diagnostic cartridges into the CAP.

For detailed instructions, see “Enter Cartridges Through a CAP” on page 254.

9. Press the appropriate CAP Unlocked button (CAP A or CAP B) on the operator 
key pad. 

The CAP closes and locks automatically, and the CAP button light turns OFF.

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

10. The diagnostic cartridges are moved to available system cells. 

The system ignores any data cartridges or diagnostic cartridges with invalid labels 
and leaves them in the CAP. 

11. After all diagnostic cartridges have been moved from the CAP, if cartridges 
remain, the CAP door is unlocked, and the Import/Export page displays a 
message that the cartridges need to be removed.
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▼ Export Diagnostic Cartridges

Task Tool

This task can be performed at either of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to export diagnostic cartridges from the library through a 
specified CAP. The library controller reserves the CAP for the entire operation. The 
diagnostic cartridges are retrieved from reserved system cells and placed in the CAP 
for removal. Only one diagnostic or cleaning cartridge import or export operation can 
be performed at a time. 

Before beginning this procedure, verify the CAP is empty, available for use (not 
reserved by a host), closed, and locked. 



Diagnostic Cartridge Management Tasks

372  SL8500 User’s Guide

Task Steps

1. Select Tools > Diagnostics.

2. Expand the CAP Folder, highlight the CAP you want to use, and then click the 
Import/Export tab.

The Import/Export page appears. 

3. Select the type of export operation you want to perform. You have the following 
options: 

• Export specific diagnostic cartridges: Enables you to specify the diagnostic 
cartridges you want to eject. The page displays a list of all diagnostic cartridges 
in the library, and you can select one or more for export. 

• Export all diagnostic cartridges: Exports all diagnostic cartridges from the 
library. 
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4. Proceed as follows:

• If you have chosen to export specific cartridges, in the “Select Cartridge(s) to 
export” table, click on the cartridges you want to export. 

• If you have chosen to export all cartridges, in the “Select rail to export cartridges 
from” list, select a rail. 
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5. Click Start.

A confirmation message appears. 

6. Click OK to continue. 

The export operation begins, and the Import/Export page displays the ongoing 
status. The library controller unlocks the CAP door if the CAP is not in auto enter 
mode.

7. Press the appropriate CAP Unlocked button (CAP A or CAP B) on the operator 
key pad. 

The CAP door opens, and the CAP button light turns ON. 

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

8. Remove all the cartridges from the CAP.

9. Push the CAP button to close the CAP.

The CAP closes and locks automatically, and the CAP button light turns OFF.

Caution – Possible Equipment Damage. DO NOT force the CAP to 
open or close.

10. The robot audits the CAP to verify that it is empty.

The CAP returns to its default state. 
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▼ Display Diagnostic Cartridge Information 

Task Tool

This task can be performed at either of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

You can use any of the following SL Console reports and searches to display 
information about diagnostic cartridges: 

• “Cartridge Table Report” on page 375

• “Cartridge Summary” on page 375

• “Cartridge Search by vol-id” on page 376

Cartridge Table Report

• Select Tools> >Reports >Status Summary > Cartridge Table 

See “Display Library Cartridge Information in Tabular Format” on page 257 for 
the full procedure.

The Cartridge Table report displays detailed information about all library 
cartridges in a sortable, tabular format. By default, this report is sorted in 
cartridge volume ID (vol-id or volser) order. You can scroll directly to the 
cartridges that begin with “DG” to see detail about all diagnostic cartridges. 

The following is a sample:

Cartridge Summary

• Select Tools> >Reports >Status Summary > Cartridge Summary 

See “List Library Cartridges” on page 261 for the full procedure.
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The Cartridge Summary displays detailed information about all library cartridges 
in a text format. By default, this report is sorted in location order. You can search 
for cartridges that begin with “DG” to see detail about diagnostic cartridges. 

Following is a sample:

Cartridge Search by vol-id 

• Select Tools> >Diagnostics > Library > Search. 

See “Locate a Cartridge by vol-id” on page 264 for the full procedure.

Search by vol-id displays detailed information about all library cartridges. By 
default the results are sorted in location order. You can change the sort order to 
VOLID and then scroll directly to the cartridges that begin with “DG” to see detail 
about all diagnostic cartridges. 
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The following is a sample:
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Audit Tasks

Task Page

Audit the Entire Library  379

Audit a Range of Cells  380

Perform a Verified Audit  381
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▼ Audit the Entire Library

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

During this audit, the robot visits all the storage cells, catalogs the vol-ids and 
locations, and updates the library controller database. 

Note – Although this audit is a background process and does not 
interrupt library operations, it does require sharing of robot 
resources. Therefore, it is not recommended that you run this 
audit during peak activity periods. 

Note – You cannot stop this audit after it has initiated. The audit 
takes approximately 1/2 second per cartridge slot. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the Audit tab.

The Audit page appears. 

4. In the Entire Library section,  click the Yes radio button. Then click the Audit 
button in the upper right corner.

A confirmation message appears. 

5. Click OK to perform the audit as a background process or Cancel to cancel the 
audit.

Note – After you click OK, you cannot stop the audit. It runs until 
completion. 

You can view the Cartridge Summary report after a few hours for the latest 
cartridge locations and vol-ids. See “Display a Library Report” on page 51 for 
details.
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▼ Audit a Range of Cells

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

During this audit, the robot visits only a specific range of storage cells (including the 
cap and drives) and updates the library controller database.

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the Audit tab.

The Audit page appears. 

4. In the Entire Library section, click the No radio button. In the Physical Audit 
section, select Yes. In the Verified Audit section, select No.

5. In the Start Address and End Address sections, select the device types you want 
to audit and the starting and ending library internal address locations. See 
“Library Internal Address” on page 608 for a detailed explanation of this 
address format. 

6. Click the Audit button in the upper right corner.

A confirmation message appears. 

7. Click OK to perform the audit as a background process, or Cancel to cancel the 
audit.

Note – After you click OK, you cannot stop the audit. It runs until 
completion. 

The Audit Console section displays the progress of the audit. 

Note – You can also view the Cartridge Summary report for the 
latest cartridge locations and vol-ids. See “Display a Library 
Report” on page 51 for details.
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▼ Perform a Verified Audit

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

A verified audit validates the status of a specific cartridge location or a range of 
locations (including CAPs and drives) in the library controller database. If a cartridge 
address has a verified status of “false,” the system performs a physical audit of that 
location and updates the library controller database. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the Audit tab.

The Audit page appears. 

4. In the Entire Library section, select No. In the Physical Audit section, select No. 
In the Verified Audit section, select Yes. 
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5. In the Start Address and End Address sections, select the device types you want 
to audit and the starting and ending library internal address locations.See 
“Library Internal Address” on page 608 for a detailed explanation of this address 
format. 

6. Click the Audit button in the upper right area of the page.

The Audit Console section displays the progress of the audit. 
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CAP Utility Tasks

Task

Task Tool  384

Take a CAP Offline  385

Bring a CAP Online  387
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▼ Perform a Self Test on a CAP 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to perform a self test on a  CAP.

Note – At present, the CAP self-tests perform the same routines as 
the library self-test. Specific CAP self-tests will be available at a 
later date.

Task Steps

1. Select Tools > Diagnostics.

2. Expand the CAP folder, and click the CAP you want to test. 

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive. 

5. Click the Run button in the upper right corner.

Status messages are displayed as the self-test is run. When the test finishes, the 
system displays a message indicating the diagnostic test is complete. 
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▼ Take a CAP Offline 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to take a CAP offline through the SL Console. 

Note – Use this procedure only if you are not using ACSLS or ELS 
tape management software, or if their servers are unable to 
communicate with the library. ACSLS and ELS are not notified 
when the state of the library or its components are changed 
through the SL Console, which could possibly lead to disruption 
in library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

3. Click the Status tab.

The page displays the current status of the CAP. 
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4. In the Transition Request list, select Take Offline. Click Apply. 

All outstanding jobs for the CAP complete. Then the CAP status changes, as 
follows:

• Health State: Warn.

• Device State: Not accessible (HLI host connections).

• Access State: Offline.
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▼ Bring a CAP Online 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to bring a rotational or AEM CAP online through the SL Console. 

Note – Library devices that are offline in an error state cannot go 
online. The error condition must be cleared first. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and click the CAP you want to modify. 

3. Click the Status tab.

The page displays the current status of the CAP. 

4. In the Transition Request list, select Bring online. Click Apply. 

The CAP status updates, as follows:

• Health State: ok

• Device State: Ready
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• Access State: Online
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Drive Utility Tasks

Task Page

Perform a Drive Self Test  390

Take a Drive Offline  391

Take a Drive Offline  391
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▼ Perform a Drive Self Test 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to perform a self test on a drive.

Task Steps

1. Select Tools > Diagnostics.

2. Expand the Drive Folder, and click the drive you want to test. 

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive. 

5. Click Run in the upper right area of the screen.

Status messages display as the self-test runs. After the test finishes, the system 
displays a message indicating the diagnostic test is complete.
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▼ Take a Drive Offline

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to take a drive offline through the SL Console. 

Note – Use this procedure only if you are not using ACSLS or ELS 
tape management software, or if their servers are unable to 
communicate with the library. ACSLS and ELS are not notified 
when the state of the library or its components are changed 
through the SL Console, which could possibly lead to disruption 
in library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to modify. 

3. Click the Status tab.

The page displays the current status of the drive. 

4. In the Transition Request field, click Take Offline. Click Apply. 

The system completes all outstanding jobs for the drive. Then the drive status 
changes as follows:

• Health State: Warn
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• Device State: Not accessible (HLI host connections) 

• Access State: Offline
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▼ Bring a Drive Online 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to bring a drive online through the SL Console. 

Note – Library devices that are offline in an error state cannot go 
online. The error condition must be cleared first. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder, and click the drive you want to modify. 

3. Click the Status tab.

The page displays the current status of the drive. 

4. In the Transition Request list, select Bring online. Click Apply. 

The drive status updates as follows:

• Health State: ok

• Device State: Ready

• Access State: Online
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▼ Perform a Robot Self-Test 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Perform a self test on a robot.

Note – To perform a robot self-test, diagnostic cartridges must be 
available in the library. 

Task Steps

1. Select Tools > Diagnostics.

2. Expand the Robot Folder, and click the robot you want to test. 

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive. 

5. Click the Run button in the uppper right corner.

Status messages display as the self-test runs. After the test finishes, the system 
displays a message indicating the diagnostic test is complete. 
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▼ Take a Robot Offline 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to take a robot offline through the SL Console. 

Note – Use this procedure only if you are not using ACSLS or ELS 
tape management software, or if their servers are unable to 
communicate with the library. ACSLS and ELS are not notified 
when the state of the library or its components are changed 
through the SL Console, which could possibly lead to disruption 
in library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot you want to modify. 

3. Click the Status tab.

The page displays the current status of the robot. 

4. In the Transition Request field, select Take Offline. Click Apply. 

All outstanding jobs for the robot are complete. Then the robot status is changed 
as follows:

• Health State: Warn.
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• Device State: Not accessible (HLI host connections) 

• Access State: Offline.

5. The robot moves to the end of the rail, and the library cannot use it. If the 
library is using the redundant robot feature, the second robot will take all 
requests. 
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▼ Bring a Robot Online 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to bring a robot online through the SL Console. 

Note – Library devices that are offline in an error state cannot go 
online. The error condition must be cleared first. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot you want to modify. 

3. Click the Status tab.

The page displays the current status of the robot. 

4. In the Transition Request list, select Bring Online. Click Apply. 

The robot status updates as follows:

• Health State: ok

• Device State: Ready

• Access State: Online
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▼ Define a Diagnostic Move

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

You can set up and run multiple diagnostic move routines simultaneously, as long as 
the target and pool address ranges do not overlap. 

Note – This procedure requires sharing of robot resources. 
Therefore, it is not recommended that you run it during peak 
activity periods. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder in the navigation tree.

The Library page appears.

3. Click the DiagMove tab, and then the Manage tab. 

The Manage page appears.

4. In the Defined Sequence section, click Add.

The TARGET dialog box appears. 

5. Complete the Sequence screen as follows. See “Target Address 
Range” on page 324 for details. 

• In the Selection Mode section, select the type of cells you want to diagnose. 

• In the Minimum Address and Maximum Address sections, select the library 
internal address of the starting and ending locations of the cells you want to 
diagnose. 

6. Click Next. 

The SOURCE dialog box appears. 

7. Complete the SOURCE screen as follows. See “Pool Address 
Range” on page 324 for details. 

• In the Selection Mode sections, select the appropriate cartridge pool address 
type. 

• In the Minimum Address and Maximum Address sections, select the library 
internal addresses of the starting and ending locations of the cartridge pool 
you want to use.
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8. Click Next.

The Sequence dialog box appears. 

9. Complete the Sequence screen as follows. See “Move Access 
Order” on page 325 for details. 

• Name of the diagnostic move.

• Move Count: Specify a number between 1 and 5000.

• Access order: Sequential or Random.

• Move Type: Robot and Cartridge or Robot Only.

• Disable pre-move cartridge compatibility check.

10. Click Finish to complete the setup.

The Diagnostic Move Manage screen appears. The diagnostic sequence you have 
just defined is listed in the Defined Sequences section. 
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▼ Manage Diagnostic Move Definitions 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to manage diagnostic move sequence definitions. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the DiagMove tab, and then the Manage tab. 

The Manage page appears.

4. From the Defined Sequences section, select any of the following options listed 
in the following TABLE 14-6.

TABLE 14-6  Options for Defining Diagnostic Moves

To
Select 
Option Notes

Define a diagnostic move Add

Start a diagnostic move Open Multiple diagnostic moves may be open at a 
time, so long as the target and pool address 
ranges setup for the moves do not overlap.

Modify options for a 
diagnostic move

Modify This diagnostic move routine must not be 
open or if open must be in a “Stopped” 
state.

Remove a diagnostic 
move

Remove This diagnostic move routine must not be 
open.

Copy an existing 
diagnostic move

Copy Copy a diagnostic move definition, make 
changes if necessary, and assign a different 
name.

5. To manage the diagnostic moves currently open, see “Monitor and Control 
Open Diagnostic Moves” on page 405.
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▼ Save a Diagnostic Move to a File 

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to save a defined diagnostic move to a local file on your 
workstation or PC. The file is saved as a JavaBean component represented as an 
XML 1.0 document (.xml). 

You can use the saved file to:

• Restore a move that has been deleted from the library. 

• Copy it to a different library for use there. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the DiagMove tab, and then the Manage tab. 

The Manage page appears.

4. Click the diagnostic move you want to save, and then click the Save button in 
the upper right area of the screen. 

The Save dialog box appears.
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5. Browse to the directory where you want to save the file. In the File Name field, 
enter the file name. 

6. Click Save. 

The data is saved to the specified file. The following is a sample excerpt:
<?xml version="1.0" encoding="UTF-8"?>  
<java version="1.5.0_11" class="java.beans.XMLDecoder">  
 <object class=
"com.stortek.ats.elib.opel.model.SequenceBeanList">  
  <string>FRS_4.10</string>  
  <string>SL500</string>  
  <void method="add">  
   <object class=
"com.stortek.ats.elib.opel.model.SequenceBeanList$SequenceBean">  
    <void property="accessOrder">  
     <string>Sequential</string>  
    </void>  
    <void property="moveCartridge">  
     <boolean>true</boolean>  
    </void>  
    <void property="moveCount">  
     <int>10</int>  
    </void>  
    <void property="name">  
     <string>DriveDiagMove1</string>  
    </void>  
    . . . 
    <void property="targetType">  
     <string>Drive</string>  
    </void>  
   </object>  
  </void>  
 </object>  
</java> 
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▼ Start a Diagnostic Move

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to begin a diagnostic move.

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the DiagMove tab, and then the Manage tab. 

The Manage page appears.

4. From the Defined Sequences section, click a diagnostic move, and then click 
Open. 

The Monitor window activates. 

You can repeat this step to open multiple moves, as long as the target and pool 
address ranges for the moves do not overlap.

A monitor window displays for each move you open.

5. From each monitor window, select File > Start Sequence to start the move. 
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▼ Monitor and Control Open Diagnostic Moves

Task Tool

This task can be performed at any of the following:

• Local operator panel

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to control and monitor the status of one or more open diagnostic 
moves.

Task Steps

1. See “Start a Diagnostic Move” on page 404 for instructions on starting one or 
more diagnostic moves. 
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2. Click the Monitor tab. 

The Monitor page appears, with one monitor window for each open move.

Each monitor window has the following status indicators listed in the following 
TABLE 14-7.

TABLE 14-7  Diagnostic Status Indicators of Monitor Windows

Status Indicators Description Valid Values

Spooling Status Indicates if the move output is 
being spooled to a file 

True, False

State Current execution state of the 
move

Running, pausing, paused, 
stopping, stopped

Health Current health state of the 
move

OK, warning, error

Completed moves Number of moves completed 
in the requested move count 



Robot Utility Tasks

SL Console Diagnostics and Utilities   407

3. Use the File menu in each Monitor window to perform any of the functions 
listed in the following TABLE 14-8.

TABLE 14-8  Functions Available in Diagnostic Monitor Windows

Select Option To Notes

File > Start Sequence Start 

File > Pause Sequence Pause Stops all diagnostic moves, but 
maintains the current location in the 
access order.

File > Stop Sequence Stop   Stops a running or paused move.

File > Start Sequence Resume Resumes a paused move starting with 
the last known location in the target 
address range.

File > Clear Output Window Clear the messages 
displayed in the monitor 
window

Erases the previous message lines and 
continues to fill the screen with new 
messages.

Spool File > Start Spooling Spool Directs the move output to a file.

Spool File > Stop Spooling Stop spooling the move 
output to a file

Stops directing the move output to the 
spool file.
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15

Manual Operations 

When in manual mode of operation, the library or library complex is unavailable for 
host access. This may be because the library has experienced an unrecoverable error 
or a library component requires service or installation. When the library is in this 
mode, cartridge mounts and dismounts require human intervention. 

In the case of a failure of a non-redundant component (for example, a single HBC/
HBCR controller card for the entire library), the library is said to be “unavailable” to 
the system. In this case, the entire library must be placed offline until the repair is 
accomplished.

A library’s inability to automatically perform cartridge mounts/dismounts does not, 
however, stop cartridge tape activity, such as mount and dismount requests by the 
host continue to be generated. 

To perform the cartridge activities, someone may be required to physically enter the 
library and manually perform the mount/dismount activities previously done by the 
robot. The location of the cartridge to be mounted is supplied by the software and the 
slot location must be determined by the coordinates shown in Chapter A, “Cartridge 
Slot Locations”.

Automatic Mode Determination
The following conditions indicate that the library is not functioning in automatic 
mode:

• One or both the library access doors are open. 

• The robot does not automatically mount and dismount cartridges. 

• The navigation tree in the SL Console indicates that there is a problem with the 
library. 
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Library Safety

General Safety Precautions

When you enter a library to manually mount and dismount cartridges, you must 
strictly observe safety precautions and pay attention to the physical space 
restrictions.

Warning – To prevent accidental closure of the access door while 
someone is in the library, it is recommended that when you 
unlock the access door, you lock it open and retain the key on 
your person. 

To prevent personal injury, follow these precautions: 

• Make sure the library is offline (see “Place the Library Offline” on page 413).

• Do not attempt to override any of the electrical or mechanical safety devices in the 
library.

• Do not enter the library without informing someone in the immediate area. 

• Leave both the front access doors open whenever you work inside the library. 
There are switches on each door frame that disconnect DC power and signal lines 
to the library’s robotic motors when either access door is opened.

• Know the physical restrictions. See “Physical Restrictions” on page 411. 

FIGURE 15-1  Emergency Robotic Stop Switch

1

1. Emergency robotics stop switch

Note – In the unlikely event that someone becomes locked inside 
the library and the system begins to start up, lights flash for 30 
seconds before the robot starts to move. This provides enough 
time for someone outside the library to push the emergency 
robotic stop switch on the CAP door (FIGURE 15-1). This actions 
stops any further robotic movement.
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Physical Restrictions

The library design is optimized for high density, so there is not much free room for 
movement. Be careful not to:

• Snag your clothing on the arrays that house the cartridges (only 0.4 m [18 in.] of 
aisle clearance).

• Bump your head or body against the arrays. 

You might also have to move a robot to gain access to a cartridge, in which case, you 
must avoid damaging the robot’s mechanical or electronic components. See “Move a 
Robot” on page 421).

If you are manually loading or unloading a cartridge, your hands must remain clear 
of the drive’s mechanical and electronic load components.
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▼ Place the Library Offline 

Use this procedure to place the library offline through the SL Console. 

Note – Use this procedure only if you are not using ACSLS or ELS 
tape management software, or if their servers are unable to 
communicate with the library. ACSLS and ELS are not notified 
when the state of the library or its components are changed 
through the SL Console, which could possibly lead to disruption 
in library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

You may need to use this procedure at the following times:

• Before powering down the library

• Before opening a library access door

• When the library is inoperative and requires maintenance 

1. Take all library drives offline. 

See “Take a Drive Offline” on page 391 for details. 

2. Select Tools > System Detail.

3. Click the Library folder in the navigation tree.

4. Click the Status tab, and then the General tab.

The current status of the library is displayed. 

5. In the Transition Request field, click Take offline. Click Apply.

All outstanding library jobs are completed, and then the library status is changed, 
as follows:

• Health State: Warn

• Device State: Not accessible (HLI host connections); Not ready (SCSI host 
connections) 

• Access State: Offline 

Wait for the message confirming the library is offline. If the library does not come 
offline, enter the command to display the status of the library.

6. The library remains offline until you explicitly place it online. 
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▼Bring the Drives Online 

The following pages describe how to bring the drives online:

T9840/T9940 Drive Display 

To verify that the T9840/T9940 drives are ready and online, press the MENU switch –
 the display should now read Online.

If the drive displays Offline, press the SELECT switch once to bring it online. 

• If the drive message indicates Online, the transition to online completed.

• If the Onl Pend message appears, the online state is pending due to completion 
of diagnostic tests.

• If other messages appear, refer to either the T9840/T9840 Tape Drive User’s Reference 
Manual, PN 95739, or T9940 Tape Drive Operator’s Guide, PN 95989.

LTO Ultrium Drives

LTO Ultrium drives are automatically brought online when you bring the library 
online.
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▼Bring the Library Online

Use this procedure to bring the library online through the SL Console. 

Note – Use this procedure only if you are not using ACSLS or ELS 
tape management software, or if their servers are unable to 
communicate with the library. ACSLS and ELS are not notified 
when the state of the library or its components are changed 
through the SL Console, which could possibly lead to disruption 
in library operations. For instructions on changing the state of the 
library and its components through ACSLS or ELS, see the 
appropriate tape management software documentation. 

Note – LTO Ultrium drives are automatically brought online 
when you bring the library online.

1. Select Tools > System Detail.

2. Click the Library folder in the navigation tree.

3. Click the Status tab, and then the General tab.

The page displays the current status of the library.

4. In the Transition Request field, click Bring online. 

5. Click Apply. 

The library status is updated, as follows:

• Health State: ok

• Device State: Ready

• Access State: Online

6. If applicable, bring the library online to ACSLS and ELS hosts. See the ACSLS 
and ELS documentation for detailed procedures. 
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▼ Power Off the Library

Caution – If you power-off the library without performing the 
following procedure, you risk possible equipment or cartridge 
damage or loss of data.

1. Make sure that all jobs have completed processing.

2. Quiesce the library to make sure the library and tape drives are not in use.

3. Take the library and the drives offline.

Note – Refer to your library management software publication for 
commands and syntax for this step and Step 2.

4. Make sure that the drives are empty by verifying the drive state using the SL 
Console. 

Note – Refer to the online help documentation accessible through 
the SL Console application. 

5. Open the rear doors of the library.

6. Locate the power distribution unit (PDU) and move the system power-off/on 
switch to the OFF position (0). 

Note – If the library has a 2N power configuration, you must 
switch off the system power on both the PDUs. 

An AC PDU is shown in FIGURE 15-2.

FIGURE 15-2  AC PDU

1. Retainer

2. LEDs

3. System Power Off/On Switch

Figure 20 illustrates the locations of all power supplies (except for the Customer 
Interface Module’s front frame area). 



FIGURE 15-3  AC PDU and DC Power Supply Locations

From left to right:

1. Optional switches or hubs (1-4)

2. Drive locations/numbering (1-64)

3. DC power supplies (1-24)

4. Rail Power enable breakers (numbered 1 and 2, 
above DC supplies)

5. Far right: AC PDUs (bottom) and the logic gate 
sections they supply (top)
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▼ Power On the Library

1. Close and lock the front access door if the doors are open.

Note – If you DO NOT want to power-on the robots, CAPs, and 
the elevators, leave the doors open.

2. Move the system power-off/on switch to ON (1) position. 

Note – If the library has a 2N power configuration, you must 
switch on the system power on both the PDUs. 

See FIGURE 15-2 on page 416 and FIGURE 15-3 on page 417 for detailed illustrations.
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▼ Enter the Library 

Use this procedure to open the main doors of the library. 

Warning – POTENTIAL INJURY. You could be injured if you do 
not follow the correct procedure to enter the library. Be sure to 
review all safety precautions before performing this procedure. 
See “General Safety Precautions” on page 410. 

Warning – POTENTIAL INJURY. If all four HandBots are parked 
near each other, before you enter the library, move the HandBots 
out of your way one at a time starting at the lowest rail. You could 
trip over the HandBots on the lower rails or injure your head with 
the HandBots on the upper rails. See “Move a Robot” on page 421 
for details. 

1. Place the library offline. See “Place the Library Offline” on page 413 for details. 

2. Insert the key and unlock the access door. 

3. Pull the paddle handle to activate the opening mechanism and open the access 
door. Opening the access door activates a switch, which automatically causes a 
software interrupt and stops the robot. 

4. Turn the key in the lock, to lock the door open, and then remove the key from 
the lock and keep it with you. This will prevent the door from being closed 
while you are in the library.

FIGURE 15-4  Library Front View (Access Doors Open) 

L203_563

1 2 3

1. Left access door

2. Robots

3. Right access door
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▼ Exit the Library 

Use this procedure to close and lock the main doors of the library. 

Note – Before you leave the library, make sure that no tools or 
foreign objects are left, and no cartridges are outside the cartridge 
slots. 

1. Return the cartridges that your removed to do a manual mount/dismount to 
their slots. 

2. Step outside the library. 

Warning – Before you close the library access door, look inside 
the library and ask in a loud voice if anyone is inside the library. 

3. Close the front access door. 

Caution – Equipment/Media Damage. Do not slam the door. You 
could damage the door or cause cartridges to fall onto the floor. The 
robot cannot recover cartridges that fall onto the floor. 

4. Insert the key and lock the access door. Keep the key in a safe place.
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▼Move a Robot 

You might have to move a robot to:

• Locate the cartridge from the slots.

• Access the drive panel and identify the drive to perform a manual mount/
dismount. 

Warning – To prevent physical injury and damage to components, 
follow the instructions carefully.

When moving a robot, follow these precautions:

• Do not enter the library or move any of the HandBot mechanisms if you have any 
reason to suspect they are enabled.

• Do not touch any shiny polished surfaces. Body oils can destroy the lubrication on 
these surfaces. 

• Do not touch any lubricated parts. 

• Hold the HandBot carriage handle to push or pull as shown in 
FIGURE 15-5 on page 421. 

• The HandBot should move freely. Do not force the HandBot if movement is 
restricted. Before you close the library access doors, look inside the library and ask 
in a loud voice if anyone is inside the library. 

• Leave the library only when you are certain that the HandBots can move freely in 
all directions.

Caution – Damage to Robot. Make sure no extra material (manuals, 
eyeglasses, tools) are left inside. These objects would cause the 
robot to stop and could damage it. 

FIGURE 15-5  Moving the HandBot

1. HandBot handle (hold the handle to move the HandBot)
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▼ Locate a Cartridge

The library management software provides the location and the vol-id of the 
cartridge and also the drive bay address available for the manual mount. Before you 
enter the library, write down the vol-id, cartridge location, and the drive bay location. 

1. Select Tools > Utilities and then select the Search tab. 

2. From the list, select Cartridge Location as the Search Type. 

3. Enter the vol-id of the cartridge you are trying to locate.

4. Select the Requester (see notes below) as the default from the list.

5. Select the Cartridge Type (data, clean, unreadable label, duplicate label).

6. Select Search button from the top right corner.

See FIGURE A-1 on page 433 through FIGURE A-8 on page 440 for pictorial maps of 
the cartridge locations. 

Note –  You can look up a cartridge location either in the internal 
library firmware format or the HLI-PRC format based on the 
library management software (see “Internal Address” on page 432 
and “HLI-PRC Address” on page 444).

Note – If the library is in a complex, make sure you enter the 
correct library number (for the internal firmware address search) 
or the LSM number (for the HLI-PRC address search). For more 
information see “PTP Addressing Scheme” on page 306.
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▼ Locate a Drive

If you need to perform a manual mount to a drive, the SL Console provides mapping 
of the hardware, firmware, and software mapping for all the drives attached to a 
library.

1. Select Tools > System Detail.

2. From the navigation tree, select the Drive folder.

Note – The navigation tree is the left panel that provides a list of 
devices attached to the library (drives, CAP, robots, elevator).

The status screen displays the SL8500 address, the corresponding drive bay, and the 
HLI-PRC addresses. 
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▼Mount a Cartridge in a Drive 

FIGURE 15-6  Drive Panel

1

L203 566

1. Drive bay

1. When you manually insert a cartridge, the vol-id label must be facing you, with 
the numeric characters above the bar code.

Note – Do not force the cartridge into the tape drive. If you feel 
some resistance as you insert the cartridge, make sure you are 
installing the cartridge into the appropriate tape drive. 

Note – T9840 and T9940 tape drives look very similar, but you 
cannot put 9840 cartridges in a T9940 tape drive, nor put 9940 
cartridges in T9840 tape drive. 

Note – Never attempt to insert an LTO Ultrium cartridge in a 
T9x40 tape drive. However, you can insert an LTO Ultrium 
cartridges in either an IBM or HP Ultrium tape drive. 

FIGURE 15-7 shows manual insertion of a T9840 cartridge.



FIGURE 15-7  Manually Inserting a Cartridge

L203_472

Manual Operation Tasks

Manual Operations  425

 

For more information on manually mounting a cartridge into a drive, refer to the 
relevant document for the tape drive.
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▼Dismount a Cartridge from a Drive 

All T9x40 and LTO Ultrium tape drives have a unload button on the operator panel.

1. Make sure that the tape drive is not in use by the system.

2. Press the UNLOAD switch. One of the following conditions occurs:

• After the tape rewinds, the cartridge is ejected from the drive. Remove the 
cartridge from the drive.

• The cartridge is not ejected after the tape rewinds. Refer to your drive 
documentation for more information.

For more information on manually dismounting a cartridge from a drive, refer to the 
relevant tape drive publication.
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▼ Perform a Disruptive PTP Installation – for ACSLS or ELS 

1. Vary the LSMs offline. 

2. Dynamically update the ELS or ACSLS configurations. 

3. Because the LSMs are being renumbered, run an audit of the existing libraries 
and the new one added to update the cartridge locations. Vary the LSMs in the 
complex online.

Refer to your library management software publication for more information.

Failure to reconfigure and audit of the libraries in the new complex will result in:

• Mount failures because cartridges cannot be found in their new, correct locations.

• Cartridge collisions because enters of new cartridges could collide with existing 
cartridges currently occupying the slots.

Perform audits in a specific sequence to avoid loss or mismatch of vol-ids. first audit 
the library with the highest numbered LSMs. The audit process must proceed 
sequentially from left-to-right, as shown in TABLE 15-1. Audit the newly added 
library (lowest numbered LSM) last.

TABLE 15-1  Adding a Library to the Right

Exiting Libraries New Library

First Audit 
Library A

Second Audit 
Library B

Last Audit 
Library C

Renumbers LSMs 4-7 to 8-11 Renumbers LSMs 0-3 to 4-7 Assigns LSM numbers 0-3

FIGURE 15-8 shows how the libraries are configured when adding a PTP to an 
exiting library complex. 



FIGURE 15-8  Adding a PTP to an Existing Library Complex

An existing Library complex has two libraries (A and B), connected with a PTP. 
A = The home library contains LSMs 0 – 3. 
B = The away library contains LSMs 4 – 7

New library C added to the 
of libraries A and B with 

a Pass-thru Port
left 

C

LSM 8
9
10
11

Front

Pass-thru Port connecting 
existing libraries A and B

L203 875

New library C added to the 
of libraries A and B with

a Pass-thru Port
right 

B

LSM 8
9
10
11

Front

Existing libraries A and B
connected with a 
Pass-thru Port

L203 876

In this example, adding another library (C) to the 
left of the library complex increases the LSM 
numbering sequentially. This is the preferred method.

In this example, adding another library (C) to the 
right of the library complex requires a 
reconfiguration of LSM numbering.
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Maintenance Mode of Operation
Maintenance mode is active when a service representative enters the access door to 
perform maintenance or to replace a component. 

An example of this would be the replacement of a defective HandBot when a 
redundant or operational HandBot is available. Each HandBot has two motors, if one 
fails, the other motor is powerful enough to move the defective HandBot into the 
forward service area. If both the motors fail for a HandBot, then the redundant 
HandBot moves the defective HandBot into the forward service area thus continuing 
HandBot operations. The service representative then requests that the library be 
made available for maintenance entry on the side where the HandBot is positioned. 
The maintenance key (available only to a service representative) is inserted, a service 
safety door moves to the side selected (partitioning the service area from operational 
library activity) and the HandBot is replaced.

Note – The service safety door is not parallel to the front of the 
library; its right side is angled toward the rear of the library (see 
FIGURE 1-2 on page 4).

See “Safety Door Monitoring Tasks” on page 394 for details about monitoring the 
service safety door. 

Service Safety Door Operation

During the replacement, the library continues to function. Because there are cartridge 
arrays in the forward portion of the Customer Interface Module, these slots are 
reserved for diagnostic and cleaning cartridges only. A mount request for a cartridge 
in the slot closer to the side (left or right) where the service safety door is engaged 
may be inhibited until the maintenance activity is completed. The reserved slots on 
the other side of the service area may still be accessed if the service safety door is not 
engaged on that side as well.

After the maintenance activity is completed, the access door is closed and locked and 
the service safety door moves to the center, clearing the area for HandBot operations. 
The HandBots then resume their full service.

Left Maintenance Area

During normal operation, take the left elevator offline to the library management 
software using the SL Console before the service representative activates the service 
safety door. After the maintenance activity is complete, bring the left elevator online 
through SL Console.

Right Maintenance Area

During normal operation:

• Take the CAPs offline to the to the library management software.

• Take the right elevator offline (using SL Console) before the service representative 
activates the service safety door to the right side of the library.

After the maintenance activity is complete, bring the CAPs and the right elevator 
online to the system through SL Console.
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The following sample screen is an example of the SL Console displaying the service 
safety door feature. 
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Library Addressing

This appendix explains the addressing schemes used in the SL8500 library. There are 
two types of addressing schemes:

• Internal Firmware (Library, Rail, Column, Side, Row) used by the firmware and 
internal communications to represent all devices and locations within the library.

• HLI-PRC (LSM, Panel, Row, and Column) used by HLI clients, such as ACSLS 
and ELS, to represent library locations and components.

Additionally, there is an external hardware numbering scheme for drive bay 
locations, which differs from both the internal firmware addressing and HLI-PRC 
addressing.  For more information, see “Tape Drive Numbering” on page 438.

Note – In the documentation that follows, “left” and “right” are in 
reference to viewing the library from the CAP-side (front) unless 
otherwise specified.

Structural Elements
The addressing of components in the library is based on a few basic structural 
elements: library walls, slot arrays, LSMs/rails, and columns/panels.

Library Walls, Arrays, and Slots

The library has two types of walls with slot arrays that hold cartridges: 

• Inner walls: consist of 14-slot arrays 

• Outer walls: consist of 13-slot arrays with space for the robotic rails 

In addition to the 13 and 14-slot arrays, there are: 

• 8-slot arrays in the pass-thru port panels 

• 8-slot arrays underneath the stop brackets for the service safety door 

• 4-slot arrays on the elevators and pass-thru ports 

• 3-slot arrays (end stops) at the ends of each HandBot rail 



Structural Elements

432  SL8500 User’s Guide

Library Storage Module (LSM) 

The SL8500 library has four robotic rails that provide power and communications to 
the HandBots. Each of these rails is considered an LSM. Because of this, there are four 
LSMs within each SL8500 library. 

Library Complex Numbering

In a library complex, for the HLI addressing scheme the LSM number increases 
sequentially with each additional library.  The LSM numbering is as follows and 
continues with this pattern for up to ten libraries:

• Library 1 (Home library):  LSM 0-3

• Library 2 : LSM 4-7 

• Library 3: LSM 8-11

When adding an additional library to a complex it is recommended to add libraries 
from right to left (viewed from the CAP-side of the library).  This prevents 
renumbering of LSMs with in the complex for non-disruptive growth. However, the 
library can grow in the other direction (from left to right) but this requires:

• Reconfiguring the system

• Renumbering the LSMs

• Re-IPLing the library

FIGURE A-1 shows two examples of three libraries connected with PTPs. 

• Example A shows the LSM numbering as you add libraries to the left. Adding 
another library (C) to the left of the library complex increases the LSM 
numbering sequentially. This is the preferred method. 
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• Example B shows the LSM numbering as you add libraries to the right. 
Adding another library (C) to the right of the library complex requires a 
reconfiguration of LSM numbering.

FIGURE A-1  Pass-thru Port Planning Example

Panels and Columns 

Panels (used in HLI-PRC addressing) and columns (used in firmware addressing) 
refer to the horizontal location of a component in the library.  Special panels/columns 
include: 

• Corners because there is no inner wall

• Pass-thru ports because the top six slots are inaccessible because of the PTPs

• Pass-thru port panels because the top cartridge slot (under the port) is reserved 
as a redundant robotics drop-off slot (two for each rail, one on each side)
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Addressing Schemes

Internal Firmware

Internal firmware addressing designates physical location in an SL8500 library using 
five parameters: Library, Rail, Column, Side, Row (L,R,C,S,W).

1. Library: Is the number of the library within a library complex. 

2. Rail: Rails are numbered top down from 1 – 4 with rail 1 being on top. 

3. Column: Indicates the horizontal location of a tape cartridge referenced from the 
center of the drive bay at the rear of the library forward, where: 

• +1 is just right of the center of the drive bays.

• -1 is just to the left of the drive bays.

• Column numbering is consecutive. The first columns that contain tape 
cartridges are +3 and -3 and continue forward to the front access doors. 

4. Side: Indicates the inner and outer walls, or left and right HandBots in a 
redundant configuration. 

• Walls:         Outer wall = 1          Inner wall = 2

• Handbots:  Left Handbot = 1      Right HandBot = 2

• CAPs:        Right Cap = 1           Left Cap = 2

5. Row: Is the vertical location of a tape cartridge and are consecutively numbered 
from the top (1) down (13 outer wall and 14 inner wall). 

HLI-PRC

Cartridge locations for HLI-PRC addressing are: LSM, Panel, Row, and Column. 

1. LSM: Each rail is considered a separate library storage module (LSM). 

• Numbered 0 – 3 (top down) 

• The libraries in a complex are identified by LSM. For example, library one 
contains LSMs 0-3, library two: LSMs 4-7, library three: LSMs 8-11, and so on.

2. Panel: Indicates the horizontal position in the library. Panels span across the width 
of the library to include both sides (left and right) and both walls (inner and 
outer) for each LSM.

• Panel 0 = CAP 
Panel 1 = Drives 
Panel 2–n = Storage slots

3. Row: Is the vertical location of a tape cartridge and are consecutively numbered 
from the top down. 

• Outer walls = 0-12             Inner walls = 13-26

4. Column: Indicates the left or right side of the library (as viewed from the front).

• Left = 0                            Right = 1
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Comparison of the Addressing Schemes

• Internal firmware addressing:

• Begins at 1 and uses negative numbers.

• Uses library, rail, column, side, and row.

• Column refers to the horizontal location in the library.

• Row numbering: Outer walls = 1-13, Inner walls = 1-14.

• HLI-PRC: addressing:

• Begins at 0 with no negative numbers.

• Uses LSM, panel, row, and column

• Column refers to the left or right side of the library.

• Row numbering: Outer walls = 0-12, Inner walls = 13-26.
 

TABLE A-1  Comparison of Library Addressing  

HLI–PRC Firmware Description 

Library Number of the specific library in a library complex.  

LSM 

LSM 0 
LSM 1 
LSM 2 
LSM 3

Rail 

Rail 1 
Rail 2 
Rail 3 
Rail 4

The SL8500 library has four rails that the HandBots travel, which are 
numbered from top to bottom 1–4 (one’s-based). 

HLI addressing considers each rail to be a separate LSM, numbered 
from top to bottom 0–3 (zero-based). The LSM number increases 
sequentially with each additional library.  For example, library two 
in a complex has LSM 4-7.

Panel

0 = CAP

1 = Drives

2–n = Storage 
slots 

Column 

1 to n   
(right side of 
library

-1 to -n  
(left-side of 
library)

Columns in internal firmware addressing indicate the horizontal location 
in the library. As viewed from the CAP-side of the library column and 
panel numbers start at the center of the drive panel (1) and sweep 
forward with increasing numbers. 

An HLI panel spans across the width of the library to include both sides 
(left and right) and both walls (inner and outer) for each LSM. 

Note – The SL8500 firmware does not use panels as an address. 

Side Wall location  
Outer wall = 1   
Inner wall = 2 

HandBot number  
Left = 1   
Right = 2

Row Row Rows indicate the vertical location of a tape cartridge and are numbered 
from the top—down. 

Column Rows for the HLI address are:
• Storage panels start at 2 with 

Column 0 = left  
and Column 1 = right 

• Rows 0–12 outer walls 
• Rows 13–26 inner walls 
• Each column in a normal 

storage panel has 27 rows. 
• For a total capacity of 54 

cartridges per panel. 

Rows for the SL8500 address are: 

• Storage slots start at  
Column -3 = left  
Column +3 = right 

• Rows 1–13 outer wall 

• Rows 1–14 inner wall 
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The following figures show the address numbering schemes of the SL8500 internal 
firmware (FIGURE A-2) and HLI-PRC (FIGURE A-3). 

FIGURE A-2  Internal Firmware Addressing



FIGURE A-3  HLI Addressing
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The following indicates the panel numbering ranges with various configurations:

• Base library: RIM 2-7, CIM 8-10

• One expansion module: RIM 2-7, SEM 8-15, CIM 16-23

• Two expansion modules: RIM 2-7, SEM 8-15, SEM 16-23, CIM 24-26

• Three expansion modules: RIM 2-7, SEM 8-15, SEM 16-23, SEM 24-31, CIM 32-34

• Four expansion modules: RIM 2-7, SEM 8-15, SEM 16-23, SEM 24-31, SEM 32-39, 
CIM 40-42

• Five expansion modules: RIM 2-7, SEM 8-15, SEM 16-23, SEM 24-31, SEM 32-39, 
SEM 40-47, CIM 48-50



Structural Elements

438  SL8500 User’s Guide

Tape Drive Numbering 
All tape drives in the SL8500 library are physically located in the Drive and 
Electronics Module. There are three types of addressing used to define the location of 
drives:

• Hardware numbering

• Internal Firmware

• HLI-PRC 

Drive Hardware Addressing

The physical hardware numbering of tape drives is assigned by the HBC controller 
card. The card automatically assigns a number (1-64), depending on the location of 
the drive in the drive array.

Note – The perspective in FIGURE A-4 below is from the drive-
side (rear) of the library.

FIGURE A-4  Tape Drive Physical Hardware Numbering (viewed from rear of library)
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Drive Internal Firmware Addressing

The firmware addressing (library, rail, column, side, row) distinguishes a drive in a 
library based on rail, column, and row.  The side value is always equal to 1.

Note – The perspective in FIGURE A-5 below is from the CAP-
side (front) of the library. For this example, the library number is 
1.

FIGURE A-5  Tape Drive Internal Firmware Addressing (viewed from front of library)
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Drive HLI-PRC Addressing

The HLI-PRC (LSM, panel, row, column) distinguishes a drive in a library based on 
LSM and row.  The panel value is always equal to 1 and the column value is always 
equal to 0.

Note – The perspective in FIGURE A-6 below is from the CAP-
side (front) of the library.

FIGURE A-6  Tape Drive HLI-PRC Addressing (viewed from front of library)
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Drive Address Comparison

FIGURE A-7 shows the three numbering schemes side by side. The perspective in the 
figure below is from the CAP-side (front) of the library.

FIGURE A-7  Drive Numbering Comparison (viewed from front of library)
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Addressing of Components
The addressing of components, such as CAPs, elevators, PTP, and HandBots, have 
unique addressing rules. Host software may not address these components directly. 
For simplicity, only internal firmware addressing of components is covered.

Important component internal firmware addressing concepts include:

• A row value equal to 0 indicates the address is referring to the device, not a slot in 
the device.

• The side value may not directly correlate to inner and outer walls.

• The column value of elevators and CAPs depends on the number of storage 
expansion modules in the library.

Note – “Left” and “right” are in reference to viewing the library 
from the CAP-side (front) unless otherwise specified.

Cartridge Access Ports 

Rail and Row

When addressing the device, the rail value is 2 and the row value is 0.

When addressing a specific slot, the rail refers to the rail adjacent to the CAP 
magazine (can be values 2-4) and the row is the slot in the CAP magazine (can be 
values 1-13).

Column

The column value depends on the size of the library. The column value is the number 
of customer accessible columns plus 3.  In a library with no SEMs, there are 11 
customer accessible columns, therefore the CAP column value is 14.

Side

Right CAP  = side value of 1

Left CAP = side value of 2

Example: CAP Firmware Addressing

For this example, the library value is 1 and the library contains one SEM (so there are 
19 customer accessible columns). The CAP is on the left, referring to slot 10 in the 
CAP magazine adjacent to the third rail from the top.

The firmware address is (1, 3, 22, 2, 10)

Elevators

Rail

The rail value is always 0, since the elevators do not correspond to a specific rail.
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Column

The column value depends on the size of the library. The column value is the number 
of customer accessible columns plus 2.  In a library with no SEMs, there are 19 
customer accessible columns, therefore the elevator column value is 13.

Side

The side value is always 2, because the elevators are on the inner wall.

Row

When addressing the device, the row is 0.

When addressing a specific slot, the row is the slot in the elevator (1-4).

Example: Elevator Firmware Addressing

For this example, the library value is 1 and the library contains one SEM. The address 
is referring to the fourth slot in the elevator.

The firmware address is (1, 0, 21, 2, 4)

HandBots

Rail

The rail value (1-4) refers to the rail the HandBot is on.

Column

The column value is always 0.

Side

If there is only one HandBot per rail, the side value is always 1.

For redundant HandBot configurations:

• Left Handbot = 1

• Right HandBot = 2

Row

When addressing the device: the row is 0.

When addressing the specific slot: the row is the slot value (1).

Example: HandBot Firmware Addressing

For this example, the library value is 1. The address is referring to the right HandBot 
on the top rail.

The firmware address is (1, 1, 0, 2, 0)
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Pass-thru Mechanisms

Rail

The rail value (1-4) refers to the rail adjacent to the PTP.

Column

Right PTP  = column value of +6

Left PTP  = column value of -6

Side

The side value is always 1, because the PTPs are on the outer wall.

Row

When addressing the device, the row is 0.

When addressing a specific slot, the row is the slot in the PTP (1 or 2).

Example: PTP Firmware Addressing

For this example, the library value is 1. The PTP is on the left side of the library on 
the second rail from the top, and the address is referring to the device.

The firmware address is (1, 2, -6, 1, 0)
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Cartridge Handling 

This chapter provides information on labeling and handling tape cartridges used in 
Oracle StorageTek libraries, and covers the following topics:

• “Software Support for Cartridges” on page 445

• “Barcode Label Standard” on page 445

• “Cartridge Types” on page 446

• “Supported Labels” on page 446

• “Handling Cartridges” on page 449

• “Apply a Label to a Cartridge” on page 451

Library cartridges must meet specifications defined in American National Standard 
Magnetic Tape and Cartridge for Information Interchange. 

For more information on cartridges and labels, see:

• The drive vendor’s publication and Web site for cartridge requirements and 
specifications

• The System Assurance Guide for the SL8500 library.

Software Support for Cartridges
For the SL8500 library, the appropriate software microcode level needed is required 
for various tape drives. For this microcode information, see the System Assurance 
Guide for the SL8500 library.

Barcode Label Standard
The SL8500 library uses labels based on the Code 39 barcode standard. This standard 
uses discrete barcodes, which means that a fixed pattern of bars represents a single 
character. Code 39 barcode standard supports the following characters:

• 36 unique alpha-numeric characters: Letters A through Z and the numbers 0 
through 9

• Special characters, which are not part of the customer label: - . $ / + % * 
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When multiple characters are arranged together as a label or volume serial number 
(VOLSER), a single, narrow white bar is placed between the individual character 
barcodes (called the inter-character gap).

Cartridge Types
The SL8500 library uses the following types of cartridges:

• Data cartridges store data written to them.

• Cleaning cartridges clean the tape path and read/write heads of the tape drives.

• Diagnostic cartridges are for service representatives to run read and write tests on 
the tape drive. In general, these tapes are standard data cartridges with a special 
diagnostic label.

Cartridge labels include a media domain and media ID. Together, these identify to  
the library the cartridge’s type of media and use. IDs allow you to mix tape drive 
types and media types in a single library or library complex. The media ID label 
corresponds to the tape drive or transport capable of using the cartridge. The media 
domain indicates whether the cartridge is for data, cleaning, or diagnostic use.

Cleaning and Diagnostic Cartridges 

Cleaning and diagnostic cartridges require different labels to distinguish them from 
data cartridges. As the name implies, cleaning cartridges clean the tape path and 
read/write heads of the tape drives.

Diagnostic cartridges are for service representatives to run read and write tests on the 
tape drive. In general, these tapes are standard data cartridges with a special 
diagnostic label. 

The first alphanumeric characters in the label sequence determine the type of 
cartridge being used. The vol-id (volume serial number) contains:

• CLN for cleaning cartridges

• DG for diagnostic cartridges

Each cleaning and diagnostic kit includes one labeled cleaning cartridge and one 
labeled diagnostic cartridge. Each of these are labeled with a volume ID of 0. Extra 
cleaning and diagnostic labels are sent with each library. 

You cannot use cleaning and diagnostic cartridges as scratch cartridges, and software 
utilities cannot initialize them.

Caution – Procedure error: When you enter a cleaning cartridge, the 
software considers it to be new, and sets the usage counter to zero. 
DO NOT RE-ENTER A CLEANING CARTRIDGE THAT THE 
LIBRARY EJECTS THROUGH THE CAP. 

Supported Labels
Barcode labels must match the drive type. The following labels are appropriate for 
the corresponding drive.
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• T9840: 1/2-inch labels supplied by Trioptic (Engineered Data Products/Colorflex) 
or Tricode (American Eagle/Writeline). Version C and D labels require a six-plus-
one character label. The separate character is a separate media ID. See TABLE B-1 
for more details.

• T10000: Labels with eight characters. The last two characters are the required 
media ID domain and the media ID type characters. See TABLE B-1 for more 
details.

• LTO drives: Labels with eight characters. This label includes a six character 
customer defined volume serial number or the cartridge’s function, such as 
diagnostic or cleaning. The other two characters identify the media domain or 
tape technology, and the media ID or version of that particular technology. See 
TABLE B-2 for more details.

• DLT drives: Labels with seven characters. The seventh character is a small 
identifier below the sixth character for the media ID or version. See TABLE B-3 for 
more details.

For more information on labels, see the System Assurance Guide for the SL8500 library.

Labels for Oracle StorageTek Tape Cartridges

The media ID characters for Oracle StorageTek T9840 (models C and D) and T10000 
drive labels are listed in TABLE B-1. These tape drives also support encryption.

TABLE B-1  Labels for StorageTek T9840 and T10000 Tape Cartridges

Beginning Characters 
of Label Media ID Cartridge Type Drive Type

VOLID R Data T9840

VOLID (Green 
background) 

R VolSafe Data T9840C

VOLID (Purple 
background)

R VolSafe Data T9840D

VOLID T1 Data T10000 A/B

VOLID T2 Data T10000 C

VOLID TS Sport Data T10000 A/B

DG (blank space) VOLID R Diagnostic T9840

DG (blank space) VOLID T1 Diagnostic T10000 A/B

DG (blank space) VOLID T2 Diagnostic T10000 C

DG (blank space) VOLID TS Sport 
Diagnostic

T10000 A/B

CLN (blank space) VOLID CC Cleaning T10000 C

CLN (blank space) VOLID CL Cleaning T10000 A/B/C
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Labels for LTO Cartridges

LTO technology was initially developed by IBM, Hewlett-Packard, and Quantum. 
LTO is an open format technology, meaning users have muliple sources of product 
and media. 

LTO cartridge labels have eight characters. The last two characters are the media ID 
(L3, L4, L5, LT, LU, or LV). CLN or DG are the first characters on the cleaning or 
diagnostic labels. LTO4 and LTO5 tape drives also support encryption. 

TABLE B-2  Labels for LTO Cartridges

Media ID Cartridge Type Drive Type or Additional Information

L1 Data Generation 1

L2 Data Generation 2

L3 Data 400 GB, Generation 3

L4 Data 800 GB, Generation 4

L5 Data 1.5 TB, Generation 5

LT Data 400 GB, Gen 3 only. Write once read many times 
(WORM).

LU Data 800 GB, Gen 4 drive only (WORM).

LV Data 1500 GB, Gen 5 drive only (WORM).

CU Cleaning Beginning characters are CLN (blank space) + VOLID. 
Oracle recommends using the CLN + CU universal label 
instead of a vendor-unique label (CLN + C1 for Hewlett-
Packard or CLN + C2 for IBM).

DG Diagnostic Beginning characters are DG (blank space) + VOLID. 
You can apply a DG label to a blank data cartridge to 
use the cartridge for library diagnostic tests. 

Note – Check availability for LTO Gen 4 drives and media. 
Library firmware must be Version 1126 or later to support LTO 
Gen 4 drives and media.

CLN (blank space) VOLID CT Sport Cleaning T10000 A/B

CLN (blank space) VOLID U Cleaning T9840 (all except 
T9840D)

CLN (blank space) VOLID Y Cleaning T9840D

TABLE B-1  Labels for StorageTek T9840 and T10000 Tape Cartridges

Beginning Characters 
of Label Media ID Cartridge Type Drive Type
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Labels for DLT and SDLT Cartridges

Media IDs for DLT and SDLT cartridges do not indicate the type of cartridge (data, 
cleaning or diagnostic). Instead, cleaning cartridges begin with CL (space), and 
diagnostic cartridges begin with DG (space).

TABLE B-3  Labels for DLT and SDLT Cartridges

Media ID Cartridge Type Additional Information

B Data DLT1

C Data DLTtape III

D Data DLTtape IV

E Data DLTtape III-XT

S Data SDLT 220/320 cartridge

2 Data SDLT 600

4 or S4 Data DLT-S4

CLN + S Cleaning 1500 GB, Gen 5 drive only (WORM)

DG + 2 Diagnostic Beginning characters are CLN (blank space) + VOLID. 
Oracle recommends using the CLN + CU universal 
label instead of a vendor-unique label (CLN + C1 for 
Hewlett-Packard or CLN + C2 for IBM).

DG + 4 Diagnostic Beginning characters are DG (blank space) + VOLID. 
You can apply a DG label to a blank data cartridge to 
use the cartridge for library diagnostic tests. 

Handling Cartridges
When cartridges are improperly handled, loss of data or damage to a library 
component can occur. To handle a cartridge correctly:

• Keep cartridges clean. 

• Inspect a cartridge before each use and never put a damaged cartridge into a drive 
or library. 

• Never open a cartridge. 

• Do not handle tape that is outside the cartridge; the tape edge might be damaged. 

• Do not expose the tape or cartridge to direct sunlight or moisture. 

• Do not expose a recorded cartridge to magnetic fields; this might destroy data on 
the tape. 

Inspecting a Cartridge

A defective or dirty cartridge can damage a tape drive. Always inspect a cartridge 
before you insert it into a tape drive or a library. Look for:

• Cracked or broken cartridge
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• Damaged write-protect switch

• Liquid in the cartridge

• Labels not firmly or neatly attached or extending over the cartridge edge

• Any other obvious damage

Inserting a Cartridge in a Drive or Cell

A defective or dirty cartridge can damage a drive. Always inspect a cartridge before 
you insert it into a drive or into a tape library. Look for:

• Cracked or broken cartridge

• Broken tape access door

• Damaged file-protect selector or write-protect switch

• Liquid in the cartridge

• Labels not firmly attached or extending over the cartridge edge

• Any other obvious damage

Insert a cartridge in a storage cell, CAP cell, or drive with the bar code on the bottom, 
and the VOLID readable from right to left. The cartridge hub must always be down.

Cleaning the Cartridge Exterior 

Keep your tape cartridges in good condition. A defective or dirty cartridge can 
damage a tape drive see “Inspecting a Cartridge” on page 449.

Caution – Potential damage to cartridges. Do not use certain solvents 
to remove labels or to clean cartridges because they can damage the 
cartridges. Do not use acetone, trichloroethane, toluene, xylene, 
benzene, ketone, methylethyl ketone, methylene chloride, 
ethyldichloride, esters, ethyl acetate, or similar chemicals. 

To clean a cartridge exterior:

• Wipe all dust, dirt, and moisture from the cartridge with a lint-free cloth. 

• Use Oracle StorageTek Tape Cleaner Wipes to clean the cartridges. These wipes 
are saturated with isopropyl alcohol. Do not let any solution touch the tape or get 
inside the cartridge.

Storing Cartridges

• Do not take a cartridge out of its protective wrapping until you are ready to use it. 
Use the tear string, not a sharp instrument, to remove the wrapping. 

• Store cartridges in a clean environment that duplicates the conditions of the room 
in which they are used. 

• Before using a cartridge, make sure that it has been in its operating environment 
for at least 24 hours. See the user manual for the drive for details.
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▼Apply a Label to a Cartridge

Cartridge labels indicate the type of cartridge media and usage. If your cartridges 
were not ordered with pre-applied labels, you must apply them yourself. Correctly 
label all cartridges for library use. Use labels that do not leave a residue when they 
are removed.

Caution – Possible misread of volume number label. Make sure the 
edges of the labels do not curl. A curled label causes the cartridge to 
become jammed in the tape drive loader, and the robot misreads the 
label.

1. Make sure the cartridge has been at room temperature for at least 24 hours.

2. Clean the surface where the label will be placed. Use Oracle StorageTek Tape 
Cleaner Wipes to clean the cartridges.

Caution – Potential damage to cartridges. Do not use certain solvents 
to remove labels or to clean cartridges because they can damage the 
cartridges. Do not use acetone, trichloroethane, toluene, xylene, 
benzene, ketone, methylethyl ketone, methylene chloride, 
ethyldichloride, esters, ethyl acetate, or similar chemicals. 

3. Locate the type of label you need. Make sure the label contains a vol-id.

4. Peel the backing from the cartridge label.

5. For an LTO cartridge, hold the cartridge so that the write-protect switch is 
toward you. For a 9840 or 9940 label, hold the cartridge so that the two recessed 
areas are toward you.

6. Attach the label to the cartridge. Press it into place.

Note – On LTO Ultrium cartridge labels, the alphanumeric 
characters can be either vertical or horizontal.

Note – The label must be within the indented (recessed) area of 
the cartridge so that the edges of the label are parallel to the edges 
of the cartridge. The label should be close to the inside edge of the 
indented area, but must never overlap the edge of this area. 

7. If the cartridge has a customer label, place the label in the area and press it into 
place.

8. For 9840 and 9940 drives, repeat Step 2 through Step 7 for the media ID label. 
Make sure the left side of both labels are aligned with each other.
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Web-launched SL Console Server 

Oracle’s Web-launched SL Console server, which is a standard feature of the SL8500, 
enables the SL Console to be installed on a centralized Web server. Individual clients 
can use a supported Web browser to download and log in to the Web-launched SL 
Console server. 

You download the server from the Oracle Software Delivery Cloud. It is distributed 
as a Java WebARchive (.war) file. After you have downloaded the file, you can 
deploy it on the Web server of your choice. See your Web server documentation for 
specific deployment instructions and requirements. 

Security Considerations
The customer is responsible for implementing all appropriate security systems, 
including firewalls, user access, etc. 

Updating the Web-launched SL Console Server
You can update the Web-launched SL Console server while it is running. Updates are 
automatically propagated to the clients when they retrieve the Web-launched SL 
Console application from the server. 
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▼ Download the SL Console Media Pack 

Use this procedure to download and extract the current SL Console Media Pack from 
the Oracle Software Delivery Cloud. The Media Pack includes the Web-launched SL 
Console server, as well as the Web-launched SL Console client and the standalone SL 
Console. 

After you complete this procedure, you can deploy the Web-launched SL Console 
server on the Web server of your choice. See your Web server documentation for 
specific deployment instructions and requirements. 

1. Start a Web browser on your PC or workstation, and navigate to the Oracle 
Software Delivery Cloud at the following URL:

http://edelivery.oracle.com/ 

2. Click Continue. 
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3. On the Export Validation screen, enter your contact information, read the 
License Agreement and Export Restrictions, and click the check boxes to accept. 

4. Click Continue to open the Media Pack screen.
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5. In the Select a Product Pack list of the Media Pack Search screen, select Oracle 
StorageTek Products. 

6. In the Select a Product Pack list of the Media Pack Search screen, use the 
Platform list, and select Generic Platform.
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7. Click Go. 

All media packs meeting your selection criteria are displayed in the Results 
section of the screen. 

8. Click the Select radio button that corresponds to the media pack for the SL 
Console version that you want to download. Click Continue. When the 
download screen for the selected media pack appears, review the information to 
verify that you have selected the correct media pack. Click the Readme button 
to review the readme file, if desired. Use the View Digest button to verify the 
MD5 and/or SHA-1 digests of the download files.

      s

9. If this is not the correct software, use the Back and/or Search Again buttons.

10. If the software is correct, click the Download. 
      s
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11. When the download dialog appears, click Save File, and press the OK.

12. When the Enter name of file to save to dialog appears, browse to the local 
directory that will hold the download file, and press Save. 

The file is large and may take some time to download, depending on your 
connection speed.

13. Use the appropriate extraction utility (for example, gunzip, pkunzip) to extract 
the media pack to the location of your choice. 

The Web-launched SL Console server filename is opel.war, located in the 
Weblaunch directory. 
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Controlling Contaminants 

Environmental Contaminants
Control over contaminant levels in a computer room is extremely important because 
tape libraries, tape drives, and tape media are subject to damage from airborne 
particulates. Most particles smaller than ten microns are not visible to the naked eye 
under most conditions, but these particles can be the most damaging. As a result, the 
operating environment must adhere to the following requirements: 

• ISO 14644-1 Class 8 Environment.

• The total mass of airborne particulates must be less than or equal to 200 
micrograms per cubic meter.

• Severity level G1 per ANSI/ISA 71.04-1985.

Oracle currently requires the ISO 14644-1 standard approved in 1999, but will require 
any updated standards for ISO 14644-1 as they are approved by the ISO governing 
body. The ISO 14644-1 standard primarily focuses on the quantity and size of 
particulates as well as the proper measurement methodology, but does not address 
the overall mass of the particulates. As a result, the requirement for total mass 
limitations is also necessary as a computer room or data center could meet the ISO 
14644-1 specification, but still damage equipment because of the specific type of 
particulates in the room. In addition, the ANSI/ISA 71.04-1985 specification 
addresses gaseous contaminations as some airborne chemicals are more hazardous. 
All three requirements are consistent with the requirements set by other major tape 
storage vendors.

Required Air Quality Levels
Particles, gasses and other contaminants may impact the sustained operations of 
computer hardware. Effects can range from intermittent interference to actual 
component failures. The computer room must be designed to achieve a high level of 
cleanliness. Airborne dusts, gasses and vapors must be maintained within defined 
limits to help minimize their potential impact on the hardware. 

Airborne particulate levels must be maintained within the limits of ISO 14644-1 Class 
8 Environment. This standard defines air quality classes for clean zones based on 
airborne particulate concentrations. This standard has an order of magnitude less 
particles than standard air in an office environment. Particles ten microns or smaller 
are harmful to most data processing hardware because they tend to exist in large 
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numbers, and can easily circumvent many sensitive components’ internal air 
filtration systems. When computer hardware is exposed to these submicron particles 
in great numbers they endanger system reliability by posing a threat to moving parts, 
sensitive contacts and component corrosion.

Excessive concentrations of certain gasses can also accelerate corrosion and cause 
failure in electronic components. Gaseous contaminants are a particular concern in a 
computer room both because of the sensitivity of the hardware, and because a proper 
computer room environment is almost entirely recirculating. Any contaminant threat 
in the room is compounded by the cyclical nature of the airflow patterns. Levels of 
exposure that might not be concerning in a well ventilated site repeatedly attack the 
hardware in a room with recirculating air. The isolation that prevents exposure of the 
computer room environment to outside influences can also multiply any detrimental 
influences left unaddressed in the room. 

Gasses that are particularly dangerous to electronic components include chlorine 
compounds, ammonia and its derivatives, oxides of sulfur and petrol hydrocarbons. 
In the absence of appropriate hardware exposure limits, health exposure limits must 
be used. 

While the following sections will describe some best practices for maintaining an ISO 
14644-1 Class 8 Environment in detail, there are some basic precautions that must be 
adhered to:

• Do not allow food or drink into the area.

• Cardboard, wood, or packing materials must not be stored in the data center clean 
area.

• Identify a separate area for unpacking new equipment from crates and boxes.

• Do not allow construction or drilling in the data center without first isolating 
sensitive equipment and any air targeted specifically for the equipment. 
Construction generates a high level of particulates that exceed ISO 14644-1 Class 8 
criteria in a localized area. Dry wall and gypsum are especially damaging to 
storage equipment.

Contaminant Properties and Sources
Contaminants in the room can take many forms, and can come from numerous 
sources. Any mechanical process in the room can produce dangerous contaminants or 
agitate settled contaminants. A particle must meet two basic criteria to be considered 
a contaminant:

• It must have the physical properties that could potentially cause damage to the 
hardware.

• It must be able to migrate to areas where it can cause the physical damage.

The only differences between a potential contaminant and an actual contaminant are 
time and location. Particulate matter is most likely to migrate to areas where it can do 
damage if it is airborne. For this reason, airborne particulate concentration is a useful 
measurement in determining the quality of the computer room environment. 
Depending on local conditions, particles as big as 1,000 microns can become airborne, 
but their active life is very short, and they are arrested by most filtration devices. 
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Submicron particulates are much more dangerous to sensitive computer hardware, 
because they remain airborne for a much longer period of time, and they are more 
apt to bypass filters.

Operator Activity

Human movement within the computer space is probably the single greatest source 
of contamination in an otherwise clean computer room. Normal movement can 
dislodge tissue fragments, such as dander or hair, or fabric fibers from clothing. The 
opening and closing of drawers or hardware panels or any metal-on-metal activity 
can produce metal filings. Simply walking across the floor can agitate settled 
contamination making it airborne and potentially dangerous.

Hardware Movement

Hardware installation or reconfiguration involves a great deal of subfloor activity, 
and settled contaminants can very easily be disturbed, forcing them to become 
airborne in the supply air stream to the room's hardware. This is particularly 
dangerous if the subfloor deck is unsealed. Unsealed concrete sheds fine dust 
particles into the airstream, and is susceptible to efflorescence -- mineral salts brought 
to the surface of the deck through evaporation or hydrostatic pressure. 

Outside Air

Inadequately filtered air from outside the controlled environment can introduce 
innumerable contaminants. Post-filtration contamination in duct work can be 
dislodged by air flow, and introduced into the hardware environment. This is 
particularly important in a downward-flow air conditioning system in which the sub-
floor void is used as a supply air duct. If the structural deck is contaminated, or if the 
concrete slab is not sealed, fine particulate matter (such as concrete dust or 
efflorescence) can be carried directly to the room's hardware. 

Stored Items

Storage and handling of unused hardware or supplies can also be a source of 
contamination. Corrugated cardboard boxes or wooden skids shed fibers when 
moved or handled. Stored items are not only contamination sources; their handling in 
the computer room controlled areas can agitate settled contamination already in the 
room.

Outside Influences

A negatively pressurized environment can allow contaminants from adjoining office 
areas or the exterior of the building to infiltrate the computer room environment 
through gaps in the doors or penetrations in the walls. Ammonia and phosphates are 
often associated with agricultural processes, and numerous chemical agents can be 
produced in manufacturing areas. If such industries are present in the vicinity of the 
data center facility, chemical filtration may be necessary. Potential impact from 
automobile emissions, dusts from local quarries or masonry fabrication facilities or 
sea mists should also be assessed if relevant.
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Cleaning Activity

Inappropriate cleaning practices can also degrade the environment. Many chemicals 
used in normal or “office” cleaning applications can damage sensitive computer 
equipment. Potentially hazardous chemicals outlined in the “Cleaning Procedures 
and Equipment” section should be avoided. Out-gassing from these products or 
direct contact with hardware components can cause failure. Certain biocide 
treatments used in building air handlers are also inappropriate for use in computer 
rooms either because they contain chemicals, that can degrade components, or 
because they are not designed to be used in the airstream of a re-circulating air 
system. The use of push mops or inadequately filtered vacuums can also stimulate 
contamination.

It is essential that steps be taken to prevent air contaminants, such as metal particles, 
atmospheric dust, solvent vapors, corrosive gasses, soot, airborne fibers or salts from 
entering or being generated within the computer room environment. In the absence 
of hardware exposure limits, applicable human exposure limits from OSHA, NIOSH 
or the ACGIH should be used. 

Contaminant Effects
Destructive interactions between airborne particulate and electronic instrumentation 
can occur in numerous ways. The means of interference depends on the time and 
location of the critical incident, the physical properties of the contaminant and the 
environment in which the component is placed.

Physical Interference

Hard particles with a tensile strength at least 10% greater than that of the component 
material can remove material from the surface of the component by grinding action 
or embedding. Soft particles will not damage the surface of the component, but can 
collect in patches that can interfere with proper functioning. If these particles are 
tacky they can collect other particulate matter. Even very small particles can have an 
impact if they collect on a tacky surface, or agglomerate as the result of electrostatic 
charge build-up.

Corrosive Failure

Corrosive failure or contact intermittence due to the intrinsic composition of the 
particles or due to absorption of water vapor and gaseous contaminants by the 
particles can also cause failures. The chemical composition of the contaminant can be 
very important. Salts, for instance, can grow in size by absorbing water vapor from 
the air (nucleating). If a mineral salts deposit exists in a sensitive location, and the 
environment is sufficiently moist, it can grow to a size where it can physically 
interfere with a mechanism, or can cause damage by forming salt solutions.
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Shorts

Conductive pathways can arise through the accumulation of particles on circuit 
boards or other components. Many types of particulate are not inherently conductive, 
but can absorb significant quantities of water in high-moisture environments. 
Problems caused by electrically conductive particles can range from intermittent 
malfunctioning to actual damage to components and operational failures.

Thermal Failure

Premature clogging of filtered devices will cause a restriction in air flow that could 
induce internal overheating and head crashes. Heavy layers of accumulated dust on 
hardware components can also form an insulative layer that can lead to heat-related 
failures.

Room Conditions
All surfaces within the controlled zone of the data center should be maintained at a 
high level of cleanliness. All surfaces should be periodically cleaned by trained 
professionals on a regular basis, as outlined in the “Cleaning Procedures and 
Equipment” section. Particular attention should be paid to the areas beneath the 
hardware, and the access floor grid. Contaminants near the air intakes of the 
hardware can more easily be transferred to areas where they can do damage. 
Particulate accumulations on the access floor grid can be forced airborne when floor 
tiles are lifted to gain access to the sub-floor.

The subfloor void in a downward-flow air conditioning system acts as the supply air 
plenum. This area is pressurized by the air conditioners, and the conditioned air is 
then introduced into the hardware spaces through perforated floor panels. Thus, all 
air traveling from the air conditioners to the hardware must first pass through the 
subfloor void. Inappropriate conditions in the supply air plenum can have a dramatic 
effect on conditions in the hardware areas.

The subfloor void in a data center is often viewed solely as a convenient place to run 
cables and pipes. It is important to remember that this is also a duct, and that 
conditions below the false floor must be maintained at a high level of cleanliness. 
Contaminant sources can include degrading building materials, operator activity or 
infiltration from outside the controlled zone. Often particulate deposits are formed 
where cables or other subfloor items form air dams that allow particulate to settle 
and accumulate. When these items are moved, the particulate is re-introduced into 
the supply airstream, where it can be carried directly to hardware.

Damaged or inappropriately protected building materials are often sources of 
subfloor contamination. Unprotected concrete, masonry block, plaster or gypsum 
wall-board will deteriorate over time, shedding fine particulate into the air. Corrosion 
on post-filtration air conditioner surfaces or subfloor items can also be a concern. The 
subfloor void must be thoroughly and appropriately decontaminated on a regular 
basis to address these contaminants. Only vacuums equipped with High Efficiency 
Particulate Air (HEPA) filtration should be used in any decontamination procedure. 
Inadequately filtered vacuums will not arrest fine particles, passing them through the 
unit at high speeds, and forcing them airborne.
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Unsealed concrete, masonry or other similar materials are subject to continued 
degradation. The sealants and hardeners normally used during construction are often 
designed to protect the deck against heavy traffic, or to prepare the deck for the 
application of flooring materials, and are not meant for the interior surfaces of a 
supply air plenum. While regular decontaminations will help address loose 
particulate, the surfaces will still be subject to deterioration over time, or as subfloor 
activity causes wear. Ideally all of the subfloor surfaces will be appropriately sealed 
at the time of construction. If this is not the case, special precautions will be necessary 
to address the surfaces in an on-line room.

It is extremely important that only appropriate materials and methodology are used 
in the encapsulation process. Inappropriate sealants or procedures can actually 
degrade the conditions they are meant to improve, impacting hardware operations 
and reliability. The following precautions should be taken when encapsulating the 
supply air plenum in an on-line room:

• Manually apply the encapsulant. Spray applications are totally inappropriate in an 
on-line data center. The spraying process forces the sealant airborne in the supply 
airstream, and is more likely to encapsulate cables to the deck.

• Use a pigmented encapsulant. The pigmentation makes the encapsulant visible in 
application, ensuring thorough coverage, and helps in identifying areas that are 
damaged or exposed over time.

•  It must have a high flexibility and low porosity to effectively cover the irregular 
textures of the subject area, and to minimize moisture migration and water 
damage.

• The encapsulant must not out-gas any harmful contaminants. Many encapsulants 
commonly used in industry are highly ammoniated or contain other chemicals 
that can be harmful to hardware. It is very unlikely that this out-gassing could 
cause immediate, catastrophic failure, but these chemicals will often contribute to 
corrosion of contacts, heads or other components.

Effectively encapsulating a subfloor deck in an on-line computer room is a very 
sensitive and difficult task, but it can be conducted safely if appropriate procedures 
and materials are used. Avoid using the ceiling void as an open supply or return for 
the building air system. This area is typically very dirty and difficult to clean. Often 
the structural surfaces are coated with fibrous fire-proofing, and the ceiling tiles and 
insulation are also subject to shedding. Even before filtration, this is an unnecessary 
exposure that can adversely affect environmental conditions in the room. It is also 
important that the ceiling void does not become pressurized, as this will force dirty 
air into the computer room. Columns or cable chases with penetrations in both the 
subfloor and ceiling void can lead to ceiling void pressurization.

Exposure Points
All potential exposure points in the data center should be addressed to minimize 
potential influences from outside the controlled zone. Positive pressurization of the 
computer rooms will help limit contaminant infiltration, but it is also important to 
minimize any breaches in the room perimeter. To ensure the environment is 
maintained correctly, the following should be considered: 

• All doors should fit snugly in their frames. 

• Gaskets and sweeps can be used to address any gaps. 
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• Automatic doors should be avoided in areas where they can be accidentally 
triggered. An alternate means of control would be to remotely locate a door 
trigger so that personnel pushing carts can open the doors easily. In highly 
sensitive areas, or where the data center is exposed to undesirable conditions, it 
may be advisable to design and install personnel traps. Double sets of doors with 
a buffer between can help limit direct exposure to outside conditions.

• Seal all penetrations between the data center and adjacent areas. 

• Avoid sharing a computer room ceiling or subfloor plenum with loosely 
controlled adjacent areas.

Filtration
Filtration is an effective means of addressing airborne particulate in a controlled 
environment. It is important that all air handlers serving the data center are 
adequately filtered to ensure appropriate conditions are maintained within the room. 
In-room process cooling is the recommended method of controlling the room 
environment. The in-room process coolers re-circulate room air. Air from the 
hardware areas is passed through the units where it is filtered and cooled, and then 
introduced into the subfloor plenum. The plenum is pressurized, and the conditioned 
air is forced into the room, through perforated tiles, which then travels back to the air 
conditioner for reconditioning. The airflow patterns and design associated with a 
typical computer room air handler have a much higher rate of air change than typical 
comfort cooling air conditioners so air is filtered much more often than in an office 
environment. Proper filtration can capture a great deal of particulates. The filters 
installed in the in-room, re-circulating air conditioners should have a minimum 
efficiency of 40% (Atmospheric Dust-Spot Efficiency, ASHRAE Standard 52.1). Low-
grade pre-filters should be installed to help prolong the life of the more expensive 
primary filters.

Any air being introduced into the computer room controlled zone, for ventilation or 
positive pressurization, should first pass through high efficiency filtration. Ideally, air 
from sources outside the building should be filtered using High Efficiency Particulate 
Air (HEPA) filtration rated at 99.97% efficiency (DOP Efficiency MILSTD-282) or 
greater. The expensive high efficiency filters should be protected by multiple layers of 
pre-filters that are changed on a more frequent basis. Low-grade pre-filters, 20% 
ASHRAE atmospheric dust-spot efficiency, should be the primary line of defense. The 
next filter bank should consist of pleated or bag type filters with efficiencies between 
60% and 80% ASHRAE atmospheric dust-spot efficiency.

ASHRAE 52-76 
 
Dust spot efficiency %

Fractional Efficiencies %

3.0 micron 1.0 micron 0.3 micron

25-30 80 20 <5

60-65 93 50 20

80-85 99 90 50

90 >99 92 60

DOP 95 -- >99 95
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Low efficiency filters are almost totally ineffective at removing sub-micron 
particulates from the air. It is also important that the filters used are properly sized 
for the air handlers. Gaps around the filter panels can allow air to bypass the filter as 
it passes through the air conditioner. Any gaps or openings should be filled using 
appropriate materials, such as stainless steel panels or custom filter assemblies.

Positive Pressurization and Ventilation
A designed introduction of air from outside the computer room system will be 
necessary in order to accommodate positive pressurization and ventilation 
requirements. The data center should be designed to achieve positive pressurization 
in relation to more loosely controlled surrounding areas. Positive pressurization of 
the more sensitive areas is an effective means of controlling contaminant infiltration 
through any minor breaches in the room perimeter. Positive pressure systems are 
designed to apply outward air forces to doorways and other access points within the 
data processing center in order to minimize contaminant infiltration of the computer 
room. Only a minimal amount of air should be introduced into the controlled 
environment. In data centers with multiple rooms, the most sensitive areas should be 
the most highly pressurized. It is, however, extremely important that the air being 
used to positively pressurize the room does not adversely affect the environmental 
conditions in the room. It is essential that any air introduction from outside the 
computer room is adequately filtered and conditioned to ensure that it is within 
acceptable parameters. These parameters can be looser than the goal conditions for 
the room since the air introduction should be minimal. A precise determination of 
acceptable limits should be based on the amount of air being introduced and the 
potential impact on the environment of the data center. 

Because a closed-loop, re-circulating air conditioning system is used in most data 
centers, it will be necessary to introduce a minimal amount of air to meet the 
ventilation requirements of the room occupants. Data center areas normally have a 
very low human population density; thus the air required for ventilation will be 
minimal. In most cases, the air needed to achieve positive pressurization will likely 
exceed that needed to accommodate the room occupants. Normally, outside air 
quantities of less than 5% make-up air should be sufficient (ASHRAE Handbook: 
Applications, Chapter 17). A volume of 15 CFM outside air per occupant or 
workstation should sufficiently accommodate the ventilation needs of the room.

Cleaning Procedures and Equipment
Even a perfectly designed data center requires continued maintenance. Data centers 
containing design flaws or compromises may require extensive efforts to maintain 
conditions within desired limits. Hardware performance is an important factor 
contributing to the need for a high level of cleanliness in the data center.

Operator awareness is another consideration. Maintaining a fairly high level of 
cleanliness will raise the level of occupant awareness with respect to special 
requirements and restrictions while in the data center. Occupants or visitors to the 
data center will hold the controlled environment in high regard and are more likely 
to act appropriately. Any environment that is maintained to a fairly high level of 
cleanliness and is kept in a neat and well organized fashion will also command 
respect from the room’s inhabitants and visitors. When potential clients visit the 
room they will interpret the overall appearance of the room as a reflection of an 
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overall commitment to excellence and quality. An effective cleaning schedule must 
consist of specially designed short-term and long-term actions. These can be 
summarized as follows:

Frequency Task

Daily Actions Rubbish removal

Weekly Actions Access floor maintenance (vacuum and damp mop)

Quarterly Actions Hardware decontamination

Room surface decontamination

Bi-Annual Actions Subfloor void decontamination

Air conditioner decontamination (as necessary)

Daily Tasks

This statement of work focuses on the removal of each day’s discarded trash and 
rubbish from the room. In addition, daily floor vacuuming may be required in Print 
Rooms or rooms with a considerable amount of operator activity.

Weekly Tasks

This statement of work focuses on the maintenance of the access floor system. During 
the week, the access floor becomes soiled with dust accumulations and blemishes. 
The entire access floor should be vacuumed and damp mopped. All vacuums used in 
the data center, for any purpose, should be equipped with High Efficiency Particulate 
Air (HEPA) filtration. Inadequately filtered equipment cannot arrest smaller particles, 
but rather simply agitates them, degrading the environment they were meant to 
improve. It is also important that mop-heads and dust wipes are of appropriate non-
shedding designs.

Cleaning solutions used within the data center must not pose a threat to the 
hardware. Solutions that could potentially damage hardware include products that 
are:

• Ammoniated

• Chlorine-based

• Phosphate-based

• Bleach enriched

• Petro-chemical based

• Floor strippers or re-conditioners. 

It is also important that the recommended concentrations are used, as even an 
appropriate agent in an inappropriate concentration can be potentially damaging. 
The solution should be maintained in good condition throughout the project, and 
excessive applications should be avoided.
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Quarterly Tasks

The quarterly statement of work involves a much more detailed and comprehensive 
decontamination schedule and should only be conducted by experienced computer 
room contamination-control professionals. These actions should be performed three 
to four times per year, based on the levels of activity and contamination present. All 
room surfaces should be thoroughly decontaminated including cupboards, ledges, 
racks, shelves and support equipment. High ledges and light fixtures and generally 
accessible areas should be treated or vacuumed as appropriate. Vertical surfaces 
including windows, glass partitions, doors, etc. should be thoroughly treated. Special 
dust cloths that are impregnated with a particle absorbent material are to be used in 
the surface decontamination process. Do not use generic dust rags or fabric cloths to 
perform these activities. Do not use any chemicals, waxes or solvents during these 
activities.

Settled contamination should be removed from all exterior hardware surfaces 
including horizontal and vertical surfaces. The unit’s air inlet and outlet grilles 
should be treated as well. Do not wipe the unit’s control surfaces as these areas can 
be decontaminated by the use of lightly compressed air. Special care should also be 
taken when cleaning keyboards and life-safety controls. Specially treated dust wipes 
should be used to treat all hardware surfaces. Monitors should be treated with optical 
cleansers and static-free cloths. No Electro-Static Discharge (ESD) dissipative 
chemicals should be used on the computer hardware, since these agents are caustic 
and harmful to most sensitive hardware. The computer hardware is sufficiently 
designed to permit electrostatic dissipation thus no further treatments are required. 
After all of the hardware and room surfaces have been thoroughly decontaminated, 
the access floor should be HEPA vacuumed and damp mopped as detailed in the 
Weekly Actions.

Bi-Annual Tasks

The subfloor void should be decontaminated every 18 months to 24 months based on 
the conditions of the plenum surfaces and the degree of contaminant accumulation. 
Over the course of the year, the subfloor void undergoes a considerable amount of 
activity that creates new contamination accumulations. Although the weekly above 
floor cleaning activities will greatly reduce the subfloor dust accumulations, a certain 
amount of surface dirt will migrate into the subfloor void. It is important to maintain 
the subfloor to a high degree of cleanliness since this area acts as the hardware’s 
supply air plenum. It is best to perform the subfloor decontamination treatment in a 
short time frame to reduce cross contamination. The personnel performing this 
operation should be fully trained to assess cable connectivity and priority. Each 
exposed area of the subfloor void should be individually inspected and assessed for 
possible cable handling and movement. All twist-in and plug-in connections should 
be checked and fully engaged before cable movement. All subfloor activities must be 
conducted with proper consideration for air distribution and floor loading. In an 
effort to maintain access floor integrity and proper psychrometric conditions, the 
number of floor tiles removed from the floor system should be carefully managed. In 
most cases, each work crew should have no more than 24 square feet (six tiles) of 
open access flooring at any one time. The access floor’s supporting grid system 
should also be thoroughly decontaminated, first by vacuuming the loose debris and 
then by damp-sponging the accumulated residue. Rubber gaskets, if present, as the 
metal framework that makes up the grid system should be removed from the grid 
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work and cleaned with a damp sponge as well. Any unusual conditions, such as 
damaged floor suspension, floor tiles, cables and surfaces, within the floor void 
should be noted and reported.

Activity and Processes
Isolation of the data center is an integral factor in maintaining appropriate 
conditions. All unnecessary activity should be avoided in the data center, and access 
should be limited to necessary personnel only. Periodic activity, such as tours, should 
be limited, and traffic should be restricted to away from the hardware so as to avoid 
accidental contact. All personnel working in the room, including temporary 
employees and janitorial personnel, should be trained in the most basic sensitivities 
of the hardware so as to avoid unnecessary exposure. The controlled areas of the data 
center should be thoroughly isolated from contaminant producing activities. Ideally, 
print rooms, check sorting rooms, command centers or other areas with high levels of 
mechanical or human activity should have no direct exposure to the data center. 
Paths to and from these areas should not necessitate traffic through the main data 
center areas.
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Glossary 

Numerics
2N
A PDU that supplies power to the redundant AC power grid and the third and fourth 
accessory racks. See also N+1 and 2N+1.

2N+1
Two PDUs for AC redundancy. Each PDU has extra DC power supplies for N+1 
redundancy for each PDU.

A
ACS
See Automated Cartridge System (ACS).

ACSLS
See Automated Cartridge System Library Software (ACSLS).

ADI
Automation drive interface.

access door
A door on either side of the front facade through which service personnel can enter the 
library. Optional CAPs are attached to the right access door.

activated capacity
The number of storage cells the library is activated to use. This cannot exceed the 
installed capacity. 

Automated Cartridge System (ACS)
A group of libraries connected via pass-thru ports.

Automated Cartridge System Library Software (ACSLS)
An open systems software package that manages library contents and controls library 
hardware to mount and dismount cartridges on tape drives. This application also 
provides library management services such as cartridge tracking, pooling, reports, and 
library control.

audit
An inventory of cartridge locations in all areas of the library, including the slots in the 
storage and reserved areas. Audits occur when:
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• The library initializes at power-on.

• After either one or both access doors are opened and closed without activating the 
service safety door.

• A physical audit request is made through SL Console.
 
Also see host audit, physical audit, security audit, verified audit and virtual audit.

away library
The SL8500 library that is always located on the left side of a home library, as viewed 
from the front. The away library does not supply power to, control, or recover the 
pass-thru port.

B
bar code line scan camera
A component of the robot that is used for cartridge identification and position 
calibration.

bulk load
Manually loading cartridges into the library, for example, during library installation.

C
CAP
See cartridge access port (CAP). 

CDS
Control data set.

CLI
Command line interface.

capacity
The storage capacity of the library. See also activated capacity and installed capacity.

cartridge
A container holding magnetic tape that can be processed without separating the tape 
from the container. The library uses data, diagnostic, and cleaning cartridges.

cartridge access port (CAP)
A bi-directional port built into the door panel of the library which provides for the 
manual entry or automatic ejection of data or cleaning cartridges. Same as import/export 
mail slot in SCSI and open system libraries.

cartridge bias
Left or right justification of a cartridge within a storage cell, CAP, or tape drive.

cartridge proximity detector
A component that determines if a cell is empty or contains an unlabeled cartridge 
during a label reading error recovery procedure. Same as empty cell detector.

cell
The location in the library in which a tape cartridge is stored. Same as slot.

cell array
An array that holds multiple cartridges when not in use.
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cleaning cartridge
A tape cartridge that contains special material to clean the tape path in a transport or 
drive. 

cold swap
To remove and replace a system component (typically one such as a logic board that has 
no redundant backup) after system operations have been stopped and system power has 
been disabled. Contrast with hot swap. 

control data set
Data set used by the host software to control the functions of the automated library. 
Also called a library database.

customer interface module
The front module of the library at which you has access to the touch screen operator 
panel and service personnel have access to the library and service bay.

D
data cartridge
A term used to distinguish a cartridge onto which a tape drive may write data from a 
cartridge used for cleaning or diagnostic purposes. 

diagnostic cartridge
A data cartridge used for diagnostic routines. 

data path
The path where data is transferred between the host and tape drives.

drive and electronics module
The module in an library that houses the electronics control module, power distribution 
units (PDUs), power supplies, accessory racks and equipment, and tape drives for the 
library.

drive array assembly
An array that is installed in the drive and electronics module for mounting tape drive 
tray assemblies. The drive and electronics module holds up to four array assemblies, 
and each array holds up to 16 tape drive tray assemblies.

drive bay
A partitioned section of the tape drive array assembly that holds one tape drive tray 
assembly.

drive bay address
A two-digit integer (01–64) that represents the physical locations into which drive 
tray assemblies are inserted.

drop-off cells
Cells used to hold a cartridge in the event of a robot failure that occurs while a cartridge 
is in the robot hand. 

Dual TCP/IP
Provides two separate host connections between the host software (ACSLS or HSC) and 
the library controller.
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dynamic WWN
When enabled, dWWN assigns names to library drive slots rather than devices. 
When a drive is replaced, the new drive receives the same name as the one it 
replaced, thereby eliminating the need for system re-configuration. dWWN assigns 
names to individual tape drive slots rather than devices

E
ECM
See electronics control module.

ELS
See Enterprise Library Software.

ESCON
See Enterprise Systems Connection (ESCON).

EPO
See emergency power-off (EPO). 

eject
See export.

electronics control module
A module that includes the HBK card, HBC/HBCR card and HBT card. The assembly 
that: 

• Processes commands from a host system

• Coordinates the activities of robots, elevators, pass-thru ports, and tape drives

• Monitors status inputs from sensors and switches

elevator
The device that transports cartridges vertically. The SL8500 library features two 
elevators that provide vertical pass-thru operations between library storage modules 
within the same library.

emergency power-off (EPO)
(1) A safety scheme that allows a “power down” of a subsystem or a system as a whole 
instead of powering it down component-by-component. 

(2) A safety switch on a machine or in a data center that allows a user to immediately 
power down a machine or a data center power supply by cutting off the external source 
power. 

enter
See import.

Enterprise Library Software
The software products that automate tape operations for mainframe users.

Enterprise Systems Connection (ESCON)
An optical fiber serial interface which supports half duplex data transfers.

environmental monitors
A collective term for the sensors that track temperatures, fan speeds, and the status of 
various other mechanism within a library.
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Ethernet
A local-area, packet-switched network technology. Ethernet is a 10- or 100-megabytes-
per-second LAN. 

export
The action in which the library places a cartridge into the cartridge access port so that 
the operator can remove the cartridge from the library. Same as eject.

F
FRU
Field replaceable unit.

failover
The act of moving to a secondary or redundant path when the primary path fails. Also, 
in ACSLS HA, failing over to the standby (alternate) ACSLS server.

Fibre Channel
A bidirectional, full-duplex, point-to-point, serial data channel structured for high 
performance capacity. The Fibre Channel is an interconnection of multiple 
communication ports, called N_Ports. These N_Ports are interconnected by a switching 
network, called a fabric, to a point-to-point link, or an arbitrated loop. 
Fibre Channel is a generalized transport mechanism with no protocol of its own. A Fibre 
Channel does not have a native input/output command set, but can transport existing 
Upper Level Protocols (ULP) such as SCSI and IPI.  
Fibre Channel operates at speeds of 100 MB per second (full speed), 50 MB per second 
(half speed), 25 MB (quarter speed), or 12.5 MB (eighth speed). Fibre Channel operates 
over distances of up to 100 m over copper media or up to 10 km over optical links.

front controller module
The module that houses the controller for the elevators, CAPs, turntables, and safety 
barrier.

front facade
The external portion of the customer interface module, between the access doors, that 
holds the:

• Membrane keypad

• Product logos

• Optional touch screen operator control panel

G
get
An activity in which a robot obtains a cartridge from a cell or drive. 

gripper
(1) The portion of the hand assembly that grasps the cartridge. 

(2) The part of the hand assembly that grasps and holds a cartridge during transport.
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H
HLI/PRC
Host Library Interface/Panel Row Column

hand assembly
A part of the library robot whose function is to grasp cartridges and move them between 
storage cells and drives. A camera on the hand assembly reads cartridge volume labels. 

home library
The library that provides power, signal, and control lines to the pass-thru port (PTP) 
mechanisms. This is the library on the right as viewed from the front. The home 
library supplys power and communication to the PTP.

host audit
The process of updating the cartridge vol-ids and locations (collected by a security 
audit) in a host CDS. This audit is initiated by a host command.

hot swap
Removal and replacement of a system component while system power remains on and 
system operations continue. Contrast with cold swap. Contrast with hot-pluggable. Same 
as online servicing.

hot-pluggable
The capability that allows an Oracle service representative to replace a system 
component while power to the system is maintained. This feature allows hardware 
maintenance actions and hardware upgrades to proceed without disrupting subsystem 
availability. Contrast with hot swap. 

I
import
The process of placing a cartridge into the cartridge access port so that the library can 
insert it into a storage cell. 

installed capacity
The number of storage cells physically present in the library.

interlock switch
A switch that disconnects power to library mechanisms, excluding tape drives, when the 
front door is opened. 

K
keypad interface
See membrane keypad.

L
LCM
See Library Content Manager (LCM).

LTO
See linear tape open format (LTO).
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library complex
Two or more SL8500 libraries attached to each other with pass-thru port (PTP). Same as 
ACS for ACSLS and HSC.

library controller (LC)
The HBC/HBCR card within the library that controls operations and communicates 
with the operator panel.

Library Content Manager (LCM)
Software that provides content management for mainframe automated tape 
environments. Works in conjunction with host software component, virtual storage 
manager and your tape management system.

library operator panel
See touch screen operator control panel.

library storage module (LSM)
Library component connected to other LSMs in a library complex via a pass-thru port. 
Same as an SL8500 rail.

linear tape open format (LTO)
A set of tape data format standards created to enable data interchange among 
different LTO Ultrium tape drive vendors. These standards allow data cartridges to 
be shared.

logical library
A virtual representation of a physical library. Same as virtual library partition. 

M
magazine
A removable array that holds cartridges and is placed into the cartridge access port 
(CAP).

master pass-thru port
The side of a pass-thru port (PTP) that contains the electronics that control the actions of 
the PTP.  See also standby pass-thru port. 

membrane keypad
A keypad mounted on the front facade used to monitor the status of the library and to 
operate the CAPs.

Multi TCP/IP
Using TCP/IP connections to multiple libraries to provide redundant communication 
paths between the host software (ACSLS or HSC) and an SL8500 library complex.

N
N+1
A power configuration that provides AC power and redundant DC power by adding a 
second DC power supply to each DC bus. See also 2N.
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O
online replacement
Replacement or service of a module while the library remains operational. The service 
person may be required to power off the module before removing or replacing it. Same as 
hot swap.

operator panel 
See touch screen operator control panel.

orphaned cartridge
A cartridge in a partitioned library that is located in an unallocated cell or drive (that 
is, a cell or drive not allocated to any defined partition). Cartridges may become 
orphaned when partition boundaries are changed, partitions are deleted, or 
cartridges are manually moved to unallocated or inaccessible cells. 

P
PDU
See power distribution unit (PDU).

PLI
See primary library interface (PLI).

PTP
See pass-thru port (PTP). 

pass-thru port (PTP)
An electro-mechanical device that allow one library storage module to pass a cartridge 
to another adjacent library storage module in the same complex. Connecting libraries 
together with pass-thru ports is what creates an SL8500 library complex. SL8500 libraries 
are joined together by four PTPs because there are four rails. See also home library and 
away library.

physical audit
Physical audits occur when the robots:

• Scan the cartridge locations in the library

• Verify the volumes

• Update the library control card inventory

• Set the status of the cartridge location to true

physical library
A physically present library as opposed to a logical library.

power distribution unit (PDU)
A device for the distribution of AC line power from one inlet to multiple outlets. 
Multiple PDUs provide higher availability because the power continues if one PDU (or 
its alternating current  source if the PDUs use separate AC sources) loses power. 

primary library interface (PLI)
The communication path between the operator panel and the library controller. 

put
An activity in which a robot places a cartridge into a cell or drive. 
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R
RE
See Redundant Electronics (RE).

RTD
See real tape drive (RTD).

rail
(1) That portion of the upper robot track assembly that provides power and 
communication to the robot. (2) All of the cartridge slots and drives accessible through a 
rail. 

rail assembly
The mechanism on which the robot travels between cartridge arrays and tape drives.

reach mechanism
A component of the robot that moves the gripper to get or put a cartridge at a 
designated location.

real tape drive (RTD)
The physical transport attached to the LSM. The transport has a data path to a VTSS 
and may also have a data path to MVS or to another VTSS. 

Redundant Electronics (RE)
A feature that provides failover protection in enterprise libraries. RE uses a two sets of 
library controller cards. At any given time, one set is active and the other set is standby. 
The active library controller can failover to the standby in response to a command from 
ACSLS or the SL Console. Automatic failover can be initiated by the library in the event 
of a library card failure.

remote operator console
The customer’s operator panel that interfaces with the PLI. See also security software 
layer.

Between the drive expansion module and another module, an extender card/cable 
connector that connects the RLM to the RLE card in the drive expansion 
module.robot
A mechanism that moves horizontally along a track to transport tape cartridges to and 
from other locations in the library. 

robotics interface module
The module containing the curved rails and pass-thru port (PTP) assemblies.

S
SSL
See Secure Sockets Layer (SSL).

security audit
The process of reading and storing in library memory the vol-ids and locations of all 
cartridges in the library. See also host audit.

Secure Sockets Layer (SSL)
A cryptographic protocol that provides communication security. The communication 
path between the PLI and the remote operator console occurs through SSL.
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service area
An area between the access doors of the customer interface module and the safety 
barrier. In the service area, a redundant or inoperable robot can be stored for service and 
other mechanisms can be repaired or replaced.

service safety door 
A motor-driven barrier that lowers and raises. This door separates the service areas of 
the front interface assembly from the rest of the library. The SSD allows service 
personnel to safely repair or replace library mechanisms while the front access door is 
opened and closed., without interference with most library operations.

slot
Same as cell.

standby pass-thru port
The side of a pass-thru port (PTP) that operates in response to actions initiated by the 
master side of the PTP. See also master pass-thru port. 

T
TTI
See tape transport interface (TTI).

tape cartridge
A container holding magnetic tape that can be processed without separating the tape 
from the container. The library uses data, diagnostic, and cleaning cartridges. These 
cartridges are not interchangeable.

tape drive
An electromechanical device that moves magnetic tape and includes mechanisms for 
writing and reading data to and from the tape. 

tape drive tray assembly
The mechanical structure that houses a tape drive, fan assembly, power and logic cards, 
cables, and connectors for data and logic cables. Same as drive tray assembly.

tape storage area
The area in the library where cartridges are stored.

tape transport interface (TTI)
An interface to control and monitor tape movement.

touch screen operator control panel
A flat-panel display with a touch screen interface and a panel mount computer. This 
feature is attached to the front of the library.

track
The horizontal path upon which a robot travels.

track drive mechanism
The component that moves the robot along the track between the cell arrays, CAPs, and 
tape drives. 

V
vol-id
Volume ID assigned to a cartridge. Same as VOLSER.
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VOLSER
Volume serial number. Same as vol-id.

VSM
See virtual storage manager (VSM).

VTCS
See virtual tape control system (VTCS). 

VTD 
See virtual tape drive (VTD).

VTSS
See virtual tape storage subsystem (VTSS).

vacancy plate
A plate that covers an unused bay, such as a drive bay or power supply bay.

verified audit
Verified audits are invoked from the SL Console and actually validate the status of a 
specific cartridge slot or range of slots.

virtual audit
Virtual audits are invoked from the SL Console and only display the cartridge 
inventory in the console screen (either local or remote).

virtual storage manager (VSM)
 A storage solution that virtualizes volumes and transports in the buffer of a virtual 
tape storage subsystem to improve media and transport use.

virtual tape control system (VTCS)
The primary host code that controls activity and information about VTSSs, VTVs, 
RTDs, and MVCs.

virtual tape drive (VTD) 
An emulation of a physical transport in the VTSS that looks like a physical tape 
transport to MVS. The data written to a VTD is really being written to DASD. The 
VTSS has 64 VTDs that do virtual mounts of VTVs.

virtual tape storage subsystem (VTSS)
The DASD buffer containing virtual volumes (VTVs) and virtual drives (VTDs). The 
VTSS is a STK RAID 6 hardware device with microcode that enables transport 
emulation. The RAID device can read and write “tape” data from/to disk, and can 
read and write the data from/to an RTD.

virtual tape volume (VTV) 
A portion of the DASD buffer that appears to the operating system as a real tape 
volume. Data is written to and read from the VTV, and the VTV can be migrated to 
and recalled from real tape.

W
See wrist
A mechanism in the robot assembly that allows the robot to access the outer and inner 
storage walls. 
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2N power configuration 291

A

ACSLS
described 18
version supported 18

activated capacity
design layout 74–78, 82–89
reports 79, 91–95

activated features
display current 108
install 99
Partitioning 123

adding a library to the right 427
addressing

CAPs 224, 442
elevators 442
HandBot 290
HandBots 443
HLI-PRC 434
internal firmware 434
library complex 432
PTPs 444
scheme comparison 435
tape drives 438

AEM access door
audits and 322, 323

arrays
locating the cartridges 434

audits
AEM access door and 322, 323
audit indicator 322
description 322–323
full library 379
main access door and 322, 323
physical 323, 379, 380
range of cells 380
tasks 378–382
verified 323, 381–382

auto clean (drive)
description 284

auto discovery
added library 11
cartridge slots 11
drives 11

auto enter mode (CAPs)
described 225

automated mode
determining library state 409
returning the library to 414

automated mode (library)
description 183
determine 184

away library 306

C

CAP
addressing 442

CAP operations
tasks 226–229

CAP reservations
library partitions and 124

capacity
CAPs 223

CAPs
addressing 224
auto enter mode 225
capacity 223
cartridges

entering 223
closing 232
display properties 229
display status 228
display summary information 227
inserting cartridges 248
library partitions and 124–125
magazines 223
manual mode 225
self-test 384
utility tasks 383–387
varying offline 385



D

484  SL8500 User’s Guide  

varying online 387
cartridge

mounting 424
present sensor 289

Cartridge Expansion Module
components in 4

cartridges
addressing 434
applying labels 451
cleaning. See cleaning cartridges.
diagnostic 448
diagnostic. See diagnostic cartridges.
display information 257
ejecting 223
ejects 248, 255
entering 223
enters 247, 254
exterior cleaning 450
handling 449
handling of 445
home cell 248
inserting in a cell or drive 450
inserting in the CAP 247, 248
inspecting 449
list 261
locate by address 266
locate by VOLID 264
locating by address 252
locating by VOLID 252
management tasks 253–280
mounts and dismounts 183
move by VOLID 271
move from specified location 276
placement in cells 8
recovery moves 252
StorageTek 447
storing 450
unlabeled 247

cautions
lubrication 421
moving robot

leaving objects inside 421
mechanical stop 421
position 421

reentering cleaning cartridge 446
solvents for cleaning a cartridge 450, 451

cells
locations in a library 434

cleaning cartridges 446
for LTO drives 448

Client System Component 16
communication

HBC controller 7

configuration
dWWN 13
flash memory 6

CSC 16
customer interface module 7

D

detection
added library 11
cartridge slots 11
drives 11
empty slot 289
non-labeled cartridges 289

device status
listing codes 335

diagnostic cartridges 446
description 321
displaying information 375
exporting 371
importing 368
library self-tests and 320
management tasks 367

diagnostic moves (robot)
control functions 326
controlling 405
defining 399–400
description 324–326
managing definitions 401
monitoring 405
pool address range 324
random access order 325
robot selection 325
saving 402–403
sequential access order 325
starting 404
target address range 324

diagnostic support files 329
dismount operations 184
disruptive installation 306, 427
domain, media labels 446
drive

addressing 438
drive cleaning

automatic 284
description 283

drive controller 201
Drive Events Report 243
Drive Media Events Report 245
drive trays

status 242
drive VOP

displaying for T10000 239
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drives
auto discovery 11
cleaning. See drive cleaning.
detection 11
display drive properties 238
display drive summary information 235
display status 237
Fibre Channel topology supported 13
interfaces 5
LED status 241
management tasks 234
mounting a cartridge 424
NCS component 17
network data 240
power on and off 418
self-test 390
states 233
supported 5
utility tasks 389–393
varying offline 391
varying online 393

dWWN
automatic handling 11

E

eject operations 248, 255
electronics module

HBC card 7
HBK card 6
HBT card 7

elevator
properties 311
status of 310
summary information 309, 312

elevators
addressing 442
configuration 9
description 9

emergency robotics stop
switch location 15
usage 410

enter operations 247, 254
entering the library 419
ESCON 5
event monitors

description 315
display 332
display multiple 334
spool data to a file 333
tasks 331

exiting the library 420

F

FC-AL 13
FC-SW 13
Fibre Channel

configuration 13
topology supported 13

Fibre Channel (interface) 5
FICON 5
firmware

addressing
CAPs 442
elevators 442
HandBots 443
PTPs 444

features 11
flash memory versions 6

flash memory, discussed 6
frame serial numbers, location 6

G

General Events Statistics Report 202
gripper

initialization 289

H

HandBot
initialization 288
numbering 290
redundant operation requirements 288

HandBots
addressing 443

hardware activation file
delete 109
description 97
display current 108
download 101
Feature Audit Log 111, 121
file type 97
install 106–107, 115–117
installing 99
library serial number and 106, 115

hardware activation key file
overlaying 98
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hardware activation screen reference 112
hardware activation tasks 99–111
HBB card 288
HBC card 7
HBK card 6
HBN card 288
HBQ card 288
HBS card 288
HBT card 7
HLI interface

displaying port status 195
HLI-PRC

comparison 435
description 434

home library 306
host

Fibre Channel connection 13
library management software 16

host interfaces
HLI. See HLI interface. 195

Host Software Component 17
HSC 17

LibraryStation component 17
storage management component

requirement 17
version 17

I

initialization
library sequence 288

inner walls 8, 431
interface

CLI 6
host-to-library 7
tape drive 5

internal addresses
description 434

K

key
location

left service safety door 15
right service safety door 16

maintenance 429
opening the front access doors 419

L

LIBGEN 17
library

ACSLS requirement 18
adding to the right 427
capacities, cartridge tapes 8, 431

determining not in automated mode 409
entering the library 419
entry precautions 419
exiting 420
firmware features 11
initialization sequence 288
mounting a cartridge 424
partitions

CAP operations 150–153
summary screen reference 154–182

placing in manual mode 413
placing online 415
power off 416, 418
returning to automated mode 414
unpartitioned

orphaned cartridges in 71, 95
library complex

addressing 432
described 11
displaying status 189
illustrated 428
properties 199

library configuration
display 196

library controller
display redundant electronics 213, 215
log in to alternate 221
properties 200

library events 315
library events. See Also event monitors.
library firmware upgrades 319

activate 345
download 340

library management software
ACSLS 16
described 16
HSC 16

library management tasks 187–203
library partitions

and hosts 124
CAP reservations and 124
deleting 148
described 123
orphaned cartridges in 126

library reboot 351
library reports 24–25

displaying 51
saving data to a file 55
searching 53

library self-tests 320
performing 361, 364

library status 23, 185
display 188
using Refresh button 24
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library utility tasks 339
LibraryStation 17
LibraryStation component 17
local operator panel

described 16, 29–30
entering data 29
factory alignment 30
logging in 35
pen and stylus 29
re-calibrating 30, 58–60
resetting calibration to factory settings 61
touch-screen 29
virtual keypad 29

log snapshot file
described 329
generating process 357
transfer process 359–360

logic cards
HBC 7
HBT 7

login IDs 20
logs

Feature Audit Log 111, 121

M

main access door
audits and 322, 323
automated mode and 184

maintenance key 429
manual CAP 225
manual mode

determining library not in automated mode 
409

entering the library 419
exiting the library 420
mounting a cartridge 424
moving the robot 421
physical restrictions 411
placing the library in manual mode 413
returning the library to automated mode 414

manual operations
safety precautions 410

general 410
tasks 412–428

media
domain labels 446
ID labels 446

Media Events Report 281
MERGEcds 17
MIB file

described 329
transfer process 353–355

module
customer interface 7
drive 6
electronics

HBC card 7
HBK card 6
HBT card 7

mount operations 183

N

N+1 power configuration 291
nagement 367
network

dWWN entries 13
nondisruptive installation, advantages 305
non-labeled cartridges

detection 289
numbering

cartridge cell locations 434
HandBot 290
tape drives 438

O

options
library 2
library partitioning 1

orphaned cartridges
partitioned libraries and 126

outer walls 8, 431

P

panel, row, column addressing 435
partitioning 123
Pass-thru Ports

locations 4
pass-thru ports

addressing 444
Pass-thru Ports (PTPs)

addressing scheme 306
away 306
configuration 305
described 10
disruptive installation 306, 427
home 306
illustrated 428
nondisruptive installation 305

passwords
activation 20
length 20
modifying 48
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placement of data cartridges 8
placing the library in manual mode 413
power

off 418
switches 416

power supplies 291
2N configuration 291
monitoring tasks 301–303
N+1 configuration 291
status of 303
summary information 302

power supplies, location 417
proximity sensor 289
PTP

properties 314
status of 313

R

reach safe, sensor 289
reboot

library 351
recovery moves 252
redundant electronics

manual switch 219
tasks 212–222

report
capacity activated 79
orphaned cartridges 78, 80

reports
capacity activated 91
cartridge cell and media summary 93
cartridge summary 262
cartridge table 258
drive events 243
drive media events 245
feature audit log 111
media events 281
orphaned cartridges 95

restrictions, library interior 411
result codes

listing 337
returning the library to automated mode 414
robot

addressing 443
diagnostic moves. See diagnostic moves.
display status of 295
display summary information 294
monitoring tasks 293–303
moving manually 421
properties 296
self-test 395
status of 299
utility tasks 394–407

varying offline 396
varying online 398

S

safety door
monitoring tasks 297–299
operation of 429
properties 300
summary information 298

safety precautions 410
general 410

SAN 13
self-tests

CAP 384
drive 390
library 320, 361, 364
robot 395

sensors
cartridge present 289
reach safe 289

serial numbers, locations on frame 6
SL Console

activation password 20
communications failures 186
description 19
first-time access 20
logging off 46
login ID 20
modes 20
modifying passwords 48
screen, components 21
screen, modifying layout 23
security 20
standalone. See standalone SL Console
synchronize with library 23
user ID 20
Web-launched. See Web-launched SL Console

SL Console Help
description 26
navigation 26

SL Console report tasks 50–56
SL Console reports

Drive Events 243
Drive Media Events 245
General Events 202
Media Events 281
Options Bar 25
types 24

SLConsole
dual TCP/IP 12

slots
addressing 435
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SMC 17
SNMP

transfer the library MIB file 353–356
standalone SL Console

description 32
installing 63–68
installing updates 32
logging in 44

status alerts
clearing 193
displaying 190

Storage Area Network
Arbitrated Loop 13
Switched Fabric 13

Storage Management Component 17
storage management component 17

T

T10000
ACSLS software requirement 18

T9x40
NCS component 17

tape drives
addressing 438

transferring the log snapshot file 359–360
troubleshooting 327

U

User ID
types 20

V

vary the library offline 413
vary the library online 415
verifying library status 409
vertical pass-thru operations 9
VOP

displaying for T10000 drives 239

W

warnings
entering the library procedures 419
exiting the LSM 421

Web-launched SL Console
client requirements 31
description 30–31
Java WebArchive file 453
logging in using a browser 36
logging in using an icon 41–43
logging in using CLI 36
security 31

starting on a client 31
updating on a client 31

Web-launched SL Console server
description 453
installing 454–458
security 453
updating 453

wrist, initialization 289
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