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Summary of Changes

Current Version: E21059-04, November 2012
Update made to include changes for SL500 firmware 1283 and SL Console 6.0:
• Addition of drive tray serial number (see “Add or Edit Drive Tray Serial 

Number” on page 248)
• Automatic time out of SL Console login after 6 hours beginning with SL Console 

5.8 and FRS_8.0 (see “Automatic Logout” on page 25)
• Updated chapter on contaminants to include warning regarding use of chlorine 

and other chemicals (see “Controlling Contaminants” on page 401)

Revision History

E21059-03 April 2012

Update made to mention use of the CLI by customers using StorageTek Tape 
Analytics. 

E21059-02, February 2012

Updates were made to support the new feature Generate Log Snapshot.

Other updates include:
• Moved the Transfer MIB File from the SNMP chapter to the SL Console 

Diagnostics chapter.
• Added screen captures to SNMP tasks.
• Added SL Console password limitations from 5-8 characters as of 4.50.

• Added a glossary.

• Edited the Partitioning chapter.

• Added section on finding customer documentation.

Revision E21059-01, June 2011

Assigned a new Oracle document part number and revision number, E21059-01. Sun 
part number 96116 has been retired. 
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Updates:
• A revised and reorganized “SL500 Introduction” chapter includes updated 

specifications and descriptions of new features like the “Dual-Port Fiber Channel 
Interface Card (PUA2).

• New chapters “Capacity on Demand” and “Hardware Activation Files” explain 
new capacity management features. 

• Download procedures have been revised for the Oracle E-Delivery website.   
• The new “Library Partitioning chapter explains how Partitioning is implemented.
• The new ADI bridging feature is described in the chapters “Configuring Bridging 

without Partitioning and Library Partitioning.
• A new appendix “Controlling Contaminants” explains the importance of 

minimizing airborne particulates and certain gases in areas where Oracle products 
are installed.

Revision KB, April 2010 (Sun Document Part Number: 96116)
• Described new reports. 
• Separated former Chapter 3, “SL500 Automated Library Operations” into multiple 

chapters on library management, CAP management, drive management, cartridge 
management, drive cleaning, and robot management.

• Updated company and product names. 
• Nomenclature changes for “hardware activation files”. 

Revision KA, July 2008

Updated the following chapters for new License Management and Capacity on 
Demand features. 
• Chapter 3, “Licensing” (new chapter)
• Chapter 4, “Capacity on Demand” (new chapter)
• Chapter 5, “Library Partitioning”

Major reorganization and enhancement of remaining chapters.  

Revision K, February 2008

Added information regarding the Library Partitioning feature:
• Chapter 1, “General Information”—Summary of library partitioning. 
• Chapter 5, “Library Partitioning”—Detailed descriptions of the concepts, tasks, 

and SLC screens involved in library partitioning. 

Added information regarding the Web-launched SL Console feature:
• Chapter 2, “StorageTek Library Console”—Detailed instructions for installing and 

using the Web-launched SL Console client.
• Appendix C, “Web-launched SL Console Server”—Detailed instructions for 

installing and managing the Web-launched SL Console server. 

Revision J, May 2007

Chapters 1 and 6: Added information regarding Quantum DLT-S4 drives/media and 
LTO Gen 4 drives/media. Library firmware must be version 1126 or later for support 
of these drives.
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Appendix A:
• Revised Sun Support telephone numbers for U.S. and Canada. 
• Added Web link to obtain telephone numbers for international Sun Support 

locations.

Older Revisions

Refer to the edition for a description of the changes.
• Revision H, October 2006
• Revision G, July 2006
• Revision F, April 2006
• Revision E, December 2005
• Revision D, May 2005
• Revision C, January 2005
• Revision B, October 2004
• Revision A, September 2004 – Initial release. 
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Preface

This book is about Oracle’s StorageTek SL500 modular library system hardware, 
StorageTek Library Console management software, and related operations. For 
specific drive information or for client application software commands, see the 
appropriate drive or software documentation. 

Audience
This guide is intended primarily for administrators and operators of Oracle’s 
StorageTek SL500 modular library system. It can also be used by Oracle partners and 
support representatives. 

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/support/contact.html or visit 
http://www.oracle.com/accessibility/support.html if you are hearing impaired.

Obtaining Customer Documentation
To access current product documentation for Tape Storage:

1. Use Web browser to go to the following Web page: 
http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html

The Tape Storage Products page opens.

2. Find the appropriate section and its list of products.

3. To view a list of documents for a product, click “View Library.”

A new page opens with a listing of all documents related to the product.

4. To download the entire suite of documents for the product, click “Download.”.

A compressed archive file will download that contains the entire suite of documents 
for that product.

5. To download a compressed archive file that contains the entire suite of documents, 
click the “Download” link.

http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
http://www.oracle.com/technetwork/documentation/tape-storage-curr-187744.html
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SL500 Introduction

This chapter provides an overview of the major hardware components of Oracle’s 
StorageTek SL500 tape library and library specifications. The SL500 library provides a 
highly adaptable storage platform made to specifically consolidate, protect and retain 
customer information. The library protects a customer’s investments by providing a 
cost-effective entry point and makes it easy to grow the library with expansion 
modules. Whether customers have a small remote site or a corporate data center, they 
can feel secure that the library can accommodate all of their current and future data 
storage needs.

The SL500 library is a self-contained, fully automated tape cartridge storage system 
that is scalable and mounts into a standard 483 mm (19 in.) rack. It is also available as 
a desk-top unit.

This chapter introduces you to the SL500 library and its components and 
configurations. This chapter includes the following topics:

• “Library Interfaces and Controls” on page 5

• “Drives, Cartridges, and Related Features” on page 10

• “Library Configurations and Capacities” on page 11

• “Library Components” on page 17

• “Safety Features” on page 22

• “Tape Management Software” on page 22 
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SL500 Features
The SL500 library offers the following features and capabilities:

• Scalable storage capacity from 30 to 575 storage cells, in 30-cell increments

• Scalable performance using from 1 to 18 tape drives

• Support for LTO and SDLT tape drives with Serial Attached SCSI (SAS), Fibre 
Channel (FC), or parallel SCSI interfaces

• Oracle’s StorageTek Any Cartridge, Any Slot support for mixed-media

• Optional Library Partitioning

• Optional host interfaces: Either Dedicated Storage-Control Interface cards that 
separate control and data paths or ADI Bridging for a combined control/data path

• Optional single- or dual path Dedicated Storage-Control Interface cards

• Comprehensive Library Management Interfaces, including the StorageTek Library 
(SL) Console, a Command Line Interface, and support for the Simple Network 
Management Protocol (SNMP)

• Heterogeneous attachments using standard interfaces
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Hardware Component Views and Locations
FIGURE 1-1 shows the front view of the SL500 library and its components. 
FIGURE 1-2 shows the back view of the library.

1. Base Module

2. Drive Expansion Module (DEM)

3. Library door

4. DEM, Cartridge Access Port (CAP)

5. Library door lock

6. Base Module, Cartridge Access Port (CAP)

7. Keypad assembly

8. Robotics unit

FIGURE 1-1  Front View of Library Hardware Components
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1. Base Module

2. Drive Expansion Module (DEM)

3. Cartridge Expansion Module (CEM)

4. Standard power supplies (if a corresponding redundant power supply is installed)

5. Redundant power supplies (if installed) or standard power supplies

6. Library power switch

7. Base Module, host drive 1 (SCSI drive 0119)

8. DEM, host drive 1 (SCSI drive 0219)

FIGURE 1-2  Back View of Library Hardware Components
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Library Interfaces and Controls
• “Host Interfaces” on page 5

• “Library Management Interfaces” on page 6

• “Mechanical Controls and Indicators” on page 8

Host Interfaces

Host systems and tape storage subsystems exchange two distinct kinds of 
information: 

• Storage-system commands: The host sends instructions that position robotics, 
mount and unmount volumes, clean drives, query the status of components, etc. 
The library sends the result of the command or the status of the queried 
component.

• User data: The host transfers user or application data to a tape drive in the library.

SL500 tape libraries can provide host interfaces by means of either:

• Dedicated Storage-Control Interface cards that maintain separate data and control 
paths

• The Bridging feature, using a single, combined control/data path

Dedicated Storage-Control Interface cards

When a dedicated SCSI over Fibre Channel interface card (MPU2 or PUA2) or a 
Parallel Low-Voltage Differential SCSI interface card (RLW) is installed, these two 
kinds of information reach the SL500 library by separate data and control paths:

• Data: Data travels directly to the data interface on the tape drive (see “Drives, 
Cartridges, and Related Features” on page 10 for further information on 
supported tape drives and interface types). 

• Control: Command and control signals travel to the library controller through the 
MPU2, PUA2, or RLW interface card. The library controller sends commands to 
the drives through an internal connection. 

Bridging

When supported LTO-5 tape drives are installed but dedicated storage-control 
interface cards are not, command and control information is sent with the data in a 
single control/data path. When an SL500 library does not detect an Oracle 
StorageTek MPU2 Fibre Channel or RLW parallel SCSI interface card at start up, the 
library adopts a bridged configuration by default.

Data and command/control signals travel directly to the Serial Attached SCSI (SAS) 
or Fibre Channel data interface on the LTO-5 tape drive. The Automation Device 
Interface (ADI) on a designated LTO-5 bridge drive handles all control 
communications for the library or library partition. The ADI passes command and 
control signals to the library controller.
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If a bridge drive has not been previously selected, the library selects the first bridge-
capable drive that it can find, starting from the top of the library. An unpartitioned 
bridged library must have one bridge drive. A partitioned bridged library must have 
a bridge drive for each partition. 

Currently, the SL500 library bridging feature is supported on HP LTO-5 Serial 
Attached SCSI (SAS) and Fibre Channel tape drives.

Library Addressing Schemes

Library addressing depends on the control-path interface used. For example, FC-SCSI 
hosts use sequential element numbering, with each element type (storage cell, tape 
drive, and CAP) having its own sequential range. See “SL500 Wall Diagrams and 
Specifications” on page 373 for full details. 

Host Interfaces and Partitioning

SL500 libraries support one host interface per library or partition. Therefore, a non-
partitioned library can use only one host and one kind of host interface (SCSI-FC, 
Parallel LVD SCSI, etc.). But each partition in a partitioned library can connect to a 
separate host using a separate interface. See “Library Partitioning” on page 103 for 
details. 

Both bridged and unbridged SL500 libraries support partitioning. In an unbridged 
library, the MPU2, PUA2 or RLW interface card manages the control path for all 
partitions in the library. In a bridged library, each partition contains an LTO-5 bridge 
drive that handles control communications for the containing partition alone. 

You cannot mix bridged and unbridged partitions in a single library. Physically, each 
SL500 library is, as a whole, either bridged or unbridged. A library that contains an 
MPU2, PUA2, or RLW interface card is unbridged. Such a library cannot include 
bridged partitions, even if otherwise bridge-capable drives are part of the 
configuration. Conversely, if an interface card is not present, there is obviously no 
way to configure an unbridged partition. All partitions must be bridged and must 
contain bridge drives. 

Library Management Interfaces

System administrators and service personnel interact with the library in one or more 
of the following ways:

• StorageTek Library (SL) Console

• Command Line Interface

• Simple Network Management Protocol

StorageTek Library (SL) Console

The StorageTek Library Console graphical user interface (GUI) is the primary tool for 
monitoring and administering SL500 libraries. SL Console is a standalone, Java-based 
or hosted, browser-based software application that enables you to control the library 
remotely over a TCP/IP local area network. 
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The network connects to the library through the PUBLIC Ethernet port located near 
the middle of the RLC controller card faceplate, as shown in FIGURE 1-3. (See 
“Library Controller Card (RLC)” on page 20 for more information about the LED 
indicators on the RLC card.)

See “StorageTek Library Console” on page 19 for complete details. 

Command Line Interface

Through the command line interface (CLI), Oracle support representatives can 
service the library through a serial connection to the CLI port at right side of the RLC 
controller card faceplate. See FIGURE 1-3 on page 7.

The CLI interface is reserved for authorized service personnel only, except for 
customers who use the StorageTek Tape Analytics (STA) server. For CLI commands 
related to the STA server, see the StorageTek Tape Analytics Installation and 
Administration Guide.

Simple Network Management Protocol

System administrators use Simple Network Management Protocol (SNMP) and 
standards-compliant management applications to monitor the SL500 library remotely 
over a TCP/IP local area network. SNMP can provide the following kinds of 
information: 

• The operational state of the library (firmware level, serial number, online/offline)

• The status of the CAPs (open, closed, etc.)

• Number of library elements (robots, drives, storage cells, CAPs, etc.) 

• Media and drive types 

For more information, see “SNMP Configuration with SL Console” on page 395.

Supported Versions

The SL500 supports two versions of SNMP:

• SNMPv2c can be used for routine machine status queries but is not secure. Data is 
completely accessible from the local network.

• SNMPv3 is preferred because it supports encryption and strong user 
authentication. Oracle requires SNMPv3 for transmission of confidential 
proprietary information.

FIGURE 1-3  RLC Controller Card Faceplate



Library Interfaces and Controls

8   SL500 User’s Guide

Activation of SNMP

The SL500 SNMP agent is disabled by default. An Oracle support representative can 
enable it for you to use the command line interface.

Mechanical Controls and Indicators

This section describes the controls and indicators that you can use to monitor and 
troubleshoot the library. For tape drive controls and indicators, refer to vendor 
publications. 

Power Switch

When the switch (see FIGURE 1-4 on page 9) is in the ON position (1) the library and 
tape drives are powered-on. When the switch is in the OFF position (0), the library 
and tape drives are powered-off.

Note that, in older libraries, the power supplies each have individual power switches. 
More recent libraries have a single power switch for all power supplies in the rack.

Power Supply LED

The power supply LED (Light Emitting Diode) indicates the condition of the power 
supply and warns you when corrective action is necessary. When the LED is ON 
(lighted), the power supply is working normally. When the LED is OFF (no light), the 
power supply is not getting power or has failed. A service technician can check 
connections and supply voltages and, if necessary, replace the power supply. 

Drive Tray LED

The drive tray LED alerts you to fan failure and potentially excessive drive 
temperatures. When the LED is ON and remains steadily lit, the fan is not cooling the 
drive assembly. Have a service technician check and, if necessary, replace the fan.

Keypad

The keypad holds both the buttons that open the door and Cartridge Access Ports 
(CAPs) and the LEDs that indicate normal functioning or alert you when service is 
needed. This section describes the behavior of keypad components under varying 
conditions. 

As the library starts, the keypad LEDs indicate the progress of initialization: 

1. When the library is first powered ON, all keypad LEDs turn ON and stay ON. 

2. As library applications start, all keypad LEDs turn OFF. 

3. Library Active LED flashes ON and OFF until the audit is complete, then turns 
OFF. 

4. The Library Active LED turns ON at the start of each command, then turns OFF 
as each command is completed.
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After the library is fully operational, the Library Active LED flashes ON and OFF 
whenever the library is active. FIGURE 1-4 shows the keypad components, and 
TABLE 1-1 provides details of the their meanings and functions. 

FIGURE 1-4  Buttons and Indicators  

TABLE 1-1  Description of Keypad Buttons and Indicators

Callout Object State Indicated Conditions and/or Actions

1 Open Door button PRESSED The software lets the current job finish and then retracts the robot 
into the robotics unit so that it is not damaged when the door opens.

2 Open Door LED ON The robot is parked in the robotics unit.

FLASHING The Open Door button has been pressed.

Initialization and audit are underway.

OFF The library is ready for use.

3 Open CAP button PRESSED The software opens all CAP doors.

4 Open CAP LED ON One or more CAP doors is open.

OFF All CAP doors are shut.

5 Service Required LED ON A non-redundant component has failed. The library is not 
operational and needs service. 

FLASHING The door is open. Close and lock the door to resume operations.

Diagnostics are running. 

Diagnostics failed, and a service representative has to check the issue.

The library is operational, but a redundant component has failed. A 
service technician needs to replace it to restore redundancy.

OFF The library is functioning normally. Service is not necessary.

6 Library Active LED FLASHING The library is active.

7 Service Robot LED ON The robot is not working. Service may be needed.

OFF The robot is functioning normally.
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Library Controller Card Indicators

The LED indicators of the library controller card are explained in the “Library 
Controller Card (RLC)” on page 20 section.

Drives, Cartridges, and Related Features
This section provides a general overview of supported drives, media, and related 
features. It covers the following topics:

• “LTO Supported Tape Drives” on page 10

• “SL500 Drive Trays” on page 10

LTO Supported Tape Drives

The SL500 library supports the following drives:

• Hewlett-Packard and IBM LTO Generation 2, 3, 4 parallel SCSI Low-Voltage 
Differential (LVD) in an unbridged library or as data drives in a bridged library.

• Hewlett-Packard and IBM LTO Generation 2, 3, 4 Fibre Channel drives in an 
unbridged library or as data drives in a bridged library.

• Hewlett-Packard LTO-5 Serial Attached SCSI (SAS) as a data drive or as a bridged 
drive.

• Hewlett-Packard LTO-6 Fibre Channel as a data drive or as a bridged drive.

SL500 Drive Trays

All tape drives are mounted on SL500-unique tray assemblies. Each assembly 
contains the:

• Tape drive

• +5 VDC fan

• RLD tape drive interface card

Drive tray assemblies are installed in slots (also called bays), accessible from the back 
of the library. When you insert a tape drive into the assigned slot, it connects to the 
RLD card by way of a cable. The RLD card connects directly to the RLM or RLE 
(Drive Expansion Module) backplane through a blind-mate connector.

Note – If a slot does not contain a tape drive, a vacancy plate 
must be installed over the slot.

Hot Swapping

Tape drives are hot-swappable. You can replace a drive without removing power 
from the library, as long you proceed as follows: 

1. Back up the server before removing the tape drive.

2. Before disconnecting the tape drives: If the tape drives are daisy-chained, stop all 
data processing on the channel to which the tape drives are connected.
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3. Before disconnecting the external SCSI cables: Make sure there is no activity on 
the SCSI bus. Stop all processes on the host.

4. Make sure that all signals are terminated at each end of the SCSI bus.

5. If your external data cables are long enough that they do not interfere with 
removing and replacing the tape drives, you can swap tape drives without 
disconnecting the external data cables. If so, disregard the steps to remove those 
cables.

Caution – Possible data loss or system problem. If you must disconnect 
the external data cables, make sure that you quiesce the system first 
(for example, stop all processes that access tape drives on the SCSI 
bus where you are replacing a tape drive).

Library Configurations and Capacities
SL500 modular libraries are assembled from the top of the rack down, starting with 
the base module. Optional Drive Expansion Modules (DEMs) and Cartridge 
Expansion Modules (CEMs) are then added until the desired capacity and 
configuration are reached.The library base module contains the robotics unit, robotic 
components, and the keypad as well as a base unit with storage cells and drive bays. 
Cartridge Expansion Modules and Drive Expansion Modules provide additional 
space for cartridges. Drive Expansion Modules provide additional space for drives. 

This section describes possible configurations of SL500 library modules and 
compatible tape drives. It starts with “LTO Library Configurations” on page 11 and 
concludes with “Mixed-Media Library Configurations” on page 14. 

Caution – Firmware problems: You can not mix LTO and mixed-
media arrays within the same library. If you add expansion 
modules, the new modules must have the same type arrays as the 
existing modules.

LTO Library Configurations 

This section explains “Internal Addressing in LTO Libraries” on page 11 and “LTO 
Library Configuration and Physical Capacity” on page 12. 

Internal Addressing in LTO Libraries 

Addressing is by library, module, row, and column, viewed from the front of the 
library. Each address consists of four integers, L,M,R,C, where: 

• The first digit, the Library number, is always 0.

• The second digit, the SL500 Module number, falls in the range [1-5], with 1 being 
the top-most module and 5 being the bottom-most.

• The third digit, the Row number, falls in the range [1-9] (for a base module) or 
[1-12] (for a Drive or Cartridge Expansion Module).

• The fourth digit, the Column number, falls in the range [1-9] (for a base module or 
Drive Expansion Module) or [1-11] (for a Cartridge Expansion Module).
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LTO Library Configuration and Physical Capacity

With Linear Tape Open (LTO) tape drives, the SL500 base module can store up to 50 
cartridges, one or two tape drives, and a five-cell cartridge access port (CAP) that can 
also store cartridges. You increase this starting number of storage cells by adding 
Drive Expansion Modules (DEMs) and Cartridge Expansion Modules (CEMs). The 
total physical capacity of the library depends on the number and type of modules 
installed and on the arrangement of the modules relative to the base and the other 
modules. This section outlines these relationships.

Note –  Physical capacity is not necessarily the same as usable 
capacity. The usable capacity of an SL500 library is the same as the 
activated capacity, the number of storage cells that your Hardware 
Activation Files make available. See “Capacity on 
Demand” on page 55 and “Hardware Activation Files” on page 97 
for a full explanation.

Extending Capacity

To extend the 50-cell base capacity, you add Drive Expansion Modules and Cartridge 
Expansion Modules to the standard rack until the desired number of storage cells and 
tape drives is reached. Each module type accommodates a different number of 
storage cells, drive bays, and CAP cells. The arrangement of the modules changes the 
internal geometry of the library and, consequently, the accessibility of storage cells.   

Loss of Active Cells

The lowest module in the library always has less capacity than an equivalent module 
placed higher in the rack. The library floor limits the robot’s range of motion and 
leaves the bottom-most cells inaccessible. In a basic library that includes only the base 
module, 16 cells are inaccessible. When a Drive Expansion Module is installed in the 
lowest position, seven cells become inaccessible. A similarly placed Cartridge 
Expansion Module loses 16 cells when it is immediately below a base module or a 
Drive Expansion Module. But when the same Cartridge Expansion Module is 
immediately beneath another Cartridge Expansion Module, both modules lose 
capacity. The upper Cartridge Expansion Module loses six cells and the lower loses 
10, for a total of 16 inaccessible cells.

Tape drives can also keep the robot from reaching storage cells in some 
configurations. For example, when a Cartridge Expansion Module is installed below 
a base module or a Drive Expansion Module, the top two rows on columns nine, 10, 
and 11 of the Cartridge Expansion Module (six storage cells) become inaccessible. 

Increased Number of Active Cells

For the same reason, when you add an expansion module under an existing module, 
you increase the capacity of the existing module. For example, when you install a 
Cartridge Expansion Module or Drive Expansion Module under a base module, the 
robot can reach the very bottom of the module, so the base module gains 16 
previously inaccessible cells. Similarly, when you install a Cartridge Expansion 
Module under an existing Cartridge Expansion Module, the existing module gains 10 
storage cells. When you install a Drive Expansion Module under an existing Drive 
Expansion Module, the existing module gains seven cells. (Oracle does not 
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recommend installing DEMs under Cartridge Expansion Modules. Drive Expansion 
Modules should be installed above all of the Cartridge Expansion Modules in the 
stack). 

Number of CAPs

The type and arrangement of installed modules also determines the number of 
Cartridge Access Ports (CAPs) in the library and, therefore, the available storage 
capacity. A base module comes with five CAP cells (one magazine). Each Drive 
Expansion Module or Cartridge Expansion Module adds 10 CAP cells (two 
magazines). These CAP cells can store additional cartridges.

Real-World Capacity

Physical accessibility is not the only factor in determining the working capacity of a 
library. Real-world working capacity depends on the software that manages library 
operations. Different software applications have different capabilities and impose 
different limitations. Refer to your software documentation for specifics.

TABLE 1-2 on page 13 provides details on the number of cartridge and tape drive 
slots available with various combinations of SL500 modules. “SL500 Wall Diagrams 
and Specifications” on page 373 provides detailed diagrams and dimensions for 
various configurations.

TABLE 1-2  Physical LTO Storage Cell and Tape Drive Capacities 

Configuration DEMs CEMs  Tape Drives Storage Cells CAP Cells Total Cells 

Base 0 0 2 50 5 55

One expansion module 1 0 6 143 15 158

0 1 2 170 15 185

Two expansion modules 2 0 10 227 25 252

1 1 6 254 25 279

0 2 2 290 25 315

Three expansion modules 3 0 14 311 35 346

2 1 10 338 35 373

1 2 6 374 35 409

0 3 2 410 35 445

Four expansion modules 4 0 18 395 45 440

3 1 14 422 45 467

2 2 10 458 45 503

1 3 6 494 45 539

0 4 2 530 45 575
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Mixed-Media Library Configurations 

This section describes “Internal Addressing in Mixed-Media Libraries” on page 14 
and “Mixed-Media Library Configuration and Capacity” on page 14

Note – Your robotics unit must be part number 314558705 or 
higher to read SDLT cartridge labels.

Internal Addressing in Mixed-Media Libraries

Addressing is by library, module, row, and column, viewed from the front of the 
library. Each address consists of four integers, L,M,R,C, where: 

• The first digit, the Library number, is always 0.

• The second digit, the SL500 Module number, falls in the range [1-5], with 1 being 
the top-most module and 5 being the bottom-most.

• The third digit, the Row number, falls in the range [1-8] (for a base module) or 
[1-10] (for a Drive or Cartridge Expansion Module).

• The fourth digit, the Column number, falls in the range [1-9] (for a base module or 
Drive Expansion Module) or [1-11] (for a Cartridge Expansion Module).

Mixed-Media Library Configuration and Capacity

In a mixed-media configuration, the SL500 base module can store up to 42 cartridges, 
one or two tape drives, and a four-cell cartridge access port (CAP) that can also store 
cartridges. You increase this starting number of storage cells by adding Drive 
Expansion Modules and Cartridge Expansion Modules. The total physical capacity of 
the library depends on the number and type of modules installed and on the 
arrangement of the modules relative to the base and the other modules. This section 
outlines these relationships.

Note –  Physical capacity is not necessarily the same as usable 
capacity. The usable capacity of an SL500 library is the same as the 
activated capacity, the number of storage cells that your Hardware 
Activation Files make available. See “Capacity on 
Demand” on page 55 and “Hardware Activation Files” on page 97 
for a full explanation.

Extending Capacity

To extend this base, 42-cell capacity, you add Drive Expansion Modules and 
Cartridge Expansion Modules to the standard rack until the desired number of 
storage cells and tape drives is reached. The available physical capacity of a given 
library depends on the exact configuration chosen. Each module type accommodates 
a different number of storage cells, drive bays, and CAP cells. So the arrangement of 
the modules changes the internal geometry of the library and, consequently, the 
accessibility of storage cells.   

Loss of Active Cells

The lowest module in the library always has less capacity than an equivalent module 
placed higher in the rack. The library floor limits the robot’s range of motion and 
leaves the bottom-most cells inaccessible. In a basic library that includes only the base 
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module, 14 cells are inaccessible. When a Drive Expansion Module is installed in the 
lowest position, 7 cells become inaccessible. A similarly placed Cartridge Expansion 
Module loses 16 cells when it is immediately below a base module or a Drive 
Expansion Module. But when the same Cartridge Expansion Module is immediately 
beneath another Cartridge Expansion Module, both modules lose capacity. The upper 
module loses 6 cells and the lower loses 10, for a total of 16 inaccessible cells.

Tape drives can also keep the robot from reaching storage cells in some 
configurations. So for instance, when a Cartridge Expansion Module is installed 
below a base module or a Drive Expansion Module, the top two rows on columns 9, 
10, and 11 of the Cartridge Expansion Module (6 storage cells) become inaccessible. 

Increased Number of Active Cells

For the same reason, when you add an expansion module under an existing module, 
you increase the capacity of the existing module. For example, when you install a 
Cartridge Expansion Module or Drive Expansion Module under a base module, the 
robot can reach the very bottom the module, so the base module gains 14 previously 
inaccessible cells. Similarly, when you install a Cartridge Expansion Module under an 
existing Cartridge Expansion Module, the existing module gains 10 storage cells. 
When you install a Drive Expansion Module under an existing Drive Expansion 
Module, the existing module gains 7 cells. (Oracle does not recommend installing 
Drive Expansion Modules under Cartridge Expansion Modules. Drive Expansion 
Modules should be installed above all the Cartridge Expansion Modules in the stack). 

Number of CAPs

The type and arrangement of installed modules also determines the number of 
Cartridge Access Ports (CAPs) in the library and, thus, the available storage capacity. 
A base module comes with 4 CAP cells (one magazine). Each Drive Expansion 
Module or CEM adds 8 CAP cells (two magazines). These CAP cells can store 
additional cartridges.

Real-World Capacity

Physical accessibility is not the only factor in determining the working capacity of a 
library. Real-world working capacity depends on the software that manages library 
operations. Different software applications have different capabilities and impose 
different limitations. Refer to your software documentation for specifics.

TABLE 1-3 on page 15 details the number of cartridge and tape drive slots available 
with various combinations of SL500 modules. “SL500 Wall Diagrams and 
Specifications” on page 373 on page 373, contains detailed diagrams and dimensions 
for various configurations. 

TABLE 1-3  Physical Mixed-Media Storage Cell and Tape Drive Capacities 

Configuration DEMs CEMs  Tape Drives Storage Cells CAP Cells Total Cells 

Base 0 0 2 42 4 46

One expansion module 1 0 6 119 12 131

0 1 2 140 12 152
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Two expansion modules 2 0 10 189 20 209

1 1 6 210 20 230

0 2 2 240 20 260

Three expansion modules 3 0 14 259 28 287

2 1 10 280 28 308

1 2 6 310 28 338

0 3 2 340 28 368

Four expansion modules 4 0 18 329 36 365

3 1 14 350 36 386

2 2 10 380 36 416

1 3 6 410 36 446

0 4 2 440 36 476

TABLE 1-3  Physical Mixed-Media Storage Cell and Tape Drive Capacities 

Configuration DEMs CEMs  Tape Drives Storage Cells CAP Cells Total Cells 
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Library Components
This section describes the following components in greater detail:

• “Cartridge Access Ports” on page 17

• “Robotics” on page 17

• “Power Supplies” on page 19

• “Cooling Fans” on page 19

• “Library Controller Card (RLC)” on page 20

• “Single-Port Fibre Channel Interface Card (MPU2)” on page 21

• “Parallel SCSI Interface Card (RLW)” on page 21

Cartridge Access Ports

Using the cartridge access ports (CAPs), you can add or remove cartridges without 
interrupting normal robotic operation. 

Although the CAPs are not physically connected, they are logically connected. If any 
of the CAPs are open, the CAP LED on the keypad is ON. This light indicates the 
CAP needs to be closed. If all of the CAPs are closed, the CAP LED is OFF.

Use the keypad on the robotics unit to issue to unlock the CAP. 

The CAP has two settings, ALLOW and PREVENT. ALLOW is the default setting 
after you power-on or reset the library. TABLE 1-4 shows how these settings affect the 
CAPs. For CAP LED indicator information see “Library Components” on page 17.

Robotics

The robotics unit moves cartridges between storage cells, tape drives, and cartridge 
access ports (CAPs). FIGURE 1-5 on page 18 shows the three main robotic 
components:

• The Z drive assembly

• The X table assembly

TABLE 1-4  CAP Conditions

CAP Condition ALLOW PREVENT

All CAPs are 
closed

When you press the CAP 
button all of the CAPs in the 
rack open. The library firmware 
turns on the CAP LED.

When you press the CAP 
button, the action is ignored 
and all the CAPs remain 
closed.

A CAP is open When you press the CAP 
button, any CAP that is not 
open in the rack opens.

When you press the CAP 
button, the action is ignored 
and all the CAPs remain in 
their individual current state, 
open or closed.
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• The hand assembly

A pulley in the Z drive assembly moves the X table up and down until the table is 
positioned by the desired storage cell or tape drive. The X carriage assembly then 
moves the hand assembly back and forth as needed.

FIGURE 1-5  Robotics Components

.

1. Z drive assembly

2. Hand assembly

3. Keypad assembly

4. X table assembly

The Hand Assembly (FIGURE 1-6) contains the wrist hub, gripper, and bar-code 
scanner. Fingers on the gripper assembly grasp the sides of cartridges. 
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If the library loses power while a cartridge is between the fingers, an operator can 
manually retrieve the cartridge by using a worm gear to rotate the hand and a 
manual release screw to release the cartridge. 

FIGURE 1-6  Hand Assembly

1. Gripper

2. Bar-code scanner

3. Wrist hub

4. Finger release screw

When the front door is open or the keypad’s Open Door button is pressed, the library 
retracts the robotics assembly into the robotics unit at the top of the library and parks 
it until the library door is closed. This prevents damage to the robot.

To verify the robot is parked, look at the lever in the cutout beneath the facade and to 
the bottom left of the keypad. When the lever is on the left, the robot is safely parked.

The robotics unit can be accessed from the front of the rack.

Power Supplies

The base unit has one standard power supply. A second supply can be ordered and 
installed to provide redundant power to the module components. Each supply 
should be plugged into a separate circuit and powered-on to provide redundant 
power. If one supply fails, the second supply automatically provides power.

A single power switch on the back of the library is used to power-on or power-off all 
the power supplies in the rack:

• The ON position is 1.

• The OFF position is 0.

Cooling Fans 

The fans provide cooling for the library electronics. The tape drives and power 
supplies contain their own fans.
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Library Controller Card (RLC)

The library controller card (RLC):

• Stores library capacity information and tape volume serial numbers (VOLIDs)

• Manages the robotics

• Monitors fan performance, card temperatures, and the status of power supplies 
and tape drives

The face plate of the RLC card has a plastic thumb latch on each side with 
management interface connectors and indicator LEDs (Light-Emitting Diodes) in 
between. The interface connectors include the following, starting from the right side 
of the face plate: 

• RS232 serial port for the library CLI (Command Line Interface)

• Reserved port (for future use)

• Public Ethernet (TCP/IP) port for connecting with the SL Console host, an SNMP 
management station, and so on

• Private Ethernet (TCP/IP) port (also reserved for future use)

The library controller (RLC) card has the LED indicators shown in FIGURE 1-7 and 
listed in TABLE 1-5 on page 20.

FIGURE 1-7  RLC Library Controller Card LED Indicators

TABLE 1-5  RLC LED Indicator Descriptions

LED Color LED State Indicated Condition

EJECT OK Red On The RLC card can be removed if the library supports redundant, 
hot-swappable RLC cards.

FAULT Red Flashing The controller has detected a problem.

STANDBY Yellow On This redundant, hot-swappable RLC card is not actively 
controlling a library that supports redundant, hot-swappable 
RLC cards.

ACTIVE Green On This RLC card is controlling the library.



Library Components

SL500 Introduction   21 

Single-Port Fibre Channel Interface Card (MPU2)

The single-path MPU2 card provides a single Fibre Channel (FC) host interface 
adjacent to the thumb latch on the left side of the faceplate. FIGURE 1-8 shows the 
MPU2 card below the RLC.

Dual-Port Fibre Channel Interface Card (PUA2)

The PUA2 card shown in FIGURE 1-9 provides two Fibre Channel host interfaces on 
the right half of the card, between the FAULT and EJECT OK indicator LEDs. When 
the dual-path Fibre Channel option is activated, the additional interface can be used 
for increasing bandwidth or for redundancy. Failover requires suitable host software. 
Failover is not automatic.

Parallel SCSI Interface Card (RLW)

The RLW card (MPW on older libraries) provides a SCSI host interface adjacent to the 
thumb latch on the left side of the faceplate, below the RLC card as shown in 
FIGURE 1-10.

FIGURE 1-8  The MPU2 Fibre Channel Interface Card Below the RLC

FIGURE 1-9  PUA2 Dual-Path Fibre Channel Interface Card

FIGURE 1-10  The RLW (MPW) SCSI Interface Card Below the RLC
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Safety Features
The SL500 library has the following safety features: 

• The RLC card, the SCSI (MPW/RLW) or Fibre Channel (MPU2 or PUA2) interface 
card, and the power supply are housed inside protective modules to prevent you 
from coming into contact with hazardous voltages and sensitive electronics.

• Before opening the front door, library software protects the robot from damage by 
retracting it into the robotics unit and powering it off. Whenever the door is not 
fully closed, a sensor alerts the software so that the robot remains powered off.

• The front door is physically secured by lock and key to protect data. 

Tape Management Software
The tape management software controls tape read and write operations and robotic 
move operations. When the library is in automated mode, these operations occur 
without manual intervention. The software determines where the cartridge is located 
by accessing audit data uploaded from the library. The software then allocates the 
tape drive to receive the cartridge.

For command descriptions and instructions, refer to your software publications.
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2

StorageTek Library Console 

Oracle’s StorageTek Library Console (SL Console) is a Java-based software 
application that provides a graphical user interface (GUI) for monitoring and 
managing the StorageTek SL500 library. 

This chapter contains the following topics:

• “Using the SL Console” on page 23

• “SL Console Modes” on page 24

• “SL Console Security” on page 24

• “SL Console Reports” on page 28

• “Web-launched SL Console” on page 33

• “Standalone SL Console” on page 34

Using the SL Console
You can perform activities with the SL Console such as:

• Manage and configure library partitions (optional feature)

• View and modify status and properties of the library and associated devices 
(drives, CAP, robot)

• Perform an audit on all or part of the library

• Perform a self-test on the library or an associated device

• Perform a diagnostic move (exercise a robot)

• Locate a cartridge

• Move a cartridge from one location to another

• Display library logs

• Display error explanations

• Download new library firmware while the library is in operation

• Display context-sensitive help
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SL Console Modes
Depending on your needs, you can run the SL Console in any of the following 
modes. For details and procedures, see: 

• “Web-launched SL Console” on page 33 

• “Standalone SL Console” on page 34

SL Console Security
Security features built into the SL Console control both user authentication and user 
authorization. The security features include:

• User IDs: User IDs control user authentication. Each user must have a valid, active 
user ID and password to log in to the SL Console.

• Access permissions: Access permissions control user authorization. Each user ID is 
assigned a set of access permissions, which determine the types of requests the 
user can submit through the SL Console. For example, to modify the system 
properties of a drive, a user must log in with a user ID that has the proper access 
permissions.

When you log in to the SL Console with a valid user ID, password, and library name, 
the system authenticates your identity and then authorizes your access to the various 
SL Console functions. 

Note – Beginning with SL Console 4.50, passwords are limited to 
5 - 8 characters.

User IDs

To log in to the SL Console, you must have a valid, active user ID. Each user ID must 
be assigned a password.

There are a fixed set of user IDs at a site. The user IDs include:

• admin: customer administrator

• service: Oracle support representative

• oem: third-party field service technician

When you log in successfully, the SL Console displays your user ID in the status bar 
of the screen.

Any number of users can connect to a library through the standalone SL Console or 
Web-launched SL Console. 

Activation Password 

Before any users at your site can use the SL Console for the first time, your library 
administrator must activate the “admin” user ID with a special activation password. 
Your Oracle support representative provides your administrator with the activation 
password, which is valid for one-time use only. 
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After logging in with the activation password, the administrator must change the 
admin user ID password to ensure system security. 

Note – Beginning with SL Console 4.50, your password must be 
limited from 5 - 8 characters. Enter the first 8 characters of the 
initially assigned password. After initial login, you can change the 
password.

For details about this process, see the appropriate library Installation Guide.

Automatic Logout

Beginning with SL Console 5.8, after you have been logged in to the SL Console for 
six hour, your session will expire. The system then displays a dialog box where you 
can either log back in or log off.

You are allowed four attempts to login. If you are unable to login after four attempts, 
the system logs you out and displays the following message.

To log in, return to the main login screen.

SL Console Screen Display
The following TABLE 2-6 explain the components of the SL Console screen shown in 
FIGURE 2-13.

FIGURE 2-11  SL Console Session Time Out Dialog Box

FIGURE 2-12  SL Console Login Retry Message
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FIGURE 2-13  SL Console Screen Display

See TABLE 2-6 on page 26 for details.

TABLE 2-6  SL Console Component Description

Component Name Description

1 Menu bar: Includes the 
Tools Menu and the Help 
Menu 

Tools menu provides access to System Detail, Reports, Monitors, 
Utilities, Partitioning, User Management, and Log off functions. 

Help menu provides access to the table of contents of the help 
system. It also identifies the version of the SL Console in use.

2 Title bar Displays the title of the current screen

3 Function tabs Identifies the available functions for a screen

4 Options bar Location of buttons related to the screen (for example, Apply, 
Refresh, Print). Always includes the SL Console Help button (?). 
See “Synchronizing the Display With the Controller 
Database” on page 27 for details on using the Apply and Refresh 
buttons. 

5 Work area Location of the screen data
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Modifying the Screen Layout

Note – This feature is available starting with SL Console version 
3.30. It is available on selected screens only. 

You can modify the layout and display of selected SL Console screens as listed in  
TABLE 2-7. 

Synchronizing the Display With the Controller Database

Logging In

The SL Console gets all library configuration data from the library controller. 
Therefore, be careful when logging in to the SL Console before the library has fully 
initialized. You may see warnings that configuration data is not yet available. In such 
a case, you must exit and log in again at a later time. Additionally, if a library audit is 
performed as part of initialization, until the audit is complete, any configuration data 
displayed may not be completely up to date and accurate. 

Library Configuration Updates

When you first bring up an SL Console screen, the display reflects the most recently 
saved data from the library controller database. If you have changed the 
configuration in some way (such as taking a drive offline, or removing or adding a 
cartridge), it is important that you synchronize the status of the library with the SL 
Console screen.

6 Library health indicator Identifies the library to which the SL Console is connected, and 
displays a graphical representation of the library health

7 UserID indicator Displays the user ID currently logged in to the SL Console

8 Server communication 
health indicator

Displays a graphical heartbeat monitor indicating the state of 
server communication health

9 Navigation tree Lists the devices included in the library

TABLE 2-6  SL Console Component Description

Component Name Description

TABLE 2-7  SL Console Display Options

Display Option Instructions

Sort the display by 
any column

Click the heading of the column you want to sort by. Initially 
the sort is in ascending order. Click the heading again to 
switch between ascending and descending order.

Arrange the 
columns in any 
order

Click and drag a column heading horizontally to any 
position in the heading row. 

Resize the columns Click the border of the column heading and drag it left or 
right to change the column width. 



SL Console Reports

28   SL500 User’s Guide

If you are making major modifications to the library configuration (such as adding 
modules, defining partitions, etc.), you should coordinate these changes with other 
library users. Failure to do so could result in conflicts within the controller database. 

Apply Button

If you use the screen to modify the library contents or configuration, your changes do 
not update the controller database until you commit your changes by clicking the 
Apply button. Multiple users can access the library at the same time, using the SL 
Console or command line interface to make changes. Various host applications can 
also access the library to make their own changes to the library contents and 
configuration. 

Refresh Button

If other users make changes and apply them to the controller database, you will not 
see these changes until you click the Refresh button on your screen. If you have 
made changes to the library (such as removing a cartridge or taking a drive offline), 
the status of the library and its components will not be updated to the SL Console 
until you click Refresh. Using Refresh, you can select all of the library for 
synchronizing or one or more library components. 

SL Console Reports 
The SL Console library reports provide information on the library and its associated 
devices (for example, drives, robot, and CAPs), events, and tape cartridges. You can 
use the reports to monitor library activity and identify potential problems. In 
addition to displaying the reports on-screen, you can save the report data to a file, 
which you can then print or include in e-mail. 

All report output is a static display of information sent from the library controller at 
the time the report is generated. The SL Console does not update the information 
dynamically unless you explicitly select the Update button on the Options bar.

Note – Running multiple instances of the standalone SL Console 
or Web-launched SL Console on the same PC or workstation can 
cause problems such as inconsistent data on reports. It is 
recommended that only one user at a time produce SL Console 
reports on a PC or workstation, unless all instances of the SL 
Console are the same version.

Report Types

The SL Console provides the following types of reports:

• Log: Detailed system event logs

• Statistics: Statistical information on library operations 

• Status Detail: Details on the status of the library and associated devices, such as 
CAPs, drives, and robot

• Status Summary: Summary information on the status of the library and associated 
devices
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• Version: Details about library hardware and software versions

• Drive Distribution: Statistical summary of cartridge mount activity for a selected 
time period

• Drive Utilization: Statistical summary of cartridge mount activity for a selected 
time period, broken into regular time intervals

• Library Utilization: Statistical summary of library activity for a selected time 
period

Report Options Bar

The Options bar on each report allows you to perform the following functions:

• “Search a Library Report” on page 48.

• Update the report with current data.

• “Save Library Report Data to a File” on page 49.

Report Procedures

For report procedures, see “General SL Console Report Tasks” on page 46. 
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SL Console Help
The SL Console Help displays information for library operators, system 
programmers, system administrators, and service representatives. 

Note – The information relates only to the SL Console. For 
information about library hardware, tape drives, or host software, 
see the appropriate product publication.

FIGURE 2-14 shows a sample SL Console Help screen.

To display the SL Console Help from any SL Console screen, use either of the 
following methods: 

• To display context-sensitive help for the current SL Console screen, click the ? 
button in the Options bar. 

• To display general help information, click Help > Contents in the Menu bar. 

Navigating Help

The left panel of the SL Console Help screen displays either of the following:

• Table of contents (TOC): An outline of topics and subtopics

• Index: A list of terms and topics, in alphabetical order

The right panel displays the Help topic itself.

FIGURE 2-14  SL Console Help, Sample Screen
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The top of the SL Console Help window includes the navigation buttons shown in 
FIGURE 2-15 and described in TABLE 2-8 on page 31.
 

FIGURE 2-15  SL Console Help Navigation Buttons

See TABLE 2-8 for details.

TABLE 2-8  SL Console Help, Navigation Buttons

Button Meaning Action

1 Back Retraces your steps, going backward one topic at a time

2 Forward Retraces your steps, going forward one topic at a time

3 Print Displays the Print dialog box, which allows you to print one or more 
topics:

• To print the current topic, click the Print button.

• To print a different topic, click the topic title in the SL Console Help 
table of contents, and click the Print button.

• To print more than one topic, highlight the topics in the SL Console 
Help table of contents by pressing Shift-Click or Ctrl-Click, and then 
click the Print button. 
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Managing Favorite Topics

To save favorite topics, navigate to the topic you want to save. Click the Add to 
Favorites button shown in FIGURE 2-16. The topic will then display in the left-hand 
column as a topic. To delete a topic, select it. Then right-click to display the menu, 
and click Remove.

Tips for Using the SL Console Help

You can minimize, maximize, or resize the Help screen to accommodate your needs.

You can resize the left and right panels of the Help screen by clicking the border 
between them and dragging it left or right. 

4 Print Setup Displays the Page Setup dialog box, which allows you to modify your 
print page layout

5 Add Favorite Saves the currently displayed topic as a favorite topic. See the following 
“Managing Favorite Topics” on page 32 for more information.

6 TOC Displays the SL Console Help table of contents

7 Index Displays the SL Console Help index

8 Favorites List Displays list of favorite topics

9 Search Allows you to enter a term and search the contents for that term

TABLE 2-8  SL Console Help, Navigation Buttons

Button Meaning Action

FIGURE 2-16  Management Menu for Favorite Help Topics
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Most topics include a Related Topics button at the bottom of the page. Click on this 
button to display and navigate to help topics containing related information. 

Web-launched SL Console
The Web-launched SL Console is a standard feature of the library. It enables the SL 
Console to be installed on a centralized Web server. Individual clients can then use a 
supported Web browser to download the Web-launched SL Console. Using the Web-
launched SL Console you can connect to any library for which you have a valid user 
ID.

The Web-launched SL Console is delivered to clients as a Java Web Start process, 
which executes outside the browser. 

Security Considerations

The Web-launched SL Console software is digitally signed, which guarantees that it 
has been issued by Oracle Corporation and has not been altered or corrupted since it 
was created. As a Java Web Start process, the Web-launched SL Console includes the 
security features provided by the Java 2 platform.

You are responsible for implementing all appropriate additional security systems, 
including firewalls, user access, etc.

Client Requirements

You can download the Web-launched SL Console to clients meeting the requirements 
listed in the following TABLE 2-9.  

Web-launched SL Console Updates

Updates to the Web-launched SL Console only need to be installed on the centralized 
Web server. After the updates are installed on the server, they are downloaded 
automatically to all clients whenever the application is started on the client. 

TABLE 2-9  Web-launched SL Console Requirements

Platform Solaris 9: SPARC (Firefox 2.x)

Solaris 10: SPARC (Firefox 2.x)

Windows 2000: 32 bit (IE 5, IE 5.5, Firefox 2.x)

Windows XP: 32 bit (IE 6, IE 7, Firefox 2.x)

Windows Vista: 32 bit (IE 7, Firefox 2.x)

Other • Java 1.5 Plug-in (the browser will install this automatically if it 
is not present already)

• Ethernet connection to the library

• Ethernet connection to the Web-launched SL Console server 
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Starting the Web-launched SL Console on a Client

You can use either of the following methods to start and log in to the Web-launched 
SL Console on a client: 

• From a command line (Solaris only) or supported browser. See “Log in to the 
Web-launched SL Console” on page 38. 

• By double-clicking the slc.jnlp icon on your client. To use this method from a 
client, you must use the browser method at least once and save the slc.jnlp file 
locally. See “Log in to the Web-launched SL Console Using an Icon” on page 41. 

Standalone SL Console
The standalone SL Console is a standard feature of the StorageTek SL500 library. It 
enables you to run the SL Console application remotely from a PC or workstation 
that has a network connection to the library. Using the standalone SL Console, you 
can connect to any library for which you have a valid user ID. 

Security Considerations

The SL Console application interfaces with the primary library interface (PLI) over a 
secure sockets layer (SSL). SSL provides a secure communication path between the 
library and the customer’s SL Console session. This security prevents an 
unauthorized network user from monitoring library activity.

Installation Requirements

You can install the standalone SL Console on a computer meeting the requirements 
listed in the following TABLE 2-10: 

The standalone SL Console software is available for download at the Oracle Software 
Delivery Cloud, available at:

http://edelivery.oracle.com/ 

TABLE 2-10  Standalone SL Console Requirements

Platform Solaris 9: SPARC

Solaris 10: SPARC 

Windows 2000 Server: 32 bit

Windows XP Client: 32 bit 

Windows Vista: 32 bit

Other Ethernet connection to the library 
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Standalone SL Console Updates 

Note – Before you can install a new version of the standalone SL 
Console, you must uninstall the previous version. See your PC or 
workstation documentation for detailed instructions. Running 
multiple versions of the SL Console on the same PC or 
workstation can cause problems such as inconsistent data on 
reports. 

After you have uninstalled the previous version of the SL Console, see the following 
procedures for detailed instructions on upgrading the software.

• “Download the Standalone SL Console Media Pack” on page 51 

• “Install the Standalone SL Console” on page 52 
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SL Console Task Summary
SL Console tasks are divided into the following categories:

• “General SL Console Usage Tasks” on page 37

• “General SL Console Report Tasks” on page 46

• “Standalone SL Console Installation Tasks” on page 50
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General SL Console Usage Tasks
• “Log in to the Web-launched SL Console” on page 38

• “Log in to the Web-launched SL Console Using an Icon” on page 41

• “Log in to the Standalone SL Console” on page 43

• “Log Off the SL Console” on page 44

• “Change a User Password” on page 45
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▼ Log in to the Web-launched SL Console

Task Tool

This procedure can be performed at either of the following:

• Web browser

• Command line

Task Purpose

Log in to the SL Console.

On Windows 2000, you may need to install a Java plugin for your Web browser 
before performing this procedure. You can download the plugin from the following 
location: 
http://java.sun.com/products/archive/j2se/5.0_04/index.html 

On Solaris platforms, it is easier to log in to the Web-launched SL Console using the 
command line. If you prefer to log in using a Web browser, however, you need to 
download a recent version of the Firefox Web browser from the following location:  
www.mozilla.com

Note – Before you perform this activity, you must obtain the DNS 
alias or IP address of the SL Console server. Depending on how 
your Web-launched SL Console server has been set up, it may be 
accessible only by IP address. See your library administrator for 
assistance. 

Note – The command line option is available on Solaris platforms 
only. 

Task Steps

1. Choose your login method:

• Command line: Available on Solaris only. Proceed to Step 2. 

• Web browser: Available on either Windows or Solaris. Proceed to Step 3. 

2. Open a terminal window, and type the following command:

javaws http://server_ID:port_ID/opel/slc.jnlp 

where:

• server_ID: Either of the following:

• IP address of the SL Console server 

• DNS alias of the SL Console server

• port_ID: Port ID of the SL Console application, typically 8080 

• opel: The name (context root) of the Web-launched SL Console application on 
the server. 

Proceed to Step 4. 
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3. Start a supported Web browser on your client PC or workstation (see “Client 
Requirements” on page 33 for a list of supported browsers), and in the Location 
Bar or Address field, enter the URL of the SL Console Web Start application: 

http://server_ID:port_ID/opel

where:

• server_ID: Either of the following:

• IP address of the SL Console server 

• DNS alias of the SL Console server

• port_ID: Port ID of the SL Console application, typically 8080 

• opel: The name (context root) of the Web-launched SL Console application on 
the server. 

Note – You can bookmark this URL for future logins. 

The SL Console Launch screen appears. 

4. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates download automatically. 

The Opening slc.jnlp dialog box appears. 

5. Complete the dialog box as follows:

a. Specify the action you want to take with the slc.jnlp file:

• Click the Open with Java(TM) Web Start Launcher radio button if you 
want to start the SL Console directly. 

• Click the Save to Disk radio button if you want to save the slc.jnlp file 
to your client and log in to the SL Console later. See “Log in to the Web-
launched SL Console Using an Icon” on page 41 for login instructions. 

b. Optionally click the “Do this automatically for files like this from now on” 
check box. If you make this selection, this message will not appear during 
future logins. 

c. Click OK. 

If this is the first time you are running the Web-launched SL Console, a digital 
signature warning dialog box appears. 

6. Complete the dialog box as follows:

a. Verify the Publisher. 

b. Optionally click the “Always trust content from the publisher” check box. If 
you make this selection, this dialog box will not appear during future logins. 

c. Click Run.

The SL Console Login screen appears. 
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7. Enter your login information, and click Log on.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

• SLC_login: SL Console user ID.

• password: Password assigned to this user ID. (Password must be between 5-8 
characters.)

• library_ID: Library to which you want to connect, expressed in either of the 
following ways:

• IP address of the library 

• DNS alias of the library

Note – Beginning with SL Console 4.50, your password must be 
limited from 5 - 8 characters. Enter the first 8 characters of the 
initially assigned password. After initial login, you can change the 
password.

Note – The user ID you use determines the screens you can 
access. See “SL Console Security” on page 24. 
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▼ Log in to the Web-launched SL Console Using an Icon

Task Tool

This procedure can be performed at your client.

Task Purpose

Log in to the SL Console.

Note – To perform this activity, you must first save the Web-
launched SL Console slc.jnlp file to your client. See “Log in to 
the Web-launched SL Console” on page 38 for details. 

Task Steps

1. Double-click the slc.jnlp desktop icon on your client. 

The Web Start process retrieves the Web-launched SL Console application from the 
server. Any updates are downloaded automatically. 

The SL Console Launch screen appears. 

2. Click Launch Now.

The Web Start process retrieves the Web-launched SL Console application from 
the server. Any updates download automatically. 

If this is the first time you are running the Web-launched SL Console, a security 
warning dialog box appears. 

3. Complete the dialog box as follows:

a. Verify the Publisher is Oracle Corporation.

b. Optionally click the “Always trust content from the publisher” check box. If 
you make this selection, this dialog box will not appear during future logins. 

c. Click Run.

The SL Console Login screen appears. 

4. Enter your login information, and click Log on.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

• SLC_login: SL Console user ID.

• password: Password assigned to this user ID. (Password must be between 5-8 
characters.)

• library_ID: Library to which you want to connect, expressed in either of the 
following ways:

• IP address of the library 

• DNS alias of the library
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Note – Beginning with SL Console 4.50, your password must be 
limited from 5 - 8 characters.

Note – The user ID you use determines the screens you can 
access. See “SL Console Security” on page 24. 
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▼ Log in to the Standalone SL Console 

Task Tool

This procedure can be performed at your client.

Task Purpose

Log in to the SL Console.

Task Steps

1. Start the SL Console application on your PC or workstation by doing either of 
the following:

• Double-click the SL Console icon on the desktop.

• Select Start > RunSLConsole or Launch > RunSLConsole.

The SL Console starts, and the Login screen appears. 

2. Enter your login information.

User ID: SLC_login  
Password: password  
Library: library_ID 

where:

• SLC_login: SL Console user ID.

• password: Password assigned to this user ID. (Password must be between 5-8 
characters.)

• library_ID: Library to which you want to connect, expressed in either of the 
following ways:

• IP address of the library 

• DNS alias of the library

Note – Beginning with SL Console 4.50, your password must be 
limited from  5 - 8 characters.

Note – The user ID you use determines the screens you can 
access. See “SL Console Security” on page 24. 

3. Click Log on. 
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▼ Log Off the SL Console

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Log off the SL Console.

Note – Before you log off, make sure all operations for the current 
SL Console session have completed (for example, code loads, 
audits, diagnostic moves). 

Task Steps

1. From any SL Console screen, select Tools > Log Off.

The Confirm message appears. 

Note – To remain logged in to the SL Console, click Cancel. You 
are returned to the originating screen without logging off. 

2. Click OK. 

You are logged off the SL Console, and the Login screen appears. 

3. Click Exit to close the SL Console.
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▼ Change a User Password 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to change the password for a user account. 

Task Steps

1. Log in to the SL Console using any of the modes available to you (Web-
launched SL Console or standalone SL Console). You must log in using the user 
account you want to modify.

2. Select Tools > User Mgmt.

The User Management page appears. 

3. On the navigation tree, expand the Permanent folder, and select the user 
account you want to modify (the user account you are logged in as). 

Detailed information for the user account is displayed. 

4. Complete the following fields: Current Password, New Password, and 
Retype Password. 

5. Click Modify.

The password for the account updates. 
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General SL Console Report Tasks
• “Display a Library Report” on page 47

• “Search a Library Report” on page 48

• “Save Library Report Data to a File” on page 49
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▼ Display a Library Report

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display library reports available from the Tools > Reports 
menu.

Note – All report output is a static display of information sent 
from the library controller at the time the report is generated. The 
SL Console does not update the information dynamically unless 
you explicitly select the Update button in the upper right corner.

If you want to search the report data or save it to a file, see the following procedures:

• “Search a Library Report” on page 48 

• “Save Library Report Data to a File” on page 49

Additional reports are available from the following menus:

• Tools > Partitions 

Task Steps

1. Select Tools > Reports. 

The reports Display page appears. All library report options are listed in the 
navigation bar.

2. In the navigation tree, expand a report category to see the report options.

3. Click the report you want to display. 

The selected report displays. 
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▼ Search a Library Report 

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to search a library report for a specified text string. This procedure 
can be performed on any of the library report screens.

Task Steps

1. Select Tools > Reports. 

The reports Display page appears. All library report options are listed in the 
navigation bar.

2. In the navigation tree, expand a report category to see the report options.

3. Click the report you want to display. 

The specified report displays. All report screens include the Search button.

4. Click Search. 

The Search Text dialog box appears. 

5. Enter the text string you want to search for, and click Search. 

Note – The search is case-sensitive, and wildcards are not 
supported. 

6. The Search Results message appears, displaying the number of occurrences of 
the text string. All instances of the text string in the report are highlighted. 

7. Click OK to dismiss the message. 
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▼ Save Library Report Data to a File

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display a library report and save the data to a file. This 
procedure can be performed from any of the library report screens.

After the file is saved, you can print it or include it in e-mail. This may be useful for 
communicating about library issues with your Oracle support representative.

Task Steps

1. Select Tools > Reports. 

The reports Display page appears. All library report options are listed in the 
navigation bar.

2. In the navigation tree, expand a report category to see the report options.

3. Click the report you want to display. 

The specified report displays. All report screens include the Save button.

4. Click Save. 

The Save dialog box appears. 

5. Browse to the directory where you want to save the file. In the File Name field, 
you can accept the default entry or enter a different file name. 

6. In the Files of Type list, select the format in which you want to save the data 
(HTML, Text, XML). 

7. Click Save. 

The data is saved to the specified file. 

Note – If the file exists already, a message appears to prompt you 
whether you want to replace the file. 
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Standalone SL Console Installation Tasks 
• “Download the Standalone SL Console Media Pack” on page 51

• “Install the Standalone SL Console” on page 52
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▼ Download the Standalone SL Console Media Pack

Task Tool

This procedure can be performed at the Web browser.

Task Purpose

Use this procedure to download and extract the current SL Console Media Pack from 
the Oracle Software Delivery Cloud. The Media Pack includes the Web-launched SL 
Console server, as well as the Web-launched SL Console client and the standalone SL 
Console. 

Note – Your Oracle support representative may have performed 
this procedure for you during library installation.

Task Steps

1. Launch a Web browser on your PC or workstation and navigate to the Oracle 
Software Delivery Cloud at the following URL: 

http://edelivery.oracle.com/ 

2. Click Continue. 

3. On the Export Validation screen, make the following entries:

• Enter your contact information.

• Read the License Agreement and Export Restrictions, and click the check boxes 
to indicate your acceptance. 

• Click Continue. 

4. On the Media Pack Search screen, make the following selections: 

• In the Select a Product Pack list, select Oracle StorageTek Products. 

• In the Platform list, select Generic Platform. 

• Click Go. 

5. All media packs meeting your selection criteria are displayed in the Results 
section of the screen. Select the SL Console version you want to download. 
Click Continue. 

6. On the specific media pack screen, review the information to verify that you 
have selected the correct media pack. Click Download. 

7. In the dialog box, click Save File to save the media pack to your PC or 
workstation. Click OK. 

Note – This process may take several minutes.

8. To complete the installation, see “Install the Standalone SL 
Console” on page 52. 
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▼ Install the Standalone SL Console 

Task Tool

This procedure can be performed at the client.

Task Purpose

Use this procedure to install the standalone SL Console on your PC or workstation. 

Note – Your Oracle support representative may have performed 
this procedure for you during library installation.

Note – Prior to using this procedure, you must have downloaded 
and extracted the standalone SL Console media pack to your PC 
or workstation. See “Download the Standalone SL Console Media 
Pack” on page 51. 

Task Steps

1. On your PC or workstation, change to the directory where you saved the 
standalone SL Console media pack and expand the archive file. 

2. Open the Install folder. 

3. Open the SL Console installer file that is appropriate for your operating system. 

The installation wizard begins and the Introduction screen appears.

Note – At any time during the installation wizard, you can click 
Cancel to cancel the installation or Previous to return to the 
previous screen and re-enter information. 

4. Review the information, and click Next. 

The Choose Install Folder screen appears. 

5. Specify where you want to install the SL Console program. You can accept the 
default location displayed, or you can click Choose to browse to a different 
directory. Click Next to continue. 

The Choose Shortcut Folder screen appears. 

6. Enter the location where you want to create the SL Console shortcut icons. You 
can accept the default location displayed, or you can click one of the other 
choices listed and specify a different location. Click Next to continue. 

On Solaris, the default location for shortcuts is the user’s home directory. 
However, shortcuts cannot be created in the root directory (/), which is the root 
user’s home, so if you are installing on a Solaris platform as root you must 
choose something other than the default location. In this case, we recommend that 
you choose /usr/bin or a similar location. 

When you click Next, the Pre-Installation Summary screen appears.

7. Review the information and verify that it is all correct. Click Install to continue. 

The installation begins, and the Installing SL Console screen appears. 

8. When the installation finishes, the Install Complete screen appears. 
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9. Review the information and click Done to exit the installation program. 
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3

Capacity on Demand

The SL500 library includes the Capacity on Demand feature. Capacity on Demand separates physical 
capacity from activated capacity, and allows you to pay only for the capacity you need. 

Physical storage capacity is the amount of storage cell hardware installed.

Activated capacity is the number of storage cells that have been activated for use. This cannot exceed 
the physical capacity.

As your needs grow, you can add modules and activate the portion that you need. To expand capacity 
within a module, you need only purchase and install a hardware activation file for the new capacity, 
and then reboot the library.

Note – Starting with SL500 firmware version 1300 and SL Console version 4.00, 
storage capacity upgrades must be installed through the SL500 hardware activation 
utility. See “Hardware Activation Files” on page 61 for details. 

Note – This feature controls cartridge storage cells only. All installed tape drives are 
available by default. All cells in CAPs configured for enter and eject operations are 
available if the module containing the CAP has any activated storage cells 

Capacity on Demand Features and Restrictions
This section describes important features and restrictions of Capacity on Demand that will help you to 
plan for and use the feature in your SL500 library. 

• Only activated storage cells can be used for tape cartridge storage. Unactivated storage cells cannot 
be used for cartridge storage, nor can they be accessed by any hosts. 

• The minimum activated capacity is 30 storage cells for LTO-only libraries, and 24 storage cells for 
mixed-media libraries. This is identified as a LimitedBase activation key. 

• You can purchase additional activated capacity in the following increments:

• FullBase: Activates all storage cells in the Base Module. 

• FullDEM: Activates all storage cells in a Drive Expansion Module (DEM). 

• ThirdDEM: Activates one-third of the storage cells in a DEM. To activate two-thirds of a DEM, 
you would install two ThirdDEM hardware activation files. To activate all of a DEM, you could 
install three ThirdDEM hardware activation files or one FullDEM activation file. 

• FullCEM: Activates all storage cells in a Cartridge Expansion Module (CEM).
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• After installing additional activated capacity, you need to reboot the library. Once verified by the 
library controller, the additional storage cells are available for use. 

• Storage capacity is incremental. Total activated capacity is equal to the sum of the capacities 
specified in each hardware activation file installed and activated on the library.

• The order that capacity activation files are installed is not significant (that is, it does not need to 
match the order of the modules in the SL500 frame). 

Planning Library Capacity

The SL500 does not support gaps in activated capacity; all storage cells must be contiguous. You can 
begin adding activated capacity to a module only if the module directly above it is activated at full 
capacity. 

Deleting a Capacity activate for a module in the middle of a library will cause the modules below it to 
be unavailable. 

Note – CEMs must be at the bottom of any SL500 configuration. A CEM cannot be 
installed between a Base Module and a DEM. 

LTO-Activated Capacity by Module

The following table shows capacity of different configurations for LTO. All capacities assume no 
reserved cells and all CAPs are configured for enter and eject operations.

Example: Base Module + DEM

The Base Module must be activated at full capacity before you can 
begin adding activated capacity to the DEM.

Example: Base Module + DEM + CEM + CEM

Removing any portion of the DEM capacity will make both CEMs 
unavailable.

TABLE 3-1  LTO Activated Capacity by Module

 Module Configuration Hardware Activation Key
Module-Activated 

Capacity

Base Shipped standard LimitedBase 30

At last module FullBase 50

With any module underneath FullBase 66

DEM As last module ThirdDem (increments 
of 26, 26, 25)

77

With any module underneath ThirdDem (increments 
of 28, 28, 28)

84
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Mixed Media-Activated Capacity by Module

The following table shows capacity of different configurations for mixed media. All capacities assume 
no reserved cells and all CAPs are configured for enter and eject operations.

Cell Assignment Rules

The library controller uses the following rules when filling activated storage cells with cartridges: 

• All cells in column 1 are filled first, then the cells in column 2, then 3, and so on. 

• Cells within each column are filled from top to bottom, starting with the first row after any reserved 
cells. For example, if the top three cells in a column are reserved, cell assignment within the column 
starts with row 4. 

• Once all cells within a module are filled, cell assignment moves to the next module, using the same 
top-to-bottom, column by column approach. 

In partitioned libraries, the library controller applies these rules separately to each partition. 

CEM after Base 
Module or DEM

As last module FULLCEM 104

With any module underneath FULLCEM 114

CEM after CEM As last module FULLCEM 110

With any module underneath FULLCEM 120

TABLE 3-2  Mixed Media-Activated Capacity by Module

 Module Configuration Hardware Activation Key
Module-Activated 

Capacity

Base Shipped standard LimitedBase 24

At last module FullBase 42

With any module underneath FullBase 56

DEM As last module ThirdDem (increments 
of 21, 21, 21)

63

With any module underneath ThirdDem (increments 
of 24, 23, 23)

70

CEM after Base 
Module or DEM

As last module FULLCEM 84

With any module underneath FULLCEM 94

CEM after CEM As last module FULLCEM 90

With any module underneath FULLCEM 110

TABLE 3-1  LTO Activated Capacity by Module

 Module Configuration Hardware Activation Key
Module-Activated 

Capacity
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Orphaned Cartridges in Non-Partitioned Libraries

Note – For a discussion of orphaned cartridges in partitioned libraries, see 
“Orphaned Cartridges in Partitioned Libraries” on page 107. 

In non-partitioned libraries, an orphaned cartridge is a cartridge located in an unactivated storage cell. 
Orphaned cartridges are inaccessible to all hosts. 

A cartridge can become orphaned for a variety of reasons. Following are some possible causes:

• Activated storage capacity has been reduced.

• The cartridge has been moved to an unactivated or inaccessible cell through manual intervention. 

Implementing Changes to Activated Capacity 

Increasing Activated Capacity

The following are special considerations for installing new activated storage capacity. 

• See “Hardware Activation File Installation Process” on page 63 for details on purchasing and 
installing a Capacity activation file. 

• If the new activated capacity exceeds the physical capacity, no corrective action is necessary. 
Physical cells that cannot be activated due to capacity limits will be activated later whenever 
additional capacity activation files are installed. 

• You must configure all affected library host applications to recognize the new activated storage 
cells. See “Host Notification of Capacity Changes” on page 59 for details. 

• In non-partitioned libraries, all newly activated cells are immediately available for use. 

• In partitioned libraries, all newly activated cells are added as “unallocated,” and are therefore not 
available for use. You must manually allocate the new cells to partitions before the cells can be used 
for cartridge storage. See “Partition Configuration Tasks” on page 116 for detailed instructions. 

Decreasing Activated Capacity

Following are special considerations for deleting activated storage capacity. 

Caution – Deleting activated capacity is an exceptional situation; use caution when 
doing so. 

• See “Delete a Hardware Activation File” on page 76 for details on deleting activated capacity. 

• Storage cells corresponding to the reduced capacity will become inaccessible, and any cartridges 
within those cells will be orphaned. No checks are made to identify cartridges that will be 
orphaned. See “Orphaned Cartridges in Non-Partitioned Libraries” on page 58 for details. 

• You must configure all affected library host applications to recognize the activated storage cell 
changes. See “Host Notification of Capacity Changes” on page 59 for details. 

• For partitioned libraries:

• The total number of storage cells allocated to all library partitions cannot exceed the activated 
capacity of the library. 
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Caution – You must manually de-allocate cells from partitions so the total allocation 
does not exceed the new activated capacity.

• If, after capacity has been decreased, the total number of cells allocated to all partitions is still 
less than the new activated capacity, you do not need to reconfigure the partitions. 

Host Notification of Capacity Changes 

When storage capacity is added or removed, the library controller notifies all affected hosts according 
to their interface requirements. SCSI hosts are notified by a “Mode Parameters Changed” unit 
attention. The host must re-audit the library to determine the specific configuration changes. See the 
appropriate tape management software documentation for detailed procedures and commands.
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4

Hardware Activation Files 

Note – This feature is available starting with SL500 firmware 
version 1409 and SL Console version 4.75.

This chapter explains how to activate optional features on the SL500 tape library. It 
begins with a brief list of the “Customer-Activated Features” on page 61 and an 
overview of “Oracle Hardware Activation Files” on page 61. It then provides:

• An overview of the “Hardware Activation File Installation Process” on page 63

• “Hardware Activation Tasks” on page 64

• A “Hardware Activation Screen Reference” on page 73

Customer-Activated Features
The hardware activation utility enables you to activate and monitor selected optional 
features on the SL500 library. Some library features are activated by the customer, 
while other must be installed and enabled by an Oracle support representative. 
Features you can activate include:

• Capacity Upgrades (Full Base, Full DEM, Third DEM, Full CEM) 

• Multi Port Fibre Channel (MultiPortFibre)

• Partitioning

The functions described in this chapter can be performed from the standalone SL 
Console or Web-launched SL Console only.

Oracle Hardware Activation Files
Selected SL500 features are activated through an Oracle hardware activation file. This 
activation file is a digitally signed image (.img) file containing a feature activation 
key. You install one hardware activation file for each feature you have purchased. 
When you install a new hardware activation file, the included feature is added to the 
ones already activated on the library. SL500 activation keys do not expire. 
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Downloading Oracle Hardware Activation Files

Download Oracle hardware activation files from the Oracle Software Delivery Cloud 
at: 

http://edelivery.oracle.com 

Legacy Hardware Activation Files

For SL500 libraries prior to version 1409, hardware activation files were delivered via 
e-mail from Oracle Corporation. This distribution system has been replaced by the 
Oracle hardware activation files described in this chapter. When you upgrade to 
SL500 firmware version 1409,all features that have already been activated on the 
library are retained. 

After the library is upgraded to SL500 firmware version 1409, use the processes 
described in this chapter to activate any new features. See “Hardware Activation File 
Installation Process” on page 63 for a summary of the process. 

Note – If your SL500 library is running firmware prior to 
version 1409, features are still delivered to you by e-mail from 
Oracle Corporation.

Legacy hardware activation files are assigned a unique sequence number to ensure 
that only one instance of a hardware activation file can be installed on a library at a 
time. 
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Hardware Activation File Installation Process
To activate library features, perform the following tasks. 

1. Purchase a feature for an Oracle StorageTek library from Oracle Corporation.

2. Locate the hardware activation file for the feature on the Oracle Software 
Delivery Cloud and download it to a system accessible to your StorageTek 
Library Console (SL Console) session.

3. Download the code using the SL Console.

4. Reboot the library to activate the new features.

5. Use the SL Console to display and verify the features on the target library.

6. To configure newly activated capacity or partitioning, see the following:

• For partitioned libraries, see “Library Partitioning” on page 83

• For non-partitioned libraries, see:

• “Capacity on Demand” on page 55

• “Configuring Bridging Without Partitioning” on page 217

Note – The functions described in this chapter can be performed 
from the standalone SL Console or Web-launched SL Console only.
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Hardware Activation Tasks
• “Download a New Hardware Activation File” on page 65

• “Install a New Hardware Activation File on the Target Library” on page 67

• “Display Current Hardware Activation Files” on page 69

• “Delete a Hardware Activation File” on page 70

• “Display the Feature Audit Log” on page 72
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▼Download a New Hardware Activation File

Task Tool

This procedure can be performed at a Web browser.

Task Purpose

Use this procedure to download a new hardware activation file for the library.

Task Steps

1. Start a Web browser on your PC or workstation, and navigate to the Oracle 
Software Delivery Cloud at the following URL:

http://edelivery.oracle.com/ 

2. Click Sign In / Register.

3. When the Export Validation screen appears, read the instructions.

4. On the Export Validation screen, enter your full name, company name, and 
e-mail address in the text fields. Select a country from the list.

5. While still on the Export Validation screen, read the Notice.

6. In the Electronic Delivery Trial License Agreement section, read the agreement 
and terms. Then check the YES check box to agree to the terms of your license.

7. While still on the Export Validation screen, read the Export Restrictions. Check 
the corresponding YES check box to accept the restrictions.

8. Click the Continue button to move from the Export Validation screen to the 
Media Pack Search screen.

9. In the Select a Product Pack list of the Media Pack Search screen, select Oracle 
StorageTek Products. 

10. Click Go. 

The Media Pack Search screen refreshes. In the Results section of the screen, a list 
of media packs meeting your selection criteria replaces the *** No search 
conducted *** notice. 

11. In the Select a Product Pack list of the Media Pack Search screen, use the 
Platform list, and select Generic Platform.

12. Click the Select radio button that corresponds to the SL500 media pack that you 
want to download, and click the Continue button. 

13. When download screen for the selected media pack appears, review the 
information to verify that you have selected the correct media pack. Click the 
Readme button to review the readme file.

14. If this is not the correct software, use the Back and/or Search Again buttons to 
return to the search screen.

15. After verifying you have chosen the correct software, click the Download 
button beside each desired feature. 



Hardware Activation Tasks

66   SL500 User’s Guide

16. The actual number, names, part numbers, and file sizes for SL500 Hardware 
Activation files may differ from the values shown in these examples.

17. When the download dialog appears, select the Save File radio button, and click 
OK.

18. When the Enter name of file to save to dialog appears, browse to the local 
directory that will hold the download file, and click Save. 

The file is large and may take some time to download, depending on your 
connection speed.

19. On the download screen for the media pack, click View Digest to view the MD5 
and/or SHA-1 digests of the download files. 

Files can be corrupted during long downloads over a network. A digest is a 
hexadecimal number that represents the contents of the file and enables you to 
verify the integrity of the download.

20. Compute your own digest of the downloaded media pack using the appropriate 
commandline utility.

For example, on Oracle’s Solaris, you could use the digest command:

# /usr/bin/digest -a sha1 download.zip  
9498a4f5303d056ad3ecae826b59f41448d63790

21.  To verify the integrity of your download, compare your computed digest with 
the digest displayed by the View Digest button on the download page. They 
should be identical.

22. If the digest values are not identical, the download file has been corrupted 
during download. Discard it and repeat the download process.

23. If the digests match, use the extraction utility appropriate for your operating 
system (gunzip, pkunzip, etc.) to extract the media pack to a location that you 
can reach from a StorageTek Library Console (SL Console) session. 
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▼ Install a New Hardware Activation File on the Target Library

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To install a new hardware activation file on a target library, follow this procedure 
using the StorageTek Library Console (SL Console).

Before performing this procedure, download a new hardware activation file to a 
system accessible to the SL Console session. See “Download a New Hardware 
Activation File” on page 65. 

Task Steps

1. Use the SL Console to log in to the target library. 

See “General SL Console Usage Tasks” on page 37 for details. 

2. Select Tools > Hardware Activation, and select the Install Hardware Activation 
Keys tab. 

The Install Hardware Activation Keys page appears. 

3. In the File Name field, enter the full path of the hardware activation file you 
want to install, and click Enter. Optionally, click Browse and navigate to the file 
location.

The Hardware Activation File Details display in the lower part of the page. 

4. Review the hardware activation file details, and then click the Install... button 
in the upper right corner. 

The Activation File Installation Confirmation message appears. 

5. Click Yes to begin installing the activation file on the target library. 

The library controller installs the hardware activation file, and a confirmation 
message appears. 

6. Click OK to dismiss the message. 

7. Reboot the library to activate the new activation file features. Click Reboot in 
the upper right corner.

See “Download Code to the Library Controller” on page 344 for detailed 
instructions. 

8. You can verify that the activation file has been installed and activated 
successfully by displaying the current activation files. See “Display Current 
Hardware Activation Files” on page 69 for details. 

Depending on the features included in the hardware activation file, you may need 
to perform additional tasks to use the new features. 



Hardware Activation Tasks

68   SL500 User’s Guide

• See “Increasing Activated Capacity” on page 58 and “Decreasing Activated 
Capacity” on page 58 for special considerations that apply when you install a 
hardware activation file that adds activated capacity to the library.
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▼Display Current Hardware Activation Files 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To display the features currently activated on a target library, perform this procedure 
using the StorageTek Library Console (SL Console).

Task Steps

1. Select Tools > Hardware Activation, and click the Current Hardware Activation 
Keys tab. 

The Current Activation Keys page appears, listing the currently activated 
features.

Note – If a feature has been installed but the library has not yet 
been rebooted, the Enabled column will indicate “No.” The 
library must be rebooted for the feature to be activated. 

See “Hardware Activation > Current Hardware Activation Keys” on page 74 for 
detailed information about the fields. 
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▼Delete a Hardware Activation File 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To delete a hardware activation file from a target library, complete this procedure 
using the StorageTek Library Console (SL Console).

Caution – Deleting a hardware activation file is an exceptional 
situation. Be sure you want to do this before you begin this 
procedure. Having extra hardware activation files installed on a 
library does not present any problems (for example, capacity 
activation files that exceed the physical capacity of the library). The 
extra activation files are simply not used. 

Caution – Capacity reduction. Deleting a capacity hardware 
activation file reduces the activated capacity of the affected library 
module. This can result in orphaned cartridges. See “Decreasing 
Activated Capacity” on page 58 and “Orphaned Cartridges in Non-
Partitioned Libraries” on page 58 for details.

Caution – Partitioning feature removal. Deleting a partitioning 
hardware activation file deletes the partitioning feature from the 
library. See “Delete a Partition” on page 148 for details about the 
effects on the library configuration.

Task Steps

1. Use the SL Console to log in to the target library. 

See “General SL Console Usage Tasks” on page 34 for details. 

2. Select Tools > Hardware Activation, and click the Current Hardware Activation 
Keys tab.

3. Click the activation file you want to delete. 

Note – Sequence numbers 99000 and above indicate legacy 
hardware activation files that are permanently retained and 
cannot be deleted from the library.

The Delete... button activates.

4. Verify you have selected the correct activation file, and click the Delete button. 

A Delete Confirmation message appears. 

5. Click Yes to begin the deletion. 

The hardware activation file is deleted from the library, and the 
Current Hardware Activation Keys Summary section updates.
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6. Reboot the library in order for the activation file deletion to take effect. See 
“Download Code to the Library Controller” on page 344 for detailed 
instructions. 

7. Depending on the feature included in the hardware activation file, you may 
need to perform additional tasks after deleting the key. 

• See “Decreasing Activated Capacity” on page 58 for special considerations that 
apply when you delete a capacity hardware activation file.

• See “Delete a Partition” on page 148 for special considerations that apply when 
you delete a Partitioning hardware activation file.
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▼Display the Feature Audit Log 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display a list of all feature activation activity that has occurred 
over the life of the library. You can use this log to verify the validity of all features 
installed on the library. 

Note – This feature is available starting with SL500 firmware 
version 1409 and SL Console version 4.75. 

By default, the report is sorted in chronological order. Optionally, you can change the 
sort order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 27.

TTask Steps

1. Select Tools > Reports. 

2. Expand the Hardware Activation Audit Log folder, and click the Hardware 
Activation Audit Log tab. 

The Feature Audit Log appears. 

See “Reports > Feature Audit Log” on page 80 for detailed information about the 
fields
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Hardware Activation Screen Reference
This section includes detailed descriptions of all SL Console hardware activation file 
screens, arranged by screen navigation path.

For example, Hardware Activation > Install Hardware Activation Keys: indicates 
the screen accessed by clicking:

1. Tools

2. Hardware Activation tab

3. Install Hardware Activation Keys tab

Screens

• “Hardware Activation > Current Hardware Activation Keys” on page 74

• “Hardware Activation > Install Hardware Activation Keys” on page 77

• “Reports > Feature Audit Log” on page 80
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Hardware Activation > Current Hardware Activation Keys

Sample Screen 

Description

Displays the contents of all hardware activation files currently installed on the library 
you are logged in to. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 27 for details. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console
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Screen Fields

Current Hardware Activation Keys Summary

Feature 

Name of the feature activated on the library. 

Sequence Number 

Unique sequence number assigned to a legacy hardware activation file. 

Note – Sequence numbers 99000 and above indicate legacy 
hardware activation files that are permanently retained and 
cannot be deleted from the library.

Value 

Qualification for the feature, if applicable. For example, for the Capacity feature, 
this field displays the capacity the activation file provides, such as full CEM, one-
third DEM, etc. Depending on the feature, the field may be blank or indicate 
“None.” 

Enabled

Indicates whether the feature is currently activated on the library. Options are:

• Yes: Feature has been activated. 

• No: Feature has been installed, but not activated. You must reboot the library 
in order for the feature to be activated. 

Associated Module Capacity Activation Detail 

Module Number

Numeric module ID. Possible values are 1–5. 

Capacity

Total module capacity that has been activated for use. Possible values are:

• Full Capacity: All storage cells in the module are activated for use. 

• None: No storage cells in the module have been activated for use. May also 
indicate that the module is not installed in the library. 

• 1/3 Capacity: One-third of the storage cells in the module have been activated. 
Applies only to the DEM. 

• 2/3 Capacity: Two-thirds of the storage cells in the module have been 
activated. Applies only to the DEM.

Sequence Number

Note – This field applies to legacy hardware activation files only.
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Hardware activation file sequence numbers used in providing the indicated 
capacity. If more than one hardware activation file is involved, the sequence 
numbers are separated by commas. 

The numbers 000 indicate no hardware activation file has been installed for the 
module. 

Cells Activated 

Total number of storage cells in the library that have been activated for use. This 
cannot be greater than the physical capacity of the library. 

Cells Not Activated

Total number of storage cells in the library that have not been activated for use. 

Total Number Of Cells

Total physical capacity of the library. 

Buttons

Reboot

Click to reboot the library.

Delete

Click to delete the selected hardware activation file from the library. 

Refresh

Click to refresh the display with current data from the library controller database.

? (Help) 

Click to display online help for the screen. 

See Also

“Hardware Activation > Install Hardware Activation Keys” on page 77 
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Hardware Activation > Install Hardware Activation Keys

Sample Screen 

Description

Enables you to display the contents of a new hardware activation file and install it on 
the library. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 27 for details. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

File Name

Required.
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Enter the full path of the hardware activation file you want to install on the 
library. Optionally, you can click Browse and navigate to the file location. The file 
must be located on a system accessible to the SL Console session. 

Product

Display only.

Type of library. For example, SL8500, SL3000 or SL500. 

Serial Number

Display only.

Serial number of the library the hardware activation file is for. This entry applies 
only to legacy hardware activation files. See “Legacy Hardware Activation 
Files” on page 62 for details. 

Key Type

Display only.

Type of hardware. Options are:

• Oracle Hardware Activation File: File downloaded from the Oracle Software 
Delivery Cloud. 

• Sun Hardware Activation File: Legacy file. See “Legacy Hardware Activation 
Files” on page 62 for details. 

Sequence #

Display only.

Unique sequence number assigned to a legacy hardware activation file. 

Note – Sequence numbers 99000 and above indicate legacy 
hardware activation files that are permanently retained and 
cannot be deleted from the library.

Comment Line 1

Display only.

Optional comment concerning the hardware activation file, from Oracle 
Corporation 

Comment Line 2

Display only.

Optional comment concerning the hardware activation file, from Oracle 
Corporation 
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Hardware Activation File Details

Feature

Display only.

Name of a feature included in the hardware activation file.

Expiration

Display only.

Number of days until the feature is due to expire. Because SL500 library features 
do not expire, the value for this field is always “N/A.” 

Value 

Display only.

Qualification for the feature, if applicable. For example, for the Capacity feature, 
this field displays the amount of storage capacity the activation file provides. 
Depending on the feature, the field may be blank. 

Buttons

Install

Click to install the displayed hardware activation file on the library you are 
logged in to.

Browse

Click to navigate to the hardware activation file you want to display and install.

? (Help) 

Click to display online help for the screen. 

See Also 

• “Hardware Activation > Current Hardware Activation Keys” on page 74 
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Reports > Feature Audit Log

Sample Screen 

Description

Displays a list of all feature activation activity that has occurred over the life of the 
library. You can use this log to verify the validity of all features installed on the 
library. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Feature Name

Name of the feature. 

The first line of the display is the type of library. 



Hardware Activation Screen Reference

Hardware Activation Files   81

Feature Value

Special attributes of the feature. Options are:

• SN: Indicates that the serial number of the library is displayed in the Feature 
Action  field. Appears on the first line of the display.

• nnnn: For capacity hardware activation files, the number of cells added or 
removed. 

• none: Appears for all other features. 

Feature Action

Action that was performed. Options are:

• nnnnnnnn: Serial number of the library. Appears on the first line of the display.

• deleted: The hardware activation file for the feature was deleted.

• disabled: The feature was disabled by an Oracle support representative. 

• enabled: The feature was enabled by an Oracle support representative.

• installed: The hardware activation file for the feature was installed. 

• Summary: The feature is active on the library. 

Action Date

Date and time when the action was performed. 

Buttons

Search

Click to search a library report for a specified text string.

Update

Click to update the report with current data.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen. 

See Also

• “Hardware Activation > Current Hardware Activation Keys” on page 74 
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5

Library Partitioning

Note – Starting with SL500 firmware version 1300 and SL Console 
version 4.00, library partitioning upgrades must be installed 
through the SL500 hardware activation utility. Partitioning 
established on a library prior to version 1300 is retained 
permanently. See “Hardware Activation Files” on page 61 for 
details.

By using library partitioning, you can assign logical groups of storage cells and tape 
drives of the SL500 library for exclusive use by specified hosts. For example, you can 
configure one group of storage cells and drives to be used only for Symantec 
operations, and another group only for Tivoli operations. This enables you to 
configure an SL500 library for applications running on multiple hosts and operating 
systems. 

You can use the standalone SL Console or Web-launched SL Console to configure 
library partitions.

This chapter covers the following:

• “Benefits of Partitioning” on page 84

• “Partitioning Concepts and Features” on page 84

• “Allocating Storage Cells and Drives to a Partition” on page 86

• “Allocating CAPs to Partitions” on page 86

• “Orphaned Cartridges in Partitioned Libraries” on page 87

• “Planning for Partitioning” on page 87

• “Preparing the Library for Partitioning” on page 92

• “Partition Process Overview” on page 95

• “Library Resource Addresses” on page 93

• “Partition Configuration Tasks” on page 98

• “Partition Screen Reference” on page 136
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Benefits of Partitioning
By partitioning the SL500 library, you can have:

• More than one operating system and application manage the library

• An improvement in the protection or isolation of files

• An increase in system and library performance

• A higher level of data organization

• An increase in user efficiency

Partitions can be customized to fit different requirements, for example:

• Allowing for special partitions to protect or archive data

• Enabling multiple organizations, companies, or departments access

• Isolating clients (such as for service centers)

• Separating different encryption key groups

• Dedicating partitions as test systems for new technologies or data migration to 
new tape drives

Partitioning Concepts and Features
This section applies to partitioning an SL500 library and covers:

• “Allocation” on page 84

• “Partitions Available” on page 84

• “Smallest Partition Unit” on page 85

• “Host Control of Partitions” on page 85

• “Sharing CAPs Between Hosts/Partitions” on page 85

Allocation

Library resources (cells, drives, and CAPs) are allocated to a partition for exclusive 
use by that partition. 

Storage cells and tape drives allocated to a partition can be used only by the hosts 
assigned to that partition. See “Allocating Storage Cells and Drives to a 
Partition” on page 86 and “Allocating CAPs to Partitions” on page 86.

Storage cells and drives not allocated to, reserved for or associated with any partition 
cannot be accessed by any hosts. For example, you might leave an area of cells 
unallocated, in preparation for future partitioning. 

Partitions Available

You can configure up to eight partitions within an SL500 library. 
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Smallest Partition Unit

A partition can be as small as a single storage cell, CAP cell, or tape drive. Cells and 
drives within a partition do not need to be adjacent. 

Host Control of Partitions

Host-partition connections identify the hosts that are able to access a partition. 

Each partition appears to the host as a separate library. A host can control one or 
more partitions. In addition, it is possible for more than one host to control a single 
FC-SCSI partition, but it is recommended that you exercise caution in implementing 
this configuration, as some host applications may not allow for resource sharing.

Oracle’s StorageTek ACSLS software does not support partitioning on the SL500 
library. 

Sharing the Entire Library

Up to eight hosts can share a single SL500 library. 

Host Accessiblity to Resources

The host assigned to SL500 library’s partition has full-time, exclusive access to all 
available storage resources allocated to that partition. The host “owns” all tape 
drives, storage slots, and cartridges in the partition, just as it would if these resources 
were located in a freestanding, unpartitioned library. A host has no access to the 
resources of partitions not assigned to it. 

Sharing CAPs Between Hosts/Partitions

HandBots in the library are shared resources which you cannot assign exclusively to 
one partition. However, CAPs can be “owned” by a partition.

Sharing a Common CAP

A common (or unassigned) CAP is a shared library resource that has no cells 
allocated to a partition. See “Common CAP: Not Allocated to Partitions” on page 86.

Dedicating an Entire CAP or CAP Cells

All the cells in a CAP can be allocated for exclusive use by (or dedicated to) only one 
partition. See “Allocating CAPs to Partitions” on page 86 for details.

A CAP can have its cells allocated to different partitions. See “Split CAP: Allocating 
CAP Cells to Partitions” on page 86.

Assigning Partitions to CAP Open Button

You can assign partitions to the CAP Open button so that only CAPs containing cells 
accessible to those partitions will open. See “Assigning Partitions to the CAP Open 
Button” on page 87.



Allocating Storage Cells and Drives to a Partition

86   SL500 User’s Guide

Allocating Storage Cells and Drives to a Partition 
After resources (storage cells, tape drives, and cartridges) are allocated to a partition, 
only host connections that are also assigned to the partition can access the partition’s 
resources. For example, if a group of tape drives is allocated to a partition, only the 
hosts assigned to that partition can use those drives.

Storage cells and drives that are not allocated to any partition cannot be accessed at 
all. For example, you can leave an area of cells non-allocated in preparation for a 
planned future partition. 

On the SL Console screens and reports, storage cells and drives appear in one of the 
following states:

• Unassigned: Not allocated to any partition, therefore, available to be assigned to 
the current partition.

• Assigned: Allocated to the current partition.

• Unavailable: Assigned to another partition.

Allocating CAPs to Partitions
The cells within each CAP can be individually allocated or non-allocated to 
partitions.

Common CAP: Not Allocated to Partitions

In a common, or non-allocated CAP, all cells in the CAP are left non-allocated and 
can be used by any partition that does not have any CAP cells allocated to it. CAP 
cells are common by default. Any CAP cells that are not explicitly allocated to a 
partition are treated as common. 

A common CAP is a shared library resource. Each host must select a common CAP to 
use it and must release the CAP when done, to make it available to other hosts. No 
other host can access the CAP until the first host has completed the operation and 
released the CAP. For additional details, see “Assigning Partitions to the CAP Open 
Button” on page 87. 

Split CAP: Allocating CAP Cells to Partitions

In a split CAP, the cells in the CAP are allocated to one or more partitions. Each 
individual CAP cell can be allocated to one partition only. Cells in a split CAP can be 
allocated in any of the following ways:

• All cells can be allocated to one partition. 

• All cells can be distributed among multiple partitions. For example, in an eight-
cell CAP, two cells could be allocated to Partition 1, one cell to Partition 2, and the 
remaining cells to Partition 3.

• You can split cells in a CAP between partitions. Some cells can be allocated to one 
partition and the remainder left unallocated, or common. For example, in an eight-
cell CAP, five cells could be allocated to Partition 3, and the remaining cells left 
common. 



Orphaned Cartridges in Partitioned Libraries

Library Partitioning   87 

When configuring a split CAP, you must plan carefully for anticipated CAP usage. A 
partition with allocated CAP cells can use the cells allocated to it only. It cannot use 
CAP cells allocated to other partitions, nor can it use common CAP cells. 

Assigning Partitions to the CAP Open Button

In a partitioned library, it is recommended that you assign partitions to the 
CAP Open button on the library control panel prior to pressing the button to open 
the CAPs. 

Once you have assigned partitions to the CAP Open button, only CAPs containing 
cells that are accessible to those partitions will open. Depending on how your 
library’s CAPs are configured, this operation may expose CAP cells that are not 
accessible to the selected partitions. As a safeguard, however, CAPs that contain only 
inaccessible cells and CAPs with cartridges in inaccessible cells do not open.

For detailed instructions, see “Enter Cartridges Into a Partitioned 
Library” on page 130 and “Eject Cartridges From a Partitioned Library” on page 133. 

Orphaned Cartridges in Partitioned Libraries
Note – For a discussion of orphaned cartridges in non-partitioned 
libraries, see “Orphaned Cartridges in Non-Partitioned 
Libraries” on page 58.

In partitioned libraries, an orphaned cartridge is a cartridge located in an unallocated 
cell or drive (that is, a cell or drive not allocated to any defined partition). 

Caution – If a host encounters an orphaned cartridge it might treat 
the cartridge as scratch and overwrite the data. Therefore, it is very 
important to disposition orphaned cartridges properly. 

A cartridge can become orphaned for a variety of reasons, including:

• Partition boundaries have changed.

• A partition has been deleted. 

• The cartridge has been moved to an non-allocated or inaccessible cell through 
manual intervention. 

If the SL Console identifies an orphaned cartridge, it displays a warning message. 
You can then place the cartridge in the correct partition with a recovery move. For 
detailed instructions on checking for and resolving orphaned cartridges, see the 
following:

• “Verify Partition Configurations” on page 107

• “Resolve Orphaned Cartridges” on page 110

• “Commit Partition Configuration Changes” on page 111

Planning for Partitioning
Library partitioning requires:

• A thorough knowledge of library wall and slot mapping
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• Clear communication among all parties involved, including system programmers 
and administrators, library operators, and your Oracle service representative

• For a bridged library, an available, bridge-capable drive in each proposed 
partition

• Verification that all tape drives and cartridges have been moved to the proper 
locations, according to the planned host/storage cell and host/tape drive 
assignments

Plan the storage area needed for resident tape cartridges, and anticipate the number 
of required free cells. Understand the boundaries of each partition you want to create 
and the host assignments to those partitions.

Allocated Storage Capacity

In partitioned libraries:

• The total number of storage cells allocated to all library partitions cannot exceed 
the activated capacity of the library.

• There is no default active storage region. 

You must explicitly assign storage cells to partitions, which configures the active 
storage regions for each partition. See “Partition Process Overview” on page 95 for 
details. Note that the total number of storage cells allocated to all library partitions 
cannot exceed the activated capacity of the library. 

Partition Configurations

To configure a partition, you must define the following: 

• “Partition Summary Information” on page 88

• “Host-Partition Connections” on page 88

• “Partition Boundaries” on page 89

For detailed instructions on defining library partitions, see “Partition Process 
Overview” on page 95. 

Partition Summary Information

Partition summary information includes the partition ID, optional name, and the 
barcode format to be used on cartridge labels. Partition IDs must be unique and can 
range from 1–8. 

Host-Partition Connections

Host-partition connections identify the hosts that are able to access a partition. Each 
partition appears to the host as a separate library module. 

A host can control one or more partitions. In addition, it is possible for more than one 
host to control a single FC-SCSI partition, but it is recommended that you exercise 
caution in implementing this configuration, as some host applications may not allow 
for resource sharing. 
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Host-Partition Connections in Bridged Libraries

In a bridged SL500 library, you automatically define the host-partition connection 
when you connect the host bus adapter (HBA) to the bridge drive that manages the 
control path for the partition. 

Host-Partition Connections in Unbridged Libraries

In an unbridged library, you must separately define the host-partition connections.

A partition can have one or more host-partition connections. The host-partition 
connection configuration is user-defined and consists of the following information: 

• World Wide Port Name of the host bus adapter 

• Logical unit number (LUN) of the partition as seen from the host. 

See “Add a Host Connection (Unbridged Libraries Only)” on page 101 for detailed 
instructions on defining this information. 

Partition Boundaries

Partition boundaries identify the storage cells, drives, and CAP cells that are part of 
each partition. Only non-allocated cells can be added to a partition, and only 
allocated cells can be removed. 

You can define partition boundaries in any of the following ways:

• Select individual cells or rectangular groups of cells to add or remove from a 
partition. Cells or cell groups do not have to be contiguous.

• Select an entire module side to add or remove from a partition. Sides do not have 
to be contiguous. 

• Select an entire module to add or remove from a partition. Modules do not have to 
be contiguous. 
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Sample Partition Configuration

FIGURE 5-1 shows a sample SL500 library partition configuration. In this example, 
there are three defined partitions: Partition 1, Partition 2, and Partition 6.

FIGURE 5-1  Library Partition Example
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The screen example is from the perspective of Partition 1, therefore the resources 
allocated to Partition 1 are shown in gold, and the resources allocated to Partition 2 
and Partition 6 are shown in red. TABLE 5-1 describes the resource allocation in 
detail. 

TABLE 5-1  Partition Example – Resource Description 

Resource Group Included Resources 

Partition 1 All resources are shown in gold. Includes the following:

• Tape drive in the base module

• Storage cells in the left side of the base module

• Top two CAP cells in the base module

Partition 2 All resources are shown in red. Includes the following:

• Top tape drive in the Drive Module

• Storage cells in the right side of the base module

• No allocated CAP cells

Partition 6 All resources are shown in red. Includes the following:

• Bottom tape drive in the Drive Module

• Storage cells in the Drive Module

• Bottom two CAP cells in the base module

Common CAP cell Middle CAP cell in the base module 

Unassigned All resources shown in white

Not Accessible All resources shown x’ed out

Orphaned cartridge Cartridge in unallocated (white) storage cell in the base 
module
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Preparing the Library for Partitioning
Before you can partition a library, you must install, activate, and enable the 
partitioning feature.

The following special considerations apply after you successfully install the 
partitioning feature on a previously non-partitioned library. 

• You must reboot the library after installing the partitioning activation file. 

• Until you create at least one partition, the library remains in a non-partitioned 
state. That is, all activated storage cells, drives, and CAPs are accessible to all 
hosts.

Activating the Partitioning Feature

Starting with SL500 firmware version 1300 and SL Console version 4.00, library 
partitioning upgrades must be installed through the SL500 hardware activation 
utility. Partitioning established on a library prior to version 1300 is retained 
permanently. See “Oracle Hardware Activation Files” on page 61 for details.

Enabling and Disabling the Partitioning Feature

The partition feature can be installed and enabled through the “Hardware Activation 
File Installation Process” on page 63.

A library with partitioning enabled can be in either of the following states: 

• Partitioned: The library has at least one user-defined partition with a valid 
partition ID. 

• Non-partitioned: The library has no user-defined partitions. A non-partitioned 
library behaves in the same manner as a library that does not have partitioning 
enabled. That is all storage cells, drives, and CAPs are accessible to all hosts. 

To disable partitioning on a library, you must first delete all partitions. The library 
state will then change to “non-partitioned.”

Deleting the Partitioning Feature

You can delete the partitioning feature by deleting the partitioning hardware 
activation file from the library. See “Delete a Hardware Activation File” on page 108 
for detailed instructions. You must reboot the library after deleting the partitioning 
activation file for the deletion to take effect.

Note – Deleting the partitioning feature is an exceptional 
situation. Be sure this is what you want to do. The partitioning 
feature cannot be deleted if it was activated by a legacy hardware 
activation file prior to SL500 firmware version 3.0.

Deleting the partitioning feature has the following effects on the library 
configuration:

• Changes the library state to “non-partitioned.”

• Makes all activated storage cells, drives, and CAPs accessible to hosts.
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• All existing partition summary information and resource allocations are retained, 
but not usable. If the partitioning activation file is later re-installed, the partition 
allocations are restored.

Library Resource Addresses
Resource addresses uniquely identify each resource (storage cells, drives, and CAP 
cells) within the library. The SL500 library and attached hosts use the following 
addressing schemes: 

• “Library Internal Address” on page 93

Each partition appears to a host as a separate library. This is reflected in the partition 
address.

Library Internal Address

The library internal address is used by the SL500 library controller and the SL 
Console device tree to identify the physical location of each resource. The addressing 
scheme used by the SL500 is a four-digit, comma-separated value, specifying the 
library, module, row, and column, as viewed from inside the library, facing the drive 
bays. This addressing scheme is commonly referred to as the LMRC address.

The format of the SL500 LMRC address is l,m,r,c where:

• l= library or partition number. In partitioned libraries, l is the partition ID (1–8). In 
non-partitioned libraries, l is always “0.” 

• m = module number (1–5). The base module is 1, additional drive expansion and 
storage expansion modules are 2–5. 

• r = row number. Numbered consecutively from the top, down, with row 1 at the 
top. 

• c = column number

Column numbers for the base module are 1-4 (left side of library) and 5-8 (right 
side of library). The column number for the DEM (Drive Expansion Module) drive 
column (rear of library) is 9. The column numbers for the CEM (Cartridge 
Expansion Module) columns (rear of library) are 9–11. 

Some examples of internal addresses are listed below:

• If the entire base module is allocated to Partition 1, the internal address for a 
cartridge in row 8, column 1 in the base module is: 1, 1, 8, 1. 

• If the entire CEM is allocated to Partition 2, the internal address for a cartridge in 
row 10, column 1 is: 2, 2, 10, 1.

Host SCSI Element Address

SCSI element addresses are used by hosts with a FC-SCSI connection to the SL500 
library. Each library resource available to a host is identified by a unique SCSI 
element address. 

Following are rules for SCSI element numbering within partitioned libraries:
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• Each SCSI element address is a single integer, up to four digits in length. 

• SCSI element addresses for each library resource type fall within a distinctive 
range: 10-999 for CAPs, 1000-1999 for drives, and 2000+ for storage cells.

• SCSI element numbering restarts for each partition. For example, storage cell 
numbering starts with 2000 for each partition within a given library. 

• Numbering starts at the upper-left back of the library, as viewed from the front of 
the library. Numbering continues to the lower-right front by frame module.  

• SCSI element addresses for a partition start at the lowest module, row, and 
column within the partition, then proceed by row until the end of the column, 
then increment by column until the end of the module. 

• SCSI element numbering is continuous within each partition, even if cell locations 
for the partition are not adjacent. 

• When additional resources are allocated to an existing FC-SCSI partition, the 
original resources are not renumbered. This helps to minimize disruption to the 
FC-SCSI host.

• Drive element numbering includes occupied drive slots only. Empty drive slots 
are not assigned a SCSI element address. 

For example, if a library’s base and storage expansion modules are allocated to 
Partition 1 and the Drive Module is allocated to Partition 2, then SCSI element 
numbering is as follows:

• For Partition 1, the first available storage cell in the base module is assigned 
element address “2000.” Numbering continues sequentially through the last 
available cell in the storage module, running from top-left through bottom-right. 
Installed drives in the base module are assigned sequential element addresses, 
starting with “1000” for the top left drive. 

• For Partition 2, the first available storage cell in the Drive Module is assigned 
element address “2000.” Numbering continues sequentially through the last 
available cell in the Drive Module, running from top-left through bottom-right. 
Installed drives in the Drives Module are assigned sequential element addresses, 
starting with “1000” for the top left drive.

SCSI Element Address Examples

A library’s Base and storage expansion modules are allocated to Partition 1, and the 
Drive Module is allocated to Partition 2. SCSI element numbering is as follows:

• For Partition 1, the first available storage cell in the base module is assigned 
element address “2000.” Numbering continues sequentially through the last 
available cell in the storage module, running from top-left through bottom-right. 
Installed drives in the Base Module are assigned sequential element addresses, 
starting with “1000” for the top left drive. 

• For Partition 2, the first available storage cell in the drive module is assigned 
element address “2000.” Numbering continues sequentially through the last 
available cell in the Drive Module, running from top-left through bottom-right. 
Installed drives in the Drives Module are assigned sequential element addresses, 
starting with “1000” for the top left drive.
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Partition Process Overview
Note – Starting with SL500 firmware version 1300 and SL Console 
version 4.00, library partitioning upgrades must be installed 
through the SL500 hardware activation utility. Partitioning 
established on a library prior to version 1300 is retained 
permanently. See “Hardware Activation Files” on page 61 for 
details.

The high level process for creating a partition for the first time is explained below.

1. Review summary instructions for the partition configuration process at the 
Instructions (Step 1) tab. See “Review Partitioning Instructions” on page 99.

2. At the Summary (Step 2) tab, add a partition by:

• Assigning the partition a partition ID

• Giving the partition a name (optional)

See “Add a Partition” on page 100 and “Add a Host Connection (Unbridged 
Libraries Only)” on page 101.

3. Design the partition:

• At the Design (Step 3) tab, allocate library resources to the partition and verify 
the partition assignments.

Note – The partition you have just designed is not applied to the 
library until you commit the configuration in Step 4.

See “Design a Partition” on page 102.

4. At the Commit (Step 4) tab, commit the partition to the library.

See “Commit Partition Configuration Changes” on page 111.

SL Console Partition Workspace

The partition Summary (Step 2) and Design (Step 3) screens, and all associated 
dialog boxes, give you a dynamic workspace to design your library partitions.

All partition configuration information is automatically saved to the partition 
workspace in SL Console memory and retained for the duration of your SL Console 
session. This enables you to switch among partition views and leave and return to the 
partition screens any number of times without losing your configuration changes.

Information in the SL Console partition workspace is committed to the library 
controller database only through the Commit (Step 4) screen. The information is lost 
if any one of the following occurs before you have committed your updates: 

• You actively log off the SL Console session.

• The SL Console session times out or the connection to the library is lost. 

• You actively refresh the SL Console workspace from the current library controller 
database. This is done through the Refresh button on the Summary (Step 2) and 
Design (Step 3) screens. 
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Caution – Although partition changes are not disruptive to library 
hosts, it is recommended that you make the library unavailable to 
other users before committing your partition workspace changes. 
Because the SL Console does not validate partition boundaries 
against the library controller database in real-time, configuration 
conflicts may arise if you change partition boundaries while other 
users are performing cartridge movements or library configuration 
changes. See “Synchronizing the Display With the Controller 
Database” on page 23 for details.
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▼ Partitioning Task Categories

Partitioning tasks are divided into the following categories:

• “Partition Configuration Tasks” on page 98

• “Partition Management Tasks” on page 114

• “Partition Report Tasks” on page 124

• “CAP Operation Tasks” on page 129
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Partition Configuration Tasks
• “Review Partitioning Instructions” on page 99

• “Add a Partition” on page 100

• “Add a Host Connection (Unbridged Libraries Only)” on page 101

• “Design a Partition” on page 102

• “Verify Partition Configurations” on page 107

• “Resolve Orphaned Cartridges” on page 110

• “Commit Partition Configuration Changes” on page 111
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▼ Review Partitioning Instructions

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to review the partitioning process prior to any other partitioning 
tasks.

Task Steps

1. Select Tools > Partitions.

The first time you make this selection during an SL Console login session, the 
Instructions (Step 1) page appears automatically. 

2. Review the instructions on the page before proceeding with other partitioning 
tasks. 
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▼ Add a Partition

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to create a new library partition and assign its storage capacity. 
You can create up to eight partitions, with IDs from 1–8. 

Task Steps

1. Select Tools > Partitions, and click the Summary (Step 2) tab. The Summary 
(Step 2) page appears.

 The exact appearance of the page depends on whether you are configuring an 
unbridged library or a bridged library:

• For an unbridged library, the interface includes a four-column table in the 
Partition Summary and a section showing Details for Partition n, where n is 
the ID number of the selected partition.

• For a bridged library, the interface includes a five-column table in the Partition 
Summary section (the fifth column is labeled Bridge Drive) and does not 
include a Details for Partition section.

2. Click Add Partition. 

The Add Partition dialog box appears. 

3. Select the Partition ID you want to add, and enter the Name, and Barcode 
Presentation.

Note – Partition IDs do not need to be contiguous. For example, 
you can create partition 2 and partition 4, with no partitions 1 or 3. 

4. Click OK. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 107 and “Commit 
Partition Configuration Changes” on page 111. 
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▼ Add a Host Connection (Unbridged Libraries Only)

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to set up the connection between a host and a selected partition in 
an unbridged library. You must perform this procedure in order for the partition to be 
accessible by the host.

Each partition can have up to nine host connections. Also, each host can connect to 
multiple partitions. 

Note – This procedure applies to FC-SCSI host-partition 
connections only. 

Task Steps

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

2. Click Add Connection. 

Note – Each initiator connected to the library must have one 
library partition assigned to LUN 0. When you verify or commit 
partition configuration changes, the SL Console will notify you if 
an initiator does not meet this requirement. 

3. Click OK. 
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▼ Design a Partition

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to allocate library resources (storage cells, tape drives, and CAP 
cells) to a partition. 

Note that library resources can be allocated to only one partition at a time. If you 
want to add resources to a partition but the resources are already allocated to another 
partition, you must first remove the resources from the assigned partition, and then 
add them to the new partition.

 Task Steps

1. Select Tools > Partitions.

2. Click the Design (Step 3) tab.

The exact appearance of the Design (Step 3) screen varies depending on whether 
you are configuring an unbridged library or a bridged library. The interface for a 
bridged library includes an additional, Bridge Drive control and indicators for the 
available, bridge-capable drives.
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Unbridged and bridged library examples for the Design (Step 3) page follow.
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3. In the Partition list, select the partition that you want to configure. 

All fields update to reflect the current configuration for the selected partition. 
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4. Choose a selection method from the Select by list control.
  

You can select by individual Cell (which includes drives), by module Side, or by 
complete Module.

5. If you are configuring a bridged library, use the Bridge Drive list control to 
select the bridge drive for this partition.

Every partition in a bridged library must have a bridge drive. 

The Bridge Drive list control includes only the accessible, bridge-capable drives. 
So, for example, given an SL500 base module with bridge-capable drives installed 
in positions 1 and 2 and an SL500 drive module with a bridge-capable drive in 
position 4, you could choose drive 1, 2, or 4 for your bridge drive. Position 3 is 
inaccessible in this configuration, so the list control does not offer 3 as an option.

6. To add a resource to the partition, select the Add radio button and click on the 
library-map icon for the cell/drive, side, or module that you want to add.

When you click on the resource, its color changes to gold, which indicates that the 
resource has been allocated to the current partition.
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7. To remove a resource from the partition, select the Remove radio button and 
click on the library-map icon for the cell/drive, side, or module that you want to 
remove from the partition.

When you click on the resource, its color changes to white, which indicates that 
the resource is not allocated.

8. To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 107 and “Commit 
Partition Configuration Changes” on page 111. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

For additional information on the design tools and library map, see 
“Partitions—Design (Step 3)” on page 159. 
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▼ Verify Partition Configurations 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to verify partition configuration changes you have made during 
this SL Console login session. This procedure warns you of the following possible 
errors:

• A partition has orphaned cartridges. See “Planning for Partitioning” on page 87 
for details.

• Library resources have been removed from a partition. 

• A host connected to the library does not have a partition assigned to LUN 0. 

Note – This procedure verifies only one partition at a time. If you 
need to verify multiple partitions, you must repeat this procedure 
separately for each partition. 

Task Steps

1. Select Tools > Partitions.

2. Click the Design (Step 3) tab.

The Design (Step 3) page appears, displaying the current configuration of the 
library you have selected.

3. In the Partition list, select the partition you want to configure. 

All fields update to reflect the current configuration for the selected partition. 
  



Partition Configuration Tasks

108   SL500 User’s Guide

4. In the upper right corner, click Verify. 

The boundaries of the selected partition are verified, including the locations of all 
tape cartridges. 

Note – This verification is performed on the current partition 
configuration in the SL Console partition workspace only. It does 
not verify current partition boundaries against the library 
controller database. Therefore, it cannot identify configuration 
conflicts that may arise due to other users performing cartridge 
movements or library configuration changes (through the 
command line interface, other SL Console sessions, or host 
applications) at the same time you have made partition changes.

5. When the Verify Results message appears, check for warnings (such as 
orphaned cartridge messages, etc.) for the current partition configuration. 
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6. To toggle between detailed warning messages and the summary, click Details. 

7. To print the warning messages, click Print in the expanded view of the warning 
messages.

8. To save the warning messages in a comma-delimited text file, click Save. 

9. If the warnings messages indicate that cartridges have been orphaned, see 
“Resolve Orphaned Cartridges” on page 110 before committing your changes to 
the library controller database.

10. To dismiss the Verify Results message and return to the Design (Step 3) page, 
click OK. 
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▼ Resolve Orphaned Cartridges

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to resolve any orphaned cartridges that are displayed on the SL 
Console.

Task Steps

1. If the SL Console identifies an orphaned cartridge, it displays a warning 
message. Perform recovery moves on all cartridges listed in the warnings (see 
“Recovery Moves” on page 253) before proceeding to “Commit Partition 
Configuration Changes” on page 111. 

Caution – Potential data loss. If you do not perform “Recovery 
Moves” on page 250, host applications may find the orphans and 
treat them as scratch volumes. Valid data could be overwritten.
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▼ Commit Partition Configuration Changes 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

This procedure updates the library controller database with all partition 
configuration changes that have made during this SL Console session. If you log out 
of SL Console without committing your changes, all changes are discarded. 

Caution – Although partition changes are not disruptive to library 
hosts, it is recommended that you make the library unavailable to 
other users before committing your partition workspace changes. 
Because the SL Console does not validate partition boundaries 
against the library controller database in real-time, configuration 
conflicts may arise if you change partition boundaries while other 
users are performing cartridge movements or library configuration 
changes. 

Note – Be sure to “Resolve Orphaned Cartridges” on page 110 
before proceeding. 

Task Steps

1. Take the library offline to ACSLS and ELS tape management software. 

See the appropriate tape management software documentation for the procedures 
and commands.

2. Select Tools > Partitions, and click the Commit (Step 4) tab.

The Commit (Step 4) page appears.
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3. Click the Apply button. 

The boundaries of the selected partition are verified, including the locations of all 
tape cartridges. 

The Confirm Apply message appears, indicating whether there are any orphaned 
cartridges or other problems in the current partition configuration.

4. To toggle between detailed warning messages and the summary, click Details. 

5. To print the warning messages, click Print in the expanded view of the warning 
messages.

6. To save the warning messages in a comma-delimited text file, click Save. 
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7. If the warnings messages indicate that cartridges have been orphaned, see 
“Resolve Orphaned Cartridges” on page 110 before committing your changes to 
the library controller database.

8. If you want to cancel the update without applying your changes, click No. 

The library controller database is not updated, but all partition changes from this 
login session are retained in the SL Console partition workspace. 

9. Otherwise, if you want to update the library controller database and apply your 
changes, click Yes. When the Commit Success message appears, click OK to 
return to the Commit (Step 4) page. 

10. You must now configure all affected library host applications to recognize your 
changes. See the appropriate tape management software documentation for the 
procedures and commands. 
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Partition Management Tasks
• “Modify Partition Summary Information” on page 115

• “Delete a Partition” on page 116

• “Modify FC-SCSI Host-Partition Connection Detail (Unbridged Libraries 
Only)” on page 117

• “Delete a FC-SCSI Host Connection (Unbridged Libraries Only)” on page 119

• “Refresh the SL Console Partition Workspace” on page 121

• “Reallocate Library Resources” on page 122

• “Make a Hardware Change to a Partitioned Library” on page 123
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▼ Modify Partition Summary Information

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to change the name or barcode presentation format of an existing 
partition.

Note – You cannot change the partition ID. To assign a different 
Partition ID, you must delete the old partition and create a new 
one with the new ID. 

Task Steps

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) page appears.

2. In the Partition Summary section, select the partition you want to modify. 

3. Click Modify Partition.

The Modify a Partition dialog box appears.

4. Enter the changes you want to make. 

5. Click OK to confirm the changes. 
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▼ Delete a Partition

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to delete a partition from the library. The following changes are 
made to the library partition configuration:

• All resources allocated to the partition are marked available. 

• All host connections for the partition are deleted. 

• The partition ID is deleted. 

Caution – Deleting partitions can result in orphaned cartridges and 
data that could be lost. See “Planning for Partitioning” on page 87 
for details. 

Note – Deleting all partitions from the library causes the library 
state to change to “non-partitioned.” All storage cells, drives, and 
CAPs will be accessible to all hosts.

Task Steps

1. Select Tools > Partitions, and click the Summary (Step 2) tab.

The Summary (Step 2) page appears.

2. In the Partition Summary section, click the partition you want to remove.

3. Click Delete Partition.

A confirmation message appears.

4. Click OK to confirm the deletion. 

The updates are made. Your partition configuration changes are saved to the SL 
Console partition workspace for the duration of this login session. 

5. To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 107. 

If there are no partitions remaining in the library, when you commit the updates 
the library state will change to “non-partitioned.” 
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▼ Modify FC-SCSI Host-Partition Connection Detail 
(Unbridged Libraries Only)

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to modify the host World Wide Port Name or LUN number of the 
library for a host-partition connection. 

Note – You cannot modify the target port number for the library. 
It is always “0.” 

Task Steps

1. Select Tools > Partitions, and click the Summary (Step 2) tab.
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2. Click OK to confirm the changes. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 107 and “Commit 
Partition Configuration Changes” on page 111. 
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▼ Delete a FC-SCSI Host Connection (Unbridged Libraries 
Only)

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to delete a host-partition connection on an unbridged library. 
After you perform this procedure, the host will no longer be able to access the 
partition. 

Task Steps

1. Select Tools > Partitions, and click the Summary (Step 2) tab.
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2. In the Connections section, click the host-partition connection you want to 
delete.

3. Press the Delete Connection button.

A confirmation message appears.

4. Click OK to confirm the deletion. 

Your partition configuration changes are saved to the SL Console partition 
workspace for the duration of this login session. 

To update the library controller database with all changes from this SL Console 
login session, see “Verify Partition Configurations” on page 107 and “Commit 
Partition Configuration Changes” on page 111. 
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▼ Refresh the SL Console Partition Workspace

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to refresh the SL Console partition workspace with current data 
from the library controller database. The current data includes all updates that other 
users have made to the library controller database during your login session, through 
the command line interface, other SL Console sessions, or host applications. 

Note – When you complete this procedure, all uncommitted 
partition changes you have made during this SL Console login 
session are discarded. 

Task Steps

1. Select Tools > Partitions.

2. Click one of the following tabs:

• Summary (Step 2) 

• Design (Step 3)

The selected page appears.

3. In the upper right corner, click Refresh. 

The Partition Refresh message appears.

4. Click Yes to confirm the refresh. 

All partition data updates with current data from the library controller database. 
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▼ Reallocate Library Resources 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Reallocate library resources (storage cells, tape drives, CAP cells, or cartridges) from 
one partition to another.

Task Steps

You must use the following two-step process: 

1. Remove the resource from the partition it is currently allocated to.

2. Allocate the resource to a different partition. 

See “Design a Partition” on page 102 for detailed instructions.

Caution – Reallocating resources can result in orphaned cartridges 
and data that could be lost. See “Planning for 
Partitioning” on page 87 for details. 
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▼ Make a Hardware Change to a Partitioned Library

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Some library hardware changes, such as adding expansion modules or adding CAP 
cells, may require the removal of all or part of an existing partitioned module. Use 
the following process to make such hardware changes without losing partitioning 
information for the sections of the library that are unchanged. 

Caution – Failure to follow this procedure could result in the loss of 
library partition configuration information after a hardware change. 

Task Steps

1. De-allocate all library resources (storage cells, CAPs, and drives) that will be 
removed as part of the hardware change from the partitions they are currently 
allocated to. 

See “Design a Partition” on page 102 for detailed instructions.

2. Power down the library. 

See “Power Down the Library” on page 615 “Power Off the Library” on page 358  
for detailed instructions. 

3. Install the hardware change.

4. Power up the library. 

See “Power Up the Library” on page 616 for detailed instructions. 

All partition allocations for the unchanged parts of the library remain in effect.

5. Allocate the library resources that have been added due to the hardware change. 

See “Design a Partition” on page 102 for detailed instructions.

Caution – Reallocating resources can result in orphaned cartridges 
and data that could be lost. See “Planning for 
Partitioning” on page 87 for details. 
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Partition Report Tasks
• “Display a Partition Report” on page 125

• “Print Partition Report Data” on page 127

• “Save Partition Report Data” on page 128
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▼ Display a Partition Report 

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display any of the following partition reports:

• Cartridge Cell and Media Summary: Displays a detailed list of all resource 
partition assignments.

• Host Connections Summary: Displays detailed host-partition connection 
information for all partitions.

• Orphaned Cartridge Report: Displays a detailed list of all orphaned cartridges.

• Partition Details: Displays detailed information for a selected partition.

• Partition Summary: Displays summary information for all partitions.

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without committing the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3) screens. 

Task Steps

1. Select Tools > Partitions, and click the Reports tab.

The Reports page appears.
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2. In the list, select the report you want to display. 

The page updates with current data from the library controller database. 

3. If you want to print the report data or save it to a file, see the following 
procedures:

• “Print Partition Report Data” on page 127

• “Save Partition Report Data” on page 128 
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▼ Print Partition Report Data

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to print a partition report. This procedure can be performed from 
any of the partition report pages. 

Task Steps

1. Select Tools > Partitions, and click the Reports tab.

The Reports page appears.

2. In the list, select any report. 

The specified report is displayed. All report pages include the Print and Save to 
File buttons. 

3. Click Print. 

The Print dialog box appears. 

4. Complete the print dialog box, and click Print. 

The report is printed to the selected printer. 
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▼ Save Partition Report Data

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to save partition report data to a comma-separated file (.csv 
format) that is compatible with most spreadsheet applications. This procedure can be 
performed from any of the partition report pages. 

Task Steps

1. Select Tools > Partitions, and click the Reports tab.

The Reports page appears.

2. In the list, select any report. 

The specified report is displayed. All report pages include the Print and Save to 
File buttons. 

3. Click Save to File.

The Save dialog box appears. 

4. Browse to the directory where you want to save the file, and enter the file name. 

5. Click Save.

The data is saved to the specified file. 
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CAP Operation Tasks 
• “Enter Cartridges Into a Partitioned Library” on page 130

• “Eject Cartridges From a Partitioned Library” on page 133
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▼ Enter Cartridges Into a Partitioned Library

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to enter cartridges into a partitioned library. Partitions with no 
allocated CAP cells must use common CAP cells. Partitions with allocated CAP cells 
must use the cells allocated to them. 

Note – This procedure highlights aspects of CAP operations that 
are unique to partitioned libraries. For general enter and eject 
procedures, see “Cartridge Handling Tasks” on page 392.

Note – Although it is possible to enter cartridges through a CAP 
without using the Assign CAP Button screen, it is recommended 
that you access the screen first to verify the partition settings. This 
will help prevent cartridges from being entered inadvertently into 
the wrong partition. 

Task Steps

1. Initiate the Enter operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

2. Select Tools > Diagnostics. 

3. Expand the CAP Folder, and click the CAP you want to use. 

Note – In a partitioned library, only one CAP is listed in the 
Diagnostics CAP Folder.

The Import/Export page appears.
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4. Click the Assign CAP Button tab. 

The Assign CAP Button page appears. 

5. In the Common CAP and Split CAP tables, click the partitions into which you 
want to enter cartridges. See “Diagnostics > CAP—Assign CAP 
Button” on page 194 for details on these page fields. 

6. Click Apply. 

The CAP Confirm message appears. 

7. Click OK. 

8. Depending on how your library’s CAPs are configured, this operation may 
expose CAP cells that are not accessible to the requesting host’s partition. For 
example, because a split CAP can contain common cells or cells allocated to 
multiple partitions, opening the CAP door may expose cells not allocated to the 
selected partition. If any of the inaccessible cells contain cartridges, the CAP 
door will not open, and a warning message appears. 

Click OK to return to the Assign CAP Button page. Before you can continue with 
this procedure, you must remove the inaccessible cartridges from the CAP. 

9. On the library control panel, push the CAP Open button.
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10. The library opens the doors of all CAPs with cells accessible to the selected 
partition. Doors to CAPs that contain only inaccessible cells do not open.

The library also sends CAP status messages to all hosts with access to the exposed 
cells. Following are examples:

• If the library opens common CAPs only, messages are sent to all hosts with 
access to common CAP cells. 

• If the library opens a split CAP containing both allocated and common cells, 
messages are sent to all hosts in the assigned partitions, as well as all hosts 
with access to common CAP cells. 

11. Place the cartridges in any CAP cells that are accessible to the selected partition.

Note – If you place cartridges in cells that are not accessible to the 
selected partition, the CAP door will not lock. You must move the 
cartridges to the appropriate CAP cells. 

12. Close the CAP. It locks automatically.

13. Move the cartridges from the CAP to storage cells within the selected partition. 
See the appropriate tape management software documentation for the 
procedures and commands. 

14. Once the selected partitions are finished with the CAP, it is recommended that 
you restore the Assign CAP Button page to the following settings. This will 
help to prevent cartridges from being entered inadvertently into the wrong 
partition in the next CAP operation. 

• In the Common CAP table, click None.

• In the Split CAP table, deselect all the check boxes. 
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▼ Eject Cartridges From a Partitioned Library

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to eject cartridges from a partitioned library. Partitions with no 
allocated CAP cells must use common CAP cells. Partitions with allocated CAP cells 
must use the cells allocated to them. 

Note – This procedure highlights aspects of CAP operations that 
are unique to partitioned libraries. For general enter and eject 
procedures, see “Cartridge Handling Tasks” on page 392.

Task Steps

1. Initiate the eject operation at the host. See the appropriate tape management 
software documentation for the procedures and commands. 

2. The HandBot places the cartridges into CAP cells accessible to the host. 

3. Select Tools > Diagnostics. 

4. Expand the CAP Folder, and click the CAP you want to use. 

Note – In a partitioned library, only one CAP is listed in the 
Diagnostics CAP Folder.

The Import/Export page appears.
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5. Click the Assign CAP Button tab. 

The Assign CAP Button page appears. 

6. In the Common CAP and Split CAP tables, click the partitions from which you 
are ejecting cartridges. See “Diagnostics > CAP—Assign CAP 
Button” on page 194 for details on these page fields. 

7. Click Apply. 

The CAP Confirm message appears. 

8. Click OK. 

9. Depending on how your library’s CAPs are configured, this operation may 
expose CAP cells that are not accessible to the requesting host’s partition. For 
example, because a split CAP can contain common cells or cells allocated to 
multiple partitions, opening the CAP door may expose cells not allocated to the 
selected partition. If any of the inaccessible cells contain cartridges, the CAP 
door will not open and a warning message appears. 

Click OK to return to the Assign CAP Button page. Before you can continue with 
this procedure, you must remove the inaccessible cartridges from the CAP. 

10. On the library control panel, push the CAP Open button.
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11. The library opens the doors of all CAPs with cells accessible to the selected 
partition. Doors to CAPs that contain only inaccessible cells do not open.

The library also sends CAP status messages to all hosts with access to the exposed 
cells. Following are examples:

• If the library opens common CAPs only, messages are sent to all hosts with 
access to common CAP cells. 

• If the library opens a split CAP containing both allocated and common cells, 
messages are sent to all hosts in the assigned partitions, as well as all hosts 
with access to common CAP cells. 

12. Remove the cartridges from the CAP cells.

13. Close the CAP. It locks automatically.

14. Once the selected partitions are finished with the CAP, it is recommended that 
you restore the Assign CAP Button page to the following settings. This will 
help to prevent cartridges from being entered inadvertently into the wrong 
partition in the next CAP operation. 

• In the Common CAP table, click None.

• In the Split CAP table, deselect all the check boxes. 
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Partition Screen Reference
This section includes detailed descriptions of all SL Console partition screens, 
arranged by screen navigation path. For example, 
Partitions—Summary (Step 2)—Add Connection indicates the screen accessed by 
clicking Tools and then Partitions from the Menu Bar, and then clicking the 
Summary (Step 2) tab, and then the Add Connection button. 

Partition Screens are organized into the following categories:

• “Partition Summary Screens” on page 137

• “Partition Design and Commit Screens” on page 158

• “Partition Report Screens” on page 173

• “Partition CAP Operation Screens” on page 193

Note – The partition Summary (Step 2) and Design (Step 3) 
screens, and all associated messages, give you a dynamic 
workspace to design your library partitions. All partition 
configuration information is automatically saved to the partition 
workspace in SL Console memory and retained for the duration of 
your SL Console session. This allows you to switch among 
partition views and leave and return to the partition screens any 
number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 
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Partition Summary Screens
• “Partitions—Instructions (Step 1)” on page 138

• “Partitions—Summary (Step 2)” on page 140

• “Partitions—Summary (Step 2)—Modify Connection (Unbridged Libraries 
Only)” on page 150

• “Partitions—Summary (Step 2)—Add Partition” on page 152

• “Partitions—Summary (Step 2)—Delete Partition” on page 154

• “Partitions—Summary (Step 2)—Modify Partition” on page 156
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Partitions—Instructions (Step 1)

Sample Screen

Description

Displays instructions for using the partition screens.

Note – This screen appears automatically the first time you select 
Tools > Partitions during an SL Console login session. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

None

Buttons and Controls

? (Help) 

Click to display online help for the screen.
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See Also

• “Partitions—Summary (Step 2)” on page 140 

• “Partitions—Design (Step 3)” on page 159 

• “Partitions—Commit (Step 4)” on page 168 

• “Partitions—Reports” on page 174 
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Partitions—Summary (Step 2)

Sample Screen (Bridged Library)
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Sample Screen (Unbridged Library)

Description

Displays summary information for the library and, optionally, a selected partition. 

Also includes buttons that enable you to initiate any of the following activities:

• Add a new partition 

• Delete a partition from the library

• Modify partition summary information 

• Add a new host-partition connection

• Delete a host-partition connection

• Modify the configuration of a host-partition connection

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console
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• Web-launched SL Console

Screen Fields

Partition Summary

Partition Number

Display only.

ID assigned to the partition. IDs can range from 1–8.

Allocated Storage Cells

Display only.

Total number of storage cells allocated to this partition. 

Allocated Drives Bays

Display only.

Total number of tape drives allocated to this partition. 

Bridge Drive

Bridged libraries only.

In a bridged library, the allocated drive that provides the control path for the other 
drives allocated to the partition.

Details for Partition n 

Unbridged Libraries Only.

Note – The following fields display host-partition connection 
information for the partition currently selected in the Partition 
Summary table. 

Name

Display only.

The optional name assigned to the selected partition. 

Barcode Presentation 

Display only.

The bar code format used when labeling cartridges assigned to the selected 
partition. 

Connections

Display only.

A table of host-connection name/value pairs:
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• Initiator (WWPN): The World Wide Port Name of the host bus adaptor (HBA).

• LUN: The Logical Unit Number of the library partition as seen from the host. 
This entry must be unique on the host.

Total Library Resources

Storage Cells 

Display only.

Total physical capacity of the library.

Drives 

Display only.

Total number of tape drives in the library.

CAP cells

Total number of CAP cells in the library.

Display only.

Resources Allocated

Storage Cells 

Display only.

Total number of storage cells allocated to all library partitions.

Drives 

Display only.

Total number of tape drives allocated to all library partitions.

CAP cells

Display only.

Total number of CAP cells allocated to all library partitions.

Resources Unallocated 

Storage Cells 

Display only.

Total number of storage cells in the library that are not yet allocated to a partition.

Drive Bays 

Display only.
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Total number of tape drives in the library that are not yet allocated to a partition.

CAP cells

Display only.

Total number of CAP cells in the library that are not allocated to any library 
partition.

Buttons and Controls

Refresh 

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh 
message appears, prompting you to confirm the refresh. 

? (Help)

Click to display online help for the screen.

Add Partition

Click to add a new partition. The “Partitions—Summary (Step 2)—Add 
Partition” on page 152 dialog box appears. 

Delete Partition

Click to delete the currently selected partition. The “Partitions—Summary 
(Step 2)—Delete Partition” on page 154 dialog box appears. 

Modify Partition

Click to modify summary information for the currently selected partition. The 
“Partitions—Summary (Step 2)—Modify Partition” on page 156 dialog box 
appears. 

Add Connection

Unbridged libraries only.

Click to add a new host connection to the currently selected partition. The 
“Partitions—Summary (Step 2)—Add Connection (Unbridged Libraries 
Only)” on page 146 dialog box appears. 

Delete Connection

Unbridged libraries only.

Click to delete the currently selected host-partition connection. The 
“Partitions—Summary (Step 2)—Delete Connection (Unbridged Libraries 
Only)” on page 148 dialog box appears.
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Modify Connection

Unbridged libraries only.

Click to modify the configuration of the currently selected host-partition 
connection. The “Partitions—Summary (Step 2)—Modify Connection 
(Unbridged Libraries Only)” on page 150 dialog box appears.

See Also

• “Partitions—Summary (Step 2)” on page 140 

• “Partitions—Summary (Step 2)—Add Partition” on page 152 

• “Partitions—Summary (Step 2)—Delete Partition” on page 154 

• “Partitions—Summary (Step 2)—Modify Partition” on page 156 

• “Partitions—Summary (Step 2)—Add Connection (Unbridged Libraries 
Only)” on page 146 

• “Partitions—Summary (Step 2)—Delete Connection (Unbridged Libraries 
Only)” on page 148 

• “Partitions—Summary (Step 2)—Modify Connection (Unbridged Libraries 
Only)” on page 150 

• “Partitions—Design (Step 3)” on page 159 

• “Partitions—Commit (Step 4)” on page 168 

• “Partitions—Reports” on page 174 
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Partitions—Summary (Step 2)—Add Connection (Unbridged 
Libraries Only)

Sample Screen

Description

Enables you to configure the connection between a host and the selected partition of 
an unbridged library.

This screen is a dialog box that appears when you click Add Connection on the 
“Partitions—Summary (Step 2)” on page 140 screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Initiator (WWPN)

Required.

World Wide Port Name of the host bus adapter (HBA). 

Sixteen hexadecimal digits. You can enter upper- or lower-case hex digits, but the 
display is always shown in all upper-case. 
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LUN

Required.

Logical unit number of the library partition as seen from the host. This entry must 
be unique on the host. You can create up to nine unique LUNs per partition. 

Note – Each initiator connected to the library must have one 
library partition assigned to LUN 0. When you verify or commit 
partition configuration changes, the SL Console will notify you if 
an initiator does not meet this requirement. 

Buttons and Controls

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• “Partitions—Summary (Step 2)” on page 140 
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Partitions—Summary (Step 2)—Delete Connection (Unbridged 
Libraries Only)

Sample Screen

Description

Enables you to delete the selected host-partition connection. 

This screen is a message that appears when you click Delete Connection on the 
“Partitions—Summary (Step 2)” on page 140 screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

None

Buttons and Controls

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 
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See Also

• “Partitions—Summary (Step 2)” on page 140 
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Partitions—Summary (Step 2)—Modify Connection (Unbridged 
Libraries Only)

Sample Screen

Description

In an unbridged library, enables you to modify the configuration of the selected host-
partition connection. 

This screen is a dialog box that appears when you click Modify Connection on the 
Partitions—Summary (Step 2)—Modify Connection (Unbridged Libraries Only) 
screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Initiator (WWPN)

World Wide Port Name of the FC-SCSI host bus adapter (HBA). 

Sixteen hexadecimal digits. You can enter upper- or lower-case hex digits, but the 
display is always shown in all upper-case. 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 
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LUN

Required.

Logical unit number of the library partition on the host. This entry must be unique 
on the host. 

Note – Each initiator connected to the library must have one 
library partition assigned to LUN 0. When you verify or commit 
partition configuration changes, the SL Console will notify you if 
an initiator does not meet this requirement. 

Buttons and Controls

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• “Partitions—Summary (Step 2)” on page 140 



Partition Summary Screens

152   SL500 User’s Guide

Partitions—Summary (Step 2)—Add Partition 

Sample Screen

Description

Enables you to add a new partition. You can create up to eight partitions, with IDs 
ranging from 1–8. 

This screen is a dialog box that appears when you click Add Partition on the 
“Partitions—Summary (Step 2)” on page 140 screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Select a Partition ID

Required.

Partition ID you want to add. Options are 1–8. 
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The list displays all available IDs. The default is the next available ID in numerical 
order. 

Name 

Optional.

Name you want to assign to the partition. 

0–60 ASCII characters.

Barcode Presentation 

Required.

Tape cartridge bar code format to be used for the partition. 

The drop-down menu displays all available formats previously defined by your 
Oracle support representative. The default is “Left 6 label characters.” 

Buttons and Controls

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• “Partitions—Summary (Step 2)” on page 140 
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Partitions—Summary (Step 2)—Delete Partition

Sample Screen

Description

Enables you to confirm that you want to delete the specified partition. All 
information for the partition – including host-partition connections, partition 
boundaries, and partition ID – are deleted from the SL Console partition workspace. 

This screen is a message that appears when you click Delete Partition on the 
“Partitions—Summary (Step 2)” on page 140. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

None

Buttons and Controls

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 
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See Also

• “Partitions—Summary (Step 2)” on page 140 
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Partitions—Summary (Step 2)—Modify Partition

Sample Screen

Description

Allows you to modify the name or barcode format of the selected partition.

This screen is a dialog box that appears when you click Modify Partition on the 
“Partitions—Summary (Step 2)” on page 140 screen. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Modify Partition n 

Display only.

ID of the partition you want to modify. 
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Name 

Required.

Name you want to assign to the partition. 

0–60 ASCII characters.

The screen displays the value assigned previously. You can leave it as is or make 
changes. 

Barcode Presentation 

Tape cartridge bar code format to be used for the partition. 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 

The list displays all available formats previously defined by your Oracle support 
representative. The default is “Left 6 label characters.” 

The screen displays the value assigned previously. You can leave it as is or make 
changes. 

Buttons and Controls

OK

Click to update the SL Console partition workspace with the current screen 
settings and return to the previous screen. 

Note – Clicking this button does not update the library controller 
database. 

Cancel

Click to discard the current screen settings and return to the previous screen. 

See Also

• “Partitions—Summary (Step 2)” on page 140 



Partition Design and Commit Screens

158   SL500 User’s Guide

Partition Design and Commit Screens
• “Partitions—Design (Step 3)” on page 159

• “Partitions—Commit (Step 4)” on page 168

• “Partitions—Commit (Step 4)—Confirm Apply” on page 170
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Partitions—Design (Step 3)

Sample Screen (Bridged Library)
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Sample Screen (Unbridged Library)

Description

Enables you to define partition boundaries by selecting the resources (storage cells, 
tape drives, or CAP cells) you want to include in the partition. You can use any of the 
following methods to add or remove resources from a partition (see “Library Map 
(not labeled)” on page 162 for detailed instructions): 

• Select individual cells or groups of cells 

• Select a side within a library module

• Select an entire library module

Caution – Changing partition boundaries can result in orphaned 
cartridges and data that could be lost. See “Planning for 
Partitioning” on page 87 for details. 

• Select a bridge drive (bridged libraries only)
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Note – The partition Summary (Step 2) and Design (Step 3) 
screens, and all associated messages, give you a dynamic 
workspace to design your library partitions. All partition 
configuration information is automatically saved to the partition 
workspace in SL Console memory and retained for the duration of 
your SL Console session. This allows you to switch among 
partition views and leave and return to the partition screens any 
number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Allocated to Partition [1-8]

Note –  The data in these fields is automatically updated from the 
SL Console partition workspace when you select a partition.

Display only.

Total numbers of Storage Cells, tape Drives, and CAP Cells allocated to the 
selected partition, based on the currently defined partition boundaries. 

Unallocated in Library 

Note – The data in these fields is automatically updated from the 
SL Console partition workspace when you select a partition.

Display only.

Total numbers of Storage Cells, tape Drives, and CAP Cells in the library that are 
not yet allocated to a partition.

Legend 

Legend for the library map. The state of each library resource (storage cell, tape 
drive, or CAP cell) is indicated as follows: 

• Not Accessible (white and x-ed out). Resource is not accessible to any 
partition, possibly because storage cells have been configured for diagnostic 
cartridges. 
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• Available (white). Resource is currently not allocated to any partition and 
therefore available to the selected partition. 

• Partition n (gold). Resource is allocated to the selected partition, partition n. 

• Other Partitions (red). Resource is allocated to another partition and therefore 
NOT available to the selected partition. 

• Cartridge (cartridge icon). Resource contains a tape cartridge. 

• Bridge capable (bridge icon, bridged libraries only). When allocated to a 
partition, the drive can carry the control path for the other allocated drives.

Library Map (not labeled)

Graphical representation of the current library configuration. Initial display for 
the current SL Console login session is from the library controller database, and 
then the display reflects data from the SL Console partition workspace as you 
modify partition configurations. The display includes the following information:

• Types of modules installed in the library (base module, drive module, storage 
module)

• Numeric module ID (1–5)

• Media configuration for each module (mixed media or LTO only) 

• Location of all resources (storage cells, tape drives, CAP cells) within the 
library 

Note – Move the cursor over any resource to display a tooltip of 
detailed information about the cell or drive, its partition 
assignment, and the identity of any resident cartridge. 

Note – If no partition IDs have been defined, the library map is 
display only.

Use the library map to modify the boundaries of the selected partition. Depending 
on whether you have clicked the Add or Remove radio button, all selected 
resources are either added to or removed from the partition. 

Depending on your choice in the Select by field, you can perform any of the 
following actions. 

• Select by cell: Select individual or groups of resources. Resources in a partition 
do not need to be adjacent to one another. 

• To select an individual resource, double-click it.

• To select a rectangular group of resources, click the cell or drive at one 
corner of the rectangle, and then click the cell or drive diagonally opposite. 

• Select by side: Select an entire side within a module, except the CAP. Sides in a 
partition do not need to be adjacent to one another. To select one side of a 
library module, click any resource in that side. 

• Select by module: Select an entire module, except the CAP. Modules in a 
partition do not have to be adjacent to one another. To select a library module, 
click any resource in that module. 



Partition Design and Commit Screens

Library Partitioning   163 

Buttons and Controls

Partition

Required.

Selectable list of available partitions.

Select the partition for which you want to assign resources (storage cells, tape 
drives, or CAP cells). 

The list displays all valid partition IDs for the library. If no partition IDs have been 
defined, the menu is blank. 

Note – When you select a partition, the screen is automatically 
updated to display data for that partition from the SL Console 
partition workspace. 

Select by

Required.

Selectable list containing Cell, Side, and Module. 

Define partition boundaries as follows:

• Select Cell to select individual or rectangular groups of resources.

• Select Side to select all resources, except the CAP, on one side of a library 
module. 

• Select Module to select all resources, except the CAP, within a library module. 

Add | Remove

Required.

Radio button.

Click Add to select unallocated library map resources that you want to add to the 
partition design.

Click Remove to select currently allocated library map resources that you want to 
remove from the partition design. 

Bridge Drive (Bridged Libraries Only)

Required.

Selectable list of the drives in the partition that can be bridge drives. Bridge drives 
handle the control path for the other drives in the partition.

Select a drive to designate it as the bridge drive for the partition.

Verify Results

Button.
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Press Verify Results to verify changes that you have made to the partition 
configuration before committing them to the library controller database. The 
Tools > Partitions—Design (Step 3)—Verify Results dialog box appears, 
indicating whether there are any orphaned cartridges or other errors in the current 
partition configuration.

Note – This procedure verifies only one partition at a time. If you 
need to verify multiple partitions, you must repeat this procedure 
separately for each partition. 

Note – This verification is performed on the current partition 
configuration in the SL Console partition workspace only. It does 
not verify current partition boundaries against the library 
controller database. Therefore, it cannot identify configuration 
conflicts that may arise due to other users performing cartridge 
movements or library configuration changes (through the 
command line interface, other SL Console sessions, or host 
applications) at the same time you have made partition changes.

Refresh

Button.

Press to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh 
message appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen.

See Also

• “Partitions—Summary (Step 2)” on page 140  

• “Partitions—Commit (Step 4)” on page 168 

• “Partitions—Reports” on page 174 
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Partitions—Design (Step 3)—Verify Results

Sample Screen

Description

Displays a list of configuration errors in the current SL Console partition workspace. 

This screen is a message that appears when you click Verify Results on the 
“Partitions—Design (Step 3)” on page 159 screen. 

Possible errors include:

• A partition has orphaned cartridges. See “Resolve Orphaned 
Cartridges” on page 110 for details.

• Library resources have been removed from a partition. 

• A host-partition connection does not have a partition assigned to LUN 0 (applies 
to FC-SCSI connections only). 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the 
library controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 
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Note – The partition Summary (Step 2) and Design (Step 3) 
screens, and all associated messages, give you a dynamic 
workspace to design your library partitions. All partition 
configuration information is automatically saved to the partition 
workspace in SL Console memory and retained for the duration of 
your SL Console session. This allows you to switch among 
partition views and leave and return to the partition screens any 
number of times without losing your configuration changes. 

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Note – The screen fields are the same as those displayed in the 
“Partitions—Commit (Step 4)—Confirm Apply” on page 170 
message. 

Warnings found

Display only.

Summary error messages regarding the partition configuration. 

The following hosts will need re-audited

Display only.

World Wide Port Names (WWPNs) of any hosts that should re-audit their library 
partition. This may be because library resources have been deleted from the 
partition. 

The following hosts do not have Lun 0 set

Display only.

World Wide Port Names (WWPNs) of any hosts that have not defined any library 
partitions as LUN 0 on the host. 

The following orphaned cartridges were found

Display only.
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Detailed information regarding all orphaned cartridges in the current partition 
configuration. Includes library, rail, column, side, and row location of the 
cartridge, cartridge volume serial number (VOLID), and probable causes and 
explanations why the cartridge is orphaned. 

Buttons and Controls

Print

Click to print the report on a selected printer.

Save

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

OK

Click to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

Details 

Click to toggle between the expanded and collapsed views of the warning 
message display. 

See Also

• “Partitions—Design (Step 3)” on page 159 

• “Partitions—Commit (Step 4)—Confirm Apply” on page 170 
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Partitions—Commit (Step 4)

Sample Screen

Description

Commits the changes made in the current SL Console partition workspace to the 
library controller database and alters the partitioning of the library. 

Caution – Although partition changes are not disruptive to library 
hosts, it is recommended that you make the library unavailable to 
other users before committing your partition workspace changes. 
Because the SL Console does not validate partition boundaries 
against the library controller database in real-time, configuration 
conflicts may arise if you change partition boundaries while other 
users are performing cartridge movements or library configuration 
changes.

Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Caution – It is recommended that you follow the procedure 
“Resolve Orphaned Cartridges” on page 110 before using this 
screen. 
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Caution – The Apply button on this screen updates the library 
controller database with all partition configuration changes you 
have made during this SL Console session. Failure apply changes 
before logging out of the current SL Console session will cause all 
your library configuration changes to be lost.

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

None 

Buttons and Controls

Apply

Click to update the library controller database with the current settings from the 
SL Console partition workspace. The Tools > Partitions—Commit 
(Step 4)—Confirm Apply message appears, indicating whether there are any 
orphaned cartridges or other errors in the current partition configuration. 

Note – This button is grayed out if you have not made any 
changes to the SL Console partition workspace since the last 
commit. 

? (Help) 

Click to display online help for the screen.

See Also

• “Partitions—Summary (Step 2)” on page 140 

• “Partitions—Design (Step 3)” on page 159 

• “Partitions—Commit (Step 4)—Confirm Apply” on page 170 

• “Partitions—Reports” on page 174 
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Partitions—Commit (Step 4)—Confirm Apply

Sample Screen

Description

Displays a list of configuration errors in the current SL Console partition workspace. 
This screen is a message that appears when you click Apply on the 
“Partitions—Commit (Step 4)” on page 168 screen. 

After viewing the error messages, you can commit all data in the SL Console partition 
workspace to the library controller database by clicking the Yes button. 

Possible errors include:

• A partition has orphaned cartridges. See “Resolve Orphaned 
Cartridges” on page 110 for details.

• Library resources have been removed from a partition. 

• A host-partition connection does not have a partition assigned to LUN 0 (applies 
to FC-SCSI connections only). 

If any of these error conditions are present, the screen initially displays summary 
warning messages. You can view detailed messages by clicking the Details button. 

It is recommended that you resolve all errors before committing the data to the 
library controller database. 

Optionally, you can print the screen data or save it to a comma-separated file. 
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Caution – Information in the SL Console partition workspace is 
saved to the library controller database only through the Commit 
(Step 4) screen. If your SL Console session ends or you refresh the 
workspace data before you have committed your updates through 
the Commit (Step 4) screen, you will lose any partition changes you 
have made through the Summary (Step 2) and Design (Step 3) 
screens and all associated messages. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Warnings found

Display only.

Summary error messages regarding the partition configuration. 

The following hosts will need re-audited

Display only.

World Wide Port Names (WWPNs) of any hosts that should re-audit their library 
partition. This may be because library resources have been deleted from the 
partition. 

The following hosts do not have Lun 0 set

Display only.

World Wide Port Names (WWPNs) of any hosts that have not defined any library 
partitions as LUN 0 on the host. 

The following orphaned cartridges were found

Display only.

Detailed information regarding all orphaned cartridges in the current partition 
configuration. Includes library, rail, column, side, and row location of the 
cartridge, cartridge volume serial number (VOLID), and probable causes and 
explanations why the cartridge is orphaned. 

Buttons and Controls

Print

Click to print the report on a selected printer.
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Save 

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

Yes

Click to confirm that you want to update the library controller database with the 
current settings from the SL Console workspace. 

No

Click to cancel the update. The library controller database is not updated, but all 
partition changes from this login session are retained in the SL Console partition 
workspace. 

Details 

Click to toggle between the expanded and collapsed views of the warning 
message display. 

See Also

• “Partitions—Commit (Step 4)” on page 168 

• “Partitions—Design (Step 3)—Verify Results” on page 165
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Partition Report Screens
• “Partitions—Reports” on page 174

• “Partitions—Reports—Cartridge Cell and Media Summary” on page 176

• “Partitions—Reports—Host Connections Summary” on page 179

• “Partitions—Reports—Orphaned Cartridge Report” on page 184

• “Partitions—Reports—Partition Details” on page 186

• “Partitions—Reports—Partition Summary” on page 189
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Partitions—Reports

Sample Screen

Description

Enables you to generate library partition reports for the most recently committed 
configuration.

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without committing the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3) screens. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Please select a report to display

Required.

Selectable list of Cartridge Cell and Media Summary, Host Connections 
Summary, Orphaned Cartridge Report, Partition Details, and Partition 
Summary.

Select the report that you want to display. 

Buttons and Controls

? (Help) 

Click to display online help for the screen. 

See Also

• “Partitions—Summary (Step 2)” on page 140 
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• “Partitions—Design (Step 3)” on page 159 

• “Partitions—Commit (Step 4)” on page 168 

• “Partitions—Reports—Cartridge Cell and Media Summary” on page 176 

• “Partitions—Reports—Host Connections Summary” on page 179 

• “Partitions—Reports—Orphaned Cartridge Report” on page 184 

• “Partitions—Reports—Partition Details” on page 186 

• “Partitions—Reports—Partition Summary” on page 189 
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Partitions—Reports—Cartridge Cell and Media Summary

Sample Screen

Description

Lists storage cells, CAP cells, drives, and resident cartridges.

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without committing the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3) screens. 

Note – You can modify the layout and display of this screen. See 
“Modifying the Screen Layout” on page 27 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Module

Display only.
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Module where the library resource is located. 

Row

Display only.

Row number where the library resource is located. Rows are numbered 
consecutively from the top down, with row 1 at the top.

Column

Display only.

Column number where the library resource is located. Column location is 
referenced from the center of the drive bays. To the right of the drive bays is +1 
and to the right is. -1.

Cell Status

Display only.

Partition status of the library resource. Options are:

• Assigned

• Unassigned

Partition ID

Display only.

Partition ID to which the library resource is allocated, if applicable. 

Partition Name

Display only.

Name of the partition to which the library resource is allocated, if applicable. 

SCSI Element

Display only.

Host SCSI element number assigned to the library resource. SCSI element 
numbers are continuous within a partition, even if resources are not adjacent.

Element Type

Display only.

Type of library resource. Options are:

• CAP

• CELL

• DRIVE
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Vol Ser 

Display only.

Volume serial number (VOLID) of the cartridge resident in the library resource, if 
applicable. 

Buttons and Controls

Print

Button.

Click to print the report on a selected printer.

Save to File

Button.

Press to save the report to a comma-separated value (.csv) file compatible with 
many spreadsheet applications. 

? (Help) 

Click to display online help for the screen.

See Also

• “Partitions—Reports—Host Connections Summary” on page 179 

• “Partitions—Reports—Orphaned Cartridge Report” on page 184 

• “Partitions—Reports—Partition Details” on page 186 

• “Partitions—Reports—Partition Summary” on page 189 
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Partitions—Reports—Host Connections Summary

Sample Screen (Bridged Library)
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Sample Screen (Unbridged Library)

Description

Displays host-partition connections for the library. 

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without committing the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3) screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 27 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console
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Screen Fields

Partitions (Unbridged Libraries)

Note – The screen fields in this section also appear on the 
“Partitions—Reports—Partition Summary” on page 189 report.

Partition ID

Display only.

ID of the partition (1–8). 

Partition Name

Display only.

Name of the partition, if any. 

Cell Count

Display only.

Total number of storage cells allocated to the partition.

Drive Count

Display only.

Total number of tape drives allocated to the partition. 

CAP Count

Display only.

Total number of CAP cells allocated to the partition. 

Cartridge Count

Display only.

Total number of tape cartridges resident in the partition. 

% of Cells with Media

Display only.

Percentage of storage cells containing tape cartridges (Cartridge Count divided by 
Cell Count times 100). 

Partitions (Bridged Libraries)

Partition ID

Display only.

ID of the partition (1–8). 
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Partition Name

Display only.

Name of the partition, if any. 

Storage Cells

Display only.

Total number of storage cells allocated to the partition.

Media in Storage Cells

Display only.

Total number of cartridges resident in storage cells that are allocated to the 
partition.

% Storage Cells w/ Media

Display only.

The percentage of the total storage cells allocated to the partition that contains 
cartridges.

Drives

Display only.

Total number of drives allocated to the partition.

CAPs

Total number of Cartridge Access Ports (CAPs) allocated to the partition.

*Total Media

Display only.

Total number of cartridges resident in the partition (includes media resident in 
allocated drives, storage cells, and CAP cells).

Host Connections (Unbridged Libraries)

Initiator WWPN

Display only.

World Wide Port Name of a host bus adapter (HBA) with a connection to the 
partition. 

Library Controller Port

Display only.

The port on the SL500 library controller card that connects to this host port.
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LUN

Display only.

Logical unit number of the library partition as seen from the host.

Partition ID 

Display only.

Partition ID to which the host has a connection. 

Host Connections (Bridged Libraries)

Bridging Drive Slot

Display only.

Location of the bridge drive that provides the control path for this partition.

LUN

Display only.

Logical unit number of the library partition as seen from the host.

Partition ID 

Display only.

Buttons and Controls

Print

Click to print the report on a selected printer.

Save to File 

Click to save the report to a designated comma-separated text file (.csv extension). 
Comma-separated files can be opened by a variety of spreadsheet and database 
programs. 

? (Help) 

Click to display online help for the screen.

See Also

• “Partitions—Reports—Cartridge Cell and Media Summary” on page 176 

• “Partitions—Reports—Orphaned Cartridge Report” on page 184 

• “Partitions—Reports—Partition Details” on page 186 

• “Partitions—Reports—Partition Summary” on page 189 
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Partitions—Reports—Orphaned Cartridge Report 

Sample Screen

Description

Displays the locations and volume serial numbers (VOLIDs) of all orphaned 
cartridges in the library. Also identifies why the cartridge is orphaned. 

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without committing the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3) screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 27 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Module

Display only.

Module number where the orphaned cartridge is located. 
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Row

Display only.

Row number where the orphaned cartridge is located. Rows are numbered 
consecutively from the top down, with row 1 at the top.

Column

Display only.

Column number where the orphaned cartridge is located. Column location is 
referenced from the center of the drive bays. +1 is to the right of the drive bays; -1 
is to the left.

Vol Ser 

Display only.

Volume serial number (VOLID) of the orphaned cartridge. 

Explanation

Display only.

Explanation of why the cartridge is orphaned. 

Because this report is produced from the library controller database, the only 
option is:

• Unreachable from any host 

Buttons and Controls

Print

Button. Press to print the report on a selected printer.

Save to File 

Button.

Press to save the report to a comma-separated value (.csv) file compatible with 
many spreadsheet applications.

? (Help) 

Click to display online help for the screen.

See Also

• “Partitions—Reports—Cartridge Cell and Media Summary” on page 176 

• “Partitions—Reports—Host Connections Summary” on page 179 

• “Partitions—Reports—Partition Details” on page 186 

• “Partitions—Reports—Partition Summary” on page 189 
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Partitions—Reports—Partition Details

Sample Screen

Description

Displays a sortable table of name/value pairs for each of the properties of the 
selected partition. 

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without committing the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3) screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 27 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console
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• Web-launched SL Console

Screen Fields

Name

Display only.

Display only.

Name of the partition property. 

Value

Display only.

The value of the partition property.

Partition properties include:

• Partition ID

A digit in the range [1–8]. 

• Bar Code

The bar code format used on cartridges assigned to the partition. 

• Assigned Cells

The total number of storage cells allocated to the partition.

• Available Cells 

Total number of storage cells in the library available for allocation to the partition.

• Occupied Cells 

Total number of storage cells in the partition with tape cartridges present.

• Assigned Drive Bays 

Total number of drive bays allocated to the partition.

• Available Drive Bays 

Total number of drive bays in the library available for allocation to the partition.

• Occupied Drives 

Total number of installed tape drives in the partition with tape cartridges present.

• Assigned CAP cells 

Total number of CAP cells allocated to the partition through dedicated or shared 
CAPs. 

• Available CAP cells

• Total number of CAP cells in the library available for allocation to the partition. 
This number includes all CAP cells in CAPs not allocated to any partition.

This number excludes all cells in the CAPs allocated to this partition. 

• Occupied CAP cells
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Total number of CAP cells in the partition with tape cartridges present.

• Percent Slot Capacity

The percentage of storage cells in the library allocated to this partition (the 
number of cells allocated to the partition divided by the total physical capacity of 
the library) 

Buttons and Controls

Print

Button.

Click to print the report on a selected printer.

Save to File 

Button 

Press to save the report to a comma-separated value (.csv) file compatible with 
many spreadsheet applications.   

? (Help) 

Click to display online help for the screen.

See Also

• “Partitions—Reports—Cartridge Cell and Media Summary” on page 176 

• “Partitions—Reports—Host Connections Summary” on page 179 

• “Partitions—Reports—Orphaned Cartridge Report” on page 184 

• “Partitions—Reports—Partition Summary” on page 189 
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Partitions—Reports—Partition Summary

Sample Screen

Description

Displays summary information for all partitions in the library. 

Note – The partition reports display data saved to the library 
controller database. If you have made partition configuration 
changes without committing the changes to the library controller 
through the Commit (Step 4) screen, the data in these reports will 
differ from data shown on the partition Summary (Step 2) and 
Design (Step 3) screens. 

You can modify the layout and display of this screen. See “Modifying the Screen 
Layout” on page 27 for details. 

Optionally, you can print the screen data or save it to a comma-separated file.

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console
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Screen Fields

Note – These screen fields also appear on the 
“Partitions—Reports—Host Connections Summary” on page 179 
report.

Partition ID

Display only.

ID of the partition (1–8). 

Partition Name

Display only.

Name of the partition. 

Cell Count

Display only.

Total number of storage cells allocated to the partition.

Drive Count

Display only.

Total number of tape drives allocated to the partition. 

CAP Count

Display only.

Total number of CAP cells allocated to the partition. 

Cartridge Count

Display only.

Total number of tape cartridges resident in the partition. 

% of Cells with Media

Display only.

Percentage of storage cells containing tape cartridges. Calculated as Cartridge 
Count / Cell Count. 

Partition ID

Display only.

A digit in the range [1–8]. 

Partition Name

Display only.

The name of the partition, if any. 
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Storage Cells

Display only.

Total number of storage cells allocated to the partition.

Media in Storage Cells

Display only.

Total number of cartridges resident in storage cells that are allocated to the 
partition.

% Storage Cells w/ Media

Display only.

The percentage of the total storage cells allocated to the partition that contains 
cartridges.

Drives

Display only.

Total number of drives allocated to the partition.

CAPs

Total number of Cartridge Access Ports (CAPs) allocated to the partition.

*Total Media

Display only.

Total number of cartridges resident in the partition (includes media resident in 
allocated drives, storage cells, and CAP cells).

Buttons and Controls

Print

Button.

Click to print the report on a selected printer.

Save to File 

Button 

Press to save the report to a comma-separated value (.csv) file compatible with 
many spreadsheet applications.   

? (Help) 

Click to display online help for the screen.
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See Also

• “Partitions—Reports—Cartridge Cell and Media Summary” on page 176 

• “Partitions—Reports—Host Connections Summary” on page 179 

• “Partitions—Reports—Orphaned Cartridge Report” on page 184 

• “Partitions—Reports—Partition Details” on page 186 
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Partition CAP Operation Screens
• “Diagnostics > CAP—Assign CAP Button” on page 194
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Diagnostics > CAP—Assign CAP Button

Sample Screen

Description

Allows you to select the partitions to which you want to assign the CAP Open button 
on the library control panel. After using this screen, the following actions occur when 
you press the CAP Open button: 

• The library opens the doors of all CAPs containing cells accessible to the partitions 
selected on this screen. 

• The library sends CAP status messages to all hosts with access to the exposed 
cells. 

• Doors to CAPs that contain only inaccessible cells do not open. 

• Doors to CAPs with cartridges in inaccessible cells do not open. 

Note – Depending on how your library’s CAPs are configured, 
this operation may expose CAP cells that are not accessible to the 
requesting host’s partition.

Note – Although it is possible to enter cartridges through a CAP 
without using the Assign CAP Button screen, it is recommended 
that you access the screen first to verify the partition settings. This 
will help prevent cartridges from being entered inadvertently into 
the wrong partition. 
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See “Enter Cartridges Into a Partitioned Library” on page 130 for complete details on 
using this screen in conjunction with the CAP Open button. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Screen Fields

Partitions with common CAP configuration

Required.

Partitions with access to common CAP cells are displayed in this table in black 
type. Partitions that have not been configured are grayed out. 

Select the partition for which you want to enter or eject cartridges. You can select 
only one partition at a time from this table. Options are:

• 1–8: Click the radio button to select the partition. 

• None (Common only): Click the radio button to deselect all partitions in this 
table. This indicates that the enter or eject operation does not involve any 
partitions with access to common CAP cells. 

Partitions with split CAP configuration

All partitions with access to split CAP cells are displayed in this table.

Select the partitions for which you want to enter or eject cartridges. You can select 
more than one partition at a time from this table. Deselecting all check boxes 
indicates that the enter or eject operation does not involve any partitions with 
allocated CAP cells. 

Options are:

• 1–8: Select the check box to select the partition. Deselect the check box to 
deselect the partition. 

• All (Split only): Select the check box to select all partitions in this table. 

Buttons and Controls

Apply

Click to update the library controller database with the current settings from this 
screen. The CAP Confirm message appears, prompting you to confirm the update. 

Refresh

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh 
message appears, prompting you to confirm the refresh. 



Partition CAP Operation Screens

196   SL500 User’s Guide

? (Help) 

Click to display online help for the screen.

See Also

None
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6

Library Management

This chapter covers the management of the SL500 library, including:

• “Automated Mode of Operation” on page 197

• “Library and Device Status” on page 199

• “Library Management Tasks” on page 201

Automated Mode of Operation
When in automated mode of operation, the library or library complex automatically 
mounts and dismounts cartridges without physical intervention by a person.

Automated operations include the following activities:

• Mounting and dismounting cartridges

• Entering and ejecting cartridges through a CAP 

• Pass-thru port (PTP) activities 

• Logging library events

• Drive cleaning 

Cartridge Mount and Dismount Activities

The primary function of the library is the automated mounting and dismounting of 
cartridges. Host mount and dismount commands are accepted by the library 
controller and translated into robotic commands that are performed by the robot. 

Mount Sequence

A simplified mount sequence involves the following steps:

1. A host requests that a specific volume serial number (vol-id or volser) be mounted 
in a drive.

2. The library controller transmits to the host that the vol-id is located within the 
library and a drive is available to satisfy the mount request.

3. The library assumes responsibility for the mount.
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4. The library controller translates the host command into motion commands for the 
robot.

5. The robot takes the cartridge from its storage cell and places it in the drive.

6. The library returns status to the host that the mount operation is completed.

7. The drive performs the read/write activity directed by the host.

Dismount Sequence

A simplified dismount sequence involves the following steps:

1. A host requests that a specific vol-id be dismounted from a drive.

2. The library controller transmits to the host that the vol-id is located in the drive 
and the library is available to satisfy the dismount request.

3. The library assumes responsibility for the dismount.

4. The library controller translates the host command into mechanical commands for 
the robot.

5. The robot takes the cartridge from its storage cell and places it in its home cell.

6. The library returns status to the host that the dismount operation is completed.

Determining When the Library is Not in Automated Mode 

The library is not in automated mode when it is not able to accept host requests. The 
following conditions indicate that the library is not in automated mode:

• A library main access door is open. 

• The robot does not automatically mount and dismount cartridges. 

• The navigation tree in the SL Console indicates that there is a problem with the 
library.
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Library and Device Status
The SL Console screen displays health indicators for each of the following devices:

• Library 

• CAPs 

• Drives

• Robot

FIGURE 6-1 describes the health monitor indicators.

Health status indicator and icon descriptions follow:

1: Health status by each device:

• 5: Normal. All library devices are functioning normally. (Green circle with 
check mark)

• 6: Warning. One or more devices in the library is offline or operating in a 
degraded state. (Yellow caution triangle with exclamation point)

FIGURE 6-1  SL Console Health Status Indicators
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• 7: Error. One or more devices in the library has experienced a failure. (Red stop 
sign shape with black X)

• 2: Communication status between SL Console and library controller

• 5: Normal. The heartbeat monitor flashes periodically when the SL Console is 
communicating normally with the library controller. (Green circle with check 
mark)

• 6: Warning. Appears if the server takes longer than 10 seconds to respond. 
(Yellow caution triangle with exclamation point)

• 7: Error. Appears when the server response takes longer than 30 seconds. (Red 
stop sign shape with black X)

• 3: Userid: User ID currently logged into the SL Console

• 4: Overall health status of library and devices

• 5: Normal. All library devices are functioning normally. (Green circle with 
check mark)

• 6: Warning. One or more devices in the library is offline or operating in a 
degraded state. (Yellow caution triangle with exclamation point)

• 7: Error. One or more devices in the library has experienced a failure. (Red stop 
sign shape with black X)

If there are multiple problems with a device or status alert conditions, the health 
indicator displays the one that is most severe. For example, if the library has been 
taken offline (a “yellow” condition) and a CAP has experienced a failure (a “red” 
condition), the library health indicator will be red. After the CAP problem is fixed, 
the library health indicator will change to yellow. The indicator will not return to 
green until the library has also been taken online. 

Communications Failures

If the SL Console loses communication with the library controller, after about 30–60 
seconds the heartbeat monitor turns gray, then red, and the following error message 
appears:
Heartbeat message not received from the library controller.

Log off from the SL Console, and then log on again to restore communication.
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Library Management Tasks
• “Display Library Status” on page 202

• “Display Library Configuration Properties” on page 203

• “Set Up an FC Control Path on an Unbridged Library” on page 207

• “Display Library Controller Properties” on page 208

• “Display Library Physical Configuration” on page 209

• “Display Library SCSI Configuration” on page 210

• “Display Library Statistics” on page 213

• “Display the Library Utilization Reports” on page 214
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▼ Display Library Status

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to view the current operational state of the library. These values 
update whenever there is host activity, background operations, or operator activity.

Note – This information is also available through 
Reports > Library Details. See “Display a Library 
Report” on page 47 for detailed instructions. 

Task Steps

1. Select Tools > System Detail, and click the Library folder in the navigation tree.

2. Click the Status tab, and then the General tab.

The page displays the current status of the library. 
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▼ Display Library Configuration Properties

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the physical, mechanical, logical, and network 
configuration of the library. Some of the information can be set up automatically 
during library initialization, while other information can be defined by the user.

This information is also available through Reports > Library Information. See 
“Display a Library Report” on page 47 for detailed instructions.

Task Steps

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the General tab.

The page displays the properties specific to a Bridged library or an Unbridged 
library: 

• Bridged library
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• Unbridged library

Screen Fields

Vendor 

Vendor is STK (for Oracle StorageTek). 

Serial Number

Serial number of the library base module. 

Library Base WWN

World Wide Node Name (WWNN) for the library. 

Module Count

Total number of modules in the library. 

Total Cell Count 

Total number of physical storage cells installed in the library. Includes data 
cartridge cells as well as reserved system cells. Not all of these cells may be 
enabled for use, however. 
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Empty Cell Count 

Total number of unoccupied data storage cells. 

Drive Count

Total number of drives installed. 

CAP Cell Count

Total number of CAP (cartridge access port) cells. 

Library Interface TCP/IP

These fields apply to the standard library TCP/IP port. 

DNS Domain Name

DNS domain name assigned to the library. 

IP Address

IPv4 (IP version 4) address for the port, if applicable. 

IP Subnet Mask 

Netmask defined for the subnet that the port is on. 

MAC Address

MAC address for the port. 

Library Host Interface

Interface Type

Type of host-library interface. Options are:

• Bridged 

• Fibre (Fibre Channel)

• LVD (parallel LVD SCSI)

LVD Target ID (Unbridged Library Only)

SCSI target identifier that identifies the library controller to the initiator on the 
host.

World Wide Name Node (Unbridged Library Only)

The World Wide Node Name (WWNN) that identifies the library on a Fibre 
Channel Storage Area Network (SAN). The WWNN is a 64-bit hardware identifier 
in IEEE format. It is set at the factory and cannot be changed.
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Port A World Wide Name (Unbridged Library Only)

The World Wide Port Name (WWPN) that identifies controller port A on a Fibre 
Channel Storage Area Network (SAN). The WWPN is a 64-bit hardware identifier 
in IEEE format. It is set at the factory and cannot be changed.

Port A Enabled (Unbridged Library Only)

Possible values include:

• true: enables FC-AL static (hard) addressing

• false: enables FC-AL dynamic (soft) addressing

Port A Loop ID (Unbridged Library Only)

The identifier for controller port A when used on a Fibre Channel Arbitrated Loop 
(FC-AL) Storage Area Network (SAN). If static (hard) addressing is used, the 
Loop ID is in the range 1-125. If dynamically arbitrated (soft) addressing is used, 
the Loop ID is 126.

Port A speed (Unbridged Library Only)

The Fibre Channel data transfer rate between the host and controller port A.

Port A topology (Unbridged Library Only)

The Fibre Channel storage area network topology that connects controller port A 
to the host.
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▼ Set Up an FC Control Path on an Unbridged Library

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

If the control path for the library is Fibre Channel (FC), you must set up the Fibre 
Channel port (Port A) on the library controller.

Task Steps

1. Select Tools > System Detail, and click the Library folder. 

2. Select Properties > General.

The page displays detailed information about the library. 

3. If you are using a Fibre Channel Arbitrated Loop (FC-AL) topology and static 
(hard) addressing on the Storage Area Network, set the Port A Enabled control 
to true and enter the correct Loop ID in the Port A Loop ID field.

FC-AL Loop IDs fall in the range 1-125.

4. If you are using a Fibre Channel Arbitrated Loop (FC-AL) topology and 
dynamically arbitrated (soft) addressing on the Storage Area Network, set the 
Port A Enabled control to false and enter 126 in the Port A Loop ID field.

5. Click Apply to save the changes.

6. Reboot the library for the changes to take effect. 
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▼ Display Library Controller Properties 

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to view details of the library controller, including the serial 
number and firmware versions.

Note – This information is also available through 
Reports > Library Information. See “Display a Library 
Report” on page 47 for detailed instructions.

Task Steps

1. Select Tools > System Detail, and click the Library folder. 

2. Click the Properties tab, and then the Library Controller tab.



Library Management Tasks

Library Management   209 

▼ Display Library Physical Configuration

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to view the current physical configuration of the library. 

Task Steps

1. Select Tools > System Detail, and click the Library folder.

2. Click the Properties tab, and then the Module tab.
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▼ Display Library SCSI Configuration

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to view the configuration of the library SCSI ports. 

Task Steps

1. Select Tools > System Detail, and click the Library folder.

2. Click the Properties tab, and then the SCSI tab.

The interface displays the SCSI Port screen for a bridged library or an unbridged 
library:

• Bridged libraries display the:

• Partition ID (a digit in the range [1-8] or 0 if unconfigured)

• Bridge Drive Slot number

• Bridge drive’s L,M,R,C (Library, Module, Row, and Column) library address

• Drive Health

• Statuses of Port A and Port B

• Bridge Health

• Drive’s Node WWN (World Wide Name)

• Drive manufacturer’s Serial Number

• Drive Type

• Drive Interface
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• Drive’s SCSI Element Address.

• Unbridged libraries display the fields:

• Port Number

• Health State

• Access State

• Topology

• Port Speed

• Fibre Channel arbitrated Loop ID

• FC WWN (Fibre Channel World Wide Name) Port Name and Node Name

Screen Fields

Bridged Libraries

Partition

The partition ID, a digit in the range [1-8] or 0 if no partitions are configured.
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Bridge Drive Slot

The slot location of the drive that handles the control path for the drives allocated 
to the partition. 

L,M,R,C

Library, Module, Row, and Column. The library address of the bridge drive.

Drive Health

The overall condition of the drives allocated to the partition. Check the System 
Details > Drive Folder for details.

Port A, Port B

The status of the SCSI ports.

Bridge Health

The status of the control path to the library.

Node WWN

The Node World Wide Name of the bridge drive.

Serial Number

The manufacturer’s serial number for the drive.

Drive Type

The vendor and LTO (Linear Tape Open) generation. For example, HpUltrium5 is 
the HP Ultrium 5 LTO tape drive.

Interface

The drive interface. For example, SAS (Serial Attached SCSI).

Element Address

The SCSI element address of the drive.
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▼ Display Library Statistics

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to view library statistics, such as the request, retry, and failure 
count of the robot and the library uptime.

Note – This information is also available through 
Reports > Statistics. See  “Display a Library Report” on page 47 
for detailed instructions.

Task Steps

1. Select Tools > System Detail, and click the Library folder.

2. Click the Statistics tab.

The Statistics page appears. 
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▼ Display the Library Utilization Reports

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Library Utilization Reports summarize library activity that has occurred during a 
selected time period. robot, drive, and CAP activity is broken into regular time 
intervals within the time period. You can use this report to determine patterns of 
library activity over time and whether there are peak and low periods of usage. 

By default, the report is sorted chronologically by time interval. Optionally, you can 
change the sort order and rearrange and resize the columns. See “Modifying the 
Screen Layout” on page 27. 

Note – This feature is available starting with SL500 firmware 
version 1393 and SL Console version 4.50. 

To create a chart from this report, save the data to a comma-separated (.csv) file, and 
then import the.csv file into a charting application. For details, see “Save Library 
Report Data to a File” on page 49. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Library Utilization folder in the navigation tree, and select the time 
period for which you want to display summary activity. Options are:

• Last 24 Hours: The previous 24 hours, divided into hourly intervals

• Last 7 Days: The previous 7 days, divided into daily intervals 

• Last Month: The previous 31 days, divided into daily intervals

• Last Year: The previous 52 weeks, divided into weekly intervals 

The selected report displays. 

Screen Fields

Start Date

Display only.

Starting date and time for each interval. 

Percent Utilization 

Display only.

Percentage of time the robot was busy during the time period. This includes time 
spent in the following activities: 
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• Moving cartridges between cells

• Moving cartridges to and from CAPs

• Mounting and dismounting cartridges to and from drives

• Waiting for cartridges to load and thread in drives 

This value is expressed as a percentage of total time in the interval. For example, a 
value of 25.70 means the robot was busy 25.7 percent of the time. The value is 
calculated as follows:

Seconds busy / total seconds in time interval 

Mounts 

Display only.

Total number of cartridge mounts initiated during the selected time period. 

Dismounts 

Display only.

Total number of cartridge dismounts initiated during the selected time period. 

Moves 

Display only.

Total number of cartridge moves from one storage cell to another that were 
initiated during the selected time period. 

CAP-Enters 

Display only.

Total number of cartridge moves from a CAP cell to a storage cell that were 
initiated during the selected time period. 

CAP-Ejects 

Display only.

Total number of cartridge moves from a storage cell to a CAP cell that were 
initiated during the selected time period. 
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Configuring Bridging Without Partitioning

Note – This feature is available starting with SL500 firmware 
version 1431 and SL Console version 5.30. 

Note – The bridging feature enables the StorageTek SL500 library 
controller to communicate with tape drives without having a 
dedicated interface card (such as an Oracle StorageTek MPU2 or 
PUA2 Fibre Channel card or RLW parallel SCSI card). 

Designated Bridge Drive
In bridged libraries, the library controller communicates with the tape drives using 
the Automation Drive Interface (ADI) of a supported tape drive. Each library or 
library partition contains a designated bridge drive that passes command and control 
information between the library controller and the drives in the library or partition. 
When an SL500 library does not detect a dedicated interface card at start up, the 
library adopts a bridged configuration by default.

If you do not previously specify a bridge drive (the drive that performs the tasks 
otherwise handled by an interface card), the library starts from the top of library and 
selects the first  bridge-capable drive it encounters. You can then decide to do one of 
the following:

• Partition the bridged library, as described in “Library Partitioning” on page 83.

• Specify a different bridge-capable drive for the unpartitioned library. In this case, 
use the following procedure.
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▼ Select a Bridge Drive

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Choose the drive for bridging.

Task Steps

1. From the SL Console main menu, select Tools > Bridging. 

2. When the Bridging screens appear, click the Instructions tab and review the 
information provided.

3. Click the Bridge Drive Selection tab.
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4. Use the Bridge Drive list in the upper left corner of the page to select the drive 
you wish to use for library control functions.

The bridge drive list includes only the accessible, bridge-capable drives.

For example, given an SL500 base module with bridge-capable drives installed in 
positions 1 and 2 and an SL500 drive module with a bridge-capable drive in 
position 4, you could choose drive 1, 2, or 4 for your bridge drive. Position 3 is 
inaccessible in this configuration, so the list does not offer 3 as an option.

 

5. Click the Apply button in the upper right corner.

The system enables the new bridge drive.
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Bridging Configuration Screen Reference
• “Bridging—Instructions” on page 221

• “Bridging—Bridge Drive Selection” on page 222

This section includes a detailed description of the SL Console bridging screens for 
bridged libraries. 
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Bridging—Instructions

Sample Screen

Description

Displays instructions for using the bridging screen.

This screen appears automatically the first time you select Tools > Partitions during 
an SL Console login session. 

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SLC

Screen Fields

None

Buttons

? (Help) 

Click to display online help for the screen. 

See Also

“Bridging—Bridge Drive Selection” on page 222
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Bridging—Bridge Drive Selection

Sample Screen

Description 

Displays a:

• Library map showing the locations of the available bridge-capable drives

• Legend listing the icons in the map

• List to select a bridge drive for the library

Screen Access

This screen can be accessed at either of the following:

• Standalone SL Console

• Web-launched SLC

Screen Fields

Legend

Lists icons for the following conditions:
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• Not Accessible: The indicated CAP cell or storage cell is not available for use 
due to limited hardware activation or physical, mechanical restrictions.

• Cartridge: The indicated CAP cell or storage cell contains media. 

• Bridge Capable: The indicated tape drive can be the bridge drive that carries the 
control path for the library.

Buttons and Controls

Bridge Drive

List of tape drives that can carry the control path for the library.

Select a drive from the list.

Apply

Button.

Click to designate the specified drive as the bridge drive for the library.

Refresh

Button.

Click to refresh the SL Console partition workspace with current data from the 
library controller database. All uncommitted partition changes you have made 
during this SL Console login session will be discarded. The Partition Refresh 
message appears, prompting you to confirm the refresh. 

? (Help) 

Click to display online help for the screen. 

See Also

“Bridging—Instructions” on page 221
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 CAP Management

By using cartridge access ports (CAPs), you can enter (or import) or eject (or export) 
cartridges to or from the library.

This chapter describes general CAP activities that apply to the SL500 library.

CAPs
The CAP in the base module has one five-cell magazine. The CAP in the Drive 
Expansion Module (DEM) has two five-cell magazines. Optionally, you can configure 
the CAP cells for cartridge storage instead of enter and eject operations. 

Additional CAP Information

See the following for complete details about CAPs:

• Partition configuration information relating to CAPs: “Library 
Partitioning” on page 83
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CAP Management Tasks
• “Display CAP Summary Information” on page 227

• “Display Current CAP Status” on page 228

• “Display CAP Properties” on page 229
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▼ Display CAP Summary Information

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To display summary information for all CAPs in the library, complete the following 
steps.

Note – This information is also available through 
Reports > CAP Summary. See “Display a Library 
Report” on page 47 for detailed instructions. 

Task Steps

1. Select Tools > System Detail.

2. Select the CAP folder in the navigation tree. 

The system lists all the library’s CAPs and their locations.
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▼ Display Current CAP Status 

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

To display the current operational state of a CAP, complete the following steps. 

Note – This information is also available on the CAP Details 
report. See “Display a Library Report” on page 47 for detailed 
instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and select the CAP you want to display. 

3. Click the Status tab.

The CAP page displays the current status of the selected CAP. 
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▼ Display CAP Properties

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display static information for a CAP, including the serial 
number and number of cells. 

Note – This information is also available through Reports > CAP 
Details. See “Display a Library Report” on page 47 for detailed 
instructions.

Task Steps

1. Select Tools > System Detail. 

2. Expand the CAP Folder, and select the CAP you want to display. 

3. Click the Properties tab. 

The CAP Properties page appears.
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Drive Management

This chapter includes the following topics:

• “Maximum Drive Capacity” on page 231

• “Drive Identification” on page 231

• “Drive States” on page 231

• “Drive Management Tasks” on page 232

Maximum Drive Capacity
You can install up to 18 drives within one library, as follows:

• Up to two in the base module

• Up to four in each Drive Expansion Module (DEM), with a total of four DEMs 
possible

See “LTO Supported Tape Drives” on page 10 for a list of supported tape drives. 

Drive Identification
The library uses the following addressing schemes for each library drive:

• Library internal address: For all drives. Assigned by the library controller based 
on the library, rail, column, side, and row location of the drive. 

• Host SCSI element address: For FC-SCSI host connections only. Assigned by host 
applications. 

• Drive bay address: For all drives. Assigned by the library controller based on the 
physical slot in which the drive is installed. 

Drive States
A drive can be in one of the following states:

• Online: The drive is available for read/write operations.

• Offline: The drive is not available for read/write operations. 
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Drive Management Tasks
• “Display Drive Summary Information” on page 233

• “Display Drive Status” on page 234

• “Display Drive Properties” on page 235

• “Enable or Disable a Drive Port” on page 237

• “Display Current Drive Mappings” on page 238

• “Display Drive Mapping History” on page 240

• “Display the Media Drive Events Report” on page 242

• “Display the Drive Distribution Reports” on page 244

• “Display the Drive Utilization Reports” on page 246

• “Add or Edit Drive Tray Serial Number” on page 248
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▼ Display Drive Summary Information

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display summary information for all drives in the library. 

The following information displays:

• Internal address

• Drive State:

• Empty

• Unloaded: Cartridge is present 

• Ready: Cartridge is loaded

• NotCommunicating

• rewindUnload: Drive is busy rewinding and unloading 

• Drive Type

• Drive serial number

• Current code version

Note – This information is also available through 
Reports > Drive Summary. See “Search a Library 
Report” on page 48 for detailed instructions. 

Task Steps

1. Select Tools > System Detail, and click the Drive folder in the navigation tree. 

The page lists the library drives and displays their locations.

Note – This information is read only.
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▼ Display Drive Status 

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the current operational state of a drive. The information 
includes:

• Current drive and drive tray status information 

• Whether the drive is loaded

• Drive cleaning information

Note – This information is also available through 
Reports > Drive Details. See “Display a Library 
Report” on page 47 for detailed instructions. 

Task Steps

1. Select Tools > System Detail

2. Expand the Drive Folder in the navigation tree, and click the drive you want to 
display. 

3. Click the Status tab.

The page displays the current status of the selected drive. 
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▼ Display Drive Properties 

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

View detailed drive configuration information, including the drive type and serial 
number and port configuration.

Note – This information is also available through 
Reports > Drive Details. See “Display a Library 
Report” on page 47 for detailed instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder in the navigation tree, and click the drive you want to 
display. 

3. Click the Properties tab. 

The Properties page appears. 

Screen Fields

Drive Type

Brand and model of drive.

Code Version

Version of code.

Vendor

Manufacturer of drive.

Serial Number

Serial number of drive.

Interface Type

Type of interface of drive.

Tray Serial Number

Drive tray serial number of drive.
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LVD Target ID

LVD target identification.

World Wide Name Node

Brand and model of drive.

Port A World Wide Name

World Wide Name of node of port A.

Port A Enabled

Whether port A is enabled: true or false.

Port A Loop ID (use 126 for soft addressing)

Loop ID of port A.

Port A Speed (GB)

Speed of port A.

Port A Link Status

Link status of port A.

Port B World Wide Name

World Wide Name of node of port B.

Port B Enabled

Whether port B is enabled: true or false.

Port B Loop ID (use 126 for soft addressing)

Loop ID of port B.

Port B Speed (GB)

Speed of port B.

Port B Link Status

Link status of port B.
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▼ Enable or Disable a Drive Port

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to enable or disable a physical port on a drive.

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder in the navigation tree, and click the drive you want to 
modify. 

3. Click the Properties tab.

4. Set the Port A Enabled or Port B Enabled status as follows:

• True: Turns on the port

• False: Turns off the port. The communication channel between the host 
software and the drive is disabled. 

The network software automatically configures the Port (A or B) address. This is 
called soft mode addressing.
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▼ Display Current Drive Mappings

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Current Drive Mapping report lists the library internal address and drive serial 
number currently assigned to each physical drive slot in the library. 

By default, the report is sorted in drive slot order. Optionally, you can change the sort 
order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 27. 

Note – This feature is available starting with SL500 firmware 
version 1393 and SL Console version 4.50. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Statistics folder in the navigation tree, and click the Statistics: Drive 
Mapping - Current tab. 

Screen Fields

Drive Slot

Display only.

Drive slot number. Slots are numbered 1–5, from the top to the bottom of the rack. 

Change Date

Display only.

Date and time of the most current mapping assignment.

Drive Address 

Display only.

Library internal address of the drive slot. 



Drive Management Tasks

Drive Management   239 

Format is l.m.r.c, where: 

• l = for non-partitioned libraries: This is the library ID (always 0). For 
partitioned libraries, this is the partition ID (1–8). 

• m = module number: 1–5, from top to bottom of the rack.

• r = drive row number: 1–2 (Base Module) or 1–4 (Drive Expansion Module), 
from top to bottom of the module.

• c = column number: always 9 for drives.

Serial Number

Display only.

Serial number of the drive currently installed in the drive slot.
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▼ Display Drive Mapping History

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Drive Mapping History report provides an audit trail of all drive mapping 
changes. Drive mappings identify the library internal address assigned to each drive 
slot, as well as the serial number of the drive installed in each slot. Whenever this 
information is modified (such as when a drive assembly is replaced or moved to a 
different slot), a time-stamped entry is made to the mappings. 

By default, the report is sorted in drive slot order. Optionally, you can change the sort 
order, and rearrange and resize the columns. See “Modifying the Screen 
Layout” on page 27. 

Note – This feature is available starting with SL500 firmware 
version 1393 and SL Console version 4.50. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Statistics folder in the navigation tree, and select Media Drive 
Events. 

Screen Fields

Drive Slot

Drive slot number. Slots are numbered 1–5, from top to bottom of the rack.

Change Date

Date and time the mapping change occurred.

Drive Address 

Library internal address of the drive installed in the slot. 

Format is l.m.r.c, where: 
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• l = for non-partitioned libraries, the library ID (always 0). For partitioned 
libraries, the partition ID (1–8). 

• m = module number: 1–5, from top to bottom of the rack.

• r = drive row number: 1–2 (Base Module) or 1–4 (Drive Expansion Module), 
from top to bottom of the module.

• c = column number: always 9 for drives.

Serial Number

Serial number of the drive installed in the drive slot.
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▼ Display the Media Drive Events Report

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Media Drive Events Report lists the 100 most recent library media access errors. 
The report updates whenever a drive is not able to perform a load, unload, read, or 
write operation on a cartridge. Use the report to help determine whether a particular 
drive or cartridge is in need of maintenance or replacement. 

By default, the report is sorted in reverse chronological order (that is, by Date/Time, 
with the most recent entry at the top). Optionally, you can change the sort order, and 
rearrange and resize the columns. See “Modifying the Screen Layout” on page 27. 

Note – This feature is available starting with SL500 firmware 
version 1200 and SL Console version 3.30. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Statistics folder in the navigation tree, and select Media Drive 
Events. 

Screen Fields

Date/Time

Date and time the error occurred.

Drive Adr

Location of the drive involved in the error. Format is l.m.r.c, where:

• l = library ID

• m = module ID

• r = row ID

• c = column ID
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Volid

VOLID of the cartridge involved in the error.

Drive Serial Num

Serial number of the drive involved in the error.

Drive Type

Type of drive. For example, Hewlett-Packard LTO Ultrium 4 or Quantum 
SDLT 320.

Exception

Type of error. Options are:

• LoadError: The drive load failed after all retries were attempted. See LoadRetry 
for an explanation of the retry conditions.

• LoadRetry: The drive load was successful, but required one or more retries. A 
retry involves removing and reinserting the cartridge and reissuing a load 
command to the drive. The system initiates a retry if either the cartridge is not 
detected as sensed from the drive (except DLT drives), or the load command to 
the drive fails.

• MediaError: The drive signaled a media error during drive load or unload. 
IBM drives allow cartridges with media errors to be loaded, while Hewlett-
Packard drives do not.

• UnloadError: The library could not successfully unload and remove the 
cartridge from the drive.
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▼ Display the Drive Distribution Reports

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Drive Distribution Reports summarize cartridge mount activity that has occurred 
for all library drives during a selected time period. Activity is summarized by 
individual drive location. Use this report to determine how evenly drive workload is 
distributed across the library and whether some drives are utilized more or less than 
others. 

Note – These reports show drive activity by location. To 
determine whether the drive serial number installed in a 
particular location has changed during the reporting period, see 
“Display Drive Mapping History” on page 240. 

By default, the reports are sorted in library internal drive address order. Optionally, 
you can change the sort order and rearrange and resize the columns. See “Modifying 
the Screen Layout” on page 23. 

To create a chart from this report, save the data to a comma-separated (.csv) file, and 
then import the.csv file into a charting application. For details, see “Save Library 
Report Data to a File” on page 53. 

The Drive Distribution Reports and the Drive Utilization Reports display similar 
information, but with the following distinctions:

• The Drive Distribution Reports show aggregate drive activity for the specified 
time period. 

• The Drive Utilization Reports show the same activity broken out into regular 
intervals within the time period. Depending on the length of time involved, an 
activity may span more than one interval. 

Note – This feature is available starting with SL500 firmware 
version 1393 and SL Console version 4.50. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Drive Distribution folder in the navigation tree, and select the time 
period for which you want to display summary activity. Options are:

• Last 24 Hours: The previous 24 hours

• Last 7 Days: The previous 7 days

• Last Month: The previous 31 days

• Last Year: The previous 52 weeks 
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The selected report displays. 

Screen Fields

Drive Address 

Library internal address of the drive. 

Format is l.m.r.c, where: 

• l = for non-partitioned libraries: This is the library ID (always 0). For 
partitioned libraries, this is the partition ID (1–8). 

• m = module number: 1–5, from top to bottom of the rack.

• r = drive row number: 1–2 (Base Module) or 1–4 (Drive Expansion Module), 
from top to bottom of the module.

• c = column number: always 9 for drives.

Slot

Drive slot number. Slots are numbered 1–5, from top to bottom of the rack. 

Mounts 

Total number of cartridge mounts initiated during the selected time period. Total 
mounts for all drives in the library displays at the bottom. 

Percent Utilization 

Percentage of time the drive was busy during the selected time period. For 
example, a value of 25.70 means the drive was busy 25.7 percent of the time. The 
value is calculated as follows:

Seconds busy / total seconds in time period 

Percent Total Mounts

Percentage of total library mounts that occurred on this drive. For example, a 
value of 49.1 means that 49.1 percent of all mounts that occurred during this time 
interval occurred on this drive. The value is calculated as follows:

Total mounts for this drive / Total mounts for all drives
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▼ Display the Drive Utilization Reports

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

The Drive Utilization Reports summarize cartridge mount activity that has occurred 
for an individual drive location during a selected time period. Activity is broken into 
regular time intervals within the selected time period. You can use this report to 
determine patterns of drive activity over time and whether there are peak and low 
periods of drive usage. 

Note – These reports show drive activity by location. To 
determine whether the drive serial number installed in a 
particular location has changed during the reporting period, see 
“Display Drive Mapping History” on page 240. 

By default, the report is sorted chronologically by time interval. Optionally, you can 
change the sort order and rearrange and resize the columns. See “Modifying the 
Screen Layout” on page 23. 

The Drive Distribution Reports and the Drive Utilization Reports display similar 
information, but with the following distinctions:

• The Drive Distribution Reports show aggregate drive activity for the specified 
time period. 

• The Drive Utilization Reports show the same activity broken out into regular 
intervals within the time period. Depending on the length of time involved, an 
activity may span more than one interval. 

Note – This feature is available starting with SL500 firmware 
version 1393 and SL Console version 4.50. 

Task Steps

1. Select Tools > Reports. 

2. Expand the Drive Utilization folder in the navigation tree, and select the time 
period for which you want to display activity summaries. Options are:

• Last 24 Hours: The previous 24 hours, broken into hourly intervals

• Last 7 Days: The previous 7 days, broken into daily intervals 

• Last Month: The previous 31 days, broken into daily intervals

• Last Year: The previous 52 weeks, broken into weekly intervals 

The selected report is displayed, with the first drive location displayed by default. 

3. In the Select a drive list, select the drive location (library internal address) you 
want to display. 
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The report displays for the selected drive location. 

Screen Fields

Select a drive

Library internal address of the drive you want to display. 

Format is l.m.r.c, where: 

• l = for non-partitioned libraries: This is the library ID (always 0). For 
partitioned libraries, this is the partition ID (1–8). 

• m = module number: 1–5, from top to bottom of the rack.

• r = drive row number: 1–2 (Base Module) or 1–4 (Drive Expansion Module), 
from top to bottom of the module.

• c = column number: always 9 for drives.

Start Date

Starting date and time for each interval. 

Mounts 

Total number of cartridge mounts initiated during the selected time period. 

Percent Utilization 

Percentage of time the drive was busy during the time interval. For example, a 
value of 25.70 means the drive was busy 25.7 percent of the time. The value is 
calculated as follows:

Seconds busy / total seconds in time period 
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▼ Add or Edit Drive Tray Serial Number 

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Add or edit the drive’s tray serial number.

Note – This feature is available with FRS_4.0 and SL Console 6.0.

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder in the navigation tree, and click the drive you want to 
display. 

3. Click the Properties tab. 

The Properties page appears. 

4. Click in the Tray Serial Number field and enter the drive tray serial number.

5. Press Enter.

A red box displays around the field and the Apply button activates.

6. Click the Apply button.

The system saves the drive tray serial number you just entered.
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10

Cartridge Management

This chapter includes the following topics:

• “Cartridge Labels” on page 249

• “Entering Cartridges” on page 249

• “Ejecting Cartridges” on page 250

• “Recovery Moves” on page 250

• “Cartridge Management Tasks” on page 252

Cartridge Labels
All library cartridges must have a readable external label.

If you place an unlabeled cartridge into a storage cell manually, the robot leaves it 
there during a hardware audit and does not attempt to place another cartridge into 
the slot.

The library controller will not allow you to mount an unlabeled or unknown type 
cartridge into any tape drive. 

Entering Cartridges
Before entering a cartridge into the library, verify it is labeled properly. Insert each 
cartridge into a CAP slot with the:

• Customer label (if present) facing you

• Hub gear facing down

• Cartridge label facing you

You can place cartridges in any CAP slot in any order. The robot audits all CAP slots 
when the CAP door is closed. 

Note – The CAP design prevents you from placing a T9840 or 
T10000 cartridge upside-down in the CAP. It does not, however, 
prevent you from placing an LTO cartridge upside-down in the 
CAP.
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The robot’s bar-code scanner reads cartridge labels only during enter operations. This 
occurs because the vol-ids are new and must be added to the library controller 
database. The robot does not need to read cartridge labels during ejects.

See “Enter Cartridges Through the CAP” on page 253.

When the system enters a cartridge into the library, the host either assigns the 
cartridge a home cell or mounts it on a drive, depending on the reason why it was 
entered. The system records the stored cartridge’s location in the library controller 
database, using the library internal address format. 

The system also transmits the location to the host for inclusion in the host’s cartridge 
database.

Ejecting Cartridges
To eject a cartridge, you must specify the vol-id of the cartridge you want to remove 
from the library. The robot moves to the storage location indicated in the library 
controller database, removes the cartridge from the slot, and places the cartridge in a 
CAP slot.

After the CAP opens, the system deletes the cartridge and its location from the 
library controller database and the host database.

Note – The robot does not read cartridge labels during eject 
operations. 

See “Eject Cartridges Through the CAP” on page 255.

Locating Cartridges
Each cartridge is associated with the library’s internal address for the slot or drive 
where it is located. To locate a cartridge by the internal library address, see “List 
Library Cartridges” on page 256.

Recovery Moves 
Note – This feature is available starting with SL500 firmware 
version 1026 and SL Console version 2.40. 

Using the recovery move diagnostic function, you can move a cartridge from one 
location to another. For example, you can:

• Return a cartridge to its original location from a CAP cell, drive, or another 
storage cell location.

• Decide to group cartridges by data type or move them closer to their assigned 
drives.

• Eject a cleaning or diagnostic cartridge that has expired.

• Enter a new cleaning or diagnostic cartridge and move it to a reserved storage 
cell.
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A cartridge currently in a storage cell can be moved only to a CAP, a system cell, or 
another storage cell, and not to a drive. A cartridge currently in a drive, CAP, or 
system cell can be moved to any other unoccupied location in the library. See the 
following procedures for complete details:

• “Move a Specified Cartridge by vol-id” on page 258

• “Move a Cartridge From a Specified Location” on page 260

Before moving any cartridge, it is helpful to display or print a report showing where 
cartridges are currently located and which storage cells are unoccupied. See the 
following procedures for detailed instructions:

• “List Library Cartridges” on page 256
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Cartridge Management Tasks
• “Enter Cartridges Through the CAP” on page 253

• “Enter Cartridges Through the CAP” on page 253

• “List Library Cartridges” on page 256

• “Move a Specified Cartridge by vol-id” on page 258

• “Move a Cartridge From a Specified Location” on page 260
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▼ Enter Cartridges Through the CAP

Task Tool

This task can be performed at the CAP.

Task Purpose

The base module CAP contains a standard four- or five-cell magazine, as shown in 
FIGURE 10-1.The expansion module CAP has two magazines. 

Use this procedure to enter a cartridge into the library through a CAP. 

Note – Before beginning this procedure, verify that the library 
CAP Prevent/Allow state is set to Allow. See your SCSI reference 
manual for syntax. 

Task Steps

1. Press the CAP Open button on the keypad.

The robot opens the CAP door and the system turns on the CAP Open LED.

2. Grip the handle of the magazine and slide it out of the CAP and onto the door.

Note – Do not remove the magazine from the door. If you leave 
the magazine on the door rails, the magazine will slide easier into 
the CAP. 

3. Place the cartridge into one of the magazine cells, making sure that the cartridge 
label is visible and the hub of the cartridge is down.

4. Grip the handle and slide the magazine back into the CAP as shown in 
FIGURE 10-1.

5. Close the CAP door, making sure that the door is securely latched.

FIGURE 10-1  Sliding a Magazine into the CAP
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6. Refer to your tape management software manual for information on how to 
move the cartridges from the CAP to the storage cells.

FIGURE 10-2  Base Module Magazine Comparison

1. Five-cell LTO magazine

2. Four-cell mixed-media magazine

3. Cartridge release buttons

1

2

3

3
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▼ Eject Cartridges Through the CAP

Task Tool

This task can be performed at the host and the CAP.

Task Purpose

Use this procedure to eject a cartridge from the library through a CAP. 

Task Steps

1. Type the eject command at the host console. Refer to your tape management 
software publication for the command syntax. 

The robot places cartridges into the CAP cells until all the specified cartridges are 
in the CAP. 

2. Press the CAP Open button on the keypad.

3. The CAP is opened, and the CAP Open LED turns on.

4. Remove the ejected cartridges using either of the following methods:

• Leave the magazine in the CAP and remove the cartridges from it directly.

• Remove the magazine from the CAP and press the red cartridge release 
buttons to remove the cartridges from the magazine.

5. If you removed the magazine from the CAP, place the magazine onto the door 
rails and slide it back inside the CAP.

6. Close the CAP doors.
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▼ List Library Cartridges

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display information about all library cartridges, including their 
vol-ids, locations, and media types. 

Task Steps

1. Select Tools > Reports. 

The navigation tree lists all library report options. 

2. Expand the Status Summary folder in the navigation tree.

The Status Summary reports display in a list. 

3. Select Cartridge Summary. 

The Cartridge Summary report displays.

4. If you want to search the report data or save it to a file, see the following 
procedures:

• “Display a Library Report” on page 47 

• “Save Library Report Data to a File” on page 49

Screen Fields

Location

Library or partition number, module number, row number and column number. 
Together, these values identify the library internal address where the cartridge is 
located.

Location Type

Type of library location where the cartridge is located. Options are:

• CAP: CAP cell

• cell: Regular storage cell

• drive: Loaded in a tape drive

• sysCell: System (reserved) cell; cleaning or diagnostic cartridges are typically 
stored in these cells 
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Media Type

Type of media in the cartridge.

Type

Domain, or usage type, of the cartridge. Options are:

• clean: Cleaning cartridge

• data: Data cartridge

• diagnostic: Diagnostic cartridge

Cartridge 

Unique vol-id of the cartridge. Standard vol-ids are eight characters in length. 

A value of #UREAD indicates the barcode label is unreadable. Possible reasons for 
this are as follows:

• The label is missing or damaged. 

• The label has a non-standard format, such as a ten-character vol-id, or an 
unrecognized cartridge domain type or media type indicator. 

The library controller does not allow you to mount an unlabeled or unknown type 
cartridge into any tape drive. 
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▼ Move a Specified Cartridge by vol-id

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to move a cartridge with a specified vol-id to a specified location 
within the library. 

Note – This procedure updates the cartridge’s location in the 
library controller database, but not in the host database. Therefore 
after performing this procedure, you must perform an audit from 
the host software to update the host database. Failure to do so will 
cause future mount requests from the host software to fail. 

Caution – Potential data overwrite. Use caution when performing 
this procedure in partitioned libraries. You could inadvertently 
move a cartridge from one partition to another, which would allow 
the new partition to overwrite data on the cartridge.

Task Steps

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the RcvrMove tab. 

The Recovery Move page appears. 

3. In the Source Location Mode section, select VOLID. 

The page updates with the appropriate Source Location choices. 

4. In the VOLID field, enter the vol-id of the cartridge you want to move. 
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5. In the Destination Location Type list, select the type of location where you want 
to move the cartridge to. Options are:

• CAP

• Storage Slots 

• Drive

• Reserved Slots

The following restrictions apply to your selection:

• The destination can be a drive only if the source is a CAP or reserved slot. 

• For you to move a cartridge to a drive, the cartridge media type must be 
compatible with the drive type. 

• You cannot move a cartridge to a location that is already occupied. 

• Although not strictly enforced, it is recommended that only diagnostic or 
cleaning cartridges be moved to reserved slots. 

6. In the Destination Location table, specify the library internal address of the 
destination location by making the appropriate selections in the following lists:

• Library 

• Module 

• Row 

• Column 

The following special selections are available on the lists:

• Min: First element of that location type (library, module, row, or column) in the 
library 

• Max: Last element of that location type (library, module, row, or column) in the 
library 

Caution – Potential overwrite of data or loss of access. If the library is 
partitioned, make sure to keep the cartridge in the same partition it 
is currently allocated to. If you move a cartridge to a cell allocated 
to a different partition, the host could treat the cartridge as scratch 
and overwrite the data. If you move the cartridge to an unallocated 
cell, no hosts will be able to access the cartridge. 

7. Click the Start button.

The robot moves the cartridge. A success message appears when the operation 
completes. 

8. Click OK.

9. To verify the new location, you can display a Cartridge Summary Report. See 
“List Library Cartridges” on page 256 for details. 

10. To update the new cartridge location in the host database, initiate a library 
audit from the host software. See the appropriate tape management software 
documentation for the procedures and commands.
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▼ Move a Cartridge From a Specified Location

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to move a cartridge from one specified location to another within 
the library. 

Note – This procedure updates the cartridge’s location in the 
library controller database, but not in the host database. Therefore, 
after performing this procedure, perform an audit from the host 
software to update the host database. If you do not perform the 
audit, future mount requests from the host software will fail.

Caution – Potential overwrite of data. Use caution when performing 
this procedure in partitioned libraries. You could inadvertently 
move a cartridge from one partition to another, causing the new 
partition to overwrite data on the cartridge. 

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the RcvrMove tab. 

The Recovery Move page appears. 

3. In the Source Location Mode section, select Location. 

The page updates with the appropriate Source Location choices. 

4. In the Source Location Type list, select the cartridge’s current location type. 
Options are:
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• CAP

• Slot

• Drive

• Reserved Slots

5. In the Source Location table, specify the library internal address of the source 
location by making the appropriate selections in the following lists:

• Library 

• Module 

• Row 

• Column 

The following special selections are available on the lists:

• Min: First element of that location type (library, module, row, or column) in the 
library 

• Max: Last element of that location type (library, module, row, or column) in the 
library 

6. In the Destination Location Type list, select the type of location where you want 
to move the cartridge to. Options are:

• CAP

• Storage Slots 

• Drive

• Reserved Slots

The following restrictions apply:

• The destination location can be a drive only if the source is a CAP or reserved 
slot. 

• For you to move a cartridge to a drive, the cartridge media type must be 
compatible with the drive type. 

• You cannot move a cartridge to a location that is already occupied. 

• Although not strictly enforced, it is recommended that only diagnostic or 
cleaning cartridges be moved to reserved slots. 

7. In the Destination Location table, specify the library internal address of the 
destination location by making the appropriate selections in the following lists:

• Library 

• Module 

• Row 

• Column 

The following special selections are available on the lists:
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• Min: First element of that location type (library, module, row, or column) in the 
library 

• Max: Last element of that location type (library, module, row, or column) in the 
library 

Caution – Potential overwrite of data or loss of access. If the library is 
partitioned, keep the cartridge in the same partition it is currently 
allocated to. If you move a cartridge to a cell allocated to a different 
partition, the host could treat the cartridge as scratch and overwrite 
the data. If you move the cartridge to an unallocated cell, no hosts 
will be able to access the cartridge. 

8. Click the Start button.

The robot moves the cartridge, and then a success message appears.

9. Click OK.

10. To verify the new location, you can display a Cartridge Summary Report. See 
“List Library Cartridges” on page 256 for details.

11. To update the new cartridge location in the host database, initiate a library 
audit from the host software. See the appropriate tape management software 
documentation for the procedures and commands.



Drive Cleaning   263 

1111

Drive Cleaning

Library tape drives require periodic cleaning to prevent read/write errors. A drive 
cleaning occurs when the system mounts a compatible cleaning cartridge in response 
to a cleaning request from the drive.

This chapter includes the following topics:

• “Library Auto Clean” on page 263

• “Drive Cleaning Tasks” on page 267

Library Auto Clean 
The library auto clean feature enables the library controller to manage all drive clean 
functions. You can import cleaning cartridges into the library, where they are stored 
in reserved system cells. As soon as a drive indicates that it needs cleaning, the 
library controller automatically selects a compatible cleaning cartridge from the 
system cells and mounts it on the drive. When the cleaning activity is completed, the 
library controller dismounts the cartridge and returns it to a system cell. 

With the auto clean feature, the library tracks cleaning cartridge usage and sends 
notification when cleaning cartridges have expired or have reached a user-defined 
usage threshold. Cleaning cartridges can be automatically exported from the library 
in bulk, by expiration date, or by selected cartridge volume ID (vol-id or volser). 

In partitioned libraries, auto clean can be configured for the entire library or for 
individual library partitions. 

See “Library Auto Clean Special Considerations” on page 264 for additional details 
about library auto clean operations. 

Library Auto Clean Process Summary 

The following is a summary of the actions needed to configure and use the library 
auto clean feature. 

1. Enable library auto clean. (The auto clean feature is disabled by default on SL8500 
libraries.) In partitioned libraries, you can enable or disable the feature separately 
for each partition. See “Configure Drive Auto Clean” on page 268.

2. Import cleaning cartridges into the library. The cartridges are placed in reserved 
system cells.
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3. Monitor status of cleaning cartridges and drives. See the following procedures for 
details: 

• “Display Cleaning Cartridges” on page 273

• “Display Drive Cleaning Status” on page 275

4. Export cleaning cartridges from the library as necessary. You can use any of the 
following methods:

• Export all cartridges

• Export expired cartridges

• Export selected cartridges

See “Export Cleaning or Diagnostic Cartridges” on page 271 and . See “Drive 
Cleaning Tasks” on page 306 for a list of all tasks related to drive cleaning. 

Library Auto Clean Special Considerations

The following are details and special considerations about the library auto clean 
feature. 

Host Interactions

With the auto clean feature, the library controller initiates a drive clean operation 
immediately upon receipt of a cleaning request from the drive. This request typically 
occurs when the drive dismounts a data cartridge. While the drive is being cleaned, 
the data cartridge dismount remains pending to the host. The host is not notified that 
the data cartridge dismount is complete until the drive clean operation has finished 
and the cleaning cartridge has been returned to a system cell. 

While a drive is being cleaned, the system marks it as busy to all hosts. If an FC-SCSI 
host requests the drive while the drive is being cleaned, the request is rejected. 

Unsuccessful Cleaning Operations

If the library controller cannot locate a non-expired cleaning cartridge that is 
compatible with the drive, the library controller sends messages to the system Event 
Log and the Status Module page. See “Library Events” on page 285. 

After a cleaning cartridge has been mounted on a drive and the drive indicates that 
the cartridge is unusable, the library controller automatically returns the cartridge to 
a reserved system cell. The drive will not be cleaned until the next dismount, 
preventing a response time out on the dismount. The next clean attempt will use a 
non-expired cleaning cartridge if one is available. 

Use of Reserved System Cells 

When cleaning cartridges are imported into the library, the library distributes the 
cartridges as evenly as possible among the sides of the library. Cleaning cartridges 
can be stored in any available system cell. 

The reserved system cells are not assigned to partitions. Therefore, a cleaning 
cartridge can be used to clean compatible drives allocated to any library partition. 
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Cleaning Cartridge Management
Ensure that the library contains a sufficient number of cleaning cartridges that are 
compatible with each drive type in your library. See the drive manufacturers’ 
documentation for compatibility requirements. 

The library auto clean feature requires that cleaning cartridge volume IDs (VOLIDs 
or volsers) be eight characters in length, with “CLN” as the first three characters. The 
library Import/Export function only accepts cleaning cartridges that have labels with 
this format. 

With the library auto clean feature, cleaning cartridges are stored in reserved system 
cells which the library controls. These reserved cells are not accessible to library host 
applications. The number of system cells available for cleaning cartridge storage 
varies, depending on the configuration of your SL500 library.

Importing and Exporting Cleaning Cartridges

You must enter cleaning cartridges into the library using the SL Console Import 
function to make the cartridges available for the library auto clean feature. 

To remove cleaning cartridges from a library using the auto clean feature, use the SL 
Console Export function. You can choose to export all cartridges, selected cartridges, 
or all expired cartridges. 

Note – The command line interface (CLI) also provides cleaning 
cartridge import and export commands accessible to your system 
administrator and Oracle support representative. 

Cartridge Usage Count

Cleaning cartridges have a limited life span. See the drive manufacturers’ 
documentation for maximum recommended usage for each type of cleaning 
cartridge. For LTO cleaning cartridges, also refer to the cleaning cartridge 
manufacturers’ documentation. 

When you import a cleaning cartridge into the library, the library controller considers 
the cartridge to be new and sets the usage count to zero. Therefore, if you import a 
used cleaning cartridge, the usage count for that cartridge will not be accurate. 

Each time a cleaning cartridge is mounted on a drive, the library controller 
increments the usage count for that cartridge. See “Display Cleaning 
Cartridges” on page 273 to display the current usage count. 

Cleaning Cartridge Expiration

Cleaning cartridges are expired based on information from the drives. If a drive 
cannot use a cleaning cartridge (due to reaching the end of tape, for example), the 
drive sends a “cleaning cartridge expired” notification to the library controller. 

The library controller:

• Dismounts the cartridge from the drive and returns it to a system cell

• Updates the cartridge’s status to “expired”
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• Sends messages to the system Event Log

The library controller does not use expired cleaning cartridges for cleaning 
operations. Replace expired cartridges as soon as possible. When you export an 
expired cleaning cartridge from the library, be sure to remove it from the CAP. If you 
leave an expired cartridge in the CAP, another user could inadvertently re-enter it 
into the library. 

Manual Cleaning 
Normally, the library auto clean feature manages drive cleaning. However, there may 
be occasions when you need to perform a manual clean. 

Caution – Potential excess wear of drive head. Cleaning a drive before 
it is due is not recommended. Excessive drive cleaning can wear out 
a drive head prematurely. 

See the drive manufacturer’s documentation for information on whether manual 
cleaning is allowed. Some drive types allow manual cleaning at any time, while 
others do not allow cleaning to be initiated unless a usage threshold has been met. If 
a usage threshold is not met, the library controller may allow you to mount a 
cleaning cartridge on a drive, but the drive will not actually perform the cleaning 
operation. 

To verify whether a drive needs cleaning, display the drive’s cleaning status and the 
date when it was last cleaned. See “Display Drive Cleaning Status” on page 275 for 
details. 



Drive Cleaning Tasks

Drive Cleaning   267 

Drive Cleaning Tasks
• “Configure Drive Auto Clean” on page 268

• “Import Cleaning or Diagnostic Cartridges” on page 269

• “Export Cleaning or Diagnostic Cartridges” on page 271

• “Display Cleaning Cartridges” on page 273

• “Display Drive Cleaning Status” on page 275

• “Clean a Drive Manually” on page 277
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▼ Configure Drive Auto Clean

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to enable or disable the library auto clean feature. If the library is 
partitioned, you can enable or disable library auto clean for individual partitions. 

Task Steps

1. Select Tools > System Detail, and select the library folder on the navigation 
tree.

2. Click Auto Clean and then Configure.

The Configure page appears. 

3. Set the Auto Clean field to Enabled. 

4. In the Threshold Configuration section, specify the warning thresholds for each 
cartridge type.

5. Click Apply.
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▼ Import Cleaning or Diagnostic Cartridges

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to import new cleaning or diagnostic cartridges to the library 
through a CAP. The cartridges are entered into reserved system cells.

Before beginning this procedure, verify that all the following conditions are met:

• The required number of reserved system cells are empty. 

• The CAP Prevent/Allow state is set to Allow (see your SCSI Reference Manual for 
syntax).

• The CAP does not contain any data cartridges. 

Task Steps

1. Select Tools > Diagnostics.

2. Expand the CAP Folder in the navigation tree, highlight the CAP, and then click 
the Import/Export tab.

3. Select “Import Cleaning/Diagnostic cartridges,” and then click Start in the 
upper right-hand corner.

4. The library controller opens the CAP door, and the CAP Open LED turns on.

5. Grip the handle of the magazine, and slide it out of the CAP and onto the door.

Note – To help slide the magazine back into the CAP, do not 
remove the magazine from the door. Instead, leave the magazine 
on the CAP door rails.

6. Place the cartridges into the empty magazine cells, making sure that the VOLID 
label is visible and the hub of the cartridge is down.
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Caution – Possible damage to components. Enter the cartridges 
properly. Otherwise, you could damage the robot or the drive, or 
cause the library to stop operating. Use only cartridges designed for 
the drives in your library.

7. Grip the handle and slide the magazine back into the CAP.

8. Close the CAP door, making sure that the door is securely latched.

The robot systematically moves each cleaning and diagnostic cartridge from the 
CAP to an empty system cell.

9. Monitor the Import/Export Console to verify the status of the import operation. 

The “Operation completed” status indicates that the import cartridge operation is 
complete.

10. After the import operation is complete, the robot audits the CAP.

To view a list of cleaning and diagnostic cartridges in the system cells, see 
“Display Cleaning Cartridges” on page 273. 

Note – If you want to import cleaning and diagnostic cartridges 
into system cells one cartridge at a time, use the Recovery Move 
diagnostic utility. See “Move a Cartridge From a Specified 
Location” on page 300. 
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▼ Export Cleaning or Diagnostic Cartridges

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to export specified cleaning or diagnostic cartridges through the 
CAP.

Note – Before beginning this procedure, verify that the CAP cells 
are empty.

Task Steps

1. Select Tools > Diagnostics.

2. Expand the CAP Folder in the navigation tree, highlight the CAP, and then click 
the Import/Export tab.

3. Do one of the following:

• To export only the expired cleaning or diagnostic cartridges, select the “Export 
expired cleaning/diagnostic cartridges” option.

• To export all cleaning and diagnostic cartridges from the reserved system cells, 
select the “Export all cleaning/diagnostic cartridges” option.

4. Click the Start button in the upper right corner of the page.

If you selected the “Export expired cleaning/diagnostic cartridges” option, the 
robot systematically moves all expired cleaning and diagnostic cartridges from the 
system cells into empty CAP cells.

If you selected the “Export all cleaning/diagnostic cartridges” option, the robot 
moves all cleaning and diagnostic cartridges from the system cells into empty 
CAP cells.

5. The library controller opens the CAP, and the CAP Open LED turns on.

6. Grip the handle of the magazine, and slide it out of the CAP and onto the door.
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Note – To help slide the magazine back into the CAP, do not 
remove the magazine from the door. Instead, leave the magazine 
on the CAP door rails.

7. Remove the cartridges from the magazine.

8. Grip the handle and slide the magazine back into the CAP.

9. Close the CAP door, making sure that the door is securely latched.

10. Monitor the Import/Export Console to verify the status of the export operation. 

The “Operation completed” status indicates that the export cartridge operation is 
completed.

Note – If you want to export cleaning or diagnostic cartridges one 
at a time, use the Recovery Move diagnostic utility. See “Move a 
Cartridge From a Specified Location” on page 300.
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▼ Display Cleaning Cartridges

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display detailed information about all cleaning cartridges 
stored in reserved system cells. In particular, you can use this procedure to monitor 
the status and usage count for all cleaning cartridges under library control. 

A cleaning cartridge may not appear on this page in the following cases:

• The cartridge is in use. 

• The cartridge is in transit. 

• The cartridge was entered into the library using the host tape management 
software (ACSLS or ELS). See your tape management software documentation for 
details about managing these cartridges.

Task Steps

1. Select Tools > System Detail, and select the library folder on the navigation 
tree.

2. Click the Auto Clean tab, and then the Cleaning Cartridges tab.

The Library Cleaning Cartridges page appears. 

Screen Fields

Tape Location 

Library, rail, column, side, and row. Together, these values identify the library 
internal address where the cartridge is located. 

All cartridges in this report are located in reserved system cells. 
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VOLID 

Volume ID (VOLID or volser) of the cartridge. The first three characters are always 
“CLN.” 

Usage Count 

Number of times the cartridge has been used for cleaning. When a cleaning 
cartridge is imported into the library, its usage count is set to 0. Each time the 
cartridge is mounted on a drive, its usage count is incremented. 

Status 

Current status of the cartridge. Options are:

• expired: The cartridge has expired, based on information from the drives. This 
cartridge is not usable and should be replaced as soon as possible. 

This status supersedes the “warning” status. Therefore, if a cartridge is both 
expired and has reached or exceeded its usage count threshold, only “expired” 
is displayed. 

• OK: The cartridge is usable for cleaning. 

• warning: The usage count has reached or exceeded the warning threshold 
defined for this cartridge type. The cartridge can still be used for cleaning, but 
you may want to replace it at your earliest convenience. 

Cart Type 

Type of cleaning cartridge. You should have an adequate supply of usable cleaning 
cartridges for each type of drive in the library. See the drive manufacturer’s 
documentation for cleaning cartridge requirements. 
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▼ Display Drive Cleaning Status 

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the current cleaning status of a drive. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Drive Folder in the navigation tree, and highlight the drive you 
want to display. 

The Drive Status page appears. 

Screen Fields

The following fields relate to drive cleaning. 

Drive needs cleaning

Indicates whether the drive has issued an unfulfilled cleaning request. Options 
are:

• true: Drive needs cleaning. 

• false: Drive does not need cleaning. 
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Drive Last Autocleaned

Date and time when the drive was last cleaned using the library auto clean 
feature. 

The field indicates “Unknown” if either of these are true:

• The library auto clean feature is not enabled.

• The drive was last cleaned using the host tape management software (ACSLS 
or ELS).
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▼ Clean a Drive Manually

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Your library could contain more than one type of drive. Before initiating a clean job, 
make sure system cells have the appropriate cleaning cartridges for the drives being 
cleaned. Generate a cartridge summary and drive details report to verify the cleaning 
cartridges present in the library. You can initiate a manual clean even if the “drive 
needs cleaning” status is “false.”

To display a list of cleaning cartridges, see “Display Cleaning 
Cartridges” on page 273. 

Task Steps

1. Select Tools > Diagnostics.

2. Expand the Drive Folder in the navigation tree.

3. Select the drive that requires cleaning, and then click the Clean tab.

4. Click Start Clean in the upper right corner.

A confirmation message appears. 

5. Click OK.

6. The Drive Cleaning Console displays the status of the cleaning operation.
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Robot Management

The robot provides movement of cartridges among the storage cells, tape drives, and 
cartridge access ports (CAPs). 

This chapter includes the following topics:

• “Parked Robot” on page 279

• “Robot Procedures” on page 279

• “Robot Monitoring Tasks” on page 280

Parked Robot
For safety purposes, the robot will be “parked” in the robotics unit when the front 
door is opened or when the Open Door button is pressed on the keypad. Parked 
means that the robotics components are fully retracted into the robotics unit at the 
top of the library. To verify the robot is parked, look at the lever in the cutout beneath 
the facade and to the bottom left of the keypad, the lever should be to the left.

Robot Procedures
For detailed robot management procedures, see “Robot Monitoring 
Tasks” on page 280. 
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Robot Monitoring Tasks
• “Display Robot Summary Information” on page 281

• “Display Robot Status” on page 282

• “Display Robot Statistics” on page 283
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▼ Display Robot Summary Information

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display summary information for the library robots. 

Note – This information is also available through 
Reports > Robot Summary. See “Display a Library 
Report” on page 47 for detailed instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Click the Robot folder on the navigation tree.

The Robot Data page appears. 
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▼ Display Robot Status 

Task Tool

This procedure can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display the current operational state of a robot. 

Note – This information is also available through 
Reports > Robot Details. See “Display a Library 
Report” on page 47 for detailed instructions. 

Task Steps

1. Select Tools > System Detail. 

2. Expand the Robot Folder in the navigation tree, and click the robot. 

3. Click the Status tab.

The page displays the current status of the selected robot.
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▼ Display Robot Statistics 

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to display robot statistics, including Get, Put, and Retry counts.

Task Steps

1. Select Tools > System Detail. 

2. Expand the Robot Folder, and click the robot. 

3. Click the Statistics tab. 

The Statistics page appears. 
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 SL Console Diagnostics and Utilities

The StorageTek Library (SL) Console enables you to perform many diagnostic tasks, 
including library self-tests and firmware upgrades.

This chapter includes information on the following:

• “Library Events” on page 285

• “Event Codes” on page 287

• “Library Self-Tests” on page 290

• “Audits” on page 292

• “Robot Diagnostic Moves” on page 294

• “Troubleshooting” on page 297

Library Events
The library controller continually monitors library operations and logs all events.

Event Monitors

The system stores event monitors under the following three headings:

• Communication events: Includes host-to-library, library-to-library, and library-to-
drive communications.

• Error event: Each error event is assigned a four-digit (hexadecimal) action code.

• Warning events: Indicate a loss of performance or conditions that may be 
indicative of future fatal errors.

You or your Oracle StorageTek support representative can use the SL Console to:

• Review library events

• Spool event data to a text file

The following information can help you diagnose the cause of the event:

• Date/time stamp: Identifies when the event occurred.

• Action codes: Identifies the command that was issued, such as “load drive.”
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• Result codes: Identify the result of the requested action.

• Known service plan diagnosis: Identifies the mechanism or component 
responsible for the task or fault.

Note – Using the SL Console, you can spool event data to a file.
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Event Codes
TABLE 13-1  Event Codes

Event Type Description Valid Codes

Activity 
Code

Activity associated with the event. 
For example, HLI host mount, 
diagnostic fetch, robot 
communication diagnostic. 

0000: no action / no activity 

0100199: common/shared activity (across devices 
and the controller)

0200–0299: common/shared activity (across 
devices - robot, drive, PTP, and so on)

0400–0499: common/shared configuration 
activity

1000–1999: host interface activity

2000–2999: management interface activity

3000–3999: internal server/library activity

4000–4999: partner library-initiated activity

5000–5999: robot activity

6000–6999: drive activity

7000–7999: CAP activity
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Result Code Reason for the activity. For 
example,  
Activity: HLI host mount  
Result: robot X cartridge fetch 
failure

0000: no problem / normal

0100–0199: common/shared results (across 
devices and the controller)

1000–1999: host interface results

2000–2999: management interface results

3000–3999: internal server/library controller 
results

4000–4999: partner library interface results

5000–5999: robot results

6000–6999: drive results

7000–7999: CAP results

Severity Identifies the significance of the 
event from the perspective of the 
activity associated with the event. 
The severity levels also identify 
log activity that must persist in the 
system across machine power 
cycles from that which might be 
considered volatile.

Error (1): Indicates a fault occurred which 
prevented a request (host or diagnostic) from 
completing successfully. Error data is non-
volatile and accumulates across machine power 
cycles.

Warning (2): Indicates a fault occurred, but the 
fault has not stopped the library’s ability to 
complete requests (host or diagnostic). Warning 
data is non-volatile and accumulates across 
machine power cycles.

Information (3): Indicates data that is not 
significant, but may be important to establish a 
history of activity around a severity 1 or 2 event. 
Information data is volatile. 

Configuration (4): Indicates change in the 
library’s configuration. This includes the 
addition and removal of drives, robot, 
controllers, and interface cards. This also 
includes changes to the software configuration. 
Configuration data are non-volatile resources 
and accumulate across machine power cycles.

Diagnostic (5): Records normal diagnostic 
activity tracing. This is independent of the debug 
or trace activity when a diagnostic activity 
affects the availability of drives or other devices 
to host operations. Diagnostic data is volatile.

Request 
Identifier

Identifies all host interface 
requests. Helps track the sequence 
of log activity resulting from each 
host request. 

TABLE 13-1  Event Codes
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Library Firmware Upgrades
Note – This feature is available starting with SL500 firmware 
version 1022. 

The library firmware resides on the library controller. Initial firmware is installed at 
the factory. Library firmware does not contain drive code upgrades. When new 
firmware is released, you must use the code load utility to upgrade the firmware on 
the library and associated devices (CAP and robot).

Firmware Upgrade Process

The steps for loading firmware code on the library controller are as follows: 

1. Locate the firmware upgrade package (.img file) on the Oracle download site.

2. Download the code to a folder on your local PC or workstation. 

3. Download the firmware package from your PC or workstation to the library 
controller. This process also unpacks the package after downloading to make it 
ready for activation. See “Download Code to the Library Controller” on page 305. 

4. Activate the downloaded code on the library controller. See “Activate Code on the 
Library Controller” on page 306. 

5. Reboot the library to make the code operational. See “Download Code to the 
Library Controller” on page 305. 

Firmware Download Site

The SL500 library firmware package is an .img (image) file. The file is available at 
the Oracle Software Delivery Cloud at the following URL: 

http://edelivery.oracle.com/ 

Multiple Versions of Firmware

You can store up to two versions of the SL500 firmware in the library controller flash 
memory. By storing two versions:

• The library can continue normal operations and run one version of firmware, 
while you download and unpack an upgrade package. Then you can activate the 
upgrade at a time that is convenient for library users. 

• You can revert to a previous version of firmware without having to download and 
unpack the code package again. 

Related Procedures

For detailed firmware upgrade procedures, see “Library Utility Tasks” on page 304. 
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Library Self-Tests 
The self-test diagnostic utility is intended to help diagnose basic problems with the 
library. A self-test typically runs after the library is installed. The test also can be run 
whenever necessary. 

You can run library self-test routines in either non-disruptive or disruptive mode. In 
non-disruptive mode, all cartridges used in the test are returned to their original 
locations. Disruptive mode may leave cartridges in a different location from where 
they started. 

When performing a self-test, the system:

1. Checks the communication path between the library controller, drives, elevators, 
and robots.

2. Performs a full library audit.

3. Performs mounts and dismounts of diagnostic cartridges for all the drives 
installed in the library. The self-test does not begin unless a diagnostic cartridge is 
found in the system cells. If the system finds a compatible diagnostic cartridge, 
the self-test repeats for each drive type. If the system does not find a diagnostic 
cartridge for a drive type, the system skips the mount/dismount operation for the 
drive.

Related Procedures

For detailed procedures, see “Library Utility Tasks” on page 304. 
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Diagnostic Cartridge Management
Library self-tests and some other diagnostic activities require the use of diagnostic 
cartridges. Ensure the library contains a sufficient number of diagnostic cartridges for 
these activities. 

Diagnostic cartridge volume IDs (vol-ids or volsers) must be eight characters in 
length, with “DG” as the first two characters. The library import/export function 
works only for diagnostic cartridges with labels in this format. 

The system stores diagnostic cartridges in reserved system cells which the library 
controls. Host library applications cannot access diagnostic cartridges. The number of 
system cells available for diagnostic cartridge storage varies, depending on the 
configuration of your SL500 library.

See “Use of Reserved System Cells” on page 264 for details. 
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Audits 
During an audit, the system reads and catalogs cartridges within a library, and 
verifies the locations of cartridges or validates a range of slot locations. The library 
controller maintains a cartridge database that contains the following information for 
all the cartridges in the library:

• Volume ID (vol-id or volser) 

• Current location (in library internal address format)

• Verified status (true or false)

The library audits all cartridge locations in the storage and reserved areas at the 
following times:

• An audit request is made through the SL Console

• A host request to audit the library is entered

You can use the SL Console to perform the following types of audits:

• “Physical Audit” on page 292 

• “Verified Audit” on page 293

Caution – System-level problems may occur if a host’s record of the 
cartridge does not match what is in the cartridge database of the 
library controller. 

Audit Indicator

Note – The audit indicator feature is available starting with SL500 
firmware version 1466 and SL Console version 5.70.

The SL Console displays a spinning visual indicator and the message “Audit in 
progress” to indicate an audit is in progress. The audit indicator displays whenever a 
library access door has been opened and closed.

The indicator may also display during power up in libraries with redundant 
electronics or after a reboot. 

When you see the audit indicator at the bottom of the screen along with the message 
“Audit in progress,” do not open the library access door. Otherwise, the library must 
start the audit process from the beginning.

Note – The audit indicator does not display for audits you initiate 
through the SL Console or the host.

Physical Audit

In a physical audit, the robot visits cartridge locations and verifies the vol-id of 
resident cartridges. The library controller updates the cartridge database based on the 
physical audit. This audit changes the “verified” status of the cartridge locations to 
“True.” Audit times vary according to the size of the library.

The library performs a physical audit at the following times:
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• When initiated manually from the SL Console. The following are the two types of 
manually initiated physical audits.

• Entire library audit: The robot:

• Visits all cells (storage, CAP, and drive)

• Catalogs the vol-ids and locations

• Updates the library controller cartridge database 

This audit is a background process, meaning it does not interrupt online 
library operations. Estimated time for such an audit is from less than 10 
minutes for a base module to 30 minutes for a maximum size library. See 
“Audit the Entire Library” on page 318 for details.

• Specific range audit: The robot visits only a specific range of cells (storage, 
CAP, and drive) and updates the library controller cartridge database. The 
audit information is displayed on the SL Console while the audit is performed. 
See “Audit a Range of Cells” on page 320 for details.

Verified Audit

A verified audit validates the status of a specific cartridge location or range of 
locations (including CAPs and drives) in the cartridge database. If a cartridge address 
has a verified status of “false,” a physical audit of that location is performed and the 
cartridge database is updated.

The progress of the audit is displayed in the Audit Console section of the SL Console. 
See “Perform a Verified Audit” on page 322 for details. 

Related Procedures

For detailed procedures, see “Audit Tasks” on page 317. 
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Robot Diagnostic Moves
Note – This feature is available starting with SL500 firmware 
version 1026 and SL Console version 2.40. 

Diagnostic moves are used to monitor or diagnose a problem with a robot. The move 
can be performed with or without cartridges. 

Successful diagnostic moves do not rearrange the cartridges in the storage cells. 
Instead, the system returns cartridges to their original locations after the diagnostic 
move completes. However, some diagnostic move failures can cause cartridges to be 
left in new locations. 

A diagnostic move involves the following elements:

• “Target Address Range” on page 294

• “Pool Address Range” on page 294

• “Move Access Order” on page 295

Target Address Range 

The system performs the get operation in a diagnostic move within a target address 
range of the library. There are two types of access orders for a target address:

• “Sequential Access Order” on page 295 

• “Random Access Order” on page 295 

Valid target address types are:

• Storage cells: Reserves storage locations as the target/pool range

• CAP: Reserves cells in a CAP as the target/pool range

• Drive and storage cells: Reserves drives and storage cells as the target/pool range

• System cells: Reserves system cells, which contain cleaning or diagnostic 
cartridges, as the target/pool range

• All: Reserves storage cells, system cells, CAP cells and drives as the target/pool 
range

Note – Selecting the Storage, CAP, Drive, System, or All option 
does reserve all the associated locations as the target range. 
However, only the location currently being accessed by the robot 
for a get/put operation is unavailable to the host.

Pool Address Range

The system uses the pool address range locations to supply cartridges required for 
diagnostic moves to and from the target address range. Also, the system uses a pool 
address in a get operation if a target address does not contain a cartridge. 

The address ranges are in the Library, Module, Row, and Column format. There is no 
specified access order within the pool address range. The pool address ranges do not 
and cannot include drive locations.
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Move Access Order

Sequential Access Order

In a diagnostic move with a sequential access order, the robot performs a get 
operation starting with the first location in the target address ranges. The robot 
continues visiting the locations sequentially through the range until it completes the 
requested number of moves. 

Note – If you choose not to move cartridges, the get/put 
operations are not performed. In such a case, the robot positions 
itself at the target and pool addresses.

Random Access Order

In a diagnostic move with a random access order, the robot randomly picks a location 
in the target address range to get a cartridge. The robot can also visit the same 
location in the in the target address range multiple times to get a cartridge. The 
random access routine ends after the requested number of moves is complete. 

If you choose not to move cartridges the get/put operations are not performed. The 
robot just positions itself at the target and pool addresses. 
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Diagnostic Move Control Functions

The following TABLE 13-2 lists the options available to manage moves that are 
currently open.

Note – If multiple diagnostic moves are open, each move has its 
own monitor screen.

Related Procedures

For detailed procedures, see “Robot Utility Tasks” on page 327. 

TABLE 13-2  Menu Options for Open Diagnostic Moves

To Select Menu Option Notes

Start File > Start Sequence

Pause File > Pause Sequence Stops all diagnostic moves, but maintains the 
current location in the access order

Stop   File > Stop Sequence Stops a running or paused exerciser

Resume File > Start Sequence Resumes a paused exerciser starting with the 
last known location in the target address 
range

Clear the messages 
displayed in the 
monitor window

File > Clear Output Window Erases the previous message lines and 
continues to fill the screen with new messages

Spool Spool File > Start Spooling Directs the move output to a file

Stop spooling the 
exerciser output to a 
file

Spool File > Stop Spooling Stops directing the move output to the spool 
file
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Troubleshooting 
Before you run diagnostic tests, check the following areas of the library by using the 
following troubleshooting tips in the following TABLE 13-3.

TABLE 13-3  Troubleshooting Tips Prior to Running Diagnostic Tests

Problem What to do

Service Required (amber) 
LED is constantly on.

Using the SL Console, check the health of the library and the attached 
devices (drives, CAPs, and robots). See “StorageTek Library 
Console” on page 23 for more details about operations.

To perform a health check:

1. Log in to the SL Console application.

2. Access the System Detail module, View > System Detail.

3. Check the navigation tree for the following indicators:

• Device Healthy

• Device Error

Additional checks:

• Check the Status (for example, online/offline) and Statistics (for 
example, uptime, downtime, errors and warnings) tabs for more 
information on the health of the library and devices. 

• Make sure the cartridges are fully seated and properly oriented in 
their storage cells.

• Inspect the X table for any foreign objects or debris and remove them 
if found.

Library does not power-
on. The SL Console does 
not display any 
messages.

1. Check that the library power switch is in the ON position. 

2. Check all power cord connections.

3. Replace the power cord.

4. Make sure that there is power to the outlet.

CAP Open LED is on 
and blinking.

Open the CAP and make sure the cartridges in the CAP cells are properly 
seated. 

The SL Console does not 
display modified data or 
information remains 
static.

Check the SL Console Heartbeat icon.
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Related Procedures

For detailed procedures, see “Library Utility Tasks” on page 304. 

Robot Fault or Library 
Fault Amber LED is 
constantly on.

1. Check the SL Console for any displayed error messages. Write down 
the error messages reported.

2. Open the front door. Observe and note the state of the cartridges, 
hand, and tape drives.

3. Make sure cartridges are fully seated and properly oriented in their 
storage cells.

4. Make sure packing materials have been removed.

5. Inspect the library floor for any objects or debris. If there are any, 
remove them.

6. Check the status of the tape drives.

7. Close the front door.

8. Make sure the tape drives are fully seated and locked forward by 
pushing and pulling on the rear of the drive tray. Any motion of the 
tray indicates that it requires reseating and locking down.

Tape drive is unable to 
eject a cartridge.

Manually remove the cartridge from the tape drive. See “Remove a 
Cartridge from a Tape Drive” on page 369.

The client computer 
cannot communicate 
with the library or tape 
drives.

Make sure cables are securely attached to their connectors on the rear of 
the library, the tape drives, and the client computer. Make sure each SCSI 
device on the same bus has a unique address and that the last device is 
properly terminated.

The library is unable to 
communicate with the 
drives.

Make sure cables are securely attached to their connectors on the rear of 
the library, the drives, and the client computer. 

Repeated or excessive 
drive cleanings or 
cleaning messages.

1. Replace the cleaning cartridge with a new cleaning cartridge.

2. Run the Library Self-Test and note if errors are reported for the drive.

3. Run any client computer-based drive diagnostic tests.

Cartridge stuck in tape 
drive.

Manually remove the cartridge. See “Remove a Cartridge from a Tape 
Drive” on page 369.

Tape drive is unable to 
eject a cartridge.

Manually remove the cartridge. See “Remove a Cartridge from a Tape 
Drive” on page 369.

TABLE 13-3  Troubleshooting Tips Prior to Running Diagnostic Tests

Problem What to do
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Diagnostic and Utility Tasks 
Library diagnostic and utility tasks are divided into the following categories:

• “Event Monitor Tasks” on page 300

• “Library Utility Tasks” on page 304

• “Audit Tasks” on page 317

• “Drive Utility Tasks” on page 324

• “Robot Utility Tasks” on page 327
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Event Monitor Tasks
• “Display an Event Monitor” on page 301

• “Spool Event Monitor Data to a File” on page 302

• “Display Multiple Monitors” on page 303
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▼ Display an Event Monitor

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Event monitors are useful tools for root cause analysis of errors. If the library is 
experiencing reproducible errors, you can open an event monitor and spool all events 
to a file to capture the data. Later, you can send the file to your Oracle support 
representative for analysis.

Event monitor information is dynamically updated depending upon the occurrence 
of selected events. The information sent during an e-mail, print, save, or spool 
operation reflects the data (and format) shown on-screen at the time the operation is 
requested. 

Note – To monitor multiple events, see “Display Multiple 
Monitors” on page 303.

Task Steps

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree. 

The system displays the library monitors accessible to you.

3. Click the event monitor you want to use, and then click the Open button in the 
upper right corner. 

The system displays the associated data collected for the event.

4. Manage the information displayed on the screen for the event selected using 
the appropriate options.

The following TABLE 13-4 lists the options available and how to access them.

5. To close a monitor, click the X in the upper right corner of the window. 

TABLE 13-4  Options for Managing Event Monitor Information

To Select

Pause the continuous display of data related to the event 
selected

Monitor > Pause

Resume displaying the events Monitor > Resume

Permanently stop the continuous display of data related 
to the event selected

Monitor > Stop

Clear the event monitor display Monitor > Clear
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▼ Spool Event Monitor Data to a File

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to spool and save event monitor data to a file. You can send the 
file to your Oracle support representative to assist in diagnosing problems.

Task Steps

1. Select Tools > Monitors.

2. Expand the Permanent Monitors folder in the navigation tree. 

The system displays the library monitors accessible to you. 

3. Click the event monitor you want to use, and then click Open in the upper right 
corner. 

The system displays the event monitor window.

4. In the event monitor window, select Spool File > Start Spooling. 

The Save dialog box appears.

5. Browse to the directory where you want to save the file. In the File Name field, 
enter the file name, and click Save. 

All event data is spooled to the specified file. 

6. To stop spooling, select Monitor > Stop Spooling. 

Following is a sample of the spool file:
2008-05-29T11:23:27.448  0,1,0,0     root  default       internal        281    
warn   0  rb_Reboot::reboot(): Resetting drive [0,3,4,9] 
2008-05-29T11:23:27.760  0,1,0,0     root  default       internal        281    
info   0  Service Beacon is ACTIVE: Current Health Event indicates Drive 04 in 
Module 03 is not operational 
2008-05-29T11:23:53.211  0,1,0,0     root  default       internal        281    
info   0  Service Beacon is ACTIVE: Current Health Event indicates Drive 04 in 
Module 03 is operational 



Event Monitor Tasks

SL Console Diagnostics and Utilities   303 

▼ Display Multiple Monitors

You can open and manage multiple event monitors using the selections from the 
Options Bar shown in the following TABLE 13-5.

TABLE 13-5  Options for Opening and Managing Multiple Event Monitors

To Select

Custom arrange the open monitors on screen Window > Arrange

Arrange the event monitor windows horizontally Window > Tile 
Horizontal

Arrange the event monitor windows vertically Window > Tile Vertical

Stack the event monitors Window > Cascade
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Library Utility Tasks 
• “Download Code to the Library Controller” on page 305

• “Activate Code on the Library Controller” on page 306

• “Reboot the Library” on page 308

• “Transfer the Library MIB File” on page 309

• “Generate and Transfer the Library Log Snapshot File” on page 311

• “Perform a Non-Disruptive Library Self-Test” on page 313

• “Perform a Disruptive Library Self-Test” on page 315
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▼ Download Code to the Library Controller

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to download and unpack library firmware upgrades on the 
library controller. 

After completing this procedure, you can choose a convenient time to activate the 
code on the library. See “Activate Code on the Library Controller” on page 306 for 
detailed instructions. 

Note – This procedure is not used for downloading drive 
firmware updates.

Note – This feature is available starting with SL500 firmware 
version 1026 and SL Console version 2.40. 

Task Steps

1. Locate the firmware upgrade package (.img file) on the Oracle download site. 
See “Firmware Download Site” on page 289. 

2. Download the code to a folder on your local PC or workstation. 

3. Log into the SL Console. 

4. Select Tools > Diagnostics, and click the Library folder. 

5. Click the Load Code tab. 

The Load Code page appears. 

The SL500 library firmware package is a.img (image) file.

6. The contents of the file display. Review the contents and file name to verify 
that you have specified the correct firmware package. 

When the code is fully transferred to the library controller, the code unpack 
process begins.

The page indicates the progress of the unpack and when it is complete. 

Next to the Failed label, you should see 0. If there are any failures indicated, 
contact your Oracle support representative for assistance. 

7. After the package is successfully unpacked, you can activate the code 
immediately or wait until a later time. See “Activate Code on the Library 
Controller” on page 306 for detailed instructions.



Library Utility Tasks

306  SL500 User’s Guide

▼ Activate Code on the Library Controller 

Task Tool

This task can be performed at either of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to activate a version of library firmware currently residing in the 
library controller flash memory. Up to two versions of firmware can be resident in 
memory at one time, but only one can be active. The active version is identified as 
“running.”

Prior to performing this procedure you must download and unpack the code you 
want to activate. See “Download Code to the Library Controller” on page 305 for 
detailed instructions. 

This procedure involves a reboot of the library. Schedule the process for a time that is 
convenient for users. 

You can restore the earlier firmware version if required. 

Task Steps

1. Select Tools > Diagnostics, and click the Library folder. 

2. Click the Activate Code tab. 

The Activate Code page appears.

3. In the Target list, select the code package you want to activate.

The list may display a library firmware package and an SL Console package. For 
this procedure, select the firmware package (SL500 Code). 

The Available Versions section of the page displays the versions currently 
residing in flash memory. The version identified as “running” is the currently 
active code. You cannot select this version again to activate.

4. Select the code version you want to activate. 

5. Click the Activate button in the upper right corner.

The Activation Confirmation message appears, asking whether you want to 
continue with the process. 

6. Click OK to begin the activation.

If you click Cancel, the process terminates and returns to Step 4. 

The code activation process begins, and the Activate Console page displays the 
status of the process. 
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Caution – POTENTIAL INTERNAL FILE CORRUPTION. Do not 
reboot any devices in the library or execute any operations on the 
library while code is being activated.

7. When the activation process finishes, a dialog appears, prompting you to reboot 
the library. 

8. Click OK to reboot the library.

If you click Cancel, the process terminates, and you must reboot the library at a 
later time. See “Download Code to the Library Controller” on page 305 for 
detailed instructions. 

The reboot process begins, and a message appears indicating that your SL Console 
session is terminating.

9. Click OK to terminate the SL Console session.

The system logs you off the library.

10. When the library initialization has completed, you can log in again to the 
library through the SL Console login screen. 

The SL Console gets all library configuration data from the library controller. 
Therefore, be careful when logging in to the SL Console before the library has 
fully initialized. You may see warnings that configuration data is not yet available. 
In such a case, you must exit and log in again at a later time. Additionally, if a 
library audit is performed as part of initialization, until the audit is complete, any 
configuration data displayed may not be completely up to date and accurate. 
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▼ Reboot the Library

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to reboot the library. This process involves reloading the firmware 
from flash memory and restarting the library controller.

Note – This feature is available starting with SL500 firmware 
version 1026 and SL Console version 2.40. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click Reboot in the upper right corner.

The Reboot confirmation message appears. 

4. Click OK to continue. 

If the library is online, the Offline confirmation message appears.

5. Click OK to take the library offline. 

The Reboot confirmation message appears. 

6. Click OK to continue. 

The SL Console termination message appears.

7. Click OK to terminate this SL Console session. 

You are logged off the SL Console. The library controller reboots the library. This 
could take several minutes. 

Note – You cannot log back in to the SL Console until the library 
has fully initialized. 
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▼ Transfer the Library MIB File

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to transfer (save) the public SNMP management information base 
(MIB) file to a specified location on your local PC or workstation. The file is saved as 
a text file. E-mail the file to your Oracle support representative to help diagnose 
problems with the library. 

Task Steps

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the TransferFile tab. 

The Library TransferFile page appears. 

4. Click Transfer File. 

The Save dialog box appears. 

5. Browse to the directory where you want to save the file, and enter the file name 
in the File Name field. Be sure to give it a .txt suffix. 

6. Click Save. 

The data is saved to the specified file, and the Transferred Successful message 
appears. 

The following is a partial sample of the MIB file output.
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-- ********************************************************************** 
--          STREAMLINE-TAPE-LIBRARY-MIB (1.3.6.1.4.1.1211.1.15) 
-- 
-- Copyright (c) 2005, 2010, Oracle and/or its affiliates. All rights 
reserved. 
-- 
-- ********************************************************************** 
 
STREAMLINE-TAPE-LIBRARY-MIB DEFINITIONS ::= BEGIN 
IMPORTS      
    enterprises, Counter32, Integer32 FROM SNMPv2-SMI 
    --OBJECT-TYPE FROM RFC-1212 
    OBJECT-GROUP, NOTIFICATION-GROUP, MODULE-COMPLIANCE FROM SNMPv2-CONF 
    TEXTUAL-CONVENTION FROM SNMPv2-TC 
    OBJECT-TYPE, MODULE-IDENTITY, NOTIFICATION-TYPE FROM SNMPv2-SMI; 
 
streamlineTapeLibrary MODULE-IDENTITY 
    LAST-UPDATED "201010280000Z" -- Oct 28, 2010 
    ORGANIZATION "Oracle" 
    CONTACT-INFO "Please contact Oracle/Sun Support:  
                    http://www.sun.com/contact/support.jsp" 
    DESCRIPTION  "The MIB module for StreamLine Tape Library. 
                  Copyright (c) 2005-2010, 
                  Oracle. All Rights Reserved." 
... 
-- ******************************************************************* 
-- 
-- Generic traps: 1-10 
-- 
-- ******************************************************************* 
 
slTrapError  NOTIFICATION-TYPE 
    OBJECTS 
    { 
        slTrapLibrarySerialNumber, 
        slTrapDeviceId, 
        slTrapDeviceTime, 
        slTrapDeviceAddress, 
        slTrapDeviceUserName,  
        slTrapDeviceInterfaceName,  
        slTrapDeviceActivity,  
        slTrapDeviceRequestId, 
        slTrapDeviceSeverity, 
        slTrapDeviceResultCode, 
        slTrapDeviceFreeFormText 
    } 
    STATUS current 
    DESCRIPTION "An error trap - a device condition which is critical to 
machine operation was encountered" 
::= { slSnmpNotifications 1 }
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▼ Generate and Transfer the Library Log Snapshot File

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to generate and transfer (save) the library log snapshot file to a 
specified location on your local PC or workstation. The system saves the file in an 
encrypted format, which means you cannot view or edit it. After generating and 
transferring the snapshot file, e-mail it to your Oracle support representative who 
will use it to diagnose problems with the library.

Note – The feature to generate a log snapshot is available starting 
with SL500 firmware version 1466 and SL Console version 5.70.

Note – Use this procedure only under the direction of your Oracle 
support representative. You must transfer the library log snapshot 
file within 15 minutes after it is generated. After 15 minutes, the 
generated snapshot is no longer available, and you must generate 
another file.

Task Steps

1. Select Tools > Diagnostics.

2. Click the Library folder on the navigation tree.

The Library screen appears.

3. Click the TransferFile tab.

The TransferFile page appears.

4. Select the Log Snapshot radio button if it is not already selected.
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5. Click the button labeled Generate Log Snapshot on Library.

The Create Log confirmation message appears.

6. Click Yes to continue creating the log snapshot.

7. Click OK when the confirmation message displays. 

8. Save the snapshot within 15 minutes after generating the snapshot. 

If you do not save within this 15-minute window, you cannot save the currently 
generated log snapshot file. In this case, you must generate another log snapshot 
file.

Click Transfer Log Snapshot To Your Computer. 

The Save dialog box appears.

9. If you have already created the directory where you want to save the file, 
browse to that directory and click Save.

10. If the directory you want does not exist, enter the name of the directory in the 
File Name field and click Save. 

The Directory Create message appears. Click OK to accept the directory creation 
and dismiss the message. Then click Save at the Save dialog box.

The data is saved in the specified directory, and the Transferred Successful 
message appears.

11. Click OK to dismiss the message. The library automatically names the file. You 
cannot view the file because it is encrypted.
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▼ Perform a Non-Disruptive Library Self-Test 

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to perform a non-disruptive library self-test, which can be used to 
help diagnose operational problems with the library. 

For the test to run completely, make sure the proper diagnostic cartridges for library 
drives are in the library. To verify this, see “List Library Cartridges” on page 256.

Task Steps

1. Select Tools > Diagnostics, and click the Library folder.

2. Click the SelfTest tab.

The Self Test page appears.

3. In the Mode list, select Non-Disruptive. 

4. Click Run to start the test. 

The test begins. The Diagnostic Console section of the page displays the status of the 
various diagnostic tests as they are performed
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When the test completes, the results of the test display. 
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▼ Perform a Disruptive Library Self-Test 

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to perform a disruptive library self-test, which can be used to help 
diagnose operational problems with the library. 

In order for the test to run completely, make sure the proper diagnostic cartridges for 
library drives are present in the library. To verify this, see “List Library 
Cartridges” on page 256.

The library will be taken offline to all hosts while the test runs, and then brought 
back online when the test completes. 

Task Steps

1. Select Tools > Diagnostics, and click the Library folder.

2. Click the Self Test tab.

The Self Test page appears. 

3. In the Mode list, select Disruptive. 

4. Click Run. 

A message appears asking you to confirm that the library will be taken offline to all 
hosts. 

5. Click OK to begin the test. 

The test begins, and the Diagnostic Console section of the page displays the status of 
the various diagnostic tests as they occur.
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When the test completes, the results of the test display in the Diagnostic Console 
section. 

The system brings the library back online automatically so you can resume normal 
operations. 

See “Bring the Library Online” on page 415 for detailed instructions. 
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Audit Tasks
• “Audit the Entire Library” on page 318

• “Audit a Range of Cells” on page 320

• “Perform a Verified Audit” on page 322



Audit Tasks

318  SL500 User’s Guide

▼ Audit the Entire Library

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

During this audit, the robot visits all the storage cells, catalogs the vol-ids and 
locations, and updates the library controller database. 

Note – Although this audit is a background process and does not 
interrupt library operations, it does require sharing of robot 
resources. Therefore, it is not recommended that you run this 
audit during peak activity periods. 

Note – You cannot stop this audit after it has initiated. The audit 
takes approximately 1/2 second per cartridge slot. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the Audit tab.

The Audit page appears. 

4. In the Entire Library section, click the Yes radio button. Then click the Audit 
button in the upper right corner.

A confirmation message appears. 
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5. Click OK to perform the audit as a background process or Cancel to cancel the 
audit.

Note – After you click OK, you cannot stop the audit. It runs until 
completion. 

You can view the Cartridge Summary report after a few hours for the latest 
cartridge locations and vol-ids. See “Display a Library Report” on page 47 for 
details.
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▼ Audit a Range of Cells

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

During this audit, the robot visits only a specific range of storage cells (including the 
cap and drives) and updates the library controller database.

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the Audit tab.

The Audit page appears.

4. In the Entire Library section, click the No radio button. In the Physical Audit 
section, select Yes. In the Verified Audit section, select No.

5. In the Start Address and End Address sections, select the device types you want 
to audit and the starting and ending library internal address locations.

6. Click the Audit button in the upper right corner.

A confirmation message appears.

7. Click OK to perform the audit as a background process, or Cancel to cancel the 
audit.
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Note – After you click OK, you cannot stop the audit. It runs until 
completion. 

The Audit Console section displays the progress of the audit. 

Note – You can also view the Cartridge Summary report for the 
latest cartridge locations and vol-ids. See “Display a Library 
Report” on page 47 for details.



Audit Tasks

322  SL500 User’s Guide

▼ Perform a Verified Audit

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

A verified audit validates the status of a specific cartridge location or a range of 
locations (including CAPs and drives) in the library controller database. If a cartridge 
address has a verified status of “false,” the system performs a physical audit of that 
location and updates the library controller database. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the Audit tab.

The Audit page appears. 

4. In the Entire Library section, select No. In the Physical Audit section, select No. 
In the Verified Audit section, select Yes. 

5. In the Start Address and End Address sections, select the device types you want 
to audit and the starting and ending library internal address locations.

See “Library Internal Address” on page 624 for a detailed explanation of this 
address format. 

6. Click the Audit button in the upper right area of the page.
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The Audit Console section displays the progress of the audit. 
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Drive Utility Tasks
• “Perform a Drive Self Test” on page 325

• “Reboot a Drive” on page 326
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▼ Perform a Drive Self Test

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to perform a self test on a drive.

Task Steps

1. Select Tools > Diagnostics.

2. Expand the Drive Folder, and click the drive you want to test. 

3. Click the SelfTest tab.

4. In the Mode list, select Non-Disruptive. 

5. Click Run in the upper right area of the screen.

Status messages display as the self-test runs. After the test finishes, the system 
displays a message indicating the diagnostic test is complete.

Note – Library devices that are offline in an error state cannot go 
online. The error condition must be cleared first. 
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▼ Reboot a Drive

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to reboot a drive. 

Task Steps

1. Select Tools > Diagnostics.

2. Expand the Drive Folder, and click the drive you want to modify. 

3. Click Reboot in the upper right corner of the screen.

If the drive is offline, the Offline Confirm message appears. 

4. Click OK to take the drive offline. 

The Reboot Confirm message appears. 

5. Click OK. 

The library controller reboots the drive, and the Reboot Success message appears. 

6. Click OK to dismiss the message. 



Robot Utility Tasks

SL Console Diagnostics and Utilities   327 

Robot Utility Tasks
• “Define a Diagnostic Move” on page 328

• “Manage Diagnostic Move Definitions” on page 333

• “Save a Diagnostic Move to a File” on page 335

• “Start a Diagnostic Move” on page 338

• “Monitor and Control Open Diagnostic Moves” on page 340
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▼ Define a Diagnostic Move

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

You can set up and run multiple diagnostic move routines simultaneously, as long as 
the target and pool address ranges do not overlap. 

Note – This procedure requires sharing of robot resources. 
Therefore, it is not recommended that you run it during peak 
activity periods. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder in the navigation tree.

The Library page appears.
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3. Click the DiagMove tab, and then the Manage tab. 

The Manage page appears.

4. In the Defined Sequence section, click Add.

The Sequence dialog box appears. 
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5. Complete the Sequence screen as follows. See “Target Address 
Range” on page 294 for details. 

• In the Selection Mode section, select the type of cells you want to diagnose. 

• In the Minimum Address and Maximum Address sections, select the library 
internal address of the starting and ending locations of the cells you want to 
diagnose. 

6. Click Next. 

The SOURCE dialog box appears. 

7. Complete the SOURCE screen as follows. See “Pool Address 
Range” on page 294 for details. 

• In the Selection Mode sections, select the appropriate cartridge pool address 
type. 

• In the Minimum Address and Maximum Address sections, select the library 
internal addresses of the starting and ending locations of the cartridge pool 
you want to use.
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8. Click Next.

The Sequence dialog box appears. 

9. Complete the Sequence screen as follows. See “Move Access 
Order” on page 295 for details. 

• Name of the diagnostic move.

• Move Count: Specify a number between 1 and 5000.

• Access order: Sequential or Random.

• Move Type: Robot and Cartridge or Robot Only.

• Disable pre-move cartridge compatibility check.
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10. Click Finish to complete the setup.

The Diagnostic Move Manage screen appears. The diagnostic sequence you have 
just defined is listed in the Defined Sequences section. 
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▼ Manage Diagnostic Move Definitions 

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to manage diagnostic move sequence definitions. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the DiagMove tab, and then the Manage tab. 

The Manage page appears.
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4. From the Defined Sequences section, select any of the following options listed 
in the following TABLE 13-6.

5. To manage the diagnostic moves currently open, see “Monitor and Control 
Open Diagnostic Moves” on page 340.

TABLE 13-6  Options for Defining Diagnostic Moves

To
Select 
Option Notes

Define a diagnostic move Add

Start a diagnostic move Open Multiple diagnostic moves may be open at a 
time, so long as the target and pool address 
ranges setup for the moves do not overlap.

Modify options for a 
diagnostic move

Modify This diagnostic move routine must not be 
open or if open must be in a “Stopped” 
state.

Remove a diagnostic 
move

Remove This diagnostic move routine must not be 
open.

Copy an existing 
diagnostic move

Copy Copy a diagnostic move definition, make 
changes if necessary, and assign a different 
name.
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▼ Save a Diagnostic Move to a File 

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to save a defined diagnostic move to a local file on your 
workstation or PC. The file is saved as a JavaBean component represented as an 
XML 1.0 document (.xml). 

You can use the saved file to:

• Restore a move that has been deleted from the library. 

• Copy it to a different library for use there. 

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.
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3. Click the DiagMove tab, and then the Manage tab. 

The Manage page appears.

4. Click the diagnostic move you want to save, and then click the Save button in 
the upper right area of the screen. 

The Save dialog box appears.

5. Browse to the directory where you want to save the file. In the File Name field, 
enter the file name. 

6. Click Save. 

The data is saved to the specified file. The following is a sample excerpt:
<?xml version="1.0" encoding="UTF-8"?>  
<java version="1.5.0_11" class="java.beans.XMLDecoder">  
 <object class=
"com.stortek.ats.elib.opel.model.SequenceBeanList">  
  <string>FRS_4.10</string>  
  <string>SL500</string>  
  <void method="add">  
   <object class=
"com.stortek.ats.elib.opel.model.SequenceBeanList$SequenceBean">  
    <void property="accessOrder">  
     <string>Sequential</string>  
    </void>  
    <void property="moveCartridge">  
     <boolean>true</boolean>  
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    </void>  
    <void property="moveCount">  
     <int>10</int>  
    </void>  
    <void property="name">  
     <string>DriveDiagMove1</string>  
    </void>  
    . . . 
    <void property="targetType">  
     <string>Drive</string>  
    </void>  
   </object>  
  </void>  
 </object>  
</java> 
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▼ Start a Diagnostic Move

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to begin a diagnostic move.

Task Steps

1. Select Tools > Diagnostics. 

2. Click the Library folder on the navigation tree.

The Library page appears.

3. Click the DiagMove tab, and then the Manage tab. 

The Manage page appears.
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4. From the Defined Sequences section, click a diagnostic move, and then click 
Open. 

The Monitor window activates.

You can repeat this step to open multiple moves, as long as the target and pool 
address ranges for the moves do not overlap.

A monitor window displays for each move you open.

5. From each monitor window, select File > Start Sequence to start the move. 
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▼ Monitor and Control Open Diagnostic Moves

Task Tool

This task can be performed at any of the following:

• Standalone SL Console

• Web-launched SL Console

Task Purpose

Use this procedure to control and monitor the status of one or more open diagnostic 
moves.

Task Steps

1. See “Start a Diagnostic Move” on page 338 for instructions on starting one or 
more diagnostic moves. 
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2. Click the Monitor tab. 

The Monitor page appears, with one monitor window for each open move.

Each monitor window has the following status indicators listed in the following 
TABLE 13-7.

TABLE 13-7  Diagnostic Status Indicators of Monitor Windows

Status Indicators Description Valid Values

Spooling Status Indicates if the move output is 
being spooled to a file 

True, False

State Current execution state of the 
move

Running, pausing, paused, 
stopping, stopped

Health Current health state of the 
move

OK, warning, error

Completed moves Number of moves completed 
in the requested move count 
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3. Use the File menu in each Monitor window to perform any of the functions 
listed in the following TABLE 13-8.

TABLE 13-8  Functions Available in Diagnostic Monitor Windows

Select Option To Notes

File > Start Sequence Start 

File > Pause Sequence Pause Stops all diagnostic moves, but 
maintains the current location in the 
access order.

File > Stop Sequence Stop   Stops a running or paused move.

File > Start Sequence Resume Resumes a paused move starting with 
the last known location in the target 
address range.

File > Clear Output Window Clear the messages 
displayed in the monitor 
window

Erases the previous message lines and 
continues to fill the screen with new 
messages.

Spool File > Start Spooling Spool Directs the move output to a file.

Spool File > Stop Spooling Stop spooling the move 
output to a file

Stops directing the move output to the 
spool file.
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SNMP Configuration with SL Console

Simple Network Management Protocol (SNMP) is an application layer protocol that 
performs network management operations over an Ethernet connection using User 
Datagram Protocol (UDP/IP). 

SNMP enables: 

• Libraries to inform the systems administrator of potential problems.

• System administrators to query the library for configuration, operation, and 
statistical information.

• Libraries to gather information to be sent to the StorageTek Tape Analytics (STA) 
server, if applicable. For more information, see the STA Installation and 
Administration Guide.

Supported Versions of SNMP
The SL500 library supports: 

• SNMPv2c: Read-only support primarily for machine status queries. With this 
version, any information transmitted is not secure.

• SNMPv3: Both read and write support. Transmitted information is secure.

SNMP Configuration Requirements
SNMP configuration requirements include the following:

• SL500 library firmware must be version 1067 or higher.

• SL Console software must be version 2.95 or higher.

Trap Numbering/Levels 
An SNMP trap is assigned numbers or levels that correspond to its type. An 
embedded SNMP agent can distinguish and filter trap recipients to include only 
those traps that you wish to monitor. These levels are specified when entering the 
trap information. Generic traps are numbered 1-10 and are generated from log entries 
containing: 

• Severity (indications such as error or warning)
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• Result codes (such as “0000 = success,” or “5010 = robotic posn error”)

• Activity string (such as “HLI move” or “CLI version print”)

• A descriptive text string

• Date and time

Other information might include:

• Device address associated with the event

• User name associated with the activity (such as “HLI host,” “advsrv”)

• The interface-specific request identifier (such as “HLI000001”)

Trap numbers 11 and higher are specific and contain distinct Object IDs (OIDs) 
within their messages. They are generated from events within the library rather than 
the log entries.

Trap or notification levels available at this time for the SL500 are listed in 
TABLE 14-1.

Note – You can also set combinations of trap levels. For example, 
“1,2”, “1,11”, “1,2,11.”

Port Control
Typically, SNMP uses user datagram protocol (UDP) ports:

• 161 for the agent

• 162 for the manager

UDP, like TCP, runs on top of IP networks and is oneone of the core protocols in the 
Internet protocol suite. UDP enables network-based devices to send short messages 
faster and more efficiently for many lightweight and time-sensitive applications.

The basic protocol for communications between manager and agent is as follows:

• The manager can send requests from any available port to the agent at port 161. 
The agent then responds to that source port, to the requesting manager.

• The agent generates traps or notifications and sends them from any available port 
to the manager at port 162.

TABLE 14-1  SNMP Trap Levels

Trap Level Number Description

Error 1 Error/System Log entries. Errors critical to library 
operation. For example, Device inoperable: refers to the 
entire system. Failure of a redundant component is not a 
Category 1.

Warning 2 Warning Log entries. Conditions that require attention. For 
example, Device degraded: Refers to recoverable failures 
that may allow the system to remain in use, but only in a 
degraded mode.

11 11 SNMP Agent Start Up
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Access Control
SNMPV2c community strings are capable of providing a form of access control in 
SNMP. Because of this, the Oracle StorageTek embedded agent will not allow 
community strings to make changes to the library’s configuration.

Either SNMPv2c or SNMPv3 can retrieve the MIB file. However, because SNMPv3 
provides encryption capabilities and a stronger user identification, library properties 
can be changed only with the SNMPv3 set command.

Using an administrative password also provides access control and authorization for 
set command operations.

Traps, however, can be sent to recipients using either SNMPv2c or SNMPv3 by 
adding entries to the Trap Recipient List.
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SNMP Configuration and Usage Tasks
• “Add SNMP Users” on page 347

• “Delete SNMP Users” on page 349

• “Add Trap Recipients” on page 350

• “Delete Trap Recipients” on page 352

• “Set Up Port Control” on page 353



SNMP Configuration and Usage Tasks

SNMP Configuration with SL Console   347 

▼ Add SNMP Users

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to add an SNMP user. 

Task Steps

1. Select Tools > System Detail.

2. Select the Library folder on the navigation tree. 

3. Select SNMP > Add Users

The Add Users page appears.

4. For each user you want to add, enter information based on the following 
descriptions:

For SNMPV2c:

• Version list: Choose v2c. With this version, any information transmitted is not 
secure.

• Community (v2c only) field: Enter the community string. Applications use 
community strings for access control, with a maximum of 31 alphanumeric 
characters. The manager includes the community string in its SNMP messages 
to an agent. The agent consequently can accept or reject the operation. 

For SNMPV3c:

• Version (v3 only) list: Choose v3. Because this version supports encryption and 
stronger user identification, it is the preferred protocol for proprietary data.

• UserName (v3 only) field: Enter the SNMP user ID.
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• Auth (v3 only) field: Select the authentication protocol type (MD5 or SHA). 
These protocols are  designed to reliably identify the integrity of the 
originating party.

• AuthPass (v3 only) field: Enter the authentication password of the user.

• Priv (v3 only) list: Choose the privacy protocol type (DES or AES). These 
protocols are designed to protect information within the message from 
disclosure.

• PrivPass (v3 only) field: Enter the encryption password that is the private key 
for encryption.

5. Click the Apply button.

The indexed SNMP list of users displays in the Users section of the screen. A 
maximum of 20 user accounts are available.
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▼ Delete SNMP Users

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to delete a SNMP user. 

Task Steps

1. Select Tools > System Detail.

2. Select the Library folder on the navigation tree. 

3. Select SNMP > Delete Users.

The Delete Users page appears.

4. Review the list of SNMP users in the Users section and note the index number 
of the user you want to delete.

5. Enter the user’s index number in the Index field.

6. Click the Apply button. 

Review the SNMP users list and verify the user was deleted. 
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▼ Add Trap Recipients

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to add a trap recipient.

A recipient is a location on a manager where the SNMP agent sends traps. This 
location is defined by the combination of either the IP address or DNS name and the 
port number. 

Task Steps

1. Select Tools > System Detail.

2. Select the Library folder on the navigation tree. 

3. Select SNMP > Add Trap Recipient.

The Add Trap Recipients page displays. 

4. For each trap recipient you want to add, enter information based on the 
following descriptions:

For SNMPV2c:

• Host field: Server name where the SNMP software application resides.

• TrapLevel field: See “Trap Numbering/Levels” on page 343 for details.

• Version list: Version of the SNMP standard. Choose SNMPv2c for machine 
status queries. With this version, any information transmitted is not secure.

• Community (v2c only) field: Enter the community string. Applications use 
community strings for access control, with a maximum of 31 alphanumeric 
characters. The manager includes the community string in its SNMP messages 
to an agent. The agent consequently can accept or reject the operation. 

For SNMPV3c:

• Host field: Server name where the SNMP software application resides.

• TrapLevel field: See “Trap Numbering/Levels” on page 343 for details.
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• Version list: Choose SNMPv3 for proprietary information. Because this version 
supports encryption and stronger user identification it is the preferred protocol 
for proprietary data.

• TrapName (v3 only) field: Enter the name of the trap recipient.

• Auth (v3 only) field: Enter the authentication password of the user.

• Priv (v3 only) list: Choose the privacy protocol type (DES or AES). These 
protocols are  designed to protect information within the message from 
disclosure.

• PrivPass (v3 only): Enter the encryption password that is the private key for 
encryption.

• EngineID (v3 only): Enter the engineId.

5. Click Apply. 

The indexed trap recipients list is displayed at the bottom of the screen. This list 
supports up to 20 recipients with no duplicate entries. Users must add themselves 
to the recipients list to receive traps.
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▼ Delete Trap Recipients

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to delete a trap recipient. 

Task Steps

1. Select Tools > System Detail.

2. Select the Library folder on the navigation tree. 

3. Select SNMP > Delete Trap Recipients.

The Delete Trap Recipients page appears.

4. Reference the Trap Recipients list and note the index number of the trap 
recipient you want to delete.

5. At the Index field, enter the index number of the trap recipient to be deleted.

6. Click the Apply button in the upper right of the screen. 

7. Verify the trap recipients list and make sure that the trap recipient is deleted. 
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▼ Set Up Port Control

Task Tool

This procedure can be performed at either of the following:

• Standalone SL Console

• Web-launched SLC

Task Purpose

Use this procedure to set up SNMP port control. 

Task Steps

1. Select Tools > System Detail.

2. Select the Library folder on the navigation tree. 

3. Click SNMP > Port Control.

4. At the Port list, select Port 1B.

Port 1B is the public access port. Other ports are unavailable on this library.

5. At the Command list, choose one of the following options:

• Disable: Agent trap requests are sent and received on LAN port.

• Enable: SNMP traps are enabled and the agent responds to “gets” from the 
clients.

Click Apply. 
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Manual Operations

When in manual mode of operation, the library is unavailable for host access. This 
could be because the library has experienced an unrecoverable error or a library 
component requires service or installation. When the library is in this mode, cartridge 
mounts and dismounts require human intervention. 

Library Safety
Thoroughly review the safety precautions in this section before attempting to enter 
the library. It is essential that you follow proper safety procedures at all times. 

Cards and Power Supply

The RLC card, SCSI (MPW/RLW) or Fibre Channel (MPU2 or PUA2) interface card, 
and the power supply are housed inside protective modules to prevent you from 
coming into contact with hazardous voltages and sensitive electronics.

Robotics

The software parks the robot by retracting it into the robotics unit module before the 
front door can be opened to prevent the robot from being damaged. 

When the front door is opened, power is removed from the robot.

Front Door

The front door must be opened with a key to ensure that the data is secure. If the 
door is not fully closed, a sensor relays the condition to the software and the robot 
remains disabled.
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Manual Operation Tasks
Manual library tasks are divided into the following categories:

• “General Library Operation Tasks” on page 357

• “Cartridge Handling Tasks” on page 365
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General Library Operation Tasks
• “Power Off the Library” on page 358

• “Power On the Library” on page 359

• “Return the Library to Ready Status” on page 360

• “Open the Front Door (With Power)” on page 361

• “Open the Front Door (Without Power)” on page 362

• “Secure the Front Door (With Power)” on page 364

• “Secure the Front Door (Without Power)” on page 364
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▼ Power Off the Library

Caution – Possible equipment or cartridge damage or data loss. If you 
power off the library without performing the following procedure, 
you risk possible equipment or cartridge damage or loss of data.

1. Make sure all jobs have completed processing.

2. Quiesce the library to make sure the library and tape drives are not in use.

Note – Refer to your client server software publication for 
instructions.

3. Move the power-on/off switch to the OFF position (0).
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▼ Power On the Library

To power on the library:

1. Close and lock the front door if the door is open.

2. Press the power switch (on the top right corner of the back of the library) to the 
ON (1) position. 



General Library Operation Tasks

360  SL500 User’s Guide

▼ Return the Library to Ready Status 

To return the library to ready status, complete the following steps:

1. Make sure cartridges are inserted correctly in the storage cells or tape drives 
and that they do not block the path of the X table assembly.

2. Close the door and lock it by turning the key counterclockwise. Put the key in a 
safe place.

3. Make sure the power switch are set to the ON position (1).

4. Check the status display of the SL Console to make sure the library goes to 
Ready Status when initialization and audit are complete.

5. Enter the system command to place all tape drives online.

6. When all tape drives are online, enter the command to place the library online.
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▼ Open the Front Door (With Power)

To open the front door when library power is on:

1. Press the Open Door button on the keypad.

The software allows the current job to complete.

The software retracts the robot into the robotic unit to prevent the robot from 
being damaged and to prepare it for servicing. 

2. When the Open Door indicator turns on, use the key to open the door.
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▼ Open the Front Door (Without Power)

To open the front door when no library power exists, complete the following process.

Note – You must manually move the robotics park lever (beneath 
the facade and to the bottom left of the keypad) to the left position 
so that you can open the door with the key. Under normal 
conditions, the lever signifies that the robot is parked inside the 
robotics unit at the top of the library, and the door can be safely 
opened. When no power exists, the robot is not actually parked, 
but you will be able to open the door when you move the lever to 
the left.

In FIGURE 15-1, the lever is not in the parked position.

1. Press the power switch on the back of the library to the OFF position.

2. Remove the robotic facade from the top of the library by gently pulling the 
facade from side to side to pull the ball studs away from the clips. You might 
have to use a screwdriver to gently pry it off.

Warning – Possible injury to finger. Make sure that your finger is 
completely to the left in the next step. Otherwise it could be 
pinched when the door locking lever extends as shown in the 
lower picture.

FIGURE 15-1  Robotics Park Lever Not in Parked Position
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3. While using one hand to move the robotics park lever to the left, use your other 
hand to unlock the door with the key.

FIGURE 15-2  Opening the Front Door Without Power
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▼ Secure the Front Door (With Power)

To secure the front door when library power exists, push it closed and use the key to 
lock it.

▼ Secure the Front Door (Without Power)

To secure the front door when no library power exists:

1. Remove the robotic facade from the top of the library by gently pulling the 
facade from side to side to pull the ball studs away from the clips. You might 
need to use a screwdriver to gently pry it off.

Caution – Possible component damage. Note the door locking lever 
protruding from the top of the door. Do not let it hit the robotics 
park lever when you close the door.

2. While using one hand to move the robotics park lever to the left, use your other 
hand to close the door.

3. While still holding the door shut, release the robotics park lever.

4. Use the key to lock the door.

5. The robotics lever automatically moves to the right when the door locking lever 
retracts.

FIGURE 15-3  Closing the Front Door Without Power
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Cartridge Handling Tasks
• “Locate and Remove a Cartridge” on page 366

• “Insert Cartridges into Storage Cells” on page 367

• “Insert a Cartridge into a Tape Drive” on page 368

• “Remove a Cartridge from a Tape Drive” on page 369

• “Remove a Cartridge from the Gripper Assembly” on page 370

• “Replace a Cleaning Cartridge” on page 372
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▼ Locate and Remove a Cartridge 

To locate a particular cartridge inside the library: 

1. Open the door.

2. Locate the particular cartridge by its VOLID (volume ID) label and storage cell.

3. Remove the cartridge from the cell by sliding the cartridge out.

4. Close the library door.
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▼ Insert Cartridges into Storage Cells

Depending on the version and configuration of your library, some storage cells 
cannot be used. See Appendix A, “SL500 Wall Diagrams and Specifications” for 
details.

You do not have to insert a cartridge into every storage cell. The library automatically 
audits cartridges and empty cells as part of its initialization routine.

Note – You can place LTO cartridges in either LTO arrays or 
mixed-media arrays. SDLT/DLT-S4 cartridges can only be placed 
in mixed-media arrays, not LTO arrays.

Caution – Potential library fail. Cartridges inserted correctly is 
critical for library operation. If you do not orient the cartridges 
correctly or do not insert them all the way into the storage cells, the 
library could fail, and the SL Console might display an error 
message. Make sure you insert the cartridge inside the array, not 
above or beneath it. FIGURE 15-4 shows the correct way to insert 
cartridges into the magazine.

1. Check the cartridges to make sure they are correctly labeled.

2. Insert as many cartridges into the library as you want and as your configuration 
allows, making sure you seat them all the way into the storage cells.

.

FIGURE 15-4  Inserting Mixed Media Cartridges into Arrays

1. SDLT/DLT-S4 cartridge

2. LTO cartridge
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▼ Insert a Cartridge into a Tape Drive

Use this procedure to manually insert a cartridge into a tape drive, as illustrated in 
FIGURE 15-5.

Note – You can place LTO cartridges in either LTO arrays or 
mixed-media arrays. SDLT/DLT-S4 cartridges can only be placed 
in mixed-media arrays, not in LTO arrays.

1. Obtain the VOLID label, location, and tape drive number from the server 
console.

2. Open the door.

3. Locate the cartridge (see “Locate and Remove a Cartridge” on page 366).

Caution – Potential equipment damage. You must insert the cartridge 
properly or you will damage the tape drive. 

4. Hold the cartridge with the VOLID facing you so that it can be read from right 
to left.

5. Insert the cartridge into the tape drive.

6. Close the library access door.

FIGURE 15-5  Inserting SDLT and LTO Cartridges into Drives

1. SDLT/DLT-S4 Drive

2. SDLT/DLT-S4 Cartridge

3. LTO Cartridge

4. LTO Drive
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▼ Remove a Cartridge from a Tape Drive

To manually remove a cartridge from a tape drive, complete the following steps:

1. Obtain the tape drive number from the server console.

2. Open the door and locate the appropriate tape drive.

Caution – Possible data loss. Failure to perform the next step could 
result in data loss.

3. Press the Unload button on the tape drive (as shown in FIGURE 15-6 and 
FIGURE 15-7) and wait approximately 12 seconds until the operation completes.

4. Gently pull the cartridge from the tape drive.

5. Store the cartridge in an empty storage cell or outside the library. 

Note – If you store the cartridge in an empty storage cell, you 
must reinitialize the library and update the tape management’s 
database (see “Return the Library to Ready Status” on page 360).

6. Close the library door.

FIGURE 15-6  Unload Button on IBM and HP LTO Tape Drives

IBM HP

FIGURE 15-7  Unload Button on SDLT Tape Drive

1. SDLT Unload Button

L204_573SDLT

1
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▼ Remove a Cartridge from the Gripper Assembly 

The hand assembly can be in any position when the library loses power. Before you 
can remove the cartridge, the hand assembly must be facing the front left arrays and 
aligned with an empty storage cell. FIGURE 15-8 shows components involved in the 
removal process.

See “Open the Front Door (Without Power)” on page 362.

If the hand assembly is facing right:

1. Gently turn the hand to the left.

2. Slide the hand assembly along the rail until the gripper is positioned across 
from an empty storage cell and close to you. 

3. Continue with the following steps.

If the hand assembly is facing left:

1. Turn the gripper belt (FIGURE 15-8 on page 371) to extend the gripper until the 
release screw is accessible. 

2. Use a small, flat-blade screwdriver to turn the screw 1/4 turn clockwise until the 
cartridge is released.

3. Push the cartridge into a storage cell. 

4. Gently push the gripper back into the hand.

5. Slide the hand assembly toward the back of the library.



Cartridge Handling Tasks

Manual Operations   371 

6. Remove the cartridge from the storage cell, or leave it there.

FIGURE 15-8  Removing Cartridge from Gripper Assembly

1. Gripper belt and pulleys

2. Release screw

3. Gripper

L204_227

2

32

1
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▼ Replace a Cleaning Cartridge

Cleaning cartridges have a limited life span. Refer to your tape drive publication to 
determine how many times a cleaning cartridge should be used. When the usage 
count exceeds its limit, you must replace it with a new one. You can use the SL 
Console to eject the cleaning cartridge to the CAP.

To replace a cleaning cartridge:

1. Open the door.

2. Remove the expired cleaning cartridge from its reserved cell.

3. Insert the new cleaning cartridge into that cell. 

Note – Refer to TABLE B-1 on page 408 to make sure your 
cartridge has the correct vendor and usage label.

4. Close the library door.

The SL Console status display shows that initialization tests are running.

5. Wait until the initialization tests complete before you perform another task.
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A

SL500 Wall Diagrams and Specifications

This appendix provides the following diagrams and tables:

• “LTO Configurations” on page 374

• “Mixed-Media Configurations” on page 379

• “Specifications” on page 382

Use the legend in TABLE A-1 for all diagrams in this appendix. 

Note – Your tape management software might conflict with the 
following information. Refer to your software publication for 
unique information. 

TABLE A-1  Cell Figure Legend

Storage cells available for customer data cartridge

Cells reserved for cleaning and diagnostic cartridges (can be 
configured for data cartridges)

Cells only available when an expansion module is installed. If this 
is the lowest module in the rack, these cells are not available.

Array targets

Tape drives
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LTO Configurations
The following figures show LTO storage cell and tape drive locations. 

FIGURE A-1 shows a library with only a Base Module.

FIGURE A-1  Base Module LTO Cells   
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FIGURE A-2 and FIGURE A-3 show a library with a Base Module that has nine 
reserved cells, one Drive Expansion Module, and one Cartridge Expansion Module.

FIGURE A-2  LTO Cell Locations for Firmware Site Mapping
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FIGURE A-3  LTO Cell Locations for SCSI Element Numbering Mapping   
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FIGURE A-4 shows a library with a Base Module that has two reserved cells, one 
Drive Expansion Module, and one Cartridge Expansion Module. The storage cell 
numbering begins with the first cell after the reserved cells in column 1. The figure 
shows two reserved cells, but there could be more. If the reserved cells are configured 
as storage cells, the top cell (row 1) would be 1.

FIGURE A-4  LTO Cell Locations for SCSI Element Numbering Mapping
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FIGURE A-5 shows the cell capacity of a Cartridge Expansion Module according to 
the type of module that is installed above and below it.

FIGURE A-5  LTO Cells for Back Wall of Cartridge Expansion Module
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Mixed-Media Configurations
The following figures show mixed-media storage cell and tape drive locations.

FIGURE A-6, shows a library with only a Base Module. 

FIGURE A-6  Base Module Mixed-Media Cells
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FIGURE A-7, shows a library with a Base Module that has eight reserved cells, one 
Drive Expansion Module, and one Cartridge Expansion Module. 

FIGURE A-7  Mixed-Media Firmware Cell Mapping
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FIGURE A-8, shows the cell capacity of a Cartridge Expansion Module according to 
which type of module is installed above and below it.

FIGURE A-8  Mixed-Media Cells for Back Wall of Cartridge Expansion Module  
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Specifications
The following pages provide the following specifications: 

• “Library and Rack Dimensions” on page 383

• “Library and Rack Clearances” on page 384

• “Power Specifications” on page 385

For specific tape drive and cartridge information, refer to vendor documentation.
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FIGURE A-9  Library and Rack Dimensions

1. Width of front of Base Module with flange: 48.3 cm (19.0 in.) 

2. Height of Base Module: 35.6 cm (14.0 in.) 

3. Height of expansion modules: 35.6 cm (14.0 in.) 

4. Distance between rack holes: 46.5 cm (18.3 in.) 

5. Front to rear rack mounting distance: 

Original modules: 60.9 cm (24.0 in.) to 86.4 cm (34.0 in.), optimally 74 cm (29 in.)

EZ install modules: 55.9 cm (22.0 in.) to 78.7 cm (31.0 in.) or up to 94 cm (37 in.) 
with optional extensions, optimally 66 cm (26 in.)

6. Width of back of Base Module: 44.5 cm (17.5 in.) 
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FIGURE A-10  Library and Rack Clearances

1. Minimum service clearance behind the library or rack: 60.9 cm (2 ft) 

2. Depth of Base Module, front mounting plane to back of drives: 81.0 cm (31.9 in.) 

3. Depth of Base Module:

Original module: 76.2 cm (30.0 in.) depth of 

EZ Install module: 71.4 cm (28.1 in.) or up to 94 cm (37 in.) with optional 
extensions

4. Depth of front door, required clearance: 3.8 cm (1.5 in.) 

5. Depth of front door and unique latch hardware: 5.3 cm (2.1 in.) 

6. Front door opening clearance 24.1 cm (9.5 in.)

7. Minimum front service clearance: 60.9 cm (2 ft) 
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Power Specifications

TABLE A-2, TABLE A-3, and TABLE A-4 list power specifications for the modules 
and tape drives.

TABLE A-2  Power for Library Without Tape Drives

Input voltage 100–240 VAC, single phase

Frequency 50/60 Hz

Maximum library power consumption 1.4 A @ 120 V  
0.8 A @ 240 V

Maximum heat output 614 Btu/hr

Voltage-amperes 180 VA

TABLE A-3  Power for Base Unit and Two LTO Tape Drives

Power Two LTO Tape Drives

Input power 219 Watts

Input voltage-amperes 226 voltage-amperes

Input current (100 VAC) 2.3 amperes

Input current (120 VAC) 1.9 amperes

Input current (240 VAC) 0.9 amperes

Btu/hour 748 Btu/hr

TABLE A-4  Power for Drive Expansion Module and Four LTO Tape Drives

Power Four LTO Tape Drives

Input power 288 Watts

Input voltage-amperes 297 voltage-amperes

Input current (100 VAC) 3.0 amperes

Input current (120 VAC) 2.5 amperes

Input current (240 VAC) 1.2 amperes

Btu/hour 983 Btu/hr
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B

Cartridge Handling 

This chapter provides information on labeling and handling tape cartridges used in 
Oracle StorageTek libraries, and covers the following topics:

• “Software Support for Cartridges” on page 387

• “Barcode Label Standard” on page 387

• “Cartridge Types” on page 388

• “Supported Labels” on page 388

• “Handling Cartridges” on page 390

• “Cartridge Handling Tasks” on page 392

Library cartridges must meet specifications defined in American National Standard 
Magnetic Tape and Cartridge for Information Interchange. 

For more information on cartridges and labels, see:

• The drive vendor’s publication and Web site for cartridge requirements and 
specifications

• The System Assurance Guide for the SL8500 library.

Software Support for Cartridges
For the SL8500 library, the appropriate software microcode level needed is required 
for various tape drives. For this microcode information, see the System Assurance 
Guide for the SL8500 library.

Barcode Label Standard
The SL8500 library uses labels based on the Code 39 barcode standard. This standard 
uses discrete barcodes, which means that a fixed pattern of bars represents a single 
character. Code 39 barcode standard supports the following characters:

• 36 unique alpha-numeric characters: Letters A through Z and the numbers 0 
through 9

• Special characters, which are not part of the customer label: - . $ / + % * 
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When multiple characters are arranged together as a label or volume serial number 
(VOLSER), a single, narrow white bar is placed between the individual character 
barcodes (called the inter-character gap).

Cartridge Types
The SL8500 library uses the following types of cartridges:

• Data cartridges store data written to them.

• Cleaning cartridges clean the tape path and read/write heads of the tape drives.

• Diagnostic cartridges are for service representatives to run read and write tests on 
the tape drive. In general, these tapes are standard data cartridges with a special 
diagnostic label.

Cartridge labels include a media domain and media ID. Together, these identify to  
the library the cartridge’s type of media and use. IDs allow you to mix tape drive 
types and media types in a single library or library complex. The media ID label 
corresponds to the tape drive or transport capable of using the cartridge. The media 
domain indicates whether the cartridge is for data, cleaning, or diagnostic use.

Cleaning and Diagnostic Cartridges 

Cleaning and diagnostic cartridges require different labels to distinguish them from 
data cartridges. As the name implies, cleaning cartridges clean the tape path and 
read/write heads of the tape drives.

Diagnostic cartridges are for service representatives to run read and write tests on the 
tape drive. In general, these tapes are standard data cartridges with a special 
diagnostic label. 

The first alphanumeric characters in the label sequence determine the type of 
cartridge being used. The vol-id (volume serial number) contains:

• CLN for cleaning cartridges

• DG for diagnostic cartridges

Each cleaning and diagnostic kit includes one labeled cleaning cartridge and one 
labeled diagnostic cartridge. Each of these are labeled with a volume ID of 0. Extra 
cleaning and diagnostic labels are sent with each library. 

You cannot use cleaning and diagnostic cartridges as scratch cartridges, and software 
utilities cannot initialize them.

Caution – Procedure error: When you enter a cleaning cartridge, the 
software considers it to be new, and sets the usage counter to zero. 
DO NOT RE-ENTER A CLEANING CARTRIDGE THAT THE 
LIBRARY EJECTS THROUGH THE CAP. 

Supported Labels
Barcode labels must match the drive type. The following labels are appropriate for 
the corresponding drive.
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• LTO drives: Labels with eight characters. This label includes a six character 
customer defined volume serial number or the cartridge’s function, such as 
diagnostic or cleaning. The other two characters identify the media domain or 
tape technology, and the media ID or version of that particular technology. 

• DLT drives: Labels with seven characters. The seventh character is a small 
identifier below the sixth character for the media ID or version.

Labels for LTO Cartridges

LTO technology was initially developed by IBM, Hewlett-Packard, and Quantum. 
LTO is an open format technology, meaning users have muliple sources of product 
and media. 

LTO cartridge labels have eight characters. The last two characters are the media ID 
(L3, L4, L5, LT, LU, or LV). CLN or DG are the first characters on the cleaning or 
diagnostic labels. LTO4 and LTO5 tape drives also support encryption. 

Note – Check availability for LTO Gen 4 drives and media. 
Library firmware must be Version 1126 or later to support LTO 
Gen 4 drives and media.

Labels for DLT and SDLT Cartridges

Media IDs for DLT and SDLT cartridges do not indicate the type of cartridge (data, 
cleaning or diagnostic). Instead, cleaning cartridges begin with CL (space), and 
diagnostic cartridges begin with DG (space).

TABLE B-1  Labels for LTO Cartridges

Media ID Cartridge Type Drive Type or Additional Information

L1 Data Generation 1

L2 Data Generation 2

L3 Data 400 GB, Generation 3

L4 Data 800 GB, Generation 4

L5 Data 1.5 TB, Generation 5

LT Data 400 GB, Gen 3 only. Write once read many times 
(WORM).

LU Data 800 GB, Gen 4 drive only (WORM).

LV Data 1500 GB, Gen 5 drive only (WORM).

CU Cleaning Beginning characters are CLN (blank space) + VOLID. 
Oracle recommends using the CLN + CU universal label 
instead of a vendor-unique label (CLN + C1 for Hewlett-
Packard or CLN + C2 for IBM).

DG Diagnostic Beginning characters are DG (blank space) + VOLID. 
You can apply a DG label to a blank data cartridge to 
use the cartridge for library diagnostic tests. 
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Handling Cartridges
When cartridges are improperly handled, loss of data or damage to a library 
component can occur. To handle a cartridge correctly:

• Keep cartridges clean. 

• Inspect a cartridge before each use and never put a damaged cartridge into a drive 
or library. 

• Never open a cartridge. 

• Do not handle tape that is outside the cartridge; the tape edge might be damaged. 

• Do not expose the tape or cartridge to direct sunlight or moisture. 

• Do not expose a recorded cartridge to magnetic fields; this might destroy data on 
the tape. 

Inspecting a Cartridge

A defective or dirty cartridge can damage a tape drive. Always inspect a cartridge 
before you insert it into a tape drive or a library. Look for:

• Cracked or broken cartridge

• Damaged write-protect switch

• Liquid in the cartridge

• Labels not firmly or neatly attached or extending over the cartridge edge

TABLE B-2  Labels for DLT and SDLT Cartridges

Media ID Cartridge Type Additional Information

B Data DLT1

C Data DLTtape III

D Data DLTtape IV

E Data DLTtape III-XT

S Data SDLT 220/320 cartridge

2 Data SDLT 600

4 or S4 Data DLT-S4

CLN + S Cleaning 1500 GB, Gen 5 drive only (WORM)

DG + 2 Diagnostic Beginning characters are CLN (blank space) + VOLID. 
Oracle recommends using the CLN + CU universal 
label instead of a vendor-unique label (CLN + C1 for 
Hewlett-Packard or CLN + C2 for IBM).

DG + 4 Diagnostic Beginning characters are DG (blank space) + VOLID. 
You can apply a DG label to a blank data cartridge to 
use the cartridge for library diagnostic tests. 
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• Any other obvious damage

Inserting a Cartridge in a Drive or Cell

A defective or dirty cartridge can damage a drive. Always inspect a cartridge before 
you insert it into a drive or into a tape library. Look for:

• Cracked or broken cartridge

• Broken tape access door

• Damaged file-protect selector or write-protect switch

• Liquid in the cartridge

• Labels not firmly attached or extending over the cartridge edge

• Any other obvious damage

Insert a cartridge in a storage cell, CAP cell, or drive with the bar code on the bottom, 
and the VOLID readable from right to left. The cartridge hub must always be down.

Cleaning the Cartridge Exterior 

Keep your tape cartridges in good condition. A defective or dirty cartridge can 
damage a tape drive see “Inspecting a Cartridge” on page 390.

Caution – Potential damage to cartridges. Do not use certain solvents 
to remove labels or to clean cartridges because they can damage the 
cartridges. Do not use acetone, trichloroethane, toluene, xylene, 
benzene, ketone, methylethyl ketone, methylene chloride, 
ethyldichloride, esters, ethyl acetate, or similar chemicals. 

To clean a cartridge exterior:

• Wipe all dust, dirt, and moisture from the cartridge with a lint-free cloth. 

• Use Oracle StorageTek Tape Cleaner Wipes to clean the cartridges. These wipes 
are saturated with isopropyl alcohol. Do not let any solution touch the tape or get 
inside the cartridge.

Storing Cartridges

When storing a cartridge:

• Do not take a cartridge out of its protective wrapping until you are ready to use it. 
Use the tear string, not a sharp instrument, to remove the wrapping. 

• Store cartridges in a clean environment that duplicates the conditions of the room 
in which they are used. 

• Before using a cartridge, make sure that it has been in its operating environment 
for at least 24 hours. See the user manual for the drive for details.
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▼Apply a Label to a Cartridge

Cartridge labels indicate the type of cartridge media and usage. If your cartridges 
were not ordered with pre-applied labels, you must apply them yourself. Correctly 
label all cartridges for library use. Use labels that do not leave a residue when they 
are removed.

Caution – Possible misread of volume number label. Make sure the 
edges of the labels do not curl. A curled label causes the cartridge to 
become jammed in the tape drive loader, and the robot misreads the 
label.

1. Make sure the cartridge has been at room temperature for at least 24 hours.

2. Clean the surface where the label will be placed. Use Oracle StorageTek Tape 
Cleaner Wipes to clean the cartridges.

Caution – Potential damage to cartridges. Do not use certain solvents 
to remove labels or to clean cartridges because they can damage the 
cartridges. Do not use acetone, trichloroethane, toluene, xylene, 
benzene, ketone, methylethyl ketone, methylene chloride, 
ethyldichloride, esters, ethyl acetate, or similar chemicals. 

3. Locate the type of label you need. Make sure the label contains a vol-id.

4. Peel the backing from the cartridge label.

5. For an LTO cartridge, hold the cartridge so that the write-protect switch is 
toward you. For a 9840 or 9940 label, hold the cartridge so that the two recessed 
areas are toward you.

6. Attach the label to the cartridge. Press it into place.

Note – On LTO Ultrium cartridge labels, the alphanumeric 
characters can be either vertical or horizontal.

Note – The label must be within the indented (recessed) area of 
the cartridge so that the edges of the label are parallel to the edges 
of the cartridge. The label should be close to the inside edge of the 
indented area, but must never overlap the edge of this area. If the 
cartridge has a customer label, place the label in the area and press 
it into place.

7. For 9840 and 9940 drives, repeat Step 2 through Step Note – for the media ID 
label. Make sure the left side of both labels are aligned with each other.
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Web-launched SL Console Server 

Oracle’s Web-launched SL Console server, which is a standard feature of the SL8500, 
enables the SL Console to be installed on a centralized Web server. Individual clients 
can use a supported Web browser to download and log in to the Web-launched SL 
Console server. 

You download the server from the Oracle Software Delivery Cloud. It is distributed 
as a Java WebARchive (.war) file. After you have downloaded the file, you can 
deploy it on the Web server of your choice. See your Web server documentation for 
specific deployment instructions and requirements. 

Security Considerations
The customer is responsible for implementing all appropriate security systems, 
including firewalls, user access, etc. 

Updating the Web-launched SL Console Server
You can update the Web-launched SL Console server while it is running. Updates are 
automatically propagated to the clients when they retrieve the Web-launched SL 
Console application from the server. 
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▼ Download the SL Console Media Pack 

Use this procedure to download and extract the current SL Console Media Pack from 
the Oracle Software Delivery Cloud. The Media Pack includes the Web-launched SL 
Console server, as well as the Web-launched SL Console client and the standalone SL 
Console. 

After you complete this procedure, you can deploy the Web-launched SL Console 
server on the Web server of your choice. See your Web server documentation for 
specific deployment instructions and requirements. 

1. Start a Web browser on your PC or workstation, and navigate to the Oracle 
Software Delivery Cloud at the following URL:

http://edelivery.oracle.com/ 

2. Click Continue. 
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3. On the Export Validation screen, enter your contact information, read the 
License Agreement and Export Restrictions, and click the check boxes to accept. 

4. Click Continue to open the Media Pack screen.
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5. In the Select a Product Pack list of the Media Pack Search screen, select Oracle 
StorageTek Products. 

6. In the Select a Product Pack list of the Media Pack Search screen, use the 
Platform list, and select Generic Platform.
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7. Click Go. 

All media packs meeting your selection criteria are displayed in the Results 
section of the screen. 

8. Click the Select radio button that corresponds to the media pack for the SL 
Console version that you want to download. Click Continue. When the 
download screen for the selected media pack appears, review the information to 
verify that you have selected the correct media pack. Click the Readme button 
to review the readme file, if desired. Use the View Digest button to verify the 
MD5 and/or SHA-1 digests of the download files.

      s

9. If this is not the correct software, use the Back and/or Search Again buttons.

10. If the software is correct, click the Download. 
      s
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11. When the download dialog appears, click Save File, and press the OK.

12. When the Enter name of file to save to dialog appears, browse to the local 
directory that will hold the download file, and press Save. 

The file is large and may take some time to download, depending on your 
connection speed.

13. Use the appropriate extraction utility (for example, gunzip, pkunzip) to extract 
the media pack to the location of your choice. 

The Web-launched SL Console server filename is opel.war, located in the 
Weblaunch directory. 
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Controlling Contaminants 

Environmental Contaminants
Control over contaminant levels in a computer room is extremely important because 
tape libraries, tape drives, and tape media are subject to damage from airborne 
particulates. Most particles smaller than ten microns are not visible to the naked eye 
under most conditions, but these particles can be the most damaging. As a result, the 
operating environment must adhere to the following requirements: 

• ISO 14644-1 Class 8 Environment.

• The total mass of airborne particulates must be less than or equal to 200 
micrograms per cubic meter.

• Severity level G1 per ANSI/ISA 71.04-1985.

Oracle currently requires the ISO 14644-1 standard approved in 1999, but will require 
any updated standards for ISO 14644-1 as they are approved by the ISO governing 
body. The ISO 14644-1 standard primarily focuses on the quantity and size of 
particulates as well as the proper measurement methodology, but does not address 
the overall mass of the particulates. As a result, the requirement for total mass 
limitations is also necessary as a computer room or data center could meet the ISO 
14644-1 specification, but still damage equipment because of the specific type of 
particulates in the room. In addition, the ANSI/ISA 71.04-1985 specification 
addresses gaseous contaminations as some airborne chemicals are more hazardous. 
All three requirements are consistent with the requirements set by other major tape 
storage vendors.

Required Air Quality Levels
Particles, gasses and other contaminants may impact the sustained operations of 
computer hardware. Effects can range from intermittent interference to actual 
component failures. The computer room must be designed to achieve a high level of 
cleanliness. Airborne dusts, gasses and vapors must be maintained within defined 
limits to help minimize their potential impact on the hardware. 

Airborne particulate levels must be maintained within the limits of ISO 14644-1 Class 
8 Environment. This standard defines air quality classes for clean zones based on 
airborne particulate concentrations. This standard has an order of magnitude less 
particles than standard air in an office environment. Particles ten microns or smaller 
are harmful to most data processing hardware because they tend to exist in large 
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numbers, and can easily circumvent many sensitive components’ internal air 
filtration systems. When computer hardware is exposed to these submicron particles 
in great numbers they endanger system reliability by posing a threat to moving parts, 
sensitive contacts and component corrosion.

Excessive concentrations of certain gasses can also accelerate corrosion and cause 
failure in electronic components. Gaseous contaminants are a particular concern in a 
computer room both because of the sensitivity of the hardware, and because a proper 
computer room environment is almost entirely recirculating. Any contaminant threat 
in the room is compounded by the cyclical nature of the airflow patterns. Levels of 
exposure that might not be concerning in a well ventilated site repeatedly attack the 
hardware in a room with recirculating air. The isolation that prevents exposure of the 
computer room environment to outside influences can also multiply any detrimental 
influences left unaddressed in the room. 

Gasses that are particularly dangerous to electronic components include chlorine 
compounds, ammonia and its derivatives, oxides of sulfur and petrol hydrocarbons. 
In the absence of appropriate hardware exposure limits, health exposure limits must 
be used. 

While the following sections will describe some best practices for maintaining an ISO 
14644-1 Class 8 Environment in detail, there are some basic precautions that must be 
adhered to:

• Do not allow food or drink into the area.

• Cardboard, wood, or packing materials must not be stored in the data center clean 
area.

• Identify a separate area for unpacking new equipment from crates and boxes.

• Do not allow construction or drilling in the data center without first isolating 
sensitive equipment and any air targeted specifically for the equipment. 
Construction generates a high level of particulates that exceed ISO 14644-1 Class 8 
criteria in a localized area. Dry wall and gypsum are especially damaging to 
storage equipment.

Contaminant Properties and Sources
Contaminants in the room can take many forms, and can come from numerous 
sources. Any mechanical process in the room can produce dangerous contaminants or 
agitate settled contaminants. A particle must meet two basic criteria to be considered 
a contaminant:

• It must have the physical properties that could potentially cause damage to the 
hardware.

• It must be able to migrate to areas where it can cause the physical damage.

The only differences between a potential contaminant and an actual contaminant are 
time and location. Particulate matter is most likely to migrate to areas where it can do 
damage if it is airborne. For this reason, airborne particulate concentration is a useful 
measurement in determining the quality of the computer room environment. 
Depending on local conditions, particles as big as 1,000 microns can become airborne, 
but their active life is very short, and they are arrested by most filtration devices. 
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Submicron particulates are much more dangerous to sensitive computer hardware, 
because they remain airborne for a much longer period of time, and they are more 
apt to bypass filters.

Operator Activity

Human movement within the computer space is probably the single greatest source 
of contamination in an otherwise clean computer room. Normal movement can 
dislodge tissue fragments, such as dander or hair, or fabric fibers from clothing. The 
opening and closing of drawers or hardware panels or any metal-on-metal activity 
can produce metal filings. Simply walking across the floor can agitate settled 
contamination making it airborne and potentially dangerous.

Hardware Movement

Hardware installation or reconfiguration involves a great deal of subfloor activity, 
and settled contaminants can very easily be disturbed, forcing them to become 
airborne in the supply air stream to the room's hardware. This is particularly 
dangerous if the subfloor deck is unsealed. Unsealed concrete sheds fine dust 
particles into the airstream, and is susceptible to efflorescence -- mineral salts brought 
to the surface of the deck through evaporation or hydrostatic pressure. 

Outside Air

Inadequately filtered air from outside the controlled environment can introduce 
innumerable contaminants. Post-filtration contamination in duct work can be 
dislodged by air flow, and introduced into the hardware environment. This is 
particularly important in a downward-flow air conditioning system in which the sub-
floor void is used as a supply air duct. If the structural deck is contaminated, or if the 
concrete slab is not sealed, fine particulate matter (such as concrete dust or 
efflorescence) can be carried directly to the room's hardware. 

Stored Items

Storage and handling of unused hardware or supplies can also be a source of 
contamination. Corrugated cardboard boxes or wooden skids shed fibers when 
moved or handled. Stored items are not only contamination sources; their handling in 
the computer room controlled areas can agitate settled contamination already in the 
room.

Outside Influences

A negatively pressurized environment can allow contaminants from adjoining office 
areas or the exterior of the building to infiltrate the computer room environment 
through gaps in the doors or penetrations in the walls. Ammonia and phosphates are 
often associated with agricultural processes, and numerous chemical agents can be 
produced in manufacturing areas. If such industries are present in the vicinity of the 
data center facility, chemical filtration may be necessary. Potential impact from 
automobile emissions, dusts from local quarries or masonry fabrication facilities or 
sea mists should also be assessed if relevant.
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Cleaning Activity

Inappropriate cleaning practices can also degrade the environment. Many chemicals 
used in normal or “office” cleaning applications can damage sensitive computer 
equipment. Potentially hazardous chemicals outlined in the “Cleaning Procedures 
and Equipment” section should be avoided. Out-gassing from these products or 
direct contact with hardware components can cause failure. Certain biocide 
treatments used in building air handlers are also inappropriate for use in computer 
rooms either because they contain chemicals, that can degrade components, or 
because they are not designed to be used in the airstream of a re-circulating air 
system. The use of push mops or inadequately filtered vacuums can also stimulate 
contamination.

It is essential that steps be taken to prevent air contaminants, such as metal particles, 
atmospheric dust, solvent vapors, corrosive gasses, soot, airborne fibers or salts from 
entering or being generated within the computer room environment. In the absence 
of hardware exposure limits, applicable human exposure limits from OSHA, NIOSH 
or the ACGIH should be used. 

Contaminant Effects
Destructive interactions between airborne particulate and electronic instrumentation 
can occur in numerous ways. The means of interference depends on the time and 
location of the critical incident, the physical properties of the contaminant and the 
environment in which the component is placed.

Physical Interference

Hard particles with a tensile strength at least 10% greater than that of the component 
material can remove material from the surface of the component by grinding action 
or embedding. Soft particles will not damage the surface of the component, but can 
collect in patches that can interfere with proper functioning. If these particles are 
tacky they can collect other particulate matter. Even very small particles can have an 
impact if they collect on a tacky surface, or agglomerate as the result of electrostatic 
charge build-up.

Corrosive Failure

Corrosive failure or contact intermittence due to the intrinsic composition of the 
particles or due to absorption of water vapor and gaseous contaminants by the 
particles can also cause failures. The chemical composition of the contaminant can be 
very important. Salts, for instance, can grow in size by absorbing water vapor from 
the air (nucleating). If a mineral salts deposit exists in a sensitive location, and the 
environment is sufficiently moist, it can grow to a size where it can physically 
interfere with a mechanism, or can cause damage by forming salt solutions.
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Shorts

Conductive pathways can arise through the accumulation of particles on circuit 
boards or other components. Many types of particulate are not inherently conductive, 
but can absorb significant quantities of water in high-moisture environments. 
Problems caused by electrically conductive particles can range from intermittent 
malfunctioning to actual damage to components and operational failures.

Thermal Failure

Premature clogging of filtered devices will cause a restriction in air flow that could 
induce internal overheating and head crashes. Heavy layers of accumulated dust on 
hardware components can also form an insulative layer that can lead to heat-related 
failures.

Room Conditions
All surfaces within the controlled zone of the data center should be maintained at a 
high level of cleanliness. All surfaces should be periodically cleaned by trained 
professionals on a regular basis, as outlined in the “Cleaning Procedures and 
Equipment” section. Particular attention should be paid to the areas beneath the 
hardware, and the access floor grid. Contaminants near the air intakes of the 
hardware can more easily be transferred to areas where they can do damage. 
Particulate accumulations on the access floor grid can be forced airborne when floor 
tiles are lifted to gain access to the sub-floor.

The subfloor void in a downward-flow air conditioning system acts as the supply air 
plenum. This area is pressurized by the air conditioners, and the conditioned air is 
then introduced into the hardware spaces through perforated floor panels. Thus, all 
air traveling from the air conditioners to the hardware must first pass through the 
subfloor void. Inappropriate conditions in the supply air plenum can have a dramatic 
effect on conditions in the hardware areas.

The subfloor void in a data center is often viewed solely as a convenient place to run 
cables and pipes. It is important to remember that this is also a duct, and that 
conditions below the false floor must be maintained at a high level of cleanliness. 
Contaminant sources can include degrading building materials, operator activity or 
infiltration from outside the controlled zone. Often particulate deposits are formed 
where cables or other subfloor items form air dams that allow particulate to settle 
and accumulate. When these items are moved, the particulate is re-introduced into 
the supply airstream, where it can be carried directly to hardware.

Damaged or inappropriately protected building materials are often sources of 
subfloor contamination. Unprotected concrete, masonry block, plaster or gypsum 
wall-board will deteriorate over time, shedding fine particulate into the air. Corrosion 
on post-filtration air conditioner surfaces or subfloor items can also be a concern. The 
subfloor void must be thoroughly and appropriately decontaminated on a regular 
basis to address these contaminants. Only vacuums equipped with High Efficiency 
Particulate Air (HEPA) filtration should be used in any decontamination procedure. 
Inadequately filtered vacuums will not arrest fine particles, passing them through the 
unit at high speeds, and forcing them airborne.
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Unsealed concrete, masonry or other similar materials are subject to continued 
degradation. The sealants and hardeners normally used during construction are often 
designed to protect the deck against heavy traffic, or to prepare the deck for the 
application of flooring materials, and are not meant for the interior surfaces of a 
supply air plenum. While regular decontaminations will help address loose 
particulate, the surfaces will still be subject to deterioration over time, or as subfloor 
activity causes wear. Ideally all of the subfloor surfaces will be appropriately sealed 
at the time of construction. If this is not the case, special precautions will be necessary 
to address the surfaces in an on-line room.

It is extremely important that only appropriate materials and methodology are used 
in the encapsulation process. Inappropriate sealants or procedures can actually 
degrade the conditions they are meant to improve, impacting hardware operations 
and reliability. The following precautions should be taken when encapsulating the 
supply air plenum in an on-line room:

• Manually apply the encapsulant. Spray applications are totally inappropriate in an 
on-line data center. The spraying process forces the sealant airborne in the supply 
airstream, and is more likely to encapsulate cables to the deck.

• Use a pigmented encapsulant. The pigmentation makes the encapsulant visible in 
application, ensuring thorough coverage, and helps in identifying areas that are 
damaged or exposed over time.

•  It must have a high flexibility and low porosity to effectively cover the irregular 
textures of the subject area, and to minimize moisture migration and water 
damage.

• The encapsulant must not out-gas any harmful contaminants. Many encapsulants 
commonly used in industry are highly ammoniated or contain other chemicals 
that can be harmful to hardware. It is very unlikely that this out-gassing could 
cause immediate, catastrophic failure, but these chemicals will often contribute to 
corrosion of contacts, heads or other components.

Effectively encapsulating a subfloor deck in an on-line computer room is a very 
sensitive and difficult task, but it can be conducted safely if appropriate procedures 
and materials are used. Avoid using the ceiling void as an open supply or return for 
the building air system. This area is typically very dirty and difficult to clean. Often 
the structural surfaces are coated with fibrous fire-proofing, and the ceiling tiles and 
insulation are also subject to shedding. Even before filtration, this is an unnecessary 
exposure that can adversely affect environmental conditions in the room. It is also 
important that the ceiling void does not become pressurized, as this will force dirty 
air into the computer room. Columns or cable chases with penetrations in both the 
subfloor and ceiling void can lead to ceiling void pressurization.

Exposure Points
All potential exposure points in the data center should be addressed to minimize 
potential influences from outside the controlled zone. Positive pressurization of the 
computer rooms will help limit contaminant infiltration, but it is also important to 
minimize any breaches in the room perimeter. To ensure the environment is 
maintained correctly, the following should be considered: 

• All doors should fit snugly in their frames. 

• Gaskets and sweeps can be used to address any gaps. 
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• Automatic doors should be avoided in areas where they can be accidentally 
triggered. An alternate means of control would be to remotely locate a door 
trigger so that personnel pushing carts can open the doors easily. In highly 
sensitive areas, or where the data center is exposed to undesirable conditions, it 
may be advisable to design and install personnel traps. Double sets of doors with 
a buffer between can help limit direct exposure to outside conditions.

• Seal all penetrations between the data center and adjacent areas. 

• Avoid sharing a computer room ceiling or subfloor plenum with loosely 
controlled adjacent areas.

Filtration
Filtration is an effective means of addressing airborne particulate in a controlled 
environment. It is important that all air handlers serving the data center are 
adequately filtered to ensure appropriate conditions are maintained within the room. 
In-room process cooling is the recommended method of controlling the room 
environment. The in-room process coolers re-circulate room air. Air from the 
hardware areas is passed through the units where it is filtered and cooled, and then 
introduced into the subfloor plenum. The plenum is pressurized, and the conditioned 
air is forced into the room, through perforated tiles, which then travels back to the air 
conditioner for reconditioning. The airflow patterns and design associated with a 
typical computer room air handler have a much higher rate of air change than typical 
comfort cooling air conditioners so air is filtered much more often than in an office 
environment. Proper filtration can capture a great deal of particulates. The filters 
installed in the in-room, re-circulating air conditioners should have a minimum 
efficiency of 40% (Atmospheric Dust-Spot Efficiency, ASHRAE Standard 52.1). Low-
grade pre-filters should be installed to help prolong the life of the more expensive 
primary filters.

Any air being introduced into the computer room controlled zone, for ventilation or 
positive pressurization, should first pass through high efficiency filtration. Ideally, air 
from sources outside the building should be filtered using High Efficiency Particulate 
Air (HEPA) filtration rated at 99.97% efficiency (DOP Efficiency MILSTD-282) or 
greater. The expensive high efficiency filters should be protected by multiple layers of 
pre-filters that are changed on a more frequent basis. Low-grade pre-filters, 20% 
ASHRAE atmospheric dust-spot efficiency, should be the primary line of defense. The 
next filter bank should consist of pleated or bag type filters with efficiencies between 
60% and 80% ASHRAE atmospheric dust-spot efficiency.

ASHRAE 52-76 
 
Dust spot efficiency %

Fractional Efficiencies %

3.0 micron 1.0 micron 0.3 micron

25-30 80 20 <5

60-65 93 50 20

80-85 99 90 50

90 >99 92 60

DOP 95 -- >99 95
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Low efficiency filters are almost totally ineffective at removing sub-micron 
particulates from the air. It is also important that the filters used are properly sized 
for the air handlers. Gaps around the filter panels can allow air to bypass the filter as 
it passes through the air conditioner. Any gaps or openings should be filled using 
appropriate materials, such as stainless steel panels or custom filter assemblies.

Positive Pressurization and Ventilation
A designed introduction of air from outside the computer room system will be 
necessary in order to accommodate positive pressurization and ventilation 
requirements. The data center should be designed to achieve positive pressurization 
in relation to more loosely controlled surrounding areas. Positive pressurization of 
the more sensitive areas is an effective means of controlling contaminant infiltration 
through any minor breaches in the room perimeter. Positive pressure systems are 
designed to apply outward air forces to doorways and other access points within the 
data processing center in order to minimize contaminant infiltration of the computer 
room. Only a minimal amount of air should be introduced into the controlled 
environment. In data centers with multiple rooms, the most sensitive areas should be 
the most highly pressurized. It is, however, extremely important that the air being 
used to positively pressurize the room does not adversely affect the environmental 
conditions in the room. It is essential that any air introduction from outside the 
computer room is adequately filtered and conditioned to ensure that it is within 
acceptable parameters. These parameters can be looser than the goal conditions for 
the room since the air introduction should be minimal. A precise determination of 
acceptable limits should be based on the amount of air being introduced and the 
potential impact on the environment of the data center. 

Because a closed-loop, re-circulating air conditioning system is used in most data 
centers, it will be necessary to introduce a minimal amount of air to meet the 
ventilation requirements of the room occupants. Data center areas normally have a 
very low human population density; thus the air required for ventilation will be 
minimal. In most cases, the air needed to achieve positive pressurization will likely 
exceed that needed to accommodate the room occupants. Normally, outside air 
quantities of less than 5% make-up air should be sufficient (ASHRAE Handbook: 
Applications, Chapter 17). A volume of 15 CFM outside air per occupant or 
workstation should sufficiently accommodate the ventilation needs of the room.

Cleaning Procedures and Equipment
Even a perfectly designed data center requires continued maintenance. Data centers 
containing design flaws or compromises may require extensive efforts to maintain 
conditions within desired limits. Hardware performance is an important factor 
contributing to the need for a high level of cleanliness in the data center.

Operator awareness is another consideration. Maintaining a fairly high level of 
cleanliness will raise the level of occupant awareness with respect to special 
requirements and restrictions while in the data center. Occupants or visitors to the 
data center will hold the controlled environment in high regard and are more likely 
to act appropriately. Any environment that is maintained to a fairly high level of 
cleanliness and is kept in a neat and well organized fashion will also command 
respect from the room’s inhabitants and visitors. When potential clients visit the 
room they will interpret the overall appearance of the room as a reflection of an 
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overall commitment to excellence and quality. An effective cleaning schedule must 
consist of specially designed short-term and long-term actions. These can be 
summarized as follows:

Daily Tasks

This statement of work focuses on the removal of each day’s discarded trash and 
rubbish from the room. In addition, daily floor vacuuming may be required in Print 
Rooms or rooms with a considerable amount of operator activity.

Weekly Tasks

This statement of work focuses on the maintenance of the access floor system. During 
the week, the access floor becomes soiled with dust accumulations and blemishes. 
The entire access floor should be vacuumed and damp mopped. All vacuums used in 
the data center, for any purpose, should be equipped with High Efficiency Particulate 
Air (HEPA) filtration. Inadequately filtered equipment cannot arrest smaller particles, 
but rather simply agitates them, degrading the environment they were meant to 
improve. It is also important that mop-heads and dust wipes are of appropriate non-
shedding designs.

Cleaning solutions used within the data center must not pose a threat to the 
hardware. Solutions that could potentially damage hardware include products that 
are:

• Ammoniated

• Chlorine-based

• Phosphate-based

• Bleach enriched

• Petro-chemical based

• Floor strippers or re-conditioners. 

It is also important that the recommended concentrations are used, as even an 
appropriate agent in an inappropriate concentration can be potentially damaging. 
The solution should be maintained in good condition throughout the project, and 
excessive applications should be avoided.

Frequency Task

Daily Actions Rubbish removal

Weekly Actions Access floor maintenance (vacuum and damp mop)

Quarterly Actions Hardware decontamination

Room surface decontamination

Bi-Annual Actions Subfloor void decontamination

Air conditioner decontamination (as necessary)
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Quarterly Tasks

The quarterly statement of work involves a much more detailed and comprehensive 
decontamination schedule and should only be conducted by experienced computer 
room contamination-control professionals. These actions should be performed three 
to four times per year, based on the levels of activity and contamination present. All 
room surfaces should be thoroughly decontaminated including cupboards, ledges, 
racks, shelves and support equipment. High ledges and light fixtures and generally 
accessible areas should be treated or vacuumed as appropriate. Vertical surfaces 
including windows, glass partitions, doors, etc. should be thoroughly treated. Special 
dust cloths that are impregnated with a particle absorbent material are to be used in 
the surface decontamination process. Do not use generic dust rags or fabric cloths to 
perform these activities. Do not use any chemicals, waxes or solvents during these 
activities.

Settled contamination should be removed from all exterior hardware surfaces 
including horizontal and vertical surfaces. The unit’s air inlet and outlet grilles 
should be treated as well. Do not wipe the unit’s control surfaces as these areas can 
be decontaminated by the use of lightly compressed air. Special care should also be 
taken when cleaning keyboards and life-safety controls. Specially treated dust wipes 
should be used to treat all hardware surfaces. Monitors should be treated with optical 
cleansers and static-free cloths. No Electro-Static Discharge (ESD) dissipative 
chemicals should be used on the computer hardware, since these agents are caustic 
and harmful to most sensitive hardware. The computer hardware is sufficiently 
designed to permit electrostatic dissipation thus no further treatments are required. 
After all of the hardware and room surfaces have been thoroughly decontaminated, 
the access floor should be HEPA vacuumed and damp mopped as detailed in the 
Weekly Actions.

Bi-Annual Tasks

The subfloor void should be decontaminated every 18 months to 24 months based on 
the conditions of the plenum surfaces and the degree of contaminant accumulation. 
Over the course of the year, the subfloor void undergoes a considerable amount of 
activity that creates new contamination accumulations. Although the weekly above 
floor cleaning activities will greatly reduce the subfloor dust accumulations, a certain 
amount of surface dirt will migrate into the subfloor void. It is important to maintain 
the subfloor to a high degree of cleanliness since this area acts as the hardware’s 
supply air plenum. It is best to perform the subfloor decontamination treatment in a 
short time frame to reduce cross contamination. The personnel performing this 
operation should be fully trained to assess cable connectivity and priority. Each 
exposed area of the subfloor void should be individually inspected and assessed for 
possible cable handling and movement. All twist-in and plug-in connections should 
be checked and fully engaged before cable movement. All subfloor activities must be 
conducted with proper consideration for air distribution and floor loading. In an 
effort to maintain access floor integrity and proper psychrometric conditions, the 
number of floor tiles removed from the floor system should be carefully managed. In 
most cases, each work crew should have no more than 24 square feet (six tiles) of 
open access flooring at any one time. The access floor’s supporting grid system 
should also be thoroughly decontaminated, first by vacuuming the loose debris and 
then by damp-sponging the accumulated residue. Rubber gaskets, if present, as the 
metal framework that makes up the grid system should be removed from the grid 
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work and cleaned with a damp sponge as well. Any unusual conditions, such as 
damaged floor suspension, floor tiles, cables and surfaces, within the floor void 
should be noted and reported.

Activity and Processes
Isolation of the data center is an integral factor in maintaining appropriate 
conditions. All unnecessary activity should be avoided in the data center, and access 
should be limited to necessary personnel only. Periodic activity, such as tours, should 
be limited, and traffic should be restricted to away from the hardware so as to avoid 
accidental contact. All personnel working in the room, including temporary 
employees and janitorial personnel, should be trained in the most basic sensitivities 
of the hardware so as to avoid unnecessary exposure. The controlled areas of the data 
center should be thoroughly isolated from contaminant producing activities. Ideally, 
print rooms, check sorting rooms, command centers or other areas with high levels of 
mechanical or human activity should have no direct exposure to the data center. 
Paths to and from these areas should not necessitate traffic through the main data 
center areas.
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Index

A

activated capacity 55–59
cell assignment rules 57
decreasing 56, 58
for LTO libraries 56, 57
hardware activation file and 56
host notification of 59
increasing 58
minimum and maximum 55
orphaned cartridges and 58
partitioned libraries and 58, 88
planning 56

activated features
Capacity on Demand 55–59
display current 69
install 63

address
internal in LTO libraries 11

audits
audit indicator 292
description 292–293
full library 318–319
main access door and 292
physical 292, 318–319, 320–321
range of cells 320–321
tasks 317–323
verified 293, 322–323

auto clean (drive)
description 263

automated mode (library)
description 197
determine 198
ejecting a cartridge through the CAP 255
entering a cartridge through the CAP 253
tape management software and 22

automation drive interface 217

B

Base Module
location 4
LTO wall diagrams 374

mixed-media wall diagrams 379
bridging 105, 140, 159, 179, 217–223

designated bridge drive 217
select a bridge drive 218

bridging screens 220
bridge drive selection 221
instructions 221

C

CAP operations
tasks 226–229

capacity
activated. See activated capacity.
allocated (in partitioned libraries) 88
extending 12, 14
physical. See physical capacity
real-world 13, 15

Capacity on Demand 55–59
features of 55

Capacity on Demand. See Also activated capacity.
CAPs

assigning CAP open button 87
base module 13
Cartridge Expansion Module 13, 15
cartridges

entering 225
common 86
display properties 229
display status 228
display summary information 227
Drive Expansion Module 13, 15
inserting cartridges into 253
library partitions and 86, 129–135, 193–196
magazine cells 254
removing cartridges from 255
settings 17
split 86
using to eject cartridges 255
using to enter cartridges 253

Cartridge Expansion Module
location 4
LTO wall diagrams 378
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mixed-media wall diagrams 381
cartridges

applying labels 393
cleaning. See cleaning cartridges.
diagnostic 389
diagnostic. See diagnostic cartridges.
ejecting 225
ejecting through the CAP 255
ejects 250
entering 225
entering through the CAP 253
enters 249
exterior cleaning 391
handling 390
handling of 387
home cell 250
insert into a drive 368
insert into storage cells 367
inserting in a cell or drive 391
inserting in the CAP 249
inspecting 390
list 256
locate 366
locating by address 250
locating by VOLID 250
management tasks 252–262
manual operations 365–372
mounts and dismounts 197
move by VOLID 258
move from specified location 260
recovery moves 250
remove from the library 366
removing from a drive 369
storing 391
unlabeled 249

cautions
reentering cleaning cartridge 388
solvents for cleaning a cartridge 391, 393

cell
active 12

cleaning cartridges 388
description 265
eject expired 271
enter 269
for LTO drives 389
list 273
replacing 372

clearance specifications (library) 384
components (library)

back 4
front 3

controls and indicators
keypad 8
Open Door 9

Service Required 9
Current Drive Mappings Report 238

D

diagnostic cartridges 388
description 291
eject 271
enter 269
library self-tests and 290

diagnostic moves (robot)
control functions 296
controlling 340
defining 328–332
description 294–296
managing definitions 333–334
monitoring 340
pool address range 294
random access order 295
saving 335–336
sequential access order 295
starting 338–339
target address range 294

dimensions (library) 383
disconnecting external SCSI cables 11
dismount operations 198
domain, media labels 388
Door Open indicator 9
drive cleaning

automatic 263
configure auto clean 268
description 263
display status of 275
eject cleaning cartridges 271
enter cleaning cartridges 269
library auto clean 263
manual 266, 277
tasks 267–277

Drive Distribution Reports 244
Drive Expansion Module

location 4
Drive Mapping History Report 240
drive ports

enable and disable 237
drive slots

HLI-PRC address 231
Drive Utilization Reports 246
drives

addressing 231
cleaning. See drive cleaning.
display current mappings 238
display drive properties 235
display drive summary information 233
display mapping history 240
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display media events 242
display status 234
display utilization 246
hot swapping 10
insert cartridges into 368
management tasks 232
maximum 231
power specifications 385
rebooting 326
removing cartridges from 369
self-test 325
states 231
utility tasks 324–326

E

eject operations 250
enabled capacity

partitioned libraries and 88
enter operations 249
event monitors

description 285
display 301
display multiple 303
spool data to a file 302
tasks 300

F

FC-SCSI address
drive 231

front door
close with power 364
close without power 364
open with power 361
open without power 362

H

hardware activation file
activated capacity and 56
delete 70–71
description 61
display current 69
download 65
Feature Audit Log 72, 80
file type 61
install 67, 77–79
installing 63
library serial number and 67, 78

hardware activation screen reference 73
hardware activation tasks 63–72
HLI-PRC address

drive slot 231

host interfaces
partitioned libraries and 117, 146, 148, 150

I

interface
host 5

L

library addressing 6
partitioned libraries and 93

library auto clean 263
library components 3
library configuration

bridged library properties 203
display 203
display physical configuration 209
display SCSI configuration 210
mixed media 14
unbridged library properties 204

library controller
description 20
properties 208

library controls 5, 8
library events 285
library events. See Also event monitors.
library features 2
library firmware upgrades 289

activate 306
download 305

library interface
management 6

library internal address
partitioned libraries and 93

library internal addressing 11, 14
LTO locations 375
mixed-media locations 380

library management tasks 201–215
library partitions

activated capacity and 58
add 152
allocated capacity 88
assigning CAP button 87
boundaries of 89
commit changes screen 168
commit configuration changes 111
configuration tasks 98–113
confirm apply screen 170
create 100
delete 116, 154
described 83
design 102
design and commit screen reference 158–172
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design screen, bridged library 159
design screen, unbridged library 160
designing 89
host connections summary, bridged library 

179
host connections summary, unbridged library 

180
hosts and 84, 88, 117, 146, 148, 150
library hardware changes and 123
library resources and 86, 122
modify summary information 115, 156
orphaned cartridges in 87, 110, 184
print reports 127
reports 124–128, 173–192
save report 128
SL Console workspace and 95, 121, 168
summary screen reference 137–157
task summary 97
using CAPs in 86
verify 107
verify screen 165

library reboot 308
library reports 28–29

displaying 47
saving data to a file 49
searching 48

library safety features 22
library self-tests 290

performing 313, 315
library statistics

display 213
library status 27, 199

display 202
using Refresh button 28

library utility tasks 304
Library Utilization Reports 214
log snapshot file

generating process 311
transfer process 312

login IDs 24
logs

Feature Audit Log 72, 80
LTO configuration

Base Module wall diagrams 374
Cartridge Expansion Module wall diagrams 

378
library internal addressing 375
library SCSI addresses 376, 377

M

main access door
audits and 292
automated mode and 198

manual cleaning (drive) 266
manual operations

cartridge handling 365–372
close the front door, power off 364
close the front door, power on 364
general 357–364
open the front door, power off 362
open the front door, power on 361
power off the library 358
power on the library 359
return the library to ready status 360
safety precautions 355
tasks 356–372

media
domain labels 388
ID labels 388

Media Drive Events Report 242
MIB file

transfer process 309
mixed-media configuration

Base Module wall diagrams 379
Cartridge Expansion Module wall diagrams 

381
library internal addresses 380

mount operations 197

O

orphaned cartridges
non-partitioned libraries and 58
partitioned libraries and 87, 110, 184

P

passwords
activation 24
length 24
modifying 45

physical capacity
LTO storage cells and drives 13, 15

power off the library 358
power on the library 359
power specifications 385
power supply

location 4
redundant 4
switch 19

power switch 4

R

ready status
return the library to 360

reboot
drive 326
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library 308
recovery moves 250
reports

cartridge summary 256
feature audit log 72

robot
description 18
diagnostic moves. See diagnostic moves.
display statistics 283
display status of 282
display summary information 281
monitoring tasks 280–283
utility tasks 327–342

S

safety precautions 355
SCSI addressing

LTO locations 376, 377
SCSI properties

display 210
self-tests

drive 325
library 290, 313, 315

Service Required indicator 9
SL Console

activation password 24
communications failures 200
description 6, 23
first-time access 24
logging off 44
login ID 24
modes 24
modifying passwords 45
partition workspace and 95, 121, 168
screen, components 25
screen, modifying layout 27
security 24
standalone. See standalone SL Console
synchronize with library 27
user ID 24
Web-launched. See Web-launched SL Console

SL Console Help
description 30
navigation 30

SL Console report tasks 46–49
SL Console reports

Current Drive Mappings 238
Drive Distribution 244
Drive Mapping History 240
Drive Utilization 246
Library Utilization 214
Media Drive Events Report 242
Options Bar 29

types 28
SNMP

access control 345
adding trap recipients 350
adding users 347
community strings support 345
defined 343
deleting trap recipients 352
deleting users 349
port control 344
setting up port control 353
SL500 supported versions 343
tasks 346
transfer the library MIB file 309
trap levels 343

specifications
drive power 385
library clearances 384
library dimensions 383
power 385

standalone SL Console
description 34–35
installing 51–53
installing updates 35
logging in 43

storage cells
wall diagrams 373–381

T

tape management software 22
transferring the log snapshot file 312
troubleshooting 297

U

User ID
types 24

W

wall diagrams
Base Module, LTO 374
Base Module, mixed-media 379
Cartridge Expansion Module, LTO 378
Cartridge Expansion Module, mixed-media 

381
LTO firmware mappings 375
LTO SCSI mappings 376, 377
mixed-media firmware mappings 380

Web-launched SL Console
client requirements 33
description 33–34
Java WebArchive file 395
logging in using a browser 38
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logging in using an icon 41
logging in using CLI 38
security 33
starting on a client 34
updating on a client 33

Web-launched SL Console server
description 395
installing 396–400
security 395
updating 395
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