
N15278C

September 2005

VERITAS NetBackup™ 6.0

Backup, Archive, and Restore 
Getting Started Guide

for UNIX, Windows, and Linux

NetBackup_BAR_GS_Guide.book  Page i  Tuesday, August 9, 2005  10:38 AM



ii NetBackup Backup, Archive, and Restore Getting Started Guide

Disclaimer

The information contained in this publication is subject to change without notice. VERITAS Software 
Corporation makes no warranty of any kind with regard to this manual, including, but not limited to, 
the implied warranties of merchantability and fitness for a particular purpose. VERITAS Software 
Corporation shall not be liable for errors contained herein or for incidental or consequential damages 
in connection with the furnishing, performance, or use of this manual.

 

VERITAS Legal Notice

Copyright © 1993–2005 VERITAS Software Corporation. All rights reserved. VERITAS, the VERITAS 
Logo, and NetBackup are trademarks or registered trademarks of VERITAS Software Corporation or 
its affiliates in the U.S. and other countries. Other names may be trademarks of their respective 
owners.

Portions of this software are derived from the RSA Data Security, Inc. MD5 Message-Digest 
Algorithm. Copyright 1991-92, RSA Data Security, Inc. Created 1991. All rights reserved. 

VERITAS Software Corporation
350 Ellis Street
Mountain View, CA 94043
USA
Phone 650-527-8000
Fax 650-527-2908
www.veritas.com

 

Third-Party Copyrights

For a list of third-party copyrights, see the NetBackup Release Notes appendix.
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Preface

This guide for new users of NetBackup describes how to use the NetBackup Backup, 
Archive, and Restore interface to back up and restore files on:

◆ UNIX, Linux, and Macintosh OS X systems

◆ Microsoft Windows 2000, Windows XP, and Windows Server 2003 systems

Getting Help
You can find answers to questions and get help from the NetBackup documentation and 
from the VERITAS technical support web site.

Finding NetBackup Documentation
A list of the entire NetBackup documentation set appears as an appendix in the NetBackup 
Release Notes. All NetBackup documents are included in PDF format on the NetBackup 
Documentation CD.

For definitions of NetBackup terms, consult the online glossary. 

▼ To access the NetBackup online glossary

1. In the NetBackup Administration Console, click Help > Help Topics.

2. Click the Contents tab.

3. Click Glossary of NetBackup Terms.

Use the scroll function to navigate through the glossary.

Accessing the VERITAS Technical Support Web Site
The address for the VERITAS Technical Support Web site is http://support.veritas.com.
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The VERITAS Support Web site lets you do any of the following:

◆ Obtain updated information about NetBackup, including system requirements, 
supported platforms, and supported peripherals

◆ Contact the VERITAS Technical Support staff and post questions to them

◆ Get the latest patches, upgrades, and utilities

◆ View the NetBackup Frequently Asked Questions (FAQ) page

◆ Search the knowledge base for answers to technical support questions

◆ Receive automatic notice of product updates

◆ Find out about NetBackup training

◆ Read current white papers related to NetBackup

From http://support.veritas.com, you can complete various tasks to obtain specific types 
of support for NetBackup:

1. Subscribe to the VERITAS Email notification service to be informed of software alerts, 
newly published documentation, Beta programs, and other services.

a. From the main http://support.veritas.com page, select a product family and a 
product. 

b. Under Support Resources, click Email Notifications. 

Your customer profile ensures you receive the latest VERITAS technical 
information pertaining to your specific interests.

2. Locate the telephone support directory at http://support.veritas.com by clicking the 
Phone Support icon. A page appears that contains VERITAS support numbers from 
around the world.

Note Telephone support for NetBackup is only available with a valid support 
contract. To contact VERITAS for technical support, dial the appropriate phone 
number listed on the Technical Support Guide included in the product box and 
have your product license information ready for quick navigation to the proper 
support group.

3. Contact technical support using e-mail.
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Accessibility Features

a. From the main http://support.veritas.com page, click the E-mail Support icon. 

A wizard guides you to do the following:

◆ Select a language of your preference

◆ Select a product and a platform

◆ Provide additional contact and product information, and your message

◆ Associate your message with an existing technical support case

b. After providing the required information, click Send Message.

Contacting VERITAS Licensing
For license information, you can contact us as follows:

◆ Call 1-800-634-4747 and select option 3

◆ Fax questions to 1-650-527-0952

◆ In the Americas, send e-mail to amercustomercare@veritas.com.

In the Asia and Pacific areas, send email to apaccustomercare@veritas.com.

In all other areas, send email to internationallicense@veritas.com.

Accessibility Features
NetBackup contains features that make the user interface easier to use by people who are 
visually impaired and by people who have limited dexterity. Accessibility features 
include:

◆ Support for assistive technologies such as screen readers and voice input (Windows 
servers only)

◆ Support for keyboard (mouseless) navigation using accelerator keys and mnemonic 
keys

For more information, see the NetBackup Installation Guide.
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Comment on the Documentation
Let us know what you like and dislike about the documentation. Were you able to find the 
information you needed quickly? Was the information clearly presented? You can report 
errors and omissions or tell us what you would find useful in future versions of our 
manuals and online help. 

Please include the following information with your comment:

◆ The title and product version of the manual on which you are commenting

◆ The topic (if relevant) on which you are commenting

◆ Your comment

◆ Your name

Email your comment to NBDocs@veritas.com.

Please only use this address to comment on product documentation. See “Getting Help” 
in this preface for information on how to contact Technical Support about our software.

We appreciate your feedback.
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Introduction 1
This guide provides information about basic user-directed back up and restore procedures 
for new users of NetBackup.

Overview
NetBackup lets you back up, archive, and restore files, folders/directories, and 
volumes/partitions that reside on your computer. The computer that needs the backup or 
restore is the client; the computer that manages the backup and retrieval of the data is the 
server.

Backup, Archive, and Restore is your interface to the NetBackup client software on your 
computer. When you start a backup or archive operation, the client software on your 
computer sends the data to be backed up to the NetBackup server, which writes it to a 
storage device. When you start a restore operation, the client software on your computer 
requests the data from the NetBackup server, and the server sends the data to the client so 
it can be restored.

The NetBackup administrator configures policies that define the rules that NetBackup 
follows when backing up clients. The policies include schedules for automatic, 
unattended backups of the NetBackup clients (server-directed backups). Policies also define 
when you can back up and restore files manually (user-directed operations). For example, if 
the time range in which you can perform user-directed operations (your user window) is 
from 8 am to 6 pm, you will not be able to back up or archive at other times (although you 
can restore at any time).

All of the files, folders/directories, and volumes/partitions from a backup job (either 
server- or user-directed) are stored in a backup image. When you restore files, you select the 
items to restore from a backup image or from multiple backup images. Backup images can 
expire after a certain amount of time (configured by your NetBackup administrator); if a 
backup image expires, you cannot see or restore its files.
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Installing and Configuring
The NetBackup administrator installs and configures NetBackup, which includes the 
following:

◆ Installing and configuring the client software and the Backup, Archive, and Restore 
interface on the computers that will be backed up in your computing environment.

◆ Configuring the client software to work with the NetBackup servers in your 
environment.

If user-directed operations are allowed in your NetBackup environment, you should not 
have to configure Backup, Archive, and Restore so it functions properly.

Normally, Backup, Archive, and Restore configuration changes are performed by the 
NetBackup administrator. If you have to change the configuration, consult your 
NetBackup administrator.

More Information in Online Help
This guide provides basic backup, archive, and restore procedures; for more information, 
see the help. The help includes the following:

◆ Information about restore destinations, restore options, and restoring from specific 
dates

◆ Procedures for other restore operations:

◆ Restoring from raw partition (UNIX) and disk image (Windows) backups

◆ Restoring from true image backups

◆ Restoring from VERITAS Backup Exec backups

◆ Restoring by proxy (Windows)

◆ Redirecting restores to different clients (administrators only)

◆ Procedures for finding the items you want to restore

◆ Procedures for specifying other backup servers (if allowed in your environment)

◆ A reference that describes windows, menus, and dialogs.

You can invoke help from the Help menu or from Help buttons in dialogs.
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Getting Started with UNIX and Linux 2
This section provides information about starting Backup, Archive, and Restore and 
performing basic backup and restore procedures on UNIX, Linux, and Macintosh OS X 
systems. On UNIX, Linux, and Macintosh OS X systems, Backup, Archive, and Restore is a 
Java-based, graphical user interface. 

◆ “Setting Up Your Window Manager” on page 3

◆ “Starting Backup, Archive, and Restore” on page 4

◆ “Backing Up or Archiving Files, Directories, and Partitions” on page 5

◆ “Restoring Files, Directories, and Partitions” on page 8

◆ “Other UNIX Interfaces” on page 11

Setting Up Your Window Manager
Set your window manager so windows become active only when you click inside the 
windows. Do not enable auto focus, which is when windows become active when you 
move the mouse pointer over them. The NetBackup Java interface does not run properly 
with auto focus enabled.

Common Desktop Environment (CDE)
The following explains how to set up a CDE window manager, which is the preferred 
window manager for NetBackup Java applications.

▼ To configure CDE for Backup, Archive, and Restore

1. On the front panel in the CDE window, click the Style Manager control icon.

The Style Manager toolbar appears.

2. On the Style Manager toolbar, click the Window control icon.

The Style Manager - Window dialog appears.
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3. In the Style Manager - Window dialog , click the Click In Window To Make Active 
button.

4. Click OK.

5. Click OK when asked to Restart the Workspace Manager.

Motif
When using the Motif window manager, set the Mwm*keyboardFocusPolicy X 
resource as follows:

Mwm*keyboardFocusPolicy:explicit

Starting Backup, Archive, and Restore
You can use Backup, Archive, and Restore to log in to a NetBackup client on a UNIX 
system on which have a user account and then perform back ups, archives, and restores 
on that client.

▼ To start Backup, Archive, and Restore

1. Log in to the computer where you are going to start Backup, Archive, and Restore. 

2. Start Backup, Archive, and Restore by entering the following:

/usr/openv/netbackup/bin/jbpSA &

The Login dialog appears.

3. Enter the name of the client where you want to perform the backup, archive, or 
restore.

You must have a valid user account on that client and have access to that client.

4. Enter your user name.

5. Enter your password.

6. Click Login.

For a description of the Backup, Archive, and Restore interface and directions about how 
to use it, see the help. For information about jbpSA command options, see the jbpSA(1) 
man page.
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5

Backing Up or Archiving Files, Directories, and Partitions
Use the following procedure to back up or archive files, directories, and partitions.

Backing up copies the selected items; archiving copies the selected items and then deletes 
the items after they are backed up. 

For more information about using Backup, Archive, and Restore, see the online help.

▼ To back up using Backup, Archive, and Restore

1. Click the Backup Files tab.

The title bar of the tab displays the names of the server, source and destination clients, 
and policy used for the operation.

2. Select the items that you want to back up. To select an item, click in the check box to 
the left of the item. A check mark indicates an item is selected; a diagonal slash mark 
indicates that only some items within a directory are selected. You can select items in 
the Directory Structure pane or the Contents pane.

3. Click Backup.
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The Backup Files dialog appears.

4. Select or specify any of the following options:

◆ NetBackup Server. To change the NetBackup server that will perform the backup 
operation, select a different server from the drop-down list. Normally, you will 
not have to specify a different master server; however, if you can send your 
backups to more than one master server, ensure that you specify the correct one. 

◆ Archive files (delete files after successful backup). To delete the items after they 
are backed up successfully, select this option.

◆ Keyword phrase to associate with this backup or archive (optional). To link a 
keyword phrase to the backup, enter a keyword phrase. When restoring files, you 
can search by keyword for items that were backed up.

◆ Use default progress log filename. To write the backup progress messages to a 
log file other than the default, deselect Use default progress log filename and 
then enter the name of the alternative progress log in the Progress log filename 
field.

5. Click Start Backup.
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A dialog appears, indicating that the backup was started successfully and asking if 
you want to view the progress of the operation.

6. Click Yes to open the Task Progress tab, from which you can view the progress of the 
backup or archive operation.

The operation may take a few minutes to complete. You can close Backup, Archive, and 
Restore after starting a backup operation. NetBackup continues the backup operation in 
the background.
 

NetBackup_BAR_GS_Guide.book  Page 7  Tuesday, August 9, 2005  10:38 AM



Restoring Files, Directories, and Partitions

8 NetBackup Backup, Archive, and Restore Getting Started Guide

Restoring Files, Directories, and Partitions
Use the following procedure to restore from a normal or archived backup. The restore 
procedure is the same except a normal backup leaves the original files on the disk and an 
archive backup deletes the files after backing them up. Most backups are normal backups.

For other types of restores, see their instructions in the online help.

▼ To restore using Backup, Archive, and Restore

1. Click the Restore Files tab.

The title bar of the window tab displays the names of the server, source and 
destination clients, and policy used for the operation.

2. Select Normal Backups or Archived Backups from the Restore Type list box 
(depending on whether you are restoring from a normal backup or an archive).

3. Click View > Refresh.

The items you can restore are displayed in the Contents pane.
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9

4. Select items to restore. 

To select an item, click in the check box to the left of the item. A check mark indicates 
an item is selected; a diagonal slash mark indicates that only some items within a 
directory are selected. You can select items in the Directory Structure pane or the 
Contents pane.

5. To preview a list of the media required for restore, click Preview.

If the backup images required to restore the data are on disk storage units rather than 
removable media such as tape, no media will be listed if you try to preview media.

Click OK to close the dialog.

6. Click Restore.

The Restore Marked Files dialog  appears. The items marked for restore are listed in 
the dialog window.
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7. Select a restore destination:

◆ Restore everything to its original location

◆ Restore everything to a different location

◆ Restore individual directories and files to different locations

By default, Restore everything to its original location is selected.

8. Select restore options:

◆ Overwrite the existing file

◆ Restore directories without crossing mount points

◆ Restore without access control attributes

◆ Rename hard links

◆ Rename soft links

9. To write the progress messages to a log file other than the default, deselect Use 
default progress log filename and then enter the name of the alternative progress log.

10. Click Start Restore.

A dialog appears, indicating that the restore began successfully and asking if you 
want to view the progress of the operation.

11. To view the status of the restore, click Yes in the dialog. 

The Task Progress tab appears, from which you can view the progress of the restore.

The restore may take a few minutes to complete. After starting a restore operation, you 
can close Backup, Archive, and Restore and perform other tasks on your computer. 
NetBackup will continue the restore operation in the background.
 

Starting from a Windows System
If the Java Windows Administration Console is installed on a Microsoft Windows system, 
you can run the Java Backup, Archive, and Restore interface on a Windows system and 
log into a NetBackup UNIX client to perform user-directed operations on that client. You 
must log into a UNIX system using the Java Windows Administration Console; you 
cannot log into a Windows system.
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▼ To start the Windows Administration Console

1. On the Windows Start menu, click Programs > VERITAS NetBackup > NetBackup - 
Java Version 6.0.

The Login dialog appears. 

2. Enter the name of the client where you want to perform the backup, archive, or 
restore.

You must have a valid user account on that client and have access to that client.

3. Enter your user name.

4. Enter your password.

5. Click Login.

Other UNIX Interfaces
NetBackup provides several other interfaces to the client software on UNIX systems:

◆ Menu user interface. You can use the menu interface on terminals that can connect to a 
client system. The bp command starts the menu interface program. For information 
about using the menu user interface, see the bp(1) man page and the help in the 
interface.

◆ Commands. Commands let you perform backup, archive, restore operations from a 
shell prompt. For command information, see the NetBackup Commands for UNIX 
guide.

Although you can perform user-directed operations through any of these interfaces, 
VERITAS recommends that you use the Backup, Archive, and Restore interface for 
user-directed operations.
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Getting Started with Windows 3
This section provides information about starting Backup, Archive, and Restore and 
performing basic backup and restore procedures on Microsoft Windows systems.

◆ “Starting Backup, Archive, and Restore” on page 13

◆ “Backing Up or Archiving Using Backup, Archive, and Restore” on page 13

◆ “Backing Up Using Windows Explorer” on page 16

◆ “Backing Up Using NetBackup Bin” on page 16

◆ “Restoring Files, Folders, and Volumes” on page 18

Starting Backup, Archive, and Restore

❖ On the Windows Start menu, click Programs > VERITAS NetBackup > Backup, 
Archive, and Restore.

If NetBackup Access Management is used to control access to your NetBackup 
environment, you may be required to enter a user name, password, and domain 
information.

For a description of the Backup, Archive, and Restore interface and directions about how 
to use it, see the help.

Backing Up or Archiving Using Backup, Archive, and 
Restore

Use the following procedure to back up or archive files, folders, volumes, registry keys, 
Windows system state, Windows system service, and Windows shadow copy 
components.

Backing up copies the selected items; archiving copies the selected items and then deletes 
the items after they are backed up. 

For more information about using Backup, Archive, and Restore, see the online help.
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▼ To back up using Backup, Archive, and Restore

1. Open a Backup window (on the File menu, click Select Files and Folders to Backup).

The title bar of the window displays the names of the server and client used for the 
operation.

2. Select the items that you want to back up. To select an item, click in the check box to 
the left of the item. A check mark indicates an item is selected; a diagonal slash mark 
indicates that only some items within a folder are selected. You can select items in the 
All Folders pane or the Contents pane.

3. On the Actions menu, click Start Backup of Marked Files.
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The Specify Backup Options dialog appears.

4. Select or specify any of the following options:

◆ Back up to NetBackup Server. To change the NetBackup server that will perform 
the backup operation, select a different server from the drop-down list. Normally, 
you will not have to specify a different master server; however, if you can send 
your backups to more than one master server, ensure that you specify the correct 
one. 

◆ Archive files (delete files after successful backup). To delete the items after they 
are backed up successfully, select this option.

◆ Keyword phrase to associate with the backup (optional). To link a keyword 
phrase to the backup, enter a keyword phrase. When restoring files, you can 
search by keyword for items that were backed up.

5. Click Start Backup.

A dialog appears, indicating that the backup was started successfully and asking if 
you want to view the progress of the operation.

6. Click Yes to open the View Status dialog , from which you can view the progress of 
the backup or archive operation.

The operation may take a few minutes to complete. You can close Backup, Archive, and 
Restore after starting a backup operation. NetBackup continues the backup operation in 
the background.
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Backing Up Using Windows Explorer
If your system is configured to use NetBackup Explorer Extensions, you can use Windows 
Explorer to back up files, folders, or volumes.

Note To back up files using Windows Explorer, NetBackup Explorer Extensions must be 
installed in your NetBackup environment and must be enabled. To enable this 
feature, select NetBackup Explorer Extensions from the Backup, Archive, and 
Restore File menu.

▼ To back up using Windows Explorer

1. Open Windows Explorer. (On the Windows Start menu, click Programs > Accessories 
> Windows Explorer.)

2. Find and select the file or folder you want to back up and right-click on it.

3. Click Backup Now.

A dialog prompts you to continue or cancel the backup operation.

4. To begin the backup operation, click Yes.

To show the progress of the backup operation, select Automatically Show Progress 
Log before you begin the backup operation.

 

Backing Up Using NetBackup Bin
If your system is configured to use NetBackup Explorer Extensions, you can use 
NetBackup Bin to back up files. NetBackup Bin is a folder into which you can place files 
that you want to back up. The folder is represented by a NetBackup Bin icon on your 
desktop:

Note To use NetBackup Bin, NetBackup Explorer Extensions must be installed in your 
NetBackup environment and must be enabled. To enable this feature, select 
NetBackup Explorer Extensions from the Backup, Archive, and Restore File menu.
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▼ To back up a file using NetBackup Bin

1. Open Windows Explorer. (On the Windows Start menu, click Programs > Accessories 
> Windows Explorer.)

2. Find and select the file or folder you want to back up.

3. Drag the file to the NetBackup Bin icon on your desktop or to the NetBackup Bin 
folder in Windows Explorer.

4. Right-click on the NetBackup Bin icon on your desktop or the NetBackup Bin folder in 
Windows Explorer and click Backup Now.

A dialog prompts you to continue or cancel the backup operation.

5. To begin the backup operation, click Yes.

To show the progress of the backup operation, select Automatically Show Progress 
Log before you begin the backup operation.

To view the files in the NetBackup Bin folder, double-click on the NetBackup Bin icon on 
your desktop or right-click on the NetBackup Bin folder in Windows Explorer and then 
click Open.
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Restoring Files, Folders, and Volumes
Use the following procedure to restore from a normal or archived backup. The restore 
procedure is the same except a normal backup leaves the original files on the disk and an 
archive backup deletes the files after backing them up. Most backups are normal backups.

For other types of restores, see their instructions in the online help.

▼ To restore using Backup, Archive, and Restore

1. On the File menu, click Select Files and Folders to Restore then click either from 
Normal Backup or from Archived Backup (depending on whether you are restoring 
from a normal backup or an archive). 

There may be a delay while NetBackup reads information about the backups and 
builds the list of files you can restore. 

The title bar of the window displays the names of the server and client used for the 
operation.

2. Select items to restore. 
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To select an item, click in the check box to the left of the item. A check mark indicates 
an item is selected; a diagonal slash mark indicates that only some items within a 
folder are selected. You can select items in the All Folders pane or the Contents pane.

3. To preview a list of the media required for restore, select Actions > Preview Media.

If the backup images required to restore the data are on disk storage units rather than 
removable media such as tape, no media will be listed if you try to preview media.

Click OK to close the dialog.

4. On the Actions menu, click Start Restore of Marked Files.

The Restore Marked Files dialog  appears. The items marked for restore are listed in 
the dialog window.

5. Select a restore destination:

◆ Restore everything to its original location

◆ Restore everything to a different location

◆ Restore individual folders and files to different locations

By default, Restore everything to its original location is selected.

6. Select restore options:

◆ Restore without access control attributes
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◆ Overwrite the existing file

◆ Restore the file using a temporary filename

◆ Do no restore the file

By default, Do not restore the file is selected.

7. Click Start Restore.

A dialog appears, indicating that the restore began successfully and asking if you 
want to view the progress of the operation.

8. To view the status of the restore, click Yes in the dialog. 

The View Status dialog appears, from which you can view the progress of the restore.

The restore may take a few minutes to complete. After starting a restore operation, you 
can close Backup, Archive, and Restore and perform other tasks on your computer. 
NetBackup will continue the restore operation in the background.
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