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Using the LDAP Binding Component in a
Project

The topics in this document provides information about LDAP Binding Component.

For more information about working with the NetBeans IDE, see the http://
www.netbeans.org page on the NetBeans web site.

What You Need to Know

These topics provide information about the functional behavior of LDAP Binding Component.
■ “Tutorial Overview” on page 6.
■ “Tutorial Requirement” on page 6.
■ “Tutorial Plan” on page 7.
■ “LDAP Binding Component Project in a Nutshell” on page 8.
■ “Starting the GlassFish Application Server” on page 10.
■ “Creating a BPEL Module Project For the Add Feature” on page 15.
■ “Creating a WSDL Document” on page 17.
■ “Create a WSDL Document For Type : SOAP” on page 26.
■ “Creating a BPEL Process” on page 31.
■ “Creating a Composite Application Project” on page 53.
■ “Deploying a Composite Application” on page 58.
■ “Testing the Composite Application” on page 59.
■ “Design View: Notification” on page 63.
■ “Create a WSDL Document : Search” on page 64.
■ “Create a WSDL Document : Update Feature” on page 66.
■ “Create a WSDL Document : Delete Feature” on page 68.

What You Need to Do

These topics provides instructions on the following:
■ “To Start the GlassFish Application Server” on page 11.
■ “To Start the JBI Components” on page 12.
■ “To Create a BPEL Module Project” on page 15.
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■ “To Create a WSDL Document: Add Operation” on page 17.
■ “To Create a WSDL Document : SOAP” on page 26.
■ “To Create a BPEL Process” on page 31.
■ “To Add a Partner Link” on page 33.
■ “To Add a Web Service and Basic Activities” on page 35.
■ “To Edit the Web Service : Receive1” on page 37.
■ “To Edit the Web Service : Invoke1” on page 40.
■ “To Edit the Web Service : Reply1” on page 44.
■ “To Edit the Basic Activities : Assign1” on page 46.
■ “To Edit the Basic Activities : Assign2” on page 50.
■ “To Create a Composite Application Project” on page 53.
■ “To Deploy a Composite Application” on page 58.
■ “To Test the Composite Application” on page 59.

Tutorial Overview
This tutorial helps you create a new OpenESB component called LDAP Binding Component.

It also shows you how to create a LDAP Binding Component project that accesses a LDAP
server. It illustrates how to implement the method for requesting and displaying data from a
LDAP server.

This component implements all the required interfaces from the JBI 1.0 specification.

The LDAP browser project is an application that holds an implementation of a data provider
(for example, LDAPTableDataProvider). In addition to this, the application demonstrates how
to pass a request to the server and how to specify the set of attributes to be received from the
server.

Tutorial Requirement
Read the sections thoroughly before trying to execute the Binding Component.

Software Needed for the Tutorial
LDAP Binding Component assumes that the following are configured on the target resource.

■ GlassFish ESB or Java CAPS
■ A JCA container, tested with GlasshFish installer
■ LDAP Web Browser (used to view the output)

For example, Softerra LDAP Browser

Tutorial Overview
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Tutorial Plan
Follow the outlined procedure to build a BPEL process.

1. Create a BPEL Module project using the New Project wizard.

2. Create the following WSDL Document for the BPEL Module.

a. LDAP WSDL
b. SOAP WSDL

Note – Test Cases are not required for File Binding Component and JMS.

3. Create a Composite Application project.

4. Add the BPEL Module project (*.jar) as a JBI Module to the Composite Application project.

5. Build the Composite Application project. Ensure that the Application Server is started.

6. Deploy the Composite Application project to the Application Server.

7. Create a Test Case.

8. Run the Test Case.

9. (Optional) Debug the BPEL process.

Debug is invoked when the Test Case fails.

Tutorial Plan
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LDAP Binding Component Project in a Nutshell
The following illustration explains the procedure of creating the LDAP BC tutorial project.

Flowchart 1

END

Deploy the
Composite Application project

to the Application Server

Create Test Case

Run Test Case Debug the
BPEL project

START

Create a BPEL Module
project

Create a Composite 
Application project

Add the BPEL Module as a
JBI Module

Make sure to start the
Application Server or

GlassFish V2

Build the Composite
Application project

LDAP Binding Component Project in a Nutshell
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Flowchart 1 (Continued)

Click New Project -> SOA ->
BPEL Module - EmployeePhoneAdd

1. Click either EmployeePhoneAdd
    or Click Process Files -> New ->
    WSDL Document _ Add
2. Choose any of the following:
        Abstract WSDL Document
        Concrete WSDL Document

1. Select Concrete WSDL Document
2. Select Binding: LDAP
3. Select Type: From LDAP Server

Choose the following Operation Setting:
   Search
   Add
   Update
   Delete

Select Operation setting: Add

1. Click EmployeePhoneAdd -> New
    -> WSDL Document
2. Binding:SOAP
3. Type: RPC Literal
4. Select Object Class and the required
    Attributes
5. Set to RDN

1. Select EmployeePhoneAdd ->
    Right-click New -> WSDL Document - 
    TriggerWsdl
2. Choose Concrete WSDL Document
    Binding:  SOAP Type: RPC Literal

Select EmployeePhoneAdd -> Right-click
New -> BPEL Process - AddBP

1. Drag and Drop the Input WSDL 
   (TriggerWSDL.wsdl) to the left and
   output WSDL (Add.wsdl) to the right of
   the BPEL panel
2. Click Palette. Select the following:
a. Web Service - Receive
    Basic Attribute - Assign
b. WebService - Invoke
    Basic Attribute - Assign
c. Web Service - Reply
3. Edit each Web Service and Save the
    project

Validate BPEL

START

1. Double-click the Process Mapper ->
    Receive -> assign
2. In the Mapper, expand the following
    variable:
    TriggerWsdlOperationIn with
    AddAddOperationIn
3. Map the following:
    Triggerln with inetOrgPerson.uid
4. Click Attributes under
    AddAddOperationln
a. Select person.sn
b. Click String -> String Literal and
    enter the value in the String Literal
    and Map them. Similarly, select
    person.cn and inetOrgPerson.mail  
    and enter the values
5. Save the project

A

LDAP Binding Component Project in a Nutshell
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Starting the GlassFish Application Server
The GlassFish Application Server is installed when GlassFish ESB is configured. NetBeans starts
the Application Server when needed.

Validate Source

Right-click and Clean and Build
EmployeePhoneAdd

1. Click New Project -> SOA ->
    Composite Application - 
    EmployeephoneAddJbi
2. Right-click EmployeePhoneAdd ->
    Add JBI Module
3. Choose EmployeePhoneAdd ->
    Add Project JAR Files
4. Select EmployeePhoneAddJbli ->
    Clean and Build
5. Save the project

1. Expand EmployeePhoneAddJbli ->
    Test -> New Test Case
2. Select the WSDL Document -
    TriggerWSDL.wsdl
3. Select the Binding Operations to
    Test – TriggerWsdlOperation
4. Click Input.xml tab -> Delete existing
    value and enter a new string value
5. Save the project
6. Right-click TestCase1 -> Run

Open LDAP Browser Editor to check
the Output

END

Right-click EmployeePhoneAddJbi ->
Deploy

A

1. Double-click Process Mapper -> 
    Invoke -> Assign
2. In the Mapper, expand the following 
    variable:
    AddAddOperationOut with
    TriggerWSDLOperationOut 
3. Map the following: response ->
    OperationResult with TriggerOut
4. Save the Project

Starting the GlassFish Application Server
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▼ To Start the GlassFish Application Server
Choose Window —> Services, if the Services tab is not visible.

Click the Services tab and expand the Servers node.

Right-click the domain (GlassFish V2, by default). Select Start.

The Output window displays log information generated during the application startup.

Note – Choose Window —> Output —> Output, if the Output window is not visible.

The following message in the Output console window is an indication that the application
server is listening.

JBI framework startup complete.

Before You Begin

1

2

Starting the GlassFish Application Server
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Note – A green arrow badge on the GlassFish Application Server node indicates the server is
listening.

▼ To Start the JBI Components
Expand GlassFish —> JBI —> Binding Components.

Right-click on sun-ldap-binding. Click Start.

1

2

Starting the GlassFish Application Server
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The action enables sun-ldap-binding.

The Output console displays a confirmation message.

Binding sun-ldap-binding has been started.

Starting the GlassFish Application Server
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Creating a BPEL Module Project For the Add Feature
In this scenario, an Object Class and an Attribute is added and are identified as Input and
Output, respectively.

▼ To Create a BPEL Module Project
Choose File —> New Project from the main menu.
This opens the New Project wizard.

Select the SOA node from the Categories list.

Select the BPEL Module node from the Projects list.

Click Next.

Type the Project Name in the Project Name field.
For example, LDAPBpelModule

Click Browse to navigate to the project location field.
The IDE stores the project files. This step is optional.

1

2

3

4

5

6

Creating a BPEL Module Project For the Add Feature
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Click Finish.
A project node for the BPEL module project named LDAPBpelModule is created in the Projects
window.

Click Save All.

7

8

Creating a BPEL Module Project For the Add Feature
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Creating a WSDL Document
In this section, create a WSDL Document in the BPEL Module project using the Add feature.
For this example, create AddWSDL.wsdl in the BPEL project. Use the Partner view of the WSDL
editor to configure the components of the WSDL Document.

▼ To Create a WSDL Document: Add Operation
Expand the BPEL Module project node in the Projects tab.

Right-click the project node or Process Files node. Select New —> WSDL Document.

This opens the New WSDL Document wizard.

Type the File Name in the File Name field.

For example, AddWSDL.wsdl

1

2

3

Creating a WSDL Document
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Select Concrete WSDL Document.

Choose the Binding — LDAP from the drop-down list.

Choose any one of the following Types from the drop-down list.

■ From LDAP Server
■ From LDIF File

Click Next.

Enter the Root DN and LDAP Server URL.

DN is the base object entry search relative to.

In the figure below, the Root DN is dc=sun,dc=com. The format for the LDAP Server URL is
ldap://hostname:port .

Click Advanced.

4

5

6

7

8

9

Creating a WSDL Document
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The Advanced Login dialog box appears.

Creating a WSDL Document
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Field Description Required Value

Principal The principal needed when using an
authentication mechanism other than the
anonymous log-in (authentication =
none).

The fully qualified Distinguished Name
(DN) of the user.

For example:
cn=Administrator,cn=Users,dc=stc,dc=com

Credentials The credentials needed when using an
authentication mechanism other than
anonymous log-in (authentication =
none).

The appropriate credentials, such as valid
password.

Creating a WSDL Document

LDAP Binding Component Tutorial • June 200920



SSL Connection Type The SSL connection type. Select None, Enable SSL, or TLS On
Demand. Enter the desired value as
follows:
■ None: No SSL, simple plain

connection.

■ Enable SSL: SSL is enabled. All
communication to the LDAP server
uses a secure communication
channel.

Note – If you are using the Enable SSL
option, the ProviderURL property
must point to a secure LDAP port.

Authentication The method authentication (none or
simple). Select the desired authentication
as follows:
■ None: No authentication, that is, an

anonymous log-on. If you use this
setting, ensure that the LDAP server
supports anonymous log-ons if you
are using this setting.

■ Simple: Authentication is based on a
user name and password. Provide the
user name and password in the
appropriate fields (Use the Principal
and Credentials).

Select None or Simple.

The default is None.

TrustStore The default TrustStore. The TrustStore is
used for CA certificate management when
establishing SSL connections.

Click Browse to select the trust store file.

A valid TrustStore file.

There is no default value.

TrustStore Type The TrustStore type of the TrustStore
used for CA certificate management while
establishing an SSL connection. If the
TrustStore type is not specified, the
application uses JKS as the default
TrustStore Type.

A valid TrustStore type.

TrustStore Password The default TrustStore password. The
password is meant to access the
TrustStore used for CA certificate
management while establishing SSL
connections.

A valid TrustStore password.

There is no default value.

Creating a WSDL Document
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KeyStore The default KeyStore file. The keystore is
used for key/certificate management
while establishing SSL connections.

Click Browse to select the key store file.

A valid package location.

There is no default value.

KeyStore Type The default KeyStore type. The keystore
type is used for key/certificate
management when establishing SSL
connections. If the KeyStore type is not
specified, the default KeyStore type is
used.

A valid KeyStore type.

KeyStore Username The user name for accessing the keystore
used for key/certificate management
when establishing SSL connections.

A valid KeyStore user name.

KeyStore Password The default KeyStore password. The
password is used to access the KeyStore
used for key/certificate management
when establishing SSL connections; there
is no default.

A valid KeyStore password.

There is no default value.

TLS Security An indicator of whether TLS security is
enabled.

The default value is NO

Click OK to close the Advanced Login Dialog.

Click Next.

The New WSDL Document — Operation Setting dialog box opens.

Note – You can perform any one of following operations.

■ Search
■ Add
■ Update
■ Delete

Click the Add tab.

10

11

12

Creating a WSDL Document

LDAP Binding Component Tutorial • June 200922



Select the following Object Class:

a. person

b. inetOrgPerson

Click the down arrow to move them from the top-left pane to the bottom-left pane.

Note – The attributes related to the schema are selected.

Each schema is made up of a set of attributes.

For example,

■ person — person.sn and person.cn
■ inetOrgPerson — inetOrgPerson.uid and inetOrgPerson.mail

They are represented as follows:

Creating a WSDL Document
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schemaname.Attributename

a. sn — Surname
b. cn — Common Name
c. uid — Unique id
d. mail — Email

Note – Use the down arrow to move the selected Object Class or Attributes from the top-left
pane to the bottom-left pane. Use this to also move from the top-right pane to the bottom-right
pane.

Set any one of the Attributes to Relative Distinguished Name (RDN).

A Relative Distinguished Name (RDN) is a component of the distinguished name.

For example, cn=John Doe, ou=People is a RDN relative to the root RDN dc=sun.com.

13
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For example, Set inetOrgPerson.uid = RDN

Click Finish.

The illustration is as shown.
14

Creating a WSDL Document
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A tree structure is formed as follows:

a. AddWSDL.wsdl — Target WSDL

b. AddWSDLAdd.xsd

c. LdapBase.xsd

Create a WSDL Document For Type : SOAP
In this section, add a WSDL document, for example, TriggerWsdl.wsdl to the BPEL Module
project. The Partner view of the WSDL editor to configure the components of the WSDL
document.

▼ To Create a WSDL Document : SOAP
Expand the project node in the Projects window. Right-click the BPEL Module node or Process
Files node. Choose New —> WSDL Document...
For example, LDAPBpelModule

1

Create a WSDL Document For Type : SOAP
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This opens the New WSDL Document wizard.

Type the File Name in the File Name field.

For example, TriggerWSDL.wsdl

Select Concrete WSDL Document.

■ binding

Defines the message format and protocol details for a port type.
■ service

Indicates the binding type to be used and the method to access the database resource.

Choose the Binding — SOAP from the drop-down list.

Select any one of the following Type.

If you select the SOAP binding type, then select any one of the following binding subtypes:

■ RPC Literal: The operations are RPC oriented (that is, messages contain parameters and
return values). Each message part uses an element or type attribute to refer to a concrete
schema definition.

■ Document Literal: The operations are document oriented (that is, messages contain one or
more documents). Each message part uses an element or type attribute to refer to a concrete
schema definition.

■ RPC Encoded: The operations are RPC oriented (that is, messages contain parameters and
return values). Each message part uses a type attribute to refer to an abstract type.

Choose Type — RPC Literal from the drop-down list.

2

3

4

5

6
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Click Next.

This action displays the New WSDL Document dialog box.

Choose the Operation Type from the drop-down list.

The WSDL Editor is used to create, edit, and delete port types.

The WSDL Editor supports the following operation types. There are two Operation Types.

■ Request-Response Operation: The operation receives a message as input, and sends a
message as output.

■ One-Way Operation: The operation receives a message as input.

Each message contains one or more logical parts. Specify the name and the type of content for
each part.

If you change the name of a port type or operation, then the WSDL Editor renames all
occurrences in the same file. Right-click the component node to rename all occurrences in the
associated XSD, WSDL, and BPEL files. Choose Refactor —> Rename.

When Operation Type is One-Way Operation. The following illustration demonstrates when
the operation type is chosen as One-Way Operation.

7

8
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LDAP Binding Component Tutorial • June 200928



Note –

a. Click the ellipses (...) button to select an Element or Type.

b. Enter both the Input and Output Message Part Names for the Request-Response Operation.

The default value of the Input and Output Message Part Names is set as xsd:string.

c. Click Add to another Message Part Name as the Input.

This selects the checkbox Generate partnerlinktype automatically.

d. Click Remove to delete the Message Part Name as the Input.

Select Operation Type : Request-Response Operation from the drop-down list.

Note – Port Type Name and Operation Name are populated from the previous wizard.

Click the ellipses (...) to select the Element or Type.

Enter a Message Part Name for both Input and Output — TriggerIn and TriggerOut,
respectively.

9

10
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This action displays the Select Element or Type dialog box.

Retain the same values for Element or Type both for Input and Output as xsd:string.

Click Next.

The New WSDL Document — Concrete Configuration window is displayed.

Verify the Concrete Configuration.

Click Finish.

11

12
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Creating a BPEL Process
In this section, add a BPEL process file. For example, AddBPEL.bpel. You will also learn to add a
partner link and associate three activities to the BPEL process file. Create a BPEL Module
project to orchestrate.

▼ To Create a BPEL Process
Expand the project node in the Projects window. Right-click the node or Process Files node.
Choose New —> BPEL Process...

For example, LDAPBpelModule

This opens the New BPEL Process wizard.

1

Creating a BPEL Process
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Type the Filename in the File Name field.

For example, AddBPELProcess

Click Finish.

2

3

Creating a BPEL Process
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Note –

■ In the Projects window, the IDE adds a AddBPELProcess.bpel node under the Process Files
node.

■ The AddBPELProcess.bpel file is open in the BPEL Designer.

The BPEL Designer has two views: Source and Design.
■ The Properties window is open.
■ Choose Window —> Properties if the Properties window is not visible.
■ The Navigator window shows the BPEL Logical View of the BPEL Process document.

▼ To Add a Partner Link
Select the Partner Link from the Projects tab. Drag and drop it to the left panel of the design
area.

For example, TriggerWSDL.wsdl

This is the Input WSDL.

1

Creating a BPEL Process
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Select the Partner Link from the Projects tab. Drag and drop it to the right panel of the design
area.

For example, AddWSDL.wsdl

This is the Output WSDL.

2

Creating a BPEL Process
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▼ To Add a Web Service and Basic Activities
Drag and Drop the following Web Services:

■ Receive
■ Invoke
■ Reply

Drag and Drop the Basic Activities : Assign.

Select the Web Service : Receive in the Web Service section of the Palette.

Drag the selection to the box in the design area between the Process Start and the Process End
activities.

For example, BPEL Process box : AddBPELProcess

The IDE provides the visual clues to show an appropriate location to drop the selection.

1

2

Creating a BPEL Process
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This action places a Web Service Receive called Receive1 in the Design view.

Select the Basic Activities. Choose Assign in the Basic Activities section of the Palette.

This action places a Assign activity called Assign1 in the Design view.

Drag the selection to the AddBPELProcess box in the design area, between the Process Start and
the Process End activities.

Note – Repeat steps 1 through 4 to select Invoke1, Assign2, and Reply1.

Choose the following:

■ Select the Web Service : Invoke and Basic Activities : Assign.
■ Select the Web Service : Reply.

The icon symbolizes that the Web Services can be edited.

Note – In the diagram, a red cross next to an element means that the element has not passed
validation and the output contains errors. Edit each Sequence to pass validation.

3

4
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▼ To Edit the Web Service : Receive1
Click Web Service — Receive1 and click Edit.

This opens the Receive1 [Receive] - Property Editor.

Select the properties of this service from the Main tab. Select PartnerLink1.

The Operation drop-down list refreshes to display TriggerWSDLOperation.

1

2

Creating a BPEL Process
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Create a new input variable.

Perform the following:

■ Click the Create button next to the Input Variable field.

This opens the New Input Variable dialog box.
■ The Name, Type, and Scope variable fields are refreshed with their default values.

Change the value in the Name field.
■ Click OK.

3
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Note –

■ All the fields are populated with the assigned values.

The Input Variable is TriggerWSDLOperationIn
■ Create Instance check-box is checked, by default.

Click OK to close the Receive1 [Receive] - Property Editor.

Save the project.

4

5
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▼ To Edit the Web Service : Invoke1
Click Web Service — Invoke1 and click Edit.

This opens the Invoke1 [Invoke] - Property Editor.

Select the properties from the Main tab. Select PartnerLink2 from the drop-down list.

The Operation drop-down list refreshes to display AddWSDLAddOperation.

1

2

Creating a BPEL Process
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Follow these steps to create a new input and an output variable.

a. Click the Create button next to the Input Variable field.

This opens the New Input Variable dialog box.

The Name, Type, and Scope variable fields are refreshed with their default values.

You can also change the value in the Name field.

b. Click OK to close the New Input Variable dialog box.

3
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c. Click the Create button next to the Output Variable field.

This opens the New Output Variable dialog box.

The Name, Type, and Scope variable fields are refreshed with their default values.

You can also change the value in the Name field.

d. Click OK to close the New Output Variable dialog box.

Note – All the fields are populated with the assigned values.

Select the following Variables:

■ Input Variable : AddWSDLAddOperationIn
■ Output Variable : AddWSDLAddOperationOut

Creating a BPEL Process
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Click OK to close the Invoke1 [Invoke] - Property Editor.

Save the project.

4
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▼ To Edit the Web Service : Reply1
Click Web Service : Reply1. Click Edit.

This opens the Reply1 [Reply] - Property Editor.

Select the properties from the Main tab. Select PartnerLink1 from the drop-down list.

The Operation drop-down list refreshes to display TriggerWSDLOperation.

Follow the steps to create a New Output Variable.

a. Make sure to select the Normal Response radio button.

b. Click the Create button next to the Output Variable field.

This opens the New Output Variable dialog box.
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c. Change the value in the Name field. This is optional.

TriggerWSDLOperationOut is displayed, by default.

d. Click OK.

Click OK to close the Reply1 [Reply] - Property Editor.4
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▼ To Edit the Basic Activities : Assign1
Double-click the Basic Activity : Assign1.

This displays the BPEL Mapper window.

Note – Choose Window —> Other —> BPEL Mapper from the main menu if the BPEL Mapper
window is not visible.

Expand the node in the Source tree pane (the left pane) of the BPEL Mapper under Output —>
Variables.

For example, TriggerWSDLOperationIn

A Trigger1n node appears under the TriggerWSDLOperationIn node.

Expand the node in the Destination tree pane (the right pane) of the BPEL Mapper under Input
—> Variables.

For example, AddWSDLAddOperationIn

A request node appears under the AddWSDLAddOperationIn node.
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Select the node in the Source tree pane. Drag the selection and map it to the node in the
Destination tree pane.

For example,

a. Source tree pane: TriggerWSDLOperationIn — Trigger1n

b. Destination tree node: AddAddOperationIn — request — attributes — MainAttribute —
inetOrgPerson.uid

Map the following:

TriggerIn — inetOrgPerson.uid

Click Save All.
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Expand the node in the Destination tree pane (the right pane) of the BPEL Mapper under Input
—> Variables.

For example, AddWSDLAddOperationIn

a. Select request — attributes — Attributes

i. Select person.sn.

ii. Click String and select String Literal from the drop-down list.

iii. Enter the values in the String Literal and map the String Literal with person.sn.

For example, person.sn = Joe, where sn = surname and person.cn = Jane where cn =
common name

Note – Similarly, select person.cn and follow steps b and c.

6
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Click Save All.

Click the Design tab.

Note – A red icon marked against Basic Activities — Assign1 is not shown.
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▼ To Edit the Basic Activities : Assign2
Double-click the Basic Activity : Assign2.

This displays the BPEL Mapper window.

Note – Choose Window —> Other —> BPEL Mapper from the main menu if the BPEL Mapper
window is not visible.

Expand the node in the Source tree pane (the left pane) of the BPEL Mapper under Output —
Variables.

For example, AddWSDLAddOperationOut

Expand response — OperationResult.

Expand the node in the Source tree pane (the right pane) of the BPEL Mapper under Input —
Variables.

For example, TriggerWSDLOperationOut

Map the following variables

For example, OperationResult — TriggerOut

1

2

3

4

Creating a BPEL Process

LDAP Binding Component Tutorial • June 200950



Click Save All.

Click the Design tab.

The final output is as shown in the illustration.
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Right-click the BPEL Module and select Clean and Build.

For example, LDAPBpelModule

The following message is displayed.
BUILD SUCCESSFUL (total time: 3 seconds).

Click Save All.

7

8

Creating a BPEL Process

LDAP Binding Component Tutorial • June 200952



Creating a Composite Application Project
Add the JBI module to the deployment project before deploying the BPEL Module project.
Deploying the project makes the service assembly available to the application server. This
allows its service units to execute their functionality.

▼ To Create a Composite Application Project
Choose File —> New Project.

This opens the New Project wizard.

Select the SOA node from the Categories list.

Select the Composite Application node from the Projects list.

Click Next.

Type the Project Name in the Project Name field.

For example, AddCompApp
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Click Finish.

The Projects window now contains a project node for a Composite Application project named
AddCompApp.

Click the Validate XML button.

This action invokes an XML check and displays the following message in the XML check
console.
XML validation finished.

Right-click either the Composite Application or the JBI Modules.

For example, AddComositeApp

Select Add JBI Module.
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Select the BPEL Module Project. Click Add Project JAR Files.

For example, LDAPBpelModule

In the current example, the Project JAR file is build/SEDeployment.jar.

10
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The JAR file is added and is as shown in the illustration.

Click Save All.11
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Note – Ensure to following services are started.

■ GlassFish Application Server
■ JBI Binding Component (sun-ldap-binding)

Right-click the Composite Application node. Select Clean and Build.
For example, AddCompApp

The CASA Editor displays the build associated with AddCompApp.

A success message is displayed in the Output window:

BUILD SUCCESSFUL (total time: 3 seconds)

Click Save All.
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Deploying a Composite Application
This section lists the procedure to deploy the composite application.

Tip – Start the Sun Java System Application Server before deploying the project.

▼ To Deploy a Composite Application
Right—click Composite Application project node from the Projects tab.

For example, AddCompAppl

Select Deploy.

After successful deployment of the project the Output window displays the following message:

BUILD SUCCESSFUL (total time: 13 seconds).
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Testing the Composite Application
This section lists the procedure to test the deployed application.

▼ To Test the Composite Application
Expand the Composite Application project. Click Test.

For example, AddCompApp

Right-click to select New Test Case.

Enter the Test Case Name.

For example, AddTest

Click Next.

Select the WSDL Document.

a. Select one WSDL Document from the BPEL Module.

In the current example, the WSDL Document is TriggerWSDL.wsdl and the BPEL Module
is LDAPBpelModule — Process Files.

Note – Select one WSDL Document.
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b. Click Next.

c. Select one Operation to text file from the Process Files.

In the current example, the Operation to Text file is TriggerWSDLOperation and the
Process File is TriggerWSDLPort (Binding=”TriggerWSDLBinding”).

Note – Select one Operation to Text file.

Click Finish.

This displays the Source code.
6
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Enter the string value.

string = Jane

The Output console displays Retrieve.xml when you enter a string value in the input.xml
window.

Right-click the Test Case and click Run.

For example, AddTest

A confirmation dialog box prompts to overwrite an existing Output.

Click Yes.

The Output is as shown in the illustration.
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For a demo on the Add feature, visit the following URL:

http://wiki.open-esb.java.net/Wiki.jsp?page=LDAPAddFeatureScreencast

Source View
Right-click a node and choose Go To —> Source.

The Source view appears with the cursor positioned at the beginning or end of the component's
block.

In the Source view, the underlying XML source code appears. You can directly edit the XML.

1. The top of the Source Editor has a tab for each open document. Each tab shows the name of
the document.

Note – If the document has been modified and has not been saved, then an asterisk (*)
appears after the name. You can right-click a tab to access various commands.

2. A toolbar is located at the top of the Source Editor window.
3. Source code displayed in the Source Editor is syntactically colored.
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4. The Source Editor status line is located beneath the horizontal scroll bar. To toggle between
insert mode and overwrite mode, use the Insert key.

Design View: Notification
The Design view displays the results of both real-time and explicit validation in callout windows
on the diagram and the error stripe.

In the illustration,

Note – A red cross next to an element on the diagram means that the element has not passed
validation and the output contains errors.

A yellow triangle with an exclamation mark means that the element has not passed validation
and the output contains warnings.

A red cross in the Design view means there are both errors and warnings.

If you click the cross or the triangle, a callout window lists errors and warnings.
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The callout window displays messages related to validation in accordance with the criteria listed
above. Messages related to real-time validation are constantly updated.

In the Design view, the error stripe displays the validation results. The error stripe is a strip to
the right of the scroll bar that contains red marks if some elements have not passed validation.
The error stripe represents the entire diagram, not just the portion that is currently displayed.
This stripe helps users to immediately detect any errors in the BPEL process without having to
scroll through the entire diagram. Click a red mark to jump to the element that causes
problems. If no errors are detected, the small square in the error stripe is green.

Create a WSDL Document : Search
In this section, the user sets to search using the search filter. The input for the uid is provided
from the HTTP/SOAP WSDL and the response is routed to the SOAP reply.

For steps, see the following links:

1. “Creating a WSDL Document” on page 17.
2. “Create a WSDL Document For Type : SOAP” on page 26.

a. Click the Search tab.
In the current example, the selected Object Class is inetOtgPerson.
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Search Filter
i. Select Search Filter — inetOrgPerson from the drop-down list.
ii. Select uid from the Search Filter list.
iii. Click the > arrow.

inetOrgPerson.uid = is moved to the right pane.

Result Set

Tip – Entries with respect to inetOrgPerson are populated both in the Search Filter
and Result set.

i. Select Result Set — homePhone from the drop-down list.
ii. Click > arrow to move the selected entry to the right pane.

b. Click Finish.
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3. “Creating a BPEL Process” on page 31.

4. “Creating a Composite Application Project” on page 53.

5. “Deploying a Composite Application” on page 58.

6. “Testing the Composite Application” on page 59.

For a demo on Search, visit the following URL:

http://wiki.open-esb.java.net/Wiki.jsp?page=LDAPSearchFeatureScreencast

Create a WSDL Document : Update Feature
In this section, the user sets to use the Update feature.

For steps, see the following links:

1. “Creating a WSDL Document” on page 17.

2. “Create a WSDL Document For Type : SOAP” on page 26.

a. Click the Update tab.

In the current example, the selected Object Class is inetOtgPerson.
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Update Filter
i. Select Update Filter — inetOrgPerson from the drop-down list.
ii. Select uid from the Update Filter list.
iii. Click the > arrow.

inetOrgPerson.uid = is moved to the right pane.

Update Set

Tip – Entries with respect to inetOrgPerson are populated both in the Update Filter
and Update set.

i. Select Update Set — homePhone from the drop-down list.
ii. Click > arrow to move the selected entry to the right pane.
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b. Click Finish.

3. “Creating a BPEL Process” on page 31.

4. “Creating a Composite Application Project” on page 53.

5. “Deploying a Composite Application” on page 58.

6. “Testing the Composite Application” on page 59.

For a demo on the Update feature, visit the following URL:

http://wiki.open-esb.java.net/Wiki.jsp?page=LDAPUpdateFeatureScreencast

Create a WSDL Document : Delete Feature
In this section, the user sets the Delete feature.

For steps, see the following links:

1. “Creating a WSDL Document” on page 17.

2. “Create a WSDL Document For Type : SOAP” on page 26.

a. Click the Delete tab.

In the current example, the selected Object Class is inetOtgPerson.
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Remove Filter
i. Select Remove Filter — inetOrgPerson from the drop-down list.
ii. Select the entry from the Remove Filter list.

For example, uid
iii. Click the > arrow.
iv. inetOrgPerson.uid = is moved to the right pane.

b. Click Finish.
3. “Creating a BPEL Process” on page 31.
4. “Creating a Composite Application Project” on page 53.
5. “Deploying a Composite Application” on page 58.
6. “Testing the Composite Application” on page 59.
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