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ABOUT THIS MANUAL

Agile Product Lifecycle Management for Process Documentation
The Agile Product Lifecycle Management (PLM) for Process documentation set 
includes Adobe® Acrobat™ PDF files. The Oracle Technology Network (OTN) 
Web site: http://www.oracle.com/technology/documentation/agile.html 
contains the latest versions of the Agile PLM for Process PDF files. You can view 
or download these manuals from the Web site, or you can ask your Agile 
administrator if there is an Agile PLM for Process Documentation folder available 
on your network from which you can access the Agile PLM for Process 
documentation (PDF) files. 

Note To read the PDF files, you must use the free Adobe Reader™ version 7.0 or 
later. This program can be downloaded from the Adobe Web site: http://
www.adobe.com/.

If you need additional assistance or information, please go to http://
metalink.oracle.com or phone 1.800.233.1711 for assistance.

TTY Access to Oracle Support Services
Oracle provides dedicated Text Telephone (TTY) access to Oracle Support 
Services within the United States of America 24 hours a day, 7 days a week. For 
TTY support, call 800.446.2398. Outside the United States, call +1.407.458.2479.

Agile Training Aids
Go to the Oracle University Web page http://www.oracle.com/education/
chooser/selectcountry_new.html for more information on Agile Training 
offerings.

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. 
The conventions for writing code require that closing braces should appear on an 
otherwise empty line; however, some screen readers may not always read a line of 
text that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or 
organizations that Oracle does not own or control. Oracle neither evaluates nor 
makes any representations regarding the accessibility of these Web sites.

Before calling Oracle Support about a problem with an Agile PLM for Process manual, please 
have the full part number, which is located on the title page.
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Audience
This guide is intended for end users who are responsible for creating and 
managing information in Agile Product Lifecycle Management for Process. 
Information about administering the system resides in the Agile Product Lifecycle 
Management for Process Administrator User Guide.

Variability of Installations
Descriptions and illustrations of the Agile PLM for Process user interface 
included in this manual may not match your installation. The user interface of 
Agile PLM for Process applications and the features included can vary greatly 
depending on such variables as:

❑ Which applications your organization has purchased and installed

❑ Configuration settings that may turn features off or on

❑ Customization specific to your organization

❑ Security settings as they apply to the system and your user account

Where to Find Information
Consult the table below to find specific information from the relevant Agile 
Product Lifecycle Management for Process information source.

Table 1: Agile Product Lifecycle Management for Process documentation topics, by source 

Information type
Install/
Upgrade 
Guide

Admin. 
User 
Guide

Release 
Notes

Agile 
training

Help 
Desk

Agile 
sales rep

Cache management ●

Core data management ●

Custom data management ●

Custom sections ● ●

Extended attributes ● ●

Feature requests ● ●

Group management ●

Installing Agile PLM for 
Process ● ● ●

Known issues ●

Managing specifications ●

New in this release ● ● ●

Printing ●

Resolved issues ●

System-based roles ●

Technical support ●

Upgrading Agile PLM for 
Process ●

User management ●

Workflow management ●



About This Manual

xi

Document Conventions
The following formatting elements appear in Agile Product Lifecycle 
Management for Process documentation.

Element Meaning

Helvetica Condensed, 
9 pt. bold type

A user interface (UI) element that a procedure is instructing 
you to click, select, or type into. For example, buttons or text 
entry fields.

9 pt. monospace font Code samples

10 pt. monospace 
font

File names or directory names

Blue italic font The linked portion of a cross-reference. Click it to go to the 
referenced heading, table, or figure.

Minion Typeface, 
Title Case

A named UI element that a procedure is describing but not 
instructing you to click, select, or type into.

Note Minion 11.5 pt, 
with faint blue 
bar over & under

Alerts you to supplemental information.

Caution! Minion 
11.5 pt, with 
faint red bar 
over & under

Alerts you to possible data loss, breaches of security, or other 
more serious problems.

Important Minion 
11.5 pt, with 
thick red bar 
over & under

Alerts you to supplementary information that is essential to 
the completion of a task.
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CHAPTER 1

Installation
This chapter discusses Agile Product Lifecycle Management for Process installation and includes the 
following topics:
❑ Installation Requirements
❑ Pre-Installation Checklists
❑ Installation
❑ Post-Installation Checklists

Overview
Installing Agile Product Lifecycle Management for Process involves several steps, 
including:

❑ Understanding system requirements

❑ Performing pre-installation tasks (such as setting up the Web application 
server and database)

❑ Running the command prompt installation batch files
❑ Performing post-installation tasks, such as:

• Configuring the remote container service

• Performing some base application environment configurations

• Testing the installation

Checking for Latest Information and Instructions
Prior to installation please refer to the following URLs for the latest information 
and instructions:

1 E-Delivery:  http://edelivery.oracle.com/.  E-Delivery provides the latest copy 
of the core software. Please note the core software does not include all 
patches and hotfixes.

a Select appropriate language and click Continue.
b Complete the export validation requirements form.
c Select “Oracle Agile Applications” as the Product Pack.
d Select “Microsoft Windows (32-bit)” as the Platform.
e Click Go.
f Search for “Oracle Agile Product Lifecycle Management for Process 

6.0.0.3.0 Media Pack” in Results and select link.
g Download the appropriate media packs.
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2 Oracle Support:  https://support.oracle.com.  Oracle Support provides the 
latest patch releases and hotfixes. To gain access to the latest patches and 
hotfixes perform the following steps:

a Log into  https://support.oracle.com. If you do not have a user ID please 
contact Oracle Support.

b Select a language from the Language drop-down, and then click Sign-In. 
c Go to Patches & Updates.
d Under Patch Search, click “Product or Family (Advanced Search)”

• Product is “Oracle Agile Product Lifecycle Management for Process.”

• Release is “{The release you are interested in}”, i.e. “Agile PLM for 
Process 6.0.0.3.0”

• Platform is “Microsoft Windows (32-bit)”

e Click Search. The latest patches and hotfixes will be provided in the 
search results.

f Download the appropriate patch releases or hotfixes. 

3 Oracle Mix:  https://mix.oracle.com/groups/16252. Visit the Prodika 
Lounge for the latest posts from customers, partners and Oracle’s Product 
Management regarding the PLM for Process product line.

Installation Requirements
This section discusses Agile Product Lifecycle Management for Process 
installation requirements for the client, application server, and database server. 
Make sure your systems meet all installation requirements before attempting to 
install the Agile application suite. In order to properly run, Agile Product 
Lifecycle Management for Process requires a Web client, a Web application 
server, a remoting container (provided by Agile), and a database server. Figure 1-
1 on the next page shows the necessary architecture.
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Figure 1-1: Agile Product Lifecycle Management for Process Physical Architecture

Web Client Requirements
To properly run Agile Product Lifecycle Management for Process, Web clients 
must meet the following minimum requirements:

❑ Internet Explorer 6.0, 7.0, and 8.0

❑ Adobe Reader 7.0 
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Important When determining server hardware requirements as described below 
in Web Application Server Requirements, SQL Database Server 
Requirements, and Oracle Database Server Requirements, keep in mind 
that these are minimum requirements. Your environment should be 
evaluated to determine the actual hardware requirements. Things to 
consider are:

- Data volume
- Application distribution
- Application usage
- User load
- User distribution across applications
- Network configuration
- Document storage location

Web Application Server Requirements

Software Requirements
To properly run Agile Product Lifecycle Management for Process, use the 
following supported versions for the web application server:

❑ Microsoft Windows™ 2003 Server, SP1

❑ Microsoft IIS 6.0

❑ Microsoft .NET Framework 2.0

Hardware Requirements
To properly run Agile Product Lifecycle Management for Process, the web 
application server must meet the following minimum requirements:

❑ Dual CPU Intel Xeon 2.8 GHz

❑ 2.0 GB RAM

❑ 50 GB available storage

Each application in the Agile application suite can be hosted on one or more web 
application servers.

Note We recommend that you use separate application pools if the same web 
application server is shared across Agile applications.
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SQL Database Server Requirements

Software Requirements
To properly run Agile Product Lifecycle Management for Process, use the 
following supported versions for the SQL database server::

❑ Microsoft Windows 2003 Server, SP1

❑ Microsoft SQL Server 2005, SP2

Hardware Requirements
To properly run Agile Product Lifecycle Management for Process, the SQL 
database server must meet the following minimum requirements:

❑ Dual CPU Intel Xeon 2.8 GHz

❑ 4.0 GB RAM

❑ 50 GB available storage

❑ Separate drives for data and log files

Note The database server can be managed in a clustered environment.

Oracle Database Server Requirements

Software Requirements
To properly run Agile Product Lifecycle Management for Process, use the 
following supported versions for the Oracle database server:

❑ Oracle Database Server:  10g Release 2 (10.2.0.4), 11g 

❑ Oracle 11g Client + ODP.NET 11.1 (On the IIS server, as described in 
Microsoft IIS 6.0 Checklist on page 1-10)

❑ Operating system supported by the Oracle database. Please note, the 11g client 
is required whether you implement Oracle DB 10g or 11g.

Hardware Requirements
To properly run Agile Product Lifecycle Management for Process, the Oracle 
database server must meet the following minimum requirements:

❑ Dual CPU Intel Xeon 2.8 GHz

❑ 4.0 GB RAM

❑ 50 GB available storage

❑ Separate drives for data and log files
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Remoting Container Requirements
With the Agile application suite, you receive the Agile Remoting Container, a 
Windows OS-level service. This remoting container can exist on the same Web 
application server described above. The following are requirements for the 
remoting container:

❑ Microsoft Windows 2003 Server, SP1

❑ Microsoft .NET Framework 2.0

The Agile remoting container typically hosts the following Agile services:

❑ Authentication bridge for Agile Single Sign-on (SSO)

❑ Authorization bridge for Agile SSO pertinent to DRL file access

❑ Syndication server (a component of Content Syndication and 
Synchronization)

❑ Reporting Queue service

❑ Taxonomy Denormalization service

❑ Import/Export service

❑ Object-level security Denormalization service

❑ Smart Issue service

Note The remoting container can be scaled or isolated as needed.

Scaling Requirements
You will need to scale your system for performance and availability as your 
system begins to grow due to an increased use of the Agile application suite and 
a growing number of users and as your business demands change or increase. The 
following sections provide scalability recommendations.

Scaling for Performance
You will need to scale for performance as your number of users and applications 
begins to increase over time. In consideration of performance scaling, we 
recommend the following:

❑ No more than 250 registered users per processor.

❑ Organize scaling according to regional user patterns (according to users in 
similar time zones and geographical regions).

❑ Once physical Web application server limitations are met, use a load-balanced 
(logical or actual) solution.

Scaling Beyond Five Core Applications
The following are recommendations for scaling beyond five (5) core Agile 
applications. Core Agile applications include:
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• Global Specification Management (GSM)

• Supply Chain Relationship Management (SCRM)

• New Product Development (NPD)

• eQuestionnaire (eQ)

• Agile applications portal

❑ Run no more than five (5) core Agile applications on a single Web application 
server.

❑ Organize scaling based on an evaluation of utilization patterns (known 
application characteristics).

Load Balancing
As mentioned above, once physical Web application server limitations are met, 
use a logical load-balanced solution based on application distribution across 
servers. For example, as shown in figure 1-2 below, a logical separation might be 
organized by application as follows:

GSMAppGroup—Includes GSM and other complimentary applications

NPDAppGroup—Includes NPD and other complimentary applications

Figure 1-2: Agile Product Lifecycle Management for Process deployed in a logical separation



Agile Product Lifecycle Management for Process

1-8 Install/Upgrade Guide

Scaling for Availability
You may also need to scale for availability as your business demands begin to 
change or increase over time. 

For application load-balancing, we recommend the following:

❑ A load balancer (such as f5 BigIP or Cisco CSS11000) that supports the 
following:

• Secure Sockets Layer (SSL) protocol

• Sticky sessions

❑ A maximum of five core Agile applications per load-balanced node.

Note A clustered node is an expansion of a logical application separation.
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For database, file, and service clustering, we recommend the following:

❑ A clustered server to support an active or passive database system

❑ A file cluster (where required)

❑ Service clustering

Figure 1-3: Sample deployment of a load-balanced and clustered system
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Pre-Installation Checklists
This section discusses Web application server-related tasks that an Agile 
implementer must complete before installing the Agile application suite.

Microsoft IIS 6.0 Checklist
Before installing the Agile application suite, complete all of the Microsoft IIS 6.0-
related tasks in the following sections:

❑ Adding an IIS Server Role to Microsoft Windows 2003

❑ Configuring the IP Address of the IIS Default Site

❑ Configuring IIS Application Pool Settings

❑ IIS Metabase Explorer Settings

❑ Enabling IIS WebDAV for NPD Applications

Adding an IIS Server Role to Microsoft Windows 2003
You will need to create a Web server role using the ASP.NET Role Manager. The 
role type must be the IIS server role, ASP.NET only.

To add a role for IIS, follow these steps:
1 Click Start > All Programs > Administrative Tools, and then click Manage Your 

Server. 

2 On the Manage Your Server page, click Add or remove a role, and then click 
Next. 

3 Under Server Role, select the Application server (IIS, ASP.NET) server role, 
and then click Next. 

4 Check the Enable ASP.NET box, and then click Next. 

5 Verify that Enable ASP.NET is listed on the Summary of Selections page, and 
then click Next. 

6 If prompted, insert your Windows Server 2003 CD in the CD drive, and then 
click Next.

7 Click Finish.
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Configuring the IP Address of the IIS Default Site
When you install IIS, it is preconfigured to serve as a default Web site; however, 
you may want to change some of the settings. 

To change the basic settings for the Web site:
1 Log on to the Web server computer as an administrator. 
2 Click Start > All Programs > Control Panel. 

3 Double-click Administrative Tools, and then double-click Internet Services 

Manager. 

4 Right-click the Web site that you want to configure in the left pane, and then 
click Properties. 

5 Click the Web site tab. 
6 Enter a description for the Web site in the Description box. 
7 Enter a value in the IP Address field for the Internet Protocol (IP) address to 

use for the Web site.
8 Modify the Transmission Control Protocol (TCP) Port as appropriate. 
9 Click the Home Directory tab. 

• To use a folder on the local computer, select a directory located on this 
computer, and then click Browse to locate the folder to use. 

• To use a folder that has been shared from another computer on the 
network, click a share located on another computer, and then either type 
the network path or click Browse to select the shared folder. 

10 Click Read to grant read access to the folder (required). 
11 Click OK to accept the Web site properties. 

Configuring IIS Application Pool Settings
You must configure various IIS Application Pool settings as follows:

1 Log on to the Web server computer as an administrator. 
2 Click Start > All Programs > Control Panel > Administrative Tools > Internet 

Information Services (IIS) Manager.
3 In the left pane, expand the local computer and locate Application Pools.
4 Right-click the DefaultAppPool option.
5 Make the following configuration changes:

• On the Recycling tab, deselect all five check boxes.

• On the Performance tab, check the Limit the kernel request queue box. Set 
the value to 4000.

• On the Identity tab, check the Predefined box. Set the value to 
LocalSystem.

• Set the Application Pool Identity to Local System. 

Note The identity of the application pool needs to be a user with access to 
any files the applications under it may need.  In the case of the DRL 
application, this user must be able to access the file repository 
location.  If this is on a network storage device, the user “Local 
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System” will not work.  The same is also true for NPD and the 
WebDAV file location.

Important If utilizing Integrated SSPI in the DB connectstring, then the 
identity of the application pool needs to be a user with datareader and 
datawriter for the database. This user will need to be added to the 
IIS_WPG group.

IIS Metabase Explorer Settings
IIS Metabase allows you to view, edit, copy, paste, move, drag, drop, and monitor 
activity in your IIS metabase. You will need to install the IIS Metabase Explorer 
1.1 and make the following Application Pool Key settings:

❑ Set DissallowOverlappingRotation to 1 (from 0)

❑ Set LogEventOnRecycle to 255 (from 8) 

Enabling IIS WebDAV for NPD Applications
If you are installing the Agile NPD (New Product Development) application, you 
must enable the WebDAV (Distributed Authoring and Versioning) protocol in 
Microsoft IIS 6.0 to support in-place editing. This is described in Installing 
WebDAV on page A-1.

Microsoft SQL Server 2005 Checklist

Refer to Microsoft SQL Server documentation for installation instructions. For 
information on the MS SQL Reporting Server, which can be optionally installed, 
refer to the Agile Product Lifecycle Management for Process Configuration Guide. 
When installing MS SQL Server 2005 Standard Edition, be sure to:

❑ Install MS SQL Server 2005 Standard Edition with the mixed mode 
authentication and default options. 
(Ensure the Collation designator and sort order are Latin1_General.)

1 Run the MS SQL Server setup.

2 Select Install Database Server and click Next.

3 Select Install Default Instance on Local Computer and click Next.

4 Select Default Instance and click Next.

5 For Setup Type, select Typical and click Next.

6 Select Use Same Account for Each Service and Use the Local System 

Account and click Next.

7 Select Mixed Mode. Enter a System Admin password and confirm. 

8 Click Next twice to complete the installation.
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❑ Configure the MS SQL Server 2005 settings as follows:

1 In the SQL Server Enterprise Manager, right-click the server in the tree 
view, left pane. 

2 Select Properties and click the Memory tab. 

3 Select Use a Fixed Memory Size.

4 On the Processor tab, under Processor Control, select all available 
processors. 

5 Click Boost SQL Server Priority, assuming the box is only running SQL 
Server.

6 Under Parallelism, select Use All Available Processors.

7 Under Database Settings > New Database Default Location, set the 
appropriate paths for the data and log files:

• Data files:
array2\Program Files\Microsoft SQL Server\MSSQL\Data 
(optimized for balance of reads and writes - 75/25) 

• Log files:
array1\Program Files\Microsoft SQL Server\MSSQL\Data 
(optimized for sequential writes) 

8 On the General tab, select Autostart SQL Server and Autostart SQL Server 

Agent.

❑ Set up two SQL accounts, which are recommended to run and manage the 
application:

• ProdikaDBAdmin—This account should have database owner access to 
the application database. Use this account to run the application 
installation and upgrade scripts.

• ProdikaAppUser—This account will be used by the Web server 
applications for access to the back-end data and should have read/write 
access to all of the application database tables and views. Additionally, 
this account should have access to execute all user-defined functions.

❑ Apply all available security patches for MS SQL Server 2005.

❑ Schedule a maintenance plan. Production backups should occur nightly. 
Test backups should occur twice weekly.

1 In the Enterprise Manager, drill down in the left pane to Management > 

Database Maintenance Plan.

2 In right pane, right-click and select New Maintenance Plan.

3 Select the database to maintain.

4 Click through the Wizard to configure the database maintenance plan.
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Oracle Database Server Checklist
❑ Create the Oracle database server using Oracle Database Configuration 

Assistant.

❑ Choose AL32UTF8 as the database character set and UTF8 as the database 
national character set.

Oracle Database Client Checklist

The following Oracle Database Checklist can be used in conjunction with Oracle 
Database documentation containing installation instructions. Clients should use 
this checklist or the Microsoft SQL Server 2005 Checklist on page 1-12, but not 
both, as they are separate installation methods. When installing the Oracle client, 
be sure to:

❑ Install Oracle 11g Release 1 (11.1.0.6) client on the server hosting the 
application. 

❑ Update the tnsnames.ora, located at %Oracle Client 
Home%\network\admin\tnsnames.ora, to include a new data source. 
This data source should point to the Oracle database that has been set up.

❑ Build your connection string: 

“User Id=<user id>;Password=<password>;Data Source=<data 

source created in step 4>” where

a User Id = db username

b Password = passwd

c Data Source = The name that you gave your tnsnames.ora entry

SSL Checklist
SSL (Secure Sockets Layer) is a protocol from Netscape Communications 
Corporation that is designed to provide secure communications on the Internet. 
SSL is not required for an Agile installation but will be used in most instances, as 
determined by the customer.

SSL can be deployed in many ways. Most commonly, SSL will run within IIS or 
on an intermediary system such as a Reverse Proxy or SSL accelerator.

The Agile application suite can operate in any of these scenarios, but the HTTP 
scheme must be configured (via environmentvariables.config) to generate 
the desired relative URLs correctly (http vs. https).

East Asian Language Support
If you plan to support foreign languages in Agile Product Lifecycle Management 
for Process, you must install East Asian language support on the server.
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To install East Asian language support on the server:
1 Access the Windows Control Panel dialog box by clicking Start > Control 

Panel.

2 Select Date, Time, Language, and Regional Options > Regional and Language 

Options and click the Languages tab.
3 Check the Install Files for East Asian Languages box.
4 Click Apply and OK.

Restoring the SQL Database and Setup Database Accounts
You should receive a copy of a prepared database as part of your Agile software 
media from Agile Software. Using Microsoft SQL Server Management Studio, 
you will need to restore this database onto your local database server. You will 
also need to make sure that the user responsible for accessing the database has the 
appropriate account setup and assigned roles.

Restoring the SQL Database
To restore the database onto your local database server:

1 Open MS SQL Server Management Studio.
2 In the left pane, right-click on Databases and select Restore Database.

The Restore Database dialog displays.

3 In the General page, type a database in the To Database field.

Note We recommend that your database name include the environment 
name and software version, for example: production_v50.

4 Select From device. 
5 Click the browse button for the From device text box, which opens the 

Specify Backup dialog box.
6 Click the Add button to display the Locate Backup File dialog box. Browse to 

the software media containing the database from Agile Software. 
7 Click OK twice to return to the Server Management Studio.
8 In the Options page, select Restore Database.

9 Verify that the data file and log file paths are set to the correct paths.
10 Click OK to begin the restoration.

Setting Up User Permissions 
To set up database user permissions:

1 Open MS SQL Server Management Studio.
2 In the left pane, drill down into the Databases folder to locate the database 

that you just restored.
3 For this database, select Security > Users.
4 Right-click on Users and select New User to display the Database User - New 

dialog box.
5 Type a user name in the User Name field.
6 Select Login Name. To the right of this radio button, click the browse button 

to display the Select Login dialog box.
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7 In the Select Login dialog, click Browse to display a list of login objects. Select 
a login object and click OK twice to return to the Database User - New dialog 
box.

8 In the Database Role Membership section, assign the following two roles to 
the user:

• db_datareader

• db_datawriter

9 Click OK.

Restoring the Oracle Database

To restore the Oracle database:
1 Create an Oracle database user. A SQL script is provided to create the 

database user and set up user permissions for the application. Run the SQL 
script createuser.sql using Oracle SQL*Plus.

2 Note that the imp client version has to match exactly the Oracle database 
server version. The client character set also needs to be set to the server 
character set. Import the Oracle database dump file from the command 
window:
C:> set NLS_LANG=AMERICAN_AMERICA.AL32UTF8

C:> imp <ORCL dbuser>/<ORCL dbpwd>@<datasource> 

fromuser=<agile> touser=<target dbuser> file=<dmp file> 

log=<log file>

Remote Container Service and Application Pool Accounts
The remote container service and application pool are standard Microsoft 
Windows services, which require user accounts in order to run. During the Agile 
installation, the service is installed as the Local System account.

To change the account which the service runs under:
1 Select Start > Administrative Tools > Services.
2 Locate the RemoteContainerService within the list of services listed in the 

Services dialog box.
3 Right-click the RemoteContainerService row and select Properties.
4 Select the Log On tab.
5 Select the This account radio button.
6 Select the user account that has the necessary security access to run the 

Remoting Container Service.

Before installing Agile Product Lifecycle Management for Process, make sure that 
your IT department has created an account for each service for you. Such 
accounts can be system accounts, local Windows accounts, or domain accounts 
(active directory). The process for creating a remote container service account 
and application pool account is a standard approach for creating Windows 
accounts.
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Important If utilizing Integrated SSPI in the database connectstring, then the 
logon account for the remote container service needs to be a user with 
datareader and datawriter rights for the database.
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Installation
The Agile PLM suite is installed through a set of manual configuration steps. 
Several of the steps are automated with utility batch scripts for a default 
configuration. The overall process consists of the following steps:

❑ Set up PRODIKA_HOME

❑ Install the core application files

❑ Register environment components

❑ Install individual media bundle application files

❑ Set up the initial IIS Web site

❑ Set up the initial IIS application pools

❑ Register the IIS virtual directories for the installed applications

❑ Register .Net version 2.0 for ASP 

❑ Restore the reference database

❑ Install language support for Simplified Chinese, Traditional Chinese, or 
Korean

❑ Configure applications

❑ Complete optional steps

Installation Process

Setting up PRODIKA_HOME

Note This step needs to be done only once per Web site instance. If you have 
multiple instances of the Agile PLM suite running on the same server, you 
will need to perform this step once per instance.

1 Create a folder (e.g. c:\PLM) into which to install the application. For 
instructional purposes, this folder will be called PRODIKA_HOME.

Installing the Core Application Files

Note This step needs to be done only once per PRODIKA_HOME. If you have 
multiple instances of the Agile PLM suite running on the same server, you 
will need to perform this step once per instance.



Chapter 1 Installation

1-19

Throughout the instructions below, the place where you extracted the media 
bundle zip file will be referred to as INSTALLER_HOME.

1 Open the containing directory for INSTALLER_HOME.
2 Extract Core.zip located in INSTALLER_HOME\PDM (where PDM is the 

name of the media bundle being installed) to a temporary directory (i.e.; 
c:\temp). This will give you a directory structure like c:\temp\Apps, 
c:\temp\Config, etc. This temporary directory will be referred to as 
TEMP_HOME.

3 Copy FileCompressionHelper.exe from INSTALLER_HOME to 
TEMP_HOME.

4 Open a command prompt and navigate to TEMP_HOME (i.e.; >cd 
c:\temp).

5 Run the following: 
>FileCompressionHelper.exe -d

Important It is extremely important that you perform the decompression 
described in step 5 before continuing to install any additional media 
pack bundle files.

6 When the distribution is complete, move your TEMP_HOME contents to 
PRODIKA_HOME.

Registering Environment Components
1 Register event logs.

a Open a command prompt and navigate to 
INSTALLER_HOME\Installer\Tools.

b Run the following batch file:

>SetupEventLogs.bat

c You will be asked to verify the addition of each event log to your system 
event logs. Click Yes/Ok through all of the event log additions.

2 Register Component Art and Apoc.
a Open a command prompt and navigate to 

INSTALLER_HOME\Installer\Tools.

b Run the following batch file:

>ConfigureRegistry.bat

c You will be asked to verify the addition of each registry entry. Click Yes/
Ok through all of the event log additions.

3 Install the Remoting Container Service.
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Note This step needs to be done only once per PRODIKA_HOME. If you 
have multiple instances of the Agile PLM suite running on the same 
server, you will need to perform this installation once per instance.

a Open a command prompt and navigate to 
INSTALLER_HOME\Installer\Tools.

b Stop IIS - from the command prompt type the following:

>iisreset /stop

c Run the following batch file with <PRODIKA_HOME> replaced by your 
specific PRODIKA_HOME directory:

>InstallRemotingContainerService.bat <PRODIKA_HOME>

Installing Individual Media Bundle Application Files
1 Open the containing directory for INSTALLER_HOME.
2 Extract the media pack zip file located in INSTALLER_HOME to a temporary 

directory (i.e.; c:\temp). This will give you a directory structure like 
c:\temp\config, c:\temp\FileCompressHelper_CentralDirectory & 
c:\temp\Web.

3 Confirm media bundle names for the ZIP files, where the name can be one 
of :
• MP1.zip for the PDM install

• MP2.zip for the FC install

• MP3.zip for the PSC install

• MP4.zip for the NPD install 

• MP-ALL.zip which includes all of the media bundles in one zip file

4 Copy FileCompressionHelper.exe from INSTALLER_HOME to 
TEMP_HOME.

5 Open a command prompt and navigate to TEMP_HOME (i.e.; >cd 
c:\Temp).

6 For all of the media bundles other than the NPD media bundle, run the 
following utility application:
>FileCompressionHelper.exe -d

7 When the distribution is complete, move your TEMP_HOME contents to 
PRODIKA_HOME.

8 Accept the warning(s) to overwrite the directories that already exist.
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Setting Up the Initial IIS Web Site
It is recommended that you create a new Web site under IIS under which the 
Agile PLM suite will be managed. If you choose to run the suite under the default 
Web site, you may skip this step.

1 Open the Internet Information Services (IIS) Manager utility Start > All 

Programs > Control Panel.
2 Double-click Administrative Tools, and then double-click Internet Information 

Services Manager.
3 Expand the {server_name} node, where {server_name} is the name of the 

server.
4 Expand the Web sites node.
5 Right-click the Web sites node and select New > Web Site….
6 Click Next.
7 Enter a Description (e.g. Agile PLM) for your Web site.
8 Click Next.
9 Set the IP configuration and Host Header for your Web site.

10 Click Next.
11 Set the path to point to the PRODIKA_HOME directory you created as the 

first step of this installation.
12 Leave the Allow anonymous access to this Web site checked.
13 Click Next.
14 Make sure the Read, Run scripts (such as ASP), and Execute (such as ISAPI 

applications or CGI) are checked.
15 Click Next.
16 Click Finish.

Setting Up ASP.net AJAX 
ASP.net AJAX is the third party software required to navigate to applications in 
Agile PLM for process. It is used in GSM to improve visual performance.

To install AJAX:
1 Access the following site: 

http://www.microsoft.com/downloads/details.aspx?FamilyID=ca9d90fa-
e8c9-42e3-aa19-08e2c027f5d6&displaylang=en

2 Click Download to begin the download process of ASP.NET AJAX 1.0.
3 Run the installer downloaded in step 2.
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Setting Up the Initial IIS Application Pools
In a default installation, it is recommended that you run the suite of applications 
under multiple application pools in order to provide better resource 
management and security. The utility scripts are designed to place the different 
applications under the same application pool, or you may run the 
SetupVirtualDirectories.bat file manually giving the values for the specific Web 
applications to segment them as you see fit.

The general process of installing the necessary Web applications using the utility 
scripts is listed below:

1 Open a command prompt and navigate to the directory 
INSTALLER_HOME\Installer\Tools.

2 To install the core Web site virtual directories, choose one of the following 
options:
• Option 1, Creating a single app pool—To install the core Web site 

virtual directories, type the following where the values 
<PRODIKA_HOME>, <siteid> & <AppPool> are replaced with the 
values associated with your specific environment:

SetupCoreVirtualDirectories.bat <PRODIKA_HOME> <siteid> 
<AppPool>

• Option 2, Segmenting the applications into separate application 
pools—To manually create the virtual directories needed for the 
individual applications within the core application bundle, type the 
following. You will need to repeat this script for each of the different 
applications within core. Refer to the SetupCoreVirtualDirectories.bat 
file to determine the applications within core.

SetupVirtualDirectories.bat drl <siteid> <PRODIKA_HOME> <AppPool> 
drl

Note Please refer to the section Determining a Web Site’s Site ID on page 1-
34 to determine the value for <siteid>.

3 Each media bundle has an associated 
Setup<MediaBundle>VitualDirectories.bat batch file where 
<MediaBundle> is PDM, FC, SupplierCollab or NPD. To install the 
necessary virtual directories for each installed media bundle, repeat the 
process outlined in step 2, replacing <Media Bundle> appropriately.

Registering .Net version 2.0 under ASP
1 Open a command prompt and navigate to INSTALLER_HOME\Installer\Tools.
2 Run the following command:

>RegisterASP_2_0.bat
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Installing the Reference Database
There is a reference database that is located under 
INSTALLER_HOME\Database. Restore this database to your database server by 
following the instructions outlined under the Restoring the SQL Database on 
page 1-15 and Setting Up User Permissions on page 1-15 section earlier in this 
guide.

Installing Language Support for Simplified Chinese, 
Traditional Chinese, or Korean
As an optional step, customers may apply 6.0.0.2.0 National Language Support 
(NLS) installation:

Pre-Upgrade checklist
1 Archive the previous installation.
2 Back up your current database.
3 Stop the Remoting Container service.

a Open Services > Start > Administrative Tools > Services.
b Locate the RemoteContainerService service and perform a Stop operation.

4 Stop IIS. From a command prompt, type the following:

> iisreset /stop

Apply Database Scripts

To apply the 6.0.0.2.0 scripts: 

(For SQL Server)
1 Open a command prompt and navigate to the directory where you unzipped 

the upgrade package.
2 Change directories (cd) to the Installer/ApplyScripts directory.
3 Apply the scripts using the following calls to the ApplyScripts.exe utility:

a Apply the scripts to load Korean translation:

> ApplyScripts -c "server=<database_server>;uid=<user>;
password=<password>;database=<database>" -f 
6.0.0.2.0_Korean_LangPack.xml

b Apply the scripts to load Simplified Chinese translation:

> ApplyScripts -c "server=<database_server>;uid=<user>;
password=<password>;database=<database>" -f 
6.0.0.2.0_Chinese_LangPack.xml

c Apply the scripts to load Traditional Chinese translation:

> ApplyScripts -c "server=<database_server>;uid=<user>;
password=<password>;database=<database>" -f 
6.0.0.2.0_ChineseTW_LangPack.xml

4 After the ApplyScripts call, you can confirm that the database upgrade 
scripts have been applied successfully when the system prompts you with the 
following message:

"Complete - with no errors"
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(For Oracle Database)
1 Open a command prompt and navigate to the directory where you unzipped 

the upgrade package.
2 Change directories (cd) to the Installer/ApplyScripts directory.
3 Apply the scripts using the following calls to the ApplyScripts.exe utility:

a Apply the scripts to load Korean translation:

> ApplyScripts -c "User Id=<user>;Password=<password>;
Data Source=<datasource>" -dbvendor="orcl"  -f 
6.0.0.2.0_Korean_LangPack.xml

b Apply the scripts to load Simplified Chinese translation:

> ApplyScripts -c "User Id=<user>;Password=<password>;
Data Source=<datasource>" -dbvendor="orcl"  -f 
6.0.0.2.0_Chinese_LangPack.xml

c Apply the scripts to load Traditional Chinese translation:

> ApplyScripts -c "User Id=<user>;Password=<password>;
Data Source=<datasource>" -dbvendor="orcl"  -f 
6.0.0.2.0_ChineseTW_LangPack.xml

4 After the ApplyScripts call, you can confirm that the database upgrade 
scripts have been applied successfully when the system prompts you with the 
following message:

“Complete - with no errors”

Post-Upgrade Checklist
1 Start the Remoting Container Service.

a Open Services > Start > Administrative Tools > Services.
b Locate the RemoteContainerService service and perform a Start operation.
c Verify that the RemotingContainerService started correctly.

2 Start IIS. From a command prompt, type the following:

> iisreset /start

Configuring Applications
Review the Agile Product Lifecycle Management for Process Configuration Guide to 
apply the configuration changes required for the installation.
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Configuring the Oracle Database Connection

To configure the Oracle Database Connection:
1 Change the Database Connection pools as shown below. The 

ADAPTER_FACTORY needs to have the Oracle specific 
ADAPTER_FACTORY. The format of the CONNECT_STRING is different 
from the default SQL Server settings. 

<ConnectionPools>

<ProdikaDB configChildKey="key">

<config key="MAX" value="8"

configOverrideModifier="IsLocked"/>

<config key="CONNECT_STRING" value="User Id=<ORCL DB 
USER>;Password=<ORCL DB PWD>;Data Source=<DATASOURCE>" 
configAttributeOverrideBehavior="Replace" 
configOverrideModifier="IsLocked"/>

<config key="ADAPTER_FACTORY" 
value="Class:Xeno.Data.Oracle.OracleDbAdapterFactory,
DataLib" configAttributeOverrideModifier="CanExtend"/> 

</ProdikaDB>

<ReportDB copyOf="ConnectionPools/ProdikaDB">

<config key="CONNECT_STRING" value="User Id=<ORCL DB 
USER>;Password=<ORCL DB PWD>;Data Source=<DATASOURCE>" />

</ReportDB>

</ConnectionPools>

Note You should change the connect string in the 
environmentvariables.config file.

2 Add the EQT Service config in the EnvironmentSettings and specify the 
DBHelper to be Oracle Specific DB Helper as shown below:

<Prodika>

<Services>
.
.
.

<EmailService configChildKey="name">

<envvar name="EMAIL_DOMAIN_FILTER" value="<YOUR EMAIL 
DOMAIN - ex: oracle.com" 
configOverrideModifier="IsLocked"/>

<envvar name="BCC_AUDIT_EMAIL_ADDRESS" value="" 
configOverrideModifier="IsLocked"/>

<envvar name="SMTP_SERVER" value="<YOUR SMTP ADDRESS>" 
configAttributeOverrideBehavior="Replace" 
configOverrideModifier="IsLocked"/>

</EmailService>

<EQTService configChildKey="name">
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<envvar name="DBHelper"
value="Xeno.Prodika.EQT.Execution.OracleDBHelper,EQT" />

</EQTService>

<SyndicationService configChildKey="name">     

<envvar name="ErrorNotifyFromAddress" 
value="#CUSTOMER_FROM@CUSTOMER.COM" 
configElementOverrideModifier="IsLocked" 
configAttributeOverrideModifier="Replace" />

<envvar name="ErrorNotifyToAddress" 
value="#CUSTOMER_TO@CUSTOMER.COM" 
configElementOverrideModifier="IsLocked" 
configAttributeOverrideModifier="Replace" />

</SyndicationService> 
.
.
.

</Services>

3 Restart IIS. You can now use the Prodika installation on the Oracle 
Database. 
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BI Publisher for Printing and Reporting
Oracle Business Intelligence Publisher (BI Publisher) has been integrated with 
the Printing and Reporting applications. Printing and Reporting have separate 
configurations settings, and BI Publisher can be configured for Printing, 
Reporting, or both. 

Requirements: Oracle BI Publisher version 10.1.3.3 (later versions are not 
supported) must be installed and accessible to the Agile PLM for Process 
environment.

When installing BI Publisher, you will be prompted to enter an administrator 
username and password for administering the BI Publisher reports. This 
username and password will also grant access to a BI Publisher web service used 
by Agile PLM for Process to processes printing and reporting requests. Take note 
of the username and password as it will be required for the configuration settings.

Note that when setting up BI publisher for Reporting, you will need to set up a 
database connection to the Agile PLM for Process database. This may involve 
installing relevant JDBC drivers, setting up the DataSource in BI Publisher, and 
configuring the connection string and database driver class. Please refer to the 
Oracle BI Publisher documentation for details. 

Printing Using BI Publisher
To configure BI Publisher for Printing, you will need to update Agile PLM for 
Process configuration settings and set up BI Publisher to process the incoming 
data using BI Publisher’s Report Templates. 

Print data is sent to the BI Publisher web service as XML data; the relevant BI 
Publisher Report Template takes the incoming XML data and can then transform 
it using a custom XSL as needed. 
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To configure Agile PLM for Process:
1 Update the \config\environmentvariables.config file:

2 Update the \config\Extensions\PrintSettings.config file. This 
file contains the print configurations for the various print items, such as 
Specifications, NPD printing, etc. You will need to update this file to use the 
BIPublisherFORender print manager:

a Open the \config\Extensions\PrintSettings.config.
b Update the specification (or other print item) type you want to print to 

use the BI publisher print manager. You can add the following to an 
existing entry, or create a new entry:

printmanager="BIPublisherFORender" reportPath="Your custom 
BI Publisher report path"

For example: 

<PrintTemplate id="Default" library="XSL_FO_LIBRARY" 
report="GSM$xlate$.xsl" 
printmanager="BIPublisherFORender" reportPath="/
ProdikaPrint/ProdikaPrintFO/ProdikaPrintFO.xdo"/>

An optional attribute, reportTemplate, is used to specify which BI 
Publisher report Layout to use.

Note that the reportPath value should correspond to the report set up in BI 
Publisher.

To configure BI Publisher for Printing:
Setting up BI Publisher for Printing involves creating a BI Publisher report, 
configuring its Data Model to link it to Agile PLM for Process, and setting up the 
possible Layouts. In this section, an example report configuration is presented, 
but other configurations are possible. 

1 Log in to BI Publisher (http://<YourBIServerURL>:9704/xmlpserver/).
2 In the Reports tab, click the Shared Folders link.
3 Create a new folder (ex: ProdikaPrint).
4 In the new folder, click the Create a new report link on the left, enter a report 

name (ex: ProdikaPrintFO) and click the Create button.
5 Click the Edit link.

Key Value

Prodika.Print.BIPublisherIntegration.EndPoint http://<BIPublisher-location>:9704/
xmlpserver/services/PublicReportService 

Prodika.Print.BIPublisherIntegration.UserName BI Publisher username as configured on 
installation

Prodika.Print.BIPublisherIntegration.Password BI Publisher password as configured on 
installation
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6 Click Parameters, then click the New icon.

Figure 1-4: Parameters option, Parameter page

a Make entries in the following fields:

Identifier— Enter DocKey. This is a required field.

Data Type—Select String from the drop-down list. This is a required 
field.

Default Value—Leave this field blank.

Parameter Type—Select Hidden from the drop-down list. This is a 
required field.

b Click Save. 

7 Click Data Model, then click the New icon, as shown in figure 1-5 below.
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Figure 1-5: PrintDataModel option, Data Set page

a Make entries in the following fields:

Name—Name of the data model. This is a required field.

Type—Select HTTP (XML Feed) from the drop-down list. This is a 
required field. 

URL—Enter
http://{application URL}/gsm/PopUps/docstream.aspx

where {application URL} is the address of the application. This is a 
required field.

Method—Select GET from the drop-down list. This is a required field.

b Click Add to display the Parameters Name and Value fields. 
c Make the following entries:

Name—The name of the parameter that you created in step a. This is a 
required field.

Value (Parameter)—Select DocKey from the drop-down list. This is a 
required field.

d Click Save. 
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8 Click Layout to set up the report layout.
a In the Manage Template Files section, upload your XSL template to use. 

In this scenario, we created and uploaded a simple XSL “pass-through” 
file called ReportTemplate.xsl, as such:

<?xml version='1.0'?>

<xsl:stylesheet version="1.0" xmlns:xsl="http://
www.w3.org/1999/XSL/Transform">

<xsl:template match="/">

<xsl:copy-of select="/" />

</xsl:template>

</xsl:stylesheet>

However, you can easily create your own transformation rules yourself.

b Click New to create a new report Layout, as shown in figure 1-6 below. 

Note You can create multiple layouts and then declare the desired layout 
in the PrintSettings.config file.

Figure 1-6: Layouts, FOTemplate option, Layout page



Agile Product Lifecycle Management for Process

1-32 Install/Upgrade Guide

c Make the following entries:

Name—The name of the report layout. This is a required field. 

Template— Select XSL Stylesheet (FO) from the drop-down list. This is a 
required field.

Template Type— Select the Limit Output Format to radio button, and 
then select the PDF checkbox. This is a required field. 

d Click Save.

Your report should now be available for printing. Make sure that the link to the 
report matches the reportPath value in the PrintSettings.config file. 
(While editing the report in BI Publisher, right-click on the View link in the top 
right and select Copy Shortcut to get the value).

If your Printing includes any images, such as logos, make sure they are available 
to BI Publisher, by adding them to the BI publisher directory. The location will 
depend on the path used.

Reporting Using BI Publisher
The Agile PLM for Process Reporting application allows clients to organize, 
configure, secure, and launch custom reports. The configuration is managed in 
the CustomerReportExtensions.xml located in the \Config\Extensions\ 
directory. Reports and their parameters are presented in PLM for user entry; their 
values are then passed to custom BI Publisher reports to process the parameters, 
query data sources, and generate the report.

To use BI Publisher for Reporting, you will need to update Agile PLM for Process 
configuration settings, set up custom reports in BI Publisher, and update the 
Agile PLM for Process Reporting configurations accordingly. 

For details on configuring custom PLM reports, refer to the Agile Product 
Lifecycle Management for Process Custom Report Configuration Guide.

To configure Agile PLM for Process:
1 Update the \config\environmentvariables.config file:

Key Value

Prodika.ReportServer.URL http://<BIPublisher-location> 

Prodika.ReportService.URL @@VAR:Prodika.ReportServer.URL@@:9704/
xmlpserver/services/PublicReportService

Prodika.ReportService.SysUser BI Publisher username as configured on 
installation

Prodika.ReportService.SysPassword BI Publisher password as configured on 
installation
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2 Update the \config\Custom\CustomerSettings.config file: 
a Find SQLReportingService node in the /CustomerSettings/Core/

Prodika/Services section.
b Set it as follows:

<SQLReportingService refscope="Session" 
factory="Class:Xeno.Reporting.Service.ReportGenerationS
ervice.Oracle.OracleBIPReportGenerationServiceFactory,
ReportingService" configChildKey="name" 
configAttributeOverrideModifier="Replace"></
SQLReportingService>

3 Update the \config\Extensions\CustomerReportExtensions.xml 
file to set up the custom reports for the Reporting application. Details can be 
found in the Agile Product Lifecycle Management for Process Custom Report 
Configuration Guide. 

To configure BI Publisher Reports:
Please refer to Oracle BI Publisher documentation for creating and setting up 
reports in BI Publisher.

Completing Optional Steps
For the NPD media bundle, create the WebDAV folder. Some parts of the Agile 
suite use WebDAV to allow in-place editing of certain document types. To allow 
for this, a setting is available in the <PRODIKA_HOME>/config/Custom/ 
EnvironmentSettings.config file for the WebDAV virtual folder. In cases for 
which WebDAV is required, create a WebDAV virtual folder and allow the 
anonymous user to access (read and write) the physical folder location on the 
hard drive. Refer to Installing WebDAV on page A-1 for instructions.
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Determining a Web Site’s Site ID

To determine the Site ID for a new Web Site within IIS 6.0:
1 Open IIS Manager via Administrative Tools.
2 Expand <server_name> node in the left pane.
3 Highlight the Web Sites node in the left pane.
4 The web sites and their corresponding ID will be listed in the right pane, as 

figure 1-7 shows below.

Figure 1-7: Web sites and IDs

Event Log
Event Viewer contains the following core event logs:

1 cssPortal-Prodika—Contains events or errors that are logged from within 
the Content Syndication Service Portal web application

2 DRL-Prodika—Contains events or errors that are logged while utilizing the 
document repository library (DRL)

3 DWBService-Prodika—Contains events or errors that are logged during 
processing of formulation optimization events

4 EQ-Prodika—Contains events or errors that are logged from within 
eQuestionnaire (EQ)

5 EQService-Prodika—Contains events or errors that are logged while 
utilizes services provided by eQuestionnaire

6 Integration-Prodika—Contains events or errors that are logged while 
utilizing external system integration services

7 NPD-Prodika—Contains events or errors that are logged from within New 
Product Development (NPD)
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8 Optimization—Contains events or errors that are logged during the process 
of optimization

9 PLMFramework-Prodika—Contains general events or errors that are 
logged during lower level service calls used throughout the Prodika 
framework

10 Portal-Prodika—Contains events or errors that are logged from within the 
Portal web application

11 PQS-Prodika—Contains events or errors that are logged from within the 
Product Quality Scorecard (PQS) web application

12 PrincipalManagement-Prodika—Contains events or errors that are logged 
within the User Group Management (UGM) web application

13 Print-Prodika—Contains events or errors that are logged during printing 
events

14 Prodika—Contains general framework events or errors that are logged 
during standard processes, such as failed log ins, etc.

15 ProdikaCommon—Contains events or errors that are logged from within 
the ProdikaCommon support library

16 Reg-Prodika—Contains events or errors that are logged from within the 
Regulatory web applications (CACS, FSIS, etc.)

17 ReportGenerator-Prodika—Contains events or errors that are logged 
during report generation

18 Reporting-Prodika—Contains events or errors that are logged from within 
the Reporting web application

19 SCRM-Prodika—Contains events or errors that are logged from within the 
Supply Chain Relationship Management (SCRM) web application

20 SP-Prodika—Contains events or errors that are logged from within the 
Supplier Portal (SP) web application

21 SupplierPortalAdmin-Prodika—Contains events or errors that are logged 
from within the Supplier Portal Administration web application

22 Syndication-Service—Contains events or errors that are logged from 
within the Content Synchronization and Syndication web application

23 WebCommon-Prodika—Contains events or errors that are logged from the 
common web controls used throughout the entire Prodika web framework

24 wfAdmin-Prodika—Contains events or errors that are logged from within 
the Workflow Administration web application

25 workFlowAdmin-Prodika—Contains events or errors that are logged from 
within the Workflow Administration web application
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Changing the Default Settings

To manually change the Event Log default settings:
1 Right click My Computer, and then click Manage. The Computer 

Management dialog box displays, as figure 1-8 shows below.

Figure 1-8: Computer Management dialog box

2 Expand the Event Viewer node to see the listing of all event logs within the 
system, as shown in figure 1-9 below.

Figure 1-9: Event Viewer, expanded

3 Select the Event Log you wish to modify by right-clicking and selecting 
Properties from the context menu. The Application Properties dialog box 
displays, as shown in figure 1-10.
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Figure 1-10: Application Properties dialog box

4 Modify the settings to match your needs and then click OK to save and exit 
the dialog box.

Post-Installation Checklists
This section discusses tasks that an Agile implementer must complete after 
installing the Agile application suite.

Setting the IIS Event Viewer Logging

Important This step is critical to successfully running the Agile application suite. 
You must set the Event Viewer logging to Overwrite events as needed 
for System, Security, Application, and all Agile-created event logs. 

If an event log is set to Overwrite events older than 7 days, then you may run into 
an issue when a new feature is introduced that uses multiple Warnings, Errors, or 
Information. The introduction of new event logging can fill up the event log so 
that no more events can be logged, throwing an exception back to the user of the 
application. The exception will not go away until the log is set to Overwrite events 

as needed or until the log is cleared manually. For this reason, we suggest setting 
all event logs to Overwrite events as needed.
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Important You will need to start up every Agile application, which will generate 
a new event viewer log. Review each event viewer setting to make sure 
the Overwrite events as needed option is selected.

To set the IIS Event Viewer Logging in IIS 6.0:
1 On your desktop, right-click the My Computer icon.
2 Click Manage from the fly-out menu to display the Computer Management 

dialog box.
3 In the left pane, click System Tools > Event Viewer to display all of the 

available event viewers.
4 Right-click on each event viewer and select Properties to display the 

Application Properties dialog box.
5 Select the Overwrite events as needed option.
6 Click Apply, and then click OK.

Updating the Version Number in the version.txt File

Modify the version.txt file as follows:
1 In your Prodika_Home directory, locate the version.txt file. 
2 Open the file with a text editor.
3 Edit the first line so that it contains only the following text:

Version: v6.0.0.3.0

4 Click File > Save to save the your change.
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Starting the Remote Container Service

To start the remote container service:
1 Right click My Computer.
2 Select Manage from the context menu. The Computer Management console 

will open.
3 Expand the Services and Applications node.
4 Select the Services node.
5 The services will be listed in the main content area.
6 Locate the RemoteContainerService.
7 Right click and select Start.
8 Wait a few seconds to verify that it starts and stays running.

Note Troubleshooting: If the service starts and then stops, check the log file 
under <PRODIKA_HOME>\logs\remoteContainer-stdout.log to 
determine the root cause.

Microsoft .NET Framework
After installing Microsoft .NET Framework, you need make some configuration 
changes to the machine.config file for performance optimization purposes.

Make the following updates to the machine.config file as follows:
1 Locate and open the machine.config file at:

C:\Windows\Microsoft.NET\Framework\v2.0.50727\Config\mach
ine.config

2 Locate the system.web tag and add the following under it:
<pages validateRequest="true" enableEventValidation="false"/>
<processModel enable="true" timeout="Infinite"

idleTimeout="Infinite"

shutdownTimeout="00:00:05" requestLimit="Infinite"

requestQueueLimit="5000" restartQueueLimit="10"

memoryLimit="60" webGarden="False" cpuMask="0xffffffff"

userName="SYSTEM" password="AutoGenerate" logLevel="Errors"

clientConnectedCheck="00:00:05"

comAuthenticationLevel="Connect" 
comImpersonationLevel="Impersonate"

responseDeadlockInterval="00:03:00"

responseRestartDeadlockInterval="00:03:00" autoConfig="True"

maxWorkerThreads="20" maxIoThreads="20" minWorkerThreads="1"

minIoThreads="1" serverErrorMessageFile="" 
pingFrequency="Infinite"

pingTimeout="Infinite" maxAppDomains="2000" />

<machineKey 
validationKey="B3B1257C1B375B1190AF16044C40A42739DEDDBA26C2F9DA3
5B20FC20C3F63B11B22C6B92D602EB8886E3D18F9548B84A0B80EBADC575C407
ED33F39ACE08389" 
decryptionKey="6D53B0178EF6AA0604C1D559B0962228B7449DAFD920113B" 
validation="SHA1"/>
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Note Sometimes, these tags might exist prior to this step. If these tags are 
already present, please update them to look as above.

3 Locate forms Attributes in either web.config or web.config.comments. (The 
xpath to the node is: /configuration/system.web/authentication.) 
[@mode='Windows']/forms 

4 Change the protection attribute on the forms tag to None.
5 Run the following command from a command prompt:

\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis
.exe -i

6 Open Internet Information Server Administrator and right-click on the 
Web virtual folder and choose Properties. 

7 Click on the ASP.NET tab to confirm that .NET 2.0 is selected.

Installation Verification Tests
In order to perform the recommended Agile installation verification tests, you 
will need the user name and password for an Agile user account having access to 
all Agile applications. The standard username and password that ships with the 
certified database is:

Username: prodikaadmin

Password: agile

Important Since this is a published username and password, it is highly advised 
that you change this password immediately upon successful 
installation of the system.

User access is managed using the User Group Management (UGM) application. 
For more information on user management, see the Agile Product Lifecycle 
Management for Process Administrator User Guide.

To verify installation:
1 Turn on Agile PLM for Process.
2 Access the Agile application using Internet Explorer. Use the following Fully 

Qualified Domain Name (FQDN) URL:
https://server.domain.tld/portal

Important Be sure to use a fully qualified domain name rather than just a 
servername.  Example: https://app/portal vs. https://
app.prodika.com/portal.

3 Type your use name and password, and press the Enter key.



Chapter 1 Installation

1-41

Note The following installation verification tests assume that you have installed 
the entire Agile application suite. If this is not the case, omit tests for 
applications that you have not installed.

Caution! You must be assigned the correct Agile roles to perform these 
installation verification tests. For more information on roles, see the 
Agile Product Lifecycle Management for Process Administrator User 
Guide.

Global Specification Management Test
Before performing this test, note that specifications, once created, cannot be 
deleted from GSM. Therefore, creating specifications for verification purposes 
contributes to the proliferation of meaningless specifications. If specifications 
already exist in the system, you may wish to skip this test.

The purpose of this test is to verify that GSM is properly functioning. 

To perform the GSM test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select GSM > Ingredient Specifications.
3 Click Create New in the upper right corner. A new ingredient specification 

template is displayed.
4 Type a specification name in the Spec Name field.
5 Complete the Approved for Use In section at the bottom of the page.
6 Click Save & Close Document in the upper right corner.
7 From the left navigation panel, select GSM > Ingredient Specifications.
8 Conduct a blind search by clicking Reset and then Search or specify search 

criteria to retrieve the specification that you just created.
9 In the Search Results table, click the Spec # link. The selected specification is 

displayed.
10 Click Workflow in the upper right corner.
11 Type any value in the Comments field.
12 Click the move step forward ( ) icon. If additional dialog boxes appear, 

it confirms that GSM is functioning.

Note To remove the test data in a production environment, restore your 
database, restart the Remoting Container, and then restart the application 
pools. This returns the environment to the default installation state. 

Printing Test
The purpose of this test is to verify that the Agile Printing Service is correctly 
functioning. 
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To perform the Printing test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select GSM > Ingredient Specifications.
3 Search for the specification that you created in Global Specification 

Management Test on page 1-41.
4 Click Print in the upper right corner.
5 In the resulting Print dialog box under Current Specification > Sections, 

select any check box.
6 Click Print again. The specification is rendered in PDF format in a separate 

window.
7 Close the window once the PDF successfully is displayed and proceed to the 

next test. If the PDF does not appear, double-click the file 
Prodika\Scripts\Installation\ApocEntry.reg and retry this test.

Attachment Test
The purpose of this test is to verify that the Attachments feature is correctly 
functioning.

To perform the Attachment test:
1 Navigate to any trade specification in GSM.
2 Select the Supporting Documents tab.
3 Click Edit to put the specification in edit mode.
4 Select the Attachments/Procedures link under Supporting Documents.
5 Click Add New button.
6 In the Title field, type test.
7 Click the Browse… button to select a file, and then select Open.

Note The size of the selected file must be less than the designated limit.

8 Click the Upload button. The first upload may take up to 30 seconds to 
complete.

9 Click Done in the Attachment Detail window.
10 Click Done in the Attachment/Procedures window.

Reporting Test
The purpose of this test is to verify that the Prodika Reporting Service is correctly 
functioning. 

To perform the Reporting test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, click RPT (Reporting).
3 Search for the specification that you created in Global Specification 

Management Test on page 1-41.
4 Click Generate Report.
5 In the resulting dialog, type a report name in the Report Name field and then 

click Save.
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6 In the left navigation panel, select Ad Hoc Reports > Reports Queue.
7 The resulting Reports Queue should contain an entry for your report. 

Refresh this view periodically by toggling from Reports Queue to Reporting 
and back, to see the status of your report update. If the report status fails to 
update, there is likely a problem with the Reporting Service.

8 When the report status indicates Complete, click the hyperlinked name of 
the report to download the report.

Supply Chain Relationship Management Test
The purpose of this test is to verify that the Agile SCRM application is correctly 
functioning. 

To perform the SCRM test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select SCRM > Company Profiles.
3 Conduct a blind search and select any company profile from the Search 

Results table to verify that it is displayed correctly.
4 If the company profile is displayed, click Cancel and proceed to the next test.

Nutrition Surveillance Management Test
The purpose of this test is to verify that the Agile NSM application is correctly 
functioning. 

To perform the NSM test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select NSM > Nutrient Analysis.
3 Click Create New in the upper right corner.
4 If the Nutrient Analysis template is displayed, click Cancel and proceed to 

the next test.

eQuestionnaire Test
The purpose of this test is to verify the Agile eQ application is correctly 
functioning. 

To perform the eQ test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select eQ > Ingredient Questionnaires.
3 Click Create New eQuestionnaire in the upper right corner.
4 In the Select Questionnaire Type dialog box, select the ingredient type and 

click Create New.
5 If the eQuestionnaire template is displayed, click Cancel and proceed to the 

next test.

New Product Development Test
The purpose of this test is to verify that the Agile NPD application is correctly 
functioning. 
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To perform the NPD test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select NPD > New Product Development > 

Projects.
3 Conduct a blind search and select any project from the Search Results table 

to verify that it is displayed correctly. If so, NPD has passed the test.
4 If no projects are found, click Create New in the upper right corner.
5 Select a business unit and project type in the resulting dialog box and then 

click Done.
6 If the NPD (Stage 1) template is displayed, click Cancel and proceed to the 

next test.

Product Quality Scorecard Test
The purpose of this test is to verify that the Agile PQS application is correctly 
functioning. 

To perform the PQS test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select PQS > Lot Samples.
3 Click Create Sample in the upper right corner. The Enter Code Data/Sample 

ID page loads.
4 In the Code Data or Sample ID field, type any text. 
5 Click Next. The Select Specification page loads.
6 In the Specification section, click the Specification link. A Specification 

Search dialog box appears.
7 In the resulting Search dialog box, type criteria to find and select the 

ingredient specification that you created in Global Specification Management 
Test on page 1-41.

8 If the ingredient specification is displayed, the test has succeeded. 
9 Click Close in the upper right corner, and proceed to the next test.

Component Catalog Test
The purpose of this test is to verify that the Agile Component Catalog service is 
correctly functioning. 

To perform the Component Catalog test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select GSM > Component Catalog.
3 Conduct a blind search and select any catalog from the Search Results table.
4 If the catalog is displayed successfully, click Cancel and proceed to the next 

test.

Computer Aided Compliance Screening Test
The purpose of this test is to verify that the Agile CACS application is correctly 
functioning. 
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To perform the CACS test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select CACS.
3 Conduct a blind search and select any computer aided compliance screen 

from the Search Results table to verify that it is displayed correctly.
4 If no computer aided compliance screens are found, click Create New in the 

upper right corner.
5 Type a name for the screen in the Title field and a description in the 

Description field.
6 Click Save & Close.

Supplier Portal Test
The purpose of this test is to verify that the Agile Supplier Portal application is 
correctly functioning. First, log in to Supplier Portal and create a new registrant 
request:

To register with Supplier Portal:
1 Access Supplier Portal at https://server.domain.tld/supplierportal. 
2 Select a Language, and on the login page click click HERE if you have not 

registered with this site. 
3 Follow the screens, filling out all required data. Once you are done,c lick 

Submit. You have now submitted a registration request. Make note of your 
User Name and Password. 

To perform the SPA test:
1 Log in to Agile Product Lifecycle Management for Process as a Supplier 

Portal administrator.
2 From the left navigation panel, select SPA > New Registrations.

The registration request you just submitted should be displayed.

Note You need to be a supplier portal administrator to log in to SPA. Refer to 
the Agile Product Lifecycle Management for Process Exensibility Pack 
documentation to find out how to create a supplier portal administrator 
user. You can find this documentation in the Agile Product Lifecycle 
Management for Process Data Administration Toolkit Guide.

User Group Administration Test
The purpose of this test is to verify that the Agile UGM application is correctly 
functioning. 

To perform the UGM test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select UGM > Groups.
3 Conduct a blind search and select any group from the Search Results table 

to verify that it is displayed correctly.
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Workflow Administration Test
The purpose of this test is to make sure that the Agile WFA application is 
correctly functioning. 

To perform the WFA test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, click WFA (Workflow Administration).
3 Click New Process Template in the upper right corner.
4 In the resulting dialog box, select GSM and then click Done.
5 If the process template is displayed successfully, click Cancel and proceed to 

the next test.
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Manage Core Data Test
The purpose of this test is to verify that the Agile ADMN (Manage Core Data) 
application is correctly functioning. 

To perform the ADMN test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select ADMN > GSM Compliance > Additives.
3 If the additives currently in the system are displayed successfully, click 

Cancel and proceed to the next test.

Manage Data Caches Test
The purpose of this test is to verify that the Agile CACHE application is correctly 
functioning. 

To perform the CACHE test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, click CACHE (Manage Data Caches).
3 If the Schedule Cache Flush tool is displayed successfully, the test has 

succeeded.

You can now use the scheduled Cache Flush Queue feature to see details for the 
different applications that been flushed. For more information, refer to the 
“Using CACHE to Manage Caches” chapter of the Agile Product Lifecycle 
Management for Process Administrator User Guide.
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CHAPTER 2

Upgrading
This chapter discusses upgrading Agile Product Lifecycle Management for Process.
Topics in this chapter include:
❑ Upgrade Tasks
❑ Web Application Tasks
❑ Stopping Services and Backing Up Files
❑ Installing Software and Scripts
❑ Reconfiguring Settings
❑ Reconfiguring and Restarting Remote Container Service and Web Application Server
❑ Verifying the Installation

Upgrade Tasks
This chapter discusses the basic steps required to upgrade the Agile application 
suite to the 6.0.0.3.0 version. The main steps in the upgrade process include:

1 Check for Active Web Application Server Sessions on page 2-2
2 Stop the Web Application Server on page 2-3
3 Stop the Remote Container Service on page 2-3
4 Back Up the Previous Database Deployment on page 2-3
5 Installing Software and Scripts on page 2-4
6 Install the Agile 6.0.0.3.0 Upgrade Software on page 2-4
7 Update the Version Number in the version.txt File on page 2-6
8 Apply Database Upgrade Scripts on page 2-7
9 Configure the Environment Variables Settings on page 2-11

10 Reconfigure the Application Environment Settings on page 2-12
11 Reconfigure the Customer Settings on page 2-12
12 Apply extensions, if any
13 Reconfigure the Remote Container Service on page 2-14
14 Restart the Remote Container Service on page 2-14
15 Restart the Web Application Server on page 2-14
16 Verifying the Installation on page 2-14
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Web Application Tasks

Check for Active Web Application Server Sessions
Before bringing down the Web application server, perform two checks to make 
sure there are no active user sessions on the server. 

Note We recommend that you notify all users in advance that you are 
performing the upgrade, to give them time to shut down their connections.

Check the Performance System Monitor for Active Sessions
Using Performance System Monitor, check to see how many people currently 
have active sessions.

1 Select Start > Run.
2 In the Run dialog box, type perfmon and click OK to bring up the 

Performance dialog box.
3 Select the System Monitor option in the left pane to bring up the System 

Monitor dialog box.
4 In the bottom portion of the System Monitor dialog box, a list of counters is 

displayed. Right-click in this area and select Add Counters from the shortcut 
menu to display the Add Counters dialog box.

5 Select the Select Counters from Computer option and select your Web 
application server.

6 From the Performance Object drop-down list, select ASP.NET Apps 

v2.0.50727. 
7 Select the Select Counters From List option and from the associated scrolling 

list, choose Sessions Active, and then click Add.

8 Click Close to close the Add Counters dialog box.
9 Using the new active sessions counter, you can view the active sessions for 

the Web application server by selecting its row in the counter list at the 
bottom of the System Monitor dialog box. In particular, look at the number 
of active sessions in the Last field. If this number is greater than 2 active 
sessions, it is likely that users are logged on to the server. Contact the user(s) 
to have them log off before you shut down the Web application server.

10 You can save the active sessions counter by right-clicking it and selecting 
Save As from the shortcut menu. You may wish to save this counter to your 
desktop for future use.
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Check the Event Viewer for Last Login
Using IIS Computer Management, check the Event Viewer log for Agile to see 
when the last user login occurred.

1 Right-click My Computer and select Manage from the shortcut menu to 
display the Computer Management dialog box.

2 Under System Tools, select Event Viewer.
3 Locate and double-click the Portal-Prodika log under Event Viewer.
4 Review the log to see when the last user login occurred. If a recent login has 

occurred, it is likely that a user is still logged on to the server. Contact the 
user to have them log off before you shut down the Web application server.

Stop the Web Application Server
After you have verified that there are no active sessions on the Web application 
server, bring the server down as follows:

1 Open a command prompt.
2 Enter the following command to stop the Web application server:

C:\Documents and Settings\Administrator>iisreset /stop

Stopping Services and Backing Up Files

Stop the Remote Container Service
Using IIS Computer Management, stop the remote container service as follows:

1 Right-click My Computer and select Manage from the shortcut menu to 
display the Computer Management dialog box.

2 Under Services and Applications, select Service to display a list of services in 
the right pane.

3 Locate the RemoteContainer Service and click it.
4 Select the Stop the Service option in the top left-hand portion of the Services 

pane.

Back Up the Previous Database Deployment
Using SQL Server Enterprise Manager, back up the previous deployment of the 
database. Be sure to use a meaningful name for the backup for future reference; 
for example, Agile 5.2.1 - Full Backup.

Note The database server must be running in order to perform the backup.

1 Open SQL Server Management Studio.
2 In the left pane under Databases, locate the database instance to back up.
3 Right-click the database and select Tasks > Back Up... from the shortcut 

menu.
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4 Select the destination for your backup. Select the Add... button to the right 
of the Back up to: text area. A dialog box will appear in which you can choose 
where to store the backup file. After you have chosen a name, click the OK 
button.

5 Click the OK button at the bottom of the dialog and the backup process will 
begin.

Back Up the Previous Oracle Database Deployment
Recovery Manager (RMAN) is the recommended method of backing up your 
Oracle database and may be accessed via Enterprise Manager. 

Note We recommend you create a full backup of the whole database.

1 Open Enterprise Manager. 
2 Configure backup settings.

a Select Enterprise Manager > Availability > Backup Settings. 
b Set the disk backup location and backup type. Be sure to use a meaningful 

name for the backup for future reference.
3 Schedule the backup.  

a Select Enterprise Manager > Availability > Schedule Backup.  
b Select either the Oracle-Suggested Backup strategy or your own 

customized strategy. The Oracle-Suggested Backup strategy makes a one-
time whole-database backup. To use the Oracle strategy, for backup type, 
select Full Backup. For Schedule, select One Time (Immediately).

4 Review and submit the backup. The Review screen allows you to review your 
selections and submit the job. 

Installing Software and Scripts
Before logging into the application for the first time, be sure to install ASP.NET 
AJAX 1.0 as described in Setting Up ASP.net AJAX on page 1-21.

Install the Agile 6.0.0.3.0 Upgrade Software
The upgrade process is a manual process that uses batch files. The number of 
steps during the upgrade process is determined by the applications that you 
utilize within your installation.

For each installation, you will need to install the Core package first. This package 
needs to be installed only once per server instance.

After installing the Core package, depending on your installation, you will install 
one to four media packs. Each media pack is installed in the same manner 
outlined below.



Chapter 2 Upgrading

2-5

Set Up the Installation Environment

Note This step is common to all media pack installations.

Download the Media Pack installation file for the specific media pack being 
installed. Unzip the media pack zip archive to a temporary directory (i.e.; 
c:\INSTALL_HOME). Follow the directions detailed below for Core/Media Pack 
installation.

Upgrade the Software

Archiving the Previous Installation
The first step in the upgrade process is to manually archive the previous 
installation, as described below. 

1 Move (i.e.; cut) all of the directories other than attachments/XDocuments & 
logs directories to your designated archive location. We recommend that 
you name the containing directory as the version that you are upgrading 
from (i.e.; v5.1.2 - installation, etc.).

Installing the Core Bundle
2 The next step in the upgrade process is installing the Core bundle. 

Note This should be done only once per PRODIKA_HOME, meaning that if 
you have multiple installations of the Prodika suite of applications 
running on the same server, you will need to perform this step only 
once per Prodika installation.

Throughout the instructions below, the place where you extracted the media 
bundle zip file will be referred to as INSTALLER_HOME.

3 Open the containing directory for INSTALLER_HOME.
4 Extract Core.zip located in INSTALLER_HOME to a temporary directory 

(i.e.; c:\temp). This will give you a directory structure like c:\temp\Apps, 
c:\temp\Config, etc. - this temporary directory will be referred to as 
TEMP_HOME.

5 Copy FileCompressionHelper.exe from INSTALLER_HOME to 
TEMP_HOME.

6 Open a command prompt and navigate to TEMP_HOME (i.e.; >cd c:\temp)
7 Run the following (it is extremely important that you perform this 

decompression before moving on to install any additional media pack 
bundle files):
FileCompressionHelper.exe -d

8 When the distribution is complete, move the contents of TEMP_HOME to 
PRODIKA_HOME.
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Upgrade the Media Pack Applications
For each media bundle you will follow the same nine step process below. The one 
exception is with the NPD media bundle installation. With NPD, there is no need 
to perform step 6.

1 If there are any files remaining in your TEMP_HOME, remove them.
2 Unzip the media pack zip file located in your INSTALLER_HOME directly to 

TEMP_HOME.
3 Confirm media bundle names for the ZIP files, where the name can be one 

of :
• MP1.zip for the PDM install

• MP2.zip for the FC install

• MP3.zip for the PSC install

• MP4.zip for the NPD install 

• MP-ALL.zip which includes all of the media bundles in one zip file

4 Copy FileCompressionHelper.exe from INSTALLER_HOME to 
TEMP_HOME.

5 Open a command prompt and navigate to TEMP_HOME (i.e.; >cd c:\Temp).
6 Run the following (it is extremely important that you perform this 

decompression before moving on to install any additional media pack 
bundle files):
FileCompressionHelper.exe -d

7 When the distribution is complete, move the contents of TEMP_HOME to 
PRODIKA_HOME.

8 You will receive a warning that a Web & config directory already exist, accept 
this to move the contents into these directories.

9 Accept the warning to overwrite the configuration file 
PRODIKA_HOME\Config\Core\FeatureDeployment\<media pack>-

FeatureConfig.config.

Update the Version Number in the version.txt File

Modify the version.txt file as follows:
1 In your Prodika_Home directory, locate the version.txt file. 
2 Open the file with a text editor.
3 Change the first line so that it contains only the following text:

Version: v6.0.0.3.0

4 Click File > Save to save the your change.
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Apply Database Upgrade Scripts

Important It is very important that you back up the database as indicated in Back 
Up the Previous Database Deployment on page 2-3 before upgrading 
the database. Once the scripts have been applied, there is no way to 
revert the database to the previous state without a backup.

It is also important that you run the database upgrade scripts in 
version order (5.2.0, 5.2.1, 5.2.2, 6.0, 6.0.0.1.0, 6.0.0.2.0, 6.0.0.3.0) to 
bring the database up to the current software version.

Important Prior to running the 6.0.0 database upgrade using ApplyScripts and 
the duplicate ID procedures below, you must first identify and remove 
existing table indices and constraints that may interfere with the 
upgrade.

If you are upgrading from 5.2.1 to 6.0, you should download Hotfix 
5.2.1.75 from Orion Support.  BugDB #: 9360352 

If you are upgrading from 5.2.2 to 6.0, you should download Hotfix 
5.2.2.15 from Orion Support.  BugDB #: 9360364

Pre Database Upgrade Procedures

Prior to running the database upgrade using ApplyScripts, you must do the 
following:

1 Verify that there are no duplicate ID data entries in common tables.
a Run the SQL script titled 6.0.0.3 Pre Database Upgrade script - check for 

uniqueness.sql located in the Installer\Tools folder of the media bundle. 
This script will check various tables for duplicate PKID entries and raises 
an error for each table affected. Affected tables will have to be examined 
individually to determine the impact of the duplicate entries and what to 
do about them. 
• For duplicates whose complete row (all columns) is a duplicate of 

another one, the duplicate entry should simply be removed. This is the 
most common scenario.

• When the duplicate entries are not complete duplicates, determining 
the impact may require more detailed analysis and assistance.
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2 Verify there are no duplicate label claims.
a Search the gsmLabelClaim table for entries that have the same Name and 

langID. 
b Make any duplicates unique by modifying their Name. For example, if 

there are two entries for “Low Fat” with a langID = 0, modify one of them 
to be “Low Fat - Archived”. 

The following SQL query will return duplicate label claims: 

SELECT * FROM gsmLabelClaim a INNER JOIN gsmLabelClaim 
b ON a.Name = b.Name AND a.langID = b.langID WHERE 
a.pkid <> b.pkid

Run Database Upgrade Script

To run the database upgrade script:
1 Open a command prompt and navigate to the directory where you unzipped 

the upgrade package.
2 Change directories (cd) to the Installer/ApplyScripts directory.
3 Apply the scripts using the following call to the ApplyScripts.exe utility:

• If running the SQL Server database upgrade:

ApplyScripts -c "server=<database_server>;uid=<user>;
password=<password>;database=<database>" -f <upgrade 
script file>

The upgrade script files are:

v6.0.0.xml—Upgrade from v5.2.2 to v6.0

v6.0.0.1.xml—Upgrade from v6.0 to v6.0.0.1.0

6.0.0.2.0.xml—Upgrade from v6.0.0.1.0 to v6.0.0.2.0

v6.0.0.3_MAINT.xml—Upgrade from v6.0.0.2.0 to v6.0.0.3.0

• If running the Oracle database upgrade:

ApplyScripts -c "server=<database_server>;uid=<user>;
password=<password>;database=<database>"-
dbvendor="orcl" -f <upgrade script file>

The upgrade script files are:

v6.0.0-orcl.xml—Upgrade from v5.2 to v6.0.

v6.0.0.1-orcl.xml—Upgrade from v6.0 to v6.0.0.1.0

6.0.0.2.0-orcl.xml—Upgrade from v6.0.0.1.0 to v6.0.0.2.0

v6.0.0.3_MAINT-orcl.xml—Upgrade from v6.0.0.2.0 to v6.0.0.3.0

4 After each ApplyScripts call, you can confirm that the database upgrade 
scripts have been applied successfully when the system prompts you with the 
following message:
“Complete - with no errors”

Note There may be multiple xml files that need to be applied. Please apply them 
in version order (6.0, 6.0.0.1.0, 6.0.0.2.0, 6.0.0.3.0).
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Applying Patches for the Database Upgrade
If you are already on version 6.0, 6.0.0.1.0 or 6.0.0.2.0, be sure to apply the scripts 
higher than the current version.

Applying Language Packs 
For instructions on installing language packs, see Installing Language Support for 
Simplified Chinese, Traditional Chinese, or Korean on page 1-23. 
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Reconfiguring Settings

Update the IIS Virtual Directories
Follow the steps outlined in Configuring IIS Application Pool Settings on page 1-
11. Add the following virtual directories to IIS: opt, gsmview, and 
GSMExtensions. The purpose of these folders is as follows:

• opt—An application to handle optimization processing for GSM.

• gsmview—A read-only view of GSM for Formulation Specification 
snapshots.

• GSMExtensions—An additional library containing Formulation 
resources.

1 At the website root, create virtual directories for opt and gsmview.  Opt 
points to web\opt; gsmview points to web\gsm.  
a For gsmview and opt, create the webcommon, images, and css sub 

virtual directories.  
2 Under gsm, create a virtual directory called gsmextensions.  

Gsmextensions maps to web\gsmextensions. 
3 Click the Remove button for “css”, “images”, and “WebCommon” virtual 

folders.

Figure 2-1: Remove button

4 Manually remove the dwb virtual directory from IIS.
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Configure the Environment Variables Settings
Using a text-based editor, open the environmentvariables.config file and update 
the server names and port addresses.

Note For further guidance, please refer to the “Environment Variable Settings” 
section of the Agile Product Lifecycle Management for Process Configuration 
Guide.
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Reconfigure the Application Environment Settings
Using a third party diff tool, you will need to reconfigure the 
environmentSettings.config file located in your Prodika_Home\Config\ 
directory.

To reconfigure application environment settings:
1 Rename the new environmentSettings.config file; change the name to 

environmentSettings.config-new.
2 Make a backup copy of the archived version of the 

environmentSettings.config file (from the archived directory) and 
copy it into the Prodika_Home\Config\Custom\ directory.

3 Using the diff tool, compare the environmentSettings.config-new file 
to the archived copy of the environmentSettings.config file.

4 Update the environmentSettings.config-new file as follows:
a Under ConnectionPools, change the CONNECT_STRING path values to 

the following:

server = your database server

database = your database name

Uid = your database user ID

Pwd = your database password

b Under Prodika > Services, make sure that the port numbers are correctly 
set up for your Agile services.

c Change %PRODIKA_HOME% values to the correct Prodika_Home value 
(c:\Prodika_Home\).

d Carefully merge any other configuration differences for your particular 
customer needs.

5 When you have completed the file comparison and updates, delete the copy 
that you made of the archived environmentSettings.config file.

6 Rename the environmentSettings.config-new file; change the name 
back to environmentSettings.config.

Reconfigure the Customer Settings
Using a diff tool such as WinMerge, you will need to reconfigure the 
CustomerSettings.config file located in your Prodika_Home\Custom\ 
directory.

To reconfigure customer settings:
1 Rename the new CustomerSettings.config file; change the name to 

CustomerSettings.config-new.
2 Make a backup copy of the archived version of the 

CustomerSettings.config file (from the archived directory) and copy it 
into the Prodika_Home\Config\Custom\ directory.

3 Using the diff tool, compare the CustomerSettings.config-new file to 
the archived copy of the CustomerSettings.config file.

4 Carefully merge any configuration differences for your particular customer 
needs.
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5 When you have completed the file comparison and updates, delete the copy 
that you made of the archived CustomerSettings.config file.

6 Rename the CustomerSettings.config-new file back to 
CustomerSettings.config.

Configure the New CustomWFAExtensionsConfig.xml Configuration File
WFA now allows the assignment of workflow actions and guard conditions to a 
workflow transition through the user interface (Previously, this was done via 
database scripts only).

If you have added any workflow actions or guard conditions to WFA using 
database scripts, you may need to add those entries to the new 
CustomWFAExtensionsConfig.xml file in the \config\extensions folder. Doing 
so will allow those workflow actions and guard conditions to be selectable from 
a pop-up in the Transitions table in WFA. 

Note WFA gives the ability to assign these to the transition only, not to the 
activity, so if you are configuring workflow actions and guard conditions 
on activities (not transitions) you will still need to do so using SQL scripts.

Look at the fkOwner column values in the following tables:

❑ For gsmWorkflowActionTemplates and gsmWFGaurdConditionTemplates: 

• If fkOwner starts with 5758 = workflow action is on the activity template 
(gsmWorkflowActivityTemplates)

• If fkOwner starts with 5757 = guard condition is on the transition 
template (gsmWorkflowTransitionTemplates)

❑ For cssWorkflowActionTemplates and cssWFGuardConditionTemplates:

• If fkOwner starts with 3165 = workflow action is on the activity template 
(cssWorkflowActivityTemplates)

• If fkOwner starts with 3166 = guard condition is on the transition 
template (cssWorkflowTransitionTemplates)

Also, note that the tables cssWFGuardConditionTemplates and 
gsmWFGaurdConditionTemplates now have a new Name column. You must 
update its value to match a user friendly name for the guard condition that needs 
to then be added to the new CustomWFAExtensionsConfig.xml configuration 
file. Look at the xml file for examples.
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Reconfiguring and Restarting Remote Container Service 
and Web Application Server

Reconfigure the Remote Container Service
As of version 6.0, it is not necessary to reconfigure the Remote Container service.

Restart the Remote Container Service

Using IIS Computer Management, restart the remote container service:
1 Right-click My Computer and select Manage from the shortcut menu to 

display the Computer Management dialog box.
2 Under Services and Applications, select Service to display a list of services in 

the right pane.
3 Locate the RemoteContainer Service and click it.
4 Select the Start the Service option in the top left portion of the Services pane. 

Restart the Web Application Server

Using a command prompt, restart the IIS Web application server:
1 Open a command prompt.
2 Enter the following command:

C:\Documents and Settings\Administrator>iisreset

The Web application server restarts.

Verifying the Installation
Log in to the Agile user portal and verify that the installation is functioning 
correctly. We recommend that you perform a variety of post-installation tests to 
ensure that all the applications are functioning correctly. For more information, 
see Installation Verification Tests on page 1-40.
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CHAPTER 3

Working with Multiple Servers
This chapter provides guidance for working with multiple servers.
Topics in this chapter include:
❑ Architecture Environment Strategy
❑ Topology Example of Production Environment
❑ Multiple Server Configuration

Architecture Environment Strategy
A good environment strategy supports the following project/business needs:

❑ Support the application upgrade process.

❑ Provide a structured process for migration (development, test, user 
acceptance) of bug fixes, new features, functionality, and configurations.  
Specifically focusing on allowing reasonable access to environments during 
migration.

❑ Provide a means for preparing/staging data for transfer into a production 
environment.

Figure 3-1 below shows a sample environment.
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Figure 3-1: Sample architecture

Verifying Environment Strategy
Use the following questions to help verify your environment strategy:

• What is the path for upgrading the application from version x to version 
y?

• What is the process for testing production issues?  Which environments 
will be available for testing: Development, QA/UAT, and/or Production?

• Where will end users be trained on the application?

• Where will extensible solutions be developed?

• Where will hot fixes be initially applied?  What is the path for migrating 
hot fixes to production?

• Where will data loading be tested/verified?

• How will multiple tasks be supported?

Also consider the following:

• Migrating from version x to version y and configuring the application to 
support new functionality.

• Testing new functionality and supporting production configurations and 
hot fixes. 

• If the implementation is split into multiple projects, how will different 
project teams share environments?
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Development
The development environment typically is used as a place to: 

❑ Deploy new releases (first place)

❑ Develop extensible solutions 
❑ Use for initial test and troubleshooting
❑ Use for prototyping and discovery
❑ Make configuration changes, which are then applied in QA

Quality Assurance/User Acceptance Testing
The Quality Assurance (QA)/User Acceptance Testing (UAT) environment 
typically is deployed to closely match the Production environment, and is used as 
a place to:

❑ Include load balancers, etc.

❑ Formally test configuration changes
❑ Perform periodic refreshes from the Production environment
❑ Consider data security/access
❑ Perform training tasks

Production/Export
The Production/Export environment typically is used as a place to:

❑ Perform data/user/workflow administrative tasks

❑ Act as the data staging/acceptance environment
❑ Complete administrative data changes , then export the changes to other 

environments

Note The Production/Import environment must be on same version as import 
environments

Production/Import
The Production/Import environment typically is used as a place where:

❑ The user community interacts with data on a day to day basis.

❑ Administrative data changes are pushed from the export environment to the 
import environment

❑ Configuration changes are pushed from QA
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Export/Import
If an environment has applications servers to support the export and import 
structure, then note the following:

The general business process:

• Admin creates records via the export application.

• Admin exports records via the export application.

• Admin imports record via the import application. 

Applications that support the export/import process:

• User Group Manager (UGM)—Users and groups are exported and 
imported

• Workflow  Administration (WFA)—Workflows are exported and 
imported

• Data Admin (ADMN)—Allergens, additives, extended attributes, and 
other administrative data are exported and imported

When managing the Export/Import structure the databases must be kept 
synchronized. If changes are made directly in the import application 
environment, and the exact changes (including primary keys) are not applied to 
the production environment as well, the Export/Import relationship is broken.  

To reestablish the Export/Import relationship the following steps must be 
performed:

1 Copy or backup the import database.
2 Restore the import database to the export database.

The relationship is now restored. Make changes to data via the export application 
and import via the import application.

Imports and Exports are only possible if both environments use the same version.

Example 1—Export v5.2 can push to Import v5.2

Example 2—Export v5.2 cannot push to Import v5.1.2

These examples demonstrate that users, workflows and administrative data 
cannot be updated or moved when application versions are different.
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Topology Example of Production Environment
Figure 3-2 depicts the hardware/software topology options for a production 
environment.

Figure 3-2: Topology example, Production environment
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Topology Example A
Example A, show in figure 3-4 below, highlights:

• Database clustering

• Load balancing

• Separate and centralized file server

Figure 3-3: Topology Example A
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Topology Example B
Topology B example, shown in figure 3-4 below, highlights: 

• Standard database

• Logically distributed applications

• Centralized file server shared with application server

Figure 3-4: Topology example B

Multiple Server Configuration
Following are the settings for configuring an environment with multiple servers 
running different application modules. Currently, two scenarios are provided.  
This includes one for multiple servers with NO reverse proxy, and one for 
multiple servers with a reverse proxy.
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Files Modified
❑ %PRODIKA_HOME%\Config\EnvironmentVariables.config

❑ %PRODIKA_HOME%\Config\Custom\EnvironmentSettings.config

Scenario 1
Customer does not have or has chosen not to use a reverse proxy or a hardware 
load balancer.  Application URLs should be configured in 
EnvironmentVariables.config as Client-Server, meaning it is the URL the 
client will see and use in Internet Explorer.  Web Service URLs should be 
configured in EnvironmentVariables.config as Server-Server, meaning the 
web service call will NOT be passed to the client. 

Note Main application URL is https://plm.xenodev.com

SSL Configuration (Optional)
An SSL certificate will need to be purchased and installed on each application 
server, corresponding to the friendly URL provided.

App Configuration
The following is an example, only. There are additional application URLs that are 
not listed below.

1 Open the %PRODIKA_HOME%\Config\EnvironmentVariables.config 
file:
# Server Topology Information

Prodika.Server1.URL = https://plm.xenodev.com

Prodika.Server2.URL=https://plmapp2.xenodev.com

Prodika.Server3.URL=https://plmapp3.xenodev.com

Prodika.SCHEME =https

# Application URL Information

Prodika.GSM.URL=@@VAR:Prodika.Server1.URL@@/gsm

Prodika.GSMInterApp.URL=@@VAR:Prodika.Server1.URL@@/gsm

Prodika.SCRM.URL=@@VAR:Prodika.Server1.URL@@/scrm

Prodika.NPD.URL=@@VAR:Prodika.Server2.URL@@/npd

Prodika.Portal.URL=@@VAR:Prodika.Server1.URL@@/portal

# DRL Attachment is used for file upload by the WebApp and 
WebService

Table 3-1: Scenario 1 

Server Name Friendly URL App Modules

AppServer001 plm.xenodev.com GSM, SCRM, Portal

AppServer002 plmapp2.xenodev.com NPD, DRL

AppServer003 plmapp3.xenodev.com WFA, UGM
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Prodika.DRLService.URL=@@VAR:Prodika.Server2.URL@@/drl 

(see note)

Prodika.DRLAttachment.URL=@@VAR:Prodika.Server2.URL@@/drl 

Prodika.DRL.URL=@@VAR:Prodika.Server2.URL@@/drl

Prodika.WFA.URL=@@VAR:Prodika.Server3.URL@@/wfa

Prodika.UGM.URL=@@VAR:Prodika.Server3.URL@@/ugm

Note DRLService.URL is only available if hot fix 5.2.1.27 is installed and 
configured.

2 Open the 
%PRODIKA_HOME%\Config\Custom\EnvironmentSettings.config 

file:

Search and replace the following keys:

• "<add key="ActionMenuImageOnClickJScript" 

value="javascript:window.location.href='https://

plm.xenodev.com/portal';return false;" />

• "<Item id="navlogo" prepend="&lt;div align=center&gt;" 

append="&lt;/div&gt;" cssClass="None" labelID="Image" 

href="&lt;img src='../images/navlogo.gif' /&gt;" 

onClick="javascript:openSiteHome('https://

plm.xenodev.com/portal');return false;" />

• "<config key="HomeURL" value="https://plm.xenodev.com/

portal" />

• "<config key="SiteMapURL" value="https://

plm.xenodev.com/portal" />

Result
The application suite is separated on multiple servers. GSM and Portal run on 
AppServer001, NPD runs on AppServer002, etc.  The user will see the 
corresponding URL based on the app that is opened.  For example, when the user 
opens GSM, the user will see https://plm.xenodev.com/GSM as the URL in their 
browser.  Subsequently, when the user opens NPD, the user will see https://

plmapp2.xenodev.com/NPD as the URL in their browser.  No matter what 
application is opened, the user will always see https://plm.xenodev.com as the URL 
in their browser.  Web Service calls, as such for GSMInterApp and DRL, will be 
passed internally, from server to server.
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Scenario 2
Customer has chosen to use a reverse proxy or hardware load balancer.  
Application URLs should be configured in EnvironmentVariables.config as 
Client-Server, meaning it is the URL the client will see and use in Internet 
Explorer.  Web Service URLs should be configured in 
EnvironmentVariables.config as Server-Server, meaning the web service 
call will NOT be passed to the client. 

Note Main application URL is https://plm.xenodev.com

SSL Configuration (Optional)
A single SSL certificate will need to be purchased and installed on the reverse 
proxy or load balancer, corresponding to the main application URL.

App Configuration
The following is an example, only. There are additional application URLs that are 
not listed below.

1 Open the %PRODIKA_HOME%\Config\EnvironmentVariables.config 
file:
# Server Topology Information

Prodika.Server1.URL = https://plm.xenodev.com

Prodika.Server2.URL=http://plmapp1.xenodev.com

Prodika.SCHEME =https

# Application URL Information

Prodika.GSM.URL=@@VAR:Prodika.Server1.URL@@/gsm

Prodika.GSMInterApp.URL=@@VAR:Prodika.Server2.URL@@/gsm

Prodika.SCRM.URL=@@VAR:Prodika.Server1.URL@@/scrm

Prodika.NPD.URL=@@VAR:Prodika.Server1.URL@@/npd

Prodika.Portal.URL=@@VAR:Prodika.Server1.URL@@/portal

# DRL Attachment is used for file upload by the WebApp and 
WebService

Prodika.DRLService.URL=@@VAR:Prodika.Server2.URL@@/drl 

(see note)

Prodika.DRLAttachment.URL=@@VAR:Prodika.Server1.URL@@/drl 

Prodika.DRL.URL=@@VAR:Prodika.Server1.URL@@/drl

Prodika.WFA.URL=@@VAR:Prodika.Server1.URL@@/wfa

Table 3-2: Scenario 2 

Server Name Friendly URL App Modules

RPServer001 plm.xenodev.com n/a

AppServer001 plmapp1.xenodev.com GSM, SCRM, Portal

AppServer002 plmapp2.xenodev.com NPD, DRL

AppServer003 plmapp3.xenodev.com WFA, UGM
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Prodika.UGM.URL=@@VAR:Prodika.Server1.URL@@/ugm

Note DRLService.URL is only available if hot fix 5.2.1.27 is installed and 
configured.

2 Open the 
%PRODIKA_HOME%\Config\Custom\EnvironmentSettings.config 
file:
Search and replace the following keys:

• <add key="ActionMenuImageOnClickJScript" 
value="javascript:window.location.href='https://plm.xenodev.com/
portal';return false;" />

• <Item id="navlogo" prepend="&lt;div align=center&gt;" append="&lt;/
div&gt;" cssClass="None" labelID="Image" href="&lt;img src='../
images/navlogo.gif' /&gt;" onClick="javascript:openSiteHome('https://
plm.xenodev.com/portal');return false;" />

• <config key="HomeURL" value="https://plm.xenodev.com/portal" />

• <config key="SiteMapURL" value="https://plm.xenodev.com/portal" />

Result
The application suite is separated on multiple servers. GSM and Portal run on 
AppServer001, NPD runs on AppServer002, etc.  No matter what application is 
opened, the user will always see https://plm.xenodev.com/<module> as the URL in 
their browser.  Web Service calls, as such for GSMInterApp and DRL, will be 
passed internally, from server to server.
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APPENDIX A
Installing WebDAV

This appendix contains instructions for installing and configuring WebDAV.

Enabling WebDAV
To make sure that Web Sharing is enabled in IIS:

1 Open the IIS Manager, and then select Web Service Extensions. 
2 Enable WebDAV if it is not already set to “Allowed,” as figure A-1 shows 

below:

Figure A-1: Enabling WebDAV
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Creating the Directory Structure
To configuring WebDAV:

1 Create the directory structure as follows:
    WebDAV\

    WebDAV\PDFComments

    WebDAV\NPDWorkArea

Figure A-2: Directory Structure

Sharing the WebDAV Directory

To share the WebDAV directory:
1 Right click on the WebDAV Directory and select Properties.
2 Select the Web Sharing tab.
3 Share the folder as WebDAV.
4 Click Edit Properties.
5 Check Read, Write and allow Scripts, as figure A-3 shows below.

Figure A-3: Properties 
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Editing Folder Permissions

To edit folder permissions:
1 Click on the Security tab.
2 Give the user that the Application Pool runs as full control, and apply to all 

sub directories, as figure A-4 shows below.

Figure A-4: Properties



Agile Product Lifecycle Management for Process

A-4  Install/Upgrade Guide

Verifying the IIS Directory Security is Configured Correctly
To verify IIS directory security:

1 Locate the WebDAV virtual directory, then right click and select Properties.
2 Verify that the directory has Write permission, as figure A-5 shows below.

Figure A-5: Virtual Directory

3 Click the Directory Security tab. 
4 Select Edit under Authentication and access control.
5 Verify that Anonymous access is enabled, as shown in figure A-6 below.
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Figure A-6: Authentication
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Configuring the Application
To configure WebDAV for a single server setup: 

1 Edit Environment Settings under 
<prodikahome>\config\EnvironmentSettings.config

2 Map the following settings in the config to the appropriate directories/
URLS. To test, you can enable directory browsing on the web dav virtual 
directory.
• <config key=“PDFWorkArea” value=“https://demo.prodika.com/

WebDAV/npdworkarea/”; />

• <config key=“PDFWorkAreaUNC” 
value=“C:\WebDAV\NPDWorkArea\” />

• <config key=“PDFCommentRepository” value=“https://
demo.prodika.com/WebDAV/PDFComments”; />

• <config key=“PDFCommentRepositoryUNC” 
value=“C:\WebDAV\PDFComments\” /> 

• <config key=“OfficeDocWorkArea” value=“https://demo.prodika.com/
WebDAV/npdworkarea/”; />

• <config key=“OfficeDocWorkAreaUNC” 
value=“C:\WebDAV\NPDWorkArea\” /> 

To configure WebDAV for a multiple server setup:
1 Share the web dav directory as webdav on server A resulting in \\<server 

a>\webdav

2 Set appropriate share and security permissions as follows:

The user running app pool on server B must have RW share and security 
access to \\<server A>\webdav.

3 Use \\<hostname>\webdav\pdfcomments\ and \\<server 
A>\webdav\npdworkarea for UNC paths in config on server B. 
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APPENDIX B
Troubleshooting

This appendix contains a list common issues that may occur after installation.

Troubleshooting Tips
The following list details common issues and suggestions for solving them. 

1 How can I compare my recent build with an older build to see if 
configuration values have changed?

Tip: Use the Config Rollup URL to check the rolled up configuration 
settings for various applications. The URL is:

http://<serverName>/<appName>/WebCommon/AdminForms/

ConfigRollup.aspx

2 Clicking upload when adding a DRL attachment causes the window to 
simply blink.

Tip: Ensure you’ve waited at least 30 seconds on the first attempt. 

Tip: Ensure the machine.config for your .NET version has the machine key 
entry. 

3 Message displayed is “trust relationship could not be established”.

Tip: Verify that the Web site your using has a signed certificate. 

Tip: If not testing SSL DRL attachments, configure them to use HTTP and 
ensure the “Prodika.GSMInterApp.URL” property is using HTTP. 

4 Message displayed is “The remote certificate is invalid according to the 
validation procedure.”

Tip: Ensure the credentials in the “EnvironmentVariables.config” file are 
correct for the “Prodika.DRLService.SysUser” user. 
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5 NPD edit-in-place documents are read-only.

Tip: The user connecting to the IIS share does not have permissions to the 
underlying folder on the server.  Grant full permissions by assigning the 
‘Everyone’ permission setting on that folder. If that solves the problem, lock 
down the folder with tighter permissions.

6 The Browser keeps redirecting to incorrect URLs or keeps jumping from 
HTTPS to HTTP.

Tip: Make sure that the environmentvariables.config file has the right URLs. 

Tip: You can only have one HTTPS site on one machine. If you have more 
than one, it bounces back and forth between the two sites 

Tip: Make sure that you are not using HTTPS in the URL to access a http 
Web site. Using https in your URL will make the Server redirect your request 
to the default https Web site. 

Tip: Conversely, if the environmentvariables.config file is using https to 
access a http Web site, you would be redirected to the default https Web site 
incorrectly 

7 Navigation to any page in the application results in a blank page after 
migrating to another version or a new version of .NET is installed.

Tip: The wrong ASP.NET version may be registered with IIS.  Run the 
“aspnet_regiis.exe” utility with the “-r” flag.

8 The rich text dialog box is prompting me with security issues concerning 
scripts.

Tip: Ensure the page event and request validation are turned off .

9 What is drl.prodika.com? 

Tip: Make sure that you have the new URLs and https:.

10 I am prompted to login to every application.

Tip: Is the remoting container running? 

Tip: Ensure you are using the trust bridge in “EnvironmentSettings.config”.


