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Preface

Oracle's Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle Technology
Network (OTN) Web site http://www.oracle.com/technetwork/documentation/agile-085940.html
contains the latest versions of the Agile PLM PDF files. You can view or download these manuals
from the Web site, or you can ask your Agile administrator if there is an Agile PLM Documentation
folder available on your network from which you can access the Agile PLM documentation (PDF)
files.

Note To read the PDF files, you must use the free Adobe Acrobat Reader version 9.0 or later.
This program can be downloaded from the Adobe Web site http://www.adobe.com.

The Oracle Technology Network (OTN) Web site
http://www.oracle.com/technetwork/documentation/agile-085940.html can be accessed through Help
> Manuals in both Agile Web Client and Agile Java Client. If you need additional assistance or
information, please contact My Oracle Support (https://support.oracle.com) for assistance.

Note Before calling Oracle Support about a problem with an Agile PLM manual, please have
the full part number, which is located on the title page.

TTY Access to Oracle Support Services

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398.
Outside the United States, call +1.407.458.2479.

Readme

Any last-minute information about Agile PLM can be found in the Readme file on the Oracle
Technology Network (OTN) Web site http://www.oracle.com/technetwork/documentation/agile-
085940.html.

Agile Training Aids

Go to the Oracle University Web page
http://www.oracle.com/education/chooser/selectcountry _new.html for more information on Agile
Training offerings.
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Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an otherwise empty line;
however, some screen readers may not always read a line of text that consists solely of a bracket or
brace.

This documentation may contain links to Web sites of other companies or organizations that Oracle
does not own or control. Oracle neither evaluates nor makes any representations regarding the
accessibility of these Web sites.
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New in Release 9.3.1.1

There are no new features or enhancements to existing features in this release of the Agile PLM
Document Publishing Solution. There are minor formatting modifications in this document.
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Chapter 1
About this Whitepaper

This chapter includes the following:

Content and OFGANIZALION. .........veuevrreierieeirieeess e se s s e ee e s es s s s s s s en e nesnnnes 1
Intended Audience
CItBA REEBIENCES ...ttt bbb bbb bbb bbbttt bbb bbb s e n bt es

SDK Samples Folder and Document Publishing EXaMPIES ... 2

Note This document is a supplement to the release Readme and other Agile manuals, for

example, the Capacity Planning Guide, PLM Administrator Guide, or the SDK Developer
Guide. The purpose of this document is to introduce Dynamic Document Publishing and
is not intended as a User or Developer Guide, and will be augmented with these
documents in the future.

Content and Organization

Information provided in this document is organized in the following parts:

m]

Dynamic Document Publishing Overview — This section describes the solution, the required
environment, and applicable processes.

Configuring the PLM Client and PLM Server — This section provides information to configure the
PLM client and PLM server and develop the Event Management process extensions (PXs) that
enable the Dynamic Document Generation capability.

Setting up BI Publisher and Bl Publisher Plugins — This section provides information on installing and
setting up the BI Publisher and ancillary tools to define templates and publish reports.

Generating sample reports — This section provides several examples that vary the Event Trigger
and objects to publish document using Agile PLM data. Information to configure Agile PLM for
specific reports and generating and storing Templates are also included.

Intended Audience

The primary users of the Dynamic Document Publishing solution are document authors who will use
its features to prepare and maintain documents with embedded PLM data, for example, product
data sheets, parts lists, or service manuals. In this process, they are supported by Agile PLM
administrators and, where applicable, SDK developers who create and manage the necessary
templates and Event subscriptions that automate document updating and generation.
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Cited References

The following Oracle Agile PLM and BI Publisher publications provide useful information to install
and configure the Dynamic Document Publishing components and generate the sample reports.

Oracle Agile PLM

= Agile PLM Readme

o Agile PLM SDK Developer Guide

o Agile PLM AIS Developer Guide

o Installing Agile PLM for WebLogic Server/Installing Agile PLM for Oracle Application Server
= Agile PLM Administrator Guide

o Agile PLM Web Services User Guide

These Oracle Agile PLM documents are available at Oracle Technology Network (OTN) Web site:
http://www.oracle.com/technetwork/documentation/agile-085940.html

Oracle Bl Publisher
o Qracle Bl Publisher 10g

Oracle Bl Publisher 10g documents are available at:
http://www.oracle.com/technetwork/middleware/bi-publisher/documentation/xmlpdocs-084437.html.

SDK Samples Folder and Document Publishing
Examples

Oracle provides Document Publishing configuration examples for PLM server and PLM
Administrator. Server examples include PXs and related Java and properties files. Client
configurations are included in a recording created by WebEx Recorder in .WRF format.

You can find these files in the Doc-Publishing folder, in SDK_samples.zip. The SDK_samples.zip
folder which also contains the APl HTML reference files and Sample applications, is maintained on
the Oracle Agile PLM 9.3.1 Event and Web Services Samples Web site at
https://codesamples.samplecode.oracle.com/servlets/tracking/id/S614. For more information and
procedures to access its contents, contact your system administrator, or refer to your Agile PLM
Installation Guide.
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Chapter 2
Dynamic Document Publishing

This chapter includes the following:

S O 1V Y. 1 T 3

B SOIULION AFCNITECIUIE ... .viveeee sttt sttt ettt e sttt st s e et et e b e se st st st e s e saese st et e e st e st st e s s st abe st et s se et e st sbe e sbens 4

B OPErating ENVIFONMENT.......oeviieieiricietsie sttt as ettt 4

T (0 Tor T O 11111 TSR 6
Overview

During the life of a product, Agile PLM acquires, processes, and maintains a wide range of data
related to the product. This data is used in many ways and for different requirements to expedite,
manage, and control product development activities. Dynamic Publishing of product information
enables publication of documents such as product data sheets, Parts List, or service manuals with
embedded PLM data.

To support this solution, Agile PLM 9.3.1 provides two new Web services APIs for XML publishing
(see Oracle Agile PLM on page 5). These APIs return an XML package with the object's schema
and another with the actual data.

These XML packages are used with a publishing tool such as Oracle's Bl Publisher to generate any
type of document based on Agile PLM metadata.

The Dynamic Document Publishing of product information can be used by Industrial, Retail, Life
Sciences, Pharmaceutical, and High Tech industries to:

o Create new structured document templates (Product Data sheets, Parts List, Service Manual)

@ Create documents in the native document publishing tool such as MS Word or Adobe
Framemaker

o Browse and insert PLM metadata and file contents into documents

o Create formatted reports from PLM objects, search results, and push selected rows to reporting
tools (compliance report, pricing model, quality report)

o Push a selected object ID, or all search results to a report for formatting
= Modify the content that is shared by other documents already stored in PLM

= Update documents that reference content that was modified
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Agile PLM Do

Solution Architecture

While the flexible architecture can support any authoring tool, for example, Adobe Framemaker, this
illustration summarizes the document and template formatting tasks by integrating Oracle Agile
PLM and BI Publisher. Bl Publisher is a reporting and document management solution. Bl Publisher
report formats are designed with MS Word and published in PDF, HTML, RTF, and Excel formats.
The flow of data from Agile PLM, output formats, and potential destinations are summarized in the

following illustration.
Figure 1: Document Publishing architecture

.:fi)

Email

Agile PLM

=" |
=
Agile PLM
SDK

LT
Printer

=

Bl Publisher ‘_E____. &

e Fax
E R‘x‘ \‘ ' o
E.lr‘i Templates ===
[Epe— Repository
Agile PLM o5
Web Services - % ’
e-Commerce
Data Source Layout Tool Output Destinations

Operating Environment

Oracle's Dynamic Document Publishing is the integration of Oracle Bl

Publisher and Oracle Agile

PLM. PLM is Oracle's product lifecycle management solution and Bl Publisher is a reporting and

document output management solution from Oracle.

The operating environment includes:

u]

Oracle Agile PLM
Oracle Bl Publisher

u]

u]

Microsoft Word
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Oracle Agile PLM

Oracle Agile PLM components are:

o Agile PLM Release 9.3.1.1 (Server and databases)

o Agile PLM Release 9.3.1.1 File Manager

o Agile PLM Release 9.3.1.1 SDK (Template Management Java and Script PXs)

o Agile PLM Release 9.3.1.1 Web Services APIs — The following APIs support Dynamic
Document Generation:

* loadXMLSchema — This Web Service API returns an XML package that fully describes the
attributes of the object. This Web Service is used to create XML schema files that are
used by Bl Publisher to create the Templates. For example, if you use this Web Service
against a subclass like ECO, it will tell Bl Publisher all of the possible attributes for ECOs.
This is useful to be able to work with all potential attributes for an object when creating a
Template.

e loadXMLData — This Web Service API returns the actual data that is stored for an object
in an XML package. This Web service is used to retrieve the object data that is combined
with the Template to create the output file. You can also use the saved output from this
Web Service to test a Template in Bl Publisher.

Note For information on these APIs, refer to Agile PLM WebServices User Guide.

Oracle Bl Publisher

Bl Publisher products and MS Word 2003/2007 serve as template builders. Bl Publisher Enterprise
is the document generation engine. Bl Publisher report formats are designed with Microsoft Word
and support creating reports from multiple data sources.

= Bl Publisher Desktop - This is a prerequisite to implement Dynamic Document Publishing

o Bl Publisher Enterprise (Bl Publisher v10gR3 - The PLM Embedded version or a separate
server version)

Note A license is necessary for Oracle Bl Publisher. Bl Publisher Enterprise is required if there
is a need to publish from multiple versus a single source of data. For a list of Agile PLM
and Bl Publisher components that you must install and configure to enable Dynamic
Document Publishing, see Installing and Configuring Bl Publisher and Word Plugins.

Microsoft Word 2003/2007 and Bl Publisher

Microsoft (MS) Word 2003/2007 is fully integrated with Bl Publisher and serves as the Document
Template Authoring tool.

v9.3.1.1 5
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Process Qutline

The following illustration is a streamlined view of the Document Publishing process. That is, a
"trigger" invokes a "handler" and then steps #1, 2, 3, and 4 happen automatically.

Figure 2: Dynamic Document Publishing Process and Steps

Event Trigger

'

Event Handler for Document Generation PX

m
1. Collect Object ORAC_'-E
ORACLE AL Bl Publisher
Agile PLM 3. Combine XML and 4. Attact
> Template to Create —_— - ac_.'
Outpurt File Output File

2. Collect
Publishing

— e
—
Template
Files

The process is triggered by various Event subscriptions that are constructed in Agile PLM's Event
Management framework. A user with Administrator privileges configures the Event subscriptions,
which are detailed further on in this document. Typical Event Triggers include Release an ECO,
Update Title Block for an Item, or any other user action that can generate a document in Agile PLM.

The Event subscription is used to call the Event Handler that performs the following sequence of
tasks:

1. Collect Object XML — Object XML is dynamically retrieved from the object that is being processed

2. Collect Publishing Template — Template is a predefined Bl Publisher RTF file stored in Agile PLM.
The PX checks a field in the Object to determine which attachment in Agile PLM contains the
Bl Publisher Template

3. Combine XML and Template in Bl Publisher to create output file — The sample PX passes the XML
package and Template to the Bl Publisher program running with Agile PLM which generates an
output file and informs the PX of the file location

4. Attach output file — The sample PX uses Agile PLM SDK commands to attach the file to an Agile
PLM business object

This process is illustrated with the aid of the following example, which updates a Datasheet with
PLM data.

6 Agile Product Lifecycle Management
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Understanding the Process

Consider the following Datasheet. It provides information about an assembly part that is not yet a
PLM object. When this object loaded into the PLM, applicable information about this PLM object is
maintained in the object's attributes. You can see some of these attributes in Datasheet
Configuration in Agile PLM on page 8.

Because of recent business activities, there is a need to update some of these attributes, such as
Name or Address, and then publish the updated Datasheet. The next few paragraphs summarize
the Dynamic Document Publishing process to update and publish this document.

Figure 3: Datasheet before it is loaded into Agile PLM
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Datasheet Configuration in Agile PLM

The Datasheet attributes are shown in the following illustration. As a PLM object, anytime the
Datasheet is updated, its attributes such as date, product title, and descriptions are subject to
change. Dynamic Document Publishing enables publication of the Datasheet with the latest
information. However, because Bl Publisher generates the final document, it is necessary is to
convert these attributes to a Data XML file for Bl Publisher processing.

ASM-00166 Preliminary
| Assembly * Data Sheet Object for Sun Server M4000 Demo Feb 11, 2010 Unincorporated
Site: | 4l | Rmev: introductory w| | [ Navigator | Actions ¥ |

Title Block | Changes SC Assy = BOM Subclasss Assembly ®  Mfr Subclass Assembly | Sites  Prices = Qualty | Complance = Sup|

Page Two | Doc Management Publshing | More Attributes | Security | Data Sheet Parameters

DS Tiie - SUN SPARC ENTERPRISE
4000 SERVER
Demo Feb 11, 2010

DS Introduction: Companies cant afford to have business-critical services go offiine. To mesat
these increasing demands for compute services, piatforms must be flexible and
provide a cost-effective growth path, Oracle’s midrange Sun SPARC Enterprise
14000 server boasts relability, flexibility, and binary compatibilty in a value-
priced server by combining the power of Oraclke's Sun Solaris Operating System
with mainframe RAS features. Built on the latest and most advanced SPARCE4
Vil quad-core or SPARCE4 VI dual-core processors, the Sun SPARC Enterprize
M4000 server delivers enlerprise-class service levels for essential business
applications, databases, and smaller consolidation projects.

DS Titke 01 MT: Investrment Protection, Scalabilty, Reliability, and Flexibility

DS Section 01: With the <b>Sun SPARC Enterprise M4000</b> servers, you can proiect your T
investment and scale out as needed with “in-box”™ upgrades, The oplion fo mix
and match different speedz/generations of SPARCES proceszors in existing and
new M-series servers uniguely protects investments and enables easy and
Bw-cost upgrades not offered by 1BM or HP.

Mainframe-class RAS features come standard in the Sun SPARC Enterprise

+ 114000 server, including automatic recovery with instruction retry, up to 128 GB
of system memory error-correcting code (ECC) protection with extended ECC
support, guaranteed data path integrity, total SRAM and register protection, and
configurable memory mirroring. In addition, the disks, power supply, and fans
are redundant and hot-zwappable, while the ¥0 cards are also hot-swappable.
Many features unique to the Solaris 10 OS5 enhance system reliability even
further, including Predictive Self-Healing, which automatically identifies and
molates faults and provides specific guidance when action is required
For more flexibilty, the Sun SPARC Enterprise M4000 server supporis up to two
Dynamic Domains, with a high level of granularity: CPU board-level domains for
farge, mission-critical werkloads requiring maximum isolation, and single-
zocket-level domains for finer granularity with high =elation. For maximum
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Generating the Data XML File

This step assumes you have installed Bl Publisher Desktop and the necessary Bl Publisher
commands are accessible from MS Word Add-Ins. This is performed by invoking the
loadXMLData Web Services API from MS Word and selecting Add-Ins > Data > Load XML Data. The
next step is to combine the Data XML and Schema XML (Template) files for Bl Publisher to
generate the Datasheet.

Figure 4: Creating and loading the Data XML file

WO ] AN b W R

[7xml version="1.0% encoding="UIF-8"7>
<AgileData xmlns:xasd="http://www.w3.org/2001/XMLSchema™>

<hssambl >

<TictleBlock>

<nppber>ASM-00166</ number>

<i voerhRasembly</itemType>

<lifecyclePhase>Preliminary</lifecyclePhase>>

<description>Data Sheetr Object for Sun Server M4000 Demo Feb 11, 2010</description>
<productLineS><Value>Automotive - Components</Value></productLineS>
<shippableItem:-No</shippableltem:>

<excludeFromBolinp>No</excludeFfromRollup></TitleBlock>

<Attachments>

<filename>AgileData_ Assembly.xml</filename>

<fileDescription>hgile Daca for ASM-00166</fileDescription>

<fileSize>5441</fileSize>

<fileType>xml</fileTyped>

<folderNumber>FOLDEROD01017</ folderNumbhear>

<folderVersion>2</foldexVersion>

<modifiedDace>2010-02-13T06:25:232</modifiedDace>

<lastViewDate>2010-02-13T06:25:22Z</1lastViewDate>

<checkinUser>Deron Johnstone</checkinUser></Attachments>

<PageThress

<DSTitle>50N SPARC ENTERFRISE

M4000 SERVER

Dema Feb 11, 2010</DSTitle>

<DSIntroduction>Companies caniapos;t afford to have business-critical services go offline. To meet t
<D5Title0IMI>Investment Protection, Scalability, Reliabilicy, and Flexibility</DSTicleQlMT>
<DSSection0l>With the slt:;begt;Sun SPARC Enterpriss M4000&1lt:/bigt; servers, you can protect your I
Hainframe-class RAS features come standard in the 5Sun SPARC Enterprise M4000 server, including autor
for more flexibiliry, the Sun SPARC Enterprise M4000 server supports up to two Dynamic Domains, with
<DSTitle02MI>Solaris: The Worldsapos;s Most Advanced Operating System</DSTitle02ZMI>
<D55ectionf2>The foundation of the Sun SPARC Enterprise M4000 server is the Solaris 10 05, which cor
<DSHeyFeatures>MATNFRAME~CLASS RELIABILITY, AVAILARILITY, AND SERVICEASILITY IN A VALUE-PRICED SERVE
&ltrulegerale;lisgt;Mix and match the boards with earlier wversions of the SPARC processor in a singl
&lt;liegt;Binary compatibility with earlier versions of your applications&lt;/lif&gt;
&lt;licgr;Scalable, mainframe-class computing for the open systems marketslt:/lisge:
&lt;lisgt;Advanced wvirtualization technologies, methodologies, and services, making Sun S5PARC Enterg
&lt;liege:Up to four quad-core SPARCS4 VII or dual-core SPARCE4 VI processorséle;/li&gt;

v9.3.1.1 9
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Creating and Testing the Template

Template is an RTF file created and formatted using Word, Bl Publisher, and object's attributes in
Agile PLM. For information and procedures to create Templates, see Building Bl Publisher
Templates on page 39 and Cited References on page 2. Assuming you have created the Template
file, running the 1oadxMLSchema API, again, from MS Word and selecting Add-Ins > Data > Load XML
Data will generate the following XSD file showing the selected attributes.

Figure 5: The Datasheet Schema XML file

1 [?xml version="1.0" encoding="UIF-87"3>

2 <xs:schema xmins:xs="htep://www.w3.org/2001/XMLSchema™>

3 <xs:element name="RgileData" type="AgilsDataType"/>

4

5 <xs:complexType name="AgileDatalype">

] <X3:sequencey

7 <xs:element name="Assembly"™ type="AsserblyType" minOccurs="0" maxOccurs="unbounded" nillable="true"/>

8 </xs:sequence>

9 </xs:complexType>

i)

il <x3:complexIype name="AszemblyIype">
a2 <8 ssquUEnCE>

i3 <xs:element name="BOM" type="AssemblyBCMType"™ minOccurs="0" maxOccurs="1" nillable="true"/>

14 <xs:element name="TitleBlock"” type="AssemblyTitleBlockIype" minOccurs="(Q" maxCccurs="1" nillable="true"/>
s <xs:element name="Attachments® cype="AssemblyAttachmencsIype® minOccurs="0" maxOccura="1" nillable="rrue®/>
L& <xs:element name="Manufacturers" type="AssemblyManufacturersType" minOccurs="0" maxCccurs="1" nillable="tru
n7 <xsa:element name="Specifications® type="AssemblySpecificationaType” minCccurs="0" maxOccura="1" nillable="g
15 <xs:element name="Relationships" type="AssemblyRelationshipsaType"™ minOccurs="0" maxOccurs="1" nillable="tru
ia <xs:element name="Quality® cype="AssemblyQualicyIvpe” minOccura=*0" maxOccurs="1" nillable="grue”/>»

20 <x3:element name="Sites" type="AssemblySitesType" minCccurs="0" maxOccurs="1" nillable="true"/>
21 <xs:element name="Prices" type="AssemblyPricesType" minOccurs="0" maxOccurs="1" nillable="true"/>
22 <x3:element name="PendingChanges" type="AssemblyPendingChangesType" minfccurs="0" maxOccurs="1" nillable="t
23 <xs:element name="WhereUsed" type="AssenmblyWhereUsedType" minQccurs="0" maxOccurs="1" nillable="tryue"/>
24 <x3:element name="PendingChangeWhereUsed" type="AsasemblyPendingChangeWheraUsedType™ minCceours="0" maxOccurs
25 <xs:element name="Compositions" type="AssemblyCompositionsType" minCccurs="0" maxOccurs="1" nillable="trus"
26 <xs:element name="Suhstances® type="lssemh]ySubstanceaType® minOccurs="0" maxOccurs="1*" nillable="cyrue®/>
27 <xs:element name="PageTlwo" type="AssemblyPFagelwolype" minOccurs="0" maxOccurs="1" nillable="true"/>
28 <xs:slement names"ChangeHistcory"” types"AsssmhlyChangeHiscoryIype”™ minOccurs="0" maxOccuras®i® nillables®cry
29 <xs:element name="Suppliers" type="AssemblySuppliersType” minOccurs="0" maxOccurs="1" nillable="true"/>
L] <xs:elemsnt names"QCRs" cypes"AssemblyQCRsType" minOccurs="0" maxOccurs="1" nillablem"crue"”/>
31 <x3:element name="History™ type="AssemblyHistoryIype" minOccurs="0" maxOccurs="1" nillable="true"/>
32 <xs:element name="Instances" type="AssemblyInstancesType” minOccurs="0" maxOccurs="1" nillable="true"/>
33 <x3:element name="PageThree" type="AssemblyPageThreeType" minOccurs="0" maxOccurs="1" nillable="true"/>
34 </xsisequence>
<) </#s:complexType>
36
37 <xa:complexType name="Lasemh]yBOMIype™>
<1 <X3:sequence>
3] <xs:slement names"EOMRowW" Typem"AssembhlyBOMRoWIype" minOccurs="0" maxOccurs="unbounded® nillablem"crue®/>
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Chapter 2: Dynamic Document Publishing

Testing/Viewing the Template

Now, you can view the Template and make sure it is properly formatted and the specified PLM
attributes are selected. To view the output, in MS Word, select Add-Ins > Preview > <File_Format>,
where file format is RTF, PDF, EXCEL, HTML, and PowerPoint. Following is the output in RTF

format.

Figure 6: Sample Template output

DsTitle

Dsintroduction

DiEkey Features

DSTitle01MT

DEsection0l

DSTitle02MT
DSSectionD2

DSsTableTitle

Services

From design and implementation ta support and smart
sourcing, Oracle provides an end-to-end portfolio of services
designed to accelerate the alignment of ITinfrastructure with
business needs, optimize usage of IT assets, and contain
costs, Oracle's expertize helpsyou address key data center
challenges, including consolidation, availability, clustering,
optimization, and disaster recovery. In addition, Oracle offers
top-ratedtechnical support for your DSTitle—including
technical support, expedited hardware service, and premium
online resources such as on-demand health checks and 05
update services. Visit oracle.com/sun/services for information
on Oracle's service program offerings for Sun products.

Warranty
Visit oracle.com/sun/warranty for Oracle's global warranty
support information on Sun products.

Contact Us

Formare infarmation about Oracle’s DSTitle, please visit
oracle.comfsun orcall +1.800.786.0404 to speak to an
Oracle representative.

v9.3.1.1
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Combining XML Data with Template - Publishing the Document

When the appropriate Event subscription which is set up in advance is triggered, XMLData is
combined with the Template and the document is generated in the specified format. In this case, in
PDF format. For information to set up the various Event subscriptions, see Getting Started with
Publishing the Sample on page 23.

Figure 7: Combining Data XML and Template to generate the document

Event Trigger

U et et e vaale G -

Muings Rreew View ' Addim Omegn  Layssd

ERTTI e WHLE PLM DOCUMENT PUBLIMING EXAMPLE ORACLE DAFA SHEET

Wi % |

SUN SPARC ENTERPRISE
M4000 SERVER
Demo Feb 11, 2010

Compamos cac afior b fove B

ffectvo groudh palt
Ertamnze W00 sanvar b0
[~ vy

b Investmant Protection, Scalasaity, Reliabiity, and
mankamedass Emudility

e epen ¢t e Sun SPARC Entarpeiss NADDD sanvers you cin
systes Akl protect your T svestmant and scale oul as nesded weh ‘i
Adanced bas” upgrmides Tha cpskon Lo mux and mech (feeent
WG grondcinanlin of SPARCEA preestor i aEsing mil
et M-20nie SOnvEr uniquely petects imesiments and
meROMOGES  anabkes ey and bw-cost Legindes not ol by IBM o

30 50
maing Sen

prres) ek ame.ciaes RAS fealures oome standand i T Sun
Enierpase SPART Ererpriss MAOKD e, nchang adomatie

servers decie  PSCOVENY Wi MeiTLCion Ty, op 40 128 Gl of sytem
ey i comeciing code (ECC) proection wih
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Chapter 3

Setting Up the Environment to Publish Sample
Documents

This chapter includes the following:

B OVBIVIBW cooeocrriser s

= InStalling Bl PUBIISNEE DESKIOP ......vuvveirrieirieiisercisiseeis ettt ses s s

= Agile PLM Administrator Configurations

= Agile PLM Server CONIQUIALIONS.......c.cv vttt ettt
Overview

Setting up the environment to publish the sample, requires the following installations and Agile PLM
configurations.

Prerequisites

Installing Bl Publisher Install to enable:

o Inserting data fields into RTF templates

= Inserting data driven tables and crosstabs

@ Inserting data driven charts

o Previewing and Validating RTF templates with sample XML data

= Browsing and updating content of form selected fields
Configuring Agile PLM Administrator

These configurations include:
o Creating the Template Subclass

= Configuring Attributes and Agile Content Services (ACS) Filters
Configuring Agile PLM Server

This involves creating and configuring the following Process Extensions (PXs):
= Template Management Structure Creation PX

@ SchemaGeneration PX

o DataGeneration PX

o Document Generation PX

v9.3.1.1 13
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Getting Started with Document Publishing

These tasks address generating the following:
= Agile PLM structure and placeholders using the Oracle supplied PXs
@ Templates with Bl Publisher

Note If you are installing Agile PLM 9.3.1, or using an installed copy, make sure File Manager
and SDK are selected or are already installed. For installation procedures, refer to
documents listed under "Install/Upgrade Guides" at http://download-
lInw.oracle.com/docs/cd/E17287 02/otn/docset.html.

Installing Bl Publisher Desktop

The BI Publisher extension to Microsoft Word simplifies the development of RTF templates.

To install Bl Publisher Desktop:

1. Download and install Bl Publisher Desktop 11g or 10g from OTN at:
http://www.oracle.com/technetwork/middleware/bi-publisher/documentation/xmlpdocs-
084437.html.

Note Installing Desktop 11g requires downloading all four installation files from OTN.

2. Verify Add-Ins is available in MS Word.
Figure 8: Bl Publisher Add-In in MS Word

E‘-a = & | ¥ 9.3.1 Agile PLM_Document_Publishing_Installation_and_Setup_Guide.doc [Comp.. M - = X
-

Home Insert Page Layout References Mailings Review View Add-Ins (7]}

Oracle Bl Publisher ~ | Data ~ Insert ~ Preview = Tools ~ Help -

Menu Commands Custom Toolbars

Agile PLM Administrator Configurations

These are the Agile PLM Administrator configurations and documented in the following paragraphs:

= One time configurations
* Add a Subclass called DocumentTemplate

= Object Level Configurations
* Add Page 2 fields
* Define ACS Filters

* Create Event Subscriptions consisting of Event Masks, Handler Masks, and Subscriber
Masks for Script PX or Java PX

14 Agile Product Lifecycle Management
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Chapter 3: Setting Up the Environment to Publish Sample Documents

Note For complete documentation of the Event Management framework, refer to the Agile

PLM Administrator Guide.

Creating the DocumentTemplate Subclass

This is a new Documents Subclass for the XML schema (Templates) files and is used in Script PX
and Java PX configurations. The PX that creates the object schema XML automatically creates an
object of this subclass for every object in the system and attaches the schema XML to this object.

Note This is a onetime configuration and provides a placeholder for all Template files.

To create the DocumentTemplate Subclass:

1. Log into Agile PLM Java Client as an administrator.

2. Select Admin > Classes > Documents Class to open the Class: Documents Class dialog.

3. In Class: Documents Class dialog, select the Subclasses tab and click New Subclass = to open

the New Subclass dialog.

4. Create a new Documents Subclass called DocumentTemplate for Item.

Be sure to select Document Number for New Autonumber. For details, see
TemplateManagement.properties file in Template Management Process Extensions. You can
find a copy in the Doc-Publishing folder described in SDK Samples Folder and Document

Publishing Examples.

Figure 9: Configuring the DocumentTemplate Subclass

T Mew Subclass

Mame

APT Marne:

Description

Enabled
Icon
Icon For Assembly

Autohumber Source

AutoGenerate

Site-Specific BOM

Docurment Template
Document Template A

Place holder For Templatefiles

es v

5

Document Autolumber 2] New Autonumber

[] Autarumber Required

Mo e

Allow v

5. Click OK.

v9.3.1.1
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The DocumentTemplate subclass General Information page appears.
Figure 10: DocumentTemplate General Information tab

-‘_ Subclass:DocumentTemplate

*
General Information | User Interface Tabs | Lifecycle Phases | Process Extensions || Event Subscribers | History_
Mame | Document Template | ~
APTMame  |[Document Template =)
Description | |
Enabled |y’es Bt |
Autorumber Required [ v|
AutoGenerste |No Bt |
Icon | | i
Icon For Assembly | |
Site-Specific BOM |Al\nw b |
Failure Mode |i= gilure Maode List - [Document Template] |
Class |D0cuments & Samples |
autohumber Source | | [ = New Autonumber } =

Refresh Close

6. To continue, see Defining Page 2 Fields for the Object on page 17.

To set the Title Block Number fields:
1. In Agile PLM Java client select the Admin tab.

2. Select Classes > Document Class > User Interface tabs > TitleBlock > Attributes:Title Block > Number field.

The Attributes:Number page appear.
Figure 11: Setting Page 2 Attributes for the object

7i' Attributes:Number

Hame  [humber |

APIMame  [number i)

Description | |

Visible oo

Include Characters ‘NI v‘ [ New Character Set ]

MaxLength (75 |

Max System Length ‘75 |

Order ‘ 1 |

Required oo

Available for Subscribe | v

Enable For Search Criteria ‘yes ~ |

Atribute  ITEM.ITEM_NUMBER. |

Type  Texl
Tnput Width [ {ong v
Change controlled ‘ Mo - |

Save

Set MaxLength field 75 and Include Characters field to All.
4. Click Save.
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Chapter 3: Setting Up the Environment to Publish Sample Documents

This completes configuring DocumentTemplate subclass attributes.

Note You can rename this subclass if you modify the configuration of the PX. For example,
changing the TEMPLATE_SUBCLASS_API_NAME=DocumentTemplate in
ManagementStructure.properties file.

Configuring Agile Content Services Filters

Document publishing Web Services rely on Agile Content Services (ACS) filters to determine:
o Where the Template is stored
= What data is returned for the object in the XML file

= How to output the document

You can tailor these filters to return the minimum information to improve performance and minimize
waste during data transfer. An ACS filter is referred to by its APl Name. As indicated earlier, these
are object-level configurations.

Defining Page 2 Fields for the Object

The required fields for the Sample are a header field, two Text fields, and one List field. The Base
IDs are for later use.

o Heading — This is for Bl Publisher to display the Doc Publishing attributes in a Heading area.

o List Field — This Alpha Type determines the Output Type (EXCEL, RTF, PDF, and HTML) and
assumes Listll and Base ID 1271.

o Text Field — This is for the Filter and assumes Text 12 and Base ID 1302.

o TextField — This is for the Template Holder and assumes Textl1 and Base ID 1301.

Note The selected fields provide flexibility for the sample and may not be necessary in a
production implementation.
To define Object Page 2 fields:

1. Log into Java Client and select Admin > Classes > Documents Class > User Interface Tabs > Page 2 >
Attributes: Page Two > List11.

v9.3.1.1 17
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The following Attributes dialog appears.
Figure 12: text field attributes

il Attributes:List11

Name [List11 |

APTName  [list11 =]

Description |0utput Type |

Visible |Ves v |

List |Duc Publishing Crutput Type List ~ | [ Mew Lisk l

List ID | |

Cascade List | |

List Detail Box View Detail

Default¥alue  PDF e}

Required |Ves v |

Avvailable for Subscribe |Nu i |

Enable for Search Criteria ||\|0 v |

Attribute |PAGE_TWo.LIST11 |

Type

Input Width |Lnng v |

hange controlled ||\|U - |

E Save | Refresh Close %

Set the fields and then click Save.

3. InJava client, select Admin > Classes > Documents Class > User Interface Tabs > Page 2, and
configure the remaining Text and Header fields as shown in the following figure.

Figure 13: Object Page 2 fields for Document Publishing sample

_" Class Tabs:Parts

pos NI
e nfomasen] Atetutecsoge Tvo |

99 (2 By 42| Fiterby Type [a1 v

« PAGE_TWO.HEADINGO2

Doc Management Publishing

Filter text12 Text Yes [N/A ...[PAGE_TWO.TEXT12 1302
Template Holder textil Text Yes  N/A o0 [ PAGE_TWO.TEXTIL 1301
Output Type list11 List Yes  |DocType POF e L o racE Two LT 1271

Important The Base ID values are used in the Java PXs Properties files and in the Script PX
text. If different fields are used, you must change the Java or Script PXs to reflect the
new Base ID values.

Defining Agile Content Services Filter for XML Data

Document Publishing PXs use ACS filters to determine how to build the XML files. Agile PLM
provides a set of Agile PLM filters and you can use these filters or define your own filters. Fields
selected for the filter provide flexibility for the sample and you can alter them for a production
environment.

Note When defining a filter, use the API Name that was used for the object that you plan to
publish.
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Chapter 3: Setting Up the Environment to Publish Sample Documents

To create the ACS filter:
1. Loginto Agile PLM Java Client as administrator.
2. Select Admin > System Settings > Agile Content Service > Filters = to open the Create Filter dialog.

Create Filter x|

Marme: IItams|:abs

APIMame [Itemstabs S|

Description |

Ohject Type IItems ;I

Migwable Tabs I‘I’itle Block,Page Two, Atkachments,Page Three 3]

BONGptians ITab only ;I

BN level I = EllLevels

AL CptT [12B Grly =
Attachment Options ITab iy LI

Note Dynamic Document Generation does not support the Files option. Use only the Tabs
Only option and avoid the Tabs and Files option.

3. Create a new filter called Itemstabs with a minimum of Title Block, Page Two, Page Three, and
Attachments tabs.
4. Click OK and select the Filter tab to view the new filter.

5. Select the settings shown in the following figure, and then click Save.
Figure 14: ACS Filter configuration interface

ii. Filter:ltemstabs

General Information | Flter | History

Object Type  [Ttems

View Tabs ITitIe Elock;Page Two;Attachments;Page Three

Attachment Options |Tab only
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Agile PLM Server Configurations

Dynamic Document Publishing involves configuring and deploying the following Agile PLM Event
Management components:

o Event Node — Event masks are configured around Event types. For example, Create Object,
Delete Object, Audit for Workflow. Agile PLM provides a list of pre-defined Events for which an
event can occur.

o Event Handler — Handler masks configure a custom action that is called when the Event is
raised. They extend the function of an action taken by a user, interface, or the system when the
Event subscription is triggered.

o Event Subscriber — Subscriber masks link a Handler mask to an Event mask.

Deploying these components enable creating Templates and generating the schema and document
files. These configurations make use of PXs described in Using Oracle Supplied Document
Publishing Examples on page 21. For more information on Event components, refer to Agile PLM
SDK Developer Guide and Agile PLM Administrator Guide.

Understanding Process Extensions and Events Framework

Process extensions (PX) is a framework for extending the functionality of the Agile PLM system.
The functionality can be server-side extensions, or extensions to client-side functionalities, such as
external reports or new commands added to the Actions menu or Tools menu. Regardless of the
type of functionality a PX provides, all custom actions are invoked on the Agile Application Server
rather than the local client.

In Agile SDK environment, Event Management framework extends the PX framework to enable
developing and deploying event-driven applications. Events act as trigger points for generating an
automation action within the PLM application. Every Event is generated from a source within Agile
PLM applications. The source can be a business action triggered by a user, a Ul action, or a system
initiated action. Agile PLM's Event framework supports developing extensions using the Java
programming language and Groovy Script.

For information to develop Java PXs/Script PXs and Events, refer to the latest release of the Agile
PLM SDK Developer Guide and Agile PLM Administrator Guide. You can find referential and
procedural information about PXs, Events, and Event triggers in these documents.

Java and Script PXs described in this chapter, namely, TemplateManagementStructureCreationPX,
SchemaGenerationPX, DataGenerationPX, and DocumentGenerationPX make use of settings
defined in Agile PLM Server Configurations (on page 20).
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Chapter 3: Setting Up the Environment to Publish Sample Documents

Using Oracle Supplied Document Publishing Samples

Configurations described in setting up the PLM server use the following Java and Script PXs (Event
Handlers):

= TemplateManagementStructureCreation

@ SchemaGeneration

@ DataGeneration

8 DocumentGeneration

The Doc-Publishing folder contains the Java, Properties, and Resources files that you need to set
up and deploy the sample Java and Script PXs. You can find these PXs and other components in
the Doc-Publishing folder in SDK_samples.zip. See SDK Samples Folder and Document Publishing
Examples.

Figure 15: Oracle-supplied PXs

Size | Tvpe

File Folder
|1 DocumentGener ationlava File: Folder
|1 DocumentGener ationJavaOpen File: Folder
|1 DocumentGener akionisPs File: Folder
|Z)GlobalschemaGeneration File: Folder
|Z)5chemaGener akion File: Folder
|) TemplateCreation File Folder
I wardPlugin File Folder
build.bat 1 KB M5-DOS Batch File
(= build.sh 1KE SHFile
custom.property 1KE PROPERTY File

Before using Java PXs, you must deploy them first. For procedures, see Working with Script PX
and Java PX Handlers on page 21. There is no need to deploy the Groovy equivalent Script PXs.
For information on deploying Script PXs, refer to Agile PLM Administrator Guide.

Working with Script and Java PX Handlers

Doc-Publishing folder contains both the Java PX and Script PX handlers. The Java Handlers
provide the Java, Properties, and Resources files that you need to deploy the sample Java PX and
Script PX handlers.

To deploy the Script PXs, refer to Agile PLM Administrator Guide. To deploy the Oracle supplied
Java PXs, you must first create the JAR files as shown below.
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To create JAR files:

1. In Doc-Publishing, open the custom.property file and specify drive name and path for the Agile
PLM server ias.deploy, and the Application server (OAS, or WLS) inias.home.

Figure 16: Configuring the Custom Properties file for JAR files

Jas.deploy.dir=0: /buildsagilesslsagilepomainsapplications app-InF, 1k
jas. home=0D:/0C4310133
px.deploy, Toc=0: /buildagiles3lAntegration/sdk /extensions

AMT_HOME=C @ fapache-ant-1.7.1
In px.deploy, specify the location the PXs will reside in your environment.

Make sure you are running apache-ant-1.7.1 and specify the path for ANT_HOME.

Run build.bat or build.sh to create all JAR files for Windows and Unix environments respectively.

a > WD

Make sure the JAR files are in "<AgileHomeDir>\integration\sdk\extensions" directory.

Note You can use these PXs to implement the Dynamic Document Publishing capabilities by
creating the Event Handler and Event Subscriber to trigger the Event. For details see
Template Management PX on page 24, Schema Generation PX on page 29, Data
Generation PXs on page 34, and Document Generation PXs on page 47. Alternatively,
you can use the information to develop your own Java Client and server configurations.
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Chapter 4
Getting Started with the Sample

This chapter includes the following:

N I TS 1= VT o TR T 23
= Configuring TemplateManagementStructureCreationPX .........ccccovviernieninneene s ssesesesees 24
= Configuring SCEMAGENEIALIONPX........cvuriieeiiereieirireieserees et ses sttt en s 29
= Generating Schema XSD and Data XML filES ..ot 33
= Configuring DataGENEIALIONPX ........cccviveiieieiiecieiise et s bbbttt e a b n st b s

= Building Bl PUDIIShEr TEMPIAES......ceevevecieirieeeisercieiseis et

=  Configuring DocumentGenerationPX

= Triggering the Event and Creating the OUIPUL FIIE ... s 55

Task Sequence

Publishing the Sample requires the completion of the following tasks:

Setting up, configuring, and running the TemplateManagementStructureCreation PX
Setting up, configuring, and running the SchemaGeneration PX

Setting up and configuring the DataGeneration PX

Downloading the schema (XSD) and data (XML) files to the local drive

Loading the schema file

Loading the data file

Laying out the BI Publisher Template and and saving the Word file in RTF format
Uploading the Template into Agile PLM

© ©® N o g > w DN PR

Triggering the Document Generation Event to create the output file
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The task sequence is summarized in the following illustration.

Figure 17: Publishing the Sample
_®_‘ Open Word with BIP Plugin ‘
(i | ’
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Load Data
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Configuring TemplateManagementStructureCreationPX

The TemplateManagementStructureCreationPX creates a 3 level Bill of Material (BOM) for Base
Classes, Classes, and Subclasses defined in Configuring DocumentTemplate Subclass on page
15. This is a placeholder for all future .RTF template files.

Note This PX is run once only and is not necessary if the Schema Structure is not needed

You can find this Script or Java PX in SDK Samples Folder and Document Publishing Examples.
Depending on the Application Server (OAS, WLS) running in your installation, the path to the Script
PX and Java PX with its .JAR and Properties files are:

= Script PX for WLS — 931_wls_sdk\samples\Doc-
Publishing\TemplateCreation\TemplateCreationScript.groovy

= Script PX for OAS —931_oas_sdk\samples\Doc-
Publishing\TemplateCreation\TemplateCreationScript.groovy
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Java PX for WLS — 931 wls_sdk\samples\Doc-
Publishing\TemplateCreation\samples\TemplateManagementStructureCreation\
TemplateManagementStructureCreationPX.java

Java PX for OAS — 931_oas_sdk\samples\Doc-
Publishing\TemplateCreation\samples\TemplateManagementStructureCreation\
TemplateManagementStructureCreationPX.java

Configuring Event Masks for TemplateManagementStructureCreationPX

These configurations involve creating the necessary Event masks, Handler masks, and Subscriber
masks.

To create Event mask and set Event Type:

1.
2.

3.

Log in to Java Client with Admin privileges.

In Java Client, select Admin > System Settings > Event Management > Events.

In Events page, select the New = button to open the Create Event dialog and define an Event
mask called CreateBomTemplate for Object Type Parts with the following settings:

Figure 18: Create Event mask for TemplateManagementStructureCreationPX

4.

Create Event E|

Event Type | Extend Tools Menu v

Mame  |CreateBomTemplate

& &

API Mame | CreateBomTemmplate

Description

Enabled |yeg “

Click OK.

To set up the Event Handler mask:

1.

In Java Client with Admin privileges, select Admin > System Settings > Event Management > Event
Handlers.

Hia .
In Event Handlers pane, select the Newié button to open the Create Event Handler dialog.
Create a new Event Handler mask called CreateBomTemplate.

Set Enabled to Yes, and for Role, select the applicable roles. For example, Quality
Administrator, Quality Analyst, Quality Analytics User. For Event Handler Type, you have the
option to select Script PX, or Java PX. You can find the Oracle supplied Script and Java PX in
Doc-Publishing folder in SDK_samples.zip described in Template Management PX on page 24.
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< Create Event Handler E
Event Hander Type i
Name | CreateBomTemplate
APIName |CreateBomTemplate A
Description < Create Event Handler @
Event Handler Type | javapi .
Enzbled |yes v Name | CreateBomTemplate
Role [#4] APIName | CreateBomTemplate [}
Seripk |inpart: conn, aghe, agilelsL . ScriptOby . IBaseScriptobj Description
1f add other import statements here
woid invoke Script{TBaseScriptob) obi) {
fiscripk body starts here.
H Enabled |yas e
Role 1%
Event Action | com, agi Tanadatetvansger entstruturedrestionFijava |
o) Ceme )

5. To configure the Script or Java PX Handler, do as follows.

o For Script PX Event Handler:

In Create Event Handler, paste the contents of TemplateCreationScript.groovy file in the
dialog's Script box and click OK. For more information, see Agile PLM Events and Event
Framework chapter in Agile PLM SDK Developer Guide. You can also find information on
configuring Script PXs in Agile PLM Administrator Guide.

o For Java PX Event Handler:

1. Make sure the Event Action for this Java PX is deployed. See Creating JAR Files and
Deploying PXs (Event Handlers).

2. Check the values in TemplateManagementStructureCreation.properties file and make sure

they conform to Java Client Admin settings shown in Properties File Settings for
TemplateManagementStructureCreationP (on page 27)X.

3. Click OK.

To configure the Event Subscriber mask:
1. In Java client with Admin privileges, select Admin > System Settings > Event Management > Event
Subscribers.
2. In Event Subscribers pane, select the New i button to open the Create Event Subscriber dialog.
3. Create a new Event Subscriber mask called CreateBomTemplate with the following settings:
* Enabled to Yes,
* Trigger Type to post
*  Execution Mode = Synchronous
®  Error Handling Rule = Stop
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4. Click the drop-down arrow to select the Event and Event Handler you created earlier.
Figure 19: Template Management Event Subscriber

Create Event Subscriber

Mame  |CreateBomTemplate

APT Mame | CreateBomTemplate

Description

Enabled |ves

X

Event [CreateBomTemplate

Event Handler [CreateBomTemplate
Trigger TYpe  |past

Execution Mode | asynchronous

<| e

<

5. Click OK.

TemplateManagementStructureCreationPX

Values set in the Oracle supplied Properties file are shown in the shaded region. Make sure these
values conform to Java Client Admin settings for this PX.

Figure 20: Properties file settings for Template Management PX

# TEMPLATE_SUECLASS_API_MAME ~ ———mmmmmmmmm o
#
# ROOT_TEMPLATE_OBJECT_NUMBER ~ ————mmmmmmm— o
#

# CLASS_TEMPLATE_OBJECT_NUMEER_FORMAT —-———------——

# OBJECT_DESCRIPTION  —mmmmmmmmme e

value for this property should be API name of the new subclass of "Documents" class which is
created for holding the template BoM

value for this ﬁmperty is the object number of the root object,the BoM tab of which will contain
objects for eacn agile class in hierarchical manner

This defines constituents of the object number created for each class of Agile hierarchy

This defines the description of child object created for every sub class.

# LOGEING  mmmmmmmee This accepts true/false as value. when this is set to true Tog messages gets
# printed on the application server console

# API_MAME e Indicates aAPI name of the class for which object is being created

# CLASS_MNAME — mmmmmmme Indicates <lass name of the class for which ohject s being created

# CLASS_ID  mmemmmmmmmmeen

Indicates <lass fd{ex 10141)) of the <lass for which object is heing created

TEMPLATE_SUBCLASS_API_NAME=DocumentTemplate

ROOT_TEMPLATE_OBJECT_NUMBER=DOCUMENT _TEMPLATE

LOGGEING=True

# Note: No property should be removed from this property file

CLASS_TEMPLATE_OBJECT _NUMEER_FORMAT=API_NAME+ "_" +CLASS_ID

OBIECT_DESCRIPTION="Schema holder for "+CLASS_NAME+" sub class”
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If there are no changes to the PX, you can use the JAR files described in Creating JAR Files and
Deploying PXs (Event Handlers). If you need to modify the Java or Script PX, do as follows:

For Java PX:

1. Copy “TemplateManagementStructreCreation.jar” to
“<AgileHomeDir>\integration\sdk\extensions”.

2. Unpack “TemplateManagementStructreCreation.jar” to gain access to
“ResourceTemplateManagement.properties” file.

3. Update as needed.

4. Repack and recopy to PLM server.

For Script PX:

1. Open the Handler in PLM client.

2. Configuration is at the beginning of the Script. Modify the Script as needed.
3. Save the modified Handler.

Output Generated by TemplateManagementPX

The Script PX or Java PX are invoked from the Tools menu and when triggered will do as follows:

1. Configure the Template Subclass and create a new Documents Subclass called
"DocumentTemplate” for Item - Document

2. Create a 3-level BOM with Level 1 for all Agile Base classes in the system
Figure 21: Template Management Outputs

Prelim
Unincorpore
Site: ‘.L_;I Rew: \rrtroduclury;] Dﬁ Mavigator Actions ~
Title Block = Changes | BOM*® | Sites Quality = Relstionships = VWhere Used = Attachmerts = History
30M
Add Retnove Go To Expancied Display More =
& B | 3% ftem Humber ¥ | tem Description Rem Rey

¥ |1 bo0841_CHANGES
i L0 DO0542__MANUFACTURER _ORDERS
[ DO0E

M

w [}, DO0B44__CHANGE_ORDERS
h ! _

| ] DOOB45__ECO

b | DO0B46__ CHAMNGE_REQIESTS
L]

» iDﬂTFi __DEVIATIONS

3 D __PRICE_CHANGE_ORDERS
L]

b |} DO0B52__STOP_SHIPS
=]

» D00&34__SITE_CHAMGE_ORDERS
=]

» | T DO0SS6__CUSTOMERS

C|
Ph

000859 DECLARATIONS
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Configuring SchemaGenerationPX

The purpose of SchemaGenerationPX is to programmatically generate XML schema files using the
Agile Java API for a given object. Document templates and document generation PXs, using Bl
Publisher Java API reside in Agile PLM.

It is necessary to run this PX for each Subclass generate the Schema XSD file. Alternately, you can
run the GlobalSchemaGeneration.jar Java PX from the Tools menu to generate a schema for ALL
subclasses in the system. The Schema XSD will be attached to the applicable object in the
Template (Schema) Management Structure'

The paths to the Script PX and Java PX with its .JAR and Properties files are:

o Script PX — 9311 wls_sdk\samples\Doc-
Publishing\TemplateCreation\SchemaGenerationScript.groovy

= Script PX — 9311 oas_sdk\samples\Doc-
Publishing\TemplateCreation\SchemaGenerationScript.groovy

o JavaPX-9311_ wls_sdk\samples\Doc-
Publishing\SchemaGeneration\samples\SchemaGenerationPX.java

o JavaPX-9311 oas_sdk\samples\Doc-
Publishing\SchemaGeneration\samples\SchemaGenerationPX.java

Configuring Event Components for SchemaGenerationPX

Similar to TemplateManagementStructureCreationPX, these configurations require creating the
Event and setting the Event Type, Event Handler (Java or Script PX), and Event Subscriber.

To create Event mask and set Event Type:

1. Follow the steps in Configuring Event Components for
TemplateManagementStructureCreation PX on page 25 and define an Event mask called
CreateSchema for Object Type Items with the following settings:

Figure 22: Create Event mask for SchemaGeneration PX

Event Type | Extend Actions Menu v

Mame  |CreateSchema ]
APT Mame | CreateSchema ]

Description | Create Schema For Subclass

Enabled |vee w

Object Type | 1rems v

2. Click OK.
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To set up the Event Handler mask:

1. Use the information in Configuring Event Components for
TemplateManagementStructureCreation PX on page 25 and create a new Event Handler
(Script PX, or Java PX) called CreateSchema.

2. Set Enabled to Yes, and for Role, select the applicable roles. For example, Quality
Administrator, Quality Analyst, Quality Analytics User. For Event Handler Type, you have the
option to select Script PX, or Java PX. You can find the Oracle supplied Script and Java PX in
Doc-Publishing folder in SDK_samples.zip described in Configuring Event Components for
TemplateManagementStructureCreation PX on page 25.

3. To configure your Script PX or Java PX Handler Type do as follows.
*  For Script PX Event Handlers:

In Create Event Handler, paste the contents of Schema Generation Groovy script file in the
dialog's Script box and click OK. For more information, see Agile PLM Events and Event
Framework chapter in Agile PLM SDK Developer Guide. You can also find information on
configuring Script PXs in Agile PLM Administrator Guide.

* For Java PX Event Handler:

a. Make sure the Event Action for this Java PX is deployed. See Deploying PXs (Event
Handlers).

b. Check the values in SchemaGeneration.properties file and make sure they conform to
settings defined in Java Client Admin in Properties File Settings for Schema Generation
PX on page 31.

4. Click OK.

To configure the Event Subscriber mask:

1. InJava Client with Admin privileges, select Admin > System Settings > Event Management > Event
Subscribers.

. g . .
2. In Event Subscribers pane, select the Newié button to open the Create Event Subscriber dialog.
3. Create a new Event Subscriber called CreateSchema with settings shown in the following figure.

4. Click the drop-down arrow to select the Event and Event Handler you created earlier.
Figure 23: Create Event Subscriber for CreateSchema Event

Create Event Subscriber X
Mame |CreateSchema ]
APIHame  [CreateSchema 1
Description
Enabled  [ygs v
Event [CreateSchema 1]
Event Handler [CreateSchema [
Trigger Type [post v
Execution Mode | asynchronous v
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Properties File Settings for SchemaGenerationPX

Values set in the Oracle supplied Properties file are shown in the shaded region of the following
illustration. Make sure these values conform to Java Client Admin settings for this PX.

Figure 24: Properties file settings for Schema Generation PX

# CLASS_TEMPLATE_OBJECT_MUMBER_FORMAT  ————————m———— wvalue for this property should be same as mentioned in ResourceTemplateManagement.properties
# SCHEMA_FILE_MAME  mmmmmmmme This property defines the constituents of the file name of the schema file

# SCHEMA_FILE_DESCRIPTION — ———mmmmmmmmo This property defines the description for the schema file.

# LOGEING e This accepts true/false as walue. when this is set to true log messages gets

+* printed on the application server console

# API_mMAME indicates  —mmmmmm API name of the object's <lass for which schamea file is being generated
# CLASS_MAME e Indicates class name of the object's class for which schamea f41e is being generated
# CcLass_ID mmmmme Indicates class id of the object's <lass for which schamea fi1d. is being generated

# note: nNo oproperty should be removed from this property file
TEMPLATE_SUBCLASS_API_NAME=DocCumentTemplate
CLASS_TEMPLATE_OBJECT_NUMBER_FORMAT=API_MNAME+ “_" +CLASS_ID
# SCHEmMA FILEMAME should of xml type
SCHEMA_FILE_MAME="Schema"+ "_" +API_MNAME+ ", xsd"
SCHEMA_FILE_DESCRIPTION="agile schema for "+CLASS_NAME

LOGGING=Truea

If there are no changes to the PX, you can use the JAR files described in Creating JAR Files and
Deploying PXs (Event Handlers). If you need to modify the Java or Script PX, then do as follows:

For Java PX:

1. Copy “SchemaGenerationPX.jar” to “<AgileHomeDir>\integration\sdk\extensions”.

2. Unpack “SchemaGenerationPX.jar” to gain access to “SchemaGeneration.properties” file.
3. Update as needed.

4. Repack and redeploy to PLM server.

For Script PX:
1. Open the Handler in PLM client.
2. Configuration is at the beginning of the Script. Modify the Script as needed.

3. Save the modified Handler.

Output Generated by SchemaGenerationPX

When the Event is triggered from the Actions menu or Tools menu, a Schema for the sub class is
created and added to the Template BOM created by TemplateManagementStructureCreationPX. It
is necessary to run this PX for each Subclass you defined in Agile PLM Administrator
Configurations on page 14 to generate the required Schema XSD file. Alternatively, you can run the
GlobalSchemaGenerationPX from Tools menu and generate a Schema for all subclasses in the
system. The Schema XSD file is attached to the applicable object in created in
TemplateManagementStructureCreationPX.

The Schema Naming Convention is
<ObjectClassName>:<ObjectSubClassName>:<SchemaSuffix>.
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These attributes are defined as follows:
o ObjectClassName — This is the name of the class. For example, Document.
o ObjectSubClassName — This is the name of the subclass. For example, Documents.

= SchemaSuffix = The SchemaSuffix is set in the properties file.
Figure 25: Event type settings for GlobalSchemaPX

P Event:GlobalSchemaPX

i General Infarmation | here Used | History

Event Type | Extend Tools Menu

Wame [GlobalschemaPy [ =
APIlame  [GlabalSchemaPX 2]
Drescription | ‘
Ensbled |\(a; [Vl

Figure 26: Output of SchemaGeneration PX

<?xml wversion="1.0" encoding="UTF-8"2>
<x&:schema xmlns:xs="http://wuw.w3.org/2001/ZML3chema s
<x3:element name="igileData"™ type="AigileDataType"/>

<x5:cowmplexType name="AgileDataType":
<xX3:3equencer
<xz:element name="DocumentTemplate”™ type="DocumentTemplateType” minOccurs="0" maxOcocurs="unbounded” nillable="true"/
</ ®5isequence>
</¥s:complexTypes

<x5:cowmplexType name="Docuwent TemplateType™:>
<xX3:3equencer
<x@:element name="EOM" type="DocumentTemplateBONType"” minOccurs="0" maxOccurs="1" nillasble="true"/>
<xs:element name="TitleBlock" type="DocumentTemplateTitleBlockType™ minOocurs="0" maxOccurs="1" nillable="true"/>

<xz:ielement name="Instances" type="DocumentTemplatelnstancesType™ minOccurs="0" maxOccurs="1" nillable="trus"/>
<xs:element name="PageThree™ type="DocumentTemplatePageThreeType” mwinCccurs="0" maxCcocurs="1" nillable="trues"/>
<f¥3:1sequences
</nsicomplexTypes>

<x3:complexType name="Docwent TemplateBONType™:>
<M3ISEqUENCEX>
<xs:element name="BOMRow"™ type="DocumentTemplateBONRowType" mindccurs="0" maxCOccurs="unbounded” nillable="trus"/>
<f¥3:1sequences
</nsicomplexTypes>

<xz:element name="itemDescription” type="xs:string” minOccurs="0" mwaxOccurs="1" nillabhle="true"/:»
</ ®gisequence>
</¥s:complexTypes
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Note In this output, Document is the Class nhame and Documents is name of the Subclass of
Document.

Generating Schema XSD and Data XML files

This requires triggering the first three Document Publishing Events. When they are triggered, the
PXs will perform the following tasks in the listed order:

1. TemplateManagementStructureCreationPX — This PX will create a 3 level BOM for all
BaseClasses/Classes/SubClasses in the system.

SchemaGenerationPX — This PX will generate the Schema file (.XSD) for the referenced objects.

DataGenerationPX — This PX will create the Data .XML file and attaches it to the object. As
prerequisite, it requires creating Item — Part/Document and setting the respective Page Two
attributes. In this case, DocType, Filter and TemplateHolder. These prerequisites for this PX
were defined in Agile PLM Administrator Configurations on page 14 and Configuring
DataGeneration PX on page 34.

Note For convenience and to facilitate search, in the Sample, names used for the PX Handlers
start with DP for Document Publishing. These names are shown in the following
illustration.

Figure 27: Document Publishing Events and Event Handlers

£ Events

]| X| nj i Tokal Mumber of record{s): 11

Filker By |Mame V| Match IF |Show Al v | Yalue | | ’ Apply ] |
Name a | Description Enabled Event Type Object T... |Waorkflow
||DP hange Status For WaorkFlow Def. .. Yes Change Status fo... (Change ... |Default Change Requests &
||oF Generate Teem Schema tes Extend Actions M., [tems i =
||DP Generate Schema Structure Yes Extend Tools Menu M)A MA w
£ >

£{ Event Handlers

X | DJ [D Total Mumber of record(s): 4
Filter By Match IF | Starts With | Yalue |DP | [ Aty |
Marme 4 |Description Enabled Handler Tyvpe Rale

DP Generate Daka XML es Scripk P

DP Generate Document From Change es Scripk P

DP Generake x50 Schema G Scripk P (Propagation) Adminiskrator
DP Schema Structure Generation es Scripk PE

< | ¥
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To run the PXs:

1. In Java Client (Admin client), select Tools > DP Generate Schema Structure to create the schema
for the desired object.

2. InJava Client, select Part - Action > Generate Schema.

Note The PX does not rely on the Filter and generates the entire schema.

3. Trigger the Event that runs the Generate Data Handler.

* Make sure to update the Title Block of a Part in the Oracle supplied sample to trigger the
PX to run.

* Make sure the all Document Publishing attributes are correct before triggering this PX

This generates attachments for the Schema XSD and Data XML for use in Word with Bl Publisher.
Schema XSD is attached to a DocumentTemplate object, for example, "Assembly 2467572" where
Assembly is the Item Type and 2467572 is the internal ID of the subclass.

Configuring DataGenerationPX

The overall aim of the DataGenerationPX is to programmatically generate sample data using the
Agile Java APl Get XML Schema for document authors to preview the outputs in the document
authoring tool. When run, the PX creates and loads the XML file into the authoring tool (MS Word)
to test the Template with Bl Publisher.

As indicated in Creating JAR Files and Deploying PXs (Event Handlers) this PX requires creating
the Item — Part/Document and setting the respective Page Two attributes DocType, Filter and
TemplateHolder.

Note This sample PX binds the Event to update the Title Block, which is not necessary
because the Action menu Event alone will generate the required XML. Therefore, binding
this PX to Create Items, leads to a recursive situation because this out of the box PX
creates a document and attaches the XML file to the document,

Configuring Event Components for DataGenerationPX

These configurations are similar to the two preceding PXs. The Script PX or Java PX Event
Handlers call the SDK Agile API to load Data for the object and add it as an attachment to the
object.
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To create Event mask and set Event Type:

1. Follow the steps in Configuring Event Components for TemplateMgtStructureCreationPX on

page 25 and define an Event called Create Object for Object Type Part and the following

settings:
Figure 28: Create Event mask for DataGenerationPX
Create Event El
Event Type | Creake Object v
Mame [createPart A
APTMame [CreatePart 2]

Description

Enabled | Yes

Obiject Type | Part

2. Click OK.

To set up the Event Handler mask:

1. Use the information in Configuring Event Components for TemplateMagtStrucCreationPX on

page 25 and create a new Event Handler mask (Script PX, or Java PX) called part creation.

2. Set Enabled to Yes, and for Role, select the applicable roles. For example, Quality
Administrator, Quality Analyst, Quality Analytics User. For Event Handler Type, you have the
option to select Script PX, or Java PX. You can find the Oracle supplied Script and Java PX in

Doc-Publishing folder in SDK_samples.zip.

3. To configure your Script PX or Java PX Handler Type do as follows.

= For Script PX Event Handler:
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Figure 29: Creating a Script PX Handler for DataGenerationPX
=10l |

Taners s [ esory [H

u]

1.

In Create Event Handler, paste the contents of Data Generation Groovy Script file in the
dialog's Script box and then click OK. For more information, see Agile PLM Events and Event
Framework chapter in Agile PLM SDK Developer Guide. You can also find information on
configuring Script PXs in Agile PLM Administrator Guide. Following is an example of a Script
PX Handler.

[l Event Handler:part creation

Handler Type I‘r'ir" [ ;I

Mame  [nart creation

AFT Hame  [PartCraation A

Dezrption |

Role  or;Report Manager;Report User;Resource Pool Administrator;Resour 4|

Enabled IVS LI
Scripk TIOTESEETIan satenn = on) W =
IEveriInfo req = obj,getPEEventInfol);

ey {

int eventTDe=ren.0etEvent Tvpe();
ink
trigget Type=req . getEvent TrgoerTypel);
F{ everk Typel =EvenkConskants, EVEMT_CREATE_OBIECT G
triggerType!=EventConstants, EVENT _TRIGGER_POST)
Ehrow new
wgleDSLExCeption( ' The Fx is only applicable for post oreate
ervart");
IZreateEventIrfo
nfo={1CreateEventInforeq;
Inbzger
nersubiClassld=nfo.getNessubdassid();

Tadrrin

bdmin=session. getAdmininstance!); =l

For Java PX Event Handler mask:

1.

Click OK.

Make sure the Event Action for this Java PX is deployed. See Creating JAR Files and
Deploying PXs (Event Handlers).

Check the values in DataGeneration.properties file and make sure they conform with Java
Client Admin settings shown in Properties File Settings for DataGenerationPX on page 37.

To configure the Event Subscriber mask:

1. In Java Client with Admin privileges, select Admin > System Settings > Event Management > Event
Subscribers.

2. In Event Subscribers pane, select the Newif button to open the Create Event Subscriber dialog.

3. Create a new Event Subscriber called item creation with settings shown in the following figure.
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4. Click the drop-down arrow to select the Event mask and Event Handler mask you created

earlier.

Figure 30: Creating an Event Subscriber for DataGenerationPX

Create Event Subscriber @

Mame
AP Name

Description

Enabled

Event

Event Handler
Trigger Type
Execution Mode
Order

Errar Handling Rule

on Createltem

CnCreateltem

‘fes
rreaterart
part Creation
Post
Synchronaus
a

Stop

5. Click OK.

Properties File Settings for DataGenerationPX

Values set in the Oracle supplied Properties file are shown in the shaded region of the following
illustration. Make sure these values conform to Java Client Admin settings for this PX.

Figure 31: Properties file settings for Data Generation PX

DATA_OBIECT _MUMBER

DATA_FILE_MAME
DATA_FILE_DESCRIPTION

#

#

#

#

#

#

# ACS_FILTER_ATTRIBUTE
#

#

#

#

# LOGGEING
#

TEMPLATE_SUBCLASS_API_MAME = —————————

value for this property must be API name of a sub <lass of "Documents" class, objects of
which will be created to hold the ML data of an object.

This property defines the constituents of the quEC‘E number of the ohject which wil hold

the ML data in its attachment tab. Incase no walue is specified fot this property, the

ML data will would be added an an attachment to the object from which the "Data Generation"

action is triggered.

This property defines the nae of the acs(agile content service) filter to be used while
genratin? the =ML data file.value for this should be API name or base id of the page two attr
which hoTds the filter name.

This property defines the constituents of the file name of the XML data file.

This property defines the description for the =ML data file.

—————— This accepts truesfalse as value. when this is set to true log messages gets
printed on the application server console

LOGGING=TIug

TEMPLATE_SUBCLASS_APT_MNAME=DoOcumentTemplate
DATA_OBIECT_WUMBER="Ag1]ebata"+0BIECT_NUMBER

ACS_FILTER_ATTRIBUTE=1302|

# API_NAME  mmmmmmmm o Indicates API name of the ohject's class for which »ML data file is being generated
# CLASS_MAME  mmmmmmmm Indicates <class name of the object's class for which =ML data file s being generated
# CLASS_ID  mmmmmmmeeeo Indicates class id of the object's <lass for which ML data file is being generated
# OBJECT_MUMBER ~ ———mmmmmm o Indicates number of the ohject for which »mL data file is being generated

# note: no oproperty should be removed from this property file

DATA_FILE_MAME="Agilebata"+"_" +API_MAME+ “.xml"

DATA_FILE_DESCRIPTION="Agile pata for "+0BIECT_MUMEER
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If there are no changes to the PX, you can use the JAR files described in Creating JAR Files and
Deploying PXs (Event Handlers). If you need to modify the Java or Script PX, then do as follows:

For Java PX:

1. Copy “DataGenerationPX.jar” to “<AgileHomeDir>\integration\sdk\extensions”.

2. Unpack “DataGenerationPX.jar” to gain access to “DataGeneration.properties” file.
3. Update as needed.

4. Repack and redeploy to PLM server.

For Script PX:
1. Open the Handler in PLM client.
2. Configuration is at the beginning of the Script. Modify the Script as needed.

3. Save the modified Handler.

Modifying the DataGenerationPX Script

The Sample creates a Document and then attaches the XML file to the new document. A better
behavior is to simply attach the XML file to the source object, especially when dealing with
processes such as Problem Reports.

To change this behavior, modify the script as shown in the bold font blow.

try {
String TEMPLATE SUBCLASS API NAME="DocumentTemplate";

String DATA OBJECT_NUMBER="OBJECT_NUMBER™";

String DATA FILE NAME=" \"AgileData\" + \" \"
+API_NAME+\".Xml\"";

int ACS FILTER ATTRIBUTE=1302;

String DATA FILE DESCRIPTION=" \"AgileData for \"+OBJECT_NUMBER";
ITable attachmentTable =null;

IAgileObject agileObject=null;

String msg="";

Output Generated by DataGenerationPX

When triggered from the Actions menu, the PX will perform the following:
1. Gets the current object data using the Agile SDK

2. Gets the Template BOM ID, filter ID, and output format using Page 3 attributes in the property
file

3. Creates a Document and attaches the XML file to the new document

The output of the PX is an XML file. The naming convention for the Data XML file is
<ObjectSubclassName>:<ObjectName>:<Rev>:<DataSuffix>.<XML>.
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These attributes are defined as follows:

o ObjectSubClassName — This is the name of the Subclass. For example, Documents.
o ObjectName — This is the instance of the Object. For example, DO00001.

@ Rev- This is the Revision name/number.

o DataSuffix — This is set by the user in the Properties file.
Figure 32: Document:D00006:A:Data. XML

<?xml wersion="1.0" encoding="UTF-8" 7=
- <AgileDatas
- <Document:
- <TitleBlock=
«number=D0O0D006 </ number:
<itemType=Document=/itemType:
ifecyclePhase =Preliminary </lifecyclePhase
<description>TESTING BUILD#38 </description =
<itemCategory >Electrical </itemCategory »
<size=A</size»
<productLineS:=
«Value=Leo</Value=
«Value=Pisces </\Value=
</productLineS=>
=shippableltem=Yes</shippableltem:
<thumbnail=http:/ /DTP-VKOTHAND-WF.agile.agilesoft.com:8080/Filemgr/DownloadServlet?
token=A0C64F834DADED35C926E07C85F558A1C0B9674EF343B10137B261C4A08A3130DB6820E3D6ASECBADCS887A723C33E6AB9326FE481B686C3728D:
</TitleBlock:>
- <Attachments>
<thumbnail=http:/ /DTP-VKOTHAND-WF.agile.agilesoft.com:8080/Filemgr/DownloadServlet?
token=9CE34EBDE5870CF43DCE3C365E0D104F5B30338632684A3BBAD019C9342183BDEF6157E8A9A78C64C3F02267D2B79C48520E6BD538872BD0OF917
<filename =Blue hills.jpg</filename:=
«fileSize=28521</fileSize =
fileType =jpg</fileType=
«<folderNumber >FOLDERDDO16 </ folderMumberz
<folderVersion=1</folderVersion:
«modifiedDate>2010-04-27T04:54:33Z </modifiedDate =
«lastviewDate>2010-04-27T04:54:337 </lastViewDate >
«<checkinUser=Administrator, admin (admin)</checkinUser>
</Attachments>
<BOM /=
- <PageTwo>
<DocType=HTML</DocType:
«Filter=Itemtabs </Filter>
<TemplateHolder-D00004 </ TemplateHolder=
</PageTwoz
</Document:
</AgileData>
< >

Building Bl Publisher Templates

To build a template, you need the Schema XML and Data XML files. For Doc-Publishing purposes,
these are the files that are generated by invoking Web Services 1oadXMLSchema and
loadXMLData APIs.

To configure the template
1. Inthe BI Publisher menu, select Insert > Field.

This opens a Bl Publisher screen that lists all available fields from the Agile PLM Schema
previously loaded using their APl Names.

2. Inthe Field selection dialog, point to the field of interest and using Insert, add them in the order
that you want them to appear in the resulting document.

3. Scroll through the list, or use Find Next to select fields, for example, CreateUser.
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4. Using Word features, customize the fonts and other formats of these inserted tags.

Figure 33: Building the Bl Publisher Template
.‘/ﬁg\\l Hd9-0@ -

Home Insert Page Layout References Mailings Review View Add-Ins '@)
Oracle BI Publisher = Data = Insert = Preview ~ Tools = Help
Find [ pagethiee vl Find Next
Menu Commands Custom Toolbars
O Pendingdeclarationsimage -~ —
O Manufactureparthasredine x|
O Mfrname
O Mfrpartnumber
O Mfrpartdescription
O Mfrpartlifecycephase
O Preferredstatus
O Pagethree
number =3
O Textiz
B =N Createuser
itemType
hic O Datedl
IifecyclePhase =2 -
SR
description 2 Humber
O Itemtype
N I
createUser Example Dan Catlisle
Calculation - I~
[” Force LTR Direction
Insert Clase | Help z
=1
Please select a node in the tres, .
[— i I

When you complete the layout, save your Template as an RTF file in the local drive.

From the BI Publisher menus, select Preview Template > PDF (or any format) to see the Data

formatted in your Template.

Copying XSD and XML Files to the Local Drive

In Agile PLM Web client, search by document name and the click the Attachments tab.

To copy XSD and XML files to the local drive:

1. Select the XSD file and either click Get, or double-click on the file.
Figure 34: Downloading XSD file to local drive

Assembly 2467572

DocumentTemplate « Schema holder for Assembly sub class

Site: Rev: Introductory ¥ Actions ~

Title Block | Changes = Related Documents = Where Used

Attachments *

Altachments
Add | ~ || Remove Get || Open || View ™ CheckOut || Cancel CheckOut || Checkin hore ¥
«/ 4 Filename File Description File Size File Type Folder Number  Folt
| Schema_Assembly. xsd Agile schema for Assembly 39,350 xsd FOLDERDOOSO
[Z] Doc2nif Description 33,858 rf

Preliminary

Unincorporated

History

2. Select the applicable Download method and then save the file to the local drive.
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3. Repeat the process for the XML Data file.
Figure 35: Copying XML File to the Local Drive

ASM-00126 Preliminary
Assembly * Deme Jan 22, 2010 test Unincorporated
Site: Rev: | Introductory |¥ E@ Navigator || Actions ¥

Title Block | Changes | BOM® | Manufacturers | Sites | Prices : Qualty | Compliance = Suppliers | Relationships | Where

Attachments
Add | ~ || Remove Get || Open || View ¥ CheckOut || Cancel CheckOut || Checkin More =
+/ % Filename File Description File Size File Type Folder Number  F
[E] AgileData_Azzembly.xml Agile Data for ASM-00128 630 xml FOLDERO0O1002

Loading Schema XSD and Data XML Using Bl Publisher Plugin

The following procedure assumes that you have already:
= Installed Bl Publisher Desktop on your system

o Ran the SchemaGenerationPX and DataGenerationPX and created the Schema XML and Data
XML files.

To load the Schema XSD and Data XML files:

1. Open the document that you want to generate. For example, a data sheet containing text that is
describes and is not subject to change and variable (data) such as Part Number, Date, and so
on that you want to update with Agile PLM data for publication.

2. Save the Word document as an .RTF file and then load the XML Schema and XML Data files.

3. Open Microsoft Word and select Add-Ins > Data.
Figure 36: Load XML Schema and XML Data

ﬁ_q =) R 9.3.1 Agile PLM Document Publishing Installation_and_Setup_Guide.doc [Compatibility Mode] - Microsaft Word - =X

-’ Hame Insert Page Layout References Mailings Review View Add-Ins ‘1}1
Cracle BI Publisher ~ |Data ~\Insert ~ Preview = Tools - Help ~
55 Load XML Data...

5| Load XML Schema...

Menu Commands COetam Tooiman

4. Select Load XML Data... and then Load XML Schema...to load the files.

Word will display "Data loaded successfully" after each action.

Loading the files enables Bl Publisher to access Agile PLM fields in the XML file that were defined
earlier for the Subclass. For example, for "Documents" subclass defined in Creating a Placeholder
for Template Files, you can use all features of Word with Bl Publisher to create a template for the
data sheet.
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Selecting Agile PLM Data Fields and Formatting the Template

Bl Publisher facilitates selecting Agile PLM data fields and provides extensive facilities to format the
data and output document.

To configure the template

1.

3.
4.

In the Bl Publisher menu, select Insert > Field.

This opens a Bl Publisher screen that lists all available fields from the Agile PLM Schema
previously loaded using their APl Names.

In the Field selection dialog, point to the field of interest and using Insert, add them in the order
that you want them to appear in the resulting document.

Scroll through the list, or use Find Next to select fields, for example, CreateUser.

Using Word features, customize the fonts and other formats of these inserted tags.

Figure 37: Building the Bl Publisher Template

(D) d9- V&)~
)

Home Insert Page Layout References Mailings Review View Add-Ins

QOracle BI Publisher = Data = Insert = Preview ~ Tools = Help p— =
Field =13
gid pagethies ¥ Find Next

Menu Commands Custom Toolbars

O Pendingdeclarationsimage ~
O ManuFactureparthasredine
O Mfrname
O Mfrpartnumber
O Mfrpartdescription
O Mfrpartlifecyclephase
O Preferredstatus
O Pagethree
number SRES)
O Textlz
itemType Creabeuser
hic O Datenl
lifecyclePhase =5
o =B
description 2 Humber
P o It‘smtyFeL [% 2
createUser Example Dan Cartlisle
Calculation -
I Force LTR Direction
Inserk Clase | Help %
Flease select a node in the tree, :
4 | m | ]
5.  When you complete the layout, save your Template as an RTF file.
42 Agile Product Lifecycle Management



Chapter 4: Getting Started with the Sample

6. From the BI Publisher menus, select Preview Template > PDF (or any format) to preview the Data

formatted in your Template.
Figure 38: Viewing the Template

Home Insert Page Layout References Review View Add-Tns
Calibri (Body] -|18 - AR EEmie ety &= 9 AaEb(‘ch" A
) B £ U-shexhx As- - A- | =[S = T Hormal | Th
rd Fant 5 Paragragh T
1‘----‘5-‘-|‘--1--‘|-~2 B Ca 4
itemType number rev
description

Inserting Agile PLM Data Fields in the Template

Use the following procedure to insert the necessary data.

To insert Agile PLM data in the template:

1. Inthe Bl Publisher menu, select Insert > Field.

This opens a Bl Publisher screen that lists all available fields from the Agile PLM Schema

previously loaded using their APl Names.

2. Inthe Field selection dialog, point to the field of interest and using Insert, add them in the order
that you want them to appear in the resulting document.

3. Scroll through the list, or use Find Next to select fields, for example, CreateUser.

4. Using Word features, customize the fonts and other formats of these inserted tags.

Figure 39: Building the Bl Publisher Template

(Op)\d2- 6 &
)
- Home Insert

Oracle BI Publisher ~
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o Hhmams
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O Mhpsrtdsscription
O Mhmsrtiferycsphase
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0 Textiz
o (R
o Datent
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=
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O Temtyps s
v
Exerle Dian Carlisls
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[~ Force LTR Direction
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|

5.  When you complete the layout, save your Template as an RTF file.

?
z
o
13
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6. From the BI Publisher menus, select Preview Template > PDF (or any format) to preview the Data

formatted in your Template.
Figure 40: Viewing the Template

Hame Insert Page Layout References Mailings Review View Add-Ins
Calibri Body] - -[& KB [EE e v Aagbcca(.‘ Al
} B £ U-asexkx far B-A- (S= =||Ba= e 1 nomal [T
d Font IFy Paragragh i
1§|1|23 ' 4
itemType number rev
description

Inserting and Formatting Tables

Using BI Publisher, you can insert and represent Agile PLM fields in a tabular form. Bl Publisher's
Table formatting to combined with Word, provide rich formatting capabilities, for example,
generating totals for numeric fields in columns or rows. For more information, see Bl Publisher

document in listings in Cited References on page 2.

To present Agile data in tabular form:

1. In Word with Bl Publisher Desktop, select Add-Ins > Insert > Table Wizard. The Wizard prompts

you to select the grouping fields that you want to report on.

Figure 41: Inserting and formatting tables

Table Wizard

Which grouping field do you want to report on?

Data Set Apile DatarDrawing hd

AgileData/Draving
AgileData/Drawing/ Tils Block
AgileData/Draving/This Black/product Line S
AgileDeta/Drawing/Change History
AgileData/Draning/Page Two
Ayl Data/Document
AgileData/Document/Tie Black
AgileData/Document/Change History

Help Cancel Back Mext
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2. Select the applicable group, for example, AgileDocumentTitleBlock.
Figure 42: Represent Agile data in a tabular format

En1 H9-0E - XML_Data_4.rif - Microsoft Ward - = x
a -
=/ Home Insert Page Layout References Mailings Review View Add-Ins (7]

Oracle BI Publisher - Data '|[nsert' Preview = Toals = Help =
ab| Field...
] Table Wizard...
Menu Commands = Table/Form..
Pivat Table )|
number
il chart. i
descript Repeating Group... E
Type Conditional Format...
status Conditional Regian...
]
Fumber Al Fieles [ TTwe [Status | |
F number | gescription | TvpE | statusE | a
o
o
=
Page:1 of 1 | Words: 14 [EEEEET e [) ()2

3. Select the fields and then format the table.
Inserting Images and Charts in Templates

Bl Publisher supports several options for adding images in a published document. These options
require including the image files in the document Template.

These options are:
o Direct insertion
= Using a URL Reference

o Referencing Elements in XML Files
To directly insert an image or chart:

Similar to inserting images or charts in Word documents, you can simply insert or paste JPG, GIF,
or PNG images directly in the RTF Template.

To insert an image using a URL reference:

1. Insert/paste an image in the Template file. This is used to access MS Word's Picture Format
dialog box.

2. Depending on the version of Word you are using do as follows to open the Alternative text box:
* In Word 2007, right click the image and select Size > Alt Text.

* For earlier versions of Word, right click the image and select Format Picture ... in the drop-
down list and then select the Web tab.
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Figure 43: Referencing a URL in earlier  Figure 44: Referrning URLs in Word 2007

versions of Word f 2%
Format Picture @ Size | AltText
Calars and Linas] Size ] Layout 1 Picture ] Web l Alternative text:
Alternative best: url:http:/f<location_of_the_image =}

.url:{http;’,l’<location of_the _image}

‘Web browsers display alternative text while pictures are loading
or if they are missing. Web search engines use alternative text to
help find Web pages. Alternative Text is also used to assist users
with disabilities.

‘Web browsers display alternative text while pictures are loading or if they
are missing. Web search engines use alternative text to help find Web
pages.

o | conce

3. In Alternative text box, type the URL pointing to the location of the image using this syntax:
url:{'http://<location_of the image>'}. For example,
url:{'http://www.oracle.com/images/ora_log.qif"}

To reference an element in an XML File:
1. Similar to inserting an image using a URL reference, insert/paste an image in the Template file.
2. Open the Alternative text box as you did in "To insert an image using a URL reference:" above.

3. Inthe Alternative text box, type the path to the image, using this syntax
url:{IMAGE _LOCATION}. IMAGE_LOCATION is an element in the XML file that holds the full
URL to the image.

By using the concat function to build the URL string, you can build a URL based on multiple
elements at runtime. For example, url:{concat(SERVER,/ . IMAGE DIR,/,IMAGE_FILE)},
where SERVER, IMAGE_DIR, and IMAGE_FILE are element names in the XML file that holds
the values to construct the URL.

Loading the Template into Agile PLM

This is done using Web client's Add function as shown below.

To load the Template into Agile PLM:

1. Log into Agile PLM and select the folder you want to load the file into. In this case,
DOCUMENT_TEMPLATE that you defined earlier.

2. Select Attachments > Add. The Add Files dialog opens.
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3. In Add Files dialog, use Browse to locate the file on the local drive and then click the ¥ #
button.

Figure 45: Loading the Template into Agile PLM

4 » [ L 3 Create Hew Q, ~ *Document_Template w || OF
Search Resultz » DOCUMENT_TEMPLATE
DOCUMENT_TEMPLATE Preliminary
DocumentTemplate Unincerporated

Site:

= http:f/cognition.agile.agilesoft.com/ - Add Files - Windows Internet Ex... E|E|g|

Tt Bock  Chanfl A dd Files B

DocumentTemplate * DOCUMENT_TEMPLATE

Attachments ¥ Browse for files to add. Zipped files can be unzipped and added as individual files by checking the alize | «
Unzip option. Help Link
| Add | = || Ren . . Cancel
b d Filename Description
ChData_Files\Data_Files  Browse...
Browse...
Browse...
=+ Browse...
Browse...

Ticme: | File Folder Lv3 [T rdd all files tn 2 sinals fils faldar

« Add || @ Cancel

0 of 0 rows selecten

4. Repeat the process to load other files.

Configuring DocumentGenerationPX

Document Generation provides the following options to publish a document:

o DocumentGenerationJavaPX — This PX generates a file based on a Template and using Bl
Publisher

= DocumentGenerationJavaPxOpen — This PX opens the document instead of saving it as an
attachment

Configuring DocumentGenerationJavaPX

The purpose of the Oracle supplied Document Generation PX is to programmatically generate a file
based on a Template and a PLM object and use Bl Publisher as the Document Publication engine
to publish the file/document.

As prerequisite, this PX requires an object number for the TemplateHolder attribute, for example,
P00001, or PO0021.
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Configuring Event Masks for DocumentGenerationJava PX

Similar to the preceding PXs, you must create an Event and set Event Type, Event Handler, and
Event Subscriber for the Java or Script PX. Upon the release of an ECO, the PX loads all items
from the BOM tab and will Generate Document from each BOM item using the Agile embedded BI
Publisher.

To create Event mask and set Event Type:

1. Follow the steps in Configuring Event Components for TemplateMgtStrucCreationPX on page
25 and define an Event called CreateDocument for Object Type Change Requests with the
following settings:

Figure 46: Configuring Event type for DcocumentGenerationJavaPX

Event TYpe | Change Stakus For Workflow o
Name CraateDocum}tnt 5]
API Mame | CreateDocument =]
Descriphion | Create Document on release of change
Enabled | vyes b
Wworkflow | pefaul Change Requests 3
Object TYPe | Change Requests 3
Status - From [CCB E1]
Status - To Released E1]

2. Click OK.

To set up the Event Handler mask:

1. Use the information in Configuring Event Components for
TemplateManagementStructureCreation PX on page 25 and create a new Event Handler mask
(Script PX, or Java PX) called GenerateDocument.

2. Set Enabled to Yes, and for Role, select the applicable roles. For example, Quality
Administrator, Quality Analyst, Quality Analytics User. For Event Handler Type, you have the
option to select Script PX, or Java PX. You can find the Oracle supplied Script and Java PX in
Doc-Publishing folder in SDK_samples.zip.

3. To configure your Script PX or Java PX Handler Type do as follows.

@ For Script PX Event Handler mask:
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In Create Event Handler, paste the contents of Document Generation Groovy Script file in the
dialog's Script box and click OK. For more information, see Agile PLM Events and Event
Framework chapter in Agile PLM SDK Developer Guide. You can also find information on
configuring Script PXs in Agile PLM Administrator Guide. Following is an example of a Script
PX Handler.

Figure 47: Creating the Script PX Handler for DocumentGenerationPX

#8 Event Handler:GenerateDocument

i General Information i where Used | History |

Handler Type

Marne: |GenerateDocument

APIMame  |GenerateDocument

Deescription |Generate document upon release of the ECO.

Role  jge Analyst;Compliance Manager; Compaonent Engineer; Configu 3]

Enabled | Yes - |

SEAPE limport com. agile. agileDSL. ScriptObj. IBaseScriptObyj; ~
import java.io.BufferedInputstrean; =
impart java.io.BufferedOutputStrean;

impart java.io.File;

import java,io, FileInpukStream;

impart java.io.FileMotFoundException;

impart java.io.FileOutputStrearnn;

import java,io, IOExcepkion;

import java.io InputStrean;

impart java.util. HashiMap;

import java,util. Ikerator;

impart java.util.Map;

impark java.util.Properties;

import java,util,zip, ZipInputStrean;

impart com. agile. api.*;

import com, agile. api.pc. Session;

impart com.agile.api.pc. attachment, IFSInputStrearn;
impart com. agile. poc. ActionResult;

import com, agile. px, EventActionResult;

impart com.agile. px, IEventAction;

impart cam. agile. pe. IEwentInfo;

impork com. agile. px, I0bjectEventInfo;

impart aracle.apps.xdo . XDOException;

impart aracle.apps.xdo.template. FOProcessor;

8 For Java PX Event Handler mask:

a. Make sure the Event Action for this Java PX is deployed. See Deploying PXs (Event
Handler masks).

b. Check the values in DocumentGeneration.properties file and make sure they conform with
Java Client Admin settings shown in Properties File Settings for
DocumentGenerationJavaPX on page 50.

4. Click OK.
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To configure the Event Subscriber mask:

1. InJava Client with Admin privileges, select Admin > System Settings > Event Management > Event
Subscribers.

. Hpa . .
In Event Subscribers pane, select the Newié button to open the Create Event Subscriber dialog.

3. Create a new Event Subscriber called GenerateDocument with settings shown in the following
figure.

4. Click the drop-down arrow to select the Event and Event Handler you created earlier.
Figure 48: Creating an Event Subscriber for DataGenerationPX

Create Ewvent Subscriber El

Mame  [on Createltem ]
APT Mame  [OniCreateltem =]

Description |
Enabled |yes ~
Event createPart =]
Event Handler part Creation [E Y]
Trigger Type | post b
Execution Mode Synchronous -

Order |g
Error Handling Rule | stop -

5. Click OK.

Properties File Settings for DocumentGenerationJavaPX

Values set in the Oracle supplied Properties file are shown in the shaded region of the following
illustration. Make sure these values conform to Java Client Admin settings for this PX.
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Note These Properties file settings also includes the ones for

DocumentGenerationJavaPxOpen.

Figure 49: Properties file settings for Document Generation Java and JavaOpen PX

# API_NAME = aPI name of the class in the object number
# CLASSMNAME = name of the class to the object number
# CLASSID = class id to the object number

# REV_NUMEER
#report type.. Ex pdf,html...
ATT_DOCUMENT _TYPE =1271

#attribute which has templete
ATT_TEMPLATEHOLDER =1302

#name of the filter
ATT_FILTER =1301

#Genenrated document file.
DOCUMEMNT _FILEMNAME

#cenenrated document file desc
DOCUMENT _FILENAME _DESC

#oocument templete subclass.
TEMPLATE_SUBCLASS_API_MAME = DocumentTemp]ate

#target object, where report will be saved
TARGET_DOCUMENT _MAME = "DOCUMENT " + CBIECT_MAME + "_" + REV_MAME

#to enable logging

rev number of item.

OBJECT_MAME + "_" + REV_MNAME

"Document of the Item” + OBJECT_MAME + " Change " + REV_NAME

Toging = true
BB BB R RO B
settings for Javaopen Px
OPEN_REPORT = trug
IS_CHANGE_CBIECT = trug

FILESERVER_URL

Output Generated by DocumentGenerationJavaPX

When the PX is triggered upon the release of an ECO, it will:

1.

o g M w

Load the Affected Items Tab of the change and calls the SDK to get the data for the Affected
ltem

Use the settings in the Properties file for the following P2 Item attributes:
®* TemplatelD

* ACS filter name

* Document Type

Load the template using the P2 Document Number attribute for the Item
Call the SDK to load the data for BOM items
Call Bl publisher and pass the data Template to generate the document

Save the document along the naming convention for the generated file in the Attachments Tab

Note The PX creates a separate document object and attaches the output file to this object.
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The naming convention for the generated file is <ObjectSubclassName> :<ObjectName>
:<Rev>:<templatelD><documentSuffix>.<documentType>.

These attributes are defined as follows:

o ObjectSubClassName — This is the name of the Subclass. For example, Documents.
o ObjectName — This is the instance of the Object. For example, DO0O0001.

@ Rev- This is the Revision name/number.

@ TemplatelD — This is the template name.

= DataSuffix — This is set by the user in the Properties file.

@ DocumentType — This is the format of the output file. Options are PDF, EXCEL, HTML, RTF and
PowerPoint.

Figure 50: DocumentGeneration PX output in PDF format

@ PUDUOE_DE. pdf - Adobe Header:

File Edit View Document Tools ‘Window Help *®

ﬁ #—- 1|3 = & e32% v - = B
~
EOM
Itemnumber Iltemdescription Qty Bomnotes
D00011 Value generated for 1 Testing

Title Block Attributes

Number PO0008
Part Type Part
Lifecycle Phase Preliminary
Description Data file

AgileData_DocumentTemplate.xm
| generated sucessfully and
uploaded to DocumentTemplate

Part Category Software

Size G [%
Product Lines Capricorn

Rev Release date 2010-08-16T10:40:247

Note When creating Events, Event handlers and Event subscribers, you must enable the
Event by clicking on the enable button in Java Client to see the Events in their respective
actions. If Events are disabled, you cannot see the Events under their respective actions.
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Configuring DocumentGenerationJavaOpen (URL PX)

The DocumentGenerationJavaPxOpen or URL PX, instead of saving the document as an
attachment, displays the output generated by the DocumentGenerationJavaPX in the URL that you
specified in Java PX's Properties file, or in Script PX's Groovy script.

Use the following procedure to setup the URL PX.

To setup the URL PX:

1.

Unzip URLPX.zip to tomcat directory at tomcat\webapps.
After unzipping, you will see the URLPX directory in tomcat\webapps.

Edit the tomcat\webapps\URLPX\WEB-INF\ web.xml by changing the http://shahdesk-
dgx520.agile.agilesoft.com:8888/web to your application server hostname.

Type the correct value for FILESERVER_URL in Tomcat\webapps\URLPX\WEB-
INF\classes\samples\DocumentGeneration\DocumentGenerationJavaPxOpen\
DocumentGeneration.properties.

In Java Client, with Admin privileges, select Admin > Data Settings > Process Extensions.

The Process Extension Library panel opens.

In Process Extension Library, select the Newif button to open and configure the Add Process
Extension dialog as shown in the following figure.

Note The Address field should point to the Filemanager. For example,
http://<filemgerHost>:<FilemgerPort>/URLPX/PX.

Figure 51: Creating a URL PX

‘S Add Process Extension E|
Marne [
APT Marme  [Urlpx A
Descripkion
TyPe |URL h

Address gerHost = <FilemgerPort = /LRLPRPY

Initiate From  Actions Menu [
Enabled |vyes v
Click OK.
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Properties File Settings for DocumentGenerationJavaOpen PX

To configure file settings:

1. Navigate to the respective object, for example, Items > Documents class.

2. Navigate to Process Extensions tab of that Document class and add this url px which has been

created.

3. Use these steps for other objects of interest.

DocumentGenerationJavaPx0Open Output Sample - Keep or Remove?

When the PX is invoked from the Actions Menu, it will open the document in the specified URL in

HTML format.
Figure 52: Output of the URL PX
e @ | @ Eom Table 3 Home [ TReadMai R Print - [bPage - G Todls v
~
JAVA PX
BOM %
Itemnumber Itemdescription Qty Bomnotes
D00011 Value generated 1 Testing
for
Title Block Attributes
Number POO0O08
Part Type Part
Lifecycle Phase Preliminary
Description Data file

AgileData_DocumentTemplate.xml
generated sucessfully and
uploaded to DocumentTemplate

Part Category Software
Size G
Product Lines Capricorn

Rev Release date

2010-08-16T10:40:242
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Chapter 4: Getting Started with the Sample

Triggering DocumentGenerationPX

On releasing the trigger (for example, a change), this PX generates a report with the file extension
defined in DocType and attaches it to the object specified in TemplateHolder. As prerequisite, it
requires assigning an existing object number for the TemplateHolder attribute.

Note The required prerequisites are defined in Agile PLM Administrator Configurations on
page 14 and Configuring DocumentGeneration PX on page 47.

Modifying DocumentGenerationPX

Sample creates a Document object and then attaches the output file to the new document. Oracle
recommends attaching the output file to the source object, especially with processes such as
Problem Reports.

Note Be sure to specify the correct location of the Template because getting the Template
retrieves the first file from the specified object.

To modify the PX, for example, to change the name of the document from Document name, to
Document and Object name, modify the PX's Properties file as shown below.

Demonstrate how to alter the script to change the attachment locations

Public ITem getTargetObject (IAgileSession session, Item object)throws
Exception{
private static final String TEMPLATE SUBCLASS API NAME =
"documentTemplate";
private static final String TARGET_DOCUMENT_NAME =
"DOCUMENT + OBJECT_NAME";

Triggering the Event and Creating the Output File

To trigger the Event and generate the sample document:

1. Make sure the object to be processed has the correct configuration with Template, Filter, and
output file type in Script PX Code, or Java PX Properties file. In this case, the settings are as
shown below.

¢ OQutput Type = PDF
* ACS Filter = Itemstabs
®* Template Holder = D-00004
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2. Trigger the Event (release the ECR).
Figure 53: Releasing the ECO to trigger the Event

R0O0007 Released

ECR * testr

W Rejec O Comment (% MextStatus | « || Actions ¥

Cover Page | Affected tems® | Workflow ® | Relationships | Attachments | History

Affected ltems

Ad ovE More ~
+ ltem Humber | #F Item Description Revision
‘55!.'—00136 Demo Jan 22, 2010 test

LifeCycl

3. Open the resulting document.
Figure 54: Creating the output file

Preliminary

Unincorporated

DOCUMENTASM-OC?%S_I ntroductory

DocumentTemplate
She: Rev: | introductory |3 Actons ¥

Where Usad | Attachments ® | History

Titke Block = Changes = Related Documents

Attachments
Add | Remove | | Gel || Open || View ~ | CheckOut || Cancel CheckOut || Checkin More ~
' #” Filename File Description File Size File Type Folder Number
[] ASM-00126_introductory. pdt Document of the RemASH-0 1,417 pdf FOLDERDOD1003

Fold

56

Agile Product Lifecycle Management



	Oracle Copyright
	 New in Release 9.3.1.1
	About this Whitepaper
	Content and Organization
	Intended Audience
	 Cited References
	Oracle Agile PLM
	Oracle BI Publisher

	SDK Samples Folder and Document Publishing Examples

	Dynamic Document Publishing
	Overview
	 Solution Architecture
	Operating Environment
	 Oracle Agile PLM
	Oracle BI Publisher
	Microsoft Word 2003/2007 and BI Publisher

	 Process Outline
	 Understanding the Process
	Datasheet Configuration in Agile PLM
	Generating the Data XML File
	Creating and Testing the Template
	Testing/Viewing the Template

	Combining XML Data with Template - Publishing the Document



	Setting Up the Environment to Publish Sample Documents
	Overview
	Prerequisites 
	Configuring Agile PLM Administrator 
	Configuring Agile PLM Server  
	Getting Started with Document Publishing

	Installing BI Publisher Desktop
	Agile PLM Administrator Configurations
	Creating  the DocumentTemplate Subclass
	Configuring Agile Content Services Filters
	Defining Page 2 Fields for the Object
	Defining Agile Content Services Filter for XML Data


	 Agile PLM Server Configurations
	Understanding Process Extensions and Events Framework
	 Using Oracle Supplied Document Publishing Samples
	Working with Script and Java PX Handlers


	Getting Started with the Sample
	Task Sequence
	Configuring TemplateManagementStructureCreationPX
	Configuring Event Masks  for TemplateManagementStructureCreationPX
	TemplateManagementStructureCreationPX
	Output Generated by TemplateManagementPX

	Configuring SchemaGenerationPX
	Configuring Event Components for SchemaGenerationPX
	Properties File Settings for SchemaGenerationPX
	Output Generated by SchemaGenerationPX

	Generating Schema XSD and Data XML files
	Configuring DataGenerationPX
	Configuring Event Components for DataGenerationPX
	Properties File Settings for DataGenerationPX
	Modifying the DataGenerationPX Script
	Output Generated by DataGenerationPX

	Building BI Publisher Templates
	Copying XSD and XML Files to the Local Drive
	Loading Schema XSD and Data XML Using BI Publisher Plugin
	 Selecting Agile PLM Data Fields and Formatting the Template
	Inserting Agile PLM Data Fields in the Template
	Inserting and Formatting Tables
	Inserting Images and Charts in Templates

	Loading the Template into Agile PLM

	Configuring DocumentGenerationPX
	Configuring DocumentGenerationJavaPX
	 Configuring Event Masks for DocumentGenerationJava PX
	Properties File Settings for DocumentGenerationJavaPX
	Output Generated by DocumentGenerationJavaPX

	 Configuring DocumentGenerationJavaOpen (URL PX)
	 Properties File Settings for DocumentGenerationJavaOpen PX
	DocumentGenerationJavaPxOpen Output Sample - Keep or Remove?

	 Triggering DocumentGenerationPX
	Modifying DocumentGenerationPX

	Triggering the Event and Creating the Output File


