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THIS SOFTWARE IS PROVIDED “AS IS,” WITHOUT A WARRANTY OF ANY KIND. ALL EXPRESS
OR IMPLIED CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY
IMPLIED WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR
NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN MICROSYSTEMS, INC. (“SUN”) AND ITS
LICENSORS SHALL NOT BE LIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A
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OR DATA, OR FOR DIRECT, INDIRECT, SPECIAL, CONSEQUENTIAL, INCIDENTAL OR
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SUN HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.
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(1) Redistributions of source code must retain the above copyright notice, this list of conditions and the
disclaimer below. (2) Redistributions in binary form must reproduce the above copyright notice, this list of
conditions and the disclaimer below in the documentation and/ot other matetials provided with the
distribution.

THE SOFTWARE IS PROVIDED “AS-1IS” AND WITHOUT WARRANTY OF ANY KIND, EXPRESS,
IMPLIED OR OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. IN NO EVENT SHALL TOM
WU BE LIABLE FOR ANY SPECIAL, INCIDENTAL, INDIRECT OR CONSEQUENTIAL DAMAGES
OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR



PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY
THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
PERFORMANCE OF THIS SOFTWARE.
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Chapter 1

Overview

This chapter includes a brief overview of Data Manager and how it fits into the Oracle Utilities
(CCS), including:

* Data Manager and the Oracle Utilities Energy Information Platform
*  The Oracle Utilities Data Repository

*  Data Manager Functions

* International and Multiple Currency Support

* Notes, Cautions, and Warnings

Overview 1-1



Data Manager and the Oracle Utilities Energy Information Platform

Data Manager and the Oracle Utilities Energy Information Platform

Using Oracle Utilities software, your utility can bring together, maintain, and maximize the value
of critical customer information, including customer profiles, rate and contract information, bill
histories, and load shapes.

The core of the Energy Information Platform and related Oracle Utilities applications is the
Oracle Utilities Data Repository. The Data Repository stores current and historical customer
profiles, including billing histories, survey data, and any other data your company uses to
understand and serve its customers. Customer data is stored in a relational format for maximum
flexibility. The Data Repository also stores interval data, or time-series data that represents
customer demand and other measurements taken at brief, regular intervals. This data is stored in a
proprietary file format.

Data Manager is a tool for managing this data. It enables you to view, add, delete, edit, query,
import, and export data in the Oracle Utilities Data Repository. If you are a rate designer, billing
analyst, or other specialist, you will use Data Manager to assemble and maintain the customer
information you need to perform a specific task, such as evaluating the impact of a new rate on a
rate class or generating bills for large accounts. When the required inputs have been assembled
using Data Manager, users can apply other Oracle Utilities products to accomplish a specific job.
In addition, Data Manager provides a “window’ on the data, presenting it in a format and detail
level best suited to each user’s needs.
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The Oracle Utilities Data Repository

The standard (or “base”) version of the Oracle Ultilities Data Repository stores information for
two key functions: large account billing and rate design and analysis. However, its use can be
extended to other applications and utility-specific needs.

The categories of data accommodated by the standard version of the database are discussed below.

Customer and Account Information

The first category of information pertains to individual customers and how their bills are
calculated. It includes customer identifiers, account history information, and recorder-channel
information.

Customer Identifiers

There are three levels of customer identifiers for billing and rate purposes: customer, account, and
(optionally) CIS account.

Customer - A customer is the entity that receives the bill. The Oracle Utilities Data
Repository stores a unique ID for each customer.

Account - An account is the entity whose bill determinants are used to calculate the bill. An
account may have one or more meters and/or recorders and recorder-channels.

While one or more accounts may belong to a single customer, and the customer receives the
bill, Oracle Utilities Billing Component does not calculate charges at the customer level.

CIS Account - No? available in all implementations. A CIS Account is any account, service
location, or other entity that has a unique ID in a Customer Information System (CIS).

Note: Internally, Data Manager assigns a unique identifier (UID) to each
customer and account; these are UIDCustomer and UIDAccount. The UIDs
are linked to customer and account records in the Data Repository, even if the
customer and/or account IDs are changed. This enables you to create new
relationships and groupings for customers and accounts without losing track of
them.

Operating Company
An account is billed by a particular operating company, according to the regulations in its
jutisdiction. For each account, the database stotes a unique ID, the opetating company/
jurisdiction to which the account belongs, and the date that it became active. Stop-dates can also
be stored to indicate inactive accounts.

Jurisdiction

An account’s jurisdiction refers to its geographical area (usually state or province). Bills are
calculated based on the regulations that pertain in that jurisdiction.

Account History

The Data Repository stores information about how each account is (and was) billed. For each
category below, the Data Repository keeps track of the version currently in effect, as well as all
previous versions.

Billing cycles - the billing cycle read dates trigger the billing process for accounts that are
billed automatically.

Rate codes - relate accounts to specific rate schedules.

Overrides - enable the application of alternate charges to an account, for discounts or for
special events such as interruptions and backups.
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*  Factors - values identified in a rate schedule script for taxes ot other charges.

Account Data

Usage Data
The Data Repository stores two categories of usage data for each account: bill determinant values
and interval data. Bill determinant values are stored in the Bill History records in the Data
Repository; interval data is stored in the Interval Database.

Bill History
For each account, the Data Repository stores usage values such as kWh or kW that are used to
compute charges for each bill period. Categories of usage values that are used to compute bills are
called billing determinants.

These values may be read from an account’s energy or demand meter and fed into the Data
Repository via your facility’s CIS, or they may be computed by an Oracle Ultilities application and
written back to the Bill History records for each bill period.

When bill history information is changed via the Data Manager, the application automatically
keeps an audit trail.

Recorder/Channels and Interval Data
In addition to metered and computed billing determinants, the Data Repository keeps track of the
account’s interval data recorders. The IDs for these recorders and their channels are the keys for
accessing interval data in the Interval Database. This data may be used for power billing, end use
analysis, and other functions.

Note: Power billing refers to billing large volumes of accounts, and/or billing
accounts with complex pricing requirements.

A recorder is a device used to measure a customer’s demand (kW) or other quantity periodically,
such as every 5, 15, 30, or 60 minutes. This data is “interval data” and is used to determine the
demand a customer places on the system at various times of the day and over the course of a year.

These recorders are usually installed for large customers whose demand has a significant impact
on the system, or for customers who are part of a load research sample.

A recorder may have several data channels, each measuring a different usage value such as kW, or
another quantity such as temperature. For example, a recorder might be installed at an office
building, with each channel assigned to a different office. Or, the recorder might belong to one
account, with each channel assigned to a particular end use such as air conditioning, refrigeration,
or water heating, With some recorders, it is necessary to sum data from a number of channels to
get a total value for a determinant.

For every account in the database that has an interval data recorder, the Data Repository stores its
recorder ID and channel numbers. This identifier -’recorder-ID,channel-number’- is the key to
accessing customers’ interval data records in the Oracle Utilities Data Repository. You can then
apply Rules Language functions to compute billing determinants from this data.

Because recorders and channels can be moved and re-assigned, the Data Repository stores
historical records of each account’s channel assignments, including the unit of measure and end
use being recorded, whether the channel measures a billing quantity, and how the channel’s data
should be combined with the others’ to compute total usage.

Note: There are important distinctions between meters (also referred to as “indicative meters”)
and recorders, and between billing determinants and interval data. A meter is a device that
measures a billing determinant. A billing determinant is a “scalar” value that represents one type
of usage for a bill period—that is, a quantity for the period expressed as a single value. A recorder
measures interval data, which is a series of values for one period and can be considered “raw data.”
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Oracle Utilities Rules Language functions are used to calculate billing determinant values from a
customer’s interval data.

Channel Groups and the Meter Value Table

When you need to track and store the usage for subsets of recorder channels belonging to an
account (for example, when an account has service locations in different tax jurisdictions), Data
Manager lets you subset the channels by assigning each one to a “group.” A group may consist of
one or more channels. You can also group channels differently for different applications.

The Bill History Table stores only one value per bill determinant per bill period for an account.
The Meter Value Table allows users to store the bill determinants for each channel group
belonging to an account, even if the channel groups have the same unit of measure. The
determinants stored in the Meter Value Table are called “bill components.”

System Peak

Billing Accounts

Data Manager stores information about the system peak for use by rate schedules with charges
based on the time of the system peak. This information should be stored in an account record
(where the Account ID is “SYSTEM?”), and its values stored in the Meter Value Table.

Billing and rate analysis require computer-readable versions of contracts, rate schedules, and ridets.
Oracle Utilities provides a powerful language, the Oracle Utilities Rules Language, that you use
to encode virtually any type of rate tariff in a program script. Language statements and functions
access the Customer and Interval databases, compute billing determinants and charges, report the
results, write data back to the Data Repository, and create CIS transaction records.

Before you can create a rate form, you must use Data Manager to create a rate form record. The
rate form record includes an identifying code for the rate form, and descriptive information such
as its type, name, and the Operating Company/Jutisdiction it belongs to. Next, you ctreate a
version record that specifies whether it is a current, historical, or trial version. When the
descriptive records are stored in the Oracle Ultilities Data Repository, you use the Rules Language
Editor to write the rate form script. These scripts consist of Rules Language statements that tell
the application how to calculate and report trial revenue or customer bills.

The rate form records provide a link between the language scripts and the customer and account
history records, keeping track of which rate forms were applied to an account or customer, and
when.

There are three types of rate forms—contracts, rate schedules, and riders:

* Contracts: A contract is a customer-specific rate form that describes the bill calculations or
contract minimums for a single customer account. It is incorporated within a rate schedule.

*  Rate Schedules: A rate schedule describes the bill calculations for a class of customers. It is
a rate tariff encoded using Rules Language statements. When used as input to a Oracle
Utilities product, rate schedules are used to compute revenue from billing determinants.

A rate schedule is specific to one operating company and jurisdiction. It can include the
definition of several rate codes, but it must represent a# least one, because that is how accounts
are related to rate schedules.

A rate schedule can include one or more riders and contracts.

*  Riders: The term “rider” refers to any sub-form. A sub-form is a set of statements that you
want to make available for use in several rate schedules. This could include tariff riders,
company-wide rules and regulations, or other common calculations such as a set of
statements that creates time-of-use billing determinants from interval data.
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Lookup Codes

Lookups are codes that identify entities commonly referenced in customer records and rate forms.

Using standardized codes makes data retrieval and computations possible. Lookups in the base
system include:

Jurisdiction - agency or commission regulating how accounts in an area are billed.
Operating Company - company that bills the accounts.
Billing Determinant - quantity used to compute account bills (kW, kWh, etc.).

Unit of Measure - unit of measure designations for customer services (electricity, hot water,
g y

gas, etc.) and related quantities. Codes “01” through “99” are reserved for Oracle Utilities

UOMs. Oracle Utilities products also accept 3-digit, user-defined UOMs.

End Use - appliance or other device whose electric or gas consumption is measured for
billing, end use studies, or other purposes. Example end uses include air conditioners,
refrigerators, hot water heaters, furnaces, and total house.

Factors - global values that can be used for billing charges.

For a complete description of Oracle Utilities Lookup codes, see Chapter 7: Maintaining Data.

More about Jurisdiction and Operating Company: An important concept in Data Manager is

the grouping of accounts based on the company doing the billing (Operating Company) and the

location of the account (Jurisdiction). A billing account must reside entirely within one company

and one jurisdiction. Accounts, rate schedules, and other information are specific to one
operating company/jurisdiction.

Note that “outside” operating companies may be specified to allow for billing of wheeling

services, because a rate schedule related to an account need not have the same operating company
and jurisdiction as the account.

Calendar Schedules
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Calendar schedules define how time-of-use and season-based rates are applied. Data Manager
accommodates the following schedule types:

Time of Use (T'OU) - classifies each hour in a week or holiday as “on peak,” “off peak,”
“shoulder,” or any other periods in use at your facility.

Season - specifies the dates for seasons in different years; you can also associate a different
set of Time of Use schedules with each season.

User Specified Day List - specifies a group of non-contiguous days to be analyzed together.
For example, you could specify several summer peak days to be averaged together.

Holidays - specifies the days to be treated as holidays when applying time-of-use periods;
requires a holiday list for each operating company/jutisdiction.

For a complete description of Calendar schedules, see Chapter 7: Maintaining Data.
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Data Manager Functions

Data Manager has two primary purposes:
*  To give you a customized “view” of the Oracle Utilities database
*  To enable you to prepare and maintain inputs for other Oracle Ultilities products.

For input to other Oracle Utilities products, you will typically refer to the appropriate product’s
User Guide to determine the required inputs, then turn to this Guide for instructions on preparing
them. Here’s a brief description of the Data Manager functions and where to find more
information about them:

*  View: View customer information in an easy-to-use tab format specifically designed for
billing analysts. This feature is called the Account-Centric View. See Chapter 5: The
Account-Centric View. You can also view interval data cuts in the Interval Database using
the Interval Data Browser. See Chapter 6: Browsing Data.

*  Add, update, and delete individual records: Data Manager’s graphical user interface
offers you two tools for managing records in the Data Repository:

*  The Account-Centric View enables billing analysts to update billing information for
selected accounts. See Chapter 5: The Account-Centric View

*  The Browser enables system administrators and other individuals to view, add, update, or
delete any records in the Data Repository, including customer records, lookup codes, and
rate form records.

*  Import: Load files of customer or Interval data into the Oracle Utilities Data Repository. See
Chapter 3: Importing Data.

*  Query (Lists): Search the database for customers, accounts, or other entities that match
criteria you define. You can use the resulting list as input for analysis and billing applications,
or you can incorporate your list in a rate form. See Chapter 8: Working with Lists and
Queries, for customer and account lists, and for lists and queries that you can use in rate
forms.

*  Calendar Schedule maintenance: Add, modify, and delete schedules used in time-of-use or
season-based analysis and billing. See Chapter 7: Maintaining Data.

*  Rules Language Editor: Write and edit Rules Language scripts. See the Oracle Utilities Rules
Language User’s Guide for more information.
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International and Multiple Currency Support

This section outlines international and multiple currency support in the Oracle Utilities Energy
Information Platform, including:

*  Locales and Languages

*  Date and Numeric Presentation
*  Cutrency Presentation

*  Multiple Currency Support

*  File Formats

*  Database Support

Locales and Languages

Two fundamental concepts underlying international support in Oracle Utilities applications are
languages and locales. Languages determine the specific language in which text labels and
controls of an application appear. Locales determine the specific region or country in which the
user is working. Specifically, locales are used to specify display and input formatting for:

*  Date/time and numeric presentation, and
*  Currency presentation

How a user selects a language and/or locale is determined by the type of application being used.

Web-enabled Products

For web-enabled products, a uset’s locale and language are selected from the Locales tab of the
Set Preferences screen. The selected locale and language ate stored in the uset’s security
properties. The available locales on this screen are specified in the LOCALES.CFG. XML
configuration file (see Chapter 2: Configuration Files in the Oracle Utilities Energy Information
Platform Confignration Guide for more information). Locales included in the LOCALES.CFG. XML
file must also be installed on the web server and be accessible from the Regional Settings Control
Panel. If a selected locale is not installed on the web server, currency formatting and presentation
may be incorrect.

If a user does not select a locale (or selects a locale of “None”), the default locale is the Server
System Locale (defined by the operating system installed on the web server). Oracle Utilities
recommends that all users specify a locale before using internationalized applications.

Client/Server Products
For client/setver products, the uset’s locale is determined by the Regional Settings of the client
and/or application server machine.

Languages
The language for client/setver products is specified using a command line switch and/or a
parameter in the LODESTAR.CFG file. See Oracle Utilities Application Command Line
Parameters on page 4-9 in the Oracle Utilities Energy Information Platform Installation Guide for more
information about command line parameters. See LODESTAR.CFG on page 2-2 in the Oracle
Utilities Energy Information Platform Configuration Guide for more information about the
LODESTAR.CFG file. At this time, available languages include English, French, German, and
Italian.
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Reports
For client/setver applications, the locale for reports is determined by the Regional Settings of the
machine on which the report is run.

For web-enabled applications, the locale for reports is based on the Server System Locale (defined
by the operating system installed on the web server)

Languages
For client/server applications, the language that appears on repotts is determined by the language
of the application that generated the report, specified either by a command line parameter or a
configuration file parameter.

For web-enabled applications, the language is specified by the Regional Settings of the machine
on which the report is run, unless overridden by the LANGUAGE parameter in the
LODESTAR.CFG file.

Date and Numeric Presentation

The display and input of dates and numbers is based on the selected locale.

Web-enabled products

Display formatting of both numbers and date/times is based on the uset's selected locale.

Copy, cut, and paste operations are supported for all input controls. Required fields are identified
by asterisks. Null values are represented by blank (empty) controls. Moving the mouse pointer
over an input area displays sample formatting for that field.

Number input controls only accept formatting based on the user's selected locale. The only
allowable characters include digits, decimal separator, and minus sign. Any other characters are
filtered from input.

Date input controls only accept formatting based on the uset's selected locale. Dates can either be
keyed in or selected from a pop-up calendar control. All times are keyed in and based on 24 hour
format (no AM or PM indicator).

Input validation occurs upon data entry.

Client/Server Products
Formatting for numbers and date/times is based on the locale determined by the regional settings
of the client and/or application server machine. Date/time formatting can be overridden from the
General Options tab of the Default Options dialog;

Reports
Display formatting of both numbers and date/times for reports is based on the Server System
Locale on the machine on which the reports are run.

Currency Presentation

Currency information is stored in the LSCurrency table in the Oracle Utilities Data Repository.
This table contains one or more currencies, each defined by a currency code, currency symbol, and
formatting rules (such as the number of decimal places). Currency codes in this table use ISO-
4217 codes. The LSCurrency table also indicates the Default currency for the database. See
LSCurrency on page 3-3 in the Oracle Utilities Energy Information Platforn Confignration Guide for
more information about setting up the LSCurrency table.

Note: Although records in the LSCurrency table are not required, Oracle Utilities strongly
recommends that at least one record with all properties specified be created and set as “Default”.
This will ensure consistent display of currency information.
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Currency Presentation in Oracle Utilities Receivables Component and Oracle
Utilities Quotations Management

Currency input and display is identical to that for numbers with two exceptions:

* A currency indicator is also displayed next to currency input controls and currency displays.
The specific currency symbol displayed and the manner in which currency is formatted are
determined in the following order:

a.  The currency associated with the account being viewed (from the LSCurrency field in
the Account table).

b.  The default currency in the LSCurrency table. If there is no default currency, the first
record in the LSCurrency table (sorted alpha-numerically by Currency Code).

b. If the LSCurrency table is not present or does not contain any records, the currency and
formatting of the Server System Locale (defined by the operating system installed on the
web setver),specified in the HKEY_USERS\.DEFAULT\ Control
Panel\International key in the Windows Registry on the web setver.

*  Currency formatting rules for the uset's selected locale are overridden if specific formatting
rules for the currency are stored in the LSCurrency table. Typically, the only formatting rules
that would be overridden at the currency level would be the ISO code, symbol, and number
of decimal places. This applies to Oracle Utilities Receivables Component reports as well,
except that the initial locale formatting rules come from the regional settings of the machine
on which the report is run.

Currency Presentation in Other Web-enabled Products
Currently, other web-enabled products do not require input of currency values.

Display of currencies is based on the formatting of the selected locale and of the default currency
in the database (currency specific formatting always overrides locale specific formatting).

Enabling Display of International Currency Symbols
Display of international currency symbols requires the appropriate Encoding option is selected on
Internet Explorer.

How to select encoding options:

1. Select View-»Encoding from the Internet Explorer menu bar.

2. Select the appropriate option from the list. For example, to enable displaying of the Euro
symbol and other Western European currency symbols, select the Western European
(Windows) option.

Currency Presentation in Client/Server Products
Client/server products do not require input of currency values.

Display of currencies is based on the formatting of the client machine's regional settings and of
the default currency in the database. Currency specific formatting always overrides locale specific
formatting, If the default currency in the database does not specify any formatting, the currency
symbol is used for formatting, If the currency table does not exist or does not contain any records
then the default currency is determined by the Regional Settings on the client/server machine.
This applies to reports as well.
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Multiple Currency Support

Multiple Currency Support allows for accounts with different associated currencies. This is
accomplished through the presence of the Currency Code column on the Account, Journal
Account, and Checking Account tables in the Oracle Utilities Data Repository. This column
references records in the LSCurrency table

Multiple Currency and Oracle Utilities Receivables Component
All input screens which have amount fields on them indicate what currency type is expected as
input.

All elements that represent a currency in Oracle Utilities Receivables Component XML structures
have a CURRENCY attribute that indicates the corresponding currency type for the amount. The
string values used for this attribute are the same as the Currency Code values in the LSCurrency
table. On output, the CURRENCY attribute is set for the account as specified in the database. If
the account's currency type is not specified in the database, the default currency is used.

A CURRENCY attribute (using the standard stem.tail notation) is supported for Oracle Ultilities
Receivables Component transaction identifiers to specify the currency type for the account.

On input, the CURRENCY attribute of all Oracle Utilities Receivables Component transactions is
checked against the currency value of the account against which the transaction is being posted
using the following rules:

1. If a currency type is specified for the account in the database, the transaction must indicate
the same currency type or it is an error.

2. If a currency type is not specified for the account in the database, the transaction must
indicate either no specific currency type or the default currency type for the database or it is
an error.

All transactions that involve two or more accounts (such as Payment and Balance Transfers)
validate that the currency types are the same for each account (no currency translation will occur).
The credit/debit account paits for each journal translation record are validated to ensure that they
both have the same currency type. Only journal translation records that have credit/debit
accounts with the same currency type as the account against which the transaction is being posted
are used. Additional currency validations occur for payment files and refund checks.

Multiple Currency and Oracle Utilities Receivables Component Reports
Where applicable, Oracle Ultilities Receivables Component reports are grouped by Currency Code.

Multiple Currency and Other Oracle Utilities Products
Oracle Ultilities Billing Component, Oracle Utilities Rate Management and Data Manager reports
display the Currency Code associated with each account where applicable. Reports that contain
multiple currency types do not include the Summary Results page.

In Oracle Utilities Rate Management - Revenue Forecasting, the default currency type is used for
all presentation of currency amounts, regardless of whether or not a specific currency has been
indicated in the database for any accounts.
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File Formats

Input/Output File Formats
Numbets and date/times in input and output files (such as files used with the PLIMPORT
program) are independent from locale settings.

Non-English characters are supported in input/output files.

XML Formats

All dates, times, and numbers contained in XML files are represented using the standard
formatting rules as defined by the W3C XML Schema Recommendation. For backward
compatibility, previously accepted formats for dates and times will continue to be accepted on
input, however, all output will use the XML Schema representation.

Note: XML files created by the SAVE TO XML Rules Language statement are
an exception. The date, time, and number formats in Rules Language generated
XML files are based on the Rules Language configuration used to create them.

Non-English characters are supported in XML files

Database Support

In addition to the LSCurrency table and related columns in the Account, Journal Account, and
Checking Account tables, database support for internationalization includes the addition of the
COUNTRY column in the Address table and the change from ZIP Code to Postal Code on user
interfaces.
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Notes, Cautions, and Warnings

The following notes, cautions, etc. apply to all Oracle Utilities products. In the development of

these applications tradeoffs were made in favor of performance, as opposed to functionality. The

following explains some of these tradeoffs.

All Oracle Utilities products accept dates and bill months from January 1, 1901 through
December 31, 3000.

All Oracle Utilities products use the C data type “double” to store floating point values. This
is limited to 15 digits of precision. Strings or numbers with more digits are rounded to the
nearest value supported by doubles when they are converted to a float.

Use of the ampersand (“&”) symbol in ID fields results in errors when exporting data in
XML format.

If the database Browser (Account Info, Customer/Account(s) or Customer Database) is
running and a database Import is run, the Import may hang. The Browser may have database
“pages” locked, which will hang Import if it tries to update one of these pages (the Import
will continue when the Browser is closed). In general, you should close Browser windows
before running the Import function.

If the Import function deletes records that are on view in a Browser, the Browser may display
an error message when it attempts to read the deleted record. Again, close Browser windows
before running the Import function.

Some data is cached for faster retrieval. This includes operating company codes and names,
determinant information, and other relatively static data. If these values are changed in the
Browser or via the Import program, the cache will not be updated (and the new values
visible) in an application until the application restarts or the user selects Edit - Refresh
Cached Tables from the menu.

When most analysis dialogs are cancelled they are actually hidden, so that all the selections
remain. When the analysis is selected again, the dialog displays the selections from the last
time it was viewed. To refresh such a dialog, use the system Close menu pick or the X pick in
the upper right corner. This destroys the dialog and re-initializes a new one.

The maximum length of all codes and names is 64 characters. However, to keep dialog boxes
at a reasonable size, a display maximum display width of 25 characters is assumed. If you use
longer names, some displays will be distorted.

Oracle Utilities Rate Management and Oracle Utilities Billing Component have some
differences in how they perform their revenue or bill calculations. All Oracle Ultilities Rate
Management calculations use the dates in the BillHistory records; in Oracle Utilities Billing
Component the interval data cut dates may override the BillHistory dates. In both cases, the
Save Statement will write data to the database; this data is “rolled back” when the analysis
completes. However, in a Oracle Utilities Billing Component analysis the data is actually saved
when the bill is approved.

Oracle Utilities Billing Component supports multiple Bill History records in a bill month.
Oracle Utilities Rate Management supports only one Bill History record in a bill month.

Oracle Utilities Billing Component requires the ReadDates in all Bill History records to be
not NULL; Oracle Utilities Rate Management allows NULL ReadDates in Bill History
records.

Oracle Ultilities Rate Management does “the best it can”. If a historical value is requested, the
nearest value will be used if the requested one does not exist. Oracle Utilities Billing
Component is exact, with these historical function exceptions:

* If HISTVALUE is used to request a value past the end of history values, 0 is returned.
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»  If the start month to historical functions is 1 and there is only the current value, 0 is
returned. However, if the start month is greater than 1 and greater than the number of
historical values, it is an ertrot.

»  If the stop month is greater than the number of historical values, it is set to the last
period with data.

*  When a rate schedule is used for an account and the analysis is Automatic Billing, Approval
Required billing, or Current/Final Bill, the rate schedule must have either the
$EFFECTIVE_REVENUE identifier or another identifier set as the total through the
REVENUE TOTAL statement. This guarantees that there is a total revenue.

*  In any numeric edit field, to make the value negative press the minus (-) key when the cursor
is left of any decimal point. To make a negative value positive, press the plus (+) key. Note
that you cannot delete or backspace over a minus sign to remove it.

*  Ifyou use an OR conjunction in a Prompted Query, the actual query may run very slowly.
This is a limitation in all relational databases.

*  If you change the Windows Regional Settings while an application (Data Manager, Oracle
Utilities Billing Component, etc.) is running, you must restart the application in order for the
new settings to take effect.
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Chapter 2

Working with Data Manager

This chapter described how you work with Data Manager. This includes:

Starting Data Manager
Data Manager Menus
Data Manager Toolbar
Default Options

Setting Global Options
Using Online Help
Changing Your Password
Shortcut Tips

Saving and Applying Settings for Dialog Boxes
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Starting Data Manager

This section covers the basics of working with Data Manager and the other Oracle Ultilities
products—how to start the program, use the on-line help system, and set user preferences. It also
acquaints you with the tools, commands, and controls you’ll find in Data Manager, as well as a few
shortcuts for navigating the system.

From the Windows Desktop

This section explains how to start Data Manager from the Windows desktop. (You can also start
Data Manager from the command line and use switches to control which database is accessed, and
other features. Ask your System Administratot.)

Depending upon how your system is configured, you can start Data Manager using one of two
methods:

*  Double-click the Data Manager icon, or

*  Click the Start button in the lower-left corner of the Windows desktop. Then, select
Programs->Oracle Utilities->Data Manager.

Depending upon your system configuration (or if an error occurs during database initialization),
the logon screen appears.

¢ User Name: the user ID for the database connection*
*  Password: the password for the supplied user ID*

*  Data Source Name: The data source name and provider for the database, in one of the
following formats:

For Oracle databases:
"Data Source=<data_ source>;LSProvider=0DP;"
For Microsoft SQL databases:

"Data Source=<address>;Initial
Catalog=<SQL database>;MultipleActiveResultSets=True;LSProvider=MS
SQL; "

where:

*  <data_source> is Oracle TNS Name from the TNS_NAMES.ora file (typically located
in the \ \<machine>\oracle\network\admin directory)

*  <address> is the IP address or Hostname of the MS SQL Server database server
*  <SQI_database> is the name of the MS SQL Server database

* User Name and Password are optional—if you do not supply them, the User ID defaults to your
Windows logon ID.

When you complete the fields and click OK, the Data Manager desktop appears. You are now
ready to begin.

From Another Application

You can start Data Manager while working in another Oracle Ultilities application program, such
as Oracle Utilities Rate Management or Oracle Utilities Billing Component. From that program’s
desktop, select Tools->Data Manager. The Data Manager desktop appeats.

Note: If Data Manager is not available on the Tools menu, contact yout System
Administrator. (Data Manager must be added to the *.ts files.)
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Data Manager Menus

File Menu

The Data Manager menus provide access to all Data Manager functions, as well as to all other
Oracle Ultilities products installed on your system. The following describes each option on each
menu.

Note: Many of the options available via the menus are also available via the
Toolbar. If the Toolbar does not appear on your screen, select Tools->Display
Toolbar.

New: Open the Rules Language Editor to create a new version of a rate form (contract, rate
schedule, or rider), or open the Rate Wizard (see the Oracle Utilities Rutes Language Users Guide for
more information about using the Rate Wizard).

Open: This has four sub-options.

*  Contract Version: Opens an existing version of a Contract (rate form) in the Rules
Language Editor.

*  Rate Schedule Version: Opens an existing version of a Rate Schedule (rate form) in the
Rules Language Editor.

*  Rider Version: Opens an existing version of a Rider (rate form) in the Rules Language
Editor.

*  File: Allows you to view contents of any ASCII text file. (You can view the contents, but not
modify them.)

Browse: Launches the browser. Use one of the following sub-options to determine what data will
appear in the browser.

*  Customer/Account(s): Use the Browser to view information in the Oracle Utilities Data
Repository about selected accounts.

*  Customer Database: View any information in the Oracle Ultilities Data Repository using the
Browser. This option is preferable for viewing lookup codes and other information. The
Customer/Account(s) option (above), on the other hand, is faster and more convenient
when you want to focus on information about specific accounts.

*  Database Schema: View a graphical representation of the table structure in the Oracle
Utilities Data Repository, as well as the table and column (record) names.

* Interval Data Database: View interval data cuts stored in the Interval Database (select the
database using Tools->Options).

*  Select Interval Data: View interval data cuts associated with a specific customer or account.
View: Opens the Account-Centric View (see Chapter 5: The Account-Centric View).

*  Account: View, update, add, and delete information about a selected account using the
Account-Centric View.

*  Substation: View, update, add, and delete information about a selected substation.
Close: Close an open report window.
Lists: Offers options for creating Lists.

*  Customer/Accounts: View, edit, create, impott, or export a list of customer or account
IDs.

*  Table-Column: View, edit, create, import, or export a list of values from any table-column in
the database. This type of list can be used only in conjunction with a rate form.
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Edit Menu

*  Substation/Transformer: View, edit, create, import, or export a list of substations or
transformers.

Save: Available only when the Rules Langnage Editor is active. Saves the rate form currently open.

Save As...: Available only when the Rules Langnage Editor is active. Saves the rate form currently open
with a new name.

Setup: Offers various setup options:

*  Blocking Tables: Create, edit, or delete blocking tables (used to create a Bill Frequency
Table for rate analysis or revenue forecasting).

*  Season Schedules: Create, edit, or delete season schedules (used for season-based analysis

and billing).

*  TOU Schedules: Create, edit, or delete time-of-use schedules (used for TOU-based analysis
and billing).

Import Data set: Imports data into the Oracle Utilities Data Repository.

*  To Customer Database: Import customer records into the Oracle Utilities Data Repository.
*  To Interval Data Database: Import interval data into the Oracle Utilities Data Repository.
Import: Imports contents of a file.

Export: Exports contents of an open report window or a rate schedule to a file.

Export/Delete: Exports and deletes the contents of an open report window or a rate schedule to
a file.

Print: Print contents of an open report window.

Exit: Close Data Manager.

Cut: _Available only when the Rules Langnage Editor is active. Cut selected text, and save it to the
Clipboard.

Copy: Copies selected text to the Clipboard.

Paste: Available only when the Rules Langnage Editor is active. Paste text from the clipboard into a rate
form.

Undo: Available only when the Rules Langnage Editor is active. Undo last action; e.g., cut, copy, or paste.
Redo: Available only when the Rules Language Editor is active. Redoes the last undo action.

Add: Add a new record to the database.

Update: Update a record in the database.

Delete: Delete a record from the database (Browser) or selected text in a rate form (Rules
Language Editor).
Note: The Add, Update, and Delete options are operable only when the

browser window or Rules Language Editor is open.

Find: This option allows you to search for a word or words in an open report window. When you
select this option (or press F3), the Find dialog opens. See Chapter 9: Reporting, for more
information.

Find Next (Shift-F3): This option finds the next instance of the word or words last entered in
the Find dialog;

Find Previous (Ctrl-F3): This option find the previous instance of the word or words last
entered in the Find Dialog.
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Analysis Menu

Records Menu

Go To (Ctrl-G): This option opens the Go To tab on the Find dialog and allows you to go to a
specific line in an open report window.

Browse Account: Examine information in the Oracle Utlities Data Repository for a selected
account using the Browser.

Note: You must first highlight an Account ID in a teport in order for this
feature to be available.

View Account: Examine information in the Oracle Utilities Data Repository for a selected
account using the Account-Centric View.

Note: You must first highlight an Account ID in a report in order for this
feature to be available.

Refresh Cached Tables: Refreshes the contents of tables displayed in the browser.

Font: Allows you to change the font in an open report window. See Chapter 9: Reporting for
more information.

Trial Calculations: Opens the Trial Calculation module. See Trial Calculations on page 10-2 for
more information.

Billing History: Generate a summary of bill determinants for one or more accounts over any
desired time period for which data is available. See The Billing History Report on page 10-9 for
more information.

Special Events: Generate a summary of special event overrides that apply to one or more
accounts over any desired time period for which data is available. See The Special Events Report
on page 10-10 for more information.

Billing Options: Opens the Default Billing Options dialog, used when performing trial
calculations. See Default Billing Options on page 10-11 for more information.

The Records menu contains options for working with records in the Oracle Utilities Data
Repository. Note that the Records menu is only available when the browser is displayed.

Insert New: Inserts a new record in the selected table.

Filter: Opens the Set Filter dialog and allows you to filter records in the browser based on a
specified account ID of table-column list. (see How to Filter records in the Browser based on
Account IDs or Table-Column Lists: on page 6-4).

Query Filter: Opens the Query to Create a List of <TABLE> Records dialog and allows you to
filter records in the browser based on a user-specified query (see How to Filter records in the
Browser based on Queries: on page 6-4).

Export: Exports all records from a selected table, as well as all associated parent, child, and
lookup records, when specified. See Chapter 4: Exporting Data for more information.

Delete: Deletes all records from a selected table, as well as all associated child records. No Export
file is created. See Chapter 4: Exporting Data for more information.

Export/Delete: Exports all records* in a selected table, as well as all associated child records, and
deletes same records from the database. See Chapter 4: Exporting Data for more information.

Refresh: Refreshes the selected table.

Browse Interval Data: This option opens the Interval Data Browser. This option is only active if
you’ve selected the Channels, Recorders, or Channel History table, or one of the records in one of
those tables. If you select a table, the Interval Data Browser displays the entire Interval Database.
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Single-Step Menu

View Menu

If you select a single record, the Interval Data Browser displays only the selected record. See
Chapter 6: Browsing Data for more information.

Refresh All: Refreshes all the tables in the Oracle Utilities Data Repository.

The Single-Step menu contains options for working with the Trial Calculation window. Note that
the Single-Step menu is only available when the Single-Step windows are displayed.

Step: Executes the selected line in the statements (upper left) window.

Jog: Executes the rate form slowly, line by line, allowing users to view the results.
Run: Runs the rate form.

Jog to Selection: Executes the rate form slowly, line by line, up to a selected line.
Run to Selection: Runs the rate form up to a selected line.

Break: Stops processing when “jogging” through a rate form.

ReStart: Reloads the rate form, allowing users to restart processing.

Graph Interval Data: If selected, displays interval data loaded in the rate form in the lower
window. The default for this option is on.

Show Selected Identifiers: Shows the values of selected identifiers in the rate form. Identifiers
are selected on the Customer Bill Modification - Edit Id dialog accessible when running a
Single Step Analysis. See How to run the Single Step Analysis on page 10-4 for more
information.

Show All Identifiers: Shows the values of all identifiers in the rate form.

View Open Interval Data Handles: Opens the Browse Open Interval Data Handles window,
displaying interval data handles loaded in the rate form.

Display Report: Opens a report window for the trial calculation.

Display Profile: Opens a performance profile that lists the processing time for each line in the
rate form.

Insert/Remove Breakpoint: Inserts or removes a breakpoint at the selected line in the top left
window in the Single Step module. See How to run the Single Step Analysis on page 10-4 for
more information.

Clear All Breakpoints: Clears all breakpoints in the rate form currently open in the Single Step
module. See How to run the Single Step Analysis on page 10-4 for more information.

The View menu contains options for altering the view of reports. Note that the View menu is only
available when an open report window is displayed.

Note: The contents of the View menu change when viewing graphs. See
Creating Graphs on page 9-6 for more information.

Graph: Opens the Create Graph dialog and allows you to create a graph based data in the report.
This option is only available if the data in the report can be graphed. See Creating Graphs on
page 9-6 for more information.

Auto Vertical Scroll: Selecting this options causes the last page of the report to be displayed as
the report progresses, if it is not checked then no automatic scrolling occurs.

Display Only Pages With Errors: Creates a new report window based on an open report
window that contains only pages that contain errors. This option is only available if an open report
window contains pages with errors.
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Tools Menu

Window Menu

Help Menu

Display Only Pages Without Errors: Creates a new report window based on an open report
window that contains only pages that contain no errors. This option is only available if an open
report window contains pages with errors.

Options: User-selectable options for tailoring the Oracle Utilities programs to your needs and
environment. See Default Options on page 2-9 for more information.

Display Toolbar: Toggle display of Toolbar on and off. See Data Manager Toolbar on page 2-8
for more information.

Customize: Available in future release. Make other programs accessible from the Oracle Utilities
Billing Component menu bar.

[application program]: Open another Oracle Utilities or usetr-supplied application. This is
optional. See your System Administrator about adding applications to the Tools menu.

Global Options: User-selectable global options for setting default values for Oracle Utilities
applications that apply to all users. See Setting Global Options on page 2-16 for more
information.

Change Password: Change password for logging in to the database. See Changing Your
Password on page 2-21 for more information.

Cascade: Overlaps multiple open windows the desktop; provides largest view of active window.
Tile: Displays multiple open windows side by side.
Arrange Icons: Organizes icons on Data Manager desktop.

Close All: Closes all open windows.

Help: Displays on-line help for currently-displayed window. See Using Online Help on page 2-
20 for more information.

Help contents: Displays table of contents for on-line help. See Using Online Help on page 2-
20 for more information.

About: Displays version number of software. Also display the username, computer (network)
name, and current database name.

Display Error Window: Displays database version, configuration settings, and error log, Useful
when calling the HelpLine. This window can be exported by selecting File->Export.
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Data Manager Toolbar

The Toolbar gives you quick access to the program’s most frequently used tools and commands. If

the toolbar is not visible, select
Tools->Display ToolBar.

N EEIEIERBE
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The following describes the function of each Toolbar button. Additional details are provided in

other parts of this guide.

Click To

New Open the Rules Language Editor to create a new version of a rate form.
This is the same function as the New option under the File Menu on
page 2-3.

Open Open an existing version of a rate form in the Rules Language Editor. This
is the same function as the Open option under the File Menu on page 2-
3.

Save Save the currently displayed report or rate form version.

Print Print the currently displayed rate form or report.

Export Export the currently displayed report or rate form.

Cut Available only when the Rules Langnage Editor is active. Remove selected text
from the rate schedule.

Copy Copy selected text and store it on the Clipboard.

Paste Available only when the Rules Langnage Editor is active. Insert contents of the
Clipboard at the insertion point or selection.

Browse View information in the Data Repository about selected accounts;

information is displayed via the Browser.

View Account

View, update, add, and delete information about a selected account using
the Account-Centric View.

Browse Opens the Customer Database Browser. This is the same function as the
Customer Browse: Customer Database option under the File Menu on page 2-3.
Database

Browse Interval ~ Opens the Interval Data Browser. This is the same function as the

Data Database

Browse: Interval Database option under the File Menu on page 2-3.

Browse
Database
Schema

Opens the Customer Database Schema. This is the same function as the
Browse: Database Schema option under the File Menu on page 2-3.

Error Window

Display database version, configuration file settings, and error log. Useful
when calling the Help Line.

Help

Display on-line help for currently displayed window.
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Default Options

The Options feature allows you to set your own default values for several frequently used

parameters. You can set your preferred defaults via Data Manager or another Oracle Utilities
product (such as Oracle Utilities Billing Component) and store them in the Oracle Utilities Data
Repository. In that way, whenever you open a Oracle Utilities program, these values are

automatically supplied—saving you the time and effort of defining them each and every time.

When you are working in any of the Oracle Ultilities application programs, you can also override

your defaults for individual work sessions, or even specific dialog boxes throughout the programs.

Whenever you see the Options button on a dialog box, you can click it to open the Options box
to override the defaults.

Available options include:

General Options

Rate Analysis Options
Billing Options
Interval Data Source
Interval Data Options
Interval Data Merge
Error Handling

User Files

How to set default options:

1.

At the Desktop, select Tools->Options
dialog box.

. Or, Click the Options button on the current active

Set your options on each tab as desired.

When you have completed the tabs as desired, click OK to save the new settings as your

defaults, replacing the previous settings. Any Oracle Ultilities program you run will

automatically use these defaults. If you click Apply, the result depends on how you opened

the Default Options dialog:

* Ifyou opened the Default Options dialog from the main menu, your new settings apply

to all of your work for remainder of your current session. The settings will revert to the

original defaults when you quit the

Oracle Utilities programs.

* If you opened the Default Options dialog by selecting the Options button in a dialog

box, your new settings apply to jus

t the current job.

The next several pages contain detailed information about the Default Option tabs.
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General Options

The General tab specifies a number of default values and formatting preferences used by the

system.
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Default Operating Company: Choose the default operating company for bill calculations
and rate analyses.

Default Jurisdiction: Choose the default jurisdiction for bill calculations and rate analyses.
Account ID: Choose the default ID for bill calculations and rate analyses.

Minimum printed line width: The type size in printed reports is partially determined by
the number of characters that you specify here. The recommended setting is 110 characters,
which yields approximately 10 to 12 point type (depending upon your printer). If you do not
supply a value here the programs automatically sizes the type based on the longest line in the
report. So for example, if the longest line were 40 characters, the program would size the
type so that the 40 characters filled the entire width of the page, which most likely would yield
uncomfortably large type. On the other hand, if the longest line in the report is longer than
the value you specify here, the value has no effect.

Default to landscape printing after this # of characters: If a line single line in a report
contains this many characters, the report will default to landscape printing. This allows the
user to print reports in landscape mode without having to manually change the mode in the
printer’s properties dialog box.

Display calculation time with date on each report page: The date/time is displayed on
every page of every report. If this option is checked, the time is also displayed with the date.

Date Format: Your selection here dictates the format used to enter dates via the graphical
user interface, and how they are displayed in reports. (This setting is not dependant upon, nor
does it affect, how dates are stored by your database software.)

Your three options are:
*  MM/dd/yyyy hh:imm:ss: Month-day-year, hours-minutes-seconds.
*  yyyy-MM-dd hh:mm:ss: Year-month-day, hours-minutes-seconds.

*  Windows Regional Settings: Default Options will draw from the Date tab of the
Regional Settings Windows Control Panel.

Using the Windows Regional Settings, you will have greater flexibility in the formats
available to you. You can set a 2-digit year (although the 4-digit, Y2K-compliant date will
still be used internally), a European format (day-month-year), and so on.

Note: If you change the Windows Regional Settings while an application (Data Manager,
Oracle Ultilities Billing Component, etc.) is running, you must restart the application in
order for the new settings to take effect.
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Rate Analysis Options

The Rate Analysis tab specifies default values for processing rate schedules and running reports.

Billing Options

Default Rate Schedule: Choose a default rate schedule for calculating charges. This is the
default schedule selected when running trial calculations.

Test Period: Can be any period, one month or greater. This period is used as the default
time range for the Billing History Report, Special Events Report, and Trial Calculations.

Default Season Schedule: Select a season schedule for the calculations.

Note: If when running an analysis or calculation, the input rate form includes
a statement that assigns a value to the SEASON_SCHEDULE_NAME
identifier, the value in the rate form takes precedence over the Options
selection.

Display Line Numbers: If this checkbox is checked, the Rules Language Editor and Rules
Language Text Editor display line numbers at the beginning of each statement/line. Line
numbers also appear in the Trial Calculuation window.

Maximum number of Undo’s allowed: This field sets the maximum number of Undos
allowed in the Rules Language Editor. The default is 1.

Display ‘Saved by’ comments at end: If selected, the ‘Saved by’ comments inserted in rate
schedules are inserted at the bottom of rate schedules instead of at the top. This option
unselected by default.

The Billing tab specifies how billing information is displayed by the system.

Round Revenue: Specifies the precision of revenue values in reports. This setting affects only
values that have been assigned to revenue identifiers via an Assignment, All, or Block statement in the
applicable rate form. A value of 0 (zero) means don’t round, -1 means round to dollars, -2 means
round to tens of dollars, 1 to tens of cents, 2 to cents, and so on.

Currency displayed to n decimal places: Specifies the number of decimal places shown in
reports for dollar values. It is usually set to be consistent with your choice for Round
Revenue. A value of 0 (zero) means use the default (display cents), 1 means display tens of
cents, 2 means display cents, 3 means display tenths of cents, 4 means display hundredths of
cents, and so on.

Note: This setting applies only to Oracle Utilities Billing Component reports;
Oracle Utilities Rate Management reports always display dollars with two
decimal places (cents).

Display midnight as 00:00:00 (not blank): Specifies whether or not a value (00:00:00) is
displayed and printed when the time is midnight or unspecified.

If you leave this option unchecked (the default), the programs print and display the date
without a time when eizher the time has not been specified or the time is midnight. For
example, if either 12/01/1998 or 12/01/1998 00:00:00 were specified, the program would
display 12/01/1998.

If you check this option, the programs print and display 00:00:00 when the time is either
unspecified or midnight. For example, if either 12/01/1998 or 12/01/1998 00:00:00 were
specified, the program would display

12/01/1998 00:00:00.
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Interval Data Source
The

Interval Data Options

Interval Data Source tab specifies the source of interval data used by the system.
Interval Data Database: Select a Type from the three options:

*  File: Specify a Pervasive.SQL (*.bte) file. The File option below becomes active when
this button is selected, allowing you to specify a Btrieve file (and path) in the File Name
field, or to Browse to a file.

*  Default: Specifies that the default Interval Data Database identified in the
LODESTAR.CFG File be used. See the Oracle Utilities Energy Information Platform
Installation and Configuration Guide for more information about setting a default Interval
Data Database.

*  Customer Database: Specifies that interval data stored in the Oracle Utilities Data
Repository be used. When this button is selected, a drop-down list appears listing all
available interval data header tables. The default table is the Channel Cut Header
(LSCHANNELCUTHEADER) table.

Export Records Overwritten by SAVE to File: This option saves interval data cuts from
the Interval Database to an export file before they are overwritten by new cuts created by a
Rules Language SAVE Statement. The full path and name of the file (including a valid
extension) must be specified.

This option appends new cuts to the same file without overwriting previously exported cuts.

The Interval Data Options tab specifies how interval data is loaded and processed by the system.

Exclude intervals with quality less than: Specify a status code level that the interval data
must meet or exceed in order to be included in the calculations. All interval values with a
code less than your selection will be ignored by the programs.

The codes are listed in order of decreasing quality—alpha codes generally indicate that the
data is acceptable; numeric codes indicate that the data is suspect and should be corrected..

Status Code Classification of interval data

(blank) Normal

A

Normal, alternate-recorded (e.g., hand-entered)

J

Data inserted by Oracle Utilities Load Analysis to correct outage

-

Default for data modified by Oracle Ultilities L.oad Analysis Load Data
Editor

Splice peak interval (estimated value)

Interruptible or curtailable load

Inserted outage

Corrected outage

Cuts resulting from merging invalid data or from unrecognized status codes

Il VORI B A

Reserved

Uncorrected outage

Non-normal (usually timing-pulse defects)
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Status Code Classification of interval data

5 Aggregated interval used in rolling format with partially missing or
unavailable data

7 Marged, aggregated, or transformed interval with partially missing data

9 Missing

Day Start: Specify the time that your facility considers the beginning of the day—8:00 am or
midnight. This setting pertains to the ROUNDATE Rules Language function.

Use in all day calculations: Check this box if you want the Day Start time to apply to all
date calculations that round to a full day or higher.

Use interval end time when displaying time of the interval: Specifies whether the start-
or end-times of intervals are displayed for the MAXDATE values in INTDVALUE and
INTDTOUVALUE functions. If checked, the end-time is displayed. If unchecked, the start-
time is displayed (the default).

Add Fall Daylight Savings Time value to Energy requests: Because previous versions of
the Oracle Utilities Data Repository stored energy in a 24-hour format, the system had to
compensate for the extra hour of interval data that is left over on the day when the clocks are
turned back for Daylight Savings Time. To do this, the system automatically takes each
account’s interval data values for the two DST hours (2:00 AM in the US) and averages them
together for a single hour. This option enables you to specify how Oracle Utilities Billing
Component (or other Oracle Utilities products) handles the “leftover” hour when calculating
energy from interval data. If this option is checked, the system doubles the averaged value. If
the option is unchecked, it uses just the single, averaged value. This option should only be
used if the DST Participant flag is set to “A” in your interval data.

Version 3.70 (and above) can store interval data in 25-hour format (for the day when DST
ends). Oracle recommends this option remain unchecked when using version 3.70 or above.
Enabling this option in version 3.70 or above can result in incorrect energy calculations.

Export Validation Flag: Controls the settings of the Validate_Record_Flag upon export.
This can be set to one of the following:

*  Valid (default): Sets all Validate_Record_Flags of each cut within the exported file to
“N”, ignoring the Validation status of the requested cuts.

*  Invalid: Sets all Validate_Record_Flags of each cut within the exported file to “Y”,
effectively ignoring the Validation status of the requested cuts.

*  Use Cut's Status: Sets the Validate_Record_Flag to either “Y” or “N” depending upon
the combination of validation flags that are current in the cut when exporting takes
place. If either the Merge flag or the Internal Validation flag are “Y”, then the
Validate_Record_Flag in the exported cut is set to “N”. If both are set to “N”” then the
Validate_Record_Flag is set to “Y”.
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Interval Data Merge

The Interval Data Merge tab allows you to specific how interval data cuts are merged when using
the INTDJOIN Rules Language function.

Error Handling

Note: The Interval Data Merge options tab only appears if you include the
INTD_NEW_JOIN parameter in the configuration file. See the Oracle Utilities
Energy Information Platform Installation and Configuration Guide for more
information.

Check Interval Data Validation before Merge: Check this checkbox to cause the program
to check cuts' merge validation flag before merging. The default is not to check.

Interval Data Merge Selection Criterion: Choose a criterion for merging overlapping

interval cuts (i.e., a rule how to merge two cuts into one). There are four criteria for merge:

Most Recent Start: Pick the interval from the cut that starts later.

Best Status: Pick the interval from the cut with a better status code. If the intervals have
the same status code, the values are averaged.

Average Value: Pick the time-weighted average of the overlapping intervals. The status
code of the averaged interval will be the worse of the overlapping intervals.

Maximum Value: Pick the interval from the cut with a larger value.

Time Stamp: Pick the interval from the cut with the later Timestamp.

The default criterion is Most Recent Start.

The Error Handling tab specifies how errors are handled by the system.
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Display error messages: If checked, the program will display the number of errors (if any)

it encountered during the job run.

Stop analysis after ## errors: The number of errors to allow when running an analysis or

bill.

On Rules Language Interval Data Error: Use this option to specify how the programs

handle interval data problems encountered while the rate schedule is running:

Stop with Error. Stop processing in any mode.

Log Message. Complete processing; include warning message in error log, but not in
report.

Continue. Complete processing; do not issue any messages.

Issue Warning Message. In the Automatic Billing mode, stop processing the bill. In
the Automatic or Approval Required modes, complete processing, but issue a warning
message in the bill report.

Issue Information Message. Complete processing; include informational message in
report.
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User Files

The User Files tab specifies where files created by the user are stored by the system.

Default User Directory: If there is a value in this field it will override the USERDIR setting
in the configuration file (after the database is opened). Files put in the user directory before
the database is opened - such as .log files - will still be placed in the USERDIR directory.

Use last save/open path as default for next save/open? - If this checkbox is checked, the
path used in the last open or save operation will be the default path for the next open and
save operation, for the duration of the application's run. Each time an application starts it will
use the Default User Directory/USERDIR path in the first open ot save.
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Setting Global Options

The Global Options feature allows you to set default values for Oracle Ultilities products for all
users. These default values correspond to parameters set in the LODESTAR.CFG file. See
LODESTAR.CFG on page 2-2 in the Oracle Ultilities Energy Information Platform Configuration Guide
for more information about LODESTAR.CFG parameters.

The values you supply in the Global Options dialog override the settings in the
LODESTAR.CFG file (both on the server and local client), and apply to all users.

How to set your Global Options:

1. At the Data Manager desktop, select Tools->Global Options.

2. Set your options on each tab as desired.

3. When you have completed the tabs as desired, click OK.

This saves the new settings as your defaults, replacing the previous settings.

You must shut down and restart the application(s) in order for your new settings to take effect on
other Oracle Utilities applications (including other instances of Data Manager or other users
currently using Data Manager).

Global Options Tabs

The next several pages contain detailed information about the Global Options tabs. The
corresponding configuration parameter is noted in parentheses in the description of each option.
Global Options include:

* Database Settings
*  RCDATA Settings
*  CIS Files Settings
*  Rules Language Settings

. Reports Settings
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Setting Global Options

Database Settings

RCDATA Settings

Database Date Format: (DATEFORMAT =). The date format string for your database. The
string uses the format items in the Oracle Utilities Energy Information Platform Configuration Guide.

Database Ping Time (minutes): (PINGDB =). Value must be the number of minutes (whole
number) between database pings. This is only needed if the database server will time-out if it is not
accessed regularly. The provided value should be smaller than the server time-out, because the
ping timer is not very accurate.

Browse entity tables: (BROWSERENTITIES =). If this checkbox is checked, only database
entities are displayed in the database browser when the tables are first displayed (all tables are
displayed on refresh).

Case Insensitive searches: (CASE_INSENSITIVE = 1). If this checkbox is checked, searches
in the record select dialog will be case insensitive. The default is case sensitive search.

Database Monitor: (DATABASE_MONITOR = 1) If this checkbox is checked, then database
monitoring is turned ON.

Userid Case: Allows you to select the case (upper or lower) for User IDs. The options are:

*  No Change: The User ID is sent just as it appears in the command line, or as it is entered in
the logon dialog,

*  Uppercase UserID: (UPPERCASE_USERID). If checked, the entered user id is converted
to all uppercase characters. This allows the user to type an upper or lower case user id if the
database ignores the case of the user id, and still get the uset's correct Options. Note that if
this parameter is set, the uset's Options will need to be reset if they were saved under a mixed
or lowercase user id.

*  Lowercase UserID: (LOWERCASE_USERID). If checked, the entered user id is converted
to all lowercase characters. This allows the user to type an upper or lowercase user id if the
database ignores the case of the user id, and still get the uset's correct Options. Note that if
this parameter is set, the uset's Options will need to be reset if they were saved under a mixed
or uppercase user id.

Note: UPPERCASE_USERID takes precedence over
LOWERCASE_USERID if both are present.

Number of 9s to round: NUMBER_OF_9S_TO_ROUND-=). If this number of consecutive
nines appears to the right of the decimal place, round them up 1. The default is 3.

Number of 0s to round: NUMBER_OF_0S_TO_ROUND=). If this number of consecutive
zeros appears to the right of the decimal place, followed by non-zero values, round them to zero.
The default is 3.

RCDATA directory: (RCDATADIR=). If checked, tells the directory where to find and place
shared application data files.If not specified, defaults to the . \RCDATA ditectory parallel to
where the application software resides. To select the RCDATA directory, click Browse and select
the desired directory.

Do not append qualifier to RCDATA directory: (PLDBQUALNODEF = 1). If checked, then
the default database qualifier selection <none> will not be listed.
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CIS Files Settings

CIS Format File: (CISFORMAT =). The input file name containing the CIS record format text.
If a file name is supplied with no path, the file must be in the USER directory. The default is
CISFORMT.TXT in the CFG directory. To select the CIS Format file, click Browse and select the
appropriate directory/file.

Default CIS Output File: (CISFILENAME =). The default output CIS file name as displayed in
the Oracle Utilities Billing Component dialogs. It is also the CIS output file name used by
AUTOBILL, if not overridden on the command line. If not set, the default file is
“LODESTAR.CIS” in the USER directory. To select the default CIS output file, click Browse and
select the approptiate directory/file.

Delayed CIS File Open: (DELAYED_CIS_FILE_OPEN =). Normally, the CIS output file is
opened in append mode during the validation done when a bill is first approved. This detects any
file problems; however, it leaves the file open while the database records are saved. If you want the
file to be open for as short a period of time as possible, check this checkbox. The CIS file will then
be opened just before committing the database changes.

Rebill Reason Required: (REBILLREASONREQUIRED =). If this checkbox is checked and
there is a REBILLREASON Table in the database, a Rebill Reason Code must be selected to run
Rebill Only or Cancel/Rebill in Bill Cotrection.

Rules Language Settings

Override NULL Value is Zero: (OVERRIDE_NULL_VAL_IS_ZERO =). If an override
record is missing or its VAL or STRVAL columns are NULL, OVERRIDE[key].VAL is set to
Null, OVERRIDE[key].STRVAL is set to Null, and the HASVALUE function will indicate that
they do not have a value. To retain the previous assignment of 0.0 or “”, check this checkbox. See
“Ouverride Identifiers” in the Oracle Utilities Rules Langnage User’s Guide.

Allow interval data handle reassign: (ALLOWINTDREASSIGN =). The default is to generate
an error if an interval data identifier is assigned any value that is not an interval data handle, or
zero (usually caused by a mistake in coding a rate schedule or its riders). Checking this checkbox
overrides the error check and allows any value to be assigned to an interval data identifier, possibly
changing it to a temporary identifier.

Lock Rate Form While Editing: (RSLOCK). If this checkbox is checked, Data Manager locks
rate forms while editing text.

Allow revenue identifier reuse: (ALLOWREVENUEIDREUSE =). There are three options:

*  No: Generate a compile error if a revenue identifier is an INTO or TOTAL identifier in
more than one BLOCK or ALL statement. This is the default.

*  Yes, with warning: If this option is selected, this check is skipped, and a warning message is
generated on validation.

Note: If a revenue identifier is used more than once, results may be incorrect
because the information from one statement may be overwritten by that from
another.

*  Yes: If this option is selected, no warning messages are generated for these errors.

If you select Yes or Yes with warning, identifiers will not be checked against the IDENTIFIER
column in the BILLDETERMINANT Table. In this case it is not be an error to assign a value to
a revenue identifier used in a BLOCK or ALL statement, even though that may lead to missing
information.

Note: These last two situations will be reported as Warnings when you validate
a rate form, but will not interfere with saving or running it.
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Reports Settings

Color Format: This option allows color coding of Rules Language statements. This color coding
is in effect when viewing and editing rate forms using the Rules Language Editor. The default
color for all statements is black text with white background.

How to set color coding for Rules Language statements:

1. From the Rules Language tab of the Global Options dialog, click the Color Format button.
The Rules Language Color Format dialog opens.

Select the statement to be color coded from the Statements box.
Select the text color for the statement from the Foreground drop-down list.
Select the background color for the statement from the Background drop-down list.

Repeat steps 2 through 4 to set color coding for other statements.

A A o

To set the color coding for a statement to the default (black text on white background), select
the statement and click Default.

7. 'To save all color codings, for all desired statements, click OK. To close the dialog without
saving any settings, click Cancel.

Remove empty report columns: (REMOVE_EMPTY_COLUMNS =). If this checkbox is
checked, a column in a billing report that has no values will not be displayed. If this is not present,
the column header will appear with nothing below it.

Default Report Column Width: (REPORT_COLUMN_WIDTH =). Default width in
characters of report columns. This value may be increased, depending on the data displayed in the
column. Must be between 8 and 32, inclusive. The default is 16.

Customer Field Separator: (CUSTOM_FIELD_SEP =). The separator between the label and
the value in the header part of reports. The separator is the first nonblank character after the =
sign. If the line is empty after the =, a blank is used. The default is a colon. Note that a space will
always follow the separator in the report.

Distribution Column Label: (BILL_CALC_DISTRIBUTION_LABEL =). Sets the label of the
Distribution column in the Bill Calculation section. The default is, obviously, Distribution. If no
value is supplied, the Distribution column is not displayed.

Log to ERRTABLE: (LOGTOTABLE) If this checkbox is checked, log records from importing
customer/account data (using either Data Manager or PLIMPORT.EXE) are placed in the
ERROR table in the Oracle Utilities Data Repository instead of into log files. Note that the
ERROR table must be in the database for this option to be enabled.
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Using Online Help

Oracle Ultilities applications provide browser-based online help.

How to open online help:

1.
2.

3.

Help Icons

Select Help Contents from the Help menu. The online help opens in a browser window.

Locate the topic you need help about via the Contents tab, Index tab, or Search tab.

The Contents tab allows users to expand/collapse sections of the table of contents as

needed to find a particular topic. Click on the book icons (% and Lu) to open/close

headings. Click on the topic icon (El)to open it.

The Index tab allows the user to browse an index for the online help. Click on the index

entry for the topic to open it.

The Search tab allows the user to search the online help for specific words. Enter the
word(s) for the search in the text box and click Go! The search results appear beneath
the text box. Click on the topic to open it.

The selected topic will appear in the right pane of the online help window.

A number of icons appear along the top of the online help window. These icons are used for

navigating the online help and other functions.These icons perform the following functions:

Icon

Description

Show Navigation: Open the navigation frame. Used after opening
a single help topic.

Previous: Display the previous help topic.

Next: Display the next help topic.

Show in Contents: Expand the Contents tab to display the current
topic.

E-mail: Send email to Customer Support.

Print: Print the current topic.

aficfuioll<il- =

Bookmark: Save the current topic as an Internet Explorer
Favorite..

Context-Sensitive Help

Users can also get online help based on a specific function or screen. This is referred to as

context-sensitive help.

How to open context-sensitive help:

1.
2.
3.

2-20 Data Manager User’s Guide

Open the function or screen you wish to find help about.

Click the Help button in the Toolbar or press F1.

An online help window opens displaying the corresponding topic.
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Changing Your Password

The Change Password option enables you to change your password for logging in to the Oracle
Utilities Data Repository.

Note: If the Change Password option appears grayed-out on your system,
consult your Database Administrator.

How to change your password:

1.

Select Tools->Change Password.

The Change Password dialog box will appear

Complete the dialog box.

User ID: This field displays your User ID. It will appear grayed-out and is uneditable.
Old Password: Enter your current password.

New Password: Enter the desired password.

Confirm Password: Re-enter the desired password. This field #xst match the password
entered in the New Password field. However, the password function is case-insensitive, so
capitalization does not matter.

Click OK to change to the new password, or Cancel to keep the old one.
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Shortcut Tips

Account ID Hyperlinks

Oracle Ultilities Billing Component and Oracle Utilities Rate Management includes a convenient

and time-saving shortcut for “jumping” from an open report to another module, while zeroing in

on information about an account of intetest.

How to use the account shortcut:

1.

Copying Text Between
This

Highlight the ID of an account of interest in an open report window. If the report was
generated based on a customer/account list, you can also select the list name.

Right-click in the report window, and select the desired option from the menu that appears.

When the next dialog opens, the ID is already supplied.

Windows

is another timesaving tip that enables you to copy information from one text entry field and

paste it into another, saving you the effort of retyping the data and ensuring that it is the same. It
is especially useful for Account IDs. The fields can be in the same or different windows.

How to copy text from one data entry field and paste it into another:

1.

Highlight the desired text, and wizh the I-beam cursor still positioned in the text field, click the right
mouse button.

A menu appeats.

Select Copy.

The text is now saved to the Clipboard.

Go to the window containing the field in which you wish to paste the text.

Click the cursor in the desired field. Without moving the cursor out of the field, click the righs
mouse button. When the menu appears, click Paste. The text appears in the field.

Alternate approach:

Here is another method that does the same thing, but with the keyboard instead of the mouse.

1.

2
3.
4
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Highlight the desired text in a text entry field. Do not move the cursor out of the text field.
Press CTRL+INSERT (or CTRL+C) on your keyboard.
Go to the window containing the field in which you wish to paste the text.

Click the cursor in the desired field. Without moving the cursor out of the field, press
SHIFT+INSERT (or CTRL+V) on your keyboard.



Saving and Applying Settings for Dialog Boxes

Saving and Applying Settings for Dialog Boxes

This section describes a very convenient and time-saving feature that enables you to save input
parameters for tasks you perform frequently. Specifically, you can save your selections for
account/customer and date(s). To use this feature, complete an input dialog box as you would
normally before running a billing, analysis, or reporting module, save the settings with a name of
your choosing, and recall them the next time you want to perform the same or a similar task.

How to save settings:

1. With the desired setting specified in an input dialog box, right-click in any blank area of the
dialog. The Save/Restore dialog box appears.

2. Enter a name and optional descriptive note for your settings, and click Save.
The settings are now saved to the database.

How to import/export settings:

To export:

1. Select the report settings and click Export. The Select File for Dialog Settings Report dialog
opens.

2. Navigate to the desired directory and click Save. The report settings are exported in XML
format, and can now be imported for use with other dialogs.

To Import:
1. Click Import. The Select File for Dialog Settings Report dialog opens.

2. Select the desired file and click Open. The report settings are now available for use with the
current dialog,

How to apply the settings:

1. Open the dialog box for which you’ve saved settings. Righ#-click in any blank area of the
dialog. The Save/Restore dialog appears.

2. Select the desired settings and click Restore.

The dialog is updated with the settings. You can use them as is, or modify them before
running the job.

How to delete the settings from the database:

The following instructions explain how to delete unwanted settings, so that they no longer appear
in the pop-up menu. You can delete reports by highlighting the report settings you wish to delete
and clicking Delete or by deleting the settings from the Data Repository using the Browser. To
delete report settings using the Browser, using the following procedure.

1. Select File->Browse->Customer Database. The Browser opens.

2. Click on the plus sign that appears to the left of the Report Settings table icon (you may
have to scroll down the tree to bring that table icon into view).

A list of the Report Setting records that are currently stored in the database appears under the
table icon. Each report setting record is identified by a combination of three IDs: the logon
ID of the user that saved the setting, the internal ID that identifies the dialog box to the
system, and the name that the user assigned to the settings when he/she saved them.

3. Highlight the icon for the record you wish to delete.
4. Select Edit->Delete from the menu bar.

A message box appears, asking you to confirm that you wish to delete the record. Click OK
to delete the record. Click Cancel to keep it.
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Closing a Dialog Box so Current Inputs are Saved or Discarded

If you complete an input dialog box but decide to close it without running the analysis, how you
close the dialog box determines the settings that the system displays the next time you open it:
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To revert to the default settings, click the Close button (X) in the upper tight corner of the
window. The current settings are not saved. The next time you open the dialog box, it will
display the defaults instead.

Click Apply to make use of the settings for this session only. To retain the original settings for
the next time, click the Cancel button. Click OK to save the zew settings for future use.



Chapter 3

Importing Data

This chapter explains how to import data into the database, where it is available for use by Oracle
Utilities products. This includes:

* Importing Customer Data

* Importing Interval Data

Making Interval Data Available to Oracle Utilities Applications

Mapping MV-90 Data to the Oracle Utilities Data Repository
* Interval Data Import DST Option
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Importing Customer Data

The Import utilities described in this section are flexible tools for managing the Data Repository.

You can use them to add new records and update existing records.

About the Import File

The first step is to create a file (either ASCII text or XML) that contains the data to be imported.
You will typically create the import files by extracting desired data from your utility’s billing

records, Customer Information System (CIS), and/or other computer data files, using an Export

program that has been customized to your data formats and applications.

Regardless of how they are created, the files must adhere to the specifications defined by Oracle.
These specifications are described in Appendix A: Oracle Utilities Data Repository Schema
Import File Format.

Using the Import Utility

1.
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Select File-Import Data Set->To Customer Database.
The Customer Database Import Utility dialog box appears.

Select the import file in the DataFile field, including the path and name of the Import file.
You can either type this information into the field, or click the Browse button to select the
desired file. If you type the information, you can supply either an absolute or relative path, but
you must include the complete file name, including either the “.imp’ or “xml’ extension.

Note: If you select an XML file to import, all settings except the DataFile and Name of
error file on this dialog are ignored. However, several of these “ignored” settings can be
specified within the XML import file. See Appendix A: Oracle Utilities Data Repository
Schema Import File Format for more information.

Optional. Specify the error file in the Name of error file field. If you specify a name here, the
application will create an error file to contain any invalid records from the original import file.
Any invalid records encountered during processing are copied as is into this error file. You
can correct the records in the error file, and then use it as the new import file in a second run
of the program. If you are importing a large quantity of data, you may have to repeat this
process several times, each time whittling down the number of errors until all data is
successfully imported. In that case, you may want to use a file naming convention to help
keep track of the file sequence; e.g,, filel.imp, file2.imp, file3.imp, and so on. If you use the
same name and path for each run, the program overwrites the file’s contents.

If you do not supply a path, the error file is placed automatically in the LODESTAR\USER
directory.

Optional. Specify the maximum number of errors (invalid records) in the import file before the
program stops processing in the Stop at error count field. If you leave the field blank (the
default), the program processes the entire file, regardless of the number of invalid records in
it. In either case, invalid records are not entered into the database.

Specify the number of records accumulated in a batch file before the program commits them
to the database in the Max. batch size of each commit field. This setting is used to
optimize the performance (speed) of the Import process. The default value is 500 records. If
performance is slow and you have spare hard disk space and memory capacity, try increasing
the number.

Specify how the program determines the percentage completed when displaying the progress
indicator bar by selecting the appropriate Record Count option:

*  Count (slower): The program reads the file once before processing it, to determine the
actual number of records in the file. This option is slower, but more accurate.
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10.

11.

12.

*  Estimate (faster): You supply a value for the number of records in the file, estimated
or real. The program uses your value as the 100% mark for the progress indicator. This
option is faster, but potentially less accurate.

Specify how the records in the Import file are processed by selecting the appropriate Import
Mode:

*  Add: Adds new records to the Data Repository. If there are any records in the file that
already exist in the database, or if there are duplicate record IDs in the import file, the
program considers it an error.

* Update: Replaces existing records in the Data Repository with the version in the
import file. If there are any records in the file that do not already exist in the database, or
if there are duplicate record IDs in the import file, the program considers it an error.

*  Delete: Deletes records from the Data Repository. For every parent ID in the import
file, the program automatically deletes both the parent and all of its dependents. If there
are any records in the file that do not already exist in the database, or if there are
duplicate record IDs in the import file, the program considers it an error.

* Add/Update: Both adds new records and replaces existing records. If a record is not
already in the database, it is added. If it does exist, it is updated.

Note: Using the ‘Add/Update’ mode will fail if the Import file contains more columns than
the database table you are importing data into. Existing records will not be updated, and New
records will not be created.

Specify the contents of the log file that is automatically produced at the end of the Import run
by selecting the appropriate Records to Log option:

*  None: Check this box if you don’t want to log any records.

*  All Records: Check this box if you want the log file to contain information about every
record processed, whether it had an error or not.

*  Records from these tables: Check this box if you want the log file to describe each
updated field for every record in selected tables. When you check this box, the list of
tables to the right becomes active. Select the tables you wish to log. To select more than
one, press Ctrl or Shift while selecting the table names.

Note: Applying the Log All Records and Log Update Fields options can significantly slow
processing time.

Select the type of data you wish to log by selecting the appropriate Data to log option:
*  Identity (Key): logs only the identity (key) of each record.
*  All fields: Logs all fields for each record.

If you do not want imported records rolled back each time an error occurs, check the Do not
rollback ERRORS checkbox. This allows batch commits to run faster.

Optional. You can write the log and error messages directly to a file, without viewing the
information on screen. This is the fastest way to run the Import utility, because it eliminates
the time and resources required for screen display. To do so, first click the Report Options
button, and check the Write Report Directly to File option in the dialog box that appears.
Then, click Save as. When the next dialog opens, specify a file name and location, and click
Save, then OK.

Note: If you do not select the Write Report Directly to File option here, the program
displays the error log at the end of the job run, but will not allow you to save it in a file.

When you have completed the dialog box, click OK.

A progress indicator appears.
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When the program run is finished, an Error Display window appears. If all of the records in
the file were imported successfully, the report will read
“n records processed, 0 had errors.”

If there were errors in the file, a warning message appears, and the report in the Error Display
window tells you how many errors there were and provides some information about them.

If there were errors and you specified the error file in Step 3, you can open the file, correct
the errors, and rerun the program using the corrected error file as the new Import file.

Note: If you close the error log window without selecting Write report
directly to file, you will be unable to reopen it later. If you want to keep a
record of the log, be sure to print it before closing the window.
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Importing Interval Data

The Interval Database stores “cuts.” A cut is one record of interval data for an account. Each cut
is identified by the recorder-ID, channel-number of the device that recorded it, as well as the start-
and stop-times of the period that it covers.

Note: If the concepts of interval data, recorders, and channels are new to you,
see Recorder/Channels and Interval Data on page 1-4.

Interval Data Import File Formats

The Interval Database can either reside in the Oracle Utilities Data Repository, or in a single file.
The available interval data formats are:

*  Oracle Utilities Enhanced Database Format (Pervasive.SQL) (*.bte)

*  Oracle Utilities Enhanced Input/Output Interval Data Format (*.Ise)
*  Oracle Utilities Standard Format (*.inp)

*  Oracle Utilities Comma Separated Format (*.csv)

*  Oracle Utilities Standard XML Format (*.xml)

*  MV90 Mainframe Format (*.mv9)

* EU Engineering Units Format (*.eu)

* DTV Engineering Units Format (*.dtv)

*  Meter Data Exchange Format (*.mdf).

See Appendix B: Oracle Utilities Enhanced Input/Output Interval Data Format,
Appendix C: Oracle Utilities Standard XML Interval Data Format - Version 1.2, and
Appendix D: Oracle Utilities Comma Separated Values (CSV) Interval Data Format for
more information about the interval data formats.

Depending upon the policies of your company, interval data from the field may be imported into
the Interval Database on a regular basis via automated batch routines, or may be imported
manually using the Interval Data Import utility.
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Interval Data Import Process

There are four main steps for importing interval data into the Interval Database and making it

available for use via the Oracle Utilities programs:

1.
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Obtain the Import file. This file contains the raw data in one of the import formats listed
above.

If the customers the data belongs to have not already been entered in the Oracle Utilities Data
Repository, you must set enter them. See Chapter 6: Browsing Data. At a minimum, you
must enter the following records to link the Interval Data Records to the accounts they
belong to:

Lookup codes (seec Chapter 6):
Operating Company

Jurisdiction

Account records (see Chapter 5):
Customer

Account

Recorder

Channel

Channel History

The complete list of records you must set up is dictated by the requirements and complexity
of the rate schedule used to calculate the customer’s bill. To produce a bill, you must also
create the rate form and identify it in the Data Repository using the Rate Form records and
Rate Code (see Chapter 6: Browsing Data). The above list is the minimum number of
records you need to link the interval data cuts in the Interval Database to the account records
in the Data Repository. (If the customer records do not exist, you can still import the cuts, but
the Import utility will generate an error message, and you will not be able to use the cuts for
billing or other purposes.)

Apply the Interval Data Import utility, as described in the next section.

Set your Options to “point” to the Interval Database, as described under Making Interval
Data Available to Oracle Ultilities Applications on page 3-9.
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Using the Interval Data Import Utility

The following instructions explain how to import a file into an Interval Database using the
Interval Data Import utility. This utility automatically produces a log at the end of the job to alert
you to any problems. You can view this log on-screen or save it to a file.

How to Import Interval Data:

1.

Select File-Import Data Set->To Interval Data Database.
The Interval Data Import Utility dialog box opens.

Select the Input File for the import, including the path and name of the file you wish to
import. Click the Browse button to select the desired file type and file. The path and file
name of the input file cannot have spaces in it. The Interval Data Source file defines the
default interval data input file type.

Select the Interval Data Database to import the file to.

If your interval data is stored in the Oracle Utilities Data Repository, select Customer
Database.

If you select file, specify the path and name of the Interval Database file you want to add the
contents of the input file to. The default is the interval data source file specified on the
Interval Data Source tab on the Default Options dialog. If using a Pervasive.SQL (*.bte)
format file, you can either type this information into the field or click the Browse button to
select the desired file.

If Interval Data is stored in the Oracle Utilities Data Repository and Btrieve/Pervasive.SQL
software is not installed, the and *.bte format is not available as input or output files.

Check the Export Overwritten Record(s) To File checkbox if you want any cuts that are
about to be replaced with new cuts in the Interval Database to be automatically exported to a
file that you specify. Specify the full path and name of the Export file in the field under the
checkbox.

If you enable this option, the program identifies any cuts in the Interval Database with the
same recorder-1D, channel-number, and start-time as a cut in the input file. It compares the
cuts’ stop time, SPI, UOM, start and stop readings, and pulse and meter multiplier and
offsets; as well as their interval values and status codes, interval by interval. If there are any
differences, it exports the old cut, appending it to the contents of the Export file.

Note: The start-times must match exactly; overlapping cuts are ignored. Enabling this option
can slow the Import process considerably.

Check the Check import data against CHANNELHISTORY values checkbox to
compare the cut’s header information with the description of the recorder that’s stored in the
Channel History Table (pulse multiplier, pulse offset, unit of measure, and so on). If there is
a mismatch, the cut fails and is not imported. If either the header or the Channel History
record has a null value in a field where the other record has a descriptive value, this does not
cause the cut to fail (only contradictory information causes an error). If you leave this option
unchecked, no comparison is made.

Select the UnderCount option from the drop-down list. This controls what behavior of
import functions when an incoming cut has too few recorded intervals for the time span
defined by the cut start time and the cut stop time and the DST Participant flag,

*  BE: Directs the function to behave similar to the default behavior observed in previous
installations and versions of Oracle Utilities products. This setting behave exactly like
FILL in most cases. If the cut being processed spans the end of the DST period, usually
the fall DST hour, if viewed directly from the raw flat file, the cut will appear to be filled
using DST calculations, yet if the cut is saved to any binary data source (RDB or BTE), it
will only be filled with missings as if the DST_Participant flag is set to “N”. For example,
if a cut is supplied that crosses the Fall DST change and has only 92 intervals (23 hours),
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the system will fill to only 96 not 100. If 100 intervals are supplied, then 100 will be
stored. Also, if 97 - 99 intervals are supplied, and the DST = “Y” then the system will
Reject the incoming cut.

Note: Use of this feature may prevent the Proxyday Extension from successfully reading
and merging together spring DST cuts imported using this feature. (It may effectively
cause the cuts to be stored in an overcount state.) Cuts being imported are for use with
Proxyday must have a valid number of intervals.

Using this feature on Spring DST cuts with may cause Data Manager and the Rules
Language to ignore the 4 missing intervals when calculating recorded intervals.

*  REJECT: Directs the function to produce and error and disallow the import of any
incoming/uploaded cut when it has too few recorded intervals (Expected > Recorded).

*  FILL: Fills all incoming cuts with missings (value = 0 Status = “9”) to the stop time of
the cut using DST adjustments if appropriate (DST_Participant = “Y”’).

*  ASIS: Allow the storage of any incoming cuts with a number of expected intervals
greater than the number of recorded intervals. The stop times of these cuts will remain
unchanged.

Select the OverCount option from the drop-down list. This controls the behavior of import
functions when an incoming cut has too many recorded intervals for the time span defined by
the cut start time and the cut stop time and the DST_Participant flag,

*  REJECT: Directs the function to produce an error and disallow the import of any
incoming/uploaded when cut has too many recorded intervals (Expected < Recorded).

*  BE: Behaves exactly like REJECT, except in the case where a cut that crosses the
beginning of a DST period, and has its recorded interval count equal to the expected
intervals count without the hour adjusted for DST.

*  ASIS: Allow the storage of any incoming cuts with a number of expected intervals less
than the number of recorded intervals. The stop times of these cuts will remain
unchanged.

Select the Validation Status option. This controls the default behavior of how the system
sets the Validate_Record_Flag.

*  Use Incoming Flag: Sets the incoming cuts as invalid if the Validate_Record_Flag for a
cut is set to “Y”, or valid if the flag is set to “N”. If the incoming Validate_Record_Flag
is “Y” then it will act as Force Invalid for that cut. If the incoming
Validate_Record_Flag is “N” then it will act as Force Valid for that cut.

*  Force Valid: Sets all incoming cuts in the import file as valid
(INTERNAL_VALIDATION, EXTERNAL_VALIDATION, MERGE, and DELETE
flags all set “Y”), effectively ignoring the Validate_Record_Flags of the imported cuts.

*  Force Invalid: Sets all incoming cuts as in the import file invalid
(INTERNAL_VALIDATION, EXTERNAL_VALIDATION, MERGE, and DELETE
flags all set “N”), effectively ignoring the Validate_Record_Flags of the imported cuts.

Optional. You can write the log and error messages directly to a file, without viewing the
information on screen. This is the fastest way to run the Import utility, because it eliminates
the time and resources required for screen display. In addition, this approach has the
advantage of saving the log as a record for future reference. If you do not apply this option,
the log is displayed on screen for viewing, but it is not saved. To apply this feature, click the
Report Options button, and check the Write Report Directly to File option in the dialog
box that appears. Next, click the Save As button. When the Save Report As dialog opens,
specify a file name and location and click Save.

Optional. Click the DST button to open the Timezone/Daylight Savings Time Options dialog;
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This advanced option lets you change the start- and stop-times of an input cut to the
corresponding times in a different timezone. You can change the start- and stop-times of a
cut from Standard Time to DST, from DST to Standard Time, and from 24-Houtr Adjusted
DST to DST or Standard Time. To use this option, select the input timezone and the target
timezone.

If only some of the data in the file is to be converted, you can use a Control file to make the
conversion specific to each recorder. Check the Recorder Specific Conversion File
checkbox, and select the appropriate Control file. If a recorder is in the file, the time zones
there override those chosen in this dialog box. Each line in the Control file must contain a
recorder ID (case sensitive), followed by a comma, followed by its input time zone, a comma,
and its target time zone. There must not be any spaces before the recorder ID; however,
spaces around the commas are ignored. A line may be empty. If it starts with a 5 the line is
ignored - it can be used as a comment. If the cut’s supplied time zone and DST information
do not match the input time zone, it results in an error.

When you have completed the dialog box, click OK.

If you specified Write Report Directly to File in the previous step, a message box appears
alerting you when the Import process completes. You can use the File->Open->File option to
view the contents of the log file.

If you did not specify Write Report Directly to File, the log appears in the Error Display
window (despite its name, this does not necessarily mean that there were errors). Review the
contents of the log to ensure that all records processed as expected. If you want a record of
the log file, print it by selecting File->Print. (The electronic version is automatically discarded
when you close the report window.) Close the window by selecting File->Close.

Important Note
Due to data storage limitations of the CLDB file format, importing interval data into a CLDB file
will yield incorrect values. Check with your System Administrator to determine the specific format
of your interval data files. The file type is displayed in parentheses following the interval data file
name when browsing interval data cuts. See Chapter 6: Browsing Data for more information.

For greater precision, Oracle Ultilities recommends using the .Ise file format when possible.

Making Interval Data Available to Oracle Utilities Applications
Before you can use any of the Oracle Utilities client/server applications such as Data Manager or
Oracle Utilities Billing Component with the data you just imported, you must set your Options to
“point” to the Interval Database.

Note: You can also use the Interval Data Options tab to specify how the
interval data is processed for analysis and billing. For example, you can set the
level of acceptable quality for the data, and how data is handled when Daylight
Savings Time takes effect. See Default Options on page 2-9.

How to “point” to the desired interval data source:

1.

Select Tools->Options.

The Default Options dialog box appeats.

Click the Interval Data Source tab.

Select the appropriate Type:

*  File: Select the desired interval database file type. The available interval data formats are:
*  Oracle Utilities Enhanced Database Format (Pervasive.SQL) (*.bte)
*  Enhanced Oracle Utilities Input/Output Format (*.Ise)

*  Oracle Utilities Standard Format (*.inp)
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*  Comma Separated Values Format (*.csv)

*  Oracle Utilities Standard XML Format (*.xml)
*  MV90 Mainframe Format (*.mv9)

*  Meter Data Exchange Format (*.mdf).

*  Default: Specifies to use the default Interval Database identified in the
LODESTAR.CFG file. See the Oracle Utilities Energy Information Platform Configuration
Guide for more information about setting a default Interval Database.

*  Customer Database: Specifies to use interval data stored in the Oracle Utilities Data
Repository.

4. If you selected File, click Browse and select the desired file. If the name of the desired file is
already displayed in the File field, click Cancel to close the dialog. The Interval Data Source
file defines the default interval data input file type.

5. Select one of the following choices for applying the new setting:

OK: Saves the new setting as your default interval data source, replacing the previous setting.
Any Oracle Utilities program you run will automatically use this interval database.

Apply: Applies to current work session only; that is, the setting will revert to the previously
specified interval data source after this work session.

Mapping MV-90 Data to the Oracle Utilities Data Repository
This section describes the mappings from MV-90 files to the Oracle Ultilities Data Repository.
MV-90 field names ate used in the following descriptions.

Overlap
The ‘Check import data overlap option’ on the Interval Data Import Utility dialog allows you to
indicate that ovetlaps are an error. If you select this option, the dates for each cut are compared to
the dates on other cuts for the same recorder and channel in the interval data repository. If there
is any overlap it will be an error and the group will be skipped. If you select this and there is a gap,
a warning message will be written to the log file, but it is not an error.

Header
Some information in the LODESTAR Interval Data Repository header is not supplied in the MV-
90 file. Most of these values that are not supplied will be filled in with the default values, as listed
in Interval Data Repository Header Data (p. 16). Two values must be supplied by the user
when importing data. An option to the program indicates the DSTPARTICIPANT status and the
time zone of the input data. The Interval Data Import DST Option on page 3-17 section
describes this option.

The field mappings from MV-90 Channel Header record to Interval Data Repository Header are:

MV-90 Field Name LODESTAR Field Name
DC_RECID RECORDER_ID
LOGCHAN, DC_LLOGCHAN CHANNEL

TA_START START_TIME

TA_STOP STOP_TIME

STRTMTR METER_START_READING
STOPMTR METER_STOP_READING
DC_MMULT METER_MULTIPLIER
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MV-90 Field Name

LODESTAR Field Name

DC_PMULT PULSE_MULTIPLIER
DC_POFFS PULSE_OFFSET
DR_INPHR SECONDS_PER_INTERVAL
(3600 / DR_INPHR)
DC_UMCODE UOM
STATUS ACCEPT_REJECT_STATUS
DR_TDATE TRANSLATION_DATE
DC_FLOW DC_FLOW
DR_NOTE DESCRIPTOR (from MV-90 CUSTOMER record)

Oracle Utilities identifies a cut by its recorder ID, channel number and start time. The recorder ID
will come from the DC_RECID field in the Channel Header Record. It is treated as a character
string, so leading and trailing spaces will be removed, but leading and trailing zeros will be
retained. The channel number is a three-digit number. The low order two digits (00 - 99) will
come from the DC_LOGCHAN field, the high order digit (0## through 9##) will come from
the LOGCHAN field, both in the Channel Header Record. The start time comes from the
TA_START field in the Channel Header Record.
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Note: The Oracle Utilities Rules Language INTDLOADxxx functions have
been modified to add all cuts with MV90_DC_FLOW flag set to ' ' (space) or
'D', and subtract all cuts with the flag set to 'R'. The FOR EACH CHANNEL
statement can be used to find only the cuts with the flag set to one value or
another.

Note: The MV-90 DR_INPHR field must NOT be set to ‘00.’

Values
The MV-90 DATA_TYPE field will be used to determine if values are in pulses or engineering
units (EU). The two valid values for this field are 'P' or 'E' (Pulse or Engineeting). Any other value
will be an error. All Oracle Ultilities interval data values ate stored as engineering units. MV-90
pulse values will be converted to engineering units using the formula:

EU = (pulse * DC_PMULT) + DC_POFFS
Status Codes
When interval data in MV90 format is imported into the Oracle Utilities Data Repository, any
Channel or Interval status codes in the incoming data are mapped to Oracle Ultilities status codes
based on the configuration of the MV90 Status Code Map table. MV90 status codes are set at

specific bits within the MV90 format. The mapping for each bit in the MV90 Status Code table
determines the resulting Oracle Utilities status code.

MV90 data can store multiple status codes for the channel and for each individual interval. Oracle
Utilities stores only individual status codes for each interval (see Note below). If more than one
bit is set on the same interval, the mapping with the higher priority is used.

Example: When importing MV90 data with interval status codes set at bits 1, 2, and 3 for a single
interval, the following records in this table would result in a Oracle Ultilities status code of 4 for
that interval.

Mapping 1

* MV90 Status Word: Interval Status
* Bitl

* LODESTAR Status Code: 2

*  Priority: 1

Mapping 2

e MV90 Status Word: Interval Status
* Bit:2

* LODESTAR Status Code: 3

*  Priority: 2

Mapping 3

e MV90 Status Word: Interval Status
* Bit:3

* LODESTAR Status Code: 4

*  Priority: 3

Note: The MV90 Status Code Map table is used when mapping MV90 status codes to standard
Oracle Ultilities status codes only. This table is NOT used to define Oracle Utilities Extended
Status Codes.

3-12 Data Manager User’s Guide



Importing Interval Data

Relational Data Import
Some values in the MV-90 Customer Header and Channel Header correspond to column values in
the Oracle Ultilities Data Repository. The actual table and column that corresponds to a MV-90
field depends on the clients database configuration. The action to take when a record or value is
missing or different form a MV-90 field value also depends on the client. The following is
intended to explain how MV-90 data is mapped into their Oracle Utilities Data Repository.

A MV-90 field may map to zero, one or more database columns (though only one column per
table). In some cases, you may want a MV-90 field change to update one column, but add a new
record for another table. In addition, you may want a change that causes a mismatch to generate
an error. The following rules address these issues, and are used when importing relational data:

a)If record is not available, create it,

b)If record is not available, error,

o)If record is available and corresponding column equals field, do nothing,

d)If record is available and corresponding column is NULL, update column,

e)If record is available and corresponding column does not equal field, error,

f)If record is available and corresponding column does not equal field, update column,

@)If record is available and corresponding column does not equal field, stop current record,
add new one.

Rule c is always in effect.

Several MV-90 fields may be required to key a database record. However, in the Oracle Utilities
Data Repository, relative to interval data, all record keys can be derived from recorder id, channel
and start time. In the following, when a table is specified its key is automatically derived from
these three values.

The import program uses a mapping file - MVIOMAPTXT - to determine how to map MV-90
data to the Oracle Utilities Data Repository. This file is REQUIRED to run the MV-90 import
program. See Sample Mappings on page 3-15 for a sample version of this file. The file must be
an ASCII text file. The first line indicates the input file type and consists of the keyword INPUT
followed by a comma and the keyword MV90.

The filename and path must be specified using the MVIOMAPFILE config parameter:
MVIOMAPFILE=\\FILESERVER\PATH\MV90MAP.TXT

If the parameter is specified with no value, then the import is done without relation database
update. If the parameter is not specified then any use of an MV file extension will produce an
error indicating that the feature is not enabled.

Each subsequent line describes one mapping - the MV-90 record and field, the Oracle Utilities
Data Repository table and column (virtual column), and the action, comma separated. Spaces
around commas are ignored. There are three MV-90 records - CUSTOMER, CHANNEL, and
DEFAULT. The action can be one of four letters - E, A, U or (Error, Add, Update or Insert).
Action I can only apply to the DEFAULT record (that is, if the record is DEFAULT, then its
action can not be anything but I). Action E, A, and U can apply to mappings from any record but
DEFAULT. Blank lines and lines that start with a semi-colon (j) are ignored.

If the MV-90 record is DEFAULT, then the value in the MV-90 field may be used as the column
value. Itis used only when adding a new record to the database and the corresponding column in
the database does not have a value in it.

Mapping must be put in order. Parents table must be mapped before its dependent tables.

Every column in the Oracle Utilities table's identity must be specified, except for the
STARTTIME column, which is described below.
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If two fields and their corresponding column values are both not equal, the action with the highest
priority is taken. The priority order, from high to low, is Error, Add and Update. Thus if one field
says Update and another says Add, a new record will be created with both new values - their values
in the original record will be unchanged.

If a record is added because of a mis-compare with an existing record, all unchanged columns in
the original record will be copied to the new record.

The action I is used only if a record is added, the corresponding columns are not compared. It is
not used if there was an old record, the old record's values are always used.

In the special case of DC_LOGCHAN as the MV-90 field, the LOGCHAN field will also be used
to create a three digit channel number, just as in the Interval Data Import section above.

The record in a table with a STARTTIME and STOPTIME column is chosen as the last one in
effect on the cut stop (TA_STOP). If there is no overlap this means the record is not available
(see Rules a and b above). If the table contains a STOPTIME column and an Add action happens,
the original record's STOPTIME will be updated to be either the previous cut's stop time (if
overlap check is on) or the new record's STARTTIME minus one second.

The lines for recorder and channel should always be first in the file (recorder first, channel
second). The only actions allowed for them are Add and Exrror (see Rules a and b above).
Records in all other tables are found via the straight path from the RECORDER and CHANNEL
tables.

The MV-90 Customer record will be processed once, using the first channel headet's recorder and
channel. All Channel records will be processed once per channel header record.

The order of the file can affect performance, since the first error will cause the import of the cut
to stop.

It is an error if a specified field is missing (all binary zeros or spaces) in the MV-90 cut and is
required for the relational database. If it is missing and not required, the corresponding field will
be set to NULL.

It is an error if a Oracle Utilities Data Repository table or column does not exist. It is an error if
the same table and column is used to match more than one MV-90 field. This validation happens
before any data is imported.
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Sample Mappings
The following is a sample MVOOMAPTXT file:

; Input type
INPUT, MV90

; MV-90 LODESTAR Customer Database
;RecordFieldTableColumn Action

DEFAULT, TVA, OPERATINGCOMPANY, OPCOCODE, I
DEFAULT, TVA, OPERATINGCOMPANY, OPCONAME,, I

DEFAULT, Tennessee, JURISDICTION, JURISCODE, I
DEFAULT, Tennessee, JURISDICTION, JURISNAME, T

CHANNEL,DC RECID,RECORDER,RECORDERID, E
DEFAULT,10/10/1980,RECORDER, STARTTIME, I

CHANNEL,DC LOGCHAN, CHANNEL, CHANNELNUM, E

CUSTOMER,CM_ADDR1, SUBSTATION, SUBSTATIONNAME, U
DEFAULT, TVA, SUBSTATION, OPCOCODE, T
DEFAULT, TVA, SUBSTATION, JURISCODE, T

CUSTOMER,CM ADDRZ2, TRANSFORMERLOC, TRANSFORMERLOCNAME, U

CHANNEL, DC_RECID, CHANNELHISTORY, RECORDERID, A
CHANNEL, DC LOGCHAN, CHANNELHISTORY , CHANNELNUM, A
CHANNEL, DC_UMCODE, CHANNELHISTORY , UOMCODE,, A
CHANNEL, DR INPHR,CHANNELHISTORY, IPH,A

CHANNEL, DC_MMULT, CHANNELHISTORY, METERMULTIPLIER, A
CHANNEL,DC_PMULT, CHANNELHISTORY, PULSEMULTIPLIER, A
CHANNEL,DC_POFFS, CHANNELHISTORY , PULSEOFFSET, A
CHANNEL,DC_PTRATIO,CHANNELHISTORY, VT, A
CHANNEL,DC_SERVTYPE, CHANNELHISTORY, SERVTYPE,A (not converted to # wires)
CHANNEL, DC_NDIALS, CHANNELHISTORY, NOOFDIALS, A
CHANNEL, DC_METERID, CHANNELHISTORY , METERNUMBER, A
DEFAULT, Y, CHANNELHISTORY, BILLED, I

DEFAULT, I, CHANNELHISTORY, TOTALIZE, I

CHANNEL,DR DEVSN, RECORDERHISTORY, SERTALNUMBER, A
DEFAULT,10/10/1980,RECORDERHISTORY, INSTALLDATE, I

The first CHANNELHISTORY line will cause a new record to be created if there is no
corresponding record.

Logging and Error Messages
A log file is generated during the import process. It describes each cut imported and provides
specific error messages if an error occurs. The error message indicates the recorder and channel
that failed, with as much detail about the error as is known.

A second log is also written. It's name is LGddmmyy.LSI (dd = day, mm = month, yy = year, LSI
for LODESTAR Import). Only one file is created per day, subsequent runs during the day will
append to the day's file. There will be one line per customer record and per MV-90 channel
header processed.

A channel header record consists of the input file name, RCODE 10, eight digit channel header
line number, 20 character recorder id (DC_RECID), three digit channel number (LOGCHAN
DC_LOGCHAN), start time (MMDDYYHHMM from TA_START), stop time
(MMDDYYHHMM from TA_STOP) and a success code, all comma separated, all values from
the Channel Header Record. The success code is zero for successful import and one for any error
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or failure, even of another cut in the same group. When an error happens to a cut and the group is
skipped, a log message is still written for every cut in the group.

A customer record consists of the input file name, a two digit RCODE 1, an eight digit customer
header line number, a 20 character customer id (CM_CUSTID), the number of expected channel
records (CM_LOGCHANS, three digits), start time (MMDDYYHHMM from TA_START), stop
time MMDDYYHHMM from TA_STOP) and a success code. All the fields are comma
separated, and come from the Customer Header Record. The success code is zero (0) if all cuts
imported successfully, and is one (1) for any error or failure of any cut following this customer
record and before another customer record.

Note that all fields after the input file are fixed width. Numeric fields are right justified with
leading zeros replaced with spaces. Character fields are left justified and blank filled. If the input
file names are all the same length, the file contains records with all fixed width columns.

An example of the log file is as follows:

JANO1.Mv9, 10, 2,1013001 , 1,0215990804,0314990810,0
JANO1.Mv9, 10, 100,1013001 , 2,0215990804,0314990810,0
JANO1.Mv9, 10, 200,1013001 , 5,0215990804,0314990810,0
JANO1.MV9, 1, 1,1013001 , 3,0215990804,0314990810,0
JANO1.Mv9, 10, 321, 6833057 , 1,0215990820,0314990830, 1
JANO1.Mv9, 10, 442,6833057 ,124,0215990820,0314990830, 1
JANO1.MV9, 1, 320, 6833057 ,  2,0215990820,0314990830, 1

Interval Data Repository Header Data
The following data is stored in each record (cut) in the Oracle Ultilities Data Repository:

Field Name Data Type Default Value
RECORD TYPE char ' ' (space)
RECORDER ID char

CHANNEL integer

START TIME datetime

DATE TIME STAMP char Date and time of import
STOP_TIME datetime

METER START READING float

METER STOP READING float

METER MULTIPLIER float

METER OFFSET float 0

PULSE MULTIPLIER float

PULSE OFFSET float

POPULATION float 0

WEIGHT float 0

CALC CONSTANT float 0

SECONDS_PER INTERVAL integer 3600 / Intervals-per-hour
TOTAL INTERVALS integer computed
BASIC UNIT CODE integer 0

UuoM integer

TIME ZONE WEST OF GMT integer Import Program input
DATA TYPE char ' ' (spaces)
DESCRIPTOR char

EDITED char ' ' (space)
INTERNAL VALIDATION char "' (space)
EXTERNAL VALIDATION char "' (space)
MERGE char "' (space)
DELETE FLAG char "' (space)
DATA STATUS FLAG char 'y

START OFFSET FIAG char ' ' (space)
ORIGIN char 'M'  (Metered)
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VAL FIAG E char "' (space)
VAL FIAG I char "' (space)
VAL FIAG O char ' ' (space)
VAL FIAG N char ' ' (space)
TK WRITTEN FLAG char N
DST PARTICIPANT char Import Program input
New interval data cut fields
Field Name Data Type Default Value
Mv90 STATUS char (2) Cut Accept/Reject Status Code
MV90_DR TDATE datetime Translation Date / Time
MV90 DC FLOW char (1) D or ' ' (Delivered), R (Received)

Interval Data Import DST Option
All interval data is stored with the time adjusted to match the accounts that use it. An option on
the interval data import dialog and command line (the DST button) allows the user to specify the
timezone of the input file and the timezone of its target accounts.

TIMEZONE Description

A timezone code describes the timezone. Four fields are associated with a timezone:

« CODE Usually three or four letters such as EDT or EDTA, EST, CST, ...

* NAME Visible name - Eastern Daylight Time, Fastern Standard Time,
Central Standard Time, ....

* TIMEZONE An integer that is the number of timezones west of GMT (Greenwich
Mean Time).

« DST Y - Indicates that all dates and times reflect Daylight Savings Times,

23 hours in spring, 25 in fall.

A - Indicates that all dates and times reflect Daylight Savings Times,
intervals are 24 hour adjusted.

N - Standard time.

Some examples:

CODE NAME TIMEZONE DST
EST Eastern Standard Time 5 N
EDT Eastern Daylight Time 5 Y
EDTA Eastern Daylight Time - Adjusted 5 A

See Timezone Codes on page 3-18 for a complete listing of Time Zone codes.

Interval Data Import
The Interval Data Import dialog has a DST dialog that lets the user input the meter and target
timezones when importing interval data. This is the Timezone/Daylight Savings Time
Options dialog. In addition, the value supplied to the -z switch on INTDIMP.EXE is the meter
timezone, a slash, then the target timezone, and then an optional colon and recorder specific
control file.

The meter timezone specifies how the data was measured, the target timezone specifies how the
data is to be stored. The recorder specific control file contains a list of recorders and their
individual meter and target timezones, comma separated (one recorder per line). Spaces around
the commas are ignored. The values in the control file override the command line or user selected
meter and target timezones. The command line meter and target timezones must both be present,
or both missing.
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A sample control file might look like this:

RECORDER1, EST, EDT
RECORDERZ, EDTA, EDT

Sample command lines are:

intdimp ... Import all cuts as they are

intdimp ... -zEST/EDT Import and convett all cuts from EST to EDT

intdimp ... -zEST/EDT:PSL.TXT Convert all cuts from EST to EDT, unless
otherwise specified in PSLTXT

intdimp ... -z:PSLTXT Import all cuts as they are, unless otherwise
specified in PSL.TXT

If an input format is used that supports meter timezone information (such as the LodeStar
enhanced format) and the values in the input file are different from the input meter option an
error will be generated.

If the expected count of intervals differs from that in the file, an error will be generated. The
expected count is basically determined by this equation (where times are measured in seconds):

Interval count = ((stop-time + 1) - start-time) / second-pet-intetval,
adjusted by plus or minus the IPH if the dates cross a DST transition (first Sunday in April, last

Sunday in October).

Timezone Codes

CODE NAME TIMEZONE DST
GMT Greenwich Mean Time 0 N
BST British Summer Time 47 N
BSTA British Summer Time - Adjusted 0 A
IST Irish Summer Time 47 N
ISTA Irish Summer Time - Adjusted 0 A
WET Western Europe Time 0 N
WEST Western Europe Summer Time 0 Y
WESTA Western Europe Summer Time - Adjusted 0 A
CET Central Europe Time 46 N
CEST Central Europe Summer Time 46 Y
CESTA Central Europe Summer Time - Adjusted 46 A
EET Eastern Europe Time 44 N
EEST Eastern Europe Summer Time 44 Y
EESTA Eastern Europe Summer Time - Adjusted 44 A
MSK Moscow Time 42 N
MSD Moscow Summer Time 42 Y
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CODE NAME TIMEZONE DST
MSDA Moscow Summer Time - Adjusted 42 A
AST Atlantic Standard Time 8 N
ADT Atlantic Daylight Time 8 Y
ADTA Atlantic Daylight Time - Adjusted 8 A
EST Eastern Standard Time 10 N
EDT Eastern Daylight Time 10 Y
EDTA Eastern Daylight Time - Adjusted 10 A
CST Central Standard Time 12 N
CDT Central Daylight Time 12 Y
CDTA Central Daylight Time - Adjusted 12 A
MST Mountain Standard Time 14 N
MDT Mountain Daylight Time 14 Y
MDTA Mountain Daylight Time - Adjusted 14 A
PST Pacific Standard Time 16 N
PDT Pacific Daylight Time 16 Y
PDTA Pacific Daylight Time - Adjusted 16 A
UTC-12 Universal Time Coordinated - 12 hours 24 N
UTC-12D Universal Time Coordinated - 12 hours (DST) 24 Y
UTC-12DA Universal Time Coordinated - 12 hours (24 Hr 24 A

Adjusted)
UTC-11 Universal Time Coordinated - 11 hours 22 N
UTC-11D Universal Time Coordinated - 11 hours (DST) 22
UTC-11DA Universal Time Coordinated - 11 hours (24 Hr 22

Adjusted)
UTC-10 Universal Time Coordinated - 10 hours 20
UTC-10D Universal Time Coordinated - 10 hours (DST) 20
UTC-10DA Universal Time Coordinated - 10 hours (24 Hr 20

Adjusted)
UTC-9 Universal Time Coordinated - 9 hours 18
UTC-9D Universal Time Coordinated - 9 hours (DST) 18
UTC-9DA Universal Time Coordinated - 9 hours (24 Hr 18

Adjusted)
UTC-8 Universal Time Coordinated - 8 hours 16
UTC-8D Universal Time Coordinated - 8 hours (DST) 16 Y
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CODE NAME TIMEZONE DST
UTC-8DA Universal Time Coordinated - 8 hours (24 Hr 16 A
Adjusted)
UTC-7 Universal Time Coordinated - 7 hours 14
UTC-7D Universal Time Coordinated - 7 hours (DST) 14
UTC-7DA Universal Time Coordinated - 7 hours (24 Hr 14
Adjusted)
UTC-6 Universal Time Coordinated - 6 hours 12
UTC-6D Universal Time Coordinated - 6 hours (DST) 12
UTC-6DA Universal Time Coordinated - 6 hours (24 Hr 12
Adjusted)
UTC-5 Universal Time Coordinated - 5 hours 10
UTC-5D Universal Time Coordinated - 5 hours (DST) 10
UTC-5DA Universal Time Coordinated - 5 hours (24 Hr 10
Adjusted)
UTC-4 Universal Time Coordinated - 4 hours 8
UTC-4D Universal Time Cootdinated - 4 hours (DST) 8
UTC-4DA Universal Time Coordinated - 4 hours (24 Hr 8
Adjusted)
UTC-3 Universal Time Coordinated - 3 hours 6
UTC-3D Universal Time Coordinated - 3 hours (DST) 6
UTC-3DA Universal Time Coordinated - 3 hours (24 Hr 6
Adjusted)
UTC-2 Universal Time Coordinated - 2 hours 4
UTC-2D Universal Time Coordinated - 2 hours (DST) 4
UTC-2DA Universal Time Coordinated - 2 hours (24 Hr 4
Adjusted)
UTC-1 Universal Time Coordinated - 1 hour 2
UTC-1D Universal Time Coordinated - 1 hour (DST) 2
UTC-1DA Universal Time Coordinated - 1 hour (24 Hr 2 A
Adjusted)
UTC Universal Time Coordinated 0 N
UTCD Universal Time Cootdinated (DST) 0 Y
UTCDA Universal Time Coordinated (24 Hr Adjusted) 0 A
UTC+1 Universal Time Coordinated + 1 hour 46 N
UTC+1D Universal Time Coordinated + 1 hour (DST) 46 Y
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CODE NAME TIMEZONE DST

UTC+1DA Universal Time Coordinated + 1 hour (24 Hr 46 A
Adjusted)

UTC+2 Universal Time Coordinated + 2 hours 44

UTC+2D Universal Time Coordinated + 2 hours (DST) 44

UTC+2DA Universal Time Coordinated + 2 hours (24 Hr 44
Adjusted)

UTC+3 Universal Time Coordinated + 3 hours 42

UTC+3D Universal Time Coordinated + 3 hours (DST) 42

UTC+3DA Universal Time Coordinated + 3 hours (24 Hr 42
Adjusted)

UTC+4 Universal Time Coordinated + 4 hours 40

UTC+4D Universal Time Coordinated + 4 hours (DST) 40

UTC+4DA Universal Time Coordinated + 4 hours (24 Hr 40
Adjusted)

UTC+5 Universal Time Coordinated + 5 hours 38

UTC+5D Universal Time Coordinated + 5 hours (DST) 38

UTC+5DA Universal Time Coordinated + 5 hours (24 Hr 38
Adjusted)

UTC+6 Universal Time Coordinated + 6 hours 36

UTC+6D Universal Time Coordinated + 6 hours (DST) 36

UTC+6DA Universal Time Coordinated + 6 hours (24 Hr 36
Adjusted)

UTC+7 Universal Time Coordinated + 7 hours 34

UTC+7D Universal Time Coordinated + 7 hours (DST) 34

UTC+7DA Universal Time Coordinated + 7 hours (24 Hr 34
Adjusted)

UTC+8 Universal Time Coordinated + 8 hours 32

UTC+8D Universal Time Coordinated + 8 hours (DST) 32

UTC+8DA Universal Time Coordinated + 8 hours (24 Hr 32
Adjusted)

UTC+9 Universal Time Coordinated + 9 hours 30

UTC+9D Universal Time Coordinated + 9 hours (DST) 30

UTCH+9DA Universal Time Coordinated + 9 hours (24 Hr 30
Adjusted)

UTC+10 Universal Time Coordinated + 10 hours 28

UTC+10D Universal Time Coordinated + 10 hours (DST) 28 Y
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CODE NAME TIMEZONE DST

UTC+10DA Universal Time Coordinated + 10 hours (24 Hr 28 A
Adjusted)

UTC+11 Universal Time Coordinated + 11 hours 26

UTC+11D Universal Time Coordinated + 11 hours (DST) 26

UTC+11DA Universal Time Coordinated + 11 hours (24 Hr 26

Adjusted)
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Chapter 4

Exporting Data

This chapter explains how to export records in from the Oracle Utilities Data Repository to files
that can be shared with other users or products, or archived for safekeeping. If desired, you can
delete the records to free disk space. This includes:

* Exporting Customer Data

*  Exporting Interval Data
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Exporting Customer Data

Data Managet’s Export and Delete functions are important tools for archiving data in the Oracle
Utilities Data Repository, and for making that data available to other Oracle Utilities products.
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The Records menu provides the following Export options:

Export - Exports all records* from a selected table, including all associated parent, child, and
lookup records, when specified. The Export file is in the Import format (either *.imp or
*xml). If desired, you can archive the file onto disk or other media for safekeeping. Because
the data is in Import format, you can import the data back into the database using the Import
utility, if necessary.

Delete - Deletes all records* from a selected table, and all associated child records. No
Export file is created.

Export/Delete - Exports all records* in a selected table, and all associated child records, and
deletes same records from the database.

The Export file is in Import format (either *.imp or *.xml), in the correct order for importing
back into the database.

*In all three modes, it is possible to filter the records. If you apply this option, only records
in the specified table that meet the specified criteria will be exported and/or deleted (along
with their parent, lookup, and child records in the Export mode, and child records in the
Delete and Export/Delete modes). For example, you could filter records of a specified table
based on Start Date of 10/01/97 and Stop Date of 10/31/97. If you applied the Delete
mode to the Account Table, all accounts that were terminated in October 1997 would be
deleted from the database, along with any of their child records, such as Bill Histories.

In all modes, the program automatically creates a log file at the end of the run and places it in
the USER directory. It lists the accounts exported and/or deleted, as well as a count of the
other records exported and/or deleted, by table.

Note: When importing a previously exported data set, be sure to use the Import
utility's Add mode. Using the Update or Add/Update modes would overwrite
any records that had been updated since the archive process was performed,
replacing a newer version with an older one.
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Exporting and Deleting Customer Data

Before you delete data from the Data Repository, you must be certain it is no longer required. The
three options discussed here (Export, Delete, and Export/Delete) enable you to:

Export records to a portable format (*.imp or *.xml)
Delete records from the Data Repository

Delete records from the Data Repository as they are exported to a backup file.

Filtering Data

Data Manager provides a Filter option that enables you to reduce the number of records

displayed in the Browser. The Filter enables you to view only records of a type you specify. You

should filter information before using the Export/Delete functions, to be certain that you get only
the desired records.

How to filter data in the Data Repository before exporting and or deleting:

1.

Select File->Browse->Customer Database.
The Browser appears.

Click on the icon for the table containing the records you want to export or delete. A list of
records currently stored in that table appears in the right pane.

To select the records to be exported and/or deleted based on specified critetia, select
Records-Filter. The Set Filter dialog appears.

Complete the dialog as follows:

Account ID: The ID of the account that contains the data to be exported. Click Exact to
look for a specific Account ID.

List Names: You can also filter data based on a table-column list..

*  Table Name: Select the table the list will be based on. Defaults to the table currently
selected in the Browser.

¢ List Names: Select a list from the List Names box and click Add>> to move it to the
Selected Lists box. To remove a list from the Selected Lists box, click << Remove.
To clear all the lists in the Selected Lists box, click Clear.

*  To create a new filter list, click New List. This opens the Table-Column list dialog (see
Chapter 7: Maintaining Data for more information).

Click OK to close the filter dialog.

The display in the right pane of the Browser is automatically updated with the results of your
Filter.

Note: Records filtered by lists cannot be updated or deleted using the browser.

Exporting Data

The Export function enables you to copy records to a *.inp file.

How to export data:

With the appropriate data in displayed in the Browser:

1.

Select Records->Export.

A dialog appears with three additional options. You can choose any combination, from none
to all three. These options let you export all or a selected portion of the complete hierarchy
the originally-selected records belong to:

*  Child Records: Exports all dependent records associated with the target records.
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*  Referenced lookup records: Exports the complete record, including any lookup codes
referenced in the target records.

*  Referenced parent records: Exports all higher-level records to which the target
records belong. For instance, if the target table is the Channel History Table, all
customer and account records that are “parents” to the channels in the Channel History
Table will be exported as well.

Select the appropriate options and click OK. The Export Records File As window appears.
Choose a file name and destination directory, as desired.

Data Manager will use the file name and directory for the Export file, and for the log file that
is automatically created at the end of the job; the default filename for both is “plexport”.

Select the Save as type. There are three choices:

*  Export Files (*.imp). This is the default type. This is the file format used by the Import
Utility and the PLIMPORT batch executable (see Chapter 3: Importing Data). If you
intend to import the data back into the database, select this type.

* XML Version 1 (*.xml) This exports the data in an XML format that can be used to
export data for use in external applications.

* XML Version 2 (*.xml) This exports the data in an XML format that can be used by the
Import Utility and the PLIMPORT batch executable (see Chapter 3: Importing Data).
If you intend to import the data back into the database, select this type. This format can
also be used to export data for use in external applications. This format is supported in
version 4.00 and later only.

If the file name you specified above already exists in the destination directory, Data Manager
gives you the option of either overwriting the existing Export file or appending (adding) the
new records to the existing file. Respond as desired.

You can now select File->Open->File to view the Export file. You can also view and/or edit
the file using a text editor such as Notepad.

Notes About Exported Records:

If you export lookups (the Referenced lookup records option on the Export dialog), each
lookup record will appear only once in the Export file.

Trailing commas are removed from exported records.

Exporting an Account
The Export function can be used to export records for a single account or group of accounts, as

follows.

How to Export Records for an Account or Accounts

1.
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Create a query list for the specific account(s) you wish to export using the Query List
function described in Chapter 7: Maintaining Data.

Select File-»Browse->Customer/Account.

Click on the List radio button, select the appropriate list for the account(s) to be exported,
and click OK. The account(s) specified in the list will appear in the Browser.

Click on the word ‘Account’ at the top of the left pane of the Browser.
Select Records->Export.

Check all three options listed (Child Records, Referenced Lookup Records, and Referenced
Parent Records) and click OK.

Name the Export file and save it as appropriate.
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Deleting Data

The Delete function permanently removes data from the Data Repository. It removes all the

records from a selected table, and any child records belonging to it. Be absolutely certain that any

important data has been backed up before you use this function. When data is deleted from the

Data Repository, it can only be recovered from a backup file.

With the appropriate data displayed in the Browser:

1. Highlight the table you want to clear.
2. Select Records->Delete.
A message box appears asking you to confirm that you wish to delete the records.
3. Click Yes to Approve the deletion; click No to Reject it.
Export/Delete

Export/Delete enables you to save everything you’re deleting from the Data Repository to a *imp
file. With the appropriate data displayed in the Browser:

1.

Select Records-Export/Delete.
The Export Records File As window appears.

Choose a file name and destination directory, as desired. Data Manager will use the file name
and directory for the Export file and for the log file that is automatically created at the end of
the job; the default filename for both is “plexport”.

Select the Save as type. If the file name you specified above already exists in the destination
directory, Data Manager gives you the option of overwriting the existing Export file or
appending (adding) the new records to the existing file. Respond as desired. A second
message box appears asking if you want to overwrite or append to the existing log file. Again,
respond as desired. There are three choices:

*  Export Files (*.imp). This is the default type. This is the file format used by the Import
Utility and the PLIMPORT batch executable (see Chapter 3: Importing Data). If you
intend to import the data back into the database, select this type.

* XML Version 1 (*.xml) This exports the data in an XML format that can be used to
export data for use in external applications.

* XML Version 2 (*.xml) This exports the data in an XML format that can be used by the
Import Utility and the PLIMPORT batch executable (see Chapter 3: Importing Data).
If you intend to import the data back into the database, select this type. This format can
also be used to export data for use in external applications. This format is supported in
version 4.00 and later only.

A message box appears asking you to confirm that you wish to delete the records. Approve or
reject the deletion by clicking Yes or No.

When the process is complete, you can view the Export or log files by selecting File-»>Open-
»File.
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Exporting Interval Data

Data Manager’s Interval Data Export and Delete functions are important tools for archiving data
in the Interval Database, and for making that data available to other Oracle Utilities products.

Important Note
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Two export options are provided in the File menu:

*  Export - Exports selected interval data records. The Export file can be in any of the
following formats:

Enhanced Oracle Udlities Input/Output Format (*.Ise)
Oracle Ultilities Standard Format (*.inp)
Comma Separated Format (*.csv)

Oracle Utilities Standard XML Format (*.xml).

If desired, you can archive the file onto disk or other media for safekeeping. Because the

export formats are also import formats, you can easily import the data back into the database
using the Interval Data Import utility.

*  Export/Delete - Exports selected interval data records, and deletes them from the database.
The exported data can be imported back into the database, if necessary.

In all modes, the program automatically creates a log file at the end of the run and places it in the
USER directory. The log file lists the data exported and/or deleted, and provides a count of the
exported/deleted records.

If the interval data to be deleted is in the Oracle Utilities Data Repository, when you delete a
recorder or channel via the Interval Data Browser, Data Manager gives you the option of deleting
only the cut data, or the recorder or channel data as well.



Exporting Interval Data

Exporting and/or Deleting Interval Data

Before you delete data from the Interval Database, you must be sure it is no longer needed. The
two options discussed here (Export and Export/Delete) enable you to:

Export records to a file in the specified format (*.Ise, *.inp, *.csv, or *.xml).

Delete records from the Interval Database as they are exported to a backup file.

Exporting Data

The Export function enables you to copy records to a file in the specified format.

How to export data:

With the appropriate data displayed in the Interval Data Browser, you can select a specific cut,

channel, recorder, or the entire Interval Database to export. See Chapter 6: Browsing Data for

more information.

1. Select File»Export.
The Select Interval Data File window appeats.

2. Choose a file name and destination ditectory.

3. Select the Save as type. The choices are:
*  Enhanced Oracle Utilities Input/Output Format (*.Ise)
*  Oracle Utilities Standard Format (*.inp)
*  Comma Separated Format (*.csv)
*  Oracle Utilities Standard XML Format (*.xml).

4. Click Save to export the data to the specified file. If the file name you specify already exists,
the exported data will be automatically appended to the file.

Export/Delete

Export/Delete enables you to save everything you’re deleting from the Interval Database to a file
in the specified format (*.Ise, *.inp, *.csv, or *.xml).

With the appropriate data displayed in the Interval Data Browser, you can select a specific cut,

channel, recorder, ot the entire interval database to export/delete. See Chapter 6: Browsing
Data for more information.

1.

Select File->Export/Delete.

The Select Interval Data File window appears.

Choose a file name and destination directory.

Select the Save as type. The choices are:

*  Enhanced Oracle Utilities Input/Output Format (*.Ise)
*  Oracle Utilities Standard Format (*.inp)

*  Comma Separated Format (*.csv)

*  Oracle Utilities Standard XML Format (*.xml).

Click Save to export the data to the specified file. If the file name you specify already exists,
the exported data will be automatically appended to the file.

A message box appears asking you to confirm that you want to delete the records. Approve
or reject the deletion by clicking Yes or No.
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Chapter 5

The Account-Centric View

This chapter describes the Account-Centric View of data in the Oracle Ultilities Data Repository.
This tool displays information in an easy-to-use tab format, designed specifically for billing
analysts, customer service representatives, and others who need to research customer inquiries, set
up new account billing, or manage the billing of existing accounts. This includes:

*  Opening and Closing the Account-Centric View

*  Navigating the Account-Centric View

*  About Fields Displayed in the Account-Centric View
The Account-Centric View serves three primary purposes:

* Setting up a new account for billing with Oracle Utilities Billing Component. When a
new account enters the system, much of the necessary information is automatically
downloaded from your CIS into Oracle Utilities Billing Component. However, you must
manually add some information and specify a few settings, such as which billing module is
used to process the account and how much detail should be included in the bill.

*  Entering information required to bill existing accounts. For complex rate schedules or
contracts, it may be necessary for billing analysts to enter some information on a regular or
as-needed basis. You can also attach informative notes to the account's record, as a reminder
to yourself or other users.

*  Researching billing information. The Account-Centric View is especially useful for
responding to customer inquiries about their bills, and for investigating any problems that
occurred during the billing process. For example, you can look up an account’s bill for a
previous month, check peak values, or track the progress of a late bill.

Note: Because the Account-Centric View is designed for specific applications, not all information
in the Data Repository is accessible from it. Also, some information displayed in the Account-
Centric View, such as data that comes from a Customer Information System (CIS), cannot be
edited via the Account-Centric View. That data is displayed in gray. Administrators who require
access to all information in the Data Repository, including support information such as
lookup codes, should use the Browser. See Chapter 6: Browsing Data for more information.
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Opening and Closing the Account-Centric View

Opening the Account-Centric View

There are two ways to open the Account-Centric View, depending upon where you are in the
system. You can open it from the menu bar, or from a report window in which the desired
account ID is displayed.

How to open the Account-Centric View from the menu bar:

1. In Data Manager, select File->View->Account.
The Enter Account ID dialog opens.
2. Enter the ID for the account you wish to view and click OK.

The View Account window appears, displaying information about the selected account.

Closing the Account-Centric View
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You can close the View in any of the following ways:
*  Press CIRL+F4 on your keyboard.

*  Click on the system icon in the upper left corner of the View window, and select Close from
the menu that appears.

¢ If View is the active window, select File->Close from the main menu.
*  Click the Close button in the lower right corner of the window.

*  Click the X in the upper right corner of the window.
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Navigating the Account-Centric View

The View has two sections. The top section displays the “header” or “indicative” data. This data
remains on the screen for easy reference while you work with the account information displayed in
the various tabs below. For instance, if you’re on the phone with a customer researching that
customet’s bills, the customet’s name is always visible at the top of the screen.

Each tab in the lower portion of the screen contains a particular category of information. To view
the contents of a tab page, click on its tab. The tabs are organized in four columns. The fields
displayed on each tab page are described later in this chapter.

Note: The specific tabs and fields in your company’s version of the Account-Centric View may
differ from those in the above illustration.

Viewing and Analysis Tools

While viewing an account’s information in the Account-Centric View, you may want to apply
other analysis or reporting tools for a deeper investigation of the data. From the Account-Centric
View, you can immediately access the Browser, as well as the Billing History and Special Events
reports.

How to open another tool while in the Account-Centric View:

1. With the mouse pointer positioned anywhere in the View Account window, click the righs
mouse button.

2. Select the desired tool from the pop-up menu that appears:

*  Billing History - Displays billing information for the account for a user specified
number of bill periods.

*  Special Events - Lists the overrides that were applied to the account over a user-
specified period.

*  Browse Account - Opens the Browser for the account, giving you access to information
not available or modifiable via the Account-Centric View.

*  View Account - Opens another Account-Centric View window for the selected
account. Note that you cannot have two Account-Centric View windows opens for the
same account.
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Navigating the Tables on the View Tabs

Each row in a table represents a record belonging to the current account. For example, the
Channel History tab has a table that displays a record for each of the channels assigned to this
account over the account’s history. You can add, update or delete these rows.

You can adjust the table to display the desired information.
How to Scroll the Table View:

If a record has more fields than can be seen at once, you can move the horizontal scroll bar to shift
the view. Similatly, if there are more records than can be seen at once, use the vertical scroll bar
(not shown in the example above).

How to Resize the Columns in the Table:
1. Move the mouse pointer over the line that separates two of the column headers.
2. Drag to resize the columns.

Resized columns will remain at the width you set them to for future sessions, until you resize
them again.

How to sort the rows by information in a selected column:

Some tables enable you to sort the rows by the entries in a selected column. Columns that have
this feature are noted in the last section of this chapter.

*  Double-click on the header of the column you want to sort by.
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Adding, Updating, and Deleting Account Information

The tab pages in the Account-Centric View have three types of controls you can use to add or
update account information: simple text entry fields; drop-down lists for selecting from a finite set
of options for a field; and spreadsheet-like tables for adding, updating, or deleting entire records
associated with an account.

Updating a Field Using a Drop-Down Menu

1. Click on the arrow to the right of the field.
2. Select the desired option from the list that appeats.

3. Click the Update button at the bottom of the View window to input your changes to the
database.

Cut, Copy, and Paste

All selectable fields in the Account-Centric View can be cut and copied, and the data pasted in any
appropriate field or application. The information cut or copied from a field is placed on the
Windows Clipboard, and can be pasted into any application that accepts alphanumeric data.

Cut data by selecting it and pressing CTRL-X. Copy data by selecting it and pressing CTRL-C. Paste
data by selecting the target field and pressing CTRL-V.

If the data cut or copied is incompatible with a field that you attempt to paste it into (e.g;, text into
a date field), the Paste command will fail.

Adding, Updating, or Deleting Rows in a Table on the View Tabs

The following explains how to add, update, or delete rows in a table.

Recorder ID/Channel [ Installati [ Removal | uom Req For Bill
> [170011 Jo1/0171993 00:00:01 01 Yes

170071 0170171993 00:00:02 01 Yes
| |MDMS1A 0170171997 00:00:00 01 No
*

How to Add or Update Information in an Existing Row:

1. Double-click in the desired cell. If nothing happens, you can’t add information to that cell. If
the field is editable, one of three things will occur:

* A cursor will appear, enabling you to edit the information in the cell.
* A window will appear, containing a list of lookup codes you can choose from.
* A drop-down menu will appear with a short list of selections, such as Yes and No.

2. When you are finished updating the information in the row, click the Update button at the
bottom of the window to input the changes.

How to Add a New Row to a Table:

1. If necessary, scroll to display the last row in the table (indicated with an asterisk (*)). This is
the row you use to add a new record. If the table does not have an asterisk, you cannot add
new rows to it.
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Recorder ID{Ch | | Installati Removal UoM Req For Bill
> [170001 |I]1.||'I]1.||'1 993 00:00:01 01 Yes

17001 0170141993 00:00:02 01 Yes
. MDMS1H 0170141997 00:00:00 01 No
*

\ The asterisk (*) marks the row

where a new record can be added.
2. Click on the asterisk to highlight the row. Where appropriate, the system automatically fills in
default information. You can accept the default information, or replace it.

If the previous record included a STOPTIME field — such as the Bill History tab — the
addition of a new record will result in Data Manager prompting you to update the
STOPTIME to reflect the new record’s STARTTIME minus one second.

Note: This prompt will not occur unless the table you’re adding a record to is listed in the
LODESTAR.CFG file in the following format:

STOPTIME_UPDATE=TABLENAME

where TABLENAME is the table to be updated. See Chapter 2: Configuration Files in the
Oracle Utilities Energy Information Platform Configuration Guide for more information.

3. Add information to the row using one of the methods described in How to Add or Update
Information in an Existing Row: on page 5-5.

4. When you are finished adding information to the row, click the Add button at the bottom of
the window to commit the information to the database.

How to Delete a Row from a Table:

1. Click anywhere in the row you wish to delete. Note that the caret in the far left column moves
into the row you just selected. This caret indicates the active record.

2. Click the Delete button at the bottom of the View window.

3. A message box appears asking for confirmation. Respond as desired.

Searching a Lookup Table

Some of the fields in the Account-Centric View are associated with lookup tables of preset
options (see Chapter 6: Browsing Data). Double-clicking in these fields brings up a Select
window, where you can select a lookup code from the appropriate table.

The Search field automatically scrolls to the first item that matches the character or string you
typed.
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About Fields Displayed in the Account-Centric View

Header Data

You can add, modify, or delete any information that is maintained via Data Manager and Oracle
Utilides Billing Component. Note that the fields available in your company's version of the
Account-Centric View may differ from those described here.

Note: If you change the Date Format (from the General options tab accessible
from the Tools->Options menu option), you must close and reopen the
Account-Centric View for the change to take effect.

The header data displayed at the top of the View typically comes from CIS, and cannot be changed
from the Account-Centric View.

Account 1D |BI]I]I]I]1 | Name |Pau| Pham | Rev Code |33 | Status |Exce||e|
Op Co [GECO | Juris [sF | Rate Code |GECO/SF/1-CLiZ1 |

Note: If a grayed-out (uneditable) field does not display the entire contents of
the field, positioning the cursor to the right of the field opens a tooltip box that
displays the field’s entire contents.

Account ID: The ID of this account in Oracle Ultilities Billing Component.
Op Co: The operating company that bills this account.

Recorder ID: The ID for the account's interval data recorder. If the account has multiple
recorders, a pair of up and down arrows is visible at the right of the field. Use these arrows to view
the IDs of other recorders that belong to this account.

Name: The name of the customer this account belongs to.

Juris: The regulatory agency that has jurisdiction over how this account is billed.
Rev Code: The revenue or business class this account belongs to.

Rate Code: The rate schedule and rate code currently in effect for this account.
Status: The current status of the account. Examples include:

*  Excellent - an account in good standing, currently receiving service
*  Active - currently receiving service

* Inactive - no longer receiving service

* New - in first month of service

*  Final - in final month of service.
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Tab Data

Account Information
The Account Information tab contains the following fields:

Account ID: The ID of this account.
Name: The name of the account.

Billing Mode Flag: Indicates how Oracle Utilities Billing Component processes this account’s
bills:

*  Fully Automatic - Automatically calculates bills when all required data is available, issues
transaction records to CIS, and saves bill history information to the Data Repository.

*  Approval Required - Calculates bills via the Approval Required module when all required
data is available, issues transaction records to CIS, and saves bill history information to the
Data Repository upon user approval.

*  Manual Start - Calculates bills upon user request via Current/Final Bill module, issues
transaction records to CIS, and saves bill history information to the Data Repository upon
user approval.

*  Use default - Applies the Bill Mode flag in the rate code record associated with the account.
If a Use Default or Null value is present, Oracle Utilities Billing Component checks the billing
mode associated with the account’s rate schedule. If that record also has a Use Default or Null
value, Oracle Utilities Billing Component applies the defaults supplied in the Default Billing
Options dialog; See the Oracle Utilities Billing Component User's Guide for details.

Customer ID: The ID of the customer this account belongs to.
Bi-Monthly: Indicates the account’s billing frequency:

* 0 - monthly
* 1 - bimonthly, on odd-numbered months
* 2 - bimonthly, on even-numbered months.

Full Day Billing: Use this flag to specify how Oracle Utilities Billing Component records the end
of the bill period for the account in the Bill History record: the actual read date and time, or
midnight of the last full 24-hour period before the actual read date and time. (This setting can
affect energy and demand calculations, depending on the functions used in the rate schedule.)
Options include:

*  Yes - Use midnight of last full day.

*  No - Use actual read date and time.

*  Use Default - Use the flag supplied in the account’s rate code record. If a Use Default or
Null value is present, Oracle Utilities Billing Component checks the setting associated with
the account’s rate schedule. If a Use Default or Null value is present there, Oracle Utilities
Billing Component uses the actual read date and time.

Print Detail: Specify the level of information that Oracle Ultilities Billing Component provides in
bill repotts, CIS transaction records, and bill e-mail/faxes for the account:

* None - Effective revenue only.

*  Normal - Effective revenue, plus any charges assigned to a revenue identifier in the
applicable rate form.

*  All Detail - Effective revenue, plus revenue identifiers, plus the values associated with the
Rules Language Label and Report statements, such as interval data and peak times and values.

*  Use Default - Use the flag supplied in the account’s rate code record. If a Use Default or
Null value is present, the application checks the rate schedule record. If that record also has a
Use Default or Null value, the application uses the defaults supplied in the Default Billing
Options dialog; See the Oracle Utilities Billing Component User's Guide for details.
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Start: The date and time the account became active.

Stop: The date and time the account became inactive. If the field is empty, the account is still
active.

Pre-Window and Post-Window: Use these fields to set the “eligibility” window for the account.
When the account becomes eligible, Oracle Utilities Billing Component begins scanning for the
data necessary to calculate its bill (this feature applies to accounts billed using the Fully Automatic
or Approval Required modes).

Eligibility is determined by whether the account’s meter is scheduled to be read on a date that is
“near” today—that is, today’s date falls within the window that extends some number of days
before and some number of days after the scheduled read date. The number of days before is the
“pre-window”’; the number of days after is the “post-window.” For either window, you can supply
a value from 0 to 28.

If you leave the Pre-Window and Post-Window fields blank here, Oracle Utilities Billing
Component looks at the Rate Code Table to see if you have set the windows at the rate code level.
If there are no values there, Oracle Utilities Billing Component uses the settings in the Default
Billing Options dialog. See the Oracle Utilities Billing Component User's Guide for a complete
description of eligibility windows.

Note: If you set the post-window to 0, the data must be available by the end of
the read date, or it is considered missing. If the data is still unavailable by the
end of the last day in the post-window, Oracle Ultilities Billing Component
stops scanning for the information and attaches a SYSTEM REJECTED note
to the bill. Then the bill can only be calculated by manually applying the
Current/Final Bill module.

Billing Cycle
The Account Information tab contains a spreadsheet-like table that lists the current and, if any,
previous billing cycle assignments for this account. The Start Time is the date and time the
assignment took effect. The Billing Cycle is identified by operating company code, jurisdiction
code, and billing cycle code.

Tip: To view the schedule of read dates associated with a billing cycle code,
click the Billing Cycles button at the bottom of the tab page.

Rate History
The Rate History tab enables you to view rate schedules, rate codes, and tariff riders that are or
have been in effect for this account, and to add new ones.

The Rate History tab page contains two spreadsheet-like tables.

Rate Schedule/Rate Code History
The upper table lists the rate schedules and rate codes that are or have been in effect for this
account. To sort rows in the Rate Code Table by entries in the Start Time, Rate Schedule/Rate

Code, or Stop Time columns, double-click the header of the desired column. The columns in this
table are:

Start Time: The date and time that this rate schedule/rate code went into effect for this account.

Rate Schedule/Rate Code: Operating company code, jurisdiction code, rate form, and rate
code.

Stop Time: The date and time that the rate code for the account expired. If this field is blank, the
code is still in effect.

Note: An optional descriptive note.
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Rider History

The lower table lists the tariff riders that are or have been in effect for this account.

Note: Do not confuse tariff riders with the larger class of generic riders. Generic riders are sets of
Rules Language statements that perform commonly used calculations or reporting functions. They
are saved as separate rate form riders so that rate analysts can use them in multiple rate schedules.
Tariff riders are a subset of generic riders; they are explicitly attached to accounts via the database
records, and appear in the Rider Summary Report.

From the system perspective, a generic rider becomes a tariff rider when you attach the rider to an
account by entering it in the Account’s Rate History tab (or, if using the Browser, the Rider
History Table). You can sort the rows in the Rider History Table by entries in the Effective Date
or Rider columns. The columns in this table are:

Effective Date: The date and time this tariff rider went into effect for this account.
Rider: Operating company code, jurisdiction code, and rate form code for the tariff rider.

Stop Time: The date and time that the tariff rider for the account expired. If this field is blank,
the code is still in effect.

Note: An optional descriptive note.

Contract History

The Contract History tab enables you to view contracts and apply them to accounts.

The upper portion of the tab page displays a spreadsheet-like table that lists the current and
previous contracts, if any, applied to this account. You can sort the rows in the Contract Table by
entries in the Start Time or Contract column. It has two columns:

Start Time: The date and time the contract took effect.

Contract: Operating company code, jurisdiction code, and rate form code that identify the
contract.

The lower box displays the Rules Language statements that make up the contract highlighted in
the upper box. This information is view-only.

Note: An account may go off a contract with no new one established. The
Contract Table does not have a column for specifying stop times for expiring
contracts. In this case, add a new row and, for “Start Time,” specify the date
and time the old contract ended; leave the “Contract” cell blank in the new row.

Account Notes
The Account Notes tab lets you view, add, or edit Account Notes.

The spreadsheet-like table lists the Account Notes that Oracle Utilities Billing Component or a
billing analyst attached to an account. These notes alert billing analysts to actual or potential
problems that occurred during the billing process, such as missing data. The notes can be
informational only, or they can actually stop the billing process. You can sort the rows in this table
by the Date Time or Account Note Type columns. The columns in this table are:

Date Time: When the note was recorded in the Data Repository.
Account Note Type: Account note type selected from the Account Note Type lookup codes.
Note: Description of the problem.

See the Oracle Utilities Billing Component User's Guide for a description of Account Notes Types and
their impact on the billing process.

You can add Account Notes to this tab page. You can also generate reports of Account Notes for
selected customers and accounts using Oracle Utilities Billing Component’s Review Billing
Exceptions feature (described in the Oracle Utilities Billing Component User's Guide).
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Don’t confuse these Account Notes with the informational notes displayed in the Account-
Centric View header or Account Information tab page; these two types of notes are unrelated.

Note: The Account Notes tab is not displayed if the
USE_WORK_Q_FOR_ACCOUNT_NOTES = 1 parameter is included in
the LODESTAR.CFG file. See LODESTAR.CFG on page 2-2 in the Oracte
Utilities Energy Information Platform Confignration Guide for more information.

Customer
The Customer tab displays information about the customer the account belongs to. It enables
you to add, update, or delete the names of account managers or other utility personnel involved
with the accounts, and to specify whether those individuals should be notified of the accounts’
activity with fax or e-mail copies of their bills.

Fields on this window include:
Customer ID: The ID of the customer this account belongs to.
Name: The name of the customer this account belongs to.

Account ID: Lists the IDs of all accounts belonging to the customer. To open another Account-
Centric View for another account, double-click on its ID in the list.

Summary Bill: Indicates whether Oracle Utilities Billing Component calculates and releases the
CIS transaction records for the customer’s accounts only when all of them are ready—thus
making it possible for CIS to calculate a “summary bill” for the customer. Options for this field
are:

*  Blank - Use the default (“No”).

*  No - Issue each account transaction record as it is calculated (and approved, if approval
required).

*  Yes - Hold processing of account transaction records until all are ready.

Directory
The Customer tab includes a spreadsheet-like table that lists the customer’s account managet,
designated contact at the utility, and any other authorized individuals who are concerned with the
account’s billing information. It also indicates whether or not Oracle Utllities Billing Component
automatically produces a copy of the customer’s bill in fax or e-mail format for these individuals
each billing period. For a complete explanation of the Directory and outputting bills in fax or e-
mail format, see Chapter 3: Working with Reports in the Oracle Utilities Billing Conaponent User’s
Guide. You can sort the rows in the Directory Table by entries in the Title, Name, or Fax flag
columns. Acct Mgr and Ultility Contact will always be at the top of the list. Sorting begins with the
third row. The columns in this table are:

Directory Code: The lookup code that identifies this individual in the Directory Lookup Table. If
you are adding a new entry to this table, you need only make a selection for this cell; the rest of the
row is completed for you.

Tip: To add a name to the contents of the Directory Lookup Table, click the
Directory button at the bottom of the tab page. This opens the Browser,
where you can register new contacts. Similarly, if you want to modify any of the
cells in an existing row (other than the Fax flag), you must do so by applying the
Browser to the contact's entry in the Directory Table. See Setting Up Bills to
be Faxed or E-mailed in Chapter 3: Working with Reports in the Oracle
Utilities Billing Component Users Guide for more information.

Title: Title of the account manager, utility contact, or other individual.

Name: The name of the account manager, utility contact, or other individual.
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Phone #1: The primary phone number of the account manager, utility contact, or other
individual.

Phone #2: An alternate phone number for the account manager, utility contact, or other
individual.

Fax: Fax number for the account manager, utility contact, or other individual.
Pager: The pager number for the account manager, utility contact, or other individual.
Mail: The e-mail address of the account manager, utility contact, or other individual.

Fax Flag: Tells Oracle Utilities Billing Component to produce the bill in an e-mail- or fax-ready
file format. If the field is blank, neither is produced.

Name of File: The name of the file that Oracle Utilities Billing Component writes e-mail to.
(Faxes ate automatically written to FAX'TXT in the POWRLINE\USER directory.)

Note: After a fax or e-mail file is issued, be sure to delete or move the file.
Otherwise, the next time Oracle Utilities Billing Component creates the fax or
e-mail, it will append the new information to the old file. You will have to
manually delete the old information from the file before sending it.

Channel History
The Channel History tab displays current and historical information about recorder/channels
assigned to this account.

With this tab, you view the information, as well as adding, updating, or deleting the account’s
channel and channel group assignments.

The Channel History tab page contains two spreadsheet-like tables.

Channel History
The upper table lists the logical interval data recorders/channels that are or have been assigned to
this account. Logical refers to the recorder associated with the account; the ID of the recorder can
stay the same even if the actual hardware is replaced. You can sort the rows in the Channel History
Table by entries in the CIS Account, Recorder ID/Channel, Installation, Removal, UOM, or Req
for Bill columns. The columns in this table are:

Recorder ID/Channel: Logical recorder ID and channel number assigned to this account.
(Note: The recorder ID/channels themselves are defined in the system via the Logical Recorder
tab. You cannot create a new recorder ID/channel here; you can only select from a pick list to
assign an existing recorder ID/channel to the account.)

Installation: Date the logical recorder/channel was activated.

Removal: Date, if any, the logical recorder/channel was deactivated.
UOM: Code identifying the unit of measure recorded by this channel.
Req for Billing: Is the data recorded by this channel necessary for billing?

Pulse Multiplier and Pulse Offset: Interval data is a series of measurements taken at regular
intervals, such as every 5, 10, 15, 30, or 60 minutes. For each interval, an interval data recorder
counts the number of pulses (the number of changes in state that occurred within the interval).
“Pulse multiplier” and “pulse offset” are values used to convert pulse counts into real
measurements. The pulse multiplier is a scale factor, and the pulse offset is a displacement. These
values are device-specific.

Meter Multiplier and Meter Offset: In some instances, metered energy is used to verify interval
data using the following formula: Metered energy equals the net-meter-reading times the meter
multiplier plus the meter offset times. These values are also device-specific.

IPH: The number of intervals per hour recorded by the device.
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Data Type: Can be cither “scalar data” or “interval data.” If this Channel History is for an
interval data recordert, select “interval data.” If it is for an indicative meter, select “scalar.” Selecting
“scalar” tells the billing programs to look for billing determinant values in the Meter Value Table,
rather than the Bill History Table. (If an account requires multiple scalar values for the same UOM
per month, they must be stored in the Meter Value Table—see zhe Bill Components tab.)

End Use: Code that represents the end use measured by the channel; refrigerator, air
conditioning, etc.

Totalize: Specifies how the programs total interval data when combining data from two or more
recorder/channels:

¢ Include - include this channel’s data in total
¢ Total - use this channel’s data as the total

¢ Exclude - exclude this channel’s data from total.

Channel Groups

The lower table in the Channel History tab lists the channel groups a recorder ID/channel is
assigned to. Channel groups make it possible to store the total usage for subsets of channels
belonging to an account, even if they measure the same bill determinant. To view, add, modify, or
delete channel group assignments, first highlight the recorder ID/channel of interest in the upper
table.

The columns are:

Group Category - Identifies the application this channel group was set up for—typically, Billing.
Group categories are lookup codes; they can only be created by applying the Browser to the
Group Category Table.

Group Name - The name assigned to this group. This name is used in rate forms to retrieve the
recorder ID/channels belonging to this group.

Meter History

Meter

The Meter History tab displays current and historical information about meters in the Meter
Table.

With this tab, you can view the information, as well as adding, updating, or deleting the Meter,
Meter History, and Meter Read records.

The Meter History tab page contains three spreadsheet-like tables.

The upper table lists the meters from the Meter Table. The columns in this table are:
Meter ID: The identifier of the meter.

Manufacturer: The meter’s manufacturer.

Serial Number: The metet’s serial number.

Unique Number: A unique number associated with the meter.

Meter History

The second table lists the meter history records. These provide a snapshot of the meter’s use. The
columns in this table are:

Meter ID: The identifier of the meter (from the Meter Table).
Start Time: Effective start date/time for the meter.
Stop Time: Stop date/time for the meter.

Service Type: Service type associated with the meter (from the Service Type Table).
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Premise Address: Address, City, State, ZIP of the premise associated with the meter.
Service Plan Account: Account associated with the service plan and meter.

Service Plan Start: Start date of the service plan.

Service Plan Service: Service type associated with the service plan.

Service Plan Address: Address, City, State, ZIP of the service plan associated with the meter.
Service Plan LDC: The account’s local distribution company account number.

Number of: Number of dials on the meter.

Meter Multiplier and Meter Offset: In some instances, metered energy is used to verify data
using the following formula: Metered energy equals the net-meter-reading times the meter
multiplier plus the meter offset times. These values are also device-specific.

UOM: The unit of measure recorded by the meter (from the Units of Measure Table).

End Use: Code that represents the end use measured by the meter; refrigerator, air conditioning,
etc. (from the End Use Table).

Bill Determinant Code: Bill determinant code associated with the meter (from the Bill

Determinants Table).

Meter Reads
The lower table in the Meter History tab lists individual meter read records for each meter. The
columns are:

Meter: The identifier of the meter (from the Meter Table)
Meter Read Time: The time the meter was read

Stop Reading Time: Time associated with the stop reading
Stop Reading: The stop reading

Start Reading Time: Time associated with the start reading
Start Reading: The start reading

Read Month: Read month

Therm Factor: Therm factor (for gas meter readings)

Peak Value: Peak value reading (for demand measurements)
Peak Time: Time of the peak reading

Reading Type: The type of reading (Actual, Cancelled, Estimated, or Adjusted).

Ready Use Flag
The Ready Use Flag tab displays a list of the Special Event overrides and Bill Determinants that
are required for billing the account. It also enables you to add new requirements, and to set the
Override Ready Flag for a bill period.

The Ready Use Flag tab page contains two spreadsheet-like tables.

Special Event Overrides
The upper table lists the Special Event overrides that must be manually verified by a billing analyst
(e.g., have an entry in the Override Use Table for the account) before Oracle Utilities Billing
Component can calculate the bill. You can use this table to set the Override Ready flag for the
account. See the Oracle Utilities Billing Component User's Guide for a complete description of Special
Event overrides. You can sort the rows in this table by entries in the Special Event or Start Time
columns.
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Note: For each Special Event Override that can be applied to this account, the
upper table displays the date and time of the most recently-entered ready flag,
although all of the past records are stored in the database.

The columns on this tab include:

Special Event: Name of the override (must have already been defined in the Override Lookup
Table).

Start Time: The date and time the override went into effect for the account.

Stop Time: The date and time the override for the account expired. If no end date is supplied, or
if the override applies indefinitely, this field is blank.

Ready Time: The time you verified this special event override for the account (typically now, if
you are now entering a record). An entry in this field constitutes the Ready flag.

Special Event Pre-Window: [7ew on/y. You must set the Ready flag (in other words, make an
entry in this special event table, including the Ready Time) within #» number of days before the
account’s actual read date, where # is the number that appears in the Special Event Pre-Window
field. If you set the Ready Flag more than # days before all other data required for billing is
available, Oracle Utilities Billing Component will reject the account (if the account is billed by
either the Approval Required or Automatic Billing module). If that happens, you must update the
overrides and reset the Ready Time.

How to Set the Ready Flag for a Special Event Override:
1. Highlight the row in the upper table that contains the desired special event override.

2. Click the Set Ready Flag button. Note that the entry in the Ready Time cell changes to
reflect when you clicked the button.

How to Clear the Ready Flag for a Special Event Override:

1. To clear the Ready Flag, highlight the row in the upper table that contains the desired special
event override.

2. Click the Clear Ready Flag button. The date and time reverts to that of the most recently
saved record.

Bill Determinants
The lower table lists the bill determinants that must be available for Oracle Utilities Billing
Component to calculate the account's bill. You can sort the rows in this table by entries in the Bill
Determinant or Start Time columns.

Bill Determinant: Code for the bill determinant (as defined in the Bill Determinant Lookup
Table).

Start Time: The date and time the requirement for the bill determinant was initiated.

Stop Time: The date and time that the requirement was dropped. If blank, the bill determinant is
currently required.
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Special Event History
The Special Event History tab lists the overrides that are or have been applied to this account at
the account and meter levels. The spreadsheets on this tab contain the same information as the
Opverride History and Name Override History tables described in the Oracle Utilities Billing
Component User's Guide. You can view the information on this tab, as well as add, update, or delete
it.
The Special Event History tab page has two spreadsheet-like tables. The upper table lists account-
level overrides; the lower lists meter-level overrides.

Account Overrides
The columns on this tab include:

Special Event: The lookup code that identifies the override (must have already been defined in
the Override Lookup Table).

Start Time: The beginning of the period over which the override applies.

Stop Time: The end of the period over which the override applies. If the stop date is unknown or
the override applies indefinitely, this field is blank.

Value: Value that expresses the scope of the override. Oracle Ultilities Billing Component uses this
value for a variable numeric value in the rate form. If the value is a percentage, it is expressed as a
decimal fraction; for example, 0.1 indicates a 10% discount.

Note: Optional. Descriptive information about the override.

String Value: Optional. Value for a variable in the rate form script that requires a text string, For
example, to apply a rider for just the period defined by the start- and stop-times above, enter the
name of the rider. To apply a factor for just that period, enter the factor’s name.

Meter-Level Overrides
The columns are:

Special Event: The lookup code that identifies the override (must have already been defined in
the Override Lookup Table).

Channel ot Group: The name of the channel group, CIS account, ot recorder ID/channel the
override applies to.

Start Time: The beginning of the period over which the override applies.

Stop Time: The end of the period over which the override applies. If the stop date is unknown or
the override applies indefinitely, this field is blank.

Value: Value that expresses the scope of the override. Oracle Ultilities Billing Component uses this
value for a variable numeric value in the rate form. If the value refers to a percentage, it is
expressed as a decimal fraction; for example, 0.1 indicates a 10% discount.

String Value: Optional. Value for a variable in the rate form script that requires a text string, For
example, to apply a rider for just the period defined by the start- and stop-times above, enter the
name of the rider. To apply a factor for just that period, enter the factor’s name.

Factor History
The Factor History tab lists the factors currently in effect for this account, and all of the values
that are or have been associated with each factor. It enables you to assign a new factor to the
account, and to change values associated with a factor.

A factor is a variable that can be used in rate form scripts to represent taxes, charges, and other
values that are used widely and are expected to change over time. The factors and their associated
values are stored separately. In that way, when a tax changes it is not necessary to update the value
in every rate form script, but only to create a new Factor Value record. The billing programs
automatically find and use the correct value.
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Factors

The upper spreadsheet-like table lists the factors that have been applied to the account. You can
sort the rows in this table by entries in the Factor Code or Start Time columns. The columns are:

Factor Code: The operating company code, jurisdiction code, and factor code identifying this
factor.

Start Time: The beginning of the period over which the factor applies to the account.

Stop Time: The end of the period over which the factor applies to the account. If the factor is
currently in effect, this field is blank.

UOM: The unit of measure for the quantity represented by the factor value.

Factor Values

The lower spreadsheet-like table lists a history of the values that have been associated with the
factor you select in the upper table. The columns are:

Factor Value: Value for the factor.
Start Time: The date and time the factor value went into effect.

Prorate: Indicates whether the programs prorate charges if the factor value changes during a bill
period:

*  No - do not prorate charges (use the factor in effect on the Bill Date for the entire bill period)

*  Yes - prorate the charges.

Factors button

To view the list of currently available Factor Codes, or to add a new Factor Code, click the Factors
button.

Bill History

The Bill History tab displays billing information, including bill determinants and revenue, for
each month. You can delete records from this table, as well as add new ones to it. When you add a
new record, the program automatically supplies default values for the next month to be billed.

You can sort the rows in this table by entries in any of the columns. The columns this tab include:
Bill Month: The revenue month for the bill.

Stop Time: The end of the bill period, which is eiher the time that the account’s meter was
actually read, or the midnight before the time that the meter was read—depending on the Full Day
Bill option setting for this account.

Read Date: The date the meter was scheduled to be read. This date zzus¢ match the read date
specified for this bill period in the account’s billing cycle. The read dates enable Oracle Utilities
Billing Component to match the Bill History record to the correct bill period.

Number of Days: Actual number of days in the bill period.

Bill Code: Not applicable to all implementations. Utility-specific code indicating the type of bill
(estimated, etc.). This field is automatically completed by CIS.

kWh: Usage for this bill petiod; either supplied by CIS or another system, or computed by Oracle
Utilities Billing Component from interval data.

Note: The next several columns are utility-specific bill determinants; ask your System
Administrator for details.

Bill Time: The date and time when Oracle Utilities Billing Component created the CIS
transaction record.

Start Time: The actual beginning of the bill period.
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Viewing a Single Bill History Record
If you double-click on the gray button at the left end of a record (row), a dialog box will appear,
displaying that record. If the selected record has related records in the Bill History Value Table, the
Bill History Value record values are also displayed.

You can edit the information in this dialog. Select the desired field to edit and change the data
accordingly. To close the dialog, click either the X’ in the upper right corner, or the Close button.

Bill Month [02/1939 Read Date [03/0171999 Start Time [02/01/1999 00:00:00
Bill Time |:| Number of days Stop time (0272871999 23:59:59
v

View Bill

The View Bill tab lets you view a selected past bill for the account.
How to view a bill:
1. If the account has multiple Rate Schedules, select one.
2. Select the Bill Month.
3. Click the View button.
The bill is displayed in the Bill Report window.

Bill Components
In Oracle Utilities Billing Component, an account is defined as the entity whose charges for bill
determinants are added together to compute a bill. However, in some cases it is necessary to track
subsets or components of these bill determinants. If an account has multiple service addresses in
different jurisdictions with different tax rates, it is necessary to store the monthly kWh for each
service address in order to compute the taxes. If an account’s meters are subject to different
ratcheting charges, it is necessaty to store separate usage values for each meter.

To accommodate such situations, Oracle Ultilities Billing Component allows you to store values for
the same bill determinant for multiple entities, such as recorder-ID/channels, channels groups, ot
CIS accounts, in the Meter Value Table.

The Bill Components tab displays information from the Meter Value Table. You can view
existing records and add new ones. When you add a new record, the program automatically
supplies default values for the next month to be billed.

You can sort the rows in this table by entries in any of the columns. The columns on this tab
include:

Read Date: The scheduled read date for the channel group.
Bill Month: The month the bill was issued.

Bill Determinant: The lookup code identifying the bill determinant that this channel group
records.

Name: The name of the channel group, recorder ID/channel, or CIS account that this bill
component belongs to.

Start Time: Start time of the bill period.
Stop Time: Stop time of the bill period.

Value: The value for the bill determinant.
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Bill History Prob/Res
The Bill History Prob/Res tab enables you to view and attach “Problem” desctiptions to bills.
These problem descriptions mark the bill for inclusion in the Late Bill report. See Chapter 10:
Problem Bills and the Late Bill Report in the Oracle Utilities Billing Component Users Guide for a
complete description of late bills and problem descriptions.

To view any problem descriptions attached to an existing bill, highlight its bill month in the upper
table on the tab. Any problems that were entered previously appear in the lower table.

How to add a problem description for a bill:
1. Click the desired bill month in the upper table.

Go to the Bill History tab and click the asterisk in the lower left corner. The program
automatically supplies default values for the next month to be billed. Leave the default values
in place—Oracle Ultilities Billing Component will update the dates and other information
when the bill is actually issued. Click Add. Then, return to the Bill History Prob/Res tab and
highlight the row that represents the new bill month.

Note: If the current bill month is not listed, that means that a Bill History record for it does
not yet exist in the database. If Oracle Ultilities Billing Component receives bill determinant
data from CIS for the account, a record will exist. On the other hand, if the account is not
billed using determinants from CIS, there won’t be a Bill History record for the month. In
that case, you must create the Bill History record, as follows:

2. In the lower table, click in the Problem cell and enter a description of the problem (up to 254
characters) to appear in the Late Bill report.

3. Enter a description of the problem’s resolution (up to 254 chatacters) to appear in the Late
Bill report. If the problem has not been resolved, leave this field blank.

4. When you have completed the tab, click the Add button to enter the information in the
database.

Logical Recorder
The Logical Recorder tab page displays information about the logical interval data recorders/
channels currently assigned to each of the account’s premises. “Logical’ refers to the utility-
assigned ID of the recorder assigned to the account; the recorder ID stays the same even if the
hardware is replaced. You can view, add, update, or delete this data.

This tab page has two spreadsheet-like tables. The upper table displays a list of recorders that
belong to the premise you select in the lower table. The lower table displays a list of channels that
belong to the recorder you select in the upper table. Following is a description of the columns in
each of the tables.

Recorders
Recorder ID: Logical recorder ID.
Interrogation Code: The interrogation lookup code that identifies the recorder type and

specifies the pre- and post-windows associated with the recorder.

Channels
Channel Number: Number identifying the recorder’s channel.
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Premise
The Premise tab lets you view, add, or edit records in the Premise Table.

The spreadsheet-like table lists the Premises associated with this account. The columns in this
table are:

Address 1: Physical address of the premise. Reguired.
Address 2: Second address of the premise. Optional.
Address 3: Third address of the premise. Optional.
City: City where the premise is located.

State: State where the premise is located.

ZIP Code: ZIP code where the premise is located.

County: County where the premise is located.

Peak Values
The Peak Values tab displays the history of weekly or monthly peak values for the account
(whether it’s weekly or monthly depends upon the rate schedule). One month of data is visible at a
time. When the tab first opens, the peak values for the latest bill month are displayed. The
information in this tab is view-only.

Demand Type: Demand that the peak is for (kWh or KVAR).
Peak Date & Time: Date and time of the peak.

Value: Value of the demand at the peak.

Contribution: Percentage peak contributes to the bill total.

Bill Month: This drop-down menu contains a list of all applicable months you can review. Select
a month to view the above values for that period’s bill.

LODESTAR Data

The LODESTAR Data tab displays information about the meter readings and interval data cuts
recorded for this account. Each row represents one cut. This information is view-only.

You can sort the rows by information in any of the columns. The columns on this tab include:
Recorder ID: ID of the interval data recorder.
Channel Number: Number that identifies the channel on the recorder.
UOM: Unit of measure for the data recorded by the channel.
Reading: Usage (meter reading stop minus meter reading start).
Reading Start: Meter reading start.
Reading Stop: Meter reading stop.
Value: Total usage for UOM.
Start Time: Date and time the cut’s recording period began.
Stop Time: Date and time the cut’s recording period ended.
Number of Days: Number of days covered by the cut.
Viewing a Single LODESTAR Data Record

If you double-click on the gray button at the left end of a record (row), a dialog box will appear,
displaying that record only.
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Chapter 6

Browsing Data

This chapter explains how to use the Browser to view the contents of the Oracle Utilities Data
Repository. The Browser displays the hierarchy of tables and records, and the information in the
records, in a “tree” view that reflects the organization of the database tables. This includes:

* Viewing Database Records in the Browser
*  Viewing the Database Schema
*  Browsing Interval Data in the Interval Database

The Browser is primarily used by database administrators who need access to the entire database.
To view a specific account, see Chapter 5: The Account-Centric View.
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Viewing Database Records in the Browser

The Browser offers two options for viewing database records; you can explore all of the tables and
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records in the Oracle Utilities Data Repository, or you can focus on specific customers or

accounts.

How to Browse the entire database:

1.

2.

Select File->Browse-»Customer Database.

The Browse Customer Database window appears, displaying a list of all primary tables in
the left pane.

Navigate the Browser (see Navigating the Browser on page 6-3).

How to Browse selected accounts:

1.

Select File->Browse-»Customer/Accounts.

The View Customer/Account(s) Input dialog appears.

Complete the dialog as follows:

Select By: Choose cither Account or Customer.

Select: Select the desired accounts or customers using one of the following options:
e All - View all customers or accounts.

e ID - Type a customer or account identifier.

*  List- Select a list of customers or accounts. See Chapter 7: Maintaining Data for more
information.

*  File - Select a file; types include customer/account IDs (*.ids), list files (*.Ist), account
query files (*.qra), and customer query files (*.qrc).

Click OK.

The Browse Customer/Account(s) window displays the customer ot account records.
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Navigating the Browser
The Browser window has two panes. On the left is the “Tree Pane,” which presents the database
in a “tree” structure. The right side, the “Record Pane,” displays the contents of each table or
record you select in the Tree Pane.

How to navigate the tree structure:

1. To expand an entity in the tree, click on the plus sign.
The tree will display the IDs of the records currently stored in that table.

Note: If you expand the tree for a table with hundreds of records, the display may take
several minutes to refresh. The cursor changes to an hourglass while this process is taking
place. If you click the plus sign and the tree does not expand, this means the table contains no
records.

2. 'To collapse the tree, click on the minus sign next to an entity.

E--@ Account
To collapse the tree, E‘EI 500001

click the minus (-) sign. %@ Customer (300001)
Togaese e 5 B cour Sos
H-B Jurisdiction [5F)

|E_£| Operating Compary [GECO]
#-B Revenue Code [33)

By SIC N
@ Account Hiztary - Account
- Account Motes - Account
ﬁ Bill Determinant Use - Account
@ Account Directany - Account

The following symbols appear in the Tree Pane:

This icon: Represents:
@ A database contains a series of tables.
E; A table contains a series of records.
% A record contains information about a single entity, such as an
account or lookup code.

As you explore the tree, you’ll see that a table or a parent record can appear under a record in the
tree. That's because the tree does not solely represent the strict parent-child hierarchy. It is a 2-
dimensional representation of the relationships between tables and records in the database. When
a record or table appears under a record in the tree, the record above contains a reference to the
record(s) in the table below it.

When the tree is expanded and a table is displayed in red, this indicates that you should not add
records to the table at that point in the tree. Instead, locate the table at the point in the tree where
it appears normally (i.e., gray).

How to View All Records in a Table:

The contents of all records stored in a table are displayed in a tabular format.
1. Locate the desired table in the Tree Pane.
2. Click on the icon for the desired table.

The information appears in the Record Pane.
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How to resize the panes:

You can adjust the relative sizes of the panes according to your needs.

1. Move the mouse pointer over the divider until a double-headed arrow appears.
2. Drag the divider in the direction of the arrows to resize the panes.

How to resize the columns in the Record pane:

1. Move the mouse pointer over the divider between two column headers until a double-headed
arrow appears.

2. Drag the divider to resize the columns.
How to view the contents of a single record:
1. Click on the icon for the desired record in the Tree Pane.

The record information appears in the Record Pane. You can add, edit, and delete this
information.

How to Filter records in the Browser based on Account IDs or Table-Column Lists:
The Filter option enables you to specify the type of records displayed in the Browser.
1. Select File->Browse->Customer Database.
The Browser appears.
2. Click on the icon for the table that contains the records you want to filter.
A list of records currently stored in that table appears in the right pane.

3. To specify the filter criteria, select Records->Filter, or click the right mouse button and select
Filter.

The Set Filter dialog appeats.
Complete the dialog as follows:

Account ID: Filter based on the account identifier. Click on Exact to look for a specific
Account ID.

List Names: Filter based on a table-column list.

Table Name: Select the table to extract the list from (defaults to the table currently
selected).

List Names: Select a list from the List Names box and click Add>> to move it to the
Selected Lists box. To remove a list from the Selected Lists box, click << Remove.
To clear the lists from the Selected Lists box, click Clear.

To create a new list to use as a filter, click New List. This opens the Table-Column list
dialog (see Chapter 7: Maintaining Data for more information).

4. Click OK to close the Filter dialog.
The Browser’s right pane will display the Filter results.

Note: Records filtered by lists cannot be updated or deleted using the browser.
How to Filter records in the Browser based on Queries:

The Query Filter option enables you to specify the number and type of records displayed in the
Browser based on a database query.

1. Select File-»Browse->Customer Database.
The Browser appears.
2. Click on the icon for the table that contains the records you want to filter.

A list of records currently stored in that table appears in the right pane.
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To specify the filter criteria, select Records-»Query Filter, or click the 7ight mouse button
and select Query Filter.

The Query to Create a List of <TABLE> Records dialog appears.

Construct the query to be used to filter the data. See Constructing Queries on page 8-16 for
more information about constructing queries.

Enter the maximum number of records you wish displayed in the Browser in the Max.
records to display field. This values overrides the value set in the
DM_BROWSER_MAX_RECORD parameter in the LODESTAR.CFG file. See
LODESTAR.CFG on page 2-2 of the Oracle Utilities Energy Information Platform Configuration
Guide for more information about this parameter.

Note: This field is displayed only when creating query filters, effectively replacing the Order
by Column drop-down list on the List Query dialog,

Click OK to apply the query and close the Filter dialog.

The Browser’s right pane will display the specified number of records that match the query. If
the desired records are not displayed, select the Query Filter option again and adjust the
quety as necessary.

How to close the Browser:

To close the Browser, do one of the following:

Press CTRL+F4 on your keyboard.

Click on the system icon in the upper left corner of the Browser window, and select Close
from the menu.

Click the Close icon (X) in the upper right corner of the Browser window. Be careful not to
click on the identical icon in the Data Manager window; clicking on it will terminate the
application.

Select File->Close.
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Viewing the Database Schema

The Data Manager provides an on-line diagram of the database structure (the schea) that you can
view using the Browser. It provides a visual representation of the database layout, as well as a list
of names that identify the tables and records in various circumstances.

How to view the database schema:
1. Select File->Browse-»Database Schema.

The Browse Database Schema window appears. Initially, the window displays all tables that
are “strong” database entities. Strong database entities are those with no parent records.

The label to the right of each table icon consists of three parts:
*  The “visible” name that appears in the Browser (for example, “Accounts”).
*  The “real” database table name (for example, “ACCOUNT”).

¢ The abbreviation used in Importt files for the PLIMPORT utility (for example,
“ACCT™).

2. Click the plus (+) symbol beside a table to display the columns it contains, and references to
and from the table.

Fach column label consists of its visible name and its real database column name. Each
reference label contains the internal reference name, with the referenced table's label in
parentheses. “To” in the table label indicates that the table is either a parent (red icon) or a
lookup (purple icon). “From” in the table label indicates a child table.
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Browsing Interval Data in the Interval Database

Data Manager includes a Browser for examining the contents of the Interval Database. You can
use it to view a list of all cuts currently available in the database, and to view each cut’s header data
and interval values.

A “cut” is one record of interval data for an account. Each cut is identified by the recorder-ID,
channel-number of the device that recorded it, and by the start- and stop-time of the period it
covers. Each recorder-ID, channel-number that identifies a cut in the Interval Database is related
to its account in the Data Repository via the Channel History Table.

The Interval Data Browser is particulatly useful for responding to customer questions about
demand charges, and for investigating any billing problems that might have been caused by bad or
missing interval data. You cannot use the Browser to change any data in the Interval Database.

Specifying the Interval Database to Browse

Your company may have several Interval Databases. Use the following instructions to specify the
one you wish to browse.

How to “point” to the desired interval data source:
1. Select Tools->Options.
The Default Options dialog box appears.
2. Click the Interval Data Source tab (see Default Options on page 2-9).
3. Select the appropriate Type:
*  File: Select one of the following formats for the desired Interval Database file:
*  Oracle Utilities Enhanced Database Format (Pervasive.SQL) (*.bte)
*  Enhanced Oracle Utilities Input/Output Format (*.Ise)
*  Oracle Utilities Standard Format (*.inp)
*  Comma Separated Format (*.csv)
*  Oracle Utilities Standard XML Format (*.xml)
*  MV90 Mainframe Format (*.mv9)
*  Meter Data Exchange Format (*.mdf).
*  Default: Use the default Interval Database identified in the LODESTAR.CFG file.
*  Customer Database: Usec interval data stored in the Oracle Utilities Data Repository.

4. If you selected File, click Browse and select the desired file. If the name of the desired file is
already displayed in the File field, click Cancel to close the dialog.

5. Select one of the following options for applying the new setting:

*  OK: Saves the new setting as your default interval data source, replacing the previous
setting. Any Oracle Utilities program you run will automatically use this Interval
Database.

*  Apply: Applies to current work session only; the setting will revert to the previously
specified interval data source after this work session.
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Using the Interval Data Browser

How to open the Browser:

1.

Select File->Browse->Interval Data Database.

The Browser appears, displaying a list of all recorders with interval data in this database.

Recorder IDs are associated with their accounts via the Channel History Table. If you do not

recognize a recorder ID and want to learn more about it, go to the Data Repository Browser by

selecting File-»Browse->Customer Database. Then, click on the Channel History table icon.

The right pane displays a list of all recorder-IDs in the database, with descriptive information

about each one. When you have found the desired information, close the Customer Database

Browser and return to the Interval Data Browser.

How to view a list of cuts for a selected recorder-ID, channel-number:

1.

Expand the tree by clicking on the plus sign next to the recorder of interest.
A list of channel-numbers assigned to the recorder appears.
Expand the tree by clicking on the plus sign next to the channel of interest.

A list of all cuts currently stored and accessible for the selected recorder-ID, channel-number
appears. The dates indicate the start- and stop-date and time of the period covered by the cut.

How to view the header data for a selected cut:

The “Header” provides descriptive information about the cut.

1.
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Expand the tree so that the icon for the desired cut is visible in the Browser window, as
described on the previous page.

Click the plus sign next to the desired cut.
The header data appears.
The header consists of the following fields:

Note: Some interval data cuts may have additional fields that are not described
below.

Recorder/Cust ID: Logical recorder-ID. (“Logical” means that it identifies the recorder
installed for the account; the ID remains the same even if the device is replaced.)

Channel: A single digit (0 to 9) that identifies the port, register, or channel of the recording
device. Each channel measures a different end-use, data type, or other quantity.

Interval Start: Date and time the recording period covered by this cut began.
Interval Stop: Date and time the recording period covered by this cut ended.
Description: Optional descriptive data.

Timestamp: Time the cut was loaded into the Interval Database.

Origin: Origin of the cut; M (Metered), P (Profiled), or C (Computed).

UOM: The Unit of Measure code identifies the type of interval data stored in the cut. “1”
means that the interval data represents kWh. For a list of UOM codes, see Appendix B:
Oracle Utilities Enhanced Input/Output Interval Data Format.

IPH: The Intervals per Hour indicate the frequency at which the interval data was recorded.
An IPH of “4” indicates that each interval value represents a 15-minute period.

SPI: The Seconds per Interval indicate the frequency at which the interval data was recorded,
in seconds. An SPT of “900” indicates that each interval value represents a 15-minute, or 900-
second, period.

Type: Frequency of the data (monthly, daily, houtly, 60-minute, etc.).
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Internal Validation Status, External Validation Status, Merge Flag, Delete Flag: Flags
used to manage data quality in the Oracle Ultilities Load Analysis Load Data Management
System. If you load data into the Data Repository using the Data Manager Import utility
described in Chapter 3: Importing Data, the flags are automatically set to ON or YES, and
therefore have no meaning. However, if your data is loaded from the Oracle Utilities Load
Analysis product, these flags indicate the actual quality of the data. A flag setting of NO
indicates bad data. In that case, the data must be edited and validated by Oracle Utilities Load
Analysis before it can be used for billing,

Count: Total number of “pulse values” in the cut. Internally, the system converts the number
of pulse counts to real measurements.

Non-zero Count: Total number of nonzero pulse values.
Total (not IPH/UOM corrected): Sum of all interval values in the cut.

Energy (IPH/UOM corrected): If the original data represents kW; it is converted to kWh
and then summed. If the original data represents kWh, it is summed.

Maximum: Value, date, and time for the maximum interval value in the cut.
Minimum: Value, date, and time for the minimum interval value in the cut.

Pulse Mult and Pulse Offset: Values the system uses to convert pulses to real
measurements. These values depend on the device used to record them.

How to view a graph of interval data for a selected cut:

To use the Interval Data Browser to display the cut’s interval data values in a graph:

1.

Double-click on the icon for the cut whose data you wish to view.

The Browser automatically reconfigures itself so that two windows are visible; the upper
window displays the header data, and the lower window displays a graph of the interval data.

To see the value associated with a particular point in the graph (such as a peak), move the
cursor to that point. Its associated value appears in the lower left corner of the window.

How to close the Browser:

You can close the Interval Data Browser (and most other windows) using the same methods as

those used to close the Customer Database. See How to close the Browser: on page 6-5 for

more information.
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Browsing Interval Data Stored in the Oracle Utilities Data Repository

Interval data can be stored in a separate Interval Database, or in the Oracle Utilities Data
Repository. The instructions in this chapter assume that your interval data is stored in the Interval
Database. When interval data is stored in the Data Repository, users can view some information
about the interval data using the Customer Database Browser, in addition to using the Interval
Database Browser.

Users can view the following types of data using the Customer Database Browser:
*  Cut Header Information

. Cut Edit Information.

Viewing Header Information
Header information is descriptive data concerning an interval data cut. The Channel Cut Header
Table stores this information.

How to view Header Information using the Customer Database Browser:
1. Select File->Browse-»Customer Database.
The Browse Customer Database window appears.
2. Click on the icon for the Channel Cut Header Table (or click the plus sign next to the icon).

A list of all the interval data cuts stored in the database appears, either beneath the Channel
Cut Header table icon or in the right pane.

3. To select the cut you wish to view, double-click on the record in the right pane.

A Channel Cut Header record will open in the right pane. This record contains the same
header as described previously, except for the Maximum Values and Oracle Utilities Load
Analysis Validation Messages. These can only be viewed using the Interval Database Browser.

Viewing Cut Edit Information
Edit messages in interval data cuts are saved to the Oracle Ultilities Data Repository, and can be
viewed using the Browser. These messages, along with other data concerning edits to interval data
cuts stored in the Data Repository, are stored in the Channel Cut Edits Table.

How to view Cut Edit Information using the Customer Database Browser:
1. Select File-»Browse->Customer Database.
The Browse Customer Database window appears.
2. Click on the icon for the Channel Cut Edits Table, or click the plus sign next to the icon.

A list of all the interval data cut edits stored in the database appears, either beneath the
Channel Cut Edits table icon or in the right pane.

3. To select the cut edit you wish to view, double-click the record in the right pane.

A Channel Cut Edit record will open in the right pane. This record contains the following
information:

*  Channel Cut: The recorderid,channel, start time, and stop time of the cut.

*  Sequence: A number that designates the order of edits for the particular cut. The first
edit has a sequence of 1, the second 2, etc.

*  Text: The text of the edit message associated with the cut edit.
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Browse Select Interval Data
Select Interval Data in the Oracle Utilities Data Repository can be viewed using the Browser.

How to view Select Interval Data:

1.

Select File->Browse-»Select Interval Data.
The Select Interval Data window appears.
Click on Account or Customer under Select By.

Click on ID, List, All, or File to specify the type of data to be selected. If File is selected, you
can click Browse to locate and select the desired file.

In the Recorder field, enter the ID of the desired recorder. Click Exact to specify an exact
match.

Under Interval Data Input, the Database/Input Type will be automatically filled in. For
FileName, enter the full path and file name, or click Browse to select a file.

Click OK.

A screen appears, displaying the selected interval data in a tree format.
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Daylight Savings Time
Oracle Utilities products support interval data reads where the meter’s clock is set differently from
the account’s clock. This occurs because the meter is set to Standard time, while the account may
be on Daylight Savings Time, or because data from a third party may be based on a different time
zone than the account that uses the third party’s data.

In addition, an account can have meters in two or mote time zones.

When a Oracle Utilities product reports a date and time that is based on interval data (such as the
date and time of a maximum), the date and time must be reported as seen by the account, not the
metet.

When a Oracle Utilities product computes a real-time price by multiplying the price data (possibly
from a third party) by the usage data, the corresponding intervals must be aligned correctly—the
price must correspond to the usage in the same real time.

All interval data is stored with the time adjusted to match the accounts that use it. An option on
the interval data import dialog and command line allows users to specify the time zones of input
files and the time zones of their target accounts.

TIMEZONE Table
The TIMEZONE Table, stored internally, provides Daylight Savings Time (DST) support. It has
four columns:

Column Name Description

CODE The code assigned to the time zone; usually three or four
alphabetic characters, such as EDT (Eastern Daylight Time),
EDTA (Eastern Daylight Time - Adjusted), EST (Eastern
Standard Time), CST (Central Standard Time), etc.

NAME Visible name: Eastern Daylight Time, Eastern Standard Time,
Central Standard Time, etc.

TIMEZONE An integer indicating the number of timezones west of Greenwich
Mean Time (GMT); valid values are from 0 (GMT) to 23, inclusive.

DST Y - Indicates that all dates and times reflect Daylight Savings Time
(23 hours in spring, 25 in fall).

A - Indicates that all dates and times reflect Daylight Savings Time,
with intervals 24-hour adjusted. For adjusted intervals, in April
there is a blank hour on the appropriate day, and in October there
is an hour that is the average of two on the appropriate day.

N - Standard time.

If a channel is used by accounts in different timezones (such as an RTP price channel), each cut is
stored repeatedly with as many adjustments as needed, with each adjusted copy stored in a
different channel. An override value in the ACCTOVERRIDEHIST Table can be used to

determine the correct channel to retrieve.

Timezone Codes

CODE NAME TIMEZONE DST
GMT Greenwich Mean Time 0 N
BST British Summer Time 47 N
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CODE NAME TIMEZONE DST
BSTA British Summer Time - Adjusted 0 A
IST Irish Summer Time 47 N
ISTA Irish Summer Time - Adjusted 0 A
WET Western Europe Time 0 N
WEST Western Europe Summer Time 0 Y
WESTA Western Europe Summer Time - Adjusted 0 A
CET Central Europe Time 46 N
CEST Central Europe Summer Time 46 Y
CESTA Central Europe Summer Time - Adjusted 46 A
EET Eastern Europe Time 44 N
EEST Eastern Europe Summer Time 44 Y
EESTA Eastern Europe Summer Time - Adjusted 44 A
MSK Moscow Time 42 N
MSD Moscow Summer Time 42 Y
MSDA Moscow Summer Time - Adjusted 42 A
AST Atlantic Standard Time 8 N
ADT Atlantic Daylight Time 8 Y
ADTA Atlantic Daylight Time - Adjusted 8 A
EST Eastern Standard Time 10 N
EDT Eastern Daylight Time 10 Y
EDTA Eastern Daylight Time - Adjusted 10 A
CST Central Standard Time 12 N
CDT Central Daylight Time 12 Y
CDTA Central Daylight Time - Adjusted 12 A
MST Mountain Standard Time 14 N
MDT Mountain Daylight Time 14 Y
MDTA Mountain Daylight Time - Adjusted 14 A
PST Pacific Standard Time 16 N
PDT Pacific Daylight Time 16 Y
PDTA Pacific Daylight Time - Adjusted 16 A
UTC-12 Universal Time Coordinated - 12 hours 24 N
UTC-12D Universal Time Coordinated - 12 hours (DST) 24 Y
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CODE NAME TIMEZONE

UTC-12DA Universal Time Coordinated - 12 hours (24 Hr 24
Adjusted)

UTC-11 Universal Time Coordinated - 11 hours 22

UTC-11D Universal Time Coordinated - 11 hours (DST) 22

UTC-11DA Universal Time Coordinated - 11 hours (24 Hr 22
Adjusted)

UTC-10 Universal Time Coordinated - 10 hours 20

UTC-10D Universal Time Coordinated - 10 hours (DST) 20

UTC-10DA Universal Time Coordinated - 10 hours (24 Hr 20
Adjusted)

UTC-9 Universal Time Coordinated - 9 hours 18

UTC-9D Universal Time Coordinated - 9 hours (DST) 18

UTC-9DA Universal Time Coordinated - 9 hours (24 Hr 18
Adjusted)

UTC-8 Universal Time Coordinated - 8 hours 16

UTC-8D Universal Time Coordinated - 8 hours (DST) 16

UTC-8DA Universal Time Coordinated - 8 hours (24 Hr 16
Adjusted)

UTC-7 Universal Time Coordinated - 7 hours 14

UTC-7D Universal Time Coordinated - 7 hours (DST) 14

UTC-7DA Universal Time Coordinated - 7 hours (24 Hr 14
Adjusted)

UTC-6 Universal Time Coordinated - 6 hours 12

UTC-6D Universal Time Coordinated - 6 hours (DST) 12

UTC-6DA Universal Time Coordinated - 6 hours (24 Hr 12
Adjusted)

UTC-5 Universal Time Coordinated - 5 hours 10

UTC-5D Universal Time Coordinated - 5 hours (DST) 10

UTC-5DA Universal Time Cootdinated - 5 hours (24 Hr 10
Adjusted)

UTC-4 Universal Time Coordinated - 4 hours 8

UTC-4D Universal Time Cootdinated - 4 hours (DST) 8

UTC-4DA Universal Time Cootdinated - 4 hours (24 Hr 8
Adjusted)

UTC-3 Universal Time Coordinated - 3 hours 6

UTC-3D Universal Time Cootdinated - 3 hours (DST) 6
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CODE NAME TIMEZONE DST
UTC-3DA Universal Time Coordinated - 3 hours (24 Hr 6 A
Adjusted)
UTC-2 Universal Time Coordinated - 2 hours 4
UTC-2D Universal Time Cootdinated - 2 hours (DST) 4
UTC-2DA Universal Time Coordinated - 2 hours (24 Hr 4
Adjusted)
UTC-1 Universal Time Coordinated - 1 hour 2
UTC-1D Universal Time Coordinated - 1 hour (DST) 2
UTC-1DA Universal Time Cootdinated - 1 hour (24 Hr 2 A
Adjusted)
UTC Universal Time Coordinated 0 N
UTCD Universal Time Coordinated (DST) 0 Y
UTCDA Universal Time Coordinated (24 Hr Adjusted) 0 A
UTC+1 Universal Time Coordinated + 1 hour 46 N
UTC+1D Universal Time Coordinated + 1 hour (DST) 46 Y
UTC+1DA Universal Time Coordinated + 1 hour (24 Hr 46 A
Adjusted)
UTC+2 Universal Time Coordinated + 2 hours 44 N
UTC+2D Universal Time Coordinated + 2 hours (DST) 44 Y
UTC+2DA Universal Time Coordinated + 2 hours (24 Hr 44
Adjusted)
UTC+3 Universal Time Coordinated + 3 hours 42
UTC+3D Universal Time Coordinated + 3 hours (DST) 42 Y
UTC+3DA Universal Time Coordinated + 3 hours (24 Hr 42
Adjusted)
UTC+4 Universal Time Coordinated + 4 hours 40
UTC+4D Universal Time Coordinated + 4 hours (DST) 40 Y
UTC+4DA Universal Time Coordinated + 4 hours (24 Hr 40
Adjusted)
UTC+5 Universal Time Coordinated + 5 hours 38
UTC+5D Universal Time Coordinated + 5 hours (DST) 38 Y
UTCH+5DA Universal Time Coordinated + 5 hours (24 Hr 38
Adjusted)
UTC+o6 Universal Time Coordinated + 6 hours 36
UTC+6D Universal Time Coordinated + 6 hours (DST) 36 Y
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CODE NAME TIMEZONE DST

UTC+6DA Universal Time Coordinated + 6 hours (24 Hr 36 A
Adjusted)

UTC+7 Universal Time Coordinated + 7 hours 34

UTC+7D Universal Time Cootdinated + 7 hours (DST) 34

UTC+7DA Universal Time Coordinated + 7 hours (24 Hr 34
Adjusted)

UTC+8 Universal Time Coordinated + 8 hours 32

UTC+8D Universal Time Coordinated + 8 hours (DST) 32

UTC+8DA Universal Time Coordinated + 8 hours (24 Hr 32
Adjusted)

UTC+9 Universal Time Coordinated + 9 hours 30

UTC+9D Universal Time Coordinated + 9 hours (DST) 30

UTC+9DA Universal Time Coordinated + 9 hours (24 Hr 30
Adjusted)

UTC+10 Universal Time Coordinated + 10 hours 28

UTC+10D Universal Time Coordinated + 10 hours (DST) 28

UTC+10DA Universal Time Coordinated + 10 hours (24 Hr 28
Adjusted)

UTC+11 Universal Time Coordinated + 11 hours 26

UTC+11D Universal Time Coordinated + 11 hours (DST) 26

UTC+11DA Universal Time Coordinated + 11 hours (24 Hr 26

Adjusted)
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Chapter 7

Maintaining Data

This chapter explains how to maintain data, including
*  Maintaining Lookup Codes
*  Creating and Maintaining Calendar Schedules

*  Creating Blockings

Maintaining Data 7-1



Maintaining Lookup Codes

Maintaining Lookup Codes

Lookup codes provide a standardized way to reference commonly-used pieces of information—
such as billing determinants, operating companies, and jurisdictions.

This section explains how to use the Browser to add, update, and delete records for many of the
types of Lookup codes used by the Oracle Utilities products.

About Lookup Codes

Lookups are codes used to identify entities that are commonly referenced in account and account
history records, rate form parent records, and rate form scripts. Each type of lookup code can be
considered a table or “picklist” of acceptable values for certain fields in other records. Lookup
codes are used to represent units of measure, bill determinant types, billing cycle codes, operating
companies, jurisdictions, etc.

Lookup codes prevent users from entering the same information in multiple ways. For instance,
without a lookup code for units of measure (UOMs), three different users might enter “kilowatt,”
“kW,” and “Kilowatts.” The system would interpret these as three different UOMs. Using a
consistent set of codes makes data retrieval possible, and helps eliminate tedious and error-prone

typing.
A lookup code must be defined in the database before you can reference it in another database
record. For example, you cannot specify an operating company for an account until that operating

company has been assigned a lookup code. Similatly, you cannot remove a lookup code from the
database until all references to it in other records are either deleted or modified.

Lookups in the base system include:
*  Operating Company

*  Jurisdiction

*  Unit of Measure (UOM)

* Bill Determinants

*  Group Category

* Interrogations

*  Account Note Type

*  Revenue Code

*  Standard Industrial Classification (SIC) Code
*  Override

*  Factor

*  Factor Values

* Billing Cycle

* Billing Cycle Dates

* Directory

* Account Statuses

*  CIS Account

* LSCurrency

This section explains how to add, modify, and delete lookup codes. Refer to the Oracle Utilities
Energy Information Platform Configuration Guide for more information about these and other lookup
codes.
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Adding a New Lookup Code

How to add a new Lookup Code:

1. Select File-»sBrowse->Customer Database.

The Browser appears.

2. Click on the table icon for the lookup code type that you wish to enter.

All currently available lookup codes of the selected type appear in the Record Pane on the

right. Scroll through the list to make sure the code you’re interested in isn’t already defined.

3. Select Records-Insert New, or click the 7gh? mouse button and select Insert New.

A blank data entry form for the lookup code type appears.

4. Add data as desired. Some general guidelines are:

All fields are required. If you do not want to insert information in a field, click the Null
checkbox for that field or group of fields. (A checkmark in the Null box means that
you've intentionally left the field blank.) If the Null box is checked and you 4o want to put
some information in that field, you must uncheck the box before you can enter any data.

Fields that have gray outlines (such as Unit of Measure Code in the preceding example)
require entries (such as other lookup codes) that have already been defined in other
tables. To complete one of these fields, click the mouse in the field and make your
selection from the pick list that appears. With the desired selection highlighted, press
ENTER, click OK, or double-click on your selection.

When completing a “Code” or “Identifier” field, Oracle Ultilities recommends that you
use all capital letters (e.g.,, GECO, not Geco). Database queries are case-sensitive, so it’s
important to be consistent when setting up the database and entering query criteria.

If you have entered some information in the form and then decide not to save the
record, simply click on another table or record to open a new one.

If you want to base a new record on an existing record (so that you don’t have to retype
information that already exists), open the old record to display its information in the
record pane, type in the new information where required, and select Edit-»Add.

Do not attempt to add a record to a table that is displayed in red in the Tree Pane. The
red warning does not mean you cannot add a record to that table at all, but that you
should not add records at that point in the tree. Instead, find the table at a different point
in the tree, where it is displayed normally (in white). Then, add records as desired.

If you add a new record but it does not appear in the tree view, you need to “refresh” the
display. Click the minus sign next to the parent table so that the tree collapses, then click
on the plus sign to re-expand it. You can also refresh the display by highlighting the
parent table and selecting Records->Refresh. Select Records->Refresh All to refresh
the entire tree after adding multiple entries.

5. To save the record when you have completed all information, select
Edit->Add, or click the rght mouse button and select Add.

Alternate Method:

This method allows you to create new lookup codes on-the-fly. Instead of browsing the

appropriate table in the Tree Pane, you can add a child lookup code from your present location via
the Record Pane.

1. Enter the name of the code you want to create in the appropriate lookup code field in the

Record Pane.

2. Right-click in an unused (gray) portion of the Record Pane; select Add from the menu that
pops up.
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The system will prompt you to add this code to the database.
3. Click Yes.
A new Browser will appear, displaying a list of all required fields.

4. Fill in the fields as desired, then right-click and select Add to add the new lookup code and
return to the original Browser window.

Updating a Lookup Code

Often, information within your system needs to change to reflect new or modified rates, tariffs,
companies, jurisdictions, etc. Use the following procedure to update lookup codes, to reflect the
changes.

How to update a lookup code:

1. In the Browser, click on the plus sign to the left of the table that contains the record you wish
to update.

The records are displayed in both the Tree Pane and the Record Pane.
2. Click on the icon for the desired record in the Tree Pane.
The edit form for that record appears.

3. Change attribute values as necessary. Refer to the previous pages for descriptions of the
record fields and allowable values.

Note: The software will not allow you to modify any field values that are referenced in other
records without first modifying or deleting the other records.

4.  Click Edit->Update, or click the 77ght mouse button and select Update, to save.

Selecting a Lookup Code

When you click in a field that has an associated list of predefined lookup codes — called a lookup
table — a window will appear, allowing you to pick from the predefined codes or add a new one.
This window can be sorted to make long lists of codes easier to navigate.

To select a code from the list, either double-click the desired code, or single-click to highlight it
and click OK.

Sorting a Lookup Table

Clicking on the header of one of the table’s columns will alpha-numerically sort the table by the
contents of that column.

To move to a particular section of the list or to a specific item, use the Column Name and Value
fields. The Column Name drop-down menu contains the names of all the columns in the
displayed table (including those you might need to scroll left or right to see). Select the column you
wish to scan. Next, enter a string into the Value field that corresponds to an entry in that column.
Then click Find.

The table will scroll to (and highlight) the first record it encounters that begins with the string
entered into the Value field. The more specific you are, the closer the selection will be to the code
you’re secking. In the illustration above, entering ‘P’ in the Value field will jump to “PAPCo.”
Entering PO’ will jump to “POC.”

The search is not case-sensitive. Wild card searches are not supported.

7-4 Data Manager User’s Guide



Maintaining Lookup Codes

Deleting a Lookup Code

When you delete a record, the software removes the selected record and any child records. For
example, when you delete a Billing Cycle record, all of its Billing Cycle Date records are also
deleted.

How to delete a lookup code:

1. In the Browser, click on the plus sign to the left of the table that contains the record you wish
to delete.

The records are displayed in both the Tree Pane and the Record Pane.
2. Click on the icon for the desired record in the Tree Pane.
3. Select Edit->Delete.
A warning message appears, reminding you that dependent records will also be deleted.

4.  Click Yes to delete the records.
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Creating and Maintaining Calendar Schedules

Holidays

Rate forms can incorporate time-of-use and season-based pricing. You use the calendar schedules
to assign every hour of every day to a Time of Use schedule, so that the computational programs
apply the correct charges. This section explains how to create new schedules and modify existing
ones.

Many of the Oracle Utilities products refer to the holiday lists when executing analyses that
incorporate time-of-use periods.

There must be at least one holiday list for each operating company/jutisdiction combination in
your system.

Holidays require two types of records: “Holiday List Name” defines the Holiday List in the
database, and “Holiday” defines the date and name of each holiday in the list.

Data Manager considers Holidays to be lookup codes, so you work with them via the Browser.
How to add a Holiday List Record:
1. Select File->Browse-»Customer Database.
The Browser appears.
2. Click on the Holiday Lists table icon.
3. Select Records-Insert New, or click the 7gh# mouse button and select Insert New.
4. Complete the fields:
Name: Enter a name for the list (up to 64 characters).
Note: Add any descriptive comments (up to 254 characters.)

5. When you have completed the fields, select Edit-»>Add, or click the 7gh# mouse button and
select Add, to save the record to the database.

How to add a Holiday to a List:

1. Click the plus sign next to the icon for the parent Holiday List record in the Tree Pane.
A Holidays table icon appears below the parent Holiday List record.

2. Click on the Holidays table icon.

3. Select Records-Insert New, or click the #gh? mouse button and select Insert New.

4. Complete the fields:

Holiday List: Click on the words ‘Holiday List’ to open a list of existing holiday lists. Select the
appropriate list.

Date: Enter the date on which the holiday falls, using the date format specified in Tools-
»Options.

Name: Add a descriptive name (up to 64 characters).

5. When you have completed the fields, select Edit-»>Add, or click the 7gh# mouse button and
select Add, to save the record to the database.

6. Repeat steps 2 through 5 for each holiday you want to include in the list.
How to Update or Delete a Holiday List or Holiday Record:

Holiday lists and Holidays are updated and deleted in the same way as other lookup codes. See
Updating a Lookup Code on page 7-4, and Deleting a Lookup Code on page 7-5 for
instructions.
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Season Schedules

Season schedules specify the dates for seasons in different years. You can define any period or

periods as “Summer,” “Winter,” or any time period consisting of a set of revenue months. Non-

contiguous time periods can belong to the same season (for example, winter in several different

years).

When you have defined the seasons, you can use the Rules Language’s SELECT BILL_PERIOD
Statement to assign different charges to each season in a rate form.

You can also associate a different set of Time-of-Use schedules with each season (explained in the

next section).

You can name and save any number of sets of seasons.

Rules for Creating Season Schedules
The rules to follow when creating a new Season Schedule or updating an existing one are.

A schedule must have at least two uniquely named periods (seasons).
Each season period must have a name, start date, and stop date.

Dates must be specified in the format selected in your Options dialog.
No overlaps are allowed. This means one day may not be in two seasons.

No gaps are allowed. This means that all season periods within the schedule must be
contiguous.

Creating or Modifying a Season Schedule

1.

Select File->Setup-»Season Schedules.
The Open Season Schedule dialog box appears.

To create a new schedule, click New. To view or modify an existing schedule, highlight it in
the list box and click Open.

The Season Schedule dialog box appeats.

You can open multiple season schedules at the same time by pressing the Shift or Ctrl key
while selecting the season schedules. The selected schedules will open in separate Season
Schedule dialog boxes.

To add a new period to your schedule, type its name, start date, and stop date in the lower
portion of the window. (Dates must be specified in the format selected in your Options
dialog.) Click Add; the season appears in the upper list box.

To modify an existing season, highlight it in the upper list box, change the information in the
edit boxes below, and click the Update button.

To remove a season from the schedule, highlight it in the upper list box and click Delete.

Continue adding or modifying seasons until all days within the schedule are assigned to a
season. Be sure that the schedule follows the guidelines described in Rules for Creating
Season Schedules on page 7-7.

When you are satisfied with the schedule, you can either click OK to replace an old schedule
with a new version or save a new schedule, or click Save As to save a modified version under
a new name.

The Save Season Schedule box appeats.
Type a name for your schedule in the Name field.

The name can be up to 64 characters long. You will use this name in rate forms to identify the

schedule.
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If you wish, supply descriptive information in the Comment field.

You can use up to 254 characters. These comments will appear in the Open Season
Schedule dialog box.

10. Click OK to save your schedule to the database.

Exporting a Season Schedule
You can export a Season Schedule from Data Manager in a file that is automatically formatted for

input to the Oracle Utilities programs.

How to Export a Season Schedule:

1.

Select File->Setup-»Season Schedules.

The Open Season Schedule dialog box appears.
Highlight the desired schedule, and click Export.

The Select season file for export dialog box appears.

If you want to overwrite an existing file, browse for it (if necessary). When the target file
appears in the window, double-click to select it.

To save to a new file, enter a new File name. Do #ot add an extension, as the program will add
it for you, based on Save as type (below).

Season schedules are saved as Common Schedule (*.txt) files. This is a plain text format so
you may open and edit the file with Notepad or another text editor.

Click Save.

Importing a Season Schedule
You can also import a previously-exported Season Schedule.

How to Import a Season Schedule:

1.

Select File->Setup->Season Schedules.

The Open Season Schedule dialog box appears.

Click Import.

The Select season schedule file for import dialog box appears.

Select the file to import. Season files are in Common Schedule (*.txt) format.

Click Open.

Time-of-Use Schedules

Use Time-Of-Use (TOU) Schedules to classify each hour in a week or holiday as “on peak,” “off
peak,” or “shoulder,” or whatever periods are used at your utility. You can set up any number of
TOU Schedules, which will then be available for reference in a rate form.

Rules for Creating TOU Schedules

Be sure to follow these rules when creating a new schedule or updating an existing one.
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A TOU Schedule must have at least one period.
Each period must have a name, start time, stop time, and at least one day checked.

No overlaps or gaps are allowed between periods. This means that every minute in the seven
weekdays and the holiday must be included in a period. No hour may be in more than one
period.
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Times should be entered on full hour boundaries. For example, 00:00 to 12:00 and 12:00 to
24:00.

Creating or Modifying a TOU Schedule

1.

10.

Select File->Setup->TOU Schedules.
The Open Time of Use Schedule box appears.

To create a new schedule from scratch, click New: To view ot modify an existing schedule,
highlight it and click Open.

The Time-of-Use Schedule dialog box appeats.

You can open multiple TOU schedules at the same time by pressing the Shift or Ctrl key
while selecting the TOU schedules. The selected TOU schedules will open in separate Time-
of-Use Schedule dialog boxes.

If you want to associate the TOU schedule with a particular season, select it from the Season
Schedule list box. (Click on the arrow to the right of the field, and make your selection. The
season must have already been defined; if not, see Season Schedules eatlier in this chapter.)

To add a new period to your TOU schedule, enter a TOU Period Name, Start Time, and Stop
Time in the lower portion of the window. Check all days that apply. Click Add. The period
appears in the upper list box.

Note: The TOU Period Name must be defined in the TOU Period Name table in the Oracle
Utilities Data Repository.

To modify an existing period, highlight it in the upper list box, change the information in the
edit boxes below, and click the Update button.

To remove a period from the schedule, highlight it in the upper list box and click Delete.

Continue adding or modifying periods until every hour of all eight days are covered. Be sure
that the schedule follows the guidelines described in “Rules for Creating TOU Schedules,” earlier
in this section.

When you are satisfied with the schedule, you can either click OK to replace an old schedule
with a new version or save a new schedule, or click Save As to save a modified version under
a new name.

The Save Time of Use Schedule box appears.

Type a name for your schedule in the Schedule Name field. The name can be up to 64
characters long.

If you wish, supply descriptive information in the Comment field. You can use up to 254
characters. These comments will appear in the “Open Time of Use Schedule” dialog box.

Exporting a TOU Schedule

You can export a Time-Of-Use Schedule from Data Manager in a file that is automatically
formatted for input to the Oracle Utilities programs.

Note: Export works only with TOU Schedules that are associated with a
Season Schedule. (This feature creates two files—a TOU Schedule Export File
and a Season Schedule Export file.) If you attempt to export a TOU file that is
not associated with a Season, the program returns an error message.

Select File->Setup->TOU Schedules.
The Open Time of Use Schedule dialog box appears.
Highlight the desired schedule, and click Export.

The Select time of use file for export dialog box appears.
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If you want to overwrite an existing file, browse for it (if necessary). When the target file
appears in the window, double-click to select it.

To save to a new file, enter a new File name. Do nof add an extension, as the program will add
it for you, based on Save as type (below).

Season schedules are saved as Common Schedule (*.txt) files. This is a plain text format so
you may open and edit the file with Notepad or another text editor.

Click Save.

About the Output Format
TOU Schedule Export File: Contains a record for each TOU period in the TOU schedule.
Each record has the following fields separated by three blanks:

Schedule number—extracted from the different season periods covered by the TOU
schedule.

TOU petiod.

Day list—identifies the day of the week to which the period applies (1 - Sunday, 2 - Monday,
etc.; 8 - holiday).

Period start-time

Period stop-time

Comments (TOU petiod name).

Sample TOU Schedule Export File

1 1 1,7,8 00:01 24:00 off peak
1 2 2,3,4,5,6 00:01 24:00 on_peak
2 1 1,7,8 00:01 24:00 off peak
2 2 2,3,4,5,6 00:01 24:00 on_peak

Season Schedule Export File: Contains a record for each TOU schedule within a season period
of a season schedule. Each record has the following fields separated by three blanks:
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Season schedule number.

Season number—season number corresponding to the season period within a season
schedule.

TOU schedule number—extracted from the TOU schedule file by matching the season
corresponding to the TOU schedule’s season period with the current season period.

Start and stop—start and end of a range within a season period. Separate records are created
for each range within a season period.

Comments (Season period name).

Sample Season Schedule Export File

1 1 1 05/01/92-00:01 08/31/92-24:00 Summer
1 1 1 05/01/93-00:01 08/31/93-24:00 Summer
1 2 2 09/01/92-00:01 04/30/92-24:00 Winter
1 2 2 09/01/93-00:01 04/30/93-24:00 Winter
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Importing a Time-of-Use Schedule
You can also import a previously-exported Time-of-Use Schedule.

How to Import a Time-of-Use Schedule:

1.

Select File->Setup->Time of Use Schedules.

The Open Time of Use Schedule dialog box appears.

Click Import.

The Select time of use schedule file for import dialog box appeats.

Select the file to import. Time of use schedule files are in Common Schedule (*.txt) format.

Click Open.

User-Specified Day Lists

A Uset-Specified Day List can be an input to some of the computational programs. It is used to

specify a group of days to be averaged together. For example, you could specify several summer

peak days to be averaged together.

Like Holiday Lists, User-Specified Day Lists are considered lookup codes from the database
perspective, so you work with them via the Browser.

User-Specified Day Lists require two types of records: User-Specified Day List Name, which
creates a parent record for the list in the database, and
User-Specified Days, which defines the date and name of each day in the list.

How to Add a User-Specified List Record:

1.
2.

Select File->Browse->Customer Database. The Browser appears.

Click on the User-Specified Day Lists table icon. (You may have to scroll down the list to
bring the icon into view.)

All currently defined lists are shown in the right Record Pane. Scroll through the pane to
make sure that the list you're interested in isn’t already defined.

Select Records->Insert New, or click the 77ght mouse button and select Insert New.
Complete the fields:

Name: Enter a name for the list (up to 64 characters).

Note: Add any descriptive comments (up to 254 characters.)

When you have completed the fields, select Edit-»>Add, or click the 7gh# mouse button and
select Add, to save the record to the database.

How to add a day to a list:

1.

Click the plus sign next to the icon for the parent User-Specified Day List record in the
Tree pane.

A table icon for User-Specified Days appears under it in the tree.
Click on the User-Specified Days table icon.
Select Records->Insert New, or click the 7ght mouse button and select Insert New.

In the data entry form that appears, specify the date using the format specified in your
Options dialog.

Select Edit-»Add, or click the right mouse button and select Add, to save it to the database.

Repeat steps 2 though 5 for each day you want to add to the list.
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Creating Blockings

When you create a blocking, you can specify the high and low values that define each individual

block. O, if all or a portion of the blocking consists of a series of contiguous, equal-size blocks,

the software gives you a shortcut—in that case, you can supply the high and low values that define

the range covered by the series of equal-sized blocks, and then the value of the block (called the
“Step” value).

How to create a new blocking:

1.

9.

Go to the Data Manager desktop. If you are at the Oracle Ultilities Rate Management desktop,
you can open Data Manager by selecting Tools-»Data Manager.

At the Data Manager desktop, select File-»Setup->Blocking Tables.
The Open Blocking dialog box appears.

Click New.

The Blocking dialog box appeats.

Under Values, enter the Low and High values for the current block (or the range of
contiguous, equal-size blocks). The High value must be greater than the Low value for each
block, except for the /st block in the blocking, which may be zero (a High value of zero
indicates infinity).

You can specify negative numbers for the low and high values that define a block (however,
these are used only in the Billing Impact Frequency report in Customer Impact). If you
change your mind and want to remove a minus sign, simply type a + sign in the Values field
for that value.

Enter a Step value for the block. If you are defining each block individually, then the Step
value must equal the difference between the High and Low values. If you are using the step
feature to specify a set of contiguous, equal-size blocks, the Step value must evenly divide into
the difference between the High and Low values. If you are specifying the last block with a
High value of 0, the Step value should be 0, too.

Note: If any usage values fall outside of the specified blockings (either at the high end if you
did not specify O for the High value in the last block, or at the low end if there are negative
values), the program automatically creates an “additional” blocking at that end when the
program creates the Bill Frequency Table.

Click Add to insert the block(s) into the Blocking Contents list box. A block is automatically
inserted into its proper position in the list box based on its Low and High values.

Repeat Steps 3 through 6 to add any other blocks necessary to complete the definition of the
Blocking. Make sure that the High values match the Low values for consecutive
blocks.

Click OK to save the new blocking in the Customer Database. The Save Blocking Table As
dialog appears.

Enter a name and comments for the blocking, and click OK.

You can also open an existing blocking file.

How to Open an Existing Blocking:

1.
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At the Data Manager desktop, select File->Setup->Blocking Tables.
The Open Blocking dialog box appears.

Select the desired blocking and click Open. You can also import a Common Blocking file by
clicking Import and selecting the appropriate Common Blocking file. The imported blocking
file then appears in the Open Blocking dialog;



Chapter 8

Working with Lists and Queries

Lists are a required input for many Oracle Utilities products. You use them to specify the
customers or accounts with which you wish to work.

You can use Data Manager’s powerful Query feature to create and work with lists of customers or
accounts that meet a set of user-defined characteristics, as well as lists of database records that can
be used by the Oracle Utilities Rules Language. This includes:

¢ Customer/Account Lists
* Lists for Use in Rate Forms (Table.Column Queries)
*  Constructing Queries

* Importing and Exporting Lists in Batch Mode
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Customer/Account Lists

Customer/account lists consist of a set of customer IDs or account IDs. Lists are required inputs
for many Oracle Ultilities applications.

You can create a customer/account list by simply typing it with a text editor or by downloading it
from another application. You can then use Data Manager’s List Import feature (described later in
this chapter) to bring the list into the Oracle Utilities Data Repository.

The Query Feature

The Query feature enables you to automatically assemble a list of all customers or accounts in the
Data Repository that match certain criteria. You can, for example, find all accounts in the database
that have a particular rate code, or all customers whose monthly kWh usage exceeds a given
amount, or all accounts in a particular jurisdiction. The system is very flexible and the search
criteria are up to you.

Note: It is also possible to use a query to generate lists of other types of entities
in the database. See Lists for Use in Rate Forms (Table.Column Queries)
on page 8-9.

Using the Query Feature, you create lists as needed, and you can save them for later or repeated
use. Because the query is automatically saved with the list, you always have a record of what was
done. And, you can quickly rerun the query against a modified database or edit it for another use.

You can also export a list in a file format that can be used as input to Oracle Utilities products; or
in a neutral, text-only file format for sharing with non-Oracle Ultilities products. This means that

you can make use of the Query feature for any application that requires segmenting the customer
population by user-defined characteristics.

Creating a New Customer/Account List Using the Query Feature

This section explains how to initiate a query that finds a list of customer or account IDs that
match a set of desired characteristics.

How to create a customer/account list:
1. Select File-Lists->Customer/Account(s).
The Account/Customer List dialog box appeats.

To browse database records for an existing list, select its name from the Name drop-down
list, and click the Browse button. The Browser opens, with the account or customer records

displayed.

2. Select Accounts or Customers, depending upon whether you want a list of customer or
account IDs.

An account is the entity for which a bill is computed. A customer is the entity that receives
the bill.

3. Type a Name and Description for your list.

Name and Description can each consist of up to 40 characters. Spaces are allowed in both. If
a name already exists, click in the field and type over the old entry. When typing the name of a
new list, be sure to remove the angle brackets (‘<‘, >’) and any existing text.

4. Click the Query button.

The Query to Create a List of Accounts (or Customers, if that’s what you selected in Step
2) dialog box appears.

The List Query dialog box gives you a convenient and structured way to describe the
customers or accounts that you want to retrieve from the database.
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Queries ate constructed in this order: “table.column, relationship, value.” You can construct
queries with multiple conditions by chaining together any number of clauses using either of
the two conjunctions (logical AND or OR).

Example of a typical query:
First Clause Conjunction  Second Clause

Accounts.ID > 10000 AND RateCodes.Code = 5

If you are creating a list of account IDs, this query retrieves all accounts whose ID is greater
than 10000 and whose rate code is 5.

See Constructing Queries on page 8-16 for more information.

When you have finished constructing your query, click OK

Data Manager displays a list of the IDs that met your search criteria.

You have several options:

Display: Click Display to view the list that resulted from your query (if not displayed).

Report: Generates a Billing History Report for a selected Customer or Account ID (see The
Billing History Report on page 10-9 for more information about the Billing History
Report). To use this option, first select one of the IDs in the currently-displayed list, then
click Report. This report uses the default test period specified on the Rate Analysis tab of the
Default Options dialog. See Default Options on page 2-9 for more information.

Save: Saves your list—and the query used to create it—to the database. Your list is now
available for other Oracle Ultilities products.

Query: If you are not satisfied with the list (perhaps the number of customers found was
much larger or smaller than expected), you can revise your query, and rerun the search. Click
the Query to redisplay the Query to Create a List dialog box.

Delete: Deletes the list if saved.

Cancel: Closes the window. Be sure to save your list first, otherwise all your work will
be lost.

Change to Customer List: Changes an account list to a customer list, or a customer list to
an account list. See Changing the List Type (Account to Customer) on page 8-4 for more
information.

Import: Imports a previously-created list. See Importing a Customer/Account List on
page 8-4 for more information.

Export: Saves the currently-displayed list to a file. See Exporting a Customer/Account
List on page 8-5 for more information.
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Changing the List Type (Account to Customer)

You can change an account list to a customer list (or change a customer list to an account list).

Note: Lists that been locked (the Editable column on the List table is set to “No”). cannot be
changed in any way.

How to change a customer/account list:
1. At the Data Manager desktop, choose File-Lists->Customet/Account(s).

2. Seclect Accounts or Customers, depending upon whether you want a list of customer or
account IDs.

3. In the Name combo box, select the desired list.

4.  Click Change to Customer List (or Change to Account List. The Change Account/
Customer List dialog box opens.

5. Select the appropriate Save Option:

* Replace List Query: Replaces the existing account (or customer) list with a customer
(or account) list based on the same query.

*  Save List Query as: Saves the account (or customer) list as a new list. If you select this
option, enter the name for the new list.

6. Click Save to save the list.

Importing a Customer/Account List
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You can import a list file containing customer or account IDs into the Oracle Utilities Data
Repository. The file must be in one of the following formats:

*  List Files (*.Ist) files are created by the Export feature explained on the previous page and
have the extension ‘. LST’. They contain both the IDs and the query used to create the list.

*  Account Query Files (.qra) Contains the query and all the account IDs in the list. It is a
proprietary format that only the Data Manager can read.

*  Customer Query Files (.qrc) Contains the query and all the customer IDs in the list. Itis a

proprietary format that only the Data Manager can read.

*  IDs Only Files (.ids) An ASCII file of just the customer IDs or account IDs. This is useful

for sharing with any type of application.

* IDs Only XML Files (.xml) An XML file containing the customer IDs or account IDs.
This is useful for sharing with any type of application.

The format for this file type is as follows:

For an Account List:

<LODESTAR LISTEXPORT>
<ACCOUNT_ID>Artemis05</ACCOUNT_ ID>
<ACCOUNT ID>Artemis04</ACCOUNT ID>
<ACCOUNT ID>Artemis03</ACCOUNT ID>
<ACCOUNT_ID>Artemis02</ACCOUNT_ ID>
<ACCOUNT ID>Artemis01</ACCOUNT ID>
</LODESTAR LISTEXPORT>

For a Customer List:

<LODESTAR LISTEXPORT>
<CUSTOMER ID>KNN 01</CUSTOMER ID>
<CUSTOMER ID>KNN 02</CUSTOMER ID>
<CUSTOMER ID>KNN_ 03</CUSTOMER ID>
<CUSTOMER ID>KNN 04</CUSTOMER ID>
<CUSTOMER ID>KNN 05</CUSTOMER ID>
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</LODESTAR LISTEXPORT>

How to import a customer/account list:

1.
2.
3.

At the Data Manager desktop, choose File-Lists-»>Customer/Account(s).
Click the Import button. The File Import List dialog box appears.
Select the desired list, and click Open.

The list appears in the Account/Customer List dialog box. You can edit the name and
description, or apply any of the other features of the dialog box. For example, if the list is in
the .LST format, you can click Query and edit or rerun the query as desired.

Click the Save button to save your list.

Exporting a Customer/Account List

When you have created a list of customer or account IDs, you can save it to a file for sharing with

other Oracle Utilities users or even other applications. There are several types of file formats to

which you can export:

List Files (.Ist) Contains the query and all the customet/account IDs in the list. Itis a
proprietary format that only the Data Manager can read.

IDs Only Files (.ids) An ASCII file of just the customer IDs or account IDs. This is useful
for sharing with any type of application. Following is an example of an “IDS’ file:

192993898985
198982988485
198929994995
192999499599

Control Files (.ctl). Contains the identifiers of the interval data recorders/channels that
belong to the customers or accounts in the list. This file format can be used as a Control file
for input to a Oracle Utilities program. An example of a Control file:

N1723, 1
N1724, 1

If there are no recorder/channels stored for one or more members of the list, you ate notified
via a pop-up message box. Data Manager also writes this information to the Log file (located
in the \user ditectory).

Totalize Files (.ctl) Use this file format if you want to totalize multiple channels of interval
data for the members of your list using the Totalizing Reporter (an optional extension to the
Oracle Utilities L.oad Analysis product). In other words, this file is automatically created in the
correct format for use as a Totalizer Control file.

Following is an example of the Totalize File Format. In the following example, the customer
ID is 80001 and it has one account (800002).

REM 'CUSTOMER NUMBER'

ACCUMULATE 'CUSTOMER NUMBER 80001
KEY N1723, 1

KEY N1725, 1

ACCUMULATE 'ACCOUNT NUMBER 800002
KEY N1736, 1

END 'ACCOUNT NUMBER 800002

END 'CUSTOMER NUMBER 80001

If a2 customer has more than one account, all accounts will be listed one after another,
enclosed within the keyword pair “ACCUMULATE-END”.

Account Query Files (.qra) Contains the query and all the account IDs in the list. It is a
proprietary format that only the Data Manager can read.
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*  Customer Query Files (.qrc) Contains the query and all the customer IDs in the list. Itis a
proprietary format that only the Data Manager can read.

Note: If desired, you can edit these files using an ASCII text editor.

* IDs Only XML Files (.xml) An XML file containing the customer IDs or account IDs.
This is useful for sharing with any type of application.

How to export a customer/account list:
1. At the Data Manager desktop, choose File->Lists->Customer/Account(s).

2. Select Accounts or Customers, depending upon whether you want a list of customer or
account IDs.

In the Name combo box, select the desired list.
Click Export. The File Export List dialog box appears.
In the File name field, supply a file name.

Specify a list type in the Save as type drop-down box.

N vk W

Click Save to save the query to the specified file.
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Refreshing Customer and Account Lists in Batch Mode

The LISTOP function of the Oracle Utilities Rules Language performs operations on lists of
values in the BILLHISTORY Table, which may contain hundreds of thousands of values. If the
list is not correct the same record may appear in the result set more than once. Lists can be
refreshed so only the most current and accurate data available is used via the LSTRFRSH.EXE
command line program.

LSTRFRSH Command Syntax

LSTRFRSH uses the syntax shown below. Parameter switches are case insensitive; you can enter
them in either upper or lower case (-c or -C). If a parameter includes a space, you must enclose it
in quotes (for example, -£<11/01/1999 12:00:00).

Istefrsh -c connectstring [-q gualifier] -£ configfilename [-1cfg logging configuration filenane|

In actual use, the command must be entered on one line. Also, you must either change to the
directory in which the program is stored (typically, \LODESTAR\bin) before entering the
command, or specify the path in the command. To view a list of all parameters on-screen, type
Istrfrsh -? at the command prompt.

Parameter Description

-c connectstring is database connection information for the Oracle Utilities
Data Repository. This parameter is required and must be in one of the
following formats:

For Oracle databases:

"Data Source=<data_source>;User
ID=<user_id>;Password=<password>;LSProvider=ODP;"

For Microsoft SQL databases:

"Data Source=<addtess>;Initial Catalog=<SQL_database>;Uset
Id=<user_id>;Password=<password>;MultipleActiveResultSets=True
;LSProvider=MSSQL;"

where:

*  <data_source> is the Oracle TNS Name for the data source, from
the TNS_NAMES.ora file (typically located in the
\\<machine>\oracle\network\admin directory)

e <user_id> is the user ID for the database connection
*  <password> is the password for the supplied user ID.

*  <address> is the IP address or Hostname of the MS SQL Server
database server

*  <SQL_database> is the name of the MS SQL Server database

-q gualifier is an optional database qualifier. The default is PWRLINE.
-f configfilename is the name of the configuration file that defines the

working environment of the Oracle Utilities software (tells the software
where to find and place the application data files, etc.). If you do not
supply a value for configfilename, the system uses the default
(LODESTAR.CFG). For information about the contents of this
configuration file, see the Oracle Utilities Energy Information Platform
Configuration Guide.
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Parameter Description

-lefg logging configuration filename Name of an optional logging configuration
file that specifies where error and log messages are sent. If you omit this
parameter, the application creates a log file named LSTRFRSH.LOG in
the LOG directory.

Example
Following is an example of LSTRFRSH.EXE.

LSTRFRSH -c lodestar -f lodestar.cfg
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Lists for Use in Rate Forms (Table.Column Queries)

This section explains how to create queties that you can incorporate in rate forms. These queries,
called “Table.Column Queries,” are strictly for use with the Oracle Utllities Rules Language—
specifically, the “For Each x in List” Statement, and the INTDLOADLIST and MVLOADLIST
functions.

These queries enable you to apply revenue calculations, report statements, or other elements of
the Rules Language to any group of entities in the database that meet a set of search criteria you
supply. This is particularly useful for applying calculations to elements of the billing hierarchy
other than just accounts, such as channels or channel groups.

This section introduces the concept of Table.Column lists and queries, and the interrelationship
between Table.Column lists and the Rules Language. It then provides step-by-step instructions for
creating and saving Table.Column queries.

What Are Table.Column Queries?

Table.Column queries are used to create lists of items in the Oracle Ultilities Data Repository that
match a set of criteria you define. They are similar to the queries used to create the lists of
Customer and Account IDs described in the previous chapter—that is, they compare a value in a
database column to criteria you supply. If the value satisfies the criteria, the entity to which it
belongs is included in your list. If not, it is skipped.

There are important differences between Customer and Account queries and Table.Column
queries, however.

First, Table.Column queries and lists are used only as part of a rate form. When the billing or analysis
program runs the rate form, the list is automatically created at that time and applied however the
Rules Language statements specify. The list itself is not saved.

Second, Table.Column queries let you specify the “target” table and column that you want to take
data from. You are not limited to customer and account IDs as you are with Customer and
Account queties. In fact, you can target any column in any table or combination of tables in the Oracle
Utilities Data Repository. For example, the result of your query might be a list of lookup codes in a
targeted lookup table, or a list of recorder IDs from the Recorder Table, or a list of channels that
belongs to a channel group in the Channel Group Table. This feature makes it possible to apply
rate calculations at any level of the billing hierarchy, such as channels or channel groups.

Further, if the column you target contains the primary key for the table, the resulting list includes
not only the contents of that column for the retrieved entity, but the rest of the row as well. This
feature is especially useful for reporting information about items in the list. For example, let’s say
you want a list of channels that belongs to an account. Therefore, the target of your query would
be the Channel Table’s UID Channel column (CHANNEL.UIDCHANNEL). For each channel
that met your search criteria, the resulting list would contain not only the channel’s unique
identifier (UID), but also its recorder-ID and channel number—because a channel record (row) in
the Channel Table consists of UUDCHANNEL, UIDRECORDER, and CHANNELNUM.

If you target a column that contains non-unique values, such as a UOMCODE in the Channel
History Table, the program returns a list of values that met your search criteria, with duplicates
removed.

Table.Column Lists and Rate Forms

To understand the value of Table.Column lists and queries, it’s helpful to explore the application
for which they were created—their use in rate forms.

You can use Table.Column lists with the “For Each x in List” Statement, and the
INTDLOADLIST and MVLOADLIST functions.
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Let’s look at the “For Each x in List” Statement. The purpose of this statement type is to apply a
set of Rules Language statements to each and every entity in the database that matches a set of
user-defined criteria. In other words, when you use an analysis or billing program to apply the rate
form, the Rules Language statements nested in the “For Each x in List” Statement are repeated for
each item in the list created by your query.

The format of this statement is:

FOR EACH <identifier> in LIST <list-name>
<nested-statements>

END FOR;

Where:

*  list-name is the name of a table.column query that you or another user have previously created
and saved. This query defines the target table.column, and the set of conditions that the
database entity must meet in order for it to be included in your list. (The next section in this
chapter, “Creating a List of Items in the Data Repository Using a Table.Column Query,”
provides step-by-step instructions for creating these queries.)

*  identifier is a temporary name you supply in the statement. When the billing or analysis
program runs the rate form, it assigns this identifier to the first item in the list and applies the
nested-statements to it. When that is done, it assigns this identifier to the second item in the
list and applies the nested-statements to it, and so on until all items in the list have been
processed.

*  nested statements are the actions you wish to occur for each item in the list.

Below is an example query and related portion of a sample rate form that might be used with
Oracle Utilities Billing Component. The purpose of this query and rate form is to include a list of
the recorder-IDs, channel-numbers that belong to the account being billed in the bill report.

Query Name: LIST_CHAN  (could be anything)
Target Table.Column: CHANNEL.UIDCHANNEL
Query: ACCOUNT.ACOUNTID = ACCOUNT_ID
Rate Form Statements:

ACCOUNT_ID=ACCOUNT.ACCOUNTID
FOR EACH CHAN in LIST “LIST CHAN”
RC = ““ 4+ CHAN.RECORDERID + ”,”CHAN.CHANNELNUM
REPORT RC LABEL “Account Recorder, Channel”;
END FOR;

When Oracle Utilities Billing Component applies this Rules Language statement, it first runs the
query—that is, it compares each ID in the Account Table with the ACCOUNTID it is billing;
When the program finds it, it retrieves all UIDCHANNEL records in the CHANNEL Table that
belong to the Account ID and puts them in the list named LIST_CHAN. When the list is
complete, the program assigns the temporary identifier CHAN to the first Channel UID in the
list, and applies the nested statements to it. In this example, the nested statements simply report
the recorder-ID and channel-numbers that belong to the channel. (Remember from the discussion
on the previous page, values for RECORDERID and CHANNELNUM were also returned in the
list, because the target column UIDCHANNEL was a primary key for the table.) The nested
statements are repeated for each UUDCHANNEL that belongs to the account.

The table below shows how the program applies the Table.Column query in Example 1 to
generate a list.
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Account Table (contains values used in search criteria)

UIDACCOUNT UIDCUSTOMER ACCOUNTID STARTTIME POSTWINDOW
097609 975721 10030 12/01/1995 3
097610 975722 10031 12/01/1995 3
097611 975723 10032 12/01/1995 3
097612 975724 10033 12/01/1995 3

The query asks the program to find the account being billed:
ACCOUNT.ACCOUNTID= ACCOUNT_ID. In this example, let’s say it’s the account ID 10031.
This corresponds to UIDACCOUNT 097610.

Channel History Table (relates Account Table to Channel Table)

UIDCHANNEL STARTTIM UIDACCOUNT STOPTIME METEROFFSET
134678 12/01/1995 097609 null 3
134679 12/01/1995 097610 null 3
162456 12/01/1995 097610 null 3
268648 12/01/1995 097611 null 3

The Channel History Table relates the Account Table (the one containing the search values) to the
Channel Table (the “target table” containing the data you want for your list). In this case,
UIDACCOUNT 097610 is associated to UIDCHANNEL 134679 and UIDCHANNEL 162456.
These are the records in the Channel Table.

Channel Table (Target Table)

UIDCHANNEL UIDRECORDER CHANNELNUM
134678 8076888 1
134679 1111101 1
162456 1111101 2
268648 8999876 1

Note: The Account and Channel History tables both contain more columns
than are shown in the illustration.
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Creating a List of Items in the Data Repository Using a Table.Column Query

The first part of this section explains how to target a table and column—that is, specify the table
and column you want to take data from. The next set of instructions explains how to create a
query that specifies your search conditions.

How to target a table and column:
1. Select File->Lists->Table-Column.
The Table-Column List dialog box appears.
2. Sclect the target table from the Target Table drop-down menu.

Each table is denoted by two names in the drop-down menu (e.g., ACCOUNT/Accounts).
The first is the “real” name—the name that the system recognizes the table by. The second is
the “visible” name that appears in the Query screen.

3. Select the target column from the Target Column drop-down menu.

If the target column stores the unique key for the table, the list will contain all values in each
row (record) that meets your criteria. The unique keys are identified in the display by the
prefix UID. In addition, if the table has just one primary key, you can use that column as the
target to retrieve the row. If the column stores non-unique values, the list will contain just the
values that met your search conditions, with duplicates removed. Other tables require
multiple columns to identify the rows. See Appendix A for information about primary keys.

Note: LONG, BLOB, CLOB, and XML columns cannot be selected as the target column for
table.column queries.

4. 'Type a Name for your query.

This is the name you will use in the rate form to call the list. The name can have up to 40
characters.

Do not use spaces in the name. Underscores are acceptable. For example, LIST_CHAN is
acceptable for use in rate forms, LIST CHAN is not. Also, if you use the percent sign (%) in
the list name, the list name must appear as a string (inside double quotes) when referenced in
a rate form. See the ‘For Each X in List’ Statement in the Oracle Utilities Rules Langnage User’s

Guide for more information.

5. Type an optional Description for your list.
The description can consist of up to 40 characters, including spaces.
6. Click the Query button. The Query to Create a List dialog box appeats.

The List Query dialog box gives you a convenient and structured way to describe the
customers or accounts that you want to retrieve from the database.

Queries are constructed in this order: “table.column, relationship, value.” You can construct
queries with multiple conditions by chaining together any number of clauses using either of
the two conjunctions (logical AND or OR).

Example of a typical query:
First Clause Conjunction  Second Clause
Accounts.ID > 10000 AND RateCodes.Code = 5

If you are creating a list of account IDs, this query retrieves all accounts whose ID is greater
than 10000 and whose rate code is 5.

See Constructing Queries on page 8-16 for more information.
7. When you have finished constructing your query, click OK
The Table-Column List dialog appears.
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If the query included a rate form identifier as the qualifier on the right side of a query clause,
the program can’t perform the search now, so it displays a reminder, “List contains Rules
Language Identifiers, access via Rate Form.” If on the other hand the query did not include
rate identifiers, the program runs the query and displays how many items it found.

You have several options now:
Display: Click Display to view the list that resulted from your query (if not displayed).
Save: Saves your query so that it is available for use in rate forms.

Query: If you are not satisfied with the query or the list (perhaps the number of items found
was much larger or smaller than expected), you can edit your query. See Editing an Existing
Table.Column Query on page 8-14 for more information.

Delete: Deletes the list if saved.

Cancel: Closes the window. Be sure to save your query and list first, otherwise all your
work will be lost.

Change Target Column: Changes the target column of the list. See Changing the Target
Column on page 8-13 for more information.

Import: Imports a previously-created query. See Importing a Table-Column List on page
8-14 for more information.

Export: Saves the quety to a file so that you can archive it and/or share it with other users.
See Exporting a Table-Column List on page 8-14 for more information.

Changing the Target Column

You can change target column of a table-column list.

Note: Lists that have been locked (the Editable column on the List table is set to “No”). cannot
be changed in any way.

How to change the target column for a table-column list:

1.

N w kb

At the Data Manager desktop, choose File->Lists->Table-Column. The Table-Column List
dialog box appeats.

Select the target table from the Target Table drop-down list.

Select the target column from the Target Column drop-down list.

In the Name combo box, select the desired list.

Click Change Target Column. The Change Target Column List dialog box opens.
Select the new target column for the list from the Change Target Column drop-down list.
Select the appropriate Save Option:

*  Replace Table-Column List: Replaces the existing list based on the new target column.

*  Save Table-Column List as: Saves the table-column list as a new list. If you select this
option, enter the name for the new list.

Click Save to save the list.
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Importing a Table-Column List

You can import a previously created Table-Column list into the Oracle Ultilities Data Repository.
The file must be a Query file (*.qry) that was created using Data Manager.

How to import a Table-Column list:

1.
2.
3.

At the Data Manager desktop, choose File->Lists->Table-Column.
Click the Import button. The File Import List dialog box appears.
Select the desired list, and click Open.

The list appears in the Table-Column List dialog box. You can edit the name and
description, or apply any of the other features of the dialog box. For example, you can click
Query and edit or rerun the query as desired.

Click the Save button to save your list.

Exporting a Table-Column List

When you have created a Table-Column list, you can save it to a file for sharing with other Oracle
Utilities users.

How to export a Table-Column list:

1.

2
3
4.
5
6
7

At the Data Manager desktop, choose File->Lists->Table-Column.
Select the target table from the Target Table drop-down list.
Select the target column from the Target Column drop-down list.
In the Name drop-down list, select the desired list.

Click Export. The File Export List dialog box appears.

In the File name field, supply a file name.

Specify a list type in the Save as type drop-down box. Thete are two types from which to
choose:

*  Query Files (*.qry). This saves only the query itself. This is the default file type for
exported queties.

*  Values Files (*.val) This saves the list of values based on the query.

*  Values in XML Files (*.xml) This saves the list of values in an XML file based on the
quety.

Click Save to save the query to the specified file.

Editing an Existing Table.Column Query

This feature enables you to view and, if desired, revise an existing Table.Column query.

Note: Lists that been locked (the Editable column on the List table is set to “No”). cannot be
changed in any way.

How to edit an existing Table.Column Query:

1.
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Select File->Lists->Table-Column.
The Table-Column List dialog box appears.
Select the Target Table and Target Column for which the query was created.

Click on the down arrow to the right of the Name field, and select a list from the drop-down
menu that appears. This menu contains only the queries that have been previously created for
the target table and column you specified in Step 2.
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Click the Query button.
Modify the query conditions:

*  To revise an existing clause, highlight it in the Query display box. Then, modify it as
desired.

*  To delete a clause that follows a conjunction, highlight both it and the conjunction that
precedes it, and click Remove.

*  To delete the entire query and start over, click Clear.
When you are satisfied with your query, click OK.

The Table-Column List dialog appears, with information about the results. If you are
satisfied with the results, click Save.
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Constructing Queries

The following instructions take you step-by-step through the process of constructing a query

using the Query to Create a List dialog, Essentially, you will specify the conditions a customer or

account or record must meet for it to be included in your list.

Query clauses compare a record’s value in a specified column in a specified database table to a

value that you supply. Therefore, your first step in constructing a query clause is to identify the

table and column that contains the information you want to use for the search conditions.

1.
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Click on the Browse button in the Query Clause box.
A database tree similar to the Browser tree appears
Click on the table icon for the desired table.

The table you want may be one or more levels deep, so you may have to expand the tree by
clicking on the plus signs. For example, the Rate Codes table is listed below the Rate Code
History Table.

Click on the desired column icon, and click OK.
The first part of your query appears in the Query Display box.
Select the desired Relationship.

Relationships are used to define how the program will compare values in the database to the
value or item you specify in the next step. The choices are:

= Equalto IN

< = Less than or Equal LIKE

> = Greater than or Equal NOT LIKE

< Less than ISNULL OR >=
> Greater than IS NOT NULL
<> Not equal IS NULL

The first six options are straightforward — they are used to set conditions of equality or
inequality. The others give you additional flexibility for expressing your search criteria.

* IN allows you to provide a /st of values for the criteria. The account's value need match
only one item in the list to be selected. For example, if you wanted to find all accounts
with rate code 461, 462, or 463, your query might be:

¢ Rate codes.code IN '461', '462', '463'

*  LIKE enables you to search for text strings that satisfy a partial match. You can use the
“percent” (%) sign or underscore (_) as wildcards to indicate that any characters are
acceptable in their place. The ‘%’ matches any series of characters, the °_” matches any
single character. LIKE and the wildcards are useful if you want to broaden your search,
or if you’re not sure how a database entry might have been spelled. Here are some
examples:

* Accounts.ID LIKE A% would find all accounts whose ID begins with the
letter A.

e Accounts.ID LIKE%A% would find all accounts whose ID contains the letter
A, anywhere in the ID.

* Rate Codes.Code LIKE _ab  would find all accounts with rate codes
that have AB in the second and third character position, such as yab01, xab02, and
SO on.
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*  NOT LIKE retrieves all database entries that do not satisfy a partial match. For example
Rate Codes.Code NOT LIKE$%AS% would find all accounts with rate codes that do
not contain an A (a code with an A anywhere in it would be rejected).

e IS NULL OR >= creates two comparisons in the query and means the column can be
NULL or, if not NULL, must be greater than or equal to the selected value. This speeds
up performance when compared to these two as separate clauses.

* IS NOT NULL enables you to find all accounts that have any value in a given column,
other than null.

* IS NULL enables you to find all accounts that have a NULL value in a given column.
Remember, NULL is not zero, but rather the intentional absence of any value.

5. Select either Value or Identifier, o7 select a table.column for the comparison.

Supply a value or identifier if you want to compare database values with a constant (the
supplied value) or the value of an Rules Language identifier. Specify a table and column if
you want to compare an item in one customer or account record to another. For example, you
could ask Data Manager to find every customer whose Account ID matches (is equal to) its
Customer ID.

Here are some important points to keep in mind if you are supplying a value:

*  Data Manager is case-sensitive: For Data Manager to retrieve an entry in the database,
the value in your query statement must match the database entry exactly. Pay particular
attention to case when dealing with character data. If you specify 104 but the database
entry was R04, Data Manager will not consider this a match. You can avoid this problem
by consistently using upper-case letters when inputting data to the database and when
specifying a query value.

*  If you are using the IN relation, type all desired values in the Value field, making sure to
separate them with a comma, or with a comma and a space. If the members of the list are
strings, you must enclose each one in single quotes. For example:

¢ Rate codes.code IN '461', '462', '463'

You can tell if the database value is a string by looking at Appendix A. Columns with
datatype “varchar” are strings. You only have to supply the single quotes in the Value
field when you are using the IN predicate. In all other cases, Data Manager automatically
supplies them for you.

*  If you wish to use cither of the wildcards ‘%’ or °_’ in the value, you must use the LIKE
predicate, as explained on the previous page.

If a percent sign or an underscore is part of the text string you are searching fot, you
must use the ESCAPE command within the query. To use this command use the
following guidelines:

*  Insert an extra special character immediately preceding the percent sign or
underscore, such as \’, ‘#’, etc.

*  Add “ESCAPE ‘<special_character>"" immediately following the query expression.

For example, to search for Account IDs that begin with ‘ACCT_,” you could use the
following query:

‘ACCT# %’ ESCAPE ‘#'

*  Decimal numbers use a decimal point as the decimal separator regardless of Regional
Settings. Also, numbers should not have thousands separators.

6.  When you are satisfied with the clause as it appears in the Query Display box, you have two
options:
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*  Ifyou want to add additional clauses: click the desired conjunction button (AND or OR)
and go to Step 7.

*  If you have finished constructing the query: Go to Step 9.

If you are constructing a query with multiple conditions, select one of the conjunctions
(AND or OR). (This step is optional; if you are using a single condition, skip to Step 9.)

The conjunction appears on a new line in the Query Display box. Then input the next
“table.column, relation, value/item” clause in the same way you entered the first one (steps 1
through 5).

The lines that appear in the Query Display box can be manipulated with the Cut, Copy, and
Paste functions. Select a line (or group of lines), then click X for Cut, C for Copy, or V for
Paste. Cut or copied lines are stored on the Windows Clipboard, and are available to other
applications.

When you use AND, only database entries that meet both conditions are selected. When you
use OR, every entry that satisfies either or both of the conditions is selected.

Note: Queries that incorporate OR can require lengthy processing time. This is an issue with
relational databases in general, not Data Manager in particular.

To put parentheses around clauses to create complex logical expressions: Highlight all
lines in the Query Display box that you want to include within the parentheses, and click the
Group button.

The grouped clauses are surrounded with parentheses.

You cannot begin or end a group with a conjunction, and that the first and last lines in a
group must be query clauses. To remove parentheses, highlight all the grouped lines and click
Ungroup. To clear the entire query and start over, click Clear. To remove a clause that
follows a conjunction, highlight it and the conjunction and click Del.

Specify the order of the list and if the list should include only distinct records.

Distinct Records: The default for all lists is to select distinct records. That is, lists return
only one value if there are duplicates. If you want all results returned, uncheck the Distinct
check box. However, be aware that if this is off and there is a join, you may get multiple
results even if each value is only in one record. This option does not affect the DISTINCT
parameter of the LISTOP function.

Ordering: The default ordering for lists is to order by the target column, in ascending order.
The default for Account, Customer, Substation and Transformer lists is their ID column (the
first two) or Name column (the last two). You can change the ordering by clicking the Order
by Column button. This opens the Order by Columns dialog.

To select a column for sorting, select the column in the Table Columns list, and click the
Add button. The selected column will appear in the Selected Columns list. To remove a
selected column, select the column in the Selected Columns list, and click the Remove
button. The selected column will no longer appear on the Selected Columns list.

To order the columns in a particular sequence for sorting, select the columns in the desired
order. For example, to sort by Account ID followed by Start Time, you would select the
Account ID column first, followed by the Start Time column. To sort by Start Time followed
by Account ID, select the columns in the reverse order (Start Time followed by Account ID).

Note that if the selected column's value is NULL in a record, the ordering is undefined. Some
databases put NULLSs first, some put them last.

By default results are sorted in ascending order. To switch to descending order, uncheck the
Ascending check box.

If you do not want the results ordered, check the No Order By checkbox.
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9. When you are satisfied with your query as it appears in the Query Display box and you want
to initiate the search, click OK.

About precedence and grouping
Your query can have any number of conditions. However, if you use both AND and OR in a
statement, Data Manager automatically evaluates all conditions connected by AND before the
conditions connected by OR. Consider the following query:

Rate Codes.Code = R100
AND

Billing Cycles.Code = 2
OR

Billing Cycles.Code

3

This query selects every account who satisfies at least one of these conditions:
Its rate code is R100 AND it is on billing cycle 2, OR it is on billing cycle 3.

This may not be what you want. If not, you can change how the expressions are evaluated by
grouping clauses with parentheses. Clauses within the parentheses are evaluated before those
outside. For example:

Rate Codes.Code = R100
AND

(

Billing Cycles.Code = 2
OR

Billing Cycles.Code

3

Now, the query selects every account who satisfies bo#h of these conditions:

Its rate code is R100 AND it is on billing cycle 2 or billing cycle 3.
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Importing and Exporting Lists in Batch Mode

In addition to setting up and creating lists, you can move lists from an older database to a newer
one. This is done using the LSTIMEXPEXE command line program.

LSTIMEXP Command Syntax

LSTIMEXP uses the following syntax. Parameter switches are case insensitive; you can enter them
in either upper or lower case (-c or -C). If a parameter includes a space, you must enclose it in
quotes (for example, -f “11/01/1999 12:00:00”). In actual use, the command must be entered on
one line. Also, you must either change to the directory in which the program is stored (typically,
\LODESTAR\bin) before entering the command, or specify the path in the command. To view a
list of all parameters on-screen, type Istimexp -? at the command prompt.

Istimexp [-c connectstring |-q qualifier|] -ffile configfilename [-1cfg logging configuration filename|

Parameter Description

-c connectstring is database connection information for the Oracle Utilities Data
Repository. This parameter is required and must be in one of the following
formats:

For Oracle databases:

"Data Source=<data_source>;User
ID=<user_id>;Password=<password>;LSProvider=ODP;"

For Microsoft SQL databases:

"Data Source=<address>;Initial Catalog=<SQL_database>;User
Id=<user_id>;Password=<password>;MultipleActiveResultSets=True;LSP
rovider=MSSQL;"

where:

e <data_source> is the Oracle TNS Name for the data source, from the
TNS_NAMES.ora file (typically located in the
\\<machine>\oracle\network\admin directory)

e <user_id> is the user ID for the database connection
e <password> is the password for the supplied user ID.

*  <address> is the IP address or Hostname of the MS SQL Server
database server

*  <SQL_database> is the name of the MS SQL Server database

-q qualifier is an optional database qualifier. The default is PWRLINE.
-f configfilename is the name of the configuration file that defines the working

environment of the Oracle Ultilities software (e.g,, directs the software where
to find and place the application data files and so on). If you do not supply a
value for configfilename, the system uses the default (LODESTAR.CFG). For
information about the contents of this configuration file, see the Oracle
Utilities Energy Information Platform Configuration Guide.

-lefg logging configuration filename Name of an optional logging configuration file
that specifies where error and log messages are sent. If you omit this
parameter, the application creates a log file named LSTIMEXPLOG in the
LOG directory.
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The parameters explained above are only those that apply to a/ LSTIMEXP modes. Additional
modes are explained on the following pages.

Import Mode
These parameters are specific to Import Mode only:
Parameter Description
-1 List file name. The list name does not include the .Ist extension. Add
quotes(“ ”) around parameter if the list name contains spaces.

This argument may be repeated.

Export Mode
These parameters are specific to Export Mode only
Parameter Description
-Xname Export this list. The exported file name will equal the list name. Special

characters (commas, semi-colons, slashes, etc.) will be replaced with an
underscore (‘).

This argument may be repeated.

-wpath Write (export) files to this directory.
Dump Mode
Dump Mode overrides all other modes.
Parameter Description
-dump Export all lists. They are put in the USER directory by default, one list

per file (unless -w used). Each file name is LISTNAME Ist.

-wpath Dump files to this directory. (Note: This directory must exist).

Display Mode

The following parameter is specific to Display Mode only.

Parameter Description
-aname Display results of the specified table-column list. This argument may be
repeated.
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Importing Groups of Lists

The Import Mode of LSTIMEXP is used to import lists one at a time. You can also import groups
of lists. To import all the list files from a specific directory, run the following command from the
DOS command line:

for %1 in (<path>*.lst) do lstimexp -i%1l
(.. is userid, password, and connect string).

Where:

*  <path> indicates the path to the directory where the exported list files (*.Ist files) are stored.

You must run this command from the “C:\LODESTAR\Bin” directory. If not, you must specify
the path to the LSTIMEXP program in the command line. For example, if your rate forms were
stoted in the C:\LODESTAR\LISTS directory, and the LSTIMEXP progtram was in the
C:\LODESTAR\APPS directory, the command line would be:

for %1 in (C:\LODESTAR\LISTS\*.lst) do C:\LODESTAR\APPS\lstimexp -i%1l ...
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Chapter 9

Reporting

This chapter covers the basics of working with Data Manager and the other Oracle Utilities
products to set report options and to create reports and graphs for analysis, including:

*  Report Options

* Viewing and Printing Reports
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Report Options

Report options allow users to customize the contents of a report, including the report
presentation and output, the print detail level, problem determination options, and the appearance
of the Bill Calculation Results section of reports.

Note: Changes to report options as described in this section apply only to the
report currently being run.

Users access the Report Options via tabs at the top of the Report Options dialog, Clicking on
these tabs allows users to navigate between types of report options, including:

*  General Options

*  Print Detail Options

*  Problem Determination Options

*  Bill Calculation Results Columns Options

How to set and save report options:

1. Click the Report Options button in the input dialog box for the report youre creating. The
Report Options dialog appears.

2. Make any appropriate changes on the General, Print Detail, Problem Determination, and
Bill Calculation Results Columns tabs.

Note: Not all report options are available for all reports. If an option is not available, it is
greyed out.

3. Click OK to save the changes. To close the Report Options dialog without saving changes,
click Cancel.

General Options

The General tab allows users to set presentation and output options for a report.

Report Titles
To add optional titles to a report, enter the title in one of the three optional title fields.

Saving Reports to Files
To write the report to a file, check the “Write report directly to File” check box and specify the
path and filename for the file. Use the “Browse” button to locate an existing file. To display the
report also, check the “Also Display Report” checkbox.

Other Options
*  To disable graphing for the report, check the “Disable graphing of data” checkbox.

*  To display only summaries for the report, check the “Display summaries only” checkbox.

*  To keep the teport data for CSV/XML exporting, check the “Keep data” checkbox.
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Print Detail Options

The Print Detail tab allow users to specify the level of detail included in both a bill report and
transaction record. The information computed and available for reporting is determined by the
statements used in the applicable rate form. The Print Detail tab enables you to specify how
much of that available data is included in the reports and transaction records.

Print Detail Options
Default: This option means the program will use the Print Detail setting normally applied to the
account (via the Account, Rate Code, Rate Schedule, or Global options specified). Alternately, you
can override the usual setting for just this job by selecting one of the following:

None: This option displays effective revenue only.

Normal Detail: This option displays effective revenue, plus any charges assigned to a revenue
identifier and any values assigned to a Report Statement in the applicable rate form.

All Detail: This option displays effective revenue, plus revenue identifiers, plus the values
associated with the Rules Language Label and Report statements in the rate form.

The table below details how these options apply to specific components of a report and
transaction record.

Report Component None Normal All

Customer/Account Detail X X X
Input Values X X
LABELed Identifier Values X
Simple Report Values X
Compound Report Values X

Print Detail ltems
To override the Print Detail Options setting for specific components of a bill report and
transaction record, select the specific options for each component in the Print Detail Items
section of the dialog. For each report component type, select one of the following:

*  On - Include the component in the report and transaction record.
*  Off - Exclude the component from the report and transaction record.

*  Print Detail Option - Apply the setting specified under Print Detail Options. The specific
manner in which these settings affect individual report components is detailed in the table
above. For example, if you had selected “None” under Print Detail Options, and selected
Print Detail Option here for Input Values, the input values would not appear in the report.

Following is a brief description of each of the report components.

Customer/Account Detail. Date activated, billing mode, number of days specified for the
eligibility pre- and post-windows.

Input values. This option reports the parameters specified for the bill calculations: bill start and
end date; date that the account's meter was scheduled to be read; rate code applied to the account;
number of days in bill period, and the bill month.

LABELed Identifier Values. This option reports the any identifier values and text strings
specified using a LABEL Statement in the rate form. LABEL statements are typically used to
substitute meaningful labels for bill determinant names or other brief and sometimes-cryptic
identifiers (e.g., LABEL LF “LOAD FACTOR?” displays LOAD FACTOR and its value in the
report). They are often used for column headings or report subtitles.
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Note: If a report component type is designated to appear in a report, and it is
assigned a name using a LABEL Statement, its values will automatically appear
in the report, with the new label. In other words, it is not necessary in that case
to apply the LABELED identifier values option to get the label and value to
appear. For example, the applicable rate form might have the statement
LABEL $EFFECTIVE_REVENUE “Total Charges”. Because Effective
Revenue is automatically included in all report types, “Total Charges” will
appear, no matter what print details options you choose.

Simple report values. This option reports any values that were assigned to an identifier using a
REPORT Statement in the rate form. REPORT statements are typically used to report values of
interest that are calculated and/or drawn from the database, such as peak times.

Compound report values. This option reports any values associated with a stem identifier using
a REPORT Statement in the rate form.

Problem Determination Options

The Problem Determination tab allows users to specify the level of problem determination detail
included in both a bill report and a transaction record.

When problems occur during the processing of a bill, error messages and other information useful
in determining the cause of the problem are created. The Problem Determination tab option
enables you to specify how much of that data is included in the reports and transaction records.

Problem Determination Options

Show All Error Messages: This option reports all error messages that occur while processing
the bill.

Show All Input Options: This option reports all input options used in processing the bill.

Show Bill records to Save (BillHistory, CSS, etc). This option includes the Bill History records
in the Bill Report. 17 is typically only used for testing. 1f you turn this option off, the records are still
output when you approve a bill, but they are not displayed or printed in the bill report.

Show Rate Schedule Used in Bill Calculation: This option includes the rate schedule used in
processing the bill on the bill report.

Bill Calculation Results Columns Options

The Bill Calculation Results Columns tab allows users to specify the labels of the Bill Calculation
Results section of a bill report.

The Bill Calculation Results section displays the number of billing units, the distribution of those

billing units, the charge rate, and revenue for each revenue identifier used in a rate schedule.

Bill Calculation Results Columns Options
*  To change one or more of the Bill Calculation labels, check the Change Bill Calculation
Labels checkbox and edit the labels as appropriate.

* To omit one or more of the columns from the bill report (except the Revenue column), check
the Change Bill Calculation Labels checkbox and delete the appropriate label.

Billing Units Label: The label for the Billing Units column. If blank, the column is omitted.
Distribution Label: The label for the Distribution column. If blank, the column is omitted.
Charge Rate Label: The label for the Charge Rate column. If blank, the column is omitted.

Revenue Label: The label for the Revenue column. This column cannot be omitted. If blank, the
column label is Revenue.
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Viewing and Printing Reports

One of the primary functions of Oracle Utilities applications is to generate reports. Each of the
various analysis modules generate reports, and the programs also generate a number of other
useful reports as well.

Once a report has been generated, it appeats in an open report window on the application
desktop. Once in an open report window, you can view and/or print the report. This section
describes how to view and print reports generated using Oracle Utilities applications.

Viewing and Searching Reports

You can search for a specific word or words (or numbers) in an open report window using the
Find option. The Find option (selected from the Edit Menu) allows you to search for a word or
words in an open report window. When you select this option (or press F3), the Find dialog opens.

Enter the word or words you wish to find and click OK. To find the next instance of the word or
words with the Find dialog still open, click Find Next. To find the previous instance of the word
or words with the Find dialog still open, click Find Previous.

Once you’ve entered a word or words in the Find dialog, you can search by using the Find Next or
Find Previous options from the Edit menu.

*  To search for the next instance of the word or words last entered in the Find dialog, select the
Find Next (or press Shift-F3) option.

*  To find the previous instance of the word or words last entered in the Find dialog, select the
Find Previous (or press Ctrl-F3) option.

Moving to a Specific Line in a Report

You can also jump to a specified line number within an open report window by using the Go to
option. The Go to option (selected from the Edit Menu) allows you to move to a specific line in
an open report window. When you select this option (or press Ctrl-G), the Go To tab on the Find
dialog opens.

Enter the line number in the report that you wish to move to and click OK.

Changing the Appearance of Reports

Printing Reports

You can also change the appearance of the text in an open report window using the Font option
(from the Edit menu). When you select the Font option, the Font dialog opens.

To change the font in the report window, select a new Font, Style, and Size and click OK. The text
in the teport window will display and print the font/style/size selected.

You can also print reports using the Print option (from the File menu). When you select the Print
option, the Print dialog opens.

To print the report, complete the Print dialog as appropriate:

* Ignore page breaks: Check this to ignore the page breaks in the report.

e  Page width in characters: Enter the desired width of the report.

* Display line numbers: Check this to include line numbers on the report.

Once you’ve completed the dialog, click OK. A standard Windows Print dialog will open, allowing
to set any desired print options.
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Creating Graphs

You can also create graphs from data in open report windows.

How to Create a Graph:

1.

5.
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Select the Graph option from the View Menu (available only when an open report window is
displayed), the Create Graph dialog opens.

Select an Account ID you wish to graph from the Select Account ID to Graph box. A list of
available rows to graph will appear in the Select Rows to Graph box.

Select a row to include on the graph and click Add. The selected row will appear in the Pairs
to Graph box. Repeat this step for each Account ID/row pair you wish to include in the
graph.

To remove a pai, select it and click Remove.

Enter an optional title for the graph in the Title box and click OK. The graph will appear in a
window.

E 2: Billing History Graph
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To change the view of the graph, select from the options in the View menu.
*  The Style option allows you to select from bar graph style (as above) or line graph style.

e The Background Color option allows you select the background color for the graph
(White, Gray, Dark Gray, or Black).



Chapter 10

The Data Manager Analysis Menu

This chapter describes the functions available from the Analysis menu. This includes:
*  Trial Calculations

*  The Billing History Report

*  The Special Events Report

*  Default Billing Options
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Trial Calculations

The Trial Calculation module enables you apply any rate form to any account’ historical data over
a user-specified date range. You can view and modify any of the billing determinants or rate form
statements used in the calculations, and quickly rerun the calculation to see the impact of your
changes. Unless otherwise specified in Advanced options, this module does not permit data to be
saved to the Data Repository. This module has several important applications:

*  “debugging” new rate forms before they are used in a production mode.

*  demonstrating to a customer the potential impact of switching to an alternative rate, or of
modifying their usage patterns on the same rate.

*  training new users.
This section explains how to run a trial calculation.
How to Run a Trial Calculation:
1. Select Analysis->Trial [Bill] Calculation.
The Trial Calculation dialog box opens.
2. Select the customer or account for the calculation:

Select By: Select Account or Customer. Account must be selected to run Single Step.
Customer can only be used with the Report option.

Select: Enter the ID of the account/customer you wish to use in your trial bill.
3. Enter the Billing Dates for the calculation by selecting one of the following options:
*  From bill history: Click Select to use a specific Bill History record.

*  Compute: Calculates the bill exactly as the billing engine calculates. This option
supports recalculating existing bills.

*  User specified: This option only applies to accounts whose bills are based on interval
data. Specify the following for any period for which interval data is available for the
account. Note that Bill History values will not be prorated to user-specified dates.

Bill Month: Enter the desired bill month.
Read Date: Enter the desired read date.
Bill From: Enter the start date of the trial bill.
Bill To: Enter the stop date of the trial bill.
4. Select the Billing Rate Schedule for the calculation using one of the following options:

*  Select Rate Schedule: Click this radio button, then the Select Rate Schedule button
if you want to select a rate form from the database. The Select Rate Schedule and
Optional Rate Code dialog box appears. This box gives you access to all current,
historical, and trial rate schedules stored in the Oracle Utilities Data Repository. If you
select this option, skip to step 5.

*  Use Applicable Rate Schedules: Click this radio button if you want to use the rate
form that was in effect for the account during the bill month you specified above. If you
select this option, skip to step 0.

5. Optional. Select the rate schedule to use for the calculation on the Select Rate Schedule and
Optional Rate Code dialog box.

*  Select an operating company, jurisdiction, and rate schedule.

*  Check the desired rate schedule Type (Current/Historical and/or Trial). A list of all
of the versions of the rate schedule that meet your criteria appears in the Rate Form
Version selection box.
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Highlight one rate form version in the Rate Form Version selection box. The language
script for that rate form appears in the box below, so that you can determine whether or
not it’s the desired version.

Select Rate Code: The program requires a rate code to determine how to price out the
billing determinants.

You can select a rate code from the From Rate Schedule Rate Code list. If you do not
select a rate code, the program will use the customer’s current rate code to determine the
correct pricing.

Click OK. You are back at the Trial Bill Calculation dialog box. Notice that the
selected rate schedule version appears under Billing Rate Schedule.

Optional. Click Options.

The Default Options dialog box opens. See Default Options in Chapter Two for more
information about setting Default Options.

Set the options as appropriate, and click OK.

Optional. Click Advanced.

The Advanced Trial Bill Calculation Options dialog box opens.

Set the options as desired then click OK to close this dialog.

INTDLOAD...ENERGY loads all energy used: This options loads energy from cuts
that extend past the bill stop date and time. The default is to only load energy used
within the bill period.

Save Options: This option allows you to specify if and how results are saved to the
database. There are four options available:

* Do not enable saves of any kind: With this option selected, Rules Language
SAVEs do not save and no CIS transactions record are written to the CIS file. This
is the option you’ll choose most often when testing rate forms and when using Trial
Bill.

*  Enable user approve/reject of saves: When this option is selected, you can either
Approve or Reject each set of results. If you approve an account (or an account and
all its related accounts), the bill will be rerun with Automatic Approval. This second
run will generate the same results, and will create database and CIS records.

*  Automatically save/approve each page if it is OK: If you select this option,
then data from each non-error page of an account is automatically written,
regardless of the errors in other pages of the account or other related accounts.

Use cut dates nearest the supplied dates: If the account uses interval data and you
want to use the best cut dates, check this option. Otherwise, to subset the interval data
based on the supplied dates, uncheck this option.

Do not Display Graph for Interval Data: If this checkbox is checked, the lower graph
window does not open. The default for this option is unchecked.

Do not use current Bill History determinant values: If the account uses interval
data, has already been billed, and you want to check the computation without using the
saved bill determinants, check this option. Otherwise the current Bill History values will
be used, and the NOVALUE statements may not execute.

Do not use Account/Customer selection: This option runs the calculation in the
same manner as the RUNRS.EXE program (see the Oracle Utilities Energy Information
Platform Installation and Configuration Guide). When Report or Single Step is pressed (see
below) the Account/Customer selection will be ignored and the rate schedule will be run
just as if it was run from RUNRS.
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Choose one of the following options to view the calculations:

*  Report: Displays the results of the calculations in a report window. Go to the section
How to View the Bill Calculation Report on the next page.

* Single Step: Lets you execute one rate form statement at a time. See How to run the
Single Step Analysis, later in this chapter.

How to View the Bill Calculation Report

1.

3.

On the Trial Calculation dialog, click the Report button.

A progress indicator displays until the calculations are complete. Then, the Bill Calculation
Report appears in a window.

Review the report to make sure that the data processed as expected.

If you want to override your default report options for this teport, output the bill report to a
file, or add titles to the report, click Report Options. The Report Options dialog opens.

To close the report, select File-»Close.

How to run the Single Step Analysis
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The Single Step Analysis feature lets you execute one rate form statement at a time so that
you can see the changes to identifier values.

On the Trial Calculation dialog, click the Single Step button.
The windows for the Single Step module appear.

The module consists of two (or three) windows. The top left window displays the statements
that make up the rate form. The next statement to be executed is highlighted (comments are
skipped). The top right window displays the identifiers in the rate form and their values. The
lower window is a graphical display of the interval data. This window appears only when an
interval data identifier is highlighted in the top right window.

You can use the Find, Find Next, Find Previous, and Go to options from the Edit menu to
search in either the top left or top right windows. To do so, select the starting point for the
search in the appropriate window, and select the desired options from the Edit menu.

When the rate form is first displayed, the first executable statement is highlighted. To execute
the statement, select Single-Step->Step, or press F8. You can execute each statement this
way.

If you want to execute a portion of the rate form up to a particular statement, highlight the
target statement and select Single-Step-»Run to Selection, or press F4. This allows you to
avoid having to single-step through every statement prior to the one of interest.

To run all statements to completion, select Single-Step->Run or press F5. Note that when
running a rate form, processing stops at each breakpoint encountered. To stop executing the
rate form, select Single-Step->Stop or press F12.

To restart executing the rate form, select Single-Step-»Restart or press F10. Note that all
warning and informational messages set before restarting will be cleared. Also, any values for
identifiers calculated before restarting will be cleared.

After you have run the statements, you can view the resulting bill report by selecting Single-
Step->Display Report, or pressing F6.

The bill report appears (it has the same format as other bill reports in the system). You can
export or print the report using options from the File menu. You can also search for selected
text or copy all or a selected portion to the clipboard using options from the Edit menu.

To close the report, select File-»Close.
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Single Step Module Advanced Options

The Single Step module also provides advanced options when executing rate forms. These include
Changing Identifiers Values, Setting Breakpoints, and Selecting Identifiers to Display.

Changing Identifier Values: To change the value of an identifier before you generate the bill
report, double-click on the identifier in the right window. The Customer Bill Modification -
Edit Id dialog box opens with the current value in an edit box. Change the value as appropriate,
and click OK to save the value in the executing rate schedule.

Note: You must enter the same value type - Integer, Float, etc. - as the current
value. If the identifier is an interval data handle, the value displayed contains its
total, maximum, pulse multiplier, and pulse offset. This value is not modifiable.

Setting Breakpoints: You can specify points within the rate form at which you want execution of
the rate to stop or break. These are called breakpoints. To set breakpoints within the rate form,
select the line at which you wish the execution to break and select Single-Step->Insert/Remove
Breakpoint or press F9. This inserts a breakpoint (“=>"") at the selected line. When the rate form
is executed, processing stops at each breakpoint. To remove a breakpoint, select a line that
contains a breakpoint and select Single-Step->Insert/Remove Breakpoint or press F9.
Breakpoints inserted into a rate form are stored in the Oracle Ultilities Data Repository until
specifically cleared.

You can also create “conditional” breakpoints. These are breakpoints related to a specific
identifier in the rate form which can be set to stop processing when the value of a specified
identifier changes or when the value equals a user-specified value. To set a conditional breakpoint
for an identifier, double-click the identifier and click Breakpoint on the Customer Bill
Modification - Edit Id dialog. The Customer Bill Modification - Breakpoint dialog opens.

This dialog allows you to set the conditions for the breakpoint in one of two ways:

*  To specify that rate form execution breaks when the value of the identifier changes, select
“Break when value changes” in the Breakpoint box on the dialog and click OK.

*  To specify that rate form execution breaks when the identifier reaches a specified value, select
select “Break when value equals” in the Breakpoint box on the dialog, select the type of the
identifier from the Type drop-down list, enter the specified value in the Value field, and
click OK.

Selecting Identifiers to Display: Normally the top right window displays all identifiers used in
the rate form, but in some cases it may be preferable to view only selected identifiers, as this can
help users more easily track the values of specific identifiers while the rate form executes. To select
an identifier for display in the top right window, double-click the identifier, check the Add
identifier to Selected list checkbox on the Customer Bill Modification - Edit Id dialog, and
click OK. The identifier will appear in the top right window when the user selects the Show
Selected Identifiers option from the Single-Step menu.

The Data Manager Analysis Menu 10-5



Trial Calculations

Graphing Options
The Trial Calculation Single Step Analysis graphing tool provides the following features:

Zoom View: The Zoom View allows users to zoom in on the graph by dragging the mouse over a
portion of the graph. To return it to it’s original size, select the Undo Zoom option on the
Graphing Options menu (see below).

Graphing Options: The Graphing Options menu provides access to several other graphing
options.

To open the Graphing Options menu, right-click on the graph. This menu provides the following
options:

*  Viewing Style opens a menu of options that change the appearance of the graph. Using
these options you can make the graph color or monochrome. You can also select Bitmap/
Gradient to add a predefined style to the graph. A variety of predefined styles are listed under
the Bitmap/Gradient item on the menu.

*  Border Style opens a menu of options that change the borders of the graph. Using these
options you can add or remove a bordet, line, shadow, or inset.

*  Font Style opens a menu of options for the size of the graph’s font.
*  Show Legend allows you to turn off and on the graph’s legend.

*  Numeric Precision opens a menu of options that allow you to change the number of
decimal points displayed in the graph’s data. Using these options you can display the data with
0 to 3 decimal places.

*  Plotting Method opens a menu of options that allow you to change the appearance of the
graph’s data. Using these options you can display the data as points, a line, bars, sticks, or
spline. You can also display the data as points combined with other options, for example, a
line with points.

*  Data Shadows opens a menu of options that affect the shadow of the data. You can add or
remove a shadow or 3D effect.

*  Grid Options opens a menu of options that alter the display of the X axis and Y axis. Using
these options you can place the grid in front of the graph, extend the Y axis tick marks,
display or hide grid lines, and change the style of the lines.

* Include Data Labels hides or displays the data labels.
*  Mark Data Points hides or displays the data points.

*  Undo Zoom returns the graph to its original size after you have zoomed in by dragging the
mouse over a portion of the graph.

*  Maximize displays the graph at full screen size. To return it to it’s original size, either press
the Esc key, or click in the blue bar at the top of the graph.

*  Customization Dialog opens the Customization dialog box.
*  Export Dialog opens the Export Dialog box.

Customization Dialog: To open the Customization Dialog box, right-click on the graph and
select Customization Dialog. The Customization Dialog box can be used to change the settings
of the graph and to export or maximize the graph. Many of the options in this box are also
available in the menu that appears when you right-click on the graph. The dialog box contains the
following tabs:

General Tab: On the General tab you can change the following settings for the graph:
*  Main Title is a text box in which you can add or edit the graph’s title.

*  Sub Title is a text box in which you can add or edit the graph’s subtitle.
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*  Border Style allows you to change the border style of the graph.
* Viewing Style allows you to change the viewing style for the graph.
*  Font Size allows you to change the size of the graph’s fonts.

*  Numeric Precision allows you to choose from 0 to 3 decimal places for the graph’s
data.

*  Grid Lines allows you to change the display settings of the graph’s grid lines.

To apply your changes select Apply. To close the dialog box without applying your change
select Cancel. To apply your changes and close the dialog box select OK. You can also select
Maximize to make the graph full screen size. (To return the graph to it’s original size press
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Plot Tab: On the Plot tab you can change the following settings for the graph:
* Axes
*  Plot Style allows you to choose the style of plot points for the graph.

*  Comparison Plot Style allows you to choose the style of plot points for the comparison
graph.
* 3D allows you to choose the 3D effects for the plot style

*  Mark Data Points allows you to mark or unmark the data points.

To apply your changes select Apply. To close the dialog box without applying your change
select Cancel. To apply your changes and close the dialog box select OK. You can also select
Maximize to make the graph full screen size. (To return the graph to it’s original size press
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Subsets Tab: On the Subsets tab you can change the following settings for the graph:
*  Subsets to Graph allows you to scroll through subsets of the graph.

If more than one interval data cut is graphed, you can select the cuts individually and make
different changes to each. The data cuts are listed in the text field on the tab.

To apply your changes select Apply. To close the dialog box without applying your change
select Cancel. To apply your changes and close the dialog box select OK. You can also select
Maximize to make the graph full screen size. (To return the graph to it’s original size press
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Axis Tab: On the Axis tab you can change the following settings for the X Axis and Y Axis:
* Linear or Log allows you to set the graph’s tick marks in either linear or log values.

*  Maximum and Minimum allows you to change the minimum and/or maximum values
for the axes.

To apply your changes select Apply. To close the dialog box without applying your change
select Cancel. To apply your changes and close the dialog box select OK. You can also select
Maximize to make the graph full screen size. (To return the graph to it’s original size press
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Font Tab: On the Font tab you can change the following settings for the graph’s fonts:

*  Main Title allows you to choose the font for the graph’s main title. You can also choose
to make the title bold, italic, and/or underlined.

*  Sub-Title allows you to choose the font for the graph’s main sub-title. You can also
choose to make the subtitle bold, italic, and/or underlined.

*  Subset / Point / Axis Labels allows you to choose the font for the graph’s subsets,
points and axis labels. You can also choose to make those items bold, italic, and/or
undetlined.
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To apply your changes select Apply. To close the dialog box without applying your change
select Cancel. To apply your changes and close the dialog box select OK. You can also select
Maximize to make the graph full screen size. (To return the graph to it’s original size press
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Color Tab: On the Color tab you can change the colors of the following parts of the graph:
*  Desk Foreground

*  Desk Background

*  Shadow Color

*  Graph Foreground

*  Graph Background

*  Table Foreground

*  Table Background

You can also add a bitmap image ot a gradient to the graph by selecting Bitmap/Gradient
Styles in the QuickStyles area of the tab. This area also lists an assortment of predefined
bitmap and gradient styles that can be applied to the graph.

To apply your changes select Apply. To close the dialog box without applying your change
select Cancel. To apply your changes and close the dialog box select OK. You can also select
Maximize to make the graph full screen size. (To return the graph to it’s original size press
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Style Tab: On the Style tab you can change the following settings for the graph’s lines:
*  Color allows you to select a color for the graph’s lines.

*  Point Type allows you to select a style for the graphs points.

*  Line Type allows you to choose the type of line for the graph.

If more than one interval data cut is graphed, you can select the cuts individually and make
different changes to each. The data cuts are listed in the text field on the Style tab.

To apply your changes select Apply. To close the dialog box without applying your change
select Cancel. To apply your changes and close the dialog box select OK. You can also select
Maximize to make the graph full screen size. (To return the graph to it’s original size press
the Esc key, or click in the top bar). Selecting Export will open the Export Dialog Box.

Export Dialog: To open the Export Dialog box, right-click on the graph and select Export
Dialog.

To Export a graph, use the following procedure:

1.
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In the Export area of the box, choose the type of file you would like to export. You can
choose from EMFE, WME, BMP, JPG, PNG or Text/Data.

In the Export Destination are of the box, select the destination of the exported file. You can
choose from ClipBoard, File or Printer.

In the Export Size area of the box, choose the unit of measurement of the file, and then set
the size. You can choose from Millimeters, Inches, or Points. BMP, JPG and PNG files will
default to Pixels. You can set the width and length of the file. You can also set the DPI for the
file. Select Large Font if you want the file to have a larger font.

Select Export to export the file, or Cancel to close the dialog box.



The Billing History Report

The Billing History Report

The Billing History Report is useful for examining and comparing bill determinant values and

other billing information for one or more accounts over a uset-specified number of bill petiods.

This report also allows you to produce a summary report which totals the data for all accounts.

How to create a Billing History Report:

1.

10.

11.

Select Analysis->Billing History.

The Billing History Report Input dialog box opens.

Select either Account or Customer in the Select By box.

Select the accounts or customers of interest using one of the following options:
* ID: Type the ID of the account or customer for the report.

*  List: Select a list for the report. For example, you might have a list of the accounts that
you are responsible for. If the contents of the list may have changed since the last time
that the query associated with it was run, check the box for Refresh list before using.
This option updates the list for this job and saves the new version of the list to the
database, replacing the old one.

*  File: Select a file containing a list of customet/account IDs (*IDS), a list file (*.Ist), an
account query file (*.qra), or a customer query file (*.qrc).

Enter the beginning and end of the period for the report in the Test Period From/To box
using the date format specified via Tools->Options.

Optional. Enter a name for the analysis in the Analysis Name field, to appear in the title bar
of the report window and on the printed report.

Enter the level of detail to be included in the report. You can check one or both of the
following options, but you must check at least one:

*  Individual Account Report: The report displays a page of information for each
account in the list.

*  Grand Total Summary: The report displays the total data for all accounts in the list.
This option is always checked.

Optional. Add Override Codes: If this checkbox is checked, the report includes the override
codes in effect for each accuont and bill period in the report. This option requires the
Individual Account Report option be selected.

Select the number of decimal places to display from the Bill Determinants Displayed to n
Decimal Places drop-down list. If the number in the database has more decimal places than
the number selected, the number displayed on the report is rounded off the number of
decimals selected. If the number in the database has less decimal places than the number
selected, the number displayed on the report will have zeros appended to the end to display
the number of decimals selected. The default setting is 1.

If you want to change the report options, click Report Options. See Report Options for
more information.

Click OK to run the report.

A progress indicator is shown until the calculations are complete. The requested information
then appears in the report window.

To close the report, select File-»Close.
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The Special Events Report

The Special Events Report summarizes all of the overrides that have been applied to an account

over a user-specified date range.

How to create a Special Events Report:

1.

10-10 Data Manager User’s Guide

Select Analysis->Special Events.

The Special Events Report Input dialog box opens.

Select either Account or Customer in the Select By box.

Select the accounts or customers of interest using one of the following options:
* ID: Type the ID of the account or customer for the report.

*  List: Selecta list for the report. For example, you might have a list of the accounts that
you are responsible for. If the contents of the list may have changed since the last time
that the query associated with it was run, check the box for Refresh list before using.
This option updates the list for this job and saves the new version of the list to the
database, replacing the old one.

*  All: Oracle Utilities Billing Component applies the report to all accounts

*  File: Select a file containing a list of customer/account IDs (*.IDS), a list file (*.Ist), an
account query file (*.qra), or a customer query file (*.qrc).

Type the start date and end date for the period you wish to report in the Special Events
Period From/To box. Use the MM/DD/YYYY date format.

Select one of the following Event Codes:

* All Codes: Include all overrides that were applied to the specified accounts or
customers during the reporting period.

*  Codes List: Include just selected overrides. When you select this button, you can then
highlight any and all desired codes in the list box to the right. To select more than one
code, hold down the CTRL key and select each code to be included. You can select up to
64 specific event codes. This box displays all of the Account Override codes that are
currently stored in the Override Table in the Oracle Utilities Database.

If you want to change your report options, click Report Options. See Report Options for
more information.

Click OK to run the report.

A progress indicator is shown until the calculations are complete. The requested information
appears in the report window.

To close the report, select File-»Close.
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Default Billing Options

The Default Billing Options dialog box lets you specify default global options that apply to all

accounts in the system. These options apply to all billing modules and to all Oracle Ultilities
Billing Component users (unlike the uset-specific Tools->Options preferences described in
Chapter Two of the Oracle Utilities Billing Component User’s Guide). However, you can override any
of these settings for specific rate schedules, rate codes, or accounts in the Oracle Utilities Data
Repository, or for individual jobs. Available Billing options include:

Billing Options

Billing Rules

Report Options

Summary Options

Multiple Bill History Records
Check Options

How to set a global billing mode:

1.

Billing Options

Select CIS Billing (or Analysis)->Billing Options.
The Default Billing Options dialog box appears.
Set your options on each tab as desired.

When you have completed the tabs as desired, you have the following choices for applying
the options:

*  OK: Saves the new settings as your defaults, replacing the previous settings.

*  Apply: The new settings apply to all of your work for remainder of your current session.
The settings will revert to the original defaults when you exit the application.

The Billing Options tab specifies a number of default values and preferences used when
performing billing calculations.

Default Billing Mode: Use this option to specify the mode that Oracle Ultilities Billing
Component applies to accounts that have not otherwise been assigned a billing mode. If you
select Automatic Billing, Oracle Utilities Billing Component calculates the bills, updates the
Oracle Utilities Data Repository, and issues transaction records—all without review and
approval by a user. If you select Approval Required, Oracle Ultilities Billing Component
puts the results of its bill calculations in a bill report which you must approve before the
software issues any transaction records or updates the bill history record in the Oracle
Utilities Data Repository).

Note: Any billing mode flags set for individual rate schedules, rate codes, or
accounts in the Oracle Utilities Data Repository records automatically override
this setting.

Default Eligibility Pre- and Post-Windows: Specify the number of days before an
account’s scheduled read date (the Pre-Window) and the number of days after an account’s
scheduled read date (the Post-Window) that defines the “eligibility” window. You can supply
any value from 0 to 28 for either. In the Automatic Billing and Approval Required modes,
Oracle Utilities Billing Component uses this window to identify “eligible” accounts. That is, if
today’s date falls within this window, Oracle Utilities Billing Component begins scanning for
the data required to bill the account and continues scanning until the data is available or the
window for the account passes today.

The Data Manager Analysis Menu 10-11



Default Billing Options

Billing Rules

Note: If you set the Post Window to 0, the data must be available by the end of
the read date, or it is considered missing. You can override the eligibility
window setting for individual accounts and recorder types.

Note: The Default Pre- and Post-Windows should be set the same or larger
than the largest Pre- and Post-Window for any single account.

Special Event Pre Window: Specify the number of days prior to the billing date within
which a Billing Analyst must approve an account’s Special Events information in order for the
account to be billed. You can enter any value from 0 to 28.

This feature is designed to ensure that all Special Events are included in a bill. For example,
suppose that the Billing Analyst approved an account’s Special Event information on
schedule. However, for some reason the account’s meter could not be read until seven days
after the scheduled date. That would mean there would be seven days during which a Special
Event could occur but not be included in the current bill. However, if you set the Special
Event Pre Window to some number less than 7, Oracle Utilities Billing Component would
flag the account as “ineligible” and the billing analyst would have to update the special events
information.

Automatic Repeat Frequency: The default amount of time between a completed
Automatic Billing cycle and the next. Set this number in minutes, from 0 (do not repeat) to
1440 (24 hours later).

Note: The setting here does not actually define the repeat frequency; it simply
specifies the default. The repeat frequency is set on the Automatic Bllling
Parameters dialog box.

The Billing Rules tab specifies a number of default rules and settings used when performing billing

calculations.
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Effective Date is: The date used to determine Rate Form versions, factor values and the
default for determining the season. There are four options:

*  Bill Stop

*  Bill Start

* 1st of Bill Month

*  Scheduled Read Date

See General Billing Rules on page 4-4 of the Oracle Utilities Billing Conponent Installation and
Confignration Guide for more information.

Allow Saves without SAVE TO CIS statement: Normally output records atre created as
part of a bill calculation. These records are used with non-Oracle Utilities Billing Component
systems such as printing, accounts receivable, and so on. Oracle Utilities Billing Component
verifies that at least one output record has been created before saving any data to the Oracle
Utilities Data Repository. Check this box to turn this verification off, then you can save to the
database without creating an output record.

You must Approve a bill to save it to the Oracle Utilities Data Repository. When you
Approve the bill, data is saved and the Bill Time (BILLTIME) column in the Bill History is
set.

Retrieve all Account Determinants: Normally, to improve performance, Oracle Utilities
Billing Component loads only the determinants that are explicitly used in the Rate Schedule.
However, if you are using indirection (the @ operator) to retrieve determinant values you
need to turn this option on. Oracle Ultilities Billing Component then loads all determinants in
the account’s Bill History records.
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Report Options

Summary Options

Use 2.10 and before Account Note generation in Automatic Billing and Approval
Required: Check this checkbox to generate Account Notes/Work Queue Items in
Automatic and Approval Required billing as was in version 2.10 and earlier versions of Oracle
Utilities Billing Component. The primary difference between pre-2.10 and post-2.10 is that
for 2.10 and eatlier, Account Notes/Work Queue Items are generated on the day after the
scheduled read date, while for post-2.10 they are generated the day after the end of the
postwindow from the scheduled read date. See Billing Account Note/Work Queue Item
Generation on page 4-11 in the Oracle Utilities Billing Component Installation and Confignration
Guide for more information.

Note: When using Work Queues, exceptions are written to the Work Queue
Open Item table instead of the Account Notes table. To enable the Work
Queues application, include the
USE_WORK_Q_FOR_ACCOUNT_NOTES = 1 parameter in the
LODESTAR.CFG file.

The Report Options tab specifies a number of default values used with printing reports.

Print Detail: This option determines the level of detail included in the bill reports,
transaction records, and bill faxes or E-mail. Select one of the following:

* None: Effective revenue only.

*  Normal: Effective revenue, plus any charges assigned to a revenue identifier and any
values assigned to a Report Statement in the applicable rate form.

¢ All: Effective revenue, plus revenue identifiers, plus the values associated with the Rules
> p > p
Language Label and Report statements in the rate form.

Note: You can override this setting for selected accounts, rate codes, or rate
schedules using the Billing Mode Flags in the corresponding records in the
Oracle Utilities Data Repository.

Show Bill History Problems/Resolutions in Bill Reports: If checked, this option
specifies that any problems or resolutions that a Billing Analyst has entered into the Bill
History Problem record for the current bill period appear near the top of the bill report (in
the header section, just after the customer and account information). This option applies to
all bill reports produced by Oracle Ultilities Billing Component.

The Summary Options tab specifies how summary customers and accounts are processed. See
Summary Bill Calculation on page 4-20 in the Oracle Utilities Billing Component Installation and
Configuration Guide for more information.

Compute Multiple Rates per Account: This option specifies whether all effective rates, or
only the most recent rate is used for billing. The options available include:

*  No: Oracle Utilities Billing Component calculates each account’s bill using just the most
recent rate specified in the Rate Code History Table for that account.

*  Throughout Bill Period: Compute multiple rates using all rates in effect for that
account throughout the Bill Period, as specified in the Account Rate Code History Table.
When computing multiple rates, Oracle Utilities Billing Component executes the rates in
reverse order starting with the record with the most recent Start Time.

Note: If you use cither of the first two options, be sure that all inactive rate
codes have a stop time in the Account Rate Code History Table; otherwise they
will be included in the calculations.
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On Effective Date: Compute multiple rates using all rates in effect for that account on
the Effective Date, as specified in the Account Rate Code History Table.

Enable Customer SUMMARY Rate Schedules: If this is checked, Oracle Ultilities Billing
Component can process Summary rate schedules.

Multiple Bill History Records

The Multiple Bill History Recotds tab specifies how customers/accounts with multiple Bill
History records pet bill period and/or read date are handled. See Multiple Bill History Records
per Bill Period on page 4-29 in the Oracle Utilities Billing Component Installation and Confignration
Guide for more information.

Allow Multiple Bill History Records per Bill Period/Read Date: Normally, Oracle
Utilities Billing Component uses the billing cycle’s scheduled meter read dates to match an

account’s Bill History records with the correct bill periods. However, this may not suffice in

all cases, either because the metered data does not come in from the field on a reliable

schedule, or because the metering and billing schedule at your company is more complex.

This tab enables you to choose the action that Oracle Utilities Billing Component takes when

it encounters two or more account Bill History records associated with the same read date.

The option you choose depends upon the metering and billing policies of your company.
(This setting applies to Automatic Billing, Approval Required, and Current/Final Bill.)
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No: Oracle Utilities Billing Component rejects all Bill History records for the specified
account that have the same read date. It does not process the bills, and issues an error
message instead.

Bill Individually - Allow Out of Order Bill Periods: This option is designed primarily
for situations in which metered data comes in from the field irregularly

for example,
readings for bill periods arrive out of sequence, and/or scheduled read dates are missed
altogether. If you select this option, Oracle Ultilities Billing Component treats any
account Bill History records that have the same read date as valid records, and processes
them as separate and complete bills. It retrieves and bills the previously unbilled Bill
History records for the account (Bill Time value equals NULL), in sequence, from oldest
to most recent. To determine the bill period that the Bill History record actually belongs
to, it looks at the Bill History record’s Start Date/Time for the metered data and
processes the bill accordingly. If the applicable rate form includes any SAVE statements,
the computed values are saved to the Bill History record for the correct bill period.

Bill Individually - Monthly Merge Historical Values: This option is designed
primarily for companies whose bill calculations require determinant values for sub-
periods within the current bill period (e.g., weekly kWh), as well as values for entire
historical bill periods (e.g., maximum kW for the past 12 bill months). In this case,
multiple sub-period records (e.g., records with different start- and stop-dates) may be
associated with a single scheduled read date. If you select this option, Oracle Utilities
Billing Component assumes that multiple bill history records with the same read date for
one account are in fact sub-period records. To perform the calculations (depending upon
the rate schedule), Oracle Ultilities Billing Component first aggregates historical sub-
period values and start- and stop-dates to find values for entire historical bill periods. It
then bills each sub-period for the bill period (same scheduled read date), from oldest
through most recent.

Aggregate to Read Date and Bill as One: This option is designed primarily for
companies that take multiple meter readings for an account within a single bill period
(i.e., partial reads), but bills the account using values for the entire bill period. In this case,
two or more Bill History records are allowed per read date. If you select this option,
Oracle Ultilities Billing Component aggregates all determinant values and dates to the
read date (in other words, records with the same read date are combined into one). If the
applicable rate form includes any SAVE statements for the sub-periods, it saves them to
the latest record with the current read date.
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Check Options

* Aggregate to Read Date and Bill as One (Oracle Utilities Rate Management
Style): This option is used only for testing, and should not be selected for billing in a
production mode. It is similar to the option described above, except that the process is
oriented to bill months. That is, two or more Bill History records with the same bill
month are combined into one record for the entire bill month.

The Check Options specifies how certain checks are performed before processing calculations. In
some systems, some of these checks are unnecessary. Use these options to turn off the unneeded
checks, to improve performance.

Do not use Interval Data: Turn off all support for Interval Data during calculations.

Do not use Interval Data to Compute Start/Stop: Don’t use interval data cuts to
compute the bill start and stop, and do not verify that all the account's interval data is ready. If
neither Interval Data check is turned off and Multiple Bill History Records are allowed, only
the verification is performed.

Do not check for Interval Data gaps: Turn off checking for gaps between cuts. The rate
schedule should then check for missing data (status code '9") to validate the data. If this is not
checked, a Warning will be reported if there are gaps between the interval data cuts.

Do not check Account Notes: Don’t check for Account Notes that stop billing in
Automatic Billing or Approval Required. Do not write Account Notes from Automatic
Billing or Approval Required.

Do not check Override Ready: Don’t check that Special Events or Overrides are Ready.

Do not check Account’s Meter Values: Don’t verify that account’s scalar data is in the
Meter Value Table.

Do not check Rate Code Flags: Do not use the BILLINGMODEFLAG,
PRINTDETAIL or FULLDAYBILL values in the RATECODE Table. If this is checked, it
also turns off the same flags in the Rate Forms (RATEFORM) Table.

Do not check Rate Schedule Flags: Do not use the BILLINGMODEFLAG,
PRINTDETAIL or FULLDAYBILL values in the RATEFORM Table, independent of the
RATECODE Table.

Do not display “Reason for Change” dialog when updating the Bill History [Value]
records: Don’t display the Reason for Change dialog after updating Bill History or Bill
History Value records.

Do not check Bill Determinant Use: Don’t check the Bill Determinants’ Use table.

Use MDM schema: When this option is checked, Oracle Utilities Billing Component checks
the Oracle Utilities Meter Data Management (MDM) tables, specifically the Meter Data
Channel Cut table, for interval data when billing accounts.

Checking this option also automatically checks the following other options:
* Do not check for Interval Data Gaps

* Do not check Account’s Meter Values

It also disables the following options:

* Do not use Interval Data

* Do not use Interval Data to compute Start/Stop

Use MDM check data: When this option is checked, usage in the Oracle Utilities Meter
Data Management tables is validated when Oracle Utilities Billing Component checks for
data.

The Data Manager Analysis Menu 10-15



Default Billing Options

Each of these checks requires at least one query to a database so turning one off eliminates its
database query and saves time. The most time consuming check is using Interval Data to Compute
Start/Stop, followed by checks for Account Notes, Account's Meter Values, Override Ready and
Bill Determinant Use. To determine what you can turn off, look at the rate schedules. If no rate
schedule, rider or contract uses Overrides, for example, turn off the Override Ready check.
Likewise, if there your system doesn’t use interval data, turn off the Interval Data checks.
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Appendix A

Oracle Utilities Data Repository Schema Import
File Format

This appendix describes the format of the input files required by the Oracle Utilities import
utilities, based on the base Oracle Utilities Data Repository schema (ILSDB 5.31.002), including:

¢  Record Formats
* A Note Regarding Dependent Records
*  Oracle Utilities Import Format (*.imp)
*  Oracle Utilities XML Import Format (*.xml)
Important Note

Any client-specific customizations to this base schema, whether implemented by the client or
Oracle, may alter one or more of the definitions provided below.
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Record Formats

Import files can be in one of two formats:
*  Oracle Utilities Import Format (*.imp)

*  Oracle Utilities XML Import Format (*.xml)

A Note Regarding Dependent Records

Dependent records can only be added to the database after all of their parent records have been
added. If a dependent record and one or more of its parent records are loaded from the same file,
the parent records must appear before the dependent record in the file.
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Oracle Utilities Import Format (*.imp)

Example:

The Oracle Utilities Import Format is a comma-delimited format in which each column value for
a record must appear on a single line, in correct order, separated by commas. The following rules
provide specific details concerning the input file format:

*  Fach record must begin on a new line (though text wrapping may occur).

*  Comments may be placed on a line by themselves by beginning the line with an asterisk (*)
character. Blank lines are also allowed.

*  The first value of each record must be the identifying mnemonic for the record type. The
table layouts (see How to view or print database table layouts: on page A-3) contain the
mnemonic for each table.

*  FEach value may optionally be enclosed by double-quotation marks. If a value is enclosed in
double quotation marks, then all characters between the quotation marks will be considered
part of the value, including any leading or trailing blanks.

*  Ifavalue contains a comma (,) character, or any leading or trailing blank characters, then it
must be enclosed in double-quotation marks.

*  Null values are represented by no value. Trailing null values must be preceded by commas.

*The following lines contain the Customer, Account Status, Jurisdiction, Operating Company,
Revenue Code, and Account information.

cusT,"800001","Paul Pham",,"HOME","OFFICE1l","E","E"
ACCTSTAT, "A", "Excellent"

JURIS, "SF","Smithfield"

OPCO, "GECO", "Generic Electric Company","123 Mars Planet
Ave","Universe","GK","12345-4321","991-123-4567"
REVCODE, "33", "Commercial (Light)"
ACCT,"™800001","800001"™,"01/01/1993 00:00:00",,"GECO","SF", "Paul
Sauvageau", ,"A","33","2","3","N",5,5

Each table in the Oracle Utilities Data Repository has its own record format, based on the specific
columns in the table. The PLIMPORT command line program can be used to view or output a
layout of each table that defines its record format.

The -t switch on the PLIMPORT program allows users to view the layout of a table (or tables), or
to create a text-only output file that contains the table layout. See Importing Customer Data on
page 8-4 of the Oracle Utilities Energy Information Platform Confignration Guide for more information
about using the PLIMPORT program.

Note: Using the -t switch overrides the other parameters. PLIMPORT can
either import data or display tables in the database, but not both in the same

command line. In other words, if you use the -t switch in the command line,
PLIMPORT will NOT import data.

How to view or print database table layouts:

1. Open a Command Prompt (DOS) Window. Select Start->Run, and type ‘cmd’ in the field
that appears.

2. Change to the directory in which your Oracle Utilities executables are stored, typically
\LODESTAR\BIN.

3. To view the database layout, type the following command at the prompt:
PLIMPORT -d dsn -t TABLENAME

where:
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*  The -d switch is identical to the switch described in Importing Customer Data on page
8-4 of the Oracle Utilities Energy Information Platform Configuration Guide.

*  The -t switch specifies the table you wish to view. To view the entire database, enter -t
without the tablename parameter.

4. To save the table layouts to a text file, type the following command at the prompt:
PLIMPORT -d dsn -t TABLENAME > outputfile.txt
where:
*  outputfile.txt is name of the output file containing the table layouts.

PLIMPORT writes the text-only output file containing the layout of the specified table(s) to the
current directory, which can be viewed and printed using Notepad or another text editor.

For example, to save the layout of the Account Table in the “lodestar” database to a file named
acctpict.txt, type the following

PLIMPORT -d lodestar -t ACCOUNT > acctpict.txt

The output might look like the following:

Column Name Req’d? | Unique | Identity Foreign Key
MNEMONIC “ACCT” N/A X
CUSTOMERID character 64 (max) X 1- CUSTOMER
ACCOUNTID character 64 (max) X 1 X
STARTTIME datetime N/A X
STOPTIME datetime N/A
OPCOCODE character 64 (max) 2 - OPERATINGCOMPANY
JURISCODE character 64 (max) 3 - JURISDICTION
NAME character 64(max)
SIC character 64 (max) 4-8SIC
ACCOUNTSTATUSCODE character 64 (max) 5 - ACCOUNTSTATUS
REVENUECODE character 64 (max) 6 - REVENUECODE
BILLINGMODEFLAG character 1

(0,1,2,3)
PRINTDETAIL character 1

0,1,2,3)
FULLDAYBILL character (0,Y, 1

N)
PREWINDOW small integer N/A
POSTWINDOW small integer N/A
EDI character 1
REGIONCODE character 64 (max) 7 - REGION
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Rules

Date Formats

There are specific rules regarding the Oracle Utilities Import format, including:

*  Asingle record will have at least one unique column (or compound column combinations),
representing the primary key, or identity, of the record.

*  The use of a tilde (“~”) in an identity column causes the column to be ignored. The identity
of the record must still be discernible from the included identity columns.

* A record may have zero or more foreign key columns (or compound column combinations).
The existence of a foreign key indicates a dependent record, meaning that all of its parent
records must exist in the database before it is added. If a dependent record and one or more
of its parent records are imported in the same file, the parent records must appear before the
dependent record in the file. For example, before records can be added to the Account table
in the above example, appropriate records must exist in the database in the Customer,
Operating Company, Jurisdiction, SIC, Account Status, Revenue Code, and Region tables. If
these records were imported using the same import file, the Customer, Operating Company,
Jurisdiction, SIC, Account Status, Revenue Code, and Region table records would have to
appear before the Account table records in the import file.

* Ifarecord is added and one of the columns in the record is Null (i.e. there is no value for the
column provided in the input file), the column is ignored. This allows default values in the
database to remain unaffected.

e  Ifupdating a record, the new record must be followed on the same line by a comma and the
primary key of the existing record (comma separated if more than one column).

Example:
Update the jurisdiction record from Smithfield (SF) to California (CA).

JURIS, "CA","California"™,, “SF”

Billmonth data types are formatted as “MM/YYYY”.
Date data types are formatted as either:

«  “MM/DD/YYYY”

* “YYYY/MM/DD”

Datetime (Timestamp) data types are formatted as either:
«  “MM/DD/YYYY HH:MM:SS”

* “YYYY/MM/DD HH:MM:SS”

Note: If import data contains milliseconds, the milliseconds must be set to “000” before
importing.
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Oracle Utilities XML Import Format (*.xml)

The Oracle Utilities XML Import Format is a XML format in which each record and column
value for a record are defined in a specific XML structure. This is the same XML format used by
the Oracle Utilities Database interface (LSImportDB). A Data Type Definition (DTD), xml
examples, and data element descriptions for this format are provided below.

DTD - Oracle Utilities XML Import Format

<IDOCTYPE LODESTAR_IMPORT

[
<IELEMENT LODESTAR_IMPORT (ROWS*)>
<IATTLIST LODESTAR_IMPORT
ACTION#PCDATA,
BATCHSIZE#PCDATA,
ONERROR#PCDATA>
<IELEMENT ROWSROW*)>
<IATTLIST ROWS
TBL #PCDATA>
<IELEMENT ROW (DBCOLUMNNAME)>
<IATTLIST ROW
TBL CDATA #IMPLIED,
ACTION(ADD | UPDATE | DELETE | ADDUPDATE)#IMPLIED>
<IELEMENT DBCOLUMNNAME (#PCDATA)>
<IATTLIST DBCOLUMNNAME
V  CDATA "column value",
NV CDATA "new column value">
1>

XML Examples - Oracle Utilities XML Import Format

Add Example

<LODESTAR IMPORT ACTION="ADD" BATCHSIZE="50" ONERROR="CONTINUE">
<ROWS>
<ROW TBL="ACCOUNT">
<CUSTOMERID V="Custl"/>
<ACCOUTNID V="Acctl"/>
<STARTTIME V="01/01/2000 00:00:00"/>
</ROW>
</ROWS>
</LODESTAR_IMPORT>

Update Example
<LODESTAR_IMPORT ACTION="UPDATE" BATCHSIZE="50" ONERROR="STOP">
<ROWS TBL="ACCOUNT">
<ROW>
<CUSTOMERID V="Custl"/>
<ACCOUTNID V="Acctl" NV="Acctl00"/>
<STARTTIME V="01/01/2001 00:00:00"/>
</ROW>
</ROWS>
</LODESTAR_IMPORT>
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Element Descriptions - Oracle Utilities XML Import Format

LODESTAR_IMPORT: Root element containing one or more sets of records, each defined in a
ROWS element.

Attributes:
ACTION: Defines the action performed. Possible values ate:

* ADD: Adds one or more records to the database. It is an error if the record(s) is already
present.

*  UPDATE: Updates one or more existing records in the database. It is an error if the record
does not exist.

¢ DELETE: Deletes one or more records in the database. It is an error if the record to be
deleted does not exist.

* ADDUPDATE: Adds or Updates one or more records in the database. This is the Default
behavior. If a record is present, the function updates it. If the record does not exist, the
function adds the record.

BATCHSIZE: The number of records to be sent to the database in a single call. Larger numbers
generally improve performance. The default is 50. The maximum is 500.

ONERROR: Defines how errors are handled. Possible values include:

* CONTINUE: Continue importing records after error.

*  STOP: Stop importing records when an error occurs.

Elements:

ROWS: Element containing one or more records for import, each defined in a ROW element.
Attributes:

TBL: Table name for all the records defined in the ROW elements included in the ROW
element.

Elements:
ROW: Element containing one record for import.
Attributes:

TBL: Table name for the record. If present in a ROW element, this overrides the TBL
attribute on the ROWS element.

Elements:

DBCOLUMNNAME: Actual database name of the column. For example, when importing
records in the Account ID column of the Account table, this would be “ACCOUNTID”.

Attributes:

V: Column value. If not present, NULL is assumed. If the value is an XML, it will be
specified as a child of the DBCOLUMNNAME element.

NV: New column value for the record. Must be specified if updating a key column.
Notes:

*  The “NV” (New value) attribute is only required for identity columns that need to be
updated.

e Also, for “DELETE” operations, providing just the identity columns is sufficient.

*  Any missing “V” (Value) attribute will be treated as a NULL value for the column.
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Appendix B

Oracle Utilities Enhanced Input/Output Interval
Data Format

This document provides a detailed desctiption of the Oracle Utilities Enhanced Input/Output
Interval Data (LSE) format, used by Oracle Utilities applications. This includes:

¢ Enhanced Format
¢ Enhanced Format Details
*  Sample Files

¢ Units of Measure
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Enhanced Format

General Field Descriptions

In the enhanced format, fields are comma-delimited. A data line may contain as many full data-
status-time groups as desired. No physical record in the file may exceed a character count (record
length) of 32750. Leading or trailing white space is allowed on any field, but will be ignored upon
processing, The descriptor field is an exception to this rule. It may contain any number of spaces,
anywhere within the field.

Numeric fields will be expressed as decimal numbers, and may contain a decimal point and/or a
leading minus sign (-), but must not contain commas or the value “+” to indicate a positive
number. Non-negative numbers are assumed on all numeric fields if no leading minus sign is
present.

The Customer Identifier, Channel Number, and the Start Time compose the full key of the record
which, in combination with each other, must uniquely identify the record to be stored in the
database.

No field except the descriptor may contain a comma.
All character values in the Enhanced Format must be uppercase.
Any cut entered with an invalid Start or Stop Time will be rejected.

An input cut with header records, but no data records, will be treated like any other cut; the
number of intervals allocated will be determined by the time range, and all intervals will be treated
as missing,

The contents of the Customer Identifier field, Origin field, and all Y/N indicators will be
translated to uppercase before they are stored in the database.

Note: Database sort order will follow ASCII collating sequence, starting with the Customer
Identifier and followed in turn by the Channel, then the Start Time.

A cut will be rejected if the number of interval values supplied is greater than the number of
interval values expected, based upon the Start Time, Stop Time, SPI, and DST_Participant fields.
If too few interval values are supplied, the cut will be filled out with “missings” (value of 0 and
status of ‘9’).

Any Stop Time falling exactly on an interval boundary will have one second subtracted from it.
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Field Relationships and Requirements

Relationships between fields exist in the enhanced format. These are described along with

detailed field requirements in this section. Defaults are inserted when the processing program

encounters an omitted field (indicated by double commas) or white space between commas.

Sort Code

Relationships:
This field has no relationship with any other field.

Requirements:

Sort codes must contain eight digits, including leading Os. Sort codes are restricted to integers
between 00000001 and 99999999. However, 00000005 through 09999999 are not used, and
may be ignored (see below).

Leading white space before the sort codes is not allowed.

The first three header records are required.

The fourth header record is optional.

Header records will have sort code 00000001 through 00000004.
Column 1 of each header record must contain a 0.

Records with Sort codes 00000005 through 05000000 are reserved.

Sort codes 00000030 through 000000039 ate reserved for user-defined attributes created
through Oracle Utilities Rules Language rate schedules.

Data records must start with sort code 10000000, and progress sequentially (i.e. 10000001,
10000002...) through 99999999, or as high as needed to accommodate the data, with the
maximum of 99999999.

Column 1 of the data records must be greater than 0.

Recorder/Customer Identifier (key element)

Relationships:
None.

Requirements:

Default:

Only letters, numbers, underscores, and hyphens will be accepted in this field; all other
characters and embedded blanks will cause the record to be rejected.

Note: Lowercase letters will be translated to uppercase before they are stored in the database.

Must be at least one character, and no more than 64 characters in length.

None; field is required.
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Channel (key element)

Relationships:
None.

Requirements:
*  Field values must be non-negative integer only.
*  Maximum value is 32767.

Default:

None; field is required.

Start Time (key element)

Relationships:
*  Must be a valid datetime value less than the value of the Stop Time.

Requirements:
¢ Format must be YYYYMMDDHHMMSS.

e Value must be after 19700101000000 when using Data Manager, Oracle Ultilities Billing
Component, and other non-Oracle Ultilities L.oad Analysis applications. The value must be
after 19670101000000 when using Oracle Utilities Load Analysis.

*  No spaces, colons, or any ASCII value allowed between time components.

Default:

None; field is required.

Stop Time

Relationships:
*  Must be a valid datetime value greater than the value of the Start Time.
*  Value must agree with the number of interval values past the start time * SPI.
*  One second is subtracted if the value is equal to an even interval start time.

Requirements:
See Start Time.

Default:

None; field is required

DST Participant Flag

Relationships:
None.

Requirements:
Valid values are Y, N, or A, indicating whether or not this record will be processed using DST
adjustments.

Flag Value Definition

Y (DST Participant) The intervals recorded participate in DST adjustments
and the intervals during DST reflect the time change.
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Flag Value Definition

N (Does not participate in DST) The intervals recorded do not make any DST
time changes.

A (DST participant) The intervals have been adjusted to 24-hour days. (At the
April time change, there should be a value at the time change (a place
holder) of 0 with status code “9”. At the October time change, there should
be a combined value.) These cuts will be converted to a “Y” or “N”, and are
not stored in the database as “A”.

Default:
As specified in the INTDDEFAULTDST configuration parameter setting, the
INTDCONFIG.XML file, or the CSDST value in Oracle Utilities Load Analysis.

Invalid Record Flag

Relationships:
None.

Requirements:
Valid values are Y or N, indicating whether or not the input programs should validate the
incoming record.

Flag Value Definitions

Y The incoming record contains unvalidated data.
In Oracle Utilities Load Analysis, a value of Y can be used to run this record
through the validation routines.

N The incoming record contains valid data (mark as valid).

Default:
Y.

Meter Start Reading

Relationships:
Must be supplied if any of the other Meter fields (Meter Stop Reading, Meter Multiplier, or Meter
Offset) are supplied.

Requirements:
If supplied, value must be a non-negative numeric value.

Default:

Meter Stop Reading

Relationships:
Must be supplied if any of the other Meter Fields (Meter Start Reading, Meter Multiplier, or Meter
Offset) are supplied.

Requirements:
If supplied, value must be a non-negative numeric value.
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Default:
0 stored in the database if not supplied.

Meter Multiplier

Relationships:
Must be supplied if any of the other Meter fields (Meter Start Reading, Meter Stop Reading, or
Meter Offset) are supplied.

Requirements:
If supplied, value must be positive numeric. However, if no value is specified, 0 will be stored.
Zero (0) is not a valid value for the meter multiplier, but its presence in the database indicates that
no meter multiplier was supplied.

Default:
None, 0 stored in the database if not supplied.

Note: If 0 is stored and/or observed in the database and a cut is exported to the LSE format, all
meter fields for that cut will be absent. A zero stored in the database is indicative of “no meter
information supplied”.

Meter Offset

Relationships:
Must be supplied if any of the other Meter fields (Meter Start Reading, Meter Stop Reading, or
Meter Multiplier) are supplied.

Requirements:
If supplied, value must be numeric.

Default:
0 stored in the database if not supplied

Pulse Multiplier

Relationships:
None.

Requirements:
Value must be positive numeric. Also, must be supplied if Pulse Offset (see below) is supplied.

Default:
None, 0 stored in the database if not supplied.

Note: If 0 is stored and/or observed in the database and a cut is exported to the LSE format, all
pulse fields for that cut will be absent. A zero stored in the database is indicative of “no pulse
information supplied”.
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Pulse Offset

Relationships:
If supplied, you must also supply Pulse Multiplier.

Requirements:
Value must be numeric.

Default:
None. (Zero is stored in the database to indicate that the Pulse Multiplier was not supplied.

Seconds Per Interval (SPI)

Description:
This field stores the interval duration if appropriate. An Intervals Per Hour (IPH) of 1 can be
translated to a Seconds Per Interval of 3600.

Relationships:
Value of 0 indicates non-uniform recording duration and a full array of interval start values (one
per recording) located in the data section. (This feature will be supported in a future release and is
not currently available.)

Requirements:

*  Value must be a positive integer.

e Valid values for SPI are 86400, 3600, 1800, 900, 300, and 60.
Default:

None; field is required.

Unit of Measure

Description:
See Units of Measure on page B-16 for valid Units of Measure.

Relationships:
None.

Requirements:
e Value should be a valid unit of measure. If the value entered is unknown to, 16
(Miscellaneous) will be stored.

*  Value must be non-negative numeric.

e  Maximum value is 32767.

Default:

None; field is required.
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Basic Unit Code

Description:
This field is reserved for future use.

Relationships:
None.

Requirements:
Omit this field.

Default:

Times Zones West of GMT

Description:

This value tells programs accessing this record which time zone the values have been recorded in.
Its value will be the difference in time, heading west, between Greenwich Mean Time and the
represented time zone as measured in half hours. Eastern Standard Time should have a value of
10; Pacific = 16. A Value of -1 will indicate “Time Zone not available™.

Relationships:
None.

Requirements:

Value must be -1 or a non-negative numeric between 0 and 47, that represents the time zones West
of GMT measured in half-hour increments. Any record containing a time zone greater than 47

will be rejected.

Default:
-1.

Population

Description:

For Oracle Utilities Load Analysis statistical records only.

Relationships:
None.

Requirements:

Value may be any non-negative integer value.

Default:
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Weight

Description:
For Oracle Utilities Load Analysis statistical records only.

Relationships:
None.

Requirements:
Value may be any non-negative numeric value.

Default:
0.0.

Time Zone Standard Name

Description:
Defines the Time Zone to which the cut is associated. The value must be one of EST, CST, MST,
PST, or be defined in the LSCALENDAR.XML configuration file (if present). Each value in this
field must contain printable ASCII characters no longer than 32 bytes.

Only letters, numbers, underscores, and hyphens will be accepted in this field, all other characters

and embedded blanks will cause the record to be rejected.

Relationships:
Must map exactly to one of EST, CST, MST, PST or an entry in the LSCALENDAR.XML file (if
present). Oracle Utilities L.oad Analysis will import without checking this file.

Requirements
Length: <= 32 bytes

Descriptor

Description:
The user may enter any descriptive information in this field. Any information entered into this
field will be stored in the database verbatim as supplied.

Relationships:
None.

Requirements:
*  Value must be 80 characters or fewer, and may contain commas.

*  May start with blanks.

e If more than 80 characters are entered, truncation will occur and the first 80 will be used.
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Timestamp

Relationships:
None.

Requirements:
*  Format should be YYYYMMDDHHMMSSmmm. The milliseconds (mmm) may be
omitted, in which case mmm will be set to 000.

*  No spaces, colons, or any ASCII value allowed between time components.
Default:
Current time that data is loaded into database.

Note: It is strongly recommended that you leave this field empty and allow the system to input
the TimeStamp for you.

Origin

Relationships:
None.

Requirements:
Must be one of: M (metered), P (profiled), C (computed), or S (Oracle Utilities LLoad Analysis
Statistic).

Default:
M (metered).

Interval Value

Description:
This field contains the actual recorded value for a time period.

Relationships:
Must have one status code entry per interval data value.

Requirements:
Any numeric value. (Up to 15 significant digits can be stored.)

Default:
0 (see Status Code, Relationships, below).

Status Code

Description:
This field contains the status code for the preceding Interval Value.

Relationships:
Must have an entry for the Interval Value.

Requirements:
Any character will be accepted.

Default:

*  This field defaults to a blank (*”) when omitted if the interval value is present.

e This field defaults to ‘9” when the Interval Value field is omitted.
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Interval Start

Description:
*  This field indicates the starting time of the recording or the time when the recording took
place.

*  Format must be YYYYMMDDHHMMSS. (This feature will be supported in a future release
and is not currently available.)
Relationships:
*  Until this feature is supported, the SPI may not be omitted (represented by ,,).
*  There must be one entry per Interval Value.

Requirements:
See Start Time, Requirements.

Default:

None.
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Enhanced Format Details

First Header Record Format

MAXIMUM LENGTH IN
ELEMENT DESCRIPTION BYTES (if applicable) COMMENT

1 Sort Code 8 Must be 00000001

2 Recorder/ 64 Letters, numbers, hyphens or
Customer underscores are acceptable
Identifier Values

3 Channel 5 Max is 32767

4 Start Time 14 YYYYMMDDHHMMSS (24-hour)

5 Stop Time 14 YYYYMMDDHHMMSS (24-hour)

6 DST Participant 1 Y/N/A
Flag

7 Invalid Record 1 Y/N
Flag

Second Header Record Format

MAXIMUM LENGTH IN
ELEMENT DESCRIPTION BYTES (if applicable) COMMENT

1 Sort Code 8 Must be 00000002
Default: None; field
required
2 Meter Start N/A Non-Negative Numeric
Reading Max: 999999999999999.9999
Default: O
3 Meter Stop N/A Non-Negative Numeric
Reading Max: 999999999999999.9999
Default: O
4 Meter N/A Positive Numeric (Optional)
Multiplier Max: 999999999999999.9999
Default: 0
5 Meter Offset N/A Numeric (Optional)
Max: 999999999999999.9999
Default: 0
6 Pulse N/A Positive Numeric (Optional)
Multiplier Max: 999999999999999.9999
Default: 0
7 Pulse Offset N/A Numeric (Optional)

Max: 999999999999999.9999
Default: None; field

required
8 Seconds Per N/A Positive Numeric
Interval (SPI) Default: None; field
required
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MAXIMUM LENGTH IN

ELEMENT DESCRIPTION BYTES (if applicable) COMMENT
9 Unit of Measure N/A Numeric Max: 32767

Default: None; field
required

10 Basic Unit Code N/A Positive Numeric (Optional)
Max: 9999
Default: O

11 Time Zones West N/A Numeric. (Optional)

of GMT Default: -1

Min: -1
Max: 47

12 Population N/A Positive Numeric (Optional)
Max: 999999999999999.9999
Default: 0.0

13 Weight N/A Positive Numeric (Optional)
Max: 999999999999999.9999
Default: 0.0

14 Time Zone Character (32)

Standard Name Overrides any value in
TZWGMT .
Must be one of “EST”, “CST”,
“MST”, “PST”, or definition
must exist in LSCalendar.xml
file.
Third Header Record Format
MAXIMUM LENGTH IN

ELEMENT DESCRIPTION BYTES (if applicable) COMMENT

1 Sort Code 8 Must be 00000003

2 Descriptor 80

Fourth Header Record Format

MAXIMUM LENGTH IN

ELEMENT DESCRIPTION BYTES (if applicable) COMMENT

1 Sort Code 8 Must be 00000004

2 Timestamp 17 YYYYMMDDHHMMS SMM
(optional)
Default: current date

3 Origin 1 C, M, P, or S (optional)
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Data Record Format

MAXIMUM LENGTH IN

ELEMENT DESCRIPTION BYTES (if applicable)

COMMENT

1 Sort Code 8 10000000 through
99999999

2 Interval Value

3 Status Code 1

4 Interval Start 14 YYYYMMDDHHMMS S
(optional)

A data line may contain as many full data-status-time groups as desired, providing the record does
not exceed a character count (record length) of 32750.

Interval start times may be omitted, but a comma must still be present as a placeholder. Data must
be contiguous and “missings” (or gaps) must be represented by value 0 and status '9'. At this time,
all intervals must be of the same duration, hence Interval Start Times should not be specified.
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Sample Files

Enhanced Direct Input File

A sample input file using the enhanced format with 3 headers and 2 data records and with interval
starts omitted:

00000001,N1732,17,19820412000001,19820412005959,Y,Y
00000002,23887.34,23903.56,1.0,0.0,0.0144,0.0,900,1,0,-1,,,
00000003,ACCEPTANCE TEST DATA NUMBER 1

00000004, ,M
10000000,31,9,,9.52,R,,.00314,5,,123456.98765,T,,
10000001,32,9,,9.53,R,,.00315,s,,123457,T,,

Standard Direct Input File

A sample old-format file is provided below for comparison.

0001WARNINGTEST 10412821351051382140004010
000201312750140025000000000912350000000000945679-000000000012346-
000000000034567

0003ACCEPTANCE TEST DATA 000000000000000000000000000000000000
0004
100000031000028Q00008Q00061Q00038Q00011Q00050Q000005000055000000900000900004Q
100100029000016Q00079Q00036Q00020Q000766000616000156000780Q00021000050Q00004Q
100200004Q000070Q00006000006000004Q00008Q00005Q00009Q00009Q00009000005000006Q
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Units of Measure

The table below lists valid Units of Measure. Intervals may be summed or averaged when

aggregating, depending on the unit of measure. The aggregation technique is noted on the table

Note: Oracle Utilities products also accept 3-digit UOMs, which may be user-

defined.

CODE DESCRIPTION ?EGCG|-|R[\]E|(Q;G.20N
01 kWh Sum

02 kW Average
03 kVARh Sum

04 kVAH Sum

05 Temperature (°F) Average
06 KQD Average
07 VZH (PTP) Sum

08 kQh Sum

09 kQh (45 degtees) Sum

10 1’H Sum

11 Volts Average
12 Amps Average
13 Temperature (°C) Average
14 Dewpoint Average
15 Amplitude Average
16 Miscellaneous Sum

17 Minute Run Time (MRT) Sum

18 Wind Velocity (Cm/Sec) Average
19 Fraction V2H (PTN) Average
20 Percent Average
21 Flow Average
22 KVAR Average
23 kVA Average
24 kVA Ratio Average
25 Power Factor Average
26 Hertz Average
27 Feet Average
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CODE DESCRIPTION ?EGCG|-I|:{[\]E|((;G1|-EION
28 Minutes Sum

29 On/ Off (Tap position) Average
30 Inches Average
31 Individual kWh Sum

32 kWh r Sum

33 Individual Totalized kVARh Sum

34 kVARh r Sum

35 Individual Totalized Temperature (°F) Average
36 kVAh r Sum

37 IND V2H (Individual totalized VZH) Sum

38 IND kQh (Individual totalized kQh) Sum

39 KQH Sum

40 Miscellaneous Average
41 IND Volts (Individual totalized Volts) Average
42 IND Amps (Individual totalized Amperes) Average
43 IND Temperature (°C) (Individual totalized Average

temperature, degrees Celsius)

44 Mw Sum

45 MVAR Average
46 MVA Average
47 IND MRT (Individual totalized MRT) Sum

48 IND CMS (Individual totalized CMS) Average
49 Run Hours Sum

50 Equivalent Full Load Hours Sum

51 KWH-OUT Sum

52 KW-OUT Average
53 KVARH-OUT Sum

54 KVAH-OUT Sum

55 KQH-OUT Sum

56 LEAD-KVARH Sum

57 LEAD-KVARH-OUT Sum

58 LAG-KVARH Sum
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CODE DESCRIPTION ?EGCGI'TI‘lElgﬁ-II-EION
59 LAG-KVARH-OUT Sum

60 Gallons / Minute Average
61 BTU Sum

62 THERMS Sum

63 Cubic Feet/Minute Average
64 Cubic Feet/Second Average
65 WM2 Average
66 Relative Humidity Average
67 MPH Average
68 THI Average
69 Gallons Sum

70 Cubic Feet Sum

71 Temperature Difference Average
72 KVAR-OUT Average
73 KVA-OUT Average
74 Knots Average
75 Degtees Average
76 CCF (Hundred cubic feet) Sum

77 CF/Hour Average
78 Pounds /Squate inch Average
79 Dollars Sum

80 DECATHERMS Sum

81 Pounds Sum

82 Pounds / Hour Average
83 MPOUNDS Sum

84 MPOUNDS /Hour Average
85 $/ KWH Average
86 $/ MW Average
87 $/MWH Average
88 $/Hour Average
89 Volt Hours Sum

90 Individual Totalized Cubic Feet Sum
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CODE DESCRIPTION ?EGCGI'TNElgGEON
91 Individual Totalized Btu Sum

92 Pressure in MILLIBARS Average
93 Visibility in Miles Average
94 Cents per kWh Average
99 Individual Totalized Gallons Sum
100 MWH Sum
102 Euros Sum
103 Euros per MWH Average
104 Euros MW Average
105 GW Average
106 TWH Sum
107 Cubic Meters (M3) Sum
108 Mega Joules per Cubic Meter (MJ/m3) Average
109 Kilograms per Cubic Meter (Kg/m3) Sum
110 Cubic Meters per Hour (M3/H) Average

UOM Compatibility

When merging cuts with different units-of-measure, cuts with specific differing UOMs can be
combined while others can't. For example, you can’t merge two cuts if the UOM of one cut is
inches and the UOM of the other is dollars, because whichever UOM is assigned to the merged
cut wouldn't apply to at least some of the data.

However, cuts with certain specific different UOMs can be combined. UOMs that can be
combined are referred to as compatible UOMs, and are listed in the table below.

Compatible UOMs

01,31,32,51

02,52

03,33,34,53,56,57,58,59

04,36,54

05,35

07,37

08,09,38,39,55

11,41

12,42

13,43
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Compatible UOMs

17,47

18,48

22,72

2373

61,69

69,99

70,90

These units of measures may have their intervals divided by the IPH for display:
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Appendix C

Oracle Utilities Standard XML Interval Data
Format - Version 1.2

This appendix provides a detailed description of the Oracle Utilities Standard XML Interval Data
Formats, supported by Oracle Utilities applications. This includes:

* Standard XML Format

* XML Standard File Format Example
* XML Standard File Format DTD

* XML Compact Format
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Standard XML Format

General Node Descriptions

In the Oracle Utilities Standard XML format, nodes are enclosed with XML tags. A data line may
contain as many full data-status-time groups as desired.

Numeric nodes will be expressed as decimal numbers, and may contain a decimal point and/or a
leading minus sign (-). Non-negative numbers are assumed on all numeric nodes if no leading
minus sign is present. If a minus sign is present, spaces may exist between it and the numeric value.
For example: ...,- 122.11,... or ..., -23.3,... are valid entries for a numeric node.

()

The Recorder, Channel Number, and the Start Time compose the full key of the record which, in
combination with each other, must uniquely identify the record to be stored in the database.

Node names and XML tag names must be uppercase.
Any cut entered with an invalid Start or Stop Time will be rejected.

The contents of the Recorder node, Origin node, and all Y/N indicators will be translated to
uppercase before they are stored in the database.

Note: Database sort order will follow ASCII collating sequence, starting with the Recorder and
followed in turn by the Channel, then the Start Time.

A cut will be rejected if the number of interval values supplied is greater than the number of
interval values expected, based upon the Start Time, Stop Time, SPI, and DST_Participant nodes.
If too few interval values are supplied, the cut will be filled out with “missing” (value of 0 and
status of ‘9’).

Any Stop Time falling exactly on an interval boundary will have one second subtracted from it.
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General Rules

Each root node of a file starts with a set of special nodes. These nodes contain the name of the
format, the version number of the format, the decimal point specification, and date/time format
specification.

Format Name
The first node identifies the format as “LODESTAR Interval Data XML Format”. It is an error if
this is not present.

Example:
<INTERVAL DATA FORMAT>LODESTAR Interval Data XML Format </INTERVAL7DATA7FORMAT>

Format Version Number
The second node identifies the version number of the format. It is an error if this is not present.

Example:
<VERSION>version_number</VERSION>

Decimal Point Specification
The third node identifies the decimal point specification to be used in the file. All float values used
throughout the file must use this decimal point format. It is an error if this is not present.

Example:
<DECIMAL7POINT>.</DECIMAL7POINT>

Date/Time Format Specification
The fourth node identifies the date/time format to be used in the file. There are three available
date/time formats:

1. MM/DD/YYYY HH:MM:SS
2. DD/MM/YYYY HH:MM:SS
3. YYYY/MM/DD HH:MM:SS
All date/time values used throughout the file must use this format. It is an error if this is not

present

Example:
<DATETIME_FORMAT>10/27/1999 10:31:OO</DATETIME_FORMAT>

These nodes are followed by the interval cut information as outlined below:
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Node Relationships and Requirements

Relationships between nodes exist in the standard XML format. These are described in this
section, and detailed node requirements are provided. Defaults are inserted when the processing
program encounters an omitted node.

RECORDER (key element)

Relationships:
None.

Requirements:
*  Only letters, numbers, underscores, and hyphens will be accepted in this node; all other
characters and embedded blanks will cause the record to be rejected.

Note: Lowercase letters will be translated to uppercase before they are stored
in the database.

*  Must be at least one character, and no more than 64 characters in length.

Default:

None; node is required.

CHANNEL (key element)

Relationships:
None.

Requirements:
*  Node values must be non-negative integer only.

e Maximum value is 32767.

Default:

None; node is required.

STARTTIME (key element)

Relationships:
*  Must be a valid datetime value less than the value of the Stop Time.

Requirements:
*  Format must match that specified by the Date/Time Format Specification on page C-3.

e Value must be after 19700101000000.

*  No spaces, colons, or any ASCII value allowed between time components.

Default:

None; node is required.
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STOPTIME

Relationships:
*  Must be a valid datetime value greater than the value of the Start Time.

*  Value must agree with the number of interval values past the start time * SPL
*  One second is subtracted if the value is equal to an even interval start time.

Requirements:
See STARTTIME.

Default:

None; node is required.

DST_PARTICIPANT

Relationships:
None.

Requirements:
Valid values are Y, N, or A, indicating whether or not this record will be processed using DST
adjustments.

Flag Value Definition

Y (DST Participant) The intervals recorded participate in DST adjustments
and the intervals during DST reflect the time change.

N (Does not participate in DST) The intervals recorded do not make any DST
time changes.

A (DST participant) The intervals have been adjusted to 24-hour days. (At the
April time change, there should be a value at the time change (a place
holder) of 0 with status code “9”. At the October time change, there should
be a combined value.) These cuts will be converted to a “Y” or “N”, and are
not stored in the database as “A”.

Default:
As specified in the INTDDEFAULTDST configuration parameter setting, the
INTDCONFIG. XML file, or the CSDST value in Oracle Utilities Load Analysis.
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VALIDATION_REQUIRED

Relationships:
None.

Requirements:
Valid values are Y or N indicating whether or not the record should be marked as valid.

Flag Value Definition
Y The incoming record contains unvalidated data.
N The incoming record contains valid data, and should be marked as such.
Default:
Y.

METER_START_READING

Relationships:
Must be supplied if any of the other Meter nodes (Meter Stop Reading, Meter Multiplier, or Meter
Offset) are supplied.

Requirements:
If supplied, value must be a non-negative numeric value.

Default:

METER_STOP_READING

Relationships:
Must be supplied if any of the other Meter nodes (Meter Start Reading, Meter Multiplier, or Meter
Offset) are supplied.

Requirements:
If supplied, value must be a non-negative numeric value.

Default:
0 (not supplied).

METER_MULTIPLIER

Relationships:
Must be supplied if any of the other Meter nodes (Meter Start Reading, Meter Stop Reading, or
Meter Offset) are supplied.
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Requirements:
If supplied, value must be positive numeric. However, if no value is specified, 0 will be stored.
Zero (0) is not a valid value for the meter multiplier, but its presence in the database indicates that
no meter multiplier was supplied.

Default:
None, 0 stored in the database if not supplied.

Note: If 0 is stored and/or observed in the database and a cut is exported to the LSE format, all
meter fields for that cut will be absent. A zero stored in the database is indicative of “no meter
information supplied”.

METER_OFFSET

Relationships:
Must be supplied if any of the other Meter nodes (Meter Start Reading, Meter Stop Reading, or
Meter Multiplier) are supplied.

Requirements:
If supplied, value must be numeric.

Default:
0 (not supplied).

PULSE_MULTIPLIER

Relationships:
None.

Requirements:
Value must be positive numeric. Also, must be supplied if Pulse Offset (see below) is supplied.

Default:
None, 0 stored in the database if not supplied.

Note: If 0 is stored and/or observed in the database and a cut is exported to the LSE format, all
pulse fields for that cut will be absent. A zero stored in the database is indicative of “no pulse
information supplied”.

PULSE_OFFSET

Relationships:
If supplied, you must also supply Pulse Multiplier.

Requirements:
Value must be numeric.

Default:

None.

SPI (Seconds per Interval)
Description:

This node will store the interval duration if appropriate. An Intervals per Hour IPH) of 1 can be
translated to an SPI of 3600.
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Relationships:
Value of 0 indicates non-uniform recording duration and a full array of interval start values (one
per recording) located in the data section. (This feature will be supported in a future release and is
not currently available.)

Requirements:

*  Value must be a positive integet.

*  Valid values for SPI are 86400, 3600, 1800, 900, 300, and 60.
Default:

None; node is required.

UOM (Unit of Measure)

Description:
See Units of Measure on page B-16 for valid Units of Measure.

Relationships:
None.

Requirements:
e Value should be a valid unit of measure. If the value entered is unknown to, 16
(Miscellaneous) will be stored.

*  Value must be non-negative numeric.

e Maximum value is 32767.

Default:

None; node is required.

DC_FLOW

Description:
Power flow direction. This is used with MV90 data.

Relationships:
None.

Requirements:
Must be either “D” (Delivered) or “R” (Received).
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Default:
(CD”

TIMEZONE

Description:
This value tells programs accessing this record which time zone the values were recorded in. Its
value will be the difference in time, heading west, between Greenwich Mean Time and the
represented time zone, measured in half hours. Eastern Standard Time should have a value of 10;
Pacific = 16. A Value of -1 indicates “Time Zone not available.”

Relationships:
None.

Requirements:
Value must be -1 or a non-negative numeric between 0 and 47, that represents the time zones west
of GMT, measured in half-hour increments. Any record containing a time zone greater than 47
will be rejected.

Default:
-1.

POPULATION

Description:
For Oracle Utilities Load Analysis Statistical records only.

Relationships:
None.

Requirements:
Value may be any non-negative integer value.

Default:

WEIGHT

Description:
For Oracle Utilities Load Analysis Statistical records only.

Relationships:
None.

Requirements:
Value may be any non-negative numeric value.

Default:
0.0.
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TIME_ZONE_STANDARD_NAME

Description:
Defines the Time Zone to which the cut is associated. The value must be one of EST, CST, MST,
PST, or be defined in the LSCALENDAR.XML configuration file. Each value in this field must
contain printable ASCII characters no longer than 32 bytes.

Only letters, numbers, underscores, and hyphens will be accepted in this field, all other characters
and embedded blanks will cause the record to be rejected.

Note: Lowercase letters will be translated to uppercase before being stored
Relationships:

Must map exactly to one of EST, CST, MST, PST or an entry in the LSCALENDAR. XML file.
Oracle Utilities Load Analysis will import without checking this file.

Requirements
Length: <= 32 bytes

DESCRIPTOR

Description:
The user may enter any descriptive information in this node. Any information entered into this
node will be stored in the database verbatim.

Relationships:
None.

Requirements:
*  Value must be 80 characters or fewer, and may contain commas.
*  May start with blanks.

e If more than 80 characters are entered, truncation occurs and the first 80 are used.

TIMESTAMP

Relationships:
None.

Requirements:
*  Format must match that specified by the Date/Time Format Specification on page C-3.
*  No spaces, colons, or any ASCII value allowed between time components.

Default:
Current time that data is loaded into database.

Note: It is strongly recommended that you leave this node empty and allow the
system to input the TimeStamp for you.

ORIGIN

Relationships:
None.

Requirements:

Must be one of: M (metered), P (profiled), C (computed), or S (Oracle Utilities LLoad Analysis
Statistic).
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Default:
M (meteted).

ACCEPT_REJECT_STATUS

Description:

This is used by MV90 to indicate if the cut was accepted or rejected.

Relationships:
None.

Requirements:
Will be either:

Status Code Description

00 Accept. No Error.

01 though 07 Rejected/Reject type.

Default:

None.

TRANSLATION DATE

Description:

This is used by MV90 to indicate the date/time the cut was translated from MV90.

Relationships:
None.

Requirements:

Format must match that specified by the Date/Time Format Specification on page C-3).

Default:

None.
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Interval Values

The interval values data is enclosed within the <INTERVAL> node. Each individual interval
value is enclosed within the <RECORD> node, and consists of the VALUE, STATUS (optional),
and STARTTIME (optional). The RECORD node will not have a STATUS node if and only if the
interval status is a space. The optional STARTTIME node in the RECORDING node is only
included if the XMLEXPORTINTDSTARTTIME=1 parameter is included in the
LODESTAR.CFG file (see Chapter Four: Configuration Files in the Oracle Utilities Energy
Information Platform Installation and Configuration Guide).

Descriptions of the RECORD nodes are as follows:

VALUE (Interval Value)

Description:
This node contains the actual recorded value for a time period.

Relationships:
Must have one status code entry per interval data value, if the status is not a space (see above).

Requirements:
Any numeric value. (Up to 15 significant digits can be stored.)

Default:
0 (see Status Code, Relationships, below).

STATUS (Status Code)

Description:
This node contains the status code for the preceding Interval Value.

Relationships:
Must have an entry for the Interval Value.

Requirements:
Any character will be accepted.

Default:

*  This node defaults to a blank (°’) when omitted if the interval value is present.

¢ This node defaults to ‘9’ when the Interval Value node is omitted.
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STARTTIME (Interval Start Time)

Description:

*  This node indicates the starting time of the recording or the time when the recording took
place.

*  Format must match that specified by the Date/Time Format Specification (page D-3).

*  This feature will be supported in a future release and is not currently available.

Relationships:
e There can be one entry per Interval Value.

Requirements:
See Start Time, Requirements.

Default:

None.
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XML Standard File Format Example

An example of the Oracle Utilities Standard XML format is shown below.

<INTERVAL DATA>
<INTERVAL_ DATA FORMAT>LODESTAR Interval Data XML Format</INTERVAL_DATA FORMAT>
<VERSION>1.2</VERSION>
<DECIMAL POINT>.</DECIMAL POINT>
<DATETIME_FORMAT>MM/dd/yyyy HH:mm:ss</DATETIME_FORMAT>
<CUT>
<RECORDER>TV011285</RECORDER>
<CHANNEL>32767</CHANNEL>
<STARTTIME>01/01/1999 00:00:00</STARTTIME>
<STOPTIME>01/31/1999 23:59:59</STOPTIME>
<DST_PARTICIPANT>Y</DST PARTICIPANT>
<VALIDATION REQUIRED>N</VALIDATION REQUIRED>
<METER START READING>1234</METER START READING>
<METER_STOP_READING>2345</METER_STOP_READING>
<METER MULTIPLIER>1.12345</METER MULTIPLIER>
<METER OFFSET>100.0</METER OFFSET>
<PULSE_MULTIPLIER>1.0000</PULSE_MULTIPLIER>
<PULSE_OFFSET>0.0000</PULSE_OFFSET>
<SPI>900</SPI>
<UOM>01</UOM>
<DC_FLOW>D</DC_FLOW>
<TIMEZONE>8</TIMEZONE>
<POPULATION>300000</POPULATION>
<WEIGHT>0.0</WEIGHT>
<TIME ZONE STANDARD NAME>EST</TIME ZONE STANDARD NAME>
<DESCRIPTOR>DEMO</DESCRIPTOR>
<TIMESTAMP>01/01/2000 00:00:00</TIMESTAMP>
<ORIGIN>M</ORIGIN>
<INTERVAL>
<RECORDING>
<VALUE>123456.1234</VALUE>
<STATUS>A</STATUS>
<STARTTIME>11/01/1999 11:12:34</STARTTIME>
</RECORDING>
<RECORDING>
<VALUE>123456.1234</VALUE>
<STATUS>A</STATUS>
<STARTTIME>11/01/1999 11:15:00</STARTTIME>
</RECORDING>
</INTERVAL>
</CUT>
</INTERVAL DATA>
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XML Standard File Format DTD

The Data Type Definition for the Oracle Utilities Standard XML format is shown below.
<IDOCTYPE INTERVAL_DATA

[

<IELEMENT INTERVAL_DATA (INTERVAL_DATA_FORMAT, VERSION, DECIMAL_POINT,
DATETIME_FORMAT, INTERVAL_CUT+)>

<IELEMENT INTERVAL_DATA_FORMAT (#PCDATA)>
<IELEMENT VERSION (#PCDATA)>

<IELEMENT DECIMAL_POINT (#PCDATA)>
<IELEMENT DATETIME_FORMAT (#PCDATA)>

<IELEMENT CUT (RECORDER, CHANNEL, STARTTIME, STOPTIME, DST_PARTICIPANT,
METER_START_READING, METER_STOP_READING, METER_MULTIPLIER,
METER_OFFSET, PULSE_MULTIPLIER, PULSE_OFFSET, SPI, UOM, TIMEZONE,
TIMESTAMP, ORIGIN?, DC_FLOW?, POPULATION?, WEIGHT?,
TIME_ZONE_STANDARD_NAME?, DESCRIPTOR?, ACCEPT_REJECT_STATUS?,
TRANSLATION_DATE?, INTERVAL)>

<IELEMENT RECORDER (#PCDATA)>
<IELEMENT CHANNEL (#PCDATA)>

<IELEMENT STARTTIME (#PCDATA)>

<IELEMENT STOPTIME (#PCDATA)>

<IELEMENT DST_PARTICIPANT (#PCDATA)>

<IELEMENT METER_START_READING (#PCDATA)>
<IELEMENT METER_STOP_READING (#PCDATA)>
<IELEMENT METER_MULTIPLIER (#PCDATA)>
<IELEMENT METER_OFFSET (#PCDATA)>

<IELEMENT PULSE_MULTIPLIER (#PCDATA)>
<IELEMENT PULSE_OFFSET (#PCDATA)>

<IELEMENT SPI (#PCDATA)>

<IELEMENT UOM (#PCDATA)>

<IELEMENT DC_FLOW (#PCDATA)>

<IELEMENT TIMEZONE (#PCDATA)>

<IELEMENT POPULATION (#PCDATA)>

<IELEMENT WEIGHT (#PCDATA)>

<IELEMENT TIME_ZONE_STANDARD_NAME (#PCDATA)>
<IELEMENT DESCRIPTOR (#PCDATA)>

<IELEMENT TIMESTAMP (#PCDATA)>

<IELEMENT ORIGIN (#PCDATA)>

<IELEMENT ACCEPT_REJECT_STATUS (#PCDATA)>
<IELEMENT TRANSLATION_DATE (#PCDATA)>
<IELEMENT INTERVAL (RECORDING+)>

<IELEMENT RECORDING (VALUE, STATUS?, STARTTIME?)>
<IELEMENT VALUE (#PCDATA)>

<IELEMENT STATUS (#PCDATA)>

<IELEMENT STARTTIME (#PCDATA)>

]>
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XML Compact Format

The XML “compact” format is an XML format used with interval data that has a smaller
footprint than the XML standard format. The compact format is the same format used by the
LSINTD Interval Data component, and can be used with the Oracle Utilities Adapter. See the
Oracle Utilities Energy Information Platform Users Guide and Oracle Ultilities Energy Information Platform
Installation and Configuration Guide for more information about the Oracle Utilities Adapter.

XML Compact File Format Examples

The following is an example of a standard interval data cut defined in the XML compact format.

<CUTS>
<CUTEX>
<HEADER
RECORDER="1700"
CHANNEL="1"
STARTTIME="2003-02-24 00:00:00"
STOPTIME="2003-02-24 23:59:59"
START_READ:15000
STOP_READ=17500
M MULT=1
M _OFFSET=0
SPI="1800"
uoM="1"
DESC="Pre-validation"]
DCFLOW="D"
ARS="00"
TZSN="EST"
ORIGIN="M"
DST="Y"
CHNSTATUS="0" />
<INTS>
<I Vv=12.00 8=" " E=" "/>
<I Vv=13.00 s=" " E=" "/>
<I v=14.00 s=" " E=" "/>

</INTS>
</CUTEX>
</CUTS>

Below is an example the compact XML format user to import data into an enhanced/generic
interval data table that includes the CALCGROUP, MINIMUM, and MAXIMUM custom

columns.

<CUTS>
<CUTEX>
<HEADER TIMESERIES="TEST,1" SPI="900" UOM="1" DST="Y" STARTTIME="2006-12-12
00:01:00" STOPTIME="2007-01-10 23:59:59" TDATE="1969-12-31 19:00:00" ORIGIN="C"
DCFLOW="" ARS="" START READ="0.0" STOP_READ="0.0" POP="0.0" WEIGHT="0.0"
M OFFSET="0.0" M MULT="0.0">
<CUSTOM CALCGROUP="1" MAXIMUM="10" MINIMUM="-10" />
</HEADER>
<INTS>
<I v="16" S="7" />
<I v="18" s="7" />
<I v="16" sS="7" />
<I v="18" s="7" />
<I v="15" s="7" />
<I v="18" s="7" />
<I v="16" S="7" />
<I v="21" s="7" />
<I v="20" sS="7" />
<I v="17" s="7" />
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</INTS>
</CUTEX>
</CUTS>

Below is a similar example that includes a category.

<CUTS>
<CUTEX>
<HEADER TIMESERIES="PERCOT,1l" CATEGORY="RAW" UOMCODE="01" STARTTIME="2005-
12-03T00:00:00" STOPTIME="2005-12-03T23:59:59" SPI="3600" DST="Y" P MULT="1.0"
P OFFSET="1.0">
<CUSTOM CALCGROUP="1" MAXIMUM="1" MINIMUM="1"/>

</HEADER>
<INTS>
<I v="2850" S=" " />
<I v="3150" S=" " />
<I V="2850" s=" " />
<I v="3150" S=" " />
<I v="2850" S=" " />
<I v="3150" S=" " />
<I v="2850" S=" " />
<I v="3150" S=" " />
<I V="2850" s=" " />
<I v="3150" S=" " />
<I v="2850" S=" " />
<I Vv="3150" S=" " />
<I v="2850" S=" " />
<I v="3150" S=" " />
</INTS>
</CUTEX>
</CUTS>

XML Compact File Format Element and Attribute Descriptions

The elements and attributes of the XML compact format are described below. All attributes
correspond to elements described under Standard XML Format on page C-2. Defaults are
inserted when the processing program encounters an omitted attribute.

CUTS: Optional element containing one or mote CUTEX elements.
CUTEX: Element containing a single interval data cut.
Elements:

HEADER: Element containing header information for the interval data cut contained in the
parent CUT element.

Attributes:

* RECORDER (key attribute): Recorder ID for the interval data cut. See RECORDER
(key element) on page C-4 for detailed information.

*  CHANNEL (key attribute): Channel number for the interval data cut. See CHANNEL
(key element) on page C-4 for detailed information.

*  TIMESERIES (key attribute): Identity of the parent record of the interval data. Used in
place of the RECORDER and CHANNEL elements when defining interval data stored
in enhanced interval data tables.

*  CATEGORY: Optional category of the interval data. Used only with interval data
stored in enhanced interval data tables..

*  STARTTIME (key attribute): Start time for the interval data cut. Must be in ISO
datetime format. See STARTTIME (key element) on page C-4 for detailed
information.

*  STOPTIME: Stop time for the interval data cut. Must be in ISO datetime format. See
STOPTIME on page C-5 for detailed information.
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TIMESTAMP: (optional) Timestamp of the interval data cut. Must be in ISO datetime
format. See TIMESTAMP on page C-10 for detailed information.

START_READ: (optional) Meter start reading for the interval data cut. See
METER_START_READING on page C-6 for detailed information.

STOP_READ: (optional) Meter stop reading for the interval data cut. See
METER_STOP_READING on page C-6 for detailed information.

M_MULT: (optional) Meter multiplier for the interval data cut. See
METER_MULTIPLIER on page C-6 for detailed information.

M_OFFSET: (optional) Meter offset for the interval data cut. See METER_OFFSET
on page C-7 for detailed information.

POP: (optional) Population for the interval data cut. See POPULATION on page C-9
for detailed information.

WEIGHT: (optional) Weight for the interval data cut. See WEIGHT on page C-9 for
detailed information.

SPI (Seconds per Interval): SPI for the interval data cut. See SPI (Seconds per
Interval) on page C-7 for detailed information.

UOM (Unit of Measure): UOM for the interval data cut. See UOM (Unit of Measure)
on page C-8 for detailed information.

DESC: (optional) Descriptor for the interval data cut. See DESCRIPTOR on page C-
10 for detailed information.

DCFLOW: (optional) DC Flow for the interval data cut. See DC_FLOW on page C-8
for detailed information.

ARS: (optional) Accept-Reject-Status for the interval data cut. See
ACCEPT_REJECT_STATUS on page C-11 for detailed information.

TDATE: (optional) Translation Date for the interval data cut. See TRANSLATION
DATE on page C-11 for detailed information.

TZSN: (optional) Time Zone Standard Name for the interval data cut. See
TIME_ZONE_STANDARD_NAME on page C-10 for detailed information.

ORIGIN: (optional) Origin for the interval data cut. See ORIGIN on page C-10 for
detailed information.

DST: (optional) DST participant flag for the interval data cut. See
DST_PARTICIPANT on page C-5 for detailed information.

CHNSTATTUS: (optional) Status code for the interval data cut.

Elements:

CUSTOM: Used to define custom columns added to enhanced/generic interval data
tables. The format of this element is:

<CUSTOM <fieldname>=<value>/>

where:

*  <fieldname> is an attribute that is the name of the custom column

*  <value> is the value to be imported into the custom column

The <fieldname> attribute can be repeated for multiple custom columns.

For example, the following <CUSTOM?> element includes import values for the
CALCGROUP, MAXIMUM, and MINIMUM custom columns:

<CUSTOM CALCGROUP="1" MAXIMUM="10" MINIMUM="-10" />
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Interval Values

The interval values data is enclosed within the <INTS> node. Each individual interval value is
enclosed within the <I> node, and consists of the V (Value) and optional S (STATUS) attributes.

INTS: Element containing interval values.
Elements:

I: Element containing a single interval value. The I node will not have an S attribute if and
only if the interval status is a space.

Attributes:
*  V (Interval Value): the actual recorded value for the interval
* S (Status Code): The status code for the interval

* E (Extended Status Code): The extended status code for the interval
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Appendix D

Oracle Utilities Comma Separated Values (CSV)
Interval Data Format

This appendix provides a detailed description of the Oracle Utilities Comma Separated Values
(CSV) Interval Data Format, supported in Oracle Ultilities programs such as Oracle Utilities Load
Analysis, Oracle Ultilities Billing Component, Oracle Utilities Rate Management, and Data
Manager. This includes:

¢ CSV Format
¢ Format Details

. Sample CSV File
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CSV Format

This format is designed to support:
*  Mixed interval lengths among cuts
*  Daylight Savings Time

* International date and value formats (via tab characters for separators); the specific formats
of dates and decimal values are solely dependent on the operating system in use.

*  The possibility of a future enhancement for non-fixed interval lengths within cuts (with the
use of Time tags for each interval).

The times that are defined in the export format will be expressed in the format designated by the
Short Date and Short Time settings on the operating system. The language indicator and the
decimal separator will also be read from the operating system. In all likelihood, the recipient of the
export file generated by the producing Oracle Utilities application will be sharing the same
language environment, so date and decimal format translation would not be necessary. If format
translation is necessary, the date format, decimal separator, and language indicator found in the
document description record of the export file could be used to translate the date and decimal
formats to the desired format representation. The format translation that occurs in this scenatio
becomes solely the responsibility of the user, unless a future specification overrides the
responsibility explicitly.

The format consists of two sections of data. The first section describes the export file format
version and the regional settings. The second section contains data that appears in the same exact
sequence as data would appear in the .LSE format, except that the data is separated by a semi-
colon.
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General Description

Records in the CSV format ate defined as a seties of tab/comma/delimiter separated values
followed by a catriage return/line feed pair. Each record begins with a record tag field that
identifies that record type.

General Rules

Order
Within each section, proper ordering is mandatory. Records in the Header and Detail sections
should arranged in the order as described in Format Details on page D-13. Trailing empty or null
fields in any record cannot be omitted.

Fields

All fields, regardless of whether they are required or optional, must be enclosed with double
quotation marks. Use the empty string to represent empty fields (“”).

Import Capability
The CSV Format file (*.CSV) differs from an Enhanced Oracle Utilities (*.LSE) file in two main
respects.

*  First, it contains a document desctiption record that provides a date format and a time
format. This record also contains a decimal separator, and the operating system 3-character
locale identifier. Data can be re-imported from this file by translating the export date/time
and decimal layouts to the appropriate format.

*  Second, the data is formatted according to the date/time and decimal format that is specified
in the document description record (see below).
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Document Description Record

The document description record contains the CSV format version, and the regional setting

information. This required single record must precede all others in the export file. All fields within

this record are required. The version number used should be related in some fashion to the

version of the specification that defines the export format (e.g. 2.2). This version number must be

changed when a syntactical change in the export format occurs for any reason. The importable

option can be used to signify that a standard Application Program Interface (API) can process the
data in this file.

[00000000] [Document Type Identifier][Field Delimiter] [Export Version] [Field

Delimiter] [Decimal Point Character] [Field Delimiter] [Language Indicator] [Field
Delimiter] [Date/Time Format] [Field Delimiter] [CSV Version] [Record Delimiter]

Notes:

The [Field Delimiter] is defined to be the character immediately following the first sequence
that consists of a double quotation mark, followed by eight consecutive zero characters and
then another double quotation mark (“00000000”). Characters preceding the first instance of
this sequence are considered to be superfluous, and should be ignored. The [Field Delimiter]
is most often a comma, but can be any delimiter character, or even non-printing characters
such as the Tab character.

The [Document Type Identifier] identifies the format of the file.

The [Export Version]| references the version of this document that the export was generated
from. No assumptions about forward and/or backward compatibility can be assumed when
comparing export files generated at differing versions. Likewise, CSV files with identical
versions are said to be structurally compatible.

The [Decimal Point Character] cannot be the same character as the [Field Delimiter|. Should
a conflict occur in the generation of the CSV file, the Decimal Separator takes precedence
over the [Field Delimiter]. So, in case of a conflict, the [Field Delimiter] would be forced to
change to an alternate character. Non-printable characters such as the tab character can be
used in the place of commas, but please be aware that delimiters that differ from commas and
semicolons may not be imported to some spreadsheets easily.

The [Language Indicator] is the unique 3-character abbreviation for a locale as defined by the
operating system.

The [Date/Time Format] is expressed as a string consisting of a sequence of date and time
elements strung together to form a date/time format (for example, mm/dd/yyyy hh:mm:ss).
Predefined date/time format strings such as “Short Date” and “Short Time” are not legal
formatting strings for the export format, because these formats are always relative to the
operating system settings of the machine that generated the export, and therefore could not
be determined from another computer.

The carriage return/line feed pair is always the [Record Delimiter]. Neither the [Field
Delimiter], nor the [Decimal Separator| can be either a carriage return or a line-feed character.

Field Relationships and Requirements

Relationships between fields exist in the CSV format. These are described along with detailed field
requirements in this section. Defaults are inserted when the processing program encounters an

omitted field (indicated by double commas) or white space between commas.

Sort Code

Relationships:
This field has no relationship with any other field.
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Requirements:
*  Sort codes must contain eight digits, including leading Os. Sort codes are restricted to integers
between 00000000 and 99999999. However, 00000005 through 09999999 are not used, and
may be ignored (see below).

Note: Sort code 00000000 can used only in the Document Description record.
*  Leading white space before the sort codes is not allowed.
*  The first three header records are required. The fourth header record is optional.
*  The document description record starts with sort code 00000000.
*  Header records will have sort code 00000001 through 00000004.
*  Column 1 of each header record must contain a 0.

*  Records with Sort codes 00000005 through 05000000 are reserved. Records with Sort codes
05000001 through 09999999 may be present, but will be ignored.

*  Data records must start with sort code 10000000, and progress sequentially (i.e. 10000001,
10000002...) through 99999999, or as high as needed to accommodate the data, with the
maximum of 99999999.

*  Column 1 of the data records must be greater than 0.

Recorder/Customer Identifier (key element)

Relationships:
None.

Requirements:
*  Only letters, numbers, underscores, and hyphens will be accepted in this field; all other
characters and embedded blanks will cause the record to be rejected.

Note: Lowercase letters will be translated to uppercase before they are stored
in the database.

*  Must be at least one character, and no more than 64 characters in length.

Default:

None; field is required.

Channel (key element)

Relationships:
None.

Requirements:
*  Tield values must be non-negative integer only.

e Maximum value is 32767.

Default:

None; field is required.

Start Time (key element)

Relationships:
*  Must be a valid date/time value less than the value of the Stop Time.
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Requirements:
*  The date format has no limitations: it is defined in the Document Description Record
Format on page D-13.

*  The date itself must correspond to acceptable date ranges of the product in use (Data
Manager, Oracle Ultilities Billing Component, and other non-Oracle Utilities Load Analysis
applications, as well as Oracle Utilities Load Analysis).

*  No spaces, colons, or any ASCII value allowed between time components.

Default:

None; field is required.

Stop Time

Relationships:
*  Must be a valid date/time value greater than the value of the Start Time.

*  Value must agree with the number of interval values past the start time * SPI.
*  One second is subtracted if the value is equal to an even interval start time.

Requirements:
See Start Time.

Default:

None; field is required.

DST Participant Flag

Relationships:
None.

Requirements:
Valid values are Y, N, or A, indicating whether or not this record will be processed using DST
adjustments.

Flag Value Definition

Y (DST Participant) The intervals recorded participate in DST adjustments
and the intervals during DST reflect the time change.

N (Does not participate in DST) The intervals recorded do not make any DST
time changes.

A (DST participant) The intervals have been adjusted to 24-hour days. (At the
April time change, there should be a value at the time change (a place
holder) of 0 with status code “9”. At the October time change, there should
be a combined value.) These cuts will be converted to a “Y” or “N”, and are
not stored in the database as “A”.

Default:
As specified in the INTDDEFAULTDST configuration parameter setting, the
INTDCONFIG.XML file, or the CSDST value in Oracle Utilities LLoad Analysis.
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Invalid Record Flag

Relationships:
None.

Requirements:
Valid values are Y or N, indicating whether or not the input programs should validate the
incoming record.

Flag Value Definitions

Y The incoming record contains unvalidated data.
In Oracle Utilities Load Analysis, a value of Y can be used to run this record
through the validation routines.

N The incoming record contains valid data (mark as valid).

Default:
Y.

Meter Start Reading

Relationships:
Must be supplied if any of the other Meter fields (Meter Stop Reading, Meter Multiplier, or Meter
Offset) are supplied.

Requirements:
If supplied, value must be a non-negative numeric value.

Default:

Meter Stop Reading

Relationships:
Must be supplied if any of the other Meter Fields (Meter Start Reading, Meter Multiplier, or Meter
Offset) are supplied.

Requirements:
If supplied, value must be a non-negative numeric value.

Default:
0 (not supplied).
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Meter Multiplier

Relationships:
Must be supplied if any of the other Meter fields (Meter Start Reading, Meter Stop Reading, or
Meter Offset) are supplied.

Requirements:
If supplied, value must be positive numeric. However, if no value is specified, 0 will be stored.
Zero (0) is not a valid value for the meter multiplier, but its presence in the database indicates that
no meter multiplier was supplied.

Default:
None, 0 stored in the database if not supplied.

Note: If 0 is stored and/or observed in the database and a cut is exported to the LSE format, all
meter fields for that cut will be absent. A zero stored in the database is indicative of “no meter
information supplied”.

Meter Offset

Relationships:
Must be supplied if any of the other Meter fields (Meter Start Reading, Meter Stop Reading, or
Meter Multiplier) are supplied.

Requirements:
If supplied, value must be numeric.

Default:
0 (not supplied).

Pulse Multiplier

Relationships:
None.

Requirements:
Value must be positive numeric. Also, must be supplied if Pulse Offset (see below) is supplied.

Default:
None, 0 stored in the database if not supplied.

Note: If 0 is stored and/or observed in the database and a cut is exported to the LSE format, all
pulse fields for that cut will be absent. A zero stored in the database is indicative of “no pulse
information supplied”.

Pulse Offset

Relationships:
If supplied, you must also supply Pulse Multiplier.

Requirements:
Value must be numeric.

Default:

None.
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Seconds Per Interval (SPI)

Description:
This field will store the interval duration if appropriate. An Intervals Per Hour (IPH) of 1 can be
translated to a Seconds Per Interval of 3600.

Relationships:
Value of 0 indicates non-uniform recording duration and a full array of interval start values (one
per recording) located in the data section. (This feature will be supported in a future release and is
not currently available.)

Requirements:

*  Value must be a positive integet.

e Valid values for SPT are 86400, 3600, 1800, 900, 300, and 60.
Default:

None; field is required.

Unit of Measure
The Oracle Utilities products will accept Units of Measure (UOMs) that ate one to three digits in
length. The Units of Measure on page B-16 are the ones supplied by Oracle.

Description:
See Units of Measure on page B-16.

Relationships:
None.

Requirements:
e Value should be a valid Unit of Measure, or a user-defined one. If the value entered is
unknown to, 16 (Miscellaneous) will be stored.

*  Value must be non-negative numeric.

*  Maximum value is 32767.

Default:

None; field is required.

Basic Unit Code

Description:
This field is reserved for future use.

Relationships:
None.

Requirements:
Omit this field.

Default:
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Times Zones West of GMT

Description:
This value tells programs accessing this record which time zone the values have been recorded in.
Its value will be the difference in time, heading west, between Greenwich Mean Time and the
represented time zone as measured in half hours. Eastern Standard Time should have a value of
10; Pacific = 16. A Value of -1 will indicate ‘““Time Zone not available.”

Relationships:
None.

Requirements:
Value must be -1 or a non-negative numeric between 0 and 47, that represents the time zones West
of GMT measured in half-hour increments. Any record containing a time zone greater than 47 will
be rejected.

Default:
-1.

Population

Description:
For Oracle Ultilities Load Analysis Statistical records only.

Relationships:
None.

Requirements:
Value may be any non-negative integer value.

Default:

0.
Weight
Description:

For Oracle Utilities Load Analysis Statistical records only.

Relationships:
None.

Requirements:
Value may be any non-negative numeric value.

Default:
0.0.

Time Zone Standard Name

Description:
Defines the Time Zone to which the cut is associated. The value must be one of EST, CST, MST,
PST, or be defined in the LSCALENDAR.XML configuration file. Each value in this field must
contain printable ASCII characters no longer than 32 bytes.

Only letters, numbers, underscores, and hyphens will be accepted in this field, all other characters
and embedded blanks will cause the record to be rejected.
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Note: Lowercase letters will be translated to uppercase before being stored

Relationships:
Must map exactly to one of EST, CST, MST, PST or an entry in the LSCALENDAR.XML file.
Oracle Utilities Load Analysis will import without checking this file.

Requirements
Length: <= 32 bytes

Descriptor

Description:
The user may enter any descriptive information in this field. Any information entered into this
field will be stored in the database verbatim as supplied.

Relationships:
None.

Requirements:
*  Value must be 80 characters or fewer, and may contain commas.
*  May start with blanks.

e If more than 80 characters are entered, truncation will occur and the first 80 will be used.

Timestamp

Relationships:
None.

Requirements:
*  Format should be YYYYMMDDHHMMSSmmm. The milliseconds (mmm) may be omitted,
in which case mmm will be set to 000.

*  No spaces, colons, or any ASCII value allowed between time components.

Default:
Current time that data is loaded into database.
Note: It is strongly recommended that you leave this field empty and allow the system to input
the TimeStamp for you.

Origin

Relationships:
None.

Requirements:
Must be one of: M (metered), P (profiled), C (computed), or S (Oracle Utilities Load Analysis
Statistic).

Default:
M (metered).
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Interval Value

Description:
This field contains the actual recorded value for a time period.

Relationships:
Must have one status code entry per interval data value.

Requirements:
Any numeric value. (Up to 15 significant digits can be stored.)

Default:
0 (see Status Code, Relationships, below).

Status Code

Description:
This field contains the status code for the preceding Interval Value.

Relationships:
Must have an entry for the Interval Value.

Requirements:
Any character will be accepted.

Default:
*  This field defaults to a blank (*”) when omitted if the interval value is present.

e This field defaults to ‘9” when the Interval Value field is omitted.

Interval Start

Description:
*  This field indicates the starting time of the recording or the time when the recording took
place.

*  Format must be YYYYMMDDHHMMSS. (This feature will be supported in a future release
and is not currently available.)
Relationships:
*  Until this feature is supported, the SPI may not be omitted (represented by ,,).
*  There must be one entry per Interval Value.

Requirements:
See Start Time, Requirements.

Default:

None.
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Format Details

Document Description Record Format

MAXIMUM LENGTH IN
ELEMENT DESCRIPTION BYTES (if applicable) COMMENT

1 Sort Code 8 Must be 00000000 (Note:
Character that immediately
follows is the Field

Delimiter.)
2 Document Type 1 LODESTAR Interval Data CSV
ID format
3 Version N/A 2.2
4 Decimal 1 Usually “.” or “,”
Separator
5 Locale 5 Defined by OS
Abbreviation
6 Date/Time N/A Date/Time format string
Format
First Header Record Format
MAXIMUM LENGTH IN
ELEMENT DESCRIPTION . . COMMENT
BYTES (if applicable)
1 Sort Code 8 Must be 00000001
2 Recorder/ [ Letters, numbers, hyphens or
Customer underscores are acceptable
Identifier values
3 Channel 5 Max is 32767
4 Start Time N/A Cut start date and time
5 Stop Time N/A Cut stop date and time
6 DST Participant 1 Y/N/A
Flag
7 Invalid Record 1 Y/N
Flag

Oracle Utilities Comma Separated Values (CSV) Interval Data Format D-13



Format Details

Second Header Record Format

MAXIMUM LENGTH IN

ELEMENT DESCRIPTION . . MMENT
s¢ o BYTES (if applicable) co
1 Sort Code 8 Must be 00000002
Default: None; field
required
2 Meter Start N/A Non-Negative Numeric
Reading Max: 999999999999999.9999
Default: 0
3 Meter Stop N/A Non-Negative Numeric
Reading Max: 999999999999999.9999
Default: 0
4 Meter N/A Positive Numeric (Optional)
Multiplier Max: 999999999999999.9999
Default: 0
5 Meter Offset N/A Numeric (Optional)
Max: 999999999999999.9999
Default: O
[ Pulse N/A Positive Numeric (Optional)
Multiplier Max: 999999999999999.9999
Default: O
7 Pulse Offset N/A Numeric (Optional)
Max: 999999999999999.9999
Default: None; field
required
8 Seconds Per N/A Positive Numeric
Interval (SPI) Default: None; field
required
9 Unit of Measure N/A Numeric Max: 32767
Default: None; field
required
10 Basic Unit Code N/A Positive Numeric (Optional)
Max: 9999
Default: O
11 Time Zones West N/A Numeric. (Optional)
of GMT Default: -1
Min: -1
Max: 47
12 Population N/A Positive Numeric (Optional)
Max: 999999999999999.9999
Default: 0.0
13 Weight N/A Positive Numeric (Optional)
Max: 999999999999999.9999
Default: 0.0
14 Time Zone Character (32) (Optional)
Standard Name If present, must be one of
“EST”, “CST”, “MST”, “PST”,

or definition must exist in
LSCalendar.xml file.
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Format Details

Third Header Record Format

MAXIMUM LENGTH IN

ELEMENT DESCRIPTION BYTES (if applicable) COMMENT
1 Sort Code 8 Must be 00000003
2 Descriptor 80

Fourth Header Record Format

MAXIMUM LENGTH IN

ELEMENT DESCRIPTION BYTES (if applicable) COMMENT
1 Sort Code 8 Must be 00000004
2 Timestamp 17 YYYYMMDDHHMMS SMM
(optional)
Default: current date
3 Origin 1 C, M, P, or S (optional)
Data Record Format
ELEMENT DESCRIPTION “Bn#él\gu(':’fl Ia-sr';lllcc;:?;l::; COMMENT
1 Sort Code 8 10000000 through 99999999
2 Interval Value Interval value in locale-
format
3 Status Code 1
4 Interval Start N/A See Note 2
5 Interval Stop N/A See Note 2
Notes

1. A data line may contain as many full data-status-time groups as desired, providing the record
does not exceed a character count (record length) of 1024.

2. When this file is generated, the interval start time is always required. The interval stop time is
required only for partial intervals.

3. Data spanning time must be contiguous and “missings” (or gaps) must be represented by
p g g g gap p y

value 0 and status '9". For fixed-length SPIs, all intervals must be of the same duration,

including “missings”. Only single intervals can appear in a single record.
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Sample CSV File

Sample CSV File

A sample *.CSV file appears below:

"00000000"™, "LODESTAR Interval Data CSV Format","2.2",".","USE","mm/dd/yyyy
hh:mm:ss"

"o0o000001","N1732","17","01/01/2000 00:00:00","01/31/2000 23:59:59","y","y"
"00000002","12.34","1234.56","1.0","100","2.0","0","900", "O4"™, """, "=1", """, ", "
"00000003","", "ACCEPTANCE TEST DATA NUMBER 1"

"ooooo004", """, "M"

"10000000","31","Q","01/01/2000 00:00:00",""
"10000001™,"32","Q","01/01/2000 00:15:00",""
"10000002","33","Q","01/01/2000 00:30:00",""
"10000003","34","Q","01/01/2000 00:45:00",""
"10000004™,"32","Q","01/01/2000 01:00:00",""
"10000005","30","Q","01/01/2000 01:15:00",""

Differences with the .LSE format

Field Delimiters

Field Types

There are a number of significant differences between the *.L.SE format and the *.CSV format.
These differences include:

*  Field Delimiters

*  Field Types

*  Document Description Record

* Date, Time, and Decimal Value Representation in Records

. Interval Data Records

Field delimiter in the CSV format is defined to be the character that immediately follows the first
sort code (“00000000”) in a file. They can be cither printable or non-printable. The LSE format
always uses a comma ().

All fields in the CSV format must be enclosed in double quotation marks, regardless of the
apparent data type. The LSE format doesn't requite this.

Document Description Record

The first record in a CSV file is always the document description record which always has a sort
code of “00000000”. This tecord provides date/time and decimal formats and locale information,
as well as a version number so incompatibility can be determined. The LSE format doesn’t include
this record.

Date, Time, and Decimal Value Representation in Records

All date, time, and decimal data in the CSV format uses the date/time and decimal format as
defined in the document description record. The LSE file uses a specific decimal and time format.

Interval Data Records

The interval start time is required for CSV files, but not for the *.LSE format. Also, only a single
interval value can be expressed in a record in CSV files. The interval data record contains an
optional interval stop field that can be used to designate a partial interval.

D-16 Data Manager User’s Guide



Compatibility Issues

Compatibility Issues

All export files, including CSV files, have export format versions. Export files with different
version numbers are inherently incompatible. A mapping algorithm is required to convert export
files from one version to another. Any APIs created to read these CSV files must consult the
export format version as basis for reading the files correctly. APIs should be flexible enough to
react accordingly to older versions and use the proper mapping mechanism. A parser built to read
a specific CSV format does not imply that it can automatically read an eatlier version.

Oracle Utilities Comma Separated Values (CSV) Interval Data Format D-17



Compatibility Issues
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Full Day Billing flag 5-8

Fully Automatic billing mode 5-8, 5-9

G

General tab on Report Options window 9-2
Generic Riders 5-10
global billing mode

setting 10-11
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LOAD FACTOR 9-3
Locales 1-8
LODESTAR Data tab 5-20
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Meter Offsets 3-7

Meter Value Table 1-5, 5-18
Meter-Level Overrides 5-16

Meters 1-3, 1-4

Minimum field 6-9

Minimum Printed Line Width 2-10
Multiple Currency Support 1-8, 1-11

Oracle Utilities Receivables Component 1-11
Oracle Utilities Receivables Component Reports 1-11

Other Oracle Utilities Products 1-11
MVLOADLIST function 8-9
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Peak Date & Time 5-20
Peak Values tab 5-20
PLIMPORT Utility 6-6
POWRLINEUSER directory 5-12
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Print Detail 9-3
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all 5-8, 9-3
default 9-3
none 5-8, 9-3
normal 5-8, 9-3
Print Detail field 5-8
Print Detail option 9-3, 9-4
Definition of 9-3
Print Detail Options 9-3
overriding 9-3
Print Detail Options on Report Options window 9-3
Print Detail Options setting 9-3
Print Detail tab on Report Options window 9-3
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Problem determination options 9-2
Problem Determination tab on Report Options window 9-4
Proprietary file format 1-2
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Pulse Multiplier column 5-12
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Pulse Offset field 6-9
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Rate Code field 5-7
Rate Code History 5-9
Rate Code History Table 8-16
Rate Code History Table, in billing options 10-13
Rate codes 1-3
Rate form record 1-5
Rate Form Version selection box 10-2
Rate Forms Table 10-15
Rate History tab 5-9
Rate Schedule 5-9
Rate schedule 1-5
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Rate schedule type 10-2
Rate Schedule/Rate Code column 5-9
RATECODE Table 10-15
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Reading Stop 5-20
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Ready Use Flag tab 5-14
Record Count 3-2
Record Pane 6-3
Browser 7-4
of Browser window 6-3
Recorder
definition 1-4
Recotder ID 5-7, 5-19, 5-20
Logical 5-12
Recorder ID/Channel 5-12, 5-13, 5-18
Recorder/Channel information 1-3
Recorder/channels 1-4
Recorder/Cust ID field 6-8
Recorder-channels 1-3
RECORDERID 8-10
Recorders 1-3, 1-4
Records
deleting 2-5
export/delete 2-5
exporting 2-5
records
filtering 4-2
Records Menu 4-2
Records to Log 3-3
Referenced lookup records 4-4
Referenced parent records 4-4
Refresh list before using 10-10
Relational format 1-2
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Removal
recorder/channel 5-12
Report 10-4
Report components 9-3
descriptions 9-3
Report options 9-2
saving 9-2
setting 9-2
Report Options button 3-3, 3-8, 10-10
Report Setting records 2-23
Report Settings 2-23
Report statements 5-8
Report Titles
adding 9-2
Reports
saving 9-2
Req for billing column 5-12
Rev Code field 5-7
Revenue Months
in Season schedules 7-7
Review Billing Exceptions 5-10
Rider
definition 1-5
Rider column 5-10
Rider History 5-10
Rider History Table 5-10



Riders 1-5
Round Revenue 2-11
Rules Language 1-5
Color Format 2-19
Rules Language Editor 1-7
Rules Language Editor 2-3, 2-4
Rules Language label 5-8
Rules Language Label and Report statements 9-3
Rules Language statements 1-5

S

Save Season Schedule box 7-7
Saving Reports to Files 9-2
Scalar data 1-4, 5-13
Schedule Name field 7-9
Schema
database 6-6
Search tab
online help 2-20
Season Schedule 1-6
Season Schedule dialog box 7-7
Season Schedule Export File 7-10
Season Schedule listbox 7-9
SEASON_SCHEDULE_NAME identifier 2-11
Select 10-2
SELECT BILL_PERIOD statement 7-7
Select By 10-2
Select Interval Data window 6-11
Select Rate Code 10-3
Select Rate Form 10-2
Select Rate Schedule 10-2
Select season file for export dialog box 7-8
Select season schedule file for import dialog box 7-8
Select time of use file for export dialog box 7-9
Select time of use file for import dialog box 7-11
Set Filter dialog 6-4
Set Ready Flag button 5-15
Setting and saving report options 9-2
Setting up a new account for billing 5-1
Setting up Data Manager 2-1
Shortcut
"jumping" from an open report to another module 2-22
Show Bill records to Save (BillHistory, CSS, etc) 9-4
Simple report values 9-4
Single Step 10-4
Single Step Analysis 10-4
Single Step button 10-4
Special Event column 5-15, 5-16
Special Event History tab 5-16
Special Event History tab page 5-16
Special Event Override 5-15
Special Event Overrides 5-14
Special Event overrides 5-14
Special Event Pre-Window column 5-15
Special Events 5-3
Special Events Period 10-10
Special Events Report Input dialog box 10-10
Specify the level of detail in a bill report 9-3
Specifying the level of detail in a CIS transaction record 9-3
SPI 3-7
SPI field 6-8

Spreadsheet-like tables 5-5
Standard Direct Input File B-15
Start and Stop readings 3-7
Start Time 5-9, 5-20
Start Time column 5-9, 5-15, 5-16
Status Codes 3-7
Status field 5-7
Stop analysis after ## errors 2-14
Stop Time 5-20
Stop Time column 5-9, 5-10, 5-15, 5-16
Stop with Error 2-14
Stop-dates 1-3
Storing
Customer IDs 1-3
IDs 1-3
Storing information
Data Repository 1-3
for large account billing 1-3
for rate design/analysis 1-3
String Value column 5-16
Sub-form
definition 1-5
Summary Bill field 5-11
System peak 1-5

T

Table.column
Selecting 8-17
Table.Column Lists and Rate Forms 8-9
Table.Column queries 8-9
Table-Column List dialog 8-12, 8-15
Tables
editing rows in 5-5
Update 5-5
Target Column 8-14
Target Column drop-down menu 8-12, 8-13, 8-14
Target Table 8-14
Target Table drop-down menu 8-12, 8-13, 8-14
Tariff riders 1-5
Test Petiod 2-11
Text
copying from one data entry field into another 2-22
Text String 5-16
Text-only file format 8-2
Time of Use Schedule 1-6
Time of Use schedules 7-7
Time-series data 1-2
Timestamp field 6-8
Title column 5-11
Toolbar 2-7
Total (not IPH/UOM corrected) field 6-9
Totalize
end use data 5-13
Totalize File (.ctl) 8-5
Totalizer Control file 8-5
TOU Schedule Export File 7-10
TOU schedules
Creating 7-8
TOU-based analysis 2-4
Trail Bill Calculation 10-4
Training new users 10-2
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Tree Pane 6-3

Browser 7-4
Tree structure

of Browser window 6-3
Trial 10-2
Trial Bill Calculation 10-4
Type field 6-8
Types of Schedules 1-6

U

UIDCHANNEL 8-9
UIDChannel column 8-9
UIDCHANNEL records 8-10
UIDRECORDER 8-9
Ungtroup button 8-18
Unique identifier (UID) 1-3, 8-9
Unit of Measure 1-6
Unit-of-Measure code 7-3
UOM 3-7, 5-12, 5-20
UOM column 5-17
UOM field 6-8
UOMCODE 8-9
UOMs 1-6
Update 7-7
Update button 7-7
Usage data

account 1-4
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