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Preface

Oracle's Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle Technology
Network (OTN) Web site http://www.oracle.com/technetwork/documentation/agile-085940.html
contains the latest versions of the Agile PLM PDF files. You can view or download these manuals
from the Web site, or you can ask your Agile administrator if there is an Agile PLM Documentation
folder available on your network from which you can access the Agile PLM documentation (PDF)
files.

Note To read the PDF files, you must use the free Adobe Acrobat Reader version 9.0 or later.
This program can be downloaded from the Adobe Web site http://www.adobe.com.

The Oracle Technology Network (OTN) Web site
http://www.oracle.com/technetwork/documentation/agile-085940.html can be accessed through Help
> Manuals in both Agile Web Client and Agile Java Client. If you need additional assistance or
information, please contact My Oracle Support (https://support.oracle.com) for assistance.

Note Before calling Oracle Support about a problem with an Agile PLM manual, please have
the full part number, which is located on the title page.

TTY Access to Oracle Support Services

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398.
Outside the United States, call +1.407.458.2479.

Readme

Any last-minute information about Agile PLM can be found in the Readme file on the Oracle
Technology Network (OTN) Web site http://www.oracle.com/technetwork/documentation/agile-
085940.html

Agile Training Aids

Go to the Oracle University Web page
http://www.oracle.com/education/chooser/selectcountry _new.html for more information on Agile
Training offerings.

Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an otherwise empty line;
however, some screen readers may not always read a line of text that consists solely of a bracket or
brace.

This documentation may contain links to Web sites of other companies or organizations that Oracle
does not own or control. Oracle neither evaluates nor makes any representations regarding the
accessibility of these Web sites.
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Chapter 1

About Export/Import Tool

This chapter includes the following:

B OVBIVIBW ..ottt s8££ R bR 1
= AssSUMPLONS AN CONSITAINES .......cviviviiicieisice ettt b s 2

This chapter provides overview information about the Agile Recipe & Material Workspace (RMW)
Export/Import tool.

Overview

Export and import operations are accomplished in two ways:
o From the Recipe & Material Workspace user interface (Ul), or

o Using Windows or Unix command-line interface (CLI); working in a CLI, the Export/Import utility
is called "ExIm".

Using the RMW Ul or ExIm, you can perform the following operations:

o Export information from an RMW development, test, or staging environment and import
information to an RMW production environment from the UL.

o Export or import information from the RMW application independent of the installation platform:
the export / import procedures can be executed from a client system on any supported
platform, using ExIm.

For information about supported platforms for Agile PLM, see the Agile PLM Capacity Planning
Guide.

o Import information in insert, update or delete mode using ExIm.

The export or import operation is a console-based operation. The export operation connects to the
RMW application and makes a request for the data to be exported. The application server retrieves
the requested data from the application’s database.

The export operation creates an XML file (cfmXML) with exported information at a location that you
can specify.

The information that is exported or imported includes metadata and related data present in the
application for the exported business object.

The import operation uses the exported information and updates the RMW application.

The output of an export operation is an XML file that contains the information you exported. The
import operation uses this XML file to perform the user-specified import operations like insert,
update, or delete.

v9.3.1 1
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RMW Administrator Cbjects

In addition to RMW business objects, you can export RMW Administrator objects:
8 Users

@ Sites

o Views

@ Roles

o Alerts

o Workflows

o ... and other Admin objects.

Assumptions and Constraints

Here are some assumptions and constraints about the ExIm tool.

o If primary key (PK) is capable of automatic sequencing (autosequence), the autosequence in
the target database for that PK is disabled by the import program and is enabled after the
import operation is completed. The disabling or enabling of PKs are done in memory and no
changes are made in the database.

o When migrating data that has autosequence attributes, the sequence number for the exported
attribute is extracted from the source database and updated in the target database, as long as
the autosequence value in the target database is less than that value in the source database.

For example, if the autosequence value for a record is 10 and this record is exported to a
database in which the highest autosequence value is 5, the autosequence value in the
destination database is reset to 10.

o |f afield is autosequence and is "non-PK", no validations are done against this field in the
target database, and the value will be inserted "as is".

o The autosequence value generation patterns in the source and target database have to be the
same for the PK autosequence attributes. If they are not the same, the import will be aborted.

For example, in the source database, if the pattern values for generating the autosequence is
EQP <000> where <000> represents a three-digit number, the target database should have
the same pattern: EQP_<000>.

o Auser can run more than one instance of the import program. If same autosequence attribute
is being inserted by multiple instances of the import program, only the first import will succeed
and others will be aborted.

@ Importing data is not possible when the target object definition does not match the source
object definition, for example, if the target category definition has a different number of columns
than the source category definition.

2 Agile Product Lifecycle Management



Chapter 2

Installation and Configuration

This chapter includes the following:

B DIFECIONY SHTUCIUIE ...ttt bbb e b bbb bbb bbbt en st 3
= Configuring EXpOrt/IMPOrt TOOI.........ciiiceeiiiceeiiets e bbb 3

This chapter provides information on the directory structure of component files in the Export/Import
tool, and installation and configuration processes.

Directory Structure

Recipe & Material Workspace must be installed in order to access the files that are required to
perform export/import operations. The files required to run export/import are located in the exim
folder within the RMW installation folder. The exim utility is run from the same server on which
RMW is installed.

The components of the exim folder are described in the table below.

Folder Name Description
bin Contains the . bat and . sh files for running export and import
procedures in Windows and Solaris, respectively.
config Contains the configuration files required for ExIm client to work.
config/locale Contains the locale files for ExIm client messages.
lib Contains the Java library (. jar) files used by Exim.
templates Contains the template files for the export operation.
templates/criteria Contains the criteria files for the export operation.
templates/schema Contains the schema files for exporting records using specific criteria.

templates/criteriaProperties Contains the properties files for the export operation.

Configuring Export/Import Tool

Before exporting or importing information from/to RMW, you must update the following:

@ Application server information in the following files:
® CFMConfig.xml file
*  Export or import command files

o Search criteria values in the template files.

v9.3.1 3
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Updating the CAVIConfig.xml Configuration Hle

Update the CFMConfig.xml file to include application server information. You must update this file
each time you connect to a different server.

To update the CFMConfig.xml file:

1.
2.

Open the CFMConfig.xml file available at /migration/config.

Specify the source server value if you are exporting information, or specify the target server
value if you are importing information:

<CFMProviderURL>t3://<server>:<port number></CFMProviderURL>

For example,
<CFMAppServerInfo>
<CFMInitialContextFactory>
Weblogic.jndi.WLInitialContextFactory
</CFMInitialContextFactory>
<CFMProviderURL>t3://localhost:7001</CFMProviderURL>
<CFMPrincipalUser>Weblogic</CFMPrincipalUser>
<CFMPrincipalUserPwd>
VvEFM5XvM57jLDvuvz0JROHxcP5WmpoC
</CFMPrincipalUserPwd>
</CFMAppServerInfo>
CFMAppServerInfo Details

Note Do not change the CFMInitialContextFactory tag value.
Update values for the following tags only if login information for the WebLogic server has
changed from the default value ‘Weblogic’:

<CFMPrincipalUser>
<CFMPrincipalUserbPwd>

Note If you are updating the Weblogic login information, then the WebLogic administrator
password must be encrypted, refer Password Encryption.

Save and close the CFMConfig.xml file.

Updating the Export or Import Command FHles

To update the WebLogic application server information in the export or import command file:

1. Fromthe AgilePharma/exim/bin/ folder, select the export or import command file you
want to update and complete the following:
2. For Windows, the files to be updated are export.bat or import.bat:
a. SetBEA=D:\bea\Weblogicl03\server\lib
(Change the path depending upon the location of the Weblogic.jar file on your machine)
b. SetJAVA HOME=D:\bea\jdkl60 14 R27.6.5-32
(Change the path depending upon location of this folder on your machine)
4 Agile Product Lifecycle Management
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Note ExIm tool requires the Weblogic. jar file to be present in the
home/bea/Weblogicl03/server/1ib folder to complete its operation.
Since ExIm is Java-based, it requires the path of Java home.
3. For UNIX, the files to be updated are export.sh or import.sh:

a. SetBEA=home/bea/Weblogicl03/server/1lib
(Change the path depending upon location of the Weblogic.jar file on your machine)

b. SetJAVA HOME=home/bea/jdkl160 14 R27.6.5-32
(Change the path depending upon location of this folder on your machine)

Note ExIm tool requires the Weblogic. jar file to be present in the
home/bea/Weblogicl03/server/1ib folder to complete its operation.
Since ExIm is Java-based, it requires the path of Java home.

4. Save and close the export or import command file.

Note Appropriate changes must be made to run ExIm client on OAS application server.

v9.3.1 5






Chapter 3

Schema, Criteria, and Qriteria Properties Hles

This chapter includes the following:

B SCNEMA FIIBS ...ttt b b a bbbttt b bbbt 7

# Updating TEMPIAE FIlES ......cucviveieirisiieis ettt s s s s e 11
B CHEEMIA FIlES ..uviii ettt bbb b et bbb bbb ee st bbbt bbbt s e anae bbb bans 12
B Criteria PrOPEIHES FlES .....c.cuiiiieieiiiicicecee ettt bbb ettt bbbttt aes 14

The main components used by the ExIm tool are template files:
@ Schema template file
@ Criteria template file

o Criteria Properties template file

In the Export/Import operation, every business object must be associated to a Schema template file,
a Criteria template file, and a Criteria Properties template file. The Criteria Properties template file
must be modified before the export operation.

Schema FHles

For the Export/Import tool, every business object must have an associated schema file. A schema
file defines the structure of a business object. It is an XML representation of the business object’s
data model. A data model consists of tables and relationships that are part of a business object.

Each schema file contains one primary category and all other categories are directly or indirectly
related to this category. The export program processes the schema file and determines the tables
from which data needs to be exported for a particular business object.

When to Change Values inthe Schema Hle

You may need to change values in the schema file in the following instances:
o When a new category should be included as part of the business object to be exported.

@ An existing relationship has changed for a business object.

v9.3.1 7
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Example Schema FHle

This is an example of a schema file for exporting the Site business object. The Entity Relationship
model for the Site business object is shown.

Site Matarial Type

¥ Site
Solid Madium
Solid Small
Solid Large
Liguid Medium
Gas Srmall
Gas Larga
Hafaly Condition
Is Expendabla
Gas Medium
Ligpuid Large
Ligpuid Srall

Sl

Site Equipment Link

She ID

= Canpany
Sila Mame

Site Type

Is Manufacturing
GMP

® 3 Address

= Environment
Has Privilege
Is Storage
Descriphion
Parant Sita 1D

3

i

3 Sila

= Equip Calagory

Address

L 4

&~

Site Storage

= Hita

|s Quarantine
15 Material

Is Equipmant
Is Secured

The schema file to export data from the tables for a Site business object contains the following

information:

<?xml version="1.0" encoding="UTF-8"?>

<l--
Definition file for Site Business Object, including all the related
objects
-—>
<cfmXML xsi:noNamespaceSchemalocation="../cfmxml.xsd"
xmlns:xsi="http://www.w3.0rg/2010/XMLSchema-instance">
<SearchInfo>
<SearchCriteria id="1">
<CategoryName/>
<CategoryDBName>D PPL ADDRESS</CategoryDBName>
<!-- Get 'Address' from D ORG SITE using searchCriteria 1 -->
<Relationship name="Address" type="inbound" refid="2">
<CategoryName/>
<CategoryDBName/>
<ObjectKey/>
</Relationship>
8 Agile Product Lifecycle Management
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</SearchCriteria>
<SearchCriteria id="2" isPrimaryCategory="yes">
<CategoryName/>
<CategoryDBName>D ORG SITE</CategoryDBName>
</SearchCriteria>
<SearchCriteria id="3">
<CategoryName/>
<CategoryDBName>D ORG SITE STORAGE</CategoryDBName>
<Relationship name="Site" refid="2">
<CategoryName/>
<CategoryDBName/>
<ObjectKey/>
</Relationship>
</SearchCriteria>
<SearchCriteria id="4">
<CategoryName/>
<CategoryDBName>D ORG_SITE EQUIPMENT LK</CategoryDBName>
<Relationship name="Site" refid="2">
<CategoryName/>
<CategoryDBName/>
<ObjectKey/>
</Relationship>
</SearchCriteria>
<SearchCriteria id="5">
<CategoryName/>
<CategoryDBName>D ORG SITE MATERIAL TYPE</CategoryDBName>
<Relationship name="Site" refid="2">
<CategoryName/>
<CategoryDBName/>
<ObjectKey/>
</Relationship>
</SearchCriteria>
</SearchInfo>
</cfmXML>

Schema FHle Detalls

The following XML indicates that the schema file belongs to cfmXML schema.

<?xml version="1.0" encoding="UTF-8"?>
<l--
Definition file for Site Business Object, including all the related
objects
-——>
<cfmXML xsi:noNamespaceSchemalLocation="../cfmxml.xsd"
xmlns:xsi="http://www.w3.0rg/2010/XMLSchema-instance">

v9.3.1 9
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Details of XML elements present in the Schema file are listed in the table.

XML Synopsis Description Example
Element
Search <SearchInfo | A Searchinfotagis defined for the Based on the Site ER model, Site
Info > business object that needs to be has an outbound relationship with
exported. Searchinfo can contain one address. So in the XML you see
or more SearchCriteria tags. (Details address category having
of SearchCriteria is described refid=1, which is the ID of the
separately in further sections.) site category.
<SearchCriteria
id="1">
Category <CategoryNa | This tag does not contain any value <CategoryName />
Name me> but required for the cfmXML schema.
Category <CategoryDB | This tag contains the database table <CategoryDBName>D PP
DBName | Name> name of the category. L_ADDRESS</CategoryD
BName>
Relations | <Relationsh | The <Relationship> tag specifies the <Relationship name=
hip ip> relationship between categories, this "Address" refid="2"
information is specified in the type="inbound">
reference ID as an attribute. The type <CategoryName>
attribute specifies if the relationship is </CategoryName>
of type inbound or outbound. An <CategoryDBName>
inbound relationship is an incoming </CategoryDBName>
relationship and an outbound , ,
relationship refers to an outgoing ;OEJ ectKey></ObjectK
relationship. Each category should Y
have only one level of relationship </Relationship>
information which is not nested. All the
tags under Relationship should be left
blank as they are required fields in the
cfmXML schema.
Search <Search Every table or category in a schema The schema file could have one
Criteria Criteria> file has search criteria. Search criteria more categories including one

can have one or more relationships.
Every category in the schema file
should have a direct or an indirect
relationship with a primary category.
Every search criteria should have a
unique ID. The relationship can be
inbound or outbound.

primary category and the primary
category should be marked as
isPrimaryCategory="y
es".

<SearchCriteria
id="2"
isPrimaryCategory="y
es">

<CategoryName/>

<CategoryDBName>
D ORG_SITE
</CategoryDBName>

</SearchCriteria>

10
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XML Synopsis Description Example
Element
Additional <Additional The schema file can have Additional <AdditionalInfo>
Info Info> information. The Additional information

4 <Attribute name=
tag has the Refresh Cache attribute "refreshCache">

which can be set to yes or no. By
setting it to yes or no, you are
specifying if the cache has to be
refreshed or not after importing. You </Attribute>

must set this value to yes or no only in </AdditionalInfo>
the exported file.

<Value dataType=
"boolean">no</Value>

Updating Template FHles

For exporting specific information, you must specify search criteria values in the search Criteria
Properties template file. This update is required to restrict the export to selected data, and to
exclude other records associated with the business object.

Template files are available at the location /exim/templates.

The templates folder contains three subordinate folders called Schema, Criteria, and Criteria
Properties.
To provide search criteria values for the export operation:

1. Open the criteria properties file that is related to the data you intend to export; the criteria
properties files are available at the following location:

exim/templates/criteriaProperties

2. Enter the search criteria value.

Note For the search criteria value that you enter, do not provide any space between "="
and its value.
For example:
$$ COMPANY NAME=MyOrg
Assignment operator and its value should not be separated by spaces.

3. Save and close the Criteria Properties file.

Qptional: Updating the Schema Template FHle for Cache Refresh

For some imported information to correctly display in RMW, you must do a cache refresh after you
perform the update, which is an import option. To refresh cache, update the output file that is
created after a successful export operation.

Some business objects that require cache refresh are roles, category, views, subviews, and so on.
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To refresh the cache:
1. Edit the output file.

2. Inthe output file, set the Attribute value to "yes" as shown in the following xmil:

- <AdditionalInfo>
- <Attribute name="refreshCache">
<Value dataType="boolean">yes</Value>
</Attribute>
</AdditionalInfo>

3. Save and close the output file.

Oriteria FHles

A Criteria file is a collection of search criteria for retrieving a subset of information as part of the
export operation. It contains the search criteria to be used when extracting business objects from
the database. This file is a template for performing search.

Example Qriteria Hle

A sample criteria file for exporting the Site business object is shown here:

<? xml version="1.0" encoding="UTF-8"?>
<cfmXML xsi:noNamespaceSchemalocation="../cfmxml.xsd"
xmlns:xsi="http://www.w3.0rg/2001/XMLSchema-instance">
<SearchInfo>
<SearchCriteria id="2">

<CategoryName />

<CategoryDBName>D ORG_SITE</CategoryDBName>

<ViewName></ViewName>

<Attribute name="Site ID">
<Value dataType="String">$$ SITE ID</Value>
<UnitOfMeasure></UnitOfMeasure>

</Attribute>

<Attribute name="Company">
<Value dataType="String">$$ COMPANY NAME</Value>
<UnitOfMeasure></UnitOfMeasure>

</Attribute>

<Attribute name="Parent Site ID">
<Value dataType="String">$$ PARENT SITE ID</Value>
<UnitOfMeasure></UnitOfMeasure>

</Attribute>

<Attribute name="Name'">
<Value dataType="String">$$ SITE NAME</Value>
<UnitOfMeasure></UnitOfMeasure>

</Attribute>

12 Agile Product Lifecycle Management
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<Attribute name="Site Type">
<Value dataType="String">$$ SITE TYPE</Value>
<UnitOfMeasure></UnitOfMeasure>
</Attribute>
<Attribute name="Is Storage Area">
<Value dataType="boolean">$$ IS STORAGE AREA</Value>
<UnitOfMeasure></UnitOfMeasure>
</Attribute>
<Attribute name="Is Manufacturing Area">
<Value dataType="boolean">$$ IS MANUFACTURING</Value>
<UnitOfMeasure></UnitOfMeasure>
</Attribute>
<Attribute name="Has Privilege">
<Value dataType="boolean">$$ HAS PRIVILEGE</Value>
<UnitOfMeasure></UnitOfMeasure>
</Attribute>
<Attribute name="GMP">
<Value dataType="boolean">$$ GMP</Value>
<UnitOfMeasure></UnitOfMeasure>
</Attribute>
<Relationship name="Environmental Condition">
<CategoryName/>
<CategoryDBName>D ORG_ ENVIRONMENT</CategoryDBName>
<ObjectKey>
<Attribute name="Name">
<Value dataType="String">$$ ENV COND</Value>
</Attribute>
</ObjectKey>
</Relationship>
</SearchCriteria>
</SearchInfo>
<AdditionalInfo>
<Attribute name="schema">
<Value dataType="file">../schema/site schema</Value>
</Attribute>
<Attribute name="values">

<Value
dataType="file">../criteriaProperties/site criteria</Value>

</Attribute>
</AdditionalInfo>
</cfmXML>
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Qiteria Hle Details

Details of XML elements present in the Criteria file are listed in the table.

XML Synopsis Description Example
Element
Search <Search For every search criteria in the schema <SearchCriteria
Info Criteria file you can have a search criteria in the id="2">
> criteria file with all the attributes for that
category. Search criteria can have a view <Attribute
. . . ripu
name, which is optional. name—"Site ID">
The criteria file correspondg toaviewin <Value dataType=
R&MW but does not contain any gearch "String">$$ SITE ID
values. Instead of search values, it </Value>
contain  place holder Sartng wih 85| 0 o emeasure>
substring. If there is no $9, then the </UnitOfMeasure>
substring is treated as a value and not as .
a placeholder. </Attribute>
Syntax: placeholder=value (no space
after the "=" symbol) </SearchCriteria>
A search criteria has an ID. It should
match with the ID in the schema file.
Additiona | <Additio Criteria file can contain an Additional Info | <AdditionalInfo>
I Info nalInfo> | section to provide schemaand/or values | .attripute

file details for exporting records. The
<Additionallnfo> tag is used to specify
the location and name of the schema
and criteria properties file. So you need
to specify only the criteria file name at
the command line.

The file names in this tag should not
have an extension as the program
automatically adds the extension. Also,
the file names are optional.

name="schema'">

<Value dataType=
"file">../schema/Sit
e

schema</Value>

</Attribute>

<Attribute
name="values">

<Value dataType=
"file">../criteria
Properties/Site crit
eria N
</Value>

</Attribute>

Criteria Properties Hles

The Criteria Properties file is used to specify search values to be used for extracting a subset of
data as part of an export operation. Before exporting, the search values in this file must be set. The

export operation is based on the values you set in this file.

14
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This file contains values for parameters specified in the criteria file. A parameter may or may not
have a value. If it does not have a value in this file then it is not used for searching. Values for the
placeholders in the criteria file are given in the criteria properties file.

Example Qriteria Properties Hle
A sample criteria properties file is shown here:

Note # is used to comment information in the criteria properties file.

#

# Export all Site using site id
# Values = valid site id

# eg. $$ SITE ID=LD005

$$ SITE ID=

# Export all Site belong to a company
# Values = valid company name

# eg. $$ COMPANY NAME=Dragerwerk
$S_COMPANY NAME=Dragerwerk

# Export all Site which belong to one parent site
# Values = valid site name

# eg. $$ PARENT SITE ID=Global Site

$$ PARENT SITE ID=

# Export all Site with given name
# Values = valid site name

# eg. $$ SITE NAME=GMP

$$ SITE NAME=

# Export site for the give site type
# Values = valid site type

# eg. $$ SITE TYPE=Storage

$$ SITE TYPE=

# Export All non-storage/storage sites
# Values = boolean [yes/no]

# eg. $$ IS STORAGE AREA=yes

$$ IS STORAGE AREA=

# Export All non-manufacturing/manufacturing sites
# Values = boolean [yes/no]

# eg. $$ IS MANUFACTURING=yes

$$ IS MANUFACTURING=
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# Export All privileged and non-privileged
# Values = boolean [yes/no]

# eg. $$ HAS PRIVILEGE=yes

$$ HAS PRIVILEGE=

# Export All GMP/non-GMP sites

# Values = boolean [yes/no]
# eg. $$ _GMP=yes
$$ GMP=

# Export All sites with different environment conditions
# Values = environment types

# eg. $$ ENV _COND=Refrigerated

$$ ENV_COND=

Qriteria Properties Hle Details

The criteria properties file contains the following information to enable modification and edits:
#

,? wild cards
User @ symbol for NULL values, eg $$ CREATED DATE=@

# Variable values for exporting site definition

# One or more of these variables can be used to export Sites(s)
# You can also use operator along with these values
# possible operators are

# > Greater than

# < Less than

# & and

# | Or

# *

#

#

#

All the above wild card can be used with any of the Search attributes
other than date

# like, created date, modified date etc. Date need to be treated
special

# All date values should be inside '(' and ')' brackets

# eg. $$ CREATED DATE=(01/12/2010)

# you can also give the date format you have used, date format is given
inside '{' '}' braces

# eg. $$ CREATED DATE=(01/12/2010 {dd/MM/yyyy})

# Valid operations in dates are.

# BETWEEN (first date {format}), (second date {format})

# get all records between two date

# eg $$ MODIFIED DATE=BETWEEN (01/01/2010 {MM/dd/yyyy}), (02/08/2010
{MM/dd/yyyy})

#

# Greater than/less than/not equal to ' >/</!= (date {format})'
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# get all records between two date

# eg $$ MODIFIED DATE= > (01/01/2010 {MM/dd/yyyy})

#

# Possible date formats

# Date and Time Pattern Result

# ______________________________________________________________________
# yyyy.MM.dd G 'at' HH:mm:ss z 2010.07.04 AD at 12:08:56 PDT
# EEE, MMM d, ''yy Wed, Jul 4, '10

# h:mm a 12:08 PM

# hh 'o''clock' a, zzzz 12 o'clock PM, Pacific
Daylight Time

# Kimm a, z 0:08 PM, PDT

# vyyyy.MMMMM.dd GGG hh:mm aaa 02010.July.04 AD 12:08 PM

# EEE, d MMM yyyy HH:mm:ss 2 Wed, 4 Jul 2010 12:08:56 -0700

# yyMMddHHmmssZ 100704120856-0700

# MM/dd/yyyy 04/30/2010

# MM-dd-yyyy 04-30-2010

# ______________________________________________________________________
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Exporting and Importing Data
from the Command Line
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This chapter provides information on commands and parameters required to run the export or
import operation.

Export/Import Parameters

Export Parameters
Option Description
-C Path of the file containing the export criteria in XML format.

If the file path contains only file name, the file is read from the current working directory.
Otherwise, the file will be loaded from the specified location.

-u Login details for user to connect to RMW in <userid>/<Password> format.

Password should not contain a "slash" (/).

-d RMW database name from which the data is being exported.

This is the logical name of the database being accessed. The database name is found in
CFMDBConfig.xml file or the login page of RMW. The database name is usually
‘Production’ or ‘Development’.

-o Output filename, which will be created by the export program containing exported data.

User can also give a file pattern while exporting. The filename will be generated using the
primary category data.

Forexample: —o F:\data\migration\{Name} .xml if used while exporting subview
or view, the {Name} part in the output file name will be replaced with the view/subview name.

User can give one or more attributes from primary category table. If an attribute name has blank
character, the blank/space character should be replaced with ‘#'.

Forexample: F: \data\migration\ {DB#Name} .xml

—-pc Used to override the primary category table with a different child category table when exporting.

User can specify the table name with which the primary category should be replaced. It can
accept comma separated table names to export from multiple categories.
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Option Description

Distinct XML files will be generated for each of the categories and the file name would have the
category table name prefixed with the output file name specified in the —o option

-h Used to export record from the entire hierarchy tree.

User has to give the parent node table name from where he/she wants to export the sub tree
hierarchy data including the parent node.

Distinct XML files will be generated for each of the categories in the hierarchy and the file name
would have the category table name prefixed with the output file name specified in the —o

option.
Import Parameters
Option Description
-u Login details for user to access R&MW in <userid>/<Password> format.

Password should not contain a "slash” (/).

-d RMW database name from which the data is being imported.

This is the logical name of the database in the R&MW Application being accessed. The database
name is found in CFMDBConfig. xml file or RMW login page. The database name is usually
‘Production’ or ‘Development’.

-1 Used to specify the input data file name including full path, this information will be used by the
import program to import data into the target database.

—-op Used to specify the types of transactions that can be performed on the objects present in the
database.

The transactions are one of the following: UPD, INS, or DEL.

UPD Read the import data file specified in the —i parameter.

For every object in the file:

= Search the database for object matching the same criteria (same primary keys)

= If object found, update the database object with values from the object in the import file.
= If no object matching the criteria found, log an error

INS Read the import data file specified in the —i parameter.
For every object in the file, insert a new database object with values from the object in the import
file.

DEL Read the import data file specified in the —1 parameter.

For every object in the file:
= Search the database for object matching the same criteria (same primary keys)
o If object found, delete the database object

= If no object matching the criteria found, log an error
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from the Command Line

How to Export

To begin exporting information from RMW.

1. Configure the Application Server information in the CFMConfig.xml file.

For more information, see Updating the CFMConfig.xml Configuration File.

2. Configure the application server information in the export command file.

For more information, see Updating the Export or Import Command Files.

3. Update the criteria properties template file to export specific information.

For more information, see Updating Template Files.

4. From the respective console, start the export operation:

For Windows, from the command prompt, execute the following commands:

cd AgilePharmal\exim\bin
export.bat

where AgilePharmalexim is the location where the export/import tool is installed.

For UNIX, from the shell prompt, execute the following commands:

.cd AgilePharma/exim/bin
./export.sh

where AgilePharmalexim is the location where the export/import tool is installed.

To complete the export process:

1. The AppServer URL information is displayed.

For Windows, from the command prompt, execute the export command:

export -u <user name/password> -d <database name> -c
<criteria file name> -o <output file name>

If the record fails to export, the event is recorded in the log file that is created by the export
program.

The output.xml and .log files will be created. The log files contain a record of the
export operation
For UNIX, from the command prompt, execute the export command:

./export.sh -u <user name/password> -d <database name> -c
<criteria file name> -o <output file name>

If the record fails to export, the event is recorded in the log file that is created by the export
program.

The output.xml and .log files will be created. The log files contain a record of the
activities during export operation.

The XML file contains object tags. An object represents a record (a row in a table).

v9.3.1
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Log Hle

The Export tool creates a log file containing all the informational and error messages, and number
of records exported from each category. The log file name is the same as the output file name with

. log suffix.

For example: If the output file name is my data xport.xml, the log file name will be
my data export.xml.log

The export log should contain the following information:

o

a

a

The login username of the user who performed the export operation
Execution date and time of the export

Schema, Criteria, and Properties file name used for the export operation
A summary for each business object exported, as shown here:

Primary Category: D ORG_SITE

Primary Category Internal id: L.DD424

Processed Record count by category: {D ORG SITE MATERIAL TYPE=0,

D PPL ADDRESS=1, D ORG SITE STORAGE=1, D ORG SITE EQUIPMENT LK=0}

Total processed count: 3

How to Import

To import information into RMW:

1.

Configure the Application Server information in CFMConfig.xml file.

For more information, see Updating the CFMConfig.xml Configuration File.
Configure the Application Server information in the import Command File.

For more information, see Updating the Export or Import Command Files.

Optional: Update the schema template file for cache refresh.

For more information, see Updating the Schema template file for Refreshing Cache

From the respective console, start the import tool:

* For Windows, from the command prompt, execute the following commands:
cd AgilePharmal\exim\bin
import.bat

where AgilePharmalexim Iis the location where the export/import tool is installed.

* For UNIX, from the shell prompt, execute the following commands:
.cd AgilePharma/exim/bin
./import.sh

where AgilePharma/exim is the location where the export/import tool is installed.
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5. From the command prompt, execute the import command.
* ForWindows:

import -u <user name/password> -d <database name> -1 <input file
path> -op <INS|UPD|DEL>

*  For UNIX:

import -u <user name/password> -d <database name> -1 <input file
path> -op <INS|UPD|DEL>

Modes of Import

o Insert mode: If the data being imported does not exist in the target database, it is inserted. If the
data being imported already exists, an error message is displayed and no changes are made to
the target database.

o Update mode: If the data being imported does not exist in the target database, it is inserted. If the
data being imported already exists, the existing information is updated.

o Delete mode: If the data being imported exists in the target database, it is deleted. If the data
being imported does not exist in the target database, an error message is displayed and no
changes are made to the target database.

If the record fails to import, the event is recorded in the log file that is created by the export
program.

Import Failure

If an import operation fails, the <import file name>.failed files are generated with the name
of the input files. These failed files can be used for repeating the import operation.

Every failed import creates a log file using the session ID on the server. In case of a failure, you can
look into this file to understand the details of activities on the server side. This log file is also created
for a successful import operation.

Rollback

During the import operation, if some records related to the imported business object failed to import,
the complete business object is rolled back and is not committed. This is recorded in the log file.

Log FHles
Log File Description
<import xml file name>.failed Logs BO records that were not imported.
<import xml Logs the number of insert, update, and delete operations
file>.<Operation><number>.log performed.
<import xml Logs client-side processing details.
file>.<Operation>.log
CFMMigration <sessionid>.log Logs server-side processing details.
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Supported Operations and Formats

The application supports exporting RMW data using RMW's User Interface (Ul) or the command-
line interface (CLI) with ExIm. From the Ul, you can export RMW data in the following file formats:

o Excel
o HTML
o PDF
o XML
®* Object

®* Object + Related Objects

Note To export RMW objects, you must use XML's Object + Related Objects option. The other
four options list the data that appears in the object's Report in the selected format and
not the object which is the data in XML format. ExIm only supports exporting Object +
Related Objects in XML format.

The basic steps for exporting data from the RMW UI:
Log in to RMW.

Use the Search utility to locate the objects and data.

1

2

3. Select the data from your Search result.

4. Bring up the Ul's Export utility and select the desired file format.
5

Save or open the exported file.

The procedures for exporting with use of Execute Search and Custom Search are detailed below.

Searching and Selecting the Export Data

Information provided in this section assume familiarity with the RMW solution and its Execute
Search utility, which provides a default report for the selected object, and the Custom Search
options. These features refine specifying the criteria for the desired objects.
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Exportable Search Results

In addition to exporting search results, RMW supports exporting tables of objects that do not have a
related object. For example, the table content on all tables under the History tab and under the Notes
and Attachments tab on all objects can be exported in EXCEL, PDF, HTML, or XML formats.

To Export data using Execute Search:

1.
2.

3.

Log on to Agile PLM and Tools menu | ® ~ _ select Recipe & Material Workspace.

In the Top Navigation bar, select the Class and subclass to locate the applicable Record. For
example, to locate all records in Recipes Library, select Recipes > Library followed by an asterisk

)

- [ o
Matetials

&

Analytical
Ecjuipment

Environmertal
+ FRecipes [ 2 | Likrary 2

Processes 4 {2/ Elemert Template

Feople S & Action Template

T

Organizations  p

In the Top Navigation bar, click the Execute Search |_* | button. For information on the Custom
Search option, see To export data using Custom Search on page 27.

Records in the Records in "Recipe" is displayed.

booxs * = 2 »~

[ ective ind  Oper g
Pocyre Hunie Deseription  Lifecyche Mhase  liate Retn Mode Cotrgarry |

Select one or more records for export.

The Export button . B 7/ in the menu bar is activated.

Click the Export button and select the export file format from Excel, PDF, HTML, XML Object
Only or Object + Related Object.

Depending on the selected file format, a Windows dialog prompts you to open or save the
newly created file. Sample Excel and PDF outputs appear below. The reports provide the data
that appeared in Execute Search shown in the Records in "Recipe" report above. The only
option that exports the object which is an XML file, is XML's Object + Related Object.
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PDF sample:

ORACLE  Recipe Report

Version Number Kame= Descripion Liecycie Phase Effecive Start Defe  EhectiveEndDafz  OperafingMode  Company Nams  Recipe Lewe!
12 Creae Sase Chemical Appooved 2332010 Climical Sapply Carporats Genzal
Excel sample:

Recipe Report

Fiecipe Lewel Recipe Type Prodwst

Approsed 3] Clinical Supphy Corporte Generzl Frocessing
1 Create Chemicd B3 Approsed i Clisical Fupphy Corporate General Frocessing
1 Wales Puiication Approsed b Clisical Fupphy Corporate General Frocessing
hject + Related Object sample:
<7aml varsions*1.0* encodngs"UTF-8" 7>
- gl==
Jenerated using S0OK3 ©
Exporct jmct and 411 its related objec:
1] L} -1y ‘
; ! T ]
—
- <cfmxML>
- «Payload>

- «ObjeciGroup =80="yes" name="Recipe Template’>
<Object name="BORoot">
<CatagoryName>Recipe</Categoryhame>
<CatagoryDBENama>A_RECIPE_TEMPLATE</CategoryDaNames>
<ViewhzmesDEFAULT </ ViawName>
- <Onjeciiey>
<ObjectiD>1623163</0bjectiOx
- <Attnbute name='Neme'>
“Valus dataType~"Basic Text' =Water Purlfication</vVaue>
<UnitOfeasure />
a/attnbutes
- cAattribute name="Version Number™>
<Value dataType="Basic Text'>1.0</Vaue>
<UnitOfMessure />
</attnbutes

To Export data using Custom Search:

1. Repeatsteps 1 and 2 in To export data using Execute Search on page 26.

2. Inthe Top Navigation bar, click the Custom Search 9" putton.
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Depending on the selected object, fields representing the available criteria for the object are
displayed in the Basic View. The DEFAULT View displays additional fields for a more

comprehensive report.

ﬂ | Creste Mew ™

[ETR nw | O“"_

Recipes : Recipe Library © Manage
Search Recipe ./

Mame:

Dezcription:
Litecycle Phase:
Effective Start Date:

Effective End Date:

i K

Operating Mode:

Eiasic
Wersion Mumberss DEF&ULT
Recipe Lewvel: =
Purpose: -
Company ; Mame: =
Product-Procuct (O .

3. Inthe selected View, click the drop-down arrows to select the desired value for each criteria
and then click | =z&rch | You can also use * in any field to display the available records for that
criteria. For example, if you typed an * in the Name field, the names of records in Recipe
Library is displayed.

& Crede e ” E = jiat] |

Fecpes - Recpe Lieary : Mansge

Szarch Recipe ' View Recipe Quick Search v
Mame.

[7] Creste Bose Chencal
Sove [7] Creste Chemical €3 ) | | |
I— ] ‘Weber Punificaton = =
Records in Recipe™
4 4 » » 3
More 7| LR 3 >
|
= £ e [

Rioers Per Page 10 ¥  Oromsselectedof b 1

4. To continue, select the records you want to export.

The Export button .B* 7/ in the menu bar is activated.

5. Click the Export button and select the export file format from Excel, PDF, HTML, XML Object
Only or Object + Related Obiject.

Note When exporting from custom search results table, depending on the view selected
for search, different set of columns are displayed. During the export operation,
values displayed in these columns are also exported.
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This chapter provides additional information about exporting and importing data from/to RMW, with
examples. Complete the configuration steps outlined in Configuring Export Import Tool on page 3
before you use the scenario examples to export or import information.

Views

To insert, update or delete views from the RMW application, use View schema files.

Note When using the View schema file to import views, only view information along with
attribute and other details will be imported. Related or parent categories and other
references will not be imported. These reference records should be imported separately
prior to view import.

Template files:
Criteria file: view_criteria.xml

Schemafile:  view_schema.xml

Properties file: view_criteria.properties

Using Search Attributes to Export Views

You can use the following search attributes to export a view, as described here.

o View Name: Provide the Web service ID for search attribute $$_VIEW_NAME. For example,
$$_VIEW_NAME=Alertsearchview

o Owner Category Name: To export all views that belong to this category. Provide the service name
for search attribute $$_CATEGORY_NAME. For example,
$$_CATEGORY_NAME=AlertDefinition
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Inserting New iews

To insert view(s) to the RMW application, the view(s) should be exported from the source RMW
application and imported to the destination RMW application in insert mode.

Step 1. Export existing view from the source

1. Open the view_criteria.properties file present in the migration/templates/criteriaproperties
folder.

2. Specify the search attribute values to export the records.
Check the preceding section for using different search attributes.
4. Export the records using following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/view criteria.xml -o
<migration home>/alertsearchview.xml

Step 2: Import exported view to the destination RMW application

1. Toimport the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/alertsearchview.xml -op INS

Step 3: Verify the imported view through RMW Web user interface Meta model Ul
Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Setup > Meta model > View > Manage.

Provide the view name as search criteria in the View Name column.

Click the Search button.

Check if the imported view is displayed in the search result.
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Click on the view name to verify the view details.

Step 4. Check the imported view through RMW Web user interface Library module

Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration> Library > Manage Record.

Click the Browse tab.

Select category Base > Meta Model Folder > View.

Click the Search tab.

Provide the required search criteria, you can use the similar criteria values used for export.

Search for the record and verify the imported records shown in the search result window.
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Click on the view link to verify the details.
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Updating Views

To update existing views in the RMW application, the views should be exported from the source
RMW application and imported to the destination RMW application in update mode.

Step 1. Export existing view(s) from source RMW application

1. Open the views_criteria.properties file.

2. Specify the search attribute values to export records.

3. Check the preceding section for using different search attributes.
4. Export the records using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/view criteria.xml -o
<migration home>/alertsearchview.xml

Step 2: Import exported view to the destination

1. Import the exported views using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/alertsearchview.xml —op UPD

Step 3: Verify the view import through RMW Web user interface Meta model Ul
Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Setup > Meta model > View > Manage.

Provide the view name as search criteria in the View Name column.

Click the Search button.

Check if the imported view is displayed in the search result.
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Click on the view name to verify the view details.

Step 4: Check the imported view through RMW Web user interface Library module

Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select category Base > Meta Model > Folder View.

Click the Search tab.

Provide the required search criteria; you can use the similar criteria values used for export.

Search for the record and verify the imported records shown in the search result window.
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Click on the view link to verify the details.
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Deleting Views

To delete existing view(s) in the RMW application, the view(s) should be first exported from the
RMW application and then imported to the RMW application in delete mode.

Step 1. Export existing view(s) from source RMW application

1. Open the views_criteria.properties file.

2. Specify the search attribute values to export records.

3. Check the preceding section for using different search attributes.
4

Export the records using following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/view criteria.xml -o
<migration home>/alertsearchview.xml

Step 2: Import the exported views to the destination RMW application

1. Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/alertsearchview.xml —op DEL

Step 3: Verify the deleted view import through RMW Web user interface Meta model Ul
Open the RMW Web URL in the Web browser.
Log in to the application using valid user credentials.
Navigate to Administration > Setup > Meta model > View > Manage.

1
2
3
4. Provide the view name as search criteria in the View Name column.
5. Click the Search button.

6

Check if the imported view not is displayed in the search result window.

Step 4: Check the imported view through RMW Web user interface Library module.

Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select category Base > Meta Model > Folder View.

Click the Search tab.

Provide the required search criteria; you can use typical criteria values used for export.

Search for the record and verify the imported records shown in the search result window.
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Click on the view link to verify the details.
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View Attributes

View attribute template files are used to insert, update or delete view attributes for a view. When
using view attribute schema only view attributes details are exported or imported. Referencing view
or category attributes are imported separately and available prior to view attribute import.

Template files:
Criteria file: viewattribute_criteria.xml
Schema file:  viewattribute_schema.xml

Properties file: viewattribute_criteria.properties

Using Search Attributes to Export Views

You can use the following search attributes to export a view name, as described here.

o View Name: Provide the Web service ID for search attribute $$ VIEW _NAME. For example,
$$_VIEW_NAME=Alertsearchview

o View Attribute Name: Provide the service name for search attribute $$ VIEW_ATTR_NAME. For
example, $$_VIEW_ATTR_NAME=AlertName

Adding Additional Attributes to Existing Views

To insert view attribute(s) to the RMW application, the view attribute(s) should be exported from the
source RMW application and imported to the destination RMW application in insert mode.

Step 1. Export existing view attribute(s) from source RMW application.
1. Open the viewattribute_criteria.properties file.

2. Specify the search attribute values to export records.

3. Check the preceding section for using different search attributes.

4. Export the records using following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/viewattribute criteria.xml -o
<migration home>/alertsearchviewattributes.xml

Step 2: Import the exported view attributes to destination RMW application.
1. Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/alertsearchviewattributes.xml -op INS

Step 3: Check the imported view attributes through RMW Web user interface Meta model Ul.
1. Openthe RMW Web URL in Internet Explorer Web browser.

2. Login to the application using valid user credentials.
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Navigate to Administration > Setup > Meta model > View > Manage.
Provide the view name as search criteria in the View Name column. Click the Search button.
Check if the imported view is displayed in the search result.

Click on the view name to view the search and result attribute used in the view.
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Click on the respective tab to view the view attributes details.

Step 5: Check the imported view attributes through RMW Web user interface Library module.

1. Openthe RMW Web URL in Internet Explorer Web browser.

2. Login to the application using valid user credentials and Database as Development.

3. Navigate to Administration> Library > Manage Record.

4. Click the Browse tab.

5. Select category Base > Meta Model Folder > View Attribute.

6. Click the Search tab.

7. Provide the required search criteria, you can use the typical criteria values used for export.
8. Search for the record and verify the imported records shown in the search result window.
Updating Existing View Attributes

To update view attribute(s) to the RMW application, the view attribute(s) should be exported from
the source RMW application and imported to the destination RMW application in update mode.

Step 1. Export existing view attribute(s) from source RMW application.
1. Open the viewattribute_criteria.properties file.

2. Specify the search attribute values to export records.

3. Check the preceding section for using different search attributes.

4. Export the records using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/viewattribute criteria.xml -o
<migration home>/alertsearchviewattributes.xml

Step 2: Import exported view attributes to the destination RMW application\

1. Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/alertsearchviewattributes.xml -op UPD

Step 3: Verify the imported view attributes through RMW Web user interface Ul

1. Openthe RMW Web URL in Internet Explorer Web browser.

2. Login to the application using valid user credentials and Database as Development.
3. Navigate to Administration > Setup >e Meta model > View > Manage.
4

Provide the view name as search criteria in the View Name column.
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Click the Search button.

5
6. Check if the imported view is displayed in the search result.
7. Click on the view name to view the view details.

8

Click on the respective tab to view the view attributes details.

Step 6: Check the imported view attributes through RMW Web user interface Library module.
Open the RMW Web URL in Internet Explorer Web browser.

Log in to the application using valid user credentials and Database as Development.
Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select category Base > Meta Model Folder > View Attribute.

Click the Search tab.

Provide the required search criteria, you can use typical criteria values used for export.
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Search for the record and verify the imported records shown in the search result window.

Deleting Existing View Attributes From Views

To delete existing view attribute(s) to RMW application, the view attribute(s) should be imported to
destination the RMW application in delete mode.

Step 1. Export existing view attribute(s) from source RMW application
1. Open the viewattribute_criteria.properties file.

2. Specify the search attribute values to export records.

3. Check the preceding section for using different search attributes.
4. Export the records using following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/viewattribute criteria.xml -o
<migration home>/alertsearchviewattributes.xml

Step 2: Import the exported view attributes to destination RMW application.

Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/alertsearchviewattributes.xml -op DEL

Step 3: Check the imported view attributes through RMW Web user interface Meta model Ul.
1. Openthe RMW Web URL in Internet Explorer Web browser.

2. Login to the application using valid user credentials and Database as Development.

3. Navigate to Administration > Setup > Meta model > View > Manage.

4. Provide the view name as search criteria in the ‘View Name’ column. Hit the search button.
5

Check if the imported view is displayed in the search result.
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6. Click on the view name to view the search and result attribute used in the view.
7. Click on the respective tab to view the view attributes details.

8. Verify the deleted attribute removed from the view.

Step 4. Check the imported view attributes through RMW Web user interface Library module.
Open the RMW Web URL in Internet Explorer Web browser.

Log in to the application using valid user credentials.

Navigate to Administration> Library > Manage Record.

Click the Browse tab.

Select category Base > Meta Model Folder > View Attribute.

Click the Search tab.

Provide the required search criteria, you can use the similar criteria values used for export.
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Search for the record and verify the imported records are not shown in the search result
window.

Categories

Using the category schema, refer table Business Objects and related templates to find the files
related to the category.

Inserting a New Category

You can export an existing category from one RMW application (source) to another RMW
application (destination). The example shows how to export the category Alert Definition from the
source RMW application to the destination RMW application.

Step 1. Export existing category from the source.

1. Update the CFMConfig.xml to point to the source RMW application.
2. Open the category_criteria.properties file.

3. Specify values for any of the search attributes to export the category.
4. Export category using category name.

Provide the category name using $$_CAT_NAME=property. For example,
$$_CAT_NAME=AlertDefinition

5. Export the category using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/category criteria.xml <output file
location>/alertdefinition.xml

Step 2: Import exported category to the destination.
1. Update the CFMConfig.xml to point to the source RMW application.

2. Use the following command to import the category to the destination:

36 Agile Product Lifecycle Management



Chapter 6: Scenario Examples

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/alertdefinition.xml -op INS

Step 3: Verify the category import through RMW Web user interface.
Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Setup > Meta model > Category > Manage.
Provide the category name as search criteria in the Name column.
Click the Search button.
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Check if the imported category is displayed in the search result.
Updating an Existing Category

The example shows how to export the category ‘Alert Definition’ from the source RMW application,
after making some modification to the existing category and importing the same category to the
destination RMW application.

Step 1. Export existing category from the source.
Refer the preceding section on how to export category.

Step 2: Import exported category to the destination.
1. Update the CFMConfig.xml to point to the source RMW application.

2. Use the following command to import the category to the destination.

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/alertdefinition.xml —op UPD

Step 3: Verify the category import through RMW Web user interface.
Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Setup > Meta model > Category > Manage.
Provide the category name as search criteria in the Name column.
Click the Search button.

Check if the imported category is displayed in the search result.
Click on the category name to view the view details.

Check the category details for the changes you have made.
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Refresh the cache if you do not see the changes. Refer the cache refresh section to see how to
refresh the cache.

Deleting an Existing Category

This example shows how to delete the category Alert Definition from the destination RMW
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application.
Step 1. Export existing category from the source.
Refer the preceding section on how to export a category.

Step 2: Import exported category to the destination.

Use the following command to import the category to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/alertdefinition.xml -op DEL

Step 3: Verify the category import through RMW Web user interface.
1. Openthe RMW Web URL in the Web browser.

2. Log in to the application using valid user credentials.

3. Navigate to Administration > Setup > Meta model > Category > Manage.
4. Provide the view name as search criteria in the Name column.
5

Click the Search button. The deleted category will not be displayed in the search result.
Adding Additional Attributes To Existing Categories

Using the Category Attribute schema refer the table Business Objects and related templates to find
the files related to Category Attribute.

Exporting category attributes of an existing category from one RMW application to importing these
attributes to the same category in another RMW application. The same category should exist in
both the application. Assume these additional attributes are not available in the destination RMW
application category.

Step 1. Export category attributes.

1. Update the CFMConfig.xml to point to the source RMW application.

2. Open the categoryattribute_criteria.properties file.

3. Specify value for any of the search attribute to export the view attribute.
4. Export category attributes using category name.

Provide the category name using $$_OWNER_CAT_NAME=property. For example,
$$ OWNER_CAT_NAME=AlertDefinition

5. Export category attribute using attribute label.

Provide category name using $$ ATTR_LABEL=property. For example,
$$ ATTR_LABEL==AlertName

6. Export the category attributes using the following command:

<migration home>/bin/export.sh -d Development -u admin/admin -c
<migration home>/templates/categoryattribute criteria.xml <output file
location>/alertdefinition attributes.xml
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Step 2: Import exported category attributes to the destination.
1. Update the CFMConfig.xml to point to the source RMW application.

2. Use the following command to import the category attributes to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/alertdefinition attributes.xml -op INS

Step 3: Verify the category attributes import through RMW Web user interface.
Open the RMW Web URL in Internet Explorer Web browser.

Log in to the application using valid user credentials.

Provide the user credentials and select Development as the DB name.
Navigate to Administration > Setup > Meta model > Category > Manage.

Provide the category name as search criteria in the Name column.

Click the Search button.

Check if the imported category is displayed in the search result.

Click on the category name to view the category details.
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In category details window check the category attributes added.

=
©

Refresh the cache if you don’t see the changes. Refer the cache refresh section to see how to
refresh the cache.

Updating Existing Category Attributes

Exporting category attributes of an existing category from one RMW application to importing these
attributes to the same category in another RMW application. The same category should exist in
both the application. Assume these additional attributes are available in the destination RMW
application category. (Update operation will insert the attributes if not found in the destination).

Step 1. Export category attributes.
Refer the preceding section to see how to export category attributes.

Step 2: Import exported category attributes to the destination.

Use the following command to import the category attributes to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/alertdefinition attribute.xml -op UPD

Step 3: Verify the category attribute import through RMW Web user interface.
1. Openthe RMW Web URL in Internet Explorer Web browser.

2. Log in to the application using valid user credentials.

3. Provide the user credentials and select Development as the DB name.

4. Navigate to Administration > Setup > Meta model > Category > Manage.
5

Provide the category name as search criteria in the Name column.
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Click the Search button.
Check if the category is displayed in the search result.

Click on the category name to view the category details.
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In category details window check the attributes updated.

10. Refresh the cache if you do not see the changes. Refer the cache refresh section to see how to
refresh the cache.

Deleting Existing Category Attributes

Exporting category attributes of an existing category from one RMW application to importing these
attributes to the same category in another RMW application. The same category should exist in
both the application. Assume these additional attributes are available in the destination RMW
application category.

Step 1. Export category attributes.
Refer the preceding section to see how to export category attributes.

Step 2: Import exported category attributes to the destination.
1. Update the CFMConfig.xml to point to the source RMW application.

2. Use the following command to import the category attributes to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/alertdefinition attribute.xml -op DEL

Step 3: Verify the category attributes import through RMW Web user interface.
Open the RMW Web URL in Internet Explorer Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Setup > Meta model > Category > Manage.

Provide the category name as search criteria in the Name column.

Click the Search button.

Check if the category is displayed in the search result.

Click on the category name link to view the category details.

In the View Details window, check if the category attributes are deleted from the category.
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Refresh the cache if you do not see the changes. Refer the cache refresh section to see how to
refresh the cache.
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Buttons
Inserting New Buttons

Using Button Schema refer the table Business Objects and related templates to find the files related
to Button.

Exporting existing button from one RMW application (source) to another RMW application
(destination). The example shows how to export the button ‘Add Roles’ from source RMW
application to the destination RMW application.

Step 1. Export existing button from the source.

1. Update the CFMConfig.xml to point to the source RMW application.

2. Open the button_criteria.properties file.

3. Specify value for any of the search attribute to export the button.

1. Export button using button name. Provide the button name using
$$ BUTTON_NAME=property. For example, $$ BUTTON_NAME=AddRoles

2. Export All Buttons using component ID. Provide the component ID using
$$_COMPONENT_ID=property. For example,
$$ COMPONENT_ID=PCM_EDIT_CONFIRM_SA BTNBAR

4. Export the button using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/button criteria.xml <output file
location>/addrolesbutton.xml

Step 2: Import exported button to the destination.
1. Update the CFMConfig.xml to point to the source RMW application.

2. Use the following command to import the button to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/addrolesbutton.xml -op INS

Step 3: Verify the button import through RMW Web user interface.

Open the RMW Web URL in Internet Explorer Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select Base > System Folder > Authorization Folder > Button category.
Click the Search tab.

Provide the button name as search criteria in the Button Name column.

Click the Search button.
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9. Check if the imported button is displayed in the search result.
Updating Existing Buttons

Using the Button Schema refer the table Business Objects and template files to know the files
related to Button]).

Exporting existing button from one RMW application (source) to another RMW application
(destination). The example shows how to export the button ‘Add Roles’ from source RMW
application to the destination RMW application.

Step 1: Export existing button from the source.

1. Update the CFMConfig.xml to point to the source RMW application.
2. Open the button_criteria.properties.

3. Specify value for any of the search attribute to export the button.

1. Export button using button name. Provide the button hame using
$$_BUTTON_NAME=property. For example, $$_BUTTON_NAME=AddRoles

2. Export All Buttons using component ID. Provide the component ID using
$$ COMPONENT_ID=property. For example,
$$_COMPONENT_ID=PCM_EDIT_CONFIRM_SA_BTNBAR

4. Export the button using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/button criteria.xml <output file
location>/addrolesbutton.xml

Step 2: Import exported button to the destination.
1. Update the CFMConfig.xml to point to the source RMW application.

2. Use the following command to import the button to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/addrolesbutton.xml —op UPD

Step 3: Verify the button import through RMW Web user interface.

Open the RMW Web URL in Internet Explorer Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select Base > System Folder > Authorization Folder > Button category.
Click the Search tab.

Provide the button name as search criteria in the Button Name column.
Click the Search button.
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Check if the imported button is displayed in the search result.

10. Click on the button name to view the details.
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Deleting Existing Buttons

Using the Button Schema refer the table Business Objects and related templates to know the files
related to Button]).

Step 1. Export existing button from the source.

1.
2.
3.

Update the CFMConfig.xml to point to the source RMW application.
Open the button_criteria.properties.
Specify value for any of the search attribute to export the button.

1. Export button using button name. Provide the button hame using
$$ BUTTON_NAME=property. For example, $$ BUTTON_NAME=AddRoles

2. Export All Buttons using component ID. Provide the component ID using
$$ COMPONENT_ID=property. For example,
$$ COMPONENT_ID=PCM_EDIT_CONFIRM_SA BTNBAR

Export the button using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/button criteria.xml <output file
location>/addrolesbutton.xml

Step 2: Import exported button to the destination.

1.
2.

Update the CFMConfig.xml to point to the source RMW application.

Use the following command to import the button to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/addrolesbutton.xml -op DEL

Step 3: Verify the button import through RMW Web user interface.
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Open the RMW Web URL in Internet Explorer Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select Base > System Folder > Authorization Folder > Button category.
Click the Search tab.

Provide the button name as search criteria in the Button Name column.
Click the Search button.

Check if the imported button is not displayed in the search result.
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Renaming Existing Buttons

The Button Name is a primary key in the button table. To rename an existing button, you must
delete the existing button and insert a new button.

The Button Callback has reference to Button. So before deleting the button the referencing button
callbacks have to be updated to point to new button. Following are the steps involved in renaming a
button.

The example shows how to rename an existing button ‘Add Roles’ to ‘Add New Roles’. Expectation
is, the button is renamed to ‘Add New Roles’ in the source RMW application and a button named
‘Add Roles’ exist in the destination RMW application

Step 1. Export existing button from destination RMW application.
1. Open the button_criteria.properties file.
2. Specify a value for any of the search attributes to export the button.

Export the button using the button name. Provide the button name using
$$ BUTTON_NAME=property. For example, $$ BUTTON_NAME=AddRoles

3. Export the button using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/button criteria.xml <output file
location>/addrolesbutton.xml

Step 2: Export renamed button from source RMW application.
1. Open the button_criteria.properties file.
2. Specify a value for any of the search attributes to export the button.

Export button using button name. Provide the button name using
$$_BUTTON_NAME=property. For example, $$_BUTTON_NAME=AddNewRoles

3. Export the button using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/button criteria.xml <output file
location>/addnewrolesbutton.xml

Step 3: Import the exported button to the destination RMW application.

Use the following command to import the button to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/addnewrolesbutton.xml —-op INS

Step 4: Verify the newly imported button through RMW Web user interface.
1. Openthe RMW Web URL in Internet Explorer Web browser.

2. Login to the application using valid user credentials.

3. Navigate to Administration > Library > Manage Record.

4. Click the Browse tab.
5

Select Base > System Folder > Authorization Folder > Button category.
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6. Click the Search tab.

7. Provide the button name as search criteria in the Button Name column.
8. Click the Search button.

9. Check if the imported button is displayed in the search result window.
Step 5: Export the related button callbacks (s) from source RMW application.
1. Open the buttoncallback_criteria.properties file.

2. Specify the search attribute values to export the button callbacks.

3. Export all button callbacks for the given button. Provide the value for $5 BUTTON_NAME
search attribute. For example, $$_BUTTON_NAME=AddNewRoles

4. Export the button callbacks using following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/buttoncallback criteria.xml -o
<migration home>/addnewrolesbuttoncallbacks.xml

Step 6: Import the exported button callbacks into the destination RMW application in update
mode.

Use the following command to import the button to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/addnewrolesbuttoncallbacks.xml —-op UPD

Step 7: Check the updated button callbacks through RMW Web user interface.
Open the RMW Web URL in Internet Explorer Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select Base > System Folder > Authorization Folder > Button Callback category.
Click the Search tab.

Provide the button name as search criteria in the Button Name column.
Click the Search button.
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Check if the imported button callbacks are displayed in the search result window.
Step 8: Import the old button (exported in Step 1) into destination RMW application in delete
mode.

Use the following command to import the button to the destination:

<migration home>./import.sh -d Development -u admin/admin -i <input
file location>/addrolesbutton.xml —-op DEL

Step 9: Verify the deleted button through RMW Web user interface.
1. Openthe RMW Web URL in Internet Explorer Web browser.

2. Login to the application using valid user credentials.
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Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select Base > System Folder > Authorization Folder > Button category.
Click the Search tab.

Provide the button name as search criteria in the Button Name column.
Click the Search button.
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Verify that the deleted button is not displayed in the search result window.

Component Buttons

The Component Button template files can be used to link or unlink existing buttons to Ul
components. Existing links can be exported from one RMW application to another RMW application.

Note This procedure using the Component Button template exports or imports only the link
between the component and button. When importing a component button link, the
related button and component should be available in the destination RMW application.
Components and buttons should be exported and imported separately.

Template files:
Criteria file: component_button_link_criteria.xml
Schema file: component_button_link_schema.xml

Properties file: component_button_link_criteria.properties

Using Search Attributes to Export Button-Component Links

You can use the following search attributes to export a button-component link, as described here.
o Component ID: To export all button-component links for the given component ID(s).

Provide the value for the $3_COMPONENT_ID search attribute. For example,
$$_COMPONENT_ID=CMPNT_USR_EDIT_ADD_SITE_ROLE_LIST

@ Screen ID: To export all button-component links across all components for the given screen
ID(S).

Provide the value for the $$ SCREEN_ID search attribute. For example,
$$ SCREEN_ID=PCM_SCR_ALT_ADD_EDIT 12

o (Callback ID: to export all button-component links for the given button callback ID.

Provide the value for the $$_BUTTON_CALLBACK_ID search attribute. For example,
$$ BUTTON_CALLBACK_ID=PCM_USR_EDIT_ADD_SITE

o Button Name: To export all button-component links for the given button.

Provide the value for the $3_BUTTON_NAME search attribute. For example,
$$ BUTTON_NAME=AddaSite
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Linking Existing Buttons to a Component

To link existing buttons to a component in the destination RMW application, export the link from the
source RMW application and import them to the destination RMW application.

Perform the following steps to export and import component-button links:

Step 1: Export existing component button link(s) from source RMW application.

1. Open the component_button_link_criteria.properties file.

2. Specify the search attribute values to export the button component link. For details, see Using
Search Attributes to Export Button-Component Links 46.

3. Export the links using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/component button link criteria.xml
-0 <migration home>/button complinks.xml

Step 2: Import the exported links to the destination RMW application, using the
following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/button complinks.xml —op INS

Step 3: Check the newly added component button links through the RMW Web user
Interface.

Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration> Library > Manage Record.

In the Browse tab, select category Base>System Folder>Authorization Folder>Component Button.
Click the Search tab.
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Provide the required search criteria. You can use typical criteria values used for export, such as
Button Callback ID, Component ID, and so on.

7. Search for the record and verify that the newly imported button-component links are shown in
the search results.

8. Click on the record to verify the details of the imported record.
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Web Services

The Web service templates are used to insert, update and delete Web services and related
information from one RMW application to another RMW application.

Note When exporting Web service details using Web service templates, only the Web service
related information is exported. Related integration application setup data will not be
exported, this should be exported and imported separately, and should be available in
the destination RMW application before importing Web service.

Template files:
Criteria file:  webservices_criteria.xml

Schema file: webservices_schema.xml

Properties file: webservices_criteria.properties

Using Search Attributes to Export Web Services

You can use the following search attributes to export web services, as described here.

o Web Service ID: Provide the Web service ID for search attribute $$ WEBSERVICE_ID. For
example, $$_WEBSERVICE_ID=WeighScaleService

@ Service Name: Provide the service name for search attribute $$_SERVICE_NAME. For example,
$$ SERVICE_NAME=WeighScaleService

Inserting New Web Services

To insert a new Web service to the destination RMW application, export those Web service(s) from
the source RMW application and import them to the destination RMW application in insert mode.

Perform the following steps to export and import Web services:

Step 1. Export existing Web service (s) from source RMW application
1. Open the webservices_criteria.properties file.

2. Specify the search attribute values to export the Web services.

3. Check the following section for using different search attributes.
4

Export the Web services using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/Webservice criteria.xml -o
<migration home>/webservices.xml

Step 2: Import the exported Web services to destination RMW application

1. Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
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<migration home>/webservices.xml —op INS

Step 3: Check the newly added Web service through RMW Web user interface.
Open the RMW Web URL in the the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select category Base>System Folder>Integration Folder>Web services.

Click the Search tab.

Provide the required search criteria, you can use the similar criteria values used for export, like,
Web service ID, service name, and so on.
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Search for the record and verify the newly imported Web services shown in the search result.

9. You can click on the Web service ID to view details.
Updating Existing Web Services

To update a Web service in the destination RMW application, export those Web service(s) from the
source RMW application and import them to the destination RMW application in update mode.

Perform the following steps to export and import Web services.

Step 1. Export existing Web services from source RMW application
1. Open the webservices_criteria.properties file.
2. Specify the search attribute values to export the button callbacks.

3. Export the Web services using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/webservice criteria.xml -o
<migration home>/webservices.xml

Step 2: Import the exported Web services to destination RMW application

1. Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/webservices.xml -op UPD

Step 3: Check the newly added Web services through RMW Web user interface
Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select category Base>System Folder>Integration Folder>Webservices.

Click the Search tab.
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7. Provide the required search criteria, you can use the similar criteria values used for export, like,
Web service ID, service name, and so on.

8. Search for the record and verify the newly imported Web services shown in the search result.

9. You can click on the Web service ID to view details. Check if the modified information is
updated in the destination RMW application.

Deleting Existing Web Services

To delete existing Web services in the destination RMW application, export those Web services and
import them to the destination RMW application in delete mode.

Perform the following steps to export and import Web services:

Step 1. Export existing Web service (s) from source RMW application
1. Open the webservices_criteria.properties file.
2. Specify the search attribute values to export the button callbacks.

3. Export the Web services using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/webservice criteria.xml -o
<migration home>/webservices.xml

Step 2: Import the exported Web services to destination RMW application

1. Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/webservices.xml -op DEL

Step 3: Check the deleted Web service through RMW Web user interface
Open the RMW Web URL in the the Web browser.

Login to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select category Base>System Folder>Integration Folder>Web services.
Click the Search tab.
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Provide the required search criteria, you can use the similar criteria values used for export, like,
Web service ID, service name, and so on.

8. Search for the record and verify the deleted Web services are not shown in the search result.
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Web Service Operations

The Web service operation templates are used to insert, update or delete Web service operations
and related information from one RMW application to another RMW application. When exporting
Web service operation details using Web service templates, not all Web service operation related
information are exported. The related integration application setup information, Web service to
which this Web service operation belongs, and so on) will not be exported. This should be exported
and imported separately, and should be available in the destination RMW application before
importing a Web service.

Template files:

Criteria file: webservice_operation_criteria.xml

Schemafile:  webservice_operation_schema.xml

Properties file: webservice_operation_criteria.properties

Using Search Attributes to Export WWeb Service Qperations

You can use the following search attributes to export a Web Service operation, as described here.

a

Web Service ID: Provide the Web service ID for search attribute $$ WEBSERVICE_ID. For
example, $$_WEBSERVICE_ID=WeighScaleService

Web Service Name: Provide the service name for search attribute $$ SERVICE_NAME. For
example, $$_SERVICE_NAME=WeighScaleService

Operation Name: Provide the operation name for search attribute $$_OPERATION_NAME. For
example, $$_OPERATION_NAME=printLabel

Inserting New Web Service Operations

To insert new Web service operation to the destination RMW application, export those Web service
operation(s) from the source RMW application and import them to the destination RMW application
in insert mode.

Follow these steps to export and import Web services.

Step 1: Export existing Web service operation(s) from source RMW application

1.

2
3.
4

Open the webservice_operation_criteria.properties file.

Specify the search attribute values to export the Web service operations.
Check the preceding section for using different search attributes.

Export the Web services operations using the following command:

<migration home>./export.sh -d Development —-u admin/admin -c
<migration home>/templates/criteria/webservice operation criteria.xml
-0 <migration home>/webservice operations.xml

v9.3.1 51



Recipe & Material Workspace Export/Import Guide

Step 2: Import the exported Web service operations to destination RMW application

1. Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/webservice operations.xml -op UPD

Step 3: Check the newly added Web service operations through RMW Web user interface
Open the RMW Web URL in the Internet Explorer Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select category System Folder > Integration Folder> Web service Operation.

Click the Search tab.
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Provide the required search criteria, you can use the similar criteria values used for export, like,
Web service ID, service name, and so on.

8. Search for the record and verify the newly imported Web service operations shown in the
search result window.

9. Click on the Web service operation to verify the Web service operation details.
Updating Existing Web Service Qperations

To update existing Web service operation in the destination RMW application, export those Web
service operation(s) from the source RMW application and import them to the destination RMW
application in update mode.

Follow the following steps to export and import Web services.

Step 1: Export existing Web service operation(s) from source RMW application
1. Open the webservice_operation_criteria.properties file.

2. Specify the search attribute values to export the Web service operations.

3. Check the preceding section for using different search attributes.

4. Export the Web services operations using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/webservice operation criteria.xml
-0 <migration home>/webservice operations.xml

Step 2: Import the exported Web service operations to destination RMW application

1. Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/webservice operations.xml -op UPD

Step 3: Check the updated Web service operations through RMW Web user interface
1. Openthe RMW Web URL in the Internet Explorer Web browser.
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9.

Login to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select category System Folder > Integration Folder > Web service Operation.
Click the Search tab.

Provide the required search criteria, you can use the similar criteria values used for export, like,
Web service ID, service name, and so on.

Search for the record and verify the updated Web service operations shown in the search result
window.

Click on the Web service operation to verify the Web service operation details.

Deleting Existing Web Service Qperations

To update existing Web service operation in the destination RMW application, import the Web
service operation xml to destination RMW application in delete mode.

Follow the following steps to export and import Web services.

Step 1. Export existing Web service operation(s) from source RMW application

1.
2.

Open the webservice_operation_criteria.properties file.

Specify the search attribute values to export the Web service operations. Check the preceding
section for using different search attributes.

Export the Web services operations using following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/webservice operation criteria.xml
-0 <migration home>/webservice operations.xml

Step 2:Import the exported Web service operations to destination RMW application

1.

Import the exported xml using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/webservice operations.xml -op DEL

Step 3: Check the deleted service operations through RMW Web user interface
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Open the RMW Web URL in Internet Explorer Web browser.

Log in to the application using valid user credentials.

Navigate to Administration> Library > Manage Record.

Click the Browse tab.

Select category System Folder > Integration Folder > Web service Operation.
Click the Search tab.

Provide the required search criteria, you can use the similar criteria values used for export, like,
Web service ID, service name, and so on.
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8. Search for the record and verify the deleted Web service operations are not shown in the
search result window.

Action-to-Web-Service Operations

Action to Web service operation templates can be used to insert, update, or delete the Web service
operation — button callback. This link is used to link an existing ‘button callback’ to an existing ‘Web
service operation’.

This procedure using ‘Action — Web service link’ template, exports or imports only the link between
a Web service operation and button callback. The referenced Web service operation and button
callback should be available in the destination RMW application prior to import.

Template files:
Criteria file:  action_webserviceoperation_criteria.xml
Schemafile:  action_webserviceoperation_schema.xml

Properties file: action_webserviceoperation_criteria.properties

Using Search Attributes to Export Action to Web Service Links

You can use the following search attributes to export an action-web service link, as described here.
o Button Callback ID: To export all Web service operation action links for the button callback ID.

Provide the value for the $3_BUTTON_CALLBACK_ID search attribute. For example,
$$ BUTTON_CALLBACK_ID=PCM_INT_PRINT_LABEL

o Web service operation name: To export all Web service operation action links for the Web service
operation.

Provide the value for the $$ OPERATION_NAME search attribute. For example,
$$_OPERATION_NAME=printLabel

Linking Button Callback To Web Service Qperation

To link existing buttons to a component in the destination RMW application, export the links from
the source RMW application and import them to the destination RMW application.

Perform the following steps to export and import component button links:

Step 1: Export existing ‘Web service operation-action link’ from source RMW
application

1. Open the action_webserviceoperation_criteria.properties file.

2. Specify the search attribute values to export the Web service operation-action link.

3. Export the links using the following command:

<migration home>./export.sh -d Development -u admin/admin -c
<migration home>/templates/criteria/action webserviceoperation criteri
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a.xml -o <migration home>/action wsoperations.xml

Step 2: Import the exported Web service operation to action link to destination
RMW application, using the following command:

<migration home>./import.sh -d Development -u admin/admin -i
<migration home>/action wsoperations.xml —op INS

Step 3: Check the newly inserted Web service operation action link through RMW
Web user interface

Open the RMW Web URL in the Web browser.

Log in to the application using valid user credentials.

Navigate to Administration > Library > Manage Record.

Click the Browse tab.

Select category Base >System Folder>Integration Folder>Action to Web service Operation.
Click the Search tab.

Provide the required search criteria, you can use the similar criteria values used for export, like,
button call back ID, Web service operation ID, and so on.
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8. Search for the record and verify that the newly added records are not shown in the search
results.

1. Click on the record to verify the record details.
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