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Preface

Oracle's Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle Technology
Network (OTN) Web site http://www.oracle.com/technetwork/documentation/agile-085940.html
contains the latest versions of the Agile PLM PDF files. You can view or download these manuals
from the Web site, or you can ask your Agile administrator if there is an Agile PLM Documentation
folder available on your network from which you can access the Agile PLM documentation (PDF)
files.

Note To read the PDF files, you must use the free Adobe Acrobat Reader version 9.0 or later.
This program can be downloaded from the Adobe Web site http://www.adobe.com.

The Oracle Technology Network (OTN) Web site
http://www.oracle.com/technetwork/documentation/agile-085940.html can be accessed through Help
> Manuals in both Agile Web Client and Agile Java Client. If you need additional assistance or
information, please contact My Oracle Support (https://support.oracle.com) for assistance.

Note  Before calling Oracle Support about a problem with an Agile PLM manual, please have
the full part number, which is located on the title page.

TTY Access to Oracle Support Services

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398.
Outside the United States, call +1.407.458.2479.

Readme

Any last-minute information about Agile PLM can be found in the Readme file on the Oracle
Technology Network (OTN) Web site http://www.oracle.com/technetwork/documentation/agile-
085940.html

Agile Training Aids

Go to the Oracle University Web page
http://www.oracle.com/education/chooser/selectcountry _new.html for more information on Agile
Training offerings.

Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an otherwise empty line;
however, some screen readers may not always read a line of text that consists solely of a bracket or
brace.

This documentation may contain links to Web sites of other companies or organizations that Oracle
does not own or control. Oracle neither evaluates nor makes any representations regarding the
accessibility of these Web sites.
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Chapter 1
Introducing Agile Drive

This chapter includes the following:

= What you can do With AGIlE DIIVE .........cciceerr s en
= What you cannot do with Agile Drive
S 1 1110 TSP
= Structure OF AGIE DIIVE 931 .. ..o

Agile Drive is a system of managing the file attachments of Agile objects from your computer
system in the form of files and folders, without requiring you to invoke Agile PLM application. It
connects Agile's Distributed File Manager as a network place on your system, thus enabling
Explorer like operations, such as copy or delete, on file attachments of Agile objects. It simplifies file
management, leveraging existing intuitive client applications, like Explorer, Mac Finder, etc.

What you can do with Agile Drive

With Agile Drive, you can carry out the following:

1. Work on Files, such as documents, drawings, etc., associated with Agile objects as File
Attachments in Agile PLM System

* View a File: Opens a file directly from an Agile Drive folder to view it in its native application,
without downloading or checking out.

* Save aFile: Saves a file directly in an Agile Drive folder, thus creating a File Attachment to
the corresponding Agile object in the Agile PLM System.

* Edit a File: Edits a file in its native application directly from an Agile Drive folder without
downloading or checking out. To create a new version, save it as a new file.

® Create a File: Creates a new file in Agile Drive using drag and drop from a non-Agile Drive.

* Delete aFile: Deletes a file from an Agile Drive folder using Delete key, which in turn deletes
the File Attachment from the corresponding Agile object in the Agile PLM System.

*  View File Properties: Views file properties, such as data of creation, date of last modification,
size, etc. Right-click a file in the Agile folder to locate View File Properties.

* Add aFile: Adds a file from your local drive, or any non-Agile network drive, into an Agile
Drive folder. Agile Drive stores this file as a File Attachment to the corresponding Agile
object in Agile PLM system. Agile Drive creates a version of every file that you add (this
applicable only for Design and File Folder objects). You can choose either the Drag-Drop
option or Copy-Paste option to add a file.

® Move aFile: Moves a file from Agile Drive folder. You can Cut-Paste a file from Agile Drive
folder. Agile Drive creates a version of every file that you remove (this is applicable only for
Design and File Folder objects).

®  Copy Files: Copies files from a non-Agile Drive folder into an Agile Drive folder, and vice-
versa. Drag and drop the required file.
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2. Work on Folders

*  View Folder Properties: View file properties, such as number of files within, etc., of an Agile
Drive folder by selecting Properties from right-click menu.

What you cannot do with Agile Drive

This release of Agile Drive does not support the following functionalities:

File Functions

o Save afile to a folder on the Agile Drive. However, you can use Save As option to save a file
under different name.

Note Save As action does not function with Non -Microsoft clients.

o Rename afile

o Check-in files from Agile Drive folders

o Check-out files into Agile Drive folders

o Create files in Agile Drive folder

o Extract data out of an uploaded file in Agile PLM

= Undo operations

Folder Functions

o Create Agile Drive folders

o Copy-Paste or Drag-Drop an Agile Drive folder into another Agile Drive folder
@ Copy-Paste or Drag-Drop a non-Agile Drive folder to an Agile Drive folder
= Rename an Agile Drive folder

Business Functions

o Affected Items & BOM revisions rendering only for ECOs

o Design Structure expansion

o Workflow approvals

@ Status change

= No display of Application data (Cover page/P2/P3)

o PPM Content tab is not supported.

Definitions
Name Descriptions
Agile Drive The Agile Drive is a file system that helps manage the files attached to objects in the

Agile PLM System.
It is a logical representation of the Agile PLM objects and their associated attachments.
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Agile object ~ An Agile object is an entity defined in Agile PLM that groups a set of attributes and
relationships related to that object.

Some of these objects are Item, Folder, etc.

Agile PLM An Agile PLM folder is a folder in Agile PLM system that holds attachments of other Agile
folder objects, such as Item, Change Order, etc. Agile PLM folder is also treated as an
independent Agile object.

Agile Drive An Agile Drive folder represents an Agile object on your system.
folder

non-Agile A folder on your system drive or any network drive other than Agile Drive.
Drive folder

Structure of Agile Drive 931

Agile Drive displays Agile objects as folders, and its Attachments as files in these folders. This can
best be understood by referring the two pictures given below.

Entity In Agile PLM System In Agile Drive
Part A Part is an Agile object. A Part is a folder, called as Agile Drive folder,
Example - P00003 named after the Agile object it represents.
Example - P00003
Revision A Revision is a state of an Agile A Revision is a Sub-folder, again called as
object. Agile Drive folder, named after the Revision
Example - Introductory state of the Agile object it represents.
Example - Introductory
Attachments An Attachment is a file associated An Attachment is a Agile Drive file contained in
to an Agile object. an Agile Drive folder. The name of this Agile
Example Drive file is exactly the same as that of

corresponding Attachment.
Example

- agile_20090224_075051312.axml|
- agile_20090224_113543937.axml|
- MirrorBolt1.SLDPRT

- agile_20090224_075051312.axml|
- agile_20090224_113543937.axml|
- MirrorBolt1.SLDPRT

Agile Drive: An Agile Object and its File Attachments in Agile Drive

Folders x agile_20090224_0750515312, axml
agile_20090224_113543937, axml

= @ AqileDrive on PrastariaDewvagilesaft - 5
= MierrBDltl.SLDF‘RT

= My Bookmarks

= 1 Pooons | Agile Object File Attachments
) introductory REEMEID]

(3 poooos
[ Recently Visited
[C1 searches
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Chapter 2
Setting up the Agile Drive

This chapter includes the following:

B ENVITONMEN ... 5

= Deployment ArChItECIUTE ..o 5

= Enabling Agile Drive in JaVa ClIENL...........ccriiiriiccc e 5

= Configuring the Agile DriVe SEHINGS ..o 6

B MaPPING AGIE DIIVE.......ceieiecicceee ettt bbb bbbttt et r s 8
Environment

You can map Agile drive on the following operating systems:

u]

u]

u]

m]

u]

Microsoft Windows XP
Microsoft Windows Vista
Mac OSX

Linux GNOME

Linux KDE

Deployment Architecture

u]

m]

o

XML based request/response model

Customized version of Tomcat 6.0 Web DAV Servlet
Supported on most platforms

Deployed on File Manager instance as a new Web Application
Communicates with Application Server for object meta data
Caching for better performance

Enabling Agile Drive in Java Client

When you deploy Agile PLM, the Agile Drive is set as Disabled by default. To use Agile Drive,
ensure to enable it in Java Client.

To enable Agile Drive:

1. InJava Client, go to System > Preferences.
2. From the Agile Drive dropdown list, select Enabled.
v9.3.1 5
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Note

&\ Preferences

General Information | Hiskary

By default, Agile Drive is set to Disabled.

add User's Default Site to Mew Items |N0

Agile Drive | [ o4

Agile Scripk Log Level |Oﬂ:

#Allow Download of Productivity Components |Yes

Allows Password Reset |N0

Allow Unsecured Files |\"es

Checksum Computation |Enabled

Content Service Maximum Retries |5

Once you enable the Agile Drive, the access will be Read-only. To change the access to Read-

Write, see Configuring the Agile Drive Settings on page 6.

3. Restart all Distributed File Managers.

Configuring the Agile Drive Settings

As an Administrator, you have to set the property 'readonly:mode’ as FALSE in the settings.conf file
located at \\<Server>:<Port>\webdav\WEB-INF\classes

URL
http://<Server>:<Port>

Name

app.server.url

[Agile/RMIServiet

file.server.url http://<Server>:<Port>
[Filemgr/services/File
Server

# User account

user.name ifsuser

user.pwd 221B758BAAE4C4

# Turns on/off read-only mode

readonly.mode TRUE

# Cache Tuning parameters

cache.reload.interval 2

Description
URL of Agile PLM Application Server

URL of Agile PLM File Manager

Agile User ID

Agile User Password
Appears in encrypted form

Turns on “Read-only” mode — Does not allow add/delete
file actions. Default = “True”

Number of times a user is required to refresh the view
within a short interval to force refresh of cache.

Agile Product Lifecycle Management
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Name URL Description
cache.timeout 30 Time to live (TTL) for cache entries
# Encodes directory names using HTML URL
Encoding
name.encoding FALSE Enables HTML URL encoding on folder names.

# Exclusion Filter - Used to exclude certain file
types (for all users)

# The specified file types will be filtered out of
the file list

# Usage: exclude.filetypes - doc,dwg,prt

exclude filetypes Specify the Files Types that should be filtered out from
being displayed.
For example, to filter out Word files and show only PDFs,
set exclude.filetypes=doc.

# Max folders to display in results. Applicable to

Search Results & BOM.

# Minimum Value > 250

max.rows 1000 Maximum Number of folders.
Applicable to BOM and search results.
Minimum value = 250.
Maximum value = 5000.

Platform Settings

1.

Microsoft Windows Explorer - XP/Vista

Web Folders Client is bundled in XP/Vista. Download and install Microsoft Web Folder Update
KB907306 from

http://www.microsoft.com/downloads/details.aspx?Familyld=17C36612-632E-4C04-9382-
987622ED1D64&displaylang=en

MAC OSX Finder

Disable creation of intermediate file store (.DS_Store), which is used for file uploads to work
correctly.

http://support.apple.com/kb/HT1629

IS Support

Only 1S 6.0 & 7.0 are supported.

Ensure to set the WebDAV Web Service Extension to Allowed.

Optional Settings

1.

Search Timeout

Agile Searches on Windows XP/Vista can timeout after 30 seconds. This is due to the timeout
feature of Microsoft Internet Explorer 7.

v9.3.1


http://www.microsoft.com/downloads/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=17C36612-632E-4C04-9382-987622ED1D64&displaylang=en
http://support.apple.com/kb/HT1629

Agile Drive User Guide

To increase the Microsoft Client timeout, add a ReceiveTimeout DWORD value with a data
value of (<number of seconds>)*1000 in the Registry settings as follows:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\internet Settings

Example: If you want the timeout duration to be 8 minutes, set the ReceiveTimeout data value to
480000 (<480>*1000).

Reboot the computer system.

Mapping Agile Drive
On Windows XP System

To map Agile Drive on your MS Windows XP system:

Note  You cannot deploy Agile Drive on Windows XP-64 and Windows 7 since they do not
contain the web folders component.

1. On the desktop, double-click My Network Places Icon.

)
Ty Mebwork
Places
2. Click the Add a network place link.
In the Add Network Place Wizard, click Next. Choose a network location.

4. Enter the IP Address of server where Agile Drive is deployed, together with its Port Number and
the Folder Name, as follows:

http://<IP Address>:<Port Number>/<Folder Name>/

w

Note  Contact your Agile Administrator for the IP Address and complete path of Agile
Drive.

5. Click Next. In the Connection window that pops up, enter your Agile PLM User name and
Password.

Note  Contact your Agile Administrator for User Name and Agile Drive.

If you do not want the Agile Drive to ask you for User Name and Password each time you
connect, check the Remember my password check box.

6. Click OK. Enter a name for the network place. You can change this name to one of your choice.

7. Click Next.
8. Click Finish.

The Agile Drive Folders window opens up.
On Windows VISTA System

To map Agile Drive on your Windows VISTA system:
1. Click Computer in the Start Menu.
In the Computer window, click the Map a Network Drive Icon.

In the Map Network Drive wizard window, click the Connect to a Web site that you can use to store
your documents and pictures link.

In the Add Network Location Wizard, click Next. Choose a custom network location.
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w

Specify the location of your website.
Select Choose a custom network location.

Enter the IP Address of server where Agile Drive is deployed, together with its Port Number and
the Folder Name, as follows:

http://<IP Address>:<Port Number>/<Folder Name>/

Note  Contact your Agile Administrator for the IP Address and complete path of Agile
Drive.

Click Next.
In the Connection window that pops up, enter your Agile PLM User name and Password.

Note  Contact your Agile Administrator for User Name and Agile Drive.

If you do not want the Agile Drive to ask you for User Name and Password each time you wish
to connect, you may check the Remember my password check box.

Click OK. Enter a name for the network location. You may change this name to one of your
choice.

Click Next.
Click Finish.
The Agile Drive folders window opens.

Note  Agile Drive folders do not open in Windows VISTA by double-clicking. Right-click on it

and select Open.

On Macintosh System

To map Agile Drive on the Macintosh system:

1.
2.

e

Select Connect to Server from Go in Main Menu.

In the Connect to Server window, enter the IP Address of the server where Agile Drive is
deployed, together with Port Number and Folder Name, as follows:

http://<IP Address>:<Port Number>/<Folder Name>/
Note  Contact your Agile PLM Administrator for required data values.
Click Connect.

Enter your Agile PLM User Name and Password.
Click OK. The Agile Drive Folders window appears.

v9.3.1
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On GNOME Linux System

To map Agile Drive on the GNOME Linux system:
1. Select Connect to Server... from Places in the Main Menu.

The Connect to Server screen appears. _
| Connect to Server x|

Service type: [WebDAV (HTTPF) = ]

Server: [10.1?5.138.15? ]

Optional information:

Port: 80 |
Folder: [webdav ]
User Name: [admin ]

)

MName to use for connection: [AgileDrive

| @rep | [Browsenework | [ Xcance |[ Comnect |

2. Enter the following parameters:

Service type Select WebDAV (HTTP) from the drop-down list.

Server Enter the IP Address of the server where Agile Drive is deployed.
Port Enter Port Number of the server. The default value is 80.

Folder Enter webdav in lower case.

User Name Enter your Agile PLM User Name.

Name to use for Enter any name of your choice.

connection

Note  Contact your Agile Administrator for required values.

3. Click Connect.

4. Enter your Agile PLM Password and click Connect. The Agile Drive default folder window
appears.

10 Agile Product Lifecycle Management
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On

Tom

KDE Linux System

ap Agile Drive on the KDE Linux system:

1. Open Shell Console and execute knetattach.

El install@install-Inx:~ - Shell - Konsole <2> — O X
Session Edit View Bookmarks Settings Help

[install@install-lnx ~1$ knetattachf] o

[ ]| @&l shelt %l

2. Select Webfolder (webdav) and click Next.
3. Enter the following data:

Name Enter a name of your choice.

User Enter your Agile PLM User Name.

Server Enter the IP Address of the server where Agile Drive is deployed.
Port Enter Port Number of the server. The default value is 80.

Folder Enter webdav in lower case.

Note  Contact your Agile Administrator for required values.

4. Click Connect. The Agile Drive Folders window appears.

v9.3.1
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Chapter 3
Using the Agile Drive

This chapter includes the following:

Searching for AQIIe ODJECES .......vcuivicece ettt
Working with Files and Folders
Opening files IN AGIIE DIIVE.........cuiuireerierieiriir et
TrACKING VEISIONS ..ottt bbb
Traversing M REVISIONS ........ccuiiiuririeieirieiereee ettt ettt bbbt
Traversing a Bill of Material

You can access Agile Drive using Windows Explorer, listed under My Network Places. When
prompted, log in using your Agile PLM User Name and Password.

For quick access to Agile Drive, you may create a shortcut of Agile Drive on your desktop or create
its menu item in the Start Menu.

Note  MS Vista 64 bit and Windows XP 64 bit are not supported because Microsoft does not
ship the required drivers. To open a folder, right-click on it and select Open.

Note  Your access to Agile Drive folders and files depend on the roles and privileges assigned
to you by Agile PLM Administrator.

Searching for Agile Objects

You can search for Agile PLM objects using Agile's canned (predefined) queries, viz., Global
Searches and Personal Searches. A canned search query appears as a Folder in Agile Drive, and
the Search Results appear as Folders within this folder.

For example, to perform a search called Unreleased Changes That | Created, navigate to the
corresponding Folder. All unreleased changes that you created appear as Folders within this
Search Folder. Navigate to the desired unreleased change folder to see the affected items and its
attachments, if any.

v9.3.1 13



Agile Drive User Guide

=] [:l AgileDrive on PrastoriaDevigilesaft
[ MMy Bookmarks
[ Recently Yisited
B (0 Searches
2 (1 @labal Searches
= 0 warkflow Searches
[C0 All Devistions About Ta Expire
21 Al Released Stop Ships
[_1 canceled Changes That I Created
[ Changes that have been approved by all Approvers
a Changes that have no Appraver
a Changes that have not been approwved by all Approvers

[ Releasable Changes that have been approved
1 Released “hanges That I Created
[ unreleased Changes that all Approvers have approved
(SR L irreleased Changes That I Created
= (O 25000
[ 1000-0z2 - &
[0 sco1_m4n0
[0 scos_100
[ sco7_1o0
[ scora
[ sco7_mion
[:' TEST_ECO4534903
(2 Personal Searches

[ Changes that have nok been signed off For more than 14 days

Search Limitations

Any search that requires user inputs or search criteria is not a feature of Agile Drive. For example,
you cannot search for a specific ECO, say ECO25000. To search for specific searches, you need to

use the Explorer feature of File or Folders search.

To search for specific folders in (MS Windows XP):

1. Click Start > Searches > For Files or Folders...

2. Inthe Search Results window, click All Files and Folders. Specify the search criterion in the

search field(s).

3. Inthe Look in drop-down list, select Browse.. A Browse for Folder window pops up.

4. Expand My Network Places and select the Agile Drive.

5. Click OK to return to the Search Results window.

6. Click Search button. The specified object appears as a folder in the Search results.

14 Agile Product Lifecycle Management



Chapter 3: Using the Agile Drive

Working with Files and Folders

You can perform the following actions on files and folders in Agile Drive.

Note

Due to limitations of the client OS, Agile Drive error messages do not show up correctly

on client side.

Intermittent failures can occur during addition of multiple files on MAC OSX Finder.

How to

View or Read a File

Save a File

Delete a File

View Properties of a File

Steps

In an Agile Drive Folder, double-click a file to read or view. Alternately,
select Open from right-click Menu. The system opens the file in its
associated application.

For example, when you double-click a MS Word Document file in an Agile
Folder, your system invokes MS Word, which opens this document in
editable mode. If MS Word is not installed in your system, you cannot view
the document.

You can open only the MS Office files directly from Agile Drive, provided
MS Office or MS Office Viewer application is installed in your system. For
every other file type, you need to first drag and drop (or copy-paste) the
file to your desktop or local drive and then open it with its associated
application.

In Agile Drive, you can save a file in two ways:

Save a new file in an Agile Drive Folder directly: Create a file in an
application and click Save (or Ctrl+S). In Save window, select the desired
Agile Drive Folder to save in.

Save As: If you edit a file that already exists in an Agile Drive Folder, you
can Save it only As another file. Agile Drive does not support direct editing
and saving of the same file due to versioning aspect of Agile PLM.

If you need to copy a file from an Agile Drive Folder to your system folder,
and want to save it after editing, you need to use the Save As function.

Deletion of a file from an Agile Drive Folder implies removal of a File
Attachment from an Agile Object.

To delete a file, select the desired file(s) in an Agile Drive Folder and
press Delete (Del) Key once, or select Delete from right-click Menu.

The system deletes the file(s) without issuing any warning or requesting
any confirmation. Agile Drive continues to display the deleted file(s) until
you Refresh the display.

Although the file appears deleted from Agile Drive Folder, and from the
corresponding Agile Object, the Agile PLM application does not purge it
out.

Agile Drive does not allow deletion of a Redlined File.

On a desired file in an Agile Drive Folder, select Properties from right-
click Menu. The system displays its General properties.

v9.3.1
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How to

Add a File

Move a File

Copy a File from a non-
Agile Drive Folder to an
Agile Drive Folder

Copy aFile from an
Agile Drive Folder to a
non-Agile Drive Folder

View Folder Properties

Steps
Adding a file in an Agile Drive Folder implies adding a File Attachment to
an Agile Object. You can do this by
- copying & pasting
- dragging & dropping
a file from a non-Agile Drive Folder into an Agile Drive Folder.
Also, by saving, or saving as, a file from an application.
Agile Drive does not display the added file(s) until you Refresh the
display.
When you add multiple Files in Read-only mode of Agile Drive, a pop-up

message appears for each file you add. It is recommended that you add
only one or two files at a time.

In an Agile Drive folder, select the desired file(s). Drag & Drop them into
your non-Agile Drive folder or into any network drive folder.

Conversely, in a non-Agile Drive folder or any network drive folder, select
the desired file(s). Drag & Drop them into the desired Agile Drive Folder.

Alternately, select Move to Folder from Edit Menu in MS Windows
Explorer.

Agile Drive does not support moving or cut-paste a file between Agile
Drive folders.

Moving a file from the Agile Drive does not imply that you remove it from
its associated Agile object. To remove it, you need to delete the file after
moving it.

In a non-Agile Drive folder, select the desired file.

Select Copy from right-click menu. Or, select Copy from Edit Menu of MS
Windows Explorer.

Navigate to the desired Agile Drive folder.

Select Paste from right-click menu. Or, select Paste from Edit Menu of
MS Windows Explorer.

When you copy a group of Files from Agile Drive folder, and do not have
privileges or permissions for a particular file-type, the system does not let
you copy even the ones you have permission/privileges for. Contact Agile
Administrator to know your access rights.

In an Agile Drive folder, select the desired file.

Select Copy from right-click Menu. Or, select Copy from Edit Menu of MS
Windows Explorer.

Navigate to the desired non-Agile Drive folder.
Select Paste from right-click menu. Or, select Paste from Edit Menu of
MS Windows Explorer.

On a folder in an Agile Drive folder, select Properties from right-click
menu. The system displays its general properties.
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Opening files in Agile Drive
Agile Drive supports opening only Microsoft Office format files from the Internet Explorer.

To open files in Agile Drive:
= For HTML, DOC, RTF, XLS, PPT and other Microsoft formats which support Microsoft clients:
Double-click file or open within Internet Explorer after authentication.

Note  Textand PDF files do not open in Agile Drive.

To open text and PDF files:
1. Drag and drop the files to desktop.
2. Click Open.

To open files in Adobe Reader or Notepad:
1. Click File>Open.

2. Navigate to Network Places>Agile Drive.

3. Click Open.

Tracking Versions

Versioning applies to Design objects and File Folder objects of Agile PLM. When you add or delete
a File Attachment from a Design object or a File-Folder object, Agile PLM retains the original status
of these attachments as a Version.

Agile Drive displays these versions as numbered folders under Previous Versions Folder in the
'versioned' Agile object, with Version Number 1 being the oldest/earliest version of the said Agile
object.

This can best be understood with an example, as follows:

1. In Agile Drive, select FOLDER00947, as shown in Screen 1. It contains three Files.

FOLDERO00947 in Agile Drive is an Agile PLM File Folder Object, which has three File
Attachments.

Screen 1: Select a folder in Agile Drive

* Marme Size | Twpe
D FOLDEROO947 A T_—» b289?4.|:u:_lf ©FS5ZME  Adobe Acrobat 7.0 Do,
(CJ FOLDERD105S 4 Bkez.bmp  2.3MB Bitmap Imags
(1 ponoss .ﬂBikﬂS.bmp 336 KB Bitmap Image
[ Recenthy Yisited
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2. Add a File in FOLDERO00947. The folder now contains four files.

Screen 2: Add a file

x Mame Size | Twpe
D FOLDERODQ47 e TT-» I:u28'9?4.|:u:lf 7.52 MB
D EOLDEROLOSS .'_‘ij,EiikEE.I:ump 2.3ME Bitmap Image
(] roooss SdEkeS.brmp 836 KE  Bitmap Image
[0 Recently visited Bllexpart.csvy 5,28 KB

Adobe Acrobat 7.0 Dac,..

Micrasoft OFfice Excel |,

3. Wait for a few seconds and Refresh (press Ctrl+F5) the Explorer view.

A Previous Versions Folder, and a sub-Folder numbered as 1, appears under FOLDER00947.
This implies, FOLDER00947 is the 'latest' version of File-Folder Object, which now has four

File Attachments.

Screen 3: Previous Versions Folder

ENERFoLOER D947

= Mame

~ [ Prewvious Versions

Size

R -
= [ Previous Versions 2= b28374.pf 7.52 MB
Ca1 |4 Bike2.brmp Z.3 MB
(3 FOLDERO10SS 4 BikeS.bmp 836 KB
[C poooss @_ﬂexpnrt.csv 5,28 KB

Tvpe

Web Folder

Adobe Acrobat 7.0 Doc. ..
Eitrap Image

Bitrap Image

Microsoft Office Excel ...

[ Recently Visited
4. Go to the Folder 1 under Previous Versions Folder.

It contains the three Files that originally existed in FOLDER00947 before you added the fourth
File. This implies, the 'earlier' version of the File-Folder Object had three File Attachments.

Screen 4: Earlier/older Version Folder - '1’

x Mame Size | Type
= 1 Previous Yersions C:j, Bikez.bmp 23ME Bitmap Image
] |4 BikeS.brmp 836 KE Bitmap Image

[ FOLDERD1OSS
[ Poooss
[ Recently Yisited

5. Now go back to FOLDERO00947, which is the ‘'latest’ version. Delete one of the Files, say

Bike2.bmp. This Folder now has three files.

This implies, you have deleted a File Attachment from the File-Folder Object.

Screen 5: Delete a File

* Mame Size | Type
B Fooero0947 7 (A Previous Yersions Web Folder
= [ Previous Versions T bzao74. pof 7.52MB  Adobe Acrobat 7.0 Doc
011 %4 BikeS bmp 836 KB  Bitmap Image
([ FOLDERODLOSSE @expnrt.csv 5,28 KB Microsoft Office Excel .

(1 Poooss
[ Recently Visited

18

Agile Product Lifecycle Management



Chapter 3: Using the Agile Drive

Wait for a few seconds and Refresh (press Ctrl+F5) the Explorer view.

The Previous Versions folder now has Two sub-folders numbered 1 and 2. This implies, the Agile
Drive folder number 2 is the 'previous' version of the said File-Folder object, FOLDER00947,
and it has the four File Attachments that existed before you deleted one.

Screen 6: Previous Version

x Mame Size

= [ FOLDEROOG47 A Tbzaor4.pdf 7.52MB
= [ Pravious Yersions I::i Bike2.bmp 2,3 MB
a1 | BikeS.bmp 836 KB

[ E &l export.csv 5,25 KB

[ FOLDERD10SS
[ Poooss
2 |:I Fecently Visiked

Twpe

Adobe Acrobat 7.0,
Bitrap Image
Bitrap Image
Microsoft Office Exc

Likewise, each time you add or delete any file in an Agile Drive Folder (corresponding to a Design
Object or File-Folder Object), it maintains the original files in version numbered folders under

Previous Versions folder.

Note  You cannot Add or Delete Files from any of the Previous Version folders.

If you delete, or purge, a version in Agile Application, the deleted or purged versions do not appear
in Agile Drive. That is, the corresponding version folders do not appear in the corresponding Agile

Drive folder.

The number of version folders that you see depends on the settings in Agile Application.

Note  Refreshing (Ctrl+F5) the view in MS Windows XP Explorer does not display the changed
versions in the folders (left) pane, although the changed versions appear in the right

pane.

v9.3.1
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Traversing ltem Revisions

A Revision in Agile Drive appears as a 'prefix' to the Change Object. The structure of Agile Drive
folder, thus, appears as follows:

<Revision Name> - <Change Object Name>

Example: In the image shown below, the Agile Drive folder B - ECO-00075 corresponds to Revision B of
Change Object EC0-00075 associated to Agile object P00058.

3 U] Pending & Latest
# J[(C)]- ECO-00076_——  Release Revisions

+ I(UNOEFINED) -[ECO-OOO?? I
i L) (X¥2) - ECO-00076 Change Number

# (J[8} eco-0007s
= /] [Other Revisions| «————— Contains Introductory

& Latest Revisions
Reision # )[a} eco-oo0s4 o

Names —J Introductory

The Agile objects, whose Revisions are not yet defined in Agile Application, are represented as
<UNDEFINED> - <Change Object Name>

Example: In the image shown above, a new Change Object, EC0-00077 has not been assigned a
Revision Number, i.e., it is in Pending state. Hence, in Agile Drive, it appears as (UNDEFINED) - ECO-
00077.

When you create a Part, its Revision state is Introductory. When you bring about a change to this
Part, a Revision is created, which is identified by a Revision Number. Once the Revision Number is
assigned, it remains in the pending state until released. This pending state is represented by the
enclosing the Revision Number in Brackets.

Example: In this image, (C) - ECO-00076.

Agile Drive moves the 'earlier released revisions' into an Agile Drive folder called Other Revisions,
except for the latest released revision. Every time an Agile object goes through a Change, the latest
revision appears as an Agile Drive folder under the folder for the main object.

Example: In the image shown above, the Agile Object P00058 had undergone a change by means of
Change Object EC0-00064, which was revised only once as Rev-A. Later, it went through another
change, EC0-00075, which was revised to Rev-B.

Note  Agile Drive does not display the structure of Design objects.

20 Agile Product Lifecycle Management



Chapter 3: Using the Agile Drive

Traversing a Bill of Material

The Bill of Material (BOM) of an Agile object appears under its corresponding Change Object as
Agile Drive folders.

In a BOM, the File Attachments of a Parent Object are located in its Change Object. For example,
the File Attachments of Part P00058 are located under the folder B - ECO-00075, which corresponds to
the Change Object of this Part.

The File Attachments of a Child Object are located in its corresponding Folder. For example, 100-
01014-A is the child object of P00058.

SR ] 00053 | Parent Object
= _llﬂmm_mzz] «—— Pending Parent
@ ] 100-01009- A Object Change

% ) 100-01010- A
+ _]4— Child Obyject
BOM Parts ® _J 100-02001 - A
= L (X¥2Z) - ECO-00076
{ + ) 100-01004 E . BOM Part Revision
+ ) 100-02001 - A
= ([B-EC0-00075] +——— Released Parent
# ] 100-02001 - A Object Change
= ] Other Revisions
= ] A-ECO-00064
# ] 100-02001 - A
J Introductory
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