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ABOUT THIS MANUAL

Agile Product Lifecycle Management for Process Documentation

Audience

The Agile Product Lifecycle Management (PLM) for Process documentation set
includes user guides, an administrator’s guide, and release notes, all in Adobe®
Acrobat™ PDF format. The Oracle Documentation Web site contains the latest
versions of the Configuration PDF files. You can view or download these manuals
from the Web site, or you can ask your administrator if there is an Agile PLM for
Process Documentation folder available on your network from which you can
access the documentation (PDF) files. Visit the Oracle documentation Web site
at:

http://www.oracle.com/technology/documentation/index.html

Note The minimum software requirement for reading the PDF files is Adobe
Reader™ version 6.0. You can download this free program from
www.adobe.com.

If you need additional assistance or information, please contact
support@agile.com or phone (408) 284-3900 for assistance.

Before calling Agile Support about a problem with an Agile PLM for Process manual, please
have ready the full part number, which is located on the cover.

This user guide is intended for end users who are responsible for creating and
managing information in Agile Product Lifecycle Management for Process.
Information about administering the system resides in the Agile Product Lifecycle
Management for Process Administrator User Guide.

Variahility of Installations

Descriptions and illustrations of the Configuration user interface included in this
manual may not match your installation. The user interface of Configuration
applications and the features included can vary greatly depending on such
variables as:

Which applications your organization has purchased and installed

Configuration settings that may turn features off or on
Customization specific to your organization

Q
Q
Q
0 Security settings as they apply to the system and your user account
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Where to Find Information

Consult the table below to find specific information from the relevant
Configuration information source.

Table 1: Configuration documentation topics, by source

Install/  Admin.
Information type Upgrade User

Readme Agile Agile
file training Desk sales rep

Guide Guide
Cache management o
Core data management
Custom data management
Custom sections
Extended attributes
Feature requests ] o
Group management

Installing Agile PLM for
Process

Known issues (
Last-minute changes o
Managing specifications
New in this release (
Printing o
Resolved issues (
System-hased roles o
Technical support o

Upgrading Agile PLM for P
Process

User management o
Workflow management o

Readme
Any last-minute information about Configuration can be found in the Readme
file on the Oracle documentation Web site (http://www.oracle.com/technology/
documentation/index.html).

Agile Training
Agile offers end user, administrator, developer, and implementation training
courses. For more information, contact your Agile project manager or sales
representative.
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About This Manual

Document Conventions

The following formatting elements appear in Configuration documentation.

Element Meaning

Helvetica Condensed, | A user interface (UI) element that a procedure is instructing
9 pt. bold type you to click, select, or type into. For example, buttons or text
entry fields.

9 pt. monospace font |Code samples

10 pt. monospace File names or directory names

font

Blue italic font The linked portion of a cross-reference. Click it to go to the
referenced heading, table, or figure.

Minion Typeface, A named UI element that a procedure is describing but not

Title Case instructing you to click, select, or type into.

Alerts you to supplemental information.

Note Minion 11.5 pt,
with faint blue
bar over & under

Alerts you to possible data loss, breaches of security, or other
more serious problems.

Caution! Minion
11.5 pt, with
faint red bar
over & under

Alerts you to supplementary information that is essential to
the completion of a task.

Important Minion
11.5 pt, with
thick red bar
over & under

Vii
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CHAPTER 1
Installation

This chapter discusses Agile Product Lifecycle Management for Process installation and includes the
following topics:

Installation Requirements

o Pre-Installation Checklists

a Installation

a Post-Installation Checklists

(]

Overview

Installing Agile Product Lifecycle Management for Process involves several steps,
including:

(]

Understanding system requirements

Performing pre-installation tasks (such as setting up the Web application
server and database)

(]

(]

Running the command prompt installation batch files

(]

Performing post-installation tasks, such as:
+ Configuring the remote container service
+  Performing some base application environment configurations

+ Testing the installation

Installation Requirements

This section discusses Agile Product Lifecycle Management for Process
installation requirements for the client, application server, and database server.
Make sure your systems meet all installation requirements before attempting to
install the Agile application suite. In order to properly run, Agile Product
Lifecycle Management for Process requires a Web client, a Web application
server, a remoting container (provided by Agile), and a database server. Figure 1-
1 on the next page shows the necessary architecture.

1-1
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Web Clients
4 l N\
Application Remoting
\_ servers Container Y,
Datab
\‘““-h-h

Web Client Requirements
To properly run Agile Product Lifecycle Management for Process, Web clients
must meet the following minimum requirements:
0 Internet Explorer 6.0
0 Adobe Reader 7.0
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Web Application Server Requirements
To properly run Agile Product Lifecycle Management for Process, Web
application servers must meet the following requirements:

Microsoft Windows™ 2003 Server, SP1

Microsoft IIS 6.0

Internet Explorer 6.0

Microsoft .NET Framework 2.0

Dual processor 2.0GHZ (Xeon recommended)

2.0 GB Memory

10K RPM Ultra360 SCSI with minimum RAID 1

T I N N A

Each application in the Agile application suite can be hosted on one or more Web
application servers.

Note We recommend that you use separate application pools if the same Web
application server is shared across Agile applications.

SQL Database Server Requirements
To properly run Agile Product Lifecycle Management for Process, the SQL

database server must meet the following minimum requirements:

0 Microsoft Windows 2003 Server, SP1

0 Microsoft SQL Server 2005, SP2

0 Dual processor 2.0 GHZ (Quad capable, Xeon recommended for expansion)
a 2.0 GB memory

0 10K RPM Ultra360 SCSI with minimum RAID 1 (separation of SQL database
and log files recommended)

o Two disk arrays (for database and log file separation)

Note The database server can be managed in a clustered environment.

Oracle Database Server Requirements

To properly run Agile Product Lifecycle Management for Process, the Oracle
database server must meet the following minimum requirements:

Oracle database 10.2.0.3 or higher

Operating system supported by the Oracle database

Dual processor 2.0 GHZ (Quad capable, Xeon recommended for expansion)
2.0 GB memory

10K RPM Ultra360 SCSI with minimum RAID 1 (separation of datafiles and
redo logs recommended)

I A

0 Two disk arrays (for datafile and redo log separation)

1-3
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Remoting Container Requirements

Scaling Requirements

With the Agile application suite, you receive the Agile Remoting Container, a
Windows OS-level service. This remoting container can exist on the same Web
application server described above. The following are minimum requirements
for the remoting container:

0 Microsoft Windows 2003 Server, SP1

0 Microsoft NET Framework 2.0

The Agile remoting container typically hosts the following Agile services:

0 Authentication bridge for Agile Single Sign-on (SSO)
0 Authorization bridge for Agile SSO pertinent to DRL file access

0 Syndication server (a component of Content Syndication and
Synchronization)

Reporting Queue service
Taxonomy Denormalization service

Import/Export service

O 0 O O

Object-level security Denormalization service

Note The remoting container can be scaled or isolated as needed.

You will need to scale your system for performance and availability as your
system begins to grow due to an increased use of the Agile application suite and
a growing number of users and as your business demands change or increase. The
following sections provide scalability recommendations.

Scaling for Performance

You will need to scale for performance as your number of users and applications
begins to increase over time. In consideration of performance scaling, we
recommend the following:

0 No more than 250 registered users per processor.

0 Organize scaling according to regional user patterns (according to users in
similar time zones and geographical regions).

0 Once physical Web application server limitations are met, use aload-balanced
(logical or actual) solution.

1-4
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Scaling Beyond Five Core Applications
The following are recommendations for scaling beyond five (5) core Agile
applications. Core Agile applications include:

Global Specification Management (GSM)

Supply Chain Relationship Management (SCRM)
Design Workbench (DWB)

New Product Development (NPD)
eQuestionnaire (eQ)

Agile applications portal

0 Run no more than five (5) core Agile applications on a single Web application
server.

0 Organize scaling based on an evaluation of utilization patterns (known
application characteristics).

Load Balancing

As mentioned above, once physical Web application server limitations are met,
use a logical load-balanced solution based on application distribution across
servers. For example, as shown in figure 1-2 below, a logical separation might be
organized by application as follows:

GSMAppGroup—Includes GSM and other complimentary applications

DWBAppGroup—Includes DWB and other complimentary applications

1-5
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Figure 1-2: Agile Product Lifecycle Management for Process deployed in a logical separation

-

~N

GSMAppGroup DWBAppGroup )

Database Server ]

\. | J

Scaling for Availability
You may also need to scale for availability as your business demands begin to
change or increase over time.

For application load-balancing, we recommend the following:
0 A load balancer (such as {5 BigIP or Cisco CSS11000) that supports the
following:
+ Secure Sockets Layer (SSL) protocol
+  Sticky sessions

0 A maximum of five core Agile applications per load-balanced node.

Note A clustered node is an expansion of a logical application separation.
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For database, file, and service clustering, we recommend the following:

0 A clustered server to support an active or passive database system

0 A file cluster (where required)

o Service clustering

Figure 1-3: Sample deployment of a load-balanced and clustered system

(

GSMWebFarm DWBWebFarm

g “

DB/File/ServiceClusteri

EER

File server
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Pre-Installation Checklists

This section discusses Web application server-related tasks that an Agile
implementer must complete before installing the Agile application suite.

Microsoft IIS 6.0 Checklist

Before installing the Agile application suite, complete all of the Microsoft IIS 6.0-
related tasks in the following sections:

o000 U

Adding an I1S Server Role to Microsoft Windows 2003
Configuring the IP Address of the IIS Default Site
Configuring IIS Application Pool Settings

IIS Metabase Explorer Settings

Enabling IIS Indexing Service

Enabling IIS WebDAV for NPD Applications

Adding an IIS Server Role to Microsoft Windows 2003

You will need to create a Web server role using the ASP.NET Role Manager. The
role type must be the IIS server role, ASP.NET only.

To add a role for lIS, follow these steps:

1

Click Start > All Programs > Administrative Tools, and then click Manage Your
Server.

On the Manage Your Server page, click Add or remove a role, and then click
Next.

Under Server Role, select the Application server (1S, ASP.NET) server role,
and then click Next.

Check the Enable ASP.NET box, and then click Next.

Verify that Enable ASP.NET is listed on the Summary of Selections page, and
then click Next.

If prompted, insert your Windows Server 2003 CD in the CD drive, and then
click Next.

Click Finish.
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Configuring the IP Address of the IIS Default Site

When you install IIS, it is preconfigured to serve as a default Web site; however,
you may want to change some of the settings.

To change the basic settings for the Web site:

1

10
1

Log on to the Web server computer as an administrator.

Click Start > All Programs > Control Panel.

Double-click Administrative Tools, and then double-click Internet Services

Manager.

Right-click the Web site that you want to configure in the left pane, and then

click Properties.

Click the Web site tab.

Enter a description for the Web site in the Deseription box.

Enter a value in the IP Address field for the Internet Protocol (IP) address to

use for the Web site.

Modify the Transmission Control Protocol (TCP) Port as appropriate.

Click the Home Directory tab.

+ To use a folder on the local computer, select a directory located on this
computer, and then click Browse to locate the folder to use.

+ To use a folder that has been shared from another computer on the
network, click a share located on another computer, and then either type
the network path or click Browse to select the shared folder.

Click Read to grant read access to the folder (required).
Click OK to accept the Web site properties.

1-9
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Configuring IIS Application Pool Settings

You must configure various IIS Application Pool settings as follows:

1

Log on to the Web server computer as an administrator.

2 Click Start > All Programs > Control Panel > Administrative Tools > Internet

Information Services (11S) Manager.

In the left pane, expand the local computer and locate Application Pools.

Right-click the DefaultAppPool option.

Make the following configuration changes:

+ On the Recycling tab, deselect all five check boxes.

*  On the Performance tab, check the Limit the kernel request queue box. Set
the value to 4000.

*  On the Health tab, check the Predefined box. Set the value to
LocalSystem.

+  Set the Application Pool Identity to Local System.

IS Metabase Explorer Settings

IIS Metabase allows you to view, edit, copy, paste, move, drag, drop, and monitor
activity in your IIS metabase. You will need to install the IIS Metabase Explorer
1.1 and make the following Application Pool Key settings:

0 Set DissallowOverlappingRotation to 1 (from 0)

0 Set LogEventOnRecycle to 255 (from 137)

Enabling IIS Indexing Service

The Microsoft Indexing Service, a component of Microsoft IIS 6.0, allows for full
text searching for attachments. The following is a checklist for setting this service
up for use with the Agile application suite:

1

Ensure that Microsoft Indexing Server is installed. This is a separate
Windows component that may or may not have been installed with the
original operating system.

« In Control Panel, click Add or Remove Programs.

+ Select Add/Remove Windows Components.

+  Make sure the component Indexing Service is installed.

Delete the two default catalogs that are created when the Microsoft Indexing
Server is installed using the Computer Management tool under Control Panel
> Administrative Tools. This is an optional step; however, it provides for
increased security if these catalogs are not going to be used.

Create two folders to house the files generated by the Index catalog. For
example:

c:\catalogs\GSMSpecs

c:\catalogs\XDocs

4 Stop the Indexing service.
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5 Add a GSMSpecs catalog to the Indexing Server again using the Computer
Management tool. Use the following specifications:
Name: GsMSpecs

Location: c: \catalogs\GSMSpecs
6 Add an XDocs catalog to the Indexing Server using the following
specifications:
Name: XDocs
Location: c: \catalogs\XDocs

7 Add the directory that the GSMSpec files are stored in to the GSMSpecs
catalog. Note that the Alias field is optional and can be left blank. Ensure that
the Include in Index option is selected.

8 Add the directory that the XDoc files are stored in to the XDocs catalog.

9 Restart the Indexing service.

Enabling IIS WebDAYV for NPD Applications

Ifyou are installing the Agile NPD (New Product Development) application, you
must enable the WebDAV (Distributed Authoring and Versioning) protocol in
Microsoft IIS 6.0 to support in-place editing.

Set up the WebDAV environmentsettings.config file as follows (using the
following examples):

PDFWorkArea = https://<hostname>/webdav/npdworkarea/
PDFCommentRepository = https: //<hostname>.com/webdav/
pdfcomments/

OfficeDocWorkArea = https://<hostname>.com/webdav/npdworkarea/
PDFWorkAreaUNC = https://<hostname>/webdav/npdworkarea/
OfficeDocWorkAreaUNC = \\<hostname>\webdav\npdworkarea\
PDFCommentRepositoryUNC = \\<hostname>\webdav\pdfcomments\

Note Be sure to create accounts with appropriate permissions to allow the Web
application server access to the above WebDAV UNC paths.

Set up the Microsoft IIS 6.0 configuration for WebDAV as follows:
1 Create a virtual directory named webDAV with default IIS 6.0 settings.
2 Create two directories under the webbDav vdir:
* PDFComments (with browsing enabled)

* NPDWorkarea (with no browsing)

3 In the WebServiceExtensions folder, ensure the webDAV directory is set to
‘Allowed.’

Note It may be necessary to give the account used by IIS (iuser_machinename)
admin rights or full access to the webDAV virtual directory.
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Microsoft SQL Server 2005 Checklist

Refer to Microsoft SQL Server documentation for installation instructions. For

information on the MS SQL Reporting Server, which can be optionally installed,
refer to the Agile Product Lifecycle Management for Process Configuration Guide.

When installing MS SQL Server 2005 Standard Edition, be sure to:

Q Install MS SQL Server 2005 Standard Edition with the mixed mode
authentication and default options.
Ensure that character set and sort order are MS SQL defaults.)

Run the MS SQL Server setup.

Select Install Database Server and click Next.

—~

Select Install Default Instance on Local Computer and click Next.
Select Default Instance and click Next.

For Setup Type, select Typical and click Next.

A G A W N =

Select Use Same Account for Each Service and Use the Local System
Account and click Next.

7 Select Mixed Mode. Enter a System Admin password and confirm.
8 Click Next twice to complete the installation.
O Configure the MS SQL Server 2005 settings as follows:
1 In the SQL Server Enterprise Manager, right-click the server in the tree
view, left pane.
2 Select Properties and click the Memory tab.
3 Select Use a Fixed Memory Size.

4 On the Processor tab, under Processor Control, select all available
processors.

5 Click Boost SQL Server Priority, assuming the box is only running SQL
Server.

6 Under Parallelism, select Use All Available Processors.

7 Under Database Settings > New Database Default Location, set the
appropriate paths for the data and log files:
« Data files:

array2\Program Files\Microsoft SQL Server\MSSQL\Data
(optimized for balance of reads and writes - 75/25)

* Logfiles:
arrayl\Program Files\Microsoft SQL Server\MSSQL\Data
(optimized for sequential writes)

8 On the General tab, select Autostart SQL Server and Autostart SQL Server
Agent.
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SSL Checklist

Set up two SQL accounts, which are recommended to run and manage the

application:

+ ProdikaDBAdmin—This account should have database owner access to
the application database. Use this account to run the application
installation and upgrade scripts.

+ ProdikaAppUser—This account will be used by the Web server
applications for access to the back-end data and should have read/write
access to all of the application database tables and views. Additionally,
this account should have access to execute all user-defined functions.

Apply all available security patches for MS SQL Server 2005.

Schedule a maintenance plan. Production backups should occur nightly.
Test backups should occur twice weekly.

1 In the Enterprise Manager, drill down in the left pane to Management >
Database Maintenance Plan.

2 In right pane, right-click and select New Maintenance Plan.
3 Select the database to maintain.

4 Click through the Wizard to configure the database maintenance plan.

SSL (Secure Sockets Layer) is a protocol from Netscape Communications
Corporation that is designed to provide secure communications on the Internet.
SSL is not required for an Agile installation but will be used in most instances, as
determined by the customer.

SSL can be deployed in many ways. Most commonly, SSL will run within IIS or
on an intermediary system such as a Reverse Proxy or SSL accelerator.

The Agile application suite can operate in any of these scenarios, but the HTTP
scheme must be configured (via deployment .xml) to generate the desired
relative URLs correctly (http vs. https).

East Asian Language Support
If you plan to support foreign languages in Agile Product Lifecycle Management
for Process, you must install East Asian language support on the server.

To install East Asian language support on the server:

1

Access the Windows Control Panel dialog box by clicking Start > Control
Panel.

Select Date, Time, Language, and Regional Options > Regional and Language
Options and click the Languages tab.

Check the Install Files for East Asian Languages box.

Click Apply and OK.
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Restoring the Database and Setup Database Accounts

You should receive a copy of a prepared database as part of your Agile software
media from Agile Software. Using Microsoft SQL Server Management Studio,
you will need to restore this database onto your local database server. You will
also need to make sure that the user responsible for accessing the database has the
appropriate account setup and assigned roles.

Restoring the Database
To restore the database onto your local database server:

1
2

10

Open MS SQL Server Management Studio.
In the left pane, right-click on Databases and select Restore Database.
The Restore Database dialog displays.

In the General page, type a database in the To Database field.

Note We recommend that your database name include the environment
name and software version, for example: production_v50.

Select From device.

Click the browse button for the From device text box, which opens the
Specify Backup dialog box.

Click the Add button to display the Locate Backup File dialog box. Browse to
the software media containing the database from Agile Software.

Click OK twice to return to the Server Management Studio.

In the Options page, select Restore Database.

Verify that the data file and log file paths are set to the correct paths.

Click OK to begin the restoration.
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Setting Up User Permissions
To set up database user permissions:

1
2

Open MS SQL Server Management Studio.

In the left pane, drill down into the Databases folder to locate the database
that you just restored.

For this database, select Security > Users.

Right-click on Users and select New User to display the Database User - New
dialog box.

Type a user name in the User Name field.

Select Login Name. To the right of this radio button, click the browse button
to display the Select Login dialog box.

In the Select Login dialog, click Browse to display a list of login objects. Select
alogin object and click OK twice to return to the Database User - New dialog
box.

In the Database Role Membership section, assign the following two roles to
the user:

» db_datareader
- db_datawriter
Click OK.

Remote Container Service and Application Pool Accounts
The remote container service and application pool are standard Microsoft
Windows services, which require user accounts in order to run. During the Agile
installation, the service is installed as the Local System account.

To change the account which the service runs under:

1
2
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Select Start > Administrative Tools > Services.

Locate the RemoteContainerService within the list of services listed in the
Services dialog box.

Right-click the RemoteContainerService row and select Properties.

Select the Log On tab.

Select the This account radio button.

Select the user account that has the necessary security access to run the
Remoting Container Service.

Before installing Agile Product Lifecycle Management for Process, make sure that
your IT department has created an account for each service. Such accounts can
be system accounts, local Windows accounts, or domain accounts (active
directory). The process for creating a remote container service account and
application pool account is a standard approach for creating Windows accounts.
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Installation Process

The Agile PLM suite is installed through a set of manual configuration steps.
Several of the steps are automated with utility batch scripts for a default
configuration. The overall process consists of the following steps:

Set up PRODIKA_HOME

Install the core application files

Register environment components

Install individual media bundle application files
Set up the initial IIS Web site

Set up the initial IIS application pools

Register .Net version 2.0 for ASP

Restore the reference database

Configure applications

O 0 U U U U 0 U 0 O

Complete optional steps

Setting up PRODIKA_HOME

Note This step needs to be done only once per Web site instance. If you have
multiple instances of the Agile PLM suite running on the same server, you
will need to perform this step once per instance.

1 Create a folder (e.g. c:\PLM) into which to install the application. For
instructional purposes, this folder will be called PRODIKA_HOME.

Installing the Core Application Files

Note This step needs to be done only once per PRODIKA_HOME. If you have
multiple instances of the Agile PLM suite running on the same server, you
will need to perform this step once per instance.

Throughout the instructions below, the place where you extracted the media
bundle zip file will be referred to as INSTALLER_HOME.

1 Open the containing directory for INSTALLER_HOME.

2 Extract Core.zip located in INSTALLER_ HOME\PDM (where PDM is the
name of the media bundle being installed) to a temporary directory (i.e.;
c:\temp). This will give you a directory structure like c:\temp\Apps,
c:\temp\Config, etc. This temporary directory will be referred to as
TEMP_HOME.

3 Copy FileCompressionHelper.exe from INSTALLER_HOME to
TEMP_HOME.
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4 Open a command prompt and navigate to TEMP_HOME (i.e.; >cd
c:\temp).
5 Run the following:

>FileCompressionHelper.exe -d

Important It is extremely important that you perform the decompression
described in step 5 before continuing to install any additional media
pack bundle files.

6 When the distribution is complete, move your TEMP_HOME contents to
PRODIKA_HOME.

Registering Environment Components
1 Register event logs.
a Open a command prompt and navigate to
INSTALLER_HOME\Installen\Tools.
b Run the following batch file:

>SetupEventLogs.bat

¢ You will be asked to verify the addition of each event log to your system
event logs. Click Yes/Ok through all of the event log additions.
2 Register Component Art and Apoc.
a Open a command prompt and navigate to
INSTALLER_HOME\Installen\Tools.
b Run the following batch file:
>ConfigureRegistry.bat
¢ You will be asked to verify the addition of each registry entry. Click Yes/
Ok through all of the event log additions.
3 Install the Remoting Container Service.

Note This step needs to be done only once per PRODIKA_HOME. If you
have multiple instances of the Agile PLM suite running on the same
server, you will need to perform this installation once per instance.

a Open a command prompt and navigate to
INSTALLER_HOME\InstallenTools.
b Stop IIS - from the command prompt type the following:
>iisreset /stop
¢ Run the following batch file with <PRODIKA_HOME?> replaced by your
specific PRODIKA_HOME directory:

>InstallRemotingContainerService.bat <PRODIKA_ HOME>
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Installing Individual Media Bundle Application Files

1
2

Open the containing directory for INSTALLER_HOME.

Extract the media pack zip file (where the name can be one of PDM.zip,
FC.zip, SupplierCollab.zip, or NPD.zip) located in INSTALLER_HOME to a
temporary directory (i.e.; c:\temp). This will give you a directory structure
like c:\temp\config, c:\temp\FileCompressHelper_CentralDirectory &
c:\temp\Web.

Copy FileCompressionHelper.exe from INSTALLER HOME to
TEMP_HOME.

Open a command prompt and navigate to TEMP_HOME (i.e.; >cd
c:\Temp).

For all of the media bundles other than the NPD media bundle, run the
following utility application:

>FileCompressionHelper.exe -d

When the distribution is complete, move your TEMP_HOME contents to
PRODIKA_HOME.

Accept the warning(s) to overwrite the directories that already exist.

Setting Up the Initial IIS Web Site

It is recommended that you create a new Web site under IIS under which the
Agile PLM suite will be managed. If you choose to run the suite under the default
Web site, you may skip this step.

1

Open the Internet Information Services (IIS) Manager utility Start > All
Programs > Control Panel.

Double-click Administrative Tools, and then double-click Internet Information
Services Manager.

Expand the {server_name} node, where {server_name} is the name of the
server.

Expand the Web Sites node.

Right-click the Web Sites node and select New > Web Site....

Click Next.

Enter a Description (e.g. Agile PLM) for your Web site.

Click Next.

Set the IP configuration and Host Header for your Web site.

Click Next.

Set the path to point to the PRODIKA_HOME directory you created as the
first step of this installation.

Leave the Allow anonymous access to this Web site checked.

Click Next.

Make sure the Read, Run scripts (such as ASP), and Execute (such as ISAPI
applications or CGI) are checked.

Click Next.

Click Finish.
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Setting Up the Initial IIS Application Pools

In a default installation, it is recommended that you run the suite of applications
under multiple application pools in order to provide better resource
management and security. The utility scripts are designed to place the different
applications under the same application pool, or you may run the
SetupVirtualDirectories.bat file manually giving the values for the specific Web
applications to segment them as you see fit.

The general process of installing the necessary Web applications using the utility
scripts is listed below:

1

2

Open a command prompt and navigate to the directory

INSTALLER_HOME\Installer\Tools.

To install the core virtual directories, choose one of the following options:

« Option 1, Creating a single app pool—To install the core Web site
virtual directories, type the following where the values
<PRODIKA_HOME>, <siteid> & <AppPool> are replaced with the
values associated with your specific environment:

SetupCoreVirtualDirectories.bat <PRODIKA_HOME> <siteid>
<AppPool>

+ Option 2, Segmenting the applications into separate application
pools—To manually create the virtual directories needed for the
individual applications within the core application bundle, type the
following. You will need to repeat this script for each of the different
applications within core. Refer to the SetupCoreVirtualDirectories.bat
file to determine the applications within core.

SetupVirtualDirectories.bat drl <siteid> <PRODIKA_HOME> <AppPool>
drl

Note Please refer to the section Determining a Web Site’s Site ID on page 1-
20 to determine the value for <siteid>.

Each media bundle has an associated
Setup<MediaBundle>VitualDirectories.bat batch file where
<MediaBundle> is PDM, FC, SupplierCollab or NPD. To install the
necessary virtual directories for each installed media bundle, repeat the
process outlined in step 2, replacing <Media Bundle> appropriately.

Registering .Net version 2.0 under ASP

1

Open a command prompt and navigate to INSTALLER_HOME\Installer\Tools.

2 Run the following command:

>RegisterASP_2_0.bat
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Installing the Reference Database

There is a reference database that is located under
INSTALLER_HOME\Database. Restore this database to your database server by
following the instructions outlined under the Restoring the Database on page 1-
14 and Setting Up User Permissions on page 1-15 section earlier in this guide.

Configuring Applications
Review the Agile Product Lifecycle Management for Process Configuration Guide to
apply the configuration changes required for the installation.

Completing Optional Steps

For the NPD media bundle, create the WebDAYV folder. Some parts of the Agile
suite use WebDAV to allow in-place editing of certain document types. To allow
for this, a setting is available in the <PRODIKA_HOME>/config/Custom/
EnvironmentSettings.config file for the WebDAV virtual folder. In cases for
which WebDAV is required, create a WebDAYV virtual folder and allow the
anonymous user to access (read and write) the physical folder location on the
hard drive. Refer to Installing WebDAV on page A-1 for instructions.

Determining a Web Site’s Site ID

To determine the Site ID for a new Web Site within IS 6.0:

1 Open the Internet Information Services (IIS) Manager utility by selecting
Start > All Programs > Control Panel.

2 Double-click Administrative Tools, and then double-click Internet Information
Services Manager.

3 Expand the {server_name} node, where {server_name} is the name of the
server.

4 Expand the Web site’s node.

5 Right-click the {website_name}, where {website_name} is the name of the
Web site for which you wish to obtain the Site ID, and select Properties from
the context menu that is displayed.

6 In the {website_name} Properties dialog box, on the Web Site tab, inside the
Enable logging section, next to the Active log format: drop down list, click
the Properties button, as figure 1-4 shows below.
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Figure 1-4: Properties button
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The Logging Properties dialog box displays.

7 At the bottom of the Logging Properties dialog box is a line of text with the
name of the log file for the {website_name} Web site in the form
W3SVCXXXX\exyymmdd.log. The XXXX in that field is the site ID assigned
to the {website_name} Web site, as figure 1-5 shows below.
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Figure 1-5: Log file containing site ID
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Post-Installation Checklists

This section discusses tasks that an Agile implementer must complete after
installing the Agile application suite.

Setting the IIS Event Viewer Logging

Important This step is critical to successfully running the Agile application suite.
You must set the Event Viewer logging to Overwrite events as needed
for System, Security, Application, and all Agile-created event logs.

If an event log is set to Overwrite events older than 7 days, then you may run into
an issue when a new feature is introduced that uses multiple Warnings, Errors, or
Information. The introduction of new event logging can fill up the event log so
that no more events can be logged, throwing an exception back to the user of the
application. The exception will not go away until the log is set to Overwrite events
as needed or until the log is cleared manually. For this reason, we suggest setting
all event logs to Overwrite events as needed.

Important You will need to start up every Agile application, which will generate
a new event viewer log. Review each event viewer setting to make sure
the Overwrite events as needed option is selected.
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To set the 1IS Event Viewer Logging in IS 6.0:

1 On your desktop, right-click the My Computer icon.

2 Click Manage from the fly-out menu to display the Computer Management
dialog box.

3 In the left pane, click System Tools > Event Viewer to display all of the
available event viewers.

4 Right-click on each event viewer and select Properties to display the
Application Properties dialog box.

5 Select the Overwrite events as needed option.

6 Click Apply, and then click OK.

Updating the Version Number in the version.txt File

Modify the version.ixt file as follows:
1 Inyour Prodika_Home directory, locate the version. txt file.
2 Open the file with a text editor.
3 Edit the first line so that it contains only the following text:
Version: v5.2.1

4 Click File > Save to save the your change.

Starting the Remote Container Service

To start the remote container service:
1 Right click My Computer.
2 Select Manage from the context menu. The Computer Management console
will open.
Expand the Services and Applications node.
Select the Services node.
The services will be listed in the main content area.
Locate the RemoteContainerService.
Right click and select Start.
Wait a few seconds to verify that it starts and stays running.
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Note Troubleshooting: If the service starts and then stops, check the log file
under <PRODIKA_HOME>\logs\remoteContainer-stdout.log to
determine the root cause.
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Microsoft .NET Framework
After installing Microsoft .NET Framework, you need make some configuration
changes to the machine. config file for performance optimization purposes.

Make the following updates to the machine.config file as follows:

1 Locate and open the machine.config file at:
C:\Windows\Microsoft .NET\Framework\v2.0.50727\Config\mach
ine.config

2 Locate the system.web tag and add the following under it:
<pages validateRequest="false" enableEventValidation="false"/>
<processModel enable="true" timeout="Infinite"
idleTimeout="Infinite"
shutdownTimeout="00:00:05" requestLimit="Infinite"
requestQueuelLimit="5000" restartQueueLimit="10"
memoryLimit="60" webGarden="False" cpuMask="Oxffffffff"
userName="SYSTEM" password="AutoGenerate" logLevel="Errors"
clientConnectedCheck="00:00:05"

comAuthenticationLevel="Connect"
comImpersonationLevel="Impersonate"

responseDeadlockInterval="00:03:00"
responseRestartDeadlockInterval="00:03:00" autoConfig="True"
maxWorkerThreads="20" maxIoThreads="20" minWorkerThreads="1"

minIoThreads="1" serverErrorMessageFile=""
pingFrequency="Infinite"

pingTimeout="Infinite" maxAppDomains="2000" />

<machineKey
validationKey="B3B1257C1B375B1190AF16044C40A42739DEDDBA26C2FIDA3
5B20FC20C3F63B11B22C6B92D602EB8886E3D18F9548B84A0BS80EBADCS575C407
ED33F39ACE08389"
decryptionKey="6D53B0178EF6AA0604C1D559B0962228B7449DAFD920113B"
validation="SHAl"/>

Note Sometimes, these tags might exist prior to this step. If these tags are
already present, please update them to look as above.

3 Locate forms Attributes. (The xpath to the node is: /configuration/
system.web/authentication.) [@mode="Windows']/forms
Change protection to None.

4 Run the following command from a command prompt:
\Windows\Microsoft .NET\Framework\v2.0.50727\aspnet_regiis
.exe -1

5 Open Internet Information Server Administrator and right-click on the
Web virtual folder and choose Properties.

6 Click on the ASP.NET tab to confirm that .NET 2.0 is selected.
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Installation Verification Tests

In order to perform the recommended Agile installation verification tests, you
will need the user name and password for an Agile user account having access to
all Agile applications. The standard username and password that ships with the
certified database is:

Username: agile

Password: prodikaadmin

Important Since this is a published username and password, it is highly advised
that you change this password immediately upon successful
installation of the system.

User access is managed using the User Group Management (UGM) application.
For more information on user management, see the Agile Product Lifecycle
Management for Process Administrator User Guide.

To verify installation:
1 Turn on Agile PLM for Process.
2 Access the Agile application using Internet Explorer. Use the following URL,
substituting the appropriate server name and http/https values (depending
on whether or not SSL is enabled):

https://servername/portal /WebCommon/Login.aspx

3 Type your use name and password, and press the Enter key.

Note The following installation verification tests assume that you have installed
the entire Agile application suite. If this is not the case, omit tests for
applications that you have not installed.

Caution! You must be assigned the correct Agile roles to perform these
installation verification tests. For more information on roles, see the
Agile Product Lifecycle Management for Process Administrator User
Guide.
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Global Specification Management Test

Before performing this test, note that specifications, once created, cannot be
deleted from GSM. Therefore, creating specifications for verification purposes
contributes to the proliferation of meaningless specifications. If specifications
already exist in the system, you may wish to skip this test.

The purpose of this test is to verify that GSM is properly functioning.

To perform the GSM test:
1 Login to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select GSM > Ingredient Specifications.
3 Click Create New in the upper right corner. A new ingredient specification
template is displayed.
Type a specification name in the Spec Name field.
Complete the Approved for Use In section at the bottom of the page.
Click Save & Close Document in the upper right corner.
From the left navigation panel, select GSM > Ingredient Specifications.
Conduct a blind search by clicking Reset and then Search or specify search
criteria to retrieve the specification that you just created.
9 In the Search Results table, click the Spec # link. The selected specification is
displayed.
10 Click Workflow in the upper right corner.
11 Type any value in the Comments field.
12 Click the move step forward (::> ) icon. If additional dialog boxes appear,
it confirms that GSM is functioning.
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Note To remove the test data in a production environment, restore your
database, restart the Remoting Container, and then restart the application
pools. This returns the environment to the default installation state.

Printing Test
The purpose of this test is to verify that the Agile Printing Service is correctly
functioning.

To perform the Printing test:

1 Login to Agile Product Lifecycle Management for Process.

2 From the left navigation panel, select GSM > Ingredient Specifications.

3 Search for the specification that you created in Global Specification
Management Test on page 1-26.

4 Click Print in the upper right corner.

5 In the resulting Print dialog box under Current Specification > Sections,
select any check box.

6 Click Print again. The specification is rendered in PDF format in a separate
window.

7 Close the window once the PDF successfully is displayed and proceed to the
next test. If the PDF does not appear, double-click the file
Prodika\Scripts\Installation\ApocEntry.reg and retry this test.
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Attachment Test
The purpose of this test is to verify that the Attachments feature is correctly
functioning.

To perform the Attachment test:

N o o h WON =

Navigate to any trade specification in GSM.

Select the Supporting Documents tab.

Click Edit to put the specification in edit mode.

Select the Attachments/Procedures link under Supporting Documents.
Click Add New button.

In the Title field, type test.

Click the Browse... button to select a file, and then select Open.

Note The size of the selected file must be less than the designated limit.

Click the Upload button. The first upload may take up to 30 seconds to
complete.

Reporting Test
The purpose of this test is to verify that the Prodika Reporting Service is correctly
functioning.

To perform the Reporting test:

1

Log in to Agile Product Lifecycle Management for Process.

From the left navigation panel, click RPT (Reporting).

Search for the specification that you created in Global Specification
Management Test on page 1-26.

Click Generate Report.

In the resulting dialog, type a report name in the Report Name field and then
click Save.

In the left navigation panel, select Ad Hoc Reports > Reports Queue.

The resulting Reports Queue should contain an entry for your report.
Refresh this view periodically by toggling from Reports Queue to Reporting
and back, to see the status of your report update. If the report status fails to
update, there is likely a problem with the Reporting Service.

When the report status indicates Complete, click the hyperlinked name of
the report to download the report.
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GSM Print Administration Test

The purpose of this test is to verify that the GSM Print Administration service is
correctly functioning.

To perform the GSM Print Administration test:
1 Login to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select GSM > Print Administration.
3 Click Create New in the upper right corner.
4 If the Process Spec Print Model is displayed, click Cancel and proceed to the
next test.

Supply Chain Relationship Management Test
The purpose of this test is to verify that the Agile SCRM application is correctly
functioning.

To perform the SCRM test:
1 Login to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select SCRM > Company Profiles.
3 Conduct a blind search and select any company profile from the Search
Results table to verify that it is displayed correctly.
4 If the company profile is displayed, click Cancel and proceed to the next test.

Nutrition Surveillance Management Test

The purpose of this test is to verify that the Agile NSM application is correctly
functioning.

To perform the NSM test:
1 Login to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select NSM > Nutrient Analysis.
3 Click Create New in the upper right corner.
4 If the Nutrient Analysis template is displayed, click Cancel and proceed to
the next test.

eQuestionnaire Test
The purpose of this test is to verify the Agile eQ application is correctly
functioning.

To perform the eQ test:

Log in to Agile Product Lifecycle Management for Process.

From the left navigation panel, select eQ > Ingredient Questionnaires.

Click Create New eQuestionnaire in the upper right corner.

In the Select Questionnaire Type dialog box, select the ingredient type and

click Create New.

5 If the eQuestionnaire template is displayed, click Cancel and proceed to the
next test.
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New Product Development Test
The purpose of this test is to verify that the Agile NPD application is correctly
functioning.

To perform the NPD test:

1
2

Log in to Agile Product Lifecycle Management for Process.

From the left navigation panel, select NPD > New Product Development >
Projects.

Conduct a blind search and select any project from the Search Results table
to verify that it is displayed correctly. If so, NPD has passed the test.

If no projects are found, click Create New in the upper right corner.

Select a business unit and project type in the resulting dialog box and then
click Done.

If the NPD (Stage 1) template is displayed, click Cancel and proceed to the
next test.

Product Quality Scorecard Test
The purpose of this test is to verify that the Agile PQS application is correctly
functioning.

To perform the PQS test:

1

Log in to Agile Product Lifecycle Management for Process.

From the left navigation panel, select PQS > Lot Samples.

Click Create Sample in the upper right corner. The Enter Code Data/Sample
ID page loads.

In the Code Data or Sample ID field, type any text.

Click Next. The Select Specification page loads.

In the Specification section, click the Specification link. A Specification
Search dialog box appears.

In the resulting Search dialog box, type criteria to find and select the
ingredient specification that you created in Global Specification Management
Test on page 1-26.

If the ingredient specification is displayed, the test has succeeded.

Click Close in the upper right corner, and proceed to the next test.
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Design Workbench Test
The purpose of this test is to verify that the Agile DWB application is correctly
functioning.

To perform the DWB test:

1 Login to Agile Product Lifecycle Management for Process.

2 From the left navigation panel, select DWB > Workbench Specifications.

3 Conduct a blind search and select any workbench specification from the
Search Results table to verify that it is displayed correctly. If it displays
correctly, DWB has passed the test.

4 If no workbench specifications are found, click Create New Workbench Spec
in the upper right corner.

5 Type a name for the workbench specification in the DWB Spec Name field.

6 Inthe Approved for Business Use In section, assign the appropriate business
unit to this specification.

7 Click Save & Close.

Food Item Catalog Test
The purpose of this test is to verify that the Agile FIC service is correctly
functioning.

To perform the FIC test:
1 Login to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select DWB > Food Item Catalog Term.
3 Conduct a blind search and select any catalog from the Search Results table.
4 If the catalog is displayed successfully, click Cancel and proceed to the next
test.

Computer Aided Compliance Screening Test
The purpose of this test is to verify that the Agile CACS application is correctly
functioning.

To perform the CACS test:

1 Login to Agile Product Lifecycle Management for Process.

2 From the left navigation panel, select CACS.

3 Conduct a blind search and select any computer aided compliance screen
from the Search Results table to verify that it is displayed correctly.

4 If no computer aided compliance screens are found, click Create New in the
upper right corner.

5 Type a name for the screen in the Title field and a description in the
Description field.

6 Click Save & Close.
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Supplier Portal Test
The purpose of this test is to verify that the Agile Supplier Portal (SPA)
application is correctly functioning.

To perform the SPA test:
1 Login to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select SPA > Approved Registrations.
If there are any approved registrations in the system, they will be displayed.

User Group Administration Test
The purpose of this test is to verify that the Agile UGM application is correctly
functioning.

To perform the UGM test:
1 Login to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select UGM > Groups.
3 Conduct a blind search and select any group from the Search Results table
to verify that it is displayed correctly.

Workflow Administration Test
The purpose of this test is to make sure that the Agile WFA application is
correctly functioning.

To perform the WFA test:

Log in to Agile Product Lifecycle Management for Process.

From the left navigation panel, click WFA (Workflow Administration).

Click New Process Template in the upper right corner.

In the resulting dialog box, select GSM and then click Done.

If the process template is displayed successfully, click Cancel and proceed to
the next test.

Sl A W N =
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Manage Core Data Test
The purpose of this test is to verify that the Agile ADMN (Manage Core Data)
application is correctly functioning.

To perform the ADMN test:
1 Login to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select ADMN > GSM Compliance > Additives.
3 If the additives currently in the system are displayed successfully, click
Cancel and proceed to the next test.

Manage Data Caches Test
The purpose of this test is to verify that the Agile CACHE application is correctly
functioning.

To perform the CACHE test:
1 Login to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, click CACHE (Manage Data Caches).
3 If the Schedule Cache Flush tool is displayed successfully, the test has
succeeded.
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CHAPTER 2
Upgrading

This chapter discusses upgrading Agile Product Lifecycle Management for Process.
Topics in this chapter include:

Upgrade Tasks

Web Application Tasks

Stopping Services and Backing Up Files

Installing Software and Scripts

Reconfiguring Settings

Customizing the User Interface

Reconfiguring and Restarting Remote Container Service and Web Application Server
Verifying the Installation

O 0 0 0 U U 0 0O

Upgrade Tasks

This chapter discusses the basic steps required to upgrade the Agile application
suite to the 5.2.1 version. The main steps in the upgrade process include:

Check for Active Web Application Server Sessions on page 2-2
Stop the Web Application Server on page 2-3

Stop the Remote Container Service on page 2-3

Back Up the Previous Database Deployment on page 2-3
Installing Software and Scripts on page 2-4

Install the Agile 5.2.1 Upgrade Software on page 2-4

Update the Version Number in the version.txt File on page 2-6
Apply Database Upgrade Scripts on page 2-6

Reconfigure the Application Environment Settings on page 2-7
Reconfigure the Customer Settings on page 2-8

Customizing the User Interface on page 2-8

Apply extensions, if any

Reconfigure the Remote Container Service on page 2-31
Restart the Remote Container Service on page 2-31

Restart the Web Application Server on page 2-31

Verifying the Installation on page 2-31
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Web Application Tasks

Check for Active Web Application Server Sessions
Before bringing down the Web application server, perform two checks to make
sure there are no active user sessions on the server.

Note We recommend that you notify all users in advance that you are

performing the upgrade, to give them time to shut down their connections.

Check the Performance System Monitor for Active Sessions
Using Performance System Monitor, check to see how many people currently
have active sessions.

1

Select Start > Run.

2 In the Run dialog box, type per fmon and click OK to bring up the

10

Performance dialog box.

Select the System Monitor option in the left pane to bring up the System
Monitor dialog box.

In the bottom portion of the System Monitor dialog box, a list of counters is
displayed. Right-click in this area and select Add Counters from the shortcut
menu to display the Add Counters dialog box.

Select the Select Counters from Computer option and select your Web
application server.

From the Performance Object drop-down list, select ASP.NET Apps
v2.0.50727.

Select the Select Counters From List option and from the associated scrolling
list, choose Sessions Active, and then click Add.

Click Close to close the Add Counters dialog box.

Using the new active sessions counter, you can view the active sessions for
the Web application server by selecting its row in the counter list at the
bottom of the System Monitor dialog box. In particular, look at the number
of active sessions in the Last field. If this number is greater than 2 active
sessions, it is likely that users are logged on to the server. Contact the user(s)
to have them log off before you shut down the Web application server.
You can save the active sessions counter by right-clicking it and selecting
Save As from the shortcut menu. You may wish to save this counter to your
desktop for future use.

2-2
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Check the Event Viewer for Last Login
Using IIS Computer Management, check the Event Viewer log for Agile to see
when the last user login occurred.

1 Right-click My Computer and select Manage from the shortcut menu to
display the Computer Management dialog box.

2 Under System Tools, select Event Viewer.

3 Locate and double-click the Portal-Prodika log under Event Viewer.

4 Review the log to see when the last user login occurred. If a recent login has
occurred, it is likely that a user is still logged on to the server. Contact the
user to have them log off before you shut down the Web application server.

Stop the Web Application Server
After you have verified that there are no active sessions on the Web application
server, bring the server down as follows:

1 Open a command prompt.
2 Enter the following command to stop the Web application server:

C:\Documents and Settings\Administrator>iisreset /stop

Stopping Services and Backing Up Files

Stop the Remote Container Service
Using IIS Computer Management, stop the remote container service as follows:

1 Right-click My Computer and select Manage from the shortcut menu to
display the Computer Management dialog box.

2 Under Services and Applications, select Service to display a list of services in
the right pane.

3 Locate the RemoteContainer Service and click it.

4 Select the Stop the Service option in the top left portion of the Services pane.

Back Up the Previous Database Deployment
Using SQL Server Enterprise Manager, back up the previous deployment of the
database. Be sure to use a meaningful name for the backup for future reference;
for example, Agile 5.1.2 - Full Backup.

Note The database server must be running in order to perform the backup.

1 Open SQL Server Management Studio.

2 In the left pane under Databases, locate the database instance to back up.

3 Right-click the database and select Tasks > Back Up... from the shortcut
menu.
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4 Select the destination for your backup. Select the Add... button to the right
of the Back up to: text area. A dialog box will appear in which you can choose
where to store the backup file. After you have chosen a name, click the 0K
button.

5 Click the OK button at the bottom of the dialog and the backup process will
begin.

Installing Software and Scripts

Install the Agile 5.2.1 Upgrade Software

The upgrade process is a manual process that uses batch files. The number of
steps during the upgrade process is determined by the applications that you
utilize within your installation.

For each installation, you will need to install the Core package first. This package
needs to be installed only once per server instance.

After installing the Core package, depending on your installation, you will install
one to four media packs. Each media pack is installed in the same manner
outlined below.

Set Up the Installation Environment
Note This step is common to all media pack installations.

Download the Media Pack installation file for the specific media pack being
installed. Unzip the media pack zip archive to a temporary directory (i.e.;
c¢\INSTALL_HOME). Follow the directions detailed below for Core/Media Pack
installation.

Upgrade the Software

Archiving the Previous Installation
The first step in the upgrade process is to manually archive the previous
installation, as described below.

1 Move (i.e.; cut) all of the directories other than attachments/XDocuments &
logs directories to your designated archive location. We recommend that
you name the containing directory as the version that you are upgrading
from (i.e.; v5.1.2 - installation, etc.).

Installing the Core Bundle
2 The next step in the upgrade process is installing the Core bundle.
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Note This should be done only once per PRODIKA_HOME, meaning that if
you have multiple installations of the Prodika suite of applications
running on the same server, you will need to perform this step only
once per Prodika installation.

Throughout the instructions below, the place where you extracted the media
bundle zip file will be referred to as INSTALLER _HOME.

3 Open the containing directory for INSTALLER_HOME.

4 Extract Core.zip located in INSTALLER_HOME to a temporary directory
(i.e.; c:\temp). This will give you a directory structure like c:\temp\Apps,
c:\temp\Config, etc. - this temporary directory will be referred to as
TEMP_HOME.

5 Copy FileCompressionHelper.exe from INSTALLER_HOME to
TEMP_HOME.

6 Open a command prompt and navigate to TEMP_HOME (i.e.; >cd c:\temp).

7 Run the following (it is extremely important that you perform this
decompression before moving on to install any additional media pack
bundle files):

FileCompressionHelper.exe -d

8 When the distribution is complete, move the contents of TEMP_HOME to

PRODIKA_HOME.

Upgrade the Media Pack Applications

For each media bundle you will follow the same eight step process below. The one
exception is with the NPD media bundle installation. With NPD, there is no need
to perform step 5.

1 If there are any files remaining in your TEMP_HOME, remove them.

2 Unzip the media pack zip file located in your INSTALLER_HOME (where the
name can be one of PDM.zip, FC.zip, SupplierCollab.zip or NPD.zip)
directly to TEMP_HOME.

3 Copy FileCompressionHelper.exe from INSTALLER_HOME to
TEMP_HOME.

4 Open a command prompt and navigate to TEMP_HOME (i.e.; >cd c:\Temp).

5 Run the following (it is extremely important that you perform this
decompression before moving on to install any additional media pack
bundle files):

FileCompressionHelper.exe -d

6 When the distribution is complete, move the contents of TEMP_HOME to
PRODIKA_HOME.

7 You will receive a warning that a Web & config directory already exist.
Accept this to move the contents into these directories.

8 Accept the warning to overwrite the configuration file
PRODIKA_HOME\Config\Core\FeatureDeployment\<media pack>-

FeatureConfig.config.
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Update the Version Number in the version.txt File

Modify the version.ixt file as follows:
1 In your Prodika_Home directory, locate the version. txt file.
2 Open the file with a text editor.
3 Change the first line so that it contains only the following text:
Version: v5.2.1

4 Click File > Save to save the your change.

Apply Database Upgrade Scripts

Agile Software customers will receive the Agile 5.2.1 database upgrade scripts on
a CD.

Important It is very important that you back up the database as indicated in Back
Up the Previous Database Deployment on page 2-3 before upgrading
the database. Once the scripts have been applied, there is no way to
revert the database to the previous state without a backup.

It is also important that you run the database upgrade scripts in
version order (5.2.0, 5.2.1) to bring the database up to the current
software version.

To run the database upgrade script:
1 Open acommand prompt and navigate to the directory where you unzipped
the upgrade package.
2 Change directories (cd) to the Installer/ApplyScripts directory.
3 Apply the scripts using the following three calls to the ApplyScripts.exe
utility:

a ApplyScripts -c “server=<database_server>;uid=<user>;
password=<password>;database=<database>" -pre
UpgradelApplyscriptsV2.sgl DBAgnos.sqgl

b ApplyScripts -c “server=<database_server>;uid=<user>;
password=<password>;database=<database>" -pre
orproperty_prescript.sgl -f v5.2.0.xml -post
ORPropertyMetaInfo_v520.sgl snapshot.sqgl

¢ ApplyScripts -c “server=<database_server>;uid=<user>;
password=<password>;database=<database>” -f v5.2.1.xml

4 After each ApplyScripts call, you can confirm that the database upgrade
scripts have been applied successfully when the system prompts you with the
following message:

“Complete - with no errors”
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Reconfiguring Settings

Configure the Environment Variables Settings
Using a text-based editor, open the environmentvariables.config file and update
the server names and port addresses.

Note For further guidance, please refer to the “Environment Variable Settings”
section of the Agile Product Lifecycle Management for Process Configuration
Guide.

Reconfigure the Application Environment Settings
Using a diff tool such as WinMerge, you will need to reconfigure the
EnvironmentSettings.config filelocated in your Prodika_Home\Config\
directory.

To reconfigure application environment settings:

1 Rename the new EnvironmentSettings.config file; change the name to
EnvironmentSettings.config-new.

2 Make a backup copy of the archived version of the
EnvironmentSettings.config file (from the archived directory) and
copy it into the Prodika_Home\Config\Custom\ directory.

3 Using the diff tool, compare the EnvironmentSettings.config-new file
to the archived copy of the EnvironmentSettings.config file.

4 Update the EnvironmentSettings.config-new file as follows:

a Under connectionPools, change the CONNECT_STRING path values to
the following:

server = your database server
database = your database name
Uid = your database user ID
Pwd = your database password

b Under Prodika > Services, make sure that the port numbers are correctly
set up for your Agile services.
¢ Change $PRODIKA_HOMES% values to the correct Prodika_Home value
(c:\Prodika_Home\).
d Carefully merge any other configuration differences for your particular
customer needs.
5 When you have completed the file comparison and updates, delete the copy
that you made of the archived EnvironmentSettings.config file.
6 Rename the EnvironmentSettings.config-new file; change the name
back to EnvironmentSettings.config.
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Reconfigure the Customer Settings
Using a diff tool such as WinMerge, you will need to reconfigure the
CustomerSettings.configfﬂeloaﬂedinyourProdika_Home\Config\
directory.

To reconfigure customer settings:

1 Rename the new CustomerSettings.config file; change the name to
CustomerSettings.config-new.

2 Make a backup copy of the archived version of the
CustomerSettings.config file (from the archived directory) and copy it
into the Prodika_ Home\Config\ directory.

3 Using the diff tool, compare the CustomerSettings.config-new file to
the archived copy of the CustomerSettings.config file.

4 Carefully merge any configuration differences for your particular customer
needs.

5 When you have completed the file comparison and updates, delete the copy
that you made of the archived CustomerSettings.config file.

6 Rename the CustomerSettings.config-new file back to

CustomerSettings.config.

Customizing the User Interface

You can customize the look and feel of your Agile PLM for Process installation in
two ways:

0 Edit the HTML of the home page or “landing page”— by using any HTML
editor (see Customizing the Agile PLM for Process Default Page on page 2-8)

0 Revise the site-wide style sheet (see Customizing the Site-wide Style Sheet on
page 2-9)

Customizing the Agile PLM for Process Default Page

The default page, or dashboard, of your Agile PLM for Process installation
consists partly of an HTML file located at:

<HOME_DIR>/Config/Custom/Content/DefaultDashboard.htm

This file displays in the main area of your Agile PLM for Process suite, as shown
in figure 2-1 below.
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Figure 2-1: Default dashboard page
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Mew Product
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Design Workbench
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Supplier Portal

Customizing the Site-wide Style Sheet
You can customize the color scheme and logo of the user interface. A cascading
style sheet (. css) file controls such visual aspects as background colors, link
colors, and your company logo. This file is named “Brand.css” and resides at:

C:\{Prodika_Home}\Web\CSS\Brand.css

You can modify Brand. css before or after installing the application suite. In
order to add some visual effects, such as your company logo, you must add a
Web-viewable graphic file (typicallya .jpg or .gif file) to the following
directory:

C:\{Prodika_Home}\Web\images\brand

Note The style sheet uses standard HTML cascading style sheet tags as set out by
the World Wide Web Consortium. Default colors are set out using
hexadecimal numbers (and in some cases, the abbreviated, 3-digit hex
method). Modifying these settings requires a level of familiarity with
cascading style sheets.

The Brand. css style sheet file is divided into the following major sections:

Link Colors—Link, active link, visited link (See Link Colors Section on page 2-10)

Brand Styles— Appearance of headers, footers, buttons, primary and cobrand
logo graphics, and so on. (See Brand Styles Section on page 2-11.)
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Link Colors Section

Navigation— Backgrounds and text colors for the Agile PLM suite home page
and for all applications, history drop-down list, tabs, and buttons, and so on. (See
Navigation Section on page 2-12.)

Content Headings— Appearance of page titles and section headings. (See
Content Headings on page 2-20.)

Tables— Table header rows, backgrounds, and background images. (See Tables
Section on page 2-21.)

System Messages— Warning notes, error messages, and so on. (See System
Messages Section on page 2-22.)

Login Styles—Customization of the various areas of the login page. (See Login
Styles Section on page 2-23.)

NPD Map—Appearance of the current step in the workflow map of an NPD
activity and that for past and future steps. (See NPD Map Section on page 2-26.)

Caution! Although Agile PLM for Process uses cascading stylesheets and other
Web standards, the system depends on technology associated with
Microsoft Internet Explorer™, and use of that Web browser is required
for correct display and functioning of this system.

Consult the guidance below to modify any element in the cascading style sheet.

The Link Colors section, shown in figure 2-2 below, is the first section in
Brand.css.

Figure 2-2: Brand.css style sheet, Link Colors section, showing default settings

/*LINK COLORS

A:link {color: #2B7C92; font-weight: bold;}
A:visited {color: #2B7C92; font-weight: bold;}
A:active {color: #2B7C92; font-weight: bold;}

.cssxPsuedoLink, .MultiTreeviewNotaccessed, .notaccessed
{color: #2B7C92;}

By default, hyperlinks do not change color when a user mouses over them or after
auser has clicked them. You can revise that behavior by modifying the color value
(in hexadecimal) and font weight.

Note You can modify link color, font weight, and any other valid CSS attribute
in this section. By default, all links are underlined.

2-10
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Brand Styles Section

In the Brand Styles section you can modify, among other things:

Header background color and image

0 Primary logo, which appears prominently on the left of the top header, as
shown in figure 2-5, on page 2-11

0 Cobrand logo, which appears at the top right of the page, in the header
section, as shown in figure 2-3 below

Note The cobrand logo image does not have to be a logo; it can be any
image you like.

0 Login info bar, as shown in figure 2-3
0 Brand bar/product bar, as shown in figure 2-5
0 Popup window header background and border, as shown in figure 2-4 below

Figure 2-3: Location of your cobrand logo
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Figure 2-4: Popup window header
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Figure 2-5: Agile PLM for Process header, showing primary logo and brand bar/product bar, whose ap-
pearance you can configure using Brand.css
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Navigation Section

In the Navigation section, you can modify the appearance of:

0 All navigation backgrounds—Navigational drop-down lists and menu items,
for example. (See All Navigation Backgrounds Subsection on page 2-12.)

0 Platform navigation—Top menu bar. (See Platform Subsection on page 2-13.)

0 Portal navigation— Left navigation panel. (See Portal Navigation Subsection
on page 2-13.)

0 Application navigation— Left navigation panel as it appears once you are
within an application. (See Application Navigation Subsection on page 2-15.)

0 Text color—Text color for the left navigation panel (portal and application
versions), the top menu bar, and history navigation. (See Text Color
Subsection on page 2-16.)

0 History drop-down list—Borders, colors, and any background image for the
history drop-down list. (See History Drop-Down List Subsection on page 2-
17.)

o Tabs—Borders, colors, and background images for all tabs used throughout
Agile PLM for Process. (See Tabs Subsection on page 2-18.)

0 Buttons—Borders, colors, and background images for all buttons in the Agile
PLM for Process suite, including page-level function buttons and system
buttons. (See Buttons Subsection on page 2-19.)

All Navigation Backgrounds Subsection
In this subsection, shown in figure 2-6, you can modify the appearance of the
backgrounds of all navigational elements.

Figure 2-6: All Navigational Backgrounds Subsection, Navigation section, Brand.css

/*All Navigation Backgrounds*/

.cssxPlatformDrop, .cssxPlatformGroup, .cssxPortalGroup,
.cssxPortalMenu, .cssxPortalDrop, .cssxAppNav, .cssxAppNavBg,
.appNav-Level2Item, .historyMenultem, .historyMenuGroup

{background-color: #eaeff5;}

2-12
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Platform Subsection
In this subsection, shown in figure 2-7, you can modify the color of the text in the
top menu bar, as shown in figure 2-8.

Figure 2-7: Platform subsection, Navigation section, Brand.css

/ *PLATFORM* /

.cssxPlatformMenulItem, .cssxPlatformMenuItemH /*Platform Text
Color*/

{color: #fff;}

Figure 2-8: The top menu bar, whose appearance is controlled by the style elements in the Platform sub-
section

Home Applications Profile and Preferences

Portal Navigation Subsection
In this subsection, shown in figure 2-9 below, you can modify the appearance of
the left navigation panel, shown in figure 2-10.

Figure 2-9: Portal Navigation subsection, Navigation section, Brand.css

/ *PORTAL*/

.cssxPortalDropItemH, .cssxPlatformDropItemH /*Highlight*/
{

background-color: #ccd7e0;

}

.cssxPortalNavTitle, .cssxPortalNavCaption /*Text Color*/
{

color: #013d74;

}
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Figure 2-10: The left navigation panel, whose appearance is controlled by the style elements in the Portal Navigation
subsection
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Application Navigation Subsection

In this subsection, shown in figure 2-11, you can modify the appearance of the
left navigation panel that displays once you are in an application, as shown in
figure 2-12, on page 2-16.

Figure 2-11: Application Navigation subsection, Navigation section, Brand.css

/*APPLICATION*/

.appNav-TopItem, .appNav-TopItem2 /*Parent Category*/
{

border: lpx solid #f2f9fe;
border-right-color:#9aa3aa;
border-bottom-color:#9aa3aa;

background-color: #ccd7e0;

}

.appNav-TopItemHover, .appNav-TopIltemHover2 /*Parent Category
Highlight*/

{

border: 1px solid #f2f9fe;

border-right-color:#9aa3aa;

border-bottom-color:#9aa3aa;

background-color: #fff;

}

.appNav-Level2ItemHover, .appNav-Level2ltemSelected , .appNav-
TopItemActive2, .appNav-TopItemActive /*Parent & Item Highlights &
Onclicks*/

{

background-color: #fff;

}
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Figure 2-12: Left navigation panel that displays once you are in GSM
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5085431-001 DG DWE Spec aaa

5085612-001 DG Process nutp from dwh

50856 16-001 DG Process nutp from dwh xx
5085613-001 DG Process Spec fromdwb
5085615-001 DG Spec nuip xxx

50856 13-001 DG Spec trade xxx

5085611-001 DG trade nutp from dwb
5085614-001 DG Trade Spec from dwb
5085421-001 DG v510rc14 Mango/Orange Drink
5085422-001 DG w510rc14 Mango/COrange Drink
5085420-001 DG v510rc14 Manago,/Crange Drink
5081516-001 FIC

5081514-001 FIC

Text Color Subsection

In this subsection, shown in figure 2-13 below, you can modify the color of the
text in the left navigation panel (portal and application versions), the top menu
bar, and history navigation.

Figure 2-13: Text Color subsection, Navigation section, Brand.css

/*Text Color*/

.appNav-Level2Item td, .appNav-TopItemActive2 td, .appNav-TopItem
td, .appNav-TopItem2 td, .appNav-TopltemHover td, .appNav-
TopItemHover2 td, .appNav-TopItemActive td, .appNav-Level2ItemHover
td, .appNav-Level2ItemSelected td

{

color: #013d74;

}
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History Drop-Down List Subsection

In this subsection, shown in figure 2-14 below, you can modify the borders,
colors, and any background image used in history drop-down lists, as shown in
figure 2-15.

Figure 2-14: History Drop-Down List subsection, Navigation section, Brand.css

/*HISTORY*/

.historyTopMenuItem, .historyTopMenultemHover /*History Menu Top
Menu Background */

{

background-image: url(../images/brand/subDimTabBg.gif) ;

}

.historyMenuItemHover /*History Menu Highlight*/
{

background-color: #FFFFFF;

}

Figure 2-15: The history drop-down list, whose appearance is controlled by the style elements in the His-
tory Drop-Down List subsection of the Navigation section of Brand.css

Edit || Create Copy || CACS || Print || Act || Resolwe

ﬁ' (ing) 5077414-001 - Spice Qil for Pork & Beans (Draft
fing) S077413-001 - Vinegar - Distilled - White - 100 Grain (Approved)
(Ibly 5077518-001 - Barrel Label Type 8872 (Draft)

(prod) S079304-001 - Daisy Land Apples (Draft (Rewview))

(pro) 5085613-001 - [ Process Spec Fromdwhb {Draft) \[b

Supporting Docume

Spec status: Craft - This specification is currently in draft status
Access Level:
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Tabs Subsection

In this subsection, shown in figure 2-16 below, you can modify the borders,
colors, and any background images used in all tabs throughout Agile PLM for
Process.

Figure 2-16: Tabs subsection, Navigation section, Brand.css

/*TABS*/

.tabmenu /*Tab Bottom Line*/

{

border-bottom: #92badc 2px solid;
}

.subtabmenu /*SubTab Bottom Line*/
{

border-bottom: #82b2db 3px solid;
}

.DefaultTab, .subDefaultTab /*Unselected Tabs*/

{

background-image: url(../images/brand/subDimTabBg.gif) ;
border: 1px solid #c0c0cO;

}

.SelectedTab, .subSelectedTab /*Selected Tabs*/

{

background-image: url(../images/brand/subTabBg.gif) ;
border: 1lpx solid #a3bed§;

color: #3c3c3c;

}

.TabMenuText, .tabnav_unselectedtab_span, .subTabMenuText /*Text
Color*/

{
color: #3e5576;
}
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Buttons Subsection

In this subsection, shown in figure 2-17 below, you can modify the borders,
colors, and any background images used in all buttons throughout Agile PLM for
Process. As shown in the figure, there are separate sections for page-level function
buttons (see figure 2-18) and system buttons (see figure 2-19, on page 2-20).

Figure 2-17: Buttons subsection, Navigation section, Brands.css

/*BUTTONS* /

/*Page-Level Function Buttons*/

input.elButton, a.elButton, a.elButton:visited, a.elButton:linked,
a.elButton:hover,

.actionMenu-TopMenultem, .actionMenu-TopMenultemHover, .actionMenu-
MenuGroup, .actionMenu-Menultem, .actionMenu-MenultemHover

{

border-right: solid 1lpx #7b8194;

border-bottom: solid 1px #7b8194;

border-top: solid 1lpx #a5a9bé6;

border-left: solid 1lpx #aba9b6;

background-image: url(../images/brand/btn-bg.gif) ;
background-color: #c9ebec;

color: #586073;

}

/*System Buttons*/

.cssxBtnFunction, A.cssxBtnFunction:link,
A.cssxBtnFunction:visited, A.cssxBtnFunction:hover,
.cssxBtnControl, A.cssxBtnControl:1link, A.cssxBtnControl:visited,
A.cssxBtnControl :hover

{

border-right: solid 1px #7b8194;

border-bottom: solid 1px #7b8194;

border-top: solid 1lpx #a5a9bé6;

border-left: solid 1lpx #a5a9bé6;

background-image: url(../images/brand/btn-bg.gif) ;
background-color: #c9eb5ec;

color: #586073;

}

Figure 2-18: Page-level function buttons, whose appearance is controlled by the style elements in the Buttons subsection of the
Navigation section of Brand.css

| Edit | Create Copy | Print | Act | Resolve Workflow | Item History | Workflow
oo

(Ibl) 5077518-001 - Barrel Label Type 8872 (Draft)
Summary Compliance | Related Specs | Supporting Documents | References | Approval/Audit Trail

Summary Information

Spec Name: Barrel Label Type 8872 * ]
Short Name: Barrel Label Type 8872 @
Spec Status: Draft - This specification is currently in draft status
Access Level:
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Figure 2-19: Sample of system buttons, whose appearance is controlled by the style elements in the But-
tons subsection of the Navigation section of Brand.css

DRL Documents

Name
Corporate Policies & Procedures
East & West

W% (%

Corporate

Add - Browse Add - Search ’

Testing Protocols

Protocol # Testing Protocol

Udd Hew Pull from Library

Content Headings

In the Content Headings section, shown in figure 2-20, you can modify the
appearance of page titles and section headings.

Figure 2-20: Content headings section of Brand.css

/*CONTENT HEADINGS

____________________________________________________________ */
/*Page Titles*/

.cssxPageTitle, .cssxPageTitle H1l, .cssxPageTitle a:link,
.cssxPageTitle a:visited, .cssxPageTitle a:hover, .cssxPageTitle
a:active

{
color: #3aba87;
}

/*Section Headings*/

h2, h4

{

color: #426ca7;

border-bottom: #567fc7 lpx inset;
font-size: 100%;

}
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Tables Section

In the Tables section, shown in figure 2-21, you can modify the appearance of:

o Table header rows

o Table background
0 Action Items header, as shown in figure 2-22

Figure 2-21: Tables section of Brand.css

/*TABLES

/* Table Header Rows */

.cssxBaseGrid th, .cssxActionGrid TH, .cssxActionGrid
.cssxActionGridHeaders, .cssxTreeDataGrid th

{
background-color:#cfeOfl;
}

/*Table Background*/

.cssxTreeDataGrid, .cssxActionGrid td, .cssxBaseGrid
{

background-color: #f2£f2f5;

}

/*Action Items Header*/

.cssxActionGrid .cssxActionHeader

{

background-image: url(../images/brand/hBar-Bg.gif) ;
color:#333;

}

Figure 2-22: Action Items header

pn Management Home Applications Profile and Preferences

Logged in a5 Fred Jones

5084027-002 Flapjacks Extraordingire | Ingredient Draft
Specifications

Ll
5083512-001 Gingkobiloba Root Hutrient Profile Draft P |
|
P |

5085995-001 Chili Pawder Inaredient Draft
Specifications

50825867-001 Color Solution - BQT Hutrient Profile Draft
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System Messages Section

In the System Messages section, shown in figure 2-23 below, you can modify the

appearance of:

0 Warning note header image and background color

0 Error message header image and background color
0 Information note header image and background color

Figure 2-23: System Messages section of Brand.css

/*SYSTEM MESSAGES

.cssxWarningNote /*Warning Message Header*/

{

background-image:url(../images/brand/warning-header.gif) ;

}

.cssxErrorNote /*Error Message Header*/

{

background-image:url (../images/brand/error-header.gif) ;
}

.cssxInfoNote /*Information Message Header*/

{

background-image:url(../images/brand/information-header.gif) ;

}

.cssxWarningNote, .cssxErrorNote, .cssxInfoNote /*Warning, Error,
Information Messages*/

{

border:solid lpx #b2c8dc;

background-color: #d9eb5ef;

}

Figure 2-24: Error message, with image, background color, and border style set by .cssErrorNote

/= Windows Internet Explorer |Z||Elb__<|

Salect Import Target Done || Cancel
"

&3 Error
You do not have permission to edit this specification.

e =L

|F'-:|rk with Sauce Ing 20071112 (5014030)

Action:
| Update Existing | |

Taraet Specification:
|New Issue w511 Ing Smoked Ham II - 20071022 (5085655-00

& Internet #100% -
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Login Styles Section

In the Login Styles section, shown in figure 2-25 below, you can modify the
appearance of different sections of the login page. The six style elements in the
Login Styles section apply to five areas of the login screen (two elements apply to
one area).

Figure 2-25: Login Styles section of Brand.css

/*LOGIN STYLES

.cssxLogin-1 /*Row 1*/
{background-color: #ededed; height:70px; }

.cssxLogin-2 /*Row 2*/
{background-color:#f4f4f4;}

.cssxLogin-3a /*Row 3 Column 1*/
{background-color:#f4f4f4;}

.cssxLogin-3b /*Row 3 Column 2*/

{background-image:url(../images/style/login-lightBlue_back.jpg) ;
background-repeat:repeat-x;background-color: #fbfbfb}

.cssxLoginPhoto

{

background-image: url(../images/style/login-people.jpg) ;
width: 417px;

height: 54px;

}

.cssxLoginGraphic

{

background-image: url(../images/style/login-globe.jpg) ;
width: 351px;

height: 259px;

}

The area affected by each of the six elements is illustrated in the following figures:
cssxLogin-1— Login screen area affected by the .cssLogin-1 style element of
Brand.css on page 2-24

cssxLogin-2— Login screen area affected by cssxLogin-2 style element of Brand.css
on page 2-24

cssxLoginPhoto— Login screen area affected by the .cssxLoginPhoto style element
in Brand.css on page 2-25

cssxLogin-3a and cssxLoginGraphic— Login screen area affected by cssxLogin-
3a and cssxLoginGraphic style elements of Brand.css on page 2-25

cssxLogin-3b— Login screen area affected by the cssxLogin-3b style element of
Brand.css on page 2-26

2-23




Agile Product Lifecycle Management for Process

Figure 2-26: Login screen area affected by the .cssLogin-1 style element of Brand.css

ORACLE agile PLM for Process

| . cssxLogin-1
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’-Gﬁ .,W}' Lo —

[Ciogm ]
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Busthaningd 15 R BOVEEE, S N ENIET Bl Nt By ENLETRY the Rl i,
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your use of this netwark

Figure 2-27: Login screen area affected by cssxLogin-2 style element of Brand.css

ORACLE agile PLM for Process

.cssxLogin-2, for
background color of
this area
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[Ciogm ]

Thig: ot bt iy 8 B s Sy Mior lngitmpte Busprwes purposes. BF you sre ngt
Busthaningd 15 R BOVEEE, S N ENIET Bl Nt By ENLETRY the Rl i,
voU agres o msnbsn & onfdentalty snd not to dedose or msue S
riForma i dortared B B i Bt S vt ur ey B E B Gur e Sy of
your use of this netwark
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Figure 2-28: Login screen area affected by the .cssxLoginPhoto style element in Brand.css

ORACLE agile PLM for Process
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Figure 2-29: Login screen area affected by cssxLogin-3a and cssxLoginGraphic style elements of Brand.css

ORACLE agile PLM for Process
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Figure 2-30: Login screen area affected by the cssxLogin-3b style element of Brand.css
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NPD Map Section
In the NPD Map section, shown in figure 2-31 below, you can modify the
appearance of the workflow map that you can view from within the New Product
Development (NPD) application. Specifically, you can control the appearance of
the current (highlighted) workflow step and the past and future (non-
highlighted) steps. Figure 2-32, on page 2-27 shows a sample of an NPD map for
reference.

Figure 2-31: NPD Map section of Brand.css

/*NPD MAP

.cssxHiMapStep /*NPD Map - Highlighted Workflow Step*/
{

color: #333;

background-color: #CCCCCC;
background-image:url (. ./images/brand/NPDHiMapStep.gif) ;
background-repeat:repeat-x;

}

.cssxMapStep /*NPD Map - Workflow Step*/

{

color: #333;

background-image:url (../images/brand/NPDMapStep.gif) ;
background-repeat:repeat-x;

background-color: #b6b6bb6;

}
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Figure 2-32: Map of an NPD activity showing highlighted and non-highlighted workflow steps

Workflow Map - Nutrition Review (Nutrition Review)

Current step

Past and future
steps

1. Draft

2. Request Review

Special Services - Jane Smith

3. Lab Analysis

Special Services -- {z2t bas=d on
project)

4., Nutrition Review

Special Services -- {z2t basad on
project)

5. Complete

6. N/A

Estimated Red: 0 days

Close
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Updating the Sort Order of the Left Navigation Panel

You can use the SiteMap-DisplayOrder.xml file to change the menu item
ordering for existing menus that come with the product. All the menu items have
a SortOrder property that is evaluated and ordered in ascending order.

For example:

<MenulItem ID="Menul" SortOrder="10" configChildKey="ID"/>
<Menultem ID="Menu2" SortOrder="20" configChildKey="ID"/>

The above menus are displayed as in the order Menul, Menu2. If the sort order
is transposed, then Menu2 gets displayed before Menul. The actual number or
the spacing between these tags does not matter. In the above example, 10 menu
items could be inserted between Menul and Menu2 and yet be sorted
deterministically. If two menus have the same sort order, then the display order
is not guaranteed between those two elements.

Extending the Left Navigation Panel

With the siteMap-Extensions.xml file you can add new menu items that are
not part of the core product. In general a menu item would look like the
following:

<Menultem ID="translation Id" DisplayText="Generally note
used.. just to indicate what gets displayed"
SecurityProfileRef="Security Profile Name"
SkinRef="Skin Profile Name"
TranslationRef="Translation Profile Name"
SortOrder="Some number" NavigateUrl="http://
SomeUrl.com" />

Menu items can be nested to create menu hierarchies, as shown below:

Application Wide Menu
Applications
GSM

...then the menu definition would look like this:

<Menultem ID=""ApplicationWideMenu" DisplayText="**Application Wide
Menu' >
<Menultem ID="Applications" DisplayText="**Applications'>
<Menultem ID=""GSMSideNav' DisplayText="**GSM"">
<Menultem ID="[translation Id]"
DisplayText="[Generally note used.. just to indicate
what gets displayed]"
SecurityProfileRef="[Security Profile Name]"
SkinRef="Default Skin"
TranslationRef=""Application Menu"
SortOrder=""[Some number]"
NavigateUrl="[http://SomeUrl.com]” />
</Menultem>
</Menultem>
</Menultem>

The values in [ ] need to be changed.
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For more information, see Setting Security on the Left Navigation Panel Items
below. Other than that, the NavigateUrl indicates the url to navigate to when a user
clicks a menu item.

Setting Security on the Left Navigation Panel ltems

This section discusses how to use the MenuConfig-Extensions.xml file to
secure left navigation items.

More than likely, only the security settings for new menu items will need to be
modified. Every SiteMap entry has three properties that determine how the menu
item is rendered in terms of security, appearance, and the translated text that is
shown to the users. These properties are SkinRef, SecurityRef and TranslationRef. All of
these properties except the SkinRef cascade to child elements; so if a menu item
does not have a SecurityRef property, then it inherits the security profile of its
parents.

Security Profile
Below is a snippet of the security provider configuration in MenuConfig.xml:

<Provider ID="SecurityProvider"™ .>
<SecurityProfiles.>
<SecurityProfile ID="Default" Mode="Visibility">
<Allow Roles="*"/>
</SecurityProfile>
<SecurityProfile ID="PQSReportViewer' Mode="Visibility"
Application=""PQS">
<Allow Roles=""[PQS_ADMIN], [PQS_Reporter]'/>
</SecurityProfile>

</Secu r'i'tyProfi les>
</Provider>

The SiteMap menu items have security profiles associated with every menu. For
example, if a menu item were set up with a profile of POSReportviewer, it
would evaluate to the above security profile. What this security profile describes
is “Any PQS user with the roles [P0S_aDMIN] OR [PQS_Reporter] has
visibility to the menu item.”

If Application were blank or not defined, then it would mean “Any user with the
roles [POS_ADMIN] OR [PQS_Reporter] has visibility to the menu item.”

Wild card of “*” is allowed on Users, Roles and Applications, and it signifies “all.”
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Translation Profile

Typically all pipelines are configured with a dynamic translation provider, which
usually looks like this:

<Provider ID="ApplicationWideMenuTranslationProvider" .>
<TranslationCaches..>
<TranslationCache ID="GSMSideBar" Path="frmMaster/ctlINavMenul"/>
<TranslationCache ID="NDPSideBar" Path=""frmNPD/ctlSidebar'/>
</TranslationCaches>

;}ﬁrovider>
If the menu item has a translation profile, it looks up the cache from the

translation caches collection. If a menu item has a TranslationRef of “GSMSideBar,
” then it maps to the frmMaster/ctiNavMenu1 translation cache.

This defines skin profiles specific to the Component Art Navigation items, which
use ItemLooks to define the way navigation controls look. When a menu or menu
item is configured with an item look, the Lookld property is very important and all
the properties are case sensitive. Every Skin can have only a finite set of ltemLooks,
and the Lookld determines the look of the menu items in various situations.

Valid Looklds for Top-Level Menus

DefaultChildSelectedltemlLook
DefaultDisabledltemlLook
DefaultltemLook
DefaultSelectedltemlLook

Valid LooklIds for Menultems

ChildSelectedLook
DefaultSubltemChildSelectedLook
DefaultSubltemDisabledLook
DefaultSubltemLook
DefaultSubltemSelectedLook
DisabledLook

Look

SelectedLook

Syntax for Setting Properties
All parameters that are picked up from context supplied to the MenuBuilderService
are of the form ${variableName[,defaultvaluel}.
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Reconfiguring and Restarting Remote Container Service
and Web Application Server

Reconfigure the Remote Container Service

As of version 5.2.1, it is not necessary to reconfigure the Remote Container
service.

Restart the Remote Container Service

Using IIS Computer Management, restart the remote container service:
1 Right-click My Computer and select Manage from the shortcut menu to
display the Computer Management dialog box.
2 Under Services and Applications, select Service to display a list of services in
the right pane.
3 Locate the RemoteContainer Service and click it.
4 Select the Start the Service option in the top left portion of the Services pane.

Restart the Web Application Server

Using a command prompt, restart the 1IS Web application server:
1 Open a command prompt.
2 Enter the following command:
C:\Documents and Settings\Administrator>iisreset

The Web application server restarts.

Verifying the Installation

Log in to the Agile user portal and verify that the installation is functioning
correctly. We recommend that you perform a variety of post-installation tests to
ensure that all the applications are functioning correctly. For more information,
see Installation Verification Tests on page 1-25.
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APPENDIX A
Installing WebDAV

This appendix contains instructions for installing and configuring WebDAV.

Enabling WebDAV

To make sure that Web Sharing is enabled in IIS:
1 Open the IIS Manager, and then select Web Service Extensions.
2 Enable WebDAV if it is not already set to “Allowed,” as figure A-1 shows

below:
Figure A-1: Enabling WebDAV
g Fil=  Ackion Wiew Window  Help |_|— &)=l

e E R EE R

g Computer Management {Local)
Eﬁﬁ Syskem Tools

. Web Service Extensions

E‘ Event Wigwer /| Web Service Extension | status |
E] E Shared Folders ? All Unknown CGI Extensions Allowed
B J Local Users and Groups Al “# Al Unknown ISAPI Extensions Allowed
= @ Ackive Server Pages Allowed
e [38 AsP.MET v1.1.4322 allowed
Removable Storags Properties [ Internet Data Connectar Alloveed
L Disk Defragmenter @ Server Side Includes Allowed
23 Diek Management o |8 webpay allowed
E--% Services and Applications
-8 Telephony
Jervices B 11dd & new web service extension. ..
-g¢5 WM Control s
Elg Indexing Service 1 pllows all Web service extensions for a

E]P-j Internet Information Services (115) Mana specific spplication...
) Application Pools

L prohibit sl Web service extensions
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Creating the Directory Structure
To configuring WebDAV:

1 Create the directory structure as follows:

WebDAV\

WebDAV\PDFComments
WebDAV\NPDWorkArea

Figure A-2: Directory Structure
El 5 WebDay
51 NPDWorkarea
|5 PDFComments

Sharing the WebDAV Directory

To share the WebDAV directory:
1 Right click on the WebDAV irectory and select Properties.
Select the Web Sharing tab.
Share the folder as WebDAV.
Click Edit Properties.
Check Read, Write and allow Scripts, as figure A-3 shows below.

g b W

Figure A-3: Properties

— Frnpertie.s - =
Generall Shalingl Security web Sharing | Custnmizel

Lg Intemet Information Services

Share on IDefauIl WwWeh Site ﬂ Alias: I'WebD.t‘-‘.\n"

" Do not share this folder
— (% Share this folder

Y N |

Directony: IE: aebDa

—ACCESS DEMMIZSIONS

Aliazes v Read ™ Script source access
Add... I wiite
Edit Properties... | — Application permissions
" Mone

Remove | {% Scripts

" Execute [includes scripts]

Ok I Cancel

QK Cancel Spplu
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Editing Folder Permissions

To edit folder permissions:
1 Click on the Security tab.
2 Give the user that the Application Pool runs as full control, and apply to all
sub directories, as figure A-4 shows below.

Figure A-4: Properties
WebDAY Properties E

Generall Sharing  Security I\A-"eb Sharingl Customizel

Group or User hames:

m Administrators MM TECHOT \Adrministrators) = |
€7 CREATOR OWNER
ﬂ ProdikaStaginglser [ProdikaStagingll ser@wenodey. com)

€7 SYSTEM
1]

Permizsions for Internet Guest

Account

Full Cantral O &
M odify O

FRead & Execute O

Ligt Folder Contents O

Fead O

Write O
[ PO [ o P S S m m LI

For special permizzions of for advanced settings, Advanced |
click &dvanced. —

QK Cancel | Apply |
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Verifying the IIS Directory Security is Configured Correctly

To verify IIS directory security:
1 Locate the WebDAYV virtual directory, then right click and select Properties.
2 Verify that the directory has Write permission, as figure A-5 shows below.

Figure A-5: Virtual Directory

wcboaveropertes GRS

HTTP Headers Custorn Errars I A5P . MET I
| Wirtual Directary Cocurnents i Directory Security I

The conkent For this resource should cane From:

& a directory located on this computeri

" 4 share located on another computer
| " & redirection b & LRL

1

i Lacal path; I C\WebDay Bromse, .. |
| [ Script source access ¥ Log visits

i ¥ Read [ Index this resource

| v Write

| ¥ Directary browsing

Application settings

| Application name: I WWebDay Remave |
1 Starting point: <Techavc_MNPD=\WebDa,
Configuration, ., i
Execute permissians: iScripts anly ;i
Application pool: iTecthc_NPD_F‘ortal ;| Unload |

QK i Cancel | Anply | Help |

3 Click the Directory Security tab.
4 Select Edit under Authentication and access control.
5 Verify that Anonymous access is enabled, as figure A-6 shows below.
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Figure A-6: Authentication
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Configuring the Application

To configure WebDAV for a single server setup:
1 Edit Environment Settings under
<prodikahome>\config\EnvironmentSettings.config
2 Map the following settings in the config to the appropriate directories/
URLS. To test, you can enable directory browsing on the web dav virtual
directory.

<config key=“PDFWorkArea” value="“https://demo.prodika.com/
WebDAV/npdworkarea/”; />

<config key=“PDFWorkAreaUNC”
value=“C:\WebDAV\NPDWorkArea\” />

<config key=“PDFCommentRepository” value="https://
demo.prodika.com/WebDAV/PDFComments”; />

<config key=“PDFCommentRepositoryUNC”
value=“C:\WebDAV\PDFComments\” />

<config key="“OfficeDocWorkArea” value="“https://demo.prodika.com/
WebDAV/npdworkarea/”; />

<config key=“OfficeDocWorkAreaUNC”
value=“C:\WebDAV\NPDWorkArea\” />

To configure WebDAV for a multiple server setup:
1 Share the web dav directory as webdav on server A resulting in \\<server
A>\webdav
2 Set appropriate share and security permissions as follows:

The user running app pool on server B must have RW share and security
access to \\<server A>\webdav.

3 Use \\<hostname>\webdav\pdfcomments\ and \\<server
A>\webdav\npdworkarea for UNC paths in config on server B.
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APPENDIX B
Troubleshooting

This appendix contains a list common issues that may occur after installation.

Troubleshooting Tips

The following list details common issues and suggestions for solving them.

1 How can I compare my recent build with an older build to see if

configuration values have changed?

Tip: Use the Config Rollup URL to check the rolled up configuration
settings for various applications. The URL is:

http://<serverName>/<appName>/WebCommon/AdminForms /
ConfigRollup.aspx

Clicking upload when adding a DRL attachment causes the window to
simply blink.

Tip: Ensure you’ve waited at least 30 seconds on the first attempt.

Tip: Ensure the machine.config for your .NET version has the machine key
entry.

Message displayed is “trust relationship could not be established”.

Tip: Verify that the Web site your using has a signed certificate.

Tip: If not testing SSL DRL attachments, configure them to use HTTP and
ensure the “Prodika.GSMInterApp.URL” property is using HTTP.

Message displayed is “The remote certificate is invalid according to the
validation procedure.”

Tip: Ensure the credentials in the “EnvironmentVariables.config” file are
correct for the “Prodika.DRLService.SysUser” user.
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5 NPD edit-in-place documents are read-only.

10

Tip: The user connecting to the IIS share does not have permissions to the
underlying folder on the server. Grant full permissions by assigning the
‘Everyone’ permission setting on that folder. If that solves the problem, lock
down the folder with tighter permissions.

The Browser keeps redirecting to incorrect URLs or keeps jumping from
HTTPS to HTTP.

Tip: Make sure that the environmentvariables.config file has the right URLs.

Tip: You can only one have HTTPS site on one machine. If you have more
than one, it bounces back and forth between the two sites

Tip: Make sure that you are not using HTTPS in the URL to access a http
Web site. Using https in your URL will make the Server redirect your request
to the default https Web site.

Tip: Conversely, if the environmentvariables.config file is using https to
access a http Web site, you would be redirected to the default https Web site
incorrectly

Navigation to any page in the application results in a blank page after
migrating to another version or a new version of .NET is installed.

Tip: The wrong ASP.NET version may be registered with IIS. Run the
“aspnet_regiis.exe” utility with the “-r” flag.

The rich text dialog box is prompting me with security issues concerning
scripts.

Tip: Ensure the page event and request validation are turned off .
What is drl.prodika.com?
Tip: Make sure that you have the new URLs and https:.

I am prompted to login to every application.

Tip: Is the remoting container running?

Tip: Ensure you are using the trust bridge in “EnvironmentSettings.config”.
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