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C H A P T E R 1
About Oracle Guardian
This chapter provides an overview of Guardian components, features, and key concepts. Also 
provided are basic instructions for using and navigating the Guardian User Interface and Online 
Help System. Topics include the following:

Introduction

Guardian User Interface

Guardian Online Help System

Guardian Command Line Interface

Key Concepts

Security

Privacy

Key Tasks

Example Scenarios

Supported Targets
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Introduction
Guardian is a diagnostic tool for identifying potential problems in your environment before they 
occur, and provides specific instructions for resolving them. Guardian is like having the entire 
Oracle Customer Support Team scrutinize your domain and immediately present their findings 
and recommendations to you, at your convenience.

Guardian can run on Windows or Linux systems that have Java Version 5 or higher installed. 
Guardian can evaluate any platform based on WebLogic Server version 8.1 through 10.3, 
regardless of the operating system on which it is running. 

To use Guardian, you must first activate one or more Domains in Guardian. A domain is a 
logically related group of WebLogic Server resources that you manage as a unit. Activating a 
domain enables it for Guardian evaluation. You can also organize multiple domains into Domain 
Groups. Then, select one or more domains, select a Signature Bundle, and launch an Evaluation. 
Guardian then proceeds to evaluate the Signature Bundle against the specified domain(s), and 
generates a detailed report of potential issues and their remedies. You can then review the report 
and decide how to proceed.

For a description of fundamental Guardian concepts, see Key Concepts on page 21. For a 
description of and instructions for basic Guardian tasks, see Basic Tasks on page 38 in Chapter 2, 
“Tasks.” 

The following section provides an overview and basic navigation instructions for the Guardian 
User Interface.

Guardian User Interface
This section provides an overview and basic navigation instructions for the Guardian User 
Interface. For a complete, detailed description of all interface components, see Chapter 3, 
“Reference.” For detailed instructions for specific Guardian tasks, see Chapter 2, “Tasks.”

In general, you will use the Guardian User Interface to perform the majority of Guardian tasks 
and activities. For some highly repetitive or complex tasks—for example, activating multiple 
Guardian domains in multiple Guardian instances—you may want to create a Guardian 
Command Line Interface (CLI) script to automate a series of tasks. For basic instructions on using 
the CLI, see Command Line Interface in Chapter 2, “Tasks.” For a detailed description of all CLI 
commands, use, and syntax, see Command Line Interface of Chapter 3, “Reference.”
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Guard ian  User  In te r face
The sections below provide a description and basic navigation instructions for each of the 
following elements: 

Main Menu Bar

Main Toolbar

Navigation Pane

Document Pane

Document View Titlebars

Context Menus

Wizards

For a complete detailed description of the Guardian User Interface, see Chapter 3, “Reference.”

Main Menu Bar
The Main Menu Bar is at the top of the Oracle Guardian main window just below the Oracle 
Guardian titlebar. The Menu Bar contains the following menus:

File Menu

Tools Menu

Window Menu

Help Menu

The Menu Bar menus in turn contain a series of options and submenus, some of which also lead 
to additional menus, dialog boxes, or wizards. The following sections provide an overview of 
each of these menus, and instructions for invoking them.
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Keyboard Shortcuts
You can invoke many menus, submenus, and menu options by using a keyboard shortcut. To 
display Menu Bar menus, press the Alt key and type the menu selection key for the menu you 
want to display. The menu selection key is the letter underlined in the menu name when you press 
the Alt key.

Some menu options also have keyboard shortcuts, which consist of a specific sequence of 
characters pressed simultaneously. If a menu item has a keyboard shortcut, the key sequence is 
listed next to the item in the menu. To see the complete list of keyboard shortcuts, press 
Ctrl+Shift+L.

File Menu
Table 1-1 describes the File menu options and submenus.

Table 1-1  File Menu

Menu Item Description

New > This option opens a submenu with the following options:
• Domain Group — Open the Add Domain Group dialog box for 

creating a new Domain Group.
• Domain — Open the Domain Activation Wizard.
• Inventory — Open the Inventory Wizard.
• Evaluation — Open the Evaluation Wizard.
• Shortcut — Open the Shortcut Wizard.

Open File... (Disabled.) This is an Eclipse Platform menu option that does not apply 
to this application.

Open Open the selected item. Select an item in the Navigation Pane, and then 
select File > Open to display the contents for that item in the Document 
Pane.

Close Close the current display in the Document Pane.

Close All Close all Document Pane displays.

Save As... Export the selected Domain Inventory or Evaluation as a file (PDF or 
HTML).
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Print Print the contents of the Report tab or Source tab currently displayed in 
the Document Pane.

Import Open the Import dialog box for importing Guardian Preferences, 
Workspace, or Report Plug-in.

Export Open the Export dialog box for exporting Guardian Preferences, 
Workspace, or Report Plug-in.

Exit Exit Guardian.

Table 1-1  File Menu

Menu Item Description
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Edit Menu
Table 1-3 describes the Edit menu options.

Table 1-2  Edit Menu

Menu Item Description

Cut (Disabled.) This is an Eclipse Platform menu option that does not apply 
to this application. Use Ctrl+X for cut operations, where applicable.

Paste (Disabled.) This is an Eclipse Platform menu option that does not apply 
to this application. Use Ctrl+V for paste operations, where applicable.

Tools Menu
Table 1-3 describes the Tools menu options and submenus.

Table 1-3  Tools Menu

Menu Item Description

Purge Inactive Domains Remove deactivated domains from the Domain Explorer and the 
Guardian Registry. This also removes from the Guardian Workspace any 
Domain Inventories, Evaluation Summaries, and Service Request 
Archives for those domains.

Modify Domain Modify the selected domain. Opens the Domain Properties dialog box, 
where you can reconfigure the properties for the selected domain.

Deactivate This opens the Domain Deactivation Wizard for the selected domain.

View Log > This opens a submenu with the following options:
• Signature Log — Display the Guardian Signature log file.
• Guardian Log — Display the Guardian log file.
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Window Menu
Table 1-4 describes the Window menu options and submenus.

Table 1-4  Window Menu

Menu Item Description

Show View > This opens a submenu containing the following options:
• Domain Explorer
• Bundle Explorer
• Shortcut Explorer
• Signature Explorer
• Active Domains Table
• Shortcuts Table
• Progress View
• Outline View

Select an option to open that View.

Working Sets > (Disabled.) This is an Eclipse Platform menu option that does not apply 
to this application.

Reset Perspective Reset the Guardian displays to their default settings.

Preferences... This opens the Preferences page.
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Help Menu
Table 1-5 describes the Help menu options and submenus.

Table 1-5  Help Menu

Menu Item Description

Help Contents This opens the Oracle Guardian Online Help System.

Search This opens the Online Help Search utility.

Dynamic Help This opens the Guardian Dynamic Online Help pane (to the right of the 
Document Pane).

Cheat Sheet... This opens the Cheat Sheet Selection dialog box for selecting and 
displaying a Guardian Cheat Sheet (to the right of the Document Pane). 
The Cheat Sheet provides step-by-step instructions for basic Guardian 
tasks. Action buttons are provided for some tasks; click a button to 
initiate that task.

Manage Guardian > This opens a submenu with the following options:
• Update Guardian — Open the Update Wizard.
• Manage Configuration — Open the Product Configuration 

Manager for performing the following tasks:

Key Assist... Display the list of keyboard shortcuts.

About Oracle Guardian Open the About Oracle Guardian dialog box. This displays the version 
of your current Guardian installation, and details about Guardian 
features, plug-ins, and configuration. 

– Scan for Updates
– View Installation History
– Show Activities
– Add an Extension Location
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Main Toolbar
The Main Toolbar is located below the Main Menu, and contains action buttons for the most 
common Guardian tasks. To identify a button, move your mouse pointer over the button; this 
displays the tool tip text for that button. 

Table 1-6 describes the Main Toolbar buttons.

Table 1-6  Guardian Main Toolbar Buttons

Button Description

Open Display the selected resource in the Document Pane.
• Opens the Active Domain Table when Target Domains is selected 

in the Domain Explorer.
• Opens the Domain Inventory view when a Domain Inventory is 

selected in the Domain Explorer.
• Opens the Evaluation Summary view when an Evaluation 

Summary is selected in the Domain Explorer. 
• Opens the Signature view when a signature is selected in the 

Signature Explorer or Bundle Explorer. 
• Opens the Signature Bundle view when a Bundle is selected in the 

Bundle Explorer. 
• Opens the Evaluation Wizard when a Shortcut is selected in the 

Shortcut Explorer. 

Print Print the contents of the Report tab or Source tab currently displayed in 
the Document Pane.

Activate Open the Domain Activation Wizard. 

Inventory Open the Inventory Wizard.

Evaluate Open the Evaluation Wizard.

Update Open the Update Wizard.
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Context Menus
Many views and displays contain context menus. Right-click on an item or anywhere in a display 
to open the associated context menu. For a complete description of context menus, see Context 
Menus in Chapter 3, “Reference.”

Navigation Pane
The Navigation Pane resides in the left side of the Oracle Guardian main window. The Navigation 
Pane contains several tabs leading to Explorer Views. You can have multiple Views open at once, 
but only one can be displayed at a time. Click on a tab to display an Explorer view. 

Explorer Views
At the top of the Navigation Pane are the Explorer View tabs. Select a tab to display that View. 
Table 1-7 provides an overview of the Navigation Pane Explorer Views.

Table 1-7  Navigation Pane Explorer Tabs

Explorer Tab Description

Domain Explorer Open the Domain Explorer. This View enables you to browse, manage, 
and monitor the domains you have defined in Guardian. Right-click in the 
Domain Explorer to open a context menu of domain operations. For a 
complete description, see Domain Explorer in Chapter 3, “Reference.” 
For instructions on Domain Explorer tasks, see Domains in Chapter 2, 
“Tasks.”

Signature Explorer Open the Signature Explorer. This View enables you to browse the 
available signatures and view the contents of a selected signature. For a 
complete description, see Signature Explorer in Chapter 3, “Reference.” 
For instructions on Signature Explorer tasks, see Signatures in 
Chapter 2, “Tasks.”
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For a detailed description of each of the Explorer views, see Navigation Pane of Chapter 3, 
“Reference.”

Bundle Explorer Open the Bundle Explorer. This View enables you to browse the 
available Signature Bundles and their contents. For a complete 
description, see Bundle Explorer in Chapter 3, “Reference.” For 
instructions on Bundle Explorer tasks, see Bundles in Chapter 2, 
“Tasks.”

Shortcut Exporer Open the Shortcut Explorer. This View enables you to view and manage 
your Evaluation Shortcuts. For a complete description, see Shortcut 
Explorer in Chapter 3, “Reference.” For instructions on Shortcut 
Explorer tasks, see Shortcuts in Chapter 2, “Tasks.”

Table 1-7  Navigation Pane Explorer Tabs

Explorer Tab Description
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Explorer Toolbar Icons
Below each Explorer titlebar is the Explorer toolbar. An Explorer toolbar may contain all or some 
of the following active icons:

Table 1-8  Explorer Toolbar Icons

Icon Function

Close

Minimize

Maximize

Restore

Expand all items.

Collapse all items.

Open Explorer menu.

Link selected item with Editor.

Explorer Toolbar Menus
The Domain Explorer, Signature Explorer, and Bundle Explorer each contain a Menu icon in 
the right corner of the toolbar. Click the Menu icon to display a menu of operations for that 
Explorer. 

Table 1-9 describes the Explorer menus.
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Table 1-9  Explorer Menus

Explorer Menu Options

Domain Explorer The Domain Explorer menu contains the following options:
• Filter Domain Explorer — Open the Filter Domain Explorer 

dialog box to filter inventories and evaluations by date created.
• Link with Editor — Link the Navigator Pane Tree to the Document 

Pane View. If you have multiple Document Views open in the 
Document Pane, the Explorer Tree tracks which Document View is 
currently active (displayed). The current active Document View 
name is then also selected (highlighted) in the Explorer Tree.

Signature Explorer The Signature Explorer menu contains the following options:
• Sort Signatures > — This opens a submenu of the following options 

for sorting signatures:

• Filters... — Open the Filters dialog box for filtering signatures in 
Signature Lists. For instructions, see Filter Signatures in 
Chapter 2, “Tasks.”

• Link with Editor — Link the Navigator Pane Tree to the Document 
Pane View. If you have multiple Document Views open in the 
Document Pane, the Explorer Tree tracks which Document View is 
currently active (displayed). The current active Document View 
name is then also selected (highlighted) in the Explorer Tree.

Bundle Explorer • Filters... — Open the Filters dialog box for filtering signatures in 
Signature Lists. For instructions, see Filter Signatures in 
Chapter 2, “Tasks.”

• Sort Signatures > — This opens a submenu of the following options 
for sorting bundles and signatures in the Bundle Explorer:

• Link with Editor — Link the Navigator Pane Tree to the Document 
Pane View. If you have multiple Document Views open in the 
Document Pane, the Explorer Tree tracks which Document View is 
currently active (displayed). The current active Document View 
name is then also selected (highlighted) in the Explorer Tree.

– By Name
– By Severity

– By Bundle Name, Signature Name
– By Bundle Name, Severity
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Explorer Context Menus
Right-click in an Explorer View to display the context menu of tasks and operations you can 
perform from that View. You can also right-click on a specific item to select it and open the 
context menu for that item. Menu options that do not apply to your selection are deactivated 
(greyed out). 

For a complete description, see Explorer Context Menus in Chapter 3, “Reference.”

Document Pane
The Document Pane is located in the central portion of the Oracle Guardian main window. The 
Document Pane displays the Document Views.

Document Views
Table 1-10 describes the Guardian Views that can be displayed in the Documentation Pane.

Table 1-10  Document Pane Views

View Description

Active Domains Table Select Window > Show View > Active Domains Table to display this 
View. This contains a table of all of the domains currently activated in 
Guardian, and action buttons for the following tasks:
• Open Admin Console — Open an instance of the WebLogic Server 

Administration Console.
• Modify Domain — Open the Domain Properties configuration 

page for the selected domain.
• Deactivate Domain — Open the Domain Deactivation Wizard for 

the selected domain(s).

Domain Inventory Double-click on a Domain Inventory entry in the Inventory History 
folder in the Domain Explorer to display the Inventory Details for that 
inventory. The inventory includes descriptions of your servers, Java 
Virtual Machines, operating systems, databases, product versions, and 
certain configuration settings. The Domain Inventory View contains the 
following tabs:
• Overview — Display the Domain Inventory Overview for this 

Inventory.
• Source — Display the XML source for the Inventory.
• Report — Display the Domain Inventory report for this inventory.
1-14 Oracle Guardian User Guide



Guard ian  User  In te r face
Note: You can have multiple Views open in the Document Pane, but only one can be active at 
a time.

Document View Titlebars
Each View has a titlebar that contains the name of the View, an identity icon, and buttons to close, 
minimize, maximize, and restore the display.

You can also use Document View titlebars to group multiple Views together on a titlebar as a tab 
group. Tab groups can be moved together as a unit, using either the System Menu > Move menu 
option or drop cursors. You can also move Views by dragging their titlebars to different locations.

For a complete description of titlebar features, see Document View Titlebars in Chapter 3, 
“Reference.”

Evaluation Summary 
View

Double-click on an Evaluation Summary entry in the Evaluation 
History folder in the Domain Explorer to display that Evaluation 
Summary. This contains a table of all detected signatures for the 
evaluated domain. Select a signature in the list to display the signature 
Description and Remedy details for that signature.

Shortcuts Table Select Window > Show View > Shortcuts Table to display this View. 
This contains a table of all of your Shortcuts, and action buttons for the 
following tasks:
• Add Shortcut — Open the Shortcut Wizard for creating Shortcuts.
• Delete Shortcut — Delete the selected Shortcut. A Confirm Delete 

dialog box prompts you to confirm the delete operation. Click OK to 
delete the Shortcut.

Signature View Double-click on a signature entry in the Signature Explorer or Bundle 
Explorer. This View contains the following tabs:
• Overview — Display the Signature Overview for the signature.
• Source — Display the XML source for the signature.
• Report — Display the Signature Report for that signature.

Signature Bundle View Double-click on a Bundle node in the Bundle Explorer. This View 
provides a description and some additional details about the selected 
Bundle. Also included is the Signature Definition for the Bundle.

Table 1-10  Document Pane Views

View Description
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Document Pane View Context Menus
Each tab page for a View has a context menu specific to the tab contents. Some context menus—
for example, Edit menus—may be available only for certain items within that View. To open a 
context menu, right-click on an item in that View.
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Wizards
Oracle Guardian provides the several wizards for guiding you through some of the more complex 
or common Guardian tasks. 

Table 1-11 describes the Guardian wizards and how to invoke them.

Table 1-11  Guardian Wizards

Menu Item Description

Annotations Wizard Right-click on a signature title in the Signature Explorer or 
Bundle Explorer and select Annotations from the context 
menu. This opens a submenu with a single option, Manage 
Annotations. Select this to open the Annotations Wizard. 
This contains fields and options for annotating the selected 
signature. For details, see Annotations Wizard. in Chapter 3, 
“Reference.” For instructions on using this wizard, see 
Signature Annotations in Chapter 2, “Tasks.” 

Bundle Evaluation Wizard Right-click in the Domain Explorer and select Evaluate 
Bundle from the context menu. This opens a submenu listing 
the Bundles available for evaluation. Select a Bundle to open 
the Bundle Evaluation Wizard for that Bundle. For details, 
see Bundle Evaluation Wizard in Chapter 3, “Reference.” For 
instructions on using this wizard, see Evaluate Bundles in 
Chapter 2, “Tasks.”

Domain Activation Wizard This contains fields and options for configuring and activating 
a domain in Guardian. Click Activate to open the Domain 
Activation Wizard. For details, see Domain Activation 
Wizard in Chapter 3, “Reference.” For instructions on using 
this wizard, see Activate Domain in Chapter 2, “Tasks.”

Domain Deactivation Wizard In Domain Explorer, right-click on a domain entry and select 
Deactivate Domain from the context menu to open this 
wizard. This contains a table of all active domains. For details, 
see Domain Deactivation Wizard. For instructions on using this 
wizard, see Deactivate Domain in Chapter 2, “Tasks.”

Evaluation Wizard Click Evaluate to open the Evaluation Wizard for evaluating 
one or more domains. For details, see Evaluation Wizard in 
Chapter 3, “Reference.” For instructions on using this wizard, 
see Evaluate Domain in Chapter 2, “Tasks.”
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Filters Wizard Click the Signature Explorer menu icon and select the Filters 
menu option. The Filters Wizard enables you to specify which 
signatures to display in Signature Lists. For details, see Filters 
Wizard in Chapter 3, “Reference.” For instructions on using 
this wizard, see Filter Signatures in Chapter 2, “Tasks.”

Inventory Wizard Click Inventory to open the Inventory Wizard. A Domain 
Inventory is a snapshot of all of the configuration details for a 
domain as it exists at that moment. For details, see Inventory 
Wizard in Chapter 3, “Reference.” For instructions on using 
this wizard, see Inventory Domain in Chapter 2, “Tasks.”

Shortcut Wizard Select File > New > Shortcut to open the Shortcut Wizard for 
creating and modifying Shortcuts. For details, see Shortcut 
Wizard in Chapter 3, “Reference.” For instructions on using 
this wizard, see Create Shortcut in Chapter 2, “Tasks.”

Shortcut Evaluation Wizard Click the Shortcut Explorer tab to open the Shortcut 
Explorer. Then, double-click on a Shortcut name in the 
Shortcut list to open the Shortcut Evaluation Wizard. For 
details, see Shortcut Evaluation Wizard in Chapter 3, 
“Reference.” For instructions on using this wizard, see 
Evaluate Shortcut in Chapter 2, “Tasks.”

Table 1-11  Guardian Wizards

Menu Item Description
1-18 Oracle Guardian User Guide



Guard ian  User  In te r face
For a detailed description of each of the Guardian Wizards, see Wizards of Chapter 3, 
“Reference.”

Wizard Titlebar Menus
Right-click a wizard titlebar to open a context menu of options to Move, Size, or Close the 
wizard. You can also move or resize a Wizard by dragging the titlebar or window borders.

Service Request Wizard Select a signature in an Evaluation Summary and click Get 
more help from Oracle Support. This opens the Service 
Request Wizard for the selected signature. This enables you to 
create a service request based on the selected signature. For 
details, see Service Request Wizard in Chapter 3, “Reference.” 
For instructions on using this wizard, see Creating a Service 
Request Archive in Chapter 2, “Tasks.”

Update Wizard Click Update to open the Update Wizard. This wizard 
enables you to automatically download new Oracle Guardian 
software and signatures from the Oracle Guardian update site. 
For details, see Update Wizard in Chapter 3, “Reference.” For 
instructions on using this wizard, see Automatically Update 
Guardian in Chapter 2, “Tasks.”

WARNING: Upgrading from Guardian 1.0.x to Guardian 1.1 
must be done manually. For instructions, see Manually Update 
Guardian and Manually Update Guardian Registry in 
Chapter 2, “Tasks.” 

You can use the Update Wizard to automatically update 
Guardian when updating from Guardian 1.1.x to  
Guardian 10g R3 (10.3.0.0). You do not have to update 
manually in this case.

Table 1-11  Guardian Wizards

Menu Item Description
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Guardian Online Help System
The Guardian Online Help system has the following structure:

About Oracle Guardian — This section provides an overview of Guardian components, 
features, and key concepts. Also provided are basic instructions for using and navigating 
the Guardian User Interface and Online Help System.

Tasks — This section provides detailed instructions for Guardian tasks and procedures. 
Tasks are categorized according to the component or feature to which they apply. The 
Tasks Help folder contains a number of subfolders, one for each task category. Expand a 
category folder to see the tasks relating to that topic.

Reference — This section provides a detailed description of the Guardian User Interface 
components and features, and a detailed reference guide to the Guardian Command Line 
Interface.

Guardian Command Line Interface
The Guardian Command Line Interface is a command interpreter that is an executable .cmd 
batch file for Windows, and a .sh shell script for Linux. Both the Windows batch file and the 
Linux shell script are wrappers that accumulate and organize arguments to the Java command. 
You can invoke the Command Line Interface from a Windows Command Prompt window or a 
Linux terminal window. 

For basic instructions on using the CLI, see Command Line Interface on Chapter 2, “Tasks.” For 
a detailed description of all CLI commands, use, and syntax, see Command Line Interface of 
Chapter 3, “Reference.”
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Key Concepts
This section provides an overview of Guardian components, features, and key concepts. These 
include:

Guardian Agent

Guardian Workspace

Guardian Registry

Domain

Domain Nodes

Domain Groups

Domain Inventory

Signature

Signature Bundle

Signature Annotations

Evaluation

Snapshot Evaluation

Evaluation Summary

Signature Repository

Shortcut

Support Service Request
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Guardian Agent
The Guardian Agent is a lightweight web application that gathers the data used for evaluations.

The Guardian Agent collects the following data:

JMX data

Java system properties

Database metadata for your JDBC connection pools

J2EE Deployment Descriptors from WebLogic instances

JRockit JMAPI data

JRockit Runtime Analyzer data

JRockit thread dump data

Multiple Guardian Agent Threads
If you have one or more managed servers in a domain, the Guardian Agent spawns the appropriate 
number of threads for communicating between the Guardian Agent on the WebLogic 
Administration Server, and the Guardian Agent running on the Managed Server(s).

An excessive number of threads can affect the performance of the Administration Server, so 
Guardian enables you to specify the maximum number of Agent threads that can be spawned. In 
addition, in order to manage Agent resources on both the Administration and Managed Servers, 
you can specify the maximum amount of time (in seconds) that can elapse before a thread is 
terminated. For instructions, see Configure Maximum Agent Threads and Configure Agent 
Thread Timeout in Chapter 2, “Tasks.”
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Guardian Workspace
The Guardian Workspace is the directory in which all of your Guardian data is stored. It includes 
the following data for each domain you have defined in Guardian:

Preferences

Domain Inventories

Evaluation Summaries

When you invoke Guardian, you are prompted to select a location for your Guardian Workspace. 
To prevent loss of work when Guardian is updated or uninstalled, select a Workspace location 
outside of the Guardian installation directory (see Select Workspace).You can also safely back 
up your Workspace data by exporting your Workspace to a file also located outside of your 
Guardian Installation directory. For instructions, see Export Workspace of Chapter 1, “About 
Oracle Guardian.”

Although the documents in the Guardian Workspace are persisted as XML files, they are best 
viewed through the Guardian User Interface. The Guardian User Interface provides a number of 
tools for viewing, managing, and processing your data, as well as better protection against 
unintended edits or deletions. For basic instructions on using the interface, see Guardian User 
Interface. For a detailed description of Guardian User Interface components and features, see 
Chapter 3, “Reference.” See Chapter 2, “Tasks,” for detailed instructions for using the interface 
to perform specific Guardian tasks.

Guardian Registry
The Guardian Registry is an XML document in which your Oracle Guardian configuration 
specifications are maintained. The Guardian Registry is created during product installation, and 
updated whenever you modify your configuration or perform certain Guardian operations. The 
Guardian Registry identifies the domains you have activated, the Signature Bundles available for 
evaluation, the Shortcuts you have defined, and your Guardian Workspace location(s). 
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Domain
A domain is a logically related group of WebLogic Server resources that are managed as a unit. 
A domain always includes at least one WebLogic Server instance called the Administration 
Server. The Administration Server acts as a central point of contact for server instances and 
system administration tools. A domain may also include additional WebLogic Server instances 
called Managed Servers. 

Each Oracle Guardian installation maintains a Guardian Registry of active domains. A domain is 
considered active when it is capable of being evaluated. You can activate and deactivate domains 
at will, and select which to evaluate at any given time.

Domain Nodes
A domain node represents a domain that has been defined in Guardian. When you activate a 
domain for the first time in Guardian, a node for the new domain is added to the Target Domains 
folder in the Domain Explorer tree. A unique name is automatically generated for the new 
domain, based upon your entries in the Domain Activation Wizard. 

Note: In the Command Line Interface, the domain node name is referred to as the domainId for 
the domain.

The Domain Explorer displays only the active domain nodes. An active domain is a domain that 
has been activated (defined for evaluation) in Guardian. This does not refer to the state of the 
domain servers. If you deactivate a domain in Guardian, that domain is removed from the Domain 
Explorer tree. However, if you reactivate the domain, the node for that domain is again displayed, 
and the original contents of the History folders are also again available. Deactivating a domain 
does not remove the Workspace data for that domain.

For more information, see “Domain Nodes” on page 3-111 in Reference.

Domain Groups
You can organize the domains in Guardian into Domain Groups for easier management. For 
instructions on creating and managing Domain Groups, see Domain Groups in Chapter 2, 
“Tasks.”
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Domain Inventory
A Domain Inventory is an XML document that describes the products in a Guardian domain. The 
inventory includes descriptions of your servers, Java Virtual Machines, operating systems, and 
databases. The descriptions include product versions as well as some configuration settings.

A Domain Inventory is created when you activate or evaluate a domain. The Inventory History 
is also refreshed each time a domain is evaluated. You can use the Domain Inventory Wizard 
in the Guardian User Interface to define and generate a new Domain Inventory. 

Domain Inventory files are stored and maintained in your Guardian Workspace. You can use the 
Domain Explorer in the Guardian User Interface to view and manage Domain Inventories. 

Signature
Oracle Support has identified patterns in user domains that can cause problems. These patterns 
are described in XML documents called signatures.

Signatures describe potential problems based on information about your Oracle WebLogic 
Servers and the environment in which they are deployed, including Java Virtual Machines 
(JVMs), operating systems, and databases. Signatures contain executable logic that can identify 
specific versions of these products as well as their configuration settings.

In addition to the potential problem description, signatures also contain a remedy 
recommendation and a severity level: 1-Critical, 2-Warning, or 3-Info.

To detect which signatures apply to your domain, you conduct an evaluation. When the 
evaluation is complete, the results are displayed in an Evaluation Summary. The Evaluation 
Summary lists all of the detected signatures, along with the severity level, description, and 
recommended remedy for each.

Signatures form a primary component of Oracle Guardian, since they contain the distilled 
knowledge of Oracle Support for both detecting potential problems and resolving them.
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Signature Bundle
A Signature Bundle is a group of signatures that are evaluated together against one or more 
specified domains. Signatures are grouped into bundles based on their characteristics. For 
example, the Security Advisories bundle contains signatures that detect potential security 
problems for which Oracle has issued Security Advisories. The Service Pack Remedy bundle 
contains signatures whose resolution requires installation of a specific service pack. 

You can select which bundle to evaluate against which domain(s). Bundles determine the 
signatures—and consequently, the potential issues—for which to search. The domain(s) you 
specify determine where to search.

You can use the Bundle Explorer Navigator view to browse the available Signature Bundles and 
their contents. 

For details, see Bundle Explorer in Chapter 3, “Reference.” For instructions on using Bundles, 
see Bundles in Chapter 2, “Tasks.” 

Signature Annotations
Signature Annotations enable you to tag a detected signature with one or more persistent 
annotations about that signature. 

An annotation contains the following information:

Type — This indicates the Annotation Type. There are two types: Ignore and Flag. 

Name — (Optional) This is a text field into which you can enter a short name for this 
annotation.

Comment — This is a text field into which you can enter comments or other notes about 
the signature. 

Timestamp — This records the date and time the annotation was created.

Domains — This specifies the Annotation Target for this annotation for this signature. 
This can be All Domains, This Domain, or This Evaluation. 

Evaluations — (Automatic) This specifies the Evaluation(s) to which this annotation 
applies for this signature.

You can use the Annotations Wizard to create, edit, and delete annotations. For details, see 
Annotations Wizard in Chapter 3, “Reference.” For instructions, see Signature Annotations in 
Chapter 2, “Tasks.” 
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In addition, you can use Signature Filters to specify which annotated signatures are to be 
displayed in the Signature Explorer, Bundle Explorer, and Evaluation Summaries. For 
instructions, see Filter Annotated Signatures in Chapter 2, “Tasks.” For complete instructions on 
using filters, see Filter Signatures in Chapter 2, “Tasks.” 

Evaluation
To detect which signatures apply to your domain, you conduct an evaluation. When the 
evaluation is complete, the results are displayed in an Evaluation Summary. The Evaluation 
Summary lists all of the detected signatures, along with the severity level, description, and 
recommended remedy for each.

Snapshot Evaluation
A Snapshot Evaluation is a complete assessment of all of the configuration details for a specific 
domain, at the particular moment the evaluation is executed. 

You can compare two Snapshot Evaluations to see very quickly the differences between 
configurations for two domains, or the same domain at different points in its history. For 
instructions, see Compare Inventories or Evaluations of Chapter 2, “Tasks.”

Evaluation Summary
The results of an evaluation are displayed in an Evaluation Summary. The Evaluation Summary 
lists all of the signatures from the specified bundle that were detected for the evaluated domain, 
along with the severity level, description, and recommended remedy for each signature.

Signature Repository
The Signature Repository contains the locally persisted store of signatures available for 
evaluation. When you download signatures from the Guardian update site, they arrive in a Java 
Archive (JAR) file. The JAR file is stored in the repository/archives directory of your 
Guardian installation directory.

Shortcut
A Shortcut enables you to streamline the evaluation procedure by predefining and storing the 
domain, Signature Bundle, and other parameters for evaluations that you perform frequently. You 
can then evaluate the Shortcut, saving you the effort of re-entering the parameter values each time 
you want to run the evaluation. 
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Support Service Request
A support service request is a record created when you submit technical questions or issues to 
Oracle Support. Customers with a support contract can open a service request on the Oracle 
eSupport website or by calling Oracle Customer Support.

Guardian enables you to open a Oracle Customer Service Request directly from a Guardian 
evaluation. When you conduct an evaluation that detects a signature, you can create a service 
request directly from a selected signature in an Evaluation Summary. Guardian creates and saves 
the service request data as a Service Request Archive for later submission to Oracle Support. 
Service Request Archives include all of the information from the signature and are stored as files 
with the file name extension .car. This enables a Oracle support engineer to begin working on 
your service request upon receipt of the archive. You can also add any additional attachments and 
notes before sending the service request archives to Oracle.

To learn more about Oracle Support and service requests, see the Oracle Customer Support 
Guidebook, which you can download from the Oracle Customer Support website.

Security

Authentication
To safeguard your domains, Guardian requires valid login credentials for all communications 
between Guardian and your Guardian domains. Whenever you conduct an evaluation or activate 
a domain, Guardian prompts you for the username and password of an Administrator or Monitor 
account on the target domain. You can choose to store the username and password so you do not 
have to enter them for every evaluation. All usernames, passwords, and server names persisted 
on disk are encrypted. 
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Data Encryption
Any passwords, usernames, or server names persisted on disk are encrypted. This encryption 
helps prevent the disclosure of any clear text data that could compromise the security of your 
domain. SSL encryption is available for communication between Guardian and your domains and 
between Guardian and Oracle. Guardian uses 128 bit open source encryption for SSL. However, 
the configuration on the server for the domain determines whether or not Guardian will use 128 
bit SSL encryption when activating that domain.

Note: Oracle recommends using SSL encryption for communication between the client and the 
Guardian Agent.

Secure Transmission
Secure Sockets Layer (SSL) encryption is available for all communication with Oracle over the 
Internet, and all communication with Guardian Agents in your target domain(s).

Note: Oracle recommends using SSL encryption for communication between the client and the 
Guardian Agent. Guardian uses 128 bit open source encryption for SSL. However, the 
configuration on the server for the domain determines whether or not Guardian will use 
128 bit SSL encryption when activating that domain.

If you want to use SSL, there are three types of communication to consider:

Target domain communication - To use SSL encryption for communications between 
Oracle Guardian and your target domain(s), select the https:// communications protocol 
option in the Domain Activation Wizard. For instructions, see Activate Domain of 
Chapter 2, “Tasks.”

Signature downloads - To use SSL encryption when downloading signatures from Oracle 
Support, select Require SSL in the Guardian Preferences page. This will also set SSL 
encryption for uploading signature usage statistics (see Privacy). For instructions on 
configuring your Guardian preferences, see Preferences of Chapter 2, “Tasks.”

Privacy
When you download signatures into Guardian from Oracle Support, Oracle collects high level 
statistics about your signature usage, including the number of times each signature was evaluated 
and detected. No customer data is included in the usage statistics. This information is used only 
in aggregate to assess the effectiveness of each signature. This data is crucial to the continuous 
improvement of Oracle Guardian.
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The signature usage statistics contain the following information:

signature id — This is the unique identifier for the signature. 

type — This is the category of the signature.

fired — This is the number of times the signature was considered for use. This also 
includes the number of times the signature was disqualified before evaluation due to 
targeting products not present on the domain. 

evaluated — This is the number of times the signature was actually compared against the 
target domain.

detected — This is the number of times the signature was actually found on the target 
domain 

The following is a sample signature usage statistic:
<?xml version="1.0" encoding="UTF-8"?> 
<usage> 
<signature id="123456.sig" type="Evaluation" fired="30" evaluated="18" 
detected="2" /> 
<signature id="234567.sig" type="Evaluation" fired="30" evaluated="20" 
detected="1" /> 
</usage>
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Key Tasks
There are many ways to configure and use Guardian to diagnose the health of your domains. 
However, there are four essential tasks that can be considered the primary functions of Guardian. 
These are as follows:

Activate Domain

Inventory Domain

Evaluate Domain

Update Guardian

The following sections provide a brief description of each of these tasks. For a complete 
description of all Guardian tasks and procedures, see Chapter 2, “Tasks.”

Activate Domain
Activating a domain prepares the domain for evaluation and conducts an initial inventory of the 
domain configuration.

To activate a domain, use the Domain Activation Wizard. For instructions, see Activate Domain 
of Chapter 2, “Tasks.”

Inventory Domain
A Domain Inventory is a snapshot of all of the configuration details for a domain as it exists at 
that moment. The results are displayed in a Domain Inventory Overview in the Document Pane. 
The inventory is also added to the Inventory History folder in the Domain Explorer. Domain 
Inventories are also generated automatically whenever you activate or evaluate domains.

To inventory a domain, use the Inventory Wizard. For instructions, see Inventory Domain of 
Chapter 2, “Tasks.”
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Evaluate Domain
To detect which signatures apply to your domain, you conduct an evaluation. Guardian collects 
data about your domain environment, and identifies which signatures apply to the domain.When 
the evaluation is complete, the results are displayed in an Evaluation Summary. The Evaluation 
Summary lists all of the detected signatures, along with the severity level, description, and 
recommended remedy for each.

You can review the Evaluation Summary to determine your response to any signatures that are 
detected. If you need more help resolving the potential problem identified by the signature, you 
can use Guardian to create an Oracle service request archive.

For instructions on conducting evaluations, see Evaluate Domain of Chapter 2, “Tasks.” 

Update Guardian
Oracle Support Engineers create new signatures every day, and new application enhancements to 
Guardian are also periodically released. The Guardian Update feature enables Guardian to 
connect directly to the Guardian Update site to automatically download and install new signatures 
and product updates. To update Guardian on servers that do not have Internet access, you can 
perform a manual update.

For instructions for performing both automatic and manual updates, see Updates and Upgrades 
of Chapter 2, “Tasks.” 
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Example Scenarios
The following scenarios are examples of some of the different ways you can use Guardian to find 
problems before they impact your environment.

Scenario 1: Development Cycle Evaluations
As you develop an application and migrate from development to quality assurance to production, 
you can run an evaluation at each stage. Guardian will help ensure that each phase of your 
development process is compliant with Oracle best practices.

Scenario 2: Heavy Load Evaluations
Some signatures are designed to evaluate runtime domain settings. Running an evaluation under 
heavy load can detect potential problems that would not otherwise be detected. Oracle 
recommends conducting these evaluations during load and performance testing.

Scenario 3: Application Update Evaluations
After you update an existing application, you can run an evaluation to assess the deployment. 
Guardian will help you find any potential problems that could impact your upgrade.

Scenario 4: Vendor Software Update Evaluations
After you install a new Oracle patch, service pack, or upgrade, or install or upgrade third party 
software, you can run an evaluation to identify any new issues that may have been introduced.

Scenario 5: Post Repair Evaluations
If Guardian earlier detected a signature, and you subsequently applied the remedy or made other 
changes to your system, you can run an evaluation to confirm that the signature is no longer 
detected and no new issues were introduced.

Scenario 6: Post Domain Change Evaluations
If you made changes to your domain configuration or settings, you can run an evaluation to 
confirm that the result is compliant with Oracle best practices.
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Scenario 7: Scheduled Overnight Evaluations
If you are concerned about domain settings being incorrectly changed overnight, or your domain 
is approaching certain resource limits, you can schedule evaluations to run overnight. You can 
review the Evaluation Summary in the morning and decide if any detected signatures merit 
further investigation.

Scenario 8: Heartbeat Evaluations
Guardian evaluations are designed to have as minimal an impact on throughput and CPU usage 
as possible. If your domain has extra capacity, you can schedule Guardian to run evaluations at 
regular intervals; for example, every 15 minutes. Then, if any changes are made or certain 
thresholds are reached, you can be notified quickly.

Scenario 9: Diagnostic Evaluations
If you notice a problem on your domain, you can run an evaluation. Even if an earlier evaluation 
detected no signatures, something may have changed since that time to cause the new problem. 
Guardian can be your first line of defense in diagnosing and repairing domain problems.
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Supported Targets
Supported Targets are the environments that Oracle Guardian can target for evaluations. 

Basically, Guardian can target any platform for evaluation that allows it to install and 
communicate with the Guardian Agent. In addition, the Guardian Agent itself must have access 
to a specific set of Java system information properties and methods. The Oracle products capable 
of supporting these operations are based on WebLogic Server versions 8.1 and above.

The following Oracle product versions are supported:

Note: For the most current information on Supported Oracle product versions, please see the 
Oracle Guardian Installation Guide.

Table 1-12  Supported Oracle Product Versions

Oracle Product Versions

AquaLogic Data Services Platform 2.0 and above

AquaLogic Service Bus 2.1 and above

Oracle JRockit JDK Java Version 5 (Version 1.5) and above

WebLogic Communications Platform SIP Server 3.0 and above

WebLogic Integration 8.1 and above

WebLogic Platform 8.1 and above

WebLogic Portal 8.1 and above

WebLogic RFID Enterprise Server 1.1 

2.0 

WebLogic Server 8.1 and above

WebLogic Virtual Edition 1.1
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C H A P T E R 2
Tasks
This chapter provides detailed instructions for using and managing the following Guardian 
features and components:

Basic Tasks

Guardian Agent

Workspaces

Preferences

Domains

Domain Groups

Proxy Servers

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Command Line Interface
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Troubleshooting

Support

Updates and Upgrades

Basic Tasks
There are many ways to configure and use Guardian to diagnose the health of your domains. 
However, there are four essential tasks that can be considered the primary functions of Guardian. 
These are as follows:

Activate Domain — Activating a domain prepares the domain for evaluation and conducts 
an initial inventory of the domain configuration. To activate a domain, use the Domain 
Activation Wizard. For instructions, see Activate Domain.

Inventory Domain — A Domain Inventory is an assessment of your current domain 
environment. The results are displayed in a Domain Inventory Overview in the Document 
Pane. The inventory is also added to the Inventory History folder in the Domain Explorer. 
Domain Inventories are also created automatically whenever you activate or evaluate 
domains. To inventory a domain, use the Inventory Wizard. For instructions, see 
Inventory Domain.

Evaluate Domain — To detect which signatures apply to your domain, you conduct an 
evaluation. Guardian collects data about your domain environment, and identifies which 
signatures apply to the domain.When the evaluation is complete, the results are displayed 
in an Evaluation Summary in the Document Pane. The Evaluation Summary lists all of 
the detected signatures, along with the severity level, description, and recommended 
remedy for each. You can review the Evaluation Summary to determine your response to 
any signatures that are detected. If you need more help resolving the potential problem the 
signature identified, you can use Guardian to create and submit an Oracle service request. 
For instructions on conducting evaluations, see Evaluate Domain.

Updates and Upgrades — Oracle Support Engineers create new signatures every day, and 
application enhancements to Guardian are also periodically released. The Guardian Update 
feature enables Guardian to connect directly to the Guardian Update Site to automatically 
download and install new signatures and product updates. To update Guardian on servers 
without Internet access, you can perform a manual update. For instructions for performing 
both automatic and manual updates, see Updates and Upgrades.
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There are numerous other Guardian tasks and activities, which are categorized according to the 
following topics:

Guardian Agent

Workspaces

Preferences

Domains

Domain Groups

Proxy Servers

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Command Line Interface

Troubleshooting

Support

Updates and Upgrades

The following sections provide detailed instructions for performing the tasks in each of these 
categories.
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Guardian Agent
This section provides instructions for the following tasks:

Manually Deploy the Guardian Agent

– Deploy Guardian Agent from WebLogic Server Administration Console

– Deploy Guardian Agent to Multiple Servers

Configure Maximum Agent Threads

Configure Agent Thread Timeout

Manually Deploy the Guardian Agent
If you upgrade from a Guardian version earlier than 1.0.7 to a Guardian version of 1.0.7 or above, 
you may not be unable to activate domains until you manually deploy the new Guardian Agent 
in the WebLogic Server. To do this, you must first undeploy the old Guardian Agent, and then 
deploy and start the new Agent.

Note: If you are using WebLogic Server 10.3, the Guardian Agent is already installed and ready 
for on-demand deployment. To enable the deployment, open the WebLogic Server 
Administration Console and select Domain > Configuration > General > Enable 
Oracle Guardian Agent. For complete instructions, see the WebLogic Server 
Administration Console online help.

You can use the WebLogic Server Administration Console to uninstall the existing Guardian 
Agent and then install and deploy the new Agent. The WebLogic Server Administration Console 
provides a series of Web-based deployment assistants that guide you through the deployment 
process. For basic instructions, see Deploy Guardian Agent from WebLogic Server 
Administration Console. For complete instructions on deploying applications, see the 
Administration Console Online Help, and WebLogic Server documentation. 

If you want to deploy the Guardian Agent to multiple servers, you can use a WebLogic Scripting 
Tool to automate this task. For basic instructions, see Deploy Guardian Agent to Multiple 
Servers. For instructions on using a script to activate multiple domains in Guardian, see Activate 
Multiple Domains. For complete instructions on using the WebLogic Scripting tool to deploy 
applications, see the WebLogic Scripting Tool documentation. 
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Deploy Guardian Agent from WebLogic Server Administration Console
You can use the WebLogic Server Administration Console to manually deploy the Guardian 
Agent on that server. This section provides a summary of the basic steps involved for WebLogic 
Server versions 9.0 and above. For complete instructions for your specific version of WebLogic 
Server, please see your WebLogic Server documentation and Administration Console Online 
Help. Please also refer to the Guardian 1.1 Installation Guide and Guardian 1.1 Release Notes 
for additional important information.

To use the Administration Console to manually deploy the Guardian Agent, do the following:

1. Start the WebLogic Administration Console, and select Lock & Edit in the left pane.

Caution: Make sure that Lock & Edit is selected for each of the following procedures.

2. Stop the existing Guardian Agent deployment in the WebLogic Server.

By default, the Guardian Agent is named bea-guardian-agent.war. 

Note: For detailed instructions for this procedure, see “Start and stop a deployed Enterprise 
Application” in the WebLogic Administration Console Online Help.

3. Delete the existing Guardian Agent deployment from the WebLogic Server, and activate your 
changes.

Note: For detailed instructions for this procedure, see “Delete an Enterprise Application” in 
the WebLogic Administration Console Online Help.

4. Install the new Guardian Agent in the WebLogic Server, and activate your changes.

The Guardian Agent is a WAR file named bea-guardian-agent.war, and is located in 
the following directory:

WARNING: Do not change the name of the Guardian Agent when deploying it. Be sure to 
use the default name, bea-guardian-agent.war.

<root>\guardian\plugins\com.bea.guardian.agent.weblogic_<guard-version>
\weblogic<wls-version>

Where: 

<root> is the parent directory for the Guardian installation. For example: 
C:\\Program Files

<guard-version> is the current (updated) Guardian version.

<wls-version> is the version of WebLogic Server in which you are deploying this Agent. 
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If you are installing the Agent on WebLogic 8.1.x, install the bea-guardian-agent.war 
file located in the ..\weblogic8 directory. For WebLogic Server 9.x and 10.x, install the 
bea-guardian-agent.war file located in the ..\weblogic9 directory.

Note: For detailed instructions for this procedure, see the section entitled, “Install an 
Enterprise Application” in the Administration Console Online Help.

5. Start the new Guardian Agent in the WebLogic Server.

Note: For detailed instructions for this procedure, see “Start and stop a deployed Enterprise 
Application” in the WebLogic Administration Console Online Help.

6. Start Guardian and activate the necessary domains in Guardian.

Note: For detailed instructions for this procedure, see “Activate Domain” in the Oracle 
Guardian Online Help.

You can now use Guardian to evaluate the activated domains in your environment.

Deploy Guardian Agent to Multiple Servers
If you need to deploy the Guardian Agent to multiple servers in a cluster environment, you can 
use the weblogic.Deployer command in the WebLogic Server Command Line Interface to 
automate this task. You can also use the Oracle WebLogic Scripting Tool (WLST) to deploy the 
Agent. This section provides basic instructions for using the weblogic.Deployer command for 
this purpose. For instructions on using WLST, please see the WebLogic Scripting Tool product 
documentation. 

Note: Please also refer to the Guardian 1.1 Installation Guide and Guardian 1.1 Release Notes 
for additional important information.

WARNING: Do not change the name of the Guardian Agent when deploying it. Be sure to use 
the default name, bea-guardian-agent.war.

At the WebLogic Server CLI prompt, enter the following command line:
java weblogic.Deployer -debug -adminurl http://<admin_url>:<port> -username 
<username> -password <password> –targets adminserver,<cluster1>,<cluster2> 
-deploy  -sourcerootforupload  <dir_path>\bea-guardian-agent.war

Where:

<admin_url> is the URL for the WLS Admin Server.

<port> is the port number for the WLS Admin Server.
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<cluster1>,<cluster2> are the names of all configured clusters.

<dir_path> is the directory path to the Guardian Agent WAR file 
(bea-guardian-agent.war).

Configure Maximum Agent Threads
If you have one or more managed servers in a domain, the Guardian Agent spawns the appropriate 
number of threads for communicating between the Guardian Agent on the WebLogic 
Administration Server, and the Guardian Agent running on the Managed Server(s). However, an 
excessive number of threads can affect the performance of the Administration Server. To control 
this, you can specify the maximum number of Agent threads to allocate to the WebLogic Server 
Administration Server for a specified domain. The Max. Agent Threads parameter setting 
determines this value. The default is 10. 

There are two ways to set the value for this parameter:

When activating the domain, you can set the Max. Agent Threads parameter in the 
Advanced tab page of the Domain Activation Wizard (see Activate Domain).

If the domain is already activated, you can set the Max. Agent Threads parameter in the 
Domain Properties dialog box (see below).

You can set the Max. Agent Threads parameter in the Guardian > Evaluation page of 
the Preferences pages. For instructions on setting Preferences, see Preferences.

To set the Max. Agent Threads value for an activated domain, do the following:

1. In the Navigation pane, click the Domain Explorer tab to open the Domain Explorer.

2. Right-click on the domain name and select Modify Domain from the context menu.

This displays the Domain Properties dialog box.

3. Select or enter a value in the Max. Agent Threads field.

This can be an integer value from 1 to 20. The default is 10. 

4. Click OK.

This resets Max. Agent Threads to the specified value for the selected domain. 
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Configure Agent Thread Timeout
In order to manage Agent resources on both the WebLogic Administration Server and Managed 
Servers, Guardian enables you to specify the maximum amount of time (in seconds) that can 
elapse before a thread is terminated. The Agent Thread Timeout parameter governs this 
timeout. The default is 60. 

There are two ways to set the Agent Thread Timeout parameter:

When activating the domain, you can set the Agent Thread Timeout parameter in the 
Advanced tab page of the Domain Activation Wizard (see Activate Domain).

If the domain is already activated, you can set the Agent Thread Timeout parameter in 
the Domain Properties dialog box (see below).

You can set the Agent Thread Timeout parameter in the Guardian > Evaluation page of 
the Preferences pages. For instructions on setting Preferences, see Preferences.

To set the Agent Thread Timeout value for an activated domain, do the following:

1. In the Navigation pane, click the Domain Explorer tab to open the Domain Explorer.

2. Right-click on the domain name and select Modify Domain from the context menu.

This displays the Domain Properties dialog box.

3. Select or enter a value in the Agent Thread Timeout field.

This can be an integer value from 10 to 600. The default is 60. 

4. Click OK.

This resets Agent Thread Timeout to the specified value for the selected domain.
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Workspaces
This section provides instructions for the following tasks:

Select Workspace

Export Workspace

Import Workspace

The Guardian Workspace is the directory in which all of your Guardian data is stored. It includes 
the following data for each domain you have defined in Guardian:

Preferences

Domain Inventories

Evaluation Summaries

Service Request Archives (optional)

To prevent loss of work when Guardian is updated or uninstalled, your Workspace directory must 
be located outside of the Guardian installation directory. You can safely back up your Workspace 
data by exporting your Workspace to a file also located outside of your Guardian Installation 
directory. For instructions, see Export Workspace.

Select Workspace
To specify the location for your Guardian Workspace, you must restart Guardian and specify a 
new location in the Select Workspace dialog box during startup. 

WARNING: To prevent loss of work when Guardian is updated or uninstalled, your 
Workspace directory must be located outside of the Guardian installation 
directory. You can safely back up your Workspace data by exporting your 
Workspace to a file also located outside of your Guardian Installation directory. 
For instructions, see Export Workspace.
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To select a Guardian Workspace when starting Guardian, do the following:

1. Start Guardian.

Guardian first displays the initial splash screen while loading, and then displays the Select 
Workspace dialog box.

2. Click Browse.

This opens the Browse For Folder dialog.

3. Select or create the folder (directory) to use as your Workspace folder.

Caution: Make sure this directory is not located within the Guardian installation directory.

To use an existing folder: Browse to the folder location and select the folder. 

To create a new folder: 

a. Click Make New Folder.

b. Select the location for the folder.

c. Enter the name of the folder

4. Click OK.

This creates or selects the file and returns to the Select Workspace dialog box.

5. (Optional) Specify this as the default Workspace.

If you do not want to select the Workspace each time you start Guardian, select the 
checkbox for Use this as the default workspace and do not ask again. 

To change this setting at a later time, do the following:

a. Select Window > Preferences... to open the Preferences page.

b. In the Preferences tree on the left, select Guardian.

c. Select the Prompt for workspace on startup checkbox.

d. Click OK.

The Select Workspace dialog box will be displayed the next time you start Guardian.

6. Click Finish.

Guardian loads the selected Workspace and completes the startup procedure.
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Export Workspace
You can export your Guardian Workspace data to a file, which you can use for backup and 
recovery purposes, or to import to another Guardian instance.

WARNING: To prevent loss of work when Guardian is updated or uninstalled, make sure your 
Workspace and any Workspace export files are located outside of your Guardian 
Installation directory. 

To export a Guardian Workspace, do the following:

1. Select File > Export.

This opens the Export Workspace Wizard.

2. In the Export dialog box, open the Guardian folder and select Guardian Workspace.

Note: To clear a typed entry, click the Clear icon (file page icon) to the right of the 
destination field. This clears the Select an export destination field and redisplays the 
default folder tree.

3. Click Next. 

4. For Select File, specify the file name and location to which to save your Workspace data.

Use one of the following methods to specify the file:

– Type in the absolute path name and file name.

– Click Browse to display a file browser from which you can select the file. Click Save 
to select the file and return to the Export Workspace Wizard.

5. Click Finish.

This saves your current Workspace as a .zip file containing all of your Workspace data, 
including the guardian.registry, .project and .refresh files.
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Import Workspace
You can import a Guardian Workspace from another Guardian instance, or an exported 
Workspace data file.

To import a Guardian Workspace, do the following:

1. Select File > Import.

This opens the Import Workspace Wizard.

2. In the Import Workspace Wizard, open the Guardian folder and select Guardian 
Workspace.

Note: To clear a typed entry, click the Clear icon (file page icon) to the right of the 
destination field. This clears the Select an import source field and redisplays the 
default folder tree.

3. Click Next.

4. For Select File, specify the Workspace file you want to import.

Use one of the following methods to specify the file:

– Type in the absolute path name and file name.

– Click Browse to display a file browser from which you can select the file. Click Save 
to select the file and return to the Import Workspace Wizard.

5. Click Finish.

This imports the selected Workspace data and returns to the main Guardian window. 
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Preferences
This section provides instructions for the following tasks:

Configure Preferences

Export Preferences

Import Preferences

Configure Preferences
You can use the Preferences page to configure your Guardian Preferences and customize your 
Guardian environment.

To configure your Guardian Preferences, do the following:

1. Open the Preferences page.

You can use either of the following methods to open the Preferences page:

– Press Ctrl+Shift+P. 

– Select Window > Preferences from the titlebar menu.

2. Open a folder and click on a category name to display the preferences in that category. 

The left pane of the Preferences page is a navigation tree containing an extensive series of 
hierarchical folders and subfolders. Each folder and subfolder in the hierarchy is a category 
of preference attributes that you can configure. 

The top level folders are as follows:

– General

– Guardian

– Help

– Install/Update

Note: For more information, see Preferences in Chapter 3, “Reference.” 

3. (Optional) Click Apply to apply your preference settings for the current category, or click 
Restore Defaults to restore the default values for all Preference page parameters.

4. When you have finished setting your preferences for each category, click OK.

This applies and saves all of your new Preference page settings.
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Export Preferences
You can export your Guardian Preferences to a file for backup and recovery purposes, or to 
import to another Guardian instance.

To export your Guardian Preferences to a file, do the following:

1. Select File > Export.

This opens the Export Preferences Wizard.

2. In the Export Preferences Wizard, open the General folder and select Preferences.

Note: To clear a typed entry, click the Clear icon (file page icon) to the right of the 
destination field. This will clear the Select an export destination field and redisplay 
the default folder tree.

3. Click Next.

4. Specify the preferences to export.

Do one of the following:

– Select Export all to export all of your Guardian Preferences information.

– Select Choose specific preferences to export to display a selection list of preferences 
in the Preferences box. Then select the individual preferences you want to export, or 
click Select All. 

5. For To preference file, specify the file name and location to which to save your preferences 
information.

Use one of the following methods to specify the file:

– Type in the absolute path name and file name.

– Click Browse to display a file browser from which you can select the file. Then click 
Save to select the file and return to the Export Preferences Wizard.

6. Click Finish.

This saves your current preferences information as a .epf file in the specified location.
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Import Preferences
To import a Guardian Preferences from a file, do the following:

1. Select File > Import.

This opens the Import Preferences Wizard. 

2. In the Import Preferences Wizard, open the General folder and select Preferences.

Note: To clear a typed entry, click the Clear icon (file page icon) to the right of the 
destination field. This clears the Select an import source field and redisplays the 
default folder tree.

3. Click Next.

4. For From preference file, specify the file name and location of the file you want to import.

Use one of the following methods to specify the file:

– Type in the absolute path name and file name.

– Click Browse to display a file browser from which you can select the file. Then click 
Save to select the file and return to the Import Preferences Wizard.

5. Specify the preferences to import.

Do one of the following:

– Select Import all to import all preference information.

– Select Choose specific preferences to import to display a selection list of preferences 
in the Preferences box. Then select the individual preferences you want to import, or 
click Select All. 

6. Click Finish.

This replaces your current Preference page settings with the settings from the imported 
file. 
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Domains
This section provides instructions for the following tasks:

Activate Domain

Activate Multiple Domains

Deactivate Domain

Modify Domain Properties

Purge All Inactive Domains

Activate Domain
A domain is active when it has been defined in Guardian and has been enabled for evaluation. 

Note: “Active” does not refer to the state of the domain servers themselves, but rather to 
whether you have enabled that domain for evaluation.

Activating a domain also results in the following:

The new domain node is added to the Domain Explorer Target Domains folder.

Guardian inventories the domain, and displays the Domain Inventory Overview in the 
Document Pane. In the Domain Explorer, the new inventory is added to the Inventory 
History folder for that domain. 

The domain is added to the Active Domain Table. 

The domain is added to the Guardian Registry. 

A folder for the domain is added to the Guardian Workspace. The domain folder contains 
the data from all Domain Inventories and Evaluation Summaries for the domain.

To activate a domain, do the following:

Note: If you are unable to activate any domains, you may need to manually deploy the Guardian 
Agent. For instructions, see Manually Deploy the Guardian Agent.

1. Open the Domain Activation Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+A. 

– Click Activate in the Main Toolbar. 
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– Select New > Domain from the File menu.

– Click the Domain Explorer tab to open the Domain Explorer. Then, right-click 
anywhere in the Domain Explorer and select Activate Domain from the context 
menu.

2. Click the General tab and configure the General Domain Properties.

The General tab contains the following fields:

– Protocol — Select one of the following from the drop-down menu:

Note: Oracle recommends using SSL encryption for communication between the client and 
the Guardian Agent. 

• http:// — Select this to use the HTTP protocol without encryption.

• https:// — Select this to use HTTP protocol with Secure Sockets Layer (SSL) 
encryption (recommended). Guardian uses 128 bit open source encryption for SSL. 
However, the configuration on the server for the domain determines whether or not 
Guardian will use 128 bit SSL encryption when activating that domain. 

– Host Name — This is the listen address for the WebLogic Administration Server in the 
target domain. 

– Port Number — This is the listen port for the WebLogic Administration Server for the 
target domain.

– Username — This is the username of a WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password — This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Remember Username/Password — This specifies that the domain credentials are to 
be stored so that you do not have to enter them for future domain operations. 
Usernames and passwords are encrypted when stored.

Note: If you preselected a deactivated domain when you invoked the Domain Activation 
Wizard, the Protocol, Hostname, and Port fields will be automatically filled with 
the appropriate values. 
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3. Click the Advanced tab and enter the Advanced Domain Properties.

The Advanced tab contains the following fields and options:

– Enable Proxy Connection: Select this if a proxy server is to be used to access the 
target domain. Then, select a proxy server from the drop-down list. Click Add Proxy 
Servers to add proxy servers to this list (see Add Inbound Proxy Servers for complete 
instructions).

– Max. Agent Threads: Select the maximum number of Agent threads to allocate in the 
WebLogic Server Administration Server. This can be an integer value from 1 to 20. 
The default is 10.

– Agent Thread Timeout (secs): Specify the maximum number of seconds that can 
elapse before an Agent thread is deactivated when collecting data from managed 
servers. This can be an integer value from 10 to 600. The default is 60. 

– Domain Notes: Enter a text description or other details pertaining to this domain. 
These notes are displayed in inventories and evaluations for this domain.

4. Click Finish.

You can now evaluate and inventory the domain.

Activate Multiple Domains
If you need to activate multiple domains in Guardian, you can use a script to automate this 
procedure.

Note: Oracle recommends using SSL encryption for communication between the client and the 
Guardian Agent. Guardian uses 128 bit open source encryption for SSL. However, the 
configuration on the server for the domain determines whether or not Guardian will use 
128 bit SSL encryption when activating that domain.

WARNING: You must deploy the Guardian Agent to each domain that is to be activated prior 
to running the activation script. For instructions, see “Deploy Guardian Agent to 
Multiple Servers,” above.

The following is an example script for activating multiple domains:
-gactivateDomain -t https://slp7:7001 -u un -p pw -c true

-gactivateDomain -t https://slp8:7001 -u un -p pw -c true

-gactivateDomain -t https://sqa-lldev:4044 -u un -p pw -c true
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The script can then be run in Guardian Headless Mode, by using the following command line:
guardianHeadless.cmd -gscript -f activatingScript.txt

For more information about running scripts, see Run Scripts.

Deactivate Domain
When you deactivate a domain, it is no longer available for evaluation. Any shortcuts that use the 
domain are removed from the Shortcuts Table and Shortcut Explorer. The Domain Inventory 
and Evaluation Summary data persists after deactivation, but is not available for viewing in 
Domain Explorer. You must reactivate the domain before you can view the data or evaluate the 
domain.

To deactivate a domain, do the following:

1. Open the Domain Deactivation Wizard.

Do one of the following:

– Click on the Domain Explorer tab to open the Domain Explorer. Then, right-click on 
a domain and select Deactivate from the context menu.

– Select Window > Show View > Active Domains Table. Then, select a domain from 
the table and click Deactivate Domain. 

2. Click on a domain entry to select it.

3. Click Finish.

WARNING: If you click Finish, you will not be prompted to confirm the deactivate 
operation. The domain will be deactivated immediately.

This deactivates the domain and returns to the Domain Explorer or Active Domain 
Table. 

Note: The Domain Deactivation Wizard does not remove the Oracle Guardian Agents that 
were installed when you activated the domains. For instructions on removing Agents, 
see the WebLogic Server Administration Console Online Help. For instructions on 
purging inactive domains from Guardian, see Purge All Inactive Domains.
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Modify Domain Properties
You can modify the Domain Properties for a domain to customize the way Oracle Guardian 
communicates with that domain. 

To modify the Domain Properties for a domain, do the following:

1. Open the Domain Properties configuration page.

Do one of the following:

– Select Window > Show View > Active Domains Table to open the Active Domains 
Table. Then, select a domain and click Modify Domain. 

– Click the Domain Explorer tab to open the Domain Explorer. Then, right-click on a 
domain in the Domain Explorer tree, and select Modify Domain from the context 
menu. 

2. Configure the Domain Properties.

The Domain Properties configuration page contains the following fields and options:

– Name: This identifies the name for this domain. You cannot modify this value.

– Username — This is the username of an WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password — This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Remember Username/Password — This specifies that the domain credentials are to 
be stored so that you do not have to enter them for future domain operations.

– Enable Proxy Connection: Select this if a proxy server is to be used to access the 
target domain. Then, select a proxy server from the drop-down list. This option is 
disabled if the Proxy Servers list is empty. For instructions on populating and enabling 
the list, see Add Inbound Proxy Servers.

– Max. Agent Threads: Select the maximum number of Agent threads to allocate in the 
WebLogic Server Administration Server. This can be an integer value from 1 to 20. 
The default is 10.
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– Agent Thread Timeout (secs): Specify the maximum number of seconds that can 
elapse before an Agent thread is deactivated when collecting data from managed 
servers. This can be an integer value from 10 to 600. The default is 60. 

– Notes: Enter a text description or other details pertaining to this domain.

3. Click OK.

This applies your new Domain Properties settings to the selected domain.

Purge All Inactive Domains
To remove all deactivated domains from the Domain Explorer, select Tools > Purge Inactive 
Domains. 

WARNING: You will not be prompted to confirm the purge operation. The domains are 
purged immediately. Purging the inactive domains also deletes the associated 
Domain Inventories and Evaluation Summaries from the Guardian Workspace, 
and removes the domains from the Guardian Registry.

Domain Groups
This section provides instructions for the following tasks:

Add Domain Group

Rename Domain Group

Delete Domain Group

Add Domain Group
To create and populate a new Domain Group, do the following:

1. In the Navigation Pane, click the Domain Explorer tab to open the Domain Explorer.

2. Right-click on Target Domains and select Add Domain Group from the context menu.

This opens the Add Domain Group dialog box.

3. In the Name field, enter a name for the Domain Group.
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4. Click OK.

This adds the new Domain Group to the Domain Explorer tree, and closes the Add 
Domain dialog box.

5. Populate the Domain Group.

In the Domain Explorer Domain tree, click on a domain name to select it, then drag and 
drop it into the new Domain Group folder. Repeat this step for each domain you want to 
include in the new Domain Group.

Rename Domain Group
To rename an existing Domain Group, do the following:

1. In the Navigation Pane, click the Domain Explorer tab to open the Domain Explorer.

2. Right-click on Target Domains and select Rename Domain Group from the context menu.

This opens the Rename Domain Group dialog box.

3. In the Name field, enter the new name for the Domain Group.

4. Click OK.

This renames the Domain Group in the Domain Explorer tree, and closes the Rename 
Domain dialog box.

Delete Domain Group
1. Click on the Domain Explorer tab to open the Domain Explorer.

2. Remove any domains from the Domain Group.

You cannot delete a Domain Group that contains a domain. If there are domains in the 
Domain Group, you can drag and drop the domains into the Target Domains folder, or 
into another Domain Group folder.

3. Right-click on the Domain Group you want to delete, and select Delete Domain Group from 
the context menu.

This displays a Domain Group Delete Confirmation dialog box prompting you to 
confirm the delete request.
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4. Click OK.

This deletes the Domain Group from the Domain Explorer tree, and closes the Delete 
Confirmation dialog box.

Proxy Servers
This section provides instructions for the following tasks:

Add Inbound Proxy Servers

Enable Inbound Proxy Connection

Enable and Test Outbound Proxy

Add Inbound Proxy Servers
If you want to use an inbound proxy server for communications between Guardian and the 
WebLogic Administration Server, you must first add the proxy server to Guardian.

To add an inbound proxy server, do the following:

1. Click Activate to open the Domain Activation Wizard.

2. Click the Advanced tab.

3. Click Add Proxy Servers to open the Proxy Servers Preferences page.

4. Click Add to open the Proxy Properties dialog box. 

5. Enter the proxy server Hostname, Port, Username, and Password information. 

6. Click OK.

This adds the proxy server to the Proxy Servers list in the Proxy Servers configuration 
page, and dismisses the Proxy Properties dialog box. 

7. (Optional) Repeat steps four through six to add additional proxy servers to the list.

8. Click OK.

This adds the new proxy server to the Proxy Server drop-down list in the Advanced tab of 
the Domain Activation Wizard and dismisses the dialog box.
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Enable Inbound Proxy Connection
If you want to use an inbound proxy server for communications between Guardian and the 
WebLogic Administration Server, you must enable the proxy connection. 

To enable an inbound proxy connection, do the following:

1. Manually deploy the Guardian Agent onto the target domain. 

2. If you have not already done so, add the proxy server to the Proxy Server list in the Domain 
Activation Wizard.

For instructions, see Add Inbound Proxy Servers.

3. Open the Domain Activation Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+A. 

– Click Activate in the Main Toolbar. 

– Select New > Domain from the File menu. 

– Click the Domain Explorer tab to open the Domain Explorer. Then, right-click in the 
Domain Explorer panel and select Activate Domain from the context menu.

4. Click the Advanced tab in the Activate Domain Wizard.

5. Check the Enable Proxy Connection checkbox.

6. Select the proxy server from the drop down list.

7. Click Finish.
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Enable and Test Outbound Proxy
If you are using an outbound proxy server for communications between Guardian and the outside 
world, you will need to test the outbound proxy connection. 

To enable and test an outbound proxy server connection, do the following:

1. Select Window > Preferences from the titlebar menu.

This displays the Preferences page.

2. In the Preferences folder tree (left pane) open the Guardian folder and select Oracle 
Support.

This displays the Oracle Support preferences, which include some settings for proxy 
testing.

3. In the Oracle Support preferences, select the Requires Proxy checkbox.

4. Click Test Proxy.

After the test completes, a status message is displayed at the top of the page as to whether 
it was successful or not.

Inventories and Evaluations
This section provides instructions for the following tasks:

Inventory Domain

View Domain Inventories and Evaluation Summaries

Evaluate Domain

Evaluate Snapshot

Compare Inventories or Evaluations

Export Inventory or Evaluation
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Inventory Domain
A Domain Inventory is an assessment of your current domain environment. The results are 
displayed in a Domain Inventory Overview in the Document Pane. The inventory is also added 
to the Inventory History folder in the Domain Explorer. Domain Inventories are also created 
automatically whenever you activate or evaluate domains. 

To inventory a domain, do the following:

1. Open the Inventory Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+I. 

– Click Inventory on the Main Toolbar. 

– Select File > New > Inventory. 

– Click the Domain Explorer tab to open the Domain Explorer. Then, right-click on a 
domain name in the Domain Explorer tree and select Inventory from the context 
menu. 

2. If you did not preselect a domain when opening the wizard, select a domain from the 
Inventory Wizard domain table.

3. Enter the Username and Password of the WebLogic Server Administrator or Monitor 
account for the target domain.

4. Click Finish.

This initiates the Domain Inventory and displays the results in a Domain Inventory 
Overview in the Document Pane.

View Domain Inventories and Evaluation Summaries
To view an existing Domain Inventory, do the following:

1. Click the Domain Explorer tab to open the Domain Explorer. 

2. Open the Inventory History folder for the domain.

3. Double-click on the inventory name to view the selected Domain Inventory Overview in the 
Document Pane.
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Evaluate Domain
To identify potential problems before they occur, you can use the Evaluation Wizard to evaluate 
one or more domains.

Note: The evaluation of some signatures may hang the evaluation. To prevent this, open the 
Preferences page, and set the Guardian > Signature Evaluation Threshold parameter 
(in miliseconds). Then select the Enable Safe Evaluation checkbox. If enabled, the 
evaluation of a signature is terminated when this threshold is reached, and the Signature 
ID is written to the Hung Signature List. In addition, if a signature evaluation fails due to 
a runtime error, that Signature ID is written to the Problem Signature List. Guardian will 
not attempt to evaluate signatures in the Problem Signature List. For general instructions 
on setting Preferences, see Preferences.

WARNING: If a server is down when the evaluation is conducted, this can prevent some 
signatures from being detected. 

To evaluate a domain, do the following:

1. In the Navigation Pane, click the Domain Explorer tab to open the Domain Explorer.

2. Select a domain and open the Evaluation Wizard.

Use any of the following methods to select a domain and open the wizard:

– In the Domain Explorer, select a domain and then click the Evaluation button. To 
select multiple domains, press the Ctrl or Shift key while selecting additional items.

– Right-click on a domain and then select Evaluate from the context menu.

– Double-click a domain name in the Domain Explorer. 

– Select File > New > Evaluation from the titlebar. 

– Select Window > Show View > Active Domains Table to display the Active 
Domains Table. Then, double-click a domain name to open the wizard for the selected 
domain. 

3. In the Bundle field, select the Signature Bundle to evaluate.

Click the Bundle field for an entry to display a down-arrow icon at the far right of the 
field. Then click the arrow to open the Bundle drop down menu, and select a Signature 
Bundle. The default is Default Signatures.
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4. Enter the credentials for the WebLogic Server for the selected domain.

In the Domain Credentials section, enter the following:

– Username: This is the username for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password: This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain.

If you selected multiple domains, you must supply the login credentials for each domain 
before you can launch the evaluation. 

5. (Optional) Select the Remember username/password checkbox to save your login 
credentials for the selected domain(s).

Select this option if you want your login information to persist so that you do not have to 
enter it each time you evaluate this domain. This is especially useful if you routinely 
evaluate multiple domains concurrently. Usernames and passwords are encrypted when 
stored.

6. (Optional) Create a shortcut for this evaluation.

This is useful if you routinely perform this particular type of evaluation. To create a 
shortcut, select the Create Shortcut checkbox, and enter a brief name for the shortcut in 
the text field. For detailed instructions on creating, evaluating, and managing shortcuts, see 
the section entitled, Shortcuts.

7. Click Finish.

This initiates the evaluation and displays an Evaluation Summary of the results in the 
Document Pane. In the Domain Explorer, the new Domain Inventory is added to the 
Inventory History folder, and the new Evaluation Summary is added to the Evaluation 
History folder. For a complete description of the Domain Explorer, see Domain Explorer 
in Chapter 3, “Reference.”

Evaluate Snapshot
A Snapshot Evaluation is a complete assessment of all of the configuration details for a specific 
domain, at the particular moment the evaluation is executed. The process for performing a 
Snapshot Evaluation is the same as for any other type of evaluation. The primary difference is in 
the type of Signature Bundle you select for the evaluation, and the type of information the 
evaluation collects and evaluates. 
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Note: As with other evaluations, you can compare Snapshot Evaluations. Comparing two 
Snapshot Evaluations enables you to see very quickly the differences between 
configurations for those two domains. For instructions, see Compare Inventories or 
Evaluations. 

Note: If a server is down when the evaluation is conducted, this can prevent some signatures 
from being detected. 

Caution: Generating a Snapshot Evaluation of a large domain may consume a lot of memory, 
and take a long time to complete.

To evaluate a snapshot of a domain configuration, do the following:

1. In the Navigation Pane, click the Domain Explorer tab to open the Domain Explorer.

1. Select a domain and open the Evaluation Wizard.

Do one of the following:

– In the Domain Explorer, select a domain and then click the Evaluation button.

– Right-click on a domain name and then select Evaluate from the context menu.

2. In the Bundle field, select the type of snapshot to create and evaluate.

Click the Bundle field for an entry to display a down-arrow icon at the far right of the 
field. Then click the arrow to open the Bundle drop down menu, and select one of the 
following:

– Snapshot - All

– Snapshot - JDBC

– Snapshot - JMS

– Snapshot - Security

3. Enter the credentials for the WebLogic Server for the selected domain.

In the Domain Credentials section, enter the following:

– Username: This is the username for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password: This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain. 
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4. Click Finish.

This initiates the Snapshot Evaluation and displays an Evaluation Summary of the results 
in the Document Pane. In the Domain Explorer, the new Domain Inventory is added to 
the Inventory History folder, and the new Evaluation Summary is added to the 
Evaluation History folder. 

Compare Inventories or Evaluations
You can compare inventories or evaluations from the same or different domains. Both objects 
must be of the same type—that is, two inventories or two evaluations. You cannot compare an 
inventory against an evaluation. 

You can compare any two Evaluation Summaries. Comparing two Snapshot Evaluations is 
particularly useful, as a Snapshot Evaluation collects and evaluates all of the configuration data 
for the evaluated domain. Such a comparison enables you to see very quickly the differences 
between the configurations and their issues for those two domains. 

To compare two Domain Inventories or Evaluation Summaries, do the following:

1. In the Navigation pane, open the Domain Explorer.

Click the Domain Explorer tab, or select Window > Show View > Domain Explorer.

2. Open the History folder containing the resources to be compared (Inventory History or 
Evaluation History).

3. Select the two documents to be compared.

Click on the first item to select it, and then Ctrl+click to select the second item.

4. Right-click on the selected items and then select Compare from the context menu.

Note: The Compare option remains deactivated until two like items have been selected.

Selecting Compare opens the Text Compare display in the Document Pane. The 
differences between the two documents are highlighted, and related segments are shown in 
boxed sections, with connectors indicating the relation.

For a description of the Text Compare View navigation controls and context menu, see Text 
Compare View in Chapter 3, “Reference.”
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Export Inventory or Evaluation
You can export a Domain Inventory or Evaluation Summary report to a PDF or HTML file for 
external viewing or archiving.

To export a report, do the following:

1. Click the Domain Explorer tab in the Navigation Pane to open the Domain Explorer.

2. Open the History folder containing the report you want to save.

The Domain Explorer contains two History folders:

– Inventory History — This contains a linked list of the available Domain Inventory 
reports.

– Evaluation History — This contains a linked list of the available Evaluation Summary 
reports.

3. Open the report.

Double-click on a report name to open the report and display it in the Document Pane.

4. Select File > Save As.

This opens a standard Save As file browser.

5. Browse to the location to which to save the file.

6. Select the type of file to which to save the report.

For the Save as type: field, select one of the following from the drop-down menu:

– PDF Files (*.pdf)

– HTML Files (*.html)

7. Enter a file name in the File name field.

8. Click OK.
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Signatures
This section provides instructions for the following tasks:

View Signature Overview

Filter Signatures

Sort Signatures

View Signature Overview
To display the Overview for a signature—also referred to as the Signature View—do the 
following:

1. In the Navigation Pane, click on the Signature Explorer or Bundle Explorer tab.

This opens the Signature Explorer or Bundle Explorer, respectively. Signature 
Overviews are accessible only through these two Explorers.

2. Double-click on a signature name in the Navigation Pane.

This displays the overview for that signature in the Document Pane.

Filter Signatures
You can use Signature Filters to specify which signatures are to be displayed in the Signature 
Explorer, Bundle Explorer, and Evaluation Summaries.

To apply Signature Filters, do the following:

1. Open the Filters dialog box.

– From the Signature Explorer or Bundle Explorer:

Click the Menu icon (small white triangle in the upper right corner), and select 
Filters... from the context menu.

– From an Evaluation Summary:

Right-click on any signature in the Detected Signatures table, and select Filters... 
from the context menu.
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2. Specify your filter settings.

Click a radio button to specify Show or Hide for each filter. The Signature Filters are as 
follows:

Name — Filter according to name. Specify all or a portion of a signature name to use as 
the filter criteria. This can be a character string or standard regular expression. Enter .* to 
filter all signatures. The default is Show all (.*).

Severity — Filter according to severity. Click a checkbox to select/deselect a severity 
level. These are: Critical, Warning, and Information. The default is Show all (all 
selected).

Type — Filter annotated signatures according to Annotation Type. Click a checkbox to 
select/deselect a type. There are two Annotation Types: Flag and Ignore. The default is 
Hide signatures with an Annotation Type of Ignore. For more information on Annotation 
Types, see Signature Annotations in Chapter 1, “About Oracle Guardian.” 

Annotation Name — Filter annotated signatures according to Annotation Name. Specify 
all or a portion of an Annotation Name to use as the filter criteria. This can be a character 
string or standard regular expression. Enter .* to filter all annotated signatures. The default 
is Show all (.*).

Comment — Filter annotated signatures according to annotation comment. Specify all or a 
portion of a comment to use as the filter criteria. This can be a character string or standard 
regular expression. Enter .* to filter all signatures. The default is Show all (.*).

Domain — Filter annotated signatures in this domain, as specified above. 

Evaluation — Filter annotated signatures in this Evaluation, as specified above. 

3. Click OK.

This applies your filter specifications and returns to the Guardian main window.

Sort Signatures
You can sort the list of signatures displayed in the Signature Explorer, Bundle Explorer, and 
Evaluation Summaries. 

There are two ways to sort signatures, depending on the context of the signature display:

Sort Menu — 

Sorting Dialog Box

The following sections describe each of these methods.
Oracle Guardian User Guide 2-69



Tasks
Sort Menu
1. In the Navigation Pane, click the Signature Explorer or Bundle Explorer tab to open one 

of these Explorers.

2. Click the Menu icon to open the Explorer menu.

3. Select Sort Signatures > to open the Sort submenu.

4. Select the category by which to sort.

Select one of the following:

– By Name

– By Severity

The signature lists are automatically reordered according to the selected category.

Sorting Dialog Box
You can use the Sorting dialog box to sort signatures in the Detected Signatures table of an 
Evaluation Summary.

To specify your sort criteria, do the following:

1. Right-click on a signature title in the table and select Sorting... from the context menu.

This opens the Sorting dialog box for specifying the sort order.

2. Specify the sort criteria.

There are four drop-down menus from which you can select a table field. The order in 
which you select the fields determines the hierarchy of the sort order. For each field, select 
one of the following:

– By Name

– By Severity

– Impact

– Product

– Topic
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3. Click a radio button next to each field selection to specify Ascending or Descending order 
for that field.

4. Click OK to apply your sort criteria to the Detected Signatures table for that Evaluation 
Summary.

Signature Annotations
This section provides instructions for the following tasks:

Annotate Signature

Edit Annotation

Delete Annotation

View Annotations

Filter Annotated Signatures

You can use the Annotations Wizard to create, edit, delete, and view signature annotations. 

You can access the Annotations Wizard from the Signatures List in any of the following 
contexts:

Evaluation Summary

Signature Explorer

Bundle Explorer

To open the wizard, right-click on a signature title and select Annotations > Manage 
Annotations from the context menu. 
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Annotate Signature
To create an annotation and add it to a signature, do the following:

1. Navigate to the Signatures List containing the signature you want to annotate.

The contents of a Signatures List may vary according to the context in which it occurs. 
Signatures Lists can be found in the following locations:

– Evaluation Summary

– Signature Explorer

– Bundle Explorer

2. Open the Annotations Wizard.

Right-click on the signature title and select Annotations > Manage Annotations from the 
context menu. 

3. Click Add. 

This displays the Add dialog box.

4. Select an Annotation Type.

Select one of the following:

– Ignore — Ignore this signature for the specified targets. 

– Flag — Flag this signature for the specified targets.

5. (Optional) Enter a Name and Comment for the annotations.

6. Select an Annotation Target.

Note: This field is available only if you invoked the wizard from an Evaluation Summary. 
For all other contexts, the default applies (All Domains).

Click the down-arrow next to the Apply to field to display a drop-down menu of 
Annotation Targets. Select one of the following:

– All Domains — Apply this annotation to this signature for all domains.

– This Domain — Apply this annotation to this signature for this domain, only. This 
option is available only if you are annotating a signature in an Evaluation Summary.

– This Evaluation — Apply this annotation to this signature in this evaluation, only. 
This option is available only if you are annotating a signature in an Evaluation 
Summary.
2-72 Oracle Guardian User Guide



Signature  Annotat i ons
7. Click Finish.

This adds the new annotation to the Annotations list for the selected signature.

8. Click OK. 

This returns to the Guardian main window. Note that a decoration has been added to the 
icon for the annotated signature.

Edit Annotation
To change an existing annotation, do the following:

1. Navigate to the Signatures List containing the signature with the annotation you want to 
modify.

Note: If the signature is not included in the Signatures List(s), you may need to temporarily 
set one or more filter attributes to Show. For instructions, see Filter Signatures.

2. Open the Annotations Wizard.

Right-click on the title of the annotated signature and select Annotations > Manage 
Annotations from the context menu.

3. Select the annotation to be modified and click Edit. 

Note: The Edit button will be greyed out (deactivated) until you select an annotation.

This displays the Edit dialog box for the selected annotation.

4. Enter your changes.

5. Click Finish.

This updates the Annotations list with your changes.

6. Click OK.

This updates the appropriate Signatures Lists and returns to the Guardian main window.

Note: If you modified any filter settings in step 1, you can reset the filters to their original 
settings now. For instructions, see Filter Signatures. 
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Delete Annotation
To delete an annotation, do the following:

1. Navigate to the Signatures List containing the signature with the annotation you want to 
delete.

Note: If the signature is not included in the Signatures List(s), you may need to temporarily 
set one or more filter attributes to Show. For instructions, see Filter Signatures. 

2. Open the Annotations Wizard.

Right-click on the title of an annotated signature and select Annotations > Manage 
Annotations from the context menu.

3. Select the annotation to be modified and click Delete. 

Note: The Delete button remains deactivated until you select an annotation.

This removes the annotation from the Annotations list for that signature.

4. Click OK. 

This updates the appropriate Signatures Lists and returns to the Guardian main window.

Note: If you modified any filter settings in step 1, you can reset the filters to their original 
settings now. For instructions, see Filter Signatures. 

View Annotations
You can view the annotations for a signature by selecting the signature and then opening the 
Annotations Wizard. The Annotations Wizard displays a table of all annotations for the 
selected signature.

You can access the Annotations Wizard from the Signatures List in any of the following 
contexts:

Evaluation Summary

Signature Explorer

Bundle Explorer

To open the wizard, right-click on a signature title and select Annotations > Manage 
Annotations from the context menu. 
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Filter Annotated Signatures
You can use Signature Filters to specify which signatures to display in the Signature Explorer, 
Bundle Explorer, and Evaluation Summaries. Some filters apply specifically to annotated 
signatures and their attributes.

This section provides instructions for applying filters to annotated signatures, only. For complete 
instructions on using Signature Filters, see Filter Signatures.

To apply Annotation Filters, do the following:

1. Open the Evaluation Summary to which you want to apply the filter. 

2. Open the Filter Configuration wizard.

In the Signatures List, right-click on a signature name and select Filters... from the context 
menu.

3. Specify your filter settings.

Click a radio button to specify Show or Hide for each filter. The Signature Filters that 
apply to annotations are as follows:

Type — Filter annotated signatures according to Annotation Type. Click a checkbox to 
select/deselect a type. There are two Annotation Types: Flag and Ignore. The default is 
Hide signatures with an Annotation Type of Ignore. 

Annotation Name — Filter annotated signatures according to Annotation Name. Specify 
all or a portion of an Annotation Name to use as the filter criteria. This can be a character 
string or a standard regular expression. Enter .* to filter all annotated signatures. The 
default is Show all (.*).

Comment — Filter annotated signatures according to annotation comment. Specify all or a 
portion of a comment to use as the filter criteria. This can be a character string or standard 
regular expression. Enter .* to filter all signatures. The default is Show all (.*).

4. Click OK.

This applies your filter specifications and returns to the Guardian main window.
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Bundles
This section provides instructions for the following tasks:

Explore Bundles

View Bundle Overview

Evaluate Bundles

Explore Bundles
You can use the Bundle Explorer to view the available Signature Bundles and their contents. For 
a detailed description of the Bundle Explorer, see Bundle Explorer in Chapter 3, “Reference.”

View Bundle Overview
To display an overview of the contents of a Bundle, do the following:

1. In the Navigation Pane, click the Bundle Explorer tab to open the Bundle Explorer.

2. In the Bundle Explorer, double-click on a bundle name.

This displays the selected Bundle Overview in the Document Pane.

Evaluate Bundles
Use the Bundle Evaluation Wizard to preselect a domain and Bundle for Evaluation, and then 
initiate the evaluation.

Note: The evaluation of some signatures may hang the evaluation. To prevent this, open the 
Preferences page, and set the Guardian > Signature Evaluation Threshold parameter 
(in miliseconds). Then select the Enable Safe Evaluation checkbox. If enabled, the 
evaluation of a signature is terminated when this threshold is reached, and the Signature 
ID is written to the Hung Signature List. In addition, if a signature evaluation fails due to 
a runtime error, that Signature ID is written to the Problem Signature List. Guardian will 
not attempt to evaluate signatures in the Problem Signature List. For general instructions 
on setting Preferences, see Preferences.

WARNING: If a server is down when the evaluation is conducted, this can prevent some 
signatures from being detected. 
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To open the Bundle Evaluation Wizard, do the following:

1. In the Domain Explorer, open the Evaluation History folder.

2. Right-click on an Evaluation Summary and select Evaluate Bundle from the context menu.

This opens a submenu containing a list of Bundles available for evaluation.

3. Select a Bundle from the submenu to open the Bundle Evaluation Wizard for that Bundle. 

The Bundle Evaluation Wizard opens with the selected domain and Bundle preselected, 
just as if you had invoked a Shortcut. 

4. Enter the credentials for the WebLogic Server for the selected domain.

In the Domain Credentials section, enter the following:

– Username: This is the username for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password: This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain.

If you selected multiple domains, you must supply the login credentials for each domain 
before you can launch the Evaluation. 

5. (Optional) Select the Remember username/password checkbox to save your login 
credentials for the selected domain(s).

Select this option if you want your login information to persist so that you do not have to 
enter it each time you evaluate this domain. This is especially useful if you routinely 
evaluate multiple domains concurrently. Usernames and passwords are encrypted when 
stored.

6. Click Finish.

This initiates the evaluation and displays an Evaluation Summary of the results in the 
Document Pane. In the Domain Explorer, the new Domain Inventory is added to the 
Inventory History folder, and the new Evaluation Summary is added to the Evaluation 
History folder. 
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Shortcuts
This section provides instructions for the following tasks:

Create Shortcut

Evaluate Shortcut

Delete Shortcut

A Shortcut enables you to streamline the evaluation procedure by predefining and storing the 
domain, Signature Bundle, and other parameters for evaluations that you perform frequently. You 
can then evaluate the Shortcut, saving you the effort of re-entering the values each time you want 
to run the evaluation. 

Create Shortcut
A Shortcut enables you to predefine the evaluation parameters for evaluations you perform 
frequently, saving you the effort of re-entering the values each time you run the evaluation.

There are two ways to create a Shortcut:

Create Shortcut with Shortcut Wizard — Use this method if you want to quickly create a 
Shortcut without evaluating the selected domain.

Create Shortcut with Evaluation Wizard — Use this method if you want to create a 
Shortcut when evaluating a domain. The parameters you set for the evaluation are then 
used to create the Shortcut. This method also enables you to enter and save the 
Administrator login credentials so that you do not have to enter them each time you 
evaluate the Shortcut. 

The following sections describe each of these procedures.

Create Shortcut with Shortcut Wizard
Use the Shortcut Wizard if you want to quickly create a Shortcut without evaluating the selected 
domain. However, you will not be able to enter and save the login credentials for the WebLogic 
Server Administrator or Monitor account. Consequently, you will need to enter these each time 
you evaluate the Shortcut. For instructions on storing the login credentials when creating a 
Shortcut, see Create Shortcut with Evaluation Wizard.
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To use the Shortcut Wizard to create a Shortcut, do the following:

1. Open the Shortcut Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+S. 

– Select File > New > Shortcut.

– Select Window > Show View > Shortcuts Table to open the Shortcuts Table. Then, 
click Add Shortcut in the Shortcuts Table toolbar. 

– Right-click in the Domain Explorer or Shortcut Explorer and select Add Shortcut 
from the context menu. 

2. Select the domain to associate with the Shortcut. 

3. Select the Signature Bundle to associate with the Shortcut.

Select a Signature Bundle from the Bundle field drop-down menu. This is the Bundle that 
will be evaluated against the specified domain when you evaluate the Shortcut. The default 
is Default Signatures. 

4. Select the Create Shortcut checkbox and enter a brief name for the Shortcut.

5. Click Finish.

This adds the new Shortcut to the Shortcuts Table and the Shortcut Explorer tree. For 
instructions on evaluating a Shortcut, see Evaluate Shortcut.

Create Shortcut with Evaluation Wizard
You can create a Shortcut by selecting the Save as Shortcut option when using the Evaluation 
Wizard to evaluate a domain. This method of creating a Shortcut enables you to enter and store 
the Administrator login credentials so that you need not enter them each time you evaluate the 
Shortcut.

To use the Evaluation Wizard to create a Shortcut, do the following:

1. Open the Evaluation Wizard.

You can use any of the following methods to open the wizard:

– Press Ctrl+Shift+E. 

– Select File > New > Evaluation.

– Right-click in the Domain Explorer and select Evaluate from the context menu. 
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2. Select the domain to associate with the Shortcut. 

3. In the Bundle field, select the Signatures Bundle to associate with the Shortcut.

Select a Signature Bundle from the Bundle field drop-down menu. This is the bundle that 
will be evaluated against the specified domain when you evaluate the Shortcut. The default 
is Default Signatures. 

4. Enter the Username and Password for the WebLogic Server Administrator or Monitor 
account on the target domain. 

5. (Optional) Select the Remember username/password checkbox to store your login 
credentials for the selected domain(s).

Select this option if you want your login information to persist so that you do not have to 
enter it each time you evaluate this Shortcut. This is especially useful if you will be 
evaluating the Shortcut on a frequent basis. Usernames and passwords are encrypted when 
stored.

6. Select the Create Shortcut checkbox and enter a brief name for the Shortcut.

7. Click Finish.

This adds the new Shortcut to the Shortcuts Table and the Shortcut Explorer tree. For 
instructions on evaluating a Shortcut, see Evaluate Shortcut.

Evaluate Shortcut
A Shortcut enables you to predefine the evaluation parameters for evaluations you perform 
frequently, saving you the effort of re-entering the values each time you run the evaluation. To 
evaluate a Shortcut, use the Shortcut Evaluation Wizard.

To evaluate a Shortcut, do the following:

1. Open the Shortcut Evaluation Wizard.

You can do this using any of the following methods:

– Select Window > Show View > Shortcuts Table to open the Shortcuts Table. Then, 
double-click on a Shortcut name in the Shortcut Table. 

– Click the Shortcut Explorer tab to open the Shortcut Explorer. Then, double-click on 
a Shortcut name in the Shortcut list.

– Click the Shortcut Explorer tab to open the Shortcut Explorer. Then, right-click on a 
Shortcut name in the Shortcut list and select Evaluate Shortcut from the context 
menu. 
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The Shortcut Evaluation Wizard opens with the predefined values for the selected 
Shortcut displayed in the domain table. You can change the Bundle selection. 

2. If necessary, enter the Username and Password for the WebLogic Server Administrator or 
Monitor account for the target domain.

If you selected the Remember username/password option when you activated the domain 
or defined the Shortcut, the Username and Password fields are pre-filled. Otherwise, you 
must enter this information before launching the evaluation.

3. Click Finish.

This launches the evaluation, and returns you to the Guardian main window when the 
evaluation completes. As with a standard evaluation, the Domain Explorer History 
folders are updated to include an entry for the resulting Domain Inventory and Evaluation 
Summary. The results of the evaluation are displayed in an Evaluation Summary 
Overview in the Document Pane.

Delete Shortcut
You can use either of the following methods to delete a Shortcut:

Select Window > Show View > Shortcuts Table to open the Shortcuts Table. Then, 
select a Shortcut from the Shortcut list and click Delete. 

Click the Shortcut Explorer tab to open the Shortcut Explorer. Then, right-click on a 
Shortcut in the Shortcut list and select Delete Shortcut from the context menu. 
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Command Line Interface
This section provides instructions for the following tasks:

Start Guardian Headless Mode

Redirecting Guardian CLI Command Output

Run Scripts

Viewing CLI Script Results

Schedule Scripts

Receive Notifications

The Guardian Command Line Interface (CLI)—also referred to as Guardian Headless Mode—is 
a set of Guardian commands that you can issue directly from the operating system command 
prompt. There is a Guardian CLI command for each of the most common tasks you can perform 
using the Guardian User Interface. For a complete description of these commands and their 
syntax, see Command Line Interface in Chapter 3, “Reference.”For instructions on starting the 
Command Line Interface, see the next section, Start Guardian Headless Mode.

Start Guardian Headless Mode
To start the Guardian Command Line Interface, do the following:

Note: Guardian Command Line Interface commands are case sensitive.

1. At the operating system command prompt, change directories to the Guardian installation 
directory.
cd <root>\guardian\

Where:

<root> is the parent directory for the Guardian installation directory. 

2. Enter the Guardian Headless command.

– On Windows:
guardianHeadless.cmd

– On Linux:
guardianHeadless.sh
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3. (Optional) To see a list of CLI commands and their syntax, enter the CLI Help command at 
the operating system prompt.

– On Windows:
guardianHeadless.cmd -ghelp

– On Linux:
guardianHeadless.sh -ghelp

Note: Each command must include the prefix -g with no trailing space, as shown in the 
following example:

guardianHeadless.cmd -glistActiveDomains 

The output file is created in your current directory, and is overwritten each time you run a 
Guardian Headless Mode command. For instructions on redirecting this to a different file, 
see Redirecting Guardian CLI Command Output.

For a complete description of Guardian Command Line Interface commands, their use, and 
syntax, see Command Line Interface in Chapter 3, “Reference.”

Redirecting Guardian CLI Command Output
Below are instructions for redirecting Guardian Headless Mode command output on Windows 
and Linux platforms, respectively.

On Windows:
On Windows, the command output is written to the following output file:

headless_output.txt

The output file is created in your current directory, and is overwritten each time you run a 
Guardian Headless Mode command. 

On Windows, you can change the name of this file by editing the following line in the 
guardianHeadless.cmd script:
guardian.exe -noSplash -application 
com.bea.support.guardian.ui.headless.Headless %command% %arg1% %val1% 
%arg2% %val2% %arg3% %val3% %arg4% %val4% %arg5% %val5% %arg6% %val6% %arg7% 
%val7% > headless_output.txt  2>&1

Replace the string headless_output.txt at the end of this line with the new filename. 
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For example: 
guardian.exe -noSplash -application 
com.bea.support.guardian.ui.headless.Headless %command% %arg1% %val1% 
%arg2% %val2% %arg3% %val3% %arg4% %val4% %arg5% %val5% %arg6% %val6% %arg7% 
%val7% > MyOutputFile.txt 2>&1

On Linux:
On Linux, by default Guardian CLI command output is directed to stdout and stderr, and can 
be redirected in the usual manner by using the “pipe” (|) operator. Please refer to your Linux 
operating system documentation for instructions.

Run Scripts
You can create a Guardian Command Line script containing a series of Guardian Command Line 
Interface commands. You can schedule scripts to run at specified times and intervals by using 
utilities such as the Windows Task Scheduler or the Linux crontab command.

For a complete description of Guardian Command Line Interface commands, their use, and 
syntax, see Command Line Interface in Chapter 3, “Reference.”

To run a script, enter the following command at the operating system prompt:

On Windows:
guardianHeadless.cmd -gscript -f <script_name>

On Linux:
guardianHeadless.sh -gscript -f <script_name>

Where:

<script_name> is the path and name of your CLI script. 
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Viewing CLI Script Results
On Windows, the output for CLI commands is written to the following output file:

headless_output.txt

The output file is created in your current directory, and is overwritten each time you run a 
Guardian Headless Mode command. For instructions on redirecting command output, see 
Redirecting Guardian CLI Command Output.

For inventory and evaluation operations, the resulting Domain Inventory or Evaluation Summary 
document is saved in the appropriate History folder in your Guardian Workspace, and an entry 
is added to the appropriate History folder in the Domain Explorer tree. These can be viewed 
using the Domain Explorer, just as you would view any other Domain Inventory or Evaluation 
Summary document.

To view a Domain Inventory or Evaluation Summary document, do the following:

1. Open the Guardian User Interface and click the Domain Explorer tab to open the Domain 
Explorer.

2. Open the History folder containing the document you want to view.

3. Select the document to view the contents in the Document Pane.

For a complete description of the Domain Explorer, see Domain Explorer in Chapter 3, 
“Reference.”

Schedule Scripts
To schedule a script to run automatically at a specified time, you can use utilities such as the 
Windows Task Scheduler or the Linux crontab command. For instructions on scheduling 
scripts, see your operating system documentation.
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Receive Notifications
To receive notification of detected signatures, create an evaluation script and use the Windows 
Task Scheduler or the Linux crontab command to schedule the script to run at regular intervals. 
Each time the script runs, the signature.log file in the Guardian installation directory is 
updated with an entry for each detected signature. You can the configure a third party 
management tool to scan the log for detected signatures, and notify you when one is found.

Each signature.log entry starts with four number signs (####) and includes a timestamp for 
the entry. Each entry with a detected signature contains the label <detected> and is followed by 
a brief description which is also surrounded by angle brackets. The description includes the 
domain name. 

The following is a sample signature.log file:
####<Tue Aug 01 16:03:47 EDT 2006> <0> <g-dev_slp7_7001> <un> <0> <000022> 
<not detected> <Signature 000022 (Rotational Upgrade may cause 
java.io.StreamCorruptedException) not detected by username un evaluating 
bundle ID 0 in domain ID g-dev_slp7_7001.>  
####<Tue Aug 01 16:03:47 EDT 2006> <0> <g-dev_slp7_7001> <un> <0> <000027> 
<detected> <Signature 000027 (Native IO should be enabled in production mode 
for better performance) detected by username un evaluating bundle ID 0 in 
domain ID g-dev_slp7_7001.>  
####<Tue Aug 01 16:03:47 EDT 2006> <0> <g-dev_slp7_7001> <un> <0> <000055> 
<not detected> <Signature 000055 (JDK 1.5 is not certified for WebLogic 8.1) 
not detected by username un evaluating bundle ID 0 in domain ID 
g-dev_slp7_7001.> 
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Troubleshooting
This section provides instructions for the following tasks:

View Logfiles

Crash Recovery

Resolve Exceptions

View Logfiles
The Oracle Guardian log files contain information that Oracle Customer Support can use to 
diagnose and resolve issues with your system. 

The Guardian log files are as follows:

guardian.log —This is located in the Guardian installation directory you specified 
during installation. This file contains information about every operation the Guardian 
application performs. 

signature.log — This is located in the Guardian installation directory you specified 
during installation. This file contains information about each evaluation performed, 
including entries for all detected signatures. You can also use a command line script to 
automatically scan the signature.log for detected signatures, and automatically notify 
you when new signatures are detected.

.log — This is located in the .metadata subdirectory of the Guardian Workspace 
directory you specified when starting Guardian. This file contains information about 
certain Guardian operations. 

install.log — This is located in the ../configuration/org.eclipse.update 
subdirectory of the Guardian installation directory you specified during installation. This 
contains Guardian installation details. 

Crash Recovery
Guardian crashes are extremely unlikely, since Guardian uses the Eclipse Rich Client Platform. 
If Guardian does crash, simply restart Guardian. No additional cleanup operations are required.
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Resolve Exceptions
In the unlikely event of an exception, the recommended steps for resolving the issue are as 
follows:

1. Read the text of the error message to determine what is wrong.

2. Save the Exception Error window text with a screen capture, or cut and paste the text into a 
file.

3. Try the operation again to see if the issue recurs.

4. Copy the Oracle Guardian log files to another location and save them for future reference 

5. Contact Oracle Support for assistance 

Tip: To save log files, copy them to another location so that the error is among the last entries 
in the log file, making it easier to identify. For the location of Guardian log files, see View 
Logfiles.

Support
This section provides instructions for the following task:

Creating a Service Request Archive

Creating a Service Request Archive
You can use the Service Request Wizard to create a service request archive based on a detected 
signature, and save the service request information as an archive file that you can send to Oracle 
Customer Support. Service request archives are stored as files with a .car file name extension.

The wizard automatically creates the service request with all of the signature-specific information 
required for an Oracle support engineer to begin working on your service request upon receipt of 
the archive. You can also add any additional attachments and notes before sending the service 
request archive to Oracle.

To create service request, do the following:

1. Open the Evaluation Summary containing the signature you want to include in the service 
request.
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a. Click the Domain Explorer tab to open the Domain Explorer. 

b. Open the Evaluation History folder for the domain in which the signature was detected.

c. Double-click on the entry for the Evaluation Summary containing the detected signature 
you want to report. This opens the Evaluation Summary View in the Document Pane.

2. Select the signature you want to include in the service request.

Click on a signature entry to highlight it. This displays the Description and Remedy for 
the signature in the bottom portion of the Evaluation Summary display in the Document 
Pane.

3. Open the Service Request Wizard. 

Click the Get more help from Oracle support link at the bottom of the signature 
Remedy section to open the wizard. This automatically includes the signature contents in 
the new service request, and displays the first page of the Service Request Wizard, which 
is the Service Request Notes page.

4. (Optional) Enter any additional service request notes.

In the Additional Service Request Notes field, enter any additional text that may be 
helpful to Oracle Customer Support in resolving your service request. 

5. Click Next to proceed to the Select Service Request Attachments page.

6. Select the background information files to include with the service request. You can select 
one or more of the following:

– Service Request Attachments:

• Domain Inventory

• Detected Signature Results

– Recommended Attachments:

• Server Log

– Other Attachments:

• Click the + icon to open a file browser from which you can select files to include. 

• Click the X icon to remove a file from the list.

7. Click Next to proceed to the Domain Login page.

8. Enter the credentials for the WebLogic Server for the selected domain.
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In the Domain Credentials section, enter the following:

– Username: This is the username for the WebLogic Server Administrator or Monitor 
account on the target domain. 

– Password: This is the password for the WebLogic Server Administrator or Monitor 
account on the target domain.

If you selected multiple domains, you must supply the login credentials for each domain 
before you can launch the Evaluation. 

9. (Optional) Select the Remember username/password checkbox to save your login 
credentials for the selected domain(s).

Select this option if you want your login information to persist so that you do not have to 
enter it each time you submit a service request. 

10. Click Next to proceed to the Select Service Request Archive Destination page.

11. In the Select Archive Location field, save the service request as an archive for uploading 
later. Enter the location to which to save the file, or click the ellipsis (...) to open a file browser 
from which you can select the location. 

12. Click Finish to create the service request archive. 

A Service Request Creation Complete dialog box displays the date, time, and location of 
the file.

13. Click OK.

This closes the wizard and returns to the Guardian main window.

Updates and Upgrades
This section provides instructions for the following tasks:

Automatically Update Guardian

Manually Update Guardian

Check Product Configuration

Note: If you are using a proxy server for outbound Guardian communications, make sure that 
you have enabled and tested the outbound proxy connection. For instructions, see Enable 
and Test Outbound Proxy.
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Automatically Update Guardian
To update Guardian, use the Update Wizard to download new Oracle Guardian software and 
signatures from the Oracle Guardian update site, http://guardian.bea.com/update.

To update Guardian, do the following:

1. Open the Update Wizard.

Use one of the following methods to open the wizard:

– Press Ctrl+Shift+U. 

– Click the Update button on the Main toolbar. 

– Select Help > Software Updates > Guardian Updates. 

2. Enter your My Oracle Support Username and Password to access your Customer Support 
Identifiers.

3. (Optional) Select the Remember Username/Password checkbox to store your login 
credentials for future use.

Select this option if you want your login information to persist so that you do not have to 
enter it each time you create a service request.

4. Click Next to proceed to the Select CSI (Customer Support Identifiers) page.

5. Select your CSI from the menu and click Finish to search for updates.

6. On the Search Results page, expand the folders in the Select the features to install tree to 
see the available selections.

To select features, do the following:

a. (Optional) To filter the results, you can select from the following filter options:

• Show the latest version of a feature only to display only the current version of 
each feature in the results.

• Select Filter patches included in other patches on the list to filter out duplicate 
patch entries.

b. (Optional) Click More Info to see details about a selection.

c. (Optional) Click Properties to display the properties for a selection.

d. (Optional) Click Select Required to automatically select all required updates.
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e. Click the checkbox beside a feature name to select/deselect it.

7. Click Next to proceed to the Feature License page.

Accept the terms in the license agreement to proceed with the installation.

8. Click Next to proceed to the Installation page.

9. Select the installation location, or accept the default.

Click Change Location to open a directory browser from which you can select the 
location. Click OK to enter your selection and close the browser. Click Next to proceed.

10. Verify the list of features to install, and click Install or Install All.

After the updates are installed, you are prompted as to whether to restart Guardian.

11. Click Yes to restart Guardian and incorporate the new features. 
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Manually Update Guardian
To update Guardian on servers that do not have Internet access, or to upgrade from Guardian 1.0.x 
to Guardian 1.1.0, you can perform a manual update. To do so, first automatically update 
Guardian on a server that has Internet access, and then copy the updated files to the server(s) 
without access.

Note: To upgrade from Guardian 1.0.x to Guardian 1.1.0, you must perform a manual update. 
You cannot use the Update Wizard to upgrade in this case. However, to upgrade from 
Guardian 1.1.x to Guardian 10g R3 (10.3.1), you can still use the Update Wizard.

WARNING: If you are upgrading from Guardian 1.0.x to Guardian 1.1.0 and want to preserve 
your Guardian Registry, you must first back up and then manually update the 
Guardian Registry. For instructions, see Manually Update Guardian Registry. 
Please also refer to the Guardian 1.1 Installation Guide and Guardian 1.1 Release 
Notes for additional important information.

To manually update Guardian, do the following;

1. Automatically update Guardian on a server that has Internet access.

For instructions, see Automatically Update Guardian.

2. Shut down Guardian on the offline server(s).

Select File > Exit from the titlebar menu.

3. Update the Guardian Signatures Repository on the secure (offline) machine.

Copy the following directory and all of its contents from the updated server to the offline 
server(s) you want to update, overwriting the old contents:
<..>\guardian\repository\archives

Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.

Note: If you only want to update the Guardian Signatures Repository but not the Guardian 
application itself, you can skip the remainder of these steps.

4. (Optional) Remove the old Signature Features directories from the offline server(s).

The Signature Features directories are kept in the following directory:
<..>\guardian\features\
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Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.

The Signature Features directories are named according to the following convention:
com.bea.guardian.feature.signature.weblogic_<old_version>

Where:

<old_version> is the old signature release version. 

For example:
..\guardian\features\com.bea.guardian.feature.signature.weblogic_1.0.42

5. Copy the updated Signatures Features directory to the offline server(s).

Copy the following directory and all of its contents from the updated machine to the offline 
server(s):
..\guardian\features\com.bea.guardian.feature.signature.weblogic_<CurVersion>

Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.

<CurVersion> is the most current signature release version. 

6. (Optional) Remove the old Signature Plug-ins JAR files from the offline server(s).

The Signature Plug-ins JAR files reside in the following directory:
<..>\guardian\plugins\

Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.

The files are named according to the following convention:
com.bea.guardian.signature.weblogic_<old_version>

Where:

<old_version> is the old signature release version. 
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7. Copy the updated Signatures Plug-ins file to the offline server(s).

Copy the following file from the updated machine to the offline server(s):
..\guardian\plugins\com.bea.guardian.signature.weblogic_<CurVersion>

Where:

<..> is the parent directory of the Guardian installation root directory. The Guardian 
installation root directory is named guardian.

<CurVersion> is the most current signature release version. 

8. Restart Guardian on the newly-updated offline servers.

9. Check the new configuration.

Do the following:

a. Select Help > Manage Guardian to open the Product Configuration page.

b. In the Product Configuration tree (left pane), expand the Oracle Guardian folder and 
subfolders.

c. Check the version numbers for each item.

Manually Update Guardian Registry
If you are upgrading from Guardian 1.0.x to Guardian 1.1, you must manually update the 
Guardian Registry. For instructions, please see the Guardian 1.1 Installation Guide and the 
Guardian 1.1 Release Notes.

Check Product Configuration
You can use the Product Configuration page to check the current configuration for a Guardian 
installation. This is especially useful if you have manually updated Guardian and want to check 
that the update was completed correctly.

To check the current Guardian configuration, do the following:

1. Select Help > Manage Guardian to open the Product Configuration page.

2. In the Product Configuration tree (left pane), expand the Guardian folder and subfolders.

3. Check the version numbers for each item.
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C H A P T E R 3
Reference
This chapter provides a detailed description of the Guardian User Interface components and 
features, and a detailed reference guide to the Guardian Command Line Interface. Topics include 
the following:

Main Menu Bar

Main Toolbar

Navigation Pane

Document Pane

Preferences

Wizards

Log Files

Command Line Interface
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Main Menu Bar
The Main Menu Bar is at the top of the Oracle Guardian main window just below the Oracle 
Guardian titlebar. The Menu Bar contains the following menus:

File Menu

Edit Menu

Tools Menu

Window Menu

Help Menu

The Menu Bar menus in turn contain a series of options and submenus, some of which also lead 
to additional menus, dialog boxes, or wizards. The following sections provide a description of 
each of these menus, and instructions for invoking them.

Keyboard Shortcuts
You can invoke many menus, submenus, and menu options by using a keyboard shortcut. To 
display Menu Bar menus, press the Alt key and type the menu selection key for the menu you 
want to display. The menu selection key is the letter underlined in the menu name in the Menu 
Bar when you press the Alt key.

Some menu options also have keyboard shortcuts, which consist of a specific sequence of 
characters pressed simultaneously. If a menu item has a keyboard shortcut, the key sequence is 
listed next to the item in the menu. To see the complete list of keyboard shortcuts, press 
Ctrl+Shift+L.
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File Menu
Table 3-1 describes the File menu options and submenus.

Table 3-1  File Menu

Menu Item Description

New > This option opens a submenu with the following options:
• Domain Group — Open the Add Domain Group dialog box for 

creating a new Domain Group.
• Domain — Open the Domain Activation Wizard.
• Inventory — Open the Inventory Wizard.
• Evaluation — Open the Evaluation Wizard.
• Shortcut — Open the Shortcut Wizard.

Open File... (Disabled.) This is an Eclipse Platform menu option that does not apply 
to this application.

Open Open the selected item. Select an item in the Navigation Pane, and then 
select File > Open to display the contents for that item in the Document 
Pane.

Close Close the current display in the Document Pane.

Close All Close all Document Pane displays.

Save As... Export the selected Domain Inventory or Evaluation as a file (PDF or 
HTML).

Print Print the contents of the Report tab or Source tab currently displayed in 
the Document Pane.

Import Open the Import dialog box for importing Guardian Preferences, 
Workspace, or Report Plug-in.

Export Open the Export dialog box for exporting Guardian Preferences, 
Workspace, or Report Plug-in.

Exit Exit Guardian.
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Table 3-2 describes the Edit menu options.

Table 3-2  Edit Menu

Menu Item Description

Cut (Disabled.) This is an Eclipse Platform menu option that does not apply 
to this application. Use Ctrl+X for cut operations, where applicable.

Paste (Disabled.) This is an Eclipse Platform menu option that does not apply 
to this application. Use Ctrl+V for paste operations, where applicable.

Tools Menu
Table 3-3 describes the Tools menu options and submenus.

Table 3-3  Tools Menu

Menu Item Description

Purge Inactive Domains Remove deactivated domains from the Domain Explorer and the 
Guardian Registry. This also removes from the Guardian Workspace any 
Domain Inventories, Evaluation Summaries, and Service Request 
Archives for those domains.

Modify Domain Modify the selected domain. Opens the Domain Properties dialog box, 
where you can reconfigure the properties for the selected domain.

Deactivate This opens the Domain Deactivation Wizard for the selected domain.

View Log > This opens a submenu with the following options:
• Signature Log — Display the Guardian Signature log file.
• Guardian Log — Display the Guardian log file.
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Window Menu
Table 3-4 describes the Window menu options and submenus.

Table 3-4  Window Menu

Menu Item Description

Show View > This opens a submenu containing the following options:
• Domain Explorer — Opens the Domain Explorer in the Navigation 

Pane.
• Bundle Explorer — Opens the Bundle Explorer in the Navigation 

Pane.
• Shortcut Explorer — Opens the Shortcut Explorer in the 

Navigation Pane.
• Signature Explorer — Opens the Signature Explorer in the 

Navigation Pane.
• Active Domains Table — Opens the Active Domains Table in the 

Document Pane.
• Shortcuts Table — Opens the Shortcuts Table in the Document 

Pane.
• Progress View — Opens the Progress View below the Navigation 

Pane.
• Outline View — Opens the Outline View to the right of the 

Document Pane.

Working Sets > (Disabled.) This is an Eclipse Platform menu option that does not apply 
to this application.

Reset Perspective Reset the Guardian displays to their default settings.

Preferences... This opens the Preferences page.
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Help Menu
Table 3-5 describes the Help menu options and submenus.

Table 3-5  Help Menu

Menu Item Description

Help Contents This opens the Oracle Guardian Online Help System.

Search This opens the Online Help Search utility.

Dynamic Help This opens the Guardian Dynamic Online Help pane (to the right of the 
Document Pane).

Cheat Sheet... This opens the Cheat Sheet Selection dialog box for selecting and 
displaying a Guardian Cheat Sheet (to the right of the Document Pane). 
The Cheat Sheet provides step-by-step instructions for basic Guardian 
tasks. Action buttons are provided for some tasks; click a button to 
initiate that task.

Manage Guardian > This opens a submenu with the following options:
• Update Guardian — Open the Update Wizard.
• Manage Configuration — Open the Product Configuration 

Manager for performing the following tasks:

Key Assist... Display the list of keyboard shortcuts.

About Oracle Guardian Open the About Oracle Guardian dialog box. This displays the version 
of your current Guardian installation, and details about Guardian 
features, plug-ins, and configuration. 

– Scan for Updates
– View Installation History
– Show Activities
– Add an Extension Location
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Main Toolbar
The Main Toolbar is located below the Main Menu Bar, and contains action buttons for the most 
common Guardian tasks. You can roll your mouse pointer over a button to display the tool tip text 
for that button.

Table 3-6 describes the Main Toolbar buttons.

Table 3-6  Guardian Main Toolbar Buttons

Button Description

Open Display the selected resource in the Document Pane.
• Opens the Active Domain Table when Target Domains is selected 

in the Domain Explorer.
• Opens the Domain Inventory view when a Domain Inventory is 

selected in the Domain Explorer.
• Opens the Evaluation Summary view when an Evaluation 

Summary is selected in the Domain Explorer. 
• Opens the Signature view when a signature is selected in the 

Signature Explorer or Bundle Explorer. 
• Opens the Signature Bundle view when a Bundle is selected in the 

Bundle Explorer. 
• Opens the Evaluation Wizard when a Shortcut is selected in the 

Shortcut Explorer. 

Print Print the contents of the Report tab or Source tab currently displayed in 
the Document Pane.

Activate Open the Domain Activation Wizard. 

Inventory Open the Inventory Wizard.

Evaluate Open the Evaluation Wizard.

Update Open the Update Wizard.
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Context Menus
Many views and displays contain context menus. Right-click on an item or anywhere in a display 
to open the associated context menu. 

Related Tasks
Basic Tasks

Domains

Command Line Interface

Automatically Update Guardian

Related Reference
Keyboard Shortcuts

Explorer Context Menus

Document View Context Menus

Main Menu Bar

Main Toolbar

Navigation Pane

Document Pane
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Navigation Pane
The Navigation Pane resides in the left side of the Oracle Guardian main window. The Navigation 
Pane contains several tabs leading to Explorer Views. You can have multiple Views open at once, 
but only one can be displayed at a time. Click on a tab to display that Explorer View. 

The following section provides an overview of Navigation Pane elements.

Navigation Pane Elements
Navigation Pane elements include the following:

Explorer Views

Explorer Toolbar Icons

Explorer Toolbar Menus

Explorer Context Menus

The following sections describe each of these elements.

Explorer Views
At the top of the Navigation Pane are the Explorer View tabs. Select a tab to display that View. 
Table 3-7 provides an overview of the Navigation Pane Explorer Views.

Table 3-7  Navigation Pane Explorer Tabs

Explorer Tab Description

Domain Explorer Open the Domain Explorer. This View enables you to browse, manage, 
and monitor the domains you have defined in Guardian. Right-click in the 
Domain Explorer to open a context menu of domain operations. For a 
complete description, see Domain Explorer. For instructions on Domain 
Explorer tasks, see Domains in Chapter 2, “Tasks.”

Signature Explorer Open the Signature Explorer. This View enables you to browse the 
available signatures and view the contents of a selected signature. For a 
complete description, see Signature Explorer. For instructions on 
Signature Explorer tasks, see Signatures in Chapter 2, “Tasks.”
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Bundle Explorer Open the Bundle Explorer. This View enables you to browse the 
available Signature Bundles and their contents. For a complete 
description, see Bundle Explorer. For instructions on Bundle Explorer 
tasks, see Bundles in Chapter 2, “Tasks.”

Shortcut Exporer Open the Shortcut Explorer. This View enables you to view and manage 
your Evaluation Shortcuts. For a complete description, see Shortcut 
Explorer. For instructions on Shortcut Explorer tasks, see Shortcuts in 
Chapter 2, “Tasks.”

Table 3-7  Navigation Pane Explorer Tabs

Explorer Tab Description
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Explorer Toolbar Icons
Below each Explorer tab titlebar is the Explorer toolbar. An Explorer toolbar may contain all or 
some of the following active icons:

Table 3-8  Explorer Toolbar Icons

Icon Function

Close

Minimize

Maximize

Restore. This icon is available only if 
the View has been maximized.

Expand all items.

Collapse all items.

Open Explorer menu.

Link with Editor. This links the 
Navigator Pane Tree to the Document 
Pane View. The current active 
Document View name is then also 
selected (highlighted) in the 
Navigator Pane.
Oracle Guardian User Guide 3-107



Refe rence
Explorer Toolbar Menus
The Domain Explorer, Signature Explorer, and Bundle Explorer each contain a menu icon in 
the right corner of the toolbar. Click the menu icon to open a menu of display options for that 
Explorer. 

Table 3-9 describes the Explorer menus.

Table 3-9  Explorer Menus

Explorer Menu Options

Domain Explorer The Domain Explorer menu contains the following options:
• Filter Domain Explorer — Open the Filter Domain Explorer 

dialog box to filter inventories and evaluations by date created. 
• Link with Editor — Link the Navigator Pane Tree to the Document 

Pane View. If you have multiple Document Views open in the 
Document Pane, the Explorer Tree tracks which Document View is 
currently active (displayed). The current active Document View 
name is then also selected (highlighted) in the Explorer Tree.

Signature Explorer The Signature Explorer menu contains the following options:
• Sort Signatures > — This opens a submenu of the following options 

for sorting signatures in the Signature Explorer:
– By Name
– By Severity

• Filters... — Open the Filters Wizard, for specifying which 
signatures to include in signature displays. For instructions, see 
Filter Signatures in Chapter 2, “Tasks.”

• Link with Editor — Link the Navigator Pane Tree to the Document 
Pane View. If you have multiple Document Views open in the 
Document Pane, the Explorer Tree tracks which Document View is 
currently active (displayed). The current active Document View 
name is then also selected (highlighted) in the Explorer Tree.
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Explorer Context Menus
Right-click in an Explorer View to display the context menu of tasks and operations you can 
perform from that View. You can also right-click on a specific item to select it and open the 
context menu for that item. Menu options that do not apply to your selection are deactivated. 

For a detailed description of a specific context menu, see the appropriate section listed below:

Domain Explorer Context Menu

Signature Explorer Context Menu

Bundle Explorer Context Menu

Shortcut Explorer Context Menu

Domain Explorer
The Domain Explorer is a Navigator View that enables you to browse, manage, and monitor the 
domains you have activated in Guardian. In the Navigation Pane, select the Domain Explorer 
tab to display the explorer.

The following table provides an overview of Domain Explorer elements:

Bundle Explorer The Bundle Explorer menu contains the following options:
• Filters... — Open the Filters Wizard, for specifying which 

signatures to include in signature displays. For instructions, see 
Filter Signatures in Chapter 2, “Tasks.”

• Sort Signatures > — This opens a submenu of the following options 
for sorting Bundles and signatures in the Bundle Explorer:
– By Bundle Name, Signature Name
– By Bundle Name, Severity

• Link with Editor — Link the Navigator Pane Tree to the Document 
Pane View. If you have multiple Document Views open in the 
Document Pane, the Explorer Tree tracks which Document View is 
currently active (displayed). The current active Document View 
name is then also selected (highlighted) in the Explorer Tree.

Table 3-9  Explorer Menus

Explorer Menu Options
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Table 3-10  Domain Explorer Elements

Element Description

Target Domains Folder This is the top-level folder in the Domain Explorer Target Domains 
tree. This folder contains a unique Domain Node for each domain 
activated in Guardian. Open the folder to see the available nodes. 
Double-click on the Target Domains folder to display the Active 
Domains Table in the Document Pane. 

See also “Active Domains Table” on page 3-158.

Domain Nodes These represent domains you have activated in Guardian. Open the 
Target Domains folder to see the available nodes.

For more information, see Domain Nodes.

Domain History Folders These contain the Domain Inventories and Evaluation Summaries 
for a domain. Each Domain Node contains the following two 
History folders: 
• Inventory History
• Evaluation History

For more information, see “Domain History Folders” on 
page 3-113.
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Domain Nodes
A domain node represents a domain that has been activated (defined and enabled for evaluation) 
in Guardian. When you activate a domain for the first time in Guardian, a node for the new 
domain is added to the Target Domains folder in the Domain Explorer tree. A unique name is 
automatically generated for the new domain, based upon your entries in the Domain Activation 
Wizard. 

The generated name has the following syntax:
<domain_name>_<hostname>_<listen-port>

Where:

<domain_name > is the name for this domain.

<hostname> is the listen address (hostname) for the WebLogic Administration Server for 
this domain. This is the hostname you entered in the Hostname field of the Domain 
Activation Wizard (for example, localhost).

<listen-port> is the listen port for the WebLogic Administration Server for this domain.

Domain Explorer Menu Click the Domain Explorer menu icon to display a menu containing 
the following options:
• Filter Domain Explorer — Opens the Filter Domain 

Explorer dialog box for filtering out older Inventories and 
Evaluations from the Domain Explorer tree.

• Link with Editor — Link the Navigator Pane Tree to the 
Document Pane View. If you have multiple Document Views 
open in the Document Pane, the Explorer Tree tracks which 
Document View is currently active (displayed). The current 
active Document View name is then also selected (highlighted) 
in the Explorer Tree. 

For more information, see “Domain Explorer Toolbar Menu” on 
page 3-114.

Domain Explorer Context 
Menu

Right-click on an item in the Domain Explorer to display a context 
menu of domain and Domain Group operations.

For more information, see “Domain Explorer Context Menu” on 
page 3-115.

Table 3-10  Domain Explorer Elements

Element Description
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For example:
wl_server_localhost_7001

Note: In the Command Line Interface, the domain node name is referred to as the domainId for 
the domain.

The Domain Explorer tree displays only the active Domain Nodes. “Active” does not refer to 
the state of the domain servers themselves, but rather to whether you have enabled that domain 
for evaluation. If you deactivate a domain in Guardian, that domain is removed from the Domain 
Explorer tree. However, if you reactivate the domain, the node for that domain is again 
displayed, and the original contents of the History folders are also again available. Deactivating 
a domain does not remove the Workspace data for that domain.

Domain Node Icon and Icon Decorations
The Domain Explorer displays only the active Domain Nodes. In the Domain Explorer tree, 
active domains have a blue node icon to the left of the domain name. Icon decorations indicate 
whether the username and password have been persisted, and whether the domain requires SSL 
encryption for all communication. 

Note: Oracle recommends using SSL encryption for communication between the client and the 
Guardian Agent. Guardian uses 128 bit open source encryption for SSL. However, the 
configuration on the server for the domain determines whether or not Guardian will use 
128 bit SSL encryption when activating that domain.

The following table describes the Domain Node icon and icon decorations.

Table 3-11  Domain Node Icons and Icon Decorations

Icon/Decoration Type Meaning

Icon Indicates this is an active domain node.

Decoration Indicates the username and password have been 
persisted. Applied to active icons only.

Decoration Indicates the domain requires 128 bit SSL. 
Applied to active icons only.
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Domain History Folders
Domain Inventories and Evaluation Summaries for a domain are accumulated in History folders, 
which persist on disk in your Guardian Workspace. These are represented as folder icons below 
each Domain Node in the Domain Explorer Target Domains tree. Each Domain Node contains 
the following two History folders: 

Inventory History Folder

Evaluation History Folder

The following sections describe each of these folders.

Inventory History Folder
The Inventory History folder contains the Domain Inventories that have been generated for that 
domain. Double-click on a Domain Inventory name to display the inventory details in the 
Document Pane. 

Each time you activate, evaluate, or inventory a domain, a new Domain Inventory is created and 
added to the Inventory History folder for that domain. A unique name is generated for each new 
Inventory, using this format: 
<domain_name>_<hostname>_<listen_port>_<date> <time>.

See also “Domain Inventory” on page 1-25 in “About Oracle Guardian,” and “Domain Inventory 
View” on page 3-136 in “Reference.”

Evaluation History Folder
The Evaluation History folder contains the Evaluation Summaries that have been generated for 
that domain. Double-click on an Evaluation Summary name to display the evaluation details in 
the Document Pane. 

Each time you evaluate a domain, a new Evaluation Summary is created and added to the 
Evaluation History folder for that domain. A unique name is generated for each new Inventory, 
using this format: 
<bundle_name>_<date> <time>

Each Evaluation Summary listed in the Evaluation History folder has an icon indicating whether 
any signatures were detected. If any signatures were detected, the icon is decorated with a 
severity indicator. The detected signature with the highest severity determines the severity of the 
Evaluation Summary.
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The following table describes the Evaluation Summary icons.

Table 3-12  Evaluation Summary Icons

Icon Severity Meaning

Critical The evaluation detected at least one critical 
signature.

Warning The evaluation detected at least one warning 
signature and no critical signatures.

Informational The evaluation detected at least one 
informational signature and no critical or 
warning signatures.

No Detected Signatures The evaluation did not detect any signatures.

Domain Explorer Toolbar Menu
Click the Domain Explorer toolbar menu icon to display a menu containing the following 
options:

Table 3-13  Domain Explorer Toolbar Menu Options

Option Description

Filter Domain Explorer This opens the Filter Domain Explorer dialog box. Use this to filter 
out older Domain Inventories and Evaluation Summaries from the 
Domain Explorer tree.

Link with Editor Link the Navigator Pane Tree to the Document Pane View. When 
enabled, if you have multiple Document Views open in the 
Document Pane, the Explorer Tree in the Navigator Pane will track 
which Document View is currently active (displayed). The current 
active Document View name is then also selected (highlighted) in 
the Navigator Pane.
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Domain Explorer Context Menu
You can use either of the following methods to open the Domain Explorer context menu:

To apply a menu option to a specific object, right-click the object in the Domain Explorer 
tree and then select the option from the context menu. 

To open the context menu without preselecting an object, right-click in an empty area in 
the Domain Explorer display. 

The following table describes the Domain Explorer context menu options.

Table 3-14  Domain Explorer Context Menu Options

Option Description

Delete Delete the selected Domain Inventory, or Evaluation Summary. This 
deletes the selected entry from the Domain Explorer as well as the 
associated files from your Guardian Workspace. A confirmation box 
prompts you to confirm or cancel the operation. 

Activate This opens the Domain Activation Wizard. If the domain is already 
activated, this option is disabled. For details, see Domain Activation 
Wizard.

Deactivate This opens the Domain Deactivation Wizard. If the domain is already 
deactivated, this option is disabled. For details, see Domain Deactivation 
Wizard.

Modify Domain This opens the Domain Properties dialog box for the selected domain. 
You can then modify the property settings for that domain. For details, 
see Domain Properties Dialog Box.

Inventory This opens the Inventory Wizard for the selected domain. If no domain 
is selected, you can select one from the domain list in the wizard. For 
details, see Inventory Wizard.

Add Shortcut This opens the Shortcut Wizard for this domain. For details, see 
Shortcut Wizard.

Evaluate This opens the Evaluation Wizard for the selected domain. If no domain 
is selected, you can select one from the domain list in the wizard. For 
details, see Evaluation Wizard.
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Domain Properties Dialog Box
Domain Properties govern how Guardian accesses a target domain. The Domain Properties 
dialog box enables you to view and modify the Domain Properties for a specific domain.

To open the Domain Properties dialog box for a domain, right-click on the domain name in the 
Domain Explorer tree, and then select Modify Domain from the context menu.

Evaluate from file This opens the Evaluate a Domain dialog box for the selected domain. 
Use this to select a domain, Signature Bundle, and Data File to use for the 
Evaluation. For details, see Evaluate from File Dialog Box.

Compare Compare two Inventories or two Evaluations. The two items must be of 
the same type. Ctrl+click to select two items, then right-click and select 
Compare from the context menu. The results are displayed in the 
Document Pane. 

Add Domain Group Create a new Domain Group. Right-click on Target Domains and select 
Add Domain Group from the context menu to display the Add Domain 
Group dialog box. For details, see Add Domain Group Dialog Box.

Delete Domain Group Remove the selected Domain Group. Right-click on a Domain Group and 
select Delete Domain Group from the context menu. A confirmation 
dialog box prompts you to confirm or cancel the operation. Click Yes to 
delete the selected group. You cannot delete a domain group that is not 
empty. To depopulate a group, drag and drop the Domain Nodes from 
that group into the Target Domains folder or anther Domain Group. See 
also Delete Domain Group in Chapter 2, “Tasks.”

Rename Domain Group This opens the Rename Domain Group dialog box for the selected 
domain. Enter the new name and click OK. See also, Rename Domain 
Group Dialog Box.

Evaluate Bundle... This opens a submenu listing the Bundles available for evaluation. Select 
a Bundle to open the Bundle Evaluation Wizard for that Bundle. For 
details, see Bundle Evaluation Wizard

Table 3-14  Domain Explorer Context Menu Options

Option Description
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The Domain Properties dialog box contains the following elements:

Table 3-15  Domain Properties

Element Description

Name This is the name for this domain.

Admin Server URL This is the URL for the WebLogic Server Administration Server for 
this domain.

Username This is the username for a WebLogic Server Administrator or 
Monitor for this domain. 

Password This is the password for the WebLogic Server Administrator or 
Monitor specified for Username.

Remember 
username/password 

Select this checkbox to encrypt and store the domain login 
credentials on disk. This saves you from having to enter the 
credentials each time you perform a domain operation.

Enable proxy connection Select this if a proxy server is to be used to access the target domain. 
Then, select a proxy server from the drop-down list. If there are no 
proxy servers in the drop down list, this checkbox is disabled. See 
Proxy Servers of Chapter 2, “Tasks,” for complete instructions on 
enabling and adding proxies.

Max Agent Threads Specifies the maximum number of Agent threads to allocate in the 
WebLogic Server Administration Server. This can be an integer 
value from 1 to 20. The default is 10.

Agent Thread Timeout Specifies the maximum number of seconds that can elapse before an 
Agent thread is deactivated when collecting data from managed 
servers. This can be an integer value from 10 to 600. The default is 
60. 

Notes This contains a text description or other details pertaining to 
this domain.
Oracle Guardian User Guide 3-117



Refe rence
Evaluate from File Dialog Box
To capture target domain data to a file for later evaluation, you can set the following flag in your 
guardian.ini file:

-Dguardian.dump.collection.data

When this flag is set, each time a domain is evaluated, the data is captured and written to two files 
in the data subdirectory of your Guardian Workspace. The files are named as follows:
collectedData_<nnnnnnnnnnnnn>.xml

Where <nnnnnnnnnnnnn> is a timestamp for the creation of the file.

For example: 
collectedData_1218570631376.xml

These two files are differentiated by their respective timestamps, and their size. The earlier, 
smaller file contains the data collected from the domain as restricted by the selected Signature 
Bundle. The second and much larger file contains a collection of all available data from the 
domain.

The captured data can then be evaluated, as explained below. The evaluation proceeds the same 
as with a “live” evaluation, except that the data in the capture file is evaluated, rather than 
evaluating the realtime data from a live server. 

Note: In most cases, you can use the smaller of the two files for the evaluation. However, using 
the larger data file reveals more Detected Signatures, since there is no Bundle restriction.

You can use the Evaluate from File dialog box to specify a domain, Signature Bundle, and data 
file to use for a data file evaluation. 

You can use either of the following methods to open the Evaluate from File dialog box:

If you do not want to preselect a domain for evaluation, right-click anywhere in the 
Domain Explorer and then select Evaluate from File from the context menu. 

To preselect a domain for evaluation, open the Domain Explorer and then open the 
Target Domains folder. Right-click on the name of the domain you want to evaluate and 
select Evaluate from File from the context menu. The dialog box opens with that domain 
preselected.
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The Evaluate from File dialog box contains the following elements:

Table 3-16  Evaluate from File Dialog Box Elements

Element Description

Domain This specifies the domain to evaluate. Select a domain from the drop 
down menu. If you preselected a domain when opening the dialog 
box, this field is already filled.

Bundle This specifies the Signature Bundle to use for the evaluation. Select 
a Bundle from the drop down menu. This can be one of the 
following:
• Default Signatures
• Other Signatures
• Security Advisories
• Critical Signatures
• Configuration Remedy

For instructions on using Bundles, see Bundles of Chapter 2, 
“Tasks.”

Data File This specifies the data file to use for the evaluation. Adding the flag

Add Domain Group Dialog Box
Use the Add Domain Group dialog box to create a new Domain Group. To open, right-click on 
Target Domains in the Domain Explorer tree and select Add Domain Group from the context 
menu. Enter a name for the domain and click OK to add the new group to the Target Domains 
folder.

For instructions on populating and using Domain Groups, see Domain Groups in Chapter 2, 
“Tasks.”

Rename Domain Group Dialog Box
Use the Rename Domain Group dialog box to change the name for a Domain Group. To open, 
right-click on Target Domains in the Domain Explorer tree and select Rename Domain 
Group from the context menu. Enter the new name and click OK.

See also, Rename Domain Group in Chapter 2, “Tasks.”
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Related Tasks
Basic Tasks

Guardian Agent

Workspaces

Preferences

Domains

Domain Groups

Inventories and Evaluations

Command Line Interface

Related Reference
Navigation Pane

Document Pane

Preferences

Command Line Interface

Active Domains Table

Domain Inventory View

Evaluation Summary View

Domain Activation Wizard

Domain Deactivation Wizard

Evaluation Wizard

Filters Wizard

Inventory Wizard
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Signature Explorer
The Signature Explorer is a Navigator View that enables you to browse the available signatures 
and view the contents of a selected signature. In the Navigation Pane, select the Signature 
Explorer tab to display the explorer.

The Signature Explorer contains a list of all existing signatures currently installed in Guardian. 
Double-click on a signature title to display the contents of that signature in the Document Pane.

Signature Severity Icons
To the left of each signature title in the Signature Explorer signature list is a Signature Severity 
icon. The icon indicates the severity level for that signature. 

The following table describes the Signature Severity icons:

Table 3-17  Signature Severity Icons

Icon Severity

Critical

Warning

Informational
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Signature Explorer Toolbar Menu
Click the Signature Explorer toolbar menu icon to open a menu of options for sorting and 
filtering the signature list. 

The Signature Explorer toolbar menu contains the following options:

Table 3-18  Signature Explorer Toolbar Menu Options

Option Description

Sort Signatures > This opens a submenu containing the following options: 
• By Name — List the signatures alphabetically by name. This is 

the default ordering when you first open the Signature 
Explorer. 

• By Severity — Group the signatures by severity level, and list 
signatures alphabetically by name within each severity level. 

Filters... This opens the Filters Wizard, for specifying which signatures to 
include in signature displays. For details, see Filters Wizard. For 
instructions on using the wizard, see Filter Signatures in Chapter 2, 
“Tasks.”

Link with Editor Link the Navigator Pane Tree to the Document Pane View. If you 
have multiple Document Views open in the Document Pane, the 
Explorer Tree tracks which Document View is currently active 
(displayed). The current active Document View name is then also 
selected (highlighted) in the Explorer Tree.
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Signature Explorer Context Menu
Right-click on a signature name in the Signature Explorer to display the Signature Explorer 
context menu. This menu has only one option:

Table 3-19  Signature Explorer Context Menu Option

Option Description

Annotations > This opens a submenu with the following option:
• Manage Annotations: Select this to open the Annotations 

Wizard. For details, see Annotations Wizard. For instructions 
on using this wizard, see Signature Annotations of Chapter 2, 
“Tasks.”

Related Tasks
Basic Tasks

Guardian Agent

Workspaces

Preferences

Inventories and Evaluations

Signatures

Signature Annotations

Command Line Interface

Related Reference
Navigation Pane

Document Pane

Preferences

Command Line Interface

Active Domains Table
Oracle Guardian User Guide 3-123



Refe rence
Text Compare View

Signature View

Annotations Wizard

Filters Wizard

Bundle Explorer
The Bundle Explorer is a Navigator view for browsing the available Signature Bundles and their 
contents. In the Navigation Pane, select the Bundle Explorer tab to display the explorer.

The Bundle Explorer contains the following elements:

Table 3-20  Bundle Explorer Elements

Element Description

Bundles Folder This is the top level folder in the Bundle Explorer tree. This 
contains a folder for each Signature Bundle that is available for 
evaluation.

Bundle Nodes (folders) Signatures are grouped into different Bundles, based on their 
characteristics. The Bundles folder contains a node (folder) for each 
Bundle that is available for evaluation. Double-click a Bundle Node 
to display the Signature Bundle Document View for that Bundle.

Signature Titles Open a Bundle Node folder to see a list of the signature titles 
included in that Bundle. Double-click on a signature title to display 
the contents of that signature in the Document Pane.
3-124 Oracle Guardian User Guide



Nav igat i on  Pane
Bundle Explorer Toolbar 
Menu

Click the Bundle Explorer menu icon to display a menu containing 
the following options:
• Filters... — Opens the Filters Wizard for filtering the contents 

of Bundle and signature lists.
• Sort Signatures > — Opens a submenu with the following 

options:
– By Bundle Name, Signature Name
– By Bundle Name, Severity

• Link with Editor — Link the Navigator Pane Tree to the 
Document Pane View. If you have multiple Document Views 
open in the Document Pane, the Explorer Tree tracks which 
Document View is currently active (displayed). The current 
active Document View name is then also selected (highlighted) 
in the Explorer Tree.

For more information, see Bundle Explorer Toolbar Menu.

Bundle Explorer Context 
Menu

Right-click on a signature title in the Bundle Explorer to display a 
context menu with the following option:
• Annotations > — Opens a submenu with the following option:

– Manage Annotations — Select this to open the 
Annotations Wizard for add an annotation to the selected 
signature.

For more information, see Bundle Explorer Context Menu.

Table 3-20  Bundle Explorer Elements

Element Description
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Bundle and Signature Severity Icons
Each Bundle Node has an icon indicating the severity level for that Bundle. The security level for 
the Bundle is determined by the highest security level occurring for any signature in that Bundle. 
For example, if only one signature in the Bundle has a severity level of Critical, then the entire 
Bundle will have a severity level of Critical.

The Bundle and Signature Severity icons are as follows:

Table 3-21  Bundle and Signature Severity Icons

Icon Severity

Critical

Warning

Informational
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Bundle Explorer Toolbar Menu
Click the Bundle Explorer menu icon to open a menu with the following options:

Table 3-22  Bundle Explorer Toolbar Menu

Element Description

Filters... This opens the Filters Wizard, for specifying which signatures to 
include in signature displays. For details, see Filters Wizard. For 
instructions on using the wizard, see Filter Signatures in Chapter 2, 
“Tasks.”

Sort Signatures This displays a submenu with the following options for sorting the 
signatures displayed in the Bundle Explorer:
• By Bundle Name, Signature Name— List the Bundles 

alphabetically, and then list the signatures in each Bundle 
alphabetically by Signature Title. This is the default ordering 
when you first open the Bundle Explorer. 

• By Bundle Name, Severity— Group the signatures in each 
Bundle by severity level, and the list the signatures 
alphabetically by Signature Title, within each severity level. 

Selecting either of the Sort Signatures choices collapses all the 
Bundle Nodes. To see the signatures in the new sort order, either 
click each Bundle Node individually to expand it, or click the 
Expand All icon to expand all of the Bundle Nodes.

Link with Editor Link the Navigator Pane Tree to the Document Pane View. If you 
have multiple Document Views open in the Document Pane, the 
Explorer Tree tracks which Document View is currently active 
(displayed). The current active Document View name is then also 
selected (highlighted) in the Explorer Tree.
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Bundle Explorer Context Menu
In the Bundle Explorer, right-click on a signature title to display the Bundle Explorer context 
menu. This menu has only one option:

Table 3-23  Signature Explorer Context Menu Option

Option Description

Annotations > This opens a submenu with the following option:
• Manage Annotations: Select this to open the Annotations 

Wizard. For details, see Annotations Wizard. For instructions 
on using this wizard, see Signature Annotations of Chapter 2, 
“Tasks.”

Related Tasks
Basic Tasks

Guardian Agent

Preferences

Signatures

Signature Annotations

Bundles

Command Line Interface

Updates and Upgrades

Related Reference
Navigation Pane

Document Pane

Domain Explorer

Signature Explorer

Shortcut Explorer
3-128 Oracle Guardian User Guide



Nav igat i on  Pane
Signature View

Signature Bundle View

Bundle Evaluation Wizard

Shortcut Explorer
The Shortcut Explorer is a Navigation Pane View for viewing and managing your Evaluation 
Shortcuts. In the Navigation Pane, select the Shortcut Explorer tab to display the explorer.

The Shortcut Explorer displays a list of all of the Evaluation Shortcuts you have created. 
Double-click on a Shortcut to open the Shortcut Evaluation Wizard with the Shortcut target 
domain and Signature Bundle preselected.

For a description of Shortcuts, see Shortcut in Chapter 1, “About Oracle Guardian.” For 
instructions on creating and using Shortcuts, see Shortcuts in Chapter 2, “Tasks.”

Shortcut Explorer Context Menu
You can use either of the following methods to open the Shortcut Explorer context menu:

To apply a menu option to a specific object, right-click the object in the Shortcut 
Explorer tree and then select the option from the context menu. 

To open the context menu without preselecting an object, right-click in an empty area in 
the Shortcut Explorer display. 
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The Shortcut Explorer context menu contains the following options:

Table 3-24  Shortcut Explorer Context Menu Options

Element Description

Add Shortcut This opens the Shortcut Wizard for creating a new Evaluation 
Shortcut. For instructions, see Shortcut Wizard.

Delete Shortcut Delete the selected Shortcut. A Confirm Delete dialog box prompts 
you to confirm the delete operation. Click OK to delete the 
Shortcut.

Evaluate Shortcut This opens the Shortcut Evaluation Wizard for conducting an 
evaluation as defined in the selected Shortcut. For instructions, see 
Shortcut Evaluation Wizard.

Related Tasks
Basic Tasks

Workspaces

Preferences

Domains

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Command Line Interface

Related Reference
Navigation Pane

Document Pane
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Domain Explorer

Bundle Explorer

Signature Explorer

Shortcut Evaluation Wizard 

Document Pane
The Document Pane is located in the central portion of the Oracle Guardian main window. The 
Document Pane displays the Document Views. 

The Document Pane contains the following elements:

Document Views

Document Pane Outline Views

Document View Titlebars

Document View Context Menus

Document Views
The Document Views display the details document(s) for the object selected in the Navigation 
Pane. Some Views also have editing features for cutting, copying, and pasting text selections into 
an external editor. If edit options are available for a View, you can right-click in that View to open 
an Edit menu of those options.

You can have multiple Views open in the Document Pane, but only one can be active at a time. 
Each opened View has a tab, located at the top of the Document Pane. Click on a View tab to 
activate and display that View. Some Views have additional tabs, located at the bottom of the 
View display. These display additional pages for that View, such as the Overview, Source, and 
Report pages.
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Table 3-25 provides an overview of the Document Views.

Table 3-25  Document Views

View/Editor Description

Domain Inventory View Open the Domain Explorer > Inventory History folder and then 
double-click on a Domain Inventory title to display that inventory in the 
Document Pane. The inventory includes descriptions of your servers, 
Java Virtual Machines, operating systems, databases, product versions, 
and certain configuration settings. The Domain Inventory View 
contains the following tabs:
• Overview — Display the Domain Inventory Overview for this 

Inventory.
• Source — Display the XML source for the Inventory.
• Report — Display the Domain Inventory report for this inventory.

For details, see Domain Inventory View.

Evaluation Summary 
View

Open the Domain Explorer > Evaluation History folder, and then 
double-click on an Evaluation Summary title to display that Evaluation 
Summary in the Document Pane. This contains a table of all detected 
signatures for the evaluated domain. Select a signature in the list to 
display the signature Description and Remedy details for that signature. 
For details, see Evaluation Summary View.

Signature View Double-click on a signature entry in the Signature Explorer or Bundle 
Explorer to display this View. This View contains the following tabs:
• Overview — Display the Signature Overview for the signature.
• Source — Display the XML source for the signature.
• Report — Display the Signature Report for that signature.

For details, see Signature View.

Signature Bundle View Double-click on a Bundle Node in the Bundle Explorer to display this 
View. This View provides a description and some additional details about 
the selected Bundle. Also included is the Signature Definition for the 
Bundle. For details, see Signature Bundle View.
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Document Pane Outline Views
When a Document View is open, you can select Window > Show View > Outline View to 
display the Outline View for the current Document View. You can use the Outline View as a 
navigator for the current Document View. You can click the Overview, Source, or Report nodes 
in the Outline View to bring the corresponding tab of the Document View to the forefront. You 
can open the Outline View Source node to select specific XML tag names, to jump to those tags 
in the Source page and highlight them. 

Active Domains Table Select Window > Show View > Active Domains Table to display this 
View. This contains a table of all of the domains currently activated in 
Guardian, and action buttons for the following tasks:
• Open Admin Console — Open an instance of the WebLogic Server 

Administration Console.
• Modify Domain — Open the Domain Properties configuration 

page for the selected domain.
• Deactivate Domain — Open the Domain Deactivation Wizard for 

the selected domain(s).

For details, see Active Domains Table.

Shortcuts Table Select Window > Show View > Shortcuts Table to display this View. 
This contains a table of all of your Shortcuts, and action buttons for the 
following tasks:
• Add Shortcut — Open the Shortcut Wizard for creating Shortcuts.
• Delete Shortcut — Delete the selected Shortcut. A Confirm Delete 

dialog box prompts you to confirm the delete operation. Click OK to 
delete the Shortcut.

For details, see Shortcuts Table.

Table 3-25  Document Views

View/Editor Description
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Document View Titlebars
Each Document View has a titlebar that contains the name of the View, an identity icon (for 
example, a Domain or Signature icon), and buttons to close, minimize, maximize, and restore the 
display.

The View titlebars also have the following additional features:

Bubble Help/Text

Roll your cursor over titlebar text for a bubble help description of that text or page. For 
example, for a Domain Inventory View, this displays the full Guardian Workspace path 
and inventory file name for that Domain Inventory. 

Maximize and Restore

Double-click the titlebar to maximize a View. Double-click it again to restore it to its 
original size. 

System Menu 

Right-click on a titlebar to open the System Menu for that View. This contains options for 
restoring, sizing, minimizing/maximizing, and closing View(s). This menu also enables 
you to open a new (unedited) copy of the View, or to move a tab or tab group.

Tab Groups

You can group multiple Views together on a titlebar as a tab group. Tab groups can be 
moved together as a unit, using either the System Menu > Move menu option or drop 
cursors. Only the titlebar of the currently active View is visible in a tab group.

Show List Icon

If you have more Views open than can fit on a titlebar, a Show List icon appears to the 
right of the titlebar tabs. The icon includes a number that indicates how many more open 
Views can fit on the titlebar. Click the icon to display a list of all the titlebar View. Select 
an item from the list to make it active and bring it to the forefront of the Navigation Pane 
or Document Pane display. The items listed in bold font are those that cannot fit on the 
titlebar. The items not listed in bold are those that are already shown on the titlebar.

Drag and Drop

You can move Views by dragging their titlebars to different locations, as follows: 

– You can move Navigation Pane Views almost anywhere, including outside the Oracle 
Guardian main window. However, you can move Document Views only within the 
Document Pane.
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– As you drag a View or Editor titlebar, the mouse pointer changes into a drop cursor 
that indicates where the View will dock when you release it. 

– The point in the titlebar at which you click determines what will be dragged. Click a 
View tab to move that View only, without moving the entire tab group. To move the 
tab group, click to the right of the tabs in the title bar, or select Move > Tab Group 
from the System Menu.

Document View Context Menus
The following Document Views have context menus:

Domain Inventory View

Evaluation Summary View

Signature View

Signature Bundle View

The Active Domains Table and Shortcuts Table Views do not have context menus. 

Each tab page for a View has a context menu specific to the tab contents. Some context menus—
for example, Edit menus—may be available only for certain items within that View. 

To open a context menu, right-click on an item in that View.

Document View Edit Menus
Edit menus are available in some View pages for text items that can be copied and pasted to an 
external editor. If an item cannot be edited (copied), the Edit menu will not be available. 
Right-click on an item to display a menu of standard edit options for that item.

The Edit context menu contains the following standard options:

Table 3-26  Document View Edit Menu

Element Description

Undo Undo last edit operation.

Cut (Disabled.) This is an Eclipse Platform menu option that does not 
apply to this application.

Copy Copy selected text to Clipboard or copy buffer.
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Domain Inventory View
The Domain Inventory Document View displays the contents of a Domain Inventory. The 
Domain Inventory is an XML document that describes the products in your domain, and is 
persisted in your Guardian Workspace. The inventory includes descriptions of your servers, Java 
Virtual Machines, operating systems, databases, product versions, and certain configuration 
settings. For details, see “Domain Inventory” on page 1-25 in the section “About Oracle 
Guardian.”

You can use either of the following methods to open a Domain Inventory View:

In the Domain Explorer, open the Inventory History folder, and then double-click on a 
Domain Inventory name to display that inventory in the Document Pane. 

Activate a domain, or inventory a domain. Then click the OK button in the Progress 
View. 

The Domain Inventory View contains the following tabs:

Domain Inventory Overview Tab

Domain Inventory Source Tab

Domain Inventory Report Tab

The contents of each of these tab pages are described in the following sections.

Paste (Disabled.) This is an Eclipse Platform menu option that does not 
apply to this application.

Delete (Disabled.) This is an Eclipse Platform menu option that does not 
apply to this application.

Select All Select all text in Document View.

Table 3-26  Document View Edit Menu

Element Description
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Domain Inventory Overview Tab
The Domain Inventory Overview page displays a summary of the selected Domain Inventory. 
The Overview page contains the following sections:

General Information Section

Servers Section

JDBC

These are described in the following sections.

General Information Section
The Domain Inventory General Information section contains the following information:

Table 3-27  Domain Inventory General Information Section

Field Description

Domain Name This is the name of the domain assessed in this Domain Inventory.

Inventory Date/Time Date and time this Domain Inventory was created. 

Servers Section
The Domain Inventory Servers section contains the following information:

Table 3-28  Domain Inventory Servers Section

Field Description

Number of Servers 
Configured

This is located at the far left at the top of the Servers section. This 
indicates the number of all configured servers, regardless of their 
state. 

Number of Active Servers This is located at the top of the Servers section, in the middle above 
the Server Details section. This is a number less than or equal to 
Number of Configured Servers. When this number is less than 
Number of Configured Servers, it indicates that some of the 
servers are not running.
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Number of Available Agents This is located at the top of the Servers section at the far right above 
the Server Details section. This is a number less than or equal to 
Number of Active Servers. When this number is less than Number 
of Active Servers, it indicates that the Guardian Agent is either not 
deployed or not started on one or more running server(s).

Sever list area This contains a list of all configured servers. An icon indicates 
whether a server is running or not. Click on a server name in the 
Servers list area to view the details for that server.

Server Details > This subsection contains the following information:
• Name — This is the name of this server. 
• Version — This is the basic version number for this server. 
• WebLogic Version — This is the complete version number for 

this instance of the WebLogic Server.
• Admin Server — (True/False) Specifies whether this server is 

the Administration Server for this domain.
• Production Mode — (True/False) Specifies whether this 

server is running in Production Mode or Development Mode.
• Agent State — Specifies the current state of the Guardian Agent 

deployed in the WebLogic Administration Server for this 
domain. This can be one of the following:
– Available
– Unavailable

Java Details > This subsection contains the following information:
• Java Vendor
• Java Version
• Java VM (Virtual Machine) Vendor
• Java VM Name, 
• Java VM Version
• Free Memory
• Total Memory
• Max Memory

Operating System Details > This subsection displays the operating system name, version, and 
processor architecture. 

Table 3-28  Domain Inventory Servers Section

Field Description
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JDBC
The Domain Inventory JDBC section contains the following information:

Table 3-29  Domain Inventory JDBC Section

Element Description

Number of Unique JDBC 
Connection Pool/Data 
Source Configurations

(Numeric value) Indicates the current number of unique JDBC 
Connection Pool and Data Source Configurations for this domain.

JDBC Connection Pool list 
area

This contains a list of the JDBC Connection Pools configured for 
this domain. Click on an entry in the JDBC Connection Pool list to 
display the JDBC Details for that Connection Pool.

JDBC Details > Click on an entry in the JDBC Connection Pool list to display the 
JDBC Details for that Connection Pool. The details for the first entry 
in the list are displayed by default.

This subsection contains the following information:
• JDBC Connection Pool name 
• JDBC data source name 
• Database product name and version 
• JDBC Driver name and version 

Domain Inventory Source Tab
The Domain Inventory Source page displays the XML source for the selected Domain Inventory. 
This page also has a context menu of options for saving, copying, and printing the inventory XML 
source. 
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Domain Inventory Source Tab Context Menu
Right-click in the Source page to display a context menu with the following options:

Table 3-30  Domain Inventory Source Tab Context Menu

Element Description

Save As... Save Source tab contents as an XML file. Opens a file browser from 
which you can specify the file name and location.

Copy Copy selected text to clipboard.

Print Print Source tab contents to the specified printer. Opens a standard 
Print dialog box for specifying print parameters and preferences.

Select All Select all text in page.

Find/Replace Find the specified text. Opens the Find/Replace dialog box for 
specifying the string search parameters. Select and then right-click 
on text to preselect the search text. The Source page is a read-only 
View, so the Replace feature is disabled.

Find Next Find the next instance of the specified search string or selected text.

Find Previous Find the previous instance of the specified search string or selected 
text.

Domain Inventory Report Tab
The Domain Inventory Report page displays all of the information contained in the Domain 
Inventory Overview page, in a printer friendly format. This page also has a system menu of 
options for exporting, printing, creating a desktop shortcut for the page, adding the inventory to 
your favorites list, and other file operations. Right-click anywhere in the Report page to display 
this menu. Some options may not be applicable in this context.

Related Tasks
Basic Tasks

Guardian Agent

Workspaces
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Preferences

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Command Line Interface

Support

Related Reference
Navigation Pane

Document Pane

Preferences

Domain Explorer 

Inventory Wizard 

Command Line Interface

Evaluation Summary View
The Evaluation Summary View displays the contents of a selected Evaluation Summary 
document. An Evaluation Summary is created each time you evaluate a domain, and is persisted 
in the Guardian Workspace. For more information, see Evaluation Summary in the section 
“About Oracle Guardian.” For instructions on conducting evaluations, see Inventories and 
Evaluations in Chapter 2, “Tasks.”

You can use either of the following methods to display an Evaluation Summary:

In the Domain Explorer, open the Evaluation History folder, and then double-click on an 
Evaluation entry to display that Evaluation Summary in the Document Pane.

Conduct an evaluation. An Evaluation Summary is opened automatically when the 
evaluation completes. For instructions, see Evaluate Domain in Chapter 2, “Tasks.”
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The Evaluation Summary View contains the following tabs:

Evaluation Summary Overview Tab

Evaluation Summary Source Tab

Evaluation Summary Report Tab

The following sections describe the contents of each of these tab pages.

Evaluation Summary Overview Tab
The Overview page displays the results data for the selected Evaluation Summary, which 
includes a table of all signatures detected in the Evaluation. You can click on a signature entry in 
the table to view the Description and Remedy information for that signature. The Description 
and Remedy information is displayed in the lower half of the Overview page, just below the 
Detected Signatures table. You can expand or collapse a View section by clicking the triangle 
icon in the heading.

The Evaluation Summary Overview page contains the following sections:

General Information Section

Detected Signatures Table

Description Section

Remedy Section

These are described in the following sections.

General Information Section
The General Information section of the Evaluation Summary View contains the following 
information:

Table 3-31  Evaluation Summary View General Information Section

Field Description

Domain Name This is the name of the target domain.

Bundle Name This is the Signature Bundle used for this evaluation.
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Detected Signatures Table
The Detected Signatures Table contains the list of signatures detected for this domain for this 
evaluation, and some additional information about each detected signature. 

Select a signature entry in the table to display the details for that signature in the Description and 
Remedy sections of the View. Details for the first entry are displayed by default. 

Click on a table column heading to sort the table contents according to that column order. The 
default sort order is by Severity and then Name.

The Detected Signatures Table contains the following information for each detected signature:

Evaluation Date/Time This is the date and time stamp for when the evaluation was 
completed.

Duration This is the amount of time (in miliseconds) that it took to complete 
the evaluation.

Targeted Signatures This is the number of signatures in the Bundle that target products 
that are actually present in the evaluated domain. Some signatures 
may not be targeted because the products targeted by the signature 
are not present in the domain.

Detected Signatures This is the number of targeted signatures that were detected for this 
domain. Detected signatures are targeted signatures that in turn 
target issues that were detected in your domain during the 
evaluation.

Table 3-32  Detected Signatures Table

Field Description

Severity This is the severity level for this signature. This can be one of the 
following:

– CRITICAL
– WARNING
– INFO

Name This is the signature title.

Table 3-31  Evaluation Summary View General Information Section

Field Description
Oracle Guardian User Guide 3-143



Refe rence
Evaluation Summary Signature Severity Icons
To the left of each signature title in the Severity column of the table is a Signature Severity icon. 
The icon indicates the severity level for that signature. 

The following table describes the Signature Severity icons:

Table 3-33  Signature Severity Icons

Icon Severity

Critical

Warning

Informational

Impact This is indicates the type of impact this issue could have in your 
domain (for example, Server Outage, Subsystem Outage, 
Administration, Performance, etc.).

Product This is the Oracle product in your domain that is targeted by this 
signature for this issue.

Topic This is the product component, feature, or support product targeted 
by this signature for this issue.

Subtopic This is an additional level of detail pertaining to the targeted topic 
for this signature.

ID This is the signature ID number.

SR (Service Request) This lists any support service requests you have filed for this 
signature.

Table 3-32  Detected Signatures Table

Field Description
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Detected Signatures Table Context Menu
Right-click on a signature title in the Detected Signatures table to open a context menu with the 
following options:

Table 3-34  Detected Signatures Table Context Menu

Element Description

Sorting... This opens the Sorting dialog box for sorting signatures. You can 
sort in ascending or descending order, and according to any 
hierarchical combination of the following criteria:
• By Name
• By Severity
• Impact
• Product
• Topic

For instructions, see Sort Signatures in Chapter 2, “Tasks.”

Filters... This opens the Filters Wizard, for specifying which signatures to 
include in signature displays. For details, see Filters Wizard. For 
instructions, see Filter Signatures in Chapter 2, “Tasks.”

Annotations > This opens a submenu with the following option:

Manage Annotations: Select this to open the Annotations 
Wizard. For details, see Annotations Wizard. For instructions on 
using this wizard, see Signature Annotations of Chapter 2, “Tasks.”

Description Section
The Description section of the Evaluation Summary View is the left panel below the Detected 
Signatures table. Select a signature entry in the Detected Signatures table to display the 
Description details for that signature. This section contains the following information:
Oracle Guardian User Guide 3-145



Refe rence
Table 3-35  Evaluation Summary Description Section

Field Description

Name This is the full title for the signature.

Severity This is the severity level for this signature. This can be one of the 
following:

Impact This is indicates the type of impact this issue could have in your 
domain (for example, Server Outage, Subsystem Outage, 
Administration, Performance, etc.).

Signature Description This is the complete text description of the error targeted by the 
signature.

Remedy Section
The Remedy section of the Evaluation Summary View is located below the Detected 
Signatures table, on the right side. Select a signature entry in the Detected Signatures table to 
display the Remedy details for that signature. 

The Remedy section contains the following information:

– CRITICAL
– WARNING
– INFO

Table 3-36  Evaluation Summary View Remedy Section

Field/Area Description

Server list This is the area at the top of the Remedy section. It contains a list of 
the servers in the evaluated domain that may be affected by this 
issue.

Remedy text This is the area just below the Server list, and contains the 
recommended solution for this issue.
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Evaluation Summary Overview Tab Context Menu
Right-click on a signature title in the Detected Signatures table to open a context menu with the 
following options:

Table 3-37  Detected Signatures Table Context Menu

Element Description

Sorting... This opens the Sorting dialog box for sorting signatures. You can 
sort in ascending or descending order, and according to any 
hierarchical combination of the following criteria:
• By Name
• By Severity
• Impact
• Product
• Topic

For instructions, see Sort Signatures in Chapter 2, “Tasks.”

Filters... This opens the Filters Wizard, for specifying which signatures to 
include in signature displays. For details, see Filters Wizard. For 
instructions, see Filter Signatures in Chapter 2, “Tasks.”

Annotations > This opens a submenu with the following option:

Manage Annotations: Select this to open the Annotations 
Wizard. For details, see Annotations Wizard. For instructions on 
using this wizard, see Signature Annotations of Chapter 2, “Tasks.”

For More Information This section contains links to the My Oracle Support website, 
product and patch download sites, recommended documentation, 
and other supporting documents for resolving this issue.

Get more help from Oracle 
Support

Click this link to open the Guardian Service Request Wizard for 
creating service request archive based on this signature. For details, 
see Service Request Wizard. For instructions on using this wizard, 
see Creating a Service Request Archive in Chapter 2, “Tasks.”

Table 3-36  Evaluation Summary View Remedy Section

Field/Area Description
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Evaluation Summary Source Tab
The Evaluation Summary Source tab page displays the XML source for the selected Evaluation 
Summary. This page also has a context menu of options for saving, copying, and printing the 
inventory XML source. 

Evaluation Summary Source Tab Context Menu
Right-click in the Source page to display a context menu with the following options:

Table 3-38  Evaluation Summary Source Tab Context Menu

Element Description

Save As... Save Source tab contents as an XML file. Opens a file browser from 
which you can specify the file name and location.

Copy Copy selected text to the Clipboard.

Print Print Source tab contents to the specified printer. Opens a standard 
Print dialog box for specifying print parameters and preferences.

Select All Select all text in page.

Find/Replace Find and replace the specified text. Opens Find/Replace dialog box 
for specifying the string search and replace parameters. Select and 
then right-click on text to preselect the search text.

Find Next Find the next instance of the specified search string or selected text.

Find Previous Find the previous instance of the specified search string or selected 
text.

Evaluation Summary Report Tab
The Evaluation Summary Report page displays all of the information contained in the Evaluation 
Summary Overview page, in a printer friendly format. This page also has a system menu of 
options for exporting, printing, creating a desktop shortcut for the page, adding the inventory to 
your favorites list, and other file operations. Right-click anywhere in the Report page to display 
this menu. Some options may not be applicable in this context.
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Related Tasks
Basic Tasks

Workspaces

Preferences

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Command Line Interface

Support

Related Reference
Navigation Pane

Document Pane

Preferences

Domain Explorer 

Text Compare View

Signature View

Evaluation Wizard

Filters Wizard

Shortcut Evaluation Wizard

Command Line Interface
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Text Compare View
The Text Compare View enables you to view two Domain Inventories or two Evaluation 
Summaries, side-by-side. You can compare inventories or evaluations from the same or different 
domains. Both objects must be of the same type—that is, two inventories or two evaluations. You 
cannot compare an inventory against an evaluation. 

To display the Text Compare View, do the following:

1. Open the Domain Explorer History folder containing the resources to be compared 
(Inventory History or Evaluation History).

2. Select the two documents to be compared.

Click on the first item to select it, and then hold down the Ctrl key and click to select the 
second item.

3. Right-click on the selected items and select Compare from the context menu.

This opens the Text Compare View in the Document Pane. The differences between the 
two files are highlighted, and related segments are shown in boxed sections, with 
connectors indicating the relation.
3-150 Oracle Guardian User Guide



Document  Pane
The Text Compare navigation controls are as follows:

Table 3-39  Text Compare View Navigation Controls

Action Instructions

Go to next/previous 
segment

Click the up/down arrows at the top right corner of the Text 
Compare display.

Jump to a segment Click on a segment bar in the far right column. 

Resize panels Move your cursor over the center divider until the cursor changes to 
a double arrow. Then click and drag the divider to the left or right to 
resize the panels.

Text Compare View Context Menu
Right-click in the left or right Text Compare View panel to display the Text Compare context 
menu. This menu has the following options:

Table 3-40  Text Compare View Context Menu

Option Description

Copy Copy the selected text. You can then use a text editor to paste the 
selected text into a file and save it.

Select All Select all text in the current panel. You can then use a text editor to 
paste the selected text into a file and save it.

Ignore White Space Remove white space characters in both panels. 

Show Whitespace 
Characters

Show white space characters and carriage returns in both panels. A 
light blue dot indicates a white space characters. A light blue 
paragraph symbol indicates a carriage return.

Show Line Numbers Display line numbers in both panels.

Find/Replace Display the Find/Replace dialog box. Enter your search criteria and 
click Find to search in the selected panel. Replace is disabled for 
this page.
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Related Tasks
Basic Tasks

Workspaces

Preferences

Inventory Domain

View Domain Inventories and Evaluation Summaries

Evaluate Domain

Evaluate Snapshot

Compare Inventories or Evaluations

Related Reference
Navigation Pane

Document Pane

Preferences

Domain Explorer 

Domain Inventory View

Evaluation Summary View

Signature View

Evaluation Wizard

Filters Wizard

Shortcut Evaluation Wizard

Command Line Interface
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Signature View
The Signature View displays some basic descriptive and target information for a selected 
signature. For information on viewing the entire contents of a signature, see Evaluation Summary 
View. 

Double-click on a signature entry in the Signature Explorer or Bundle Explorer to display this 
View.

The Signature View contains the following tabs:

Signature View Overview Tab

Signature View Source Tab

Signature View Report Tab

The following sections describe the contents of each of these tab pages.

Signature View Overview Tab
The Signature View Overview tab page displays some basic descriptive and target information 
for the signature. For information on viewing the entire contents of a signature, see Evaluation 
Summary View.

The Signature View Overview page contains the following sections:

Table 3-41  Signature View Overview Page Sections

Section Description

General Information This section contains the following information for the selected 
signature:
• ID — Signature identification number.
• Name — The complete signature title.
• Publication Date — Signatures are periodically updated as 

signature target or remedy information changes. This date 
indicates the publication date for this version of this signature.
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Signature View Source Tab
The Signature View Source tab page displays the complete XML source for the selected 
signature. This page also has a context menu of options for saving, copying, and printing the 
inventory XML source. 

Signature View Source Tab Context Menu
Right-click in the Source page to display a context menu with the following options:

Description This is a description of the issue addressed by this signature.

Target This section contains the target information for this signature. The 
Target section contains the following subsection:
• [Expression] — This contains an XPath expression identifying 

the target(s) for this signature. The target identifies the 
product(s), product version(s), and/or environment(s) to which 
this issue pertains. 

Table 3-42  Signature View Source Tab Context Menu

Element Description

Save As... Save Source tab contents as an XML file. Opens a file browser from 
which you can specify the file name and location.

Copy Copy selected text to clipboard.

Print Print Source tab contents to the specified printer. Opens a standard 
Print dialog box for specifying print parameters and preferences.

Select All Select all text in page.

Find/Replace Find and replace the specified text. Opens Find/Replace dialog box 
for specifying the string search and replace parameters. Select and 
then right-click on text to preselect the search text.

Table 3-41  Signature View Overview Page Sections

Section Description
3-154 Oracle Guardian User Guide



Document  Pane
Signature View Report Tab
The Signature View Report page displays all of the information contained in the Signature 
View Overview page, in a printer friendly format. This page also has a system menu of options 
for exporting, printing, creating a desktop shortcut for the page, adding the inventory to your 
favorites list, and other file operations. Right-click anywhere in the Report page to display this 
menu. Some options may not be applicable in this context.

Related Tasks
Basic Tasks

Preferences

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Related Reference
Navigation Pane

Document Pane

Preferences

Signature Explorer 

Bundle Explorer

Evaluation Summary View

Find Next Find the next instance of the specified search string or selected text.

Find Previous Find the previous instance of the specified search string or selected 
text.

Table 3-42  Signature View Source Tab Context Menu

Element Description
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Text Compare View

Annotations Wizard

Evaluation Wizard

Filters Wizard

Signature Bundle View
The Document Pane Signature Bundle View displays a description and some additional details 
about the selected Signature Bundle. This also includes the Signature Definition for the Bundle, 
which determines which signatures are included in the Bundle.

To open the Signature Bundle View, double-click on a Bundle Node in the Bundle Explorer. 

The Signature Bundle View has the following tabs:

Signature Bundle View Overview Tab

Signature Bundle View Report Tab

The following sections describe the contents of each of these tab pages.

Signature Bundle View Overview Tab
The Signature Bundle View Overview page displays a description and some additional details 
about the selected Signature Bundle. 

The Overview page contains the following sections:

Table 3-43  Signature Bundle View Overview Tab

Section Description

General Information This section contains the following information:
• ID
• Name
• Creation Date
• Last Modification Date

Description This is a summary description of the Bundle contents.

Signature Def This is the XPath expression that defines which signatures are 
included in this Bundle.
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Signature Bundle View Report Tab
The Signature Bundle View Report page displays all of the information contained in the 
Signature Bundle View Overview page, in a printer friendly format. This page also has a system 
menu of options for exporting, printing, creating a desktop shortcut for the page, adding the 
inventory to your favorites list, and other file operations. Right-click anywhere in the Report page 
to display this menu. Some options may not be applicable in this context.

Related Tasks
Basic Tasks

Preferences

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Related Reference
Navigation Pane

Document Pane

Preferences

Signature Explorer 

Bundle Explorer

Evaluation Summary View

Signature View

Evaluation Wizard

Filters Wizard
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Active Domains Table
The Active Domains Table is a Document View for managing the domains currently activated 
in Guardian.

You can use either of the following methods to open the Active Domains Table:

Double-click on Target Domains in the Navigation Pane to display the Active Domains 
Table.

In the Main Menu Bar, select Window > Show View > Active Domains Table.

The Active Domains Table contains the following information for each active domain:

Table 3-44  Active Domains table Fields

Field Description

Domain This is the domain name.

Administration Server URL This is the URL for the WebLogic Administration Server for this 
domain.

Last Evaluation This is the name of the most recent Evaluation Summary for this 
domain.

By default, the domains are listed alphabetically by domain name. Click a column heading to sort 
the table entries according to the sort order for that column. Click a column heading again to 
alternate between ascending or descending order.

Active Domains Table Toolbar Buttons
The Active Domains Table toolbar contains the following buttons: 

Note: You must select an entry in the table to activate the buttons.
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Table 3-45  Active Domains Table Toolbar Buttons

Element Description

Open Admin Console This opens an Oracle WebLogic Server Administration Console in 
your default Web browser. If you selected the Remember 
username/password checkbox when activating or modifying the 
domain, the browser will automatically log you into the 
Administration Console. If not, the browser will start at the 
Administration Console login page.

Modify Domain This opens the Domain Properties dialog box, which enables you 
to configure how Guardian accesses the domain, and to configure 
the Max Agent Threads and Agent Thread Timeout parameters. 
For instructions, see Modify Domain Properties in Chapter 2, 
“Tasks.”

Deactivate Domain This invokes the Domain Deactivation Wizard for deactivating the 
selected domain. For instructions, see Deactivate Domain in 
Chapter 2, “Tasks.”

Related Tasks
Basic Tasks

Preferences

Domains

Domain Groups

Proxy Servers

Inventories and Evaluations

Command Line Interface

Related Reference
Navigation Pane

Document Pane
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Preferences

Domain Explorer 

Evaluation Summary View 

Domain Activation Wizard 

Inventory Wizard 

Domain Deactivation Wizard 

Domain Properties Dialog Box 

Command Line Interface

Shortcuts Table
The Shortcuts Table is a Document Pane View for viewing and managing the Evaluation 
Shortcuts you have created. 

Note: For a description of Evaluation Shortcuts, see Shortcut in Chapter 1, “About Oracle 
Guardian.” For instructions on creating Evaluation Shortcuts, see Create Shortcut in 
Chapter 2, “Tasks.”

To open the Shortcuts Table, go to the Main Menu Bar and select Window > Show View > 
Shortcuts Table.

The Shortcuts Table contains the following information for each Shortcut:

Table 3-46  Shortcuts Table

Element Description

Shortcut This is the Shortcut name.

Domain This is the domain targeted for evaluation.

Bundle This is the Signature Bundle used for the evaluation.

By default, the Shortcuts are listed alphabetically by Shortcut name. Clicking a column heading 
sorts the Shortcuts according to the sort order for that column. For example, clicking the Domain 
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column orders the Shortcuts alphabetically by domain name. Clicking the same column heading 
in succession alternates between ascending and descending order.

Shortcuts Table Toolbar
The Shortcuts Table toolbar contains the following buttons:

Table 3-47  Shortcuts Table Toolbar Buttons

Button Description

Add Shortcut This opens the Shortcut Wizard for creating a new Evaluation 
Shortcut. 

Delete Shortcut Delete the selected Shortcut. A confirmation box prompts you to 
confirm the delete operation. 

Related Tasks
Basic Tasks

Preferences

Domains

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Related Reference
Navigation Pane

Document Pane

Preferences

Shortcut Explorer 
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Evaluation Summary View 

Evaluation Wizard 

Shortcut Wizard

Shortcut Evaluation Wizard

Command Line Interface

Shortcut Wizard 

Shortcut Explorer 

Preferences
The Preferences page enables you to customize your Oracle Guardian environment.

You can use either of the following methods to open the Preferences page:

Press Ctrl+Shift+P.

In the Main Menu Bar, select Window > Preferences. 

Preference parameters are organized into primary and secondary categories, or pages. The left 
pane of the Preferences page contains a Navigation Tree listing these pages, in hierarchical 
order. Click on a category title in the tree to display that page. For instructions on setting 
Preferences, see Preferences in Chapter 2, “Tasks.”

The following table provides an overview of the Preferences pages.
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Table 3-48  Preferences Categories and Pages

Category Description

General This includes the following pages:
• General (main)
• Appearance
• Compare/Patch
• Content Types
• Editors
• Keys
• Network Connections
• Perspectives
• Welcome Page
• Workspace

Guardian This includes the following pages:
• Guardian (main)
• Encryption
• Evaluation
• Logging and Debug
• Oracle Support
• Proxies
• Reporting
• XML Appearance

Help These parameters control the content and appearance of Guardian 
online help. This includes the following pages:
• Help (main)
• Content

Install/Update These parameters are for configuring and automating Guardian 
application and signature updates. This includes the following 
pages:
• Install/Update (main)
• Automatic Updates
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Related Tasks
Basic Tasks

Guardian Agent

Workspaces

Preferences

Proxy Servers

Inventories and Evaluations

Command Line Interface

Troubleshooting

Support

Updates and Upgrades

Related Reference
Window Menu 

Navigation Pane

Document Pane

Wizards

Log Files

Command Line Interface
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Wizards
Oracle Guardian provides the several wizards for guiding you through some of the more common 
or complex Guardian tasks. 

The following table describes the Guardian wizards and how to invoke them.

Table 3-49  Guardian Wizards

Menu Item Description

Annotations Wizard Right-click on a signature title in the Signature Explorer or 
Bundle Explorer and select Annotations from the context 
menu. This opens a submenu with a single option, Manage 
Annotations. Select this to open the Annotations Wizard. 
This contains fields and options for annotating the selected 
signature. For details, see Annotations Wizard. For instructions 
on using this wizard, see Signature Annotations of Chapter 2, 
“Tasks.” 

Bundle Evaluation Wizard Right-click in the Domain Explorer and select Evaluate 
Bundle from the context menu. This opens a submenu listing 
the Bundles available for evaluation. Select a Bundle to open 
the Bundle Evaluation Wizard for that Bundle. For details, 
see Bundle Evaluation Wizard. For instructions on using this 
wizard, see Evaluate Bundles in Chapter 2, “Tasks.”

Domain Activation Wizard This contains fields and options for configuring and activating 
a domain in Guardian. Click Activate to open the Domain 
Activation Wizard. For details, see Domain Activation 
Wizard. For instructions on using this wizard, see Activate 
Domain in Chapter 2, “Tasks.”

Domain Deactivation Wizard In Domain Explorer, right-click on a domain entry and select 
Deactivate Domain from the context menu to open this 
wizard. This contains a table of all active domains. For details, 
see Domain Deactivation Wizard. For instructions on using this 
wizard, see Deactivate Domain in Chapter 2, “Tasks.”

Evaluation Wizard Click Evaluate to open the Evaluation Wizard for evaluating 
one or more domains. For details, see Evaluation Wizard. For 
instructions on using this wizard, see Evaluate Domain in 
Chapter 2, “Tasks.”
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Filters Wizard Click the Signature Explorer menu icon and select the Filters 
menu option. The Filters Wizard enables you to specify which 
signatures to display in Signature Lists. 

For details, see Filters Wizard. For instructions on using this 
wizard, see Filter Signatures in Chapter 2, “Tasks.”

Inventory Wizard Click Inventory to open the Inventory Wizard. A Domain 
Inventory is a snapshot of all of the configuration details for a 
domain as it exists at that moment. For details, see Inventory 
Wizard. For instructions on using this wizard, see Inventory 
Domain in Chapter 2, “Tasks.”

Shortcut Wizard Select File > New > Shortcut to open the Shortcut Wizard for 
creating and modifying Shortcuts. For details, see Shortcut 
Wizard. For instructions on using this wizard, see Create 
Shortcut in Chapter 2, “Tasks.”

Shortcut Evaluation Wizard Click the Shortcut Explorer tab to open the Shortcut 
Explorer. Then, double-click on a Shortcut name in the 
Shortcut list to open the Shortcut Evaluation Wizard. For 
details, see Shortcut Evaluation Wizard. For instructions on 
using this wizard, see Evaluate Shortcut in Chapter 2, “Tasks.”

Table 3-49  Guardian Wizards

Menu Item Description
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Wizard Titlebar Menus
Right-click a wizard titlebar to open a context menu of options to Move, Size, or Close the 
wizard. You can also move or resize a Wizard by dragging the titlebar or window borders.

Service Request Wizard Select a signature in an Evaluation Summary and click Get 
more help from Oracle Support. This opens the Service 
Request Wizard for the selected signature. This enables you to 
create a service request archive based on the selected signature. 
For details, see Service Request Wizard. For instructions on 
using this wizard, see Creating a Service Request Archive in 
Chapter 2, “Tasks.”

Update Wizard Click Update to open the Update Wizard. This wizard 
enables you to automatically download new Oracle Guardian 
software and signatures from the Oracle Guardian update site. 
For details, see Update Wizard. For instructions on using this 
wizard, see , “” in Chapter 2, “Tasks.”

WARNING: Upgrading from Guardian 1.0.x to Guardian 1.1 
must be done manually. For instructions, see Manually Update 
Guardian and Manually Update Guardian Registry in 
Chapter 2, “Tasks.” 

You can use the Update Wizard to automatically update 
Guardian when updating from Guardian 1.1.x to Guardian 10g 
R3 (10.3.0.0). You do not have to update manually in this case.

Table 3-49  Guardian Wizards

Menu Item Description
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Annotations Wizard
Use the Annotations Wizard to create an annotation for a selected signature.

To open the Annotations Wizard, first navigate to a signature list containing the signature you 
want to annotate. Then right-click on the signature title and select Annotations > Manage 
Annotations from the context menu. 

For instructions on using this wizard, see Signature Annotations in Chapter 2, “Tasks.”

The Annotations Wizard contains the following elements:

Table 3-50  Annotations Wizard

Element Description

Annotations Table This contains a list of the annotations that exist for the selected 
signature. For a description of Annotations table contents, see 
Annotations Table.

Add Click Add to open the Add Annotation dialog box for creating a 
new annotation for this signature. For instructions, see Annotate 
Signature in Chapter 2, “Tasks.”

Edit Click Edit to open the Edit Annotation dialog box for creating a 
new annotation for this signature. For instructions, see Edit 
Annotation in Chapter 2, “Tasks.”

Delete Select an annotation in the table and click Delete to remove that 
annotation from this signature. 

Note: There is no prompt for confirmation; the annotation is 
removed immediately. 

For instructions, see Delete Annotation in Chapter 2, “Tasks.”
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Annotations Table
The Annotations Wizard contains an Annotations table listing the annotations that exist for the 
selected signature. 

The Annotations table contains the following information for each annotation in the list:

Table 3-51  Annotations Wizard Annotations Table

Field Description

Type This is the type of annotation. This can be one of the following:
• Ignore — Ignore this signature for the specified targets. 
• Flag — Flag this signature for the specified targets.

Name This is the annotation name.

Comment This contains notes about the signature.

Timestamp This is the date and time the annotation was created.

Domains These are the target domain(s) for this annotation. 

Evaluations This is the evaluation set to which this annotation applies. This can 
be one of the following:
• This Evaluation Only
• All Evaluations

Note: This option is available only if the annotation was created 
for a signature in an Evaluation Summary. Annotations 
created from other locations do not have this specification.

Related Tasks
Basic Tasks

Preferences

Domains

Inventories and Evaluations

Signatures
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Signature Annotations

Bundles

Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Domain Explorer

Signature Explorer

Bundle Explorer

Document Views

Command Line Interface

Bundle Evaluation Wizard
Use the Bundle Evaluation Wizard to preselect a domain and Bundle for Evaluation, and then 
initiate the evaluation. 

To open the Bundle Evaluation Wizard, do the following:

1. In the Domain Explorer, open the Evaluation History folder.

2. Right-click on an Evaluation Summary and select Evaluate Bundle from the context menu.

This opens a submenu containing a list of Bundles available for evaluation. 

3. Select a Bundle to open the Bundle Evaluation Wizard for that Bundle. 

The Bundle Evaluation Wizard opens with the selected domain and Bundle preselected, 
just as if you had invoked a Shortcut. 

For instructions on using this wizard, see Evaluate Bundles in Chapter 2, “Tasks.”

The Bundles Evaluation Wizard contains the following sections and fields:
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Table 3-52  Bundle Evaluation Wizard

Sections Description

Available Domains Table This lists the currently active domains available to evaluate. The 
table contains the following fields:
• Name — This is the domain name.
• Admin Server URL — This is the URL for the WebLogic 

Server Administration Server for this domain.
• Bundle — This is the Signature Bundle to be used for the 

Shortcut Evaluation

Select a domain in this table to specify the domain to evaluate.

Bundle Menu This is a drop-down menu for selecting the Bundle to be used for this 
evaluation. Right-click the Bundle entry for a domain in the 
Available Domains table to display this menu. Select one of the 
following:
• All Signatures
• Configuration Remedy
• Critical Signatures
• Default Signatures
• JRockit JRA Signatures
• Other Signatures
• Patch Remedy
• Security Advisories
• Service Pack remedy
• Snapshot-All
• Snapshot-Deployment Descriptor
• Snapshot-JDBC
• Snapshot-JMS
• Snapshot-JRockit
• Snapshot-Security
• Upgrade Remedy

Username This is the username for a WebLogic Server Administrator or 
Monitor for this domain. 
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Related Tasks
Basic Tasks

Workspaces

Preferences

Domains

Domain Groups

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Command Line Interface

Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Domain Explorer

Signature Explorer

Password This is the password for the WebLogic Server Administrator or 
Monitor specified for Username.

Remember 
username/password 

Select this checkbox to encrypt and store the domain login 
credentials on disk. This saves you from having to enter the 
credentials each time you perform a domain operation.

Table 3-52  Bundle Evaluation Wizard

Sections Description
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Bundle Explorer

Shortcut Explorer

Evaluation Summary View

Text Compare View

Signature View

Signature Bundle View

Command Line Interface

Domain Activation Wizard
Use the Domain Activations Wizard to activate a domain in Guardian.

You can use any of the following methods to open the wizard:

Press Ctrl+Shift+A. 

Click Activate in the Main Toolbar. 

Select New > Domain from the File menu.

Click the Domain Explorer tab to open the Domain Explorer. Then, right-click anywhere 
in the Domain Explorer and select Activate Domain from the context menu.

For complete instructions on using this wizard, see Activate Domain in Chapter 2, “Tasks.”

Note: Oracle recommends using SSL encryption for communication between the client and the 
Guardian Agent. Guardian uses 128 bit open source encryption for SSL. However, the 
configuration on the server for the domain determines whether or not Guardian will use 
128 bit SSL encryption when activating that domain.

The Domain Activation Wizard contains the following tabs:

General Tab

Advanced Tab

These are described in the following sections. 
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General Tab
The General tab contains the following fields:

Table 3-53  Domain Activations Wizard — General Tab

Field Description

Protocol Select one of the following from the drop-down menu:

Note: Oracle recommends using SSL encryption for 
communication between the client and the Guardian Agent. 

• http:// — Select this to use the HTTP protocol without 
encryption.

• https:// — Select this to use HTTP protocol with Secure Sockets 
Layer (SSL) encryption (recommended). Guardian uses 128 bit 
open source encryption for SSL. However, the configuration on 
the server for the domain determines whether or not Guardian 
will use 128 bit SSL encryption when activating that domain.

Host Name This is the listen address for the WebLogic Administration Server in 
the target domain. 

Port Number This is the listen port for the WebLogic Administration Server for 
the target domain.

Username This is the username of a WebLogic Server Administrator or 
Monitor account on the target domain. 

Password This is the password for the WebLogic Server Administrator or 
Monitor account on the target domain. 

Remember 
Username/Password

This specifies that the domain credentials are to be stored so that you 
do not have to enter them for future domain operations. Usernames 
and passwords are encrypted when stored.
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Advanced Tab
The Advanced tab contains the following fields and options:

Table 3-54  Domain Activation Wizard — Advanced Tab

Field Description

Enable Proxy Connection Select this if a proxy server is to be used to access the target domain. 
Then, select a proxy server from the drop-down list. Click Add 
Proxy Servers to add proxy servers to this list. For complete 
instructions, see Add Inbound Proxy Servers in Chapter 2, “Tasks.”

Max. Agent Threads Specifies the maximum number of Agent threads to allocate in the 
WebLogic Server Administration Server. This can be an integer 
value from 1 to 20. The default is 10.

Agent Thread Timeout 
(secs)

Specifies the maximum number of seconds that can elapse before an 
Agent thread is deactivated while collecting data from managed 
servers. This can be an integer value from 10 to 600. The default is 
60. 

Domain Notes This is a text field in which you can enter text description or other 
details pertaining to this domain. These notes are displayed in 
inventories and evaluations for this domain.

Related Tasks
Basic Tasks

Guardian Agent

Preferences

Domains

Domain Groups

Proxy Servers

Inventories and Evaluations

Command Line Interface

Updates and Upgrades
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Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Domain Explorer 

Active Domains Table 

Domain Inventory View 

Evaluation Summary View 

Keyboard Shortcuts 

Command Line Interface

Domain Deactivation Wizard
You can use either of the following methods to open the Domain Deactivation Wizard:

In the Domain Explorer, right-click on a domain and select Deactivate from the context 
menu.

Select Window > Show View > Active Domains Table. Then, select a domain from the 
table and click Deactivate Domain. 

Select a domain and click Finish to deactivate the domain. 

Caution: You will not be prompted to confirm the deactivate operation. The domain will be 
deactivated immediately. 

For complete instructions on using this wizard, see Deactivate Domain in Chapter 2, “Tasks.”

The Domain Deactivation Wizard contains the following fields:
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Table 3-55  Domain Deactivation Wizard

Sections Description

Name This is the name for this domain. 

Admin Server URL This is the URL for the WebLogic Server Administration Server for 
this domain.

Related Tasks
Basic Tasks

Domains

Domain Groups

Command Line Interface

Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Domain Explorer 

Active Domains Table 

Domain Inventory View 

Evaluation Summary View 

Keyboard Shortcuts 

Command Line Interface
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Evaluation Wizard
Use the Evaluation Wizard to evaluate a domain. You can select one or more domains for 
evaluation.

You can use any of the following methods to select a domain and open the wizard:

In the Domain Explorer, select a domain and then click the Evaluation button. To select 
multiple domains, press the Ctrl or Shift key while selecting additional items.

Right-click on a domain and then select Evaluate from the context menu.

Double-click a domain name in the Domain Explorer. 

Select File > New > Evaluation from the titlebar. 

Select Window > Show View > Active Domains Table to display the Active Domains 
Table. Then, double-click a domain name to open the wizard for the selected domain. 

For complete instructions on using this wizard, see Evaluate Domain in Chapter 2, “Tasks.”

The Evaluation Wizard contains the following fields:

Table 3-56  Evaluation Wizard

Fields Description

Available Domains Table This lists the currently active domains available to evaluate. The 
table contains the following fields:
• Name — This is the domain name.
• Admin Server URL — This is the URL for the WebLogic 

Server Administration Server for this domain.
• Bundle — This is the Signature Bundle to be used for the 

Shortcut Evaluation

Select a domain in this table to specify the domain to evaluate.

Bundle Menu This is a drop-down menu for selecting the Bundle to be used for this 
evaluation. Right-click the Bundle entry for a domain in the 
Available Domains table to display a list of the available Bundles. 
Select a Bundle from the list.

Username This is the username for a WebLogic Server Administrator or 
Monitor for this domain. 
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Related Tasks
Basic Tasks

Workspaces

Preferences

Domains

Domain Groups

Proxy Servers

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Command Line Interface

Password This is the password for the WebLogic Server Administrator or 
Monitor specified for Username.

Remember 
username/password 

Select this checkbox to encrypt and store the domain login 
credentials on disk. This saves you from having to enter the 
credentials each time you perform a domain operation.

Create Shortcut Select this checkbox to create a Shortcut for this evaluation. This is 
useful if you routinely perform this particular type of evaluation. For 
detailed instructions on creating, evaluating, and managing 
Shortcuts, see the section entitled, Shortcuts in Chapter 2, “Tasks.”

Shortcut Name This is a text field for entering the name of the new Shortcut.

Table 3-56  Evaluation Wizard

Fields Description
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Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Command Line Interface

Domain Explorer 

Active Domains Table

Evaluation Summary View 

Text Compare View

Signature View

Service Request Wizard 

Filters Wizard
Use the Filters Wizard to specify which signatures to display in signature lists.

You can use either of the following methods to open the wizard:

From the Signature Explorer or Bundle Explorer:

In the Explorer toolbar, click the menu icon and select Filters... from the menu.

From an Evaluation Summary:

Right-click on any signature in the Detected Signatures list, and select Filters... from the 
context menu.

For complete instructions on using this wizard, see Filter Signatures in Chapter 2, “Tasks.”
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The Filters Wizard contains the following sections and fields:

Table 3-57  Filters Wizard Sections and Fields

Section Description

Name Filter according to name. This section contains the following fields 
and options:
• Show Name (radio button)
• Hide Name (radio button)
• Name — (Text field) Specify all or a portion of a signature 

name to use as the filter criteria. This can be a character string 
or standard regular expression. Enter .* to filter all signatures. 
The default is Show all (.*). 

Severity Filter according to severity. This section contains the following 
options:
• Show Severity
• Hide Severity

Select one of the above, and then select/deselect a severity level. 
These are:
• Critical
• Warning
• Information. 

The default is Show all (all selected).

Type Filter annotated signatures according to Annotation Type. This 
section contains the following options:

Show Type

Hide Type

Annotation Name
Select one of the above, and then select/deselect an Annotation 
Type. These are:
• Flag
• Ignore. 

The default is Hide signatures with an Annotation Type of Ignore. 
For more information on Annotation Types, see Signature 
Annotations in Chapter 1, “About Oracle Guardian.” 
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Related Tasks
Basic Tasks

Preferences

Domains

Domain Groups

Inventories and Evaluations

Annotation Name Filter annotated signatures according to Annotation Name. This 
section contains the following options:
• Show Annotation Name
• Hide Annotation Name
• Annotation Name — (Text field) Specify all or a portion of an 

annotation name to use as the filter criteria. This can be a 
character string or standard regular expression. Enter .* to filter 
all annotations. 

The default is Show all (.*). 

Comment Filter annotated signatures according to annotation comment. 
Specify all or a portion of a comment to use as the filter criteria. This 
can be a character string or standard regular expression. Enter .* to 
filter all signatures. The default is Show all (.*).

Domain Filter annotated signatures in this domain. This section contains the 
following options:
• Show Domain
• Hide Domain

The default is Show Domain.

Evaluation Filter annotated signatures in this Evaluation. This section contains 
the following options:
• Show Evaluation
• Hide Evaluation

The default is Show Evaluation.

Table 3-57  Filters Wizard Sections and Fields

Section Description
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Signatures

Signature Annotations

Bundles

Command Line Interface

Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Signature Explorer

Bundle Explorer

Evaluation Summary View

Signature View

Inventory Wizard
Use the Inventory Wizard to inventory a domain.

You can use any of the following methods to open the wizard:

Press Ctrl+Shift+I. 

Click Inventory on the Main Toolbar. 

Select File > New > Inventory. 

In the Domain Explorer, right-click on a domain name in the Domain Explorer tree and 
select Inventory from the context menu. 

For a description of Domain Inventories, see Domain Inventory in Chapter 1, “About Oracle 
Guardian.” For instructions on using the Domain Inventory Wizard, see Inventory Domain of 
Chapter 2, “Tasks.”

The Inventory Wizard contains the following sections and fields:
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Table 3-58  Inventory Wizard

Section/Field Description

Available Domains Table This lists the currently active domains available to inventory. The 
table contains the following fields:
• Name — This is the domain name.
• Admin Server URL — This is the URL for the WebLogic 

Server Administration Server for this domain.

Select a domain in this table to specify the domain to inventory.

Username This is the username for a WebLogic Server Administrator or 
Monitor for this domain. 

Password This is the password for the WebLogic Server Administrator or 
Monitor specified for Username.

Remember 
username/password 

Select this checkbox to encrypt and store the domain login 
credentials on disk. This saves you from having to enter the 
credentials each time you perform a domain operation.

Related Tasks
Basic Tasks

Workspaces

Preferences

Domains

Domain Groups

Proxy Servers

Inventories and Evaluations

Command Line Interface

Related Reference
Navigation Pane
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Document Pane

Preferences

Wizards

Command Line Interface

Domain Explorer

Active Domains Table 

Domain Activation Wizard 

Domain Inventory View 

Shortcut Wizard
Use the Shortcut Wizard to create an Evaluation Shortcut. 

You can use any of the following methods to open the wizard:

Press Ctrl+Shift+S. 

Select File > New > Shortcut.

Select Window > Show View > Shortcuts Table to open the Shortcuts Table. Then, 
click Add Shortcut in the Shortcuts Table toolbar. 

Right-click in the Domain Explorer or Shortcut Explorer and select Add Shortcut from 
the context menu. 

For a description of Shortcuts, see Shortcut in Chapter 1, “About Oracle Guardian.” For 
instructions, see Create Shortcut in Chapter 2, “Tasks.”
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The Shortcut Wizard contains the following sections and fields:

Table 3-59  Shortcut Wizard

Fields Description

Available Domains Table This lists the currently active domains available to evaluate. The 
table contains the following fields:
• Name — This is the domain name.
• Admin Server URL — This is the URL for the WebLogic 

Server Administration Server for this domain.
• Bundle — This is the Signature Bundle to be used for the 

Shortcut Evaluation

Select a domain in this table to specify the domain to evaluate.

Bundle Menu This is a drop-down menu for selecting the Bundle to be used for this 
evaluation. Right-click the Bundle entry for a domain in the 
Available Domains table to display a list of the available Bundles. 
Select a Bundle from the list.

Create Shortcut Select this checkbox to create a Shortcut for this evaluation. This is 
useful if you routinely perform this particular type of evaluation. For 
detailed instructions on creating, evaluating, and managing 
Shortcuts, see the section entitled, Shortcuts in Chapter 2, “Tasks.”

Shortcut Name This is a text field for entering the name of the new Shortcut.

Related Tasks
Basic Tasks

Preferences

Domains

Domain Groups

Inventories and Evaluations

Signatures

Signature Annotations
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Bundles

Shortcuts

Command Line Interface

Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Command Line Interface

Shortcuts Table 

Shortcut Explorer 

Domain Explorer

Active Domains Table 

Signature Bundle View 

Shortcut Evaluation Wizard 

Evaluation Summary View
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Shortcut Evaluation Wizard
Use the Shortcut Evaluation Wizard to evaluate a selected Shortcut.

You can use any of the following methods to open the wizard:

Select Window > Show View > Shortcuts Table to open the Shortcuts Table. Then, 
double-click on a Shortcut name in the Shortcut Table. 

Click the Shortcut Explorer tab to open the Shortcut Explorer. Then, double-click on a 
Shortcut name in the Shortcut list.

Click the Shortcut Explorer tab to open the Shortcut Explorer. Then, right-click on a 
Shortcut name in the Shortcut list and select Evaluate Shortcut from the context menu. 

For a description of Shortcuts, see Shortcut in Chapter 1, “About Oracle Guardian.” For 
instructions, see Evaluate Shortcut in Chapter 2, “Tasks.”

The Shortcut Evaluation Wizard contains the following sections and fields:

Table 3-60  Shortcut Evaluation Wizard

Fields Description

Available Domains Table This lists the currently active domains available to evaluate. The 
table contains the following fields:
• Name — This is the domain name.
• Admin Server URL — This is the URL for the WebLogic 

Server Administration Server for this domain.
• Bundle — This is the Signature Bundle to be used for the 

Shortcut Evaluation

Select a domain in this table to specify the domain to evaluate.

Bundle Menu This is a drop-down menu for selecting the Bundle to be used for this 
evaluation. Right-click the Bundle entry for a domain in the 
Available Domains table to display a list of the available Bundles. 
You can change the Bundle selection, but only for the current 
evaluation. The Bundle for that Shortcut will remain unchanged for 
future invocations of the Shortcut Evaluation Wizard.

Username This is the username for a WebLogic Server Administrator or 
Monitor for this domain. 
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Related Tasks
Basic Tasks

Preferences

Domains

Domain Groups

Inventories and Evaluations

Signatures

Signature Annotations

Bundles

Shortcuts

Command Line Interface

Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Command Line Interface

Shortcut Explorer 

Password This is the password for the WebLogic Server Administrator or 
Monitor specified for Username.

Remember 
username/password 

Select this checkbox to encrypt and store the domain login 
credentials on disk. This saves you from having to enter the 
credentials each time you perform a domain operation.

Table 3-60  Shortcut Evaluation Wizard

Fields Description
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Domain Explorer

Shortcuts Table 

Evaluation Summary View

Active Domains Table

Shortcut Wizard 

Evaluation Wizard 

Service Request Wizard
You can use the Service Request Wizard to create a service request archive based on a detected 
signature, which can be submitted to Oracle Customer Support at your convenience. 

To open the Service Request Wizard, do the following:

1. Open the Evaluation Summary containing the signature you want to include in the support 
service request.

Double-click on an Evaluation Summary entry in the Domain Explorer.

2. Select the signature you want to include in the support service request.

Click on a signature entry to highlight it. This displays the Description and Remedy for 
the signature in the bottom portion of the Evaluation Summary View in the Document 
Pane.

3. Click the Get more help from Oracle support link at the bottom of the signature Remedy 
section to open the wizard. 

For a description of a Guardian Service Request Archive, see Support Service Request in 
Chapter 1, “About Oracle Guardian.” For instructions on using the wizard, see Creating a Service 
Request Archive in Chapter 2, “Tasks.”
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The Service Request Wizard presents a series of pages that guide you through the service 
request creation process. These pages are as follows:

Table 3-61  Service Request Wizard

Page Description

Select Server Node Note: If there is only one server in your domain, then the 
Administration Server is used by default and this step is 
skipped.

Specifies the server node for the domain that has the detected 
signature. To change the server node preselected in the dialog box, 
select another server from the pull down list. 

Service Request Notes In the Additional Service Request Notes field, enter any additional 
text that may be helpful to Oracle customer support in resolving 
your service request. 

Select Service Request 
Attachments

Select the background information files to include with the service 
request. These attachments save the Oracle Support Engineer time 
so that your service request can be resolved more quickly. You can 
select one or more of the following:
• Service Request Attachments:

• Recommended Attachments:

• Other Attachments:

Domain Login Specify the username and password for a WebLogic Server 
Administrator or Monitor for this domain. 

Select Service Request 
Archive Destination

In the Select Archive Location field, enter the location to which to 
save the service request archive file, or click the ellipsis (...) to open 
a file browser from which you can select the location.

Related Tasks
Basic Tasks

Guardian Agent

Preferences

– Domain Inventory
– Detected Signature Results

– Server Log
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Proxy Servers

Inventories and Evaluations

Signatures

Bundles

Command Line Interface

Troubleshooting

Support

Updates and Upgrades

Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Command Line Interface

Evaluation Summary View 

Text Compare View

Signature View

Evaluation Wizard 

Update Wizard
Use the Update Wizard to update your Guardian software and signature Bundles.

You can use either of the following methods to open the wizard:

Press Ctrl+Shift+U. 

Click the Update button on the Main Toolbar. 

Select Help > Software Updates > Guardian Updates. 
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For a description of this feature, see Update Guardian in Chapter 1, “About Oracle Guardian.” 
For instructions on using the wizard, see Automatically Update Guardian in Chapter 2, “Tasks.”

The Update Wizard presents a series of pages that guide you through the update process. The 
following table describes each of these pages.

Table 3-62  Update Wizard

Page Description

My Oracle Support Login Enter your Oracle My Support Username and Password. Select the 
Remember username/password checkbox to encrypt and store the 
domain login credentials on disk. This will save you having to enter 
the credentials each time you use the Update Wizard.

Select CSI Select a Customer Support Identifier from the Select CSI menu. If 
you have only one CSI, this field is disabled.

No Updates Dialog Box If there are no new signatures or application features available, a 
dialog box prompts you to try again at a later time. 

Search Results If there are new signatures or application features available, this 
page displays the results. Expand the folders in the Select the 
features to install tree to see the available selections. 

Feature License Click the radio button to accept the terms in the license agreement 
and proceed with the installation.

Installation Location Select the installation location, or accept the default. Click Change 
Location to open a directory browser from which you can select the 
location. A progress indicator tracks the progress as the updates are 
downloaded. 

Feature Verification Verify the list of features to install, and click Install or Install All. 

Restart Guardian After the updates are installed, you are prompted as to whether to 
restart Guardian. Click Yes to restart Guardian and incorporate the 
new features. 

Related Tasks
Basic Tasks
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Guardian Agent

Workspaces

Preferences

Proxy Servers

Command Line Interface

Troubleshooting

Support

Updates and Upgrades

Related Reference
Navigation Pane

Document Pane

Preferences

Wizards

Main Toolbar

Command Line Interface

Log Files
The Oracle Guardian log files contain information that Oracle Customer Support can use to 
diagnose and resolve issues with your Guardian system. 
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The Guardian log files are as follows:

Table 3-63  Guardian Log Files

File Name Description

guardian.log This is located in the Guardian installation directory you specified 
during installation. This file contains information about every 
operation the Guardian application performs. 

signature.log This is located in the Guardian installation directory you specified 
during installation. This file contains information about each 
evaluation performed, including entries for all detected signatures. 
You can also use a command line script to automatically scan the 
signature.log for detected signatures, and to automatically 
receive notifications when new signatures are detected. 

.log This is located in the .metadata subdirectory of the Guardian 
Workspace directory you specified when starting Guardian. This file 
contains information about certain Guardian operations. 

install.log This is located in the subdirectory 
../configuration/org.eclipse.update  
residing in the Guardian installation directory you specified during 
installation. This file contains Guardian installation details. 
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Related Tasks
Basic Tasks

Workspaces

Preferences

Domains

Inventories and Evaluations

Command Line Interface

Troubleshooting

Support

Updates and Upgrades

Related Reference
Command Line Interface

Command Line Interface
The Guardian Command Line Interface (CLI)—also referred to as Guardian Headless Mode—is 
a set of Guardian commands that can be issued directly from the operating system command 
prompt. There is a Guardian CLI command for each of the most common tasks you can perform 
using the Guardian User Interface. 

The Guardian command interpreter is an executable .cmd batch file for Windows, and a .sh shell 
script for Linux. Both the Windows batch file and the Linux shell script are wrappers that 
accumulate and organize arguments to the Java command.

For instructions on starting and using the Command Line Interface, see Command Line Interface 
in Chapter 2, “Tasks.”

Important Notes
The following are some guidelines for using the Command Line Interface. For complete 
instructions on using the CLI commands, see Command Line Interface in Chapter 2, “Tasks.”
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The Command Line Interface uses your specified Guardian Workspace as the location for 
all CLI operations, unless you specify otherwise in each command. Identifying the 
Guardian Workspace location is essential for accessing the correct set of active domains, 
Domain Inventories, and Evaluation Summaries. For instructions on selecting a Guardian 
Workspace, see Select Workspace in Chapter 2, “Tasks.”

Guardian Command Line Interface commands are case sensitive.

Each command must include the prefix -g with no trailing space, as shown in the 
following example:

guardianHeadless.cmd -glistActiveDomains 

Quotes are required for command parameters only if the parameter contains a space.

On Linux, command output is directed by default to stdout and stderr. On Windows, 
command output is written to the following output file:

headless_output.txt

The output file is created in your current directory, and is overwritten each time you run a 
Guardian Headless Mode command. For instructions on redirecting this to a different file, 
see Redirecting Guardian CLI Command Output in Chapter 2, “Tasks.”

To create an output file containing the list of CLI commands and their syntax, type the 
following command at the operating system prompt:
guardianHeadless.cmd -ghelp 

The following section provides an overview of the Command Line Interface commands.

Overview of CLI Commands
The following table provides a brief description of each of the Guardian Command Line Interface 
commands. For a detailed description and syntax for each command, see CLI Command 
Reference.

Table 3-64  Guardian Command Line Interface Commands

Command Description

activateDomain Activate the specified domain and return the domain identifier. 

createShortcut Create a Shortcut for the specified domain and Bundle. 
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See Overview of CLI Commands for a detailed description of each of these commands.

deactivateDomain Deactivate the specified domain. 

deleteShortcut Delete the specified Shortcut. 

evaluateDomainBundle Evaluate the specified domain and Bundle. To see the results, 
open the Guardian User Interface and open the Domain 
Explorer > Evaluation History folder and select the 
evaluation. The results are displayed in the Evaluation 
Summary View in the Document Pane.

evaluateShortcut Evaluate the domain and Bundle associated with the specified 
Shortcut. To see the results, open the Guardian User Interface 
and open the Domain Explorer > Evaluation History folder 
and select the evaluation. The results are displayed in the 
Evaluation Summary View in the Document Pane.

help Display the list of commands and command syntax.

inventoryDomain Inventory the specified domain. To see the results, open the 
Guardian User Interface and open the Domain Explorer > 
Inventory History folder and select the inventory. The results 
are displayed in the Domain Inventory View in the Document 
Pane.

listActiveDomains List the active domains in Domain Identifier format.

listBundles List the Bundle identifier and Bundle name for each of the 
available Signature Bundles.

listShortcuts List the Shortcuts available for evaluation.

script Execute the commands contained in the specified script file.

Table 3-64  Guardian Command Line Interface Commands
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CLI Command Reference
This section describes the syntax, arguments, and usage for each of the Command Line Interface 
commands. For instructions on starting and using the Command Line Interface, see Command 
Line Interface in Chapter 2, “Tasks.”

activateDomain
Activate the specified domain and return the domain identifier.

activateDomain -t targetUrl -u username -p password  
[ -c persistCredentials ] [ -data workspaceDir ] [ -x proxy ]  
[ -m maxAgentThreads ] [ -o agentThreadTimeoutSecs ]

The arguments for this command are described in the following table:

Table 3-65  activateDomain Command Arguments

Argument Description

targetUrl (Without quotes) This is the address of the Administration Server for 
the domain, in the following format:
http://<listen-address>:<port-number>

username This is the username for the Administrator or Monitor account for 
the specified domain.

password This is the password for the Administrator or Monitor account for 
the specified domain.

persistCredentials (true or false, without quotes) This specifies whether to persist 
the username and password. If set to true, the login credentials will 
be saved on disk in encrypted form. The default is false.

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.

proxy (Without quotes) This is the proxy IP address and port, in the 
following format:
proxyIPaddress:port
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createShortcut
Create a Shortcut for the specified domain and Bundle.

createShortcut -d domainId [ -b bundleId ] [ -s shortcutName ]  
[ -data workspaceDir ] 

The arguments for this command are described in the following table:

Table 3-66  createShortcut Command Arguments

Argument Description

domainId This is the Domain Identifier for the Shortcut.

bundleId (Numeric) This is the Bundle Identifier for the Shortcut. The default 
is 0, which is the identifier for the Bundle named Default 
Signatures. Use the listBundles command to see the list of 
Bundle values.

shortcutName (In quotes) This is the name of the Shortcut. The default is:

"<bundle_name> in <domain_name>" 

For example:
Critical Signatures in TestDomain

Where:

Critical Signatures is the name of the Bundle and 
TestDomain is the domain name.

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.

maxAgentThreads Specifies the maximum number of Agent threads to allocate in the 
WebLogic Server Administration Server. This can be an integer 
value from 1 to 20. The default is 10.

agentThreadTimeoutSecs Specifies the maximum time in seconds before a Guardian Agent 
thread is terminated when collecting data from managed servers.

Table 3-65  activateDomain Command Arguments

Argument Description
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deactivateDomain
Deactivate the specified domain.

deactivateDomain -d domainId [ -l deleteUserData ] [ -data workspaceDir ] 

The arguments for this command are described in the following table:

Table 3-67  deactivateDomain Command Arguments

Argument Description

domainId This is the Domain Identifier of the domain to be deactivated.

deleteUserData (true or false, without quotes) This specifies whether to delete 
the Domain Inventories and Evaluation Summaries from the 
Guardian Workspace. The default is false.

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.

deleteShortcut
Delete the specified Shortcut. 

deleteShortcut -s shortcutName [ -data workspaceDir ] 

The arguments for this command are described in the following table:

Table 3-68  deleteShortcut Command Arguments

Argument Description

shortcutName (In quotes) This is the name of the Shortcut to be deleted, as listed 
in the output from the listShortcuts command. 

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.
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evaluateDomainBundle
Evaluate the specified domain and Bundle. To see the results, open the Guardian User Interface 
and open the Domain Explorer > Evaluation History folder and select the evaluation. The 
results are displayed in the Evaluation Summary View in the Document Pane. 

evaluateDomainBundle -d domainId [ -b bundleId ]  
[ -u username -p password ] [ -c persistCredentials ] [ -data workspaceDir ] 

The arguments for this command are described in the following table:

Table 3-69  evaluateDomainBundle Command Arguments

Argument Description

domainId This is the Domain Identifier of the domain to be evaluated.

bundleId (Numeric) This is the Bundle Identifier for the Bundle to be 
evaluated. The default is 0, which is the identifier for the Bundle 
named Default Signatures. Use the listBundles 
command to see the list of Bundle values.

username (Not required if persistCredentials is set to true in 
activateDomain.) This is the username for the Administrator or 
Monitor account for the specified domain.

password (Not required if persistCredentials is set to true in 
activateDomain) This is the password for the Administrator or 
Monitor account for the specified domain 

persistCredentials (true or false, without quotes) This specifies whether to persist 
the username and password. If set to true, the login credentials will 
be saved on disk in encrypted form. The default is false.

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.
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evaluateShortcut
Evaluate the domain and Bundle associated with the specified Shortcut. To see the results, open 
the Guardian User Interface and open the Domain Explorer > Evaluation History folder and 
select the evaluation. The results are displayed in the Evaluation Summary View in the 
Document Pane.

evaluateShortcut -s shortcutName [ -u username -p password ]  
[ -c persistCredentials ] [ -data workspaceDir ] 

The arguments for this command are described in the following table:

Table 3-70  evaluateShortcut Command Arguments

Argument Description

shortcutName (In quotes) This is the name of the Shortcut to be evaluated.

username (Not required if persistCredentials is set to true in 
activateDomain.) This is the username for the Administrator or 
Monitor account for the specified domain.

password (Not required if persistCredentials is set to true in 
activateDomain) This is the password for the Administrator or 
Monitor account for the specified domain.

persistCredentials (true or false, without quotes) This specifies whether to persist 
the username and password. If set to true, the login credentials will 
be saved on disk in encrypted form. The default is false.

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.

help 
Display the list of commands and command syntax.

There are no arguments for this command.
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inventoryDomain
Inventory the specified domain. To see the results, open the Guardian User Interface and open the 
Domain Explorer > Inventory History folder and select the inventory. The results are displayed 
in the Domain Inventory View in the Document Pane. 

inventoryDomain -d domainId [ -u username -p password ]

The arguments for this command are described in the following table:

Table 3-71  inventoryDomain Command Arguments

Argument Description

domainId This is the Domain Identifier of the domain to be evaluated.

username (Not required if persistCredentials is set to true in 
activateDomain.) This is the username for the Administrator or 
Monitor account for the specified domain.

password (Not required if persistCredentials is set to true in 
activateDomain) This is the password for the Administrator or 
Monitor account for the specified domain 

listActiveDomains
List the active domains in domain identifier format.

listActiveDomains [ -data workspaceDir ] 

The arguments for this command are described in the following table:

Table 3-72  listActiveDomains Command Arguments

Argument Description

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.
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listBundles
List the Bundle identifier and Bundle name for each of the available Signature Bundles.

listBundles [ -data workspaceDir ] 

The arguments for this command are described in the following table:

Table 3-73  listBundles Command Arguments

Argument Description

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.

listShortcuts
List the Shortcuts available for evaluation.

listShortcuts [ -data workspaceDir ] 

The arguments for this command are described in the following table:

Table 3-74  listShortcuts Command Arguments

Argument Description

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.

script
Execute the commands contained in the specified script file.

script -f scriptname [ -data workspaceDir ] 

The arguments for this command are described in the following table:
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Table 3-75  script Command Arguments

Argument Description

scriptname This is the name of a script file containing Guardian commands. 
Each command must be on a separate line. For instructions, see Run 
Scripts in Chapter 2, “Tasks.”

workspaceDir (In quotes) This is the absolute pathname for the Guardian 
Workspace.

Related Tasks
Basic Tasks

Guardian Agent

Workspaces

Domains

Proxy Servers

Inventories and Evaluations

Signatures

Bundles

Shortcuts

Command Line Interface

Troubleshooting

Updates and Upgrades

Related Reference
Wizards

Log Files

Domain Explorer
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Signature Explorer

Bundle Explorer

Shortcut Explorer

Domain Inventory View

Evaluation Summary View

Text Compare View

Signature View

Signature Bundle View

Active Domains Table

Shortcuts Table
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Appendix A: Apache License
Apache License
The following applies to all products licensed under the Apache 2.0 License. You may not use 
the identified files except in compliance with the Apache License, Version 2.0 (the "License"). 
You may obtain a copy of the License at: http://www.apache.org/licenses/LICENSE-2.0. A copy 
of the license is also reproduced below. Unless required by applicable law or agreed to in writing, 
software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT 
WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License 
for the specific language governing permissions and limitations under the License. 

Apache License 
Version 2.0, January 2004 

http://www.apache.org/licenses/ 

TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION 

1. Definitions.

"License" shall mean the terms and conditions for use, reproduction, and distribution as defined 
by Sections 1 through 9 of this document. 

"Licensor" shall mean the copyright owner or entity authorized by the copyright owner that is 
granting the License. 

"Legal Entity" shall mean the union of the acting entity and all other entities that control, are 
controlled by, or are under common control with that entity. For the purposes of this definition, 
"control" means (i) the power, direct or indirect, to cause the direction or management of such 
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entity, whether by contract or otherwise, or (ii) ownership of fifty percent (50%) or more of the 
outstanding shares, or (iii) beneficial ownership of such entity. 

"You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by 
this License. 

"Source" form shall mean the preferred form for making modifications, including but not limited 
to software source code, documentation source, and configuration files.

"Object" form shall mean any form resulting from mechanical transformation or translation of a 
Source form, including but not limited to compiled object code, generated documentation, and 
conversions to other media types. 

"Work" shall mean the work of authorship, whether in Source or Object form, made available 
under the License, as indicated by a copyright notice that is included in or attached to the work 
(an example is provided in the Appendix below).

"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or 
derived from) the Work and for which the editorial revisions, annotations, elaborations, or other 
modifications represent, as a whole, an original work of authorship. For the purposes of this 
License, Derivative Works shall not include works that remain separable from, or merely link (or 
bind by name) to the interfaces of, the Work and Derivative Works thereof. 

"Contribution" shall mean any work of authorship, including the original version of the Work and 
any modifications or additions to that Work or Derivative Works thereof, that is intentionally 
submitted to Licensor for inclusion in the Work by the copyright owner or by an individual or 
Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this 
definition, "submitted" means any form of electronic, verbal, or written communication sent to 
the Licensor or its representatives, including but not limited to communication on electronic 
mailing lists, source code control systems, and issue tracking systems that are managed by, or on 
behalf of, the Licensor for the purpose of discussing and improving the Work, but excluding 
communication that is conspicuously marked or otherwise designated in writing by the copyright 
owner as "Not a Contribution." 

"Contributor" shall mean Licensor and any individual or Legal Entity on behalf of whom a 
Contribution has been received by Licensor and subsequently incorporated within the Work. 

2. Grant of Copyright License.  Subject to the terms and conditions of this License, each 
Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, 
irrevocable copyright license to reproduce, prepare Derivative Works of, publicly display, 
publicly perform, sublicense, and distribute the Work and such Derivative Works in Source or 
Object form. 
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3. Grant of Patent License.  Subject to the terms and conditions of this License, each 
Contributor hereby grants to You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, 
irrevocable (except as stated in this section) patent license to make, have made, use, offer to sell, 
sell, import, and otherwise transfer the Work, where such license applies only to those patent 
claims licensable by such Contributor that are necessarily infringed by their Contribution(s) alone 
or by combination of their Contribution(s) with the Work to which such Contribution(s) was 
submitted. If You institute patent litigation against any entity (including a cross-claim or 
counterclaim in a lawsuit) alleging that the Work or a Contribution incorporated within the Work 
constitutes direct or contributory patent infringement, then any patent licenses granted to You 
under this License for that Work shall terminate as of the date such litigation is filed.

4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works 
thereof in any medium, with or without modifications, and in Source or Object form, provided 
that You meet the following conditions: 

(a) You must give any other recipients of the Work or Derivative Works a copy of this License; 
and 

(b) You must cause any modified files to carry prominent notices stating that You changed the 
files; and (

c) You must retain, in the Source form of any Derivative Works that You distribute, all copyright, 
patent, trademark, and attribution notices from the Source form of the Work, excluding those 
notices that do not pertain to any part of the Derivative Works; and 

(d) If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative 
Works that You distribute must include a readable copy of the attribution notices contained 
within such NOTICE file, excluding those notices that do not pertain to any part of the Derivative 
Works, in at least one of the following places: within a NOTICE text file distributed as part of the 
Derivative Works; within the Source form or documentation, if provided along with the 
Derivative Works; or, within a display generated by the Derivative Works, if and wherever such 
third-party notices normally appear. The contents of the NOTICE file are for informational 
purposes only and do not modify the License. 

You may add Your own attribution notices within Derivative Works that You distribute, 
alongside or as an addendum to the NOTICE text from the Work, provided that such additional 
attribution notices cannot be construed as modifying the License. You may add Your own 
copyright statement to Your modifications and may provide additional or different license terms 
and conditions for use, reproduction, or distribution of Your modifications, or for any such 
Derivative Works as a whole, provided Your use, reproduction, and distribution of the Work 
otherwise complies with the conditions stated in this License. 
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5.Submission of Contributions.  Unless You explicitly state otherwise, any Contribution 
intentionally submitted for inclusion in the Work by You to the Licensor shall be under the terms 
and conditions of this License, without any additional terms or conditions. Notwithstanding the 
above, nothing herein shall supersede or modify the terms of any separate license agreement you 
may have executed with Licensor regarding such Contributions. 

6. Trademarks.  This License does not grant permission to use the trade names, trademarks, 
service marks, or product names of the Licensor, except as required for reasonable and customary 
use in describing the origin of the Work and reproducing the content of the NOTICE file. 

7. Disclaimer of Warranty.  Unless required by applicable law or agreed to in writing, Licensor 
provides the Work (and each Contributor provides its Contributions) on an "AS IS" BASIS, 
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied, 
including, without limitation, any warranties or conditions of TITLE, NON-INFRINGEMENT, 
MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely 
responsible for determining the appropriateness of using or redistributing the Work and assume 
any risks associated with Your exercise of permissions under this License. 

8. Limitation of Liability.  In no event and under no legal theory, whether in tort (including 
negligence), contract, or otherwise, unless required by applicable law (such as deliberate and 
grossly negligent acts) or agreed to in writing, shall any Contributor be liable to You for damages, 
including any direct, indirect, special, incidental, or consequential damages of any character 
arising as a result of this License or out of the use or inability to use the Work (including but not 
limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any 
and all other commercial damages or losses), even if such Contributor has been advised of the 
possibility of such damages. 

9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative 
Works thereof, You may choose to offer, and charge a fee for, acceptance of support, warranty, 
indemnity, or other liability obligations and/or rights consistent with this License. However, in 
accepting such obligations, You may act only on Your own behalf and on Your sole 
responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, 
and hold each Contributor harmless for any liability incurred by, or claims asserted against, such 
Contributor by reason of your accepting any such warranty or additional liability. 

END OF TERMS AND CONDITIONS 

APPENDIX: How to apply the Apache License to your work

To apply the Apache License to your work, attach the following boilerplate notice, with the fields 
enclosed by brackets "[]" replaced with your own identifying information. (Don't include the 
brackets!) The text should be enclosed in the appropriate comment syntax for the file format.  
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We also recommend that a file or class name and description of purpose be included on the same 
"printed page" as the copyright notice for easier identification within third-party archives.

Copyright 2008 [name of copyright owner] Licensed under the Apache License, 

Version 2.0 (the "License"); you may not use this file except in compliance 

with the License. You may obtain a copy of the License at 

http://www.apache.org/licenses/LICENSE-2.0. Unless required by applicable 

law or agreed to in writing, software distributed under the License is 

distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY 

KIND, either express or implied. See the License for the specific language 

governing permissions and limitations under the License.

Apache Modules
Apache xerces 
Available at: http://xerces.apache.org/

Some portions of this source:

Copyright (c) 2000 World Wide Web Consortium, (Massachusetts Institute of Technology, 
Institut National de Recherche en Informatique et en Automatique, Keio University).

Some portions of this source:

Copyright (c) 1999,2000 The Apache Software Foundation.

Apache log4j
Available at: http://logging.apache.org/log4j/docs/

Copyright 2007 The Apache Software Foundation

Apache commons http client 
Available at: http://jakarta.apache.org/commons/httpclient/

Copyright 1999-2008 The Apache Software Foundation.

Apache commons lang
Available at: http://jakarta.apache.org/commons/lang/

Copyright 2001-2008 The Apache Software Foundation.
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Apache commons logging 
Available at: http://jakarta.apache.org/commons/logging/

Copyright 2003-2007 The Apache Software Foundation.

Apache XMLbeans available at http://xmlbeans.apache.org/
Portions of this software were originally based on BEA Systems software, copyright (c) 
2000-2003, BEA Systems. Available at: http://www.bea.com/

Aside from contributions to the Apache XMLBeans project, this software also includes:

One or more source files from the Apache Xerces-J and Apache Axis products

Copyright (c) 1999-2003 Apache Software Foundation.

W3C XML Schema Documents

Copyright 2001-2003 (c) World Wide Web Consortium (Massachusetts Institute of 
Technology, European Research Consortium for Informatics and Mathematics, Keio 
University)

resolver.jar from Apache Xml Commons project,

Copyright (c) 2001-2003 Apache Software Foundation.

Piccolo XML Parser for Java

Available at: http://piccolo.sourceforge.net/

Copyright 2002 Yuval Oren under the terms of the Apache Software License 2.0.

JSR-173 Streaming API for XML

Available at: http://sourceforge.net/projects/xmlpullparser/

Copyright 2005 BEA under the terms of the Apache Software License 2.0.

Apache lucene 
Available at: http://lucene.apache.org/java/docs/

Copyright 2006 The Apache Software Foundation.

Spring framework
Available at: http://www.springframework.org/

Copyright 2002-2008 the original author or authors.
A-214 Oracle Guardian User Guide



Apache  L icense
Apache batik
Available at: http://xmlgraphics.apache.org/batik/

Copyright 1999-2007 The Apache Software Foundation.

Apache commons codec
Available at: http://commons.apache.org/codec/

Copyright 2001-2008 The Apache Software Foundation.

Apache derby
Available at: http://db.apache.org/derby/

Copyright 2004-2008 The Apache Software Foundation.

Apache tomcat
Available at: http://tomcat.apache.org/

Copyright (c) 1999 The Apache Software Foundation.

Jetty
Available at: http://www.mortbay.org/jetty

Copyright 2006 Mort Bay Consulting Pty. Ltd.

Stax
Available at: http://stax.codehaus.org/

Some portions of this source:

Copyright (c) 2000 The Apache Software Foundation.

Some portions of this source:

Copyright (c) 2003 by BEA Systems.
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cglib
Available at: http://cglib.sourceforge.net/

Some portions of this source:

Copyright (c) 2000,2002,2003 INRIA, France Telecom.

Some portions of this source:

Copyright 2003,2004 The Apache Software Foundation.
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Appendix B: Eclipse License
Eclipse Foundation Software User Agreement
March 17, 2005

Usage Of Content
THE ECLIPSE FOUNDATION MAKES AVAILABLE SOFTWARE, DOCUMENTATION, 
INFORMATION AND/OR OTHER MATERIALS FOR OPEN SOURCE PROJECTS 
(COLLECTIVELY "CONTENT"). USE OF THE CONTENT IS GOVERNED BY THE 
TERMS AND CONDITIONS OF THIS AGREEMENT AND/OR THE TERMS AND 
CONDITIONS OF LICENSE AGREEMENTS OR NOTICES INDICATED OR 
REFERENCED BELOW. BY USING THE CONTENT, YOU AGREE THAT YOUR USE OF 
THE CONTENT IS GOVERNED BY THIS AGREEMENT AND/OR THE TERMS AND 
CONDITIONS OF ANY APPLICABLE LICENSE AGREEMENTS OR NOTICES 
INDICATED OR REFERENCED BELOW. IF YOU DO NOT AGREE TO THE TERMS AND 
CONDITIONS OF THIS AGREEMENT AND THE TERMS AND CONDITIONS OF ANY 
APPLICABLE LICENSE AGREEMENTS OR NOTICES INDICATED OR REFERENCED 
BELOW, THEN YOU MAY NOT USE THE CONTENT.

Applicable Licenses
Unless otherwise indicated, all Content made available by the Eclipse Foundation is provided to 
you under the terms and conditions of the Eclipse Public License Version 1.0 ("EPL"). A copy of 
the EPL is provided with this Content and is also available at 
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http://www.eclipse.org/legal/epl-v10.html. For purposes of the EPL, "Program" will mean the 
Content.

Content includes, but is not limited to, source code, object code, documentation and other files 
maintained in the Eclipse.org CVS repository ("Repository") in CVS modules ("Modules") and 
made available as downloadable archives ("Downloads").

Content may be structured and packaged into modules to facilitate delivering, extending, 
and upgrading the Content. Typical modules may include plug-ins ("Plug-ins"), plug-in 
fragments ("Fragments"), and features ("Features").

Each Plug-in or Fragment may be packaged as a sub-directory or JAR (Java™ ARchive) in 
a directory named "plugins".

A Feature is a bundle of one or more Plug-ins and/or Fragments and associated material. 
Each Feature may be packaged as a sub-directory in a directory named "features". Within a 
Feature, files named "feature.xml" may contain a list of the names and version numbers of 
the Plug-ins and/or Fragments associated with that Feature.

Features may also include other Features ("Included Features"). Within a Feature, files 
named "feature.xml" may contain a list of the names and version numbers of Included 
Features.

The terms and conditions governing Plug-ins and Fragments should be contained in files named 
"about.html" ("Abouts"). The terms and conditions governing Features and Included Features 
should be contained in files named "license.html" ( "Feature Licenses"). Abouts and Feature 
Licenses may be located in any directory of a Download or Module including, but not limited to 
the following locations:

    * The top-level (root) directory

    * Plug-in and Fragment directories

    * Inside Plug-ins and Fragments packaged as JARs

    * Sub-directories of the directory named "src" of certain Plug-ins

    * Feature directories

Note: If a Feature made available by the Eclipse Foundation is installed using the Eclipse 
Update Manager, you must agree to a license ("Feature Update License") during the 
installation process. If the Feature contains Included Features, the Feature Update 
License should either provide you with the terms and conditions governing the Included 
Features or inform you where you can locate them. Feature Update Licenses may be 
found in the "license" property of files named "feature.properties" found within a 
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Feature. Such Abouts, Feature Licenses, and Feature Update Licenses contain the terms 
and conditions (or references to such terms and conditions) that govern your use of the 
associated Content in that directory.

THE ABOUTS, FEATURE LICENSES, AND FEATURE UPDATE LICENSES MAY REFER 
TO THE EPL OR OTHER LICENSE AGREEMENTS, NOTICES OR TERMS AND 
CONDITIONS. SOME OF THESE OTHER LICENSE AGREEMENTS MAY INCLUDE 
(BUT ARE NOT LIMITED TO):

Common Public License Version 1.0  
(available at http://www.eclipse.org/legal/cpl-v10.html)

Apache Software License 1.1  
(available at http://www.apache.org/licenses/LICENSE)

Apache Software License 2.0  
(available at http://www.apache.org/licenses/LICENSE-2.0)

IBM Public License 1.0  
(available at http://oss.software.ibm.com/developerworks/opensource/license10.html)

Metro Link Public License 1.00  
(available at http://www.opengroup.org/openmotif/supporters/metrolink/license.html)

Mozilla Public License Version 1.1  
(available at http://www.mozilla.org/MPL/MPL-1.1.html)

IT IS YOUR OBLIGATION TO READ AND ACCEPT ALL SUCH TERMS AND 
CONDITIONS PRIOR TO USE OF THE CONTENT. If no About, Feature License, or Feature 
Update License is provided, please contact the Eclipse Foundation to determine what terms and 
conditions govern that particular Content.

Cryptography
Content may contain encryption software. The country in which you are currently may have 
restrictions on the import, possession, and use, and/or re-export to another country, of encryption 
software. BEFORE using any encryption software, please check the country’s laws, regulations 
and policies concerning the import, possession, or use, and re-export of encryption software, to 
see if this is permitted.

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United 
States, other countries, or both. 
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Eclipse Modules
org.eclipse.ant
Copyright 1999-2008 The Apache Software Foundation.

Copyright (c) 2000, 2008 IBM Corporation and others.

org.eclipse.birt
Copyright (c) 2004 Actuate Corporation.

org.eclipse.core
Copyright (c) 2005, 2008 IBM Corporation and others.

org.eclipse.datatools
Copyright (c) 2001, 2004 IBM Corporation and others.

org.eclipse.emf
Copyright (c) 2002, 2007 IBM Corporation and others.

org.eclipse.help
Copyright (c) 2006, 2007 IBM Corporation and others.

Copyright (c) 2000, 2005 IBM Corporation and others.

org.eclipse.jface
Copyright (c) 2006 IBM Corporation and others.

org.eclipse.osgi
Copyright (c) 2003, 2008 IBM Corporation and others.

org.eclipse.rcp
Copyright (c) 2003, 2005 IBM Corporation and others.

org.eclipse.swt
Copyright (c) 2000, 2008 IBM Corporation and others.

org.eclipse.text
Copyright (c) 2000, 2006 IBM Corporation and others.
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org.eclipse.tomcat
Copyright (c) 2000, 2006 IBM Corporation and others.

org.eclipse.ui
Copyright (c) 2000, 2007 IBM Corporation and others.

org.eclipse.update
Copyright (c) 2000, 2006 IBM Corporation and others.

AspectJ
Copyright (c) 1999-2001 Xerox Corporation, 2002 Palo Alto Research Center, Incorporated 
(PARC).

Equinox
Copyright (c) 1997-2007 by ProSyst Software GmbH.

Copyright (c) 2006, 2008 IBM Corporation and others.
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