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Preface 
The Oracle|Agile documentation set includes Adobe® Acrobat™ PDF files. The Oracle Technology 
Network (OTN) Web site http://www.oracle.com/technology/documentation/agile.html contains the 
latest versions of the Oracle|Agile PLM PDF files. You can view or download these manuals from 
the Web site, or you can ask your Agile administrator if there is an Oracle|Agile Documentation 
folder available on your network from which you can access the Oracle|Agile documentation (PDF) 
files. 

Note To read the PDF files, you must use the free Adobe Acrobat Reader™ version 7.0 or later. 
This program can be downloaded from the Adobe Web site http://www.adobe.com. 

The Oracle Technology Network (OTN) Web site 
http://www.oracle.com/technology/documentation/agile.html can be accessed through Help > Manuals 
in both the Agile Web Client and the Agile Java Client. If you need additional assistance or 
information, please contact support http://www.oracle.com/agile/support.html 
(http://www.oracle.com/agile/support.html) for assistance. 

Note Before calling Agile Support about a problem with an Oracle|Agile PLM manual, please 
have the full part number, which is located on the title page. 

TTY Access to Oracle Support Services 

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479. 

 

Readme 

Any last-minute information about Oracle|Agile PLM can be found in the Readme file on the Oracle 
Technology Network (OTN) Web site http://www.oracle.com/technology/documentation/agile.html
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Agile Training Aids 

Go to the Oracle University Web page 
http://www.oracle.com/education/chooser/selectcountry_new.html for more information on Agile 
Training offerings. 

Accessibility of Code Examples in Documentation  

Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise empty line; 
however, some screen readers may not always read a line of text that consists solely of a bracket or 
brace.  

Accessibility of Links to External Web Sites in Documentation  

This documentation may contain links to Web sites of other companies or organizations that Oracle 
does not own or control. Oracle neither evaluates nor makes any representations regarding the 
accessibility of these Web sites.  
 

http://www.oracle.com/education/chooser/selectcountry_new.html
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Chapter 1 

Introducing Viewer 
This chapter includes the following: 

 How to Use this Manual....................................................................................................................................... 9 
 Getting Help......................................................................................................................................................... 10 
 About Viewer ....................................................................................................................................................... 10 
 What's New in this Release ................................................................................................................................. 11 
 Viewer Window.................................................................................................................................................... 12 
 Understanding the Viewer ................................................................................................................................... 12 

 
 

How to Use this Manual 
This manual is a supplement to Agile Viewer online Help. It is intended to be used in conjunction 
with the viewer online help and other Oracle|Agile manuals. 

The viewer has been integrated into the Agile system to make use of the Agile’s ability to manage 
attached files by using Agile system features. The integration also streamlines the viewer menus, 
toolbars, and shortcuts. The following table shows where you can find information about Agile 
features and concepts which you may find useful. 

Feature  or  concept  Conta ined in  th is  document  

Java Client Navigation Getting Started with Agile PLM User Guide, 
Chapter 2, "Navigating in Agile Java Client" 

Web Client Navigation Getting Started with Agile PLM User Guide, 
Chapter 3, "Navigating in Agile Web Client" 

Relationships and rules between objects Getting Started with Agile PLM User Guide, 
Chapter 5, "Working with Business Objects" 

Attachment files 

Working with file folder objects 

File folder mass update 

Routing and reviewing file folders 

File validation (Handle Check Sum) 

Viewing and redlining file folder contents 

Getting Started with Agile PLM User Guide, 

Chapter 9, "Navigating in Agile Web Client" 

and 

Chapter 10, "Working with File Folders" 

Redlining through ECOx, MCOs and SCOs Product Collaboration User Guide, 
Chapter 5, "Changes" 

Note To find an Agile PLM document, choose Help > Manuals in the Java Client or the Web 
Client to display the Agile PLM documentation web page. 

 

Agile Product Lifecycle Management Page - 9 

 

 



Viewer Supplement   
 
 
 

Getting Help 
To get help at any time, choose Help > Contents in the Agile Viewer menu bar. The viewer online help 
is displayed; it includes detailed information about using viewer features. 

Note See “Agile-specific Features and Functions (on page 17)” for a complete list of features 
and user interface details described in the viewer online Help that have been modified in 
order to integrate the viewer with the Agile system. 

 

About Viewer 
Viewer can display many different file formats without their authoring applications. You can view 
files from many database, graphic, spreadsheet, word-processing, and CAD applications. Even 
archive files can be listed and viewed without the need to decompress them. It isn’t necessary for 
you to identify the file type; Viewer automatically identifies the type of file you are requesting it to 
read. The Agile administrator determines which types of files can be viewed by setting the 
Supported File Types property  and Structured File Types property in the Agile Administrator 
module in Java Client.       

Important To view files through the Advanced Viewer, you need Agile Discovery, Read, and 
ViewFile privileges. To redline files through the Advanced Viewer, you need the 
appropriate privileges that allow you to redline attachment files (for example, the Agile 
default role Markup for Self). 

The action of attaching your comments, notes, and drawings to a document is known as marking 
up, also commonly known as annotating or redlining. A markup refers to the change being made to 
a document by attaching a markup object. You can use Viewer to mark up files as well as view 
them. 

Note Agile Java Client and Agile Web Client support attachment redlining. Markups for ECOs 
can be made on the Redline Attachments tab in Java Client and Web Client. You access the 
appropriate redline tab on the Affected Items tabs of ECOs. Markups for a file folder object 
can be made on the Files tab of the file folder object in Java Client and Web Client and do 
not require an ECO. 

Some of Viewer’s features are: 

 Flexible user-defined objects — Viewer offers a vast selection of markup objects, including circles, 
clouds, polygons, and arrows. Text can be attached to objects, and lengthier comments can be 
contained in embedded notes. 

See Viewer online help for a detailed discussion of markup objects. Choose Help > Contents in 
the Viewer menu bar. 

 Storage of unedited original documents — Original documents are never changed. All your notes 
and drawings are saved in a separate file called a markup file, although when viewed they 
appear to be part of the main document. You do not have to manage the storage and retrieval 
of markup files; Agile does that for you. 

 Support for non-English languages and operating systems — Viewer works with many non-English 
languages, and has been tested on Japanese, Chinese, French, German, Hebrew, and 
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Swedish operating systems. 

added to this release: 

 

lies 
D 

 

What's New in this Release 
The following new features have been 

Viewing Structured CAD Designs 

This Agile PLM release supports the ability to view data, such as CAD data, stored in Agile as 
item structures.  The typical use case is for viewing mechanical or electronic CAD assemb
saved into "DocuBOM" structures in Agile using the Engineering Collaboration (EC) CA
Connectors. See Viewing File Folder Structured File Types on page 21. 

 

 

 viewer itself. 

Ability to Search and Browse Agile Data from within the Viewer 

In previous releases, when entering the viewer for a more complex operation such as 
Compare, Cross Probe, or Digital Mockup, it was necessary to select all desired files in Agile
PLM  prior to the viewer starting.  This release provides new Agile Search and Agile Browse 
buttons within the viewer commands, to retrieve additional files from within the
See Opening Agile Attachment Files from the Viewer Window (on page 19). 

The Compare function has extended so the user can initiate the Agile PLM    to 

g the viewer window. See Comparing Revisions or Versions of a File

View command
view a particular file and the Viewer Compare command will contain a pre-loaded list of 
additional revisions or versions of the file to be compared against.  This provides a simple 
process to perform repetitive Compare commands against multiple revisions or versions 
without leavin  (on page 

LM 9.2.2.4 
 

  
 in 

all the Files table rows. 

 er feature opens a version browser window 

 object 
 the specified version. 

ss to support an Agile PLM 

 
 

s menu. The Version Browser displays information about all versions of the 
re. 

 A il

21). 
 

What's New in Agile P
File folders and attachments: 

Bulk download of business object attachments in Web Client by using Get All Files button to
download a zip file of all the Attachment table rows. Bulk download of file folder files
Web Client by using Actions > Get All Files to download a zip file of 
When using Advanced File Productivity components, the user can choose to either 
download the files to a specified directory or download a zip file. 

 File folder Routing Slip tab is version-specific; each version can have a different set of 
approvers and observers. 
In Web Client, file folder Actions > Version Brows
which lists information about all versions of the file folder. You can select files in the 
Version Browser window to view or compare. 

 The Checkin User field is available on the File Folders Title Block tab and the business
Attachments tab. Identifies the user who checked in

 The Designs class is added to the File Folders base cla
Engineering Collaboration (EC) CAD integration. 
Attached URLs can be up to 255 characters in length. 
A Version Browser is added to the Web Client File Folder class objects and Design class 
objects Action
File Folder or Designs object. You can select Version Browser rows to view or compa

e Viewer: g
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 arkups allows you to promote or copy 

 r Ad Hoc markups allows you to promote or copy Ad Hoc markups 
from previous version to the current version. 

esign objects and their corresponding Design Structures in order 

 

You e item Attachments tab or the file folder Files tab. 

To s e Viewer in Java Client: 

u . 

ele

 drop-down arrow and select View 

Markup promotion for change-based redline m
redline markups from previous versions to the current version. 
Markup promotion fo

 Agile Viewer can view D
to view 3D models. 

Viewer Window 
 can start the Viewer from either th

tart th

Do ble-click the attachment row

Or 

1. S ct one or more rows. 

2. Click the View File(s) button’s  from the menu. 

Note If the View  icon is visible on the button, you can simply click the button. 

To start the Viewer in Web Client: 

ble. 

ele

ct View 

Click the file name link in the ta

Or 

1. S ct one or more rows. 

2. Click the View File(s) button’s drop-down arrow and sele  from the menu. 

ote N If the View  icon is visible on the button, you can simply click the button. 

When you sta r window appears.         

ment Files in 

rt Viewer, the main Viewe

Note For more information about starting the Viewer, see Opening Agile Attach
the Viewer (on page 17). 

 

Viewing an Attachment Tab Row with Multiple Files 
When wing files from the  vie

 to iles window lists the 
files in that file folder an lect one or more files that you want to view. 

Viewer, see Opening Agile Attachment Files 

Attachments tab of an Agile business object, if you view a single row that 
refers a multiple-file file folder, the Select Files window appears. The Select F

d allows you to se

Note For more information about starting the Agile 
in the Viewer (on page 17). 

 

e Viewer 
The following sections describe the main Viewer window and performance modes, plus other 
information needed to use Viewer. 

Understanding th
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Viewer Modes 
Viewer has two performance modes: View and Markup. 

View Mode 

When a document is first opened from business object’s Attachments tab or file folder Files tab, the 
menu bar and toolbars are those of View mode. View mode is Agile Viewer’s default mode. 
Documents can be edited or marked up only from Markup mode, described in the next section.      

Markup Mode 

When Agile Viewer is in Markup mode, the currently displayed document can be marked up. That 
is, you can redline or annotate it. Available markup objects include various shapes, notes, symbols, 
and text. When you open Agile Viewer from the Redline Attachments tab or Files tab in a file folder 
object, Agile Viewer opens either in View or Markup mode, depending on whether the attachment 
has a saved markup and the privileges assigned to the user. If the attachment is checked out, then 
the redlining will not be allowed, however, you can change to Agile Viewer Markup mode to display 
saved markup. For instructions on how to enter Markup mode from View mode, see “Guidelines for 
Marking Up or Redlining Attachments (on page 25)”. When you open a markup file, Markup mode 
starts automatically. 

Note Markup mode is available in the viewer only when the viewer is opened from tabs where 
markups are allowed: from a change order’s Redline Attachments tab and from the Files tab 
of a file folder. In addition, you must have the appropriate privileges that allow you to 
redline attachment files (for example the Agile default role, Markup for Self). Contact your 
Agile administrator if you have questions about your assigned roles and privileges. 
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Viewer Window Components 
There are a few basic components to the Viewer work environment, shown in the following figure. 
These differ according to whether Viewer is in View mode or Markup mode. 

 
 

PinMe Icon 

In the upper right corner of the viewer window is the PinMe .  icon. Click  to pin (or lock) the 
viewer window open. A pinned viewer window (displays a pinned icon  to indicate the viewer 
window is pinned) stays open until you close it. When you view an additional attachment, a new 
viewer window opens. This feature allows you have multiple viewer windows open at one time, thus 
allowing you to switch between open viewer windows to compare or refer to multiple viewed files. 

Menu Bar 

The menu bar at the top of the window is the main access to all of the menu commands. The 
selection of available commands changes according to the mode the viewer is in and the task that 
you’re performing.      

Toolbars 

The tool buttons under the menu bar offer easy access to the basic commands presented in the 
menu bar. As with menu commands, the selection of available toolbar buttons changes according to 
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the mode the viewer is in and the task that you’re performing.       

Status Bar 

In both View mode and Markup mode, there is a status bar located at the bottom of the main 
window. The fields from left to right for each mode’s status bar are as follows:  markers (see the 
following list), current active file name, file type, zoom factor, current page and total number of 
pages, current active file size, date of the file’s creation, and the pointer’s coordinate position. 

The following types of markers can appear on the status bar: 

 A red light bulb marker indicates that the current active file has associated markup files. While in 
View mode, click the markup from the File menu to view the Markup Files dialog box. Then 
select a markup file or group of markup files to open. When you open a markup file, Markup 
mode starts automatically.       

 A red exclamation mark indicates that some main resources required to properly read the current 
active document are not available (for example, missing fonts or missing CAD files). To quickly 
identify the missing resources, click the red exclamation mark, and the File Properties dialog 
box appears. 

 The Join Session  button, which indicates that you have been invited to join a Collaboration 
session. 

 

Moving Objects 
You can use the left mouse button to click and drag.       

 In View mode — By default, drag to perform an autozoom of all supported file formats (including 
raster and vector files). Select the area you want to enlarge. 

 In Markup mode — If objects are selected, drag to modify and move objects. If no objects are 
selected, drag to perform an autozoom (same as in View mode). 

To select an object, click it. Selected objects are framed by a text box. Modify the size of the 
object by dragging the frame handles. To move an object, move the cursor to the borders (the 
edges) of the markup entity until the cursor turns into a hand pointer. Drag the hand pointer to a 
new location. 

Accessing Commands with Shortcut Menus 
The easiest and quickest way to access most of Agile Viewer’s functions is using the shortcut 
menus. Simply right-click with the pointer over the View window to access appropriate commands. 

In View mode, use these commands: 

 Zoom Fit — to automatically fit the document to the width of the view window. 

 a 
Markup mode only when markups are allowed. 

In Markup mode, use these additional commands: 

 ally return to your previous zoom level. Zoom Previous — to automatic

 Zoom Page Width — to automatically fit the document to the width of the view window. 

Markup/Exit Markup — to enter and exit Markup mode and open an existing markup or create 
new one. The  command is available in View 
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 Line Style — to select a style of line to use in your markup. 

 Line Thickness — to select a line thickness for use in your markup. 

 Fill Type — to select the type of fill to apply to your markup object: Solid Fill, No Fill, or 
Transparent Fill. 

 Entity Color — to select a color for your markup object. 

 Order — to select the overlay order when several markups are being displayed simultaneously. 

 Markup Layers — to select which layers are visible or active, change layer color, add new layers, 
and rename existing layers. 

 

Canceling an Operation in Progress 
For example, if while drawing a box you realize that you would prefer to draw a cloud, right-click 
while drawing the box and the box is erased from the display. 

If you have already drawn a box, you can either choose Edit > Undo from the menu bar or select the 
ox and press the Delete key on your keyboard. What has already been drawn is erased. b
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Agile-specific Features and Functions 
This chapter includes the following: 

 Opening Agile Attachment Files in the Viewer..................................................................................................... 17 
 Ad Hoc Markups .................................................................................................................................................. 25 
 Marking Up — How It Works ............................................................................................................................... 25 
 Guidelines for Marking Up or Redlining Attachments .......................................................................................... 25 
 Marking Up Documents ....................................................................................................................................... 30 
 2D Features and Functions ................................................................................................................................. 32 
 EDA Features and Functions............................................................................................................................... 32 
 3D Features and Functions ................................................................................................................................. 33 
 Cross Probing ...................................................................................................................................................... 33 
 Comparing Files................................................................................................................................................... 37 
 Overlaying Files ................................................................................................................................................... 40 
 Working with Schematic and PCB Files .............................................................................................................. 43 
 Real-Time Collaboration ...................................................................................................................................... 43 
 Digital Mockup ..................................................................................................................................................... 44 

 
 

Opening Agile Attachment Files in the Viewer 
You can view files from either the Attachments tab of a business object or from the Files tab of a file 
folder object. 

Viewing Files From Java Client 
To view a file from Java Client, Attachments tab: 

1. Go to the Attachments tab of a business object that references the file. 

2. Double-click the attachment row. 
 If the attachment row refers to a file folder with only one file, the Viewer opens and 

displays that file. 
 If the attachment row refers to a multiple-file file folder, the Select Files window appears. 

Select one or more files to view and click OK. The Viewer opens and displays the files you 
selected. 

Or, you can use the Attachment tab View File(s) button: 

1. Go to the Attachments tab of a business object that references the file. 

2. Select one or more attachment rows. 

3. Click the View File(s) button’s drop-down arrow and select View  from the menu.  

Note If the View  icon is visible on the button, you can simply click the button. 
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 If you selected one attachment row that refers to a file folder with only one file, the Viewer 
opens and displays that file. 

 If you selected one attachment row that refers to a multiple-file file folder, the Select Files 
window appears. Select one or more files to view and click OK. The Viewer opens and 
displays the files you selected. 

 If you selected more than one attachment row, the Viewer opens and all the files in all the 
selected rows are displayed in the viewer. The Select Files window does not appear. 

To view a file from Java Client, Files tab: 

1. Go to the Files tab of a file folder object containing the files you want to view. 

2. Double-click the filename in the file table. 

The Viewer opens and displays the file. 

3. Or, select one or more file rows. 

4. Click the tab menu View File(s) button’s drop-down arrow and select View  from the menu.  

Note If the View  icon is visible on the button, you can simply click the button. 

The Viewer opens and displays the selected files. 

Viewing Files From Web Client 
To view a file from Web Client, Attachments tab: 

1. Go to the Attachments tab of a business object that references the file. 

2. Click the file name link in the attachments table. 
 If the attachment row refers to a file folder with only one file, the Viewer opens and 

displays that file. 
 If the attachment row refers to a multiple-file file folder, the Select Files window appears. 

Select one or more files to view and click Finish. The Viewer opens and displays the files 
you selected. 

Or, you can use the Attachment tab View button: 

1. Go to the Attachments tab of a business object that references the file. 

2. Select one or more attachment rows. 

3. Click the View button’s drop-down arrow and select  View from the menu.  

Note If the View  icon is visible on the button, you can simply click the button. 

 If you selected one attachment row that refers to a file folder with only one file, the Viewer 
opens and displays that file. 

 If you selected one attachment row that refers to a multiple-file file folder, the Select File
window appears. Select one or 

s 
more files to view and click OK. The Viewer opens and 

  the 
selected rows are displayed in the viewer. The Select Files window does not appear. 

displays the files you selected. 
If you selected more than one attachment row, the Viewer opens and all the files in all
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To view a file from Web Client, Files tab: 

1. Go to the Files tab of a file folder object containing the files you want to view. 

2. Click the filename link in the file table. 

The Viewer opens and displays the file. 

3. Or, select one or more file rows. 

4. Click the tab menu View button’s drop-down arrow and select  View from the menu. 

Note If the View  icon is visible on the button, you can simply click the button. 

The Viewer opens and displays the selected files. 

Opening Agile Attachment Files from the Viewer Window 
When the Viewer window is open, you can use the Viewer menus to select a different Agile 
attachment file to view without using the Java Client or Web Client Attachments tab commands. 

The specific Viewer menu choices that are available to allow you to select an Agile attachment file 
depend upon the function you originally chose in Agile PLM when you opened the viewer (View, 
Cross Probe, Compare, Overlay, or Digital Mockup) and the file type of the currently viewed file.  

Note Because the list of available Viewer menu selections for attachment file selection can 
vary, some of the following menu selections may not be available for you to choose in a 
specific Viewer session. 

The possible available Viewer menu selections that allow you to select another attachment file 
include: 

 File | Open URL 

 Analysis | Compare 

 Analysis | Overlay 

 Analysis | DMU 

 Analysis | Cross Probe 

When you choose one of these menu selections, in order to select the file you want to view or to 
add to the current analysis view, a File Open dialog appears. The Agile Browse button in the File 
Open dialog allows you to use your Agile Bookmarks to select a file. The Agile Search button in the 
File Open dialog allows you to perform a quick search and select the a file. 

To use your Agile Bookmarks to select an attachment file: 

1. e Viewer menu option: Choose an availabl
 File | Open URL 
 Analysis | Compare 

y 

2. Follow any dialog prompts until the File Open dialog appears. 

 Analysis | Overla
 Analysis | DMU 
 Analysis | Cross Probe 
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3. Click the Agile Browse button in the File Open dialog to display the DMS: File Open dialog.  

The DMS: File Open dialog displays your Agile Bookmarks in a tree structure. 

Note If you have not defined any Bookmarks in Agile PLM, the Agile Browse button 
does not appear in the File Open dialog. 

4. Click + to expand a bookmark and display its item revisions or its file folder versions. 

5. Click a revision or version row to highlight the file you want to view. 

6. Click OK in the DMS: File Open dialog. 

The selected file name appears in the File Name field  of the File Open dialog. 

7. Click OK in the File Open dialog. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the current 
analysis function. 

To perform a quick search to select an attachment file: 

1. Choose an available Viewer menu option: 
 File | Open URL 
 Analysis | Compare 
 Analysis | Overlay 
 Analysis | DMU 
 Analysis | Cross Probe 

2. Follow any dialog prompts until the File Open dialog appears. 

3. Click the Agile Search button in the File Open dialog to display a Search dialog which allows you 
to run a quick search. 

4. fi Search De ne your search and click the button: 
 Class - Select an object class, for example, Items. 
 

n 

ver, you may use wildcard characters to specify part of an ID number as 

  parameter to Yes to search the contents of the 

5. k the + next to the object number to expand the list of 

rsion row to select the file you want to view. 

7. 

 the File Name field of the File Open dialog. 

8. 

the selected file, or, if appropriate, adds the selected file to the current 

Search Parameter - Enter a text string or a number. 

Agile PLM searches the object ID number attribute and the object Name or Descriptio
attribute. A Quick search behaves like a Contains search for text strings. The search 
criteria is treated as a single string and Agile PLM searches for names or descriptions that 
contain the search parameter string. In the case of ID numbers, Agile PLM searches for an 
exact match, howe
a search criteria. 
Search Attachment Content - Set this
attachment files as well. 

In the Search Results table, clic
attachment files for that object. 

6. Click a revision row or a ve

Click the Load File button. 

The selected file name appears in

Click OK in the File Open dialog. 

The Viewer opens 
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analysis function. 

Comparing Revisions or Versions of a File 
You can view a file from an item Attachments tab or a file folder Files tab then select, from the Viewer 
window, other item revisions or f
one revision or version, you may sele

ile folder versions of the file to compare against. After comparing 
ct another, comparing multiple revisions or versions of the file 

. 

 appears. 

5. 

Note ompare the 

from within the Viewer window. 

To compare multiple item revisions of an attached file: 

1. On the item Attachments tab, select the file you want to compare. 

2. Choose View from the tab menu. The Viewer opens, displaying the selected file

3. In the Viewer menu, choose Analysis | Compare. The File Open dialog

4. Check the Document Versions checkbox, if it is not already checked. 

Use the drop-down menu to select another revision of the file for comparison. 

Only released item revisions appear in the drop-down list. To c
attachment of a pending revision, view the pending revision file, then use 
Analysis | Compare to select released revisions for comparison. 

6. Click . The Viewer opens the selected version in second window and displays the 
differences between the two files in a third window. 

OK

7. To compare another revision, choose File | Exit Compare Mode in the Viewer menu. 

evision. 

. 

 appears. 

. 

e in the Viewer menu. 

red File Types 
in

Note Viewing structured data in a File folders class object relies on the DocuBOM or the 

8. Repeat steps 3 through 6 to select another item r

To compare multiple file folder versions of a file: 

1. On the file folder Files tab, select the file you want to compare. 

2. Choose View from the tab menu. The Viewer opens, displaying the selected file

3. In the Viewer menu, choose Analysis | Compare. The File Open dialog

4. Check the Document Versions checkbox, if it is not already checked. 

5. Use the drop-down menu to select another file folder version of the file for comparison

OK6. Click . The Viewer opens the selected version in second window and displays the 
differences between the two files in a third window. 

7. To compare another file version, choose File | Exit Compare Mod
8. Repeat steps 3 through 6 to select another file folder version. 
 

Viewing File Folder Structu
View g Structured File Types 

Relationships tab to resolve related objects in the structure. 

CAD data can be stored in Agile PLM using document object BOM structures. This is usually 
accomplished automatically when Agile PLM and EC are integrated using EC CAD connectors. A 
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CAD assembly file is attached to an Agile document object, and the subordinate CAD part files are 
also attached to Agile document objects. The part file document objects appear on the BOM tab of 

Note Files types that are used in structured file hierarchy are specified in Agile Administrator as 

the CAD assembly document object, thus creating a hierarchical file structure for the attached files. 

Structured Files Types. All other file types are specified as Supported File Types.  

When you open an Structured File Type assembly attachment, Agile PLM automatically opens the 
subordinate part files in the Viewer also, allowing you to view the entire CAD design. This process is 

e 

 LM extracts only Structured File Type files. If an attached file type is specified on the 

 n the Structure File Type list, then Agile PLM will traverse all levels of the 
e 

 
s 

ose Attachment Type 

  the matching value of Attachment Type on the same 
m 

 ent in the hierarchy does not have any file attachments, o y with the 

 .  
 

st 
ar exactly as it was saved.  If not, the view may differ slightly if 

s 
D. 

pes, including View, Markup, Compare, 

b 

seamless and requires no action by the user other than initiating the view function for the assembly 
file. 

The following list provides details about how Agile PLM extracts Structured File Type files from th
document BOM structure for CAD design viewing: 

Agile P
Supported File Types list, Agile PLM does not traverse the document structure to find other 
files. 

If the file type is o
document hierarchy, starting with the selected file, and extract other files necessary to build th
complete model. 

In order to avoid pulling out unnecessary files, the viewing logic makes use of the Attachment 
Type attribute on the document's Attachments tab.  If there is a value in this attribute (such a
SOURCE) for the originally selected file attachment, then only files wh
attribute matches this value will be extracted.  If there is no value in the Attachment Type 
attribute, then all files within the structure hierarchy will be extracted. 

If there are multiple file attachments with
document, they will all be extracted and sent to the Viewer.  This includes the document fro
which the view operation was initiated. 

If any given docum r an
correct value of Attachment Type, the extraction process does not stop but simply continues 
down the tree. 

The Agile administrator may have configured Agile PLM to use the CAD Revision BOM attribute
This is a technique, principally used by the standard Agile EC CAD Connectors, to provide an
As Saved fixed BOM resolution for CAD designs. If this is enabled, when you view a pa
revision of a design it will appe
child components have been revisioned in the meantime (that is, standard Agile BOM 
resolution logic is followed). 

 You may select any document revision for viewing, including a pending revision. If the CAD 
Revision attribute is enabled, then viewing a pending Rev will display any active pending Rev
within the structure that were saved from CA

 All Agile Viewer operations support structured file ty
Cross Probe, Overlay, and Digital Mockup. 

 

Viewing Design Object Structures 
Note Viewing structured data in a Design data model class object relies on the the Structure ta

to resolve related objects in the structure. 
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When you open a CAD assembly file in a Design object, Agile PLM also automatically opens the 

 objects. 

Des ure table for CAD design viewing: 

ist 

 
 

 d Design matches the Category 

o value for Category, then all files in all child 

 ategory value as the starting 

 

 When a Design object is from a business object's Attachment tab, Agile PLM uses the rules for 
, Design object viewing rules are always applied to 
n is initiated from a Design object or from the business 

er 
r object is open, you can view information about all versions of the File Folder in 

ersion Browse

When a Design object is open, you can view information about all versions of the Design in the 

subordinate CAD part files in the Viewer, allowing you to view the entire CAD design. Agile PLM 
uses the assembly structure, as defined on the Structure tab of the Design object and the Structure 
tabs of its child Design

This process is seamless and requires no action by the user other than initiating the view function 
for the assembly file. 

The following list provides details about how Agile PLM extracts Structured File Type files from the 
ign object and its Struct

 The file type of the Design object selected file must be included in the Structured File Types l
in Agile Administrator. 

The structure used to extract files is explicitly set on the Design object Structure tab. 

Agile PLM identifies which Design objects files to extract by the following methods: 
If the value of the Category attribute from any file row of a chil
value of the starting file, the file is extracted. 

 If the selected starting Design object file has n
Designs are extracted, including the starting Design object. 

If multiple file rows on a Design object structure have the same C
file, they are all extracted, at any level in the tree. 

If the user selects multiple Design object files and chooses View, each selected file is 
interpreted separately, based on Design structure viewing logic. 

viewing Designs, not DocuBOMs. That is
Design objects whether the viewing actio
object Attachments tab. 

 

Using the Version Brows
When a File Folde
the V r. 

Version Browser. 

Note The Version Browser is available only in Web Client.  

To open the Version Browser: 

1. In the Actions menu, choose Version Browser. The ser opens. 

ion Browser d

 Version Brow

The Vers isplays the following information about each version: 

Vers ion Browser  
Column 

Descr ipt ion 

Approval An Awaiting Approval icon  in this column indicates that the version is awaiting 
approval; the Routing Slip for that version lists users who have not yet signed off. 

Version The version number. 
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Vers ion Browser  
Column 

Descr ipt ion 

Checkin Date
Checkin User

the checkin. The date the version was checked in and the user who performed 

When the version is checked out, these fields are blank. 

Change Info rsion was modified before it was checked in. 

For Design objects, Structure indicates that the Design's Structure tab was modified. 

indicates how the ve

Files indicates that the object's files were modified, for example, files were replaced, 
added, or deleted. 

Label, Revision, These are version-specific editable fields used with Design data model objects. 
Revision Date

 

Actions you can initiate in the Version Browser: 

 e Viewer. 

w 

ts Tab 

 through to the File Folder object. This is useful when 

d 

 

View Files: Select any version row and click View to view the file or files in the Agil

 Compare Files: For single-file versions, select two version rows, and choose Compare in the Vie
button drop-down list. The selected files are compared in the Agile Viewer. 

 

Accessing Different File Versions from the Business Object 
Attachmen
You can get, open, view, and print any version of an attachment file from the Attachments tab of the 
business object. 

You can easily access history without clicking
a single file is being modified and accessed by multiple people/different functions. For instance, 
user can easily trace and identify which versions another user made their edits in - this is identifie
from version create date and checkout user. 

The Versions dialog displays, for each version, the Version Creation Date (date the version was
created), whether that version has redlines (indicated by the Has Been Redlined  icon), and the 
Checkout User (user who created that version). This allows you to easily see the history of an 
attachment from the Attachments tab, including who modified the file, and when it was modified. 

ments tab in Java Client: 

row that you want to access. 

To switch between versions of file folders from an object's Attach

1. On the Attachments tab, select one or more attachment 

2. Click the Show Versions button . The Versions dialog appears. 

5. Optionally, click the Has Been Redlined 

3. Select the version row or rows that you want to access. 

4. Click the appropriate action button (Get, Open, View, or Print). 

 icon to open the viewer and display the redlines. 

6. Optionally, select two version rows, then choose Compare or Overlay in the View action button 
drop-down menu. 
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To s etween versions of file folders from an object’s Attachments tab in Web Client: witch b

1. On the Attachments tab, click the Show Versions button  in the attachment row you want and 
the Versions dialog appears. 

t to access, click the appropriate action button (Get, View, or 

3. Optionally, select two version rows, then choose Compare or Overlay in the View action button 

c Markups 
c 2 ect. 

 other. 

2. In the version row that you wan
Print). 

drop-down menu. 
 

Ad Ho
Ad ho D, 3D, and EDA/ECAD markup can be done from the Files tab in the file folder obj
Change order-controlled 2D, 3D, and EDA/ECAD markup can be done from the Redline Attachments 
tab in the ECO. When you view a markup file, the original document, also known as the base file, 
opens too. 

Note Change order-controlled and ad hoc markups are independent from each

To view change order-controlled markups, open the redlined file fro
item Attachments tab or from the change order Redline Attach

m the appropriate revision of the 
ments tab (see “Viewing ECO Redlines 

from the Attachments Tab of the Item Pending Revision (on page 28)”. 

 Up — How It Works 

nal 

Markup files are divided into uniquely named layers. Create, name, and color the layers to organize 
nd each layer 
 other attachment 

nager (AFM). Markup files are managed by Agile and are 
presented when you view the redlined document. 

Attachments 
With app
the Files t
accessibl

To view ad hoc markups, open the redlined file from the file folder object Files tab. 

Marking
Marking up refers to drawing and writing in an electronic document. With Agile Viewer, your original 
document remains unchanged because your markups are saved in separate markup files. When 
you view a markup file, Agile Viewer loads the markups into memory and lays them over the origi
document.       

There can be as many markup files as you wish for a document because each has its own unique 
filename. This allows several individuals to mark up the same document at the same time because 
a unique markup file is created for each person’s work. With the markup information attached to 
each markup file, you can even tell who created each markup. 

your work as you like. For example, different colors could indicate time priorities, a
could contain markups relating to a common purpose. Markup files are stored with
files in the file vault, part of Agile File Ma
automatically retrieved and 

Guidelines for Marking Up or Redlining 

ropriate privileges, you can redline Microsoft Office documents, 2D, 3D, and EDA files on 
ab of a file folder object and redline 2D, 3D, and EDA files on the Redline Attachments tab, 
e from the Affected Items tab of an ECO.      
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Note You can create and edit file markups only through the Affected Items tab of an ECO or the 
Files tab of a file folder object. Your Agile administrator must give you privileges that allow 

Os and file folder you to mark up or redline attachments. For more information about EC
objects, see Getting Started with Agile PLM. 

 

va Client Ja
To mark up o

1. If you hav  of an 
unrelease . 

te 

r redline an attachment file from an ECO in the Java Client: 

e not already done so, add an item with an attachment to the Affected Items tab
d ECO. The item now has a pending revision associated with the unreleased ECO

No When redlining an attachment through an ECO, the pending revision 
attachment Folder Version must be set to a specific version number; if the 
Folder Version is set to LATEST-x, you will not be able to create redline 
markups. However, you can edit the Folder Version on the Attachments tab of 
the pending revision so that it refers to a specific Folder Version. 

 For example, if the pending revision of the item refers to Folder Version LATEST-7 of 
the file folder, select that row on the Attachments tab, click the Edit  button an
the

d use 
mplete 

the edit process. You will now be able to create redline markups for that 
f the ECO. 

t the row containing the file you want to redline and click the View button. 

ile you want to redline. 
2.  the arkups 

are allow

3. Use the tools chment. To view online 

ith the pending revision of 

 Folder Version drop-down list in the Edit dialog box to select 7. Click OK to co

attachment.Select the added item on the Affected Items tab o

On the Redline Attachments tab: 
 Selec

Or 
 Double-click the row containing the f

When  Viewer appears, click the Markup button. (This button is available only when m
ed.) 

described in the viewer online Help to redline the atta
Help, choose Help > Content in the menu bar. 

Note ECO markups are saved against and associated w
the item. If the ECO is released without first replacing the file, the markups 
appear against the released revision of the item 

To ad hoc mark up or redline an attachment file from a file folder object in the Java Client

Double-click the row containing the file you w

: 

1. ant to redline. 

2.  the arkups 
are allow

bed in the viewer online Help to redline the attachment. To view online 
 in the menu bar. 

 

When  Viewer appears, click the Markup button. (This button is available only when m
ed.) 

3. Use the tools descri
Help, choose Help > Content

Note Ad hoc markups are saved against and associated with the version of the file 
folder object. 
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We

Note If th

b Client 

e item or file has already been redlined, then the Has been redlined icon  will be 
displayed in the place of the Do Redlining icon . Click either   or  to initiate redlining. 

To mark up or redline an

1. 
unrelease

Note 

 attachment file from an ECO in the Web Client: 

If you have not already done so, add an item with an attachment to the Affected Items tab of an 
d ECO. The item now has a pending revision associated with the unreleased ECO. 

When redlining an attachment through an ECO, the pending revision 
attachment Folder Version must be set to a specific version number; if the 

 it refers to a specific Folder Version. 

Folder Version is set to LATEST-x, you will not be able to create redline 
markups. However, you can edit the Folder Version on the Attachments tab of 
the pending revision so that

 For example, if the pending revision of the item refers to Folder Version LATEST-7 f 
the file folder, select that row on the 

 o
 the 

Folder Version drop-down list to select 7. Click Save to complete the edit process. You 
 

at item to open the Redlines page. 

2. On e Af

Attachments tab, click the Edit button and use

will now be able to create redline markups for that attachment.On the Affected Items
tab, click the Do Redlining icon for th

th fected Items tab, click the Do Redlining button   (or Has been redlined button )
o open the Redlines page. 

dline Attachments tab, click the Do Redlining button 

 next to 
the item t

3. On the Re   (or Has been redlined button ) 
on the row of the file you want to redline. (This button is available only when markups are 
allowed. 

4. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

Note ECO markups are saved against and associated with the pending revision of 
the item. If the ECO is released without first replacing the file, the markups 
appear against the released revision of the item 

To ad hoc ma

button 

rk up or redline an attachment file from a File Folder object in the Web Client: 

1. On the Files tab of a file folder object, click the Do Redlining  (or Has been redlined button 
) on the row of the file you want to redline. (This button is available only when markups are 

allowed.) 

2. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

Note Ad hoc markups are saved against and associated with the version of the file 
folder object. 

 

Redlin
The chan evision of the item. 
The markup changes are visible from either the change orders’s Redline Attachments tab or from the 

ending revision item Attachments tab. 

ing Markups for Change Orders 
ge order redlines of 2D, 3D, and EDA files are based on the pending r

p

Important 3D features and access to 3D files are available only with Agile Advanced Viewer. 
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Fea
the Agile Advanced Viewer. In order to u

tures for schematic and PCB files, also referred to as EDA files, are available only with 
se these features, your company must have the 

er 

ie g 

sion by displaying the 
ion (C) ECO000453. The redlined file is 

View and Mark Up (3D) server license, which provides access to Advanced View
functions. For more information about server licenses, see the Administrator Guide. 
Contact your Agile Account Executive or reseller to obtain a license. 

 
 

V wing ECO Redlines from the Attachments Tab of the Item Pendin
Revision 

You can view the change order markup redlines of the pending revi
Attachments tab of the item pending revision, for example, revis
indicated by the Has been redlined  icon. 

 In Java Client, select the redlined file you want to view and click the View File(s)  button. 

 In Web Client, click the Has been redlined  button in the row of the file you want to view. 

If you have checked out the redlined file and checked in a new version from the Attachments tab, the 
le. 

1. On ect the row you want to view. 

3. 

Has been redlined icon does not appear on the Attachments tab

To view the redlines of previous versions in Java Client: 

the Attachments tab of the pending revision, sel

2. Click the Show Versions button. The Versions dialog appears. 

On the version row for which you want to view redlines, double-click the Has been redlined  
n. 

2. On the version row for which you want to view redlines, double-click the Has been redlined 

butto

To view the redlines of previous versions in Web Client: 

1. On the Attachments tab of the pending revision, click the Show Versions button in the row you 
want to view. The Versions dialog appears. 

 
button. 

Note If you need to determine which file folder version is associated with the change 
order redlines, refer to the change order History tab. 

However, if the attachment file on the pending revision item is not replaced prior to the change 
order release, the redlines will be accessible from the released revision of the item. The following 
diagram shows an example of the change order attachment redlining process.  
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See also Product Collaboration User Guide and Getting Started with Agile PLM User Guide. 

 
 

 Page - 29

  

 



Viewer Supplement   
 
 
 

Marking Up Documents 
For information about working with markups, including markup layers and markup objects, refer to 
the viewer online help. Choose Help > Contents in the Agile Viewer menu bar. 

Tips for Marking Up Documents 
If you exit the Agile viewer without saving, you will lose any redline you have added to the 
attachment. 

Attaching Information to Markup Files 

In Markup mode, the Markup > Information command displays the Markup Information dialog box with 
five information fields attached to the current active markup file.    

Entity Rotate 

Entity Rotate allows you to rotate symbol markup objects. 

To rotate a symbol markup object: 

1. Select the symbol markup object you want. 

2. Click the Rotate Entity button, or choose Markup > Entity Rotate. 

When this feature is activated, the Rotate Entity button appears as a recessed button (light gray) 
on the toolbar. 

3. Place the cursor on one of the corner squares that indicate the selected object. 

4. When you see the crossed-arrows cursor (pointing in four directions), hold down the left mouse 
button and adjust the rotation angle of the object. 

5. Release the mouse button when you are finished adjusting the rotation angle. 

 
 

Markup Promotion 
Markup promotion is the ability to bring forward, or promote: 

 Change-based markups from previous change orders to the current change order. 

 Ad-Hoc markups from older file folder versions to the newer versions. 

This allows you to revalidate older markups against a new design. 

Markup Promotion for Change-Based Markups 

To promote change-based markups in Java Client: 

1. Open the change order and display the Affected Items tab. 

2. On the Redline Attachments tab: 
 Select the row containing the file you want to redline and click the View button. 
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Or 
 Double-click the row containing the file you want to redline. 

3. When the Viewer opens, enter Markup mode. In the Viewer File menu, choose the Markup 
command. 

4. In the Viewer File menu, choose the Open command. 

The Markup Files dialog appears 

5. Click the All Revisions checkmark and all valid markups are displayed. 

The available markups are associated to files that have the same file extension as the file you 
are viewing. 

6. Select the markup files you want to promote to the current markup. 

7. Click OK. 

8. The promoted markups are displayed in the file you are currently viewing. 

9. To save the promoted markups with the change order revision, save the markups in the Viewer 
before exiting the Viewer. 

To promote change-based markups in Web Client: 

1. Open the change order and display the Affected Items tab. 

2. On the Affected Items tab, click the Do Redlining button   (or Has been redlined button ) next to 
the item to open the Redlines page. 

3. On the Redline Attachments tab, click the Do Redlining button  (or Has been redlined button ) on 
the row of the file you want to redline. (This button is available only when markups are allowed. 

4. When the Viewer opens, enter Markup mode. In the Viewer File menu, choose the Markup 
command. 

5. In the Viewer File menu, choose the Open command. 

The Markup Files dialog appears 

6. Click the All Revisions checkmark and all valid markups are displayed. 

The available markups are associated to files that have the same file extension as the file you 
are viewing. 

7. Select the markup files you want to promote to the current markup. 

8. Click OK. 

9. The promoted markups are displayed in the file you are currently viewing. 

10. To save the promoted markups with the change order revision, save the markups in the Viewer 
before exiting the Viewer. 

 

Markup Promotion for Ad-Hoc Markups 

To promote file folder ad hoc mark ups in Java Client: 

1. Open the file folder object and display the Files tab. 

2. Click the Do Redlining button  (or Has been redlined button ) on the row of the file you want to 
redline. (This button is available only when markups are allowed.) 
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3. When the Viewer opens, enter Markup mode. In the Viewer File menu, choose the Markup 
command. 

4. In the Viewer File menu, choose the Open command. 

The Markup Files dialog appears. 

5. Click the All Revisions checkmark and all valid markups are displayed. 

The available markups are associated to files that have the same file extension as the file you 
are viewing. 

6. Select the markup files you want to promote to the current markup. 

7. Click OK. 

The promoted markups are displayed in the file you are currently viewing. 

8. To save the promoted markups with the current file folder version, save the markups in the 
Viewer  

To promote file folder ad hoc mark ups in Web Client: 

1. Open the file folder object and display the Files tab. 

2. Click the Do Redlining button  (or Has been redlined button ) on the row of the file you want to 
redline. (This button is available only when markups are allowed.) 

3. When the Viewer opens, enter Markup mode. In the Viewer File menu, choose the Markup 
command. 

4. In the Viewer File menu, choose the Open command. 

The Markup Files dialog appears. 

5. Click the All Revisions checkmark and all valid markups are displayed. 

The available markups are associated to files that have the same file extension as the file you 
are viewing. 

6. Select the markup files you want to promote to the current markup. 

7. Click OK. 

The promoted markups are displayed in the file you are currently viewing. 

8. To save the promoted markups with the current file folder version, save the markups in the 
Viewer before exiting the Viewer. 

9. before exiting the Viewer. 
 

2D Features and Functions 
For information about working with 2D files, including CAD views and measuring objects, refer to 
the viewer online help. Choose Help > Contents in the Agile Viewer menu bar. 

EDA Features and Functions 
Agile Advanced Viewer EDA features include: 
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 A formats including artwork formats, PCB/IC layouts, schematics 

Cross Probing

Ability to view all relevant ED
and manufacturing formats 

 Cross probe between a PCB layout and related schematics (see  on page 33). 

on. 

A features, refer to the viewer online help. Choose 
Help > Contents

3D Features and Functions 
ttings and models, refer to the viewer 

Important 

ut 
inistrator Guide. Contact your Agile Account Executive or 

reseller to obtain a license. 

blies, see: 

 Verify design by testing for manufacturability or design violati

 Generate and export Bills of Material in a variety of formats. 

For detailed information about all the ED
 in the Viewer menu bar. 

For information about working with 3D files, including light se
online help. Choose Help > Contents in the Viewer menu bar. 

3D features and access to 3D files are available only with Agile Advanced Viewer. In order 
to use these features, your company must have the View and Mark Up (3D) server 
license, which provides access to Advanced Viewer functions. For more information abo
server licenses, see the Adm

 
 

For details about about how Agile PLM views 3D CAD assem

 Viewing File Folder Structured File Types on page 21. 

 Viewing Design Object Structures on page 22. 

bing features, see the Viewer online help. Choose 

Important 

Administrator Guide. Contact your Agile Account Executive or reseller to 

Important robing to interrogate ECAD schematic and layout files in separate viewer 

Note e Supported Files Types 

 
 

Cross Probing 
Cross probing is also described in the viewer online Help. In Agile, this feature is initiated from 
either the business object Attachments tab or the file folder Files tab rather than from the viewer 
menus. For detailed information about cross pro
Help  > Contents in the viewer menu bar. 

Cross probing features are available only with Agile Advanced Viewer. In order to use 
these features, your company must have the View and Mark Up (3D) server license, 
which provides access to Advanced Viewer functions. For more information about server 
licenses, see the 
obtain a license. 

Use cross p
windows. 

The Agile administrator must specify the ECAD file extension in th
list in Agile Administrator for you to view the ECAD files. 

You can select both needed files from the same Attachments tab or the same file folder Files tab from 
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which you launch the Cross Probe action. Or, you can select one file on the current tab and then 
search for the remaining file from the attachments of any other object. 

The View > By Search > Crossprobe option allows you to find other files in the system, which you ma
want to use to c

y 
ross probe, without having to select two files from the same Attachments tab or Files 

w a single ECAD file then initiate cross probing within the viewer by adding 

2. rk with and choose:  

oss Probe. 

3. . 

oose Help > Contents in the 

n Java Client and Web Client 

1. sp

2. rk with and choose:  

> Cross Probe. 

3. . 

 information about cross probing. Choose Help > Contents in the 

1. 

2. Sele
obe. 

3. 

tab; that is, you can search and select one attached file from Part 234 and another attached file 
from Part 765. 

Alternatively, you can vie
another file from your desktop. 

To run Cross Probing: 

1.  Display the Attachments tab or the Files tab.

Select both file rows you want to wo
 Java Client: View File(s)  > Cross Probe. 
 Web Client: View > Cr

Each file is displayed in a separate viewer window. 

Begin cross probing

See Viewer online help for more information about cross probing. Ch
Viewer menu bar. 

Cross Probing i
To run Cross Probing: 

Di lay the Attachments tab or the Files tab. 

Select both file rows you want to wo
 Java Client:  View File(s)  > Cross Probe. 
 Web Client: View 

Each file is displayed in a separate viewer window. 

Begin cross probing

See Viewer online help for more
Viewer menu bar. 

To run Cross Probing By Search: 

Display the Attachments tab or the Files tab. 

ct a file row you want to work with and choose:  
 Java Client: View File(s) > By Search > Cross Pr

The Select Files dialog appears, with three Search tabs. 
 Web Client:  View  > By Search > Cross Probe. 

The View Files by Search dialog appears, with three Search tabs. 

The search dialog allows you to search for any business object (for example, items or 
manufacturer parts) and select the attachments of those objects to use to Cross Probe. 

Use any of the following search methods: 
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ontents, too. 

re 
e performing. 

ar on the Recently Visited list of the 

ted 

nd move attachments to the Selected Files table. 

6. ts until you are finished selecting the 

d, click OK. 

g. Choose Help > Contents in the 
Viewer menu bar. 

ewer 
 must first select and view an appropriate file, that 

sis. 

w

1. tab or the Files tab. 

2. 

The er File Open dialog appears. 

4. 

ewer window. 
 Agile Viewer 

Search tab lets you create a simple search or an advanced search. You can check to 
search attachment c

 Saved Searches tab opens to your navigation pane where you can browse in search folders, 
select a search, and run it. Again, returned results may be moved to the Selected Items 
table, and click OK. 

 Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that a
appropriate to the operation you ar

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appe
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the Results table, and the rela
files for that object appear in the Related Files table. 

5. In the Related Files table, select a

You can continue to run multiple searches or shortcu
attachments you want. 

7.  When you are finishe

Each file is displayed in a separate viewer window. 

8. Begin cross probing. 

See Viewer online help for more information about cross probin

 

Initiate Cross Probing in the Agile Vi
To initiate cross probing in the Agile Viewer, you
is, a file type that can be used for cross probing analy

Vie  an appropriate ss probing:  file for cro

s Display the Attachment
Select a file row you want to work with and choose: 
 Java Client: View Files(s) 
 Web Client: View 

The Agile Viewer opens and displays the selected file. 

3. In the Agile Viewer Analysis menu, choose Cross Probe. 

 Agile View

Use one of the following File Open dialog methods to select a file for cross probing: 
 Browse to browse your local directories to select and open files from the Agile Viewer 

window. 
 Agile Browse to use Agile bookmarks to open files from the Agile Vi
 Search to perform an Agile Quick Search to select an open files from the

window. 
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Browse to browse your local directories to select an attachment file: 

1. 

2. Use -down list to select the directory you want. 

he current 
sis f

Agile Browse t an attachment file: 

log.  

cture. 

in Agile PLM, the Agile Browse button 

Click the Browse button in the File Open dialog to display File Open dialog.  

the Look in: drop

3. Select the file you want and click Open. 

4. Click OK in the File Open dialog. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to t
analy unction. 

 to use your Agile Bookmarks to selec

1. Click the Agile Browse button in the File Open dialog to display the DMS: File Open dia

2. The DMS: File Open dialog displays your Agile Bookmarks in a tree stru

Note If you have not defined any Bookmarks 
does not appear in the File Open dialog. 

3. Click + to expand a bookmark and display its item revisions or its file folder versions. 

4. 

5. Click alog. 

riate, adds the selected file to the current 

Agi e chment file: 

1. Clic ou 
to ru

2. Defi
 
 Enter a text string or a number. 

ption 
behaves like a Contains search for text strings. The search 

ions that 
ring. In the case of ID numbers, Agile PLM searches for an 

number as 

ent - Set this parameter to Yes to search the contents of the 

the + next to the object number to expand the list of 

4. 

5. Click the Load File button. 

The selected file name appears in the File Name field of the File Open dialog. 

Click a revision or version row to highlight the file you want to view. 

OK in the DMS: File Open di

The selected file name appears in the File Name field of the File Open dialog. 

6. Click OK in the File Open dialog. 

The Viewer opens the selected file, or, if approp
analysis function. 

le S arch to perform a quick search to select an atta

k the Agile Search button in the File Open dialog to display a Search dialog which allows y
n a quick search. 

ne your search and click the Search button: 
Class - Select an object class, for example, Items. 
Search Parameter - 
Agile PLM searches the object ID number attribute and the object Name or Descri
attribute. A Quick search 
criteria is treated as a single string and Agile PLM searches for names or descript
contain the search parameter st
exact match, however, you may use wildcard characters to specify part of an ID 
a search criteria. 

 Search Attachment Cont
attachment files as well. 

3. In the Search Results table, click 
attachment files for that object. 

Click a revision row or a version row to select the file you want to view. 
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6. Click OK in the File Open dialog

The Viewer opens the selected

. 

 file, or, if appropriate, adds the selected file to the current 

 
n the viewer online Help. In Agile, rather than initiating file 

For detail
Contents

Important Compare file features are available only with Agile Advanced Viewer. In order to use 
these features, your company must have the View and Mark Up (3D) server license, 
which provides access to Advanced Viewer functions. For more information about server 

ontact your Agile Account Executive or reseller to 

 Java Client and Web Client 
gle file folder Files tab or a single business object 

To in

1. Display 

2. Select both files you want to work with and choose: 

View > Compare 

isplayed in a single viewer window. 

tions, choose Help > Contents in the viewer 

e

 
 
 Select any file on any business object  Attachments tab or on any file folder Files tab, then search 

for a file to use for comparison.  

analysis function. 

Comparing Files
Comparing files is also described i
compare from the viewer menus, you initiate file compare from either the file folder Files tab or the 
business object Attachments tab. 

ed information about file comparison features, see the Viewer online help. Choose Help > 
 in the viewer Menu bar. 

licenses, see the Administrator Guide. C
obtain a license. 

 
 

Markups and Comparing Files 
Markups (redlines) are not supported in the Agile viewer compare mode. 

Comparing Files in
You can select and compare two files from a sin
Attachments tab. 

itiate comparing files: 

the Attachments tab or the Files tab. 

 Java Client: View File(s) > Compare 
 Web Client: 

The files and the comparison results are d

For more information about compare file features and op
menu bar. 
 

Comparing Files By Search 
Th  View > By Search > Compare command allows you to 

Compare files from different released revisions of an item . 

Compare files from different file folder versions. 
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Depe g on your search, you can select a business object, then select a file from the 
e es for that object. Or, if you have th

s, then select a file from the list 

ndin list of 
relat d fil e appropriate privileges, you can search for file 
folder object of related files for the selected file folder. 

ons and unreleased pending revisions do Note For item objects, Introductory revisi
not appear in the related files list.  

To initiate comparing files by Search : 

1. 

2. 

ars with three search tabs. 

3. 
man chments of those objects to compare.  

 

 

re 
rforming. 

Recently Visited list of the 

4. he
files

5.  th
 the Related 

 table
  sele

 

oductory revisions and unreleased pending revisions do not 

Display the Attachments tab or Files tab. 

Select a file row you want to work with and choose: 
 Java Client: View File(s) > By Search > Compare 
 Web Client: View > By Search > Compare 

The Compare Files By Search dialog appe

The search dialog allows you to search for any business object (for example items or 
ufacturer parts) and select the atta

Use any of the following search methods: 
Search tab lets you create a simple search or an advanced search. You can check to 
search attachment contents, too. 

 Saved Searches tab opens to your navigation pane where you can browse in search folders,
select a search, and run it. Again, returned results may be moved to the Selected Items 

OKtable, and Click . 
 Shortcuts tab opens to your navigation pane where you can select objects from My 

Bookmarks or Recently Visited. The system displays shortcuts to only those objects that a
appropriate to the operation you are pe

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appear on the 
Shortcuts tab if it has no attachments. 

W n the results of your search are returned, select a row in the results table, and the related 
 for that object appear in the Related Files table. 

In e Related Files table, select the file you want. 
If the selected search object is a file folder, use the Version drop-down list in 
Files  to select the file folder version you want. 
If the cted search object is an item, in the Related Files table displays item 
attachments for each released revision of the item (the file name followed by the revision
number or letter, for example, widget.dwg - A and widget.dwg - B). 

Note For item objects, Intr
appear in the related files list.  

 If the selected search object is a business object, check the Show Matching File Types On
checkbox to display only the related files that are the same file type as the file you with
which you want to c

ly 
 

ompare.  

attachments you want. 

The files and the comparison results are displayed in a single viewer window. Fore more 

6.  When you are finished, Click OK. 

You can continue to run multiple searches or shortcuts until you are finished selecting the 
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information about compare file features and options, choose Help > Content in the viewer menu bar.  

st first select and view an appropriate file, that 
e analysis. 

2. ork with and choose: 
(s) 

e. 

3. mpare. 

4. Use
wer 

 se to use Agile bookmarks to open files from the Agile Viewer window. 
m the Agile Viewer 

 file: 

 dialog to display File Open dialog.  

ct the directory you want. 

3. 

4.  Open dialog. 

e to the current 

1. Click the Agile Browse button in the File Open dialog to display the DMS: File Open dialog.  

2. MS

n 

Initiate Compare in the Agile Viewer 
To initiate comparing files in the Agile Viewer, you mu
is, a file type that can be used for compar

View an appropriate file for compare: 

1. Display the Attachments tab or the Files tab. 

Select a file row you want to w
 Java Client: View Files
 Web Client: View 

The Agile Viewer opens and displays the selected fil

In the Agile Viewer Analysis menu, choose Co
The Agile Viewer File Open dialog appears. 

 one of the following File Open dialog methods to select a file to compare: 
 Browse to browse your local directories to select and open files from the Agile Vie

window. 
Agile Brow

 Search to perform an Agile Quick Search to select an open files fro
window. 

 

Browse to browse your local directories to select an attachment

1. Click the Browse button in the File Open

2. Use the Look in: drop-down list to sele

Select the file you want and click Open. 

Click OK in the File

The Viewer opens the selected file, or, if appropriate, adds the selected fil
analysis function. 

Agile Browse to use your Agile Bookmarks to select an attachment file: 

The D : File Open dialog displays your Agile Bookmarks in a tree structure. 

Note If you have not defined any Bookmarks in Agile PLM, the Agile Browse butto
does not appear in the File Open dialog. 

3. Click + to expand a bookmark and display its item revisions or its file folder versions. 

4. 

alog. 

6.  Open dialog. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the current 

Click a revision or version row to highlight the file you want to view. 

5. Click OK in the DMS: File Open di

The selected file name appears in the File Name field of the File Open dialog. 

Click OK in the File
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analysis function. 

Agile Search to perform a quick search to select an attachment file: 

Click the 1. tton in the File Open dialog to display a Search dialog which allows you 

2. 

 

r as 

  parameter to Yes to search the contents of the 

3. + next to the object number to expand the list of 

rsion row to select the file you want to view. 

5. 

 the File Name field of the File Open dialog. 

6. 

ected file, or, if appropriate, adds the selected file to the current 

he 
le overlay 

Important 

Administrator Guide. Contact your Agile Account Executive or reseller to 
obtain a license. 

lient and Web Client 

2. le ith and choose 
verlay . 

Agile Search bu
to run a quick search. 

Define your search and click the Search button: 
 Class - Select an object class, for example, Items. 

Search Parameter - Enter a text string or a number. 

Agile PLM searches the object ID number attribute and the object Name or Description 
attribute. A Quick search behaves like a Contains search for text strings. The search 
criteria is treated as a single string and Agile PLM searches for names or descriptions that 
contain the search parameter string. In the case of ID numbers, Agile PLM searches for an 
exact match, however, you may use wildcard characters to specify part of an ID numbe
a search criteria. 
Search Attachment Content - Set this
attachment files as well. 

In the Search Results table, click the 
attachment files for that object. 

4. Click a revision row or a ve

Click the Load File button. 

The selected file name appears in

Click OK in the File Open dialog. 

The Viewer opens the sel
analysis function. 

Overlaying Files 
Overlaying files is also described in the viewer online Help. In Agile, this feature is initiated from t
file folder Files tab rather than from the viewer menus. For detailed information about fi
features, see the Viewer online help. Choose Help  > Contents in the viewer menu bar. 

Overlaying files features are available only with Agile Advanced Viewer. In order to use 
these features, your company must have the View and Mark Up (3D) server license, 
which provides access to Advanced Viewer functions. For more information about server 
licenses, see the 

 
 

Overlaying Files in Java C
To initiate overlaying files: 

1. Display the Attachments tab or the Files tab. 

Se ct both file rows you want to work w
 Java Client:  View File(s)  > O
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 Web Client: View > Overlay. 

The files are displayed in a single viewer window, one on top of the other. For more information
about overlay file features (for example, 

 
File > Overlays in the menu bar) and options, choose 

r. 

2. e: 
 

ree Search tabs. 
 

3. siness object (for example, items or 
ents of those objects to use to overlay.  

se

 ens to your navigation pane where you can browse in search folders, 
tems 

  you can select objects from My 
 

s appear in the search results table. For example, a 

he related 

earches or shortcuts until you are finished selecting the 

7. 

on top of the other. For more information 
rlays in the menu bar) and options, 

 must first select and view an appropriate file, that 
. 

2. Select a file row you want to work with and choose: 

Help  > Contents in the viewer menu ba

To initiate overlaying files By Search: 

1. Display the Attachments tab or the Files tab. 

Select a file row you want to work with and choos
Java Client: View File(s) > By Search > Overlay. 

The Select Files dialog appears, with th
Web Client:  View  > By Search > Overlay. 

The View Files by Search dialog appears, with three Search tabs. 

The search dialog allows you to search for any bu
manufacturer parts) and select the attachm

U  any of the following search methods: 
 Search tab lets you create a simple search or an advanced search. You can check to 

search attachment contents, too. 
Saved Searches tab op
select a search, and run it. Again, returned results may be moved to the Selected I
table, and click OK. 
Shortcuts tab opens to your navigation pane where
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that are
appropriate to the operation you are performing. 

Only business objects with attached file
business object that you viewed recently will not appear on the Recently Visited list of the 
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the Results table, and t
files for that object appear in the Related Files table. 

5. In the Related Files table, select and move attachments to the Selected Files table. 

6. You can continue to run multiple s
attachments you want. 

 When you are finished, click OK. 

The files are displayed in a single viewer window, one 
about overlay file features (for example, Analysis > Ove
choose Help  > Contents in the viewer menu bar. 

 

Initiate Overlay in the Agile Viewer 
To initiate overlaying files in the Agile Viewer, you
is, a file type that can be used for overlay analysis

Vie  an appropriate file for overlay analysis: 

1.  the Files tab. 

w

Display the Attachments tab or
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 Java Client: View Files(s) 

ile. 

3. erlay. 

4. 
r 

 Search to perform an Agile Quick Search to select an open files from the Agile Viewer 

en dialog.  

the directory you want. 

Open. 

4. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the current 

en dialog.  

2. 

Note If you have not defined any Bookmarks in Agile PLM, the Agile Browse button 

 Web Client: View 

The Agile Viewer opens and displays the selected f

In the Agile Viewer Analysis menu, choose Ov
The Agile Viewer File Open dialog appears. 

Use one of the following File Open dialog methods to select a file to overlay: 
 Browse to browse your local directories to select and open files from the Agile Viewe

window. 
 Agile Browse to use Agile bookmarks to open files from the Agile Viewer window. 

window. 
 

Browse to browse your local directories to select an attachment file: 

1. Click the Browse button in the File Open dialog to display File Op

2. Use the Look in: drop-down list to select 

3. Select the file you want and click 

Click OK in the File Open dialog. 

analysis function. 

Agile Browse to use your Agile Bookmarks to select an attachment file: 

1. Click the Agile Browse button in the File Open dialog to display the DMS: File Op

The DMS: File Open dialog displays your Agile Bookmarks in a tree structure. 

 
does not appear in the File Open dialog. 

3. Click + to expand a bookmark and display its item revisions or its file folder versions. 

ht the file you want to view. 

5. 

 the File Name field of the File Open dialog. 

6. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the current 

og to display a Search dialog which allows you 

2. fi

 

4. Click a revision or version row to highlig

Click OK in the DMS: File Open dialog. 

The selected file name appears in

Click OK in the File Open dialog. 

analysis function. 

Agile Search to perform a quick search to select an attachment file: 

1. Click the Agile Search button in the File Open dial
to run a quick search. 

D ne your search a
 Class 
e nd click the Search button: 

- Select an object class, for example, Items. 
Search Parameter - Enter a text string or a number. 

Agile PLM searches the object ID number attribute and the object Name or Description 
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attribute. A Quick search behaves like a Contains search for text strings. The search 
criteria is treated as a single string and Agile PLM searches for names or descriptions that 
contain the search parameter string. In the case of ID numbers, Agile PLM searches for an 

umber as 

nd the list of 

rsion row to select the file you want to view. 

5. 

 the File Name field of the File Open dialog. 

6. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the current 

Important ly with 
the 

anced Viewer 
functions. For more information about server licenses, see the Adm  

For information about these features, refer to the viewer online help. Choose Help > Contents in the 

fer to the viewer online help. Choose 

Important  

cess to Advanced Viewer functions. For more information about server 
licenses, see the Administrator Guide. Contact your Agile Account Executive or reseller to 
obtain a license. 

tion feature is available to all users who have Agile Discovery, Read, 

exact match, however, you may use wildcard characters to specify part of an ID n
a search criteria. 

 Search Attachment Content - Set this parameter to Yes to search the contents of the 
attachment files as well. 

3. In the Search Results table, click the + next to the object number to expa
attachment files for that object. 

4. Click a revision row or a ve

Click the Load File button. 

The selected file name appears in

Click OK in the File Open dialog. 

analysis function. 

Working with Schematic and PCB Files 
Features for schematic and PCB files, also referred to as EDA files, are available on
the Agile Advanced Viewer.In order to use these features, your company must have 
View and Mark Up (3D) server license, which provides access to Adv

inistrator Guide.
Contact your Agile Account Executive or reseller to obtain a license. 

Viewer menu bar. 

Real-Time Collaboration 
For detailed information about collaboration features, re
Help > Contents in the Viewer menu bar. The following sections discuss Agile View server information 
and Agile privileges that affect collaboration sessions. 

Real-time collaboration features are available only with Agile Advanced Viewer. In order to
use these features, your company must have the View and Mark Up (3D) server license, 
which provides ac

 
 

Overview of Collaboration Sessions 
The Collaboration feature lets multiple users team up and review documents interactively and 
simultaneously, thus shortening an otherwise lengthy review process where documents are passed 
back and forth. The Collabora
and the appropriate privileges that allow you to redline attachment files (for example, the Agile 
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default role Markup for Self). 

From the Collaboration menu, anyone with the required Agile privileges can initiate a Collaboratio
nd act as host, or join a Collaboration session if invited by the host. 

If you plan to host a Collaboration session, ensure that

n 
session a

Important 
s 

ple, the Agile default role Markup for Self). If they can view and redline a file, 
ssary privileges. If they cannot, contact your Agile administrator, who 

 

the collaborators must be logged into Agile 
laboration session. They do not need view the 

 

Collaboration menu during a Collaboration session. It displays the session subject (the name 

markup entities. Participants are assigned different layer colors for the session so that the markup 

only one 

Note In order to use the collaboration feature all users must connect to the same Agile Viewer 

 all intended participants have 
Discovery, Read, and the appropriate privileges that allow them to redline attachment file
(for exam
they have the nece
can grant them the necessary privileges, before you attempt to initiate the Collaboration
session. 

In order to participate in the collaboration session, all 
and viewing a file in the viewer when you start the col
file you are going to review in the collaboration session; they can view any file. For this reason, they
may choose to view a small file that will load quickly. 

When the host initiates a Collaboration session, a session object is created on the server, which is 
maintained for the duration of the Collaboration session. Session information is available from the 

assigned to the Collaboration session), the session ID (each session subject is assigned a unique 
session ID), the name of the base file viewed, the host, and the list of users participating. 

A session markup file is created during the Collaboration session to which all participants can add 

entity from each participant is identifiable. The host for the session owns the markup file and is the 
who can save it. 

server. All users must specify, in their user profile, Preferences tab, under System 
 Preferred File Manager setting. Preferences, the same

 

Digital Mockup 
In 3D mode, you can use the Mockup feature (DMU) to test alignment and
assemblies. You can save the mockup as a redline markup entity. 

 interference of multiple 

 

Client and Web Client 

1. 

2.  with and choose: 

Digital Mockup in Java 
To initiate Digital Mockup of files: 

Display the Attachments tab or the Files tab. 

Select all the file rows you want to work
 Java Client: View File(s) > Digital Mockup. 
 Web Client:  View  > Digital Mockup. 

The files are loaded into the same Viewer workspace. 

3. Manipulate the models using the viewer features including the features in the Analysis menu, for 
example User Defined Coordinate Systems, Manipulators, Interference Checking, and Part 
Alignment. 
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For information about these features, refer to the viewer online help. Choose Help > Contents in the 

1. 

2.  with and choose: 

 viewer online help. Choose Help > Contents in the 

1. 

2. Sele
kup. 

3. 

 
ontents, too. 

re 
e performing. 

ar on the Recently Visited list of the 

ted 

nd move attachments to the Selected Files table. 

6.  until you are finished selecting the 

Viewer menu bar. 

To initiate Digital Mockup of files: 

Display the Attachments tab or the Files tab. 

Select all the file rows you want to work
 Java Client: View File(s) > Digital Mockup. 
 Web Client:  View  > Digital Mockup. 

The files are loaded into the same Viewer workspace. 

3. Manipulate the models using the viewer features including the features in the Analysis menu, for 
example User Defined Coordinate Systems, Manipulators, Interference Checking, and Part 
Alignment. 

For information about these features, refer to the
Viewer menu bar. 

To initiate Digital Mockup of files By Search: 

Display the Attachments tab or the Files tab. 

ct a file row you want to work with and choose: 
 Java Client: View File(s) > By Search > Digital Moc

The Select Files dialog appears, with three Search tabs. 
 Web Client:  View  > By Search > Digital Mockup. 

The View Files by Search dialog appears, with three Search tabs. 

The search dialog allows you to search for any business object (for example, items or 
manufacturer parts) and select the attachments of those objects to use for the mockup.  

Use any of the following search methods: 
Search tab lets you create a simple search or an advanced search. You can check to 
search attachment c

 Saved Searches tab opens to your navigation pane where you can browse in search folders, 
select a search, and run it. Again, returned results may be moved to the Selected Items 
table, and click OK. 

 Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that a
appropriate to the operation you ar

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appe
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the Results table, and the rela
files for that object appear in the Related Files table. 

5. In the Related Files table, select a

You can continue to run multiple searches or shortcuts
attachments you want. 

7.  When you are finished, click OK. 

 Page - 45

  

 



Viewer Supplement   
 
 
 

The files are loaded into the same Viewer workspace. 

8.  
Coordinate Systems, Manipulators, Interference Checking, and Part 

elp. Choose Help > Contents in 

ewer 
er, you must first select and view an appropriate 

analysis. 

w

1. s tab or the Files tab. 

2. 

3. 

The er File Open dialog appears. 

4. e

ewer window. 
 Agile Viewer 

o select an attachment file: 

 Open dialog to display File Open dialog.  

2. 

3. want and click Open. 

Agile Browse

1. Click the  to display the DMS: File Open dialog.  

gile Browse button 

Manipulate the models using the viewer features including the features in the Analysis menu, for
example User Defined 
Alignment. 

For information about these features, refer to the viewer online h
the Viewer menu bar. 

 

Initiate Mockup (DMU) in the Agile Vi
To initiate DMU analysis of files in the Agile View
file, that is, a file type that can be used for DMU 

Vie  analysis:  an appropriate file for DMU

Display the Attachment
Select a file row you want to work with and choose: 
 Java Client: View Files(s) 
 Web Client: View 

The Agile Viewer opens and displays the selected file. 

In the Agile Viewer Analysis menu, choose DMU. 

 Agile View

Us  one of the following File Open dialog methods to select files for DMU analysis: 
 Browse to browse your local directories to select and open files from the Agile Viewer 

window. 
 Agile Browse to use Agile bookmarks to open files from the Agile Vi
 Search to perform an Agile Quick Search to select an open files from the

window. 
 

Browse to browse your local directories t

1. Click the Browse button in the File

Use the Look in: drop-down list to select the directory you want. 

Select the file you 

4. Click OK in the File Open dialog. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the current 
analysis function. 

 to use your Agile Bookmarks to select an attachment file: 

Agile Browse button in the File Open dialog

2. The DMS: File Open dialog displays your Agile Bookmarks in a tree structure. 

Note If you have not defined any Bookmarks in Agile PLM, the A
does not appear in the File Open dialog. 

3. rsions. 

4. Click a revision or version row to highlight the file you want to view. 

Click + to expand a bookmark and display its item revisions or its file folder ve
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5. Click OK in the DMS: File Open dialog. 

6.  Open dialog. 

d file to the current 

Agi  quick search to select an attachment file: 

ay a Search dialog which allows you 

2. 
 
 

s a single string and Agile PLM searches for names or descriptions that 
es for an 

u may use wildcard characters to specify part of an ID number as 

et this parameter to Yes to search the contents of the 

le, click the + next to the object number to expand the list of 
ject. 

4. 

6. Click OK in the File Open dialog. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the current 
analysis function. 

The selected file name appears in the File Name field of the File Open dialog. 

Click OK in the File

The Viewer opens the selected file, or, if appropriate, adds the selecte
analysis function. 

le Search to perform a

1. Click the Agile Search button in the File Open dialog to displ
to run a quick search. 

Define your search and click the Search button: 
Class - Select an object class, for example, Items. 
Search Parameter - Enter a text string or a number. 

Agile PLM searches the object ID number attribute and the object Name or Description 
attribute. A Quick search behaves like a Contains search for text strings. The search 
criteria is treated a
contain the search parameter string. In the case of ID numbers, Agile PLM search
exact match, however, yo
a search criteria. 

 Search Attachment Content - S
attachment files as well. 

3. In the Search Results tab
attachment files for that ob

Click a revision row or a version row to select the file you want to view. 

5. Click the Load File button. 

The selected file name appears in the File Name field of the File Open dialog. 
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Chapter 3 

Modified and Unavailable Viewer 
Features 

This chapter includes the following: 

 User Interface Modifications ................................................................................................................................ 49 
 File Storage and Management Modifications ...................................................................................................... 49 
 Opening Files Features ....................................................................................................................................... 50 
 Working with Hyperlinks ...................................................................................................................................... 50 
 Viewer Modes ...................................................................................................................................................... 50 

 
 

User Interface Modifications 
The following features described in the viewer online Help have been modified or have been 
suppressed and are not available. 

 Window menu and its options for viewing multiple files (New, Cascade, Tile Horizontally, and Tile 
Vertically) are not available. (See “Viewing Multiple Files in the Agile Viewer”.)  

 The ability to click and drag toolbars to move them is not available.  

 Mnemonic letter shortcuts (ALT+letter) are not available and are not displayed as underlined 
letters in the menus.  

 Tooltips Quick Menu is not available.  

 The Customize > Options menu selection does not include toolbar and tooltip settings.  
 

File Storage and Management Modifications 
Because the Agile system manages and controls access to attached files and markups (redline 
files), the following features described in the viewer online Help may have been modified or are not 
available to you. 

Many of these modifications relate to how files are opened, saved, and where they are stored. 
Instead of using viewer features (for example, File > Open, as described in the viewer online Help) to 
view files, the files are selected via the Agile object Attachments tab and the file folder Files tab, and 
retrieved from the file vault, part of Agile File Manager (AFM). The files are then displayed in the 
viewer window. When you create and save markup files, they are also saved in the file vault. (See 
Opening Agile Attachment Files in the Viewer (on page 17) and Guidelines for Marking Up or 
Redlining Attachments (on page 25).) 

If you need more information about a viewer feature, see the viewer online Help. To view online 
Help, choose Help > Content in the menu bar. 
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Opening Files Features 
These features described in the viewer online Help are not available: 

 Viewer Startup view (empty viewer window).   

 Drag and drop files from Windows Explorer onto the viewer window to open them.  

 The following viewer File menu selections are not available in the Agile Advanced Viewer: Open, 
Browse, Next File, Previous File, Load File, Open URL, and Close. 

 Archive file directory displayed in viewer window. 

 Import and Export Markup files feature is not available. Import and Export 3D Models is not 
available. 

Access to all files, including markup files, is managed by the Agile system. For more 
information about markup files in Agile, see Marking Up — How It Works (on page 25) and 
Guidelines for Marking Up or Redlining Attachments (on page ).  25

Working with Hyperlinks 
Refer to the Agile Viewer online help for details about working with and creating hyperlinks. To view 
the online help, choose Help  > Contents in the viewer menu bar. 

Although you can create hyperlink markup entities, you cannot create hyperlinks to other files in the 
Agile file vault. 

The purpose of this viewer feature is to gather or link related information together. This functionality 
is provided by Agile features such as Attachments tabs (which may have multiple attached file folder 
objects) and Relationships tabs. For more information about file folder objects and attachments see 
Getting Started in Agile PLM. 

Viewer Modes 
The viewer modes Startup View and Thumbnails Mode described in the online Help are not 
available. 

Page - 50 Agile Product Lifecycle Management 

 

 



 

Chapter 4 

Printing 
This chapter includes the following: 

 Printing Documents from within the Viewer ......................................................................................................... 51 
 Headers/Footers Group in Print Properties ......................................................................................................... 51 
 Watermarks and Banners in Print Properties ...................................................................................................... 52 
 Stamps Group In Print Properties........................................................................................................................ 52 
 Printing DGN Files ............................................................................................................................................... 53 

 
 

Printing Documents from within the Viewer 
For detailed information about printing attachments from the file folder object Files tab, see the 
Getting Started with Agile PLM manual, Chapter 9, “Working with Attachments", and Chapter 10, 
"Working with File Folders.” 

For detailed information about printing from the viewer, see the viewer online Help. To view online 
Help, choose Help > Content in the viewer menu bar. 

For information about how the Agile administrator can customize the Viewer print options. see 
Viewer Administration Tasks (on page 55). 

The following sections describe print features that have been modified to integrate the viewer with 
the Agile system. 

Headers/Footers Group in Print Properties 
This group defines the headers and footers to be included on every printed page of the document.           

Note These settings are maintained and modified by your Agile administrator. 

To view the header and footer settings: 

Select the Headers/Footers tab. 

A literal percentage mark is indicated by %%. Other codes are as follows: 

 %f = full path of document (for example, D:\PICS\TIFF\CTROK.TIF) 

 %v = document drive 

 %d = document directory (for example, D:\PICS\TIFF) 

 %b = document base name (for example, CTROK) 

 %e = document file extension (for example, TIF) 

 %n = total number document pages 
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 %p = current page number 

 %N = total number of tiled pages 

 %P = current tile number 

 %r = newline 

 %F = Excel native print settings 

 %Y = date: year 

f week 

 %S = time: second 

Watermarks and Banners in Print Properties 
des a Watermark tab. This tab cannot be modified in the Agile 

r 
and watermarks. 

 BMP) will not show the watermark. It will show only on “transparent” file 
AD). 

Note 

 %M = date: month 

 %D = date: day 

 %W = date: day o

 %H = time: hour 

 %U = time: minute 

 

The Print Properties dialog box inclu
Viewer Print Properties dialog box. 

Watermark and Banner settings are defined and maintained in Agile Administrator. The Agile 
Administrator watermark and banner settings determine whether banners and watermarks appea
on printouts of files attached to Agile objects and the content of those banners 
These banners and watermarks appear on files printed with the Agile Viewer. 

Watermarks on attachments are inserted under the file. Therefore, file types that are in “solid” 
formats (for example, PDF,
types (for example, C

Watermarks 
A faint and transparent watermark appears on the current document’s contents. 

For high resolution black and white printing, the transparent watermark is printed on the 
current document’s contents. For low resolution black and white printing, the watermark is 
printed on the current document’s contents, but it is not transparent. 

The watermark settings are maintained and modified by your Agile administrator; see the 
Administrator Guide. For more information, see Viewer Administration Tasks (on page 55). 

Stamps Group In Print Properties 
Note This feature is not available in this implementation of Agile Viewer. 
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Printing DGN Files 
Agile Viewer can be configured to print files with a DGN extension in the same manner as 
MicroStation. This option must be configured on the server side; please contact your Agile system 
administrator for assistance.           

 Page - 53

  

 



Viewer Supplement   
 
 
 

 

Page - 54 Agile Product Lifecycle Management 

 

 



 

Chapter 5 

Viewer Administration Tasks 
This chapter includes the following: 

 Setting the Print Options...................................................................................................................................... 55 
 Adding Fonts........................................................................................................................................................ 57 
 Viewing Excel Files.............................................................................................................................................. 57 

Note For information about Agile PLM Administrator settings related to the Agile Viewer (for 
example, Supported File and Valid Model File Type settings), see Administrator Guide, “Viewer 
and Files” section of the “General System Settings” chapter. 

For more information about the Agile View Server, including where to find additional Agile View 
Server documentation, see the appropriate Agile installation guide for your Agile PLM system; refer 
the chapter about configuring the Agile View Server. 
 

Setting the Print Options 
Some file formats require configuring specific settings to print properly. In general, you can change 
these settings for all users or for individual users: 

 To change the print settings for all users, you need to modify some of the parameters in the 
AVS\bin\allusers.ini file. 

 To change the print settings for individual users, you need to modify some of the parameters in 
each user's .ini file under AVS\bin\profiles. 

Caution When you modify options in the allusers.ini file, the existing user profiles are not 
automatically modified. Because editing every individual user profile is impractical, in the 
procedures below you are instructed to delete the existing user profiles when you modify 
allusers.ini. The next time a user opens the Agile Viewer, a new user profile is created 
which includes the new allusers.ini options settings. You may want to notify your users in 
advance to let them know that their user profiles will be reset. 

To change the way that the watermark, border, and header (banner) appear when printed, you will 
need to modify the following .ini file parameters: 

 [OPTIONS] – HPBACKGROUND, KEEPORIGINALCOLORS, and 
SWSHOWVIEWPORTBORDER 

 [PRINTWATERMARK] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE 

 [PRINTHEADERS] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE 

The following sections describe the procedures for printing watermarks and borders, and for 
modifying the headers and watermarks. 
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Printing Watermarks in .hpg and .plt Files 
To print watermarks correctly in .hpg and .plt files, you must set the background color correctly. 

Note If the watermark image or the color used in the watermark image is not transparent, the 
watermark will not be visible. 

To set the background color: 

1. Shut down the JVue server. 

2. On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini) 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, add or update the following two lines: 

HPBACKGROUND = 0
KEEPORIGINALCOLORS = 1

Printing Viewport Borders in SolidWorks Files 
To print viewport borders correctly in SolidWorks files, you must enable the viewing/printing of 
viewport borders. 

To enable the option: 

1. Shut down the JVue server. 

2. On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, add or update the following line: 

SWSHOWVIEWPORTBORDER = 1

Modifying the Header and Watermark Font Settings 
Note The watermark may be truncated if the font size is too large or if there are too many 

characters in the watermark text. Truncation ensures that the watermark does not distort 
the image. 

To set the watermark font size: 

1. Shut down the JVue server. 

2. On the drive where the Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [PRINTHEADERS] section and in the [PRINTWATERMAK] section, update the lines for 
Fontname, Fontsize, Orientation, and Fontstyle. For example: 
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FONTNAME = Serif
FONTSIZE = 24
ORIENTATION = 1
FONTSTYLE = 2

Note ORIENTATION can be specified as 1 (portrait) or 2 (landscape). 
 

Adding Fonts 
To ensure that specific fonts are recognized by the Agile Viewer, you can add the font path to the 
allusers.ini configuration file. 

To add fonts: 

1. Shut down the JVue server. 

2. On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, update the following line: 

XFONTPATHS = {paths}
6. Add the full paths of the font files to the line. Separate the paths with a semicolon. 

7. Save the allusers.ini file. 

8. Clear your web browser’s cache. 

9. Restart the JVue server. 
 

Viewing Excel Files 
When viewing Excel files in the Agile Viewer, the number of pages listed in the viewer status bar is 
the number of Excel worksheet and the Viewer menu command View > Page selects a different Excel 
worksheet to view. 
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