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Copyright and Trademarks 
Copyright © 1995, 2008, Oracle and/or its affiliates. All rights reserved. 

This software and related documentation are provided under a license agreement containing 
restrictions on use and disclosure and are protected by intellectual property laws. Except as 
expressly permitted in your license agreement or allowed by law, you may not use, copy, 
reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish or 
display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation 
of this software, unless required by law for interoperability, is prohibited. 

The information contained herein is subject to change without notice and is not warranted to be 
error-free. If you find any errors, please report them to us in writing. 

If this software or related documentation is delivered to the U.S. Government or anyone licensing it 
on behalf of the U.S. Government, the following notice is applicable: 

U.S. GOVERNMENT RIGHTS 
Programs, software, databases, and related documentation and technical data delivered to U.S. 
Government customers are "commercial computer software" or "commercial technical data" 
pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental 
regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject 
to the restrictions and license terms set forth in the applicable Government contract, and, to the 
extent applicable by the terms of the Government contract, the additional rights set forth in FAR 
52.227-19, Commercial Computer Software License (December 2007). Oracle USA, Inc., 500 
Oracle Parkway, Redwood City, CA 94065. 

This software is developed for general use in a variety of information management applications. It is 
not developed or intended for use in any inherently dangerous applications, including applications 
which may create a risk of personal injury. If you use this software in dangerous applications, then 
you shall be responsible to take all appropriate fail-safe, backup, redundancy and other measures 
to ensure the safe use of this software. Oracle Corporation and its affiliates disclaim any liability for 
any damages caused by use of this software in dangerous applications. 

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be 
trademarks of their respective owners. 

This software and documentation may provide access to or information on content, products and 
services from third parties. Oracle Corporation and its affiliates are not responsible for and 
expressly disclaim all warranties of any kind with respect to third party content, products and 
services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages 
incurred due to your access to or use of third party content, products or services. 
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Preface 
The Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle Technology 
Network (OTN) Web site http://www.oracle.com/technology/documentation/agile.html contains the 
latest versions of the Agile PLM PDF files. You can view or download these manuals from the Web 
site, or you can ask your Agile administrator if there is an Agile PLM Documentation folder available 
on your network from which you can access the Agile PLM documentation (PDF) files. 

Note To read the PDF files, you must use the free Adobe Acrobat Reader version 7.0 or later. 
This program can be downloaded from the Adobe Web site http://www.adobe.com. 

The Oracle Technology Network (OTN) Web site 
http://www.oracle.com/technology/documentation/agile.html can be accessed through Help > Manuals 
in both Agile Web Client and Agile Java Client. If you need additional assistance or information, 
please contact support http://www.oracle.com/agile/support.html 
(http://www.oracle.com/agile/support.html) for assistance. 

Note Before calling Agile Support about a problem with an Agile PLM manual, please have the 
full part number, which is located on the title page. 

TTY Access to Oracle Support Services 

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479. 

Readme 

Any last-minute information about Agile PLM can be found in the Readme file on the Oracle 
Technology Network (OTN) Web site http://www.oracle.com/technology/documentation/agile.html

Agile Training Aids 

Go to the Oracle University Web page 
http://www.oracle.com/education/chooser/selectcountry_new.html for more information on Agile 
Training offerings. 
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Accessibility of Code Examples in Documentation  

Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise empty line; 
however, some screen readers may not always read a line of text that consists solely of a bracket or 
brace.  

Accessibility of Links to External Web Sites in Documentation  

This documentation may contain links to Web sites of other companies or organizations that Oracle 
does not own or control. Oracle neither evaluates nor makes any representations regarding the 
accessibility of these Web sites.  





 

Chapter 1 

Resolved Issues 

This chapter includes the following: 

 Install and Test Notice ......................................................................................................................................... 7 
 Oracle|Agile Patch Note ...................................................................................................................................... 7 
 Common Services ............................................................................................................................................... 7 
 Install and Upgrade.............................................................................................................................................. 12 
 Integration............................................................................................................................................................ 15 
 Product Collaboration .......................................................................................................................................... 22 
 Product Cost Management .................................................................................................................................. 28 
 Product Portfolio Management ............................................................................................................................ 30 
 Product Quality Management .............................................................................................................................. 35 

This section lists issues that were resolved during this release. Numbers in bold (for example, 
123456) are Customer Support ID numbers from customer-reported issues. 
 

Install and Test Notice 
Important Install and test this release on a designated development server before installing it on 

your production environment. Your development environment should mirror your 
production environment as closely as possible to provide accurate testing results. It is 
important to validate the installation of this release, and confirm your integrations are 
working correctly as part of your minimum due diligence. Any problems or questions noted 
during your development system testing should be resolved before installing this release 
on your production environment. 

 

Oracle|Agile Patch Note 
Note The contents of this release include the following Patches: Oracle|Agile PLM 9.2.1.3HF52, 

9.2.1.4HF23, 9.2.2.2HF17, 9.2.2.3HF3, 9.2.2.3HF4, and 9.2.2.3HF6. 
 

Common Services 
281281/ 18973482.6

282585/ 18974748.6

283219/ 18975322.6

Standard Reports 

Issue: Report titles are showing the attribute name and not the actual configured name. 
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Root Cause: Using internal attribute name of the Item Manufacturer tab. 

Resolution: Replace the name with display names. 

Verification: Follow the steps below to verify the resolution: 

1. In Java Client, go to Data Settings > Classes > Parts class > User Interface tab > Select BOM > 
Attributes: BOM tab. 

2. Rename BOM.List01 (both name and the description fields) and enable the field to be visible.  

3. Go to Reports and Analytics > Standard Reports > Run Where Used Report report from Web 
Client. 

4. Select the Default Layout and make necessary changes for the field to be visible. 

5. In generated report, the attribute name will display the customized one. If the customized 
attribute name is the same for both Part and Document object, there will be one customized 
name displayed in the generated report. If Document and Part have different attribute name for 
the same attribute, the report output will display both of these two names. 

 

 

282366/ 18974548.6

Standard Reports 

Issue: Item description changes on the Where Used report results. 

Root Cause: A hard-coded Rev and Site information is passed to the report server side so the report 
displays a wrong description. 

Resolution: Remove the code and pass the Rev and Site information to report server side. 

Verification: Follow the steps below to verify the resolution: 

1. Log into Web Client. 

2. Create a Part. 

3. Ensure this part has at least 2 or 3 revisions and change the part description in each revision 
(Release the part using ECO). 

4. Execute the Where Used Report. 

5. Select this Part, and note the latest part description is shown. 

6. In the Report Output window note the Part Description, this shows the Part description of the 
latest released revision. 

 

 

284426/ 18976596.6

Custom Report 

Issue: Problems from saving and modifying personal reports. 

Root Cause: Each user has a personal report folder, although the folder names are the same. The 
report is stored in User1's personal folder, so when user2 performs a SaveAs on the report, the new 
report will still be stored in the User1's personal folder. From this view, the behavior is correct, but 
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from the security view, this behavior is not acceptable. So when performing these two actions, 
additional logic should be applied to avoid this case. 

Resolution: Do not perform a SaveAs Custom report into another users' personal folder. Check the 
folder type first. If the folder type is a personal folder and the folder does not belong to the user, 
then the folder information will be blank when user2 does a SaveAs action. 

Verification: Follow the steps below to verify the resolution: 

1. User1 sends a link from their personal reports to User2. 

2. User2 performs a SaveAs from that link creating a new version of the report. 

3. The new version is automatically saved. Meanwhile, the Folder field on the Cover Page will not 
display the Personal folder in the newly created report. 

 

 

296849/ 18994642.6

Searches 

Issue: List of available values in an Advanced Search on manufacturers.General 
Info.State/Province/Region do not change when the List that the attribute is linked to changes. 

Verification: Follow the steps below to verify the resolution: 

1. In Java Client as administrator, go to Data Settings > Classes and open Manufacturers > User 
Interface Tabs > General Information > State/Province/Region. 

2. Change Visible to Yes if it is not already. 

3. Change List to another list that has some values or create a new list with values for this attribute 
to be linked to. 

4. Save changes. 

5. Open another session (either Web or Java). 

6. Open a Manufacturer object and verify that the available values are consistent with your new list. 

7. Start an advance search with following criteria: 

Object Type: Manufacturers 

Field: General Info.State/Province/Region 

Match if: In 

8. Next, click on Values for the search and see that it remains linked to the Region/Province/State 
list instead of the new list that you linked the attribute to. 

9. The values for the list is changed to new list values. 
 

 

297171/ 18995108.6

Standard Reports 

Issue: Mfr Names that contain three blanks export to Microsoft Excel with only one blank. 

Root Cause: Browser behavior. If the content contains several blanks, browser just displays them 
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with only one blank. Essentially the exported report is not a native Excel but a web file. 

Resolution: Convert the blank characters to entity (&nbsp;) first. 

Verification: Follow the steps below to verify the resolution: 

1. Create a Manufacturer (Mfr) with three blanks in its name. 

2. Create a Custom Report; include the Mfr Name in the Report Output field. 

3. Execute the report; export the result into two formats: xls and csv; in the exported file the Mfr 
name can be displayed with three blanks correctly. 

Note Not for BI publisher report. In BI Publisher report the 3 blanks will be auto-convert into 1 
Blank in an exported report. 

 

 

297954/ 18996234.6

Category 

Issue: Deleted sites appear in the user configuration report. 

Root Cause: When deleting the site, did not delete site reference, for example the user_assignment 
table. 

Resolution: Handle and filter out those sites which delete_flag is 1. 

Verification: Follow the steps below to verify the resolution: 

1. Create Site A, assign it to User01.  

2. Disable and delete Site A. 

3. Execute User Configuration Report and check User01 column; the deleted site is no longer 
displayed in generated report. 

 

 

298145/ 18996524.6

302584/ 19004202.6

Attachments 

Issue: Checkout on the Content tab is not downloading the file correctly. 
 

 

298169/ 18996566.6

Standard Reports 

Issue: Users Configuration Report does not provide Geography Information. 

Root Cause: Missing the Get function for this attribute value. 

Resolution: Added a new Integer (CMType.ATT_USER_GEOGRAPHY), 'getGeography' in the 
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methods variable of UserConfiguration.java. 

Verification: Follow the steps below to verify the resolution: 

1. Fill in the Geography field of the user in his profile.  

2. Go to Reports and Analytics.  

3. Expand Standard Reports.  

4. Expand Administrator Reports.  

5. Execute Users Configuration Report.  

6. Geography field can be displayed with correct value. 
 

 

301186/ 19001704.6

Searches 

Issue: A deleted item search takes too long. 

Root Cause: SQL Generated uses NVL function and Order by clause. 

Verification: Follow the steps below to verify the resolution: 

1. Log into Web Client. 

2. Search out about 600 items and soft delete them. 

3. Click on the Search Folder icon on the left hand pane. 

4. Go to Recycle Bin Searches > Deleted Items. 

5. The results are presented normally. 
 

 

301992/ 19003062.6

300478/19000378.6

Web Client 

Issue: Wrong search result when using Prompt and searches for item number with leading zero. 

Verification: Follow the steps below to verify the resolution: 

1. Create items with item numbers: 

900002, 090004 (leading zero and leading number) 

2. Create and save a search with the following definition: 

Object: Items (or Parts) 

Title Block. Number Starts With  

3. Run the search and enter "09" as the parameter. 

4. The result will be 090004. 
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302646/ 19004324.6

305367/ 19009564.6

305375/ 19009580.6

306241/ 19011300.6

Web Client 

Issue: Hanging OC4J process leads to high CPU usage. 

Root Cause: Issue was with the Hashmap where multiple objects/threads were trying to access the 
same hashmap and was going into infinite loop. 

Resolution: Modified the code to synchronize the hashmap. 

 

302891/ 19004740.6

Web Client 

Issue: The user is unable to create multiple groups within an advanced search. 

Root Cause: Because of the wrong condition, adding multiple groups was not allowed. 

Resolution: Fixed the issue by modifying the condition to allow multiple groups and also not allowing 
adding nested brackets. 

Verification: Follow the steps below to verify the resolution: 

1. Log into Web Client and create a new advanced search. 

2. Search for Change Orders; add some search criteria such as: Workflow.Approver\ 
Workflow.Approver Action\ Workflow.Next Status\ Workflow.Workflow Status etc. 

3. Try to add two criteria as one [group1], and another two as another [group2]. 

4. In Web Client, the Add [Group] is not grayed out and it is allowing adding multi-[groups]. 
 

Install and Upgrade 
19002010.6

AUT 

Issue: AUT did not add the Enable for Search Criteria field to custom attributes. 

Root Cause: While deleting notify_template entries before creating a new one, it should not delete the 
customer created notify_templates. While deleting notify_template we should delete the rows with 
customized=0. 

Resolution: Scripts are added so that it will delete notify_template entry row where customized=0. It 
will avoid deleting customer created notify entries. 
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Verification: Follow the steps below to verify the resolution: 

1. Working in the DB, create a list attribute with the name PAGETWO_LISTXXX, where XXX is 
greater than 25. 

2. Now upgrade the same DB to 9.2.2.5 using AUT1.5.6. 

3. Open the newly created attribute and the open attribute. 

4. Check that the Enable For Search Criteria field in the attribute is now created. 
 

 

294758/ 18992074.6

301374/ 19002064.6

AUT 

Issue: Files without any file type and which are in a FileFolder are not migrated. 

Root Cause: Attachment_map table's FILE_ID column had become NULL for file type equal to Folder 
in the customer database while upgrading. 

Resolution: This is fixed by setting FILE_ID equal to '0' in 85to90post upgrade script. 

Verification: Follow the steps below to verify the resolution: 

1. Upgraded the DB to 9.2.2.5 using AUT156. 

2. Connected to the Appserver and checked for all the attachments that were created using different 
scenarios. 

3.  Able to view all three attachments: 

a) URL 

b) Single File Attachment and 

c) Multiple attachments within a file folder. 
 

 

298933/ 18997792.6

Schedule Management 

Issue: Deletion of project objects in the recycle bin leaves orphan records in Activity_baseline table 

Root Cause: The AVerify test case is checking whether all parent ids in Activity Baseline table are 
valid ids in Activity. This is incorrect because after the baseline is created, the parent activities (not 
the root task) could have been soft deleted and later hard deleted. So there will be some rows in 
Baseline table with parent ids that are no longer valid ids in Activity table. 

Resolution: Different error conditions included for testcase: 
a. 1. Baseline ID does not exist in Activity table where parent_id=0 and root_id=0  
b. 2. Activity_baseline with Activity ID=Root_id does not exist  
c. 3. Activity_baseline with Activity ID=parent_id does not exist Verification: Follow the steps 

below to verify the resolution: 

1. Upgraded DB to current Agile release using AUT156. 

 Page - 13

  

 



Readme  
 
 
 

2. From Web Client, created a program and added some phases to the schedule tab of this 
program. Created a baseline now. 

3. Added few more phases to the scheduled tab and created another baseline. 

4. Now deleted the root program from the actions menu and after that from Recycle Bin Searches --
> Deleted programs. 

5. Ran the AVerify testcase that is modified and now the AVerify reports are correct. 
 

 

300795/ 19000962.6

AUT/AVerify 

Issue: AVerify Error AGIL-00155006. 

Root Cause: In the migrate_pgc package NO_DATA_FOUND exception was not handled  well, if 
NO_DATA_FOUND exception arises for one row the whole procedure was coming out without 
updating other rows. 

Resolution: Added NO_DATA_FOUND exception. Even if exception arises it will not affect remaining 
rows. 

 

301206/ 19001744.6

302662/ 19004356.6

AVerify 

Issue: Adding line to set NSL_LANG in averify.bat. 

Root Cause: Running Averify 1.5.X on Japanese DB environment without setting 
NLS_LANG=American_America.utf8. Notice that you will get error: ORA-00904. 

Resolution: NLS parameter has been included in AVerify.properties file with default value 
American_america.utf8. 

Verification: Follow the steps below to verify the resolution: 

1. Checked for the new parameter that has been added to averify.properties file with default value 
AMERICAN_AMERICA.UTF8.  
 

 

302757/ 19004546.6

AVerify 

Issue: AVerify log performs incorrect checking. 

Root Cause: The POOL_IDS column was added to the activity table in agile version 9.2. These test 
cases were not checking the version before running, therefore it was throwing POOL_IDS invalid 
identifier error for 9.2 previous versions. 
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Resolution: Fixed by including Version check for the testcases AGIL-00015002 and AGIL-00105034. 

Verification: Follow the steps below to verify the resolution: 

1. Version check has been added to handle these kinds of errors. 

2. Checked for the added code in the problematic AVerify testcases. 
 

Integration 

Agile 9.2.2.5 SDK 

Agile 9.2.2.5 SDK User Guide contains a What's New section on page 4 that should be reviewed. 
The following summarizes the new features and enhancements implemented in this release of the 
SDK:  

 Building and deploying URL-Based process extensions on a WLS platform. 

 New code samples for Working with RFQ Responses 

 Discrepancy between the actual Project Start dates and SDK returned dates. 

 SDK support for Price Lookup and Cost Rollup functions in Product Cost Management (PCM) 
module. The following two new APIs enable using the SDK to perform these PCM functions: 
 lookupPrices(Object, lookupParams) 
 costRollup() 

Important The PG&C constants and the relationships table functionality in AgileAPI.jar Release 9.2.2 
and subsequent releases of Agile PLM are incompatible with the ones in the earlier 
versions of AgileAPI.jar . 

 

18996472.6

PX 

Issue: Process Extension action menu is not showing up after changing workflow 

Verification:  to verify the resolution:  Follow the steps below

1. Log into Java Client as admin. 

2. Go to Data Settings > Process Extension. 

3. Create following two PXs that Initiate from Actions menu: 

PX-A  

PX-B  

4. Go to Data Settings > Classes. 

5. Open property of Base Class 'Changes'. 

6. Go to Process Extension tab, and set

7. Open property of Sub Class 'ECO'. 

 PX-A. 
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8. Go to Process Extension tab, and set PX-B. 

d name it as 'TEST'. 

 X. 

m Actions menu. Make sure that both PX-A and PX-B are enabled  

5. Select Process Extension from Actions menu. 

5164.6

u but not for Actions Menu. 

 to verify the resolution: 

2. C ith below names in below order: 

 

iate from both 'Tools Menu' and 'Actions Menu'  

9. Go to Workflow Settings. 

10. Save As 'Default Change Orders' workflow an

11. Re-login to Java Client and create ECO

12. Set workflow 'Default Change Orders'. 

13. Select Process Extension fro

14. Change workflow to 'TEST'. 

1

 

1900

PX 

Issue: PX menu shows up in order of creation for Tools Men

Verification: Follow the steps below

1. Log into Java Client as admin. 

reate PX w

 C1  

 B1  

 A1  

Note    Make it available to init

3. Go to Data Settings > Classes. 

4. Open property for 'Change Orders' class and go to the Process Extensions tab. 

6. G  > Process Extension. Verify that PX should be in the below order: 

7. C  to the Process Extensions from the Action menu. Verify that PX should be in 
er: 

 C1 

5. Add in order of C1, B1, A1. 

o to Tools

 A1 

 B1  

 C1  

reate ECO and go
the below ord

 A1  

 B1  
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6886892.994

M tab was selected for the export. 

 steps below to verify the resolution: 

. Open the output file and ensure that P2 is not included in the output. 

8996692.6

settings > Classes > Manufacturer Parts > User 

s for the manufacturer parts 
that could not be imported due to exceeding the maximum length. 

buteModification SmartRule. 

r 

rning Violation 

 and Item.rev). 

Export 

Issue: Hard disk would be exhausted when exporting multiple large files. 

Root Cause: The extract code for the BOM item information was not correctly checking if the BOM 
tab was selected for inclusion in the export, which resulted in too much data getting exported. 

Resolution: Code was changed to properly check that the BO

Verification: Follow the

1. Create a Part, P1. 

2. On P1's BOM tab, add P2. 

3. Export P1, making sure to not select the BOM tab. 

4
 

 

298246/ 1

Import 

Issue: AML import terminates unexpectedly. 

Verification: Follow the steps below to verify the resolution: 

1. Log into Java Client and go to Admin > Data 
Interface Tabs > General Information. 

2. Modify mfrpart.number.maxlength as 5. 

3. Create an Excel file for importing AML's so that value for at least some mfr.partnumbers should 
be more than 5 characters and import the file. 

s not get terminated unexpectedly. It shows error message4. Import doe

 

 

298818/ 18997598.6

Issue: Import does not ignore WorkflowMatchingCriteriaAttri

Verification: Follow the steps below to verify the resolution: 

1. Log into Java Client and set SmartRule : WorkflowMatchingCriteriaAttributeModification = 
Warning. 

2. Create criteria as "change.ai.rev equal A" and assign to a new workflow "my eco workflow". 

3. Create Change C00001 and add Part P0001 as affected item and set the new workflow fo
C00001. 

4. Go to Tools -> Import and navigate to Preferences and set SmartRules Wa
Behavior = Reject. 

5. Import the Excel file (containing data related to Item.num
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6
 

. Displays the error for the SmartRule violation behavior. 

8998258.6

s for the BOM row without checking if it is enabled 

 loading it. 

e of BOM tab of parts class from Java Client. 

2. Im o

v, child_item, qty, find_no  

w change. 

4. M  

te (default name)  

ber  

.Item Number  

ind Num  

e file with new ECO (ECO3). 

er re-import; change the quantity of the previous imported file and with redlining on 

. Import is successful without fatal error. 

8999782.6

 

299249/ 1

Import 

Issue: Fatal error while performing and Import. 

Root Cause: Import server tried to load ref-de
during re-import with same change order. 

Resolution: The fix is checking if the ref-des is enabled when

Verification: Follow the steps below to verify the resolution: 

1. Set visible property to NO of Ref Des attribut

p rt the file with content as the following: 

 parent_item, parent_re

 'P01', 'B', 'P03', 2, 10  

3. Set the Change mode to Redlining and set to ne

ap the fields as below and save the map file.

Import File    Agile attribu

------------  -----------------  

parent_item -> Parts.Title Block.Num

parent_rev -> Parts.Title Block.Rev  

child_item -> Parts.BOM

qty -> Parts.BOM.Qty  

find_no -> Parts.BOM.F

 5. Do Import successfully. 

6. Re-import with the sam

7. Import is successful. 

8. Do anoth
ECO3. 

9
 

 

300130/ 1

Import 

Issue: Unable to Import Item Description into Agile 9.2.2.1. 
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Root Cause: Import server update item object cover page first, and then add the object into the 

ng the item to the affected item table. 
the new rev. 

em's description of change.  

3. Im line mode (standard template) as the following: 

4. Appropriate error message should be displayed to the user after importing an item in the redline 
mode with no privilege for the description of change affected item. 

9000280.6

s not package all of the manufacturer data when extracting the manufacturer tab 

f other fixes. 

eps below to verify the resolution: 

te. 

m filter - BOM options=Tab and Items, First level, AML Options=Tab and mfg 

release it. 

. All the data should be exported. 

/ 19000426.6

affected item of the change. The description will be added into the new rev for this case; it is why 
the update description will fail. 

Resolution: Switch the order for update cover page and addi
Then the rev is created when updating the description into 

Verification: Follow the steps below to verify the resolution: 

1. User has no modify privilege for Affected It

2. The item was not added into the change.  

port source with red

   item, description  

   item001, desc001  

 

 

300414/ 1

Export 

Issue: Export doe
from the Part record. 

Resolution: The issue was resolved by the implementation o

Verification: Follow the st

1. Log into Java Client. 

2. Enable one test field on mfg page two. 

3. Enable the same field on part's mfg tab attribu

4. Give Read and Modify privileges to the user. 

5. Setup ACS - ite
parts. 

6. Create a part. 

7. Create a transfer order and 

8. Verify the output pdx data. 

9
 

 

300506

SDK 

Issue: Adding a group to a User's User Groups table using SDK ITable.createRow() removes its 
existing Groups 
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Root Cause: Server deletes existing usergroups and adds new ones. SDK implementation was 
written to add user groups to existing list. 

Resolution: SDK implementation gets current user group list and then adds to the list. The updated 
er group list for a user object. Each time 

howing new user group. 

he resolution: 

G2]. 

. Add UG2 to User Group table of U. 

5. Verify that User group table size is 2. 

s when required fields are blank. 

olution: 

nments tab.  

 according to the order.  

ck the sorting order. 

s unchecked and the sorting order is retained. 

 

T 

 in 9.2.2 is adding an extra space. 

e resolution: 

geCAST for Change Order. 

. Verify the output axml file. 

5. The extra space is truncated in the output axml file 

list is used to add user groups. Add users one by one to us
the list should increase s

Verification: Follow the steps below to verify t

1. Create one User [U]. 

2. Create two user groups [UG1 and U

3. Add UG1 to User Group table of user [U]. 

4

 

 

300896/ 19001156.6

Import 

Issue: Import creates item

Verification: Follow the steps below to verify the res

1. Log into Java Client. 

2. Go to System Settings > My Assig

3. Click on the order tab to have the list

4. Un-check any one column name. 

5. Save it and che

6. Only one column get
 

300936/ 19001236.6

ChangeCAS

Issue: ChangeCAST

Verification: Follow the steps below to verify th

1. Create an ECO. 

2. Add space in the 'ECO number' as prefix. 

3. Create a profile in the Chan

3. Enable and transfer the profile in ChangeCAST. 

4
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301420/ 19002146.6

SDK 

Issue g list field using Customers list is very slow with SDK, causes the application se: Updatin rver to 

ich cause the performance issue. 

t non-enumerable. 

te List11 and List12 fields. 

. Verify that the fields of all three customers are updated within a few minutes [About 5 minutes]. 

e above steps using WSX. 

/ 19002340.6

nnot find the attribute because it has a trailing white space. 

: Changed the XML parser to preserve spaces when reading the Applied-to attribute 

he path to the WAS 
uthentication property files must not have any spaces anywhere in the path. 

 the double quote (") to make the command valid. 

sponse Expected attribute of an ACS destination was being saved with the 
destination types where it was not applicable (File and FTP). 

crash when using WSX. 

Root Cause: Originally customer list can be enumerated, wh

Resolution: Make customer lis

Verification: Follow the steps below to verify the resolution: 

1. Create 50000 customers. 

2. Make PageTwo List11 and List12 fields visible and set List=customer. 

3. Get 3 random customer numbers and upda

4

5. Now perform th
 

 

301607

301608/ 19002342.6

ACP 

Issue: ACP ca

Resolution
names. 

 

301675/ 19002460.6

ACP 

Issue: Java Parameters are not being set in WAS environment. 

Root Cause: Unable to quote the value due to a Unix limitation. This means that t
a

Resolution: Moved

 

302055/ 19003184.6

ACS 

Issue: The CTO cannot go to the Completed status for a file or FTP. 

Root Cause: The Re
destination, even for those 
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Resolution: The code has been modified to ignore this attribute for the destination types for which it 

elow to verify the resolution: 

2. C

est of the 
attributes for a File destination. 

work properly when a CTO is released using it. 

llaboration 
244530/ 18936692.6

y the resolution: 

o" button, fill in Item Number, and select all levels. 

nd the item and no IE error present. 

Mfr tab, it will not order correctly unless you click 
h button on the top pane. 

Verif  the steps below to verify the resolution: 

1. Log into Web Client and create 5 Sites as below and enable them: 

 

is not applicable. 

Verification: Follow the steps b

1. In Java Client, go to Admin, System Settings, ACS, Destinations. 

reate a new destination. 

3. In the create new destination dialog, set the Response Expected to Yes, then set the r

4. Save and the destination should now 
 

Product Co

300301/ 19000086.6

Web Client 

Issue: The GoTo option in the Bill of Material fails. 

Verification: Follow the steps below to verif

1. Log in Web Client as administrator/power user. 

2. Open an item that has multiple BOMs. 

3. Click "Go T

4. Click Find Next. It will fi
 

 

294866/ 18992188.6

STS 

Issue: When ordering on the Manufacturer/Redline 
the Refres

Root Cause: The sort by site is by site ID originally. 

Resolution: Use site name instead of site ID. 

ication: Follow

    1Suzhou

    Apple 

    Banana 

    Eggplant 

    San Jose 
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2. Create a Part and add above Sites to its Site tab. 

3. Add site-specific BOM for each site. 

4. Add site-specific Manufacturer Part for each site. 

reate an ECO against the Part. 5. C

6. S t's Site tab, BOM tab, Manufacturer tab, Redline BOM tab, 
ufacturers tab and ECO's AI tab. 

s below when Ascending: 

 

elow when Descending: 

 

nt 

    Apple 

er changing workflow. 

 by the implementation of other fixes. 

e resolution: 

2. Go to Data Settings > Process Extension. 

3. Create the following two PXs that Initiate from Actions menu: 

es'. 

s 'ECO'. 

ort table by Site Name column for Par
Redline Man

It shows a

    1Suzhou

    Apple 

    Banana 

    Eggplant 

    San Jose 

It shows as b

    San Jose

    Eggpla

    Banana 

    1Suzhou 
 

 

298115/ 18996472.6

Java Client 

Issue: Process Extension action menu is not showing up aft

Resolution: The issue was resolved

Verification: Follow the steps below to verify th

1. Log into Java Client as admin. 

- PX-A  

- PX-B  

4. Go to Data Settings > Classes. 

5. Open property of Base Class 'Chang

6. Go to Process Extension tab and set PX-A. 

7. Open property of Sub Clas

8. Go to Process Extension tab and set PX-B. 

9. Go to Workflow Settings. 

 Page - 23

  

 



Readme  
 
 
 

10. SaveAs 'Default Change Orders' workflow and name it as 'TEST'. 

ers'. 

 PX-B is enabled. 

4. Change workflow to 'TEST'. 

s Extension from Actions menu. The menu displays correctly. 

96716.6

s not trigger status demotion. 

ats user group as user in 

review status. 

dd UG1 as approver. 

. Log in as user2, open the change from Workflow Routings and reject it. 

emoted to Pending status automatically as expected. 

OM Tab. 

to the BOM Tab.  

 the BOM of 'PART-A' in Redline Window.  

ev --> you can see the Assembly part-1. 

11. Re-login to Java Client and create ECO X. 

12. Set workflow 'Default Change Ord

13. Select Process Extension from Actions menu. Make sure that both PX-A and

1

15. Select Proces
 

 

298261/ 189

301259/ 19001846.6

Changes 

Issue: Reject from user under Transfer Authority doe

Root Cause: When adding approvers in the process of changeStatus, it tre
BaseServiceRoute::appendAppObsIDs(). 

Resolution: Get all users in the user group and add them into approvers. 

Verification: Follow the steps below to verify the resolution: 

1. Create two users (user1, user2) with Approve/Reject Change privileges. 

2. Create two user groups (UG1, UG2), assign user1 into UG1, assign user2 into UG2. 

3. Create a Transfer Authority for all changes to start immediately: From user1 to user2. 

4. In the change workflow, set the 'If rejected set status to' to Pending for a 

5. Create a change, assign this workflow and move to the review status, a

6

7. The change is d
 

 

300787/ 19000946.6

Web Client 

Issue: Problem expanding BOM Assemblies (by clicking '+" sign) on B

Verification: Follow the steps below to verify the resolution: 

1. Create an Item 'part1' and add one or two Items 

2. Create an Item 'PART-A' and add an Item to the BOM Tab.  

3. Create a Change ECO1 and release 'PART-A'. 

4. Create another Change ECO2 --> Add PART-A to the AI Tab.  

5. Add the Assembly 'Part1' created in first step to

6. Now Open 'PART-A' --> Select Pending R
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7. Click on '+' sign of part-1 to expand the BOM. 

d and display correctly.  

ccess the Attachment tab in Web Client. 

. Select "Reference Designator Range Indicator List" and try to delete. 

w deleting this list. 

en changing status. 

discover privilege (just read). 

scReadSignoffPrivileges in 
thod. 

erify the resolution: 

1. L nt. 

very privilege for Change. 

8. BOM will expan
 

 

301181/ 19001694.6

Java Client 

Issue: User is unable to a

Verification: Follow the steps below to verify the resolution: 

1. Log into Java Client. 

2

3. Should not allo
 

 

301209/ 19001750.6

Changes 

Issue: Notification is sent to user without Discovery status wh

Root Cause: When routing change, system needs to remove 'noPrivileged' users from 'Notify' field, 
original design is not consider 

Resolution: Set 'true' for ReadDisccover when calling checkDi
removeNoPrivUser() me

Verification: Follow the steps below to v

og into Java Clie

2. Create user1 with below privilege: 

Read Change 

Note Make sure this user does not have Disco

3. Create an ECO. 

4. Click Send and set user1 to To field and Send. 

rivileges'. This is OK. 

. When changing status to CCB, set user1 to Notify field and Route.  

will prompt 'The following user does not have Discover/Read privileges'. 

bject from search result points to Attachment tab. 

5. You will get error 'The following user does not have Discover/Read p

6. Change status. 

7

8. Error message 
 

 

301258/ 19001844.6

Java Client 

Issue: Opening History tab of Change o
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Verification: Follow the steps below to verify the resolution: 

rch Results window, right click on the Change with Attachment, and Open > History 
Tab. 

an 10 seconds; it will open the Change's History tab instead of Attachment tab. 

 does not exist in the cache. It may have been deleted already.” 

t 
status.  

us of the workflow without release 

 

 Yes for Review status, 

. Route the ECR to Review status, Audit Status for this ECR. 

y "Node 0 does not exist in the cache. It may have been deleted already." 

03054.6 

nges 

omatically for the items added after row 

s the 

1. Log into Java Client as admin user. 

2. Search out changes by Simple Search. 

3. From Sea

4. Wait for less th
 

 

301979/ 19003036.6

Changes 

Issue: When performing an 'Audit Status' on an ECR from the SSR Subclass, this error message 
appears: “Node 0

Root Cause: Doing audit on the object with related object does not deal with the workflow withou
release 

Resolution: When auditing related object set the right to Stat
status. 

Verification: Follow the steps below to verify the resolution: 

1. Log into Java Client as admin user. 

2. Save workflow "Default Change Requests" as a new one "Test wlf for ECR".

e Audit as3. Delete all "Release" and "Complete" status, set Pass Releas
and then enable this workflow. 

4. Create an ECR and select "Test wlf for ECR" in Workflow field. 

5

6. It will not displa
 

 

301988/ 190

303813/ 19006554.6

Cha

Issue: Affected Items Number field width is not adjusted aut
20. 

Verification: Follow the steps below to verify the resolution: 

1. Log into Java Client. 

2. Create 20 items with 6 characters as the item number (i.e. P00001-P00020). 

3. Create an item with 30 characters (i.e. P1234678901234567890123456789). 

rs a4. Create an ECO and go to the Affected Items tab, and then add one part with 6 characte
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item number (i.e. P00001).  

5. Add item with the 30 characters item number (i.e. P1234678901234567890123456789). 

6. Notice that Affected Items tab Item Number field width is adjusted automatically.  

emove the item with the 30 characters item7. R  number from the Affected Items tab. 

. Add the rest of the items with 6 characters so that there will be a total of 20 affected items listed. 

e 30 characters item number from Affected Items tab again and the Item number 
field width will be adjusted automatically. 

. 

1. Create a Part and add one BOM. 

. Modify the BOM row and type <SCH> in the Ref Des field.  

ication. The value for the Ref Des displays correctly for both Java Client and Web 
Client. 

splays changes where redlines will be lost. 

: ChangeService::additionalAuditCheck() around L1525 warning message does not 
ong ExceptionID, the warning message 

 by the implementation of other fixes. 

 verify the resolution: 

4. G

5. Try to

rning messages in the same window as: 

'xxxx, releasing this change will cause another change to lose redlines' and 'Pending change(s) 
XXX contains conflicting redlines in AML that will become non-displayable if you 

se this change. Would you like to continue releasing this change anyway?' 

8

9. Add item with th

 

 

302504/ 19004046.6

Changes 

Issue: Special character causes the Ref Des field to not display

Verification: Follow the steps below to verify the resolution: 

2

3. Save the modif

 

 

303162/ 19005274.6

Changes 

Issue: Releasing a change no longer di

Root Cause
match the ExceptionID, the Java Client Warning reserve wr
will not display. 

Resolution: The issue was resolved

Verification: Follow the steps below to

1. Create a part with a manufacturer part. 

2. Release the part with an ECO. 

3. Create three MCOs on that part. 

o to the three MCOs and redline the part, for example, on the same cost field. 

 release one of the three MCOs. 

6. Get two wa

XXXX, X
relea
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304023/ 19006962.6

s/observers are having huge impact on 

 or an Escalation takes huge time and 

2. C n ECO and route to CCB status, and then add some of the above users as approvers 
and others as observers. 

ve ECO. 

about five seconds on Web Client to open that 

thorized User field 

ution: 

Go to Sourcing Project > General Info 

6. Create Sourcing Project with Authorized user as administrator. 

d search and search for Sourcing Project > Authorized users > Equal to > admin. 

 Search drop-down select sourcing project Authorized users field is present in 
rch. 

Changes 

Issue: Changes having more number of approver
performance. 

Root Cause: The check of current user is a transfer authority
multiple sql calls when approvers are many. 

Resolution: Changed the algorithm of the check. 

Verification: Follow the steps below to verify the resolution: 

1. Create 500 users and assign with Change Analyst role. 

reate a

3. Login as another user and try to open the abo

4. It will take about three seconds on Java Client and 
ECO. 

 

Product Cost Management 
299626/ 18998926.6

Sourcing Project 

Issue: Cannot set Privileges or Advanced searches based on Au

Verification: Follow the steps below to verify the resol

1. Log into Java Client. 

2. Click on Classes and 

3. Open Authorized supplier field. 

4. Set yes to Enable for Search Criteria field. 

5. Log into Web Client. 

7. Go to advance

8. From Advanced
permitted sea

 

 

300620/ 19000646.6

Sourcing Project 

Issue: Show/Hide AML is inconsistent 
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Root Cause: Missing RFQ Line attributes for buyer and planner which led to unnecessary filtering of 

Reso r/planner. These new attributes are used 

Verif lution: 

nd configure the display for 
Project-->Analysis and RFQ-->Response attributes.  

 with AML in a Sourcing Project.  Assign a value to Buyer field for the item.  Run 
r on Analysis to filter this value.  

rs based on Show AML/Hide AML configuration. 

 Analysis tab responses export with Best Response Filter. 

on: 

2. C

3. D

. Analysis tab | Filter for Parts with Best Responses  

lobal select and check the count of items 3. Responses | Export ... to Excel 4. Check the 
resulting file - AML is exported only when it is a best response. Best Response column has 

 file. 

plier Assembly Cost Report (ACR) error on deleted AML. 

ntry instead of the current live entry for 

Resolution:

Verification:

ct on a BOM that contains MPN components.  

onent and add the same MPN 

AML rows (Buyer/planner are not AML fields). 

lution: Introduced new attributes on RFQ line for buye
to construct buyer/planner filters for Analysis and Response tabs. 

ication: Follow the steps below to verify the reso

1. Enable Buyer attribute in Java Client via the AML-->Items table a

2. Create an Item
the Buyer filte

3. AML row appea
 

 

301656/ 19002424.6

Sourcing Project 

Issue rk on: Global selection does not wo

Verification: Follow the steps below to verify the resoluti

1. Create a sourcing project with items displayed on several pages. 

reate RFQ and send it to suppliers. 

o Set as best in Analysis tab. 

4

5. Do g

only 'Yes' value for all the Items in Excel
 

 

302332

Sourcing Project 

Issue: Sup

Root Cause: Supplier ACR computation uses deleted AML e
determining pricing.  

 Sql that pulls best AML and its' price for supplier ACR now excludes deleted AML 
entries.  

 Follow the steps below to verify the resolution: 

1. Create a sourcing proje

2. In Sourcing Project.AML table, delete the MPN in the leaf comp
back.  

3. Create an RFQ on the BOM and make sure to share the Cost BOM view.  
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4. Open RFQ to supplier. 

pplier and enter responses.  

andard Reports/Sourcing Reports folder, run Assembly Cost Report and the 

PCM Sourcing Project. 

CM classes (Sourcing Project, RFQ, RFQ Response and Price). 

page2 or page3.  

elect the attribute of matching data types for 

r created attributes are not displayed in the Map Data To attribute list. 

solution:

 the file productivity components to Standard and click on Save. 

. Add a Part or any other content. 

. From preview pane of part add file to its attachments table. 

. Then click on checkout. 

r with download file options (Open, Save and Cancel) 

 

5. Log in as the su

6. From Report/St
report runs without errors. 
 

 

302408/ 19003864.6

Sourcing Project 

Issue: Fails to pull commodity manager information into the 

Root Cause: User created flex attributes mapping. 

Resolution: Changed administrator to filter out the user created flex attributes in the attribute map 
data to list for P

Verification: Follow the steps below to verify the resolution: 

1. Create user created attributes in items/mfr part/price 

2. Navigate to sourcing project AML.Items/AML table, s
example text. 

3. Make sure the use
 

Product Portfolio Management 
18996524.6  

19004202.6

Verification Steps: Follow the steps below to verify the re
1. Log into Web Client. 

2. Go to Tools > My Settings > Preferences. 

3. Click on Edit and change

4. Create a program and navigate to Content tab. 

5

6

7

8. It should prompt the use
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295512/ 18993022.6

Java Client 

Issue: My Assignments configuration has problems with Sort function. 

2. Go to System Settings > My Assignments Tab.  

. Un-check any one column name. 

ck the sorting order. 

column gets unchecked and the sorting order is retained. 

he activity. As part of this 

ribed for this activity is already 
iption was deleted from DB and the 

rrectly. 

ities before deletion of content 

ify the resolution: 

ser's profile. 

ote Note that activity is displayed. 

Verification: ution:  Follow the steps below to verify the resol

1. Log into Java Client. 

3. Click on the order tab to have the list according to the order.  

4

5. Save it and che

6. Only one 
 

 

295592/ 18993128.6

Web Client 

Issue: Hard Delete distorts returned list view of Subscriptions. 

Root Cause: On soft deletion of the activity, all contents are deleted for t
content removal the rows in Subscriptions table corresponding to this activity is also deleted. Since 
subscriptions table stores User subscriptions' also, the user subscriptions' for this activity is also 
deleted. If the subscription table for the user who had subsc
accessed then this information is cached. Since the subscr

splayed cocache information is out of sync, the rows are not di

Resolution: Collect all the user(s) subscribed for the soft deleted activ
and invalidate Users.Subscription table for all these users. 

Verification: Follow the steps below to ver

1. Log into Web Client and create a program. 

2. Subscribe to it and check subscriptions tab on the u

N

3. Now soft delete and then hard delete the program and go back to check the subscriptions. 

ns tab does not display deleted activity. 

ing 

4. Subscriptio
 

 

296628/ 18994300.6

Notifications 

Issue: No privilege shows on the notification to a team member. 

Root Cause: To create a discover object for PPM, the ACL of the object looked up instead of load
team members from DB. This was done to improve performance. As part for this only those ACLs 
that have valid roles will be added to the Discover object. When any update operation performed on 
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PPM object, the discover object corresponding to that object is cleaned from cache and reloaded on
demand. In most the cases the existing code works, as the object is referenced immediately 
(because 

 

reloads/refreshes the page) after any modification operation is done. However, when 

 
M roles (mentioned 

in module and this call fails as context is 

ctivityApplicableRoleIds() has to be 
 of remote call. 

ogram with a subtask Task1 

to a Task1. 

. UserA receives notification. 

ect and body of the notification. 

 is displayed correctly without any 'No Privilege' message. 

ing to users. 

5. A rule set on it as ECO -> Submitted then A->InProcess 

 

7. Approver newUser will receive the notification. NewUser is getting notification without any No 

ote When the notification threw a No privilege error in notification, then the pc notifications 

there are some modifications that are run in the background when the discover object is not 
reloaded immediately instead is loaded and con Demand. If this reload happens from a background
tasks then the con is NULL and hence the implementation to check for valid PP
above to construct discover object) is a remote call to Adm
NULL. 

Resolution: The implementation of ActivityDiscoverBuilder.getA
changed to load the roles from metadata cache directly instead

Verification: Follow the steps below to verify the resolution: 

1. Program Manager creates pr

2. Program Manager adds a team Member,UserA 

4. Changes status of Task1 to in-process, and add UserA as Approver. 

3

4. Check the subj

5. Notification
 

 

298708/ 18997464.6

Notifications 

Issue: Product Collaboration notifications are not go

Verification: Follow the steps below to verify the resolution: 

1. Log into Web Client as admin. 

2. Create newUser with only My User Profile Role. 

3. For Default Activities workflow add newUser as approver to in-process Status.  

4. Create a Program A and add newUser with team member role. 

dd a Content ECO with a 

6. Go to ECO cover page and change the status to submitted, which will trigger the change status
on A and moves it to In Process.  

privilege error message. 

N
were not working. With this fix, user should not see a No Privilege error. 

8. Now create a p
 

art and sent it to a User. User gets notification. 

 

 

Page - 32 Agile Product Lifecycle Management 

 

 



 Chapter 1  
 
 

299374/ 18998474.6

correct. 

e steps below to verify the resolution: 

s > Preferences. 

l Chinese and then 

. Log out and log back in. 

nments. 

e This Week or any other view. Data is correctly displayed. 

y. 

s. 

phase, read and discover all programs privilege. 

 UserA should be able to create all phase, task and gate under it since he is the owner. 

299659/ 18998974.6

301380/ 19002076.6

Dashboard 

Issue: View Due this week in Agile 9.2.2.1 is in

Verification: Follow th

1. Log into Web Client. 

2. Go to Tools > My Setting

3. Click on Edit and change the language to Simplified Chinese and Traditiona
click on Save. 

4

5. Go to My Assig

6. Select View Du
 

 

299847/ 18999292.6

302285/ 19003626.6

Web Client 

Issue: Agile does not check the create privilege correctl

Verification: Follow the steps below to verify the resolution: 

1. Log into Java Client. 

2. Create a user (UserA) from User Settings -> user

m User Settings -> roles. 3. Create a role (role01) fro

4. Add create privilege on 

5. Log into Web Client as UserA 

6. Create a program and navigate to Schedule tab. 

7. Click on Create button. 

Note

8. Now search for a program that is not created by UserA and navigate to Schedule tab. 

nd check the drop-down list. Drop-down list should have only phase as 
UserA has Create privilege only on Phase. 

9. Click on Create button a
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300200/ 18999902.6

Web Client 

s and Matching Criteria 

3. G d Complete. 

s and Put ""All Activities"" criteria for complete.  

ct 

 bac s and assign above created criteria.  

8. Log into Web Client.  

. Create a program ""D Phase 123""; (Program object) with 'D Phase'(Task object) as child. Add 
object) as child to 'D Phase' and assign PPM_Workflow to D Phase and Task1. 

Issue: The General Info.Parent is not working for the criteria. 

Root Cause: VOCell.getValueString() is used while evaluating criteria and VOCellObject. 
getValueString() [Actual Implementation is VOCellID baseclass] return id as String. 

Verification: Follow the steps below to verify the resolution: 

1. Log into Java Client. Go to Workflow settings- workflows.  

2. Create a PPM workflow as PPM_Workflow with Object type as Program
as All Activities. And click ok.  

o to Status tab add new status of type- Pending, Review an

4. Select Pending Status and Put ""All Activities"" criteria for pending.  

5. Select Complete Statu

6. Create criteria from Data setting - Criteria with following details:  Name: GeneralinfoParent Obje
type: Task Attribute: General info.parent contain 'D Phase' 

7. Go k to workflow and select Review statu

9
Task1 (Task 

Note Task1 will move to review state. 
 

 

s of the 

eral Info tab based on the total number of server 
ing set correctly for PPM object i.e. 

rn default value (-1), the Edit button is disabled.  

r.java by 

1. L   

s- Privileges) by using above criteria with only P2, P3 as 

a user (user01) 

5. Also add Create, Discover, and Read for all programs privilege to the Demo Role.  

302389/ 19003826.6

Issue: Unable to use modify privilege when criteria is specifically restricted by the statu
Activity object. 

Root Cause: The edit button is enabled on the Gen
rows in P1, P2 & P3. Since for P2 & P3, this value is not be
VOTable.getTotalCacheRows() retu

Resolution: Set the TotalCacheRows correctly when building P2 or P3 table in ActivityHelpe
calling IBaseServerTable.setTotalCacheRows(). 

Verification: Follow the steps below to verify the resolution: 

og into Java Client.

2. Create criteria (Data settings - Criteria) with object type as task and criteria as General 
Info.Status=Default Activities.Not Started. 

3. Create Modify Privilege (User Setting
applied to fields.  

4. Add this privilege to a new role (User Settings -Roles) and assign this role to 
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6. Now log into Web Client as user01.  

7. Search for existing tasks.  

 task objects and navigate to the General Info page.  

e P2, P3 fields and then click Save. The Edit button is enabled. 

304032/ 19006980.6

. Japanese characters become 

erify the resolution: 

 chart for any program. 

e. 

. Update and save it as a .GCX file. 

nd check the names. 

5. Program name will be displayed correctly without any junk characters. 

nagement 

e to add a resource pool owner to a task. 

elegate Owner test". 

4. Search for the program created in step 2 (Delegate Owner test). 

6. Delegation operation will be successful both from Web Client and Gantt chart. 

.6

8. Open any of the

9. Click Edit and edit som
 

 

306169/ 19011156.6

6925831.993

Gantt 

Issue: There is unknown code when we open the GCX file format
illegible in Gantt chart when opening from saved file. 

Verification: Follow the steps below to v

1. Log into Web Client and launch Gantt

2. In Gantt, add child activities with name in Chinese or Japanese languag

3

4. Open that file a

 

 

305840/ 19010504.6

Resource Ma

Issue: Unabl

Root Cause:  

Resolution: 

Verification: Follow the steps below to verify the resolution: 

1. Log in as User 1. 

2. Create a program, such as "D

3. Log in as User 2 (Should have delegate privilege). 

5. Delegate the task to User 2. 

 

Product Quality Management 
303587/ 19006110
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Issue: CAR is requiring revision of affected item, but the revision is automatically filled in. 

d not deal with as a static list when 

Reso correct value. 

CR class. Set the Exit Required Fields of Pending as:  

 

. A 2 as AffectedItem to the QCR object; select the ItemRev as 'A01'. 

6. Try to route this QCR object from Pending to next status. 

7. You will not get an Error saying, 'Error: The following required fields are missing: xxxx/Affected 
Items.Item Rev'.  

 

Root Cause: CAPA.AI.Item_Rev is a special list, which shoul
getting its cell. 

lution: Reload the cell of the attribute and then able to get the 

Verification: Follow the steps below to verify the resolution: 

1. Create a workflow for Q

'Corrective and Preventive Actions.Affected Items.Item Rev;'

2. Create a Part, create a Change for this part, and release this Change. 

3. Set the REV as 'A01'. 

4. Create a QCR object, assign the workflow created in Step 1.  

dd the part of Step5
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Known Issues 

This chapter includes the following: 

 Known Issue Disclaimer ...................................................................................................................................... 37 
 Common Services ............................................................................................................................................... 37 
 Install and Upgrade.............................................................................................................................................. 38 
 Integration............................................................................................................................................................ 40 
 Product Cost Management .................................................................................................................................. 40 
 Product Portfolio Management ............................................................................................................................ 41 

This section contains a list of known issues for this release. These were deferred from this release, 
but may be fixed in a future release. Numbers in this section are for Oracle|Agile internal use only. 
 

Known Issue Disclaimer 
This list of Known Issues consists of those found at the time of the initial release. The product may 
have additional issues found after the initial release and therefore this list is subject to change and 
is not always comprehensive. Oracle support will continue to track known issues of this product 
release found on MetaLink. Please check for updates. 
 

Common Services 
7142367

Doc Management 

Issue: Not able to replace the file which has a "CHECKSUM ERROR" in Web Client. 

Workaround: Open the same object in Java Client to replace the file which has Checksum Error. 

 

7175002

Reports 

Issue: BI Publisher report is not supported on WebSphere. 

Workaround: No workaround solution is available. 
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7200782

Doc Management 

Issue: TA/Escalation will not work on FileFolder object. 

Workaround: No workaround solution is available. 
 

 

7218394

Doc Management 

Issue: Viewer will not pick the correct files when the file category is set differently in FileFolders. 

Workaround: No workaround solution is available. 

Install and Upgrade 
7236877

Service Pack Installer 

Issue: Error in DEFAULT_GROUP~HOME~DEFAULT_GROUP~1.log before the 9.2.2.5 PLM starts 
up. 

Root Cause: Error was introduced by the Russian language support to the schema in 9224L10N.  

Workaround: No workaround solution is available. 

 

7264298

Issue: AUT.sh cannot be started on AIX platform. 

Root Cause: Need to modify aut.sh to work on AIX platform. 

Workaround: Remove "-hotspot -ms64m -mx64m" entry in aut.sh and encryptpwd.sh. 

 

7277320

Issue: LDAPUTIL.JAR does not get updated in C:\AGILE9225\AGILEDOMAIN\LDAPLIB for 9.2.2.5 
release. 

Workaround: No workaround solution is available. 
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7264298

AUT 

Issue: AUT.sh cannot be started on AIX platform. 

Root Cause: Need to modify aut.sh to work on AIX platform. 

Workaround: Remove "-hotspot -ms64m -mx64m" entry in aut.sh and encryptpwd.sh. 
 

 

7277320

Issue: LDAPUTIL.JAR does not get updated in C:\AGILE9225\AGILEDOMAIN\LDAPLIB for 9.2.2.5 
release. 

Workaround: No workaround solution is available. 
 

 

7525966, 7605185 

Issue: The 9.2.2.5 International build cannot be updated with multi-byte character OS based on the 
9.2.2.4 International GA build. 

Steps to Reproduce: 

1. Install 9224L10N on a multi-byte character OS. 

2. Update to 9225L10N from 9224L10N. 

3. Restart the server. 

4. The server cannot be displayed with the following warning information: 

The DB schema data version: 9.2.624 

The server version: 9.2.614 

The versions are not matching. 

Workaround: The user needs to manually change the .cfg files. In the D:\Agile\Agile92\Install\config 
folder, backup all the existing .cfg files (Examples: agile_app.cfg, agile_api.cfg, agile_dfm.cfg, 
agile_ws.cfg etc.). Next, manually add the server configuration information in English for the 
different environments, such as WLS or OAS, before upgrading to the 9225NLS build when 
installing build on JP/CH/TW OS. Please modify the English code with the correct server 
configurations below and add the modified code into the head of the agile_app.cfg, agile_api.cfg, 
agile_dfm.cfg, agile_ws.cfg..etc files. 

OAS:  

Application Server Type=oas 

Application Server Host=@APP_SERVER_HOST_NAME@ 

Application Server Virtual Path=@APP_SERVER_VIRTUAL_PATH@ 

Clustered=@CLUSTER_INSTALLED@ 
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OAS Home=@OAS_HOME@ 

OAS HTTP Listen Port=@OAS_LISTEN_PORT@ 

Web Server Host=@WEB_SERVER_HOST_NAME@ 

Web Server Port=@WEB_SERVER_PORT_NUMBER@ 

 

WLS: 

Application Server Type=wls 

Application Server Host=@APP_SERVER_HOST_NAME@ 

Application Server Virtual 

Path=@APP_SERVER_VIRTUAL_PATH@ Application Server Virtual Patch 

Clustered=@CLUSTER_INSTALLED@ 

BEA Home=@BEA_HOME@ Where you installed BEA 

application server Listen Port=@BEA_LISTEN_PORT@ 

Web Server Host=@WEB_SERVER_HOST_NAME@ 

Web Server Port=@WEB_SERVER_PORT_NUMBER@ 
 

Integration 
7184509

SDK 

Issue: Period start date of project is returning the wrong date value. 

Root Cause: The problem happens because of converting date into time zone format and at some 
point of time when you create a project after the conversion the date stored in the PricePoint table is 
not the same as the current time. 

Workaround: No workaround solution is available. 
 

Product Cost Management 
7260441

Sourcing Project 

Issue: Prices are not getting carried into the reports, but they are visible in sourcing project analysis 
tab. The issue occurs only if we have a supplier (S1), which is a supplier for the source project and 
a partner for the other SP. 
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Workaround: No workaround solution is available. 

Product Portfolio Management 
7136843

Issue: After substituting a resource from the General Information page, the resource is not displayed 
in the Team tab. 

Workaround: Do a global refresh to see resource. 

 

7137170

Issue: Cloning is not supported for Design class objects. 

Workaround: No workaround solution is available. 

 
 

7261051

Issue: Irrelevant message is displayed when a user with only My User Profile is added as an 
approver and when the program status is changed from Not Started to In Process. 

Workaround: No workaround solution is available. 

 

7289829

Issue: A Parametric search with the attachment option selected along with the search criteria having 
a character is not working for programs. 

Workaround: Use simple search. 
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