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CHAPTER 1

Installation
This chapter discusses Agile installation and includes the following topics:
❑ Installation Requirements
❑ Pre-Installation Checklists
❑ Installation
❑ Post-Installation Checklists

Overview
Installing Agile Product Lifecycle Management for Process involves several steps, 
including:

❑ Understanding system requirements

❑ Performing pre-installation tasks (such as setting up the Web application 
server and database)

❑ Running the command prompt installation batch files

❑ Performing post-installation tasks, such as:

• Configuring the remote container service

• Performing some base application environment configurations

• Testing the installation

Installation Requirements
This section discusses Agile Product Lifecycle Management for Process 
installation requirements for the client, application server, and database server. 
Make sure your systems meet all installation requirements before attempting to 
install the Agile application suite. In order to properly run, Agile Product 
Lifecycle Management for Process requires a Web client, a Web application 
server, a remoting container (provided by Agile), and a database server. Figure 1-
1 on the next page shows the necessary architecture.
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Figure 1-1: Agile Product Lifecycle Management for Process Physical Architecture

Web Client Requirements
To properly run Agile Product Lifecycle Management for Process, Web clients 
must meet the following minimum requirements:

❑ Internet Explorer 6.0

❑ Adobe Reader 7.0 
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Web Application Server Requirements
To properly run Agile Product Lifecycle Management for Process, Web 
application servers must meet the following requirements:

❑ Microsoft Windows™ 2003 Server, SP1

❑ Microsoft IIS 6.0

❑ IIS Metabase Explorer 1.1

❑ Internet Explorer 6.0

❑ Microsoft .NET Framework 2.0

❑ Dual processor 2.0GHZ (Xeon recommended)

❑ 2.0 GB Memory

❑ 10K RPM Ultra3 SCSI with minimum RAID 1

Each application in the Agile application suite can be hosted on one or more Web 
application servers.

Note We recommend that you use separate application pools if the same Web 
application server is shared across Agile applications.

Database Server Requirements
To properly run Agile Product Lifecycle Management for Process, the database 
server must meet the following minimum requirements:

❑ Microsoft Windows 2003 Server, SP1

❑ Microsoft SQL Server 2005, SP2

❑ Dual processor 2.0 GHZ (Quad capable, Xeon recommended for expansion)

❑ 2.0 GB memory

❑ 10K RPM Ultra3 SCSI with minimum RAID 1 (separation of SQL database 
and log files recommended)

❑ Two disk arrays (for database and log file separation)

Note The database server can be managed in a clustered environment.
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Remoting Container Requirements
With the Agile application suite, you receive the Agile Remoting Container, a 
Windows OS-level service. This remoting container can exist on the same Web 
application server described above. The following are minimum requirements 
for the remoting container

❑ Microsoft Windows 2003 Server, SP1

❑ Microsoft .NET Framework 2.0

The Agile Remoting Container typically hosts the following Agile services:

❑ Authentication Bridge for Agile Single Sign-on (SSO)

❑ Authorization Bridge for Agile SSO pertinent to DRL file access

❑ Syndication Server (a component of Content Syndication and 
Synchronization)

❑ Reporting Queue service

❑ Taxonomy Denormalization service

❑ Import/Export service

❑ Object-level security denormalization service

Note The remote container can be scaled or isolated as needed.

Scaling Requirements
You will need to scale your system for performance and availability as your 
system begins to grow due to an increased use of the Agile application suite and 
a growing number of users and as your business demands change or increase. The 
following sections provide scalability recommendations.

Scaling for Performance
You will need to scale for performance as your number of users and applications 
begins to increase over time. In consideration of performance scaling, we 
recommend the following:

❑ No more than 250 registered users per processor.

❑ Organize scaling according to regional user patterns (according to users in 
similar time zones and geographical regions).

❑ Once physical Web application server limitations are met, use a load-balanced 
(logical or actual) solution.
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Scaling Beyond Five Core Applications
The following are recommendations for scaling beyond five (5) core Agile 
applications. Core Agile applications include:

• Global Specification Management (GSM)

• Supply Chain Relationship Management (SCRM)

• Design Workbench (DWB)

• New Product Development (NPD)

• eQuestionnaire (eQ)

• Agile applications portal

❑ Run no more than five (5) core Agile applications on a single Web application 
server.

❑ Organize scaling based on an evaluation of utilization patterns (known 
application characteristics).

Load Balancing
As mentioned above, once physical Web application server limitations are met, 
use a logical load-balanced solution based on application distribution across 
servers. For example, as shown in figure 1-2 below, a logical separation might be 
organized by application as follows:

GSMAppGroup—includes GSM and other complimentary applications

DWBAppGroup—includes DWB and other complimentary applications
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Figure 1-2: Agile Product Lifecycle Management for Process deployed in a logical separation

Scaling for Availability
You may also need to scale for availability as your business demands begin to 
change or increase over time. 

For application load-balancing, we recommend the following:

❑ A load balancer (such as f5 BigIP or Cisco CSS11000) that supports the 
following:

• Secure Sockets Layer (SSL) protocol

• Sticky sessions

❑ A maximum of five core Agile applications per load-balanced node.

Note A clustered node is an expansion of a logical application separation.
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For database, file, and service clustering, we recommend the following:

❑ A clustered server to support an active or passive database system

❑ A file cluster (where required)

❑ Service clustering

Figure 1-3: Sample deployment of a load-balanced and clustered system
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Pre-Installation Checklists
This section discusses Web application server-related tasks that an Agile 
implementer must complete before installing the Agile application suite.

Microsoft IIS 6.0 Checklist
Before installing the Agile application suite, complete all of the Microsoft IIS 6.0-
related tasks in the following sections:

❑ Add an IIS Server Role to Microsoft Windows 2003

❑ Configure the IP Address of the IIS Default Site

❑ Set all Web Sites to a 30 Minute Connection Time-Out

❑ Configure IIS Application Pool Settings

❑ IIS Metabase Explorer Settings

❑ Enable IIS Indexing Service

❑ Enable IIS WebDAV for NPD Applications

Add an IIS Server Role to Microsoft Windows 2003
You will need to create a Web server role using the ASP.NET Role Manager. The 
role type must be the IIS server role, ASP.NET only.

To add a role for IIS, follow these steps:
1 Click Start > All Programs > Administrative Tools, and then click Manage Your 

Server. 

2 On the Manage Your Server page, click Add or remove a role, and then click 
Next. 

3 Under Server Role, select the Application server (IIS, ASP.NET) server role, 
and then click Next. 

4 Check the Enable ASP.NET box, and then click Next. 

5 Verify that Enable ASP.NET is listed on the Summary of Selections page, and 
then click Next. 

6 If prompted, insert your Windows Server 2003 CD in the CD drive, and then 
click Next.

7 Click Finish.
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Configure the IP Address of the IIS Default Site
When you install IIS, it is preconfigured to serve as a default Web site; however, 
you may want to change some of the settings. 

To change the basic settings for the Web site:
1 Log on to the Web server computer as an administrator. 
2 Click Start > All Programs > Control Panel. 

3 Double-click Administrative Tools, and then double-click Internet Services 

Manager. 

4 Right-click the Web site that you want to configure in the left pane, and then 
click Properties. 

5 Click the Web site tab. 
6 Enter a description for the Web site in the Description box. 
7 Enter a value in the IP Address field for the Internet Protocol (IP) address to 

use for the Web site.
8 Modify the Transmission Control Protocol (TCP) Port as appropriate. 
9 Click the Home Directory tab. 

• To use a folder on the local computer, select a directory located on this 
computer, and then click Browse to locate the folder to use. 

• To use a folder that has been shared from another computer on the 
network, click a share located on another computer, and then either type 
the network path or click Browse to select the shared folder. 

10 Click Read to grant read access to the folder (required). 
11 Click OK to accept the Web site properties. 

Set all Web Sites to a 30 Minute Connection Time-Out

To set all Web sites to a 30 minute connection time-out:
1 Log on to the Web server computer as an administrator. 
2 Click Start > All Programs > Control Panel. 

3 Double-click Administrative Tools, and then double-click Internet Services 

Manager. 

4 Expand the {server_name} node, where {server_name} is the name of the server.
5 Expand the Web Sites node.
6 Right-click the Default Web Site and select Properties.
7 In the Default Web Site Properties dialog box, on the Home Directory tab, 

click Configuration. In the Application Configuration dialog box, on the 
Options tab, the Session Timeout box displays the Session.Timeout value. 

8 Set this value to 30 minutes.
9 Click Apply, then click OK.
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Configure IIS Application Pool Settings
You must configure various IIS Application Pool settings as follows:

1 Log on to the Web server computer as an administrator. 
2 Click Start > All Programs > Control Panel > Administrative Tools > Internet 

Information Services (IIS) Manager.
3 In the left pane, expand the local computer and locate Application Pools.
4 Right-click the DefaultAppPool option.
5 Make the following configuration changes:

• On the Recycling tab, deselect all five check boxes.

• On the Performance tab, check the Limit the kernel request queue box. Set 
the value to 4000.

• On the Health tab, check the Predefined box. Set the value to 
LocalSystem.

• Set the Application Pool Identity to Local System.

IIS Metabase Explorer Settings
IIS Metabase allows you to view, edit, copy, paste, move, drag, drop, and monitor 
activity in your IIS metabase. You will need to install the IIS Metabase Explorer 
1.1 and make the following Application Pool Key settings:

❑ Set DissallowOverlappingRotation to 1 (from 0)

❑ Set LogEventOnRecycle to 255 (from 137) 

Enable IIS Indexing Service
The Microsoft Indexing Service, a component of Microsoft IIS 6.0, allows for full 
text searching for attachments. The following is a checklist for setting this service 
up for use with the Agile application suite:

1 Ensure that Microsoft Indexing Server is installed. This is a separate 
Windows component that may or may not have been installed with the 
original operating system. 
• In Control Panel, click Add or Remove Programs.

• Select Add/Remove Windows Components. 

• Make sure the component Indexing Service is installed. 

2 Delete the two default catalogs that are created when the Microsoft Indexing 
Server is installed using the Computer Management tool under Control Panel 

> Administrative Tools. This is an optional step; however, it provides for 
increased security if these catalogs are not going to be used.

3 Create two folders to house the files generated by the Index catalog. For 
example:
c:\catalogs\GSMSpecs 

c:\catalogs\XDocs 

4 Stop the Indexing service.
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5 Add a GSMSpecs catalog to the Indexing Server again using the Computer 
Management tool. Use the following specifications:
Name: GSMSpecs 

Location: c:\catalogs\GSMSpecs 

6 Add an XDocs catalog to the Indexing Server using the following 
specifications: 
Name: XDocs

Location: c:\catalogs\XDocs 

7 Add the directory that the GSMSpec files are stored in to the GSMSpecs 
catalog. Note that the Alias field is optional and can be left blank. Ensure that 
the Include in Index option is selected. 

8 Add the directory that the XDoc files are stored in to the XDocs catalog. 
9 Restart the Indexing service.

Enable IIS WebDAV for NPD Applications
If you are installing the Agile NPD (New Product Development) application, you 
must enable the WebDAV (Distributed Authoring and Versioning) protocol in 
Microsoft IIS 6.0 to support in-place editing.

Set up the WebDAV environmentsettings.config file as follows (using the 
following examples):

PDFWorkArea = https://<hostname>/webdav/npdworkarea/ 

PDFCommentRepository = https://<hostname>.com/webdav/
pdfcomments/

OfficeDocWorkArea = https://<hostname>.com/webdav/npdworkarea/

PDFWorkArea = https://prodikaapp.customerdomain.com/webdav/
npdworkarea/

OfficeDocWorkAreaUNC = \\<hostname>\webdav\NPDWorkArea\ 

PDFCommentRepositoryUNC = \\<hostname>\webdav\pdfcomments\ 

Note Be sure to create accounts with appropriate permissions to allow the Web 
application server access to the above WebDAV UNC paths.

Set up the Microsoft IIS 6.0 configuration for WebDAV as follows:
1 Create a virtual directory named WebDAV with default IIS 6.0 settings.
2 Create two directories under the WebDAV vdir: 

• PDFComments (with browsing enabled)

• NPDWorkarea (with no browsing)

Note It may be necessary to give the account used by IIS (iuser_machinename) 
admin rights or full access to the WebDAV virtual directory.
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Microsoft SQL Server 2005 Checklist

When installing MS SQL Server 2005 Standard Edition, be sure to:

❑ Install MS SQL Server 2005 Standard Edition with the mixed mode 
authentication and default options. 
(Ensure that character set and sort order are MS SQL defaults.)

1 Run the MS SQL Server setup.

2 Select Install Database Server and click Next.

3 Select Install Default Instance on Local Computer and click Next.

4 Select Default Instance and click Next.

5 For Setup Type, select Typical and click Next.

6 Select Use Same Account for Each Service and Use the Local System 

Account and click Next.

7 Select Mixed Mode. Enter a System Admin password and confirm. 

8 Click Next twice to complete the installation.

❑ Configure the MS SQL Server 2005 settings as follows:

1 In the SQL Server Enterprise Manager, right-click the server in the tree 
view, left pane. 

2 Select Properties and click the Memory tab. 

3 Select Use a Fixed Memory Size.

4 On the Processor tab, under Processor Control, select all available 
processors. 

5 Click Boost SQL Server Priority, assuming the box is only running SQL 
Server.

6 Under Parallelism, select Use All Available Processors.

7 Under Database Settings > New Database Default Location, set the 
appropriate paths for the data and log files:

• Data files:
array2\Program Files\Microsoft SQL Server\MSSQL\Data 
(optimized for balance of reads and writes - 75/25) 

• Log files:
array1\Program Files\Microsoft SQL Server\MSSQL\Data 
(optimized for sequential writes) 

8 On the General tab, select Autostart SQL Server and Autostart SQL Server 

Agent.
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❑ Set up two SQL accounts, which are recommended to run and manage the 
application:

• ProdikaDBAdmin—This account should have database owner access to 
the application database. Use this account to run the application 
installation and upgrade scripts.

• ProdikaAppUser—This account will be used by the Web server 
applications for access to the back-end data and should have read/write 
access to all of the application database tables and views. Additionally, 
this account should have access to execute all user-defined functions.

❑ Apply all available security patches for MS SQL Server 2005.

❑ Schedule a maintenance plan. Production backups should occur nightly. 
Test backups should occur twice weekly.

1 In the Enterprise Manager, drill down in the left pane to Management > 

Database Maintenance Plan.

2 In right pane, right-click and select New Maintenance Plan.

3 Select the database to maintain.

4 Click through the Wizard to configure the database maintenance plan.

SSL Checklist
SSL (Secure Sockets Layer) is a protocol from Netscape Communications 
Corporation that is designed to provide secure communications on the Internet. 
SSL is not required for an Agile installation but will be used in most instances, as 
determined by the customer.

SSL can be deployed in many ways. Most commonly, SSL will run within IIS or 
on an intermediary system such as a Reverse Proxy or SSL accelerator.

The Agile application suite can operate in any of these scenarios, but the HTTP 
scheme must be configured (via deployment.xml) to generate the desired 
relative URLs correctly (http vs. https).

East Asian Language Support
If you plan to support foreign languages in Agile Product Lifecycle Management 
for Process, you must install East Asian language support on the server.

To install East Asian language support on the server:
1 Access the Windows Control Panel dialog box by clicking Start > Control 

Panel.

2 Select Date, Time, Language, and Regional Options > Regional and Language 

Options and click the Languages tab.
3 Check the Install Files for East Asian Languages box.
4 Click Apply and OK.
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Restore the Database and Setup Database Accounts
You should receive a copy of a prepared database as part of your Agile software 
media from Agile Software. Using Microsoft SQL Server Management Studio, 
you will need to restore this database onto your local database server. You will 
also need to make sure that the user responsible for accessing the database has the 
appropriate account setup and assigned roles.

Restoring the Database
To restore the database onto your local database server:

1 Open MS SQL Server Management Studio.
2 In the left pane, right-click on Databases and select Restore Database.

The Restore Database dialog displays.

3 In the General page, type a database in the To Database field.

Note We recommend that your database name include the environment 
name and software version, for example: production_v50.

4 Select From device. 
5 Click the browse button for the From device text box, which opens the 

Specify Backup dialog box.
6 Click the Add button to display the Locate Backup File dialog box. Browse to 

the software media containing the database from Agile Software. 
7 Click OK twice to return to the Server Management Studio.
8 In the Options page, select Restore Database.

9 Verify that the data file and log file paths are set to the correct paths.
10 Click OK to begin the restoration.
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Set Up User Permissions 
To set up database user permissions:

1 Open MS SQL Server Management Studio.
2 In the left pane, drill down into the Databases folder to locate the database 

that you just restored.
3 For this database, select Security > Users.
4 Right-click on Users and select New User to display the Database User - New 

dialog box.
5 Type a user name in the User Name field.
6 Select Login Name. To the right of this radio button, click the browse button 

to display the Select Login dialog box.
7 In the Select Login dialog, click Browse to display a list of login objects. Select 

a login object and click OK twice to return to the Database User - New dialog 
box.

8 In the Database Role Membership section, assign the following two roles to 
the user:

• db_datareader

• db_datawriter

9 Click OK.

Remote Container Service and Application Pool Accounts
The remote container service and application pool are standard Microsoft 
Windows services, which require user accounts in order to run. During the Agile 
installation, you will be asked to enter your remote container service credentials, 
as well as credentials for the application pool.

Before installing Agile Product Lifecycle Management for Process, make sure that 
your IT department has created an account for each service for you. Such 
accounts can be system accounts, local Windows accounts, or domain accounts 
(active directory). The process for creating a remote container service account 
and application pool account is a standard approach for creating Windows 
accounts.
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Installation
The Agile PLM suite is installed with a batch file process. The batch files are 
designed to be run from the Windows command line. Through a simple process, 
the batch file installation will:

❑ Set up the initial IIS Web site

❑ Set up the initial IIS application pools

❑ Set up the folder structure within the Web site for various Agile applications

After the batch program has completed, simply decompress the Agile Server 
package into the target %PRODIKA_HOME% location to be accessible by IIS.

Installation Process
1 Run the command: “SetupIIS.bat <SiteName> <HostHeader> <RootPath> 

<UserName> <Password> <SiteID>”.

Figure 1-4: Run the command

Note For usage information, just type SetupIIS.bat from the directory 
in which you unzip the script.
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Figure 1-5: Batch run example

2 Following the batch run, create the metabase items that are needed in IIS:
• Prodika_Global

• Prodika_GSM

• Prodika_NPD

• Prodika_Portal

Note The batch file will install four different application pools. Though this is 
the default application pool layout, in some cases, it might not be necessary 
if each application is hosted on a different machine since each machine will 
need only one application pool. In some cases, more application pools 
might be needed based on usage.
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Figure 1-6: Application pools

3 Uncompress v5_2_0_Setup_Installer.zip and double-click Setup.bat. 
The installer extracts the files and displays the initial installer screen, shown 
in figure 1-7, below.

Important You must use this installer tool as of version 5.2.0 in order to 
successfully install Agile PLM, because as of this release, installation 
history is maintained in a file called install.his, which is required 
for future upgrades. If you use the previous process, this file will not 
be created, thus preventing future upgrades.
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Figure 1-7: Installer initial screen

4 Click the green arrow icon ( ) at the upper left of the window. The 
installer begins the installation process and prompts you for the root folder 
for the new installation, as shown in figure 1-8 below. The installer 
completes the installation.

Figure 1-8: Installer: Specify root folder

5 Run the command: IISCreateProdikaApps.bat <AppPoolID> <WebRoot> 
<SiteID>

Note For usage information, you can run IISCreateProdikaApps.bat with 
no parameters, resulting in output similar to that shown in the figure 
below.
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6 For simplicity, use the Prodika_Global Application Pool’s ID as your 
<AppPoolID> and after the installation is complete, move Web sites of your 
choice to separate application pools (Prodika_GSM, Prodika_NPD, 
Prodika_Portal and any other application based on customer usage.

7 For the <SiteId> use the output from step 1. For example, it shows 879425 as 
the SiteId for this run. This is a system-generated number and in your case, 
the number would be different based on your run.

8 Move the application pools and set Caching Rules as described in step 9. By 
default the Prodika_Global application pool is added to all sites. The sites 
need to be distributed to their appropriate application pools. Though this 
depends totally on the customer-specific setup and resource availability, the 
rule of thumb is to move GSM, NPD, and Portal to their own application 
pools at a minimum.

9 Two virtual folders—componentart_webui_client and ProdikaHelp  
—are set up in IIS. These virtual folders contain static content and can be 
cached to improve performance. The cache settings can be set on the 
Properties context menu of the virtual folder by setting the Content 
Expiration to 100 days as shown in figure 1-9 below.

Figure 1-9: Content expiration settings
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10 Similarly, set the content expiration to 100 days on the ProdikaHelp folder 
and on all the images and CSS subfolders for all the Web applications. This 
is very essential to guarantee optimal performance of the application.

11 Conditionally create the WebDAV folder - Some parts of the Agile suite use 
WebDAV to allow in-place editing of certain document types. To allow for 
this, a setting is available in the EnvironmentSettings.config file for the 
WebDAV virtual folder. In cases for which WebDAV is required, create a 
WebDAV virtual folder and allow the anonymous user to access (read and 
write) the physical folder location on the hard drive.

12 Review the Agile Product Lifecycle Management for Process Configuration 
Guide to apply the configuration changes required for the installation.

Post-Installation Checklists
This section discusses tasks that an Agile implementer must complete after 
installing the Agile application suite.

Set the IIS Event Viewer Logging

Important This step is critical to successfully running the Agile application suite. 
You must set the Event Viewer logging to Overwrite events as needed 
for System, Security, Application, and all Agile-created event logs. 

If an event log is set to Overwrite events older than 7 days, then you may run into 
an issue when a new feature is introduced that uses multiple Warnings, Errors, or 
Information. The introduction of new event logging can fill up the event log so 
that no more events can be logged, throwing an exception back to the user of the 
application. The exception will not go away until the log is set to Overwrite events 

as needed or until the log is cleared manually. For this reason, we suggest setting 
all event logs to Overwrite events as needed.

Important You will need to start up every Agile application, which will generate 
a new event viewer log. Review each event viewer setting to make sure 
the Overwrite events as needed option is selected.

To set the IIS Event Viewer Logging in IIS 6.0:
1 On your desktop, right-click the My Computer icon.
2 Click Manage from the fly-out menu to display the Computer Management 

dialog box.
3 In the left pane, click System Tools > Event Viewer to display all of the 

available event viewers.
4 Right-click on each event viewer and select Properties to display the 

Application Properties dialog box.
5 Select the Overwrite events as needed option.
6 Click Apply, and then click OK.
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Update the Version Number in the version.txt File

Modify the version.txt file as follows:
1 In your Prodika_Home directory, locate the version.txt file. 
2 Open the file with a text editor.
3 Edit the first line so that it contains only the following text:

Version: v5.1

4 Click File > Save to save the your change.

Verify that the Remote Container is Listening on All Ports
Verify that the remote container service is listening on the correct ports as 
follows:

1 Once again, open the remote container service configuration file at:
Prodika_Home\RemotingContainer\RemotingContainer.exe

2 Locate RemoteServices. Take note of the various port settings.
3 Open the environment settings configuration file at:

Prodika_Home\Config\EnvironmentSettings.exe

4 Locate Services (under Prodika). 
5 Verify that the Remote URLs for the various services contain the correct port 

settings.
6 Open the remote container log file to verify that the remote container is 

listening on all ports. This file is at:
Prodika_Home\Logs\remoteContainer.stdout.log

7 Scroll to the bottom of the log file to view the log results. This should tell you 
if your remote container is listening on all ports, and if not, the log file 
should indicate a reason.
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Microsoft .NET Framework
After installing Microsoft .NET Framework, you need make some configuration 
changes to the machine.config file for performance optimization purposes.

Make the following updates to the machine.config file as follows:
1 Locate and open the machine.config file at:

C:\Windows\Microsoft.NET\Framework\v2.0.50727\Config\mach
ine.config

2 Locate the system.web tag and add the following under it:
<pages validateRequest="false" enableEventValidation="false"/>

<processModel enable="true" timeout="Infinite"

idleTimeout="Infinite"

shutdownTimeout="00:00:05" requestLimit="Infinite"

requestQueueLimit="5000" restartQueueLimit="10"

memoryLimit="60" webGarden="False" cpuMask="0xffffffff"

userName="SYSTEM" password="AutoGenerate" logLevel="Errors"

clientConnectedCheck="00:00:05"

comAuthenticationLevel="Connect" 
comImpersonationLevel="Impersonate"

responseDeadlockInterval="00:03:00"

responseRestartDeadlockInterval="00:03:00" autoConfig="True"

maxWorkerThreads="20" maxIoThreads="20" minWorkerThreads="1"

minIoThreads="1" serverErrorMessageFile="" 
pingFrequency="Infinite"

pingTimeout="Infinite" maxAppDomains="2000" />

<machineKey 
validationKey="B3B1257C1B375B1190AF16044C40A42739DEDDBA26C2F9DA3
5B20FC20C3F63B11B22C6B92D602EB8886E3D18F9548B84A0B80EBADC575C407
ED33F39ACE08389" 
decryptionKey="6D53B0178EF6AA0604C1D559B0962228B7449DAFD920113B" 
validation="SHA1"/>

Note Sometimes, these tags might exist prior to this step. If these tags are 
already present, please update them to look as above.

3 Locate forms Attributes. (The xpath to the node is: /configuration/
system.web/authentication.) [@mode='Windows']/forms 
Change protection to None.

4 Run the following command from a command prompt:
\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis
.exe -i

5 Open Internet Information Server Administrator and right-click on the 
Web virtual folder and choose Properties. 

6 Click on the ASP.NET tab to confirm that .NET 2.0 is selected.
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Installation Verification Tests
In order to perform the recommended Agile installation verification tests, you 
will need the user name and password for an Agile user account having access to 
all Agile applications. User access is managed using the User Group Management 
(UGM) application. For more information on user management, see the Agile 
Product Lifecycle Management for Process Administrator User Guide.

Access the Agile application using Internet Explorer. Use the following URL, 
substituting the appropriate server name and http/https values (depending on 
whether or not SSL is enabled):

https://servername/portal/WebCommon/Login.aspx

Type your use name and password, and press the Enter key.

Note The following installation verification tests assume that you have installed 
the entire Agile application suite. If this is not the case, omit tests for 
applications that you have not installed.

Caution! You must be assigned the correct Agile roles to perform these 
installation verification tests. For more information on roles, see the 
Agile Product Lifecycle Management for Process Administrator User 
Guide.

Global Specification Management Test
Before performing this test, note that specifications, once created, cannot be 
deleted from GSM. Therefore, creating specifications for verification purposes 
contributes to the proliferation of meaningless specifications. If specifications 
already exist in the system, you may wish to skip this test.

The purpose of this test is to verify that GSM is properly functioning. 

To perform the GSM test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select GSM > Ingredient Specifications.
3 Click Create New in the upper right corner. A new ingredient specification 

template is displayed.
4 Type a specification name in the Spec Name field.
5 Complete the Approved for Use In section at the bottom of the page.
6 Click Save & Close Document in the upper right corner.
7 From the left navigation panel, select GSM > Ingredient Specifications.
8 Conduct a blind search by clicking Reset and then Search or specify search 

criteria to retrieve the specification that you just created.
9 In the Search Results table, click the Spec # link. The selected specification is 

displayed.
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10 Click Workflow in the upper right corner.
11 Type any value in the Comments field.
12 Click the move step forward ( ) icon. If additional dialog boxes 

appear, it confirms that GSM is functioning.

Printing Test
The purpose of this test is to verify that the Agile Printing Service is correctly 
functioning. 

To perform the Printing test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select GSM > Ingredient Specifications.
3 Search for the specification that you created in Global Specification 

Management Test on page 1-24.
4 Click Print in the upper right corner.
5 In the resulting Print dialog box under Current Specification > Sections, 

select any check box.
6 Click Print again. The specification is rendered in PDF format in a separate 

window.
7 Close the window once the PDF successfully is displayed and proceed to the 

next test. If the PDF does not appear, double-click the file 
Prodika\Scripts\Installation\ApocEntry.reg and retry this test.

Reporting Test
The purpose of this test is to verify that the Prodika Reporting Service is correctly 
functioning. 

To perform the Reporting test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, click RPT (Reporting).
3 Search for the specification that you created in Global Specification 

Management Test on page 1-24.
4 Click Generate Report.
5 In the resulting dialog, type a report name in the Report Name field and then 

click Save.
6 In the left navigation panel, select Ad Hoc Reports > Reports Queue.
7 The resulting Reports Queue should contain an entry for your report. 

Refresh this view periodically by toggling from Reports Queue to Reporting 
and back, to see the status of your report update. If the report status fails to 
update, there is likely a problem with the Reporting Service.

8 When the report status indicates Complete, click the hyperlinked name of 
the report to download the report.
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GSM Print Administration Test
The purpose of this test is to verify that the GSM Print Administration service is 
correctly functioning. 

To perform the GSM Print Administration test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select GSM > Print Administration.
3 Click Create New in the upper right corner.
4 If the Process Spec Print Model is displayed, click Cancel and proceed to the 

next test.

Supply Chain Relationship Management Test
The purpose of this test is to verify that the Agile SCRM application is correctly 
functioning. 

To perform the SCRM test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select SCRM > Company Profiles.
3 Conduct a blind search and select any company profile from the Search 

Results table to verify that it is displayed correctly.
4 If the company profile is displayed, click Cancel and proceed to the next test.

Nutrition Surveillance Management Test
The purpose of this test is to verify that the Agile NSM application is correctly 
functioning. 

To perform the NSM test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select NSM > Nutrient Analysis.
3 Click Create New in the upper right corner.
4 If the Nutrient Analysis template is displayed, click Cancel and proceed to 

the next test.

eQuestionnaire Test
The purpose of this test is to verify the Agile eQ application is correctly 
functioning. 

To perform the eQ test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select eQ > Ingredient Questionnaires.
3 Click Create New eQuestionnaire in the upper right corner.
4 In the Select Questionnaire Type dialog box, select the ingredient type and 

click Create New.
5 If the eQuestionnaire template is displayed, click Cancel and proceed to the 

next test.
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New Product Development Test
The purpose of this test is to verify that the Agile NPD application is correctly 
functioning. 

To perform the NPD test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select NPD > New Product Development > 

Projects.
3 Conduct a blind search and select any project from the Search Results table 

to verify that it is displayed correctly. If so, NPD has passed the test.
4 If no projects are found, click Create New in the upper right corner.
5 Select a business unit and project type in the resulting dialog box and then 

click Done.
6 If the NPD (Stage 1) template is displayed, click Cancel and proceed to the 

next test.

Product Quality Scorecard Test
The purpose of this test is to verify that the Agile PQS application is correctly 
functioning. 

To perform the PQS test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select PQS > Lot Samples.
3 Click Create Sample in the upper right corner. The Enter Code Data/Sample 

ID page loads.
4 In the Code Data or Sample ID field, type any text. 
5 Click Next. The Select Specification page loads.
6 In the Specification section, click the Specification link. A Specification 

Search dialog box appears.
7 In the resulting Search dialog box, type criteria to find and select the 

ingredient specification that you created in Global Specification Management 
Test on page 1-24.

8 If the ingredient specification is displayed, the test has succeeded. 
9 Click Close in the upper right corner, and proceed to the next test.
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Design Workbench Test
The purpose of this test is to verify that the Agile DWB application is correctly 
functioning. 

To perform the DWB test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select DWB > Workbench Specifications.
3 Conduct a blind search and select any workbench specification from the 

Search Results table to verify that it is displayed correctly. If it displays 
correctly, DWB has passed the test.

4 If no workbench specifications are found, click Create New Workbench Spec 
in the upper right corner.

5 Type a name for the workbench specification in the DWB Spec Name field.
6 In the Approved for Business Use In section, assign the appropriate business 

unit to this specification.
7 Click Save & Close.

Food Item Catalog Test
The purpose of this test is to verify that the Agile FIC service is correctly 
functioning. 

To perform the FIC test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select DWB > Food Item Catalog Term.
3 Conduct a blind search and select any catalog from the Search Results table.
4 If the catalog is displayed successfully, click Cancel and proceed to the next 

test.

Computer Aided Compliance Screening Test
The purpose of this test is to verify that the Agile CACS application is correctly 
functioning. 

To perform the CACS test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select CACS.
3 Conduct a blind search and select any computer aided compliance screen 

from the Search Results table to verify that it is displayed correctly.
4 If no computer aided compliance screens are found, click Create New in the 

upper right corner.
5 Type a name for the screen in the Title field and a description in the 

Description field.
6 Click Save & Close.
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Supplier Portal Test
The purpose of this test is to verify that the Agile Supplier Portal (SPA) 
application is correctly functioning. 

To perform the SPA test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select SPA > Approved Registrations.

If there are any approved registrations in the system, they will be displayed.

User Group Administration Test
The purpose of this test is to verify that the Agile UGM application is correctly 
functioning. 

To perform the UGM test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select UGM > Groups.
3 Conduct a blind search and select any group from the Search Results table 

to verify that it is displayed correctly.

Workflow Administration Test
The purpose of this test is to make sure that the Agile WFA application is 
correctly functioning. 

To perform the WFA test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, click WFA (Workflow Administration).
3 Click New Process Template in the upper right corner.
4 In the resulting dialog box, select GSM and then click Done.
5 If the process template is displayed successfully, click Cancel and proceed to 

the next test.
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Manage Core Data Test
The purpose of this test is to verify that the Agile ADMN (Manage Core Data) 
application is correctly functioning. 

To perform the ADMN test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, select ADMN > GSM > Additives.
3 If the additives currently in the system are displayed successfully, click 

Cancel and proceed to the next test.

Manage Data Caches Test
The purpose of this test is to verify that the Agile CACHE application is correctly 
functioning. 

To perform the CACHE test:
1 Log in to Agile Product Lifecycle Management for Process.
2 From the left navigation panel, click CACHE (Manage Data Caches).
3 If the Schedule Cache Flush tool is displayed successfully, the test has 

succeeded.
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CHAPTER 2

Upgrading
This chapter discusses Agile Product Lifecycle Management for Process upgrading.
Topics in this chapter include:
❑ Upgrade Tasks
❑ Web Application Tasks
❑ Stopping Services and Backing Up Files
❑ Installation Software and Scripts
❑ Reconfiguring Settings
❑ Customizing the User Interface
❑ Reconfiguring and Restarting Remote Container Service and Web Application Server
❑ Verifying the Installation

Upgrade Tasks
This chapter discusses the basic steps required to upgrade the Agile application 
suite to the 5.2 version. The main steps in the upgrade process include:

1 Check for Active Web Application Server Sessions on page 2-2
2 Stop the Web Application Server on page 2-3
3 Stop the Remote Container Service on page 2-3
4 Back Up the Previous Database Deployment on page 2-3
5 Installation Software and Scripts on page 2-4
6 Installing the Agile 5.2 Upgrade Software on page 2-4
7 Update the Version Number in the version.txt File on page 2-9
8 Apply Database Upgrade Scripts on page 2-10
9 Reconfigure the Application Environment Settings on page 2-11

10 Reconfigure the Customer Settings on page 2-12
11 Customizing the User Interface on page 2-12
12 Apply extensions, if any
13 Reconfigure the Remote Container Service on page 2-35
14 Restart the Remote Container Service on page 2-35
15 Restart the Web Application Server on page 2-35
16 Verifying the Installation on page 2-35
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Web Application Tasks

Check for Active Web Application Server Sessions
Before bringing down the Web application server, perform two checks to make 
sure there are no active user sessions on the server. 

Note We recommend that you notify all users in advance that you are 
performing the upgrade, to give them time to shut down their connections.

Check the Performance System Monitor for Active Sessions
Using Performance System Monitor, check to see how many people currently 
have active sessions.

1 Select Start > Run.
2 In the Run dialog box, type perfmon and click OK to bring up the 

Performance dialog box.
3 Select the System Monitor option in the left pane to bring up the System 

Monitor dialog box.
4 In the bottom portion of the System Monitor dialog box, a list of counters is 

displayed. Right-click in this area and select Add Counters from the shortcut 
menu to display the Add Counters dialog box.

5 Select the Select Counters from Computer option and select your Web 
application server.

6 From the Performance Object drop-down list, select ASP.NET Apps 

v2.0.50727.
7 Select the Select Counters From List option and from the associated scrolling 

list, choose Sessions Active, and then click Add.

8 Click Close to close the Add Counters dialog box.
9 Using the new active sessions counter, you can view the active sessions for 

the Web application server by selecting its row in the counter list at the 
bottom of the System Monitor dialog box. In particular, look at the number 
of active sessions in the Last field. If this number is greater than 2 active 
sessions, it is likely that users are logged on to the server. Contact the user(s) 
to have them log off before you shut down the Web application server.

10 You can save the active sessions counter by right-clicking it and selecting 
Save As from the shortcut menu. You may wish to save this counter to your 
desktop for future use.
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Check the Event Viewer for Last Login
Using IIS Computer Management, check the Event Viewer log for Agile to see 
when the last user login occurred.

1 Right-click My Computer and select Manage from the shortcut menu to 
display the Computer Management dialog box.

2 Under System Tools, select Event Viewer.
3 Locate and double-click the Portal-Prodika log under Event Viewer.
4 Review the log to see when the last user login occurred. If a recent login has 

occurred, it is likely that a user is still logged on to the server. Contact the 
user to have them log off before you shut down the Web application server.

Stop the Web Application Server
After you have verified that there are no active sessions on the Web application 
server, bring the server down as follows:

1 Open a command prompt.
2 Enter the following command to stop the Web application server:

C:\Documents and Settings\Administrator>iisreset /stop

Stopping Services and Backing Up Files

Stop the Remote Container Service
Using IIS Computer Management, stop the remote container service as follows:

1 Right-click My Computer and select Manage from the shortcut menu to 
display the Computer Management dialog box.

2 Under Services and Applications, select Service to display a list of services in 
the right pane.

3 Locate the RemoteContainer Service and click it.
4 Select the Stop the Service option in the top left-hand portion of the Services 

pane.

Back Up the Previous Database Deployment
Using SQL Server Enterprise Manager, make sure to back up the previous 
deployment of the database. Be sure to use a meaningful name for the backup for 
future reference; for example, Agile 5.1.1 - Full Backup.

Note The database server must be running in order to perform the backup.

1 Open SQL Server Enterprise Manager.
2 In the left pane under Databases, locate the database server to back up.
3 Right-click the database and select All Tasks > Back Up Database from the 

shortcut menu.
4 Type a name for the backup, select the destination for your backup, and then 

click OK. The backup process should begin.
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Installation Software and Scripts

Installing the Agile 5.2 Upgrade Software
You can use an upgrading program, Setup.bat, to help with upgrading from 
Prodika PLM 5.1x to Agile PLM for Process 5.2. This program is designed to be 
run on the Windows computer on which the 5.1x release is currently installed. 
Through a simple, graphical user interface, the upgrading program will:

❑ Assist you with archiving the previous installation

❑ Set up the initial IIS Web site

❑ Set up the initial IIS application pools

❑ Set up the folder structure within the Web site for various Agile applications

❑ Decompress the Agile Server package into the target %PRODIKA_HOME% 
location to be accessible by IIS.

Upgrade Process
1 Double-click Setup.bat in your upgrader directory, as shown in figure 2-1 on 

page 2-5 . The upgrading program launches, displaying a screen listing the 
following steps in the left pane, as shown in figure 2-2 on page 2-5:
• 1) Setup Information

• 2) Unzip Patch

• 3) Smart Uncompress

• 4) Update EnvironmentSettings

• 5) Update CustomerSettings

• 6) Replace Web Folder

• 7) Replace Config Folder

• 8) Replace Apps Folder

• 9) Replace SharedLibs Folder

• 10) Replace Models Folder

• 11) Replace RemotingContainer Folder

• 12) Replace Schema Folder

• 13) Replace Reports Folder

• 14) Replace Scripts Folder

• 15) Replace Version File

• 16) Updating Install Information

• 17) Zip Archive

• 18) Confirmation Message
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Figure 2-1: Upgrader directory, showing Setup batch file

Figure 2-2: Upgrader program initial screen

Click this arrow 
button to start the 
installation
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2 Click the green arrow icon ( ) at the upper left of the window. The 
upgrader begins the upgrade process and prompts you for a directory in 
which to archive the currently deployed release, as shown in figure 2-3 
below.

Figure 2-3: Upgrader: prompt for archive directory

3 Type the directory in which to archive the currently deployed release or click 
the browse button ( ) to navigate to an existing directory. 

Caution! This field accepts alphanumeric characters only. To prevent any 
problems, choose a directory whose name consists of [A-Z,a-z,0-9] 
characters only (no spaces, hyphens, or other punctuation).

4 Click Submit. The upgrader records your archive directory choice and 
prompts you a temporary directory for use in upgrading, as shown in 
figure 2-4 below.

Figure 2-4: Upgrader: prompt for temp directory

5 Type a temp directory or use the browse function to select an existing and 
and then click Submit. The upgrader records your temp directory choice and 
prompts you for the location and name of a zip file with which to archive the 
current installation, as shown in figure 2-5 below.

Note The drive used for specifying a temporary working directory should 
match the drive used for Prodika_Home. 
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Figure 2-5: Upgrader: prompt for archive zip file

6 Type a zip file name and location or use the browse function to select an 
existing file and then click Submit. The upgrader records the zip file name 
and begins the largest portion of the deployment, which is automated, as 
shown in figure 2-6.

Figure 2-6: Upgrader: Info output as upgrader begins the automated portion of the process

7 The automated portion continues through the Smart Uncompress step, at 
which the upgrader prompts you for the root folder of the existing 
installation, as shown in figure 2-7.
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Figure 2-7: Upgrader: Smart Uncompress step, prompting you for root directory of existing deployment

8 Type the root folder of the currently deployed release and then click Submit. 
The upgrader works through the remaining steps.

Note This process may take several minutes.

When finished, the upgrader displays an alert box notifying you that the 
deployment has succeeded and advising you to manually confirm that the 
config files are correct, as shown in figure 2-8 below.
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Figure 2-8: Upgrader: Deployment Successful alert box

Update the Version Number in the version.txt File

Modify the version.txt file as follows:
1 In your Prodika_Home directory, locate the version.txt file. 
2 Open the file with a text editor.
3 Change the first line so that it contains only the following text:

Version: v5.2

4 Click File > Save to save the your change.
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Apply Database Upgrade Scripts

Agile Software customers will receive the Agile 5.2 database upgrade scripts on a 
CD. The scripts are packaged as a zip file. 

Important It is very important that you back up the database as indicated in Back 
Up the Previous Database Deployment on page 2-3 before upgrading 
the database. Once the scripts have been applied, there is no way to 
revert the database to the previous state without a backup.

It is also important that you run the database upgrade scripts in 
version order (4.9, 4.9.1,5.0,5.0.1,5.1,5.1.1) to bring the database up to 
the current software version.

To run the database upgrade script:
1 Create a directory to contain your database upgrade scripts. Be sure to use a 

meaningful name for each directory, for example: 
C:\work\5.2database\v5.2.0

2 Unzip the database upgrade scripts into the directory that you just created.
3 Open a command prompt and change directories (cd) to the new directory 

that you created:
C:\work\5.2_database\v5.2.0

4 Apply the scripts as indicated in the README.txt file provided with the 
database upgrade package.

5 Once the database upgrade scripts have been applied successfully, the system 
prompts you with the following message:
“Complete - with no errors”
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Reconfiguring Settings

Configure the Environment Variables Settings
Using a Text based editor, open the environmentvariables.config file and update 
the server names and port addresses.

Note For further guidance, please refer to the “Environment Variable Settings” 
section of the Agile Product Lifecycle Management for Process Configuration 
Guide.

Reconfigure the Application Environment Settings
Using a diff tool such as WinMerge, you will need to reconfigure the 
EnvironmentSettings.config file located in your Prodika_Home\Config\ 
directory.

To reconfigure application environment settings:
1 Rename the new EnvironmentSettings.config file; change the name to 

EnvironmentSettings.config-new.
2 Make a backup copy of the archived version of the 

EnvironmentSettings.config file (from the archived directory) and 
copy it into the Prodika_Home\Config\Custom\ directory.

3 Using the diff tool, compare the EnvironmentSettings.config-new file 
to the archived copy of the EnvironmentSettings.config file.

4 Update the EnvironmentSettings.config-new file as follows:
a Under ConnectionPools, change the CONNECT_STRING path values to 

the following:

server = your database server

database = your database name

Uid = your database user ID

Pwd = your database password

b Under Prodika > Services, make sure that the port numbers are correctly 
set up for your Agile services.

c Change %PRODIKA_HOME% values to the correct Prodika_Home value 
(c:\Prodika_Home\).

d Carefully merge any other configuration differences for your particular 
customer needs.

5 When you have completed the file comparison and updates, delete the copy 
that you made of the archived EnvironmentSettings.config file.

6 Rename the EnvironmentSettings.config-new file; change the name 
back to EnvironmentSettings.config.
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Reconfigure the Customer Settings
Using a diff tool such as WinMerge, you will need to reconfigure the 
CustomerSettings.config file located in your Prodika_Home\Config\ 
directory.

To reconfigure customer settings:
1 Rename the new CustomerSettings.config file; change the name to 

CustomerSettings.config-new.
2 Make a backup copy of the archived version of the 

CustomerSettings.config file (from the archived directory) and copy it 
into the Prodika_Home\Config\ directory.

3 Using the diff tool, compare the CustomerSettings.config-new file to 
the archived copy of the CustomerSettings.config file.

4 Carefully merge any configuration differences for your particular customer 
needs.

5 When you have completed the file comparison and updates, delete the copy 
that you made of the archived CustomerSettings.config file.

6 Rename the CustomerSettings.config-new file back to 
CustomerSettings.config.

Customizing the User Interface
You can customize the look and feel of your Agile PLM for Process installation in 
two ways:

❑ Edit the HTML of the home page or “landing page”— by using any HTML 
editor (see Customizing the Aglie PLM for Process Default Page on page 2-12)

❑ Revise the sitewide style sheet (see Customizing the Sitewide Style Sheet on 
page 2-13)

Customizing the Aglie PLM for Process Default Page
The default page, or dashboard, of your Agile PLM for Process installation 
consists partly of an HTML file located at:

<HOME_DIR>/Config/Custom/Content/DefaultDashboard.htm

This file displays in the main area of your Agile PLM for Process suite, as shown 
in figure 2-9 below.
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Figure 2-9: Default dashboard page

Customizing the Sitewide Style Sheet
You can customize the color scheme and logo of the user interface. A cascading 
style sheet (.css) file controls such visual aspects as background colors, link 
colors, and your company logo. This file is named “Brand.css” and resides at:

C:\{Prodika_Home}\Web\CSS\Brand.css 

You can modify Brand.css before or after installing the application suite. In 
order to add some visual effects, such as your company logo, you must add a 
Web-viewable graphic file (typically a .jpg or .gif file) to the following 
directory:

C:\{Prodika_Home}\Web\images\brand

Note The style sheet uses standard HTML cascading style sheet tags as set out by 
the World Wide Web Consortium. Default colors are set out using 
hexadecimal numbers (and in some cases, the abbreviated, 3-digit hex 
method). Modifying these settings requires a level of familiarity with 
cascading style sheets.

The Brand.css style sheet file is divided into the following major sections:

Link Colors—Link, active link, visited link (See Link Colors Section on page 2-14)

Brand Styles—Appearance of headers, footers, buttons, primary and cobrand 
logo graphics, and so on. (See Brand Styles Section on page 2-15.)

You can modify this area 
of the default dashboard 
page by editing 
DefaultDashboard.html
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Navigation— Backgrounds and text colors for the Agile PLM suite home page 
and for all applications, history drop-down list, tabs, and buttons, and so on. (See 
Navigation Section on page 2-16.)

Content Headings—Appearance of page titles and section headings. (See 
Content Headings on page 2-24.)

Tables— Table header rows, backgrounds, and background images. (See Tables 
Section on page 2-25.)

System Messages— Warning notes, error messages, and so on. (See System 
Messages Section on page 2-26.)

Login Styles—Customization of the various areas of the login page. (See Login 
Styles Section on page 2-27.)

NPD Map—Appearance of the current step in the workflow map of an NPD 
activity and that for past and future steps. (See NPD Map Section on page 2-30.)

Caution! Although Agile PLM for Process uses cascading stylesheets and other 
Web standards, the system depends on technology associated with 
Microsoft Internet Explorer™, and use of that Web browser is required 
for correct display and functioning of this system.

Consult the guidance below to modify any element in the cascading style sheet.

Link Colors Section
The Link Colors section, shown in figure 2-10 below, is the first section in 
Brand.css.

By default, hyperlinks do not change color when a user mouses over them or after 
a user has clicked them. You can revise that behavior by modifying the color value 
(in hexadecimal) and font weight.

Note You can modify link color, font weight, and any other valid CSS attribute 
in this section. By default, all links are underlined.

Figure 2-10: Brand.css style sheet, Link Colors section, showing default settings

/*LINK COLORS
------------------------------------------------------------ */
A:link {color: #2B7C92; font-weight: bold;}
A:visited {color: #2B7C92; font-weight: bold;}
A:active {color: #2B7C92; font-weight: bold;}

.cssxPsuedoLink,  .MultiTreeviewNotaccessed, .notaccessed
{color: #2B7C92;}
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Brand Styles Section
In the Brand Styles section you can modify, among other things:

❑ Header background color and image

❑ Primary logo, which appears prominently on the left of the top header, as 
shown in figure 2-13 on page 2-16

❑ Cobrand logo, which appears at the top right of the page, in the header 
section, as shown in figure 2-11 below

Note The cobrand logo image does not have to be a logo; it can be any 
image you like.

❑ Login info bar, as shown in figure 2-11

❑ Brand bar/product bar, as shown in figure 2-13

❑ Popup window header background and border, as shown in figure 2-12 below

Figure 2-11: Location of your cobrand logo

Figure 2-12: Popup window header

Your cobrand logo 
appears here

Login info bar

Popup window 
header area
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Figure 2-13: Agile PLM for Process header, showing primary logo and brand bar/product bar, whose 
appearance you can configure using Brand.css

Navigation Section
In the Navigation section, you can modify the appearance of:

❑ All navigation backgrounds—Navigational drop-down lists and menu items, 
for example. (See All Navigation Backgrounds Subsection on page 2-16.)

❑ Platform navigation—Top menu bar. (See Platform Subsection on page 2-17.)

❑ Portal navigation—Left navigation panel. (See Portal Navigation Subsection 
on page 2-17.)

❑ Application navigation—Left navigation panel as it appears once you are 
within an application. (See Application Navigation Subsection on page 2-19.)

❑ Text color —Text color for the left navigation panel (portal and application 
versions), the top menu bar, and history navigation. (See Text Color 
Subsection on page 2-20.)

❑ History drop-down list—Borders, colors, and any background image for the 
history drop-down list. (See History Drop-Down List Subsection on page 2-
21.)

❑ Tabs—Borders, colors, and background images for all tabs used throughout 
Agile PLM for Process. (See Tabs Subsection on page 2-22.)

❑ Buttons—Borders, colors, and background images for all buttons in the Agile 
PLM for Process suite, including page-level function buttons and system 
buttons. (See Buttons Subsection on page 2-23.)

All Navigation Backgrounds Subsection
In this subsection, shown in figure 2-14, you can modify the appearance of the 
backgrounds of all navigational elements.

Figure 2-14: All Navigational Backgrounds Subsection, Navigation section, Brand.css

/*All Navigation Backgrounds*/
.cssxPlatformDrop, .cssxPlatformGroup, .cssxPortalGroup, 
.cssxPortalMenu, .cssxPortalDrop, .cssxAppNav, .cssxAppNavBg, 
.appNav-Level2Item, .historyMenuItem, .historyMenuGroup
{background-color: #eaeff5;}

Brand bar/
product bar

Primary logo
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Platform Subsection
In this subsection, shown in figure 2-15, you can modify the color of the text in 
the top menu bar, as shown in figure 2-16.

Figure 2-16: The top menu bar, whose appearance is controlled by the style elements in the Platform 
subsection

Portal Navigation Subsection
In this subsection, shown in figure 2-17 below, you can modify the appearance of 
the left navigation panel, shown in figure 2-18.

Figure 2-15: Platform subsection, Navigation section, Brand.css

/*PLATFORM*/
.cssxPlatformMenuItem, .cssxPlatformMenuItemH  /*Platform Text 
Color*/ 
{color: #fff;}

Figure 2-17: Portal Navigation subsection, Navigation section, Brand.css

/*PORTAL*/
.cssxPortalDropItemH, .cssxPlatformDropItemH /*Highlight*/ 
{
background-color: #ccd7e0;
}

.cssxPortalNavTitle, .cssxPortalNavCaption /*Text Color*/ 
{
color: #013d74;
}
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Figure 2-18: The left navigation panel, whose appearance is controlled by the style elements in the Portal Navigation 
subsection
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Application Navigation Subsection
In this subsection, shown in figure 2-19, you can modify the appearance of the 
left navigation panel that displays once you are in an application, as shown in 
figure 2-19 on page 2-19.

Figure 2-19: Application Navigation subsection, Navigation section, Brand.css

/*APPLICATION*/
.appNav-TopItem, .appNav-TopItem2 /*Parent Category*/ 
{
border: 1px solid #f2f9fe;
border-right-color:#9aa3aa;
border-bottom-color:#9aa3aa;
background-color: #ccd7e0;
}

.appNav-TopItemHover, .appNav-TopItemHover2 /*Parent Category 
Highlight*/ 
{
border: 1px solid #f2f9fe;
border-right-color:#9aa3aa;
border-bottom-color:#9aa3aa;
background-color: #fff;
}

.appNav-Level2ItemHover, .appNav-Level2ItemSelected , .appNav-
TopItemActive2, .appNav-TopItemActive /*Parent & Item Highlights & 
Onclicks*/ 
{
background-color: #fff;
}
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Figure 2-20: Left navigation panel that displays once you are in GSM

Text Color Subsection
In this subsection, shown in figure 2-21 below, you can modify the color of the 
text in the left navigation panel (portal and application versions), the top menu 
bar, and history navigation.

Figure 2-21: Text Color subsection, Navigation section, Brand.css

/*Text Color*/ 
.appNav-Level2Item td, .appNav-TopItemActive2 td, .appNav-TopItem 
td, .appNav-TopItem2 td, .appNav-TopItemHover td, .appNav-
TopItemHover2 td, .appNav-TopItemActive td, .appNav-Level2ItemHover 
td, .appNav-Level2ItemSelected td
{
color: #013d74;
}
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History Drop-Down List Subsection
In this subsection, shown in figure 2-22 below, you can modify the borders, 
colors, and any background image used in history drop-down lists, as shown in 
figure 2-23.

Figure 2-23: The history drop-down list, whose appearance is controlled by the style elements in the 
History Drop-Down List subsection of the Navigation section of Brand.css

Figure 2-22: History Drop-Down List subsection, Navigation section, Brand.css

/*HISTORY*/
.historyTopMenuItem, .historyTopMenuItemHover /*History Menu Top 
Menu Background */
{
background-image: url(../images/brand/subDimTabBg.gif);
}

.historyMenuItemHover /*History Menu Highlight*/
{
background-color:#FFFFFF;
}
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Tabs Subsection
In this subsection, shown in figure 2-24 below, you can modify the borders, 
colors, and any background images used in all tabs throughout Agile PLM for 
Process.

Figure 2-24: Tabs subsection, Navigation section, Brand.css

/*TABS*/
.tabmenu /*Tab Bottom Line*/ 
{
border-bottom: #92badc 2px solid;
}

.subtabmenu /*SubTab Bottom Line*/ 
{
border-bottom: #82b2db 3px solid;
}

.DefaultTab, .subDefaultTab /*Unselected Tabs*/ 
{
background-image: url(../images/brand/subDimTabBg.gif);
border: 1px solid #c0c0c0;
}

.SelectedTab, .subSelectedTab /*Selected Tabs*/ 
{
background-image: url(../images/brand/subTabBg.gif);
border: 1px solid #a3bed8;
color: #3c3c3c;
}

.TabMenuText, .tabnav_unselectedtab_span, .subTabMenuText /*Text 
Color*/
{
color: #3e5576;
 }
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Buttons Subsection
In this subsection, shown in figure 2-25 below, you can modify the borders, 
colors, and any background images used in all buttons throughout Agile PLM for 
Process. As shown in the figure, there are separate sections for page-level function 
buttons (see figure 2-26) and system buttons (see figure 2-27 on page 2-24). 

Figure 2-26: Page-level function buttons, whose appearance is controlled by the style elements in the Buttons subsection of the 
Navigation section of Brand.css

Figure 2-25: Buttons subsection, Navigation section, Brands.css

/*BUTTONS*/

/*Page-Level Function Buttons*/ 
input.elButton, a.elButton, a.elButton:visited, a.elButton:linked, 
a.elButton:hover,  
.actionMenu-TopMenuItem, .actionMenu-TopMenuItemHover, .actionMenu-
MenuGroup, .actionMenu-MenuItem, .actionMenu-MenuItemHover 
{   
border-right: solid 1px #7b8194;
border-bottom: solid 1px #7b8194;
border-top: solid 1px #a5a9b6;
border-left: solid 1px #a5a9b6;
background-image: url(../images/brand/btn-bg.gif);
background-color: #c9e5ec;
color: #586073;
}

/*System Buttons*/ 
.cssxBtnFunction, A.cssxBtnFunction:link, 
A.cssxBtnFunction:visited, A.cssxBtnFunction:hover, 
.cssxBtnControl, A.cssxBtnControl:link, A.cssxBtnControl:visited, 
A.cssxBtnControl:hover
{
border-right: solid 1px #7b8194;
border-bottom: solid 1px #7b8194;
border-top: solid 1px #a5a9b6;
border-left: solid 1px #a5a9b6;
background-image: url(../images/brand/btn-bg.gif);
background-color: #c9e5ec;
color: #586073;
}
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Figure 2-27: Sample of system buttons, whose appearance is controlled by the style elements in the 
Buttons subsection of the Navigation section of Brand.css

Content Headings
In the Content Headings section, shown in figure 2-28, you can modify the 
appearance of page titles and section headings.

Figure 2-28: Content headings section of Brand.css

/*CONTENT HEADINGS
------------------------------------------------------------ */
/*Page Titles*/
.cssxPageTitle, .cssxPageTitle H1, .cssxPageTitle a:link, 
.cssxPageTitle a:visited, .cssxPageTitle a:hover, .cssxPageTitle 
a:active 
{
color: #3a5a87;
}

/*Section Headings*/ 
h2, h4
{
color: #426ca7;
border-bottom: #567fc7 1px inset;
font-size: 100%; 
}
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Tables Section
In the Tables section, shown in figure 2-29, you can modify the appearance of:

❑ Table header rows

❑ Table background

❑ Action Items header, as shown in figure 2-30

Figure 2-30: Action Items header

Figure 2-29: Tables section of Brand.css

/*TABLES
------------------------------------------------------------ */

/* Table Header Rows */ 
.cssxBaseGrid th, .cssxActionGrid TH, .cssxActionGrid 
.cssxActionGridHeaders, .cssxTreeDataGrid th   
{
background-color:#cfe0f1;
}

/*Table Background*/
.cssxTreeDataGrid, .cssxActionGrid td, .cssxBaseGrid  
{
background-color:#f2f2f5;
}

/*Action Items Header*/ 
.cssxActionGrid .cssxActionHeader 
{
background-image: url(../images/brand/hBar-Bg.gif);
color:#333;
}
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System Messages Section
In the System Messages section, shown in figure 2-31 below, you can modify the 
appearance of:

❑ Warning note header image and background color

❑ Error message header image and background color

❑ Information note header image and background color

Figure 2-32: Error message, with image, background color, and border style set by .cssErrorNote

Figure 2-31: System Messages section of Brand.css

/*SYSTEM MESSAGES
------------------------------------------------------------ */
.cssxWarningNote /*Warning Message Header*/
{
background-image:url(../images/brand/warning-header.gif);
}

.cssxErrorNote /*Error Message Header*/
{
background-image:url(../images/brand/error-header.gif);
}

.cssxInfoNote /*Information Message Header*/
{
background-image:url(../images/brand/information-header.gif);
}

.cssxWarningNote, .cssxErrorNote, .cssxInfoNote /*Warning, Error, 
Information Messages*/
{
border:solid 1px #b2c8dc;
background-color: #d9e5ef;
}
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Login Styles Section
In the Login Styles section, shown in figure 2-33 below, you can modify the 
appearance of different sections of the login page. The six style elements in the 
Login Styles section apply to five areas of the login screen (two elements apply to 
one area). 

The area affected by each of the six elements is illustrated in the following figures:
cssxLogin-1— Login screen area affected by the .cssLogin-1 style element of 
Brand.css on page 2-28

cssxLogin-2—Login screen area affected by cssxLogin-2 style element of Brand.css 
on page 2-28

cssxLoginPhoto—Login screen area affected by the .cssxLoginPhoto style element 
in Brand.css on page 2-29

cssxLogin-3a and cssxLoginGraphic—Login screen area affected by cssxLogin-
3a and cssxLoginGraphic style elements of Brand.css on page 2-29

cssxLogin-3b—Login screen area affected by the cssxLogin-3b style element of 
Brand.css on page 2-30

Figure 2-33: Login Styles section of Brand.css

/*LOGIN STYLES
------------------------------------------------------------ */
.cssxLogin-1 /*Row 1*/
{background-color:#ededed;height:70px;}

.cssxLogin-2 /*Row 2*/
{background-color:#f4f4f4;}

.cssxLogin-3a /*Row 3 Column 1*/
{background-color:#f4f4f4;}

.cssxLogin-3b /*Row 3 Column 2*/
{background-image:url(../images/style/login-lightBlue_back.jpg);
background-repeat:repeat-x;background-color:#fbfbfb}

.cssxLoginPhoto   
 {
 background-image: url(../images/style/login-people.jpg);
 width: 417px; 
 height: 54px;
 }
 
.cssxLoginGraphic
 {
 background-image: url(../images/style/login-globe.jpg);
 width: 351px; 
 height: 259px;
 }



Agile Product Lifecycle Management for Process

2-28 Install/Upgrade Manual

Figure 2-34: Login screen area affected by the .cssLogin-1 style element of Brand.css

Figure 2-35: Login screen area affected by cssxLogin-2 style element of Brand.css

.cssxLogin-1 
controls this area

.cssxLogin-2, for 
background color of 
this area
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Figure 2-36: Login screen area affected by the .cssxLoginPhoto style element in Brand.css

Figure 2-37: Login screen area affected by cssxLogin-3a and cssxLoginGraphic style elements of Brand.css

.cssxLoginPhoto 
for this area

cssxLoginGraphic, for 
the login image

cssxLogin-3a, for background color 
for this area
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Figure 2-38: Login screen area affected by the cssxLogin-3b style element of Brand.css

NPD Map Section
In the NPD Map section, shown in figure 2-39 below, you can modify the 
appearance of the workflow map that you can view from within the New Product 
Development (NPD) application. Specifically, you can control the appearance of 
the current (highlighted) workflow step and the past and future (non-
highlighted) steps. Figure 2-40, on page 2-31 shows a sample of an NPD map for 
reference.

Figure 2-39: NPD Map section of Brand.css

/*NPD MAP
------------------------------------------------------------ */
.cssxHiMapStep /*NPD Map - Highlighted Workflow Step*/ 
{
color: #333;
background-color: #CCCCCC;
background-image:url(../images/brand/NPDHiMapStep.gif);
background-repeat:repeat-x;
}

.cssxMapStep  /*NPD Map - Workflow Step*/ 
{
color: #333;
background-image:url(../images/brand/NPDMapStep.gif);
background-repeat:repeat-x;
background-color: #b6b6b6;
}

.cssxLogin-3b, here 
setting background 
image and background 
color
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Figure 2-40: Map of an NPD activity showing highlighted and non-highlighted workflow steps

Current step

Past and future 
steps
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Updating the Sort Order of the Left Navigation Panel

You can use the SiteMap-DisplayOrder.xml file to change the menu item 
ordering for existing menus that come with the product. All the menu items have 
a SortOrder property that is evaluated and ordered in ascending order.

For example:

<MenuItem ID="Menu1" SortOrder="10" configChildKey="ID"/>
<MenuItem ID="Menu2" SortOrder="20" configChildKey="ID"/>

The above menus are displayed as in the order Menu1, Menu2. If the sort order 
is transposed, then Menu2 gets displayed before Menu1. The actual number or 
the spacing between these tags does not matter. In the above example, 10 menu 
items could be inserted between Menu1 and Menu2 and yet be sorted 
deterministically. If two menus have the same sort order, then the display order 
is not guaranteed between those two elements.

Extending the Left Navigation Panel
With the SiteMap-Extensions.xml file you can add new menu items that are 
not part of the core product. In general a menu item would look like the 
following:

<MenuItem ID="translation Id" DisplayText="Generally note 
used… just to indicate what gets displayed" 
SecurityProfileRef="Security Profile Name" 
SkinRef="Skin Profile Name" 
TranslationRef="Translation Profile Name" 
SortOrder="Some number" NavigateUrl="http://
SomeUrl.com"  />

Menu items can be nested to create menu hierarchies, as shown below:

Application Wide Menu
Applications

GSM 

...then the menu definition would look like this:

<MenuItem ID="ApplicationWideMenu" DisplayText="**Application Wide 
Menu" >

<MenuItem ID="Applications" DisplayText="**Applications">
<MenuItem ID="GSMSideNav" DisplayText="**GSM">

<MenuItem ID="[translation Id]" 
DisplayText="[Generally note used… just to indicate 
what gets displayed]" 
SecurityProfileRef="[Security Profile Name]" 
SkinRef="Default Skin" 
TranslationRef="Application Menu"
SortOrder="[Some number]"
NavigateUrl="[http://SomeUrl.com]"  />

</MenuItem>
</MenuItem>

</MenuItem>

The values in [ ] need to be changed.
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For more information, see Setting Security on the Left Navigation Panel Items 
below. Other than that, the NavigateUrl indicates the url to navigate to when a user 
clicks a menu item.

Setting Security on the Left Navigation Panel Items
This section discusses how to use the MenuConfig-Extensions.xml file to 
secure left navigation items. 

More than likely, only the security settings for new menu items will need to be 
modified. Every SiteMap entry has three properties that determine how the menu 
item is rendered in terms of security, appearance, and the translated text that is 
shown to the users. These properties are SkinRef, SecurityRef and TranslationRef. All of 
these properties except the SkinRef cascade to child elements; so if a menu item 
does not have a SecurityRef property, then it inherits the security profile of its 
parents.

Security Profile
Below is a snippet of the security provider configuration in MenuConfig.xml:

<Provider ID="SecurityProvider" …>
      <SecurityProfiles…>
            <SecurityProfile ID="Default" Mode="Visibility">
                  <Allow Roles="*"/>
            </SecurityProfile>
            <SecurityProfile ID="PQSReportViewer" Mode="Visibility" 
Application="PQS">
                  <Allow Roles="[PQS_ADMIN],[PQS_Reporter]"/>
            </SecurityProfile>
            …
     </SecurityProfiles>
</Provider>

The SiteMap menu items have security profiles associated with every menu. For 
example, if a menu item were set up with a profile of PQSReportViewer, it 
would evaluate to the above security profile. What this security profile describes 
is “Any PQS user with the roles [PQS_ADMIN] OR [PQS_Reporter] has 
visibility to the menu item.”

If Application were blank or not defined, then it would mean “Any user with the 
roles [PQS_ADMIN] OR [PQS_Reporter] has visibility to the menu item.”

Wild card of “*” is allowed on Users, Roles and Applications, and it signifies “all.”
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Translation Profile
Typically all pipelines are configured with a dynamic translation provider, which 
usually looks like this:

<Provider ID="ApplicationWideMenuTranslationProvider" …>
<TranslationCaches…>

<TranslationCache ID="GSMSideBar" Path="frmMaster/ctlNavMenu1"/>
<TranslationCache ID="NDPSideBar" Path="frmNPD/ctlSidebar"/>

</TranslationCaches>
...
</Provider>

If the menu item has a translation profile, it looks up the cache from the 
translation caches collection. If a menu item has a TranslationRef of “GSMSideBar,
” then it maps to the frmMaster/ctlNavMenu1 translation cache. 

This defines skin profiles specific to the Component Art Navigation items, which 
use ItemLooks to define the way navigation controls look. When a menu or menu 
item is configured with an item look, the LookId property is very important and all 
the properties are case sensitive. Every Skin can have only a finite set of ItemLooks, 
and the LookId determines the look of the menu items in various situations.

Valid LookIds for Top-Level Menus
    DefaultChildSelectedItemLook
    DefaultDisabledItemLook
    DefaultItemLook
    DefaultSelectedItemLook

Valid LookIds for MenuItems
    ChildSelectedLook
    DefaultSubItemChildSelectedLook
    DefaultSubItemDisabledLook
    DefaultSubItemLook
    DefaultSubItemSelectedLook
    DisabledLook
    Look
    SelectedLook

Syntax for Setting Properties
All parameters that are picked up from context supplied to the MenuBuilderService 
are of the form ${variableName[,defaultValue]}.
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Reconfiguring and Restarting Remote Container Service 
and Web Application Server

Reconfigure the Remote Container Service
As of version 5.2, it is not necessary to reconfigure the Remote Container service.

Restart the Remote Container Service

Using IIS Computer Management, restart the remote container service:
1 Right-click My Computer and select Manage from the shortcut menu to 

display the Computer Management dialog box.
2 Under Services and Applications, select Service to display a list of services in 

the right pane.
3 Locate the RemoteContainer Service and click it.
4 Select the Start the Service option in the top left portion of the Services pane. 

Restart the Web Application Server

Using a command prompt, restart the IIS Web application server:
1 Open a command prompt.
2 Enter the following command:

C:\Documents and Settings\Administrator>iisreset

The Web application server restarts.

Verifying the Installation
Log in to the Agile user portal and verify that the installation is functioning 
correctly. We recommend that you perform a variety of post-installation tests to 
ensure that all the applications are functioning correctly. For more information, 
see Installation Verification Tests on page 1-24.
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