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Preface 
The Oracle|Agile documentation set includes Adobe® Acrobat™ PDF files. The Oracle Technology 
Network (OTN) Web site (http://www.oracle.com/technology/documentation/agile.html) contains the 
latest versions of the Oracle|Agile PLM PDF files. You can view or download these manuals from 
the Web site, or you can ask your Agile administrator if there is an Oracle|Agile Documentation 
folder available on your network from which you can access the Oracle|Agile documentation (PDF) 
files. 

Note To read the PDF files, you must use the free Adobe Acrobat Reader™ version 7.0 or later. 
This program can be downloaded from the Adobe Web site (http://www.adobe.com). 

The Oracle Technology Network (OTN) Web site 
(http://www.oracle.com/technology/documentation/agile.html) can be accessed through Help > 
Manuals in both the Agile Web Client and the Agile Java Client. If you need additional assistance or 
information, please contact support (http://www.oracle.com/agile/support.html) 
(http://www.oracle.com/agile/support.html) for assistance. 

Note Before calling Agile Support about a problem with an Oracle|Agile PLM manual, please 
have ready the full part number, which is located on the title page. 

TTY Access to Oracle Support Services 

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479. 

Documentation Accessibility  

Our goal is to make Oracle products, services, and supporting documentation accessible, with good 
usability, to the disabled community. To that end, our documentation includes features that make 
information available to users of assistive technology. This documentation is available in HTML 
format, and contains markup to facilitate access by the disabled community. Accessibility standards 
will continue to evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be accessible to 
all of our customers. For more information, visit the Oracle Accessibility Program Web site at 
http://www.oracle.com/accessibility/ http://www.oracle.com/accessibility/.  

Readme 

Any last-minute information about Oracle|Agile PLM can be found in the Readme file on the Oracle 
Technology Network (OTN) Web site (http://www.oracle.com/technology/documentation/agile.html). 

Agile Training Aids 

Go to the Oracle University Web page 
(http://www.oracle.com/education/chooser/selectcountry_new.html) for more information on Agile 
Training offerings. 

http://www.oracle.com/technology/documentation/agile.html
http://www.adobe.com/
http://www.oracle.com/technology/documentation/agile.html
http://www.oracle.com/agile/support.html
http://www.oracle.com/agile/support.html
http://www.oracle.com/accessibility/
http://www.oracle.com/accessibility/
http://www.oracle.com/technology/documentation/agile.html
http://www.oracle.com/education/chooser/selectcountry_new.html


 

Accessibility of Code Examples in Documentation  

Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise empty line; 
however, some screen readers may not always read a line of text that consists solely of a bracket or 
brace.  

Accessibility of Links to External Web Sites in Documentation  

This documentation may contain links to Web sites of other companies or organizations that Oracle 
does not own or control. Oracle neither evaluates nor makes any representations regarding the 
accessibility of these Web sites.  
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Chapter 1 

Introducing Viewer 
This chapter includes the following: 

� How to Use this Manual....................................................................................................................................... 7 
� Getting Help......................................................................................................................................................... 8 
� About Viewer ....................................................................................................................................................... 8 
� What's New in this Release ................................................................................................................................. 9 
� Viewer Window.................................................................................................................................................... 9 
� Understanding the Viewer ................................................................................................................................... 10 

 
 

How to Use this Manual 
This manual is a supplement to Agile Viewer online Help. It is intended to be used in conjunction 
with the viewer online help and other Oracle|Agile manuals. 

The viewer has been integrated into the Agile system to make use of the Agile’s ability to manage 
attached files by using Agile system features. The integration also streamlines the viewer menus, 
toolbars, and shortcuts. The following table shows where you can find information about Agile 
features and concepts which you may find useful. 

Feature  or  concept  Conta ined in  th is  document  

Java Client Navigation Getting Started with Agile PLM User Guide, 
Chapter 2, "Navigating in Agile Java Client" 

Web Client Navigation Getting Started with Agile PLM User Guide, 
Chapter 3, "Navigating in Agile Web Client" 

Relationships and rules between objects Getting Started with Agile PLM User Guide, 
Chapter 5, "Working with Business Objects" 

Attachment files 

Working with file folder objects 

File folder mass update 

Routing and reviewing file folders 

File validation (Handle Check Sum) 

Viewing and redlining file folder contents 

Getting Started with Agile PLM User Guide, 

Chapter 9, "Navigating in Agile Web Client" 

and 

Chapter 10, "Working with File Folders" 

Redlining through ECOx, MCOs and SCOs Product Collaboration User Guide, 
Chapter 5, "Changes" 

Note To find an Agile PLM document, choose Help > Manuals in the Java Client or the Web 
Client to display the Agile PLM documentation web page. 
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Getting Help 
To get help at any time, choose Help > Contents in the Agile Viewer menu bar. The viewer online help 
is displayed; it includes detailed information about using viewer features. 

Note See “Agile-specific Features and Functions (on page 15)” for a complete list of features 
and user interface details described in the viewer online Help that have been modified in 
order to integrate the viewer with the Agile system. 

 

About Viewer 
Viewer can display many different file formats without their authoring applications. You can view 
files from many database, graphic, spreadsheet, word-processing, and CAD applications. Even 
archive files can be listed and viewed without the need to decompress them. It isn’t necessary for 
you to identify the file type; Viewer automatically identifies the type of file you are requesting it to 
read. The Agile administrator determines which types of files can be viewed by setting the 
Supported File Types property  and Structured File Types property in the Agile Administrator 
module in Java Client.       

Important To view files through the Advanced Viewer, you need Agile Discovery, Read, and 
ViewFile privileges. To redline files through the Advanced Viewer, you need the 
appropriate privileges that allow you to redline attachment files (for example, the Agile 
default role Markup for Self). 

The action of attaching your comments, notes, and drawings to a document is known as marking 
up, also commonly known as annotating or redlining. A markup refers to the change being made to 
a document by attaching a markup object. You can use Viewer to mark up files as well as view 
them. 

Note Agile Java Client and Agile Web Client support attachment redlining. Markups for ECOs 
can be made on the Redline Attachments tab in Java Client and Web Client. You access the 
appropriate redline tab on the Affected Items tabs of ECOs. Markups for a file folder object 
can be made on the Files tab of the file folder object in Java Client and Web Client and do 
not require an ECO. 

Some of Viewer’s features are: 

à Flexible user-defined objects — Viewer offers a vast selection of markup objects, including circles, 
clouds, polygons, and arrows. Text can be attached to objects, and lengthier comments can be 
contained in embedded notes. 

See Viewer online help for a detailed discussion of markup objects. Choose Help > Contents in 
the Viewer menu bar. 

à Storage of unedited original documents — Original documents are never changed. All your notes 
and drawings are saved in a separate file called a markup file, although when viewed they 
appear to be part of the main document. You do not have to manage the storage and retrieval 
of markup files; Agile does that for you. 

à Support for non-English languages and operating systems — Viewer works with many non-English 
languages, and has been tested on Japanese, Chinese, French, German, Hebrew, and 
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Swedish operating systems. 

added to this release: 

à 

lies 
ration (EC) CAD 

 

What's New in this Release 
The following new features have been 

Viewing Structured CAD Designs 

This Agile PLM release supports the ability to view data, such as CAD data, stored in Agile as 
item structures.  The typical use case is for viewing mechanical or electronic CAD assemb
saved into "DocuBOM" structures in Agile using the Engineering Collabo
Connectors. See Viewing Structured File Types (on page 19). 

à 

 

 viewer itself. 

Ability to Search and Browse Agile Data from within the Viewer 

In previous releases, when entering the viewer for a more complex operation such as 
Compare, Cross Probe, or Digital Mockup, it was necessary to select all desired files in Agile
PLM  prior to the viewer starting.  This release provides new Agile Search and Agile Browse 
buttons within the viewer commands, to retrieve additional files from within the
See Opening Agile Attachment Files from the Viewer Window (on page 17). 

The Compare function has extended so the user can initiate the Agile PLM  à  to 

g the viewer window. See Comparing Revisions or Versions of a File

View command
view a particular file and the Viewer Compare command will contain a pre-loaded list of 
additional revisions or versions of the file to be compared against.  This provides a simple 
process to perform repetitive Compare commands against multiple revisions or versions 
without leavin  (on page 

Viewer Window 
he item Attachments tab or the file folder Files tab. 

To s

ble-click the attachment row. 

19). 
 

You can start the Viewer from either t

tart the Viewer in Java Client: 

Dou

Or 

1. Select one or more rows. 

2. Click the View File(s) button’s drop-down arrow and select View  from the menu. 

Note If the View  icon is visible on the button, you can simply click the button. 

To s

k the file name link in the table. 

tart the Viewer in Web Client: 

Clic

Or 

1. Select one or more rows. 

2. Click the View File(s) button’s drop-down arrow and select View  from the menu. 

Note If the View  icon is visible on the button, you can simply click the button. 

When you start Viewer, the main Viewer window appears.         
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Note For more information about starting the Viewer, see “Opening Agile Attachment Files in 
the Viewer (on page 15)”. 

 

Viewing an Attachment Tab Row with Multiple Files 
When viewing files from the Attachments tab of an Agile business object, if you view a single row that 
refers to a multiple-file file folder, the Select Files window appears. The Select Files window lists the 
files in that file folder and allows you to select one or more files that you want to view. 

Note For more information about starting the Agile Viewer, see “Opening Agile Attachment 
Files in the Viewer (on page 15)”. 

 

Understanding the Viewer 
The following sections describe the main Viewer window and performance modes, plus other 
information needed to use Viewer. 

Viewer Modes 
Viewer has two performance modes: View and Markup. 

View Mode 

When a document is first opened from business object’s Attachments tab or file folder Files tab, the 
menu bar and toolbars are those of View mode. View mode is Agile Viewer’s default mode. 
Documents can be edited or marked up only from Markup mode, described in the next section.      

Markup Mode 

When Agile Viewer is in Markup mode, the currently displayed document can be marked up. That 
is, you can redline or annotate it. Available markup objects include various shapes, notes, symbols, 
and text. When you open Agile Viewer from the Redline Attachments tab or Files tab in a file folder 
object, Agile Viewer opens either in View or Markup mode, depending on whether the attachment 
has a saved markup and the privileges assigned to the user. If the attachment is checked out, then 
the redlining will not be allowed, however, you can change to Agile Viewer Markup mode to display 
saved markup. For instructions on how to enter Markup mode from View mode, see “Guidelines for 
Marking Up or Redlining Attachments (on page 21)”. When you open a markup file, Markup mode 
starts automatically. 

Note Markup mode is available in the viewer only when the viewer is opened from tabs where 
markups are allowed: from a change order’s Redline Attachments tab and from the Files tab 
of a file folder. In addition, you must have the appropriate privileges that allow you to 
redline attachment files (for example the Agile default role, Markup for Self). Contact your 
Agile administrator if you have questions about your assigned roles and privileges. 
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Viewer Window Components 
There are a few basic components to the Viewer work environment, shown in the following figure. 
These differ according to whether Viewer is in View mode or Markup mode. 

 
 

Menu Bar 

The menu bar at the top of the window is the main access to all of the menu commands. The 
selection of available commands changes according to the mode the viewer is in and the task that 
you’re performing.      

Toolbars 

The tool buttons under the menu bar offer easy access to the basic commands presented in the 
menu bar. As with menu commands, the selection of available toolbar buttons changes according to 
the mode the viewer is in and the task that you’re performing.       

Status Bar 

In both View mode and Markup mode, there is a status bar located at the bottom of the main 
window. The fields from left to right for each mode’s status bar are as follows:  markers (see the 
following list), current active file name, file type, zoom factor, current page and total number of 
pages, current active file size, date of the file’s creation, and the pointer’s coordinate position. 
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The following types of markers can appear on the status bar: 

à A red light bulb marker indicates that the current active file has associated markup files. While in 
View mode, click the markup from the File menu to view the Markup Files dialog box. Then 
select a markup file or group of markup files to open. When you open a markup file, Markup 
mode starts automatically.       

à A red exclamation mark indicates that some main resources required to properly read the current 
active document are not available (for example, missing fonts or missing CAD files). To quickly 
identify the missing resources, click the red exclamation mark, and the File Properties dialog 
box appears. 

à The Join Session  button, which indicates that you have been invited to join a Collaboration 
session. 

 

Moving Objects 
You can use the left mouse button to click and drag.       

à In View mode — By default, drag to perform an autozoom of all supported file formats (including 
raster and vector files). Select the area you want to enlarge. 

à In Markup mode — If objects are selected, drag to modify and move objects. If no objects are 
selected, drag to perform an autozoom (same as in View mode). 

To select an object, click it. Selected objects are framed by a text box. Modify the size of the 
object by dragging the frame handles. To move an object, move the cursor to the borders (the 
edges) of the markup entity until the cursor turns into a hand pointer. Drag the hand pointer to a 
new location. 

Accessing Commands with Shortcut Menus 
The easiest and quickest way to access most of Agile Viewer’s functions is using the shortcut 
menus. Simply right-click with the pointer over the View window to access appropriate commands. 

In View mode, use these commands: 

à Zoom Fit — to automatically fit the document to the width of the view window. 

Zoom Previous — to automatically return to your previous zoom level. à 

à 

à a 
new one. The Markup command is available in View mode only when markups are allowed. 

à ct the type of fill to apply to your markup object: Solid Fill, No Fill, or 

Zoom Page Width — to automatically fit the document to the width of the view window. 

Markup/Exit Markup — to enter and exit Markup mode and open an existing markup or create 

In Markup mode, use these additional commands: 

à Line Style — to select a style of line to use in your markup. 

à Line Thickness — to select a line thickness for use in your markup. 

Fill Type — to sele
Transparent Fill. 

à Entity Color — to select a color for your markup object. 
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à Order — to select the overlay order when several markups are being displayed simultaneously. 

Markup Layersà  — to select which layers are visible or active, change layer color, add new layers, 

w a cloud, right-click 

select the 
box and press the Delete key on your keyboard. What has already been drawn is erased. 

and rename existing layers. 
 

Canceling an Operation in Progress 
For example, if while drawing a box you realize that you would prefer to dra
while drawing the box and the box is erased from the display. 

If you have already drawn a box, you can either choose Edit > Undo from the menu bar or 

 Page - 13

  

 



Viewer Supplement   
 
 
 

 

Page - 14 Agile Product Lifecycle Management 

 

 



 

Chapter 2 

Agile-specific Features and Functions 
This chapter includes the following: 

� Opening Agile Attachment Files in the Viewer..................................................................................................... 15 
� Ad Hoc Markups .................................................................................................................................................. 20 
� Marking Up — How It Works ............................................................................................................................... 21 
� Guidelines for Marking Up or Redlining Attachments .......................................................................................... 21 
� Marking Up Documents ....................................................................................................................................... 26 
� 2D Features and Functions ................................................................................................................................. 26 
� EDA Features and Functions............................................................................................................................... 26 
� 3D Features and Functions ................................................................................................................................. 27 
� Cross Probing ...................................................................................................................................................... 29 
� Comparing Files................................................................................................................................................... 31 
� Overlaying Files ................................................................................................................................................... 33 
� Working with Schematic and PCB Files .............................................................................................................. 34 
� Real-Time Collaboration ...................................................................................................................................... 34 
� Digital Mockup ..................................................................................................................................................... 35 

 
 

Opening Agile Attachment Files in the Viewer 
You can view files from either the Attachments tab of a business object or from the Files tab of a file 
folder object. 

Viewing Files From Java Client 
To view a file from Java Client, Attachments tab: 

1. Go to the Attachments tab of a business object that references the file. 

2. Double-click the attachment row. 
y If the attachment row refers to a file folder with only one file, the Viewer opens and 

displays that file. 
y If the attachment row refers to a multiple-file file folder, the Select Files window appears. 

Select one or more files to view and click OK. The Viewer opens and displays the files you 
selected. 

Or, you can use the Attachment tab View File(s) button: 

1. Go to the Attachments tab of a business object that references the file. 

2. Select one or more attachment rows. 

3. Click the View File(s) button’s drop-down arrow and select View  from the menu.  

Note If the View  icon is visible on the button, you can simply click the button. 
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y nt row that refers to a file folder with only one file, the Viewer 

y s 
more files to view and click OK. The Viewer opens and 

y  the 
iewer. The Select Files window does not appear. 

v

taining the files you want to view. 

2. . 

e file. 

lick

If you selected one attachme
opens and displays that file. 
If you selected one attachment row that refers to a multiple-file file folder, the Select File
window appears. Select one or 
displays the files you selected. 
If you selected more than one attachment row, the Viewer opens and all the files in all
selected rows are displayed in the v

To iew a file from Java Client, Files tab: 

1. Go to the Files tab of a file folder object con

Double-click the filename in the file table

The Viewer opens and displays th

3. Or, select one or more file rows. 

4. C  the tab me  nu View File(s) button’s drop-down arrow and select View  from the menu.  

Note If the View  icon is visible on the button, you can simply click the button. 

The Viewer opens and displays the selected files. 

Viewing Files From Web Client 
v

t references the file. 

2. 
y 

y 
ore files to view and click Finish. The Viewer opens and displays the files 

 

ct that references the file. 

To iew a file from Web Client, Attachments tab: 

1. Go to the Attachments tab of a business object tha

Click the file name link in the attachments table. 
If the attachment row refers to a file folder with only one file, the Viewer opens and 
displays that file. 
If the attachment row refers to a multiple-file file folder, the Select Files window appears. 
Select one or m
you selected. 

Or, you can use the Attachment tab View button: 

1. Go to the Attachments tab of a business obje

2. Select one or more attachment rows. 

3. Click the View button’s drop-down arrow and select  View from the menu.  

Note If the View  icon is visible on the button, you can simply click the button. 

y If you selected one attachment row that refers to a file folder with only one file, the Viewer 
opens and displays that file. 
If you selected one attachment ry ow that refers to a multiple-file file folder, the Select Files 

nt row, the Viewer opens and all the files in all the 
iewer. The Select Files window does not appear. 

window appears. Select one or more files to view and click OK. The Viewer opens and 
displays the files you selected. 

y If you selected more than one attachme
selected rows are displayed in the v
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To iew a file from Web Client, Files tab:v  

1. ontaining the files you want to view. 

ble. 

4. Click the tab menu View button’s drop-down arrow and select 

Go to the Files tab of a file folder object c

2. Click the filename link in the file ta

The Viewer opens and displays the file. 

3. Or, select one or more file rows. 

 View from the menu. 

Note If the View  icon is visible on the button, you can simply click the button. 

The Viewer opens and displays the selected files. 

Opening Agile Attachment Files from the Viewer Window 
When the Viewer window is open, you can use the Viewer menus to select a different Agile 
attachment file to view without using the Java Client or Web Client Attachments tab commands. 

The sp
depe pon the function you originally chose in Agile PLM when you opened the viewer (View,

be, Compare, Overlay, or Digital Mockup) and the file type of the currently viewed file.  

ecific Viewer menu choices that are available to allow you to select an Agile attachment file 
nd u  

Cross Pro

Note Because the list of available Viewer menu selections for attachment file selection can 
vary, some of the following menu selections may not be available for you to choose in a 
specific Viewer session. 

The possible available Viewer menu selections that allow you to select another attachment file 
u

are 

e Agile Browse button in the File 
arks to select a file. The Agile Search button in the 
earch and select the a file. 

To u arks to select an attachment file: 

1. iewer menu option: 

2. Follow any dialog prompts until the File Open dialog appears. 

incl de: 

à File | Open URL 

à Analysis | Comp

à Analysis | Overlay 

à Analysis | DMU 

à Analysis | Cross Probe 

When you choose one of these menu selections, in order to select the file you want to view or to 
add to the current analysis view, a File Open dialog appears. Th
Open dialog allows you to use your Agile Bookm
File Open dialog allows you to perform a quick s

se your Agile Bookm

Choose an available V
y File | Open URL 
y Analysis | Compare 
y Analysis | Overlay 
y Analysis | DMU 
y Analysis | Cross Probe 
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3. Click the .  

The DMS kmarks in a tree structure. 

n 

Agile Browse button in the File Open dialog to display the DMS: File Open dialog

: File Open dialog displays your Agile Boo

Note If you have not defined any Bookmarks in Agile PLM, the Agile Browse butto
does not appear in the File Open dialog. 

4. Click + to expand a bookmark and display its item revisions or its file folder versions. 

5. 

alog. 

7.  Open dialog. 

ds the selected file to the current 

To perfo rch to select an attachment file: 

1. ewer menu option: 

alog appears. 

3. isplay a Search dialog which allows you 

4. Defi
y 
y 

search behaves like a Contains search for text strings. The search 
ions that 
es for an 

 may use wildcard characters to specify part of an ID number as 

et this parameter to Yes to search the contents of the 

e, click the + next to the object number to expand the list of 

ow to select the file you want to view. 

7. 

ame appears in the File Name field of the File Open dialog. 

8. Click OK in the File Open dialog. 

The Viewer opens the selected file, or, if appropriate, adds the selected file to the current 

Click a revision or version row to highlight the file you want to view. 

6. Click OK in the DMS: File Open di

The selected file name appears in the File Name field  of the File Open dialog. 

Click OK in the File

The Viewer opens the selected file, or, if appropriate, ad
analysis function. 

rm a quick sea

Choose an available Vi
File | Open URL y 

y Analysis | Compare 
y Analysis | Overlay 
y Analysis | DMU 
y Analysis | Cross Probe 

2. Follow any dialog prompts until the File Open di

Click the Agile Search button in the File Open dialog to d
to run a quick search. 

ne your search and click the Search button: 
Class - Select an object class, for example, Items. 
Search Parameter - Enter a text string or a number. 

Agile PLM searches the object ID number attribute and the object Name or Description 
attribute. A Quick 
criteria is treated as a single string and Agile PLM searches for names or descript
contain the search parameter string. In the case of ID numbers, Agile PLM search
exact match, however, you
a search criteria. 

y Search Attachment Content - S
attachment files as well. 

5. In the Search Results tabl
attachment files for that object. 

6. Click a revision row or a version r

Click the Load File button. 

The selected file n
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analysis function. 

Comparing Revisions or Versions of a File 
You can view a file from an item Attachments tab or a file folder Files tab then select, from the Viewer 
window, other item revisions or f
one revision or version, you may sele

ile folder versions of the file to compare against. After comparing 
ct another, comparing multiple revisions or versions of the file 

. 

 appears. 

5. 

Note ompare the 

from within the Viewer window. 

To compare multiple item revisions of an attached file: 

1. On the item Attachments tab, select the file you want to compare. 

2. Choose View from the tab menu. The Viewer opens, displaying the selected file

3. In the Viewer menu, choose Analysis | Compare. The File Open dialog

4. Check the Document Versions checkbox, if it is not already checked. 

Use the drop-down menu to select another revision of the file for comparison. 

Only released item revisions appear in the drop-down list. To c
attachment of a pending revision, view the pending revision file, then use 
Analysis | Compare to select released revisions for comparison. 

6. Click . The Viewer opens the selected version in second window and displays the 
differences between the two files in a third window. 

OK

7. To compare another revision, choose File | Exit Compare Mode in the Viewer menu. 

evision. 

. 

 appears. 

. 

e in the Viewer menu. 

e folder version. 

ocument objects. The "part" file document objects appear on the BOM 
bly document object, thus creating a hierarchical file structure for the attached 

8. Repeat steps 3 through 6 to select another item r

To compare multiple file folder versions of a file: 

1. On the file folder Files tab, select the file you want to compare. 

2. Choose View from the tab menu. The Viewer opens, displaying the selected file

3. In the Viewer menu, choose Analysis | Compare. The File Open dialog

4. Check the Document Versions checkbox, if it is not already checked. 

5. Use the drop-down menu to select another file folder version of the file for comparison

OK6. Click . The Viewer opens the selected version in second window and displays the 
differences between the two files in a third window. 

7. To compare another file version, choose File | Exit Compare Mod
8. Repeat steps 3 through 6 to select another fil
 

Viewing Structured File Types 
CAD data can be stored in Agile PLM using document object BOM structures. This is usually 
accomplished automatically when Agile PLM and EC are integrated using EC CAD connectors. A 
CAD "assembly" file is attached to an Agile document object, and the subordinate CAD "part" files 
are also attached to Agile d
tab of the CAD assem
files. 
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Note Files types that can are used in structured file hierarchy are specified in Agile 
Administrator as Structured Files Types. All other file types are specified as Supported 
File Types.  

When you open an Structured File Type assembly attachment, Agile PLM automatically opens the 
subordinate "part" files in the Viewer also, allowing you to view the entire CAD design. This process
is seamless and requires no action by the user othe

 
r than initiating the view function for the 

The following list provides details about how Agile PLM extracts Structured File Type files from the 
document BO

à 
pes list, Agile PLM does not traverse the document structure to find other 

à 
 the 

à s use of the Attachment 

the Attachment Type 

à  
 will all be extracted and sent to the Viewer.  This includes the document from 

à 

à have configured Agile PLM to use the CAD Revision BOM attribute.  
n 

eantime (that is, standard Agile BOM 

à g, including a pending revision. If the CAD 
g a pending Rev will display any active pending Revs 

ved from CAD. 

port structured file types, including View, Markup, Compare, 

c Markups 
c 2 ect. 

Change order-controlled 2D, 3D, and EDA/ECAD markup can be done from the Redline Attachments 

assembly file. 

M structure for CAD design viewing: 

Agile PLM extracts only Structured File Type files. If an attached file type is specified on the 
Supported File Ty
files. 

If the file type is on the Structure File Type list, then Agile PLM will traverse all levels of the 
document hierarchy, starting with the selected file, and extract other files necessary to build
complete model. 

In order to avoid pulling out unnecessary files, the viewing logic make
Type attribute on the document's Attachments tab.  If there is a value in this attribute (such as 
SOURCE) for the originally selected file attachment, then only files whose Attachment Type 
attribute matches this value will be extracted.  If there is no value in 
attribute, then all files within the structure hierarchy will be extracted. 

If there are multiple file attachments with the matching value of Attachment Type on the same
document, they
which the view operation was initiated. 

If any given document in the hierarchy does not have any file attachments, or any with the 
correct value of Attachment Type, the extraction process does not stop but simply continues 
down the tree. 

The Agile administrator may 
This is a technique, principally used by the standard Agile EC CAD Connectors, to provide a
"As Saved" fixed BOM resolution for CAD designs.  If this is enabled, when you view a past 
revision of a design it will appear exactly as it was saved.  If not, the view may differ slightly if 
child components have been revisioned in the m
resolution logic is followed). 

You may select any document revision for viewin
Revision attribute is enabled, then viewin
within the structure that were sa

à All Agile Viewer operations sup
Cross Probe, Overlay, and Digital Mockup. 

 

Ad Ho
Ad ho D, 3D, and EDA/ECAD markup can be done from the Files tab in the file folder obj

tab in the ECO. When you view a markup file, the original document, also known as the base file, 
opens too. 
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Note Change order-controlled and ad hoc markups are independent from each other. 

To view change order-controlled markups, open the redline
item Attachments tab or from the change order Redline Attach

d file from the appropriate revision of the 
ments tab (see “Viewing ECO Redlines 

from the Attachments Tab of the Item Pending Revision (on page 23)”. 

To view ad hoc markups, open the redlined file from the file folder object  tab. Files

Marking Up — How It Works 

mory and lays them over the original 

layers to organize 
nd each layer 

mon purpose. Markup files are stored with other attachment 
nager (AFM). Markup files are managed by Agile and are 

 or Redlining 
ac

With app
the Files t d EDA files on the Redline Attachments tab, 

Affected Items tab of an ECO.      

te and edit file markups only through the Affected Items tab of an ECO or the 

Marking up refers to drawing and writing in an electronic document. With Agile Viewer, your original 
document remains unchanged because your markups are saved in separate markup files. When 
you view a markup file, Agile Viewer loads the markups into me
document.       

There can be as many markup files as you wish for a document because each has its own unique 
filename. This allows several individuals to mark up the same document at the same time because 
a unique markup file is created for each person’s work. With the markup information attached to 
each markup file, you can even tell who created each markup. 

Markup files are divided into uniquely named layers. Create, name, and color the 
your work as you like. For example, different colors could indicate time priorities, a
could contain markups relating to a com
files in the file vault, part of Agile File Ma
automatically retrieved and presented when you view the redlined document. 

Guidelines for Marking Up
Att hments 

ropriate privileges, you can redline Microsoft Office documents, 2D, 3D, and EDA files on 
ab of a file folder object and redline 2D, 3D, an

accessible from the 

Note You can crea
Files tab of a file folder object. Your Agile administrator must give you 
you to mark up or redline attachments. For more information about EC

privileges that allow 
Os and file folder 

objects, see Getting Started with Agile PLM. 
 

Ja lie
To mark up o

1. If you hav  of an 
unrelease unreleased ECO. 

 

va C nt 
r redline an attachment file from an ECO in the Java Client: 

e not already done so, add an item with an attachment to the Affected Items tab
d ECO. The item now has a pending revision associated with the 

Note When redlining an attachment through an ECO, the pending revision 
attachment Folder Version must be set to a specific version number; if the 
Folder Version is set to LATEST-x, you will not be able to create redline 
markups. However, you can edit the Folder Version on the Attachments ta
the pending revision so that it refers to a specific Folder Version. 

b of 
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�  revision of the item refers to Folder Version LATEST-7 of For example, if the pending
the file folder, select that row on the Attachments tab, click the Edit  button and use 
the Folder Version drop-down list in the Edit dialog box to select 7. Click OK to complete 

f the ECO. 

t the row containing the file you want to redline and click the View button. 

nt to redline. 
2.  the arkups 

are allow

3. Use the tools described in the viewer online Help to redline the attachment. To view online 

ith the pending revision of 

the edit process. You will now be able to create redline markups for that 
attachment.Select the added item on the Affected Items tab o

 On the Redline Attachments tab: 
� Selec
Or 
� Double-click the row containing the file you wa

When  Viewer appears, click the Markup button. (This button is available only when m
ed.) 

Help, choose Help > Content in the menu bar. 

Note ECO markups are saved against and associated w
the item. If the ECO is released without first replacing the file, the markups 
appear against the released revision of the item 

To ad hoc mark up or redline an attachment file from a file folder object in the Java Client

Double-click the row containing the file you wa

: 

1. nt to redline. 

2.  the arkups 
are allow

bed in the viewer online Help to redline the attachment. To view online 
 in the menu bar. 

 

When  Viewer appears, click the Markup button. (This button is available only when m
ed.) 

3. Use the tools descri
Help, choose Help > Content

Note Ad hoc markups are saved against and associated with the version of the file 
folder object. 

 

Web Client 

Note If the item or file has already been redlined, then the Has been redlined icon  will be 
displayed in the place of the Do Redlining icon . Click either   or  to initiate 

ining. redl

To mark up o

1. If you hav ted Items tab of an 
eased E

Note 

r redline an attachment file from an ECO in the Web Client: 

e not already done so, add an item with an attachment to the Affec
unrel CO. The item now has a pending revision associated with the unreleased ECO. 

When redlining an attachment through an ECO, the pending revision 
attachment Folder Version must be set to a specific version number; if the 
Folder Version is set to LATEST-x, you will not be able to create redline 
markups. However, you can edit the Folder Version on the Attachments tab of 
the pending revision so that it refers to a specific Folder Version. 
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� For example, if the pending revision of the item refers to Folder Version LATEST-7 o
the file folder, select that row on the

f 
 Attachments tab, click the Edit button and use the 

You 
tems 

2. On the Redline Attachments tab, click the Do Redlining button 

Folder Version drop-down list to select 7. Click Save to complete the edit process. 
will now be able to create redline markups for that attachment.On the Affected I
tab, click the Do Redlining icon for that item to open the Redlines page. 

  (or Has been redlined button ) 

3. On

on the row of the file you want to redline. (This button is available only when markups are 
allowed. 

 the Affected Items tab, click the Do Redlining icon next to the item to open the Redlines 
page. 

4. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

Note ECO markups are saved against and associated with the pending revision of 
the item. If the ECO is released without first replacing the file, the markups 
appear against the released revision of the item 

To ad hoc mark up or redline an attachment file from a File Folder object in the Web Client: 

1. On the Files tab of a file folder object, click the Do Redlining button  (or Has been redlined button 
) on the row of the file you want to redline. (This button is available only when markups are 

allowed.) 

2. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

Ad hoc markups are saved against and associated with the version of the file Note 
folder object. 

 

Redlining Markups for Change Orders 

 
ion item  tab. 

s ense, which provides access to Advanced Viewer 

 

ab of the Item Pending 

 the 
(C) ECO000453. The redlined file is 

The change order redlines of 2D, 3D, and EDA files are based on the pending revision of the item. 
The markup changes are visible from either the change orders’s Redline Attachments tab or from the
pending revis Attachments

Important 3D features and access to 3D files are available only with Agile Advanced Viewer. 
Features for schematic and PCB files, also referred to as EDA files, are available only with 
the Agile Advanced Viewer. In order to use these features, your company must have the 
View and Mark Up (3D) erver lic
functions. For more information about server licenses, see the Administrator Guide. 
Contact your Agile Account Executive or reseller to obtain a license. 

 

Viewing ECO Redlines from the Attachments T
Revision 

You can view the change order markup redlines of the pending revision by displaying
Attachments tab of the item pending revision, for example, revision 
indicated by the Has been redlined  icon. 

In Java Cà lient, select the redlined file you want to view and click the View File(s)  button. 
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à In Web Client, click the Has been redlined  button in the row of the file you want to view. 

he 
Has chments table. 

v

1. On  tab of the pending revision, select the row you want to view. 

2. Click the 

If you have checked out the redlined file and checked in a new version from the Attachments tab, t
been redlined icon does not appear on the Atta

To iew the redlines of previous versions in Java Client: 

the Attachments
Show Versions button. The Versions dialog appears. 

3. On the version row for which you want to view redlines, double-click the Has been redlined  

1. On the Attachments tab of the pending revision, click the Show Versions button in the row you 
want to view. The Versions dialog appears. 

2. On the version row for which you want to view redlines, double-click the Has been redlined 

button. 

To view the redlines of previous versions in Web Client: 

 
button. 

Note If you need to determine which file folder version is associated with the change 
order redlines, refer to the change order History tab. 

However, if the attachment file on the pending revision item is not replaced prior to the change 
order release, the redlines will be accessible from the released revision of the item. The following 
diagram shows an example of the change order attachment redlining process.  
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See also Product Collaboration User Guide and Getting Started with Agile PLM User Guide. 
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Marking Up Documents 
For information about working with markups, including markup layers and markup objects, refer to 
the viewer online help. Choose Help > Contents in the Agile Viewer menu bar. 

Tips for Marking Up Documents 
If you exit the Agile viewer without saving, you will lose any redline you have added to the 
attachment. 

Attaching Information to Markup Files 

In Markup mode, the Markup > Information command displays the Markup Information dialog box with 
five information fields attached to the current active markup file.    

Entity Rotate 

Entity Rotate allows you to rotate symbol markup objects. 

To rotate a symbol markup object: 

1. Select the symbol markup object you want. 

2. Click the Rotate Entity button, or choose Markup > Entity Rotate. 

When this feature is activated, the Rotate Entity button appears as a recessed button (light gray) 
on the toolbar. 

3. Place the cursor on one of the corner squares that indicate the selected object. 

4. When you see the crossed-arrows cursor (pointing in four directions), hold down the left mouse 
button and adjust the rotation angle of the object. 

5. Release the mouse button when you are finished adjusting the rotation angle. 

 
 

2D Features and Functions 
For information about working with 2D files, including CAD views and measuring objects, refer to 
the viewer online help. Choose Help > Contents in the Agile Viewer menu bar. 

EDA Features and Functions 
Agile Advanced Viewer EDA features include: 

à Ability to view all relevant EDA formats including artwork formats, PCB/IC layouts, schematics 
and manufacturing formats 

à Cross probe between a PCB layout and related schematics (see “Cross Probing (on page 29)”). 

à Verify design by testing for manufacturability or design violation. 
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à Generate and export Bills of Material in a variety of formats. 

For detailed information about all the EDA features, refer to the viewer online help. Choose 
Help > Contents in the Viewer menu bar. 

Important EDA features and access to EDA files are available only with Agile Advanced Viewer. In 
order to use these features, your company must have the View and Mark Up (3D) server 
license, which provides access to Advanced Viewer functions. For more information about 
server licenses, see the Administrator Guide. Contact your Agile Account Executive or 
reseller to obtain a license. 

 
 

3D Features and Functions 
For information about working with 3D files, including light settings and models, refer to the viewer 
online help. Choose Help > Contents in the Viewer menu bar. 

Important 3D features and access to 3D files are available only with Agile Advanced Viewer. In order 
to use these features, your company must have the View and Mark Up (3D) server 
license, which provides access to Advanced Viewer functions. For more information about 
server licenses, see the Administrator Guide. Contact your Agile Account Executive or 
reseller to obtain a license. 

 
 

Understanding 3D Basics 
3D CAD assemblies are made up of many files dependent one upon another. For example, a 
SolidWorks or Pro/E CAD design consists of at least one assembly file and one or more part files. 
The 3D files are used primarily in manufacturing departments for drawing the blueprint of the new 
instrument. 3D files may be added to the Files tab in one or several file folder objects.  

à One File Folder 

Add all files in one CAD assembly are added to the Files tab of one file folder. When you view 
the assembly, Agile prompts you to identify the top file in the assembly and the complete 
assembly is displayed in the Viewer. 

à Multiple File Folders 

The assembly file is added to the Files tab in one file folder object, and parts files can be 
referenced by adding other file folder objects containing the files as relationships with no rules 
to the Relationships tab of the assembly’s file folder object.  

3D files can be redlined both through a change order (Redline Attachments) and on the Files tab of 
the file folder object. 

Viewing 3D CAD Assemblies in a Multiple-file File Folder from Java 
Client 

To view a CAD assembly from Java Client, Attachments tab: 

1. Go to the Attachment tab of the business object that references the assembly. 
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2. Double-click the multiple-file attachment row that references the CAD assembly. The Select 
Files window appears. 

Note A multiple-file attachment row is indicated by a file folder icon in the Filename 
field, followed by the filenames of all the files in the file folder. 

Or use the Attachment tab View File(s) button: 
a. On the business object Attachments tab, click to select the multiple-file attachment row. 
b. Click the View File(s) button's  drop-down arrow and select View from the menu. 

3. In the Select Files window, click the radio button to select the option View all files as an assembly, 
starting from the selected file. 

4. Click to select the file row of the assembly file that indicates the top or starting file of the 
assembly. 

5. Click OK. 

To view a CAD assembly from Java Client, Files tab: 

1. Go to the Files tab of a file folder object containing the CAD files for the assembly that you want 
to view. 

2. Click to select the row for the top or starting file of the assembly. 

3. Click the View File(s) button's  drop-down arrow and select View As Assembly from the menu. 

 
 

Viewing 3D CAD Assemblies in a Multiple-file File Folder from Web 
Client 

To view a CAD assembly from Web Client, Attachments tab: 

1. Go to the Attachment tab of the business object that references the assembly. 

2. Click the multiple-file attachment row that references the CAD assembly. The Select Files 
window appears. 

Note A multiple-file attachment row is indicated by a file folder icon in the Filename 
field, followed by the filenames of all the files in the file folder. 

Or use the Attachment tab View File(s) button: 
a. On the business object Attachments tab, click to select the multiple-file attachment row. 
b. Click the View File(s) button's  drop-down arrow and select View from the menu. 

3. In the Select Files window, click the radio button to select the option View all files as an assembly, 
starting from the selected file. 

4. Click to select the file row of the assembly file that indicates the top or starting file of the 
assembly. 

5. Click Finish. 

To view a CAD assembly from Web Client, Files tab: 

1. Go to the Files tab of a file folder object containing the CAD files for the assembly that you want 
to view. 
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2. Click to select the row for the top or starting file of the assembly. 

3. Click the View File(s) button's  drop-down arrow and select View As Assembly from the menu. 
 

Cross Probing 
Cross probing is also described in the viewer online Help. In Agile, this feature is initiated from 
either the business object Attachments tab or the file folder Files tab rather than from the viewer 
menus. For detailed information about cross probing features, see the Viewer online help. Choose 
Help  > Contents in the viewer menu bar. 

Important Cross probing features are available only with Agile Advanced Viewer. In order to use 
these features, your company must have the View and Mark Up (3D) server license, 
which provides access to Advanced Viewer functions. For more information about server 
licenses, see the Administrator Guide. Contact your Agile Account Executive or reseller to 
obtain a license. 

Use cross probing to interrogate ECAD schematic and layout files in separate viewer windows. 

Note The Agile administrator should specify the ECAD file extension in the Valid Model File Type 
field for you to view the ECAD files. 

You can select both needed files from the same Attachments tab or the same file folder Files tab from 
which you launch the Cross Probe action. Or, you can select one file on the current tab and then 
search for the remaining file from the attachments of any other object. 

The View > By Search > Crossprobe option allows you to find other files in the system, which you may 
want to use to cross probe, without having to select two files from the same Attachments tab or Files 
tab; that is, you can search and select one attached file from Part 234 and another attached file 
from Part 765. 

Alternatively, you can view a single ECAD file then initiate cross probing within the viewer by adding 
another file from your desktop. 

To run Cross Probing: 

1. Display the Attachments tab or the Files tab. 

2. Select both file rows you want to work with and choose:  
y Java Client: View File(s)  > Cross Probe. 
y Web Client: View > Cross Probe. 

Each file is displayed in a separate viewer window. 

3. Begin cross probing. 

See Viewer online help for more information about cross probing. Choose Help > Contents in the 
Viewer menu bar. 

 

Cross Probing in Java Client and Web Client 
To run Cross Probing: 

1. Display the Attachments tab or the Files tab. 
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2. and choose:  
Probe. 

in a separate viewer window. 

3. 

See Viewer online help for more information about cross probing. Choose Help > Contents in the 

2. e
y 

bs. 
y 

3.  any business object (for example, items or 
ents of those objects to use to Cross Probe. 

Use

y ens to your navigation pane where you can browse in search folders, 
tems 

y  you can select objects from My 
 

s appear in the search results table. For example, a 

he related 

5. e, select and move attachments to the Selected Files table. 

earches or shortcuts until you are finished selecting the 

d, click OK. 

8. . 

See Viewer online help for more information about cross probing. Choose Help > Contents in the 

Select both file rows you want to work with 
y Java Client:  View File(s)  > Cross 
y Web Client: View > Cross Probe. 

Each file is displayed 

Begin cross probing. 

Viewer menu bar. 

To run Cross Probing By Search: 

1. Display the Attachments tab or the Files tab. 

Sel ct a file row you want to work with and choose:  
Java Client: View File(s) > By Search > Cross Probe. 

The Select Files dialog appears, with three Search ta
Web Client:  View  > By Search > Cross Probe. 

The View Files by Search dialog appears, with three Search tabs. 

The search dialog allows you to search for
manufacturer parts) and select the attachm

 any of the following search methods: 
y Search tab lets you create a simple search or an advanced search. You can check to 

search attachment contents, too. 
Saved Searches tab op
select a search, and run it. Again, returned results may be moved to the Selected I
table, and click OK. 
Shortcuts tab opens to your navigation pane where
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that are
appropriate to the operation you are performing. 

Only business objects with attached file
business object that you viewed recently will not appear on the Recently Visited list of the 
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the Results table, and t
files for that object appear in the Related Files table. 

In the Related Files tabl

6. You can continue to run multiple s
attachments you want. 

7.  When you are finishe

Each file is displayed in a separate viewer window. 

Begin cross probing

Viewer menu bar. 
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Comparing Files 
Comparing files is also described in the viewer online Help. In Agile, rather than initiating file 
compare from the viewer menus, you initiate file compare from either the file folder Files tab or the 

For detail lp > 
Contents

Important res are available only with Agile Advanced Viewer. In order to use 
these features, your company must have the View and Mark Up (3D) server license, 
which provides access to Advanced Viewer functions. For more information about server 
licenses, see the Administrator Guide. Contact your Agile Account Executive or reseller to 

lient and Web Client 
gle file folder Files tab or a single business object 

To i

1.  Files tab. 

2. 

eb Client: View > Compare 

isplayed in a single viewer window. 

res and options, choose Help > Contents in the viewer 

à sed revisions of an item . 

à 

à n search 
file t

Dependin business object, then select a file from the list of 
related files for that object. Or, if you have the appropriate privileges, you can search for file 

he list of related files for the selected file folder. 

business object Attachments tab. 

ed information about file comparison features, see the Viewer online help. Choose He
 in the viewer Menu bar. 

Compare file featu

obtain a license. 

 
 

Markups and Comparing Files 
Markups (redlines) are not supported in the Agile viewer compare mode. 

Comparing Files in Java C
You can select and compare two files from a sin
Attachments tab. 

nitiate comparing files: 

Display the Attachments tab or the

Select both files you want to work with and choose: 
y Java Client: View File(s) > Compare 
y W

The files and the comparison results are d

For more information about compare file featu
menu bar. 
 

Comparing Files By Search 
The View > By Search > Compare command allows you to 

Compare files from different relea

Compare files from different file folder versions. 

Select any file on any business object  Attachments tab or on any file folder Files tab, the
for a o use for comparison.  

g on your search, you can select a 

folder objects, then select a file from t
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Note For item objects, Introductory revisions and unreleased pending revisions do 
not appear in the related files list.  

To initiate comparing files b

1. 

mpare 

The ppears with three search tabs. 

3. 
man

y 

s, 
s 

Shor
4. Whe

files

5. In the Related
y If the sele r, use the Version drop-down list in the Related 

y 
 revision of the item (the file name followed by the revision 
widget.dwg - A and widget.dwg - B). 

 not 

y Search : 

Display the Attachments tab or Files tab. 

2. Select a file row you want to work with and choose: 
y Java Client: View File(s) > By Search > Co
y Web Client: View > By Search > Compare 

 Compare Files By Search dialog a

The search dialog allows you to search for any business object (for example items or 
ufacturer parts) and select the attachments of those objects to compare.  

Use any of the following search methods: 
Search tab lets you create a simple search or an advanced search. You can check to 
search attachment contents, too. 

y Saved Searches tab opens to your navigation pane where you can browse in search folder
select a search, and run it. Again, returned results may be moved to the Selected Item
table, and Click OK. 

y Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that are 
appropriate to the operation you are performing. 

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appear on the Recently Visited list of the 

tcuts tab if it has no attachments. 

n the results of your search are returned, select a row in the results table, and the related 
 for that object appear in the Related Files table. 

 Files table, select the file you want. 
cted search object is a file folde

Files table to select the file folder version you want. 
If the selected search object is an item, in the Related Files table displays item 
attachments for each released
number or letter, for example, 

Note For item objects, Introductory revisions and unreleased pending revisions do
appear in the related files list.  

y If the selected search object is a business object, check the Show Matching File Ty
checkbox to display only the related files that are the same file type as the file you with 
which you want to compare.  

pes Only 

. 

le searches or shortcuts until you are finished selecting the 
attachments you want. 

r menu bar.  

6.  When you are finished, Click OK
You can continue to run multip

The files and the comparison results are displayed in a single viewer window. Fore more 
information about compare file features and options, choose Help > Content in the viewe
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Over
Overlayin ribed in the viewer online Help. In Agile, this feature is initiated from the 
file folder Files tab rather than from the viewer menus. For detailed information about file overlay 

atures, see the Viewer online help. Choose Help  > Contents in the viewer menu bar. 

ewer. In order to use 
D) server license, 

which provides access to Advanced Viewer functions. For more information about server 
ministrator Guide. Contact your Agile Account Executive or reseller to 

 

Overlaying Files in Java Client and Web Client 
To i

1. b. 

k with and choose 

 one on top of the other. For more information 
about overl ar) and options, choose 
Help

To initiate ov

2. 
erlay. 

y rlay. 

3. The  you to search for any business object (for example, items or 

Use

rs, 
ed results may be moved to the Selected Items 

e you can select objects from My 
 that are 

ith attached files appear in the search results table. For example, a 
business object that you viewed recently will not appear on the Recently Visited list of the 

laying Files 
g files is also desc

fe

Important Overlaying files features are available only with Agile Advanced Vi
these features, your company must have the View and Mark Up (3

licenses, see the Ad
obtain a license. 

 

nitiate overlaying files: 

Display the Attachments tab or the Files ta

2. Select both file rows you want to wor
y Java Client:  View File(s)  > Overlay . 
y Web Client: View > Overlay. 

The files are displayed in a single viewer window,
ay file features (for example, File > Overlays in the menu b

  > Contents in the viewer menu bar. 

erlaying files By Search: 

1. Display the Attachments tab or the Files tab. 

Select a file row you want to work with and choose: 
y Java Client: View File(s) > By Search > Ov

The Select Files dialog appears, with three Search tabs. 
Web Client:  View  > By Search > Ove
The View Files by Search dialog appears, with three Search tabs. 

 search dialog allows
manufacturer parts) and select the attachments of those objects to use to overlay.  

 any of the following search methods: 
y Search tab lets you create a simple search or an advanced search. You can check to 

search attachment contents, too. 
y Saved Searches tab opens to your navigation pane where you can browse in search folde

select a search, and run it. Again, return
table, and click OK. 

y Shortcuts tab opens to your navigation pane wher
Bookmarks or Recently Visited. The system displays shortcuts to only those objects
appropriate to the operation you are performing. 

Only business objects w
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Shortcuts tab if it has no attachments. 

4. 

5. hments to the Selected Files table. 

electing the 

abou
choo

 

r schematic and PCB files, also referred to as EDA files, are available only with 
ese features, your company must have the 

ich provides access to Advanced Viewer 
ver licenses, see the Administrator Guide. 

Real
For detail boration features, refer to the viewer online help. Choose 
Help > Contents in the Viewer menu bar. The following sections discuss Agile View server information 

nd Agile privileges that affect collaboration sessions. 

 with Agile Advanced Viewer. In order to 
View and Mark Up (3D) server license, 

r 

back and
and the a
default ro

From the on menu, anyone with the required Agile privileges can initiate a Collaboration 
session and act as host, or join a Collaboration session if invited by the host. 

When the results of your search are returned, select a row in the Results table, and the related 
files for that object appear in the Related Files table. 

In the Related Files table, select and move attac

6. You can continue to run multiple searches or shortcuts until you are finished s
attachments you want. 

7.  When you are finished, click OK. 

The files are displayed in a single viewer window, one on top of the other. For more information 
t overlay file features (for example, Analysis > Overlays in the menu bar) and options, 
se Help  > Contents in the viewer menu bar. 

Working with Schematic and PCB Files 
Important Features fo

the Agile Advanced Viewer.In order to use th
View and Mark Up (3D) server license, wh
functions. For more information about ser
Contact your Agile Account Executive or reseller to obtain a license. 

For information about these features, refer to the viewer online help. Choose Help > Contents in the 
Viewer menu bar. 

-Time Collaboration 
ed information about colla

a

Important Real-time collaboration features are available only
use these features, your company must have the 
which provides access to Advanced Viewer functions. For more information about serve
licenses, see the Administrator Guide. Contact your Agile Account Executive or reseller to 
obtain a license. 

 
 

Overview of Collaboration Sessions 
The Collaboration feature lets multiple users team up and review documents interactively and 
simultaneously, thus shortening an otherwise lengthy review process where documents are passed 

 forth. The Collaboration feature is available to all users who have Agile Discovery, Read, 
ppropriate privileges that allow you to redline attachment files (for example, the Agile 
le Markup for Self). 

Collaborati

Important If you plan to host a Collaboration session, ensure that all intended participants have 
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Discovery, Read, and the appropriate privileges that allow them to redline attachment files 
(for example, the Agile default role Markup for Self). If they can view and redline a file, 
they have the necessary privileges. If they cannot, contact your Agile administrator, who 

 view the 
 

 of the Collaboration session. Session information is available from the 
boration
ned

session ID), the name of the base file viewed, the host, and the list of users participating. 

during the Collaboration session to which all participants can add 
 assigned different layer colors for the session so that the markup 

e collaboration feature. 

can grant them the necessary privileges, before you attempt to initiate the Collaboration 
session. 

In order to participate in the collaboration session, all the collaborators must be logged into Agile 
and viewing a file in the viewer when you start the collaboration session. They do not need
file you are going to review in the collaboration session; they can view any file. For this reason, they
may choose to view a small file that will load quickly. 

When the host initiates a Collaboration session, a session object is created on the server, which is 
maintained for the duration
Colla  menu during a Collaboration session. It displays the session subject (the name 
assig  to the Collaboration session), the session ID (each session subject is assigned a unique 

A session markup file is created 
markup entities. Participants are
entity from each participant is identifiable. The host for the session owns the markup file and is the 
only one who can save it. 

Note All users must connect to the same Agile Viewer server to use th
 

Digital Mockup 
In 3D mode, you can use the Mockup feature (DMU) to test alig
assemblies. You can save the mockup as a redline markup entity. 

nment and interference of multiple 

 

Dig t and Web Client 

1. 

2. e file rows you want to work with and choose: 

t:  View  > Digital Mockup. 

e Viewer workspace. 

tures including the features in the Analysis menu, for 
 Interference Checking, and Part 

For  the viewer online help. Choose Help > Contents in the 
View

1. 

2. rk with and choose: 

ital Mockup in Java Clien
To initiate Digital Mockup of files: 

Display the Attachments tab or the Files tab. 

Select all th
y Java Client: View File(s) > Digital Mockup. 
y Web Clien

The files are loaded into the sam

3. Manipulate the models using the viewer fea
example User Defined Coordinate Systems, Manipulators,
Alignment. 

information about these features, refer to
er menu bar. 

To initiate Digital Mockup of files: 

Display the Attachments tab or the Files tab. 

Select all the file rows you want to wo
y Java Client: View File(s) > Digital Mockup. 
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y Web Client:  View  > Digital Mockup. 

rkspace. 

tures including the features in the Analysis menu, for 
ators, Interference Checking, and Part 

For informati lp. Choose Help > Contents in the 
Viewer m

To initiate Di

2. 
ital Mockup. 

y ital Mockup. 

3. The  you to search for any business object (for example, items or 
  

Use

rs, 
ed results may be moved to the Selected Items 

e you can select objects from My 
 that are 

ith attached files appear in the search results table. For example, a 
cently will not appear on the Recently Visited list of the 
nts. 

4. row in the Results table, and the related 

5. 

6. 

.  When you are finished, click OK. 

The files are loaded into the same Viewer workspace. 

8. Manipulate the models using the viewer features including the features in the Analysis menu, for 
example User Defined Coordinate Systems, Manipulators, Interference Checking, and Part 
Alignment. 

For information about these features, refer to the viewer online help. Choose Help > Contents in 
the Viewer menu bar. 

 

The files are loaded into the same Viewer wo

3. Manipulate the models using the viewer fea
example User Defined Coordinate Systems, Manipul
Alignment. 

on about these features, refer to the viewer online he
enu bar. 

gital Mockup of files By Search: 

1. Display the Attachments tab or the Files tab. 

Select a file row you want to work with and choose: 
y Java Client: View File(s) > By Search > Dig

The Select Files dialog appears, with three Search tabs. 
Web Client:  View  > By Search > Dig
The View Files by Search dialog appears, with three Search tabs. 

 search dialog allows
manufacturer parts) and select the attachments of those objects to use for the mockup.

 any of the following search methods: 
y Search tab lets you create a simple search or an advanced search. You can check to 

search attachment contents, too. 
y Saved Searches tab opens to your navigation pane where you can browse in search folde

select a search, and run it. Again, return
table, and click OK. 

y Shortcuts tab opens to your navigation pane wher
Bookmarks or Recently Visited. The system displays shortcuts to only those objects
appropriate to the operation you are performing. 

Only business objects w
business object that you viewed re
Shortcuts tab if it has no attachme

When the results of your search are returned, select a 
files for that object appear in the Related Files table. 

In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run multiple searches or shortcuts until you are finished selecting the 
attachments you want. 

7
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Modified and Unavailable Viewer 
Features 

This chapter includes the following: 

� User Interface Modifications ................................................................................................................................ 37 
� File Storage and Management Modifications ...................................................................................................... 37 
� Opening Files Features ....................................................................................................................................... 38 
� Working with Hyperlinks ...................................................................................................................................... 38 
� Viewer Modes ...................................................................................................................................................... 38 

 
 

User Interface Modifications 
The following features described in the viewer online Help have been modified or have been 
suppressed and are not available. 

à Window menu and its options for viewing multiple files (New, Cascade, Tile Horizontally, and Tile 
Vertically) are not available. (See “Viewing Multiple Files in the Agile Viewer”.)  

à The ability to click and drag toolbars to move them is not available.  

à Mnemonic letter shortcuts (ALT+letter) are not available and are not displayed as underlined 
letters in the menus.  

à Tooltips Quick Menu is not available.  

à The Customize > Options menu selection does not include toolbar and tooltip settings.  
 

File Storage and Management Modifications 
Because the Agile system manages and controls access to attached files and markups (redline 
files), the following features described in the viewer online Help may have been modified or are not 
available to you. 

Many of these modifications relate to how files are opened, saved, and where they are stored. 
Instead of using viewer features (for example, File > Open, as described in the viewer online Help) to 
view files, the files are selected via the Agile object Attachments tab and the file folder Files tab, and 
retrieved from the file vault, part of Agile File Manager (AFM). The files are then displayed in the 
viewer window. When you create and save markup files, they are also saved in the file vault. (See 
“Opening Agile Attachment Files in the Viewer (on page 15)”  and “Guidelines for Marking Up or 
Redlining Attachments (on page 21)”.) 

If you need more information about a viewer feature, see the viewer online Help. To view online 
Help, choose Help > Content in the menu bar. 
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Opening Files Features 
These features described in the viewer online Help are not available: 

à Viewer Startup view (empty viewer window).   

à Drag and drop files from Windows Explorer onto the viewer window to open them.  

à The following viewer File menu selections are not available in the Agile Advanced Viewer: Open, 
Browse, Next File, Previous File, Load File, Open URL, and Close. 

à Archive file directory displayed in viewer window. 

à Import and Export Markup files feature is not available. Import and Export 3D Models is not 
available. 

Access to all files, including markup files, is managed by the Agile system. For more 
information about markup files in Agile, see “Marking Up — How It Works (on page 21)” and 
“Guidelines for Marking Up or Redlining Attachments (on page 21)”.  

Working with Hyperlinks 
Refer to the Agile Viewer online help for details about working with and creating hyperlinks. To view 
the online help, choose Help  > Contents in the viewer menu bar. 

Although you can create hyperlink markup entities, you cannot create hyperlinks to other files in the 
Agile file vault. 

The purpose of this viewer feature is to gather or link related information together. This functionality 
is provided by Agile features such as Attachments tabs (which may have multiple attached file folder 
objects) and Relationships tabs. For more information about file folder objects and attachments see 
Getting Started in Agile PLM. 

Viewer Modes 
The viewer modes Startup View and Thumbnails Mode described in the online Help are not 
available. 
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Chapter 4 

Printing 
This chapter includes the following: 

� Printing Documents from within the Viewer ......................................................................................................... 39 
� Headers/Footers Group in Print Properties ......................................................................................................... 39 
� Watermarks and Banners in Print Properties ...................................................................................................... 40 
� Stamps Group In Print Properties........................................................................................................................ 40 
� Printing DGN Files ............................................................................................................................................... 41 

 
 

Printing Documents from within the Viewer 
For detailed information about printing attachments from the file folder object Files tab, see the 
Getting Started with Agile PLM manual, Chapter 9, “Working with Attachments", and Chapter 10, 
"Working with File folders.” 

For detailed information about printing from the viewer, see the viewer online Help. To view online 
Help, choose Help > Content in the viewer menu bar. 

For information about how the Agile administrator can customize the Viewer print options. see 
“Viewer Administration Tasks (on page 43).” 

The following sections describe print features that have been modified to integrate the viewer with 
the Agile system. 

Headers/Footers Group in Print Properties 
This group defines the headers and footers to be included on every printed page of the document.           

Note These settings are maintained and modified by your Agile administrator. 

To view the header and footer settings: 

Select the Headers/Footers tab. 

A literal percentage mark is indicated by %%. Other codes are as follows: 

à %f = full path of document (for example, D:\PICS\TIFF\CTROK.TIF) 

à %v = document drive 

à %d = document directory (for example, D:\PICS\TIFF) 

à %b = document base name (for example, CTROK) 

à %e = document file extension (for example, TIF) 

à %n = total number document pages 
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à %p = current page number 

à %N = total number of tiled pages 

à %P = current tile number 

à %r = newline 

à %F = Excel native print settings 

à %Y = date: year 

à 

f week 

à %S = time: second 

Watermarks and Banners in Print Properties 
des a Watermark tab. This tab cannot be modified in the Agile 

r 
and watermarks. 

 BMP) will not show the watermark. It will show only on “transparent” file 
AD). 

Note 

%M = date: month 

à %D = date: day 

à %W = date: day o

à %H = time: hour 

à %U = time: minute 

 

The Print Properties dialog box inclu
Viewer Print Properties dialog box. 

Watermark and Banner settings are defined and maintained in Agile Administrator. The Agile 
Administrator watermark and banner settings determine whether banners and watermarks appea
on printouts of files attached to Agile objects and the content of those banners 
These banners and watermarks appear on files printed with the Agile Viewer. 

Watermarks on attachments are inserted under the file. Therefore, file types that are in “solid” 
formats (for example, PDF,
types (for example, C

Watermarks 
A faint and transparent watermark appears on the current document’s contents. 

For high resolution black and white printing, the transparent watermark is printed on the 
current document’s contents. For low resolution black and white printing, the watermark is 
printed on the current document’s contents, but it is not transparent. 

The watermark settings are maintained and modified by your Agile administrator; see the 
Administrator Guide. For more information, see “Viewer Administration Tasks (on page 43).” 

Stamps Group In Print Properties 
Note This feature is not available in this implementation of Agile Viewer. 
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Printing DGN Files 
Agile Viewer can be configured to print files with a DGN extension in the same manner as 
MicroStation. This option must be configured on the server side; please contact your Agile system 
administrator for assistance.           
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Chapter 5 

Viewer Administration Tasks 
This chapter includes the following: 

� Setting the Print Options...................................................................................................................................... 43 
� Adding Fonts........................................................................................................................................................ 45 
� Viewing Excel Files.............................................................................................................................................. 45 

Note For information about Agile PLM Administrator settings related to the Agile Viewer (for 
example, Supported File and Valid Model File Type settings), see Administrator Guide, “Viewer 
and Files” section of the “General System Settings” chapter. 

For more information about the Agile View Server, including where to find additional Agile View 
Server documentation, see the appropriate Agile installation guide for your Agile PLM system; refer 
the chapter about configuring the Agile View Server. 
 

Setting the Print Options 
Some file formats require configuring specific settings to print properly. In general, you can change 
these settings for all users or for individual users: 

à To change the print settings for all users, you need to modify some of the parameters in the 
AVS\bin\allusers.ini file. 

à To change the print settings for individual users, you need to modify some of the parameters in 
each user's .ini file under AVS\bin\profiles. 

Caution When you modify options in the allusers.ini file, the existing user profiles are not 
automatically modified. Because editing every individual user profile is impractical, in the 
procedures below you are instructed to delete the existing user profiles when you modify 
allusers.ini. The next time a user opens the Agile Viewer, a new user profile is created 
which includes the new allusers.ini options settings. You may want to notify your users in 
advance to let them know that their user profiles will be reset. 

To change the way that the watermark, border, and header (banner) appear when printed, you will 
need to modify the following .ini file parameters: 

à [OPTIONS] – HPBACKGROUND, KEEPORIGINALCOLORS, and 
SWSHOWVIEWPORTBORDER 

à [PRINTWATERMARK] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE 

à [PRINTHEADERS] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE 

The following sections describe the procedures for printing watermarks and borders, and for 
modifying the headers and watermarks. 
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Printing Watermarks in .hpg and .plt Files 
To print watermarks correctly in .hpg and .plt files, you must set the background color correctly. 

Note If the watermark image or the color used in the watermark image is not transparent, the 
watermark will not be visible. 

To set the background color: 

1. Shut down the JVue server. 

2. On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini) 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, add or update the following two lines: 

HPBACKGROUND = 0
KEEPORIGINALCOLORS = 1

Printing Viewport Borders in SolidWorks Files 
To print viewport borders correctly in SolidWorks files, you must enable the viewing/printing of 
viewport borders. 

To enable the option: 

1. Shut down the JVue server. 

2. On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, add or update the following line: 

SWSHOWVIEWPORTBORDER = 1

Modifying the Header and Watermark Font Settings 
Note The watermark may be truncated if the font size is too large or if there are too many 

characters in the watermark text. Truncation ensures that the watermark does not distort 
the image. 

To set the watermark font size: 

1. Shut down the JVue server. 

2. On the drive where the Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [PRINTHEADERS] section and in the [PRINTWATERMAK] section, update the lines for 
Fontname, Fontsize, Orientation, and Fontstyle. For example: 
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FONTNAME = Serif
FONTSIZE = 24
ORIENTATION = 1
FONTSTYLE = 2

Note ORIENTATION can be specified as 1 (portrait) or 2 (landscape). 
 

Adding Fonts 
To ensure that specific fonts are recognized by the Agile Viewer, you can add the font path to the 
allusers.ini configuration file. 

To add fonts: 

1. Shut down the JVue server. 

2. On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, update the following line: 

XFONTPATHS = {paths}
6. Add the full paths of the font files to the line. Separate the paths with a semicolon. 

7. Save the allusers.ini file. 

8. Clear your web browser’s cache. 

9. Restart the JVue server. 
 

Viewing Excel Files 
When viewing Excel files in the Agile Viewer, all pages may not be displayed. View the file in its 
native application to verify the correct number of pages in the file. 
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