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Preface 
The Oracle|Agile documentation set includes Adobe® Acrobat™ PDF files. The Oracle Technology 
Network (OTN) Web site (http://www.oracle.com/technology/documentation/agile.html) contains the 
latest versions of the Oracle|Agile PLM PDF files. You can view or download these manuals from 
the Web site, or you can ask your Agile administrator if there is an Oracle|Agile Documentation 
folder available on your network from which you can access the Oracle|Agile documentation (PDF) 
files. 

Note To read the PDF files, you must use the free Adobe Acrobat Reader™ version 7.0 or later. 
This program can be downloaded from the Adobe Web site (http://www.adobe.com). 

The Oracle Technology Network (OTN) Web site 
(http://www.oracle.com/technology/documentation/agile.html) can be accessed through Help > 
Manuals in both the Agile Web Client and the Agile Java Client. If you need additional assistance or 
information, please contact support (http://www.oracle.com/agile/support.html) 
(http://www.oracle.com/agile/support.html) for assistance. 

Note Before calling Agile Support about a problem with an Oracle|Agile PLM manual, please 
have ready the full part number, which is located on the title page. 

TTY Access to Oracle Support Services 

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479. 

Documentation Accessibility  

Our goal is to make Oracle products, services, and supporting documentation accessible, with good 
usability, to the disabled community. To that end, our documentation includes features that make 
information available to users of assistive technology. This documentation is available in HTML 
format, and contains markup to facilitate access by the disabled community. Accessibility standards 
will continue to evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be accessible to 
all of our customers. For more information, visit the Oracle Accessibility Program Web site at 
http://www.oracle.com/accessibility/ http://www.oracle.com/accessibility/.  

Readme 

Any last-minute information about Oracle|Agile PLM can be found in the Readme file on the Oracle 
Technology Network (OTN) Web site (http://www.oracle.com/technology/documentation/agile.html). 

Agile Training Aids 

Go to the Oracle University Web page 
(http://www.oracle.com/education/chooser/selectcountry_new.html) for more information on Agile 

http://www.oracle.com/technology/documentation/agile.html
http://www.adobe.com/
http://www.oracle.com/technology/documentation/agile.html
http://www.oracle.com/agile/support.html
http://www.oracle.com/agile/support.html
http://www.oracle.com/accessibility/
http://www.oracle.com/accessibility/
http://www.oracle.com/technology/documentation/agile.html
http://www.oracle.com/education/chooser/selectcountry_new.html


 

Training offerings. 

Accessibility of Code Examples in Documentation  

Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise empty line; 
however, some screen readers may not always read a line of text that consists solely of a bracket or 
brace.  

Accessibility of Links to External Web Sites in Documentation  

This documentation may contain links to Web sites of other companies or organizations that Oracle 
does not own or control. Oracle neither evaluates nor makes any representations regarding the 
accessibility of these Web sites.  
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Chapter 1 

Introduction 

This chapter includes the following: 

 Agile Program Management ................................................................................................................................ 1 
 Program Management Objects............................................................................................................................ 2 
 Program Navigation ............................................................................................................................................. 4 
 Tracking Project Status........................................................................................................................................ 5 
 Program Costing.................................................................................................................................................. 8 

Agile Product Portfolio Management (PPM) gives you powerful capabilities to define, analyze, and 
manage all aspects of a project or program. 

Executives use the PPM Dashboard to view portfolio data for all programs being monitored, including 
risks to program health caused by schedule slips, lack of resources, and program cost. 

Program Managers use PPM to create and manage program tasks, resources, documents, and 
schedules; make program assignments; conduct program discussions; and track program health 
and budget. 

Program participants use PPM to report on the completion of program tasks, update program 
documents, manage any resource pools they own, manage program activities they own, and 
participate in program discussions. 

Tasks can be placed on a timeline and dependencies can be defined where one task cannot begin 
before the start or completion date of another. You can also define Milestones or Gates that 
represent critical deliverables or decision points in the development process and track areas that 
could impact the defined schedule. 

The program can be managed with an iterative approach based on changing needs. You can adjust 
start dates and durations of tasks to meet the overall timing goals. Downstream activities are 
dynamically updated when dates or dependencies are adjusted. 

Powerful filtering and summarizing tools let you find trouble spots quickly and drill down to study the 
details. The program objects of PPM provide detailed control over all aspects of program 
management, from high level overview to individual employee activities. 

Agile PPM objects and functionality are accessed using the Agile Web Client. 
 

Agile Program Management 
The program management objects and features in Agile enable Program Managers to: 

 Define a program in terms of its schedules, tasks, resources, and deliverables 

 Plan, execute, and manage multiple related program/phase/gate processes 

 Associate product deliverables with program objects 
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 Establish templates that can be used to generate other programs 

onal, product, and program types 

objects. Each 
program object contains not only schedule information, but also the attachments, discussions and 

Agile PPM provides the means to “roll up” data from child objects to higher levels by rules and 

 View resource workload by user and resource pool 

 Categorize programs according to organizati

 View portfolio-level dashboards and reports 

Program Managers schedule and execute programs in Agile PPM using program 

actions items, resources and roles, and history of actions related to the program. 

relationships, to provide management with an executive-level view of program progress. 

You can track program progress against schedules, cost, resources and quality by tracking each 
child object in your program. See (“Tracking Project Status (on page 5)”.) You can view project 
progress via the tables in the Agile Dashboard. (See "Dashboard (on page 31)".) Or view a Gantt 
Chart that shows project progress visually (See "Gantt Chart (on page 87)" ). 

Once an activity (program) has been created, you can add the following elements to it: 

Tasks 

 Programs 

 Phases 

 
 Gates 

We introduce these objects in “Program Management Objects (on page 2)” below, and describe 
their use in detail in "Creating and Managing Programs (on page 43)".  

To quickly learn the basics of program creation, try out the steps defined in the real-life scenario 
pledescribed in "Creating Programs: A "Real World" Exam  (on page 127)". 

t of scheduling, tasks, status, discussions, 

 a

eries bjects - such as phases, tasks, ms. 

table scribes 

Program Management Objects 
The program management process involves managemen
document and resources. s, phases/gates, 

At  minimum, a typical Agile PPM program consists of: 

 A root-level program 

 A s  of child o  gates, or other progra

The below de the objects that can comprise an Agile PPM program. 

Icon Object  Descr ipt ion 

 Program
d manage progress on a specific project.  

A program is the top-level object, but a program can also be a child of another 
program. 

A program is a set of related activities and gates (milestones) that is created to 
monitor an
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Icon Object  Descr ipt ion 

 Phase A phase, sometimes called a stage, is a segment of a program. 

Phases are often used to define the activities required to create a set of 
deliverables. When phases end, program managers may hold a phase exit or 
gate review to examine the completion status of each phase element. 

Phases usually derive their dates and status information from the program 
elements that report to them. 

 Task A task is a segment of work that one or more resources can complete over a 
period of time. Progress or status reported in a task is rolled up to higher levels 
of the program. 

Tasks may be embedded in programs, phases, or other tasks. 

 Gate A gate (or milestone) is a specific point in time that denotes the completion of a 
set of related activities, such as a phase. 

Gate status is frequently controlled by deliverables. A gate’s status is closed until 
all its deliverables are complete, at which time it opens so work can go forward 
(“through the gate”). The change in the gate’s workflow status can be 
automatically triggered by the status of deliverables, so that when all 
deliverables reach a certain status, the gate goes into review or it opens. 

 Deliverable An Agile PLM object whose state change can trigger a state change in the 
program element that contains it. When the deliverable changes to a predefined 
target workflow status, the event triggers a change of status in the activity to a 
predetermined new status. 

Deliverables are often used to control the status of gates. 

 Discussion Informal conversations relating to a specific program activity, found on the 
program object’s Discussions tab. 

 Action Items Unplanned tasks, with owners and due dates, found on the program object’s 
Discussions tab. Action items can be attached to discussions or to the program 
object. 
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The figure below shows how Agile PPM objects are employed. 

 

Note Programs, phases, tasks and gates are fully customizable. For further information, see 
your site’s Agile administrator. 

 

Program Navigation 
In Agile Web Client, the left pane, called the navigation pane, provides access to searches and 
Analytics and Reports. As you perform certain actions in Web Client, such as stepping through 
wizards, the navigation pane provides tools for navigating the process. 

In Agile PPM, the navigation pane also includes navigation tools that allow you to view an entire 
program tree structure and to keep that program tree visible and accessible as you work in Web 
Client. For example, you may open and view other types of Agile objects, run searches, and view 
attachments, then return to the most recently viewed program tree view in the navigation pane. 

When you open any Agile PPM object, the root program tree for that object appears in the 
navigation pane, and the Program Tree navigation control becomes available. 
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Act ion  or  But ton  Descr ipt ion 

  Expand All

  Collapse All

Expands all levels of the program tree. 

Collapses all levels of the program tree so that only the root parent activity is 
displayed. 

You can also click + or - in the program tree to expand or collapse one level at a 
time. 

Click an activity in the 
program tree navigation 
pane 

The activity is displayed in the right pane with the most recently viewed tab in front. 

For example, if you display the Discussions tab in the right pane, when you click 
another activity in the program tree navigation pane, that activity is displayed in the 
right pane with the Discussions tab in front. 

As you click through the program tree in the left pane, the same tab is always 
displayed in the right pane until you select a different tab. 

  Program Tree
If the program tree is not currently displayed in the navigation pane, clicking 
Program Tree returns the navigation pane view to the most recently viewed 
expansion of the program tree. 

If the program tree is currently displayed in the navigation pane, clicking Program 
Tree collapses the navigation pane. 

You may perform a number of actions (including running searches, opening and 
viewing other Agile objects, opening your Inboxes) during which the Program Tree 
button remains visible. Click Program Tree at any time to return to the most 
recently viewed expansion of the program tree. 

If the program tree is not currently displayed in the navigation pane and the 
Program Tree button is visible, you may also click the Refresh button in the main 
toolbar to return to the program tree in the navigation pane. 

Note: The Program Tree button is removed if you use Show BOM Tree when 
viewing an Agile item or if you perform an action that displays wizard steps in the 
navigation pane. However, if you select and display an activity in the root program 
(for example, by using the Recently Viewed list), the most recently viewed 
expansion of the program tree is displayed in the navigation pane and the 
Program Tree button is visible. 

Navigate to (by any 
means) a different root 
program 

The navigation pane program tree is updated with the program tree of the newly 
selected root program. 

 
 

Tracking Project Status 
Agile PPM enables Executives and Program Managers to track the status of each activity, and 
overall “health” of the project (on track, needs attention, and off track). 

How Status Roll-Up works 

A number of attributes are passed upward from child objects to parents, in a process called rolling 
up. 

 Page - 5
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The attributes that are rolled up include: 

 Activity workflow status 

 Health statuses 

 Scheduled dates and scheduled duration 

 Actual start/end dates and actual duration 

 Estimated start/end dates and estimated duration 

 Days effort 

 Percent complete 

r 
ny leaf node object is determined 

to be Off Track, the parent object is considered to be Off Track. 

d 
 from lower levels in the hierarchy. 

Status can only be edited at the lowest levels (leaf nodes). 

Note  to 

The rolling up of values starts with leaf nodes (child objects that have no children) that are not eithe
Complete or Canceled, and moves upward to parent objects. If a

Parent object fields that reflect rolled-up status of child objects, such as Days Effort or Schedule
Dates, cannot be edited because it is automatically rolled up

The only way you can change the status of a parent object at the program level is
cancel the program using the Actions > Change to Canceled menu command. Once 
canceled, a program can be reset to the Not Started state, using Actions > Change to Not 
Started. 

 

Health Status 

Health Status values are rolled up for all objects that are configured to report health status. This 
configuration is done in the Java Client by setting the Rollup Health Status attribute to Yes in that 

 tab. The following status elements are rolled upward: 

 

Off Track. If the 

maintained in administrator settings, and each value has an associated 

 appear in the upper right of the activity window. Colors 

object’s General Info

 Overall 

 Schedule

 Cost 

 Resource 

 Quality 

If any one child of a program object is Off Track, the parent program is set to 
Quality Status of a child is Below Quality, the parent is set to Below Quality. 

Health attribute values are 
activation period or value. 

The activity Health Status indicators
indicating stages of the health are: 

 On Track (green)  

 Needs Attention e (y llow)  
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 Off Track (red)  
 

Default Health Statuses 

The following table shows default schedule, cost, resource, and quality health statuses. 

Status Values What  t r iggers  change? 

Schedule On Track (green), Needs Attention (yellow), 
Off Track (red) 

s 
ue for 

Within the Java Client you can create a setting 
to trigger a health status change if there is 
schedule slippage of a certain number of days.  
The default setting for the Health Status to 
change from Not Started or On Track to Need
Attention is 1-5 days. If the task is overd
more than 5 days, the status changes to Off 
Track. To learn how to configure these 
settings, see the Agile Administrator Guide. 

Cost On Budget (green), Off Budget (yellow), s is calculated based on the 
deviation (Percentage property) from the 

riginal cost. 

The cost statu
Over Budget (red) %

o

Resource Staffed (green), Understaffed (yellow), Not 
Staffed (red) 

 

Quality Meets (green), Below (yellow), Poor (red)  

Overall nds to the most severe (red) 
setting of the four health statuses for any 
project. 

 Correspo

 
 

Reason fields 

When you update an object’s status in its General Info tab, use the Reason field to specify a reason 
for the status. For example, if you set the Cost Status field to Off Budget, you might specify “high 

ason. 

ow stamp in the upper right of the General Info tab to indicate the 
workflow status of an activity (see the figure below). The Agile administrator defines the name of 

ach status in each workflow. 

shipping costs” as the re

Workflow Status 

Agile Web Client uses a workfl

e

 

 

 workflow statuses are: The default program

 Not Started 
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 In Process 

 Complete 

 Canceled 

Your company may have its own customized workflows and s, as displayed in the 

If a user has the appropriate privileges, they can use the Change Status button to change an activity’s 

Important  the 
tus button to change status on individual leaf node objects (objects with no 

children). You cannot promote an activity whose Template field setting is Template or 
Proposed. 

d 

to let a particular summary task’s values 
be calculated automatically (rolled up) or edited manually. For more information on enabling the 
calculate attribute, see the Agile PLM Administrator Guide. 

status stamp
Workflow tab. For further information see "Workflow Routings". 

status, promoting it to the next lifecycle state. 

Since lifecycle status of parent objects is rolled up from lower levels, you can only use
Change Sta

 

Program Costing 
Program costing information is rolled up through the project structure the same way status an
health are rolled up. By default, cost information for each field is rolled up automatically, such that a 
summary or parent task is a summation of the values of its child objects. However, there are 
'Calculate' attributes that can be enabled within Java Client 
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Program cost calculations generally occur as shown in the figure below. 

Program

Phase 1

Phase 3

Phase 2

Task 1

Task 2

Total Cost = $70$25 + $30 + $15 = 

Cost = $25

Cost = $20 + $10 = $30

Cost = $20

Cost = $10

Cost = $15

 
 

How Total Cost is Determined 

Total Cost fields that appear on the General Info tab are calculated values and cannot be edited. 
Total Cost is the sum of the four cost types: Labor Cost, Capital Expenses, Fixed Cost and Flex 
Cost. 

For example, Total Actual Cost is the sum of: 

 Actual Labor Cost 

 Actual Capital Expenses 

 Actual Fixed Cost 

 Actual Flex Cost 

In the same manner, Total Estimated Cost is the sum of Estimated Labor Cost, Estimated Capital 
Expenses, Estimated Fixed Cost, and Estimated Flex Cost. Total Budgeted Cost is the sum of 
Budgeted Labor Cost, Budgeted Capital Expenses, Budgeted Fixed Cost, and Budgeted Flex Cost. 

Cost Status 

The cost status is calculated based on the % deviation (Percentage property) defined in the cost 
status node in Agile Administrator, under System Settings->Product Portfolio Management. For 

 Page - 9

  

 



Product Portfolio Management User Guide  
 
 
 

information about Agile system settings, see the Agile PLM Administrator Guide. 

Costs Included in Baselines 

All Cost fields are part of the baseline. The cost fields are Labor Cost, Capital Expenses, Fixed Cost 
and Flex Cost. Each of these costs have Actual, Budgeted and Estimated categories. There are 12 
cost fields in total. Ten Calculate flags are also baselined. Budgeted and Actual Labor costs do not 
have the calculate/roll-up flags as they are always calculated and rolled up. 

Use the Baseline Comparison Report in the Agile Standard Reports to compare these values. 

Labor Costs 

Actual and Budgeted Labor costs are automatically calculated. Budgeted Labor Cost uses 
scheduled duration, % allocation, and the users' resource pool rate, and man hours (8 hours per 
day) to calculate a labor cost per resource assignment. These are summed for multiple resources 
assigned to an activity. If an activity has a resource assigned, and has lower-level objects with 
Labor costs, then it is summed at the parent level and not replaced. Budgeted and Actual Labor 
Costs are always calculated in this way. However, Estimated Labor Cost can be editable at all 
levels. If not edited, it will be rolled up by default. Capital and Fixed Costs (Actual, Budgeted and 
Estimated) can be both rolled up as well as edited values, depending on whether the Agile 
administrator has enabled the Calculate/Roll-up flag on each cost field. 

Note If a Resource is not assigned to a Resource Pool, the user’s individual Labor Rate is 
used. 
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Home Page 

This chapter includes the following: 

 Viewing the Home Page ...................................................................................................................................... 11 
 Quick Links .......................................................................................................................................................... 12 
 Home Page Inbox Tabs ....................................................................................................................................... 12 
 Notifications ......................................................................................................................................................... 13 
 Workflow Routings............................................................................................................................................... 20 
 My Assignments .................................................................................................................................................. 21 

 
 

Viewing the Home Page 
The Agile Home page provides access to Dashboard, Notifications, Workflow Routings, and My 
Assignments. Dashboard features are documented separately, see "Dashboard (on page 31)". 

To access the Home Page, click the  icon. The page that displays when you first open Web 
Client can be changed, as described in the Getting Started with Agile PLM Guide. If you choose a 
Dashboard page as your Preferred Start Page, that Dashboard page will be displayed when you 
click the  Home button in the main menu. 

To view your Inbox tabs in Web Client: 

You can open and view the Home page using any of the following methods: 

 At any time while you are using Web Client, click the small down-arrow next to the Home button 

 and select an inbox view: My Assignments, Notifications, or Workflow Routings. 

 If your preferred start page is a Home page tab, it is displayed when you login to Agile Web 
Client. 

 If your preferred start page is a Home page tab: 

a. In the menu bar, click the Home button . 

The Home page is displayed with your preferred inbox view tab on top. 
b. To view a different inbox view, click the Home page tab you want to view. 

Note If your preferred start page is a Dashboard tab, you will not see the Home page tabs when 

you click the Home button . Click the small down-arrow next to the Home button  
and select a non-Dashboard inbox view: My Assignments, Notifications, or Workflow Routings. 
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Quick Links 
Quick Links, at the top of the Home page, is a list of up to ten links that you use frequently. You 
define your own Quick Links list and you can edit and modify your Quick Links list at any time. Your 
Quick Links list can include predefined system links, saved searches in your Personal Searches 
folder, or bookmarks in your Bookmarks folder. 

To edit your Quick Links list: 

1. Click the Edit link next to the Quick Links: heading at the top of the Home page. The editable list 
appears at the top of the page. 

2. From the drop-down list choose the type of link you want to use. 

The three types of available links are: 
 Links – predefined Agile system links including My User Profile, Change Password, 

Analytics and Reports, and Dashboard. 
 Bookmarks – available values are all the bookmarks in your Bookmarks folders, listed 

individually. 
 Searches – available values are all the searches in your Personal Searches folders, listed 

individually. 

3. Use the arrow buttons to move links from the Available Values list to the Selected Values list. 

Or, double-click to move links from one list to the other list. 

4. You may include more than ten links in the Selected Values list, but only the first ten links in the 
list will be displayed in your Quick Links list. Reorder the list by selecting one or more links and 
using the up and down arrow buttons to move them up or down in the list. 

5. When you are finished, click the Save button. 
 

 

Home Page Inbox Tabs 
As information passes through the Agile system, users receive news of status changes, requests, 
and other notifications through email. Users with different roles and privileges receive different 
notifications. When you first start Web Client, it is a good idea to view the information collected for 
you on the Home page. 

 Notifications tab – Notifications inform you of some action or process that has taken place or a 
notification can let you know that you have a request to accept or decline ownership of an 
action item or activity. Delete notifications after you have read them. 

 Workflow Routings tab – lists routable objects that require your review or action. Click the object 
number in the table to open it. 

 My Assignments tab – lists program leaf node objects assigned to you which are not yet 
complete and action items assigned to you which are not yet complete.  
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Notifications 
The Home page Notifications tab lists notifications that have been sent to you. Notifications inform 

action or process that has taken plac scriptions, RFQs, and project 
requires your attention 

in the My Assignments tab. Requests ask you to accept or decline ownership of an action item or 

te My Assignments tab. 

you of some e, such as sub
invitations. A notification can also let you know that you have a request that 

activity. 

No  To accept or decline a request, use the 

You can view or delete a notification. 

 ck the Subject link. 

To delete a notification, sel

To view a notification, cli

 ect its row and click  Delete. 

 

Icon or  But ton Descr ipt ion 

  Delete ted notifications. Deletes the selec

Select one or more rows in the Notifications table, and click this button to delete them 
from the table. 

 
ations table row. Indicates that you have not yet opened this notification. 

New Notification 

Icon in Notific

 Read Notification 

in Notifications table row. Indicates that you have previously opened this 
cation. 

Icon 
notifi

 
 

PPM Notifications 

Withi duct Portfolio Management, notifications are triggered and sent to appropriate reci
when  perform various actions on a program object. For example, a notification can info

le or status changes, or an activity assigned to you, or a program 

n Pro pients 
 you rm you 

of schedu that needs your 
approval, depending upon your role.  

te hen enabled in the Java Client. For details on No  Notifications are generated only w
configuring notifications, see the Agile PLM Administrator Guide. 

PPM notifications are related to any of the following: 

gnment or Delegation 

e 

 Discussions 

 Ownership, Assi

 Schedule Chang

 Cost  

 Workflow  
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hip, Assignment, or Delega tions

The following notification  owne gnmen bject.  

Setup 

Owners tion Notifica  

s are related to rship, assi t, or delegation of a program o

Program 
Object  

Not i f icat ion Received  By When. . .  

Activity Program Object 
Delegation Notification 

Delegated user. A program activity is delegated to the 
recipient. 

 Action Item Assignment Assigned user. ssigned to the 
Notification 

An action item is a
recipient. 

 
ification 

Program owner. nt creates a program from Program Owner 
Assignment Not

The recipie
a template or is assigned ownership 
of a program during program creation 
from a template. 

 Assignment of a
to a resource.  

n activity Assigned user. An activity is assigned to the 
recipient. 

 ccept activity 
ssignment 

Program Owner The assigned resource accepts the 
activity assignment. 

A
a
 

 y 
ssignment 

Program Owner The assigned resource rejects the 
activity assignment 

Reject activit
a
 

 
ccept 

Program Owner ccepts an activity 
delegation. 

Program Object 
Delegation A
Notification 
 

A resource a

 Program Object 
Delegation Reject 

Program Owner 
ation. 

Notification 

A resource declines an activity 
deleg

 Notification for Program 
Object Delegation 

ed user.  
nt and needs to be accepted 

ments 

Delegat A program activity is delegated to the
recipie
or rejected from the My Assign
tab. 

Resource 
Pool

r Program 
elegation Notification 

Resource Pool 
Owner 

An activity (with or without child 
activities) is delegated to a resource 
pool. 

Pool Owne
D

 Notification for Activity 
Assignment to a 
Resource 

 

Resource Pool 
Member 

 

An activity is assigned to the 
recipient. 
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Program 
Object  

Not i f icat ion Received  By When. . .  

 Pool Owner Program 
Delegation Request
 

 Owner 
m  

cipient's 
resource pool and needs to be 
accepted or rejected from the My 
Assignments tab. 

Resource Pool A child activity of a template progra
is delegated to the re

 Pool Owner Program 
Delegation Accept 
Notification 
 

Program Owner A resource pool owner accepts an
activity assignment. 

 

 Pool Owner Program 
Delegation Reject 
Notification

Program Owner A resource pool owner rejects an 
activity assignment. 

 
 

 
ool owner- Assignment 
f Activity 

Resource Pool 
Owner 

rce 
ient's resource pool. For 

proposed programs, this can be 

Notification to Resource 
p
o

An activity is assigned to a resou
in the recip

controlled using a SmartRule. 

Gate ate Action Item 
Assignment Notification   

Assigned user tem associated with a 
program gate is assigned to the 

G

 

An action i

recipient. 

 Gate Object Delegation   Delegated user A program gate is delegated to the 
 recipient. 

 ate Object Delegation 
ccept Notification  

Gate Owner A user accepts a gate object 
delegation. 

G
A

 tion 
Reject Notification  
 

Gate Owner Gate Object Delega A user rejects a gate object 
delegation. 

 Notification for Gate Delegated user A program gate is delegated to the 
recipient and needs to be accepted 
or rejected from the My Assignments 
tab. 

Object Delegation 
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Schedule Change Notifications 

Program 
Object  

Not i f icat ion Received  By When. . .  

Activity am 
chedule Change 

 

Parent Program 
Owner  only when there 

e 

Parent Progr
S
Notification 

 

The scheduled date of a parent activity 
is changed. Applies
one or more baselines created for th
tree. 

 Predecessor Program 
Schedule Change 

Successor Program 
Owner y is changed, resulting in 

Notification 
 

The scheduled dates of a predecessor 
activit
changes to the scheduled dates of the 
successor activity. 

 Microsoft Project Sync 
Change Notification 

Program Owner 

 

Changes made to a PPM program 
from Microsoft Project are 
synchronized, resulting in schedule 
date changes.Applies only when there
one or more baselines created for the 
tree. 

 
otification 

Activity Owner The scheduled date of a child activity 
is changed as a result of changes to 

Child Activity 
Reschedule N

the scheduled date of the parent 
activity. Applies only when there one 
or more baselines created for the tree. 

  Activity 
Owner for Program 
Schedule Date Change 

Activity Owner The Schedule Date of an activity has 
changed because it is now dependent 
upon a preceding activity. 

Notification to

due to addition of 
Predecessor 

G Program
Change Notification - 

Activity O y has 
changed because it is now dependent 
upon a

ate  Schedule 

addition of gate 
predecessor 

wner The Schedule Date of an activit

 preceding gate. 

 
 

ost Impact NC otifications 

Program 
 

Not i f icat ion 
Object

Received  By When. . .  

Activity
 
 

Task Owner 
r 

Task Overbudget Notification The cost of executing a task 
exceeds the budget allocation fo
it. 
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Program 
Object  

Not i f icat ion Received  By When. . .  

 Actu Budgeted
time to Object Owner 

er Resource(s) allocated to a task 
have exceeded the budgeted time 

al Time exceeds  Program own

Notification to complete the task. 

Resource 
Pool

 Budge ol Owner Resource(s) from the recipient's 
resource pool have exceeded the 
budgeted time to complete the 
allocated task. 

Actual Time exceeds
time to Pool Owner Notification 

ted Resource Po

 
 

orkflow-rela ed Notifications W t

Program 
Object  

Not i f icat ion Received  By When. . .  

Activity rogram Status 

 

Designated 
users 
 list. 

There is a change in activity status. P
Promotion, 
Observers/Notifiers 

 

observers or 
on the Notify

 Program Status 
Promotion, Approvers 

Designated 
approvers. 

There is a change in activity status that 
requires approval.  

  

Approve Program,
Notifiers 

All users on the 
Notify list for the 
activity.  

 

The activity has been approved to move 
forward in the workflow. 

 Program Approve
Activity, Ad

 
d Approver approver. 

r 
ram or activity. 

 

Designated The recipient is added as an approve
for a prog

 
 Add Observer 

Designated observer. n observer 
for a program or activity. 

Program Approve 
Activity,

The recipient is added as a

 

 

 
Program Approve 
Activity, Remove 
Approver 

Designated Program 
Approver 

The recipient is removed from the list of 
approvers for a program or activity.

 Program Activity 
Comment 
 

Program Owner A user has added a comment to an 
activity. 
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Program 
Object  

Not i f icat ion Received  By When. . .  

 Program Activity 
Promotion Failure, 

eject 

 
uest. 

R
 

Program Owner A required approver rejects a program
status promotion req

  
romotion , Approve 

wner pprover approves a 
program status promotion request. 

Program Activity
P

Program O A required a

Gate
ers   

Gate Status Promotion 
Observers/Notifi

 
 

Designated Gate 
Observers

There is a change in gate status.  

 ate Status Promotion; 
provers  

Program/Gate 
Approvers 

There is a change in gate status that 
requires approval.  

G
Ap
 

 rogram Approve Gate; 
dd Approver   

Designated Gate 
Approver 

The recipient is added an an approver 
for a gate. 

P
A
 

  Approve Gate; 
dd Observer  

Designated Gate 
Observer 

The recipient is added as an observer 
for a gate. 

Program
A
 

 
Gate; Remove Approver  

  

Designated Gate 
Approver 

om the list of 
approvers for a gate. 

Program Approver The recipient is removed fr

 Program Gate 
Comment  
 

Program Owner A user adds a comment to a program 
gate. 

 Prog
Promo
Reject

ram Gate 
tion Fail
  

 

Program Ow
ure 

ner A required approver rejects a gate 
status promotion request. 

 Program Gate 
Promotion; Ap

w  
status promotion request. prove 

Program O ner A required approver approves a gate
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Discussion-related Notifications 

Not i f icat ion Received  By When. . .  

Discussion Action Item Discussion 
participant/program 
resource 

An action item associated with a discussion is 
assigned to the recipient. Assignment Notification  

 

Discussion Create Notification  Any user added to the 
Notify list during 
discussion creation. 

A new discussion object is created successfully. 

Discussion Send  Discuss
partic

ion 
ipant/program 

resource 

A discussion is sent to the recipient. 

Reply Create No Discuss A user replies to a message within a discussion tification 
 

ion 
participants thread. 

Reply Update Notification  Discussion 
participants 

A user updates a reply message within a 
discussion thread. 

 

 

 

cations 

 
 

Setup-related Notifi

Not i f icat ion Received  By When. . .  

Program Creation Notific
 

ation Program Creator Program creation is run as a background process 
and a new program is created successfully. 

Activity Send Any user. nt to the recipient. 
 

An activity is se

User Disabled Notification Resource Pool Owner A user who was assigned as a resource to an 
activity from the recipient's resource pool has been 
disabled by the system. 

 
 

Other Notifications 

Not i f icat ion Received  By When. . .  

Relationship Promotion 
Failure Notification 

Program Owner Automatic promotion of a program status fails for 
any reason, for example, the non-completion of a 
required field. 

 Page - 19

  

 



Product Portfolio Management User Guide  
 
 
 

Not i f icat ion Received  By When. . .  

Relationship Notifications > 
ion Notification 

 

Notifi s within a subs
da

cation subscriber Field tag cription notification is 
changed or up ted. Subscript

 
 

Workflow Routings 
ection  that require your review or action. 
x ma re a  approver. The out-of-box 

w routings are a combination of base classes and actions that define the kind of review, as in 

The Workflow Routings s
For example, your Inbo
workflo

 of the Inbox lists routable objects
y contain changes for which you a n

the table below. 

Base c lass . . .  . . . includes routab le  objects . . .combined wi th  these 
f rom these c lasses. . .  act ions of  rev iew 

Change ge Requests, Site 
 Orders, 

. That Require My Approval

. That I Am An Observer Of
... That Were Returned To Me
. Transferred to Me

... Escalated to Me
 

Change Orders, Chan ..

..Change Orders, Price Change
Deviations, and Stop Ships 

..

Quality Change Request 
(QCR) 

tive Actions and 
Audits 

 Corrective and Preven

Problem Service Request Non-Conformance Requests and  
(PSR) Problem Reports 

Package Packages  

Program Activities and Gates  

Transfer Order Content Transfer Orders and 
Automated Transfer Orders 

 

Declarations S
D

ubstance Declarations, Part 
eclarations, JGPSSI Declarations, 

 

Homogeneous Material Declarations, 
Supplier Declarations of Conformance, 
IPC 1752-1 Declarations, and IPC 
1752-2 Declarations 

 

To open a workflow routing in the table, double-click its number. 

Tools > 
Expo

The 

To export objects to a text or PDX file (if you have privileges), select the row and choose 
rt. 

Print button prints the entire Inbox table. 
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My A
The Hom
The My A
assignm r select one or more assignment rows in 
the le assignments. For example, you can accept or 
decli

nts tab table includes: 

 ti
te or Canceled. 

re not 

de. Activities with children are not included. 
 You are the owner of the activity and the Delegated Owner field is blank. If you have 

ontains the name of the delegated owner 

n 0%. 

ctio
 
 een accepted. 

has not been declined. 
 and it has been declined by the assignee. 

 

Programs that display in your My Assignments tab are: 
 r which you are the owner. 

 which you are the owner. 
 delegated to a resource from the Actions > Delegate menu. 

 ents ssignm
e page My Assignments tab lists Activities and Action Items for which you are responsible. 
ssignments tab provides a set of tools that allow you to efficiently work with your 
ents. You can sort the assignments table rows, o

tab , and then perform an action on the selected 
ne a program activity assignment, or flag an assignment for easier tracking.  

The Home page My Assignme

Ac vity objects where: 
 The activity is In Process. The workflow status type is not Comple
 The activity’s Template attribute is set to Active. Proposed or Template activities a

included. 
 The activity is a leaf no

delegated ownership, the Delegated Owner field c
until the activity is accepted or declined. 

 You are the delegated owner of the activity. 
 You are a resource on the Team tab of the activity and your allocation is greater tha

 A n Items where: 
The action item is assigned to you and it is not Complete or Cancelled. 
The action item is assigned to you and it has b

 The action item is assigned to you and it 
 You are the creator of the action item

Program Assignments 

Active root-level programs that have no child objects, fo
 Leaf-level programs for
 Programs that you have

Note The program is displayed till the assigned resource accepts the action item. Once the 
resource accepts the action item, it disappears from your My Assignments list and you 
receive a notification in the Notifications tab. 

 

Program Activity Assignment Request 

If a user adds you ion greater than zero in a program’s Team 
tab, you receive a Progra est in My Assignments. You can open the 

t and accep

Note You also 

as a resource with a percent allocat
m Activity Assignment Requ

t or decline the request. reques

receive a notification in the Notifications tab. 
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My Assignments Table 

Your Agile adminis able. If you have 
questions about th

By default, the My A

trator determines which columns appear in the My Assignments t
e My Assignments tab, contact your Agile administrator. 

ssignments tab includes the following columns: 

Column name Descr ipt ion 

Flag Flag icon which you can set to manage your assignments. For more information, see 
Flagging Assignments (on page 27). 

Name The name of the activity or action item. 

Click this link to open the activity or action item. 

Status Workflow status of the activity or action item. For example, an activity can be Not 
Started or In Process and an action item can be Not Accepted or Accepted. 

If you have the appropriate privileges, you can edit the Status column. For more 
information, see Editing Assignments (on page 26). 

Due Date The date the activity or action item is due. 

You can sort the assignment list by due dates. For more information, see Using the 
View Options to Sort your Assignment List (on page 24). 

If you have the appropriate privileges, you can edit the Due Date column. For more 
information, see Editing Assignments (on page 26). 

% Complete . 

If you have the appropriate privileges, you can edit the % Complete column. For more 
g Assignments

For activities, the percentage of the task that has been completed

information, see Editin  (on page 26). 

Related To For activities, the Related To column lists the parent activity and root parent activity. 

elated To column lists the activity or discussion object to which 
the action item is associated. 

Click the links in pen the related activities or discussions. 

For action items, the R

this column to o

Actual Hours For activities, th

If you ha  
informati

e number of hours expended on the activity. 

ve the appropriate privileges, you can edit the Actual Hours column. For more
on, see Editing Assignments (on page 26). 

 
 

My Assignments Ta

The My Assignments tab tools incl

b Tools 

ude: 
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Tool  Descr ipt ion 

      View View drop-down list. 

Use the list to sort your assignments by pre-defined views, for example, 
pending requests, flagged assignments, due dates, action items, or activities 
where you are a resource. 

For more information, see Using the View Options to Sort your 
Assignment List (on page 24). 

 Edit
. 

s. 

Edit the selected row objects. 

Allows you to edit object fields displayed in the table, based on your privileges

For example, you can modify the Status, Due Date, and Actual Hours field

For more information, see Editing Assignments (on page 26). 

 Accept e selected activities, program activity assignments, or action items. 

t the assignment as a resource for the 

 assignee and the 

ation, see Accepting Assignments

Accept th

For activities, accept the ownership when you are the designated owner. 

For program activity assignments, accep
activity. 

For action items, accept the action item when you are the
action item has not yet been accepted. 

For more inform  (on page 26). 

 Decline
 when you are the designated owner. 

clining Assignments

Decline the selected activities, program activity assignments, or action items. 

For activities, decline the ownership

For program activity assignments, decline the assignment as a resource for the 
activity. 

For action items, decline the action item when you are the assignee and the 
action item has not yet been accepted. 

For more information, see De  (on page 26). 

 Mark Complete
 

 and removes them from your 

Mark as complete the selected activities or action items. 

For activities, sets the Complete field to 100% and changes the workflow status
to Complete.  

For action items, changes their status to complete
assignment list. 

For more information, see Mark Assignments Complete (on page 27). 

 Show Filter
 Hide Filter

Displays or hides the filter definition fields. 

For detailed information about using the filter, see Using the Filter to Sort 
your Assignment List (on page 25). 

Prints the table sorted table. 

Allow
 Print

s you to print the assignment table that is currently displayed. 

For more information, see Printing the Assignment Table (on page 29). 
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Tool  Descr ipt ion 

More Actions...
Add to Flagged View

Sets the flag for all the selected table rows. 

Allows you to flag multiple rows at one time. 

To display flagged rows, in the View drop-down list, choose Flagged. 

For more information, see Flagging Assignments (on page 27). 

More Actions...
Add to Hidden 
Assignments View

 in the assignments table. 

Allows you to hide assignments. 

Hidden assignments do not appear

For more information see Hiding and Unhiding Assignments (on page 
28). 

More Actions...
Remove From View  assignment view, allows you to remove (unhide) 

s. 

Remove assignments from the Hidden view. 

When displaying the hidden
the selected assignment row

See also Hiding and Unhiding Assignments (on page 28) and 
Flagging Assignments (on page 27). 

 Flag not set Flag icon appears in each row of the assignment table. 

 Flag set
The flag helps you to organize your assignments and flag the ones you want to 
track. 

Set or unset the flag by clicking it. 

For more information, see Flagging Assignments (on page 27). 

View Details 

allows you to edit, accept, or decline the object. The content of this window can 
rator. 

For more information, see Using the  Dialog

View Details icon button.  

Appears in each activity row next to the activity name. 

Opens a popup window that displays important details about the object and 

be configured in Java Client Administ

 Show Details  (on page 29). 

 
 

Using the View Options to Sort your Assignment List 

Use the Home page My Assignments ta
the assignments with which you want ests or for 

 the following pre-define ories. 

b View drop-down list to sort you assignments and quickly find 
to work. For example, you can sort for pending requ

overdue assignments. 

Agile provides d view categ

View Descr ipt ion 

All Displays all assignments, except hidden assignments. 

Pending Requests Displays only pending requests. 
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View Descr ipt ion 

Flagged Displays only the flagged assignment rows. 

ts. This 
splays only the rows that you have flagged. 

You set or clear flags in order to manage your assignmen
View list choice di

Due Today or Overdue
Due this Week

s
Due in 90 Days

s according 

Due in Two Days
Due in 30 Day

These View list choices display assignment table row
to due dates. 

Hidden Assignments hidden assignments. 

You decide which assignments you want to hide on your 
assignments list. 

iding and Unhiding 

Displays only 

For more information, see H
Assignments (on page 28). 

Activities where I am a Resource Displays activities where you have been assigned as a resource 
on the Team tab. 

Action Items Displays action items assigned to you. 

Action items are generated and assigned from activities and 
discussions. 

 
 

Using the Filter to Sort your Assignment List 

s tab, the On the Home page My Assignment  Show Filter and  Hide Filter button toggles the 
n 
le 

row

marketing

<att

1. Use

display of the table filter. The table filter allows you to define filter criteria based on any column i
the table. You can define multiple filter criteria, which are combined in an AND search of the tab

s. 

For example, you can filter for assignments whose Related To column includes the word  
and the % Complete column is less than 50. 

The format of each filter criteria row is similar to an Agile search criteria: 

ribute> is <Match If Operator> <value to match>

To use the My Assignments tab filter: 

 the Home button   drop-down list and choose My Assignments to display your list of 
assignments. 

2. Click  Show Filter to display the Filter: criteria. 

In the first f3. ilter drop-down list, labeled --Select an Attribute--, choose from a list of the columns in 

4. In the next drop-down list, choose a Match If operator. The list of available Match If operators 
depends on the attribute type you chose as the --Select an Attribute-- drop-down list. 

the assignments table. 
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5. In the remaining field, enter the filter values. 

 To add a filter criteria row, click  Add Row at the end of the row. A filter criteria row is 
added to the display. 

 To delete a filter criteria row, click  Delete Row at the end of the row. The row is deleted. 

6. Click Apply to filter the assignments table. Only assignments that match your filter criteria are 
displayed. 

7. To define different set of filter criteria, click Clear to clear the criteria and begin again. 
 

ts tab Accept function to accept multiple activities or 
cept action applies to activities where you are the delegated owner, 

prog ems whose status is Not Accepted and you are the 
assi

signment tab: 

Accepting Assignments 

You can use the Home page My Assignmen
action items at one time. The ac

ram activities assigned to you, and action it
gnee.  

To accept assignments on the My As

1. Use the Home button drop-down  list and choose My Assignments to display your list of 
assignments. 

2. Select one or more rows in the table. 

3. Click the  Accept button. 

The selected objects are accepted. 

Declining Assignments 

You me page My Assignments tab Decline function to decline multiple activities or 
 applies to activities where you are the delegated owner 

 Not Accepted and you are the assignee. 

e

 can use the Ho
action items at one time. The decline action
and action items whose status is

Not  When you decline an activity, you must enter a reason. 

To decline assignments on the My

1. Use the Home button drop

 Assignment tab: 

-down  list and choose My Assignments to display your list of 
assignments. 

2. Select one or more rows in the table. 

3. Click the  Decline button. 

4. If one or more of the selected rows are activities, you must enter a reason why you are 
p dialog and click Send. 

ts tab Edit function to edit assignment attributes in the 
ges for the editable fields. 

our privileges, for an activity, you can edit the Status, the Percent 

declining. Enter your reason in the popu
 

Editing Assignments 

You can use the Home page My Assignmen
table. You must have the appropriate Modify privile

For example, depending on y
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Complete, Actual Hours, and Due Date. 

To e  Assdit My ignment table rows: 

1. Use the Home button drop-down  list and choose My Assignments to display your list of 

. 

assignments. 

2. Select one or more rows in the table

3. Click the  Edit button. 

4. Make the desired modifications. 

N The editable fields are determined by which fields your Agile administrator has ote 
included in the assignments table and your modify privileges. 

5. When you are finished, click Save. 

ltiple 
activ tems at one time. 

e n item, you cannot mark it as complete. Accept the 

 

Mark Assignments Complete 

You can use the Home page My Assig ntsnme  tab Mark Complete function to mark as complete mu
ities or action i

Not  If you have not accepted an actio
action item first, then mark it as complete. 

Whe

To mark assignments as complete on the My Assignments tab: 

n you mark an activity as complete, the Percent Complete field is automatically set to 100%. 

1. Use the Home button drop-down  list and choose My Assignments to display your list of 
assignments. 

2. Select one or more rows in the table. 

3. Click the  Mark Complete button. 

Action items in status Not Accepted cannot be marked complete and an error message is 

lag icon included in each row is a useful assignment 
ignments according to whether or not they are flagged, 

you n ifferently from other 
assignm r My Assignments tab, so you 
can decide how you wish to use them. 

To set or unset the flag in a single assi s table row: 

1. utton drop-down 

displayed. 

Flagging Assignments 

On the Home page My Assignments tab, the f
management tool. Because you can sort ass

 ca use the flag to indicate assignments that you want to trac  dk
ents. The flags o your assignment table appear only on oun  y

gnment

Use the Home b  list and choose My Assignments to display your list of 

ant. 

assignments. 

2. Click the flag icon in the row you w
 If the flag is not set , clicking it toggles the flag to set: . 
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 If the flag is set , clicking it toggles the flag to not set: . 

To set the flags in multiple assignments tab  rows: 

Use the 

le

1. utton drop-down Home b  list and choose My Assignments to display your list of 

ch assignment rows are displayed. 

n the flagged view: 

assignments. 

2. If desired, use the View drop-down list or the filter to sort whi

3. Select the rows you want to flag. 

4. Choose More Actions... > Add to Flagged View. 

To unset the flags in multiple assignments table rows i

1. Use the Home button drop-down  list and choose My Assignments to display your list of 
assignments. 

2. In the View drop-down list, choose Flagged. 

and 

management tool. For example, suppose you are 
ou are not the activity owner. You have completed your 

portion of the r resour ve not yet completed thei ns of the task. Therefore, 
y A

Com  hide this assignment so it no longer appears on your assignments list, however, 

our My Assignments tab views except your Hidden 
t on the assignment lists of other users. 
display your hidden assignments, and 

ove them from your hidden view). 

1. utton drop-down 

3. In the flagged assignments view, select the rows you want. 

4. Choose More Actions... > Remove from View. 
 

Hiding and Unhiding Assignments 

On the Home page My Assignments tab, the More Actions...Add to Hidden Assignments View comm
allows you to hide assignment rows that you do not want to see. The assignments are still part of 
your assignment list, but they are displayed only when you choose Hidden Assignments in the View 
drop-down list. 

Hiding assignments can be a useful assignment 
assigned as a resource for an activity, but y

task, but othe r portio
the assignment still appears on your 

ces ha
M ssignments tab because it has not been marked as 

plete. You can
it will still appear on the assignment lists of other resources. 

Hiding an assignment removes it from all y
Assignments view. Your Hidden Assignments view has no effec
You can hide assignments (add them to your hidden view), 
unhide hidden assignments (rem

To add assignment rows to your Hidden Vi

Use the 

ew: 

Home b  list and choose My Assignments to display your list of 

ilter to sort which assignment rows are displayed. 

3. Select one or more rows in

den

assignments. 

2. If desired, use the View drop-down list or the f

 the table. 

4. Choose More Actions... > Add to Hid  Assignments View. 

To view your hidden assignments: 

1. Use the Home button drop-down  list and choose My Assignments to display your list of 
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assignments. 

2. In the View drop-down list, choose Hidden Assignments. 

To remove assignment rows from your Hidden View: 

1. Use the Home button drop-down  list and choose My Assignments to display your list of 
assignments. 

2. In the View drop-down list, choose Hidden Assignments. 

3. In the hidden assignments view, select the rows you want. 

ew. 

e page My Assignments tab, the Show Details icon 

4. Choose More Actions... > Remove from Vi
 

Using the Show Details Dialog 

On the Hom  (in each row next to the name of 
ialog that displays additional information about the object and 

ect, for example, edit and bookmark. Your Agile 
 

You can u
assi

1. Use the Home button drop-down 

activity objects) opens a details d
allows you to perform actions on that obj
administrator determines which attribute  and actions are available in the details dialog of each
object type. 

s

Printing the Assignment Table 

se the Home page My Assignments tab Print function to print the currently displayed 
gnments table. Use the View drop-down list or the Filter to sort the table, then print the displayed 

table rows. 

To print the My Assignment table: 

 list and choose My Assignments to display your list of 
assignments. 

2. Use the View drop-down list or the Filter to sort the table to display the assignments you want. 

3. Click the  Print button. 

A printable version of table is displayed in a new browser window and the Print dialog appears. 

4. Click Print in the Print dialog. 

5. Close the new browser window when you are finished. 
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Chapter 3 

Dashboard 

This chapter includes the following: 

 Starting the Dashboard........................................................................................................................................ 31 
 Manipulating the Dashboard Windows ................................................................................................................ 31 
 Dashboard View .................................................................................................................................................. 32 
 Configuring Dashboard Views ............................................................................................................................. 32 
 Executive View .................................................................................................................................................... 34 
 Programs View .................................................................................................................................................... 35 
 Resources View................................................................................................................................................... 36 
 Financial View...................................................................................................................................................... 38 
 My Activities View ................................................................................................................................................ 38 
 Dashboard Management Administration Tasks................................................................................................... 39 
 PPM Reports ....................................................................................................................................................... 40 

The Dashboard enables you to view and manage information across all your programs. Depending 
on your roles and privileges, you can use the Dashboard to get an executive-level view of key 
information for all your programs, and user-level information about your own activities and tasks. All 
users can use the Dashboard to access reports and view consolidated information. See also 
"Reports (on page 53)“. 
 
 

Starting the Dashboard 
You can make the Dashboard your default start page when you log into Web Client. To do this, go 
to Tools > My Settings > User Profile and select the Preferences tab. Click Edit, and select the Dashboard 
tab you want as your Preferred Start Page. Most users open on My Activities, but an executive 
might prefer to open on the Executive tab. 

To start the Dashboard, choose Home > Dashboard.
 

Manipulating the Dashboard Windows 
The Dashboard windows can be manipulated by the icons described in the table below. 

Button  Descr ipt ion 

  Export Exports data in comma-separated value (.CSV) format for use in a 
spreadsheet (available in all tables). 

  Maximize/Restore Original 
Size

Expands the window to full size or reduces it to the size it was 
previously. 

  Refresh Table Refreshes the table view to show latest changes to content. 
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Button  Descr ipt ion 

  Remove Content From View Closes the window. 

To reopen the window, refresh your browser view. Or select the content 
object from the Add Content drop-down list at the bottom of the page 
and click Add. 

In the windows that display a table, you can click column headings of most tables to change the sort 
order. Depending on your privileges, you can click on data in most tables to “drill down” to a view of 
the individual object. 

Dashboard View 
The Dashboard comprises: 

 Default Tabs that enable you to select the view: Executive, Programs, Resources, Financial, My 
Activities, Optional Tab 1, and Optional Tab 2. 

 User-configured tabs that display customized information in tabular or chart formats, based on 
preferences set up by an administrator. 

Note To view user-configured tabs, you must have the Dashboard Tab View 
privilege assigned to you, and this privilege must be applied to these tabs 
within the Agile Java Client. 

 Windows within each tab that present information relevant to that view. For example, in the My 
Activities tab the windows represent the current user’s program activities: My Assignments, My 
Documents, My Action Items, My Issues, and Notifications. 

 The Configuration panel in the upper right, which enables you to filter data for all the Dashboard 
tabs and windows, to create a customized view. 

The only information you can view in the Executive, Programs, and Financial tabs comes from root 
programs that you are privileged to read and discover. 

If you are an Executive, you have global privileges. You can view all root-level programs that 
contain matching values for the dashboard category fields. By default, these fields are labeled 
Program Type, Region, Division, Customer, Launch Year, Product Line, Category 7, Category 8, 
Category 9, and Category 10. These are multi-select list fields that can be relabeled and configured 
within the Administration > General Info tab in the Agile Java Client. 

For information on how to configure optional dashboard tabs, see the Agile Administrator Guide. 

Configuring Dashboard Views 
The Configuration panel in the upper right lets you filter the data in the dashboard views to show only 
the information that’s most relevant to you. The notation on the Configuration panel shows which 
filters are currently in place. 

For example, a functional manager who owns a number of resource pools might want to view only 
off-track tasks assigned to people in certain pools. An executive might set the dashboard to show all 
the programs, issues, gates, financial summaries, and resources that apply to a division and region, 
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or view a specified subset. Once the dashboard settings are entered, you only see information that 

g 

ly used for Customer, Market and 
other attributes that are relevant at the top level of the project. 

Note 

satisfies the specified settings. 

You can use the dashboard category fields to rapidly classify tasks and to slice data for reportin
purposes. The values that you set at the root project level are applied down the hierarchy. For 
example, if you set a particular value for Division at the root project level, all the tasks within the 
hierarchy are also set to the same value. These fields are ideal

If a root program has a value set to “All,” then, by design, it will show up in all views no 
matter what value is selected in the configuration view for that field. “All” is interpreted as 
including the specific value. 

 

 

 

Chart Display 

Within a Dashboard table, you can select a chart display type from the Type drop-down list to view 
data in different formats. When you select an option, consider the number of labels that need to be
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displayed within the chart. Label display within the chart can be affected by the number of values 

 o

ats as the display type. 

axi

Note 

retrieved and by the way labels are formatted. 

To ptimize display when the list of data labels is long: 

 Choose Pie, Table, or Polar form

 Maximize the dashboard table. 

 M mize your browser window. 

If the number of labels exceeds the screen area available to accommodate the labels, an 
automatic mechanism computes the number of steps to skip between each label, to 
prevent overlapping. The skipped labels do not display in your view. 

 

Executive View 

ormation on programs where 
an s

Note s data only if you have the Executive role, or have Read privilege 

The Executive tab provides portfolio data for the executive who needs to monitor programs and see 
information rollups by type of program. It provides a cross-section of inf
you c ee the major risks in terms of schedule, resources, and cost. 

The Executive tab contain
for root rams. -level prog

Windows in the Executive tab include: 

gement 

d 
 of 

rams that comprise a segment, pass the mouse pointer over that 

Programs tab with a particular segment of programs selected in all windows, click on 

Note d 

 Program Mana

 Resources 

 Financial 
 

Viewing Program Status 

The Program Management window provides a graph of all active programs the user has configure
to view, showing their overall status (i.e., On Time, Needs Attention, Off Track). For each type
status displayed, the window shows the percentage of programs that have that status. 

To display the number of prog
segment of the chart. 

To display the 
that segment. 

The data in this window does not include programs that are in the Completed or Cancele
states, programs with a Template field setting of Proposed or Template, or programs that 
are archived or soft deleted. 

 

Viewing Resource Allocation 

The Resources window displays a table showing the names of available resource pools and 
associated data, filtered by the settings in the Configuration panel. 
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Pool members who have no current assignments are not counted. 

Resources who are not assigned to any resource pool do not appear on the Dashboard. 

To view the Pool Utilization Summary report, click the Report button beside the pool name. 

To view the user profile of the pool owner, click the owner’s name from the Owner column. If yo
have the required privilege

u 
s, you can edit information about the user and create a Resource 

Note  no d 

Utilization report for them. 

The data in this window does t include programs that are in the Completed or Cancele
states, programs with a Template field setting of Proposed or Template, or programs that 

ted. are archived or soft-dele
 

Viewing Financial Data 

The Financial window displays a table showing cost rollups for the root programs you are 
configured to view. The Financial tab in the Executive view also shows the same table that is 

indow. See "Financial Viewpresented in the Financial w  (on page 38)". 

Programs View 
out all programs that you are involved in, including status, 

grams tab include: 

Pool Utilization by Program 

ch you have access (subject to the filters in the 
me, owner, status, start date and end date. 

bject, click its name. The icon next to the program name indicates the status of 
 On Track or Needs Attention. 

ities required and completed for each gate thus far. (The number 
verables listed on the Content tab plus the number of 

To open a program object, click its name. 

The Programs tab displays information ab
gate progress, and top priority issues. 

Windows in the Pro

 Programs 

 Gate Progress 

 Top Priority Issues 

 Resource 
 

Programs 

The Programs window displays all programs to whi
Configuration panel). It includes the root program na

To change the sort order, click a column heading. 

To open a program o
the program, such as

Gate Progress 

The Gate Progress window shows the gates for each active program, and their status; also, the 
number of deliverables/activ
required is derived from the number of deli
dependencies to the gate.) 
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Top Priority Issues 

The Top Priority Issues window shows issues arranged in order of priority. If an Action Item icon  
appears in the row, it means there is an associated Action Item. Click the icon to open the Action 
Item. 

To view a program’s associated issues, click the program name to open its object, then open its 
Discussions tab. (For further information on the Discussions tab, see "Discussion Table Details (see 
"Discussions Table" on page 82)".) 

To sort issues by a different priority, or view all priorities, use the selection list. 

Note The data in this window does not include programs that are in the Completed or Canceled 
states, programs with a Template field setting of Proposed or Template, or programs that 
are archived or soft-deleted. 

 

Resources View 
The Resources tab provides several views on resource utilization and issues for resource pools that 
you own or for pools that match your privileges. 

To select the resource pools to be considered in this tab, use the category fields in the Configuration 
panel or use the Resource Pools field at the top of the page. 

You can minimize, maximize or close tables and charts in the tab view. When a table is closed, the 
Add Content list appears. Use this list to re-open any table or chart you have closed. 

Windows in the Resources tab include: 

 Resources 

 My Pool Members Top Priority Issues 

 My Pool Members Off Track Activities 

 Resource Pool Utilization by Program 
 

Resources 

The Resources window shows each resource pool’s programs and status, noting items that are 
pending, assigned, or overdue. It also notes resources that are over allocated. 

A pending activity or gate is one that has been delegated to a resource pool but it has not yet been 
assigned to a user in that pool. 

The number of overdue items is a count of all activities or gates that are past the due date, whether 
or not they are assigned to users. 

To edit status for a resource pool (add or remove resources, or create a report), click its name. 

To create a Pool Utilization report, click the icon to the left of the pool name, or click the pool name 
and click Report. 
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Note The data in this window does not include programs that are in the Completed or Canceled 
states, programs with a Template field setting of Proposed or Template, or programs that 
are archived or soft deleted. 

 

My Pool Members Top Priority Issues 

This window shows the highest priority discussions for each Resource Pool, but you can select 
other priorities to display from the Priority list. An icon shows the program status, and an Action Items 
icon appears at the right if there are Action Items. Click a program name to open it. Once the 
program object is open you can go its Discussions tab, and view associated issues. (For further 
information on the Discussions tab, see "Discussion Table Details (see "Discussions Table" on 
page 82)".) 

If there is a discussion thread, only the top level issue is displayed. Click the + symbol to expand the 
display. 

Note The data in this window does not include programs that are in the Completed or Canceled 
states, programs with a Template field setting of Proposed or Template, or programs that 
are archived or soft-deleted. 

 

My Pool Members Off Track Activities 

This window displays Off Track items assigned to pool members of pools that you own, noting 
scheduled due date, actual date, and percent completed. 

To view and update off-track resource pool activities, click the resource pool name. 

Note The data in this window does not include programs that are in the Completed or Canceled 
states, programs with a Template field setting of Proposed, or programs that are archived 
or soft deleted. 

 

Resource Pool Utilization by Program 

This window shows a graph of the resource pool utilization by program, enabling a program 
manager to see where resources are allocated or over-allocated. 

To view program name and percent utilization of resources, pass the mouse pointer over each chart 
segment. 

To view team data, click the chart segment of interest. This opens the corresponding program 
object in the Team tab. 

To view and change report settings, click the Show Report Options link at the top. You can specify the 
chart type, date range, programs to include, and time intervals used in the graph. Every time you 
change field selections, click Refresh to refresh the chart.  

Note The data in this window does not include programs that are in the Completed or Canceled 
states, programs with a Template field setting of Proposed, or programs that are archived 
or soft-deleted. 
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Financial View 
The Financial tab shows charts of capital expense, labor cost, and fixed cost for each root program 
available. The Financial tab also shows the same table that is presented in the Financial window. 

To select the programs to be considered in this tab, use the category and status fields in the 
Configuration panel. 

You can minimize, maximize or close charts in the tab view. When a chart is closed, the Add Content 
list appears. Use this list to re-open any chart you have closed. 

My Activities View 
The My Activities tab displays activities that you own or are participating in. 

To select the activities to be considered in this tab, use the category and status fields in the 
Configuration panel. 

You can minimize, maximize or close tables and charts in the tab view. When a table is closed, the 
Add Content list appears. Use this list to re-open any table or chart you have closed. 

Windows in the My Activities tab include: 

 My Assignments 

 My Documents 

 My Action Items 

 My Issues 

 Notifications 
 

My Assignments 

The My Assignments window lists the programs, phases, tasks, and gates that you either own or 
are an assigned resource thereof. 

To change the sort order (view assignments alphabetically, sort by start or end date), click on the 
heading of the desired column. 

My Documents 

The My Documents window lists all program-related documents that you own, with the document 
description, size, and other data. 

To open a file, click the file name. 

My Action Items 

The My Action Items window displays all your action items, along with status and due date. 
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If the action item is associated with a program object or discussion object, these appear in the 
Belongs To column with iconic indicators. Click the link in the Belongs To column to open the 
associated object. 

Click the name of the action item in the Subject column to open the action item. 

To see details of your issues, click the name of the program of interest, then select its Discussions 
tab. 

My Issues 

The My Issues window includes all discussions you have created for the selected set of programs 
(not just your top priority discussions). The data includes the program name, issue number, and 
issue title. 

To see details of your issues, click the name of the program of interest, then select its Discussions 
tab. 

Notifications 

The Notifications window displays your notifications, including the type and description, sender, and 
date received. Agile PLM can be configured to automatically send notifications to users either when 
the user is required to take action or to notify the user that an action has taken place.  

Note  Notification settings must be configured and enabled in Java Client by an administrator.  

To see details of your notifications, click the link in the Subject field. 

Important If an action triggers multiple notifications to the same user, the user will receive only one 
notification. For example, if the triggering action is the status promotion of a routable 
object, and Bob is an approver, and  Bob is added to the Notify list when the object is 
promoted, Bob is now specified as a recipient of notifications as both an approver and as 
a person on the notify list. However, Bob will receive only one notification related to this 
triggering action. 

 

Dashboard Management Administration Tasks 
If your Agile administrator has given you Administrator privilege applied to Dashboard Management, 
you can use the Tools menu (Tools > Administration) to modify system-wide settings that determine 
which available tables to display on each tab and the order in which they are displayed. 

Caution Any Dashboard Management modifications you make affects every Agile PLM user. If you 
display a particular table, then every user can see that table in their dashboard. If you hide 
a particular table, then no one can see that table in their dashboard. 

Note In order to make Dashboard Management modifications, you must have the appropriate 
Administrator privilege. For more information, see the Agile PLM Administrator Guide. 
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PPM Reports 
Agile PPM includes a set of standard reports for use in analyzing program health. PPM reports are 
not part of the Dashboard. You can select the PPM report you want to use in the navigation pane of 
the Agile PLM window. 

About Agile Standard Reports 

Reports allow you to display the values of your Agile programs and product records. By accessing 
this information and summarizing it in a meaningful way, reports provide insight into your business 
processes and can help guide better-informed decisions. Agile PLM provides a robust reporting 
platform that allows you to: 

 Measure and monitor business performance using standard out-of-the-box reports. These 
standard reports capture the best practices in product lifecycle management business 
processes. 

 Configure reports with Agile’s custom reporting to obtain the specific information you need. 

 Use a single point of access to all relevant reports—even those developed outside of the Agile 
PLM application— through Agile’s external reporting capability. 

For detailed information about using all types of Agile reports, see the Getting Started with Agile 
PLM Guide, which includes information about: 

 How your roles and privileges affect reports 

 Report object tabs 

 Creating and modifying report layouts 

aving, and deleting reports 

Report output window 

Note  

 Creating custom and external reports 

 Running, scheduling, s

 

Your browser may have default security settings that compromise report display. If you
are using Internet Explorer with Windows XP, add the Agile site URL as a trusted site 
within the Tools > Internet Options > Security tab to enable proper downloading of reports. 

 

Agile Standard Reports for PPM 

This section discusses the Agile standard reports that are included as part of Agile Product Portfolio 

1. Reports, or in 
ain 

Management. 

To access program reports:
Open the Navigation Pane to the left of the Dashboard, and select Analytics and 
the m toolbar, select Tools > Reports to display the Reports navigation pane. 

Note The analytics option is only available for licensed Analytics users. 

2.  Expand the report tree and navigate to Standard Reports > Program & Portfolio Reports. Agile PPM
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standard reports are organized into subfolders under the Program and Portfolio Reports folder.  

Click on the report you wish to view. Available reports are listed here for your reference. For 
details on selecting report param

3. 
eters, using searches, and executing reports, see the Getting 

grams that a lete or Canceled are not li on. 

Started with Agile PLM Guide. 

Note Pro re Comp sted for selecti

PPM Report  
Fo lder  

Report  Descr ipt ion 

End User Reports My Open Action Items ciated with issues All the open action items asso
and tasks that are asto you.  

My Activities and Utilization  All your task assignments.   

 My Discussions  the priority All open discussions owned by you with
selected when you execute the report. 

 My Documents s for which you are the Creator or All the document
Checkout User. 

 User Time e the specified user has All the programs wher
entered Actual Time. 

Portfolio Reports Portfolio Cost all the root programs to which you Cost report of 
have access. 

 Portfolio Cross Program De activities that have external Report of all the 
dependencies.  

 Portfolio Deliverable Gate Report of all the Gates and their dependent tasks 
and deliverables in the portfolio of root programs.  

 Portfolio Priority Discussions e open discussions in your portfolio Report of all th
of programs. 

 Portfolio Status f all the root programs to which you Status report o
have access. 

Program Reports Program Open Action Items Report of all the open action items associated with 
discussions and tasks of the selected root program.  

 Program Deliverable Gate Report of all the Gates and their dependent tasks 
and deliverables in the selected Root Programs.  

 Program Documents ll the documents of the selected Root Report of a
Program.  

 Program Off Track Activities  Report of all the activities based on the selected
health status within the selected root program.  

 Program Schedule l the activities of the The schedule report of al
selected root program.  
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PPM Report  
Fo lder  

Report  Descr ipt ion 

Program Top Discussions Report of all open discussions with priority you 
select, within the r

 
oot program you select.  

Program User Assignments Report of assignments of a selected user withi
selected root pro 

n a  

Baseline Comparison Report of comparison of the baselines for the 
selected program. . 

 

Program Actual vs. Budgeted 
Cost ected program.   

Report of the Actual Cost and Budgeted Cost for 
the sel

 

Resource Pool 
Reports

urce Pool Member Report Report of all the resources of the selected reso
pool. 

Resource Pool Utilization Report of all your task assignments for all root 
programs and programs.  

 

Resource Pool Consumption Report of the resource pool consumption during the 
specified time pe 
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Chapter 4 

Creating and Managing Programs 

This chapter includes the following: 

 About Programs................................................................................................................................................... 43 
 Creating Program-related Objects ....................................................................................................................... 44 
 Editing Program Objects Concurrently ................................................................................................................ 47 
 Creating a Project Environment: The Actions Menu............................................................................................ 49 

 
 

About Programs 
Agile Product Portfolio Management provides many tools a Program Manager can use to schedule 
and track a program, including the means to send automatic reminders to team members when they 
have tasks due, maintain a record of project-related discussions, or let team members know when 
aspects of the projects have changed. 

You can start “from scratch” by creating a new program structure in PPM, or import an existing 
Microsoft Project file. For detailed examples showing this process in action, see "Creating 
Programs: A "Real World" Example (on page 127)". 

Setting Up a Program Structure 

When creating a new program, the easiest way to build the structure is to start at the top and work 
down. At a minimum, you need: 

 Parent program object 

 Child activity objects 

 Designated program “gates” 

 Pool of resources (project team members) 

You can store program specifications and requirements documents with the parent program object, 
to make it easy for program members to locate them. 

The general procedure is to create the root-level program first and then create the child objects. 

The table below shows the general workflow for creating a program structure. 

Start ing “f rom scratch” in  Agi le  PPM Port ing  an  Exist ing  Program f rom 
Microsof t  Pro ject  

1.Create the root-level program object using one of 
the methods described in “Creating Program-related 
Objects.” Be sure to specify Program as the object 
type. 

1. Publish the program’s Microsoft Project file into 
Agile PPM, as described in "Creating a program 
in PPM from an existing Microsoft Project 
file (see "Creating a PPM Program from an Existing 
Microsoft Project File" on page 108)." 

Agile Product Lifecycle Management Page - 43 

 

 



Product Portfolio Management User Guide  
 
 
 

Start ing “f rom scratch” in  Agi le  PPM Port ing  an  Exist ing  Program f rom 
Microsof t  Pro ject  

2. Create the first child object. Go to the Schedule 
tab of the new program object, and click Add. Create 
the first child object. All objects created from the 
Schedule tab are children of the current object.  

 

3. Repeat the process to create additional children, as 
needed. 

 

4. Open each child object and create its children, as 
needed. 

 

5. Set gates to delineate the completion of key 
program goals. 

 

6. Map existing dependencies between program 
objects. 

2. Re-set any dependencies that were not originally 
entered as “Finish to Start” dates. 

  

Once you have the structure in place, you may want to save it as a template, to make it easier to 
create future programs; see "Using Save As to Create a Template (on page 50)“. 

Note You can also create program objects working from the project Gantt Chart. For further 
information, see "Gantt Chart (on page 87)". 

 

Creating Program-related Objects 
You can create a number of program-related objects in Agile PPM. A program-related object can be 
the parent program itself, a gate, phase, or task. 

The PLM user interface gives you four different ways to create a program-related object: 

 Use the Create menu to define the program object “from scratch”, or from a template. 

 Open an existing program object and choose Save As. 

 Open the project Gantt Chart and click Add Activity, as described in "Adding Activities (on page 
97)". 

 Import an existing program from Microsoft Project, as described in "Working with Microsoft 
Project (on page 107)". 

 Open the Schedule tab of a program and click Add, to add an activity using the Add Activity 
wizard.  

 

Using the Create Menu 

You can create new programs from the Create menu, either directly or using a template. If you 
choose to create a program that is based on an existing program template, be sure to read the 
considerations listed in “Cloning Deliverables (on page 79)” before you begin. 
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To create a new program object or template: 

1. Launch Agile Web Client. 

2. Go to the main toolbar and click the Create menu. 

3. Select Programs > New. The Create Project_Activities Wizard appears. 

4. Click the Activities Type drop-down list, and select the desired activity type. 

5. Fill in the required fields, such as Name, Schedule Start Date, and Schedule End Date. Click the 
 icon next to date fields to select the appropriate dates. 

 To continue using the Create wizard to enter information on each tab of the program, 
check the Continue Creation in  Wizard checkbox, and click Continue. Follow the onscreen 
instructions to complete the wizard as described in step 6 below 

 To create and display the program immediately, clear the Continue Creation in  Wizard 
checkbox and click Finish. The new program appears with its General Info tab displayed. Fill 
in information on program tabs, as desired. 

6. On the General Info page, enter information for the following: 
 Rollup Health Status -- If you want this information rolled up to parent objects, select Yes. For 

more information, see “How Status Roll-Up works (on page 5)”. 
 Template -- If you are creating a new template (not saving an existing template with a new 

name), select Template in this field. 

Note You cannot change the status of objects which have the Template value set to 
Proposed or Template.  

7. If you want to add an attachment to the object, click Next. Otherwise, click Finish. The General 
Info tab of the new object appears. 

If you create a new template type program, you can edit the owner field on the General Info tab and 
change the owner for that activity. 

When you create a program from a template, the owners of all activities are copied from the 
template. If an Active program is created from the template, notifications are sent to the respective 
owners of the activities. 

To create a new program object from an existing template: 

1. Launch Agile Web Client. 

2. Go to the main toolbar and click the Create menu. 

3. Select Programs > From Template. The Program Creation Wizard appears. 

4. In the Select Template page, select the template you want to use to create the program and click 
Next. 

5. In the Details page: 
a. Enter a name and description for the program. 
b. Specify the new owner of the program. The default owner of any activity in the program is 

the owner specified for that activity in the template. Select the Apply to All Levels checkbox if 
you want this user to own all the child program-objects as well. 

c. In the Schedule field, select a start date or end date for the program. If you provide a 
duration, PPM will automatically calculate dates based on the start or end date provided.  

d. In the Template field, select Proposed. You can change the status to Active when you are 
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ready to roll out the program. Your selection here can have implications on the 
Autonumber attributes of the new program. For more details, see “Cloning Deliverables (on 

e. 
re cloned when you select the Content checkbox, 

page 79)". 
Select the optional components of the template that you want to have in the new program. 
For more details on program objects that a
see “Cloning Deliverables (on page 79)". 

Click 6.  has a 

x when the process completes. You can open the program directly from the 
notification link. 

Identifying the Template Used to Create a Program 

 
child activities. You can click on this link to open 

ated from 
Template

ld 

k. If you perform a Save As operation on any level lower than the root level, the 
field is left blank. 

schedule, structure, team, dependencies, deliverables, attachments, and general information. 

 current activity under a new name. 

3.  Click Finish when done. The General Info tab of the new activity appears. 

 on 
the state change of one or more deliverables. A gate is a leaf node, meaning it has no children. 

t that point, it becomes Open, which means that the program 

A gate is created as the child of another program element.  

Finish to complete program creation. If the program that you are using as a template
large list of deliverables, select the Run as a background process check box. You can then 
continue working on other programs while the new program is being created. A notification is 
sent to your Inbo

 

If a program is created from a template, a link to the template is provided in the Created from Template
field in the General Info tab of the program and its 
the template that was used for program creation.  

After creating a program from a template, if you add child activities to this program, the Cre
 field for these activities will be blank as these are not created from the template. 

If you save an existing Template as a Proposed or Active Program, the Created from Template fie
shows the name of the original Template. If you save an existing Template as another Template, 
the field is left blan

 

Using the Save As Command 

You can use the Save As command to duplicate an activity and all its information, including 

To use Save As to create a new activity: 

1.  Choose Actions > Save As to save the

2.  Select which components to copy. 

 

Creating and Using Gates 

A gate is a special PPM object representing a point in time that denotes the completion of a set of 
related activities, such as a phase or some other set of tasks. Gates usually change state based

The status of a gate can be Closed or Open. The default is the Closed state. A gate is closed until 
all its deliverables have been met. A
can now proceed through the gate. 
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To create a gate: 

 Go to the parent activity. 1. 

bject, click Add and specify Gate as the object type. The 

ntent

2.  On the Schedule tab of the parent o
Add Activity wizard appears. 

3.  Fill in the information for the gate. 

4.  Click Finish. The General Info tab of the new gate appears. 

You can add deliverable objects to the gate, which can be used to control the status of the gate. 
The Content tab displays objects and deliverables that are required for the review and approval 
process of the Gate object. See "Adding Co  (on page 77)". 

he dependencies are accounted 

e dreds of activities and 
 for multiple users to edit the following: 

me. 

 The same task at the same time. 

e edit modifications may 
have affects on objects higher in the program tree (rollup) or lower in the program tree (rolldown). 

es his modifications, the 
rollup or rolldown takes place. In this scenario, it is possible for a user to enter a specific 
 edit page, yet see a different date upon save because of the rollup or rolldown caused 

Exam

 g 
right after the other. 

 

 
 for the parent or child activity 

nd 

You can also add dependencies to a gate, as with other activities. T
for in the rescheduling of the project plan.  

Editing Program Objects Concurrently 
Th  Agile PPM solution is designed to manage large programs with hun
numerous team members. It is possible

 Multiple tasks in the same project tree structure at the same ti

 

Editing Multiple Tasks in the Same Project Tree 

When multiple tasks in the same project tree are edited at the same time, th

Editing Tasks with a Predecessor and Successor Relationship 

When a parent task is rescheduled to a specific end date, that end date rolls down to the child 
objects. You can also edit a child object end date, which then extends the bounds of the parent 
object (by rollup to the parent object). As each user makes and sav
necessary 
date on the
by another user’s edits. However, the schedule remains accurate. 

ples 

Task B (owned by Bob) is a predecessor to task A (owned by Mark). Bob and Mark are editin
the schedule dates of their tasks at the same time, and save their edits one 
If the new edited dates of the first saved task cause the dates of the second saved task to 
change, the person saving the second task is presented with a message explaining that the 
dates he entered will be changed and he can accept the change or cancel. 

Mary is editing a parent activity and several other users are editing several child activities at the 
same time. Mary reschedules the specific end date of the parent activity. At the same time, 
some of the child activities have been modified in such a way that the end date of the parent
activity is extended. As each edited activity is saved, the dates
are updated correctly for schedule accuracy. It is possible that a user may save his activity a
see a different date than the one he entered on the edit page, but the schedule is accurate. 
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 common parent, 

task M, thus they are both in the same tree structure. Both Susan and Fred are editing their 
 M (percent complete, cost, or status data). 
cording to Fred’s edits. Then Susan saves task 

Lock 

New roll-up data overwrites a common parent or root activity. 

Susan owns task C and Fred owns task D. Both task C and task D have a

tasks, modifying data that rolls up to parent task
Fred saves task D and task M is rescheduled ac
C, and task M is again rescheduled, this time according to Susan’s edits. 

Multiple Users Editing the Same Task 

To keep other users from editing roll-up or roll-down attributes of the object you want to edit, use the 
 feature. Locking an object means that only you can edit roll-up and roll-down attributes and 

use ollup 
and rolldo  and 
you have

other rs who edit the object are “locked out.” Although they can edit attributes that do not r
wn, they cannot edit roll-up and roll-down attributes until you have finished your edits

 unlocked the object. 

Note When you use Launch in Microsoft Project or Gantt Chart, Agile automatically locks the 
project. When you update from Gantt Chart or Microsoft Project, Agile automatically 
unlocks the project. 

In contrast, when you use Edit on the Cover Page, you must click Lock  before you click Edit if you 
want to lock the object. The differences between locked editing and unlocked editing are explained 

Whe sk before entering edit mode, Agile provides the following 

 

rl’s edits may be overwritten. 

 The ption. Even though it is not a rollup attribute, 
 the lock user may edit this attribute. 

e ependencies (both external and internal) are locked; the 

below. 

Locking Tasks for Editing 

n a user (Mary) locks the ta
safeguards when a second user (Carl) edits the same task: 

Carl sees a message “This activity is currently locked by another user. For this reason some 
fields will not be editable.” 

 While in edit mode, Carl can edit only non-rollup attributes on the Cover Page, Page Two, and 
Page Three. Carl can save his edits. When Mary saves her edits, Ca
The most recent update of non-rollup attributes overwrites the others. 

Name attribute on the Cover Page is an exce
when the task is locked, only

Not  When you lock an object, its d
successors and their children are locked. 

To lock and edit an activity object: 

1.  Open the object you want to edit. 

2.  Click  Lock. 

3.  Click Edit on the Cover Page tab. 

. 

age tab. 

4.  Make your desired edits

5.  Click Save on the Cover P
6.  Click  Unlock. 
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Editing Unlocked Tasks 

If you do not lock a task before editing it, the same safeguards do not apply.  

For example, let's assume we have two users, Joe and Carl. When Joe enters edit mode for a
, and Carl then enters edit mode, the following applies: 

The second user, Carl, does not see a warning that another user is in edit mode

 task 
first

 . 

 want 

 
e been modified in a manner that extends the bounds of the parent, no messages 

ut the schedule information 
is correct. 

hange 
ges and 

n done in parallel. 

roject Environment: The Actions Menu 
 has the following commands: 

e 

Some of the above commands, such as Bookmark and Subscribe, are useful with all Agile objects; 

 Regardless of who entered edit mode first, the user who saves first will update the Agile 
database with his modified data. The second user who saves receives the following error 
message: “The current object has been modified by another user, please try again. If you
to ensure that your changes are saved, please lock the object prior to editing.” 

If the unlocked parent object has been rescheduled to a specific end date, and any child 
objects hav
are presented, and each modification is saved. The appropriate roll-up or roll-down date 
modifications are performed. It is possible that the date information that a user saves might not 
match the date he entered (due to edits made by a different user), b

 The exception to the above behavior is when two users edit the task status (use the C
Status button) or two users add to the Schedule at the same time. Multiple status chan
schedule additions are accepted and saved whe

 

Creating a P
The Actions menu

 Bookmark 

 Subscrib

 Save As 

 Delete 

 Print 

 Send 

 Sharing 

 View workflows 

 Delegate 

 Substitute resource 

 Change parent 

 Change archive status 

 Reports 

they are described in detail in the Getting Started with Agile PLM Guide. 
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Other commands are discussed in the following sections. 

ubscribe to vary per object. Product Portfolio Management has the following 
n events that do not apply to other objects: 

-
se Page Two and Page Three fields can be defined 

s, phases, and tasks, any of the attributes that do not apply are ignored. 

 of existing objects in new objects 
e new program as owner of all 

ate 

1.  Open the program you want to save as a template. Choose Actions > Save As. 

 template appears. 

Note

Subscribing to Events 

The events you can s
Activity-specific subscriptio

 Add Discussion 

 Reply to Discussion 

 Add News 

 Add Action Item 

 Modify Schedule 

The Apply to Children checkbox in activities and gates “push” a subscription to all child objects. If you 
subscribe to an activity that has a schedule and select this checkbox, you will automatically 
subscribe to all of the activity’s programs, phases, and tasks (that is, any object created in the out
of-box subclasses of Activities class). Becau
differently for program

Using Save As to Create a Template 

You can use Save As to duplicate values and other dependencies
or templates. The Save As command will replace the creator of th
activities for the newly created program. 

To cre a template: 

2.  Select the components you want to include. 

3.  Select Template in the Template drop-down list. Click Finish. 

The General Info tab of the new

 Discussions, action items, and history are not included in the template. 

Once saved as a template, a program does not appear on active program lists. However, 
lable 

ate 

Delegating Ownership 

e er by default. The Delegate command 

 element retains ownership of lower level items 

documents continue to be stored for the program on the Attachments tab. The template is avai
to cre new programs using the Create > Program > From Template command. 

Wh n you create a program element, you are made its own
enables you to change ownership of a program element. 

Note An owner of a higher-level program
reporting to it, even when ownership of the lower level is delegated to another team 
member. 
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To delegate ownership of a program, phase, task, deliverable, or gate: 

1. Open the activity you want to assign to a new owner. 

2. Cho se Actions > Delegate. 

 not listed, add him or her to the team at this time. Click the Add 

o

3. Select a new owner from the team list. 

4. If the intended new owner is
button on the Delegate Ownership page, then select the user in the Select Delegate list. 

A gray  icon appears beside the General Info tab link. It remains until the delegated owner has 
d the deleg Delegated Owneraccepte ation, thereby becoming the owner of the activity. In the  field, the 

 ico isplays next to the delegated user’s name. n d

When the del e PLM, he or she receives a in the 
Notifications request in the My Ass ation is 
a

egated user logs in to Agil
 tab, and a corresponding 

delegation notification 
ignments tab. Once the deleg

ccepted, the  icon is cleared. 

 the delegated owner has not yet accepIf ted th  > Delegate to choose 
a different user as the delegated owner. 

Note ns > Delegate and select the original owner as the 

e delegation, you can use Actions

 To cancel the delegation, use Actio
delegate. 

Act ion  or  condi t ion  Resul ts  or  consequences 

The program is not active (the Template field 
setting on the General Info tab is not equal to 
Active). 

Or 

The program is active, but its status is Not Started. 

Note: To start a program (move it to the In 

 
ities. 

No delegations are sent to the delegated owners. Delegations are 
sent only when the program is Active. 

 

Process status), change the status of one of its 
leaf activities. You cannot directly change the
status of an activity if it has subordinate activ

The new owner’s name appears in the Delegated Owner field on 
the General Info tab. 

 The gray  icon appears beside the General Info tab name 
indicating that the program has been delegated, but the delegation 
has not been accepted. 

A current team member is selected as the new 
owner, but has not yet accepted. 

A user who is not a current team member is 
selected as the new owner, but has not yet 
accepted. 

 The new owner’s name appears in the Delegated Owner field on
the General Info tab. 

The gray  icon appears beside the General Info tab name 
 delegation 

ner 

indicating that the program has been delegated, but the
has not been accepted. 

Because the delegation has not yet been accepted, the new ow
does not appear on the Team tab. 
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Act ion  or  condi t ion  Resul ts  or  consequences 

The delegated user accepts the deleg
My Assignments tab. 

ation in the The gray  icon beside the General Info tab name is removed. 

If the delegated owner was not a current team member, he is 

automatically added to the delegated owner’s assigned roles. By 
default, the default owner role is the Program Manager role, 
however, your Agile administrator may set a different role. For 

added as a team member on the Team tab. 

On the Team tab, the Agile PPM default owner role is 

more information, see the Agile PLM Administrator Guide. 

eside the General Info tab name is removed. The delegated user rejects the delegation. The  icon b

The Delegated Owner field on the General Info tab is empty. 

 
 

Substituting Resources 

You can use the Actions > Substitute Resource command to substitute one resource for another.  

To substitute one resource for another: 

 resource to be replaced in the From Resource drop-down list. The list contains all team 
members including those assigned to child activities. 

ce field and use the 

1. Choose Actions > Substitute Resource. 

2. Select a

3. Click the To Resour  button to select the substituted resource. If you want 
source in all the child activities, select the Apply to Children checkbox. 

is assigned to the substituted resource. 

ted activity only if the % allocation is zero.  

to substitute the re

4. Click Substitute. The replaced resource’s role 

Note You can substitute a resource on a comple
 

Changing the Parent 

You c change the parent of a program element. For example, you can change th
A, so that it reports to Task A instead of Task B, or have Phase A report to Program 2 in

an e parent of Gate 
stead of 

vity: 

to locate the new parent. 

bject, and click Change. 

ship of a program element also changes the rollup status, dates, and 

Program 1. 

To change the parent of an acti

1. Open the activity. 

2. Select the Actions > Change Parent command. 

3. Use one of the search options 

4. Select the new parent o

Changing the reporting relation
progress to those of the new parent.  

Note You cannot change the parent of an activity that is in Completed status. 
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Archiving Programs 

Programs are archived by changing the root-level program’s archive status. 

nge the archive status of a root-level program from the Actions menu. Archiving old data 
can improve system performance. 

 status: 

2. Select Actions > Change Archive Status. 

m all active program lists and from the program 
navigation tree. All buttons and Actions menu choices are grayed out, except for Actions > Change 

and to view the Program Resource Utilization and 

 analytics opt lytics. 

You can cha

To change the archive

1. Select a root-level object. 

When a program is archived, it is removed fro

Archive Status. You can select this option again to remove the archive status. The archived 
program’s data remains searchable. 

Reports 

Use the Actions > Report and Analytics comm
Schedule Reports. 

Note The ion is available only if you have installed Ana
 

m Resource Uti

 Resource Ut ys Effort and Percentage Utilization for 
nd resource po  into account allocations across all child 

 of the program.  

ategorizes the d users who are not 
ny resource  fully 

 categorized a

Progra lization Report 

The Program
resources a

ilization report shows you Da
ols within a program, taking

objects

This report c  Resource % Allocation by resource pools an
pools as No Pool. All the tasks for which resources have not been
s Unassigned. 

members of a
assigned are

Fields  Descr ipt ion 

Root Program f the activity type such as program or phase. Name o

Owner The owner of the activity. 

Scheduled Start/End The scheduled start and end dates of the activity. 

% Complete The % of the activity completed. 

Status The workflow status of the activity. 

Report Type ogram Utilization report. Type of report; defaults to Pr

Display Type Select the type of chart: Table, Line, Area, Stacked Area, Bar, Stacked Bar, 
Stair. 

Start/End Dates The start and end dates for duration-based assignments such as phases and 
tasks. 
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Fields  Descr ipt ion 

Pool Select the resource pools assigned. By default all the existing pools are 
selected. But you can change the selection to filter the data displayed in the 
report. 

Reporting Intervals Report by day or other interval. 

Display Values By Select the type of report data you wish to see for the selected criteria - Days 
Effort or Percent Utilization. 

Include allocations from 
proposed Pr

Select this check box 
state. The list in the Pool ograms

to view allocations from programs that are in the Proposed 
field ch odate additional options. 

Change the selection as required
anges to accomm
 to filter data. 

To apply changes to filter

To print the report, click th

 the report, click the 

Schedule Reports 

tions > Report and An
reports provide a complet  and ownership can be selected 
to apply filters to the list of activities. 

You can customize the report by selecting values in the Owner, Status, and Health fields. 

The schedule report has the following fields: 

 criteria, click Refresh. 

e  button. Print

To export
separated value format (.

Export to CSV button. The report will be exported into the comma-
CSV), which can be opened in Microsoft Excel. 

The Ac alytics > Schedule option opens the Schedule Reports page. Schedule 
e view of the schedule. Values for status

Field  Descr ipt ion 

Name The number of the program. 

Description The schedule description. 

Owner The program owner. 

Schedule Contains information that enables you to quickly track Program progress. Tells you 
the targeted start and finish dates as well as the duration remaining until Program 
completion. The Complete subfield tells you to what percent the Program is 
complete. 

Actual Actual varies from Schedule in so far as you are ahead or behind targeted Program 
dates. It tracks actual time spent on a Program. 

Click the Print button to print the report. 

For descriptions of other reports, see “PPM Reports (on page 40)”. 

Changing Workflow Status 

The Change Status button lets you change the workflow status of leaf objects (objects that have no 
children). The status of parent objects cannot be changed directly, since it is changed by rolling up 
the status from leaf-level objects. You must have the appropriate privileges; by default, the Program 
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Manager and Program Administrator roles have the required privileges. 

The Change Status button is only available for objects whose Template field is Active in the General Info 
tab. You cannot c
Changing the Tem
moved to the Tem

hange the status of objects whose Template field is Proposed or Template. 
plate field must be done at the parent level, and child objects are automatically 
plate value of the parent. 
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Working with Program-related Objects 

This chapter includes the following: 

 Accessing Program Objects ................................................................................................................................ 57 
 Viewing Project Summary...................................................................................................................................
 Viewing General In

. 58 
formation ............................................................................................................................... 62 

................................................................................................................................................. 71 
ing Content ............................................................................................................................................... 75 

anaging .... ..... 81 
aging .... ..... 81 
aging ....... ..... 85 

 Viewing Hi ............ 85 
 
 

Accessing Program Objects 
You can manage program-related objects from the f

 Managing Schedules ........................................................................................................................................... 65 
 Managing Dependencies ..................................................................................................................................... 68 
 Managing Teams
 Manag
 M
 Man
 Man

Workflows ..................................................
Discussions................................................
Attachments ............................................
story ...................................................

................................................................................

................................................................................

................................................................................

.....................................................................................

ollowing tabs or pages: 

Tab/Page Tasks 

Summary View overall program informatio
selected activities. See “Viewin

n, perform actions on or navigate quickly to 
g Project Summary (on page 58)”. 

General Info View and edit general informatio
and other attributes configured i ing General 

n about the program, including activities, status, 
n Administration. See “View

Information (on page 62)". 

Schedule Manage the schedule of individual activities within the program, create baselines, 
and analyze the impact of changes. See “Managing Schedules (on page 65)”. 

Dependencies Create and manage dependencies between various program-related activities. 
See “Managing Dependencies (on page 68)”. 

Team Manage resources for a program. See “Managing Teams (on page 71)”. 

Content View and manage all program-related content, including deliverables. See 
“Managing Content (on page 75)”. 

Workflow View workflows and sign-offs, and assign approvers, observers, and notifiers as 
necessary. See  “Managing Workflows (on page 81)”. 

Discussions Create or join program-related discussions and view action items. See 
“Managing Discussions (on page 81)”. 

News Share news and information. 

Attachments View, edit, and manage attachments that are required for program execution. See  
“Managing Attachments (on page 85)”. 
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Tab/Page Tasks 

History View program history. “Viewing History (on page 85)”. 

 
 

Viewing 
When you first ct with his 
is a consolidate ecut n 
use this page to , s can 
comprise all pa s, is view 
is not available on leaf-level activities and gates. 

The Summary page contains several ‘widgets’. Each 
information and action buttons for a specific aspect of the proje t, as configured by an administrator. 
For example, a “Project Gates” widget may provide u
gates (milestones) for that program and deliverables  
Activities” widget may list upcoming activities and pr  can 
use to add an action item to be performed for an act

gure the  appropriate privilege
ge gile PL

Project Summary 
open a program, or a child obje
d view of project information. Ex
 quickly review current information

rent-level objects (programs, phase

in a program, the Summary view displays. T
ives, task owners and program managers ca
tatus, and health of a project. This view 
 and tasks) that have child activities. Th

widget provides users with customized 
c

sers visibility into the status of the project 
 associated with those gates. An “Upcoming
ovide an “Add Action Item” button that you
ivity. 

Summary view, you need
 configuration steps, see the A

s. For details on privileges and 
M Administrator Guide.

To confi
summary pa
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Summary Page Ac

 perfor n the

Most widgets c an use rm 
necessary actions on a et, you 
can click Manage Content to take you directly to the Co

Some objects have a 

tions 

m the primary actions required o

ontain action buttons that you c
selected program object. Fo

 program directly from the Summary view.   

to navigate to the relevant tab to perfo
r example, in the Important Content widg
ntent tab in the Details View. 

You can

 icon next to them. You can  
actions on that object as configured by an administra ields 
that display in the Show Details dialog, see the section le PLM 

trator G

The contents o ou e 
table below. 

click this icon to view details and perform
tor. For details on how to configure the f
 “UI Configuration Data” in the Agi

Adminis uide. 

f each widget and the actions that y  can perform within each are explained in th

 Widget  Descr ipt ion Act ions Avai lab le  

Project 
ary

A quick overview of the project. Displays 

ect Manager, Project 
so on. 

from your local 

s 

ers, and only on the root program. 

widget. The attributes that display here are 
configured by an administrator within the Tools > 

tion page. You must have Modify 
ge to edit these values. For details, see the 

Add image - Insert an image file 
Summ drive. Click Add Image to browse and select an 

image file from your local drive. The image file i
data for attributes associated to project 
activities, as configured by an 
administrator. For example, Project 
Priority, Proj
Objectives, Current Phase, and 

automatically resized if it exceeds the allotted space 
and resolution. 

Replace Image - Replace the current image file 
with another. 

Image editing options are available only to root 
program manag

Edit -Edit the attribute values displayed within the 

Administra
privile
Agile Administrator Guide. 
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 Widget  Descr ipt ion Act ions Avai lab le  

Upcoming Helps you keep track of immediate 
Activities requirements. Lists project activities and 

en Action Items associated to the 
Activity being vie
activities. Table 
by default these 

Add Action Item - Create a new Action Item for the 
activity being viewed currently. Click Add Action 

t to display upcoming action 
items and activities, or items that need your 
immediate attention. For example, you can use the 

t 

After selecting an option, you can additionally 
in the 
ield is 

tion 
item. Click the icon next to the activity or action item 

nd 

and Action 
Items

action items that are either overdue, or 
will be due within a specified timeframe. 
You can view leaf-level program objects 
(including gate sub-classes) that are in 

 Progress states, and 

Item to open a dialog where you can create the new 
action item. 

Filter -Filter the list using the options within the 
Show drop-down lisNot Started or In

Op
wed and its child 
columns are sortable; 
are sorted by Due Date. 

My Activities and Action Items option to filter the lis
by items for which you are the assigned owner. 

narrow down the results by entering a number 
due in — days field. The default value in this f
7 (days). 

Show Details - View Details of the activity or ac

to open a dialog where you can view details a
optionally perform additional actions on that object, 
as configured by an administrator. 

Recent 
Discussions

Displays a list of , open 
discussions that 
specified time fr
particular discussion, the thread of that 
discussion displ
of the window a

Add - Create a new discussion to be associated 

izard and enter discussion details. You 

 join 

ssage. Click Reply 
on the right-hand side of the selected discussion 

 
ssion. You 

can edit the Notify List field in the dialog to change 
. 

 recent
occurred within a 

ame. When you select a 
with the current Activity. Click 

ays in the bottom pane 
s a preview. 

can select the list of users you wish to include in the 
discussion and notify them. 

Add to open the Add 
Discussion w

Join - Join an existing discussion. Select the row of 
the discussion you wish to join and click Join to
the discussion. 

Reply - Reply to a discussion me

row to open a dialog where you can enter your 
response. You can edit the subject of the message 
if you want. By default, the response will be sent to
all users currently included in the discu

the list of users who will receive the response

Project Displays the foll

A list of Gates a

A list of delivera
a given Gate. 

If you have creat
subclasses to es
can configure th
Gate subclasses
details, see the 
Guide.

Quick Navigation - Click the name of a listed gate 
avigate directly to the General Info tab view of 
 gate. 

Expand or Collapse - Expand or collapse the view 
n 
h 

ay take some time, depending on 

owing: 

nd their due dates. to n
that

Gates

bles and their status for 

ed multiple Gate 
of the Gate Deliverables table.  Click on the + sig
next to a gate to view deliverables associated wit

tablish milestones, you 
is widget to display the 

it. This action m
the number of deliverables defined. 

 you wish to view. For 
Agile Administrator 
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 Widget  Descr ipt ion Act ions Avai lab le  

Important Displays a list of
 added to th
from the C

g Con

 content objects that 
Content were

view 
e Important Content 

ontent tab. See 
“Viewin tent (on page 76)”. Manage Content - Click M

Quick Navigation - Click the content object name 
ral Info tab for that 

anage Content to 

en to open or download a 
chment. 

to navigate directly to that Gene
object. 

navigate to the Content tab of the activity being 
viewed. 

Open files - Click Op
content object that has a file atta

Project 
News

Displays project
team members and resources informed 

ject inf
y currently 

d a subject and news text. 

t. You can multi-select 
e them. 

-related news to keep Add - Click Add to open a dialog where you can 
create a news item related to the activit

about pro ormation.  being viewed. You can ad

Remove - Select a news item and click Remove to 
remove it from the widge
items in the list to remov

Team 
Contact 
Info.

Displays the tea
with the selected
contact informat
members.  

te 

er 

he Email icon next to the username to 
ents dialog box, where you can enter 

nts and then send these as an email to the 

m member associated 
 activity and provides 

ion for those team 

Manage Team - Click Manage Team to naviga
directly to the Team tab of the current activity. 

Send Email - Send an Email to a team memb
whose name appears as an attribute within the 
widget. Click t
open a comm
comme
team member. 

To toggle between the summ ls 
View as appropriate. 

ing the Pro

 personalize the Pro ly, in the order in 
whi nt to see them.  

lize widget display: 

roject Summary 

e current configuratio e is 
played. Only the widg be hidden or 

le during Proj  under  
Tools > Administration > Pr
Administrator Guide.)  

2. In the Configure Wide Colu ant 
to display from the Availa ns 

the arrow icons.  

3. Arrange the selected wid ou want them to appear. 

ve to save your s age reflects the new 
figuration.  

ary view and a detailed view of the program, click Summary or Detai

Personaliz ject Summary Page 

You can ject Summary page to display chosen widgets on
ch you wa

To persona

page, select the Personalize tab.  1. In the P

Th
dis

n of widgets for the wide and narrow columns of the Summary pag
ets that are currently enabled are visible. (Widgets can 

made visib ect Summary page configuration using the options available
oject Summary Configuration. For more details, see the Agile 

mn and Configure Narrow Column sections, select the widgets you w
ble Widgets columns and move these to the Selected Widgets colum

using 

gets in the order y

4. Click Sa election and exit the dialog. The Summary p
con
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Viewing General
The eneral Info tab contains Activity and Status information, and displays information for the fields 

e table. Fields which contain information that is compiled or rolled up from other fields are 
le.  To edit fields, click the Edit button. You can make changes in the editable fields, and 

click Save to save the changes, or click Cancel to exit without saving. 

 Information 
G

listed in th
not editab

Field  Conta ins . . .  

Schedule Contains information that enables you to quickly track program progress. Tells 
you the targeted start and finish dates as well as the duration remaining until 
program completion. 

Estimated Contains information that enables you to track when overdue items will be 
delivered. See also "Estimated Dates (on page 64)". 

Actua Actual varies from schedule if you are ahead of or behind targeted program l
dates. 

Work Days Variance
e

Start Variance, Finish Variance, and Duration Variance are displayed for 
Estimated, and Actual dates, compared with Scheduled dates. Variances can 
be displayed in either Work Days or Calendar Days, or both Work and Calendar 
days. 

rmation is displayed in the 

Calendar Days Varianc

Note: Your Agile administrator determines which info
summary table on the General Info tab. 

Dur

% C

ffort is determined. For more information ation Type Duration Type influences how Days E
about duration type and days effort, see “Duration (on page 64)”. 

The % Complete field tells you to what percent of the program is complete. 
Days Effort

omplete

Activities Type Displays whether the activity is a program, phase, or task. 

Owner The program owner. 

Delegated Owner The user who has been assigned the activity. Becomes the owner once he/she 
accepts the delegated object. If a user has been delegated ownership but has 

elegated Owner. not accepted the request, they are listed as the D

Name The name of the activity. 

Description Text that describes the program. The maximum length is set by the Agile 
administrator. 

Root Parent A link to the root parent object. 

Par the parent object. ent A link to 

Te platem Indicates the type: Active, Proposed, Template. Only an Active program can 
undergo changes in workflow status. 

Audit Score The audit score for the activity. See “Audit Values (on page 65)”. 

Wei Weight assigned to the activity. See “Audit Valuesght  (on page 65)”. 

Weighted Score A calculated score based on the audit score times the weight. See “Audit 
Values (on page 65)”. 
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Field  Conta ins . . .  

Status Indicates the workflow status of the program. 

Rollup Health Status Indicates whether the health status rollup is selected or not. 

Schedule Status Reason Describes the schedule status for the program object. 

Cost Status Denotes the cost status for the activity. This value is a selected value for the 
leaf object and a rolled-up value for a parent object. 

Cost Status Reason Describes the cost status for the program object. 

Resource Status Denotes the resource status for the activity. This value is a selected value for 
the leaf object and a rolled-up value for a parent object. 

Res e resource status for the program object. ource Status Reason Describes th

Quality Status Denotes the quality status for the activity. This value is a selected value for the 
leaf object and a rolled-up value for a parent object. 

Quality Status Reason Describes the quality status for the program object. 

Lock User Name of th
modify the 
Project, the activity is automat

e user who is currently using Gantt Chart or Microsoft Project to 
program. When a user launches either Gantt Chart or Microsoft 

ically locked to prevent any other user from 
editing the program in PPM. 

Workflow Identifies the object’s assigned workflow. 

Schedule Status The schedule status of the activity. 

Overall Status An overall status of the activity. This value is calculated based on either 
selected or rolled up-values
the worst of these status val

 for cost, resource, quality, and schedule. It denotes 
ues (cost, resource, quality, and schedule). 

Program Type Dashboard field. May be renamed during implementation. 

Region Dashboard field. May be renamed during implementation. 

Division Dashboard field. May be renamed during implementation. 

Product Line lementation. Dashboard field. May be renamed during imp

Customer ld. May be renamed during implementation. Dashboard fie

Launch Year Dashboard field. May be renamed during implementation. 

Global lable to all executives or not. Controls whether the program is avai

Schedule Editor ule editing for this program: PPM or MSP 
atically set to MSP when you launch a project 

 PPM from Microsoft Project the project dates are correct in PPM. 

Indicates the source of sched
(Microsoft Project). This is autom
into Microsoft Project. When set to MSP, the PPM project does not roll up 
dates, durations and % complete. This ensures that when the project is 
published in

Cost fields s track Monetary fields that are used in the dashboard and reports. These field
program level costs. 

Time Fields Data for these fields is manually entered using Edit. 

Critical Indicates whether the activity is on the critical path. 
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Field  Conta ins . . .  

Custom fields Fields that can be configured by the administrator. 

 
 

Dates 

in Agile PPM, dates are displayed in your preferred date format, but there is no time zone 
rsion applied for dates such as Sche

With
conve dule Start Date, Schedule End Date, Actual Start Date, 

s that you enter are stored in Greenwich Mean Time (GMT) and displayed without the 

database

Note 

Actual End Date, Estimated Start Date and Estimated End Date.  

Date value
time zone.  For example, if you enter a date value of 10/10/2007, the system stores the date in the 

 as 10/10/2007 00:00:00 GMT. 

Page Two, Page Three, Workflow, and History dates are displayed in user-preferred time 
zones.  

 
 

Estimated Dates 

Estimated dates for a child object are calculated on the following basis: 

ed start date and the latest estimated end date. 

cified only for some leaf-level tasks, the system considers the earliest 
 earliest scheduled start date, whichever is earlier, and the latest 

estimated end date or the latest scheduled end date, whicheve

If estimated dates are not specified for any leaf-level tasks, the system considers the earliest 

Obje

ct takes a defined period of time (for example, five days). For Fixed 
 calculated as the Scheduled Duration times the sum of the % 

 can also create a zero-effort activity by selecting Fixed duration 
and setting zero as the Days Effort. A zero-effort activity can have any scheduled duration 

cts’ Days Effort is fixed, but the number of resources assigned affects 
 For Effort Driven Duration Type, the Scheduled Duration is calculated 

 If estimated dates are specified for all leaf-level tasks, the system considers the earliest 
estimat

 If estimated dates are spe
estimated start date or the

r is later. 

 
scheduled start date and the latest scheduled end date. 

 

Duration 

cts within a program can have different duration types such as: 

 Fixed duration — The obje
duration type, the Days Effort is
allocation of all resources. You

(such as six months), but the Days Effort is zero. Gates and milestones are examples of 
objects that require zero effort. 

 Effort driven — The obje
the scheduled duration.
as the Days Effort divided by the sum of % allocation of all resources. 

 Calculated — This applies to parent objects and is set by the system. You cannot edit this 
duration type. 
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Note   If a parent changes to a leaf node object (an activity with no children) then the duration
type changes from calculated to fixed. The duration remains the same as it was when it 

 
s assigned to the Team tab. If there are no resources, 

eduled duration. A zero duration parent changes to a 

was the parent. If the parent object had resources, Days Effort is calculated based on the
% allocation of the Resource/Group
days effort is the same as the sch
zero-duration child node. 

 

Audit Values 

The General Info tab of activities contains the following audit values: 

 ssigned to each object in a program by an auditor during an audit, 

 Weig ject compared to other objects, 
in the context of the entire program.  

 value calculated by multiplying the values in the Weight and Audit Score fields. 

schedule of the current activity and its children in a 
ins all the child objects required to complete the 

es after you create your schedule, you can update 
r you. You must have the appropriate 

To o

Audit Score - The value a
based on performance indicators. 

ht  - A value that reflects the importance of the individual ob

 Weighted Score - A
 

Managing Schedules 
The Schedule tab displays the activities and 
hierarchical fashion. For a root program, it conta
program. If anything about your program chang
the activities and resources, and Agile adjusts the schedule fo
privileges to work within the Schedule tab. For details, see the Agile PLM Administrator Guide.  

pen a program, click the link in the name field. 

The Schedule tab contains the following buttons: 

Button  Descr ipt ion 

Expand Enables you to see all child objects associated with the selected activity. 

Delete Enables you to delete the selected child object. 

Edit
in the parent program. 

Change display order of child activities

A checkbox in the menu indicates that you must select an item before using the 
menu choice.  

Enables you to : 

Edit dependencies between the child tasks with

. 

Reschedule the current activity. 

Add a team member or a resource. 

Add En
program schedule using the Add 

ables you to add a new child object (program, phase, task, gate) to the 
Activity wizard. 

Create Baseline Enables you to create baseline. See “Creating a Baseline (on page 67)”. 

Remove Baseline Enables you to remove a baseline. 
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tabase. 

element. 

Note You need appropriate privileges to delete a program. An owner may delete a phase, task, 

Deleting a Program Element 

To delete a program element: 

1. Select the row of the object you want to remove. 

2. Click the Delete button. A warning message appears asking you to confirm that you want to 
delete this program object. Choose OK in the confirmation message if you want to delete the 
program element from the da

Alternatively, you can also use the Actions > Delete menu command to delete a selected program 

deliverable, or gate. Discussions and File Folders are not deleted from the system; they 
are removed from the program and become stand-alone objects in Agile when the activity 
is deleted. 

 

Establishing Dependencies 

You can establish dependencies between activities within your program schedule. A dependen
between activities mandates that one activity's schedule is driven by the predecessor's schedul
See “

cy 
e. 

ging DependenciesMana  (on page 68)”. 

cies using the Gantt Chart. See "Gantt ChartYou can also establish and change dependen  (on 

Schedule tab.   

 

the Edit > Move Back/Forward function acts on the currently displayed object only, not on the rows in 
hed

To resche

From the Schedule tab, select Edit > Move Back / Forward. The Move Back/Forward page opens. 

To move the scheduled dates of a program element forward or backward, do one of the 
following: 

1. Select the Start Date or End Date options and use the calendar to select new dates. 

page 87)". 

Editing Display Order 

You can change the order in which tasks or phases appear on the Schedule Page tab. 

To edit the sequence of the Program elements on the Schedule tab: 

1. On the Schedule tab, select Edit > Display Order. The Display Order page appears. 

2. In the boxes in the Line # column, enter a number that represents the order in which you want 
the corresponding program elements to appear on the 

3. Click Save when done. 

Rescheduling a Program 

While other Schedule tab edit functions allow you to select and modify rows in the schedule table, 

the sc ule table.  

dule your Program: 

1. 

2. 

Page - 66 Agile Product Lifecycle Management 

 

 



 Chapter 5  
 
 

2. Select the Move Forward or 
days by which the sched

Move Back options as appropriate and specify the number of 
ule should move.   

ation on this page, see “Managing SchedulesFor more field and button inform  (on page 65)”. 

e program. 

he  date of a program to reschedule it, errors can occur if there is slack 
avoid this, you can do either of the following: 

 the Time Buffer field. See "Dependency Time Buffer

3. Click Save to reschedule th

W n you move the end
between the activities. To 

 Quantify the slack in ". 

to launch the Gantt Chart for the program and 
is action adjusts program dates to give you a 'best fit' 

ule a parent program by moving the end date and 

 Remove slack. The quickest way to do this is 
use the Edit > Remove Slack command. Th
schedule. 

Note This error can also occur if you resched
the end dates of any child activities fall on weekend dates 

 

Adding a Team 

You can select single or multiple activities an
allocation is 100%). 

See also “Managing Teams

d add team members or resources (the default 

 (on page 71)”. 

To add members to a team from the Schedule tab: 

1. Select one or more activities and select 

2. Search for a name by typing the Search Name
leaving the Search Name box empty and cl

3. Select individual team members from the
to the Selected Users list. You can use Ctrl

Edit > Add Team. 

 and clicking Find. Or view all available users by 
icking Find. 

 Available Users list, and click the arrow to move them 
+click and Shift+click to select multiple users. 

d this 

the % Allocation field, the default allocation is 100%. You can accept the default or you 
an e

5. Click Next
6. Select the t arrow 

to move t

 

racking progress. The original estimates it contains are permanent reference points against 
which you can compare the updated task structure, schedule and actual dates. 

4. To add the selected users as resources (with a % allocation): 

1. Clear the Add as Team Member Only checkbox. By default, the checkbox is selected, an
will add the selected users as team members with zero % allocation.  

2. In 
c nter the desired allocation. 

. 

 appropriate roles for these users from the Available Roles list, and click the righ
hem to the Selected Roles list. 

7. Select Apply to Children if you want the settings to apply to the current object and child objects.  

8. Click Finish. 

Creating a Baseline 

Baselines are used for comparing actual progress with your original plans. A baseline is essential 
for t
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You create baselines only for the root program object so you can take a snapshot of the schedule. 

To create a baseline: 

electing 

 report to compare baselines. In the navigation 

1.  From the Schedule tab of a root program, click the Create Baseline button. 

2.  Enter a description for the baseline, and click Save. 

Once you save a baseline, you can compare the current schedule with any baseline by s
the baseline from the Version list. 

Note You can use the Baseline Comparison
pane, click Analytics and Reports navigatio
Program & Portfolio Reports > Program Repo

n button, then navigate to Standard Reports > 
rts > Baseline Comparison Report. 

If you need to take snapshots of extensive program data during the planning phase, save mu
baselines. For example, you may want to do this at major planning milestones. 

To remove a baseline: 

ltiple 

he
r m

Ma
Activities (Programs, Phases, Tasks) and Gates can be linked to each other as dependencies. Agile 

f dependencies - Finish to Start (FS), Start to Start (SS), Finish to Finish 

1. Selecting the baseline in the Version list. 

2. Click Remove Baseline.  

W n you remove a baseline, the references to the baseline for all objects in the tree are also 
e oved. 

naging Dependencies 

PLM supports four types o
(FF), and Start to Finish (SF). For more information about dependency types, see “Types of 
Dependencies (on page 69)”. 

e you have identified the activities that will be dependent on each otheOnc r, you need to identify 
one whose 
start or fini ose 
star

s 

e duration of the successor task is held constant. 

s moved in, the end date of the successor also moves in.  

te. 

 task as the predecessor and another task as the successor. A Predecessor is a task 
sh date determines the start or finish date of its successor. A Successor is a task wh

t or finish date is determined by its predecessor task. 

 If an FS dependency is established between two tasks, the start date of the successor i
moved out 1 day past the end date of the predecessor. 

 If the predecessor's start date is moved forward in time (increased) then the successor task is 
correspondingly moved forward. Th

 If the end date of the predecessor i

Note A dependency relationship has no bearing on the workflow state of an Activity or Ga
For example, Gates with predecessors can still be opened even if the predecessor 
Activities are not complete or the prior Gates are not opened. 
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Ty es of Dependencies p

p

 ish (FF) 

De endencies can be of four types: 

 Finish to Start (FS) 

 Start to Start (SS) 

Finish to Fin

 Start to Finish (SF) 

 

he Successor task is Task B: 

 Task A starts. 

For example, if the Predecessor task is Task A and t

 Finish to Start: In an FS scenario, Task A is scheduled to finish before the start of Task B. 

Start to Start: In an SS scenario, the work of Task B cannot start until 

Note In an actual scenario, SS dependencies generally occur when you want the 
work of two tasks to overlap. When two tasks have an FS dependency, but the 
work can overlap or be done in parallel, consider changing their dependency to 
SS to reduce the overall duration of your project. Overlapping work also helps 
to reduce the overall duration of a project. 

 Finish to Finish: In an FF scenario, the finish date of Task A determines the finish date of Task B. 

In a prog
if a 
whe
dep  
B). 

 Start to Finish: In an SF scenario, the start date of Task A determines the finish date of Task B. 

ram, you can specify the SF dependency to create a just-in-time scheduling. For example, 
related task needs to finish before a Gate or program finish date, but it does not matter exactly 
n and you do not want a late finish to affect the just-in-time task, you can create an SF 
endency between the task you want scheduled just in time (Task A) and its related task (Task
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Dependency Time Buffer 

A buffer can be inserted to maintain a gap between a predecessor and its successors. Either 

e in the Time Buffer field that represents 

positive values or negative values are accepted for the buffer.  

When creating or editing a dependency, you can enter a valu
“slack time” between the end of the predecessor activity and the start of the successor. 

You can also create and change dependencies from the Gantt Chart view. See “Creating and 
Editing Dependencies in Gantt (on page 100)". 

Creating and Editing Dependencies 

redecessor (Dependent Upon) and successor 
(Required for) information of the program. If you have established dependencies to other activities 

re also shown.  

letes the selected object. The Remove button affects only the selected activities in 
the curr e. 

  add a depe
activities in the same pro

To o  activity, click its n

To cr ies: 

1. Select at least two activities in the list of child o
window that opens lets y
define the dependency fo n Line # field. 

e, if you want

er the 
r activity, SS

2. After you finish editing de

For q of dependen ing 

The Dependencies tab displays a list of all the p

outside the program (external dependencies), links to these a

This tab presents the following action buttons: 

 Edit  - lets you edit dependencies between tasks. The Edit button affects only the c cked items 
on the current page.  

he

 Remove - de
ent pag

Add - lets you ndency to the selected activity. Dependencies can be made between 
gram or other programs. 

pen an ame.  

eate dependenc

bjects, and choose Edit > Dependencies. The 
ou create or edit dependencies between selected activities. You can 
r each line in its Dependent Upo

For exampl  to specify that Line 2 is dependent on Line 1: 

Dependent Upon Line #, enter 1SS2. Where 1 is the Line # of In the Line 2 row, und
predecesso  (Start-to-Start is the dependency type, and 2 is the Time Buffer value. 

pendencies, click Save to save your changes. 

uick editing cies, use the Gantt Chart view. See also "Creating and Edit
Dependencies in Gantt (on p

Crea ndency Ch

Whe  dependency ndency types, certain 
considerations apply. The start date of a successor task can be  scheduled one day after the end 
date of a predecessor task or gate, only if certain criteria are met. If these criteria are not met, the 
start or end date of the successor can be the same as that of the predecessor. 

For a simple dependency chain such as Task1 - Gate1 - Task2, the start date of Task2 will be one 
day after the end date of Gate1, only if the following conditions are met: 

age 100)". 

ting Depe ains 

n creating a  chain between tasks using different depe
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 There is -Start (FS) dependency between Task1 nd between Gate1 and 
Task

 There is no slack betwee

For a longer dependency cha s Task 1 - Gate1 - Gate2 - Gate 3 ... GateN - Task2, the start 
date of Task2 will be one day

 There are dependencies 
specified.  

 There is no slack between the gates. 

 The first dependency - the dependency between Task1 and Gate1 - is FS, with no slack or time 

The last dependency - the dependency between GateN and Task2  - is FS, with no slack or 

 even if zero duration tasks exist instead of gates in the dependency 

 a Finish-to  and Gate1, a
2, with no time buffers specified. 

n Task1 and Gate1. 

in such a
 after the end date of Gate1, only if the following conditions are met: 

(FS, SS, FF, or SF) between the gates and no time buffers are 

buffer. 

 
time buffer. 

Note These rules apply
chain. 

 

u
can a sources, mbers’ roles, and change their 

ers and apply roles: 

2. To fi
leave . To assign a resource pool as a placeholder (if you 
do not know the specific names of the resources), select All Groups. 

o 

 

Managing Teams 
Yo  can manage resource assignments to program activities from the Team tab. Within this tab, you 

dd or remove team members or re  change team me
allocation. You must have the appropriate privileges to work within the Team tab. 

Adding Team Members 

To add team memb

1. Within the Team tab of the program, Click Add. 

nd a resource, type a name in the Name(s) field and click Find. To view all available users, 
 the Name(s) field empty and click Find

3. Select individual team members from the Available Users list, and click the right arrow to move 
them to the Selected Users list. You can use Ctrl+click and Shift+click to select multiple users.  

Before you select a resource or user group, you can review resource utilization details. To d
this, click the Report button. This opens a window where you can review resource utilization 
details based on query criteria. See also "Reviewing Resource Utilization (on page 73)".  

4. When you finish selecting resources, Cl

5. To add a person as a team member but not as a re

ick Next. 
source with a % allocation, select the Add As 

 
ximum value setting can be configured in the Java 

Team Member Only checkbox.  

To allocate a person as a resource for the task, clear the checkbox. In the % Allocation field, fill 
in the percentage of the time that this resource will dedicate to this task. The default maximum
value allowed in this field is 400. This ma
Client 
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6. Assign one or more roles to the  resource. To do this, select the required roles from the Available 
Roles Selected Roles list on the right. 

 box. 

8

The d assigned roles are displayed in the Team tab. People added as 

Whe
Notificatio

the  
effe

E

2. Enter the changes you want in the Resource Pool and lds. Click the 

list on the left and click the right arrow to move them to the 

7. If you want the team member to be included for all child objects, select the Apply to Children
. Click Finish. 

 selected resources an
resources are also added as team members automatically. 

n you complete the Add action, each of the selected resources receives a notification in their 
ns tab. If you add a resource pool, the pool owner receives a notification. The request 

also appears in their My Assignments tab. Each resource can accept or reject the request. When 
resource accepts or rejects the request, the Resource Pool owner receives a notification to that
ct.  

diting Team Member Attributes 

To edit a team member’s resource pool, roles, and % allocation: 

1. Select the rows you want to affect. Click Edit. 

 % Allocation fie  button in 
the Roles column to edit roles. 

ve. 3. Click Sa

Field  Descr ipt ion 

Click this icon to view the Resource Pool Utilization Report. The Resource Pool Utilization report 
provides a user’s utilization based on the % allocation for the selected user. 

 

Name Name of team member or group. 

Assigned From The name of the pool from w
pools, the appropriate pool c

hich the resource is assigned. If the resource is assigned to multiple 
an be selected. 

ned as a For best results in managing resource utilization, Agile recommends that a user be assig
member of only one resource pool. 

Roles Program-specific roles assigned to team member for this activity. 

Days Effort Days effort corresponds to the total sum for the resource or group. 

Is Resource Identifies the user as a re
Information is dependent on 

source or just a team member with no time allocated to the activity. This 
% allocation of Resource/Team Member / User Group. If % 

allocation is greater than 0, it is Yes, otherwise No. 

Rejected flag This indicates that the resource or pool has rejected the Inbox Request. 

% Allocation For both Fixed and Effort Driven duration type, this value determines utilization of a resource or 
p. grou

Pool Owner Name of the resource pool owner, if there is one. 
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Field  Descr ipt ion 

Actual Hours The number of actual hours (duration) the team member has worked. 

Reported Actual Hours are rolled up and compared to Estimated Duration and Scheduled 
Duration. 

rs are multiplied by 
by 

d up to the top 

Actual hours are also used to determine the labor cost per activity. Actual hou
the resource rate to determine the current applied cost of each resource. These totals 
resource are added up to determine the applied cost per activity, and are then rolle
to create labor costs for all parent objects. 

 
 

Assigning Team Members from a Resource Pool Placeholder 

e as an AppliedTo property within the Modify privilege to be able to 

If you added a resource pool to the Team tab as a placeholder, you can easily select the specific 
users you want to assign.  

Note You must have Team.Nam
assign members from a resource pool. 

To assign team members from a resource pool: 

1. Open the activity and click the Team tab to display it. 

2. In the Name column, click the  button next to the resource pool you want. The Assign User 
From User Group wizard appears. 

 and Shift+click to select multiple users. 

 n of the current activity, select the Apply to 

5. 

a 

3. Select individual team members from the Available Users list, and click the arrow to move them 
to the Selected Users list. You can use Ctrl+click

4. To apply the team member assignments to childre
Children check box. 

Click Finish. 

Note The % Allocation will be divided among the selected users. If there is a fraction of 
percent, the percentage will be rounded down to the next lowest whole number; the 
fractions of a percent are discarded. 

For example, if the resource pool was assigned at 100% allocation, and you select three users, 
each user will
the 

rded
ntag

to the res

ization 

Before you add or assign resources to a program, you can review their current utilization details to 

 Utilization Report for a selected user or user group to determine the following: 

 current program. 

 be assigned 33%. If you remove the three users and reassign the % Allocation back to 
resource pool, the % Allocation for the pool will be 99% – the fractions of a percent are 

disca . However, you can select the appropriate rows in the table and click Edit to adjust the 
perce es for the users assigned from the resource pool, or (if you have assigned allocation back 

ource pool) adjust the percentage for the resource pool. 

Reviewing Resource Util

ascertain how much time and effort they will be able to allocate to the activity in question. You can 
view a Resource

 Utilization within the
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 Utilization across all programs. 

To view a Resource Utilization report, do any of the following: 

 From the Details view of a program, choose Actions > Reports & Analytics > Program Resource 
Utilization. This opens a report window that displays a selected user's or user group's utiliz
within that program.  

ation 

am tab, click Add. Select a user or user group as described in "Adding a team From the Te  (on 
page 67)", and click Report. This opens a report window where you can run a query to view 

e 

details of a selected user's or group's utilization across all programs. 

 From any tab, click the name of a user or user group to view more detailed information. In th
page that opens, within the Assignments tab, click  User Group Utilization Report or simply click 
the  icon next to the user or group name. 

 From the Gantt Chart view of a program, select an activity row and choose Resources > Manage 
Resources in the main toolbar. In the Manage Resources dialog, select a user or group and click  

ce Utilization Summary.  

Within the Resource Utilization dialog, you can edit field values to filter report results as described in 

to open the Resour

the following table. See also "Program Resource Utilization Report (on page 53)". 

Fields  Descr ipt ion 

Rep ilization Summary. ort Type Type of report; defaults to Resource Ut

Display Type Select the type of chart: Table, Line, Area, Stacked Area, Bar, Stacked Bar, Stair. 

Start / End Dates The start and end dates of the duration for which you want to check utilization. 

Pool es 
ere selected in the Add Team page are selected. You can cha

Select the resources or pools for which you want to check utilization. By default all resourc
that w nge the selection to filter 
the data displayed in the report. 

Reporting Intervals Report by day or other interval. 

Include allocati
pro

in the Proposed state. The list ons from Select this check box to view allocations to programs that are 
posed Programs in the Pool field changes to accommodate additional options. Change the selection as 

required to filter data. 

 
 

Bulk Assigning T

You can b m 
Manage  pool 
own

To b  a

1. From the name of the resource to view resource information. You can use the 

2. 

3. 

asks to a Resource 

assign several tasks to a singleulk  resource if necessary. For example, a Progra
r can bulk assign a set of tasks to a particular resource pool owner. This resource

er can then assign these tasks to members of the resource pool. 

ulk ssign tasks to a resource: 

 any tab, click 
Search options to search for a particular user by name.  

In the page that opens, within the Assignments tab, click Show Filter to view the Filter options. 

Filter the assignments list by any attribute, for example, a root program. 
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4. Select the pending assignments that you wish to bulk assign and click  

5. 

6. ic

Note heir existing 

Assign. 

In the Activity Assignments dialog that opens, select the user to whom you wish to assign the 
tasks. 

Cl k OK. 

 Before you assign tasks to a resource or user group, you can review t
 Assignments List Report assignments and resource utilization details. To do this, use the 

or  User Group Utilization Report buttons. When you finish assigning tasks, you can use 
the same reports to verify that the specified resource is identified for that program. 

 

Splitting a Task Among Several Resources 

 your 
as been assigned to your resource pool, you can split the % Allocation of the 

n for each resource. 

 

, 

 
rce 

-assign percent allocation to pools (if applicable) 

ned from a pool, the resource is removed and the resource’s allocation 
is not in a pool, the resource is removed and the 

arded. 

 the allocation is discarded. 

Note For 

As a resource pool owner, you have more visibility into the utilization status of each resource in
pool. Once a task h
task across several resources. 

To split a task across several users: 

1. In the Assignments tab, select the task and click Assign. 

2. In the Activity Assignments dialog that opens, enter the percentage allocatio

3. Click OK. 

Removing Team Members 

Use the Team tab to remove a team member, resource, or pool from the activity. When you remove
you can choose one of the following options. 

Delete only if resource has no percent allocation 

Removes the selected resources only if the resource has no allocation. If the selected resou
does have allocations, it will not be removed. 

 Delete resource and re

If the resource is assig
is reassigned to the pool. If the resource 
allocation is disc

 Delete resource and discard percent allocations 

The resource (whether assigned from a pool or not) is removed and

 an effort-driven task, removing the resource and discarding the allocation changes the 
schedule duration of the task and affects roll-ups to parent activities. 

 

l program-related objects and enables you to take required actions on 

Managing Content 
The Contents tab displays al
these objects.  

Within this tab you can: 
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 information about each object.  

Con ile 
PLM
gen r Change Control and managed in the Agile database.  

Deli t can 
cha s  Agile PLM object to PPM objects as triggers to 

ation.  

te the Content tab view in several ways to display the objects you wish to focus 
on: 

ls: Select this option from the top right corner of the page to ensure that your view 
ierarchy. 

cludes options such as All Content, All Deliverables, Pending 

Manage Views. You 
the name of the view in the dialog that opens. 

Note A view can be deleted only by the owner of the root program. 

Organize documentation and other Agile objects related to a PPM program.  

View the status, due date, relationship, and rule of each object. You can also view selected 
revisions and other

 Add new content, add or edit relationship rules, manage file attachments, create change 
orders, and so on. 

Deliverables 

tent objects that have a rule assigned to them are called ‘deliverables’. A deliverable is an Ag
 object that can be linked to a Program, Phase, or Task. Product deliverables, or items, are 

erally placed unde

verables must be in a specified workflow status or lifecycle before the current PPM objec
nge tatus. Deliverables enable you to add any

enable cross-business process autom

Viewing Content 

You can manipula

 Include all Leve
displays objects at all levels of the project h

 View: You can use the options in the View drop-down list to filter the view by attributes that you 
configure. By default, the list in
Deliverables, Completed Deliverables and Important Content. A Pending Deliverable is an object 
which has not yet met the specified rule criteria, and a Completed Deliverable is an object that 
has met the rule criteria. 
 To change the name of any of these views, click the last item in the list, 

can edit 

 To add objects to a view, select the objects, go to More Actions > Add to View, and click the 
 Important Content view will also display in the 

nly the program owner can create a new view. Program team members can 

view name. Content that you add to the
Project Summary page. 

 To add more views, go to More Actions > Add to View and click New View. Provide a name for 
the new view and click OK. The newly created view appears in the Add to View list. 

Note O
add content to existing views. 

 To bookmark a selected content object, use the More Actions > Bookmark option. 
cations on attribute changes for a selected item, use the More Actions > 

ou can click Show Filter to filter the rows in the table by the attributes listed in the Filter 
drop-down list. Additional selection options display based on the attribute you specify, to help 
you narrow down your query. To apply several filters successively, click the 

 To subscribe to notifi
Subscribe option. 

 To create a change order for an item, select the item and use the More Actions > Create 
Change option. 

 Filter: Y

 icon and select 
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other filter attributes. Click Apply to apply your changes. 

 Preview: You can click on the row of an object to see details of that object in a preview pane at 

View a selected revision. 

 for attribute changes on selected items. 

Add

Any
deliv
deliv

rule  
com s opened, you can add that activity as a deliverable for the 

u can even restrict one Gate from opening before another Gate is opened - by 
ate as a deliverable for the subsequent Gate to open. 

he

m  

 
 s a deliverable. For example, you 

Add

To a

1. 

2. 

dding an Item object, you can add a rule to the object. To do this, select 

the bottom of the page. Within this preview pane, you can take several actions on the object, 
such as: 
 
 View, add, edit, or remove a rule, to ensure hard dependencies. 
 Add, remove, check out, or view a file attachment in multiple formats. 
 Create a change for an item. 
 Subscribe to notifications

 

ing Content 

 program object that has a lifecycle phase or a workflow assigned to it can be added as a 
erable. Discussions, users, and user groups are the only objects that cannot be added as 
erables. 

You can add Activities and Gates as deliverables on other Activities and Gates. You can also set 
s to ensure the completion of one activity before another. For example, if you want to ensure the
pletion of an activity before a Gate i

Gate to open. Yo
adding the prior G

W n adding Programs as deliverables to other programs, they can be Proposed or Active. 

Te plates can also be deliverables. For a program that has its own copies of deliverables, a
template can be a deliverable on tasks. 

If an external root program is a deliverable for a template, it should also be of type Template. 

You cannot add an object that causes a circular relationship a
cannot mandate that Task1 is a deliverable for Task2 to reach completion, and Task2 is a 
deliverable for Task1 to reach completion. 

 In order to add an object, you must have Create privilege for that object, as well as Modify 
privilege on the Relationships.Name attribute for that object. 

 

ing a Deliverable 

dd a deliverable: 

In the Content tab toolbar, go to Add > Create New. 

Select the object you wish to add and enter details as appropriate. 

Note While a
the Ad
Rule di

d Rule option at the bottom right corner of the dialog. In the Relationship 
alog, specify the rule for this deliverable. You can also add a rule from 

the preview pane of that object within the Content tab. 

3. Click 
 

OK. The selected object displays in the Content tab. 
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Sea

ced 
on searches, see the Getting Started with 

2. n 

3. 

4. 

cted, the first object is displayed at the bottom of the table in the dialog. Within this 
: 

Mandatory attribute of each selected object to Yes or No as appropriate. 

5. 

e

Add

To a

nd select files from your hard drive. You can add a description and specify whether 

3. 

4. 
 

Add

To a

1. 

2. Enter the URLs which you wish to add. To preview the HTML pages, click Preview. 

ions. You can choose to add all selected URLs to a single 
ovide a description for the folder. 

rching for Content 

To search for content: 

1. In the Content tab toolbar, go to Add > Search. You can perform a simple search by selecting a 
base class from the Search for drop-down list. You can also conduct more specific searches 
using the additional search options provided: Search Folders, Bookmarks, Recently Visited, Advan
Search, and Parametric Search. For detailed information 
Agile PLM Guide. 

Within the search results, select the objects you wish to add and click Add Selected. You ca
sort selected search results by column heading. 

To edit the object attributes, select Edit rows after adding. 

Click OK. The Edit newly added rows dialog opens. 

If a single object was selected, this object appears selected automatically. If several objects 
were sele
dialog, you can
 Change the 
 Specify a relationship rule for the object. 

Click OK to apply your changes. 

Th  selected objects display in the Content tab. 

ing a File 

dd files: 

the Content tab toolbar, go to Add > Files. 1. In 

2. Browse a
the files need to be unzipped. 

Click Options to view additional options. You can choose to add all selected files to a single 
folder if you want. You can also provide a description for the folder. 

Click OK. The selected files display in the Content tab. 

ing a URL 

dd URLs: 

In the Content tab toolbar, go to Add > URLs. 

3. Click Options to view additional opt
folder if you want. You can also pr

4. Click OK.  

The selected URLs display in the Content tab. 
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Cloning Deliverables 

The  in mind before you create a program from a 
template as

re are certain considerations you should bear
ng the Create Menu described in "Usi  (on page 44)". These are provided here for your 

fe

Content Objects 

tent objects 
, you select the Content checkbox in the program creation 

 If the content check box is selected, copies are created for all deliverables in the template. The 
ities will reference the newly created copies and not the original 

 For example, a content object such as a Marketing Requirements 
Document that was available in the template is duplicated in the new project, with the file 

 no 

ndard Operating 
 

 
 error log 

not know which one to 
use, content is not created and an error is reported. 

auto utomatically selected based on the autonumber 
nt tab 

 The Autonumbers attribute is not filled in Proposed or Active Type Programs. If such programs 
 fill in the autonumber attribute in the template again. 

es where the Autonumber field is left blank. 

e 

reated from this template, a new copy of 
 

re rence. 

While creating a program from a template, you can opt to duplicate or clone the con
from the template program. To do this
wizard. 

program and all its child activ
deliverables in the template.

attached from the template. 

 If the content check box is not selected, there are no copies of deliverables created, and
links are provided to any deliverables on the template. 

 If the content object does not have a Rule, only the link is copied and this link will point to the 
same object as in the template. For example, a content object such as a Sta
Procedure (SOP) document, where it is not necessary to create a new object, and only a link to
the controlled document is necessary. 

In general, copies are not created for all objects that do not have a Save as functionality. All 
deliverable objects for which copies cannot be automatically created are listed in the
window. 

 

Autonumbers 

 If multiple autonumbers exist on a Content object and the system does 

 Within the template, ensure that an autonumber is set for each deliverable. Deliverable 
numbers for the created program are a

chosen for the original deliverable in the template. The Autonumber attribute on the Conte
for templates allows you to specify the autonumber used. 

are saved as templates, you need to

 Copies are not created for deliverabl

 For all classes, if the same object is a deliverable for multiple activities and/or gates in th
template, the copy of the object is created for the first activity / gate that it is a deliverable for, 
and a link to this copy is provided for all other subsequent activities / gates that the same object 
is a deliverable for. 

For example, let’s say that a document DOC00341 is a deliverable that is referenced twice in a 
template, on Task1 and Task2. When a program is c
the original deliverable in the template is created - DOC00982 for Task1. This document will be
a deliverable for Task2 as well, following the same pattern as in the template that the program 
is created from. 
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Required Fields 

 All required fields are copied from the original deliverable to the new copy created. 
 

Tabs 

 For all subclasses, Cove

For example, if an assembl

r Page, Page Two, Page Three and Attachments tabs are copied. 

y is a deliverable on one of the tasks, the only tabs that are copied 
s NOT copied over. 

e are used as deliverables, corresponding 
s in the 

 plate or source program are added as deliverables to 
verables on a program created from the 

onding activities on the newly created program. 

 Task2 in the template, then for any program that is 
e program will be a deliverable of Task2 in the program. 

t is, ensuring certain activities are 

 

ate type are allowed as deliverables of activities and gates 
 of Proposed and Active type are not allowed 
emplate. 

 program deliverable 
plate deliverable. This copy of the original program 

s 
nd 

. 
 

Tem

 ooses to create a Proposed program from a Template, all templates that are 
deliverables of the 
ate an Active 

om a Template. For the copies, only the name of the root program is changed; the 
names of the activities and gates remain the same. The activities and gates numbers, however, 

que. 

 Copies of external activity deliverables that are not root templates are not created due to the 
, the deliverables on the 

program created from the template will reference the original deliverables on the template for 
such objects. 

 

are Page 1, Page 2, Page 3 and Attachments. The BOM tab i

Activities and Gates 

 When internal activities and gates in the templat
copies are created in the newly created program tree and referenced as deliverable
other activities and gates as defined in the template. 

When activities and gates within a tem
later activities and gates in the template, the deli
template will also reference corresp

For example, if Task1 is a deliverable of
created from the template, Task1 in th
This is one approach of implementing hard exit on gates tha
completed or certain gates are opened before another specific activity is completed or gate is 
opened. 

Root Programs

 Only external root programs of templ
within a template. In other words, root programs
as deliverables for activities and gates within a t

 If an external root template is a deliverable on a task of template, a new a 
is created as a copy of the original tem
deliverable has the program tree structure in place, but no deliverables. When creating copie
of external root templates, only General Info, Page 2, Page 3, Attachments, Dependencies a
Schedule tabs are copied. Team and Content tabs are NOT copied. External root templates, if 
used as deliverables multiple times, are cloned only once similar to internal activities and gates

plates 

If the user ch
deliverables of this template are created as Proposed programs that are 
newly created Proposed program. (The same applies if you choose to cre
program fr

are system generated and uni

fact that non-root activities cannot exist by themselves. In this case
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Managing Workflows 
 object is in the assigned workflow and lists past signoff 

info rs 
on t

 Status Roll-Up Works

The Workflow tab shows where the program
rmation. If you have the necessary privileges, you can add or remove approvers and observe
his tab, or you can move the object to another status in the workflow. 

Programs, phases, and tasks roll up their statuses as described in “How  (on 
s: 

 lt A

   Not Sta ss —> Complete 

n 

you have the appropriate privileges, you can 
orkflow status. 

Note om workflows, your list of statuses may be different and your 

page 5)”). Default workflows for programs contains the following statuse

Defau ctivities Workflow 

rted —> In Proce

 Default Gates Workflow 

   Closed —> In Review —> Ope

Default workflows also include a Canceled status. If 
move the program object to the Canceled status from any current w

 If your company uses cust
ability to move from one status to another status may controlled differently. 

 

Ru

ge: 

hild workflows start. For 
rent status is In Process. 

mplete. 

 
example, a workflow with seven steps can roll 

 has only one transition between the “Pending” 
and “Review” type (Pending, Review, Complete, and Cancel are the Status Types). 

n to change the workflow status 

To change th  status of the pa af-level child activity and click the 

e ange the workflow status of an activity that 

les for Parent Status 

The following rules apply for parent object status chan

 Parent object workflows are affected when any of the related c
example, if one child activity is in the In Process state, then Pa

 Parent object workflows are affected when all of the related child object workflows co
For example, if all activities are Complete, then parent status is Complete. 

When custom workflows are used, the roll up is governed by the transition between the Status 
Type, not necessarily a change in the step. For 
up to a parent with three steps because each

For leaf-node objects, you can click the Change Status butto
(provided you have the required role). 

e workflow rent activity, open a le
Change Status button to change the workflow status of the leaf-level activity. 

Not  You cannot use the Change Status button to ch
has children (subordinate activities). 

For more information about workflows, see Getting Started with Agile PLM 
Administrator Guide. 

and the Agile PLM 

rs can post and reply to 
discussions that arise in the course of managing programs. High priority discussions appear on the 

Managing Discussions 
The Discussions tab contains both discussions and action items. Use
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Agile dashboard as Issues. Action items may be used in conjunction with discussions to ensure that 
the loop is always closed so that discussions do not go unattended. Action items can also be 

ch activity level independe
 

tracked at ea nt of any discussion or issue, and can be used to track and 
mea

s discussions are raised. This 
-making and history of a 

sure activity follow-up, meeting to-dos, and so forth. 

Subscriptions are often set up by the team members to get notified a
promotes a collaborative thread of replies and captures the decision
program.  

Discussions Table 

The Discussions table displays important information about each discussion. An action item icon  
indic tems associated with the discussion. Click the icon or click the discussion 

e discussion. 

Add

to an existing discussion. 

ates there are action i
name to open th

ing Discussions 

You can add a new discussion or reply 

To add a new discussion: 

1. Open the activity, and click the Discussions tab. 

2. Click the Add drop-down menu button and choose the  Create New option. 

3. Type drop-down list. 

5. Type the message you want to send. 

list, set the discussion priority. 

7. Click the Notify List field to add users who should receive notification of this discussion in their 

op-down menu button and choose the 

The Add Discussion wizard appears. 

Select Discussion from the 

4. Enter a subject for the discussion. 

6. From the Priority drop-down 

Notifications inboxes.  

8. Click Finish. 

To search for an existing discussion to add: 

1. Open the activity, and click the Discussions tab. 

2. Click the Add dr  Search option. 

x appears. 

3. Search for one or more existing discussions. In the Add Objects dialog box, select a search 

.) 

The Add Objects dialog bo

method. If you choose to perform a simple search, enter the value to search for and click 
Search. You can also define an advanced search, run a saved search, or select a bookmarked 
or recently visited item (Shortcuts). (For more information about searches, see Getting Started 
with Agile PLM

4. In the search results, select the discussions you want by moving them into the Selected 
Objects list. 

You can run multiple searches to find and select additional discussions. 
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5. Click OK. 
 

ussions 

ssions. 

e

tivity, and click the Discussions tab. 

root program object, you can see which activities have discussions by looking for the 
symbol in the discussions column on the Schedule tab. 

ussion you want to reply to. 

Preview Message

Replying to Disc

You or your team members or notified users can reply to discu

To r ply to discussions: 

1. Open the ac

2. Click the discussion name to open it. 

In the 

3. On the Discussions tab, select the disc

Note You can use the  checkbox to quickly preview the message text 
of all the discussions in the Discussion table when selecting the discussion you 
want to reply to. 

4. Click the Reply button. Enter your message and the list of people to notify, and click Save. 

To a d a c

the + symbol next to a discussion in the Subject column. 

The list of replies is displayed. 

3. If a reply has subordinate replies or comments, click the + symbol in the Subject column next to 
st. 

that the reply has subordinate replies. Click the + symbol on each 

6. If de

. Enter your message and the list of people to notify, and click Save. 

Your reply is added to the discussion thread below the reply row you selected in step 4 above. 

Replying to Discussions from your Inbox 

When a discussion appears in your Notifications Inbox, you can open the discussion object and 
either add a reply or add a comment to an existing reply. 

To reply to Discussions from your Inbox: 

1. In your Notifications inbox, click the Regarding field (not the Subject field) of the discussion to 
open the discussion item. 

2. Select the button for the row you want to reply to. 

3. Click Reply. The Discussion Reply wizard appears. 

4. Add the reply message and the list of people to notify, and click Save. 

d omment to an existing reply: 

1. Open the activity, and click the Discussions tab. 

2. Click 

the reply to expand the li

Each + symbol indicates 
successive level until you have displayed the reply to which you want to add a comment. 

4. Select the row to which you want to add a reply. 

5. Click the Reply button. The Discussion Reply wizard appears. 

sired, enter a subject for the reply. Or, use the default subject provided for you. 

7
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To add a comment to an existing reply: 

1. In your Notifications inbox, click the Regarding field (not the Subject field) of the discussion to 
open the discussion item. 

2. Select a row in the replies table to add a comment to that row. 

3. Or, if a reply row has subordinate replies or comments, click the + symbol in the Subject column 
next to the reply to expand the list. 

Each + symbol indicates that the reply has subordinate replies. Click the + symbol on each 
successive level until you have displayed the reply to which you want to add a comment. 

4. Select the button for the row to which you want to add a reply. 

5. Click Reply. The Discussion Reply wizard appears. 

6. If desired, enter a subject for the reply. Or, use the default subject provided for you. 

7. Add the reply message and the list of people to notify, and click Save. 

8. Click the Notify List field to add users who should receive notification of this discussion in their 
Notifications inboxes.  

9. Click Save. 

Your reply is added to the discussion thread below the reply row you selected in step 4 above. 

Viewing Discussion Replies 

To see a list of replies to a discussion: 

1. Click the + symbol next to a discussion in the Subject column to expand the list of replies. 

2. Click a discussion subject to open the discussion object.  

3. Click the + symbol in the Subject column of the Message Thread table to view all the replies 
related to this discussion. 

Note You can use the Preview Message checkbox to quickly preview the message text of all the 
discussions in the Discussion table. 

 

Removing Discussions 

After you finish all your discussions, you can remove the discussion objects. 

To remove discussions: 

1.  Open the activity, and click the Discussions tab. 

2.  Select the button for the discussion you want to remove. 

3.  Click Remove. 
 

Viewing Action Items 

You can access action item details from the Discussions tab by clicking the name of the action item. 
Action Items appear separately below discussions in the Action Item table in the lower part of the 
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page. 

 The list of action items in the table is a combined list of the action items associat
program and the action items associated with the listed discussions. 

 The Belongs To column and icon indicate whether the action item is ass
object or with a program object. Click the link in the Belongs To column to open th

Subject column to open the action item. 

To add an Action Item: 

1 O

2 In

3 F

4 C

T  a
assign

achments 
The Attachments tab enables you to attach files and URLs that are helpful or needed for your and 

 

ed with the 

ociated with a discussion 
e object. 

Click the name of the action item in the 

. Discussionspen the activity and click the  tab 

.  the Action Item section, click the Create button. 

. ill in the action item information. Fields that are in boldface are required. 

. lick Save. 

he ction item will appear in the Notifications and My Assignments tabs of the person to whom it is 
ed. 

Managing Att

your team members’ work. If there are items on the Attachments tab, a paper clip icon appears on
the tab. 

Note You must have at least edit permissions to add an attachment to a program element. 

Refer to the Agile PLM Getting Started Guide for details about the Attachments tab. 

 

Viewing History 
The History tab records all actions taken, such as editing the General Info tab or changing activities or 
team members. 

Note If you do not have the appropriate read privileges, you cannot view the fields on the History 
tab. If you have questions about your privileges, see your Agile administrator. 
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Chapter 6 

t Gantt Char

This chapter includes the following: 

 Overview.............................................................................................................................................................. 87 
......................... 88 

................................................................................................................................... 88 
.............. 89 

....................................................................................................... 91 
93 

 ............................................... 96 
 .. 101 
 

 
 

v
ant

plan, adm
and then  
tasks, cre

The Gant l-like data editing) to manipulate and 
raphical or tabular formats. Multiple view options enable you to focus on discrete 

nus help you to quickly take actions on selected program 

 Prerequisites...............................................................................................................................
 Launching Gantt ...............
 Gantt Toolbar Icons ...............................................................................................................................
 Views in Gantt...............................................
 Customizing the Gantt Chart ...............................................................................................................................

Creating Programs, Phases, and Tasks ...............................................................
Resource Management .....................................................................................................................................
Working Offline on Gantt ..................................................................................................................................... 104 

O erview 
The G t Chart feature is a powerful program management tool that helps Program Managers 

inister, and track programs from start to finish. With Gantt, you can create a new program 
 plan the work breakdown structure for this program, which includes defining activities and
ating dependencies between tasks, and performing resource management. 

t Chart offers rich user-friendly features (such as Exce
view data in g
program aspects, and right-click me
objects. 
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The default Gantt view consists of a ar, a ta ane and a 
hica vity pane. The tabular a  pane provid

rep esen n of all activities and the graphical pane pr
activities with color and iconic indicators. 

 menu bar, standard toolb bular activity p
grap l acti

tatio
ctivity es a hierarchical tree structure 

ovides a graphical representation of r

 
 

Prerequisites 
Make sure you have the appropriate privileges to perfor in the 
Gantt Chart. If you have questions about your assigned  

strato

The Gantt chart uses Java Web Star gy and requires JRE 1.5 (Java Runtime Environment) 
e ins our computer. If th ended J f you 

ha e a l on installed, you a d to inst

 rewalls prevent this automatic down JRE 1.5 

m program management activities with
 roles and privileges, contact your Agile

admini r. 

t technolo
to b talled on y

ower versi
e recomm

re prompte
RE does not exist on your system or i
all the latest JRE version. v

Note If certain fi load, you can download and install 
from the URL: http://www.sun.com. 

 

Launching Gantt 
ch the Gantt Chart for a program, open the prog art. If 

your program has sub-activities, you can also select Actions > Gantt Chart from the Summary view.  
hen you start the Gantt Chart, Java JAR files are downloaded into your computer’s temporary 

files folder. Once these have been loaded, the Gantt Chart appears.  

ram and select Details View > Gantt ChTo laun

W
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Launching Gantt Using Shortcuts 

During Gantt download, you are prompted to confirm whether you want shortcuts to the Gantt 
application to be installed on your Desktop and Start menu. Click Yes to confirm.  These shortcuts 
are especially useful when you want to work on Gantt offline.  

To launch Gantt from the Desktop, double-click the  icon. To launch Gantt from the Start menu, 
choose Programs > Oracle | Agile PLM  and select the Gantt application. Once you have saved a Gan
Chart Exchange (.gcx) file on your system, you can simply double-click on the file to launch
Gantt Chart

tt 
 the 

. 

es in three modes: 

ta is obtained directly from the server.  

d data is obtained from the installation folder. If the server is not 
hes to this mode. Once the server becomes available, it switches back to 

ta is retrieved from the installation folder. The server is assumed to be 

 the mode it was set to when you last worked on it. If the Gantt 

Modes of Operation 

The Gantt chart operat

 Connected – Requested da

 Disconnected - Requeste
available, Gantt switc
Connected mode. 

 Offline - Requested da
unavailable. 

Note The Gantt chart opens in
Chart was set to Offline mode in your last session, it opens in Offline mode when you next 
try to launch a program from Web Client. This means the requested program cannot be 
opened as the system assumes server unavailability. Instead, a new default program is 
launched. To open the program you wanted, change the mode from Offline to Connected, 
and then launch the program again from Web Client. 

 

Gantt Toolbar Icons 
Most actions on the Gantt chart can be performed using the icons on the toolbar or corresponding 

xt to shortcut keys. When you place your mouse pointer over an icon, the shortcut key appears ne
the name of the icon.  

Icon Name Shortcut  Keys Descr ipt ion 

 Cut Ctrl+X Cuts a selected cell value, activity or gate. 

 Ctrl+C Copies a selected cell value, activity or gate. Copy

 Paste Ctrl+V Pastes the cut or copied cell value, activity or 
gate. 

 Save Ctrl+S Saves changed information in the Gantt.  

 Activity Insert Inserts an activity below the selected activity, 
at the same indent level. 
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Icon Name Shortcut  Keys Descr ipt ion 

 Alt+G Inserts a gate below the selected activity, at Gate
the same indent level. 

 Delete Delete Deletes the selected item from the Gantt 
Chart. 

To select an activity for deletion, highlight or 
select the whole row. 

 Create Dependency Alt+C Adds a dependency. 

 Edit Dependency Alt+D Opens the Edit Dependency dialog for the 
selected dependency. 

 Go To Selected Task Ctrl+G Brings the corresponding graphic into view. 

 Outdent or Move Left Alt+Shift+Left Outdents an item, so that a program element 
no longer reports to the higher-level element. 

Moves the selected item or items to the left. 

 Indent or Move Right Alt+Shift+Right Indents an item, making a program element 
report to another item. 

cted item or items to the right. Moves the sele

 p to change the order of the 
ems at the same level. If program 

 

Move Up Alt+Shift+Up Moves an item u
listed it
elements report to that item, these move
along with it.  

 
the listed items at the same level. If program 

Move Down Alt+Shift+Down Moves an item down to change the order of 

elements report to the item, these move along 
with it.  

 Zoom In Ctrl+Plus 
(NumPad)

Enlarges the graphical pane view. 

 Zoom Out Ctrl+Minus Reduces the graphical pane view. 

 Zoom To Fit Ctrl+0 Changes the size of the graphical pane to 
show the entire program within the visible 
area. 

 Manage Resources Alt+F10 Allows you to select and manage resources 
for the selected activities. 

 Delegate Owner Alt+F12 Allows you to delegate the ownership of the 
selected activities. 
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Views in Gantt 
Views lp you see your program in different aspects and formats. Views are a subset of the 

n you enter in PPM. These subsets of information get stored in Gantt an
 he

informatio d can be 
displayed in different views. 

s various views, for example, you can view the resource allocation information either in 
rmat. Combination views are split views that contain more than two 

 Views to enter, edit, and display information on activities and 
resources. 

Bar, 

 
 rl+2) 

 
 

) 

Ga

The iew. This view displays the program activities and schedules in a 
re. The 

vities in a bar graph format. 

Task Assignment 

f the Gantt Chart in the top pane and the 

e 

u to create, edit, and review your project tasks in a calendar format. 
The Calendar view consists of two tabs, Month and Day. The Month tab displays a monthly view with 

 easily view tasks that are scheduled on a particular day, week or 
ules for a specific week or range of weeks. You can create a program 

n of a program using the calendar format. 

PPM provide
a graph format or in a table fo
views at a time. You can use

To change your view, select any of the view options listed here from the View menu or the View 
or use the shortcut keys provided to access the view. 

Gantt (Ctrl+1) 

Task Assignment (Ct

Calendar (Ctrl+3) 

Critical Path (Ctrl+4) 

 Comparative Gantt (Ctrl+5

 Resource (Ctrl+6) 

 Resource Sheet (Ctrl+7) 

 Resource Utilization (Ctrl+8) 
 

ntt 

 Gantt view is the default v
combination pane. One pane displays a tabular view of activities in a hierarchical tree structu
other displays a graphical view of acti

The Task Assignment view is a combination view o
Manage Resources sheet and Resource Utilization chart in the bottom pane. When you select an 
activity in the Gantt view, resource information about the task appears in the Manage Resource 
view. You can simultaneously view the resource utilization of each resource in a graph format in th
Resource Utilization pane. 

Calendar 

The Calendar view allows yo

all the days in the month. The Day tab displays a day view with all the hours in the day. 

The Calendar view is helpful to
month. It shows tasks sched
by entering a nd the task a duratio
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Critical Path 

Critical path view helps you plan all activities that directly affect the completion date of a program.
cal Path is determined by identifying all the activities that have slack, below a pre-determined
ber of days.  

 
Criti  
num

Critical path activities act as the basis for creating a schedule and planning resource allocation. It 
quired to get a program back on track. Critical path 

 the current activity on the critical 
helps you analyze where a remedial action is re
can be viewed at activity and sub-activity level. The critical task is
path. 

Note If a schedule is on a critical path, the schedule bar on the graphical pane appears red. 

 
 

 you compare the current program schedule against estimated or 
rison, select an option from the 

 
 ld activity displays in pink. 

hedule of the parent activity displays in white. 

 e

In the ta
alongsid chedule information. 
 

Resou

r a particular program and their task allocation as 

topmost row  graph of all resources simultaneously. 

urce Sheet contains a set of users who are associated with the activities within a 
prog sources to a Resource Sheet reduces duplication and maintenance of 
reso ess the Resource Sheet from  View > Resource Sheet.

The tains fields with relevant user information such as Title, Business 
Pho d from Pool and so on. You can review, add, or edit information on 
eac  quickly create a resource list for your project by adding the name of each 

Comparative Gantt 

The Comparative Gantt view helps
actual schedules, or against a saved baseline. To view a compa
drop-down list in the main toolbar. The default comparison value is Estimated. All saved baselines 
display in this list for selection. 

In the graphical view: 

The Current schedule of a parent displays in orange. 

The Current schedule of a chi

 The Estimated, Actual, or Baseline sc

Th  Estimated, Actual, or Baseline schedule of selected child activities displays in gray.  

bular view, you can view baseline schedule information (start and end dates) in columns 
e current s

rce 

The Resource view displays a list of all users fo
per the schedule, in a calendar format. If you assign an allocation to a user, you will be able to view 
a bar graph in the pane below displaying the percentage of allocation. You can also select the 

- All Users - to view a bar

Resource Sheet 

The Resource Sheet allows you to view available resources and add selected resources to your 
program. The Reso

ram. Adding re
urces. You can acc

R iew con
ne, Email, Status, Assigne

esource Sheet v

h resource. You can
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reso related information. A resource can be an individual, a company or department, a 

Note eous updates to the Resource Sheet by different users is not supported. Updates 

urce and their 
piece of equipment, a room, or any other resource that you are using for your program. 

 Simultan
to the resource sheet are saved independently of Gantt chart updates.  

 
 

Resource Utilization 

tilization view displays all the resources and the tasks assigned to each resource. It 
s and task allocations from other programs in PPM as well. You can view the 

following information for each resource or resource group in this table: 

on 
t 

To fo  the report: 

1. .  

2. Within the Preferences dialog that opens, in the Columns tab, select the columns you want to 
lay. 

3. Use the arrow buttons to move selected column names from the Available Columns list to the 

e list using 
 

5. elect the appropriate check boxes for Horizontal and Vertical. 
6. nges. 
 

Custo antt Chart 
The lay of data within the Gantt Chart can be customized based on your 
pref re the display of columns, grids, bar labels, appearance, and styles 
usin at menu. 

le 
 in the Java Client General Info attribute settings. 

Setting Preferences 

mize column display and set other preferences such as preferred file download 
location, as described further. 

The Resource U
displays the task

 Name 
 Pool Name 
 % Allocati
 Schedule Star
 Schedule End 

rmat columns in

Choose Format > Preferences

disp

Selected Columns list.  

4. To rearrange the order in which the columns display, move them up or down in th
the up and down arrows.

To hide or show gridlines, s

Click OK to apply your cha

mizing the G
 graphical and tabular disp
erences. You can configu
g the options in the Form

The columns can be configured to display Page One attributes - the options that are made availab
in these fields are configured

You can custo

To customize column display: 

1. Choose Format > Preferences. 
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2. Within the Preferences dialog that opens, in the Columns tab, select the columns you want to 
a

3. Use the arrow buttons to move selected column names from the Available columns list to the 
Frozen or Non-Frozen columns list as desired. The Non-Frozen column displays all the visible 

1. Within the tabular view pane, select the column or columns. 

displ y. 

columns in the tabular activity pane. 

4. Click OK. 

To freeze, unfreeze, or hide one or more columns: 

2. In the right-click menu, select Freeze Column, Unfreeze Column or Hide as appropriate.   

Within the Columns tab of the Preferences dialog, you can use the  and  arrow buttons to 

 s

 

3. older to which you want your files downloaded 

4. , you can enter a default value for program names. For example, if 
several of your programs start with the same name, say 'ABC Program V.1', 'ABC Program 

ou can enter 'ABC Program' in this field so that you only need to 

es for the Download Page Two and Pag eld, this information gets 
downloaded when you are fline activity. If you 
select No, this inform roperties of a selected 
activity.  

 If you select Yes in t xit 
Gantt, where you ca
choose to unlock pr  need to access.    

OK to exit the Prefe

7. In the Format menu, click ese 
settings are maintained. 

 

arance and Style

ize the appearanc e from the 
following themes. 

 Metal 
CDE Motif 

 Windows 
 Windows Classic 

sort the order of the displayed columns. Or you can simply click and drag a column in the 
tabular view pane to change its location. 

To et preferences for offline mode: 

1. Choose Format > Preferences. 

2. Within the Preferences dialog, select the Advanced tab. 

In the File Location field, browse and select the f
for offline access. The default location for file downloads is your My Documents folder. 

In the Program Name field

V.2', 'ABC Program V.3' etc., y
change the rest of the name. 

5. Select other options as appropriate: 
 If you select Y e Three fi

 in Online mode, and can be saved for of
ation is loaded only if you choose to view the p

he Display Locked Programs on Exit field, a dialog appears when you e
n view the list of programs that are locked by you. You can then 

ograms that other users may

6. Click rences dialog. 

 Save Settings to save your preferences. The next time you log in, th

Appe  

To custom e of your Gantt Chart, choose Format > Appearance and choos
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 Kunststoff 
 Office 

To change the graphical view tyles: 
 

ical Path 
Custom Time Scale 

 Level Coloring 
 Standard 

You
cust

 Show Weekends 

 Show Horizontal Grid 

Onc s, select Format > Save Settings from the 
menu ba

Note

 style, choose Format > Styles and choose any of the following s
Agile 

 Activity Completion 
 Crit
 

 

Bar Labels 

You can select the text to be displayed on the bar graphs on the graphical view pane. The 
information will be displayed in relation to the task, program or phase corresponding to the bar 
graph. Choose Format > Bar Labels and select an option from the following labels: 

 Name 
 Start Date 
 End Date 
 Status 
 % Completed 
 None 

 

Grids 

 can choose the way you would like the grids in your graphical view to be displayed and 
omize the color of the grids and rows. You can select from the following options: 

 Show Vertical Grid 
 Vertical Grid Color 

 Weekends Color 

 Horizontal Grid Color 
 Color Rows 
 Even Row Color 
 Odd Row Color 

e you have made changes to any of the format setting
r to save changes. 

 e Save Settings command does not save changes to the Grid. Th
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View Bar 

The View Ba t is displayed on the left of the Gantt Chart and allows you easy access 

click  display the view. The View Bar is enabled by default. To disable it for a particular 
sess

ark next to the View Bar option indicates that the view bar is enabled.   

r is a pane tha
to view the different type of Gantt views. The Gantt view types are displayed as icons and you can 

 on the icon to
ion, select View > View Bar. 

Note A check m
 

Creating Programs, Phases, and Tasks 
Once you have created a basic program object in Agile webclient, you can develop this program in 
Gantt.  

nents and tasks that will comprise your program. You can then use the 
PM objects: 

fine Schedule 

 to be completed - Insert these as activities within the program. 

ch high-level task - Insert these as tasks within the activities. 

 

The File m

First, plan the list of compo
Gantt chart to translate these components into P

 Create a list of project deliverables - Define these as phases within the program. 

 Define target dates for the deliverables - Use these to work backwards and de
Start and Schedule End Dates for each Phase of the program. 

 Define the high-level tasks

 Define the sub-tasks for ea

Define milestones within the program - Insert Gates that open only upon completion of a set of 
related activities or on completion of a phase. 

 Allocate resources for each task and sub-task - Assign resources or resource pools for each 
activity in the program. 

 

Gantt File Menu Options 

enu in the Gantt Chart offers the following options:  

Menu Command Act ion  

New Creates a new root program with default program data.   

Open Opens a search window where you can locate and open programs from the 

n the Find From field. 
server. Available only in online mode. The search criteria you last used appears 
by default i

Open File Helps you search and locate a saved .gcx (Gantt Chart Exchange) file on your 
hard drive. If you saved a folder location as a preference in the Advanced tab of 
the Format > Preferences dialog, this folder is opened. If the current program 

pened using a .gcx file stored in a particular folder, that folder is opened.   was o

Save Saves the program to the server. Saved data includes: Page One, Page Two, 
Page Three, Schedule, Dependencies, Team, and Resources.  
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Menu Command Act ion  

Save File Saves the program to your hard drive. Saved data includes all activities, 
dependencies, resource sheet, activity states, and any modifications made after 
you last saved the program. 

Save As Saves the program to the server under a different name. Saved data includes: 
e, Schedule, Team, and Resource Sheet. 

Content (from the Content tab) is not saved.  If you save a Completed or 
gram, the new program's status is set to 'Not Started'. 

Page One, Page Two, Page Thre

Canceled pro

Save As File Saves the program to your hard drive under a different name. Make sure you  

program on the server inadvertently.  
change the name of the root program so that you do not update an existing 

Recent Files Displays a t of u  to 10 files that were recently opened from the hard drive.  lis p

Work Offline When selected, switches the Gantt to offline mode, regardless of server 
n. Connection 

status is displayed at the bottom right corner of the window. 
availability. To return to online mode, select this option gai a

 

Adding Activities 

You

 

 can add activities to a program from the Gantt Chart using the  Insert Activity options on the 
n toolbar or the right-click menu. Or you can use the quickemai r options listed below. 

To add an

1. w under wh dd an activity. 

2.  on your keyboard. This inserts a new low the row c  selected. 

3. e of the activity in the newly created blank row.  

class, 
use the s

4. In the Ac , select a subclass for the activity. 

te. The Schedule Duration field will automatically display the 
e start date and enter 
 end date is 

6. Clic

 
 

e ation 

 s icons indicate the status of each activity in the tabular activity pane. The 
icons are displayed next to the activity name of a program, phase, task or gate. 

 indicated by the following icons: 

 activity: 

Select the ro ich you want to a

Press the Insert key  row be urrently

Type the nam

The activity created will belong to the Task subclass. To add an activity of a specific sub
hortcut key Ctrl+Alt+A. 

tivity dialog that opens

5. Specify the Start Date and End Da
number of days based on the start and end date. You can also specify th
the total number of days of your program in the Schedule Duration field; the
automatically calculated. 

k OK to add the activity. 

Vi wing Activity Inform

Activity Status - Statu

The activity status is
    Not Started —The program has not started. 
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    Complete —The program is complete. 
    Canceled —The program has been canceled. 

  On Track —The program object is on schedule. 

  Needs Attention —The program or child objects are off schedule or overdue. 

  Off Track —The program or its child objects are more than 5 days overdue. 

Note The exact time period to elapse before the yellow and green indicators should 
display can be configured in Administration. Please refer to the Agile 
Administrator Guide for details on configuring this setting. 

 Activ d P2 details from the 
Gantt Chart.  

ty and select Properties. 

le before a new task can start. A dependency should be created to achieve this. See 
ependencies in Gantt

ity Information - You can view an activity’s general information, P1, an

To view program information, right-click a program activi
 

Adding Gates 

A Gate is a zero duration activity which signifies completion of a major activity similar to a 
milestone. A Gate can be added in the Gantt Chart to enable checks or control for completing tasks 
on schedu
“Creating and Editing D  (on page 100)”. 

2. n 

3. In th

4. Click
 

t toolbar icons to edit and move data around quickly. Most menu commands 

edit u can perform are listed here. 

rt Save option to 
save changes to the database. Save overwrites any changes others may have made to the 
PPM program while Gantt was open. You must be the program owner of the program you 
are working on to be able to save changes. 

 cell to make it editable. Alternatively, you can select a 
cell and press F2 on your keyboard.  

al 

To add a Gate: 

1. Select an activity on the tabular view pane. 

From the right-click menu, click Insert Gate. Or simply click the Gate icon on the toolbar. You ca
also use the shortcut key Alt+G. 

e dialog that opens, enter a name for the Gate and specify the End Date. 

 OK to add the Gate. 

Editing Data 

You can use the Gant
and icons have shortcut commands that you can use to save time. The shortcut command for each 
menu item appears next to it or becomes visible when you place your mouse pointer over it. Data 

ing actions that yo

Important After making changes in the Gantt Cha , you must use the Gantt Chart 

 
 

Editing Inline 

In the tabular view pane, double-click within a

All fields in the tabular pane can be edited, and changes are dynamically reflected on the graphic
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pane. 

Entering or Changing Dates 

dar.

In the gra e activity task; the dates are automatically 
usted in the Schedule Start and Schedule End columns. 

 date and the duration of an activity, drag the marker at the ends of each 
bar on the Gantt Chart. You can also click anywhere on the bar and drag the entire bar backwards 

To enter dates in the date fields, type in the dates or click the Calendar icon to select a date from the 
calen   

phical view, you can simply click and drag th
readj

To change the start or end

or forwards to change dates. 

 
 

he row number that appears in the first column, to the left of the 

Change Task Order or Hierarchy 

To select an activity row, click t
activity name. 

To move an activity up or down, click or  on the toolbar. You can only move activities up or 
down within the same level in the hierarchy. 

To make a selected activity a sub-activity (child) of another activity, click .  

Similarly, if you want to promote a selected sub-activity to a parent activity, click . 

n the field format shown below.  

 

Copy and Paste Options 

 Copy and Paste Programs from Excel 
To copy and paste a program directly from an Excel sheet into the Gantt tabular pane, data in 
the Excel sheet must be i

Sub-c lass  Name Schedule  Star t  Schedule  End 

<Activity type <Program Name> <Date format as per 
User Preference in 
Agile> 

<Date format as per 
User Preference in 
Agile> Example: Program, 

Phase, Task or Gate. 

Note All four fields are mandatory. Activity type and Program name fields are case-
sensitive. For Gates, the Start Date is considered as the E
zero-duration activity. Make sure you do not select the he

nd Date as it is a 
ader row when 

copying from Excel.  

 Copy and Paste Program Activities 

You can copy and paste single or multiple activities in the tabular view.  

 To copy, select the activity or activities, and click Copy in the right-click menu, or click  

elect Paste in the right-click menu 
or click 

on the toolbar.  
 To paste, place your cursor on the destination row and s

 on the toolbar. 
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 Copy and Paste Content  
Content must be pasted in a relevant destination. For example, you cannot copy a text field into 

 copies 

To

1. 

2. 

e hed to the activity, and the fill action results in the Successor 

a date format field. 
 

Fill up or Fill Down 

You can replicate content such a  activity names or dates on the tabular view. This action
the text of the selected cell to adjoining cells you select.  

s

 fill up or fill down: 

Select the cells in which you want to replicate content. The first cell in the selection is your 
reference for Fill Down, and the last cell in the selection is your reference for Fill Up.  

Right-click and select Fill Up or Fill Down as appropriate. 

Alternatively, place your cursor on the corner of the selected cell. The cursor changes into a cross-
hair shape. Drag the cross-hair up or down to replicate the same text in the cells above or below. 

Not  If there is a dependency attac
date falling before the Predecessor date, the action is disallowed.  

 

Creating and Editing Dependencies in Gantt 

You can  
schedule
complete
accurate
accurate

To create

1. Clic toolbar. The cursor turns into a cross-hair pointer. 

2. he direction you 

Note her, 

create a dependency between two activities in the Gantt Chart. By default, all program
s begin on the start date of the first task and finish based on date of the last task to 
. When dependencies are created, the Gantt Chart adjusts the schedule to assign more 
 dates to each task. Dependencies can change the program’s finish date to be more 
. 

 a dependency: 

k the Create Dependency icon on the 

Drag the cross-hair pointer from the start point of the task to its end point. T
drag and the start point or end point of the task you select determines the dependency type. 

If you need to create a dependency between two tasks that are not close to each ot
you can type the dependency directly into the predecessor column. Type the 
predecessor’s task ID no. (shown on the right-hand side of the tabular view) in the 
Predecessor column in the tabular view pane. 

You can e Edit > Create Dependency menu command. 

To e epen

1. Double-c  Edit  > 
Edit Depen

n menu. 

 

 
 

 also create a Dependency using th

dit a d dency: 

lick the dependency arrow link on the graphical view of the Gantt Chart or select
dency.  

2. Select the type of dependency from the Types drop-dow
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Deleting Objects in Gantt 

You can delete programs, phases, tasks, and gates in the Gantt Chart by selecting the activity you
want to delete and clicking on the Delete ico

 
n on the toolbar. You can also use the Edit > Delete 

option or the keyboard shortcut Ctrl+Delete. 

 the Gantt Chart, you need the appropriate Delete privilege assigned to your 
role. If you do not have this privilege, deletions that you make in the Gantt Chart are not applied 

sage indicates that you do not have the appropriate privilege to 

nistrator to ensure that you have the appropriate Delete privileges. 

e you will not 

To delete any activity in

within Agile PLM. An error mes
delete activities. 

Contact your Agile PPM Admi

Not  If the update fails because you do not have the appropriate Delete privileges, 
be able to go back to the original program tree in the Gantt Chart. You must go back to 

start the Gantt Chart again. Agile PPM and 
 

Undoing Changes 

The Gan
action  s
bas on

also use the shortcut key Ctrl+Z 
tion. 

You can print any view of the Gantt Chart using the Print option in the File menu.  

nt window, or the Print Preview window, you can manually change Page Setup options 
 page margins are set to .5 inches, and the page orientation is set to 

e program. 

t in Gantt allows you to do the following: 

 of a resource for a particular task. 

 Swap resources across projects to handle attrition or reassigning. 

 Add new team members globally or on specific tasks within an active program. 

tt Chart allows you to undo any action that you perform, except Save. You can also undo 
s uch as the opening of a program. The Edit menu displays contextual Undo or Redo options 

ed  the current action.  

Only one Undo or Redo operation is supported per action. You can 
to undo an action. Pressing Ctrl+Z a second time will redo the ac

Printing a Gantt Chart 

Within the Pri
if necessary. By default, the
Landscape. 

Resource Management 
The Gantt Chart offers dynamic resource management capabilities that help you assign resources 
to programs or tasks within a program. You can also delegate ownership to resources for defined 
activities within th

Resource managemen

 Add new resources. 

 Add or remove existing resources. 

 Change roles assigned to resources. 

 Change the percentage allocation
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 Change a user’s role throughout the proj

 Remove users globally or from individua

ect or on specific tasks. 

l tasks while saving completed work and actual hours 
billed. 

esource pool of a user globally or for a project. 

ss

You c e Management allows you to 
etween programs. 

o add resources to your program: 

 Change % allocation at a single-task level or apply the change to all leaf-level tasks. 

 Change the r
 

A igning Resources 

an assign resources to your program from within Gantt. Resourc
allocate resources to various programs and also split resources b

T

1. Select an activity and click  on the toolbar. The Manage Resources dialog opens. 

 
2. In the Manage Resources dialog: 

1. To add a resource, click . This creates a new row in the table. To enter a value in the 
new row under the Name column, double-click the cell and choose a resource name fro
the list of values that appears.  

m 

To add resources from a resource address book, click . Click Find to view all the 
resources from the selected resource list. Use the Find From drop-down list to select a 

l or 

Depending upon your selection, more options become available. Click Options to perform a 
parametric search to find resources. For more information on Parametric Search, see the 

 Resources table. 

resource list from your existing resource sheets, for example, an existing resource poo
resource sheet list. Resources or resource pools that have already been added do not 
appear in the search results. 

Agile PLM Getting Started Guide. 

2. Click OK. Selected resources appear in the Manage

3. In the Roles column, specify the role for each resource. To change cell values, double-click 
the cell and click . In the dialog that opens, select a role from the Available Roles 
column, move it to the Selected Roles column, and click OK. 

4. In the % Allocation column, enter the percentag
allocate for this activity. If the resource rejects

e of the resource's time that you want to 
 the activity assignment, an   icon is 

displayed in the Rejected column.  
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Note The percentage (%) allocation for a full-time resource who is assigned to only 
one activity is 100%. If the resource is being shared across multiple programs, 
the percentage allocated would vary depending on the time allocation towards 
each program or activity. 

3. To assign a resource, select the row and click Apply.  

Before you assign resources, you can confirm availability of each resource. See "Viewing 
Resource Utilization (on page 103)".  

 

Viewing Resource Utilization 

To view resource utilization data, click  at the top right corner of the Manage Resources dialog. 
This opens the Resource Utilization chart. 

The Resource Utilization chart helps you to view resource availability before you assign a resource 
to a particular activity.  

Removing Resources 

To remove assigned resources: 

1. In the Manage Resource dialog, select a resource or multiple resources to delete. 

2. Click . A message prompts you to confirm deletion.  

3. Click Yes to confirm. 

4. In the dialog that opens, select either of the following: 
 Delete resource and re-assign % allocation to pools (if applicable) - Select this option if you want 

to delete the resource and re-assign the resource allocation percentage to other resources 
in the program resource pool. 

 Delete resource and discard % allocation - Select this option if you do not want to re-assign the 
resource allocation percentage. 

The selected resources are removed as per your specification. 

Note In the Manage Resource dialog, a black check mark next to the resource name indicates 
that the resource is allocated to all selected tasks. If the resource is allocated to at least 
one task, but not all tasks, the check mark will be grey. 

 
 

Delegating Owners 

You can delegate ownership of an activity to a selected resource. In this way, you can assign an 
owner to each task in your program. When you delegate an owner to a task, a request is sent to the 
owner for approval. See also: "My Assignments (on page 38)". 

Once the delegated owner accepts the request, that resource owns the task and the delegated field 
becomes blank. 
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To delegate ownership: 

1. Select the activity or task. The Delegate Owner  icon is enabled. 

2. Click . A list of default resources is displayed.  

3. Select the resource from the list, or click  to select resources from the Address Book.  

4. Click OK to delegate ownership. 
 

Working Offline on Gantt 
You can continue working on the Gantt chart even when you are not logged into Agile PLM. The 
Gantt client can be used as a standalone application on your computer. This feature enables you to 
do the following: 

 Continue working on a program while traveling or during server downtime. 

 Create a preliminary draft of a program and make it available online only when you want other 
users to see it. 

 Email a saved program to others for opinions and updates. 

 

The first time you launch a Gantt chart from <Web Client>, you are provided the option to save a 
shortcut to the Gantt chart on your desktop. Once you save the shortcut, you can use it to launch 
Gantt and work on it offline.  

Reviewing Changes 

After making changes to a program offline or online, you can review your changes using an HTML 
report before saving the program.  

To review your changes to a program: 

1. From the Tools menu, select Show Changes. 

A new window opens, showing a comparative view of changes recorded on the server and on 
the Gantt Chart. Activities that have been modified, added or deleted are indicated by the 
colors shown in the legend below the table. A icon indicates a modified object.  

2. To see details of changes made to an activity or gate, click its name. A pop-up window shows 
Page One, Page Two, Page Three, Schedule and Resource information with old and new 
values. Scroll down to see all changes. 

3. To view details of any modifications made to your program schedule, allocated resources, 
dependencies, or Page One / Page Two / Page Three fields, click the appropriate icon in the 
respective columns. 
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Toggling the View from Gantt to Web Client 

While you are working on the Ga
option is available in all modes o
from the Program Tree is selecte

To switch to the <Web Client> view of the current program: 

in the Gantt chart. 

2 In
th

3 L

 you clo

for their u  Programs 
dialog tha  wish to unlock for the use of others and click OK. 

ntt Chart, you can switch to the <Web Client> view if required. This 
f the Gantt Chart and is highlighted only when at least one row 
d.  

1. Select one or more activity rows 

.  the Tools menu, or in the right-click menu, select Show In Browser. If you are not connected to 
e server, the Agile PLM login screen appears.  

. og in to Agile. A new browser window opens for each activity row that you selected. 

 
 

Unlocking Programs before Exiting 

When se the Gantt Chart after working on it in Offline or Disconnected mode, the programs 
that you opened from Gantt remain locked. To ensure that programs used by others are unlocked 

se, you are prompted to unlock programs before you exit. Within the Unlock
t appears, select the programs that you
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Working with Microsoft Project 

This chapter includes the following: 

 7 
 ported Microsoft Project Files..................................................................................................... 107 
  

If yo
con

For ject files, see the Agile 9 Import 
Exp

Note ject are not 

Before You Begin................................................................................................................................................. 10
Working with Im
Microsoft Project Troubleshooting Tips ............................................................................................................... 110

u use Microsoft Project 2002 or 2003, you can import your project file to Agile PPM, and 
tinue managing your project from there. 

detailed information about how Agile works with Microsoft Pro
ort Guide.

 Certain complex dependency and constraint types supported in Microsoft Pro
yet supported in Agile PPM. For further information see “Microsoft Project 
Troubleshooting Tips (on page 110)”. 

 
 

Be
re all your Microsoft Project team members exist in the Agile database 

ake sure you have the Microsoft Privilege assigned to you by your Agile administrator. 

1.  Open Microsoft Project. 

ith Microsoft Project 98 and 2000 project files is not supported. If 
you have Microsoft Project
Micr  
For  in the Microsoft Project menu. 

onization Setup. 

fore You Begin 
 Make su

 If your work site has previously used PPM 8.5 or 9.0, uninstall the 8.5 or 9.0 macros. 

 M

To uninstall the Agile PPM 8.5 or 9.0 macros:

2.  Select Tools > Organizer > Modules. 

3.  Open Global.mpt and delete the Get File and XML macros. 
 

Working with Imported Microsoft Project Files 
In Agile PLM 9.2.2, integration w

 98 or 2000 project files with which you would like to work, open them in 
osoft Project 2002 or 2003 to automatically convert the project files to the appropriate format.
more information, select Help > Microsoft Project Help

Setting Up Microsoft Project Synchronization 

To install the plug-in: 

1. Choose Tools > Microsoft Project Synchr
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2. Agile displays a warning-security message. Click Yes. 

e the Setup window. 

ither of the following: 
Open Microsoft Project and make sure the 

3. Clos

4. Do e
 Agile Menu appears on the menu bar. 
 Click the Microsoft Project button from any Agile program, then select Launch in Microsoft 

Project. This starts Microsoft Project and installs the Agile menu. 

The figure below shows the Agile Menu item on the Microsoft Project menu. 

 

that contains only one Level 1 task, as the basis for 
 rolled up under a single project; PPM transforms 

ars. 

osoft project file as an .xml file and use this file to publish the 

roject file saved as an .xml file: 

 > Save As to save the project file as an .xml file. 

 Project Publish. 

want to publish. 

u soft Project 

deta

To la

1. 

2. nu, choose Microsoft Project > Launch as Read Only or choose Microsoft 

3. 

 

 

Creating a PPM Program from an Existing Microsoft Project File 

You can use an existing Microsoft Project plan 
an Agile PPM project object. (All tasks must be
that project into the root program object.) 

To create a PPM program from an existing Microsoft Project file: 

1. Open the target file in Microsoft Project. 

2. Choose Agile > Publish to PPM. The Agile PLM Publish page appe

Alternatively, you can save the Micr
project. 

To create a PPM program from an existing Microsoft P

1. Open the target file in Microsoft Project. 

2. In the Microsoft Project menu, select File
3. Move to the Agile Tools menu and select Tools > Microsoft
4. Navigate to the Microsoft Project .xml file you 

5. Click Next. 
 

La nching a PPM Project in Micro

You can launch a PPM program in Microsoft Project if you have the appropriate privileges. For 
ils of required privileges, see the Agile Administrator Guide.  

unch a PPM project in Microsoft Project: 

Open the program you wish to launch. 

From the Actions me
Project > Launch in Edit Mode. Microsoft Project opens. 

Specify that the file should be launched As a New Project. 
4. Click Finish. 
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Re

e you choose can 
affect program data. 

When you launch a PPM project in Microsoft Project using Launch as Read Only, it allows you to 
in 

PPM. In Microsoft Project you can perform any edit, modification, or analysis actions you 

The 
affec program file. 

aunch in Edit Mode, the PPM 
. Your name appears in the 
ct.  

 when you save a PPM program using the Save As XML menu 

For 

ad Only and Edit Modes 

You can launch or save a PPM program in Read Only or Edit mode. The mod

 Read Only Mode 

view, print, or analyze a PPM project in Microsoft Project without altering the project data 
Agile 
choose. You can save the Microsoft Project file in any local or network directory to which you 
have access. 

However, you cannot publish the launched-as-read-only program back into Agile PPM. When 
you launch as read-only, the PPM project is not locked, the Lock User field remains empty, and 
the Schedule Editor field remains set to PPM. It is therefore possible for another user to modify 
the PPM project by using any of the available Agile PPM edit methods: edit in PPM, edit in 
Microsoft Project (Launch in Edit Mode), or edit in Gantt Chart. 

Microsoft Project file that you create when you use Launch as Read Only is not updated or 
ted by any subsequent edits or modifications made to the PPM 

 Edit Mode 

When you launch a PPM project in Microsoft Project using L
program is automatically locked so that no other user can modify it
Lock User field, and the Schedule Editor field is set to Microsoft Proje

You are able to publish the launched-in-edit-mode program back into Agile PPM. 

The same considerations apply
commands. 

more information about locking programs, see “Multiple Users Editing the Same Task (on page 
. 

rking Offline on a PPM Program 

48)”

Wo

If you do not have Microsoft Project installed on your computer, you can save your PPM program to 

cha

 
  - Edit Mode 

c
see "

your local drive as an XML file, and work on it offline. You can access this file from a machine on 
your network which has Microsoft Project installed, view or edit it offline, and then publish your 

nges back to PPM when you are online again.  

You can use either of the following commands to save your program as an XML file: 

Save as XML - Read Only  

Save as XML

For onsiderations that you should be aware of before you choose Read Only or Edit mode, 
Read Only and Edit Modes (on page 109)".  

To save your program as an XML file: 

1. Open the program you wish to save. 

2. From the Actions menu, choose Microsoft Project > Save as XML - Read only or Save as XML - Edit. 
3. Download the file to your local drive. 
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Note If you are using Windows XP with Internet Explorer 7, default security settings for file 
downloads may result in duplication of History records during the Save as XML - Read 
only operation. To prevent this: Ensure that the Web Client URL is added under Tools
Internet Options > Trusted Sites > Sites

 > 
. Under Custom Level settings, select Enable for 

"Automatic prompting for file downloads". 

 

 
 

Microsoft Project Troubleshooting Tips 
If Microsoft Project sync does not work, you may want to reinstall the Agile PPM menu. To do so, 
you need to manually remove the pre-existing Agile menu by doing the following: 

To see a list of active COM add-ins for Microsoft Project:
1. Go to Tools > Customize > Toolbars. The “Customize” window opens. 

2. From the Commands tab, within the left-hand list, select Tools. 

3. Locate “COM Add-Ins” in the right-hand list. 

4. Drag and drop “COM Add-Ins” from the list onto the menu bar. 

5. Close the Customize window. 

6. Click the newly added COM Add-Ins menu. A list of all the installed add-ins is displayed. 

To manually uninstall a COM Add-In from Microsoft Project:
1. Click the COM Add-Ins menu to see a list of COM Add-Ins. 

2. Select the add-in you wish to uninstall. 

3. Click the Remove button to uninstall the selected add-in. 

Other things that might cause difficulty with integration:

 Split-task resource assignments 

 Use of actual dates vs. scheduled dates 

 Customized calendars and working days 

 Constraint types such as Must Finish On are not maintained in the Agile system after you Publish 
from Microsoft Project. Therefore, launching the plan back into Microsoft Project will result in 
different dates than those in the initial Microsoft Project plan. 

 Microsoft Project allows duration to be entered in hours. PPM uses days as the lowest unit of 
time. Therefore, accuracy issues are compounded with heavy usage of tasks that are less than 
one day's duration. 

 The Agile PPM project name must be at outline level one in Microsoft Project. All Agile PPM 
subtasks, phases, and gates must be indented under level one in Microsoft Project. 

 Within Microsoft Project, each resource for your program needs to be assigned a certain % 
allocation within the Resource tab of the relevant Task. The maximum value you can enter for 
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this field is configured in Java Client. The default setting is 400. If you enter a
than the maximum value setting, errors result when you publish to PPM. This
for % allocation can be reset in Java Client (Team attributes) if required.  

Note Microsoft Project outline numbers are not imported 

 value greater 
 maximum value 

into Agile PPM. 
 

Deleting Objects in Microsoft Project 

You can delete programs, phases or tasks in Microsoft Project by using the Microsoft Project 
fe r

When
c k
o at
e te
ou will see an error message telling you that you do not have the appropriate privileges. 

blish to PPM fails because you do not have the appropriate Delete privileges, you 

atu es. 

 you update Agile PPM with the changes you have made in Microsoft Project, Agile PPM 
hec s your assigned Delete privileges to ensure that you are allowed to delete programs, phases, 
r g es in Agile PPM. If you have deleted activities in Microsoft Project that you are not allowed to 
le  in Agile PPM, none of your Microsoft Project changes are written to the Agile database, and d

y

Note If the pu
will not be able to go back to the original program tree in Microsoft Project. However, you 
can go back to Agile PPM and launch Microsoft Project again. 

If you are not able to delete specific types of PPM objects in Agile PPM, you will also not be able
delete them in Microsoft Project and update the Agile database. 

 to 

re the accurate mapping of work values from Microsoft Project to a PPM program, some 

ed based on the % allocation and 
 Project, Agile PPM requires an allocation to a resource or resource 

ated. To ensure that effort data values without resource 

s. 

sfy these conditions have a generic resource pool associated to them on the Team 
tab. 

st  creating new tasks in MSP for a PPM program, you can override 
the default su  in the Text29 column with custom subclass values specified in the 

t the 
propriate values in the MSP/Agile PPM mapping file (MSPSyncMapping.properties on the 

se v P  at no p

Caution Data in the Text3 ot be tampered with, as this could interfere w  
sy ati nd  error

For detailed ation on any of the e uct Portfolio Manag
settings in the Agile PLM Administrator Guide. 

Transferring Microsoft Project Work Values to PPM 

To ensu
data manipulation is required. 

 Days Effort - In Agile PPM, days effort is always calculat
duration. Unlike in Microsoft
pool in order for days effort to be popul
or resource pool allocation are not lost while publishing tasks from Microsoft Project, your Agile 
administrator can set up and define a generic resource pool to hold the work/days effort value
If your Agile administrator has defined the generic resource pool, you will notice that tasks 
which sati

 Cu om Subclasses - While
bclass values

Java Client. 

 Page Two Attributes - To ensure the correct mapping of Page Two attributes, you must edi
ap
Agile rver) pro ided by Agile. age Three tributes can t be map ed. 

0 column should n ith the
nchroniz

 inform

on process a  cause

 above, se

s. 

the topic on Prod ement 
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Note Within Micro e on rce b etw nd soft Project, th  % allocati  for a resou  should e a value b een 0 a
400 to ensure er  data mapping. The default maximum value for the corresponding 
field in PPM is 400. If you wish to assign a highe chang
co on for the Team attributes in J s appropriate rn h ify 
attributes, see  the Agile PLM Administrator Guide 

ror-free
r value, you can 

ava Client a
e the def

. To lea
ault 

ow to modnfigurati
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Import and Export 

ng: This chapter includes the followi

 
 Before You Begin................................................................................................................................................. 114 
 Supp

Overview.............................................................................................................................................................. 113 

orted File Formats ....................................................................................................................................... 115 
...................... 116 

................................................................................................................ 121 
 

The Import wizard enables you to add and update large files (product content) from other formats 
t is required to start your business 

processes within Agile, but also enables you to update product content periodically. The Import 
y to reap the value of Agile solutions. 

quickly upload them in bulk into Agile through the import 

The Impo ws you to import the followi bjects into Agile PPM, in a orting 
rmatio

 Discussions and Action Ite
at ty  a ned tasks, 

a is rting 
discussions, the relevan  be inclu n 
data file. 

Note Discussion and Ac nd not ou cannot update or 

 Importing Data ...............................................................................................................................
 Exporting Data .....................................

 

Overview 

into Agile PPM. Import not only brings in legacy data tha

process must be implemented appropriatel

You can create large data source files and 
procedures described here. Prior to import, you can set preferences to specify the conditions for 
import. 

rt Wizard allo ng o ddition to imp
standard program info n from previous Agile releases. 

ms 

Discussions are ch
with owners and due d

pe notifications relating to a program
tes, found on the program object’s D
t program information must also

nd Activities are unplan
cussions tab. When impo

ded in the Import Discussio

tion items can only be created a  updated. Y
modify existing data. 

The figure below shows a s  Discussion ain 
values for Number, Name, D e, Status, Priority and Notify List 
fields. 

ample of the data file for importing
iscussion Type, Subject, Messag

s. The file must cont

Number  Name Discussion  
type  

Subject  Message Status  Pr ior i ty  Not i fy  
L ist  

D00123 Shopper, Discu
Henry 

ssion Quote 
Questions 

Please post 
all questions 

resolution. 

Open 3 - Low Agile, 
Acme03 

here for 
quick 
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Nu ber  m Name Discussion  
type  

Subject  Message Status  Pr ior i ty  Not i fy  
L ist  

D00021 Maguire, Discussion Need for To get 99% Open 
Paul multiple 

English 
accur
differe

Versions versions 

acy, 
nt 

1- High Hage - QA 
Manager, 
Joe, Tom, 
Smith 

needed. 

D00101 Maguire, Discussion Regulator The 

for Regulator 
is on hold. 

Open 2 - 
 

Salesy-
Quanta 
ODM, Roy, 
Jones 

Paul manufacturer Medium

 

 Users and User Groups 

User and User Group information is often changed and updated. Importing Users and User 
Groups provides a quick way to update the information in your Agile system. 

oot 
t programs with PI, P2 and P3 fields. You can export data, make 
P2 and P3 fields in it, and import it back into Agile. 

Befo  y PPM: 

 ppropriate Agile PPM user license and privileges. To import Agile data, you 
ead, and Modify and Import privileges for each type of Agile 

also need to have the Import privilege options enabled in Java 
 

er privilege and Import privilege. 

field. Certain fields are mandatory, therefore 
you need to map them in the Import wizard fields. Fields also have data types, which determine 
how the data should be formatted, and maximum lengths, which the Agile PPM system 
validates on import. These are set in the Import Wizard Preferences. 

Make sure that your data is in the correct file format. If you are importing data from text files, check 
sure that it is in a supported file format, and matches the Import 
details, see “Supported File Formats

 R Programs (Updates only) 
You can import Roo
modifications to P1, 

Before You Begin 
re ou import data from source files into Agile 

Make sure you have the a
must have Create, Discover, R
object you are importing. You 
Client. If you have questions about privileges, contact your Agile PPM administrator or refer to
the Agile PPM Administrator Guide. To launch Import, you must have the My User Profile role, 
Read Us

 Make sure you understand the specifications for each 

 
your source data to make 
Preferences settings. For  (on page 115)”. To create aXML 
files, use Agile Content Service (ACS), Agile Integration Services (AIS), or create an aXML file 

 sufficient hard disk space for importing large data files or create 
. 

from the Export command. You can view aXML files in any XML viewer, including Internet 
Explorer. 

 Make sure the Agile PPM system has
an aXML file from Export Wizard
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Persistence of Import Settings 

Whe o session. 
The sett

 
 
 Sele

 Sele

 
 ted 

When you cho tion file 
are reset. 

Before im e file, clear the L rmations preference chec faster results. If 
you a arge amou e import ses sion 
during non-business hours - when ow. After the import session is finished, you can 
view the log file in a browser o

For more information, see the port Guide.

Supported File Formats 
You nd export da ile formats. The fol  

n y u use the Import Wizard in Web Client, the data stays as long as you maintain the 
ings that persist include: 

Import preference settings 

Source file configuration 

cted content to import 

cted mapping file 

Selected transformation file 

Selec change number 

ose a different source file, the selected content, mapping file, and transforma

Importing Large Data Files 

porting a larg og Transfo kbox for 
re importing l nts of data during on sion, you should perform the ses

system usage is l
r save it to a file. 

 Import and Ex

can import a ta in several f lowing file formats are supported:

Use F i le  Type Descr ipt ion To  Import  

Delim A standard flat text file where each field 
data is delimited by a special character, 
such as a comma or a tab. 

ited Text File (.dtf) Any object. 

Exce M ook files. The impo
wizard supports files created from MS 
Excel 2000, 2002, 2003, and Win XP. 

l Workbook (.txt,.csv) icrosoft Excel workb rt Users, User Groups, Root 
Programs, and Action Items. 

Agile XML (.axml) Agile’s proprietary XML format that 
includes data not supported by PDX. 

Users, User Groups, and 
Discussions 

MS Project Export File (.xml) XML data exported from Microsoft Projec
for import to Agile. For more information 
about this format, see the Agile Import 
and Export Guide. 

rosoft Project. 
t Programs and program objects 

created in Mic
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Importing Data 
To launch the Import function, click s the Import Wizard that guides you 
through the import procedure. steps: 

1.  Define import preference

2.  Select the source file to  specify file type. 

3.  Select the content from t  can be imported. 

.  Map source fields to target solution fields to store the imported data. 

5.  Tr e field data into the Agile format. 

6.  format tered and star

An Import log records the he results and errors. 

Each step of the import p scribed in detail in the following sections. 

Define Import Preferences 

Preference settings allow you to set different conditions to run the import. The Import wizard has 
seve ttin et from any step i ersist 
durin  current Agile PLM client session, but they are no r’s 
profile. 

Note tings  can complete the s. 

Tools > Import.   This open
 Importing is done in five 

s. 

be imported and

he list of contents that

4

ansform sourc

Review the in ion that you have en t the import. 

 process, and logs t

rocedure is de

ral preference se
g the

gs that you can s n the wizard. These settings p
t permanently saved with each use

These set are optional; you  import without specifying preference

To set import preferences: 

1. Click the Preferences button at the bottom left corner of t
Preference Settings window appears. 

2. Select one of the following from the list: 
 Parsing and Validation Options 
 Business Rule Options 
 Default Types 
 AutoNumber Sources 

Depending on the option you choose, the wizard displays a list of values that you can define. 
ch setting you define, see the Agile Import and Export 

he Import wizard. The Specify 

For complete details on the impact of ea
Guide. 

3. Select preference settings and click OK. 
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Select Import Source 

The Import Source page in the Imp
configure it for import. 

ort Wizard lets you select the source file to be imported and 

To s ile for the import: 

1. om

2.  your 

elect the source f

Fr  the Import Source page, select the File option. 

Specify the file name. Type in the file name or path or click Browse to select the file from
local drive. See also “Supported File Formats (on page 115)” before you choose the type of
file

ct one of the 

 
. 

3. Sele

character such as a comm xtension .csv or .txt. 
xcel hese 

must
 Product Data eXchange (PDX) package: oduct content. 

their 
mat and must have a .pdx extension. The PDX package 

uct content managed in Agile 

Note e you can select only one object type to 

File type options: 
 Delimited Text file(.dtf): Text files where each field of data is delimited by a specified 

a or tab. They must have a file name e
 E  Workbook: Spreadsheets with rows and columns that allow you to format data. T

 have a filename extension .xls. 
Standardized XML format containing pr

You can import from a PDX package. Attachments are imported along with 
associated objects in PDX for
does not support any PPM objects, Users, and User groups. 

 Agile XML (aXML) Package: An XML format that contains all prod
PLM. aXML files must have an .axml extension. 

 With the Delimited Text file and Excel fil
import, while with the aXML and PDX files you can select multiple objects to 
import. 

4. iguration options appear. Select 
the 
Click Configure. Depending on the file type that is chosen, conf

appropriate options for your import and click Next. 

Field  Name Opt ions Act ion  

Template Type Standard

Parent-ch

, no template 

ild Template 

Select the template type of your import 
file. 

Level Template 

Field Delimiter Comma (,) 

Tab 

Vertical Bar (|) 

Select the appropriate field delimiter which 
will separate figures or text within the file. 

Text Qualifier Apostrophe (‘) Select the symbol which will qualify the 

Double quotation mark (“) data as text and not figures. 

Location of Header Row (any row number) Specify the row number within the 
worksheet which contains the text to be 
used as the header row. 
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Field  Name Opt ions Act ion  

Location of Last Row (any row number) Specify the row number in the worksheet 
to be taken as the last row to import data. 

This can be used if you want to import a 
table format file which may contain 

last row specified. 

multiple object types. Import will only load 
specified data based on header row and 

File Encoding Japanese (EUC) Specify File encoding.

Japanese (Shift-JIS) 

 

Simplified Chinese (GB2312) 

Traditional Chinese (Big5) 

Unicode (UFT-8) 

O) Western European (IS

 

Field  Name Opt ions F ie ld  Descr ipt ion  

Template Type Standard, no template 

rent-child Template 

Select the template type of your import file. 

Pa

Level Template 

Select Worksheet (enter the sheet number) Excel files consists of several sheets in a 
single file. In case more than 1 sheet exists, 
you can specify the sheet number here. 

Location of Header 
R  

(any row number) Specify the row number within the 
worksheet which contains the text to be ow
used as the header row. 

Location of Last 
Row 

(any row number) Specify the row number in the worksheet to 
be taken as the last row to import data. 

This can be used if you want to import a 
table format file which may contain multiple 
object types. Import will only load specified 
data based on header row and last row 
specified. 

(This can be used if the import sheet is too 
o long and you do not want all the content t

be imported.) 
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S ect Product Contenel t 

The Product Content page in the Import Wizard lists objects that can be imported. These objects can 
ps. 

ported: 

 to Import page, select the content object you wish to import. 

 
Only data fields that can be can imported will be displayed in Agile PPM fields. Only fields that are 

fields and the Import data will be imported. The remaining data will not 

ping file which corresponds 
o th

 Creat pping file - If you wish to map the fields manually, select this option. 
 

 ion. 

be classes like Programs, Users, or User grou

To select product content to be im

1. From the Select Contents
2. Click Next to move to the next step. 
 

Map Import Data 

The Mapping File page in the Import Wizard helps you maps fields in the source data to Agile fields.

mapped between the Agile 
be included. 

To map source fields to Agile fields: 

1. In the Select Mapping File page, select one of the following options to define mapping 
specifications. 
 Use an existing mapping file - If you already have an existing map

t e file which is being imported, select this option. 
e a new ma

 Use currently defined mapping definition This option becomes available only if a mapping
definition already exists. If you wish to use the last mapping definition that was created, 

 - 

select this option. 
Default mapping definition - If you wish to use default settings to map fields, select this opt

Use an existing mapping file UsNote When you select  and the file is mapped, the e 
currently defined mapping definition option gets automatically selected, that is, the 
mapping that was created last is used. 

T

er Import fields in the left column, select the source field to import. 

lds. 

d. Mandatory fields for creating a program are displayed in bold in the Mapping dialog. 
Required fields appear in green. 

e. After mapping source fields to Agile fields, click Finished. 
You can save this mapping file for future use if you wish, using the Save As option. 

3. Click Next to move to the next step. 
 

Select Transformation File 

Before you import data, you may need to transform the values in some fields to make them 

o change any of the fields that are already mapped, click Edit Chosen Mapping. 

2. In the Edit Chosen Mapping dialog: 
a. Und
b. Click Expand All to view all the fields listed under Agile fields. 
c. Navigate to the corresponding Agile fields in the right column and select these fie

Ensure that all Required fields are selected. 
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compatible with the Agile system. You can use a Transformation Definition file to perform this 
transformation. Transformation definition files are especially helpful for importing data from PDX or 
aXML packages. Generally, PDX or aXML packages are read-only. You cannot change the values 
contained in an archived file. If there are data inconsistencies in a PDX or aXML package, you must 
try to correct them using a transformation definition file. 

A transformation definition file is a comma-delimited text file. Optionally, you can qualify text strings 
in the file using double-quotes ("). The file must contain a set of required fields needed to transform 
import data. 

Note The Import wizard does not support transformation definition files created with previous 
Agile Product Cost Management or Agile Product Collaboration releases. 

Transformation definition files are optional for importing data. If the source data does not need to be 
modified you can skip the Transformation Definition File step. Transformation file step is used only 
in case of aXML data as it cannot be modified in any other tool. 

To transform source field data into the Agile format: 

1. In the Select Transformation Definition File page: 
a. If you are not importing an aXML file, then select Do not Perform any Transformations and click 

Next. 
b. If you are importing an aXML file, select Apply Transformation and do either of the following: 
 Browse and select a Transformation Definition file from your directory. 
 Or click Download Transformation Template to download a template file that you can use as a 

Transformation definition file. 

Note All transformation that occurs during an import session are recorded in the 
Import Log file. 

2. Click Next to move to the next step. 
 

Review Settings and Begin Import 

The Review Settings and Begin Import page displays the import and preferences settings that you 
have defined. 

To begin the import process: 

1. Review the import settings to make sure all the fields that you wish to import are covered. 

2. To begin import, click Import. The source data is imported into Agile PPM. To cancel the 
process, click Cancel. 
An Import Summary Report generates a log report with the following: 
 Time information - States the time import started and the time of completion of import. 
 Processed Records Summary - Provides the details of objects that have been accepted, 

rejected or ignored. 
 Message Summary - Provides a summary of the errors in the imported data. 

 To redo the import process, click Restart. 

 To save imported data, click Save Log. 
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 To return to Agile Web Client, click Done. 
 

Exporting Data 
The Export Wizard enables the extraction of programs and objects from Agile PLM into other 
formats such as Microsoft Excel worksheets, comma-delimited text, PDX Package or aXML 

nding the content to customers or vendors. 

You can al

 D

 R

 U

1. Open an object to export. 

To start the Export wizard from Agile Java Client: 

ed, and select one or more objects in the Search Results 

To e

1. ort to drop-down list, select the format to which you 

e field, select a site. To export data for all sites, select All. 

if your Agile system includes the Sites server 

Package formats, for distributing or se

so export the following types of objects from Agile PPM: 

iscussions 

oot Programs 

sers and User Groups 

You can export PPM program or objects from Agile in Excel, Text (CSV) or aXML formats. 

To start the Export wizard from Agile Web Client: 

2. Choose Tools > Export. 

1. Open an object to export. 

2. Choose Actions > Export. 
3. Search for objects that can be export

page. 

4. Choose Tools > Export. 

xport a Program or PPM object: 

In the Objects to Extract page, from the Exp
want to export data. 

2. In the Sit

Note The Site field is only available 
license. 

3. To add programs or Agile objects, click . An Add Objects dialog opens, where you can 

ttachments as 
. 

 

4. Select the objects you wish to export and move them to the Selected area using the right arrow 
button. 

search for objects. 
 Use the Search tab to search for users, user groups, discussions or programs. Select the 

Search Attachments Contents checkbox if you want to search through a
well. Click the Advanced Search link to search using parametric search criteria

 Use the Saved Searches tab to browse through your saved searches in the PPM Search
Folders. 

 Use the Shortcuts tab to view the most recently used programs or objects, for faster 
selection. 
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5. To restrict the export to Page 1, Page 2 and Page 3 fields, select the Table Format check box. 

ta when prompted. 
 
6. Click Export. Specify a directory or location to save your export da
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Chapter 9 

ile e5.1 Integration 

This

Ag

 chapter includes the following: 

 Adding Agile e5.1 Objects as Deliverables.......................................................................................................... 123 
.......................................................................................................... 124 
.......................................................................................................... 124 

 Modifying Objects in Agile e5.1 ........................................................................................................................... 124 
.............................. 125 

ility 
ena
obje  
Agil
 

nnection has been established, you can add Agile e5.1 objects as 
eliverables to a PPM activity such as a program or task. 

To add Agile e5.1 objects to a PPM activity: 

1. From the Content tab of the PPM object, choose Add > Create New. 
2. In the Add Related Content wizard: 

1. Enter the object type, and provide a name and number. All fields are mandatory.  

2. Click Finish to add the object to PPM. 

If you need to add multiple objects, use the search option to locate and add several objects at the 
same time.  

To locate and add existing Agile e5.1 objects:  

1. From the Content tab of the PPM object, choose Add > Search. 
2. In the Add Related Content wizard: 

1. Use the search options under Search From Existing Agile-e Entities to search for the object by 
type. Select an object type, enter details as appropriate, and click Next. 

2. In the search results, select all the objects you want to add as deliverables. 

3. To add another type of Agile e5.1 object, Click Add More. Specify the object type, and 
repeat the procedure.  

4. When you are finished selecting all the required objects, click Finish to add the selected 
objects to the PPM activity. 

 

 Modifying the Trigger Event and Result.....
 Updating a Program to Agile e5.1..............

 Additional Information ............................................................................................................
Objects in Agile e5.1 can be added to Agile PPM activities and gates as deliverables. This capab

bles a change of state in an Agile e5.1 object to trigger a change in workflow status of an Agile 
ct. You can also copy Agile programs to Agile e5.1 as new projects, duplicate deliverables into
e e5.1, and launch the Agile e5.1 object in the Agile e5.1 web client directly from Agile PPM. 

Adding Agile e5.1 Objects as Deliverables 
Once the Agile e5.1 co
d
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Modifying the Trigger Event and Result 
Once the Agile e5.1 entity has been added, you can change the status-change trigger and result. 

To change the trigger event and result: 

1. Open the Content tab of the activity. 

2. Select the deliverable you want to modify. Click Add Rule. 

3. In the Relationship Rule dialog, specify the status change rule for this deliverable.  

4. Click Save to save the changes in Agile PPM. 
 

Updating a Program to Agile e5.1 
Once you have created a program in PPM, you can send the program structure, deliverables, links 
and roles on the Team tab to the Agile e5.1 system as a new Agile e5.1 project. 

You can copy this PPM program structure into Agile e5.1 from the Agile PPM root program. A flag is 
set at each Agile object to indicate whether or not it will be updated to Agile e5.1. 

Users who have access to the program in PPM are given access to the corresponding objects in 
Agile e5.1 through a role mapping that is set up by the administrator. Users must also have the 
necessary permissions to log into the Agile e5.1 web client. 

To update the Agile e5.1 database with an Agile program: 

1. Open the program. 

2. Verify that the Update to Agile e5.1 field on the General Info tab is set to Yes for all levels of the 
hierarchy that you want to copy into Agile e5.1 as Agile e5.1 project objects. If it is not, click the 
Edit button, and set the field to Yes. 

3. From the Actions menu, choose Update Program to Agile e5.1. 
4. Select the Agile e5.1 project into which you want to copy the PPM program. The new Agile e5.1 

project will be placed within the selected project. 

5. Select options to copy the deliverables, links, and roles of team members to Agile e5.1. 

You now can view the new project in Agile e5.1. You can select the In Projects tab within the Agile 
e5.1 web client to see the higher level project that was selected. 

Within Agile PPM, the root level program will now appear in the Content tab. You can click on the 
link to navigate directly to this project in Agile e5.1. 

Modifying Objects in Agile e5.1 
Agile e5.1 objects that appear on the Content tab can be modified in the Agile e5.1 web client. 

Note You must have the appropriate permission to log into the Agile e5.1 web client in order to 
add objects. 
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To modify an Agile e5.1 object on the Content tab: 

1. Click the object name. Then object opens in the Agile e5.1 web client. Separate l
re

2. M

If you make a change to the status of the object in Agile e5.1 (to promote it to its event or target 
status), then the corresponding activity in Agile PPM is updated when the page is refreshed. 

ing objects in Agile e5.1 web client, refer to the Agile e5.1 
web client documentation. 

A d

s 

source 
r attribute specifies the owner of the resource pool in 

ogin is not 
quired. 

ake your modifications in the web client and save.  

For more information about modify

d itional Information 
Additional information about the integration between Agile PPM and Agile e5.1: 

 A new user or user group added to the Agile e5.1 system is updated to Agile PPM during a 
periodic resource sync process. These users and user groups are not available for adding a
resources in PPM immediately, but they are available after the next periodic system resource 
sync. Users in Agile e5.1 that have person information, including first name, last name, and 
email, are automatically copied to the Agile PPM user list. 

 User Groups that have an owner and department are automatically populated as Re
Pools within Agile PPM. The manage
PPM. 
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Appendix A 

Creating Programs: A "Real World" Example 

This Appendix includes the following: 

 Step 1: Create a Program Template.................................................................................................................... 127 
ate a Sche ............................................................................ ............ 128 
ate the Roo ............................................................................ ............ 130 

 Step 4: Activate the Pr .................................................................. ............ 130 
his topic presents a sce gram manager would set up a simple program 

in Agile PPM. You can follo ram creation in Agile PPM.  

enario - You are the pro calibur Designs Corporation, which has been 
ntracted to create, test ototype electric “clown car” -- a ca ppears quite 

 a surp r of people. 

o create and structure t ile PPM, you would have to do the fol

Step 1: Create a pro

Step 2: Create a sch

eate a root program from this template and make it Active. 

tep 1: Create gram Template 
efore creating the actua create a program template so that you can reuse 
for similar programs later. Most programs that you create would have similar c s 

of tasks, resources, and de s. Once the template is ready, you can use it as a base and 
ange program content quired. 

 create a program templa

. Launch the Agile Web Client. 

r, select Programs > New. The Activity Creation wizard 

 Step 2: Cre
 Step 3: Cre

dule.......................
t Program ............

....................

....................
ogram............................. ....................

T nario to illustrate how a pro
s outlined here to try out progw the step

Sc
co

gram manager at Ex
, and implement a pr r that a

small, but can hold risingly large numbe

T he program in Ag lowing: 

 gram template.  

 edule and define a gate. 

 Step 3: Cr
 
 

S  a Pro
B l program, you decide to 
it omponents in term

liverable
ch and schedule as re

To te: 

1

2. From the Create menu on the main toolba
appears. 

3. Select Program as the Activity Type, and fill in details as described in the table below: 

Program Object  F ie ld  Set t ing  

Activities Type Program 

N eam RoboClown 

Schedule Start Date 03/01/2007 

Schedule Duration 154 (days automatically calculated when Schedule End Date is specified) 

Schedule End Date 09/30/2007 
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Program Object  F ie ld  Set t ing  

Description Design and implement prototype electric clown car. 

Project milestones to include: obtain requirements, create proposal, write 
specifications, build prototype. 

Delegated Owner  

Template Template  

Duration Type Fixed 

Days Effort  

 

4. After filling in the fields, click Continue. The Activity Creation wizard displays the project cover 

dule and status fields 
displayed here draw information from child objects of this program, and cannot be populated 

tabase as a program template. 
 

e 

 
 

Each de

1. gram's Schedule tab. 

2. 

3. 

hases in your program are sequential, you can 
f days. Once you do this, you can add a 

sor and successor phase. Adding dependencies 

omatically adjusted to honor these 

te , you are the default owner of all the phases. To change 

page. 

At this point most of the fields in the cover page are not filled in. Sche

until information can be compiled and rolled up. 

5. Click Finish. RoboClown is now present in the Agile da

Step 2: Create a Schedul
Let's assume that your project deliverables are as follows: 

 Obtain requirements (14 days) 

 Create proposal (15 days) 

Write specifications (110 days) 

Build prototype (110 days) 

liverable becomes a phase in the RoboClown program. 

To add these phases to the program: 

Open the RoboClown pro

Click Add to add an activity to the schedule. PPM displays the Add Activity wizard. 

Specify Phase as the Activity type, then create each phase one by one.  

Tip: While creating phases, if you are sure that the p
simply specify the duration of each phase in number o
Finish-to-Start dependency between each predeces
between phases ensures that a successor phase does not start until the predecessor phase is 
completed. The default start date for each phase is the start date of the root program. Once 
dependencies are established, start and end dates are aut
dependencies.  

No  As the program manager
ownership of a phase to another Team Member, you can delegate ownership during 
phase creation. 
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nd the expected duration of each phase, the phases are scheduled 

With the phases, define various tasks as described in the table below.  

Given a start date of March 1, a
to start as follows: 

 Obtain Requirements: March1 - March 18 
 Create Pr : March 21 - April 8 oposal
 Write Specifications: April 11 - April 29 
 Build Prototype: May 23 - September 30 

in three of 

Phase Task Dates  

Create Proposal Preliminary draft Mar 21-25 
 Core Executive review Mar 28-29 
 Incorporate comments, expand Mar 30-Apr 1 
 Final review Apr 4-7 
 Produce and distribute Apr 8 

Write Specifications Assign team members Apr 11-12 
 Preliminary draft Apr11-22 
 Engineering review Apr25-28 
 Incorporate comments, polish Apr 27-29 

Build Prototype Fabrication May 2-27 
 Initial test (lab) May 31-Jun7 
 Refine design June 8-July1 
 Track test July 5-8 
 Optimization and tuning July11-Aug5 
 Road test Aug 8-19 
 Acceptance test Aug 22-Sept 22 
 Demonstration Sept 26 

 

To add tasks to each phase within the program: 

1. Open the Schedule tab for the selected phase. 

2. Click Add to add an activity to the schedule. PPM displays the Add Activity wizard. 

3. Specify Task as the activity type, then create each task. 
 



 

Note   You can also carry out the steps described here using the Gantt chart. 

Create a Gate 

Let's say you want to make it mandatory that RoboClown passes the Acceptance test before a 
demonstration can be scheduled. According to the planned schedule, there is a short time window 
between the end of the Acceptance test and the demonstration. You can use that period to 
accommodate a “gate” for the project. 

To create a gate on “Acceptance Test": 

1. Open the Schedule tab of the Acceptance Test task. 

2. Click Add and specify Gate as the object type. The Add Activity wizard appears. 

3. Fill in the information for the gate. 

4. Click Finish. The General Info tab of the new gate appears. 

Once the program is made active, you can add this gate as an activity that needs to be monitored 
during a gate review by defined approvers or observers. 

Step 3: Create the Root Program 
Now that you have a template, you can create a root program from it. 

To create the root program: 

1. From the Create menu on the main toolbar, select Programs > From Template. 
2. In the Select Template page, select RoboClown V 0.1. 

3. In the Details page, fill in details as appropriate:  

1. In the Template field, select Proposed. Once you complete program creation and are ready 
to roll out the program, you can make it Active.  

2. In the Optional Components field, select Page One, Page Two, Page Three, and Content. 
This means that you can reuse the information you filled in for these components in the 
new program.   

4. Click Finish. Your new program is ready. The Project Summary page of the RoboClown V 0.1 
program appears. 

You can now edit program attributes further as you wish, adding dependencies between 
phases and tasks, adding team members and so on, using the options in the appropriate 
program tabs. For detailed information, see "Creating and Managing Programs (on page 43)".  

Step 4: Activate the Program 
The new RoboClown V 0.1 program is now ready to be rolled out. To activate the program, or move 
it out of the Not Started status, do either of  the following: 

 Change the Template setting. 

 Change the workflow status. 
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To change the Template setting: 

1. In the Program Navigation Pane on the left, select the root program - RoboClown V 0.1.  

2. Within the General Info tab of the program, click Edit to mak

3. Change the Template field setting from Proposed to Active.
status of Proposed or Template programs.) 

nged to Active, the Active setting rolls down to all children 

T

1 O

. Change the status of the leaf activity to In Process. The workflow status change rolls up to the 
root parent activity, changing the workflow status of the program to In Process. 

e the fields editable.  

 (You cannot change the workflow 

When the root parent activity is cha
activities. 

o change the workflow status of the root parent activity: 

. pen a leaf-level activity and click its Workflow tab.  

2

RoboClown V 0.1 is now active. 
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Appendix B 

Installation Notes 

This Appendix includes the following: 

 HProduct Portfolio Management User LicensesH .................................................................................................... X133X 
 HConfigurationH ....................................................................................................................................................... X133X 
 HUpgradeH ............................................................................................................................................................... X133X 

 
 

Product Portfolio Management User Licenses 
The PPM server license is required with a predetermined number of concurrent and power user 
licenses. Users are assigned as either a concurrent or power user by the Agile administrator using 
the Java Client. 

Once the PPM system is activated and users are designated as concurrent or power, the Agile 
administrator assigns roles that govern system-level access and functionality. For example, a user 
must typically be assigned a system-level Program Manager role to be able to Create new 
programs from the Create menu. 

However, on specific programs, an owner of a task or program can add users to the team and 
assign an object-specific role. The potential roles that are assigned are all the roles related to the 
program object, not just the system-level roles defined for that user by the Agile administrator. 

For more details on licenses, see the TAgile PLM Administrator GuideT. 

Configuration 
 For Japanese and Chinese OS, an Agile PPM database instance can only be configured to use 

UTF-8 language encoding. Agile PPM sets the browser’s character encoding to UTF-8, and it is 
not recommended to change the character encoding setting in the browser. 

 The Agile PPM Gantt application requires the International JRE 1.5 (Java Runtime 
Environment) on client systems. Higher versions such as JRE 1.6, and Japanese or Chinese 
JRE versions are not supported. 

 

Upgrade 
During an upgrade from a previous version of PPM, data migration is necessary in order for the 
existing data to comply with new or changed business rules. 

To facilitate the data migration, a post upgrade utility is available. For information on using this 
utility, see the TInstalling Agile PLM with BEA WebLogic TGuideT.T 

Note The PPM post upgrade utility is NOT supported on WebSphere Application Server. 
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