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THIRD PARTY SOFTWARE NOTICES

This product includes software developed by Apache Software Foundation (http://www.apache.org/).

THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE 
ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, 
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT 
LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR 
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Copyright © 2000-2009 The Apache Software Foundation. All rights reserved.

This product includes software distributed via the Berkeley Software Distribution (BSD) and licensed for binary distribution 
under the Generic BSD license.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS ``AS IS'' AND ANY EXPRESS 
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE 
COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER 
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN 
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Copyright © 2009, Berkeley Software Distribution (BSD)

This product includes software developed by the JDOM Project (http://www.jdom.org/).

THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE 
ARE DISCLAIMED. IN NO EVENT SHALL THE JDOM AUTHORS OR THE PROJECT CONTRIBUTORS BE LIABLE 
FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, 
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, 
WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN 
ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Copyright (C) 2000-2004 Jason Hunter & Brett McLaughlin. All rights reserved.

This product includes software developed by the Massachusetts Institute of Technology (MIT).

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING 
BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY 
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, 
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE 
SOFTWARE.

Copyright © 2009 MIT

This product includes software developed by Jean-loup Gailly and Mark Adler. This software is provided 'as-is', without any 
express or implied warranty. In no event will the authors be held liable for any damages arising from the use of this software.

Copyright (c) 1995-2005 Jean-loup Gailly and Mark Adler



This software is based in part on the work of the Independent JPEG Group (http://www.ijg.org/).

This product includes software developed by the Dojo Foundation (http://dojotoolkit.org).

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS 
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE 
COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER 
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN 
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Copyright (c) 2005-2009, The Dojo Foundation. All rights reserved.

This product includes software developed by W3C.

Copyright © 2009 World Wide Web Consortium, (Massachusetts Institute of Technology, Institut National de Recherche en 
Informatique et en Automatique, Keio University). All Rights Reserved. (http://www.w3.org/Consortium/Legal/)

This product includes software developed by Mathew R. Miller (http://www.bluecreststudios.com).

Copyright (c) 1999-2002 ComputerSmarts. All rights reserved.

This product includes software developed by Shaun Wilde and distributed via Code Project Open License (http://
www.codeproject.com).

THIS WORK IS PROVIDED "AS IS", "WHERE IS" AND "AS AVAILABLE", WITHOUT ANY EXPRESS OR IMPLIED 
WARRANTIES OR CONDITIONS OR GUARANTEES. YOU, THE USER, ASSUME ALL RISK IN ITS USE, INCLUDING 
COPYRIGHT INFRINGEMENT, PATENT INFRINGEMENT, SUITABILITY, ETC. AUTHOR EXPRESSLY DISCLAIMS 
ALL EXPRESS, IMPLIED OR STATUTORY WARRANTIES OR CONDITIONS, INCLUDING WITHOUT LIMITATION, 
WARRANTIES OR CONDITIONS OF MERCHANTABILITY, MERCHANTABLE QUALITY OR FITNESS FOR A 
PARTICULAR PURPOSE, OR ANY WARRANTY OF TITLE OR NON-INFRINGEMENT, OR THAT THE WORK (OR ANY 
PORTION THEREOF) IS CORRECT, USEFUL, BUG-FREE OR FREE OF VIRUSES. YOU MUST PASS THIS 
DISCLAIMER ON WHENEVER YOU DISTRIBUTE THE WORK OR DERIVATIVE WORKS. 

This product includes software developed by Chris Maunder and distributed via Code Project Open License (http://
www.codeproject.com).

THIS WORK IS PROVIDED "AS IS", "WHERE IS" AND "AS AVAILABLE", WITHOUT ANY EXPRESS OR IMPLIED 
WARRANTIES OR CONDITIONS OR GUARANTEES. YOU, THE USER, ASSUME ALL RISK IN ITS USE, INCLUDING 
COPYRIGHT INFRINGEMENT, PATENT INFRINGEMENT, SUITABILITY, ETC. AUTHOR EXPRESSLY DISCLAIMS 
ALL EXPRESS, IMPLIED OR STATUTORY WARRANTIES OR CONDITIONS, INCLUDING WITHOUT LIMITATION, 
WARRANTIES OR CONDITIONS OF MERCHANTABILITY, MERCHANTABLE QUALITY OR FITNESS FOR A 
PARTICULAR PURPOSE, OR ANY WARRANTY OF TITLE OR NON-INFRINGEMENT, OR THAT THE WORK (OR ANY 
PORTION THEREOF) IS CORRECT, USEFUL, BUG-FREE OR FREE OF VIRUSES. YOU MUST PASS THIS 
DISCLAIMER ON WHENEVER YOU DISTRIBUTE THE WORK OR DERIVATIVE WORKS. 



This product includes software developed by PJ Arends and distributed via Code Project Open License (http://
www.codeproject.com).

THIS WORK IS PROVIDED "AS IS", "WHERE IS" AND "AS AVAILABLE", WITHOUT ANY EXPRESS OR IMPLIED 
WARRANTIES OR CONDITIONS OR GUARANTEES. YOU, THE USER, ASSUME ALL RISK IN ITS USE, INCLUDING 
COPYRIGHT INFRINGEMENT, PATENT INFRINGEMENT, SUITABILITY, ETC. AUTHOR EXPRESSLY DISCLAIMS 
ALL EXPRESS, IMPLIED OR STATUTORY WARRANTIES OR CONDITIONS, INCLUDING WITHOUT LIMITATION, 
WARRANTIES OR CONDITIONS OF MERCHANTABILITY, MERCHANTABLE QUALITY OR FITNESS FOR A 
PARTICULAR PURPOSE, OR ANY WARRANTY OF TITLE OR NON-INFRINGEMENT, OR THAT THE WORK (OR ANY 
PORTION THEREOF) IS CORRECT, USEFUL, BUG-FREE OR FREE OF VIRUSES. YOU MUST PASS THIS 
DISCLAIMER ON WHENEVER YOU DISTRIBUTE THE WORK OR DERIVATIVE WORKS. 

This product includes software developed by Erwin Tratar. This source code and all accompanying material is copyright (c) 1998-
1999 Erwin Tratar. All rights reserved.

THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. USE IT AT YOUR OWN 
RISK! THE AUTHOR ACCEPTS NO LIABILITY FOR ANY DAMAGE/LOSS OF BUSINESS THAT THIS PRODUCT MAY 
CAUSE.

This product includes software developed by Sam Leffler of Silicon Graphics.

THE SOFTWARE IS PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND, EXPRESS, IMPLIED OR 
OTHERWISE, INCLUDING WITHOUT LIMITATION, ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A 
PARTICULAR PURPOSE.

IN NO EVENT SHALL SAM LEFFLER OR SILICON GRAPHICS BE LIABLE FOR ANY SPECIAL, INCIDENTAL, 
INDIRECT OR CONSEQUENTIAL DAMAGES OF ANY KIND, OR ANY DAMAGES WHATSOEVER RESULTING FROM 
LOSS OF USE, DATA OR PROFITS, WHETHER OR NOT ADVISED OF THE POSSIBILITY OF DAMAGE, AND ON ANY 
THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS 
SOFTWARE

Copyright (c) 1988-1997 Sam Leffler 
Copyright (c) 1991-1997 Silicon Graphics, Inc.

This product includes software developed by Guy Eric Schalnat, Andreas Dilger, Glenn Randers-Pehrson (current maintainer), 
and others. (http://www.libpng.org)

The PNG Reference Library is supplied "AS IS". The Contributing Authors and Group 42, Inc. disclaim all warranties, expressed 
or implied, including, without limitation, the warranties of merchantability and of fitness for any purpose. The Contributing 
Authors and Group 42, Inc. assume no liability for direct, indirect, incidental, special, exemplary, or consequential damages, 
which may result from the use of the PNG Reference Library, even if advised of the possibility of such damage.

This product includes software components distributed by the Cryptix Foundation.

THIS SOFTWARE IS PROVIDED BY THE CRYPTIX FOUNDATION LIMITED AND CONTRIBUTORS ``AS IS'' AND 
ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE 
CRYPTIX FOUNDATION LIMITED OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 
SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT 
OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) 
HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR 
TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, 
EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE

Copyright © 1995-2005 The Cryptix Foundation Limited. All rights reserved.



This product includes software components distributed by Sun Microsystems.

This software is provided "AS IS," without a warranty of any kind. ALLEXPRESS OR IMPLIED CONDITIONS, 
REPRESENTATIONS AND WARRANTIES, INCLUDING ANYIMPLIED WARRANTY OF MERCHANTABILITY, 
FITNESS FOR A PARTICULAR PURPOSE OR NON-INFRINGEMENT, ARE HEREBY EXCLUDED. SUN AND ITS 
LICENSORS SHALL NOT BELIABLE FOR ANY DAMAGES SUFFERED BY LICENSEE AS A RESULT OF USING, 
MODIFYING OR DISTRIBUTING THE SOFTWARE OR ITS DERIVATIVES. IN NO EVENT WILL SUN OR ITS 
LICENSORS BE LIABLE FOR ANY LOST REVENUE, PROFIT OR DATA, OR FOR DIRECT, INDIRECT, SPECIAL, 
CONSEQUENTIAL, INCIDENTAL OR PUNITIVE DAMAGES, HOWEVER CAUSED AND REGARDLESS OF THE 
THEORY OF LIABILITY, ARISING OUT OF THE USE OF OR INABILITY TO USE SOFTWARE, EVEN IF SUN HAS 
BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

Copyright (c) 1998 Sun Microsystems, Inc. All Rights Reserved.

This product includes software components distributed by Dennis M. Sosnoski.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS'" AND ANY EXPRESS 
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE 
COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER 
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN 
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Copyright © 2003-2007 Dennis M. Sosnoski. All Rights Reserved

It also includes materials licensed under Apache 1.1 and the following XPP3 license

THIS SOFTWARE IS PROVIDED "AS IS'" AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT 
LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE 
ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY 
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT 
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR 
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, 
STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE 
USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Copyright © 2002 Extreme! Lab, Indiana University. All Rights Reserved

This product includes software components distributed by CodeProject. This software contains material that is © 1994-2005 The 
Ultimate Toolbox, all rights reserved.

This product includes software components distributed by Geir Landro.

Copyright © 2001-2003 Geir Landro (drop@destroydrop.com) JavaScript Tree - www.destroydrop.com/hjavascripts/tree/version 
0.96



This product includes software components distributed by the Hypersonic SQL Group.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS'" AND ANY EXPRESS 
OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE 
COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF 
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER 
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN 
IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE

Copyright © 1995-2000 by the Hypersonic SQL Group. All Rights Reserved

This product includes software components distributed by the International Business Machines Corporation and others. 

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING 
BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY 
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, 
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE 
SOFTWARE.

Copyright (c) 1995-2009 International Business Machines Corporation and others. All rights reserved. 

This product includes software components distributed by the University of Coimbra.

University of Coimbra distributes this software in the hope that it will be useful but DISCLAIMS ALL WARRANTIES WITH 
REGARD TO IT, including all implied warranties of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. In 
no event shall University of Coimbra be liable for any special, indirect or consequential damages (or any damages whatsoever) 
resulting from loss of use, data or profits, whether in an action of contract, negligence or other tortious action, arising out of or in 
connection with the use or performance of this software.

Copyright (c) 2000 University of Coimbra, Portugal. All Rights Reserved.

This product includes software components distributed by Steve Souza.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS "AS IS'" AND ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR 
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY 
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE.

Copyright © 2002, Steve Souza (admin@jamonapi.com). All Rights Reserved.

This product includes software developed by the OpenSymphony Group (http://www.opensymphony.com/.)"

Copyright © 2001-2004 The OpenSymphony Group. All Rights Reserved.



PANTONE (R) Colors displayed in the software application or in the user documentation may not match PANTONE-identified 
standards. Consult current PANTONE Color Publications for accurate color. PANTONE(R) and other Pantone LLC trademarks 
are the property of Pantone LLC. (C) Pantone LLC, 2011.

Pantone LLC is the copyright owner of color data and/or software which are licensed to Oracle to distribute for use only in 
combination with Oracle Documaker. PANTONE Color Data and/or Software shall not be copied onto another disk or into 
memory unless part of the execution of Oracle Documaker.
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Chapter 1

Introduction

Tagcommander is the Docucreate workstation software component that you use to 
create, manage, and insert

• BPSDs (Boiler Plate Space Definitions)

• DGSDs (Docugraph Space Definitions), a.k.a. “Docugraph Charts”

• Docuflex Tags, similar to BPSD tag objects, that derive their contents from 
Reserved Tags, Schema fields, or Rules within a Docuflex Studio project

The various forms of Space Definitions discussed in this guide are commonly 
referred to as tags.

OVERVIEW
A tag represents placeholder characters (“replacement characters”) that are later 
replaced with variable data when a document is processed, as part of a larger 
Document Package, by Documaker fp, Documaker ws, or Docuflex.

You use Tagcommander to insert tags into documents that are commonly composed 
in a word processing application, such as Microsoft Word. For example, you could 
use Tagcommander to create a form letter. When composing the form letter, you type

Dear ,

with a space separating the two items. Then, you insert a tag immediately before the 
comma. As you insert the tag, it resembles the following:

Dear @@@@@@@@@@@@@@,

Later, the target application replaces the tag with variable data and it achieves its 
final appearance:

Note Please note that the images or screenshots that follow in the upcoming explanation of 
the topics may not resemble those as encountered in the actual installation, un-
installation  or other related functions performed on the application.
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Dear Mr. Smith,

You can use Tagcommander to insert tags into any document created with a 
Microsoft Windows-compatible composition tool, such as Microsoft Word, Corel 
Word Pro, or WordPerfect.

When you've completed the document, you must print it with Docucreate ws, which 
makes the output compatible with Documaker fp and Docuflex. As your documents 
are processed, the application retrieves the data for the tags from a data file and 
substitutes the correct variable data for the replacement characters in the tag.
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BENEFITS AND FEATURES OF TAGCOMMANDER

REUSABLE BOILERPLATE DOCUMENTS
Tagcommander, along with the other components in the document production cycle, 
provides the means for you to use the same fixed (constant) text names over and over 
again while substituting an ever-changing array of variable data.
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INFORMATIVE FEATURES FOR SETTING UP TAGS

Tagcommander offers several features that make the effort of identifying and 
preparing tags much easier. The following illustration shows the features that help 
you set up and prepare tags.
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EASY INTERACTIVE INSERTION OF TAGS

Tagcommander is a tag-insertion application that easily integrates with other 
Windows based document composition applications. This means you can use the 
interactive and graphical user interface features of Windows to compose the fixed 
text for a document and insert tags into the same without having to leave the 
composition application. The following illustration shows how easy it is to insert a 
tag into your document from within Microsoft Word for Windows.
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WHAT YOU NEED TO KNOW

Types of Oracle Tags and Tag Processing Limitations

You must have a Oracle Merge Engine to process tags created by and inserted with 
Oracle products. The following table lists the required products for processing all 
types of Oracle tags.

Although you can insert BPSD, DGSD, and Docuflex tags with Tagcommander; 
DWSD tags with Docusolve; and VSD tags with Docuword; you must license the 
appropriate Merge Engines listed above to process the tags. For example, you can 
insert DGSD tags with Tagcommander and view Docugraph Chart samples in 
Tagcommander, but you must license and install Documaker fp with Docugraph to 
create the Docugraph charts within your documents.

TAGCOMMANDER SUPPORTED PRINTING 
ENVIRONMENTS
If you'll be printing documents after you create and place tags, you'll need 
knowledge of, or access to, information about any of the following printer-related 
areas that are relevant for your printing environment.

Xerox Printer Software—If you'll be using Tagcommander and Docucreate ws 
with a Metacode printer, you must know the Xerox software parameter values for 
your location's JDL, JDE, and DJDE and be familiar with JSL. Consult your printer 
specialist or your Xerox documentation if you need assistance.

Xerox Printer Hardware—If you'll be using Tagcommander and Docucreate ws 
with a Metacode printer, your printer may require additional software. Verify that 
your printer is equipped with GHO (Graphics Handling Option) or GVG (Graphics 
Video Generation) for producing graphics.

Metacode Print Files—If you'll be using Tagcommander and Docucreate ws with a 
Metacode printer, you'll need to know how print files from Docucreate ws are routed 
from your system to the printer. Consult with your network systems administrator for 
the necessary setup.

Oracle Tag Tag Insertion Method
You must license the following Merge 
Engine to process tags:

Boilerplate Space 
Definition (BPSD) 

Supported composition

system or Tagcommander

Documaker fp

Docuword Space 
Definition (DWSD) 

Documaker ws Documaker ws

Variable Space 
Definition (VSD)

Docuword or Dynacomp Docuword or Dynacomp

Docugraph Space 
Definition (DGSD)

Tagcommander Documaker fp with the Docugraph Engine 

Docuflex tags  Tagcommander Documaker fp or Docuflex

Note If you use Docucreate ws to update a document containing tags created with 
Tagcommander 1.4.6 or earlier, you must select each tag and convert it using. Tags 
created with Tagcommander 1.5 and later are automatically recognized and processed.
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Hewlett-Packard (HP) Hardware, Software, and Print Files—If you'll be proof-
printing your documents to an HP LaserJet, you should set your default printer as 
Metacode or AFP and insert all your tags before printing your output to the HP. 
Because line and page breaks are different for different printer drivers, your output 
to the HP may not be exactly the same as the output on your production printer.

IBM Printer Software—If you'll be using Tagcommander and Docucreate ws with 
an AFP printer, the AFP data stream will be processed by PSF (Print Services 
Facility). Your application may require particular AFP resources. Consult your 
printer specialist or your IBM documentation if you need assistance.

IBM Printer Hardware—If you'll be using Tagcommander and Docucreate ws 
with an AFP printer, PSF takes into account any hardware differences between 
various AFP printers you're using as it processes your data stream and automatically 
resolves those differences.

You can refer to the IBM publication, Advanced Function Presentation: Printer 
Information (G544-3290), for more information.

AFP Print Files—If you'll be using Tagcommander and Docucreate ws with an AFP 
printer, you'll need to know how print files from Docucreate ws are routed from your 
system to the printer. Consult with your network systems administrator for the 
necessary setup.

COMPANION PROGRAMS TO TAGCOMMANDER
Other products which complement Tagcommander include:

• Docucreate ws—use with Tagcommander and your document composition 
system to produce documents compatible with AFP and Metacode printers. You 
can then store these documents in a repository for later inclusion in your 
Document Packages.

• Fontcommander—lets you create and manage the printer font metrics (PFM) 
files which Docucreate ws uses to print documents.

For more information about the companion programs, refer to the 
Printcommanderand Fontcommander documentation.
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ABOUT THIS GUIDE

This guide describes the daily use and general operation of Tagcommander 6.3. It's 
designed to be a reference tool as well as a framework in your daily operation.

Installing Tagcommander lists the minimum hardware and software requirements 
necessary for Tagcommander, plus a step-by-step procedure to install the program. 
See Installing Tagcommander on page 9.

Using Tagcommander explains the process by which you insert BPSD tags into 
your word processing program and includes an in-depth discussion of the tag 
properties. See Using Tagcommander on page 11.

Using Docugraph Charts explains the process by which you insert DGSD tags 
(Docugraph charts) into your word processing program and includes a discussion on 
assigning and choosing colors for your charts. See Using Docugraph Charts on page 
35.

Using Docuflex Tags explains the process by which you insert Docuflex Tags into 
your word processing program and includes an in-depth discussion of the tag 
properties. See Using Docuflex Tag Manager on page 45. The Appendix at the end 
discussed some helpful tips in operating Tagcommander. 



19

Chapter 2

Installing Tagcommander

SYSTEM REQUIREMENTS
The following hardware requirements are necessary to install and run 
Tagcommander:

• 100%-compatible PC with a Pentium microprocessor (Pentium II processor or 
faster recommended)

• 32 megabytes (MB) of memory (64 MB recommended)

• A hard disk with 8 MB of free space

The following software requirements are necessary to install and run 
Tagcommander:

• Microsoft Windows

• Tagcommander supports both 32-bit and 64-bit windows environment.

• Docucreate Workstation for producing print files

INSTALLING TAGCOMMANDER

IMPORTANT! You must ensure that Oracle Common Objects has been installed for your system 
before using Tagcommander with Docucreate ws.

The following installation procedure assumes that you have no other active 
applications running on your computer.

Oracle Tagcommander application is available for download from the Oracle 
Software Delivery Cloud web site. The process includes:

• Logging in and agreeing to the terms and restrictions

• Searching for the applications you want to download

• Downloading those applications

Go to the Oracle Software Delivery Cloud website to download the application:

https://edelivery.oracle.com

To Install Tagcommander

1.  From the directory into which you downloaded the media pack, unzip the 
mediapack. Click on the setup.exe located in Tagcommanders' Disk1 directory.
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After InstallShield prepares the installation, the Tagcommander title screen and 
Setup dialog display.

2. Click Next> to continue with the installation or Cancel to quit the program.

The install displays the Choose Destination Location dialog box, prompting you 
for the directory path for the program installation.
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3. Do one of the following:

4. Click Next> to continue with the installation if you haven’t already done so. You 
can also click <Back to return to the previous screen or Cancel to abort the 
routine.

You’ll next see the Setup Type dialog box offering different setup options.

5. Choose the Setup type you prefer, according to the Description on the right, and 
then click Next>.

To Perform this Action

Accept the default path the  installation 
routine proposes

Click Next>.

Select another path for the installation Click Browse, select a new path, and then 

click Next>.
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The Select Program Folder dialog box displays the program folder in which it 
proposes to place the program icons.

6. Do one of the following:

A dialog box indicating the setup program’s progress displays until all the files 
have been copied to your PC.

To Perform this Action

Accept the proposed folder to hold the 
program icons

Click Next>.

Choose another folder for the program 
icons

Use the scroll bar to select another folder;  then click Next>.
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When the installation is 100% complete, the program displays the Docucreate 
Setup is Complete dialog box.

7. Click Finish to complete installation of Tagcommander.
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Chapter 3

Using Tagcommander

Before You Start

WORKING WITH DOCUMENTS
Before you start inserting tags into documents, here is a quick primer on the general 
steps you take to compose, tag, and prepare a document for Documaker fp or 
Docuflex processing. 

To Create a Document

1. Plan the layout and format of your document, including the names, lengths, and 
placement of the tags that hold the items of variable data to be merged. 

2. Start Tagcommander and create a tag file that lists the names of the variable data 
tags for the document. 

3. Create the document in your word processing application. 

4. Start Tagcommander from within your word processor and insert tags from the 
tag file as necessary. 

5. Print the document using Printcommander. Be sure to enable the Normalization 
function in Printcommander and choose it as your current print driver. 

6. Add the newly-created document to the appropriate Electronic Document 
Library (EDL). 

USING TAGCOMMANDER WITH YOUR COMPOSITION 
SYSTEM
Tagcommander works with Windows applications supporting object linking and 
embedding (OLE), a program interface that lets you easily update objects within an 
application. 

If you choose not to directly embed tags, you can still use Tagcommander, but you'll 
be required to use additional steps to insert a tag. You can either copy the tag to the 
Windows Clipboard and then paste it into the document or use the mouse to drag the 
tag from Tagcommander into your document. 

Although Tagcommander supports the Copy/Paste and drag functions, the manually-
inserted Tags can’t be directly updated; you must delete the tag and insert a new, 
updated tag.

GETTING STARTED WITH TAGCOMMANDER 
After you've installed Tagcommander on your system, you can launch it or its 
companion applications from the Programs sub-menu of the Windows taskbar. 
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To Start Tagcommander

After you install Tagcommander in your Windows system, the Programs sub-menu 
displays the Docucreate folder. 

• Click the Docucreate icon.

For more information about Tagcommander DGSD, see Starting 
Tagcommander DGSD on page 36. 

For more information about Logical Color Definition, see Starting Logical 
Color Definition on page 42.

Tagcommander displays its main program window. 

When you open Tagcommander for the first time, [Untitled] is displayed in the title 
bar. A new tag file is already opened for you, waiting to receive tags. You can now 
begin entering tags, or perform other operations as described in the next topic. 



Getting Started with Tagcommander

27

To Use Tagcommander

Because there are several tasks you can perform with Tagcommander, this guide 
provides a separate topic for each task. Use the following table to locate the section 
that contains the task that you need to perform. 

To End Tagcommander 

• Choose File>Exit & Return to doc_name.doc. 

-or-

Click Close on the Tagcommander window. 

CONFIGURING TAGCOMMANDER
This section addresses the global settings you can make to configure Tagcommander 
to your working preferences. 

Use a Text Data File

Use a Text data file determines which tag file format Tagcommander uses. When this 
option is set, and you choose File>Open, Tagcommander automatically searches for 
tag files with a .TXT file name extension. If you disable this option by clearing (un-
checking) the Options>Use a Text data file menu item, Tagcommander will search 
for tag files with a .TGA file name extension when you choose File>Open. For more 
information about tag file formats, see Tag File Format on page 60. 

To Go to this section:

Set up your Tagcommander working environment Configuring Tagcommander on page 27

Insert, configure, move, replace, delete, or rename a tag in a 
document 

Inserting and Updating Tags on page 29

Create/Add, view the properties of, search for, sort, or delete a tag 
(in a tag list) 

Working with the Tag List on page 49

Create, open, append, remove appended, or print (a tag file) Working With Tag Files on page 53

Assemble the Document Package and merge the data Assembling the Documents and Merging the 
Data on page 55

View the various menu options Menu Options on page 55
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Always Open Last File Accessed

When you open Tagcommander for the first time, [Untitled] displays in the title bar. 
A new tag file is already opened for you, waiting to receive tags. 

Always open last file accessed instructs Tagcommander to open the tag file in use the 

last time you accessed Tagcommander. Tagcommander searches for the previously-
opened tag file and automatically opens it when you start the program, whether you 
choose the program icon or start it through an application. If Tagcommander can't 
find the previous tag file, you're prompted for the name of another tag file. 

To set this option, choose Options>Always open last file accessed. If you clear 
(uncheck) this option, you must start a new tag file, or open a tag file each time you 
enter Tagcommander. 

Prevent Tag Duplication 

Prevent Tag duplication instructs Tagcommander to prevent you from entering two 
tags with the same name. Tagcommander verifies the name of any new tags, as well 
as the tags loaded from a tag file. Because Tagcommander must check each tag in 
the file, this process can slow your processing time. 

To disable this option, choose Options>Prevent Tag duplication to uncheck the 
option. Then, Tagcommander won’t prevent you from entering two tags with the 
same name -- it's your responsibility. 

Provide Rulebase Reminder 

Provide Rulebase reminder instructs Tagcommander to prompt you with a message 
after you create a tag. As each tag is added to the current tag file, a message displays 
to remind you to update the Documaker fp Rulebase. To disable this option, choose 
Options>Provide Rulebase reminder to uncheck the option. Then, Tagcommander 
won't display the message. 

Notify When Tag is Missing

Notify when Tag is missing is only available when you?e embedding a tag into a 
word processing document. This option prompts you to add the tag to the Tag 
Attribute file if it isn’t found. To disable this option, choose Options>Notify when 
Tag is missing to uncheck the option. Then, Tagcommander won’t displays the 
message and automatically updates the attribute file. 

Sort Tags By Name

Sort Tags by name instructs Tagcommander to place the tags in alphabetical order. 
As you add tags to the list, Tagcommander sorts the tags into the appropriate order. 
To enable this option, choose Options>Sort Tags by name to check the option. Then, 
Tagcommander simply places the tags in the order in which you entered them. 
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INSERTING AND UPDATING TAGS
Tagcommander lets you insert tags either directly or pasted from the Windows 
Clipboard. 

This section contains information about the daily operations of Tagcommander. 
You'll find step-by-step instructions for inserting tags in your document, and 
performing other types of updates on tags. You can: 

• Insert a tag as an embedded object. For instructions, read Inserting a Tag as an 
Embedded Object on page 30.

• Update an embedded tag. For instructions, read Updating an Embedded Tag on 
page 34. 

• Insert a tag using the Windows clipboard. For instructions, read Copying or 
Moving a Tag to Another Location on page 34.

• Update a tag inserted with the clipboard. For instructions, read Updating a 
Manually-inserted Tag on page 39.

•  Change the formatting and display settings for a tag. For instructions, read 
Changing Tag Properties on page 39.

• Copy or move a tag to another location. For instructions, read Copying or 
Moving a Tag to Another Location on page 34.

• Replace a tag in a document. For instructions, read Replacing a Tag on page 35.

• Delete a tag in a document. For instructions, read Deleting a Tag on page 35.

• Rename a tag. For instructions, read Working with the Tag List on page 49.

Note Nearly all word processing programs support object linking and embedding (OLE). 
Throughout the manual, you'll encounter examples illustrating the steps necessary to 
insert and update tags (all steps are based on the Microsoft Word for Windows 
interface). 
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Inserting a Tag as an Embedded Object

All Windows applications supporting object linking and embedding (OLE) contain 
a menu item for inserting objects. The Insert option is usually found either on the 
main menu or as a sub menu item in the Edit menu. When you choose Insert>Object, 
the application displays a window containing a list of the objects you can insert. You 
can then choose to insert a tag (e.g., Insert>Object>BPSD Tag_W32). 

To Insert a Tag as an Embedded Object

When you're inserting tags as embedded objects, use the following procedures for 
inserting and updating tags: 

1. Position the cursor at the place in your document where you want to insert the 
tag. 

Tip In order to properly insert tags, you should:

1. Go into your word processor, open the document, and begin entering the text. 

2. Position your cursor at the place where you want to insert a tag. 

3. Select Insert>Object>BPSD Tag_W32 (from within your word processor) to insert a 
tag. 

4. Double-click the tag you want to insert. 

-or-

Highlight the tag in the tag list and press ENTER. 

5. Click Update. 

If you want to paste the tags into your application, please see Manually Inserting a Tag 
on page 36.



Getting Started with Tagcommander

31

2. Choose Insert>Object from the main word processor menu, then choose BPSD 
Tag_W32 from the Object Type list box. This action automatically invokes 
Tagcommander.

3. Choose a tag by double-clicking a tag in the list box. 

-or-

Highlight a tag and press ENTER. If necessary, you can create a tag. 
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You'll know you've correctly selected the tag when its name displays in the 
Name field. 

4. Make any changes to the default settings for the tag by selecting your 
preferences in the Properties portion of the screen (located on the left half of the 
main window). 

For instructions and short descriptions about tag formatting and display 
properties, read To Change the Properties for a Tag on page 39.
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5. Click Accept to apply your changes to the Properties. 

6. After reviewing the preview box to verify the format of the tag, click Update on 
the bottom of the Tagcommander window to insert the tag in your document. 
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The updated tag is inserted at the current cursor position in the document (unless 
you double-clicked an existing tag to launch the preceding process). 

Updating an Embedded Tag

After you've inserted tags in your document, you might need to change some option 
about the tag. The steps are almost identical to inserting a tag. 

To Update an Embedded Tag

1. Double-click the tag (replacement characters). Windows automatically executes 
Tagcommander, where you can change any of the optional settings for the tag. 

For instructions and short descriptions about tag formatting and display 
properties, read To Change the Properties for a Tag on page 39.

2. Click Accept after you make the changes. 

3. Click Update to update the tag. 

Copying or Moving a Tag to Another Location 

You can use your word processing program Cut or Copy commands to copy or move 
a tag just like you copy or move text or pictures. 

To Copy or Move a Tag to Another Location

1. In the document that contains the tag, click the tag to select it. 

2. Choose either Edit>Copy or Edit>Cut to either copy or move the selected tag to 
the Windows Clipboard. 

3. Click an insertion point at the location in document where you want to place the 
tag. 

4. Choose Edit>Paste to insert the tag. 
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Replacing a Tag

You can easily replace one tag with another, with or without updating the properties 
for the tag. 

To Replace a Tag

1. Delete the current tag from the document. For instructions, read the next topic. 

2. Do one of the following: 

3. If you need to change the properties for the inserted tag, do one of the following: 

Deleting a Tag 

You can delete a tag just like you would delete a picture. 

To Delete a Tag

1. In the document, click the tag to select it. 

2. Press DELETE. 

To replace the deleted tag 
with Do this

Another tag that’s already been 
inserted in a document 

Read the instructions for “Copying or Moving a Tag to Another Location”

A new embedded tag Read the instructions for Inserting a Tag as an Embedded Object on page 30

A tag copied to the clipboard Read the instructions for Manually Inserting a Tag on page 36.

To update Do this

An embedded tag Read the instructions for Updating an Embedded Tag on page 34.

A tag inserted from the 
clipboard

Read the instructions for Updating a Manually-inserted Tag on page 39.
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MANUALLY INSERTING A TAG
Instead of directly inserting tags into your document, you can paste a copy of the tag 
using the Windows Clipboard. 

The following tip lists the short version of the procedure necessary to paste tags into 
your document. A full explanation follows in To Insert a Tag with the Clipboard on 
page 36. 

To Insert a Tag with the Clipboard

When you're inserting tags through the Clipboard, use the following procedures to 
insert and update a tag: 

1. Open your word processor application and begin creating your document. 

2. Position the cursor at the place where you want to insert the tag. 

3. Choose Start, then Programs, then Docucreate. 

4. Click the Tagcommander icon.  
 

Tip If you don’t see BPSD Tag_W32 listed in the Insert>Object dialog, you should: 

1. Go into your word processor, open the document, and begin entering the text. 

2. Position your cursor at the place where you want to insert a tag. 

3. Choose Start, then Programs, then Docucreate. 

4. Click the Tagcommander icon. 

5. Double-click the tag you want to insert. 

-or-

Highlight the tag and press ENTER. 

6. Choose Edit>Copy Tag to Clipboard. 

7. Go to your word processor. 

8. Choose Edit>Paste. 

You can also use the mouse to drag the tag directly into your document and save a few 
steps. 
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5. Choose a tag by double-clicking a tag in the list box. 

-or-

Highlight a tag and press ENTER. If necessary, you can create a tag. 

You'll know you've correctly selected the tag when its name displays in the 
Name field. 

6. Make any changes to the tag by selecting your preferences in the Properties 
portion of the screen (located on the right half of the main window). 
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For instructions and short descriptions about tag formatting and display 
properties, read To Change the Properties for a Tag on page 39.

7. Click Accept to apply your changes to the Properties. 

At this point, you can skip these last steps by dragging the tag from the preview 
box directly into your document. 

8. After reviewing the preview box to verify the format of the tag, choose 
Edit>Copy Tag to Clipboard to copy the tag to the Windows Clipboard. 



Getting Started with Tagcommander

39

9. Switch to your word processor. Make sure the cursor is still at the location where 
you want to insert the tag. 

10. Choose Edit>Paste to insert a copy of the tag. 

Updating a Manually-inserted Tag

The application should allow you to move the tag within the document. If you want 
to make any changes to the tag, such as changing the name or the length, you'll need 
to perform the following steps. 

To Update a Pasted Tag

1. In the document, click the tag to select it. 

2. Press DELETE. 

3. Repeat the preceding procedure to paste in a new, updated tag. 

CHANGING TAG PROPERTIES
Tagcommander automatically supplies some default properties for each of the tags 
you add. If you need to change the properties for a tag, proceed with the following 
instructions. 

To Change the Properties for a Tag

1. Double-click the tag in the tag list box to select it. 

-or-

Highlight a tag and press ENTER. 

You'll know when you've correctly selected the tag because its name is displayed 
in the Name field in the Properties group. 

2. Choose any of the properties and then the desired setting: 

Option Explanation

Replacement Replacement characters are strings of characters which represent the approximate width 
and length of actual data. Tagcommander supplies you with the default characters @, #, !, 
and ". For more information, see Replacement on page 41.
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3. Click Accept to apply the settings you made to the tag list and update the 
preview. 

4. Repeat the preceding steps for all your tags. 

Tag Width You can edit the width (length) value for the current tag by clicking on the Width field. For 
more information, see Tag Width on page 41.

Tag Depth You can edit the depth (number of lines) value for the current tag by clicking on the Depth 
field. For more information, see Tag Depth on page 41.

Multi Data The Multi Data function controls the number of line feeds between the lines of variable data. 
For more information, see Multi Data on page 42.

Line End The Line End is mostly encountered in block tags and it acts as a delimiter, or separator, 
between lines of variable data. You can use the keyboard keys to enter your Line End 
selection. 

However, you shouldn't use a common character, such as a letter of the alphabet, as your 
Line End. For more information, see Line End on page 42.

Delete You can indicate whether Documaker fp should delete the tag value after it's used. When you 
create a tag that serves multiple purposes, you can direct Documaker fp to re-use the same 
tag for different values. For more information, see Delete on page 42.

Generate You can indicate whether Tagcommander should automatically supply replacement 
characters based on the tag's width and depth. For more information, see Generate on page 
43.

Type You can indicate whether supplying data for the tag is optional or mandatory. For more 
information, see Type on page 43.

Extra Leading Your composition system may insert the tag at a position that isn't level with the adjacent text. 
If this happens, use an Extra Leading value to shift the vertical position of the replacement 
characters. For more information, see Extra Leading on page 44.

Use Screen 
Metric

Indicates whether Tagcommander uses font metrics from Windows or device-specific PFMs 
to determine font characteristics. For more information, see Use Screen Metric on page 45.

Align To 
Baseline

This setting adjusts the height of an embedded tag to align with the baseline of the 
surrounding text. For more information, see Align to Baseline on page 45.

Font Click Font to display a dialog box of fonts and choose the font for the tag. For more 
information, see Font on page 45.

Accept Accept instructs Tagcommander to update the tag list and refresh the preview based upon 
current properties. For more information, see Accept on page 47.

Update Update displays when you’re embedding a tag directly into your composition system. For 
more information, see Update (Embed only) on page 48.

Cancel Cancel displays when you?e embedding a tag directly into your composition system. For 
more information, see Cancel (Embed only) on page 48.

Tag List The tag list displays the names of all tags in the current file. For more information, see Tag 
List on page 48.

Tag Preview The preview displays the replacement characters for the given width, depth, and font 
properties. For more information, see Tag Preview on page 48.

Option Explanation
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Replacement

The replacement characters are strings of characters which represent the 
approximate width and depth of actual data. Tagcommander automatically cycles 
through the four default replacement characters. You can edit the replacement 
character at any time. 

To Select the Replacement Character

• Choose a replacement character from the available list by clicking on the drop-
down arrow beside the list. 

-or-

Type your own replacement character. 

Tagcommander displays a list of default replacement characters ?, #, !, and 
"from which you can make your choice or enter your own replacement character. 

CAUTION! If you choose to enter your own replacement character, you should NOT choose a 
common letter, numeral, or symbol, such as A-Z or 0-9. In other words, if you choose 
the percent (%) symbol as your replacement character, for example, Documaker fp 
would supply a piece of data whenever it encounters that symbol. 

Tag Width

You can edit the width (length) value for the current tag by clicking on the Width 
field. 

If you don't specify a tag width when you're setting up a tag, Tagcommander uses a 
default value of 1. Whichever width setting you choose, it should be long enough to 
accommodate the longest instance of that variable. For example, you might choose 
a width of 30 to accommodate lengthy names. 

To Set the Tag Width

• Use the keyboard or number pad keys to enter your selection. 

Tag Depth

You can edit the depth (number of lines) value for the current tag by clicking on the 
Depth field. 

If you don't specify a tag depth when you're setting up a tag, Tagcommander uses a 
default value of 1. If the variable data you're replacing exceeds a single line of text, 
you can increase the necessary number of lines of replacement characters. 
Depending on your needs, you can set the depth to 2 for a two-line tag, set the depth 
to 3 for a three-line tag, and so on. 

To Set the Tag Depth

• Use the keyboard or number pad keys to enter your selection. 
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Multi Data

You'll use the Multi Data setting mostly with block tags (tags containing more than 
one line of data), such as an address. The Multi Data function controls the number 
of line feeds between the lines of variable data. 

To Select the Number of Line Feeds Between Multiple Lines of Variable 
Data 

1. Choose a Multi Data setting from the available list by clicking on the drop-down 
arrow beside the list box. Tagcommander displays a list of multi data settings 
from which you can make your choice. 

2. Select the desired Multi Data setting. 

Line End

The Line End character is mostly encountered in block tags, and it acts as a delimiter, 
or separator, between lines of variable data. 

The input source data probably includes a particular delimiter: you should also enter 
the same delimiter in this field. In other words, this field identifies the character that 
will be encountered in the data the Documaker fp VDR creates. (You shouldn't use 
a common character, such as a letter of the alphabet, as your Line End character.) 

To Set the Delimiter Character for Line Ends

1. Enter or edit the Line End character by clicking on the field. 

2. Use the keyboard keys to enter your Line End character selection. If you need to 
enter a Line End character that isn't located on the standard keyboard, you can 
use ALT plus the number key pad to enter extended ASCII characters (e.g. the 
cent sign (?) is entered by holding down ALT and entering the number string 
0162). 

Delete

You can indicate whether Documaker fp should delete the tag value after it's used. 
When you create a tag that serves multiple purposes, you can direct Documaker fp 
to re-use the same tag for different values. 

Option Result

N Documaker fp only chooses one data item.

0 no line feeds between data items

1 single-spaced lines between data items

2-9 double-spaced lines, and so on through 9.

Tip You should check with the person coding the Documaker fp VDR, or your Documaker 
fp team leader, for the necessary Line End character. 
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To Specify the Delete Option

• Click the appropriate radio button to make your selection: 

Generate

You can indicate whether Tagcommander should supply the replacement characters, 
based on width and depth of the tag. 

To Specify the Generation Option 

• Click the appropriate radio button to make your selection: 

If your document includes tags with special requirements (such as a date field with 
slashes or a Social Security number with hyphens), for example, choose No and 
you'll be required to enter the format in the User Supplied Replacement Characters 
dialog box. 

Tagcommander creates the tag exactly as it’s displayed in this window. 

Clicking Default displays the replacement text based on your initial input for the 
replacement character, tag width, and tag depth. This representation is useful when 
editing the format. 

Type

You can specify whether supplying data for this tag is Optional or Mandatory. 

Option Result

No Keep the first occurrence of a particular data value. That same data value “flows through” to 
all other occurrences of that tag with the No setting (such as the customer name or policy 
number). 

Yes Include different data for the same tag such as a generic AMOUNT field for both the down-
payment amount and the outstanding amount. 

1 (Documaker fp only) DMGMERGE reverts to the first VRF tag occurrence that matches the 
name, inserts the data?hus re-using the same value?nd does not delete the tag data. 

R  (Documaker fp only) DMGMERGE reverts to the first VRF tag occurrence that matches the 
name, inserts the data?hus re-using the same value?nd deletes the tag data. 

Option Result

Yes Tagcommander generates replacement characters of the specified width and depth. 

No Tagcommander allows the user to type in special formatting characters, along with the 
replacement characters, such as slashes in a date field. 
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To Specify the Tag Type

• Click the appropriate radio button to make your selection: 

• The tag is filled with blanks 
• You'll receive a Documaker fp error message 
• The output is routed to a Documaker fp error print stack 

Extra Leading

Your composition system may insert the tag at a position that isn't level with the 
adjacent text. If this happens, experiment with Extra Leading values to shift the 
vertical position of the replacement characters. 

On your monitor, the shifting may cause the lower portion of the replacement 
characters to disappear from view. If so, you can align the tops of the replacement 
characters to match the tops of the adjacent text. Complete replacement characters 
are printed, even though their lower portions may not be displayed on your monitor. 

To Select Extra Leading (Vertical Spacing) for Replacement Characters

1. Double-click the tag. 

-or-

Highlight the tag and press ENTER. 

2. Click the drop-down arrow next to the Extra Leading list box to adjust the 
leading value. Tagcommander displays a list of choices from which to make 
your selection. If necessary, you can enter negative numbers to raise the level of 
the replacement characters. For more information on adjusting your tags, refer 
to Working With Tag Files on page 53.

For example, the following illustrates the replacement character leading (change 
in baseline height) you would see with Extra Leading values of -9 points, 0 
(none), and 9 points: 

@@ Extra Leading =-6 points 

@@ Extra Leading = 0 points 

@@ Extra Leading = 6 points 

Option Result

Mandatory If you indicate that entering data is mandatory, and no data is found during the Documaker fp 
merging process: 

Optional If you indicate that entering data is optional, and no data is found during the Documaker fp 
merging process, the tag is filled with blanks and processing continues. 
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Use Screen Metric

This option determines whether Tagcommander uses font metrics from the Windows 
font list or device-specific PFMs to determine font characteristics such as point size, 
stroke weight, and character width. 

To Specify Font Metrics

• If you want to use Windows font metrics, enable (check) the option. The default 
is for Tagcommander to use device-specific PFMs. 

Align to Baseline

To eliminate the problem of uneven vertical-line spacing (leading) for a tag inserted 
in fixed text, use this option to adjust the height of the embedded tag so that its 
baseline aligns with the baseline of the surrounding fixed text. 

Tagcommander decreases the height of the rectangle with handles that surrounds the 
tag by the amount of the descender portion of the font or the Extra Leading value, 
and moves the replacement characters to the top of the rectangle. 

Use of this option might affect the point size of the font for the tag because it attempts 
to control baseline alignment and line spacing by decreasing the height of the frame 
around the tag. 

For some fonts, it might not be possible to get both the correct point size and get the 
correct line spacing. In those cases, you might have to force the proper line spacing 
with options provided by the word processing program. 

To Specify Tag Alignment

• If you want Tagcommander to align the baseline of the tag with the adjacent text, 
enable (check) the option. The default is not to align the tag. 

Font

While you're editing tags in Tagcommander, you can choose the font with which you 
want the tag (and its subsequent variable data) printed. Tagcommander works with 
IBM AFP, Xerox Metacode, and Windows-based laser printers. 

The current font name, point size, and other attributes are displayed to the right of 
the Font button. By clicking Font, you can display a font dialog box and choose a 
different font for the tag. 

There are two font selection dialogs for Tagcommander: one for AFP and Metacode 
Printer Definitions and one for all others. 

Before you start creating tags and specifying the fonts for those tags, you should 
decide which type of font metrics you want to use to determine the point size and 
other display and print characteristics of the font. 

The tag image is created by using the font that is selected for it with these dialogs. 
Metacode and AFP users should use the PFMs pointing to device fonts that reside on 
your printer so the tag image placed in the document exactly matches the printer's 
output. 
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For details about the types of font metrics Tagcommander can use, read one or both 
of the following topics: 

AFP and Metacode Printer Definitions

The AFP and Metacode Font selection dialog is entitled Available Fonts and displays 
all the viable PFMs identified in the current Printer Definition selected in 
Printcommander 6.0. 

The dialog actually reads the physical device font from the disk as indicated by the 
PFM. If the physical PFM can’t be located, the font isn’t displayed. 

The Printer Definition Font Section is read by Tagcommander and each PFM entry 
is searched for the physical PFM. When a PFM is found on disk, Tagcommander 
reads it and extracts the font metrics (Case 1). 

With Font Sections that contain references to Font Matching tables, Tagcommander 
reads the table and searches for the PFM on disk; once again, Tagcommander 
extracts the metrics from the PFM (Case 2). 

Printer Definitions that Generate PFMs don’t point to physical PFMs, so none are 
required. 

In this case, Tagcommander reads the Font Matching table, generates the PFMs, and 
then extracts the font metrics (Case 3). 

If Tagcommander encounters a situation where font references point to non-existent 
fonts, a warning dialog box displays the first five expected fonts that are missing 
(only for Cases 1 and 2). 

For instructions on selecting fonts for the tags, see To Specify the Font for a Tag on 
page 47.

DCD and Windows Printer Definitions

Note If you choose a Oracle Compound Document (DCD) or Windows Printer Definition, the 
font dialog box displays a complete list of all the TrueType or Adobe fonts installed for 
your Windows environment. However, it does not use, nor does it display, any device 
fonts. 

The other font selection dialog is simply entitled fonts. It’s a standard dialog box 
provided by Windows for selecting fonts and, thus, requires no specialization. 

For instructions on selecting font for the tags, see To Specify the Font for a Tag on 
page 47.

For printing on this printer type See:

IBM AFP or Xerox Metacode AFP and Metacode Printer Definitions on page 46

DCD and Windows DCD and Windows Printer Definitions on page 46
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To Specify the Font for a Tag

1. Click Font to display the current font settings for the tag. Tagcommander 
displays the Available Fonts dialog.

Note If you choose a DCD Printer Definition in Docucreate ws, Tagcommander displays the 
Windows Font dialog instead of the normal device-specific Available Fonts dialog. 

2. Choose the appropriate font typeface, font style, and point size by clicking on the 

corresponding options in the respective list boxes. 

3. In the Effects group box, select any special effects you want to apply to the tag. 

4. In the Effects group box, choose the color of your tag by clicking on the Color 
drop-down arrow. Tagcommander displays the available choices of Black, Red, 
Green, and Blue. 

The results of your choices are displayed in the Sample display area in the 
Sample group box. 

5. Click OK to save your changes or Cancel to exit without saving. 

Accept

Accept instructs Tagcommander to update the tag list and refresh the preview based 
upon current properties. 

To Apply Property Changes

• Click Accept to apply the changes to the tag. 
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Update (Embed only)

Update is only available when you are in interactive mode, where you?e directly 
inserting a tag into your document. 

To Update and Insert a Tag

• Choose Update and Tagcommander inserts the tag into your document. 

Tip If you've made changes to your tag properties and have yet to save them, you'll be 
prompted to save the changes when you choose Update. The Properties settings are 
saved only if you have chosen to save the tags in a TGA file format. For more information 
about tag file formats, see Tag File Format on page 94.

Cancel (Embed only)

Cancel is only available when you’re in interactive mode, where you’re directly 
inserting a tag into your document. 

To Cancel Changes to a Tag

• Choose Cancel. Tagcommander shuts down and returns to your document 
without making any changes to the tag object. 

Tag List

Tagcommander displays a listing of the tags in the top portion of the right side of the 
window. The tags are listed either in the order you entered them or sorted by name, 
depending on your choice (see Sort Tags By Name on page 28).

To View the Tag List

• Double-click a tag in the list box. 

-or-

Highlight the tag and press ENTER. 

Tagcommander displays the properties of and preview for the tag. 

Tag Preview

The preview box displays a preview of the tag. The length of the tag is represented 
by the selected replacement character; the width and depth of the tag are displayed 
in the respective fields to the left of the preview box. 

Let's use a client named Russell Johnson as a replacement-character example. The 
client's name is 15 characters in length, including the space. If you choose to use a 
pound sign (#) to reserve space for the characters in the name, you'll see 15 pound 
signs in the preview box when you select the Name tag. 

Tip Pressing the CTRL key while clicking the right mouse button on the Preview pane 
displays the PFM metrics as text. 
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WORKING WITH THE TAG LIST
When you start new tag file or open an existing tag file, Tagcommander displays the 
contents of the file in the tag list box. Tagcommander provides several commands 
that let you operate on this list. You can:

• View detailed information about a tag in the list. For instructions, read Viewing 
Detailed Tag Information on page 49.

• Add a tag to the list. For instructions, read Adding a Tag to a Tag File or Tag 
List on page 50.

• Delete a tag from the list. For instructions, read Deleting Tags on page 51.

• Rename a tag. For instructions, read Renaming a Tag on page 52.

• Search for a particular tag in the list. For instructions, read Searching for Tags 
on page 53.

• Sort the tags in the list. For instructions, read Sorting Tags on page 53.

Viewing Detailed Tag Information

You can view detailed tag information of any tag, as that information is displayed in 
the Properties area of the Tagcommander dialog box for the currently-selected tag. 

To View Detailed Information for a Tag

1. Use the mouse to highlight your selection. 

2. Double-click the tag or highlight it and press Enter to select it. 

3. The detailed information is shown in the Properties area of the Tagcommander 
dialog box. 
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Adding a Tag to a Tag File or Tag List

When you need to insert tags in a document, you must first name each tag, and then 
add it to the tag list. 

Occasionally, you might need to create one or more tags for data item(s) that have 
recently been added to your application, but not complete the process of inserting the 
tag(s). You can create a tag and add it to a tag file without having to initially insert 
the tag, or update a Rulebase Tag table, or define other tags that will eventually be 
included in a tag file. 

To Create and Save a Tag to a Tag List

1. Start Tagcommander. 

2. Do one of the following, if required: 

3. Choose Edit>Add a Tag, and Tagcommander displays the Add a Tag dialog box. 

4. Enter the name, width (number of characters in the field), and depth (number of 
lines-enter more than one line for a block tag, such as a insurance rate table), and 
then choose OK. 

Note The maximum Name length is 30 characters. 

After adding a tag to the tag list, Tagcommander displays a reminder dialog box and 
prompts you to add this tag to a Rulebase Tag table (if you’re enabled the option). 

To Do this

Store the tag in a new tag file If [Untitled] isn’t displayed in the title bar, choose File>New. 

Store the tag in the tag file 
that was last used 

If the name of the tag file last used isn’t displayed in the title bar, select the 
File menu and choose the tag file from the list of previously-used files. 

Store the tag in a previously- 
created tag file, other than the 
one that was last used.

Choose File>Open, and then select the file to load using the Open dialog. 
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5. Click OK to return to the main Tagcommander screen. 

The tag is displayed in the tag list box, its preview (based on the default 
replacement character settings) is displayed in the tag preview box, and its 
current Properties settings are displayed on the left side of the window. 

6. At this point, you'll probably need to adjust some of the Properties settings to suit 
your document requirements. 

For details about changing Properties settings for a tag, see Changing Tag 
Properties on page 39.

7. To save the tag file, choose File>Save. If the tag file is new, specify a path and 
name for the file, and then choose OK. 

Deleting Tags

You can use the Delete a Tag command to delete the currently-selected tag from the 
list. 
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To Delete a Tag

1. Use the mouse to highlight your selection. 

2. Choose Edit>Delete a Tag and Tagcommander displays the Delete a Tag dialog 
box. 

3. Click OK to delete the tag or Cancel to exit without deleting. 

Renaming a Tag

When a variable data item for one of your documents changes and you want to 
preserve the old tag but give it a more meaningful name, you can use the 
Edit>Rename a Tag command to give the old a new tag name. 

To Rename a Tag

1. In the tag list box, double-click to select the tag to rename. 

-or-

Highlight the tag and press ENTER. 

2. Choose Edit>Rename a Tag. The Rename a Tag dialog displays. 

3. Type a new name for the tag, and then choose OK. Tagcommander updates the 
selected tag with the new name. 



Getting Started with Tagcommander

53

Searching for Tags

You can use the Search command to search the tag list for a specific tag. 

To Search for a Tag

1. Choose Edit>Search for Tag and Tagcommander displays the Search for Tag 
dialog box. 

2. Enter the tag you want to locate. 

3. Click OK to begin the search or Cancel to exit without searching. 

4. If the search is successful, the tag will be highlighted; if not, a Not Found dialog 
box displays telling you the tag was not found. 

Sorting Tags

You can use the Sort command to display the tags in alphabetical or entry order. 

To Sort Tags

• Choose Options>Sort Tags by name. 

Tagcommander displays the tag list in either alphabetical order or the order in which 
they were entered. 

WORKING WITH TAG FILES
Generally, you should build a separate tag file for each application you'll process 
using Tagcommander. By doing so, you'll keep all your tag formats consistent and 
easier to find. Tagcommander provides several commands that let you operate on tag 
files. You can:

• create a tag file. For instructions, read Creating a Tag File on page 53.

• open a tag file. For instructions, read Opening a Tag File on page 54.

• print the contents of a tag file. For instructions, read Printing a Tag File on page 
54.

Creating a Tag File

You can use the New command to clear the current tags list and open a new one. 

To Create a Tag File

1. Choose File>New and Tagcommander displays a screen with no tags in the list 
and [Untitled] in the title bar. If you've made changes since the last New or Open 
action, you're prompted to save the current list before it's cleared. 

2. Begin entering tags. See To Create and Save a Tag to a Tag List on page 50.
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Opening a Tag File

You can use the Open command to load a tag list from an existing tag file. 

To Open a Tag File 

1. Choose File>Open and Tagcommander displays the Open dialog box. 

If you've made changes since the last New or Open action, you're prompted to save 
the current list before it's cleared and tags are loaded from the file. 

2. Type the name of the desired tag file in the File Name text box or use the mouse 
to highlight your selection. 

3. Click Open to open a tag file or Cancel to exit without opening. 

Printing a Tag File 

You can use the Print command to print the tag list to the default printer. 

To Print a Tag File 

• Choose File>Print and Tagcommander prints the tag file. 

Tip If you want to use the basic tag file that contains Documaker fp reserved tags, you 
should open RSVTAGNM.TXT and immediately save it as RSVTAGNM.TGA. 
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ASSEMBLING THE DOCUMENTS AND MERGING THE DATA 
After you've inserted tags into your documents and generated the print streams with 
Printcommander, see the Rulecommander documentation for instructions on 
combining the documents into a Document Package. Then, see the Documaker fp 
Server documentation for details about merging the data and printing the Document 
Package. 

MENU OPTIONS
Docuflex Studio comprises the following menus: 

• File Menu on page 55

• Edit Menu on page 56

• View Menu on page 56

• Options Menu on page 56

• Help Menu on page 57

File Menu

The File menu contains the tools necessary to open, save, and print the tag list(s). 

Sub menu Item Function

New New clears the current tag list and opens a new one. If your’e made changes since 
the last New or Open action, you're prompted to save the current list before it's 
cleared. For more information, see Creating a Tag File on page 53.

Open Open loads the tag list from an existing tag file. If you’re made changes since the last 
New or Open action, you're prompted to save the current list before it's cleared and 
tags are loaded from the file. For more information, see Opening a Tag File on page 
54.

Save Save saves the contents of the tag list to the file from which it was loaded. If the list 
is derived from more than one file, you're prompted to enter a new tag file name. 

Save As Save As is the same as Save, except you'll always be prompted for the tag file name. 

Print Print prints the tag list to the default printer. Before printing the tag list, you should 
choose Control Panel>Printers and verify the currentprinter. For more information, 
Printing a Tag File on page 54.

Exit Exit exits Tagcommander and returns you to your application or Windows Desktop. 
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Edit Menu

The Edit menu contains the functions whereby you can manipulate the individual 
tags. 

View Menu

The View menu lets you sort the tag list or display the tag detail information. 

Options Menu

The Options menu lets you specify the following settings. 

Sub menu Item Function

Add a Tag Add a Tag prompts you to add a tag (including width and depth) that isn't in the tag 
list. For more information, see Adding a Tag to a Tag File or Tag List on page 50.

Delete a Tag Delete a Tag deletes the currently selected tag from the tag list. For more information, 
Deleting Tags on page 51.

Rename a Tag Rename a Tag allows for the renaming of the selected tag from the tag list. For more 
information, see Renaming a Tag on page 52.

Search for Tag Search for Tag searches the tag list for a user-specified tag. For more information, 
see Searching for Tags on page 53.

Copy Tag to 
Clipboard

Copy Tag to Clipboard copies the current tag object to the Windows Clipboard. You 
can then paste the object into other Windows applications. For more information, see 
Manually Inserting a Tag on page 36.

Sub menu Item Function

Toolbar Toolbar toggles a display of a toolbar that allows for doing the same functions that are 
displayed on the Menu Bar. 

Status Bar Status Bar toggles a display a bar under the Tagcommander dialog box that gives you 
information as the status of Tagcommander. 

Settings Settings displays an Environmental Settings dialog box listing highlights of the active 
Printer Definition. 

Refresh Refresh to update the currently displayed Tagcommander dialog box with new data. 

Sub menu Item Function

Use a Text Data 
File

When checked, the Open command searches for tag files with a TXT extension. If this 
item isn't checked, Open searches for tag files with a TGA extension. For more 
information, see Use a Text Data File on page 27.

Always Open Last 
File Accessed 

When checked and Tagcommander is started, it will open the last file that was 
accessed by Tagcommander, before Tagcommander was shut down. For more 
information, see Always Open Last File Accessed on page 28.

Prevent Tag 
Duplication

When checked, this selection will not allow you to create any new tag or rename a tag 
that already exists in the opened file. For more information, see Prevent Tag 
Duplication on page 28.
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Help Menu 

The Help menu contains helpful hints about the use and maintenance of 
Tagcommander. 

Tagcommander Help

Tagcommander provides extensive on-line help for its basic procedures, operations, 
and menu commands. 

• To access help, use any of the following methods. 

Provide Rulebase 
Reminders

When checked, this message opens a dialog that reminds you toupdate the 
Documaker fp Rulebase after each tag is added. For more information, see Provide 
Rulebase Reminder on page 28.

Sort Tags By 
Name

When checked, this options alphabetizes the tags. If left unchecked, the tags are 
listed in the order in which they were added. For more information, see Sort Tags By 
Name on page 28.

To Perform this action

Navigate the help

file with the Table

of Contents

1 Choose Help>Tagcommander Help.

Tagcommander displays its help window.

2 Click the Contents tab in the panel on the left side.

3 Use the mouse to expand the various topics in the table of

contents.

4 Select the desired topic and the contents is displayed in the panel

on the right.

Access and/or

browse a

comprehensive

listing of index

entries

1 Choose Help>Tagcommander Help.

Tagcommander displays its help window.

2 Click the Index tab in the panel on the left side.

3 Type the keyword you want to find, and then choose the closest

index entry.

-or-

Browse the list of index entries and select the one you want.

4 Click Display and the contents is displayed in the panel on the

right.

Use the help

Search feature to

directly access a

help topic

1 Choose Help>Tagcommander Help.

Tagcommander displays its help window.

2 Click the Search tab in the panel on the left side.

3 Type a search keyword for which you want help, and then choose

List Topics.

Related help topics display in the lower list box.

4 Choose the help topic you want to view, and then choose

Display.

Tagcommander displays help for the topic you chose.

Sub menu Item Function
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About

• Choose Help>About Tagcommander to get the version number, product type, 
and copyright date for your current version of Tagcommander. 
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Chapter 4

Using Docugraph Charts

OVERVIEW
Docugraph, a productivity tool, inserts business graphics as charts. Docugraph charts 
include a full range of business applications, such as pie, bar, stacked bar, line, 
histogram, and others. Docugraph dynamically generates two- and three-
dimensional charts that can be printed on Windows- and OS/2-compatible desktop 
printers, and highspeed Xerox Metacode and IBM Advanced Function Presentation 
(AFP) laser printers.

Docugraph is a powerful tool that can incorporate charts, generated from your 
variable data, into new or existing documents. Docugraph also improves the 
informational display of any business document that requires a visual representation 
of statistical or numerical data, such as customer statements, bills, and portfolios. 
Among other features, Docugraph:

• converts your variable data into charts “on-the-fly”

• incorporates and prints charts to your high-speed Xerox and IBM laser printers

• integrates seamlessly with your Documaker fp applications

• integrates charts into your own applications

Docugraph also provides real-time charting: Both the X-axis and Y-axis support 
manual or automatic scaling for positive and negative data. Within a chart, you can 
specify chart text such as titles, footnotes, margins, and data legends. You can 
control font sizing or allow fonts to re-size automatically in the chart areas.

With Documaker fp, the flagship product used by hundreds of companies worldwide 
for document assembly, the implementation of Docugraph is extremely easy. Using

Docucreate ws and Tagcommander/DGSD, Documaker fp users simply add 
Docugraph Space Definition (DGSD) tags that, during processing, will call 
Docugraph fp to generate and merge the selected graphs into the document being 
printed.

COMPATIBILITY WITH ORACLE TAGS
You must have a Oracle Merge Engine to process tags created by and inserted with 
Oracle products. For a complete listing of the necessary Merge Engines, see Types 
of Oracle Tags and Tag Processing Limitations on page 6.

PROGRAM COMPONENTS
Tagcommander/DGSD contains an extended set of functions. These functions 
specify the parameters necessary to define charts to be included in your documents.

The Logical Color Definition application facilitates the set up and storage of logical 
device colors.
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CHARTING CONVENTIONS
At any time during the set up of a chart, you can view a sample of the chart by 
clicking Sample in the Tagcommander/DGSD window.

TAGCOMMANDER/DGSD
You can use Tagcommander/DGSD to define various parameters of the DGSD tag, 
which you will then insert in your document. These parameters control the 
appearance and size of the chart. For more information, see Inserting a Tag as an 
Embedded Object on page 53.

Starting Tagcommander DGSD

After you've installed Tagcommander on your system, you can launch its 
applications from the Start>Programs sub-menu.

To Start Tagcommander DGSD

1. Select Start>Programs and Windows displays the Docucreate folder.

2. Click the Docucreate DGSD icon:

For more information about Logical Color Definition, see Starting Logical 
Color Definition on page 66.
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Tagcommander DGSD displays its main window.

Ending Tagcommander DGSD

You can use the Exit command to close Tagcommander DGSD and return to the 
Windows Desktop.

To End Tagcommander DGSD

• Select File>Exit.

-or-

Click Close .

Tagcommander DGSD closes and returns control to the Windows Desktop.

Inserting DGSD Tags

When you reach the location in your document where you want to include a chart, 
click Insert>Object>DGSD Tag and Tagcommander/DGSD displays its main 
window.

To Insert DGSD Tags

1. Position the cursor at the place in your document where you want to insert the 
chart tag.

2. Click Insert>Object from the main word processor menu, then select DGSD 
Tag from the Object Type list box. This action automatically invokes 
Tagcommander/DGSD.
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3. Use the following table for information about defining the chart parameters.

Field Explanation

Docugraph 
Space 
Definition Tag 
Name

Enter the name of the DGSD tag. This name should correspond with the tag in the Documaker 
fp VRF that contains the actual data for the chart.

Delete After 
Use 

You can indicate whether Documaker fp should delete the tag value after it's used. 
When you create a tag that serves multiple purposes, you can direct Documaker fp to re-use 
the same tag for different values. Click the check box for Yes; leave it blank for No.

No No keeps the first occurrence of a particular data value. That same data value “flows 
through” to all other occurrences of that tag with the No setting.

Yes Yes includes different data for each successive tag.

Width Use the selection box to choose the width of the space reserved for printing the chart. 
The width is expressed in increments of 1/10th of an inch, from 1 to 110 (1/10th of an inch to 
11 inches).

Height Use the selection box to choose the height of the space reserved for printing the chart. 
The height is expressed in increments of 1/10th of an inch, from 1 to 110 (1/10th of an inch to 
11 inches).

Type Click the check box to display your chart in three dimensions.

On most charts, you have a choice between two dimensions and three; however, some charts 
are only 2D and others are only 3D.

For an illustration and explanation of the following parameters, see Charting 
Conventions on page 60.

Outer Frame Click the check box to display a frame around the outerperimeter of the chart.

Inner Frame Click the check box to create a frame out of the X- and Y-axes.

Shade 
Background

Click the check box to shade the background of the chart.

Y-Grid Line Click the check box to display Y-axis (horizontal) grid lines.

Language Click the drop-down arrow to choose the language in which you'd like to display certain 
labels on the chart. The areas affected by the Language selection include the X-Tick labels 
(e.g., Months and Days) and numeric values on the Y-axis (e.g., £1.600,00 instead of 
$1,600.00).

Heading Enter the text to display as the chart heading.

Footing Enter the text to display as the chart footing.

Left Margin Enter the text to display as the left margin of the chart.

Right Margin Enter the text to display as the right margin of the chart.
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4. Click Update to insert the DGSD tag.

Choosing Fonts

You can choose a range of fonts that Tagcommander/DGSD uses to display the 
various labels on your chart. You should choose a variety of font typefaces, point 
sizes, and styles, because Tagcommander/DGSD determines which font to use 
depending on the available space.

To Choose Fonts

1. Click Fonts and Tagcommander/DGSD displays the Chart Font Selection dialog 
box.

As mentioned earlier, you should choose a variety of fonts. Any one of these 
fonts could be used for the chart titles, depending on the amount of available 
space. For example, if your chart consumes most of the amount of reserved 
space, a very small font will be used, if at all. On the other hand, if your chart 
doesn't use up much of the reserved space, a large font will suffice.

2. Click Font One: to edit the typeface, point size, or style. Tagcommander/DGSD 
displays the Available Converted Fonts dialog.

3. Choose the appropriate font typeface, font style, and point size by clicking on 
the corresponding options in the respective list boxes. As an alternative, you can 
simply choose the desired device font and the other attributes are automatically 
adjusted.

X-Ticks The X-Ticks option controls the labels at each data point along the X-axis, such as the months 
of the year or the days of the week. Click the drop-down arrow to choose between the following 
choices:

• X-Ticks Text (CSV): If you choose this option, you can override the available labels and 
enter custom text labels by selecting this option. Enter your custom text in the corresponding 
text box. Your labels must be in comma Separated Value (CSV) format (e.g.,Bob, Fred, 
Charles).

• X-Ticks Type: If you choose this option, you should then click the accompanying drop-down 
arrow to display the available choices. After choosing your X-Ticks Type label, you can 
specify the starting point of the sequence. For example, if your choice is Months and you 
choose to Start With: 12, your X-Ticks labels will begin with December.

Field Explanation
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4. Click OK to save your changes or Cancel to exit without saving.

5. Repeat Steps 2 through 4 for the remaining fonts.

6. Click the drop-down arrow beside the Heading, Footing, Left Margin, and Right 
Margin chart titles to choose the exclusive font for those titles. The drawback to 
choosing an exclusive font is that the title might not display if there isn't enough 
room for that particular font.

You can leave the titles set to the Default font and Tagcommander/DGSD 
chooses the most appropriate font based on the amount of available space.

7. Click OK to save your changes or Cancel to exit without saving.

Choosing Chart Colors

Tagcommander/DGSD can display and print charts in color for full-color devices, 
such as the screen display, a color inkjet or color laser printer, or a plotter. For those 
charts that are destined for a highlight-color device, such as an IBM AFP or Xerox 
Metacode high-speed laser printer, the charts are represented in shades which are a 
combination of black and a highlight color.

Most charts offer both two-dimensional and three-dimensional views. When you 
view or print a two- or three-dimensional chart, Tagcommander/DGSD represents 
the foreground color of the group in the Primary Color. On a three-dimensional 
chart, the color which creates the shadow (or “depth”) is the Shading Color.

Tagcommander/DGSD includes default colors for each of eight color Groups. The 
following list contains the default colors for full color devices:

Group Primary Color Shading Color

1 Red Dark Red

2 Green Dark Green

3 Blue Dark Blue

4 Yellow Brown

5 Dark Gray Black

6 Cyan Dark Cyan

7 Pink Dark Pink

8 Pale Gray Dark Gray
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The following list contains the default colors for highlight color devices:

To Choose Chart Colors

1. Click Colors and Tagcommander/DGSD displays the Logical Group Colors 
dialog box.

2. Click the drop-down arrow next to the particular Group to choose the color for 
that Group.

By not choosing a specific color, your output is displayed and printed in the 
default color. For more information on the default colors for full color and 
highlight color devices, see Choosing Chart Colors on page 64.

Group Primary Color Shading Color

1 Shade16 Black52

2 Shade09 Black80

3 Shade11 Black59

4 Shade10 Black63

5 Shade17 Black100

6 Shade12 Black47

7 Shade06 Black84

8 Shade23 Shade17



Chapter 4 – Using Docugraph Charts

66

The Logical Group Color dialog displays the color choices for eight color 
Groups; however, Docugraph supports up to 12 Groups as can be supplied by the 
variable data. The Primary colors you choose for Groups 1 through 4 are re-used 
as the Shading Colors for Groups 9 through 12. Likewise, the Shading colors you 
choose for Groups 1 through 4 are re-used as the Primary Colors for Groups 9 
through 12.

IMPORTANT! To choose colors other than the default Group colors, or for highlight-color devices, you must set 
up logical group colors through the Logical Color Definition routine (see Logical Color 
Definition on page 66.

3. Click OK to save your changes or Cancel to exit without saving.

LOGICAL COLOR DEFINITION
Use the Logical Color Definition executable program that accompanies 
Tagcommander DGSD to create custom colors for your output device. 
Tagcommander DGSD contains default colors for each of the color Groups, but your 
enterprise will probably use preset or company colors for any business charts.

Starting Logical Color Definition

After you've installed Tagcommander on your system, you can launch its 
applications from the Start>Programs sub-menu.

To Start Logical Color Definition

Select Start>Programs sub-menu and Windows displays the Docucreate folder.

• Click the DGSD Logical Color Definition icon:

For more information about Tagcommander DGSD, see Starting 
Tagcommander DGSD on page 60.

Tip After you've created logical group colors in the Logical Color Definition executable, they 
are available for use on the Logical Group Colors dialog in Tagcommander DGSD.
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Logical Color Definition displays its main window.

Ending Logical Color Definition

You can use the Exit command to close Logical Color Definition and return to the 
Windows Desktop.

To End Logical Color Definition

• Select File>Exit.

-or-

Click Close.

Logical Color Definition closes and returns control to the Windows Desktop.

To Add Logical Colors (Full Color Printer)

1. Enter the name of the logical color you're creating (e.g., pink, orange, purple).

2. Click RGB: to choose the color for this logical color name and Tagcommander/
DGSD displays the Color dialog box.

When you choose a color for Full Color Devices, the color displays during the 
screen display of a chart. The same color is also used for printing the chart to a 
color inkjet, color laser, or plotter printer.

3. Click the desired color. For more information about selecting colors, see the 
Microsoft Windows documentation.
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4. Click OK to save your changes or Cancel to exit without saving. 
Tagcommander/DGSD returns you to the Logical Color Definition dialog box.

5. Select Add>Update to add this color to the list of available logical colors

To Add Logical Colors (Highlight Color Printer)

1. Enter the name of the logical color you're creating. This name describes the 
percentages of highlight color and black present in the desired “color” (e.g., for 
a shade that is 44% color and 11% black, you could enter the name C44K11).

2. Click RGB: to choose the color for this logical color name and Tagcommander/
DGSD displays the Color dialog box.

Tip Even when you're using a Highlight Color Device, you can still choose a Full Color 
Device color to use when sampling the chart on the screen display.

3. Click the desired color. For more information about selecting colors, see the 
Microsoft Windows documentation.

4. Click OK to save your changes or Cancel to exit without saving. 
Tagcommander/DGSD returns you to the Logical Color Definition dialog box.

5. Choose your Hex Pattern choices for your Highlight Color Device.

When you choose a color for Highlight Color Devices, you're actually selecting 
a shade composed of a mixture of black and a highlight color. For example, let's 
say that the highlight color in your printer is red. By mixing certain percentages 
of black and red, you can represent upwards of 5000 shades of red, including 
solid red and solid black.

Tagcommander/DGSD includes Xerox standard percentages of black (Black 
Hex Patterns) and the highlight color (Highlight Color Hex Pattern). These 
percentages range from 0% to 100% and are listed by the labels “DFXBlackxx” 
and “DFXColorxx”. You can use these percentages to “mix” your particular 
shade, from 100% Black and 0% Color to 0% Black and 100% Color.

Tip The Black and Highlight Color Hex Patterns correspond to the samples listed in the 
Xerox “4850 Highlight Color Printer Palette” sheets. (Please see your Xerox printer 
specialist representative for more information.) 

Example Using one of the palette sheets as an example, you can accurately re-create a particular shade by 
choosing the correct mix of black and the highlight color. If you choose a shade of green, for 
example, that is labeled G48K12, this shade contains 48% Green and 12% Black. You should 
choose a Black Hex Pattern of DFXBlack12 and a Highlight Color Pattern of DFXColor48.
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To Add Logical Colors (Black-and-White Printer)

1. Enter the name of the logical color you're creating. For black-and-white printers, 
this name describes the shading pattern you want to use.

2. Click RGB: to choose the color for this logical color name and Tagcommander/
DGSD displays the Color dialog box.

Tip Even when you're using a black-and-white printer, you can still choose a Full Color 
Device color to use when sampling the chart on the screen display.

3. Click the desired color. For more information about selecting colors, see the 
Microsoft Windows documentation.

4. Click OK to save your changes or Cancel to exit without saving. 
Tagcommander/DGSD returns you to the Logical Color Definition dialog box.

Field Explanation

Black Hex 
Pattern

Click the drop-down arrow to choose the desired percentage of Black to be 
included in the color shade. For a shade that contains 22% Black, for 
example, you should scroll through the list and choose DFXBlack22.

After you choose a Black Hex Pattern, the area on the right displays your choice. The 
display isn’t exactly what will print, because the screen resolution is approximately 96 
dots per inch (DPI) and your printer's resolution is 300 DPI.

Custom Click CUSTOM to see an enlarged view of your Hex Pattern. For more 
information about editing Hex Patterns, see To Customize Logical Colors on 
page 70.

Highlight Color 
Hex Pattern

Click the drop-down arrow to choose the desired percentage of the highlight color to 
be included in the color shade. For a shade that contains 17% color, for example, you 
should scroll through the list and choose DFXColor17.

The Highlight Color Hex Patterns are purposely left generic because of the 
variety of colors that can be used for your highlight color.

After you choose a Highlight Color Hex Pattern, the area on the right displays your 
choice. The display isn’t exactly what will print, because the screen resolution is 
approximately 96 dots per inch (DPI) and your printer's resolution is 300 DPI.

Custom Click CUSTOM to see an enlarged view of your Hex Pattern. For more 
information about editing Hex Patterns, see To Customize Logical Colors on 
page 70.

Black Priority Click the check box to give black print priority over color print, or leave it un-
checked to give color print priority over black print. To understand “black priority”, you 
must realize that, with highlight color printing, there are two layers of print for every 
shade—black and the highlight color.

The printer will only print one color per pel, so you must give either the black or the 
highlight color priority.
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5. Choose the Hex Pattern choices for your black-and-white printer. You'll choose 
a black-and-white shading pattern for your printer.

•  percentage of Black to be included in the color shade, or
• shading pattern (e.g., DFXShade19).

To Customize Logical Colors

1. Click the drop-down arrow next to the Black Hex Pattern and Highlight Color 
Hex Pattern and choose <custom>/0000000000000000.

2. Click Custom and Tagcommander/DGSD displays the Hex Pattern Editor 
dialog box.

CAUTION! Although you can edit the Hex Pattern for any of the established DFXBlack, DFXShade, and 
DFXColor patterns, you should choose the <custom> choice instead.

The Hex Pattern Editor dialog initially displays zeros at the top, indicating that no 
choices have been made. As you click individual boxes, however, the numbers 
change to indicate the hexadecimal pattern you're creating.

3. Click the desired pixel boxes to create a shading pattern. The area on the right 
displays the pattern as you create it. The Hex Pattern Editor displays an 8 pixel 
by 8 pixel block on the left and a more accurate depiction on the right.

4. Click All to highlight all boxes or Clear to clear the pattern and start creating a 
pattern again.

5. Click OK to save your changes or Cancel to exit without saving.

To Update Logical Colors

1. Click the drop-down arrow next to the Logical Color text box and choose the 
color you want to edit (update).

2. Make the desired changes to your logical color's settings.

3. Select Add>Update to update this color/shading pattern in the list of available 
logical colors.

Field Explanation

Black Hex 
Pattern

Click the drop-down arrow to choose the desired:

Note: The DFXShade choices in the Black Hex Pattern list are Oracle-supplied 
gradient patterns.

After you choose a Black Hex Pattern, the area on the right displays your choice. The 
display isn’t exactly what will print, because the screen resolution is approximately 96 
dots per inch (DPI) and your printer's resolution is 300 DPI.

Custom Click CUSTOM to see an enlarged view of your Hex Pattern. For more 
information about editing Hex Patterns, see To Customize Logical Colors on 
page 70.

Highlight Color 
Hex Pattern

For black-and-white printers, the Highlight Color Hex Pattern option doesn't apply. 
Click the drop-down arrow and choose the <Default> option.

Black Priority For black-and-white printers, the Black Priority option doesn't apply.
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To Delete Logical Colors

1. Click the drop-down arrow next to the Logical Color text box and choose the 
color you want to delete.

2. Click Delete to delete this color/shading pattern from the list of available logical 
colors.
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Chapter 5

Using Docuflex Tag Manager

OVERVIEW
Docuflex Tag Manager is the Docucreate workstation software component that you 
use to manage and insert Docuflex Tags, temporary placeholders that derive their 
contents from Reserved Tags, Schema fields, or Rules within a Docuflex data project 
(*.ddp) file.

By using Docuflex Tag Manager, Docucreate Workstation, and a word processor, 
you can create documents that directly access components included in a Docuflex 
Studio project, and then insert those documents into your project.

Docuflex Tag Manager works with Windows applications supporting object linking 
and embedding (OLE), a program interface that lets you easily update objects within 
an application.

CREATING DOCUMENTS
Before you start inserting tags into documents, here’s a quick primer on the general 
steps you take to compose, tag, and prepare a document for Docuflex processing.

To Create a Document

1. Plan the layout and format of your document, including the names, lengths, and 
placement of the tags that hold the items of variable data to be merged.

2. Create the document in your word processing application.

3. Start Docuflex Tag Manager from within your word processor and insert tags 
from the Docuflex data project (*.ddp) file as necessary. For more information, 
see Inserting and Updating Tags on page 80.

4. Print the document in DCD format using Printcommander (see the 
Printcommander User Guide).

Be sure to enable the Normalization function in Printcommander and choose 
Printcommander as the current printer in your composition system.
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INCLUDING DOCUMENTS IN DOCUFLEX STUDIO
Now that the documents are in a Oracle-compatible format, you can add them to your 
current Docuflex Studio data project (*.ddp).

To Include Documents in Docuflex Studio

1. Start Docuflex Studio and open the project into which you want to insert 
documents containing Docuflex Tags (see the Docuflex User Guide).

2. Add the document into your project as a Pre-Composed Document member (see 
the Docuflex User Guide).

3. Review the contents of the Docuflex Tag(s) by viewing the Additional 
Properties panel in the Source Pane (see the Docuflex User Guide).

GETTING STARTED WITH DOCUFLEX TAG MANAGER
After you've installed Docuflex Tag Manager on your system, you can launch it or 
its companion applications from the Programs sub-menu of the Windows taskbar.

To Start Docuflex Tag Manager

1. Select Start>Programs and Windows displays the Docucreate folder.

2. Click the Docuflex Tag Manager icon:

Docuflex Tag Manager displays its main program window.

Because there are several tasks you can perform with Docuflex Tag Manager, 
this guide provides a separate topic for each task. To End Docuflex Tag Manager

• Select File>Exit.
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-or-

Click Close on the Docuflex Tag Manager window.

CONFIGURING DOCUFLEX TAG MANAGER
This section addresses the global settings you can make to configure Docuflex Tag 
Manager to your working preferences.

These settings are located on the Options menu. You can enable an option by 
selecting it from the menu—this action placed a check mark next to the option. By 
selecting the option again, you remove the check mark and disable it.

Always Open Last File Accessed

When you open Docuflex Tag Manager for the first time, [Untitled] displays in the 
title bar.

This option instructs Docuflex Tag Manager to open the last project file in use from 
a previous session. Docuflex Tag Manager searches for the previously-opened 
project file and automatically opens it, whether you choose the program icon or start 
it through a wordprocessing application. If Docuflex Tag Manager can't find the 
previous project file, you're prompted for the name of another one.

If you clear (uncheck) this option, you must open a project file each time you enter 
Docuflex Tag Manager.

Use Screen Font Metrics

This option determines whether Docuflex Tag Manager uses font metrics from the 
Windows font list or device-specific PFMs to determine font characteristics such as 
point size, stroke weight, and character width.

If you don’t want to use Windows font metrics, disable (uncheck) the option. The 
default is for Docuflex Tag Manager to use Windows fonts.

Tip If the Preview box displays the following message, you’ll need to verify which font 
metrics you should use:

"The list of PFMs is empty. If your PrintDef does not reference PFMs then the screen 
metrics option should be used."
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Align to the Font Baseline

To eliminate the problem of uneven vertical-line spacing (leading) for a tag inserted 
in fixed text, use this option to adjust the height of the embedded tag so that its 
baseline aligns with the baseline of the surrounding fixed text.

Docuflex Tag Manager decreases the height of the rectangle that surrounds the tag 
by the amount of the descender portion of the font and moves the replacement 
characters to the top of the rectangle.

For some fonts, it might not be possible to get both the correct point size and line 
spacing. In those cases, you might have to force the proper line spacing with options 
provided by theword processing program.

Display Field Name

This option determines whether Docuflex Tag Manager should display the field 
name instead of the replacement characters for the selected field, with some 
conditions:

• a Rule or Tag—the full name is displayed up to the number of replacement 
characters

•  a Schema item—the column name is displayed up to the number of replacement 
characters.

Example If you enable this feature and the number of replacement characters you specify is 10, 
then the following results are encountered:

• a Rule called CustomerRule is displayed as “CustomerRu”

•  a Tag called DCP.MEMBER.NAME is displayed as “DCP.MEMBER”

• a Schema item called Customer.CityStateZip is displayed as “CityStateZ”

These conditions do not change the way the field is viewed in Docuflex Studio, only 
in Microsoft Word and Docuflex Tag Manager.

Sort Properties Alphabetically

When you click anywhere on the Field Properties grid, on the right side of the main 
window, you can view the grid in organizational categories or alphabetically by 
property name. The default is for Docuflex Tag Manager to sort the list of field 
properties alphabetically.

NAVIGATING THE MAIN WINDOW

The main Docuflex Tag Manager window is split into several panes, the 

WARNING! Use of this option might affect the point size of the font for the tag because it attempts to control 
baseline alignment and line spacing by decreasing the height of the frame around the 
tag. 
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explanation of which follows:

Field Name

The tag you choose from this tree view box is contained in the Docuflex Studio data 
project (*.ddp) file:

The Schema, Rules, and Tags represent the layout of the data file, processing rules, 
and reserved tag names, respectively.

Option Explanation

Field Name The name of the schema field, business rule, or reserved tag that provides data for 
this tag. For more information, see Field Name on page 77.

Field Style Predefined property attributes for a field; designed in a Docuflex Studio project. For 
more information, see Field Style on page 78.

Update Update displays when you’re embedding a tag directly into your composition 
system. For more information, see Update on page 79Update on page 79.

Cancel Cancel displays when you’re embedding a tag directly into your composition 
system. For more information, see Cancel on page 79.

Preview box The preview displays the replacement characters formatted with the Character Style 
properties. For more information, see Tag Preview on page 79.

Field 
Properties grid

Individual property attributes that control formatting and content characteristics. This 
grid mirrors the one present in Docuflex Studio. 
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To Select a Field Name

1. Use the mouse to expand the category in which you want to select a tag.

2. After locating the tag, select it with the mouse.

If you select a Schema data field to which a Docuflex Field Style has been 
assigned, the Field Properties reflect these stored settings and the preview box 
displays a representation of the tag.

You can override any of the properties specified by the Field Style. For more 
information about assigning field styles to schema data fields, see (see the 
Docuflex User Guide).

Field Style

Field Styles are created in Docuflex Studio and specify such property characteristics 
as size, font, and formatting for variable data fields in a Docuflex Studio project.

To Apply a Field Style

Note You can apply Field Styles to Rules and Reserved tags, as well as Schema data fields.

• In the Field Style drop-down list box, select a field style.

All property values specified by the Field Style are automatically updated; 
however, if the Field Style doesn’t specify a value then the current property 
remains unchanged.

Tip If you make changes to a field that doesn’t use a Field Style, and then you select a 
different field that uses a Field Style, Docuflex Tag Manager displays a message asking 
if you want to use the Field Style values.
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To Change or Remove a Field Style

• You can change the field style by selecting a different style.

Note If you decide to remove the field style, you’ll receive a warning dialog.

Update

Update is only available when you’re in interactive mode—where you’ve accessed 
Docuflex Tag Manager via your word processing application and you’re inserting a 
tag into your document.

To Update and Insert a Tag

• Click Update and Docuflex Tag Manager inserts the tag into your document.

Cancel

Cancel is only available when you’re in interactive mode, where you’re directly 
inserting a tag into your document.

To Cancel Changes to a Tag

• Click Cancel and Docuflex Tag Manager shuts down without making any 
changes to the tag object.

Tag Preview

The preview box displays a preview of the tag in the font and point size you’ve 
chosen. The length of the tag is represented by the selected replacement character; 
the number of replacement characters is displayed in the Length field (to the right of 
the preview box in the properties grid).

Let's use a client named Russell Johnson as a replacement character example. The 
client's name is 15 characters in length, including the space. If you choose to use a 
pound sign (#) to reserve space for the characters in the name, you'll see 15 pound 
signs in the preview box when you select the name tag.

OPENING A PROJECT FILE
You can use the Open command to load a Docuflex Data Project (*.ddp) file created 
by Docuflex Studio. Docuflex Tag Manager works exclusively with Docuflex Studio 
to create documents that include tags representing reserved tag names, data fields 
defined by the schema, and custom business processing rules.

To Open a Project File

1. Select File>Open and Docuflex Tag Manager displays the Open dialog box.

2. Navigate to the folder containing your Docuflex projects.

3. Type the name of the desired project file in the File Name text box or use the 
mouse to highlight your selection.
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4. Click Open to open the file or Cancel to exit without opening.

INSERTING AND UPDATING TAGS
Docuflex Tag Manager lets you insert tags directly into a Windows-compatible word 
processing program.

This section contains information about the operations of Docuflex Tag Manager. 
You'll find step-by-step instructions for inserting tags in your document, and 
performing other types of updates on tags.

Inserting a Tag as an Embedded Object

All Windows applications supporting object linking and embedding (OLE) contain 
a menu item for inserting objects. The Insert option is usually found either on the 
main menu or as a sub menu item in the Edit menu. When you choose Insert>Object, 
the application displays a window containing a list of the objects you can insert. You 
can then choose to insert a tag (e.g., Insert>Object>Docuflex Tag).

To Insert a Tag as an Embedded Object

When you're inserting tags as embedded objects, use the following procedures for 
inserting and updating tags:

Note Nearly all word processing programs support object linking and embedding (OLE). 
Throughout the manual, you'll encounter examples illustrating the steps necessary to 
insert and update tags (all steps are based on the Microsoft Word for Windows 
interface).

Tip In order to properly insert tags, you should

1. Go into your word processor, open the document, and begin entering the text.

2. Position your cursor at the place where you want to insert a tag.

3. Select Insert>Object>Docuflex Tag (from within your word processor).

4. Select the tag you want to insert from Docuflex Tag Manager’s Field Name list.

5. Click Update.
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1. Position the cursor at the place in your document where you want to insert the 
tag.

2. Select Insert>Object from the main word processor menu, then select Docuflex 
Tag from the Object Type list box.

This action automatically invokes Docuflex Tag Manager.
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3. Choose a Docuflex Tag from the Field Name tree view box. If necessary, you 
can open a project file.

Tip If you select a Docuflex schema data field as the source for the Docuflex Tag, see Field 
Style on page 78.

4. Make any changes to the Field Properties of the tag by selecting and editing the 
properties in the grid.

Tip Docuflex Tag Manager automatically chooses the Normal Character Style and 10 @, 
“at” symbols, as the Replacement Characters for the tag. You can substitute a different 
replacement character, as long as all the characters are the same (i.e., you can’t mix 
replacement characters).

The Length and ReplacementChars fields update each other—if you change the number 
of symbols or type in a different Length, the corresponding field is updated.

For instructions and short descriptions about tag formatting and display 
properties, read To Change the Properties for a Tag on page 85.
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5. After reviewing the preview box to verify the format of the tag, click Update on 
the bottom of the Docuflex Tag Manager window to insert the tag into your 
document.

The updated tag is inserted at the current cursor position in the document (unless 
you double-clicked an existing tag to launch the preceding process).

Updating an Embedded Tag

After you've inserted tags in your document, you might need to change some option 
about the tag. The steps are almost identical to inserting a tag.

To Update an Embedded Tag

1. Double-click the tag (replacement characters).

-or-
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Highlight the tag and press ENTER.

Windows automatically executes Docuflex Tag Manager.

2. Make the necessary changes to any of the field properties for the tag.

For instructions and short descriptions about tag formatting and display 
properties, read To Change the Properties for a Tag on page 85.

3. Click Update to update the tag.

Copying or Moving a Tag to Another Location

You can use your word processing program’s Cut or Copy commands to copy or 
move a tag just like you copy or move text or pictures.

To Copy or Move a Tag to Another Location

1. In the document that contains the tag, click the tag to select it.

2. Click Edit>Copy or Edit>Cut to either copy or move the selected tag to the 
Windows Clipboard.

3. Click an insertion point at the location in document where you want to place the 
tag.

4. Click Edit>Paste to insert the tag.

Replacing a Tag

You can easily replace one tag with another, with or without updating the properties 
for the tag.

To Replace a Tag

1. Delete the current tag from the document. For instructions, read the next topic.

2. If you need to change the properties for the inserted tag, see Updating an 
Embedded Tag on page 83.
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Deleting a Tag

You can delete a tag just like you would delete a picture.

To Delete a Tag

1. In the document, click the tag to select it.

2. Press DELETE.

Changing Tag Properties

Docuflex Tag Manager automatically supplies some default properties for each of 
the tags you add. If you need to change the properties for a tag, proceed with the 
following instructions.

To Change the Properties for a Tag

1. Select the desired tag from the Name drop-down list.

2. Choose a property in the grid and then type the desired setting. Repeat as 
necessary for all properties you want to change.

MENU OPTIONS
Docuflex Tag Manager comprises the following menus:

• File Menu on page 85

• Edit Menu on page 86

• View Menu on page 86

• Options Menu on page 86

• Help Menu on page 87

File Menu

The File menu contains the tools necessary to open a data project file or select from 
a list of previous projects.

Sub menu 
Item Function

Open Open lets you choose a current Docuflex data project (*.ddp) file. For more 
information, see Opening a Project File on page 79.

Exit Exit closes Docuflex Tag Manager and returns you to your application or Windows Desktop.
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Edit Menu

The Edit menu contains the functions whereby you can manipulate the individual 
tags.

View Menu

The View menu lets you sort the tag list or display the tag detail information.

Options Menu

The Options menu lets you specify the following settings.

Sub menu 
Item Function

Cut Moves the text you've selected onto the Windows Clipboard.

Copy Places a copy of text you've selected onto the Windows Clipboard.

Paste Copies text from the Clipboard to a location where you have clicked an insertion point.

Reset Reset cancels any value change to the currently-selected property. You can also right-click in 
the property grid and select Reset from the context menu.

Reset All Reset All cancels any changes you’ve made in the property grid. You can also right-click in the 
property grid and select Reset All from the context menu.

Sub menu 
Item Function

Toolbar Toolbar toggles a display of a toolbar that allows for doing the same functions that are 
displayed on the Menu Bar.

Status Bar Status Bar toggles a bar under the Docuflex Tag Manager dialog box that gives you 
information as the status of Docuflex Tag Manager.

Settings Settings displays the Environment Settings dialog that contains information about the 
location of the Docuflex project and the printer specifications you’re currently using.

Sub menu 
Item Function

Always Open 
Last File 
Accessed

When checked and Docuflex Tag Manager is started, it will open the last file that was accessed 
by Docuflex Tag Manager before it was shut down. For more information, see Always Open 
Last File Accessed on page 75.

Use Screen 
Font Metrics

Toggle this option to indicate whether Docuflex Tag Manager should use Windows fonts or 
device-specific PFMs to determine font characteristics. For more information, see Use Screen 
Font Metrics on page 75.

Align to the 
Font Baseline

Enable this option to adjust the height of an embedded tag to align with the baseline of the 
surrounding text. For more information, see Align to the Font Baseline on page 76.

Sort 
Properties 
Alphabetically

Toggle this option when you want to display the properties grid in alphabetical order by field 
property name. For more information, see Sort Properties Alphabetically on page 76.
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Help Menu

The Help menu contains helpful hints about the use and maintenance of Docuflex 
Tag Manager.

Docuflex Tag Manager Help

Docuflex Tag Manager provides extensive on-line help for its basic procedures, 
operations, and menu commands.

• To access help, use any of the following methods.

About Docuflex Tag Manager

• Choose Help>About Docuflex Tag Manager to get the version number, 
product type, and copyright date for your current version of Docuflex Tag 
Manager.

To Perform this Action

Navigate the 
helpfile with 
the Table of 
Contents

1. Choose Help>Docuflex Tag Manager Help. Docuflex Tag Manager displays its help 
window.

2. Click the Contents tab in the panel on the left side.

3. Use the mouse to expand the various topics in the table of contents.

4. Select the desired topic and the contents is displayed in the panelon the right.

Access and/
orbrowse a 
comprehensiv
e listing of 
index entries

1. Choose Help>Docuflex Tag Manager Help. Docuflex Tag Manager displays its help 
window.

2. Click the Index tab in the panel on the left side.

3. Type the keyword you want to find, and then choose the closest index entry.

-or-

Browse the list of index entries and select the one you want.

4. Click Display and the contents is displayed in the panel on the right.

Use the help 
Search feature 
to directly 
access a help 
topic

1. Choose Help>Docuflex Tag Manager Help. Docuflex Tag Manager displays its help 
window.

2. Click the Search tab in the panel on the left side.

3. Type a search keyword for which you want help, and then choose List Topics. Related 
help topics display in the lower list box.

4. Choose the help topic you want to view, and then choose Display. Docuflex Tag Manager 
displays help for the topic you chose
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Appendix A

Tagcommander Tips for Operation

TIPS AND TECHNIQUES FOR TAGCOMMANDER

Normalization and Fonts

Documaker can only merge data into forms containing tags with converted fonts. It 
is extremely important to choose fonts for tags that have been converted for use with 
Printcommander. You should ensure that normalization has been enabled in 
Printcommander before starting the tagging process.

When you enable the normalization feature in the Metacode version of

Printcommander, Tagcommander only reports those fonts listed in the common

Fonts section of the ISI.INI file. Enabling normalization ensures that Tagcommander 
selects fonts from the common font list which Printcommander accesses.

Working With Frames

Most word processing Document Packages place any inserted objects, bit maps, or

other non-text items in frames. You can then use the built-in options to control

whether text near the frame wraps around the frame.

BPSD tag objects are usually inserted in frames. You should not adjust the frame size 
to fit the replacement characters, however: a better strategy is to adjust the tag within 
the frame. When a block tag is inserted into a document, most applications tend to 
insert the frame above the current cursor position. To adjust the tag within the frame, 
you can experiment with the Extra Leading feature (see Extra Leading on page 30.) 
After you've inserted tags, you can verify whether your word processor has applied 
any scaling percentages to the tags. In Word for Windows, for example, you can do 
so by choosing Format>Picture. The tag shouldn't be scaled (e.g., it should indicate 
100% width by 100% height), so that the proper size font is selected for the BPSD 
tag.

SAMPLE TAGCOMMANDER AND DOCUFLEX TAG 

Note If you fail to enable Normalization, Printcommander does not create an index packet;
therefore, your tags aren't recognized as such and no merging can take place with

Documaker.
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MACROS

Overview

Tagcommander includes sample Microsoft Word macros you can use to speed up the 
tag insertion process. Normally, you insert a tag object by selecting Insert>Object 
followed by the desired Tag object (e.g., BPSD Tag_W32, DGSD Tag, or Docuflex 
Tag). The supplied macros offer a single-step process for inserting tags to a 
Microsoft Word document.

Sample Macros

You’ll receive a total of six sample macros—three each for Tagcommander and

Docuflex Tag Manager:

Configuring Microsoft Word

The following paragraphs provide directions on how to enable Microsoft Word to

use the sample macros. Please note that these instructions are based on Word2002

and may not accurately describe the locations of menu items or folders on your

system Also, your company may have policies in place that determine how Word 
macros are installed on your system; if so, please refer to them before using these 
macros.

Macro Purpose

TCMenu.dot

TCDFXMenu.d
ot

These templates create a new menu item under the File menu in Word. Select the
menu item to insert a tag.
• TCMenu generates the caption Tagcommander Insert. When you select it, 
Word
inserts a Tagcommander BPSD tag into the document.
• TCDFXMenu generates the caption Docuflex Tag Insert. When you select it, 
Word

inserts a Docuflex tag into the document.

TCToolBar.dot

TCDFXToolBar.
dot

These templates create a “dockable” Toolbar item with the same captions and

behaviors as TCMenu and TCDFXMenu.

TCKeyPress.do
t

TCDFXKeyPre
ss.dot

These templates insert a tag in response to the key combination pressed on the
keyboard.
• TCKeyPress inserts a Tagcommander BPSD tag when you type CTRL+INSERT.
• TCDFXKeyPress responds to the same key combination but inserts a Docuflex

Tag.
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 To Configure Microsoft Word

• Select one of the following methods to install the supplied macros:

To Store a Macro in the Startup Folder

You can copy the supplied macros in the Microsoft Word Startup folder. Then, each

time you start Word, the macro executes the proper command to operate the shortcut 
method you selected (e.g., TCMenu.dot creates a sub menu item labelled 
Tagcommander Insert under the File menu each time that you start Word).

For Windows XP, copy the macro to the following destination: C:\Documents and 
Settings\user_name\Application Data\Microsoft\Word\Startup\

To Add a Macro to the Template

You can add the supplied macros to the global Microsoft Word template. Then, each

time you start Word, the macro executes the proper command to operate the shortcut

method you selected (e.g., TCDFXToolBar.dot displays a Toolbar containing a

button labelled Docuflex Tag Insert).

1. 1. Select Tools>Templates and Add-Ins, then click Add. The Add Template 
dialog box displays.

2. Navigate the dialog to the folder where you installed the macros.

3. Highlight the macro and click OK.

4. The macro is added to the list of checked items and becomes part of your 
Normal.dot template.

To Store a Macro in the Startup Folder

You can copy the supplied macros in the Microsoft Word Startup folder. Then, each

Note Each macro is presented as a “sample” and doesn’t have a Digital Certificate for
authentication; therefore, your macro security setting must be either Medium or Low.
You can access this setting at Tools>Macros>Security. If your setting is Medium, you’ll
need to click ‘Enable Macros’ each time Word starts.

If you want 
to See

Add the macros 
to the Startup 
folder

To Store a Macro in the Startup Folder

Add the macros 
to the global 
template

To Add a Macro to the Template

Customize the

macros

To Customize a Macro
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time you start Word, the macro executes the proper command to operate the shortcut 
method you selected (e.g., TCMenu.dot creates a sub menu item labelled

Tagcommander Insert under the File menu each time that you start Word).

For Windows XP, copy the macro to the following destination:

C:\Documents and Settings\user_name\Application

Data\Microsoft\Word\Startup\

To Add a Macro to the Template

You can add the supplied macros to the global Microsoft Word template. Then, each

time you start Word, the macro executes the proper command to operate the shortcut 
method you selected (e.g., TCDFXToolBar.dot displays a Toolbar containing a 
button labelled Docuflex Tag Insert).

1. Select Tools>Templates and Add-Ins, then click Add. The Add Template
dialog box displays.
2. Navigate the dialog to the folder where you installed the macros.
3. Highlight the macro and click OK.
The macro is added to the list of checked items and becomes part of your 
Normal.dot template.

Recording Macros

With many Windows application, you can create macros to help activate frequent

keystroke and mouse sequences. You may want to create a macro for the Word for

Windows Insert>Object>BPSD Tag sequence. To make them easier to use, some

applications even allow macros to be associated with action buttons on the window.

To Record a Word Macro

1. Choose Tools>Macro...>Record....
2. Enter a name, choose where the macro will be displayed, type a short
description, and press OK.
3. Use the keyboard to choose Insert>Object...>BPSD Tag.
4. For more information about recording and using macros, please see the
Microsoft Word for Windows User's Guide.

Tag File Format

Tagcommander uses tag files which are stored in one of two formats: text (TXT) files 
including tag name, tag width, and tag depth; and Tag Attribute (TGA) files

including tag name, length, depth, and all replacement and formatting information.

The installation disk contains a sample tag file called RSVTAGNM.TXT.

You can easily switch between tag file formats, depending on the amount of detail

you need to store. The TGA file is in a binary file format, which allows

Tagcommander to store the complete formatting data for each tag name. The TXT
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format, on the other hand, only stores the name, width, and length. Of the two

formats, the TXT file is the older one. You can enable this format when accessing

older tag files.

Colors

Changing the “color” for your replacement BPSD tags is a relative issue, depending

on your printer. If you're printing documents on the Xerox 4850 or 4890 printer, for

example, you should be aware that any color except black will be printed in the

highlight color. The highlight color printed depends on the toner color currently

installed in the printer.

The net result is this — no matter which color you choose, you won't receive color

output unless you inform Printcommander of the appropriate action (see your

Printcommander documentation).
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Glossary

AFP Advanced Function Presentation. The ability of IBM-licensed programs to use the 
all-points-addressable concept to print text and illustrations on specialized IBM 
printers. 

application A computer program used for a particular kind of work, such as word processing or 
database management. 

directory Part of an MS-DOS structure for organizing files on disk. A directory can contain 
files and other directories (called subdirectories). 

Docuflex Skywire Software batch processing software that provides document assembly, 
variable data merging, and document finishing for multiple Document Packages.

Dynamic Load Library 
(DLL)

A Microsoft Windows or OS/2 executable code module that is loaded on demand 
and linked at run-time.

Dynamic Runtime 
Library (DRL)

A UNIX executable code module that is loaded on demand and linked at run-time.

operating system Software that controls the execution of programs. An operating system may provide 
services such as resource allocation, scheduling, input/output control, and data 
management. 

page description 
language (PDL)

A programming language that uses special commands to describe how text or an 
image will be printed on a page.

path Within the MS-DOS operating system, the path refers to a listing of the directories 
that lead from the current directory to a file. 

Windows A multitasking graphical user interface environment that runs on MS-DOS-based 
computers. 
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