
User’s Guide
iPlanet Partner Agent for ECXpert Windows Client

Version 1.0 for Windows NT/98/95

806-4605-01
December  2000



Copyright © 2000 Sun Microsystems, Inc. Some preexisting portions Copyright © 2000 Netscape 
Communications Corporation. All rights reserved. 

Sun, Sun Microsystems, the Sun Logo and all other Sun trademarks, service marks, slogans, and 
logos are trademarks or registered trademarks of Sun Microsystems, Inc. in the United States and 
other countries. Netscape and the Netscape N logo are registered trademarks of Netscape 
Communications Corporation in the U.S. and other countries. Other Netscape logos, product 
names, and service names are also trademarks of Netscape Communications Corporation, which 
may be registered in other countries. Other product and brand names are trademarks of their 
respective owners.

Portions of this product are based upon copyrighted materials of Oracle Corporation, Inc. and 
Netscape Communications Corporation, RSA Data Security, Inc. copyright © 1994, 1995 RSA Data 
Security, Inc. Portions copyright © 1996 BMC Software, Inc. All rights reserved. Portions copyright 
© 1996 TSI International, Inc. Portions copyright © 1996-1997 Actuate Software Corporation. All 
rights reserved.

This file drive contains licensed technology from Receipt.com, formerly known as Differential. More 
information on Receipt.com products and services can be found at www.receipt.com. The following 
Third Party Encumbrances have been incorporated into this application: SSLeay SSL toolkit 
received from Eric Young; Perl5 for the sever administration scripts received from Free Software 
Foundation; gzip utility for decompression agent for the server received from Free Software 
Foundation (free and provided upon request); FTP server software received from University of 
California, Berkeley; wu FTP extensions to server software (FileDrive is a derivative work), received 
from University of Washington, Saint Louis; Apache Web server for server admin system received 
from Apache Group; and Apache SSL enhancements received from Ben Laurie.

Federal Acquisitions: Commercial Software -- Government Users Subject to Standard License Terms 
and Conditions. 

The product described in this document is distributed under licenses restricting its use, copying, 
distribution, and decompilation. No part of the product or this document may be reproduced in any 
form by any means without prior written authorization of the Sun-Netscape Alliance and its 
licensors, if any.

THIS DOCUMENTATION IS PROVIDED “AS IS” AND ALL EXPRESS OR IMPLIED 
CONDITIONS, REPRESENTATIONS AND WARRANTIES, INCLUDING ANY IMPLIED 
WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR 
NON-INFRINGEMENT, ARE DISCLAIMED, EXCEPT TO THE EXTENT THAT SUCH 
DISCLAIMERS ARE HELD TO BE LEGALLY INVALID.



3

Contents

About this Book  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  7

Before You Begin . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  8
Downloading Updated Documentation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  8
Suggested Supplementary Reading  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9

The ECXpert Documentation Set  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9
Release Note  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . . . .  10
Getting Started Guide  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  10
User’s Guide  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . . . .  10
Site Administrator’s Handbook . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  11
Developer’s Handbook  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  11
Operations Reference Manual  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  11

Audience and Roles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Organization . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  12
Conventions Used in This Guide  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  12

Actions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  12
Typographic Conventions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13

Chapter 1  Introducing iPlanet Partner Agent for ECXpert Windows Client Software . . . . . . 15
The Partner Agent for ECXpert Client/Server System  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16

Partner Agent Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
Partner Agent Client  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . 17

Partner Agent Client Features and Benefits  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  17

Chapter 2  Installing iPlanet Partner Agent for ECXpert Windows Client Software  . . . . . . . 21
Installing Partner Agent Windows Client  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  22
Setup for Authentication Using VeriSign Class 1 Certificates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  25
Uninstalling Partner Agent Windows Client  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  26



4 iPlanet Partner Agent for ECXpert Windows Client User’s Guide • December  2000

Chapter 3  Using the Client Interface and Screens  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  27
Starting Partner Agent Windows Client  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  28
Exiting Partner Agent Windows Client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  28
User Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  28
Manager Screen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  29

Manager Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  30
View Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . . .  31
Menu Options  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . .  32

File Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  32
Edit Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . . .  33
View Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . .  33
Help Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  34

Profiles—New Explore Screen  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  34
Profiles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35
Accessing the Profiles - New Explore Screen  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35
Explore Profile  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . .  36
Explore Toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . .  37
Transferring Files From the Explore Screen  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  38

Drag and Drop  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . .  38
Downloading  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . .  38
Uploading  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . . .  39

Adding a Profile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  40
Modifying a Profile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  46
Duplicating a Profile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  46
Deleting a Profile . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  47
Creating a Shortcut  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . .  47
Exiting the Profiles - New Explore Screen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  47

Progress Screen  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . . . .  48
Progress Screen Options . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  48

Preferences Screen  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . .  49
General Preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  51
Transferring Preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  53
Scheduling Preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  55
Security Preferences  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  .  56
Proxy/Firewall Preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  58
Exploring Preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  59

Chapter 4  Transferring Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  61
Submitting Files to ECXpert  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  62

Submitting Files to ECXpert using the File Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  62
Adding Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  64
Removing Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  65
Toggling the Move Feature  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  65



5

Starting a Transfer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . 66
Canceling a Transfer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  66
Scheduling a Transfer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  66
Starting a Transfer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66

Sending Files to Another User . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  66
Sending Files using the Explore Screen  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  67
Sending Files using the File Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  67
Adding Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . . . . . .  70
Removing Files . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70
Toggling the Move Feature . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71
Starting a Transfer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . . 71

Canceling a Transfer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71
Scheduling a Transfer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71
Starting a Transfer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Receiving Files or Folders from ECXpert . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  72
Receiving Files using the Explore Screen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  72
Receiving Files using the Manager Screen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  72

Receiving Files or Folders from Another User  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  76
Receiving Files using the Explore Screen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  76
Receiving Files using the Manager Screen . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  76

Scheduling File Transfers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  79
Setting an Absolute Time  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  80
Repeating Transfers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81
Setting Time Limits  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . 82
Using the Advance Schedule  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  84

Index  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  . . 85



6 iPlanet Partner Agent for ECXpert Windows Client User’s Guide • December  2000



7

About this Book

This handbook documents the conceptual, structural, and operational components 
of the iPlanet Partner Agent for ECXpert Windows Client for Windows NT or 
95/98 . It also provides a description of the functionality and guidelines for 
administering the system.

The following topics are discussed in this section:

• Before You Begin

• The ECXpert Documentation Set

• Audience and Roles

• Organization

• Conventions Used in This Guide
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Before You Begin
This Handbook is written with the assumption that you understand the basics of 
transferring files, the Internet, and the operating system on which you are running 
this software.

Downloading Updated Documentation
We continuously update ECXpert documentation. Follow these steps to:

• Determine whether you have the latest version of any ECXpert document

• Download a copy of any ECXpert document

1. Obtain a user ID and password for ProductTracker by SubscribNet.

If you do not know where to start, display the ProductTracker by SubscribNet 
home page at the URL below:

http://home.netscape.com/support/producttracker/index.html

The information provided on this page should let you determine the contact 
person at your company who can provide you with the user ID and password. 
If that person is you, and you have not received this information, call the 
iPlanet Customer Support phone number that is provided.

2. Display the ProductTracker by SubscribNet web page.

The URL is...
http://subscribnet.netscape.com/

3. Enter your Subscribnet user ID and password.

The main Subscribnet page is displayed.

4. Click the link in “Click here to access your software.”

An index of the Netscape and iPlanet software registered for your user ID is 
displayed.

5. Click the “iPlanet ECXpert” link.

A page is displayed that asks you to select the version and platform. 

NOTE In these instructions, the environment variable $NSBASE is the 
full path to the Netscape ECXpert installation directory.
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6. Locate the link for your version, platform, and domestic vs. export 
combination.

First locate Version 1.0, and then find Solaris, for Export or Domestic 
(US/CAN) sale, as appropriate.

7. Click the link you have located.

A list of all the downloads available for ECXpert 1.0 for Solaris, including 
documentation, is displayed.

8. Locate the title in the ECXpert document set that you want.

9. Compare dates.

Compare the date for that title with the date in the footers in your copy of the 
same document.

If these dates are the same, you already have the latest version of the 
documentation.

10. If your documentation is outdated, click the download link.

If the date in the footers of the documentation you have is earlier than the date 
for the same document on the screen, you should download the updated 
version.

Suggested Supplementary Reading
The following documents may be helpful as supplements to this handbook:

• The iPlanet Partner Agent for ECXpert Server Ad ministrator’s Hand book , for 
information about administering the Partner Agent Server

• For ECXpert technical support, always visit the iPlanet Online Support website 
at http://www.iplanet.com/support/online

• Your operating system manuals, particularly any pertaining to system security

The ECXpert Documentation Set
You may wish to refer to other ECXpert books for additional information. This 
section discusses each book in the ECXpert documentation set.
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Release Note
After you receive the ECXpert 3.5 software, before you do anything else, you 
should download the ECXpert 3.5 Release Note . See the ECXpert Getting Started  
Guide (for the operating system that applies to you) for instructions on 
downloading the latest release note.

The Release Note contains:

• A list of bugs fixed in the current release

• A list of all documentation corrections

• Warnings and workarounds for known problems

• Additional important information you should know before you install or use 
ECXpert

The Release Note  is platform-specific, so make sure you have the right version for 
the platform you’re using.

Getting Started Guide
The ECXpert Getting Started  Guide  is the book you use to install ECXpert. It 
includes preinstallation tasks—including basic instructions for installing or 
upgrading to the required version of Oracle—ECXpert installation steps, and 
information on additional tasks you may wish to perform after you install 
ECXpert. The Getting Started  Guide  is platform-specific, so make sure you have 
the right version for the platform you’re using.

Administrator’s Handbook
The ECXpert Administrator’s Handbook  is written for the ECXpert System’s 
administrator. This book provides an overview of the ECXpert system and uses 
specific examples, or “scenarios,” to illustrate the different ways in which ECXpert 
can be used most effectively in a wide variety of different business situations. It 
also covers the ECXpert Server Administrative Interface in depth, discusses the 
ECXpert command line utilities, and explains how to integrate ECXpert with SAP 
and MQSeries.
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Developer’s Handbook
The ECXpert Developer Handbook  book is written for C++ developers who want 
to customize ECXpert. It primarily documents the ECXpert APIs which give C++ 
applications full access to the database. This includes detailed documentation of 
each class, each method in each class, and code examples. It also documents the 
complete database schema.

Operations Reference Manual
If you ever have difficulty using ECXpert, the ECXpert Operations Reference 
Manual more than likely documents a quick resolution. This book contains basic 
troubleshooting guidelines for ECXpert, other Netscape products, and third-party 
products. It also includes a complete error message reference.

Audience and Roles
This handbook is written for Partner Agent Windows Client users. All 
documentation needed by Partner Agent’s administrator is supplied in the iPlanet 
Partner Agent for ECXpert Server Ad ministrator’s Handbook .
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Organization
This handbook is structured as follows:

Chapter 1: Introducing iPlanet Partner Agent for ECXpert Windows Client 
Software

This chapter introduces the iPlanet Partner Agent for ECXpert family of 
applications and describes the major features and concepts of the Partner Agent.

Chapter 2: Installing iPlanet Partner Agent for ECXpert Windows Client So ftware

This chapter describes how to install and uninstall Partner Agent.

Chapter 3: Using the Client Interface and  Screens

This chapter describes the interface and controls and how to access the various 
screens.

Chapter 4: Transferring Files

This chapter explains how to transfer files and folders with Partner Agent Client, 
including how to schedule transfers.

Index

The index lists important terms and page numbers where information about those 
terms appears in the text.

Conventions Used in This Guide

Actions
Clicking the right mouse button is called right-clicking. A menu that appears when 
you right click is called the right mouse menu. Instructions for selecting an item 
from the right-mouse menu are documented like this:

• Right-click on the Partner Agent icon in the Windows system tray. This is 
usually in the lower right corner of your screen

• From the right-mouse menu, select Manager.
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Menus and sub-menus are represented with the side carat, (>). Where appropriate, 
menu items are underlined and capitalized as they appear on the screen. For 
example, to start Partner Agent you click on the Start menu and select the 
Programs sub-menu, and from that sub-menu you select the PartnerAgent 
sub-menu, and from that sub-menu select PartnerAgent. This is documented like 
this:

From the Start menu select Programs > PartnerAgent > PartnerAgent.

Typographic Conventions
A number of typographic conventions are used throughout this manual to help 
you recognize special terms and instructions. These conventions are summarized 
in the table below.

Convention Meaning Example

numbered 
steps

higher level descriptions of 
tasks you perform (more 
detailed instructions follow)

1. Enter the group information.

Enter the name in the Group Name field, and a short 
description in the Description field.

italics key words, such as terms that 
are defined in the text

The notices posted on an electronic BBS are called 
articles.

names of books For more information, refer to the ECXpert Getting 
Started  Guide .

variables

In command syntax, items in 
italics are not literals.

usrlogin=login

You must substitute valid values for italicized items.

courier font file names The associated data is stored in the Dispatcher section of 
the bdg.ini file.

text file content (HTML 
templates, config files)

<TITLE>Password Check</TITLE>
<IMG SRC="/ui/icons/hd_svcs.gif">

code samples and command 
line output

Syntax const char* getName() const

courier bold command line input, to be 
entered by the user

Enter the following command:

ls *.mle

# or fdx> command line prompt fdx>sslmode tun
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square 
brackets, [...] 

In command syntax, items 
within square brackets are 
optional.

In the following example:

nsusrgrp [-v] insert [-l] -k key arguments -r 
act=relation action, usrid=ID|usrlogin=login

-v and -l are optional.

You may specify either usrid  or usrlogin.

You must substitute valid values for italicized items.

vertical line 
(|)

In command syntax, items on 
either side are valid 
alternatives.

em dash 
(—)

“none” or “nothing” Arguments —

Convention Meaning Example
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Chapter 1

Introducing iPlanet Partner Agent for
ECXpert Windows Client Software

This chapter gives some background on the iPlanet Partner Agent for ECXpert 
client/server system and the features of the Partner Agent Windows Client in 
particular.

The following topics are discussed in this section:

• The Partner Agent for ECXpert Client/Server System

• Partner Agent Client Features and Benefits
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The Partner Agent for ECXpert Client/Server 
System

Partner Agent for ECXpert is a client/server solution for secure file transfer and 
automated document processing. Partner Agent products work with the ECXpert 
system to provide high performance file transfer capabilities as well as state of the 
art security, reliability, and automation. Partner Agent is fully compatible with FTP 
and HTTP(S) standards.

Partner Agent is made up of the Partner Agent Server and the Partner Agent 
Client. Partner Agent Server is integrated with ECXpert, turning ECXpert into a 
secure file transfer site.  Partner Agent Client runs as a stand-alone application that 
turns your PC into a powerful, secure, and reliable download and upload manager 
for exchanging files with ECXpert, as well as with other machines.

Partner Agent allows Client users to exchange files directly with ECXpert. Partner 
Agent uses the ECXpert submit utility to upload files from the Client to ECXpert, 
where they are processed further as required. It uses the ECXpert poll utility to 
retrieve files downloaded from ECXpert; these files can be viewed and processed 
using the Client.

Partner Agent is scalable, making it an ideal building block for industrial-strength 
extranet applications.

Partner Agent Server
Partner Agent for ECXpert Server is a customized, pre-configured system that 
allows you to turn ECXpert into a secure file transfer site.

In addition to integrating state-of-the-art security standards, such as Secure Socket 
Layer (SSL) and digital certificates (X.509), Partner Agent contains a sophisticated 
access control system as well as EnGuard™ security auditing software that 
automatically warns of potential security issues.

Partner Agent also guarantees Extranet data delivery and data integrity while 
protecting corporate bandwidth.

Partner Agent’s functionality is extended through a plug-in architecture that uses 
ActiveAgents. ActiveAgents are transactional software agents that call ECXpert 
APIs to initiate events based on file transfers and to also feed information into 
back-end applications, such as databases, enterprise scheduling software, and 
network printing operations. ActiveAgents also make it easy to add third-party 
functionality to Partner Agent, such as virus scanning, file format conversion, or 
additional security mechanisms as required.



Partner Agent Client Features and Benefits

Chapter 1 Introducing iPlanet Partner Agent for ECXpert Windows Client Software 17

Partner Agent Server comes with a browser-based administration system, which 
can optionally be used to reconfigure the Server in special circumstances; it is not 
needed in most cases since the Server is already preconfigured for optimal, secure 
performance with ECXpert. It also comes with a secure command line client, which 
can optionally be used for testing the system.

Partner Agent Client
Partner Agent Client software for Windows 98/95 and NT provides 
high-performance, reliable, and secure file transfer of critical business documents 
between your Windows desktop and ECXpert or other machines—over your 
intranet, business extranet, or the Internet.

You can also use a standard browser as a client for file transfers to non-ECXpert 
machines.

Partner Agent Client Features and Benefits
The Partner Agent Windows Client has all of the standard features of regular FTP 
and more. The Windows Client offers the following additional features to a typical 
file transfer:

• Partner Agent provides unparalleled reliability when transferring large files 
(100Mb - 4Gb) over unreliable network connections, dial-up connections, 
overloaded servers, or the Internet. You can restart a file transfer if the 
connection is interrupted or the transfer is terminated for some reason.

• FTP file transfers to ECXpert.

• FTP, HTTP, or HTTPS file transfers to non-ECXpert machines.

• SSL. 

• Security through encryption of all communications. 

• Supports X.509 certificates for authentication of client and server identities. 

• Supports Tunnel Mode, which is a firewall-friendly mode that allows you to 
connect securely through a firewall or proxy server.

• MD5 checksums of local and remote files.

• Supports mirrored server locations.



Partner Agent Client Features and Benefits

18 iPlanet Partner Agent for ECXpert Windows Client User’s Guid e• December  2000

• Provides highly reliable, high performance, and secure transfer of large files 
over the Internet or private network when accessing a Partner Agent Server. 

• Client-side APIs allow the output of the server-side ActiveAgents, such as the 
ECXpert tracking ID of submitted and retrieved files, to be displayed in the 
user interface.

Table  1-1 Partner Agent Client features and benefits

Features Benefits

Supercharged File Transfer

• Secure and reliable downloading and uploading 
of very large files.

• Adds high performance file transfer capabilities 
to your Web browser.

• Secure server.

• Complete system customability and tensibility 
through ActiveAgents APIs.

• Compatible with FTP and HTTP protocols.

• Allows customers to design, deploy, and access a 
new generation of network-accessible business 
services, online software distribution systems, 
digital rights management systems and 
business-to-business commerce.

Rapid Resume

• Automatically restarts transfers if network 
connection fails.

• Restart transfers from where the last transfer left 
off.

• Allows you to pause and resume file transfers.

• Schedules file uploads and downloads for 
unattended transfer in one time or recurring 
fashions.

• Automatically rolls-over to alternate Partner 
Agent mirrored servers.

• Keeps a log of file tranfers.

• Reliable high-performance transfer of large 
documents over unreliable network connections. 

• Provides guaranteed “Fed-like” delivery of any 
number or size of files (documents, graphics, 
software, etc.), along with flexibility on 
scheduling automatic file uploads and 
downloads.

• Automatically accesses alternate mirrored 
Partner Agent servers in case of a failed 
connection.



Partner Agent Client Features and Benefits

Chapter 1 Introducing iPlanet Partner Agent for ECXpert Windows Client Software 19

Built-In Full System Security

• Secure Sockets Layer (SSL) encryption, client and 
server.

• Support for X.509 digital certificates.

• Name and password support.

• Partner Agent server has extensive security 
features.

• Provides a range of security options for ensuring 
that files, IDs and passwords are transferred 
securely.

• Partner Agent Server provides a complete suite 
of access controls and security monitoring 
systems to ensure server security.

ActiveAgents

• Client and server-side Application Programming 
Interfaces (API).

• Automatically generate content processing based 
on client file requests.

• Automatic post-processing of transferred files.

• Allows the functionality of Partner Agent to be 
easily extended by defining processes that take 
place on files coming or going from the client or 
server. (For example, automatically send notices 
on database changes, virus scan incoming data 
before accepted, serial number stamping, 
preload a file into a database).

Easy to use

• Drag-and-drop interface.

• Client runs as a standalone application and as a 
Netscape Navigator protocol handler.

• Makes the process of transferring files easy and 
intuitive.

• Seamlessly supercharges the file transfer 
functionality of your Netscape Navigator 
browser.

Cross-Platform

• Windows 98/95/NT Client.

• UNIX command-line client.

• Netscape Navigator support (versions 2.0 and 
up).

• Microsoft Internet Explorer 4.0.

• Microsoft Internet Explorer 3.0 via 
drag-and-drop links from your browser to 
Partner Agent.

Note: Internet Explorer has a bug that prevents third 
parties from directly enhancing its file transfer 
capabilities. Microsoft has fixed this bug for Internet 
Explorer 4.0.

• Allows customers to deploy Partner Agent on 
the industry-leading hardware and software 
platforms across the organization.

Table  1-1 Partner Agent Client features and benefits (Continued)

Features Benefits
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Based on Industry Standards

• TCP/IP

• FTP

• HTTP

• SSL

• HTML

• Allows seamless integration of Partner Agent 
into your intranet or Extranet.

Table  1-1 Partner Agent Client features and benefits (Continued)

Features Benefits
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Chapter 2

Installing iPlanet Partner Agent for
ECXpert Windows Client Software

This chapter describes how to install and uninstall Partner Agent Windows Client.

The following topics are discussed in this section:

• Installing Partner Agent Windows Client

• Setup for Authentication Using VeriSign Class 1 Certificates

• Uninstalling Partner Agent Windows Client
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Installing Partner Agent Windows Client
Follow the steps below to install the Partner Agent for ECXpert Win32 Client on 
any Windows NT/98/95 machine.

1. Log on as administrator to a Windows NT/98/95 machine.

2. Download the Partner Agent Client installation file.

a. Display the iPlanet Downloads web page.

The URL is
http://iplanet.com/downloads/testdrive/index.html

An index of the iPlanet software available for download is displayed.

b. Locate the Partner Agent for ECXpert Windows Client link and click it.

A page is displayed that asks you to select the version and platform.

c. Locate the version and platform available for download—for either 
Domestic or Export customers, as appropriate—and click the download 
link.

3. If you are not previously registered for iPlanet downloads, fill out the 
registration form.

4. Accept the license agreement.

The file will be downloaded to your machine.

5. Open the directory in which the Partner Agent Windows Client was 
downloaded and double-click on the Install icon.
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6. Click Next to begin the installation.

Figure  2-1 Partner Agent Installer Step One

7. Click Accept to accept the end user license agreement.

Figure  2-2 Partner Agent Installer Step Two
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8. Select the destination directory.

The Partner Agent for ECXpert client is installed immediately below the 
directory specified here.

a. Click Browse if you want to select a different destination directory. Make 
sure that the directory you want appears in the destination directory box 
before you continue.

b. Click Next to continue.

Figure  2-3 Partner Agent Installer Step Three

As you begin copying files to the new installation directories, a window similar 
to that in Figure 2-4 will appear.

Figure  2-4 Partner Agent Installer Step Four

9. Restart your machine after installation is complete.
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Setup for Authentication Using VeriSign Class 1 
Certificates

To allow the Partner Agent Client to authenticate itself to the Partner Agent Server 
using a VeriSign Class 1 certificate, follow these steps: 

1. Log on as administrator to the Windows Client machine.

1. Open a Command Prompt window.

2. Convert your private key from pkcs12 format to pem format.

Enter the following command to use the pkcs12 utility packaged with Partner 
Agent: 

<client_d irectory>\pkcs12 -in <certfilename> -nocerts -out 
<certfilename>-key.pem

where <client_d irectory> is the directory in which the Partner Agent Client 
application is installed.

3. Convert your certificate from pkcs12 format to pem format.

Enter the following command to use the pkcs12 utility packaged with Partner 
Agent: 

<client_d irectory>\pkcs12 -in <certfilename> -clcerts -nokeys -out 
<certfilename>-crt.pem

where <client_d irectory> is the directory in which the Partner Agent Client 
application is installed.

4. Specify the certificate and public key in the Client preferences.

a. Open the Manager interface, Edit, Preferences/Security tab.

b. Specify the Certificate File by entering a path or using the Browse button to 
select a file.

c. Specify the Key File by entering a path or using the Browse button to select 
a file.

d. Click OK.
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Uninstalling Partner Agent Windows Client
Once Partner Agent Client has been installed, you can uninstall it. If you installed 
Partner Agent Client in the default directory:

• From the Start menu, select Programs > PartnerAgent > Uninstall 
PartnerAgent.

Partner Agent Client is uninstalled.

NOTE If you installed Partner Agent in any other folders, substitute the 
appropriate folders.
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Chapter 3

Using the Client Interface and
Screens

This chapter describes how to start Partner Agent Windows Client. It also 
describes the interface and controls and how to access the various screens.

The following topics are discussed in this section:

• Starting Partner Agent Windows Client

• Exiting Partner Agent Windows Client

• User Interface

• Manager Screen

• Profiles—New Explore Screen

• Progress Screen

• Preferences Screen
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Starting Partner Agent Windows Client
To start the Client, use the Start Menu.

If you installed Partner Agent Client in the default directory:

• From the Start menu select Programs > PartnerAgent > PartnerAgent.

A small icon will be displayed in the system tray of the Windows task bar, usually 
in the lower right corner of your screen (Figure 3-1).

Figure  3-1 Partner Agent icon in Windows system tray

Exiting Partner Agent Windows Client
To exit the Client:

• Right-mouse click on the Partner Agent icon in the Windows system tray.

• From the right-mouse menu, select Exit.

User Interface
The controls for Partner Agent Client are accessed through the buttons and menus 
in several different graphical user interface (GUI) screens. They are the Explore, 
Progress, Manager, and Preferences screens.

NOTE If you have the preference set to launch Partner Agent at startup, 
Partner Agent may be running.

NOTE If you installed Partner Agent in any other folders, substitute the 
appropriate folders.



Manager Screen

Chapter 3 Using the Client Interface and Screens 29

Manager Screen
The main screen for accessing the Client controls is the Manager screen. To access 
the Manager screen:

• Double-click on the Partner Agent icon in the lower right-hand corner of the 
screen.

OR

• Right-mouse click on the Partner Agent icon.

• From the right-mouse menu, select Manager.

The Manager screen displays (Figure 3-2), and a Partner Agent button appears in 
the Windows task bar at the bottom of the screen.

Figure  3-2 Manager screen
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Manager Toolbar
The Partner Agent Manager toolbar, at the top of the Manager screen, has nine 
buttons to simplify sending and receiving files. Refer to Figure 3-3 to identify each 
button with its name and function.

Figure  3-3 Manager screen toolbar

1. Transfer Now—Starts transfer of any selected entries.

2. Schedule—Opens a window so you can set a specific time for a transfer to 
occur.

3. Change Destination—Opens a Save As window so you can set the download 
directory for the selected entries and, if desired, change the name.

4. Information—Opens the transfer log screen for the selected items.

5. Remove—Deletes any selected files from the transfer list.

6. Explore—Opens the Profiles - New Explore screen to allow you to search for 
files or to create profiles.

7. Progress—Displays the Progress screen, which gives you the status of any files 
being transferred.

8. Preferences—Displays the Preferences screen to configure Partner Agent for 
your environment and other preferred settings.

9. Quick Help—Launches the online help system for Partner Agent Client.
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View Options
The Manager displays one of eight different views, depending on what is selected 
in the first drop-down list. Use the drop-down list to select one of these options:

• Files to Receive—The Manager displays a list of files that are being received or 
scheduled to be received from a machine other than ECXpert.

To display a list of files that are being received or scheduled to be received 
from ECXpert, use the Files to Be Received from ECXpert option.

• Files to Send—The Manager displays a list of files that are being sent or 
scheduled to be sent to a machine other than ECXpert.

To display a list of files that are being sent or scheduled to be sent to  ECXpert, 
use the Files to Submit to ECXpert option.

• Files Received—The Manager displays a list of files that have been received 
from a machine other than ECXpert.

To display a list of files that have been received from ECXpert, use the Files 
Received from ECXpert option.

• Files Sent—The Manager displays a list of files that have been sent to a 
machine other than ECXpert.

To display a list of files that have been sent to  ECXpert, use the Files Submitted 
to ECXpert option.

• Files to Submit to ECXpert—The Manager displays a list of files that are being 
sent or scheduled to be sent to ECXpert.

To display a list of files that are being sent or scheduled to be sent to a machine 
other than ECXpert, use the Files to Send option.

• Files Submitted to ECXpert—The Manager displays a list of files that have been 
sent to ECXpert.

To display a list of files that have been sent to a machine other than ECXpert, 
use the Files Sent option.

• Files to Be Received from ECXpert—The Manager displays a list of files that 
are being received or scheduled to be received from ECXpert.

To display a list of files that are being received or scheduled to be received 
from a machine other than ECXpert, use the Files to Receive option.
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• Files Received from ECXPert—The Manager displays a list of files that have 
been received from ECXpert.

To display a list of files that have been received from a machine other than 
ECXpert, use the Files Received option.

Menu Options
The following options are available from the menus in the Manager screen.

File Menu
The following options are available in the File menu of the Manager screen.

• Explore—Opens an Explore Profiles window which allows you to add, modify, 
and delete user profiles for file transfers.

• Open URL—Opens a window in which you can enter a fully qualified “http,” 
“ftp,” “gxp,” “ftpu,” or “gxpu” URL. For example, to send files, type: 

ftpu://user:password@host/pathname 

A Send Files window displays for you to select the files to send.

To explore a site, enter a pathname that ends in a forward slash (/). An Explore 
screen displays.

• Send Files—Opens a window in which you can enter the address of a server 
other than ECXpert (such as ftp .YourCompany.com  or 205.115.164.123), the 
port number (for FTP the default is 21), the user name (leave blank for 
anonymous), the password (leave blank for anonymous), and the path name 
on the server to send the files. This window is similar to entering an “ftpu” 
link.

• Receive Files—Opens a window in which you can enter the address of a server 
other than ECXpert (such as ftp .YourCompany.com  or 205.115.164.123), the 
port number (for FTP the default is 21), the user name (leave blank for 
anonymous), the password (leave blank for anonymous), and the path name 
on the server to send the files. This window is similar to entering an “ftpu” 
link.
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• Submit Files to ECXpert—Opens a window in which you can enter the 
ECXpert host address (such as ftp .YourCompany.com  or 205.115.164.123) and 
port number (for FTP the default is 21), the login name and password, the 
sender name and password (must be a valid ECXpert member), the receiver 
name (must be a valid ECXpert member name), and the ECXpert document 
type. You can also schedule file submissions to ECXpert.

• Receive Files from ECXpert—Opens a window in which you can enter the 
ECXpert host address (such as ftp .YourCompany.com  or 205.115.164.123) and 
port number (for FTP the default is 21), the login name and password, the 
sender name (must be a valid ECXpert member name), the receiver name 
(must be a valid ECXpert member name), the ECXpert document type, the file 
prefix, and the download path. You can also set up the Windows machine to 
receive files from ECXpert according to a schedule.

• Transfer Now—Starts the transfer of any selected entries.

• Schedule—Opens a window so you can set a specific time for a transfer to 
occur.

• Change Destination—Opens a Save As window so you can set the download 
directory for the selected entries and, if desired, change the name.

• Information—Opens the transfer log screen for the selected items.

• Remove—Deletes any selected files from the transfer list.

• Close—Closes the Manager screen.

• Exit—Exits the Partner Agent client.

Edit Menu
The Edit menu of the Manager screen contains the standard Windows controls for 
Undo, Cut, Copy, Paste, Select All, and Invert Selection. You can also access the 
Preferences screen.

To access the preferences screen from the Edit menu, select Edit > Preferences. For 
more information about setting preferences, refer to “Preferences Screen,” on page 
50.

View Menu
The following options are available in the View menu of the Manager screen.

• Toolbar—Toggles the display of the Manager toolbar.

• Status Bar—Toggles the display of the Status bar at the bottom of the screen.
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• Progress Window—Displays the Progress screen

• Files to Receive—Displays a list of files that are being received or scheduled to 
be received from a machine other than ECXpert.

• Files to Send—Displays a list of files that are being sent or scheduled to be sent 
to a machine other than ECXpert.

• Files Received—Displays a list of files that have been received from a machine 
other than ECXpert.

• Files Sent—Displays a list of files that have been sent to a machine other than 
ECXpert.

• Files to Submit to ECXpert—Displays a list of files that are being sent or 
scheduled to be sent to ECXpert.

• Files Submitted to ECXpert—Displays a list of files that have been sent to 
ECXpert.

• Files to Receive from ECXpert—Displays a list of files that are being received 
or scheduled to be received from ECXpert.

• Files Received from ECXpert—Displays a list of files that have been received 
from ECXpert.

Help Menu
The following options are available in the Help menu of the Manager screen.

• Quick Help—Launches the online help for Partner Agent Client in a browser 
window.

• About iPlanet Partner Agent—Displays information about Partner Agent, 
including the version number.

To open a browser window displaying the iPlanet web site, click About 
iPlanet.

NOTE The name of the list of files currently displayed (e.g., Files 
Received from ECXpert) appears under the top menu bar.

Each of the Files options in the View menu can also be selected 
by clicking the Expand  button under the top menu bar and 
selecting the option from the drop-down list that appears.
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Profiles—New Explore Screen
Use the Profiles - New Explore screen to create, modify, copy, or delete connection 
profiles or to explore a location to find files to transfer. You can explore any local 
drive or any remote site that has a profile. You can also use this screen to create a 
desktop shortcut to a profile.

Profiles
A profile is stored information about a connection. This makes it easy to connect to 
commonly used servers without having to retype information. Profiles can be 
selected when you send or receive files, but they must be created in the Profiles - 
New Explore screen.

Accessing the Profiles - New Explore Screen
To access the Profiles - New Explore screen:

• Right-mouse click on the Partner Agent icon in the Windows system tray.

• From the right-mouse menu, select Explore.

OR

• From the Manager screen, select File > Explore.

OR

• Click the Explore button in the toolbar.

The Profiles - New Explore screen displays (Figure 3-4).
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Figure  3-4 Profiles - New Explore screen
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Explore Profile
To Explore a connection profile or local drive:

1. Select a drive or profile to explore from the window of the Profiles - New 
Explore screen.

2. Click Explore.

An Explore screen displays (Figure 3-5).

Figure  3-5 Explore screen for a selected drive or profile

If you selected a connection profile, Partner Agent attempts to connect and 
display the contents of the directory specified in the profile.

If you selected a local drive or folder, the Explore screen displays the contents 
of the drive or folder.

3. Click on folders to explore further.
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Explore Toolbar
The Explore toolbar, at the top of the Explore screen, has sixteen buttons. Refer to 
Figure 3-6 to identify each button with its name and function.

Figure  3-6 Explore screen toolbar

1. Up one level—Changes the current view up one folder or directory level.

2. New Explore—Opens a new Explore screen.

3. Explore From Here—Opens a new Explore screen with the current folder as 
the starting point.

4. Refresh—Refreshes the current view.

5. Download To—Opens a Download To window, which downloads the selected 
file to a location that you specify in the window.

6. Download—Downloads the selected file to the default location.

7. Upload—Opens an Upload screen to select a file. The file is uploaded to the 
location that is selected in the Explore screen.

8. Copy—Copies the selection to the clipboard.

9. Paste—Pastes the clipboard contents.

10. Delete—Deletes the selected file or folder.

11. Properties—Displays properties of files and folders. 

12. Large Icons—Shows large icons.

13. Small Icons—Shows small icons.

14. List—Shows a list of files and folders.

15. Details—Shows details of files and folders.

16. Manager—Switches to the Manger screen.
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Transferring Files From the Explore Screen
You can transfer files several ways from the Explore screen. You can use buttons in 
the toolbar, you can use the right-mouse menu, or you can drag and drop.

Drag and Drop
You can drag and drop files to and from the Explore screen. You can do this to 
upload or download files or folders.

You can drag and drop to between the Explore screen:

• The desktop.

• The Manager screen.

• Another Explore screen.

• A Microsoft Explorer window.

Downloading
Other ways to download a file, from the Explore screen:

1. Explore to locate a file and if necessary click once on the file to select it.

2. Use the right-mouse menu to select download or download to.

OR

Click the download button, (the down-pointing arrow), in the Explore toolbar.

If you select download, Partner Agent attempts to download the selected file. If 
you select download to, the Download To screen displays.

NOTE You can download files from ECXpert using the Explore screen 
only when the ECXpert partnership for the specific 
Sender/Receiver/Document Type uses the FTP protocol and a 
service that deposits incoming documents into your ECXpert 
mailbox.

If incoming documents are not stored in your ECXpert mailbox, 
you will not be able to retrieve them using the Explore screen.
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Figure  3-7 Download To screen

3. Use the Drives drop-down list to locate the drive to which to download the file.

4. Use the Folders drop-down list to locate the desired folder.

5. If desired, click Network to locate a drive on your network.

6. Click Cancel to abort the download.

7. Click OK to start the download.

Partner Agent downloads the selected file.

Uploading
Other ways to upload a file to a non-ECXpert machine from the Explore screen:

1. Explore to locate the directory or folder into which you want to upload a file.

2. Select upload from the right-mouse menu.

OR

Click the upload button—the up-pointing arrow—in the Explore toolbar.
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Figure  3-8 An Upload screen displays.Upload screen

3. Use the Look in drop-down list to locate the file to be uploaded.

4. Click on the file to select it.

The file name displays in the File name field.

5. Click Open to start the upload.

The file is uploaded.

Adding a Profile
To create a connection profile, in the Profiles - New Explore screen:

1. Click Add.

An Explore Profile screen displays.

The Explore Profile screen contains six pages: one for each connection type. 
The connection types are ECXFTP Submit, ECXFTP Receive, FTP, HTTP, 
HTTPS, and Local Computer. The FTP, HTTP and HTTPS pages are identical 
except that the FTP page contains an option to login as an anonymous user.

NOTE You cannot upload files to ECXpert using the Explore screen.

To upload files to ECXpert, see “Submitting Files to ECXpert,” 
on page 62.
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2. Select the appropriate Tab for the connection type.

3. Enter information in the following fields:

For ECXFTP Submit pro files:

Figure  3-9 Explore Profile screen, ECXFTP Submit tab

m Host Address—Enter the address of the ECXpert host.

m Port—Enter the ECXpert host port. The default port—1027—is already 
entered, but you can enter any desired value.

m Login—Enter the sender’s login name.

m Password—Enter the sender’s password for connect.

m Sender Name—Enter the sender’s ECXpert membership ID.
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m Sender Password—Enter the sender’s ECXpert password.

m Receiver Name—Enter the receiver’s ECXpert membership ID.

m Document Type—Enter the ECXpert document type.

m Profile Name—Enter a Profile name. This field automatically displays 
information you enter into the Host Address and Login fields, but you can 
enter any desired name.

For ECXFTP Receive profiles:

Figure  3-10 Explore Profile screen, ECXFTP Receive tab

m Host Address—Enter the address of the ECXpert host.

m Port—Enter the ECXpert host port. The default port—1027—is already 
entered, but you can enter any desired value.
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m Login—Enter the receiver’s login name.

m Password—Enter the receiver’s password for connect.

m Sender Name—Enter the sender’s ECXpert membership ID.

m Receiver Name—Enter the receiver’s ECXpert membership ID.

m Document Type—Enter the ECXpert document type.

m File Prefix—Enter an optional prefix to be added to the names of incoming 
files.

m Download Path—This field displays any current default download path. 
Enter a path or use the Browse button to select where you want to 
download files.

m Profile Name—Enter a Profile name. This field automatically displays 
information you enter into the Host Address and Login fields, but you can 
enter any desired name.
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For FTP, HTTP, and  HTTPS pro files:

Figure  3-11 Explore Profile screen, FTP tab

m Host Address—Enter the address of the host to which you will connect.

m Port—Enter a port. The default ports are already entered, but you can enter 
any desired value.

m Login—Enter your login name (if not anonymous).

m Anonymous—For anonymous logins (FTP only), select this check box.

NOTE When this box is checked, the Login and Password fields fill 
in automatically.
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m Password—Enter your password for connect.

m Startup Path—Enter the startup path on the server you are exploring.

m Download Path—This field displays any current default download path. 
Enter a path or use the Browse button to select where you want to 
download files.

m Cache data between sessions—Select this option to have Partner Agent 
cache data between sessions.

m Profile Name—Enter a Profile name. This field automatically displays 
information you enter into the Host Address and Login fields, but you can 
enter any desired name.

For Local Computer pro files:

Figure  3-12 Explore Profile screen, Local Computer tab
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m Path—Enter the desired local path, use the  button to select a local 
path or select the all drives option below.

m All drives on local machine—Select this option to include all drives.

m Profile Name—Enter a Profile name. This field automatically displays any 
information entered in the Path field, but you can enter any desired name.

4. Click OK.

The Profile name is displayed in the list of profiles in the Profiles - New 
Explore screen.

Modifying a Profile
To modify a connection profile:

1. Select a profile from the list of profiles in the Profiles - New Explore screen.

2. Click Modify.

3. Make the desired changes.

4. Click OK.

The profile is modified.

Duplicating a Profile
To copy a connection profile:

1. Select a profile from the list of profiles in the Profiles - New Explore screen.

2. Click Duplicate.

A copy of the profile is created in the list of profiles in the Profiles - New 
Explore screen. A suffix is added that includes the copy number, for example 
the first copy of the profile New Profile is called New Profile-1.

NOTE If you have not entered all the required information for a new 
profile, the OK button is disabled.
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Deleting a Profile
To delete a connection profile:

1. Select a profile from the list of profiles in the Profiles - New Explore screen.

2. Click Delete.

The profile is removed in the list of profiles in the Profiles - New Explore 
screen.

Creating a Shortcut
To create a shortcut to a connection profile:

1. Select a profile from the list of profiles in the Profiles - New Explore screen.

2. Click Shortcut.

A shortcut to the selected profile is added to your desktop.

Exiting the Profiles - New Explore Screen
To exit the screen:

• Click Close.

OR

• Click the X in the upper right-hand corner of the screen.
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Progress Screen
The Progress screen shows the status of any files that are waiting to be transferred 
and the progress of files that are transferring. If a file is being transferred, you can 
pause it from this screen.

To access the Progress screen:

• Right-mouse click on the Partner Agent icon in the Windows system tray.

• From the right-mouse menu, select Progress.

OR

• From the Manager screen, select View > Progress window.

The Progress screen displays (Figure 3-13), and a Partner Agent button appears 
in the Windows task bar at the bottom of the screen.

Figure  3-13 Progress screen

Progress Screen Options
The following options are available when a file is transferring.

• To pause a transfer, click Pause.

• To cancel a transfer, click Cancel.

• To access the Manager screen, click Manager.

If no file is transferring, the Pause and Cancel buttons are disabled.
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Preferences Screen
Preferences allow you to create your own business and security standards for using 
Partner Agent. The Preference screen is where you set your preferences.

To access the Preferences screen:

• Right-mouse click on the Partner Agent icon in the Windows system tray.

• From the right-mouse menu, select Preferences.

OR

• From the Manager screen, select Edit > Preferences.

The Preferences screen displays.

Figure  3-14 Preferences screen, initial tab
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Preference settings are contained on six pages within the Preferences screen. Each 
page has a tab at the top with its name. The pages are:

• General

• Transferring

• Scheduling

• Security

• Proxy/Firewall

• Explore

To d isplay a page:

• Click the appropriate tab at the top of the Preferences screen. 

To set preferences:

1. Use the tabs to switch pages.

2. Select any desired options.

3. Click Apply.

To cancel any changes you have made:

• Click Cancel.

To d isplay the Help  file:

• Click Help.
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General Preferences

Figure  3-15 Preferences screen, General tab

The following options are available on the General page:

• Identification: Email address—Enter your email address. It is used as your 
password when you log in as an anonymous user.

• Prompt: Before deleting queued items—If this option is selected, you are 
prompted when you try to delete items that are waiting to be transferred.

• Navigator Integration: Intercept Navigator links—This option is disabled.
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• Startup: Launch Partner Agent at system startup—Select one of the radio 
buttons to determine if you want the Partner Agent Client to start 
automatically at System Startup. Select Never, Only when items are pending, 
or Always.

• Use PASV mode—If this option is selected, the Server provides the address 
and port for the Client to connect to when transferring. If this option is not 
checked, the Client is in PORT mode and provides the address and port for the 
Server to connect to when transferring.

• Share connection between Explorer and Manager—If this option is selected, 
the Client is limited to one connection with the Server. If this option is not 
selected, you can transfer a file while exploring; a new connection is made to 
the Server so you can continue exploring while the transfer occurs.

NOTE This option is required if your Server is set up to only allow one 
connection per login.

The advantage of using this option (if it is not required) is that 
transfers occur more quickly since the overhead of re-login is 
eliminated. The disadvantage is that you can not explore while 
performing a transfer.



Preferences Screen

54 iPlanet Partner Agent for ECXpert Windows Client User’s Guid e• December  2000

Transferring Preferences

Figure  3-16 Preferences screen, Transferring tab

The following options are available on the Transferring page:

• Default Download Location—Use the radio buttons to select whether you want 
the Client to ask for file location when saving files or to automatically save files 
in a specified directory. If you choose to have Partner Agent ask for a location, 
you are prompted each time you download a file. If you choose to 
automatically save, enter the path name or use the Browse button to locate the 
desired folder.
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• Transfer Mode—Use the radio buttons to select the transfer mode. Select to 
transfer files using binary or text mode, or to perform text mode transfers for 
files ending with specific suffixes. If you select the last option, enter the file 
suffixes, (for example .html or .txt), separated by commas, in the field below. 
Files of types not specified are transferred in binary mode.

• Download files—Use the radio buttons to select whether to overwrite files on 
your system that have the same name as files that are downloading or to create 
new unique names for the downloading files.

• Expand compressed files after downloading—Select this option to have the 
Client decompress compressed files after download.

• Compress upload files using—Select this option to have the Client compress 
files that you are sending. If you select this option, use the drop-down menu to 
select a compression application.

• Launch installer programs automatically—Select this option to have the Client 
start installer programs that you download.

NOTE We recommend using WinZipTM with Partner Agent Client.
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Scheduling Preferences

Figure  3-17 Preferences screen, Scheduling tab

The following options are available on the Scheduling page:

• Connection—Enter the number of times you want to retry a failed connection 
in the Retry transferring file field. Enter the number of minutes to wait between 
retries in the Delay between retry field.

• Enable Dial-up Networking—Select this option to use a dial-up account. If you 
select this option, use the drop-down menu to select from your phone list 
entries, which have been set up through your control panel. For Windows 95 
and 98, your password must be specified in the dial-up login window.
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• Schedule—Select this option to have the Schedule screen open before any 
transfer occurs.

Security Preferences

Figure  3-18 Preferences screen, Security tab
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The following options are available on the Security page:

• Enable Security— Select this option to have the Client negotiate to use the 
Server’s security system upon connection. Use the checkboxes below to set the 
desired level of security.

• Use only secure connections— Select this option to require encrypted (SSL) 
connections.

• Always use firewall-friendly secure connections (tunnel mode)—Select this 
option to require the Client to connect in tunnel mode.

• Prompt user when not recognizing the authority of a certificate— Select this 
option to have the Client warn you if a server certificate is from an unknown 
source.

m Do not accept certificates with unrecognized authorities— Select this 
option to require server certificates from known sources to be present in 
your certificate file.

• Certificate file— Enter the pathname for a user’s certificate file or use the 
Browse button to locate a certificate file.

• Key file— Enter the pathname for a user’s key file or use the Browse button to 
locate a key file.

• Import authority certificate to storage—Click this button to locate and 
manually import a server’s certificate to the Windows Client machine.

NOTE If this option is selected, files will still transfer without security 
if the Server has no security, unless you select the Use only 
secure connections option.
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Proxy/Firewall Preferences

Figure  3-19 Preferences screen, Proxy/Firewall tab

The following options are available on the Proxy/Firewall page:

• Connect through a proxy server or a firewall—Select this option to configure 
the Client to connect to other local network computers through a proxy server 
or through a firewall.

• Proxy Settings—Enter the Proxy address for the type of proxy you are 
using—FTP, HTTP, or SOCKS—in the appropriate fields or, to import the 
settings from your default browser, click the Import button.

For FTP, HTTP, or SOCKS servers that require a user name and password, click 
User and enter your user name and password.
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• Proxy Exceptions—Enter any addresses for which you do not want to use a 
Proxy Server. Use commas to separate multiple entries. Wildcards can be used 
in this field.

• FTP Firewall Type—For FTP firewalls, select the firewall type from the 
drop-down menu.

Exploring Preferences

Figure  3-20 Preferences screen, Explorer tab
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The following options are available on the Explorer page:

• Show Explore Profiles upon startup— Select this option to have the Client 
show the Explore profiles. For more on profiles, see Profiles on page 35.

• Automatically refresh current view—Select this option to have the Client 
automatically refresh the current directory view, and enter the number of 
minutes after which it should refresh. The Client connects to the current Server 
and updates the view periodically based on the number of minutes entered in 
the minutes field.

• Cached Files—Enter a time period for the cache data to expire. To manually 
clear the cache, click the Clear All Cached Files button. This section also lists 
the current number of cached files, the amount of disk space used and the path 
of the cache.

• Show any available message for current folder—Select this option to have the 
Client display messages for a selected folder on the Explore screen.

• Show greeting when first connected to a site—Select this option to have the 
Client display a greeting acknowledging your first connection to a site.
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Chapter 4

Transferring Files

This chapter describes different ways to transfer files and folders with Partner 
Agent Client. This chapter also describes how to schedule transfers.

Transferring files or folders can be sending or receiving, (downloading or 
uploading). Scheduling of transfers is done to optimize resources and for regularly 
occurring transfers.

The following topics are discussed in this section:

• Submitting Files to ECXpert

• Sending Files to Another User

• Receiving Files or Folders from ECXpert

• Receiving Files or Folders from Another User

• Scheduling File Transfers
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Submitting Files to ECXpert
Use Partner Agent Windows Client to send, i.e., upload, files or groups of files 
from your machine or network to ECXpert over the Internet, quickly and securely. 
To send files, use the File menu from the Manager screen or the Explore screen.

Submitting Files to ECXpert using the File Menu
To send a file to ECXpert from the Manager screen:

1. From the menu, select File > Submit Files to ECXpert.

A Submit Files to ECXpert window displays (Figure 4-1).

Figure  4-1 Submit Files to ECXpert screen

2. If desired, select a submission profile from the Submission Profiles drop-down 
list.

NOTE To send files to  another user, see “Submitting Files to 
ECXpert,” on page 62.
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The URL Settings display the information from the selected profile.

3. Enter information in the URL Settings section of the window.

If you are using a profile and do not want to modify any of the settings, skip 
this step.

a. The Partner Agent Windows Client supports one protocol: ECXFTP. You 
cannot modify this setting.

b. In the Address field, enter the address of the ECXpert server.

You may specify the exact IP address of the server using the standard dot 
format, for example 205.164.115.160.

c. Enter the port on which the ECXpert server is listening for a connection in 
the Port field.

d. Enter your user name in the User field or select the Anonymous checkbox.

If the Anonymous checkbox is selected, this field is not editable and the 
word anonymous is displayed.

e. Enter your password in the Password field.

If you selected the Anonymous checkbox, enter your user and domain 
name, for example alien@wigglytreats.org.

f. In the Sender Name field, enter your ECXpert member ID.

g. In the Sender Password field, enter your ECXpert member password.

h. In the Receiver Name field, enter the ID of the ECXpert member to whom 
you are submitting a file.

i. In the Document Type field, enter the ECXpert document type.

The entire URL for where the file is being sent is displayed next to the word 
URL.

4. If you want to abort the transfer, click Cancel.

5. To start the transfer, click OK.

After you click OK, the Send File(s) window displays, where you select the files 
or folders to transfer (Figure 4-2).

NOTE If you change any of the fields, the profile name is not displayed 
in the Connection Profiles field.
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Figure  4-2 Send File(s) screen

Adding Files
To select a file to transfer to ECXpert:

1. Click Add Files.

An Open window displays.

2. Browse to locate a file in the Open window.

3. Double-click on the file, to add it to the list of files to send.

The file is added to the list of files to Send (Figure 4-3).
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Figure  4-3 Send File(s) screen with a file selected for transfer

Removing Files
1. Select a file from the list of files to send to ECXpert.

2. Click Remove (Figure 4-3).

Toggling the Move Feature
To have the original file deleted after you upload it, enable the Move feature. When 
move is enabled, the word yes is displayed in the list of files to send, in the Move 
column.

To toggle the move feature:

1. Select a File or folder.

2. Click Toggle Move (Figure 4-3).

The move column displays yes or no, depending on what was previously 
selected.
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Starting a Transfer
To transfer the file, either start the transfer or schedule it for another time.

Canceling a Transfer
To cancel the transfer:

1. Select a File or folder.

2. Click Cancel (Figure 4-3).

Scheduling a Transfer
To schedule the upload for a different time:

1. Select a File or folder.

2. Click Schedule (Figure 4-3).

For more information about setting up transfer schedules, see “Scheduling File 
Transfers,” on page 79.

Starting a Transfer
To start the transfer:

1. Select a File or folder.

2. Click Send (Figure 4-3).

The Client attempts to transfer any files for immediate transfer or queues any 
files that are scheduled for later.

Sending Files to Another User
Use Partner Agent Windows Client to send, i.e., upload, files or groups of files 
from your machine or network to another user over the Internet, quickly and 
securely. To send files, use the File menu from the Manager screen or the Explore 
screen.

NOTE To send files to  ECXpert, see “Submitting Files to ECXpert,” on 
page 62.
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Sending Files using the Explore Screen
For instructions on how to send or upload files to a non-ECXpert machine from the 
Explore screen, see “Transferring Files From the Explore Screen,” on page 39.

Sending Files using the File Menu
To send a file from the Manager screen:

1. From the menu, select File > Send Files.

A Send Files window displays (Figure 4-4).

Figure  4-4 Send Files screen

2. If desired, select a connection profile from the Connection Profiles drop-down 
list.

The URL Settings display the information from the selected profile.

NOTE If you change any of the fields, the profile name is not displayed 
in the Connection Profiles field.
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3. Enter information in the URL Settings section of the window.

If you are using a profile and do not want to modify any of the settings, skip 
this step.

a. Use the Protocol list to select a transfer protocol: FTP, HTTP, or HTTPS.

b. In the Address field, enter the address of the server to which you would 
like to send files.

You may specify the exact IP address of the server using the standard dot 
format, for example 205.164.115.160.

c. Enter the port on which the server is listening for a connection in the Port 
field.

d. Enter your user name in the User field or select the Anonymous checkbox.

If the Anonymous checkbox is selected, this field is not editable and the 
word anonymous is displayed.

e. Enter your password in the Password field.

If you selected the Anonymous checkbox, enter your user and domain 
name, for example alien@wigglytreats.org.

f. Enter the path to where you want the file uploaded in the Path field.

The path is the name of the directory to which you want to upload files. 

If you specify a directory in the Send Files window, the path may be left 
empty to specify the root path. On Windows 95 and NT, in DOS and in 
other programs, the “\” character is used in the file paths. Do not use the 
“\” character in the path field to delimit path names. The FTP standard is 
“/”.

Some examples of path names are as follows:

m / home/ joe/

NOTE Keep in mind your transfer protocol. 

NOTE The path names consist of a list of directories or folders 
separated by the “/” character. Path names are generally 
case-sensitive.
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m / pub/ test/ samples

m / incoming

When specifying path names, remember that all path names are absolute 
path names, from the root directory of the server. A path name that starts 
with “/” is not relative to the login directory. Because this window is a 
form-based way to specify a URL, and the URL standard does not allow for 
relative path names from the login directory, relative path names are not 
supported.

The entire URL for where the file is being sent is displayed next to the word 
URL.

4. If you want to abort the transfer, click Cancel.

5. To start the transfer, click OK.

After you click OK, the Send File(s) window displays where you select the files 
or folders to transfer (Figure 4-5).

Figure  4-5 Send File(s) screen
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Adding Files
To select a file to transfer:

1. Click Add Files.

An Open window displays.

2. Browse to locate a file in the Open window.

3. Double-click on the file, to add it to the list of files to send.

The file is added to the list of files to Send (Figure 4-6).

Figure  4-6 Send File(s) screen with a file selected for transfer

Removing Files
1. Select a file from the list of files to send.

2. Click Remove in the Manager Toolbar (Figure 4-6).
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Toggling the Move Feature
To have the original file deleted after you upload it, enable the Move feature. When 
move is enabled, the word yes is displayed in the list of files to send, in the Move 
column.

To toggle the move feature:

1. Select a File or folder.

2. Click Toggle Move (Figure 4-6).

The move column displays yes or no, depending on what was previously 
selected.

Starting a Transfer
To transfer the file, either start the transfer or schedule it for another time.

Canceling a Transfer
To cancel the transfer:

1. Select a File or folder.

2. Click Cancel (Figure 4-3).

Scheduling a Transfer
To schedule the upload for a different time:

1. Select a File or folder.

2. Click Schedule (Figure 4-3).

For more information about setting up transfer schedules, see “Scheduling File 
Transfers,” on page 79.

Starting a Transfer
To start the transfer:

1. Select a File or folder.

2. Click Send (Figure 4-3).

The Client attempts to transfer any files for immediate transfer or queues any 
files that are scheduled for later.
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Receiving Files or Folders from ECXpert
To receive files or folders from ECXpert, use the File menu from the Manager 
screen or the Explore screen.

Receiving Files using the Explore Screen
For instructions on how to receive or download files from the Explore screen, see 
“Transferring Files From the Explore Screen,” on page 39.

Receiving Files using the Manager Screen
To receive, i.e., download, a file, from ECXpert using the Manager screen:

1. From the menu, select File > Receive Files from ECXpert.

A Receive Files window from ECXpert displays.

NOTE To receive files or folder from another user, see “Receiving Files 
or Folders from ECXpert,” on page 72.

NOTE You can download files from ECXpert using the Explore screen 
only when the ECXpert partnership for the specific 
Sender/Receiver/Document Type uses the FTP protocol and a 
service that deposits incoming documents into your ECXpert 
mailbox.

If incoming documents are not stored in your ECXpert mailbox, 
you will not be able to retrieve them using the Explore screen.
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Figure  4-7 Receive Files from ECXpert screen

2. If desired, select a connection profile from the Connection Profiles drop-down 
list.

The URL Settings display the information from the selected profile.

3. Enter information in the URL Settings section of the window.

If you are using a profile and do not want to modify any of the settings, skip 
this step.

a. The Partner Agent Windows Client supports one protocol: ECXFTP. You 
cannot modify this setting.

NOTE If you change any of the fields, the profile name is not displayed in 
the Connection Profiles field.
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b. In the Address field, enter the address of the ECXpert server.

You may specify the exact IP address of the server using the standard dot 
format, for example 205.164.115.160.

c. Enter the port on which the ECXpert server is listening for a connection in 
the Port field.

d. Enter your login name in the User field or select the Anonymous checkbox.

If the Anonymous checkbox is selected, this field is not editable and the 
word anonymous is displayed.

e. Enter your password in the Password field. 

If you selected the Anonymous checkbox, enter your user and domain 
name, for example Imyoung@heart.org.

f. In the Sender Name field, enter the ID of the ECXpert member who is 
sending you a file.

g. In the Receiver Name field, enter your ECXpert member ID.

h. In the Document Type field, enter the ECXpert document type you will 
receive.

i. In the File Prefix field, enter any alphanumeric text that you want to be 
prepended to the file name when it is received.

NOTE Keep in mind your transfer protocol. 

NOTE  If multiple files with the same sender, receiver, and 
document type are available in the ECXpert system for 
retrieval, Partner Agent Client can retrieve only one of them 
at a time.

To retrieve more than one file with the same sender, 
receiver, and document type, schedule downloads at 
regular intervals (“Repeating Transfers,” on page 81). 
ECXpert will mark each file as it is downloaded, until all of 
the files have all been retrieved.
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j. Enter the path from where the file is to be downloaded, in the Host Path 
field.

The path is the name of the directory where the file or files are located. 
Separate multiple entries with Returns, (not commas).

If you specify a directory in the Receive Files window, the path may be left 
empty to specify the root path. On Windows 95 and NT, in DOS and in 
other programs, the “\” character is used in the file paths. Do not use the 
“\” character in the path field to delimit path names. The FTP standard is 
“/”.

Some examples of path names are as follows:

m /home/joe/ 

m /pub/test/ 

m /incoming 

When specifying path names, remember that all path names are absolute 
path names, from the root directory of the server. A path name that starts 
with “/” is not relative to the login directory. Because this window is a 
form-based way to specify a URL, and the URL standard does not allow for 
relative path names from the login directory, relative path names are not 
supported.

k. To schedule the download, click Schedule (see “Scheduling File Transfers,” 
on page 79).

The entire URL for any files being downloaded is displayed next to the word 
URL.

4. If you want to abort the transfer, click Cancel.

5. To start the transfer, click OK.

After you click OK, Partner Agent attempts to download any files for 
immediate transfer or queues up any files for scheduled downloading.

NOTE The path name consists of a list of directories or folders 
separated by the “/” character. Path names are generally 
case-sensitive.



Receiving Files or Folders from Another User

76 iPlanet Partner Agent for ECXpert Windows Client User’s Guid e• December  2000

Receiving Files or Folders from Another User
To receive files or folders from a server over the Internet, use the File menu from 
the Manager screen or the Explore screen.

Receiving Files using the Explore Screen
For instructions on how to receive or download files from the Explore screen, see 
“Transferring Files From the Explore Screen,” on page 39.

Receiving Files using the Manager Screen
To receive (i.e., download) a file, from the Manager screen:

1. From the menu, select File > Receive Files.

A Receive Files window displays.

Figure  4-8 Receive Files screen

NOTE To receive files or folder from ECXpert, see “Receiving Files or 
Folders from ECXpert,” on page 72.
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2. If desired, select a connection profile from the Connection Profiles drop-down 
list.

The URL Settings display the information from the selected profile.

3. Enter information in the URL Settings section of the window.

If you are using a profile and do not want to modify any of the settings, skip 
this step.

a. Use the Protocol drop-down list to select a transfer protocol: FTP, HTTP or 
HTTPS.

b. In the Address field, enter the address of the server from which you would 
like to download the file or files.

You may specify the exact IP address of the server using the standard dot 
format, for example 205.164.115.160.

c. Enter the port on which the server is listening for a connection in the Port 
field.

d. Enter your user name in the User field or select the Anonymous checkbox.

If the Anonymous checkbox is selected, this field is not editable and the 
word anonymous is displayed.

e. Enter your password in the Password field. 

If you selected the Anonymous checkbox, enter your user and domain 
name, for example Imyoung@heart.org.

NOTE If you change any of the fields, the profile name is not 
displayed in the Connection Profiles field.

NOTE Keep in mind your transfer protocol. 
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f. Enter the path from where the file is to be downloaded, in the Host Path 
field.

The path is the name of the directory where the file or files are located. 
Separate multiple entries with Returns, (not commas).

If you specify a directory in the Receive Files window, the path may be left 
empty to specify the root path. On Windows 95 and NT, in DOS and in 
other programs, the “\” character is used in the file paths. Do not use the 
“\” character in the path field to delimit path names. The FTP standard is 
“/”.

Some examples of path names are as follows:

m /home/joe/ 

m /pub/test/ 

m /incoming 

When specifying path names, remember that all path names are absolute 
path names, from the root directory of the server. A path name that starts 
with “/” is not relative to the login directory. Because this window is a 
form-based way to specify a URL, and the URL standard does not allow for 
relative path names from the login directory, relative path names are not 
supported.

g. Enter the name of any files you want to download, in the File(s) field.

h. To delete the file from the server after you download it, select the Move 
checkbox. 

i. To schedule the download, click Schedule (see “Scheduling File Transfers,” 
on page 79).

The entire URL for any files being downloaded is displayed next to the word 
URL.

NOTE The path name consists of a list of directories or folders 
separated by the “/” character. Path names are generally 
case-sensitive.
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4. If you want to abort the transfer, click Cancel.

5. To start the transfer, click OK.

After you click OK, Partner Agent attempts to download any files for 
immediate transfer or queues up any files for scheduled downloading.

Scheduling File Transfers
Partner Agent has a schedule feature that allows you to choose when and how 
often you want to transfer files. This is especially useful if you are moving large 
files or folders and want to perform the transfer at the end of the business day 
when the server is not as busy.

To schedule any transfer:

• When you set up a file transfer, click on .

A Schedule window displays (Schedule screen, Absolute tab).

Figure  4-9 Schedule screen, Absolute tab
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In the scheduling window, you have the following choices for scheduling file 
transfers:

• Absolute

• Repeat 

• Limit

You can also schedule multiple transfers for the same file or folder with the 
Advance Feature (see “Using the Advance Schedule,” on page 84).

Setting an Absolute Time
An absolute transfer is a one-time transfer for which you set the day and time. To 
set an absolute transfer:

1. Click on the Date drop-down list. 

A calendar appears. 

2. Click on the date you want to transfer the file.

Use the left and right pointing arrows to display a different month.

3. To select the time you want the transfer to occur, click the arrow keys next to 
the Time field.

To adjust hours, minutes or AM/PM, click on the hours, minutes or AM/PM 
and then click the arrows to adjust the desired time.

4. To schedule multiple transfers, click Advance.

5. To schedule the transfer, click OK.

6. To abort the scheduling —not the transfer—click Cancel.

7. To transfer the file immediately rather than according to a schedule, click Now.

You will return to the Send File(s) screen, from which you can send or cancel 
the file transfer.
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Repeating Transfers
The Repeat feature allows you to set a transfer to occur on a periodic basis from a 
specific starting date and time. Set the period to be a number of minutes, hours, or 
days.

To use the Repeat schedule feature:

1. Click on the Repeat tab, in the Schedule window.

The Repeat page displays.

Figure  4-10 Schedule screen, Repeat tab

2. Click on the Start Date drop-down list, to select the start date. 

A calendar appears.

3. Click on the date you want to transfer the file. 

Use the left and right pointing arrows to display a different month.
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4. To select the time for the first transfer to occur, click the arrow keys next to the 
Start Time field.

To adjust hours, minutes or AM/PM, click on the hours, minutes or AM/PM 
and then click the arrows to adjust to the desired time.

5. Enter the repeat number in the Repeat every field.

6. Use the drop-down list to select the period: either days, hours, or minutes.

7. To schedule multiple transfers, click Advance.

8. To schedule the transfer, click OK.

9. To abort the scheduling —not the transfer—click Cancel.

10. To transfer the file immediately rather than according to a schedule, click Now.

You will return to the Send File(s) screen, from which you can send or cancel 
the file transfer.

Setting Time Limits
The Limits feature lets you choose specific values such as the year, month, day, 
hour, minute.

To use the Limit schedule feature:

1. Click on the Limit tab, in the Schedule window.

The Limit page displays.
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Figure  4-11 Schedule screen, Limit tab

2. Use the checkboxes to choose parameters to limit the transfer.

When you select a checkbox, use its arrows or drop-down list to select the 
desired values.

The Description box describes the limit you have selected.

3. To schedule multiple transfers, click Advance.

4. To schedule the transfer, click OK.

5. To abort the scheduling —not the transfer—click Cancel.

6. To transfer the file immediately rather than according to a schedule, click Now.

You will return to the Send File(s) screen, from which you can send or cancel 
the file transfer.
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Using the Advance Schedule
Use the Advance feature to schedule multiple transfers for the same file. To use the 
Advance feature:

1. At the bottom of the schedule window, click Advance.

The Advance window displays. Any scheduling that has been set up is 
displayed in the Scheduled Event List.

Figure  4-12 Schedule screen, Advance Schedule option

2. Click Add to add a scheduled event.

A schedule window displays.

3. Schedule a transfer, according to the instructions in “Setting an Absolute 
Time,” on page 80, “Repeating Transfers,” on page 81, or “Setting Time 
Limits,” on page 82.

4. Click OK.

The Advance Schedule window displays with the new entry in the Scheduled 
Event List.

5. To change a selected entry, click Edit.

6. To remove an entry from the Scheduled Event List, click Delete.

7. Click OK when you are done.

8. To abort the scheduling of the transfer, click Cancel.
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