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Introduction to the Host Agent
The Host Agent reports configuration information as well as file system, physical volume, 
and logical volume information for industry-leading server platforms, including Windows, 
Solaris, IBM AIX, HP-UX, Novell, and Linux platforms.

Note: With the acquisition of StorageTek, Sun Microsystems has re-branded and re-
named Global Storage Manager (GSM) as Sun StorageTek Analytics, a member of the 
Enterprise Storage Manager portfolio of software solutions. The functionality of Business 
Analytics is identical to GSM, only the name has changed.

Sun StorageTek Business Analytics provides three agent installation CDs for the 
supported platforms: Windows Local Manager, Solaris Local Manager, UNIX Agents (HP-
UX and IBM AIX). To upgrade the Host Agent, uninstall the previously installed Host 
Agent before you install the Sun StorageTek Business Analytics 5.0 Host Agent. The 
decision to upgrade an existing Host Agent to the current Sun StorageTek Business 
Analytics Host Agent may be performed because:

• The Sun StorageTek Business Analytics Release Notes indicate a problem has been 
fixed or a new feature added.

• The upgrade is recommended by your Sun representative.

The following notes apply to installing and configuring the Host Agent:

• Refer to the Sun StorageTek Business Analytics Support Matrix located on the 
Documentation CD to confirm the latest agent support requirements.

• Specify the optional configurable parameter, CONFIG CACHE REFRESH 
INTERVAL, which controls the duration for refreshing cached information. The 
default value is 7200 seconds.

• Specify the optional parameter, HOST SLEEP TIME, which is used to specify the 
interval for checking whether the HBA adapter is online. The default value is 600 
seconds.

• Specify the location of the EMC PowerPath software executable program, if installed. 
This configuration setting is required to enable the host end-to-end mapping feature.

• May be installed by using the Central Manager or Local Manager Installation CD or by 
using the Sun StorageTek Business Analytics Host and SRM Agent Self-Extracting 
Install CD (Windows).

• Some installation types, such as Self Extracting Host Installation and Standalone 
Host Installation, do not support agent auto registration.

• Is installed and started automatically when the Typical installation option for the 
Central Manager is selected.

• Non-Solaris UNIX installs use the .tgz (gzipped tar) file and the install script 
(<Agentname>-install.sh).

Solaris Installation
Effective with Sun StorageTek Business Analytics Release 5.1, all Solaris installation 
packages contain the prefix, SUNWbizan, within their package names. These names 
appear in the informational status text that is displayed when you install or uninstall a 
Business Analytics agent. 

The Solaris Agent Installation CD provides an installation script (setup). The installation 
script (setup) can be used to:
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• View a list of the available agents, depending on the server platform, that you can 
choose to install or upgrade.

• Perform agent upgrade for existing agent packages.
• Uninstall (setup –u) a previously installed agent package.

The installation script will validate that you have logged in as root, which is the required 
user permission to perform an agent installation. It also validates that the system is 
running a supported Operating System for an agent that you select for installation or 
upgrading.

Automatic and Static Agent Registration
Automatic agent registration is a configuration option for agent data collection. In the 
storability.ini file, automatic agent registration is configured as follows:

• Local Manager – Specify the IP address or host name of the Local Manager to be 
contacted to activate agent registration. 

• Local Manager Registration Port – Specifies the TCP port number used by the 
Local Manager for agent auto registration. The default port number is 17146.

• Enable Auto Registration – Turns agent auto registration on (default) or off.

To register the Host Agent statically, proceed as follows:
• Enter false in the Enable Auto Registration field. 
• Modify the Routing Agent static agent configuration to include an entry (port 

number|<agent IP address/name>) 
• Restart the Routing Agent
• Restart the companion Central Manager agents

Host Agent Matrix
The Host Agent matrix follows.

Item Description

HBAs The Sun StorageTek Business Analytics Host Agent supports any 
HBA that implements the standard Common (formerly SNIA) HBA 
API.

Operating Systems
Windows • InstallShield and Self-Extracting Agent Install supported

• Silent Installation supported for both InstallShield and Self-
Extracting Agent Install

• Required Server Access: Administrator privileges
• Default Cache Interval: 120 minutes

Solaris • Solaris package install
• Required Server Access: root access
• Default Cache Interval: 120 minutes

AIX • “Tar/install.sh” installation
• Required Server Access: root access
• Default Cache Interval: 240 minutes

HP-UX • “Tar/install.sh” installation
• Required Server Access: root access
• Default Cache Interval: 240 minutes
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Suse Linux • “Tar/install.sh” installation
• Required Server Access: root access
• Default Cache Interval: 120 minutes

Red Hat Linux • “Tar/install.sh” installation
• Required Server Access: root access
• Default Cache Interval: 120 minutes

Novell NetWare • Novell NetWare Network Loadable Module (NLM) installation

Note: The Host Agent for Novell NetWare does not collect certain 
information that is collected by the Host Agent installed on other 
platforms, including Host Bus Adapter (HBA) information.

Configuration 
Parameters

• Local Manager – Specifies the IP address or host name of the 
Local Manager to be contacted for agent auto registration. The 
default value is local host (meaning the Host Agent contacts 
the Routing Agent on its server for agent auto registration).

• Local Manager Registration Port – Specifies the TCP port 
number used by the Local Manager for auto registration. The 
default port number is 17146 for agent auto registration.

• Config. Cache Interval – Specifies how long configuration 
data is cached; default value is 600 seconds. The minimum 
cache age for the Host Agent is six hundred (600) seconds on 
Win32, Solaris and Linux servers. On IBM AIX and HP-UX 
servers, it is thirty (30) minutes.

• Enable Auto Registration – Turns agent auto registration on 
(default) or off.

• EMC PowerPath File Location for End-to-End Mapping – 
Specifies the fully qualified path to the EMC PowerPath binary, 
if installed. 

Table 1 - Host Agent Matrix

Host Agent Objects
The following table describes the relational objects that the Host Agent publishes. You 
can use the Agent Diagnostic Tool (gsmdiag.exe) to collect any and all of these objects. 
See also the Verifying Host Agent section. 

Object Description

alerts-3_1 ip_address, port, when, application, severity, id, 
description, timestamp

gsa_agent_version-2_0 ip_address, port, agent_name, version, compile_time, 
managed_entities, tz_name, tz, timestamp

gsa_cache_control-2_0 ip_address, port, table_name, cache_age, 
last_update_request_length, update_request_pending, 
group_name, group_master, timestamp

gsa_hba_config ip_address, nodename, host_id, api_version,vendor, 
model, serial_number, port_num, driver_version, 
wwnn, wwpn, firmware_version, port_fcid, port_type, 
effective_speed, max_speed, link_status, fabric_wwn, 
ctrl_instance, ctrl_num, hardware_path, timestamp
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gsa_host_config ip_address, nodename, host_id, osname, vendorname, 
model, version_number, release_level, numcpus, 
memory, timestamp.
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Object Description

gsa_host_filesystem-2_3 ip_address, nodename, host_id, device, filesystem 
name, filesystem_type, blocksize, total_blocks, blocks_ 
used, blocks_ available, total_files, files_used, 
files_available, filesystem _id lvm, 
logical_device_group, logical_device_ name, 
timestamp.

gsa_host_interfaces ip_address, nodename, host_id, interface_name, mac_ 
address, interface_ip, interface ip_name, subnet mask, 
default_gateway, interface_status, timestamp.

gsa_host_netshares ip_address, nodename, host_id, share_name, share_ 
type, share_path, filesystem name, options, 
timestamp.

gsa_ini_control-2_0 ip_address, port, domain, parameter, value, status, 
timestamp

gsa_logical_volume_config-
2_1

ip_address, nodename, host_id, lvm, logical_device_ 
group, logical_device_name, type, device_layout, 
capacity, blocksize, logical_device-status, timestamp.

gsa_logical_volume_relation ip_address, nodename, host_id, lvm, logical_device_ 
group, logical_device_name, uses_lvm, 
uses_logical_device_group, uses_ logical_device name, 
timestamp.

gsa_parm_info ip_address, port, object, parm_name, value_syntax, 
description, required

gsa_physicalvolume_config ip_address, nodename, host_id, physical_device name, 
vendor, product, serialnum, volume_id, array_ id, 
physical_device_status, timestamp.

gsa_physical_volume_path-
2_1

ip_address, nodename, host_id,, physical_device 
_name, path_device_name, ctrl_instance, ctrl_number, 
channel, target, LUN, array_wwpn, array_port_id, 
path_status, path_ software_name, 
path_software_version, timestamp.

Table 2 - Host Agent Objects

Windows Local Manager Installation CD - 
InstallShield
1. Insert the Windows Local Manager CD into the CD-ROM drive.

2. Click Next on the Welcome menu to continue the installation.

3. Click Yes to accept the terms of the software license agreement.

4. Click Next.

5. Review/modify the informational User Name and Company Name and click Next.

6. On the screen that allows you to select agents to be installed, select Host Agent 
and click Next.
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7. Review the settings and click Next to continue.

8. Click OK to acknowledge the message regarding the Microsoft Disk Management 
Diagnostic utility. See the Sun StorageTek Business Analytic Support Matrix for 
information on this requirement if you have dynamic disks.

9. If prompted, specify whether (yes/no) to install the new version of the Configuration 
Tool. The Sun StorageTek Business Analytic Release Notes will specify any agent 
whose configuration requires a new release of the Configuration Tool.

10.After the Configuration Tool is automatically launched, click File->Edit->Smart 
Agent Configuration.

11.Click the HostAgent tab in the main window, similar to the Configuration Tool 
window that appears below.

Figure 1 - Configuration Tool Host Agent Tab

12. In the Local Manager field, specify the IP address or host name of the Local 
Manager to be contacted for agent auto registration. The default value is “localhost”. 

13. In the Local Manager Registration Port field, specify the port number hat the 
Local Manager uses for agent auto registration. The default TCP port number is 
17146.

14. In Config. Cache Refresh Interval field, review/modify how long the agent caches 
data. The default value is 6000 seconds.

15.Click Show Advanced Settings.

16.Review/modify the Enable Auto Registration configuration setting that turns auto 
discovery on (true) or off (false). The default value causes the agent to attempt to 
register with the Local Manager at start up. If registration fails, the agent will re-
attempt registration every five minutes. If registration succeeds, the agent will 
“refresh” its registration every twenty-four (24) hours.
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17.Review/modify the EMC powerpath file for End to end mapping setting. If the 
host server has EMC PowerPath software installed, use the Browse icon to locate 
and specify the location of the powermt.exe file.

18.With the “Save Configuration Settings” check box enabled (check mark), click File-
>Save and then confirm saving the storability.ini file.

19. If you have made any configuration changes, select Tools->Restart Service to 
restart the Host Agent.

20.Click File->Exit to close the Configuration Tool.

21.View and then close the Readme file and click Finish.

22. Proceed to the Verifying Host Agent section.

Standalone Installation - InstallShield
1. Insert the Sun StorageTek Business Analytic Local Manager CD into the CD-ROM 

drive. If the InstallShield-based installation program is automatically launched, close 
the program.

2. Open a DOS Command Window.

3. Change directory to Win32\HostAgentSetup.

4. Type setup.exe and press Enter. The Storability Host Agent Welcome screen 
appears.

Figure 2 - Storability Host Agent Welcome Screen

5. Click Next> to continue.

6. Click Yes to accept the terms of the software license agreement.
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7. Review/modify the informational User Name and Company Name and click Next>.

8. Click Next> to accept the default destination folder (i.e., <drive>:\Program 
Files\Storability) or click Browse to select another destination folder. Note that the 
\GSM folder will be created under the destination folder that you specify.

9. Review the settings and click Next> to continue.

10.Read the information concerning the Microsoft Disk Management Diagnostic Utility 
that appears in the Information dialog and click OK to continue. The Installation in 
progress splash screen appears.

11.When the InstallShield Wizard Complete screen appears, click Finish. At this 
point, the Storability Host Agent is installed and running on the Windows server.

12.Use the Configuration Tool on a Windows Local Manager to add the Host Agent as a 
SUB_AGENT entry in the desired Local Manager/Central Manager storability.ini file. 

Figure 3 - Adding Sub Agent Entry Using Configuration Tool

13. Proceed to the Verifying the Host Agent section.

Silent Installation - InstallSheild
A silent installation of the Windows Host Agent enables you to perform multiple 
installations of the Host Agent using the same parameters, which are recorded during a 
reference installation into a setup.iss file. The high-level procedure is summarized as 
follows:

1. Record a reference installation session of the Windows Host Agent into the setup.iss 
file.

2. Execute the Host Agent’s installation using the recorded session on as many Local 
Managers, as needed.
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During a silent installation, the InstallShield installation reads the necessary input from 
the response file that you created.

Proceed as follows: 

1. Copy the contents of HostAgentSetup from the Storability Local Manager and 
Smart Agent CD (d:\Win32\HostAgentSetup) onto the hard drive of the Windows 
Local Manager. 

2. From a command prompt, change to that directory. For example:  
C:\>cd "Program Files\HostAgentSetup" 

3. Run the following command: 

C:\Program Files\HostAgentSetup> setup.exe -r -f1"C:\Program 
Files\HostAgentSetup\setup.iss" 

Notes: 

a. Enter no space after -f1, quotation marks (“”) are required. 
b. The setup command with the above options will create the response file in the 

same directory that contains all the required software to do a remote installation.
c. While creating the response file, you are installing the Host Agent. As a result, 

you do not perform Step 4 below on that machine. 
d. If you press the Back button while you are creating the response file, the 

reference file is not set up correctly. In this case, remove the existing setup.iss 
file and start Step 3 again. 

4. Copy the contents of this directory (e.g., c:\Program Files\HostAgentSetup) with the 
setup.iss to any other Windows Local Managers on which you will install the Host 
Agent.

5. Run the following command: 

C:\Program Files\HostAgentSetup> setup.exe -s -v"/qn” 

Notes:

• Enter no space after the -v option, and quotes are required. You must enter a 
space after qn. 

• A silent installation takes less than two minutes on Windows 2000 and Windows 
NT platforms. 

• After the installation is completed, a Storability Host Agent service is installed 
and running. 

• Proceed to the Verifying the Host Agent section.

Note: If the Host Agent and SRM Agent were previously installed using 
InstallShield, uninstall these agents before installing them using the Self-Extracting 
Install CD.

1. Select Start->Program Files->Storability->Uninstall->Uninstall Local 
Manager     

Or:

Start->Program Files->Storability->Uninstall->Uninstall Host Agent. The 
Storability Uninstall dialog appears.
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2. Click the checkbox for the Host Agent and SRM Agent.
3. Click Next>. The Question dialog appears.
4. Click Yes to confirm uninstalling the software. An uninstalling agent splash box 

appears as each selected agent is uninstalled.
5. When the InstallShield Wizard Complete dialog box appears, click Finish.

Solaris Installation
The installation procedure for the Storability Host Agent follows. The installation script 
(setup) is supplied on the Solaris Local Manager Installation CD.

1. Open a terminal window on the desktop of the Sun host.

2. Mount the Local Manager installation CD in your CD-ROM drive. For example:

mount –o  ro  –F hsfs /dev/dsk/c0t6d0s0 /cdrom

3. Change directory to the CD directory (e.g., /cdrom)

4. Run the installation script to access the main agent installation main menu.

5. Select to install the Host Agent and press Enter. 

6. Type zero (0) and press Enter to end the selection of agents for installation.

7. If EMC PowerPath is installed but not in the default directory, type y. You are 
prompted to specify the fully qualified path to the PowerPath software. 

If it is not installed, type n and press Enter. 

8. When prompted, enter y and press Enter to review/ modify the Advanced Settings 
or n to accept the default values. For the Advanced Settings.

• Specify whether (y/n) to start the Host Agent (if down) using the agentMonitor. 
Agent Monitor will send an SNMP trap and restart an agent if it is detected as not 
running.

• Review/modify the data collection interval that specifies how long the Host Agent 
caches data; the default value is 7200 seconds.

• Review/modify the HOST_SLEEP_TIME parameter in the range of 1 to 600 
seconds.  This setting specifies the interval for checking whether the HBA is 
online. The default value is 600 seconds.

• Review/modify the enable agent auto registration; agent auto registration is 
enabled by default.

• Enter the IP address/network resolvable host name of the Local Manager to be 
contacted for agent auto registration. In the above screen, the Local Manager’s IP 
address is 10.250.2.11.

• Review/modify the TCP port number the Local Manager uses for agent auto 
registration; the default port number is 17146.
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• Specify (y/n) whether to restart the agents after installation. If the agent is 
already running, the install script displays this operational status when the agents 
are restarted, if applicable.

9. Enter y to confirm continuing with the installation of the Host Agent (GSMhost), 
when prompted.

10. The installation will complete and return you to the command line.

11. If you restarted the agents, use the process status (ps) command to verify they are 
running. 

12. Proceed to the Verifying the Host Agent section.

IBM AIX Host Agent Installation
All currently supported AIX agents are provided with both the hostAgent-AIX.tgz 
(gzipped tar) file and the install script. Ensure that the “hostAgent-install.sh” and 
hostAgent-AIX.tgz files reside in the same location.

1. Mount the installation CD in the CD-ROM drive of the AIX server. For example:

mount -v cdrfs -r /dev/cd0 /mnt # /mnt must exist

2. Change directory to the software installation directory. For example:

cd /mnt/Unix/AIX/5.x

3. Run the installation script:

./hostAgent-install.sh

4. The installation script installs and starts the Host Agent.

Agent Auto Registration on IBM AIX
To configure agent auto registration after installation, you can add the Host Agent to a 
Local Manager Routing Agent configuration or manually add the required entries to the 
storability.ini file. Sample storability.ini entries for the Host Agent appear below.

GSM_LM_HOST = 10.192.1.15
      GSM_LM_PORT = 17146

      GSM_ENABLE_LM_REGISTRATION = true

HP-UX Host Agent Installation
The following notes apply to installing Sun StorageTek Business Analytic agents on this 
platform:

• The Sun StorageTek Business Analytic Agent installation must be carried out locally 
by root.

• You may mount the software media directly using the local CD-ROM drive or copy 
the CD contents to some location on the server.

o # ioscan –funC disk  # Identifies cdrom device
o Sample mount command: 

# pfs_mount –o xlat=unix /dev/rdsk/cXtXd0 /SD_CDROM
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(where /dev/rdsk/cXtXd0 is the cdrom device)
• Depending on which filesystem extensions are recognized by the host, the location, 

relative to the CD root, will be:

              UNIX/HP-UX/<version>    (basic ISO 9660 filesystem)
      Unix/HP-UX/<version>    (ISO 9660 with extensions)

• The software installation directory contains both the .tgz (gzipped tar) file and the 
install script.

• To install individual agents, simply run the corresponding installation
script:

          HOSTAGEN.SH;1              (basic ISO 9660 filesystem)
      hostAgent-install.sh       (ISO 9660 with extensions)

    
• The agent should be started and stopped using the init scripts in the /sbin/init.d 

directory. 
• Use the following command to confirm which agents are running:

      $ ps -ef | grep Agent

• Refer to the READ.TXT file on the installation CD for additional information on 
installing Sun StorageTek Business Analytic agents on a HP-UX server.

• The Host Agent must be installed before any other Sun StorageTek Business Analytic 
agent on a HP-UX server. 

1. Mount the installation CD in the CD-ROM drive of the HP-UX server.
2. Change directory to the software installation directory. For example:

cd /cdrom/UNIX/HPUX/11.00

3. Run the Host Agent installation script. For example:

./hostAgent-install.sh

The installation script installs and starts the Host Agent. A sample output follows.

x opt/storability/bin/hostAgent, 3379200 bytes, 6600 tape blocks
x opt/storability/etc/storability.ini, 43 bytes, 1 tape blocks
x opt/storability/etc/HBAmanufacturers.dat, 303 bytes, 1 tape blocks
x opt/storability/GSM-license.txt, 9930 bytes, 20 tape blocks
x opt/storability/lgpl-license.txt, 26532 bytes, 52 tape blocks
x opt/storability/openssl-license.txt, 6279 bytes, 13 tape blocks
x opt/storability/pcre-license.txt, 1944 bytes, 4 tape blocks
x opt/storability/snia-license.txt, 23716 bytes, 47 tape blocks
x opt/storability/snmp++-license.txt, 1238 bytes, 3 tape blocks
x opt/storability/xercesc-license.txt, 2697 bytes, 6 tape blocks
x sbin/init.d/hostAgent, 1615 bytes, 4 tape blocks
x sbin/rc1.d/K250hostAgent symbolic link to ../init.d/hostAgent
x sbin/rc3.d/S120hostAgent symbolic link to ../init.d/hostAgent
Starting Storability host agent:                hostAgent started

Agent Auto Registration on UNIX Servers (non-Solaris)
To configure agent auto registration after installation, you can manually add the Host 
Agent to a Local Manager Routing Agent configuration as a SUB_AGENT entry or add the 
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required entries to the storability.ini file. Sample storability.ini entries for the Host Agent 
appear below.

GSM_LM_HOST = 10.192.1.15
      GSM_LM_PORT = 17146

      GSM_ENABLE_LM_REGISTRATION = true

Red Hat Linux Host Agent Installation
On Red Hat Linux, the Host Agent is provided as a simple “Tarball” or zipped tar archive. 
To install the agent, simply unpack the “Tarball” (<agent>-rh<version>.tgz) and start 
the agent using the startup script (located in /etc/rc.d/init.d on Red Hat servers). 

1. Mount the Sun StorageTek Business Analytics UNIX Agent Installation CD to cdrom. 
For example:

/mount/mnt/cdrom

2. Change directory to the Linux directory:

/mnt/cdrom/Unix/Linux

[root@Linux]# ls -al
total 10
dr-xr-xr-x    5 root     root         2048 Nov  1 03:24 .
dr-xr-xr-x    6 root     root         2048 Oct 13 16:47 ..
dr-xr-xr-x    2 root     root         2048 Oct 25 00:28 RedHat-7.2
dr-xr-xr-x    2 root     root         2048 Nov  1 03:24 RedHat-EnterpriseEdition
dr-xr-xr-x    2 root     root         2048 Oct 25 00:25 Suse-8.0

3. The installation files are listed as follows:

RedHat-7.2: hostAgent-install.sh   hostAgent-rh72.tgz
RedHat Enterprise Edition 3.0 or 4.0: hostAgent-install.sh   hostAgent-rhee.tgz

4.  To install the agent, simply run the installation script hostAgent.sh as shown below.

./hostAgent-install.sh

This script will look for the "Tarball" in its current directory default or in the path 
specified as the first argument.

Note: The same installation files are used to support RedHat Edition 3.0 and 
RedHat Edition 4.0.

5. Verify the hostAgent started.  
6. To start/stop the agent, simply run the startup script as shown below.

etc/rc.d/init.d/hostAgent   start
etc/rc.d/init.d/hostAgent   stop

Uninstalling/Upgrade Storability Host 
Agent Linux Host
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1. Backup the Storability Initialization File if upgrading.

/opt/storability/etc/storability.ini

2. Stop the currently installed Host Agent (hostAgent).

/etc/rc.d/init.d/hostAgent stop

[root@Linux opt]# /etc/rc.d/init.d/hostAgent stop
Stopping Storability host agent:        hostAgent 927 killed

Note: If the SRM Agent (srmAgent) is installed, please refer to backing up and 
stopping srmAgent first.

3. Manually remove the storability directory under /opt

rm -rf storability

4. Verify the storability directory under /opt is deleted

Suse Linux Host Agent Installation
On Suse Linux, the Host Agent is provided as a simple “Tarball” hostAgent-[suse 
version].tgz. For Suse 8.0, the installation files are hostAgent-install.sh and hostAgent-
suse80.tgz.

The command:

tar –zhvf  <tarball-name>

will untar the package.

To install the agent, simply run the installation script hostAgent.sh as 
shown below.

./hostAgent.sh [<tarfile-path>]

This script will look for the "Tarball" in its current directory default or in the path 
specified as first argument.

To start the agent, simply run the startup script as shown below.

/etc/rc.d/init.d/hostAgent   start

Host Agent for Novell NetWare
Follow these instructions to properly install and configure the agent on this operating 
system:

1. Copy hostAgent.nlm, clibnetware.nlm & storability.ini to the desired folder on the 
host machine. We recommend that you create a folder called storability in the SYS 
volume, and copy the .nlm and .ini files into this directory

It is possible to access the Novell Host from a Windows box, using UNC paths (eg: 
\\192.168.1.1\sys).  To do this, you must first install the Novell Client for Windows 
available from the Novell web site at http://www.novell.com/products/clients/.
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2. The storability.ini file provided on the CD has the following default entries: 

#GSMhost
:hostAgent.nlm
GSM_LM_HOST = localhost
GSM_LM_PORT = 17146
CONFIG_CACHE_REFRESH_INTERVAL = 7200
GSM_ENABLE_LM_REGISTRATION = false

EOF

Modify these parameters as follows:

- For GSM_LM_HOST, enter the IP Address of the local manager routing agent 
that will collect the host data

- There is no need to change the setting for GSM_LM_PORT.
- By default the agent will refresh its cache every 2 hours.  Change the setting 

for CONFIG_CACHE_REFRESH_INTERVAL if desired.
- To have the host agent automatically register with the local manager, change 

the GSM_ENABLE_LM_REGISTRATION setting to the following:

GSM_ENABLE_LM_REGISTRATION = true

If you choose to manually register the agent, be sure to enter the IP address 
of the Novell host as a static subagent in as part of the Local Manager routing 
agent configuration.  Restart the routing agent after configuring the static 
subagent.

3. Use the NetWare load command to start the Novell host agent:

a. Launch the System Console on the Novell host.
b. Run the following command:

load sys:\storability\hostAgent.nlm

This will automatically load the dependent clibnetware.nlm.

4. When necessary, use the unload command to stop the Novell host agent. Run 
following commands in order specified below:

unload hostAgent.nlm
unload clibnetware.nlm

If it is necessary to update the host agent, be sure to stop it first.

Information Gathered by the Novell 
NetWare Host Agent
The Novell NetWare host agent gathers less information than some of the other host 
agents.  In particular, it does not collect HBA information. This section explains the 
information not supported by the host agent and in host reports for this environment.
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Information not Supported in Reports

Detailed Host Configuration and Utilization Reports:
General Tab: 

• HBA Interfaces, including Vendor/Model, Efective Speed, Status, WW Node 
Name/Port Name, and Driver/Firmware, are not collected.  

• In the Physical Devices section, Vendor, Array and Volume are not reported.  End to 
end mapping is not supported for this host type.

Filesystem Tab:

• Filesystem Access statistics are not supported because there is no SRM agent for 
Novell NetWare.

Allocation Tab, Fabric Tab, Topology Tab:

• These reports will always be blank because they are dependent upon HBA support.

Volume Management reports:

• The Logical Volume report Logical Devices Listing and Device Detail reports show LV 
Mgr. and LV Grp. as "N/A".

• Only devices and logical volumes with an "Okay" status are reported.

• For PDISKs, Vol. ID, Arr.ID Vendor, and Ser.# are not reported.

Data fields not collected by Novell NetWare agent
• The gsa_hba_config object is not populated with any data

• In gsa_host_filesystem-2_3, values for "device", "lvm" and "logical_device_group" 
columns are reported as "N/A".

• In gsa_logicalvolume_config-2_1, values for "lvm" and "logical_device_group" 
columns are reported as "N/A".  The name used in the "logical_device_name" column 
for partitions is the Partition Name and Object ID published by the Novell NetWare 
API.  Agent will report a POOL as a Logical Volume (LVOL) in the "type" column.

• In gsa_logicalvolume_relation, values for "lvm", "logical_device_group", "uses_lvm" 
and "uses_logical_device_group" will show "N/A" as LVM is native on Netware NSS 
filesystem.  A POOL as a Logical Volume (LVOL) in the "type" column.

• In gsa_physicalvolume_config, values for "vendor", "serial_num", "volume_id", and 
"arrayid" are not reported. The "physical_device_status" column will always shows 
status as "Okay" because NetWare does not report devices that have failed.

• In gsa_physicalvolume_path-2_1, data is not reported for "path_device_name", 
"ctrl_instance", "ctrl_number", "channel", "target", "lun", "array_wwpn", 
"array_port_id", "path_software_name" and "path_software_version" because values 
for these fields require.  Only devices with a "path_status" of "Okay" are reported.

Verifying Host Agent
Use the Sun StorageTek Business Analytics Agent Diagnostic Tool to verify the Host 
Agent functionality. GSMdiag is installed in the Storability Local Manager Utilities folder 
as part of the Sun StorageTek Business Analytics Central Manager or Local Manager 
software installation. It represents the primary tool to verify agent functionality or 
troubleshoot agent problems. The GSMdiag utility runs only on Microsoft Windows.

Proceed as follows:

1. Wait approximately 30 seconds after the Host Agent has started to allow it to 
initialize before querying it using the Business Analytics Agent Diagnostic Tool.
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a. In the Agent location input box, enter the IP Address or network resolvable 
Host Name of the server where the agent is installed in the ip address/host 
name input box.

b. Set the port to 17132 (or select the Host agent from the drop down list of service 
names).

c. Click the Get Object List button and you should receive a list of objects 
published by the Host Agent.

d. Select the gsa_host_config object and it should list the IP address, node name, 
host ID of the host server as well as additional fields. Refer also to Table 2 – Host 
Agent Objects.

Figure 4 – Sample Host Configuration Object

e. Proceed to collect all other objects published by the agent. 

2. To verify the Host Agent has registered successfully with its configured Local 
Manager:

a. In the Agent location input box, enter the IP Address or network resolvable 
Host Name of the Local Manager in the ip address/host name input box and 
set the port to 17146 (or select the Storability Routing Agent from the drop 
down list of service names). 

b. Click the Get Object List button and you should receive a list of objects 
published by the Routing Agent.

c.   Select the gsa_agent_register table.

d. Verify this collected object reports the Host Agent using the following fields:

• port – 17132 (Host Agent default TCP port number)

• peer_list – IP Address or Host Name of the server where the Host Agent is 
running

• last_freshened – Date/time agent last registered

• application_status – Should be ‘ACTIVATED’
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• network_status – Should be ‘Up’

Verifying Management Console 
Functionality
The following procedure describes how the administrator verifies the Sun StorageTek 
Business Analytics Host Agent’s reports in the Management Console. Refer to the 
Administration chapter to obtain information on the administrative menus you can 
access from the Tools pull down menu, including the Data Polling Schedule and 
Change Dashboard menus.

1. Log in to the Management Console as an administrative user (e.g., gsmuser) whose 
views provide access to the desired assets (e.g., sites).

2. Verify that your customized Home Page includes the Host Filesystem Utilization 
pane (or use Change Dashboard to select one that includes this pane).

Figure 5 - Host Filesystem Utilization Pane

3. Select Tools->Data Polling Schedule.

4. Use the Collect Now button to collect the Host (collection type) Filesystem 
(Collection Metric) data for all sites.

5. Wait approximately thirty seconds and then use the Collect Now button to collect 
the Host (collection type) Configuration (Collection Metric) data for all sites.

6. Wait approximately thirty seconds and then use the Collect Now button to collect 
the Host (collection type) Logical VM (Collection Metric) data for all sites.

7. Close the Polling Schedules window.
8. Select Tools-> Database Administration-> Refresh Homepage Cache and then 

click Submit.
9. Verify the Host Filesystem Utilization dashboard reports information on the server 

whose installed Host Agent you are verifying. If the pane displays no data, refresh 
the browser window (press F5 or click the Refresh tab). 

10.Click the Host Name link in the dashboard and the Detailed Host Configuration 
and Utilization report appears.

11.Verify the Server, Platform, IP, and Site information is reported with the General tab 
enabled.

12.Verify all the tabular device reports by clicking the respective tabs, including: 
Filesystem, Allocation, Fabric, Topology, Backup, Databases, Backup, and Asset. 

Note: Keep in mind that some device-specific tabs may display no report data 
because they do not apply (e.g., Topology tab for standalone server) for that server. 
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In these instances, the window typically displays the “No Data Found” informational 
text.

13.Close the browser session with the Management Console as the above steps 
complete verifying the Management Console functionality.

Host Agent Troubleshooting

1. Verify system/agent prerequisites – Refer to Sun StorageTek Business Analytics 
Support Matrix to verify the most recent support requirements for the agent.

2. Use the Business Analytics Agent Diagnostic Tool to save the output for all the tables 
if escalating a problem to support.
a. Launch the Agent Diagnostic Tool from its Program Folder.
b. Enter the IP Address or Hostname of the server where the agent is installed 

and set the port to 17132 (or select the Host agent from the drop down list of 
service names).

c. Click the Get Object List button and you should receive a list of tables published 
by the Host Agent. If unsuccessful, verify the Ethernet connectivity to the server 
running the Storability Host Agent and that the Storability Host Agent is running. 

d. Select the alerts-3_1 table and examine the Description column for each 
reported alert. 

e. Select File->Save All and the “This action will network fetch all objects 
published by the currently specified agent and save the data to a single file.” 
Message appears. 

f. Click OK and the Save As dialog appears. 
g. Enter a meaningful file name and click OK to initiate the collection.

3. Review the Message Log – Review/collect the Message.log file that can contain 
information on startup errors, configuration errors, or errors regarding accessing 
data or parsing output. Note: The following messages specify that there was a rare 
host server state where the Host Agent should be restarted.

------------------------------------------------------------------------------
<date/time>|WARNING|0|Invalidating instance -- constructor failed -- 
pipe(afdPipe) failed -- 24|host
Agent|SysChannelUnix.cc|327
--------------------------------------------------------------------------------
------------------------------------------------------------------------------
<date/time>|WARNING|0|SDSPipe in HostDiskPartitionGenerator 
failed|hostAgent|HostDiskPartitionGenera
tor.cc|622
-------------------------------------------------------------------------------

Windows

• Located by default in: <drive>:\Program Files\Storability\GSM\Agents\Storability 
Host Agent folder.

• Can enable debug level logging by appending LOG_SEVERITY=Debug to the Host 
Agent section of the storability.ini file (if your Sun support representative requests 
it).

Solaris

• The agents’ common Message.log file located by default in: /opt/storability/data.
• Can enable debug level logging by appending LOG_SEVERITY=Debug to the Host 

Agent section of the storability.ini file (if your support representative requests it).
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4. Verify Local Manager Registration - The configured Routing Agent’s 
gsa_agent_register table displays agents that have registered with the Routing 
Agent.

The Type field indicates the type of registration. If the agent registered using agent 
auto registration, “AUTO_NET” is displayed in the Type field. If the agent was 
defined manually as a SUB_AGENT entry in the Routing Agent’s storability.ini file, the 
Type field will display “STATIC”.

Figure 6 - Routing Agent's Agent Register Object

5. Review the Routing Agent Message Log – Review/collect the Routing Agent 
Message Log to check for errors related to Ethernet connectivity problems contacting 
the Storability Host Agent and registration details.

6. Confirm Polling Schedules – Using the Management Console’s Polling Schedules 
window, review/modify the existing polling schedules for the Collection Type of 
Host and the three collection metrics (configuration, filesystem, logical VM). 

7. Review Aggregator Message Log – Open the Aggregator’s Message Log in a text 
editor. Verify that the Host Tables were requested and that rows were inserted into 
the database. If you performed an on-demand (Collect Now) request in the Polling 
menu, look for timestamps in the log that closely approximate when that request 
occurred. 

The log contains two entries, TID (Transaction ID) and SID (Session ID), which can 
help you locate (e.g., Find) and view relevant logged entries. For scheduled polling 
requests, the TID will be equal to the Job ID in the Polling menu. Each SID is a 
unique identifier for a particular agent data collection session. For on-demand polling 
requests, the TID is a uniquely generated TID (not the Job ID) and SID, and the TID 
and SID will be equal to the same integer value. 

8. Check the assurent database – The assurent database is the data repository for 
your application. For the Host Agent, use any MS SQL Query interface, such as isql, 
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to verify rows have been inserted into the host-related tables, such as the 
gsa_host_config table.

9. Verify Management Console Functionality – As a final step in the agent 
troubleshooting procedure, minimally verify that the host server now appears in the 
Management Console’s Host Filesystem Utilization dashboard on the Home Page.

Upgrade Host Agent 
To upgrade a previous release of a Host Agent, the procedure is to:

1. Uninstall the currently installed Host Agent.
2. Install the current Sun StorageTek Business Analytics Host Agent.

The following sections described the uninstallation procedures for various supported 
platforms.

Uninstall Host Agent - InstallShield

1. Select Start->Program Files->Storability->Uninstall->Uninstall Local 
Manager     
Or:
Start->Program Files->Storability->Uninstall->Uninstall Host Agent and 
Uninstall SRM Agent. The Storability Uninstall dialog appears.

2. Click the checkbox for the Host Agent and/or SRM Agent.
3. Click Next>. The Question dialog appears.
4. Click Yes to confirm uninstalling the agent. An uninstalling agent splash box appears 

as each selected agent is uninstalled.
5. When the InstallShield Wizard Complete dialog box appears, click Finish.

Uninstall Host Agent – Self-Extracting 
Install
To uninstall the Host Agent, proceed as follows

1. Using Windows Explorer, select Program Files->Storability->hostAgentuninstall.exe. 
The Storability Host Agent Uninstall: Confirmation dialog appears.

2. Click Uninstall.

3. When the Storability Host Agent Uninstall: Completed dialog appears, click Close.

Silent Uninstall Host Agent – Self-
Extracting Install
To uninstall the Host Agent, proceed as follows

1. From a command prompt, type:

“<drive>:\Program Files\Storability\hostAgentuninstall.exe”  /S

2. This will remove the Host Agent and returns you to the command prompt.
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Uninstall Host Agent – Solaris
The installation script (setup) is used to uninstall agents on a Solaris server. The 
installation script is supplied on the Solaris Local Manager Installation CD.

1. To view a list of installed agents, type:

setup -u

and press Enter.

2. Type the number corresponding to the Host Agent and press Enter.

3. Type zero (0) to end the selection of agents.

4. When prompted, enter y and press Enter to confirm removing the agent. 

Uninstalling Agents – Non-Solaris UNIX 
Host

1. Stop all Sun StorageTek Business Analytics Agents. For example:

/etc/rc.hostAgent stop

2. Refer to backing up Configuration files “Reinstalling Agents – Unix Host” below.

3. Remove the storability directory from /opt 

rm –rf storability

4. Verify the storability directory has been deleted

Reinstalling Host Agent – Non-Solaris UNIX 
Host
The reinstallation procedure for all agents supported on non-Solaris UNIX hosts, such as 
the Host Agent on an IBM AIX server, requires that the installer perform the following 
steps before running the agent’s installation script:

1. Make a backup copy of the existing agent configuration file (storability.ini).

2. Make a backup copy of the contents of /opt/storability/etc/agents.

3. Open the existing agent configuration file (storability.ini) in a system text editor.

4. Locate the configuration section for the agent to be reinstalled.

5. Delete all existing configuration settings for that Storability agent.

6. Save the modified agent configuration file.

7. Remove the existing /opt/storability/etc/agents directory.

At this point, you may reinstall the agent using the agent’s installation script (e.g., 
hostAgent-install.sh).
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